Cycles

User’s Manual Cycle Programming

Valid for:
606420-04, 606421-04, 606424-04

Release:
31.07.2014-en-

Copyright © 2014 DR. JOHANNES HEIDENHAIN GmbH. All rights reserved.


About this Manual

Further Informations:
> About this Manual
> TNC model, software and features
> New cycle functions of software 60642x-01
> New cycle functions of software 60642x-02
> New cycle functions of software 60642x-03
> New cycle functions of software 60642x-04
> Changed cycle functions of software 60642x-01
> Changed cycle functions of software 60642x-02
> Changed cycle functions of software 60642x-04


About this Manual

About this Manual

The symbols used in this manual are described below.

This symbol indicates that important information about the function described must be considered.

This symbol indicates that there is one or more of the following risks when using the described function:

  • Danger to workpiece
  • Danger to fixtures
  • Danger to tool
  • Danger to machine
  • Danger to operator

This symbol indicates that the described function must be adapted by the machine tool builder. The function described may therefore vary depending on the machine.

This symbol indicates that you can find detailed information about a function in another manual.
Further Informations:
> Would you like any changes, or have you found any errors?


Would you like any changes, or have you found any errors?

We are continuously striving to improve our documentation for you. Please help us by sending your requests to the following e-mail address: tnc-userdoc@heidenhain.de.


TNC model, software and features

This manual describes functions and features provided by TNCs as of the following NC software numbers.

TNC model | NC software number
iTNC 530, HSCI and HEROS 5 | 606420-04
iTNC 530 E, HSCI and HEROS 5 | 606421-04
iTNC 530 HSCI Programming Station | 606424-04

    The suffix E indicates the export version of the TNC. The export version of the TNC has the following limitations:

  • Simultaneous linear movement in up to 4 axes

HSCI (HEIDENHAIN Serial Controller Interface) identifies the new hardware platform of the TNC controls.

HEROS 5 identifies the new operating system of HSCI-based TNC controls.

The machine tool builder adapts the usable features of the TNC to his machine by setting machine parameters. Some of the functions described in this manual may therefore not be among the features provided by the TNC on your machine tool.

    TNC functions that may not be available on your machine include:

  • Tool measurement with the TT

Please contact your machine tool builder to become familiar with the features of your machine.

Many machine manufacturers, as well as HEIDENHAIN, offer programming courses for the TNCs. We recommend these courses as an effective way of improving your programming skill and sharing information and ideas with other TNC users.

User's Manual:

All TNC functions that have no connection with cycles are described in the User's Manual of the iTNC 530. Please contact HEIDENHAIN if you require a copy of this User's Manual.

ID of User's Manual for Conversational Programming: 670387-xx.

ID of User’s Manual for DIN/ISO Programming: 670391-xx.

smarT.NC user documentation:

The smarT.NC operating mode is described in a separate Pilot. Please contact HEIDENHAIN if you require a copy of this Pilot. ID: 533191-xx.

Further Informations:
> Software options
> Feature content level (upgrade functions)
> Intended place of operation


Software options

The iTNC 530 features various software options that can be enabled by you or your machine tool builder. Each option is to be enabled separately and contains the following respective functions:

Software option 1

Cylinder surface interpolation (Cycles 27, 28, 29 and 39)

Feed rate in mm/min for rotary axes: M116

Tilting the machining plane (Cycle 19, PLANE function and 3-D ROT soft key in the Manual Operation mode)

Circle in 3 axes with tilted working plane
Software option 2

5-axis interpolation

Spline interpolation

3-D machining:

  • M114: Automatic compensation of machine geometry when working with tilted axes
  • M128: Maintaining the position of the tool tip when positioning with tilted axes (TCPM)
  • FUNCTION TCPM: Maintaining the position of the tool tip when positioning with tilted axes (TCPM) in selectable modes
  • M144: Compensating the machine’s kinematic configuration for ACTUAL/NOMINAL positions at end of block
  • Additional parameters for finishing/roughing and tolerance for rotary axes in Cycle 32 (G62)
  • LN blocks (3-D compensation)
DCM Collision software option | Description
Function that monitors areas defined by the machine manufacturer to prevent collisions. | User’s Manual for Conversational Programming
DXF Converter software option | Description
Extract contours and machining positions from DXF files (R12 format). | User’s Manual for Conversational Programming
Global Program Settings software option | Description
Function for superimposing coordinate transformations in the Program Run modes, handwheel superimposed traverse in virtual axis direction. | User’s Manual for Conversational Programming
AFC software option | Description
Function for adaptive feed-rate control for optimizing the machining conditions during series production. | User’s Manual for Conversational Programming
KinematicsOpt software option | Description
Touch-probe cycles for inspecting and optimizing the machine accuracy | Fundamentals
3D-ToolComp software option | Description
3-D radius compensation depending on the tool’s contact angle for LN block. | User’s Manual for Conversational Programming
Expanded Tool Management software option | Description
Tool management that can be changed by the machine manufacturer using Python scripts | User’s Manual for Conversational Programming
CAD Viewer software option | Description
Opening of 3-D models on the control | User’s Manual for Conversational Programming
Interpolation Turning software option | Description
Interpolation turning of a shoulder with Cycle 290. | INTERPOLATION TURNING (Software Option, Cycle 290, DIN/ISO: G290)
Remote Desktop Manager software option | Description
Remote operation of external computer units (e.g. a Windows PC) via the user interface of the TNC | User’s Manual for Conversational Programming
Cross Talk Compensation (CTC) software option | Description
Compensation of axis couplings | Machine Manual
Position Adaptive Control (PAC) software option | Description
Adaptation of control parameters | Machine Manual
Load Adaptive Control (LAC) software option | Description
Dynamic changing of control parameters | Machine Manual
Active Chatter Control (ACC) software option | Description
Fully automatic function for chatter control during machining | Machine Manual


Feature content level (upgrade functions)

Along with software options, significant further improvements of the TNC software are managed via the Feature Content Level (FCL) upgrade functions. Functions subject to the FCL are not available simply by updating the software on your TNC.

All upgrade functions are available to you without surcharge when you receive a new machine.

Upgrade functions are identified in the manual with FCL n, where n indicates the sequential number of the feature content level.

You can purchase a code number in order to permanently enable the FCL functions. For more information, contact your machine tool builder or HEIDENHAIN.

FCL 4 functions | Description
Graphical depiction of the protected space when DCM collision monitoring is active | User’s Manual
Handwheel superimposition in stopped condition when DCM collision monitoring is active | User’s Manual
3-D basic rotation (set-up compensation) | Machine manual
FCL 3 functions | Description
Touch probe cycle for 3-D probing | MEASURING IN 3-D (Cycle 4, FCL 3 function)
Touch probe cycles for automatic datum setting using the center of a slot/ridge | SLOT CENTER REF PT (Cycle 408, DIN/ISO: G408, FCL 3 Function)
Feed-rate reduction for the machining of contour pockets with the tool being in full contact with the workpiece | User’s Manual
PLANE function: Entry of axis angle | User’s Manual
User documentation as a context-sensitive help system | User’s Manual
smarT.NC: Programming of smarT.NC and machining can be carried out simultaneously | User’s Manual
smarT.NC: Contour pocket on point pattern | smarT.NC Pilot
smarT.NC: Preview of contour programs in the file manager | smarT.NC Pilot
smarT.NC: Positioning strategy for machining point patterns | smarT.NC Pilot
FCL 2 functions | Description
3-D line graphics | User’s Manual
Virtual tool axis | User’s Manual
USB support of block devices (memory sticks, hard disks, CD-ROM drives) | User’s Manual
Filtering of externally created contours | User’s Manual
Possibility of assigning different depths to each subcontour in the contour formula | User’s Manual
DHCP dynamic IP address management | User’s Manual
Touch-probe cycle for global setting of touch-probe parameters | FAST PROBING (Cycle 441, DIN/ISO: G441, FCL 2 function)
smarT.NC: Graphic support of block scan | smarT.NC Pilot
smarT.NC: Coordinate transformation | smarT.NC Pilot
smarT.NC: PLANE function | smarT.NC Pilot


Intended place of operation

The TNC complies with the limits for a Class A device in accordance with the specifications in EN 55022, and is intended for use primarily in industrially-zoned areas.


New cycle functions of software 60642x-01

  • New Cycle 275 "Trochoidal Contour Slot"(see SLOT MILLING (Cycle 253, DIN/ISO: G253))
  • In Cycle 241 "Single-Lip Deep-Hole Drilling" it is now possible to define a dwell depth (see SINGLE-LIP DEEP-HOLE DRILLING (Cycle 241, DIN/ISO: G241))
  • The approach and departure behavior of Cycle 39 "Cylinder Surface Contour" can now be adjusted (see Cycle run)
  • New touch probe cycle for calibration of a touch probe on a calibration sphere (see CALIBRATE TS (Cycle 460, DIN/ISO: G460))
  • KinematicsOpt: An additional parameter for determination of the backlash in a rotary axis was introduced (see Backlash)
  • KinematicsOpt: Better support for positioning of Hirth-coupled axes (see Machines with Hirth-coupled axes)


New cycle functions of software 60642x-02

  • New fixed cycle 225 Engraving (see THREE-D CONTOUR TRAIN (Cycle 276, DIN/ISO: G276))
  • New fixed cycle 276 3-D Contour Train (see THREE-D CONTOUR TRAIN (Cycle 276, DIN/ISO: G276))
  • New fixed cycle 290 Interpolation Turning (see INTERPOLATION TURNING (Software Option, Cycle 290, DIN/ISO: G290))
  • For the thread milling cycles (Cycles 26x), a separate feed rate is now available for tangential approach to the thread (see the respective description of cycle parameters)
  • The following improvements were made to the KinematicsOpt cycles:
    • Newer, faster optimization algorithmAfter angle optimization, a separate measurement series is no longer required for position optimization (see Various modes (Q406))
    • Return of offset errors (change of machine datum) in the parameters Q147-149 (see Cycle run)
    • Up to eight plane measuring points for the measurement of spheres (see Cycle parameters)
    • Rotary axes that are not configured are ignored by the TNC when executing the cycle (see Please note while programming:)


New cycle functions of software 60642x-03

  • With Cycle 256 Rectangular Stud, a parameter is now available with which you can determine the approach position on the stud (see RECTANGULAR STUD (Cycle 256, DIN/ISO: G256))
  • With Cycle 257 Circular Stud Milling, a parameter is now available with which you can determine the approach position on the stud (see CIRCULAR STUD (Cycle 257, DIN/ISO: G257))


New cycle functions of software 60642x-04

  • Cycle 25: Automatic identification of residual material added (see CONTOUR TRAIN (Cycle 25, DIN/ISO: G125))
  • Cycle 200: Input parameter Q359 added to allow definition of the depth reference (see DRILLING (Cycle 200))
  • Cycle 203: Input parameter Q359 added to allow definition of the depth reference (see UNIVERSAL DRILLING (Cycle 203, DIN/ISO: G203))
  • Cycle 205: Input parameter Q208 for retraction feed rate added (see UNIVERSAL PECKING (Cycle 205, DIN/ISO: G205))
  • Cycle 205: Input parameter Q359 added to allow definition of the depth reference (see UNIVERSAL PECKING (Cycle 205, DIN/ISO: G205))
  • Cycle 225: Input of German umlauts is now possible; text can also be arranged at an angle (see THREE-D CONTOUR TRAIN (Cycle 276, DIN/ISO: G276))
  • Cycle 253: Input parameter Q439 for feed rate reference added (see SLOT MILLING (Cycle 253, DIN/ISO: G253))
  • Cycle 254: Input parameter Q439 for feed rate reference added (see CIRCULAR SLOT (Cycle 254, DIN/ISO: G254))
  • Cycle 276: Automatic identification of residual material added (see THREE-D CONTOUR TRAIN (Cycle 276, DIN/ISO: G276))
  • Cycle 290: It is now also possible to machine a recess with Cycle 290 (see INTERPOLATION TURNING (Software Option, Cycle 290, DIN/ISO: G290))
  • Cycle 404: Input parameter Q305 added to allow saving a basic rotation in any line of the datum table (see SET BASIC ROTATION (Cycle 404, DIN/ISO: G404))


Changed cycle functions of software 60642x-01

  • The approach behavior during side finishing with Cycle 24 (DIN/ISO: G124) has been changed (see Please note while programming:)


Changed cycle functions of software 60642x-02

  • Position of the soft key for defining Cycle 270 has been changed


Changed cycle functions of software 60642x-04

  • Cycle 206: The TNC now monitors the thread pitch if entered in the tool table
  • Cycle 207: The TNC now monitors the thread pitch if entered in the tool table
  • Cycle 209: The TNC now monitors the thread pitch if entered in the tool table
  • Cycle 209: The TNC now retracts the tool completely from the hole for chip breaking if the parameter Q256=0 is defined (retraction rate for chip breaking)
  • Cycle 202: The TNC does not retract the tool for disengaging at the bottom of the hole if the parameter Q214=0 is defined (disengaging direction)
  • Cycle 405: The TNC now also writes the datum in line 0 of the datum table if the parameter Q337=0 is defined
  • Relevant touch probe cycles 4xx: The input range of parameter Q305 (number in table) has been increased to 99999
  • Cycle 451 and Cycle 452: During a measurement, the TNC now closes the status window only if the distance to the calibration sphere is greater than the radius of the ball tip


Fundamentals / Overviews

Further Informations:
> Introduction
> Available cycle groups


Introduction

Frequently recurring machining cycles that comprise several working steps are stored in the TNC memory as standard cycles. Coordinate transformations and several special functions are also available as cycles.

Most cycles use Q parameters as transfer parameters. Parameters with specific functions that are required in several cycles always have the same number: For example, Q200 is always assigned the set-up clearance, Q202 the plunging depth, etc.

Danger of collision!

Cycles sometimes execute extensive operations. For safety reasons, you should run a graphical program test before machining.

If you use indirect parameter assignments in cycles with numbers greater than 200 (e.g. Q210 = Q1), any change in the assigned parameter (e.g. Q1) will have no effect after the cycle definition. Define the cycle parameter (e.g. Q210) directly in such cases.

If you define a feed-rate parameter for fixed cycles greater than 200, then instead of entering a numerical value you can use soft keys to assign the feed rate defined in the TOOL CALL block (FAUTO soft key). You can also use the feed-rate alternatives FMAX (rapid traverse), FZ (feed per tooth) and FU (feed per rev), depending on the respective cycle and the function of the feed-rate parameter.

Note that, after a cycle definition, a change of the FAUTO feed rate has no effect, because internally the TNC assigns the feed rate from the TOOL CALL block when processing the cycle definition.

If you want to delete a block that is part of a cycle, the TNC asks you whether you want to delete the whole cycle.


Available cycle groups

Further Informations:
> Overview of fixed cycles
> Overview of touch probe cycles


Overview of fixed cycles

The soft key row shows the available groups of cycles

Cycle group | Soft key | Page
Cycles for pecking, reaming, boring, and counterboring |  | Overview
Cycles for tapping, thread cutting and thread milling |  | Overview
Cycles for milling pockets, studs and slots |  | Overview
Cycles for producing hole patterns, such as circular or linear point patterns |  | Overview
SL (Subcontour List) cycles which allow the contour-parallel machining of relatively complex contours consisting of several overlapping subcontours, cylinder surface interpolation |  | Overview
Cycles for multipass milling of flat or twisted surfaces |  | Overview
Coordinate transformation cycles which enable datum shift, rotation, mirror image, enlarging and reducing for various contours |  | Overview
Special cycles such as dwell time, program call, oriented spindle stop, tolerance, engraving and interpolation turning (option) |  | Fundamentals

If required, switch to machine-specific fixed cycles. These fixed cycles can be integrated by your machine tool builder.


Overview of touch probe cycles

The soft key row shows the available groups of cycles

Cycle group | Soft key | Page
Cycles for automatic measurement and compensation of workpiece misalignment |  | Overview
Cycles for automatic workpiece presetting |  | Overview
Cycles for automatic workpiece inspection |  | Overview
Calibration cycles, special cycles |  | Overview
Cycles for automatic kinematics measurement |  | Overview
Cycles for automatic tool measurement (enabled by the machine tool builder) |  | Overview

If required, switch to machine-specific touch probe cycles. These touch probe cycles can be integrated by your machine tool builder.


Using Fixed Cycles

Further Informations:
> Working with fixed cycles
> Program defaults for cycles
> PATTERN DEF pattern definition
> Point tables


Working with fixed cycles

Further Informations:
> General information
> Machine-specific cycles
> Defining a cycle using soft keys
> Defining a cycle using the GOTO function
> Calling cycles
> Working with the secondary axes U/V/W


General information

    If you transfer NC programs from old TNC controls or create NC programs externally (by using a CAM system or an ASCI editor, for example), keep the following conventions in mind:

  • Fixed cycles and touch probe cycles with numbers smaller than 200:
    • In older iTNC software versions and older TNC controls, text strings that could not always be converted correctly by the current iTNC editor were used in some conversational languages. Make sure that cycle texts do not end with a period.
  • Fixed cycles and touch probe cycles with numbers greater than 200:
    • Indicate the end of a line with the tilde character (~). The last parameter in the cycle must not contain any tilde character.
    • Cycle names and cycle comments do not essentially need to be indicated. The iTNC supplements the cycle names and cycle comments in the selected conversational language when the program is transferred to the control.


Machine-specific cycles

In addition to the HEIDENHAIN cycles, many machine tool builders offer their own cycles in the TNC. These cycles are available in a separate cycle-number range:

  • Cycles 300 to 399
    Machine-specific cycles that are to be defined through the CYCLE DEF key
  • Cycles 500 to 599
    Machine-specific touch probe cycles that are to be defined through the TOUCH PROBE key

Refer to your machine manual for a description of the specific function.

Sometimes machine-specific cycles use transfer parameters that HEIDENHAIN already uses in standard cycles. The TNC executes DEF-active cycles as soon as they are defined (see also Calling cycles). It executes CALL-active cycles only after they have been called (see also Calling cycles). When DEF-active cycles and CALL-active cycles are used simultaneously, it is important to prevent overwriting of transfer parameters already in use. Use the following procedure:

  • As a rule, always program DEF-active cycles before CALL-active cycles

  • If you do want to program a DEF-active cycle between the definition and call of a CALL-active cycle, do it only if there is no common use of specific transfer parameters


Defining a cycle using soft keys

The soft-key row shows the available groups of cycles

Press the soft key for the desired group of cycles, for example DRILLING for the drilling cycles

Select the desired cycle, for example THREAD MILLING. The TNC initiates the programming dialog and asks for all required input values. At the same time a graphic of the input parameters is displayed in the right screen window. The parameter that is asked for in the dialog prompt is highlighted.

Enter all parameters requested by the TNC and conclude each entry with the ENT key

The TNC ends the dialog when all required data has been entered


Defining a cycle using the GOTO function

The soft-key row shows the available groups of cycles

The TNC shows an overview of cycles in a pop-up window

Choose the desired cycle with the arrow keys, or

Choose the desired cycle with CTRL and the arrow keys (for pagewise scrolling), or

Enter the cycle number and confirm it with the ENT key. The TNC then initiates the cycle dialog as described above

Example NC blocks
7 CYCL DEF 200 DRILLING
Q200=2 ;SET-UP CLEARANCE
Q201=3 ;DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q202=5 ;PLUNGING DEPTH
Q210=0 ;DWELL TIME AT TOP
Q203=+0 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q211=0.25 ;DWELL TIME AT DEPTH


Calling cycles

Requirements

    The following data must always be programmed before a cycle call:

  • BLK FORM for graphic display (needed only for test graphics)
  • Tool call
  • Direction of spindle rotation (M functions M3/M4)
  • Cycle definition (CYCL DEF)

For some cycles, additional prerequisites must be observed. They are detailed in the descriptions for each cycle.

    The following cycles become effective automatically as soon as they are defined in the part program. These cycles cannot and must not be called:

  • Cycle 220 for point patterns on circles and Cycle 221 for point patterns on lines
  • SL Cycle 14 CONTOUR
  • SL Cycle 20 CONTOUR DATA
  • Cycle 32 TOLERANCE
  • Coordinate transformation cycles
  • Cycle 9 DWELL TIME
  • All touch probe cycles

You can call all other cycles with the functions described as follows.

Further Informations:
> Calling a cycle with CYCL CALL
> Calling a cycle with CYCL CALL PAT
> Calling a cycle with CYCL CALL POS
> Calling a cycle with M99/M89


Calling a cycle with CYCL CALL

The CYCL CALL function calls the most recently defined fixed cycle once. The starting point of the cycle is the position that was programmed last before the CYCL CALL block.

Program the cycle call: Press the CYCL CALL key

Enter the cycle call: Press the CYCL CALL M soft key

If necessary, enter the miscellaneous function M (for example M3 to switch the spindle on), or end the dialog by pressing the END key


Calling a cycle with CYCL CALL PAT

The CYCL CALL PAT function calls the most recently defined fixed cycle at all positions that you defined in a PATTERN DEF pattern definition (see PATTERN DEF pattern definition) or in a point table (see Point tables).


Calling a cycle with CYCL CALL POS

The CYCL CALL POS function calls the most recently defined fixed cycle once. The starting point of the cycle is the position that you defined in the CYCL CALL POS block.

Using positioning logic the TNC moves to the position defined in the CYCL CALL POS block:

  • If the tool’s current position in the tool axis is greater than the top surface of the workpiece (Q203), the TNC moves the tool to the programmed position first in the working plane and then in the tool axis.
  • If the tool’s current position in the tool axis is below the top surface of the workpiece (Q203), the TNC moves the tool to the programmed position first in the tool axis to the clearance height and then in the working plane to the programmed position.

Three coordinate axes must always be programmed in the CYCL CALL POS block. With the coordinate in the tool axis you can easily change the starting position. It serves as an additional datum shift.

The feed rate most recently defined in the CYCL CALL POS block applies only for traverse to the start position programmed in this block.

As a rule, the TNC moves without radius compensation (R0) to the position defined in the CYCL CALL POS block.

If you use CYCL CALL POS to call a cycle in which a start position is defined (for example Cycle 212), then the position defined in the cycle serves as an additional shift of the position defined in the CYCL CALL POS block. You should therefore always define the start position to be set in the cycle as 0.


Calling a cycle with M99/M89

The M99 function, which is active only in the block in which it is programmed, calls the last defined fixed cycle once. You can program M99 at the end of a positioning block. The TNC moves to this position and then calls the last defined fixed cycle.

If the TNC is to execute the cycle automatically after every positioning block, program the first cycle call with M89 (depending on MP7440).

    To cancel the effect of M89, program:

  • M99 in the positioning block in which you move to the last starting point, or
  • A CYCL CALL POS block or
  • A new fixed cycle with CYCL DEF


Working with the secondary axes U/V/W

    The TNC performs infeed movements in the axis that was defined in the TOOL CALL block as the spindle axis. It performs movements in the working plane only in the principal axes X, Y or Z. Exceptions:

  • You program secondary axes for the side lengths in Cycles 3 SLOT MILLING and 4 POCKET MILLING.

  • You program secondary axes in the first block of the contour geometry subprogram of an SL cycle.

  • In Cycles 5 (CIRCULAR POCKET), 251 (RECTANGULAR POCKET), 252 (CIRCULAR POCKET), 253 (SLOT) and 254 (CIRCULAR SLOT), the TNC machines the cycle in the axes that you programmed in the last positioning block before the cycle call. When tool axis Z is active, the following combinations are permissible:
    • X/Y
    • X/V
    • U/Y
    • U/V


Program defaults for cycles

Further Informations:
> Overview
> Entering GLOBAL DEF definitions
> Using GLOBAL DEF information
> Global data valid everywhere
> Global data for drilling operations
> Global data for milling operations with pocket cycles 25x
> Global data for milling operations with contour cycles
> Global data for positioning behavior
> Global data for probing functions


Overview

All Cycles 20 to 25, as well as all of those with numbers 200 or higher, always use identical cycle parameters, such as the set-up clearance Q200, which you must enter for each cycle definition. The GLOBAL DEF function gives you the possibility of defining these cycle parameters once at the beginning of the program, so that they are effective globally for all fixed cycles used in the program. In the respective fixed cycle you then simply link to the value defined at the beginning of the program.

The following GLOBAL DEF functions are available:

Machining patterns | Soft key | Page
GLOBAL DEF COMMON Definition of generally valid cycle parameters |  | Global data valid everywhere
GLOBAL DEF DRILLING Definition of specific drilling cycle parameters |  | Global data for drilling operations
GLOBAL DEF POCKET MILLING Definition of specific pocket-milling cycle parameters |  | Global data for milling operations with pocket cycles 25x
GLOBAL DEF CONTOUR MILLING Definition of specific contour milling parameters |  | Global data for milling operations with contour cycles
GLOBAL DEF POSITIONING Definition of the positioning behavior for CYCL CALL PAT |  | Global data for positioning behavior
GLOBAL DEF PROBING Definition of specific touch probe cycle parameters |  | Global data for probing functions

Use the INSERT SMART UNIT function (see Special Functions chapter in the Conversational Programming User's Manual) and then UNIT 700 to insert all GLOBAL DEF functions into a block.


Entering GLOBAL DEF definitions

Select the Programming and Editing operating mode

Press the special functions key

Select the functions for program defaults

Select global DEF functions

Select the desired GLOBAL DEF function, e.g. GLOBAL DEF COMMON

Enter the required definitions, and confirm each entry with the ENT key


Using GLOBAL DEF information

If you have entered the corresponding GLOBAL DEF functions at the beginning of the program, then you can link to these globally valid values when defining any fixed cycle.

Proceed as follows:

Select the Programming and Editing operating mode

Select fixed cycles

Select the desired group of cycles, for example: drilling cycles

Select the desired cycle, e.g. DRILLING

The TNC displays the Set standard values soft key, if there is a global parameter for it

Press the Set standard values soft key. The TNC enters the word PREDEF (predefined) in the cycle definition. You have now created a link to the corresponding GLOBAL DEF parameter that you defined at the beginning of the program

Danger of collision!

Please note that later changes to the program settings affect the entire machining program, and can therefore change the machining procedure significantly.

If you enter a fixed value in a fixed cycle, then this value will not be changed by the GLOBAL DEF functions.


Global data valid everywhere

  • Set-up clearance: Distance between tool tip and workpiece surface for automated approach of the cycle start position in the tool axis

  • 2nd set-up clearance: Position to which the TNC positions the tool at the end of a machining step. The next machining position is approached at this height in the machining plane

  • F positioning: Feed rate at which the TNC traverses the tool within a cycle

  • F retraction: Feed rate at which the TNC retracts the tool

The parameters are valid for all fixed cycles with numbers greater than 2xx.


Global data for drilling operations

  • Retraction rate for chip breaking: Value by which the TNC retracts the tool during chip breaking

  • Dwell time at depth: Time in seconds that the tool remains at the hole bottom

  • Dwell time at top: Time in seconds that the tool remains at the set-up clearance

The parameters apply to the drilling, tapping and thread milling cycles 200 to 209, 240, and 262 to 267.


Global data for milling operations with pocket cycles 25x

  • Overlap factor: The tool radius multiplied by the overlap factor equals the lateral stepover

  • Climb or up-cut: Select the type of milling

  • Plunging type: Plunge into the material helically, in a reciprocating motion, or vertically

The parameters apply to milling cycles 251 to 257.


Global data for milling operations with contour cycles

  • Set-up clearance: Distance between tool tip and workpiece surface for automated approach of the cycle start position in the tool axis

  • Clearance height: Absolute height at which the tool cannot collide with the workpiece (for intermediate positioning and retraction at the end of the cycle)

  • Overlap factor: The tool radius multiplied by the overlap factor equals the lateral stepover

  • Climb or up-cut: Select the type of milling

The parameters apply to SL cycles 20, 22, 23, 24 and 25.


Global data for positioning behavior

  • Positioning behavior: Retraction in the tool axis at the end of the machining step: Return to the 2nd set-up clearance or to the position at the beginning of the unit

The parameters apply to each fixed cycle that you call with the CYCL CALL PAT function.


Global data for probing functions

  • Set-up clearance: Distance between stylus and workpiece surface for automated approach of the probing position

  • Clearance height: The coordinate in the touch probe axis to which the TNC traverses the touch probe between measuring points, if the Move to clearance height option is activated

  • Move to clearance height: Select whether the TNC moves the touch probe to the set-up clearance or clearance height between the measuring points

The parameters apply to all touch probe cycles with numbers greater than 4xx.


PATTERN DEF pattern definition

Further Informations:
> Application
> Entering PATTERN DEF
> Using PATTERN DEF
> Defining individual machining positions
> Defining a single row
> Defining a single pattern
> Defining individual frames
> Defining a full circle
> Defining a pitch circle


Application

You use the PATTERN DEF function to easily define regular machining patterns, which you can call with the CYCL CALL PAT function. As with the cycle definitions, support graphics that illustrate the respective input parameter are also available for pattern definitions.

PATTERN DEF is to be used only in connection with the tool axis Z.

The following machining patterns are available:

Machining pattern | Soft key | Page
POINT Definition of up to any 9 machining positions |  | Defining individual machining positions
ROW Definition of a single row, straight or rotated |  | Defining a single row
PATTERN Definition of a single pattern, straight, rotated or distorted |  | Defining a single pattern
FRAME Definition of a single frame, straight, rotated or distorted |  | Defining individual frames
CIRCLE Definition of a full circle |  | Defining a full circle
PITCH CIRCLE Definition of a pitch circle |  | Defining a pitch circle


Entering PATTERN DEF

Select the Programming and Editing operating mode

Press the special functions key

Select the functions for contour and point machining

Open a PATTERN DEF block

Select the desired machining pattern, e.g. a single row

Enter the required definitions, and confirm each entry with the ENT key


Using PATTERN DEF

As soon as you have entered a pattern definition, you can call it with the CYCL CALL PAT function (see Calling a cycle with CYCL CALL PAT). The TNC then performs the most recently defined machining cycle on the machining pattern you defined.

A machining pattern remains active until you define a new one, or select a point table with the SEL PATTERN function.

You can use the mid-program startup function to select any point at which you want to start or continue machining (see User's Manual, Test Run and Program Run sections).


Defining individual machining positions

You can enter up to 9 machining positions. Confirm each entry with the ENT key.

If you have defined a workpiece surface in Z not equal to 0, then this value is effective in addition to the workpiece surface Q203 that you defined in the machining cycle.

Example: NC blocks
10 L Z+100 R0 FMAX
11 PATTERN DEF pos1 (x+25 y+33.5 z+0) pos2 (x+50 y+75 z+0)

X coord. of machining position (absolute): Enter X coordinate

Y coord. of machining position (absolute): Enter Y coordinate

Workpiece surface coordinate (absolute): Enter Z coordinate at which machining is to begin


Defining a single row

If you have defined a workpiece surface in Z not equal to 0, then this value is effective in addition to the workpiece surface Q203 that you defined in the machining cycle.

Example: NC blocks
10 L Z+100 R0 FMAX
11 PATTERN DEF ROW1 (x+25 y+33.5 d+8 num5 rot+0 z+0)

Starting point in X (absolute): Coordinate of the starting point of the row in the X axis

Starting point in Y (absolute): Coordinate of the starting point of the row in the Y axis

Spacing of machining positions (incremental): Distance between the machining positions. You can enter a positive or negative value

Number of repetitions: Total number of machining operations

Rot. position of entire pattern (absolute): Angle of rotation around the entered starting point. Reference axis: Reference axis of the active machining plane (e.g. X for tool axis Z). You can enter a positive or negative value

Workpiece surface coordinate (absolute): Enter Z coordinate at which machining is to begin


Defining a single pattern

If you have defined a workpiece surface in Z not equal to 0, then this value is effective in addition to the workpiece surface Q203 that you defined in the machining cycle.

The Rotary pos. ref. ax. and Rotary pos. minor ax. parameters are added to a previously performed rotated position of the entire pattern.

Example: NC blocks
10 L Z+100 R0 FMAX
11 PATTERN DEF PAT1 (x+25 y+33.5 dX+8 dy+10 numx5 numy4 rot+0 rotx+0 roty+0 z+0)

Starting point in X (absolute): Coordinate of the starting point of the pattern in the X axis

Starting point in Y (absolute): Coordinate of the starting point of the pattern in the Y axis

Spacing of machining positions X (incremental): Distance between the machining positions in the X direction. You can enter a positive or negative value

Spacing of machining positions Y (incremental): Distance between the machining positions in the Y direction. You can enter a positive or negative value

Number of columns: Total number of columns in the pattern

Number of lines: Total number of rows in the pattern

Rot. position of entire pattern (absolute): Angle of rotation by which the entire pattern is rotated around the entered starting point. Reference axis: Reference axis of the active machining plane (e.g. X for tool axis Z). You can enter a positive or negative value

Rotary pos. ref. ax.: Angle of rotation around which only the reference axis of the machining plane is distorted with respect to the entered starting point. You can enter a positive or negative value.

Rotary pos. minor ax.: Angle of rotation around which only the minor axis of the machining plane is distorted with respect to the entered starting point. You can enter a positive or negative value.

Workpiece surface coordinate (absolute): Enter Z coordinate at which machining is to begin


Defining individual frames

If you have defined a workpiece surface in Z not equal to 0, then this value is effective in addition to the workpiece surface Q203 that you defined in the machining cycle.

The Rotary pos. ref. ax. and Rotary pos. minor ax. parameters are added to a previously performed rotated position of the entire pattern.

Example: NC blocks
10 L Z+100 R0 FMAX
11 PATTERN DEF FRAME1 (x+25 y+33.5 dX+8 dy+10 numx5 numy4 rot+0 rotx+0 roty+0 z+0)

Starting point in X (absolute): Coordinate of the starting point of the frame in the X axis

Starting point in Y (absolute): Coordinate of the starting point of the frame in the Y axis

Spacing of machining positions X (incremental): Distance between the machining positions in the X direction. You can enter a positive or negative value

Spacing of machining positions Y (incremental): Distance between the machining positions in the Y direction. You can enter a positive or negative value

Number of columns: Total number of columns in the pattern

Number of lines: Total number of rows in the pattern

Rot. position of entire pattern (absolute): Angle of rotation by which the entire pattern is rotated around the entered starting point. Reference axis: Reference axis of the active machining plane (e.g. X for tool axis Z). You can enter a positive or negative value

Rotary pos. ref. ax.: Angle of rotation around which only the reference axis of the machining plane is distorted with respect to the entered starting point. You can enter a positive or negative value.

Rotary pos. minor ax.: Angle of rotation around which only the minor axis of the machining plane is distorted with respect to the entered starting point. You can enter a positive or negative value.

Workpiece surface coordinate (absolute): Enter Z coordinate at which machining is to begin


Defining a full circle

If you have defined a workpiece surface in Z not equal to 0, then this value is effective in addition to the workpiece surface Q203 that you defined in the machining cycle.

Example: NC blocks
10 L Z+100 R0 FMAX
11 PATTERN DEF circ1 (x+25 y+33 d80 start+45 num8 z+0)

Bolt-hole circle center X (absolute): Coordinate of the circle center in the X axis

Bolt-hole circle center Y (absolute): Coordinate of the circle center in the Y axis

Bolt-hole circle diameter: Diameter of the bolt-hole circle

Starting angle: Polar angle of the first machining position. Reference axis: Reference axis of the active machining plane (e.g. X for tool axis Z). You can enter a positive or negative value

Number of repetitions: Total number of machining positions on the circle

Workpiece surface coordinate (absolute): Enter Z coordinate at which machining is to begin


Defining a pitch circle

If you have defined a workpiece surface in Z not equal to 0, then this value is effective in addition to the workpiece surface Q203 that you defined in the machining cycle.

Example: NC blocks
10 L Z+100 R0 FMAX
11 PATTERN DEF pitchcirc1 (x+25 y+33 d80 start+45 step30 -num8 z+0)

Bolt-hole circle center X (absolute): Coordinate of the circle center in the X axis

Bolt-hole circle center Y (absolute): Coordinate of the circle center in the Y axis

Bolt-hole circle diameter: Diameter of the bolt-hole circle

Starting angle: Polar angle of the first machining position. Reference axis: Reference axis of the active machining plane (e.g. X for tool axis Z). You can enter a positive or negative value

Stepping angle/end angle: Incremental polar angle between two machining positions. You can enter a positive or negative value. As an alternative you can enter the end angle (switch via soft key).

Number of repetitions: Total number of machining positions on the circle

Workpiece surface coordinate (absolute): Enter Z coordinate at which machining is to begin


Point tables

Further Informations:
> Application
> Creating a point table
> Hiding single points from the machining process
> Defining the clearance height
> Selecting a point table in the program
> Calling a cycle in connection with point tables


Application

You should create a point table whenever you want to run a cycle, or several cycles in sequence, on an irregular point pattern. If you are using drilling cycles, the coordinates of the working plane in the point table represent the hole centers. If you are using milling cycles, the coordinates of the working plane in the point table represent the starting-point coordinates of the respective cycle (e.g. center-point coordinates of a circular pocket). Coordinates in the spindle axis correspond to the coordinate of the workpiece surface.


Creating a point table

Select the Programming and Editing mode of operation.

 | Call the file manager: Press the PGM MGT key
File name?
 | Enter the name and file type of the point table and confirm your entry with the ENT key.
 | Select the unit of measure: Press the MM or INCH soft key. The TNC switches to the program blocks window and displays an empty point table
 | With the soft key INSERT LINE, insert new lines and enter the coordinates of the desired machining position
Repeat the process until all desired coordinates have been entered

Use the soft keys X OFF/ON, Y OFF/ON, Z OFF/ON (second soft-key row) to specify which coordinates you want to enter in the point table.


Hiding single points from the machining process

In the FADE column of the point table you can specify if the defined point is to be hidden during the machining process.

In the table, select the point to be hidden

Select the FADE column.

Activate hiding, or

Deactivate hiding

To hide the marked point during machining, you must also set the Block skip soft key to ON in the Program Run operating mode.


Defining the clearance height

In the CLEARANCE column you can define a separate height for every point. The TNC then positions the tool to this value in the tool axis before you reach this position in the working plane (see also Calling a cycle in connection with point tables).


Selecting a point table in the program

In the Programming and Editing mode of operation, select the program for which you want to activate the point table:

 | Press the PGM CALL key to call the function for selecting the point table
 | Press the POINT TABLE soft key
 | Press the Window selection soft key: The TNC superimposes a window where you can select the desired datum table
Select a point table with the arrow keys or by mouse click and confirm by pressing ENT: The TNC enters the complete path name in the SEL pattern block.
 | Conclude this function with the END key

Alternatively you can also enter the table name or the complete path name of the table to be called directly via the keyboard.

Example NC block
7 SEL PATTERN "TNC:\DIRKT5\NUST35.PNT"


Calling a cycle in connection with point tables

With CYCL CALL PAT the TNC runs the point table that you last defined (even if you defined the point table in a program that was nested with CALL PGM.

If you want the TNC to call the last defined fixed cycle at the points defined in a point table, then program the cycle call with CYCL CALL PAT:

Program the cycle call: Press the CYCL CALL key

Call the point table: Press the CYCL CALL PAT soft key

Enter the feed rate at which the TNC is to move from point to point (if you make no entry the TNC will move at the last programmed feed rate; FMAX is not valid)

If required, enter a miscellaneous function M, then confirm with the END key

The TNC retracts the tool to the clearance height between the starting points. The TNC uses either the spindle axis coordinate from the cycle call, the value from the cycle parameter Q204, or the value defined in the CLEARANCE column as the clearance height, whichever is greatest.

If you want to move at reduced feed rate when pre-positioning in the spindle axis, use the miscellaneous function M103.

Effect of the point tables with SL cycles and Cycle 12

The TNC interprets the points as an additional datum shift.

Effect of the point tables with Cycles 200 to 208 and 262 to 267

The TNC interprets the points of the working plane as coordinates of the hole centers. If you want to use the coordinate defined in the point table for the spindle axis as the starting point coordinate, you must define the workpiece surface coordinate (Q203) as 0.

Effect of the point tables with Cycles 210 to 215

The TNC interprets the points as an additional datum shift. If you want to use the points defined in the point table as starting-point coordinates, you must define the starting points and the workpiece surface coordinate (Q203) in the respective milling cycle as 0.

Effect of the point tables with Cycles 251 to 254

The TNC interprets the points of the working plane as coordinates of the cycle starting point. If you want to use the coordinate defined in the point table for the spindle axis as the starting point coordinate, you must define the workpiece surface coordinate (Q203) as 0.


Fixed Cycles: Drilling

Further Informations:
> Fundamentals
> CENTERING (Cycle 240, DIN/ISO: G240)
> DRILLING (Cycle 200)
> REAMING (Cycle 201, DIN/ISO: G201)
> BORING (Cycle 202, DIN/ISO: G202)
> UNIVERSAL DRILLING (Cycle 203, DIN/ISO: G203)
> BACK BORING (Cycle 204, DIN/ISO: G204)
> UNIVERSAL PECKING (Cycle 205, DIN/ISO: G205)
> BORE MILLING (Cycle 208)
> SINGLE-LIP DEEP-HOLE DRILLING (Cycle 241, DIN/ISO: G241)
> Programming examples


Fundamentals

Further Informations:
> Overview


Overview

The TNC offers 9 cycles for all types of drilling operations:

Cycle | Soft key | Page
240 CENTERING With automatic pre-positioning, 2nd set-up clearance, optional entry of the centering diameter or centering depth |  | CENTERING (Cycle 240, DIN/ISO: G240)
200 DRILLING With automatic pre-positioning, 2nd set-up clearance |  | DRILLING (Cycle 200)
201 REAMING With automatic pre-positioning, 2nd set-up clearance |  | REAMING (Cycle 201, DIN/ISO: G201)
202 BORING With automatic pre-positioning, 2nd set-up clearance |  | BORING (Cycle 202, DIN/ISO: G202)
203 UNIVERSAL DRILLING With automatic pre-positioning, 2nd set-up clearance, chip breaking, and decrementing |  | UNIVERSAL DRILLING (Cycle 203, DIN/ISO: G203)
204 BACK BORING With automatic pre-positioning, 2nd set-up clearance |  | BACK BORING (Cycle 204, DIN/ISO: G204)
205 UNIVERSAL PECKING With automatic pre-positioning, 2nd set-up clearance, chip breaking, and advanced stop distance |  | UNIVERSAL PECKING (Cycle 205, DIN/ISO: G205)
208 BORE MILLING With automatic pre-positioning, 2nd set-up clearance |  | BORE MILLING (Cycle 208)
241 SINGLE-LIP DEEP-HOLE DRILLING With automatic pre-positioning to deepened starting point, shaft speed and coolant definition |  | SINGLE-LIP DEEP-HOLE DRILLING (Cycle 241, DIN/ISO: G241)


CENTERING (Cycle 240, DIN/ISO: G240)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the set-up clearance above the workpiece surface.
  2. The tool is centered at the programmed feed rate F to the entered centering diameter or centering depth.
  3. If defined, the tool remains at the centering depth.
  4. Finally, the tool moves to set-up clearance or—if programmed—to the 2nd set-up clearance at rapid traverse FMAX.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter Q344 (diameter) or Q201 (depth) determines the working direction. If you program the diameter or depth = 0, the cycle will not be executed.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive diameter or depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
10 L Z+100 R0 FMAX
11 CYCL DEF 240 CENTERING
Q200=2 ;SET-UP CLEARANCE
Q343=1 ;SELECT DEPTH/DIA.
Q201=+0 ;DEPTH
Q344=-9 ;DIAMETER
Q206=250 ;FEED RATE FOR PLNGNG
Q211=0.1 ;DWELL TIME AT DEPTH
Q203=+20 ;SURFACE COORDINATE
Q204=100 ;2ND SET-UP CLEARANCE
12 CYCL CALL pos x+30 y+20 z+0 fmax m3
13 CYCL CALL pos x+80 y+50 z+0 fmax

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Enter a positive value. Input range 0 to 99999.9999; alternatively PREDEF

Select Depth/Diameter (1/0) Q343: Select whether centering is based on the entered diameter or depth. If the TNC is to center based on the entered diameter, the point angle of the tool must be defined in the T-angle column of the tool table TOOL.T. 0: Centering based on the entered depth 1: Centering based on the entered diameter

Depth Q201 (incremental): Distance between workpiece surface and centering bottom (tip of centering taper). Only effective if Q343=0 is defined. Input range ‑99999.9999 to 99999.9999

Diameter (algebraic sign) Q344: Centering diameter. Only effective if Q343=1 is defined. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during centering. Input range 0 to 99999.999; alternatively FAUTO, fu

Dwell time at depth Q211: Time in seconds that the tool remains at the hole bottom. Input range 0 to 3600.0000; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF


DRILLING (Cycle 200)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the set-up clearance above the workpiece surface.
  2. The tool drills to the first plunging depth at the programmed feed rate F.
  3. The TNC returns the tool at FMAX to the set-up clearance, dwells there (if a dwell time was entered), and then moves at FMAX to the set-up clearance above the first plunging depth.
  4. The tool then advances with another infeed at the programmed feed rate F.
  5. The TNC repeats this process (2 to 4) until the programmed depth is reached.
  6. The tool is retracted from the hole bottom to the set-up clearance or—if programmed—to the 2nd set-up clearance at FMAX.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
11 CYCL DEF 200 DRILLING
Q200=2 ;SET-UP CLEARANCE
Q201=-15 ;DEPTH
Q206=250 ;FEED RATE FOR PLNGNG
Q202=5 ;PLUNGING DEPTH
Q210=0 ;DWELL TIME AT TOP
Q203=+20 ;SURFACE COORDINATE
Q204=100 ;2ND SET-UP CLEARANCE
Q211=0.1 ;DWELL TIME AT DEPTH
Q395=0 ;DEPTH REFERENCE
12 L X+30 Y+20 FMAX M3 M99
14 L X+80 Y+50 FMAX M99

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Enter a positive value. Input range 0 to 99999.9999; alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of hole (tip of drill taper). Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during drilling. Input range 0 to 99999.999; alternatively FAUTO, fu

Plunging depth Q202 (incremental): Infeed per cut. Input range 0 to 99999.9999. The depth does not have to be a multiple of the plunging depth. The TNC will go to depth in one movement if:

  • the plunging depth is equal to the depth
  • the plunging depth is greater than the depth

Dwell time at top Q210: Time in seconds that the tool remains at set-up clearance after having been retracted from the hole for chip removal. Input range 0 to 3600.0000; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Dwell time at depth Q211: Time in seconds that the tool remains at the hole bottom. Input range 0 to 3600.0000; alternatively PREDEF

Depth reference Q395: Select whether the entered depth is referenced to the tool tip or the cylindrical part of the tool. If the TNC is to reference the depth to the cylindrical part of the tool, the point angle of the tool must be defined in the T ANGLE column of the tool table TOOL.T. 0 = Depth referenced to tool tip 1 = Depth referenced to the cylindrical part of the tool


REAMING (Cycle 201, DIN/ISO: G201)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  2. The tool reams to the entered depth at the programmed feed rate F.
  3. If programmed, the tool remains at the hole bottom for the entered dwell time.
  4. The tool then retracts to the set-up clearance at the feed rate F, and from there—if programmed—to the 2nd set-up clearance at FMAX.


Cycle parameters

Example: NC blocks
11 CYCL DEF 201 REAMING
Q200=2 ;SET-UP CLEARANCE
Q201=-15 ;DEPTH
Q206=100 ;FEED RATE FOR PLNGNG
Q211=0.5 ;DWELL TIME AT DEPTH
Q208=250 ;RETRACTION FEED RATE
Q203=+20 ;SURFACE COORDINATE
Q204=100 ;2ND SET-UP CLEARANCE
12 L X+30 Y+20 FMAX M3
13 CYCL CALL
14 L X+80 Y+50 FMAX M9
15 L Z+100 FMAX M2

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of hole. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during reaming. Input range 0 to 99999.999; alternatively FAUTO, fu

Dwell time at depth Q211: Time in seconds that the tool remains at the hole bottom. Input range 0 to 3600.0000; alternatively PREDEF

Feed rate for retraction Q208: Traversing speed of the tool in mm/min when retracting from the hole. If you enter Q208 = 0, the feed rate for reaming applies. Input range 0 to 99999.999

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range 0 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF


BORING (Cycle 202, DIN/ISO: G202)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the set-up clearance above the workpiece surface.
  2. The tool bores to the programmed depth at the feed rate for plunging.
  3. If programmed, the tool remains at the hole bottom for the entered dwell time with active spindle rotation for cutting free.
  4. The TNC then orients the spindle to the position that is defined in parameter Q336.
  5. If retraction is selected, the tool retracts in the programmed direction by 0.2 mm (fixed value).
  6. The TNC moves the tool at the retraction feed rate to the set-up clearance and then, if entered, to the 2nd set-up clearance at FMAX. If Q214=0 the tool point remains on the wall of the hole.


Please note while programming:

Machine and TNC must be specially prepared by the machine tool builder for use of this cycle.

This cycle is effective only for machines with servo-controlled spindle.

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

After the cycle is completed, the TNC restores the coolant and spindle conditions that were active before the cycle call.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Select a disengaging direction in which the tool moves away from the edge of the hole.

Check the position of the tool tip when you program a spindle orientation to the angle that you enter in Q336 (for example, in the Positioning with Manual Data Input mode of operation). Set the angle so that the tool tip is parallel to a coordinate axis.

During retraction the TNC automatically takes an active rotation of the coordinate system into account.

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of hole. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during boring. Input range 0 to 99999.999; alternatively FAUTO, fu

Dwell time at depth Q211: Time in seconds that the tool remains at the hole bottom. Input range 0 to 3600.0000; alternatively PREDEF

Feed rate for retraction Q208: Traversing speed of the tool in mm/min when retracting from the hole. If you enter Q208 = 0, the feed rate for plunging applies. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.999; alternatively PREDEF
Example:
10 L Z+100 R0 FMAX
11 CYCL DEF 202 BORING
Q200=2 ;SET-UP CLEARANCE
Q201=-15 ;DEPTH
Q206=100 ;FEED RATE FOR PLNGNG
Q211=0.5 ;DWELL TIME AT DEPTH
Q208=250 ;RETRACTION FEED RATE
Q203=+20 ;SURFACE COORDINATE
Q204=100 ;2ND SET-UP CLEARANCE
Q214=1 ;DISENGAGING DIRECTN
Q336=0 ;ANGLE OF SPINDLE
12 L X+30 Y+20 FMAX M3
13 CYCL CALL
14 L X+80 Y+50 FMAX M99

Disengaging direction (0/1/2/3/4) Q214: Determine the direction in which the TNC retracts the tool at the hole bottom (after spindle orientation).

0 | Do not retract tool
1 | Retract tool in the negative ref. axis direction
2 | Retract tool in the negative minor axis direction
3 | Retract tool in the positive ref. axis direction
4 | Retract tool in the positive minor axis direction

Angle for spindle orientation Q336 (absolute): Angle at which the TNC positions the tool before retracting it. Input range ‑360.000 to 360.000


UNIVERSAL DRILLING (Cycle 203, DIN/ISO: G203)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  2. The tool drills to the first plunging depth at the programmed feed rate F.
  3. If you have programmed chip breaking, the tool then retracts by the entered retraction value. If you are working without chip breaking, the tool retracts at the retraction feed rate to the set-up clearance, remains there—if programmed—for the entered dwell time, and advances again at FMAX to the set-up clearance above the first plunging depth.
  4. The tool then advances with another infeed at the programmed feed rate. If programmed, the plunging depth is decreased after each infeed by the decrement.
  5. The TNC repeats this process (2 to 4) until the programmed total hole depth is reached.
  6. The tool remains at the hole bottom—if programmed—for the entered dwell time to cut free, and then retracts to the set-up clearance at the retraction feed rate. If programmed, the tool moves to the 2nd set-up clearance at FMAX.


Cycle parameters

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of hole (tip of drill taper). Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during drilling. Input range 0 to 99999.999; alternatively FAUTO, fu

Plunging depth Q202 (incremental): Infeed per cut. Input range 0 to 99999.9999. The depth does not have to be a multiple of the plunging depth. The TNC will go to depth in one movement if:

  • the plunging depth is equal to the depth
  • the plunging depth is greater than the depth and no chip breaking is defined

Dwell time at top Q210: Time in seconds that the tool remains at set-up clearance after having been retracted from the hole for chip removal. Input range 0 to 3600.0000; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Decrement Q212 (incremental): Value by which the TNC decreases the plunging depth Q202 after each infeed. Input range 0 to 99999.9999

Example: NC blocks
11 CYCL DEF 203 UNIVERSAL DRILLING
Q200=2 ;SET-UP CLEARANCE
Q201=-20 ;DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q202=5 ;PLUNGING DEPTH
Q210=0 ;DWELL TIME AT TOP
Q203=+20 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q212=0.2 ;DECREMENT
Q213=3 ;NR OF BREAKS
Q205=3 ;MIN. PLUNGING DEPTH
Q211=0.25 ;DWELL TIME AT DEPTH
Q208=500 ;RETRACTION FEED RATE
Q256=0.2 ;DIST FOR CHIP BRKNG
Q395=0 ;DEPTH REFERENCE

No. of breaks before retracting Q213: Number of chip breaks after which the TNC is to withdraw the tool from the hole for chip removal. For chip breaking, the TNC retracts the tool each time by the value in Q256. Input range 0 to 99999

Minimum plunging depth Q205 (incremental): If you have entered a decrement, the TNC limits the plunging depth to the value entered with Q205. Input range 0 to 99999.9999

Dwell time at depth Q211: Time in seconds that the tool remains at the hole bottom. Input range 0 to 3600.0000; alternatively PREDEF

Feed rate for retraction Q208: Traversing speed of the tool in mm/min when retracting from the hole. If you enter Q208 = 0, the TNC retracts the tool at the feed rate Q206. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Retraction rate for chip breaking Q256 (incremental): Value by which the TNC retracts the tool during chip breaking. Input range 0.1000 to 99999.9999; alternatively PREDEF

Depth reference Q395: Select whether the entered depth is referenced to the tool tip or the cylindrical part of the tool. If the TNC is to reference the depth to the cylindrical part of the tool, the point angle of the tool must be defined in the T ANGLE column of the tool table TOOL.T. 0 = Depth referenced to tool tip 1 = Depth referenced to the cylindrical part of the tool


BACK BORING (Cycle 204, DIN/ISO: G204)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

This cycle allows holes to be bored from the underside of the workpiece.

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the set-up clearance above the workpiece surface.
  2. The TNC then orients the spindle to the 0° position with an oriented spindle stop, and displaces the tool by the off-center distance.
  3. The tool is then plunged into the already bored hole at the feed rate for pre-positioning until the tooth has reached the set-up clearance on the underside of the workpiece.
  4. The TNC then centers the tool again over the bore hole, switches on the spindle and the coolant and moves at the feed rate for boring to the depth of bore.
  5. If a dwell time is entered, the tool will pause at the top of the bore hole and will then be retracted from the hole again. Another oriented spindle stop is carried out and the tool is once again displaced by the off-center distance.
  6. The tool then retracts to set-up clearance at the feed rate for pre-positioning, and from there—if programmed—to the 2nd set-up clearance at FMAX.


Please note while programming:

Machine and TNC must be specially prepared by the machine tool builder for use of this cycle.

This cycle is effective only for machines with servo-controlled spindle.

Special boring bars for upward cutting are required for this cycle.

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter depth determines the working direction. Note: A positive sign bores in the direction of the positive spindle axis.

The entered tool length is the total length to the underside of the boring bar and not just to the tooth.

When calculating the starting point for boring, the TNC considers the tooth length of the boring bar and the thickness of the material.

You can also execute Cycle 204 with M04 if you have programmed M04 instead of M03 prior to the cycle call.

Danger of collision!

Check the position of the tool tip when you program a spindle orientation to the angle that you enter in Q336 (for example, in the Positioning with Manual Data Input mode of operation). Set the angle so that the tool tip is parallel to a coordinate axis. Select a disengaging direction in which the tool moves away from the edge of the hole.


Cycle parameters

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Depth of counterbore Q249 (incremental): Distance between underside of workpiece and the counterbore floor. A positive sign means the hole will be bored in the positive spindle axis direction. Input range ‑99999.9999 to 99999.9999

Material thickness Q250 (incremental): Thickness of the workpiece. Input range 0.0001 to 99999.9999

Off-center distance Q251 (incremental): Off-center distance for the boring bar; value from tool data sheet. Input range 0.0001 to 99999.9999

Tool edge height Q252 (incremental): Distance between the underside of the boring bar and the main cutting tooth; value from tool data sheet. Input range 0.0001 to 99999.9999

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min when plunging into the workpiece, or when retracting from the workpiece. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Feed rate for countersinking Q254: Traversing speed of the tool in mm/min during countersinking. Input range 0 to 99999.999; alternatively FAUTO, FU

Dwell time Q255: Dwell time in seconds at the top of the bore hole. Input range 0 to 3600.000

Example: NC blocks
11 CYCL DEF 204 BACK BORING
Q200=2 ;SET-UP CLEARANCE
Q249=+5 ;DEPTH OF COUNTERBORE
Q250=20 ;MATERIAL THICKNESS
Q251=3.5 ;OFF-CENTER DISTANCE
Q252=15 ;TOOL EDGE HEIGHT
Q253=750 ;F PRE-POSITIONING
Q254=200 ;F COUNTERSINKING
Q255=0 ;DWELL TIME
Q203=+20 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q214=1 ;DISENGAGING DIRECTN
Q336=0 ;ANGLE OF SPINDLE

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999

Disengaging direction (0/1/2/3/4) Q214: Determine the direction in which the TNC displaces the tool by the off-center distance (after spindle orientation). Input of 0 is not permitted

1 | Retract tool in the negative ref. axis direction
2 | Retract tool in the negative minor axis direction
3 | Retract tool in the positive ref. axis direction
4 | Retract tool in the positive minor axis direction

Angle for spindle orientation Q336 (absolute): Angle at which the TNC positions the tool before it is plunged into or retracted from the bore hole. Input range -360.0000 to 360.0000


UNIVERSAL PECKING (Cycle 205, DIN/ISO: G205)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  2. If you enter a deepened starting point, the TNC moves at the defined positioning feed rate to the set-up clearance above the deepened starting point.
  3. The tool drills to the first plunging depth at the programmed feed rate F.
  4. If you have programmed chip breaking, the tool then retracts by the entered retraction value. If you are working without chip breaking, the tool is moved at rapid traverse to the set-up clearance, and then at FMAX to the entered advanced stop distance above the first plunging depth.
  5. The tool then advances with another infeed at the programmed feed rate. If programmed, the plunging depth is decreased after each infeed by the decrement.
  6. The TNC repeats this process (2 to 4) until the programmed total hole depth is reached.
  7. The tool remains at the hole bottom—if programmed—for the entered dwell time to cut free, and then retracts to the set-up clearance at the retraction feed rate. If programmed, the tool moves to the 2nd set-up clearance at FMAX.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

If you enter different advanced stop distances for Q258 and Q259, the TNC will change the advanced stop distances between the first and last plunging depths at the same rate.

If you use Q379 to enter a deepened starting point, the TNC merely changes the starting point of the infeed movement. Retraction movements are not changed by the TNC, therefore they are calculated with respect to the coordinate of the workpiece surface.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of hole (tip of drill taper). Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during drilling. Input range 0 to 99999.999; alternatively FAUTO, fu

Plunging depth Q202 (incremental): Infeed per cut. Input range 0 to 99999.9999. The depth does not have to be a multiple of the plunging depth. The TNC will go to depth in one movement if:

  • the plunging depth is equal to the depth
  • the plunging depth is greater than the depth

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Decrement Q212 (incremental): Value by which the TNC decreases the plunging depth Q202. Input range 0 to 99999.9999

Minimum plunging depth Q205 (incremental): If you have entered a decrement, the TNC limits the plunging depth to the value entered with Q205. Input range 0 to 99999.9999

Upper advanced stop distance Q258 (incremental): Set-up clearance for rapid traverse positioning when the TNC moves the tool again to the current plunging depth after retraction from the hole; value for the first plunging depth. Input range 0 to 99999.9999

Lower advanced stop distance Q259 (incremental): Set-up clearance for rapid traverse positioning when the TNC moves the tool again to the current plunging depth after retraction from the hole; value for the last plunging depth. Input range 0 to 99999.9999

Example: NC blocks
11 CYCL DEF 205 UNIVERSAL PECKING
Q200=2 ;SET-UP CLEARANCE
Q201=-80 ;DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q202=15 ;PLUNGING DEPTH
Q203=+100 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q212=0.5 ;DECREMENT
Q205=3 ;MIN. PLUNGING DEPTH
Q258=0.5 ;UPPER ADV. STOP DIST.
Q259=1 ;LOWER ADV. STOP DIST.
Q257=5 ;DEPTH FOR CHIP BRKNG
Q256=0.2 ;DIST FOR CHIP BRKNG
Q211=0.25 ;DWELL TIME AT DEPTH
Q379=7.5 ;STARTING POINT
Q253=750 ;F PRE-POSITIONING
Q208=99999 ;RETRACTION FEED RATE
Q395=0 ;DEPTH REFERENCE

Infeed depth for chip breaking Q257 (incremental): Depth at which the TNC carries out chip breaking. No chip breaking if 0 is entered. Input range 0 to 99999.9999

Retraction rate for chip breaking Q256 (incremental): Value by which the TNC retracts the tool during chip breaking. The TNC retracts the tool at a feed rate of 3000 mm/min. Input range 0.1000 to 99999.9999; alternatively PREDEF

Dwell time at depth Q211: Time in seconds that the tool remains at the hole bottom. Input range 0 to 3600.0000; alternatively PREDEF

Deepened starting point Q379 (incremental with respect to the workpiece surface): Starting position of drilling if a shorter tool has already pilot drilled to a certain depth. The TNC moves at the feed rate for pre-positioning from the set-up clearance to the deepened starting point. Input range 0 to 99999.9999

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min during positioning from set-up clearance to the deepened starting point. Effective only if the value entered for Q379 is not equal to 0. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Feed rate for retraction Q208: Traversing speed of the tool in mm/min when retracting after the machining operation. If you enter Q208 = 0, the TNC retracts the tool at the feed rate Q207. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Depth reference Q395: Select whether the entered depth is referenced to the tool tip or the cylindrical part of the tool. If the TNC is to reference the depth to the cylindrical part of the tool, the point angle of the tool must be defined in the T ANGLE column of the tool table TOOL.T. 0 = Depth referenced to tool tip 1 = Depth referenced to the cylindrical part of the tool


BORE MILLING (Cycle 208)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the programmed set-up clearance above the workpiece surface and then moves the tool to the bore hole circumference on a rounded arc (if enough space is available).
  2. The tool mills in a helix from the current position to the first plunging depth at the programmed feed rate F.
  3. When the drilling depth is reached, the TNC once again traverses a full circle to remove the material remaining after the initial plunge.
  4. The TNC then positions the tool at the center of the hole again.
  5. Finally the TNC returns to the set-up clearance at FMAX. If programmed, the tool moves to the 2nd set-up clearance at FMAX.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

If you have entered the bore hole diameter to be the same as the tool diameter, the TNC will bore directly to the entered depth without any helical interpolation.

An active mirror function does not influence the type of milling defined in the cycle.

Note that if the infeed distance is too large, the tool or the workpiece may be damaged.

To prevent the infeeds from being too large, enter the maximum plunge angle of the tool in the ANGLE column of the tool table. The TNC then automatically calculates the max. infeed permitted and changes your entered value accordingly.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
12 CYCL DEF 208 BORE MILLING
Q200=2 ;SET-UP CLEARANCE
Q201=-80 ;DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q334=1.5 ;PLUNGING DEPTH
Q203=+100 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q335=25 ;NOMINAL DIAMETER
Q342=0 ;ROUGHING DIAMETER
Q351=+1 ;CLIMB OR UP-CUT

Set-up clearance Q200 (incremental): Distance between tool lower edge and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of hole. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during helical drilling. Input range 0 to 99999.999; alternatively FAUTO, FU, FZ

Infeed per helix Q334 (incremental): Depth of the tool plunge with each helix (=360°). Input range 0 to 99999.9999

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Nominal diameter Q335 (absolute): Bore-hole diameter. If you have entered the nominal diameter to be the same as the tool diameter, the TNC will bore directly to the entered depth without any helical interpolation. Input range 0 to 99999.9999

Roughing diameter Q342 (absolute): As soon as you enter a value greater than 0 in Q342, the TNC no longer checks the ratio between the nominal diameter and the tool diameter. This allows you to rough-mill holes whose diameter is more than twice as large as the tool diameter. Input range 0 to 99999.9999

Climb or up-cut Q351: Type of milling operation with M3 +1 = climb milling –1 = up-cut milling PREDEF = use the default value from global def


SINGLE-LIP DEEP-HOLE DRILLING (Cycle 241, DIN/ISO: G241)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  2. Then the TNC moves the tool at the defined positioning feed rate to the set-up clearance above the deepened starting point and switches on the drilling speed (M3) and the coolant. The approach motion is executed at the direction of rotation defined in the cycle, with clockwise, counterclockwise or stationary spindle.
  3. The tool drills to the entered drilling depth or, if defined so, to the entered dwell depth, at the programmed feed rate F.
  4. If programmed, the tool remains at the hole bottom for chip breaking. Then the TNC switches off the coolant and resets the drilling speed to the value defined for retraction.
  5. After the dwell time at the hole bottom, the tool is retracted to the set-up clearance at the retraction feed rate. If programmed, the tool moves to the 2nd set-up clearance at FMAX.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!


Cycle parameters

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of hole. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during drilling. Input range 0 to 99999.999; alternatively FAUTO, fu

Dwell time at depth Q211: Time in seconds that the tool remains at the hole bottom. Input range 0 to 3600.0000; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Deepened starting point Q379 (incremental with respect to the workpiece surface): Starting position for actual drilling operation. The TNC moves at the feed rate for pre-positioning from the set-up clearance to the deepened starting point. Input range 0 to 99999.9999

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min during positioning from set-up clearance to the deepened starting point. Effective only if the value entered for Q379 is not equal to 0. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Feed rate for retraction Q208: Traversing speed of the tool in mm/min when retracting from the hole. If you enter Q208 = 0, the TNC retracts the tool at the drilling feed rate Q206. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF
Example: NC blocks
11 CYCL DEF 241 SINGLE-LIP D.H.DRLNG
Q200=2 ;SET-UP CLEARANCE
Q201=-80 ;DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q211=0.25 ;DWELL TIME AT DEPTH
Q203=+100 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q379=7.5 ;STARTING POINT
Q253=750 ;F PRE-POSITIONING
Q208=1000 ;RETRACTION FEED RATE
Q426=3 ;DIR. OF SPINDLE ROT.
Q427=25 ;ROT. SPEED INFEED/OUT
Q428=500 ;DRILLING SPEED
Q429=8 ;COOLANT ON
Q430=9 ;COOLANT OFF
Q435=0 ;DWELL DEPTH

Rotat. dir. of entry/exit (3/4/5) Q426: Desired direction of spindle rotation when tool moves into and retracts from the hole. Input range: 3: Spindle rotation with M3 4: Spindle rotation with M4 5: Movement with stationary spindle

Spindle speed of entry/exit Q427: Desired spindle speed when tool moves into and retracts from the hole. Input range 0 to 99999

Drilling speed Q428: Desired speed for drilling. Input range 0 to 99999

M function for coolant ON Q429: M function for switching on the coolant. The TNC switches the coolant on if the tool is in the hole at the deepened starting point. Input range 0 to 999

M function for coolant OFF Q430: M function for switching off the coolant. The TNC switches the coolant off if the tool is at the hole depth. Input range 0 to 999

Dwell depth Q435 (incremental): Coordinate in the spindle axis at which the tool is to dwell. If 0 is entered, the function is not active (standard setting). Application: During machining of through-holes some tools require a short dwell time before exiting the bottom of the hole in order to transport the chips to the top. Define a value smaller than the hole depth Q201; input range 0 to 99999.9999.


Programming examples

Further Informations:
> Example: Drilling cycles
> Example: Using drilling cycles in connection with PATTERN DEF


Example: Drilling cycles

0 BEGIN PGM C200 MM |
1 BLK FORM 0.1 Z X+0 Y+0 Z-20 | Definition of workpiece blank
2 BLK FORM 0.2 X+100 Y+100 Z+0 |
3 TOOL CALL 1 Z S4500 | Tool call (tool radius 3)
4 L Z+250 R0 FMAX | Retract the tool
5 CYCL DEF 200 DRILLING | Cycle definition
Q200=2 ;SET-UP CLEARANCE |
Q201=-15 ;DEPTH |
Q206=250 ;FEED RATE FOR PLNGNG |
Q202=5 ;PLUNGING DEPTH |
Q210=0 ;DWELL TIME AT TOP |
Q203=-10 ;SURFACE COORDINATE |
Q204=20 ;2ND SET-UP CLEARANCE |
Q211=0.2 ;DWELL TIME AT DEPTH |
Q395=0 ;DEPTH REFERENCE |
6 L X+10 Y+10 R0 FMAX M3 | Approach hole 1, spindle ON
7 CYCL CALL | Cycle call
8 L Y+90 R0 FMAX M99 | Approach hole 2, call cycle
9 L X+90 R0 FMAX M99 | Approach hole 3, call cycle
10 L Y+10 R0 FMAX M99 | Approach hole 4, call cycle
11 L Z+250 R0 FMAX M2 | Retract the tool, end program
12 END PGM C200 MM |


Example: Using drilling cycles in connection with PATTERN DEF

    The drill hole coordinates are stored in the pattern definition PATTERN DEF POS and are called by the TNC with CYCL CALL PAT: The tool radii are selected so that all work steps can be seen in the test graphics. Program sequence

  • Centering (tool radius 4)

  • Drilling (tool radius 2.4)

  • Tapping (tool radius 3)

0 begin pgm 1 mm |
1 blk form 0.1 z x+0 y+0 z-20 | Definition of workpiece blank
2 blk form 0.2 x+100 y+100 y+0 |
3 tool call 1 z s5000 | Call the centering tool (tool radius 4)
4 l z+10 R0 f5000 | Move tool to clearance height (enter a value for F): the TNC positions to the clearance height after every cycle
5 pattern def | Define all drilling positions in the point pattern
pos1( x+10 y+10 z+0 ) |
pos2( x+40 y+30 z+0 ) |
pos3( x+20 y+55 z+0 ) |
pos4( x+10 y+90 z+0 ) |
pos5( x+90 y+90 z+0 ) |
pos6( x+80 y+65 z+0 ) |
pos7( x+80 y+30 z+0 ) |
pos8( x+90 y+10 z+0 ) |
6 cycl def 240 CENTERING | Cycle definition: CENTERING
Q200=2 ;SET-UP CLEARANCE |
Q343=0 ;SELECT DEPTH/DIA. |
Q201=-2 ;DEPTH |
Q344=-10 ;DIAMETER |
Q206=150 ;FEED RATE FOR PLNGNG |
Q211=0 ;DWELL TIME AT DEPTH |
Q203=+0 ;SURFACE COORDINATE |
Q204=50 ;2ND SET-UP CLEARANCE |
7 cycl call pat f5000 m13 | Call the cycle in connection with the point pattern
8 l z+100 r0 fmax | Retract the tool, change the tool
9 tool call 2 z s5000 | Call the drilling tool (radius 2.4)
10 l z+10 R0 f5000 | Move tool to clearance height (enter a value for F)
11 cycl def 200 DRILLING | Cycle definition: drilling
Q200=2 ;SET-UP CLEARANCE |
Q201=-25 ;DEPTH |
Q206=150 ;FEED RATE FOR PLNGNG |
Q202=5 ;PLUNGING DEPTH |
Q210=0 ;DWELL TIME AT TOP |
Q203=+0 ;SURFACE COORDINATE |
Q204=50 ;2ND SET-UP CLEARANCE |
Q211=0.2 ;DWELL TIME AT DEPTH |
Q395=0 ;DEPTH REFERENCE |
12 cycl call pat f5000 m13 | Call the cycle in connection with the point pattern
13 l z+100 r0 fmax | Retract the tool
14 tool call 3 z s200 | Call the tapping tool (radius 3)
15 l z+50 r0 fmax | Move tool to clearance height
16 cycl def 206 TAPPING NEW | Cycle definition for tapping
Q200=2 ;SET-UP CLEARANCE |
Q201=-25 ;DEPTH OF THREAD |
Q206=150 ;FEED RATE FOR PLNGNG |
Q211=0 ;DWELL TIME AT DEPTH |
Q203=+0 ;SURFACE COORDINATE |
Q204=50 ;2ND SET-UP CLEARANCE |
17 cycl call pat f5000 m13 | Call the cycle in connection with the hole pattern
18 l z+100 r0 fmax m2 | Retract the tool, end program
19 end pgm 1 mm |


Fixed Cycles: Tapping / Thread Milling

Further Informations:
> Fundamentals
> TAPPING NEW with a Floating Tap Holder (Cycle 206, DIN/ISO: G206)
> RIGID TAPPING without a Floating Tap Holder NEW (Cycle 207, DIN/ISO: G207)
> TAPPING WITH CHIP BREAKING (Cycle 209, DIN/ISO: G209)
> Fundamentals of thread milling
> THREAD MILLING (Cycle 262, DIN/ISO: G262)
> THREAD MILLING/COUNTERSINKING (Cycle 263, DIN/ISO: G263)
> THREAD DRILLING/MILLING (Cycle 264, DIN/ISO: G264)
> HELICAL THREAD DRILLING/MILLING (Cycle 265, DIN/ISO: G265)
> OUTSIDE THREAD MILLING (Cycle 267, DIN/ISO: G267)
> Programming examples


Overview

The TNC offers 8 cycles for all types of threading operations:

Cycle | Soft key | Page
206 TAPPING NEW With a floating tap holder, with automatic pre-positioning, 2nd set-up clearance |  | TAPPING NEW with a Floating Tap Holder (Cycle 206, DIN/ISO: G206)
207 RIGID TAPPING NEW Without a floating tap holder, with automatic pre-positioning, 2nd set-up clearance |  | RIGID TAPPING without a Floating Tap Holder NEW (Cycle 207, DIN/ISO: G207)
209 TAPPING W/ CHIP BREAKING Without a floating tap holder, with automatic pre-positioning, 2nd set-up clearance, chip breaking |  | TAPPING WITH CHIP BREAKING (Cycle 209, DIN/ISO: G209)
262 THREAD MILLING Cycle for milling a thread in pre-drilled material |  | THREAD MILLING (Cycle 262, DIN/ISO: G262)
263 THREAD MILLING/CNTSNKG Cycle for milling a thread in pre-drilled material and machining a countersunk chamfer |  | THREAD MILLING/COUNTERSINKING (Cycle 263, DIN/ISO: G263)
264 THREAD DRILLING/MILLING Cycle for drilling into solid material with subsequent milling of the thread with a tool |  | THREAD DRILLING/MILLING (Cycle 264, DIN/ISO: G264)
265 HEL.THREAD DRILLING/MILLING Cycle for milling the thread into solid material |  | HELICAL THREAD DRILLING/MILLING (Cycle 265, DIN/ISO: G265)
267 OUTSIDE THREAD MILLING Cycle for milling an external thread and machining a countersunk chamfer |  | HELICAL THREAD DRILLING/MILLING (Cycle 265, DIN/ISO: G265)


TAPPING NEW with a Floating Tap Holder (Cycle 206, DIN/ISO: G206)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  2. The tool taps to the total hole depth in one movement.
  3. Once the tool has reached the total hole depth, the direction of spindle rotation is reversed and the tool is retracted to the set-up clearance at the end of the dwell time. If programmed, the tool moves to the 2nd set-up clearance at FMAX.
  4. At the set-up clearance, the direction of spindle rotation reverses once again.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

A floating tap holder is required for tapping. It must compensate the tolerances between feed rate and spindle speed during the tapping process.

When a cycle is being run, the spindle speed override knob is disabled. The feed-rate override knob is active only within a limited range, which is defined by the machine tool builder (refer to your machine manual).

For tapping right-hand threads activate the spindle with M3, for left-hand threads use M4.

If you enter the thread pitch of the tap in the PITCH column of the tool table, the TNC compares the thread pitch from the tool table with the thread pitch defined in the cycle. The TNC displays an error message if the values do not match. In Cycle 206 the TNC uses the programmed rotational speed and the feed rate defined in the cycle to calculate the thread pitch.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
25 CYCL DEF 206 TAPPING NEW
Q200=2 ;SET-UP CLEARANCE
Q201=-20 ;DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q211=0.25 ;DWELL TIME AT DEPTH
Q203=+25 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE

Set-up clearance Q200 (incremental): Distance between tool tip (at starting position) and workpiece surface. Standard value: approx. 4 times the thread pitch. Input range 0 to 99999.9999; alternatively PREDEF

Total hole depth Q201 (thread length, incremental): Distance between workpiece surface and end of thread. Input range ‑99999.9999 to 99999.9999

Feed rate F Q206: Traversing speed of the tool during tapping. Input range 0 to 99999.999; alternatively FAUTO

Dwell time at bottom Q211: Enter a value between 0 and 0.5 seconds to avoid wedging of the tool during retraction. Input range 0 to 3600.0000; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF
The feed rate is calculated as follows: F = S x p
F: | Feed rate (mm/min)
S: | Spindle speed (rpm)
p: | Thread pitch (mm)
Retracting after a program interruption

If you interrupt program run during tapping with the machine stop button, the TNC will display a soft key with which you can retract the tool.


RIGID TAPPING without a Floating Tap Holder NEW (Cycle 207, DIN/ISO: G207)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

The TNC cuts the thread without a floating tap holder in one or more passes.

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  2. The tool taps to the total hole depth in one movement.
  3. Once the tool has reached the total hole depth, the direction of spindle rotation is reversed and the tool is retracted to the set-up clearance at the end of the dwell time. If programmed, the tool moves to the 2nd set-up clearance at FMAX.
  4. The TNC brings the spindle to a stop at the set-up clearance.


Please note while programming:

Machine and TNC must be specially prepared by the machine tool builder for use of this cycle.

This cycle is effective only for machines with servo-controlled spindle.

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the total hole depth parameter determines the working direction.

The TNC calculates the feed rate from the spindle speed. If the spindle speed override is used during tapping, the feed rate is automatically adjusted.

The feed-rate override knob is disabled.

At the end of the cycle the spindle comes to a stop. Before the next operation, restart the spindle with M3 (or M4).

If you enter the thread pitch of the tap in the PITCH column of the tool table, the TNC compares the thread pitch from the tool table with the thread pitch defined in the cycle. The TNC displays an error message if the values do not match.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
26 CYCL DEF 207 RIGID TAPPING NEW
Q200=2 ;SET-UP CLEARANCE
Q201=-20 ;DEPTH
Q239=+1 ;PITCH
Q203=+25 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE

Set-up clearance Q200 (incremental): Distance between tool tip (at starting position) and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Total hole depth Q201 (incremental): Distance between workpiece surface and end of thread. Input range ‑99999.9999 to 99999.9999

Pitch Q239 Pitch of the thread. The algebraic sign differentiates between right-hand and left-hand threads: + = right-hand thread – = left-hand thread Input range ‑99.9999 to 99.9999

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF
Retracting after a program interruption

If you interrupt program run during thread cutting with the machine stop button, the TNC will display the MANUAL OPERATION soft key. If you press the MANUAL OPERATION soft key, you can retract the tool under program control. Simply press the positive axis direction button of the active spindle axis.


TAPPING WITH CHIP BREAKING (Cycle 209, DIN/ISO: G209)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

The TNC machines the thread in several passes until it reaches the programmed depth. You can define in a parameter whether the tool is to be retracted completely from the hole for chip breaking.

  1. The TNC positions the tool in the tool axis at rapid traverse FMAX to the programmed set-up clearance above the workpiece surface. There it carries out an oriented spindle stop.
  2. The tool moves to the programmed infeed depth, reverses the direction of spindle rotation and retracts by a specific distance or completely for chip release, depending on the definition. If you have defined a factor for increasing the spindle speed, the TNC retracts from the hole at the corresponding speed.
  3. It then reverses the direction of spindle rotation again and advances to the next infeed depth.
  4. The TNC repeats this process (2 to 3) until the programmed thread depth is reached.
  5. The tool is then retracted to the set-up clearance. If programmed, the tool moves to the 2nd set-up clearance at FMAX.
  6. The TNC brings the spindle to a stop at the set-up clearance.


Please note while programming:

Machine and TNC must be specially prepared by the machine tool builder for use of this cycle.

This cycle is effective only for machines with servo-controlled spindle.

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the parameter thread depth determines the working direction.

The TNC calculates the feed rate from the spindle speed. If the spindle speed override is used during tapping, the feed rate is automatically adjusted.

The feed-rate override knob is disabled.

If you defined an rpm factor for fast retraction in cycle parameter Q403, the TNC limits the speed to the maximum speed of the active gear range.

At the end of the cycle the spindle comes to a stop. Before the next operation, restart the spindle with M3 (or M4).

If you enter the thread pitch of the tap in the PITCH column of the tool table, the TNC compares the thread pitch from the tool table with the thread pitch defined in the cycle. The TNC displays an error message if the values do not match.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
26 CYCL DEF 209 TAPPING W/ CHIP BRKG
Q200=2 ;SET-UP CLEARANCE
Q201=-20 ;DEPTH
Q239=+1 ;PITCH
Q203=+25 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q257=5 ;DEPTH FOR CHIP BRKNG
Q256=+1 ;DIST FOR CHIP BRKNG
Q336=50 ;ANGLE OF SPINDLE
Q403=1.5 ;RPM FACTOR

Set-up clearance Q200 (incremental): Distance between tool tip (at starting position) and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Thread depth Q201 (incremental): Distance between workpiece surface and end of thread. Input range ‑99999.9999 to 99999.9999

Pitch Q239
Pitch of the thread. The algebraic sign differentiates between right-hand and left-hand threads:
+ = right-hand thread
– = left-hand thread
Input range ‑99.9999 to 99.9999

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Infeed depth for chip breaking Q257 (incremental): Depth at which TNC carries out chip breaking. Input range 0 to 99999.9999

Retraction rate for chip breaking Q256: The TNC multiplies the pitch Q239 by the programmed value and retracts the tool by the calculated value during chip breaking. If you enter Q256 = 0, the TNC retracts the tool completely from the hole (to the set-up clearance) for chip breaking. Input range 0 to 99999.9999

Angle for spindle orientation Q336 (absolute): Angle at which the TNC positions the tool before machining the thread. This allows you to regroove the thread, if required. Input range -360.0000 to 360.0000

RPM factor for retraction Q403: Factor by which the TNC increases the spindle speed—and therefore also the retraction feed rate—when retracting from the drill hole. Input range 0.0001 to 10; the speed is increased at most to the maximum speed of the active gear range.

Retracting after a program interruption

If you interrupt program run during thread cutting with the machine stop button, the TNC will display the MANUAL OPERATION soft key. If you press the MANUAL OPERATION soft key, you can retract the tool under program control. Simply press the positive axis direction button of the active spindle axis.


Fundamentals of thread milling

Further Informations:
> Requirements


Requirements

  • Your machine tool should feature internal spindle cooling (cooling lubricant at least 30 bars, compressed air supply at least 6 bars).
  • Thread milling usually leads to distortions of the thread profile. To correct this effect, you need tool-specific compensation values which are given in the tool catalog or are available from the tool manufacturer. You program the compensation with the delta value for the tool radius DR in the TOOL CALL.
  • The Cycles 262, 263, 264 and 267 can only be used with rightward rotating tools. For Cycle 265 you can use rightward and leftward rotating tools.
  • The working direction is determined by the following input parameters: Algebraic sign Q239 (+ = right-hand thread / – = left-hand thread) and milling method Q351 (+1 = climb / –1 = up-cut). The table below illustrates the interrelation between the individual input parameters for rightward rotating tools.
Internal thread | Pitch | Climb/Up-cut | Work direction
Right-handed | + | +1(RL) | Z+
Left-handed | – | –1(RR) | Z+
Right-handed | + | –1(RR) | Z–
Left-handed | – | +1(RL) | Z–
External thread | Pitch | Climb/Up-cut | Work direction
Right-handed | + | +1(RL) | Z–
Left-handed | – | –1(RR) | Z–
Right-handed | + | –1(RR) | Z+
Left-handed | – | +1(RL) | Z+

The TNC references the programmed feed rate during thread milling to the tool cutting edge. Since the TNC, however, always displays the feed rate relative to the path of the tool tip, the displayed value does not match the programmed value.

The machining direction of the thread changes if you execute a thread milling cycle in connection with Cycle 8 MIRROR IMAGE in only one axis.

Danger of collision!

Always program the same algebraic sign for the infeeds: Cycles comprise several sequences of operation that are independent of each other. The order of precedence according to which the work direction is determined is described with the individual cycles. For example, if you only want to repeat the countersinking process of a cycle, enter 0 for the thread depth. The work direction will then be determined from the countersinking depth.

Procedure in case of a tool break

If a tool break occurs during thread cutting, stop program run, change to the Positioning with MDI operating mode and move the tool on a linear path to the hole center. You can then retract the tool in the infeed axis and replace it.


THREAD MILLING (Cycle 262, DIN/ISO: G262)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  2. The tool moves at the programmed feed rate for pre-positioning to the starting plane. The starting plane is derived from the algebraic sign of the thread pitch, the milling method (climb or up-cut milling) and the number of threads per step.
  3. The tool then approaches the thread diameter tangentially in a helical movement. Before the helical approach, a compensating motion of the tool axis is carried out in order to begin at the programmed starting plane for the thread path.
  4. Depending on the setting of the parameter for the number of threads, the tool mills the thread in one helical movement, in several offset helical movements or in one continuous helical movement.
  5. After this, the tool departs the contour tangentially and returns to the starting point in the working plane.
  6. At the end of the cycle, the TNC retracts the tool at rapid traverse to the set-up clearance, or—if programmed—to the 2nd set-up clearance.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign for the cycle parameter "thread depth" determines the working direction. If you program the thread DEPTH = 0, the cycle will not be executed.

The nominal thread diameter is approached in a semi-circle from the center. A pre-positioning movement to the side is carried out if the tool diameter is smaller than the nominal thread diameter by four times the thread pitch.

Note that the TNC makes a compensation movement in the tool axis before the approach movement. The length of the compensation movement is at most half of the thread pitch. Ensure sufficient space in the hole!

If you change the thread depth, the TNC automatically changes the starting point for the helical movement.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Keep in mind that if the depth is changed, the TNC adjust the starting angle so that the tool reaches the defined depth at the 0° position of the spindle. In such cases, recutting the thread may result in a second thread groove.

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
25 CYCL DEF 262 THREAD MILLING
Q335=10 ;NOMINAL DIAMETER
Q239=+1.5 ;PITCH
Q201=-20 ;DEPTH OF THREAD
Q355=0 ;THREADS PER STEP
Q253=750 ;F PRE-POSITIONING
Q351=+1 ;CLIMB OR UP-CUT
Q200=2 ;SET-UP CLEARANCE
Q203=+30 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q207=500 ;FEED RATE FOR MILLING
Q512=50 ;FEED RATE FOR APPROACH

Nominal diameter Q335: Nominal thread diameter. Input range 0 to 99999.9999

Thread pitch Q239: Pitch of the thread. The algebraic sign differentiates between right-hand and left-hand threads: + = right-hand thread – = left-hand thread Input range ‑99.9999 to 99.9999

Thread depth Q201 (incremental): Distance between workpiece surface and root of thread. Input range ‑99999.9999 to 99999.9999

Threads per step Q355: Number of thread revolutions by which the tool is moved: 0 = one 360° helical line to the thread depth 1 = continuous helical path over the entire length of the thread >1 = several helical paths with approach and departure; between them, the TNC offsets the tool by Q355, multiplied by the pitch. Input range 0 to 99999

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min when plunging into the workpiece, or when retracting from the workpiece. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Climb or up-cut Q351: Type of milling operation with M3 +1 = climb milling –1 = up-cut milling Alternatively PREDEF

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Feed rate for milling Q207: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.999; alternatively FAUTO

Feed rate for approach Q512: Traversing speed of the tool in mm/min during entry into the thread. Input range 0 to 99999.999; alternatively FAUTO


THREAD MILLING/COUNTERSINKING (Cycle 263, DIN/ISO: G263)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  1. Countersinking
  2. The tool moves at the feed rate for pre-positioning to the countersinking depth minus the set-up clearance, and then at the feed rate for countersinking to the countersinking depth.
  3. If a set-up clearance to the side has been entered, the TNC immediately positions the tool at the feed rate for pre-positioning to the countersinking depth.
  4. Then, depending on the available space, the TNC makes a tangential approach to the core diameter, either tangentially from the center or with a pre-positioning move to the side, and follows a circular path.
  1. Countersinking at front
  5. The tool moves at the feed rate for pre-positioning to the countersinking depth at front.
  6. The TNC positions the tool without compensation from the center on a semicircle to the offset at front, and then follows a circular path at the feed rate for countersinking.
  7. The tool then moves in a semicircle to the hole center.
  1. Thread milling
  8. The TNC moves the tool at the programmed feed rate for pre-positioning to the starting plane for the thread. The starting plane is determined from the algebraic sign of the thread pitch and the type of milling (climb or up-cut).
  9. Then the tool moves tangentially on a helical path to the thread diameter and mills the thread with a 360° helical motion.
  10. After this, the tool departs the contour tangentially and returns to the starting point in the working plane.
  11. At the end of the cycle, the TNC retracts the tool at rapid traverse to the set-up clearance, or—if programmed—to the 2nd set-up clearance.


Please note while programming:

Before programming, note the following

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign of the cycle parameters thread depth, countersinking depth or depth at front determines the working direction. The working direction is defined in the following sequence:
1 Thread depth
2 Countersinking depth
3 Depth at frontIf you program a depth parameter to be 0, the TNC does not execute that step.

If you want to countersink at front, define the countersinking depth as 0.

Program the thread depth as a value smaller than the countersinking depth by at least one-third the thread pitch.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Nominal diameter Q335: Nominal thread diameter. Input range 0 to 99999.9999

Thread pitch Q239: Pitch of the thread. The algebraic sign differentiates between right-hand and left-hand threads: + = right-hand thread – = left-hand thread Input range ‑99.9999 to 99.9999

Thread depth Q201 (incremental): Distance between workpiece surface and root of thread. Input range ‑99999.9999 to 99999.9999

Countersinking depth Q356 (incremental): Distance between tool tip and the top surface of the workpiece. Input range ‑99999.9999 to 99999.9999

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min when plunging into the workpiece, or when retracting from the workpiece. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Climb or up-cut Q351: Type of milling operation with M3 +1 = climb milling –1 = up-cut milling Alternatively PREDEF

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Set-up clearance to the side Q357 (incremental): Distance between tool tooth and the wall of the hole. Input range 0 to 99999.9999

Depth at front Q358 (incremental): Distance between tool tip and the top surface of the workpiece for countersinking at front. Input range ‑99999.9999 to 99999.9999

Countersinking offset at front Q359 (incremental): Distance by which the TNC moves the tool center away from the hole center. Input range 0 to 99999.9999

Example: NC blocks
25 CYCL DEF 263 THREAD MLLNG/CNTSNKG
Q335=10 ;NOMINAL DIAMETER
Q239=+1.5 ;PITCH
Q201=-16 ;DEPTH OF THREAD
Q356=-20 ;COUNTERSINKING DEPTH
Q253=750 ;F PRE-POSITIONING
Q351=+1 ;CLIMB OR UP-CUT
Q200=2 ;SET-UP CLEARANCE
Q357=0.2 ;CLEARANCE TO SIDE
Q358=+0 ;DEPTH AT FRONT
Q359=+0 ;OFFSET AT FRONT
Q203=+30 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q254=150 ;F COUNTERSINKING
Q207=500 ;FEED RATE FOR MILLING
Q512=50 ;FEED RATE FOR APPROACH

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Feed rate for countersinking Q254: Traversing speed of the tool in mm/min during countersinking. Input range 0 to 99999.999; alternatively FAUTO, fu

Feed rate for milling Q207: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.9999; alternatively FAUTO

Feed rate for approach Q512: Traversing speed of the tool in mm/min during entry into the thread. Input range 0 to 99999.999; alternatively FAUTO


THREAD DRILLING/MILLING (Cycle 264, DIN/ISO: G264)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  1. Drilling
  2. The tool drills to the first plunging depth at the programmed feed rate for plunging.
  3. If you have programmed chip breaking, the tool then retracts by the entered retraction value. If you are working without chip breaking, the tool is moved at rapid traverse to the set-up clearance, and then at FMAX to the entered advanced stop distance above the first plunging depth.
  4. The tool then advances with another infeed at the programmed feed rate.
  5. The TNC repeats this process (2 to 4) until the programmed total hole depth is reached.
  1. Countersinking at front
  6. The tool moves at the feed rate for pre-positioning to the countersinking depth at front.
  7. The TNC positions the tool without compensation from the center on a semicircle to the offset at front, and then follows a circular path at the feed rate for countersinking.
  8. The tool then moves in a semicircle to the hole center.
  1. Thread milling
  9. The TNC moves the tool at the programmed feed rate for pre-positioning to the starting plane for the thread. The starting plane is determined from the algebraic sign of the thread pitch and the type of milling (climb or up-cut).
  10. Then the tool moves tangentially on a helical path to the thread diameter and mills the thread with a 360° helical motion.
  11. After this, the tool departs the contour tangentially and returns to the starting point in the working plane.
  12. At the end of the cycle, the TNC retracts the tool at rapid traverse to the set-up clearance, or—if programmed—to the 2nd set-up clearance.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign of the cycle parameters thread depth, countersinking depth or depth at front determines the working direction. The working direction is defined in the following sequence:
1 Thread depth
2 Total hole depth
3 Depth at frontIf you program a depth parameter to be 0, the TNC does not execute that step.

Program the thread depth as a value smaller than the total hole depth by at least one-third the thread pitch.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Nominal diameter Q335: Nominal thread diameter. Input range 0 to 99999.9999

Thread pitch Q239: Pitch of the thread. The algebraic sign differentiates between right-hand and left-hand threads: + = right-hand thread – = left-hand thread Input range ‑99.9999 to 99.9999

Thread depth Q201 (incremental): Distance between workpiece surface and root of thread. Input range ‑99999.9999 to 99999.9999

Total hole depth Q356 (incremental): Distance between workpiece surface and bottom of hole. Input range ‑99999.9999 to 99999.9999

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min when plunging into the workpiece, or when retracting from the workpiece. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Climb or up-cut Q351: Type of milling operation with M3 +1 = climb milling –1 = up-cut milling Alternatively PREDEF

Plunging depth Q202 (incremental): Infeed per cut. The depth does not have to be a multiple of the plunging depth. Input range 0 to 99999.9999. The TNC will go to depth in one movement if:

  • the plunging depth is equal to the depth
  • the plunging depth is greater than the depth

Upper advanced stop distance Q258 (incremental): Set-up clearance for rapid traverse positioning when the TNC moves the tool again to the current plunging depth after retraction from the hole. Input range 0 to 99999.9999

Infeed depth for chip breaking Q257 (incremental): Depth at which TNC carries out chip breaking. No chip breaking if 0 is entered. Input range 0 to 99999.9999; alternatively PREDEF

Retraction rate for chip breaking Q256 (incremental): Value by which the TNC retracts the tool during chip breaking. Input range 0.1000 to 99999.9999

Example: NC blocks
25 CYCL DEF 264 THREAD DRILLNG/MLLNG
Q335=10 ;NOMINAL DIAMETER
Q239=+1.5 ;PITCH
Q201=-16 ;DEPTH OF THREAD
Q356=-20 ;TOTAL HOLE DEPTH
Q253=750 ;F PRE-POSITIONING
Q351=+1 ;CLIMB OR UP-CUT
Q202=5 ;PLUNGING DEPTH
Q258=0.2 ;ADVANCED STOP DISTANCE
Q257=5 ;DEPTH FOR CHIP BRKNG
Q256=0.2 ;DIST FOR CHIP BRKNG
Q358=+0 ;DEPTH AT FRONT
Q359=+0 ;OFFSET AT FRONT
Q200=2 ;SET-UP CLEARANCE
Q203=+30 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q206=150 ;FEED RATE FOR PLNGNG
Q207=500 ;FEED RATE FOR MILLING
Q512=50 ;FEED RATE FOR APPROACH

Depth at front Q358 (incremental): Distance between tool tip and the top surface of the workpiece for countersinking at front. Input range ‑99999.9999 to 99999.9999

Countersinking offset at front Q359 (incremental): Distance by which the TNC moves the tool center away from the hole center. Input range 0 to 99999.9999

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Feed rate for plunging Q206: Traversing speed of the tool in mm/min during drilling. Input range 0 to 99999.999; alternatively FAUTO, fu

Feed rate for milling Q207: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.9999; alternatively FAUTO

Feed rate for approach Q512: Traversing speed of the tool in mm/min during entry into the thread. Input range 0 to 99999.999; alternatively FAUTO


HELICAL THREAD DRILLING/MILLING (Cycle 265, DIN/ISO: G265)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  1. Countersinking at front
  2. If countersinking is before thread milling, the tool moves at the feed rate for countersinking to the sinking depth at front. If countersinking occurs after thread milling, the TNC moves the tool to the countersinking depth at the feed rate for pre-positioning.
  3. The TNC positions the tool without compensation from the center on a semicircle to the offset at front, and then follows a circular path at the feed rate for countersinking.
  4. The tool then moves in a semicircle to the hole center.
  1. Thread milling
  5. The tool moves at the programmed feed rate for pre-positioning to the starting plane for the thread.
  6. The tool then approaches the thread diameter tangentially in a helical movement.
  7. The tool moves on a continuous helical downward path until it reaches the thread depth.
  8. After this, the tool departs the contour tangentially and returns to the starting point in the working plane.
  9. At the end of the cycle, the TNC retracts the tool at rapid traverse to the set-up clearance, or—if programmed—to the 2nd set-up clearance.


Please note while programming:

Program a positioning block for the starting point (hole center) in the working plane with radius compensation R0.

The algebraic sign of the cycle parameters thread depth or depth at front determines the working direction. The working direction is defined in the following sequence:
1 Thread depth
2 Depth at frontIf you program a depth parameter to be 0, the TNC does not execute that step.

If you change the thread depth, the TNC automatically changes the starting point for the helical movement.

The type of milling (up-cut/climb) is determined by the thread (right-hand/left-hand) and the direction of tool rotation, since it is only possible to work in the direction of the tool.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Nominal diameter Q335: Nominal thread diameter. Input range 0 to 99999.9999

Thread pitch Q239: Pitch of the thread. The algebraic sign differentiates between right-hand and left-hand threads: + = right-hand thread – = left-hand thread Input range ‑99.9999 to 99.9999

Thread depth Q201 (incremental): Distance between workpiece surface and root of thread. Input range ‑99999.9999 to 99999.9999

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min when plunging into the workpiece, or when retracting from the workpiece. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Depth at front Q358 (incremental): Distance between tool tip and the top surface of the workpiece for countersinking at front. Input range ‑99999.9999 to 99999.9999

Countersinking offset at front Q359 (incremental): Distance by which the TNC moves the tool center away from the hole center. Input range 0 to 99999.9999

Countersink Q360: Execution of the chamfer 0 = before thread machining 1 = after thread machining

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF
Example: NC blocks
25 CYCL DEF 265 HEL. THREAD DRLG/MLG
Q335=10 ;NOMINAL DIAMETER
Q239=+1.5 ;PITCH
Q201=-16 ;DEPTH OF THREAD
Q253=750 ;F PRE-POSITIONING
Q358=+0 ;DEPTH AT FRONT
Q359=+0 ;OFFSET AT FRONT
Q360=0 ;COUNTERSINK
Q200=2 ;SET-UP CLEARANCE
Q203=+30 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q254=150 ;F COUNTERSINKING
Q207=500 ;FEED RATE FOR MILLING

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Feed rate for countersinking Q254: Traversing speed of the tool in mm/min during countersinking. Input range 0 to 99999.999; alternatively FAUTO, fu

Feed rate for milling Q207: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.999; alternatively FAUTO


OUTSIDE THREAD MILLING (Cycle 267, DIN/ISO: G267)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool in the spindle axis at rapid traverse FMAX to the entered set-up clearance above the workpiece surface.
  1. Countersinking at front
  2. The TNC moves on the reference axis of the working plane from the center of the stud to the starting point for countersinking at front. The position of the starting point is determined by the thread radius, tool radius and pitch.
  3. The tool moves at the feed rate for pre-positioning to the countersinking depth at front.
  4. The TNC positions the tool without compensation from the center on a semicircle to the offset at front, and then follows a circular path at the feed rate for countersinking.
  5. The tool then moves on a semicircle to the starting point.
  1. Thread milling
  6. The TNC positions the tool to the starting point if there has been no previous countersinking at front. Starting point for thread milling = starting point for countersinking at front.
  7. The tool moves at the programmed feed rate for pre-positioning to the starting plane. The starting plane is derived from the algebraic sign of the thread pitch, the milling method (climb or up-cut milling) and the number of threads per step.
  8. The tool then approaches the thread diameter tangentially in a helical movement.
  9. Depending on the setting of the parameter for the number of threads, the tool mills the thread in one helical movement, in several offset helical movements or in one continuous helical movement.
  10. After this, the tool departs the contour tangentially and returns to the starting point in the working plane.
  11. At the end of the cycle, the TNC retracts the tool at rapid traverse to the set-up clearance, or—if programmed—to the 2nd set-up clearance.


Please note while programming:

Program a positioning block for the starting point (stud center) in the working plane with radius compensation R0.

The offset required before countersinking at the front should be determined ahead of time. You must enter the value from the center of the stud to the center of the tool (uncorrected value).

The algebraic sign of the cycle parameters depth of thread or sinking depth at front determines the working direction. The working direction is defined in the following sequence:
1 Thread depth
2nd Depth at frontIf you program a depth parameter to be 0, the TNC does not execute that step.

The algebraic sign for the cycle parameter "thread depth" determines the working direction.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Keep in mind that if the depth is changed, the TNC adjust the starting angle so that the tool reaches the defined depth at the 0° position of the spindle. In such cases, recutting the thread may result in a second thread groove.

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Nominal diameter Q335: Nominal thread diameter. Input range 0 to 99999.9999

Thread pitch Q239: Pitch of the thread. The algebraic sign differentiates between right-hand and left-hand threads: + = right-hand thread – = left-hand thread Input range ‑99.9999 to 99.9999

Thread depth Q201 (incremental): Distance between workpiece surface and root of thread.

Threads per step Q355: Number of thread revolutions by which the tool is moved: 0 = one helical line to the thread depth 1 = continuous helical path over the entire length of the thread >1 = several helical paths with approach and departure; between them, the TNC offsets the tool by Q355, multiplied by the pitch. Input range 0 to 99999

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min when plunging into the workpiece, or when retracting from the workpiece. Input range 0 to 99999.999; alternatively Fmax, FAUTO, PREDEF

Climb or up-cut Q351: Type of milling operation with M3 +1 = climb milling –1 = up-cut milling Alternatively PREDEF
Example: NC blocks
25 CYCL DEF 267 OUTSIDE THREAD MLLNG
Q335=10 ;NOMINAL DIAMETER
Q239=+1.5 ;PITCH
Q201=-20 ;DEPTH OF THREAD
Q355=0 ;THREADS PER STEP
Q253=750 ;F PRE-POSITIONING
Q351=+1 ;CLIMB OR UP-CUT
Q200=2 ;SET-UP CLEARANCE
Q358=+0 ;DEPTH AT FRONT
Q359=+0 ;OFFSET AT FRONT
Q203=+30 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q254=150 ;F COUNTERSINKING
Q207=500 ;FEED RATE FOR MILLING
Q512=50 ;FEED RATE FOR APPROACH

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Depth at front Q358 (incremental): Distance between tool tip and the top surface of the workpiece for countersinking at front. Input range ‑99999.9999 to 99999.9999

Countersinking offset at front Q359 (incremental): Distance by which the TNC moves the tool center away from the stud center. Input range 0 to 99999.9999

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Feed rate for countersinking Q254: Traversing speed of the tool in mm/min during countersinking. Input range 0 to 99999.999; alternatively FAUTO, fu

Feed rate for milling Q207: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.999; alternatively FAUTO

Feed rate for approach Q512: Traversing speed of the tool in mm/min during entry into the thread. Input range 0 to 99999.999; alternatively FAUTO


Programming examples

Further Informations:
> Example: Tapping


Example: Tapping

    The drill hole coordinates are stored in the point table TAB1.PNT and are called by the TNC with CYCL CALL PAT. The tool radii are selected so that all work steps can be seen in the test graphics. Program sequence

  • Centering

  • Drilling

  • Tapping

0 begin pgm 1 mm |
1 blk form 0.1 z x+0 y+0 z-20 | Definition of workpiece blank
2 blk form 0.2 x+100 y+100 y+0 |
3 tool def 1 l+0 r+4 | Tool definition of center drill
4 tool def 2 l+0 2.4 | Tool definition of drill
5 tool def 3 l+0 r+3 | Tool definition of tap
6 tool call 1 z s5000 | Call tool: centering drill
7 l z+10 R0 f5000 | Move tool to clearance height (enter a value for F): the TNC positions to the clearance height after every cycle
8 sel pattern "tab1" | Definition of point table
9 cycl def 200 DRILLING | Cycle definition: CENTERING
Q200=2 ;SET-UP CLEARANCE |
Q201=-2 ;DEPTH |
Q206=150 ;FEED RATE FOR PLNGNG |
Q202=2 ;PLUNGING DEPTH |
Q210=0 ;DWELL TIME AT TOP |
Q203=+0 ;SURFACE COORDINATE | 0 must be entered here, effective as defined in point table
Q204=0 ;2ND SET-UP CLEARANCE | 0 must be entered here, effective as defined in point table
Q211=0.2 ;DWELL TIME AT DEPTH |
Q395=0 ;DEPTH REFERENCE |
10 cycl call pat f5000 m3 | Cycle call in connection with point table TAB1.PNT, feed rate between the points: 5000 mm/min
11 l z+100 r0 fmax m6 | Retract the tool, change the tool
12 tool call 2 z s5000 | Call tool: drill
13 l z+10 R0 f5000 | Move tool to clearance height (enter a value for F)
14 cycl def 200 DRILLING | Cycle definition: drilling
Q200=2 ;SET-UP CLEARANCE |
Q201=-25 ;DEPTH |
Q206=150 ;FEED RATE FOR PLNGNG |
Q202=5 ;PLUNGING DEPTH |
Q210=0 ;DWELL TIME AT TOP |
Q203=+0 ;SURFACE COORDINATE | 0 must be entered here, effective as defined in point table
Q204=0 ;2ND SET-UP CLEARANCE | 0 must be entered here, effective as defined in point table
Q211=0.2 ;DWELL TIME AT DEPTH |
Q395=0 ;DEPTH REFERENCE |
15 cycl call pat f5000 m3 | Cycle call in connection with point table TAB1.PNT
16 l z+100 r0 fmax m6 | Retract the tool, change the tool
17 tool call 3 z s200 | Call tool: tap
18 l z+50 r0 fmax | Move tool to clearance height
19 cycl def 206 TAPPING NEW | Cycle definition for tapping
Q200=2 ;SET-UP CLEARANCE |
Q201=-25 ;DEPTH OF THREAD |
Q206=150 ;FEED RATE FOR PLNGNG |
Q211=0 ;DWELL TIME AT DEPTH |
Q203=+0 ;SURFACE COORDINATE | 0 must be entered here, effective as defined in point table
Q204=0 ;2ND SET-UP CLEARANCE | 0 must be entered here, effective as defined in point table
20 cycl call pat f5000 m3 | Cycle call in connection with point table TAB1.PNT
21 l z+100 r0 fmax m2 | Retract the tool, end program
22 end pgm 1 mm |

Point table TAB1.PNT

TAB1. PNT MM
NR X Y Z
0 +10 +10 +0
1 +40 +30 +0
2 +90 +10 +0
3 +80 +30 +0
4 +80 +65 +0
5 +90 +90 +0
6 +10 +90 +0
7 +20 +55 +0
[END]


Fixed Cycles: Pocket Milling / Stud Milling / Slot Milling

Further Informations:
> Fundamentals
> RECTANGULAR POCKET (Cycle 251, DIN/ISO: G251)
> CIRCULAR POCKET (Cycle 252, DIN/ISO: G252)
> SLOT MILLING (Cycle 253, DIN/ISO: G253)
> CIRCULAR SLOT (Cycle 254, DIN/ISO: G254)
> RECTANGULAR STUD (Cycle 256, DIN/ISO: G256)
> CIRCULAR STUD (Cycle 257, DIN/ISO: G257)
> Programming examples


Fixed Cycles: Pocket Milling / Stud Milling / Slot Milling

Fundamentals

Further Informations:
> Overview


Overview

The TNC offers 6 cycles for machining pockets, studs and slots:

Cycle | Soft key | Page
251 RECTANGULAR POCKET Roughing/finishing cycle with selection of machining operation and helical plunging |  | RECTANGULAR POCKET (Cycle 251, DIN/ISO: G251)
252 CIRCULAR POCKET Roughing/finishing cycle with selection of machining operation and helical plunging |  | CIRCULAR POCKET (Cycle 252, DIN/ISO: G252)
253 SLOT MILLING Roughing/finishing cycle with selection of machining operation and reciprocal plunging |  | SLOT MILLING (Cycle 253, DIN/ISO: G253)
254 CIRCULAR SLOT Roughing/finishing cycle with selection of machining operation and reciprocal plunging |  | CIRCULAR SLOT (Cycle 254, DIN/ISO: G254)
256 RECTANGULAR STUD Roughing/finishing cycle with stepover, if multiple passes are required |  | RECTANGULAR STUD (Cycle 256, DIN/ISO: G256)
257 CIRCULAR STUD Roughing/finishing cycle with stepover, if multiple passes are required |  | CIRCULAR STUD (Cycle 257, DIN/ISO: G257)


RECTANGULAR POCKET (Cycle 251, DIN/ISO: G251)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

    Use Cycle 251 RECTANGULAR POCKET to completely machine rectangular pockets. Depending on the cycle parameters, the following machining alternatives are available:

  • Complete machining: Roughing, floor finishing, side finishingOnly roughingOnly floor finishing and side finishingOnly floor finishingOnly side finishing
  1. Roughing
  2. The tool plunges into the workpiece at the pocket center and advances to the first plunging depth. Specify the plunging strategy with parameter Q366.
  3. The TNC roughs out the pocket from the inside out, taking the overlap factor (parameter Q370) and the finishing allowances (parameters Q368 and Q369) into account.
  4. At the end of the roughing operation, the TNC moves the tool tangentially away from the pocket wall, then moves by the set-up clearance above the current infeed depth and returns from there at rapid traverse to the pocket center.
  5. This process is repeated until the programmed pocket depth is reached.
  1. Finishing
  5. Inasmuch as finishing allowances are defined, the TNC then finishes the pocket walls, in multiple infeeds if so specified. The pocket wall is approached tangentially.
  6. Then the TNC finishes the floor of the pocket from the inside out. The pocket floor is approached tangentially.


Please note while programming:

With an inactive tool table you must always plunge vertically (Q366=0) because you cannot define a plunging angle.

Pre-position the tool in the machining plane to the starting position with radius compensation R0. Note parameter Q367 (pocket position).

The TNC carries out the cycle in the axes (machining plane) in which you approached the start position. For example, in X and Y if you programmed CYCL CALL POS X... Y... or in U and V if you programmed CYCL CALL POS U... V...

The TNC automatically pre-positions the tool in the tool axis. Note parameter Q204 (2nd set-up clearance).

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

At the end of the cycle, the TNC returns the tool to the starting position.

At the end of a roughing operation, the TNC positions the tool back to the pocket center at rapid traverse. The tool is above the current pecking depth by the set-up clearance. Enter the set-up clearance so that the tool cannot jam because of chips.

If you mirror Cycle 251 in one axis, the TNC reverses the machining direction defined in the cycle.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.

If you call the cycle with machining operation 2 (only finishing), then the TNC positions the tool in the center of the pocket at rapid traverse to the first plunging depth.


Cycle parameters

Machining operation (0/1/2) Q215: Define the machining operation:
0: Roughing and finishing
1: Only roughing
2: Only finishing
Side finishing and floor finishing are only executed if the respective finishing allowance (Q368, Q369) has been defined

1st side length Q218 (incremental): Pocket length, parallel to the reference axis of the working plane. Input range 0 to 99999.9999

2nd side length Q219 (incremental): Pocket length, parallel to the minor axis of the working plane. Input range 0 to 99999.9999

Corner radius Q220: Radius of the pocket corner. If you have entered 0 or a value smaller than the tool radius, the TNC defines the corner radius to be equal to the tool radius. In these cases, the TNC will not display an error message. Input range 0 to 99999.9999

Finishing allowance for side Q368 (incremental): Finishing allowance in the working plane. Input range 0 to 99999.9999

Angle of rotation Q224 (absolute): Angle by which the entire pocket is rotated. The center of rotation is the position at which the tool is located when the cycle is called. Input range -360.0000 to 360.0000

Pocket position Q367: Position of the pocket in reference to the position of the tool when the cycle is called: 0: Tool position = Center of pocket 1: Tool position = Lower left corner 2: Tool position = Lower right corner 3: Tool position = Upper right corner 4: Tool position = Upper left corner

Feed rate for milling Q207: Traversing speed of the tool in mm/min while milling. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Climb or up-cut Q351: Type of milling operation with M3: +1 = climb milling –1 = up-cut milling +0 = climb milling; if a mirror function is active, the climb milling method remains effective Alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of pocket. Input range ‑99999.9999 to 99999.9999

Plunging depth Q202 (incremental): Infeed per cut. Enter a value greater than 0. Input range 0 to 99999.9999

Finishing allowance for floor Q369 (incremental): Finishing allowance in the tool axis. Input range 0 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min while moving to depth. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Infeed for finishing Q338 (incremental): Infeed per cut. Q338=0: Finishing in one infeed. Input range 0 to 99999.9999

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Workpiece surface coordinate Q203 (absolute): Absolute coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF
Example: NC blocks
8 cycl def 251 RECTANGULAR POCKET
Q215=0 ;MACHINING OPERATION
Q218=80 ;1ST SIDE LENGTH
Q219=60 ;2ND SIDE LENGTH
Q220=5 ;CORNER RADIUS
Q368=0.2 ;ALLOWANCE FOR SIDE
Q224=+0 ;ANGLE OF ROTATION
Q367=0 ;POCKET POSITION
Q207=500 ;FEED RATE FOR MILLING
Q351=+1 ;CLIMB OR UP-CUT
Q201=-20 ;DEPTH
Q202=5 ;PLUNGING DEPTH
Q369=0.1 ;ALLOWANCE FOR FLOOR
Q206=150 ;FEED RATE FOR PLNGNG
Q338=5 ;INFEED FOR FINISHING
Q200=2 ;SET-UP CLEARANCE
Q203=+0 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q370=1 ;TOOL PATH OVERLAP
Q366=1 ;PLUNGE
Q385=500 ;FEED RATE FOR FINISHING
9 cycl call pos x+50 y+50 z+0 fmax m3

Path overlap factor Q370: Q370 x tool radius = stepover factor k. Input range: 0.1 to 1.414; alternatively PREDEF

Plunging strategy Q366: Type of plunging strategy:

  • 0 = Vertical plunging. The TNC plunges perpendicularly, regardless of the plunging angle ANGLE defined in the tool table.
  • 1 = Helical plunging. In the tool table, the plunging angle ANGLE for the active tool must be defined as not equal to 0. The TNC will otherwise display an error message.
  • 2 = Reciprocating plunge. In the tool table, the plunging angle ANGLE for the active tool must be defined as not equal to 0. Otherwise, the TNC generates an error message. The reciprocation length depends on the plunging angle. As a minimum value the TNC uses twice the tool diameter.
  • Alternative: PREDEF

Feed rate for finishing Q385: Traversing speed of the tool in mm/min during side and floor finishing. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ


CIRCULAR POCKET (Cycle 252, DIN/ISO: G252)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

    Use Cycle 252 CIRCULAR POCKET to completely machine circular pockets. Depending on the cycle parameters, the following machining alternatives are available:

  • Complete machining: Roughing, floor finishing, side finishingOnly roughingOnly floor finishing and side finishingOnly floor finishingOnly side finishing
  1. Roughing
  2. The tool plunges into the workpiece at the pocket center and advances to the first plunging depth. Specify the plunging strategy with parameter Q366.
  3. The TNC roughs out the pocket from the inside out, taking the overlap factor (parameter Q370) and the finishing allowances (parameters Q368 and Q369) into account.
  4. At the end of the roughing operation, the TNC moves the tool tangentially away from the pocket wall, then moves by the set-up clearance above the current infeed depth and returns from there at rapid traverse to the pocket center.
  5. This process is repeated until the programmed pocket depth is reached.
  1. Finishing
  5. Inasmuch as finishing allowances are defined, the TNC then finishes the pocket walls, in multiple infeeds if so specified. The pocket wall is approached tangentially.
  6. Then the TNC finishes the floor of the pocket from the inside out. The pocket floor is approached tangentially.


Please note while programming:

With an inactive tool table you must always plunge vertically (Q366=0) because you cannot define a plunging angle.

Pre-position the tool in the machining plane to the starting position (circle center) with radius compensation R0.

The TNC carries out the cycle in the axes (machining plane) in which you approached the start position. For example, in X and Y if you programmed CYCL CALL POS X... Y... or in U and V if you programmed CYCL CALL POS U... V...

The TNC automatically pre-positions the tool in the tool axis. Note parameter Q204 (2nd set-up clearance).

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

At the end of the cycle, the TNC returns the tool to the starting position.

At the end of a roughing operation, the TNC positions the tool back to the pocket center at rapid traverse. The tool is above the current pecking depth by the set-up clearance. Enter the set-up clearance so that the tool cannot jam because of chips.

If you mirror Cycle 252, the machining direction defined in the cycle remains effective and is not mirrored.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.

If you call the cycle with machining operation 2 (only finishing), then the TNC positions the tool in the center of the pocket at rapid traverse to the first plunging depth.


Cycle parameters

Machining operation (0/1/2) Q215: Define the machining operation:
0: Roughing and finishing
1: Only roughing
2: Only finishing
Side finishing and floor finishing are only executed if the respective finishing allowance (Q368, Q369) has been defined

Circle diameter Q223: Diameter of the finished pocket. Input range 0 to 99999.9999

Finishing allowance for side Q368 (incremental): Finishing allowance in the working plane. Input range 0 to 99999.9999

Feed rate for milling Q207: Traversing speed of the tool in mm/min while milling. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Climb or up-cut Q351: Type of milling operation with M3: +1 = climb milling –1 = up-cut milling +0 = climb milling; if a mirror function is active, the climb milling method remains effective Alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of pocket. Input range ‑99999.9999 to 99999.9999

Plunging depth Q202 (incremental): Infeed per cut. Enter a value greater than 0. Input range 0 to 99999.9999

Finishing allowance for floor Q369 (incremental): Finishing allowance in the tool axis. Input range 0 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min while moving to depth. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Infeed for finishing Q338 (incremental): Infeed per cut. Q338=0: Finishing in one infeed. Input range 0 to 99999.9999

Example: NC blocks
8 cycl def 252 CIRCULAR POCKET
Q215=0 ;MACHINING OPERATION
Q223=60 ;CIRCLE DIAMETER
Q368=0.2 ;ALLOWANCE FOR SIDE
Q207=500 ;FEED RATE FOR MILLING
Q351=+1 ;CLIMB OR UP-CUT
Q201=-20 ;DEPTH
Q202=5 ;PLUNGING DEPTH
Q369=0.1 ;ALLOWANCE FOR FLOOR
Q206=150 ;FEED RATE FOR PLNGNG
Q338=5 ;INFEED FOR FINISHING
Q200=2 ;SET-UP CLEARANCE
Q203=+0 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q370=1 ;TOOL PATH OVERLAP
Q366=1 ;PLUNGE
Q385=500 ;FEED RATE FOR FINISHING
9 cycl call pos x+50 y+50 Z+0 fmax m3

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Workpiece surface coordinate Q203 (absolute): Absolute coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Path overlap factor Q370: Q370 x tool radius = stepover factor k. Input range: 0.1 to 1.414; alternatively PREDEF

Plunging strategy Q366: Type of plunging strategy:

  • 0 = Vertical plunging. The TNC plunges perpendicularly, regardless of the plunging angle ANGLE defined in the tool table.
  • 1 = Helical plunging. In the tool table, the plunging angle ANGLE for the active tool must be defined as not equal to 0. The TNC will otherwise display an error message.
  • Alternative: PREDEF

Feed rate for finishing Q385: Traversing speed of the tool in mm/min during side and floor finishing. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ


SLOT MILLING (Cycle 253, DIN/ISO: G253)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

    Use Cycle 253 to completely machine a slot. Depending on the cycle parameters, the following machining alternatives are available:

  • Complete machining: Roughing, floor finishing, side finishingOnly roughingOnly floor finishing and side finishingOnly floor finishingOnly side finishing
  1. Roughing
  2. Starting from the left slot arc center, the tool moves in a reciprocating motion at the plunging angle defined in the tool table to the first infeed depth. Specify the plunging strategy with parameter Q366.
  3. The TNC roughs out the slot from the inside out, taking the finishing allowances (parameters Q368 and Q369) into account.
  4. This process is repeated until the programmed slot depth is reached.
  1. Finishing
  4. Inasmuch as finishing allowances are defined, the TNC then finishes the slot walls, in multiple infeeds if so specified. The slot side is approached tangentially in the right slot arc.
  5. Then the TNC finishes the floor of the slot from the inside out. The slot floor is approached tangentially.


Please note while programming:

With an inactive tool table you must always plunge vertically (Q366=0) because you cannot define a plunging angle.

Pre-position the tool in the machining plane to the starting position with radius compensation R0. Note parameter Q367 (slot position).

The TNC carries out the cycle in the axes (machining plane) in which you approached the start position. For example, in X and Y if you programmed CYCL CALL POS X... Y... or in U and V if you programmed CYCL CALL POS U... V...

The TNC automatically pre-positions the tool in the tool axis. Note parameter Q204 (2nd set-up clearance).

At the end of the cycle the TNC merely moves the tool in working plane back to the center of the slot; in the other working plane axis the TNC does not do any positioning. If you define a slot position not equal to 0, then the TNC only positions the tool in the tool axis to the 2nd set-up clearance. Prior to a new cycle call, move the tool back to the starting position or program always absolute traverse motions after the cycle call.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

If the slot width is greater than twice the tool diameter, the TNC roughs the slot correspondingly from the inside out. You can therefore mill any slots with small tools, too.

If you mirror Cycle 253, the machining direction defined in the cycle remains effective and is not mirrored.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.

If you call the cycle with machining operation 2 (only finishing), then the TNC positions the tool to the first plunging depth at rapid traverse!


Cycle parameters

Machining operation (0/1/2) Q215: Define the machining operation:
0: Roughing and finishing
1: Only roughing
2: Only finishing
Side finishing and floor finishing are only executed if the respective finishing allowance (Q368, Q369) has been defined

Slot length Q218 (value parallel to the reference axis of the working plane): Enter the length of the slot. Input range 0 to 99999.9999

Slot width Q219 (value parallel to the minor axis of the working plane): Enter the slot width. If you enter a slot width that equals the tool diameter, the TNC will carry out the roughing process only (slot milling). Maximum slot width for roughing: Twice the tool diameter. Input range 0 to 99999.9999

Finishing allowance for side Q368 (incremental): Finishing allowance in the working plane.

Angle of rotation Q374 (absolute): Angle by which the entire slot is rotated. The center of rotation is the position at which the tool is located when the cycle is called. Input range -360.000 to 360.000

Slot position (0/1/2/3/4) Q367: Position of the slot in reference to the position of the tool when the cycle is called: 0: Tool position = Center of slot 1: Tool position = Left end of slot 2: Tool position = Center of left slot circle 3: Tool position = Center of right slot circle 4: Tool position = Right end of slot

Feed rate for milling Q207: Traversing speed of the tool in mm/min while milling. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Climb or up-cut Q351: Type of milling operation with M3: +1 = climb milling –1 = up-cut milling +0 = climb milling; if a mirror function is active, the climb milling method remains effective Alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of slot. Input range ‑99999.9999 to 99999.9999

Plunging depth Q202 (incremental): Infeed per cut. Enter a value greater than 0. Input range 0 to 99999.9999

Finishing allowance for floor Q369 (incremental): Finishing allowance in the tool axis. Input range 0 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min while moving to depth. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Infeed for finishing Q338 (incremental): Infeed per cut. Q338=0: Finishing in one infeed. Input range 0 to 99999.9999

Example: NC blocks
8 cycl def 253 SLOT MILLING
Q215=0 ;MACHINING OPERATION
Q218=80 ;SLOT LENGTH
Q219=12 ;SLOT WIDTH
Q368=0.2 ;ALLOWANCE FOR SIDE
Q374=+0 ;ANGLE OF ROTATION
Q367=0 ;SLOT POSITION
Q207=500 ;FEED RATE FOR MILLING
Q351=+1 ;CLIMB OR UP-CUT
Q201=-20 ;DEPTH
Q202=5 ;PLUNGING DEPTH
Q369=0.1 ;ALLOWANCE FOR FLOOR
Q206=150 ;FEED RATE FOR PLNGNG
Q338=5 ;INFEED FOR FINISHING
Q200=2 ;SET-UP CLEARANCE
Q203=+0 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q366=1 ;PLUNGE
Q385=500 ;FEED RATE FOR FINISHING
Q439=0 ;FEED RATE REFERENCE
9 cycl call pos x+50 y+50 Z+0 fmax m3

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Workpiece surface coordinate Q203 (absolute): Absolute coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Plunging strategy Q366: Type of plunging strategy:

  • 0 = Vertical plunging. The TNC plunges perpendicularly, regardless of the plunging angle ANGLE defined in the tool table.
  • 1 = Helical plunging. In the tool table, the plunging angle ANGLE for the active tool must be defined as not equal to 0. Otherwise, the TNC generates an error message. Plunge on a helical path only if there is enough space.
  • 2 = Reciprocating plunge. In the tool table, the plunging angle ANGLE for the active tool must be defined as not equal to 0. The TNC will otherwise display an error message.
  • Alternative: PREDEF

Feed rate for finishing Q385: Traversing speed of the tool in mm/min during side and floor finishing. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate reference Q439: Select a reference for the programmed feed rate:

  • 0 = Feed rate refers to the tool path center
  • 1 = Feed rate refers to the tool cutting edge only during side finishing; otherwise it refers to the tool path center
  • 2 = Feed rate refers to the tool cutting edge during side finishing and floor finishing; otherwise it refers to the tool path center
  • 3 = Feed rate always refers to the tool cutting edge; otherwise it refers to the tool path center


CIRCULAR SLOT (Cycle 254, DIN/ISO: G254)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

    Use Cycle 254 to completely machine a circular slot. Depending on the cycle parameters, the following machining alternatives are available:

  • Complete machining: Roughing, floor finishing, side finishingOnly roughingOnly floor finishing and side finishingOnly floor finishingOnly side finishing
  1. Roughing
  2. The tool moves in a reciprocating motion in the slot center at the plunging angle defined in the tool table to the first infeed depth. Specify the plunging strategy with parameter Q366.
  3. The TNC roughs out the slot from the inside out, taking the finishing allowances (parameters Q368 and Q369) into account.
  4. This process is repeated until the programmed slot depth is reached.
  1. Finishing
  4. Inasmuch as finishing allowances are defined, the TNC then finishes the slot walls, in multiple infeeds if so specified. The slot side is approached tangentially.
  5. Then the TNC finishes the floor of the slot from the inside out. The slot floor is approached tangentially.


Please note while programming:

With an inactive tool table you must always plunge vertically (Q366=0) because you cannot define a plunging angle.

Pre-position the tool in the machining plane with radius compensation R0. Define parameter Q367 (reference for slot position) appropriately.

The TNC carries out the cycle in the axes (machining plane) in which you approached the start position. For example, in X and Y if you programmed CYCL CALL POS X... Y... or in U and V if you programmed CYCL CALL POS U... V...

The TNC automatically pre-positions the tool in the tool axis. Note parameter Q204 (2nd set-up clearance).

At the end of the cycle the TNC merely moves the tool in working plane back to the center of the pitch circle; in the other working plane axis the TNC does not do any positioning. If you define a slot position not equal to 0, then the TNC only positions the tool in the tool axis to the 2nd set-up clearance. Prior to a new cycle call, move the tool back to the starting position or program always absolute traverse motions after the cycle call.

At the end of the cycle the TNC returns the tool to the starting point (center of the pitch circle) in the working plane. Exception: if you define a slot position not equal to 0, then the TNC only positions the tool in the tool axis to the 2nd set-up clearance. In these cases, always program absolute traverse movements after the cycle call.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

If the slot width is greater than twice the tool diameter, the TNC roughs the slot correspondingly from the inside out. You can therefore mill any slots with small tools, too.

The slot position 0 is not allowed if you use Cycle 254 Circular Slot in combination with Cycle 221.

If you mirror Cycle 254, the machining direction defined in the cycle remains effective and is not mirrored.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.

If you call the cycle with machining operation 2 (only finishing), then the TNC positions the tool to the first plunging depth at rapid traverse!


Cycle parameters

Machining operation (0/1/2) Q215: Define the machining operation:
0: Roughing and finishing
1: Only roughing
2: Only finishing
Side finishing and floor finishing are only executed if the respective finishing allowance (Q368, Q369) has been defined

Slot width Q219 (value parallel to the minor axis of the working plane): Enter the slot width. If you enter a slot width that equals the tool diameter, the TNC will carry out the roughing process only (slot milling). Maximum slot width for roughing: Twice the tool diameter. Input range 0 to 99999.9999

Finishing allowance for side Q368 (incremental): Finishing allowance in the working plane. Input range 0 to 99999.9999

Pitch circle diameter Q375: Enter the diameter of the pitch circle. Input range 0 to 99999.9999

Reference for slot position (0/1/2/3) Q367: Position of the slot in reference to the position of the tool when the cycle is called: 0: The tool position is not taken into account. The slot position is determined from the entered pitch circle center and the starting angle. 1: Tool position = Center of left slot circle. Starting angle Q376 refers to this position. The entered pitch circle center is not taken into account. 2: Tool position = Center of center line. Starting angle Q376 refers to this position. The entered pitch circle center is not taken into account. 3: Tool position = Center of right slot circle. Starting angle Q376 refers to this position. The entered pitch circle center is not taken into account.

Center in 1st axis Q216 (absolute): Center of the pitch circle in the reference axis of the working plane. Only effective if Q367 = 0. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q217 (absolute): Center of the pitch circle in the minor axis of the working plane. Only effective if Q367 = 0. Input range ‑99999.9999 to 99999.9999

Starting angle Q376 (absolute): Enter the polar angle of the starting point. Input range -360.000 to 360.000

Angular length Q248 (incremental): Enter the angular length of the slot. Input range 0 to 360.000

Stepping angle Q378 (incremental): Angle by which the entire slot is rotated. The center of rotation is at the center of the pitch circle. Input range -360.000 to 360.000

Number of repetitions Q377: Number of machining operations on a pitch circle. Input range 1 to 99999

Feed rate for milling Q207: Traversing speed of the tool in mm/min while milling. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Climb or up-cut Q351: Type of milling operation with M3: +1 = climb milling –1 = up-cut milling +0 = climb milling; if a mirror function is active, the climb milling method remains effective Alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of slot. Input range ‑99999.9999 to 99999.9999

Plunging depth Q202 (incremental): Infeed per cut. Enter a value greater than 0. Input range 0 to 99999.9999

Finishing allowance for floor Q369 (incremental): Finishing allowance in the tool axis. Input range 0 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min while moving to depth. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Infeed for finishing Q338 (incremental): Infeed per cut. Q338=0: Finishing in one infeed. Input range 0 to 99999.9999

Example: NC blocks
8 cycl def 254 CIRCULAR SLOT
Q215=0 ;MACHINING OPERATION
Q219=12 ;SLOT WIDTH
Q368=0.2 ;ALLOWANCE FOR SIDE
Q375=80 ;PITCH CIRCLE DIA.
Q367=0 ;ref. slot position
Q216=+50 ;center in 1st axis
Q217=+50 ;CENTER IN 2ND AXIS
Q376=+45 ;starting angle
Q248=90 ;ANGULAR LENGTH
Q378=0 ;stepping angle
Q377=1 ;NUMBER OF OPERATIONS
Q207=500 ;FEED RATE FOR MILLING
Q351=+1 ;CLIMB OR UP-CUT
Q201=-20 ;DEPTH
Q202=5 ;PLUNGING DEPTH
Q369=0.1 ;ALLOWANCE FOR FLOOR
Q206=150 ;FEED RATE FOR PLNGNG
Q338=5 ;INFEED FOR FINISHING
Q200=2 ;SET-UP CLEARANCE
Q203=+0 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q366=1 ;PLUNGE
Q385=500 ;FEED RATE FOR FINISHING
Q439=0 ;FEED RATE REFERENCE
9 cycl call pos x+50 y+50 Z+0 fmax m3

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Workpiece surface coordinate Q203 (absolute): Absolute coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Plunging strategy Q366: Type of plunging strategy:

  • 0 = Vertical plunging. The TNC plunges perpendicularly, regardless of the plunging angle ANGLE defined in the tool table.
  • 1 = Helical plunging. In the tool table, the plunging angle ANGLE for the active tool must be defined as not equal to 0. Otherwise, the TNC generates an error message. Plunge on a helical path only if there is enough space.
  • 2 = Reciprocating plunge. In the tool table, the plunging angle ANGLE for the active tool must be defined as not equal to 0. Otherwise, the TNC generates an error message. The TNC can only plunge reciprocally once the traversing length on the circular arc is at least three times the tool diameter.
  • Alternative: PREDEF

Feed rate for finishing Q385: Traversing speed of the tool in mm/min during side and floor finishing. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Feed rate reference (0 to 3) Q439: Select a reference for the programmed feed rate:

  • 0 = Feed rate refers to the tool path center
  • 1 = Feed rate refers to the tool cutting edge only during side finishing; otherwise it refers to the tool path center
  • 2 = Feed rate refers to the tool cutting edge during floor finishing and side finishing; otherwise it refers to the tool path center
  • 3 = Feed rate always refers to the tool cutting edge; otherwise it refers to the tool path center


RECTANGULAR STUD (Cycle 256, DIN/ISO: G256)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Use Cycle 256 to machine a rectangular stud. If a dimension of the workpiece blank is greater than the maximum possible stepover, then the TNC performs multiple stepovers until the finished dimension has been machined.

  1. The tool moves from the cycle starting position (stud center) to the starting position for stud machining. Specify the starting position with parameter Q437. The standard setting (Q437=0) lies 2 mm to the right next to the stud blank.
  2. If the tool is at the 2nd set-up clearance, it moves at rapid traverse FMAX to the set-up clearance, and from there it advances to the first plunging depth at the feed rate for plunging.
  3. The tool then moves tangentially to the stud contour and machines one revolution.
  4. If the finished dimension cannot be machined with one revolution, the TNC performs a stepover with the current factor, and machines another revolution. The TNC takes the dimensions of the workpiece blank, the finished dimension, and the permitted stepover into account. This process is repeated until the defined finished dimension has been reached. If you have set the starting point on a corner (Q437 not equal to 0), the TNC mills on a spiral path from the starting point inward until the finished dimension has been reached.
  5. If more than one plunging movement is required, the tool departs the contour on a tangential path and returns to the starting point of stud machining.
  6. The TNC then plunges the tool to the next plunging depth, and machines the stud at this depth.
  7. This process is repeated until the programmed stud depth is reached.
  8. At the end of the cycle, the TNC merely positions the tool in the tool axis at the clearance height defined in the cycle. This means that the end position differs from the starting position.


Please note while programming:

Pre-position the tool in the machining plane to the starting position with radius compensation R0. Note parameter Q367 (stud position).

The TNC automatically pre-positions the tool in the tool axis. Note parameter Q204 (2nd set-up clearance).

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Leave enough room next to the stud for the approach motion. Minimum: Tool diameter plus 2 mm if you are working with standard approach radius and approach angle.

At the end, the TNC positions the tool back to the set-up clearance, or to the 2nd set-up clearance if one was programmed. This means that the end position of the tool after the cycle differs from the starting position.

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

1st side length Q218: Stud length, parallel to the reference axis of the working plane. Input range 0 to 99999.9999

Workpiece blank side length 1 Q424: Length of the stud blank, parallel to the reference axis of the working plane. Enter Workpiece blank side length 1 greater than1st side length. The TNC performs multiple stepovers if the difference between blank dimension 1 and finished dimension 1 is greater than the permitted stepover (tool radius multiplied by path overlap Q370). The TNC always calculates a constant stepover. Input range 0 to 99999.9999

2nd side length Q219: Stud length, parallel to the minor axis of the working plane. Enter Workpiece blank side length 2 greater than 2nd side length. The TNC performs multiple stepovers if the difference between blank dimension 2 and finished dimension 2 is greater than the permitted stepover (tool radius multiplied by path overlap Q370). The TNC always calculates a constant stepover. Input range 0 to 99999.9999

Workpiece blank side length 2 Q425: Length of the stud blank, parallel to the minor axis of the working plane. Input range 0 to 99999.9999

Corner radius Q220: Radius of the stud corner. Input range 0 to 99999.9999

Finishing allowance for side Q368 (incremental): Finishing allowance in the working plane, is left over after machining. Input range 0 to 99999.9999

Angle of rotation Q224 (absolute): Angle by which the entire stud is rotated. The center of rotation is the position at which the tool is located when the cycle is called. Input range -360.000 to 360.000

Stud position Q367: Position of the stud in reference to the position of the tool when the cycle is called: 0: Tool position = Center of stud 1: Tool position = Lower left corner 2: Tool position = Lower right corner 3: Tool position = Upper right corner 4: Tool position = Upper left corner

Example: NC blocks
8 cycl def 256 RECTANGULAR STUD
Q218=60 ;1ST SIDE LENGTH
Q424=74 ;WORKPC. BLANK SIDE 1
Q219=40 ;2ND SIDE LENGTH
Q425=60 ;WORKPC. BLANK SIDE 2
Q220=5 ;CORNER RADIUS
Q368=0.2 ;ALLOWANCE FOR SIDE
Q224=+0 ;ANGLE OF ROTATION
Q367=0 ;STUD POSITION
Q207=500 ;FEED RATE FOR MILLING
Q351=+1 ;CLIMB OR UP-CUT
Q201=-20 ;DEPTH
Q202=5 ;PLUNGING DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q200=2 ;SET-UP CLEARANCE
Q203=+0 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q370=1 ;TOOL PATH OVERLAP
Q437=0 ;APPROACH POSITION
9 cycl call pos x+50 y+50 z+0 fmax m3

Feed rate for milling Q207: Traversing speed of the tool in mm/min while milling. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Climb or up-cut Q351: Type of milling operation with M3: +1 = climb milling –1 = up-cut milling Alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of stud. Input range ‑99999.9999 to 99999.9999

Plunging depth Q202 (incremental): Infeed per cut. Enter a value greater than 0. Input range 0 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min while moving to depth. Input range 0 to 99999.999; alternatively Fmax, FAUTO, fu, FZ

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Workpiece surface coordinate Q203 (absolute): Absolute coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Path overlap factor Q370: Q370 x tool radius = stepover factor k. Input range: 0.1 to 1.414; alternatively PREDEF

Approach position (0...4) Q437: Specify the tool approach strategy: 0: From the right of the stud (default setting) 1: Lower left corner 2: Lower right corner 3: Upper right corner 4: Upper left corner If approach marks should be appear on the stud surface during approach with the setting Q437=0, then choose another approach position


CIRCULAR STUD (Cycle 257, DIN/ISO: G257)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Use Cycle 257 to machine a circular stud. If the diameter of the workpiece blank is greater than the maximum possible stepover, then the TNC performs a spiral infeed until the finished diameter has been machined.

  1. The tool moves from the cycle starting position (stud center) to the starting position for stud machining. With the polar angle you specify the starting position with respect to the stud center using parameter Q376.
  2. If the tool is at the 2nd set-up clearance, it moves at rapid traverse FMAX to the set-up clearance, and from there it advances to the first plunging depth at the feed rate for plunging.
  3. The tool then moves tangentially on a helical path to the stud contour and machines one revolution.
  4. If the finished diameter cannot be machined with one revolution, the TNC performs helical infeed movements until the finished diameter is reached. The TNC takes the dimensions of the workpiece blank diameter, the finished diameter, and the permitted stepover into account.
  5. The TNC retracts the tool on a helical path from the contour.
  6. If more than one plunging movement is required, the tool repeats the plunging movement at the point next to the departure movement.
  7. This process is repeated until the programmed stud depth is reached.
  8. At the end of the cycle, the TNC merely positions the tool in the tool axis at the clearance height defined in the cycle. This means that the end position differs from the starting position.


Please note while programming:

Pre-position the tool in the machining plane to the starting position (stud center) with radius compensation R0.

The TNC automatically pre-positions the tool in the tool axis. Note parameter Q204 (2nd set-up clearance).

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

At the end of the cycle, the TNC merely moves the tool in the tool axis back to the starting position; no positioning is performed in the machining plane.

Danger of collision!

Enter in MP7441 bit 2 whether the TNC should output an error message (bit 2=1) or not (bit 2=0) if a positive depth is entered.

Keep in mind that the TNC reverses the calculation for pre-positioning when a positive depth is entered. This means that the tool moves at rapid traverse in the tool axis to set-up clearance below the workpiece surface!

Leave enough room next to the stud for the approach motion. Minimum: Tool diameter plus 2 mm if you are working with standard approach radius and approach angle.

At the end, the TNC positions the tool back to the set-up clearance, or to the 2nd set-up clearance if one was programmed. This means that the end position of the tool after the cycle differs from the starting position.

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Finished part diameter Q223: Diameter of the completely machined stud. Input range 0 to 99999.9999

Workpiece blank diameter Q222: Diameter of the workpiece blank. Enter the workpiece blank diameter greater than the finished diameter. The TNC performs multiple stepovers if the difference between the workpiece blank diameter and finished diameter is greater than the permitted stepover (tool radius multiplied by path overlap Q370). The TNC always calculates a constant stepover. Input range 0 to 99999.9999

Finishing allowance for side Q368 (incremental): Finishing allowance in the working plane. Input range 0 to 99999.9999

Feed rate for milling Q207: Traversing speed of the tool in mm/min while milling. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Climb or up-cut Q351: Type of milling operation with M3: +1 = climb milling –1 = up-cut milling Alternatively PREDEF
Example: NC blocks
8 cycl def 257 CIRCULAR STUD
Q223=60 ;FINISHED PART DIA.
Q222=60 ;workpiece blank dia.
Q368=0.2 ;ALLOWANCE FOR SIDE
Q207=500 ;FEED RATE FOR MILLING
Q351=+1 ;CLIMB OR UP-CUT
Q201=-20 ;DEPTH
Q202=5 ;PLUNGING DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q200=2 ;SET-UP CLEARANCE
Q203=+0 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q370=1 ;TOOL PATH OVERLAP
Q376=0 ;STARTING ANGLE
9 cycl call pos x+50 y+50 Z+0 fmax m3

Depth Q201 (incremental): Distance between workpiece surface and bottom of stud. Input range ‑99999.9999 to 99999.9999

Plunging depth Q202 (incremental): Infeed per cut. Enter a value greater than 0. Input range 0 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min while moving to depth. Input range 0 to 99999.999; alternatively Fmax, FAUTO, fu, FZ

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Workpiece surface coordinate Q203 (absolute): Absolute coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Path overlap factor Q370: Q370 x tool radius = stepover factor k. Input range: 0.1 to 1.414; alternatively PREDEF

Starting angle Q376: Polar angle relative to the stud center from which the tool approaches the stud. Input range 0 to 359°


Programming examples

Further Informations:
> Example: Milling pockets, studs and slots


Example: Milling pockets, studs and slots

0 begin pgm c210 mm |
1 blk form 0.1 z x+0 y+0 z-40 | Definition of workpiece blank
2 blk form 0.2 x+100 y+100 z+0 |
3 tool def 1 l+0 r+6 | Define the tool for roughing/finishing
4 tool def 2 l+0 r+3 | Define slotting mill
5 tool call 1 z s3500 | Call the tool for roughing/finishing
6 l z+250 r0 fmax | Retract the tool
7 cycl def 256 RECTANGULAR STUD | Define cycle for machining the contour outside
Q218=90 ;1ST SIDE LENGTH |
Q424=100 ;WORKPC. BLANK SIDE 1 |
Q219=80 ;2ND SIDE LENGTH |
Q425=100 ;WORKPC. BLANK SIDE 2 |
Q220=0 ;CORNER RADIUS |
Q368=0 ;ALLOWANCE FOR SIDE |
Q224=0 ;ANGLE OF ROTATION |
Q367=0 ;STUD POSITION |
Q207=250 ;FEED RATE FOR MILLING |
Q351=+1 ;CLIMB OR UP-CUT |
Q201=-30 ;DEPTH |
Q202=5 ;PLUNGING DEPTH |
Q206=250 ;FEED RATE FOR PLNGNG |
Q200=2 ;SET-UP CLEARANCE |
Q203=+0 ;SURFACE COORDINATE |
Q204=20 ;2ND SET-UP CLEARANCE |
Q370=1 ;TOOL PATH OVERLAP |
Q437=1 ;APPROACH POSITION |
8 cycl call pos x+50 y+50 z+0 m3 | Call cycle for machining the contour outside
9 cycl def 252 CIRCULAR POCKET | Define CIRCULAR POCKET MILLING cycle
Q215=0 ;MACHINING OPERATION |
Q223=50 ;CIRCLE DIAMETER |
Q368=0.2 ;ALLOWANCE FOR SIDE |
Q207=500 ;FEED RATE FOR MILLING |
Q351=+1 ;CLIMB OR UP-CUT |
Q201=-30 ;DEPTH |
Q202=5 ;PLUNGING DEPTH |
Q369=0.1 ;ALLOWANCE FOR FLOOR |
Q206=150 ;FEED RATE FOR PLNGNG |
Q338=5 ;INFEED FOR FINISHING |
Q200=2 ;SET-UP CLEARANCE |
Q203=+0 ;SURFACE COORDINATE |
Q204=50 ;2ND SET-UP CLEARANCE |
Q370=1 ;TOOL PATH OVERLAP |
Q366=1 ;PLUNGE |
Q385=750 ;FEED RATE FOR FINISHING |
10 cycl call pos x+50 y+50 Z+0 fmax | Call CIRCULAR POCKET MILLING cycle
11 l z+250 r0 fmax m6 | Tool change
12 tool call 2 z s5000 | Call tool: slotting mill
13 cycl def 254 CIRCULAR SLOT | Define SLOT cycle
Q215=0 ;MACHINING OPERATION |
Q219=8 ;SLOT WIDTH |
Q368=0.2 ;ALLOWANCE FOR SIDE |
Q375=70 ;PITCH CIRCLE DIA. |
Q367=0 ;ref. slot position | No pre-positioning in X/Y required
Q216=+50 ;center in 1st axis |
Q217=+50 ;CENTER IN 2ND AXIS |
Q376=+45 ;starting angle |
Q248=90 ;ANGULAR LENGTH |
Q378=180 ;stepping angle | Starting point for 2nd slot
Q377=2 ;NUMBER OF OPERATIONS |
Q207=500 ;FEED RATE FOR MILLING |
Q351=+1 ;CLIMB OR UP-CUT |
Q201=-20 ;DEPTH |
Q202=5 ;PLUNGING DEPTH |
Q369=0.1 ;ALLOWANCE FOR FLOOR |
Q206=150 ;FEED RATE FOR PLNGNG |
Q338=5 ;INFEED FOR FINISHING |
Q200=2 ;SET-UP CLEARANCE |
Q203=+0 ;SURFACE COORDINATE |
Q204=50 ;2ND SET-UP CLEARANCE |
Q366=1 ;PLUNGE |
Q439=0 ;FEED RATE REFERENCE |
14 cycl call fmax m3 | Call SLOT cycle
15 l z+250 r0 fmax m2 | Retract the tool, end program
16 end pgm c210 mm |


Fixed Cycles: Pattern Definitions

Further Informations:
> Fundamentals
> POLAR PATTERN (Cycle 220, DIN/ISO: G220)
> CARTESIAN PATTERN (Cycle 221, DIN/ISO: G221)
> Programming examples


Overview

The TNC provides two cycles for machining point patterns directly:

Cycle | Soft key | Page
220 POLAR PATTERN |  | POLAR PATTERN (Cycle 220, DIN/ISO: G220)
221 CARTESIAN PATTERN |  | CARTESIAN PATTERN (Cycle 221, DIN/ISO: G221)

You can combine Cycle 220 and Cycle 221 with the following fixed cycles:

If you have to machine irregular point patterns, use CYCL CALL PAT (see Point tables) to develop point tables.

More regular point patterns are available with the PATTERN DEF function (see PATTERN DEF pattern definition).

Cycle 200 | DRILLING
Cycle 201 | REAMING
Cycle 202 | BORING
Cycle 203 | UNIVERSAL DRILLING
Cycle 204 | BACK BORING
Cycle 205 | UNIVERSAL PECKING
Cycle 206 | TAPPING NEW with a floating tap holder
Cycle 207 | RIGID TAPPING without a floating tap holder NEW
Cycle 208 | BORE MILLING
Cycle 209 | TAPPING WITH CHIP BREAKING
Cycle 240 | CENTERING
Cycle 251 | RECTANGULAR POCKET
Cycle 252 | CIRCULAR POCKET MILLING
Cycle 253 | SLOT MILLING
Cycle 254 | CIRCULAR SLOT (can only be combined with Cycle 221)
Cycle 256 | RECTANGULAR STUD
Cycle 257 | CIRCULAR STUD
Cycle 262 | THREAD MILLING
Cycle 263 | THREAD MILLING/COUNTERSINKING
Cycle 264 | THREAD DRILLING/MILLING
Cycle 265 | HELICAL THREAD DRILLING/MILLING
Cycle 267 | OUTSIDE THREAD MILLING


POLAR PATTERN (Cycle 220, DIN/ISO: G220)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC moves the tool at rapid traverse from its current position to the starting point for the first machining operation.

      2. Sequence:

    • Move to the 2nd set-up clearance (spindle axis)
    • Approach the starting point in the machining plane
    • Move to the set-up clearance above the workpiece surface (spindle axis)
  2. From this position the TNC executes the last defined fixed cycle.
  3. The tool then approaches on a straight line or circular arc the starting point for the next machining operation. The tool stops at the set-up clearance (or the 2nd set-up clearance).
  4. This process (1 to 3) is repeated until all machining operations have been executed.


Please note while programming:

Cycle 220 is DEF active, which means that Cycle 220 automatically calls the last defined fixed cycle.

If you combine Cycle 220 with one of the fixed cycles 200 to 209 and 251 to 267, the set-up clearance, workpiece surface and 2nd set-up clearance from Cycle 220 will be effective for the selected fixed cycle.


Cycle parameters

Center in 1st axis Q216 (absolute): Center of the pitch circle in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q217 (absolute): Center of the pitch circle in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Pitch circle diameter Q244: Diameter of the pitch circle. Input range 0 to 99999.9999

Starting angle Q245 (absolute): Angle between the reference axis of the working plane and the starting point for the first machining operation on the pitch circle. Input range -360.000 to 360.000

Stopping angle Q246 (absolute): Angle between the reference axis of the working plane and the starting point for the last machining operation on the pitch circle (does not apply to full circles). Do not enter the same value for the stopping angle and starting angle. If you enter the stopping angle greater than the starting angle, machining will be carried out counterclockwise; otherwise, machining will be clockwise. Input range -360.000 to 360.000

Stepping angle Q247 (incremental): Angle between two machining operations on a pitch circle. If you enter an angle step of 0, the TNC will calculate the angle step from the starting and stopping angles and the number of pattern repetitions. If you enter a value other than 0, the TNC will not take the stopping angle into account. The sign for the angle step determines the working direction (negative = clockwise). Input range -360.000 to 360.000

Number of repetitions Q241: Number of machining operations on a pitch circle. Input range 1 to 99999

Example: NC blocks
53 cycl def 220 POLAR PATTERN
Q216=+50 ;center in 1st axis
Q217=+50 ;center in 2nd axis
Q244=80 ;PITCH CIRCLE DIA.
Q245=+0 ;starting angle
Q246=+360 ;STOPPING ANGLE
Q247=+0 ;stepping angle
Q241=8 ;NUMBER OF OPERATIONS
Q200=2 ;SET-UP CLEARANCE
Q203=+30 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q301=1 ;MOVE TO CLEARANCE
Q365=0 ;TYPE OF TRAVERSE

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Move to clearance height Q301: Definition of how the tool is to move between machining processes:
0: Move to the set-up clearance between machining operations
1: Move to the 2nd set-up clearance between machining operations
Alternatively PREDEF

Type of traverse? Line=0/Arc=1 Q365: Definition of the path function with which the tool moves between machining operations:
0: Move in a straight line between machining operations
1: Move in a circular arc on the pitch circle diameter between machining operations


CARTESIAN PATTERN (Cycle 221, DIN/ISO: G221)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC automatically moves the tool from its current position to the starting point for the first machining operation.

      2. Sequence:

    • Move to the 2nd set-up clearance (spindle axis)
    • Approach the starting point in the machining plane
    • Move to the set-up clearance above the workpiece surface (spindle axis)
  2. From this position the TNC executes the last defined fixed cycle.
  3. The tool then approaches the starting point for the next machining operation in the positive reference axis direction at the set-up clearance (or the 2nd set-up clearance).
  4. This process (1 to 3) is repeated until all machining operations on the first line have been executed. The tool is located above the last point on the first line.
  5. The tool subsequently moves to the last point on the second line where it executes the machining operation.
  6. From this position the tool approaches the starting point for the next machining operation in the negative reference axis direction.
  7. This process (6) is repeated until all machining operations in the second line have been executed.
  8. The tool then moves to the starting point of the next line.
  9. All subsequent lines are machined in a reciprocating movement.


Please note while programming:

Cycle 221 is DEF active, which means that Cycle 221 automatically calls the last defined fixed cycle.

If you combine Cycle 221 with one of the fixed cycles 200 to 209 and 251 to 267, the set-up clearance, workpiece surface, 2nd set-up clearance and rotational position that you defined in Cycle 221 will be effective for the selected fixed cycle.

The slot position 0 is not allowed if you use Cycle 254 Circular Slot in combination with Cycle 221.


Cycle parameters

Example: NC blocks
54 cycl def 221 CARTESIAN PATTERN
Q225=+15 ;STARTING POINT 1ST AXIS
Q226=+15 ;STARTING POINT 2ND AXIS
Q237=+10 ;SPACING IN 1ST AXIS
Q238=+8 ;SPACING IN 2ND AXIS
Q242=6 ;NUMBER OF COLUMNS
Q243=4 ;NUMBER OF LINES
Q224=+15 ;ANGLE OF ROTATION
Q200=2 ;SET-UP CLEARANCE
Q203=+30 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q301=1 ;MOVE TO CLEARANCE

Starting point 1st axis Q225 (absolute): Coordinate of the starting point in the reference axis of the working plane

Starting point 2nd axis Q226 (absolute): Coordinate of the starting point in the minor axis of the working plane

Spacing in 1st axis Q237 (incremental): Spacing between each point on a line

Spacing in 2nd axis Q238 (incremental): Spacing between each line

Number of columns Q242: Number of machining operations on a line

Number of lines Q243: Number of lines

Rotational position Q224 (absolute): Angle by which the entire pattern is rotated. The center of rotation lies in the starting point

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface; alternatively predef

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur; alternatively PREDEF

Move to clearance height Q301: Definition of how the tool is to move between machining processes:
0: Move to the set-up clearance between machining operations
1: Move to the 2nd set-up clearance between machining operations
Alternatively PREDEF


Programming examples

Further Informations:
> Example: Polar hole patterns


Example: Polar hole patterns

0 BEGIN PGM PATTERN MM |
1 blk form 0.1 z x+0 y+0 z-40 | Definition of workpiece blank
2 blk form 0.2 x+100 y+100 z+0 |
3 tool def 1 l+0 r+3 | Tool definition
4 tool call 1 z s3500 | Tool call
5 l z+250 r0 fmax m3 | Retract the tool
6 cycl def 200 DRILLING | Cycle definition: drilling
Q200=2 ;SET-UP CLEARANCE |
Q201=-15 ;DEPTH |
Q206=250 ;FEED RATE FOR PLNGNG |
Q202=4 ;PLUNGING DEPTH |
Q210=0 ;DWELL TIME |
Q203=+0 ;SURFACE COORDINATE |
Q204=0 ;2ND SET-UP CLEARANCE |
Q211=0.25 ;DWELL TIME AT DEPTH |
Q395=0.25 ;DEPTH REFERENCE |
7 cycl def 220 POLAR PATTERN | Define cycle for polar pattern 1, CYCL 200 is called automatically; Q200, Q203 and Q204 are effective as defined in Cycle 220.
Q216=+30 ;center in 1st axis |
Q217=+70 ;CENTER IN 2ND AXIS |
Q244=50 ;PITCH CIRCLE DIA. |
Q245=+0 ;starting angle |
Q246=+360 ;STOPPING ANGLE |
Q247=+0 ;stepping angle |
Q241=10 ;Number of repetitions |
Q200=2 ;SET-UP CLEARANCE |
Q203=+0 ;SURFACE COORDINATE |
Q204=100 ;2ND SET-UP CLEARANCE |
Q301=1 ;MOVE TO CLEARANCE |
Q365=0 ;TYPE OF TRAVERSE |
8 cycl def 220 POLAR PATTERN | Define cycle for polar pattern 2, CYCL 200 is called automatically; Q200, Q203 and Q204 are effective as defined in Cycle 220.
Q216=+90 ;center in 1st axis |
Q217=+25 ;CENTER IN 2ND AXIS |
Q244=70 ;PITCH CIRCLE DIA. |
Q245=+90 ;starting angle |
Q246=+360 ;STOPPING ANGLE |
Q247=30 ;stepping angle |
Q241=5 ;Number of repetitions |
Q200=2 ;SET-UP CLEARANCE |
Q203=+0 ;SURFACE COORDINATE |
Q204=100 ;2ND SET-UP CLEARANCE |
Q301=1 ;MOVE TO CLEARANCE |
Q365=0 ;TYPE OF TRAVERSE |
9 l z+250 r0 fmax m2 | Retract the tool, end program
10 end pgm pattern mm |


Fixed Cycles: Contour Pocket, Contour Trains

Further Informations:
> SL cycles
> CONTOUR GEOMETRY (Cycle 14, DIN/ISO: G37)
> Overlapping contours
> CONTOUR DATA (Cycle 20, DIN/ISO: G120)
> PILOT DRILLING (Cycle 21, DIN/ISO: G121)
> ROUGH-OUT (Cycle 22, DIN/ISO: G122)
> FLOOR FINISHING (Cycle 23, DIN/ISO: G123)
> SIDE FINISHING (Cycle 24, DIN/ISO: G124)
> CONTOUR TRAIN DATA (Cycle 270, DIN/ISO: G270)
> CONTOUR TRAIN (Cycle 25, DIN/ISO: G125)
> TROCHOIDAL SLOT (Cycle 275, DIN/ISO: G275)
> THREE-D CONTOUR TRAIN (Cycle 276, DIN/ISO: G276)
> Programming examples


SL cycles

Further Informations:
> Fundamentals
> Overview


Fundamentals

Example: Program structure: Machining with SL cycles
0 begin pgm sl2 mm
...
12 cycl def 14 contour geometry ...
13 cycl def 20 contour data ...
...
16 cycl def 21 pilot drilling ...
17 cycl call
...
18 cycl def 22 rough-out ...
19 cycl call
...
22 cycl def 23 floor finishing ...
23 cycl call
...
26 cycl def 24 side finishing ...
27 cycl call
...
50 l z+250 r0 fmax m2
51 lbl 1
...
55 lbl 0
56 lbl 2
...
60 lbl 0
...
99 end pgm sl2 mm

SL cycles enable you to form complex contours by combining up to 12 subcontours (pockets or islands). You define the individual subcontours in subprograms. The TNC calculates the total contour from the subcontours (subprogram numbers) that you enter in Cycle 14 CONTOUR GEOMETRY.

The memory capacity for programming an SL cycle (all contour subprograms) is limited. The number of possible contour elements depends on the type of contour (inside or outside contour) and the number of subcontours. You can program up to 8192 contour elements.

SL cycles conduct comprehensive and complex internal calculations as well as the resulting machining operations. For safety reasons, always run a graphical program test before machining! This is a simple way of finding out whether the TNC-calculated program will provide the desired results.

    Characteristics of the subprograms

  • Coordinate transformations are allowed. If they are programmed within the subcontour they are also effective in the following subprograms, but they need not be reset after the cycle call.
  • The TNC ignores feed rates F and miscellaneous functions M.
  • The TNC recognizes a pocket if the tool path lies inside the contour, for example if you machine the contour clockwise with radius compensation RR.
  • The TNC recognizes an island if the tool path lies outside the contour, for example if you machine the contour clockwise with radius compensation RL.
  • The subprograms must not contain spindle axis coordinates.
  • The working plane is defined in the first coordinate block of the subprogram. The secondary axes U,V,W are permitted in useful combinations. Always define both axes of the machining plane in the first block.
  • If you use Q parameters, then only perform the calculations and assignments within the affected contour subprograms.
  • If an open contour is defined in the subprogram, the TNC uses a straight line from the end point to the starting point to close the contour.

    Characteristics of the fixed cycles

  • The TNC automatically positions the tool to the set-up clearance before a cycle.
  • Each level of infeed depth is milled without interruptions since the cutter traverses around islands instead of over them.
  • In order to avoid leaving dwell marks, the TNC inserts a globally definable rounding radius at non-tangential inside corners. The rounding radius, which is entered in Cycle 20, affects the tool center point path, meaning that it would increase a rounding defined by the tool radius (applies to rough-out and side finishing).
  • The contour is approached in a tangential arc for side finishing.
  • For floor finishing, the tool again approaches the workpiece on a tangential arc (for tool axis Z, for example, the arc is in the Z/X plane).
  • The contour is machined throughout in either climb or up-cut milling.

With bit 4 in MP7420 you can determine where the tool is positioned at the end of Cycles 21 to 24.

  • bit 4 = 0:
    At the end of the cycle, the TNC at first positions the tool in the tool axis at the clearance height (Q7) defined in the cycle, and then to the position in the working plane at which the tool was located when the cycle was called.
  • Bit 4 = 1:
    At the end of the cycle, the TNC always positions the tool in the tool axis at the clearance height (Q7) defined in the cycle. Ensure that no collisions can occur during the following positioning movements!

The machining data (such as milling depth, finishing allowance and set-up clearance) are entered as CONTOUR DATA in Cycle 20.


Overview

Cycle | Soft key | Page
14 CONTOUR GEOMETRY (essential) |  | CONTOUR GEOMETRY (Cycle 14, DIN/ISO: G37)
20 CONTOUR DATA (essential) |  | CONTOUR DATA (Cycle 20, DIN/ISO: G120)
21 PILOT DRILLING (optional) |  | PILOT DRILLING (Cycle 21, DIN/ISO: G121)
22 ROUGH-OUT (essential) |  | ROUGH-OUT (Cycle 22, DIN/ISO: G122)
23 FLOOR FINISHING (optional) |  | FLOOR FINISHING (Cycle 23, DIN/ISO: G123)
24 SIDE FINISHING (optional) |  | SIDE FINISHING (Cycle 24, DIN/ISO: G124)

Enhanced cycles:

Cycle | Soft key | Page
270 CONTOUR TRAIN DATA |  | CONTOUR TRAIN DATA (Cycle 270, DIN/ISO: G270)
25 CONTOUR TRAIN |  | CONTOUR TRAIN (Cycle 25, DIN/ISO: G125)
275 TROCHOIDAL SLOT |  | SLOT MILLING (Cycle 253, DIN/ISO: G253)
276 THREE-D CONT. TRAIN |  | THREE-D CONTOUR TRAIN (Cycle 276, DIN/ISO: G276)


CONTOUR GEOMETRY (Cycle 14, DIN/ISO: G37)

Further Informations:
> Please note while programming:
> Cycle parameters


Please note while programming:

All subprograms that are superimposed to define the contour are listed in Cycle 14 CONTOUR GEOMETRY.

Before programming, note the following

Cycle 14 is DEF active which means that it becomes effective as soon as it is defined in the part program.

You can list up to 12 subprograms (subcontours) in Cycle 14.


Cycle parameters

Label numbers for the contour: Enter all label numbers for the individual subprograms that are to be superimposed to define the contour. Confirm every label number with the ENT key. When you have entered all numbers, conclude entry with the END key. Entry of up to 12 subprogram numbers 1 to 254.


Overlapping contours

Further Informations:
> Fundamentals
> Subprograms: overlapping pockets
> Area of inclusion
> Area of exclusion
> Area of intersection


Fundamentals

Example: NC blocks
12 cycl def 14.0 contour geometry
13 cycl def 14.1 contour label 1/2/3/4

Pockets and islands can be overlapped to form a new contour. You can thus enlarge the area of a pocket by another pocket or reduce it by an island.


Subprograms: overlapping pockets

The subsequent programming examples are contour subprograms that are called by Cycle 14 CONTOUR GEOMETRY in a main program.

Pockets A and B overlap.

The TNC calculates the points of intersection S1 and S2. They do not have to be programmed.

The pockets are programmed as full circles.

Subprogram 1: Pocket A
51 lbl 1
52 l x+10 y+50 rr
53 cc x+35 y+50
54 c x+10 y+50 dr-
55 lbl 0
Subprogram 2: Pocket B
56 lbl 2
57 l x+90 y+50 rr
58 cc x+65 y+50
59 c x+90 y+50 dr-
60 lbl 0


Area of inclusion

    Both surfaces A and B are to be machined, including the overlapping area:

  • The surfaces A and B must be pockets.
  • The first pocket (in Cycle 14) must start outside the second pocket.
Surface A:
51 lbl 1
52 l x+10 y+50 rr
53 cc x+35 y+50
54 c x+10 y+50 dr-
55 lbl 0
Surface B:
56 lbl 2
57 l x+90 y+50 rr
58 cc x+65 y+50
59 c x+90 y+50 dr-
60 lbl 0


Area of exclusion

    Surface A is to be machined without the portion overlapped by B:

  • Surface A must be a pocket and B an island.
  • A must start outside of B.
  • B must start inside of A.
Surface A:
51 lbl 1
52 l x+10 y+50 rr
53 cc x+35 y+50
54 c x+10 y+50 dr-
55 lbl 0
Surface B:
56 lbl 2
57 l x+40 y+50 rl
58 cc x+65 y+50
59 c x+40 y+50 dr-
60 lbl 0


Area of intersection

    Only the area where A and B overlap is to be machined. (The areas covered by A or B alone are to be left unmachined.)

  • A and B must be pockets.
  • A must start inside of B.
Surface A:
51 lbl 1
52 l x+60 y+50 rr
53 cc x+35 y+50
54 c x+60 y+50 dr-
55 lbl 0
Surface B:
56 lbl 2
57 l x+90 y+50 rr
58 cc x+65 y+50
59 c x+90 y+50 dr-
60 lbl 0


CONTOUR DATA (Cycle 20, DIN/ISO: G120)

Further Informations:
> Please note while programming:
> Cycle parameters


Please note while programming:

Machining data for the subprograms describing the subcontours are entered in Cycle 20.

Cycle 20 is DEF active, which means that it becomes effective as soon as it is defined in the part program.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH = 0, the TNC performs the cycle at the depth 0.

The machining data entered in Cycle 20 are valid for Cycles 21 to 24.

If you are using the SL cycles in Q parameter programs, the cycle parameters Q1 to Q20 cannot be used as program parameters.


Cycle parameters

Example: NC blocks
57 cycl def 20 contour data
Q1=-20 ;MILLING DEPTH
Q2=1 ;TOOL PATH OVERLAP
Q3=+0.2 ;ALLOWANCE FOR SIDE
Q4=+0.1 ;ALLOWANCE FOR FLOOR
Q5=+30 ;SURFACE COORDINATE
Q6=2 ;SET-UP CLEARANCE
Q7=+80 ;CLEARANCE HEIGHT
Q8=0.5 ;ROUNDING RADIUS
Q9=+1 ;DIRECTION OF ROTATION

Milling depth Q1 (incremental): Distance between workpiece surface and bottom of pocket. Input range ‑99999.9999 to 99999.9999

Path overlap factor Q2: Q2 x tool radius = stepover factor k. Input range ‑0.0001 to 1.9999

Finishing allowance for side Q3 (incremental): Finishing allowance in the working plane. Input range ‑99999.9999 to 99999.9999

Finishing allowance for floor Q4 (incremental): Finishing allowance in the tool axis. Input range ‑99999.9999 to 99999.9999

Workpiece surface coordinate Q5 (absolute): Absolute coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q6 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q7 (absolute): Absolute height at which the tool cannot collide with the workpiece (for intermediate positioning and retraction at the end of the cycle). Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Inside corner radius Q8: Inside "corner" rounding radius; entered value is referenced to the path of the tool center and is used to calculate smoother traverse motions between the contour elements. Q8 is not a radius that is inserted as a separate contour element between programmed elements! Input range 0 to 99999.9999

Direction of rotation? Q9: Machining direction for pockets

  • Q9 = –1 up-cut milling for pocket and island
  • Q9 = +1 climb milling for pocket and island
  • Alternative: PREDEF

You can check the machining parameters during a program interruption and overwrite them if required.


PILOT DRILLING (Cycle 21, DIN/ISO: G121)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The tool drills from the current position to the first plunging depth at the programmed feed rate F.
  2. Then the tool retracts at rapid traverse FMAX to the starting position and advances again to the first plunging depth minus the advanced stop distance t.
  3. The advanced stop distance is automatically calculated by the control:
    • At a total hole depth up to 30 mm: t = 0.6 mm
    • At a total hole depth exceeding 30 mm: t = hole depth / 50
    • Maximum advanced stop distance: 7 mm
  4. The tool then advances with another infeed at the programmed feed rate F.
  5. The TNC repeats this process (1 to 4) until the programmed depth is reached.
  6. After a dwell time at the hole bottom, the tool is returned to the starting position at rapid traverse FMAX for chip breaking.

Application

Cycle 21 is for PILOT DRILLING of the cutter infeed points. It accounts for the allowance for side and the allowance for floor as well as the radius of the rough-out tool. The cutter infeed points also serve as starting points for roughing.


Please note while programming:

Before programming, note the following

When calculating the infeed points, the TNC does not account for the delta value DR programmed in a TOOL CALL block.

In narrow areas, the TNC may not be able to carry out pilot drilling with a tool that is larger than the rough-out tool.

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
58 cycl def 21 pilot drilling
Q10=+5 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q13=1 ;ROUGH-OUT TOOL

Plunging depth Q10 (incremental): Dimension by which the tool drills in each infeed (negative sign for negative working direction). Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool in mm/min during drilling. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Rough-out tool number/name Q13 or QS13: Number or name of rough-out tool. Input range 0 to 32767.9 if a number is entered; maximum 32 characters if a name is entered.


ROUGH-OUT (Cycle 22, DIN/ISO: G122)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The TNC positions the tool over the cutter infeed point, taking the allowance for side into account.
  2. In the first plunging depth, the tool mills the contour from the inside outward at the milling feed rate Q12.
  3. The island contours (here: C/D) are cleared out with an approach toward the pocket contour (here: A/B).
  4. In the next step the TNC moves the tool to the next plunging depth and repeats the roughing procedure until the programmed depth is reached.
  5. Finally the TNC retracts the tool to the clearance height.


Please note while programming:

This cycle requires a center-cut end mill (ISO 1641) or pilot drilling with Cycle 21.

    You define the plunging behavior of Cycle 22 with parameter Q19 and with the tool table in the ANGLE and LCUTS columns:

  • If Q19=0 is defined, the TNC always plunges perpendicularly, even if a plunge angle (ANGLE) is defined for the active tool.
  • If you define the ANGLE=90°, the TNC plunges perpendicularly. The reciprocation feed rate Q19 is used as plunging feed rate.
  • If the reciprocation feed rate Q19 is defined in Cycle 22 and ANGLE is defined between 0.1 and 89.999 in the tool table, the TNC plunges helically at the defined ANGLE.
  • If the reciprocation feed rate is defined in Cycle 22 and no ANGLE is in the tool table, the TNC displays an error message.
  • If geometrical conditions do not allow helical plunging (slot geometry), the TNC tries a reciprocating plunge. The reciprocation length is calculated from LCUTS and ANGLE (reciprocation length = LCUTS / tan ANGLE).

If you clear out an acute inside corner and use an overlap factor greater than 1, some material might be left over. Check especially the innermost path in the test run graphic and, if necessary, change the overlap factor slightly. This allows another distribution of cuts, which often provides the desired results.

During fine roughing the TNC does not take a defined wear value DR of the coarse roughing tool into account.

Feed rate reduction through parameter Q401 is an FCL3 function and is not automatically available after a software update (see Feature content level (upgrade functions)).

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
59 cycl def 22 rough-out
Q10=+5 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q12=750 ;FEED RATE FOR ROUGHING
Q18=1 ;COARSE ROUGHING TOOL
Q19=150 ;RECIPROCATION FEED RATE
Q208=99999 ;RETRACTION FEED RATE
Q401=80 ;FEED RATE REDUCTION
Q404=0 ;FINE ROUGH STRATEGY

Plunging depth Q10 (incremental): Infeed per cut. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool in mm/min during plunging. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for roughing Q12: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Coarse roughing tool Q18 or QS18: Number or name of the tool with which the TNC has already coarse-roughed the contour. Press the tool name soft key to switch to name input. The TNC automatically inserts the closing quotation mark when you exit the input field. If there was no coarse roughing, enter "0"; if you enter a number or a name, the TNC will only rough-out the portion that could not be machined with the coarse roughing tool. If the portion that is to be roughed cannot be approached from the side, the TNC will mill in a reciprocating plunge-cut; for this purpose you must enter the tool length LCUTS in the tool table TOOL.T and define the maximum plunging ANGLE of the tool. Otherwise, the TNC will display an error message. Input range 0 to 32767.9 if a number is entered; maximum 32 characters if a name is entered.

Reciprocation feed rate Q19: Traversing speed of the tool in mm/min during reciprocating plunge-cut. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for retraction Q208: Traversing speed of the tool in mm/min when retracting after the machining operation. If you enter Q208 = 0, the TNC retracts the tool at the feed rate Q12. Input range 0 to 99999.9999; alternatively Fmax, FAUTO, PREDEF

Feed rate factor in % Q401: Percentage factor by which the TNC reduces the machining feed rate (Q12) as soon as the tool moves within the material over its entire circumference during roughing. If you use the feed rate reduction, then you can define the feed rate for roughing so large that there are optimum cutting conditions with the path overlap (Q2) specified in Cycle 20. The TNC then reduces the feed rate as per your definition at transitions and narrow places, so the machining time should be reduced in total. Input range 0.0001 to 100.0000

Fine-roughing strategy Q404: Specify how the TNC should move the tool during fine roughing when the radius of the fine-roughing tool is larger than half the coarse roughing tool.

  • Q404 = 0
    Between areas that need to be fine-roughed, move the tool along the contour at the current depth
  • Q404 = 1
    Between areas that need to be fine-roughed, retract the tool to set-up clearance and move to the starting point of the next area to be roughed out


FLOOR FINISHING (Cycle 23, DIN/ISO: G123)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

The tool approaches the machining plane smoothly (on a vertically tangential arc) if there is sufficient room. If there is not enough room, the TNC moves the tool to depth vertically. The tool then clears the finishing allowance remaining from rough-out.


Please note while programming:

The TNC automatically calculates the starting point for finishing. The starting point depends on the available space in the pocket.

The approaching radius for pre-positioning to the final depth is permanently defined and independent of the plunging angle of the tool.

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
60 cycl def 23 floor finishing
Q11=100 ;FEED RATE FOR PLNGNG
Q12=350 ;FEED RATE FOR ROUGHING
Q208=99999 ;RETRACTION FEED RATE

Feed rate for plunging Q11: Traversing speed of the tool during plunging. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for roughing Q12: Milling feed rate. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for retraction Q208: Traversing speed of the tool in mm/min when retracting after the machining operation. If you enter Q208 = 0, the TNC retracts the tool at the feed rate Q12. Input range 0 to 99999.9999; alternatively Fmax, FAUTO, PREDEF


SIDE FINISHING (Cycle 24, DIN/ISO: G124)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

The individual subcontours are approached and departed on a tangential arc. The TNC finishes each subcontour separately.


Please note while programming:

The sum of allowance for side (Q14) and the radius of the finish mill must be smaller than the sum of allowance for side (Q3, Cycle 20) and the radius of the rough mill.

This calculation also holds if you run Cycle 24 without having roughed out with Cycle 22; in this case, enter "0" for the radius of the rough mill.

You can use Cycle 24 also for contour milling. Then you must:

  • define the contour to be milled as a single island (without pocket limit), and
  • enter the finishing allowance (Q3) in Cycle 20 to be greater than the sum of the finishing allowance Q14 + radius of the tool being used.

The TNC automatically calculates the starting point for finishing. The starting point depends on the available space in the pocket and the allowance programmed in Cycle 20. The TNC executes the positioning logic to the starting point of the finishing operation as follows: approach the starting point in the working plane, then move to depth in tool axis direction.

The starting point calculated by the TNC also depends on the machining sequence. If you select the finishing cycle with the GOTO key and then start the program, the starting point can be at a different location from where it would be if you execute the program in the defined sequence.

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
61 cycl def 24 side finishing
Q9=+1 ;DIRECTION OF ROTATION
Q10=+5 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q12=350 ;FEED RATE FOR ROUGHING
Q14=+0 ;ALLOWANCE FOR SIDE
Q438=+0 ;ROUGH-OUT TOOL

Direction of rotation? Clockwise = –1 Q9:
Machining direction:
+1: Counterclockwise
–1: Clockwise
Alternatively PREDEF

Plunging depth Q10 (incremental): Infeed per cut. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool during plunging. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for roughing Q12: Milling feed rate. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Finishing allowance for side Q14 (incremental): Enter the allowed material for several finish-milling operations. If you enter Q14 = 0, the remaining finishing allowance will be cleared. Input range ‑99999.9999 to 99999.9999

Rough-out tool Q438 or QS438: Number or name of the tool with which the TNC roughed out the contour pocket. Press the tool name soft key to switch to name input. The TNC automatically inserts the closing quotation mark when you exit the input field. The starting point of the circular arc on which the tool approaches the finishing path is on the outermost roughing path from Cycle 22. The TNC calculates the starting point from the sum of the rough-out tool radius and the finishing allowance for side Q3 defined in Cycle 20. If you enter Q438=0 (rough-out tool is zero tool), you can use the finishing allowance for side Q3 from Cycle 20 to define the distance of the starting point from the contour. Input range -32767.9 to +32767.9 if a number is entered; maximum 32 characters if a name is entered.


CONTOUR TRAIN DATA (Cycle 270, DIN/ISO: G270)

Further Informations:
> Please note while programming:
> Cycle parameters


Please note while programming:

If desired, you can use this cycle to specify various properties of Cycle 25, Contour Train and Cycle 276, 3-D Contour Train.

Before programming, note the following

Cycle 270 is DEF active, which means that it becomes effective as soon as it is defined in the part program.

The TNC resets Cycle 270 as soon as you define another SL cycle (with the exception of Cycle 25 and Cycle 276).

If Cycle 270 is used, do not define any radius compensation in the contour subprogram.

Approach and departure properties are always performed identically (symmetrically) by the TNC.

Define Cycle 270 before Cycle 25 or Cycle 276.


Cycle parameters

Example: NC blocks
62 cycl def 270 contour train data
Q390=1 ;type of approach
Q391=1 ;radius compensation
Q392=3 ;RADIUS
Q393=+45 ;center angle
Q394=+2 ;distance

Type of approach/departure Q390: Definition of the type of approach or departure.

  • Q390 = 1:
    Approach the contour tangentially on a circular arc.
  • Q390 = 2:
    Approach the contour tangentially on a straight line.
  • Q390 = 3:
    Approach the contour at a right angle.

Radius compensation (0=R0/1=RL/2=RR) Q391: Definition of the radius compensation:

  • Q391 = 0:
    Machine the defined contour without radius compensation.
  • Q391 = 1:
    Machine the defined contour with compensation to the left.
  • Q391 = 2:
    Machine the defined contour with compensation to the right.

Approach/departure radius Q392: Only in effect if tangential approach on a circular path was selected. Radius of the approach/departure arc. Input range 0 to 99999.9999

Center angle Q393: Only in effect if tangential approach on a circular path was selected. Angular length of the approach arc. Input range 0 to 99999.9999

Distance to auxiliary point Q394: Only in effect if tangential approach on a straight line or right-angle approach was selected. Distance to the auxiliary point from which the TNC is to approach the contour. Input range 0 to 99999.9999


CONTOUR TRAIN (Cycle 25, DIN/ISO: G125)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

In conjunction with Cycle 14 CONTOUR GEOMETRY, this cycle facilitates the machining of open and closed contours.

    Cycle 25 CONTOUR TRAIN offers considerable advantages over machining a contour using positioning blocks:

  • The TNC monitors the operation to prevent undercuts and surface blemishes. It is recommended that you run a graphic simulation of the contour before execution.
  • If the radius of the selected tool is too large, the inside corners of the contour can be reworked using the feature for automatic identification of residual material.
  • The contour can be machined throughout by up-cut or by climb milling. The type of milling even remains effective when contours are mirrored in one axis.
  • The tool can traverse back and forth for milling in several infeeds (reciprocating plunge-cut): This results in faster machining.
  • Allowance values can be entered in order to perform repeated rough-milling and finish-milling operations.
  • Cycle 270 CONTOUR TRAIN DATA provides an easy way to define the behavior of Cycle 25.


Please note while programming:

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

When using Cycle 25 CONTOUR TRAIN, you can define only one contour subprogram in Cycle 14 CONTOUR GEOMETRY.

The memory capacity for programming an SL cycle is limited. You can program up to 4090 contour elements in one SL cycle.

The TNC does not need Cycle 20 CONTOUR DATA in conjunction with Cycle 25.

Do not use any approach or departure blocks APPR/DEP in the contour subprogram.

Do not perform Q parameter calculations in the contour subprogram.

Use the CONTOUR TRAIN DATA cycle to define the machining behavior of Cycle 25 (see CONTOUR TRAIN DATA (Cycle 270, DIN/ISO: G270)).

Danger of collision!

To avoid collisions,

  • Do not program positions in incremental dimensions immediately after Cycle 25 since they are referenced to the position of the tool at the end of the cycle.
  • Move the tool to defined (absolute) positions in all principal axes, since the position of the tool at the end of the cycle is not identical to the position of the tool at the start of the cycle.
  • If you program APPR and DEP blocks for contour approach and departure, the TNC monitors whether the execution of these blocks would damage the contour.

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
62 cycl def 25 contour train
Q1=-20 ;MILLING DEPTH
Q3=+0 ;ALLOWANCE FOR SIDE
Q5=+0 ;SURFACE COORDINATE
Q7=+50 ;CLEARANCE HEIGHT
Q10=+5 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q12=350 ;FEED RATE FOR MILLING
Q15=-1 ;CLIMB OR UP-CUT
Q18=0 ;COARSE ROUGHING TOOL
Q446=0.01 ;RESIDUAL MATERIAL
Q447=10 ;CONNECTION DISTANCE
Q448=2 ;PATH EXTENSION

Milling depth Q1 (incremental): Distance between workpiece surface and contour floor. Input range ‑99999.9999 to 99999.9999

Finishing allowance for side Q3 (incremental): Finishing allowance in the working plane. Input range ‑99999.9999 to 99999.9999

Workpiece surface coordinate Q5 (absolute): Absolute coordinate of the workpiece surface referenced to the workpiece datum. Input range ‑99999.9999 to 99999.9999

Clearance height Q7 (absolute): Absolute height at which the tool cannot collide with the workpiece. Position for tool retraction at the end of the cycle. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Plunging depth Q10 (incremental): Infeed per cut. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool in the spindle axis. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for milling Q12: Traversing speed of the tool in the working plane. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Climb/Up-cut? Up-cut = –1 Q15: Climb milling: Input value = +1 Up-cut milling: Input value = –1 To enable climb milling and up-cut milling alternately in several infeeds: Input value = 0

Coarse roughing tool Q18 or QS18: Number or name of the tool with which the TNC has already coarse-roughed the contour. Press the tool name soft key to switch to name input. The TNC automatically inserts the closing quotation mark when you exit the input field. If there was no coarse roughing, enter "0"; the TNC will then machine the contour to the maximum extent that is possible with the active tool. If you enter a number or a name, the TNC will only machine the portion that could not be machined with the coarse roughing tool. Input range 0 to 32767.9 if a number is entered; maximum 32 characters if a name is entered.

Accepted residual material Q446: Thickness of the residual material that is to be left unmachined by the TNC. Default value: 0.01 mm Input range 0 to +9.999

Maximum connection distance Q447: Maximum distance between two areas to be fine-roughed, between which the tool is to move at the machining depth along the contour without a lift-off motion. Input range 0 to 999

Path extension Q448: Length by which the tool path is extended at the start and end of the contour. The TNC always extends the tool path in parallel to the contour. The approach and departure behavior for fine-roughing must be defined in Cycle 270. Input range 0 to 99.999


TROCHOIDAL SLOT (Cycle 275, DIN/ISO: G275)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Example: TROCHOIDAL SLOT scheme
0 begin pgm CYC275 mm
...
12 cycl def 14.0 contour geometry
13 cycl def 14.1 contour label 10
14 cycl def 275 TROCHOIDAL SLOT ...
15 cycl call M3
...
50 l z+250 r0 fmax m2
51 lbl 10
...
55 lbl 0
...
99 end pgm CYC275 mm

In conjunction with Cycle 14 CONTOUR GEOMETRY, this cycle facilitates the complete machining of open slots or contour slots using trochoidal milling.

With trochoidal milling, large cutting depths and high cutting speeds are possible because the equally distributed cutting conditions prevent wear-increasing influences on the tool. When tool inserts are used the entire cutting length is exploited to increase the attainable chip volume per tooth. Moreover, trochoidal milling is easy on the machine mechanics. Enormous amounts of time can also be saved by combining this milling method with the integrated adaptive feed control AFC software option (see User's Manual on conversational programming).

    Depending on the cycle parameters you select, the following machining alternatives are available:

  • Complete machining: Roughing, side finishingOnly roughingOnly side finishing
  1. Roughing The contour description of an open slot must always start with an approach block (APPR).
  2. Following the positioning logic, the tool moves to the starting point of the machining operation as defined by the parameters in the APPR block, and positions there perpendicular to the first plunging depth.
  3. The TNC roughs the slot in circular motions to the contour end point. During the circular motion the TNC moves the tool in machining direction by an infeed you can define (Q436). Define climb or up-cut of the circular motion in parameter Q351.
  4. At the contour end point, the TNC moves the tool to clearance height and returns to the starting point of the contour description.
  5. This process is repeated until the programmed slot depth is reached.
  1. Finishing
  5. Inasmuch as a finishing allowance is defined, the TNC finishes the slot walls, in multiple infeeds if so specified. Starting from the defined starting point of the APPR block, the TNC approaches the slot wall. Climb or up-cut are taken into consideration.


Please note while programming:

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

When using Cycle 275 TROCHOIDAL SLOT, you can define only one contour program in Cycle 14 CONTOUR GEOMETRY.

Define the center line of the slot with all available path functions in the contour subprogram.

The memory capacity for programming an SL cycle is limited. You can program up to 4090 contour elements in one SL cycle.

The TNC does not need Cycle 20 CONTOUR DATA in conjunction with Cycle 275.

Cycle 275 cannot be used for machining a closed contour.

Danger of collision!

To avoid collisions,

  • Do not program positions in incremental dimensions immediately after Cycle 275 since they are referenced to the position of the tool at the end of the cycle.
  • Move the tool to defined (absolute) positions in all principal axes, since the position of the tool at the end of the cycle is not identical to the position of the tool at the start of the cycle.

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Machining operation (0/1/2) Q215: Define the machining operation:
0: Roughing and finishing
1: Only roughing
2: Only finishing
The TNC also executes side finishing if the finishing allowance (Q368) defined is 0.

Slot width Q219: Enter the slot width; if you enter a slot width that equals the tool diameter, the TNC will only machine the contour outline. Input range 0 to 99999.9999

Finishing allowance for side Q368 (incremental): Finishing allowance in the working plane.

Infeed per rev. Q436 (absolute): Value by which the TNC moves the tool in the machining direction per revolution. Input range 0 to 99999.9999

Feed rate for milling Q207: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Climb or up-cut Q351: Type of milling operation with M3: +1 = climb milling –1 = up-cut milling Alternatively PREDEF

Depth Q201 (incremental): Distance between workpiece surface and bottom of slot. Input range ‑99999.9999 to 99999.9999

Plunging depth Q202 (incremental): Infeed per cut. Enter a value greater than 0. Input range 0 to 99999.9999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min while moving to depth. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ

Infeed for finishing Q338 (incremental): Infeed per cut. Q338=0: Finishing in one infeed. Input range 0 to 99999.9999

Feed rate for finishing Q385: Traversing speed of the tool in mm/min during side finishing. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ
Example: NC blocks
8 cycl def 275 TROCHOIDAL SLOT
Q215=0 ;MACHINING OPERATION
Q219=12 ;SLOT WIDTH
Q368=0.2 ;ALLOWANCE FOR SIDE
Q436=2 ;infeed per revolution
Q207=500 ;FEED RATE FOR MILLING
Q351=+1 ;CLIMB OR UP-CUT
Q201=-20 ;DEPTH
Q202=5 ;PLUNGING DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q338=5 ;INFEED FOR FINISHING
Q385=500 ;FEED RATE FOR FINISHING
Q200=2 ;SET-UP CLEARANCE
Q203=+0 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE
Q366=2 ;PLUNGE
9 cycl call fmax m3

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Workpiece surface coordinate Q203 (absolute): Absolute coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF

Plunging strategy Q366: Type of plunging strategy:

  • 0 = Vertical plunging. The TNC plunges perpendicularly, regardless of the plunging angle ANGLE defined in the tool table.
  • 1: No function
  • 2 = Reciprocating plunge. In the tool table, the plunging angle ANGLE for the active tool must be defined as not equal to 0. The TNC will otherwise display an error message.
  • Alternative: PREDEF


THREE-D CONTOUR TRAIN (Cycle 276, DIN/ISO: G276)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

In conjunction with Cycle 14 CONTOUR GEOMETRY, this cycle facilitates the machining of open and closed contours. Using the function for automatic identification of residual material, you can rework the inside corners of the contour, if required.

Unlike Cycle 25 CONTOUR TRAIN, Cycle 276 THREE-D CONTOUR TRAIN also interprets coordinates in the tool axis (Z axis) that are defined in the contour subprogram. This makes it possible to easily machine contours created with a CAM system, for example.

  1. Machining a contour without infeed: Milling depth Q1=0
  2. Using positioning logic, the tool moves to the starting point of machining that results from the first contour point of the selected machining direction and the selected approach function.
  3. The contour is approached on a tangential arc and machined up to the end.
  4. When the tool reaches the end point of the contour, it departs the contour tangentially. The departure function is performed in the same manner as the approach function.
  5. Finally, the TNC retracts the tool to the clearance height.
  1. Machining a contour with infeed: Milling depth Q1 not equal to 0 and plunging depth Q10 are defined
  2. Using positioning logic, the tool moves to the starting point of machining that results from the first contour point of the selected machining direction and the selected approach function.
  3. The contour is approached on a tangential arc and machined up to the end.
  4. When the tool reaches the end point of the contour, it departs the contour tangentially. The departure function is performed in the same manner as the approach function.
  5. If reciprocating plunge is selected (Q15=0), the TNC moves the tool to the next plunging depth and machines the contour until the original starting point is reached. Otherwise the tool is moved to clearance height and returned to the starting point of machining. From there, the TNC moves the tool to the next plunging depth. The departure function is performed in the same manner as the approach function.
  6. This process is repeated until the programmed depth is reached.
  7. Finally, the TNC retracts the tool to the clearance height.


Please note while programming:

The first block in the contour subprogram must contain values in all of the three axes X, Y and Z.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the TNC will execute the cycle using the tool axis coordinates defined in the contour subprogram.

When using Cycle 25 CONTOUR TRAIN, you can define only one contour subprogram in Cycle 14 CONTOUR GEOMETRY.

The memory capacity for programming an SL cycle is limited. You can program up to 4090 contour elements in one SL cycle.

The TNC does not need Cycle 20 CONTOUR DATA in conjunction with Cycle 276.

Make sure that the tool is in the tool axis above the workpiece when the cycle is called; otherwise the TNC will issue an error message.

Use the CONTOUR TRAIN DATA cycle to define the machining behavior of Cycle 276 (see CONTOUR TRAIN DATA (Cycle 270, DIN/ISO: G270)).

Danger of collision!

To avoid collisions,

  • Before the cycle call, position the tool in the tool axis such that the TNC can approach the starting point of the contour without collision. If the actual position of the tool is below the clearance height when the cycle is called, the TNC will issue an error message.
  • If you program APPR and DEP blocks for contour approach and departure, the TNC monitors whether the execution of these blocks would damage the contour.
  • Do not program positions in incremental dimensions immediately after Cycle 276 since they are referenced to the position of the tool at the end of the cycle.
  • Move the tool to defined (absolute) positions in all principal axes, since the position of the tool at the end of the cycle is not identical to the position of the tool at the start of the cycle.

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
62 CYCL DEF 276 THREE-D CONTOUR TRAIN
Q1=-20 ;MILLING DEPTH
Q3=+0 ;ALLOWANCE FOR SIDE
Q7=+50 ;CLEARANCE HEIGHT
Q10=+5 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q12=350 ;FEED RATE FOR MILLING
Q15=-1 ;CLIMB OR UP-CUT
Q18=0 ;COARSE ROUGHING TOOL
Q446=0.01 ;RESIDUAL MATERIAL
Q447=10 ;CONNECTION DISTANCE
Q448=2 ;PATH EXTENSION

Milling depth Q1 (incremental): Distance between workpiece surface and contour floor. If milling depth Q1 = 0 and plunging depth Q10 = 0 are programmed, the TNC machines the contour according to the Z values defined in the contour subprogram. Input range ‑99999.9999 to 99999.9999

Finishing allowance for side Q3 (incremental): Finishing allowance in the working plane. Input range ‑99999.9999 to 99999.9999

Clearance height Q7 (absolute): Absolute height at which the tool cannot collide with the workpiece. Position for tool retraction at the end of the cycle. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Plunging depth Q10 (incremental): Infeed per cut. Effective only when the milling depth Q1 is defined as not equal to 0. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool in the spindle axis. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for milling Q12: Traversing speed of the tool in the working plane. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Climb/Up-cut? Up-cut = –1 Q15: Climb milling: Input value = +1 Up-cut milling: Input value = –1 To enable climb milling and up-cut milling alternately in several infeeds: Input value = 0

Coarse roughing tool Q18 or QS18: Number or name of the tool with which the TNC has already coarse-roughed the contour. Press the tool name soft key to switch to name input. The TNC automatically inserts the closing quotation mark when you exit the input field. If there was no coarse roughing, enter "0"; the TNC will then machine the contour to the maximum extent that is possible with the active tool. If you enter a number or a name, the TNC will only machine the portion that could not be machined with the coarse roughing tool. Input range 0 to 32767.9 if a number is entered; maximum 32 characters if a name is entered.

Accepted residual material Q446: Thickness of the residual material that is to be left unmachined by the TNC. Default value: 0.01 mm Input range 0 to +9.999

Maximum connection distance Q447: Maximum distance between two areas to be fine-roughed, between which the tool is to move at the machining depth along the contour without a lift-off motion. Input range 0 to 999

Path extension Q448: Length by which the tool path is extended at the start and end of the contour. The TNC always extends the tool path in parallel to the contour. Input range 0 to 99.999


Programming examples

Further Informations:
> Example: Roughing-out and fine-roughing a pocket
> Example: Pilot drilling, roughing-out and finishing overlapping contours
> Example: Contour train


Example: Roughing-out and fine-roughing a pocket

0 begin pgm c20 mm |
1 blk form 0.1 z x-10 y-10 z-40 |
2 blk form 0.2 x+100 y+100 z+0 | Definition of workpiece blank
3 tool call 1 z s2500 | Tool call: coarse roughing tool, diameter 30
4 l z+250 r0 fmax | Retract the tool
5 cycl def 14.0 contour geometry | Define contour subprogram
6 cycl def 14.1 contour label 1 |
7 cycl def 20 contour data | Define general machining parameters
Q1=-20 ;MILLING DEPTH |
Q2=1 ;TOOL PATH OVERLAP |
Q3=+0 ;ALLOWANCE FOR SIDE |
Q4=+0 ;ALLOWANCE FOR FLOOR |
Q5=+0 ;SURFACE COORDINATE |
Q6=2 ;SET-UP CLEARANCE |
Q7=+100 ;CLEARANCE HEIGHT |
Q8=0.1 ;ROUNDING RADIUS |
Q9=-1 ;DIRECTION OF ROTATION |
8 cycl def 22 rough-out | Cycle definition: Coarse roughing
Q10=5 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=350 ;FEED RATE FOR ROUGHING |
Q18=0 ;COARSE ROUGHING TOOL |
Q19=150 ;RECIPROCATION FEED RATE |
Q208=30000 ;RETRACTION FEED RATE |
Q401=100 ;feed rate factor |
Q404=0 ;FINE ROUGH STRATEGY |
9 cycl call m3 | Cycle call: Coarse roughing
10 l z+250 r0 fmax m6 | Tool change
11 tool call 2 z s3000 | Tool call: fine roughing tool, diameter 15
12 cycl def 22 rough-out | Define the fine roughing cycle
Q10=5 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=350 ;FEED RATE FOR ROUGHING |
Q18=1 ;COARSE ROUGHING TOOL |
Q19=150 ;RECIPROCATION FEED RATE |
Q208=30000 ;RETRACTION FEED RATE |
Q401=100 ;feed rate factor |
Q404=0 ;FINE ROUGH STRATEGY |
13 cycl call m3 | Cycle call: Fine roughing
14 l z+250 r0 fmax m2 | Retract the tool, end program
15 lbl 1 | Contour subprogram
16 l x+0 y+30 rr |
17 fc dr- r30 ccx+30 ccy+30 |
18 fl an+60 pdx+30 pdy+30 d10 |
19 fselect 3 |
20 fpol x+30 y+30 |
21 fc dr- r20 ccpr+55 ccpa+60 |
22 fselect 2 |
23 fl an-120 pdx+30 pdy+30 d10 |
24 fselect 3 |
25 fc x+0 dr- r30 ccx+30 ccy+30 |
26 fselect 2 |
27 lbl 0 |
28 end pgm c20 mm |


Example: Pilot drilling, roughing-out and finishing overlapping contours

0 begin pgm c21 mm |
1 blk form 0.1 z x+0 y+0 z-40 | Definition of workpiece blank
2 blk form 0.2 x+100 y+100 z+0 |
3 tool call 1 z s2500 | Tool call: Drill, diameter 12
4 l z+250 r0 fmax | Retract the tool
5 cycl def 14.0 contour geometry | Define contour subprograms
6 cycl def 14.1 contour label 1/2/3/4 |
7 cycl def 20 contour data | Define general machining parameters
Q1=-20 ;MILLING DEPTH |
Q2=1 ;TOOL PATH OVERLAP |
Q3=+0.5 ;ALLOWANCE FOR SIDE |
Q4=+0.5 ;ALLOWANCE FOR FLOOR |
Q5=+0 ;SURFACE COORDINATE |
Q6=2 ;SET-UP CLEARANCE |
Q7=+100 ;CLEARANCE HEIGHT |
Q8=0.1 ;ROUNDING RADIUS |
Q9=-1 ;DIRECTION OF ROTATION |
8 cycl def 21 pilot drilling | Cycle definition: Pilot drilling
Q10=5 ;PLUNGING DEPTH |
Q11=250 ;FEED RATE FOR PLNGNG |
Q13=2 ;ROUGH-OUT TOOL |
9 cycl call m3 | Cycle call: Pilot drilling
10 l +250 r0 fmax m6 | Tool change
11 tool call 2 z s3000 | Call the tool for roughing/finishing, diameter 12
12 cycl def 22 rough-out | Cycle definition: Rough-out
Q10=5 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=350 ;FEED RATE FOR ROUGHING |
Q18=0 ;COARSE ROUGHING TOOL |
Q19=150 ;RECIPROCATION FEED RATE |
Q208=30000 ;RETRACTION FEED RATE |
Q401=100 ;feed rate factor |
Q404=0 ;FINE ROUGH STRATEGY |
13 cycl call m3 | Cycle call: Rough-out
14 cycl def 23 floor finishing | Cycle definition: Floor finishing
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=200 ;FEED RATE FOR ROUGHING |
Q208=30000 ;RETRACTION FEED RATE |
15 cycl call | Cycle call: Floor finishing
16 cycl def 24 side finishing | Cycle definition: Side finishing
Q9=+1 ;DIRECTION OF ROTATION |
Q10=5 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=400 ;FEED RATE FOR ROUGHING |
Q14=+0 ;ALLOWANCE FOR SIDE |
17 cycl call | Cycle call: Side finishing
18 l z+250 r0 fmax m2 | Retract the tool, end program
19 lbl 1 | Contour subprogram 1: left pocket
20 cc x+35 y+50 |
21 l x+10 y+50 rr |
22 c x+10 dr- |
23 lbl 0 |
24 lbl 2 | Contour subprogram 2: right pocket
25 cc x+65 y+50 |
26 l x+90 y+50 rr |
27 c x+90 dr- |
28 lbl 0 |
29 lbl 3 | Contour subprogram 3: square left island
30 l x+27 y+50 rl |
31 l y+58 |
32 l x+43 |
33 l y+42 |
34 l x+27 |
35 lbl 0 |
36 lbl 4 | Contour subprogram 4: triangular right island
39 l x+65 y+42 rl |
37 l x+57 |
38 l x+65 y+58 |
39 l x+73 y+42 |
40 lbl 0 |
41 end pgm c21 mm |


Example: Contour train

0 begin pgm c25 mm |
1 blk form 0.1 z x+0 y+0 z-40 | Definition of workpiece blank
2 blk form 0.2 x+100 y+100 z+0 |
3 tool call 1 z s2000 | Tool call: Diameter 20
4 l z+250 R0 fmax | Retract the tool
5 cycl def 14.0 contour geometry | Define contour subprogram
6 cycl def 14.1 contour label 1 |
7 cycl def 25 contour train | Define machining parameters
Q1=-20 ;MILLING DEPTH |
Q3=+0 ;ALLOWANCE FOR SIDE |
Q5=+0 ;SURFACE COORDINATE |
Q7=+250 ;CLEARANCE HEIGHT |
Q10=5 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=200 ;FEED RATE FOR MILLING |
Q15=+1 ;CLIMB OR UP-CUT |
8 cycl call m3 | Cycle call
9 l z+250 r0 fmax m2 | Retract the tool, end program
10 lbl 1 | Contour subprogram
11 l x+0 y+15 rl |
12 l x+5 y+20 |
13 ct x+5 y+75 |
14 l y+95 |
15 rnd r7.5 |
16 l x+50 |
17 rnd r7.5 |
18 l x+100 y+80 |
19 lbl 0 |
20 end pgm c25 mm |


Fixed Cycles: Cylindrical Surface

Further Informations:
> Fundamentals
> CYLINDER SURFACE (Cycle 27, DIN/ISO: G127, Software Option 1)
> CYLINDER SURFACE slot milling (Cycle 28, DIN/ISO: G128, Software Option 1)
> CYLINDER SURFACE ridge milling (Cycle 29, DIN/ISO: G129, Software Option 1)
> CYLINDER SURFACE outside contour milling (Cycle 39, DIN/ISO: G139, Software Option 1)
> Programming examples


Fundamentals

Further Informations:
> Overview of cylindrical surface cycles


Overview of cylindrical surface cycles

Cycle | Soft key | Page
27 CYLINDER SURFACE |  | Cycle run
28 CYLINDER SURFACE slot milling |  | CYLINDER SURFACE slot milling (Cycle 28, DIN/ISO: G128, Software Option 1)
29 CYLINDER SURFACE ridge milling |  | CYLINDER SURFACE ridge milling (Cycle 29, DIN/ISO: G129, Software Option 1)
39 CYLINDER SURFACE outside contour milling |  | CYLINDER SURFACE outside contour milling (Cycle 39, DIN/ISO: G139, Software Option 1)


CYLINDER SURFACE (Cycle 27, DIN/ISO: G127, Software Option 1)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

This cycle enables you to program a contour in two dimensions and then roll it onto a cylindrical surface for 3-D machining. Use Cycle 28 if you want to mill guideways on the cylinder.

The contour is described in a subprogram identified in Cycle 14 CONTOUR GEOMETRY.

The subprogram contains coordinates in a rotary axis and in its parallel axis. The rotary axis C, for example, is parallel to the Z axis. The path functions L, CHF, CR, RND, APPR (except APPR LCT) and DEP are available.

The dimensions in the rotary axis can be entered as desired either in degrees or in mm (or inches). You can select the desired dimension type in the cycle definition.

  1. The TNC positions the tool over the cutter infeed point, taking the allowance for side into account.
  2. At the first plunging depth, the tool mills along the programmed contour at the milling feed rate Q12.
  3. At the end of the contour, the TNC returns the tool to the set-up clearance and returns to the point of penetration.
  4. Steps 1 to 3 are repeated until the programmed milling depth Q1 is reached.
  5. Then the tool moves to the set-up clearance.


Please note while programming:

The machine and TNC must be prepared for cylinder surface interpolation by the machine tool builder. Refer to your machine manual.

In the first NC block of the contour subprogram, always program both cylinder surface coordinates.

The memory capacity for programming an SL cycle is limited. You can program up to 8192 contour elements in one SL cycle.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

This cycle requires a center-cut end mill (ISO 1641).

The cylinder must be set up centered on the rotary table.

The tool axis must be perpendicular to the rotary table. If this is not the case, the TNC will generate an error message.

This cycle can also be used in a tilted working plane.


Cycle parameters

Example: NC blocks
63 cycl def 27 CYLINDER SURFACE
Q1=-8 ;MILLING DEPTH
Q3=+0 ;ALLOWANCE FOR SIDE
Q6=+0 ;SET-UP CLEARANCE
Q10=+3 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q12=350 ;FEED RATE FOR MILLING
Q16=25 ;RADIUS
Q17=0 ;TYPE OF DIMENSION

Milling depth Q1 (incremental): Distance between the cylindrical surface and the floor of the contour. Input range ‑99999.9999 to 99999.9999

Finishing allowance for side Q3 (incremental): Finishing allowance in the plane of the unrolled cylindrical surface. This allowance is effective in the direction of the radius compensation. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q6 (incremental): Distance between the tool tip and the cylinder surface. Input range 0 to 99999.9999; alternatively PREDEF

Plunging depth Q10 (incremental): Infeed per cut. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool in the spindle axis. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for milling Q12: Traversing speed of the tool in the working plane. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Cylinder radius Q16: Radius of the cylinder on which the contour is to be machined. Input range 0 to 99999.9999

Dimension type? deg=0 MM/INCH=1 Q17: The coordinates for the rotary axis of the subprogram are given either in degrees (0) or in mm/inches (1).


CYLINDER SURFACE slot milling (Cycle 28, DIN/ISO: G128, Software Option 1)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

This cycle enables you to program a guide notch in two dimensions and then transfer it onto a cylindrical surface. Unlike Cycle 27, with this cycle the TNC adjusts the tool so that, with radius compensation active, the walls of the slot are nearly parallel. You can machine exactly parallel walls by using a tool that is exactly as wide as the slot.

The smaller the tool is with respect to the slot width, the larger the distortion in circular arcs and oblique line segments. To minimize this process-related distortion, you can define in parameter Q21 a tolerance with which the TNC machines a slot as similar as possible to a slot machined with a tool of the same width as the slot.

Program the midpoint path of the contour together with the tool radius compensation. With the radius compensation you specify whether the TNC cuts the slot with climb milling or up-cut milling.

  1. The TNC positions the tool over the cutter infeed point.
  2. At the first plunging depth, the tool mills along the programmed slot wall at the milling feed rate Q12 while respecting the finishing allowance for the side.
  3. At the end of the contour, the TNC moves the tool to the opposite wall and returns to the infeed point.
  4. Steps 2 and 3 are repeated until the programmed milling depth Q1 is reached.
  5. If you have defined the tolerance in Q21, the TNC then remachines the slot walls to be as parallel as possible.
  6. Finally, the tool retracts in the tool axis to the clearance height or to the position last programmed before the cycle (depending on MP7420).


Please note while programming:

The machine and TNC must be prepared for cylinder surface interpolation by the machine tool builder. Refer to your machine manual.

In the first NC block of the contour subprogram, always program both cylinder surface coordinates.

The memory capacity for programming an SL cycle is limited. You can program up to 8192 contour elements in one SL cycle.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

This cycle requires a center-cut end mill (ISO 1641).

The cylinder must be set up centered on the rotary table.

The tool axis must be perpendicular to the rotary table. If this is not the case, the TNC will generate an error message.

This cycle can also be used in a tilted working plane.

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
63 cycl def 28 CYLINDER SURFACE
Q1=-8 ;MILLING DEPTH
Q3=+0 ;ALLOWANCE FOR SIDE
Q6=+0 ;SET-UP CLEARANCE
Q10=+3 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q12=350 ;FEED RATE FOR MILLING
Q16=25 ;RADIUS
Q17=0 ;TYPE OF DIMENSION
Q20=12 ;SLOT WIDTH
Q21=0 ;TOLERANCE

Milling depth Q1 (incremental): Distance between the cylindrical surface and the floor of the contour. Input range ‑99999.9999 to 99999.9999

Finishing allowance for side Q3 (incremental): Finishing allowance on the slot wall. The finishing allowance reduces the slot width by twice the entered value. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q6 (incremental): Distance between the tool tip and the cylinder surface. Input range 0 to 99999.9999; alternatively PREDEF

Plunging depth Q10 (incremental): Infeed per cut. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool in the spindle axis. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for milling Q12: Traversing speed of the tool in the working plane. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Cylinder radius Q16: Radius of the cylinder on which the contour is to be machined. Input range 0 to 99999.9999

Dimension type? deg=0 MM/INCH=1 Q17: The coordinates for the rotary axis of the subprogram are given either in degrees (0) or in mm/inches (1).

Slot width Q20: Width of the slot to be machined. Input range ‑99999.9999 to 99999.9999

Tolerance? Q21: If you use a tool smaller than the programmed slot width Q20, process-related distortion occurs on the slot wall wherever the slot follows the path of an arc or oblique line. If you define the tolerance Q21, the TNC adds a subsequent milling operation to ensure that the slot dimensions are as close as possible to those of a slot that has been milled with a tool exactly as wide as the slot. With Q21 you define the permitted deviation from this ideal slot. The number of subsequent milling operations depends on the cylinder radius, the tool used, and the slot depth. The smaller the tolerance is defined, the more exact the slot is and the longer the remachining takes. Recommendation: Use a tolerance of 0.02 mm. Function inactive: Enter 0 (default setting) Input range 0 to 9.9999


CYLINDER SURFACE ridge milling (Cycle 29, DIN/ISO: G129, Software Option 1)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

This cycle enables you to program a ridge in two dimensions and then transfer it onto a cylindrical surface. With this cycle the TNC adjusts the tool so that, with radius compensation active, the walls of the slot are always parallel. Program the midpoint path of the ridge together with the tool radius compensation. With the radius compensation you specify whether the TNC cuts the ridge with climb milling or up-cut milling.

At the ends of the ridge the TNC always adds a semicircle whose radius is half the ridge width.

  1. The TNC positions the tool over the starting point of machining. The TNC calculates the starting point from the ridge width and the tool diameter. It is located next to the first point defined in the contour subprogram, offset by half the ridge width and the tool diameter. The radius compensation determines whether machining begins from the left (1, RL = climb milling) or the right of the ridge (2, RR = up-cut milling).
  2. After the TNC has positioned to the first plunging depth, the tool moves on a circular arc at the milling feed rate Q12 tangentially to the ridge wall. If so programmed, it will leave material for the finishing allowance.
  3. At the first plunging depth, the tool mills along the programmed ridge wall at the milling feed rate Q12 until the stud is completed.
  4. The tool then departs the ridge wall on a tangential path and returns to the starting point of machining.
  5. Steps 2 to 4 are repeated until the programmed milling depth Q1 is reached.
  6. Finally, the tool retracts in the tool axis to the clearance height or to the position last programmed before the cycle (depending on MP7420).


Please note while programming:

The machine and TNC must be prepared for cylinder surface interpolation by the machine tool builder. Refer to your machine manual.

In the first NC block of the contour subprogram, always program both cylinder surface coordinates.

Ensure that the tool has enough space laterally for contour approach and departure.

The memory capacity for programming an SL cycle is limited. You can program up to 8192 contour elements in one SL cycle.

The algebraic sign for the cycle parameter DEPTH determines the working direction. If you program DEPTH=0, the cycle will not be executed.

The cylinder must be set up centered on the rotary table.

The tool axis must be perpendicular to the rotary table. If this is not the case, the TNC will generate an error message.

This cycle can also be used in a tilted working plane.

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
63 cycl def 29 CYLINDER SURFACE RIDGE
Q1=-8 ;MILLING DEPTH
Q3=+0 ;ALLOWANCE FOR SIDE
Q6=+0 ;SET-UP CLEARANCE
Q10=+3 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q12=350 ;FEED RATE FOR MILLING
Q16=25 ;RADIUS
Q17=0 ;TYPE OF DIMENSION
Q20=12 ;RIDGE WIDTH

Milling depth Q1 (incremental): Distance between the cylindrical surface and the floor of the contour. Input range ‑99999.9999 to 99999.9999

Finishing allowance for side Q3 (incremental): Finishing allowance on the ridge wall. The finishing allowance increases the ridge width by twice the entered value. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q6 (incremental): Distance between the tool tip and the cylinder surface. Input range 0 to 99999.9999; alternatively PREDEF

Plunging depth Q10 (incremental): Infeed per cut. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool in the spindle axis. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for milling Q12: Traversing speed of the tool in the working plane. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Cylinder radius Q16: Radius of the cylinder on which the contour is to be machined. Input range 0 to 99999.9999

Dimension type? deg=0 MM/INCH=1 Q17: The coordinates for the rotary axis of the subprogram are given either in degrees (0) or in mm/inches (1).

Ridge width Q20: Width of the ridge to be machined. Input range ‑99999.9999 to 99999.9999


CYLINDER SURFACE outside contour milling (Cycle 39, DIN/ISO: G139, Software Option 1)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

This cycle enables you to program an open contour in two dimensions and then roll it onto a cylindrical surface for 3-D machining. With this cycle the TNC adjusts the tool so that, with radius compensation active, the wall of the open contour is always parallel to the cylinder axis.

Unlike Cycles 28 and 29, in the contour subprogram you define the actual contour to be machined.

  1. The TNC positions the tool over the starting point of machining. The TNC locates the starting point next to the first point defined in the contour subprogram, offset by the tool diameter (standard behavior).
  2. After the TNC has positioned to the first plunging depth, the tool moves on a circular arc at the milling feed rate Q12 tangentially to the contour. If so programmed, it will leave material for the finishing allowance.
  3. At the first plunging depth, the tool mills along the programmed contour at the milling feed rate Q12 until the contour train is completed.
  4. The tool then departs the ridge wall on a tangential path and returns to the starting point of machining.
  5. Steps 2 to 4 are repeated until the programmed milling depth Q1 is reached.
  6. Finally, the tool retracts in the tool axis to the clearance height or to the position last programmed before the cycle (depending on MP7420).

You can define the approach behavior of Cycle 39 in MP7680, bit 16.

  • Bit 16 = 0:
    Tangential approach and departure
  • Bit 16 = 1:
    Move to depth vertically at the starting point of the contour without tangential tool approach and move up at the contour end point without tangential departure.


Cycle parameters

Example: NC blocks
63 cycl def 39 CYL. SURFACE CONTOUR
Q1=-8 ;MILLING DEPTH
Q3=+0 ;ALLOWANCE FOR SIDE
Q6=+0 ;SET-UP CLEARANCE
Q10=+3 ;PLUNGING DEPTH
Q11=100 ;FEED RATE FOR PLNGNG
Q12=350 ;FEED RATE FOR MILLING
Q16=25 ;RADIUS
Q17=0 ;TYPE OF DIMENSION

Milling depth Q1 (incremental): Distance between the cylindrical surface and the floor of the contour. Input range ‑99999.9999 to 99999.9999

Finishing allowance for side Q3 (incremental): Finishing allowance on the contour wall. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q6 (incremental): Distance between the tool tip and the cylinder surface. Input range 0 to 99999.9999; alternatively PREDEF

Plunging depth Q10 (incremental): Infeed per cut. Input range ‑99999.9999 to 99999.9999

Feed rate for plunging Q11: Traversing speed of the tool in the spindle axis. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for milling Q12: Traversing speed of the tool in the working plane. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Cylinder radius Q16: Radius of the cylinder on which the contour is to be machined. Input range 0 to 99999.9999

Dimension type? deg=0 MM/INCH=1 Q17: The coordinates for the rotary axis of the subprogram are given either in degrees (0) or in mm/inches (1).


Programming examples

Further Informations:
> Example: Cylinder surface with Cycle 27
> Example: Cylinder surface with Cycle 28


Example: Cylinder surface with Cycle 27

    Note:

  • Machine with B head and C table
  • Cylinder centered on rotary table
  • Datum at center of rotary table
0 begin pgm c27 mm |
1 tool call 1 z s2000 | Tool call: Diameter 7
2 l z+250 r0 fmax | Retract the tool
3 l x+50 y0 r0 fmax | Pre-position tool at rotary table center
4 plane spatial spa+0 spb+90 spc+0 turn mbmax fmax | Tilting
5 cycl def 14.0 contour geometry | Define contour subprogram
6 cycl def 14.1 contour label 1 |
7 cycl def 27 CYLINDER SURFACE | Define machining parameters
Q1=-7 ;MILLING DEPTH |
Q3=+0 ;ALLOWANCE FOR SIDE |
Q6=2 ;SET-UP CLEARANCE |
Q10=4 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=250 ;FEED RATE FOR MILLING |
Q16=25 ;RADIUS |
Q17=1 ;TYPE OF DIMENSION |
8 l c+0 r0 fmax m13 m99 | Pre-position rotary table, spindle ON, call the cycle
9 l z+250 r0 fmax | Retract the tool
10 plane reset turn fmax | Tilt back, cancel the PLANE function
11 m2 | End of program
12 lbl 1 | Contour subprogram
13 l c+40 x+20 rl | Data for the rotary axis are entered in mm (Q17=1), traverse in the X axis because of 90° tilting
14 l c+50 |
15 rnd r7.5 |
16 l x+60 |
17 rnd r7.5 |
18 l ic-20 |
19 rnd r7.5 |
20 l x+20 |
21 rnd r7.5 |
22 l c+40 |
23 lbl 0 |
24 end pgm c27 mm |


Example: Cylinder surface with Cycle 28

    Notes:

  • Cylinder centered on rotary table
  • Machine with B head and C table
  • Datum at center of rotary table
  • Description of the midpoint path in the contour subprogram
0 begin pgm c28 mm |
1 tool call 1 z s2000 | Tool call, tool axis Z, diameter 7
2 l z+250 R0 fmax | Retract the tool
3 l x+50 y+0 r0 fmax | Position tool at rotary table center
4 plane spatial spa+0 spb+90 spc+0 turn fmax | Tilting
5 cycl def 14.0 contour geometry | Define contour subprogram
6 cycl def 14.1 contour label 1 |
7 cycl def 28 CYLINDER SURFACE | Define machining parameters
Q1=-7 ;MILLING DEPTH |
Q3=+0 ;ALLOWANCE FOR SIDE |
Q6=2 ;SET-UP CLEARANCE |
Q10=-4 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=250 ;FEED RATE FOR MILLING |
Q16=25 ;RADIUS |
Q17=1 ;TYPE OF DIMENSION |
Q20=10 ;SLOT WIDTH |
Q21=0.02 ;TOLERANCE | Remachining active
8 l c+0 r0 fmax m3 m99 | Pre-position rotary table, spindle ON, call the cycle
9 l z+250 r0 fmax | Retract the tool
10 plane reset turn fmax | Tilt back, cancel the PLANE function
11 m2 | End of program
12 lbl 1 | Contour subprogram, description of the midpoint path
13 l c+40 x+0 rl | Data for the rotary axis are entered in mm (Q17=1), traverse in the X axis because of 90° tilting
14 l X+35 |
15 l c+60 X+52.5 |
16 l X+70 |
17 lbl 0 |
18 end pgm c28 mm |


Fixed Cycles: Contour Pocket with Contour Formula

Further Informations:
> SL cycles with complex contour formula
> SL cycles with simple contour formula


SL cycles with complex contour formula

Further Informations:
> Fundamentals
> Selecting a program with contour definitions
> Defining contour descriptions
> Entering a complex contour formula
> Overlapping contours
> Contour machining with SL Cycles
> Example: Roughing and finishing superimposed contours with the contour formula


Fundamentals

Example: Program structure: Machining with SL cycles and complex contour formula
0 begin pgm contour mm
...
5 sel contour "MODEL"
6 cycl def 20 contour data ...
8 cycl def 22 rough-out ...
9 cycl call
...
12 cycl def 23 floor finishing ...
13 cycl call
...
16 cycl def 24 side finishing ...
17 cycl call
63 l z+250 r0 fmax m2
64 end pgm contour mm

SL cycles and the complex contour formula enable you to form complex contours by combining subcontours (pockets or islands). You define the individual subcontours (geometry data) as separate programs. In this way, any subcontour can be used any number of times. The TNC calculates the complete contour from the selected subcontours, which you link together through a contour formula.

The memory capacity for programming an SL cycle (all contour description programs) is limited to 128 contours. The number of possible contour elements depends on the type of contour (inside or outside contour) and the number of contour descriptions. You can program up to 8192 elements.

The SL cycles with contour formula presuppose a structured program layout and enable you to save frequently used contours in individual programs. Using the contour formula, you can connect the subcontours to a complete contour and define whether it applies to a pocket or island.

In its present form, the "SL cycles with contour formula" function requires input from several areas in the TNC’s user interface. This function is to serve as a basis for further development.
Example: Program structure: Calculation of the subcontours with contour formula
0 begin pgm model mm
1 declare contour qc1 = "CIRCLE1"
2 declare contour qc2 = "CIRCLE31XY"
3 declare contour qc3 = "TRIANGLE"
4 declare contour qc4 = "SQUARE"
5 QC10 = ( QC1 | QC3 | QC4 ) \ QC2
6 end pgm model mm
0 begin pgm circle1 mm
1 cc x+75 y+50
2 lp pr+45 pa+0
3 cp ipa+360 dr+
4 end pgm circle1 mm
0 begin pgm circle31xy mm
...
...

    Properties of the subcontours

  • By default, the TNC assumes that the contour is a pocket. Do not program a radius compensation. In the contour formula you can convert a pocket to an island by making it negative.
  • The TNC ignores feed rates F and miscellaneous functions M.
  • Coordinate transformations are allowed. If they are programmed within the subcontour they are also effective in the following subprograms, but they need not be reset after the cycle call.
  • Although the subprograms can contain coordinates in the spindle axis, such coordinates are ignored.
  • The working plane is defined in the first coordinate block of the subprogram. The secondary axes U,V,W are permitted.

    Characteristics of the fixed cycles

  • The TNC automatically positions the tool to the set-up clearance before a cycle.
  • Each level of infeed depth is milled without interruptions since the cutter traverses around islands instead of over them.
  • The radius of "inside corners" can be programmed—the tool keeps moving to prevent surface blemishes at inside corners (this applies to the outermost pass in the Rough-out and Side Finishing cycles).
  • The contour is approached in a tangential arc for side finishing.
  • For floor finishing, the tool again approaches the workpiece on a tangential arc (for tool axis Z, for example, the arc is in the Z/X plane).
  • The contour is machined throughout in either climb or up-cut milling.

With Machine Parameter 7420 you can determine where the tool is positioned at the end of Cycles 21 to 24.

The machining data (such as milling depth, finishing allowance and set-up clearance) are entered as CONTOUR DATA in Cycle 20.


Selecting a program with contour definitions

With the SEL CONTOUR function you select a program with contour definitions, from which the TNC takes the contour descriptions:

Show the soft-key row with special functions

Select the menu for functions for contour and point machining

Select the COMPLEX CONTOUR FORMULA menu

Press the SEL CONTOUR soft key

Press the Window selection soft key: The TNC superimposes a window where you can select the program with the contour definitions

Select a program with the arrow keys or by mouse click and confirm by pressing ENT: The TNC enters the complete path name in the SEL CONTOUR block

Conclude this function with the END key

Enter the full name of the program with the contour definition and confirm with the END key

Alternatively you can also enter the program name or the complete path name of the program with the contour definition directly via the keyboard.

Program a SEL CONTOUR block before the SL cycles. Cycle 14 CONTOUR GEOMETRY is no longer necessary if you use SEL CONTUR.


Defining contour descriptions

With the DECLARE CONTOUR function you enter in a program the path for programs from which the TNC draws the contour descriptions. In addition, you can select a separate depth for this contour description (FCL 2 function):

Show the soft-key row with special functions

Select the menu for functions for contour and point machining

Select the COMPLEX CONTOUR FORMULA menu

Press the declare CONTOUR soft key

Enter the number for the contour designator QC, and confirm with the ENT key

Press the Window selection soft key: The TNC superimposes a window where you can select the program to be called

Select the program with the contour description with the arrow keys or by mouse click, and confirm by pressing ENT: The TNC enters the complete path name in the declare contour block

Define a separate depth for the selected contour

Conclude this function with the END key

Alternatively you can also enter the name of the program with the contour description or the complete path name of the program directly via the keyboard.

With the entered contour designators QC you can include the various contours in the contour formula.

If you program separate depths for contours, then you must assign a depth to all subcontours (assign the depth 0 if necessary).


Entering a complex contour formula

You can use soft keys to interlink various contours in a mathematical formula.

Show the soft-key row with special functions

Select the menu for functions for contour and point machining

Select the COMPLEX CONTOUR FORMULA menu

Press the Contour formula soft key. The TNC then displays the following soft keys:

Mathematical function | Soft key
Intersected with e.g. QC10 = QC1 & QC5 |
Joined with e.g. QC25 = QC7 | QC18 |
Joined without intersection e.g. QC12 = QC5 ^ QC25 |
Intersected with complement of e.g. QC25 = QC1 \ QC2 |
Complement of the contour area e.g. QC12 = #QC11 |
Opening parenthesis e.g. QC12 = QC1 * (QC2 + QC3) |
Closing parenthesis e.g. QC12 = QC1 * (QC2 + QC3) |
Defining a single contour e.g. QC12 = QC1 |


Overlapping contours

By default, the TNC considers a programmed contour to be a pocket. With the functions of the contour formula, you can convert a contour from a pocket to an island.

Pockets and islands can be overlapped to form a new contour. You can thus enlarge the area of a pocket by another pocket or reduce it by an island.

Subprograms: overlapping pockets

The following programming examples are contour description programs that are defined in a contour definition program. The contour definition program is called through the SEL CONTOUR function in the actual main program.

Pockets A and B overlap.

The TNC calculates the points of intersection S1 and S2 (they do not have to be programmed).

The pockets are programmed as full circles.

Contour description program 1: pocket A
0 begin pgm POCKET_A mm
1 l x+10 y+50 r0
2 cc x+35 y+50
3 c x+10 y+50 dr-
4 end pgm POCKET_A mm
Contour description program 2: pocket B
0 begin pgm POCKET_B mm
1 l x+90 y+50 r0
2 cc x+65 y+50
3 c x+90 y+50 dr-
4 end pgm POCKET_B mm
Further Informations:
> Area of inclusion
> Area of exclusion
> Area of intersection


Area of inclusion

    Both areas A and B are to be machined, including the overlapping area:

  • The areas A and B must be entered in separate programs without radius compensation.
  • In the contour formula, the areas A and B are processed with the "joined with" function.
Contour definition program:
50 ...
51 ...
52 declare contour qc1 = "POCKET_A.H"
53 declare contour qc2 = "POCKET_B.H"
54 qc10 = QC1 | QC2
55 ...
56 ...


Area of exclusion

    Area A is to be machined without the portion overlapped by B:

  • The areas A and B must be entered in separate programs without radius compensation.
  • In the contour formula, the area B is subtracted from the area A with the "intersected with complement of" function.
Contour definition program:
50 ...
51 ...
52 declare contour qc1 = "POCKET_A.H"
53 declare contour qc2 = "POCKET_B.H"
54 qc10 = QC1 \ QC2
55 ...
56 ...


Area of intersection

    Only the area where A and B overlap is to be machined. (The areas covered by A or B alone are to be left unmachined.)

  • The areas A and B must be entered in separate programs without radius compensation.
  • In the contour formula, the areas A and B are processed with the "intersection with" function.
Contour definition program:
50 ...
51 ...
52 declare contour qc1 = "POCKET_A.H"
53 declare contour qc2 = "POCKET_B.H"
54 qc10 = QC1 & QC2
55 ...
56 ...


Contour machining with SL Cycles

The complete contour is machined with the SL Cycles 20 to 24 (see Overview).


Example: Roughing and finishing superimposed contours with the contour formula

0 begin pgm contour mm |
1 blk form 0.1 z x+0 y+0 z-40 | Definition of workpiece blank
2 blk form 0.2 x+100 y+100 z+0 |
3 tool def 1 l+0 r+2.5 | Tool definition of roughing cutter
4 tool def 2 l+0 r+3 | Tool definition of finishing cutter
5 tool call 1 z s2500 | Tool call of roughing cutter
6 l z+250 r0 fmax | Retract the tool
7 sel contour "MODEL" | Specify contour definition program
8 cycl def 20 contour data | Define general machining parameters
Q1=-20 ;MILLING DEPTH |
Q2=1 ;TOOL PATH OVERLAP |
Q3=+0.5 ;ALLOWANCE FOR SIDE |
Q4=+0.5 ;ALLOWANCE FOR FLOOR |
Q5=+0 ;SURFACE COORDINATE |
Q6=2 ;SET-UP CLEARANCE |
Q7=+100 ;CLEARANCE HEIGHT |
Q8=0.1 ;ROUNDING RADIUS |
Q9=-1 ;DIRECTION OF ROTATION |
9 cycl def 22 rough-out | Cycle definition: Rough-out
Q10=5 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=350 ;FEED RATE FOR ROUGHING |
Q18=0 ;COARSE ROUGHING TOOL |
Q19=150 ;RECIPROCATION FEED RATE |
Q401=100 ;feed rate factor |
Q404=0 ;FINE ROUGH STRATEGY |
10 cycl call m3 | Cycle call: Rough-out
11 tool call 2 z s5000 | Tool call of finishing cutter
12 cycl def 23 floor finishing | Cycle definition: Floor finishing
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=200 ;FEED RATE FOR ROUGHING |
13 cycl call m3 | Cycle call: Floor finishing
14 cycl def 24 side finishing | Cycle definition: Side finishing
Q9=+1 ;DIRECTION OF ROTATION |
Q10=5 ;PLUNGING DEPTH |
Q11=100 ;FEED RATE FOR PLNGNG |
Q12=400 ;FEED RATE FOR ROUGHING |
Q14=+0 ;ALLOWANCE FOR SIDE |
15 cycl call m3 | Cycle call: Side finishing
16 l z+250 r0 fmax m2 | Retract the tool, end program
17 end pgm contour mm |

Contour definition program with contour formula:

0 begin pgm model mm | Contour definition program
1 declare contour qc1 = "CIRCLE1" | Definition of the contour designator for the program "CIRCLE1"
2 fn 0: Q1 =+35 | Assignment of values for parameters used in PGM "CIRCLE31XY"
3 fn 0: q2 =+50 |
4 FN 0: q3 =+25 |
5 declare contour qc2 = "CIRCLE31XY" | Definition of the contour designator for the program "CIRCLE31XY"
6 declare contour qc3 = "TRIANGLE" | Definition of the contour designator for the program "TRIANGLE"
7 declare contour qc4 = "SQUARE" | Definition of the contour designator for the program "SQUARE"
8 QC10 = ( QC 1 | QC 2 ) \ QC 3 \ QC 4 | Contour formula
9 end pgm model mm |

Contour description programs:

0 begin pgm circle1 mm | Contour description program: circle at right
1 cc x+65 y+50 |
2 l pr+25 pa+0 r0 |
3 cp ipa+360 dr+ |
4 end pgm circle1 mm |
0 begin pgm circle31xy mm | Contour description program: circle at left
1 cc x+q1 y+q2 |
2 lp pr+q3 pa+0 r0 |
3 cp ipa+360 dr+ |
4 end pgm circle31xy mm |
0 begin pgm triangle mm | Contour description program: triangle at right
1 l x+73 y+42 r0 |
2 l x+65 y+58 |
3 l x+58 y+42 |
4 l x+73 |
5 end pgm triangle mm |
0 begin pgm square mm | Contour description program: square at left
1 l x+27 y+58 r0 |
2 l x+43 |
3 l y+42 |
4 l x+27 |
5 l y+58 |
6 end pgm square mm |


SL cycles with simple contour formula

Further Informations:
> Fundamentals
> Entering a simple contour formula
> Contour machining with SL Cycles


Fundamentals

Example: Program structure: Machining with SL cycles and complex contour formula
0 begin pgm CONTDEF mm
...
5 contour def P1= "POCK1.H" I2 = "ISLE2.H" depth5 i3 "isle3.h" depth7.5
6 cycl def 20 contour data ...
8 cycl def 22 rough-out ...
9 cycl call
...
12 cycl def 23 floor finishing ...
13 cycl call
...
16 cycl def 24 side finishing ...
17 cycl call
63 l z+250 r0 fmax m2
64 end pgm CONTDEF mm

SL cycles and the simple contour formula enable you to form contours by combining up to 9 subcontours (pockets or islands) in a simple manner. You define the individual subcontours (geometry data) as separate programs. In this way, any subcontour can be used any number of times. The TNC calculates the contour from the selected subcontours.

The memory capacity for programming an SL cycle (all contour description programs) is limited to 128 contours. The number of possible contour elements depends on the type of contour (inside or outside contour) and the number of contour descriptions. You can program up to approx. 8192 elements.

    Properties of the subcontours

  • By default, the TNC assumes that the contour is a pocket. Do not program a radius compensation.
  • The TNC ignores feed rates F and miscellaneous functions M.
  • Coordinate transformations are allowed. If they are programmed within the subcontour they are also effective in the following subprograms, but they need not be reset after the cycle call.
  • Although the subprograms can contain coordinates in the spindle axis, such coordinates are ignored.
  • The working plane is defined in the first coordinate block of the subprogram. The secondary axes U,V,W are permitted.

    Characteristics of the fixed cycles

  • The TNC automatically positions the tool to the set-up clearance before a cycle.
  • Each level of infeed depth is milled without interruptions since the cutter traverses around islands instead of over them.
  • The radius of "inside corners" can be programmed—the tool keeps moving to prevent surface blemishes at inside corners (this applies to the outermost pass in the Rough-out and Side Finishing cycles).
  • The contour is approached in a tangential arc for side finishing.
  • For floor finishing, the tool again approaches the workpiece on a tangential arc (for tool axis Z, for example, the arc is in the Z/X plane).
  • The contour is machined throughout in either climb or up-cut milling.

With Machine Parameter 7420 you can determine where the tool is positioned at the end of Cycles 21 to 24.

The machining data (such as milling depth, finishing allowance and set-up clearance) are entered as CONTOUR DATA in Cycle 20.


Entering a simple contour formula

You can use soft keys to interlink various contours in a mathematical formula.

Show the soft-key row with special functions

Select the menu for functions for contour and point machining

Press the contour def soft key. The TNC opens the dialog for entering the contour formula

Select the name of the first subcontour with the WINDOW SELECTION soft key or enter it directly The first subcontour must always be the deepest pocket. Confirm with the ENT key

Specify via soft key whether the next subcontour is a pocket or an island. Confirm with the ENT key

Select the name of the second subcontour with the WINDOW SELECTION soft key or enter it directly. Confirm by pressing the ENT key

If needed, enter the depth of the second subcontour. Confirm with the ENT key

Carry on with the dialog as described above until you have entered all subcontours.

  • Always start the list of subcontours with the deepest pocket!
  • If the contour is defined as an island, the TNC interprets the entered depth as the island height. The entered value (without an algebraic sign) then refers to the workpiece top surface!
  • If the depth is entered as 0, then for pockets the depth defined in the Cycle 20 is effective. Islands then rise up to the workpiece top surface!


Fixed Cycles: Multipass Milling

Further Informations:
> Fundamentals
> RUN 3-D DATA (Cycle 30, DIN/ISO: G60)
> MULTIPASS MILLING (Cycle 230, DIN/ISO: G230)
> RULED SURFACE (Cycle 231, DIN/ISO: G231)
> FACE MILLING (Cycle 232, DIN/ISO: G232)
> Programming examples


Overview

    The TNC offers four cycles for machining surfaces with the following characteristics:

  • Created with a CAD/CAM system
  • Flat, rectangular surfaces
  • Flat, oblique-angled surfaces
  • Surfaces that are inclined in any way
  • Twisted surfaces
Cycle | Soft key | Page
30 RUN 3-D DATA For multipass milling of 3-D data in several infeeds |  | RUN 3-D DATA (Cycle 30, DIN/ISO: G60)
230 MULTIPASS MILLING For flat rectangular surfaces |  | MULTIPASS MILLING (Cycle 230, DIN/ISO: G230)
231 RULED SURFACE For oblique, inclined or twisted surfaces |  | RULED SURFACE (Cycle 231, DIN/ISO: G231)
232 FACE MILLING For level rectangular surfaces, with indicated oversizes and multiple infeeds |  | FACE MILLING (Cycle 232, DIN/ISO: G232)


RUN 3-D DATA (Cycle 30, DIN/ISO: G60)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. From the current position, the TNC positions the tool at rapid traverse FMAX in the tool axis to the set-up clearance above the MAX point that you have programmed in the cycle.
  2. The tool then moves at FMAX in the working plane to the MIN point you have programmed in the cycle.
  3. From this point, the tool advances to the first contour point at the feed rate for plunging.
  4. The TNC subsequently processes all points that are stored in the digitizing data file at the feed rate for milling. If necessary, the TNC retracts the tool between machining operations to the set-up clearance if specific areas are to be left unmachined.
  5. At the end of the cycle, the tool is retracted at FMAX to the set-up clearance.


Please note while programming:

You can particularly use Cycle 30 to run conversational programs created offline in multiple infeeds.


Cycle parameters

Example: NC blocks
64 cycl def 30.0 Run 3-D data
65 cycl def 30.1 pgm digit.: bsp.h
66 cycl def 30.2 x+0 y+0 z-20
67 cycl def 30.3 x+100 y+100 z+0
68 cycl def 30.4 setup 2
69 cycl def 30.5 peckg -5 f100
70 cycl def 30.6 f350 m8

PGM name 3-D data: Enter the name of the program in which the contour data is stored. If the file is not stored in the current directory, enter the complete path. A maximum of 254 characters can be entered.

Min. point of range: Lowest coordinates (X, Y and Z coordinates) in the range to be milled. Input range ‑99999.9999 to 99999.9999

Max. point of range: Largest coordinates (X, Y and Z coordinates) in the range to be milled. Input range ‑99999.9999 to 99999.9999

Set-up clearance 1 (incremental): Distance between tool tip and workpiece surface for tool movements at rapid traverse. Input range 0 to 99999.9999

Plunging depth 2 (incremental): Infeed per cut Input range ‑99999.9999 to 99999.9999

Feed rate for plunging 3: Traversing speed of the tool in mm/min when moving into the workpiece. Input range 0 to 99999.999; alternatively FAUTO

Feed rate for milling 4: Traversing speed of the tool in mm/min while milling. Input range 0 to 99999.9999; alternatively FAUTO

Miscellaneous function M: Optional entry of one to two miscellaneous functions, for example M13. Input range 0 to 999


MULTIPASS MILLING (Cycle 230, DIN/ISO: G230)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. From the current position in the working plane, the TNC positions the tool at rapid traverse FMAX to the starting point 1; the TNC moves the tool by its radius to the left and upward.
  2. The tool then moves at FMAX in the tool axis to the set-up clearance. From there it approaches the programmed starting position in the tool axis at the feed rate for plunging.
  3. The tool then moves at the programmed feed rate for milling to the end point 2. The TNC calculates the end point from the programmed starting point, the programmed length, and the tool radius.
  4. The TNC offsets the tool to the starting point in the next pass at the stepover feed rate. The offset is calculated from the programmed width and the number of cuts.
  5. The tool then returns in the negative direction of the first axis.
  6. Multipass milling is repeated until the programmed surface has been completed.
  7. At the end of the cycle, the tool is retracted at FMAX to the set-up clearance.


Please note while programming:

From the current position, the TNC positions the tool at the starting point, first in the working plane and then in the spindle axis.

Pre-position the tool in such a way that no collision with the workpiece or the fixtures can occur.

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Example: NC blocks
71 cycl def 230 MULTIPASS MILLING
Q225=+10 ;STARTING POINT 1ST AXIS
Q226=+12 ;STARTING POINT 2ND AXIS
Q227=+2.5 ;starting point 3rd axis
Q218=150 ;1ST SIDE LENGTH
Q219=75 ;2ND SIDE LENGTH
Q240=25 ;number of cuts
Q206=150 ;FEED RATE FOR PLNGNG
Q207=500 ;FEED RATE FOR MILLING
Q209=200 ;stepover feed rate
Q200=2 ;SET-UP CLEARANCE

Starting point in 1st axis Q225 (absolute): Minimum-point coordinate of the surface to be multipass-milled in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Starting point in 2nd axis Q226 (absolute): Minimum-point coordinate of the surface to be multipass-milled in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Starting point in 3rd axis Q227 (absolute): Height in the spindle axis at which multipass-milling is carried out. Input range ‑99999.9999 to 99999.9999

First side length Q218 (incremental): Length of the surface to be multipass-milled in the reference axis of the working plane, referenced to the starting point in the 1st axis. Input range 0 to 99999.9999

Second side length Q219 (incremental): Length of the surface to be multipass-milled in the minor axis of the working plane, referenced to the starting point in the 2nd axis. Input range 0 to 99999.9999

Number of cuts Q240: Number of passes to be made over the width. Input range 0 to 99999

Feed rate for plunging Q206: Traversing speed of the tool in mm/min when moving from set-up clearance to the milling depth. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for milling Q207: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Stepover feed rate Q209: Traversing speed of the tool in mm/min when moving to the next pass. If you are moving the tool transversely in the material, enter Q209 to be smaller than Q207. If you are moving it transversely in the open, Q209 may be greater than Q207. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Set-up clearance Q200 (incremental): Distance between tool tip and milling depth for positioning at the start and end of the cycle. Input range 0 to 99999.9999; alternatively PREDEF


RULED SURFACE (Cycle 231, DIN/ISO: G231)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. From the current position, the TNC positions the tool in a linear 3-D movement to the starting point 1.
  2. The tool subsequently advances to the end point 2 at the programmed feed rate for milling.
  3. From this point, the tool moves at rapid traverse FMAX by the tool diameter in the positive tool axis direction, and then back to starting point 1.
  4. At the starting point 1 the TNC moves the tool back to the last traversed Z value.
  5. Then the TNC moves the tool in all three axes from point 1 in the direction of point 4 to the next line.
  6. From this point, the tool moves to the end point on this pass. The TNC calculates the end point from point 2 and a movement in the direction of point 3.
  7. Multipass milling is repeated until the programmed surface has been completed.
  8. At the end of the cycle, the tool is positioned above the highest programmed point in the spindle axis, offset by the tool diameter.
Further Informations:
> Cutting motion


Cutting motion

The starting point, and therefore the milling direction, is selectable because the TNC always moves from point 1 to point 2 and in the total movement from point 1 / 2 to point 3 / 4. You can program point 1 at any corner of the surface to be machined.

    If you are using an end mill for the machining operation, you can optimize the surface finish in the following ways:

  • A shaping cut (spindle-axis coordinate of point 1 greater than spindle-axis coordinate of point 2) for slightly inclined surfaces.

  • A drawing cut (spindle-axis coordinate of point 1 smaller than spindle-axis coordinate of point 2) for steep surfaces.

  • When milling twisted surfaces, program the main cutting direction (from point 1 to point 2) parallel to the direction of the steeper inclination.

    If you are using a spherical cutter for the machining operation, you can optimize the surface finish in the following way:

  • When milling twisted surfaces, program the main cutting direction (from point 1 to point 2) perpendicular to the direction of the steepest inclination.


Please note while programming:

From the current position, the TNC positions the tool in a linear 3-D movement to the starting point 1. Pre-position the tool in such a way that no collision with the workpiece or the fixtures can occur.

The TNC moves the tool with radius compensation R0 to the programmed positions.

If required, use a center-cut end mill (ISO 1641).

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Starting point in 1st axis Q225 (absolute): Starting point coordinate of the surface to be multipass-milled in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Starting point in 2nd axis Q226 (absolute): Starting point coordinate of the surface to be multipass-milled in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Starting point in 3rd axis Q227 (absolute): Starting point coordinate of the surface to be multipass-milled in the tool axis. Input range ‑99999.9999 to 99999.9999

2nd point in 1st axis Q228 (absolute): End point coordinate of the surface to be multipass-milled in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd point in 2nd axis Q229 (absolute): End point coordinate of the surface to be multipass-milled in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd point in 3rd axis Q230 (absolute): End point coordinate of the surface to be multipass-milled in the spindle axis. Input range ‑99999.9999 to 99999.9999

3rd point in 1st axis Q231 (absolute): Coordinate of point 3 in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

3rd point in 2nd axis Q232 (absolute): Coordinate of point 3 in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

3rd point in 3rd axis Q233 (absolute): Coordinate of point 3 in the spindle axis. Input range ‑99999.9999 to 99999.9999

Example: NC blocks
72 cycl def 231 ruled surface
Q225=+0 ;STARTING POINT 1ST AXIS
Q226=+5 ;STARTING POINT 2ND AXIS
Q227=-2 ;starting point 3rd axis
Q228=+100 ;2nd point 1st axis
Q229=+15 ;2nd point 2nd axis
Q230=+5 ;2nd point 3rd axis
Q231=+15 ;3rd point 1st axis
Q232=+125 ;3rd point 2nd axis
Q233=+25 ;3rd point 3rd axis
Q234=+15 ;4th point 1st axis
Q235=+125 ;4th point 2nd axis
Q236=+25 ;4th point 3rd axis
Q240=40 ;number of cuts
Q207=500 ;FEED RATE FOR MILLING

4th point in 1st axis Q234 (absolute): Coordinate of point 4 in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

4th point in 2nd axis Q235 (absolute): Coordinate of point 4 in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

4th point in 3rd axis Q236 (absolute): Coordinate of point 4 in the spindle axis. Input range ‑99999.9999 to 99999.9999

Number of cuts Q240: Number of passes to be made between points 1 and 4, 2 and 3. Input range 0 to 99999

Feed rate for milling Q207: Traversing speed of the tool in mm/min while milling. The TNC performs the first step at half the programmed feed rate. Input range 0 to 99999.999; alternatively FAUTO, fu, FZ


FACE MILLING (Cycle 232, DIN/ISO: G232)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

    Cycle 232 is used to face mill a level surface in multiple infeeds while taking the finishing allowance into account. Three machining strategies are available:

  • Strategy Q389=0: Meander machining, stepover outside the surface being machined
  • Strategy Q389=1: Meander machining, stepover within the surface being machined
  • Strategy Q389=2: Line-by-line machining, retraction and stepover at the positioning feed rate
  1. From the current position, the TNC positions the tool at rapid traverse FMAX to the starting point 1 using positioning logic: If the current position in the spindle axis is greater than the 2nd set-up clearance, the TNC positions the tool first in the machining plane and then in the spindle axis. Otherwise it first moves to the 2nd set-up clearance and then in the machining plane. The starting point in the machining plane is offset from the edge of the workpiece by the tool radius and the safety clearance to the side.
  2. The tool then moves in the spindle axis at the positioning feed rate to the first plunging depth calculated by the TNC.
  1. Strategy Q389=0
  3. The tool then advances to the end point 2 at the programmed feed rate for milling. The end point lies outside the surface. The TNC calculates the end point from the programmed starting point, the programmed length, the programmed safety clearance to the side and the tool radius.
  4. The TNC offsets the tool to the starting point in the next pass at the pre-positioning feed rate. The offset is calculated from the programmed width, the tool radius and the maximum path overlap factor.
  5. The tool then moves back in the direction of the starting point 1.
  6. The process is repeated until the programmed surface has been completed. At the end of the last pass, the tool plunges to the next machining depth.
  7. In order to avoid non-productive motions, the surface is then machined in reverse direction.
  8. The process is repeated until all infeeds have been machined. In the last infeed, simply the finishing allowance entered is milled at the finishing feed rate.
  9. At the end of the cycle, the tool is retracted at FMAX to the 2nd set-up clearance.
  1. Strategy Q389=1
  3. The tool then advances to the end point 2 at the programmed feed rate for milling. The end point lies within the surface. The TNC calculates the end point from the programmed starting point, the programmed length and the tool radius.
  4. The TNC offsets the tool to the starting point in the next pass at the pre-positioning feed rate. The offset is calculated from the programmed width, the tool radius and the maximum path overlap factor.
  5. The tool then moves back in the direction of the starting point 1. The motion to the next line occurs within the workpiece borders.
  6. The process is repeated until the programmed surface has been completed. At the end of the last pass, the tool plunges to the next machining depth.
  7. In order to avoid non-productive motions, the surface is then machined in reverse direction.
  8. The process is repeated until all infeeds have been machined. In the last infeed, simply the finishing allowance entered is milled at the finishing feed rate.
  9. At the end of the cycle, the tool is retracted at FMAX to the 2nd set-up clearance.
  1. Strategy Q389=2
  3. The tool then advances to the end point 2 at the programmed feed rate for milling. The end point lies outside the surface. The control calculates the end point from the programmed starting point, the programmed length, the programmed safety clearance to the side and the tool radius.
  4. The TNC positions the tool in the spindle axis to the set-up clearance over the current infeed depth, and then moves at the pre-positioning feed rate directly back to the starting point in the next line. The TNC calculates the offset from the programmed width, the tool radius and the maximum path overlap factor.
  5. The tool then returns to the current infeed depth and moves in the direction of the next end point 2.
  6. The milling process is repeated until the programmed surface has been completed. At the end of the last pass, the tool plunges to the next machining depth.
  7. In order to avoid non-productive motions, the surface is then machined in reverse direction.
  8. The process is repeated until all infeeds have been machined. In the last infeed, simply the finishing allowance entered is milled at the finishing feed rate.
  9. At the end of the cycle, the tool is retracted at FMAX to the 2nd set-up clearance.


Please note while programming:

Enter the 2nd set-up clearance in Q204 so that no collision with the workpiece or the fixtures can occur.

Danger of collision!

Enter in MP7441 bit 0 whether the TNC should output an error message (bit 0=0) or not (bit 0=1) if spindle rotation is not active when the cycle is called. The function also needs to be adapted by your machine manufacturer.


Cycle parameters

Machining strategy (0/1/2) Q389: Specify how the TNC is to machine the surface: 0: Meander machining, stepover at positioning feed rate outside the surface to be machined 1: Meander machining, stepover at feed rate for milling within the surface to be machined 2: Line-by-line machining, retraction and stepover at the positioning feed rate

Starting point in 1st axis Q225 (absolute): Starting point coordinate of the surface to be machined in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Starting point in 2nd axis Q226 (absolute): Starting point coordinate of the surface to be multipass-milled in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Starting point in 3rd axis Q227 (absolute): Coordinate of the workpiece surface used to calculate the infeeds. Input range ‑99999.9999 to 99999.9999

End point in 3rd axis Q386 (absolute): Coordinate in the spindle axis to which the surface is to be face milled. Input range ‑99999.9999 to 99999.9999

1st side length Q218 (incremental): Length of the surface to be machined in the reference axis of the working plane. Use the algebraic sign to specify the direction of the first milling path in reference to the starting point in the 1st axis. Input range ‑99999.9999 to 99999.9999

2nd side length Q219 (incremental): Length of the surface to be machined in the minor axis of the working plane. Use the algebraic sign to specify the direction of the first stepover in reference to the starting point in the 2nd axis. Input range ‑99999.9999 to 99999.9999

Maximum plunging depth Q202 (incremental): Maximum amount that the tool is advanced each time. The TNC calculates the actual plunging depth from the difference between the end point and starting point of the tool axis (taking the finishing allowance into account), so that uniform plunging depths are used each time. Input range 0 to 99999.9999

Allowance for floor Q369 (incremental): Distance used for the last infeed. Input range 0 to 99999.9999

Max. path overlap factor Q370: Maximum stepover factor k. The TNC calculates the actual stepover from the second side length (Q219) and the tool radius so that a constant stepover is used for machining. If you have entered a radius R2 in the tool table (e.g. tooth radius when using a face-milling cutter), the TNC reduces the stepover accordingly. Input range 0.1 to 1.9999; alternatively PREDEF
Example: NC blocks
71 cycl def 232 FACE MILLING
Q389=2 ;STRATEGY
Q225=+10 ;STARTING POINT 1ST AXIS
Q226=+12 ;STARTING POINT 2ND AXIS
Q227=+2.5 ;STARTING POINT 3RD AXIS
Q386=-3 ;END POINT IN 3RD AXIS
Q218=150 ;1ST SIDE LENGTH
Q219=75 ;2ND SIDE LENGTH
Q202=2 ;MAX. PLUNGING DEPTH
Q369=0.5 ;ALLOWANCE FOR FLOOR
Q370=1 ;MAX. OVERLAP
Q207=500 ;FEED RATE FOR MILLING
Q385=800 ;FEED RATE FOR FINISHING
Q253=2000 ;F PRE-POSITIONING
Q200=2 ;SET-UP CLEARANCE
Q357=2 ;CLEARANCE TO SIDE
Q204=2 ;2ND SET-UP CLEARANCE

Feed rate for milling Q207: Traversing speed of the tool in mm/min during milling. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for finishing Q385: Traversing speed of the tool in mm/min while milling the last infeed. Input range 0 to 99999.9999; alternatively FAUTO, fu, FZ

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min when approaching the starting position and when moving to the next pass. If you are moving the tool transversely to the material (Q389=1), the TNC moves the tool at the feed rate for milling Q207. Input range 0 to 99999.9999; alternatively Fmax, FAUTO, PREDEF

Set-up clearance Q200 (incremental): Distance between tool tip and the starting position in the tool axis. If you are milling with machining strategy Q389=2, the TNC moves the tool at the set-up clearance over the current plunging depth to the starting point of the next pass. Input range 0 to 99999.9999; alternatively PREDEF

Clearance to side Q357 (incremental): Safety clearance to the side of the workpiece when the tool approaches the first plunging depth, and distance at which the stepover occurs if the machining strategy Q389=0 or Q389=2 is used. Input range 0 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF


Programming examples

Further Informations:
> Example: Multipass milling


Example: Multipass milling

0 begin pgm c230 mm |
1 blk form 0.1 z x+0 y+0 z+0 | Definition of workpiece blank
2 blk form 0.2 x+100 y+100 z+40 |
3 tool def 1 l+0 r+5 | Tool definition
4 tool call 1 z s3500 | Tool call
5 l z+250 r0 fmax | Retract the tool
6 cycl def 230 MULTIPASS MILLING | Cycle definition: MULTIPASS MILLING
Q225=+0 ;STARTING POINT 1ST AXIS |
Q226=+0 ;STARTING POINT 2ND AXIS |
Q227=+35 ;STARTING POINT 3RD AXIS |
Q218=100 ;1ST SIDE LENGTH |
Q219=100 ;2ND SIDE LENGTH |
Q240=25 ;number of cuts |
Q206=250 ;FEED RATE FOR PLNGNG |
Q207=400 ;FEED RATE FOR MILLING |
Q209=150 ;STEPOVER FEED RATE |
Q200=2 ;SET-UP CLEARANCE |
7 l x+-25 y+0 r0 fmax m3 | Pre-position near the starting point
8 cycl call | Cycle call
9 l z+250 r0 fmax m2 | Retract the tool, end program
10 end pgm c230 mm |


Cycles: Coordinate Transformations

Further Informations:
> Fundamentals
> DATUM SHIFT (Cycle 7, DIN/ISO: G54)
> DATUM SHIFT with datum tables (Cycle 7, DIN/ISO: G53)
> DATUM SETTING (Cycle 247, DIN/ISO: G247)
> MIRROR IMAGE (Cycle 8, DIN/ISO: G28)
> ROTATION (Cycle 10, DIN/ISO: G73)
> SCALING (Cycle 11, DIN/ISO: G72)
> AXIS-SPECIFIC SCALING (Cycle 26)
> WORKING PLANE (Cycle 19, DIN/ISO: G80, Software Option 1)
> Programming examples


Fundamentals

Further Informations:
> Overview
> Effect of coordinate transformations


Overview

Once a contour has been programmed, you can position it on the workpiece at various locations and in different sizes through the use of coordinate transformations. The TNC provides the following coordinate transformation cycles:

Cycle | Soft key | Page
7 DATUM SHIFT For shifting contours directly within the program or from datum tables |  | DATUM SHIFT (Cycle 7, DIN/ISO: G54)
247 DATUM SETTING Datum setting during program run |  | DATUM SETTING (Cycle 247, DIN/ISO: G247)
8 MIRROR IMAGE Mirroring contours |  | MIRROR IMAGE (Cycle 8, DIN/ISO: G28)
10 ROTATION Rotating contours in the working plane |  | ROTATION (Cycle 10, DIN/ISO: G73)
11 SCALING For increasing or reducing the size of contours |  | SCALING (Cycle 11, DIN/ISO: G72)
26 AXIS-SPECIFIC SCALING FACTOR For increasing or reducing the size of contours with scaling factors for each axis |  | AXIS-SPECIFIC SCALING (Cycle 26)
19 WORKING PLANE Machining in tilted coordinate system on machines with swivel heads and/or rotary tables |  | WORKING PLANE (Cycle 19, DIN/ISO: G80, Software Option 1)


Effect of coordinate transformations

Beginning of effect: A coordinate transformation becomes effective as soon as it is defined—it is not called separately. It remains in effect until it is changed or canceled.

    To cancel coordinate transformations:

  • Define cycles for basic behavior with a new value, such as scaling factor 1.0
  • Execute a miscellaneous function M2, M30, or an END PGM block (depending on MP7300)
  • Select a new program
  • Program miscellaneous function M142 "Erasing modal program information"


DATUM SHIFT (Cycle 7, DIN/ISO: G54)

Further Informations:
> Effect
> Cycle parameters


Effect

A DATUM SHIFT allows machining operations to be repeated at various locations on the workpiece.

When the DATUM SHIFT cycle is defined, all coordinate data is based on the new datum. The TNC displays the datum shift in each axis in the additional status display. Input of rotary axes is also permitted.

Reset

  • Program a datum shift to the coordinates X=0, Y=0 etc. directly with a cycle definition.
  • Use the TRANS DATUM RESET function.
  • Call a datum shift to the coordinates
    X=0; Y=0 etc. from the datum table.

Graphics

If you program a new BLK FORM after a datum shift, you can use MP7310 to determine whether the BLK FORM is referenced to the current datum or to the original datum. Referencing a new BLK FORM to the current datum enables you to display each part in a program in which several pallets are machined.


Cycle parameters

Example: NC blocks
13 cycl def 7.0 DATUM SHIFT
14 cycl def 7.1 x+60
16 cycl def 7.3 z-5
15 cycl def 7.2 y+40

Datum shift: Enter the coordinates of the new datum. Absolute values are referenced to the manually set workpiece datum. Incremental values are always referenced to the datum which was last valid—this can be a datum which has already been shifted. Input range: Up to six NC axes, each from –99999.9999 to 99999.9999


DATUM SHIFT with datum tables (Cycle 7, DIN/ISO: G53)

Further Informations:
> Effect
> Please note while programming:
> Cycle parameters
> Selecting a datum table in the part program
> Editing the datum table in the Programming and Editing mode of operation
> Editing a datum table in a Program Run operating mode
> Transferring the actual values into the datum table
> Configuring the datum table
> To exit a datum table


Effect

    Datum tables are used for:

  • Frequently recurring machining sequences at various locations on the workpiece
  • Frequent use of the same datum shift

Within a program, you can either program datum points directly in the cycle definition or call them from a datum table.

Further Informations:
> Reset
> Graphic
> Status displays


Reset
  • Call a datum shift to the coordinates
    X=0; Y=0 etc. from the datum table.
  • Execute a datum shift to the coordinates X=0, Y=0 etc. directly with a cycle definition.
  • Use the TRANS DATUM RESET function.


Graphic

If you program a new BLK FORM after a datum shift, you can use MP7310 to determine whether the BLK FORM is referenced to the current datum or to the original datum. Referencing a new BLK FORM to the current datum enables you to display each part in a program in which several pallets are machined.


Status displays

    In the additional status display, the following data from the datum table are shown:

  • Name and path of the active datum table
  • Active datum number
  • Comment from the DOC column of the active datum number


Please note while programming:

Danger of collision!

Datums from a datum table are always and exclusively referenced to the current datum (preset).

MP7475, which earlier defined whether datums are referenced to the machine datum or the workpiece datum, now serves only as a safety measure. If MP7475 = 1, the TNC outputs an error message if a datum shift is called from a datum table.

Datum tables from the TNC 4xx whose coordinates are referenced to the machine datum (MP7475 = 1) cannot be used in the iTNC 530.

If you are using datum shifts with datum tables, then use the SEL TABLE function to activate the desired datum table from the NC program.

If you work without SEL TABLE, then you must activate the desired datum table before the test run or the program run. (This applies also to the programming graphics).

  • Use the file management to select the desired table for a test run in the Test Run operating mode: The table receives the status S.
  • Use the file management in a program run mode to select the desired table for program run: The table receives the status M.

The coordinate values from datum tables are only effective with absolute coordinate values.

New lines can only be inserted at the end of the table.


Cycle parameters

Example: NC blocks
77 cycl def 7.0 DATUM SHIFT
78 cycl def 7.1 #5

Datum shift: Enter the number of the datum from the datum table or a Q parameter. If you enter a Q parameter, the TNC activates the datum number entered in the Q parameter. Input range 0 to 9999


Selecting a datum table in the part program

With the SEL TABLE function you select the table from which the TNC takes the datums:

Select the functions for program call: Press the PGM CALL key

Press the DATUM TABLE soft key

Press the Window selection soft key: The TNC superimposes a window where you can select the desired datum table

Select the desired datum table with the arrow keys or by mouse click and confirm by pressing ENT: The TNC enters the complete path name in the SEL TABLE block

Conclude this function with the END key

Alternatively you can also enter the table name or the complete path name of the table to be called directly via the keyboard.

Program a SEL TABLE block before Cycle 7 Datum Shift.

A datum table selected with SEL TABLE remains active until you select another datum table with SEL TABLE or through PGM MGT.

You can define datum tables and datum numbers in an NC block with the TRANS DATUM TABLE function (see Conversational Programming User's Manual).


Editing the datum table in the Programming and Editing mode of operation

After you have changed a value in a datum table, you must save the change with the ENT key. Otherwise the change might not be included during program run.

Select the datum table in the Programming and Editing mode of operation.

Call the file manager: Press the PGM MGT key

Display the datum tables: Press the SELECT TYPE and SHOW .D soft keys

Select the desired table or enter a new file name

Edit the file The soft-key row comprises the following functions for editing:

Function | Soft key
Select beginning of table |
Select end of table |
Go to previous page |
Go to next page |
Insert line (only possible at the end of table) |
Delete line |
Confirm the entered line and go to the beginning of the next line |
Add the entered number of lines (datums) to the end of the table |


Editing a datum table in a Program Run operating mode

In a program run mode you can select the active datum table. Press the DATUM TABLE soft key. You can then use the same editing functions as in the Programming and Editing mode of operation.


Transferring the actual values into the datum table

You can enter the current tool position or the last probed position in the datum table by pressing the "actual-position-capture" key:

  • Place the text box on the line of the column in which you want to enter the position

Select the actual-position-capture function: The TNC opens a pop-up window that asks whether you want to enter the current tool position or the last probed values

Select the desired function with the arrow keys and confirm your selection with the ENT key

To enter the values in all axes, press the All values soft key

To enter the value in the axis where the text box is located, press the Current value soft key


Configuring the datum table

In the second and third soft-key rows you can define for each datum table the axes for which you wish to set the datums. In the standard setting all of the axes are active. If you wish to exclude an axis, set the corresponding soft key to OFF. The TNC then deletes that column from the datum table.

If you do not wish to define a datum for an active axis, press the no ent key. The TNC then enters a dash in that column.


To exit a datum table

Select a different type of file in file management and choose the desired file.


DATUM SETTING (Cycle 247, DIN/ISO: G247)

Further Informations:
> Effect
> Please note before programming:
> Cycle parameters


Effect

With the DATUM SETTING cycle you can activate as the new datum a preset defined in a preset table.

After a DATUM SETTING cycle definition, all of the coordinate inputs and datum shifts (absolute and incremental) are referenced to the new preset.

Status display

In the status display the TNC shows the active preset number behind the datum symbol.


Please note before programming:

When activating a datum from the preset table, the TNC resets the active datum shift.

The TNC sets the preset only in the axes that are defined with values in the preset table. The datums of axes marked with — remain unchanged.

If you activate preset number 0 (line 0), then you activate the datum that you last set in a manual operating mode.

Cycle 247 is not functional in Test Run mode.


Cycle parameters

Example: NC blocks
13 cycl def 247 DATUM SETTING
Q339=4 ;DATUM NUMBER

Number for datum?: Enter the number of the datum to be activated from the preset table. Input range 0 to 65535


MIRROR IMAGE (Cycle 8, DIN/ISO: G28)

Further Informations:
> Effect
> Please note while programming:
> Cycle parameters


Effect

The TNC can machine the mirror image of a contour in the working plane.

The mirroring cycle becomes effective as soon as it is defined in the program. It is also effective in the Positioning with MDI mode of operation. The active mirrored axes are shown in the additional status display.

  • If you mirror only one axis, the machining direction of the tool is reversed (except in fixed cycles).
  • If you mirror two axes, the machining direction remains the same.

    The result of the mirroring depends on the location of the datum:

  • If the datum lies on the contour to be mirrored, the element simply flips over.
  • If the datum lies outside the contour to be mirrored, the element also "jumps" to another location.

Reset

Program the MIRROR IMAGE cycle once again with NO ENT.


Please note while programming:

If you mirror only one axis, the machining direction is reversed for the milling cycles (Cycles 2xx). Exception: Cycle 208, in which the direction defined in the cycle applies.


Cycle parameters

Example: NC blocks
79 cycl def 8.0 mirror image
80 cycl def 8.1 x y u

Mirrored axis?: Enter the axis to be mirrored. You can mirror all axes—including rotary axes—with the exception of the spindle axis and its associated auxiliary axis. You can enter up to three axes. Input range: Up to 3 NC axes X, Y, Z, U, V, W, A, B, C


ROTATION (Cycle 10, DIN/ISO: G73)

Further Informations:
> Effect
> Please note while programming:
> Cycle parameters


Effect

The TNC can rotate the coordinate system about the active datum in the working plane within a program.

The ROTATION cycle becomes effective as soon as it is defined in the program. It is also effective in the Positioning with MDI mode of operation. The active rotation angle is shown in the additional status display.

    Reference axis for the rotation angle:

  • X/Y plane: X axis
  • Y/Z plane: Y axis
  • Z/X plane: Z axis

Reset

Program the ROTATION cycle once again with a rotation angle of 0°.


Please note while programming:

An active radius compensation is canceled by defining Cycle 10 and must therefore be reprogrammed, if necessary.

After defining Cycle 10, you must move both axes of the working plane to activate rotation for all axes.


Cycle parameters

Example: NC blocks
12 call lbl 1
13 cycl def 7.0 DATUM SHIFT
14 cycl def 7.1 x+60
15 cycl def 7.2 y+40
16 cycl def 10.0 ROTATION
17 cycl def 10.1 rot+35
18 call lbl 1

Rotation: Enter the rotation angle in degrees (°). Input range –360.000° to +360.000° (absolute or incremental)


SCALING (Cycle 11, DIN/ISO: G72)

Further Informations:
> Effect
> Cycle parameters


Effect

The TNC can increase or reduce the size of contours within a program, enabling you to program shrinkage and oversize allowances.

The SCALING FACTOR becomes effective as soon as it is defined in the program. It is also effective in the Positioning with MDI mode of operation. The active scaling factor is shown in the additional status display.

    The scaling factor has an effect on

  • the working plane, or on all three coordinate axes at the same time (depending on MP7410)
  • dimensions in cycles
  • the parallel axes U,V,W

Prerequisite

It is advisable to set the datum to an edge or a corner of the contour before enlarging or reducing the contour.

Enlargement: SCL greater than 1 (up to 99.999 999)

Reduction: SCL less than 1 (down to 0.000 001)

Reset

Program the SCALING cycle once again with a scaling factor of 1.


Cycle parameters

Example: NC blocks
11 call lbl 1
12 cycl def 7.0 DATUM SHIFT
13 cycl def 7.1 x+60
14 cycl def 7.2 y+40
15 cycl def 11.0 SCALING
16 cycl def 11.1 scl 0.75
17 call lbl 1

Scaling factor?: Enter the scaling factor SCL. The TNC multiplies the coordinates and radii by the SCL factor (as described under "Effect" above). Input range: 0.000000 to 99.999999


AXIS-SPECIFIC SCALING (Cycle 26)

Further Informations:
> Effect
> Please note while programming:
> Cycle parameters


Effect

With Cycle 26 you can account for shrinkage and oversize factors for each axis.

The SCALING FACTOR becomes effective as soon as it is defined in the program. It is also effective in the Positioning with MDI mode of operation. The active scaling factor is shown in the additional status display.

Reset

Program the SCALING cycle once again with a scaling factor of 1 for the same axis.


Please note while programming:

Coordinate axes sharing coordinates for arcs must be enlarged or reduced by the same factor.

You can program each coordinate axis with its own axis-specific scaling factor.

In addition, you can enter the coordinates of a center for all scaling factors.

The size of the contour is enlarged or reduced with reference to the center, and not necessarily (as in Cycle 11 SCALING) with reference to the active datum.


Cycle parameters

Example: NC blocks
25 call lbl 1
26 cycl def 26.0 AXIS-SPECIFIC SCALING
27 cycl def 26.1 x 1.4 y 0.6 ccx+15 ccy+20
28 call lbl 1

Axis and scaling factor: Select the coordinate axis/axes by soft key and enter the factor(s) involved in enlarging or reducing. Input range: 0.000000 to 99.999999

Center coordinates: Enter the center of the axis-specific enlargement or reduction. Input range ‑99999.9999 to 99999.9999


WORKING PLANE (Cycle 19, DIN/ISO: G80, Software Option 1)

Further Informations:
> Effect
> Please note while programming:
> Cycle parameters
> Reset
> Positioning the axes of rotation
> Position display in the tilted system
> Workspace monitoring
> Positioning in a tilted coordinate system
> Combining coordinate transformation cycles
> Automatic workpiece measurement in the tilted system
> Procedure for working with Cycle 19 WORKING PLANE


Effect

    In Cycle 19 you define the position of the working plane—i.e. the position of the tool axis referenced to the machine coordinate system—by entering tilt angles. There are two ways to determine the position of the working plane:

  • Enter the position of the rotary axes directly.

  • Describe the position of the working plane using up to 3 rotations (spatial angle) of the fixed machine coordinate system. The required spatial angle can be calculated by cutting a perpendicular line through the tilted working plane and considering it from the axis around which you wish to tilt. With two spatial angles, every tool position in space can be defined exactly.

Note that the position of the tilted coordinate system, and therefore also all movements in the tilted system, are dependent on your description of the tilted plane.

If you program the position of the working plane via spatial angles, the TNC will calculate the required angle positions of the tilted axes automatically and will store these in the parameters Q120 (A axis) to Q122 (C axis).

Danger of collision!

Depending on your machine configuration, two mathematical solutions (axis positions) are possible for a spatial angle definition. Conduct appropriate tests on your machine to find out which axis position the TNC software selects in each case.

If the DCM software option is available to you, the axis position can be displayed in the PROGRAM + KINEMATICS view during test run (see User’s Manual for Conversational Programming, Dynamic collision monitoring).

The axes are always rotated in the same sequence for calculating the tilt of the plane: The TNC first rotates the A axis, then the B axis, and finally the C axis.

Cycle 19 becomes effective as soon as it is defined in the program. As soon as you move an axis in the tilted system, the compensation for this specific axis is activated. You must move all axes to activate compensation for all axes.

If you set the function Tilting program run to Active in the Manual Operation mode, the angular value entered in this menu is overwritten by Cycle 19 WORKING PLANE.


Please note while programming:

The functions for tilting the working plane are interfaced to the TNC and the machine tool by the machine tool builder. For certain swivel heads and tilting tables the machine tool builder specifies whether the entered angles are interpreted as coordinates of the rotary axes or as mathematical angles of a tilted plane. Refer to your machine manual.

Because nonprogrammed rotary axis values are interpreted as unchanged, you should always define all three spatial angles, even if one or more angles are at zero.

The working plane is always tilted around the active datum.

If you use Cycle 19 when M120 is active, the TNC automatically rescinds the radius compensation, which also rescinds the M120 function.

Danger of collision!

Ensure that the last defined angle is smaller than 360°.


Cycle parameters

Rotary axis and tilt angle?: Enter the axes of rotation together with the associated tilt angles. The rotary axes A, B and C are programmed using soft keys. Input range ‑360.000 to 360.000

If the TNC automatically positions the rotary axes, you can enter the following parameters:

Feed rate? F=: Traversing speed of the rotary axis during automatic positioning. Input range 0 to 99999.999

Set-up clearance? (incremental): The TNC positions the swivel head so that the position that results from the extension of the tool by the set-up clearance does not change relative to the workpiece. Input range 0 to 99999.9999

Danger of collision!

Please note that the set-up clearance in Cycle 19 does not refer to the upper edge of the workpiece (as is the case in the fixed cycles) but rather to the active datum.


Reset

To cancel the tilt angles, redefine the WORKING PLANE cycle and enter an angular value of 0° for all axes of rotation. You must then program the WORKING PLANE cycle once again and respond to the dialog question with the NO ENT key to disable the function.


Positioning the axes of rotation

The machine tool builder determines whether Cycle 19 positions the axes of rotation automatically or whether they must be positioned manually in the program. Refer to your machine manual.

Further Informations:
> Manual positioning of rotary axes
> Automatic positioning of rotary axes


Manual positioning of rotary axes

If the rotary axes are not positioned automatically in Cycle 19, you must position them in a separate L block after the cycle definition.

If you use axis angles, you can define the axis values right in the L block. If you use spatial angles, then use the Q parameters Q120 (A-axis value), Q121 (B-axis value) and Q122 (C-axis value), which are described by Cycle 19.

Example NC blocks:
10 l z+100 r0 fmax |
11 l x+25 y+10 r0 fmax |
12 cycl def 19.0 WORKING PLANE | Define the spatial angle for calculation of the compensation
13 cycl def 19.1 A+0 B+45 C+0 |
14 l A+Q120 C+q122 r0 f1000 | Position the rotary axes by using values calculated by Cycle 19
15 l z+80 r0 fmax | Activate compensation for the spindle axis
16 l x-8.5 y-10 r0 fmax | Activate compensation for the working plane

For manual positioning, always use the rotary axis positions stored in Q parameters Q120 to Q122.

Avoid using functions, such as M94 (modulo rotary axes), in order to avoid discrepancies between the actual and nominal positions of rotary axes in multiple definitions.


Automatic positioning of rotary axes

    If the rotary axes are positioned automatically in Cycle 19:

  • The TNC can position only controlled axes
  • In order for the tilted axes to be positioned, you must enter a feed rate and a set-up clearance in addition to the tilting angles, during cycle definition.
  • Use only preset tools (the full tool length must be defined).
  • The position of the tool tip as referenced to the workpiece surface remains nearly unchanged after tilting
  • The TNC performs the tilt at the last programmed feed rate. The maximum feed rate that can be reached depends on the complexity of the swivel head or tilting table.
Example NC blocks:
10 l z+100 r0 fmax |
11 l x+25 y+10 r0 fmax |
12 cycl def 19.0 WORKING PLANE | Define the angle for calculation of the compensation
13 cycl def 19.1 A+0 B+45 C+0 f5000 setup50 | Also define the feed rate and the clearance
14 l z+80 r0 fmax | Activate compensation for the spindle axis
15 l x-8.5 y-10 r0 fmax | Activate compensation for the working plane


Position display in the tilted system

On activation of Cycle 19, the displayed positions (ACTL and NOML) and the datum indicated in the additional status display are referenced to the tilted coordinate system. The positions displayed immediately after cycle definition might not be the same as the coordinates of the last programmed position before Cycle 19.


Workspace monitoring

The TNC monitors only those axes in the tilted coordinate system that are moved. If any of the software limit switches is traversed the TNC will display an error message.


Positioning in a tilted coordinate system

With the miscellaneous function M130 you can move the tool, while the coordinate system is tilted, to positions that are referenced to the non-tilted coordinate system.

Positioning movements with straight lines that are referenced to the machine coordinate system (blocks with M91 or M92) can also be executed in a tilted working plane. Constraints:

  • Positioning is without length compensation.
  • Positioning is without machine geometry compensation.
  • Tool radius compensation is not permitted.


Combining coordinate transformation cycles

When combining coordinate transformation cycles, always make sure the working plane is swiveled around the active datum. You can program a datum shift before activating Cycle 19. In this case, you are shifting the machine-based coordinate system.

If you program a datum shift after having activated Cycle 19, you are shifting the tilted coordinate system.

Important: When resetting the cycles, use the reverse sequence used for defining them:

1. Activate the datum shift

2. Activate the tilting function

3. Activate rotation

...

Workpiece machining

...

1. Reset the rotation

2. Reset the tilting function

3. Reset the datum shift


Automatic workpiece measurement in the tilted system

The TNC measuring cycles enable you to have the TNC measure a workpiece in a tilted system automatically. The TNC stores the measured data in Q parameters for further processing (for example, for printout).


Procedure for working with Cycle 19 WORKING PLANE

1 Write the program

  • Define the tool (not required if TOOL.T is active), and enter the full tool length.

  • Call the tool

  • Retract the tool in the tool axis to a position where there is no danger of collision with the workpiece or clamping devices during tilting.

  • If required, position the rotary axis or axes with an L block to the appropriate angular value(s) (depending on a machine parameter).

  • Activate datum shift if required.

  • Define Cycle 19 WORKING PLANE; enter the angular values for the tilt axes

  • Traverse all principal axes (X, Y, Z) to activate compensation.

  • Write the program as if the machining process were to be executed in a non-tilted plane.

  • If required, define Cycle 19 WORKING PLANE with other angular values to execute machining in a different axis position. In this case, it is not necessary to reset Cycle 19. You can define the new angular values directly.

  • Reset Cycle 19 WORKING PLANE; program 0° for all tilt axes.

  • Disable the WORKING PLANE function; redefine Cycle 19 and answer the dialog question with NO ENT.

  • Reset datum shift if required.

  • Position the tilt axes to the 0° position if required.

2 Clamp the workpiece

3 Preparations in the operating mode Positioning with Manual Data Input

Pre-position the rotary axis/axes to the corresponding angular value(s) for setting the datum. The angular value depends on the selected reference plane on the workpiece.

4 Preparations in the operating mode Manual Operation

Use the 3-D ROT soft key to set the function TILT WORKING PLANE to ACTIVE in the Manual Operating mode. For open loop axes, enter the angular values for the rotary axes into the menu.

If the axes are not controlled, the angular values entered in the menu must correspond to the actual position(s) of the rotary axis or axes, respectively. The TNC will otherwise calculate a wrong datum.

5 Datum setting

  • Manually by touching the workpiece with the tool in the untilted coordinate system.
  • Controlled with a HEIDENHAIN 3-D touch probe (see the Touch Probe Cycles User's Manual, chapter 2).
  • Automatically with a HEIDENHAIN 3-D touch probe (see the Touch Probe Cycles User's Manual, chapter 3).

6 Start the part program in the operating mode Program Run, Full Sequence

7 Manual Operation mode

Use the 3-D ROT soft key to set the TILT WORKING PLANE function to INACTIVE. Enter an angular value of 0° for each rotary axis in the menu.


Programming examples

Further Informations:
> Example: Coordinate transformation cycles


Example: Coordinate transformation cycles

    Program sequence

  • Program the coordinate transformations in the main program
  • Machining within a subprogram
0 begin pgm COTRANS mm |
1 blk form 0.1 z x+0 y+0 z-20 | Definition of workpiece blank
2 blk form 0.2 x+130 y+130 z+0 |
3 tool def 1 l+0 r+1 | Tool definition
4 tool call 1 z s4500 | Tool call
5 l z+250 r0 fmax | Retract the tool
6 cycl def 7.0 DATUM SHIFT | Shift datum to center
7 cycl def 7.1 x+65 |
8 cycl def 7.2 y+65 |
9 call lbl 1 | Call milling operation
10 lbl 10 | Set label for program section repeat
11 cycl def 10.0 ROTATION | Rotate by 45° (incremental)
12 cycl def 10.1 irot+45 |
13 call lbl 1 | Call milling operation
14 call lbl 10 rep 6/6 | Return jump to LBL 10; repeat the milling operation six times
15 cycl def 10.0 ROTATION | Reset the rotation
16 cycl def 10.1 rot+0 |
17 trans datum reset | Reset the datum shift
18 l z+250 r0 fmax m2 | Retract the tool, end program
19 lbl 1 | Subprogram 1
20 l x+0 y+0 r0 fmax | Define milling operation
21 l z+2 r0 fmax m3 |
22 l z-5 r0 f200 |
23 l x+30 rl |
24 l iy+10 |
25 rnd r5 |
26 l ix+20 |
27 l ix+10 iy-10 |
28 rnd r5 |
29 l ix-10 iy-10 |
30 l ix-20 |
31 l iy+10 |
32 l x+0 y+0 r0 f5000 |
33 l z+20 r0 fmax |
34 lbl 0 |
35 end pgm COTRANS mm |


Cycles: Special Functions

Further Informations:
> Fundamentals
> DWELL TIME (Cycle 9, DIN/ISO: G04)
> PROGRAM CALL (Cycle 12, DIN/ISO: G39)
> SPINDLE ORIENTATION (Cycle 13, DIN/ISO: G36)
> TOLERANCE (Cycle 32, DIN/ISO: G62)
> ENGRAVING (Cycle 225, DIN/ISO: G225)
> INTERPOLATION TURNING (Software Option, Cycle 290, DIN/ISO: G290)


Overview

The TNC provides various cycles for the following special purposes:

Cycle | Soft key | Page
9 DWELL TIME |  | DWELL TIME (Cycle 9, DIN/ISO: G04)
12 PROGRAM CALL |  | PROGRAM CALL (Cycle 12, DIN/ISO: G39)
13 SPINDLE ORIENTATION |  | SPINDLE ORIENTATION (Cycle 13, DIN/ISO: G36)
32 TOLERANCE |  | TOLERANCE (Cycle 32, DIN/ISO: G62)
225 ENGRAVING of texts |  | THREE-D CONTOUR TRAIN (Cycle 276, DIN/ISO: G276)
290 INTERPOLATION TURNING (software option) |  | INTERPOLATION TURNING (Software Option, Cycle 290, DIN/ISO: G290)


DWELL TIME (Cycle 9, DIN/ISO: G04)

Further Informations:
> Function
> Cycle parameters


Function

Example: NC blocks
89 cycl def 9.0 DWELL TIME
90 cycl def 9.1 dwell 1.5

This causes the execution of the next block within a running program to be delayed by the programmed DWELL TIME. A dwell time can be used for such purposes as chip breaking.

The cycle becomes effective as soon as it is defined in the program. Modal conditions such as spindle rotation are not affected.


Cycle parameters

Dwell time in seconds: Enter the dwell time in seconds. Input range: 0 to 3600 s (1 hour) in steps of 0.001 seconds


PROGRAM CALL (Cycle 12, DIN/ISO: G39)

Further Informations:
> Cycle function
> Please note while programming:
> Cycle parameters


Cycle function

Routines that you have programmed (such as special drilling cycles or geometrical modules) can be written as main programs. These can then be called like fixed cycles.


Please note while programming:

The program you are calling must be stored on the hard disk of your TNC.

If the program you are defining to be a cycle is located in the same directory as the program you are calling it from, you need only enter the program name.

If the program you are defining to be a cycle is not located in the same directory as the program you are calling it from, you must enter the complete path, for example TNC:\KLAR35\FK1\50.H.

If you want to define a DIN/ISO program to be a cycle, enter the file type .I behind the program name.

As a rule, Q parameters are globally effective when called with Cycle 12. So please note that changes to Q parameters in the called program can also influence the calling program.


Cycle parameters

Example: Designate program 50 as a cycle and call it with M99
55 cycl def 12.0 pgm call
56 cycl def 12.1 pgm TNC:\KLAR35\FK1\50.H
57 l x+20 y+50 fmax m99

Program name: Enter the name of the program you want to call and, if necessary, the directory it is located in. A maximum of 254 characters can be entered.

    The following functions can be used to call the defined program:

  • CYCL CALL (separate block), or
  • CYCL CALL POS (separate block) or
  • M99 (blockwise) or
  • M89 (executed after every positioning block)


SPINDLE ORIENTATION (Cycle 13, DIN/ISO: G36)

Further Informations:
> Cycle function
> Please note while programming:
> Cycle parameters


Cycle function

Example: NC blocks
93 cycl def 13.0 ORIENTATION
94 cycl def 13.1 ANGLE 180

Machine and TNC must be specially prepared by the machine tool builder for use of this cycle.

The TNC can control the machine tool spindle and rotate it to a given angular position.

    Oriented spindle stops are required for

  • Tool changing systems with a defined tool change position
  • Orientation of the transmitter/receiver window of HEIDENHAIN 3-D touch probes with infrared transmission

The angle of orientation defined in the cycle is positioned to by entering M19 or M20 (depending on the machine).

If you program M19 or M20 without having defined Cycle 13, the TNC positions the machine tool spindle to an angle that has been set by the machine manufacturer (see your machine manual).


Please note while programming:

Cycle 13 is used internally for Cycles 202, 204 and 209. Please note that, if required, you must program Cycle 13 again in your NC program after one of the machining cycles mentioned above.


Cycle parameters

Angle of orientation: Enter the angle referenced to the reference axis of the working plane. Input range: 0.0000° to 360.0000°


TOLERANCE (Cycle 32, DIN/ISO: G62)

Further Informations:
> Cycle function
> Influences of the geometry definition in the CAM system
> Please note while programming:
> Cycle parameters


Cycle function

Machine and TNC must be specially prepared by the machine tool builder for use of this cycle. The cycle may be locked.

With the entries in Cycle 32 you can influence the result of HSC machining with respect to accuracy, surface definition and speed, inasmuch as the TNC has been adapted to the machine’s characteristics.

The TNC automatically smoothens the contour between two path elements (whether compensated or not). The tool has constant contact with the workpiece surface and therefore reduces wear on the machine tool. The tolerance defined in the cycle also affects the traverse paths on circular arcs.

If necessary, the TNC automatically reduces the programmed feed rate so that the program can be machined at the fastest possible speed without short pauses for computing time. Even if the TNC does not move with reduced speed, it will always comply with the tolerance that you have defined. The larger you define the tolerance, the faster the TNC can move the axes.

Smoothing the contour results in a certain amount of deviation from the contour. The size of this contour error (tolerance value) is set in a machine parameter by the machine manufacturer. You can change the pre-set tolerance value with Cycle 32.


Influences of the geometry definition in the CAM system

The most important factor of influence in offline NC program creation is the chord error S defined in the CAM system. The maximum point spacing of NC programs generated in a postprocessor (PP) is defined through the chord error. If the chord error is less than or equal to the tolerance value T defined in Cycle 32, then the TNC can smooth the contour points unless any special machine settings limit the programmed feed rate.

You will achieve optimal smoothing if in Cycle 32 you choose a tolerance value between 110 % and 200 % of the CAM chord error.


Please note while programming:

With very small tolerance values the machine cannot cut the contour without jerking. These jerking movements are not caused by poor processing power in the TNC, but by the fact that, in order to machine the contour element transitions very exactly, the TNC might have to drastically reduce the speed.

Cycle 32 is DEF active which means that it becomes effective as soon as it is defined in the part program.

The TNC resets Cycle 32 if you

  • Redefine it and confirm the dialog question for the tolerance value with NO ENT.
  • Select a new program with the PGM MGT key.

After you have reset Cycle 32, the TNC reactivates the tolerance that was predefined by machine parameter.

In a program with millimeters set as unit of measure, the TNC interprets the entered tolerance value in millimeters. In an inch program it interprets it as inches.

If you load a program with Cycle 32 that contains only the cycle parameter Tolerance value T, the TNC inserts the two remaining parameters with the value 0 if required.

As the tolerance value increases, the diameter of circular movements usually decreases. If the HSC filter is active on your machine (ask your machine tool builder, if necessary), the circle can also become larger.

If Cycle 32 is active, the TNC shows the parameters defined for Cycle 32 on the CYC tab of the additional status display.


Cycle parameters

Example: NC blocks
95 cycl def 32.0 tolerance
96 cycl def 32.1 t0.05
97 cycl def 32.2 hsc-mode:1 ta5

Tolerance value T: Permissible contour deviation in mm (or inches with inch programming). Input range 0 to 99999.9999

HSC MODE, Finishing=0, Roughing=1: Activate filter:

  • Input value 0:
    Milling with increased contour accuracy. The TNC uses internally defined finishing filter settings
  • Input value 1:
    Milling at an increased feed rate. The TNC uses internally defined roughing filter settings

Tolerance for rotary axes TA: Permissible position error of rotary axes in degrees when M128 is active (TCPM function). The TNC always reduces the feed rate in such a way that—if more than one axis is traversed—the slowest axis moves at its maximum feed rate. Rotary axes are usually much slower than linear axes. You can significantly reduce the machining time for programs for more than one axis by entering a large tolerance value (e.g. 10°), since the TNC does not always have to move the rotary axis to the given nominal position. The contour will not be damaged by entering a rotary axis tolerance value. Only the position of the rotary axis with respect to the workpiece surface will change. Input range 0 to 179.9999


ENGRAVING (Cycle 225, DIN/ISO: G225)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters
> Allowed engraving characters
> Characters that cannot be printed
> Engraving system variables


Cycle run

This cycle is used to engrave texts on a flat surface of the workpiece. The texts can be arranged in a straight line or along an arc.

  1. The TNC positions the tool in the working plane to the starting point of the first character.
  2. The tool plunges perpendicularly to the engraving floor and mills the character. The TNC retracts the tool to the set-up clearance between the characters when required. At the end of the character the tool is at the set-up clearance above the workpiece surface.
  3. This process is repeated for all characters to be engraved.
  4. Finally, the TNC retracts the tool to the 2nd set-up clearance.


Please note while programming:

The algebraic sign for the cycle parameter DEPTH determines the working direction.

If you engrave the text in a straight line (Q516=0), the starting point of the first character is determined by the tool position at the time the cycle is called.

If you engrave the text along an arc (Q516=1), the arc's center is determined by the tool position at the time the cycle is called.

The text to be engraved can also be transferred with a string variable (QS).


Cycle parameters

Example: NC blocks
62 cycl def 225 ENGRAVING
Qs500="TXT2" ;ENGRAVING TEXT
Q513=10 ;CHARACTER HEIGHT
Q514=0 ;SPACE FACTOR
Q515=0 ;FONT
Q516=0 ;TEXT LAYOUT
Q374=0 ;ANGLE OF ROTATION
Q515=0 ;CIRCLE RADIUS
Q207=750 ;FEED RATE FOR MILLING
Q201=-0.5 ;DEPTH
Q206=150 ;FEED RATE FOR PLNGNG
Q200=2 ;SET-UP CLEARANCE
Q203=+20 ;SURFACE COORDINATE
Q204=50 ;2ND SET-UP CLEARANCE

Engraving text QS500: Text to be engraved inside quotation marks. Assignment of a string variable through the Q key of the numerical keypad. The Q key on the ASCI keyboard represents normal text input. Allowed entry characters: See Engraving system variables

Character height Q513 (absolute): Height of the characters to be engraved in mm. Input range 0 to 99999.9999

Space factor Q514: The font used is a proportional font. Each character has its own width, which is engraved correspondingly by the TNC if you program Q514 = 0. If Q514 is not equal to 0, the TNC scales the space between the characters. Input range 0 to 9.9999

Font Q515: Currently without function

Text on a line/on an arc (0/1) Q516: Engrave text in a straight line: Input = 0 Engrave text on an arc: Input = 1

Angle of rotation Q374: Center angle if the text is to be arranged on an arc. Engraving angle if the text is arranged in a straight line. Input range -360.0000 to +360.0000°

Radius of text on an arc Q517 (absolute): Radius of the arc in mm on which the TNC is to arrange the text. Input range 0 to 99999.9999

Feed rate for milling Q207: Traversing speed of the tool in mm/min while engraving. Input range 0 to 99999.999; alternatively FAUTO, Fu or FZ

Depth Q201 (incremental value): Distance between workpiece surface and engraving floor

Feed rate for plunging Q206: Traversing speed of the tool in mm/min when moving into the workpiece. Input range 0 to 99999.999; alternatively FAUTO, fu

Set-up clearance Q200 (incremental): Distance between tool tip and workpiece surface. Input range 0 to 99999.9999; alternatively PREDEF

Coordinate of workpiece surface Q203 (absolute): Coordinate of the workpiece surface. Input range ‑99999.9999 to 99999.9999

2nd set-up clearance Q204 (incremental): Coordinate in the spindle axis at which no collision between tool and workpiece (fixtures) can occur. Input range 0 to 99999.9999; alternatively PREDEF


Allowed engraving characters

The following special characters are allowed in addition to lowercase letters, uppercase letters and numbers:

 ! # $ % & ‘ ( ) * + , - . / : ; < = > ? @ [ \ ] _

The TNC uses the special characters % and \ for special functions. These characters must be indicated twice in the text to be engraved (e.g. %%) if you want to engrave them.

You can also use the cycle to engrave German umlauts and the diameter symbol::

Character | Input
ä | %ae
ö | %oe
ü | %ue
Ä | %AE
Ö | %OE
Ü | %UE
ø | %D


Characters that cannot be printed

Apart from text, you can also define certain non-printable characters for formatting purposes. Enter the special character \ before the non-printable characters.

    The following formatting possibilities are available:

  • \n: Line break
  • \t: Horizontal tab (the tab width is permanently set to 8 characters)
  • \v: Vertical tab (the tab width is permanently set to one line)


Engraving system variables

In addition to the standard characters, you can engrave the contents of certain system variables. Enter the special character % before the system variable.

You can also engrave the current date. Enter %time<x>. <x> defines the date format whose meaning is identical to the function SYSSTR ID332 (see the User's Manual for Conversational Programming, "Q parameter programming" chapter, "Copying system data to a string parameter" section).

Keep in mind that you must enter a leading 0 when entering the date formats 1 to 9, e.g. time08.


INTERPOLATION TURNING (Software Option, Cycle 290, DIN/ISO: G290)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

This cycle is used to create a rotationally symmetric shoulder or a recess in the working plane, which is defined by the starting and end point (see also Machining variants). The center of rotation is the starting point (XY) at the time the cycle is called. The rotational surfaces can be inclined or rounded relative to each other. Interpolation-turning or milling cycles can be used to machine the surfaces.

The workpiece is not rotated during interpolation turning. The tool moves in a circular motion in the principal axes X and Y. At the same time, the TNC orients the spindle S so that the cutting edge of the turning tool is always oriented to the center of rotation of the workpiece. Cycle 290 can thus also be used on a three-axis machine.

The center of the machining operation does not have to lie in the center of a rotary table. The center of the machining operation is defined by the tool position at the time the cycle is called.

  1. The TNC moves the tool at clearance height to the starting point of machining. The starting point is obtained by extending the contour starting point tangentially by the set-up clearance.
  2. The TNC uses the interpolation turning cycle to machine the defined contour. In interpolation turning the principal axes of the working plane move on a circle, whereas the spindle axis is oriented perpendicularly to the surface.
  6. At the end point of the contour, the TNC retracts the tool perpendicularly by the set-up clearance.
  7. Finally, the TNC retracts the tool to the clearance height.


Please note while programming:

    You can use a turning tool or a milling tool (Q444=0) for this cycle. The geometry data of this tool are defined in the TOOL.T tool table as follows:

  • Column L (DL for compensation values):
    Length of the tool (bottommost point of the tool cutting edge)
  • Column R (DR for compensation values):
    Effective radius of the tool (outermost point of the tool cutting edge)
  • Column R2 (DR2 for compensation values):
    Cutting-edge radius of the tool

Machine and TNC must be specially prepared by the machine tool builder for use of this cycle. Refer to your machine manual.

This cycle is effective only for machines with servo-controlled spindle (exception: Q444=0).

Software option 96 must be enabled.

Roughing operations with multiple passes are not possible in this cycle.

The center of interpolation is the tool position at the time the cycle is called.

The TNC extends the first surface to be machined by the set-up clearance.

You can use the values DL and DR of the TOOL CALL block to realize oversizes. DR2 entries in the TOOL CALL block are not taken into account by the TNC.

Before cycle call, define a large tolerance with Cycle 32 for your machine to attain high contour speeds.

Program a cutting speed that can just be reached at the contour speed of the machine axes. This ensures optimum geometry resolution and a constant machining speed.

The TNC does not monitor for possible damage to the contour, which might be caused by unsuitable tool geometry.

Note the machining variants: See Machining variants


Cycle parameters

Set-up clearance Q200 (incremental): Extension of the defined contour during approach and departure. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q445 (absolute): Absolute height at which the tool cannot collide with the workpiece. Position for tool retraction at the end of the cycle. Input range ‑99999.9999 to 99999.9999

Angle for spindle orientation Q336 (absolute): Angle for orienting the cutting edge to the 0° position of the spindle. Input range -360.0000 to 360.0000

Cutting speed [m/min] Q440: Cutting speed of the tool in m/min. Input range 0 to 99.999

Infeed per revolution [mm/rev] Q441: Feed rate of the tool per revolution. Input range 0 to 99.999

Start angle in plane XY Q442: Starting angle in the XY plane. Input range 0 to 359.999

Machining direction (–1/+1) Q443: Machine in clockwise direction: Input = –1 Machine in counterclockwise direction: Input = +1

Interpolating axis (4...9) Q444: Axis designation of the interpolating axis. A axis is interpolating axis: Input = 4 B axis is interpolating axis: Input = 5 C axis is interpolating axis: Input = 6 U axis is interpolating axis: Input = 7 V axis is interpolating axis: Input = 8 W axis is interpolating axis: Input = 9 Contour milling: Input = 0

Example: NC blocks
62 cycl def 290 interpolation turning
Q200=2 ;SET-UP CLEARANCE
Q445=+50 ;CLEARANCE HEIGHT
Q336=0 ;ANGLE OF SPINDLE
Q440=20 ;CUTTING SPEED
Q441=0.75 ;INFEED
Q442=+0 ;starting angle
Q443=–1 ;MACHINING DIRECTION
Q444=+6 ;INTERPOLATED AXIS
Q491=+25 ;DIAMETER AT CONTOUR START
Q492=+0 ;CONTOUR START IN Z
Q493=+50 ;CONTOUR END IN X
Q494=–45 ;CONTOUR END IN Z
Q495=+0 ;ANGLE OF CYLINDER SURFACE
Q496=+0 ;ANGLE OF FACE
Q500=4.5 ;RADIUS OF CONTOUR EDGE

Diameter at contour start Q491 (absolute): Corner of the starting point in X, enter the diameter. Input range ‑99999.9999 to 99999.9999

Contour start in Z Q492 (absolute): Corner of the starting point in Z. Input range ‑99999.9999 to 99999.9999

Diameter at end of contour Q493 (absolute): Corner of the end point in X, enter the diameter. Input range ‑99999.9999 to 99999.9999

Contour end in Z Q494 (absolute): Corner of the end point in Z. Input range ‑99999.9999 to 99999.9999

Angle of circumferential surface Q495: Angle of the first surface to be machined in degrees. Input range ‑179.999 to 179.999

Angle of the face Q496: Angle of the second surface to be machined in degrees. Input range ‑179.999 to 179.999

Radius of contour edge Q500: Corner rounding between the surfaces to be machined. Input range 0 to 999.999

Further Informations:
> Contour milling
> Machining variants


Contour milling

You can mill the surfaces by entering Q444=0. Use a milling cutter with a cutting radius (R2) for this machining operation. It is usually advisable to pre-machine surfaces with a large oversize by milling rather than by interpolation turning.

Milling operations with multiple passes are possible in this cycle.

Keep in mind that the feed rate during milling matches the value specified in Q440 (cutting speed). The cutting speed is specified in meters per minute.


Machining variants

Combining the starting and end points with the angles Q495 and Q496 results in the following possible machining operations:

  • Outside machining in quadrant 1 (1):
    • Enter the circumferential angle (Q495) as a positive value.
    • Enter the angle of the face (Q496) as a negative value.
    • For the contour start in X (Q491), enter a value smaller than the contour end in X (Q493).
    • For the contour start in Z (Q492), enter a value greater than the contour end in Z (Q494).
  • Inside machining in quadrant 2 (2):
    • Enter the circumferential angle (Q495) as a negative value.
    • Enter the angle of the face (Q496) as a positive value.
    • For the contour start in X (Q491), enter a value greater than the contour end in X (Q493).
    • For the contour start in Z (Q492), enter a value greater than the contour end in Z (Q494).
  • Outside machining in quadrant 3 (3):
    • Enter the circumferential angle (Q495) as a positive value.
    • Enter the angle of the face (Q496) as a negative value.
    • For the contour start in X (Q491), enter a value greater than the contour end in X (Q493).
    • For the contour start in Z (Q492), enter a value smaller than the contour end in Z (Q494).
  • Inside machining in quadrant 4 (4):
    • Enter the circumferential angle (Q495) as a negative value.
    • Enter the angle of the face (Q496) as a positive value.
    • For the contour start in X (Q491), enter a value smaller than the contour end in X (Q493).
    • For the contour start in Z (Q492), enter a value smaller than the contour end in Z (Q494).
  • Recess axial:
    • For the contour start in X (Q491), enter a value equal to the contour end in X (Q493).
  • Recess radial:
    • For the contour start in Z (Q492), enter a value smaller than the contour end in Z (Q494).


Using Touch Probe Cycles

Further Informations:
> General information about touch probe cycles
> Before you start working with touch probe cycles


General information about touch probe cycles

The TNC must be specially prepared by the machine tool builder for the use of a 3-D touch probe. The machine manual provides further information.

Please note that HEIDENHAIN grants a warranty for the function of the touch probe cycles only if HEIDENHAIN touch probes are used!

If you are carrying out measurements during program run, be sure that the tool data (length, radius) can be used from the calibrated data or from the last TOOL CALL block (selected with MP7411).

Further Informations:
> Principle of function
> Touch probe cycles in the Manual Operation and Electronic Handwheel modes
> Touch probe cycles for automatic operation


Principle of function

Whenever the TNC runs a touch probe cycle, the 3-D touch probe approaches the workpiece in one linear axis. This is also true during an active basic rotation or with a tilted working plane. The machine tool builder determines the probing feed rate in a machine parameter (see "Before You Start Working with Touch Probe Cycles" later in this chapter).

When the probe stylus contacts the workpiece,

  • the 3-D touch probe transmits a signal to the TNC: the coordinates of the probed position are stored,
  • the touch probe stops moving, and
  • returns to its starting position at rapid traverse.

If the stylus is not deflected within a distance defined in MP6130, the TNC displays an error message.


Touch probe cycles in the Manual Operation and Electronic Handwheel modes

In the Manual Operation and El. Handwheel modes, the TNC provides touch probe cycles that allow you to:

  • Calibrate the touch probe
  • Compensate workpiece misalignment
  • Set datums


Touch probe cycles for automatic operation

Besides the touch probe cycles, which you can use in the Manual and El. Handwheel modes, the TNC provides numerous cycles for a wide variety of applications in automatic mode:

  • Calibrating a touch trigger probe
  • Compensating workpiece misalignment
  • Setting datums
  • Automatic workpiece inspection
  • Automatic tool measurement

You can program the touch probe cycles in the Programming and Editing operating mode via the TOUCH PROBE key. Like the most recent fixed cycles, touch probe cycles with numbers greater than 400 use Q parameters as transfer parameters. Parameters with specific functions that are required in several cycles always have the same number: For example, Q260 is always assigned the clearance height, Q261 the measuring height, etc.

To simplify programming, the TNC shows a graphic during cycle definition. In the graphic, the parameter that needs to be entered is highlighted (see figure at right).

Further Informations:
> Defining the touch probe cycle in the Programming and Editing mode of operation


Defining the touch probe cycle in the Programming and Editing mode of operation
Example: NC blocks
5 tch probe 410 DATUM INSIDE RECTAN.
Q321=+50 ;CENTER IN 1ST AXIS
Q322=+50 ;CENTER IN 2ND AXIS
Q323=60 ;1ST SIDE LENGTH
Q324=20 ;2ND SIDE LENGTH
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q305=10 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+0 ;DATUM

The soft-key row shows all available touch probe functions divided into groups.

Select the desired probe cycle group, for example datum setting. Cycles for automatic tool measurement are available only if your machine has been prepared for them.

Select a cycle, e.g. datum setting at pocket center. The TNC initiates the programming dialog and asks for all required input values. At the same time a graphic of the input parameters is displayed in the right screen window. The parameter that is asked for in the dialog prompt is highlighted.

Enter all parameters requested by the TNC and conclude each entry with the ENT key.

The TNC ends the dialog when all required data has been entered

Group of measuring cycles | Soft key | Page
Cycles for automatic measurement and compensation of workpiece misalignment |  | Overview
Cycles for automatic workpiece presetting |  | Overview
Cycles for automatic workpiece inspection |  | Overview
Calibration cycles, special cycles |  | Overview
Cycles for automatic kinematics measurement |  | Fundamentals
Cycles for automatic tool measurement (enabled by the machine tool builder) |  | Overview


Before you start working with touch probe cycles

To make it possible to cover the widest possible range of applications, machine parameters enable you to determine the behavior common to all touch probe cycles.

Further Informations:
> Maximum traverse to touch point: MP6130
> Safety clearance to touch point: MP6140
> Orient the infrared touch probe to the programmed probe direction: MP6165
> Consider a basic rotation in the Manual Operation mode: MP6166
> Multiple measurements: MP6170
> Confidence interval for multiple measurements: MP6171
> Touch trigger probe, probing feed rate: MP6120
> Touch trigger probe, rapid traverse for positioning: MP6150
> Touch trigger probe, rapid traverse for positioning: MP6151
> KinematicsOpt: Tolerance limit in Optimization mode: MP6600
> KinematicsOpt, permissible deviation of the calibration ball radius: MP6601
> Executing touch probe cycles


Maximum traverse to touch point: MP6130

If the stylus is not deflected within the path defined in MP6130, the TNC outputs an error message.


Safety clearance to touch point: MP6140

In MP6140 you define how far from the defined (or calculated) touch point the TNC is to pre-position the touch probe. The smaller the value you enter, the more exactly you must define the touch point position. In many touch probe cycles you can also define a safety clearance that is added to MP6140.


Orient the infrared touch probe to the programmed probe direction: MP6165

To increase measuring accuracy, you can use MP 6165 = 1 to have an infrared touch probe oriented in the programmed probe direction before every probe process. In this way the stylus is always deflected in the same direction.

If you change MP6165, you must recalibrate the touch probe, because its deflection behavior changes.


Consider a basic rotation in the Manual Operation mode: MP6166

Set MP 6166 = 1 for the TNC to consider an active basic rotation during the probing process (the workpiece is approached along an angular path if required) to ensure that the measuring accuracy for probing individual positions is also increased in Setup mode.

This feature is not active during the following functions in the Manual Operation mode:

  • Calibrate length
  • Calibrate radius
  • Measure basic rotation


Multiple measurements: MP6170

To increase measuring certainty, the TNC can run each probing process up to three times in sequence. If the measured position values differ too greatly, the TNC outputs an error message (the limit value is defined in MP6171). With multiple measurements it is possible to detect random errors, e.g. from contamination.

If the measured values lie within the confidence interval, the TNC saves the mean value of the measured positions.


Confidence interval for multiple measurements: MP6171

In MP6171 you store the value by which the results may differ when you make multiple measurements. If the difference in the measured values exceeds the value in MP6171, the TNC outputs an error message.


Touch trigger probe, probing feed rate: MP6120

In MP6120 you define the feed rate at which the TNC is to probe the workpiece.


Touch trigger probe, rapid traverse for positioning: MP6150

In MP6150 you define the feed rate at which the TNC pre-positions the touch probe, or positions it between measuring points.


Touch trigger probe, rapid traverse for positioning: MP6151

In MP6151 you define whether the TNC is to position the touch probe at the feed rate defined in MP6150 or at rapid traverse.

  • Input value = 0: Position at feed rate from MP6150
  • Input value = 1: Pre-position at rapid traverse


KinematicsOpt: Tolerance limit in Optimization mode: MP6600

In MP6600 you define the tolerance limit starting from which the TNC displays a note in the Optimization mode when the measured kinematic data is greater than this limit value. The default value is 0.05. The larger the machine, the greater these values should be.

  • Input range 0.001 to 0.999


KinematicsOpt, permissible deviation of the calibration ball radius: MP6601

In MP6601 you define the maximum permissible deviation from the entered cycle parameter by the calibration ball radius measured in the cycles.

  • Input range: 0.01 to 0.1

The TNC calculates the calibration ball radius twice at every measuring point for all 5 touch points. If the radius is greater than Q407 + MP6601 an error message appears because it could be contamination.

If the radius found by the TNC is less than 5 * (Q407 - MP6601), the TNC also issues an error message.


Executing touch probe cycles

All touch probe cycles are DEF active. This means that the TNC runs the cycle automatically as soon as the TNC executes the cycle definition in the program run.

Make sure that at the beginning of the cycle the compensation data (length, radius) from the calibrated data or from the last TOOL CALL block are active (selection via MP7411, see the User's Manual of the iTNC530, “General User Parameters”).

You can also run the Touch Probe Cycles 408 to 419 during an active basic rotation. Make sure, however, that the basic rotation angle does not change when you use Cycle 7 DATUM SHIFT with datum tables after the measuring cycle.

Touch probe cycles with a number greater than 400 position the touch probe according to a positioning logic:

  • If the current coordinate of the south pole of the stylus is less than the coordinate of the clearance height (defined in the cycle), the TNC retracts the touch probe in the touch-probe axis to the clearance height and then positions it in the working plane to the first probe point.
  • If the current coordinate of the stylus south pole is greater than the coordinate of the clearance height, then the TNC first positions the touch probe to the first probe point in the working plane, and then in the touch-probe axis directly to the measuring height.


Touch Probe Cycles: Automatic Measurement of Workpiece Misalignment

Further Informations:
> Fundamentals
> BASIC ROTATION (Cycle 400, DIN/ISO: G400)
> BASIC ROTATION from two holes (Cycle 401, DIN/ISO: G401)
> BASIC ROTATION over two studs (Cycle 402, DIN/ISO: G402)
> BASIC ROTATION compensation via rotary axis (Cycle 403, DIN/ISO: G403)
> SET BASIC ROTATION (Cycle 404, DIN/ISO: G404)
> Compensating workpiece misalignment by rotating the C axis (Cycle 405, DIN/ISO: G405)
> Example: Determining a basic rotation from two holes


Fundamentals

Further Informations:
> Overview
> Characteristics common to all touch probe cycles for measuring workpiece misalignment


Overview

The TNC provides five cycles that enable you to measure and compensate workpiece misalignment. In addition, you can reset a basic rotation with Cycle 404:

Cycle | Soft key | Page
400 BASIC ROTATION Automatic measurement using two points. Compensation via basic rotation. |  | BASIC ROTATION (Cycle 400, DIN/ISO: G400)
401 ROT OF 2 HOLES Automatic measurement using two holes. Compensation via basic rotation. |  | BASIC ROTATION from two holes (Cycle 401, DIN/ISO: G401)
402 ROT OF 2 STUDS Automatic measurement using two studs. Compensation via basic rotation. |  | BASIC ROTATION over two studs (Cycle 402, DIN/ISO: G402)
403 ROT IN ROTARY AXIS Automatic measurement using two points. Compensation via table rotation. |  | BASIC ROTATION compensation via rotary axis (Cycle 403, DIN/ISO: G403)
405 ROT IN C AXIS Automatic alignment of an angular offset between a hole center and the positive Y axis. Compensation via table rotation. |  | Compensating workpiece misalignment by rotating the C axis (Cycle 405, DIN/ISO: G405)
404 SET BASIC ROTATION Setting any basic rotation. |  | SET BASIC ROTATION (Cycle 404, DIN/ISO: G404)


Characteristics common to all touch probe cycles for measuring workpiece misalignment

For Cycles 400, 401 and 402 you can define through parameter Q307 Default setting for basic rotation whether the measurement result is to be corrected by a known angle α (see figure at right). This enables you to measure the basic rotation against any straight line 1 of the workpiece and to establish the reference to the actual 0° direction 2.


BASIC ROTATION (Cycle 400, DIN/ISO: G400)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch probe cycle 400 determines a workpiece misalignment by measuring two points, which must lie on a straight surface. With the basic rotation function the TNC compensates the measured value.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the programmed probe starting point 1 at rapid traverse (value from MP6150). The TNC offsets the touch probe by the set-up clearance in the direction opposite to the defined traverse direction.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves to the next starting position 2 and probes the second touch point.
  4. The TNC returns the touch probe to the clearance height and performs the basic rotation.


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The TNC will reset an active basic rotation at the beginning of the cycle.


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 1st axis Q265 (absolute): Coordinate of the second touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 2nd axis Q266 (absolute): Coordinate of the second touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Measuring axis Q272: Axis in the working plane in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis

Traverse direction 1 Q267: Direction in which the touch probe is to approach the workpiece: -1: Negative traverse direction +1: Positive traverse direction

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF
Example: NC blocks
5 TCH PROBE 400 BASIC ROTATION
Q263=+10 ;1ST POINT 1ST AXIS
Q264=+3.5 ;1ST POINT 2ND AXIS
Q265=+25 ;2ND POINT 1ST AXIS
Q266=+8 ;2ND POINT 2ND AXIS
Q272=2 ;MEASURING AXIS
Q267=+1 ;TRAVERSE DIRECTION
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q307=0 ;PRESET BASIC ROTATION
Q305=0 ;NO. IN TABLE

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Default setting for basic rotation Q307 (absolute): If the misalignment is to be measured against a straight line other than the reference axis, enter the angle of this reference line. The TNC will then calculate the difference between the value measured and the angle of the reference line for the basic rotation. Input range -360.000 to 360.000

Preset number in table Q305: Enter the preset number in the table in which the TNC is to save the determined basic rotation. If you enter Q305=0, the TNC automatically places the determined basic rotation in the ROT menu of the Manual Operation mode. Input range 0 to 99999


BASIC ROTATION from two holes (Cycle 401, DIN/ISO: G401)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

The Touch Probe Cycle 401 measures the centers of two holes. Then the TNC calculates the angle between the reference axis in the working plane and the line connecting the hole centers. With the basic rotation function, the TNC compensates the calculated value. As an alternative, you can also compensate the determined misalignment by rotating the rotary table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the point entered as center of the first hole 1.
  2. Then the touch probe moves to the entered measuring height and probes four points to find the first hole center.
  3. The touch probe returns to the clearance height and then to the position entered as center of the second hole 2.
  4. The TNC moves the touch probe to the entered measuring height and probes four points to find the second hole center.
  5. Then the TNC returns the touch probe to the clearance height and performs the basic rotation.


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The TNC will reset an active basic rotation at the beginning of the cycle.

This touch probe cycle is not allowed when the tilted working plane function is active.

If you want to compensate the misalignment by rotating the rotary table, the TNC will automatically use the following rotary axes:

  • C for tool axis Z
  • B for tool axis Y
  • A for tool axis X


Cycle parameters

1st hole: Center in 1st axis Q268 (absolute): Center of the first hole in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st hole: Center in 2nd axis Q269 (absolute): Center of the first hole in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd hole: Center in 1st axis Q270 (absolute): Center of the second hole in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd hole: Center in 2nd axis Q271 (absolute): Center of the second hole in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Default setting for basic rotation Q307 (absolute): If the misalignment is to be measured against a straight line other than the reference axis, enter the angle of this reference line. The TNC will then calculate the difference between the value measured and the angle of the reference line for the basic rotation. Input range -360.000 to 360.000

Example: NC blocks
5 TCH PROBE 401 ROT OF 2 HOLES
Q268=+37 ;1ST CENTER IN 1ST AXIS
Q269=+12 ;1ST CENTER IN 2ND AXIS
Q270=+75 ;2ND CENTER IN 1ST AXIS
Q271=+20 ;2ND CENTER IN 2ND AXIS
Q261=-5 ;MEASURING HEIGHT
Q260=+20 ;CLEARANCE HEIGHT
Q307=0 ;PRESET BASIC ROTATION
Q305=0 ;NO. IN TABLE
Q402=0 ;ALIGNMENT
Q337=0 ;SET TO ZERO

Preset number in table Q305: Enter the preset number in the table in which the TNC is to save the determined basic rotation. If you enter Q305=0, the TNC automatically places the determined basic rotation in the ROT menu of the Manual Operation mode. The parameter has no effect if the misalignment is to be compensated by a rotation of the rotary table (Q402=1). In this case the misalignment is not saved as an angular value. Input range 0 to 99999

Basic rotation / alignment Q402: Specify whether the TNC should compensate misalignment with a basic rotation, or by rotating the rotary table: 0: Set basic rotation 1: Rotate the rotary table If you select rotary table, the TNC does not save the measured misalignment, not even when you have defined a table line in parameter Q305.

Set to zero after alignment Q337: Definition of whether the TNC should set the display of the aligned rotary axis to zero: 0: Do not reset the display of the rotary axis to 0 after alignment 1: Reset the display of the rotary axis to 0 after alignment The TNC sets the display to 0 only if you have defined Q402=1.


BASIC ROTATION over two studs (Cycle 402, DIN/ISO: G402)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

The Touch Probe Cycle 402 measures the centers of two studs. Then the TNC calculates the angle between the reference axis in the working plane and the line connecting the stud centers. With the basic rotation function, the TNC compensates the calculated value. As an alternative, you can also compensate the determined misalignment by rotating the rotary table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe in rapid traverse (value from MP6150) to the probe starting point 1 of the first stud.
  2. Then the touch probe moves to the entered measuring height 1 and probes four points to find the center of the first stud. The touch probe moves on a circular arc between the touch points, each of which is offset by 90°.
  3. The touch probe returns to the clearance height and then positions the probe to starting point 5 of the second stud.
  4. The TNC moves the touch probe to the entered measuring height 2 and probes four points to find the center of the second stud.
  5. Then the TNC returns the touch probe to the clearance height and performs the basic rotation.


Cycle parameters

1st stud: Center in 1st axis (absolute): Center of the first stud in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st stud: Center in 2nd axis Q269 (absolute): Center of the first stud in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Diameter of stud 1 Q313: Approximate diameter of the 1st stud. Enter a value that is more likely to be too large than too small. Input range 0 to 99999.9999

Measuring height 1 in the probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis at which stud 1 is to be measured. Input range ‑99999.9999 to 99999.9999

2nd stud: Center in 1st axis Q270 (absolute): Center of the second stud in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd stud: Center in 2nd axis Q271 (absolute): Center of the second stud in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Diameter of stud 2 Q314: Approximate diameter of the 2nd stud. Enter a value that is more likely to be too large than too small. Input range 0 to 99999.9999

Measuring height of stud 2 in the probe axis Q315 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis at which stud 2 is to be measured. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF
Example: NC blocks
5 TCH PROBE 402 ROT OF 2 STUDS
Q268=-37 ;1ST CENTER IN 1ST AXIS
Q269=+12 ;1ST CENTER IN 2ND AXIS
Q313=60 ;DIAMETER OF STUD 1
Q261=-5 ;MEASURING HEIGHT 1
Q270=+75 ;2ND CENTER IN 1ST AXIS
Q271=+20 ;2ND CENTER IN 2ND AXIS
Q314=60 ;DIAMETER OF STUD 2
Q315=-5 ;MEASURING HEIGHT 2
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q307=0 ;PRESET BASIC ROTATION
Q305=0 ;NO. IN TABLE
Q402=0 ;ALIGNMENT
Q337=0 ;SET TO ZERO

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Default setting for basic rotation Q307 (absolute): If the misalignment is to be measured against a straight line other than the reference axis, enter the angle of this reference line. The TNC will then calculate the difference between the value measured and the angle of the reference line for the basic rotation. Input range -360.000 to 360.000

Preset number in table Q305: Enter the preset number in the table in which the TNC is to save the determined basic rotation. If you enter Q305=0, the TNC automatically places the determined basic rotation in the ROT menu of the Manual Operation mode. The parameter has no effect if the misalignment is to be compensated by a rotation of the rotary table (Q402=1). In this case the misalignment is not saved as an angular value. Input range 0 to 99999

Basic rotation / alignment Q402: Specify whether the TNC should compensate misalignment with a basic rotation, or by rotating the rotary table: 0: Set basic rotation 1: Rotate the rotary table If you select rotary table, the TNC does not save the measured misalignment, not even when you have defined a table line in parameter Q305.

Set to zero after alignment Q337: Definition of whether the TNC should set the display of the aligned rotary axis to zero: 0: Do not reset the display of the rotary axis to 0 after alignment 1: Reset the display of the rotary axis to 0 after alignment The TNC sets the display to 0 only if you have defined Q402=1.


BASIC ROTATION compensation via rotary axis (Cycle 403, DIN/ISO: G403)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch probe cycle 403 determines a workpiece misalignment by measuring two points, which must lie on a straight line. The TNC compensates the determined misalignment by rotating the A, B or C axis. The workpiece can be clamped in any position on the rotary table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the programmed probe starting point 1 at rapid traverse (value from MP6150). The TNC offsets the touch probe by the set-up clearance in the direction opposite to the defined traverse direction.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves to the next starting position 2 and probes the second touch point.
  4. The TNC returns the touch probe to the clearance height and moves the rotary axis, which was defined in the cycle, by the measured value. Optionally you can have the display set to 0 after alignment.


Please note while programming:

Danger of collision!

Ensure that the clearance height is sufficiently large so that no collisions can occur during the final positioning of the rotary axis.

If you enter 0 in parameter Q312 Axis for compensating movement, the cycle automatically determines the rotary axis to be aligned (recommended setting). Depending on the sequence of the probing points, an angle with the actual direction is determined. The measured angle goes from the first to the second probing point. If you select the A, B or C axis as compensation axis in parameter Q312, the cycle determines the angle, regardless of the sequence of the probing points. The calculated angle lies in the range from –90° to +90°. After alignment, check the position of the rotary axis.

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The TNC stores the measured angle in parameter Q150.

A kinematics description must be stored in the TNC in order for the compensation axis to be determined automatically by the cycle.


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 1st axis Q265 (absolute): Coordinate of the second touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 2nd axis Q266 (absolute): Coordinate of the second touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Measuring axis Q272: Axis in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis 3: Touch probe axis = measuring axis

Traverse direction 1 Q267: Direction in which the touch probe is to approach the workpiece: -1: Negative traverse direction +1: Positive traverse direction

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF
Example: NC blocks
5 TCH PROBE 403 ROT IN C-AXIS
Q263=+25 ;1ST POINT 1ST AXIS
Q264=+10 ;1ST POINT 2ND AXIS
Q265=+40 ;2ND POINT 1ST AXIS
Q266=+17 ;2ND POINT 2ND AXIS
Q272=2 ;MEASURING AXIS
Q267=+1 ;TRAVERSE DIRECTION
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q312=0 ;COMPENSATION AXIS
Q337=0 ;SET TO ZERO
Q305=1 ;NO. IN TABLE
Q303=+1 ;MEAS. VALUE TRANSFER
Q380=+0 ;REFERENCE ANGLE

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points

Axis for compensation motion Q312: Assignment of the rotary axis in which the TNC is to compensate the measured misalignment. 0: Automatic mode – the TNC uses the active kinematics to determine the rotary axis to be aligned. In automatic mode the first rotary table axis (as viewed from the workpiece) is used as compensation axis. Recommended setting. 4: Compensate misalignment with rotary axis A 5: Compensate misalignment with rotary axis B 6: Compensate misalignment with rotary axis C

Set to zero after alignment Q337: Definition of whether the TNC should set the display of the aligned rotary axis to zero: 0: Do not reset the display of the rotary axis to 0 after alignment 1: Reset the display of the rotary axis to 0 after alignment

Number in table Q305: Enter the number in the preset table/datum table in which the TNC is to set the rotary axis to zero. Only effective if Q337 is set to 1. Input range 0 to 99999

Measured-value transfer (0, 1) Q303: Specify whether the determined angle is to be saved in the datum table or in the preset table: 0: Write the measured angle as a datum shift in the active datum table. The reference system is the active workpiece coordinate system. 1: Write the measured angle in the preset table. The reference system is the machine coordinate system (REF system).

Reference angle? (0=ref. axis) Q380: Angle with which the TNC is to align the probed straight line. Only effective if rotary axis = automatic mode is selected, or rotary axis = C is selected (Q312 = 0 or 6). Input range -360.000 to 360.000


SET BASIC ROTATION (Cycle 404, DIN/ISO: G404)

Further Informations:
> Cycle run
> Cycle parameters


Cycle run

Example: NC blocks
5 TCH PROBE 404 BASIC ROTATION
Q307=+0 ;PRESET BASIC ROTATION
Q305=1 ;NO. IN TABLE

With Touch Probe Cycle 404, you can set any basic rotation automatically during program run. This cycle is intended primarily for resetting a previous basic rotation.


Cycle parameters

Preset value for basic rotation: Angular value at which the basic rotation is to be set. Input range -360.000 to 360.000

Number in table Q305: Enter the number in the preset/datum table in which the TNC is to save the defined basic rotation. -1: The TNC overwrites the active datum and activates it. 0: The TNC copies the active datum to the datum 0, writes the basic rotation, and activates the datum 0. >0: The TNC merely writes the defined basic rotation to the specified datum number and does not activate this datum. Use Cycle 247, if necessary (see DATUM SETTING (Cycle 247, DIN/ISO: G247)) Input range 0 to 99999


Compensating workpiece misalignment by rotating the C axis (Cycle 405, DIN/ISO: G405)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

With Touch Probe Cycle 405, you can measure

  • the angular offset between the positive Y axis of the active coordinate system and the center of a hole, or
  • the angular offset between the nominal position and the actual position of a hole center.

The TNC compensates the determined angular offset by rotating the C axis. The workpiece can be clamped in any position on the rotary table, but the Y coordinate of the hole must be positive. If you measure the angular misalignment of the hole with touch probe axis Y (horizontal position of the hole), it may be necessary to execute the cycle more than once because the measuring strategy causes an inaccuracy of approx. 1% of the misalignment.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The TNC derives the probing direction automatically from the programmed starting angle.
  3. Then the touch probe moves in a circular arc either at measuring height or at clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points, and then positions the touch probe to the center of the measured hole.
  5. Finally the TNC returns the touch probe to the clearance height and aligns the workpiece by rotating the table. The TNC rotates the rotary table so that the hole center after compensation lies in the direction of the positive Y axis, or at the nominal position of the hole center—both with a vertical and a horizontal touch probe axis. The measured angular misalignment is also available in parameter Q150.


Please note while programming:

Danger of collision!

To prevent a collision between the touch probe and the workpiece, enter a low estimate for the nominal diameter of the pocket (or hole).

If the dimensions of the pocket and the safety clearance do not permit pre-positioning in the proximity of the touch points, the TNC always starts probing from the center of the pocket. In this case the touch probe does not return to the clearance height between the four measuring points.

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The smaller the angle, the less accurately the TNC can calculate the circle center. Minimum input value: 5°.


Cycle parameters

Center in 1st axis Q321 (absolute): Center of the hole in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q322 (absolute): Center of the hole in the minor axis of the working plane. If you program Q322 = 0, the TNC aligns the hole center to the positive Y axis. If you program Q322 not equal to 0, then the TNC aligns the hole center to the nominal position (angle of the hole center). Input range ‑99999.9999 to 99999.9999

Nominal diameter Q262: Approximate diameter of the circular pocket (or hole). Enter a value that is more likely to be too small than too large. Input range 0 to 99999.9999

Starting angle Q325 (absolute): Angle between the reference axis of the working plane and the first touch point. Input range -360.000 to 360.000

Stepping angle Q247 (incremental): Angle between two measuring points. The algebraic sign of the stepping angle determines the direction of rotation (negative = clockwise) in which the touch probe moves to the next measuring point. If you wish to probe a circular arc instead of a complete circle, then program the stepping angle to be less than 90°. Input range -120.000 to 120.000

Example: NC blocks
5 TCH PROBE 405 ROT IN C AXIS
Q321=+50 ;CENTER IN 1ST AXIS
Q322=+50 ;CENTER IN 2ND AXIS
Q262=10 ;NOMINAL DIAMETER
Q325=+0 ;STARTING ANGLE
Q247=90 ;STEPPING ANGLE
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q337=0 ;SET TO ZERO

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Set to zero after alignment Q337: Definition of whether the TNC should set the display of the C axis to zero, or write the angular misalignment in column C of the datum table: 0: Set the display of the C axis to zero and write the value in line 0 of the datum table >0: Write the measured angular misalignment with correct algebraic signs in the datum table. Line number = value of Q337. If a C-axis shift is registered in the datum table, the TNC adds the measured angular misalignment.


Touch Probe Cycles: Automatic Measurement of Workpiece Misalignment

Example: Determining a basic rotation from two holes

0 begin pgm cyc401 mm |
1 tool call 69 z |
2 TCH PROBE 401 ROT OF 2 HOLES |
Q268=+25 ;1ST CENTER IN 1ST AXIS | Center of the 1st hole: X coordinate
Q269=+15 ;1ST CENTER IN 2ND AXIS | Center of the 1st hole: Y coordinate
Q270=+80 ;2ND CENTER IN 1ST AXIS | Center of the 2nd hole: X coordinate
Q271=+35 ;2ND CENTER IN 2ND AXIS | Center of the 2nd hole: Y coordinate
Q261=-5 ;MEASURING HEIGHT | Coordinate in the touch probe axis in which the measurement is made
Q260=+20 ;CLEARANCE HEIGHT | Height in the touch probe axis at which the probe can traverse without collision
Q307=+0 ;PRESET BASIC ROTATION | Angle of the reference line
Q402=1 ;ALIGNMENT | Compensate misalignment by rotating the rotary table
Q337=1 ;SET TO ZERO | Set the display to zero after the alignment
3 call pgm 35k47 | Call part program
4 end pgm cyc401 mm |


Touch Probe Cycles: Automatic Datum Setting

Further Informations:
> Fundamentals
> SLOT CENTER REF PT (Cycle 408, DIN/ISO: G408, FCL 3 Function)
> RIDGE CENTER REF PT (Cycle 409, DIN/ISO: G409, FCL 3 function)
> DATUM FROM INSIDE OF RECTANGLE (Cycle 410, DIN/ISO: G410)
> DATUM FROM OUTSIDE OF RECTANGLE (Cycle 411, DIN/ISO: G411)
> DATUM FROM INSIDE OF CIRCLE (Cycle 412, DIN/ISO: G412)
> DATUM FROM OUTSIDE OF CIRCLE (Cycle 413, DIN/ISO: G413)
> DATUM FROM OUTSIDE OF CORNER (Cycle 414, DIN/ISO: G414)
> DATUM FROM INSIDE OF CORNER (Cycle 415, DIN/ISO: G415)
> DATUM CIRCLE CENTER (Cycle 416, DIN/ISO: G416)
> DATUM IN TOUCH PROBE AXIS (Cycle 417, DIN/ISO: G417)
> DATUM AT CENTER OF 4 HOLES (Cycle 418, DIN/ISO: G418)
> DATUM IN ONE AXIS (Cycle 419, DIN/ISO: G419)
> Example: Datum setting in center of a circular segment and on top surface of workpiece
> Example: Datum setting on top surface of workpiece and in center of a bolt hole circle


Fundamentals

Further Informations:
> Overview
> Characteristics common to all touch probe cycles for datum setting


Overview

    The TNC offers twelve cycles for automatically finding reference points and handling them as follows:

  • Setting the determined values directly as display values
  • Entering the determined values in the preset table
  • Entering the determined values in a datum table
Cycle | Soft key | Page
408 SLOT CENTER REF PT. Measuring the inside width of a slot, and defining the slot center as datum |  | SLOT CENTER REF PT (Cycle 408, DIN/ISO: G408, FCL 3 Function)
409 RIDGE CENTER REF PT. Measuring the outside width of a ridge, and defining the ridge center as datum |  | RIDGE CENTER REF PT (Cycle 409, DIN/ISO: G409, FCL 3 function)
410 DATUM INSIDE RECTANGLE Measuring the inside length and width of a rectangle, and defining the center as datum |  | DATUM FROM INSIDE OF RECTANGLE (Cycle 410, DIN/ISO: G410)
411 DATUM OUTSIDE RECTANGLE Measuring the outside length and width of a rectangle, and defining the center as datum |  | DATUM FROM OUTSIDE OF RECTANGLE (Cycle 411, DIN/ISO: G411)
412 DATUM INSIDE CIRCLE Measuring any four points on the inside of a circle, and defining the center as datum |  | DATUM FROM INSIDE OF CIRCLE (Cycle 412, DIN/ISO: G412)
413 DATUM OUTSIDE CIRCLE Measuring any four points on the outside of a circle, and defining the center as datum |  | DATUM FROM OUTSIDE OF CIRCLE (Cycle 413, DIN/ISO: G413)
414 DATUM OUTSIDE CORNER Measuring two lines from the outside of a corner, and defining the intersection as datum |  | DATUM FROM OUTSIDE OF CORNER (Cycle 414, DIN/ISO: G414)
415 DATUM INSIDE CORNER Measuring two lines from the inside of a corner, and defining the intersection as datum |  | DATUM FROM INSIDE OF CORNER (Cycle 415, DIN/ISO: G415)
416 DATUM CIRCLE CENTER (2nd soft-key row) Measuring any three holes on a bolt hole circle, and defining the bolt-hole circle center as datum |  | DATUM CIRCLE CENTER (Cycle 416, DIN/ISO: G416)
417 DATUM IN TS AXIS (2nd soft-key row) Measuring any position in the touch probe axis and defining it as datum |  | DATUM IN TOUCH PROBE AXIS (Cycle 417, DIN/ISO: G417)
418 DATUM FROM 4 HOLES (2nd soft-key row) Measuring 4 holes crosswise and defining the intersection of the lines between them as datum |  | DATUM AT CENTER OF 4 HOLES (Cycle 418, DIN/ISO: G418)
419 DATUM IN ONE AXIS (2nd soft-key row) Measuring any position in any axis and defining it as datum |  | DATUM IN ONE AXIS (Cycle 419, DIN/ISO: G419)


Characteristics common to all touch probe cycles for datum setting

You can also run the Touch Probe Cycles 408 to 419 during an active rotation (basic rotation or Cycle 10).
Further Informations:
> Datum point and touch probe axis
> Saving the calculated datum
> Measurement results in Q parameters


Datum point and touch probe axis

From the touch probe axis that you have defined in the measuring program the TNC determines the working plane for the datum.:

Active touch probe axis | Datum setting in
Z or W | X and Y
Y or V | Z and X
X or U | Y and Z


Saving the calculated datum

In all cycles for datum setting you can use the input parameters Q303 and Q305 to define how the TNC is to save the calculated datum:

  • Q305 = 0, Q303 = any value
    The TNC sets the calculated datum in the display. The new datum is active immediately. At the same time, the TNC saves the datum set in the display by the cycle in line 0 of the preset table.
  • Q305 not equal to 0, Q303 = -1

This combination can only occur if you

  • read in programs containing Cycles 410 to 418 created on a TNC 4xx
  • read in programs containing Cycles 410 to 418 created with an older software version on an iTNC 530
  • did not specifically define the measured-value transfer with parameter Q303 when defining the cycle.

In these cases the TNC outputs an error message, since the complete handling of REF-referenced datum tables has changed. You must define a measured-value transfer yourself with parameter Q303.

  • Q305 not equal to 0, Q303 = 0
    The TNC writes the calculated datum in the active datum table. The reference system is the active workpiece coordinate system. The value of parameter Q305 determines the datum number. Activate the datum with Cycle 7 in the part program.
  • Q305 not equal to 0, Q303 = 1
    The TNC writes the calculated datum in the preset table. The reference system is the machine coordinate system (REF coordinates). The value of parameter Q305 determines the preset number. Activate the preset with Cycle 247 in the part program.


Measurement results in Q parameters

The TNC saves the measurement results of the respective touch probe cycle in the globally effective Q parameters Q150 to Q160. You can use these parameters in your program. Note the table of result parameters listed with every cycle description.


SLOT CENTER REF PT (Cycle 408, DIN/ISO: G408, FCL 3 Function)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 408 finds the center of a slot and defines its center as datum. If desired, the TNC can also enter the coordinates into a datum table or the preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves either paraxially at the measuring height or linearly at the clearance height to the next starting point 2 and probes the second touch point.
  4. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum) and saves the actual values in the Q parameters listed below.
  5. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing.
Parameter number | Meaning
Q166 | Actual value of measured slot width
Q157 | Actual value of the centerline


Please note while programming:

Danger of collision!

To prevent a collision between touch probe and workpiece, enter a low estimate for the slot width.

If the slot width and the safety clearance do not permit pre-positioning in the proximity of the touch points, the TNC always starts probing from the center of the slot. In this case the touch probe does not return to the clearance height between the two measuring points.

Before a cycle definition you must have programmed a tool call to define the touch probe axis.


Cycle parameters

Center in 1st axis Q321 (absolute): Center of the slot in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q322 (absolute): Center of the slot in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Width of slot Q311 (incremental): Width of the slot, regardless of its position in the working plane. Input range 0 to 99999.9999

Measuring axis (1=1st axis / 2=2nd axis) Q272: Axis in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the slot center. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the slot center. If you enter Q305=0 and Q303=0, the TNC writes the slot center in line 0 of the datum table. Input range 0 to 99999

New datum Q405 (absolute): Coordinate in the measuring axis at which the TNC should set the calculated slot center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 TCH PROBE 408 SLOT CENTER REF PT
Q321=+50 ;CENTER IN 1ST AXIS
Q322=+50 ;CENTER IN 2ND AXIS
Q311=25 ;SLOT WIDTH
Q272=1 ;MEASURING AXIS
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q305=10 ;NO. IN TABLE
Q405=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999


RIDGE CENTER REF PT (Cycle 409, DIN/ISO: G409, FCL 3 function)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 409 finds the center of a ridge and defines its center as datum. If desired, the TNC can also enter the coordinates into a datum table or the preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves at clearance height to the next touch point 2 and probes the second touch point.
  4. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum) and saves the actual values in the Q parameters listed below.
  5. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing.
Parameter number | Meaning
Q166 | Actual value of measured ridge width
Q157 | Actual value of the centerline


Please note while programming:

Danger of collision!

To prevent a collision between touch probe and workpiece, enter a high estimate for the ridge width.

Before a cycle definition you must have programmed a tool call to define the touch probe axis.


Cycle parameters

Center in 1st axis Q321 (absolute): Center of the ridge in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q322 (absolute): Center of the ridge in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Width of ridge Q311 (incremental): Width of the ridge, regardless of its position in the working plane. Input range 0 to 99999.9999

Measuring axis (1=1st axis / 2=2nd axis) Q272: Axis in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the ridge center. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the ridge center. If you enter Q305=0 and Q303=0, the TNC writes the ridge center in line 0 of the datum table. Input range 0 to 99999

New datum Q405 (absolute): Coordinate in the measuring axis at which the TNC should set the calculated ridge center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Example: NC blocks
5 TCH PROBE 409 SLOT CENTER RIDGE
Q321=+50 ;CENTER IN 1ST AXIS
Q322=+50 ;CENTER IN 2ND AXIS
Q311=25 ;RIDGE WIDTH
Q272=1 ;MEASURING AXIS
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q305=10 ;NO. IN TABLE
Q405=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999


DATUM FROM INSIDE OF RECTANGLE (Cycle 410, DIN/ISO: G410)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 410 finds the center of a rectangular pocket and defines its center as datum. If desired, the TNC can also enter the coordinates into a datum table or the preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves either paraxially at the measuring height or linearly at the clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum).
  6. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing and saves the actual values in the following Q parameters.
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q154 | Actual value of length in the reference axis
Q155 | Actual value of length in the minor axis


Please note while programming:

Danger of collision!

To prevent a collision between touch probe and workpiece, enter low estimates for the lengths of the first and second sides.

If the dimensions of the pocket and the safety clearance do not permit pre-positioning in the proximity of the touch points, the TNC always starts probing from the center of the pocket. In this case the touch probe does not return to the clearance height between the four measuring points.

Before a cycle definition you must have programmed a tool call to define the touch probe axis.


Cycle parameters

Center in 1st axis Q321 (absolute): Center of the pocket in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q322 (absolute): Center of the pocket in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st side length Q323 (incremental): Pocket length, parallel to the reference axis of the working plane. Input range 0 to 99999.9999

2nd side length Q324 (incremental): Pocket length, parallel to the minor axis of the working plane. Input range 0 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the pocket center. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is at the center of the pocket. If you enter Q305=0 and Q303=0, the TNC writes the pocket center in line 0 of the datum table. Input range 0 to 99999

New datum for reference axis Q331 (absolute): Coordinate in the reference axis at which the TNC should set the pocket center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

New datum for minor axis Q332 (absolute): Coordinate in the minor axis at which the TNC should set the pocket center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 tch probe 410 DATUM INSIDE RECTAN.
Q321=+50 ;CENTER IN 1ST AXIS
Q322=+50 ;CENTER IN 2ND AXIS
Q323=60 ;1ST SIDE LENGTH
Q324=20 ;2ND SIDE LENGTH
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q305=10 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999


DATUM FROM OUTSIDE OF RECTANGLE (Cycle 411, DIN/ISO: G411)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 411 finds the center of a rectangular stud and defines its center as datum. If desired, the TNC can also enter the coordinates into a datum table or the preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves either paraxially at the measuring height or linearly at the clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum).
  6. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing and saves the actual values in the following Q parameters.
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q154 | Actual value of length in the reference axis
Q155 | Actual value of length in the minor axis


Please note while programming:

Danger of collision!

To prevent a collision between the touch probe and workpiece, enter high estimates for the lengths of the first and second sides.

Before a cycle definition you must have programmed a tool call to define the touch probe axis.


Cycle parameters

Center in 1st axis Q321 (absolute): Center of the stud in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q322 (absolute): Center of the stud in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st side length Q323 (incremental): Stud length, parallel to the reference axis of the working plane Input range 0 to 99999.9999

2nd side length Q324 (incremental): Stud length, parallel to the minor axis of the working plane. Input range 0 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the stud center. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the stud center. If you enter Q305=0 and Q303=0, the TNC writes the stud center in line 0 of the datum table. Input range 0 to 99999

New datum for reference axis Q331 (absolute): Coordinate in the reference axis at which the TNC should set the stud center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

New datum for minor axis Q332 (absolute): Coordinate in the minor axis at which the TNC should set the stud center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 TCH PROBE 411 DATUM OUTS. RECTAN.
Q321=+50 ;CENTER IN 1ST AXIS
Q322=+50 ;CENTER IN 2ND AXIS
Q323=60 ;1ST SIDE LENGTH
Q324=20 ;2ND SIDE LENGTH
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q305=0 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999


DATUM FROM INSIDE OF CIRCLE (Cycle 412, DIN/ISO: G412)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 412 finds the center of a circular pocket (or of a hole) and defines its center as datum. If desired, the TNC can also enter the coordinates into a datum table or the preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The TNC derives the probing direction automatically from the programmed starting angle.
  3. Then the touch probe moves in a circular arc either at measuring height or at clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum) and saves the actual values in the Q parameters listed below.
  6. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing.
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q153 | Actual value of diameter


Please note while programming:

Danger of collision!

To prevent a collision between the touch probe and the workpiece, enter a low estimate for the nominal diameter of the pocket (or hole).

If the dimensions of the pocket and the safety clearance do not permit pre-positioning in the proximity of the touch points, the TNC always starts probing from the center of the pocket. In this case the touch probe does not return to the clearance height between the four measuring points.

The smaller the angle increment Q247, the less accurately the TNC can calculate the datum. Minimum input value: 5°

Before a cycle definition you must have programmed a tool call to define the touch probe axis.


Cycle parameters

Center in 1st axis Q321 (absolute): Center of the pocket in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q322 (absolute): Center of the pocket in the minor axis of the working plane. If you program Q322 = 0, the TNC aligns the hole center to the positive Y axis. If you program Q322 not equal to 0, then the TNC aligns the hole center to the nominal position. Input range ‑99999.9999 to 99999.9999

Nominal diameter Q262: Approximate diameter of the circular pocket (or hole). Enter a value that is more likely to be too small than too large. Input range 0 to 99999.9999

Starting angle Q325 (absolute): Angle between the reference axis of the working plane and the first touch point. Input range -360.0000 to 360.0000

Stepping angle Q247 (incremental): Angle between two measuring points. The algebraic sign of the stepping angle determines the direction of rotation (negative = clockwise) in which the touch probe moves to the next measuring point. If you wish to probe a circular arc instead of a complete circle, then program the stepping angle to be less than 90°. Input range -120.0000 to 120.0000

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the pocket center. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is at the center of the pocket. If you enter Q305=0 and Q303=0, the TNC writes the pocket center in line 0 of the datum table. Input range 0 to 99999

New datum for reference axis Q331 (absolute): Coordinate in the reference axis at which the TNC should set the pocket center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

New datum for minor axis Q332 (absolute): Coordinate in the minor axis at which the TNC should set the pocket center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 TCH PROBE 412 DATUM INSIDE CIRCLE
Q321=+50 ;CENTER IN 1ST AXIS
Q322=+50 ;CENTER IN 2ND AXIS
Q262=75 ;NOMINAL DIAMETER
Q325=+0 ;starting angle
Q247=+60 ;stepping angle
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q305=12 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM
Q423=4 ;NO. OF MEAS. POINTS
Q365=1 ;TYPE OF TRAVERSE

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999

No. of measuring points (4/3) Q423: Specify whether the TNC should measure the hole with 4 or 3 probing points: 4: Use 4 measuring points (default setting) 3: Use 3 measuring points

Type of traverse? Line=0/Arc=1 Q365: Definition of the path function with which the touch probe is to move between the measuring points if "traversing to clearance height" (Q301=1) is active:
0: Move in a straight line between measuring points
1: Move in a circular arc between measuring points


DATUM FROM OUTSIDE OF CIRCLE (Cycle 413, DIN/ISO: G413)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 413 finds the center of a circular stud and defines it as datum. If desired, the TNC can also enter the coordinates into a datum table or the preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The TNC derives the probing direction automatically from the programmed starting angle.
  3. Then the touch probe moves in a circular arc either at measuring height or at clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum) and saves the actual values in the Q parameters listed below.
  6. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing.
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q153 | Actual value of diameter


Please note while programming:

Danger of collision!

To prevent a collision between touch probe and workpiece, enter a high estimate for the nominal diameter of the stud.

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The smaller the angle increment Q247, the less accurately the TNC can calculate the datum. Minimum input value: 5°.


Cycle parameters

Center in 1st axis Q321 (absolute): Center of the stud in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q322 (absolute): Center of the stud in the minor axis of the working plane. If you program Q322 = 0, the TNC aligns the hole center to the positive Y axis. If you program Q322 not equal to 0, then the TNC aligns the hole center to the nominal position. Input range ‑99999.9999 to 99999.9999

Nominal diameter Q262: Approximate diameter of the stud. Enter a value that is more likely to be too large than too small. Input range 0 to 99999.9999

Starting angle Q325 (absolute): Angle between the reference axis of the working plane and the first touch point. Input range -360.0000 to 360.0000

Stepping angle Q247 (incremental): Angle between two measuring points. The algebraic sign of the stepping angle determines the direction of rotation (negative = clockwise) in which the touch probe moves to the next measuring point. If you wish to probe a circular arc instead of a complete circle, then program the stepping angle to be less than 90°. Input range -120.0000 to 120.0000

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the stud center. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the stud center. If you enter Q305=0 and Q303=0, the TNC writes the stud center in line 0 of the datum table. Input range 0 to 99999

New datum for reference axis Q331 (absolute): Coordinate in the reference axis at which the TNC should set the stud center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

New datum for minor axis Q332 (absolute): Coordinate in the minor axis at which the TNC should set the stud center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 TCH PROBE 413 DATUM OUTSIDE CIRCLE
Q321=+50 ;CENTER IN 1ST AXIS
Q322=+50 ;CENTER IN 2ND AXIS
Q262=75 ;NOMINAL DIAMETER
Q325=+0 ;starting angle
Q247=+60 ;stepping angle
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q305=15 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM
Q423=4 ;NO. OF MEAS. POINTS
Q365=1 ;TYPE OF TRAVERSE

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0

No. of measuring points (4/3) Q423: Specify whether the TNC should measure the stud with 4 or 3 probing points: 4: Use 4 measuring points (default setting) 3: Use 3 measuring points

Type of traverse? Line=0/Arc=1 Q365: Definition of the path function with which the touch probe is to move between the measuring points if "traversing to clearance height" (Q301=1) is active.
0: Move in a straight line between measuring points
1: Move in a circular arc between measuring points


DATUM FROM OUTSIDE OF CORNER (Cycle 414, DIN/ISO: G414)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 414 finds the intersection of two lines and defines it as the datum. If desired, the TNC can also enter the intersection into a datum table or preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the probe starting point 1 (see figure at upper right). The TNC offsets the touch probe by the safety clearance in the direction opposite to the respective traverse direction.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The TNC derives the probing direction automatically from the programmed 3rd measuring point.
  3. Then the touch probe moves to the next starting position 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum) and saves the coordinates of the determined corner in the Q parameters listed below.
  6. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing.
Parameter number | Meaning
Q151 | Actual value of corner in reference axis
Q152 | Actual value of corner in minor axis


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The TNC always measures the first line in the direction of the minor axis of the working plane.

By defining the positions of the measuring points 1 and 3 you also determine the corner at which the TNC sets the datum (see figure at right and table below).

Corner | X coordinate | Y coordinate
A | Point 1 greater than point 3 | Point 1 less than point 3
B | Point 1 less than point 3 | Point 1 less than point 3
C | Point 1 less than point 3 | Point 1 greater than point 3
D | Point 1 greater than point 3 | Point 1 greater than point 3


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Spacing in 1st axis Q326 (incremental): Distance between the first and second measuring points in the reference axis of the working plane. Input range 0 to 99999.9999

3rd meas. point 1st axis Q296 (absolute): Coordinate of the third touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

3rd meas. point 2nd axis Q297 (absolute): Coordinate of the third touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Spacing in 2nd axis Q327 (incremental): Distance between the third and fourth measuring points in the minor axis of the working plane. Input range 0 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Execute basic rotation Q304: Definition of whether the TNC should compensate workpiece misalignment with a basic rotation: 0: No basic rotation 1: Basic rotation

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the corner. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the corner. If you enter Q305=0 and Q303=0, the TNC writes the corner in line 0 of the datum table. Input range 0 to 99999

New datum for reference axis Q331 (absolute): Coordinate in the reference axis at which the TNC should set the corner. Default setting = 0. Input range ‑99999.9999 to 99999.9999

New datum for minor axis Q332 (absolute): Coordinate in the minor axis at which the TNC should set the corner. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 TCH PROBE 414 DATUM INSIDE CORNER
Q263=+37 ;1ST POINT 1ST AXIS
Q264=+7 ;1ST POINT 2ND AXIS
Q326=50 ;SPACING IN 1ST AXIS
Q296=+95 ;3RD POINT 1ST AXIS
Q297=+25 ;3RD POINT 2ND AXIS
Q327=45 ;SPACING IN 2ND AXIS
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q304=0 ;BASIC ROTATION
Q305=7 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999


DATUM FROM INSIDE OF CORNER (Cycle 415, DIN/ISO: G415)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 415 finds the intersection of two lines and defines it as the datum. If desired, the TNC can also enter the intersection into a datum table or preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the starting point 1 (see figure at upper right) for probing the first touch point defined in the cycle. The TNC offsets the touch probe by the safety clearance in the direction opposite to the respective traverse direction.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The probing direction is derived from the number by which you identify the corner.
  3. Then the touch probe moves to the next starting position 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum) and saves the coordinates of the determined corner in the Q parameters listed below.
  6. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing.
Parameter number | Meaning
Q151 | Actual value of corner in reference axis
Q152 | Actual value of corner in minor axis


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The TNC always measures the first line in the direction of the minor axis of the working plane.


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Spacing in 1st axis Q326 (incremental): Distance between the first and second measuring points in the reference axis of the working plane. Input range 0 to 99999.9999

Spacing in 2nd axis Q327 (incremental): Distance between the third and fourth measuring points in the minor axis of the working plane. Input range 0 to 99999.9999

Corner Q308: Number identifying the corner which the TNC is to set as datum. Input range 1 to 4

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Execute basic rotation Q304: Definition of whether the TNC should compensate workpiece misalignment with a basic rotation: 0: No basic rotation 1: Basic rotation

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the corner. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the corner. If you enter Q305=0 and Q303=0, the TNC writes the corner in line 0 of the datum table. Input range 0 to 99999

New datum for reference axis Q331 (absolute): Coordinate in the reference axis at which the TNC should set the corner. Default setting = 0. Input range ‑99999.9999 to 99999.9999

New datum for minor axis Q332 (absolute): Coordinate in the minor axis at which the TNC should set the corner. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 TCH PROBE 415 DATUM OUTSIDE CORNER
Q263=+37 ;1ST POINT 1ST AXIS
Q264=+7 ;1ST POINT 2ND AXIS
Q326=50 ;SPACING IN 1ST AXIS
Q296=+95 ;3rd point 1st axis
Q297=+25 ;3rd point 2nd axis
Q327=45 ;SPACING IN 2ND AXIS
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q304=0 ;BASIC ROTATION
Q305=7 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999


DATUM CIRCLE CENTER (Cycle 416, DIN/ISO: G416)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 416 finds the center of a bolt hole circle by measuring three holes, and defines the determined center as the datum. If desired, the TNC can also enter the coordinates into a datum table or the preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the point entered as center of the first hole 1.
  2. Then the touch probe moves to the entered measuring height and probes four points to find the first hole center.
  3. The touch probe returns to the clearance height and then to the position entered as center of the second hole 2.
  4. The TNC moves the touch probe to the entered measuring height and probes four points to find the second hole center.
  5. The touch probe returns to the clearance height and then to the position entered as center of the third hole 3.
  6. The TNC moves the touch probe to the entered measuring height and probes four points to find the third hole center.
  7. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum) and saves the actual values in the Q parameters listed below.
  8. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing.
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q153 | Actual value of bolt hole circle diameter


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.


Cycle parameters

Center in 1st axis Q273 (absolute): Bolt-hole circle center (nominal value) in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q274 (absolute): Bolt-hole circle center (nominal value) in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Nominal diameter Q262: Enter the approximate bolt-hole circle diameter. The smaller the hole diameter, the more exact the nominal diameter must be. Input range 0 to 99999.9999

Angle of 1st hole Q291 (absolute): Polar coordinate angle of the first hole center in the working plane. Input range -360.0000 to 360.0000

Angle of 2nd hole Q292 (absolute): Polar coordinate angle of the second hole center in the working plane. Input range -360.0000 to 360.0000

Angle of 3rd hole Q293 (absolute): Polar coordinate angle of the third hole center in the working plane. Input range -360.0000 to 360.0000

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Number in table Q305: Enter the number in the datum/preset table in which the TNC is to save the coordinates of the bolt-hole circle center. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the bolt-hole circle center. If you enter Q305=0 and Q303=0, the TNC writes the bolt-hole circle center in line 0 of the datum table. Input range 0 to 99999

New datum for reference axis Q331 (absolute): Coordinate in the reference axis at which the TNC should set the bolt-hole circle center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

New datum for minor axis Q332 (absolute): Coordinate in the minor axis at which the TNC should set the bolt-hole circle center. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 TCH PROBE 416 DATUM CIRCLE CENTER
Q273=+50 ;CENTER IN 1ST AXIS
Q274=+50 ;CENTER IN 2ND AXIS
Q262=90 ;NOMINAL DIAMETER
Q291=+34 ;ANGLE OF 1ST HOLE
Q292=+70 ;ANGLE OF 2ND HOLE
Q293=+210 ;ANGLE OF 3RD HOLE
Q261=-5 ;MEASURING HEIGHT
Q260=+20 ;CLEARANCE HEIGHT
Q305=12 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+1 ;DATUM
Q320=0 ;SET-UP CLEARANCE

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140, and is only effective when the datum is probed in the touch probe axis. Input range 0 to 99999.9999; alternatively PREDEF


DATUM IN TOUCH PROBE AXIS (Cycle 417, DIN/ISO: G417)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 417 measures any coordinate in the touch probe axis and defines it as datum. If desired, the TNC can also enter the measured coordinate in a datum table or preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the programmed probe starting point 1 at rapid traverse (value from MP6150). The TNC offsets the touch probe by the safety clearance in the positive direction of the touch probe axis.
  2. Then the touch probe moves in its own axis to the coordinate entered as touch point 1 and measures the actual position with a simple probing movement.
  3. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum) and saves the actual value in the Q parameter listed below.
Parameter number | Meaning
Q160 | Actual value of measured point


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis. The TNC then sets the datum in this axis.


Cycle parameters

Example: NC blocks
5 TCH PROBE 417 DATUM IN TS AXIS
Q263=+25 ;1ST POINT 1ST AXIS
Q264=+25 ;1ST POINT 2ND AXIS
Q294=+25 ;1ST POINT 3RD AXIS
Q320=0 ;SET-UP CLEARANCE
Q260=+50 ;CLEARANCE HEIGHT
Q305=0 ;NO. IN TABLE
Q333=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 3rd axis Q294 (absolute): Coordinate of the first touch point in the touch probe axis. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Number in table Q305: Enter the number in the datum or preset table in which the TNC is to save the coordinate. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the probed surface. If you enter Q305=0 and Q303=0, the TNC writes the coordinate in line 0 of the datum table. Input range 0 to 99999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).


DATUM AT CENTER OF 4 HOLES (Cycle 418, DIN/ISO: G418)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 418 calculates the intersection of the lines connecting opposite holes and sets the datum at the intersection. If desired, the TNC can also enter the intersection into a datum table or preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the center of the first hole 1.
  2. Then the touch probe moves to the entered measuring height and probes four points to find the first hole center.
  3. The touch probe returns to the clearance height and then to the position entered as center of the second hole 2.
  4. The TNC moves the touch probe to the entered measuring height and probes four points to find the second hole center.
  5. The TNC repeats steps 3 and 4 for the holes 3 and 4.
  6. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum). The TNC calculates the datum as the intersection of the lines connecting the centers of holes 1/3 and 2/4 and saves the actual values in the Q parameters listed below.
  7. If desired, the TNC subsequently measures the datum in the touch probe axis in a separate probing.
Parameter number | Meaning
Q151 | Actual value of intersection point in reference axis
Q152 | Actual value of intersection point in minor axis


Cycle parameters

First center in 1st axis Q268 (absolute): Center of the 1st hole in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

First center in 2nd axis Q269 (absolute): Center of the 1st hole in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Second center in 1st axis Q270 (absolute): Center of the 2nd hole in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Second center in 2nd axis Q271 (absolute): Center of the 2nd hole in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Third center in 1st axis Q316 (absolute): Center of the 3rd hole in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Third center in 2nd axis Q317 (absolute): Center of the 3rd hole in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Fourth center in 1st axis Q318 (absolute): Center of the 4th hole in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Fourth center in 2nd axis Q319 (absolute): Center of the 4th hole in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Number in table Q305: Enter the number in the datum or preset table in which the TNC is to save the coordinates of the line intersection. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is at the intersection of the connecting lines. If you enter Q305=0 and Q303=0, the TNC writes the coordinates of the line intersection in line 0 of the datum table. Input range 0 to 99999

New datum for reference axis Q331 (absolute): Coordinate in the reference axis at which the TNC should set the calculated intersection of the connecting lines. Default setting = 0. Input range ‑99999.9999 to 99999.9999

New datum for minor axis Q332 (absolute): Coordinate in the minor axis at which the TNC should set the calculated intersection of the connecting lines. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. Is entered by the TNC when old programs are read in (see Saving the calculated datum). 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).

Example: NC blocks
5 TCH PROBE 418 DATUM FROM 4 HOLES
Q268=+20 ;1ST CENTER IN 1ST AXIS
Q269=+25 ;1ST CENTER IN 2ND AXIS
Q270=+150 ;2ND CENTER IN 1ST AXIS
Q271=+25 ;2ND CENTER IN 2ND AXIS
Q316=+150 ;3RD CENTER IN 1ST AXIS
Q317=+85 ;3RD CENTER IN 2ND AXIS
Q318=+22 ;4TH CENTER IN 1ST AXIS
Q319=+80 ;4TH CENTER IN 2ND AXIS
Q261=-5 ;MEASURING HEIGHT
Q260=+10 ;CLEARANCE HEIGHT
Q305=12 ;NO. IN TABLE
Q331=+0 ;DATUM
Q332=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER
Q381=1 ;PROBE IN TS AXIS
Q382=+85 ;1ST CO. FOR TS AXIS
Q383=+50 ;2ND CO. FOR TS AXIS
Q384=+0 ;3RD CO. FOR TS AXIS
Q333=+0 ;DATUM

Probe in TS axis Q381: Specify whether the TNC should also set the datum in the touch probe axis: 0: Do not set the datum in the touch probe axis 1: Set the datum in the touch probe axis

Probe TS axis: Coord. 1st axis Q382 (absolute): Coordinate of the probe point in the reference axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1

Probe TS axis: Coord. 2nd axis Q383 (absolute): Coordinate of the probe point in the minor axis of the working plane at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

Probe TS axis: Coord. 3rd axis Q384 (absolute): Coordinate of the probe point in the touch probe axis, at which point the datum is to be set in the touch probe axis. Only effective if Q381 = 1. Input range ‑99999.9999 to 99999.9999

New datum in TS axis Q333 (absolute): Coordinate in the touch probe axis at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999


DATUM IN ONE AXIS (Cycle 419, DIN/ISO: G419)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 419 measures any coordinate in any axis and defines it as datum. If desired, the TNC can also enter the measured coordinate in a datum table or preset table.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the programmed touch point 1. The TNC offsets the touch probe by the safety clearance in the direction opposite the programmed probing direction.
  2. Then the touch probe moves to the programmed measuring height and measures the actual position with a simple probing movement.
  3. Finally the TNC returns the touch probe to the clearance height and processes the determined datum depending on the cycle parameters Q303 and Q305 (see Saving the calculated datum).


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

If you use Cycle 419 several times in succession to save the datum in more than one axis in the preset table, you must activate the preset number last written to by Cycle 419 after every execution of Cycle 419 (this is not required if you overwrite the active preset).


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Measuring axis (1...3: 1=reference axis) Q272: Axis in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis 3: Touch probe axis = measuring axis

Axis assignment
Active touch probe axis: Q272= 3 | Corresponding reference axis: Q272 = 1 | Corresponding minor axis: Q272 = 2
Z | X | Y
Y | Z | X
X | Y | Z
Example: NC blocks
5 TCH PROBE 419 DATUM IN ONE AXIS
Q263=+25 ;1ST POINT 1ST AXIS
Q264=+25 ;1ST POINT 2ND AXIS
Q261=+25 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+50 ;CLEARANCE HEIGHT
Q272=+1 ;MEASURING AXIS
Q267=+1 ;TRAVERSE DIRECTION
Q305=0 ;NO. IN TABLE
Q333=+0 ;DATUM
Q303=+1 ;MEAS. VALUE TRANSFER

Traverse direction Q267: Direction in which the touch probe is to approach the workpiece: -1: Negative traverse direction +1: Positive traverse direction

Number in table Q305: Enter the number in the datum or preset table in which the TNC is to save the coordinate. If you enter Q305=0 and Q303=1, the TNC automatically sets the display so that the new datum is on the probed surface. If you enter Q305=0 and Q303=0, the TNC writes the coordinate in line 0 of the datum table. Input range 0 to 99999

Datum number in table Q305: Enter the number in the datum or preset table in which the TNC is to save the coordinate. If you enter Q305=0, the TNC automatically sets the display so that the new datum is on the probed surface. Input range 0 to 99999

New datum Q333 (absolute): Coordinate at which the TNC should set the datum. Default setting = 0. Input range ‑99999.9999 to 99999.9999

Measured-value transfer (0, 1) Q303: Specify whether the determined datum is to be saved in the datum table or in the preset table: -1: Do not use. See Saving the calculated datum 0: Write determined datum in the active datum table. The reference system is the active workpiece coordinate system. 1: Write determined datum in the preset table. The reference system is the machine coordinate system (REF system).


Touch Probe Cycles: Automatic Datum Setting

Example: Datum setting in center of a circular segment and on top surface of workpiece

0 begin pgm cyc413 mm |
1 tool call 69 z | Call tool 0 to define the touch probe axis
2 TCH PROBE 413 DATUM OUTSIDE CIRCLE |
Q321=+25 ;CENTER IN 1ST AXIS | Center of circle: X coordinate
Q322=+25 ;CENTER IN 2ND AXIS | Center of circle: Y coordinate
Q262=30 ;NOMINAL DIAMETER | Circle diameter
Q325=+90 ;starting angle | Polar coordinate angle for 1st touch point
Q247=+45 ;stepping angle | Stepping angle for calculating the touch points 2 to 4
Q261=-5 ;MEASURING HEIGHT | Coordinate in the touch probe axis in which the measurement is made
Q320=2 ;SET-UP CLEARANCE | Safety clearance in addition to MP6140
Q260=+10 ;CLEARANCE HEIGHT | Height in the touch probe axis at which the probe can traverse without collision
Q301=0 ;MOVE TO CLEARANCE | Do not move to clearance height between measuring points
Q305=0 ;NO. IN TABLE | Set display
Q331=+0 ;DATUM | Set the display in X to 0
Q332=+10 ;DATUM | Set the display in Y to 10
Q303=+0 ;MEAS. VALUE TRANSFER | Without function, since display is to be set
Q381=1 ;PROBE IN TS AXIS | Also set datum in the touch probe axis
Q382=+25 ;1ST CO. FOR TS AXIS | X coordinate of touch point
Q383=+25 ;2ND CO. FOR TS AXIS | Y coordinate of touch point
Q384=+25 ;3RD CO. FOR TS AXIS | Z coordinate of touch point
Q333=+0 ;DATUM | Set the display in Z to 0
Q423=4 ;NO. OF MEAS. POINTS | Number of measuring points
Q365=1 ;TYPE OF TRAVERSE | Position in circular arc or in straight line to the next touch point
3 call pgm 35k47 | Call part program
4 end pgm cyc413 mm |


Touch Probe Cycles: Automatic Datum Setting

Example: Datum setting on top surface of workpiece and in center of a bolt hole circle

The measured bolt-hole circle center shall be written in the preset table so that it may be used at a later time.

0 begin pgm cyc416 mm |
1 tool call 69 z | Call tool 0 to define the touch probe axis
2 TCH PROBE 417 DATUM IN TS AXIS | Cycle definition for datum setting in the touch probe axis
Q263=+7.5 ;1ST POINT 1ST AXIS | Touch point: X coordinate
Q264=+7.5 ;1ST POINT 2ND AXIS | Touch point: Y coordinate
Q294=+25 ;1ST POINT 3RD AXIS | Touch point: Z coordinate
Q320=0 ;SET-UP CLEARANCE | Safety clearance in addition to MP6140
Q260=+50 ;CLEARANCE HEIGHT | Height in the touch probe axis at which the probe can traverse without collision
Q305=1 ;NO. IN TABLE | Write Z coordinate in line 1
Q333=+0 ;DATUM | Set touch-probe axis to 0
Q303=+1 ;MEAS. VALUE TRANSFER | In the preset table PRESET.PR, save the calculated datum referenced to the machine-based coordinate system (REF system)
3 TCH PROBE 416 DATUM CIRCLE CENTER |
Q273=+35 ;CENTER IN 1ST AXIS | Center of the bolt hole circle: X coordinate
Q274=+35 ;CENTER IN 2ND AXIS | Center of the bolt hole circle: Y coordinate
Q262=50 ;NOMINAL DIAMETER | Diameter of the bolt hole circle
Q291=+90 ;ANGLE OF 1ST HOLE | Polar coordinate angle for 1st hole center 1
Q292=+180 ;ANGLE OF 2ND HOLE | Polar coordinate angle for 2nd hole center 2
Q293=+270 ;ANGLE OF 3RD HOLE | Polar coordinate angle for 3rd hole center 3
Q261=+15 ;MEASURING HEIGHT | Coordinate in the touch probe axis in which the measurement is made
Q260=+10 ;CLEARANCE HEIGHT | Height in the touch probe axis at which the probe can traverse without collision
Q305=1 ;NO. IN TABLE | Enter center of bolt hole circle (X and Y) in line 1
Q331=+0 ;DATUM |
Q332=+0 ;DATUM |
Q303=+1 ;MEAS. VALUE TRANSFER | In the preset table PRESET.PR, save the calculated datum referenced to the machine-based coordinate system (REF system)
Q381=0 ;PROBE IN TS AXIS | Do not set a datum in the touch probe axis
Q382=+0 ;1ST CO. FOR TS AXIS | No function
Q383=+0 ;2ND CO. FOR TS AXIS | No function
Q384=+0 ;3RD CO. FOR TS AXIS | No function
Q333=+0 ;DATUM | No function
Q320=0 ;SET-UP CLEARANCE | Safety clearance in addition to MP6140
4 cycl def 247 DATUM SETTING | Activate new preset with Cycle 247
Q339=1 ;DATUM NUMBER |
6 call pgm 35klz | Call part program
7 end pgm cyc416 mm |


Touch Probe Cycles: Automatic Workpiece Inspection

Further Informations:
> Fundamentals
> REF. PLANE (Cycle 0, DIN/ISO: G55)
> POLAR REFERENCE PLANE (Cycle 1)
> MEASURE ANGLE (Cycle 420, DIN/ISO: G420)
> MEASURE HOLE (Cycle 421, DIN/ISO: G421)
> MEASURE CIRCLE OUTSIDE (Cycle 422, DIN/ISO: G422)
> MEASURE RECTANGLE INSIDE (Cycle 423, DIN/ISO: G423)
> MEASURE RECTANGLE OUTSIDE (Cycle 424, DIN/ISO: G424)
> MEASURE INSIDE WIDTH (Cycle 425, DIN/ISO: G425)
> MEASURE RIDGE WIDTH (Cycle 426, DIN/ISO: G426)
> MEASURE COORDINATE (Cycle 427, DIN/ISO: G427)
> MEASURE BOLT HOLE CIRCLE (Cycle 430, DIN/ISO: G430)
> MEASURE PLANE (Cycle 431, DIN/ISO: G431)
> Programming examples


Fundamentals

Further Informations:
> Overview
> Recording the results of measurement
> Measurement results in Q parameters
> Classification of results
> Tolerance monitoring
> Tool monitoring
> Reference system for measurement results


Overview

The TNC offers twelve cycles for measuring workpieces automatically.

Cycle | Soft key | Page
0 REFERENCE PLANE Measuring a coordinate in a selectable axis |  | REF. PLANE (Cycle 0, DIN/ISO: G55)
1 POLAR DATUM PLANE Measuring a point in a probing direction |  | POLAR REFERENCE PLANE (Cycle 1)
420 MEASURE ANGLE Measuring an angle in the working plane |  | MEASURE ANGLE (Cycle 420, DIN/ISO: G420)
421 MEASURE HOLE Measuring the position and diameter of a hole |  | MEASURE HOLE (Cycle 421, DIN/ISO: G421)
422 MEASURE CIRCLE OUTSIDE Measuring the position and diameter of a circular stud |  | MEASURE CIRCLE OUTSIDE (Cycle 422, DIN/ISO: G422)
423 MEASURE RECTANGLE INSIDE Measuring the position, length and width of a rectangular pocket |  | MEASURE RECTANGLE INSIDE (Cycle 423, DIN/ISO: G423)
424 MEASURE RECTANGLE OUTSIDE Measuring the position, length and width of a rectangular stud |  | MEASURE RECTANGLE OUTSIDE (Cycle 424, DIN/ISO: G424)
425 MEASURE INSIDE WIDTH (2nd soft-key row) Measuring the width of a slot |  | MEASURE INSIDE WIDTH (Cycle 425, DIN/ISO: G425)
426 MEASURE RIDGE WIDTH (2nd soft-key row) Measuring the width of a ridge |  | MEASURE RIDGE WIDTH (Cycle 426, DIN/ISO: G426)
427 MEASURE COORDINATE (2nd soft-key row) Measuring any coordinate in a selectable axis |  | MEASURE COORDINATE (Cycle 427, DIN/ISO: G427)
430 MEASURE BOLT HOLE CIRCLE (2nd soft-key row) Measuring position and diameter of a bolt hole circle |  | MEASURE BOLT HOLE CIRCLE (Cycle 430, DIN/ISO: G430)
431 MEASURE PLANE (2nd soft-key row) Measuring the A and B axis angles of a plane |  | MEASURE PLANE (Cycle 431, DIN/ISO: G431)


Recording the results of measurement

For all cycles in which you automatically measure workpieces (with the exception of Cycles 0 and 1), you can have the TNC record the measurement results. In the respective probing cycle you can define if the TNC is to

  • Save the measuring log to a file
  • Interrupt program run and display the measuring log on the screen
  • Create no measuring log

If you want to save the measuring log as a file, the TNC, by default, saves the measuring log as an ASCII file in the directory from which you run the measuring program. As an alternative, you can also send the measuring log directly to a printer or transfer it to a PC via the data interface. To do this, set the print function (in the interface configuration menu) to RS232:\ (see also the User's Manual under “MOD Functions, Setting Up the Data Interface”).

All measured values listed in the log file are referenced to the datum active during the respective cycle you are running. In addition, the coordinate system may have been rotated in the plane or the plane may have been tilted by using 3-D ROT. In this case, the TNC converts the measuring results to the respective active coordinate system.

Use the HEIDENHAIN data transfer software TNCremo if you wish to output the measuring log via the data interface.

Example: Measuring log for touch probe cycle 421:

Measuring log for Probing Cycle 421 Hole Measuring

Date: 30-06-2005
Time: 6:55:04
Measuring program: TNC:\GEH35712\CHECK1.H

Nominal values:
Center in reference axis: 50.0000
Center in minor axis: 65.0000
Diameter: 12.0000

Given limit values:
Maximum dimension for center in reference axis: 50.1000
Minimum dimension for center in reference axis: 49.9000
Maximum dimension for center in minor axis: 65.1000
Minimum dimension for center in minor axis: 64.9000
Maximum dimension for hole: 12.0450
Minimum dimension for hole: 12.0000

Actual values: Center
Reference axis: 50.0810
Center in minor axis: 64.9530
Diameter: 12.0259

Deviations:
Center in reference axis: 0.0810
Center in minor axis: -0.0470
Diameter: 0.0259

Further measuring results: Measuring height: -5.0000

End of measuring log


Measurement results in Q parameters

The TNC saves the measurement results of the respective touch probe cycle in the globally effective Q parameters Q150 to Q160. Deviations from the nominal value are saved in the parameters Q161 to Q166. Note the table of result parameters listed with every cycle description.

During cycle definition the TNC also shows the result parameters for the respective cycle in a help graphic (see figure at upper right). The highlighted result parameter belongs to that input parameter.


Classification of results

For some cycles you can inquire the status of measuring results through the globally effective Q parameters Q180 to Q182.:

Class of results | Parameter value
Measurement results are within tolerance | Q180 = 1
Rework is required | Q181 = 1
Scrap | Q182 = 1

The TNC sets the rework or scrap marker as soon as one of the measuring values falls outside of tolerance. To determine which of the measuring results lies outside of tolerance, check the measuring log, or compare the respective measuring results (Q150 to Q160) with their limit values.

In Cycle 427 the TNC assumes that you are measuring an outside dimension (stud). However, you can correct the status of the measurement by entering the correct maximum and minimum dimension together with the probing direction.

The TNC also sets the status markers if you have not defined any tolerance values or maximum/minimum dimensions.


Tolerance monitoring

For most of the cycles for workpiece inspection you can have the TNC perform tolerance monitoring. This requires that you define the necessary limit values during cycle definition. If you do not wish to monitor for tolerances, simply leave the 0 (the default value) in the monitoring parameters.


Tool monitoring

For some cycles for workpiece inspection you can have the TNC perform tool monitoring. The TNC then monitors whether

  • The tool radius should be compensated because of the deviations from the nominal value (values in Q16x).
  • The deviations from the nominal value (values in Q16x) are greater than the tool breakage tolerance.
Further Informations:
> Tool compensation
> Tool breakage monitoring


Tool compensation

This function works only:

  • If the tool table is active.
  • If tool monitoring is switched on in the cycle (enter a tool name or Q330 unequal to 0). Select the tool name input by soft key. The TNC no longer displays the right single quotation mark.

If you perform several compensation measurements, the TNC adds the respective measured deviation to the value stored in the tool table.

The TNC always compensates the tool radius in the DR column of the tool table, even if the measured deviation lies within the given tolerance. You can inquire whether re-working is necessary via parameter Q181 in the NC program (Q181=1: must be reworked).

For Cycle 427:

  • If an axis of the active working plane is defined as measuring axis (Q272 = 1 or 2), the TNC compensates the tool radius as described above. From the defined traversing direction (Q267) the TNC determines the direction of compensation.
  • If the touch probe axis is defined as measuring axis (Q272 = 3), the TNC compensates the tool length.


Tool breakage monitoring

This function works only:

  • If the tool table is active.
  • If tool monitoring is switched on in the cycle (enter Q330 not equal to 0).
  • If the breakage tolerance RBREAK for the tool number entered in the table is greater than 0 (see also the User's Manual, section 5.2 "Tool Data").

The TNC will output an error message and stop program run if the measured deviation is greater than the breakage tolerance of the tool. At the same time the tool will be deactivated in the tool table (column TL = L).


Reference system for measurement results

The TNC transfers all the measurement results to the result parameters and the log file in the active coordinate system, or as the case may be, the shifted and/or rotated/tilted coordinate system.


REF. PLANE (Cycle 0, DIN/ISO: G55)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. The touch probe moves at rapid traverse (value from MP6150) to the starting position 1 programmed in the cycle.
  2. Then the touch probe approaches the workpiece at the probing feed rate assigned in MP6120. The probing direction is defined in the cycle.
  3. After the TNC has saved the position, the touch probe retracts to the starting point and saves the measured coordinate in a Q parameter. The TNC also stores the coordinates of the touch probe position at the time of the triggering signal in the parameters Q115 to Q119. For the values in these parameters the TNC does not account for the stylus length and radius.


Please note while programming:

Danger of collision!

Pre-position the touch probe in order to avoid a collision when the programmed pre-positioning point is approached.


Cycle parameters

Example: NC blocks
67 TCH PROBE 0.0 REF. PLANE Q5 X-
68 tch probe 0.1 x+5 y+0 z-5

Parameter number for result: Enter the number of the Q parameter to which you want to assign the coordinate. Input range: 0 to 1999

Probing axis/Probing direction: Enter the probing axis with the axis selection keys or ASCII keyboard and the algebraic sign for the probing direction. Confirm your entry with the ENT key. Input range: All NC axes

Nominal position value: Use the axis selection keys or the ASCII keyboard to enter all coordinates of the nominal pre-positioning point values for the touch probe. Input range ‑99999.9999 to 99999.9999

To conclude the input, press the ENT key.


POLAR REFERENCE PLANE (Cycle 1)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

  1. Touch Probe Cycle 1 measures any position on the workpiece in any direction.
  2. The touch probe moves at rapid traverse (value from MP6150) to the starting position 1 programmed in the cycle.
  3. Then the touch probe approaches the workpiece at the probing feed rate assigned in MP6120. During probing the TNC moves simultaneously in two axes (depending on the probing angle). The probing direction is defined by the polar angle entered in the cycle.
  4. After the TNC has saved the position, the probe returns to the starting point. The TNC also stores the coordinates of the touch probe position at the time of the triggering signal in parameters Q115 to Q119.


Please note while programming:

Danger of collision!

Pre-position the touch probe in order to avoid a collision when the programmed pre-positioning point is approached.

    The probing axis defined in the cycle specifies the probing plane:

  • Probing axis X: X/Y plane
  • Probing axis Y: Y/Z plane
  • Probing axis Z: Z/X plane


Cycle parameters

Example: NC blocks
67 tch probe 1.0 polar reference plane
68 tch probe 1.1 x angle: +30
69 tch probe 1.2 x+5 y+0 z-5

Probing axis: Enter the probing axis with the axis selection keys or ASCII keyboard. Confirm your entry with the ENT key. Input range: X, Y or Z

Probing angle: Angle, measured from the probing axis, at which the touch probe is to move. Input range –180.0000 to 180.0000

Nominal position value: Use the axis selection keys or the ASCII keyboard to enter all coordinates of the nominal pre-positioning point values for the touch probe. Input range ‑99999.9999 to 99999.9999

To conclude the input, press the ENT key.


MEASURE ANGLE (Cycle 420, DIN/ISO: G420)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 420 measures the angle that any straight surface on the workpiece describes with respect to the reference axis of the working plane.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the programmed touch point 1. The TNC offsets the touch probe by the safety clearance in the direction opposite to the defined traverse direction.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves to the next starting position 2 and probes the second touch point.
  4. The TNC returns the touch probe to the clearance height and saves the measured angle in the following Q parameter:
Parameter number | Meaning
Q150 | The measured angle is referenced to the reference axis of the machining plane.


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

If touch probe axis = measuring axis, set Q263 equal to Q265 if the angle about the A axis is to be measured; set Q263 not equal to Q265 if the angle is to be measured about the B axis.


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 1st axis Q265 (absolute): Coordinate of the second touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 2nd axis Q266 (absolute): Coordinate of the second touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Measuring axis Q272: Axis in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis 3: Touch probe axis = measuring axis

Example: NC blocks
5 TCH PROBE 420 MEASURE ANGLE
Q263=+10 ;1ST POINT 1ST AXIS
Q264=+10 ;1ST POINT 2ND AXIS
Q265=+15 ;2nd point 1st axis
Q266=+95 ;2nd point 2nd axis
Q272=1 ;MEASURING AXIS
Q267=-1 ;TRAVERSE DIRECTION
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+10 ;CLEARANCE HEIGHT
Q301=1 ;MOVE TO CLEARANCE
Q281=1 ;MEASURING LOG

Traverse direction 1 Q267: Direction in which the touch probe is to approach the workpiece: -1: Negative traverse direction +1: Positive traverse direction

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR420.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.


MEASURE HOLE (Cycle 421, DIN/ISO: G421)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 421 measures the center and diameter of a hole (or circular pocket). If you define the corresponding tolerance values in the cycle, the TNC makes a nominal-to-actual value comparison and saves the deviation values in system parameters.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The TNC derives the probing direction automatically from the programmed starting angle.
  3. Then the touch probe moves in a circular arc either at measuring height or at clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and saves the actual values and the deviations in the following Q parameters:
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q153 | Actual value of diameter
Q161 | Deviation at center of reference axis
Q162 | Deviation at center of minor axis
Q163 | Deviation from diameter


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The smaller the angle, the less accurately the TNC can calculate the hole dimensions. Minimum input value: 5°.


Cycle parameters

Center in 1st axis Q273 (absolute): Center of the hole in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q274 (absolute): Center of the hole in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Nominal diameter Q262: Enter the diameter of the hole. Input range 0 to 99999.9999

Starting angle Q325 (absolute): Angle between the reference axis of the working plane and the first touch point. Input range -360.0000 to 360.0000

Stepping angle Q247 (incremental): Angle between two measuring points. The algebraic sign of the stepping angle determines the direction of rotation (negative = clockwise). If you wish to probe a circular arc instead of a complete circle, then program the stepping angle to be less than 90°. Input range -120.0000 to 120.0000

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Maximum limit of size for hole Q275: Maximum permissible diameter for the hole (circular pocket). Input range 0 to 99999.9999

Minimum limit of size for hole Q276: Minimum permissible diameter for the hole (circular pocket). Input range 0 to 99999.9999

Tolerance for center 1st axis Q279: Permissible position deviation in the reference axis of the working plane. Input range 0 to 99999.9999

Tolerance for center 2nd axis Q280: Permissible position deviation in the minor axis of the working plane. Input range 0 to 99999.9999

Example: NC blocks
5 TCH PROBE 421 MEASURE HOLE
Q273=+50 ;CENTER IN 1ST AXIS
Q274=+50 ;CENTER IN 2ND AXIS
Q262=75 ;NOMINAL DIAMETER
Q325=+0 ;starting angle
Q247=+60 ;stepping angle
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=1 ;MOVE TO CLEARANCE
Q275=75.12 ;MAX. LIMIT
Q276=74.95 ;MIN. LIMIT
Q279=0.1 ;TOLERANCE 1ST CENTER
Q280=0.1 ;TOLERANCE 2ND CENTER
Q281=1 ;MEASURING LOG
Q309=0 ;PGM STOP IF ERROR
Q330=0 ;TOOL
Q423=4 ;NO. OF MEAS. POINTS
Q365=1 ;TYPE OF TRAVERSE

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR421.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.

PGM stop if tolerance error Q309: Definition of whether in the event of a violation of tolerance limits the TNC is to interrupt program run and output an error message: 0: Do not interrupt program run, no error message 1: Interrupt program run, output an error message

Tool for monitoring Q330: Definition of whether the TNC is to monitor the tool (see Tool monitoring). Input range: 0 to 32767.9, alternatively tool name with max. 16 characters 0: Monitoring not active >0: Tool number in the tool table TOOL.T

No. of measuring points (4/3) Q423: Specify whether the TNC should measure the hole with 4 or 3 probing points: 4: Use 4 measuring points (default setting) 3: Use 3 measuring points

Type of traverse? Line=0/Arc=1 Q365: Definition of the path function with which the touch probe is to move between the measuring points if "traversing to clearance height" (Q301=1) is active:
0: Move in a straight line between measuring points
1: Move in a circular arc between measuring points


MEASURE CIRCLE OUTSIDE (Cycle 422, DIN/ISO: G422)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 422 measures the center and diameter of a circular stud. If you define the corresponding tolerance values in the cycle, the TNC makes a nominal-to-actual value comparison and saves the deviation values in system parameters.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The TNC derives the probing direction automatically from the programmed starting angle.
  3. Then the touch probe moves in a circular arc either at measuring height or at clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and saves the actual values and the deviations in the following Q parameters:
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q153 | Actual value of diameter
Q161 | Deviation at center of reference axis
Q162 | Deviation at center of minor axis
Q163 | Deviation from diameter


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

The smaller the angle, the less accurately the TNC can calculate the dimensions of the stud. Minimum input value: 5°


Cycle parameters

Center in 1st axis Q273 (absolute): Center of the stud in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q274 (absolute): Center of the stud in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Nominal diameter Q262: Enter the diameter of the stud. Input range 0 to 99999.9999

Starting angle Q325 (absolute): Angle between the reference axis of the working plane and the first touch point. Input range -360.0000 to 360.0000

Stepping angle Q247 (incremental): Angle between two measuring points. The algebraic sign of the stepping angle determines the direction of rotation (negative = clockwise). If you wish to probe a circular arc instead of a complete circle, then program the stepping angle to be less than 90°. Input range -120.0000 to 120.0000

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Maximum limit of size for stud Q277: Maximum permissible diameter for the stud. Input range 0 to 99999.9999

Minimum limit of size for stud Q278: Minimum permissible diameter for the stud. Input range 0 to 99999.9999

Tolerance for center 1st axis Q279: Permissible position deviation in the reference axis of the working plane. Input range 0 to 99999.9999

Tolerance for center 2nd axis Q280: Permissible position deviation in the minor axis of the working plane. Input range 0 to 99999.9999

Example: NC blocks
5 TCH PROBE 422 MEAS. CIRCLE OUTSIDE
Q273=+50 ;CENTER IN 1ST AXIS
Q274=+50 ;CENTER IN 2ND AXIS
Q262=75 ;NOMINAL DIAMETER
Q325=+90 ;starting angle
Q247=+30 ;stepping angle
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+10 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q277=35.15 ;MAX. LIMIT
Q278=34.9 ;MIN. LIMIT
Q279=0.05 ;TOLERANCE 1ST CENTER
Q280=0.05 ;TOLERANCE 2ND CENTER
Q281=1 ;MEASURING LOG
Q309=0 ;PGM STOP IF ERROR
Q330=0 ;TOOL
Q423=4 ;NO. OF MEAS. POINTS
Q365=1 ;TYPE OF TRAVERSE

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR422.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.

PGM stop if tolerance error Q309: Definition of whether in the event of a violation of tolerance limits the TNC is to interrupt program run and output an error message: 0: Do not interrupt program run, no error message 1: Interrupt program run, output an error message

Tool for monitoring Q330: Definition of whether the TNC is to monitor the tool (see Tool monitoring). Input range: 0 to 32767.9, alternatively tool name with max. 16 characters 0: Monitoring not active >0: Tool number in the tool table TOOL.T

No. of measuring points (4/3) Q423: Specify whether the TNC should measure the stud with 4 or 3 probing points: 4: Use 4 measuring points (default setting) 3: Use 3 measuring points

Type of traverse? Line=0/Arc=1 Q365: Definition of the path function with which the touch probe is to move between the measuring points if "traversing to clearance height" (Q301=1) is active:
0: Move in a straight line between measuring points
1: Move in a circular arc between measuring points


MEASURE RECTANGLE INSIDE (Cycle 423, DIN/ISO: G423)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 423 finds the center, length and width of a rectangular pocket. If you define the corresponding tolerance values in the cycle, the TNC makes a nominal-to-actual value comparison and saves the deviation values in system parameters.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves either paraxially at the measuring height or linearly at the clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and saves the actual values and the deviations in the following Q parameters:
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q154 | Actual value of length in the reference axis
Q155 | Actual value of length in the minor axis
Q161 | Deviation at center of reference axis
Q162 | Deviation at center of minor axis
Q164 | Deviation of side length in reference axis
Q165 | Deviation of side length in minor axis


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

If the dimensions of the pocket and the safety clearance do not permit pre-positioning in the proximity of the touch points, the TNC always starts probing from the center of the pocket. In this case the touch probe does not return to the clearance height between the four measuring points.


Cycle parameters

Center in 1st axis Q273 (absolute): Center of the pocket in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q274 (absolute): Center of the pocket in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st side length Q282: Pocket length, parallel to the reference axis of the working plane. Input range 0 to 99999.9999

2nd side length Q283: Pocket length, parallel to the minor axis of the working plane. Input range 0 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Max. size limit 1st side length Q284: Maximum permissible length of the pocket. Input range 0 to 99999.9999

Min. size limit 1st side length Q285: Minimum permissible length of the pocket. Input range 0 to 99999.9999

Max. size limit 2nd side length Q286: Maximum permissible width of the pocket. Input range 0 to 99999.9999

Min. size limit 2nd side length Q287: Minimum permissible width of the pocket. Input range 0 to 99999.9999

Tolerance for center 1st axis Q279: Permissible position deviation in the reference axis of the working plane. Input range 0 to 99999.9999

Tolerance for center 2nd axis Q280: Permissible position deviation in the minor axis of the working plane. Input range 0 to 99999.9999

Example: NC blocks
5 TCH PROBE 423 MEAS. RECTAN. INSIDE
Q273=+50 ;CENTER IN 1ST AXIS
Q274=+50 ;CENTER IN 2ND AXIS
Q282=80 ;1ST SIDE LENGTH
Q283=60 ;2ND SIDE LENGTH
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+10 ;CLEARANCE HEIGHT
Q301=1 ;MOVE TO CLEARANCE
Q284=0 ;MAX. LIMIT 1ST SIDE
Q285=0 ;MIN. LIMIT 1ST SIDE
Q286=0 ;MAX. LIMIT 2ND SIDE
Q287=0 ;MIN. LIMIT 2ND SIDE
Q279=0 ;TOLERANCE 1ST CENTER
Q280=0 ;TOLERANCE 2ND CENTER
Q281=1 ;MEASURING LOG
Q309=0 ;PGM STOP IF ERROR
Q330=0 ;TOOL

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR423.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.

PGM stop if tolerance error Q309: Definition of whether in the event of a violation of tolerance limits the TNC is to interrupt program run and output an error message: 0: Do not interrupt program run, no error message 1: Interrupt program run, output an error message

Tool for monitoring Q330: Definition of whether the TNC is to monitor the tool (see Tool monitoring). Input range: 0 to 32767.9, alternatively tool name with max. 16 characters 0: Monitoring not active >0: Tool number in the tool table TOOL.T


MEASURE RECTANGLE OUTSIDE (Cycle 424, DIN/ISO: G424)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 424 finds the center, length and width of a rectangular stud. If you define the corresponding tolerance values in the cycle, the TNC makes a nominal-to-actual value comparison and saves the deviation values in system parameters.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120).
  3. Then the touch probe moves either paraxially at the measuring height or linearly at the clearance height to the next starting point 2 and probes the second touch point.
  4. The TNC positions the touch probe to starting point 3 and then to starting point 4 to probe the third and fourth touch points.
  5. Finally the TNC returns the touch probe to the clearance height and saves the actual values and the deviations in the following Q parameters:
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q154 | Actual value of length in the reference axis
Q155 | Actual value of length in the minor axis
Q161 | Deviation at center of reference axis
Q162 | Deviation at center of minor axis
Q164 | Deviation of side length in reference axis
Q165 | Deviation of side length in minor axis


Cycle parameters

Center in 1st axis Q273 (absolute): Center of the stud in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q274 (absolute): Center of the stud in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st side length Q282: Stud length, parallel to the reference axis of the working plane. Input range 0 to 99999.9999

2nd side length Q283: Stud length, parallel to the minor axis of the working plane. Input range 0 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

Max. size limit 1st side length Q284: Maximum permissible length of the stud. Input range 0 to 99999.9999

Min. size limit 1st side length Q285: Minimum permissible length of the stud. Input range 0 to 99999.9999

Max. size limit 2nd side length Q286: Maximum permissible width of the stud. Input range 0 to 99999.9999

Min. size limit 2nd side length Q287: Minimum permissible width of the stud. Input range 0 to 99999.9999

Tolerance for center 1st axis Q279: Permissible position deviation in the reference axis of the working plane. Input range 0 to 99999.9999

Tolerance for center 2nd axis Q280: Permissible position deviation in the minor axis of the working plane. Input range 0 to 99999.9999

Example: NC blocks
5 TCH PROBE 424 MEAS. RECTAN. OUTS.
Q273=+50 ;CENTER IN 1ST AXIS
Q274=+50 ;CENTER IN 2ND AXIS
Q282=75 ;1ST SIDE LENGTH
Q283=35 ;2ND SIDE LENGTH
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q301=0 ;MOVE TO CLEARANCE
Q284=75.1 ;MAX. LIMIT 1ST SIDE
Q285=74.9 ;MIN. LIMIT 1ST SIDE
Q286=35 ;MAX. LIMIT 2ND SIDE
Q287=34.95 ;MIN. LIMIT 2ND SIDE
Q279=0.1 ;TOLERANCE 1ST CENTER
Q280=0.1 ;TOLERANCE 2ND CENTER
Q281=1 ;MEASURING LOG
Q309=0 ;PGM STOP IF ERROR
Q330=0 ;TOOL

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR424.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.

PGM stop if tolerance error Q309: Definition of whether in the event of a violation of tolerance limits the TNC is to interrupt program run and output an error message: 0: Do not interrupt program run, no error message 1: Interrupt program run, output an error message

Tool for monitoring Q330: Definition of whether the TNC is to monitor the tool (see Tool monitoring). Input range: 0 to 32767.9, alternatively tool name with max. 16 characters: 0: Monitoring not active >0: Tool number in the tool table TOOL.T


MEASURE INSIDE WIDTH (Cycle 425, DIN/ISO: G425)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 425 measures the position and width of a slot (or pocket). If you define the corresponding tolerance values in the cycle, the TNC makes a nominal-to-actual value comparison and saves the deviation value in a system parameter.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The first probing is always in the positive direction of the programmed axis.
  3. If you enter an offset for the second measurement, the TNC then moves the touch probe (if required, at clearance height) to the next starting point 2 and probes the second touch point. If the nominal length is large, the TNC moves the touch probe to the second touch point at rapid traverse. If you do not enter an offset, the TNC measures the width in the exact opposite direction.
  4. Finally the TNC returns the touch probe to the clearance height and saves the actual values and the deviation in the following Q parameters:
Parameter number | Meaning
Q156 | Actual value of measured length
Q157 | Actual value of the centerline
Q166 | Deviation of the measured length


Cycle parameters

Starting point in 1st axis Q328 (absolute): Starting point for probing in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Starting point in 2nd axis Q329 (absolute): Starting point for probing in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Offset for 2nd measurement Q310 (incremental): Distance by which the touch probe is displaced before the second measurement. If you enter 0, the TNC does not offset the touch probe. Input range ‑99999.9999 to 99999.9999

Measuring axis Q272: Axis in the working plane in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Nominal length Q311: Nominal value of the length to be measured. Input range 0 to 99999.9999

Maximum dimension Q288: Maximum permissible length. Input range 0 to 99999.9999

Minimum dimension Q289: Minimum permissible length. Input range 0 to 99999.9999

Example: NC blocks
5 TCH PROBE 425 MEASURE INSIDE WIDTH
Q328=+75 ;STARTING POINT 1ST AXIS
Q329=-12.5 ;STARTING POINT 2ND AXIS
Q310=+0 ;OFFS. 2ND MEASUREMENT
Q272=1 ;MEASURING AXIS
Q261=-5 ;MEASURING HEIGHT
Q260=+10 ;CLEARANCE HEIGHT
Q311=25 ;NOMINAL LENGTH
Q288=25.05 ;MAX. LIMIT
Q289=25 ;MIN. LIMIT
Q281=1 ;MEASURING LOG
Q309=0 ;PGM STOP IF ERROR
Q330=0 ;TOOL
Q320=0 ;SET-UP CLEARANCE
Q301=0 ;MOVE TO CLEARANCE

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR425.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.

PGM stop if tolerance error Q309: Definition of whether in the event of a violation of tolerance limits the TNC is to interrupt program run and output an error message: 0: Do not interrupt program run, no error message 1: Interrupt program run, output an error message

Tool for monitoring Q330: Definition of whether the TNC is to monitor the tool (see Tool monitoring). Input range: 0 to 32767.9, alternatively tool name with max. 16 characters 0: Monitoring not active >0: Tool number in the tool table TOOL.T

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF


MEASURE RIDGE WIDTH (Cycle 426, DIN/ISO: G426)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 426 measures the position and width of a ridge. If you define the corresponding tolerance values in the cycle, the TNC makes a nominal-to-actual value comparison and saves the deviation value in system parameters.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC calculates the probe starting points from the data in the cycle and the safety clearance from MP6140.
  2. Then the touch probe moves to the entered measuring height and probes the first touch point at the probing feed rate (MP6120). The first probing is always in the negative direction of the programmed axis.
  3. Then the touch probe moves at clearance height to the next starting position and probes the second touch point.
  4. Finally the TNC returns the touch probe to the clearance height and saves the actual values and the deviation in the following Q parameters:
Parameter number | Meaning
Q156 | Actual value of measured length
Q157 | Actual value of the centerline
Q166 | Deviation of the measured length


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

Ensure that the first measurement is always carried out in the negative direction of the selected measuring axis. Define Q263 and Q264 correspondingly.


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 1st axis Q265 (absolute): Coordinate of the second touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 2nd axis Q266 (absolute): Coordinate of the second touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Measuring axis Q272: Axis in the working plane in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Nominal length Q311: Nominal value of the length to be measured. Input range 0 to 99999.9999

Maximum dimension Q288: Maximum permissible length. Input range 0 to 99999.9999

Minimum dimension Q289: Minimum permissible length. Input range 0 to 99999.9999

Example: NC blocks
5 TCH PROBE 426 MEASURE RIDGE WIDTH
Q263=+50 ;1ST POINT 1ST AXIS
Q264=+25 ;1ST POINT 2ND AXIS
Q265=+50 ;2ND POINT 1ST AXIS
Q266=+85 ;2ND POINT 2ND AXIS
Q272=2 ;MEASURING AXIS
Q261=-5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q260=+20 ;CLEARANCE HEIGHT
Q311=45 ;NOMINAL LENGTH
Q288=45 ;MAX. LIMIT
Q289=44.95 ;MIN. LIMIT
Q281=1 ;MEASURING LOG
Q309=0 ;PGM STOP IF ERROR
Q330=0 ;TOOL

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR426.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.

PGM stop if tolerance error Q309: Definition of whether in the event of a violation of tolerance limits the TNC is to interrupt program run and output an error message: 0: Do not interrupt program run, no error message 1: Interrupt program run, output an error message

Tool for monitoring Q330: Definition of whether the TNC is to monitor the tool (see Tool monitoring). Input range: 0 to 32767.9, alternatively tool name with max. 16 characters 0: Monitoring not active >0: Tool number in the tool table TOOL.T


MEASURE COORDINATE (Cycle 427, DIN/ISO: G427)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 427 finds a coordinate in a selectable axis and saves the value in a system parameter. If you define the corresponding tolerance values in the cycle, the TNC makes a nominal-to-actual value comparison and saves the deviation value in system parameters.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe to the probe starting point 1 at rapid traverse (value from MP6150). The TNC offsets the touch probe by the safety clearance in the direction opposite to the defined traverse direction.
  2. Then the TNC positions the touch probe to the entered touch point 1 in the working plane and measures the actual value in the selected axis.
  3. Finally the TNC returns the touch probe to the clearance height and saves the measured coordinate in the following Q parameter:
Parameter number | Meaning
Q160 | Measured coordinate


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Measuring axis (1 to 3: 1=reference axis) Q272: Axis in which the measurement is to be made: 1: Reference axis = measuring axis 2: Minor axis = measuring axis 3: Touch probe axis = measuring axis

Traverse direction 1 Q267: Direction in which the touch probe is to approach the workpiece: -1: Negative traverse direction +1: Positive traverse direction

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF
Example: NC blocks
5 TCH PROBE 427 MEASURE COORDINATE
Q263=+35 ;1ST POINT 1ST AXIS
Q264=+45 ;1ST POINT 2ND AXIS
Q261=+5 ;MEASURING HEIGHT
Q320=0 ;SET-UP CLEARANCE
Q272=3 ;MEASURING AXIS
Q267=-1 ;TRAVERSE DIRECTION
Q260=+20 ;CLEARANCE HEIGHT
Q281=1 ;MEASURING LOG
Q288=5.1 ;MAX. LIMIT
Q289=4.95 ;MIN. LIMIT
Q309=0 ;PGM STOP IF ERROR
Q330=0 ;TOOL

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR427.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.

Maximum limit of size Q288: Maximum permissible measured value. Input range ‑99999.9999 to 99999.9999

Minimum limit of size Q289: Minimum permissible measured value. Input range ‑99999.9999 to 99999.9999

PGM stop if tolerance error Q309: Definition of whether in the event of a violation of tolerance limits the TNC is to interrupt program run and output an error message: 0: Do not interrupt program run, no error message 1: Interrupt program run, output an error message

Tool for monitoring Q330: Definition of whether the TNC is to monitor the tool (see Tool monitoring). Input range: 0 to 32767.9, alternatively tool name with max. 16 characters: 0: Monitoring not active >0: Tool number in the tool table TOOL.T


MEASURE BOLT HOLE CIRCLE (Cycle 430, DIN/ISO: G430)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 430 finds the center and diameter of a bolt hole circle by probing three holes. If you define the corresponding tolerance values in the cycle, the TNC makes a nominal-to-actual value comparison and saves the deviation value in system parameters.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the point entered as center of the first hole 1.
  2. Then the touch probe moves to the entered measuring height and probes four points to find the first hole center.
  3. The touch probe returns to the clearance height and then to the position entered as center of the second hole 2.
  4. The TNC moves the touch probe to the entered measuring height and probes four points to find the second hole center.
  5. The touch probe returns to the clearance height and then to the position entered as center of the third hole 3.
  6. The TNC moves the touch probe to the entered measuring height and probes four points to find the third hole center.
  7. Finally the TNC returns the touch probe to the clearance height and saves the actual values and the deviations in the following Q parameters:
Parameter number | Meaning
Q151 | Actual value of center in reference axis
Q152 | Actual value of center in minor axis
Q153 | Actual value of bolt hole circle diameter
Q161 | Deviation at center of reference axis
Q162 | Deviation at center of minor axis
Q163 | Deviation of bolt hole circle diameter


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

Cycle 430 only monitors for tool breakage; there is no automatic tool compensation.


Cycle parameters

Center in 1st axis Q273 (absolute): Bolt-hole circle center (nominal value) in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

Center in 2nd axis Q274 (absolute): Bolt-hole circle center (nominal value) in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

Nominal diameter Q262: Enter the bolt hole circle diameter. Input range 0 to 99999.9999

Angle of 1st hole Q291 (absolute): Polar coordinate angle of the first hole center in the working plane. Input range -360.0000 to 360.0000

Angle of 2nd hole Q292 (absolute): Polar coordinate angle of the second hole center in the working plane. Input range -360.0000 to 360.0000

Angle of 3rd hole Q293 (absolute): Polar coordinate angle of the third hole center in the working plane. Input range -360.0000 to 360.0000

Measuring height in the touch probe axis Q261 (absolute): Coordinate of the ball tip center (= touch point) in the touch probe axis in which the measurement is to be made. Input range ‑99999.9999 to 99999.9999

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Maximum limit of size Q288: Maximum permissible diameter of bolt hole circle. Input range 0 to 99999.9999

Minimum limit of size Q289: Minimum permissible diameter of bolt hole circle. Input range 0 to 99999.9999

Tolerance for center 1st axis Q279: Permissible position deviation in the reference axis of the working plane. Input range 0 to 99999.9999

Tolerance for center 2nd axis Q280: Permissible position deviation in the minor axis of the working plane. Input range 0 to 99999.9999

Example: NC blocks
5 TCH PROBE 430 MEAS. BOLT HOLE CIRC
Q273=+50 ;CENTER IN 1ST AXIS
Q274=+50 ;CENTER IN 2ND AXIS
Q262=80 ;NOMINAL DIAMETER
Q291=+0 ;ANGLE OF 1ST HOLE
Q292=+90 ;ANGLE OF 2ND HOLE
Q293=+180 ;ANGLE OF 3RD HOLE
Q261=-5 ;MEASURING HEIGHT
Q260=+10 ;CLEARANCE HEIGHT
Q288=80.1 ;MAX. LIMIT
Q289=79.9 ;MIN. LIMIT
Q279=0.15 ;TOLERANCE 1ST CENTER
Q280=0.15 ;TOLERANCE 2ND CENTER
Q281=1 ;MEASURING LOG
Q309=0 ;PGM STOP IF ERROR
Q330=0 ;TOOL

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR430.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.

PGM stop if tolerance error Q309: Definition of whether in the event of a violation of tolerance limits the TNC is to interrupt program run and output an error message: 0: Do not interrupt program run, no error message 1: Interrupt program run, output an error message

Tool number for monitoring Q330: Definition of whether the TNC is to monitor for tool breakage (see Tool monitoring). Input range 0 to 32767.9; alternatively tool name with max. 16 characters 0: Monitoring not active >0: Tool number in the tool table TOOL.T


MEASURE PLANE (Cycle 431, DIN/ISO: G431)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 431 finds the angles of a plane by measuring three points. It saves the measured values in system parameters.

  1. Following the positioning logic (see Executing touch probe cycles), the TNC positions the touch probe at rapid traverse (value from MP6150) to the programmed starting point 1 and measures the first touch point of the plane. The TNC offsets the touch probe by the safety clearance in the direction opposite to the direction of probing.
  2. The touch probe returns to the clearance height and then moves in the working plane to starting point 2 and measures the actual value of the second touch point of the plane.
  3. The touch probe returns to the clearance height and then moves in the working plane to starting point 3 and measures the actual value of the third touch point of the plane.
  4. Finally the TNC returns the touch probe to the clearance height and saves the measured angle values in the following Q parameters:
Parameter number | Meaning
Q158 | Projection angle of the A axis
Q159 | Projection angle of the B axis
Q170 | Spatial angle A
Q171 | Spatial angle B
Q172 | Spatial angle C
Q173 to Q175 | Measured values in the touch probe axis (first to third measurement)


Please note while programming:

Before a cycle definition you must have programmed a tool call to define the touch probe axis.

For the TNC to be able to calculate the angular values, the three measuring points must not be positioned on one straight line.

The spatial angles that are needed for tilting the working plane are saved in parameters Q170 – Q172. With the first two measuring points you also specify the direction of the reference axis when tilting the working plane.

The third measuring point determines the direction of the tool axis. Define the third measuring point in the direction of the positive Y axis to ensure that the position of the tool axis in a clockwise coordinate system is correct.

If you run the cycle while a tilted working plane is active, the spatial angles are measured with respect to the tilted coordinate system. In this case, use the measured spatial angles with PLANE RELATIV.


Cycle parameters

1st meas. point 1st axis Q263 (absolute): Coordinate of the first touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 2nd axis Q264 (absolute): Coordinate of the first touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

1st meas. point 3rd axis Q294 (absolute): Coordinate of the first touch point in the touch probe axis. Input range ‑99999.9999 to 99999.9999

2nd meas. point 1st axis Q265 (absolute): Coordinate of the second touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 2nd axis Q266 (absolute): Coordinate of the second touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

2nd meas. point 3rd axis Q295 (absolute): Coordinate of the second touch point in the touch probe axis. Input range ‑99999.9999 to 99999.9999

3rd meas. point 1st axis Q296 (absolute): Coordinate of the third touch point in the reference axis of the working plane. Input range ‑99999.9999 to 99999.9999

3rd meas. point 2nd axis Q297 (absolute): Coordinate of the third touch point in the minor axis of the working plane. Input range ‑99999.9999 to 99999.9999

3rd meas. point 3rd axis Q298 (absolute): Coordinate of the third touch point in the touch probe axis. Input range ‑99999.9999 to 99999.9999

Example: NC blocks
5 TCH PROBE 431 MEASURE PLANE
Q263=+20 ;1ST POINT 1ST AXIS
Q264=+20 ;1ST POINT 2ND AXIS
Q294=+10 ;1ST POINT 3RD AXIS
Q265=+90 ;2ND POINT 1ST AXIS
Q266=+25 ;2ND POINT 2ND AXIS
Q295=+15 ;2ND POINT 3RD AXIS
Q296=+50 ;3RD POINT 1ST AXIS
Q297=+80 ;3RD POINT 2ND AXIS
Q298=+20 ;3RD POINT 3RD AXIS
Q320=0 ;SET-UP CLEARANCE
Q260=+5 ;CLEARANCE HEIGHT
Q281=1 ;MEASURING LOG

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur. Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Measuring log Q281: Definition of whether the TNC is to create a measuring log: 0: No measuring log 1: Create measuring log: By default, the TNC saves the log file TCHPR431.TXT in the directory in which your measuring program is stored. 2: Interrupt program run and display the measuring log on the screen. Resume program run with NC Start.


Programming examples

Further Informations:
> Example: Measuring and reworking a rectangular stud
> Example: Measuring a rectangular pocket and recording the results


Example: Measuring and reworking a rectangular stud

    Program sequence:

  • Roughing with 0.5 mm finishing allowance
  • Measuring
  • Rectangular stud finishing in accordance with the measured values
0 BEGIN PGM BEAMS mm |
1 TOOL CALL 69 z | Tool call for roughing
2 l z+100 r0 fmax | Retract the tool
3 fn 0: q1 = +81 | Pocket length in X (roughing dimension)
4 fn 0: q2 = +61 | Pocket length in Y (roughing dimension)
5 call lbl 1 | Call subprogram for machining
6 l z+100 r0 fmax | Retract the tool, change the tool
7 tool call 99 z | Call the touch probe
8 TCH PROBE 424 MEAS. RECTAN. OUTS. | Measure the rough-milled rectangle
Q273=+50 ;CENTER IN 1ST AXIS |
Q274=+50 ;CENTER IN 2ND AXIS |
Q282=80 ;1ST SIDE LENGTH | Nominal length in X (final dimension)
Q283=60 ;2ND SIDE LENGTH | Nominal length in Y (final dimension)
Q261=-5 ;MEASURING HEIGHT |
Q320=0 ;SET-UP CLEARANCE |
Q260=+30 ;CLEARANCE HEIGHT |
Q301=0 ;MOVE TO CLEARANCE |
Q284=0 ;MAX. LIMIT 1ST SIDE | Input values for tolerance checking not required
Q285=0 ;MIN. LIMIT 1ST SIDE |
Q286=0 ;MAX. LIMIT 2ND SIDE |
Q287=0 ;MIN. LIMIT 2ND SIDE |
Q279=0 ;TOLERANCE 1ST CENTER |
Q280=0 ;TOLERANCE 2ND CENTER |
Q281=0 ;MEASURING LOG | No measuring log transmission
Q309=0 ;PGM STOP IF ERROR | Do not output an error message
Q330=0 ;TOOL NUMBER | No tool monitoring
9 fn 2: q1 = +q1 - +q164 | Calculate length in X including the measured deviation
10 fn 2: q2 = +q2 - +q165 | Calculate length in Y including the measured deviation
11 l z+100 r0 fmax | Retract the touch probe, change the tool
12 tool call 1 z s5000 | Tool call for finishing
13 call lbl 1 | Call subprogram for machining
14 l z+100 r0 fmax m2 | Retract the tool, end program
15 lbl 1 | Subprogram with fixed cycle for rectangular stud
16 CYCL DEF 213 STUD FINISHING |
Q200=20 ;SET-UP CLEARANCE |
Q201=-10 ;DEPTH |
Q206=150 ;FEED RATE FOR PLNGNG |
Q202=5 ;PLUNGING DEPTH |
Q207=500 ;FEED RATE FOR MILLING |
Q203=+10 ;SURFACE COORDINATE |
Q204=20 ;2ND SET-UP CLEARANCE |
Q216=+50 ;CENTER IN 1ST AXIS |
Q217=+50 ;CENTER IN 2ND AXIS |
Q218=Q1 ;1ST SIDE LENGTH | Length in X variable for roughing and finishing
Q219=q2 ;2ND SIDE LENGTH | Length in Y variable for roughing and finishing
Q220=0 ;CORNER RADIUS |
Q221=0 ;ALLOWANCE IN 1ST AXIS |
17 cycl call m3 | Cycle call
18 lbl 0 | End of subprogram
19 end pgm beams mm |


Example: Measuring a rectangular pocket and recording the results

0 BEGIN PGM BSMEAS MM |
1 tool call 1 z | Tool call for touch probe
2 l z+100 r0 fmax | Retract the touch probe
3 TCH PROBE 423 MEAS. RECTAN. INSIDE |
Q273=+50 ;CENTER IN 1ST AXIS |
Q274=+40 ;CENTER IN 2ND AXIS |
Q282=90 ;1ST SIDE LENGTH | Nominal length in X
Q283=70 ;2ND SIDE LENGTH | Nominal length in Y
Q261=-5 ;MEASURING HEIGHT |
Q320=0 ;SET-UP CLEARANCE |
Q260=+20 ;CLEARANCE HEIGHT |
Q301=0 ;MOVE TO CLEARANCE |
Q284=90.15 ;MAX. LIMIT 1ST SIDE | Maximum limit in X
Q285=89.95 ;MIN. LIMIT 1ST SIDE | Minimum limit in X
Q286=70.1 ;MAX. LIMIT 2ND SIDE | Maximum limit in Y
Q287=69.9 ;MIN. LIMIT 2ND SIDE | Minimum limit in Y
Q279=0.15 ;TOLERANCE 1ST CENTER | Permissible position deviation in X
Q280=0.1 ;TOLERANCE 2ND CENTER | Permissible position deviation in Y
Q281=1 ;MEASURING LOG | Save measuring log to a file
Q309=0 ;PGM STOP IF ERROR | Do not display an error message in case of a tolerance violation
Q330=0 ;TOOL NUMBER | No tool monitoring
4 l z+100 r0 fmax m2 | Retract the tool, end program
5 END PGM BSMEAS MM |


Touch Probe Cycles: Special Functions

Further Informations:
> Fundamentals
> CALIBRATE TS (Cycle 2)
> CALIBRATE TS LENGTH (Cycle 9)
> MEASURING (Cycle 3)
> MEASURING IN 3-D (Cycle 4, FCL 3 function)
> MEASURE AXIS SHIFT (Touch Probe Cycle 440, DIN/ISO: G440)
> FAST PROBING (Cycle 441, DIN/ISO: G441, FCL 2 function)
> CALIBRATE TS (Cycle 460, DIN/ISO: G460)


Overview

The TNC provides seven cycles for the following special purposes:

Cycle | Soft key | Page
2 CALIBRATE TS Radius calibration of the touch trigger probe |  | CALIBRATE TS (Cycle 2)
9 CALIBRATE TS LENGTH Length calibration of the touch trigger probe |  | CALIBRATE TS LENGTH (Cycle 9)
3 MEASURING Cycle for defining OEM cycles |  | MEASURING (Cycle 3)
4 MEASURING IN 3-D Measuring cycle for 3-D probing for defining OEM cycles |  | MEASURING IN 3-D (Cycle 4, FCL 3 function)
440 MEASURE AXIS SHIFT |  | MEASURE AXIS SHIFT (Touch Probe Cycle 440, DIN/ISO: G440)
441 FAST PROBING |  | FAST PROBING (Cycle 441, DIN/ISO: G441, FCL 2 function)
460 CALIBRATE TS Radius and length calibration on a calibration sphere |  | CALIBRATE TS (Cycle 460, DIN/ISO: G460)


CALIBRATE TS (Cycle 2)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 2 automatically calibrates a touch trigger probe using a ring gauge or a precision stud as calibration standard.

  1. The touch probe moves at rapid traverse (value from MP6150) to the clearance height (but only if the current position is below the clearance height).
  2. Then the TNC positions the touch probe in the working plane to the center of the ring gauge (calibration from inside) or in its proximity (calibration from outside).
  3. The touch probe then moves to the measuring depth (result of MP618x.2 and MP6185.x) and probes the ring gauge successively in X+, Y+, X- and Y-.
  4. Finally, the TNC moves the touch probe to the clearance height and writes the effective radius of the ball tip to the calibration data.


Please note while programming:

Before you begin calibrating, you must define in Machine Parameters 6180.0 to 6180.2 the center of the calibrating workpiece in the working space of the machine (REF coordinates).

If you are working with several traverse ranges you can save a separate set of coordinates for the center of each calibrating workpiece (MP6181.1 to 6181.2 and MP6182.1 to 6182.2).


Cycle parameters

Example: NC blocks
5 TCH PROBE 2.0 CALIBRATE TS
6 TCH PROBE 2.1 HEIGHT: +50 R +25.003 DIRECTION: 0

Clearance height (absolute): Coordinate in the touch probe axis at which the touch probe cannot collide with the calibration workpiece or any fixtures. Input range ‑99999.9999 to 99999.9999

Radius of ring gauge: Radius of the calibrating workpiece. Input range 0 to 99999.9999

Inside calib. =0/outs. calib.=1: Definition of whether the TNC is to calibrate from inside or outside: 0: Calibrate from inside 1: Calibrate from outside


CALIBRATE TS LENGTH (Cycle 9)

Further Informations:
> Cycle run
> Cycle parameters


Cycle run

Touch Probe Cycle 9 automatically calibrates the length of a touch trigger probe at a point that you determine.

  1. Pre-position the touch probe so that the touch probe axis coordinate defined in the cycle can be accessed without collision.
  2. The TNC moves the touch probe in the direction of the negative tool axis until a trigger signal is released.
  3. Finally, the TNC moves the touch probe back to the starting point of the probing process and writes the effective touch probe length to the calibration data.


Cycle parameters

Example: NC blocks
5 l x-235 y+356 r0 fmax
6 TCH PROBE 9.0 CALIBRATE TS LENGTH
7 TCH PROBE 9.1 DATUM +50 REFERENCE SYSTEM 0

Coordinate of datum (absolute): Exact coordinate of the point that is to be probed. Input range ‑99999.9999 to 99999.9999

Reference system? (0=ACT/1=REF): Specify the coordinate system on which the entered datum is to be based: 0: Entered datum is based on the active workpiece coordinate system (ACT system) 1: Entered datum is based on the active machine coordinate system (REF system)


MEASURING (Cycle 3)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 3 measures any position on the workpiece in a selectable direction. Unlike other measuring cycles, Cycle 3 enables you to enter the measuring range SET UP and feed rate F directly. Also, the touch probe retracts by the definable value MB after determining the measured value.

  1. The touch probe moves from the current position at the entered feed rate in the defined probing direction. The probing direction must be defined in the cycle as a polar angle.
  2. After the TNC has saved the position, the touch probe stops. The TNC saves the X, Y, Z coordinates of the probe-tip center in three successive Q parameters. The TNC does not conduct any length or radius compensations. You define the number of the first result parameter in the cycle.
  3. Finally, the TNC moves the touch probe back by that value against the probing direction that you defined in the parameter MB.


Please note while programming:

The exact behavior of Touch Probe Cycle 3 is defined by your machine tool builder or a software manufacturer who uses it within specific touch probe cycles.

MP6130 (maximum traverse to touch point) and MP6120 (probing feed rate), which are effective in other measuring cycles, do not apply in touch probe cycle 3.

Remember that the TNC always writes to four successive Q-parameters.

If the TNC was not able to determine a valid touch point, the program is run without error message. In this case the TNC assigns the value –1 to the 4th result parameter so that you can deal with the error yourself.

The TNC retracts the touch probe by no more than the retraction distance MB and does not pass the starting point of the measurement. This rules out any collision during retraction.

With function FN17: SYSWRITE ID 990 NR 6 you can set whether the cycle runs through the probe input X12 or X13.


Cycle parameters

Example: NC blocks
4 TCH PROBE 3.0 MEASURING
5 TCH PROBE 3.1 q1
6 TCH PROBE 3.2 X ANGLE: +15
7 TCH PROBE 3.3 DIST +10 f100 mb1 reference system:0
8 TCH PROBE 3.4 ERRORMODE1

Parameter number for result: Enter the number of the Q parameter to which you want the TNC to assign the first measured coordinate (X). The values Y and Z are in the immediately following Q parameters. Input range: 0 to 1999

Probing axis: Enter the axis in whose direction the probe is to move and confirm with the ENT key. Input range: X, Y or Z

Probing angle: Angle, measured from the defined probing axis, in which the touch probe is to move. Confirm with ENT. Input range –180.0000 to 180.0000

Maximum measuring range: Enter the maximum distance from the starting point by which the touch probe is to move. Confirm with ENT. Input range ‑99999.9999 to 99999.9999

Feed rate for measurement: Enter the measuring feed rate in mm/min. Input range 0 to 3000.000

Maximum retraction distance: Traverse path in the direction opposite the probing direction, after the stylus was deflected. The TNC returns the touch probe to a point no farther than the starting point, so that there can be no collision. Input range 0 to 99999.9999

Reference system? (0=ACT/1=REF): Specify whether the probing direction and the result of measurement are to be referenced to the actual coordinate system (ACT, can be shifted or rotated), or to the machine coordinate system (REF): 0: Probe in the current system and save measurement result in the ACT system 1: Probe in the machine-based REF system and save measurement result in the REF system

Error mode (0=OFF/1=ON): Specify whether the TNC is to issue an error message if the stylus is deflected at cycle start. If mode 1 is selected, the TNC saves the value 2.0 in the 4th result parameter and continues the cycle: 0: Issue error message 1: Do not issue error message


MEASURING IN 3-D (Cycle 4, FCL 3 function)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Cycle 4 is an auxiliary cycle that you can only use in conjunction with external software! The TNC does not provide any cycle with which you can calibrate the touch probe.

Touch probe cycle 4 measures any position on the workpiece in the probing direction defined by a vector. Unlike other measuring cycles, Cycle 4 enables you to enter the measuring distance and feed rate directly. Also, the touch probe retracts by a definable value after determining the measured value.

  1. The touch probe moves from the current position at the entered feed rate in the defined probing direction. Define the probing direction in the cycle by using a vector (delta values in X, Y and Z).
  2. After the TNC has saved the position, the touch probe stops. The TNC saves the X, Y, Z coordinates of the probe-tip center (without calculation of the calibration data) in three successive Q parameters. You define the number of the first parameter in the cycle.
  3. Finally, the TNC moves the touch probe back by that value against the probing direction that you defined in the parameter MB.


Please note while programming:

The TNC retracts the touch probe by no more than the retraction distance MB and does not pass the starting point of the measurement. This rules out any collision during retraction.

Ensure during pre-positioning that the TNC moves the probe-tip center without compensation to the defined position!

Remember that the TNC always writes to 4 successive Q parameters. If the TNC could not determine a valid touch point, the 4th result parameter will have the value –1.

The TNC saves the measured values without calculating the calibration data of the touch probe.

With function FN17: SYSWRITE ID 990 NR 6 you can set whether the cycle runs through the probe input X12 or X13.


Cycle parameters

Example: NC blocks
5 TCH PROBE 4.0 MEASURING IN 3-D
6 TCH PROBE 4.1 q1
7 TCH PROBE 4.2 ix-0.5 iy-1 iz-1
8 TCH PROBE 4.3 DIST +45 f100 mb50 REFERENCE SYSTEM:0

Parameter number for result: Enter the number of the Q parameter to which you want the TNC to assign the first coordinate (X). Input range 0 to 1999

Relative measuring path in X: X component of the direction vector defining the direction in which the touch probe is to move. Input range ‑99999.9999 to 99999.9999

Relative measuring path in Y: Y component of the direction vector defining the direction in which the touch probe is to move. Input range ‑99999.9999 to 99999.9999

Relative measuring path in Z: Z component of the direction vector defining the direction in which the touch probe is to move. Input range ‑99999.9999 to 99999.9999

Maximum measuring path: Enter the maximum distance from the starting point by which the touch probe may move along the direction vector. Input range ‑99999.9999 to 99999.9999

Feed rate for measurement: Enter the measuring feed rate in mm/min. Input range 0 to 3000.000

Maximum retraction distance: Traverse path in the direction opposite the probing direction, after the stylus was deflected. Input range 0 to 99999.9999

Reference system? (0=ACT/1=REF): Specify whether the result of measurement is to be saved in the actual coordinate system (ACT, can be shifted or rotated), or with respect to the machine coordinate system (REF). 0: Save the measurement result in the ACT system 1: Save the measurement result in the REF system


MEASURE AXIS SHIFT (Touch Probe Cycle 440, DIN/ISO: G440)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 440 measures the axis shifts of the machine. Make sure that the cylindrical calibrating tool used in connection with the TT 130 has the correct dimensions.

  1. The TNC positions the calibrating tool at rapid traverse (value from MP6550) and following the positioning logic (refer to section 1.2) in the vicinity of the TT.
  2. At first the TNC makes a measurement in the touch probe axis. The calibrating tool is offset by the value you have defined in the tool table TOOL.T under TT: R-OFFS (standard = tool radius). The TNC always performs the measurement in the touch probe axis.
  3. Then the TNC makes the measurement in the working plane. You define via parameter Q364 in which axis and in which direction of the working plane the measurement is to be made.
  4. If you make a calibration, the TNC saves the calibration data. Whenever you make a measurement, the TNC compares the measured values to the calibration data and writes the deviations to the following Q parameters:
Parameter number | Meaning
Q185 | Deviation from calibration value in X
Q186 | Deviation from calibration value in Y
Q187 | Deviation from calibration value in Z
  1. You can use this value for compensating the deviation through an incremental datum shift (Cycle 7).
  5. Finally, the calibrating tool returns to the clearance height.


Please note while programming:

Before running Cycle 440 for the first time, you must have calibrated the TT tool touch probe with the TT Cycle 30.

Ensure that the tool data of the calibrating tool has been entered in the tool table TOOL.T.

Before running the cycle, you must activate the calibrating tool with TOOL CALL.

Ensure that the TT tool touch probe is connected to input X13 of the logic unit and is ready to function (MP65xx).

Before you perform a measurement, you must have made at least one calibration, otherwise the TNC will output an error message. If you are working with several traverse ranges, you have to make a calibration for each of them.

The TNC calculates incorrect values if the probing directions for calibrating and measuring do not correspond.

Each time you run Cycle 440, the TNC resets the result parameters Q185 to Q187.

If you want to set a limit for the axis shift in the machine axes, enter the desired limits in the tool table TOOL.T under LTOL for the spindle axis and under RTOL for the working plane. If the limits are exceeded, the TNC outputs a corresponding error message after a verification measurement.

After the cycle is completed, the TNC restores the spindle settings that were active before the cycle (M3/M4).


Cycle parameters

Example: NC blocks
5 TCH PROBE 440 MEASURE AXIS SHIFT
Q363=1 ;DIRECTION
Q364=0 ;PROBING DIRECTIONS
Q320=2 ;SET-UP CLEARANCE
Q260=+50 ;CLEARANCE HEIGHT

Operation: 0=calibr., 1=measure? Q363: Specify whether you want to calibrate or make a verification measurement: 0: Calibrate 1: Measure

Probing directions Q364: Definition of probing direction(s) in the working plane: 0: Measuring only in the positive direction of the reference axis 1: Measuring only in the positive direction of the minor axis 2: Measuring only in the negative direction of the reference axis 3: Measuring only in the negative direction of the minor axis 4: Measuring in the positive directions of the reference axis and the minor axis 5: Measuring in the positive direction of the reference axis and in the negative direction of the minor axis 6: Measuring in the negative direction of the reference axis and in the positive direction of the minor axis 7: Measuring in the negative directions of the reference axis and the minor axis

Set-up clearance Q320 (incremental): Additional distance between measuring point and probe contact. Q320 is added to MP6540. Input range 0 to 99999.9999; alternatively PREDEF

Clearance height Q260 (absolute): Coordinate in the touch probe axis at which no collision between touch probe and workpiece (fixtures) can occur (referenced to the active datum). Input range ‑99999.9999 to 99999.9999; alternatively PREDEF


FAST PROBING (Cycle 441, DIN/ISO: G441, FCL 2 function)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

Touch Probe Cycle 441 allows the global setting of different touch probe parameters (e.g. positioning feed rate) for all subsequently used touch probe cycles. This makes it easy to optimize the programs so that reductions in total machining time are achieved.


Please note while programming:

Before programming, note the following

There are no machine movements contained in Cycle 441. It only sets different probing parameters.

END PGM, M02, M30 resets the global settings of Cycle 441.

You can activate automatic angle tracking (Cycle Parameter Q399) only if Machine Parameter 6165=1. If you change MP6165, you must recalibrate the touch probe.


Cycle parameters

Example: NC blocks
5 TCH PROBE 441 FAST PROBING
Q396=3000 ;POSITIONING FEED RATE
Q397=0 ;SELECT FEED RATE
Q399=1 ;ANGLE TRACKING
Q400=1 ;INTERRUPTION

Positioning feed rate Q396: Define the feed rate at which the touch probe is moved to the specified positions. Input range 0 to 99999.9999

Positioning feed rate=FMAX (0/1) Q397: Define whether the touch probe is to move at FMAX (rapid traverse) to the specified positions: 0: Move at feed rate from Q396 1: Move at FMAX If your machine provides separate potentiometers for rapid traverse and feed rate, the feed rate can only be controlled with the feed-rate potentiometer even if you enter Q397=1.

Angle tracking Q399: Define whether the TNC is to orient the touch probe before each probing process: 0: Do not orient 1: Orient the spindle before each probing process to increase the accuracy

Automatic interruption Q400: Define whether the TNC is to interrupt program run and display the measurement results on the screen after a measuring cycle for automatic workpiece measurement: 0: Never interrupt the program run, not even if the output of the measurement results on the screen is selected in the respective probing cycle. 1: Always interrupt program run and display the measurement results on the screen. To continue the program run, press the NC Start button.


CALIBRATE TS (Cycle 460, DIN/ISO: G460)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

With Cycle 460 you can calibrate a triggering 3-D touch probe automatically on an exact calibration sphere. You can do radius calibration alone, or radius and length calibration.

  1. Clamp the calibration sphere and check for potential collisions.
  2. In the touch probe axis, position the touch probe over the calibration sphere, and in the working plane, approximately over the sphere center.
  3. The first movement in the cycle is in the negative direction of the touch probe axis.
  4. Then the cycle determines the exact center of the sphere in the touch probe axis.


Please note while programming:

Before programming, note the following

Pre-position the touch probe in the program so that it is located approximately above the center of the calibration sphere.


Cycle parameters

Example: NC blocks
5 TCH PROBE 460 CALIBRATE TS
Q407=12.5 ;SPHERE RADIUS
Q320=0 ;SET-UP CLEARANCE
Q301=1 ;MOVE TO CLEARANCE
Q423=4 ;NO. OF PROBE POINTS
Q380=+0 ;REFERENCE ANGLE
Q433=0 ;CALIBRATE LENGTH
Q434=-2.5 ;DATUM

Exact calibration sphere radius Q407: Enter the exact radius of the calibration sphere used. Input range 0.0001 to 99.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Traversing to clearance height Q301: Definition of how the touch probe is to move between the measuring points: 0: Move at measuring height between measuring points 1: Move at clearance height between measuring points Alternative: PREDEF

No. of probe points in plane (4/3) Q423: Specify whether the TNC should measure the calibration sphere in the plane with 4 or 3 probing points. 3 probing points increase the measuring speed: 4: Use 4 measuring points (default setting) 3: Use 3 measuring points

Reference angle Q380 (absolute): Reference angle (basic rotation) for measuring the measuring points in the active workpiece coordinate system. Defining a reference angle can considerably enlarge the measuring range of an axis. Input range 0 to 360.0000

Calibrate length (0/1) Q433: Define whether the TNC should also calibrate the touch probe length after radius calibration: 0: Do not calibrate touch probe length 1: Calibrate touch probe length

Datum for length Q434 (absolute): Coordinate of the calibration sphere center. The definition is only required if length calibration is to be carried out. Input range ‑99999.9999 to 99999.9999


Touch Probe Cycles: Automatic Kinematics Measurement

Further Informations:
> Kinematics measurement with TS touch probes (KinematicsOpt option)
> Prerequisites
> SAVE KINEMATICS (Cycle 450, DIN/ISO: G450; Option)
> MEASURE KINEMATICS (Cycle 451, DIN/ISO: G451; Option)
> PRESET COMPENSATION (Cycle 452, DIN/ISO: G452, Option)


Kinematics measurement with TS touch probes (KinematicsOpt option)

Further Informations:
> Fundamentals
> Overview


Fundamentals

Accuracy requirements are becoming increasingly stringent, particularly in the area of 5-axis machining. Complex parts need to be manufactured with precision and reproducible accuracy even over long periods.

Some of the reasons for inaccuracy in multi-axis machining are deviations between the kinematic model saved in the control (see 1 in the figure at right), and the kinematic conditions actually existing on the machine (see 2 in the figure at right). When the rotary axes are positioned, these deviations cause inaccuracy of the workpiece (see 3 in the figure at right). It is therefore necessary for the model to approach reality as closely as possible.

The new TNC function KinematicsOpt is an important component that helps you to really fulfill these complex requirements: A 3-D touch probe cycle measures the rotary axes on your machine fully automatically, regardless of whether they are in the form of tables or spindle heads. A calibration sphere is fixed at any position on the machine table, and measured with a resolution that you define. During cycle definition you simply define for each rotary axis the area that you want to measure.

From the measured values, the TNC calculates the static tilting accuracy. The software minimizes the positioning error arising from the tilting movements and, at the end of the measurement process, automatically saves the machine geometry in the respective machine constants of the kinematic table.


Overview

The TNC offers cycles that enable you to automatically save, check and optimize the machine kinematics:

Cycle | Soft key | Page
450 SAVE KINEMATICS: Automatically saving and restoring kinematic configurations |  | SAVE KINEMATICS (Cycle 450, DIN/ISO: G450; Option)
451 MEASURE KINEMATICS: Automatically checking or optimizing the machine kinematics |  | MEASURE KINEMATICS (Cycle 451, DIN/ISO: G451; Option)
452 PRESET COMPENSATION: Automatically checking or optimizing the machine kinematics |  | PRESET COMPENSATION (Cycle 452, DIN/ISO: G452, Option)


Prerequisites

The following are prerequisites for using the KinematicsOpt option:

  • The software options 48 (KinematicsOpt) and 8 (software option 1) and FCL3 must be enabled.
  • Software option 52 (KinematicsComp) is necessary for compensations of angular positions.
  • The 3-D touch probe used for the measurement must be calibrated.
  • The cycles can only be carried out with the tool axis Z.
  • A calibration sphere with an exactly known radius and sufficient rigidity must be attached to any position on the machine table. HEIDENHAIN recommends using the calibration spheres KKH 250 (ID number 655 475-01) or KKH 100 (ID number 655 475-02), which have particularly high rigidity and are designed especially for machine calibration. Please contact HEIDENHAIN if you have any questions in this regard.
  • The kinematics description of the machine must be complete and correct. The transformation values must be entered with an accuracy of approx. 1 mm.
  • The complete machine geometry must have been measured (by the machine tool builder during commissioning).
  • MP6600 must define the tolerance limit starting from which the TNC displays a note if the changes in the kinematic data exceed this limit value (see KinematicsOpt: Tolerance limit in Optimization mode: MP6600).
  • MP6601 must define the maximum permissible deviation from the entered cycle parameter by the calibration sphere radius measured in the cycles (see KinematicsOpt, permissible deviation of the calibration ball radius: MP6601).
  • The M function number to be used for rotary axis positioning must be entered in MP6602, or –1 if positioning is to be done by the NC. An M function must be specially provided for this application by your machine tool builder.
Further Informations:
> Please note while programming:


Please note while programming:

The KinematicsOpt cycles use the global string parameters QS0 to QS99. Please note that they may have changed after execution of these cycles.

If MP6602 is not equal to –1, you have to position the rotary axes to 0 degrees (ACTUAL system) before starting one of the KinematicsOpt cycles (except for Cycle 450).


SAVE KINEMATICS (Cycle 450, DIN/ISO: G450; Option)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters
> Log function


Cycle run

With touch probe cycle 450, you can save the active machine kinematics, restore a previously saved one, or output the current saving status on the screen and in a log file. There are 10 memory spaces available (numbers 0 to 9).


Please note while programming:

    Always save the active kinematics configuration before running a kinematics optimization. Advantage:

  • You can restore the old data if you are not satisfied with the results or if errors occur during optimization (e.g. power failure).

Save mode: In addition to the kinematic configuration, the TNC always saves the code number (freely definable) last entered under MOD. Then you cannot overwrite this memory space unless you enter this code number. If you have saved a kinematic configuration without a code number, the TNC automatically overwrites this memory space during the next saving process!

Restore mode: The TNC can restore saved data only to a matching kinematic configuration.

Restore mode: Note that a change in the kinematics always changes the preset as well. Set the preset again if necessary.


Cycle parameters

Example: NC blocks
5 TCH PROBE 450 SAVE KINEMATICS
Q410=0 ;MODE
Q409=1 ;MEMORY

Mode (0/1/2) Q410: Specify whether to save or restore a kinematics configuration: 0: Save active kinematics 1: Restore previously saved kinematics configuration 2: Display the storage status

Memory (0…9) Q409: Number of the memory space to which you want to save the entire kinematics configuration, or the number of the memory space from which you want to restore it. Input range 0 to 9, no function if mode 2 is selected.


Log function

    After running Cycle 450, the TNC creates a measuring log (tchpr450.txt) containing the following information:

  • Creation date and time of the log
  • Path of the NC program from which the cycle was run
  • Mode used (0=Save/1=Restore/2=Saving status)
  • Number of the memory space (0 to 9)
  • Line number of the kinematics configuration in the kinematic table
  • Code number, if you entered one immediately before running Cycle 450

    The other data in the log vary depending on the selected mode:

  • Mode 0:
    Logging of all axis entries and transformation entries of the kinematics chain that the TNC has saved.
  • Mode 1:
    Logging of all transformation entries before and after restoring the kinematics configuration
  • Mode 2:
    List with the current saving status on the screen and in the log, including the number of the memory space, code numbers, kinematics numbers and date of saving


MEASURE KINEMATICS (Cycle 451, DIN/ISO: G451; Option)

Further Informations:
> Cycle run
> Positioning direction
> Machines with Hirth-coupled axes
> Choice of number of measuring points
> Choice of the calibration sphere position on the machine table
> Notes on the accuracy
> Notes on various calibration methods
> Backlash
> Please note while programming:
> Cycle parameters
> Various modes (Q406)
> Log function


Cycle run

The touch probe cycle 451 enables you to check and, if required, optimize the kinematics of your machine. Use the 3-D TS touch probe to measure a HEIDENHAIN calibration sphere that you have attached to the machine table.

HEIDENHAIN recommends using the calibration spheres KKH 250 (ID number 655 475-01) or KKH 100 (ID number 655 475-02), which have particularly high rigidity and are designed especially for machine calibration. Please contact HEIDENHAIN if you have any questions in this regard.

The TNC evaluates the static tilting accuracy. The software minimizes the spatial error arising from the tilting movements and, at the end of the measurement process, automatically saves the machine geometry in the respective machine constants of the kinematics description.

  1. Clamp the calibration sphere and check for potential collisions.
  2. In the Manual Operation mode, set the datum in the center of the sphere, or if Q431=1 or Q431=3 is defined: In the touch probe axis, manually position the touch probe over the calibration sphere , and in the working plane, over the sphere center.
  3. Select the Program Run mode and start the calibration program.
  4. The TNC automatically measures all the rotary axes successively in the resolution you defined. The current measurement status is displayed in a pop-up window. The TNC hides the status window when the distance to be traversed is greater than the radius of the ball tip.
  5. The TNC saves the measured values in the following Q parameters:
Parameter number | Meaning
Q141 | Standard deviation measured in the A axis (–1 if axis was not measured)
Q142 | Standard deviation measured in the B axis (–1 if axis was not measured)
Q143 | Standard deviation measured in the C axis (–1 if axis was not measured)
Q144 | Optimized standard deviation in the A axis (–1 if axis was not optimized)
Q145 | Optimized standard deviation in the B axis (–1 if axis was not optimized)
Q146 | Optimized standard deviation in the C axis (–1 if axis was not optimized)
Q147 | Offset error in X direction, for manual transfer to the corresponding machine parameter
Q148 | Offset error in Y direction, for manual transfer to the corresponding machine parameter
Q149 | Offset error in Z direction, for manual transfer to the corresponding machine parameter


Positioning direction

The positioning direction of the rotary axis to be measured is determined from the start angle and the end angle that you define in the cycle. A reference measurement is automatically performed at 0°. The TNC will issue an error message if the selected start angle, end angle and number of measuring points result in a measuring position of 0°.

Specify the start and end angles to ensure that the same position is not measured twice. As mentioned above, a duplicated point measurement (e.g. measuring positions +90° and -270°) is not advisable, however it does not cause an error message.

  • Example: Start angle = +90°, end angle = –90°
    • Start angle = +90°
    • End angle = -90°
    • No. of measuring points = 4
    • Stepping angle resulting from the calculation = (-90 - +90) / (4-1) = –60°
    • Measuring point 1 = +90°
    • Measuring point 2 = +30°
    • Measuring point 3 = -30°
    • Measuring point 4 = -90°
  • Example: Start angle = +90°, end angle = +270°
    • Start angle = +90°
    • End angle = +270°
    • No. of measuring points = 4
    • Stepping angle resulting from the calculation = (270 – 90) / (4 – 1) = +60°
    • Measuring point 1 = +90°
    • Measuring point 2 = +150°
    • Measuring point 3 = +210°
    • Measuring point 4 = +270°


Machines with Hirth-coupled axes

Danger of collision!

In order to be positioned, the axis must move out of the Hirth coupling. So remember to leave a large enough safety clearance to prevent any risk of collision between the touch probe and calibration sphere. Also ensure that there is enough space to reach the safety clearance (software limit switch).

Define a retraction height Q408 greater than 0 if software option 2 (M128, FUNCTION TCPM) is not available.

If necessary, the TNC rounds the calculated measuring positions so that they fit into the Hirth grid (depending on the start angle, end angle and number of measuring points).

Depending on the machine configuration, the TNC cannot position the rotary axes automatically. If this is the case, you need a special M function from the machine tool builder enabling the TNC to move the rotary axes. The machine manufacturer must have entered the number of the M function in MP6602 for this purpose.

The measuring positions are calculated from the start angle, end angle and number of measurements for the respective axis and from the Hirth grid.

Example calculation of measuring positions for an A axis:

Start angle Q411 = -30

End angle Q412 = +90

Number of measuring points Q414 = 4

Hirth grid = 3°

Calculated stepping angle = ( Q412 – Q411 ) / ( Q414 – 1 )

Calculated stepping angle = = ( 90 – -30 ) / ( 4 – 1 ) = 120 / 3 = 40

Measuring position 1 = Q411 + 0 * stepping angle = -30° --> -30°

Measuring position 2 = Q411 + 1 * stepping angle = +10° --> 9°

Measuring position 3 = Q411 + 2 * stepping angle = +50° --> 51°

Measuring position 4 = Q411 + 3 * stepping angle = +90° --> 90°


Choice of number of measuring points

To save time, you can make a rough optimization with a small number of measuring points (1-2).

You then make a fine optimization with a medium number of measuring points (recommended value = 4). Higher numbers of measuring points do not usually improve the results. Ideally, you should distribute the measuring points evenly over the tilting range of the axis.

This is why you should measure an axis with a tilting range of 0° to 360° at three measuring points, namely at 90°, 180° and 270°.

If you want to check the accuracy accordingly, you can enter a higher number of measuring points in the Check mode.

You must not define a measuring point at 0° or 360°. These positions do not provide any metrologically relevant data and lead to an error message!


Choice of the calibration sphere position on the machine table

    In principle, you can fix the calibration sphere to any accessible position on the machine table and also on fixtures or workpieces. The following factors can positively influence the result of measurement:

  • On machines with rotary tables/tilting tables:
    Clamp the calibration sphere as far as possible away from the center of rotation.
  • Machines with large traverse:
    Clamp the calibration sphere as closely as possible to the position intended for subsequent machining.


Notes on the accuracy

The geometrical and positioning error of the machine influences the measured values and therefore also the optimization of a rotary axis. For this reason there will always be a certain amount of error.

If there were no geometrical and positioning errors, any values measured by the cycle at any point on the machine at a certain time would be exactly reproducible. The greater the geometrical and positioning error, the greater is the dispersion of measured results when you fix the calibration sphere to different positions in the machine coordinate system.

The dispersion of results recorded by the TNC in the measuring log is a measure of the machine's static tilting accuracy. However, the measuring circle radius and the number and position of measuring points have to be included in the evaluation of accuracy. One measuring point alone is not enough to calculate dispersion. For only one point, the result of the calculation is the spatial error of that measuring point.

If several rotary axes are moved simultaneously, their error values are combined. In the worst case they are added together.

If your machine is equipped with a controlled spindle, you should activate the angle tracking using MP6165. This generally increases the accuracy of measurements with a 3-D touch probe.

If required, deactivate the lock on the rotary axes for the duration of the calibration. Otherwise it may falsify the results of measurement. The machine manual provides further information.


Notes on various calibration methods

  • Rough optimization during commissioning after entering approximate dimensions.
    • Number of measuring points between 1 and 2
    • Angular step of the rotary axes: Approx. 90°
  • Fine optimization over the entire range of traverse
    • Number of measuring points between 3 and 6
    • The start and end angles should cover the largest possible traverse range of the rotary axes.
    • Position the calibration sphere on the machine table so that on rotary table axes there is a large measuring circle, or so that on swivel head axes the measurement can be made at a representative position (e.g. in the center of the traverse range).
  • Optimization of a specific rotary axis position
    • Number of measuring points between 2 and 3
    • The measurements are made near the rotary axis angle at which the workpiece is to be machined.
    • Position the calibration sphere on the machine table for calibration at the position subsequently intended for machining.
  • Inspecting the machine accuracy
    • Number of measuring points between 4 and 8
    • The start and end angles should cover the largest possible traverse range of the rotary axes.
  • Determination of the rotary axis backlash
    • Number of measuring points between 8 and 12
    • The start and end angles should cover the largest possible traverse range of the rotary axes.


Backlash

Backlash is a small amount of play between the rotary or angle encoder and the table that occurs when the traverse direction is reversed. If the rotary axes have backlash outside of the control loop, for example because the angle measurement is made with the motor encoder, this can result in significant error during tilting.

With input parameter Q432 you can activate backlash measurement. Enter an angle that the TNC uses as traversing angle. The cycle will then carry out two measurements per rotary axis. If you take over the angle value 0, the TNC will not measure any backlash.

The TNC does not perform an automatic backlash compensation.

If the measuring circle radius is < 1 mm, the TNC does not calculate the backlash. The larger the measuring circle radius, the more accurately the TNC can determine the rotary axis backlash (see also Log function).

Backlash measurement is not possible if MP6602 is set or if the axis is a Hirth axis.


Please note while programming:

Note that all functions for tilting in the working plane are reset. M128 and FUNCTION TCPM are deactivated.

Position the calibration sphere on the machine table so that there can be no collisions during the measuring process.

Before defining the cycle you must set the datum in the center of the calibration sphere and activate it, or you define the input parameter Q431 correspondingly to 1 or 3.

If MP6602 is not equal to –1 (PLC macro positions the rotary axes), only start a measurement if all rotary axes are at 0°.

For the positioning feed rate when moving to the probing height in the touch probe axis, the TNC uses the value from cycle parameter Q253 or MP6150, whichever is smaller. The TNC always moves the rotary axes at positioning feed rate Q253, while the probe monitoring is inactive.

If the kinematic data attained in the Optimize mode are greater than the permissible limit (MP6600), the TNC shows a warning. Then you have to confirm acceptance of the attained value by pressing NC start.

Note that a change in the kinematics always changes the preset as well. After an optimization, reset the preset.

In every probing process the TNC first measures the radius of the calibration sphere. If the measured sphere radius differs from the entered sphere radius by more than you have defined in MP6601, the TNC shows an error message and ends the measurement.

If you interrupt the cycle during the measurement, the kinematic data might no longer be in the original condition. Save the active kinematic configuration before an optimization with Cycle 450, so that in case of a failure the most recently active kinematic configuration can be restored.

Programming in inches: The TNC always records the log data and results of measurement in millimeters.

The TNC ignores cycle definition data that applies to inactive axes.


Cycle parameters

Example: Calibration program
4 TOOL CALL "TCH PROBE" Z
5 TCH PROBE 450 SAVE KINEMATICS
Q410=0 ;MODE
Q409=5 ;MEMORY
6 TCH PROBE 451 MEASURE KINEMATICS
Q406=1 ;MODE
Q407=12.5 ;SPHERE RADIUS
Q320=0 ;SET-UP CLEARANCE
Q408=0 ;RETR. HEIGHT
Q253=750 ;F PRE-POSITIONING
Q380=0 ;REFERENCE ANGLE
Q411=-90 ;START ANGLE A AXIS
Q412=+90 ;END ANGLE A AXIS
Q413=0 ;INCID. ANGLE A AXIS
Q414=0 ;MEAS. POINTS A AXIS
Q415=-90 ;START ANGLE B AXIS
Q416=+90 ;END ANGLE B AXIS
Q417=0 ;INCID. ANGLE B AXIS
Q418=2 ;MEAS. POINTS B AXIS
Q419=-90 ;START ANGLE C AXIS
Q420=+90 ;END ANGLE C AXIS
Q421=0 ;INCID. ANGLE C AXIS
Q422=2 ;MEAS. POINTS C AXIS
Q423=4 ;NO. OF MEAS. POINTS
Q431=1 ;PRESET
Q432=0 ;BACKLASH, ANG. RANGE

Mode (0/1/2) Q406: Specify whether the TNC should check or optimize the active kinematics: 0: Check the active machine kinematics. The TNC measures the kinematics in the rotary axes you have defined, but it does not make any changes to it. The TNC displays the results of measurement in a measurement log 1: Optimize the active machine kinematics. The TNC measures the kinematics in the rotary axes you have defined and optimizes the position of the rotary axes of the active kinematics. 2: Optimize the active machine kinematics. The TNC measures the kinematics in the rotary axes you have defined and optimizes the position and compensates the angle of the rotary axes of the active kinematics. The KinematicsComp option must be enabled for Mode 2.

Exact calibration sphere radius Q407: Enter the exact radius of the calibration sphere used. Input range 0.0001 to 99.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Retraction height Q408 (absolute): Input range 0.0001 to 99999.9999

  • Input 0:
    Do not move to any retraction height. The TNC moves to the next measuring position in the axis to be measured. Not allowed for Hirth axes! The TNC moves to the first measuring position in the sequence A, then B, then C.
  • Input >0:
    Retraction height in the untilted workpiece coordinate system to which the TNC positions before a rotary axis positioning in the spindle axis. Also, the TNC moves the touch probe in the working plane to the datum. Probe monitoring is not active in this mode. Define the positioning velocity in parameter Q253.

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min during positioning. Input range 0.0001 to 99999.9999; alternatively Fmax, FAUTO, PREDEF

Reference angle Q380 (absolute): Reference angle (basic rotation) for measuring the measuring points in the active workpiece coordinate system. Defining a reference angle can considerably enlarge the measuring range of an axis. Input range 0 to 360.0000

Start angle A axis Q411 (absolute): Starting angle in the A axis at which the first measurement is to be made. Input range -359.999 to 359.999

End angle A axis Q412 (absolute): Ending angle in the A axis at which the last measurement is to be made. Input range -359.999 to 359.999

Angle of incid. A axis Q413: Angle of incidence in the A axis at which the other rotary axes are to be measured. Input range -359.999 to 359.999

Number meas. points A axis Q414: Number of probe measurements with which the TNC is to measure the A axis. If the input value = 0, the TNC does not measure the respective axis. Input range 0 to 12

Start angle B axis Q415 (absolute): Starting angle in the B axis at which the first measurement is to be made. Input range -359.999 to 359.999

End angle B axis Q416 (absolute): Ending angle in the B axis at which the last measurement is to be made. Input range -359.999 to 359.999

Angle of incid. in B axis Q417: Angle of incidence in the B axis at which the other rotary axes are to be measured. Input range -359.999 to 359.999

Number meas. points B axis Q418: Number of probe measurements with which the TNC is to measure the B axis. If the input value = 0, the TNC does not measure the respective axis. Input range 0 to 12

Start angle C axis Q419 (absolute): Starting angle in the C axis at which the first measurement is to be made. Input range -359.999 to 359.999

End angle C axis Q420 (absolute): Ending angle in the C axis at which the last measurement is to be made. Input range -359.999 to 359.999

Angle of incid. in C axis Q421: Angle of incidence in the C axis at which the other rotary axes are to be measured. Input range -359.999 to 359.999

Number meas. points C axis Q422: Number of probe measurements with which the TNC is to measure the C axis. Input range 0 to 12. If the input value = 0, the TNC does not measure the respective axis.

No. of measuring points Q423: Specify the number of probing points to be used by the TNC for measuring the calibration sphere in the plane. Input range: 3 to 8 measurements

Preset (0/1/2/3) Q431: Specify whether the TNC is to set the active preset (datum) automatically in the center of the sphere: 0: Do not set the preset automatically in the center of the sphere: Set the preset manually before the start of the cycle 1: Set the preset automatically in the center of the sphere before measurement: Pre-position the touch probe manually over the calibration sphere before the start of the cycle 2: Set the preset automatically in the center of the sphere after measurement: Set the preset manually before the start of the cycle 3: Set the preset in the center of the sphere before and after measurement: Pre-position the touch probe manually over the calibration sphere before the start of the cycle

Backlash, angle range Q432: Here you define the angle value to be used as traverse for the measurement of the rotary axis backlash. The traversing angle must be significantly larger than the actual backlash of the rotary axes. If input value = 0, the TNC does not measure the backlash. Input range -3.0000 to +3.0000

If you have activated "Preset" before measurement (Q431 = 1/3), then move the touch probe to a position approximately above the center of the calibration sphere before the start of the cycle.


Various modes (Q406)

Example: Angle and position optimization of the rotary axes after automatic datum setting
1 tool call "tS640" Z
2 TCH PROBE 451 MEASURE KINEMATICS
Q406=2 ;MODE
Q407=12.5 ;SPHERE RADIUS
Q320=0 ;SET-UP CLEARANCE
Q408=0 ;RETR. HEIGHT
Q253=750 ;F PRE-POSITIONING
Q380=0 ;REFERENCE ANGLE
Q411=-90 ;START ANGLE A AXIS
Q412=+90 ;END ANGLE A AXIS
Q413=0 ;INCID. ANGLE A AXIS
Q414=0 ;MEAS. POINTS A AXIS
Q415=-90 ;START ANGLE B AXIS
Q416=+90 ;END ANGLE B AXIS
Q417=0 ;INCID. ANGLE B AXIS
Q418=4 ;MEAS. POINTS B AXIS
Q419=+90 ;START ANGLE C AXIS
Q420=+270 ;END ANGLE C AXIS
Q421=0 ;INCID. ANGLE C AXIS
Q422=3 ;MEAS. POINTS C AXIS
Q423=3 ;NO. OF MEAS. POINTS
Q431=1 ;PRESET
Q432=0 ;BACKLASH, ANG. RANGE
  • Test mode Q406 = 0
    • The TNC measures the rotary axes in the positions defined and calculates the static accuracy of the tilting transformation.
    • The TNC records the results of a possible position optimization but does not make any adjustments.
  • Position Optimization mode Q406 = 1
    • The TNC measures the rotary axes in the positions defined and calculates the static accuracy of the tilting transformation.
    • During this, the TNC tries to change the position of the rotary axis in the kinematics model in order to achieve higher accuracy.
    • The machine data is adjusted automatically.
  • Position and Angle Optimization mode Q406 = 2
    • The TNC measures the rotary axes in the positions defined and calculates the static accuracy of the tilting transformation.
    • First the TNC tries to optimize the angular orientation of the rotary axis by means of compensation (Option #52, KinematicsComp).
    • If the TNC succeeded in optimizing the angular orientation, it then optimizes the position through another measurement series.

For angle optimization, the machine manufacturer must have adapted the configuration correspondingly. You can ask your machine manufacturer if this is the case, and whether an angle optimization makes sense. Angle optimization can be particularly useful on small, compact machines.

Angle compensation is only possible with Option #52 KinematicsComp.


Log function

    After running Cycle 451, the TNC creates a measuring log (TCHPR451.TXT) containing the following information:

  • Creation date and time of the log
  • Path of the NC program from which the cycle was run
  • Mode used (0=Check/1=Optimize position/2=Optimize pose)
  • Active kinematic number
  • Entered calibration sphere radius
  • For each measured rotary axis:
    • Starting angle
    • End angle
    • Angle of incidence
    • Number of measuring points
    • Dispersion (standard deviation)
    • Maximum error
    • Angular error
    • Averaged backlash
    • Averaged positioning error
    • Measuring circle radius
    • Compensation values in all axes (preset shift)
    • Evaluation of measuring points
    • Measurement uncertainty of rotary axes
Further Informations:
> Notes on log data


Notes on log data
  • Error outputs
    In the Test mode (Q406=0) the TNC outputs the accuracy that can be attained by optimization and/or the accuracies attained through optimization (Modes 1 and 2).
    If the angular position of a rotary axis was calculated, the measured data is also shown in the log.
  • Dispersion (standard deviation)
    In the log, 'dispersion', a term from statistics, is used as a measure of accuracy. Measured dispersion (measured standard deviation) means that 68.3% of the actually measured spatial errors are within the specified range (+/–). Optimized dispersion (optimized standard deviation) means that 68.3% of the spatial errors to be expected after the correction of the kinematics are within the specified range (+/–).
  • Evaluation of measuring points The valuation numbers are a measure of the quality of the measuring positions with respect to the changeable transformations of the kinematics model. The higher the valuation number, the greater the benefit from optimization by the TNC. The valuation of any rotary axis should not fall below a value of 2. Values greater than or equal to 4 are desirable. If the valuation numbers are too small, increase the measurement range of the rotary axis, or the number of measuring points.

If the valuation numbers are too small, increase the measurement range of the rotary axis, or the number of measuring points. If these measures do not improve the valuation number, this might be due to an incorrect kinematics description. If necessary, inform your service agency.

Measurement uncertainty of angles

The TNC always indicates measurement uncertainty in degrees per 1 µm of system uncertainty. This information is important for evaluating the quality of the measured positioning errors, or the backlash of a rotary axis.

The system uncertainty includes at least the repeatability of the axes (backlash) as well as the positioning uncertainty of the linear axes (positioning errors) and of the touch probe. Since the TNC does not know the accuracy of the complete system, you must make a separate evaluation.

  • Example of uncertainty of the calculated positioning errors:
    • Positioning uncertainty of each linear axis: 10 µm
    • Uncertainty of touch probe: 2 µm
    • Logged measurement uncertainty: 0.0002 °/µm
    • System uncertainty = SQRT( 3 * 10² + 2² ) = 17.4 µm
    • Measurement uncertainty = 0.0002 °/µm * 17.4 µm = 0.0034°
  • Example of uncertainty of the calculated backlash:
    • Repeatability of each linear axis: 5 µm
    • Uncertainty of touch probe: 2 µm
    • Logged measurement uncertainty: 0.0002 °/µm
    • System uncertainty = SQRT( 3 * 5² + 2² ) = 8.9 µm
    • Measurement uncertainty = 0.0002 °/µm * 8.9 µm = 0.0018°


PRESET COMPENSATION (Cycle 452, DIN/ISO: G452, Option)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters
> Adjustment of interchangeable heads
> Drift compensation
> Log function


Cycle run

Touch probe cycle 452 optimizes the kinematic transformation chain of your machine (see MEASURE KINEMATICS (Cycle 451, DIN/ISO: G451; Option)). Then the TNC corrects the workpiece coordinate system in the kinematics model in such a way that the current preset is in the center of the calibration sphere after optimization.

This cycle enables you, for example, to adjust different interchangeable heads so that the workpiece preset applies for all heads.

  1. Clamp the calibration sphere.
  2. Measure the complete reference head with Cycle 451, and use Cycle 451 to finally set the preset in the center of the sphere.
  3. Insert the second head.
  4. Use Cycle 452 to measure the interchangeable head up to the point where the head is changed.
  5. Use Cycle 452 to adjust other interchangeable heads to the reference head.

If it is possible to leave the calibration sphere clamped to the machine table during machining, you can compensate for machine drift, for example. This procedure is also possible on a machine without rotary axes.

  1. Clamp the calibration sphere and check for potential collisions.
  2. Set the preset in the calibration sphere.
  3. Set the preset on the workpiece, and start machining the workpiece.
  4. The TNC automatically measures all the rotary axes successively in the resolution you defined. The current measurement status is displayed in a pop-up window. The TNC hides the status window when the distance to be traversed is greater than the radius of the ball tip.
  5. Use Cycle 452 for preset compensation at regular intervals. The TNC measures the drift of the axes involved and compensates it in the kinematics description.
Parameter number | Meaning
Q141 | Standard deviation measured in the A axis (–1 if axis was not measured)
Q142 | Standard deviation measured in the B axis (–1 if axis was not measured)
Q143 | Standard deviation measured in the C axis (–1 if axis was not measured)
Q144 | Optimized standard deviation in the A axis (–1 if axis was not measured)
Q145 | Optimized standard deviation in the B axis (–1 if axis was not measured)
Q146 | Optimized standard deviation in the C axis (–1 if axis was not measured)
Q147 | Offset error in X direction, for manual transfer to the corresponding machine parameter
Q148 | Offset error in Y direction, for manual transfer to the corresponding machine parameter
Q149 | Offset error in Z direction, for manual transfer to the corresponding machine parameter


Please note while programming:

In order to be able to perform a preset compensation, the kinematics must be specially prepared. The machine manual provides further information.

Note that all functions for tilting in the working plane are reset. M128 and FUNCTION TCPM are deactivated.

Position the calibration sphere on the machine table so that there can be no collisions during the measuring process.

Before defining the cycle you must set the datum in the center of the calibration sphere and activate it.

For rotary axes without separate position encoders, select the measuring points in such a way that you have to traverse a distance of 1° to the limit switch. The TNC needs this distance for internal backlash compensation.

For the positioning feed rate when moving to the probing height in the touch probe axis, the TNC uses the value from cycle parameter Q253 or MP6150, whichever is smaller. The TNC always moves the rotary axes at positioning feed rate Q253, while the probe monitoring is inactive.

If the kinematic data attained in the Optimize mode are greater than the permissible limit (MP6600), the TNC shows a warning. Then you have to confirm acceptance of the attained value by pressing NC start.

Note that a change in the kinematics always changes the preset as well. After an optimization, reset the preset.

In every probing process the TNC first measures the radius of the calibration sphere. If the measured sphere radius differs from the entered sphere radius by more than you have defined in MP6601, the TNC shows an error message and ends the measurement.

If you interrupt the cycle during the measurement, the kinematic data might no longer be in the original condition. Save the active kinematic configuration before an optimization with Cycle 450, so that in case of a failure the most recently active kinematic configuration can be restored.

Programming in inches: The TNC always records the log data and results of measurement in millimeters.


Cycle parameters

Example: Calibration program
4 TOOL CALL "TCH PROBE" Z
5 TCH PROBE 450 SAVE KINEMATICS
Q410=0 ;MODE
Q409=5 ;MEMORY
6 TCH PROBE 452 PRESET COMPENSATION
Q407=12.5 ;SPHERE RADIUS
Q320=0 ;SET-UP CLEARANCE
Q408=0 ;RETR. HEIGHT
Q253=750 ;F PRE-POSITIONING
Q380=0 ;REFERENCE ANGLE
Q411=-90 ;START ANGLE A AXIS
Q412=+90 ;END ANGLE A AXIS
Q413=0 ;INCID. ANGLE A AXIS
Q414=0 ;MEAS. POINTS A AXIS
Q415=-90 ;START ANGLE B AXIS
Q416=+90 ;END ANGLE B AXIS
Q417=0 ;INCID. ANGLE B AXIS
Q418=2 ;MEAS. POINTS B AXIS
Q419=-90 ;START ANGLE C AXIS
Q420=+90 ;END ANGLE C AXIS
Q421=0 ;INCID. ANGLE C AXIS
Q422=2 ;MEAS. POINTS C AXIS
Q423=4 ;NO. OF MEAS. POINTS
Q432=0 ;BACKLASH, ANG. RANGE

Exact calibration sphere radius Q407: Enter the exact radius of the calibration sphere used. Input range 0.0001 to 99.9999

Set-up clearance Q320 (incremental): Additional distance between measuring point and ball tip. Q320 is added to MP6140. Input range 0 to 99999.9999; alternatively PREDEF

Retraction height Q408 (absolute): Input range 0.0001 to 99999.9999

  • Input 0:
    Do not move to any retraction height. The TNC moves to the next measuring position in the axis to be measured. Not allowed for Hirth axes! The TNC moves to the first measuring position in the sequence A, then B, then C.
  • Input >0:
    Retraction height in the untilted workpiece coordinate system to which the TNC positions before a rotary axis positioning in the spindle axis. Also, the TNC moves the touch probe in the working plane to the datum. Probe monitoring is not active in this mode. Define the positioning velocity in parameter Q253.

Feed rate for pre-positioning Q253: Traversing speed of the tool in mm/min during positioning. Input range 0.0001 to 99999.9999; alternatively Fmax, FAUTO PREDEF

Reference angle Q380 (absolute): Reference angle (basic rotation) for measuring the measuring points in the active workpiece coordinate system. Defining a reference angle can considerably enlarge the measuring range of an axis. Input range 0 to 360.0000

Start angle A axis Q411 (absolute): Starting angle in the A axis at which the first measurement is to be made. Input range -359.999 to 359.999

End angle A axis Q412 (absolute): Ending angle in the A axis at which the last measurement is to be made. Input range -359.999 to 359.999

Angle of incid. A axis Q413: Angle of incidence in the A axis at which the other rotary axes are to be measured. Input range -359.999 to 359.999

Number meas. points A axis Q414: Number of probe measurements with which the TNC is to measure the A axis. If the input value = 0, the TNC does not measure the respective axis. Input range 0 to 12

Start angle B axis Q415 (absolute): Starting angle in the B axis at which the first measurement is to be made. Input range -359.999 to 359.999

End angle B axis Q416 (absolute): Ending angle in the B axis at which the last measurement is to be made. Input range -359.999 to 359.999

Angle of incid. in B axis Q417: Angle of incidence in the B axis at which the other rotary axes are to be measured. Input range -359.999 to 359.999

Number meas. points B axis Q418: Number of probe measurements with which the TNC is to measure the B axis. If the input value = 0, the TNC does not measure the respective axis. Input range 0 to 12

Start angle C axis Q419 (absolute): Starting angle in the C axis at which the first measurement is to be made. Input range -359.999 to 359.999

End angle C axis Q420 (absolute): Ending angle in the C axis at which the last measurement is to be made. Input range -359.999 to 359.999

Angle of incid. in C axis Q421: Angle of incidence in the C axis at which the other rotary axes are to be measured. Input range -359.999 to 359.999

Number meas. points C axis Q422: Number of probe measurements with which the TNC is to measure the C axis. If the input value = 0, the TNC does not measure the respective axis. Input range 0 to 12

No. of measuring points Q423: Specify the number of probing points to be used by the TNC for measuring the calibration sphere in the plane. Input range: 3 to 8 measurements

Backlash, angle range Q432: Here you define the angle value to be used as traverse for the measurement of the rotary axis backlash. The traversing angle must be significantly larger than the actual backlash of the rotary axes. If input value = 0, the TNC does not measure the backlash. Input range -3.0000 to +3.0000


Adjustment of interchangeable heads

Example: Measuring a reference head
1 TOOL CALL "TCH PROBE" Z
2 TCH PROBE 451 MEASURE KINEMATICS
Q406=1 ;MODE
Q407=12.5 ;SPHERE RADIUS
Q320=0 ;SET-UP CLEARANCE
Q408=0 ;RETR. HEIGHT
Q253=2000 ;F PRE-POSITIONING
Q380=45 ;REFERENCE ANGLE
Q411=-90 ;START ANGLE A AXIS
Q412=+90 ;END ANGLE A AXIS
Q413=45 ;INCID. ANGLE A AXIS
Q414=4 ;MEAS. POINTS A AXIS
Q415=-90 ;START ANGLE B AXIS
Q416=+90 ;END ANGLE B AXIS
Q417=0 ;INCID. ANGLE B AXIS
Q418=2 ;MEAS. POINTS B AXIS
Q419=+90 ;START ANGLE C AXIS
Q420=+270 ;END ANGLE C AXIS
Q421=0 ;INCID. ANGLE C AXIS
Q422=3 ;MEAS. POINTS C AXIS
Q423=4 ;NO. OF MEAS. POINTS
Q431=3 ;PRESET
Q432=0 ;BACKLASH, ANG. RANGE

The goal of this procedure is for the workpiece preset to remain unchanged after changing rotary axes (head exchange).

In the following example, a fork head is adjusted to the A and C axes. The A axis is changed, whereas the C axis continues being a part of the basic configuration.

  • Insert the interchangeable head that will be used as a reference head

  • Clamp the calibration sphere

  • Insert the touch probe

  • Use Cycle 451 to measure the complete kinematics, including the reference head

  • Set the preset (using Q431 = 2 or 3 in Cycle 451) after measuring the reference head

Example: Adjusting an interchangeable head
3 TOOL CALL "TCH PROBE" Z
4 TCH PROBE 452 PRESET COMPENSATION
Q407=12.5 ;SPHERE RADIUS
Q320=0 ;SET-UP CLEARANCE
Q408=0 ;RETR. HEIGHT
Q253=2000 ;F PRE-POSITIONING
Q380=45 ;REFERENCE ANGLE
Q411=-90 ;START ANGLE A AXIS
Q412=+90 ;END ANGLE A AXIS
Q413=45 ;INCID. ANGLE A AXIS
Q414=4 ;MEAS. POINTS A AXIS
Q415=-90 ;START ANGLE B AXIS
Q416=+90 ;END ANGLE B AXIS
Q417=0 ;INCID. ANGLE B AXIS
Q418=2 ;MEAS. POINTS B AXIS
Q419=+90 ;START ANGLE C AXIS
Q420=+270 ;END ANGLE C AXIS
Q421=0 ;INCID. ANGLE C AXIS
Q422=0 ;MEAS. POINTS C AXIS
Q423=4 ;NO. OF MEAS. POINTS
Q432=0 ;BACKLASH, ANG. RANGE

  • Insert the second interchangeable head

  • Insert the touch probe

  • Measure the interchangeable head with Cycle 452

  • Measure only the axes that have actually been changed (in this example: only the A axis; the C axis is hidden with Q422)

  • The preset and the position of the calibration sphere must not be changed during the complete process

  • All other interchangeable heads can be adjusted in the same way

The head change function can vary depending on the individual machine tool. Refer to your machine manual.


Drift compensation

Example: Reference measurement for drift compensation
1 TOOL CALL "TCH PROBE" Z
2 CYCL DEF 247 DATUM SETTING
Q339=1 ;DATUM NUMBER
3 TCH PROBE 451 MEASURE KINEMATICS
Q406=1 ;MODE
Q407=12.5 ;SPHERE RADIUS
Q320=0 ;SET-UP CLEARANCE
Q408=0 ;RETR. HEIGHT
Q253=750 ;F PRE-POSITIONING
Q380=45 ;REFERENCE ANGLE
Q411=+90 ;START ANGLE A AXIS
Q412=+270 ;END ANGLE A AXIS
Q413=45 ;INCID. ANGLE A AXIS
Q414=4 ;MEAS. POINTS A AXIS
Q415=-90 ;START ANGLE B AXIS
Q416=+90 ;END ANGLE B AXIS
Q417=0 ;INCID. ANGLE B AXIS
Q418=2 ;MEAS. POINTS B AXIS
Q419=+90 ;START ANGLE C AXIS
Q420=+270 ;END ANGLE C AXIS
Q421=0 ;INCID. ANGLE C AXIS
Q422=3 ;MEAS. POINTS C AXIS
Q423=4 ;NO. OF MEAS. POINTS
Q431=3 ;PRESET
Q432=0 ;BACKLASH, ANG. RANGE

During machining various machine components are subject to drift due to varying ambient conditions. If the drift remains sufficiently constant over the range of traverse, and if the calibration sphere can be left on the machine table during machining, the drift can be measured and compensated with Cycle 452.

  • Clamp the calibration sphere

  • Insert the touch probe

  • Measure the complete kinematics with Cycle 451 before starting the machining process

  • Set the preset (using Q432 = 2 or 3 in Cycle 451) after measuring the kinematics.

  • Then set the presets on your workpieces and start the machining process

Example: Drift compensation
4 TOOL CALL "TCH PROBE" Z
5 TCH PROBE 452 PRESET COMPENSATION
Q407=12.5 ;SPHERE RADIUS
Q320=0 ;SET-UP CLEARANCE
Q408=0 ;RETR. HEIGHT
Q253=99999 ;F PRE-POSITIONING
Q380=45 ;REFERENCE ANGLE
Q411=-90 ;START ANGLE A AXIS
Q412=+90 ;END ANGLE A AXIS
Q413=45 ;INCID. ANGLE A AXIS
Q414=4 ;MEAS. POINTS A AXIS
Q415=-90 ;START ANGLE B AXIS
Q416=+90 ;END ANGLE B AXIS
Q417=0 ;INCID. ANGLE B AXIS
Q418=2 ;MEAS. POINTS B AXIS
Q419=+90 ;START ANGLE C AXIS
Q420=+270 ;END ANGLE C AXIS
Q421=0 ;INCID. ANGLE C AXIS
Q422=3 ;MEAS. POINTS C AXIS
Q423=3 ;NO. OF MEAS. POINTS
Q432=0 ;BACKLASH, ANG. RANGE

  • Measure the drift of the axes at regular intervals.

  • Insert the touch probe.

  • Activate the preset in the calibration sphere.

  • Use Cycle 452 to measure the kinematics.

  • The preset and the position of the calibration sphere must not be changed during the complete process

This procedure can also be performed on machines without rotary axes.


Log function

    After running Cycle 452, the TNC creates a measuring log (TCHPR452.TXT) containing the following information:

  • Creation date and time of the log
  • Path of the NC program from which the cycle was run
  • Active kinematic number
  • Entered calibration sphere radius
  • For each measured rotary axis:
    • Starting angle
    • End angle
    • Angle of incidence
    • Number of measuring points
    • Dispersion (standard deviation)
    • Maximum error
    • Angular error
    • Averaged backlash
    • Averaged positioning error
    • Measuring circle radius
    • Compensation values in all axes (preset shift)
    • Evaluation of measuring points
    • Measurement uncertainty of rotary axes
Further Informations:
> Notes on log data


Notes on log data

(see Notes on log data)


Touch Probe Cycles: Automatic Tool Measurement

Further Informations:
> Fundamentals
> Calibrating the TT (Cycle 30 or 480, DIN/ISO: G480)
> CALIBRATING THE WIRELESS TT 449 (Cycle 484, DIN/ISO: G484)
> Measuring the Tool Length (Cycle 31 or 481, DIN/ISO: G481)
> Measuring the Tool Radius (Cycle 32 or 482, DIN/ISO: G482)
> Measuring Tool Length and Radius (Cycle 33 or 483, DIN/ISO: G483)


Fundamentals

Further Informations:
> Overview
> Differences between Cycles 31 to 33 and Cycles 481 to 483
> Setting the machine parameters
> Entries in the tool table TOOL.T
> Display of the measurement results


Overview

The TNC and the machine tool must be set up by the machine tool builder for use of the TT touch probe.

Some cycles and functions may not be provided on your machine tool. Refer to your machine manual.

In conjunction with the TNC's tool measurement cycles, the tool touch probe enables you to measure tools automatically. The compensation values for tool length and radius can be stored in the central tool file TOOL.T and are accounted for at the end of the touch probe cycle. The following types of tool measurement are provided:

  • Tool measurement while the tool is at standstill
  • Tool measurement while the tool is rotating
  • Measurement of individual teeth

You can program the cycles for tool measurement in the Programming and Editing mode of operation via the TOUCH PROBE key. The following cycles are available:

Cycle | New format | Old format | Page
Calibrating the TT, Cycles 30 and 480 |  |  | Calibrating the TT (Cycle 30 or 480, DIN/ISO: G480)
Calibrating the wireless TT 449, Cycle 484 |  |  | CALIBRATING THE WIRELESS TT 449 (Cycle 484, DIN/ISO: G484)
Measuring the tool length, Cycles 31 and 481 |  |  | Measuring the Tool Length (Cycle 31 or 481, DIN/ISO: G481)
Measuring the tool radius, Cycles 32 and 482 |  |  | Measuring the Tool Radius (Cycle 32 or 482, DIN/ISO: G482)
Measuring the tool length and radius, Cycles 33 and 483 |  |  | Measuring Tool Length and Radius (Cycle 33 or 483, DIN/ISO: G483)

The measuring cycles can be used only when the central tool file TOOL.T is active.

Before working with the measuring cycles, you must first enter all the required data into the central tool file and call the tool to be measured with TOOL CALL.

You can also measure tools in a tilted working plane.


Differences between Cycles 31 to 33 and Cycles 481 to 483

The features and the operating sequences are absolutely identical. There are only two differences between Cycles 31 to 33 and Cycles 481 to 483:

  • Cycles 481 to 483 are also available in controls for ISO programming under G481 to G483.
  • Instead of a selectable parameter for the status of the measurement, the new cycles use the fixed parameter Q199.


Setting the machine parameters

The TNC uses the feed rate for probing defined in MP6520 when measuring a tool at standstill.

When measuring a rotating tool, the TNC automatically calculates the spindle speed and feed rate for probing.

The spindle speed is calculated as follows:

n = MP6570 / (r • 0.0063) where

n | Shaft speed [rpm]
MP6570 | Maximum permissible cutting speed in m/min
r | Active tool radius in mm

The feed rate for probing is calculated from:v = meas. tolerance • n where

v | Feed rate for probing in mm/min
Measuring tolerance | Measuring tolerance [mm], depending on MP6507
n | Shaft speed in rpm

MP6507 determines the calculation of the probing feed rate:

MP6507=0:

The measuring tolerance remains constant regardless of the tool radius. With very large tools, however, the feed rate for probing is reduced to zero. The smaller you set the maximum permissible rotational speed (MP6570) and the permissible tolerance (MP6510), the sooner you will encounter this effect.

MP6507=1:

The measuring tolerance is adjusted relative to the size of the tool radius. This ensures a sufficient feed rate for probing even with large tool radii. The TNC adjusts the measuring tolerance according to the following table:

Tool radius | Measuring tolerance
Up to 30 mm | MP6510
30 to 60 mm: | 2 • MP6510
60 to 90 mm: | 3 • MP6510
90 to 120 mm: | 4 • MP6510

MP6507=2:

The feed rate for probing remains constant; the error of measurement, however, rises linearly with the increase in tool radius:

Measuring tolerance = (r • MP6510)/ 5 mm), where

r | Active tool radius in mm
MP6510 | Maximum permissible error of measurement


Entries in the tool table TOOL.T

Abbr. | Inputs | Dialog
CUT | Number of teeth (20 teeth maximum) | Number of teeth?
LTOL | Permissible deviation from tool length L for wear detection. If the entered value is exceeded, the TNC locks the tool (status L). Input range: 0 to 0.9999 mm | Wear tolerance: length?
RTOL | Permissible deviation from tool radius R for wear detection. If the entered value is exceeded, the TNC locks the tool (status L). Input range: 0 to 0.9999 mm | Wear tolerance: radius?
DIRECT. | Cutting direction of the tool for measuring the tool during rotation | Cutting direction (M3 = –)?
TT:R-OFFS | Tool length measurement: Tool offset between stylus center and tool center. Preset value: Tool radius R (NO ENT means R) | Tool offset: radius?
TT:L-OFFS | Radius measurement: Tool offset in addition to MP6530 between upper surface of stylus and lower surface of tool. Default: 0 | Tool offset: length?
LBREAK | Permissible deviation from tool length L for breakage detection. If the entered value is exceeded, the TNC locks the tool (status L). Input range: 0 to 0.9999 mm | Breakage tolerance: length?
RBREAK | Permissible deviation from tool radius R for breakage detection. If the entered value is exceeded, the TNC locks the tool (status L). Input range: 0 to 0.9999 mm | Breakage tolerance: radius?
Further Informations:
> Input examples for common tool types


Input examples for common tool types
Tool type | CUT | TT:R-OFFS | TT:L-OFFS
Drill | – (no function) | 0 (no offset required because tool tip is to be measured) |
End mill with diameter < 19 mm | 4 (4 teeth) | 0 (no offset required because tool diameter is smaller than the contact plate diameter of the TT) | 0 (no additional offset required during radius measurement. Offset from MP6530 is used.)
End mill with diameter > 19 mm | 4 (4 teeth) | R (offset required because tool diameter is larger than the contact plate diameter of the TT) | 0 (no additional offset required during radius measurement. Offset from MP6530 is used.)
Radius cutter | 4 (4 teeth) | 0 (no offset required because the south pole of the ball is to be measured) | 5 (always define the tool radius as the offset so that the diameter is not measured in the radius)


Display of the measurement results

You can display the results of tool measurement in the additional status display (in the machine operating modes). The TNC then shows the program blocks in the left and the measuring results in the right screen window. The measuring results that exceed the permissible wear tolerance are marked in the status display with an asterisk “*”; the results that exceed the permissible breakage tolerance are marked with the character B.


Calibrating the TT (Cycle 30 or 480, DIN/ISO: G480)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

The TT is calibrated with the measuring cycle TCH PROBE 30 or TCH PROBE 480 (see also Differences between Cycles 31 to 33 and Cycles 481 to 483). The calibration process is automatic. The TNC also measures the center misalignment of the calibrating tool automatically by rotating the spindle by 180° after the first half of the calibration cycle.

The calibrating tool must be a precisely cylindrical part, for example a cylinder pin. The resulting calibration values are stored in the TNC memory and are accounted for during subsequent tool measurement.

The calibration tool should have a diameter of more than 15 mm and protrude approx. 50 mm from the chuck. This configuration causes a deformation of 0.1 µm per 1 N of probing force.


Please note while programming:

The functioning of the calibration cycle is dependent on MP6500. Refer to your machine manual.

Before calibrating the touch probe, you must enter the exact length and radius of the calibrating tool into the tool table TOOL.T.

The position of the TT within the machine working space must be defined by setting the Machine Parameters 6580.0 to 6580.2.

If you change the setting of any of the Machine Parameters 6580.0 to 6580.2, you must recalibrate the TT.


Cycle parameters

Example: NC blocks in old format
6 TOOL CALL 1 z
7 TCH PROBE 30.0 CALIBRATE TT
8 TCH PROBE 30.1 HEIGHT: +90
Example: NC blocks in new format
6 TOOL CALL 1 z
7 TCH PROBE 480 CALIBRATE TT
Q260=+100 ;CLEARANCE HEIGHT

Clearance height: Enter the position in the spindle axis at which there is no danger of collision with the workpiece or fixtures. The clearance height is referenced to the active workpiece datum. If you enter such a small clearance height that the tool tip would lie below the level of the probe contact, the TNC automatically positions the calibration tool above the level of the probe contact (safety zone from MP6540). Input range ‑99999.9999 to 99999.9999; alternatively PREDEF


CALIBRATING THE WIRELESS TT 449 (Cycle 484, DIN/ISO: G484)

Further Informations:
> Fundamentals
> Cycle run
> Please note while programming:
> Cycle parameters


Fundamentals

With Cycle 484, you calibrate the wireless infrared TT 449 tool touch probe. The calibration process is not completely automated, because the TT's position on the table is not defined.


Cycle run

  • Insert the calibrating tool

  • Define and start the calibration cycle

  • Position the calibrating tool manually above the center of the touch probe and follow the instructions in the pop-up window. Ensure that the calibrating tool is located above the measuring surface of the probe contact

The calibration process is semi-automatic. The TNC also measures the center misalignment of the calibrating tool by rotating the spindle by 180° after the first half of the calibration cycle.

The calibrating tool must be a precisely cylindrical part, for example a cylinder pin. The resulting calibration values are stored in the TNC memory and are accounted for during subsequent tool measurement.

The calibration tool should have a diameter of more than 15 mm and protrude approx. 50 mm from the chuck. This configuration causes a deformation of 0.1 µm per 1 N of probing force.


Please note while programming:

The functioning of the calibration cycle is dependent on MP 6500. Refer to your machine manual.

Before calibrating the touch probe, you must enter the exact length and radius of the calibrating tool into the tool table TOOL.T.

The TT needs to be recalibrated if you change its position on the table.


Cycle parameters

Cycle 484 has no cycle parameters.


Measuring the Tool Length (Cycle 31 or 481, DIN/ISO: G481)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

To measure the tool length, program the measuring cycle TCH PROBE 31 or TCH PROBE 481 (see also Differences between Cycles 31 to 33 and Cycles 481 to 483). Via input parameters you can measure the length of a tool by three methods:

  • If the tool diameter is larger than the diameter of the measuring surface of the TT, you measure the tool while it is rotating.
  • If the tool diameter is smaller than the diameter of the measuring surface of the TT, or if you are measuring the length of a drill or spherical cutter, you measure the tool while it is at standstill.
  • If the tool diameter is larger than the diameter of the measuring surface of the TT, you measure the individual teeth of the tool while it is at standstill.
Further Informations:
> Cycle for measuring a tool during rotation
> Cycle for measuring a tool during standstill (e.g. for drills)
> Cycle for measuring individual teeth


Cycle for measuring a tool during rotation

The control determines the longest tooth of a rotating tool by positioning the tool to be measured at an offset to the center of the touch probe and then moving it toward the measuring surface of the TT until it contacts the surface. The offset is programmed in the tool table under Tool offset: Radius (TT: R-OFFS).


Cycle for measuring a tool during standstill (e.g. for drills)

The control positions the tool to be measured over the center of the measuring surface. It then moves the non-rotating tool toward the measuring surface of the TT until contact is made. To activate this function, enter zero for the tool offset: Radius (TT: R-OFFS) in the tool table.


Cycle for measuring individual teeth

The TNC pre-positions the tool to be measured to a position at the side of the touch probe head. The distance from the tip of the tool to the upper edge of the touch probe head is defined in MP6530. You can enter an additional offset with tool offset: Length (TT: L-OFFS) in the tool table. The TNC probes the tool radially during rotation to determine the starting angle for measuring the individual teeth. It then measures the length of each tooth by changing the corresponding angle of spindle orientation. To activate this function, program TCH PROBE 31 = 1 for CUTTER MEASUREMENT.


Please note while programming:

Before measuring a tool for the first time, enter the following data on the tool into the tool table TOOL.T: the approximate radius, the approximate length, the number of teeth, and the cutting direction.

You can run an individual tooth measurement of tools with up to 99 teeth. The TNC shows the measured values of up to 24 teeth in the status display.


Cycle parameters

Example: Measuring a rotating tool for the first time; old format
6 TOOL CALL 12 z
7 TCH PROBE 31.0 TOOL LENGTH
8 TCH PROBE 31.1 CHECK: 0
9 TCH PROBE 31.2 HEIGHT: +120
10 TCH PROBE 31.3 PROBING THE TEETH: 0
Example: Inspecting a tool and measuring the individual teeth and saving the status in Q5; old format
6 TOOL CALL 12 z
7 TCH PROBE 31.0 TOOL LENGTH
8 TCH PROBE 31.1 CHECK: 1 Q5
9 TCH PROBE 31.2 HEIGHT: +120
10 TCH PROBE 31.3 PROBING THE TEETH: 1
Example: NC blocks in new format
6 TOOL CALL 12 z
7 TCH PROBE 481 TOOL LENGTH
Q340=1 ;CHECK
Q260=+100 ;CLEARANCE HEIGHT
Q341=1 ;PROBING THE TEETH

Measure tool=0 / Check tool=1: Select whether the tool is to be measured for the first time or whether a tool that has already been measured is to be inspected. If the tool is being measured for the first time, the TNC overwrites the tool length L in the central tool file TOOL.T by the delta value DL = 0. If you wish to inspect a tool, the TNC compares the measured length with the tool length L that is stored in TOOL.T. It then calculates the positive or negative deviation from the stored value and enters it into TOOL.T as the delta value DL. The deviation can also be used for parameter Q115. If the delta value is greater than the permissible tool length tolerance for wear or break detection, the TNC will lock the tool (status L in TOOL.T).

Parameter number for result?: Parameter number in which the TNC stores the status of the measurement: 0.0: Tool is within the tolerance 1.0: Tool is worn (LTOL exceeded) 2.0: Tool is broken (LBREAK exceeded). If you do not wish to use the result of measurement within the program, answer the dialog prompt with NO ENT.

Clearance height: Enter the position in the spindle axis at which there is no danger of collision with the workpiece or fixtures. The clearance height is referenced to the active workpiece datum. If you enter such a small clearance height that the tool tip would lie below the level of the probe contact, the TNC automatically positions the tool above the level of the probe contact (safety zone from MP6540). Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Cutter measurement? 0=No / 1=Yes: Choose whether the control is to measure the individual teeth (maximum of 99 teeth)


Measuring the Tool Radius (Cycle 32 or 482, DIN/ISO: G482)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

To measure the tool radius, program the cycle TCH PROBE 32 or TCH PROBE 482 (see also Differences between Cycles 31 to 33 and Cycles 481 to 483). Select via input parameters by which of two methods the radius of a tool is to be measured:

  • Measuring the tool while it is rotating
  • Measuring the tool while it is rotating and subsequently measuring the individual teeth.

The TNC pre-positions the tool to be measured to a position at the side of the touch probe head. The distance from the tip of the milling tool to the upper edge of the touch probe head is defined in MP6530. The TNC probes the tool radially while it is rotating. If you have programmed a subsequent measurement of individual teeth, the control measures the radius of each tooth with the aid of oriented spindle stops.


Please note while programming:

Before measuring a tool for the first time, enter the following data on the tool into the tool table TOOL.T: the approximate radius, the approximate length, the number of teeth, and the cutting direction.

Cylindrical tools with diamond surfaces can be measured with stationary spindle. To do so, define in the tool table the number of teeth (CUT) as 0 and adjust machine parameter 6500. Refer to your machine manual.

You can run an individual tooth measurement of tools with up to 99 teeth. The TNC shows the measured values of up to 24 teeth in the status display.


Cycle parameters

Example: Measuring a rotating tool for the first time; old format
6 TOOL CALL 12 z
7 TCH PROBE 32.0 TOOL RADIUS
8 TCH PROBE 32.1 CHECK: 0
9 TCH PROBE 32.2 HEIGHT: +120
10 TCH PROBE 32.3 PROBING THE TEETH: 0
Example: Inspecting a tool and measuring the individual teeth and saving the status in Q5; old format
6 TOOL CALL 12 z
7 TCH PROBE 32.0 TOOL RADIUS
8 TCH PROBE 32.1 CHECK: 1 Q5
9 TCH PROBE 32.2 HEIGHT: +120
10 TCH PROBE 32.3 PROBING THE TEETH: 1
Example: NC blocks in new format
6 TOOL CALL 12 z
7 TCH PROBE 482 TOOL RADIUS
Q340=1 ;CHECK
Q260=+100 ;CLEARANCE HEIGHT
Q341=1 ;PROBING THE TEETH

Measure tool=0 / Check tool=1: Select whether the tool is to be measured for the first time or whether a tool that has already been measured is to be inspected. If the tool is being measured for the first time, the TNC overwrites the tool radius R in the central tool file TOOL.T by the delta value DR = 0. If you wish to inspect a tool, the TNC compares the measured radius with the tool radius R that is stored in TOOL.T. It then calculates the positive or negative deviation from the stored value and enters it into TOOL.T as the delta value DR. The deviation can also be used for parameter Q116. If the delta value is greater than the permissible tool radius tolerance for wear or break detection, the TNC will lock the tool (status L in TOOL.T).

Parameter number for result?: Parameter number in which the TNC stores the status of the measurement: 0.0: Tool is within the tolerance 1.0: Tool is worn (RTOL exceeded) 2.0: Tool is broken (RBREAK exceeded). If you do not wish to use the result of measurement within the program, answer the dialog prompt with NO ENT.

Clearance height: Enter the position in the spindle axis at which there is no danger of collision with the workpiece or fixtures. The clearance height is referenced to the active workpiece datum. If you enter such a small clearance height that the tool tip would lie below the level of the probe contact, the TNC automatically positions the tool above the level of the probe contact (safety zone from MP6540). Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Cutter measurement? 0=No / 1=Yes: Choose whether the control is also to measure the individual teeth (maximum of 99 teeth)


Measuring Tool Length and Radius (Cycle 33 or 483, DIN/ISO: G483)

Further Informations:
> Cycle run
> Please note while programming:
> Cycle parameters


Cycle run

To measure both the length and radius of a tool, program the measuring cycle TCH PROBE 33 or TCH PROBE 483 (see also Differences between Cycles 31 to 33 and Cycles 481 to 483). This cycle is particularly suitable for the first measurement of tools, as it saves time when compared with individual measurement of length and radius. Via input parameters you can select the desired type of measurement:

  • Measuring the tool while it is rotating
  • Measuring the tool while it is rotating and subsequently measuring the individual teeth.

The TNC measures the tool in a fixed programmed sequence. First it measures the tool radius, then the tool length. The sequence of measurement is the same as for measuring cycles 31 and 32.


Cycle parameters

Example: Measuring a rotating tool for the first time; old format
6 TOOL CALL 12 z
7 TCH PROBE 33.0 MEASURE TOOL
8 TCH PROBE 33.1 CHECK: 0
9 TCH PROBE 33.2 HEIGHT: +120
10 TCH PROBE 33.3 PROBING THE TEETH: 0
Example: Inspecting a tool and measuring the individual teeth and saving the status in Q5; old format
6 TOOL CALL 12 z
7 TCH PROBE 33.0 MEASURE TOOL
8 TCH PROBE 33.1 CHECK: 1 Q5
9 TCH PROBE 33.2 HEIGHT: +120
10 TCH PROBE 33.3 PROBING THE TEETH: 1
Example: NC blocks in new format
6 TOOL CALL 12 z
7 TCH PROBE 483 MEASURE TOOL
Q340=1 ;CHECK
Q260=+100 ;CLEARANCE HEIGHT
Q341=1 ;PROBING THE TEETH

Measure tool=0 / Check tool=1: Select whether the tool is to be measured for the first time or whether a tool that has already been measured is to be inspected. If the tool is being measured for the first time, the TNC overwrites the tool radius R and the tool length L in the central tool file TOOL.T by the delta values DR = 0 and DL = 0. If you are checking a tool, the measured tool data is compared with the data in the tool table. The TNC calculates the deviations and enters them as positive or negative delta values DR and DL in TOOL.T. The deviations can also be used for parameters Q115 and Q116. If the delta values are greater than the permissible tool tolerances for wear or break detection, the TNC will lock the tool (status L in TOOL.T).

Parameter number for result?: Parameter number in which the TNC stores the status of the measurement: 0.0: Tool is within the tolerance 1.0: Tool is worn (LTOL or/and RTOL exceeded) 2.0: Tool is broken (LBREAK or/and RBREAK exceeded). If you do not wish to use the result of measurement within the program, answer the dialog prompt with NO ENT .

Clearance height: Enter the position in the spindle axis at which there is no danger of collision with the workpiece or fixtures. The clearance height is referenced to the active workpiece datum. If you enter such a small clearance height that the tool tip would lie below the level of the probe contact, the TNC automatically positions the tool above the level of the probe contact (safety zone from MP6540). Input range ‑99999.9999 to 99999.9999; alternatively PREDEF

Cutter measurement? 0=No / 1=Yes: Choose whether the control is also to measure the individual teeth (maximum of 99 teeth)


Overview

Further Informations:
> Overview


Overview

Overview

Further Informations:
> Fixed cycles
> Touch probe cycles


Fixed cycles

Cycle number | Cycle designation | DEF active | CALL active | Page
7 | Datum shift | ■ |  |
8 | Mirroring | ■ |  |
9 | Dwell time | ■ |  |
10 | Rotation | ■ |  |
11 | Scaling factor | ■ |  |
12 | Program call | ■ |  |
13 | Oriented spindle stop | ■ |  |
14 | Contour definition | ■ |  |
19 | Tilting the working plane | ■ |  |
20 | SL II contour data | ■ |  |
21 | SL II pilot drilling |  | ■ |
22 | SL II rough out |  | ■ |
23 | Floor finishing SL II |  | ■ |
24 | Side finishing SL II |  | ■ |
25 | Contour train |  | ■ |
26 | Axis-specific scaling | ■ |  |
27 | Cylinder surface |  | ■ |
28 | Cylindrical surface slot |  | ■ |
29 | Cylinder surface ridge |  | ■ |
30 | Run 3-D data |  | ■ |
32 | Tolerance | ■ |  |
39 | Cylinder surface external contour |  | ■ |
200 | Drilling |  | ■ |
201 | Reaming |  | ■ |
202 | Boring |  | ■ |
203 | Universal drilling |  | ■ |
204 | Back boring |  | ■ |
205 | Universal pecking |  | ■ |
206 | Tapping with a floating tap holder, new |  | ■ |
207 | Rigid tapping, new |  | ■ |
208 | Bore milling |  | ■ |
209 | Tapping with chip breaking |  | ■ |
220 | Polar pattern | ■ |  |
221 | Cartesian pattern | ■ |  |
230 | Multipass milling |  | ■ |
231 | Ruled surface |  | ■ |
232 | Face milling |  | ■ |
240 | Centering |  | ■ |
241 | Single-fluted deep-hole drilling |  | ■ |
247 | Datum setting | ■ |  |
251 | Rectangular pocket (complete machining) |  | ■ |
252 | Circular pocket (complete machining) |  | ■ |
253 | Slot milling |  | ■ |
254 | Circular slot |  | ■ |
256 | Rectangular stud (complete machining) |  | ■ |
257 | Circular stud (complete machining) |  | ■ |
262 | Thread milling |  | ■ |
263 | Thread milling/countersinking |  | ■ |
264 | Thread drilling/milling |  | ■ |
265 | Helical thread drilling/milling |  | ■ |
267 | Outside thread milling |  | ■ |
270 | Contour train data | ■ |  |
275 | Trochoidal slot |  | ■ |
290 | Interpolation turning |  | ■ | INTERPOLATION TURNING (Software Option, Cycle 290, DIN/ISO: G290)


Touch probe cycles

Cycle number | Cycle designation | DEF active | CALL active | Page
0 | Reference plane | ■ |  |
1 | Polar datum | ■ |  |
2 | Calibrate TS radius | ■ |  |
3 | Measuring | ■ |  |
4 | Measuring in 3-D | ■ |  |
9 | Calibrate TS length | ■ |  |
30 | Calibrate the TT | ■ |  |
31 | Measure/Inspect the tool length | ■ |  |
32 | Measure/Inspect the tool radius | ■ |  |
33 | Measure/Inspect the tool length and the tool radius | ■ |  |
400 | Basic rotation using two points | ■ |  |
401 | Basic rotation from two holes | ■ |  |
402 | Basic rotation from two studs | ■ |  |
403 | Compensate misalignment with rotary axis | ■ |  |
404 | Set basic rotation | ■ |  |
405 | Compensate misalignment with the C axis | ■ |  |
408 | Reference point at slot center (FCL 3 function) | ■ |  |
409 | Reference point at ridge center (FCL 3 function) | ■ |  |
410 | Datum from inside of rectangle | ■ |  |
411 | Datum from outside of rectangle | ■ |  |
412 | Datum from inside of circle (hole) | ■ |  |
413 | Datum from outside of circle (stud) | ■ |  |
414 | Datum from outside of corner | ■ |  |
415 | Datum from inside of corner | ■ |  |
416 | Datum from circle center | ■ |  |
417 | Datum in touch probe axis | ■ |  |
418 | Datum at center between four holes | ■ |  |
419 | Datum in any one axis | ■ |  |
420 | Workpiece—measure angle | ■ |  |
421 | Workpiece—measure hole (center and diameter of hole) | ■ |  |
422 | Workpiece—measure circle from outside (diameter of circular stud) | ■ |  |
423 | Workpiece—measure rectangle from inside | ■ |  |
424 | Workpiece—measure rectangle from outside | ■ |  |
425 | Workpiece—measure inside width (slot) | ■ |  |
426 | Workpiece—measure outside width (ridge) | ■ |  |
427 | Workpiece—measure in any selectable axis | ■ |  |
430 | Workpiece—measure bolt hole circle | ■ |  |
431 | Workpiece—measure plane | ■ |  |
440 | Measure axis shift | ■ |  |
441 | Rapid probing: Set global touch probe parameters (FCL 2 function) | ■ |  |
450 | KinematicsOpt: Save kinematics (option) | ■ |  |
451 | KinematicsOpt: Measure kinematics (option) | ■ |  |
452 | KinematicsOpt: Preset compensation (option) | ■ |  |
460 | Calibrate TS: Radius and length calibration on a calibration sphere | ■ |  |
480 | Calibrate the TT | ■ |  |
481 | Measure/Inspect the tool length | ■ |  |
482 | Measure/Inspect the tool radius | ■ |  |
483 | Measure/Inspect the tool length and the tool radius | ■ |  |
484 | Calibrate infrared TT | ■ |  |