FAQs

FAQs, Frequently asked Questions

Stand:
21.08.2006-de-

Copyright © 2006 DR. JOHANNES HEIDENHAIN GmbH. Alle Rechte vorbehalten.


smarT.NC

Weitere Informationen:
> Dateien selektieren
> DXF-Daten
> Verfuegbarkeit smarT.NC


Dateien selektieren

Frage

Gibt es in Funktionen wie PGM CALL oder SEL TABLE eine einfache Moeglichkeit die jeweilige Datei per Ueberblendfenster zu waehlen? Momentan muss der komplette Pfadname eingegeben werden.

Antwort

In der Betriebsart smarT.NC werden Dateien grundsaetzlich auf diese Weise selektiert. Im Klartext-Dialog planen wir fuer die iTNC 530 eine solche Funktion einzufuehren.


DXF-Daten

Frage

Kann die TNC DXF-Daten verarbeiten?

Antwort

Mit der neuen smarT.NC-Software 340 49x-02 ist dies moeglich. Diese Funktion steht als zu erwerbende Software-Option zur Verfuegung. Momentan koennen Sie mit dem DXF-Konverter direkt auf der TNC Konturen selektieren und als Klartext-Dialog-Programm speichern.


Verfuegbarkeit smarT.NC

Frage

Ab wann wird smarT.NC verfuegbar sein?

Antwort

Die ersten Maschinen mit smarT.NC wurden Mitte 2005 ausgeliefert! Genaue Liefertermine erfragen Sie bitte bei Ihrem Maschinenhersteller.
Eine Programmierplatz-Version der smarT.NC-Software steht auf unserer Filebase zum Download bereit (siehe Link weiter unten).


PC-Software

Weitere Informationen:
> TNCremoNT
> TeleService
> Programmierplatz


TNCremoNT

Weitere Informationen:
> Ab welcher NC Software ist TeleService moeglich?
> Datenuebertragung am Programmierplatz
> Kein Zugriff auf TNC mit TNCremo NT
> LSV2 an der iTNC 530
> Problem bei USB-to-COM Adapter
> Screendump vom Programmierplatz
> TNCserver fuer mehrere Schnittstellen konfigurieren
> Verbindungsaufbau mit TNCremoNT dauert sehr lange
> Verwenden von Environment-Variablen mit TNCcmd


Ab welcher NC Software ist TeleService moeglich?

Frage

Ich moechte Maschinen die mit HEIDENHAIN Steuerungen vom Typ TNC 426/430 bzw. iTNC 530 ausgeruestet sind, ueber TeleService von zu Hause aus ueberwachen koennen. Gibt es Einschraenkungen bezueglich der TeleService Faehigkeiten?

Antwort

Sie benoetigen TNC 426/430 Steuerungen mit NC Software 280 476 04 oder neuer (wird angezeigt, wenn Sie die MOD Taste betaetigen).
Alle iTNC 530-Steuerungen sind standardmae�ig fuer den TeleService vorbereitet.
Selbstverstaendlich ist der TeleService erst verfuegbar, wenn Sie die TNC via Netzwerkkarte in Ihr Firmen-Netzwerk integriert haben.


Datenuebertragung am Programmierplatz

Frage

Besteht die Moeglichkeit, die Daten vom Programmierplatz mit TNCremoNT zu uebertragen? Sind hierfuer besondere Einstellungen noetig?

Antwort

Um eine Verbindung zwischen einer HEIDENHAIN PC-Software (z.B.
TNCremo NT oder CycleDesign) und dem Programmierplatz herstellen
zu koennen, besitzt der Programmierplatz eine spezielle IP-Adresse,
die sogenannte loop back-IP. Diese loop back-IP ist 127.0.0.1 und
muss in das enstprechende Konfigurationsmenue der HEIDENHAIN
PC-Software eingetragen werden. Sie koennen dann eine Verbindung
mit dem Programmierplatz erstellen, als ob Sie mit einer Maschine
verbunden waeren.


Kein Zugriff auf TNC mit TNCremo NT

Frage

Beim Versuch mit der Datenuebertragungs-Software TNCremo NT eine Verbindung mit der iTNC 530 herzustellen erscheint die Fehlermeldung
"Kann keine Verbindung aufnehmen". Nach Druecken des Buttons Details erscheint der Text "Fehler 2000171h: Zugangsprivileg nicht erteilt". Was mache ich falsch?

Antwort

Aus Sicherheitsgruenden muessen Sie einen Zugriff von extern auf die TNC erlauben. Gehen Sie dabei wie folgt vor:
> Betriebsart Programm-Einspeichern waehlen
> MOD-Funktion aktivieren: Taste MOD druecken
> Softkey EXTERNER ZUGRIFF auf EIN stellen
Jetzt ist der Zugriff auf die TNC ueber eine externe Datenuebertragungs-Software moeglich.
�brigens gilt diese Vorgehensweise auch fuer den Programmierplatz iTNC, wenn Sie ueber die Loop-Back-IP (127.0.0.1) auf den Programmierplatz zugreifen wollen.


LSV2 an der iTNC 530

Frage

Wir verwenden Fraesmaschinen mit Heidenhain TNC430 und iTNC 530 Steuerung.
Die Steuerungen werden ueber die serielle Schnittstelle von RemoNT mit Programmen versorgt.
Bei der iTNC 530 wird zwar die Baudrate des LSV2 Protokolls angezeigt,
das LSV2 Protokoll selbst kann jedoch nicht ausgewaehlt werden.

Antwort

Die iTNC 530 erkennt automatisch wenn mit LSV2 Protokoll uebertragen wird. Sollte dies nicht funktionieren koennte eine aeltere Software oder eine aeltere Version der TNCremoNT hierfuer verantwortlich sein. Die aktuelle TNCremoNT koennen Sie von unserer Homepage kostenfrei downladen.


Problem bei USB-to-COM Adapter

Frage

Problem bei USB-to-COM Adapter (keine Verbindung)

Antwort

Bei der Verwendung eines USB-to-COM Adapter fuer die Datenuebertragung mit TNCremoNT muss bei den Einstellungen der �bertragungsgeschwindigkeit die Baudrate manuell gleich wie in der Maschine eingestellt werden und der Haken bei "wird bei der Verbindung automatisch ermittelt" entfernt werden, da die Geschwindigkeit des USB-Ports nicht richtig erkannt und automatisch eingestellt wird.


Screendump vom Programmierplatz

Frage

Ich habe versucht einen Screendump mittels TNCremoNT (TNC Bildschirm in die Zwischenablage) von einem iTNC530 Programmierplatz (340494 01) zu erzeugen.
Die erzeugte Bitmap-Datei enthaelt jedoch lediglich einen schwarzen Bildschirm.

Antwort

Um den Screendump korrekt zu erhalten, muessen Sie die Farbtiefe Ihres Rechners auf HighColor (16 Bit) einstellen. Dann funktioniert der Screendump problemlos.


TNCserver fuer mehrere Schnittstellen konfigurieren

Frage

Wie kann ich TNCserver konfigurieren, um mehrere Schnittstellen gleichzeitig zu bedienen?
Ich habe ueber 2 serielle Schnittstellen jeweils eine Steuerung an meinen PC angeschlossen.
Wenn ich den TNCserver zweimal starte, und in der Konfiguration unterschiedliche Werte auswaehle, wird beim naechsten Start von TNCserver immer die Konfiguration vorgelegt, die beim Schlie�en der letzten TNCserver Instanz aktiv war.

Antwort

Um mit mehreren Verbindungen zu arbeiten , richten Sie fuer jede Konfiguration eine eigene Programmverknuepfung auf dem Desktop ein.
Rechts auf Desktop klicken
Im Popup Menue "Neu/Verknuepfung" waehlen
Im Durchsuchen-Dialog TNCserver.exe suchen (ueblicherweise in C:\Programme\HEIDENHAIN\TNCremoNT)
Tragen Sie Aufrufparameter fuer diese Verknuepfung ein:
Programmverknuepfung rechts anklicken
Im Popup Menue "Eigenschaften" waehlen
Im Eigenschaftendialog Register "Verknuepfung" anklicken
In der Textbox "Ziel:" Aufrufparameter nach dem Programmaufruf anfuegen (getrennt mit Leerzeichen!)
Beispiele fuer Aufrufparameter:
-P<x> Schnittstelle (<x>: 1...9)
-B<xxxx> Baudrate (<xxxx>: 1200...115200)
-C<prot> Protokoll (<prot>: FE, ME_SND, ME_RCV, EXT_SND, EXT_RCV, LSV2)
-N<control> Steuerung (<control>: "POSITIP", "CNC PILOT", "MANUAL PLUS", "MILL PLUS", "ND XXX", "TNC 122", "TNC 124", "TNC 131", "TNC 135", "TNC 145", "TNC 150", "TNC 151", "TNC 155", "TNC 223","TNC 232", "TNC 234", "TNC 2500B", "TNC 246", "TNC 306", "TNC 355", "TNC 360", "CONTOUR", "TNC 370", "TNC 310", "TNC 410", "TNC 400", "TNC 406", "TNC 407", "TNC 415", "TNC 416", "TNC 425", "TNC 426", "TNC 430")
Beispiel fuer Ziel:
"C:\Programme\HEIDENHAIN\TNCremoNT 2.0\TNCserver.exe" -P2 -B19200 -CFE "-NTNC 415"
Hinweis: Programmpfad und Parameter, die Leerzeichen enthalten, muessen in Anfuehrungszeichen gesetzt werden


Verbindungsaufbau mit TNCremoNT dauert sehr lange

Frage

Wenn ich TNCremoNT starte und die Verbindung aufbaue, dauert es sehr lange bis ich das Steuerungsverzeichnis sehe. Auch nach einem Verzeichniswechsel wird das neue Verzeichnis erst nach einer langen Verzoegerung angezeigt. Die Verzoegerung betraegt typisch ca. 5 Sekunden.

Antwort

Diese Verzoegerung liegt nicht an Netzwerk oder Verbindungsproblemen, sondern kommt daher, dass beim Lesen versucht wird zu ermitteln, ob auch Diskettenlaufwerke angebunden sind. Diese Suche bricht erst nach einer gewissen Timeout-Zeit ab.
Sie koennen dieses Verhalten aendern lassen, indem der Maschinenparameter 7225 von Ihrem Maschinenhersteller so konfiguriert wird, dass nicht nach Diskettenlaufwerken gesucht wird.


Verwenden von Environment-Variablen mit TNCcmd

Frage

Kann ich mit TNCcmd Environment-Variablen verwenden?

Antwort

Ab Version 3.0 unterstuetzt TNCcmd Environment-Variablen.
Die Environment-Variablen werden ab Version 3.0 sowohl in der Kommandodatei als auch im Dialogmodus und auch bei der �bergabe in der Kommandozeile ausgewertet, wenn das Kommando zusammen mit den Parametern in Anfuehrungszeichen uebergeben wurde.
Beispiel fuer �bergabe in der Kommandozeile:
TNCcmd -i127.0.0.1 "PUT %SOURCEPATH%test.h %TARGETPATH%test.h"


PC-Software

TeleService


Programmierplatz

Weitere Informationen:
> Datenuebertragung am Programmierplatz
> Fehlermeldung Werkzeug-Tabelle? im Programm-Test
> Laufwerke am Programmierplatz
> Programmierplatz: CC-Taste und PGM-Call Taste nicht verfuegbar
> Programmierplatz iTNC 530
> Programmierplatz ohne Werkzeugtabelle
> Programmierplatz startet nicht
> Programmierplatz: Mousepad an der Tastatur funktioniert nicht richtig
> Programmierplatz: Trotz TNC-Tastatur Shareware Hinweis
> Programmierplatz: Zyklenstruktur TNC 426
> Softkeyleiste weiterschalten am Programmierplatz
> USB-Treiber fuer Programmierplatz laeuft nicht


Fehlermeldung Werkzeug-Tabelle? im Programm-Test

Frage

Im PGM-Test wird der Fehler "Werkzeug-Tabelle ?" beim Testen eines Programmes angezeigt.

Antwort

Vermutlich ist keine Werkzeug-Tabelle im PGM-Test aktiv.
Werkzeug-Tabelle im Programm-Test aktivieren:
> Betriebsart Programm-Test waehlen
> Datei-Verwaltung aufrufen (PGM-MGT)
> Wahl der Datei-Typen anzeigen: Softkey TYPE WAEHLEN druecken
> Dateien vom Typ .T anzeigen: Softkey ZEIGE .T druecken
> Waehlen Sie die Datei ( .T) mit der Taste ENT oder mit dem Softkey WAEHLEN
Die TNC kennzeichnet eine fuer den Programm-Test aktive Werkzeug-Tabelle in der Spalte STATUS mit einem "S".


Laufwerke am Programmierplatz

Frage

Im PGM MGT (Programmierplatz) werden alle Laufwerke angezeigt. Ist es moeglich bestimmte Laufwerke auszusperren?

Antwort

Über den Maschinen-Parameter 7225 koennen Sie Laufwerksbuchstaben definieren, die nicht in der Datei-Verwaltung der TNC angezeigt werden sollen.


Programmierplatz: CC-Taste und PGM-Call Taste nicht verfuegbar

Frage

Problem mit Programmierplatz iTnc530: CC-Taste und PGM-Call Taste nicht verfuegbar

Antwort

Das Problem ergibt sich aus einer �berschneidung der Shortcut-Tastenbelegung des Programmierplatzes und der OnBoard-Grafikkarte "Intel� Extreme Graphics 2" im PC.
Durch die folgende Vorgehensweise koennen Sie dieses Problem beheben:
> Systemsteuerung
> Intel Extreme Graphics waehlen
> Reiter Abkuerzungstasten waehlen
> Abkuerzungstasten deaktivieren
Es koennen auch von anderen Anwendungen Shortcut-Tasten aktiv sein, die den gleichen Fehler verursachen.


Programmierplatz iTNC 530

Frage

Bei mir startet der Programmierplatz nach der Installation nicht. Ich benutze einen PC mit Win XP und SP2.

Antwort

Wurde bei der Installation von Windows XP mit SP2 die Firewall aktiviert, koennen Probleme beim Starten des Programmierplatzes auftreten.
Um dies zu umgehen, koennen Sie die Firewall ganz ausschalten oder manuell den Port 6000 (Zugriff Programmierplatz) freischalten. Dieses Vorgehen ist auch bei anderen Firewalls wie z.B. ZoneAlarm noetig.


Programmierplatz ohne Werkzeugtabelle

Frage

Meine Maschine arbeitet ohne Werkzeug-Tabelle (ohne Wechsler). Kann ich am Programmierplatz iTNC auch im NC-Programm die Werkzeug-Definition ueber TOOL DEF programmieren?

Antwort

Ja, einen TOOL DEF-Satz koennen Sie auf dem Programmierplatz iTNC auch dann programmieren, wenn dort die Werkzeug-Tabelle aktiv ist. Beim Testen des Programmes gibt der Programmierplatz in diesem Fall jedoch eine Fehlermeldung aus.
Wenn Sie grundsaetzlich ohne Werkzeug-Tabelle arbeiten wollen, dann gehen Sie wie folgt vor:
> In der Betriebsart Einspeichern/Editieren Taste MOD druecken
> Schluesselzahl 123 eingeben, mit Taste ENT bestaetigen
> MP7224.0 anwaehlen
> %00000100 eingeben
> MP7260 anwaehlen
> 0 eingeben (Anzahl Werkzeuge in der Tabelle)
Die Werkzeug-Tabelle ist dann inaktiv und alle Werkzeug-Definitionen muessen dann im Programm ueber die Funktion TOOL DEF erfolgen.
Umgekehrt ist es natuerlich auch moeglich an Ihrer Maschine den zentralen Werkzeugspeicher zu aktivieren und alle Werkzeuge dort zu verwalten, auch wenn die Maschine keinen automatischen Wechsler besitzt..


Programmierplatz startet nicht

Frage

Programmierplatz auf Computer Intel Celeron 128MB - RAM , Windows 98 SE
Beim Ausfuehren des Programmes tritt ein Fehler auf. Das Programm oeffnet mit "STARTING"------PLEASE WAIT......" startet aber nicht.

Antwort

Die Programmierplatz-Software ist auf folgenden PC�s lauffaehig:
&#56256;&#56452; Standard-PC mit Windows 2000 oder Windows XP
&#56256;&#56452; USB-Schnittstelle
&#56256;&#56452; Mindestens 128 MByte RAM
&#56256;&#56452; Grafikkarte: Farbtiefe mindestens 16 bit
&#56256;&#56452; Mindestens 350 MByte Speicherplatz auf der Festplatte
&#56256;&#56452; Mindestens 15-Zoll-XGA-Bildschirm


Programmierplatz: Mousepad an der Tastatur funktioniert nicht richtig

Frage

Das Mousepad an der TNC-Tastatur hat keine Doppelklick-Funktion wie z.B. beim Laptop

Antwort

Sie muessen einen Windows-Treiber installieren. Er befindet sich auf der CD "Programmierplatz-Programming Station iTNC" im Verzeichnis: \JH\EasyCat2.0.exe


Programmierplatz: Trotz TNC-Tastatur Shareware Hinweis

Frage

Obwohl die Vollversion gekauft und die Heidenhain TNC-Tastatur an den USB des PC angesteckt ist, kommt immer noch der Sharewarehinweis

Antwort

Sie muessen den Windows-Treiber fuer den USB-Dongle installieren. Er befindet sich auf der CD "Programmierplatz-Programming Station iTNC" im Verzeichnis:
\JH\hldrv32.exe


Programmierplatz: Zyklenstruktur TNC 426

Frage

Wir haben im Betrieb 4 Maschinen mit der TNC 426.
Koennen wir unseren neuen Programmierplatz (iTNC530) auf die TNC 426 umstellen?

Antwort

Sie koennen die Zyklenstruktur auch auf TNC 426 oder TNC 410 umzustellen. Hierzu muessen Sie folgende Einstellungen vornehmen:
1.Betriebsart Programm-Einspeichern/Editieren
2.MOD
3.Schluesselzahl 123
4.ENT Taste
5.MOD
6.Softkey CYCL
7. Gewuenschte Steuerung auswaehlen. (Mit Taste "ENT" werden die Steuerungen angezeigt)
8. Mit 2x END abschliessen.


Softkeyleiste weiterschalten am Programmierplatz

Frage

Wie kann ich beim Programmierplatz iTNC 530 mit virtueller Tastatur die Softkeyleiste weiterschalten? Auf der virtuellen Tastatur fehlt die normalerweise am TNC-Bildschirm vorhandene Softkey-Umschalttaste.

Antwort

Die Softkeyleiste laesst sich per Mouseklick umschalten. Einfach auf einen der kleinen Balken klicken, die direkt ueber den Softkeys angezeigt werden. Diese Balken zeigen die Anzahl der verfuegbaren Softkeyleisten an.


USB-Treiber fuer Programmierplatz laeuft nicht

Frage

Auf meinem Rechner laesst sich der USB-Treiber fuer den Programmierplatz nicht installieren. auf einem anderen Rechner laeuft er ohne Probleme

Antwort

Auf einem PC mit AMD 64bit CPU kann der Treiber der sich auf unserer Homepage oder den Software-CDs befindet nicht installiert werden. Der Hersteller der Hardwaredongle hat unter www.aladdin.com einen neuen Treiber (hldinst.zip) zum Download. Nach entpacken muessen Sie in der Commandozeile den Befehl "hldinst -install" eingeben.
Wir sind bemueht so bald als moeglich eine komfortable Windows-Installation zum Download und auf den CDs zur Verfuegung zu stellen.


Programmieren

Weitere Informationen:
> Konturen
> Q-Parameter
> Unterprogr. / Wiederholungen
> M-Funktionen
> Werkzeuge


Konturen

Weitere Informationen:
> DXF-Daten


Q-Parameter

Weitere Informationen:
> Daten aus der Steuerung am PC weiterbearbeiten
> Q-Parameter Belegung
> Zaehler fuer Werkstuecke


Daten aus der Steuerung am PC weiterbearbeiten

Frage

Ist es moeglich, Daten aus frei definierbaren Tabellen am PC weiter zu bearbeiten?

Antwort

In der Anlage finden Sie eine Beschreibung, um Daten aus einer frei definierbaren Tabelle in Excel zu uebernehmen.


Q-Parameter Belegung

Frage

Welche Parameternummern kann ich fuer meine Programme verwenden?
Waere es moeglich mehr als 100 Parameter zu verwenden?

Antwort

Welche Nummern Sie verwenden koennen sehen Sie in der Liste Parameterbelegung.pdf.
Ab der NC-Software 340490 01 koennen die Parameter Q0 - Q1999 verwendet werden. (siehe Parameterbelegung.pdf)


Zaehler fuer Werkstuecke

Frage

Wie kann ich einen Zaehler programmieren, der auch nach dem Ausschalten der Maschine noch aktuell ist?

Antwort

Dies ist mit einer frei definierbaren Tabelle moeglich. Eine genaue Beschreibung hiezu finden Sie in der Anlage.


Unterprogr. / Wiederholungen

Weitere Informationen:
> Dateien selektieren
> Programmteilwiederholungen


Dateien selektieren

Frage

Gibt es in Funktionen wie PGM CALL oder SEL TABLE eine einfache Moeglichkeit die jeweilige Datei per �berblendfenster zu waehlen? Momentan muss der komplette Pfadname eingegeben werden.

Antwort

In der Betriebsart smarT.NC werden Dateien grundsaetzlich auf diese Weise selektiert. Im Klartext-Dialog planen wir fuer die iTNC 530 eine solche Funktion einzufuehren.


Programmteilwiederholungen

Frage

Bei der TNC 426 konnten wir genau sehen wieviele Programmteil-Wiederholungen bereits abgearbeitet waren (z.B. Call LBL 1 REP 4/4).
Kann die iTNC 530 auch die Anzahl der Wiederholungen angezeigen?

Antwort

Selbstverstaendlich ist dies auch bei der iTNC 530 moeglich. Zur Anzeige der bereits abgearbeiteten Wiederholungen, steht Ihnen nun eine eigene Status-Anzeige zur verfuegung.
Hierzu waehlen Sie die Bildschirmaufteilung PGM + Status. In der Anzeige Status CALL LBL (Softkey) werden die Informationen zur Programmteil-Wiederholung angezeigt.


M-Funktionen

Weitere Informationen:
> Automatisches Abschalten der Maschine am Programm Ende.


Automatisches Abschalten der Maschine am Programm Ende.

Frage

Kann ich die Maschine in einer "Geisterschicht", also bei mannlosem Betrieb am Programm Ende ueber eine Steuerungsfunktion (z.B. M-Funktion) automatisch abschalten lassen? Gemeint ist das Abschalten aller Aggregate mit anschlie�endem Herunterfahren der Steuerung, so wie dies beim Abschalten ueber den Maschinenhauptschalter durchgefuehrt wird.

Antwort

Prinzipiell steht diese Funktionalitaet zur Verfuegung, sie muss jedoch ueber das PLC-Programm von Ihrem Maschinenhersteller realisiert werden. Setzen Sie sich mit Ihrem Maschinenhersteller in Verbindung, wenn Sie die Funktion benoetigen.


Werkzeuge

Weitere Informationen:
> Istwert - Übernahme
> Programmierplatz ohne Werkzeugtabelle


Istwert - Übernahme

Frage

Wir muessen viele Teile nach Anriss fraesen.
Waere es moeglich die angefahrenen Positionen in ein Programm zu uebernehmen?

Antwort

Fuer diese Anwendung koennen Sie die Funktion "Ist-Position-Übernahme" verwenden. Anbei finden Sie eine Beschreibung zu dieser Funktion und einen Link zum Benutzerhandbuch (siehe Kapitel 13.13).


Bearbeitungsebene Schwenken

Weitere Informationen:
> Geschwindigkeit der Testgrafik.


Geschwindigkeit der Testgrafik.

Frage

Die Testgrafik der iTNC 530 mit Software 340 422 ist im Vergleich zur TNC 430 wesentlich langsamer. Wie kann die Geschwindigkeit erhoeht werden?

Antwort

In neueren Softwarestaenden der iTNC 530 wurde die Moeglichkeit geschaffen Programme so grafisch zu simulieren, das auch Schwenkbearbeitungen und Mehrachsbearbeitungen richtig dargestellt werden. Bei diesem Simulationsmodell muss die komplette Maschinenkinematik von der iTNC beim Programm-Test mit verrechnet werden, wodurch verstaendlicherweise die Testzeit ansteigt.
Durch Setzen des Maschinen-Parameters 7310=1 koennen Sie das Simulationsmodell so umstellen, dass intern das schnellere alte Verfahren verwendet wird. Schwenkbearbeitungen und Mehrachsbearbeitungen werden dann jedoch nicht mehr korrekt dargestellt.


Tastsystem-Zyklen

Weitere Informationen:
> Grunddrehung / Schieflage
> Autom. Bezugspunkt setzen
> Messen
> Tastsystem kalibrieren
> Werkzeugvermessung
> Manuelle Tastsystem-Zyklen


Grunddrehung / Schieflage


Autom. Bezugspunkt setzen


Messen

Weitere Informationen:
> Messprotokoll auf einem Netzlaufwerk speichern


Messprotokoll auf einem Netzlaufwerk speichern

Frage

Besteht die Moeglichkeit, ein Messzyklenprotokoll (Tastsystem-Zyklen 420 bis 431) auch auf einem Netzwerk-Laufwerk zu speichern.

Antwort

Standardmaeßig speichert die TNC das Messprotokoll in dem Verzeichnis der TNC-Festplatte, von dem aus der Messzyklus aufgerufen bzw. abgearbeitet wird. Sie koennen jedoch in der MOD-Funktion zum Einrichten der Schnittstelle einen beliebigen Pfad angeben, in dem die TNC dann das Messprotokoll ablegt.
Voraussetzungen:
- Sie haben Schreibrechte auf diesem Netzlaufwerk bzw. Verzeichnis
- Das Netzlaufwerk ist zum Zeitpunkt des Zyklus-Aufrufes angebunden
- Sie haben den Pfad unter
>MOD>RS232 EINRICHT.>PRINT
richtig eingetragen


Tastsystem kalibrieren

Weitere Informationen:
> Kalibrierdaten 3D-Tastsystem
> TT Kalibrieren


Kalibrierdaten 3D-Tastsystem

Frage

Bei meiner iTNC 530 mit NC-Software 340 49x fehlt der Softkey zur �bernahme der 3D-Tastsystem-Kalibrierdaten in die Werkzeug-Tabelle.

Antwort

Sofern Sie den Maschinen-Parameter MP7411 auf 1 gesetzt haben, also Kalibrierdaten in der Werkzeug-Tabelle verwaltet werden sollen, schreibt die TNC die ermittelten Kalibrierwerte automatisch in die Werkzeug-Tabelle. Das Speichern ueber die Softkeys ist nicht mehr erforderlich, da die TNC die Daten jetzt automatisch der aktiven Werkzeug-Nummer zuordnet.


TT Kalibrieren

Frage

Warum trift die Steuerung beim Kalibrieren des Tischtasters den Stylus nicht?

Antwort

Vor dem Kalibrieren des TT muessen die Koordinaten des Stylus-Mittelpunktes bezogen auf den Maschinennullpunkt (REF-Koordinaten) in den MP 6580 eingetragen werden. Die REF-Koordinaten werden aber immer ohne Werkzeuglaenge ausgegeben.
Loesung: Werkzeuglaenge verrechnen, oder Z-Koordinate ohne Werkzeug ermitteln.


Werkzeugvermessung

Weitere Informationen:
> TT Kalibrieren


Manuelle Tastsystem-Zyklen


Datenschnittstelle

Weitere Informationen:
> Ab welcher NC Software ist TeleService moeglich?
> Bei CimcoNFS startet der Portmapper nicht.
> CimcoNFS an WIN XP SP2 mit Firewall
> Datenuebertragung TNC-Server auf TNC155
> Drucker an TNC
> Ethernet: SMB-Anbindung an Windows 2003 Server
> Kabel von Maschine 25 pol. Stecker auf PC 9 pol. Buchse
> Kein Zugriff auf TNC mit TNCremo NT
> LSV2 an der iTNC 530
> MAC-Adresse einer iTNC 530
> Messprotokoll auf einem Netzlaufwerk speichern
> Problem bei USB-to-COM Adapter
> Redistribution der HeidenhainDNC COM-Komponente
> TNCremoNT-Patch3 installieren, wie und warum?


Ab welcher NC Software ist TeleService moeglich?

Frage

Ich moechte Maschinen die mit HEIDENHAIN Steuerungen vom Typ TNC 426/430 bzw. iTNC 530 ausgeruestet sind, ueber TeleService von zu Hause aus ueberwachen koennen. Gibt es Einschraenkungen bezueglich der TeleService Faehigkeiten?

Antwort

Sie benoetigen TNC 426/430 Steuerungen mit NC Software 280 476 04 oder neuer (wird angezeigt, wenn Sie die MOD Taste betaetigen).
Alle iTNC 530-Steuerungen sind standardmaeßig fuer den TeleService vorbereitet.
Selbstverstaendlich ist der TeleService erst verfuegbar, wenn Sie die TNC via Netzwerkkarte in Ihr Firmen-Netzwerk integriert haben.


Bei CimcoNFS startet der Portmapper nicht.

Frage

Auf unserem Windows-Server startet CimcoNFS nach der Installation mit dem Fehler "1067-Portmapper startet nicht".

Antwort

Wenn eine andere Software wie z.B. ARCserv (Backup-Software) ebenfalls den Port 111 verwendet, kann dies zu der genannten Fehlermeldung fuehren. Achten Sie darauf, dass zuerst diese Software gestartet wird und dann erst CimcoNFS. Dann sollte der Fehler nicht mehr auftreten.


CimcoNFS an WIN XP SP2 mit Firewall

Frage

Die Datenuebertragung mit Cimco an o.g. Betriebssystem funktioniert nur bei kpl. ausgeschalteter Firewall.
Gibt es eine Loesung ?

Antwort

Das Problem liegt an der Konfiguration der Firewall nicht am Cimco NFS-Server.
Konfiguration der MS-Firewall (Windows XP + SP2):
Windows-Firewall starten ueber Systemsteuerung (wcsui.cpl oder firewall.cpl).
Im Register Ausnahmen ueber >Programm >Durchsuchen jeweils die Dateien (Dienste) portmap.exe und nfs.exe (Default-Verzeichnis C:\CIMCO\NFS\) >Öffnen und mit >OK hinzufuegen. Diese beiden Eintraege werden dann aktiviert (mit Haekchen) unter Programme und Dienste gelistet. Über >Bearbeiten >Bereich aendern kann man noch die Option >Nur fuer eigenes Netzwerk (Subnetz)] oder ueber >benutzerdefinierte Liste den Zugriff einschraenken.


Datenuebertragung TNC-Server auf TNC155

Frage

Mit dem aktuellen TNC-Server 2.4.044 und einer Baud-Rate von 2400 bricht die Datenuebertragung zu einer TNC155 ab.

Antwort

Die eingestellte Baud-Rate sollte beim TNC-Server und der TNC155 einen Wert von 9600 nicht unterschreiten.


Drucker an TNC

Frage

Im Handbuch steht beschrieben, dass man mit der Funktion FN16 Daten ueber die Schnittstelle RS232 direkt an einen Drucker ausgeben kann. Leider ist nicht beschrieben mit welchem Drucker dies funktioniert und was man fuer Kabel benoetigt. Ich habe schon einen Nadeldrucker und einen Tintenstrahldrucker von HP versucht und immer kommt die Meldung
"EXT. Daten Ein/Ausgabe nicht bereit". Ich hatte es am Bedientpult und auch im Schaltschrank (X21) versucht aber immer mit dem gleichen Ergebnis.

Antwort

Wenn Sie einen Drucker ueber die RS 232 betreiben wollen, muessen Sie einen seriellen Drucker verwenden. Mittlerweile sind diese Geraete aber ziemlich selten geworden. Zum Anschließen des
Druckers sollten Sie ein serielles Schnittstellenkabel verwenden (ID-Nr.274545).
Eine weitere Moeglichkeit waere, wenn Ihre Steuerung mit einer Ethernet-Karte bestueckt ist, einen Netzwerkdrucker zu verwenden. Ein normaler Drucker kann nicht verwendet werden, da auf der Steuerung keine Druckertreiber installiert werden koennen.


Ethernet: SMB-Anbindung an Windows 2003 Server

Frage

Wie kann ich ich eine TNC per SMB an einen Windows 2003 Server anbinden?

Antwort

Bei einer Standard-Installation des Windows 2003 Servers ist das sogenannte SMB-Signing als Grundeinstellung aktiviert. Fruehere Software-Versionen der iTNC benutzten eine aeltere Variante des SMB-Protokolls, in der noch kein SMB-Signing moeglich war. Diese aelteren Softwarestaende arbeiten daher auch - in der Regel - mit Windows 2003 Server zusammen, eine Gewaehr hierfuer koennen wir jedoch nicht uebernehmen. Da diese aeltere Protokoll-Variante zudem fehlerbehaftet war, wurde die Umstellung der iTNC auf eine neuere Protokoll-Variante noetig. Leider hat Microsoft das SMB-Signing mit Windows 2003 Server eingefuehrt ohne Ruecksicht auf (None-Microsoft-)Geraete, die dieses Verfahren nicht unterstuetzen.
Um die TNC dennoch an einen Windows 2003 Server anbinden zu koennen, stehen zwei Moeglichkeiten zur Verfuegung:
1. Sie deaktivieren SMB-Signing am Server. Gehen Sie dabei wie folgt vor:
> Group Policy
> Computer Configuration
> Windows Settings
> Security Settings
> SMB-Signing deaktivieren
2. Sie nehmen einen Linux-Rechner mit Samba in Betrieb, der die fuer die iTNC relevanten Verzeichnisse ueber Netzwerk (mit SMB-Singning) anbindet und wiederum als SMB share (ohne SMB- Signing) freigibt. Dann waere das SMB-Signing nur fuer die von der iTNC benoetigten Verzeichnisse deaktiviert.


Kabel von Maschine 25 pol. Stecker auf PC 9 pol. Buchse

Frage

Meine Maschine hat einen 25 pol. Buchse fuer RS232, mein PC aber nur einen 9 pol. Stecker, gibt es ein passendes Kabel dafuer ?

Antwort

Hierfuer benoetigen Sie ein Kabel vom Adapterblock-Maschine (25 pol. Sub-D Stecker) zum PC (9 pol. Sub-D Buchse).
Das Kabel koennen Sie bei Heidenhain in verschiedenen Laengen bestellt werden.
Ident Nr. 368017 - xx


Kein Zugriff auf TNC mit TNCremo NT

Frage

Beim Versuch mit der Datenuebertragungs-Software TNCremo NT eine Verbindung mit der iTNC 530 herzustellen erscheint die Fehlermeldung
"Kann keine Verbindung aufnehmen". Nach Druecken des Buttons Details erscheint der Text "Fehler 2000171h: Zugangsprivileg nicht erteilt". Was mache ich falsch?

Antwort

Aus Sicherheitsgruenden muessen Sie einen Zugriff von extern auf die TNC erlauben. Gehen Sie dabei wie folgt vor:
> Betriebsart Programm-Einspeichern waehlen
> MOD-Funktion aktivieren: Taste MOD druecken
> Softkey EXTERNER ZUGRIFF auf EIN stellen
Jetzt ist der Zugriff auf die TNC ueber eine externe Datenuebertragungs-Software moeglich.
Übrigens gilt diese Vorgehensweise auch fuer den Programmierplatz iTNC, wenn Sie ueber die Loop-Back-IP (127.0.0.1) auf den Programmierplatz zugreifen wollen.


MAC-Adresse einer iTNC 530

Frage

Wie kann ich die MAC-Adresse einer iTNC 530 sehen?

Antwort

Das ist nur vom PC aus moeglich. In der Eingabeaufforderung senden Sie zuerst einen Ping zur Steuerung (z.B. ping 168.1.180.4).
Anschließend geben Sie "arp -a" ein.
Hinter der IP-Adresse wird nun die MAC-Adresse der iTNC dargestellt.
z.B.: 168.1.180.4 00-a0-cd-01-0b-3d dynamisch


Problem bei USB-to-COM Adapter

Frage

Problem bei USB-to-COM Adapter (keine Verbindung)

Antwort

Bei der Verwendung eines USB-to-COM Adapter fuer die Datenuebertragung mit TNCremoNT muss bei den Einstellungen der Übertragungsgeschwindigkeit die Baudrate manuell gleich wie in der Maschine eingestellt werden und der Haken bei "wird bei der Verbindung automatisch ermittelt" entfernt werden, da die Geschwindigkeit des USB-Ports nicht richtig erkannt und automatisch eingestellt wird.


Redistribution der HeidenhainDNC COM-Komponente

Frage

Wie wird die HeidenhainDNC COM-Komponente des RemoTools SDK auf einem Zielsystem installiert?

Antwort

Bei der Installation des RemoTools SDK wird die Softwarekomponente, die aus mehreren Dateien besteht,
auf den Entwicklungsrechner installiert (kopiert und registriert).
Um auf einem Zielsystem die COM-Komponente zu installieren stehen 3 Moeglichkeiten zur Verfuegung:
Separat installieren
Auf der Heidenhain FileBase steht ein Installationspaket (.msi Datei) mit den aktuellsten Versionen der HeidenhainDNC Komponentendateien zur Verfuegung, das mit dem Microsoft Installer installiert werden kann.
Der Microsoft Installer ist ab Windows 2000 Bestandteil des Betriebssystems.
In eine eigene Installation aufnehmen
Im RemoTools SDK Ordner finden Sie einen Unterordner MergeModules, der .msm-Dateien enthaelt.
Diese Dateien, die auch Informationen ueber Versionen und Abhaengigkeiten enthalten, koennen Sie in Ihre Installation mit aufnehmen, sofern Ihr Installationstool .msm Dateien (Microsoft merge modules) unterstuetzt.
Zum Beispiel koennen Sie dazu die Produkte der Firma InstallShield verwenden.
Manuell installieren
Sie koennen auch die Komponentendateien, die Sie nach der RemoTools SDK Installation im Ordner \Programme\Gemeinsame Dateien\Heidenhain shared finden, auf das Zielsystem kopieren und mit der Kommandozeilenanwendung regsvr32.exe manuell registrieren.
Die Anwendung regsvr32.exe ist Bestandteil des Windows Betriebssystems.


TNCremoNT-Patch3 installieren, wie und warum?

Frage

Wie wirt das Patch3 von TNCremoNT installiert und wozu brauche ich es?

Antwort

Die .ZIP-Datei in ein Verzeichnis auf der Festplatte entpacken (z.B. mit WinZip oder WinRar ect.) und von dort alle .exe-Dateien in das Installationsverzeichnis von TNCremoNT kopieren
(meist ist das C:\Programme\Heidenhain\TNCremoNT\ )
und dann noch die Datei lsv2ctrl_2.ocx ins Windows-System32-Verzeichnis kopieren.
(z.B. C:\WINNT\system32\ , bei WIN9x: z.B. C:\WIN\system\)
Die Version von TNCremoNT ist dann 2.3.257
Das Patch3 erweitert bei der seriellen Dateiuebertragung (V24) das Übertragen ganzer Ordner und großer Programme bei aelteren Steuerungen


Preset-Tabelle / Bezugspunkte

Weitere Informationen:
>


Preset-Tabelle / Bezugspunkte


Koordinaten-Umrechnung

Weitere Informationen:
>


Koordinaten-Umrechnung


Bearbeitungszyklen

Weitere Informationen:
> Bohren / Gewinde
> Fraesen
> Punktemuster
> SL-Zyklen


Bohren / Gewinde

Weitere Informationen:
> An meiner TNC426 steht der Zyklus 202 nicht zur Verfuegung!
> Ensat-Buchsen eindrehen
> Helix-Gewindefraesen
> Vorschub beim Gewindefraesen


An meiner TNC426 steht der Zyklus 202 nicht zur Verfuegung!

Frage

An meiner TNC426 ist der Softkey zur Definition des Zyklus 202 Ausdrehen leer. Im Benutzer-Handbuch steht: Maschine und TNC muessen vom Maschinenhersteller vorbereitet sein.

Antwort

Die Zyklen 17, 18, 202, 204 und 217 benoetigen eine geregelte Spindel. Wenn Ihre Maschine nicht mit dieser Funktion ausgeruestet ist, blendet die TNC die Zyklen automatisch aus und die Softkeys sind leer.


Ensat-Buchsen eindrehen

Frage

Wie kann ich mit einer TNC Ensat-Buchsen eindrehen? Beim Eindrehen muss eine andere Steigung als beim Ausschrauben verwendet werden!

Antwort

Zyklus 18 GEWINDESCHNEIDEN faehrt das Werkzeug mit geregelter
Spindel von der aktuellen Position auf die eingegebene Tiefe. Am Bohrungsgrund erfolgt ein Spindel-Stop. Das Werkzeug kann nun mit einer zweiten Zyklus-Definition (mit anderer Steigung) wieder herausgefahren werden.


Helix-Gewindefraesen

Frage

Das Veraendern der Gewindetiefe fuehrt dazu, dass das Werkzeug beim zweiten Schnitt nicht mehr denselben Gang fraest, sondern versetzt faehrt. Kann man diese Verhalten beeinflussen?

Antwort

Im Prinzip nicht. Die Software berechnet den Startpunkt ausgehend von der Gewindetiefe so, dass das Gewinde mit einer ganzzahligen Anzahl von Umdrehungen gefraest wird. In denselben Gewindegang kommen Sie nur dann, wenn Sie die Tiefe in ganzzahligen Vielfachen der Steigung veraendern. Ansonsten variiert der Startpunkt immer.


Vorschub beim Gewindefraesen

Frage

In der Anzeige erscheint ein kleinerer Vorschub als programmiert wurde!

Antwort

Der angezeigte Vorschub bezieht sich grundsaetzlich immer auf die Fraeser-Mittelpunktsbahn. Beim Gewindefraesen (Kreisbewegung) ist der programmierte Vorschub an der Werkzeugschneide wirksam, der angezeigte Vorschub der Fraeser-Mittelpunktsbahn also in Abhaengigkeit vom Werkzeug-Radius entsprechend kleiner!


Fraesen

Weitere Informationen:
> Helix-Gewindefraesen
> Vorschub beim Gewindefraesen


Punktemuster

Weitere Informationen:
> Punktemuster


Punktemuster

Frage

Warum wird beim Zyklus Punktemuster auf Kreis die letzte Bearbeitung doppelt ausgefuehrt?

Antwort

Die Zyklen 220 / 221 (Punkemuster auf Kreis / Linien) sind DEF-Aktiv, das bedeutet die Zyklen sind sofort nach ihrer Definition wirksam und brauchen keinen gesonderten Zyklus-Aufruf (z.B. M99). Die Zyklen zum Herstellen von Punktemustern arbeiten den zuletzt definierten Bearbeitungszyklus, automatisch auf den jeweiligen Positionen ab. In der Anlage finden Sie ein entsprechendes Beispiel.
Wird nach einem Punktemuster-Zyklus ein Zyklus-Aufruf programmiert, wird der Bearbeitungs-Zyklus auf der letzten Position noch einmal abgearbeitet. (Zyklus-Aufruf entfernen!)
.


SL-Zyklen

Weitere Informationen:
> Schlichten mit Zyklus 24


Schlichten mit Zyklus 24

Frage

Ich moechte eine Kontur nur mit dem Zyklus 24 (DIN/ISO: G124) schlichten, ohne vorher mit Zyklus 22 (DIN/ISO: G122) ausgeraeumt zu haben.

Antwort

In diesem Fall muessen Sie das Schlichtaufmaß Q3 im Zyklus 20 (DIN/ISO: G120) groeßer als die Summe des im Zyklus 24 (DIN/ISO: G124) definierten Schlicht-Aufmaßes Q14 und des Schlichtwerkzeug-Radius eingeben.


Extern erstellte Programme

Weitere Informationen:
> 5-Achs Bearbeitung
> TCPM / M128
> HSC


5-Achs Bearbeitung

Weitere Informationen:
>


<>
Extern erstellte Programme / 5-Achs Bearbeitung


TCPM / M128

Weitere Informationen:
>


<>
Extern erstellte Programme / TCPM / M128


Extern erstellte Programme

HSC

Weitere Informationen:
>


<>
Extern erstellte Programme / HSC


Werkzeuge

Weitere Informationen:
> Ersetzen einzelner Zeilen in der Werkzeugtabelle
> In der Werkzeug-Tabelle kann man den Typ nicht waehlen.
> Programmierplatz ohne Werkzeugtabelle


Ersetzen einzelner Zeilen in der Werkzeugtabelle

Frage

In der Werkzeugtabelle sollen nur einzelne Zeilen durch neue Werte ersetzt werden. Die neuen Daten erzeugt ein Werkzeugvoreinstellgeraet.

Antwort

Wenn Sie eine beliebige Werkzeug-Tabelle in die Tool.T kopieren, koennen Sie mit dem Softkey FELDER ERSETZEN einzelne Zeilen oder Spalten in der Ziel-Tabelle ueberschreiben.
Voraussetzungen:
- die Ziel-Tabelle muss bereits existieren
- die zu kopierende Datei darf nur die zu ersetzenden Spalten oder
Zeilen enthalten
Achtung!
Der Softkey FELDER ERSETZEN erscheint nicht, wenn Sie
von extern mit einer Datenuebertragungssoftware z. B.
TNCremoNT die Tabelle in der TNC ueberschreiben wollen.
Kopieren Sie die extern erstellte Datei in ein anderes Verzeichnis
und fuehren Sie anschließend den Kopiervorgang
mit der Dateiverwaltung der TNC aus.
Beispiel:
Sie haben auf einem Voreinstellgeraet die Werkzeug-Laenge und den
Werkzeug-Radius von 10 neuen Werkzeugen vermessen. Anschlie�end
erzeugt das Voreinstellgeraet die Werkzeug-Tabelle TOOL.T mit
10 Zeilen (sprich 10 Werkzeugen) und den Spalten
- Werkzeug-Nummer (Spalte T)
- Werkzeug-Laenge (Spalte L)
- Werkzeug-Radius (Spalte R)
Kopieren Sie diese Datei in ein anderes Verzeichnis, als die vorhandene
TOOL.T steht. Wenn Sie diese Datei mit der Dateiverwaltung der TNC ueber die bestehende Tabelle kopieren, fragt die TNC, ob die bestehende Werkzeug-Tabelle TOOL.T ueberschrieben werden soll:
> Druecken Sie den Softkey JA, dann ueberschreibt die TNC die aktuelle
Datei TOOL.T vollstaendig. Nach dem Kopiervorgang besteht TOOL.T also aus 10 Zeilen. Alle Spalten natuerlich außer den Spalten
Nummer, Laenge und Radius werden zurueckgesetzt
> Oder druecken Sie den Softkey FELDER ERSETZEN, dann ueberschreibt
die TNC in der Datei TOOL.T nur die Spalten Nummer, Laenge und Radius der ersten 10 Zeilen. Die Daten der restlichen Zeilen
und Spalten werden von der TNC nicht veraendert
> Oder druecken Sie den Softkey LEERZEILEN ERSETZEN, dann ueberschreibt die TNC in der Datei TOOL.T nur die Zeilen, in denen keine
Daten eingetragen sind. Die Daten der restlichen Zeilen und Spalten
werden von der TNC nicht veraendert.


In der Werkzeug-Tabelle kann man den Typ nicht waehlen.

Frage

In der Werkzeug-Tabelle kann man den Werkzeug-Typ nicht waehlen.

Antwort

Mit der Funktion COPY SAMPLE FILE werden mehrere Dateien aus der SYS-Partition in das Verzeichnis "Proto" kopiert. Unter anderem eine Tabelle in der die Werkzeug-Typen abgelegt sind. Danach sollte der Werkzeug-Typ waehlbar sein.
Wenden Sie sich hierzu an Ihren Maschinen-Hersteller!


Datei-Verwaltung

Weitere Informationen:
> Anzahl speicherbarer Dateien
> Dateien nicht alphabetisch sortiert
> Dateien selektieren
> Ersetzen einzelner Zeilen in der Werkzeugtabelle
> Wandeln von ISO in Klartext und zurueck


Anzahl speicherbarer Dateien

Frage

Wie viele Dateien kann ich auf der iTNC 530 speichern

Antwort

Die Anzahl der Dateien ist nur durch die Groeße der TNC-Festplatte begrenzt. Die Groeße der Festplatte haengt von der Hardware-Version ab, mit der Ihre Maschine ausgeruestet ist.
Vorhandene Einschraenkung:
Wenn Sie mehr als 512 Dateien in einem Verzeichnis speichern, dann sortiert die TNC die Dateien nicht mehr alphabetisch.


Dateien nicht alphabetisch sortiert

Frage

Bei einer TNC430 werden bei der Dateuebertragung die Dateien des PC-Fensters nicht in alphabetischer Reihenfolge dargestellt.

Antwort

Wenn Sie mehr als 512 Dateien in einem Verzeichnis speichern, dann sortiert die TNC die Dateien nicht mehr alphabetisch!
Loesung:
Legen Sie Unterverzeichnisse an und verteilen Sie die Dateien auf diese Verzeichnisse (z.B. fuer jeden Kunden oder Auftrag).


Dateien selektieren

Frage

Gibt es in Funktionen wie PGM CALL oder SEL TABLE eine einfache Moeglichkeit die jeweilige Datei per Überblendfenster zu waehlen? Momentan muss der komplette Pfadname eingegeben werden.

Antwort

In der Betriebsart smarT.NC werden Dateien grundsaetzlich auf diese Weise selektiert. Im Klartext-Dialog planen wir fuer die iTNC 530 eine solche Funktion einzufuehren.


Ersetzen einzelner Zeilen in der Werkzeugtabelle

Frage

In der Werkzeugtabelle sollen nur einzelne Zeilen durch neue Werte ersetzt werden. Die neuen Daten erzeugt ein Werkzeugvoreinstellgeraet.

Antwort

Wenn Sie eine beliebige Werkzeug-Tabelle in die Tool.T kopieren, koennen Sie mit dem Softkey FELDER ERSETZEN einzelne Zeilen oder Spalten in der Ziel-Tabelle ueberschreiben.
Voraussetzungen:
- die Ziel-Tabelle muss bereits existieren
- die zu kopierende Datei darf nur die zu ersetzenden Spalten oder
Zeilen enthalten
Achtung!
Der Softkey FELDER ERSETZEN erscheint nicht, wenn Sie
von extern mit einer Datenuebertragungssoftware z. B.
TNCremoNT die Tabelle in der TNC ueberschreiben wollen.
Kopieren Sie die extern erstellte Datei in ein anderes Verzeichnis
und fuehren Sie anschließend den Kopiervorgang
mit der Dateiverwaltung der TNC aus.
Beispiel:
Sie haben auf einem Voreinstellgeraet die Werkzeug-Laenge und den
Werkzeug-Radius von 10 neuen Werkzeugen vermessen. Anschließend
erzeugt das Voreinstellgeraet die Werkzeug-Tabelle TOOL.T mit
10 Zeilen (sprich 10 Werkzeugen) und den Spalten
- Werkzeug-Nummer (Spalte T)
- Werkzeug-Laenge (Spalte L)
- Werkzeug-Radius (Spalte R)
Kopieren Sie diese Datei in ein anderes Verzeichnis, als die vorhandene
TOOL.T steht. Wenn Sie diese Datei mit der Dateiverwaltung der TNC ueber die bestehende Tabelle kopieren, fragt die TNC, ob die bestehende Werkzeug-Tabelle TOOL.T ueberschrieben werden soll:
> Druecken Sie den Softkey JA, dann ueberschreibt die TNC die aktuelle
Datei TOOL.T vollstaendig. Nach dem Kopiervorgang besteht TOOL.T also aus 10 Zeilen. Alle Spalten natuerlich außer den Spalten
Nummer, Laenge und Radius werden zurueckgesetzt
> Oder druecken Sie den Softkey FELDER ERSETZEN, dann ueberschreibt
die TNC in der Datei TOOL.T nur die Spalten Nummer, Laenge und Radius der ersten 10 Zeilen. Die Daten der restlichen Zeilen
und Spalten werden von der TNC nicht veraendert
> Oder druecken Sie den Softkey LEERZEILEN ERSETZEN, dann ueberschreibt die TNC in der Datei TOOL.T nur die Zeilen, in denen keine
Daten eingetragen sind. Die Daten der restlichen Zeilen und Spalten
werden von der TNC nicht veraendert.


Wandeln von ISO in Klartext und zurueck

Frage

Ist es bei den neuen Steuerung noch moeglich von DIN/ISO-Programmierung auf Klartext-Programmierung umzuschalten?

Antwort

Diese Funktion war nur bis zur TNC355 moeglich.
Bei den Nachfolge-Steuerungen TNC 4xx und iTNC 5xx koennen sowohl DIN/ISO-Programme als auch Klartext-Dialog.Programme gleichzeitig auf der Steuerung gespeichert werden (mit Angabe der Dateiextension .I fuer DIN/ISO; .H fuer Klartext-Dialog), ohne die Steuerung jeweils booten zu muessen.
Desweiteren koenn Sie sowohl aus einem DIN/ISO- ein Klartext-Dialog-Programm aufrufen als auch umgekehrt aus einem DIN/ISO-Programm ein Klartext-Dialog-Programm.


Paletten-Verwaltung

Weitere Informationen:
>


Paletten-Verwaltung


Programmierhilfen

Weitere Informationen:
> Taschenrechner
> HELP-Funktion
> ERR-Funktion
> Schnittdaten-Tabellen


Programmierhilfen

Taschenrechner


Programmierhilfen

HELP-Funktion


Programmierhilfen

ERR-Funktion


Schnittdaten-Tabellen

Weitere Informationen:
> Beispieldateien Schnittdaten-Tabellen


Beispieldateien Schnittdaten-Tabellen

Frage

Auf meiner TNC sind keine Schnittdaten-Tabellen vorhanden. Wie bekomme ich die?

Antwort

Die Beispiel-Schnittdaten-Tabellen koennen Sie auf der TNC wie folgt erhalten:
> Betriebsart Programm-Einspeichern Editieren waehlen
> Taste MOD druecken
> Schluesselzahl 123 eingeben, mit Taste ENT bestaetigen
> Taste MOD erneut druecken
> Softkey UPDATE DATA druecken
> Softkey COPY SAMPLE FILE druecken:
Die TNC kopiert die Beispiel-Dateien
> Taste END zweimal druecken


Programme testen / abarbeiten

Weitere Informationen:
> Automatisches Abschalten der Maschine am Programm Ende.
> BLK-Form nicht darstellbar
> Fehlermeldung Werkzeug-Tabelle? im Programm-Test
> Geschwindigkeit der Testgrafik.
> Programm-Test zeigt keine Verfahrwege
> Programmteilwiederholungen


BLK-Form nicht darstellbar

Frage

Warum kann eine BLK-Form, die an einer iTNC 530 erstellt wurde, von einer TNC426 nicht dargestellt werden?
1 BLK FORM 0.1 Z X+0 Y+0 Z-1
2 BLK FORM 0.2 X+1000 Y+700 Z+0

Antwort

Bei der TNC 426/430 muß das Verhaetnis kuerzeste : laengste Seite der BLK-FORM kleiner als 1 : 64 definiert sein.
In der von Ihnen beschriebenen BLK-FORM ist der Z-Wert kleiner, als 1/64 zum Y-Wert..
Abhilfe: Rohteil in einem darstellbaren Verhaeltnis programmieren.


Fehlermeldung Werkzeug-Tabelle? im Programm-Test

Frage

Im PGM-Test wird der Fehler "Werkzeug-Tabelle ?" beim Testen eines Programmes angezeigt.

Antwort

Vermutlich ist keine Werkzeug-Tabelle im PGM-Test aktiv.
Werkzeug-Tabelle im Programm-Test aktivieren:
> Betriebsart Programm-Test waehlen
> Datei-Verwaltung aufrufen (PGM-MGT)
> Wahl der Datei-Typen anzeigen: Softkey TYPE WÄHLEN druecken
> Dateien vom Typ .T anzeigen: Softkey ZEIGE .T druecken
> Waehlen Sie die Datei ( .T) mit der Taste ENT oder mit dem Softkey WÄHLEN
Die TNC kennzeichnet eine fuer den Programm-Test aktive Werkzeug-Tabelle in der Spalte STATUS mit einem "S".


Programm-Test zeigt keine Verfahrwege

Frage

Ich habe versucht ein Programm in der Betriebsart Programm-Test zu simulieren, sehe aber kein Ergebnis im Rohteil.

Antwort

Dieser Effekt kann mehrere Ursachen haben:
- Sie verfahren Ihr Werkzeug oberhalb des Rohteils (Z-Zustellung pruefen)
- Sie verfahren Ihr Werkzeug außerhalb des Rohteils (BLK FORM aendern)
- Sie haben ein Werkzeug mit Radius 0 aktiv
- Sie haben fuer den Programm-Test eine andere Werkzeug-Tabelle aktiviert.


Manueller Betrieb / Handrad

Weitere Informationen:
> Istwert - Übernahme


Istwert - Übernahme

Frage

Wir muessen viele Teile nach Anriss fraesen.
Waere es moeglich die angefahrenen Positionen in ein Programm zu uebernehmen?

Antwort

Fuer diese Anwendung koennen Sie die Funktion "Ist-Position uebernahme" verwenden. Anbei finden Sie eine Beschreibung zu dieser Funktion und einen Link zum Benutzerhandbuch (siehe Kapitel 13.13).


MOD-Funktionen

Weitere Informationen:
> In der Werkzeug-Tabelle kann man den Typ nicht waehlen.
> Kein Zugriff auf TNC mit TNCremo NT
> Messprotokoll auf einem Netzlaufwerk speichern


Maschinen-Parameter

Weitere Informationen:
> In der Werkzeug-Tabelle kann man den Typ nicht waehlen.
> Maschinen-Parameter sichern
> Umrechnung Dezimal/Binaer


Maschinen-Parameter sichern

Frage

Wie kann ich die Maschinen-Parameter auf PC oder Festplatte sichern ?

Antwort

Die Maschinen-Parameter sind in einer Datei (.mp) gespeichert. Den Zugang zu dieser Datei erhalten Sie durch Eingabe einer Schluesselzahl. Die Datei kann direkt an der TNC oder mit TNCremoNT gesichert werden.
Wenden Sie sich hierzu an Ihren Maschinen-Hersteller!


Umrechnung Dezimal/Binaer

Frage

Wie kann ich z.B. den Dezimalwert 393 als Binaerwert anzeigen lassen ohne viel zu rechnen ?

Antwort

Hierzu koennen Sie den Rechner in Windows verwenden.
Nach dem Öffnen des Rechners, waehlen Sie im Menue "Ansicht" die Einstellung "Wissenschaftlich".
Wenn Sie jetzt einen dezimalen Wert eingeben (z.B. 33) und "Bin" waehlen wird der Wert im Binaerformat dargestellt (z.B. 100001).


Windows-Version

Weitere Informationen:
> Virenscanner auf Zwei-Prozessor-Version


Virenscanner auf Zwei-Prozessor-Version

Frage

Koennen auf der Zwei-Prozessor-Version der iTNC 530 Virenscanner eingesetzt werden?

Antwort

Ja, Sie sollten Virenscanner jedoch prinzipiell nur dann verwenden, wenn gerade kein NC-Programm abgearbeitet wird. HEIDENHAIN emfiehlt, Virenscanner entweder direkt nach dem Einschalten oder direkt vor dem Ausschalten der Steuerung anzuwenden.
Hintergrund: Virenscanner arbeiten unter Windows grundsaetzlich mit der Prioritaetsstufe Echtzeit (real time) und ziehen dadurch entsprechend Systemkapazitaeten. Dies haette ggf. zur Folge, das der TNC nicht mehr genuegend Systemresourcen zur Verfuegung stehen, um NC-Programme ohne Einschraenkung abzuarbeiten.


Allgemeines

Weitere Informationen:
> Dateien selektieren
> Umrechnung Dezimal/Binaer