BHB smarT.NC

Benutzer-Handbuch smarT.NC

Gültig für:
340 490-08, 340 491-08, 340 492-08, 340 493-08, 340 494-08, 606 420-03, 606 421-03, 606 424-03,

Stand:
20.03.2013-de-

Copyright © 2012 DR. JOHANNES HEIDENHAIN GmbH. Alle Rechte vorbehalten.


Der smarT.NC-Lotse

Weitere Informationen:
>


Der smarT.NC-Lotse
Weitere Informationen:
> Der smarT.NC-Lotse


Der smarT.NC-Lotse

Steuerung | NC-Software-Nummer
iTNC 530 | 340490-08
iTNC 530 mit HSCI | 606420-03
iTNC 530, Export-Version | 340491-08
iTNC 530, Export-Version mit HSCI | 606421-03
iTNC 530 mit -Windows XP | 340492-08
iTNC 530 mit -Windows XP, Export-Version | 340493-08
iTNC 530 Programmierplatz | 340494-08
iTNC 530 Programmierplatz | 606424-03

... ist die Programmier-Hilfe für die Betriebsart smarT.NC der iTNC 530 in Kurzfassung. Eine vollständige Anleitung zum Programmieren und Bedienen der iTNC 530 finden Sie im Benutzer-Handbuch.

Weitere Informationen:
> Symbole im Lotsen


Symbole im Lotsen

Wichtige Informationen werden im Lotsen mit folgenden Symbolen herausgestellt:

Wichtiger Hinweis!

Maschine und TNC müssen vom Maschinen-Hersteller für die beschriebene Funktion vorbereitet sein!

Warnung: Bei Nichtbeachten Gefahr für Bediener oder Maschine!


Quickstart, der Schnelleinstieg

Weitere Informationen:
> Quickstart, der Schnelleinstieg


Quickstart, der Schnelleinstieg

Quickstart, der Schnelleinstieg

Weitere Informationen:
> Das erste Mal die neue Betriebsart wählen und ein neues Programm erstellen
> Übung 1: Einfache Bohrbearbeitungen in smarT.NC
> Übung 2: Einfache Fräsbearbeitung in smarT.NC
> Übung 3: Konturfräsen in smarT.NC


Das erste Mal die neue Betriebsart wählen und ein neues Programm erstellen

Betriebsart smarT.NC wählen: Die TNC befindet sich in der Datei-Verwaltung (siehe Bild rechts). Wenn sich die TNC nicht in der Datei-Verwaltung befindet: Taste PGM MGT drücken

Um ein neues Bearbeitungs-Programm zu eröffnen, Softkey neue datei drücken: smarT.NC zeigt ein Überblendfenster

Datei-Namen mit Datei-Typ .HU eingeben, mit Taste ENT bestätigen

Softkey MM (bzw. INCH) oder Schaltfläche MM (bzw. INCH) bestätigen: smarT.NC öffnet ein .HU-Programm in der gewählten Maßeinheit und fügt automatisch das Programmkopf-Formular ein. Dieses Formular enthält neben der Rohteil-Definition auch die wichtigsten Voreinstellungen, die für das ganze restliche Programm gelten

Standardwerte übernehmen und Programmkopf-Formular speichern: Taste END drücken: Sie können jetzt Bearbeitungsschritte definieren


Übung 1: Einfache Bohrbearbeitungen in smarT.NC

Weitere Informationen:
> Aufgabe
> Voraussetzungen
> Zentrieren definieren
> Bohren definieren
> Gewindebohren definieren
> Programm testen
> Programm abarbeiten


Aufgabe

Lochkreis zentrieren, bohren und gewindebohren.


Voraussetzungen

    In der Werkzeug-Tabelle TOOL.T müssen folgende Werkzeuge definiert sein:

  • NC-Anbohrer, Durchmesser 10 mm
  • Bohrer, Durchmesser 5 mm
  • Gewindebohrer M6


Zentrieren definieren

Bearbeitungsabschnitt einfügen: Softkey einfügen drücken

Bearbeitung einfügen

Bohrbearbeitung einfügen: Die TNC zeigt eine Softkeyleiste mit den verfügbaren Bohrbearbeitungen an

Zentrieren wählen: Die TNC zeigt das Übersichtsformular zur Definition der kompletten Zentrierbearbeitung an

Werkzeug festlegen: Softkey wählen drücken, die TNC zeigt in einem Überblendfenster den Inhalt der Werkzeug-Tabelle TOOL.T an

Hellfeld mit den Pfeiltasten auf den NC-Anbohrer bewegen und mit Taste ENT ins Formular übernehmen. Alternativ können Sie die Werkzeug-Nummer auch direkt eingeben, mit Taste ENT bestätigen

Spindeldrehzahl eingeben, mit Taste ENT bestätigen

Zentriervorschub eingeben, mit Taste ENT bestätigen

Per Softkey auf Tiefeneingabe umschalten, mit Taste ENT bestätigen. Gewünschte Tiefe eingeben

Mit der Reiter-Umschalttaste das Detailformular Position wählen

Auf Lochkreis-Definition umschalten. Erforderliche Lochkreisdaten eingeben, jeweils mit Taste ENT bestätigen

Formular mit Taste END speichern. Die Zentrierbearbeitung ist vollständig definiert


Bohren definieren

Bohren wählen: Softkey unit 205 drücken, die TNC zeigt das Formular für Bohrbearbeitungen an

Werkzeug festlegen: Softkey wählen drücken, die TNC zeigt in einem Überblendfenster den Inhalt der Werkzeug-Tabelle TOOL.T an

Hellfeld mit den Pfeiltasten auf den Bohrer bewegen und mit Taste ENT ins Formular übernehmen

Spindeldrehzahl eingeben, mit Taste ENT bestätigen

Bohrvorschub eingeben, mit Taste ENT bestätigen

Bohrtiefe eingeben, mit Taste ENT bestätigen

Zustelltiefe eingeben, das Formular mit Taste end speichern

Die Bohrpositionen müssen Sie nicht noch einmal definieren. Die TNC verwendet automatisch die zuletzt, also für die Zentrierbearbeitung, definierten Positionen.


Gewindebohren definieren

Mit Softkey BACK eine Ebene nach oben

Gewindebohrbearbeitung einfügen: Softkey gewinde drücken, die TNC zeigt eine Softkeyleiste mit den verfügbaren Gewindebohrbearbeitungen an

Gewindebohren ohne Ausgleichsfutter wählen: Softkey unit 209 drücken, die TNC zeigt das Formular zur Definition der Gewindebohrbearbeitung an

Werkzeug festlegen: Softkey wählen drücken, die TNC zeigt in einem Überblendfenster den Inhalt der Werkzeug-Tabelle TOOL.T an

Hellfeld mit den Pfeiltasten auf den Gewindebohrer bewegen und mit Taste ENT ins Formular übernehmen

Spindeldrehzahl eingeben, mit Taste ENT bestätigen

Gewindetiefe eingeben, mit Taste ENT bestätigen

Gewindesteigung eingeben, das Formular mit Taste end speichern

Die Bohrpositionen müssen Sie nicht noch einmal definieren. Die TNC verwendet automatisch die zuletzt, also für die Zentrierbearbeitung, definierten Positionen.


Programm testen

Mit Taste smarT.NC die Einstiegs-Softkey-Leiste wählen (Home-Funktion)

Unterbetriebsart Programm-Test wählen

Programm-Test starten, die TNC simuliert die von Ihnen definierten Bearbeitungen

Nach Programm-Ende mit Taste smarT.NC die Einstiegs-Softkey-Leiste wählen (Home-Funktion)


Programm abarbeiten

Mit Taste smarT.NC die Einstiegs-Softkey-Leiste wählen (Home-Funktion)

Unterbetriebsart Abarbeiten wählen

Programmlauf starten, die TNC arbeitet die von Ihnen definierten Bearbeitungen ab

Nach Programm-Ende mit Taste smarT.NC die Einstiegs-Softkey-Leiste wählen (Home-Funktion)


Übung 2: Einfache Fräsbearbeitung in smarT.NC

Weitere Informationen:
> Aufgabe
> Voraussetzungen
> Kreistasche definieren


Aufgabe

Kreistasche mit einem Werkzeugen schruppen und schlichten.


Voraussetzungen

    In der Werkzeug-Tabelle TOOL.T muss folgendes Werkzeug definiert sein:

  • Schaftfräser, Durchmesser 10 mm


Kreistasche definieren

Bearbeitungsabschnitt einfügen: Softkey einfügen drücken

Bearbeitung einfügen

Taschenbearbeitung einfügen: Softkey taschen/zapfen drücken, die TNC zeigt eine Softkeyleiste mit den verfügbaren Fräsbearbeitungen an

Kreistasche wählen: Softkey unit 252 drücken, die TNC zeigt das Formular für eine Kreistaschenbearbeitung an. Der Bearbeitungsumfang steht auf schruppen und schlichten

Werkzeug festlegen: Softkey wählen drücken, die TNC zeigt in einem Überblendfenster den Inhalt der Werkzeug-Tabelle TOOL.T an

Hellfeld mit den Pfeiltasten auf den Schaftfräser bewegen und mit Taste ENT ins Formular übernehmen

Spindeldrehzahl eingeben, mit Taste ENT bestätigen

Eintauchvorschub eingeben, mit Taste ENT bestätigen

Fräsvorschub eingeben, mit Taste ENT bestätigen

Durchmesser der Kreistasche eingeben, mit Taste ENT bestätigen

Tiefe, Zustell-Tiefe und Schlichtaufmaß Seite eingeben, jeweils mit Taste ENT bestätigen

Mittelpunktskoordinaten der Kreistasche in X und Y eingeben, jeweils mit Taste ENT bestätigen

Formular mit Taste END speichern. Die Kreistaschenbearbeitung ist vollständig definiert

Das erstellte Programm wie zuvor beschrieben testen und abarbeiten


Übung 3: Konturfräsen in smarT.NC

Weitere Informationen:
> Aufgabe
> Voraussetzungen
> Konturbearbeitung definieren


Aufgabe

Kontur mit einem Werkzeugen schruppen und schlichten.


Voraussetzungen

    In der Werkzeug-Tabelle TOOL.T muss folgendes Werkzeug definiert sein:

  • Schaftfräser, Durchmesser 22 mm


Konturbearbeitung definieren

Bearbeitungsabschnitt einfügen: Softkey einfügen drücken

Bearbeitung einfügen

Konturbearbeitung einfügen: Softkey kontur-pgm drücken, die TNC zeigt eine Softkeyleiste mit den verfügbaren Konturbeitungen an

Konturzugbearbeitung wählen: Softkey unit 125 drücken, die TNC zeigt das Formular für eine Konturbearbeitung an.

Werkzeug festlegen: Softkey wählen drücken, die TNC zeigt in einem Überblendfenster den Inhalt der Werkzeug-Tabelle TOOL.T an

Hellfeld mit den Pfeiltasten auf den Schaftfräser bewegen und mit Taste ENT ins Formular übernehmen

Spindeldrehzahl eingeben, mit Taste ENT bestätigen

Eintauchvorschub eingeben, mit Taste ENT bestätigen

Fräsvorschub eingeben, mit Taste ENT bestätigen

Koordinate der Werkstück-Oberkante, Tiefe, Zustell-Tiefe und Schlichtaufmaß Seite eingeben, jeweils mit Taste ENT bestätigen

Fräsart, Radiuskorrektur und Anfahrart per Softkeys wählen, jeweils mit Taste ENT bestätigen

Anfahrparameter eingeben, jeweils mit Taste ENT bestätigen

Das Eingabefeld Konturname ist aktiv. Neues Konturprogramm erstellen: smarT.NC zeigt ein Überblendfenster zur Eingabe des Konturnamens. Namen der Kontur eingeben, mit Taste ENT bestätigen, smarT.NC befindet sich jetzt im Modus Konturprogrammierung

Mit der Taste L den Startpunkt der Kontur in X und Y definieren: X=10, Y=10, mit Taste end speichern

Mit der Taste L Punkt 2 anfahren: X=90, mit Taste END speichern

Mit der Taste rnd den Rundungsradius von 8 mm definieren, mit Taste end speichern

Mit der Taste L den Punkt 3 anfahren: Y=80, mit Taste END speichern

Mit der Taste L den Punkt 4 anfahren: X=90, Y=70, mit Taste END speichern

Mit der Taste L den Punkt 5 anfahren: Y=10, mit Taste END speichern

Mit der Taste chf die Fase von 6 mm definieren, mit Taste end speichern

Mit der Taste L den Endpunkt 6 anfahren: X=10, mit Taste END speichern

Konturprogramm mit Taste END speichern: smarT.NC befindet sich jetzt wieder im Formular zur Definition der Konturbearbeitung

Gesamte Konturbearbeitung mit Taste END speichern. Die Konturbearbeitung ist vollständig definiert

Das erstellte Programm wie zuvor beschrieben testen und abarbeiten


Grundlagen

Weitere Informationen:
> Grundlagen


Grundlagen

Grundlagen

Weitere Informationen:
> Einführung in smarT.NC
> Programme/Dateien
> Das erste Mal die neue Betriebsart wählen
> Datei-Verwaltung in smarT.NC
> Navigieren in smarT.NC
> Bildschirm-Aufteilung beim Editieren
> Maus-Bedienung
> Kopieren von Units
> Werkzeug-Tabelle editieren
> MOD-Funktion


Einführung in smarT.NC

Mit smarT.NC erstellen Sie auf einfache Weise in getrennte Bearbeitungsschritte (Units) unterteilte Klartext-Dialog-Programme, die Sie auch mit dem Klartext-Editor bearbeiten können. Im Klartext-Editor geänderte Daten sehen Sie selbstverständlich auch in der Formular-Darstellung, da smarT.NC immer das „normale“ Klartext-Dialog-Programm als einzige Datenbasis verwendet.

Übersichtliche Eingabeformulare in der rechten Bildschirmhälfte erleichtern die Definition der erforderlichen Bearbeitungsparameter, die zusätzlich in einem Hilfsbild grafisch dargestellt sind (linke untere Bildschirmhälfte). Die strukturierte Programm-Darstellung in einer Baumstruktur (linke obere Bildschirmhälfte) hilft, einen schnellen Überblick über die Bearbeitungsschritte des jeweiligen Bearbeitungsprogramms zu erhalten.

smarT.NC ist eine separate Universal-Betriebsart, die Sie alternativ zur bekannten Klartext-Dialog-Programmierung einsetzen können. Sobald Sie einen Bearbeitungsschritt definiert haben, können Sie diesen in der neuen Betriebsart grafisch testen und/oder abarbeiten.

Darüber hinaus können Sie die UNIT-Programmierung auch in normalen Klartext-Dialog-Programmen (.H-Programmen) nutzen. Über die Funktion smartWizard können Sie alle zur Verfügung stehenden UNIT‘s an einer beliebigen Stelle des Klartext-Programmes einfügen. Beachten Sie hierzu auch das Benutzer-Handbuch Klartext-Dialog-Programmierung, Kapitel Sonderfunktionen.

Weitere Informationen:
> Parallel-Programmierung


Parallel-Programmierung

smarT.NC-Programme können Sie auch erstellen oder editieren, wenn die TNC gerade ein Programm abarbeitet. Wechseln Sie dazu einfach in die Betriebsart Programm-Einspeichern/Editieren und öffnen dort das gewünschte smarT.NC-Programm.

Wenn Sie das smarT.NC-Programm mit dem Klartext-Editor bearbeiten wollen, wählen Sie in der Datei-Verwaltung die Funktion öffnen mit und anschließend klartext.


Programme/Dateien

Dateien in der TNC | Typ
Programme im HEIDENHAIN-Format im DIN/ISO-Format | .H .I
smarT.NC-Dateien Strukturierte Unit-Programme Konturbeschreibungen Punkte-Tabellen für -Bearbeitungspositionen | .HU .HC .HP
Tabellen für Werkzeuge Werkzeug-Wechsler Paletten Nullpunkte Presets (Bezugspunkte) Schnittdaten Schneidstoffe, Werkstoffe | .T .TCH .P .D .PR .CDT .TAB
Texte als ASCII-Dateien Hilfe-Dateien | .A .CHM
Zeichnungsdaten als DXF-Dateien | .DXF

Programme, Tabellen und Texte speichert die TNC in Dateien. Die Datei-Bezeichnung besteht aus zwei Komponenten:

PROG20 | .HU
Datei-Name | Datei-Typ

smarT.NC verwendet überwiegend drei Datei-Typen:

  • Unit-Programme (Datei-Typ .HU)
    Unit-Programme sind Klartext-Dialog-Programme, die zwei zusätzliche Strukturierungselemente enthalten: Den Anfang (UNIT xxx) und das Ende (END OF UNIT xxx) eines Bearbeitungsschrittes
  • Konturbeschreibungen (Datei-Typ .HC)
    Konturbeschreibungen sind Klartext-Dialog-Programme, die ausschließlich Bahnfunktionen enthalten dürfen, mit denen eine Kontur in der Bearbeitungsebene zu beschreiben ist: Dies sind die Elemente L, C mit CC, CT, CR, RND, CHF und die Elemente der Freien Kontur-Programmierung FK FPOL, FL, FLT, FC und FCT
  • Punkte-Tabellen (Datei-Typ .HP)
    In Punkte-Tabellen speichert smarT.NC Bearbeitungspositionen, die Sie über den leistungsfähigen Mustergenerator definiert haben

smarT.NC legt standardmäßig alle Dateien im Verzeichnis TNC:\smarTNC ab. Sie können jedoch auch ein beliebig anderes Verzeichnis wählen.


Das erste Mal die neue Betriebsart wählen

Betriebsart smarT.NC wählen: Die TNC befindet sich in der Datei-Verwaltung

Eines der verfügbaren Beispielprogramme mit den Pfeiltasten und der Taste ENT wählen, oder

Um ein neues Bearbeitungs-Programm zu eröffnen, Softkey neue datei drücken: smarT.NC zeigt ein Überblendfenster

Datei-Namen mit Datei-Typ .HU eingeben, mit Taste ENT bestätigen

Softkey MM (bzw. INCH) oder Schaltfläche MM (bzw. INCH) bestätigen: smarT.NC öffnet ein .HU-Programm in der gewählten Maßeinheit und fügt automatisch das Programmkopf-Formular ein

Die Daten des Programmkopf-Formulares sind zwingend einzugeben, da diese global für das komplette Bearbeitungsprogramm gelten. Die Defaultwerte sind intern festgelegt. Daten bei Bedarf ändern und mit Taste END speichern

Um Bearbeitungsschritte zu definieren, über Softkey -editieren den gewünschten Bearbeitungsschritt wählen


Datei-Verwaltung in smarT.NC

Wie zuvor bereits erwähnt, unterscheidet smarT.NC die drei Datei-Typen Unit-Programme (.HU), Konturbeschreibungen (.HC) und Punkte-Tabellen (.HP). Diese drei Datei-Typen lassen sich über die Datei-Verwaltung in der Betriebsart smarT.NC wählen und editieren. Das Editieren von Konturbeschreibungen und Punkte-Tabellen ist auch dann möglich, wenn Sie gerade eine Bearbeitungseinheit definieren.

Zusätzlich können Sie innerhalb von smarT.NC auch DXF-Dateien öffnen, um daraus Konturbeschreibungen (.HC-Dateien) und Bearbeitungspositionen (.HP-Dateien) zu extrahieren (Software-Option).

Die Datei-Verwaltung in smarT.NC ist ohne Einschränkungen auch per Maus bedienbar. Insbesondere können Sie die Fenstergrößen innerhalb der Datei-Verwaltung mit der Maus verschieben. Klicken Sie dazu auf die horizontale bzw. vertikale Trennlinie und verschieben diese mit gedrückter Maus-Taste auf die gewünschte Position.

Weitere Informationen:
> Datei-Verwaltung aufrufen
> Laufwerke, Verzeichnisse und Dateien wählen
> Neues Verzeichnis erstellen
> Neue Datei öffnen
> Datei in dasselbe Verzeichnis kopieren
> Datei in ein anderes Verzeichnis kopieren
> Datei löschen
> Datei umbenennen
> Datei schützen/Dateischutz aufheben
> Eine der letzten 15 gewählten Dateien wählen
> Verzeichnisse aktualisieren
> Dateien sortieren
> Datei-Verwaltung anpassen


Datei-Verwaltung aufrufen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken: Die TNC zeigt das Fenster zur Datei-Verwaltung (das Bild rechts zeigt die Grundeinstellung). Wenn die TNC eine andere Bildschirm-Aufteilung anzeigt, drükken Sie den Softkey FENSTER auf der zweiten Softkey-Leiste)

Das linke, obere Fenster zeigt die vorhandenen Laufwerke und Verzeichnisse an. Laufwerke bezeichnen Geräte, mit denen Daten gespeichert oder übertragen werden. Ein Laufwerk ist die Festplatte der TNC, über ein Netzwerk verbundene Verzeichnisse oder USB-Geräte. Ein Verzeichnis ist immer durch ein Ordner-Symbol (links) und den Verzeichnis-Namen (rechts daneben) gekennzeichnet. Unterverzeichnisse sind nach rechts eingerückt. Befindet sich vor dem Ordner-Symbol ein nach rechts zeigendes Dreieck, dann sind noch weitere Unterverzeichnisse vorhanden, die Sie mit der Taste Pfeil nach rechts einblenden können.

Das linke, untere Fenster zeigt eine Vorschau des jeweiligen Datei-Inhalts an, wenn das Hellfeld auf einer .HP- oder .HC-Datei steht.

Das rechte, breite Fenster zeigt alle Dateien an, die in dem gewählten Verzeichnis gespeichert sind. Zu jeder Datei werden mehrere Informationen gezeigt, die in der Tabelle unten aufgeschlüsselt sind.

Anzeige | Bedeutung
Datei-Name | Name mit maximal 25 Zeichen
Typ | Datei-Typ
Größe | Dateigröße in Byte
Geändert | Datum und Uhrzeit der letzten Änderung
Status | Eigenschaft der Datei: E: Programm ist in der Betriebsart Programm-Einspeichern/Editieren angewählt S: Programm ist in der Betriebsart Programm-Test angewählt M: Programm ist in einer Programmlauf-Betriebsart angewählt P: Datei ist gegen Löschen und Ändern geschützt (Protected) +: Es sind abhängige Dateien vorhanden (Gliederungs-Datei, Werkzeug-Einsatzdatei)


Laufwerke, Verzeichnisse und Dateien wählen
 | Datei-Verwaltung aufrufen
Benutzen Sie die Pfeil-Tasten oder die Softkeys, um das Hellfeld an die gewünschte Stelle auf dem Bildschirm zu bewegen:
 | Bewegt das Hellfeld vom rechten ins linke Fenster und umgekehrt
 | Bewegt das Hellfeld in einem Fenster auf und ab
 | Bewegt das Hellfeld in einem Fenster seitenweise auf und ab

Schritt 1: Laufwerk wählen

Laufwerk im linken Fenster markieren:
 | Laufwerk wählen: Softkey WÄHLEN drücken, oder
 | Taste ENT drücken

Schritt 2: Verzeichnis wählen

Verzeichnis im linken Fenster markieren: Das rechte Fenster zeigt automatisch alle Dateien aus dem Verzeichnis an, das markiert (hell hinterlegt) ist

Schritt 3: Datei wählen

 | Softkey TYP WÄHLEN drücken
 | Softkey des gewünschten Datei-Typs drücken, oder
 | alle Dateien anzeigen: Softkey ALLE ANZ. drücken, oder
Datei im rechten Fenster markieren:
 | Softkey WÄHLEN drücken, oder
 | Taste ENT drücken: Die TNC öffnet die gewählte Datei

Wenn Sie per Tastatur einen Namen eintippen, dann synchronisiert die TNC das Hellfeld auf die eingegebenen Ziffern, so dass Sie Datei leicht auffinden können.


Neues Verzeichnis erstellen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Mit Taste Pfeil nach links den Verzeichnisbaum wählen

  • Laufwerk TNC:\ wählen, wenn Sie ein neues Hauptverzeichnis erstellen wollen oder vorhandenes Verzeichnis wählen, in dem Sie ein neues Unterverzeichnis erstellen wollen

  • Neuen Verzeichnisnamen eingeben, mit Taste ent bestätigen: smarT.NC zeigt ein Überblendfenster zur Bestätigung des neuen Verzeichnisnamens

  • Mit Taste ENT oder Schaltfläche Ja bestätigen. Um den Vorgang abzubrechen: Taste ESC oder Schaltfläche Nein drücken

Sie können ein neues Verzeichnis auch über den Softkey neues verzeichn. öffnen. Geben Sie den Verzeichnis-Namen dann im Überblendfenster ein und bestätigen mit der Taste ENT.


Neue Datei öffnen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Datei-Typ der neuen Datei wählen wie zuvor beschrieben

  • Datei-Namen ohne Datei-Typ eingeben, mit Taste ENT bestätigen

  • Softkey MM (bzw. INCH) oder Schaltfläche MM (bzw. INCH) bestätigen: smarT.NC öffnet eine Datei in der gewählten Maßeinheit. Um den Vorgang abzubrechen: Taste ESC oder Schaltfläche Abbrechen drücken

Sie können eine neue Datei auch über den Softkey neue datei öffnen. Geben Sie den Datei-Namen dann im Überblendfenster ein und bestätigen mit der Taste ENT.


Datei in dasselbe Verzeichnis kopieren

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Mit den Pfeiltasten Hellfeld auf die Datei schieben, die Sie kopieren wollen

  • Softkey kopieren drücken: smarT.NC zeigt ein Überblendfenster

  • Datei-Namen der Ziel-Datei ohne Datei-Typ eingeben, mit Taste ENT oder Schaltfläche OK bestätigen: smarT.NC kopiert den Inhalt der gewählte Datei in eine neue Datei vom gleichen Datei-Typ. Um den Vorgang abzubrechen: Taste ESC oder Schaltfläche Abbrechen drücken

  • Wenn Sie die Datei in ein anderes Verzeichnis kopieren wollen: Softkey zur Pfadauswahl drücken, im Überblendfenster gewünschtes Verzeichnis wählen und mit Taste ENT oder Schaltfläche OK bestätigen


Datei in ein anderes Verzeichnis kopieren

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Mit den Pfeiltasten Hellfeld auf die Datei schieben, die Sie kopieren wollen

  • Zweite Softkey-Leiste wählen, Softkey fenster drücken, um den TNC-Bildschirm zu teilen

  • Mit Taste Pfeil nach links das Hellfeld in das linke Fenster schieben

  • Softkey pfad drücken: smarT.NC zeigt ein Überblendfenster

  • Im Überblendfenster das Verzeichnis wählen, in das Sie die Datei kopieren wollen, mit Taste ENT oder Schaltfläche OK bestätigen

  • Mit Taste Pfeil nach rechts das Hellfeld in das rechte Fenster schieben

  • Softkey kopieren drücken: smarT.NC zeigt ein Überblendfenster

  • Wenn erforderlich neuen Datei-Namen der Ziel-Datei ohne Datei-Typ eingeben, mit Taste ENT oder Schaltfläche OK bestätigen: smarT.NC kopiert den Inhalt der gewählte Datei in eine neue Datei vom gleichen Datei-Typ. Um den Vorgang abzubrechen: Taste ESC oder Schaltfläche Abbrechen drücken

Wenn Sie mehrere Dateien kopieren wollen, dann können Sie mit der Maus-Taste weitere Dateien markieren. Drücken Sie dazu die CTRL-Taste und anschließend auf die gewünschte Datei.


Datei löschen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Mit den Pfeiltasten Hellfeld auf die Datei schieben, die Sie löschen wollen

  • Zweite Softkey-Leiste wählen

  • Softkey löschen drücken: smarT.NC zeigt ein Überblendfenster

  • Um die gewählte Datei zu löschen: Taste ENT oder Schaltfläche Ja drücken. Um den Löschvorgang abzubrechen: Taste ESC oder Schaltfläche Nein drücken


Datei umbenennen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Mit den Pfeiltasten Hellfeld auf die Datei schieben, die Sie umbenennen wollen

  • Zweite Softkey-Leiste wählen

  • Softkey umbenen. drücken: smarT.NC zeigt ein Überblendfenster

  • Neuen Datei-Namen eingeben, mit Taste ENT oder Schaltfläche OK bestätigen. Um den Vorgang abzubrechen: Taste ESC oder Schaltfläche Abbrechen drücken


Datei schützen/Dateischutz aufheben

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Mit den Pfeiltasten Hellfeld auf die Datei schieben, die Sie schützen, bzw. deren Dateischutz Sie aufheben wollen

  • Dritte Softkey-Leiste wählen

  • Softkey löschen drücken: smarT.NC zeigt ein Überblendfenster

  • Softkey zusätzl. funkt. drücken

  • Um die gewählte Datei zu schützen: Softkey schützen drücken, um den Dateischutz aufzuhenen: Softkey ungesch. drücken


Eine der letzten 15 gewählten Dateien wählen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Softkey letzte dateien drücken: smarT.NC zeigt die letzten 15 Dateien an, die Sie in der Betriebsart smarT.NC gewählt hatten

  • Mit den Pfeiltasten Hellfeld auf die Datei schieben, die Sie wählen wollen

  • Gewählte Datei übernehmen: Taste ent drücken


Verzeichnisse aktualisieren

Wenn Sie auf einem externen Datenträger navigieren, kann es erforderlich sein den Verzeichnisbaum zu aktualisieren:

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Mit Taste Pfeil nach links den Verzeichnisbaum wählen

  • Softkey AKT. BAUM drücken: Die TNC aktualisiert den Verzeichnisbaum


Dateien sortieren

Die Funktionen zum Sortieren von Dateien führen Sie per Maus-Klick aus. Sie können nach Datei-Name, Datei-Typ, Datei-Größe, Änderungs-Datum und Datei-Status auf- oder absteigend sortieren:

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Mit der Maus auf den Spaltenkopf klicken nach dem Sie sortieren wollen: Ein Dreieck im Spaltenkopf zeigt die Sortierfolge an, erneuter Klick auf denselben Spaltenkopf dreht die Sortierreihenfolge um


Datei-Verwaltung anpassen

Das Menü für die Anpassung können Sie entweder durch Maus-Klick auf den Pfadnamen, oder per Softkeys öffnen:

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Dritte Softkey-Leiste wählen

  • Softkey zusätzl. funkt. drücken

  • Softkey optionen drücken: Die TNC blendet das Menü zur Anpassung der Datei-Verwaltung ein

  • Mit den Pfeiltasten Hellfeld auf die gewünschte Einstellung schieben

  • Mit der Blank-Taste die gewünschte Einstellung aktivieren/deaktivieren

    Folgende Anpassungen können Sie an der Datei-Verwaltung vornehmen:

  • Bookmarks
    Über Bookmarks verwalten Sie Ihre Verzeichnis-Favoriten. Sie können das aktive Verzeichnis hinzufügen oder löschen oder alle Bookmarks löschen. Alle von Ihnen hinzugefügten Verzeichnisse erscheinen in der Bookmark-Liste und lassen sich somit schnell anwählen
  • Ansicht
    Im Menüpunkt Ansicht legen Sie fest, welche Informationen die TNC im Dateifenster anzeigen soll
  • Datums-Format
    Im Menüpunkt Datums-Format legen Sie fest, in welchem Format die TNC das Datum in der Spalte Geändert anzeigen soll
  • Einstellungen
    Wenn Cursor im Verzeichnisbaum steht: Festlegen, ob die TNC beim Drücken der Pfeil nach rechts-Taste das Fenster wechseln soll, oder ob die TNC ggf. vorhandene Unterverzeichnisse aufklappen soll


Navigieren in smarT.NC

Bei der Entwicklung von smarT.NC wurde darauf geachtet, dass die vom Klartext-Dialog her bekannten Bedientasten (ENT, DEL, END, ...) auch in der neuen Betriebsart weitestgehend identisch verwendbar sind. Die Tasten haben folgende Funktionalität:

Funktion wenn Treeview (linke Bildschirmseite) aktiv ist | Taste
Formular aktivieren, um Daten eingeben bzw. ändern zu können |
Editieren beenden: smarT.NC ruft automatisch die Datei-Verwaltung auf |
Angewählten Bearbeitungsschritt (komplette Unit) löschen |
Hellfeld auf nächsten/vorherigen Bearbeitungsschritt positionieren |
Symbole für Detailformulare im Treeview einblenden, wenn vor dem Treeview-Symbol ein nach rechts ausgerichteter Pfeil angezeigt wird, oder ins Formular wechseln, wenn Treeview bereits aufgeklappt ist |
Symbole für Detailformulare im Treeview ausblenden, wenn vor dem Treeview-Symbol ein nach unten ausgerichteter Pfeil angezeigt wird |
Seite nach oben blättern |
Seite nach unten blättern |
Sprung zum Datei-Anfang |
Sprung zum Datei-Ende |
Funktion wenn Formular (rechte Bildschirmseite) aktiv ist | Taste
Nächstes Eingabefeld wählen |
Editieren des Formulars beenden: smarT.NC speichert alle geänderten Daten |
Editieren des Formulars abbrechen: smarT.NC speichert die geänderten Daten nicht ab |
Hellfeld auf nächstes/vorheriges Eingabefeld/Eingabeelement positionieren |
Cursor im aktiven Eingabefeld positionieren, um einzelne Teilwerte abändern zu können, oder wenn eine Option-Box aktiv ist: Nächste/vorherige Option wählen |
Bereits eingegebenen Zahlenwert auf 0 rücksetzen |
Inhalt des aktiven Eingabefeldes komplett löschen |

Darüber hinaus stehen auf der Tastatur-Einheit drei Tasten zur Verfügung, mit denen Sie innerhalb von Formularen noch schneller navigieren können:

Funktion wenn Formular (rechte Bildschirmseite) aktiv ist | Taste
Nächstes Unterformular wählen |
Ersten Eingabeparameter im nächsten Rahmen wählen |
Ersten Eingabeparameter im vorherigen Rahmen wählen |

Wenn Sie Konturen editieren, dann können Sie den Cursor auch mit den orangenen Achstasten positionieren, so dass die Koordinaten-Eingabe identisch zur Klartext-Dialog-Eingabe ist. Ebenso können Sie Absolut-/Inkremental-Umschaltungen oder Umschaltungen zwischen kartesischer und Polarkoordinaten-Programmierung mit den entsprechenden Klartext-Dialog-Tasten durchführen.

Funktion wenn Formular (rechte Bildschirmseite) aktiv ist | Taste
Eingabefeld für X-Achse wählen |
Eingabefeld für Y-Achse wählen |
Eingabefeld für Z-Achse wählen |
Umschaltung Inkremental-/Absoultwert-Eingabe |
Umschaltung kartesische/Polarkoordinaten-Eingabe |


Bildschirm-Aufteilung beim Editieren

Der Bildschirm beim Editieren in smarT.NC hängt vom Datei-Typ ab, den Sie gerade zum Editieren angewählt haben.

Weitere Informationen:
> Unit-Programme editieren
> Bearbeitungspositionen editieren
> Konturen editieren
> DXF-Dateien anzeigen


Unit-Programme editieren

1

Kopfzeile: Betriebsartentext, Fehlermeldungen

2

Aktive Hintergrund-Betriebsart

3

Baumstruktur (Treeview), in dem die definierten Bearbeitungseinheiten strukturiert dargestellt werden

4

Formularfenster mit den jeweiligen Eingabeparametern: In Abhängigkeit vom gewählten Bearbeitungsschritt, können bis zu fünf Formulare vorhanden sein:

  • 4.1: Übersichtsformular
    Die Eingabe der Parameter im Übersichtsformular genügt, um den jeweiligen Bearbeitungsschritt mit Grundfunktionalität auszuführen. Die Daten des Übersichtsformulars sind ein Auszug der wichtigsten Daten, die auch in den Detailformularen eingebbar sind
  • 4.2: Detailformular Werkzeug
    Eingabe zusätzlicher werkzeugspezifischer Daten
  • 4.3: Detailformular optionale Parameter
    Eingabe von zusätzlichen, otionalen Bearbeitungsparametern
  • 4.4: Detailformular Positionen
    Eingabe von zusätzlichen Bearbeitungspositionen
  • 4.5: Detailformular Globale Daten
    Liste der wirksamen globalen Daten

5

Hilfsbildfenster, in dem der im Formular jeweils aktive Eingabeparameter grafisch dargestellt ist


Bearbeitungspositionen editieren
1 | Kopfzeile: Betriebsartentext, Fehlermeldungen
2 | Aktive Hintergrund-Betriebsart
3 | Baumstruktur (Treeview), in dem die definierten Bearbeitungsmuster strukturiert dargestellt werden
4 | Formularfenster mit den jeweiligen Eingabeparametern
5 | Hilfsbildfenster, in dem der jeweils aktive Eingabeparameter grafisch dargestellt ist
6 | Grafikfenster, in dem die programmierten Bearbeitungspositionen sofort nach dem Speichern des Formulars dargestellt werden


Konturen editieren

1

Kopfzeile: Betriebsartentext, Fehlermeldungen

2

Aktive Hintergrund-Betriebsart

3

Baumstruktur (Treeview), in dem die jeweiligen Konturelemente strukturiert dargestellt werden

4

Formularfenster mit den jeweiligen Eingabeparametern: Bei der FK‑Programmierung sind bis zu vier Formulare vorhanden:

  • 4.1: Übersichtsformular
    Enthält die am meisten verwendeten Eingabemöglichkeiten
  • 4.2: Detailformular 1
    Enthält Eingabemöglichkeiten für Hilspunkte (FL/FLT) bzw. für Kreisdaten (FC/FCT)
  • 4.3: Detailformular 2
    Enthält Eingabemöglichkeiten für Relativ-Bezüge (FL/FLT) bzw. für Hilfspunkte (FC/FCT)
  • 4.4: Detailformular 3
    Nur verfügbar bei FC/FCT, enthält Eingabemöglichkeiten für Relativ-Bezüge

5

Hilfsbildfenster, in dem der jeweils aktive Eingabeparameter grafisch dargestellt ist

6

Grafikfenster, in dem die programmierten Konturen sofort nach dem Speichern des Formulars dargestellt werden


DXF-Dateien anzeigen
1 | Kopfzeile: Betriebsartentext, Fehlermeldungen
2 | Aktive Hintergrund-Betriebsart
3 | In der DXF-Datei enthaltene Layer oder bereits selektierte Konturelemente bzw. selektierte Positionen
4 | Zeichnungsfenster, in dem smarT.NC den Inhalt der DXF-Datei anzeigt


Maus-Bedienung

    Besonders einfach ist auch die Bedienung per Maus. Beachten Sie bitte folgende Besonderheiten:

  • Neben den von Windows her bekannten Maus-Funktionen, können Sie auch die smarT.NC-Softkeys per Maus-Klick bedienen
  • Wenn mehrere Softkey-Leisten verfügbar sind (Anzeige durch Balken direkt über den Softkeys), können Sie per Klick auf einen der Balken die gewünschte Leiste aktivieren
  • Um im Treeview Detailformulare anzuzeigen: Auf das waagrecht liegende Dreieck klicken, zum Ausblenden auf das senkrecht liegende Dreieck klicken
  • Um Werte im Formular ändern zu können: In beliebiges Eingabefeld oder auf eine Option-Box klicken, smarT.NC wechselt dann automatisch in den Editiermodus.
  • Um das Formular wieder zu verlassen (zum Beenden des Editiermodus): An eine beliebige Stelle im Treeview klicken, smarT.NC blendet dann eine Abfrage ein, ob Änderungen im Formular gespeichert werden sollen oder nicht
  • Wenn Sie mit der Maus über ein beliebiges Element fahren, zeigt smarT.NC einen Tipp-Text an. Der Tipp-Text enthält kurze Informationen zur jeweiligen Funktion des Elements


Kopieren von Units

Einzelne Bearbeitungsunits kopieren Sie ganz einfach mit den von Windows her bekannten Kurzbefehlen:

  • STRG+C, um die Unit zu kopieren
  • STRG+X, um die Unit auszuschneiden
  • STRG+V, um die Unit hinter der momentan aktiven Unit einzufügen

Wenn Sie mehrere Units gleichzeitig kopieren wollen, gehen Sie wie folgt vor:

Softkey-Leiste in der obersten Ebene umschalten

Mit den Pfeiltasten oder per Maus-Klick die erste zu kopierende Unit wählen

Markieren-Funktion aktivieren

Mit den Pfeiltasten oder per Softkey NÄCHSTEN BLOCK MARKIEREN alle zu kopierenden Units wählen

Markierten Block in den Zwischenspeicher kopieren (funktioniert auch mit STRG+C)

Mit den Pfeiltasten oder per Softkey die Unit wählen, hinter der Sie den kopierten Block einfügen wollen

Block aus dem Zwischenspeicher einfügen (funktioniert auch mit STRG+V)


Werkzeug-Tabelle editieren

Direkt nachdem Sie die Betriebsart smarT.NC gewählt haben, können Sie die Werkzeug-Tabelle TOOL.T editieren. Die TNC stellt die Werkzeug-Daten in Formularen gegliedert dar, die Navigation in der Werkzeug-Tabelle ist identisch zur Navigation in smarT.NC siehe Navigieren in smarT.NC.

Die Werkzeug-Daten sind in folgende Gruppen gegliedert:

  • Reiter Übersicht:
    Zusammenfassung der am häufigsten verwendeten Werkzeug-Daten wie Werkzeug-Name, -Länge oder -Radius
  • Reiter Zus. Daten:
    Zusätzliche Werkzeugdaten, die für Sonderanwendung wichtig sind
  • Reiter Zus. Daten:
    Schwester-Werkzeugverwaltung und weitere zusätzliche Werkzeugdaten
  • Reiter Tastsystem:
    Daten für 3D-Tastsysteme und Tisch-Tastsysteme
  • Reiter PLC:
    Daten, die für die Anpassung Ihrer Maschine an die TNC erforderlich sind und von Ihrem Maschinenhersteller festgelegt werden
  • Reiter CDT:
    Daten für automatische Schnittdaten-Berechnung

Beachten Sie auch die detailliertere Beschreibung der Werkzeug-Daten im Benutzer-Handbuch Klartext-Dialog.

Über den Werkzeug-Typ legen Sie fest, welches Symbol die TNC im Treeview anzeigt. Zusätzlich zeigt die TNC im Treeview auch den eingegebenen Werkzeug-Namen an.

Werkzeug-Daten, die per Maschinen-Parameter deaktiviert sind, stellt smarT.NC im jeweiligen Reiter nicht dar. Ggf. sind dann ein oder mehrere Reiter nicht sichtbar.


MOD-Funktion

Über die MOD-Funktionen können Sie zusätzliche Anzeigen und Eingabemöglichkeiten wählen.

Weitere Informationen:
> MOD-Funktionen wählen
> Einstellungen ändern
> MOD-Funktionen verlassen


MOD-Funktionen wählen

Taste MOD drücken: Die TNC zeigt die Einstellmöglichkeiten in der Betriebsart smarT.NC


Einstellungen ändern

  • MOD-Funktion im angezeigten Menü mit Pfeiltasten wählen

    Um eine Einstellung zu ändern, stehen – abhängig von der gewählten Funktion – drei Möglichkeiten zur Verfügung:

  • Zahlenwert direkt eingeben, z.B. beim Festlegen der Verfahrbereichs-Begrenzung
  • Einstellung durch Drücken der Taste ENT ändern, z.B. beim Festlegen der Programm-Eingabe
  • Einstellung ändern über ein Auswahlfenster. Wenn mehrere Einstellmöglichkeiten zur Verfügung stehen, können Sie durch Drücken der Taste GOTO ein Fenster einblenden, in dem alle Einstellmöglichkeiten auf einen Blick sichtbar sind. Wählen Sie die gewünschte Einstellung direkt durch Drücken der entsprechenden Zifferntaste (links vom Doppelpunkt), oder mit der Pfeiltaste und anschließendem bestätigen mit der Taste ENT. Wenn Sie die Einstellung nicht ändern wollen, schließen Sie das Fenster mit der Taste END


MOD-Funktionen verlassen

  • MOD-Funktion beenden: Softkey ENDE oder Taste END drücken


Bearbeitungen definieren

Weitere Informationen:
> Bearbeitungen definieren


Bearbeitungen definieren

Bearbeitungen definieren

Weitere Informationen:
> Grundlagen
> Programm-Einstellungen
> Werkzeug-Auswahl
> Umschaltung Drehzahl /Schnittgeschwindigkeit
> Umschaltung F/FZ/FU/FMAX
> Daten aus vorheriger, gleichartiger Unit übernehmen
> Verfügbare Bearbeitungsschritte (Units)
> Hauptgruppe Bearbeiten
> Bearbeitungsgruppe Bohren
> Bearbeitungsgruppe Gewinde
> Bearbeitungsgruppe Taschen/Zapfen
> Bearbeitungsgruppe Kontur-Programm
> Bearbeitungsgruppe Flächen
> Bearbeitungsgruppe Sonder UNITs
> Hauptgruppe Antasten
> Funktionsgruppe Rotation
> Funktionsgruppe Preset (Bezugspunkt)
> Funktionsgruppe Messen
> Funktionsgruppe Sonderfunktionen
> Funktionsgruppe Kinematikvermessung (Option)
> Funktionsgruppe Werkzeug
> Hauptgruppe Umrechnen
> Hauptgruppe Sonder-Funktionen


Grundlagen

Bearbeitungen in smarT.NC definieren Sie grundsätzlich als Bearbeitungsschritte (Units), die in der Regel aus mehreren Klartext-Dialog-Sätzen bestehen. Die Klartext-Dialog-Sätze erzeugt smarT.NC automatisch im Hintergrund in einer .HU-Datei (HU: HEIDENHAIN Unit-Programm), die wie ein normales Klartext-Dialog-Programm aussieht.

Die eigentliche Bearbeitung wird in der Regel von einem in der TNC verfügbaren Zyklus ausgeführt, dessen Parameter von Ihnen über die Eingabefelder der Formulare festgelegt werden.

Einen Bearbeitungsschritt können Sie bereits durch wenige Eingaben im Übersichts-Formular 1 definieren (siehe Bild rechts oben). smarT.NC führt die Bearbeitung dann mit Grundfunktionalität aus. Um zusätzliche Bearbeitungsdaten eingeben zu können, stehen Detailformulare 2 zur Verfügung. Eingabewerte in den Detailformularen werden mit den Eingabewerten des Übersichts-Formulars automatisch synchronisiert, müssen also nicht doppelt eingegeben werden. Folgende Detailformulare stehen zur Verfügung:

  • Detailformular Werkzeug (3)
    Im Detailformular Werkzeug können Sie zusätzliche werkzeugspezifische Daten eingeben, z.B. Delta-Werte für Länge und Radius oder Zusatz-Funktionen M
  • Detailformular optionale Parameter (4)
    In Detailformular optionale Parameter können Sie zusätzliche Bearbeitungsparameter definieren, die im Übersichtsformular nicht aufgeführt sind, z.B. Abnahmebeträge beim Bohren oder Taschenlagen beim Fräsen
  • Detailformular Positionen (5)
    Im Detailformular Positionen können Sie zusätzliche Bearbeitungspositionen definieren, wenn die drei Bearbeitungsorte des Übersichtsformulars nicht ausreichen. Wenn Sie Bearbeitungspositionen in Punkte-Dateien definieren, enthält das Detailformular Positionen ebenso wie das Übersichtsformular lediglich den Dateinamen der jeweiligen Punkte-Datei siehe Grundlagen
  • Detailformular globale Daten (6)
    In Detailformular globale Daten sind die im Programmkopf definierten global wirksamen Bearbeitungsparameter aufgeführt. Bei Bedarf können Sie diese Parameter für die jeweilige Unit lokal abändern


Programm-Einstellungen

Nachdem Sie ein neues Unit-Programm eröffnet haben, fügt smarT.NC automatisch die Unit 700 Programm-Einstellungen ein.

Die Unit 700 Programm-Einstellungen muss in jedem Programm zwingend vorhanden sein, ansonsten kann dieses Programm von smarT.NC nicht abgearbeitet werden.

In den Programm-Einstellungen müssen folgende Daten definiert sein:

  • Rohteil-Definition zur Festlegung der Bearbeitungsebene und für die grafische Simulation
  • Optionen, für die Auswahl des Werkstück-Bezugspunktes und die zu verwendende Null-punkt-Tabelle
  • Globale Daten, die für das komplette Programm gelten. Die globalen Daten werden von smarT.NC automatisch mit Defaultwerten vorbelegt und sind jederzeit änderbar

Beachten Sie, dass sich nachträgliche Änderungen der Programm-Einstellungen auf das gesamte Bearbeitungsprogramm auswirken und somit den Bearbeitungsablauf erheblich verändern können.
Weitere Informationen:
> Globale Daten
> Allgemeingültige globale Daten
> Globale Daten für das Positionierverhalten
> Globale Daten für Bohrbearbeitungen
> Globale Daten für Fräsbearbeitungen mit Taschenzyklen
> Globale Daten für Fräsbearbeitungen mit Konturzyklen
> Globale Daten für Antastfunktionen


Globale Daten

Die globalen Daten sind in sechs Gruppen unterteilt:

  • Allgemeingültige globale Daten
  • Globale Daten, die ausschließlich für Bohrbearbeitungen gelten
  • Globale Daten, die das Positionierverhalten festlegen
  • Globale Daten, die ausschließlich für Fräsbearbeitungen mit Taschen-zyklen gelten
  • Globale Daten, die ausschließlich für Fräsbearbeitungen mit Konturzy-klen gelten
  • Globale Daten, die ausschließlich für Antastfunktionen gelten

Wie zuvor bereits erwähnt, gelten die globalen Daten für das komplette Bearbeitungs-Programm. Selbstverständlich können Sie bei Bedarf für jeden Bearbeitungsschritt die globalen Daten ändern:

  • Wechseln Sie dazu in das Detailformular Globale Daten des Bearbeitungsschrittes: Im Formular zeigt smarT.NC die für den jeweiligen Bearbeitungsschritt gültigen Parameter mit dem jeweils aktiven Wert an. Auf der rechten Seite des grünen Eingabefeldes steht ein G als Kennung dafür, das der jeweilige Wert global gültig ist

  • Globalen Parameter wählen, den Sie verändern wollen

  • Neuen Wert eingeben und mit Taste ENTER bestätigen, smarT.NC ändert die Farbe des Eingabefeldes auf rot

  • Auf der rechten Seite des roten Eingabefeldes steht jetzt ein L als Kennung für einen lokal wirksamen Wert

Die Änderung eines globalen Parameters über das Detailformular Globale Daten bewirkt lediglich eine lokale, für den jeweiligen Bearbeitungsschritt gültige, Änderung des Parameters. Das Eingabefeld lokal veränderter Parameter zeigt smarT.NC mit rotem Hintergrund an. Rechts neben dem Eingabefeld steht ein L als Kennung für einen lokalen Wert.

Über den Softkey standardwert setzen können Sie den Wert des globalen Parameters aus dem Programm-Kopf wieder laden und somit aktivieren. Das Eingabefeld eines globalen Parameters, dessen Wert aus dem Programm-Kopf wirkt, zeigt smarT.NC mit grünem Hintergrund an. Rechts neben dem Eingabefeld steht ein G als Kennung für einen globalen Wert.


Allgemeingültige globale Daten

  • Sicherheits-Abstand: Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche beim automatischen Anfahren der Zyklus-Startposition in der Werkzeug-Achse

  • 2. Sicherheits-Abstand: Position, auf die smarT.NC das Werkzeug am Ende eines Bearbeitungsschrittes positioniert. Auf dieser Höhe wird die nächste Bearbeitungsposition in der Bearbeitungsebene angefahren

  • F Positionieren: Vorschub, mit dem smarT.NC das Werkzeug innerhalb eines Zyklus verfährt

  • F Rückzug: Vorschub, mit dem smarT.NC das Werkzeug zurückpositioniert


Globale Daten für das Positionierverhalten

  • Positionier-Verhalten: Rückzug in der Werkzeug-Achse am Ende eines Bearbeitungsschrittes: Auf 2. Sicherheits-Abstand oder auf die Position am Unit-Anfang zurückziehen


Globale Daten für Bohrbearbeitungen

  • Rückzug Spanbruch: Wert, um den smarT.NC das Werkzeug beim Spanbrechen zurückzieht

  • Verweilzeit unten: Zeit in Sekunden, die das Werkzeug am Bohrungsgrund verweilt

  • Verweilzeit oben: Zeit in Sekunden, die das Werkzeug auf Sicherheits-Abstand verweilt


Globale Daten für Fräsbearbeitungen mit Taschenzyklen

  • Überlappungs-Faktor: Werkzeug-Radius x Überlappungsfaktor ergibt die seitliche Zustellung

  • Fräsart: Gleichlauf/Gegenlauf

  • Eintauchart: helixförmig, pendelnd oder senkrecht ins Material eintauchen


Globale Daten für Fräsbearbeitungen mit Konturzyklen

  • Sicherheits-Abstand: Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche beim automatischen Anfahren der Zyklus-Startposition in der Werkzeug-Achse

  • Sichere Höhe: Absolute Höhe, in der keine Kollision mit dem Werkstück erfolgen kann (für Zwischenpositionierungen und Rückzug am Zyklus-Ende)

  • Überlappungs-Faktor: Werkzeug-Radius x Überlappungsfaktor ergibt die seitliche Zustellung

  • Fräsart: Gleichlauf/Gegenlauf


Globale Daten für Antastfunktionen

  • Sicherheits-Abstand: Abstand zwischen Taststift und Werkstück-Oberfläche beim automatischen Anfahren der Antastposition

  • Sichere Höhe: Koordinate in der Tastsystem-Achse, auf der smarT.NC das Tastsystem zwischen Messpunkten verfährt, sofern Option Fahren auf sichere Höhe aktiviert ist

  • Fahren auf sichere Höhe: Wählen, ob smarT.NC zwischen Messpunkten auf Sicherheits-Abstand oder auf sicherer Höhe verfahren soll


Werkzeug-Auswahl

Sobald ein Eingabefeld zur Werkzeug-Auswahl aktiv ist, können Sie per Softkey werkzeug-name wählen, ob Sie die Werkzeug-Nummer oder den Werkzeug-Namen eingeben wollen.

Darüber hinaus können Sie per Softkey wählen ein Fenster einblenden, über das Sie ein in der Werkzeug-Tabelle TOOL.T definiertes Werkzeug wählen können. smarT.NC schreibt die Werkzeug-Nummer bzw. den Werkzeug-Namen des gewählten Werkzeuges dann automatisch in das entsprechende Eingabefeld.

Bei Bedarf können Sie die angezeigten Werkzeugdaten auch editieren:

  • Per Pfeiltasten die Zeile und anschließend die Spalte des zu editierenden Wertes wählen: Der hellblaue Rahmen kennzeichnet das editierbare Feld

  • Softkey editieren auf ein stellen, gewünschten Wert eingeben und mit Taste ENT bestätigen

  • Bei Bedarf weitere Spalten wählen und zuvor beschriebene Vorgehensweise erneut durchführen


Umschaltung Drehzahl /Schnittgeschwindigkeit

Sobald ein Eingabefeld zur Definition der Spindeldrezahl aktiv ist, können Sie wählen, ob Sie die Drehzahl in U/min oder eine Schnittgeschwindigkeit in m/min [bzw. inch/min] eingeben wollen.

Um eine Schnittgeschwindigkeit einzugeben

  • Softkey VC drücken: Die TNC schaltet das Eingabefeld um

Um von Schnittgeschwindigkeit auf Drehzahleingabe umzuschalten

  • Taste NO ENT drücken: Die TNC löscht die Schnittgeschwindigkeits-Eingabe

  • Um Drehzahl einzugeben: Mit Pfeiltaste zurück auf das Eingabefeld cursorn


Umschaltung F/FZ/FU/FMAX

Sobald ein Eingabefeld zur Definition eines Vorschubes aktiv ist, können Sie wählen, ob Sie den Vorschub in mm/min (F), in U/min (FU) oder in mm/Zahn (FZ) eingeben wollen. Welche Vorschubalternativen erlaubt sind, hängt von der jeweiligen Bearbeitung ab. Bei einigen Eingabefeldern ist auch die Eingabe FMAX (Eilgang) erlaubt.

Um eine Vorschubalternative einzugeben

  • Softkey F, FZ, FU oder FMAX drücken


Daten aus vorheriger, gleichartiger Unit übernehmen

Nachdem Sie eine neue Unit eröffnet haben, können Sie über den Softkey unit-daten übernehmen alle Daten einer zuvor definierten, gleichartigen Unit übernehmen. smarT.NC übernimmt dann alle in dieser Unit definierten Werte, und trägt diese in die aktive Unit ein.

Insbesondere bei den Fräs-Units können Sie auf diese Weise besonders einfach Schrupp-/Schlichtbearbeitungen definieren, indem Sie z.B. bei der Folgeunit nach der Datenübernahme lediglich das Aufmaß und bei Bedarf auch das Werkzeug korrigieren.

smarT.NC durchsucht das smarT-Programm zunächst nach oben auf eine gleichartige Unit:

  • Sollte smarT.NC bis zum Programmanfang keine entsprechende Unit gefunden haben, dann startet die Suche am Programmende bis zum aktuellen Satz.
  • Wenn smarT.NC im gesamten Programm keine entsprechende Unit findet, zeigt die Steuerung eine Fehlermeldung an.


Verfügbare Bearbeitungsschritte (Units)

Nach Anwahl der Betriebsart smarT.NC wählen Sie über den Softkey einfügen die verfügbaren Bearbeitungsschritte an. Die Bearbeitungsschritte sind in folgende Hauptgruppen unterteilt:

Hauptgruppe | Softkey | Seite
Bearbeiten: Bohren, Gewindebearbeitung, Fräsen |  | Hauptgruppe Bearbeiten
Antasten: Antast-Funktionen für 3D-Tastsystem |  | Hauptgruppe Antasten
Umrechnen: Funktionen zur Koordinaten-Umrechnung |  | Hauptgruppe Umrechnen
Sonderfunktionen: Programm-Aufruf, Positionier-Unit, M-Funktions-Unit, Klartext-Dialog-Unit, Programm-Ende-Unit |  | Hauptgruppe Sonder-Funktionen

Die Softkeys kontur-pgm und positionen auf der dritten Softkey-Leiste, starten die Kontur-Programmierung bzw. den Mustergenerator.


Hauptgruppe Bearbeiten

In der Hauptgruppe Bearbeiten wählen Sie folgende Bearbeitungsgruppen aus:

Bearbeitungsgruppe | Softkey | Seite
Bohren: Zentrieren, Bohren, Reiben, Ausdrehen, Rückwärts-Senken |  | Bearbeitungsgruppe Bohren
Gewinde: Gewindebohren mit und ohne Ausgleichsfutter, Gewindefräsen |  | Bearbeitungsgruppe Gewinde
Taschen/zapfen: Bohrfräsen, Rechtecktasche, Kreistasche, Nut, runde Nut |  | Bearbeitungsgruppe Taschen/Zapfen
kontur-pgm: Kontur-Programme bearbeiten: Konturzug, Konturtasche schruppen, nachräumen und schlichten |  | Bearbeitungsgruppe Kontur-Programm
flächen: Planfräsen |  | Bearbeitungsgruppe Flächen
SONDER UNITS: Gravieren und Interpolationsdrehen |  | Bearbeitungsgruppe Sonder UNITs


Bearbeitungsgruppe Bohren

In der Bearbeitungsgruppe Bohren stehen folgende Units für die Bohrbearbeitung zur Verfügung:

Unit | Softkey | Seite
Unit 240 Zentrieren |  | Unit 240 Zentrieren
Unit 205 Bohren |  | Unit 205 Bohren
Unit 201 Reiben |  | Unit 201 Reiben
Unit 202 Ausdrehen |  | Unit 202 Ausdrehen
Unit 204 Rückwärts-Senken |  | Unit 204 Rückwärts-Senken
Unit 241 Einlippen-Bohren |  | Unit 241 Einlippen-Bohren
Weitere Informationen:
> Unit 240 Zentrieren
> Unit 205 Bohren
> Unit 201 Reiben
> Unit 202 Ausdrehen
> Unit 204 Rückwärts-Senken
> Unit 241 Einlippen-Bohren


Unit 240 Zentrieren

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Zentriervorschub [mm/min] oder FU [mm/U]

  • Auswahl Tiefe/Durchmesser: Auswahl, ob auf Tiefe oder auf Durchmesser zentriert werden soll

  • Durchmesser: Zentrierdurchmesser. Eingabe von T-ANGLE in TOOL.T erforderlich

  • Tiefe: Zentriertiefe

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Keine

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Verweilzeit unten

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Unit 205 Bohren

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Bohrvorschub [mm/min] oder FU [mm/U]

  • Tiefe: Bohrtiefe

  • Zustell-Tiefe: Maß, um welches das Werkzeug vor dem Herausfahren aus der Bohrung jeweils zugestellt wird

  • Tiefe Spanbruch: Zustellung, nach der smarT.NC einen Spanbruch durchführt

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Tiefe Spanbruch: Zustellung, nach der smarT.NC einen Spanbruch durchführt

  • Abnahmebetrag: Wert, um den smarT.NC die Zustell-Tiefe verkleinert

  • Min. Zustellung: Wenn Abnahmebetrag eingegeben: Begrenzung für minimale Zustellung

  • Vorhalteabstand oben: Sicherheits-Abstand oben beim Rückpositionieren nach Spanbruch

  • Vorhalteabst. unten: Sicherheits-Abstand unten beim Rückpositionieren nach Spanbruch

  • Startpunkt Zustellung: Vertiefter Startpunkt bezogen auf die Koordinate Oberfläche bei vorbearbeiteten Bohrungen

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Rückzugsbetrag bei Spanbruch

Verweilzeit unten

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Unit 201 Reiben

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Reibvorschub [mm/min] oder FU [mm/U]

  • Tiefe: Reibtiefe

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Keine.

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Vorschub Rückzug

Verweilzeit unten

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Unit 202 Ausdrehen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Bohrvorschub [mm/min] oder FU [mm/U]

  • Tiefe: Ausdrehtiefe

  • Freifahr-Richtung: Richtung, in der smarT.NC das Werkzeug am Bohrungsgrund freifährt

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Winkel Spindel: Winkel, auf den smarT.NC das Werkzeug vor dem Freifahren positioniert

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Vorschub Rückzug

Verweilzeit unten

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Unit 204 Rückwärts-Senken

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Bohrvorschub [mm/min] oder FU [mm/U]

  • Senktiefe: Tiefe der Senkung

  • Materialstärke: Dicke des Werkstücks

  • Exzentermaß: Exzentermaß der Bohrstange

  • Schneidenhöhe: Abstand Unterkante Bohrstange – Hauptschneide

  • Freifahr-Richtung: Richtung, in der smarT.NC das Werkzeug um das Exzentermaß versetzen soll

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Winkel Spindel: Winkel, auf den smarT.NC das Werkzeug vor dem Eintauchen und vor dem Herausfahren aus der Bohrung positioniert

  • Verweilzeit: Verweilzeit am Senkungsgrund

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Vorschub Positionieren

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Unit 241 Einlippen-Bohren

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] beim Bohren

  • F: Bohrvorschub [mm/min] oder FU [mm/U]

  • Tiefe: Bohrtiefe

  • Startpunkt Zust.: Startpunkt der eigentlichen Bohrbearbeitung. Die TNC fährt im Vorschub Vorpositionieren vom Sicherheits-Abstand auf den vertieften Startpunkt

  • Drehrich. ein-/ausfahren: Drehrichtung der Spindel beim Einfahren in die Bohrung und beim Herausfahren aus der Bohrung drehen soll

  • Drehzahl Einfahren: Drehzahl, mit der das Werkzeug beim Einfahren in die Bohrung und beim Herausfahren aus der Bohrung drehen soll

  • Kühlmittel EIN: M?: Zusatz-Funktion M zum Einschalten des Kühlmittels. Die TNC schaltet das Kühlmittel ein, wenn das Werkzeug in der Bohrung auf dem vertieften Startpunkt steht

  • Kühlmittel AUS: M?: Zusatz-Funktion M zum Ausschalten des Kühlmittels. Die TNC schaltet das Kühlmittel aus, wenn das Werkzeug auf der Bohrtiefe steht

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Verweiltiefe: Koordinate Spindelachse, auf der das Werkzeug verweilen soll. Funktion ist nicht aktiv bei Eingabe von 0

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Vorschub Positionieren

Verweilzeit unten

Vorschub Rückzug

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Bearbeitungsgruppe Gewinde

In der Bearbeitungsgruppe Gewinde stehen folgende Units für die Gewindebearbeitung zur Verfügung:

Unit | Softkey | Seite
Unit 206 Gewindebohren mit Ausgleichsfutter |  | Unit 206 Gewindebohren mit Ausgleichsfutter
Unit 209 Gewindebohren ohne Ausgleichsfutter (auch mit Spanbruch) |  | Unit 209 Gewindebohren ohne Ausgleichsfutter
Unit 262 Gewindefräsen |  | Unit 262 Gewindefräsen
Unit 263 Senkgewindefräsen |  | Unit 263 Senkgewindefräsen
Unit 264 Bohrgewindefräsen |  | Unit 264 Bohrgewindefräsen
Unit 265 Helix-Bohrgewindefräsen |  | Unit 265 Helix-Bohrgewindefräsen
Unit 267 Außengewindefräsen |  | Unit 267 Gewindefräsen
Weitere Informationen:
> Unit 206 Gewindebohren mit Ausgleichsfutter
> Unit 209 Gewindebohren ohne Ausgleichsfutter
> Unit 262 Gewindefräsen
> Unit 263 Senkgewindefräsen
> Unit 264 Bohrgewindefräsen
> Unit 265 Helix-Bohrgewindefräsen
> Unit 267 Gewindefräsen


Unit 206 Gewindebohren mit Ausgleichsfutter

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Bohrvorschub: Berechnen aus S x Gewindesteigung p

  • Gewindetiefe: Tiefe des Gewindes

  • Bearbeitungspositionen siehe Grundlagen

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Keine.

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Verweilzeit unten

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Unit 209 Gewindebohren ohne Ausgleichsfutter

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • Gewindetiefe: Tiefe des Gewindes

  • Gewindesteigung: Steigung des Gewindes

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Tiefe Spanbruch: Zustellung, nach der ein Spanbruch erfolgen soll

  • Winkel Spindel: Winkel, auf den smarT.NC das Werkzeug vor dem Gewindeschneid-Vorgang positionieren soll: Dadurch Gewinde bei Bedarf nachschneidbar

  • Faktor für S bei Rückzug Q403: Faktor, um den die TNC die Spindeldrehzahl - und damit auch den Rückzugsvorschub - beim Herausfahren aus der Bohrung erhöht

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Rückzugsbetrag bei Spanbruch

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Unit 262 Gewindefräsen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Fräsvorschub

  • Durchmesser: Nenndurchmesser des Gewindes

  • Gewindesteigung: Steigung des Gewindes

  • Tiefe: Gewindetiefe

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Nachsetzen Gänge: Anzahl der Gewindegänge, um die das Werkzeug versetzt wird

  • Vorschub anfahren: Vorschub zum Einfahren in das Gewinde

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Positioniervorschub

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Unit 263 Senkgewindefräsen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Fräsvorschub

  • F: Senkvorschub [mm/min] oder FU [mm/U]

  • Durchmesser: Nenndurchmesser des Gewindes

  • Gewindesteigung: Steigung des Gewindes

  • Tiefe: Gewindetiefe

  • Senktiefe: Abstand zwischen Werkstück-Oberfläche und Werkzeug-Spitze beim Senken

  • Abstand Seite: Abstand zwischen Werkzeugschneide und Bohrungswand

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Senktiefe stirnseitig: Senktiefe beim stirnseitigen Senken

  • Versatz stirnseitig: Abstand, um den die TNC die Werkzeugmitte beim stirnseitigen Senken aus der Bohrung versetzt

  • Vorschub anfahren: Vorschub zum Einfahren in das Gewinde

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Positioniervorschub

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Unit 264 Bohrgewindefräsen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Fräsvorschub

  • F: Bohrvorschub [mm/min] oder FU [mm/U]

  • Durchmesser: Nenndurchmesser des Gewindes

  • Gewindesteigung: Steigung des Gewindes

  • Tiefe: Gewindetiefe

  • Bohrtiefe: Bohrtiefe

  • Zustell-Tiefe Bohren

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Tiefe Spanbruch: Zustellung, nach dem die TNC beim Bohren einen Spanbruch durchführen soll

  • Vorhalteabstand oben: Sicherheits-Abstand, wenn die TNC das Werkzeug nach einem Spanbruch wieder auf die aktuelle Zustell-Tiefe fährt

  • Senktiefe stirnseitig: Senktiefe beim stirnseitigen Senken

  • Versatz stirnseitig: Abstand, um den die TNC die Werkzeugmitte aus der Bohrungsmitte versetzt

  • Vorschub anfahren: Vorschub zum Einfahren in das Gewinde

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Positioniervorschub

Rückzugsbetrag bei Spanbruch

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Unit 265 Helix-Bohrgewindefräsen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Fräsvorschub

  • F: Senkvorschub [mm/min] oder FU [mm/U]

  • Durchmesser: Nenndurchmesser des Gewindes

  • Gewindesteigung: Steigung des Gewindes

  • Tiefe: Gewindetiefe

  • Senkvorgang: Auswahl, ob vor oder nach dem Gewindefräsen gesenkt werden soll

  • Senktiefe stirnseitig: Senktiefe beim stirnseitigen Senken

  • Versatz stirnseitig: Abstand, um den die TNC die Werkzeugmitte aus der Bohrungsmitte versetzt

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Keine.

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Positioniervorschub

Vorschub beim Verfahren zwischen Bearbeitungspositionen


Unit 267 Gewindefräsen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Fräsvorschub

  • F: Senkvorschub [mm/min] oder FU [mm/U]

  • Durchmesser: Nenndurchmesser des Gewindes

  • Gewindesteigung: Steigung des Gewindes

  • Tiefe: Gewindetiefe

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Nachsetzen Gänge: Anzahl der Gewindegänge, um die das Werkzeug versetzt wird

  • Senktiefe stirnseitig: Senktiefe beim stirnseitigen Senken

  • Versatz stirnseitig: Abstand, um den die TNC die Werkzeugmitte aus der Zapfenmitte versetzt

  • Vorschub anfahren: Vorschub zum Einfahren in das Gewinde

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Positioniervorschub

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Bearbeitungsgruppe Taschen/Zapfen

In der Bearbeitungsgruppe Taschen/Zapfen stehen folgende Units für die Fräsbearbeitung von einfachen Taschen, Zapfen und Nuten zur Verfügung:

Unit | Softkey | Seite
Unit 251 Rechtecktasche |  | Unit 251 Rechtecktasche
Unit 252 Kreistasche |  | Unit 252 Kreistasche
Unit 253 Nut |  | Unit 253 Nut
Unit 254 Runde Nut |  | Unit 254 Runde Nut
Unit 256 Rechteckzapfen |  | Unit 256 Rechteckzapfen
Unit 257 Kreiszapfen |  | Unit 257 Kreiszapfen
Unit 208 Bohrfräsen |  | Unit 208 Bohrfräsen
Weitere Informationen:
> Unit 251 Rechtecktasche
> Unit 252 Kreistasche
> Unit 253 Nut
> Unit 254 Runde Nut
> Unit 256 Rechteckzapfen
> Unit 257 Kreiszapfen
> Unit 208 Bohrfräsen


Unit 251 Rechtecktasche

Parameter im Formular Übersicht:

  • Bearbeitungs-Umfang: Schruppen und schlichten, nur schruppen oder nur schlichten per Softkey wählen

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Taschenlänge: Länge der Tasche in der Hauptachse

  • Taschenbreite: Breite der Tasche in der Nebenachse

  • Eckenradius: Wenn nicht eingegeben, setzt smarT.NC den Eckenradius gleich dem Werkzeug-Radius

  • Tiefe: Endtiefe der Tasche

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Taschenparameter:

  • Aufmaß Seite: Schlichtaufmaß Seite

  • Aufmaß Tiefe: Schlichtaufmaß Tiefe

  • Zustellung Schlichten: Zustellung für Schlichten Seite. Wenn nicht eingegeben, dann schlichten mit 1 Zustellung

  • F Schlichten: Vorschub fürs Schlichten [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Drehlage: Winkel, um den die gesamte Tasche gedreht wird

  • Taschenlage: Lage der Tasche bezogen auf die programmierte Position

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Überlappungsfaktor

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf

Helixförmig eintauchen, oder

Pendelnd eintauchen, oder

Senkrecht eintauchen


Unit 252 Kreistasche

Parameter im Formular Übersicht:

  • Bearbeitungs-Umfang: Schruppen und schlichten, nur schruppen oder nur schlichten per Softkey wählen

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Durchmesser: Fertigteil-Durchmesser der Kreistasche

  • Tiefe: Endtiefe der Tasche

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Bearbeitungspositionen siehe Grundlagen

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Taschenparameter:

  • Aufmaß Seite: Schlichtaufmaß Seite

  • Aufmaß Tiefe: Schlichtaufmaß Tiefe

  • Zustellung Schlichten: Zustellung für Schlichten Seite. Wenn nicht eingegeben, dann schlichten mit 1 Zustellung

  • F Schlichten: Vorschub fürs Schlichten [mm/min], FU [mm/U] oder FZ [mm/Zahn]

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Überlappungsfaktor

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf

Helixförmig eintauchen, oder

Senkrecht eintauchen


Unit 253 Nut

Parameter im Formular Übersicht:

  • Bearbeitungs-Umfang: Schruppen und schlichten, nur schruppen oder nur schlichten per Softkey wählen

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Nutlänge: Länge der Nut in der Hauptachse

  • Nutbreite: Breite der Nut in der Nebenachse

  • Tiefe: Endtiefe der Nut

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Bearbeitungspositionen siehe Grundlagen

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Taschenparameter:

  • Aufmaß Seite: Schlichtaufmaß Seite

  • Aufmaß Tiefe: Schlichtaufmaß Tiefe

  • Zustellung Schlichten: Zustellung für Schlichten Seite. Wenn nicht eingegeben, dann schlichten mit 1 Zustellung

  • F Schlichten: Vorschub fürs Schlichten [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Drehlage: Winkel, um den die gesamte Tasche gedreht wird

  • Nutlage: Lage der Nut bezogen auf die programmierte Position

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf

Helixförmig eintauchen, oder

Pendelnd eintauchen, oder

Senkrecht eintauchen


Unit 254 Runde Nut

Parameter im Formular Übersicht:

  • Bearbeitungs-Umfang: Schruppen und schlichten, nur schruppen oder nur schlichten per Softkey wählen

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Mitte 1. Achse: Teilkreis-Mitte Hauptachse

  • Mitte 2. Achse: Teilkreis-Mitte Nebenachse

  • Teilkreis-Durchmesser

  • Startwinkel: Polarwinkel des Startpunktes

  • Öffnungswinkel

  • Nutbreite

  • Tiefe: Endtiefe der Nut

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Taschenparameter:

  • Aufmaß Seite: Schlichtaufmaß Seite

  • Aufmaß Tiefe: Schlichtaufmaß Tiefe

  • Zustellung Schlichten: Zustellung für Schlichten Seite. Wenn nicht eingegeben, dann schlichten mit 1 Zustellung

  • F Schlichten: Vorschub fürs Schlichten [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Winkelschritt: Winkel, um den die gesamte Nut weiter gedreht wird

  • Anzahl Bearbeitungen: Anzahl Bearbeitungen auf dem Teilkreis

  • Nutlage: Lage der Nut bezogen auf die programmierte Position

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf

Helixförmig eintauchen, oder

Pendelnd eintauchen, oder

Senkrecht eintauchen


Unit 256 Rechteckzapfen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Zapfenlänge: Länge des Zapfens in der Hauptachse

  • Rohteilmaß Länge: Länge des Rohteils in der Hauptachse

  • Zapfenbreite: Breite des Zapfens in der Nebenachse

  • Rohteilmaß Breite: Breite des Rohteils in der Hauptachse

  • Eckenradius: Radius an der Zapfenecke

  • Tiefe: Endtiefe des Zapfens

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Zapfenparameter:

  • Aufmaß Seite: Schlichtaufmaß Seite

  • Drehlage: Winkel, um den der gesamte Zapfen gedreht wird

  • Zapfenlage: Lage des Zapfens bezogen auf die programmierte Position

  • Anfahrposition: Festlegung der Anfahrposition am Zapfen

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Überlappungsfaktor

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Unit 257 Kreiszapfen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Fertigteil-Durchmesser: Fertigteil-Durchmesser des Kreiszapfens

  • Rohteil-Durchmesser: Rohteil-Durchmesser des Kreiszapfens

  • Tiefe: Endtiefe des Zapfens

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Bearbeitungspositionen siehe Grundlagen

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Zapfenparameter:

  • Aufmaß Seite: Schlichtaufmaß Seite

  • Startwinkel: Polarwinkel bezogen auf die Zapfenmitte, von dem aus das Werkzeug an den Zapfen anfahren soll

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Überlappungsfaktor

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Unit 208 Bohrfräsen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Durchmesser: Soll-Durchmesser der Bohrung

  • Tiefe: Frästiefe

  • Zustell-Tiefe: Maß, um welches das Werkzeug auf einer Schraubenlinie (360°) jeweils zugestellt wird

  • Bearbeitungspositionen (siehe „Bearbeitungspositionen definieren” auf Seite 164)

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Bohrparameter:

  • Vorgebohrter Durchmesser: Eingeben, wenn vorgefertigte Bohrungen nachbearbeitet werden sollen. Dadurch können Sie Bohrungen ausfräsen, die mehr als doppelt so groß wie der Werkzeug-Durchmesser sind

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Vorschub beim Verfahren zwischen Bearbeitungspositionen

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Bearbeitungsgruppe Kontur-Programm

In der Bearbeitungsgruppe Kontur-Programm stehen folgende Units für die Bearbeitung beliebig geformter Taschen und Konturzüge zur Verfügung:

Unit | Softkey | Seite
Unit 122 Konturtasche ausräumen |  | Unit 122 Konturtasche
Unit 22 Konturtasche nachräumen |  | Unit 22 Nachräumen
Unit 123 Konturtasche Schlichten Tiefe |  | Unit 123 Konturtasche Schlichten Tiefe
Unit 124 Konturtasche Schlichten Seite |  | Unit 124 Konturtasche Schlichten Seite
Unit 125 Konturzug |  | Unit 125 Konturzug
Unit 275 Konturzug trochoidal |  | Unit 275 Konturnut
Unit 276 Konturzug 3D |  | Unit 276 Konturzug 3D
Unit 130 Konturtasche auf Punktemuster |  | Unit 130 Kontutasche auf Punktemuster (FCL 3-Funktion)
Weitere Informationen:
> Unit 122 Konturtasche
> Unit 22 Nachräumen
> Unit 123 Konturtasche Schlichten Tiefe
> Unit 124 Konturtasche Schlichten Seite
> Unit 125 Konturzug
> Unit 275 Konturnut
> Unit 276 Konturzug 3D
> Unit 130 Kontutasche auf Punktemuster (FCL 3-Funktion)


Unit 122 Konturtasche

Mit der Konturtasche können Sie beliebig geformte Taschen, die auch Inseln enthalten dürfen, ausräumen.

Wenn erforderlich, können Sie im Detailformular Kontur jeder Teilkontur eine separate Tiefe zuweisen (FCL 2-Funktion). In diesem Fall müssen Sie immer mit der tiefsten Tasche beginnen.

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Einpendeln [mm/min], FU [mm/U] oder FZ [mm/Zahn]. 0 eingeben, wenn senkrecht eingetaucht werden soll

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Koordinate Oberfläche: Koordinate der Werkstück-Oberfläche, auf die sich eingegebene Tiefen beziehen

  • Tiefe: Frästiefe

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Aufmaß Seite: Schlichtaufmaß Seite

  • Aufmaß Tiefe: Schlichtaufmaß Tiefe

  • Konturname: Liste der Teilkonturen (.HC-Dateien) die verknüpft werden sollen. Wenn Option DXF-Konverter verfügbar ist, dann können Sie direkt aus dem Formular heraus eine Kontur mit dem DXF-Konverter erstellen

  • Per Softkey bestimmen, ob die jeweilige Teilkontur eine Tasche oder eine Insel ist!
  • Liste der Teilkonturen grundsätzlich immer mit der tiefsten Tasche beginnen!
  • Maximal können Sie im Detailformular Kontur bis zu 9 Teilkonturen definieren!

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Rundungs-Radius: Verrundungs-Radius der Werkzeug--Mittelpunktsbahn an den Innen-Ecken

  • Vorschubfaktor in %: Prozentualer Faktor, um den die TNC den Bearbeitungs-Vorschub reduziert, sobald das Werkzeug beim Ausräumen mit dem vollen Umfang im Material verfährt. Wenn Sie die Vorschubreduzierung nutzen, dann können Sie den Vorschub Ausräumen so groß definieren, dass bei der festgelegten Bahn-Überlappung (globale Daten) optimale Schnittbedingungen herrschen. Die TNC reduziert dann an Übergängen oder Engstellen den Vorschub wie von Ihnen definiert, so dass die Bearbeitungszeit insgesamt kleiner sein sollte

Zusätzliche Parameter im Detailformular Kontur:

  • Tiefe: Separat definierbare Tiefen für jede Teilkontur (FCL 2-Funktion)

  • Liste der Teilkonturen grundsätzlich immer mit der tiefsten Tasche beginnen!
  • Wenn die Kontur als Insel definiert ist, dann interpretiert die TNC die eingegebene Tiefe als Inselhöhe. Der eingegebene, vorzeichenlose Wert bezieht sich dann auf die Werkstück-Oberfläche!
  • Wenn Tiefe mit 0 eingegeben ist, dann wirkt bei Taschen die im Übersichtsformular definierte Tiefe, Inseln ragen dann bis zur Werkstück-Oberfläche!

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Überlappungsfaktor

Vorschub Rückzug

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Unit 22 Nachräumen

Mit der Unit Nachräumen können Sie eine zuvor mit der Unit 122 ausgeräumte Konturtasche mit einem kleineren Werkzeug nachbearbeiten. smarT.NC bearbeitet dann nur die Stellen, an denen Restmaterial vorhanden ist.

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Vorräum-Werkzeug: Nummer oder Name des Werkzeugs (per Softkey umschaltbar), mit dem Sie die Konturtasche vorgeräumt haben

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Nachräumstrategie. Dieser Parameter ist nur wirksam, wenn der Radius des Nachräumwerkzeuges größer als die Hälfte des Radius des Vorräumwerkzeuges ist:

Das Werkzeug zwischen nachzuräumenden Bereichen auf aktueller Tiefe entlang der Kontur verfahren

Das Werkzeug zwischen nachzuräumenden Bereichen auf Sicherheits-Abstand abheben und zum Startpunkt des nächsten Ausräumbereiches fahren

Global wirksame Parameter im Detailformular Globale Daten:

Vorschub Rückzug


Unit 123 Konturtasche Schlichten Tiefe

Mit der Unit Schlichten Tiefe können Sie eine zuvor mit der Unit 122 ausgeräumte Konturtasche tiefenschlichten.

Schlichten Tiefe grundsätzlich immer vor Schlichten Seite ausführen!

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Global wirksame Parameter im Detailformular Globale Daten:

Vorschub Rückzug


Unit 124 Konturtasche Schlichten Seite

Mit der Unit Schlichten Seite können Sie eine zuvor mit der Unit 122 ausgeräumte Konturtasche seitenschlichten.

Schlichten Seite grundsätzlich immer nach Schlichten Tiefe ausführen!

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Aufmaß Seite Schlichten: Schlichtaufmaß, wenn in mehreren Schritten geschlichtet werden soll

Global wirksame Parameter im Detailformular Globale Daten:

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Unit 125 Konturzug

Mit dem Konturzug lassen sich offene und geschlossene Konturen bearbeiten, die Sie in einem .HC-Programm definiert, oder mit dem DXF-Konverter erzeugt haben.

Start- und Endpunkt der Kontur so wählen, das genügend Platz für An- und Wegfahrbewegungen vorhanden ist!

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Koordinate Oberfläche: Koordinate der Werkstück-Oberfläche, auf die sich eingegebene Tiefen beziehen

  • Tiefe: Frästiefe

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Aufmaß Seite: Schlichtaufmaß

  • Fräsart: Gleichlauffräsen, Gegenlauffräsen oder Pendelbearbeitung

  • Radius-Korrektur: Die Kontur linkskorrigiert, rechtskorrigiert oder unkorrigiert bearbeiten

  • Anfahrart: Tangentiales Anfahren auf einem Kreisbogen oder tangentiales Anfahren auf einer Geraden oder senkrecht auf die Kontur anfahren

  • Anfahr-Radius (nur wirksam, wenn tangentiales Anfahren auf einem Kreisbogen gewählt ist): Radius des Einfahrkreises

  • Mittelpunktswinkel (nur wirksam, wenn tangentiales Anfahren auf einem Kreisbogen gewählt ist): Winkel des Einfahrkreises

  • Abstand Hilfspunkt (nur wirksam, wenn tangentiales Anfahren auf einer Geraden oder senkrechtes Anfahren gewählt ist): Abstand des Hilfspunktes, von dem aus die Kontur angefahren wird

  • Konturname: Name der Kontur-Datei (.HC), die bearbeitet werden soll. Wenn Option DXF-Konverter verfügbar ist, dann können Sie direkt aus dem Formular heraus eine Kontur mit dem DXF-Konverter erstellen

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Keine.

Global wirksame Parameter im Detailformular Globale Daten:

2. Sicherheits-Abstand


Unit 275 Konturnut

Mit der Konturnut lassen sich offene und geschlossene Konturnuten bearbeiten, die Sie in einem .HC-Programm definiert, oder mit dem DXF-Konverter erzeugt haben.

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Fräsart: Gleichlauffräsen, Gegenlauffräsen oder Pendelbearbeitung

  • Nutbreite: Breite der Nut eingeben; wenn Nutbreite gleich Werkzeug-Durchmesser eingegeben, dann fährt die TNC das Werkzeug lediglich entlang der definierten Kontur

  • Zust. pro Umlauf: Wert, um den die TNC das Werkzeug pro Umlauf in Bearbeitungsrichtung versetzt

  • Koordinate Oberfläche: Koordinate der Werkstück-Oberfläche, auf die sich eingegebene Tiefen beziehen

  • Tiefe: Frästiefe

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Aufmaß Seite: Schlichtaufmaß

  • Konturname: Name der Kontur-Datei (.HC), die bearbeitet werden soll. Wenn Option DXF-Konverter verfügbar ist, dann können Sie direkt aus dem Formular heraus eine Kontur mit dem DXF-Konverter erstellen

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Zustellung Schlichten: Zustellung für Schlichten Seite. Wenn nicht eingegeben, dann schlichten mit 1 Zustellung

  • F Schlichten: Vorschub fürs Schlichten [mm/min], FU [mm/U] oder FZ [mm/Zahn]

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf

Helixförmig eintauchen, oder

Pendelnd eintauchen, oder

Senkrecht eintauchen


Unit 276 Konturzug 3D

Mit dem Konturzug lassen sich offene und geschlossene Konturen bearbeiten, die Sie in einem .HC-Programm definiert, oder mit dem DXF‑Konverter erzeugt haben.

Start- und Endpunkt der Kontur so wählen, das genügend Platz für An- und Wegfahrbewegungen vorhanden ist!

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Tiefe: Frästiefe, wenn mit 0 programmiert, fährt die TNC auf der Z‑Koordinate des Kontur-Unterprogramms

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Aufmaß Seite: Schlichtaufmaß

  • Fräsart: Gleichlauffräsen, Gegenlauffräsen oder Pendelbearbeitung

  • Radius-Korrektur: Die Kontur linkskorrigiert, rechtskorrigiert oder unkorrigiert bearbeiten

  • Anfahrart: Tangentiales Anfahren auf einem Kreisbogen oder tangentiales Anfahren auf einer Geraden oder senkrecht auf die Kontur anfahren

  • Anfahr-Radius (nur wirksam, wenn tangentiales Anfahren auf einem Kreisbogen gewählt ist): Radius des Einfahrkreises

  • Mittelpunktswinkel (nur wirksam, wenn tangentiales Anfahren auf einem Kreisbogen gewählt ist): Winkel des Einfahrkreises

  • Abstand Hilfspunkt (nur wirksam, wenn tangentiales Anfahren auf einer Geraden oder senkrechtes Anfahren gewählt ist): Abstand des Hilfspunktes, von dem aus die Kontur angefahren wird

  • Konturname: Name der Kontur-Datei (.HC), die bearbeitet werden soll. Wenn Option DXF-Konverter verfügbar ist, dann können Sie direkt aus dem Formular heraus eine Kontur mit dem DXF-Konverter erstellen

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Keine.

Global wirksame Parameter im Detailformular Globale Daten:

Sichere Höhe


Unit 130 Kontutasche auf Punktemuster (FCL 3-Funktion)

Mit dieser UNIT können Sie beliebig geformte Taschen, die auch Inseln enthalten dürfen, auf einem beliebigen Punktemuster anordnen und ausräumen.

Wenn erforderlich, können Sie im Detailformular Kontur jeder Teilkontur eine separate Tiefe zuweisen (FCL2-Funktion). In diesem Fall müssen Sie immer mit der tiefsten Tasche beginnen.

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Vorschub Einpendeln [mm/min], FU [mm/U] oder FZ [mm/Zahn]. 0 eingeben, wenn senkrecht eingetaucht werden soll

  • F: Vorschub Tiefenzustellung [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Tiefe: Frästiefe

  • Zustell-Tiefe: Maß, um welches das Werkzeug jeweils zugestellt wird

  • Aufmaß Seite: Schlichtaufmaß Seite

  • Aufmaß Tiefe: Schlichtaufmaß Tiefe

  • Konturname: Liste der Teilkonturen (.HC-Dateien) die verknüpft werden sollen. Wenn Option DXF-Konverter verfügbar ist, dann können Sie direkt aus dem Formular heraus eine Kontur mit dem DXF-Konverter erstellen

  • Positionen oder Punktemuster: Positionen definieren, auf denen die TNC die Konturtasche abarbeiten soll siehe Grundlagen
  • Per Softkey bestimmen, ob die jeweilige Teilkontur eine Tasche oder eine Insel ist!
  • Liste der Teilkonturen grundsätzlich immer mit einer Tasche (ggf. der tiefsten Tasche) beginnen!
  • Maximal können Sie im Detailformular Kontur bis zu 9 Teilkonturen definieren!

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Rundungs-Radius: Verrundungs-Radius der Werkzeug--Mittelpunktsbahn an den Innen-Ecken

  • Vorschubfaktor in %: Prozentualer Faktor, um den die TNC den Bearbeitungs-Vorschub reduziert, sobald das Werkzeug beim Ausräumen mit dem vollen Umfang im Material verfährt. Wenn Sie die Vorschubreduzierung nutzen, dann können Sie den Vorschub Ausräumen so groß definieren, dass bei der festgelegten Bahn-Überlappung (globale Daten) optimale Schnittbedingungen herrschen. Die TNC reduziert dann an Übergängen oder Engstellen den Vorschub wie von Ihnen definiert, so dass die Bearbeitungszeit insgesamt kleiner sein sollte

Zusätzliche Parameter im Detailformular Kontur:

  • Tiefe: Separat definierbare Tiefen für jede Teilkontur (FCL 2-Funktion)

  • Liste der Teilkonturen grundsätzlich immer mit der tiefsten Tasche beginnen!
  • Wenn die Kontur als Insel definiert ist, dann interpretiert die TNC die eingegebene Tiefe als Inselhöhe. Der eingegebene, vorzeichenlose Wert bezieht sich dann auf die Werkstück-Oberfläche!
  • Wenn Tiefe mit 0 eingegeben ist, dann wirkt bei Taschen die im Übersichtsformular definierte Tiefe, Inseln ragen dann bis zur Werkstück-Oberfläche!

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Überlappungsfaktor

Vorschub Rückzug

Fräsen im Gleichlauf, oder

Fräsen im Gegenlauf


Bearbeitungsgruppe Flächen

In der Bearbeitungsgruppe Flächen steht folgende Unit zur Bearbeitung von Flächen zur Verfügung:

Unit | Softkey | Seite
Unit 232 Planfräsen |  | Unit 232 Planfräsen
Weitere Informationen:
> Unit 232 Planfräsen


Unit 232 Planfräsen

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Fräsvorschub [mm/min], FU [mm/U] oder FZ [mm/Zahn]

  • Frässtrategie: Auswahl der Frässtrategie

  • Startpunkt 1. Achse: Startpunkt in der Hauptachse

  • Startpunkt 2. Achse: Startpunkt in der Nebenachse

  • Startpunkt 3. Achse: Startpunkt in der Werkzeugachse

  • Endpunkt 3. Achse: Endpunkt in der Werkzeugachse

  • Aufmaß Tiefe: Schlichtaufmaß Tiefe

  • 1. Seiten-Länge: Länge der abzufräsenden Fläche in der Hauptachse bezogen auf den Startpunkt

  • 2. Seiten-Länge: Länge der abzufräsenden Fläche in der Nebenachse bezogen auf den Startpunkt

  • Maximale Zustellung: Maß, um das das Werkzeug jeweils maximal zugestellt wird

  • Abstand Seite: Seitlicher Abstand, um den das Werkzeug über die Fläche hinaus fährt

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • F Schlichten: Vorschub für den letzten Schlichtschnitt

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand

Positioniervorschub

Überlappungsfaktor


Bearbeitungsgruppe Sonder UNITs

In der Bearbeitungsgruppe Sonder UNITs stehen folgende Units zur Verfügung:

Unit | Softkey | Seite
Unit 225 Gravieren |  | Unit 225 Gravieren
Unit 290 Interpolationsdrehen (Option) |  | Unit 290 Interpolationsdrehen (Option)
Weitere Informationen:
> Unit 225 Gravieren
> Unit 290 Interpolationsdrehen (Option)


Unit 225 Gravieren

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • F: Fräsvorschub [mm/min]

  • F: Vorschub Tiefenzustellung [mm/min]

  • Text: Zu gravierenden Text definieren

  • Zeichenhöhe: Höhe der zu gravierenden Zeichen in mm (inch)

  • Faktor Abstand F: Faktor der den Abstand der Zeichen untereinander definiert

  • Koordinate Oberfläche: Koordinate der Werkstück-Oberfläche, auf die sich die eingegebene Tiefe bezieht

  • Tiefe: Graviertiefe

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M3

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Textanordnung: Festlegung ob Text auf einer Geraden oder einem Kreisbogen angeordnet werden soll

  • Drehlage: Mittelpunktswinkel, wenn die TNC den Text auf einem Kreis anordnen soll

  • Kreisradius: Radius des Kreisbogens, auf dem die TNC den Text anordnen soll in mm

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand

2. Sicherheits-Abstand


Unit 290 Interpolationsdrehen (Option)

Parameter im Formular Übersicht:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • Schnittgeschwindigkeit: Schnittgeschwindigkeit [m/min]

  • Startdurchmesser: Ecke des Startpunkts in X, Durchmesser eingeben

  • Konturstart Z: Ecke des Startpunkts in Z

  • Enddurchmesser: Ecke des Endpunkts in X, Durchmesser eingeben

  • Konturende Z: Ecke des Endpunkts in Z

  • Bearbeit.-Richtung: Bearbeitung im Gegenuhrzeigersinn oder im Uhrzeigersinn ausführen

  • Interpol.-Achse: Achsbezeichnung der interpolierenden Achse definieren

Zusätzliche Parameter im Detailformular Tool:

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • M-Funktion: Beliebige Zusatzfunktionen M

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)

Zusätzliche Parameter im Detailformular Fräsparameter:

  • Startwinkel: Startwinkel in der XY-Ebene

  • Winkel Umfangsfläche: Winkel der ersten zu bearbeitenden Fläche

  • Winkel Planfläche: Winkel der zweiten zu bearbeitenden Fläche

  • Radius Konturecke: Eckenverrundung zwischen den zu bearbeitenden Flächen in mm

  • Sichere Höhe: Absolute Höhe, in der keine Kollision zwischen Werkzeug und Werkstück erfolgen kann

  • Spindel: Spindeldrehrichtung. smarT.NC setzt standardmäßig M5. Nur wenn Modus MILL gewählt ist, dann können Sie eine Spindeldrehzahl und die Spindeldrehrichtung definieren

Global wirksame Parameter im Detailformular Globale Daten:

Sicherheits-Abstand


Hauptgruppe Antasten

In der Hauptgruppe Antasten wählen Sie folgende Funktionsgruppen aus:

Funktionsgruppe | Softkey
rotation: Antastfunktionen zur automatischen Ermittlung einer Grunddrehung |
preset: Antastfunktionen zur automatischen Ermittlung eines Bezugspunktes |
messen: Antastfunktionen zur automatischen Werkstück-Vermessung |
sonderfunkt.: Sonderfunktion zum Setzen von Tastsystemdaten |
kinematik.: Antastfunktionen zur Prüfung und Optimierung der Maschinenkinematik |
werkzeug: Antastfunktionen zur automatischen Werkzeug-Vermessung |

Eine detailierte Beschreibung zur Funktionsweise der Antastzyklen finden Sie im Benutzer-Handbuch Tastsystem-Zyklen.


Funktionsgruppe Rotation

In der Funktionsgruppe Rotation stehen folgende Units zur automatischen Ermittlung einer Grunddrehung zur Verfügung:

Unit | Softkey
Unit 400 Rotation über Gerade |
Unit 401 Rotation 2 Bohrungen |
Unit 402 Rotation 2 Zapfen |
Unit 403 Rotation Drehachse |
Unit 405 Rotation C-Achse |


Funktionsgruppe Preset (Bezugspunkt)

In der Funktionsgruppe Preset stehen folgende Units zum automatischen Bezugspunkt-Setzen zur Verfügung:

Unit | Softkey
Unit 408 Bezugspunkt Nut innen (FCL 3-Funktion) |
Unit 409 Bezugspunkt Nut außen (FCL 3-Funktion) |
Unit 410 Bezugspunkt Rechteck innen |
Unit 411 Bezugspunkt Rechteck außen |
Unit 412 Bezugspunkt Kreis innen |
Unit 413 Bezugspunkt Kreis außen |
Unit 414 Bezugspunkt Ecke außen |
Unit 415 Bezugspunkt Ecke innen |
Unit 416 Bezugspunkt Lochkreismitte |
Unit 417 Bezugspunkt Tastsystem-Achse |
Unit 418 Bezugspunkt 4 Bohrungen |
Unit 419 Bezugspunkt einzelne Achse |


Funktionsgruppe Messen

In der Funktionsgruppe Messen stehen folgende Units zur automatischen Werkstück-Vermessung zur Verfügung:

Unit | Softkey
Unit 420 Messen Winkel |
Unit 421 Messen Bohrung |
Unit 422 Messen Kreiszapfen |
Unit 423 Messen Rechteck innen |
Unit 424 Messen Rechteck außen |
Unit 425 Messen Breite innen |
Unit 426 Messen Breite außen |
Unit 427 Messen Koordinate |
Unit 430 Messen Lochkreis |
Unit 431 Messen Ebene |


Funktionsgruppe Sonderfunktionen

In der Funktionsgruppe Sonderfunktionen stehen folgende Units zur Verfügung:

Unit | Softkey
Unit 441 Antast-Parameter |
Unit 460 3D-Tastsystem kalibrieren |


Funktionsgruppe Kinematikvermessung (Option)

In der Funktionsgruppe Kinematik stehen folgende Units zur Verfügung:

Unit | Softkey
Unit 450 Kinematik sichern/wiederherstellen |
Unit 451 Kinematik prüfen/optimieren |
Unit 452 Preset-Kompensation |
Unit 460 3D-Tastsystem kalibrieren |


Funktionsgruppe Werkzeug

In der Funktionsgruppe Werkzeug stehen folgende Units für die automatische Werkzeug-Vermessung zur Verfügung:

Unit | Softkey
Unit 480 TT: TT kalibrieren |
Unit 481 TT: Werkzeug-Länge messen |
Unit 482 TT: Werkzeug-Radius messen |
Unit 483 TT: Werkzeug komplett messen |


Hauptgruppe Umrechnen

In der Hauptgruppe Umrechnen stehen Funktionen zur Koordinaten-Umrechnung zur Verfügung:

Funktion | Softkey | Seite
Unit 141 (FCL 2-Funktion): Nullpunkt-Verschiebung |  | Unit 141 Nullpunkt-Verschiebung
Unit 8 (FCL 2-Funktion): Spiegeln |  | Unit 8 Spiegeln (FCL 2-Funktion)
Unit 10 (FCL 2-Funktion): Drehung |  | Unit 10 Drehung (FCL 2-Funktion)
Unit 11 (FCL 2-Funktion): Skalierung |  | Unit 11 Skalierung (FCL 2-Funktion)
Unit 140 (FCL 2-Funktion): Bearbeitungsebene schwenken mit der PLANE-Funktion |  | Unit 140 Ebene schwenken (FCL 2-Funktion)
Unit 247: Preset-Nummer |  | Unit 247 Bezugspunkt wählen
Unit 7 (FCL 2-Funktion, 2. Softkey-Leiste): Nullpunkt-Verschiebung über Nullpunkt-Tabelle |  | Unit 7 Nullpunkt-Verschiebung (FCL 2-Funktion)
Unit 404 (2. Softkey-Leiste): Grunddrehung setzen |  | Unit 404 Grunddrehung setzen
Weitere Informationen:
> Unit 141 Nullpunkt-Verschiebung
> Unit 8 Spiegeln (FCL 2-Funktion)
> Unit 10 Drehung (FCL 2-Funktion)
> Unit 11 Skalierung (FCL 2-Funktion)
> Unit 140 Ebene schwenken (FCL 2-Funktion)
> Unit 247 Bezugspunkt wählen
> Unit 7 Nullpunkt-Verschiebung (FCL 2-Funktion)
> Unit 404 Grunddrehung setzen


Unit 141 Nullpunkt-Verschiebung

Mit der Unit 141 Nullpunkt-Verschiebung definieren Sie eine Nullpunkt-Verschiebung durch direkte Eingabe von Verschiebungswerten in den einzelnen Achsen, oder durch Definition einer Nummer aus der Nullpunkt-Tabelle. Die Nullpunkt-Tabelle müssen Sie im Program-Kopf festgelegt haben.

Per Softkey die gewünschte Definitionsart wählen

Nullpunkt-Verschiebung durch Werteingabe definieren

Nullpunkt-Verschiebung über Nullpunkt-Tabelle definieren. Nullpunkt-Nummer eingeben, oder per Softkey nummer wählen auswählen. Bei Bedarf Nullpunkt-Tabelle wählen

Nullpunkt-Verschiebung rücksetzen

Wenn Sie eine Nullpunkt-Tabelle gewählt haben, dann verwendet die TNC die programmierte Zeilennummer nur bis zum nächsten Aufruf einer Nullpunkt-Nummer (unitweise wirksame Nullpunkt-Verschiebung).

Nullpunkt-Verschiebung vollständig rücksetzen: Softkey nullpunkt-verschieb. rücksetzen drücken. Wenn Sie die Nullpunkt-Verschiebung nur in einzelnen Achsen rücksetzen wollen, dann im Formular für diese Achse den Wert 0 programmieren.


Unit 8 Spiegeln (FCL 2-Funktion)

Mit der Unit 8 definieren Sie per Checkbox die gewünschten Spiegelachsen.

Wenn Sie nur eine Spiegelachse definieren, ändert die TNC die Bearbeitungs-Richtung.

Spiegeln rücksetzen: Unit 8 ohne Spiegelachsen definieren.


Unit 10 Drehung (FCL 2-Funktion)

Mit der Unit 10 Drehung definieren Sie einen Drehwinkel, um den smarT.NC die nachfolgend definierten Bearbeitungen in der aktiven Bearbeitungsebene gedreht ausführen soll.

Vor Zyklus 10 muss zumindest ein Werkzeug-Aufruf mit Definition der Werkzeug-Achse programmiert sein, damit smarT.NC die Ebene bestimmen kann, in der gedreht werden soll.

Drehung rücksetzen: Unit 10 mit Drehung 0 definieren.


Unit 11 Skalierung (FCL 2-Funktion)

Mit der Unit 11 definieren Sie einen Maßfaktor, mit dem Sie nachfolgend definierte Bearbeitungen vergrößert bzw- verkleinert ausführen können.

Mit Maschinen-Parameter MP7411 stellen Sie ein, ob der Maßfaktor nur in der aktiven Bearbeitungsebene oder zusätzlich auch in der Werkzeugachse wirken soll.

Maßfaktor rücksetzen: Unit 11 mit Maßfaktor 1 definieren.


Unit 140 Ebene schwenken (FCL 2-Funktion)

Die Funktionen zum Schwenken der Bearbeitungsebene müssen von Ihrem Maschinenhersteller freigegeben sein!

Die PLANE-Funktion können Sie grundsätzlich nur an Maschinen einsetzen, die über mindestens zwei Schwenkachsen (Tisch oder/und Kopf) verfügt. Ausnahme: Die Funktion PLANE AXIAL (FCL 3-Funktion) können Sie auch dann verwenden, wenn an Ihrer Maschine nur eine einzelne Drehachse vorhanden bzw. aktiv ist.

Mit der Unit 140 können Sie auf unterschiedliche Weise geschwenkte Bearbeitungsebenen definieren. Ebenendefinition und Positionier-verhalten können Sie unabhängig voneinander einstellen.

Folgende Ebenen-Definitionen stehen zur Verfügung:

Art der Ebenen-Definition | Softkey
Ebene über Raumwinkel definieren |
Ebene über Projektionswinkel definieren |
Ebene über Eulerwinkel definieren |
Ebene über Vektoren definieren |
Ebene über drei Punkte definieren |
Inkrementalen Raumwinkel definieren |
Achswinkel definieren (FCL 3-Funktion) |
Rücksetzen der Funktion Bearbeitungsebene |

Das Positionier-Verhalten, die Auswahl der Schwenkrichtung und die Transformationsart können Sie per Softkey umschalten.

Die Transformationsart wirkt nur bei Transformationen mit einer C-Achse (Rundtisch).


Unit 247 Bezugspunkt wählen

Mit der Unit 247 definieren Sie einen Bezugspunkt aus der aktiven Preset-Tabelle.


Unit 7 Nullpunkt-Verschiebung (FCL 2-Funktion)

Bevor Sie Unit 7 verwenden, müssen Sie die Nullpunkt-Tabelle im Programm-Kopf wählen, aus der smarT.NC die Nullpunkt-Nummer verwenden soll siehe Programm-Einstellungen.

Nullpunkt-Verschiebung rücksetzen: Unit 7 mit Nummer 0 defieren. Darauf achten, dass in Zeile 0 alle Koordinaten mit 0 definiert sind.

Wenn Sie eine Nullpunkt-Verschiebung mit Koordinaten-Eingabe definieren wollen: Klartext-Dialog-Unit verwenden siehe Unit 40 Klartext-Dialog-Unit.

Mit der Unit 7 Nullpunkt-Verschiebung definieren Sie eine Nullpunkt-Nummer aus der Nullpunkt-Tabelle, die Sie im Program-Kopf festgelegt haben. Nullpunkt-Nummer per Softkey wählen.


Unit 404 Grunddrehung setzen

Mit der Unit 404 setzen Sie eine beliebige Grunddrehung. Vorzugsweise verwenden, um Grunddrehungen zurückzusetzen, die Sie über Antast-Funktionen ermittelt haben.


Hauptgruppe Sonder-Funktionen

In der Hauptgruppe Sonder-Funktionen stehen verschiedenste Funktionen Verfügung:

Funktion | Softkey | Seite
Unit 151: Programm-Aufruf |  | Unit 151 Programm-Aufruf
Unit 799: Programm-Ende-Unit |  | Unit 799 Programm-Ende-Unit
Unit 70: Positioniersatz eingeben |  | Unit 70 Positionier-Unit
Unit 60: Zusatz-Funktionen M eingeben |  | Unit 60 M-Funktions-Unit
Unit 50: Separater Werkzeug-Aufruf |  | Unit 50 Separater Werkzeug-Aufruf
Unit 40: Klartext-Dialog-Unit |  | Unit 40 Klartext-Dialog-Unit
Unit 700 (2. Softkey-Leiste): Programm-Einstellungen |  | Programm-Einstellungen
Weitere Informationen:
> Unit 151 Programm-Aufruf
> Unit 799 Programm-Ende-Unit
> Unit 70 Positionier-Unit
> Unit 60 M-Funktions-Unit
> Unit 50 Separater Werkzeug-Aufruf
> Unit 40 Klartext-Dialog-Unit


Unit 151 Programm-Aufruf

Mit dieser Unit können Sie von smarT.NC aus ein beliebiges Programm mit folgenden Datei-Typen aufrufen:

  • smarT.NC Unit-Programm (Datei-Typ .HU)
  • Klartext-Dialog-Programm (Datei-Typ .H)
  • DIN/ISO-Programm (Datei-Typ .I)

Parameter im Übersichtsformular:

  • Programm-Name: Pfadname des aufzurufenden Programmes eingeben

  • Wenn Sie das gewünschte Programm per Softkey wählen wollen (Überblendfenster, siehe Bild rechts unten), muss es im Verzeichnis TNC:\smarTNC gespeichert sein!
  • Ist das gewünschte Programm nicht im Verzeichnis TNC:\smarTNC gespeichert, dann vollständigen Pfadnamen direkt eingeben!


Unit 799 Programm-Ende-Unit

Mit dieser Unit kennzeichnen Sie das Ende eines Unit-Programmes. Sie können Zusatz-Funktionen M definieren und alternativ eine Position, die die TNC anfahren soll.

Parameter:

  • M-Funktion: Bei Bedarf Eingabe von beliebigen Zusatzfunktionen M, die TNC fügt beim Definieren standardmäßig M2 (Programm-Ende) ein

  • Endposition anfahren: Bei Bedarf Eingabe einer Position, die am Programmende angefahren werden soll. Positionierfolge: Zuerst Werkzeugachse (Z), dann Bearbeitungsebene (X/Y)

  • Bezugssystem Werkstück: Die eingegebenen Koordinaten beziehen sich auf den aktiven Werkstück-Bezugspunkt

  • M91: Die eingegebenen Koordinaten beziehen sich auf den Maschinen-Nullpunkt (M91)

  • M92: Die eingegebenen Koordinaten beziehen sich auf eine vom Maschinenhersteller definierte, maschinenfeste Position (M92)


Unit 70 Positionier-Unit

Mit dieser Unit können Sie eine Positionierung definieren, die die TNC zwischen beliebigen Units ausführen soll.

Parameter:

  • Endposition anfahren: Bei Bedarf Eingabe einer Position, die die TNC anfahren soll. Positionierfolge: Zuerst Werkzeugachse (Z), dann Bearbeitungsebene (X/Y)

  • Bezugssystem Werkstück: Die eingegebenen Koordinaten beziehen sich auf den aktiven Werkstück-Bezugspunkt

  • M91: Die eingegebenen Koordinaten beziehen sich auf den Maschinen-Nullpunkt (M91)

  • M92: Die eingegebenen Koordinaten beziehen sich auf eine vom Maschinenhersteller definierte, maschinenfeste Position (M92)


Unit 60 M-Funktions-Unit

Mit dieser Unit können Sie zwei beliebige Zusatzfunktionen M definieren.

Parameter:

  • M-Funktion: Eingabe von beliebigen Zusatzfunktionen M


Unit 50 Separater Werkzeug-Aufruf

Mit dieser Unit können Sie einen separaten Werkzeug-Aufruf definieren.

Parameter im Übersichtsformular:

  • T: Werkzeug-Nummer oder -Name (per Softkey umschaltbar)

  • S: Spindeldrehzahl [U/min] oder Schnittgeschwindigkeit [m/min]

  • DL: Delta-Länge für Werkzeug T

  • DR: Delta-Radius für Werkzeug T

  • DR2: Delta-Radius 2 (Eckenradius) für Werkzeug T

  • M-Funktion definieren: Bei Bedarf Eingabe von beliebigen Zusatzfunktionen M

  • Vorpositionierung definieren: Bei Bedarf Eingabe einer Position, die nach dem Werkzeugwechsel angefahren werden soll. Positionierfolge: Zuerst Bearbeitungsebene (X/Y), dann Werkzeugachse (Z)

  • WZ-Vorauswahl: Bei Bedarf Nummer des nächsten Werkzeugs zur Beschleunigung des Werkzeug-Wechsels (maschinenabhängig)


Unit 40 Klartext-Dialog-Unit

Mit dieser Unit können Sie Klartext-Dialog-Sequenzen zwischen Bearbeitungsblöcke einfügen. Sie ist immer dann verwendbar, wenn

  • Sie TNC-Funktionen benötigen, für die noch keine Formulareingabe zur Verfügung steht
  • Sie Hersteller-Zyklen definieren wollen

Die Anzahl der einfügbaren Klartext-Dialog-Sätze pro Klartext-Dialog-Sequenz ist nicht begrenzt!

    Folgende Klartext-Funktionen für die keine Formulareingabe möglich ist, sind einfügbar:

  • Bahnfunktionen L, CHF, CC, C, CR, CT, RND über die grauen -Bahnfunktions-Tasten
  • STOP-Satz über STOP-Taste
  • Separater M-Funktions-Satz über ASCII-Taste M
  • Werkzeug-Aufruf über Taste TOOL CALL
  • Zyklus-Definitionen
  • Antast-Zyklus-Definitionen
  • Programmteil-Wiederholung/Unterprogramm-Technik
  • Q-Parameter-Programmierung


Bearbeitungspositionen definieren

Weitere Informationen:
> Bearbeitungspositionen definieren


Bearbeitungspositionen definieren

Bearbeitungspositionen definieren

Weitere Informationen:
> Grundlagen
> Bearbeitungspositionen wiederholt verwenden
> Bearbeitungsmuster im Detailformular Positionen definieren
> Mustergenerator starten
> Mustergenerator beenden
> Arbeiten mit dem Mustergenerator


Grundlagen

Bearbeitungspositionen können Sie direkt im Übersichts-Formular 1 des jeweiligen Bearbeitungsschrittes in kartesischen Koordinaten definieren (siehe Bild rechts oben). Wenn Sie die Bearbeitung an mehr als drei Positionen oder auf Bearbeitungsmustern durchführen wollen, können Sie im Detailformular Positionen (2) bis zu 6 weitere – also insgesamt bis zu 9 Bearbeitungspositionen – eingeben, oder alternativ verschiedene Bearbeitungsmuster definieren.

Inkremental-Eingabe ist ab der 2. Bearbeitungsposition erlaubt. Umschaltung per Taste I oder per Softkey möglich, die 1. Bearbeitungsposition ist zwingend absolut einzugeben.

Besonders komfortabel definieren Sie Bearbeitungspositionen über den Mustergenerator. Der Mustergenerator zeigt die eingegebenen Bearbeitungspositionen sofort grafisch an, nachdem Sie die erforderlichen Parameter eingegeben und gespeichert haben.

Bearbeitungspositionen, die Sie über den Mustergenerator definiert haben, speichert smarT.NC automatisch in einer Punkte-Tabelle (.HP‑Datei), die Sie beliebig oft wiederverwenden können. Besonders praktisch ist die Möglichkeit, beliebige, grafisch selektierbare Bearbeitungspositionen auszublenden oder zu sperren.

Wenn Sie bereits auf älteren Steuerungen Punkte-Tabellen verwendet haben (.PNT-Dateien), können Sie diese über die Schnittstellen einlesen auch in smarT.NC verwenden.

Wenn Sie regelmäßige Bearbeitungsmuster benötigen, verwenden Sie die Definitionsmöglichkeiten im Detailformular Positionen. Wenn Sie umfangreiche und unregelmäßige Bearbeitungsmuster benötigen, verwenden Sie den Mustergenerator.


Bearbeitungspositionen wiederholt verwenden

Unabhängig davon, ob Sie die Bearbeitungspositionen direkt im Formular oder als .HP-Datei im Mustergenerator erstellt haben, können Sie diese Bearbeitungspositionen für alle direkt nachfolgenden Bearbeitungsunits verwenden. Lassen sie dazu die Eingabefelder für die Bearbeitungspositionen einfach leer, smarT.NC verwendet dann automatisch die zuletzt von Ihnen definierten Bearbeitungspositionen.

Bearbeitungspositionen bleiben so lange wirksam, bis Sie in einer beliebigen, folgenden Unit neue Bearbeitungspositionen definieren.


Bearbeitungsmuster im Detailformular Positionen definieren

  • Beliebige Bearbeitungs-Unit wählen

Detailformular Position wählen

Per Softkey das gewünschte Bearbeitungsmuster wählen

Wenn Sie ein Bearbeitungsmuster definiert haben, dann zeigt smarT.NC im Übersichts-Formular aus Platzgründen anstelle der Eingabewerte einen entsprechenden Hinweistext mit zugehöriger Grafik an.

Werteänderungen können Sie im Detailformular Position durchführen!

Weitere Informationen:
> Einzelne Reihe, gerade oder gedreht
> Muster, gerade, gedreht oder verzerrt
> Rahmen, gerade, gedreht oder verzerrt
> Vollkreis
> Teilkreis


Einzelne Reihe, gerade oder gedreht

Startpunkt 1. Achse: Koordinate des Reihen-Startpunktes in der Hauptachse der Bearbeitungsebene

Startpunkt 2. Achse: Koordinate des Reihen-Startpunktes in der Nebenachse der Bearbeitungsebene

Abstand: Abstand zwischen den Bearbeitungspositionen. Wert positiv oder negativ eingebbar

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen

Drehung: Drehwinkel um den eingegebenen Startpunkt. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Koordinate Oberfläche: Koordinate Werkstück-Oberfläche


Muster, gerade, gedreht oder verzerrt

Startpunkt 1. Achse: Koordinate des Muster-Startpunktes 1 in der Hauptachse der Bearbeitungsebene

Startpunkt 2. Achse: Koordinate des Muster-Startpunktes 2 in der Nebenachse der Bearbeitungsebene

Abstand 1. Achse: Abstand der Bearbeitungspositionen in der Hauptachse der Bearbeitungsebene. Wert positiv oder negativ eingebbar

Abstand 2. Achse: Abstand der Bearbeitungspositionen in der Nebenachse der Bearbeitungsebene. Wert positiv oder negativ eingebbar

Anzahl Spalten: Gesamt-Spaltenanzahl des Musters

Anzahl Zeilen: Gesamt-Zeilenanzahl des Musters

Drehung: Drehwinkel, um den das gesamte Muster um den eingegebenen Startpunkt gedreht wird. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Drehlage Hauptachse: Drehwinkel, um den ausschließlich die Hauptachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Drehlage Nebenachse: Drehwinkel, um den ausschließlich die Nebenachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Koordinate Oberfläche: Koordinate Werkstück-Oberfläche

Die Parameter Drehlage Hauptachse und Drehlage Nebenachse wirken additiv auf eine zuvor durchgeführte Drehung des gesamten Musters.


Rahmen, gerade, gedreht oder verzerrt

Startpunkt 1. Achse: Koordinate des Rahmen-Startpunktes 1 in der Hauptachse der Bearbeitungsebene

Startpunkt 2. Achse: Koordinate des Rahmen-Startpunktes 2 in der Nebenachse der Bearbeitungsebene

Abstand 1. Achse: Abstand der Bearbeitungspositionen in der Hauptachse der Bearbeitungsebene. Wert positiv oder negativ eingebbar

Abstand 2. Achse: Abstand der Bearbeitungspositionen in der Nebenachse der Bearbeitungsebene. Wert positiv oder negativ eingebbar

Anzahl Zeilen: Gesamt-Zeilenanzahl des Rahmens

Anzahl Spalten: Gesamt-Spaltenanzahl des Rahmens

Drehung: Drehwinkel, um den der gesamte Rahmen um den eingegebenen Startpunkt gedreht wird. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Drehlage Hauptachse: Drehwinkel, um den ausschließlich die Hauptachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Drehlage Nebenachse: Drehwinkel, um den ausschließlich die Nebenachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Koordinate Oberfläche: Koordinate Werkstück-Oberfläche

Die Parameter Drehlage Hauptachse und Drehlage Nebenachse wirken additiv auf eine zuvor durchgeführte Drehung des gesamten Rahmens.


Vollkreis

Mitte 1. Achse: Koordinate des Kreis-Mittelpunktes 1 in der Hauptachse der Bearbeitungsebene

Mitte 2. Achse: Koordinate des Kreis-Mittelpunktes 2 in der Nebenachse der Bearbeitungsebene

Durchmesser: Durchmesser des Lochkreises

Startwinkel: Polarwinkel der ersten Bearbeitungsposition. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen auf dem Kreis

Koordinate Oberfläche: Koordinate Werkstück-Oberfläche

smarT.NC berechnet den Winkelschritt zwischen zwei Bearbeitungspositionen immer aus 360° dividiert durch die Anzahl der Bearbeitungen.


Teilkreis

Mitte 1. Achse: Koordinate des Kreis-Mittelpunktes 1 in der Hauptachse der Bearbeitungsebene

Mitte 2. Achse: Koordinate des Kreis-Mittelpunktes 2 in der Nebenachse der Bearbeitungsebene

Durchmesser: Durchmesser des Lochkreises

Startwinkel: Polarwinkel der ersten Bearbeitungsposition. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Winkelschritt/Endwinkel: Inkrementaler Polarwinkel zwischen zwei Bearbeitungspositionen. Alternativ absoluter Endwinkel eingebbar (per Softkey umschalten). Werte positiv oder negativ eingebbar

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen auf dem Kreis

Koordinate Oberfläche: Koordinate Werkstück-Oberfläche


Mustergenerator starten

Der smarT.NC-Mustergenerator lässt sich auf zwei unterschiedliche Weisen starten:

  • Direkt aus der dritten Softkeyleiste des smarT.NC-Hauptmenüs, wenn Sie mehrere Punkte-Dateien direkt hintereinander definieren wollen
  • Während der Bearbeitungsdefinition aus dem Formular heraus, wenn Sie Bearbeitungspositionen eingeben wollen
Weitere Informationen:
> Mustergenerator aus der Hauptleiste des Editieren-Menüs starten
> Mustergenerator aus einem Formular heraus starten


Mustergenerator aus der Hauptleiste des Editieren-Menüs starten

Betriebsart smarT.NC wählen

Dritte Softkey-Leiste wählen

Mustergenerator starten: smarT.NC wechselt in die Datei-Verwaltung (siehe Bild rechts) und zeigt - wenn vorhanden - bereits existierende Punkte-Dateien an

Vorhandene Punkte-Datei (*.HP) wählen, mit Taste ENT übernehmen, oder

Neue Punkte-Datei öffnen: Datei-Namen (ohne Datei-Typ) eingeben, mit Taste mm oder inch bestätigen: smarT.NC öffnet eine Punkte-Datei in der von Ihnen gewählten Maßeinheit und befindet sich anschließend im Mustergenerator


Mustergenerator aus einem Formular heraus starten

Betriebsart smarT.NC wählen

Beliebigen Bearbeitungsschritt wählen, bei dem Bearbeitungspositionen definierbar sind

Eines der Eingabefeld wählen, in dem eine Bearbeitungspositionen zu definieren ist (siehe Bild rechts oben)

Umschalten auf Bearbeitungspositionen in Punkte-Datei definieren

Um eine neue Datei zu erstellen: Datei-Namen (ohne Datei-Typ) eingeben, mit Softkey neu .hp bestätigen

Maßeinheit der neuen Punktedatei im Überblendfenster mit Taste mm oder inch bestätigen: smarT.NC befindet sich jetzt im Mustergenerator

Um eine vorhandene HP-Datei zu wählen: Softkey wählen .Hp drücken: smarT.NC zeigt ein Überblendfenster mit vorhandenen Punktedateien. Eine der angezeigten Dateien wählen und mit Taste ENT oder Schalftläche OK ins Formular übernehmen.

Um eine bereits gewählte HP-Datei zu editieren: Softkey editieren .HP drücken: smarT.NC startet dann direkt den Mustergenerator

Um eine vorhandene PNT-Datei zu wählen: Softkey wählen .PNT drücken: smarT.NC zeigt ein Überblendfenster mit vorhandenen Punktedateien. Eine der angezeigten Dateien wählen und mit Taste ENT oder Schalftläche OK ins Formular übernehmen.

Wenn Sie eine .PNT-Datei editieren wollen, dann konvertiert smarT.NC diese Datei in eine .HP-Datei! Dialogfrage mit OK beantworten.


Mustergenerator beenden

Taste END oder Softkey ENDE drücken: smarT.NC zeigt ein Überblendfenster an (siehe Bild rechts)

Taste ENT oder Schaltfläche Ja drücken, um alle durchgeführten Änderungen zu speichern – bzw. eine neu erstellte Datei zu speichern – und den Mustergenerator zu beenden

Taste NO ENT oder Schaltfläche Nein drücken, um alle durchgeführten Änderungen nicht zu speichern und den Mustergenerator zu beenden

Taste ESC drücken, um zurück in den Mustergenerator zu gelangen

Wenn Sie den Mustergenerator aus einem Formular heraus gestartet haben, dann kehren Sie nach dem Beenden automatisch wieder dorthin zurück.

Wenn Sie den Mustergenerator aus der Hauptleiste gestartet haben, dann kehren Sie nach dem Beenden automatisch wieder in das zuletzt angewählte .HU-Programm zurück.


Arbeiten mit dem Mustergenerator

Weitere Informationen:
> Übersicht
> Muster definieren
> Funktionen des Mustergenerators
> Einzelner Punkt, kartesisch
> Einzelne Reihe, gerade oder gedreht
> Muster, gerade, gedreht oder verzerrt
> Rahmen, gerade, gedreht oder verzerrt
> Vollkreis
> Teilkreis
> Starthöhe verändern
> Rückzugshöhe für Anpositionierung definieren (FCL 3-Funktion)


Übersicht

Um Bearbeitungspositionen zu definieren, stehen im Mustergenerator folgende Möglichkeiten zur Verfügung:

Funktion | Softkey | Seite
Einzelner Punkt, kartesisch |  | Einzelner Punkt, kartesisch
Einzelne Reihe, gerade oder gedreht |  | Einzelne Reihe, gerade oder gedreht
Muster gerade, gedreht oder verzerrt |  | Muster, gerade, gedreht oder verzerrt
Rahmen gerade, gedreht oder verzerrt |  | Rahmen, gerade, gedreht oder verzerrt
Vollkreis |  | Vollkreis
Teilkreis |  | Teilkreis
Starthöhe verändern |  | Starthöhe verändern


Muster definieren

  • Zu definierendes Muster per Softkey wählen

  • Erforderliche Eingabeparameter im Formular definieren: Mit Taste ENT oder Taste „Pfeil nach unten“ nächstes Eingabefeld wählen

  • Eingabeparameter speichern: Taste END drücken

Nachdem Sie ein beliebiges Muster per Formular eingegeben haben, stellt smarT.NC dieses symbolisch als Icon auf der linken Bildschirmhälfte im Treeview 1 dar.

In der rechten unteren Bildschirmhälfte 2 wird unmittelbar nach dem Speichern der Eingabeparameter das Muster grafisch dargestellt.

Wenn Sie mit der „Pfeiltaste rechts“ den Treeview öffnen, lässt sich per „Pfeiltaste nach unten“ jeder Punkt innerhalb des von Ihnen zuvor definierten Musters selektieren. smarT.NC zeigt den links selektierten Punkt in der Grafik rechts blau markiert an (3). Zur Information werden in der rechten oberen Bildschirmhälfte 4 zusätzlich die kartesischen Koordinaten des jeweils selektierten Punktes angezeigt.


Funktionen des Mustergenerators
Funktion | Softkey
Im Treeview gewähltes Muster bzw. gewählte Position, für die Bearbeitung ausblenden. Ausgeblendete Muster bzw. Positionen werden im Treeview mit einem roten Schrägstrich und in der Vorschau-Grafik durch einen hellroten Punkt markiert |
Ausgeblendetes Muster, bzw. ausgeblendete Position, wieder aktivieren |
Im Treeview gewählte Position für die Bearbeitung sperren. Gesperrte Positionen werden im Treeview mit einem roten Kreuz markiert. In der Grafik zeigt smarT.NC gesperrte Positionen nicht an. Diese Positionen werden nicht in der .HP-Datei gespeichert, die smarT.NC anlegt, sobald Sie den Musterbenerator beenden |
Gesperrte Positionen wieder aktivieren |
Definierte Bearbeitungspositionen in eine .PNT-Datei exportieren. Nur erforderlich, wenn Sie das Bearbeitungsmuster auf älteren Software-Ständen der iTNC 530 verwenden wollen |
Nur im Treeview gewähltes Muster anzeigen/alle definierten Muster anzeigen. Im Treeview gewähltes Muster zeigt smarT.NC blau an. |
Lineale anzeigen/ausblenden |
Seite nach oben blättern |
Seite nach unten blättern |
Sprung zum Datei-Anfang |
Sprung zum Datei-Ende |
Zoom-Funktion: Zoombereich nach oben verschieben (letzte Softkey-Leiste) |
Zoom-Funktion: Zoombereich nach unten verschieben (letzte Softkey-Leiste) |
Zoom-Funktion: Zoombereich nach links verschieben (letzte Softkey-Leiste) |
Zoom-Funktion: Zoombereich nach rechts verschieben (letzte Softkey-Leiste) |
Zoom-Funktion: Werkstück vergrößern. Die TNC vergrößert grundsätzlich so, dass die Mitte des momentan dargestellten Ausschnittes jeweils vergrößert wird. Ggf. mit den Bildlaufleisten die Zeichnung so im Fenster positionieren, dass das gewünschte Detail nach Betätigung des Softkeys direkt sichtbar ist (letzte Softkey-Leiste) |
Zoom-Funktion: Werkstück verkleinern (letzte Softkey-Leiste) |
Zoom-Funktion: Werkstück in Originalgröße anzeigen (letzte Softkey-Leiste) |


Einzelner Punkt, kartesisch

X: Koordinate in der Hauptachse der Bearbeitungsebene

Y: Koordinate in der Nebenachse der Bearbeitungsebene


Einzelne Reihe, gerade oder gedreht

Startpunkt 1. Achse: Koordinate des Reihen-Startpunktes in der Hauptachse der Bearbeitungsebene

Startpunkt 2. Achse: Koordinate des Reihen-Startpunktes in der Nebenachse der Bearbeitungsebene

Abstand: Abstand zwischen den Bearbeitungspositionen. Wert positiv oder negativ eingebbar

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen

Drehung: Drehwinkel um den eingegebenen Startpunkt. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar


Muster, gerade, gedreht oder verzerrt

Startpunkt 1. Achse: Koordinate des Muster-Startpunktes 1 in der Hauptachse der Bearbeitungsebene

Startpunkt 2. Achse: Koordinate des Muster-Startpunktes 2 in der Nebenachse der Bearbeitungsebene

Abstand 1. Achse: Abstand der Bearbeitungspositionen in der Hauptachse der Bearbeitungsebene. Wert positiv oder negativ eingebbar

Abstand 2. Achse: Abstand der Bearbeitungspositionen in der Nebenachse der Bearbeitungsebene. Wert positiv oder negativ eingebbar

Anzahl Zeilen: Gesamt-Zeilenanzahl des Musters

Anzahl Spalten: Gesamt-Spaltenanzahl des Musters

Drehung: Drehwinkel, um den das gesamte Muster um den eingegebenen Startpunkt gedreht wird. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Drehlage Hauptachse: Drehwinkel, um den ausschließlich die Hauptachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Drehlage Nebenachse: Drehwinkel, um den ausschließlich die Nebenachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Die Parameter Drehlage Hauptachse und Drehlage Nebenachse wirken additiv auf eine zuvor durchgeführte Drehung des gesamten Musters.


Rahmen, gerade, gedreht oder verzerrt

Startpunkt 1. Achse: Koordinate des Rahmen-Startpunktes 1 in der Hauptachse der Bearbeitungsebene

Startpunkt 2. Achse: Koordinate des Rahmen-Startpunktes 2 in der Nebenachse der Bearbeitungsebene

Abstand 1. Achse: Abstand der Bearbeitungspositionen in der Hauptachse der Bearbeitungsebene. Wert positiv oder negativ eingebbar

Abstand 2. Achse: Abstand der Bearbeitungspositionen in der Nebenachse der Bearbeitungsebene. Wert positiv oder negativ eingebbar

Anzahl Zeilen: Gesamt-Zeilenanzahl des Rahmens

Anzahl Spalten: Gesamt-Spaltenanzahl des Rahmens

Drehung: Drehwinkel, um den der gesamte Rahmen um den eingegebenen Startpunkt gedreht wird. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Drehlage Hauptachse: Drehwinkel, um den ausschließlich die Hauptachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Drehlage Nebenachse: Drehwinkel, um den ausschließlich die Nebenachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Die Parameter Drehlage Hauptachse und Drehlage Nebenachse wirken additiv auf eine zuvor durchgeführte Drehung des gesamten Rahmens.


Vollkreis

Mitte 1. Achse: Koordinate des Kreis-Mittelpunktes 1 in der Hauptachse der Bearbeitungsebene

Mitte 2. Achse: Koordinate des Kreis-Mittelpunktes 2 in der Nebenachse der Bearbeitungsebene

Durchmesser: Kreis-Durchmesser

Startwinkel: Polarwinkel der ersten Bearbeitungsposition. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen auf dem Kreis

smarT.NC berechnet den Winkelschritt zwischen zwei Bearbeitungspositionen immer aus 360° dividiert durch die Anzahl der Bearbeitungen.


Teilkreis

Mitte 1. Achse: Koordinate des Kreis-Mittelpunktes 1 in der Hauptachse der Bearbeitungsebene

Mitte 2. Achse: Koordinate des Kreis-Mittelpunktes 2 in der Nebenachse der Bearbeitungsebene

Durchmesser: Kreis-Durchmesser

Startwinkel: Polarwinkel der ersten Bearbeitungsposition. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Winkelschritt: Inkrementaler Polarwinkel zwischen zwei Bearbeitungspositionen. Wert positiv oder negativ eingebbar. Eine Änderung des Winkelschritts bewirkt automatisch eine Änderung des definierten Endwinkels

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen auf dem Kreis

Endwinkel: Polarwinkel der letzten Bohrung. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar. Eine Änderung des Endwinkels bewirkt automatisch eine Änderung des ggf. zuvor definierten Winkelschritts


Starthöhe verändern

Koordinate Oberfläche: Koordinate der Werkstück-Oberfläche

Wenn Sie bei der Definition der Bearbeitungspositionen keine Starthöhe definieren, setzt smarT.NC die Koordinate der Werkstück-Oberfläche immer auf 0.

Wenn Sie die Starthöhe verändern, dann gilt die neue Starthöhe für alle nachfolgend programmierten Bearbeitungspositionen.

Wenn Sie im Treeview das Symbol für Koordinate Oberfläche anwählen, markiert die Vorschau-Grafik alle Bearbeitungspositionen grün, für die diese Starthöhe gilt.


Rückzugshöhe für Anpositionierung definieren (FCL 3-Funktion)

  • Per Pfeiltasten beliebige einzelne Position wählen, die auf einer von Ihnen definierten Höhe angefahren werden soll

Rückzugshöhe: Absolute Koordinate eingeben, in der die TNC diese Position anfahren soll. Position wird von der TNC mit einem zusätzlichen Kreis markiert

Die von Ihnen definierte Rückzugshöhe bezieht sich grundsätzlich auf den aktiven Bezugspunkt.


Konturen definieren

Weitere Informationen:
> Konturen definieren


Konturen definieren

Konturen definieren

Weitere Informationen:
> Grundlagen
> Konturprogrammierung starten
> Konturprogrammierung beenden
> Arbeiten mit der Konturprogrammierung


Grundlagen

Konturen definieren Sie grundsätzlich in separaten Dateien (Datei-Typ .HC). Da .HC-Dateien reine Konturbeschreibung – nur Geometrie-, keine Technologiedaten – beinhalten, können Sie diese flexibel einsetzen: als Konturzug, als Tasche oder als Insel.

HC-Dateien können Sie entweder mit den zur Verfügung stehenden Bahnfunktionen erstellen oder mit Hilfe des DXF-Konverters (Software-Option) aus existierenden DXF-Dateien exportieren.

Bereits existierende Konturbeschreibungen in älteren Klartext-Dialog-Programmen (.H-Dateien), können Sie mit wenigen Handgriffen in eine smarT.NC-Konturbeschreibung konvertieren (siehe Vorhandene Klartext-Dialog-Programme in Kontur-Programme konvertieren).

Ebenso wie in Unitprogrammen und beim Mustergenerator, stellt smarT.NC jedes einzelne Konturelement im Treeview 1 mit einem entsprechenden Icon dar. Im Eingabeformular 2 geben Sie die Daten zum jeweiligen Konturelement ein. Bei der Freien Kontur-Programmierung FK stehen neben dem Übersichtsformular 3 bis zu 3 weitere Detailformulare (4) zur Verfügung, in denen Sie Daten eingeben können (siehe Bild rechts unten).


Konturprogrammierung starten

Die smarT.NC-Konturprogrammierung lässt sich auf zwei unterschiedliche Weisen starten:

  • Direkt aus der Hauptleiste des Editieren-Menüs, wenn Sie mehrere separate Konturen direkt hintereinander definieren wollen
  • Während der Bearbeitungsdefinition aus dem Formular heraus, wenn Sie die zu bearbeitenden Konturnamen eingeben sollen
Weitere Informationen:
> Konturprogrammierung aus der Hauptleiste des Editieren-Menüs starten
> Konturprogrammierung aus einem Formular heraus starten


Konturprogrammierung aus der Hauptleiste des Editieren-Menüs starten

Betriebsart smarT.NC wählen

Dritte Softkey-Leiste wählen

Konturprogrammierung starten: smarT.NC wechselt in die Datei-Verwaltung (siehe Bild rechts) und zeigt - wenn vorhanden - bereits existierende Konturprogramme an

Vorhandens Konturprogramm (*.HC) wählen, mit Taste ENT übernehmen, oder

Neues Konturprogramm öffnen: Datei-Namen (ohne Datei-Typ) eingeben, mit Taste mm oder inch bestätigen: smarT.NC öffnet ein Konturprogramm in der von Ihnen gewählten Maßeinheit

smarT.NC fügt automatisch zwei Zeilen zur Definition der Zeichenfläche ein. Ggf. Dimensionen anpassen


Konturprogrammierung aus einem Formular heraus starten

Betriebsart smarT.NC wählen

Beliebigen Bearbeitungsschritt wählen, für den Konturprogramme erforderlich sind (UNIT 122, UNIT 125)

Eingabefeld wählen, in dem der Name des Konturprogramms zu definieren ist (1, siehe Bild)

Um eine neue Datei zu erstellen: Datei-Namen (ohne Datei-Typ) eingeben, mit Softkey neu bestätigen

Maßeinheit des neuen Konturprogramms im Überblendfenster mit Taste mm oder inch bestätigen: smarT.NC öffnet ein Konturprogramm in der von Ihnen gewählten Maßeinheit, befindet sich anschließend in der Konturprogrammierung und übernimmt automatisch die im Unit-Programm festgelegte Rohteildefinition (Definition der Zeichenfläche)

Um eine vorhandene HC-Datei zu wählen: Softkey wählen hc drücken: smarT.NC zeigt ein Überblendfenster mit vorhandenen Konturprogrammen. Eine der angezeigten Konturprogramme wählen und mit Taste ENT oder Schalftläche OK ins Formular übernehmen

Um eine bereits gewählte HC-Datei zu editieren: Softkey editieren drücken: smarT.NC startet dann direkt die Konturprogrammeirung

Um eine HC-Datei mit dem DXF-Konverter zu erstellen: Softkey ZEIGE dxf drücken: smarT.NC zeigt ein Überblendfenster mit vorhandenen DXF-Dateien. Eine der angezeigten DXF-Dateien wählen und mit Taste ENT oder Schalftläche OK übernehmen: Die TNC startet den DXF-Konverter, mit dem Sie die gewünschte Kontur selektieren und den Konturnamen direkt ins Formular speichern können siehe DXF-Dateien verarbeiten (Software-Option)


Konturprogrammierung beenden

Taste END drücken: smarT.NC beendet die Konturprogrammierung und kehrt in den Zustand zurück, von wo aus Sie die Konturprogrammierung gestartet haben: In das zuletzt aktive HU-Programm - sofern Sie aus der smarT.NC-Hauptleiste gestartet haben, bzw. in das Eingabeformular des jeweiligen Bearbeitungsschrittes, sofern Sie aus dem Formular heraus gestartet haben

Wenn Sie die Konturprogrammierung aus einem Formular heraus gestartet haben, dann kehren Sie nach dem Beenden automatisch wieder dorthin zurück.

Wenn Sie die Konturprogrammierung aus der Hauptleiste gestartet haben, dann kehren Sie nach dem Beenden automatisch wieder in das zuletzt angewählte HU-Programm zurück.


Arbeiten mit der Konturprogrammierung

Weitere Informationen:
> Übersicht
> Freie Kontur-Programmierung FK
> Funktionen der Programmier-Grafik
> Wählen aus mehreren möglichen Lösungen
> Verfügbare Funktionen bei der Kontur-Programmierung
> Vorhandene Klartext-Dialog-Programme in Kontur-Programme konvertieren


Übersicht

Die Programmierung der Konturelemente erfolgt mit den bekannten Klartext-Dialog-Funktionen. Neben den grauen Bahnfunktionstasten steht selbstverständlich auch die leistungsfähige Freie Konturprogrammierung FK zur Verfügung, deren Formulare per Softkeys aufzurufen sind.

Besonders hilfreich bei der Freien Kontur-Programmierung FK sind die Hilfsbilder, die zu jedem Eingabefeld verfügbar sind und verdeutlichen, welcher Parameter einzugeben ist.

Alle bekannten Funktionen der Programmier-Grafik, stehen auch in smarT.NC uneingeschränkt zur Verfügung.

    Die Dialogführung in den Formularen ist nahezu identisch zur Dialogführung bei der Klartext-Programmierung:

  • Die orangenen Achstasten positionieren den Cursor ins entsprechende Eingabefeld
  • Mit der orangenen Taste I schalten Sie zwischen Absolut- und Inkremental-Programmierung um
  • Mit der orangenen Taste P schalten Sie zwischen kartesischer und Polarkoordinaten-Programmierung um


Freie Kontur-Programmierung FK

Werkstückzeichnungen, die nicht NC-gerecht bemaßt sind, enthalten oft Koordinaten-Angaben, die Sie nicht über die grauen Dialog-Tasten eingeben können.

Solche Angaben programmieren Sie direkt mit der Freien Kontur-Programmierung FK. Die TNC errechnet die Kontur aus den von Ihnen per Formular eingegebenen, bekanten Kontur-Informationen. Folgende Funktionen stehen zur Verfügung:

Funktion | Softkey
Gerade mit tangentialem Anschluss |
Gerade ohne tangentialen Anschluss |
Kreisbogen mit tangentialem Anschluss |
Kreisbogen ohne tangentialen Anschluss |
Pol für FK-Programmierung |

Informationen zu den möglichen Kontur-Angaben finden Sie im Tipp-Text, den die TNC zu jedem Eingabefeld einblendet siehe Maus-Bedienung und im Benutzer-Handbuch Klartext-Dialog.


Funktionen der Programmier-Grafik
Funktion | Softkey
Programmier-Grafik vollständig erstellen |
Programmier-Grafik satzweise erstellen |
Programmier-Grafik komplett erstellen, oder nach RESET + START vervollständigen |
Programmier-Grafik anhalten. Dieser Softkey erscheint nur, während die TNC eine Programmier-Grafik erstellt |
Zoom-Funktion (Softkey-Leiste 3): Rahmen einblenden und verschieben |
Zoom-Funktion: Ausschnitt verkleinern, zum Verkleinern Softkey mehrfach drücken |
Zoom-Funktion: Ausschnitt vergrößern, zum Vergrößern Softkey mehrfach drücken |
Ursprünglichen Ausschnitt wieder herstellen |
Ausgewählten Bereich übernehmen |

Unterschiedliche Farben der angezeigten Konturelemente bestimmen deren Gültigkeit:

blau | Das Konturelement ist eindeutig bestimmt
grün | Die eingegebenen Daten lassen mehrere Lösungen zu; Sie wählen die richtige aus
rot | Die eingegebenen Daten legen das Konturelement noch nicht ausreichend fest; Sie geben weitere Angaben ein


Wählen aus mehreren möglichen Lösungen

Sofern unvollständige Eingaben auf mehrere, theoretisch mögliche Lösungen führen, können Sie per Softkey die richtige Lösung grafisch unterstützt wählen:

Die verschiedenen Lösungen anzeigen

Die angezeigte Lösung auswählen und übernehmen

Weitere Konturelemente programmieren

Programmier-Grafik zum nächsten programmierten Satz erstellen


Verfügbare Funktionen bei der Kontur-Programmierung
Funktion | Softkey
Rohteil-Definition aus dem .HU-Programm übernehmen, wenn Sie die Kontur-Programmierung aus einer smarT.NC-Unit heraus aufgerufen haben |
Anzeigen/Ausblenden der Satznummer |
Programmier-Grafik neu zeichnen, wenn z.B. durch Überschneidungen Linien gelöscht wurden |
Programmier-Grafik löschen |
Programmierte Konturelemente sofort nach der Eingabe grafisch darstellen: Funktion AUS / EIN |


Vorhandene Klartext-Dialog-Programme in Kontur-Programme konvertieren

Bei diesem Vorgang müssen Sie ein vorhandenes Klartext-Dialog-Programm (.H-Datei) in eine Konturbeschreibung (.HC-Datei) kopieren. Da beide Datei-Typen ein unterschiedliches internes Datenformat besitzen, muss der Kopiervorgang über eine ASCII-Datei laufen. Gehen Sie wie folgt vor:

Betriebsart Programm-Einspeichern/Editieren wählen

Datei-Verwaltung aufrufen

zu konvertierendes .H-Programm wählen

Kopierfunktion wählen: Als Zieldatei *.A eingeben, die TNC erstellt aus dem Klartext-.Dialog-Programm eine ASCII-Datei

Zuvor erstellte ASCII-Datei wählen

Kopierfunktion wählen: Als Zieldatei *.HC eingeben, die TNC erstellt aus der ASCII-Datei eine Konturbeschreibung

Neu erstellte .HC-Datei wählen und alle Sätze – mit Ausnahme der Rohteil-Definition BLK FORM – entfernen, die keine Kontur beschreiben

Programmierte Radius-Korrekturen, Vorschübe und Zusatz-Funktionen M entfernen, die HC-Datei ist jetzt von smarT.NC verwendbar


DXF-Dateien verarbeiten (Software-Option)

Weitere Informationen:
> DXF-Dateien verarbeiten (Software-Option)


DXF-Dateien verarbeiten (Software-Option)

DXF-Dateien verarbeiten (Software-Option)

Weitere Informationen:
> Anwendung
> DXF-Datei öffnen
> Grundeinstellungen
> Layer einstellen
> Bezugspunkt festlegen
> Kontur wählen, Konturprogramm speichern
> Bearbeitungspositionen wählen und speichern
> Zoom-Funktion


Anwendung

Auf einem CAD-System erzeugte DXF-Dateien können Sie direkt auf der TNC öffnen, um daraus Konturen oder Bearbeitungspositionen zu extrahieren und diese als Klartext-Dialog-Programme bzw. als Punkte-Dateien zu speichern. Die bei der Konturselektion gewonnen Klartext-Dialog-Programme können auch von älteren TNC-Steuerungen abgearbeitet werden, da die Konturprogramme nur L- und CC-/C-Sätze enthalten.

Die zu verarbeitende DXF-Datei muss auf der Festplatte der TNC gespeichert sein.

Vor dem Einlesen in die TNC darauf achten, dass der Dateiname der DXF-Datei keine Leerzeichen bzw. unzulässige Sonderzeichen enthält.

Die zu öffnende DXF-Datei muss mindestens einen Layer enthalten.

Die TNC unterstützt das am weitesten verbreitete DXF‑Format R12 (entspricht AC1009).

Die TNC unterstützt kein binäres DXF-Format. Beim Erzeugen der DXF-Datei aus dem CAD- oder Zeichenprogramm darauf achten, dass Sie die Datei im ASCII-Format speichern.

    Als Kontur selektierbar sind folgende DXF-Elemente:

    • LINE (Gerade)
    • CIRCLE (Vollkreis)
    • ARC (Teilkreis)
    • POLYLINE (Poly-Linie)


DXF-Datei öffnen

Der DXF-Konverter lässt sich auf unterschiedliche Weisen starten:

  • Über die Datei-Verwaltung, wenn Sie mehrere Kontur- oder Positions-Dateien hintereinander extrahieren wollen
  • Während der Bearbeitungsdefinition der Units 125 (Konturzug), 122 (Konturtasche) und 130 (Konturtasche auf Punktemuster) aus dem Formular heraus, wenn Sie die zu bearbeitenden Konturnamen eingeben sollen
  • Während der Bearbeitungsdefinition, wenn Sie Bearbeitungspositionen über Punkte-Dateien eingeben

Die TNC speichert beim Beenden des DXF-Konverters automatisch den von Ihnen definierten Bezugspunkt und zusätzlich den aktuellen Zoom-Zustand. Wenn Sie dieselbe DXF-Datei erneut öffnen, dann lädt die TNC diese Informationen (gilt für die zuletzt gewählte Datei).

Weitere Informationen:
> DXF-Konverter über die Datei-Verwaltung starten
> DXF-Konverter aus einem Formular heraus starten


DXF-Konverter über die Datei-Verwaltung starten

Betriebsart smarT.NC wählen

Datei-Verwaltung wählen

Softkey-Menü zur Auswahl der anzuzeigenden Datei-Typen wählen: Softkey TYP WÄHLEN drücken

Alle DXF-Dateien anzeigen lassen: Softkey zeige DXF drücken

Gewünschte DXF-Datei wählen, mit Taste ENT übernehmen: smarT.NC startet den DXF-Konverter und zeigt den Inhalt der DXF-Datei am Bildschirm an. Im linken Fenster zeigt die TNC die sogenannten Layer (Ebenen) an, im rechten Fenster die Zeichnung


DXF-Konverter aus einem Formular heraus starten

Betriebsart smarT.NC wählen

Beliebigen Bearbeitungsschritt wählen, für den Konturprogramme oder Punkte-Dateien erforderlich sind

Eingabefeld wählen, in dem der Name eines Konturprogramms bzw. der Name einer Punkte-Datei zu definieren ist

DXF-Konverter starten: Softkey ZEIGE dxf drücken: smarT.NC zeigt ein Überblendfenster mit vorhandenen DXF‑Dateien. Bei Bedarf Verzeichnis wählen, in dem die zu öffnende DXF-Datei gespeichert ist. Eine der angezeigten DXF-Dateien wählen und mit Taste ENT oder Schalftläche OK übernehmen: Die TNC startet den DXF-Konverter, mit dem Sie die gewünschte Kontur oder die gewünschten Positionen selektieren und den Konturnamen bzw. den Namen der Punkte-Datei direkt ins Formular speichern können siehe DXF-Dateien verarbeiten (Software-Option)


Grundeinstellungen

Auf der dritten Softkey-Leiste stehen verschieden Einstellmöglichkeiten zur Verfügung:

Einstellung Softkey

FARBE normal/invers: Umschalten des Farbschemas

3D-Modus/2D-Modus: Umschalten zwischen 2D‑ und 3D-Modus

Maßeinheit MM/INCH: Maßeinheit der DXF-Datei einstellen. In dieser Maßeinheit gibt die TNC auch das Kontur-Programm aus.

Toleranz einstellen. Die Toleranz legt fest, wie weit benachbarte Konturelemente voneinander entfernt sein dürfen. Mit der Toleranz können Sie Ungenauigkeiten ausgleichen, die bei der Zeichnungserstellung gemacht wurden. Grundeinstellung ist abhängig von der Ausdehnung der gesamten DXF-Datei.

Auflösung einstellen. Die Auflösung legt fest, mit wieviel Nachkommastellen die TNC das Kontur-Programm erzeugen soll. Grundeinstellung: 4 Nachkommastellen (entspricht 0.1 µm Auflösung)

    Modus für Punktübernahme bei Kreisen und Teilkreisen. Modus legt fest, ob die TNC beim Wählen von Bearbeitungspositionen mit einem Maus-Klick den Kreismittelpunkt direkt übernehmen soll (AUS), oder ob zunächst zusätzliche Kreispunkte angezeigt werden sollen.

    • AUS
      Zusätzliche Kreispunkte nicht anzeigen, Kreismittelpunkt direkt übernehmen, wenn Sie einen Kreis oder einen Teilkreis anklicken
    • EIN
      Zusätzliche Kreispunkte anzeigen, gewünschten Kreispunkt durch erneutes Anklicken übernehmen

Werkzeugbahn anzeigen: Festlegen, ob die TNC beim Wählen von Bearbeitungspositionen den Verfahrweg des Werkzeugs anzeigen soll oder nicht.

Beachten Sie, dass Sie die richtige Maßeinheit einstellen müssen, da in der DXF-Datei diesbezüglich keine Informationen enthalten sind.


Layer einstellen

DXF-Dateien enthalten in der Regel mehrere Layer (Ebenen), mit denen der Konstrukteur seine Zeichnung organisieren kann. Mit Hilfe der Layertechnik gruppiert der Konstrukteur verschiedenartige Elemente, z.B. die eigentliche Werkstück-Kontur, Bemaßungen, Hilfs- und Konstruktionslinien, Schraffuren und Texte.

Um bei der Konturauswahl möglichst wenig überflüssige Informationen am Bildschirm zu haben, können Sie alle überflüssigen, in der DXF-Datei enthaltenen Layer ausblenden.

Die zu verarbeitende DXF-Datei muss mindestens einen Layer enthalten.

Sie können eine Kontur auch dann selektieren, wenn der Konstrukteur diese auf unterschiedlichen Layern gespeichert hat.

Wenn nicht schon aktiv, den Modus zum Einstellen der Layer wählen: Die TNC zeigt im linken Fenster alle Layer an, die in der aktiven DXF-Datei enthalten sind

Um einen Layer auszublenden: Mit der linken Maus-Taste den gewünschten Layer wählen und durch -Klicken auf das Kontrollkästchen ausblenden

Um einen Layer einzublenden: Mit der linken Maus-Taste den gewünschten Layer wählen und durch -Klicken auf das Kontrollkästchen wieder einblenden


Bezugspunkt festlegen

Der Zeichnungs-Nullpunkt der DXF-Datei liegt nicht immer so, dass Sie diesen direkt als Werkstück-Bezugspunkt verwenden können. Die TNC stellt daher eine Funktion zur Verfügung, mit der Sie den Zeichnungs-Nullpunkt durch Anklicken eines Elementes an eine sinnvolle Stelle verschieben können.

    An folgenden Stellen können Sie den Bezugspunkt definieren:

  • am Anfangs-, Endpunkt oder in der Mitte einer Geraden
  • am Anfangs- oder Endpunkt eines Kreisbogens
  • jeweils am Quadrantenübergang oder in der Mitte eines Vollkreises
  • im Schnittpunkt von
    • Gerade – Gerade, auch wenn der Schnittpunkt in der Verlängerung der jeweiligen Geraden liegt
    • Gerade – Kreisbogen
    • Gerade – Vollkreis
    • Vollkreis/Teilkreis – Vollkreis/Teilkreis

Um einen Bezugspunkt festlegen zu können, müssen Sie das Touch-Pad auf der TNC-Tastatur oder eine über USB angeschlossene Maus verwenden.

Sie können den Bezugspunkt auch noch verändern, wenn Sie die Kontur bereits gewählt haben. Die TNC berechnet die tatsächlichen Konturdaten erst, wenn Sie die gewählte Kontur in ein Konturprogramm speichern.
Weitere Informationen:
> Bezugspunkt auf einzelnem Element wählen
> Bezugspunkt als Schnittpunkt zweier Elemente wählen
> Elementinformationen


Bezugspunkt auf einzelnem Element wählen

Modus zum Festlegen des Bezugspunktes wählen

Mit der linken Maus-Taste das gewünschte Element anklicken, auf das Sie den Bezugspunkt legen wollen: Die TNC zeigt per Stern wählbare Bezugspunkte an, die auf dem selektierten Element liegen

Auf den Stern klicken, den Sie als Bezugspunkt wählen wollen: Die TNC setzt das Bezugspunkt-Symbol auf die gewählte Stelle. Ggf. Zoom-Funktion verwenden, wenn das gewählte Element zu klein ist


Bezugspunkt als Schnittpunkt zweier Elemente wählen

Modus zum Festlegen des Bezugspunktes wählen

Mit der linken Maus-Taste das erste Element (Gerade, Vollkreis oder Kreisbogen) anklicken: Die TNC zeigt per Stern wählbare Bezugspunkte an, die auf dem selektierten Element liegen

Mit der linken Maus-Taste das zweite Element (Gerade, Vollkreis oder Kreisbogen) anklicken: Die TNC setzt das Bezugspunkt-Symbol auf den Schnittpunkt

Die TNC berechnet den Schnittpunkt zweier Elemente auch dann, wenn dieser in der Verlängerung eines Elementes liegt.

Wenn die TNC mehrere Schnittpunkte berechnen kann, dann wählt die Steuerung den Schnittpunkt, der dem Mausklick des zweiten Elementes am nächsten liegt.

Wenn die TNC keinen Schnittpunkt berechnen kann, dann hebt sie ein bereits markiertes Element wieder auf.


Elementinformationen

Die TNC zeigt im Bildschirm links unten an, wie weit der von Ihnen gewählte Bezugspunkt vom Zeichnungsnullpunkt entfernt ist.


Kontur wählen, Konturprogramm speichern

Um eine Kontur wählen zu können, müssen Sie das Touch-Pad auf der TNC-Tastatur oder eine über USB angeschlossene Maus verwenden.

Wählen Sie das erste Konturelement so aus, dass ein kollisionsfreies Anfahren möglich ist.

Sollten die Konturelemente sehr dicht aufeinander liegen, Zoom-Funktion nutzen

Modus zum Selektieren der Kontur wählen: Die TNC blendet die im linken Fenster angezeigten Layer aus und das rechte Fenster ist für die Konturauswahl aktiv

Um ein Konturelement zu wählen: Mit der linken Maus-Taste auf das gewünschten Konturelement klicken. Die TNC stellt das ausgewählte Konturelement blau dar. Gleichzeitig zeigt die TNC das gewählte Element mit einem Symbol (Kreis oder Gerade) im linken Fenster an

Um das nächste Konturelement zu wählen: Mit der linken Maus-Taste auf das gewünschte Konturelement klicken. Die TNC stellt das ausgewählte Konturelement blau dar. Wenn weitere Konturelemente in der gewählten Umlaufrichtung eindeutig selektierbar sind, dann kennzeichnet die TNC diese Elemente grün. Durch Klicken auf das letzte grüne Element übernehmen Sie alle Elemente in das Kontur-Programm. Im linken Fenster zeigt die TNC alle selektierten Konturelemente an. Noch grün markierte Elemente zeigt die TNC ohne Häkchen in der Spalte NC an. Solche Elemente speichert die TNC nicht in das Konturprogramm

Bei Bedarf können Sie bereits selektierte Elemente wieder deselektieren, indem Sie das Element im rechten Fenster erneut anklicken, jedoch zusätzlich die Taste CTRL gedrückt halten

Wenn Sie Poly-Linien selektiert haben, dann zeigt die TNC im linken Fenster eine zweistufige Id-Nummer an. Die erste Nummer ist die fortlaufende Konturelement-Nummer, die zweite Nummer ist die aus der DXF-Datei stammende Elementnummer der jeweiligen Poly-Linie.

Gewählte Konturelemente in einem Klartext-Dialog-Programm speichen: Die TNC zeigt ein Überblendfenster, in dem Sie einen beliebigen Dateinamen eingeben können. Grundeinstellung: Name der DXF-Datei

Eingabe bestätigen: Die TNC speichert das Kontur-Programm in dem Verzeichnis, in dem auch die DXF-Datei gespeichert ist

Wenn Sie noch weitere Konturen wählen wollen: Softkey gewählte elemente aufheben drücken und nächste Kontur wie zuvor beschrieben wählen

Die TNC gibt zwei Rohteil-Definitionen (BLK FORM) mit ins Konturprogramm aus. Die erste Definition enthält die Abmessungen der gesamten DXF-Datei, die zweite und damit - zunächst wirksame Definition - umschließt die selektierten Konturelemente, so dass eine optimierte Rohteilgröße entsteht.

Die TNC speichert nur die Elemente, die tatsächlich auch selektiert sind (blaue markierte Elemente), also mit einem Häckchen im linken Fenster versehen sind.

Wenn Sie den DXF-Konverter aus einem Formular heraus aufgerufen haben, dann beendet smarT.NC den DXF-Konverter automatisch, nachdem Sie die Funktion gewählte elemente speichern ausgeführt haben. Den definierten Konturnamen schreibt smarT.NC dann in das Eingabefeld, von dem aus Sie den DXF-Konverter gestartet haben.

Weitere Informationen:
> Konturelemente teilen, verlängern, verkürzen
> Elementinformationen


Konturelemente teilen, verlängern, verkürzen

Wenn zu selektierende Konturelemente in der Zeichnung stumpf aneinderstoßen, müssen Sie das entsprechende Konturelement zunächst teilen. Diese Funktion steht Ihnen automatisch zur Verfügung, wenn Sie sich im Modus zum Selektieren einer Kontur befinden.

Gehen Sie wie folgt vor:

  • Das stumpf anstoßende Konturelement ist ausgewählt, also blau markiert

  • Zu teilendes Konturelement anklicken: Die TNC zeigt den Schnittpunkt durch einen Stern mit Kreis an und die selektierbaren Endpunkte durch einen einfachen Stern

  • Mit gedrückter Taste CTRL auf den Schnittpunkt klicken: Die TNC teilt das Konturelement im Schnittpunkt und blendet die Punkte wieder aus. Ggf. verlängert oder verkürzt die TNC das stumpf anstoßende Konturelement bis an den Schnittpunkt beider Elemente

  • Das geteilte Konturelement erneut anklicken: Die TNC blendet den Schnitt- und die Endpunkte wieder ein

  • Gewünschten Endpunkt anklicken: Die TNC markiert das jetzt geteilte Element blau

  • Nächstes Konturelement wählen

Wenn das zu verlängernde/zu verkürzende Konturelement eine Gerade ist, dann verlängert/verkürzt die TNC das Konturelement linear. Wenn das zu verlängernde/zu verkürzende Konturelement ein Kreisbogen ist, dann verlängert/verkürzt die TNC den Kreisbogen zirkular.

Um diese Funktionen nutzen zu können, müssen mindestens zwei Konturelemente bereits selektiert sein, damit die Richtung eindeutig bestimmt ist.


Elementinformationen

    Die TNC zeigt im Bildschirm links unten verschiedene Informationen zu dem Konturelement an, das Sie zuletzt im linken oder rechten Fenster per Maus-Klick gewählt haben.

  • Gerade
    Endpunkt der Geraden und zusätzlich ausgegraut den Startpunkt der Geraden
  • Kreis, Teilkreis
    Kreismittelpunkt, Kreisendpunkt und Drehsinn. Zusätzlich ausgegraut Startpunkt und Radius des Kreises


Bearbeitungspositionen wählen und speichern

Um Bearbeitungspositionen wählen zu können, müssen Sie das Touch-Pad auf der TNC-Tastatur oder eine über USB angeschlossene Maus verwenden.

Sollten die zu wählenden Positionen sehr dicht aufeinander liegen, Zoom-Funktion nutzen.

Ggf. Grundeinstellung so wählen, dass die TNC Werkzeugbahnen anzeigt siehe Grundeinstellungen.

    Um Bearbeitungspositionen zu wählen, stehen Ihnen drei Möglichkeiten zur Verfügung:

  • Einzelanwahl:
    Sie wählen die gewünschte Bearbeitungsposition durch einzelne Maus-Klicks
  • Schnellanwahl für Bohrpositionen über Maus-Bereich:
    Sie wählen durch Aufziehen eines Bereiches mit der Maus alle darin enthaltenen Bohrpositionen aus
  • Schnellanwahl für Bohrpositionen über Durchmesser-Eingabe:
    Sie wählen durch Eingabe eines Bohrungsdurchmessers alle in der DXF-Datei enthaltenen Bohrpositionen mit diesem Durchmesser aus
Weitere Informationen:
> Einzelanwahl
> Schnellanwahl von Bohrpositionen über Maus-Bereich
> Schnellanwahl von Bohrpositionen über Durchmesser-Eingabe
> Filtereinstellungen
> Elementinformationen
> Aktionen rückgängig machen


Einzelanwahl

Modus zum Selektieren von Bearbeitungsposition wählen: Die TNC blendet die im linken Fenster angezeigten Layer aus und das rechte Fenster ist für die Positionsauswahl aktiv

Um eine Bearbeitungsposition zu wählen: Mit der linken Maus-Taste das gewünschte Element anklicken: Die TNC zeigt per Stern wählbare Bearbeitungspositionen an, die auf dem selektierten Element liegen. Einen der Sterne anklicken: Die TNC übernimmt die gewählte Position ins linke Fenster (anzeigen eines Punkt-Symbols). Wenn Sie einen Kreis anklicken, dann übernimmt die TNC den Kreismittelpunkt direkt als Bearbeitungsposition

Bei Bedarf können Sie bereits selektierte Elemente wieder deselektieren, indem Sie das Element im rechten Fenster erneut anklicken, jedoch zusätzlich die Taste CTRL gedrückt halten (innerhalb der Markierung anklicken)

Wenn Sie die Bearbeitungsposition durch Schneiden zweier Elemente bestimmen wollen, erstes Element mit der linken Maus-Taste anklicken: Die TNC zeigt per Stern wählbare Bearbeitungspositionen an

Mit der linken Maus-Taste das zweite Element (Gerade, Vollkreis oder Kreisbogen) anklicken: Die TNC übernimmt den Schnittpunkt der Elemente ins linke Fenster (anzeigen eines Punkt-Symbols)

Gewählte Bearbeitungspositionen in eine Punkte-Datei speichern: Die TNC zeigt ein Überblendfenster, in dem Sie einen beliebigen Dateinamen eingeben können. Grundeinstellung: Name der DXF-Datei

Eingabe bestätigen: Die TNC speichert das Kontur-Programm in dem Verzeichnis, in dem auch die DXF-Datei gespeichert ist

Wenn Sie noch weitere Bearbeitungspositionen wählen wollen, um diese in einer anderen Datei zu speichern: Softkey gewählte elemente aufheben drücken und wie zuvor beschrieben wählen


Schnellanwahl von Bohrpositionen über Maus-Bereich

Modus zum Selektieren von Bearbeitungsposition wählen: Die TNC blendet die im linken Fenster angezeigten Layer aus und das rechte Fenster ist für die Positionsauswahl aktiv

Shift-Taste auf der Tastatur drücken und mit der linken Maus-Taste einen Bereich aufziehen, in dem die TNC alle enthaltenen Kreismittelpunkte als Bohrpositionen übernehmen soll: Die TNC blendet ein Fenster ein, in dem Sie die Bohrungen nach ihrer Größe filtern können

Filtereinstellungen setzen Filtereinstellungen und mit Schaltfläche Anwenden bestätigen: Die TNC übernimmt die gewählten Positionen ins linke Fenster (Anzeigen eines Punkt-Symbols)

Bei Bedarf können Sie bereits selektierte Elemente wieder deselektieren, indem Sie nochmal einen Bereich aufziehen, jedoch zusätzlich die Taste CTRL gedrückt halten

Gewählte Bearbeitungspositionen in eine Punkte-Datei speichen: Die TNC zeigt ein Überblendfenster, in dem Sie einen beliebigen Dateinamen eingeben können. Grundeinstellung: Name der DXF-Datei. Wenn der Name der DXF Umlaute oder Leerstellen enthält, dann ersetzt die TNC diese Zeichen durch einen Unterstrich

Eingabe bestätigen: Die TNC speichert das Kontur-Programm in dem Verzeichnis, in dem auch die DXF-Datei gespeichert ist

Wenn Sie noch weiter Bearbeitungspositionen wählen wollen um diese in einer anderen Datei zu speichern: Softkey gewählte elemente aufheben drücken und wie zuvor beschrieben wählen


Schnellanwahl von Bohrpositionen über Durchmesser-Eingabe

Modus zum Selektieren von Bearbeitungsposition wählen: Die TNC blendet die im linken Fenster angezeigten Layer aus und das rechte Fenster ist für die Positionsauswahl aktiv

Letzte Softkey-Leiste wählen

Dialog zur Durchmessereingabe öffnen: Die TNC zeigt ein Überblendfenster, in dem Sie einen beliebigen Durchmesser eingeben können

Gewünschten Durchmesser eingeben, mit Taste ENT bestätigen: Die TNC durchsucht die DXF-Datei nach dem eingegebenen Durchmesser und blendet danach ein Fenster ein, in dem der Durchmesser gewählt ist, der dem von Ihnen eingegebenen Durchmesser am nächsten kommt. Zusätzlich können Sie die Bohrungen nachträglich nach ihrer Größe filtern

Ggf. Filtereinstellungen setzen Filtereinstellungen und mit Schaltfläche Anwenden bestätigen: Die TNC übernimmt die gewählten Positionen ins linke Fenster (Anzeigen eines Punkt-Symbols)

Bei Bedarf können Sie bereits selektierte Elemente wieder deselektieren, indem Sie nochmal einen Bereich aufziehen, jedoch zusätzlich die Taste CTRL gedrückt halten

Gewählte Bearbeitungspositionen in eine Punkte-Datei speichen: Die TNC zeigt ein Überblendfenster, in dem Sie einen beliebigen Dateinamen eingeben können. Grundeinstellung: Name der DXF-Datei. Wenn der Name der DXF Umlaute oder Leerstellen enthält, dann ersetzt die TNC diese Zeichen durch einen Unterstrich

Eingabe bestätigen: Die TNC speichert das Kontur-Programm in dem Verzeichnis, in dem auch die DXF-Datei gespeichert ist

Wenn Sie noch weiter Bearbeitungspositionen wählen wollen um diese in einer anderen Datei zu speichern: Softkey gewählte elemente aufheben drücken und wie zuvor beschrieben wählen


Filtereinstellungen

Nachdem Sie über die Schnellauswahl Bohrpositionen markiert haben, zeigt die TNC ein Überblendfenster an, in dem links der kleinste und rechts der größte gefundene Bohrungsdurchmesser angezeigt wird. Mit den Schaltflächen unterhalb der Durchmesseranzeige können Sie im linken Bereich den unteren und im rechten Bereich den oberen Durchmesser so einstellen, dass Sie die von Ihnen gewünschten Bohrungsdurchmesser übernehmen können.

Folgende Schaltflächen stehen zur Verfügung:

Filtereinstellung kleinster Durchmesser | Softkey
Kleinsten gefundenen Durchmesser anzeigen (Grundeinstellung) |
Nächst kleineren gefundenen Durchmesser anzeigen |
Nächst größeren gefundenen Durchmesser anzeigen |
Größten gefundenen Durchmesser anzeigen. Die TNC setzt den Filter für den kleinsten Durchmesser auf den Wert, der für den größten Durchmesser gesetzt ist |

Filtereinstellung größter Durchmesser | Softkey
Kleinsten gefundenen Durchmesser anzeigen. Die TNC setzt den Filter für den größten Durchmesser auf den Wert, der für den kleinsten Durchmesser gesetzt ist |
Nächst kleineren gefundenen Durchmesser anzeigen |
Nächst größeren gefundenen Durchmesser anzeigen |
Größten gefundenen Durchmesser anzeigen (Grundeinstellung) |

Mit der Option Wegoptimierung anwenden (Grundeinstellung ist Wegoptimierung anwenden) sortiert die TNC die gewählten Bearbeitungspositionen so, dass möglichst keine unnötigen Leerwege entstehen. Die Werkzeugbahn können Sie sich über den Softkey WERKZEUGBAHN ANZEIGEN einblenden lassen siehe Grundeinstellungen.


Elementinformationen

Die TNC zeigt im Bildschirm links unten die Koordinaten der Bearbeitungsposition an, die Sie zuletzt im linken oder rechten Fenster per Maus-Klick gewählt haben.


Aktionen rückgängig machen

Sie können die letzten vier Aktionen, die Sie im Modus zum Selektieren von Bearbeitungspositionen durchgeführt haben, rückgängig machen. Hierfür stehen auf der letzten Softkey-Leiste folgende Softkeys zur Verfügung:

Funktion | Softkey
Zuletzt durchgeführte Aktion rückgängig machen |
Zuletzt durchgeführte Aktion wiederholen |


Zoom-Funktion

Um bei der Kontur- oder Punkteauswahl auch kleine Details leicht erkennen zu können, stellt die TNC eine leistungsfähige Zoom-Funktion zur Verfügung:

Funktion | Softkey
Werkstück vergrößern. Die TNC vergrößert grundsätzlich so, dass die Mitte des momentan dargestellten Ausschnittes jeweils vergrößert wird. Ggf. mit den Bildlaufleisten die Zeichnung so im Fenster positionieren, dass das gewünschte Detail nach Betätigung des Softkeys direkt sichtbar ist. |
Werkstück verkleinern |
Werkstück in Originalgröße anzeigen |
Zoombereich nach oben verschieben |
Zoombereich nach unten verschieben |
Zoombereich nach links verschieben |
Zoombereich nach rechts verschieben |

Wenn Sie eine Maus mit Rad verwenden, dann können Sie durch Drehen des Rades Aus- und Einzoomen. Das Zoomzentrum liegt an der Stelle, an der sich der Maus-Zeiger gerade befindet.


Datenübernahme aus Klartext-Dialog-Programmen (Software-Option)

Weitere Informationen:
> Datenübernahme aus Klartext-Dialog-Programmen (Software-Option)


Datenübernahme aus Klartext-Dialog-Programmen (Software-Option)

Datenübernahme aus Klartext-Dialog-Programmen (Software-Option)

Weitere Informationen:
> Anwendung
> Klartext-Dialogdatei öffnen
> Bezugspunkt festlegen, Konturen wählen und speichern


Anwendung

Mit dieser Funktion können Sie Konturabschnitte oder auch vollständige Konturen aus bestehenden, insbesondere mit CAM-Systemen erzeugten, Klartext-Dialog-Programmen entnehmen. Die TNC stellt die Klartext-Dialog-Programme zwei- oder dreidimensional dar.


Klartext-Dialogdatei öffnen

Betriebsart smarT.NC wählen

Beliebigen Bearbeitungsschritt wählen, für den Konturprogramme erforderlich sind

Eingabefeld wählen, in dem der Name eines Konturprogramms bzw. der Name einer Punkte-Datei zu definieren ist

Alle Klartext-Dialog-Dateien anzeigen lassen: Softkey zeige H drücken

Verzeichnis wählen, in dem die Datei gespeichert ist

Gewünschte H-Datei wählen


Bezugspunkt festlegen, Konturen wählen und speichern

Das Setzen des Bezugspunktes und das Wählen der Konturen ist identisch wie bei der Datenübernahme aus einer DXF-Datei:

  • Siehe „Bezugspunkt festlegen”, Seite 209
  • Siehe „Kontur wählen, Konturprogramm speichern”, Seite 212


UNIT-Programm grafisch testen und abarbeiten

Weitere Informationen:
> UNIT-Programm grafisch testen und abarbeiten


UNIT-Programm grafisch testen und abarbeiten

UNIT-Programm grafisch testen und abarbeiten

Weitere Informationen:
> Programmier-Grafik
> Test-Grafik und Programmlauf-Grafik
> Status-Anzeigen
> UNIT-Programm Abarbeiten


Programmier-Grafik

Die Programmier-Grafik steht nur bei der Erstellung eines Kontur-Programms (.HC-Datei) zur Verfügung.

Während der Programm-Eingabe kann die TNC die programmierte Kontur mit einer zweidimensionalen Grafik darstellen:

Programmier-Grafik vollständig erstellen

Programmier-Grafik satzweise erstellen

Grafik starten und vervollständigen

Automatisch mitzeichnen

Grafik löschen

Grafik neu zeichnen

Satznummern anzeigen oder ausblenden


Test-Grafik und Programmlauf-Grafik

Die Bildschirmaufteilung GRAFIK oder PROGRAMM+-GRAFIK wählen!

In den Unter-Betriebsarten Testen und Abarbeiten kann die TNC eine Bearbeitung grafisch darstellen. Über Softkey sind folgende Funktionen wählbar:

Draufsicht

Darstellung in 3 Ebenen

3D-Darstellung

Programm-Test bis zu einem bestimmten Satz ausführen

Gesamtes Programm testen

Programm unitweise testen

Rohteil rücksetzen und gesamtes Programm testen

Rohteilumriss anzeigen/nicht anzeigen

Rohteil zurücksetzen

Werkzeug anzeigen/ausblenden

Funktion „Bearbeitungszeit ermitteln“ ein-/ausschalten

Programm-Sätze mit „/“-Zeichen beachten oder nicht beachten

Stoppuhr-Funktionen anwählen

Simulations-Geschwindigkeit einstellen

Funktionen zur Auschnitts-Vergrößerung

Funktionen für die Schnittebenen

Funktionen zum Drehen und Vergrößern/Verkleinern


Status-Anzeigen

Die Bildschirmaufteilung PROGRAMM+STATUS wählen!

Im unteren Abschnitt des Bildschirms stehen in den Programmlauf-Betriebsarten Informationen über

  • Werkzeug-Position
  • Vorschub
  • aktive Zusatz-Funktionen

Über Softkeys oder durch Maus-Klick auf den jeweiligen Reiter können Sie weitere Status-Informationen in einem Bildschirmfenster einblenden lassen:

Reiter Übersicht aktivieren: Anzeige der wichtigsten Status-Informationen

Reiter POS aktivieren: Anzeige von Positionen

Reiter TOOL aktivieren: Anzeige von Werkzeug-Daten

Reiter TRANS aktivieren: Anzeige von aktiven Koordinaten-Tranformationen

Reiter nach links weiterschalten

Reiter nach rechts weiterschalten


UNIT-Programm Abarbeiten

UNIT-Programme (*.HU) können Sie in der Betriebsart smarT.NC oder in den herkömmlichen Programmlauf-Betriebsarten Einzelsatz bzw. Satzfolge ausführen.

Die TNC deaktiviert beim Wählen der Betriebsart smarT.NC‑Abarbeiten automatisch alle globalen Programmlaufeinstellungen, die Sie in den herkömmlichen Programmlauf-Betriebsarten Einzelsatz bzw. Satzfolge aktiviert haben. Weitere Informationen hierzu finden Sie im Benutzer-Handbuch Klartext-Dialog.

    In der Unter-Betriebsart Abarbeiten können Sie ein UNIT-Programm auf folgende Arten ausführen:

  • UNIT-Programm unitweise ausführen
  • UNIT-Programm komplett ausführen
  • Einzelne, aktive Unit ausführen

Beachten Sie die Hinweise zum Ausführen eines Programms im Maschinen-Handbuch und im Benutzer-Handbuch.
Weitere Informationen:
> Vorgehensweise
> Beliebiger Einstieg ins Programm (Satzvorlauf, FCL 2-Funktion)
> Satzvorlauf in eine Punkte-Tabelle (FCL 2-Funktion)


Vorgehensweise

Betriebsart smarT.NC wählen

Unter-Betriebsart Abarbeiten wählen

Softkey Unit einzeln abarbeiten wählen, oder

Softkey alle Units abarbeiten wählen, oder

Softkey aktive Unit abarbeiten wählen


Beliebiger Einstieg ins Programm (Satzvorlauf, FCL 2-Funktion)

Mit der Funktion Satzvorlauf können Sie ein Bearbeitungs-Programm ab einer frei wählbaren Zeilennummer abarbeiten. Die Werkstück-Bearbeitung bis zu dieser Zeilennummer wird von der TNC rechnerisch berücksichtigt und grafisch dargestellt (Bildschirm-Aufteilung programm + grafik wählen).

Wenn die Wiedereinstiegsstelle auf einem Bearbeitungsschritt liegt, bei dem Sie mehrere Bearbeitungspositionen definiert haben, dann können Sie die gewünschte Einstiegsstelle per Eingabe eines Punkte-Index wählen. Der Punkte-Index entspricht der Position des Punktes im Eingabeformular.

Besonders komfortabel können Sie den Punkte-Index wählen, wenn Sie die Bearbeitungspositionen in einer Punkte-Tabelle definiert haben. smarT.NC zeigt dann automatisch das definierte Bearbeitungsmuster in einem Vorschaufenster an und Sie können per Softkey die gewünschte Einstiegsstelle grafisch unterstützt wählen.


Satzvorlauf in eine Punkte-Tabelle (FCL 2-Funktion)

Betriebsart smarT.NC wählen

Unter-Betriebsart Abarbeiten wählen

Funktion Satzvorlauf wählen

Zeilennummer der Bearbeitungsunit eingeben in der Sie den Programmlauf starten wollen, mit Taste ENT bestätigen: smarT.NC zeigt im Vorschaufenster den Inhalt der Punkte-Tabelle an

Gewünschte Bearbeitungsposition wählen, an der Sie einsteigen wollen

NC-Start-Taste drücken: smarT.NC berechnet alle für den Programmeinstieg erforderlichen Faktoren

Funktion zum Anfahren der Startposition wählen: smarT.NC zeigt in einem Überblendfenster den an der Einstiegsstelle erforderlichen Maschinenstatus an

NC-Start-Taste drücken: smarT.NC stellt den Maschinenstatus her (z.B. erforderliches Werkzeug einwechseln)

NC-Start-Taste erneut drücken: smarT.NC fährt die Startposition in der im Überblendfenster gezeigten Reihenfolge an, alternativ können Sie per Softkey jede Achse separat auf die Startposition fahren

NC-Start-Taste drücken: smarT.NC setzt den Programmlauf fort

Zusätzlich stehen im Überblendfenster noch folgende Funktionen zur Verfügung:

Vorschau-Fenster ein-/ausblenden

Letzten gespeicherten Programm-Unterbrechungspunkt ein-/ausblenden

Letzten gespeicherten Programm-Unterbrechungspunkt übernehmen