BHB Programmierplatz iTNC 530

Benutzer-Handbuch Programmierplatz iTNC 530

Gültig für:
606424-04

Stand:
31.07.2014-de-

Copyright © 2014 DR. JOHANNES HEIDENHAIN GmbH. Alle Rechte vorbehalten.


TNC-Typ, Software und Funktionen

Weitere Informationen:
> TNC-Typ, Software und Funktionen


TNC-Typ, Software und Funktionen

TNC-Typ, Software und Funktionen

Dieses Handbuch beschreibt Funktionen, die im TNC-Programmierplatz ab der folgenden NC-Software-Nummern verfügbar sind.

TNC-Typ | NC-Software-Nr.
Programmierplatz iTNC 530 HSCI | 606424‑04

Die Programmierplatz-Software ist zu den nachfolgend aufgeführten TNCs voll kompatibel.

TNC-Typ | NC-Software-Nr.
iTNC 530 mit HSCI | 606420‑04
iTNC 530 mit HSCI (Export-Version) | 606421‑04

Viele Maschinenhersteller und HEIDENHAIN bieten für die TNCs Programmier-Kurse an. Die Teilnahme an solchen Kursen ist empfehlenswert, um sich intensiv mit den TNC-Funktionen vertraut zu machen.

Benutzer-Dokumentation:

Alle TNC-Funktionen sind in den Benutzer-Handbüchern der iTNC 530 beschrieben. Wenden Sie sich ggf. an -HEIDENHAIN, wenn Sie diese Benutzer-Handbücher -benötigen. Halten Sie die NC-Software-Nummer bereit, die Sie im MOD-Bildschirm der iTNC ablesen können.

Zusätzlich ist die Benutzer-Dokumentation in Form eines Hilfesystemes auch über die Taste Help an Ihrem Programmierplatz aufrufbar.

Wenn Sie ein Vollversion des Programmierplatzes erworben haben, finden Sie darüber hinaus die komplette Benutzer-Dokumentation als PDF-Dateien auf der zum Lieferumfang gehörenden DVD -TNCguide.


Wichtiges zur Programmierplatz-Software

Weitere Informationen:
> Einführung
> Arbeiten mit dem Programmierplatz iTNC 530
> Daten-Übertragung vom Programmierplatz zur Maschine
> Besonderheiten der Demo-Version


Einführung

Weitere Informationen:
> Allgemeines
> Optionen/Entwicklungsstand (FCL)
> Kompatibilität
> Abwärtskompatibilität


Allgemeines

In diesem Handbuch sind die Besonderheiten des Programmierplatzes iTNC 530 beschrieben. Alle verfügbaren NC-Funktionen sind im Benutzer-Handbuch und im Benutzer-Handbuch Zyklenprogrammierung beschrieben. smarT.NC-Funktionen sind im Lotsen smarT.NC beschrieben.

Die TNC-Steuerungen von HEIDENHAIN waren immer schon anwenderfreundlich: einfache Programmierung im HEIDENHAIN-Klartext-Dialog, praxisgerechte Zyklen, eindeutige Funktionstasten, und anschauliche Grafikfunktionen machen sie zu den beliebten werkstattprogrammierbaren Steuerungen.

Jetzt steht Ihnen auch eine Programmierplatz-Software zur Verfügung, die unter Windows lauffähig ist. Die Bedienung erfolgt über die im Lieferumfang enthaltene HEIDENHAIN-Tastatur, die einfach über eine USB-Schnittstelle an Ihren PC anzuschließen ist. Zu Testzwecken können Sie den Programmierplatz iTNC 530 auch über die Standard-PC-Tastatur bedienen (siehe „Besonderheiten der Demo-Version” auf Seite 58).

Alternativ können Sie den Programmierplatz auch über die virtuelle Tastatur bedienen (siehe Virtuelles Keyboard einblenden).


Optionen/Entwicklungsstand (FCL)

Einige leistungsfähige Funktionen, sind nicht standardmäßig auf jeder TNC-Steuerung verfügbar, sondern sind per Schlüsselzahl freizuschalten.

Auf dem Programmierplatz iTNC 530 sind grundsätzlich alle Funktionen ohne Mehrkosten frei verfügbar. Die kostenlos verfügbare DEMO-Version erlaubt jedoch nur das Speichern von Programmen bis zu einer bestimmten Programm-Länge (siehe Besonderheiten der Demo-Version).

Achten Sie bei der Programm-Erstellung auf dem Programmierplatz iTNC 530 darauf, dass Sie nur die Funktionen nutzen, die Sie auch auf Ihrer Maschine verfügbar haben. Ansonsten könnte das Programm nach dem Einlesen in die Maschinensteuerung ERROR-Sätze enthalten oder beim Testen/Abarbeiten Fehlermeldungen ausgeben.


Kompatibilität

    In den Programmier-Betriebsarten stehen Ihnen die gleichen Funktionen zur Verfügung, wie an einer iTNC 530, die an der Maschine angebaut ist (mit NC-Software 606424‑04). Sie erstellen Programme

  • im HEIDENHAIN-Klartext-Dialog, nach DIN/ISO oder mit smarT.NC
  • mit grafischer Unterstützung bei der Programm-Eingabe und beim Programm-Test
  • mit allen weiteren bewährten iTNC-Funktionen wie z.B. der freien Konturprogrammierung FK

Sie arbeiten mit der original iTNC-Software – ohne Kompatibilitätsprobleme. Die am Programmierplatz erstellten Programme laufen auf Ihrer Maschine, die mit der iTNC 530 und der NC-Software 606424‑04, ausgerüstet ist. Voraussetzung dafür ist, dass die Programmierplatz-Software an Ihre Maschine angepasst wurde und Sie auf Ihrer Maschine ggf. verwendete Software-Optionen freigeschaltet haben.

Wenn Sie mit dem Programmierplatz auch für ältere Software-Versionen der iTNC 530, bzw. für ältere TNC-Bahnsteuerungen Programme erstellen, bitte den nächsten Abschnitt Abwärtskompatibilität beachten!


Abwärtskompatibilität

    Der Funktionsumfang des Programmierplatzes iTNC 530 stimmt exakt überein mit dem Funktions-Umfang der TNC-Software 606424‑04. Wenn Ihre TNC-Steuerung mit dieser Software ausgerüstet ist, können Sie alle auf dem Programmierplatz erstellten Programme direkt in Ihre Steuerung einlesen. Falls Sie mit dem Programmierplatz Programme für ältere TNC-Steuerungen erstellen wollen, beachten Sie bitte folgende Punkte:

  • Keine bei der iTNC 530 verfügbaren Funktionen verwenden, die in den älteren TNC-Steuerungen nicht verfügbar sind. Eine Übersicht, welche Funktion in welchem Softwarestand verfügbar ist, finden Sie auf den nächsten Seiten
  • Bei einigen Zyklen wurden zusätzliche Parameter eingeführt, die auf älteren Steuerungen, bzw. Softwareständen der iTNC 530 nicht zur Verfügung stehen (siehe Unterschiede bei Bearbeitungs-Zyklen bezogen auf TNC 4xx, bzw. siehe Unterschiede bei Tastsystem-Zyklen bezogen auf TNC 4xx). Diese zusätzlichen Parameter sind intern als optionale Parameter gekennzeichnet. Sie können diese mit der Taste NO ENT, beginnend am letzten Parameter des jeweiligen Zyklus, aus der Zyklusdefinition löschen und erhalten so ein entsprechend abwärtskompatibles Programm.

Bei Unklarheiten vergleichen Sie bitte das auf dem Programmierplatz iTNC 530 erstellte Programm mit dem Satzformat Ihrer Steuerung, das im jeweiligen Benutzer-Handbuch beschrieben ist.

Weitere Informationen:
> Unterschiede bei Bearbeitungs-Zyklen bezogen auf TNC 4xx
> Unterschiede bei Bearbeitungs-Zyklen bezogen auf ältere Softwarestände der iTNC 530
> Unterschiede bei Tastsystem-Zyklen bezogen auf TNC 4xx
> Unterschiede bei Tastsystem-Zyklen bezogen auf ältere Softwarestände der iTNC 530
> Unterschiede bei Zusatz-Funktionen M bezogen auf TNC 4xx
> Unterschiede bei Zusatz-Funktionen M bezogen auf ältere Softwarestände der iTNC 530
> Unterschiede bei der Q-Parameter-Programmierung bezogen auf TNC 4xx
> Unterschiede bei der Q-Parameter-Programmierung bezogen auf ältere Softwarestände der iTNC 530
> Unterschiede bei sonstigen Funktionen bezogen auf TNC 4xx
> Unterschiede bei sonstigen Funktionen bezogen auf ältere Softwarestände der iTNC 530


Unterschiede bei Bearbeitungs-Zyklen bezogen auf TNC 4xx

Bedeutung der in der Tabelle verwendeten Symbole:

– | Parameter in dieser Software-Version nicht verfügbar
o | Parameter oder Zyklus in dieser Software-Version verfügbar
x | Zyklus in dieser Software-Version nicht verfügbar
Zyklus | Zusätzliche Parameter | TNC 426/ TNC 430, Softwarestand |  |  |  |  | TNC 410
 |  | 280476 | 280474 | 280472 | 280470 | 280462 | 286060
20, Kontur-Daten | – | o | o | o | o | o | x
21, Vorbohren | – | o | o | o | o | o | x
22, Ausräumen | Q208 Q401 Q404 | – – – | – – – | – – – | – – – | – – – | x x x
23, Schlichten Tiefe | Q208 | – | – | – | – | – | x
24, Schlichten Seite | – | o | o | o | o | o | x
25, Konturzug | – | o | o | o | o | o | x
27, Zylindermantel | – | o | o | o | o | o | x
28, Zylinder-Mantel | – | o | o | x | x | x | x
30, 3D-Daten abarbeiten | – | o | o | o | o | o | x
32, Toleranz | HSC-MODE TA | – – | – – | – – | x x | x x | x x
200, Bohren | Q211 | o | o | – | – | – | –
202, Ausdrehen | Q336 | o | o | – | – | – | –
203, Universal-Bohren | Q256 | o | o | – | – | – | –
204, Rückwärts-Senken | Q336 | o | o | – | x | x | x
205, Universal-Tiefbohren | Q379 Q253 | – – | – – | x x | x x | x x | – –
206, Gew.-Bohren m. A. neu | – | o | o | x | x | x | x
207, Gew.-Bohren o. A. neu | – | o | o | x | x | x | x
208, Bohrfräsen | Q342 Q351 | o – | – – | x x | x x | x x | x x
209, Gew.-Bohren Spanbr. | Q403 | – | – | x | x | x | x
210, Nut pendelnd | Q338 Q206 | o – | o – | – – | – – | – – | – –
211, Runde Nut | Q338 Q206 | o – | o – | o – | o – | o – | – –
220, Punktemuster Kreis | Q301 Q365 | o – | o – | – – | – – | – – | – –
221, Punktemuster Linien | Q301 | o | o | – | – | – | –
225, Gravieren | – | x | x | x | x | x | x
232, Planfräsen | – | x | x | x | x | x | x
240, Zentrieren | – | x | x | x | x | x | x
241, Einlippen-Bohren | – | x | x | x | x | x | x
247, Bezugsp. setzen | – | o | x | x | x | x | x
251, Rechtecktasche komplett | – | x | x | x | x | x | x
252, Kreistasche komplett | – | x | x | x | x | x | x
253, Nut komplett | – | x | x | x | x | x | x
254, Runde Nut komplett | – | x | x | x | x | x | x
256, Rechteckzapfen komplett | – | x | x | x | x | x | x
257, Kreiszapfen komplett | – | x | x | x | x | x | x
262, Gewindefräsen | Q512 | o | x | x | x | x | x
263, Senkgewindefräsen | Q512 | o | x | x | x | x | x
264, Bohrgewindefräsen | Q512 | o | x | x | x | x | x
265, Helix-Bohrgewindefräsen | – | o | x | x | x | x | x
267, Außengewindefräsen | Q512 | o | x | x | x | x | x
270, Konturzugdaten | – | x | x | x | x | x | x
275, Konturnut Trochoidal | – | x | x | x | x | x | x
276, Konturzug 3D | – | x | x | x | x | x | x
290, Interpolationsdrehen (Option) | – | x | x | x | x | x | x


Unterschiede bei Bearbeitungs-Zyklen bezogen auf ältere Softwarestände der iTNC 530

Bedeutung der in der Tabelle verwendete Symbole:

– | Parameter in dieser Software-Version nicht verfügbar
o | Parameter oder Zyklus in dieser Software-Version verfügbar
x | Zyklus in dieser Software-Version nicht verfügbar
Zyklus | Zusätzliche Parameter | iTNC 530, Softwarestand
 |  | 340422 | 340420
22, Ausräumen | Q208 Q401 Q404 | o – – | – – –
205, Universal-Tiefbohren | Q379 Q253 | o o | – –
208, Bohrfräsen | Q351 | – | –
225, Gravieren | – | x | x
240, Zentrieren | – | x | x
241, Einlippen-Bohren | Q435 | x | x
251, Rechtecktasche kompl. | – | o | x
252, Kreistasche kompl. | – | o | x
253, Nut komplett | Q439 | o | x
254, Runde Nut komplett | Q439 | o | x
256, Rechteckzapfen kompl. | – | x | x
257, Kreiszapfen kompl. | – | x | x
262, Gewindefräsen | Q512 | o | o
263, Senkgewindefräsen | Q512 | o | o
264, Bohrgewindefräsen | Q512 | o | o
267, Außengewindefräsen | Q512 | o | o
241, Einlippen-Bohren | Q435 | x | x
270, Konturzugdaten | – | x | x
275, Konturnut Trochoidal | – | x | x
276, Konturzug 3D | – | x | x
290, Interpolationsdrehen | – | x | x


Unterschiede bei Tastsystem-Zyklen bezogen auf TNC 4xx

Bedeutung der in der Tabelle verwendete Symbole:

– | Parameter in dieser Software-Version nicht verfügbar
o | Parameter oder Zyklus in dieser Software-Version verfügbar
x | Zyklus in dieser Software-Version nicht verfügbar
Zyklus | Zusätzliche Parameter | TNC 426 / TNC 430, Softwarestand |  |  |  |  | TNC 410
 |  | 280476 | 280474 | 280472 | 280470 | 280462 | 286060
1, Bezugsebene polar | – | o | o | o | x | x | x
2, TS kalibrieren | – | o | o | o | x | x | x
3, Messen | MB BEZUGSSYSTEM ERRORMODE | – – – | – – – | x – – | x – – | x – – | x x x
4, Messen 3D | – | x | x | x | x | x | x
9, TS kalibrieren Länge | – | x | x | x | x | x | x
400, Grunddrehung | Q305 | – | – | – | x | x | x
401, ROT 2 Bohrungen | Q305 Q402 Q337 | – – – | – – – | – – – | x x x | x x x | x x x
402, ROT 2 Zapfen | Q305 Q402 Q337 | – – – | – – – | – – – | x x x | x x x | x x x
403, ROT über Drehachse | Q337 Q305 Q303 Q380 | – – – – | – – – – | – – – – | x x x x | x x x x | x x x x
404, Grunddr. setzen | Q305 | – | – | x | x | x | x
405, ROT über C-Achse | – | o | o | x | x | x | x
408, Bezpkt. Mitte Nut | – | x | x | x | x | x | x
409, Bezpkt. Mitte Steg | – | x | x | x | x | x | x
410, Bezpkt. Rechteck innen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – – | – – – – – – | x x x x x x | x x x x x x | x x x x x x
411, Bezpkt. Rechteck außen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – – | – – – – – – | x x x x x x | x x x x x x | x x x x x x
412, Bezpkt. Kreis innen | Q303 Q381 Q382 Q383 Q384 Q333 Q423 Q365 | – – – – – – – – | – – – – – – – – | – – – – – – – – | x x x x x x x x | x x x x x x x x | x x x x x x x x
413, Bezpkt. Kreis außen | Q303 Q381 Q382 Q383 Q384 Q333 Q423 Q365 | – – – – – – – – | – – – – – – – – | – – – – – – – – | x x x x x x x x | x x x x x x x x | x x x x x x x x
414, Bezpkt. Ecke außen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – – | – – – – – – | x x x x x x | x x x x x x | x x x x x x
415, Bezpkt. Ecke innen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – – | – – – – – – | x x x x x x | x x x x x x | x x x x x x
416, Bezpkt. Mitte Lochkreis | Q303 Q381 Q382 Q383 Q384 Q333 Q320 | – – – – – – – | – – – – – – – | – – – – – – – | x x x x x x x | x x x x x x x | x x x x x x x
417, Bezpkt. TS-Achse | Q303 | – | – | – | x | x | x
418, Bezpkt. 4 Bohrungen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – – | – – – – – – | x x x x x x | x x x x x x | x x x x x x
419, Bezpkt. einzelne Achse | – | x | x | x | x | x | x
420, Winkel messen | – | o | o | o | x | x | x
421, Bohrung messen | Q423 Q365 | – – | – – | – – | x x | x x | x x
422, Kreis außen messen | Q423 Q365 | – – | – – | – – | x x | x x | x x
423, Rechteck innen messen | – | o | o | o | x | x | x
424, Rechteck außen messen | – | o | o | o | x | x | x
425, Breite innen messen | Q301 Q320 | – – | – – | – – | x x | x x | x x
426, Steg außen messen | – | o | o | o | x | x | x
427, Koordinate messen | – | o | o | o | x | x | x
430, Lochkreis messen | – | o | o | o | x | x | x
431, Ebene messen | – | o | o | o | x | x | x
440, Achsversch. messen | – | o | x | x | x | x | x
441, Schnelles Antasten | – | x | x | x | x | x | x
450, Kinematik sichern | – | x | x | x | x | x | x
451, Kinematik vermessen | 423 431 432 | x x x | x x x | x x x | x x x | x x x | x x x
452, Preset-Kompensation | – | x | x | x | x | x | x
460, TS kalibrieren | – | x | x | x | x | x | x
480, TT kalibrieren | – | o | x | x | x | x | x
481, WZ-Länge messen | – | o | x | x | x | x | x
482, WZ-Radius messen | – | o | x | x | x | x | x
483, Länge + Radius messen | – | o | x | x | x | x | x
484, Kabelloses TT kalibrieren | – | o | x | x | x | x | x


Unterschiede bei Tastsystem-Zyklen bezogen auf ältere Softwarestände der iTNC 530

Bedeutung der in der Tabelle verwendete Symbole:

– | Parameter in dieser Software-Version nicht verfügbar
o | Parameter oder Zyklus in dieser Software-Version verfügbar
x | Zyklus in dieser Software-Version nicht verfügbar
Zyklus | Zusätzliche Parameter | iTNC 530, Softwarestand
 |  | 340422 | 340420
4, Messen 3D | – | x | x
9, TS kalibrieren Länge | – | o | x
400, Grunddrehung | Q305 | – | –
401, ROT 2 Bohrungen | Q305 Q402 Q337 | – – – | – – –
402, ROT 2 Zapfen | Q305 Q402 Q337 | – – – | – – –
403, ROT über Drehachse | Q337 Q305 Q380 | – – – | – – –
404, Grunddr. setzen | Q305 | – | –
408, Bezpkt. Mitte Nut | – | x | x
409, Bezpkt. Mitte Steg | – | x | x
410, Bezpkt. Rechteck innen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – –
411, Bezpkt. Rechteck außen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – –
412, Bezpkt. Kreis innen | Q303 Q381 Q382 Q383 Q384 Q333 Q423 Q365 | – – – – – – – – | – – – – – – – –
413, Bezpkt. Kreis außen | Q303 Q381 Q382 Q383 Q384 Q333 Q423 Q365 | – – – – – – – – | – – – – – – – –
414, Bezpkt. Ecke außen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – –
415, Bezpkt. Ecke innen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – –
416, Bezpkt. Mitte Lochkreis | Q303 Q381 Q382 Q383 Q384 Q333 Q320 | – – – – – – – | – – – – – – –
417, Bezpkt. TS-Achse | Q303 | – | –
418, Bezpkt. 4 Bohrungen | Q303 Q381 Q382 Q383 Q384 Q333 | – – – – – – | – – – – – –
419, Bezpkt. einzelne Achse | – | – | x
421, Bohrung messen | Q423 Q365 | – – | – –
422, Kreis außen messen | Q423 Q365 | – – | – –
425, Breite innen messen | Q301 Q320 | – – | – –
441, Schnelles Antasten | – | x | x
450, Kinematik sichern | – | x | x
451, Kinematik vermessen | – | x | x
460, TS kalibrieren | – | x | x
450, Kinematik sichern | – | x | x
484, Kabelloses TT kalibrieren | – | x | x


Unterschiede bei Zusatz-Funktionen M bezogen auf TNC 4xx

Bedeutung der in der Tabelle verwendete Symbole:

x | Funktion in dieser Software-Version nicht verfügbar
o | Funktion in dieser Software-Version verfügbar
M-Funktion | TNC 426 / TNC 430, Softwarestand |  |  |  |  | TNC 410
 | 280476 | 280474 | 280472 | 280470 | 280462 | 286060
Zwei Zusatz-Funktionen in einem NC-Satz programmierbar | o | x | x | x | x | o
M01 | o | x | x | x | x | o
M104 | o | o | x | x | x | x
M128 | o | o | o | x | x | x
M129 | o | o | o | x | x | x
M130 | o | o | o | o | x | x
M134 | o | o | o | x | x | x
M135 | o | o | o | x | x | x
M136 | o | o | x | x | x | x
M137 | o | o | x | x | x | x
M138 | o | o | x | x | x | x
M140 | o | x | x | x | x | x
M141 | o | x | x | x | x | x
M142 | o | x | x | x | x | x
M143 | o | x | x | x | x | x
M144 | o | x | x | x | x | x
M145 | o | x | x | x | x | x


Unterschiede bei Zusatz-Funktionen M bezogen auf ältere Softwarestände der iTNC 530

Bedeutung der in der Tabelle verwendete Symbole:

x | Funktion in dieser Software-Version nicht verfügbar
o | Funktion in dieser Software-Version verfügbar
M-Funktion | iTNC 530, Softwarestand
 | 340422 | 340420
M150 | x | x


Unterschiede bei der Q-Parameter-Programmierung bezogen auf TNC 4xx

Bedeutung der in der Tabelle verwendete Symbole:

x | Funktion in dieser Software-Version nicht verfügbar
o | Funktion in dieser Software-Version verfügbar
Funktion | TNC 426 / TNC 430, Softwarestand |  |  |  |  | TNC 410
 | 280476 | 280474 | 280472 | 280470 | 280462 | 286060
Formeleingabe: SGN | x | x | x | x | x | o
Formeleingabe: % | x | x | x | x | x | x
FN16 | o | o | o | o | o | x
FN20 | o | o | o | x | x | x
FN23 | o | o | o | x | x | x
FN24 | o | o | o | x | x | x
FN25 | o | o | o | x | x | x
FN26 | o | o | x | x | x | x
FN27 | o | o | x | x | x | x
FN28 | o | o | x | x | x | x
Konturformel QC... | x | x | x | x | x | x
Stringformel QS... | x | x | x | x | x | x
Lokale Parameter QL... | x | x | x | x | x | x
Remanente Parameter Qr... | x | x | x | x | x | x


Unterschiede bei der Q-Parameter-Programmierung bezogen auf ältere Softwarestände der iTNC 530

Bedeutung der in der Tabelle verwendete Symbole:

x | Funktion in dieser Software-Version nicht verfügbar
o | Funktion in dieser Software-Version verfügbar
Funktion | iTNC 530, Softwarestand
 | 340422 | 340420
Stringformel QS... | x | x
Lokale Parameter QL... | x | x
Remanente Parameter QR... | x | x


Unterschiede bei sonstigen Funktionen bezogen auf TNC 4xx

Bedeutung der in der Tabelle verwendete Symbole:

x | Funktion in dieser Software-Version nicht verfügbar
o | Funktion in dieser Software-Version verfügbar
Funktion | TNC 426 / TNC 430, Softwarestand |  |  |  |  | TNC 410
 | 280476 | 280474 | 280472 | 280470 | 280462 | 286060
CYCL CALL PAT | o | x | x | x | x | o
CYCL CALL POS | x | x | x | x | x | x
Schnittdaten-Tabellen (WMAT-Satz) | o | o | o | x | x | x
Vorschub F im Fasensatz CHF | o | o | o | x | x | o
Konturdefinition DECLARE CONTOUR | x | x | x | x | x | x
Bearbeitungsebene schwenken: PLane | x | x | x | x | x | x
Positionierverhalten von Drehachsen function tcpm | x | x | x | x | x | x
FK-Programmierung: FL P2X/flt p2x | o | o | o | o | o | x
FK-Programmierung: FL p2y/flt p2y | o | o | o | o | o | x
FK-Programmierung: FL RX/flt rx | o | o | o | o | o | x
FK-Programmierung: FL RY/flt ry | o | o | o | o | o | x
FK-Programmierung: FL RPR/flt rpr | o | o | o | o | o | x
FK-Programmierung: FL RPA/flt rpa | o | o | o | o | o | x
FK-Programmierung: FL RAN/flt ran | o | o | o | o | o | x
FK-Programmierung: Fc len/fct len | o | o | o | o | o | x
FK-Programmierung: Fc an/fct an | o | o | o | o | o | x
FK-Programmierung: Fc p2x/fct p2x | o | o | o | o | o | x
FK-Programmierung: Fc p2y/fct p2y | o | o | o | o | o | x
FK-Programmierung: Fc p3x/fct p3x | o | o | o | o | o | x
FK-Programmierung: Fc p3x/fct p3y | o | o | o | o | o | x
FK-Programmierung: Fc rx/fct rx | o | o | o | o | o | x
FK-Programmierung: Fc ry/fct ry | o | o | o | o | o | x
FK-Programmierung: Fc rpr/fct rpr | o | o | o | o | o | x
FK-Programmierung: Fc rpa/fct rpa | o | o | o | o | o | x
FK-Programmierung: Fc ran/fct ran | o | o | o | o | o | x
FK-Programmierung: Fc rccx/fct rccx | o | o | o | o | o | x
FK-Programmierung: Fc rccy/fct rccy | o | o | o | o | o | x
FK-Programmierung: Fc rccpr/fct rccpr | o | o | o | o | o | x
FK-Programmierung: Fc rccpa/fct rccpa | o | o | o | o | o | x


Unterschiede bei sonstigen Funktionen bezogen auf ältere Softwarestände der iTNC 530

Bedeutung der in der Tabelle verwendete Symbole:

x | Funktion in dieser Software-Version nicht verfügbar
o | Funktion in dieser Software-Version verfügbar
Funktion | iTNC 530, Softwarestand
 | 340422 | 340420
Bearbeitungsebene schwenken: PLane | o | x
Bearbeitungsebene schwenken: PLane AXIS | x | x
Bearbeitungsebene schwenken: PLane TURN MB.. | x | x
Positionierverhalten von Drehachsen function tcpm | o | x
Bearbeitungspositionen definieren: -Pattern def | x | x
Einfache Konturformel definieren: contour def | x | x
Globale Zyklenparameter definieren: -global def | x | x
Dateifunktionen function file | x | x
Nullpunkt-Verschiebung trans datum | x | x


Arbeiten mit dem Programmierplatz iTNC 530

Weitere Informationen:
> Programmierplatz starten
> Fenstermodus festlegen
> Virtuelles Keyboard einblenden
> Programmierplatz beenden


Programmierplatz starten

Sie starten den Programmierplatz iTNC 530 wie jede andere Windows-Anwendung, indem Sie auf das HEIDENHAIN-Icon Ihres Desktops doppelklicken oder über das Startmenü. Das iTNC Control Panel erscheint (siehe Bild rechts). Sobald die Programmierplatz-Software gestartet ist, minimiert sich das iTNC Control Panel automatisch.

Die TNC-Funktionen (z.B. L, C, CC usw.) werden intern über bestimmte Tastenkombinationen (Short-Cuts) an die Programmierplatz-Software gesendet. Beachten Sie, dass solche Tastenkombinationen auch von anderen Windows-Programmen verwendet werden und dadurch ungewollte Effekte entstehen können.


Fenstermodus festlegen

Standardmäßig startet die Programmierplatz-Software im full screen-Modus. Wenn Ihr PC eine höhere Auflösung als 1024x768 ermöglicht, können Sie den Programmierplatz auch im Fenstermodus starten, so dass sich die Programmierplatz-Software verhält wie jede andere Windows-Anwendung auch.

Um den Fenstermodus zu wählen gehen Sie wie folgt vor:

  • Programmierplatz-Software starten

  • Auf das grüne HEIDENHAIN-Symbol in der Task-Leiste doppelklicken: Das iTNC-ControlPanel erscheint (siehe Bild)

  • Schaltfläche More >> anklicken: Zusätzliche Einstellmöglichkeiten werden angezeigt

  • Schaltfläche Settings anklicken: Anzeige-Optionen werden angezeigt

  • Option 1024 x768 window wählen, über Schaltfläche OK bestätigen

Änderungen werden erst aktiv, wenn Sie die Programmierplatz-Software neu starten: Schaltfläche Restart iTNC betätigen.


Virtuelles Keyboard einblenden

Um mit dem virtuellen Keyboard effektiv arbeiten zu können, müssen Sie eine Bildschirm-Auflösung von mehr als 1024x768 aktiv haben.

Mit dem virtuellen Keyboard können Sie per Mouseklick die auf der TNC-Tastatur verfügbaren Tasten simulieren. Softkeys können Sie per Mouse direkt im TNC-Window betätigen oder per Funktionstasten F1 bis F8 auf der PC-Tastatur. Die normalerweise auf dem TNC-Bildschirmgehäuse verfügbaren Tasten bedienen Sie ebenfalls über Funktionstasten der PC-Tastatur:

  • Softkey-Leiste nach links schalten: F9
  • Softkey-Leiste nach rechts schalten: F10
  • Bildschirm-Aufteilung einstellen: F11
  • Umschalten Vorder-/Hintergrund-Betriebsart: F12

Um das virtuelle Keyboard einzublenden gehen Sie wie folgt vor:

  • Programmierplatz-Software starten

  • Auf das grüne HEIDENHAIN-Symbol in der Task-Leiste doppelklicken: Das iTNC-ControlPanel erscheint

  • Schaltfläche More >> anklicken: Zusätzliche Einstellmöglichkeiten werden angezeigt

  • Schaltfläche Keypad anklicken: Das Virtuelle Keyboard wird eingeblendet

Wenn Sie das Keyboard automatisch beim Starten der Programmierplatz-Software einblenden lassen wollen, dann gehen Sie wie folgt vor

  • Programmierplatz-Software starten

  • Auf das grüne HEIDENHAIN-Symbol in der Task-Leiste doppelklicken: Das iTNC-ControlPanel erscheint

  • Schaltfläche More >> anklicken: Zusätzliche Einstellmöglichkeiten werden angezeigt

  • Schaltfläche Settings anklicken: Anzeige-Optionen werden angezeigt

  • Option Launch keypad at startup wählen, festlegen, ob Sie das horizontale (Horizontal Keypad) oder vertikale Keyboard (Vertical Keypad) nutzen wollen und über Schaltfläche OK bestätigen

Änderungen werden erst aktiv, wenn Sie die Programmierplatz-Software neu starten: Schaltfläche Restart iTNC betätigen.


Programmierplatz beenden

Weitere Informationen:
> Grundsätzliches
> Programmierplatz vollständig beenden
> Programmierplatz zeitweise beenden


Grundsätzliches

Um Datenverluste beim Beenden der Software zu vermeiden, müssen Sie den Programmierplatz gezielt beenden. Dafür stehen zwei Möglichkeiten zur Verfügung, die in den folgenden Abschnitten beschrieben sind.

Willkürliches Beenden des Programmierplatzes kann zu Datenverlust führen.


Programmierplatz vollständig beenden

  • Betriebsart Manuell wählen

  • Softkey-Leiste weiterschalten, bis Softkey zum Herunterfahren des Systems angezeigt wird

Funktion zum Herunterfahren wählen, anschließende Dialogfrage nochmals mit Softkey JA bestätigen


Programmierplatz zeitweise beenden

  • Auf der ASCII-Tastatur die Windows-Taste betätigen: Der Bildschirm zeigt die zuletzt aktive Anwendung und die Task-Leiste an

  • Auf das grüne HEIDENHAIN-Symbol in der Task-Leiste doppelklicken: Das iTNC-ControlPanel erscheint (siehe Bild rechts)

Funktion zum Beenden der iTNC 530-Anwendung wählen: Schaltfläche Stop iTNC drücken. Das iTNC-ControlPanel bleibt aktiv. Über die Schaltfläche Restart iTNC können Sie die Programmierplatz-Software wieder neu starten


Daten-Übertragung vom Programmierplatz zur Maschine

Weitere Informationen:
> Voraussetzungen
> Vorbereitungen am Programmierplatz
> Programm von der Maschine aus abrufen
> Verbindung zwischen dem Programmierplatz und HEIDENHAIN PC-Software


Voraussetzungen

Bevor Sie Daten übertragen können, müssen Sie den PC, auf dem Sie den iTNC-Programmierplatz installiert haben, an Ihre Maschine angebunden haben. Beachten Sie dazu die Hinweise zur Ethernet-Schnittstelle im Benutzer-Handbuch.

Sie können eine Daten-Übertragung nur von Ihrer Maschine aus starten.


Vorbereitungen am Programmierplatz

Um die auf dem Programmierplatz erstellten Programme an Ihre Maschine übertragen zu können, müssen Sie auf dem PC ein Transfer-Verzeichnis erstellen, in das Sie die zu übertragenden Programme zwischenspeichern müssen. Gehen Sie dabei wie folgt vor:

  • Wenn noch nicht vorhanden, erstellen Sie auf Ihrem PC – oder auf einem beliebigen Netzlaufwerk – mit Hilfe des Explorers ein neues Verzeichnis, z.B. <c:\pgmtransfer>

  • Wechseln Sie zurück zur Programmierplatz-Software

  • Betriebsart Einspeichern/Editieren wählen

  • Datei-Verwaltung aufrufen: Taste PGM MGT drücken

  • Programm wählen, das Sie zur Maschine übertragen wollen

  • Zwei-Fenster-Darstellung wählen

  • Im rechten Fenster als Zielpfad das Verzeichnis <c:\pgmtransfer> wählen

  • Programm in das Verzeichnis <pgmtransfer> kopieren

Weitere Informationen zum Kopieren von Dateien finden Sie im Benutzer-Handbuch der TNC.


Programm von der Maschine aus abrufen

  • Betriebsart Einspeichern/Editieren wählen

  • Datei-Verwaltung aufrufen: Taste PGM MGT drücken

  • Ziel-Verzeichnis wählen, in das Sie das auf dem Programmierplatz erstellte Programm kopieren wollen

  • Zwei-Fenster-Darstellung wählen

  • Im rechten Fenster das Verzeichnis des Programmierplatz-PC’s <c:\pgmtransfer> wählen

  • Zu übertragendes Programm wählen und auf die Maschine übertragen

Weitere Informationen zum Kopieren von Dateien finden Sie im Benutzer-Handbuch der TNC.


Verbindung zwischen dem Programmierplatz und HEIDENHAIN PC-Software

Um eine Verbindung zwischen einer HEIDENHAIN PC-Software (z.B. TNCremo NT oder -CycleDesign) und dem Programmierplatz herstellen zu können, besitzt der Programmierplatz eine spezielle IP-Adresse, die sogenannte loop back-IP. Diese loop back-IP ist 127.0.0.1 und muss in das enstprechende Konfigurationsmenü der HEIDENHAIN PC-Software eingetragen werden. Sie können dann eine Verbindung mit dem Programmierplatz erstellen, als ob Sie mit einer Maschine verbunden wären.


Besonderheiten der Demo-Version

Weitere Informationen:
> Allgemeines
> Demo-Version starten
> Tastaturbelegung
> Gesamtübersicht Tastaturbelegung
> Tastaturbelegung auf mobilen Computern


Allgemeines

Nachdem Sie den Programmierplatz iTNC 530 auf Ihrem PC installiert haben, können Sie zu Testzwecken die TNC-Funktionen über die Standard-PC-Tastatur aufrufen. Es stehen alle Funktionen der iTNC 530 zur Verfügung. Alternativ können Sie die DEMO-Version auch über das virtuelle Keyboard bedienen (siehe Virtuelles Keyboard einblenden)

Die Demoversion des Programmierplatzes iTNC 530 erlaubt das Speichern von bis zu 100 NC-Sätzen pro NC-Programm.

Beim Extrahieren von Konturen aus DXF-Dateien speichert die TNC maximal 50 NC-Sätze in das jeweilige Konturprogramm. Dieselbe Beschränkung gilt für das Extrahieren von Bearbeitungspositionen in eine Punkte-Tabelle.


Demo-Version starten

Nachdem Sie die Demo-Version über das Windows-Startmenü gestartet haben, meldet sich die Programmierplatz-Software mit einem Überblendfenster, das Sie auf die Besonderheiten der Demo-Version hinweist. Gehen Sie dann wie folgt vor:

  • Um den Hinweis auf die Demo-Version zu quittieren: Drücken Sie die TNC-Taste CE auf der virtuellen Tastatur. Wenn Sie mit der normalen PC-Tastatur arbeiten, drücken Sie die Komma-Taste im Nummernblock Ihrer Tastatur. Wenn Sie am Laptop arbeiten, aktivieren Sie die NUM-Lock-Funktion und drücken anschließend die Komma-Taste im Nummernblock Ihrer Tastatur. Die TNC-Software schließt dann das Überblendfenster und zeigt den Dialog Strom-Unterbrechung an

  • Um die Strom-Unterbrechung zu quittieren, drücken Sie die TNC-Taste CE, bzw. die passende PC-Taste, erneut. Die Programmierplatz-Software ist jetzt einsatzbereit in der Betriebsart Manuell

Beachten Sie auch die Hinweise zur Tastaturbelegung (siehe Tastaturbelegung).


Tastaturbelegung

Die Belegung der TNC-Sondertasten (Achstasten und Dialogtasten) und der TNC-Ziffernblock sind im Bild rechts oben dargestellt. Die Belegung der Bildschirmtasten finden Sie in nachfolgender Tabelle Funktion der Bildschirm-Tasten, alle übrigen TNC-Funktionen rufen Sie über Kurzbefehle auf, die in der nachfolgenden Tabelle TNC-Funktionen aufgeführt sind.

Weitere Informationen:
> Tasten des TNC Bildschirms
> Tasten für TNC-Funktionen
> Tastaturbelegung auf amerikanischen PC-Tastaturen


Tasten des TNC Bildschirms

Funktionen für vertikale Softkeys stehen nur dann zur Verfügung, wenn Sie ein spezielles PLC-Programm für den Programmierplatz verwenden.

Um einen vertikalen Softkey zu betätigen, müssen Sie auf der PC-Tastatur zusätzlich die Tasten STRG+ALT+SHIFT drücken.

Funktion der Bildschirm-Tasten | TNC-Taste | PC-Taste
Horizontaler Softkey 1 |  |
Horizontaler Softkey 2 |  |
Horizontaler Softkey 3 |  |
Horizontaler Softkey 4 |  |
Horizontaler Softkey 5 |  |
Horizontaler Softkey 6 |  |
Horizontaler Softkey 7 |  |
Horizontaler Softkey 8 |  |
Horizontaler Softkey 9 bei großer Bildschirm-Auflösung (1280x1024) |  | STRG+ALT+
Horizontaler Softkey 10 bei großer Bildschirm-Auflösung (1280x1024) |  | STRG+ALT+
Softkey-Leiste nach links umschalten |  |
Softkey-Leiste nach rechts umschalten |  |
Bildschirm-Aufteilung wählen |  |
Bildschirm zwischen Maschinen- und Programmier-Betriebsart umschalten |  |
Vertikaler Softkey 1 |  |
Vertikaler Softkey 2 |  |
Vertikaler Softkey 3 |  |
Vertikaler Softkey 4 |  |
Vertikaler Softkey 5 |  |


Tasten für TNC-Funktionen

Um die nachfolgend beschriebenen TNC-Funktionen mit der PC-Tastatur aufrufen zu können, müssen Sie auf der PC-Tastatur zusätzlich die Tasten STRG+ALT drücken.

TNC-Funktion | TNC-Taste | PC-Taste
Programme/Dateien wählen und löschen, Externe Datenübertragung |  |
Taschenrechner einblenden |  |
MOD-Funktion wählen |  |
Hilfetext anzeigen bei NC-Fehlermeldungen |  |
Alle anstehenden Fehlermeldungen anzeigen |  |
Kontur anfahren/verlassen |  |
Freie Konturprogrammierung FK |  |
Fase programmieren |  |
Gerade programmieren |  |
Kreisbahn mit Radius programmieren |  |
Eckenrundung programmieren |  |
Kreisbahn mit tangentialem Anschluss programieren |  |
Kreismittelpunkt/Pol für Polarkoordinaten programmieren |  |
Kreisbahn um Kreismittelpunkt programmieren |  |
Betriebsart Manuell wählen |  |
Betriebsart smarT.NC wählen |  |
Betriebsart Handrad wählen |  |
Betriebsart Positionieren mit Handeingabe wählen |  |
Betriebsart Programmlauf Einzelsatz wählen |  |
Betriebsart Programmlauf Satzfolge wählen |  |
Betriebsart Einspeichern/Editieren wählen |  |
Betriebsart Programm-Test wählen |  |
Tastsystem-Zyklen definieren |  |
Bearbeitungs-Zyklen definieren |  |
Bearbeitungs-Zyklen aufrufen |  |
Unterprogramme und Programmteil-Wiederholungen definieren |  |
Unterprogramme und Programmteil-Wiederholungen aufrufen |  |
Programm-Halt eingeben |  |
Werkzeug im Programm definieren |  |
Werkzeug aufrufen |  |
Softkey-Menü für Sonderfunktionen aufrufen |  |
Programmaufruf eingeben |  |


Tastaturbelegung auf amerikanischen PC-Tastaturen

Wenn Sie eine PC-Tastatur mit amerikanischen Tastaturlayout verwenden, sind folgende Tasten anders angeordnet:

TNC-Funktion | TNC-Taste | PC-Taste
Freie Konturprogrammierung FK |  |
Fase programmieren |  |
Gerade programmieren |  |
Betriebsart smarT.NC wählen |  |
Betriebsart Handrad wählen |  |
Eckenrundung programmieren |  |
Programm-Halt eingeben |  |


<>
Wichtiges zur Programmierplatz-Software / Besonderheiten der Demo-Version

Gesamtübersicht Tastaturbelegung


Tastaturbelegung auf mobilen Computern

Auf mobilen Computer (Laptops, Notebooks) ist die Anzahl der zur Verfügung stehenden Tasten geringer (siehe Bild rechts). Über die Taste NUM aktivieren Sie den Nummernblock, der in der Regel auf Ihrer Tastatur farblich abgehoben dargestellt ist (siehe Bild unten). Beachten Sie hierzu die Bedienungsanleitung Ihres Laptops/Notebooks. Desweiteren sind einige Funktionen wie ENTF (löschen) oder die Pfeiltasten mit einer FN-Taste aktivierbar. Beachten Sie auch hierzu die Bedienungsanleitung Ihres Laptops/Notebooks.

Bei einigen mobilen Computern steht die Taste ENT nicht zur Verfügung. In den meisten Fällen können Sie dann den Dialog mit der Pfeil nach rechts-Taste fortsetzen.


Lieferumfang/Installation

Weitere Informationen:
> Lieferumfang/Systemvoraussetzungen
> Programmierplatz in Betrieb nehmen


Lieferumfang/Systemvoraussetzungen

Weitere Informationen:
> Lieferumfang
> Systemvoraussetzungen


Lieferumfang

Der Programmierplatz iTNC ist in drei Versionen erhältlich.

Weitere Informationen:
> Programmierplatz iTNC mit TNC-Tastatur
> Programmierplatz iTNC mit virtueller Tastatur
> Programmierplatz iTNC mit Netzwerklizenz


Programmierplatz iTNC mit TNC-Tastatur

    Zum Lieferumfang gehören:

  • Die Programmierplatz-Software auf CD
  • Die Tastatur TE 530 L zum Anschluss an den PC über die USB-Schnittstelle
  • 1 USB-Kabel, 2 m
  • 4 Kabelklemmen zur Montage auf dem Programmierplatzgehäuse
  • Selbstklebende Folien für Softkeybeschriftungen
  • Benutzer-Dokumentation auf DVD


Programmierplatz iTNC mit virtueller Tastatur

    Zum Lieferumfang gehören:

  • Die Programmierplatz-Software auf CD
  • USB-Dongle, Einzelplatzlizenz zur Aufhebung der Speicherbegrenzung
  • Benutzer-Dokumentation auf DVD


Programmierplatz iTNC mit Netzwerklizenz

    Zum Lieferumfang gehören:

  • Die Programmierplatz-Software auf CD
  • USB-Dongle mit 14 oder 20 Netzwerklizenzen zur Aufhebung der Speicherbegrenzung
  • Benutzer-Dokumentation auf DVD


Systemvoraussetzungen

    Die Programmierplatz-Software ist auf folgenden PC’s lauffähig:

  • Standard-PC mit Windows 2000, Windows XP, Windows Vista, Windows 7, Prozessor mindestens PIII mit 800 MHz
  • USB-Schnittstelle
  • Mindestens 512-MByte-RAM
  • Grafikkarte: Farbtiefe mindestens 16 bit
  • Mindestens 400 MByte Speicherplatz auf der Festplatte
  • Mindestens 15-Zoll Bildschirm mit einer Auflösung von 1024x768 Punkten, bei Verwendung der virtuellen Tastatur Auflösung von mindestens 1280x1024 Punkten erforderlich
  • LAN-Verbindung bei Verwendung des Programmierplatzes iTNC mit Netzwerklizenz

Beachten Sie, dass Sie sowohl für die Installation als auch für den Betrieb der Programmierplatz-Software Administratorrechte benötigen.

Zum Betrieb der Programmierplatz-Software genügen Administratorrechte auf das Installations-Verzeichnis der Programmierplatz-Software.


Programmierplatz in Betrieb nehmen

Weitere Informationen:
> Programmierplatz-Tastatur anschließen
> Nummernfolien
> USB-Dongle anschließen (nur bei Version mit virtuellem Keyboard)
> USB-Netzwerk-Dongle anschließen (nur bei Version mit virtuellem Keyboard)
> Programmierplatz-Software installieren
> Konfiguration der Programmierplatz-Software bei Verwendung eines USB-Netzwerk-Dongles
> Dialogsprache einstellen
> Arbeiten mit dem HEIDENHAIN Basis PLC-Programm
> Arbeiten mit einem maschinenspezifischen PLC-Programm


Programmierplatz-Tastatur anschließen

Schließen Sie die Programmierplatz-Tastatur an einen freien USB-Anschluss Ihres Rechners an.

Installieren Sie anschließend von der Programmierplatz-CD den passenden Treiber für den USB-Dongle. HEIDENHAIN liefert die Programmierplatz-Tastatur momentan mit zwei verschiedenen USB-Dongle aus. Welcher Dongle in Ihrer Tastatur eingebaut ist, erkennen Sie an der Ident-Nummer, die auf dem schwarzen Typenschild auf der Rückseite der Tastatur aufgedruckt ist:

  • Alladin-Dongle:
    Programmierplatz-Tastaturen mit der Identnummer 532524-01 sind mit dem Alladin-Dongle ausgestattet
  • Marx-Dongle:
    Programmierplatz-Tastaturen ab der Identnummer 532524-02 sind mit dem Marx-Dongle ausgestattet

Beachten Sie die Hinweise zur Treiberinstallation auf der Programmierplatz-CD.

Die Programmierplatz-Software erkennt die angeschlossene Programmierplatz-Tastatur dann automatisch.

An der Rückseite der Programmierplatz-Tastatur befindet sich auch ein USB-Anschluss, an dem Sie ein weiteres USB-Gerät anschließen können, z.B. auch einen weiteren Dongle für einen anderen TNC-Programmierplatz.

Das an der Programmierplatz-Tastatur angeschlossene zusätzliche USB-Gerät darf nicht mehr als 200 mA Strom ziehen.


Nummernfolien

Die der Programmierplatz-Tastatur beiliegenden, selbstklebenden Nummern-Folien erleichtern die Zuordnung zwischen den Softkeytasten und den angezeigten Softkeys am PC-Bildschirm.

Die zusammenhängende Folie können Sie auf der Programmierplatz-Tastatur, die einzelnen Nummern am PC-Bildschirm anbringen.


USB-Dongle anschließen (nur bei Version mit virtuellem Keyboard)

Schließen Sie den USB-Dongle an einen freien USB-Anschluss Ihres Rechners an.

Installieren Sie anschließend von der Programmierplatz-CD den passenden Treiber für den USB-Dongle. HEIDENHAIN liefert momentan zwei verschiedene USB-Dongle aus:

  • Marx-Dongle:
    Den Marx-Dongle erkennen Sie an seiner silbernen Oberfläche, siehe auch Bild rechts oben
  • Alladin-Dongle:
    Den Alladin-Dongle erkennen Sie an seiner blauen Farbe, siehe auch Bild rechts unten

Beachten Sie die Hinweise zur Treiberinstallation auf der Programmierplatz-CD.

Die Programmierplatz-Software erkennt nach der Installation den angeschlossenen Dongle automatisch.


USB-Netzwerk-Dongle anschließen (nur bei Version mit virtuellem Keyboard)

Schließen Sie den USB-Netzwerk-Dongle an einen freien USB-Anschluss des Rechners an, den Sie als Server verwenden wollen.

Installieren Sie anschließend von der Programmierplatz-CD den passenden Treiber für den USB-Dongle. HEIDENHAIN liefert momentan zwei verschiedene USB-Dongle aus:

  • Marx-Dongle:
    Den Marx-Dongle erkennen Sie an seiner silbernen Oberfläche, siehe auch Bild rechts oben
  • Alladin-Dongle:
    Den Alladin-Dongle erkennen Sie an seiner blauen Farbe, siehe auch Bild rechts unten

Beachten Sie die Hinweise zur Treiberinstallation auf der Programmierplatz-CD.

Die Programmierplatz-Software auf diesem Rechner erkennt den angeschlossenen Dongle nach erfolgter Installation des Netzwerktreibers automatisch. Die Rechner, denen Sie Zugriff auf den Netzwerk-Dongle geben wollen, müssen Sie nach Installation der Programmierplatz-Software entsprechend konfigurieren (siehe Konfiguration der Programmierplatz-Software bei Verwendung eines USB-Netzwerk-Dongles).


Programmierplatz-Software installieren

Beachten Sie, das beim Installieren eines Updates folgende Dateien grundsätzlich überschrieben werden:

  • Konfigurations-Datei OEM.SYS
  • Maschinen-Parameter-Datei DEMO.MP
  • Alle Beispiel-NC-Programme im Verzeichnis TNC:\DEMO

Sollten Sie Änderungen an einer dieser Dateien durchgeführt haben, vor der Installation eine Sicherheitskopie erstellen, oder Dateien umbenennen.

  • Programmierplatz-CD ins CD-ROM-Laufwerk einlegen

  • Der CD-Browser startet automatisch, wenn Ihr CD-ROM-Laufwerk entsprechend konfiguriert ist. Sollte kein Autostart aktiv sein, starten Sie die Datei <Start.exe>

  • Wählen Sie die Sprache, mit der die CD-Navigation ausgeführt werden soll

  • Wählen Sie <Software installieren>

  • Wählen Sie <Software-Version wählen>

  • Um das Installationsprogramm zu starten, wählen Sie <Setup> für die Software-Version, die Sie installieren wollen

  • Folgen Sie den Anweisungen des Installationsprogramms

Bei der Neuinstallation des Programmierplatzes iTNC 530 können Sie wählen, ob das HEIDENHAIN Basis-PLC-Programm für den Programmierplatz mit Programmierbeispielen mit installiert werden soll. Wählen Sie dazu den Setuptyp Benutzer und anschließend Basis PLC-Programm oder Standard (Benutzer) (siehe Arbeiten mit dem HEIDENHAIN Basis PLC-Programm).

Sie können diese Programmierplatz-Version parallel zu einer bereits auf Ihrem PC vorhandenen Version installieren, können jedoch nicht beide Versionen gleichzeitig starten.


Konfiguration der Programmierplatz-Software bei Verwendung eines USB-Netzwerk-Dongles

HEIDENHAIN liefert momentan zwei verschiedene USB-Dongle aus:

  • Marx-Dongle:
    Den Marx-Dongle erkennen Sie an seiner silbernen Oberfläche, siehe auch Bild rechts oben
  • Alladin-Dongle:
    Den Alladin-Dongle erkennen Sie an seiner blauen Farbe, siehe auch Bild rechts Mitte

Beachten Sie die Hinweise zur Treiberinstallation auf der Programmierplatz-CD.
Weitere Informationen:
> Konfiguration Alladin-Dongle
> Konfiguration Marx-Dongle


Konfiguration Alladin-Dongle

Bei allen Rechnern, denen Sie Zugriff auf den Netzwerk-Dongle geben wollen, müssen Sie die nachfolgend beschriebene Konfiguration durchführen:

  • Programmierplatz-Software starten

  • Auf das grüne HEIDENHAIN-Symbol in der Task-Leiste doppelklicken: Das iTNC-ControlPanel erscheint

  • Schaltfläche More >> anklicken: Zusätzliche Einstellmöglichkeiten werden angezeigt

  • Schaltfläche Settings anklicken: Programmierplatz-Einstellungen werden angezeigt (siehe Bild)

  • Option Use Hardlock Server wählen

  • Ggf. noch wählen, ob Sie einen Programmierplatz (Programming Station ist Grundeinstellung) oder VirtualTNC (Virtual Machine) einsetzen. Die Einstellung Marx Crypto-Box ist nur für Sonderanwendungen in Verbindung mit virtuellen Maschinen erforderlich, die der jeweilige Software-Hersteller durchführt

  • Im Eingabefeld Server die IP-Adresse oder den Netzwerknamen des Rechners angeben, den Sie als Server verwenden, also in den Sie den USB-Netzwerk-Dongle gesteckt haben

  • Einstellungen mit Schaltfläche OK bestätigen

Änderungen werden erst aktiv, wenn Sie die Programmierplatz-Software neu starten: Schaltfläche Restart iTNC betätigen.

Sie müssen auf dem Client-PC keine zusätzlichen Treiber installieren, um Zugriff auf den USB-Netzwerk-Dongle zu haben.


Konfiguration Marx-Dongle

Bevor Sie die Netzwerklizenz für Mehrplatz-Anwendungen verwenden, müssen Sie auf einem Rechner das Server-Programm "SmarxOS" starten und den USB-Dongle anschließen. Dieser Rechner wird als „Dongle-Server" bezeichnet und überwacht die Verbindungen zu den Client-PC´s auf denen die Programmierplätze installiert sind.

Um das Server-Programm "SmarxOS" auf dem Dongle-Server-PC zu starten, gehen Sie wie folgt vor:

  • Kopieren Sie das komplette Verzeichnis "CBServer" von der CD (\JH\CBServer) auf ein lokales Laufwerk Ihres PC´s

  • Starten Sie den Server mit: „CBIOSSrv.exe“

Nach dem Start des Server-Programms wird in der Taskleiste das Icon [image] angezeigt.

Die Programmierplatz-PC‘s melden sich beim Start an dem Dongle-Server an. Während des Betriebs überprüft der Server, ob ein gemeldeter Programmierplatz aktiv ist. Meldet sich der Programmierplatz-PC über einen längeren Zeitraum nicht beim Dongle-Server, wird die Anmeldung automatisch zurückgenommen (Default-Einstellung: 15 min). Wenn Sie den Programmierplatz beenden, erfolgt die Abmeldung beim Dongle-Server.

Sie können das Server-Programm "SmarxOS" auch als Dienst auf dem Dongle-Server-PC installieren. Ein Dienst wird automatisch beim Start von Windows ausgeführt und läuft im Hintergrund. Sie brauchen so das Server-Programm nicht mehr nach jedem Hochfahren des PC´s starten. Um das Server-Programm als Dienst zu installieren, gehen Sie wie folgt vor:

  • Kopieren Sie das komplette Verzeichnis "CBServer" von der CD (\JH\CBServer) auf ein lokales Laufwerk Ihres PC´s

  • Starten Sie den Server mit: „CBIOSSrv.exe“

  • Stoppen Sie den Server über die Schaltfläche "Stop" im Serverfenster

  • Markieren Sie die Option "Run as Service" (als Dienst ausführen)

  • Starten Sie den Server über die Schaltfläche "Start" im Serverfenster

Der Dienst wird nun automatisch beim Start von Windows ausgeführt. Nach dem nächsten Systemstart wird das Icon [image] in der Taskleiste nicht mehr angezeigt.

Ggf. müssen Sie das Programm „CBIOSSRV.SRV“ als „Ausnahme“ in die Windows-Firewall eintragen.

Sie können die Einstellungen für den Dienst "CBIOS Server" auch in der Systemsteuerung unter Verwaltung\Dienste überprüfen und ändern.

Weitere Servereinstellungen können Sie mit dem Programm "Server-Administration" vornehemen. Starten Sie hierzu das Programm „AdminApp.exe“ (Verzeichnis: CBServer):

  • Wenn Sie die Schaltfläche "Search" wählen, werden alle PC´s angezeigt, an denen ein Dongle angeschlossen ist
  • Durch Anklicken der IP-Adresse wird diese in den Adressblock der Verbindungseinstellung übernommen
  • Mit der IP-Adresse 127.0.0.1 (Standardeinstellung) werden die Daten des lokalen Dongle-Servers geladen
  • Durch Anklicken der Schaltfläche "Connect" wird ein Fenster mit Informationen des Dongles und weiteren Einstellmöglichkeiten (z. B. "Connection timeout") geöffnet

Weitere Informationen zum Programm Server-Administration finden Sie in der Datei „readme.txt“ (Verzeichnis: CBServer).


Dialogsprache einstellen

Die Programmierplatz-Software wird standardmäßig mit deutschem Dialog installiert. Um auf eine andere Dialogsprache umzuschalten, gehen Sie wie folgt vor:

  • Programmierplatz-Software starten

Betriebsart Einspeichern wählen

MOD-Funktion wählen

Schlüsselzahl 123 eingeben, mit Taste ENT bestätigen

Maschinen-Parameter 7230 wählen: Taste GOTO drücken, 7230 eingeben, mit Taste ENT bestätigen

Gewünschte Dialogsprache einstellen (siehe Tabelle unten), mit Taste END bestätigen

Dialogsprache | Wert von MP7230
Englisch | 0
Deutsch | 1
Tschechisch | 2
Französisch | 3
Italienisch | 4
Spanisch | 5
Portugiesisch | 6
Schwedisch | 7
Dänisch | 8
Finnisch | 9
Niederländisch | 10
Polnisch | 11
Ungarisch | 12
Russisch | 14
Chinesisch (simplified) | 15
Chinesisch (traditionell) | 16
Slowenisch | 17
Norwegisch | 18
Slowakisch | 19
Koreanisch | 21
Norwegisch | 22
Türkisch | 23
Rumänisch | 24


Arbeiten mit dem HEIDENHAIN Basis PLC-Programm

Manche Maschinenhersteller stellen für den Programmierplatz ein für den jeweiligen Maschinentyp angepasstes PLC-Programm zur Verfügung.

Um Daten und Dateien besser zu schützen, kann der Maschinenhersteller die PLC verschlüsseln, da der Zugriff Dritter aufgrund dieser Verschlüsselung erschwert wird.

HEIDENHAIN weist darauf hin, dass keine Datenverschlüsselung einen 100%igen Schutz der Daten, vor allem vor dem Zugriff Dritter bzw. Zerstörung oder Beschädigung durch Dritte, etc. geben kann. Daher kann HEIDENHAIN auch keine Gewährleistung und Haftung für die Beeinträchtigung von dort gespeicherten Daten, bzw. den daraus resultierenden Schäden übernehmen.

Nachdem Sie den Programmierplatz mit aktiver PLC gestartet haben, zeigt die TNC die Fehlermeldung 98 TNC Programmierplatz aktiv an.

  • Drücken Sie die Taste HELP, um eine Liste anzeigen zu lassen, in der die wichtigsten Programmierplatz-Funktionen zur Maschinenbedienung aufgeführt sind

Nachfolgend sind diese Funktionen nochmals tabellarisch aufgeführt:

Funktion | Tasten
NC-Start | STRG+S
NC-Stopp | STRG+X
Aktive Achse in positive Richtung fahren | STRG+Cursor-Auf-Taste
Aktive Achse in negative Richtung fahren | STRG+Cursor-Ab-Taste
Not-Aus | ALT+X

Über die vertikale Softkey-Leiste können Sie verschiedene Maschinenfunktionen des Basis-PLC-Programms per Mouse simulieren:

Softkey Tasten

M
  • NC-Start
  • NC-Stopp
  • Achsen verfahren in positive und negative Richtung
  • Programmierplatz beenden

S
  • Spindel einschalten
  • Spindel ausschalten
  • Spindel-Tippbetrieb M3
  • Spindel-Tippbetrieb M4
  • Spindel-Orientierung M19

T
  • Werkzeug-Wechsel quittieren
  • Werkzeug entspannen/spannen

DIAGNOSE
  • PLC Fehlertabelle anzeigen
  • Diagnose-Funktionen
  • Status-Funktionen
  • Dokumentation zu M-Funktionen

Wenn Sie nicht mit der Standard-Achskonfiguration arbeiten wollen, dann stehen verschiedene Kinematiken zur Verfügung, die Sie über die MOD-Funktion in der Betriebsart Programm-Einspeichern/Editieren wählen können:

Betriebsart Einspeichern wählen

MOD-Funktion wählen

Schlüsselwort kinematic eingeben, mit Taste ENT bestätigen: Die TNC zeigt ein Überblendfenster mit verschiedenen Achskonfigurationen

Mit den Pfeiltasten gewünschte Achskonfiguration wählen, mit Taste ENT oder Softkey SELECT wählen: Die TNC führt einen Warmstart aus und aktiviert die von Ihnen gewählte Achskonfiguration


Arbeiten mit einem maschinenspezifischen PLC-Programm

Manche Maschinenhersteller stellen für den Programmierplatz ein für den jeweiligen Maschinentyp angepasstes PLC-Programm zur Verfügung. Setzen Sie sich mit Ihrem Maschinenhersteller in Verbindung, um eine Funktionsbeschreibung für dieses angepasste PLC-Programm zu erhalten.

Um Daten und Dateien besser zu schützen, kann der Maschinenhersteller die PLC verschlüsseln, da der Zugriff Dritter aufgrund dieser Verschlüsselung erschwert wird.

HEIDENHAIN weist darauf hin, dass keine Datenverschlüsselung einen 100%igen Schutz der Daten, vor allem vor dem Zugriff Dritter bzw. Zerstörung oder Beschädigung durch Dritte, etc. geben kann. Daher kann HEIDENHAIN auch keine Gewährleistung und Haftung für die Beeinträchtigung von dort gespeicherten Daten, bzw. den daraus resultierenden Schäden übernehmen.