BHB Zyklen

Benutzer-Handbuch Zyklenprogrammierung

Gültig für:
606420-04, 606421-04, 606424-04

Stand:
20.03.2014-de-

Copyright © 2014 DR. JOHANNES HEIDENHAIN GmbH. Alle Rechte vorbehalten.


Über dieses Handbuch

Weitere Informationen:
> Über dieses Handbuch
> TNC-Typ, Software und Funktionen
> Neue Zyklen-Funktionen der Software 60642x-01
> Neue Zyklen-Funktionen der Software 60642x-02
> Neue Zyklen-Funktionen der Software 60642x-03
> Neue Zyklen-Funktionen der Software 60642x-04
> Geänderte Zyklen-Funktionen der 60642x-01
> Geänderte Zyklen-Funktionen der bzw. 60642x-02
> Geänderte Zyklen-Funktionen der bzw. 60642x-04


Über dieses Handbuch

Über dieses Handbuch

Nachfolgend finden Sie eine Liste der in diesem Handbuch verwendeten Hinweis-Symbole

Dieses Symbol zeigt Ihnen, dass zur beschriebenen Funktion besondere Hinweise zu beachten sind.

Dieses Symbol zeigt Ihnen, dass bei Verwendung der beschriebenen Funktion eine oder mehrere der folgenden Gefahren bestehen:

  • Gefahren für Werkstück
  • Gefahren für Spannmittel
  • Gefahren für Werkzeug
  • Gefahren für Maschine
  • Gefahren für Bediener

Dieses Symbol zeigt Ihnen, dass die beschriebene Funktion von Ihrem Maschinenhersteller angepasst werden muss. Die beschriebene Funktion kann demnach von Maschine zu Maschine unterschiedlich wirken.

Dieses Symbol zeigt Ihnen, dass Sie detailliertere Beschreibungen einer Funktion in einem anderen Benutzer-Handbuch finden.
Weitere Informationen:
> Änderungen gewünscht oder den Fehlerteufel entdeckt?


Änderungen gewünscht oder den Fehlerteufel entdeckt?

Wir sind ständig bemüht unsere Dokumentation für Sie zu verbessern. Helfen Sie uns dabei und teilen uns bitte Ihre Änderungswünsche unter folgender E-Mail-Adresse mit: tnc-userdoc@heidenhain.de.


TNC-Typ, Software und Funktionen

Dieses Handbuch beschreibt Funktionen, die in den TNCs ab den folgenden NC-Software-Nummern verfügbar sind.

TNC-Typ | NC-Software-Nr.
iTNC 530, HSCI und HEROS 5 | 606420-04
iTNC 530 E, HSCI und HEROS 5 | 606421-04
iTNC 530 Programmierplatz HSCI | 606424-04

    Der Kennbuchstabe E kennzeichnet die Exportversion der TNC. Für die Exportversione der TNC gilt folgende Einschränkung:

  • Geradenbewegungen simultan bis zu 4 Achsen

HSCI (HEIDENHAIN Serial Controller Interface) kennzeichnet die neue Hardware-Plattform der TNC-Steuerungen.

HEROS 5 kennzeichnet das neue Betriebssystem der HSCI basierten TNC-Steuerungen.

Der Maschinenhersteller paßt den nutzbaren Leistungsumfang der TNC über Maschinen-Parameter an die jeweilige Maschine an. Daher sind in diesem Handbuch auch Funktionen beschrieben, die nicht an jeder TNC verfügbar sind.

    TNC-Funktionen, die nicht an allen Maschinen zur Verfügung stehen, sind beispielsweise:

  • Werkzeug-Vermessung mit dem TT

Setzen Sie sich bitte mit dem Maschinenhersteller in Verbindung, um den tatsächlichen Funktionsumfang Ihrer Maschine kennenzulernen.

Viele Maschinenhersteller und HEIDENHAIN bieten für die TNCs Programmier-Kurse an. Die Teilnahme an solchen Kursen ist empfehlenswert, um sich intensiv mit den TNC-Funktionen vertraut zu machen.

Benutzer-Handbuch:

Alle TNC-Funktionen, die nicht mit Zyklen in Verbindung stehen, sind im Benutzer-Handbuch der iTNC 530 beschrieben. Wenden Sie sich ggf. an HEIDENHAIN, wenn Sie dieses Benutzer-Handbuch benötigen.

ID Benutzer-Handbuch Klartext-Dialog: 670387-xx.

ID Benutzer-Handbuch DIN/ISO: 670391-xx.

Benutzer-Dokumentation smarT.NC:

Die Betriebsart smarT.NC ist in einem separaten Lotsen beschrieben. Wenden Sie sich ggf. an HEIDENHAIN, wenn Sie diesen Lotsen benötigen. ID: 533191-xx.
Weitere Informationen:
> Software-Optionen
> Entwicklungsstand (Upgrade-Funktionen)
> Vorgesehener Einsatzort


Software-Optionen

Die iTNC 530 verfügt über verschiedene Software-Optionen, die von Ihnen oder Ihrem Maschinenhersteller freigeschaltet werden können. Jede Option ist separat freizuschalten und beinhaltet jeweils die nachfolgend aufgeführten Funktionen:

Software-Option 1

Zylindermantel-Interpolation (Zyklen 27, 28, 29 und 39)

Vorschub in mm/min bei Rundachsen: M116

Schwenken der Bearbeitungsebene (Zyklus 19, PLANE-Funktion und Softkey 3D-ROT in der Betriebsart Manuell)

Kreis in 3 Achsen bei geschwenkter Bearbeitungsebene
Software-Option 2

5-Achs-Interpolation

Spline-Interpolation

3D-Bearbeitung:

  • M114: Automatische Korrektur der Maschinengeometrie beim Arbeiten mit Schwenkachsen
  • M128: Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM)
  • FUNCTION TCPM: Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM) mit Einstellmöglichkeit der Wirkungsweise
  • M144: Berücksichtigung der Maschinen-Kinematik in IST/SOLL-Positionen am Satzende
  • Zusätzliche Parameter Schlichten/Schruppen und Toleranz für Drehachsen im Zyklus 32 (G62)
  • LN-Sätze (3D-Korrektur)
Software-Option DCM Collision | Beschreibung
Funktion, die vom Maschinenhersteller definierte Bereiche überwacht, um Kollisionen zu vermeiden. | Benutzer-Handbuch Klartext-Dialog
Software-Option DXF-Converter | Beschreibung
Konturen und Bearbeitungspositionen aus DXF-Dateien (Format R12) extrahieren. | Benutzer-Handbuch Klartext-Dialog
Software-Option Globale Programm-Einstellungen | Beschreibung
Funktion zur Überlagerung von Koordinaten-Transformationen in den Abarbeiten-Betriebsarten, handragüberlagertes Verfahren in virtueller Achsrichtung. | Benutzer-Handbuch Klartext-Dialog
Software-Option AFC | Beschreibung
Funktion adaptive Vorschubregelung zur Optimierung der Schnittbedingungen bei Serienproduktion. | Benutzer-Handbuch Klartext-Dialog
Software-Option KinematicsOpt | Beschreibung
Tastsystem-Zyklen zur Prüfung und Optimierung der Maschinengenauigkeit. | Grundlegendes
Software-Option 3D-ToolComp | Beschreibung
Eingriffswinkelabhängige 3D Werkzeug-Radiuskorrektur bei LN-Sätzen. | Benutzer-Handbuch Klartext-Dialog
Software-Option erweiterte Werkzeug-Verwaltung | Beschreibung
Vom Maschinenhersteller über Python-Scripte anpassbare Werkzeug-Verwaltung. | Benutzer-Handbuch Klartext-Dialog
Software-Option CAD-Viewer | Beschreibung
Öffnen von 3D-Modellen auf der Steuerung. | Benutzer-Handbuch Klartext-Dialog
Software-Option Interpolationsdrehen | Beschreibung
Interpolationsdrehen eines Absatzes mit Zyklus 290. | INTERPOLATIONSDREHEN (Software-Option, Zyklus 290, DIN/ISO: G290)
Software-Option Remote Desktop Manager | Beschreibung
Fernbedienung externer Rechner-Einheiten (z. B. Windows-PC) über die Benutzer-Oberfläche der TNC | Benutzer-Handbuch Klartext-Dialog
Software-Option Cross Talk Compensation CTC | Beschreibung
Kompensation von Achskopplungen | Maschinen-Handbuch
Software-Option Position Adaptive Control PAC | Beschreibung
Anpassung von Regelparametern | Maschinen-Handbuch
Software-Option Load Adaptive Control LAC | Beschreibung
Dynamische Anpassung von Regelparametern | Maschinen-Handbuch
Software-Option Active Chatter Control ACC | Beschreibung
Vollautomaische Funktion zur Rattervermeidung während der Bearbeitung | Maschinen-Handbuch


Entwicklungsstand (Upgrade-Funktionen)

Neben Software-Optionen werden wesentliche Weiterentwicklungen der TNC-Software über Upgrade-Funktionen, den sogenannten Feature Content Level (engl. Begriff für Entwicklungsstand), verwaltet. Funktionen die dem FCL unterliegen, stehen Ihnen nicht zur Verfügung, wenn Sie an Ihrer TNC einen Software-Update erhalten.

Wenn Sie eine neue Maschine erhalten, dann stehen Ihnen alle Upgrade-Funktionen ohne Mehrkosten zur Verfügung.

Upgrade-Funktionen sind im Handbuch mit FCL n gekennzeichnet, wobei n die fortlaufende Nummer des Entwicklungsstandes kennzeichnet.

Sie können durch eine käuflich zu erwerbende Schlüsselzahl die FCL-Funktionen dauerhaft freischalten. Setzen Sie sich hierzu mit Ihrem Maschinenhersteller oder mit HEIDENHAIN in Verbindung.

FCL 4-Funktionen | Beschreibung
Grafische Darstellung des Schutzraumes bei aktiver Kollisionsüberwachung DCM | Benutzer-Handbuch
Handradüberlagerung in gestopptem Zustand bei aktiver Kollisionsüberwachung DCM | Benutzer-Handbuch
3D-Grunddrehung (Aufspannkompensation) | Maschinenhandbuch
FCL 3-Funktionen | Beschreibung
Tastsystem-Zyklus zum 3D-Antasten | MESSEN 3D (Zyklus 4, FCL 3‑Funktion)
Tastsystemzyklen zum automatischen Bezugspunkt-Setzen Mitte Nut/Mitte Steg | BEZUGSPUNKT MITTE NUT (Zyklus 408, DIN/ISO: G408, FCL 3-Funktion)
Vorschubreduzierung bei Konturtaschenbearbeitung wenn Werkzeug im Volleingriff ist | Benutzer-Handbuch
PLANE-Funktion: Achswinkeleingabe | Benutzer-Handbuch
Benutzer-Dokumentation als Kontextsensitives Hilfesystem | Benutzer-Handbuch
smarT.NC: smarT.NC programmieren parallel zur Bearbeitung | Benutzer-Handbuch
smarT.NC: Konturtasche auf Punktemuster | Lotse smarT.NC
smarT.NC: Preview von Konturprogrammen im Datei-Manager | Lotse smarT.NC
smarT.NC: Positionierstrategie bei Punkte-Bearbeitungen | Lotse smarT.NC
FCL 2-Funktionen | Beschreibung
3D-Liniengrafik | Benutzer-Handbuch
Virtuelle Werkzeug-Achse | Benutzer-Handbuch
USB-Unterstützung von Block-Geräten (Speicher-Sticks, Festplatten, CD-ROM-Laufwerke) | Benutzer-Handbuch
Konturen filtern, die extern erstellt wurden | Benutzer-Handbuch
Möglichkeit, jeder Teilkontur bei der Konturformel unterschiedliche Tiefen zuzuweisen | Benutzer-Handbuch
Dynamische IP-Adressen-Verwaltung DHCP | Benutzer-Handbuch
Tastsystem-Zyklus zum globalen Einstellen von Tastsystem-Parametern | SCHNELLES ANTASTEN (Zyklus 441, DIN/ISO: G441, FCL 2-Funktion)
smarT.NC: Satzvorlauf grafisch unterstützt | Lotse smarT.NC
smarT.NC: Koordinaten-Transformationen | Lotse smarT.NC
smarT.NC: PLANE-Funktion | Lotse smarT.NC


Vorgesehener Einsatzort

Die TNC entspricht der Klasse A nach EN 55022 und ist hauptsächlich für den Betrieb in Industriegebieten vorgesehen.


Neue Zyklen-Funktionen der Software 60642x-01

  • Neuer Zyklus 275 Konturnut mit wirbelfräsen herstellen (siehe NUTENFRAESEN (Zyklus 253, DIN/ISO: G253))
  • Beim Zyklus 241 zum Einlippen-Bohren kann nun auch eine Verweiltiefe definiert werden (siehe EINLIPPEN-BOHREN (Zyklus 241, DIN/ISO: G241))
  • An- und Wegfahrverhalten des Zyklus 39 ZYLINDERMANTEL KONTUR ist nun einstellbar (siehe Zyklusablauf)
  • Neuer Tastsystem-Zyklus zum Kalibrieren eines Tastsystems an einer Kalibrierkugel (siehe TS KALIBRIEREN (Zyklus 460, DIN/ISO: G460))
  • KinematicsOpt: Ein zusätzlicher Parameter zur Ermittlung der Lose einer Drehachse wurde eingeführt (siehe Lose)
  • KinematicsOpt: Bessere Unterstützung zur Positionierung von hirthverzahnten Achsen (siehe Maschinen mit hirthverzahnten-Achsen)


Neue Zyklen-Funktionen der Software 60642x-02

  • Neuer Bearbeitungszyklus 225 Gravieren (siehe KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276))
  • Neuer Bearbeitungszyklus 276 Konturzug 3D (siehe KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276))
  • Neuer Bearbeitungszyklus 290 Interpolationsdrehen (siehe INTERPOLATIONSDREHEN (Software-Option, Zyklus 290, DIN/ISO: G290))
  • Bei den Gewindefräszyklen 26x steht jetzt ein separater Vorschub für das tangentiale Anfahren an Gewinde zur Verfügung (siehe jeweilige Beschreibung der Zyklenparameter)
  • Bei den KinematicsOpt-Zyklen wurden folgende Verbesserungen durchgeführt:
    • Neuer, schnellerer OptimierungsalgorithmusNach der Winkeloptimierung ist keine separate Messreihe mehr für die Positionsoptimierung erforderlich (siehe Verschiedene Modi (Q406))
    • Rückgabe der Offsetfehler (Änderung des Maschinennullpunkts) in den Parametern Q147-149 (siehe Zyklusablauf)
    • Bis zu 8 Ebenenmesspunkte bei der Kugelmessung (siehe Zyklusparameter)
    • Drehachsen die nicht konfiguriert sind werden von der TNC beim Ausführen des Zyklus ignoriert (siehe Beim Programmieren beachten!)


Neue Zyklen-Funktionen der Software 60642x-03

  • Beim Zyklus 256 Rechteckzapfen steht jetzt ein Parameter zur Verfügung, mit dem Sie die Anfahrposition am Zapfen festlegen können (siehe RECHTECKZAPFEN (Zyklus 256, DIN/ISO: G256))
  • Beim Zyklus 257 Kreiszapfenfräsen steht jetzt ein Parameter zur Verfügung, mit dem Sie die Anfahrposition am Zapfen festlegen können (siehe KREISZAPFEN (Zyklus 257, DIN/ISO: G257))


Neue Zyklen-Funktionen der Software 60642x-04

  • Zyklus 25: Automatische Restmaterialerkennung neu dazu (siehe KONTUR-ZUG (Zyklus 25, DIN/ISO: G125))
  • Zyklus 200: Eingabeparameter Q359 zur Festlegung des Tiefenbezugs ergänzt (siehe BOHREN (Zyklus 200))
  • Zyklus 203: Eingabeparameter Q359 zur Festlegung des Tiefenbezugs ergänzt (siehe UNIVERSAL-BOHREN (Zyklus 203, DIN/ISO: G203))
  • Zyklus 205: Eingabeparameter Q208 für Rückzugsvorschub ergänzt (siehe UNIVERSAL-TIEFBOHREN (Zyklus 205, DIN/ISO: G205))
  • Zyklus 205: Eingabeparameter Q359 zur Festlegung des Tiefenbezugs ergänzt (siehe UNIVERSAL-TIEFBOHREN (Zyklus 205, DIN/ISO: G205))
  • Zyklus 225: Eingabe von Umlauten ermöglicht, Text kann jetzt auch schräg angeordnet werden (siehe KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276))
  • Zyklus 253: Eingabeparameter Q439 für Vorschubbezug ergänzt (siehe NUTENFRAESEN (Zyklus 253, DIN/ISO: G253))
  • Zyklus 254: Eingabeparameter Q439 für Vorschubbezug ergänzt (siehe RUNDE NUT (Zyklus 254, DIN/ISO: G254))
  • Zyklus 276: Automatische Restmaterialerkennung neu dazu (siehe KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276))
  • Zyklus 290: Mir Zyklus 290 kann nun auch ein Einstich hergestellt werden (siehe INTERPOLATIONSDREHEN (Software-Option, Zyklus 290, DIN/ISO: G290))
  • Zyklus 404: Eingabeparameter Q305 neu dazu, um eine Grunddrehung in einer beliebigen Zeile der Bezugspunkt-Tabelle speichern zu können (siehe GRUNDDREHUNG SETZEN (Zyklus 404, DIN/ISO: G404))


Geänderte Zyklen-Funktionen der 60642x-01

  • Anfahrverhalten beim Seitenschlichten mit Zyklus 24 (DIN/ISO: G124) geändert (siehe Beim Programmieren beachten!)


Geänderte Zyklen-Funktionen der bzw. 60642x-02

  • Position des Softkeys zur Definition von Zyklus 270 geändert


Geänderte Zyklen-Funktionen der bzw. 60642x-04

  • Zyklus 206: Die TNC überwacht jetzt, sofern in er Werkzeug-Tabelle angegeben, die Gewindesteigung
  • Zyklus 207: Die TNC überwacht jetzt, sofern in er Werkzeug-Tabelle angegeben, die Gewindesteigung
  • Zyklus 209: Die TNC überwacht jetzt, sofern in er Werkzeug-Tabelle angegeben, die Gewindesteigung
  • Zyklus 209: Die TNC fährt nun beim Spanbruch vollständig aus der Bohrung heraus, wenn der Parameter Q256=0 definiert ist (Rückzug bei Spanbruch)
  • Zyklus 202: Die TNC fährt das Werkzeug am Bohrungsgrund nicht frei, wenn der Parameter Q214=0 definiert ist (Freifahrrichtung)
  • Zyklus 405: Die TNC schreibt den Bezugspunkt jetzt auch in die Zeile 0 der Bezugspunkttabelle, wenn der Parameter Q337=0 definiert ist
  • Entsprechende Tastsystem-Zyklen 4xx: Der Eingabebereich des Parameters Q305 (Bezugspunkt-Nummer bzw. Nullpunkt-Nummer) wurde auf 99999 erhöht
  • Zyklen 451 und 452: Die TNC blendet jetzt während der Messung das Statusfenster erst aus, wenn zur Kalibrierkugel ein Weg zu verfahren ist, der größer ist, als der Tastkugelradius


Grundlagen / Übersichten

Weitere Informationen:
> Einführung
> Verfügbare Zyklengruppen


Einführung

Häufig wiederkehrende Bearbeitungen, die mehrere Bearbeitungsschritte umfassen, sind in der TNC als Zyklen gespeichert. Auch Koordinaten-Umrechnungen und einige Sonderfunktionen stehen als Zyklen zur Verfügung.

Die meisten Zyklen verwenden Q-Parameter als Übergabeparameter. Parameter mit gleicher Funktion, die die TNC in verschiedenen Zyklen benötigt, haben immer dieselbe Nummer: z.B. Q200 ist immer der Sicherheits-Abstand, Q202 immer die Zustell-Tiefe usw.

Achtung Kollisionsgefahr!

Zyklen führen ggf. umfangreiche Bearbeitungen durch. Aus Sicherheitsgründen vor dem Abarbeiten einen grafischen Programm-Test durchführen!

Wenn Sie bei Zyklen mit Nummern größer 200 indirekte Parameter-Zuweisungen (z.B. Q210 = Q1) verwenden, wird eine Änderung des zugewiesenen Parameters (z.B. Q1) nach der Zyklus-Definition nicht wirksam. Definieren Sie in solchen Fällen den Zyklusparameter (z.B. Q210) direkt.

Wenn Sie bei Bearbeitungszyklen mit Nummern größer 200 einen Vorschub-Parameter definieren, dann können Sie per Softkey anstelle eines Zahlenwertes auch den im TOOL CALL-Satz definierten Vorschub (Softkey FAUTO) zuweisen. Abhängig vom jeweiligen Zyklus und von der jeweiligen Funktion des Vorschub-Parameters, stehen noch die Vorschub-Alternativen FMAX (Eilgang), FZ (Zahnvorschub) und FU (Umdrehungs-Vorschub) zur Verfügung.

Beachten Sie, dass eine Änderung des FAUTO-Vorschubes nach einer Zyklus-Definition keine Wirkung hat, da die TNC bei der Verarbeitung der Zyklus-Definition den Vorschub aus dem TOOL CALL-Satz intern fest zuordnet.

Wenn Sie einen Zyklus mit mehreren Teilsätzen löschen wollen, gibt die TNC einen Hinweis aus, ob der komplette Zyklus gelöscht werden soll.


Verfügbare Zyklengruppen

Weitere Informationen:
> Übersicht Bearbeitungszyklen
> Übersicht Tastsystemzyklen


Übersicht Bearbeitungszyklen

Die Softkey-Leiste zeigt die verschiedenen Zyklus-Gruppen

Zyklengruppe | Softkey | Seite
Zyklen zum Tiefbohren, Reiben, Ausdrehen und Senken |  | Übersicht
Zyklen zum Gewindebohren, Gewindeschneiden und Gewindefräsen |  | Übersicht
Zyklen zum Fräsen von Taschen, Zapfen und Nuten |  | Übersicht
Zyklen zur Herstellung von Punktemustern, z.B. Lochkreis od. Lochfläche |  | Übersicht
SL-Zyklen (Subcontur-List), mit denen aufwendigere Konturen konturparallel bearbeitet werden, die sich aus mehreren überlagerten Teilkonturen zusammensetzen, Zylindermantel-Interpolation |  | Übersicht
Zyklen zum Abzeilen ebener oder in sich verwundener Flächen |  | Übersicht
Zyklen zur Koordinaten-Umrechnung, mit denen beliebige Konturen verschoben, gedreht, gespiegelt, vergrößert und verkleinert werden |  | Übersicht
Sonder-Zyklen Verweilzeit, Programm-Aufruf, Spindel-Orientierung, Toleranz, Gravieren, Interpolationsdrehen (Option) |  | Grundlagen

Ggf. auf maschinenspezifische Bearbeitungszyklen weiterschalten. Solche Bearbeitungszyklen können von Ihrem Maschinenhersteller integriert werden


Übersicht Tastsystemzyklen

Die Softkey-Leiste zeigt die verschiedenen Zyklus-Gruppen

Zyklengruppe | Softkey | Seite
Zyklen zum automatischen Erfassen und Kompensieren einer Werkstück-Schieflage |  | Übersicht
Zyklen zum automatischen Bezugspunkt-Setzen |  | Übersicht
Zyklen zur automatischen Werkstück-Kontrolle |  | Übersicht
Kalibrierzyklen, Sonderzyklen |  | Übersicht
Zyklen zur automatischen Kinematik-Vermessung |  | Übersicht
Zyklen zur automatischen Werkzeug-Vermessung (wird vom Maschinenhersteller freigegeben) |  | Übersicht

Ggf. auf maschinenspezifische Tastsystemzyklen weiterschalten. Solche Tastsystemzyklen können von Ihrem Maschinenhersteller integriert werden


Bearbeitungszyklen verwenden

Weitere Informationen:
> Mit Bearbeitungszyklen arbeiten
> Programmvorgaben für Zyklen
> Muster-Definition PATTERN DEF
> Punkte-Tabellen


Mit Bearbeitungszyklen arbeiten

Weitere Informationen:
> Allgemeine Hinweise
> Maschinenspezifische Zyklen
> Zyklus definieren über Softkeys
> Zyklus definieren über GOTO-Funktion
> Zyklen aufrufen
> Arbeiten mit Zusatzachsen U/V/W


Allgemeine Hinweise

    Sofern Sie NC-Programme aus alten TNC-Steuerungen einlesen oder extern erstellen, z.B. über ein CAM-System oder auch mit einem ASCI-Editor, achten Sie auf folgende Konventionen:

  • Bearbeitungs- und Tastsystemzyklen mit Nummern kleiner 200:
    • Bei älteren iTNC-Softwareständen und älteren TNC-Steuerungen wurden in manchen Dialogsprachen Textfolgen verwendet, die der aktuelle iTNC-Editor nicht immer richtig wandeln konnte. Darauf achten, dass keine Zyklustexte mit einem Punkt enden.
  • Bearbeitungs- und Tastsystemzyklen mit Nummern größer 200:
    • Mit dem Tilde-Zeichen (~) das jeweilige Zeilenende kennzeichnen. Der letzte Parameter im Zyklus darf kein Tilde-Zeichen enthalten
    • Zyklusnamen und-Kommentare müssen nicht zwingend angegeben sein. Beim Einlesen in die Steuerung ergänzt die iTNC die Zyklusnamen und-Kommentare entsprechend der eingestellten Dialogsprache


Maschinenspezifische Zyklen

An vielen Maschinen stehen Zyklen zur Verfügung, die von Ihrem Maschinenhersteller zusätzlich zu den HEIDENHAIN-Zyklen in die TNC implementiert werden. Hierfür steht ein separater Zyklen-Nummernkreis zur Verfügung:

  • Zyklen 300 bis 399
    Maschinensprezifische Zyklen, die über die Taste cycle def zu definieren sind
  • Zyklen 500 bis 599
    Maschinenspezifische Tastsystemzyklen, die über die Taste touch probe zu definieren sind

Beachten Sie hierzu die jeweilige Funktionsbeschreibung im Maschinenhandbuch.

Unter Umständen werden bei maschinenspezifischen Zyklen auch Übergabe-Parameter verwendet, die HEIDENHAIN bereits in Standard-Zyklen verwendet hat. Um bei der gleichzeitigen Verwendung von DEF-aktiven Zyklen (Zyklen, die die TNC automatisch bei der Zyklus-Definition abarbeitet, siehe auch Zyklen aufrufen) und CALL-aktiven Zyklen (Zyklen, die Sie zur Ausführung aufrufen müssen, siehe auch Zyklen aufrufen) Probleme hinsichtlich des Überschreibens von mehrfach verwendeten Übergabe-Parametern zu vermeiden, folgende Vorgehensweise beachten:

  • Grundsätzlich DEF-aktive Zyklen vor CALL-aktiven Zyklen programmieren

  • Zwischen der Definition eines CALL-aktiven Zyklus und dem jeweiligen Zyklus-Aufruf einen DEF-aktiven Zyklus nur dann programmieren, wenn keine Überschneidungen bei den Übergabeparametern dieser beiden Zyklen auftreten


Zyklus definieren über Softkeys

Die Softkey-Leiste zeigt die verschiedenen Zyklus-Gruppen

Zyklus-Gruppe wählen, z.B. Bohrzyklen

Zyklus wählen, z.B. GEWINDEFRÄSEN. Die TNC eröffnet einen Dialog und erfragt alle Eingabewerte; gleichzeitig blendet die TNC in der rechten Bildschirmhälfte eine Grafik ein, in der der einzugebende Parameter hell hinterlegt ist

Geben Sie alle von der TNC geforderten Parameter ein und schließen Sie jede Eingabe mit der Taste ENT ab

Die TNC beendet den Dialog, nachdem Sie alle erforderlichen Daten eingegeben haben


Zyklus definieren über GOTO-Funktion

Die Softkey-Leiste zeigt die verschiedenen Zyklus-Gruppen

Die TNC zeigt in einem Überblend-Fenster die Zyklen-Übersicht an

Wählen Sie mit den Pfeiltasten den gewünschten Zyklus oder

Wählen Sie mit CTRL + Pfeiltasten (seitenweises Blättern) den gewünschten Zyklus oder

Geben Sie die Zyklus-Nummer ein und bestätigen jeweils mit der Taste ENT. Die TNC eröffnet dann den Zyklus-Dialog wie zuvor beschrieben

NC-Beispielsätze
7 CYCL DEF 200 BOHREN
Q200=2 ;sicherheits-abst.
Q201=3 ;tiefe
Q206=150 ;vorschub tiefenz.
Q202=5 ;zustell-tiefe
Q210=0 ;verweilzeit oben
Q203=+0 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q211=0.25 ;verweilzeit unten


Zyklen aufrufen

Voraussetzungen

    Vor einem Zyklus-Aufruf programmieren Sie in jedem Fall:

  • BLK FORM zur grafischen Darstellung (nur für Testgrafik erforderlich)
  • Werkzeug-Aufruf
  • Drehsinn der Spindel (Zusatz-Funktion M3/M4)
  • Zyklus-Definition (CYCL DEF).

Beachten Sie weitere Voraussetzungen, die bei den nachfolgenden Zyklusbeschreibungen aufgeführt sind.

    Folgende Zyklen wirken ab ihrer Definition im Bearbeitungs-Programm. Diese Zyklen können und dürfen Sie nicht aufrufen:

  • die Zyklen 220 Punktemuster auf Kreis und 221 Punktemuster auf Linien
  • den SL-Zyklus 14 KONTUR
  • den SL-Zyklus 20 KONTUR-DATEN
  • Zyklus 32 TOLERANZ
  • Zyklen zur Koordinaten-Umrechnung
  • den Zyklus 9 VERWEILZEIT
  • alle Tastsystem-Zyklen

Alle übrigen Zyklen können Sie mit den nachfolgend beschriebenen Funktionen aufrufen.

Weitere Informationen:
> Zyklus-Aufruf mit CYCL CALL
> Zyklus-Aufruf mit CYCL CALL PAT
> Zyklus-Aufruf mit CYCL CALL POS
> Zyklus-Aufruf mit M99/M89


Zyklus-Aufruf mit CYCL CALL

Die Funktion CYCL CALL ruft den zuletzt definierten Bearbeitungszyklus einmal auf. Startpunkt des Zyklus ist die zuletzt vor dem CYCL CALL-Satz programmierte Position.

Zyklus-Aufruf programmieren: Taste CYCL CALL -drücken

Zyklus-Aufruf eingeben: Softkey CYCL CALL M -drücken

Ggf. Zusatz-Funktion M eingeben (z.B. M3 um die Spindel einzuschalten), oder mit der Taste END den Dialog beenden


Zyklus-Aufruf mit CYCL CALL PAT

Die Funktion CYCL CALL PAT ruft den zuletzt definierten Bearbeitungszyklus an allen Positionen auf, die Sie in einer in einer Musterdefinition PATTERN DEF (siehe Muster-Definition PATTERN DEF) oder in einer Punkte-Tabelle (siehe Punkte-Tabellen) definiert haben.


Zyklus-Aufruf mit CYCL CALL POS

Die Funktion CYCL CALL POS ruft den zuletzt definierten Bearbeitungszyklus einmal auf. Startpunkt des Zyklus ist die Position, die Sie im CYCL CALL POS-Satz definiert haben.

Die TNC fährt die im CYCL CALL POS-Satz angegebene Position mit Positionierlogik an:

  • Ist die aktuelle Werkzeugposition in der Werkzeugachse größer als die Oberkante des Werkstücks (Q203), dann positioniert die TNC zuerst in der Bearbeitungsebene auf die programmierte Position und anschließend in der Werkzeugachse
  • Liegt die aktuelle Werkzeugposition in der Werkzeugachse unterhalb der Oberkante des Werkstücks (Q203), dann positioniert die TNC zuerst in Werkzeugachse auf die Sichere Höhe und anschließend in der Bearbeitungsebene auf die programmierte Position

Im CYCL CALL POS-Satz müssen immer drei Koordinatenachsen programmiert sein. Über die Koordinate in der Werkzeug-Achse können Sie auf einfache Weise die Startposition verändern. Sie wirkt wie eine zusätzliche Nullpunkt-Verschiebung.

Der im CYCL CALL POS-Satz definierte Vorschub gilt nur zum Anfahren der in diesem Satz programmierten Startposition.

Die TNC fährt die im CYCL CALL POS-Satz definierte Position grundsätzlich mit inaktiver Radiuskorrektur (R0) an.

Wenn Sie mit CYCL CALL POS einen Zyklus aufrufen in dem eine Startposition definiert ist (z.B. Zyklus 212), dann wirkt die im Zyklus definierte Position wie eine zusätzliche Verschiebung auf die im CYCL CALL POS-Satz definierte Position. Sie sollten daher die im Zyklus festzulegende Startposition immer mit 0 definieren.


Zyklus-Aufruf mit M99/M89

Die satzweise wirksame Funktion M99 ruft den zuletzt definierten Bearbeitungszyklus einmal auf. M99 können Sie am Ende eines Positioniersatzes programmieren, die TNC fährt dann auf diese Position und ruft anschließend den zuletzt definierten Bearbeitungszyklus auf.

Soll die TNC den Zyklus nach jedem Positionier-Satz automatisch ausführen, programmieren Sie den ersten Zyklus-Aufruf mit M89 (abhängig von Maschinen-Parameter 7440).

    Um die Wirkung von M89 aufzuheben, programmieren Sie:

  • M99 in dem Positioniersatz, in dem Sie den letzten Startpunkt anfahren, oder
  • einen CYCL CALL POS-Satz, oder
  • mit CYCL DEF einen neuen Bearbeitungszyklus


Arbeiten mit Zusatzachsen U/V/W

    Die TNC führt Zustellbewegungen in der Achse aus, die Sie im TOOL CALL-Satz als Spindelachse definiert haben. Bewegungen in der Bearbeitungsebene führt die TNC grundsätzlich nur in den Hauptachsen X, Y oder Z aus. Ausnahmen:

  • Wenn Sie im Zyklus 3 NUTENFRAESEN und im Zyklus 4 TASCHENFRAESEN für die Seitenlängen direkt Zusatzachsen programmieren

  • Wenn Sie bei SL-Zyklen Zusatzachsen im ersten Satz des Kontur-Unterprogrammes programmieren

  • Bei den Zyklen 5 (KREISTASCHE), 251 (RECHTECKTASCHE), 252 (KREISTASCHE), 253 (NUT) und 254 (RUNDE NUT) arbeitet die TNC den Zyklus in den Achsen ab, die Sie im letzten Positioniersatz vor dem jeweiligen Zyklus-Aufruf programmiert haben. Bei aktiver Werkzeugachse Z sind folgende Kombinationen zulässig:
    • X/Y
    • X/V
    • U/Y
    • U/V


Programmvorgaben für Zyklen

Weitere Informationen:
> Übersicht
> GLOBAL DEF eingeben
> GLOBAL DEF-Angaben nutzen
> Allgemeingültige globale Daten
> Globale Daten für Bohrbearbeitungen
> Globale Daten für Fräsbearbeitungen mit Taschenzyklen 25x
> Globale Daten für Fräsbearbeitungen mit Konturzyklen
> Globale Daten für das Positionierverhalten
> Globale Daten für Antastfunktionen


Übersicht

Alle Zyklen 20 bis 25 und mit Nummern größer 200, verwenden immer wieder identische Zyklenparameter, wie z.B. den Sicherheits-Abstand Q200, die Sie bei jeder Zyklendefinition angeben müssen. Über die Funktion GLOBAL DEF haben Sie die Möglichkeit, diese Zyklenparameter am Programm-Anfang zentral zu definieren, so dass sie global für alle im Programm verwendeten Bearbeitungszyklen wirksam sind. Im jeweiligen Bearbeitungszyklus verweisen Sie dann lediglich auf den Wert, den Sie am Programm-Anfang definiert haben.

Folgende GLOBAL DEF-Funktionen stehen zur Verfügung:

Bearbeitungsmuster | Softkey | Seite
GLOBAL DEF ALLGEMEIN Definition von allgemeingültigen Zyklenparametern |  | Allgemeingültige globale Daten
GLOBAL DEF BOHREN Definition spezieller Bohrzyklenparameter |  | Globale Daten für Bohrbearbeitungen
GLOBAL DEF TASCHENFRAESEN Definition spezieller Taschenfräs-Zyklenparameter |  | Globale Daten für Fräsbearbeitungen mit Taschenzyklen 25x
GLOBAL DEF KONTURFRAESEN Definition spezieller Konturfräsparameter |  | Globale Daten für Fräsbearbeitungen mit Konturzyklen
GLOBAL DEF POSITIONIEREN Definition des Positionierverhaltens bei CYCL CALL PAT |  | Globale Daten für das Positionierverhalten
GLOBAL DEF ANTASTEN Definition spezieller Tastsystemzyklenparameter |  | Globale Daten für Antastfunktionen

Über die Funktion SMART UNIT EINFÜGEN (siehe Benutzer-Handbuch Klartext-Dialog, Kapitel Sonderfunktionen), können Sie mit der UNIT 700 alle GLOBAL DEF-Funktionen in einem Block einfügen.


GLOBAL DEF eingeben

Betriebsart Einspeichern/Editieren wählen

Sonderfunktionen wählen

Funktionen für die Programmvorgaben wählen

global DEF-Funktionen wählen

Gewünschte GLOBAL-DEF-Funktion wählen, z.B. GLOBAL DEF ALLGEMEIN

Erforderliche Definitionen eingeben, jeweils mit Taste ENT bestätigen


GLOBAL DEF-Angaben nutzen

Wenn Sie am Programm-Anfang die entsprechenden GLOBAL DEF-Funktionen eingegeben haben, dann können Sie bei der Definition eines beliebigen Bearbeitungs-Zyklus auf diese global gültigen Werte referenzieren.

Gehen Sie dabei wie folgt vor:

Betriebsart Einspeichern/Editieren wählen

Bearbeitungszyklen wählen

Gewünschte Zyklengruppe wählen, z.B. Bohrzyklen

Gewünschten Zyklus wählen, z.B. bohren

Die TNC blendet den Softkey Standardwert setzen ein, wenn es dafür einen globalen Parameter gibt

Softkey Standardwert setzen drücken: Die TNC trägt das Wort PREDEF (englisch: Vordefiniert) in die Zyklusdefinition ein. Damit haben Sie eine Verknüpfung zum entsprechenden GLOBAL DEF-Parameter durchgeführt, den Sie am Programm-Anfang definiert haben

Achtung Kollisionsgefahr!

Beachten Sie, dass sich nachträgliche Änderungen der Programm-Einstellungen auf das gesamte Bearbeitungsprogramm auswirken und somit den Bearbeitungsablauf erheblich verändern können.

Wenn Sie in einem Bearbeitungs-Zyklus einen festen Wert eintragen, dann wird dieser Wert nicht von GLOBAL DEF-Funktionen verändert.


Allgemeingültige globale Daten

  • Sicherheits-Abstand: Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche beim automatischen Anfahren der Zyklus-Startposition in der Werkzeug-Achse

  • 2. Sicherheits-Abstand: Position, auf die die TNC das Werkzeug am Ende eines Bearbeitungsschrittes positioniert. Auf dieser Höhe wird die nächste Bearbeitungsposition in der Bearbeitungsebene angefahren

  • F Positionieren: Vorschub, mit dem die TNC das Werkzeug innerhalb eines Zyklus verfährt

  • F Rückzug: Vorschub, mit dem die TNC das Werkzeug zurückpositioiniert

Parameter gelten für alle Bearbeitungszyklen 2xx.


Globale Daten für Bohrbearbeitungen

  • Rückzug Spanbruch: Wert, um den die TNC das Werkzeug beim Spanbrechen zurückzieht

  • Verweilzeit unten: Zeit in Sekunden, die das Werkzeug am Bohrungsgrund verweilt

  • Verweilzeit oben: Zeit in Sekunden, die das Werkzeug auf Sicherheits-Abstand verweilt

Parameter gelten für die Bohr-, Gewindebohr- und Gewindefräszyklen 200 bis 209, 240 und 262 bis 267.


Globale Daten für Fräsbearbeitungen mit Taschenzyklen 25x

  • Überlappungs-Faktor: Werkzeug-Radius x Überlappungsfaktor ergibt die seitliche Zustellung

  • Fräsart: Gleichlauf/Gegenlauf

  • Eintauchart: helixförmig, pendelnd oder senkrecht ins Material eintauchen

Parameter gelten für die Fräszyklen 251 bis 257.


Globale Daten für Fräsbearbeitungen mit Konturzyklen

  • Sicherheits-Abstand: Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche beim automatischen Anfahren der Zyklus-Startposition in der Werkzeug-Achse

  • Sichere Höhe: Absolute Höhe, in der keine Kollision mit dem Werkstück erfolgen kann (für Zwischenpositionierungen und Rückzug am Zyklus-Ende)

  • Überlappungs-Faktor: Werkzeug-Radius x Überlappungsfaktor ergibt die seitliche Zustellung

  • Fräsart: Gleichlauf/Gegenlauf

Parameter gelten für die SL-Zyklen 20, 22, 23, 24 und 25.


Globale Daten für das Positionierverhalten

  • Positionier-Verhalten: Rückzug in der Werkzeug-Achse am Ende eines Bearbeitungsschrittes: Auf 2. Sicherheits-Abstand oder auf die Position am Unit-Anfang zurückziehen

Parameter gelten für alle Bearbeitungszyklen, wenn Sie den jeweiligen Zyklus mit der Funktion CYCL CALL PAT rufen.


Globale Daten für Antastfunktionen

  • Sicherheits-Abstand: Abstand zwischen Taststift und Werkstück-Oberfläche beim automatischen Anfahren der Antastposition

  • Sichere Höhe: Koordinate in der Tastsystem-Achse, auf der die TNC das Tastsystem zwischen Messpunkten verfährt, sofern Option Fahren auf sichere Höhe aktiviert ist

  • Fahren auf sichere Höhe: Wählen, ob die TNC zwischen Messpunkten auf Sicherheits-Abstand oder auf sicherer Höhe verfahren soll

Parameter gelten für alle Tastsystemzyklen 4xx.


Muster-Definition PATTERN DEF

Weitere Informationen:
> Anwendung
> PATTERN DEF eingeben
> PATTERN DEF verwenden
> Einzelne Bearbeitungspositionen definieren
> Einzelne Reihe definieren
> Einzelnes Muster definieren
> Einzelnen Rahmen definieren
> Vollkreis definieren
> Teilkreis definieren


Anwendung

Mit der Funktion PATTERN DEF definieren Sie auf einfache Weise regelmäßige Bearbeitungsmuster, die Sie mit der Funktion CYCL CALL PAT rufen können. Wie bei den Zyklus-Definitionen, stehen auch bei der Musterdefinition Hilfsbilder zur Verfügung, die den jeweiligen Eingabeparameter verdeutlichen.

PATTERN DEF nur in Verbindung mit Werkzeug-Achse Z verwenden!

Folgende Bearbeitungsmuster stehen zur Verfügung:

Bearbeitungsmuster | Softkey | Seite
PUNKT Definition von bis zu 9 beliebigen Bearbeitungspositionen |  | Einzelne Bearbeitungspositionen definieren
REIHE Definition einer einzelnen Reihe, gerade oder gedreht |  | Einzelne Reihe definieren
MUSTER Definition eines einzelnen Musters, gerade, gedreht oder verzerrt |  | Einzelnes Muster definieren
RAHMEN Definition eines einzelnen Rahmens, gerade, gedreht oder verzerrt |  | Einzelnen Rahmen definieren
KREIS Definition eines Vollkreises |  | Vollkreis definieren
TEILKREIS Definition eines Teilkreises |  | Teilkreis definieren


PATTERN DEF eingeben

Betriebsart Einspeichern/Editieren wählen

Sonderfunktionen wählen

Funktionen für die Kontur- und Punktbearbeitung wählen

PATTERN DEF-Satz öffnen

Gewünschtes Bearbeitungsmuster wählen, z.B. einzelne Reihe

Erforderliche Definitionen eingeben, jeweils mit Taste ENT bestätigen


PATTERN DEF verwenden

Sobald Sie eine Musterdefinition eingegeben haben, können Sie diese über die Funktion CYCL CALL PAT aufrufen (siehe Zyklus-Aufruf mit CYCL CALL PAT). Die TNC führt dann den zuletzt definierten Bearbeitungszyklus auf den von Ihnen definiertem Bearbeitungsmuster aus.

Ein Bearbeitungsmuster bleibt so lange aktiv, bis Sie ein Neues definieren, oder über die Funktion SEL pattern eine Punkte-Tabelle angewählt haben.

Über den Satzvorlauf können Sie einen beliebigen Punkt wählen, an dem Sie die Bearbeitung beginnen oder fortsetzen können (siehe Benutzer-Handbuch, Kapitel Programm-Test und Programmlauf).


Einzelne Bearbeitungspositionen definieren

Sie können maximal 9 Bearbeitungspositionen eingeben, Eingabe jeweils mit Taste ENT bestätigen.

Wenn Sie eine Werkstückoberfläche in Z ungleich 0 definieren, dann wirkt dieser Wert zusätzlich zur Werkstückoberfläche Q203, die Sie im Bearbeitungszyklus definiert haben.

Beispiel: NC-Sätze
10 L Z+100 R0 FMAX
11 pattern def pos1 (x+25 y+33,5 z+0) pos2 (x+50 y+75 z+0)

X-Koordinate Bearbeitungspos. (absolut): X‑Koordinate eingeben

Y-Koordinate Bearbeitungspos. (absolut): Y‑Koordinate eingeben

Koordinate Werkstück-Oberfläche (absolut): Z‑Koordinate eingeben, an der die Bearbeitung starten soll


Einzelne Reihe definieren

Wenn Sie eine Werkstückoberfläche in Z ungleich 0 definieren, dann wirkt dieser Wert zusätzlich zur Werkstückoberfläche Q203, die Sie im Bearbeitungszyklus definiert haben.

Beispiel: NC-Sätze
10 L Z+100 R0 FMAX
11 pattern def ROW1 (x+25 y+33,5 d+8 num5 rot+0 z+0)

Startpunkt X (absolut): Koordinate des Reihen-Startpunktes in der X-Achse

Startpunkt Y (absolut): Koordinate des Reihen-Startpunktes in der Y-Achse

Abstand Bearbeitungspositionen (inkremental): Abstand zwischen den Bearbeitungspositionen. Wert positiv oder negativ eingebbar

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen

Drehlage des gesamten Musters (absolut): Drehwinkel um den eingegebenen Startpunkt. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Koordinate Werkstück-Oberfläche (absolut): Z-Koordinate eingeben, an der die Bearbeitung starten soll


Einzelnes Muster definieren

Wenn Sie eine Werkstückoberfläche in Z ungleich 0 definieren, dann wirkt dieser Wert zusätzlich zur Werkstückoberfläche Q203, die Sie im Bearbeitungszyklus definiert haben.

Die Parameter Drehlage Hauptachse und Drehlage Nebenachse wirken additiv auf eine zuvor durchgeführte Drehlage des gesamten Musters.

Beispiel: NC-Sätze
10 L Z+100 R0 FMAX
11 pattern def PAT1 (x+25 y+33,5 dX+8 dy+10 numx5 numy4 rot+0 rotx+0 roty+0 z+0)

Startpunkt X (absolut): Koordinate des Muster-Startpunktes in der X-Achse

Startpunkt Y (absolut): Koordinate des Muster-Startpunktes in der Y-Achse

Abstand Bearbeitungspositionen X (inkremental): Abstand zwischen den Bearbeitungspositionen in X‑Richtung. Wert positiv oder negativ eingebbar

Abstand Bearbeitungspositionen Y (inkremental): Abstand zwischen den Bearbeitungspositionen in Y‑Richtung. Wert positiv oder negativ eingebbar

Anzahl Spalten: Gesamt-Spaltenanzahl des Musters

Anzahl Zeilen: Gesamt-Zeilenanzahl des Musters

Drehlage des gesamten Musters (absolut): Drehwinkel, um den das gesamte Muster um den eingegebenen Startpunkt gedreht wird. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Drehlage Hauptachse: Drehwinkel, um den ausschließlich die Hauptachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Drehlage Nebenachse: Drehwinkel, um den ausschließlich die Nebenachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Koordinate Werkstück-Oberfläche (absolut): Z‑Koordinate eingeben, an der die Bearbeitung starten soll


Einzelnen Rahmen definieren

Wenn Sie eine Werkstückoberfläche in Z ungleich 0 definieren, dann wirkt dieser Wert zusätzlich zur Werkstückoberfläche Q203, die Sie im Bearbeitungszyklus definiert haben.

Die Parameter Drehlage Hauptachse und Drehlage Nebenachse wirken additiv auf eine zuvor durchgeführte Drehlage des gesamten Musters.

Beispiel: NC-Sätze
10 L Z+100 R0 FMAX
11 pattern def FRAME1 (x+25 y+33,5 dX+8 dy+10 numx5 numy4 rot+0 rotx+0 roty+0 z+0)

Startpunkt X (absolut): Koordinate des Rahmen-Startpunktes in der X-Achse

Startpunkt Y (absolut): Koordinate des Rahmen-Startpunktes in der Y-Achse

Abstand Bearbeitungspositionen X (inkremental): Abstand zwischen den Bearbeitungspositionen in X‑Richtung. Wert positiv oder negativ eingebbar

Abstand Bearbeitungspositionen Y (inkremental): Abstand zwischen den Bearbeitungspositionen in Y‑Richtung. Wert positiv oder negativ eingebbar

Anzahl Spalten: Gesamt-Spaltenanzahl des Musters

Anzahl Zeilen: Gesamt-Zeilenanzahl des Musters

Drehlage des gesamten Musters (absolut): Drehwinkel, um den das gesamte Muster um den eingegebenen Startpunkt gedreht wird. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Drehlage Hauptachse: Drehwinkel, um den ausschließlich die Hauptachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Drehlage Nebenachse: Drehwinkel, um den ausschließlich die Nebenachse der Bearbeitungsebene bezogen auf den eingegebenen Startpunkt verzerrt wird. Wert positiv oder negativ eingebbar.

Koordinate Werkstück-Oberfläche (absolut): Z‑Koordinate eingeben, an der die Bearbeitung starten soll


Vollkreis definieren

Wenn Sie eine Werkstückoberfläche in Z ungleich 0 definieren, dann wirkt dieser Wert zusätzlich zur Werkstückoberfläche Q203, die Sie im Bearbeitungszyklus definiert haben.

Beispiel: NC-Sätze
10 L Z+100 R0 FMAX
11 pattern def circ1 (x+25 y+33 d80 start+45 num8 z+0)

Lochkreis-Mitte X (absolut): Koordinate des Kreis-Mittelpunktes in der X-Achse

Lochkreis-Mitte Y (absolut): Koordinate des Kreis-Mittelpunktes in der Y-Achse

Lochkreis-Durchmesser: Durchmesser des Lochkreises

Startwinkel: Polarwinkel der ersten Bearbeitungsposition. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen auf dem Kreis

Koordinate Werkstück-Oberfläche (absolut): Z‑Koordinate eingeben, an der die Bearbeitung starten soll


Teilkreis definieren

Wenn Sie eine Werkstückoberfläche in Z ungleich 0 definieren, dann wirkt dieser Wert zusätzlich zur Werkstückoberfläche Q203, die Sie im Bearbeitungszyklus definiert haben.

Beispiel: NC-Sätze
10 L Z+100 R0 FMAX
11 pattern def pitchcirc1 (x+25 y+33 d80 start+45 step30 -num8 z+0)

Lochkreis-Mitte X (absolut): Koordinate des Kreis-Mittelpunktes in der X-Achse

Lochkreis-Mitte Y (absolut): Koordinate des Kreis-Mittelpunktes in der Y-Achse

Lochkreis-Durchmesser: Durchmesser des Lochkreises

Startwinkel: Polarwinkel der ersten Bearbeitungsposition. Bezugsachse: Hauptachse der aktiven Bearbeitungsebene (z.B. X bei Werkzeug-Achse Z). Wert positiv oder negativ eingebbar

Winkelschritt/Endwinkel: Inkrementaler Polarwinkel zwischen zwei Bearbeitungspositionen. Wert positiv oder negativ eingebbar. Alternativ Endwinkel eingebbar (per Softkey umschalten)

Anzahl Bearbeitungen: Gesamtanzahl der Bearbeitungspositionen auf dem Kreis

Koordinate Werkstück-Oberfläche (absolut): Z‑Koordinate eingeben, an der die Bearbeitung starten soll


Punkte-Tabellen

Weitere Informationen:
> Anwendung
> Punkte-Tabelle eingeben
> Einzelne Punkte für die Bearbeitung ausblenden
> Sichere Höhe definieren
> Punkte-Tabelle im Programm wählen
> Zyklus in Verbindung mit Punkte-Tabellen aufrufen


Anwendung

Wenn Sie einen Zyklus, bzw. mehrere Zyklen hintereinander, auf einem unregelmäßigen Punktemuster abarbeiten wollen, dann erstellen Sie Punkte-Tabellen. Wenn Sie Bohrzyklen verwenden, entsprechen die Koordinaten der Bearbeitungsebene in der Punkte-Tabelle den Koordinaten der Bohrungs-Mittelpunkte. Setzen Sie Fräszyklen ein, entsprechen die Koordinaten der Bearbeitungsebene in der Punkte-Tabelle den Startpunkt-Koordinaten des jeweiligen Zyklus (z.B. Mittelpunkts-Koordinaten einer Kreistasche). Koordinaten in der Spindelachse entsprechen der Koordinate der Werkstück-Oberfläche.


Punkte-Tabelle eingeben

Betriebsart Programm-Einspeichern/Editieren wählen:

 | Datei-Verwaltung aufrufen: Taste PGM MGT drücken
Datei-Name?
 | Name und Datei-Typ der Punkte-Tabelle eingeben, mit Taste ENT bestätigen
 | Maßeinheit wählen: Softkey MM oder INCH drücken. Die TNC wechselt ins Programm-Fenster und stellt eine leere Punkte-Tabelle dar
 | Mit Softkey ZEILE EINFÜGEN neue Zeile einfügen und die Koordinaten desgewünschten Bearbeitungsortes eingeben
Vorgang wiederholen, bis alle gewünschten Koordinaten eingegeben sind

Mit den Softkeys X AUS/EIN, Y AUS/EIN, Z AUS/EIN (zweite Softkey-Leiste) legen Sie fest, welche Koordinaten Sie in die Punkte-Tabelle eingeben können.


Einzelne Punkte für die Bearbeitung ausblenden

In der Punkte-Tabelle können Sie über die Spalte FADE den in der jeweiligen Zeile definierten Punkt so kennzeichnen, das dieser für die Bearbeitung wahlweise ausgeblendet wird.

Punkt in der Tabelle wählen, der ausgeblendet werden soll

Spalte FADE wählen

Ausblenden aktivieren, oder

Ausblenden deaktivieren

Um einen entsprechend markierten Punkt bei der Bearbeitung auszublenden, müssen Sie zusätzlich in der Betriebsart Programmlauf den Softkey Sätze ausblenden auf EIN setzen.


Sichere Höhe definieren

In der Spalte CLEARANCE können Sie für jeden Punkt eine separate Sichere Höhe definieren. Die TNC positioniert das Werkzeug in der Werkzeug-Achse dann auf diesem Wert, befor sie die Position in der Bearbeitungsebene anfährt (siehe auch Zyklus in Verbindung mit Punkte-Tabellen aufrufen).


Punkte-Tabelle im Programm wählen

In der Betriebsart Programm-Einspeichern/Editieren das Programm wählen, für das die Punkte-Tabelle aktiviert werden soll:

 | Funktion zur Auswahl der Punkte-Tabelle aufrufen: Taste PGM CALL drücken
 | Softkey PUNKTE-TABELLE drücken
 | Softkey Auswahl fenster drücken: Die TNC blendet ein Fenster ein, in dem Sie die gewünschte Nullpunkt-Tabelle wählen können
Gewünschtes Punkte-Tabelle mit Pfeiltasten oder per Mouse-Klick wählen, mit Taste ENT bestätigen: Die TNC trägt den vollständigen Pfadnamen in den SEL pattern-Satz ein
 | Funktion mit Taste END abschließen

Alternativ können Sie den Tabellen-Namen oder den vollständigen Pfadnamen der aufzurufenden Tabelle auch direkt über die Tastatur eingeben.

NC-Beispielsatz
7 SEL PATTERN “TNC:\DIRKT5\NUST35.PNT“


Zyklus in Verbindung mit Punkte-Tabellen aufrufen

Die TNC arbeitet mit CYCL CALL PAT die Punkte-Tabelle ab, die Sie zuletzt definiert haben (auch wenn Sie die Punkte-Tabelle in einem mit CALL PGM verschachtelten Programm definiert haben).

Soll die TNC den zuletzt definierten Bearbeitungszyklus an den Punkten aufrufen, die in einer Punkte-Tabelle definiert sind, programmieren Sie den Zyklus-Aufruf mit CYCL CALL PAT:

Zyklus-Aufruf programmieren: Taste CYCL CALL drücken

Punkte-Tabelle rufen: Softkey CYCL CALL PAT drücken

Vorschub eingeben, mit dem die TNC zwischen den Punkten verfahren soll (keine Eingabe: Verfahren mit zuletzt programmiertem Vorschub, FMAX nicht gültig)

Bei Bedarf Zusatz-Funktion M eingeben, mit Taste END bestätigen

Die TNC zieht das Werkzeug zwischen den Startpunkten zurück auf die sichere Höhe. Als sichere Höhe verwendet die TNC entweder die Spindelachsen-Koordinate beim Zyklus-Aufruf, den Wert aus dem Zyklus-Parameter Q204 oder den in der Spalte CLEARANCE definierten Wert, je nach dem, welcher größer ist.

Wenn Sie beim Vorpositionieren in der Spindelachse mit reduziertem Vorschub fahren wollen, verwenden Sie die Zusatz-Funktion M103.

Wirkungsweise der Punkte-Tabellen mit SL-Zyklen und Zyklus 12

Die TNC interpretiert die Punkte als zusätzliche Nullpunkt-Verschiebung.

Wirkungsweise der Punkte-Tabellen mit Zyklen 200 bis 208 und 262 bis 267

Die TNC interpretiert die Punkte der Bearbeitungsebene als Koordinaten des Bohrungs-Mittelpunktes. Wenn Sie die in der Punkte-Tabelle definierte Koordinate in der Spindel-Achse als Startpunkt-Koordinate nutzen wollen, müssen Sie die Werkstück-Oberkante (Q203) mit 0 definieren.

Wirkungsweise der Punkte-Tabellen mit Zyklen 210 bis 215

Die TNC interpretiert die Punkte als zusätzliche Nullpunkt-Verschiebung. Wenn Sie die in der Punkte-Tabelle definierten Punkte als Startpunkt-Koordinaten nutzen wollen, müssen Sie die Startpunkte und die Werkstück-Oberkante (Q203) im jeweiligen Fräszyklus mit 0 programmieren.

Wirkungsweise der Punkte-Tabellen mit Zyklen 251 bis 254

Die TNC interpretiert die Punkte der Bearbeitungsebene als Koordinaten des Zyklus-Startpunktes. Wenn Sie die in der Punkte-Tabelle definierte Koordinate in der Spindel-Achse als Startpunkt-Koordinate nutzen wollen, müssen Sie die Werkstück-Oberkante (Q203) mit 0 definieren.


Bearbeitungszyklen: Bohren

Weitere Informationen:
> Grundlagen
> ZENTRIEREN (Zyklus 240, DIN/ISO: G240)
> BOHREN (Zyklus 200)
> REIBEN (Zyklus 201, DIN/ISO: G201)
> AUSDREHEN (Zyklus 202, DIN/ISO: G202)
> UNIVERSAL-BOHREN (Zyklus 203, DIN/ISO: G203)
> RUECKWAERTS-SENKEN (Zyklus 204, DIN/ISO: G204)
> UNIVERSAL-TIEFBOHREN (Zyklus 205, DIN/ISO: G205)
> BOHRFRAESEN (Zyklus 208)
> EINLIPPEN-BOHREN (Zyklus 241, DIN/ISO: G241)
> Programmierbeispiele


Grundlagen

Weitere Informationen:
> Übersicht


Übersicht

Die TNC stellt insgesamt 9 Zyklen für die verschiedensten Bohrbearbeitungen zur Verfügung:

Zyklus | Softkey | Seite
240 ZENTRIEREN Mit automatischer Vorpositionierung, 2. Sicherheits-Abstand, wahlweise Eingabe Zentrierdurchmesser/Zentriertiefe |  | ZENTRIEREN (Zyklus 240, DIN/ISO: G240)
200 BOHREN Mit automatischer Vorpositionierung, 2. Sicherheits-Abstand |  | BOHREN (Zyklus 200)
201 REIBEN Mit automatischer Vorpositionierung, 2. Sicherheits-Abstand |  | REIBEN (Zyklus 201, DIN/ISO: G201)
202 AUSDREHEN Mit automatischer Vorpositionierung, 2. Sicherheits-Abstand |  | AUSDREHEN (Zyklus 202, DIN/ISO: G202)
203 UNIVERSAL-BOHREN Mit automatischer Vorpositionierung, 2. Sicherheits-Abstand, Spanbruch, Degression |  | UNIVERSAL-BOHREN (Zyklus 203, DIN/ISO: G203)
204 RUECKWAERTS-SENKEN Mit automatischer Vorpositionierung, 2. Sicherheits-Abstand |  | RUECKWAERTS-SENKEN (Zyklus 204, DIN/ISO: G204)
205 UNIVERSAL-TIEFBOHREN Mit automatischer Vorpositionierung, 2. Sicherheits-Abstand, Spanbruch, Vorhalteabstand |  | UNIVERSAL-TIEFBOHREN (Zyklus 205, DIN/ISO: G205)
208 BOHRFRAESEN Mit automatischer Vorpositionierung, 2. Sicherheits-Abstand |  | BOHRFRAESEN (Zyklus 208)
241 EINLIPPEN-BOHREN Mit automatischer Vorpositionierung auf vertieften Startpunkt, Drehzahl- Kühlmitteldefinition |  | EINLIPPEN-BOHREN (Zyklus 241, DIN/ISO: G241)


ZENTRIEREN (Zyklus 240, DIN/ISO: G240)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Das Werkzeug zentriert mit dem programmierten Vorschub F bis auf den eingegebenen Zentrierdurchmesser, bzw. auf die eingegebene Zentriertiefe
  3. Falls definiert, verweilt das Werkzeug am Zentriergrund
  4. Abschließend fährt das Werkzeug mit FMAX auf Sicherheits-Abstand oder – falls eingegeben – auf den 2. Sicherheits-Abstand


Beim Programmieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Q344 (Durchmesser), bzw. Q201 (Tiefe) legt die Arbeitsrichtung fest. Wenn Sie den Durchmesser oder die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebenem Durchmesser bzw. bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
10 L Z+100 R0 FMAX
11 CYCL DEF 240 zentrieren
Q200=2 ;sicherheits-abst.
Q343=1 ;auswahl durchm./tiefe
Q201=+0 ;tiefe
Q344=-9 ;durchmesser
Q206=250 ;vorschub tiefenz.
Q211=0.1 ;verweilzeit unten
Q203=+20 ;koor. oberflaeche
Q204=100 ;2. sicherheits-abst.
12 CYCL CALL pos x+30 y+20 z+0 fmax m3
13 CYCL CALL pos x+80 y+50 z+0 fmax

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche; Wert positiv eingeben. Eingabebereich 0 bis 99999,9999 alternativ PREDEF

Auswahl Durchmesser/Tiefe (1/0) Q343: Auswahl, ob auf eingegebenen Durchmesser oder auf eingegebene Tiefe zentriert werden soll. Wenn die TNC auf den eingegebenen Durchmesser zentrieren soll, müssen Sie den Spitzenwinkel des Werkzeugs in der Spalte T-angle der Werkzeug-Tabelle TOOL.T definieren. 0: Auf eingegebene Tiefe zentrieren 1: Auf eingegebenen Durchmesser zentrieren

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Zentriergrund (Spitze des Zentrierkegels). Nur wirksam, wenn Q343=0 definiert ist. Eingabebereich -99999,9999 bis 99999,9999

Durchmesser (Vorzeichen) Q344: Zentrierdurchmesser. Nur wirksam, wenn Q343=1 definiert ist. Eingabebereich -99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Zentrieren in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Verweilzeit unten Q211: Zeit in Sekunden, die das Werkzeug am Bohrungsgrund verweilt. Eingabebereich 0 bis 3600,0000 alternativ PREDEF

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ PREDEF


BOHREN (Zyklus 200)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Das Werkzeug bohrt mit dem programmierten Vorschub F bis zur ersten Zustell-Tiefe
  3. Die TNC fährt das Werkzeug mit FMAX auf den Sicherheits-Abstand zurück, verweilt dort - falls eingegeben - und fährt anschließend wieder mit FMAX bis auf Sicherheits-Abstand über die erste Zustell-Tiefe
  4. Anschließend bohrt das Werkzeug mit eingegebenem Vorschub F um eine weitere Zustell-Tiefe
  5. Die TNC wiederholt diesen Ablauf (2 bis 4), bis die eingegebene Bohrtiefe erreicht ist
  6. Vom Bohrungsgrund fährt das Werkzeug mit FMAX auf Sicherheits-Abstand oder – falls eingegeben – auf den 2. Sicherheits-Abstand


Beim Programmieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
11 CYCL DEF 200 BOHREN
Q200=2 ;sicherheits-abst.
Q201=-15 ;tiefe
Q206=250 ;vorschub tiefenz.
Q202=5 ;zustell-tiefe
Q210=0 ;verweilzeit oben
Q203=+20 ;koor. oberflaeche
Q204=100 ;2. sicherheits-abst.
Q211=0.1 ;verweilzeit unten
Q395=0 ;Bezug Tiefe
12 L X+30 Y+20 FMAX M3 M99
14 L X+80 Y+50 FMAX M99

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche; Wert positiv eingeben. Eingabebereich 0 bis 99999,9999 alternativ PREDEF

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Bohrungsgrund (Spitze des Bohrkegels). Eingabebereich -99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Bohren in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird. Eingabebereich 0 bis 99999,9999. Die Tiefe muss kein Vielfaches der Zustell-Tiefe sein. Die TNC fährt in einem Arbeitsgang auf die Tiefe wenn:

  • Zustell-Tiefe und Tiefe gleich sind
  • die Zustell-Tiefe größer als die Tiefe ist

Verweilzeit oben Q210: Zeit in Sekunden, die das Werkzeug auf dem Sicherheits-Abstand verweilt, nachdem es die TNC zum Entspanen aus der Bohrung herausgefahren hat. Eingabebereich 0 bis 3600,0000 alternativ PREDEF

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ PREDEF

Verweilzeit unten Q211: Zeit in Sekunden, die das Werkzeug am Bohrungsgrund verweilt. Eingabebereich 0 bis 3600,0000 alternativ PREDEF

Bezug Tiefe Q395: Auswahl, ob sich die eingegebene Tiefe auf die Werkzeugspitze oder auf den zylindrischen Teil des Werkzeugs bezieht. Wenn die TNC die Tiefe auf den zylindrischen Teil des Werkzeugs beziehen soll, müssen Sie den Spitzenwinkel des Werkzeugs in der Spalte T-ANGLE der Werkzeug-Tabelle TOOL.T definieren. 0 = Tiefe bezogen auf die Werkzeugspitze 1 = Tiefe bezogen auf den zylindrischen Teil des Werkzeugs


REIBEN (Zyklus 201, DIN/ISO: G201)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Das Werkzeug reibt mit dem eingegebenen Vorschub F bis zur programmierten Tiefe
  3. Am Bohrungsgrund verweilt das Werkzeug, falls eingegeben
  4. Anschließend fährt die TNC das Werkzeug im Vorschub F zurück auf den Sicherheits-Abstand und von dort – falls eingegeben – mit FMAX auf den 2. Sicherheits-Abstand


Zyklusparameter

Beispiel: NC-Sätze
11 CYCL DEF 201 REIBEN
Q200=2 ;sicherheits-abst.
Q201=-15 ;tiefe
Q206=100 ;vorschub tiefenz.
Q211=0.5 ;verweilzeit unten
Q208=250 ;vorschub rueckzug
Q203=+20 ;koor. oberflaeche
Q204=100 ;2. sicherheits-abst.
12 L X+30 Y+20 FMAX M3
13 CYCL CALL
14 L X+80 Y+50 FMAX M9
15 L Z+100 FMAX M2

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ PREDEF

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Bohrungsgrund. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Reiben in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Verweilzeit unten Q211: Zeit in Sekunden, die das Werkzeug am Bohrungsgrund verweilt. Eingabebereich 0 bis 3600,0000 alternativ PREDEF

Vorschub Rückzug Q208: Verfahrgeschwindigkeit des Werkzeugs beim Herausfahren aus der Bohrung in mm/min. Wenn Sie Q208 = 0 eingeben, dann gilt Vorschub Reiben. Eingabebereich 0 bis 99999,999

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ PREDEF


AUSDREHEN (Zyklus 202, DIN/ISO: G202)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Das Werkzeug bohrt mit dem Bohrvorschub bis zur Tiefe
  3. Am Bohrungsgrund verweilt das Werkzeug – falls eingegeben – mit laufender Spindel zum Freischneiden
  4. Anschließend führt die TNC eine Spindel-Orientierung auf die Position durch, die im Parameter Q336 definiert ist
  5. Falls Freifahren gewählt ist, fährt die TNC in der eingegebenen Richtung 0,2 mm (fester Wert) frei
  6. Anschließend fährt die TNC das Werkzeug im Vorschub Rückzug auf den Sicherheits-Abstand und von dort – falls eingegeben – mit FMAX auf den 2. Sicherheits-Abstand. Wenn Q214=0 erfolgt der Rückzug an der Bohrungswand


Beim Programmieren beachten!

Maschine und TNC müssen vom Maschinenhersteller vorbereitet sein.

Zyklus nur an Maschinen mit geregelter Spindel verwendbar.

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Die TNC stellt am Zyklus-Ende den Kühlmittel- und Spindelzustand wieder her, der vor dem Zyklus-Aufruf aktiv war.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Wählen Sie die Freifahr-Richtung so, dass das Werkzeug vom Bohrungsrand wegfährt.

Überprüfen Sie, wo die Werkzeug-Spitze steht, wenn Sie eine Spindel-Orientierung auf den Winkel programmieren, den Sie im Q336 eingeben (z.B. in der Betriebsart Positionieren mit Handeingabe). Wählen Sie den Winkel so, dass die Werkzeug-Spitze parallel zu einer Koordinaten-Achse steht.

Die TNC berücksichtigt beim Freifahren eine aktive Drehung des Koordinatensystems automatisch.

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ PREDEF

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Bohrungsgrund. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Ausdrehen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Verweilzeit unten Q211: Zeit in Sekunden, in der das Werkzeug am Bohrungsgrund verweilt. Eingabebereich 0 bis 3600,0000 alternativ PREDEF

Vorschub Rückzug Q208: Verfahrgeschwindigkeit des Werkzeugs beim Herausfahren aus der Bohrung in mm/min. Wenn Sie Q208=0 eingeben, dann gilt Vorschub Tiefenzustellung. Eingabebereich 0 bis 99999,999 alternativ Fmax, FAUTO, predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,999 alternativ PREDEF
Beispiel:
10 L Z+100 R0 FMAX
11 CYCL DEF 202 AUSDREHEN
Q200=2 ;sicherheits-abst.
Q201=-15 ;tiefe
Q206=100 ;vorschub tiefenz.
Q211=0.5 ;verweilzeit unten
Q208=250 ;vorschub rueckzug
Q203=+20 ;koor. oberflaeche
Q204=100 ;2. sicherheits-abst.
Q214=1 ;freifahr-richtung
Q336=0 ;winkel spindel
12 L X+30 Y+20 FMAX M3
13 CYCL CALL
14 L X+80 Y+50 FMAX M99

Freifahr-Richtung (0/1/2/3/4) Q214: Richtung festlegen, in der die TNC das Werkzeug am Bohrungsgrund freifährt (nach der Spindel-Orientierung)

0 | Werkzeug nicht freifahren
1 | Werkzeug freifahren in Minus-Richtung der Hauptachse
2 | Werkzeug freifahren in Minus-Richtung der Nebenachse
3 | Werkzeug freifahren in Plus-Richtung der Hauptachse
4 | Werkzeug freifahren in Plus-Richtung der Nebenachse

Winkel für Spindel-Orientierung Q336 (absolut): Winkel, auf den die TNC das Werkzeug vor dem Freifahren positioniert. Eingabebereich ‑360,000 bis 360,000


UNIVERSAL-BOHREN (Zyklus 203, DIN/ISO: G203)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Das Werkzeug bohrt mit dem eingegebenen Vorschub F bis zur ersten Zustell-Tiefe
  3. Falls Spanbruch eingegeben, fährt die TNC das Werkzeug um den eingegebenen Rückzugswert zurück. Wenn Sie ohne Spanbruch arbeiten, dann fährt die TNC das Werkzeug mit dem Vorschub Rückzug auf den Sicherheits-Abstand zurück, verweilt dort – falls eingegeben – und fährt anschließend wieder mit FMAX bis auf Sicherheits-Abstand über die erste Zustell-Tiefe
  4. Anschließend bohrt das Werkzeug mit Vorschub um eine weitere Zustell-Tiefe. Die Zustell-Tiefe verringert sich mit jeder Zustellung um den Abnahmebetrag – falls eingegeben
  5. Die TNC wiederholt diesen Ablauf (2-4), bis die Bohrtiefe erreicht ist
  6. Am Bohrungsgrund verweilt das Werkzeug – falls eingegeben – zum Freischneiden und wird nach der Verweilzeit mit dem Vorschub Rückzug auf den Sicherheits-Abstand zurückgezogen. Falls Sie einen 2. Sicherheits-Abstand eingegeben haben, fährt die TNC das Werkzeug mit FMAX dorthin


Zyklusparameter

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Bohrungsgrund (Spitze des Bohrkegels). Eingabebereich -99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Bohren in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird. Eingabebereich 0 bis 99999,9999. Die Tiefe muss kein Vielfaches der Zustell-Tiefe sein. Die TNC fährt in einem Arbeitsgang auf die Tiefe wenn:

  • Zustell-Tiefe und Tiefe gleich sind
  • die Zustell-Tiefe größer als die Tiefe und gleichzeitig kein Spanbruch definiert ist

Verweilzeit oben Q210: Zeit in Sekunden, die das Werkzeug auf Sicherheits-Abstand verweilt, nachdem es die TNC zum Entspanen aus der Bohrung herausgefahren hat. Eingabebereich 0 bis 3600,0000 alternativ predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Abnahmebetrag Q212 (inkremental): Wert, um den die TNC die Zustell-Tiefe Q202 nach jeder Zustellung verkleinert. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
11 CYCL DEF 203 UNIVERSAL-BOHREN
Q200=2 ;sicherheits-abst.
Q201=-20 ;tiefe
Q206=150 ;vorschub tiefenz.
Q202=5 ;zustell-tiefe
Q210=0 ;verweilzeit oben
Q203=+20 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q212=0.2 ;abnahmebetrag
Q213=3 ;spanbrueche
Q205=3 ;min. zustell-tiefe
Q211=0.25 ;verweilzeit unten
Q208=500 ;vorschub rueckzug
Q256=0.2 ;rz bei spanbruch
Q395=0 ;Bezug Tiefe

Anz. Spanbrüche bis Rückzug Q213: Anzahl der Spanbrüche bevor die TNC das Werkzeug aus der Bohrung zum Entspanen herausfahren soll. Zum Spanbrechen zieht die TNC das Werkzeug jeweils um den Rückzugswert Q256 zurück. Eingabebereich 0 bis 99999

Minimale Zustell-Tiefe Q205 (inkremental): Falls Sie einen Abnahmebetrag eingegeben haben, begrenzt die TNC die Zustellung auf den mit Q205 eingegeben Wert. Eingabebereich 0 bis 99999,9999

Verweilzeit unten Q211: Zeit in Sekunden, die das Werkzeug am Bohrungsgrund verweilt. Eingabebereich 0 bis 3600,0000 alternativ predef

Vorschub Rückzug Q208: Verfahrgeschwindigkeit des Werkzeugs beim Herausfahren aus der Bohrung in mm/min. Wenn Sie Q208=0 eingeben, dann fährt die TNC das Werkzeug mit Vorschub Q206 heraus. Eingabebereich 0 bis 99999,999 alternativ Fmax, FAUTO, predef

Rückzug bei Spanbruch Q256 (inkremental): Wert, um die die TNC das Werkzeug beim Spanbrechen zurückfährt. Eingabebereich 0,1000 bis 99999,9999 alternativ predef

Bezug Tiefe Q395: Auswahl, ob sich die eingegebene Tiefe auf die Werkzeugspitze oder auf den zylindrischen Teil des Werkzeugs bezieht. Wenn die TNC die Tiefe auf den zylindrischen Teil des Werkzeugs beziehen soll, müssen Sie den Spitzenwinkel des Werkzeugs in der Spalte T-ANGLE der Werkzeug-Tabelle TOOL.T definieren. 0 = Tiefe bezogen auf die Werkzeugspitze 1 = Tiefe bezogen auf den zylindrischen Teil des Werkzeugs


RUECKWAERTS-SENKEN (Zyklus 204, DIN/ISO: G204)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit diesem Zyklus stellen Sie Senkungen her, die sich auf der Werkstück-Unterseite befinden.

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Dort führt die TNC eine Spindel-Orientierung auf die 0°-Position durch und versetzt das Werkzeug um das Exzentermaß
  3. Anschließend taucht das Werkzeug mit dem Vorschub Vorpositionieren in die vorgebohrte Bohrung ein, bis die Schneide im Sicherheits-Abstand unterhalb der Werkstück-Unterkante steht
  4. Die TNC fährt jetzt das Werkzeug wieder auf Bohrungsmitte, schaltet die Spindel und ggf. das Kühlmittel ein und fährt dann mit dem Vorschub Senken auf die eingegebene Tiefe Senkung
  5. Falls eingegeben, verweilt das Werkzeug am Senkungsgrund und fährt anschließend wieder aus der Bohrung heraus, führt eine Spindelorientierung durch und versetzt erneut um das Exzentermaß
  6. Anschließend fährt die TNC das Werkzeug im Vorschub Vorpositionieren auf den Sicherheits-Abstand und von dort – falls eingegeben – mit FMAX auf den 2. Sicherheits-Abstand.


Beim Programmieren beachten!

Maschine und TNC müssen vom Maschinenhersteller vorbereitet sein.

Zyklus nur an Maschinen mit geregelter Spindel verwendbar.

Zyklus arbeitet nur mit Rückwärtsbohrstangen.

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung beim Senken fest. Achtung: Positives Vorzeichen senkt in Richtung der positiven Spindelachse.

Werkzeug-Länge so eingeben, dass nicht die Schneide, sondern die Unterkante der Bohrstange vermaßt ist.

Die TNC berücksichtigt bei der Berechnung des Startpunktes der Senkung die Schneidenlänge der Bohrstange und die Materialstärke.

Zyklus 204 können Sie auch mit M04 abarbeiten, wenn Sie vor dem Zyklus-Aufruf anstelle M03 das M04 programmiert haben.

Achtung Kollisionsgefahr!

Überprüfen Sie, wo die Werkzeug-Spitze steht, wenn Sie eine Spindel-Orientierung auf den Winkel programmieren, den Sie im Q336 eingeben (z.B. in der Betriebsart Positionieren mit Handeingabe). Wählen Sie den Winkel so, dass die Werkzeug-Spitze parallel zu einer Koordinaten-Achse steht. Wählen Sie die Freifahr-Richtung so, dass das Werkzeug vom Bohrungsrand wegfährt.


Zyklusparameter

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Tiefe Senkung Q249 (inkremental): Abstand Werkstück-Unterkante – Senkungsgrund. Positives Vorzeichen stellt die Senkung in positiver Richtung der Spindelachse her. Eingabebereich -99999,9999 bis 99999,9999

Materialstärke Q250 (inkremental): Dicke des Werkstücks. Eingabebereich 0,0001 bis 99999,9999

Exzentermaß Q251 (inkremental): Exzentermaß der Bohrstange; aus Werkzeug-Datenblatt entnehmen. Eingabebereich 0,0001 bis 99999,9999

Schneidenhöhe Q252 (inkremental): Abstand Unterkante Bohrstange – Hauptschneide; aus Werkzeug-Datenblatt entnehmen. Eingabebereich 0,0001 bis 99999,9999

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Eintauchen in das Werkstück bzw. beim Herausfahren aus dem Werkstück in mm/min. Eingabebereich 0 bis 99999,999 alternativ Fmax, FAUTO, predef

Vorschub Senken Q254: Verfahrgeschwindigkeit des Werkzeugs beim Senken in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, FU

Verweilzeit Q255: Verweilzeit in Sekunden am Senkungsgrund. Eingabebereich 0 bis 3600,000

Beispiel: NC-Sätze
11 CYCL DEF 204 RUECKWAERTS-SENKEN
Q200=2 ;sicherheits-abst.
Q249=+5 ;tiefe senkung
Q250=20 ;materialstaerke
Q251=3.5 ;exzentermass
Q252=15 ;schneidenhoehe
Q253=750 ;vorschub vorpos.
Q254=200 ;vorschub senken
Q255=0 ;verweilzeit
Q203=+20 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q214=1 ;freifahr-richtung
Q336=0 ;winkel spindel

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999 alternativ predef

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999

Freifahr-Richtung (0/1/2/3/4) Q214: Richtung festlegen, in der die TNC das Werkzeug um das Exzentermaß versetzen soll (nach der Spindel-Orientierung); Eingabe von 0 nicht erlaubt

1 | Werkzeug freifahren in Minus-Richtung der Hauptachse
2 | Werkzeug freifahren in Minus-Richtung der Nebenachse
3 | Werkzeug freifahren in Plus-Richtung der Hauptachse
4 | Werkzeug freifahren in Plus-Richtung der Nebenachse

Winkel für Spindel-Orientierung Q336 (absolut): Winkel, auf den die TNC das Werkzeug vor dem Eintauchen und vor dem Herausfahren aus der Bohrung positioniert. Eingabebereich -360,0000 bis 360,0000


UNIVERSAL-TIEFBOHREN (Zyklus 205, DIN/ISO: G205)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Wenn ein vertiefter Startpunkt eingegeben, fährt die TNC mit dem definierten Positioniervorschub auf den Sicherheits-Abstand über den vertieften Startpunkt
  3. Das Werkzeug bohrt mit dem eingegebenen Vorschub F bis zur ersten Zustell-Tiefe
  4. Falls Spanbruch eingegeben, fährt die TNC das Werkzeug um den eingegebenen Rückzugswert zurück. Wenn Sie ohne Spanbruch arbeiten, dann fährt die TNC das Werkzeug im Eilgang auf den Sicherheits-Abstand zurück und anschließend wieder mit FMAX bis auf den eingegebenen Vorhalteabstand über die erste Zustell-Tiefe
  5. Anschließend bohrt das Werkzeug mit Vorschub um eine weitere Zustell-Tiefe. Die Zustell-Tiefe verringert sich mit jeder Zustellung um den Abnahmebetrag – falls eingegeben
  6. Die TNC wiederholt diesen Ablauf (2-4), bis die Bohrtiefe erreicht ist
  7. Am Bohrungsgrund verweilt das Werkzeug – falls eingegeben – zum Freischneiden und wird nach der Verweilzeit mit dem Vorschub Rückzug auf den Sicherheits-Abstand zurückgezogen. Falls Sie einen 2. Sicherheits-Abstand eingegeben haben, fährt die TNC das Werkzeug mit FMAX dorthin


Beim Programmieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Wenn Sie die Vorhalteabstände Q258 ungleich Q259 eingeben, dann verändert die TNC den Vorhalteabstand zwischen der ersten und letzten Zustellung gleichmäßig.

Wenn Sie über Q379 einen vertieften Startpunkt eingeben, dann verändert die TNC lediglich den Startpunkt der Zustell-Bewegung. Rückzugsbewegung werden von der TNC nicht verändert, beziehen sich also auf die Koordinate der Werkstück-Oberfläche.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Bohrungsgrund (Spitze des Bohrkegels). Eingabebereich -99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Bohren in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird. Eingabebereich 0 bis 99999,9999. Die Tiefe muss kein Vielfaches der Zustell-Tiefe sein. Die TNC fährt in einem Arbeitsgang auf die Tiefe wenn:

  • Zustell-Tiefe und Tiefe gleich sind
  • die Zustell-Tiefe größer als die Tiefe ist

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Abnahmebetrag Q212 (inkremental): Wert, um den die TNC die Zustell-Tiefe Q202 verkleinert. Eingabebereich 0 bis 99999,9999

Minimale Zustell-Tiefe Q205 (inkremental): Falls Sie einen Abnahmebetrag eingegeben haben, begrenzt die TNC die Zustellung auf den mit Q205 eingegeben Wert. Eingabebereich 0 bis 99999,9999

Vorhalteabstand oben Q258 (inkremental): Sicherheits-Abstand für Eilgang-Positionierung, wenn die TNC das Werkzeug nach einem Rückzug aus der Bohrung wieder auf die aktuelle Zustell-Tiefe fährt; Wert bei erster Zustellung. Eingabebereich 0 bis 99999,9999

Vorhalteabstand unten Q259 (inkremental): Sicherheits-Abstand für Eilgang-Positionierung, wenn die TNC das Werkzeug nach einem Rückzug aus der Bohrung wieder auf die aktuelle Zustell-Tiefe fährt; Wert bei letzter Zustellung. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
11 CYCL DEF 205 UNIVERSAL-TIEFBOHREN
Q200=2 ;sicherheits-abst.
Q201=-80 ;tiefe
Q206=150 ;vorschub tiefenz.
Q202=15 ;zustell-tiefe
Q203=+100 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q212=0.5 ;abnahebetrag
Q205=3 ;min. zustell-tiefe
Q258=0.5 ;vorhalteabstand oben
Q259=1 ;vorhalteabst. unten
Q257=5 ;bohrtiefe spanbruch
Q256=0.2 ;rz bei spanbruch
Q211=0.25 ;verweilzeit unten
Q379=7.5 ;startpunkt
Q253=750 ;vorschub vorpos.
Q208=99999 ;Vorschub Rueckzug
Q395=0 ;Bezug Tiefe

Bohrtiefe bis Spanbruch Q257 (inkremental): Zustellung, nach der die TNC einen Spanbruch durchführt. Kein Spanbruch, wenn 0 eingegeben. Eingabebereich 0 bis 99999,9999

Rückzug bei Spanbruch Q256 (inkremental): Wert, um die die TNC das Werkzeug beim Spanbrechen zurückfährt. Die TNC fährt den Rückzug mit einem Vorschub von 3000 mm/min. Eingabebereich 0,1000 bis 99999,9999 alternativ predef

Verweilzeit unten Q211: Zeit in Sekunden, die das Werkzeug am Bohrungsgrund verweilt. Eingabebereich 0 bis 3600,0000 alternativ predef

Vertiefter Startpunkt Q379 (inkremental bezogen auf die Werkstück-Oberfläche): Startpunkt der eigentlichen Bohrbearbeitung, wenn bereits mit einem kürzeren Werkzeug auf eine bestimmte Tiefe vorgebohrt wurde. Die TNC fährt im Vorschub Vorpositionieren vom Sicherheits-Abstand auf den vertieften Startpunkt. Eingabebereich 0 bis 99999,9999

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Positionieren vom Sicherheits-Abstand auf einen vertieften Startpunkt in mm/min. Wirkt nur, wenn Q379 ungleich 0 eingegeben ist. Eingabebereich 0 bis 99999,999 alternativ Fmax, FAUTO, predef

Vorschub Rückzug Q208: Verfahrgeschwindigkeit des Werkzeugs beim Herausfahren nach der Bearbeitung in mm/min. Wenn Sie Q208=0 eingeben, dann fährt die TNC das Werkzeug mit Vorschub Q207 heraus. Eingabebereich 0 bis 99999,999 alternativ Fmax, FAUTO, predef

Bezug Tiefe Q395: Auswahl, ob sich die eingegebene Tiefe auf die Werkzeugspitze oder auf den zylindrischen Teil des Werkzeugs bezieht. Wenn die TNC die Tiefe auf den zylindrischen Teil des Werkzeugs beziehen soll, müssen Sie den Spitzenwinkel des Werkzeugs in der Spalte T-ANGLE der Werkzeug-Tabelle TOOL.T definieren. 0 = Tiefe bezogen auf die Werkzeugspitze 1 = Tiefe bezogen auf den zylindrischen Teil des Werkzeugs


BOHRFRAESEN (Zyklus 208)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche und fährt den eingegebenen Durchmesser auf einem Rundungskreis an (wenn Platz vorhanden ist)
  2. Das Werkzeug fräst mit dem eingegebenen Vorschub F in einer Schraubenlinie bis zur eingegebenen Bohrtiefe
  3. Wenn die Bohrtiefe erreicht ist, fährt die TNC nochmals einen Vollkreis, um das beim Eintauchen stehengelassene Material zu entfernen
  4. Danach positioniert die TNC das Werkzeug wieder zurück in die Bohrungsmitte
  5. Abschließend fährt die TNC mit FMAX zurück auf den Sicherheits-Abstand. Falls Sie einen 2. Sicherheits-Abstand eingegeben haben, fährt die TNC das Werkzeug mit FMAX dorthin


Beim Programmieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Wenn Sie den Bohrungs-Durchmesser gleich dem Werkzeug-Durchmesser eingegeben haben, bohrt die TNC ohne Schraubenlinien-Interpolation direkt auf die eingegebene Tiefe.

Eine aktive Spiegelung beeinflusst nicht die im Zyklus definierte Fräsart.

Beachten Sie, dass Ihr Werkzeug bei zu großer Zustellung sowohl sich selbst als auch das Werkstück beschädigt.

Um die Eingabe zu großer Zustellungen zu vermeiden, geben Sie in der Werkzeug-Tabelle TOOL.T in der Spalte ANGLE den maximal möglichen Eintauchwinkel des Werkzeugs an. Die TNC berechnet dann automatisch die maximal erlaubte Zustellung und ändert ggf. Ihren eingegebenen Wert ab.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
12 CYCL DEF 208 BOHRFRAESEN
Q200=2 ;sicherheits-abst.
Q201=-80 ;tiefe
Q206=150 ;vorschub tiefenz.
Q334=1.5 ;zustell-tiefe
Q203=+100 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q335=25 ;soll-durchmesser
Q342=0 ;vorgeb. durchmesser
Q351=+1 ;fraesart

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeug-Unterkante – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Bohrungsgrund. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Bohren auf der Schraubenlinie in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, FU, FZ

Zustellung pro Schraubenlinie Q334 (inkremental): Maß, um welches das Werkzeug auf einer Schraubenlinie (=360°) jeweils zugestellt wird. Eingabebereich 0 bis 99999,9999

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Soll-Durchmesser Q335 (absolut): Bohrungs-Durchmesser. Wenn Sie den Soll-Durchmesser gleich dem Werkzeug-Durchmesser eingeben, dann bohrt die TNC ohne Schraubenlinien-Interpolation direkt auf die eingegebene Tiefe. Eingabebereich 0 bis 99999,9999

Vorgebohrter Durchmesser Q342 (absolut): Sobald Sie in Q342 einen Wert größer 0 eingeben, führt die TNC keine Überprüfung bzgl. des Durchmesser-Verhältnisses Soll- zu Werkzeug-Durchmesser mehr durch. Dadurch können Sie Bohrungen ausfräsen, deren Durchmesser mehr als doppelt so groß sind wie der Werkzeug-Durchmesser. Eingabebereich 0 bis 99999,9999

Fräsart Q351: Art der Fräsbearbeitung bei M3 +1 = Gleichlauffräsen –1 = Gegenlauffräsen PREDEF = Standardwert aus global def verwenden


EINLIPPEN-BOHREN (Zyklus 241, DIN/ISO: G241)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Danach fährt die TNC das Werkzeug mit dem definierten Positioniervorschub auf den Sicherheits-Abstand über den vertieften Startpunkt und schaltet dort die Bohrdrehzahl mit M3 und das Kühlmittel ein. Die Einfahrbewegung wird je nach der im Zyklus definierten Drehrichtung, mit rechtsdrehender, linksdrehender oder stehender Spindel ausgeführt
  3. Das Werkzeug bohrt mit dem eingegebenen Vorschub F bis zur eingegebenen Bohrtiefe oder, wenn definiert, bis zur eingegebenen Verweiltiefe.
  4. Am Bohrungsgrund verweilt das Werkzeug – falls eingegeben – zum Freischneiden. Anschließend schaltet die TNC das Kühlmittel aus und die Drehzahl wieder auf den definierten Ausfahrwert zurück
  5. Am Bohrungsgrund wird nach der Verweilzeit mit dem Vorschub Rückzug auf den Sicherheits-Abstand zurückgezogen. Falls Sie einen 2. Sicherheits-Abstand eingegeben haben, fährt die TNC das Werkzeug mit FMAX dorthin


Beim Programmieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!


Zyklusparameter

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Bohrungsgrund. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Bohren in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Verweilzeit unten Q211: Zeit in Sekunden, die das Werkzeug am Bohrungsgrund verweilt. Eingabebereich 0 bis 3600,0000 alternativ predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Vertiefter Startpunkt Q379 (inkremental bezogen auf die Werkstück-Oberfläche): Startpunkt der eigentlichen Bohrbearbeitung. Die TNC fährt im Vorschub Vorpositionieren vom Sicherheits-Abstand auf den vertieften Startpunkt. Eingabebereich 0 bis 99999,9999

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Positionieren vom Sicherheits-Abstand auf den vertieften Startpunkt in mm/min. Wirkt nur, wenn Q379 ungleich 0 eingegeben ist. Eingabebereich 0 bis 99999,999 alternativ Fmax, FAUTO, predef

Vorschub Rückzug Q208: Verfahrgeschwindigkeit des Werkzeugs beim Herausfahren aus der Bohrung in mm/min. Wenn Sie Q208=0 eingeben, dann fährt die TNC das Werkzeug mit Bohrvorschub Q206 heraus. Eingabebereich 0 bis 99999,999 alternativ Fmax, FAUTO, predef
Beispiel: NC-Sätze
11 CYCL DEF 241 einlippen-BOHREN
Q200=2 ;sicherheits-abst.
Q201=-80 ;tiefe
Q206=150 ;vorschub tiefenz.
Q211=0.25 ;verweilzeit unten
Q203=+100 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q379=7.5 ;startpunkt
Q253=750 ;vorschub vorpos.
Q208=1000 ;vorschub rueckzug
Q426=3 ;sp.-drehrichtung
Q427=25 ;drehzahl ein-/ausf.
Q428=500 ;drehzahl bohren
Q429=8 ;kuehlung ein
Q430=9 ;kuehlung aus
Q435=0 ;VERWEILTIEFE

Drehr. ein-/ausfahren (3/4/5) Q426: Drehrichtung, in die das Werkzeug beim Einfahren in die Bohrung und beim Herausfahren aus der Bohrung drehen soll. Eingabebereich: 3: Spindel mit M3 drehen 4: Spindel mit M4 drehen 5: Mit stehender Spindel fahren

Spindeldrehzahl ein-/ausfahren Q427: Drehzahl, mit der das Werkzeug beim Einfahren in die Bohrung und beim Herausfahren aus der Bohrung drehen soll. Eingabebereich 0 bis 99999

Drehzahl Bohren Q428: Drehzahl, mit der das Werkzeug bohren soll. Eingabebereich 0 bis 99999

M-Fkt. Kühlmittel EIN Q429: Zusatz-Funktion M zum Einschalten des Kühlmittels. Die TNC schaltet das Kühlmittel ein, wenn das Werkzeug in der Bohrung auf dem vertieften Startpunkt steht. Eingabebereich 0 bis 999

M-Fkt. Kühlmittel AUS Q430: Zusatz-Funktion M zum Ausschalten des Kühlmittels. Die TNC schaltet das Kühlmittel aus, wenn das Werkzeug auf der Bohrtiefe steht. Eingabebereich 0 bis 999

Verweiltiefe Q435 (inkremental): Koordinate Spindelachse, auf der das Werkzeug verweilen soll. Funktion ist nicht aktiv bei Eingabe von 0 (Standardeinstellung). Anwendung: Bei der Herstellung von Durchgangsbohrungen, erfordern manche Werkzeuge eine kurze Verweilzeit vor dem Austritt am Bohrungsgrund, um die Späne nach oben zu transportieren. Wert kleiner als Bohrtiefe Q201 definieren, Eingabebereich 0 bis 99999,9999


Programmierbeispiele

Weitere Informationen:
> Beispiel: Bohrzyklen
> Beispiel: Bohrzyklen in Verbindung mit PATTERN DEF verwenden


Beispiel: Bohrzyklen

0 BEGIN PGM C200 MM |
1 BLK FORM 0.1 Z X+0 Y+0 Z-20 | Rohteil-Definition
2 BLK FORM 0.2 X+100 Y+100 Z+0 |
3 TOOL CALL 1 Z S4500 | Werkzeug-Aufruf (Werkzeug-Radius 3)
4 L Z+250 R0 FMAX | Werkzeug freifahren
5 CYCL DEF 200 BOHREN | Zyklus-Definition
Q200=2 ;sicherheits-abst. |
Q201=-15 ;tiefe |
Q206=250 ;f tiefenzust. |
Q202=5 ;zustell-tiefe |
Q210=0 ;F.-zeit oben |
Q203=-10 ;koor. oberfl. |
Q204=20 ;2. s.-abstand |
Q211=0.2 ;verweilzeit unten |
Q395=0 ;BEZUG TIEFE |
6 L X+10 Y+10 R0 FMAX M3 | Bohrung 1 anfahren, Spindel einschalten
7 CYCL CALL | Zyklus-Aufruf
8 L Y+90 R0 FMAX M99 | Bohrung 2 anfahren, Zyklus-Aufruf
9 L X+90 R0 FMAX M99 | Bohrung 3 anfahren, Zyklus-Aufruf
10 L Y+10 R0 FMAX M99 | Bohrung 4 anfahren, Zyklus-Aufruf
11 L Z+250 R0 FMAX M2 | Werkzeug freifahren, Programm-Ende
12 END PGM C200 MM |


Beispiel: Bohrzyklen in Verbindung mit PATTERN DEF verwenden

    Die Bohrungskoordinaten sind in der Musterdefintion Pattern def pos gespeichert und werden von der TNC mit CYCL CALL PAT gerufen. Die Werkzeug-Radien sind so gewählt, dass alle Arbeitsschritte in der Testgrafik zu sehen sind. Programm-Ablauf

  • Zentrieren (Werkzeug-Radius 4)

  • Bohren (Werkzeug-Radius 2,4)

  • Gewindebohren (Werkzeug-Radius 3)

0 begin pgm 1 mm |
1 blk form 0.1 z x+0 y+0 z-20 | Rohteil-Definition
2 blk form 0.2 x+100 y+100 y+0 |
3 tool call 1 z s5000 | Werkzeug-Aufruf Zentrierer (Radius 4)
4 l z+10 R0 f5000 | Werkzeug auf sichere Höhe fahren (F mit Wert programmieren), die TNC positioniert nach jedem Zyklus auf die sichere Höhe
5 pattern def | Alle Bohrpositionen im Punktemuster definieren
pos1( x+10 y+10 z+0 ) |
pos2( x+40 y+30 z+0 ) |
pos3( x+20 y+55 z+0 ) |
pos4( x+10 y+90 z+0 ) |
pos5( x+90 y+90 z+0 ) |
pos6( x+80 y+65 z+0 ) |
pos7( x+80 y+30 z+0 ) |
pos8( x+90 y+10 z+0 ) |
6 cycl def 240 zentrieren | Zyklus-Definition Zentrieren
Q200=2 ;sicherheits-abst. |
Q343=0 ;auswahl durchm/tiefe |
Q201=-2 ;tiefe |
Q344=-10 ;durchmesser |
Q206=150 ;f tiefenzust. |
Q211=0 ;verweilzeit unten |
Q203=+0 ;koor. oberfl. |
Q204=50 ;2. sicherheits-abst. |
7 cycl call pat f5000 m13 | Zyklus-Aufruf in Verbindung mit Punktemuster
8 l z+100 r0 fmax | Werkzeug freifahren, Werkzeug-Wechsel
9 tool call 2 z s5000 | Werkzeug-Aufruf Bohrer (Radius 2,4)
10 l z+10 r0 f5000 | Werkzeug auf sichere Höhe fahren (F mit Wert programmieren)
11 cycl def 200 BOHREN | Zyklus-Definition Bohren
Q200=2 ;sicherheits-abst. |
Q201=-25 ;tiefe |
Q206=150 ;vorschub tiefenzust. |
Q202=5 ;zustell-tiefe |
Q210=0 ;verweilzeit oben |
Q203=+0 ;koor. oberfl. |
Q204=50 ;2. sicherheits-abst. |
Q211=0.2 ;verweilzeit unten |
Q395=0 ;BEZUG TIEFE |
12 cycl call pat f5000 m13 | Zyklus-Aufruf in Verbindung mit Punktemuster
13 l z+100 r0 fmax | Werkzeug freifahren
14 tool call 3 z s200 | Werkzeug-Aufruf Gewindebohrer (Radius 3)
15 l z+50 r0 fmax | Werkzeug auf sichere Höhe fahren
16 cycl def 206 gewindeBOHREN neu | Zyklus-Definition Gewindebohren
Q200=2 ;sicherheits-abst. |
Q201=-25 ;gewindetiefe |
Q206=150 ;vorschub tiefenzust. |
Q211=0 ;verweilzeit unten |
Q203=+0 ;koor. oberflaeche |
Q204=50 ;2. sicherheits-abst. |
17 cycl call pat f5000 m13 | Zyklus-Aufruf in Verbindung mit Punktemuster
18 l z+100 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
19 end pgm 1 mm |


Bearbeitungszyklen: Gewindebohren / Gewindefräsen

Weitere Informationen:
> Grundlagen
> GEWINDEBOHREN NEU mit Ausgleichsfutter (Zyklus 206, DIN/ISO: G206)
> GEWINDEBOHREN ohne Ausgleichsfutter GS NEU (Zyklus 207, DIN/ISO: G207)
> GEWINDEBOHREN SPANBRUCH (Zyklus 209, DIN/ISO: G209)
> Grundlagen zum Gewindefräsen
> GEWINDEFRAESEN (Zyklus 262, DIN/ISO: G262)
> SENKGEWINDEFRAESEN (Zyklus 263, DIN/ISO: G263)
> BOHRGEWINDEFRAESEN (Zyklus 264, DIN/ISO: G264)
> HELIX- BOHRGEWINDEFRAESEN (Zyklus 265, DIN/ISO: G265)
> AUSSENGEWINDE-FRAESEN (Zyklus 267, DIN/ISO: G267)
> Programmierbeispiele


Bearbeitungszyklen: Gewindebohren / Gewindefräsen

Grundlagen

Weitere Informationen:
> Übersicht


Übersicht

Die TNC stellt insgesamt 8 Zyklen für die verschiedensten Gewindebearbeitungen zur Verfügung:

Zyklus | Softkey | Seite
206 GEWINDEBOHREN NEU Mit Ausgleichsfutter, mit automatischer Vorpositionierung, 2. Sicherheits-Abstand |  | GEWINDEBOHREN NEU mit Ausgleichsfutter (Zyklus 206, DIN/ISO: G206)
207 GEWINDEBOHREN GS NEU Ohne Ausgleichsfutter, mit automatischer Vorpositionierung, 2. Sicherheits-Abstand |  | GEWINDEBOHREN ohne Ausgleichsfutter GS NEU (Zyklus 207, DIN/ISO: G207)
209 GEWINDEBOHREN SPANBRUCH Ohne Ausgleichsfutter, mit automatischer Vorpositionierung, 2. Sicherheits-Abstand; Spanbruch |  | GEWINDEBOHREN SPANBRUCH (Zyklus 209, DIN/ISO: G209)
262 GEWINDEFRAESEN Zyklus zum Fräsen eines Gewindes ins vorgebohrte Material |  | GEWINDEFRAESEN (Zyklus 262, DIN/ISO: G262)
263 SENKGEWINDEFRAESEN Zyklus zum Fräsen eines Gewindes ins vorgebohrte Material mit Herstellung einer Senkfase |  | SENKGEWINDEFRAESEN (Zyklus 263, DIN/ISO: G263)
264 BOHRGEWINDEFRAESEN Zyklus zum Bohren ins volle Material und anschließendem Fräsen des Gewindes mit einem Werkzeug |  | BOHRGEWINDEFRAESEN (Zyklus 264, DIN/ISO: G264)
265 HELIX-BOHRGEWINDEFRAESEN Zyklus zum Fräsen des Gewindes ins volle Material |  | HELIX- BOHRGEWINDEFRAESEN (Zyklus 265, DIN/ISO: G265)
267 AUSSENGEWINDE FRAESEN Zyklus zum Fräsen eines Aussengewindes mit Herstellung einer Senkfase |  | HELIX- BOHRGEWINDEFRAESEN (Zyklus 265, DIN/ISO: G265)


GEWINDEBOHREN NEU mit Ausgleichsfutter (Zyklus 206, DIN/ISO: G206)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Das Werkzeug fährt in einem Arbeitsgang auf die Bohrtiefe
  3. Danach wird die Spindeldrehrichtung umgekehrt und das Werkzeug nach der Verweilzeit auf den Sicherheits-Abstand zurückgezogen. Falls Sie einen 2. Sicherheits-Abstand eingegeben haben, fährt die TNC das Werkzeug mit FMAX dorthin
  4. Auf Sicherheits-Abstand wird die Spindeldrehrichtung erneut umgekehrt


Beim Programmieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Das Werkzeug muss in ein Längenausgleichsfutter gespannt sein. Das Längenausgleichsfutter kompensiert Toleranzen von Vorschub und Drehzahl während der Bearbeitung.

Während der Zyklus abgearbeitet wird, ist der Drehknopf für den Drehzahl-Override unwirksam. Der Drehknopf für den Vorschub-Override ist noch begrenzt aktiv (vom Maschinenhersteller festgelegt, Maschinenhandbuch beachten).

Für Rechtsgewinde Spindel mit M3 aktivieren, für Linksgewinde mit M4.

Wenn Sie in der Werkzeug-Tabelle in der Spalte PITCH die Gewindesteigung des Gewindebohrers eintragen, vergleicht die TNC die Gewindesteigung aus der Werkzeug-Tabelle, mit der im Zyklus definierten Gewindesteigung. Die TNC gibt eine Fehlermeldung aus, wenn die Werte nicht übereinstimmen. Im Zyklus 206 berechnet die TNC die Gewindesteigung anhand der programmierten Drehzahl und des im Zyklus definierten Vorschubs.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
25 CYCL DEF 206 GEWINDEBOHREN NEU
Q200=2 ;sicherheits-abst.
Q201=-20 ;tiefe
Q206=150 ;vorschub tiefenz.
Q211=0.25 ;verweilzeit unten
Q203=+25 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze (Startposition) – Werkstück-Oberfläche; Richtwert: 4x Gewindesteigung. Eingabebereich 0 bis 99999,9999 alternativ predef

Bohrtiefe Q201 (Gewindelänge, inkremental): Abstand Werkstück-Oberfläche – Gewindeende. Eingabebereich -99999,9999 bis 99999,9999

Vorschub F Q206: Verfahrgeschwindigkeit des Werkzeugs beim Gewindebohren. Eingabebereich 0 bis 99999,999 alternativ FAUTO

Verweilzeit unten Q211: Wert zwischen 0 und 0,5 Sekunden eingeben, um ein Verkeilen des Werkzeugs beim Rückzug zu vermeiden. Eingabebereich 0 bis 3600,0000 alternativ predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef
Vorschub ermitteln: F = S x p
F: | Vorschub mm/min)
S: | Spindel-Drehzahl (U/min)
p: | Gewindesteigung (mm)
Freifahren bei Programm-Unterbrechung

Wenn Sie während des Gewindebohrens die externe Stopp-Taste drücken, zeigt die TNC einen Softkey an, mit dem Sie das Werkzeug freifahren können.


GEWINDEBOHREN ohne Ausgleichsfutter GS NEU (Zyklus 207, DIN/ISO: G207)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Die TNC schneidet das Gewinde entweder in einem oder in mehreren Arbeitsgängen ohne Längenausgleichsfutter.

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Das Werkzeug fährt in einem Arbeitsgang auf die Bohrtiefe
  3. Danach wird die Spindeldrehrichtung umgekehrt und das Werkzeug nach der Verweilzeit auf den Sicherheits-Abstand zurückgezogen. Falls Sie einen 2. Sicherheits-Abstand eingegeben haben, fährt die TNC das Werkzeug mit FMAX dorthin
  4. Auf Sicherheits-Abstand hält die TNC die Spindel an


Beim Programmieren beachten!

Maschine und TNC müssen vom Maschinenhersteller vorbereitet sein.

Zyklus nur an Maschinen mit geregelter Spindel verwendbar.

Positionier-Satz auf den Startpunkt (Bohrungsmitte) in der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Parameters Bohrtiefe legt die Arbeitsrichtung fest.

Die TNC berechnet den Vorschub in Abhängigkeit von der Drehzahl. Wenn Sie während des Gewindebohrens den Drehknopf für den Drehzahl-Override betätigen, passt die TNC den Vorschub automatisch an.

Der Drehknopf für den Vorschub-Override ist nicht aktiv.

Am Zyklusende steht die Spindel. Vor der nächsten Bearbeitung Spindel mit M3 (bzw. M4) wieder einschalten.

Wenn Sie in der Werkzeug-Tabelle in der Spalte PITCH die Gewindesteigung des Gewindebohrers eintragen, vergleicht die TNC die Gewindesteigung aus der Werkzeug-Tabelle, mit der im Zyklus definierten Gewindesteigung. Die TNC gibt eine Fehlermeldung aus, wenn die Werte nicht übereinstimmen.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
26 CYCL DEF 207 GEW.-BOHREN GS NEU
Q200=2 ;sicherheits-abst.
Q201=-20 ;tiefe
Q239=+1 ;gewindesteigung
Q203=+25 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze (Startposition) – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Bohrtiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Gewindeende. Eingabebereich ‑99999,9999 bis 99999,9999

Gewindesteigung Q239
Steigung des Gewindes. Das Vorzeichen legt Rechts- oder Linksgewinde fest:
+ = Rechtsgewinde
– = Linksgewinde
Eingabebereich -99,9999 bis 99,9999

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef
Freifahren bei Programm-Unterbrechung

Wenn Sie während des Gewindeschneid-Vorgangs die externe Stopp-Taste drücken, zeigt die TNC den Softkey MANUELL FREIFAHREN an. Wenn Sie MANUEL FREIFAHREN drücken, können Sie das Werkzeug gesteuert freifahren. Drücken Sie dazu die positive Achsrichtungs-Taste der aktiven Spindelachse.


GEWINDEBOHREN SPANBRUCH (Zyklus 209, DIN/ISO: G209)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Die TNC schneidet das Gewinde in mehreren Zustellungen auf die eingegebene Tiefe. Über einen Parameter können Sie festlegen, ob beim Spanbruch ganz aus der Bohrung herausgefahren werden soll oder nicht.

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche und führt dort eine Spindelorientierung durch
  2. Das Werkzeug fährt auf die eingegebene Zustell-Tiefe, kehrt die Spindeldrehrichtung um und fährt – je nach Definition – einen bestimmten Betrag zurück oder zum Entspanen aus der Bohrung heraus. Sofern Sie einen Faktor für Drehzahlerhöhung definiert haben, fährt die TNC mit entsprechend höherer Spindeldrehzahl aus der Bohrung heraus
  3. Danach wird die Spindeldrehrichtung wieder umgekehrt und auf die nächste Zustelltiefe gefahren
  4. Die TNC wiederholt diesen Ablauf (2 bis 3), bis die eingegebene Gewindetiefe erreicht ist
  5. Danach wird das Werkzeug auf den Sicherheits-Abstand zurückgezogen. Falls Sie einen 2. Sicherheits-Abstand eingegeben haben, fährt die TNC das Werkzeug mit FMAX dorthin
  6. Auf Sicherheits-Abstand hält die TNC die Spindel an


Beim Programmieren beachten!

Maschine und TNC müssen vom Maschinenhersteller vorbereitet sein.

Zyklus nur an Maschinen mit geregelter Spindel verwendbar.

Positionier-Satz auf den Startpunkt (Bohrungsmitte) in der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Parameters Gewindetiefe legt die Arbeitsrichtung fest.

Die TNC berechnet den Vorschub in Abhängigkeit von der Drehzahl. Wenn Sie während des Gewindebohrens den Drehknopf für den Drehzahl-Override betätigen, passt die TNC den Vorschub automatisch an.

Der Drehknopf für den Vorschub-Override ist nicht aktiv.

Wenn Sie über den Zyklus-Parameter Q403 einen Drehzahlfaktor für schnelleren Rückzug definiert haben, dann beschränkt die TNC die Drezahl auf die Maximaldrehzahl der aktiven Getriebestufe.

Am Zyklusende steht die Spindel. Vor der nächsten Bearbeitung Spindel mit M3 (bzw. M4) wieder einschalten.

Wenn Sie in der Werkzeug-Tabelle in der Spalte PITCH die Gewindesteigung des Gewindebohrers eintragen, vergleicht die TNC die Gewindesteigung aus der Werkzeug-Tabelle, mit der im Zyklus definierten Gewindesteigung. Die TNC gibt eine Fehlermeldung aus, wenn die Werte nicht übereinstimmen.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
26 CYCL DEF 209 GEW.-BOHREN SPANBR.
Q200=2 ;sicherheits-abst.
Q201=-20 ;tiefe
Q239=+1 ;gewindesteigung
Q203=+25 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q257=5 ;bohrtiefe spanbruch
Q256=+1 ;rz bei spanbruch
Q336=50 ;winkel spindel
Q403=1.5 ;faktor drehzahl

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze (Startposition) – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Gewindetiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Gewindeende. Eingabebereich -99999,9999 bis 99999,9999

Gewindesteigung Q239
Steigung des Gewindes. Das Vorzeichen legt Rechts- oder Linksgewinde fest:
+ = Rechtsgewinde
– = Linksgewinde
Eingabebereich -99,9999 bis 99,9999

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Bohrtiefe bis Spanbruch Q257 (inkremental): Zustellung, nachdem die TNC einen Spanbruch durchführt. Eingabebereich 0 bis 99999,9999

Rückzug bei Spanbruch Q256: Die TNC multipliziert die Steigung Q239 mit dem eingegebenen Wert und fährt das Werkzeug beim Spanbrechen um diesen errechneten Wert zurück. Wenn Sie Q256 = 0 eingeben, dann fährt die TNC zum Entspanen vollständig aus der Bohrung heraus (auf Sicherheits-Abstand). Eingabebereich 0 bis 99999,9999

Winkel für Spindel-Orientierung Q336 (absolut): Winkel, auf den die TNC das Werkzeug vor dem Gewindeschneid-Vorgang positioniert. Dadurch können Sie das Gewinde ggf. nachschneiden. Eingabebereich -360,0000 bis 360,0000

Faktor Drehzahländerung Rückzug Q403: Faktor, um den die TNC die Spindeldrehzahl - und damit auch den Rückzugsvorschub - beim Herausfahren aus der Bohrung erhöht. Eingabebereich 0,0001 bis 10, Erhöhung maximal auf Maximaldrehzahl der aktiven Getriebestufe

Freifahren bei Programm-Unterbrechung

Wenn Sie während des Gewindeschneid-Vorgangs die externe Stopp-Taste drücken, zeigt die TNC den Softkey MANUELL FREIFAHREN an. Wenn Sie MANUEL FREIFAHREN drücken, können Sie das Werkzeug gesteuert freifahren. Drücken Sie dazu die positive Achsrichtungs-Taste der aktiven Spindelachse.


Grundlagen zum Gewindefräsen

Weitere Informationen:
> Voraussetzungen


Voraussetzungen

  • Die Maschine sollte mit einer Spindelinnenkühlung (Kühlschmiermittel min. 30 bar, Druckluft min. 6 bar) ausgerüstet sein
  • Da beim Gewindefräsen in der Regel Verzerrungen am Gewindeprofil entstehen, sind in der Regel werkzeugspezifische Korrekturen erforderlich, die Sie aus dem Werkzeugkatalog entnehmen oder bei Ihrem Werkzeughersteller erfragen können. Die Korrektur erfolgt beim TOOL CALL über den Delta-Radius DR
  • Die Zyklen 262, 263, 264 und 267 sind nur mit rechtsdrehenden Werkzeugen verwendbar. Für den Zyklus 265 können Sie rechts- und linksdrehende Werkzeuge einsetzen
  • Die Arbeitsrichtung ergibt sich aus folgenden Eingabeparametern: Vorzeichen der Gewindesteigung Q239 (+ = Rechtsgewinde /– = Linksgewinde) und Fräsart Q351 (+1 = Gleichlauf /–1 = Gegenlauf). Anhand nachfolgender Tabelle sehen sie die Beziehung zwischen den Eingabeparametern bei rechtsdrehenden Werkzeugen.
Innengewinde | Steigung | Fräsart | Arbeitsrichtung
rechtsgängig | + | +1(RL) | Z+
linksgängig | – | –1(RR) | Z+
rechtsgängig | + | –1(RR) | Z–
linksgängig | – | +1(RL) | Z–
Außengewinde | Steigung | Fräsart | Arbeitsrichtung
rechtsgängig | + | +1(RL) | Z–
linksgängig | – | –1(RR) | Z–
rechtsgängig | + | –1(RR) | Z+
linksgängig | – | +1(RL) | Z+

Die TNC bezieht den programmierten Vorschub beim Gewindefräsen auf die Werkzeug-Schneide. Da die TNC aber den Vorschub bezogen auf die Mittelpunktsbahn anzeigt, stimmt der angezeigte Wert nicht mit dem programmierten Wert überein.

Der Umlaufsinn des Gewindes ändert sich, wenn Sie einen Gewindefräszyklus in Verbindung mit Zyklus 8 SPIEGELN in nur einer Achse abarbeiten.

Achtung Kollisionsgefahr!

Programmieren Sie bei den Tiefenzustellungen immer die gleichen Vorzeichen, da die Zyklen mehrere Abläufe enthalten, die voneinander unabhängig sind. Die Rangfolge nach welcher die Arbeitsrichtung entschieden wird, ist bei den jeweiligen Zyklen beschrieben. Wollen Sie z.B. einen Zyklus nur mit dem Senkvorgang wiederholen, so geben Sie bei der Gewindetiefe 0 ein, die Arbeitsrichtung wird dann über die Senktiefe bestimmt.

Verhalten bei Werkzeugbruch!

Wenn während des Gewindeschneidens ein Werkzeugbruch erfolgt, dann stoppen Sie den Programmlauf, wechseln in die Betriebsart Positionieren mit Handeingabe und fahren dort das Werkzeug in einer Linearbewegung auf die Bohrungsmitte. Anschließend können Sie das Werkzeug in der Zustellachse freifahren und auswechseln.


GEWINDEFRAESEN (Zyklus 262, DIN/ISO: G262)

Weitere Informationen:
> Zyklusablauf
> Beim Programieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  2. Das Werkzeug fährt mit dem programmierten Vorschub Vorpositionieren auf die Startebene, die sich aus dem Vorzeichen der Gewindesteigung, der Fräsart und der Anzahl der Gänge zum Nachsetzen ergibt
  3. Anschließend fährt das Werkzeug tangential in einer Helix-Bewegung an den Gewindenenndurchmesser. Dabei wird vor der Helix-Anfahrbewegung noch eine Ausgleichsbewegung in der Werkzeugachse durchgeführt, um mit der Gewindebahn auf der programmierten Startebene zu beginnen
  4. Abhängig vom Parameter Nachsetzen fräst das Werkzeug das Gewinde in einer, in mehreren versetzten oder in einer kontinuierlichen Schraubenlinienbewegung
  5. Danach fährt das Werkzeug tangential von der Kontur zurück zum Startpunkt in der Bearbeitungsebene
  6. Am Ende des Zyklus fährt die TNC das Werkzeug im Eilgang auf den Sicherheits-Abstand oder – falls eingegeben – auf den 2. Sicherheits-Abstand


Beim Programieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Das Vorzeichen des Zyklusparameters Gewindetiefe legt die Arbeitsrichtung fest. Wenn Sie die Gewindetiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Die Anfahrbewegung an den Gewindenenndurchmesser erfolgt im Halbkreis von der Mitte aus. Ist der Werkzeugdurchmesser um die 4fache Steigung kleiner als der Gewindenenndurchmesser wird eine seitliche Vorpositionierung ausgeführt.

Beachten Sie, dass die TNC vor der Anfahrbewegung eine Ausgleichsbewegung in der Werkzeug-Achse durchführt. Die Größe der Ausgleichsbewegung beträgt maximal die halbe Gewindesteigung. Auf ausreichend Platz in der Bohrung achten!

Wenn Sie die Gewindetiefe verändern, ändert die TNC automatisch den Startpunkt für die Helix-Bewegung.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Beachten Sie, dass die TNC bei einer Änderung der Tiefe den Startwinkel so anpasst, dass das Werkzeug die definierte Tiefe an der 0°-Position der Spindel erreicht. In solchen Fällen führt ein Nachschneiden des Gewindes ggf. zu einem zweiten Gang.

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
25 CYCL DEF 262 GEWINDEFRAESEN
Q335=10 ;soll-durchmesser
Q239=+1.5 ;steigung
Q201=-20 ;gewindetiefe
Q355=0 ;nachsetzen
Q253=750 ;vorschub vorpos.
Q351=+1 ;fraesart
Q200=2 ;sicherheits-abst.
Q203=+30 ;Koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q207=500 ;vorschub fraesen
Q512=50 ;vorschub anfahren

Soll-Durchmesser Q335: Gewindenenndurchmesser. Eingabebereich 0 bis 99999,9999

Gewindesteigung Q239: Steigung des Gewindes. Das Vorzeichen legt Rechts- oder Linksgewinde fest: + = Rechtsgewinde – = Linksgewinde Eingabebereich -99,9999 bis 99,9999

Gewindetiefe Q201 (inkremental): Abstand zwischen Werkstück-Oberfläche und Gewindegrund. Eingabebereich -99999,9999 bis 99999,9999

Nachsetzen Q355: Anzahl der Gewindegänge um die das Werkzeug versetzt wird: 0 = eine 360° Schraubenlinie auf die Gewindetiefe 1 = kontinuierliche Schraubenlinie auf der gesamten Gewindelänge >1 = mehrere Helixbahnen mit An -und Wegfahren, dazwischen versetzt die TNC das Werkzeug um Q355 mal der Steigung. Eingabebereich 0 bis 99999

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Eintauchen in das Werkstück bzw. beim Herausfahren aus dem Werkstück in mm/min. Eingabebereich 0 bis 99999,999 alternativ fmax, FAUTO, predef

Fräsart Q351: Art der Fräsbearbeitung bei M3 +1 = Gleichlauffräsen –1 = Gegenlauffräsen alternativ predef

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO

Vorschub Anfahren Q512: Verfahrgeschwindigkeit des Werkzeugs beim Einfahren in das Gewinde in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO


SENKGEWINDEFRAESEN (Zyklus 263, DIN/ISO: G263)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  1. Senken
  2. Das Werkzeug fährt im Vorschub Vorpositionieren auf Senktiefe minus Sicherheitsabstand und anschließend im Vorschub Senken auf die Senktiefe
  3. Falls ein Sicherheits-Abstand Seite eingeben wurde, positioniert die TNC das Werkzeug gleich im Vorschub Vorpositionieren auf die Senktiefe
  4. Anschließend fährt die TNC je nach Platzverhältnissen aus der Mitte heraus oder mit seitlichem Vorpositionieren den Kerndurchmesser weich an und führt eine Kreisbewegung aus
  1. Stirnseitig Senken
  5. Das Werkzeug fährt im Vorschub Vorpositionieren auf die Senktiefe Stirnseitig
  6. Die TNC positioniert das Werkzeug unkorrigiert aus der Mitte über einen Halbkreis auf den Versatz Stirnseitig und führt eine Kreisbewegung im Vorschub Senken aus
  7. Anschließend fährt die TNC das Werkzeug wieder auf einem Halbkreis in die Bohrungsmitte
  1. Gewindefräsen
  8. Die TNC fährt das Werkzeug mit dem programmierten Vorschub Vorpositionieren auf die Startebene für das Gewinde, die sich aus dem Vorzeichen der Gewindesteigung und der Fräsart ergibt
  9. Anschließend fährt das Werkzeug tangential in einer Helix-Bewegung an den Gewindenenndurchmesser und fräst mit einer 360°- Schraubenlinienbewegung das Gewinde
  10. Danach fährt das Werkzeug tangential von der Kontur zurück zum Startpunkt in der Bearbeitungsebene
  11. Am Ende des Zyklus fährt die TNC das Werkzeug im Eilgang auf den Sicherheits-Abstand oder – falls eingegeben – auf den 2. Sicherheits-Abstand


Beim Programmieren beachten!

Beachten Sie vor dem Programmieren

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Die Vorzeichen der Zyklenparameter Gewindetiefe, Senktiefe bzw. Tiefe Stirnseitig legen die Arbeitsrichtung fest. Die Arbeitsrichtung wird nach folgender Reihenfolge entschieden:
1. Gewindetiefe
2. Senktiefe
3. Tiefe StirnseitigFalls Sie einen der Tiefenparameter mit 0 belegen, führt die TNC diesen Arbeitsschritt nicht aus.

Wenn Sie Stirnseitig senken wollen, dann den Parameter Senktiefe mit 0 definieren.

Programmieren Sie die Gewindetiefe mindestens um ein Drittel mal der Gewindesteigung kleiner als die Senktiefe.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Soll-Durchmesser Q335: Gewindenenndurchmesser. Eingabebereich 0 bis 99999,9999

Gewindesteigung Q239: Steigung des Gewindes. Das Vorzeichen legt Rechts- oder Linksgewinde fest: + = Rechtsgewinde – = Linksgewinde Eingabebereich -99,9999 bis 99,9999

Gewindetiefe Q201 (inkremental): Abstand zwischen Werkstück-Oberfläche und Gewindegrund. Eingabebereich -99999,9999 bis 99999,9999

Senktiefe Q356: (inkremental): Abstand zwischen Werkstück-Oberfläche und Werkzeugspitze. Eingabebereich -99999,9999 bis 99999,9999

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Eintauchen in das Werkstück bzw. beim Herausfahren aus dem Werkstück in mm/min. Eingabebereich 0 bis 99999,999 alternativ fmax, FAUTO, predef

Fräsart Q351: Art der Fräsbearbeitung bei M3 +1 = Gleichlauffräsen –1 = Gegenlauffräsen alternativ predef

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Sicherheits-Abstand Seite Q357 (inkremental): Abstand zwischen Werkzeugschneide und Bohrungswand. Eingabebereich 0 bis 99999,9999

Tiefe Stirnseitig Q358 (inkremental): Abstand zwischen Werkstück-Oberfläche und Werkzeugspitze beim stirnseitigen Senkvorgang. Eingabebereich -99999,9999 bis 99999,9999

Versatz Senken Stirnseite Q359 (inkremental): Abstand um den die TNC die Werkzeugmitte aus der Bohrungsmitte versetzt. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
25 CYCL DEF 263 SENKGEWINDEFRAESEN
Q335=10 ;soll-durchmesser
Q239=+1.5 ;steigung
Q201=-16 ;gewindetiefe
Q356=-20 ;senktiefe
Q253=750 ;vorschub vorpos.
Q351=+1 ;fraesart
Q200=2 ;sicherheits-abst.
Q357=0.2 ;si.-abst. seite
Q358=+0 ;tiefe stirnseitig
Q359=+0 ;versatz stirnseitig
Q203=+30 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q254=150 ;vorschub senken
Q207=500 ;vorschub fraesen
Q512=50 ;vorschub anfahren

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Vorschub Senken Q254: Verfahrgeschwindigkeit des Werkzeugs beim Senken in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO

Vorschub Anfahren Q512: Verfahrgeschwindigkeit des Werkzeugs beim Einfahren in das Gewinde in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO


BOHRGEWINDEFRAESEN (Zyklus 264, DIN/ISO: G264)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  1. Bohren
  2. Das Werkzeug bohrt mit dem eingegebenen Vorschub Tiefenzustellung bis zur ersten Zustell-Tiefe
  3. Falls Spanbruch eingegeben, fährt die TNC das Werkzeug um den eingegebenen Rückzugswert zurück. Wenn Sie ohne Spanbruch arbeiten, dann fährt die TNC das Werkzeug im Eilgang auf den Sicherheits-Abstand zurück und anschließend wieder mit FMAX bis auf den eingegebenen Vorhalteabstand über die erste Zustell-Tiefe
  4. Anschließend bohrt das Werkzeug mit Vorschub um eine weitere Zustell-Tiefe
  5. Die TNC wiederholt diesen Ablauf (2-4), bis die Bohrtiefe erreicht ist
  1. Stirnseitig Senken
  6. Das Werkzeug fährt im Vorschub Vorpositionieren auf die Senktiefe Stirnseitig
  7. Die TNC positioniert das Werkzeug unkorrigiert aus der Mitte über einen Halbkreis auf den Versatz Stirnseitig und führt eine Kreisbewegung im Vorschub Senken aus
  8. Anschließend fährt die TNC das Werkzeug wieder auf einem Halbkreis in die Bohrungsmitte
  1. Gewindefräsen
  9. Die TNC fährt das Werkzeug mit dem programmierten Vorschub Vorpositionieren auf die Startebene für das Gewinde, die sich aus dem Vorzeichen der Gewindesteigung und der Fräsart ergibt
  10. Anschließend fährt das Werkzeug tangential in einer Helix-Bewegung an den Gewindenenndurchmesser und fräst mit einer 360°- Schraubenliniebewegung das Gewinde
  11. Danach fährt das Werkzeug tangential von der Kontur zurück zum Startpunkt in der Bearbeitungsebene
  12. Am Ende des Zyklus fährt die TNC das Werkzeug im Eilgang auf den Sicherheits-Abstand oder – falls eingegeben – auf den 2. Sicherheits-Abstand


Beim Programmieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Die Vorzeichen der Zyklenparameter Gewindetiefe, Senktiefe bzw. Tiefe Stirnseitig legen die Arbeitsrichtung fest. Die Arbeitsrichtung wird nach folgender Reihenfolge entschieden:
1. Gewindetiefe
2. Bohrtiefe
3. Tiefe StirnseitigFalls Sie einen der Tiefenparameter mit 0 belegen, führt die TNC diesen Arbeitsschritt nicht aus.

Programmieren Sie die Gewindetiefe mindestens um ein Drittel mal der Gewindesteigung kleiner als die Bohrtiefe.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Soll-Durchmesser Q335: Gewindenenndurchmesser. Eingabebereich 0 bis 99999,9999

Gewindesteigung Q239: Steigung des Gewindes. Das Vorzeichen legt Rechts- oder Linksgewinde fest: + = Rechtsgewinde – = Linksgewinde Eingabebereich -99,9999 bis 99,9999

Gewindetiefe Q201 (inkremental): Abstand zwischen Werkstück-Oberfläche und Gewindegrund. Eingabebereich -99999,9999 bis 99999,9999

Bohrtiefe Q356: (inkremental): Abstand zwischen Werkstück-Oberfläche und Bohrungsgrund. Eingabebereich -99999,9999 bis 99999,9999

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Eintauchen in das Werkstück bzw. beim Herausfahren aus dem Werkstück in mm/min. Eingabebereich 0 bis 99999,999 alternativ fmax FAUTO, predef

Fräsart Q351: Art der Fräsbearbeitung bei M3 +1 = Gleichlauffräsen –1 = Gegenlauffräsen alternativ predef

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird. Die Tiefe muss kein Vielfaches der Zustell-Tiefe sein. Eingabebereich 0 bis 99999,9999. Die TNC fährt in einem Arbeitsgang auf die Tiefe wenn:

  • Zustell-Tiefe und Tiefe gleich sind
  • die Zustell-Tiefe größer als die Tiefe ist

Vorhalteabstand oben Q258 (inkremental): Sicherheits-Abstand für Eilgang-Positionierung, wenn die TNC das Werkzeug nach einem Rückzug aus der Bohrung wieder auf die aktuelle Zustell-Tiefe fährt. Eingabebereich 0 bis 99999,9999

Bohrtiefe bis Spanbruch Q257 (inkremental): Zustellung, nachdem die TNC einen Spanbruch durchführt. Kein Spanbruch, wenn 0 eingegeben. Eingabebereich 0 bis 99999,9999 alternativ predef

Rückzug bei Spanbruch Q256 (inkremental): Wert, um die die TNC das Werkzeug beim Spanbrechen zurückfährt. Eingabebereich 0,1000 bis 99999,9999

Beispiel: NC-Sätze
25 CYCL DEF 264 BOHRGEWINDEFRAESEN
Q335=10 ;soll-durchmesser
Q239=+1.5 ;steigung
Q201=-16 ;gewindetiefe
Q356=-20 ;bohrtiefe
Q253=750 ;vorschub vorpos.
Q351=+1 ;fraesart
Q202=5 ;zustell-tiefe
Q258=0.2 ;vorhalteabstand
Q257=5 ;bohrtiefe spanbruch
Q256=0.2 ;rz bei spanbruch
Q358=+0 ;tiefe stirnseitig
Q359=+0 ;versatz stirnseitig
Q200=2 ;sicherheits-abst.
Q203=+30 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q206=150 ;vorschub tiefenz.
Q207=500 ;vorschub fraesen
Q512=50 ;vorschub anfahren

Tiefe Stirnseitig Q358 (inkremental): Abstand zwischen Werkstück-Oberfläche und Werkzeugspitze beim stirnseitigen Senkvorgang. Eingabebereich -99999,9999 bis 99999,9999

Versatz Senken Stirnseite Q359 (inkremental): Abstand um den die TNC die Werkzeugmitte aus der Bohrungsmitte versetzt. Eingabebereich 0 bis 99999,9999

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Bohren in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO

Vorschub Anfahren Q512: Verfahrgeschwindigkeit des Werkzeugs beim Einfahren in das Gewinde in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO


HELIX- BOHRGEWINDEFRAESEN (Zyklus 265, DIN/ISO: G265)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  1. Stirnseitig Senken
  2. Beim Senken vor der Gewindebearbeitung fährt das Werkzeug im Vorschub Senken auf die Senktiefe Stirnseitig. Beim Senkvorgang nach der Gewindebearbeitung fährt die TNC das Werkzeug auf die Senktiefe im Vorschub Vorpositionieren
  3. Die TNC positioniert das Werkzeug unkorrigiert aus der Mitte über einen Halbkreis auf den Versatz Stirnseitig und führt eine Kreisbewegung im Vorschub Senken aus
  4. Anschließend fährt die TNC das Werkzeug wieder auf einem Halbkreis in die Bohrungsmitte
  1. Gewindefräsen
  5. Die TNC fährt das Werkzeug mit dem programmierten Vorschub Vorpositionieren auf die Startebene für das Gewinde
  6. Anschließend fährt das Werkzeug tangential in einer Helix-Bewegung an den Gewindenenndurchmesser
  7. Die TNC fährt das Werkzeug auf einer kontinuierlichen Schraubenlinie nach unten, bis die Gewindetiefe erreicht ist
  8. Danach fährt das Werkzeug tangential von der Kontur zurück zum Startpunkt in der Bearbeitungsebene
  9. Am Ende des Zyklus fährt die TNC das Werkzeug im Eilgang auf den Sicherheits-Abstand oder – falls eingegeben – auf den 2. Sicherheits-Abstand


Beim Programmieren beachten!

Positionier-Satz auf den Startpunkt (Bohrungsmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Die Vorzeichen der Zyklenparameter Gewindetiefe oder Tiefe Stirnseitig legen die Arbeitsrichtung fest. Die Arbeitsrichtung wird nach folgender Reihenfolge entschieden:
1. Gewindetiefe
2. Tiefe StirnseitigFalls Sie einen der Tiefenparameter mit 0 belegen, führt die TNC diesen Arbeitsschritt nicht aus.

Wenn Sie die Gewindetiefe verändern, ändert die TNC automatisch den Startpunkt für die Helix-Bewegung.

Die Fräsart (Gegen-/Gleichlauf) ist durch das Gewinde (Rechts-/Linksgewinde) und die Drehrichtung des Werkzeugs bestimmt, da nur die Arbeitsrichtung von der Werkstückoberfläche ins Teil hinein möglich ist.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Soll-Durchmesser Q335: Gewindenenndurchmesser. Eingabebereich 0 bis 99999,9999

Gewindesteigung Q239: Steigung des Gewindes. Das Vorzeichen legt Rechts- oder Linksgewinde fest: + = Rechtsgewinde – = Linksgewinde Eingabebereich -99,9999 bis 99,9999

Gewindetiefe Q201 (inkremental): Abstand zwischen Werkstück-Oberfläche und Gewindegrund. Eingabebereich -99999,9999 bis 99999,9999

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Eintauchen in das Werkstück bzw. beim Herausfahren aus dem Werkstück in mm/min. Eingabebereich 0 bis 99999,999 alternativ fmax, FAUTO, predef

Tiefe Stirnseitig Q358 (inkremental): Abstand zwischen Werkstück-Oberfläche und Werkzeugspitze beim stirnseitigen Senkvorgang. Eingabebereich -99999,9999 bis 99999,9999

Versatz Senken Stirnseite Q359 (inkremental): Abstand um den die TNC die Werkzeugmitte aus der Bohrungsmitte versetzt. Eingabebereich 0 bis 99999,9999

Senkvorgang Q360: Ausführung der Fase 0 = vor der Gewindebearbeitung 1 = nach der Gewindebearbeitung

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef
Beispiel: NC-Sätze
25 CYCL DEF 265 HELIX-BOHRGEWINDEFR.
Q335=10 ;soll-durchmesser
Q239=+1.5 ;steigung
Q201=-16 ;gewindetiefe
Q253=750 ;vorschub vorpos.
Q358=+0 ;tiefe Stirnseitig
Q359=+0 ;versatz stirnseitig
Q360=0 ;senkvorgang
Q200=2 ;sicherheits-abst.
Q203=+30 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q254=150 ;vorschub senken
Q207=500 ;vorschub fraesen

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Vorschub Senken Q254: Verfahrgeschwindigkeit des Werkzeugs beim Senken in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO


AUSSENGEWINDE-FRAESEN (Zyklus 267, DIN/ISO: G267)

Weitere Informationen:
> Zyklusablauf
> Beim Programmiern beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug in der Spindelachse im Eilgang FMAX auf den eingegebenen Sicherheits-Abstand über der Werkstück-Oberfläche
  1. Stirnseitig Senken
  2. Die TNC fährt den Startpunkt für das stirnseitige Senken ausgehend von der Zapfenmitte auf der Hauptachse der Bearbeitungsebene an. Die Lage des Startpunktes ergibt sich aus Gewinderadius, Werkzeugradius und Steigung
  3. Das Werkzeug fährt im Vorschub Vorpositionieren auf die Senktiefe Stirnseitig
  4. Die TNC positioniert das Werkzeug unkorrigiert aus der Mitte über einen Halbkreis auf den Versatz Stirnseitig und führt eine Kreisbewegung im Vorschub Senken aus
  5. Anschließend fährt die TNC das Werkzeug wieder auf einem Halbkreis auf den Startpunkt
  1. Gewindefräsen
  6. Die TNC positioniert das Werkzeug auf den Startpunkt falls vorher nicht stirnseitig gesenkt wurde. Startpunkt Gewindefräsen = Startpunkt Stirnseitig Senken
  7. Das Werkzeug fährt mit dem programmierten Vorschub Vorpositionieren auf die Startebene, die sich aus dem Vorzeichen der Gewindesteigung, der Fräsart und der Anzahl der Gänge zum Nachsetzen ergibt
  8. Anschließend fährt das Werkzeug tangential in einer Helix-Bewegung an den Gewindenenndurchmesser
  9. Abhängig vom Parameter Nachsetzen fräst das Werkzeug das Gewinde in einer, in mehreren versetzten oder in einer kontinuierlichen Schraubenlinienbewegung
  10. Danach fährt das Werkzeug tangential von der Kontur zurück zum Startpunkt in der Bearbeitungsebene
  11. Am Ende des Zyklus fährt die TNC das Werkzeug im Eilgang auf den Sicherheits-Abstand oder – falls eingegeben – auf den 2. Sicherheits-Abstand


Beim Programmiern beachten!

Positionier-Satz auf den Startpunkt (Zapfenmitte) der Bearbeitungsebene mit Radiuskorrektur R0 programmieren.

Der erforderliche Versatz für das Senken Stirnseite sollte vorab ermittelt werden. Sie müssen den Wert von Zapfenmitte bis Werkzeugmitte (unkorrigierter Wert) angeben.

Die Vorzeichen der Zyklenparameter Gewindetiefe bzw. Tiefe Stirnseitig legen die Arbeitsrichtung fest. Die Arbeitsrichtung wird nach folgender Reihenfolge entschieden:
1. Gewindetiefe
2. Tiefe StirnseitigFalls Sie einen der Tiefenparameter mit 0 belegen, führt die TNC diesen Arbeitsschritt nicht aus.

Das Vorzeichen des Zyklusparameters Gewindetiefe legt die Arbeitsrichtung fest.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Beachten Sie, dass die TNC bei einer Änderung der Tiefe den Startwinkel so anpasst, dass das Werkzeug die definierte Tiefe an der 0°-Position der Spindel erreicht. In solchen Fällen führt ein Nachschneiden des Gewindes ggf. zu einem zweiten Gang.

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Soll-Durchmesser Q335: Gewindenenndurchmesser. Eingabebereich 0 bis 99999,9999

Gewindesteigung Q239: Steigung des Gewindes. Das Vorzeichen legt Rechts- oder Linksgewinde fest: + = Rechtsgewinde – = Linksgewinde Eingabebereich -99,9999 bis 99,9999

Gewindetiefe Q201 (inkremental): Abstand zwischen Werkstück-Oberfläche und Gewindegrund

Nachsetzen Q355: Anzahl der Gewindegänge um die das Werkzeug versetzt wird: 0 = eine Schraubenlinie auf die Gewindetiefe 1 = kontinuierliche Schraubenlinie auf der gesamten Gewindelänge >1 = mehrere Helixbahnen mit An -und Wegfahren, dazwischen versetzt die TNC das Werkzeug um Q355 mal der Steigung. Eingabebereich 0 bis 99999

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Eintauchen in das Werkstück bzw. beim Herausfahren aus dem Werkstück in mm/min. Eingabebereich 0 bis 99999,999 alternativ fmax, FAUTO, predef

Fräsart Q351: Art der Fräsbearbeitung bei M3 +1 = Gleichlauffräsen –1 = Gegenlauffräsen alternativ predef
Beispiel: NC-Sätze
25 CYCL DEF 267 AUSSENGEWINDE FR.
Q335=10 ;soll-durchmesser
Q239=+1.5 ;steigung
Q201=-20 ;gewindetiefe
Q355=0 ;nachsetzen
Q253=750 ;vorschub vorpos.
Q351=+1 ;fraesart
Q200=2 ;sicherheits-abst.
Q358=+0 ;tiefe stirnseitig
Q359=+0 ;versatz stirnseitig
Q203=+30 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q254=150 ;vorschub senken
Q207=500 ;vorschub fraesen
Q512=50 ;vorschub anfahren

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Tiefe Stirnseitig Q358 (inkremental): Abstand zwischen Werkstück-Oberfläche und Werkzeugspitze beim stirnseitigen Senkvorgang. Eingabebereich -99999,9999 bis 99999,9999

Versatz Senken Stirnseite Q359 (inkremental): Abstand um den die TNC die Werkzeugmitte aus der Zapfenmitte versetzt. Eingabebereich 0 bis 99999,9999

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Vorschub Senken Q254: Verfahrgeschwindigkeit des Werkzeugs beim Senken in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO

Vorschub Anfahren Q512: Verfahrgeschwindigkeit des Werkzeugs beim Einfahren in das Gewinde in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO


Programmierbeispiele

Weitere Informationen:
> Beispiel: Gewindebohren


Beispiel: Gewindebohren

    Die Bohrungskoordinaten sind in der Punkte-Tabelle TAB1.PNT gespeichert und werden von der TNC mit CYCL CALL PAT gerufen. Die Werkzeug-Radien sind so gewählt, dass alle Arbeitsschritte in der Testgrafik zu sehen sind. Programm-Ablauf

  • Zentrieren

  • Bohren

  • Gewindebohren

0 begin pgm 1 mm |
1 blk form 0.1 z x+0 y+0 z-20 | Rohteil-Definition
2 blk form 0.2 x+100 y+100 y+0 |
3 tool def 1 l+0 r+4 | Werkzeug-Definition Zentrierer
4 tool def 2 l+0 2.4 | Werkzeug-Definition Bohrer
5 tool def 3 l+0 r+3 | Werkzeug-Definition Gewindebohrer
6 tool call 1 z s5000 | Werkzeug-Aufruf Zentrierer
7 l z+10 R0 f5000 | Werkzeug auf sichere Höhe fahren (F mit Wert programmieren), die TNC positioniert nach jedem Zyklus auf die sichere Höhe
8 sel pattern “tab1“ | Punkte-Tabelle festlegen
9 cycl def 200 BOHREN | Zyklus-Definition Zentrieren
Q200=2 ;sicherheits-abst. |
Q201=-2 ;tiefe |
Q206=150 ;f tiefenzust. |
Q202=2 ;zustell-tiefe |
Q210=0 ;F.-zeit oben |
Q203=+0 ;koor. oberfl. | Zwingend 0 eingeben, wirkt aus Punkte-Tabelle
Q204=0 ;2. s.-abstand | Zwingend 0 eingeben, wirkt aus Punkte-Tabelle
Q211=0.2 ;verweilzeit unten |
Q395=0 ;BEZUG TIEFE |
10 cycl call pat f5000 m3 | Zyklus-Aufruf in Verbindung mit Punkte-Tabelle TAB1.PNT, Vorschub zwischen den Punkten: 5000 mm/min
11 l z+100 r0 fmax m6 | Werkzeug freifahren, Werkzeug-Wechsel
12 tool call 2 z s5000 | Werkzeug-Aufruf Bohrer
13 l z+10 r0 f5000 | Werkzeug auf sichere Höhe fahren (F mit Wert programmieren)
14 cycl def 200 BOHREN | Zyklus-Definition Bohren
Q200=2 ;sicherheits-abst. |
Q201=-25 ;tiefe |
Q206=150 ;vorschub tiefenzust. |
Q202=5 ;zustell-tiefe |
Q210=0 ;verweilzeit oben |
Q203=+0 ;koor. oberfl. | Zwingend 0 eingeben, wirkt aus Punkte-Tabelle
Q204=0 ;2. sicherheits-abstand | Zwingend 0 eingeben, wirkt aus Punkte-Tabelle
Q211=0.2 ;verweilzeit unten |
Q395=0 ;BEZUG TIEFE |
15 cycl call pat f5000 m3 | Zyklus-Aufruf in Verbindung mit Punkte-Tabelle TAB1.PNT
16 l z+100 r0 fmax m6 | Werkzeug freifahren, Werkzeug-Wechsel
17 tool call 3 z s200 | Werkzeug-Aufruf Gewindebohrer
18 l z+50 r0 fmax | Werkzeug auf sichere Höhe fahren
19 cycl def 206 gewindeBOHREN neu | Zyklus-Definition Gewindebohren
Q200=2 ;sicherheits-abst. |
Q201=-25 ;gewindetiefe |
Q206=150 ;vorschub tiefenzust. |
Q211=0 ;verweilzeit unten |
Q203=+0 ;koor. oberflaeche | Zwingend 0 eingeben, wirkt aus Punkte-Tabelle
Q204=0 ;2. sicherheits-abstand | Zwingend 0 eingeben, wirkt aus Punkte-Tabelle
20 cycl call pat f5000 m3 | Zyklus-Aufruf in Verbindung mit Punkte-Tabelle TAB1.PNT
21 l z+100 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
22 end pgm 1 mm |

Punkte-Tabelle TAB1.PNT

TAB1. PNT MM
NR X Y Z
0 +10 +10 +0
1 +40 +30 +0
2 +90 +10 +0
3 +80 +30 +0
4 +80 +65 +0
5 +90 +90 +0
6 +10 +90 +0
7 +20 +55 +0
[END]


Bearbeitungszyklen: Taschenfräsen / Zapfenfräsen / Nutenfräsen

Weitere Informationen:
> Grundlagen
> RECHTECKTASCHE (Zyklus 251, DIN/ISO: G251)
> KREISTASCHE (Zyklus 252, DIN/ISO: G252)
> NUTENFRAESEN (Zyklus 253, DIN/ISO: G253)
> RUNDE NUT (Zyklus 254, DIN/ISO: G254)
> RECHTECKZAPFEN (Zyklus 256, DIN/ISO: G256)
> KREISZAPFEN (Zyklus 257, DIN/ISO: G257)
> Programmierbeispiele


Bearbeitungszyklen: Taschenfräsen / Zapfenfräsen / Nutenfräsen

Grundlagen

Weitere Informationen:
> Übersicht


Übersicht

Die TNC stellt insgesamt 6 Zyklen für Taschen-, Zapfen- und Nutenbearbeitungen zur Verfügung:

Zyklus | Softkey | Seite
251 RECHTECKTASCHE Schrupp-/Schlicht-Zyklus mit Auswahl des Bearbei-tungsumfanges und helixförmigem Eintauchen |  | RECHTECKTASCHE (Zyklus 251, DIN/ISO: G251)
252 KREISTASCHE Schrupp-/Schlicht-Zyklus mit Auswahl des Bearbeitungsumfanges und helixförmigem Eintauchen |  | KREISTASCHE (Zyklus 252, DIN/ISO: G252)
253 NUTENFRAESEN Schrupp-/Schlicht-Zyklus mit Auswahl des Bearbeitungsumfanges und pendelndem Eintauchen |  | NUTENFRAESEN (Zyklus 253, DIN/ISO: G253)
254 RUNDE NUT Schrupp-/Schlicht-Zyklus mit Auswahl des Bearbeitungsumfanges und pendelndem Eintauchen |  | RUNDE NUT (Zyklus 254, DIN/ISO: G254)
256 RECHTECKZAPFEN Schrupp-/Schlicht-Zyklus mit seitlicher Zustellung, wenn Mehrfachumlauf erforderlich |  | RECHTECKZAPFEN (Zyklus 256, DIN/ISO: G256)
257 KREISZAPFEN Schrupp-/Schlicht-Zyklus mit seitlicher Zustellung, wenn Mehrfachumlauf erforderlich |  | KREISZAPFEN (Zyklus 257, DIN/ISO: G257)


RECHTECKTASCHE (Zyklus 251, DIN/ISO: G251)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten
> Zyklusparameter


Zyklusablauf

    Mit dem Rechtecktaschen-Zyklus 251 können Sie eine Rechtecktasche vollständig bearbeiten. In Abhängigkeit der Zyklus-Parameter stehen folgende Bearbeitungsalternativen zur Verfügung:

  • Komplettbearbeitung: Schruppen, Schlichten Tiefe, Schlichten SeiteNur SchruppenNur Schlichten Tiefe und Schlichten SeiteNur Schlichten TiefeNur Schlichten Seite
  1. Schruppen
  2. Das Werkzeug taucht in der Taschenmitte in das Werkstück ein und fährt auf die erste Zustell-Tiefe. Die Eintauchstrategie legen Sie mit dem Parameter Q366 fest
  3. Die TNC räumt die Tasche von innen nach aussen unter Berücksichtigung des Überlappungsfaktors (Parameter Q370) und der Schlichtaufmaße (Parameter Q368 und Q369) aus
  4. Am Ende des Ausräumvorgangs fährt die TNC das Werkzeug tangential von der Taschenwand weg, fährt um den Sicherheits-Abstand über die aktuelle Zustell-Tiefe und von dort aus im Eilgang zurück zur Taschenmitte
  5. Dieser Vorgang wiederholt sich, bis die programmierte Taschentiefe erreicht ist
  1. Schlichten
  5. Sofern Schlichtaufmaße definiert sind, schlichtet die TNC zunächst die Taschenwände, falls eingegeben in mehreren Zustellungen. Die Taschenwand wird dabei tangential angefahren
  6. Anschließend schlichtet die TNC den Boden der Tasche von innen nach aussen. Der Taschenboden wird dabei tangential angefahren


Beim Programmieren beachten

Bei inaktiver Werkzeug-Tabelle müssen Sie immer senkrecht eintauchen (Q366=0), da sie keinen Eintauchwinkel definieren können.

Werkzeug auf Startposition in der Bearbeitungsebene vorpositionieren mit Radiuskorrektur R0. Parameter Q367 (Taschenlage) beachten.

Die TNC führt den Zyklus in den Achsen (Bearbeitungsebene) aus, mit denen Sie die Startposition angefahren haben. Z.B. in X und Y, wenn Sie mit CYCL CALL POS X... Y... und in U und V, wenn Sie CYCL CALL POS U... V... programmiert haben.

Die TNC positioniert das Werkzeug in der Werkzeug-Achse automatisch vor. Parameter Q204 (2. Sicherheits-Abstand) beachten.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Die TNC positioniert das Werkzeug am Zyklusende wieder zurück auf die Startposition.

Die TNC positioniert das Werkzeug am Ende eines Ausräum-Vorgangs im Eilgang zurück zur Taschenmitte. Das Werkzeug steht dabei um den Sicherheits-Abstand über der aktuellen Zustell-Tiefe. Sicherheits-Abstand so eingeben, dass das Werkzeug beim Verfahren nicht mit abgetragenen Spänen verklemmen kann.

Wenn Sie Zyklus 251 in einer Achse spiegeln, dann spiegelt die TNC den im Zyklus definierten Umlaufsinn ebenfalls.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.

Wenn Sie den Zyklus mit Bearbeitungs-Umfang 2 (nur Schlichten) aufrufen, dann positioniert die TNC das Werkzeug in der Taschenmitte im Eilgang auf die erste Zustell-Tiefe!


Zyklusparameter

Bearbeitungs-Umfang (0/1/2) Q215: Bearbeitungs-Umfang festlegen:
0: Schruppen und Schlichten
1: Nur Schruppen
2: Nur Schlichten
Schlichten Seite und Schlichten Tiefe werden nur ausgeführt, wenn das jeweilige Schlichtaufmaß (Q368, Q369) definiert ist

1. Seiten-Länge Q218 (inkremental): Länge der Tasche, parallel zur Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

2. Seiten-Länge Q219 (inkremental): Länge der Tasche, parallel zur Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Eckenradius Q220: Radius der Taschenecke. Wenn mit 0 oder kleiner als der aktive Werkzeug-Radius eingegeben, setzt die TNC den Eckenradius gleich dem Werkzeug-Radius. Die TNC gibt in diesen Fällen keine Fehlermeldung aus. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Seite Q368 (inkremental): Schlicht-Aufmaß in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Drehlage Q224 (absolut): Winkel, um den die gesamte Tasche gedreht wird. Das Drehzentrum liegt in der Position, auf der das Werkzeug beim Zyklus-Aufruf steht. Eingabebereich -360,0000 bis 360,0000

Taschenlage Q367: Lage der Tasche bezogen auf die Position des Werkzeuges beim Zyklus-Aufruf: 0: Werkzeugposition = Taschenmitte 1: Werkzeugposition = Linke untere Ecke 2: Werkzeugposition = Rechte untere Ecke 3: Werkzeugposition = Rechte obere Ecke 4: Werkzeugposition = Linke obere Ecke

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Fräsart Q351: Art der Fräsbearbeitung bei M3: +1 = Gleichlauffräsen –1 = Gegenlauffräsen +0 = Gleichlauffräsen, bei aktiver Spiegelung behält die TNC jedoch die Fräsart Gleichlauf bei alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Taschengrund. Eingabebereich ‑99999,9999 bis 99999,9999

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird; Wert größer 0 eingeben. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Tiefe Q369 (inkremental): Schlicht-Aufmaß für die Tiefe. Eingabebereich 0 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Fahren auf Tiefe in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Zustellung Schlichten Q338 (inkremental): Maß, um welches das Werkzeug in der Spindelachse beim Schlichten zugestellt wird. Q338=0: Schlichten in einer Zustellung. Eingabebereich 0 bis 99999,9999

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koordinate Werkstück-Oberfläche Q203 (absolut): Absolute Koordinate der Werkstück-Oberfläche. Eingabebereich -99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef
Beispiel: NC-Sätze
8 cycl def 251 rechtecktasche
Q215=0 ;BEARBEITUNGS-UMFANG
Q218=80 ;1. seiten-laenge
Q219=60 ;2. seiten-laenge
Q220=5 ;eckenradius
Q368=0.2 ;AUFMASS SEITE
Q224=+0 ;DREHLAGE
Q367=0 ;taschenlage
Q207=500 ;vorschub fraesen
Q351=+1 ;fraesart
Q201=-20 ;tiefe
Q202=5 ;zustell-tiefe
Q369=0.1 ;AUFMASS TIEFE
Q206=150 ;VORSCHUB TIEFENZ.
Q338=5 ;zust. schlichten
Q200=2 ;sicherheits-abst.
Q203=+0 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q370=1 ;BAHN-UEBERLAPPUNG
Q366=1 ;EINTAUCHEN
Q385=500 ;VORSCHUB schlichten
9 cycl call pos x+50 y+50 z+0 fmax m3

Bahn-Überlappung Faktor Q370: Q370 x Werkzeug-Radius ergibt die seitliche Zustellung k. Eingabebereich 0,1 bis 1,414 alternativ predef

Eintauchstrategie Q366: Art der Eintauchstrategie:

  • 0 = senkrecht eintauchen. Unabhängig vom in der Werkzeug-Tabelle definierten Eintauchwinkel ANGLE taucht die TNC senkrecht ein
  • 1 = helixförmig eintauchen. In der Werkzeug-Tabelle muss für das aktive Werkzeug der Eintauchwinkel ANGLE ungleich 0 definiert sein. Ansonsten gibt die TNC eine Fehlermeldung aus
  • 2 = pendelnd eintauchen. In der Werkzeug-Tabelle muss für das aktive Werkzeug der Eintauchwinkel ANGLE ungleich 0 definiert sein. Ansonsten gibt die TNC eine Fehlermeldung aus. Die Pendellänge ist abhängig vom Eintauchwinkel, als Minimalwert verwendet die TNC den doppelten Werkzeug-Durchmesser
  • Alternativ predef

Vorschub Schlichten Q385: Verfahrgeschwindigkeit des Werkzeugs beim Seiten- und Tiefenschlichten in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ


KREISTASCHE (Zyklus 252, DIN/ISO: G252)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

    Mit dem Kreistaschen-Zyklus 252 können Sie eine Kreistasche vollständig bearbeiten. In Abhängigkeit der Zyklus-Parameter stehen folgende Bearbeitungsalternativen zur Verfügung:

  • Komplettbearbeitung: Schruppen, Schlichten Tiefe, Schlichten SeiteNur SchruppenNur Schlichten Tiefe und Schlichten SeiteNur Schlichten TiefeNur Schlichten Seite
  1. Schruppen
  2. Das Werkzeug taucht in der Taschenmitte in das Werkstück ein und fährt auf die erste Zustell-Tiefe. Die Eintauchstrategie legen Sie mit dem Parameter Q366 fest
  3. Die TNC räumt die Tasche von innen nach aussen unter Berücksichtigung des Überlappungsfaktors (Parameter Q370) und der Schlichtaufmaße (Parameter Q368 und Q369) aus
  4. Am Ende des Ausräumvorgangs fährt die TNC das Werkzeug tangential von der Taschenwand weg, fährt um den Sicherheits-Abstand über die aktuelle Zustell-Tiefe und von dort aus im Eilgang zurück zur Taschenmitte
  5. Dieser Vorgang wiederholt sich, bis die programmierte Taschentiefe erreicht ist
  1. Schlichten
  5. Sofern Schlichtaufmaße definiert sind, schlichtet die TNC zunächst die Taschenwände, falls eingegeben in mehreren Zustellungen. Die Taschenwand wird dabei tangential angefahren
  6. Anschließend schlichtet die TNC den Boden der Tasche von innen nach aussen. Der Taschenboden wird dabei tangential angefahren


Beim Programmieren beachten!

Bei inaktiver Werkzeug-Tabelle müssen Sie immer senkrecht eintauchen (Q366=0), da sie keinen Eintauchwinkel definieren können.

Werkzeug auf Startposition (Kreismitte) in der Bearbeitungsebene vorpositionieren mit Radiuskorrektur R0.

Die TNC führt den Zyklus in den Achsen (Bearbeitungsebene) aus, mit denen Sie die Startposition angefahren haben. Z.B. in X und Y, wenn Sie mit CYCL CALL POS X... Y... und in U und V, wenn Sie CYCL CALL POS U... V... programmiert haben.

Die TNC positioniert das Werkzeug in der Werkzeug-Achse automatisch vor. Parameter Q204 (2. Sicherheits-Abstand) beachten.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Die TNC positioniert das Werkzeug am Zyklusende wieder zurück auf die Startposition.

Die TNC positioniert das Werkzeug am Ende eines Ausräum-Vorgangs im Eilgang zurück zur Taschenmitte. Das Werkzeug steht dabei um den Sicherheits-Abstand über der aktuellen Zustell-Tiefe. Sicherheits-Abstand so eingeben, dass das Werkzeug beim Verfahren nicht mit abgetragenen Spänen verklemmen kann.

Wenn Sie Zyklus 252 spiegeln, dann behält die TNC den im Zyklus definierten Umlaufsinn bei, spiegelt diesen also nicht mit.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.

Wenn Sie den Zyklus mit Bearbeitungs-Umfang 2 (nur Schlichten) aufrufen, dann positioniert die TNC das Werkzeug in der Taschenmitte im Eilgang auf die erste Zustell-Tiefe!


Zyklusparameter

Bearbeitungs-Umfang (0/1/2) Q215: Bearbeitungs-Umfang festlegen:
0: Schruppen und Schlichten
1: Nur Schruppen
2: Nur Schlichten
Schlichten Seite und Schlichten Tiefe werden nur ausgeführt, wenn das jeweilige Schlichtaufmaß (Q368, Q369) definiert ist

Kreisdurchmesser Q223: Durchmesser der fertig bearbeiteten Tasche. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Seite Q368 (inkremental): Schlicht-Aufmaß in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Fräsart Q351: Art der Fräsbearbeitung bei M3: +1 = Gleichlauffräsen –1 = Gegenlauffräsen +0 = Gleichlauffräsen, bei aktiver Spiegelung behält die TNC jedoch die Fräsart Gleichlauf bei alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Taschengrund. Eingabebereich ‑99999,9999 bis 99999,9999

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird; Wert größer 0 eingeben. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Tiefe Q369 (inkremental): Schlicht-Aufmaß für die Tiefe. Eingabebereich 0 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Fahren auf Tiefe in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Zustellung Schlichten Q338 (inkremental): Maß, um welches das Werkzeug in der Spindelachse beim Schlichten zugestellt wird. Q338=0: Schlichten in einer Zustellung. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
8 cycl def 252 kreistasche
Q215=0 ;BEARBEITUNGS-UMFANG
Q223=60 ;KREISDURCHMESSER
Q368=0.2 ;AUFMASS SEITE
Q207=500 ;vorschub fraesen
Q351=+1 ;fraesart
Q201=-20 ;tiefe
Q202=5 ;zustell-tiefe
Q369=0.1 ;AUFMASS TIEFE
Q206=150 ;VORSCHUB TIEFENZ.
Q338=5 ;zust. schlichten
Q200=2 ;sicherheits-abst.
Q203=+0 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q370=1 ;BAHN-UEBERLAPPUNG
Q366=1 ;EINTAUCHEN
Q385=500 ;VORSCHUB schlichten
9 cycl call pos x+50 y+50 Z+0 fmax m3

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koordinate Werkstück-Oberfläche Q203 (absolut): Absolute Koordinate der Werkstück-Oberfläche. Eingabebereich -99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Bahn-Überlappung Faktor Q370: Q370 x Werkzeug-Radius ergibt die seitliche Zustellung k. Eingabebereich 0,1 bis 1,414 alternativ predef

Eintauchstrategie Q366: Art der Eintauchstrategie:

  • 0 = senkrecht eintauchen. Unabhängig vom in der Werkzeug-Tabelle definierten Eintauchwinkel ANGLE taucht die TNC senkrecht ein
  • 1 = helixförmig eintauchen. In der Werkzeug-Tabelle muss für das aktive Werkzeug der Eintauchwinkel ANGLE ungleich 0 definiert sein. Ansonsten gibt die TNC eine Fehlermeldung aus
  • Alternativ predef

Vorschub Schlichten Q385: Verfahrgeschwindigkeit des Werkzeugs beim Seiten- und Tiefenschlichten in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ


NUTENFRAESEN (Zyklus 253, DIN/ISO: G253)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

    Mit dem Zyklus 253 können Sie eine Nut vollständig bearbeiten. In Abhängigkeit der Zyklus-Parameter stehen folgende Bearbeitungsalternativen zur Verfügung:

  • Komplettbearbeitung: Schruppen, Schlichten Tiefe, Schlichten SeiteNur SchruppenNur Schlichten Tiefe und Schlichten SeiteNur Schlichten TiefeNur Schlichten Seite
  1. Schruppen
  2. Das Werkzeug pendelt ausgehend vom linken Nutkreis-Mittelpunkt mit dem in der Werkzeug-Tabelle definierten Eintauchwinkel auf die erste Zustell-Tiefe. Die Eintauchstrategie legen Sie mit dem Parameter Q366 fest
  3. Die TNC räumt die Nut von innen nach aussen unter Berücksichtigung der Schlichtaufmaße (Parameter Q368 und Q369) aus
  4. Dieser Vorgang wiederholt sich, bis die programmierte Nuttiefe erreicht ist
  1. Schlichten
  4. Sofern Schlichtaufmaße definiert sind, schlichtet die TNC zunächst die Nutwände, falls eingegeben in mehreren Zustellungen. Die Nutwand wird dabei tangential im rechten Nutkreis angefahren
  5. Anschließend schlichtet die TNC den Boden der Nut von innen nach aussen. Der Nutboden wird dabei tangential angefahren


Beim Programmieren beachten!

Bei inaktiver Werkzeug-Tabelle müssen Sie immer senkrecht eintauchen (Q366=0), da sie keinen Eintauchwinkel definieren können.

Werkzeug auf Startposition in der Bearbeitungsebene vorpositionieren mit Radiuskorrektur R0. Parameter Q367 (Nutlage) beachten.

Die TNC führt den Zyklus in den Achsen (Bearbeitungsebene) aus, mit denen Sie die Startposition angefahren haben. Z.B. in X und Y, wenn Sie mit CYCL CALL POS X... Y... und in U und V, wenn Sie CYCL CALL POS U... V... programmiert haben.

Die TNC positioniert das Werkzeug in der Werkzeug-Achse automatisch vor. Parameter Q204 (2. Sicherheits-Abstand) beachten.

Am Zyklus-Ende positioniert die TNC das Werkzeug in der Bearbeitungsebene lediglich zurück in die Nutmitte, in der anderen Achse der Bearbeitungsebene führt die TNC keine Positionierung aus. Wenn Sie eine Nutlage ungleich 0 definieren, dann positioniert die TNC das Werkzeug ausschließlich in der Werkzeug-Achse auf den 2. Sicherheits-Abstand. Vor einem erneuten Zyklus-Aufruf das Werkzeug wieder auf die Startposition fahren, bzw. immer absolute Verfahrbewegungen nach dem Zyklus-Aufruf programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Ist die Nutbreite größer als der doppelte Werkzeug-Durchmesser, dann räumt die TNC die Nut von innen nach aussen entsprechend aus. Sie können also auch mit kleinen Werkzeugen beliebige Nuten fräsen.

Wenn Sie Zyklus 253 spiegeln, dann behält die TNC den im Zyklus definierten Umlaufsinn bei, spiegelt diesen also nicht mit.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.

Wenn Sie den Zyklus mit Bearbeitungs-Umfang 2 (nur Schlichten) aufrufen, dann positioniert die TNC das Werkzeug im Eilgang auf die erste Zustell-Tiefe!


Zyklusparameter

Bearbeitungs-Umfang (0/1/2)Q215: Bearbeitungs-Umfang festlegen:
0: Schruppen und Schlichten
1: Nur Schruppen
2: Nur Schlichten
Schlichten Seite und Schlichten Tiefe werden nur ausgeführt, wenn das jeweilige Schlichtaufmaß (Q368, Q369) definiert ist

Nutlänge Q218 (Wert parallel zur Hauptachse der Bearbeitungsebene): Längere Seite der Nut eingeben. Eingabebereich 0 bis 99999,9999

Nutbreite Q219 (Wert parallel zur Nebenachse der Bearbeitungsebene): Breite der Nut eingeben; wenn Nutbreite gleich Werkzeug-Durchmesser eingegeben, dann schruppt die TNC nur (Langloch fräsen). Maximale Nutbreite beim Schruppen: Doppelter Werkzeug-Durchmesser. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Seite Q368 (inkremental): Schlicht-Aufmaß in der Bearbeitungsebene

Drehlage Q374 (absolut): Winkel, um den die gesamte Nut gedreht wird. Das Drehzentrum liegt in der Position, auf der das Werkzeug beim Zyklus-Aufruf steht. Eingabebereich -360,000 bis 360,000

Lage der Nut (0/1/2/3/4)Q367: Lage der Nut bezogen auf die Position des Werkzeuges beim Zyklus-Aufruf: 0: Werkzeugposition = Nutmitte 1: Werkzeugposition = Linkes Ende der Nut 2: Werkzeugposition = Zentrum linker Nutkreis 3: Werkzeugposition = Zentrum rechter Nutkreis 4: Werkzeugposition = Rechtes Ende der Nut

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Fräsart Q351: Art der Fräsbearbeitung bei M3: +1 = Gleichlauffräsen –1 = Gegenlauffräsen +0 = Gleichlauffräsen, bei aktiver Spiegelung behält die TNC jedoch die Fräsart Gleichlauf bei alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Nutgrund. Eingabebereich -99999,9999 bis 99999,9999

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird; Wert größer 0 eingeben. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Tiefe Q369 (inkremental): Schlicht-Aufmaß für die Tiefe. Eingabebereich 0 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Fahren auf Tiefe in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Zustellung Schlichten Q338 (inkremental): Maß, um welches das Werkzeug in der Spindelachse beim Schlichten zugestellt wird. Q338=0: Schlichten in einer Zustellung. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
8 cycl def 253 nutenfraesen
Q215=0 ;BEARBEITUNGS-UMFANG
Q218=80 ;nutlaenge
Q219=12 ;nutbreite
Q368=0.2 ;AUFMASS SEITE
Q374=+0 ;DREHLAGE
Q367=0 ;nutlage
Q207=500 ;vorschub fraesen
Q351=+1 ;fraesart
Q201=-20 ;tiefe
Q202=5 ;zustell-tiefe
Q369=0.1 ;AUFMASS TIEFE
Q206=150 ;VORSCHUB TIEFENZ.
Q338=5 ;zust. schlichten
Q200=2 ;sicherheits-abst.
Q203=+0 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q366=1 ;EINTAUCHEN
Q385=500 ;VORSCHUB schlichten
Q439=0 ;Bezug Vorschub
9 cycl call pos x+50 y+50 Z+0 fmax m3

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koordinate Werkstück-Oberfläche Q203 (absolut): Absolute Koordinate der Werkstück-Oberfläche. Eingabebereich -99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Eintauchstrategie Q366: Art der Eintauchstrategie:

  • 0 = senkrecht eintauchen. Unabhängig vom in der Werkzeug-Tabelle definierten Eintauchwinkel ANGLE taucht die TNC senkrecht ein
  • 1 = helixförmig eintauchen. In der Werkzeug-Tabelle muss für das aktive Werkzeug der Eintauchwinkel ANGLE ungleich 0 definiert sein. Ansonsten gibt die TNC eine Fehlermeldung aus. Nur helixförmig eintauchen, wenn genügend Platz vorhanden ist
  • 2 = pendelnd eintauchen. In der Werkzeug-Tabelle muss für das aktive Werkzeug der Eintauchwinkel ANGLE ungleich 0 definiert sein. Ansonsten gibt die TNC eine Fehlermeldung aus
  • Alternativ predef

Vorschub Schlichten Q385: Verfahrgeschwindigkeit des Werkzeugs beim Seiten- und Tiefenschlichten in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Bezug Vorschub (0 bis 3) Q439: Auswahl, auf was sich der der programmierte Vorschub bezieht:

  • 0 = Vorschub bezieht sich auf die Mittelpunktsbahn des Werkzeugs
  • 1 = Vorschub bezieht sich nur beim Schlichten Seite auf die Werkzeugschneide, ansonsten auf die Mittelpunktsbahn
  • 2 = Vorschub bezieht sich beim Schlichten Seite und Schlichten Seite auf die Werkzeugschneide, ansonsten auf die Mittelpunktsbahn
  • 3 = Vorschub bezieht sich grundsätzlich immer auf die Werkzeug-Schneide, ansonsten auf die Mittelpunktsbahn


RUNDE NUT (Zyklus 254, DIN/ISO: G254)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

    Mit dem Zyklus 254 können Sie eine runde Nut vollständig bearbeiten. In Abhängigkeit der Zyklus-Parameter stehen folgende Bearbeitungsalternativen zur Verfügung:

  • Komplettbearbeitung: Schruppen, Schlichten Tiefe, Schlichten SeiteNur SchruppenNur Schlichten Tiefe und Schlichten SeiteNur Schlichten TiefeNur Schlichten Seite
  1. Schruppen
  2. Das Werkzeug pendelt im Nutzentrum mit dem in der Werkzeug-Tabelle definierten Eintauchwinkel auf die erste Zustell-Tiefe. Die Eintauchstrategie legen Sie mit dem Parameter Q366 fest
  3. Die TNC räumt die Nut von innen nach aussen unter Berücksichtigung der Schlichtaufmaße (Parameter Q368 und Q369) aus
  4. Dieser Vorgang wiederholt sich, bis die programmierte Nuttiefe erreicht ist
  1. Schlichten
  4. Sofern Schlichtaufmaße definiert sind, schlichtet die TNC zunächst die Nutwände, falls eingegeben in mehreren Zustellungen. Die Nutwand wird dabei tangential angefahren
  5. Anschließend schlichtet die TNC den Boden der Nut von innen nach aussen. Der Nutboden wird dabei tangential angefahren


Beim Programmieren beachten!

Bei inaktiver Werkzeug-Tabelle müssen Sie immer senkrecht eintauchen (Q366=0), da sie keinen Eintauchwinkel definieren können.

Werkzeug in der Bearbeitungsebene vorpositionieren mit Radiuskorrektur R0. Parameter Q367 (Bezug für Nutlage) entsprechend definieren.

Die TNC führt den Zyklus in den Achsen (Bearbeitungsebene) aus, mit denen Sie die Startposition angefahren haben. Z.B. in X und Y, wenn Sie mit CYCL CALL POS X... Y... und in U und V, wenn Sie CYCL CALL POS U... V... programmiert haben.

Die TNC positioniert das Werkzeug in der Werkzeug-Achse automatisch vor. Parameter Q204 (2. Sicherheits-Abstand) beachten.

Am Zyklus-Ende positioniert die TNC das Werkzeug in der Bearbeitungsebene lediglich zurück in die Teilkreismitte, in der anderen Achse der Bearbeitungsebene führt die TNC keine Positionierung aus. Wenn Sie eine Nutlage ungleich 0 definieren, dann positioniert die TNC das Werkzeug ausschließlich in der Werkzeug-Achse auf den 2. Sicherheits-Abstand. Vor einem erneuten Zyklus-Aufruf das Werkzeug wieder auf die Startposition fahren, bzw. immer absolute Verfahrbewegungen nach dem Zyklus-Aufruf programmieren.

Am Zyklus-Ende positioniert die TNC das Werkzeug in der Bearbeitungsebene zurück auf den Startpunkt (Teilkreis-Mitte). Ausnahme: Wenn Sie eine Nutlage ungleich 0 definieren, dann positioniert die TNC das Werkzeug nur in der Werkzeug-Achse auf den 2. Sicherheits-Abstand. In diesen Fällen immer absolute Verfahrbewegungen nach dem Zyklus-Aufruf programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Ist die Nutbreite größer als der doppelte Werkzeug-Durchmesser, dann räumt die TNC die Nut von innen nach aussen entsprechend aus. Sie können also auch mit kleinen Werkzeugen beliebige Nuten fräsen.

Wenn Sie den Zyklus 254 Runde Nut in Verbindung mit Zyklus 221 verwenden, dann ist die Nutlage 0 nicht erlaubt.

Wenn Sie Zyklus 254 spiegeln, dann behält die TNC den im Zyklus definierten Umlaufsinn bei, spiegelt diesen also nicht mit.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.

Wenn Sie den Zyklus mit Bearbeitungs-Umfang 2 (nur Schlichten) aufrufen, dann positioniert die TNC das Werkzeug im Eilgang auf die erste Zustell-Tiefe!


Zyklusparameter

Bearbeitungs-Umfang (0/1/2) Q215: Bearbeitungs-Umfang festlegen:
0: Schruppen und Schlichten
1: Nur Schruppen
2: Nur Schlichten
Schlichten Seite und Schlichten Tiefe werden nur ausgeführt, wenn das jeweilige Schlichtaufmaß (Q368, Q369) definiert ist

Nutbreite Q219 (Wert parallel zur Nebenachse der Bearbeitungsebene): Breite der Nut eingeben; wenn Nutbreite gleich Werkzeug-Durchmesser eingegeben, dann schruppt die TNC nur (Langloch fräsen). Maximale Nutbreite beim Schruppen: Doppelter Werkzeug-Durchmesser. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Seite Q368 (inkremental): Schlicht-Aufmaß in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Teilkreis-Durchmesser Q375: Durchmesser des Teilkreises eingeben. Eingabebereich 0 bis 99999,9999

Bezug für Nutlage (0/1/2/3) Q367: Lage der Nut bezogen auf die Position des Werkzeuges beim Zyklus-Aufruf: 0: Werkzeugposition wird nicht berücksichtigt. Nutlage ergibt sich aus eingegebener Teilkreis-Mitte und Startwinkel 1: Werkzeugposition = Zentrum linker Nutkreis. Startwinkel Q376 bezieht sich auf diese Position. Eingegebene Teilkreis-Mitte wird nicht berücksichtigt 2: Werkzeugposition = Zentrum Mittelachse. Startwinkel Q376 bezieht sich auf diese Position. Eingegebene Teilkreis-Mitte wird nicht berücksichtigt 3: Werkzeugposition = Zentrum rechter Nutkreis. Startwinkel Q376 bezieht sich auf diese Position. Eingegebene Teilkreis-Mitte wird nicht berücksichtigt

Mitte 1. Achse Q216 (absolut): Mitte des Teilkreises in der Hauptachse der Bearbeitungsebene. Nur wirksam, wenn Q367 = 0. Eingabebereich ‑99999,9999 bis 99999,9999

Mitte 2. Achse Q217 (absolut): Mitte des Teilkreises in der Nebenachse der Bearbeitungsebene. Nur wirksam, wenn Q367 = 0. Eingabebereich ‑99999,9999 bis 99999,9999

Startwinkel Q376 (absolut): Polarwinkel des Startpunkts eingeben. Eingabebereich -360,000 bis 360,000

Öffnungs-Winkel der Nut Q248 (inkremental): Öffnungs-Winkel der Nut eingeben. Eingabebereich 0 bis 360,000

Winkelschritt Q378 (inkremental): Winkel, um den die gesamte Nut gedreht wird. Das Drehzentrum liegt in der Teilkreis-Mitte . Eingabebereich -360,000 bis 360,000

Anzahl Bearbeitungen Q377: Anzahl der Bearbeitungen auf dem Teilkreis. Eingabebereich 1 bis 99999

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Fräsart Q351: Art der Fräsbearbeitung bei M3: +1 = Gleichlauffräsen –1 = Gegenlauffräsen +0 = Gleichlauffräsen, bei aktiver Spiegelung behält die TNC jedoch die Fräsart Gleichlauf bei alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Nutgrund. Eingabebereich -99999,9999 bis 99999,9999

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird; Wert größer 0 eingeben. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Tiefe Q369 (inkremental): Schlicht-Aufmaß für die Tiefe. Eingabebereich 0 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Fahren auf Tiefe in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Zustellung Schlichten Q338 (inkremental): Maß, um welches das Werkzeug in der Spindelachse beim Schlichten zugestellt wird. Q338=0: Schlichten in einer Zustellung. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
8 cycl def 254 runde nut
Q215=0 ;BEARBEITUNGS-UMFANG
Q219=12 ;nutbreite
Q368=0.2 ;AUFMASS SEITE
Q375=80 ;teilkreis-durchm.
Q367=0 ;bezug nutlage
Q216=+50 ;mitte 1. achse
Q217=+50 ;mitte 2. achse
Q376=+45 ;startwinkel
Q248=90 ;OEFFNUNGSWINKEL
Q378=0 ;winkelschritt
Q377=1 ;anzahl bearbeitungen
Q207=500 ;vorschub fraesen
Q351=+1 ;fraesart
Q201=-20 ;tiefe
Q202=5 ;zustell-tiefe
Q369=0.1 ;AUFMASS TIEFE
Q206=150 ;VORSCHUB TIEFENZ.
Q338=5 ;zust. schlichten
Q200=2 ;sicherheits-abst.
Q203=+0 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q366=1 ;EINTAUCHEN
Q385=500 ;VORSCHUB schlichten
Q439=0 ;Bezug Vorschub
9 cycl call pos x+50 y+50 Z+0 fmax m3

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koordinate Werkstück-Oberfläche Q203 (absolut): Absolute Koordinate der Werkstück-Oberfläche. Eingabebereich -99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Eintauchstrategie Q366: Art der Eintauchstrategie:

  • 0 = senkrecht eintauchen. Unabhängig vom in der Werkzeug-Tabelle definierten Eintauchwinkel ANGLE taucht die TNC senkrecht ein
  • 1 = helixförmig eintauchen. In der Werkzeug-Tabelle muss für das aktive Werkzeug der Eintauchwinkel ANGLE ungleich 0 definiert sein. Ansonsten gibt die TNC eine Fehlermeldung aus. Nur helixförmig eintauchen, wenn genügend Platz vorhanden ist
  • 2 = pendelnd eintauchen. In der Werkzeug-Tabelle muss für das aktive Werkzeug der Eintauchwinkel ANGLE ungleich 0 definiert sein. Ansonsten gibt die TNC eine Fehlermeldung aus. Die TNC kann erst dann pendelnd eintauchen, wenn die Verfahrlänge auf dem Teilkreis mindestens den dreifachen Werkzeug-Durchmesser veträgt.
  • Alternativ predef

Vorschub Schlichten Q385: Verfahrgeschwindigkeit des Werkzeugs beim Seiten- und Tiefenschlichten in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Bezug Vorschub (0 bis 3) Q439: Auswahl, auf was sich der der programmierte Vorschub bezieht:

  • 0 = Vorschub bezieht sich auf die Mittelpunktsbahn des Werkzeugs
  • 1 = Vorschub bezieht sich nur beim Schlichten Seite auf die Werkzeugschneide, ansonsten auf die Mittelpunktsbahn
  • 2 = Vorschub bezieht sich beim Schlichten Seite und Schlichten Seite auf die Werkzeugschneide, ansonsten auf die Mittelpunktsbahn
  • 3 = Vorschub bezieht sich grundsätzlich immer auf die Werkzeug-Schneide, ansonsten auf die Mittelpunktsbahn


RECHTECKZAPFEN (Zyklus 256, DIN/ISO: G256)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit dem Rechteckzapfen-Zyklus 256 können Sie einen Rechteckzapfen bearbeiten. Wenn ein Rohteilmaß größer als die maximal mögliche seitliche Zustellung ist, dann führt die TNC mehrere seitliche Zustellungen aus bis das Fertigmaß ereicht ist.

  1. Das Werkzeug fährt von der Zyklus-Startposition aus (Zapfenmitte) auf die Startposition der Zapfenbearbeitung. Die Startposition legen Sie über den Parameter Q437 fest. Die der Standardeinstellung (Q437=0) liegt 2 mm rechts neben dem Zapfenrohteil
  2. Falls das Werkzeug auf dem 2. Sicherheits-Abstand steht, fährt die TNC das Werkzeug im Eilgang FMAX auf den Sicherheits-Abstand und von dort mit dem Vorschub Tiefenzustellung auf die erste Zustelltiefe
  3. Anschließend fährt das Werkzeug tangential an die Zapfenkontur und fräst danach einen Umlauf.
  4. Wenn sich das Fertigmaß nicht in einem Umlauf erreichen lässt, stellt die TNC das Werkzeug auf der aktuellen Zustell-Tiefe seitlich zu und fräst danach erneut einen Umlauf. Die TNC berücksichtigt dabei das Rohteilmaß, das Fertigmaß und die erlaubte seitliche Zustellung. Dieser Vorgang wiederholt sich, bis das definierte Fertigmaß erreicht ist. Sofern Sie den Startpunkt auf eine Ecke gelegt haben (Q437 ungleich 0), fräst die TNC spiralförmig vom Startpunkt aus nach innen bis das Fertigmaß erreicht ist
  5. Sind weitere Zustellungen erforderlich, fährt das Werkzeug tangential von der Kontur weg zurück zum Startpunkt der Zapfenbearbeitung
  6. Anschließend fährt die TNC das Werkzeug auf die nächste Zustell-Tiefe und bearbeitet den Zapfen auf dieser Tiefe
  7. Dieser Vorgang wiederholt sich, bis die programmierte Zapfentiefe erreicht ist
  8. Am Zyklusende positioniert die TNC das Werkzeug lediglich in der Werkzeug-Achse auf die im Zyklus definierte Sichere Höhe. Die Endposition stimmt also nicht mit der Startposition überein


Beim Programmieren beachten!

Werkzeug auf Startposition in der Bearbeitungsebene vorpositionieren mit Radiuskorrektur R0. Parameter Q367 (Zapfenlage) beachten.

Die TNC positioniert das Werkzeug in der Werkzeug-Achse automatisch vor. Parameter Q204 (2. Sicherheits-Abstand) beachten.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Rechts neben dem Zapfen ausreichend Platz für die Anfahrbewegung lassen. Minimum: Werkzeug-Durchmesser + 2 mm, wenn Sie mit Standard-Anfahradius und Anfahrwinkel arbeiten.

Die TNC positioniert das Werkzeug am Ende zurück auf den Sicherheits-Abstand, wenn eingegeben auf den 2. Sicherheits-Abstand. Die Endposition des Werkzeugs nach dem Zyklus stimmt also mit der Startposition nicht überein.

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

1. Seiten-Länge Q218: Länge des Zapfens, parallel zur Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Rohteilmaß Seitenlänge 1 Q424: Länge des Zapfenrohteils, parallel zur Hauptachse der Bearbeitungsebene. Rohteilmaß Seitenlänge 1 größer als 1. Seiten-Länge eingeben. Die TNC führt mehrere seitliche Zustellungen aus, wenn die Differenz zwischen Rohteilmaß 1 und Fertigmaß 1größer ist als die erlaubte seitliche Zustellung (Werkzeug-Radius mal Bahn-Überlappung Q370). Die TNC berechnet immer eine konstante seitliche Zustellung. Eingabebereich 0 bis 99999,9999

2. Seiten-Länge Q219: Länge des Zapfens, parallel zur Nebenachse der Bearbeitungsebene. Rohteilmaß Seitenlänge 2 größer als 2. Seiten-Länge eingeben. Die TNC führt mehrere seitliche Zustellungen aus, wenn die Differenz zwischen Rohteilmaß 2 und Fertigmaß 2 größer ist als die erlaubte seitliche Zustellung (Werkzeug-Radius mal Bahn-Überlappung Q370). Die TNC berechnet immer eine konstante seitliche Zustellung. Eingabebereich 0 bis 99999,9999

Rohteilmaß Seitenlänge 2 Q425: Länge des Zapfenrohteils, parallel zur Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Eckenradius Q220: Radius der Zapfenecke. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Seite Q368 (inkremental): Schlicht-Aufmaß in der Bearbeitungsebene, das die TNC bei der Bearbeitung stehen lässt. Eingabebereich 0 bis 99999,9999

Drehlage Q224 (absolut): Winkel, um den der gesamte Zapfen gedreht wird. Das Drehzentrum liegt in der Position, auf der das Werkzeug beim Zyklus-Aufruf steht. Eingabebereich -360,000 bis 360,000

Zapfenlage Q367: Lage des Zapfens bezogen auf die Position des Werkzeuges beim Zyklus-Aufruf: 0: Werkzeugposition = Zapfenmitte 1: Werkzeugposition = Linke untere Ecke 2: Werkzeugposition = Rechte untere Ecke 3: Werkzeugposition = Rechte obere Ecke 4: Werkzeugposition = Linke obere Ecke

Beispiel: NC-Sätze
8 cycl def 256 rechteckzapfen
Q218=60 ;1. seiten-laenge
Q424=74 ;rohteilmass 1
Q219=40 ;2. seiten-laenge
Q425=60 ;rohteilmass 2
Q220=5 ;eckenradius
Q368=0.2 ;AUFMASS SEITE
Q224=+0 ;DREHLAGE
Q367=0 ;zapfenlage
Q207=500 ;vorschub fraesen
Q351=+1 ;fraesart
Q201=-20 ;tiefe
Q202=5 ;zustell-tiefe
Q206=150 ;VORSCHUB TIEFENZ.
Q200=2 ;sicherheits-abst.
Q203=+0 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q370=1 ;BAHN-UEBERLAPPUNG
Q437=0 ;Anfahrposition
9 cycl call pos x+50 y+50 z+0 fmax m3

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Fräsart Q351: Art der Fräsbearbeitung bei M3: +1 = Gleichlauffräsen –1 = Gegenlauffräsen alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Zapfengrund. Eingabebereich ‑99999,9999 bis 99999,9999

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird; Wert größer 0 eingeben. Eingabebereich 0 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Fahren auf Tiefe in mm/min. Eingabebereich 0 bis 99999,999 alternativ fmax, FAUTO, fu, FZ

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koordinate Werkstück-Oberfläche Q203 (absolut): Absolute Koordinate der Werkstück-Oberfläche. Eingabebereich -99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Bahn-Überlappung Faktor Q370: Q370 x Werkzeug-Radius ergibt die seitliche Zustellung k. Eingabebereich 0,1 bis 1,414 alternativ predef

Anfahrposition (0...4) Q437 Anfahrstrategie des Werkzeugs festlegen: 0: Rechts vom Zapfen (Grundeinstellung) 1: Linke untere Ecke 2: Rechte untere Ecke 3: Rechte obere Ecke 4: Linke obere Ecke Sollten beim Anfahren mit der Einstellung Q437=0 Anfahrmarken auf der Zapfenoberfläche entstehen, dann eine andere Anfahrposition wählen


KREISZAPFEN (Zyklus 257, DIN/ISO: G257)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit dem Kreiszapfen-Zyklus 257 können Sie einen Kreiszapfen bearbeiten. Wenn der Rohteil-Durchmesser größer als die maximal mögliche seitliche Zustellung ist, dann führt die TNC eine spiralförmige Zustellungen aus bis der Fertigteil-Durchmesser ereicht ist.

  1. Das Werkzeug fährt von der Zyklus-Startposition aus (Zapfenmitte) auf die Startposition der Zapfenbearbeitung. Die Startposition legen Sie über den Polarwinkel bezogen auf die Zapfenmitte mit dem Parameter Q376 fest
  2. Falls das Werkzeug auf dem 2. Sicherheits-Abstand steht, fährt die TNC das Werkzeug im Eilgang FMAX auf den Sicherheits-Abstand und von dort mit dem Vorschub Tiefenzustellung auf die erste Zustelltiefe
  3. Anschließend fährt das Werkzeug in einer spiralförmigen Bewegung tangential an die Zapfenkontur und fräst danach einen Umlauf.
  4. Wenn sich der Fertigteil-Durchmesser nicht in einem Umlauf erreichen lässt, stellt die TNC solange spiralförmig zu, bis der Fertigteil-Durchmesser erreicht ist. Die TNC berücksichtigt dabei den Rohteil-Durchmesser, den Fertigteil-Durchmesser und die erlaubte seitliche Zustellung
  5. Die TNC fährt das Werkzeug auf einer spiralförmigen Bahn von der Kontur weg
  6. Sind mehrere Tiefenzustellungen nötig, so erfolgt die neue Tiefenzustellung an dem der Abfahrbewegung nächstgelegenen Punkt
  7. Dieser Vorgang wiederholt sich, bis die programmierte Zapfentiefe erreicht ist
  8. Am Zyklusende positioniert die TNC das Werkzeug lediglich in der Werkzeug-Achse auf die im Zyklus definierte Sichere Höhe. Die Endposition stimmt also nicht mit der Startposition überein


Beim Programmieren beachten!

Werkzeug auf Startposition in der Bearbeitungsebene (Zapfenmitte) vorpositionieren mit Radiuskorrektur R0.

Die TNC positioniert das Werkzeug in der Werkzeug-Achse automatisch vor. Parameter Q204 (2. Sicherheits-Abstand) beachten.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Die TNC positioniert das Werkzeug am Zyklusende lediglich in der Werkzeug-Achse zurück auf die Startposition, nicht jedoch in der Bearbeitungsebene.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 2 stellen Sie ein, ob die TNC bei der Eingabe einer positiven Tiefe eine Fehlermeldung ausgeben soll (Bit 2=1) oder nicht (Bit 2=0).

Beachten Sie, dass die TNC bei positiv eingegebener Tiefe die Berechnung der Vorposition umkehrt. Das Werkzeug fährt also in der Werkzeug-Achse mit Eilgang auf Sicherheits-Abstand unter die Werkstück-Oberfläche!

Rechts neben dem Zapfen ausreichend Platz für die Anfahrbewegung lassen. Minimum: Werkzeug-Durchmesser + 2 mm, wenn Sie mit Standard-Anfahradius und Anfahrwinkel arbeiten.

Die TNC positioniert das Werkzeug am Ende zurück auf den Sicherheits-Abstand, wenn eingegeben auf den 2. Sicherheits-Abstand. Die Endposition des Werkzeugs nach dem Zyklus stimmt also mit der Startposition nicht überein.

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Fertigteil-Durchmesser Q223: Durchmesser des fertig bearbeiteten Zapfens. Eingabebereich 0 bis 99999,9999

Rohteil-Durchmesser Q222: Durchmesser des Rohteils. Rohteil-Durchmesser größer Fertigteil-Durchmesser eingeben. Die TNC führt mehrere seitliche Zustellungen aus, wenn die Differenz zwischen Rohteil-Durchmesser und Fertigteil-Durchmesser größer ist als die erlaubte seitliche Zustellung (Werkzeug-Radius mal Bahn-Überlappung Q370). Die TNC berechnet immer eine konstante seitliche Zustellung. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Seite Q368 (inkremental): Schlicht-Aufmaß in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Fräsart Q351: Art der Fräsbearbeitung bei M3: +1 = Gleichlauffräsen –1 = Gegenlauffräsn alternativ predef
Beispiel: NC-Sätze
8 cycl def 257 kreiszapfen
Q223=60 ;fertigteil-durchm.
Q222=60 ;rohteil-DURCHM.
Q368=0.2 ;AUFMASS SEITE
Q207=500 ;vorschub fraesen
Q351=+1 ;fraesart
Q201=-20 ;tiefe
Q202=5 ;zustell-tiefe
Q206=150 ;VORSCHUB TIEFENZ.
Q200=2 ;sicherheits-abst.
Q203=+0 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q370=1 ;BAHN-UEBERLAPPUNG
Q376=0 ;STARTWINKEL
9 cycl call pos x+50 y+50 Z+0 fmax m3

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Zapfengrund. Eingabebereich ‑99999,9999 bis 99999,9999

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird; Wert größer 0 eingeben. Eingabebereich 0 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Fahren auf Tiefe in mm/min. Eingabebereich 0 bis 99999,999 alternativ fmax, FAUTO, fu, FZ

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koordinate Werkstück-Oberfläche Q203 (absolut): Absolute Koordinate der Werkstück-Oberfläche. Eingabebereich -99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Bahn-Überlappung Faktor Q370: Q370 x Werkzeug-Radius ergibt die seitliche Zustellung k. Eingabebereich 0,1 bis 1,414 alternativ predef

Startwinkel Q376: Polarwinkel bezogen auf den Zapfenmittelpunkt, von dem aus das Werkzeug an den Zapfen anfährt. Eingabebereich 0 bis 359°


Programmierbeispiele

Weitere Informationen:
> Beispiel: Tasche, Zapfen und Nuten fräsen


Beispiel: Tasche, Zapfen und Nuten fräsen

0 beginn pgm c210 mm |
1 blk form 0.1 z x+0 y+0 z-40 | Rohteil-Definition
2 blk form 0.2 x+100 y+100 z+0 |
3 tool def 1 l+0 r+6 | Werkzeug-Definition Schruppen/Schlichten
4 tool def 2 l+0 r+3 | Werkzeug-Definition Nutenfräser
5 tool call 1 z s3500 | Werkzeug-Aufruf Schruppen/Schlichten
6 l z+250 r0 fmax | Werkzeug freifahren
7 cycl def 256 rechteckzapfen | Zyklus-Definition Außenbearbeitung
Q218=90 ;1. seiten-laenge |
Q424=100 ;rohteilmass 1 |
Q219=80 ;2. seiten-laenge |
Q425=100 ;rohteilmass 2 |
Q220=0 ;eckenradius |
Q368=0 ;aufmass seite |
Q224=0 ;drehlage |
Q367=0 ;zapfenlage |
Q207=250 ;vorschub fraesen |
Q351=+1 ;fraesart |
Q201=-30 ;tiefe |
Q202=5 ;zustell-tiefe |
Q206=250 ;vorschub tiefenz. |
Q200=2 ;sicherheits-abst. |
Q203=+0 ;koor. oberfl. |
Q204=20 ;2. s.-abstand |
Q370=1 ;bahn-ueberlappung |
Q437=1 ;ANFAHRPOSITION |
8 cycl call pos x+50 y+50 z+0 m3 | Zyklus-Aufruf Außenbearbeitung
9 cycl def 252 kreistasche | Zyklus-Definition Kreistasche
Q215=0 ;BEARBEITUNGS-UMFANG |
Q223=50 ;KREISDURCHMESSER |
Q368=0.2 ;AUFMASS SEITE |
Q207=500 ;vorschub fraesen |
Q351=+1 ;fraesart |
Q201=-30 ;tiefe |
Q202=5 ;zustell-tiefe |
Q369=0.1 ;AUFMASS TIEFE |
Q206=150 ;VORSCHUB TIEFENZ. |
Q338=5 ;zust. schlichten |
Q200=2 ;sicherheits-abst. |
Q203=+0 ;koor. oberflaeche |
Q204=50 ;2. sicherheits-abst. |
Q370=1 ;BAHN-UEBERLAPPUNG |
Q366=1 ;EINTAUCHEN |
Q385=750 ;vorschub schlichten |
10 cycl call pos x+50 y+50 Z+0 fmax | Zyklus-Aufruf Kreistasche
11 l z+250 r0 fmax m6 | Werkzeug-Wechsel
12 toll call 2 z s5000 | Werkzeug-Aufruf Nutenfräser
13 cycl def 254 runde nut | Zyklus-Definition Nuten
Q215=0 ;BEARBEITUNGS-UMFANG |
Q219=8 ;nutbreite |
Q368=0.2 ;AUFMASS SEITE |
Q375=70 ;teilkreis-durchm. |
Q367=0 ;bezug nutlage | Keine Vorpositionierung in X/Y erforderlich
Q216=+50 ;mitte 1. achse |
Q217=+50 ;mitte 2. achse |
Q376=+45 ;startwinkel |
Q248=90 ;OEFFNUNGSWINKEL |
Q378=180 ;winkelschritt | Startpunkt 2. Nut
Q377=2 ;anzahl bearbeitungen |
Q207=500 ;vorschub fraesen |
Q351=+1 ;fraesart |
Q201=-20 ;tiefe |
Q202=5 ;zustell-tiefe |
Q369=0.1 ;AUFMASS TIEFE |
Q206=150 ;VORSCHUB TIEFENZ. |
Q338=5 ;zust. schlichten |
Q200=2 ;sicherheits-abst. |
Q203=+0 ;koor. oberflaeche |
Q204=50 ;2. sicherheits-abst. |
Q366=1 ;EINTAUCHEN |
Q439=0 ;BEZUG VORSCHUB |
14 cycl call fmax m3 | Zyklus-Aufruf Nuten
15 l z+250 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
16 end pgm c210 mm |


Bearbeitungszyklen: Musterdefinitionen

Weitere Informationen:
> Grundlagen
> PUNKTEMUSTER AUF KREIS (Zyklus 220, DIN/ISO: G220)
> PUNKTEMUSTER AUF LINIEN (Zyklus 221, DIN/ISO: G221)
> Programmierbeispiele


Übersicht

Die TNC stellt 2 Zyklen zur Verfügung, mit denen Sie Punktemuster direkt fertigen können:

Zyklus | Softkey | Seite
220 PUNKTEMUSTER AUF KREIS |  | PUNKTEMUSTER AUF KREIS (Zyklus 220, DIN/ISO: G220)
221 PUNKTEMUSTER AUF LINIEN |  | PUNKTEMUSTER AUF LINIEN (Zyklus 221, DIN/ISO: G221)

Folgende Bearbeitungszyklen können Sie mit den Zyklen 220 und 221 kombinieren:

Wenn Sie unregelmäßige Punktemuster fertigen müssen, dann verwenden Sie Punkte-Tabellen mit CYCL CALL PAT (siehe Punkte-Tabellen).

Mit der Funktion pattern def stehen weitere regelmäßige Punktemuster zur Verfügung (siehe Muster-Definition PATTERN DEF).

Zyklus 200 | BOHREN
Zyklus 201 | REIBEN
Zyklus 202 | AUSDREHEN
Zyklus 203 | UNIVERSAL-BOHREN
Zyklus 204 | RUECKWAERTS-SENKEN
Zyklus 205 | UNIVERSAL-TIEFBOHREN
Zyklus 206 | GEWINDEBOHREN NEU mit Ausgleichsfutter
Zyklus 207 | GEWINDEBOHREN GS NEU ohne Ausgleichsfutter
Zyklus 208 | BOHRFRAESEN
Zyklus 209 | GEWINDEBOHREN SPANBRUCH
Zyklus 240 | ZENTRIEREN
Zyklus 251 | RECHTECKTASCHE
Zyklus 252 | KREISTASCHE
Zyklus 253 | NUTENFRAESEN
Zyklus 254 | RUNDE NUT (nur mit Zyklus 221 kombinierbar)
Zyklus 256 | RECHTECKZAPFEN
Zyklus 257 | KREISZAPFEN
Zyklus 262 | GEWINDEFRAESEN
Zyklus 263 | SENKGEWINDEFRAESEN
Zyklus 264 | BOHRGEWINDEFRAESEN
Zyklus 265 | HELIX-BOHRGEWINDEFRAESEN
Zyklus 267 | AUSSEN-GEWINDEFRAESEN


PUNKTEMUSTER AUF KREIS (Zyklus 220, DIN/ISO: G220)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug im Eilgang von der aktuellen Position zum Startpunkt der ersten Bearbeitung.

      2. Reihenfolge:

    • 2. Sicherheits-Abstand anfahren (Spindelachse)
    • Startpunkt in der Bearbeitungsebene anfahren
    • Auf Sicherheits-Abstand über Werkstück-Oberfläche fahren (Spindelachse)
  2. Ab dieser Position führt die TNC den zuletzt definierten Bearbeitungszyklus aus
  3. Anschließend positioniert die TNC das Werkzeug mit einer Geraden-Bewegung oder mit einer Kreis-Bewegung auf den Startpunkt der nächsten Bearbeitung; das Werkzeug steht dabei auf Sicherheits-Abstand (oder 2. Sicherheits-Abstand)
  4. Dieser Vorgang (1 bis 3) wiederholt sich, bis alle Bearbeitungen ausgeführt sind


Beim Programmieren beachten!

Zyklus 220 ist DEF-Aktiv, das heißt, Zyklus 220 ruft automatisch den zuletzt definierten Bearbeitungszyklus auf.

Wenn Sie einen der Bearbeitungszyklen 200 bis 209 und 251 bis 267 mit Zyklus 220 kombinieren, wirken der Sicherheits-Abstand, die Werkstück-Oberfläche und der 2. Sicherheits-Abstand aus Zyklus 220.


Zyklusparameter

Mitte 1. Achse Q216 (absolut): Teilkreis-Mittelpunkt in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q217 (absolut): Teilkreis-Mittelpunkt in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Teilkreis-Durchmesser Q244: Durchmesser des Teilkreises. Eingabebereich 0 bis 99999,9999

Startwinkel Q245 (absolut): Winkel zwischen der Hauptachse der Bearbeitungsebene und dem Startpunkt der ersten Bearbeitung auf dem Teilkreis. Eingabebereich -360,000 bis 360,000

Endwinkel Q246 (absolut): Winkel zwischen der Hauptachse der Bearbeitungsebene und dem Startpunkt der letzten Bearbeitung auf dem Teilkreis (gilt nicht für Vollkreise); Endwinkel ungleich Startwinkel eingeben; wenn Endwinkel größer als Startwinkel eingegeben, dann Bearbeitung im Gegen-Uhrzeigersinn, sonst Bearbeitung im Uhrzeigersinn. Eingabebereich -360,000 bis 360,000

Winkelschritt Q247 (inkremental): Winkel zwischen zwei Bearbeitungen auf dem Teilkreis; wenn der Winkelschritt gleich null ist, dann berechnet die TNC den Winkelschritt aus Startwinkel, Endwinkel und Anzahl Bearbeitungen; wenn ein Winkelschritt eingegeben ist, dann berücksichtigt die TNC den Endwinkel nicht; das Vorzeichen des Winkelschritts legt die Bearbeitungsrichtung fest (– = Uhrzeigersinn). Eingabebereich -360,000 bis 360,000

Anzahl Bearbeitungen Q241: Anzahl der Bearbeitungen auf dem Teilkreis. Eingabebereich 1 bis 99999

Beispiel: NC-Sätze
53 cycl def 220 muster kreis
Q216=+50 ;mitte 1. achse
Q217=+50 ;mitte 2. Achse
Q244=80 ;teilkreis-durchm.
Q245=+0 ;startwinkel
Q246=+360 ;endwinkel
Q247=+0 ;winkelschritt
Q241=8 ;anzahl bearbeitungen
Q200=2 ;sicherheits-abst.
Q203=+30 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q301=1 ;fahren auf s. hoehe
Q365=0 ;Verfahrart

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Werkzeug zwischen den Bearbeitungen verfahren soll:
0: Zwischen den Bearbeitungen auf Sicherheits-Abstand verfahren
1: Zwischen den Bearbeitungen auf 2. Sicherheits-Abstand verfahren
Alternativ predef

Verfahrart? Gerade=0/Kreis=1 Q365: Festlegen, mit welcher Bahnfunktion das Werkzeug zwischen den Bearbeitungen verfahren soll:
0: Zwischen den Bearbeitungen auf einer Geraden verfahren
1: Zwischen den Bearbeitungen zirkular auf dem Teilkreis-Durchmesser verfahren


PUNKTEMUSTER AUF LINIEN (Zyklus 221, DIN/ISO: G221)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug automatisch von der aktuellen Position zum Startpunkt der ersten Bearbeitung

      2. Reihenfolge:

    • 2. Sicherheits-Abstand anfahren (Spindelachse)
    • Startpunkt in der Bearbeitungsebene anfahren
    • Auf Sicherheits-Abstand über Werkstück-Oberfläche fahren (Spindelachse)
  2. Ab dieser Position führt die TNC den zuletzt definierten Bearbeitungszyklus aus
  3. Anschließend positioniert die TNC das Werkzeug in positiver Richtung der Hauptachse auf den Startpunkt der nächsten Bearbeitung; das Werkzeug steht dabei auf Sicherheits-Abstand (oder 2. Sicherheits-Abstand)
  4. Dieser Vorgang (1 bis 3) wiederholt sich, bis alle Bearbeitungen auf der ersten Zeile ausgeführt sind; das Werkzeug steht am letzten Punkt der ersten Zeile
  5. Danach fährt die TNC das Werkzeug zum letzten Punkt der zweiten Zeile und führt dort die Bearbeitung durch
  6. Von dort aus positioniert die TNC das Werkzeug in negativer Richtung der Hauptachse auf den Startpunkt der nächsten Bearbeitung
  7. Dieser Vorgang (6) wiederholt sich, bis alle Bearbeitungen der zweiten Zeile ausgeführt sind
  8. Anschließend fährt die TNC das Werkzeug auf den Startpunkt der nächsten Zeile
  9. In einer Pendelbewegung werden alle weiteren Zeilen abgearbeitet


Beim Programmieren beachten!

Zyklus 221 ist DEF-Aktiv, das heißt, Zyklus 221 ruft automatisch den zuletzt definierten Bearbeitungszyklus auf.

Wenn Sie einen der Bearbeitungszyklen 200 bis 209 und 251 bis 267 mit Zyklus 221 kombinieren, wirken der Sicherheits-Abstand, die Werkstück-Oberfläche, der 2. Sicherheits-Abstand und die Drehlage aus Zyklus 221.

Wenn Sie den Zyklus 254 Runde Nut in Verbindung mit Zyklus 221 verwenden, dann ist die Nutlage 0 nicht erlaubt.


Zyklusparameter

Beispiel: NC-Sätze
54 cycl def 221 muster linien
Q225=+15 ;startpunkt 1. achse
Q226=+15 ;startpunkt 2. achse
Q237=+10 ;abstand 1. achse
Q238=+8 ;abstand 2. achse
Q242=6 ;anzahl spalten
Q243=4 ;anzahl zeilen
Q224=+15 ;drehlage
Q200=2 ;sicherheits-abst.
Q203=+30 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q301=1 ;fahren auf s. hoehe

Startpunkt 1. Achse Q225 (absolut): Koordinate des Startpunktes in der Hauptachse der Bearbeitungsebene

Startpunkt 2. Achse Q226 (absolut): Koordinate des Startpunktes in der Nebenachse der Bearbeitungsebene

Abstand 1. Achse Q237 (inkremental): Abstand der einzelnen Punkte auf der Zeile

Abstand 2. Achse Q238 (inkremental): Abstand der einzelnen Zeilen voneinander

Anzahl Spalten Q242: Anzahl der Bearbeitungen auf der Zeile

Anzahl Zeilen Q243: Anzahl der Zeilen

Drehlage Q224 (absolut): Winkel, um den das gesamte Anordnungsbild gedreht wird; das Drehzentrum liegt im Startpunkt

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Werkstück-Oberfläche alternativ predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Werkzeug zwischen den Bearbeitungen verfahren soll:
0: Zwischen den Bearbeitungen auf Sicherheits-Abstand verfahren
1: Zwischen den Bearbeitungen auf 2. Sicherheits-Abstand verfahren
Alternativ predef


Programmierbeispiele

Weitere Informationen:
> Beispiel: Lochkreise


Beispiel: Lochkreise

0 begin pgm bohrb mm |
1 blk form 0.1 z x+0 y+0 z-40 | Rohteil-Definition
2 blk form 0.2 y+100 y+100 z+0 |
3 tool def 1 l+0 r+3 | Werkzeug-Definition
4 tool call 1 z s3500 | Werkzeug-Aufruf
5 l z+250 r0 fmax m3 | Werkzeug freifahren
6 cycl def 200 bohren | Zyklus-Definition Bohren
Q200=2 ;sicherheits-abst. |
Q201=-15 ;tiefe |
Q206=250 ;f tiefenzust. |
Q202=4 ;zustell-tiefe |
Q210=0 ;v.-zeit |
Q203=+0 ;koor. oberfl. |
Q204=0 ;2. S.-abstand |
Q211=0.25 ;verweilzeit unten |
Q395=0.25 ;BEZUG TIEFE |
7 cycl def 220 muster kreis | Zyklus-Definition Lochkreis 1, CYCL 200 wird automatisch gerufen, Q200, Q203 und Q204 wirken aus Zyklus 220
Q216=+30 ;mitte 1. achse |
Q217=+70 ;mitte 2. achse |
Q244=50 ;teilkreis-durch. |
Q245=+0 ;startwinkel |
Q246=+360 ;endwinkel |
Q247=+0 ;winkelschritt |
Q241=10 ;anzahl |
Q200=2 ;sicherheits-abst. |
Q203=+0 ;koor. oberfl. |
Q204=100 ;2. S.-Abstand |
Q301=1 ;fahren auf s. hoehe |
Q365=0 ;verfahrart |
8 cycl def 220 muster kreis | Zyklus-Definition Lochkreis 2, CYCL 200 wird automatisch gerufen, Q200, Q203 und Q204 wirken aus Zyklus 220
Q216=+90 ;mitte 1. achse |
Q217=+25 ;mitte 2. achse |
Q244=70 ;teilkreis-durch. |
Q245=+90 ;startwinkel |
Q246=+360 ;endwinkel |
Q247=30 ;winkelschritt |
Q241=5 ;anzahl |
Q200=2 ;sicherheitsabst. |
Q203=+0 ;koor. oberfl. |
Q204=100 ;2. s.-abstand |
Q301=1 ;fahren auf s. hoehe |
Q365=0 ;verfahrart |
9 l z+250 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
10 end pgm bohrb mm |


Bearbeitungszyklen: Konturtasche, Konturzüge

Weitere Informationen:
> SL-Zyklen
> KONTUR (Zyklus 14, DIN/ISO: G37)
> Überlagerte Konturen
> KONTUR-DATEN (Zyklus 20, DIN/ISO: G120)
> VORBOHREN (Zyklus 21, DIN/ISO: G121)
> RAEUMEN (Zyklus 22, DIN/ISO: G122)
> SCHLICHTEN TIEFE (Zyklus 23, DIN/ISO: G123)
> SCHLICHTEN SEITE (Zyklus 24, DIN/ISO: G124)
> KONTURZUG-Daten (Zyklus 270, DIN/ISO: G270)
> KONTUR-ZUG (Zyklus 25, DIN/ISO: G125)
> KONTURNUT WIRBELFRÄSEN (Zyklus 275, DIN/ISO: G275)
> KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276)
> Programmierbeispiele


SL-Zyklen

Weitere Informationen:
> Grundlagen
> Übersicht


Grundlagen

Beispiel: Schema: Abarbeiten mit SL-Zyklen
0 begin pgm sl2 mm
...
12 cycl def 14 kontur ...
13 cycl def 20 kontur-daten ...
...
16 cycl def 21 vorbohren ...
17 cycl call
...
18 cycl def 22 raeumen ...
19 cycl call
...
22 cycl def 23 schlichten tiefe ...
23 cycl call
...
26 cycl def 24 schlichten seite ...
27 cycl call
...
50 l z+250 r0 fmax m2
51 lbl 1
...
55 lbl 0
56 lbl 2
...
60 lbl 0
...
99 end pgm sl2 mm

Mit den SL-Zyklen können Sie komplexe Konturen aus bis zu 12 Teilkonturen (Taschen oder Inseln) zusammensetzen. Die einzelnen Teilkonturen geben Sie als Unterprogramme ein. Aus der Liste der Teilkonturen (Unterprogramm-Nummern), die Sie im Zyklus 14 KONTUR angeben, berechnet die TNC die Gesamtkontur.

Der Speicher für einen SL-Zyklus (alle Kontur-Unterprogramme) ist begrenzt. Die Anzahl der möglichen Konturelemente hängt von der Konturart (Innen-/Außenkontur) und der Anzahl der Teilkonturen ab und beträgt maximal 8192 Konturelemente.

SL-Zyklen führen intern umfangreiche und komplexe Berechnungen und daraus resultierende Bearbeitungen durch. Aus Sicherheitsgründen in jedem Fall vor dem Abarbeiten einen grafischen Programm-Test durchführen! Dadurch können Sie auf einfache Weise feststellen, ob die von der TNC ermittelte Bearbeitung richtig abläuft.

    Eigenschaften der Unterprogramme

  • Koordinaten-Umrechnungen sind erlaubt. Werden sie innerhalb der Teilkonturen programmiert, wirken sie auch in den nachfolgenden Unterprogrammen, müssen aber nach dem Zyklusaufruf nicht zurückgesetzt werden
  • Die TNC ignoriert Vorschübe F und Zusatz-Funktionen M
  • Die TNC erkennt eine Tasche, wenn Sie die Kontur innen umlaufen, z.B. Beschreibung der Kontur im Uhrzeigersinn mit Radius-Korrektur RR
  • Die TNC erkennt eine Insel, wenn Sie die Kontur außen umlaufen, z.B. Beschreibung der Kontur im Uhrzeigersinn mit Radius-Korrektur RL
  • Die Unterprogramme dürfen keine Koordinaten in der Spindelachse enthalten
  • Im ersten Koordinatensatz des Unterprogramms legen Sie die Bearbeitungsebene fest. Zusatzachsen U,V,W sind in sinnvoller Kombination erlaubt. Im ersten Satz grundsätzlich immer beide Achsen der Bearbeitungsebene definieren
  • Wenn Sie Q-Parameter verwenden, dann die jeweiligen Berechnungen und Zuweisungen nur innerhalb des jeweiligen Kontur-Unterprogrammes durchführen
  • Ist im Unterprogramm eine nicht geschlossene Kontur definiert, dann schließt die TNC die Kontur automatisch mit einer Geraden vom End- zum Startpunkt

    Eigenschaften der Bearbeitungszyklen

  • Die TNC positioniert vor jedem Zyklus automatisch auf den Sicherheits-Abstand
  • Jedes Tiefen-Niveau wird ohne Werkzeug-Abheben gefräst; Inseln werden seitlich umfahren
  • Um Freischneidemarkierungen zur vermeiden, fügt die TNC an nicht tangentialen „Innen-Ecken“ einen global definierbaren Verrundungsradius ein. Der im Zyklus 20 eingebbare Rundungsradius wirkt auf die Werkzeug-Mittelpunktsbahn, vergrößert also ggf. eine durch den Werkzeug-Radius definierte Rundung (gilt beim Ausräumen und Seiten-Schlichten)
  • Beim Seiten-Schlichten fährt die TNC die Kontur auf einer tangentialen Kreisbahn an
  • Beim Tiefen-Schlichten fährt die TNC das Werkzeug ebenfalls auf einer tangentialen Kreisbahn an das Werkstück (z.B.: Spindelachse Z: Kreisbahn in Ebene Z/X)
  • Die TNC bearbeitet die Kontur durchgehend im Gleichlauf bzw. im Gegenlauf

Mit Bit 4 des MP7420 legen Sie fest, wohin die TNC das Werkzeug am Ende der Zyklen 21 bis 24 positionieren soll:

  • Bit 4 = 0:
    Die TNC positioniert das Werkzeug am Zyklusende zunächst in der Werkzeugachse auf die im Zyklus definierte sichere Höhe (Q7) und anschließend in der Bearbeitungsebene auf die Position, auf der das Werkzeug beim Zyklus-Aufruf stand.
  • Bit4 = 1:
    Die TNC positioniert das Werkzeug am Zyklusende ausschließlich in der Werkzeugachse auf die im Zyklus definierte sichere Höhe (Q7). Beachten Sie, dass bei nachfolgenden Positionierungen keine Kollisionen auftreten!

Die Maßangaben für die Bearbeitung, wie Frästiefe, Aufmaße und Sicherheits-Abstand geben Sie zentral im Zyklus 20 als KONTUR-DATEN ein.


Übersicht

Zyklus | Softkey | Seite
14 KONTUR (zwingend erforderlich) |  | KONTUR (Zyklus 14, DIN/ISO: G37)
20 KONTUR-DATEN (zwingend erforderlich) |  | KONTUR-DATEN (Zyklus 20, DIN/ISO: G120)
21 VORBOHREN (wahlweise verwendbar) |  | VORBOHREN (Zyklus 21, DIN/ISO: G121)
22 RAEUMEN (zwingend erforderlich) |  | RAEUMEN (Zyklus 22, DIN/ISO: G122)
23 SCHLICHTEN TIEFE (wahlweise verwendbar) |  | SCHLICHTEN TIEFE (Zyklus 23, DIN/ISO: G123)
24 SCHLICHTEN SEITE (wahlweise verwendbar) |  | SCHLICHTEN SEITE (Zyklus 24, DIN/ISO: G124)

Erweiterte Zyklen:

Zyklus | Softkey | Seite
270 KONTURZUG-DATEN |  | KONTURZUG-Daten (Zyklus 270, DIN/ISO: G270)
25 KONTUR-ZUG |  | KONTUR-ZUG (Zyklus 25, DIN/ISO: G125)
275 KONTURNUT TROCHOIDAL |  | NUTENFRAESEN (Zyklus 253, DIN/ISO: G253)
276 KONTUR-ZUG 3D |  | KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276)


KONTUR (Zyklus 14, DIN/ISO: G37)

Weitere Informationen:
> Beim Programmieren beachten!
> Zyklusparameter


Beim Programmieren beachten!

In Zyklus 14 KONTUR listen Sie alle Unterprogramme auf, die zu einer Gesamtkontur überlagert werden sollen.

Beachten Sie vor dem Programmieren

Zyklus 14 ist DEF-Aktiv, das heißt ab seiner Definition im Programm wirksam.

In Zyklus 14 können Sie maximal 12 Unterprogramme (Teilkonturen) auflisten.


Zyklusparameter

Label-Nummern für die Kontur: Alle Label-Nummern der einzelnen Unterprogramme eingeben, die zu einer Kontur überlagert werden sollen. Jede Nummer mit der Taste ENT bestätigen und die Eingaben mit der Taste END abschließen. Eingabe von bis zu 12 Unterprogrammnummern 1 bis 254


Überlagerte Konturen

Weitere Informationen:
> Grundlagen
> Unterprogramme: Überlagerte Taschen
> „Summen“-Fläche
> „Differenz“-Fläche
> „Schnitt“-Fläche


Grundlagen

Beispiel: NC-Sätze
12 cycl def 14.0 kontur
13 cycl def 14.1 konturlabel 1/2/3/4

Taschen und Inseln können Sie zu einer neuen Kontur überlagern. Damit können Sie die Fläche einer Tasche durch eine überlagerte Tasche vergrößern oder eine Insel verkleinern.


Unterprogramme: Überlagerte Taschen

Die nachfolgenden Programmierbeispiele sind Kontur-Unterprogramme, die in einem Hauptprogramm von Zyklus 14 KONTUR aufgerufen werden.

Die Taschen A und B überlagern sich.

Die TNC berechnet die Schnittpunkte S1 und S2, sie müssen nicht programmiert werden.

Die Taschen sind als Vollkreise programmiert.

Unterprogramm 1: Tasche A
51 lbl 1
52 l x+10 y+50 rr
53 cc x+35 y+50
54 c x+10 y+50 dr-
55 lbl 0
Unterprogramm 2: Tasche B
56 lbl 2
57 l x+90 y+50 rr
58 cc x+65 y+50
59 c x+90 y+50 dr-
60 lbl 0


„Summen“-Fläche

    Beide Teilflächen A und B inklusive der gemeinsam überdeckten Fläche sollen bearbeitet werden:

  • Die Flächen A und B müssen Taschen sein.
  • Die erste Tasche (in Zyklus 14) muss außerhalb der zweiten beginnen.
Fläche A:
51 lbl 1
52 l x+10 y+50 rr
53 cc x+35 y+50
54 c x+10 y+50 dr-
55 lbl 0
Fläche B:
56 lbl 2
57 l x+90 y+50 rr
58 cc x+65 y+50
59 c x+90 y+50 dr-
60 lbl 0


„Differenz“-Fläche

    Fläche A soll ohne den von B überdeckten Anteil bearbeitet werden:

  • Fläche A muss Tasche und B muss Insel sein.
  • A muss außerhalb B beginnen.
  • B muss innerhalb von A beginnen
Fläche A:
51 lbl 1
52 l x+10 y+50 rr
53 cc x+35 y+50
54 c x+10 y+50 dr-
55 lbl 0
Fläche B:
56 lbl 2
57 l x+40 y+50 rl
58 cc x+65 y+50
59 c x+40 y+50 dr-
60 lbl 0


„Schnitt“-Fläche

    Die von A und B überdeckte Fläche soll bearbeitet werden. (Einfach überdeckte Flächen sollen unbearbeitet bleiben.)

  • A und B müssen Taschen sein.
  • A muss innerhalb B beginnen.
Fläche A:
51 lbl 1
52 l x+60 y+50 rr
53 cc x+35 y+50
54 c x+60 y+50 dr-
55 lbl 0
Fläche B:
56 lbl 2
57 l x+90 y+50 rr
58 cc x+65 y+50
59 c x+90 y+50 dr-
60 lbl 0


KONTUR-DATEN (Zyklus 20, DIN/ISO: G120)

Weitere Informationen:
> Beim Programmieren beachten!
> Zyklusparameter


Beim Programmieren beachten!

In Zyklus 20 geben Sie Bearbeitungs-Informationen für die Unterprogramme mit den Teilkonturen an.

Zyklus 20 ist DEF-Aktiv, das heißt Zyklus 20 ist ab seiner Definition im Bearbeitungs-Programm aktiv.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den jeweiligen Zyklus auf Tiefe 0 aus.

Die in Zyklus 20 angegebenen Bearbeitungs-Informationen gelten für die Zyklen 21 bis 24.

Wenn Sie SL-Zyklen in Q-Parameter-Programmen anwenden, dann dürfen Sie die Parameter Q1 bis Q20 nicht als Programm-Parameter benutzen.


Zyklusparameter

Beispiel: NC-Sätze
57 cycl def 20 kontur-daten
Q1=-20 ;fraestiefe
Q2=1 ;bahn-ueberlappung
Q3=+0.2 ;aufmass seite
Q4=+0.1 ;aufmass tiefe
Q5=+30 ;koor. oberflaeche
Q6=2 ;sicherheits-abst.
Q7=+80 ;sichere hoehe
Q8=0.5 ;rundungsradius
Q9=+1 ;drehsinn

Frästiefe Q1 (inkremental): Abstand Werkstückoberfläche – Taschengrund. Eingabebereich -99999,9999 bis 99999,9999

Bahn-Überlappung Faktor Q2: Q2 x Werkzeug-Radius ergibt die seitliche Zustellung k. Eingabebereich ‑0,0001 bis 1,9999

Schlichtaufmaß Seite Q3 (inkremental): Schlicht-Aufmaß in der Bearbeitungsebene. Eingabebereich ‑99999,9999 bis 99999,9999

Schlichtaufmaß Tiefe Q4 (inkremental): Schlicht-Aufmaß für die Tiefe. Eingabebereich -99999,9999 bis 99999,9999

Koordinate Werkstück-Oberfläche Q5 (absolut): Absolute Koordinate der Werkstück-Oberfläche. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q6 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q7 (absolut): Absolute Höhe, in der keine Kollision mit dem Werkstück erfolgen kann (für Zwischenpositionierung und Rückzug am Zyklus-Ende). Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Innen-Rundungsradius Q8: Verrundungs-Radius an Innen-„Ecken“; Eingegebener Wert bezieht sich auf die Werkzeug-Mittelpunktsbahn und wird verwendet, um weichere Verfahrbewegungen zwischen Konturelementen zu errechen. Q8 ist kein Radius, den die TNC als separates Konturelement zwischen programmierte Elemente einfügt! Eingabebereich 0 bis 99999,9999

Drehsinn? Q9: Bearbeitungs-Richtung für Taschen

  • Q9 = -1 Gegenlauf für Tasche und Insel
  • Q9 = +1 Gleichlauf für Tasche und Insel
  • Alternativ predef

Sie können die Bearbeitungs-Parameter bei einer Programm-Unterbrechung überprüfen und ggf. überschreiben.


VORBOHREN (Zyklus 21, DIN/ISO: G121)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Das Werkzeug bohrt mit dem eingegebenen Vorschub F von der aktuellen Position bis zur ersten Zustell-Tiefe
  2. Danach fährt die TNC das Werkzeug im Eilgang FMAX zurück und wieder bis zur ersten Zustell-Tiefe, verringert um den Vorhalte-Abstand t.
  3. Die Steuerung ermittelt den Vorhalte-Abstand selbsttätig:
    • Bohrtiefe bis 30 mm: t = 0,6 mm
    • Bohrtiefe über 30 mm: t = Bohrtiefe/50
    • maximaler Vorhalte-Abstand: 7 mm
  4. Anschließend bohrt das Werkzeug mit dem eingegebenen Vorschub F um eine weitere Zustell-Tiefe
  5. Die TNC wiederholt diesen Ablauf (1 bis 4), bis die eingegebene Bohrtiefe erreicht ist
  6. Am Bohrungsgrund zieht die TNC das Werkzeug, nach der Verweilzeit zum Freischneiden, mit FMAX zur Startposition zurück

Einsatz

Zyklus 21 VORBOHREN berücksichtigt für die Einstichpunkte das Schlichtaufmaß Seite und das Schlichtaufmaß Tiefe, sowie den Radius des Ausräum-Werkzeugs. Die Einstichpunkte sind gleichzeitig die Startpunkte fürs Räumen.


Beim Programmieren beachten!

Beachten Sie vor dem Programmieren

Die TNC berücksichtigt einen im TOOL CALL-Satz programmierten Deltawert DR nicht zur Berechnung der Einstichpunkte.

An Engstellen kann die TNC ggf. nicht mit einem Werkzeug vorgebohren das größer ist als das Schruppwerkzeug.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
58 cycl def 21 vorbohren
Q10=+5 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q13=1 ;ausraeum-werkzeug

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird (Vorzeichen bei negativer Arbeitsrichtung „–“). Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11: Bohrvorschub in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Ausräum-Werkzeug Nummer/Name Q13 bzw. QS13: Nummer oder Name des Ausräum-Werkzeugs. Eingabebereich 0 bis 32767,9 bei Nummerneingabe, maximal 32 Zeichen bei Namenseingabe


RAEUMEN (Zyklus 22, DIN/ISO: G122)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug über den Einstichpunkt; dabei wird das Schlichtaufmaß Seite berücksichtigt
  2. In der ersten Zustell-Tiefe fräst das Werkzeug mit dem Fräsvorschub Q12 die Kontur von innen nach außen
  3. Dabei werden die Inselkonturen (hier: C/D) mit einer Annäherung an die Taschenkontur (hier: A/B) freigefräst
  4. Im nächsten Schritt fährt die TNC das Werkzeug auf die nächste Zustell-Tiefe und wiederholt den Ausräum-Vorgang, bis die programmierte Tiefe erreicht ist
  5. Abschließend fährt die TNC das Werkzeug auf die Sichere Höhe zurück


Beim Programmieren beachten!

Ggf. Fräser mit einem über Mitte schneidenden Stirnzahn verwenden (DIN 844), oder Vorbohren mit Zyklus 21.

    Das Eintauchverhalten des Zyklus 22 legen Sie mit dem Parameter Q19 und in der Werkzeug-Tabelle mit den Spalten ANGLE und LCUTS fest:

  • Wenn Q19=0 definiert ist, dann taucht die TNC grundsätzlich senkrecht ein, auch wenn für das aktive Werkzeug ein Eintauchwinkel (ANGLE) definiert ist
  • Wenn Sie ANGLE=90° definieren, taucht die TNC senkrecht ein. Als Eintauchvorschub wird dann der Pendelvorschub Q19 verwendet
  • Wenn der Pendelvorschub Q19 im Zyklus 22 definiert ist und ANGLE zwischen 0.1 und 89.999 in der Werkzeug-Tabelle definiert ist, taucht die TNC mit dem festgelegten ANGLE helixförmig ein
  • Wenn der Pendelvorschub im Zyklus 22 definiert ist und kein ANGLE in der Werkzeug-Tabelle steht, dann gibt die TNC eine Fehlermeldung aus
  • Sind die Geometrieverhältnisse so, dass nicht helixförmig eingetaucht werden kann (Nutgeometrie), so versucht die TNC pendelnd einzutauchen. Die Pendellänge berechnet sich dann aus LCUTS und ANGLE (Pendellänge = LCUTS / tan ANGLE)

Bei Taschenkonturen mit spitzen Innenecken kann bei Verwendung eines Überlappungsfaktors von größer 1 Restmaterial beim Ausräumen stehen bleiben. Insbesondere die innerste Bahn per Testgrafik prüfen und ggf. den Überlappungsfaktor geringfügig ändern. Dadurch lässt sich eine andere Schnittaufteilung erreichen, was oftmals zum gewünschten Ergebnis führt.

Beim Nachräumen berücksichtigt die TNC einen definierten Verschleißwert DR des Vorräumwerkzeuges nicht.

Die Vorschubreduzierung über den Parameter Q401 ist eine FCL3-Funktion und steht nach einem Software-Update nicht automatisch zur Verfügung (siehe Entwicklungsstand (Upgrade-Funktionen)).

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
59 cycl def 22 raeumen
Q10=+5 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q12=750 ;vorschub raeumen
Q18=1 ;vorraeum-werkzeug
Q19=150 ;vorschub pendeln
Q208=99999 ;vorschub rueckzug
Q401=80 ;vorschubreduzierung
Q404=0 ;nachraeumstrategie

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11: Eintauchvorschub in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Ausräumen Q12: Fräsvorschub in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorräum-Werkzeug Q18 bzw. QS18: Nummer oder Name des Werkzeugs, mit dem die TNC bereits vorgeräumt hat. Umschalten auf Namen-Eingabe: Softkey werkzeug-name drücken. Die TNC fügt das Anführungszeichen oben automatisch ein, wenn Sie das Eingabefeld verlassen. Falls nicht vorgeräumt wurde „0“ eingeben; falls Sie hier eine Nummer oder einen Namen eingeben, räumt die TNC nur den Teil aus, der mit dem Vorräum-Werkzeug nicht bearbeitet werden konnte. Falls der Nachräumbereich nicht seitlich anzufahren ist, taucht die TNC pendelnd ein; dazu müssen Sie in der Werkzeug-Tabelle TOOL.T, die Schneidenlänge LCUTS und den maximalen Eintauchwinkel ANGLE des Werkzeugs definieren. Ggf. gibt die TNC eine Fehlermeldung aus. Eingabebereich 0 bis 32767,9 bei Nummerneingabe, maximal 32 Zeichen bei Namenseingabe

Vorschub Pendeln Q19: Pendelvorschub in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Rückzug Q208: Verfahrgeschwindigkeit des Werkzeugs beim Herausfahren nach der Bearbeitung in mm/min. Wenn Sie Q208=0 eingeben, dann fährt die TNC das Werkzeug mit Vorschub Q12 heraus. Eingabebereich 0 bis 99999,9999 alternativ fmax FAUTO, predef

Vorschubfaktor in % Q401: Prozentualer Faktor, auf den die TNC den Bearbeitungs-Vorschub (Q12) reduziert, sobald das Werkzeug beim Ausräumen mit dem vollen Umfang im Material verfährt. Wenn Sie die Vorschubreduzierung nutzen, dann können Sie den Vorschub Ausräumen so groß definieren, dass bei der im Zyklus 20 festgelegten Bahn-Überlappung (Q2) optimale Schnittbedingungen herrschen. Die TNC reduziert dann an Übergängen oder Engstellen den Vorschub wie von Ihnen definiert, so dass die Bearbeitungszeit insgesamt kleiner sein sollte. Eingabebereich 0,0001 bis 100,0000

Nachräumstrategie Q404: Festlegen, wie die TNC beim Nachräumen verfahren soll, wenn der Radius des Nachräumwerkzeuges größer als die Hälfte des Vorräumwerkzeuges ist:

  • Q404 = 0
    Das Werkzeug zwischen nachzuräumenden Bereichen auf aktueller Tiefe entlang der Kontur verfahren
  • Q404 = 1
    Das Werkzeug zwischen nachzuräumenden Bereichen auf Sicherheits-Abstand abheben und zum Startpunkt des nächsten Ausräumbereiches fahren


SCHLICHTEN TIEFE (Zyklus 23, DIN/ISO: G123)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Die TNC fährt das Werkzeug weich (vertikaler Tangentialkreis) auf die zu bearbeitende Fläche, sofern hierfür genügend Platz vorhanden ist. Bei beengten Platzverhältnissen fährt die TNC das Werkzeug senkrecht auf Tiefe. Anschließend wird das beim Ausräumen verbliebene Schlichtaufmaß abgefräst.


Beim Programmieren beachten!

Die TNC ermittelt den Startpunkt fürs Schlichten selbständig. Der Startpunkt ist abhängig von den Platzverhältnissen in der Tasche.

Der Einfahrradius zum Anpositionieren auf die Endtiefe ist intern fest definiert und unabhängig vom Eintauchwinkel des Werkzeugs.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
60 cycl def 23 schlichten tiefe
Q11=100 ;vorschub tiefenz.
Q12=350 ;vorschub raeumen
Q208=99999 ;vorschub rueckzug

Vorschub Tiefenzustellung Q11: Verfahrgeschwindigkeit des Werkzeugs beim Einstechen. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Ausräumen Q12: Fräsvorschub. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Rückzug Q208: Verfahrgeschwindigkeit des Werkzeugs beim Herausfahren nach der Bearbeitung in mm/min. Wenn Sie Q208=0 eingeben, dann fährt die TNC das Werkzeug mit Vorschub Q12 heraus. Eingabebereich 0 bis 99999,9999 alternativ fmax, FAUTO, predef


SCHLICHTEN SEITE (Zyklus 24, DIN/ISO: G124)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Die TNC fährt das Werkzeug auf einer Kreisbahn tangential an die einzelnen Teilkonturen. Die TNC schlichtet jede Teilkontur separat.


Beim Programmieren beachten!

Die Summe aus Schlichtaufmaß Seite (Q14) und Schlichtwerkzeug-Radius muss kleiner sein als die Summe aus Schlichtaufmaß Seite (Q3,Zyklus 20) und Räumwerkzeug-Radius.

Wenn Sie Zyklus 24 abarbeiten ohne zuvor mit Zyklus 22 ausgeräumt zu haben, gilt oben aufgestellte Berechnung ebenso; der Radius des Räum-Werkzeugs hat dann den Wert „0“.

Sie können Zyklus 24 auch zum Konturfräsen verwenden. Sie müssen dann

  • die zu fräsende Kontur als einzelne Insel definieren (ohne Taschenbegrenzung) und
  • im Zyklus 20 das Schlichtaufmaß (Q3) größer eingeben, als die Summe aus Schlichtaufmaß Q14 + Radius des verwendeten Werkzeugs

Die TNC ermittelt den Startpunkt fürs Schlichten selbständig. Der Startpunkt ist abhängig von den Platzverhältnissen in der Tasche und dem im Zyklus 20 programmierten Aufmaß. Die Positionierlogik zum Startpunkt der Schlichtbearbeitung führt die TNC wie folgt aus: Anfahren des Startpunktes in der Bearbeitungsebene, anschließend Fahren auf Tiefe in Werkzeug-Achsrichtung.

Die TNC berechnet den Startpunkt auch in Abhängigkeit von der Reihenfolge beim Abarbeiten. Wenn Sie den Schlichtzyklus mit der Taste GOTO anwählen und das Programm dann starten, kann der Startpunkt an einer anderen Stelle liegen, als wenn Sie das Programm in der definierten Reihenfolge abarbeiten.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
61 cycl def 24 schlichten seite
Q9=+1 ;drehsinn
Q10=+5 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q12=350 ;vorschub raeumen
Q14=+0 ;aufmass seite
Q438=+0 ;AUSRAEUM-WERKZEUG

Drehsinn? Uhrzeigersinn = –1 Q9:
Bearbeitungsrichtung:
+1: Drehung im Gegen-Uhrzeigersinn
–1: Drehung im Uhrzeigersinn
Alternativ predef

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11: Eintauchvorschub. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Ausräumen Q12: Fräsvorschub. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Schlichtaufmaß Seite Q14 (inkremental): Aufmaß für mehrmaliges Schlichten; der letzte Schlicht-Rest wird ausgeräumt, wenn Sie Q14 = 0 eingeben. Eingabebereich -99999,9999 bis 99999,9999

Ausraeum-Werkzeug Q438 bzw. QS438: Nummer oder Name des Werkzeugs, mit dem die TNC die Konturtasche ausgeräumt hat. Umschalten auf Namen-Eingabe: Softkey werkzeug-name drücken. Die TNC fügt das Anführungszeichen oben automatisch ein, wenn Sie das Eingabefeld verlassen. Der Startpunkt für den Anfahrkreis der Schlichtbahn liegt auf der äußersten Räumbahn des Zyklus 22, den die TNC aus der Summe des Ausräumfräserradius und dem Seitenaufmass Q3 des Zyklus 20 ermittelt. Bei Eingabe von Q438=0 (Ausräum-Werkzeug gleich Nullwerkzeug), können Sie über das Schlichtaufmaß Q3 im Zyklus 20 den Abstand des Startpunktes von der Kontur festlegen. Eingabebereich -32767,9 bis +32767,9 bei Nummerneingabe, maximal 32 Zeichen bei Namenseingabe


KONTURZUG-Daten (Zyklus 270, DIN/ISO: G270)

Weitere Informationen:
> Beim Programmieren beachten!
> Zyklusparameter


Beim Programmieren beachten!

Mit diesem Zyklus können Sie - wenn gewünscht - verschiedene Eigenschaften der Zyklen 25 Kontur-Zug und 276 Kontur-Zug 3D festlegen.

Beachten Sie vor dem Programmieren

Zyklus 270 ist DEF-Aktiv, das heißt Zyklus 270 ist ab seiner Definition im Bearbeitungs-Programm aktiv.

Die TNC setzt den Zyklus 270 zurück, sobald Sie einen beliebigen anderen SL-Zyklus definieren (Ausnahme: Zyklus 25 und Zyklus 276).

Bei Verwendung von Zyklus 270 im Kontur-Unterprogramm keine Radius-Korrektur definieren.

An- und Wegfahreigenschaften werden von der TNC immer identisch (symmetrisch) durchgeführt.

Zyklus 270 vor Zyklus 25 bzw. Zyklus 276 definieren.


Zyklusparameter

Beispiel: NC-Sätze
62 cycl def 270 konturzug-Daten
Q390=1 ;anfahrart
Q391=1 ;radius-korrektur
Q392=3 ;radius
Q393=+45 ;mittelpunktswinkel
Q394=+2 ;abstand

Anfahrart/Wegfahrart Q390: Definition der Anfahrart/Wegfahrart:

  • Q390 = 1:
    Kontur tangential auf einem Kreisbogen anfahren
  • Q390 = 2:
    Kontur tangential auf einer Geraden anfahren
  • Q390 = 3:
    Kontur senkrecht anfahren

Radius-Korr. (0=R0/1=RL/2=RR) Q391: Definition der Radius-Korrektur:

  • Q391 = 0:
    Definierte Kontur ohne Radius-Korrektur bearbeiten
  • Q391 = 1:
    Definierte Kontur linkskorrigiert bearbeiten
  • Q391 = 2:
    Definierte Kontur rechtskorrigiert bearbeiten

Anfahrradius/Wegfahrradius Q392: Nur wirksam, wenn tangentiales Anfahren auf einem Kreisbogen gewählt ist. Radius des Einfahrkreises/Wegfahrkreises. Eingabebereich 0 bis 99999,9999

Mittelpunktswinkel Q393: Nur wirksam, wenn tangentiales Anfahren auf einem Kreisbogen gewählt ist. Öffnungswinkel des Einfahrkreises. Eingabebereich 0 bis 99999,9999

Abstand Hilfspunkt Q394: Nur wirksam, wenn tangentiales Anfahren auf einer Geraden oder senkrechtes Anfahren gewählt ist. Abstand des Hilfspunktes, von dem aus die TNC die Kontur anfahren soll. Eingabebereich 0 bis 99999,9999


KONTUR-ZUG (Zyklus 25, DIN/ISO: G125)

Weitere Informationen:
> Zyklusablauf
> Beim Programmmiern beachten!
> Zyklusparameter


Zyklusablauf

Mit diesem Zyklus lassen sich zusammen mit Zyklus 14 KONTUR -offene und geschlossene Konturen bearbeiten.

    Der Zyklus 25 KONTUR-ZUG bietet gegenüber der Bearbeitung einer Kontur mit Positioniersätzen erhebliche Vorteile:

  • Die TNC überwacht die Bearbeitung auf Hinterschneidungen und Konturverletzungen. Kontur mit der Test-Grafik überprüfen
  • Ist der Werkzeug-Radius zu groß, so können Sie die Kontur an Innenecken mit der automatischen Restmaterialerkennung nachbearbeiten
  • Die Bearbeitung lässt sich durchgehend im Gleich- oder Gegenlauf ausführen. Die Fräsart bleibt sogar erhalten, wenn Sie Konturen in einer Achse spiegeln
  • Bei mehreren Zustellungen kann die TNC das Werkzeug hin und her verfahren (Pendelbearbeitung): Dadurch verringert sich die Bearbeitungszeit
  • Sie können Aufmaße eingeben, um in mehreren Arbeitsgängen zu schruppen und zu schlichten
  • Über den Zyklus 270 KONTURZUG-DATEN können Sie das Verhalten des Zyklus 25 komfortabel einstellen


Beim Programmmiern beachten!

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Bei Verwendung von Zyklus 25 KONTUR-ZUG dürfen Sie im Zyklus 14 KONTUR nur ein Kontur-Unterprogramm definieren.

Der Speicher für einen SL-Zyklus ist begrenzt. Sie können in einem SL-Zyklus maximal 4090 Konturelemente programmieren.

Die TNC benötigt den Zyklus 20 KONTUR-DATEN nicht in Verbindung mit Zyklus 25.

Im Kontur-Unterprogramm keine Anfahr-/Wegfahr-Sätze APPR/DEP verwenden.

Im Kontur-Unterprogramm keine Q-Parameter-Berechnungen durchführen.

Nutzen Sie den Zyklus KONTURZUG-DATEN, um das Verhalten des Zyklus 25 beim Abarbeiten einzustellen (siehe KONTURZUG-Daten (Zyklus 270, DIN/ISO: G270))

Achtung Kollisionsgefahr!

Um mögliche Kollisionen zu vermeiden:

  • Direkt nach Zyklus 25 keine Kettenmaße programmieren, da sich Kettenmaße auf die Position des Werkzeugs am Zyklus-Ende beziehen
  • In allen Hauptachsen eine definierte (absolute) Position anfahren, da die Position des Werkzeugs am Zyklusende nicht mit der Position am Zyklusanfang übereinstimmt.
  • Wenn Sie zum An- und Wegfahren an die Kontur APPR- bzw. DEP-Sätze verwenden, dann überwacht die TNC, ob diese Sätze die Kontur verletzen würden.

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
62 cycl def 25 kontur-zug
Q1=-20 ;fraestiefe
Q3=+0 ;aufmass seite
Q5=+0 ;koor. oberflaeche
Q7=+50 ;sichere hoehe
Q10=+5 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q12=350 ;vorschub fraesen
Q15=-1 ;fraesart
Q18=0 ;vorraeum-werkzeug
Q446=0.01 ;Restmaterial
Q447=10 ;VerbindungsaBstand
Q448=2 ;Bahnverlaengerung

Frästiefe Q1 (inkremental): Abstand zwischen Werkstück-Oberfläche und Konturgrund. Eingabebereich -99999,9999 bis 99999,9999

Schlichtaufmaß Seite Q3 (inkremental): Schlichtaufmaß in der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Koord. Werkstück-Oberfläche Q5 (absolut): Absolute Koordinate der Werkstück Oberfläche bezogen auf den Werkstück-Nullpunkt. Eingabebereich ‑99999,9999 bis 99999,9999

Sichere Höhe Q7 (absolut): Absolute Höhe, in der keine Kollision zwischen Werkzeug und Werkstück erfolgen kann; Werkzeug-Rückzugposition am Zyklus-Ende. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11:Vorschub bei Verfahrbewegungen in der Spindelachse. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Fräsen Q12: Vorschub bei Verfahrbewegungen in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Fräsart? Gegenlauf = –1 Q15: Gleichlauf-Fräsen: Eingabe = +1 Gegenlauf-Fräsen: Eingabe = –1 Abwechselnd im Gleich- und Gegenlauf fräsen bei mehreren Zustellungen: Eingabe = 0

Vorräum-Werkzeug Q18 bzw. QS18: Nummer oder Name des Werkzeugs, mit dem die TNC die Kontur bereits vorgeräumt hat. Umschalten auf Namen-Eingabe: Softkey werkzeug-name drücken. Die TNC fügt das Anführungszeichen oben automatisch ein, wenn Sie das Eingabefeld verlassen. Falls nicht vorgeräumt wurde „0“ eingeben, dann bearbeitet die TNC die Kontur so wie es mit dem aktiven Werkzeug maximal möglich ist; falls Sie hier eine Nummer oder einen Namen eingeben, bearbeitet die TNC nur den Konturteil, der mit dem Vorräum-Werkzeug nicht bearbeitet werden konnte. Eingabebereich 0 bis 32767,9 bei Nummerneingabe, maximal 32 Zeichen bei Namenseingabe

Akzeptiertes Restmaterial Q446: Restmaterialdicke, ab der die TNC die Kontur nicht mehr bearbeiten soll. Standardwert 0.01 mm. Eingabebereich 0 bis +9,999

Maximaler Verbindungsabstand Q447: Maximaler Abstand zwischen zwei nachzuräumenden Bereichen, zwischen denen das Werkzeug noch ohne Abhebebewegung auf der Bearbeitungstiefe entlang der Kontur verfahren soll. Eingabebereich 0 bis 999

Bahnverlängerung Q448: Betrag für die Verlängerung der Werkzeugbahn am Konturanfang und Konturende. Die TNC verlängert die Werkzeugbahn grundsätzlich immer parallel zur Kontur. Anfahr- und Wegfahrverhalten beim Nachräumen über Zyklus 270 festlegen. Eingabebereich 0 bis 99,999


KONTURNUT WIRBELFRÄSEN (Zyklus 275, DIN/ISO: G275)

Weitere Informationen:
> Zyklusablauf
> Beim Programmmiern beachten!
> Zyklusparameter


Zyklusablauf

Beispiel: Schema KONTURNUT TROCHOIDAL
0 begin pgm CYC275 mm
...
12 cycl def 14.0 kontur
13 cycl def 14.1 konturlabel 10
14 cycl def 275 KONTURNUT WIRBELFR. ...
15 cycl call M3
...
50 l z+250 r0 fmax m2
51 lbl 10
...
55 lbl 0
...
99 end pgm CYC275 mm

Mit diesem Zyklus lassen sich - in Verbindung mit Zyklus 14 KONTUR -offene Nuten oder Konturnuten mit dem Wirbelfräsverfahren vollständig bearbeiten.

Beim Wirbelfräsen können Sie mit großer Schnitttiefe und hoher Schnittgeschwindigkeit fahren, da durch die gleichmäßigen Schnittbedingungen keine verschleißsteigernden Einflüsse auf das Werkzeug ausgeübt werden. Beim Einsatz von Schneidplatten können Sie die komplette Schneidenlänge nutzen und steigern dadurch das erzielbare Spanvolumen pro Zahn. Zudem schont das Wirbelfräsen die Maschinenmechanik. Wenn Sie diese Fräsmethode zusätzlich noch mit der integrierten adaptiven Vorschubregelung AFC (Software-Option, siehe Benutzer-Handbuch Klartext-Dialog) kombinieren, lassen sich enorme Zeiteinsparung erzielen.

    In Abhängigkeit von der Wahl der Zyklus-Parameter stehen folgende Bearbeitungsalternativen zur Verfügung:

  • Komplettbearbeitung: Schruppen, Schlichten SeiteNur SchruppenNur Schlichten Seite
  1. Schruppen Die Konturbeschreibung der offenen Nut muss immer mit einem Approach-Satz (appr) beginnen.
  2. Das Werkzeug fährt mit Positionierlogik auf den Startpunkt der Bearbeitung, der sich aus den im APPR-Satz definierten Parametern ergibt und positioniert dort senkrecht auf die erste Zustell-Tiefe
  3. Die TNC räumt die Nut in kreisförmigen Bewegungen bis zum Konturendpunkt aus. Während der kreisförmigen Bewegung versetzt die TNC das Werkzeug in Bearbeitungsrichtung um eine von Ihnen definierbare Zustellung (Q436). Gleich-/Gegenlauf der kreisförmigen Bewegung legen Sie über den Parameter Q351 fest
  4. Am Konturendpunkt fährt die TNC das Werkzeug auf sichere Höhe und positioniert zurück auf den Startpunkt der Konturbeschreibung
  5. Dieser Vorgang wiederholt sich, bis die programmierte Nuttiefe erreicht ist
  1. Schlichten
  5. Sofern ein Schlichtaufmaß definiert ist, schlichtet die TNC die Nutwände, falls eingegeben in mehreren Zustellungen. Die Nutwand fährt die TNC dabei ausgehend vom sich ergebenden Startpunkt des APPR-Satzes an. Dabei berücksichtigt die TNC Gleich-/Gegenlauf


Beim Programmmiern beachten!

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Bei Verwendung von Zyklus 275 konturnut WIRBELFRÄSEN dürfen Sie im Zyklus 14 KONTUR nur ein Kontur-Unterprogramm definieren.

Im Kontur-Unterprogramm definieren Sie die Mittelline der Nut mit allen zur Verfügung stehenden Bahnfunktionen.

Der Speicher für einen SL-Zyklus ist begrenzt. Sie können in einem SL-Zyklus maximal 4090 Konturelemente programmieren.

Die TNC benötigt den Zyklus 20 KONTUR-DATEN nicht in Verbindung mit Zyklus 275.

Das Bearbeiten einer geschlossenen Kontur ist mit dem Zyklus 275 nicht möglich.

Achtung Kollisionsgefahr!

Um mögliche Kollisionen zu vermeiden:

  • Direkt nach Zyklus 275 keine Kettenmaße programmieren, da sich Kettenmaße auf die Position des Werkzeugs am Zyklus-Ende beziehen
  • In allen Hauptachsen eine definierte (absolute) Position anfahren, da die Position des Werkzeugs am Zyklusende nicht mit der Position am Zyklusanfang übereinstimmt.

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Bearbeitungs-Umfang (0/1/2)Q215: Bearbeitungs-Umfang festlegen:
0: Schruppen und Schlichten
1: Nur Schruppen
2: Nur Schlichten
Die TNC führt das Seitenschlichten auch dann aus, wenn das Schlichtaufmaß (Q368) mit 0 definiert ist

Nutbreite Q219: Breite der Nut eingeben; wenn Nutbreite gleich Werkzeug-Durchmesser eingegeben, dann fährt die TNC das Werkzeug lediglich entlang der definierten Kontur. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Seite Q368 (inkremental): Schlicht-Aufmaß in der Bearbeitungsebene

Zustellung pro Umlauf Q436 (absolut): Wert, um den die TNC das Werkzeug pro Umlauf in Bearbeitungsrichtung versetzt. Eingabebereich: 0 bis 99999,9999

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Fräsart Q351: Art der Fräsbearbeitung bei M3: +1 = Gleichlauffräsen –1 = Gegenlauffräsen alternativ predef

Tiefe Q201 (inkremental): Abstand Werkstück-Oberfläche – Nutgrund. Eingabebereich -99999,9999 bis 99999,9999

Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird; Wert größer 0 eingeben. Eingabebereich 0 bis 99999,9999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Fahren auf Tiefe in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ

Zustellung Schlichten Q338 (inkremental): Maß, um welches das Werkzeug in der Spindelachse beim Schlichten zugestellt wird. Q338=0: Schlichten in einer Zustellung. Eingabebereich 0 bis 99999,9999

Vorschub Schlichten Q385: Verfahrgeschwindigkeit des Werkzeugs beim Seitenschlichten in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ
Beispiel: NC-Sätze
8 cycl def 275 KONTURNUT WIRBELFR.
Q215=0 ;BEARBEITUNGS-UMFANG
Q219=12 ;nutbreite
Q368=0.2 ;AUFMASS SEITE
Q436=2 ;zust. pro umlauf
Q207=500 ;vorschub fraesen
Q351=+1 ;fraesart
Q201=-20 ;tiefe
Q202=5 ;zustell-tiefe
Q206=150 ;VORSCHUB TIEFENZ.
Q338=5 ;zust. schlichten
Q385=500 ;VORSCHUB schlichten
Q200=2 ;sicherheits-abst.
Q203=+0 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.
Q366=2 ;EINTAUCHEN
9 cycl call fmax m3

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koordinate Werkstück-Oberfläche Q203 (absolut): Absolute Koordinate der Werkstück-Oberfläche. Eingabebereich -99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef

Eintauchstrategie Q366: Art der Eintauchstrategie:

  • 0 = senkrecht eintauchen. Unabhängig vom in der Werkzeug-Tabelle definierten Eintauchwinkel ANGLE taucht die TNC senkrecht ein
  • 1: Ohne Funktion
  • 2 = pendelnd eintauchen. In der Werkzeug-Tabelle muss für das aktive Werkzeug der Eintauchwinkel ANGLE ungleich 0 definiert sein. Ansonsten gibt die TNC eine Fehlermeldung aus
  • Alternativ predef


KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276)

Weitere Informationen:
> Zyklusablauf
> Beim Programmmiern beachten!
> Zyklusparameter


Zyklusablauf

Mit diesem Zyklus lassen sich zusammen mit Zyklus 14 KONTUR -offene und geschlossene Konturen bearbeiten. Bei Bedarf können Sie die Kontur an Innenecken auch mit der automatischen Restmaterialerkennung nachbearbeiten.

Der Zyklus 276 KONTUR-ZUG 3D interpretiert im Vergleich zum Zyklus 25 Kontur-ZUG auch Koordinaten in der Werkzeug-Achse (Z-Achse), die im Kontur-Unterprogramm definiert sind. Dadurch lassen sich beispeilsweise Umrisse, die im CAM-System erzeugt wurden, auf einfache Weise bearbeiten.

  1. Bearbeiten einer Kontur ohne Zustellung: Frästiefe Q1=0
  2. Das Werkzeug fährt mit Positionierlogik auf den Startpunkt der Bearbeitung, der sich durch den ersten Konturpunkt der gewählten Bearbeitungsrichtung und der gewählten Anfahrfunktion ergibt
  3. Die TNC fährt tangential an die Kontur an und bearbeitet diese bis zum Konturende
  4. Am Konturendpunkt fährt die TNC das Werkzeug tangential von der Kontur weg. Die Wegfahrfunktion führt die TNC identisch zur Anfahrfunktion aus
  5. Abschließend positioniert die TNC das Werkzeug auf die sichere Höhe
  1. Bearbeiten einer Kontur mit Zustellung: Frästiefe Q1 ungleich 0 und Zustell-Tiefe Q10 definiert
  2. Das Werkzeug fährt mit Positionierlogik auf den Startpunkt der Bearbeitung, der sich durch den ersten Konturpunkt der gewählten Bearbeitungsrichtung und der gewählten Anfahrfunktion ergibt
  3. Die TNC fährt tangential an die Kontur an und bearbeitet diese bis zum Konturende
  4. Am Konturendpunkt fährt die TNC das Werkzeug tangential von der Kontur weg. Die Wegfahrfunktion führt die TNC identisch zur Anfahrfunktion aus
  5. Wenn pendelnde Bearbeitung gewählt ist (Q15=0), fährt die TNC auf die nächste Zustell-Tiefe und bearbeitet die Kontur zurück bis zum ursprünglichen Startpunkt. Ansonsten fährt die TNC das Werkzeug auf sicherer Höhe zurück zum Startpunkt der Bearbeitung und dort auf die nächste Zustell-Tiefe. Die Wegfahrfunktion führt die TNC identisch zur Anfahrfunktion aus
  6. Dieser Vorgang wiederholt sich, bis die programmierte Tiefe erreicht ist
  7. Abschließend positioniert die TNC das Werkzeug auf die sichere Höhe


Beim Programmmiern beachten!

Der erste Satz im Kontur-Unterprogramm muss Werte in allen drei Achsen X, Y und Z enthalten.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann fährt die TNC den Zyklus auf den im Kontur-Unterprogramm definierten Koordinaten der Werkzeug-Achse.

Bei Verwendung von Zyklus 25 KONTUR-ZUG dürfen Sie im Zyklus 14 KONTUR nur ein Kontur-Unterprogramm definieren.

Der Speicher für einen SL-Zyklus ist begrenzt. Sie können in einem SL-Zyklus maximal 4090 Konturelemente programmieren.

Die TNC benötigt den Zyklus 20 KONTUR-DATEN nicht in Verbindung mit Zyklus 276.

Darauf achten, dass das Werkzeug beim Zyklus-Aufruf in der Werkzeug-Achse über dem Werkstück steht, ansonsten gibt die TNC ggf. eine Fehlermeldung aus.

Nutzen Sie den Zyklus KONTURZUG-DATEN, um das Verhalten des Zyklus 276 beim Abarbeiten einzustellen (siehe KONTURZUG-Daten (Zyklus 270, DIN/ISO: G270))

Achtung Kollisionsgefahr!

Um mögliche Kollisionen zu vermeiden:

  • Werkzeug vor Zyklus-Aufruf in der Werkzeugachse so positionieren, dass die TNC den Konturstartpunkt ohne Kollision anfahren kann. Wenn die Istposition des Werkzeugs beim Zyklus-Aufruf unterhalb der sicheren Höhe liegt, dann gibt die TNC eine Fehlermeldung aus.
  • Wenn Sie zum An- und Wegfahren an die Kontur APPR- bzw. DEP-Sätze verwenden, dann überwacht die TNC, ob diese Sätze die Kontur verletzen würden.
  • Direkt nach Zyklus 276 keine Kettenmaße programmieren, da sich Kettenmaße auf die Position des Werkzeugs am Zyklus-Ende beziehen
  • In allen Hauptachsen eine definierte (absolute) Position anfahren, da die Position des Werkzeugs am Zyklusende nicht mit der Position am Zyklusanfang übereinstimmt.

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
62 cycl def 276 kontur-zug 3D
Q1=-20 ;fraestiefe
Q3=+0 ;aufmass seite
Q7=+50 ;sichere hoehe
Q10=+5 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q12=350 ;vorschub fraesen
Q15=-1 ;fraesart
Q18=0 ;vorraeum-werkzeug
Q446=0.01 ;Restmaterial
Q447=10 ;VerbindungsaBstand
Q448=2 ;Bahnverlaengerung

Frästiefe Q1 (inkremental): Abstand zwischen Werkstück-Oberfläche und Konturgrund. Wenn Frästiefe Q1 = 0 und Zustell-Tiefe Q10 = 0 definiert, dann bearbeitet die TNC die Kontur entsprechend den im Kontur-Unterprogramm definierten Z-Werten. Eingabebereich -99999,9999 bis 99999,9999

Schlichtaufmaß Seite Q3 (inkremental): Schlichtaufmaß in der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Sichere Höhe Q7 (absolut): Absolute Höhe, in der keine Kollision zwischen Werkzeug und Werkstück erfolgen kann; Werkzeug-Rückzugposition am Zyklus-Ende. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird. Nur wirksam, wenn Frästiefe Q1 ungleich 0 definiert ist. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11:Vorschub bei Verfahrbewegungen in der Spindelachse. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Fräsen Q12: Vorschub bei Verfahrbewegungen in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Fräsart? Gegenlauf = –1 Q15: Gleichlauf-Fräsen: Eingabe = +1 Gegenlauf-Fräsen: Eingabe = –1 Abwechselnd im Gleich- und Gegenlauf fräsen bei mehreren Zustellungen: Eingabe = 0

Vorräum-Werkzeug Q18 bzw. QS18: Nummer oder Name des Werkzeugs, mit dem die TNC die Kontur bereits vorgeräumt hat. Umschalten auf Namen-Eingabe: Softkey werkzeug-name drücken. Die TNC fügt das Anführungszeichen oben automatisch ein, wenn Sie das Eingabefeld verlassen. Falls nicht vorgeräumt wurde „0“ eingeben, dann bearbeitet die TNC die Kontur so wie es mit dem aktiven Werkzeug maximal möglich ist; falls Sie hier eine Nummer oder einen Namen eingeben, bearbeitet die TNC nur den Konturteil, der mit dem Vorräum-Werkzeug nicht bearbeitet werden konnte. Eingabebereich 0 bis 32767,9 bei Nummerneingabe, maximal 32 Zeichen bei Namenseingabe

Akzeptiertes Restmaterial Q446: Restmaterialdicke, ab der die TNC die Kontur nicht mehr bearbeiten soll. Standardwert 0.01 mm. Eingabebereich 0 bis +9,999

Maximaler Verbindungsabstand Q447: Maximaler Abstand zwischen zwei nachzuräumenden Bereichen, zwischen denen das Werkzeug noch ohne Abhebebewegung auf der Bearbeitungstiefe entlang der Kontur verfahren soll. Eingabebereich 0 bis 999

Bahnverlängerung Q448: Betrag für die Verlängerung der Werkzeugbahn am Konturanfang und Konturende. Die TNC verlängert die Werkzeugbahn grundsätzlich immer parallel zur Kontur. Eingabebereich 0 bis 99,999


Programmierbeispiele

Weitere Informationen:
> Beispiel: Tasche räumen und nachräumen
> Beispiel: Überlagerte Konturen vorbohren, schruppen, schlichten
> Beispiel: Kontur-Zug


Beispiel: Tasche räumen und nachräumen

0 begin pgm c20 mm |
1 blk form 0.1 z x-10 y-10 z-40 |
2 blk form 0.2 x+100 y+100 z+0 | Rohteil-Definition
3 tool call 1 z s2500 | Werkzeug-Aufruf Vorräumer, Durchmesser 30
4 l z+250 r0 fmax | Werkzeug freifahren
5 cycl def 14.0 kontur | Kontur-Unterprogramm festlegen
6 cycl def 14.1 konturlabel 1 |
7 cycl def 20 kontur-daten | Allgemeine Bearbeitungs-Parameter festlegen
Q1=-20 ;fraestiefe |
Q2=1 ;bahn-ueberlappung |
Q3=+0 ;aufmass seite |
Q4=+0 ;aufmass tiefe |
Q5=+0 ;koor. oberflaeche |
Q6=2 ;sicherheits-abst. |
Q7=+100 ;sichere hoehe |
Q8=0.1 ;rundungsradius |
Q9=-1 ;drehsinn |
8 cycl def 22 raeumen | Zyklus-Definition Vorräumen
Q10=5 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=350 ;vorschub raeumen |
Q18=0 ;vorraeum-werkzeug |
Q19=150 ;vorschub pendeln |
Q208=30000 ;vorschub rueckzug |
Q401=100 ;vorschubfaktor |
Q404=0 ;nachraeumstrategie |
9 cycl call m3 | Zyklus-Aufruf Vorräumen
10 l z+250 r0 fmax m6 | Werkzeug-Wechsel
11 tool call 2 z s3000 | Werkzeug-Aufruf Nachräumer, Durchmesser 15
12 cycl def 22 raeumen | Zyklus-Definition Nachräumen
Q10=5 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=350 ;vorschub raeumen |
Q18=1 ;vorraeum-werkzeug |
Q19=150 ;vorschub pendeln |
Q208=30000 ;vorschub rueckzug |
Q401=100 ;vorschubfaktor |
Q404=0 ;nachraeumstrategie |
13 cycl call m3 | Zyklus-Aufruf Nachräumen
14 l z+250 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
15 lbl 1 | Kontur-Unterprogramm
16 l x+0 y+30 rr |
17 fc dr- r30 ccx+30 ccy+30 |
18 fl an+60 pdx+30 pdy+30 d10 |
19 fselect 3 |
20 fpol x+30 y+30 |
21 fc dr- r20 ccpr+55 ccpa+60 |
22 fselect 2 |
23 fl an-120 pdx+30 pdy+30 d10 |
24 fselect 3 |
25 fc x+0 dr- r30 ccx+30 ccy+30 |
26 fselect 2 |
27 lbl 0 |
28 end pgm c20 mm |


Beispiel: Überlagerte Konturen vorbohren, schruppen, schlichten

0 begin pgm c21 mm |
1 blk form 0.1 z x+0 y+0 z-40 | Rohteil-Definition
2 blk form 0.2 x+100 y+100 z+0 |
3 tool call 1 z s2500 | Werkzeug-Aufruf Bohrer, Durchmesser 12
4 l z+250 r0 fmax | Werkzeug freifahren
5 cycl def 14.0 kontur | Kontur-Unterprogramme festlegen
6 cycl def 14.1 konturlabel 1/2/3/4 |
7 cycl def 20 kontur-daten | Allgemeine Bearbeitungs-Parameter festlegen
Q1=-20 ;fraestiefe |
Q2=1 ;bahn-ueberlappung |
Q3=+0.5 ;aufmass seite |
Q4=+0.5 ;aufmass tiefe |
Q5=+0 ;koor. oberflaeche |
Q6=2 ;sicherheits-abst. |
Q7=+100 ;sichere hoehe |
Q8=0.1 ;rundungsradius |
Q9=-1 ;drehsinn |
8 cycl def 21 vorbohren | Zyklus-Definition Vorbohren
Q10=5 ;zustell-tiefe |
Q11=250 ;vorschub tiefenz. |
Q13=2 ;ausraeum-werkzeug |
9 cycl call m3 | Zyklus-Aufruf Vorbohren
10 l +250 r0 fmax m6 | Werkzeug-Wechsel
11 tool call 2 z s3000 | Werkzeug-Aufruf Schruppen/Schlichten, Durchmesser 12
12 cycl def 22 raeumen | Zyklus-Definition Räumen
Q10=5 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=350 ;vorschub raeumen |
Q18=0 ;vorraeum-werkzeug |
Q19=150 ;vorschub pendeln |
Q208=30000 ;vorschub rueckzug |
Q401=100 ;vorschubfaktor |
Q404=0 ;nachraeumstrategie |
13 cycl call m3 | Zyklus-Aufruf Räumen
14 cycl def 23 schlichten tiefe | Zyklus-Definition Schlichten Tiefe
Q11=100 ;vorschub tiefenz. |
Q12=200 ;vorschub raeumen |
Q208=30000 ;vorschub rueckzug |
15 cycl call | Zyklus-Aufruf Schlichten Tiefe
16 cycl def 24 schlichten seite | Zyklus-Definition Schlichten Seite
Q9=+1 ;drehsinn |
Q10=5 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=400 ;vorschub raeumen |
Q14=+0 ;aufmass seite |
17 cycl call | Zyklus-Aufruf Schlichten Seite
18 l z+250 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
19 lbl 1 | Kontur-Unterprogramm 1: Tasche links
20 cc x+35 y+50 |
21 l x+10 y+50 rr |
22 c x+10 dr- |
23 lbl 0 |
24 lbl 2 | Kontur-Unterprogramm 2: Tasche rechts
25 cc x+65 y+50 |
26 l x+90 y+50 rr |
27 c x+90 dr- |
28 lbl 0 |
29 lbl 3 | Kontur-Unterprogramm 3: Insel Viereckig links
30 l x+27 y+50 rl |
31 l y+58 |
32 l x+43 |
33 l y+42 |
34 l x+27 |
35 lbl 0 |
36 lbl 4 | Kontur-Unterprogramm 4: Insel Dreieckig rechts
39 l x+65 y+42 rl |
37 l x+57 |
38 l x+65 y+58 |
39 l x+73 y+42 |
40 lbl 0 |
41 end pgm c21 mm |


Beispiel: Kontur-Zug

0 begin pgm c25 mm |
1 blk form 0.1 z x+0 y+0 z-40 | Rohteil-Definition
2 blk form 0.2 x+100 y+100 z+0 |
3 tool call 1 z s2000 | Werkzeug-Aufruf , Durchmesser 20
4 l z+250 R0 fmax | Werkzeug freifahren
5 cycl def 14.0 kontur | Kontur-Unterprogramm festlegen
6 cycl def 14.1 Konturlabel 1 |
7 cycl def 25 kontur-zug | Bearbeitungs-Parameter festlegen
Q1=-20 ;fraestiefe |
Q3=+0 ;aufmass seite |
Q5=+0 ;koor. oberflaeche |
Q7=+250 ;sichere hoehe |
Q10=5 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=200 ;vorschub fraesen |
Q15=+1 ;fraesart |
8 cycl call m3 | Zyklus-Aufruf
9 l z+250 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
10 lbl 1 | Kontur-Unterprogramm
11 l x+0 y+15 rl |
12 l x+5 y+20 |
13 ct x+5 y+75 |
14 l y+95 |
15 rnd r7.5 |
16 l x+50 |
17 rnd r7.5 |
18 l x+100 y+80 |
19 lbl 0 |
20 end pgm c25 mm |


Bearbeitungszyklen: Zylindermantel

Weitere Informationen:
> Grundlagen
> ZYLINDER-MANTEL (Zyklus 27, DIN/ISO: G127, Software-Option 1)
> ZYLINDER-MANTEL Nutenfräsen (Zyklus 28, DIN/ISO: G128, Software‑Option 1)
> ZYLINDER-MANTEL Stegfräsen (Zyklus 29, DIN/ISO: G129, Software‑Option 1)
> ZYLINDER-MANTEL Außenkontur fräsen (Zyklus 39, DIN/ISO: G139, Software‑Option 1)
> Programmierbeispiele


Grundlagen

Weitere Informationen:
> Übersicht Zylindermantel-Zyklen


Übersicht Zylindermantel-Zyklen

Zyklus | Softkey | Seite
27 ZYLINDER-MANTEL |  | Zyklus-Ablauf
28 ZYLINDER-MANTEL Nutenfräsen |  | ZYLINDER-MANTEL Nutenfräsen (Zyklus 28, DIN/ISO: G128, Software‑Option 1)
29 ZYLINDER-MANTEL Stegfräsen |  | ZYLINDER-MANTEL Stegfräsen (Zyklus 29, DIN/ISO: G129, Software‑Option 1)
39 ZYLINDER-MANTEL Außenkontur fräsen |  | ZYLINDER-MANTEL Außenkontur fräsen (Zyklus 39, DIN/ISO: G139, Software‑Option 1)


ZYLINDER-MANTEL (Zyklus 27, DIN/ISO: G127, Software-Option 1)

Weitere Informationen:
> Zyklus-Ablauf
> Beim Programmieren beachten
> Zyklusparameter


Zyklus-Ablauf

Mit diesem Zyklus können Sie eine auf der Abwicklung definierte Kontur auf den Mantel eines Zylinders übertragen. Verwenden Sie den Zyklus 28, wenn Sie Führungsnuten auf dem Zylinder fräsen wollen.

Die Kontur beschreiben Sie in einem Unterprogramm, das Sie über Zyklus 14 (KONTUR) festlegen.

Das Unterprogramm enthält Koordinaten in einer Winkelachse (z.B. C-Achse) und der Achse, die dazu parallel verläuft (z.B. Spindelachse). Als Bahnfunktionen stehen L, CHF, CR, RND, APPR (außer APPR LCT) und DEP zur Verfügung.

Die Angaben in der Winkelachse können Sie wahlweise in Grad oder in mm (Inch) eingeben (bei der Zyklus-Definition festlegen).

  1. Die TNC positioniert das Werkzeug über den Einstichpunkt; dabei wird das Schlichtaufmaß Seite berücksichtigt
  2. In der ersten Zustell-Tiefe fräst das Werkzeug mit dem Fräsvorschub Q12 entlang der programmierten Kontur
  3. Am Konturende fährt die TNC das Werkzeug auf Sicherheitsabstand und zurück zum Einstichpunkt
  4. Die Schritte 1 bis 3 wiederholen sich, bis die programmierte Frästiefe Q1 erreicht ist
  5. Anschließend fährt das Werkzeug auf Sicherheitsabstand


Beim Programmieren beachten

Maschine und TNC müssen vom Maschinenhersteller für die Zylindermantel-Interpolation vorbereitet sein. Beachten Sie Ihr Maschinenhandbuch.

Im ersten NC-Satz des Kontur-Unterprogramms immer beide Zylindermantel-Koordinaten programmieren.

Der Speicher für einen SL-Zyklus ist begrenzt. Sie können in einem SL-Zyklus maximal 8192 Konturelemente programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Fräser mit einem über Mitte schneidenden Stirnzahn verwenden (DIN 844).

Der Zylinder muss mittig auf dem Rundtisch aufgespannt sein.

Die Spindelachse muss senkrecht zur Rundtisch-Achse verlaufen. Wenn dies nicht der Fall ist, dann gibt die TNC eine Fehlermeldung aus.

Diesen Zyklus können Sie auch bei geschwenkter Bearbeitungsebene ausführen.


Zyklusparameter

Beispiel: NC-Sätze
63 cycl def 27 zylinder-mantel
Q1=-8 ;fraestiefe
Q3=+0 ;aufmass seite
Q6=+0 ;sicherheits-abst.
Q10=+3 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q12=350 ;vorschub fraesen
Q16=25 ;radius
Q17=0 ;bemassungsart

Frästiefe Q1 (inkremental): Abstand zwischen Zylinder-Mantel und Konturgrund. Eingabebereich ‑99999,9999 bis 99999,9999

Schlichtaufmaß Seite Q3 (inkremental): Schlichtaufmaß in der Ebene der Mantel-Abwicklung; das Aufmaß wirkt in der Richtung der Radiuskorrektur. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q6 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Zylinder Mantelfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11: Vorschub bei Verfahrbewegungen in der Spindelachse. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Fräsen Q12: Vorschub bei Verfahrbewegungen in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Zylinderradius Q16: Radius des Zylinders, auf dem die Kontur bearbeitet werden soll. Eingabebereich 0 bis 99999,9999

Bemaßungsart? Grad =0 MM/INCH=1 Q17: Koordinaten der Drehachse im Unterprogramm in Grad oder mm (inch) programmieren


ZYLINDER-MANTEL Nutenfräsen (Zyklus 28, DIN/ISO: G128, Software‑Option 1)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit diesem Zyklus können Sie eine auf der Abwicklung definierte -Führungsnut auf den Mantel eines Zylinders übertragen. Im Gegensatz zum Zyklus 27, stellt die TNC das Werkzeug bei diesem Zyklus so an, dass die Wände bei aktiver Radiuskorrektur nahezu parallel zueinander verlaufen. Exakt parallel verlaufende Wände erhalten Sie dann, wenn Sie ein Werkzeug verwenden, das exakt so groß ist wie die Nutbreite.

Je kleiner das Werkzeug im Verhältnis zur Nutbreite ist, desto größere Verzerrungen enstehen bei Kreisbahnen und schrägen Geraden. Um diese verfahrensbedingten Verzerrungen zu minimieren, können Sie über den Parameter Q21 eine Toleranz definieren, mit der die TNC die herzustellende Nut an eine Nut annähert, die mit einem Werkzeug hergestellt wurde, dessen Durchmesser der Nutbreite entspricht.

Programmieren Sie die Mittelpunktsbahn der Kontur mit Angabe der Werkzeug-Radiuskorrektur. Über die Radiuskorrektur legen Sie fest, ob die TNC die Nut im Gleich- oder Gegenlauf herstellt.

  1. Die TNC positioniert das Werkzeug über den Einstichpunkt
  2. In der ersten Zustelltiefe fräst das Werkzeug mit dem Fräsvorschub Q12 entlang der Nutwand; dabei wird das Schlichtaufmaß Seite berücksichtigt
  3. Am Konturende versetzt die TNC das Werkzeug an die gegenüberliegende Nutwand und fährt zurück zum Einstichpunkt
  4. Die Schritte 2 und 3 wiederholen sich, bis die programmierte Frästiefe Q1 erreicht ist
  5. Wenn Sie die Toleranz Q21 definiert haben, dann führt die TNC die Nachbearbeitung aus, um möglichst parallele Nutwände zu erhalten.
  6. Abschließend fährt das Werkzeug in der Werkzeug-Achse zurück auf die sichere Höhe oder auf die zuletzt vor dem Zyklus programmierte Position (abhängig von Maschinen-Parameter 7420)


Beim Programmieren beachten!

Maschine und TNC müssen vom Maschinenhersteller für die Zylindermantel-Interpolation vorbereitet sein. Beachten Sie Ihr Maschinenhandbuch.

Im ersten NC-Satz des Kontur-Unterprogramms immer beide Zylindermantel-Koordinaten programmieren.

Der Speicher für einen SL-Zyklus ist begrenzt. Sie können in einem SL-Zyklus maximal 8192 Konturelemente programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Fräser mit einem über Mitte schneidenden Stirnzahn verwenden (DIN 844).

Der Zylinder muss mittig auf dem Rundtisch aufgespannt sein.

Die Spindelachse muss senkrecht zur Rundtisch-Achse verlaufen. Wenn dies nicht der Fall ist, dann gibt die TNC eine Fehlermeldung aus.

Diesen Zyklus können Sie auch bei geschwenkter Bearbeitungsebene ausführen.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
63 cycl def 28 zylinder-mantel
Q1=-8 ;fraestiefe
Q3=+0 ;aufmass seite
Q6=+0 ;sicherheits-abst.
Q10=+3 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q12=350 ;vorschub fraesen
Q16=25 ;radius
Q17=0 ;bemassungsart
Q20=12 ;nutbreite
Q21=0 ;TOLERANZ

Frästiefe Q1 (inkremental): Abstand zwischen Zylinder-Mantel und Konturgrund. Eingabebereich ‑99999,9999 bis 99999,9999

Schlichtaufmaß Seite Q3 (inkremental): Schlichtaufmaß an der Nutwand. Das Schlichtaufmaß verkleinert die Nutbreite um den zweifachen eingegebenen Wert. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q6 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Zylinder Mantelfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11: Vorschub bei Verfahrbewegungen in der Spindelachse. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Fräsen Q12: Vorschub bei Verfahrbewegungen in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Zylinder-Radius Q16: Radius des Zylinders, auf dem die Kontur bearbeitet werden soll. Eingabebereich 0 bis 99999,9999

Bemaßungsart? Grad =0 MM/INCH=1 Q17: Koordinaten der Drehachse im Unterprogramm in Grad oder mm (inch) programmieren

Nutbreite Q20: Breite der herzustellenden Nut. Eingabebereich -99999,9999 bis 99999,9999

Toleranz? Q21: Wenn Sie ein Werkzeug verwenden, das kleiner ist als die programmierte Nutbreite Q20, entstehen verfahrensbedingt Verrzerrungen an der Nutwand bei Kreisen und schrägen Geraden. Wenn Sie die Toleranz Q21 definieren, dann nähert die TNC die Nut in einem nachgeschalteten Fräsvorgang so an, als ob Sie die Nut mit einem Werkzeug gefräst hätten, das exakt so groß ist wie die Nutbreite. Mit Q21 definieren Sie die erlaubte Abweichung von dieser idealen Nut. Die Anzahl der Nachbearbeitungsschritte hängt ab vom Zylinderradius, dem verwendeten Werkzeug und der Nuttiefe. Je kleiner die Toleranz definiert ist, desto exakter wird die Nut, desto länger dauert aber auch die Nachbearbeitung. Empfehlung: Toleranz von 0.02 mm verwenden. Funktion inaktiv: 0 eingeben (Grundeinstellung). Eingabebereich 0 bis 9,9999


ZYLINDER-MANTEL Stegfräsen (Zyklus 29, DIN/ISO: G129, Software‑Option 1)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit diesem Zyklus können Sie einen auf der Abwicklung definierten Steg auf den Mantel eines Zylinders übertragen. Die TNC stellt das Werkzeug bei diesem Zyklus so an, dass die Wände bei aktiver Radiuskorrektur immer parallel zueinander verlaufen. Programmieren Sie die Mittelpunktsbahn des Steges mit Angabe der Werkzeug-Radiuskorrektur. Über die Radiuskorrektur legen Sie fest, ob die TNC den Steg im Gleich- oder Gegenlauf herstellt.

An den Stegenden fügt die TNC grundsätzlich immer einen Halbkreis an, dessen Radius der halben Stegbreite entspricht.

  1. Die TNC positioniert das Werkzeug über den Startpunkt der Bearbeitung. Den Startpunkt berechnet die TNC aus der Stegbreite und dem Werkzeug-Durchmesser. Er liegt um die halbe Stegbreite und dem Werkzeug-Durchmesser versetzt neben dem ersten im Kontur-Unterprogramm definierten Punkt. Die Radius-Korrektur bestimmt, ob links (1, RL=Gleichlauf) oder rechts vom Steg (2, RR=Gegenlauf) gestartet wird
  2. Nachdem die TNC auf die erste Zustelltiefe positioniert hat, fährt das Werkzeug auf einem Kreisbogen mit Fräsvorschub Q12 tangential an die Stegwand an. Ggf. wird das Schlichtaufmaß Seite berücksichtigt
  3. Auf der ersten Zustelltiefe fräst das Werkzeug mit dem Fräsvorschub Q12 entlang der Stegwand, bis der Zapfen vollständig hergestellt ist
  4. Anschließend fährt das Werkzeug tangential von der Stegwand weg zurück zum Startpunkt der Bearbeitung
  5. Die Schritte 2 bis 4 wiederholen sich, bis die programmierte Frästiefe Q1 erreicht ist
  6. Abschließend fährt das Werkzeug in der Werkzeug-Achse zurück auf die sichere Höhe oder auf die zuletzt vor dem Zyklus programmierte Position (abhängig von Maschinen-Parameter 7420)


Beim Programmieren beachten!

Maschine und TNC müssen vom Maschinenhersteller für die Zylindermantel-Interpolation vorbereitet sein. Beachten Sie Ihr Maschinenhandbuch.

Im ersten NC-Satz des Kontur-Unterprogramms immer beide Zylindermantel-Koordinaten programmieren.

Achten Sie darauf, dass das Werkzeug für die An- und Wegfahrbewegung seitlich genügend Platz hat.

Der Speicher für einen SL-Zyklus ist begrenzt. Sie können in einem SL-Zyklus maximal 8192 Konturelemente programmieren.

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest. Wenn Sie die Tiefe = 0 programmieren, dann führt die TNC den Zyklus nicht aus.

Der Zylinder muss mittig auf dem Rundtisch aufgespannt sein.

Die Spindelachse muss senkrecht zur Rundtisch-Achse verlaufen. Wenn dies nicht der Fall ist, dann gibt die TNC eine Fehlermeldung aus.

Diesen Zyklus können Sie auch bei geschwenkter Bearbeitungsebene ausführen.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
63 cycl def 29 zylinder-mantel steg
Q1=-8 ;fraestiefe
Q3=+0 ;aufmass seite
Q6=+0 ;sicherheits-abst.
Q10=+3 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q12=350 ;vorschub fraesen
Q16=25 ;radius
Q17=0 ;bemassungsart
Q20=12 ;Stegbreite

Frästiefe Q1 (inkremental): Abstand zwischen Zylinder-Mantel und Konturgrund. Eingabebereich ‑99999,9999 bis 99999,9999

Schlichtaufmaß Seite Q3 (inkremental): Schlichtaufmaß an der Stegwand. Das Schlichtaufmaß vergrößert die Stegbreite um den zweifachen eingegebenen Wert. Eingabebereich ‑99999,9999 bis 99999,9999

Sicherheits-Abstand Q6 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Zylinder Mantelfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11: Vorschub bei Verfahrbewegungen in der Spindelachse. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Fräsen Q12: Vorschub bei Verfahrbewegungen in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Zylinder-Radius Q16: Radius des Zylinders, auf dem die Kontur bearbeitet werden soll. Eingabebereich 0 bis 99999,9999

Bemaßungsart? Grad =0 MM/INCH=1 Q17: Koordinaten der Drehachse im Unterprogramm in Grad oder mm (inch) programmieren

Stegbreite Q20: Breite des herzustellenden Steges. Eingabebereich -99999,9999 bis 99999,9999


ZYLINDER-MANTEL Außenkontur fräsen (Zyklus 39, DIN/ISO: G139, Software‑Option 1)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit diesem Zyklus können Sie eine auf der Abwicklung definierte offene Kontur auf den Mantel eines Zylinders übertragen. Die TNC stellt das Werkzeug bei diesem Zyklus so an, dass die Wand der gefrästen Kontur bei aktiver Radiuskorrektur parallel zur Zylinderachse verläuft.

Im Gegensatz zu den Zyklen 28 und 29 definieren Sie im Kontur-Unterprogramm die tatsächlich herzustellende Kontur.

  1. Die TNC positioniert das Werkzeug über den Startpunkt der Bearbeitung. Den Startpunkt legt die TNC um dem Werkzeug-Durchmesser versetzt neben dem ersten im Kontur-Unterprogramm definierten Punkt (Standard-Verhalten)
  2. Nachdem die TNC auf die erste Zustelltiefe positioniert hat, fährt das Werkzeug auf einem Kreisbogen mit Fräsvorschub Q12 tangential an die Kontur an. Ggf. wird das Schlichtaufmaß Seite berücksichtigt
  3. Auf der ersten Zustelltiefe fräst das Werkzeug mit dem Fräsvorschub Q12 entlang der Kontur, bis der definierte Konturzug vollständig hergestellt ist
  4. Anschließend fährt das Werkzeug tangential von der Stegwand weg zurück zum Startpunkt der Bearbeitung
  5. Die Schritte 2 bis 4 wiederholen sich, bis die programmierte Frästiefe Q1 erreicht ist
  6. Abschließend fährt das Werkzeug in der Werkzeug-Achse zurück auf die sichere Höhe oder auf die zuletzt vor dem Zyklus programmierte Position (abhängig von Maschinen-Parameter 7420)

Über den Maschinen-Parameter 7680, Bit 16 können Sie das Anfahrverhalten des Zyklus 39 festlegen:

  • Bit 16 = 0:
    Tangentiales An- und Wegfahren ausführen.
  • Bit 16 = 1:
    Am Konturstartpunkt senkrecht auf Tiefe fahren, ohne dass Werkzeug tangential anzufahren und am Konturendpunkt wieder nach oben ziehen ohne tangential wegzufahren.


Zyklusparameter

Beispiel: NC-Sätze
63 cycl def 39 zylinder-man. KONTUR
Q1=-8 ;fraestiefe
Q3=+0 ;aufmass seite
Q6=+0 ;sicherheits-abst.
Q10=+3 ;zustell-tiefe
Q11=100 ;vorschub tiefenz.
Q12=350 ;vorschub fraesen
Q16=25 ;radius
Q17=0 ;bemassungsart

Frästiefe Q1 (inkremental): Abstand zwischen Zylinder-Mantel und Konturgrund. Eingabebereich ‑99999,9999 bis 99999,9999

Schlichtaufmaß Seite Q3 (inkremental): Schlichtaufmaß an der Konturwand. Eingabebereich ‑99999,9999 bis 99999,9999

Sicherheits-Abstand Q6 (inkremental): Abstand zwischen Werkzeug-Stirnfläche und Zylinder Mantelfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Zustell-Tiefe Q10 (inkremental): Maß, um das das Werkzeug jeweils zugestellt wird. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung Q11: Vorschub bei Verfahrbewegungen in der Spindelachse. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Fräsen Q12: Vorschub bei Verfahrbewegungen in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Zylinder-Radius Q16: Radius des Zylinders, auf dem die Kontur bearbeitet werden soll. Eingabebereich 0 bis 99999,9999

Bemaßungsart? Grad =0 MM/INCH=1 Q17: Koordinaten der Drehachse im Unterprogramm in Grad oder mm (inch) programmieren


Programmierbeispiele

Weitere Informationen:
> Beispiel: Zylinder-Mantel mit Zyklus 27
> Beispiel: Zylinder-Mantel mit Zyklus 28


Beispiel: Zylinder-Mantel mit Zyklus 27

    Hinweis:

  • Maschine mit B-Kopf und C-Tisch
  • Zylinder mittig auf Rundtisch aufgespannt.
  • Bezugspunkt liegt in der Rundtisch-Mitte
0 begin pgm c27 mm |
1 tool call 1 z s2000 | Werkzeug-Aufruf, Durchmesser 7
2 l z+250 r0 fmax | Werkzeug freifahren
3 l x+50 y0 r0 fmax | Werkzeug auf Rundtisch-Mitte vorpositionieren
4 plane spatial spa+0 spb+90 spc+0 turn mbmax fmax | Einschwenken
5 cycl def 14.0 kontur | Kontur-Unterprogramm festlegen
6 cycl def 14.1 konturlabel 1 |
7 cycl def 27 zylinder-mantel | Bearbeitungs-Parameter festlegen
Q1=-7 ;fraestiefe |
Q3=+0 ;aufmass seite |
Q6=2 ;sicherheits-abst. |
Q10=4 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=250 ;vorschub fraesen |
Q16=25 ;radius |
Q17=1 ;bemassungsart |
8 l c+0 r0 fmax m13 m99 | Rundtisch vorpositionieren, Spindel ein, Zyklus aufrufen
9 l z+250 r0 fmax | Werkzeug freifahren
10 plane reset turn fmax | Zurückschwenken, PLANE-Funktion aufheben
11 m2 | Programm-Ende
12 lbl 1 | Kontur-Unterprogramm
13 l c+40 x+20 rl | Angaben in der Drehachse in mm (Q17=1), Verfahren in X-Achse wegen 90° Einschwenkung
14 l c+50 |
15 rnd r7.5 |
16 l x+60 |
17 rnd r7.5 |
18 l ic-20 |
19 rnd r7.5 |
20 l x+20 |
21 rnd r7.5 |
22 l c+40 |
23 lbl 0 |
24 end pgm c27 mm |


Beispiel: Zylinder-Mantel mit Zyklus 28

    Hinweise:

  • Zylinder mittig auf Rundtisch aufgespannt.
  • Maschine mit B-Kopf und C-Tisch
  • Bezugspunkt liegt in der Rundtisch-Mitte
  • Beschreibung der Mittelpunktsbahn im Kontur-Unterprogramm
0 begin pgm c28 mm |
1 tool call 1 z s2000 | Werkzeug-Aufruf, Werkzeug-Achse Z, Durchmesser 7
2 l z+250 R0 fmax | Werkzeug freifahren
3 l x+50 y+0 r0 fmax | Werkzeug auf Rundtisch-Mitte positionieren
4 plane spatial spa+0 spb+90 spc+0 turn fmax | Einschwenken
5 cycl def 14.0 kontur | Kontur-Unterprogramm festlegen
6 cycl def 14.1 konturlabel 1 |
7 cycl def 28 zylinder-mantel | Bearbeitungs-Parameter festlegen
Q1=-7 ;fraestiefe |
Q3=+0 ;aufmass seite |
Q6=2 ;sicherheits-abst. |
Q10=-4 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=250 ;vorschub fraesen |
Q16=25 ;radius |
Q17=1 ;bemassungsart |
Q20=10 ;nutbreite |
Q21=0.02 ;toleranz | Nachbearbeitung aktiv
8 l c+0 r0 fmax m3 m99 | Rundtisch vorpositionieren, Spindel ein, Zyklus aufrufen
9 l z+250 r0 fmax | Werkzeug freifahren
10 plane reset turn fmax | Zurückschwenken, PLANE-Funktion aufheben
11 m2 | Programm-Ende
12 lbl 1 | Kontur-Unterprogramm, Beschreibung der Mittelpunktsbahn
13 l c+40 X+0 rl | Angaben in der Drehachse in mm (Q17=1), Verfahren in X-Achse wegen 90° Einschwenkung
14 l X+35 |
15 l c+60 X+52.5 |
16 l X+70 |
17 lbl 0 |
18 end pgm c28 mm |


Bearbeitungszyklen: Konturtasche mit Konturformel

Weitere Informationen:
> SL-Zyklen mit komplexer Konturformel
> SL-Zyklen mit einfacher Konturformel


SL-Zyklen mit komplexer Konturformel

Weitere Informationen:
> Grundlagen
> Programm mit Konturdefinitionen wählen
> Konturbeschreibungen definieren
> Komplexe Konturformel eingeben
> Überlagerte Konturen
> Kontur Abarbeiten mit SL-Zyklen
> Beispiel: Überlagerte Konturen mit Konturformel schruppen und schlichten


Grundlagen

Beispiel: Schema: Abarbeiten mit SL-Zyklen und komplexer Konturformel
0 begin pgm kontur mm
...
5 sel contour “MODEL“
6 cycl def 20 kontur-daten ...
8 cycl def 22 raeumen ...
9 cycl call
...
12 cycl def 23 schlichten tiefe ...
13 cycl call
...
16 cycl def 24 schlichten seite ...
17 cycl call
63 l z+250 r0 fmax m2
64 end pgm kontur mm

Mit den SL-Zyklen und der komplexen Konturformel können Sie komplexe Konturen aus Teilkonturen (Taschen oder Inseln) zusammensetzen. Die einzelnen Teilkonturen (Geometriedaten) geben Sie als separate Programme ein. Dadurch sind alle Teilkonturen beliebig wiederverwendbar. Aus den gewählten Teilkonturen, die Sie über eine Konturformel miteinander verknüpfen, berechnet die TNC die Gesamtkontur.

Der Speicher für einen SL-Zyklus (alle Konturbeschreibungs-Programme) ist auf maximal 128 Konturen begrenzt. Die Anzahl der möglichen Konturelemente hängt von der Konturart (Innen-/Außenkontur) und der Anzahl der Konturbeschreibungen ab und beträgt maximal 8192 Konturelemente.

Die SL-Zyklen mit Konturformel setzen einen strukturierten Programmaufbau voraus und bieten die Möglichkeit, immer wiederkehrende Konturen in einzelnen Programmen abzulegen. Über die Konturformel verknüpfen Sie die Teilkonturen zu einer Gesamtkontur und legen fest, ob es sich um eine Tasche oder Insel handelt.

Die Funktion SL-Zyklen mit Konturformel ist in der Bedienoberfläche der TNC auf mehrere Bereiche verteilt und dient als Grundlage für weitergehende Entwicklungen.
Beispiel: Schema: Verrechnung der Teilkonturen mit Konturformel
0 begin pgm model mm
1 declare contour qc1 = “KREIS1“
2 declare contour qc2 = “KREIS31XY“
3 declare contour qc3 = “DREIECK“
4 declare contour qc4 = “QUADRAT“
5 QC10 = ( QC1 | QC3 | QC4 ) \ QC2
6 end pgm model mm
0 begin pgm kreis1 mm
1 cc x+75 y+50
2 lp pr+45 pa+0
3 cp ipa+360 dr+
4 end pgm kreis1 mm
0 begin pgm kreis31xy mm
...
...

    Eigenschaften der Teilkonturen

  • Die TNC erkennt grundsätzlich alle Konturen als Tasche. Programmieren Sie keine Radiuskorrektur. In der Konturformel können Sie eine Tasche durch negieren in eine Insel umwandeln.
  • Die TNC ignoriert Vorschübe F und Zusatz-Funktionen M
  • Koordinaten-Umrechnungen sind erlaubt. Werden sie innerhalb der Teilkonturen programmiert, wirken sie auch in den nachfolgenden Unterprogrammen, müssen aber nach dem Zyklusaufruf nicht zurückgesetzt werden
  • Die Unterprogramme dürfen auch Koordinaten in der Spindelachse enthalten, diese werden aber ignoriert
  • Im ersten Koordinatensatz des Unterprogramms legen Sie die Bearbeitungsebene fest. Zusatzachsen U,V,W sind erlaubt

    Eigenschaften der Bearbeitungszyklen

  • Die TNC positioniert vor jedem Zyklus automatisch auf den Sicherheits-Abstand
  • Jedes Tiefen-Niveau wird ohne Werkzeug-Abheben gefräst; Inseln werden seitlich umfahren
  • Der Radius von „Innen-Ecken“ ist programmierbar – das Werkzeug bleibt nicht stehen, Freischneide-Markierungen werden verhindert (gilt für äußerste Bahn beim Räumen und Seiten-Schlichten)
  • Beim Seiten-Schlichten fährt die TNC die Kontur auf einer tangentialen Kreisbahn an
  • Beim Tiefen-Schlichten fährt die TNC das Werkzeug ebenfalls auf einer tangentialen Kreisbahn an das Werkstück (z.B.: Spindelachse Z: Kreisbahn in Ebene Z/X)
  • Die TNC bearbeitet die Kontur durchgehend im Gleichlauf bzw. im Gegenlauf

Mit Maschinen-Parameter 7420 legen Sie fest, wohin die TNC das Werkzeug am Ende der Zyklen 21 bis 24 positionieren soll.

Die Maßangaben für die Bearbeitung, wie Frästiefe, Aufmaße und Sicherheits-Abstand geben Sie zentral im Zyklus 20 als KONTUR-DATEN ein.


Programm mit Konturdefinitionen wählen

Mit der Funktion SEL CONTOUR wählen Sie ein Programm mit Kontur-Definitionen, aus denen die TNC die Konturbeschreibungen entnimmt:

Softkey-Leiste mit Sonderfunktionen einblenden

Menü für Funktionen zur Kontur- und Punktbearbeitung wählen

Menü für komplexe Konturformel wählen

Softkey sel contour drücken

Softkey Auswahl fenster drücken: Die TNC blendet ein Fenster ein, in dem Sie das Programm mit der Kontur-Definitionen wählen können

Gewünschtes Programm mit Pfeiltasten oder per Mouse-Klick wählen, mit Taste ENT bestätigen: Die TNC trägt den vollständigen Pfadnamen in den sel contour-Satz ein

Funktion mit Taste END abschließen

Vollständigen Programmnamen des Programms mit der Kontur-Definitionen eingeben, mit Taste END bestätigen

Alternativ können Sie den Programm-Namen oder den vollständigen Pfadnamen des Programms mit der Kontur-Definitionen auch direkt über die Tastatur eingeben.

SEL CONTOUR-Satz vor den SL-Zyklen programmieren. Zyklus 14 KONTUR ist bei der Verwendung von SEL CONTUR nicht mehr erforderlich.


Konturbeschreibungen definieren

Mit der Funktion DECLARE CONTOUR geben Sie einem Programm den Pfad für Programme an, aus denen die TNC die Konturbeschreibungen entnimmt. Desweiteren können Sie für diese Konturbeschreibung eine separate Tiefe wählen (FCL 2-Funktion):

Softkey-Leiste mit Sonderfunktionen einblenden

Menü für Funktionen zur Kontur- und Punktbearbeitung wählen

Menü für komplexe Konturformel wählen

Softkey declare CONTOUR drücken

Nummer für den Konturbezeichner QC eingeben, mit Taste ENT bestätigen

Softkey Auswahl fenster drücken: Die TNC blendet ein Fenster ein, in dem Sie das zu rufende Programm wählen können

Gewünschtes Programm mit der Kontur-Beschreibung mit Pfeiltasten oder per Mouse-Klick wählen, mit Taste ENT bestätigen: Die TNC trägt den vollständigen Pfadnamen in den declare contour-Satz ein

Separate Tiefe für die gewählte Kontur definieren

Funktion mit Taste END abschließen

Alternativ können Sie den Programm-Namen des Programms mit der Kontur-Beschreibung oder den vollständigen Pfadnamen des Programms auch direkt über die Tastatur eingeben.

Mit den angegebenen Konturbezeichnern QC können Sie in der Konturformel die verschiedenen Konturen miteinander verrechnen.

Wenn Sie Konturen mit separater Tiefe verwenden, dann müssen Sie allen Teilkonturen eine Tiefe zuweisen (ggf. Tiefe 0 zuweisen).


Komplexe Konturformel eingeben

Über Softkeys können Sie verschiedene Konturen in einer mathematischen Formel miteinander verknüpfen:

Softkey-Leiste mit Sonderfunktionen einblenden

Menü für Funktionen zur Kontur- und Punktbearbeitung wählen

Menü für komplexe Konturformel wählen

Softkey kontur formel drücken: Die TNC zeigt folgende Softkeys an:

Verknüpfungs-Funktion | Softkey
geschnitten mit z.B. QC10 = QC1 & QC5 |
vereinigt mit z.B. QC25 = QC7 | QC18 |
vereinigt mit, aber ohne Schnitt z.B. QC12 = QC5 ^ QC25 |
geschnitten mit Komplement von z.B. QC25 = QC1 \ QC2 |
Komplement des Konturgebietes z.B. QC12 = #QC11 |
Klammer auf z.B. QC12 = QC1 * (QC2 + QC3) |
Klammer zu z.B. QC12 = QC1 * (QC2 + QC3) |
Einzelne Kontur definieren z.B. QC12 = QC1 |


Überlagerte Konturen

Die TNC betrachtet grundsätzlich eine programmierte Kontur als Tasche. Mit den Funktionen der Konturformel haben Sie die Möglichkeit, eine Kontur in eine Insel umzuwandeln

Taschen und Inseln können Sie zu einer neuen Kontur überlagern. Damit können Sie die Fläche einer Tasche durch eine überlagerte Tasche vergrößern oder eine Insel verkleinern.

Unterprogramme: Überlagerte Taschen

Die nachfolgenden Programmierbeispiele sind Konturbeschreibungs-Programme, die in einem Konturdefinitions-Programm definiert sind. Das Konturdefinitions-Programm wiederum ist über die Funktion SEL CONTOUR im eigentlichen Hauptprogramm aufzurufen.

Die Taschen A und B überlagern sich.

Die TNC berechnet die Schnittpunkte S1 und S2, sie müssen nicht programmiert werden.

Die Taschen sind als Vollkreise programmiert.

Konturbeschreibungs-Programm 1: Tasche A
0 begin pgm TASCHE_A mm
1 l x+10 y+50 r0
2 cc x+35 y+50
3 c x+10 y+50 dr-
4 end pgm TASCHE_A mm
Konturbeschreibungs-Programm 2: Tasche B
0 begin pgm TASCHE_B mm
1 l x+90 y+50 r0
2 cc x+65 y+50
3 c x+90 y+50 dr-
4 end pgm TASCHE_B mm
Weitere Informationen:
> „Summen“-Fläche
> „Differenz“-Fläche
> „Schnitt“-Fläche


„Summen“-Fläche

    Beide Teilflächen A und B inklusive der gemeinsam überdeckten Fläche sollen bearbeitet werden:

  • Die Flächen A und B müssen in separaten Programmen ohne Radiuskorrektur programmiert sein
  • In der Konturformel werden die Flächen A und B mit der Funktion “vereinigt mit“ verrechnet
Konturdefinitions-Programm:
50 ...
51 ...
52 declare contour qc1 = “TASCHE_A.H“
53 declare contour qc2 = “TASCHE_b.H“
54 qc10 = QC1 | QC2
55 ...
56 ...


„Differenz“-Fläche

    Fläche A soll ohne den von B überdeckten Anteil bearbeitet werden:

  • Die Flächen A und B müssen in separaten Programmen ohne Radiuskorrektur programmiert sein
  • In der Konturformel wird die Fläche B mit der Funktion “geschnitten mit Komplement von“ von der Fläche A abgezogen
Konturdefinitions-Programm:
50 ...
51 ...
52 declare contour qc1 = “TASCHE_A.H“
53 declare contour qc2 = “TASCHE_b.H“
54 qc10 = QC1 \ QC2
55 ...
56 ...


„Schnitt“-Fläche

    Die von A und B überdeckte Fläche soll bearbeitet werden. (Einfach überdeckte Flächen sollen unbearbeitet bleiben.)

  • Die Flächen A und B müssen in separaten Programmen ohne Radiuskorrektur programmiert sein
  • In der Konturformel werden die Flächen A und B mit der Funktion “geschnitten mit“ verrechnet
Konturdefinitions-Programm:
50 ...
51 ...
52 declare contour qc1 = “TASCHE_A.H“
53 declare contour qc2 = “TASCHE_b.H“
54 qc10 = QC1 & QC2
55 ...
56 ...


Kontur Abarbeiten mit SL-Zyklen

Die Bearbeitung der definierten Gesamtkontur erfolgt mit den SL-Zyklen 20 - 24 (siehe Übersicht).


Beispiel: Überlagerte Konturen mit Konturformel schruppen und schlichten

0 begin pgm kontur mm |
1 blk form 0.1 z x+0 y+0 z-40 | Rohteil-Definition
2 blk form 0.2 x+100 y+100 z+0 |
3 tool def 1 l+0 r+2.5 | Werkzeug-Definition Schruppfräser
4 tool def 2 l+0 r+3 | Werkzeug-Definition Schlichtfräser
5 tool call 1 z s2500 | Werkzeug-Aufruf Schruppfräser
6 l z+250 r0 fmax | Werkzeug freifahren
7 sel contour “MODEL“ | Konturdefinitions-Programm festlegen
8 cycl def 20 kontur-daten | Allgemeine Bearbeitungs-Parameter festlegen
Q1=-20 ;fraestiefe |
Q2=1 ;bahn-ueberlappung |
Q3=+0.5 ;aufmass seite |
Q4=+0.5 ;aufmass tiefe |
Q5=+0 ;koor. oberflaeche |
Q6=2 ;sicherheits-abst. |
Q7=+100 ;sichere hoehe |
Q8=0.1 ;rundungsradius |
Q9=-1 ;drehsinn |
9 cycl def 22 raeumen | Zyklus-Definition Räumen
Q10=5 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=350 ;vorschub raeumen |
Q18=0 ;vorraeum-werkzeug |
Q19=150 ;vorschub pendeln |
Q401=100 ;vorschubfaktor |
Q404=0 ;nachraeumstrategie |
10 cycl call m3 | Zyklus-Aufruf Räumen
11 tool call 2 z s5000 | Werkzeug-Aufruf Schlichtfräser
12 cycl def 23 schlichten tiefe | Zyklus-Definition Schlichten Tiefe
Q11=100 ;vorschub tiefenz. |
Q12=200 ;vorschub raeumen |
13 cycl call m3 | Zyklus-Aufruf Schlichten Tiefe
14 cycl def 24 schlichten seite | Zyklus-Definition Schlichten Seite
Q9=+1 ;drehsinn |
Q10=5 ;zustell-tiefe |
Q11=100 ;vorschub tiefenz. |
Q12=400 ;vorschub raeumen |
Q14=+0 ;aufmass seite |
15 cycl call m3 | Zyklus-Aufruf Schlichten Seite
16 l z+250 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
17 end pgm kontur mm |

Konturdefinitions-Programm mit Konturformel:

0 begin pgm model mm | Konturdefinitions-Programm
1 declare contour qc1 = “KREIS1“ | Definition des Konturbezeichners für das Programm “KREIS1“
2 fn 0: Q1 =+35 | Wertzuweisung für verwendete Parameter im PGM “KREIS31XY“
3 fn 0: q2 =+50 |
4 FN 0: q3 =+25 |
5 declare contour qc2 = “KREIS31XY“ | Definition des Konturbezeichners für das Programm “KREIS31XY“
6 declare contour qc3 = “DREIECK“ | Definition des Konturbezeichners für das Programm “DREIECK“
7 declare contour qc4 = “QUADRAT“ | Definition des Konturbezeichners für das Programm “QUADRAT“
8 QC10 = ( QC 1 | QC 2 ) \ QC 3 \ QC 4 | Konturformel
9 end pgm model mm |

Konturbeschreibungs-Programme:

0 begin pgm kreis1 mm | Konturbeschreibungs-Programm: Kreis rechts
1 cc x+65 y+50 |
2 l pr+25 pa+0 r0 |
3 cp ipa+360 dr+ |
4 end pgm kreis1 mm |
0 begin pgm kreis31xy mm | Konturbeschreibungs-Programm: Kreis links
1 cc x+q1 y+q2 |
2 lp pr+q3 pa+0 r0 |
3 cp ipa+360 dr+ |
4 end pgm kreis31xy mm |
0 begin pgm dreieck mm | Konturbeschreibungs-Programm: Dreieck rechts
1 l x+73 y+42 r0 |
2 l x+65 y+58 |
3 l x+58 y+42 |
4 l x+73 |
5 end pgm dreieck mm |
0 begin pgm quadrat mm | Konturbeschreibungs-Programm: Quadrat links
1 l x+27 y+58 r0 |
2 l x+43 |
3 l y+42 |
4 l x+27 |
5 l y+58 |
6 end pgm quadrat mm |


SL-Zyklen mit einfacher Konturformel

Weitere Informationen:
> Grundlagen
> Einfache Konturformel eingeben
> Kontur Abarbeiten mit SL-Zyklen


Grundlagen

Beispiel: Schema: Abarbeiten mit SL-Zyklen und komplexer Konturformel
0 begin pgm CONTDEF mm
...
5 contour def P1= “POCK1.H“ I2 = “ISLE2.H“ depth5 i3 “isle3.h“ depth7.5
6 cycl def 20 kontur-daten ...
8 cycl def 22 raeumen ...
9 cycl call
...
12 cycl def 23 schlichten tiefe ...
13 cycl call
...
16 cycl def 24 schlichten seite ...
17 cycl call
63 l z+250 r0 fmax m2
64 end pgm CONTDEF mm

Mit den SL-Zyklen und der einfachen Konturformel können Sie Konturen aus bis zu 9 Teilkonturen (Taschen oder Inseln) auf einfache Weise zusammensetzen. Die einzelnen Teilkonturen (Geometriedaten) geben Sie als separate Programme ein. Dadurch sind alle Teilkonturen beliebig wiederverwendbar. Aus den gewählten Teilkonturen berechnet die TNC die Gesamtkontur.

Der Speicher für einen SL-Zyklus (alle Konturbeschreibungs-Programme) ist auf maximal 128 Konturen begrenzt. Die Anzahl der möglichen Konturelemente hängt von der Konturart (Innen-/Außenkontur) und der Anzahl der Konturbeschreibungen ab und beträgt maximal ca. 8192 Konturelemente.

    Eigenschaften der Teilkonturen

  • Die TNC erkennt grundsätzlich alle Konturen als Tasche. Programmieren Sie keine Radiuskorrektur.
  • Die TNC ignoriert Vorschübe F und Zusatz-Funktionen M.
  • Koordinaten-Umrechnungen sind erlaubt. Werden sie innerhalb der Teilkonturen programmiert, wirken sie auch in den nachfolgenden Unterprogrammen, müssen aber nach dem Zyklusaufruf nicht zurückgesetzt werden
  • Die Unterprogramme dürfen auch Koordinaten in der Spindelachse enthalten, diese werden aber ignoriert
  • Im ersten Koordinatensatz des Unterprogramms legen Sie die Bearbeitungsebene fest. Zusatzachsen U,V,W sind erlaubt

    Eigenschaften der Bearbeitungszyklen

  • Die TNC positioniert vor jedem Zyklus automatisch auf den Sicherheits-Abstand
  • Jedes Tiefen-Niveau wird ohne Werkzeug-Abheben gefräst; Inseln werden seitlich umfahren
  • Der Radius von „Innen-Ecken“ ist programmierbar – das Werkzeug bleibt nicht stehen, Freischneide-Markierungen werden verhindert (gilt für äußerste Bahn beim Räumen und Seiten-Schlichten)
  • Beim Seiten-Schlichten fährt die TNC die Kontur auf einer tangentialen Kreisbahn an
  • Beim Tiefen-Schlichten fährt die TNC das Werkzeug ebenfalls auf einer tangentialen Kreisbahn an das Werkstück (z.B.: Spindelachse Z: Kreisbahn in Ebene Z/X)
  • Die TNC bearbeitet die Kontur durchgehend im Gleichlauf bzw. im Gegenlauf

Mit Maschinen-Parameter 7420 legen Sie fest, wohin die TNC das Werkzeug am Ende der Zyklen 21 bis 24 positionieren soll.

Die Maßangaben für die Bearbeitung, wie Frästiefe, Aufmaße und Sicherheits-Abstand geben Sie zentral im Zyklus 20 als KONTUR-DATEN ein.


Einfache Konturformel eingeben

Über Softkeys können Sie verschiedene Konturen in einer mathematischen Formel miteinander verknüpfen:

Softkey-Leiste mit Sonderfunktionen einblenden

Menü für Funktionen zur Kontur- und Punktbearbeitung wählen

Softkey contour def drücken: Die TNC startet die Eingabe der Konturformel

Namen der ersten Teilkontur über den Softkey AUSWAHL FENSTER wählen oder direkt eingeben. Die erste Teilkontur muss immer die tiefste Tasche sein, mit Taste ent bestätigen

Per Softkey festlegen, ob die nächste Kontur eine Tasche oder Insel ist, mit Taste ENt bestätigen

Namen der zweiten Teilkontur über den Softkey AUSWAHL FENSTER wählen oder direkt eingeben, mit Taste ent bestätigen

Bei Bedarf Tiefe der zweiten Teilkontur eingeben, mit Taste ent bestätigen

Dialog wie zuvor beschrieben fortführen, bis Sie alle Teilkonturen eingegeben haben

  • Liste der Teilkonturen grundsätzlich immer mit der tiefsten Tasche beginnen!
  • Wenn die Kontur als Insel definiert ist, dann interpretiert die TNC die eingegebene Tiefe als Inselhöhe. Der eingegebene, vorzeichenlose Wert bezieht sich dann auf die Werkstück-Oberfläche!
  • Wenn Tiefe mit 0 eingegeben ist, dann wirkt bei Taschen die im Zyklus 20 definierte Tiefe, Inseln ragen dann bis zur Werkstück-Oberfläche!


Bearbeitungszyklen: Abzeilen

Weitere Informationen:
> Grundlagen
> 3D-DATEN ABARBEITEN (Zyklus 30, DIN/ISO: G60)
> ABZEILEN (Zyklus 230, DIN/ISO: G230)
> REGELFLAECHE (Zyklus 231; DIN/ISO: G231)
> PLANFRAESEN (Zyklus 232, DIN/ISO: G232)
> Programmierbeispiele


Übersicht

    Die TNC stellt vier Zyklen zur Verfügung, mit denen Sie Flächen mit folgenden Eigenschaften bearbeiten können:

  • Von einem CAD-/CAM-System erzeugt
  • Eben rechteckig
  • Eben schiefwinklig
  • Beliebig geneigt
  • In sich verwunden
Zyklus | Softkey | Seite
30 3D-DATEN ABARBEITEN Zum Abzeilen von 3D-Daten in mehreren Zustellungen |  | 3D-DATEN ABARBEITEN (Zyklus 30, DIN/ISO: G60)
230 ABZEILEN Für ebene rechteckige Flächen |  | ABZEILEN (Zyklus 230, DIN/ISO: G230)
231 REGELFLAECHE Für schiefwinklige, geneigte und verwundene Flächen |  | REGELFLAECHE (Zyklus 231; DIN/ISO: G231)
232 PLANFRAESEN Für ebene rechteckige Flächen, mit Aufmaß-Angabe und mehreren Zustellungen |  | PLANFRAESEN (Zyklus 232, DIN/ISO: G232)


3D-DATEN ABARBEITEN (Zyklus 30, DIN/ISO: G60)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug im Eilgang FMAX von der aktuellen Position aus in der Spindelachse auf Sicherheits-Abstand über den im Zyklus programmierten MAX-Punkt
  2. Anschließend fährt die TNC das Werkzeug mit FMAX in der Bearbeitungsebene auf den im Zyklus programmierten MIN-Punkt
  3. Von dort aus fährt das Werkzeug mit Vorschub Tiefenzustellung auf den ersten Konturpunkt
  4. Anschließend arbeitet die TNC alle im angegeben Programm gespeicherten Punkte im Vorschub Fräsen ab; falls nötig fährt die TNC zwischendurch auf Sicherheits-Abstand, um unbearbeitete Bereiche zu überspringen
  5. Am Ende fährt die TNC das Werkzeug mit FMAX zurück auf den Sicherheits-Abstand


Beim Programmieren beachten!

Mit Zyklus 30 können Sie insbesondere extern erstellte Klartext-Dialog-Programme in mehreren Zustellungen abarbeiten.


Zyklusparameter

Beispiel: NC-Sätze
64 cycl def 30.0 3d-daten abarbeiten
65 cycl def 30.1 pgm digit.: bsp.h
66 cycl def 30.2 x+0 y+0 z-20
67 cycl def 30.3 x+100 y+100 z+0
68 cycl def 30.4 abst 2
69 cycl def 30.5 zustlg -5 f100
70 cycl def 30.6 f350 m8

Datei-Name 3D-Daten: Name des Programmes eingeben, in der die Konturdaten gespeichert sind; wenn die Datei nicht im aktuellen Verzeichnis steht, kompletten Pfad eingeben. Maximal 254 Zeichen eingebbar

MIN-Punkt Bereich: Minimal-Punkt (X-, Y- und Z-Koordinate) des Bereichs, in dem gefräst werden soll. Eingabebereich -99999,9999 bis 99999,9999

MAX-Punkt Bereich: Maximal-Punkt (X-, Y- und Z-Koordinate) des Bereichs, in dem gefräst werden soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand 1 (inkremental): Abstand zwischen Werkzeugspitze und Werkstück-Oberfläche bei Eilgang-Bewegungen. Eingabebereich 0 bis 99999,9999

Zustell-Tiefe 2 (inkremental): Maß, um welches das Werkzeug jeweils zugestellt wird. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Tiefenzustellung 3: Verfahrgeschwindigkeit des Werkzeugs beim Eintauchen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO

Vorschub Fräsen 4: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO

Zusatz-Funktion M: Optionale Eingabe von bis zu zwei Zusatz-Funktionen, z.B. M13. Eingabebereich 0 bis 999


ABZEILEN (Zyklus 230, DIN/ISO: G230)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug im Eilgang FMAX von der aktuellen Position aus in der Bearbeitungsebene auf den Startpunkt 1; die TNC versetzt das Werkzeug dabei um den Werkzeug-Radius nach links und nach oben
  2. Anschließend fährt das Werkzeug mit FMAX in der Spindelachse auf Sicherheits-Abstand und danach im Vorschub Tiefenzustellung auf die programmierte Startposition in der Spindelachse
  3. Danach fährt das Werkzeug mit dem programmierten Vorschub Fräsen auf den Endpunkt 2; den Endpunkt berechnet die TNC aus dem programmierten Startpunkt, der programmierten Länge und dem Werkzeug-Radius
  4. Die TNC versetzt das Werkzeug mit Vorschub Fräsen quer auf den Startpunkt der nächsten Zeile; die TNC berechnet den Versatz aus der programmierten Breite und der Anzahl der Schnitte
  5. Danach fährt das Werkzeug in negativer Richtung der 1. Achse zurück
  6. Das Abzeilen wiederholt sich, bis die eingegebene Fläche vollständig bearbeitet ist
  7. Am Ende fährt die TNC das Werkzeug mit FMAX zurück auf den Sicherheits-Abstand


Beim Programmieren beachten!

Die TNC positioniert das Werkzeug von der aktuellen Position zunächst in der Bearbeitungsebene und anschließend in der Spindelachse auf den Startpunkt.

Werkzeug so vorpositionieren, dass keine Kollision mit dem Werkstück oder Spannmitteln erfolgen kann.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Beispiel: NC-Sätze
71 cycl def 230 abzeilen
Q225=+10 ;startpunkt 1. achse
Q226=+12 ;startpunkt 2. achse
Q227=+2.5 ;startpunkt 3. achse
Q218=150 ;1. seiten-laenge
Q219=75 ;2. Seiten-laenge
Q240=25 ;anzahl schnitte
Q206=150 ;vorschub tiefenz.
Q207=500 ;vorschub fraesen
Q209=200 ;vorschub quer
Q200=2 ;sicherheits-abst.

Startpunkt 1. Achse Q225 (absolut): Min-Punkt-Koordinate der abzuzeilenden Fläche in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Startpunkt 2. Achse Q226 (absolut): Min-Punkt-Koordinate der abzuzeilenden Fläche in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Startpunkt 3. Achse Q227 (absolut): Höhe in der Spindelachse, auf der abgezeilt wird. Eingabebereich -99999,9999 bis 99999,9999

1. Seiten-Länge Q218 (inkremental): Länge der abzuzeilenden Fläche in der Hauptachse der Bearbeitungsebene, bezogen auf den Startpunkt 1. Achse. Eingabebereich 0 bis 99999,9999

2. Seiten-Länge Q219 (inkremental): Länge der abzuzeilenden Fläche in der Nebenachse der Bearbeitungsebene, bezogen auf den Startpunkt 2. Achse. Eingabebereich 0 bis 99999,9999

Anzahl Schnitte Q240: Anzahl der Zeilen, auf denen die TNC das Werkzeug in der Breite verfahren soll. Eingabebereich 0 bis 99999

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Fahren vom Sicherheits-Abstand auf die Frästiefe in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub quer Q209: Verfahrgeschwindigkeit des Werkzeugs beim Fahren auf die nächste Zeile in mm/min; wenn Sie im Material quer fahren, dann Q209 kleiner als Q207 eingeben; wenn Sie im Freien quer fahren, dann darf Q209 größer als Q207 sein. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Frästiefe für Positionierung am Zyklus-Anfang und am Zyklus-Ende. Eingabebereich 0 bis 99999,9999 alternativ predef


REGELFLAECHE (Zyklus 231; DIN/ISO: G231)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Die TNC positioniert das Werkzeug von der aktuellen Position aus mit einer 3D-Geradenbewegung auf den Startpunkt 1
  2. Anschließend fährt das Werkzeug mit dem programmierten Vorschub Fräsen auf den Endpunkt 2
  3. Dort fährt die TNC das Werkzeug im Eilgang FMAX um den Werkzeug-Durchmesser in positive Spindelachsenrichtung und danach wieder zurück zum Startpunkt 1
  4. Am Startpunkt 1 fährt die TNC das Werkzeug wieder auf den zuletzt gefahrenen Z-Wert
  5. Anschließend versetzt die TNC das Werkzeug in allen drei Achsen von Punkt 1 in Richtung des Punktes 4 auf die nächste Zeile
  6. Danach fährt die TNC das Werkzeug auf den Endpunkt dieser Zeile. Den Endpunkt berechnet die TNC aus Punkt 2 und einem Versatz in Richtung Punkt 3
  7. Das Abzeilen wiederholt sich, bis die eingegebene Fläche vollständig bearbeitet ist
  8. Am Ende positioniert die TNC das Werkzeug um den Werkzeug-Durchmesser über den höchsten eingegebenen Punkt in der Spindelachse
Weitere Informationen:
> Schnittführung


Schnittführung

Der Startpunkt und damit die Fräsrichtung ist frei wählbar, weil die TNC die Einzelschnitte grundsätzlich von Punkt 1 nach Punkt 2 fährt und der Gesamtablauf von Punkt 1 / 2 nach Punkt 3 / 4 verläuft. Sie können Punkt 1 an jede Ecke der zu bearbeitenden Fläche legen.

    Die Oberflächengüte beim Einsatz von Schaftfräsern können Sie optimieren:

  • Durch stoßenden Schnitt (Spindelachsenkoordinate Punkt 1 größer als Spindelachsenkoordinate Punkt 2) bei wenig geneigten Flächen.

  • Durch ziehenden Schnitt (Spindelachsenkoordinate Punkt 1 kleiner als Spindelachsenkoordinate Punkt 2) bei stark geneigten Flächen

  • Bei windschiefen Flächen, Hauptbewegungs-Richtung (von Punkt 1 nach Punkt 2) in die Richtung der stärkeren Neigung legen

    Die Oberflächengüte beim Einsatz von Radiusfräsern können Sie optimieren:

  • Bei windschiefen Flächen Hauptbewegungs-Richtung (von Punkt 1 nach Punkt 2) senkrecht zur Richtung der stärksten Neigung legen


Beim Programmieren beachten!

Die TNC positioniert das Werkzeug von der aktuellen Position mit einer 3D-Geradenbewegung auf den Startpunkt 1. Werkzeug so vorpositionieren, dass keine Kollision mit dem Werkstück oder Spannmitteln erfolgen kann.

Die TNC fährt das Werkzeug mit Radiuskorrektur R0 zwischen den eingegebenen Positionen

Ggf. Fräser mit einem über Mitte schneidenden Stirnzahn verwenden (DIN 844).

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Startpunkt 1. Achse Q225 (absolut): Startpunkt-Koordinate der abzuzeilenden Fläche in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Startpunkt 2. Achse Q226 (absolut): Startpunkt-Koordinate der abzuzeilenden Fläche in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Startpunkt 3. Achse Q227 (absolut): Startpunkt-Koordinate der abzuzeilenden Fläche in der Spindelachse. Eingabebereich -99999,9999 bis 99999,9999

2. Punkt 1. Achse Q228 (absolut): Endpunkt-Koordinate der abzuzeilenden Fläche in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Punkt 2. Achse Q229 (absolut): Endpunkt-Koordinate der abzuzeilenden Fläche in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Punkt 3. Achse Q230 (absolut): Endpunkt-Koordinate der abzuzeilenden Fläche in der Spindelachse. Eingabebereich -99999,9999 bis 99999,9999

3. Punkt 1. Achse Q231 (absolut): Koordinate des Punktes 3 in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

3. Punkt 2. Achse Q232 (absolut): Koordinate des Punktes 3 in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

3. Punkt 3. Achse Q233 (absolut): Koordinate des Punktes 3 in der Spindelachse. Eingabebereich ‑99999,9999 bis 99999,9999

Beispiel: NC-Sätze
72 cycl def 231 regelflaeche
Q225=+0 ;startpunkt 1. achse
Q226=+5 ;startpunkt 2. achse
Q227=-2 ;startpunkt 3. achse
Q228=+100 ;2. punkt 1. achse
Q229=+15 ;2. punkt 2. achse
Q230=+5 ;2. punkt 3. achse
Q231=+15 ;3. punkt 1. achse
Q232=+125 ;3. punkt 2. achse
Q233=+25 ;3. punkt 3. achse
Q234=+15 ;4. punkt 1. achse
Q235=+125 ;4. punkt 2. achse
Q236=+25 ;4. punkt 3. achse
Q240=40 ;anzahl schnitte
Q207=500 ;vorschub fraesen

4. Punkt 1. Achse Q234 (absolut): Koordinate des Punktes 4 in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

4. Punkt 2. Achse Q235 (absolut): Koordinate des Punktes 4 in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

4. Punkt 3. Achse Q236 (absolut): Koordinate des Punktes 4 in der Spindelachse. Eingabebereich ‑99999,9999 bis 99999,9999

Anzahl Schnitte Q240: Anzahl der Zeilen, die die TNC das Werkzeug zwischen Punkt 1 und 4, bzw. zwischen Punkt 2 und 3 verfahren soll. Eingabebereich 0 bis 99999

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/ min. Die TNC führt den ersten Schnitt mit dem halben programmierten Wert aus. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu, FZ


PLANFRAESEN (Zyklus 232, DIN/ISO: G232)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

    Mit dem Zyklus 232 können Sie eine ebene Fläche in mehreren Zustellungen und unter Berücksichtigung eines Schlicht-Aufmaßes planfräsen. Dabei stehen drei Bearbeitungsstrategien zur Verfügung:

  • Strategie Q389=0: Mäanderförmig bearbeiten, seitliche Zustellung ausserhalb der zu bearbeitenden Fläche
  • Strategie Q389=1: Mäanderförmig bearbeiten, seitliche Zustellung innerhalb der zu bearbeitenden Fläche
  • Strategie Q389=2: Zeilenweise bearbeiten, Rückzug und seitliche Zustellung im Positionier-Vorschub
  1. Die TNC positioniert das Werkzeug im Eilgang FMAX von der aktuellen Position aus mit Positionier-Logik auf den Startpunkt 1: Ist die aktuelle Position in der Spindelachse größer als der 2. Sicherheits-Abstand, dann fährt die TNC das Werkzeug zunächst in der Bearbeitungsebene und dann in der Spindelachse, ansonsten zuerst auf den 2. Sicherheits-Abstand und dann in der Bearbeitungsebene. Der Startpunkt in der Bearbeitungsebene liegt um den Werkzeug-Radius und um den seitlichen Sicherheits-Abstand versetzt neben dem Werkstück
  2. Anschließend fährt das Werkzeug mit Positionier-Vorschub in der Spindelachse auf die von der TNC berechnete erste Zustell-Tiefe
  1. Strategie Q389=0
  3. Danach fährt das Werkzeug mit dem programmierten Vorschub Fräsen auf den Endpunkt 2. Der Endpunkt liegt außerhalb der Fläche, die TNC berechnet ihn aus dem programmierten Startpunkt, der programmierten Länge, dem programmierten seitlichen Sicherheits-Abstand und dem Werkzeug-Radius
  4. Die TNC versetzt das Werkzeug mit Vorschub Vorpositionieren quer auf den Startpunkt der nächsten Zeile; die TNC berechnet den Versatz aus der programmierten Breite, dem Werkzeug-Radius und dem maximalen Bahn-Überlappungs-Faktor
  5. Danach fährt das Werkzeug wieder zurück in Richtung des Startpunktes 1
  6. Der Vorgang wiederholt sich, bis die eingegebene Fläche vollständig bearbeitet ist. Am Ende der letzten Bahn erfolgt die Zustellung auf die nächste Bearbeitungstiefe
  7. Um Leerwege zu vermeiden, wird die Fläche anschließend in umgekehrter Reihenfolge bearbeitet
  8. Der Vorgang wiederholt sich, bis alle Zustellungen ausgeführt sind. Bei der letzten Zustellung wird lediglich das eingegebene Schlichtaufmaß im Vorschub Schlichten abgefräst
  9. Am Ende fährt die TNC das Werkzeug mit FMAX zurück auf den 2. Sicherheits-Abstand
  1. Strategie Q389=1
  3. Danach fährt das Werkzeug mit dem programmierten Vorschub Fräsen auf den Endpunkt 2. Der Endpunkt liegt innerhalb der Fläche, die TNC berechnet ihn aus dem programmierten Startpunkt, der programmierten Länge und dem Werkzeug-Radius
  4. Die TNC versetzt das Werkzeug mit Vorschub Vorpositionieren quer auf den Startpunkt der nächsten Zeile; die TNC berechnet den Versatz aus der programmierten Breite, dem Werkzeug-Radius und dem maximalen Bahn-Überlappungs-Faktor
  5. Danach fährt das Werkzeug wieder zurück in Richtung des Startpunktes 1. Der Versatz auf die nächste Zeile erfolgt wieder innerhalb des Werkstückes
  6. Der Vorgang wiederholt sich, bis die eingegebene Fläche vollständig bearbeitet ist. Am Ende der letzten Bahn erfolgt die Zustellung auf die nächste Bearbeitungstiefe
  7. Um Leerwege zu vermeiden, wird die Fläche anschließend in umgekehrter Reihenfolge bearbeitet
  8. Der Vorgang wiederholt sich, bis alle Zustellungen ausgeführt sind. Bei der letzten Zustellung wird lediglich das eingegebene Schlichtaufmaß im Vorschub Schlichten abgefräst
  9. Am Ende fährt die TNC das Werkzeug mit FMAX zurück auf den 2. Sicherheits-Abstand
  1. Strategie Q389=2
  3. Danach fährt das Werkzeug mit dem programmierten Vorschub Fräsen auf den Endpunkt 2. Der Endpunkt liegt ausserhalb der Fläche, die TNC berechnet ihn aus dem programmierten Startpunkt, der programmierten Länge, dem programmierten seitlichen Sicherheits-Abstand und dem Werkzeug-Radius
  4. Die TNC fährt das Werkzeug in der Spindelachse auf Sicherheits-Abstand über die aktuelle Zustell-Tiefe und fährt im Vorschub Vorpositionieren direkt zurück auf den Startpunkt der nächsten Zeile. Die TNC berechnet den Versatz aus der programmierten Breite, dem Werkzeug-Radius und dem maximalen Bahn-Überlappungs-Faktor
  5. Danach fährt das Werkzeug wieder auf die aktuelle Zustell-Tiefe und anschließend wieder in Richtung des Endpunktes 2
  6. Der Abzeil-Vorgang wiederholt sich, bis die eingegebene Fläche vollständig bearbeitet ist. Am Ende der letzten Bahn erfolgt die Zustellung auf die nächste Bearbeitungstiefe
  7. Um Leerwege zu vermeiden, wird die Fläche anschließend in umgekehrter Reihenfolge bearbeitet
  8. Der Vorgang wiederholt sich, bis alle Zustellungen ausgeführt sind. Bei der letzten Zustellung wird lediglich das eingegebene Schlichtaufmaß im Vorschub Schlichten abgefräst
  9. Am Ende fährt die TNC das Werkzeug mit FMAX zurück auf den 2. Sicherheits-Abstand


Beim Programmieren beachten!

Den 2. Sicherheits-Abstand Q204 so eingeben, dass keine Kollision mit dem Werkstück oder Spannmitteln erfolgen kann.

Achtung Kollisionsgefahr!

Mit Maschinen-Parameter 7441 Bit 0 stellen Sie ein, ob die TNC eine Fehlermeldung ausgeben soll (Bit 0=0) oder nicht (Bit 0=1), wenn beim Zyklus-Aufruf die Spindel nicht läuft. Die Funktion muss auch von Ihrem Maschinenhersteller angepasst sein.


Zyklusparameter

Bearbeitungsstrategie (0/1/2) Q389: Festlegen, wie die TNC die Fläche bearbeiten soll: 0: Mäanderförmig bearbeiten, seitliche Zustellung im Positionier-Vorschub ausserhalb der zu bearbeitenden Fläche 1: Mäanderförmig bearbeiten, seitliche Zustellung im Fräsvorschub innerhalb der zu bearbeitenden Fläche 2: Zeilenweise bearbeiten, Rückzug und seitliche Zustellung im Positionier-Vorschub

Startpunkt 1. Achse Q225 (absolut): Startpunkt-Koordinate der zu bearbeitenden Fläche in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Startpunkt 2. Achse Q226 (absolut): Startpunkt-Koordinate der abzuzeilenden Fläche in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Startpunkt 3. Achse Q227 (absolut): Koordinate Werkstück-Oberfläche, von der aus die Zustellungen berechnet werden. Eingabebereich -99999,9999 bis 99999,9999

Endpunkt 3. Achse Q386 (absolut): Koordinate in der Spindelachse, auf die die Fläche plangefräst werden soll. Eingabebereich -99999,9999 bis 99999,9999

1. Seiten-Länge Q218 (inkremental): Länge der zu bearbeitenden Fläche in der Hauptachse der Bearbeitungsebene. Über das Vorzeichen können Sie die Richtung der ersten Fräsbahn bezogen auf den Startpunkt 1. Achse festlegen. Eingabebereich ‑99999,9999 bis 99999,9999

2. Seiten-Länge Q219 (inkremental): Länge der zu bearbeitenden Fläche in der Nebenachse der Bearbeitungsebene. Über das Vorzeichen können Sie die Richtung der ersten Querzustellung bezogen auf den Startpunkt 2. Achse festlegen. Eingabebereich -99999,9999 bis 99999,9999

Maximale Zustell-Tiefe Q202 (inkremental): Maß, um welches das Werkzeug jeweils maximal zugestellt wird. Die TNC berechnet die tatsächliche Zustell-Tiefe aus der Differenz zwischen Endpunkt und Startpunkt in der Werkzeugachse – unter Berücksichtigung des Schlichtaufmaßes – so, dass jeweils mit gleichen Zustell-Tiefen bearbeitet wird. Eingabebereich 0 bis 99999,9999

Schlichtaufmaß Tiefe Q369 (inkremental): Wert, mit dem die letzte Zustellung verfahren werden soll. Eingabebereich 0 bis 99999,9999

Max. Bahn-Überlappung Faktor Q370: Maximale seitliche Zustellung k. Die TNC berechnet die tatsächliche seitliche Zustellung aus der 2. Seitenlänge (Q219) und dem Werkzeug-Radius so, dass jeweils mit konstanter seitlicher Zustellung bearbeitet wird. Wenn Sie in der Werkzeug-Tabelle einen Radius R2 eingetragen haben (z.B. Plattenradius bei Verwendung eines Messerkopfes), verringert die TNC die seitlichen Zustellung entsprechend. Eingabebereich 0,1 bis 1,9999 alternativ predef
Beispiel: NC-Sätze
71 cycl def 232 planfraesen
Q389=2 ;strategie
Q225=+10 ;startpunkt 1. achse
Q226=+12 ;startpunkt 2. achse
Q227=+2.5 ;startpunkt 3. achse
Q386=-3 ;endpunkt 3. achse
Q218=150 ;1. seiten-laenge
Q219=75 ;2. Seiten-laenge
Q202=2 ;Max. Zustell-tiefe
Q369=0.5 ;aufmass tiefe
Q370=1 ;max. ueberlappung
Q207=500 ;vorschub fraesen
Q385=800 ;vorschub schlichten
Q253=2000 ;vorschub vorpos.
Q200=2 ;sicherheits-abst.
Q357=2 ;si.-abstand seite
Q204=2 ;2. sicherheits-abst.

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Schlichten Q385: Verfahrgeschwindigkeit des Werkzeugs beim Fräsen der letzten Zustellung in mm/min. Eingabebereich 0 bis 99999,9999 alternativ FAUTO, fu, FZ

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Anfahren der Startposition und beim Fahren auf die nächste Zeile in mm/min; wenn Sie im Material quer fahren (Q389=1), dann fährt die TNC die Querzustellung mit Fräsvorschub Q207. Eingabebereich 0 bis 99999,9999 alternativ fmax, FAUTO, predef

Sicherheits-Abstand Q200 (inkremental): Abstand zwischen Werkzeugspitze und Startposition in der Werkzeugachse. Wenn Sie mit Bearbeitungsstrategie Q389=2 fräsen, fährt die TNC im Sicherheits-Abstand über der aktuellen Zustell-Tiefe den Startpunkt auf der nächsten Zeile an. Eingabebereich 0 bis 99999,9999 alternativ predef

Sicherheits-Abstand Seite Q357 (inkremental): Seitlicher Abstand des Werkzeuges vom Werkstück beim Anfahren der ersten Zustell-Tiefe und Abstand, auf dem die seitliche Zustellung bei Bearbeitungsstrategie Q389=0 und Q389=2 verfahren wird. Eingabebereich 0 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef


Programmierbeispiele

Weitere Informationen:
> Beispiel: Abzeilen


Beispiel: Abzeilen

0 begin pgm c230 mm |
1 blk form 0.1 z x+0 y+0 z+0 | Rohteil-Definition
2 blk form 0.2 x+100 y+100 z+40 |
3 tool def 1 l+0 r+5 | Werkzeug-Definition
4 tool call 1 z s3500 | Werkzeug-Aufruf
5 l z+250 r0 fmax | Werkzeug freifahren
6 cycl def 230 abzeilen | Zyklus-Definition Abzeilen
Q225=+0 ;startPUNKT 1. achse |
Q226=+0 ;startPUNKT 2. achse |
Q227=+35 ;startPUNKT 3. achse |
Q218=100 ;1. seiten-laenge |
Q219=100 ;2. seiten-laenge |
Q240=25 ;anzahl schnitte |
Q206=250 ;f tiefenzust. |
Q207=400 ;f fraesen |
Q209=150 ;f quer |
Q200=2 ;sicherheitsabst. |
7 l x+-25 y+0 r0 fmax m3 | Vorpositionieren in die Nähe des Startpunkts
8 cycl call | Zyklus-Aufruf
9 l z+250 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
10 end pgm c230 mm |


Zyklen: Koordinaten-Umrechnungen

Weitere Informationen:
> Grundlagen
> NULLPUNKT-Verschiebung (Zyklus 7, DIN/ISO: G54)
> NULLPUNKT-Verschiebung mit Nullpunkt-Tabellen (Zyklus 7, DIN/ISO: G53)
> BEZUGSPUNKT SETZEN (Zyklus 247, DIN/ISO: G247)
> SPIEGELN (Zyklus 8, DIN/ISO: G28)
> DREHUNG (Zyklus 10, DIN/ISO: G73)
> MASSFAKTOR (Zyklus 11, DIN/ISO: G72)
> MASSFAKTOR ACHSSP. (Zyklus 26)
> BEARBEITUNGSEBENE (Zyklus 19, DIN/ISO: G80, Software-Option 1)
> Programmierbeispiele


Grundlagen

Weitere Informationen:
> Übersicht
> Wirksamkeit der Koordinaten-Umrechnungen


Übersicht

Mit Koordinaten-Umrechnungen kann die TNC eine einmal programmierte Kontur an verschiedenen Stellen des Werkstücks mit veränderter Lage und Größe ausführen. Die TNC stellt folgende Koordinaten-Umrechnungszyklen zur Verfügung:

Zyklus | Softkey | Seite
7 NULLPUNKT Konturen verschieben direkt im Programm oder aus Nullpunkt-Tabellen |  | NULLPUNKT-Verschiebung (Zyklus 7, DIN/ISO: G54)
247 BEZUGSPUNKT SETZEN Bezugspunkt während des Programmlaufs setzen |  | BEZUGSPUNKT SETZEN (Zyklus 247, DIN/ISO: G247)
8 SPIEGELN Konturen spiegeln |  | SPIEGELN (Zyklus 8, DIN/ISO: G28)
10 DREHUNG Konturen in der Bearbeitungsebene drehen |  | DREHUNG (Zyklus 10, DIN/ISO: G73)
11 MASSFAKTOR Konturen verkleinern oder vergrößern |  | MASSFAKTOR (Zyklus 11, DIN/ISO: G72)
26 ACHSSPEZIFISCHER MASSFAKTOR Konturen verkleinern oder vergrößern mit achsspezifischen Maßfaktoren |  | MASSFAKTOR ACHSSP. (Zyklus 26)
19 BEARBEITUNGSEBENE Bearbeitungen im geschwenkten Koordinatensystem durchführen für Maschinen mit Schwenkköpfen und/oder Drehtischen |  | BEARBEITUNGSEBENE (Zyklus 19, DIN/ISO: G80, Software-Option 1)


Wirksamkeit der Koordinaten-Umrechnungen

Beginn der Wirksamkeit: Eine Koordinaten-Umrechnung wird ab ihrer Definition wirksam – wird also nicht aufgerufen. Sie wirkt so lange, bis sie rückgesetzt oder neu definiert wird.

    Koordinaten-Umrechnung rücksetzen:

  • Zyklus mit Werten für das Grundverhalten erneut definieren, z.B. Maßfaktor 1.0
  • Zusatzfunktionen M2, M30 oder den Satz END PGM ausführen (abhängig von Maschinen-Parameter 7300)
  • Neues Programm wählen
  • Zusatzfunktion M142 Modale Programminformationen löschen -programmieren


NULLPUNKT-Verschiebung (Zyklus 7, DIN/ISO: G54)

Weitere Informationen:
> Wirkung
> Zyklusparameter


Wirkung

Mit der NULLPUNKT-VERSCHIEBUNG können Sie Bearbeitungen an beliebigen Stellen des Werkstücks wiederholen.

Nach einer Zyklus-Definition NULLPUNKT-VERSCHIEBUNG beziehen sich alle Koordinaten-Eingaben auf den neuen Nullpunkt. Die Verschiebung in jeder Achse zeigt die TNC in der zusätzlichen Status-Anzeige an. Die Eingabe von Drehachsen ist auch erlaubt.

Rücksetzen

  • Verschiebung zu den Koordinaten X=0; Y=0 etc. durch erneute Zyklus-Definition programmieren
  • Funktion TRANS DATUM RESET verwenden
  • Aus der Nullpunkt-Tabelle Verschiebung zu den Koordinaten
    X=0; Y=0 etc. aufrufen

Grafik

Wenn Sie nach einer Nullpunkt-Verschiebung eine neue BLK FORM programmieren, können Sie über den Maschinen-Parameter 7310 entscheiden, ob sich die BLK FORM auf den neuen oder alten Nullpunkt beziehen soll. Bei der Bearbeitung mehrerer Teile kann die TNC dadurch jedes Teil einzeln grafisch darstellen.


Zyklusparameter

Beispiel: NC-Sätze
13 cycl def 7.0 nullpunkt
14 cycl def 7.1 x+60
16 cycl def 7.3 z-5
15 cycl def 7.2 y+40

Verschiebung: Koordinaten des neuen Nullpunkts eingeben; Absolutwerte beziehen sich auf den Werkstück-Nullpunkt, der durch das Bezugspunkt-Setzen festgelegt ist; Inkrementalwerte beziehen sich immer auf den zuletzt gültigen Nullpunkt – dieser kann bereits verschoben sein. Eingabe-Bereich bis zu 6 NC-Achsen, jeweils von -99999,9999 bis 99999,9999


NULLPUNKT-Verschiebung mit Nullpunkt-Tabellen (Zyklus 7, DIN/ISO: G53)

Weitere Informationen:
> Wirkung
> Beim Programmieren beachten!
> Zyklusparameter
> Nullpunkt-Tabelle im NC-Programm wählen
> Nullpunkt-Tabelle editieren in der Betriebsart Programm-Einspeichern/Editieren
> Nullpunkt-Tabelle in einer Programmlauf-Betriebsart editieren
> Istwerte in die Nullpunkt-Tabelle übernehmen
> Nullpunkt-Tabelle konfigurieren
> Nullpunkt-Tabelle verlassen


Wirkung

    Nullpunkt-Tabellen setzen Sie z.B. ein bei

  • häufig wiederkehrenden Bearbeitungsgängen an verschiedenen Werkstück-Positionen oder
  • häufiger Verwendung derselben Nullpunktverschiebung

Innerhalb eines Programms können Sie Nullpunkte sowohl direkt in der Zyklus-Definition programmieren als auch aus einer Nullpunkt-Tabelle heraus aufrufen.

Weitere Informationen:
> Rücksetzen
> Grafik
> Status-Anzeigen


Rücksetzen
  • Aus der Nullpunkt-Tabelle Verschiebung zu den Koordinaten
    X=0; Y=0 etc. aufrufen
  • Verschiebung zu den Koordinaten X=0; Y=0 etc. direkt mit einer Zyklus-Definition aufrufen
  • Funktion TRANS DATUM RESET verwenden


Grafik

Wenn Sie nach einer Nullpunkt-Verschiebung eine neue BLK FORM programmieren, können Sie über den Maschinen-Parameter 7310 entscheiden, ob sich die BLK FORM auf den neuen oder alten Nullpunkt beziehen soll. Bei der Bearbeitung mehrerer Teile kann die TNC dadurch jedes Teil einzeln grafisch darstellen.


Status-Anzeigen

    In der zusätzlichen Status-Anzeige werden folgende Daten aus der Nullpunkt-Tabelle angezeigt:

  • Name und Pfad der aktiven Nullpunkt-Tabelle
  • Aktive Nullpunkt-Nummer
  • Kommentar aus der Spalte DOC der aktiven Nullpunkt-Nummer


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Nullpunkte aus der Nullpunkt-Tabelle beziehen sich immer und ausschließlich auf den aktuellen Bezugspunkt (Preset).

Der Maschinen-Parameter 7475, mit dem früher festgelegt wurde, ob sich Nullpunkte auf den Maschinen-Nullpunkt oder den Werkstück-Nullpunkt beziehen, hat nur noch eine Sicherheits-Funktion. Ist MP7475 = 1 gesetzt gibt die TNC eine Fehlermeldung aus, wenn eine Nullpunkt-Verschiebung aus einer Nullpunkt-Tabelle aufgerufen wird.

Nullpunkt-Tabellen aus der TNC 4xx, deren Koordinaten sich auf den Maschinen-Nullpunkt bezogen (MP7475 = 1), dürfen in der iTNC 530 nicht verwendet werden.

Wenn Sie Nullpunkt-Verschiebungen mit Nullpunkt-Tabellen einsetzen, dann verwenden Sie die Funktion SEL TABLE, um die gewünschte Nullpunkt-Tabelle vom NC-Programm aus zu aktivieren.

Wenn Sie ohne SEL TABLE arbeiten, dann müssen Sie die gewünschte Nullpunkt-Tabelle vor dem Programm-Test oder dem Programm-Lauf aktivieren (gilt auch für die Programmier-Grafik):

  • Gewünschte Tabelle für Programm-Test in der Betriebsart Programm-Test über die Datei-Verwaltung wählen: Tabelle erhält den Status S
  • Gewünschte Tabelle für den Programmlauf in einer Programmlauf-Betriebsart über die Datei-Verwaltung wählen: Tabelle erhält den Status M

Die Koordinaten-Werte aus Nullpunkt-Tabellen sind ausschließlich absolut wirksam.

Neue Zeilen können Sie nur am Tabellen-Ende einfügen.


Zyklusparameter

Beispiel: NC-Sätze
77 cycl def 7.0 nullpunkt
78 cycl def 7.1 #5

Verschiebung: Nummer des Nullpunktes aus der Nullpunkt-Tabelle oder einen Q-Parameter eingeben; Wenn Sie einen Q-Parameter eingeben, dann aktiviert die TNC die Nullpunkt-Nummer, die im Q-Parameter steht. Eingabe-Bereich 0 bis 9999


Nullpunkt-Tabelle im NC-Programm wählen

Mit der Funktion SEL TABLE wählen Sie die Nullpunkt-Tabelle, aus der die TNC die Nullpunkte entnimmt:

Funktionen zum Programm-Aufruf wählen: Taste PGM CALL drücken

Softkey NULLPUNKT TABELLE drücken

Softkey Auswahl fenster drücken: Die TNC blendet ein Fenster ein, in dem Sie die gewünschte Nullpunkt-Tabelle wählen können

Gewünschtes Nullpunkt-Tabelle mit Pfeiltasten oder per Mouse-Klick wählen, mit Taste ENT bestätigen: Die TNC trägt den vollständigen Pfadnamen in den SEL TABLE-Satz ein

Funktion mit Taste END abschließen

Alternativ können Sie den Tabellen-Namen oder den vollständigen Pfadnamen der aufzurufenden Tabelle auch direkt über die Tastatur eingeben.

SEL TABLE-Satz vor Zyklus 7 Nullpunkt-Verschiebung programmieren.

Eine mit SEL TABLE gewählte Nullpunkt-Tabelle bleibt solange aktiv, bis Sie mit SEL TABLE oder über PGM MGT eine andere Nullpunkt-Tabelle wählen.

Mit der Funktion TRANS DATUM TABLE können Sie Nullpunkt-Tabellen und Nullpunkt-Nummer in einem NC-Satz definieren (siehe Benutzer-Handbuch Klartext-Dialog).


Nullpunkt-Tabelle editieren in der Betriebsart Programm-Einspeichern/Editieren

Nachdem Sie einen Wert in einer Nullpunkt-Tabelle geändert haben, müssen Sie die Änderung mit der Taste ENT speichern. Ansonsten wird die Änderung ggf. beim Abarbeiten eines Programmes nicht berücksichtigt.

Die Nullpunkt-Tabelle wählen Sie in der Betriebsart Programm-Einspeichern/Editieren

Datei-Verwaltung aufrufen: Taste PGM MGT drücken

Nullpunkt-Tabellen anzeigen: Softkeys TYP WÄHLEN und ZEIGE .D drücken

Gewünschte Tabelle wählen oder neuen Dateinamen eingeben

Datei editieren. Die Softkey-Leiste zeigt dazu folgende Funktionen an:

Funktion | Softkey
Tabellen-Anfang wählen |
Tabellen-Ende wählen |
Seitenweise blättern nach oben |
Seitenweise blättern nach unten |
Zeile einfügen (nur möglich am Tabellen-Ende) |
Zeile löschen |
Eingegebene Zeile übernehmen und Sprung zur nächsten Zeile |
Eingebbare Anzahl von Zeilen (Nullpunkten) am Tabellenende anfügen |


Nullpunkt-Tabelle in einer Programmlauf-Betriebsart editieren

In einer Programmlauf-Betriebsart können Sie die jeweils aktive Nullpunkt-Tabelle wählen. Drücken Sie dazu den Softkey NULLPUNKT-TABELLE. Ihnen stehen dann die selben Editierfunktionen zur Verfügung wie in der Betriebsart Programm-Einspeichern/Editieren


Istwerte in die Nullpunkt-Tabelle übernehmen

Über die Taste „Ist-Position übernehmen“ können Sie die aktuelle Werkzeug-Position oder die zuletzt angetastete Positionen in die Nullpunkt-Tabelle übernehmen:

  • Eingabefeld auf die Zeile und in die Spalte positionieren, in die eine Position übernommen werden soll

Funktion Ist-Position übernehmen wählen: Die TNC fragt in einem Überblendfenster ab, ob Sie die aktuelle Werkzeug-Position oder zuletzt angetastete Werte übernehmen wollen

Gewünschte Funktion mit Pfeiltasten wählen und mit Taste ent bestätigen

Werte in allen Achsen übernehmen: Softkey alle werte drücken, oder

Wert in der Achse übernehmen, auf der das Eingabefeld steht: Softkey aktuellen wert drücken


Nullpunkt-Tabelle konfigurieren

Auf der zweiten und dritten Softkeyleiste können Sie für jede Nullpunkt-Tabelle die Achsen festlegen, für die Sie Nullpunkte definieren wollen. Standardmäßig sind alle Achsen aktiv. Wenn Sie eine Achse aussperren wollen, dann setzen Sie den entsprechenden Achs-Softkey auf AUS. Die TNC löscht dann die zugehörige Spalte in der Nullpunkt-Tabelle.

Wenn Sie zu einer aktiven Achse keinen Nullpunkt definieren wollen, drücken Sie die Taste no ent. Die TNC trägt dann einen Bindestrich in die entsprechende Spalte ein.


Nullpunkt-Tabelle verlassen

In der Datei-Verwaltung anderen Datei-Typ anzeigen lassen und gewünschte Datei wählen.


BEZUGSPUNKT SETZEN (Zyklus 247, DIN/ISO: G247)

Weitere Informationen:
> Wirkung
> Vor dem Programmieren beachten!
> Zyklusparameter


Wirkung

Mit dem Zyklus BEZUGSPUNKT SETZEN können Sie einen in der Preset-Tabelle definierten Preset als neuen Bezugspunkt aktivieren.

Nach einer Zyklus-Definition BEZUGSPUNKT SETZEN beziehen sich alle Koordinaten-Eingaben und Nullpunkt-Verschiebungen (absolute und inkrementale) auf den neuen Preset.

Status-Anzeige

In der Status-Anzeige zeigt die TNC die aktive Preset-Nummer hinter dem Bezugspunkt-Symbol an.


Vor dem Programmieren beachten!

Beim Aktivieren eines Bezugspunktes aus der Preset-Tabelle, setzt die TNC eine aktive Nullpunkt-Verschiebung zurück.

Die TNC setzt den Preset nur in den Achsen, die in der Preset-Tabelle mit Werten definiert sind. Der Bezugspunkt von Achsen, die mit - gekennzeichnet sind bleibt unverändert.

Wenn Sie den Preset Nummer 0 (Zeile 0) aktivieren, dann aktivieren Sie den Bezugspunkt, den Sie zuletzt in einer manuellen Betriebsart gesetzt haben.

In der Betriebsart PGM-Test ist Zyklus 247 nicht wirksam.


Zyklusparameter

Beispiel: NC-Sätze
13 cycl def 247 bezugspunkt setzen
Q339=4 ;bezugspunkt-nummer

Nummer für Bezugspunkt?: Nummer des Bezugspunktes aus der Preset-Tabelle angeben, der aktiviert werden soll. Eingabe-Bereich 0 bis 65535


SPIEGELN (Zyklus 8, DIN/ISO: G28)

Weitere Informationen:
> Wirkung
> Beim Programmieren beachten!
> Zyklenparameter


Wirkung

Die TNC kann Bearbeitung in der Bearbeitungsebene spiegelbildlich ausführen.

Die Spiegelung wirkt ab ihrer Definition im Programm. Sie wirkt auch in der Betriebsart Positionieren mit Handeingabe. Die TNC zeigt aktive Spiegelachsen in der zusätzlichen Status-Anzeige an.

  • Wenn Sie nur eine Achse spiegeln, ändert sich der Umlaufsinn des Werkzeugs. Dies gilt nicht bei Bearbeitungszyklen.
  • Wenn Sie zwei Achsen spiegeln, bleibt der Umlaufsinn erhalten.

    Das Ergebnis der Spiegelung hängt von der Lage des Nullpunkts ab:

  • Nullpunkt liegt auf der zu spiegelnden Kontur: Das Element wird direkt am Nullpunkt gespiegelt;
  • Nullpunkt liegt außerhalb der zu spiegelnden Kontur: Das Element verlagert sich zusätzlich;

Rücksetzen

Zyklus SPIEGELN mit Eingabe NO ENT erneut programmieren.


Beim Programmieren beachten!

Wenn Sie nur eine Achse Spiegeln, ändert sich der Umlaufsinn bei den Frässzyklen mit 200er Nummer. Außnahme: Zyklus 208, bei dem der im Zyklus definierte Umlaufsinn erhalten bleibt.


Zyklenparameter

Beispiel: NC-Sätze
79 cycl def 8.0 spiegeln
80 cycl def 8.1 x y u

Gespiegelte Achse?: Achsen eingeben, die gespiegelt werden soll; Sie können alle Achsen spiegeln – incl. Drehachsen – mit Ausnahme der Spindelachse und der dazugehörigen Nebenachse. Erlaubt ist die Eingabe von maximal drei Achsen. Eingabe-Bereich bis zu 3 NC-Achsen X, Y, Z, U, V, W, A, B, C


DREHUNG (Zyklus 10, DIN/ISO: G73)

Weitere Informationen:
> Wirkung
> Beim Programmieren beachten!
> Zyklusparameter


Wirkung

Innerhalb eines Programms kann die TNC das Koordinatensystem in der Bearbeitungsebene um den aktiven Nullpunkt drehen.

Die DREHUNG wirkt ab ihrer Definition im Programm. Sie wirkt auch in der Betriebsart Positionieren mit Handeingabe. Die TNC zeigt den aktiven Drehwinkel in der zusätzlichen Status-Anzeige an.

    Bezugsachse für den Drehwinkel:

  • X/Y-Ebene X-Achse
  • Y/Z-Ebene Y-Achse
  • Z/X-Ebene Z-Achse

Rücksetzen

Zyklus DREHUNG mit Drehwinkel 0° erneut programmieren.


Beim Programmieren beachten!

Die TNC hebt eine aktive Radius-Korrektur durch Definieren von Zyklus 10 auf. Ggf. Radius-Korrektur erneut programmieren.

Nachdem Sie Zyklus 10 definiert haben, verfahren Sie beide Achsen der Bearbeitungsebene, um die Drehung zu aktivieren.


Zyklusparameter

Beispiel: NC-Sätze
12 call lbl 1
13 cycl def 7.0 nullpunkt
14 cycl def 7.1 x+60
15 cycl def 7.2 y+40
16 cycl def 10.0 drehung
17 cycl def 10.1 rot+35
18 call lbl 1

Drehung: Drehwinkel in Grad (°) eingeben. Eingabebereich -360,000° bis +360,000° (absolut oder inkremental)


MASSFAKTOR (Zyklus 11, DIN/ISO: G72)

Weitere Informationen:
> Wirkung
> Zyklusparameter


Wirkung

Die TNC kann innerhalb eines Programms Konturen vergrößern oder verkleinern. So können Sie beispielsweise Schrumpf- und Aufmaß-Faktoren berücksichtigen.

Der MASSFAKTOR wirkt ab seiner Definition im Programm. Er wirkt auch in der Betriebsart Positionieren mit Handeingabe. Die TNC zeigt den aktiven Maßfaktor in der zusätzlichen Status-Anzeige an.

    Der Maßfaktor wirkt

  • in der Bearbeitungsebene, oder auf alle drei Koordinatenachsen gleichzeitig (abhängig von Maschinen-Parameter 7410)
  • auf Maßangaben in Zyklen
  • auch auf Parallelachsen U,V,W

Voraussetzung

Vor der Vergrößerung bzw. Verkleinerung sollte der Nullpunkt auf eine Kante oder Ecke der Kontur verschoben werden.

Vergrößern: SCL größer als 1 bis 99,999 999

Verkleinern: SCL kleiner als 1 bis 0,000 001

Rücksetzen

Zyklus MASSFAKTOR mit Maßfaktor 1 erneut programmieren.


Zyklusparameter

Beispiel: NC-Sätze
11 call lbl 1
12 cycl def 7.0 nullpunkt
13 cycl def 7.1 x+60
14 cycl def 7.2 y+40
15 cycl def 11.0 massfaktor
16 cycl def 11.1 scl 0.75
17 call lbl 1

Faktor?: Faktor SCL eingeben (engl.: scaling); die TNC multipliziert Koordinaten und Radien mit SCL (wie in „Wirkung“ beschrieben). Eingabe-Bereich 0,000000 bis 99,999999


MASSFAKTOR ACHSSP. (Zyklus 26)

Weitere Informationen:
> Wirkung
> Beim Programmieren beachten!
> Zyklusparameter


Wirkung

Mit dem Zyklus 26 können Sie Schrumpf- und Aufmaß-Faktoren achsspezifisch berücksichtigen.

Der MASSFAKTOR wirkt ab seiner Definition im Programm. Er wirkt auch in der Betriebsart Positionieren mit Handeingabe. Die TNC zeigt den aktiven Maßfaktor in der zusätzlichen Status-Anzeige an.

Rücksetzen

Zyklus MASSFAKTOR mit Faktor 1 für die entsprechende Achse erneut programmieren


Beim Programmieren beachten!

Koordinatenachsen mit Positionen für Kreisbahnen dürfen Sie nicht mit unterschiedlichen Faktoren strecken oder stauchen.

Für jede Koordinaten-Achse können Sie einen eigenen achsspezifischen Maßfaktor eingeben.

Zusätzlich lassen sich die Koordinaten eines Zentrums für alle Maßfaktoren programmieren.

Die Kontur wird vom Zentrum aus gestreckt oder zu ihm hin gestaucht, also nicht unbedingt vom und zum aktuellen Nullpunkt – wie beim Zyklus 11 MASSFAKTOR.


Zyklusparameter

Beispiel: NC-Sätze
25 call lbl 1
26 cycl def 26.0 massfaktor achssp.
27 cycl def 26.1 x 1.4 y 0.6 ccx+15 ccy+20
28 call lbl 1

Achse und Faktor: Koordinatenachse(n) per Softkey wählen und Faktor(en) der achsspezifischen Streckung oder Stauchungeingeben. Eingabe-Bereich 0,000000 bis 99,999999

Zentrums-Koordinaten: Zentrum der achsspezifischen Streckung oder Stauchung. Eingabe-Bereich ‑99999,9999 bis 99999,9999


BEARBEITUNGSEBENE (Zyklus 19, DIN/ISO: G80, Software-Option 1)

Weitere Informationen:
> Wirkung
> Beim Programmieren beachten!
> Zyklusparameter
> Rücksetzen
> Drehachsen positionieren
> Positions-Anzeige im geschwenkten System
> Arbeitsraum-Überwachung
> Positionieren im geschwenkten System
> Kombination mit anderen Koordinaten-Umrechnungszyklen
> Automatisches Messen im geschwenkten System
> Leitfaden für das Arbeiten mit Zyklus 19 BEARBEITUNGSEBENE


Wirkung

    Im Zyklus 19 definieren Sie die Lage der Bearbeitungsebene – sprich die Lage der Werkzeugachse bezogen auf das maschinenfeste Koordinatensystem – durch die Eingabe von Schwenkwinkeln. Sie können die Lage der Bearbeitungsebene auf zwei Arten festlegen:

  • Stellung der Schwenkachsen direkt eingeben

  • Lage der Bearbeitungsebene durch bis zu drei Drehungen (Raumwinkel) des maschinenfesten Koordinatensystems beschreiben. Die einzugebenden Raumwinkel erhalten Sie, indem Sie einen Schnitt senkrecht durch die geschwenkte Bearbeitungsebene legen und den Schnitt von der Achse aus betrachten, um die Sie schwenken wollen. Mit zwei Raumwinkeln ist bereits jede beliebige Werkzeuglage im Raum eindeutig definiert.

Beachten Sie, dass die Lage des geschwenkten Koordinatensystems und damit auch Verfahrbewegungen im geschwenkten System davon abhängen, wie Sie die geschwenkte Ebene beschreiben.

Wenn Sie die Lage der Bearbeitungsebene über Raumwinkel programmieren, berechnet die TNC die dafür erforderlichen Winkelstelllungen der Schwenkachsen automatisch und legt diese in den Parametern Q120 (A-Achse) bis Q122 (C-Achse) ab.

Achtung Kollissionsgefahr!

Abhängig von Ihrer Maschinenkonfiguration sind bei einer Raumwinkeldefinition rechnerisch zwei Lösungen (Achsstellungen) möglich. Prüfen Sie durch entsprechende Tests an Ihrer Maschine, welche Achsstellung die Software der TNC jeweils wählt.

Wenn Sie die Software-Option DCM verfügbar haben, dann können Sie im Programm-Test die jeweilige Achsstellung in der Ansicht PROGRAMM+KINEMATIK anzeigen lassen (siehe Benutzer-Handbuch Klartext-Dialog, Dynamische Kollisionsüberwachung).

Die Reihenfolge der Drehungen für die Berechnung der Lage der Ebene ist festgelegt: Zuerst dreht die TNC die A-Achse, danach die B-Achse und schließlich die C-Achse.

Zyklus 19 wirkt ab seiner Definition im Programm. Sobald Sie eine Achse im geschwenkten System verfahren, wirkt die Korrektur für diese Achse. Wenn die Korrektur in allen Achsen verrechnet werden soll, dann müssen Sie alle Achsen verfahren.

Falls Sie die Funktion Schwenken Programmlauf in der Betriebsart Manuell auf Aktiv gesetzt haben wird der in diesem Menü eingetragene Winkelwert vom Zyklus 19 BEARBEITUNGSEBENE überschrieben.


Beim Programmieren beachten!

Die Funktionen zum Schwenken der Bearbeitungsebene werden vom Maschinenhersteller an TNC und Maschine angepasst. Bei bestimmten Schwenkköpfen (Schwenktischen) legt der Maschinenhersteller fest, ob die im Zyklus programmierten Winkel von der TNC als Koordinaten der Drehachsen oder als mathematische Winkel einer schiefen Ebene interpretiert werden. Beachten Sie Ihr Maschinenhandbuch.

Da nicht programmierte Drehachsenwerte grundsätzlich immer als unveränderte Werte interpretiert werden, sollten Sie immer alle drei Raumwinkel definieren, auch wenn einer oder mehrere Winkel gleich 0 sind.

Das Schwenken der Bearbeitungsebene erfolgt immer um den aktiven Nullpunkt.

Wenn Sie den Zyklus 19 bei aktivem M120 verwenden, dann hebt die TNC die Radius-Korrektur und damit auch die Funktion M120 automatisch auf.

Achtung Kollisionsgefahr!

Darauf achten, dass der letzte definierte Winkel kleiner 360° eingegeben ist!


Zyklusparameter

Drehachse und -winkel?: Drehachse mit zugehörigem Drehwinkel eingeben; die Drehachsen A, B und C über Softkeys programmieren. Eingabe-Bereich ‑360,000 bis 360,000

Wenn die TNC die Drehachsen automatisch positioniert, dann können Sie noch folgende Parameter eingeben

Vorschub? F=: Verfahrgeschwindigkeit der Drehachse beim automatischen Positionieren. Eingabe-Bereich 0 bis 99999,999

Sicherheits-Abstand? (inkremental): Die TNC positioniert den Schwenkkopf so, dass die Position, die sich aus der Verlängerung des Werkzeugs um den Sicherheits-Abstand, sich relativ zum Werkstück nicht ändert. Eingabe-Bereich 0 bis 99999,9999

Achtung Kollisionsgefahr!

Beachten Sie, dass sich der Sicherheits-Abstand beim Zyklus 19 nicht auf die Oberkante des Werkstücks bezieht (wie dies bei den Bearbeitungszyklen der Fall ist), sondern auf den aktiven Bezugspunkt!


Rücksetzen

Um die Schwenkwinkel rückzusetzen, Zyklus BEARBEITUNGSEBENE erneut definieren und für alle Drehachsen 0° eingeben. Anschließend Zyklus BEARBEITUNGSEBENE nochmal definieren, und die Dialogfrage mit der Taste NO ENT bestätigen. Dadurch setzen Sie die Funktion inaktiv.


Drehachsen positionieren

Der Maschinenhersteller legt fest, ob Zyklus 19 die Drehachsen automatisch positionieren, oder ob Sie die Drehachsen im Programm manuell positionieren müssen. Beachten Sie Ihr Maschinenhandbuch.

Weitere Informationen:
> Drehachsen manuell positionieren
> Drehachsen automatisch positionieren


Drehachsen manuell positionieren

Wenn Zyklus 19 die Drehachsen nicht automatisch positioniert, müssen Sie die Drehachsen in einem separaten L-Satz nach der Zyklus-Definition positionieren.

Wenn Sie mit Achswinkeln arbeiten, können Sie die Achswerte direkt im L-Satz definieren. Wenn Sie mit Raumwinkel arbeiten, dann verwenden Sie die vom Zyklus 19 beschriebenen Q-Parameter Q120 (A-Achswert), Q121 (B-Achswert) und Q122 (C-Achswert).

NC-Beispielsätze:
10 l z+100 r0 fmax |
11 l x+25 y+10 r0 fmax |
12 cycl def 19.0 bearbeitungsebene | Raumwinkel für Korrekturberechnung definieren
13 cycl def 19.1 A+0 B+45 C+0 |
14 l A+Q120 C+q122 r0 f1000 | Drehachsen mit Werten positionieren, die Zyklus 19 berechnet hat
15 l z+80 r0 fmax | Korrektur aktivieren Spindelachse
16 l x-8.5 y-10 r0 fmax | Korrektur aktivieren Bearbeitungsebene

Verwenden Sie beim mauellen Positionieren grundsätzlich immer die in den Q-Parametern Q120 bis Q122 abgelegten Drehachspositionen!

Vermeiden Sie Funktionen wie M94 (Winkelreduzierung), um bei Mehrfachaufrufen keine Unstimmigkeiten zwischen Ist- und Sollpositionen der Drehachsen zu erhalten.


Drehachsen automatisch positionieren

    Wenn Zyklus 19 die Drehachsen automatisch positioniert, gilt:

  • Die TNC kann nur geregelte Achsen automatisch positionieren.
  • In der Zyklus-Definition müssen Sie zusätzlich zu den Schwenkwinkeln einen Sicherheits-Abstand und einen Vorschub eingeben, mit dem die Schwenkachsen positioniert werden.
  • Nur voreingestellte Werkzeuge verwenden (volle Werkzeuglänge muss definiert sein).
  • Beim Schwenkvorgang bleibt die Position der Werkzeugspitze gegenüber dem Werkstück nahezu unverändert.
  • Die TNC führt den Schwenkvorgang mit dem zuletzt programmierten Vorschub aus. Der maximal erreichbare Vorschub hängt ab von der Komplexität des Schwenkkopfes (Schwenktisches).
NC-Beispielsätze:
10 l z+100 r0 fmax |
11 l x+25 y+10 r0 fmax |
12 cycl def 19.0 bearbeitungsebene | Winkel für Korrekturberechnung definieren
13 cycl def 19.1 A+0 B+45 C+0 f5000 abst50 | Zusätzlich Vorschub und Abstand definieren
14 l z+80 r0 fmax | Korrektur aktivieren Spindelachse
15 l x-8.5 y-10 r0 fmax | Korrektur aktivieren Bearbeitungsebene


Positions-Anzeige im geschwenkten System

Die angezeigten Positionen (SOLL und IST) und die Nullpunkt-Anzeige in der zusätzlichen Status-Anzeige beziehen sich nach dem Aktivieren von Zyklus 19 auf das geschwenkte Koordinatensystem. Die angezeigte Position stimmt direkt nach der Zyklus-Definition also ggf. nicht mehr mit den Koordinaten der zuletzt vor Zyklus 19 programmierten Position überein.


Arbeitsraum-Überwachung

Die TNC überprüft im geschwenkten Koordinatensystem nur die Achsen auf Endschalter, die verfahren werden. Ggf. gibt die TNC eine Fehlermeldung aus.


Positionieren im geschwenkten System

Mit der Zusatz-Funktion M130 können Sie auch im geschwenkten System Positionen anfahren, die sich auf das ungeschwenkte Koordinatensystem beziehen.

Auch Positionierungen mit Geradensätzen die sich auf das Maschinen-Koordinatensystem beziehen (Sätze mit M91 oder M92), lassen sich bei geschwenkter Bearbeitungsebene ausführen. Einschränkungen:

  • Positionierung erfolgt ohne Längenkorrektur
  • Positionierung erfolgt ohne Maschinengeometrie-Korrektur
  • Werkzeug-Radiuskorrektur ist nicht erlaubt


Kombination mit anderen Koordinaten-Umrechnungszyklen

Bei der Kombination von Koordinaten-Umrechnungszyklen ist darauf zu achten, dass das Schwenken der Bearbeitungsebene immer um den aktiven Nullpunkt erfolgt. Sie können eine Nullpunkt-Verschiebung vor dem Aktivieren von Zyklus 19 durchführen: dann verschieben Sie das „maschinenfeste Koordinatensystem“.

Falls Sie den Nullpunkt nach dem Aktivieren von Zyklus 19 verschieben, dann verschieben Sie das „geschwenkte Koordinatensystem“.

Wichtig: Gehen Sie beim Rücksetzen der Zyklen in der umgekehrten Reihenfolge wie beim Definieren vor:

1. Nullpunkt-Verschiebung aktivieren

2. Bearbeitungsebene schwenken aktivieren

3. Drehung aktivieren

...

Werkstückbearbeitung

...

1. Drehung rücksetzen

2. Bearbeitungsebene schwenken rücksetzen

3. Nullpunkt-Verschiebung rücksetzen


Automatisches Messen im geschwenkten System

Mit den Messzyklen der TNC können Sie Werkstücke im geschwenkten System vermessen. Die Messergebnisse werden von der TNC in Q-Parametern gespeichert, die Sie anschließend weiterverarbeiten können (z.B. Messergebnisse auf Drucker ausgeben).


Leitfaden für das Arbeiten mit Zyklus 19 BEARBEITUNGSEBENE

1 Programm erstellen

  • Werkzeug definieren (entfällt, wenn TOOL.T aktiv), volle Werkzeug-Länge eingeben

  • Werkzeug aufrufen

  • Spindelachse so freifahren, dass beim Schwenken keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann

  • Ggf. Drehachse(n) mit L-Satz positionieren auf entsprechenden Winkelwert (abhängig von einem Maschinen-Parameter)

  • Ggf. Nullpunkt-Verschiebung aktivieren

  • Zyklus 19 BEARBEITUNGSEBENE definieren; Winkelwerte der Drehachsen eingeben

  • Alle Hauptachsen (X, Y, Z) verfahren, um die Korrektur zu aktivieren

  • Bearbeitung so programmieren, als ob sie in der ungeschwenkten Ebene ausgeführt werden würde

  • Ggf. Zyklus 19 BEARBEITUNGSEBENE mit anderen Winkeln definieren, um die Bearbeitung in einer anderen Achsstellung auszuführen. Es ist in diesem Fall nicht erforderlich Zyklus 19 zurückzusetzen, Sie können direkt die neuen Winkelstellungen definieren

  • Zyklus 19 BEARBEITUNGSEBENE rücksetzen; für alle Drehachsen 0° eingeben

  • Funktion BEARBEITUNGSEBENE deaktivieren; Zyklus 19 erneut definieren, Dialogfrage mit NO ENT bestätigen

  • Ggf. Nullpunkt-Verschiebung rücksetzen

  • Ggf. Drehachsen in die 0°-Stellung positionieren

2 Werkstück aufspannen

3 Vorbereitungen in der Betriebsart Positionieren mit Handeingabe

Drehachse(n) zum Setzen des Bezugspunkts auf entsprechenden Winkelwert positionieren. Der Winkelwert richtet sich nach der von Ihnen gewählten Bezugsfläche am Werkstück.

4 Vorbereitungen in der Betriebsart Manueller Betrieb

Funktion Bearbeitungsebene schwenken mit Softkey 3D-ROT auf AKTIV setzen für Betriebsart Manueller Betrieb; bei nicht geregelten Achsen Winkelwerte der Drehachsen ins Menü eintragen

Bei nicht geregelten Achsen müssen die eingetragenen Winkelwerte mit der Ist-Position der Drehachse(n) übereinstimmen, sonst berechnet die TNC den Bezugspunkt falsch.

5 Bezugspunkt-Setzen

  • Manuell durch Ankratzen wie im ungeschwenkten System
  • Gesteuert mit einem HEIDENHAIN 3D-Tastsystem (siehe Benutzer-Handbuch Tastsystemzyklen, Kapitel 2)
  • Automatisch mit einem HEIDENHAIN 3D-Tastsystem (siehe Benutzer-Handbuch Tastsystemzyklen, Kapitel 3)

6 Bearbeitungsprogramm in der Betriebsart Programmlauf Satzfolge starten

7 Betriebsart Manueller Betrieb

Funktion Bearbeitungsebene schwenken mit Softkey 3D-ROT auf INAKTIV setzen. Für alle Drehachsen Winkelwert 0° ins Menü eintragen.


Programmierbeispiele

Weitere Informationen:
> Beispiel: Koordinaten-Umrechnungszyklen


Beispiel: Koordinaten-Umrechnungszyklen

    Programm-Ablauf

  • Koordinaten-Umrechnungen im Hauptprogramm
  • Bearbeitung im Unterprogramm
0 begin pgm koumr mm |
1 blk form 0.1 z x+0 y+0 z-20 | Rohteil-Definition
2 blk form 0.2 x+130 y+130 z+0 |
3 tool def 1 l+0 r+1 | Werkzeug-Definition
4 tool call 1 z s4500 | Werkzeug-Aufruf
5 l z+250 r0 fmax | Werkzeug freifahren
6 cycl def 7.0 nullpunkt | Nullpunkt-Verschiebung ins Zentrum
7 cycl def 7.1 x+65 |
8 cycl def 7.2 y+65 |
9 call lbl 1 | Fräsbearbeitung aufrufen
10 lbl 10 | Marke für Programmteil-Wiederholung setzen
11 cycl def 10.0 drehung | Drehung um 45° inkremental
12 cycl def 10.1 irot+45 |
13 call lbl 1 | Fräsbearbeitung aufrufen
14 call lbl 10 rep 6/6 | Rücksprung zu LBL 10; insgesamt sechsmal
15 cycl def 10.0 drehung | Drehung rücksetzen
16 cycl def 10.1 rot+0 |
17 trans datum reset | Nullpunkt-Verschiebung rücksetzen
18 l z+250 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
19 lbl 1 | Unterprogramm 1
20 l x+0 y+0 r0 fmax | Festlegung der Fräsbearbeitung
21 l z+2 r0 fmax m3 |
22 l z-5 r0 f200 |
23 l x+30 rl |
24 l iy+10 |
25 rnd r5 |
26 l ix+20 |
27 l ix+10 iy-10 |
28 rnd r5 |
29 l ix-10 iy-10 |
30 l ix-20 |
31 l iy+10 |
32 l x+0 y+0 r0 f5000 |
33 l z+20 r0 fmax |
34 lbl 0 |
35 end pgm koumr mm |


Zyklen: Sonderfunktionen

Weitere Informationen:
> Grundlagen
> VERWEILZEIT (Zyklus 9, DIN/ISO: G04)
> PROGRAMM-AUFRUF (Zyklus 12, DIN/ISO: G39)
> SPINDEL-ORIENTIERUNG (Zyklus 13, DIN/ISO: G36)
> TOLERANZ (Zyklus 32, DIN/ISO: G62)
> GRAVIEREN (Zyklus 225, DIN/ISO: G225)
> INTERPOLATIONSDREHEN (Software-Option, Zyklus 290, DIN/ISO: G290)


Übersicht

Die TNC stellt verschiedene Zyklen für folgende Sonderanwendungen zur Verfügung:

Zyklus | Softkey | Seite
9 VERWEILZEIT |  | VERWEILZEIT (Zyklus 9, DIN/ISO: G04)
12 PROGRAMM-AUFRUF |  | PROGRAMM-AUFRUF (Zyklus 12, DIN/ISO: G39)
13 SPINDEL-ORIENTIERUNG |  | SPINDEL-ORIENTIERUNG (Zyklus 13, DIN/ISO: G36)
32 TOLERANZ |  | TOLERANZ (Zyklus 32, DIN/ISO: G62)
225 GRAVIEREN von Texten |  | KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276)
290 INTERPOLATIONSDREHEN (Software-Option) |  | INTERPOLATIONSDREHEN (Software-Option, Zyklus 290, DIN/ISO: G290)


VERWEILZEIT (Zyklus 9, DIN/ISO: G04)

Weitere Informationen:
> Funktion
> Zyklusparameter


Funktion

Beispiel: NC-Sätze
89 cycl def 9.0 verweilzeit
90 cycl def 9.1 v.zeit 1.5

Der Programmlauf wird für die Dauer der VERWEILZEIT angehalten. Eine Verweilzeit kann beispielsweise zum Spanbrechen dienen.

Der Zyklus wirkt ab seiner Definition im Programm. Modal wirkende (bleibende) Zustände werden dadurch nicht beeinflusst, wie z.B. die Drehung der Spindel.


Zyklusparameter

Verweilzeit in Sekunden: Verweilzeit in Sekunden eingeben. Eingabebereich 0 bis 3 600 s (1 Stunde) in 0,001 s-Schritten


PROGRAMM-AUFRUF (Zyklus 12, DIN/ISO: G39)

Weitere Informationen:
> Zyklusfunktion
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusfunktion

Sie können beliebige Bearbeitungs-Programme, wie z.B. spezielle Bohrzyklen oder Geometrie-Module, einem Bearbeitungs-Zyklus gleichstellen. Sie rufen dieses Programm dann wie einen Zyklus auf.


Beim Programmieren beachten!

Das aufgerufene Programm muss auf der Festplatte der TNC gespeichert sein.

Wenn Sie nur den Programm-Namen eingeben, muss das zum Zyklus deklarierte Programm im selben Verzeichnis stehen wie das rufende Programm.

Wenn das zum Zyklus deklarierte Programm nicht im selben Verzeichnis steht wie das rufende Programm, dann geben Sie den vollständigen Pfadnamen ein, z.B. TNC:\KLAR35\FK1\50.H.

Wenn Sie ein DIN/ISO-Programm zum Zyklus deklarieren wollen, dann geben Sie den Datei-Typ .I hinter dem Programm-Namen ein.

Q-Parameter wirken bei einem Programm-Aufruf mit Zyklus 12 grundsätzlich global. Beachten Sie daher, dass Änderungen an Q-Parametern im aufgerufenen Programm sich ggf. auch auf das aufrufende Programm auswirken.


Zyklusparameter

Beispiel: Programm 50 als Zyklus deklarieren und mit M99 aufrufen
55 cycl def 12.0 pgm call
56 cycl def 12.1 pgm TNC:\KLAR35\FK1\50.H
57 l x+20 y+50 fmax m99

Programm-Name: Name des aufzurufenden Programms ggf. mit Pfad, in dem das Programm steht. Maximal 254 Zeichen eingebbar

    Definiertes Programm ist mit folgenden Funktionen aufrufbar:

  • CYCL CALL (separater Satz) oder
  • CYCL CALL POS (separater Satz) oder
  • M99 (satzweise) oder
  • M89 (wird nach jedem Positionier-Satz ausgeführt)


SPINDEL-ORIENTIERUNG (Zyklus 13, DIN/ISO: G36)

Weitere Informationen:
> Zyklusfunktion
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusfunktion

Beispiel: NC-Sätze
93 cycl def 13.0 orientierung
94 cycl def 13.1 winkel 180

Maschine und TNC müssen vom Maschinenhersteller vorbereitet sein.

Die TNC kann die Hauptspindel einer Werkzeugmaschine ansteuern und in eine durch einen Winkel bestimmte Position drehen.

    Die Spindel-Orientierung wird z.B. benötigt

  • bei Werkzeugwechsel-Systemen mit bestimmter Wechsel-Position für das Werkzeug
  • zum Ausrichten des Sende- und Empfangsfensters von 3D-Tastsystemen mit Infrarot-Übertragung

Die im Zyklus definierte Winkelstellung positioniert die TNC durch Programmieren von M19 oder M20 (maschinenabhängig).

Wenn Sie M19, bzw. M20 programmieren, ohne zuvor den Zyklus 13 definiert zu haben, dann positioniert die TNC die Hauptspindel auf einen Winkelwert, der vom Maschinenhersteller festgelegt ist (siehe Maschinenhandbuch).


Beim Programmieren beachten!

In den Bearbeitungszyklen 202, 204 und 209 wird intern Zyklus 13 verwendet. Beachten Sie in Ihrem NC-Programm, daß Sie ggf. Zyklus 13 nach einem der oben genannten Bearbeitungszyklen erneut programmieren müssen.


Zyklusparameter

Orientierungswinkel: Winkel bezogen auf die Winkel-Bezugsachse der Arbeitsebene eingeben. Eingabe-Bereich: 0,0000° bis 360,0000°


TOLERANZ (Zyklus 32, DIN/ISO: G62)

Weitere Informationen:
> Zyklusfunktion
> Einflüsse bei der Geometriedefinition im CAM-System
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusfunktion

Maschine und TNC müssen vom Maschinenhersteller vorbereitet sein. Der Zyklus kann gesperrt sein.

Durch die Angaben im Zyklus 32 können Sie das Ergebnis bei der HSC-Bearbeitung hinsichtlich Genauigkeit, Oberflächengüte und Geschwindigkeit beeinflussen, sofern die TNC an die maschinenspezifischen Eigenschaften angepasst wurde.

Die TNC glättet automatisch die Kontur zwischen beliebigen (unkorrigierten oder korrigierten) Konturelementen. Dadurch verfährt das Werkzeug kontinuierlich auf der Werkstück-Oberfläche und schont dabei die Maschinenmechanik. Zusäztlich wirkt die im Zyklus definierte Toleranz auch bei Verfahrbewegungen auf Kreisbögen.

Falls erforderlich, reduziert die TNC den programmierten Vorschub automatisch, so dass das Programm immer „ruckelfrei“ mit der schnellstmöglichen Geschwindigkeit von der TNC abgearbeitet wird. Auch wenn die TNC mit nicht reduzierter Geschwindigkeit verfährt, wird die von Ihnen definierte Toleranz grundsätzlich immer eingehalten. Je größer Sie die Toleranz definieren, desto schneller kann die TNC verfahren.

Durch das Glätten der Kontur entsteht eine Abweichung. Die Größe dieser Konturabweichung (Toleranzwert) ist in einem Maschinen-Parameter von Ihrem Maschinenhersteller festgelegt. Mit dem Zyklus 32 können Sie den voreingestellten Toleranzwert verändern.


Einflüsse bei der Geometriedefinition im CAM-System

Der wesentlichste Einflussfaktor bei der externen NC-Programmerstellung ist der im CAM-System definierbare Sehnenfehler S. Über den Sehnenfehler definiert sich der maximale Punktabstand des über einen Postprozessor (PP) erzeugten NC-Programmes. Ist der Sehnenfehler gleich oder kleiner als der im Zyklus 32 gewählte Toleranzwert T, dann kann die TNC die Konturpunkte glätten, sofern durch spezielle Maschineneinstellungen der programmierte Vorschub nicht begrenzt wird.

Eine optimale Glättung der Kontur erhalten Sie, wenn Sie den Toleranzwert im Zyklus 32 zwischen dem 1,1 und 2-fachen des CAM-Sehnenfehlers wählen.


Beim Programmieren beachten!

Bei sehr kleinen Toleranzwerten kann die Maschine die Kontur nicht mehr ruckelfrei bearbeiten. Das Ruckeln liegt nicht an fehlender Rechenleistung der TNC, sondern an der Tatsache, dass die TNC die Konturübergänge nahezu exakt anfahren, die Verfahrgeschwindigkeit also ggf. drastisch reduzieren muss.

Zyklus 32 ist DEF-Aktiv, das heißt ab seiner Definition im Programm wirksam.

Die TNC setzt den Zyklus 32 zurück, wenn Sie

  • den Zyklus 32 erneut definieren und die Dialogfrage nach dem Toleranzwert mit NO ENT bestätigen
  • über die Taste PGM MGT ein neues Programm anwählen

Nachdem Sie den Zyklus 32 zurückgesetzt haben, aktiviert die TNC wieder die über Maschinen-Parameter voreingestellte Toleranz.

Der eingegebene Toleranzwert T wird von der TNC in MM-programm in der Maßeinheit mm und in einem Inch-Programm in der Maßeinheit Inch interpretiert.

Wenn Sie ein Programm mit Zyklus 32 einlesen, dass als Zyklusparameter nur den Toleranzwert T beinhaltet, fügt die TNC ggf. die beiden restlichen Parameter mit dem Wert 0 ein.

Bei zunehmender Toleranzeingabe verkleinert sich bei Kreisbewegungen im Regelfall der Kreisdurchmesser. Wenn an Ihrer Maschine der HSC-Filter aktiv ist (ggf. beim Maschinenhersteller nachfragen), kann der Kreis auch größer werden.

Wenn Zyklus 32 aktiv ist, zeigt die TNC in der zusätzlichen Status-Anzeige, Reiter CYC die definierten Zyklus 32-Parameter an.


Zyklusparameter

Beispiel: NC-Sätze
95 cycl def 32.0 toleranz
96 cycl def 32.1 t0.05
97 cycl def 32.2 hsc-mode:1 ta5

Toleranzwert T: Zulässige Konturabweichung in mm (bzw. inch bei Inch-Programmen). Eingabebereich 0 bis 99999,9999

HSC-MODE, Schlichten=0, Schruppen=1: Filter aktivieren:

  • Eingabewert 0:
    Mit höherer Konturgenauigkeit fräsen. Die TNC verwendet intern definierte Schlicht-Filtereinstellungen
  • Eingabewert 1:
    Mit höherer Vorschub-Geschwindigkeit fräsen. Die TNC verwendet intern definierte Schrupp-Filtereinstellungen

Toleranz für Drehachsen TA: Zulässige Positionsabweichung von Drehachsen in Grad bei aktivem M128 (Function TCPM). Die TNC reduziert den Bahnvorschub immer so, dass bei mehrachsigen Bewegungen die langsamste Achse mit ihrem maximalen Vorschub verfährt. In der Regel sind Drehachsen wesentlich langsamer als Linearachsen. Durch Eingabe einer großen Toleranz (z.B. 10°), können Sie die Bearbeitungszeit bei mehrachsigen Bearbeitungs-Programmen erheblich verkürzen, da die TNC die Drehachse dann nicht immer auf die vorgegebene Soll-Position fahren muss. Die Kontur wird durch Eingabe der Drehachsen-Toleranz nicht verletzt. Es verändert sich lediglich die Stellung der Drehachse bezogen auf die Werkstück-Oberfläche. Eingabebereich 0 bis 179,9999


GRAVIEREN (Zyklus 225, DIN/ISO: G225)

Weitere Informationen:
> Zyklusablauf
> Beim Programmmiern beachten!
> Zyklusparameter
> Erlaubte Gravierzeichen
> Nicht druckbare Zeichen
> Systemvariablen gravieren


Zyklusablauf

Mit diesem Zyklus lassen sich Texte auf eine ebene Fläche des Werkstücks gravieren. Die Texte lassen sich entlang einer Geraden oder auf einem Kreisbogen anordnen.

  1. Die TNC positioniert in der Bearbeitungsebene zum Startpunkt des ersten Zeichens.
  2. Das Werkzeug taucht senkrecht auf den Graviergrund und fräst das Zeichen. Erforderliche Abhebebewegungen zwischen den Zeichen führt die TNC auf Sicherheits-Abstand aus. Am Ende des Zeichens steht das Werkzeug auf Sicherheits-Abstand über der Oberfläche.
  3. Dieser Vorgang wiederholt sich für alle zu gravierenden Zeichen.
  4. Abschließend positioniert die TNC das Werkzeug auf den 2. Sicherheits-Abstand.


Beim Programmmiern beachten!

Das Vorzeichen des Zyklusparameters Tiefe legt die Arbeitsrichtung fest.

Wenn Sie den Text auf einer Gerade gravieren (Q516=0), dann bestimmt die Werkzeugposition beim Zyklusaufruf den Startpunkt des ersten Zeichens.

Wenn Sie den Text auf einem Kreis gravieren (Q516=1), dann bestimmt die Werkzeugposition beim Zyklusaufruf den Mittelpunkt des Kreises.

Den Graviertext können Sie auch per String-Variable (QS) übergeben.


Zyklusparameter

Beispiel: NC-Sätze
62 cycl def 225 gravieren
Qs500=“TXT2“ ;graviertext
Q513=10 ;zeichenhoehe
Q514=0 ;faktor abstand
Q515=0 ;schriftart
Q516=0 ;textanordnung
Q374=0 ;drehlage
Q517=0 ;kreisradius
Q207=750 ;vorschub fraesen
Q201=-0.5 ;tiefe
Q206=150 ;vorschub tiefenz.
Q200=2 ;sicherheits-abst.
Q203=+20 ;koor. oberflaeche
Q204=50 ;2. sicherheits-abst.

Graviertext QS500: Graviertext innerhalb Hochkommata. Zuweisung einer String-Variable über Taste Q des Nummernblocks, Taste Q auf der ASCI-Tastatur entspricht normaler Texteingabe. Erlaubte Eingabezeichen: Siehe Systemvariablen gravieren

Zeichenhöhe Q513 (absolut): Höhe der zu gravierenden Zeichen in mm. Eingabebereich 0 bis 99999,9999

Faktor Abstand Q514: Beim verwendeten Font handelt es sich um einen sogenannten Proportionalfont. Jedes Zeichen hat demnach seine eigene Breite, die die TNC bei Definition von Q514=0 entsprechend graviert. Bei Definition von Q514 ungleich 0 skaliert die TNC den Abstand zwischen den Zeichen. Eingabebereich 0 bis 9,9999

Schriftart Q515: Momentan ohne Funktion

Text auf Gerade/Kreis (0/1) Q516: Text entlang einer Geraden gravieren: Eingabe = 0 Text auf einem Kreisbogen gravieren: Eingabe = 1

Drehlage Q374: Mittelpunktswinkel, wenn Text auf Kreis angeordnet werden soll. Gravierwinkel bei gerader Textanordnung. Eingabebereich -360,0000 bis +360,0000°

Radius bei Text auf Kreis Q517 (absolut): Radius des Kreisbogens, auf dem die TNC den Text anordnen soll in mm. Eingabebereich 0 bis 99999,9999

Vorschub Fräsen Q207: Verfahrgeschwindigkeit des Werkzeugs beim Gravieren in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, Fu oder FZ

Tiefe Q201 (inkremental): Abstand zwischen Werkstück-Oberfläche und Graviergrund

Vorschub Tiefenzustellung Q206: Verfahrgeschwindigkeit des Werkzeugs beim Eintauchen in mm/min. Eingabebereich 0 bis 99999,999 alternativ FAUTO, fu

Sicherheits-Abstand Q200 (inkremental): Abstand Werkzeugspitze – Werkstück-Oberfläche. Eingabebereich 0 bis 99999,9999 alternativ predef

Koord. Werkstück-Oberfläche Q203 (absolut): Koordinate Werkstück-Oberfläche. Eingabebereich ‑99999,9999 bis 99999,9999

2. Sicherheits-Abstand Q204 (inkremental): Koordinate Spindelachse, in der keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann. Eingabebereich 0 bis 99999,9999 alternativ predef


Erlaubte Gravierzeichen

Neben Kleinbuchstaben, Großbuchstaben und Zahlen sind folgende Sonderzeichen möglich:

 ! # $ % & ‘ ( ) * + , - . / : ; < = > ? @ [ \ ] _

Die Sonderzeichen % und \ nutzt die TNC für spezielle Funktionen. Wenn Sie diese Zeichen gravieren wollen, dann müssen Sie diese im Graviertext doppelt angeben, z.B.: %%.

Sie können mit dem Zyklus auch Umlaute und Durchmesserzeichen gravieren:

Zeichen | Eingabe
ä | %ae
ö | %oe
ü | %ue
Ä | %AE
Ö | %OE
Ü | %UE
ø | %D


Nicht druckbare Zeichen

Neben Text, ist es auch möglich, einige nicht druckbare Zeichen für Formatierungszwecke zu definieren. Die Angabe von nicht druckbaren Zeichen leiten Sie mit dem Sonderzeichen \ ein.

    Folgende Möglichkeiten existieren:

  • \n: Zeilenumbruch
  • \t: Horizontaler Tabulator (Tabulatorweite ist fest auf 8 Zeichen)
  • \v: Vertikaler Tabulator (Tabulatorweite ist fest auf eine Zeile)


Systemvariablen gravieren

Zusätzlich zu festen Zeichen, ist es möglich, den Inhalt von bestimmten Systemvariablen zu gravieren. Die Angabe einer Systemvariablen leiten sie mit dem Sonderzeichen % ein.

Es ist möglich, das aktuelle Datum zu gravieren. Geben Sie dazu %time<x> ein. <x> definiert das Datumsformat, deren Bedeutung identisch zur Funktion SYSSTR ID332 ist (siehe Benutzer-Handbuch Klartext-Dialog, Kapitel Q-Parameter-Programmierung, Abschnitt Systemdaten in einen String-Parameter kopieren).

Beachten Sie, dass Sie bei der Eingabe der Datumsformate 1 bis 9 eine führende 0 angeben müssen, z.B. time08.


INTERPOLATIONSDREHEN (Software-Option, Zyklus 290, DIN/ISO: G290)

Weitere Informationen:
> Zyklusablauf
> Beim Programmmiern beachten!
> Zyklusparameter


Zyklusablauf

Mit diesem Zyklus lässt sich ein rotationssymmetrischer Absatz oder ein Einstich in der Bearbeitungsebene, die durch Start- und Endpunkt definiert sind, erstellen (siehe auch Bearbeitungsvarianten). Die Rotationsmitte ist der Startpunkt (XY) beim Zyklusaufruf. Die Rotationsflächen können geneigt und gegeneinander abgerundet werden. Die Flächen können sowohl per Interpolationsdrehen, als auch per Fräsen erstellt werden.

Das Werkstück dreht sich beim Interpolationsdrehen nicht. Das Werkzeug führt eine Kreisbbewegung in den Hauptachsen X und Y aus. Gleichzeitig führt die TNC die Spindel S so nach, dass die Schneide des Drehmeissels immer zum Drehzentrum des Werkstücks ausgerichtet ist. Dadurch können Sie den Zyklus 290 auch auf einer Dreiachsmaschine verwenden.

Der Mittelpunkt der Bearbeitung muss nicht im Zentrum eines Runddtisches liegen. Den Mittelpunkt legen Sie durch die Position des Werkzeugs beim Zyklus-Aufruf fest.

  1. Die TNC positioniert das Werkzeug auf der Sicheren Höhe zum Startpunkt der Bearbeitung. Dieser ergibt sich durch eine tangentiale Verlängerung des Kontur-Startpunkts um den Sicherheitsabstand.
  2. Die TNC erstellt die definierte Kontur durch Interpolationsdrehen. Dabei beschreiben die Hauptachsen der Bearbeitungsebene eine kreisförmige Bewegung, während die Spindelachse senkrecht zur Oberfläche nachgeführt wird.
  3. Am Konturendpunkt fährt die TNC das Werkzeug senkrecht um den Sicherheitsabstand ab.
  4. Abschließend positioniert die TNC das Werkzeug auf die sichere Höhe


Beim Programmmiern beachten!

    Das Werkzeug, das sie für diesen Zyklus verwenden, kann sowohl ein Drehwerkzeug, als auch ein Fräswerkzeug (Q444=0) sein. Die Geometriedaten dieses Werkzeugs definieren Sie in der Werkzeug-Tabelle TOOL.T wie folgt:

  • Spalte L (DL für Korrekturwerte):
    Länge des Werkzeugs (unterster Punkt an der Werkzeug-Schneide)
  • Spalte R (DR für Korrekturwerte):
    Fliehkreisradius des Werkzeugs (äußerster Punkt der Werkzeug-Schneide)
  • Spalte R2 (DR2 für Korrekturwerte):
    Schneidenradius des Werkzeugs

Maschine und TNC müssen vom Maschinenhersteller vorbereitet sein. Beachten Sie das Maschinenhandbuch.

Zyklus nur an Maschinen mit geregelter Spindel verwendbar (Ausnahme Q444=0)

Die Software-Option 96 muss freigeschaltet sein.

Der Zyklus ermöglicht keine Schruppbearbeitungen mit mehreren Schnitten.

Das Interpolationszentrum ist die Werkzeug-Position beim Zyklus-Aufruf.

Die TNC verlängert die erste zu bearbeitende Fläche um den Sicherheits-Abstand.

Über die Werte DL und DR des TOOL CALL-Satzes können Sie Aufmaße realisieren. DR2-Eingaben im TOOL CALL-Satz berücksichtigt die TNC nicht.

Damit Ihre Maschine hohe Bahngeschwindigkeiten erreichen kann, definieren Sie vor Zyklusaufruf eine große Toleranz mit Zyklus 32.

Programmieren Sie eine Schnittgeschwindigkeit, die durch die Bahngeschwindigkeit der Achsen Ihrer Maschine auch gerade erreicht werden kann. So erhalten Sie eine optimale Auflösung der Geometrie und eine stetige Bearbeitungsgeschwindigkeit.

Die TNC überwacht mögliche Konturverletzungen, die durch entsprechende Werkzeuggeometrie entstehen kann, nicht.

Bearbeitungsvarianten beachten: Siehe Bearbeitungsvarianten


Zyklusparameter

Sicherheits-Abstand Q200 (inkremental): Verlängerungsdistanz der definierten Kontur beim An- und Abfahren. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q445 (absolut): Absolute Höhe, in der keine Kollision zwischen Werkzeug und Werkstück erfolgen kann; Werkzeug-Rückzugposition am Zyklus-Ende. Eingabebereich -99999,9999 bis 99999,9999

Winkel für Spindel-Orientierung Q336 (absolut): Winkel, um die Schneide auf die 0°-Position der Spindel auszurichten. Eingabebereich -360,0000 bis 360,0000

Schnittgeschwindigkeit [m/min] Q440: Schnittgeschwindigkeit des Werkzeugs in m/min. Eingabebereich 0 bis 99,999

Zustellung pro Umdrehung [mm/U] Q441: Vorschub, den das Werkzeug pro Umdrehung ausführt. Eingabebereich 0 bis 99,999

Startwinkel Ebene XY Q442: Startwinkel in der XY-Ebene. Eingabebereich 0 bis 359,999

Bearbeitungs-Richtung (-1/+1) Q443: Bearbeitung im Uhrzeigersinn: Eingabe = -1 Bearbeitung im Gegenuhrzeigersinn: Eingabe = +1

Interpolierende Achse (4...9) Q444: Achsbezeichnung der interpolierenden Achse. A-Achse ist interpolierende Achse: Eingabe = 4 B-Achse ist interpolierende Achse: Eingabe = 5 C-Achse ist interpolierende Achse: Eingabe = 6 U-Achse ist interpolierende Achse: Eingabe = 7 V-Achse ist interpolierende Achse: Eingabe = 8 W-Achse ist interpolierende Achse: Eingabe = 9 Kontur fräsen: Eingabe = 0

Beispiel: NC-Sätze
62 cycl def 290 interpolationsdrehen
Q200=2 ;sicherheits-abst.
Q445=+50 ;sichere hoehe
Q336=0 ;winkel spindel
Q440=20 ;schnittgeschw.
Q441=0.75 ;zustellung
Q442=+0 ;startwinkel
Q443=-1 ;bearbeitungsr.
Q444=+6 ;interp. achse
Q491=+25 ;konturstart durchm
Q492=+0 ;konturstart Z
Q493=+50 ;konturende x
Q494=-45 ;konturende z
Q495=+0 ;winkel umfangflaeche
Q496=+0 ;winkel planflaeche
Q500=4.5 ;radius konturecke

Konturstart Durchmesser Q491 (absolut): Ecke des Startpunkts in X, Durchmesser eingeben. Eingabebereich -99999,9999 bis 99999,9999

Konturstart Z Q492 (absolut): Ecke des Startpunkts in Z. Eingabebereich -99999,9999 bis 99999,9999

Konturende Durchmesser Q493 (absolut): Ecke des Endpunkts in X, Durchmesser eingeben. Eingabebereich -99999,9999 bis 99999,9999

Konturende Z Q494 (absolut): Ecke des Endpunkts in Z. Eingabebereich -99999,9999 bis 99999,9999

Winkel Umfangsfläche Q495: Winkel der ersten zu bearbeitenden Fläche in Grad. Eingabebereich ‑179,999 bis 179,999

Winkel der Planfläche Q496: Winkel der zweiten zu bearbeitenden Fläche in Grad. Eingabebereich ‑179,999 bis 179,999

Radius der Konturecke Q500: Eckenverrundung zwischen den zu bearbeitenden Flächen. Eingabebereich 0 bis 999,999

Weitere Informationen:
> Kontur fräsen
> Bearbeitungsvarianten


Kontur fräsen

Durch Eingabe von Q444=0 können Sie die Flächen fräsen. Für diese Bearbeitung verwenden Sie einen Fräser mit einem Schneidenradius (R2). Ist auf den Flächen ein großes Aufmass, so können Sie diese durch Fräsen in der Regel besser vorbearbeiten, als durch Interpolationsdrehen.

Der Zyklus ermöglicht beim Fräsen auch Bearbeitungen mit mehreren Schnitten.

Beachten Sie, dass beim Fräsen die Vorschubgeschwindigkeit der Angabe im Q440 (Schnittgeschwindigkeit) entspricht. Die Einheit der Schnittgeschwindigkeit ist Meter pro Minute.


Bearbeitungsvarianten

Durch Kombination der Start- und Endpunkte mit den Winkeln Q495 und Q496 ergeben sich folgende Bearbeitungsmöglichkeiten:

  • Außenbearbeitung in Quadrant 1 (1):
    • Winkel Umfangsfläche Q495 positiv eingeben
    • Winkel Planfläche Q496 negativ eingeben
    • Konturstart X Q491 kleiner Konturende X Q493 eingeben
    • Konturstart Z Q492 größer Konturende Z Q494 eingeben
  • Innenbearbeitung in Quadrant 2 (2):
    • Winkel Umfangsfläche Q495 negativ eingeben
    • Winkel Planfläche Q496 positiv eingeben
    • Konturstart X Q491 größer Konturende X Q493 eingeben
    • Konturstart Z Q492 größer Konturende Z Q494 eingeben
  • Außenbearbeitung in Quadrant 3 (3):
    • Winkel Umfangsfläche Q495 positiv eingeben
    • Winkel Planfläche Q496 negativ eingeben
    • Konturstart X Q491 größer Konturende X Q493 eingeben
    • Konturstart Z Q492 kleiner Konturende Z Q494 eingeben
  • Innenbearbeitung in Quadrant 4 (4):
    • Winkel Umfangsfläche Q495 negativ eingeben
    • Winkel Planfläche Q496 positiv eingeben
    • Konturstart X Q491 kleiner Konturende X Q493 eingeben
    • Konturstart Z Q492 kleiner Konturende Z Q494 eingeben
  • Einstich Axial:
    • Konturstart X Q491 gleich Konturende X Q493 eingeben
  • Einstich Radial:
    • Konturstart Z Q492 kleiner Konturende Z Q494 eingeben


Mit Tastsystemzyklen arbeiten

Weitere Informationen:
> Allgemeines zu den Tastsystemzyklen
> Bevor Sie mit Tastsystemzyklen arbeiten!


Allgemeines zu den Tastsystemzyklen

Die TNC muss vom Maschinenhersteller für den Einsatz von 3D-Tastsystemen vorbereitet sein. Maschinenhandbuch beachten.

Beachten Sie, dass HEIDENHAIN grundsätzlich nur dann die Gewährleistung für die Funktion der Tastsystem-Zyklen übernimmt, wenn Sie HEIDENHAIN Tastsysteme verwenden!

Wenn Sie Messungen während des Programmlaufs durchführen, dann achten Sie darauf, dass die Werkzeug-Daten (Länge, Radius) entweder aus den kalibrierten Daten oder aus dem letzten TOOL CALL-Satz verwendet werden können (Auswahl über MP7411).

Weitere Informationen:
> Funktionsweise
> Tastsystemzyklen in den Betriebsarten Manuell und El. Handrad
> Tastsystemzyklen für den Automatik-Betrieb


Funktionsweise

Wenn die TNC einen Tastsystem-Zyklus abarbeitet, fährt das 3D-Tastsystem achsparallel auf das Werkstück zu (auch bei aktiver Grunddrehung und bei geschwenkter Bearbeitungsebene). Der Maschinenhersteller legt den Antast-Vorschub in einem Maschinen-Parameter fest (siehe „Bevor Sie mit Tastsystemzyklen arbeiten“ weiter hinten in diesem Kapitel).

Wenn der Taststift das Werkstück berührt,

  • sendet das 3D-Tastsystem ein Signal an die TNC: Die Koordinaten der angetasteten Position werden gespeichert
  • stoppt das 3D-Tastsystem und
  • fährt im Eilvorschub auf die Startposition des Antastvorgangs zurück

Wird innerhalb eines festgelegten Wegs der Taststift nicht ausgelenkt, gibt die TNC eine entsprechende Fehlermeldung aus (Weg: MP6130).


Tastsystemzyklen in den Betriebsarten Manuell und El. Handrad

Die TNC stellt in den Betriebsarten Manuell und El. Handrad Tastsystemzyklen zur Verfügung, mit denen Sie:

  • das Tastsystem kalibrieren
  • Werkstück-Schieflagen kompensieren
  • Bezugspunkte setzen


Tastsystemzyklen für den Automatik-Betrieb

Neben den Tastsystemzyklen, die Sie in der Betriebsarten Manuell und El. Handrad verwenden, stellt die TNC eine Vielzahl von Zyklen für die unterschiedlichsten Einsatzmöglichkeiten im Automatik-Betrieb zur Verfügung:

  • Schaltendes Tastsystem kalibrieren
  • Werkstück-Schieflagen kompensieren
  • Bezugspunkte setzen
  • Automatische Werkstück-Kontrolle
  • Automatische Werkzeug-Vermessung

Die Tastsystemzyklen programmieren Sie in der Betriebsart Programm-Einspeichern/Editieren über die Taste TOUCH PROBE. Tastsystemzyklen mit Nummern ab 400 verwenden, ebenso wie neuere Bearbeitungszyklen, Q-Parameter als Übergabeparameter. Parameter mit gleicher Funktion, die die TNC in verschiedenen Zyklen benötigt, haben immer dieselbe Nummer: z.B. Q260 ist immer die Sichere Höhe, Q261 immer die Messhöhe usw.

Um die Programmierung zu vereinfachen, zeigt die TNC während der Zyklus-Definition ein Hilfsbild an. Im Hilfsbild ist der Parameter hell hinterlegt, den Sie eingeben müssen (siehe Bild rechts).

Weitere Informationen:
> Tastsystem-Zyklus in Betriebsart Einspeichern/Editieren definieren


Tastsystem-Zyklus in Betriebsart Einspeichern/Editieren definieren
Beispiel: NC-Sätze
5 tch probe 410 bzpkt rechteck innen
Q321=+50 ;mitte 1. achse
Q322=+50 ;mitte 2. achse
Q323=60 ;1. seiten-laenge
Q324=20 ;2. seiten-laenge
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q305=10 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. KO. fuer ts-achse
Q383=+50 ;2. KO. fuer ts-achse
Q384=+0 ;3. KO. fuer ts-achse
Q333=+0 ;BEZUGSPUNKT

Die Softkey-Leiste zeigt – in Gruppen gegliedert – alle verfügbaren Tastsystem-Funktionen an

Antastzyklus-Gruppe wählen, z.B. Bezugspunkt-Setzen. Zyklen zur automatischen Werkzeug-Vermessung stehen nur zur Verfügung, wenn Ihre Maschine dafür vorbereitet ist

Zyklus wählen, z.B. Bezugspunkt-Setzen Taschenmitte. Die TNC eröffnet einen Dialog und erfragt alle Eingabewerte; gleichzeitig blendet die TNC in der rechten Bildschirmhälfte eine Grafik ein, in der der einzugebende Parameter hell hinterlegt ist

Geben Sie alle von der TNC geforderten Parameter ein und schließen Sie jede Eingabe mit der Taste ENT ab

Die TNC beendet den Dialog, nachdem Sie alle erforderlichen Daten eingegeben haben

Messzyklus-Gruppe | Softkey | Seite
Zyklen zum automatischen Erfassen und Kompensieren einer Werkstück-Schieflage |  | Übersicht
Zyklen zum automatischen Bezugspunkt-Setzen |  | Übersicht
Zyklen zur automatischen Werkstück-Kontrolle |  | Übersicht
Kalibrierzyklen, Sonderzyklen |  | Übersicht
Zyklen zur automatischen Kinematikvermessung |  | Grundlagen
Zyklen zur automatischen Werkzeug-Vermessung (wird vom Maschinenhersteller freigegeben) |  | Übersicht


Bevor Sie mit Tastsystemzyklen arbeiten!

Um einen möglichst großen Anwendungsbereich an Messaufgaben abdecken zu können, stehen Ihnen über Maschinen-Parameter Einstellmöglichkeiten zur Verfügung, die das grundsätzliche Verhalten aller Tastsystemzyklen festlegen:

Weitere Informationen:
> Maximaler Verfahrweg zum Antastpunkt: MP6130
> Sicherheits-Abstand zum Antastpunkt: MP6140
> Infrarot-Tastsystem auf programmierte Antastrichtung orientieren: MP6165
> Grunddrehung im Manuellen Betrieb berücksichtigen: MP6166
> Mehrfachmessung: MP6170
> Vertrauensbereich für Mehrfachmessung: MP6171
> Schaltendes Tastsystem, Antastvorschub: MP6120
> Schaltendes Tastsystem, Vorschub für Positionierbewegungen: MP6150
> Schaltendes Tastsystem, Eilgang für Positionierbewegungen: MP6151
> KinematicsOpt, Toleranzgrenze für Modus Optimieren: MP6600
> KinematicsOpt, erlaubte Abweichung Kalibrierkugelradius: MP6601
> Tastsystemzyklen abarbeiten


Maximaler Verfahrweg zum Antastpunkt: MP6130

Wenn der Taststift innerhalb des in MP6130 festgelegten Wegs nicht ausgelenkt wird, gibt die TNC eine Fehlermeldung aus.


Sicherheits-Abstand zum Antastpunkt: MP6140

In MP6140 legen Sie fest, wie weit die TNC das Tastsystem vom definierten – bzw. vom Zyklus berechneten – Antastpunkt entfernt vorpositionieren soll. Je kleiner Sie diesen Wert eingeben, desto genauer müssen Sie die Antastpositionen definieren. In vielen Tastsystemzyklen können Sie zusätzlich einen Sicherheits-Abstand definieren, der additiv zum Maschinen-Parameter 6140 wirkt.


Infrarot-Tastsystem auf programmierte Antastrichtung orientieren: MP6165

Um die Messgenauigkeit zu erhöhen, können Sie über MP 6165 = 1 erreichen, dass ein Infrarot-Tastsystem vor jeden Antastvorgang in Richtung der programmierten Antastrichtung orientiert. Der Taststift wird dadurch immer in die gleiche Richtung ausgelenkt.

Wenn Sie MP6165 verändern, dann müssen Sie das Tastsystem neu kalibrieren, da sich das Auslenkverhalten verändert.


Grunddrehung im Manuellen Betrieb berücksichtigen: MP6166

Um auch im Einrichtebetrieb die Messgenauigkeit beim Antasten einzelner Positionen zu erhöhen, können Sie über MP 6166 = 1 erreichen, dass die TNC beim Antastvorgang eine aktive Grunddrehung berücksichtigt, also ggf. schräg auf das Werkstück zufährt.

Die Funktion schräges Antasten ist für folgende Funktionen im manuellen Betrieb nicht aktiv:

  • Kalibrieren Länge
  • Kalibrieren Radius
  • Grunddrehung ermitteln


Mehrfachmessung: MP6170

Um die Messsicherheit zu erhöhen, kann die TNC jeden Antastvorgang bis zu dreimal hintereinander ausführen. Weichen die gemessenen Positionswerte zu sehr voneinander ab, gibt die TNC eine Fehlermeldung aus (Grenzwert in MP6171 festgelegt). Über die Mehrfachmessung können Sie ggf. zufällige Messfehler ermitteln, die z.B. durch Verschmutzung entstehen.

Liegen die Messwerte innerhalb des Vertrauensbereichs, speichert die TNC den Mittelwert aus den erfassten Positionen.


Vertrauensbereich für Mehrfachmessung: MP6171

Wenn Sie eine Mehrfachmessung durchführen, legen Sie in MP6171 den Wert ab, den die Messwerte voneinander abweichen dürfen. Überschreitet die Differenz der Messwerte den Wert in MP6171, gibt die TNC eine Fehlermeldung aus.


Schaltendes Tastsystem, Antastvorschub: MP6120

In MP6120 legen Sie den Vorschub fest, mit dem die TNC das Werkstück antasten soll.


Schaltendes Tastsystem, Vorschub für Positionierbewegungen: MP6150

In MP6150 legen Sie den Vorschub fest, mit dem die TNC das Tastsystem vorpositioniert, bzw. zwischen Messpunkten positioniert.


Schaltendes Tastsystem, Eilgang für Positionierbewegungen: MP6151

In MP6151 legen Sie fest, ob die TNC das Tastsystem mit dem in MP6150 definierten Vorschub positionieren soll, oder im Maschinen-Eilgang.

  • Eingabewert = 0: Mit Vorschub aus MP6150 positionieren
  • Eingabewert = 1: Mit Eilgang vorpositionieren


KinematicsOpt, Toleranzgrenze für Modus Optimieren: MP6600

In MP6600 legen Sie die Toleranzgrenze fest, ab der die TNC im Modus Optimieren einen Hinweis anzeigen soll, wenn die ermittelten Kinematikdaten über diesem Grenzwert liegen. Voreinstellung: 0.05. Je größer die Maschine, desto größere Werte wählen

  • Eingabebereich: 0.001 bis 0.999


KinematicsOpt, erlaubte Abweichung Kalibrierkugelradius: MP6601

In MP6601 legen Sie die maximal erlaubte Abweichung des von den Zyklen automatisch gemessenen Kalibrierkugelradius vom eingegebenen Zyklusparameter fest.

  • Eingabebereich: 0.01 bis 0.1

Die TNC berechnet den Kalibirierkugelradius bei jedem Messpunkt zweimal über alle 5 Antastpunkte. Ist der Radius größer als Q407 + MP6601 so erfolgt eine Fehlermeldung, weil dann von einer Verschmutzung ausgegangen wird.

Ist der von der TNC ermittelte Radius kleiner als 5 * (Q407 - MP6601), dann gibt die TNC ebenfalls eine Fehlermeldung aus.


Tastsystemzyklen abarbeiten

Alle Tastsystemzyklen sind DEF-aktiv. Die TNC arbeitet also den Zyklus automatisch ab, wenn im Programmlauf die Zyklus-Definition von der TNC abgearbeitet wird.

Achten Sie darauf, dass am Zyklus-Anfang die Korrektur-Daten (Länge, Radius) entweder aus den kalibrierten Daten oder aus dem letzten TOOL-CALL-Satz aktiv werden (Auswahl über MP7411, siehe Benutzer-Handbuch der iTNC 530, „Allgemeine Anwender-Parameter“).

Die Tastsystemzyklen 408 bis 419 dürfen Sie auch bei aktiver Grunddrehung abarbeiten. Achten Sie jedoch darauf, dass sich der Winkel der Grunddrehung nicht mehr verändert, wenn Sie nach dem Messzyklus mit dem Zyklus 7 Nullpunkt-Verschiebung aus Nullpunkt-Tabelle arbeiten.

Tastsystemzyklen mit einer Nummer größer 400 positionieren das Tastsystem nach einer Positionierlogik vor:

  • Ist die aktuelle Koordinate des Taststift-Südpols kleiner als die Koordinate der Sicheren Höhe (im Zyklus definiert), dann zieht die TNC das Tastsystem zuerst in der Tastsystemachse auf Sichere Höhe zurück und positioniert anschließend in der Bearbeitungsebene zum ersten Antastpunkt
  • Ist die aktuelle Koordinate des Taststift-Südpols größer als die Koordinate der Sicheren Höhe, positioniert die TNC das Tastsystem zuerst in der Bearbeitungsebene auf den ersten Antastpunkt und anschließend in der Tastsystemachse direkt auf die Messhöhe


Tastsystemzyklen: Werkstückschieflagen automatisch ermitteln

Weitere Informationen:
> Grundlagen
> GRUNDDREHUNG (Zyklus 400, DIN/ISO: G400)
> GRUNDDREHUNG über zwei Bohrungen (Zyklus 401, DIN/ISO: G401)
> GRUNDDREHUNG über zwei Zapfen (Zyklus 402, DIN/ISO: G402)
> GRUNDDREHUNG über eine Drehachse kompensieren (Zyklus 403, DIN/ISO: G403)
> GRUNDDREHUNG SETZEN (Zyklus 404, DIN/ISO: G404)
> Schieflage eines Werkstücks über C-Achse ausrichten (Zyklus 405, DIN/ISO: G405)
> Beispiel: Grunddrehung über zwei Bohrungen bestimmen


Grundlagen

Weitere Informationen:
> Übersicht
> Gemeinsamkeiten der Tastsystemzyklen zum Erfassen der Werkstück-Schieflage


Übersicht

Die TNC stellt fünf Zyklen zur Verfügung, mit denen Sie eine Werkstückschieflage erfassen und kompensieren können. Zusätzlich können Sie mit dem Zyklus 404 eine Grunddrehung zurücksetzen:

Zyklus | Softkey | Seite
400 GRUNDDREHUNG Automatische Erfassung über zwei Punkte, Kompensation über Funktion Grunddrehung |  | GRUNDDREHUNG (Zyklus 400, DIN/ISO: G400)
401 ROT 2 BOHRUNGEN Automatische Erfassung über zwei Bohrungen, Kompensation über Funktion Grunddrehung |  | GRUNDDREHUNG über zwei Bohrungen (Zyklus 401, DIN/ISO: G401)
402 ROT 2 ZAPFEN Automatische Erfassung über zwei Zapfen, Kompensation über Funktion Grunddrehung |  | GRUNDDREHUNG über zwei Zapfen (Zyklus 402, DIN/ISO: G402)
403 ROT UEBER DREHACHSE Automatische Erfassung über zwei Punkte, Kompensation über Rundtischdrehung |  | GRUNDDREHUNG über eine Drehachse kompensieren (Zyklus 403, DIN/ISO: G403)
405 ROT UEBER C-ACHSE Automatisches Ausrichten eines Winkelversatzes zwischen einem Bohrungs-Mittelpunkte und der positiven Y-Achse, Kompensation über Rundtisch-Drehung |  | Schieflage eines Werkstücks über C-Achse ausrichten (Zyklus 405, DIN/ISO: G405)
404 GRUNDDREHUNG SETZEN Setzen einer beliebigen Grunddrehung |  | GRUNDDREHUNG SETZEN (Zyklus 404, DIN/ISO: G404)


Gemeinsamkeiten der Tastsystemzyklen zum Erfassen der Werkstück-Schieflage

Bei den Zyklen 400, 401 und 402 können Sie über den Parameter Q307 Voreinstellung Grunddrehung festlegen, ob das Ergebnis der Messung um einen bekannten Winkel α (siehe Bild rechts) korrigiert werden soll. Dadurch können Sie die Grunddrehung an einer beliebigen Gerade 1 des Werkstückes messen und den Bezug zur eigentlichen 0°-Richtung 2 herstellen.


GRUNDDREHUNG (Zyklus 400, DIN/ISO: G400)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 400 ermittelt durch Messung zweier Punkte, die auf einer Geraden liegen müssen, eine Werkstück-Schieflage. Über die Funktion Grunddrehung kompensiert die TNC den gemessenen Wert.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum programmierten Antastpunkt 1. Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand entgegen der festgelegten Verfahrrichtung
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Anschließend fährt das Tastsystem zum nächsten Antastpunkt 2 und führt den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zurück auf die Sichere Höhe und führt die ermittelte Grunddrehung durch


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Die TNC setzt eine aktive Grunddrehung am Zyklusanfang zurück.


Zyklusparameter

1. Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 1. Achse Q265 (absolut): Koordinate des zweiten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 2. Achse Q266 (absolut): Koordinate des zweiten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Messachse Q272: Achse der Bearbeitungsebene, in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse

Verfahrrichtung 1 Q267: Richtung, in der das Tastsystem auf das Werkstück zufahren soll: -1: Verfahrrichtung negativ +1: Verfahrrichtung positiv

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef
Beispiel: NC-Sätze
5 TCH PROBE 400 GRUNDDREHUNG
Q263=+10 ;1. PUNKT 1. ACHSE
Q264=+3,5 ;1. PUNKT 2. ACHSE
Q265=+25 ;2. PUNKT 1. ACHSE
Q266=+8 ;2. PUNKT 2. ACHSE
Q272=2 ;MESSACHSE
Q267=+1 ;VERFAHRRICHTUNG
Q261=-5 ;MESSHOEHE
Q320=0 ;SICHERHEITS-ABST.
Q260=+20 ;SICHERE HOEHE
Q301=0 ;FAHREN AUF S. HOEHE
Q307=0 ;voreinst. grunddr.
Q305=0 ;Nr. in tabelle

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Voreinstellung Grunddrehung Q307 (absolut): Wenn sich die zu messende Schieflage nicht auf die Hauptachse, sondern auf eine beliebige Gerade beziehen soll, Winkel der Bezugsgeraden eingeben. Die TNC ermittelt dann für die Grunddrehung die Differenz aus dem gemessenen Wert und dem Winkel der Bezugsgeraden. Eingabebereich -360,000 bis 360,000

Preset-Nummer in Tabelle Q305: Nummer in der Preset-Tabelle angeben, in der die TNC die ermittelte Grunddrehung speichern soll. Bei Eingabe von Q305=0, legt die TNC die ermittelte Grunddrehung im ROT-Menü der Betriebsart Manuell ab. Eingabebereich 0 bis 99999


GRUNDDREHUNG über zwei Bohrungen (Zyklus 401, DIN/ISO: G401)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 401 erfasst die Mittelpunkte zweier Bohrungen. Anschließend berechnet die TNC den Winkel zwischen der Hauptachse der Bearbeitungsebene und der Verbindungsgeraden der Bohrungs-Mittelpunkte. Über die Funktion Grunddrehung kompensiert die TNC den berechneten Wert. Alternativ können Sie die ermittelte Schieflage auch durch eine Drehung des Rundtisches kompensieren.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) auf den eingegebenen Mittelpunkt der ersten Bohrung 1
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den ersten Bohrungs-Mittelpunkt
  3. Anschließend fährt das Tastsystem zurück auf die sichere Höhe und positioniert auf den eingegebenen Mittelpunkt der zweiten Bohrung 2
  4. Die TNC fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den zweiten Bohrungs-Mittelpunkt
  5. Abschließend fährt die TNC das Tastsystem zurück auf die Sichere Höhe und führt die ermittelte Grunddrehung durch


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Die TNC setzt eine aktive Grunddrehung am Zyklusanfang zurück.

Dieser Tastsystem-Zyklus ist bei aktiver Funktion Bearbeitungsebene schwenken nicht erlaubt.

Wenn Sie die Schieflage über eine Rundtischdrehung kompensieren wollen, dann verwendet die TNC automatisch folgende Drehachsen:

  • C bei Werkzeug-Achse Z
  • B bei Werkzeug-Achse Y
  • A bei Werkzeug-Achse X


Zyklusparameter

1. Bohrung: Mitte 1. Achse Q268 (absolut): Mittelpunkt der ersten Bohrung in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Bohrung: Mitte 2. Achse Q269 (absolut): Mittelpunkt der ersten Bohrung in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Bohrung: Mitte 1. Achse Q270 (absolut): Mittelpunkt der zweiten Bohrung in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Bohrung: Mitte 2. Achse Q271 (absolut): Mittelpunkt der zweiten Bohrung in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Voreinstellung Grunddrehung Q307 (absolut): Wenn sich die zu messende Schieflage nicht auf die Hauptachse, sondern auf eine beliebige Gerade beziehen soll, Winkel der Bezugsgeraden eingeben. Die TNC ermittelt dann für die Grunddrehung die Differenz aus dem gemessenen Wert und dem Winkel der Bezugsgeraden. Eingabebereich -360,000 bis 360,000

Beispiel: NC-Sätze
5 TCH PROBE 401 ROT 2 BOHRUNGEN
Q268=+37 ;1. MITTE 1. ACHSE
Q269=+12 ;1. MITTE 2. ACHSE
Q270=+75 ;2. MITTE 1. ACHSE
Q271=+20 ;2. MITTE 2. ACHSE
Q261=-5 ;MESSHOEHE
Q260=+20 ;SICHERE HOEHE
Q307=0 ;voreinst. grunddr.
Q305=0 ;Nr. in tabelle
Q402=0 ;Ausrichten
Q337=0 ;null setzen

Preset-Nummer in Tabelle Q305: Nummer in der Preset-Tabelle angeben, in der die TNC die ermittelte Grunddrehung speichern soll. Bei Eingabe von Q305=0, legt die TNC die ermittelte Grunddrehung im ROT-Menü der Betriebsart Manuell ab. Parameter hat keine Wirkung, wenn Schieflage über Rundtischdrehung kompensiert werden soll (Q402=1). In diesem Fall wird die Schieflage nicht als Winkelwert gespeichert. Eingabebereich 0 bis 99999

Grunddrehung/Ausrichten Q402: Festlegen, ob die TNC die ermittelte Schieflage als Grunddrehung setzen, oder per Rundtischdrehung ausrichten soll: 0: Grunddrehung setzen 1: Rundtischdrehung ausführen Wenn Sie Rundtischdrehung wählen, dann speichert die TNC die ermittelte Schieflage nicht ab, auch wenn Sie im Parameter Q305 eine Tabellenzeile definiert haben

Null setzen nach Ausrichtung Q337: Festlegen, ob die TNC die Anzeige der ausgerichteten Drehachse auf 0 setzen soll: 0: Anzeige der Drehachse nach dem Ausrichten nicht auf 0 setzen 1: Anzeige der Drehachse nach dem Ausrichten auf 0 setzen Die TNC setzt die Anzeige nur dann = 0, wenn Sie Q402=1 definiert haben


GRUNDDREHUNG über zwei Zapfen (Zyklus 402, DIN/ISO: G402)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 402 erfasst die Mittelpunkte zweier Zapfen. Anschließend berechnet die TNC den Winkel zwischen der Hauptachse der Bearbeitungsebene und der Verbindungsgeraden der Zapfen-Mittelpunkte. Über die Funktion Grunddrehung kompensiert die TNC den berechneten Wert. Alternativ können Sie die ermittelte Schieflage auch durch eine Drehung des Rundtisches kompensieren.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) auf den Antastpunkt 1 des ersten Zapfens
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe 1 und erfasst durch vier Antastungen den ersten Zapfen-Mittelpunkt. Zwischen den jeweils um 90° versetzten Antastpunkten verfährt das Tastsystem auf einem Kreisbogen
  3. Anschließend fährt das Tastsystem zurück auf die sichere Höhe und positioniert auf den Antastpunkt 5 des zweiten Zapfens
  4. Die TNC fährt das Tastsystem auf die eingegebene Messhöhe 2 und erfasst durch vier Antastungen den zweiten Zapfen-Mittelpunkt
  5. Abschließend fährt die TNC das Tastsystem zurück auf die Sichere Höhe und führt die ermittelte Grunddrehung durch


Zyklusparameter

1. Zapfen: Mitte 1. Achse (absolut): Mittelpunkt des ersten Zapfens in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Zapfen: Mitte 2. Achse Q269 (absolut): Mittelpunkt des ersten Zapfens in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Durchmesser Zapfen 1 Q313: Ungefährer Durchmesser des 1. Zapfens. Wert eher zu groß eingeben. Eingabebereich 0 bis 99999,9999

Messhöhe Zapfen 1 in TS-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung des Zapfens 1 erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

2. Zapfen: Mitte 1. Achse Q270 (absolut): Mittelpunkt des zweiten Zapfens in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Zapfen: Mitte 2. Achse Q271 (absolut): Mittelpunkt des zweiten Zapfens in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Durchmesser Zapfen 2 Q314: Ungefährer Durchmesser des 2. Zapfens. Wert eher zu groß eingeben. Eingabebereich 0 bis 99999,9999

Messhöhe Zapfen 2 in TS-Achse Q315 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung des Zapfens 2 erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef
Beispiel: NC-Sätze
5 TCH PROBE 402 ROT 2 ZAPFEN
Q268=-37 ;1. MITTE 1. ACHSE
Q269=+12 ;1. MITTE 2. ACHSE
Q313=60 ;DURCHMESSER ZAPFEN 1
Q261=-5 ;MESSHOEHE 1
Q270=+75 ;2. MITTE 1. ACHSE
Q271=+20 ;2. MITTE 2. ACHSE
Q314=60 ;DURCHMESSER ZAPFEN 2
Q315=-5 ;MESSHOEHE 2
Q320=0 ;SICHERHEITS-ABST.
Q260=+20 ;SICHERE HOEHE
Q301=0 ;FAHREN AUF S. HOEHE
Q307=0 ;voreinst. grunddr.
Q305=0 ;Nr. in tabelle
Q402=0 ;Ausrichten
Q337=0 ;null setzen

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Voreinstellung Grunddrehung Q307 (absolut): Wenn sich die zu messende Schieflage nicht auf die Hauptachse, sondern auf eine beliebige Gerade beziehen soll, Winkel der Bezugsgeraden eingeben. Die TNC ermittelt dann für die Grunddrehung die Differenz aus dem gemessenen Wert und dem Winkel der Bezugsgeraden. Eingabebereich -360,000 bis 360,000

Preset-Nummer in Tabelle Q305: Nummer in der Preset-Tabelle angeben, in der die TNC die ermittelte Grunddrehung speichern soll. Bei Eingabe von Q305=0, legt die TNC die ermittelte Grunddrehung im ROT-Menü der Betriebsart Manuell ab. Parameter hat keine Wirkung, wenn Schieflage über Rundtischdrehung kompensiert werden soll (Q402=1). In diesem Fall wird die Schieflage nicht als Winkelwert gespeichert. Eingabebereich 0 bis 99999

Grunddrehung/Ausrichten Q402: Festlegen, ob die TNC die ermittelte Schieflage als Grunddrehung setzen, oder per Rundtischdrehung ausrichten soll: 0: Grunddrehung setzen 1: Rundtischdrehung ausführen Wenn Sie Rundtischdrehung wählen, dann speichert die TNC die ermittelte Schieflage nicht ab, auch wenn Sie im Parameter Q305 eine Tabellenzeile definiert haben

Null setzen nach Ausrichtung Q337: Festlegen, ob die TNC die Anzeige der ausgerichteten Drehachse auf 0 setzen soll: 0: Anzeige der Drehachse nach dem Ausrichten nicht auf 0 setzen 1: Anzeige der Drehachse nach dem Ausrichten auf 0 setzen Die TNC setzt die Anzeige nur dann = 0, wenn Sie Q402=1 definiert haben


GRUNDDREHUNG über eine Drehachse kompensieren (Zyklus 403, DIN/ISO: G403)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 403 ermittelt durch Messung zweier Punkte, die auf einer Geraden liegen müssen, eine Werkstück-Schieflage. Die ermittelte Werkstück-Schieflage kompensiert die TNC durch Drehung der A-, B- oder C-Achse. Das Werkstück darf dabei beliebig auf dem Rundtisch aufgespannt sein.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum programmierten Antastpunkt 1. Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand entgegen der festgelegten Verfahrrichtung
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Anschließend fährt das Tastsystem zum nächsten Antastpunkt 2 und führt den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zurück auf die Sichere Höhe und positioniert die im Zyklus definierte Drehachse um den ermittelten Wert. Optional können Sie die Anzeige nach dem Ausrichten auf 0 setzen lassen


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Achten Sie auf ausreichend große sichere Höhe, so dass beim abschließenden Positionieren der Drehachse keine Kollisionen entstehen können!

Wenn Sie im Parameter Q312 Achse für Ausgleichsbewegung den Wert 0 eingeben, ermittelt der Zyklus die auszurichtende Drehachse automatisch (empfohlene Einstellung). Dabei wird, abhängig von der Reihenfolge der Antastpunkte, ein Winkel mit der tatsächlichen Richtung ermittelt. Der ermittelte Winkel zeigt vom ersten und zum zweiten Antastpunkt. Wenn Sie im Parameter Q312 die A-, B- oder C-Achse als Ausgleichsachse wählen, ermittelt der Zyklus den Winkel unabhängig von der Reihenfolge der Antastpunkte. Der berechnete Winkel liegt im Bereich von -90 bis +90°. Überprüfen Sie nach dem Ausrichten die Stellung der Drehachse!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Die TNC speichert den ermittelten Winkel auch im Parameter Q150 ab.

Um die Ausgleichsachse automatisch vom Zyklus bestimmen zu lassen, muss eine Kinematikbeschreibung in der TNC hinterlegt sein.


Zyklusparameter

1. Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 1. Achse Q265 (absolut): Koordinate des zweiten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 2. Achse Q266 (absolut): Koordinate des zweiten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Messachse Q272: Achse, in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse 3: Tastsystem-Achse = Messachse

Verfahrrichtung 1 Q267: Richtung, in der das Tastsystem auf das Werkstück zufahren soll: -1: Verfahrrichtung negativ +1: Verfahrrichtung positiv

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef
Beispiel: NC-Sätze
5 TCH PROBE 403 ROT UEBER C-ACHSE
Q263=+25 ;1. PUNKT 1. ACHSE
Q264=+10 ;1. PUNKT 2. ACHSE
Q265=+40 ;2. PUNKT 1. ACHSE
Q266=+17 ;2. PUNKT 2. ACHSE
Q272=2 ;messachse
Q267=+1 ;verfahrrichtung
Q261=-5 ;messhoehe
Q320=0 ;SICHERHEITS-ABST.
Q260=+20 ;sichere hoehe
Q301=0 ;FAHREN AUF S. HOEHE
Q312=0 ;ausgleichsachse
Q337=0 ;null setzen
Q305=1 ;nr. in tabelle
Q303=+1 ;messwert-uebergabe
Q380=+0 ;bezugswinkel

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren

Achse für Ausgleichsbewegung Q312: Festlegen, mit welcher Drehachse die TNC die gemessene Schieflage kompensieren soll. 0: Automatikmodus – die TNC ermittelt die auszurichtende Drehachse anhand der aktiven Kinematik. Im Automatikmodus wird die erste Tischdrehachse (ausgehend vom Werkstück) als Ausgleichsachse verwendet. Empfohlene Einstellung! 4: Schieflage mit Drehachse A kompensieren 5: Schieflage mit Drehachse B kompensieren 6: Schieflage mit Drehachse C kompensieren

Null setzen nach Ausrichtung Q337: Festlegen, ob die TNC die Anzeige der ausgerichteten Drehachse auf 0 setzen soll: 0: Anzeige der Drehachse nach dem Ausrichten nicht auf 0 setzen 1: Anzeige der Drehachse nach dem Ausrichten auf 0 setzen

Nummer in Tabelle Q305: Nummer in der Preset-Tabelle/Nullpunkt-Tabelle angeben, in der die TNC die Drehachse abnullen soll. Nur wirksam, wenn Q337 = 1 gesetzt ist. Eingabebereich 0 bis 99999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Winkel in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: 0: Ermittelten Winkel als Nullpunkt-Verschiebung in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Winkel in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Bezugswinkel ?(0=Hauptachse) Q380: Winkel, auf den die TNC die angetastete Gerade ausrichten soll. Nur wirksam, wenn Drehachse = Automatikmodus oder C gewählt ist (Q312 = 0 oder 6). Eingabebereich -360,000 bis 360,000


GRUNDDREHUNG SETZEN (Zyklus 404, DIN/ISO: G404)

Weitere Informationen:
> Zyklusablauf
> Zyklusparameter


Zyklusablauf

Beispiel: NC-Sätze
5 tch probe 404 grunddrehung
Q307=+0 ;voreinst. grunddr.
Q305=1 ;nr. in tabelle

Mit dem Tastsystem-Zyklus 404 können Sie während des Programmlaufs automatisch eine beliebige Grunddrehung setzen. Vorzugsweise ist der Zyklus zu verwenden, wenn Sie eine zuvor durchgeführte Grunddrehung rücksetzen wollen.


Zyklusparameter

Voreinstellung Grunddrehung: Winkelwert, mit dem die Grunddrehung gesetzt werden soll. Eingabebereich -360,000 bis 360,000

Nummer in Tabelle Q305: Nummer in der Bezugspunkt-Tabelle/Nullpunkt-Tabelle angeben, in der die TNC die definierte Grunddrehung speichern soll. -1: Die TNC überschreibt den aktiven Bezugspunkt und aktiviert ihn 0: Die TNC kopiert den aktiven Bezugspunkt in den Bezugspunkt 0, schreibt die Grunddrehung und aktiviert den Bezugspunkt 0 >0: Die TNC schreibt lediglich die definierte Grunddrehung in die angegebenen Bezugspunktnummer und aktiviert diesen Bezugspunkt nicht. Ggf. Zyklus 247 verwenden (siehe BEZUGSPUNKT SETZEN (Zyklus 247, DIN/ISO: G247)) Eingabebereich 0 bis 99999


Schieflage eines Werkstücks über C-Achse ausrichten (Zyklus 405, DIN/ISO: G405)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit dem Tastsystem-Zyklus 405 ermitteln Sie

  • den Winkelversatz zwischen der positiven Y-Achse des aktiven Koordinaten-Systems und der Mittellinie einer Bohrung oder
  • den Winkelversatz zwischen der Sollposition und der Istposition eines Bohrungs-Mittelpunktes

Den ermittelten Winkelversatz kompensiert die TNC durch Drehung der C-Achse. Das Werkstück darf dabei beliebig auf dem Rundtisch aufgespannt sein, die Y-Koordinate der Bohrung muss jedoch positiv sein. Wenn Sie den Winkelversatz der Bohrung mit Tastsystemachse Y (Horizontale Lage der Bohrung) messen, kann es erforderlich sein, den Zyklus mehrfach auszuführen, da durch die Messstrategie eine Ungenauigkeit von ca. 1% der Schieflage entsteht.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Die TNC bestimmt die Antast-Richtung automatisch in Abhängigkeit vom programmierten Startwinkel
  3. Danach fährt das Tastsystem zirkular, entweder auf Messhöhe oder auf Sicherer Höhe, zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch und positioniert das Tastsystem auf die ermittelte Bohrungsmitte
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und richtet das Werkstück durch Drehung des Rundtisches aus. Die TNC dreht dabei den Rundtisch so, dass der Bohrungs-Mittelpunkt nach der Kompensation - sowohl bei vertikaler als auch bei horizontaler Tastsystemachse - In Richtung der positiven Y-Achse, oder auf der Sollposition des Bohrungs-Mittelpunktes liegt. Der gemessene Winkelversatz steht zusätzlich noch im Parameter Q150 zur Verfügung


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Um eine Kollision zwischen Tastsystem und Werkstück zu vermeiden, geben Sie den Soll-Durchmesser der Tasche (Bohrung) eher zu klein ein.

Wenn die Taschenmaße und der Sicherheits-Abstand eine Vorpositionierung in die Nähe der Antastpunkte nicht erlauben, tastet die TNC immer ausgehend von der Taschenmitte an. Zwischen den vier Messpunkten fährt das Tastsystem dann nicht auf die Sichere Höhe.

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Je kleiner Sie den Winkelschritt programmieren, desto ungenauer berechnet die TNC den Kreismittelpunkt. Kleinster Eingabewert: 5°.


Zyklusparameter

Mitte 1. Achse Q321 (absolut): Mitte der Bohrung in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q322 (absolut): Mitte der Bohrung in der Nebenachse der Bearbeitungsebene. Wenn Sie Q322 = 0 programmieren, dann richtet die TNC den Bohrungs-Mittelpunkt auf die positive Y-Achse aus, wenn Sie Q322 ungleich 0 programmieren, dann richtet die TNC den Bohrungs-Mittelpunkt auf die Sollposition (Winkel, der sich aus der Bohrungsmitte ergibt) aus. Eingabebereich -99999,9999 bis 99999,9999

Soll-Durchmesser Q262: Ungefährer Durchmesser der Kreistasche (Bohrung). Wert eher zu klein eingeben. Eingabebereich 0 bis 99999,9999

Startwinkel Q325 (absolut): Winkel zwischen der Hauptachse der Bearbeitungsebene und dem ersten Antastpunkt. Eingabebereich -360,000 bis 360,000

Winkelschritt Q247 (inkremental): Winkel zwischen zwei Messpunkten, das Vorzeichen des Winkelschritts legt die Drehrichtung fest (- = Uhrzeigersinn), mit der das Tastsystem zum nächsten Messpunkt fährt. Wenn Sie Kreisbögen vermessen wollen, dann programmieren Sie einen Winkelschritt kleiner 90°. Eingabebereich -120,000 bis 120,000

Beispiel: NC-Sätze
5 tch probe 405 rot ueber c-achse
Q321=+50 ;mitte 1. achse
Q322=+50 ;mitte 2. achse
Q262=10 ;soll-durchmesser
Q325=+0 ;startwinkel
Q247=90 ;winkelschritt
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q337=0 ;null setzen

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Null setzen nach Ausrichtung Q337: Festlegen, ob die TNC die Anzeige der C-Achse auf 0 setzen soll, oder den Winkelversatz in die Spalte C der Nullpunkt-Tabelle schreiben soll: 0: Anzeige der C-Achse auf 0 setzen und Wert in die Zeile 0 der Bezugspunktabelle Schreiben >0: Gemessenen Winkelversatz vorzeichenrichtig in die Nullpunkt-Tabelle schreiben. Zeilen-Nummer = Wert vom Q337. Ist bereits eine C-Verschiebung in die Nullpunkt-Tabelle eingetragen, dann addiert die TNC den gemessenen Winkelversatz vorzeichenrichtig


Tastsystemzyklen: Werkstückschieflagen automatisch ermitteln

Beispiel: Grunddrehung über zwei Bohrungen bestimmen

0 begin pgm cyc401 mm |
1 tool call 69 z |
2 tch probe 401 rot 2 bohrungen |
Q268=+25 ;1. mitte 1. achse | Mittelpunkt der 1. Bohrung: X-Koordinate
Q269=+15 ;1. mitte 2. achse | Mittelpunkt der 1. Bohrung: Y-Koordinate
Q270=+80 ;2. mitte 1. achse | Mittelpunkt der 2. Bohrung: X-Koordinate
Q271=+35 ;2. mitte 2. achse | Mittelpunkt der 2. Bohrung: Y-Koordinate
Q261=-5 ;messhoehe | Koordinate in der Tastsystem-Achse, auf der die Messung erfolgt
Q260=+20 ;sichere hoehe | Höhe, auf der das Tastsystem-Achse ohne Kollision verfahren kann
Q307=+0 ;voreinst. grunddr. | Winkel der Bezugsgeraden
Q402=1 ;ausrichten | Schieflage durch Rundtischdrehung kompensieren
Q337=1 ;null setzen | Nach dem Ausrichten Anzeige abnullen
3 call pgm 35k47 | Bearbeitungsprogramm aufrufen
4 end pgm cyc401 mm |


Tastsystemzyklen: Bezugspunkte automatisch erfassen

Weitere Informationen:
> Grundlagen
> BEZUGSPUNKT MITTE NUT (Zyklus 408, DIN/ISO: G408, FCL 3-Funktion)
> BEZUGSPUNKT MITTE STEG (Zyklus 409, DIN/ISO: G409, FCL 3-Funktion)
> BEZUGSPUNKT RECHTECK INNEN (Zyklus 410, DIN/ISO: G410)
> BEZUGSPUNKT RECHTECK AUSSEN (Zyklus 411, DIN/ISO: G411)
> BEZUGSPUNKT KREIS INNEN (Zyklus 412, DIN/ISO: G412)
> BEZUGSPUNKT KREIS AUSSEN (Zyklus 413, DIN/ISO: G413)
> BEZUGSPUNKT ECKE AUSSEN (Zyklus 414, DIN/ISO: G414)
> BEZUGSPUNKT ECKE INNEN (Zyklus 415, DIN/ISO: G415)
> BEZUGSPUNKT LOCHKREIS-MITTE (Zyklus 416, DIN/ISO: G416)
> BEZUGSPUNKT TASTSYSTEM-ACHSE (Zyklus 417, DIN/ISO: G417)
> BEZUGSPUNKT MITTE 4 BOHRUNGEN (Zyklus 418, DIN/ISO: G418)
> BEZUGSPUNKT EINZELNE ACHSE (Zyklus 419, DIN/ISO: G419)
> Beispiel: Bezugspunkt-Setzen Mitte Kreissegment und Werkstück-Oberkante
> Beispiel: Bezugspunkt-Setzen Werkstück-Oberkante und Mitte Lochkreis


Grundlagen

Weitere Informationen:
> Übersicht
> Gemeinsamkeiten aller Tastsystemzyklen zum Bezugspunkt-Setzen


Übersicht

    Die TNC stellt zwölf Zyklen zur Verfügung, mit denen Sie Bezugspunkte automatisch ermitteln und wie folgt verarbeiten können:

  • Ermittelte Werte direkt als Anzeigewerte setzen
  • Ermittelte Werte in die Preset-Tabelle schreiben
  • Ermittelte Werte in eine Nullpunkt-Tabelle schreiben
Zyklus | Softkey | Seite
408 BZPKT MITTE NUT Breite einer Nut innen messen, Nutmitte als Bezugspunkt setzen |  | BEZUGSPUNKT MITTE NUT (Zyklus 408, DIN/ISO: G408, FCL 3-Funktion)
409 BZPKT MITTE STEG Breite eines Steges außen messen, Stegmitte als Bezugspunkt setzen |  | BEZUGSPUNKT MITTE STEG (Zyklus 409, DIN/ISO: G409, FCL 3-Funktion)
410 BZPKT RECHTECK INNEN Länge und Breite eines Rechtecks innen messen, Rechteckmitte als Bezugspunkt setzen |  | BEZUGSPUNKT RECHTECK INNEN (Zyklus 410, DIN/ISO: G410)
411 BZPKT RECHTECK AUSSEN Länge und Breite eines Rechtecks außen messen, Rechteckmitte als Bezugspunkt setzen |  | BEZUGSPUNKT RECHTECK AUSSEN (Zyklus 411, DIN/ISO: G411)
412 BZPKT KREIS INNEN Vier beliebige Kreispunkte innen messen, Kreismitte als Bezugspunkt setzen |  | BEZUGSPUNKT KREIS INNEN (Zyklus 412, DIN/ISO: G412)
413 BZPKT KREIS AUSSEN Vier beliebige Kreispunkte außen messen, Kreismitte als Bezugspunkt setzen |  | BEZUGSPUNKT KREIS AUSSEN (Zyklus 413, DIN/ISO: G413)
414 BZPKT ECKE AUSSEN Zwei Geraden außen messen, Schnittpunkt der Geraden als Bezugspunkt setzen |  | BEZUGSPUNKT ECKE AUSSEN (Zyklus 414, DIN/ISO: G414)
415 BZPKT ECKE INNEN Zwei Geraden innen messen, Schnittpunkt der Geraden als Bezugspunkt setzen |  | BEZUGSPUNKT ECKE INNEN (Zyklus 415, DIN/ISO: G415)
416 BZPKT LOCHKREIS-MITTE (2. Softkey-Ebene) Drei beliebige Bohrungen auf dem Lochkreis messen, Lochkreis-Mitte als Bezugspunkt setzen |  | BEZUGSPUNKT LOCHKREIS-MITTE (Zyklus 416, DIN/ISO: G416)
417 BZPKT TS.-ACHSE (2. Softkey-Ebene) Beliebige Position in der Tastsystem-Achse messen und als Bezugspunkt setzen |  | BEZUGSPUNKT TASTSYSTEM-ACHSE (Zyklus 417, DIN/ISO: G417)
418 BZPKT 4 BOHRUNGEN (2. Softkey-Ebene) Jeweils 2 Bohrungen über Kreuz messen, Schnittpunkt der Verbindungsgeraden als Bezugspunkt setzen |  | BEZUGSPUNKT MITTE 4 BOHRUNGEN (Zyklus 418, DIN/ISO: G418)
419 BZPKT EINZELNE ACHSE (2. Softkey-Ebene) Beliebige Position in einer wählbaren Achse messen und als Bezugspunkt setzen |  | BEZUGSPUNKT EINZELNE ACHSE (Zyklus 419, DIN/ISO: G419)


Gemeinsamkeiten aller Tastsystemzyklen zum Bezugspunkt-Setzen

Sie können die Tastsystemzyklen 408 bis 419 auch bei aktiver Rotation (Grunddrehung oder Zyklus 10) abarbeiten.
Weitere Informationen:
> Bezugspunkt und Tastsystem-Achse
> Berechneten Bezugspunkt speichern
> Messergebnisse in Q-Parametern


Bezugspunkt und Tastsystem-Achse

Die TNC setzt den Bezugspunkt in der Bearbeitungsebene in Abhängigkeit von der Tastsystem-Achse, die Sie in Ihrem Messprogramm definiert haben:

Aktive Tastsystem-Achse | Bezugspunkt-Setzen in
Z oder W | X und Y
Y oder V | Z und X
X oder U | Y und Z


Berechneten Bezugspunkt speichern

Bei allen Zyklen zum Bezugspunkt-Setzen können Sie über die Eingabeparameter Q303 und Q305 festlegen, wie die TNC den berechneten Bezugspunkt speichern soll:

  • Q305 = 0, Q303 = beliebiger Wert:
    Die TNC setzt den berechneten Bezugspunkt in der Anzeige. Der neue Bezugspunkt ist sofort aktiv. Gleichzeitig speichert die TNC den per Zyklus in der Anzeige gesetzten Bezugspunkt auch in die Zeile 0 der Preset-Tabelle
  • Q305 ungleich 0, Q303 = -1

Diese Kombination kann nur entstehen, wenn Sie

  • Programme mit Zyklen 410 bis 418 einlesen, die auf einer TNC 4xx erstellt wurden
  • Programme mit Zyklen 410 bis 418 einlesen, die mit einem älteren Softwarestand der iTNC 530 erstellt wurden
  • bei der Zyklus-Definition die Messwert-Übergabe über den Parameter Q303 nicht bewusst definiert haben

In solchen Fällen gibt die TNC eine Fehlermeldung aus, da sich das komplette Handling in Verbindung mit REF-bezogenen Nullpunkt-Tabellen geändert hat und Sie über den Parameter Q303 eine definierte Messwert-Übergabe festlegen müssen.
  • Q305 ungleich 0, Q303 = 0
    Die TNC schreibt den berechneten Bezugspunkt in die aktive Nullpunkt-Tabelle. Bezugssystem ist das aktive Werkstück-Koordinatensystem. Der Wert des Parameters Q305 bestimmt die Nullpunkt-Nummer. Nullpunkt über Zyklus 7 im NC-Programm aktivieren
  • Q305 ungleich 0, Q303 = 1
    Die TNC schreibt den berechneten Bezugspunkt in die Preset-Tabelle. Bezugssystem ist das Maschinen-Koordinatensystem (REF-Koordinaten). Der Wert des Parameters Q305 bestimmt die Preset-Nummer. Preset über Zyklus 247 im NC-Programm aktivieren


Messergebnisse in Q-Parametern

Die Messergebnisse des jeweiligen Antast-Zyklus legt die TNC in den global wirksamen Q-Parametern Q150 bis Q160 ab. Diese Parameter können Sie in Ihrem Programm weiterverwenden. Beachten Sie die Tabelle der Ergebnis-Parameter, die bei jeder Zyklus-Beschreibung mit aufgeführt ist.


BEZUGSPUNKT MITTE NUT (Zyklus 408, DIN/ISO: G408, FCL 3-Funktion)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 408 ermittelt den Mittelpunkt einer Nut und setzt diesen Mittelpunkt als Bezugspunkt. Wahlweise kann die TNC den Mittelpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Mess-höhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Danach fährt das Tastsystem entweder achsparallel auf Messhöhe oder linear auf Sicherer Höhe zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern) und speichert die Istwerte in nachfolgend aufgeführten Q-Parametern ab
  5. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse
Parameter-Nummer | Bedeutung
Q166 | Istwert gemessene Nutbreite
Q157 | Istwert Lage Mittelachse


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Um eine Kollision zwischen Tastsystem und Werkstück zu vermeiden, geben Sie die Nutbreite eher zu klein ein.

Wenn die Nutbreite und der Sicherheits-Abstand eine Vorpositionierung in die Nähe der Antastpunkte nicht erlauben, tastet die TNC immer ausgehend von der Nutmitte an. Zwischen den zwei Messpunkten fährt das Tastsystem dann nicht auf die Sichere Höhe.

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.


Zyklusparameter

Mitte 1. Achse Q321 (absolut): Mitte der Nut in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q322 (absolut): Mitte der Nut in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Breite der Nut Q311 (inkremental): Breite der Nut unabhängig von der Lage in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Messachse (1=1.Achse/2=2.Achse) Q272: Achse, in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse

Messhöhe in der Tastsystemachse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Nutmitte speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Nutmitte sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Nutmittein in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Q405 (absolut): Koordinate in der Messachse, auf die die TNC die ermittelte Nutmitte setzen soll. Grundeinstellung = 0. Eingabebereich ‑99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 408 bzpkt mitte nut
Q321=+50 ;mitte 1. achse
Q322=+50 ;mitte 2. achse
Q311=25 ;nutbreite
Q272=1 ;messachse
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q305=10 ;nr. in tabelle
Q405=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. ko. fuer ts-achse
Q384=+0 ;3. ko. fuer ts-achse
Q333=+1 ;bezugspunkt

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999


BEZUGSPUNKT MITTE STEG (Zyklus 409, DIN/ISO: G409, FCL 3-Funktion)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 409 ermittelt den Mittelpunkt eines Steges und setzt diesen Mittelpunkt als Bezugspunkt. Wahlweise kann die TNC den Mittelpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Mess-höhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Danach fährt das Tastsystem auf Sicherer Höhe zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern) und speichert die Istwerte in nachfolgend aufgeführten Q-Parametern ab
  5. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse
Parameter-Nummer | Bedeutung
Q166 | Istwert gemessene Stegbreite
Q157 | Istwert Lage Mittelachse


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Um eine Kollision zwischen Tastsystem und Werkstück zu vermeiden, geben Sie die Stegbreite eher zu groß ein.

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.


Zyklusparameter

Mitte 1. Achse Q321 (absolut): Mitte des Steges in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q322 (absolut): Mitte des Steges in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Stegbreite Q311 (inkremental): Breite des Steges unabhängig von der Lage in der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Messachse (1=1.Achse/2=2.Achse) Q272: Achse, in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse

Messhöhe in der Tastsystemachse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Stegmitte speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Stegmitte sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Stegmitte in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Q405 (absolut): Koordinate in der Messachse, auf die die TNC die ermittelte Stegmitte setzen soll. Grundeinstellung = 0. Eingabebereich ‑99999,9999 bis 99999,9999

Beispiel: NC-Sätze
5 tch probe 409 bzpkt mitte steg
Q321=+50 ;mitte 1. achse
Q322=+50 ;mitte 2. achse
Q311=25 ;stegbreite
Q272=1 ;messachse
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q305=10 ;nr. in tabelle
Q405=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. ko. fuer ts-achse
Q384=+0 ;3. ko. fuer ts-achse
Q333=+1 ;bezugspunkt

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999


BEZUGSPUNKT RECHTECK INNEN (Zyklus 410, DIN/ISO: G410)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 410 ermittelt den Mittelpunkt einer Rechtecktasche und setzt diesen Mittelpunkt als Bezugspunkt. Wahlweise kann die TNC den Mittelpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Mess-höhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Danach fährt das Tastsystem entweder achsparallel auf Messhöhe oder linear auf Sicherer Höhe zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern)
  6. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse und speichert die Istwerte in folgenden Q-Parametern ab
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q154 | Istwert Seiten-Länge Hauptachse
Q155 | Istwert Seiten-Länge Nebenachse


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Um eine Kollision zwischen Tastsystem und Werkstück zu vermeiden, geben Sie die 1. und 2. Seiten-Länge der Tasche eher zu klein ein.

Wenn die Taschenmaße und der Sicherheits-Abstand eine Vorpositionierung in die Nähe der Antastpunkte nicht erlauben, tastet die TNC immer ausgehend von der Taschenmitte an. Zwischen den vier Messpunkten fährt das Tastsystem dann nicht auf die Sichere Höhe.

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.


Zyklusparameter

Mitte 1. Achse Q321 (absolut): Mitte der Tasche in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q322 (absolut): Mitte der Tasche in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Seiten-Länge Q323 (inkremental): Länge der Tasche, parallel zur Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

2. Seiten-Länge Q324 (inkremental): Länge der Tasche, parallel zur Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Taschenmitte speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Taschenmitte sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Taschenmitte in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Hauptachse Q331 (absolut): Koordinate in der Hauptachse, auf die die TNC die ermittelte Taschenmitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt Nebenachse Q332 (absolut): Koordinate in der Nebenachse, auf die die TNC die ermittelte Taschenmitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 410 bzpkt rechteck innen
Q321=+50 ;mitte 1. achse
Q322=+50 ;mitte 2. achse
Q323=60 ;1. seiten-laenge
Q324=20 ;2. seiten-laenge
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q305=10 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. ko. fuer ts-achse
Q384=+0 ;3. ko. fuer ts-achse
Q333=+1 ;bezugspunkt

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999


BEZUGSPUNKT RECHTECK AUSSEN (Zyklus 411, DIN/ISO: G411)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 411 ermittelt den Mittelpunkt eines Rechteckzapfens und setzt diesen Mittelpunkt als Bezugspunkt. Wahlweise kann die TNC den Mittelpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Danach fährt das Tastsystem entweder achsparallel auf Messhöhe oder linear auf Sicherer Höhe zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern)
  6. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse und speichert die Istwerte in folgenden Q-Parametern ab
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q154 | Istwert Seiten-Länge Hauptachse
Q155 | Istwert Seiten-Länge Nebenachse


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Um eine Kollision zwischen Tastsystem und Werkstück zu vermeiden, geben Sie die 1. und 2. Seiten-Länge des Zap-fens eher zu groß ein.

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.


Zyklusparameter

Mitte 1. Achse Q321 (absolut): Mitte des Zapfens in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q322 (absolut): Mitte des Zapfens in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Seiten-Länge Q323 (inkremental): Länge des Zapfens, parallel zur Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

2. Seiten-Länge Q324 (inkremental): Länge des Zapfens, parallel zur Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Zapfenmitte speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Zapfenmitte sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Zapfenmitte in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Hauptachse Q331 (absolut): Koordinate in der Hauptachse, auf die die TNC die ermittelte Zapfenmitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt Nebenachse Q332 (absolut): Koordinate in der Nebenachse, auf die die TNC die ermittelte Zapfenmitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 411 bzpkt rechteck AUS.
Q321=+50 ;mitte 1. achse
Q322=+50 ;mitte 2. achse
Q323=60 ;1. seiten-laenge
Q324=20 ;2. seiten-laenge
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q305=0 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. ko. fuer ts-achse
Q384=+0 ;3. ko. fuer ts-achse
Q333=+1 ;bezugspunkt

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999


BEZUGSPUNKT KREIS INNEN (Zyklus 412, DIN/ISO: G412)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 412 ermittelt den Mittelpunkt einer Kreis-tasche (Bohrung) und setzt diesen Mittelpunkt als Bezugspunkt. Wahlweise kann die TNC den Mittelpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Die TNC bestimmt die Antast--Richtung automatisch in Abhängigkeit vom programmierten Startwinkel
  3. Danach fährt das Tastsystem zirkular, entweder auf Messhöhe oder auf Sicherer Höhe, zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern) und speichert die Istwerte in nachfolgend aufgeführten Q-Parametern ab
  6. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q153 | Istwert Durchmesser


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Um eine Kollision zwischen Tastsystem und Werkstück zu vermeiden, geben Sie den Soll-Durchmesser der Tasche (Bohrung) eher zu klein ein.

Wenn die Taschenmaße und der Sicherheits-Abstand eine Vorpositionierung in die Nähe der Antastpunkte nicht erlauben, tastet die TNC immer ausgehend von der Taschenmitte an. Zwischen den vier Messpunkten fährt das Tastsystem dann nicht auf die Sichere Höhe.

Je kleiner Sie den Winkelschritt Q247 programmieren, desto ungenauer berechnet die TNC den Bezugspunkt. Kleinster Eingabwert: 5°.

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.


Zyklusparameter

Mitte 1. Achse Q321 (absolut): Mitte der Tasche in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q322 (absolut): Mitte der Tasche in der Nebenachse der Bearbeitungsebene. Wenn Sie Q322 = 0 programmieren, dann richtet die TNC den Bohrungs-Mittelpunkt auf die positive Y-Achse aus, wenn Sie Q322 ungleich 0 programmieren, dann richtet die TNC den Bohrungs-Mittelpunkt auf die Sollposition aus. Eingabebereich -99999,9999 bis 99999,9999

Soll-Durchmesser Q262: Ungefährer Durchmesser der Kreistasche (Bohrung). Wert eher zu klein eingeben. Eingabebereich 0 bis 99999,9999

Startwinkel Q325 (absolut): Winkel zwischen der Hauptachse der Bearbeitungsebene und dem ersten Antastpunkt. Eingabebereich -360,0000 bis 360,0000

Winkelschritt Q247 (inkremental): Winkel zwischen zwei Messpunkten, das Vorzeichen des Winkelschritts legt die Drehrichtung fest (- = Uhrzeigersinn), mit der das Tastsystem zum nächsten Messpunkt fährt. Wenn Sie Kreisbögen vermessen wollen, dann programmieren Sie einen Winkelschritt kleiner 90°. Eingabebereich -120,0000 bis 120,0000

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Taschenmitte speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Taschenmitte sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Taschenmitte in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Hauptachse Q331 (absolut): Koordinate in der Hauptachse, auf die die TNC die ermittelte Taschenmitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt Nebenachse Q332 (absolut): Koordinate in der Nebenachse, auf die die TNC die ermittelte Taschenmitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 412 bzpkt kreis innen
Q321=+50 ;mitte 1. achse
Q322=+50 ;mitte 2. achse
Q262=75 ;soll-durchmesser
Q325=+0 ;startwinkel
Q247=+60 ;winkelschritt
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q305=12 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. ko. fuer ts-achse
Q384=+0 ;3. ko. fuer ts-achse
Q333=+1 ;bezugspunkt
Q423=4 ;ANZAHL MESSPUNKTE
Q365=1 ;Verfahrart

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Anzahl Messpunkte (4/3) Q423: Festlegen, ob die TNC die Bohrung mit 4 oder 3 Antastungen messen soll: 4: 4 Messpunkte verwenden (Standardeinstellung) 3: 3 Messpunkte verwenden

Verfahrart? Gerade=0/Kreis=1 Q365: Festlegen, mit welcher Bahnfunktion das Werkzeug zwischen den Messpunkten verfahren soll, wenn Fahren auf sicherer Höhe (Q301=1) aktiv ist:
0: Zwischen den Bearbeitungen auf einer Geraden verfahren
1: Zwischen den Bearbeitungen zirkular auf dem Teilkreis-Durchmesser verfahren


BEZUGSPUNKT KREIS AUSSEN (Zyklus 413, DIN/ISO: G413)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 413 ermittelt den Mittelpunkt eines Kreiszapfens und setzt diesen Mittelpunkt als Bezugspunkt. Wahlweise kann die TNC den Mittelpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Die TNC bestimmt die Antast-Richtung automatisch in Abhängigkeit vom programmierten Startwinkel
  3. Danach fährt das Tastsystem zirkular, entweder auf Messhöhe oder auf Sicherer Höhe, zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern) und speichert die Istwerte in nachfolgend aufgeführten Q-Parametern ab
  6. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q153 | Istwert Durchmesser


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Um eine Kollision zwischen Tastsystem und Werkstück zu vermeiden, geben Sie den Soll-Durchmesser des Zapfens eher zu groß ein.

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Je kleiner Sie den Winkelschritt Q247 programmieren, desto ungenauer berechnet die TNC den Bezugspunkt. Kleinster Eingabewert: 5°.


Zyklusparameter

Mitte 1. Achse Q321 (absolut): Mitte des Zapfens in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q322 (absolut): Mitte des Zapfens in der Nebenachse der Bearbeitungsebene. Wenn Sie Q322 = 0 programmieren, dann richtet die TNC den Bohrungs-Mittelpunkt auf die positive Y-Achse aus, wenn Sie Q322 ungleich 0 programmieren, dann richtet die TNC den Bohrungs-Mittelpunkt auf die Sollposition aus. Eingabebereich -99999,9999 bis 99999,9999

Soll-Durchmesser Q262: Ungefährer Durchmesser des Zapfens. Wert eher zu groß eingeben. Eingabebereich 0 bis 99999,9999

Startwinkel Q325 (absolut): Winkel zwischen der Hauptachse der Bearbeitungsebene und dem ersten Antastpunkt. Eingabebereich -360,0000 bis 360,0000

Winkelschritt Q247 (inkremental): Winkel zwischen zwei Messpunkten, das Vorzeichen des Winkelschritts legt die Drehrichtung fest (- = Uhrzeigersinn), mit der das Tastsystem zum nächsten Messpunkt fährt. Wenn Sie Kreisbögen vermessen wollen, dann programmieren Sie einen Winkelschritt kleiner 90°. Eingabebereich -120,0000 bis 120,0000

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Zapfenmitte speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Zapfenmitte sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Zapfenmitte in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Hauptachse Q331 (absolut): Koordinate in der Hauptachse, auf die die TNC die ermittelte Zapfenmitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt Nebenachse Q332 (absolut): Koordinate in der Nebenachse, auf die die TNC die ermittelte Zapfenmitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 413 bzpkt kreis AUSSEN
Q321=+50 ;mitte 1. achse
Q322=+50 ;mitte 2. achse
Q262=75 ;soll-durchmesser
Q325=+0 ;startwinkel
Q247=+60 ;winkelschritt
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q305=15 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. ko. fuer ts-achse
Q384=+0 ;3. ko. fuer ts-achse
Q333=+1 ;bezugspunkt
Q423=4 ;ANZAHL MESSPUNKTE
Q365=1 ;Verfahrart

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0

Anzahl Messpunkte (4/3) Q423: Festlegen, ob die TNC den Zapfen mit 4 oder 3 Antastungen messen soll: 4: 4 Messpunkte verwenden (Standardeinstellung) 3: 3 Messpunkte verwenden

Verfahrart? Gerade=0/Kreis=1 Q365: Festlegen, mit welcher Bahnfunktion das Werkzeug zwischen den Messpunkten verfahren soll, wenn Fahren auf sicherer Höhe (Q301=1) aktiv ist:
0: Zwischen den Bearbeitungen auf einer Geraden verfahren
1: Zwischen den Bearbeitungen zirkular auf dem Teilkreis-Durchmesser verfahren


BEZUGSPUNKT ECKE AUSSEN (Zyklus 414, DIN/ISO: G414)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 414 ermittelt den Schnittpunkt zweier Geraden und setzt diesen Schnittpunkt als Bezugspunkt. Wahlweise kann die TNC den Schnittpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum ersten Antastpunkt 1 (siehe Bild rechts oben). Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand entgegen der jeweiligen Verfahrrichtung
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Die TNC bestimmt die Antast-Richtung automatisch in Abhängigkeit vom programmierten 3. Messpunkt
  3. Danach fährt das Tastsystem zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern) und speichert die Koordinaten der ermittelten Ecke in nachfolgend aufgeführten Q-Parametern ab
  6. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse
Parameter-Nummer | Bedeutung
Q151 | Istwert Ecke Hauptachse
Q152 | Istwert Ecke Nebenachse


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Die TNC misst die erste Gerade immer in Richtung der Nebenachse der Bearbeitungsebene.

Durch die Lage der Messpunkte 1 und 3 legen Sie die Ecke fest, an der die TNC den Bezugspunkt setzt (siehe Bild rechts Mitte und nachfolgende Tabelle).

Ecke | Koordinate X | Koordinate Y
A | Punkt 1 größer Punkt 3 | Punkt 1 kleiner Punkt 3
B | Punkt 1 kleiner Punkt 3 | Punkt 1 kleiner Punkt 3
C | Punkt 1 kleiner Punkt 3 | Punkt 1 größer Punkt 3
D | Punkt 1 größer Punkt 3 | Punkt 1 größer Punkt 3


Zyklusparameter

1. Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Abstand 1. Achse Q326 (inkremental): Abstand zwischen erstem und zweitem Messpunkt in der Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

3. Messpunkt 1. Achse Q296 (absolut): Koordinate des dritten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

3. Messpunkt 2. Achse Q297 (absolut): Koordinate des dritten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Abstand 2. Achse Q327 (inkremental): Abstand zwischen drittem und viertem Messpunkt in der Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Grunddrehung durchführen Q304: Festlegen, ob die TNC die Werkstück-Schieflage durch eine Grunddrehung kompensieren soll: 0: Keine Grunddrehung durchführen 1: Grunddrehung durchführen

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Ecke speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Ecke sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Ecke in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Hauptachse Q331 (absolut): Koordinate in der Hauptachse, auf die die TNC die ermittelte Ecke setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt Nebenachse Q332 (absolut): Koordinate in der Nebenachse, auf die die TNC die ermittelte Ecke setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 414 bzpkt ecke innen
Q263=+37 ;1. Punkt 1. achse
Q264=+7 ;1. punkt 2. achse
Q326=50 ;abstand 1. achse
Q296=+95 ;3. punkt 1. achse
Q297=+25 ;3. punkt 2. achse
Q327=45 ;abstand 2. achse
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q304=0 ;grunddrehung
Q305=7 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. ko. fuer ts-achse
Q384=+0 ;3. ko. fuer ts-achse
Q333=+1 ;bezugspunkt

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999


BEZUGSPUNKT ECKE INNEN (Zyklus 415, DIN/ISO: G415)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 415 ermittelt den Schnittpunkt zweier Geraden und setzt diesen Schnittpunkt als Bezugspunkt. Wahlweise kann die TNC den Schnittpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum ersten Antastpunkt 1 (siehe Bild rechts oben), den Sie im Zyklus definieren. Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand entgegen der jeweiligen Verfahrrichtung
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Die Antast-Richtung ergibt sich durch die Eckennummer
  3. Danach fährt das Tastsystem zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern) und speichert die Koordinaten der ermittelten Ecke in nachfolgend aufgeführten Q-Parametern ab
  6. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse
Parameter-Nummer | Bedeutung
Q151 | Istwert Ecke Hauptachse
Q152 | Istwert Ecke Nebenachse


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Die TNC misst die erste Gerade immer in Richtung der Nebenachse der Bearbeitungsebene.


Zyklusparameter

1. Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Abstand 1. Achse Q326 (inkremental): Abstand zwischen erstem und zweitem Messpunkt in der Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Abstand 2. Achse Q327 (inkremental): Abstand zwischen drittem und viertem Messpunkt in der Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Ecke Q308: Nummer der Ecke, an der die TNC den Bezugspunkt setzen soll. Eingabebereich 1 bis 4

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Grunddrehung durchführen Q304: Festlegen, ob die TNC die Werkstück-Schieflage durch eine Grunddrehung kompensieren soll: 0: Keine Grunddrehung durchführen 1: Grunddrehung durchführen

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Ecke speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Ecke sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Ecke in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Hauptachse Q331 (absolut): Koordinate in der Hauptachse, auf die die TNC die ermittelte Ecke setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt Nebenachse Q332 (absolut): Koordinate in der Nebenachse, auf die die TNC die ermittelte Ecke setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 415 bzpkt ecke aussen
Q263=+37 ;1. Punkt 1. achse
Q264=+7 ;1. punkt 2. achse
Q326=50 ;abstand 1. achse
Q296=+95 ;3. punkt 1. achse
Q297=+25 ;3. punkt 2. achse
Q327=45 ;abstand 2. achse
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q304=0 ;grunddrehung
Q305=7 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. ko. fuer ts-achse
Q384=+0 ;3. ko. fuer ts-achse
Q333=+1 ;bezugspunkt

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999


BEZUGSPUNKT LOCHKREIS-MITTE (Zyklus 416, DIN/ISO: G416)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 416 berechnet den Mittelpunkt eines Lochkreises durch Messung dreier Bohrungen und setzt diesen Mittelpunkt als Bezugspunkt. Wahlweise kann die TNC den Mittelpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) auf den eingegebenen Mittelpunkt der ersten Bohrung 1
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den ersten Bohrungs-Mittelpunkt
  3. Anschließend fährt das Tastsystem zurück auf die Sichere Höhe und positioniert auf den eingegebenen Mittelpunkt der zweiten Bohrung 2
  4. Die TNC fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den zweiten Bohrungs-Mittelpunkt
  5. Anschließend fährt das Tastsystem zurück auf die Sichere Höhe und positioniert auf den eingegebenen Mittelpunkt der dritten Bohrung 3
  6. Die TNC fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den dritten Bohrungs-Mittelpunkt
  7. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern) und speichert die Istwerte in nachfolgend aufgeführten Q-Parametern ab
  8. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q153 | Istwert Lochkreis-Durchmesser


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.


Zyklusparameter

Mitte 1. Achse Q273 (absolut): Lochkreis-Mitte (Sollwert) in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q274 (absolut): Lochkreis-Mitte (Sollwert) in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Soll-Durchmesser Q262: Ungefähren Lochkreis-Durchmesser eingeben. Je kleiner der Bohrungsdurchmesser ist, desto genauer müssen Sie den Soll-Durchmesser angeben. Eingabebereich 0 bis 99999,9999

Winkel 1. Bohrung Q291 (absolut): Polarkoordinaten-Winkel des ersten Bohrungs-Mittelpunktes in der Bearbeitungsebene. Eingabebereich -360,0000 bis 360,0000

Winkel 2. Bohrung Q292 (absolut): Polarkoordinaten-Winkel des zweiten Bohrungs-Mittelpunktes in der Bearbeitungsebene. Eingabebereich -360,0000 bis 360,0000

Winkel 3. Bohrung Q293 (absolut): Polarkoordinaten-Winkel des dritten Bohrungs-Mittelpunktes in der Bearbeitungsebene. Eingabebereich -360,0000 bis 360,0000

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten der Lochkreis-Mitte speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt in der Lochkreis-Mitte sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Lochkreis-Mitte in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Hauptachse Q331 (absolut): Koordinate in der Hauptachse, auf die die TNC die ermittelte Lochkreis-Mitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt Nebenachse Q332 (absolut): Koordinate in der Nebenachse, auf die die TNC die ermittelte Lochkreis-Mitte setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 416 bzpkt lochkreismitte
Q273=+50 ;MITTE 1. ACHSE
Q274=+50 ;MITTE 2. ACHSE
Q262=90 ;soll-durchmesser
Q291=+34 ;WINKEL 1. BOHRUNG
Q292=+70 ;WINKEL 2. BOHRUNG
Q293=+210 ;winkel 3. bohrung
Q261=-5 ;messhoehe
Q260=+20 ;sichere hoehe
Q305=12 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. KO. fuer ts-achse
Q384=+0 ;3. KO. fuer ts-achse
Q333=+1 ;bezugspunkt
Q320=0 ;sicherheits-abst.

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140 und nur beim Antasten des Bezugspunktes in der Tastsystem-Achse. Eingabebereich 0 bis 99999,9999 alternativ predef


BEZUGSPUNKT TASTSYSTEM-ACHSE (Zyklus 417, DIN/ISO: G417)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 417 misst eine beliebige Koordinate in der Tastsystem-Achse und setzt diese Koordinate als Bezugspunkt. Wahlweise kann die TNC die gemessene Koordinate auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum programmierten Antastpunkt 1. Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand in Richtung der positiven Tastsystem-Achse
  2. Anschließend fährt das Tastsystem in der Tastsystem-Achse auf die eingegebene Koordinate des Antastpunktes 1 und erfasst durch einfaches Antasten die Ist-Position
  3. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern) und speichert den Istwert in nachfolgend aufgeführtem Q-Parameter ab
Parameter-Nummer | Bedeutung
Q160 | Istwert gemessener Punkt


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben. Die TNC setzt dann in dieser Achse den Bezugs-punkt.


Zyklusparameter

Beispiel: NC-Sätze
5 tch probe 417 bzpkt ts.-achse
Q263=+25 ;1. PUNKT 1. ACHSE
Q264=+25 ;1. PUNKT 2. ACHSE
Q294=+25 ;1. PUNKT 3. ACHSE
Q320=0 ;sicherheits-abst.
Q260=+50 ;sichere hoehe
Q305=0 ;nr. in tabelle
Q333=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe

1. Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 3. Achse Q294 (absolut): Koordinate des ersten Antastpunktes in der Tastsystem-Achse. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinate speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt auf der angetasteten Fläche sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Koordinate in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)


BEZUGSPUNKT MITTE 4 BOHRUNGEN (Zyklus 418, DIN/ISO: G418)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 418 berechnet den Schnittpunkt der Verbindungslinien von jeweils zwei Bohrungs-Mittelpunkten und setzt diesen Schnittpunkt als Bezugspunkt. Wahlweise kann die TNC den Schnittpunkt auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) in die Mitte der ersten Bohrung 1
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den ersten Bohrungs-Mittelpunkt
  3. Anschließend fährt das Tastsystem zurück auf die Sichere Höhe und positioniert auf den eingegebenen Mittelpunkt der zweiten Bohrung 2
  4. Die TNC fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den zweiten Bohrungs-Mittelpunkt
  5. Die TNC wiederholt Vorgang 3 und 4 für die Bohrungen 3 und 4
  6. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern). Die TNC berechnet den Bezugspunkt als Schnittpunkt der Verbindungslinien Bohrungs-Mittelpunkt 1/3 und 2/4 und speichert die Istwerte in nachfolgend aufgeführten Q-Parametern ab
  7. Wenn gewünscht, ermittelt die TNC anschließend in einem separaten Antast-Vorgang noch den Bezugspunkt in der Tastsystem-Achse
Parameter-Nummer | Bedeutung
Q151 | Istwert Schnittpunkt Hauptachse
Q152 | Istwert Schnittpunkt Nebenachse


Zyklusparameter

1 Mitte 1. Achse Q268 (absolut): Mittelpunkt der 1. Bohrung in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1 Mitte 2. Achse Q269 (absolut): Mittelpunkt der 1. Bohrung in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2 Mitte 1. Achse Q270 (absolut): Mittelpunkt der 2. Bohrung in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2 Mitte 2. Achse Q271 (absolut): Mittelpunkt der 2. Bohrung in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

3 Mitte 1. Achse Q316 (absolut): Mittelpunkt der 3. Bohrung in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

3 Mitte 2. Achse Q317 (absolut): Mittelpunkt der 3. Bohrung in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

4 Mitte 1. Achse Q318 (absolut): Mittelpunkt der 4. Bohrung in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

4 Mitte 2. Achse Q319 (absolut): Mittelpunkt der 4. Bohrung in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinaten des Schnittpunkts der Verbindungslinien speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt im Schnittpunkt der Verbindungslinien sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Koordinaten des Schnittpunkts der Verbindungslinien in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Hauptachse Q331 (absolut): Koordinate in der Hauptachse, auf die die TNC den ermittelten Schnittpunkt der Verbindungslinien setzen soll. Grundeinstellung = 0. Eingabebereich ‑99999,9999 bis 99999,9999

Neuer Bezugspunkt Nebenachse Q332 (absolut): Koordinate in der Nebenachse, auf die die TNC den ermittelten Schnittpunkt der Verbindungslinien setzen soll. Grundeinstellung = 0. Eingabebereich ‑99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Wird von der TNC eingetragen, wenn alte Programme eingelesen werden (siehe Berechneten Bezugspunkt speichern) 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)

Beispiel: NC-Sätze
5 tch probe 418 bzpkt 4 bohrungen
Q268=+20 ;1. mitte 1. achse
Q269=+25 ;1. MITTE 2. ACHSE
Q270=+150 ;2. MITTE 1. ACHSE
Q271=+25 ;2. MITTE 2. ACHSE
Q316=+150 ;3. MITTE 1. ACHSE
Q317=+85 ;3. MITTE 2. ACHSE
Q318=+22 ;4. MITTE 1. ACHSE
Q319=+80 ;4. MITTE 2. ACHSE
Q261=-5 ;messhoehe
Q260=+10 ;sichere hoehe
Q305=12 ;nr. in tabelle
Q331=+0 ;bezugspunkt
Q332=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe
Q381=1 ;antasten ts-achse
Q382=+85 ;1. ko. fuer ts-achse
Q383=+50 ;2. KO. fuer ts-achse
Q384=+0 ;3. KO. fuer ts-achse
Q333=+0 ;bezugspunkt

Antasten in TS-Achse Q381: Festlegen, ob die TNC auch den Bezugspunkt in der Tastsystem-Achse setzen soll: 0: Bezugspunkt in der Tastsystem-Achse nicht setzen 1: Bezugspunkt in der Tastsystem-Achse setzen

Tasten TS-Achse: Koor. 1. Achse Q382 (absolut): Koordinate des Antastpunktes in der Hauptachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1

Tasten TS-Achse: Koor. 2. Achse Q383 (absolut): Koordinate des Antastpunktes in der Nebenachse der Bearbeitungsebene, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Tasten TS-Achse: Koor. 3. Achse Q384 (absolut): Koordinate des Antastpunktes in der Tastystem-Achse, an dem der Bezugspunkt in der Tastsystemachse gesetzt werden soll. Nur wirksam, wenn Q381 = 1. Eingabebereich -99999,9999 bis 99999,9999

Neuer Bezugspunkt TS-Achse Q333 (absolut): Koordinate in der Tastsystem-Achse, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999


BEZUGSPUNKT EINZELNE ACHSE (Zyklus 419, DIN/ISO: G419)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklenparameter


Zyklusablauf

Der Tastsystem-Zyklus 419 misst eine beliebige Koordinate in einer wählbaren Achse und setzt diese Koordinate als Bezugspunkt. Wahlweise kann die TNC die gemessene Koordinate auch in eine Nullpunkt- oder Preset-Tabelle schreiben.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum programmierten Antastpunkt 1. Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand entgegen der programmierten Antast-Richtung
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch einfaches Antasten die Ist-Position
  3. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und verarbeitet den ermittelten Bezugspunkt in Abhängigkeit der Zyklusparameter Q303 und Q305 (siehe Berechneten Bezugspunkt speichern)


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Wenn Sie Zyklus 419 mehrfach hintereinander verwenden, um in mehreren Achsen den Bezugspunkt in der Preset-Tabelle zu speichern, dann müssen Sie die Preset-Nummer nach jeder Ausführung des Zyklus 419 aktivieren, in die Zyklus 419 zuvor geschrieben hat (ist nicht erforderlich, wenn Sie den aktiven Preset überschreiben).


Zyklenparameter

1. Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Messachse (1...3: 1=Hauptachse) Q272: Achse, in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse 3: Tastsystem-Achse = Messachse

Achszuordnungen
Aktive Tastsystem-Achse: Q272 = 3 | Zugehörige Hauptachse: Q272 = 1 | Zugehörige Nebenachse: Q272 = 2
Z | X | Y
Y | Z | X
X | Y | Z
Beispiel: NC-Sätze
5 tch probe 419 bzpkt einzelne achse
Q263=+25 ;1. PUNKT 1. ACHSE
Q264=+25 ;1. PUNKT 2. ACHSE
Q261=+25 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+50 ;sichere hoehe
Q272=+1 ;messachse
Q267=+1 ;verfahrrichtung
Q305=0 ;nr. in tabelle
Q333=+0 ;bezugspunkt
Q303=+1 ;messwert-uebergabe

Verfahrrichtung Q267: Richtung, in der das Tastsystem auf das Werkstück zufahren soll: -1: Verfahrrichtung negativ +1: Verfahrrichtung positiv

Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinate speichern soll. Bei Eingabe von Q305=0 und Q303=1, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt auf der angetasteten Fläche sitzt. Bei Eingabe von Q305=0 und Q303=0, schreibt die TNC die Koordinate in die Zeile 0 der Nullpunkt-Tabelle. Eingabebereich 0 bis 99999

Nullpunkt-Nummer in Tabelle Q305: Nummer in der Nullpunkt-Tabelle/Preset-Tabelle angeben, in der die TNC die Koordinate speichern soll. Bei Eingabe von Q305=0, setzt die TNC die Anzeige automatisch so, dass der neue Bezugspunkt auf der angetasteten Fläche sitzt. Eingabebereich 0 bis 99999

Neuer Bezugspunkt Q333 (absolut): Koordinate, auf die die TNC den Bezugspunkt setzen soll. Grundeinstellung = 0. Eingabebereich -99999,9999 bis 99999,9999

Messwert-Übergabe (0,1) Q303: Festlegen, ob der ermittelte Bezugspunkt in der Nullpunkt-Tabelle oder in der Preset-Tabelle abgelegt werden soll: -1: Nicht verwenden! Siehe Berechneten Bezugspunkt speichern 0: Ermittelten Bezugspunkt in die aktive Nullpunkt-Tabelle schreiben. Bezugssystem ist das aktive Werkstück-Koordinatensystem 1: Ermittelten Bezugspunkt in die Preset-Tabelle schreiben. Bezugssystem ist das Maschinen-Koordinatensystem (REF-System)


Tastsystemzyklen: Bezugspunkte automatisch erfassen

Beispiel: Bezugspunkt-Setzen Mitte Kreissegment und Werkstück-Oberkante

0 begin pgm cyc413 mm |
1 tool call 69 z | Werkzeug 0 aufrufen zur Festlegung der Tastsystem-Achse
2 tch probe 413 bzpkt kreis aussen |
Q321=+25 ;mitte 1. achse | Mittelpunkt des Kreises: X-Koordinate
Q322=+25 ;mitte 2. achse | Mittelpunkt des Kreises: Y-Koordinate
Q262=30 ;soll-durchmesser | Durchmesser des Kreises
Q325=+90 ;startwinkel | Polarkoordinaten-Winkel für 1. Antastpunkt
Q247=+45 ;winkelschritt | Winkelschritt zur Berechnung der Antastpunkte 2 bis 4
Q261=-5 ;messhoehe | Koordinate in der Tastsystem-Achse, auf der die Messung erfolgt
Q320=2 ;sicherheits-abst. | Sicherheits-Abstand zusätzlich zu MP6140
Q260=+10 ;sichere hoehe | Höhe, auf der das Tastsystem-Achse ohne Kollision verfahren kann
Q301=0 ;fahren auf s. hoehe | Zwischen den Messpunkten nicht auf sichere Höhe fahren
Q305=0 ;nr. in tabelle | Anzeige setzen
Q331=+0 ;bezugspunkt | Anzeige in X auf 0 setzen
Q332=+10 ;bezugspunkt | Anzeige in Y auf 10 setzen
Q303=+0 ;messwert-uebergabe | Ohne Funktion, da Anzeige gesetzt werden soll
Q381=1 ;antasten ts-achse | Auch Bezugspunkt in der TS-Achse setzen
Q382=+25 ;1. ko. fuer ts-achse | X-Koordinate Antastpunkt
Q383=+25 ;2. KO. fuer ts-achse | Y-Koordinate Antastpunkt
Q384=+25 ;3. KO. fuer ts-achse | Z-Koordinate Antastpunkt
Q333=+0 ;bezugspunkt | Anzeige in Z auf 0 setzen
Q423=4 ;ANZAHL MESSPUNKTE | Anzahl der Messpunkte
Q365=1 ;Verfahrart | Auf Kreisbogen oder linear zum nächsten Antastpunkt positionieren
3 call pgm 35k47 | Bearbeitungsprogramm aufrufen
4 end pgm cyc413 mm |


Tastsystemzyklen: Bezugspunkte automatisch erfassen

Beispiel: Bezugspunkt-Setzen Werkstück-Oberkante und Mitte Lochkreis

Der gemessene Lochkreis-Mittelpunkt soll zur späteren Verwendung in eine Preset-Tabelle geschrieben werden.

0 begin pgm cyc416 mm |
1 tool call 69 z | Werkzeug 0 aufrufen zur Festlegung der Tastsystem-Achse
2 tch probe 417 bzpkt ts.-achse | Zyklus-Definition zum Bezugspunkt-Setzen in der Tastsystem-Achse
Q263=+7,5 ;1. Punkt 1. achse | Antastpunkt: X-Koordinate
Q264=+7,5 ;1. punkt 2. achse | Antastpunkt: Y-Koordinate
Q294=+25 ;1. punkt 3. achse | Antastpunkt: Z-Koordinate
Q320=0 ;sicherheits-abst. | Sicherheits-Abstand zusätzlich zu MP6140
Q260=+50 ;sichere hoehe | Höhe, auf der das Tastsystem-Achse ohne Kollision verfahren kann
Q305=1 ;nr. in tabelle | Z-Koordinate in Zeile 1 schreiben
Q333=+0 ;bezugspunkt | Tastsystemachse 0 setzen
Q303=+1 ;messwert-uebergabe | Berechneten Bezugspunkt bezogen auf das maschinenfeste Koordinatensystem (REF-System) in der Preset-Tabelle PRESET.PR speichern
3 tch probe 416 bzpkt lochkreismitte |
Q273=+35 ;mitte 1. achse | Mittelpunkt des Lochkreises: X-Koordinate
Q274=+35 ;mitte 2. achse | Mittelpunkt des Lochkreises: Y-Koordinate
Q262=50 ;soll-durchmesser | Durchmesser des Lochkreises
Q291=+90 ;winkel 1. bohrung | Polarkoordinaten-Winkel für 1. Bohrungsmittelpunkt 1
Q292=+180 ;winkel 2. bohrung | Polarkoordinaten-Winkel für 2. Bohrungsmittelpunkt 2
Q293=+270 ;winkel 3. bohrung | Polarkoordinaten-Winkel für 3. Bohrungsmittelpunkt 3
Q261=+15 ;messhoehe | Koordinate in der Tastsystem-Achse, auf der die Messung erfolgt
Q260=+10 ;sichere hoehe | Höhe, auf der das Tastsystem-Achse ohne Kollision verfahren kann
Q305=1 ;nr. in tabelle | Lochkreis-Mitte (X und Y) in Zeile 1 schreiben
Q331=+0 ;bezugspunkt |
Q332=+0 ;bezugspunkt |
Q303=+1 ;messwert-uebergabe | Berechneten Bezugspunkt bezogen auf das maschinenfeste Koordinatensystem (REF-System) in der Preset-Tabelle PRESET.PR speichern
Q381=0 ;antasten ts-achse | Keinen Bezugspunkt in der TS-Achse setzen
Q382=+0 ;1. ko. fuer ts-Achse | Ohne Funktion
Q383=+0 ;2. ko. fuer ts-achse | Ohne Funktion
Q384=+0 ;3. ko. fuer ts-achse | Ohne Funktion
Q333=+0 ;bezugspunkt | Ohne Funktion
Q320=0 ;sicherheits-abst. | Sicherheits-Abstand zusätzlich zu MP6140
4 cycl def 247 bezugspunkt setzen | Neuen Preset mit Zyklus 247 aktivieren
Q339=1 ;bezugspunkt-nummer |
6 call pgm 35klz | Bearbeitungsprogramm aufrufen
7 end pgm cyc416 mm |


Tastsystemzyklen: Werkstücke automatisch kontrollieren

Weitere Informationen:
> Grundlagen
> BEZUGSEBENE (Zyklus 0, DIN/ISO: G55)
> BEZUGSEBENE Polar (Zyklus 1)
> MESSEN WINKEL (Zyklus 420, DIN/ISO: G420)
> MESSEN BOHRUNG (Zyklus 421, DIN/ISO: G421)
> MESSEN KREIS AUSSEN (Zyklus 422, DIN/ISO: G422)
> MESSEN RECHTECK INNEN (Zyklus 423, DIN/ISO: G423)
> MESSEN RECHTECK AUSSEN (Zyklus 424, DIN/ISO: G424)
> MESSEN BREITE INNEN (Zyklus 425, DIN/ISO: G425)
> MESSEN STEG AUSSEN (Zyklus 426, DIN/ISO: G426)
> MESSEN KOORDINATE (Zyklus 427, DIN/ISO: G427)
> MESSEN LOCHKREIS (Zyklus 430, DIN/ISO: G430)
> MESSEN EBENE (Zyklus 431, DIN/ISO: G431)
> Programmierbeispiele


Grundlagen

Weitere Informationen:
> Übersicht
> Messergebnisse protokollieren
> Messergebnisse in Q-Parametern
> Status der Messung
> Toleranz-Überwachung
> Werkzeug-Überwachung
> Bezugssystem für Messergebnisse


Übersicht

Die TNC stellt zwölf Zyklen zur Verfügung, mit denen Sie Werkstücke automatisch vermessen können:

Zyklus | Softkey | Seite
0 BEZUGSEBENE Messen einer Koordinate in einer wählbaren Achse |  | BEZUGSEBENE (Zyklus 0, DIN/ISO: G55)
1 BEZUGSEBENE POLAR Messen eines Punktes, Antastrichtung über Winkel |  | BEZUGSEBENE Polar (Zyklus 1)
420 MESSEN WINKEL Winkel in der Bearbeitungsebene messen |  | MESSEN WINKEL (Zyklus 420, DIN/ISO: G420)
421 MESSEN BOHRUNG Lage und Durchmesser einer Bohrung messen |  | MESSEN BOHRUNG (Zyklus 421, DIN/ISO: G421)
422 MESSEN KREIS AUSSEN Lage und Durchmesser eines kreisförmigen Zapfens messen |  | MESSEN KREIS AUSSEN (Zyklus 422, DIN/ISO: G422)
423 MESSEN RECHTECK INNEN Lage, Länge und Breite einer Rechteck-Tasche messen |  | MESSEN RECHTECK INNEN (Zyklus 423, DIN/ISO: G423)
424 MESSEN RECHTECK AUSSEN Lage, Länge und Breite eines Rechteck-Zapfens messen |  | MESSEN RECHTECK AUSSEN (Zyklus 424, DIN/ISO: G424)
425 MESSEN BREITE INNEN (2. Softkey-Ebene) Nutbreite innen messen |  | MESSEN BREITE INNEN (Zyklus 425, DIN/ISO: G425)
426 MESSEN STEG AUSSEN (2. Softkey-Ebene) Steg außen messen |  | MESSEN STEG AUSSEN (Zyklus 426, DIN/ISO: G426)
427 MESSEN KOORDINATE (2. Softkey-Ebene) Beliebige Koordinate in wählbarer Achse messen |  | MESSEN KOORDINATE (Zyklus 427, DIN/ISO: G427)
430 MESSEN LOCHKREIS (2. Softkey-Ebene) Lochkreis-Lage und -Durchmesser messen |  | MESSEN LOCHKREIS (Zyklus 430, DIN/ISO: G430)
431 MESSEN EBENE (2. Softkey-Ebene) A- und B-Achsenwinkel einer Ebene messen |  | MESSEN EBENE (Zyklus 431, DIN/ISO: G431)


Messergebnisse protokollieren

Zu allen Zyklen, mit denen Sie Werkstücke automatisch vermessen können (Ausnahmen: Zyklus 0 und 1), können Sie von der TNC ein Messprotokoll erstellen lassen. Im jeweiligen Antastzyklus können Sie definieren, ob die TNC

  • das Messprotokoll in einer Datei speichern soll
  • das Messprotokoll auf den Bildschirm ausgeben und den Programmlauf unterbrechen soll
  • kein Messprotokoll erzeugen soll

Sofern Sie das Messprotokoll in einer Datei ablegen wollen, speichert die TNC die Daten standardmäßig als ASCII-Datei in dem Verzeichnis, aus dem Sie das Messprogramm abarbeiten. Alternativ können Sie das Messprotokoll auch über die Datenschnittstelle direkt auf einen Drucker ausgeben bzw. auf einem PC speichern. Setzen Sie dazu die Funktion Print (im Schnittstellen-Konfigurationsmenü) auf RS232:\ (siehe auch Benutzer-Handbuch, MOD-Funktionen, Datenschnittstelle einrichten").

Alle Messwerte, die in der Protokolldatei aufgeführt sind, beziehen sich auf den Nullpunkt, der zum Zeitpunkt der jeweiligen Zyklus-Ausführung aktiv ist. Zusätzlich kann das Koordinatensystem noch in der Ebene gedreht oder mit 3D-ROT geschwenkt sein. In diesen Fällen rechnet die TNC die Messergebnisse ins jeweils aktive Koordinatensy-stem um.

Benutzen Sie die HEIDENHAIN Datenübertragungs-Soft-ware TNCremo, wenn Sie das Messprotokoll über die Datenschnittstelle ausgeben wollen.

Beispiel: Protokolldatei für Antastzyklus 421:

Messprotokoll Antastzyklus 421 Bohrung messen

Datum: 30-06-2005
Uhrzeit: 6:55:04
Messprogramm: TNC:\GEH35712\CHECK1.H

Sollwerte:
Mitte Hauptachse : 50.0000
Mitte Nebenachse : 65.0000
Durchmesser : 12.0000

Vorgegebene Grenzwerte:
Größtmaß Mitte Hauptachse: 50.1000
Kleinstmaß Mitte Hauptachse: 49.9000
Größtmaß Mitte Nebenachse: 65.1000
Kleinstmaß Mitte Nebenachse: 64.9000
Größtmaß Bohrung : 12.0450
Kleinstmaß Bohrung: 12.0000

Istwerte: Mitte
Hauptachse : 50.0810
Mitte Nebenachse : 64.9530
Durchmesser : 12.0259

Abweichungen:
Mitte Hauptachse : 0.0810
Mitte Nebenachse : -0.0470
Durchmesser : 0.0259

Weitere Messergebnisse: Messhöhe : -5.0000

Messprotokoll-Ende


Messergebnisse in Q-Parametern

Die Messergebnisse des jeweiligen Antast-Zyklus legt die TNC in den global wirksamen Q-Parametern Q150 bis Q160 ab. Abweichungen vom Sollwert sind in den Parametern Q161 bis Q166 gespeichert. Beachten Sie die Tabelle der Ergebnis-Parameter, die bei jeder Zyklus-Beschreibung mit aufgeführt ist.

Zusätzlich zeigt die TNC bei der Zyklus-Definition im Hilfsbild des jeweiligen Zyklus die Ergebnis-Parameter mit an (siehe Bild rechts oben). Dabei gehört der hell hinterlegte Ergebnisparameter zum jeweiligen Eingabeparameter.


Status der Messung

Bei einigen Zyklen können Sie über die global wirksamen Q-Parametern Q180 bis Q182 den Status der Messung abfragen:

Mess-Status | Parameter-Wert
Messwerte liegen innerhalb der Toleranz | Q180 = 1
Nacharbeit erforderlich | Q181 = 1
Ausschuss | Q182 = 1

Die TNC setzt den Nacharbeits- bzw. Ausschuss-Merker, sobald einer der Messwerte außerhalb der Toleranz liegt. Um festzustellen welches Messergebnis außerhalb der Toleranz liegt, beachten Sie zusätzlich das Messprotokoll, oder prüfen Sie die jeweiligen Messergebnisse (Q150 bis Q160) auf ihre Grenzwerte.

Beim Zyklus 427 geht die TNC standardmäßig davon aus, dass Sie ein Aussenmaß (Zapfen) vermessen. Durch entsprechende Wahl von Größt- und Kleinstmaß in Verbindung mit der Antastrichtung können Sie den Status der Messung jedoch richtigstellen.

Die TNC setzt die Status-Merker auch dann, wenn Sie keine Toleranzwerte oder Größt-/ bzw. Kleinstmaße eingegeben haben.


Toleranz-Überwachung

Bei den meisten Zyklen zur Werkstück-Kontrolle können Sie von der TNC eine Toleranz-Überwachung durchführen lassen. Dazu müssen Sie bei der Zyklus-Definition die erforderlichen Grenzwerte definieren. Wenn Sie keine Toleranzüberwachung durchführen wollen, geben Sie diese Parameter mit 0 ein (= voreingestellter Wert)


Werkzeug-Überwachung

Bei einigen Zyklen zur Werkstück-Kontrolle können Sie von der TNC eine Werkzeug-Überwachung durchführen lassen. Die TNC übewacht dann, ob

  • aufgrund der Abweichungen vom Sollwert (Werte in Q16x) der Werkzeug-Radius korrigiert werden soll
  • die Abweichungen vom Sollwert (Werte in Q16x) größer als die Bruch-Toleranz des Werkzeugs ist
Weitere Informationen:
> Werkzeug korrigieren
> Werkzeug-Bruchüberwachung


Werkzeug korrigieren

Funktion arbeitet nur

  • bei aktiver Werkzeug-Tabelle
  • wenn Sie die Werkzeug-Überwachung im Zyklus ein-schalten: Q330 ungleich 0 oder einen Werkzeug-Namen eingeben. Die Eingabe des Werkzeug-Namens wählen Sie per Softkey, die TNC zeigt das rechte Hochkomma nicht mehr an.

Wenn Sie mehrere Korrekturmessungen durchführen, dann addiert die TNC die jeweils gemessene Abweichung auf den in der Werkzeug-Tabelle bereits gespeicherten Wert.

Die TNC korrigiert den Werkzeug-Radius in der Spalte DR der Werkzeug-Tabelle grundsätzlich immer, auch wenn die gemessene Abweichung innerhalbhalb der vorgegebenen Toleranz liegt. Ob Sie nacharbeiten müssen, können Sie in Ihrem NC-Programm über den Parameter Q181 abfragen (Q181=1: Nacharbeit erforderlich).

Für den Zyklus 427 gilt darüber hinaus:

  • Wenn als Messachse eine Achse der aktiven Bearbeitungsebene definiert ist (Q272 = 1 oder 2), führt die TNC eine Werkzeug-Radiuskorrektur durch, wie zuvor beschrieben. Die Korrektur-Richtung ermittelt die TNC anhand der definierten Verfahrrichtung (Q267)
  • Wenn als Messachse die Tastsystem-Achse gewählt ist (Q272 = 3), führt die TNC eine Werkzeug-Längenkorrektur durch


Werkzeug-Bruchüberwachung

Funktion arbeitet nur

  • bei aktiver Werkzeug-Tabelle
  • wenn Sie die Werkzeug-Überwachung im Zyklus ein-schalten (Q330 ungleich 0 eingeben)
  • wenn für die eingegebene Werkzeug-Nummer in derTabelle die Bruch-Toleranz RBREAK größer 0 eingegeben ist (siehe auch Benutzer-Handbuch, Kapitel 5.2 „Werkzeug-Daten“)

Die TNC gibt eine Fehlermeldung aus und stoppt den Programmlauf, wenn die gemessene Abweichung größer als die Bruch-Toleranz des Werkzeugs ist. Gleichzeitig sperrt sie das Werkzeug in der Werkzeug-Tabelle (Spalte TL = L).


Bezugssystem für Messergebnisse

Die TNC gibt alle Messergebnisse in die Ergebnis-Parameter und in die Protokolldatei im aktiven - also ggf. im verschobenen oder/und gedrehten/geschwenkten - Koordinatensystem aus.


BEZUGSEBENE (Zyklus 0, DIN/ISO: G55)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Das Tastsystem fährt in einer 3D-Bewegung mit Eilvorschub (Wert aus MP6150) die im Zyklus programmierte Vorposition 1 an
  2. Anschließend führt das Tastsystem den Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Die Antast-Richtung ist im Zyklus festzulegen
  3. Nachdem die TNC die Position erfasst hat, fährt das Tastsystem zurück auf den Startpunkt des Antast-Vorgangs und speichert die gemessene Koordinate in einem Q-Parameter ab. Zusätzlich speichert die TNC die Koordinaten der Position, an der sich das Tastsystem zum Zeitpunkt des Schaltsignals befindet, in den Parametern Q115 bis Q119 ab. Für die Werte in diesen Parametern berücksichtigt die TNC Taststiftlänge und -radius nicht


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Tastsystem so vorpositionieren, dass eine Kollision beim Anfahren der programmierten Vorposition vermieden wird.


Zyklusparameter

Beispiel: NC-Sätze
67 tch probe 0.0 bezugsebene q5 x-
68 tch probe 0.1 x+5 y+0 z-5

Parameter-Nr. für Ergebnis: Nummer des Q-Parameters eingeben, dem der Wert der Koordinate zugewiesen wird. Eingabebereich 0 bis 1999

Antast-Achse/Antast-Richtung: Antast-Achse mit Achswahl-Taste oder über die ASCII-Tastatur und Vorzeichen für Antastrichtung eingeben. Mit Taste ENT bestätigen. Eingabebereich alle NC-Achsen

Positions-Sollwert: Über die Achswahl-Tasten oder über die ASCII-Tastatur alle Koordinaten für das Vorpositionieren des Tastsystems eingeben. Eingabebereich -99999,9999 bis 99999,9999

Eingabe abschließen: Taste ENT drücken


BEZUGSEBENE Polar (Zyklus 1)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

  1. Der Tastsystem-Zyklus 1 ermittelt in einer beliebigen Antast-Richtung eine beliebige Position am Werkstück.
  2. Das Tastsystem fährt in einer 3D-Bewegung mit Eilvorschub (Wert aus MP6150) die im Zyklus programmierte Vorposition 1 an
  3. Anschließend führt das Tastsystem den Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Beim Antastvorgang verfährt die TNC gleichzeitig in 2 Achsen (abhängig vom Antast-Winkel) Die Antast-Richtung ist über Polarwinkel im Zyklus festzulegen
  4. Nachdem die TNC die Position erfasst hat, fährt das Tastsystem zurück auf den Startpunkt des Antast-Vorgangs. Die Koordinaten der Position, an der sich das Tastsystem zum Zeitpunkt des Schaltsignals befindet, speichert die TNC in den Parametern Q115 bis Q119.


Beim Programmieren beachten!

Achtung Kollisionsgefahr!

Tastsystem so vorpositionieren, dass eine Kollision beim Anfahren der programmierten Vorposition vermieden wird.

    Die im Zyklus definierte Antast-Achse legt die Tastebene fest:

  • Antast-Achse X: X/Y-Ebene
  • Antast-Achse Y: Y/Z-Ebene
  • Antast-Achse Z: Z/X-Ebene


Zyklusparameter

Beispiel: NC-Sätze
67 tch probe 1.0 bezugsebene polar
68 tch probe 1.1 x winkel: +30
69 tch probe 1.2 x+5 y+0 z-5

Antast-Achse: Antast-Achse mit Achswahl-Taste oder über die ASCII-Tastatur eingeben. Mit Taste ENT bestätigen. Eingabebereich X, Y oder Z

Antast-Winkel: Winkel bezogen auf die Antast-Achse, in der das Tastsystem verfahren soll. Eingabebereich -180,0000 bis 180,0000

Positions-Sollwert: Über die Achswahl-Tasten oder über die ASCII-Tastatur alle Koordinaten für das Vorpositionieren des Tastsystems eingeben. Eingabebereich -99999,9999 bis 99999,9999

Eingabe abschließen: Taste ENT drücken


MESSEN WINKEL (Zyklus 420, DIN/ISO: G420)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 420 ermittelt den Winkel, den eine beliebige Gerade mit der Hauptachse der Bearbeitungsebene einschließt.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum programmierten Antastpunkt 1. Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand entgegen der festgelegten Verfahrrichtung
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Danach fährt das Tastsystem zum nächsten Antastpunkt 2 und führt den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zurück auf die Sichere Höhe und speichert den ermittelten Winkel in folgendem Q-Parameter:
Parameter-Nummer | Bedeutung
Q150 | Gemessener Winkel bezogen auf die Hauptachse der Bearbeitungsebene


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Wenn Tastsystemachse = Messachse definiert ist, dann Q263 gleich Q265 wählen, wenn Winkel in Richtung der A-Achse gemessen werden soll; Q263 ungleich Q265 wäh-len, wenn Winkel in Richtung der B-Achse gemessen wer-den soll.


Zyklusparameter

1. Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 1. Achse Q265 (absolut): Koordinate des zweiten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 2. Achse Q266 (absolut): Koordinate des zweiten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Messachse Q272: Achse, in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse 3: Tastsystem-Achse = Messachse

Beispiel: NC-Sätze
5 tch probe 420 messen winkel
Q263=+10 ;1. punkt 1. achse
Q264=+10 ;1. punkt 2. achse
Q265=+15 ;2. punkt 1. achse
Q266=+95 ;2. punkt 2. achse
Q272=1 ;messachse
Q267=-1 ;verfahrrichtung
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+10 ;sichere hoehe
Q301=1 ;fahren auf s. hoehe
Q281=1 ;messprotokoll

Verfahrrichtung 1 Q267: Richtung, in der das Tastsystem auf das Werkstück zufahren soll: -1: Verfahrrichtung negativ +1: Verfahrrichtung positiv

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR420.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen


MESSEN BOHRUNG (Zyklus 421, DIN/ISO: G421)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 421 ermittelt den Mittelpunkt und den Durchmesser einer Bohrung (Kreistasche). Wenn Sie die entsprechenden Toleranzwerte im Zyklus definieren, führt die TNC einen Soll-Istwertvergleich durch und legt die Abweichungen in Systemparametern ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Die TNC bestimmt die Antast-Richtung automatisch in Abhängigkeit vom programmierten Startwinkel
  3. Danach fährt das Tastsystem zirkular, entweder auf Messhöhe oder auf Sicherer Höhe, zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die Istwerte und die Abweichungen in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q153 | Istwert Durchmesser
Q161 | Abweichung Mitte Hauptachse
Q162 | Abweichung Mitte Nebenachse
Q163 | Abweichung Durchmesser


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Je kleiner Sie den Winkelschritt programmieren, desto ungenauer berechnet die TNC die Bohrungsmaße. Klein-ster Eingabwert: 5°.


Zyklusparameter

Mitte 1. Achse Q273 (absolut): Mitte der Bohrung in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q274 (absolut): Mitte der Bohrung in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Soll-Durchmesser Q262: Durchmesser der Bohrung eingeben. Eingabebereich 0 bis 99999,9999

Startwinkel Q325 (absolut): Winkel zwischen der Hauptachse der Bearbeitungsebene und dem ersten Antastpunkt. Eingabebereich -360,0000 bis 360,0000

Winkelschritt Q247 (inkremental): Winkel zwischen zwei Messpunkten, das Vorzeichen des Winkelschritts legt die Bearbeitungsrichtung fest (- = Uhrzeigersinn). Wenn Sie Kreisbögen vermessen wollen, dann programmieren Sie einen Winkelschritt kleiner 90°. Eingabebereich -120,0000 bis 120,0000

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Größtmaß Bohrung Q275: Größter erlaubter Durchmesser der Bohrung (Kreistasche). Eingabebereich 0 bis 99999,9999

Kleinstmaß Bohrung Q276: Kleinster erlaubter Durchmesser der Bohrung (Kreistasche). Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 1. Achse Q279: Erlaubte Lageabweichung in der Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 2. Achse Q280: Erlaubte Lageabweichung in der Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
5 tch probe 421 messen bohrung
Q273=+50 ;mitte 1. achse
Q274=+50 ;mitte 2. achse
Q262=75 ;soll-durchmesser
Q325=+0 ;startwinkel
Q247=+60 ;winkelschritt
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=1 ;fahren auf s. hoehe
Q275=75,12 ;groesstmass
Q276=74,95 ;kleinstmass
Q279=0,1 ;toleranz 1. mitte
Q280=0,1 ;toleranz 2. mitte
Q281=1 ;messprotokoll
Q309=0 ;pgm-stop bei fehler
Q330=0 ;werkzeug
Q423=4 ;ANZAHL MESSPUNKTE
Q365=1 ;Verfahrart

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR421.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen

PGM-Stop bei Toleranzfehler Q309: Festlegen, ob die TNC bei Toleranz-Überschreitungen den Programmlauf unterbrechen und eine Fehlermeldung ausgeben soll: 0: Programmlauf nicht unterbrechen, keine Fehlermeldung ausgeben 1: Programmlauf unterbrechen, Fehlermeldung ausgeben

Werkzeug für Überwachung Q330: Festlegen, ob die TNC eine Werkzeug-Überwachung durchführen soll (siehe Werkzeug-Überwachung). Eingabebereich 0 bis 32767,9, alternativ Werkzeug-Name mit maximal 16 Zeichen 0: Überwachung nicht aktiv >0: Werkzeug-Nummer in der Werkzeug-Tabelle TOOL.T

Anzahl Messpunkte (4/3) Q423: Festlegen, ob die TNC den Zapfen mit 4 oder 3 Antastungen messen soll: 4: 4 Messpunkte verwenden (Standardeinstellung) 3: 3 Messpunkte verwenden

Verfahrart? Gerade=0/Kreis=1 Q365: Festlegen, mit welcher Bahnfunktion das Werkzeug zwischen den Messpunkten verfahren soll, wenn Fahren auf sicherer Höhe (Q301=1) aktiv ist:
0: Zwischen den Bearbeitungen auf einer Geraden verfahren
1: Zwischen den Bearbeitungen zirkular auf dem Teilkreis-Durchmesser verfahren


MESSEN KREIS AUSSEN (Zyklus 422, DIN/ISO: G422)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 422 ermittelt den Mittelpunkt und den Durchmesser eines Kreiszapfens. Wenn Sie die entsprechenden Toleranzwerte im Zyklus definieren, führt die TNC einen Soll-Istwertvergleich durch und legt die Abweichungen in Systemparametern ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. Die TNC bestimmt die Antast-Richtung automatisch in Abhängigkeit vom programmierten Startwinkel
  3. Danach fährt das Tastsystem zirkular, entweder auf Messhöhe oder auf Sicherer Höhe, zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die Istwerte und die Abweichungen in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q153 | Istwert Durchmesser
Q161 | Abweichung Mitte Hauptachse
Q162 | Abweichung Mitte Nebenachse
Q163 | Abweichung Durchmesser


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Je kleiner Sie den Winkelschritt programmieren, desto ungenauer berechnet die TNC die Zapfenmaße. Kleinster Eingabwert: 5°.


Zyklusparameter

Mitte 1. Achse Q273 (absolut): Mitte des Zapfens in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q274 (absolut): Mitte des Zapfens in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Soll-Durchmesser Q262: Durchmesser des Zapfens eingeben. Eingabebereich 0 bis 99999,9999

Startwinkel Q325 (absolut): Winkel zwischen der Hauptachse der Bearbeitungsebene und dem ersten Antastpunkt. Eingabebereich -360,0000 bis 360,0000

Winkelschritt Q247 (inkremental): Winkel zwischen zwei Messpunkten, das Vorzeichen des Winkelschritts legt die Bearbeitungsrichtung fest (- = Uhrzeigersinn). Wenn Sie Kreisbögen vermessen wollen, dann programmieren Sie einen Winkelschritt kleiner 90°. Eingabebereich -120,0000 bis 120,0000

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Größtmaß Zapfen Q277: Größter erlaubter Durchmesser des Zapfens. Eingabebereich 0 bis 99999,9999

Kleinstmaß Zapfen Q278: Kleinster erlaubter Durchmesser des Zapfens. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 1. Achse Q279: Erlaubte Lageabweichung in der Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 2. Achse Q280: Erlaubte Lageabweichung in der Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
5 tch probe 422 messen kreis aussen
Q273=+50 ;mitte 1. achse
Q274=+50 ;mitte 2. achse
Q262=75 ;soll-durchmesser
Q325=+90 ;startwinkel
Q247=+30 ;winkelschritt
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+10 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q277=35,15 ;groesstmass
Q278=34,9 ;kleinstmass
Q279=0,05 ;toleranz 1. mitte
Q280=0,05 ;toleranz 2. mitte
Q281=1 ;messprotokoll
Q309=0 ;pgm-stop bei fehler
Q330=0 ;werkzeug
Q423=4 ;ANZAHL MESSPUNKTE
Q365=1 ;Verfahrart

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR422.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen

PGM-Stop bei Toleranzfehler Q309: Festlegen, ob die TNC bei Toleranz-Überschreitungen den Programmlauf unterbrechen und eine Fehlermeldung ausgeben soll: 0: Programmlauf nicht unterbrechen, keine Fehlermeldung ausgeben 1: Programmlauf unterbrechen, Fehlermeldung ausgeben

Werkzeug für Überwachung Q330: Festlegen, ob die TNC eine Werkzeug-Überwachung durchführen soll (siehe Werkzeug-Überwachung). Eingabebereich 0 bis 32767,9, alternativ Werkzeug-Name mit maximal 16 Zeichen 0: Überwachung nicht aktiv >0: Werkzeug-Nummer in der Werkzeug-Tabelle TOOL.T

Anzahl Messpunkte (4/3) Q423: Festlegen, ob die TNC den Zapfen mit 4 oder 3 Antastungen messen soll: 4: 4 Messpunkte verwenden (Standardeinstellung) 3: 3 Messpunkte verwenden

Verfahrart? Gerade=0/Kreis=1 Q365: Festlegen, mit welcher Bahnfunktion das Werkzeug zwischen den Messpunkten verfahren soll, wenn Fahren auf sicherer Höhe (Q301=1) aktiv ist:
0: Zwischen den Bearbeitungen auf einer Geraden verfahren
1: Zwischen den Bearbeitungen zirkular auf dem Teilkreis-Durchmesser verfahren


MESSEN RECHTECK INNEN (Zyklus 423, DIN/ISO: G423)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 423 ermittelt den Mittelpunkt sowie Länge und Breite einer Rechtecktasche. Wenn Sie die entsprechenden Toleranzwerte im Zyklus definieren, führt die TNC einen Soll-Istwertvergleich durch und legt die Abweichungen in Systemparametern ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Danach fährt das Tastsystem entweder achsparallel auf Messhöhe oder linear auf Sicherer Höhe zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die Istwerte und die Abweichungen in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q154 | Istwert Seiten-Länge Hauptachse
Q155 | Istwert Seiten-Länge Nebenachse
Q161 | Abweichung Mitte Hauptachse
Q162 | Abweichung Mitte Nebenachse
Q164 | Abweichung Seiten-Länge Hauptachse
Q165 | Abweichung Seiten-Länge Nebenachse


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Wenn die Taschenmaße und der Sicherheits-Abstand eine Vorpositionierung in die Nähe der Antastpunkte nicht erlauben, tastet die TNC immer ausgehend von der Taschenmitte an. Zwischen den vier Messpunkten fährt das Tastsystem dann nicht auf die Sichere Höhe.


Zyklusparameter

Mitte 1. Achse Q273 (absolut): Mitte der Tasche in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q274 (absolut): Mitte der Tasche in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Seiten-Länge Q282: Länge der Tasche, parallel zur Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

2. Seiten-Länge Q283: Länge der Tasche, parallel zur Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Größtmaß 1. Seiten-Länge Q284: Größte erlaubte Länge der Tasche. Eingabebereich 0 bis 99999,9999

Kleinstmaß 1. Seiten-Länge Q285: Kleinste erlaubte Länge der Tasche. Eingabebereich 0 bis 99999,9999

Größtmaß 2. Seiten-Länge Q286: Größte erlaubte Breite der Tasche. Eingabebereich 0 bis 99999,9999

Kleinstmaß 2. Seiten-Länge Q287: Kleinste erlaubte Breite der Tasche. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 1. Achse Q279: Erlaubte Lageabweichung in der Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 2. Achse Q280: Erlaubte Lageabweichung in der Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
5 tch probe 423 messen rechteck inn.
Q273=+50 ;mitte 1. achse
Q274=+50 ;mitte 2. achse
Q282=80 ;1. seiten-laenge
Q283=60 ;2. seiten-laenge
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+10 ;sichere hoehe
Q301=1 ;fahren auf s. hoehe
Q284=0 ;groesstmass 1. seite
Q285=0 ;kleinstmass 1. seite
Q286=0 ;groesstmass 2. seite
Q287=0 ;kleinstmass 2. seite
Q279=0 ;toleranz 1. mitte
Q280=0 ;toleranz 2. mitte
Q281=1 ;messprotokoll
Q309=0 ;pgm-stop bei fehler
Q330=0 ;werkzeug

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR423.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen

PGM-Stop bei Toleranzfehler Q309: Festlegen, ob die TNC bei Toleranz-Überschreitungen den Programmlauf unterbrechen und eine Fehlermeldung ausgeben soll: 0: Programmlauf nicht unterbrechen, keine Fehlermeldung ausgeben 1: Programmlauf unterbrechen, Fehlermeldung ausgeben

Werkzeug für Überwachung Q330: Festlegen, ob die TNC eine Werkzeug-Überwachung durchführen soll (siehe Werkzeug-Überwachung). Eingabebereich 0 bis 32767,9, alternativ Werkzeug-Name mit maximal 16 Zeichen 0: Überwachung nicht aktiv >0: Werkzeug-Nummer in der Werkzeug-Tabelle TOOL.T


MESSEN RECHTECK AUSSEN (Zyklus 424, DIN/ISO: G424)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 424 ermittelt den Mittelpunkt sowie Länge und Breite eines Rechteckzapfens. Wenn Sie die entsprechenden Toleranzwerte im Zyklus definieren, führt die TNC einen Soll-Istwertvergleich durch und legt die Abweichungen in Systemparametern ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch
  3. Danach fährt das Tastsystem entweder achsparallel auf Messhöhe oder linear auf Sicherer Höhe zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch
  4. Die TNC positioniert das Tastsystem zum Antastpunkt 3 und danach zum Antastpunkt 4 und führt dort den dritten bzw. vierten Antast-Vorgang durch
  5. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die Istwerte und die Abweichungen in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q154 | Istwert Seiten-Länge Hauptachse
Q155 | Istwert Seiten-Länge Nebenachse
Q161 | Abweichung Mitte Hauptachse
Q162 | Abweichung Mitte Nebenachse
Q164 | Abweichung Seiten-Länge Hauptachse
Q165 | Abweichung Seiten-Länge Nebenachse


Zyklusparameter

Mitte 1. Achse Q273 (absolut): Mitte des Zapfens in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q274 (absolut): Mitte des Zapfens in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Seiten-Länge Q282: Länge des Zapfens, parallel zur Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

2. Seiten-Länge Q283: Länge des Zapfens, parallel zur Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Größtmaß 1. Seiten-Länge Q284: Größte erlaubte Länge des Zapfens. Eingabebereich 0 bis 99999,9999

Kleinstmaß 1. Seiten-Länge Q285: Kleinste erlaubte Länge des Zapfens. Eingabebereich 0 bis 99999,9999

Größtmaß 2. Seiten-Länge Q286: Größte erlaubte Breite des Zapfens. Eingabebereich 0 bis 99999,9999

Kleinstmaß 2. Seiten-Länge Q287: Kleinste erlaubte Breite des Zapfens. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 1. Achse Q279: Erlaubte Lageabweichung in der Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 2. Achse Q280: Erlaubte Lageabweichung in der Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
5 tch probe 424 messen rechteck aus.
Q273=+50 ;mitte 1. achse
Q274=+50 ;mitte 2. achse
Q282=75 ;1. seiten-laenge
Q283=35 ;2. seiten-laenge
Q261=-5 ;messhoehe
Q320=0 ;sicherheits-abst.
Q260=+20 ;sichere hoehe
Q301=0 ;fahren auf s. hoehe
Q284=75,1 ;groesstmass 1. seite
Q285=74,9 ;kleinstmass 1. seite
Q286=35 ;groesstmass 2. seite
Q287=34,95 ;kleinstmass 2. seite
Q279=0,1 ;toleranz 1. mitte
Q280=0,1 ;toleranz 2. mitte
Q281=1 ;messprotokoll
Q309=0 ;pgm-stop bei fehler
Q330=0 ;werkzeug

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR424.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen

PGM-Stop bei Toleranzfehler Q309: Festlegen, ob die TNC bei Toleranz-Überschreitungen den Programmlauf unterbrechen und eine Fehlermeldung ausgeben soll: 0: Programmlauf nicht unterbrechen, keine Fehlermeldung ausgeben 1: Programmlauf unterbrechen, Fehlermeldung ausgeben

Werkzeug für Überwachung Q330: Festlegen, ob die TNC eine Werkzeug-Überwachung durchführen soll (siehe Werkzeug-Überwachung). Eingabebereich 0 bis 32767,9, alternativ Werkzeug-Name mit maximal 16 Zeichen: 0: Überwachung nicht aktiv >0: Werkzeug-Nummer in der Werkzeug-Tabelle TOOL.T


MESSEN BREITE INNEN (Zyklus 425, DIN/ISO: G425)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 425 ermittelt die Lage und die Breite einer Nut (Tasche). Wenn Sie die entsprechenden Toleranzwerte im Zyklus definieren, führt die TNC einen Soll-Istwertvergleich durch und legt die Abweichung in einem Systemparameter ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. 1. Antastung immer in positive Richtung der programmierten Achse
  3. Wenn Sie für die zweite Messung einen Versatz eingeben, dann fährt die TNC das Tastsystem (ggf. auf sicherer Höhe) zum nächsten Antastpunkt 2 und führt dort den zweiten Antast-Vorgang durch. Bei großen Solllängen positioniert die TNC zum zweiten Antastpunkt mit Eilvorschub. Wenn Sie keinen Versatz eingeben, misst die TNC die Breite direkt in der entgegengesetzten Richtung
  4. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die Istwerte und die Abweichung in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q156 | Istwert gemessene Länge
Q157 | Istwert Lage Mittelachse
Q166 | Abweichung der gemessenen Länge


Zyklusparameter

Startpunkt 1. Achse Q328 (absolut): Startpunkt des Antastvorgangs in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Startpunkt 2. Achse Q329 (absolut): Startpunkt des Antastvorgangs in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Versatz für 2. Messung Q310 (inkremental): Wert, um den das Tastsystem vor der zweiten Messung versetzt wird. Wenn Sie 0 eingeben, versetzt die TNC das Tastsystem nicht. Eingabebereich -99999,9999 bis 99999,9999

Messachse Q272: Achse der Bearbeitungsebene, in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Soll-Länge Q311: Sollwert der zu messenden Länge. Eingabebereich 0 bis 99999,9999

Größtmaß Q288: Größte erlaubte Länge. Eingabebereich 0 bis 99999,9999

Kleinstmaß Q289: Kleinste erlaubte Länge. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
5 TCH prone 425 messen breite innen
Q328=+75 ;STARTPUNKT 1. ACHSE
Q329=-12.5 ;STARTPUNKT 2. ACHSE
Q310=+0 ;VERSATZ 2. MESSUNG
Q272=1 ;MESSACHSE
Q261=-5 ;MESSHOEHE
Q260=+10 ;SICHERE HOEHE
Q311=25 ;SOLL-LAENGE
Q288=25.05 ;GROESSTMASS
Q289=25 ;KLEINSTMASS
Q281=1 ;MESSPROTOKOLL
Q309=0 ;PGM-STOP BEI FEHLER
Q330=0 ;WERKZEUG
Q320=0 ;sicherheits-abst.
Q301=0 ;fahren auf s. hoehe

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR425.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen

PGM-Stop bei Toleranzfehler Q309: Festlegen, ob die TNC bei Toleranz-Überschreitungen den Programmlauf unterbrechen und eine Fehlermeldung ausgeben soll: 0: Programmlauf nicht unterbrechen, keine Fehlermeldung ausgeben 1: Programmlauf unterbrechen, Fehlermeldung ausgeben

Werkzeug für Überwachung Q330: Festlegen, ob die TNC eine Werkzeug-Überwachung durchführen soll (siehe Werkzeug-Überwachung):. Eingabebereich 0 bis 32767,9, alternativ Werkzeug-Name mit maximal 16 Zeichen 0: Überwachung nicht aktiv >0: Werkzeug-Nummer in der Werkzeug-Tabelle TOOL.T

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef


MESSEN STEG AUSSEN (Zyklus 426, DIN/ISO: G426)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 426 ermittelt die Lage und die Breite eines Steges. Wenn Sie die entsprechenden Toleranzwerte im Zyklus definieren, führt die TNC einen Soll-Istwertvergleich durch und legt die Abweichung in Systemparametern ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC berechnet die Antastpunkte aus den Angaben im Zyklus und dem Sicherheits-Abstand aus MP6140
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und führt den ersten Antast-Vorgang mit Antast-Vorschub (MP6120) durch. 1. Antastung immer in negative Richtung der programmierten Achse
  3. Danach fährt das Tastsystem auf sicherer Höhe zum nächsten Antastpunkt und führt dort den zweiten Antast-Vorgang durch
  4. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die Istwerte und die Abweichung in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q156 | Istwert gemessene Länge
Q157 | Istwert Lage Mittelachse
Q166 | Abweichung der gemessenen Länge


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Darauf achten, dass die erste Messung immer in negative Richtung der gewählten Messachse erfolgt. Q263 und Q264 entsprechend definieren.


Zyklusparameter

1 Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1 Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2 Messpunkt 1. Achse Q265 (absolut): Koordinate des zweiten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2 Messpunkt 2. Achse Q266 (absolut): Koordinate des zweiten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Messachse Q272: Achse der Bearbeitungsebene, in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Soll-Länge Q311: Sollwert der zu messenden Länge. Eingabebereich 0 bis 99999,9999

Größtmaß Q288: Größte erlaubte Länge. Eingabebereich 0 bis 99999,9999

Kleinstmaß Q289: Kleinste erlaubte Länge. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
5 TCH PROBE 426 MESSEN STEG AUSSEN
Q263=+50 ;1. PUNKT 1. ACHSE
Q264=+25 ;1. PUNKT 2. ACHSE
Q265=+50 ;2. PUNKT 1. ACHSE
Q266=+85 ;2. PUNKT 2. ACHSE
Q272=2 ;MESSACHSE
Q261=-5 ;MESSHOEHE
Q320=0 ;SICHERHEITS-ABST.
Q260=+20 ;SICHERE HOEHE
Q311=45 ;SOLL-LAENGE
Q288=45 ;GROESSTMASS
Q289=44.95 ;KLEINSTMASS
Q281=1 ;MESSPROTOKOLL
Q309=0 ;PGM-STOP BEI FEHLER
Q330=0 ;WERKZEUG

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR426.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen

PGM-Stop bei Toleranzfehler Q309: Festlegen, ob die TNC bei Toleranz-Überschreitungen den Programmlauf unterbrechen und eine Fehlermeldung ausgeben soll: 0: Programmlauf nicht unterbrechen, keine Fehlermeldung ausgeben 1: Programmlauf unterbrechen, Fehlermeldung ausgeben

Werkzeug für Überwachung Q330: Festlegen, ob die TNC eine Werkzeug-Überwachung durchführen soll (siehe Werkzeug-Überwachung). Eingabebereich 0 bis 32767,9, alternativ Werkzeug-Name mit maximal 16 Zeichen 0: Überwachung nicht aktiv >0: Werkzeug-Nummer in der Werkzeug-Tabelle TOOL.T


MESSEN KOORDINATE (Zyklus 427, DIN/ISO: G427)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 427 ermittelt eine Koordinate in einer wählbaren Achse und legt den Wert in einem Systemparameter ab.Wenn Sie die entsprechenden Toleranzwerte im Zyklus definieren, führt die TNC einen Soll-Istwertvergleich durch und legt die Abweichung in Systemparametern ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum Antastpunkt 1. Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand entgegen der festgelegten Verfahrrichtung
  2. Danach positioniert die TNC das Tastsystem in der Bearbeitungsebene auf den eingegebenen Antastpunkt 1 und misst dort den Istwert in der gewählten Achse
  3. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die ermittelte Koordinate in folgendem Q-Parameter:
Parameter-Nummer | Bedeutung
Q160 | Gemessene Koordinate


Zyklusparameter

1 Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1 Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Messachse (1..3: 1=Hauptachse) Q272: Achse in der die Messung erfolgen soll: 1: Hauptachse = Messachse 2: Nebenachse = Messachse 3: Tastsystem-Achse = Messachse

Verfahrrichtung 1 Q267: Richtung, in der das Tastsystem auf das Werkstück zufahren soll: -1: Verfahrrichtung negativ +1: Verfahrrichtung positiv

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef
Beispiel: NC-Sätze
5 TCH PROBE 427 MESSEN KOORDINATE
Q263=+35 ;1. PUNKT 1. ACHSE
Q264=+45 ;1. PUNKT 2. ACHSE
Q261=+5 ;MESSHOEHE
Q320=0 ;SICHERHEITS-ABST.
Q272=3 ;MESSACHSE
Q267=-1 ;VERFAHRRICHTUNG
Q260=+20 ;SICHERE HOEHE
Q281=1 ;MESSPROTOKOLL
Q288=5.1 ;GROESSTMASS
Q289=4.95 ;KLEINSTMASS
Q309=0 ;PGM-STOP BEI FEHLER
Q330=0 ;WERKZEUG

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR427.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen

Größtmaß Q288: Größter erlaubter Messwert. Eingabebereich -99999,9999 bis 99999,9999

Kleinstmaß Q289: Kleinster erlaubter Messwert. Eingabebereich -99999,9999 bis 99999,9999

PGM-Stop bei Toleranzfehler Q309: Festlegen, ob die TNC bei Toleranz-Überschreitungen den Programmlauf unterbrechen und eine Fehlermeldung ausgeben soll: 0: Programmlauf nicht unterbrechen, keine Fehlermeldung ausgeben 1: Programmlauf unterbrechen, Fehlermeldung ausgeben

Werkzeug für Überwachung Q330: Festlegen, ob die TNC eine Werkzeug-Überwachung durchführen soll (siehe Werkzeug-Überwachung). Eingabebereich 0 bis 32767,9, alternativ Werkzeug-Name mit maximal 16 Zeichen: 0: Überwachung nicht aktiv >0: Werkzeug-Nummer in der Werkzeug-Tabelle TOOL.T


MESSEN LOCHKREIS (Zyklus 430, DIN/ISO: G430)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 430 ermittelt den Mittelpunkt und den Durchmesser eines Lochkreises durch Messung dreier Bohrungen. Wenn Sie die entsprechenden Toleranzwerte im Zyklus definieren, führt die TNC einen Soll-Istwertvergleich durch und legt die Abweichung in Systemparametern ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) auf den eingegebenen Mittelpunkt der ersten Bohrung 1
  2. Anschließend fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den ersten Bohrungs-Mittelpunkt
  3. Anschließend fährt das Tastsystem zurück auf die Sichere Höhe und positioniert auf den eingegebenen Mittelpunkt der zweiten Bohrung 2
  4. Die TNC fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den zweiten Bohrungs-Mittelpunkt
  5. Anschließend fährt das Tastsystem zurück auf die Sichere Höhe und positioniert auf den eingegebenen Mittelpunkt der dritten Bohrung 3
  6. Die TNC fährt das Tastsystem auf die eingegebene Messhöhe und erfasst durch vier Antastungen den dritten Bohrungs-Mittelpunkt
  7. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die Istwerte und die Abweichungen in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q151 | Istwert Mitte Hauptachse
Q152 | Istwert Mitte Nebenachse
Q153 | Istwert Lochkreis-Durchmesser
Q161 | Abweichung Mitte Hauptachse
Q162 | Abweichung Mitte Nebenachse
Q163 | Abweichung Lochkreis-Durchmesser


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Zyklus 430 führt nur Bruch-Überwachung durch, keine automatische Werkzeug-Korrektur.


Zyklusparameter

Mitte 1. Achse Q273 (absolut): Lochkreis-Mitte (Sollwert) in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Mitte 2. Achse Q274 (absolut): Lochkreis-Mitte (Sollwert) in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

Soll-Durchmesser Q262: Lochkreis-Durchmesser eingeben. Eingabebereich 0 bis 99999,9999

Winkel 1. Bohrung Q291 (absolut): Polarkoordinaten-Winkel des ersten Bohrungs-Mittelpunktes in der Bearbeitungsebene. Eingabebereich -360,0000 bis 360,0000

Winkel 2. Bohrung Q292 (absolut): Polarkoordinaten-Winkel des zweiten Bohrungs-Mittelpunktes in der Bearbeitungsebene. Eingabebereich -360,0000 bis 360,0000

Winkel 3. Bohrung Q293 (absolut): Polarkoordinaten-Winkel des dritten Bohrungs-Mittelpunktes in der Bearbeitungsebene. Eingabebereich -360,0000 bis 360,0000

Messhöhe in der Tastsystem-Achse Q261 (absolut): Koordinate des Kugelzentrums (=Berührpunkt) in der Tastsystem-Achse, auf der die Messung erfolgen soll. Eingabebereich -99999,9999 bis 99999,9999

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Größtmaß Q288: Größter erlaubter Lochkreis-Durchmesser. Eingabebereich 0 bis 99999,9999

Kleinstmaß Q289: Kleinster erlaubter Lochkreis-Durchmesser. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 1. Achse Q279: Erlaubte Lageabweichung in der Hauptachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Toleranzwert Mitte 2. Achse Q280: Erlaubte Lageabweichung in der Nebenachse der Bearbeitungsebene. Eingabebereich 0 bis 99999,9999

Beispiel: NC-Sätze
5 TCH PROBE 430 MESSEN LOCHKREIS
Q273=+50 ;MITTE 1. ACHSE
Q274=+50 ;MITTE 2. ACHSE
Q262=80 ;SOLL-DURCHMESSER
Q291=+0 ;WINKEL 1. BOHRUNG
Q292=+90 ;WINKEL 2. BOHRUNG
Q293=+180 ;WINKEL 3. BOHRUNG
Q261=-5 ;MESSHOEHE
Q260=+10 ;SICHERE HOEHE
Q288=80.1 ;GROESSTMASS
Q289=79.9 ;KLEINSTMASS
Q279=0.15 ;TOLERANZ 1. MITTE
Q280=0.15 ;TOLERANZ 2. MITTE
Q281=1 ;MESSPROTOKOLL
Q309=0 ;PGM-STOP BEI FEHLER
Q330=0 ;WERKZEUG

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR430.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen

PGM-Stop bei Toleranzfehler Q309: Festlegen, ob die TNC bei Toleranz-Überschreitungen den Programmlauf unterbrechen und eine Fehlermeldung ausgeben soll: 0: Programmlauf nicht unterbrechen, keine Fehlermeldung ausgeben 1: Programmlauf unterbrechen, Fehlermeldung ausgeben

Werkzeug für Überwachung Q330: Festlegen, ob die TNC eine Werkzeug-Bruchüberwachung durchführen soll (siehe Werkzeug-Überwachung). Eingabebereich 0 bis 32767,9, alternativ Werkzeug-Name mit maximal 16 Zeichen. 0: Überwachung nicht aktiv >0: Werkzeug-Nummer in der Werkzeug-Tabelle TOOL.T


MESSEN EBENE (Zyklus 431, DIN/ISO: G431)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 431 ermittelt die Winkel einer Ebene durch Messung dreier Punkte und legt die Werte in Systemparametern ab.

  1. Die TNC positioniert das Tastsystem mit Eilvorschub (Wert aus MP6150) und mit Positionierlogik (siehe Tastsystemzyklen abarbeiten) zum programmierten Antastpunkt 1 und misst dort den ersten Ebenenpunkt. Die TNC versetzt dabei das Tastsystem um den Sicherheits-Abstand entgegen der Antastrichtung
  2. Anschließend fährt das Tastsystem zurück auf die Sichere Höhe, danach in der Bearbeitungsebene zum Antastpunkt 2 und misst dort den Istwert des zweiten Ebenenpunktes
  3. Anschließend fährt das Tastsystem zurück auf die Sichere Höhe, danach in der Bearbeitungsebene zum Antastpunkt 3 und misst dort den Istwert des dritten Ebenenpunktes
  4. Abschließend positioniert die TNC das Tastsystem zurück auf die Sichere Höhe und speichert die ermittelten Winkelwerte in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q158 | Projektionswinkel der A-Achse
Q159 | Projektionswinkel der B-Achse
Q170 | Raumwinkel A
Q171 | Raumwinkel B
Q172 | Raumwinkel C
Q173 bis Q175 | Messwerte in der Tastsystem-Achse (erste bis dritte Messung)


Beim Programmieren beachten!

Vor der Zyklus-Definition müssen Sie einen Werkzeug-Aufruf zur Definition der Tastsystem-Achse programmiert haben.

Damit die TNC Winkelwerte berechnen kann, dürfen die drei Messpunkte nicht auf einer Geraden liegen.

In den Parametern Q170 - Q172 werden die Raumwinkel gespeichert, die bei der Funktion Bearbeitungsebene Schwenken benötigt werden. Über die ersten zwei Messpunkte bestimmen Sie die Ausrichtung der Hauptachse beim Schwenken der Bearbeitungsebene.

Der dritte Messpunkt legt die Richtung der Werkzeug-Achse fest. Dritten Messpunkt in Richtung positiver Y-Achse definieren, damit die Werkzeug-Achse im rechtsdrehenden Koordinatensystem richtig liegt

Wenn Sie den Zyklus bei aktiver geschwenkter Bearbeitungsebene ausführen, dann beziehen sich die gemessenen Raumwinkel auf das geschwenkte Koordinatensystem. In diesen Fällen die ermittelten Raumwinkel mit PLANE RELATIV weiterverarbeiten.


Zyklusparameter

1. Messpunkt 1. Achse Q263 (absolut): Koordinate des ersten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 2. Achse Q264 (absolut): Koordinate des ersten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

1. Messpunkt 3. Achse Q294 (absolut): Koordinate des ersten Antastpunktes in der Tastsystem-Achse. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 1. Achse Q265 (absolut): Koordinate des zweiten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 2. Achse Q266 (absolut): Koordinate des zweiten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

2. Messpunkt 3. Achse Q295 (absolut): Koordinate des zweiten Antastpunktes in der Tastsystem-Achse. Eingabebereich -99999,9999 bis 99999,9999

3. Messpunkt 1. Achse Q296 (absolut): Koordinate des dritten Antastpunktes in der Hauptachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

3. Messpunkt 2. Achse Q297 (absolut): Koordinate des dritten Antastpunktes in der Nebenachse der Bearbeitungsebene. Eingabebereich -99999,9999 bis 99999,9999

3. Messpunkt 3. Achse Q298 (absolut): Koordinate des dritten Antastpunktes in der Tastsystem-Achse . Eingabebereich -99999,9999 bis 99999,9999

Beispiel: NC-Sätze
5 TCH PROBE 431 MESSEN EBENE
Q263=+20 ;1. PUNKT 1. ACHSE
Q264=+20 ;1. PUNKT 2. ACHSE
Q294=+10 ;1. PUNKT 3. ACHSE
Q265=+90 ;2. PUNKT 1. ACHSE
Q266=+25 ;2. PUNKT 2. ACHSE
Q295=+15 ;2. PUNKT 3. ACHSE
Q296=+50 ;3. PUNKT 1. ACHSE
Q297=+80 ;3. PUNKT 2. ACHSE
Q298=+20 ;3. PUNKT 3. ACHSE
Q320=0 ;SICHERHEITS-ABST.
Q260=+5 ;SICHERE HOEHE
Q281=1 ;MESSPROTOKOLL

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Messprotokoll Q281: Festlegen, ob die TNC ein Messprotokoll erstellen soll: 0: Kein Messprotokoll erstellen 1: Messprotokoll erstellen: Die TNC legt die Protokolldatei TCHPR431.TXT standardmäßig in dem Verzeichnis ab, in dem auch Ihr Messprogramm gespeichert ist 2: Programmlauf unterbrechen und Messprotokoll auf den TNC-Bildschirmausgeben. Programm mit NC-Start fortsetzen


Programmierbeispiele

Weitere Informationen:
> Beispiel: Rechteck-Zapfen messen und nachbearbeiten
> Beispiel: Rechtecktasche vermessen, Messergebnisse protokollieren


Beispiel: Rechteck-Zapfen messen und nachbearbeiten

    Programm-Ablauf:

  • Rechteck-Zapfen schruppen mit Aufmaß 0,5
  • Rechteck-Zapfen messen
  • Rechteck-Zapfen schlichten unter Berücksichtigung der Messwerte
0 BEGIN PGM BEAMS mm |
1 TOOL CALL 69 z | Werkzeug-Aufruf Vorbearbeitung
2 l z+100 r0 fmax | Werkzeug freifahren
3 fn 0: q1 = +81 | Taschen-Länge in X (Schrupp-Maß)
4 fn 0: q2 = +61 | Taschen-Länge in Y (Schrupp-Maß)
5 call lbl 1 | Unterprogramm zur Bearbeitung aufrufen
6 l z+100 r0 fmax | Werkzeug freifahren, Werkzeug-Wechsel
7 tool call 99 z | Taster aufrufen
8 tch probe 424 messen rechteck aus. | Gefrästes Rechteck messen
Q273=+50 ;mitte 1. achse |
Q274=+50 ;mitte 2. achse |
Q282=80 ;1. seiten-laenge | Soll-Länge in X (Endgültiges Maß)
Q283=60 ;2. seiten-laenge | Soll-Länge in Y (Endgültiges Maß)
Q261=-5 ;messhoehe |
Q320=0 ;sicherheits-abst. |
Q260=+30 ;sichere hoehe |
Q301=0 ;fahren auf s. hoehe |
Q284=0 ;groesstmass 1. seite | Eingabewerte für Toleranzprüfung nicht erforderlich
Q285=0 ;kleinstmass 1. seite |
Q286=0 ;groesstmass 2. seite |
Q287=0 ;kleinstmass 2. seite |
Q279=0 ;toleranz 1. mitte |
Q280=0 ;toleranz 2. mitte |
Q281=0 ;messprotokoll | Kein Messprotokoll ausgeben
Q309=0 ;pgm-stop bei fehler | Keine Fehlermeldung ausgeben
Q330=0 ;werkzeug-nummer | Keine Werkzeug-Überwachung
9 fn 2: q1 = +q1 - +q164 | Länge in X berechnen anhand der gemessenen Abweichung
10 fn 2: q2 = +q2 - +q165 | Länge in Y berechnen anhand der gemessenen Abweichung
11 l z+100 r0 fmax | Taster freifahren, Werkzeug-Wechsel
12 tool call 1 z s5000 | Werkzeug-Aufruf Schlichten
13 call lbl 1 | Unterprogramm zur Bearbeitung aufrufen
14 l z+100 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
15 lbl 1 | Unterprogramm mit Bearbeitungs-Zyklus Rechteck-Zapfen
16 cycl def 213 ZAPFEN SCHLICHTEN |
Q200=20 ;SICHERHEITS-ABST. |
Q201=-10 ;tiefe |
Q206=150 ;VORSCHUB TIEFENZUST. |
Q202=5 ;zustell-tiefe |
Q207=500 ;VORSCHUB FRAESEN |
Q203=+10 ;KOOR. OBERFLAECHE |
Q204=20 ;2. SICHERHEITS-ABST. |
Q216=+50 ;MITTE 1. ACHSE |
Q217=+50 ;MITTE 2. ACHSE |
Q218=Q1 ;1. SEITEN-LAENGE | Länge in X variabel für schruppen und schlichten
Q219=q2 ;2. SEITEN-LAENGE | Länge in Y variabel für schruppen und schlichten
Q220=0 ;ECKENRADIUS |
Q221=0 ;AUFMASS 1. ACHSE |
17 cycl call m3 | Zyklus-Aufruf
18 lbl 0 | Unterprogramm-Ende
19 end pgm beams mm |


Beispiel: Rechtecktasche vermessen, Messergebnisse protokollieren

0 begin pgm bsmess mm |
1 tool call 1 z | Werkzeug-Aufruf Taster
2 l z+100 r0 fmax | Taster freifahren
3 tch probe 423 MESSEN RECHTECK INN. |
Q273=+50 ;MITTE 1. ACHSE |
Q274=+40 ;MITTE 2. ACHSE |
Q282=90 ;1. SEITEN-LAENGE | Soll-Länge in X
Q283=70 ;2. SEITEN-LAENGE | Soll-Länge in Y
Q261=-5 ;messhoehe |
Q320=0 ;SICHERHEITS-ABST. |
Q260=+20 ;SICHERE HOEHE |
Q301=0 ;FAHREN AUF S. HOEHE |
Q284=90.15 ;GROESSTMASS 1. SEITE | Größtmaß in X
Q285=89.95 ;KLEINSTMASS 1. SEITE | Kleinstmaß in X
Q286=70.1 ;GROESSTMASS 2. SEITE | Größtmaß in Y
Q287=69.9 ;KLEINSTMASS 2. SEITE | Kleinstmaß in Y
Q279=0.15 ;TOLERANZ 1. MITTE | Erlaubte Lageabweichung in X
Q280=0.1 ;TOLERANZ 2. MITTE | Erlaubte Lageabweichung in Y
Q281=1 ;MESSPROTOKOLL | Messprotokoll in Datei ausgeben
Q309=0 ;PGM-STOP BEI FEHLER | Bei Toleranzüberschreitung keine Fehlermeldung anzeigen
Q330=0 ;WERKZEUG-NUMMER | Keine Werkzeug-Überwachung
4 l z+100 r0 fmax m2 | Werkzeug freifahren, Programm-Ende
5 end pgm bsmess mm |


Tastsystemzyklen: Sonderfunktionen

Weitere Informationen:
> Grundlagen
> TS KALIBRIEREN (Zyklus 2)
> TS KALIBRIEREN LAENGE (Zyklus 9)
> MESSEN (Zyklus 3)
> MESSEN 3D (Zyklus 4, FCL 3‑Funktion)
> ACHSVERSCHIEBUNG MESSEN (Tastsystem-Zyklus 440, DIN/ISO: G440)
> SCHNELLES ANTASTEN (Zyklus 441, DIN/ISO: G441, FCL 2-Funktion)
> TS KALIBRIEREN (Zyklus 460, DIN/ISO: G460)


Übersicht

Die TNC stellt sieben Zyklen für folgende Sonderanwendungen zur Verfügung:

Zyklus | Softkey | Seite
2 TS KALIBRIEREN: Radius-Kalibrierung des schaltenden Tastsystems |  | TS KALIBRIEREN (Zyklus 2)
9 TS KAL. LAENGE: Längen-Kalibrierung des schaltenden Tastsystems |  | TS KALIBRIEREN LAENGE (Zyklus 9)
3 MESSEN Messzyklus zur Erstellung von Hersteller-Zyklen |  | MESSEN (Zyklus 3)
4 MESSEN 3D Messzyklus für 3D-Antastung zur Erstellung von Hersteller-Zyklen |  | MESSEN 3D (Zyklus 4, FCL 3‑Funktion)
440 ACHSVERSCHIEBUNG MESSEN |  | ACHSVERSCHIEBUNG MESSEN (Tastsystem-Zyklus 440, DIN/ISO: G440)
441 SCHNELLES ANTASTEN |  | SCHNELLES ANTASTEN (Zyklus 441, DIN/ISO: G441, FCL 2-Funktion)
460 TS KALIBRIEREN: Radius- und Längenkalibrierung an einer Kalibrierkugel |  | TS KALIBRIEREN (Zyklus 460, DIN/ISO: G460)


TS KALIBRIEREN (Zyklus 2)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 2 kalibriert ein schaltendes Tastsystem automatisch an einem Kalibrierring oder einem Kalibrierzapfen.

  1. Das Tastsystem fährt mit Eilvorschub (Wert aus MP6150) auf die Sichere Höhe (nur wenn aktuelle Position unterhalb der sicheren Höhe liegt)
  2. Danach positioniert die TNC das Tastsystem in der Bearbeitungsebene ins Zentrum des Kalibrierrings (innen kalibrieren) oder in die Nähe des ersten Antastpunktes (außen kalibrieren)
  3. Danach fährt das Tastsystem auf die Messtiefe (Ergibt sich aus Maschinen-Parameter 618x.2 und 6185.x) und tastet nacheinander in X+, Y+, X- und Y- den Kalibrierring an
  4. Abschließend fährt die TNC das Tastsystem auf die Sichere Höhe und schreibt den wirksamen Radius der Tastkugel in die Kalibrierdaten


Beim Programmieren beachten!

Bevor Sie kalibrieren, müssen Sie in den Maschinen-Para-metern 6180.0 bis 6180.2 das Zentrum des Kalibrierwerk-stücks im Arbeitsraum der Maschine festlegen (REF-Koor-dinaten).

Wenn Sie mit mehreren Verfahrbereichen arbeiten, dann können Sie zu jedem Verfahrbereich einen eigenen Satz Koordinaten für das Zentrum des Kalibrierwerkstückes ablegen (MP6181.1 bis 6181.2 und MP6182.1 bis 6182.2.).


Zyklusparameter

Beispiel: NC-Sätze
5 tch probe 2.0 ts kalibrieren
6 TCH PROBE 2.1 hoehe: +50 R +25.003 messart: 0

Sichere Höhe (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Kalibrierwerkstück (Spannmittel) erfolgen kann. Eingabebereich -99999,9999 bis 99999,9999

Radius Kalibrierring: Radius des Kalibrierwerkstücks. Eingabebereich 0 bis 99999,9999

Innen kalibr.=0/außen kalibr.=1: Festlegen, ob die TNC innen oder außen kalibrieren soll: 0: Innen kalibrieren 1: Außen kalibrieren


TS KALIBRIEREN LAENGE (Zyklus 9)

Weitere Informationen:
> Zyklusablauf
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 9 kalibriert die Länge eines schaltenden Tastsystems automatisch an einem von Ihnen festzulegenden Punkt.

  1. Tastsystem so vorpositionieren, dass die im Zyklus definierte Koordinate in der Tastsystem-Achse kollisionsfrei angefahren werden kann
  2. Die TNC fährt das Tastsystem in Richtung der negativen Werkzeug-Achse, bis ein Schaltsignal ausgelöst wird
  3. Abschließend fährt die TNC das Tastsystem wieder zurück auf den Startpunkt des Antastvorganges und schreibt die wirksame Tastsystemlänge in die Kalibrierdaten


Zyklusparameter

Beispiel: NC-Sätze
5 l x-235 y+356 r0 fmax
6 TCH PROBE 9.0 TS KAL. laenge
7 TCH PROBE 9.1 bezugspunkt +50 bezugssystem 0

Koordinate Bezugspunkt (absolut): Exakte Koordinate des Punktes, der angetastet werden soll. Eingabebereich -99999,9999 bis 99999,9999

Bezugssystem? (0=IST/1=REF): Festlegen, auf welches Koordinatensystem sich der eingegebene Bezugspunktes beziehen soll: 0: Eingegebener Bezugspunkt bezieht sich auf das aktive Werkstück-Koordinatensystem (IST-System) 1: Eingegebener Bezugspunkt bezieht sich auf das aktive Maschinen-Koordinatensystem (REF-System)


MESSEN (Zyklus 3)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Der Tastsystem-Zyklus 3 ermittelt in einer wählbaren Antast-Richtung eine beliebige Position am Werkstück. Im Gegensatz zu anderen Messzyklen können Sie im Zyklus 3 den Messweg ABST und den Messvorschub F direkt eingeben. Auch der Rückzug nach Erfassung des Messwertes erfolgt um den eingebbaren Wert MB.

  1. Das Tastsystem fährt von der aktuellen Position aus mit dem eingegebenen Vorschub in die festgelegte Antast-Richtung. Die Antast-Richtung ist über Polarwinkel im Zyklus festzulegen
  2. Nachdem die TNC die Position erfasst hat, stoppt das Tastsystem. Die Koordinaten des Tastkugel-Mittelpunktes X, Y, Z, speichert die TNC in drei aufeinanderfolgenden Q-Parametern ab. Die TNC führt keine Längen- und Radiuskorrekturen durch. Die Nummer des ersten Ergebnisparameters definieren Sie im Zyklus
  3. Abschließend fährt die TNC das Tastsystem um den Wert entgegen der Antast-Richtung zurück, den Sie im Parameter MB definiert haben


Beim Programmieren beachten!

Die genaue Funktionsweise des Tastsystem-Zyklus 3 legt Ihr Maschinenhersteller oder ein Softwarehersteller fest, der Zyklus 3 innerhalb von speziellen Tastsystemzyklen verwenden.

Die bei anderen Messzyklen wirksamen Maschinen-Parameter 6130 (maximaler Verfahrweg zum Antastpunkt) und 6120 (Antastvorschub) wirken nicht im Tastsystem-Zyklus 3.

Beachten Sie, dass die TNC grundsätzlich immer 4 aufeinanderfolgende Q-Parameter beschreibt.

Wenn die TNC keinen gültiger Antastpunkt ermitteln konnte, wird das Programm ohne Fehlermeldung weiter abgearbeitet. In diesem Fall weist die TNC dem 4. Ergebnis-Parameter den Wert -1 zu, so dass Sie selbst eine entsprechende Fehlerbehandlung durchführen können.

Die TNC fährt das Tastsystem maximal um den Rückzugsweg MB zurück, jedoch nicht über den Startpunkt der Messung hinaus. Dadurch kann beim Rückzug keine Kollision erfolgen.

Mit der Funktion FN17: SYSWRITE ID 990 NR 6 können Sie festlegen, ob der Zyklus auf den Tastereingang X12 oder X13 wirken soll.


Zyklusparameter

Beispiel: NC-Sätze
4 TCH PROBE 3.0 messen
5 TCH PROBE 3.1 q1
6 TCH PROBE 3.2 x winkel: +15
7 TCH PROBE 3.3 abst +10 f100 mb1 bezugssystem:0
8 tch probe 3.4 ERRORMODE1

Parameter-Nr. für Ergebnis: Nummer des Q-Parameters eingeben, dem die TNC den Wert der ersten ermittelten Koordinate (X) zuweisen soll. Die Werte Y und Z stehen in den direkt folgenden Q-Parametern. Eingabebereich 0 bis 1999

Antast-Achse: Achse eingeben, in deren Richtung die Antastung erfolgen soll, mit Taste ENT bestätigen. Eingabebereich X, Y oder Z

Antast-Winkel: Winkel bezogen auf die definiertre Antast-Achse, in der das Tastsystem verfahren soll, mit Taste ENT bestätigen. Eingabebereich -180,0000 bis 180,0000

Maximaler Messweg: Verfahrweg eingeben, wie weit das Tastsystem vom Startpunkt aus verfahren soll, mit Taste ENT bestätigen. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Messen: Messvorschub in mm/min eingeben. Eingabebereich 0 bis 3000,000

Maximaler Rückzugsweg: Verfahrweg entgegen der Antast-Richtung, nachdem der Taststift ausgelenkt wurde. Die TNC verfährt das Tastsystem maximal bis zum Startpunkt zurück, so dass keine Kollision erfolgen kann. Eingabebereich 0 bis 99999,9999

Bezugssystem? (0=IST/1=REF): Festlegen, ob sich die Antastrichtung und das Messergebnis auf das aktuellen Koordinatensystem (IST, kann also verschoben oder verdreht sein) oder auf das Maschinen-Koordinatensystem (REF) beziehen sollen: 0: Im aktuellen System antasten und Messergebnis im IST-System ablegen 1: Im maschinenfesten REF-System antasten und Messergebnis im ref-System ablegen

Fehlermodus (0=AUS/1=EIN): Festlegen, ob die TNC bei ausgelenktem Taststift am Zyklus-Anfang eine Fehlermeldung ausgeben soll oder nicht. Wenn Modus 1 gewählt ist, dann speichert die TNC im 4. Ergebnisparameter den Wert 2.0 und arbeitet den Zyklus weiter ab: 0: Fehlermeldung ausgeben 1: Keine Fehlermeldung ausgeben


MESSEN 3D (Zyklus 4, FCL 3‑Funktion)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Zyklus 4 ist ein Hilfszyklus, den Sie nur in Verbindung mit externer Software einsetzten können! Die TNC stellt keinen Zyklus zur Verfügung, mit dem Sie den Taster kalibrieren könnten.

Der Tastsystem-Zyklus 4 ermittelt in einer per Vektor definierbaren Antast-Richtung eine beliebige Position am Werkstück. Im Gegensatz zu anderen Messzyklen, können Sie im Zyklus 4 den Messweg und den Messvorschub direkt eingeben. Auch der Rückzug nach Erfassung des Messwertes erfolgt um einen eingebbaren Wert.

  1. Das Tastsystem fährt von der aktuellen Position aus mit dem eingegebenen Vorschub in die festgelegte Antast-Richtung. Die Antast-Richtung ist über einen Vektor (Delta-Werte in X, Y und Z) im Zyklus festzulegen
  2. Nachdem die TNC die Position erfasst hat, stoppt das Tastsystem. Die Koordinaten des Tastkugel-Mittelpunktes X, Y, Z, (ohne Verrechnung der Kalibrierdaten) speichert die TNC in drei aufeinanderfolgenden Q-Parametern ab. Die Nummer des ersten Parameters definieren Sie im Zyklus
  3. Abschließend fährt die TNC das Tastsystem um den Wert entgegen der Antast-Richtung zurück, die Sie im Parameter MB definiert haben


Beim Programmieren beachten!

Die TNC fährt das Tastsystem maximal um den Rückzugsweg MB zurück, jedoch nicht über den Startpunkt der Messung hinaus. Dadurch kann beim Rückzug keine Kollision erfolgen.

Beim Vorpositionieren darauf achten, dass die TNC den Tastkugel-Mittelpunkt unkorrigiert auf die definierte Position fährt!

Beachten Sie, dass die TNC grundzätzlich immer 4 aufeinanderfolgende Q-Parameter beschreibt. Wenn die TNC keinen gültiger Antastpunkt ermitteln konnte, enthält der 4. Ergebnis-Parameter den Wert -1.

Die TNC speichert die Messwerte ohne die Kalibrierdaten des Tastsystems zu verrechnen.

Mit der Funktion FN17: SYSWRITE ID 990 NR 6 können Sie festlegen, ob der Zyklus auf den Tastereingang X12 oder X13 wirken soll.


Zyklusparameter

Beispiel: NC-Sätze
5 TCH PROBE 4.0 messen 3d
6 TCH PROBE 4.1 q1
7 TCH PROBE 4.2 ix-0.5 iy-1 iz-1
8 TCH PROBE 4.3 abst +45 f100 mb50 bezugssystem:0

Parameter-Nr. für Ergebnis: Nummer des Q-Parameters eingeben, dem die TNC den Wert der ersten Koordinate (X) zuweisen soll. Eingabebereich 0 bis 1999

Relativer Messweg in X: X-Anteil des Richtungsvektors, in dessen Richtung das Tastsystem verfahren soll. Eingabebereich ‑99999,9999 bis 99999,9999

Relativer Messweg in Y: Y-Anteil des Richtungsvektors, in dessen Richtung das Tastsystem verfahren soll. Eingabebereich ‑99999,9999 bis 99999,9999

Relativer Messweg in Z: Z-Anteil des Richtungsvektors, in dessen Richtung das Tastsystem verfahren soll. Eingabebereich ‑99999,9999 bis 99999,9999

Maximaler Messweg: Verfahrweg eingeben, wie weit das Tastsystem vom Startpunkt aus entlang des Richtungsvektors verfahren soll. Eingabebereich ‑99999,9999 bis 99999,9999

Vorschub Messen: Messvorschub in mm/min eingeben. Eingabebereich 0 bis 3000,000

Maximaler Rückzugsweg: Verfahrweg entgegen der Antast-Richtung, nachdem der Taststift ausgelenkt wurde. Eingabebereich 0 bis 99999,9999

Bezugssystem? (0=IST/1=REF): Festlegen, ob das Messergebnis im aktuellen Koordinatensystem (IST, kann also verschoben oder verdreht sein) oder bezogen auf das Maschinen-Koordinatensystem (REF) abgelegt werden soll: 0: Messergebnis im IST-System ablegen 1: Messergebnis im ref-System ablegen


ACHSVERSCHIEBUNG MESSEN (Tastsystem-Zyklus 440, DIN/ISO: G440)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit dem Tastsystem-Zyklus 440 können Sie die Achsverschiebungen ihrer Maschine ermitteln. Dazu sollten Sie ein exakt vermessenes zylindrisches Kalibrierwerkzeug in Verbindung mit dem TT 130 verwenden.

  1. Die TNC positioniert das Kalibrierwerkzeug mit Eilvorschub (Wert aus MP6550) und mit Positionierlogik (siehe Kapitel 1.2) in die Nähe des TT
  2. Zuerst führt die TNC in der Tastsystemachse eine Messung durch. Dabei wird das Kalibrierwerkzeug um den Betrag versetzt, den Sie in der Werkzeug-Tabelle TOOL.T in der Spalte TT:R-OFFS festgelegt haben (Standard = Werkzeug-Radius). Die Messung in der Tastsystem-Achse wird immer durchgeführt
  3. Anschließend führt die TNC die Messung in der Bearbeitungsebene durch. In welcher Achse und in welcher Richtung in der Bearbeitungsebene gemessen werden soll, legen Sie über den Parameter Q364 fest
  4. Falls Sie eine Kalibrierung durchführen, legt die TNC die Kalibrierdaten intern ab. Wenn Sie eine Messung durchführen, vergleicht die TNC die Messwerte mit den Kalibrierdaten und schreibt die Abweichungen in folgende Q-Parameter:
Parameter-Nummer | Bedeutung
Q185 | Abweichung vom Kalibrierwert in X
Q186 | Abweichung vom Kalibrierwert in Y
Q187 | Abweichung vom Kalibrierwert in Z
  1. Die Abweichung können Sie direkt verwenden, um über eine inkrementale Nullpunkt-Verschiebung (Zyklus 7) die Kompensation durchzuführen.
  5. Abschließend fährt das Kalibrierwerkzeug zurück auf die Sichere Höhe


Beim Programmieren beachten!

Bevor Sie Zyklus 440 das erste Mal abarbeiten, müssen Sie das TT mit dem TT-Zyklus 30 kalibriert haben.

Die Werkzeug-Daten des Kalibrierwerkzeugs müssen in der Werkzeug-Tabelle TOOL.T hinterlegt sein.

Bevor der Zyklus abgearbeitet wird, müssen Sie das Kalibrierwerkzeug mit TOOL CALL aktivieren.

Das Tischtastsystem TT muss am Tastsystem-Eingang X13 der Logik-Einheit angeschlossen und funktionsfähig sein (Maschinen-Parameter 65xx).

Bevor Sie eine Messung durchführen, müssen Sie mindestens einmal kalibriert haben, ansonsten gibt die TNC eine Fehlermeldung aus. Wenn Sie mit mehreren Verfahrbereichen arbeiten, dann müssen Sie für jeden Verfahrbereich eine Kalibrierung durchführen.

Die Antastrichtung(en) beim Kalibrieren und Messen müssen übereinstimmen, ansonsten ermittelt die TNC falsche Werte.

Mit jedem Abarbeiten von Zyklus 440 setzt die TNC die Ergebnisparameter Q185 bis Q187 zurück.

Wenn Sie einen Grenzwert für die Achsverschiebung in den Achsen der Maschine festlegen wollen, dann tragen Sie in der Werkzeug-Tabelle TOOL.T in den Spalten LTOL (für die Spindelachse) und RTOL (für die Bearbeitungsebene) die gewünschten Grenzwerte ein. Beim Überschreiten der Grenzwerte gibt die TNC dann nach einer Kontrollmessung eine entsprechende Fehlermeldung aus.

Am Zyklusende stellt die TNC den Spindelzustand wieder her, der vor dem Zyklus aktiv war (M3/M4).


Zyklusparameter

Beispiel: NC-Sätze
5 TCH PROBE 440 ACHSVERSCHIEBUNG MESSEN
Q363=1 ;messart
Q364=0 ;ANTASTRICHTUNGEN
Q320=2 ;SICHERHEITS-ABST.
Q260=+50 ;SICHERE HOEHE

Messart: 0=Kalibr., 1=Messen? Q363: Festlegen, ob Sie kalibrieren oder eine Kontrollmessung durchführen wollen: 0: Kalibrieren 1: Messen

Antastrichtungen Q364: Antastrichtung(en) in der Bearbeitungsebene definieren: 0: Messen nur in positiver Hauptachsen-Richtung 1: Messen nur in positiver Nebenachsen-Richtung 2: Messen nur in negativer Hauptachsen-Richtung 3: Messen nur in negativer Nebenachsen-Richtung 4: Messen in positiver Hauptachsen- und in positiver Nebenachsen-Richtung 5: Messen in positiver Hauptachsen- und in negativer Nebenachsen-Richtung 6: Messen in negativer Hauptachsen- und in positiver Nebenachsen-Richtung 7: Messen in negativer Hauptachsen- und in negativer Nebenachsen-Richtung

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemscheibe. Q320 wirkt additiv zu MP6540. Eingabebereich 0 bis 99999,9999 alternativ predef

Sichere Höhe Q260 (absolut): Koordinate in der Tastsystem-Achse, in der keine Kollision zwischen Tastsystem und Werkstück (Spannmittel) erfolgen kann (bezogen auf den aktiven Bezugspunkt). Eingabebereich -99999,9999 bis 99999,9999 alternativ predef


SCHNELLES ANTASTEN (Zyklus 441, DIN/ISO: G441, FCL 2-Funktion)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit dem Tastsystem-Zyklus 441 können Sie verschiedene Tastsystem-Parameter (z.B. den Positioniervorschub) global für alle nachfolgend verwendeten Tastsystemzyklen setzen. Damit lassen sich auf einfache Weise Programmoptimierung durchführen, die zu kürzeren Gesamt-Bearbeitungszeiten führen.


Beim Programmieren beachten!

Beachten Sie vor dem Programmieren

Zyklus 441 führt keine Maschinenbewegungen aus, er setzt lediglich verschiedene Antast-Parameter.

END PGM, M02, M30 setzt die globalen Einstellungen des Zyklus 441 wieder zurück.

Die automatische Winkelnachführung (Zyklus-Parameter Q399) können Sie nur aktivieren, wenn der Maschinen-Parameter 6165=1 gesetzt ist . Das Ändern des Maschinen-Parameters 6165 setzt eine Neukalibrierung des Tastsystems voraus.


Zyklusparameter

Beispiel: NC-Sätze
5 TCH PROBE 441 schnelles antasten
Q396=3000 ;POSITIONIER-VORschub
Q397=0 ;AUSWAHL VORSCHUB
Q399=1 ;winkelnachführung
Q400=1 ;unterbrechung

Positionier-Vorschub Q396: Festlegen, mit welchem Vorschub Sie Positionierbewegungen des Tastsystems durchführen wollen. Eingabebereich 0 bis 99999,9999

Positionier-Vorschub=FMAX (0/1) Q397: Festlegen, ob Sie Positionierbewegungen des Tastsystems mit FMAX (Maschineneilgang) verfahren wollen: 0: Mit Vorschub aus Q396 verfahren 1: Mit FMAX verfahren Wenn Sie an Ihrer Maschine getrennte Potentiometer für Eilgang und Vorschub besitzen, dann können Sie den Vorschub auch bei Q397=1 nur mit dem Potentiometer für Vorschubbewegungen regeln.

Winkelnachführung Q399: Festlegen, ob die TNC das Tastsystem vor jedem Antast-Vorgang orientieren soll: 0: Nicht orientieren 1: Vor jedem Antast-Vorgang Spindel-Orientierung ausführen, um die Genauigkeit zu erhöhen

Automatische Unterbrechung Q400: Festlegen, ob die TNC nach einem Messzyklus zur automatischen Werkstück-Vermessung den Programmlauf unterbrechen und die Messergebnisse am Bildschirm ausgeben soll: 0: Programmlauf grundsätzlich nicht unterbrechen, auch wenn im jeweiligen Antastzyklus die Ausgabe der Messergebnisse auf den Bildschirm gewählt ist 1: Programmlauf grundsätzlich unterbrechen, Messergebnisse am Bildschirm ausgeben. Programmlauf ist dann mit der NC-Start-Taste fortsetzbar


TS KALIBRIEREN (Zyklus 460, DIN/ISO: G460)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Mit dem Zyklus 460 können Sie ein schaltendes 3D-Tastsystem an einer exakten Kalibrierkugel automatisch kalibrieren. Es ist möglich nur eine Radiuskalibrierung, oder eine Radius- und Längenkalibrierung durchzuführen.

  1. Kalibrierkugel aufspannen, auf Kollisionsfreiheit achten
  2. Tastsystem in der Tastsystem-Achse über die Kalibrierkugel und in der Bearbeitungsebene ungefähr in die Kugelmitte positionieren
  3. Die erste Bewegung im Zyklus erfolgt in die negative Richtung der Tastsystem-Achse
  4. Anschließend ermittelt der Zyklus das exakte Kugelzentrum in der Tastsystem-Achse


Beim Programmieren beachten!

Beachten Sie vor dem Programmieren

Tastsystem im Programm so vorpositionieren, dass es ungefähr über der Kugelmitte steht.


Zyklusparameter

Beispiel: NC-Sätze
5 TCH PROBE 460 TS kalibrieren
Q407=12.5 ;kugelradius
Q320=0 ;sicherheits-abst.
Q301=1 ;fahren auf s. hoehe
Q423=4 ;Anzahl ANtastungen
Q380=+0 ;Bezugswinkel
Q433=0 ;laenge kalibrieren
Q434=-2.5 ;Bezugspunkt

Exakter Kalibrierkugelradius Q407: Exakten Radius der verwendeten Kalibrierkugel eingeben. Eingabebereich 0,0001 bis 99,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Fahren auf sichere Höhe Q301: Festlegen, wie das Tastsystem zwischen den Messpunkten verfahren soll: 0: Zwischen Messpunkten auf Messhöhe verfahren 1: Zwischen Messpunkten auf Sicherer Höhe verfahren Alternativ predef

Anzahl Antastungen Ebene (4/3) Q423: Festlegen, ob die TNC die Kalibrierkugel in der Ebene mit 4 oder 3 Antastungen vermessen soll. 3 Antastungen erhöhen die Geschwindigkeit: 4: 4 Messpunkte verwenden (Standardeinstellung) 3: 3 Messpunkte verwenden

Bezugswinkel Q380 (absolut): Bezugswinkel (Grunddrehung) für die Erfassung der Messpunkte im wirksamen Werkstück-Koordinatensystem. Das Definieren eines Bezugswinkels kann den Messbereich einer Achse erheblich vergrößern. Eingabebereich 0 bis 360,0000

Länge kalibrieren (0/1) Q433: Festlegen, ob die TNC nach der Radiuskalibrierung auch die Tastsystem-Länge kalibrieren soll: 0: Tastsystem-Länge nicht kalibrieren 1: Tastsystem-Länge kalibrieren

Bezugspunkt für Länge Q434 (absolut): Koordinate des Kalibrierkugel-Zentrums. Definition nur erforderlich, wenn Längenkalibrierung durchgeführt werden soll. Eingabebereich ‑99999,9999 bis 99999,9999


Tastsystemzyklen: Kinematik automatisch vermessen

Weitere Informationen:
> Kinematik-Vermessung mit Tastsystemen TS (Option KinematicsOpt)
> Voraussetzungen
> KINEMATIK SICHERN (Zyklus 450, DIN/ISO: G450, Option)
> KINEMATIK VERMESSEN (Zyklus 451, DIN/ISO: G451, Option)
> PRESET-KOMPENSATION (Zyklus 452, DIN/ISO: G452, Option)


Kinematik-Vermessung mit Tastsystemen TS (Option KinematicsOpt)

Weitere Informationen:
> Grundlegendes
> Übersicht


Grundlegendes

Die Genauigkeitsanforderungen, insbesondere auch im Bereich der 5-Achs-Bearbeitung, werden immer höher. So sollen komplexe Teile exakt und mit reproduzierbarer Genauigkeit auch über lange Zeiträume gefertigt werden können.

Grund für Ungenauigkeiten bei der Mehrachsbearbeitung sind - unter anderen - die Abweichungen zwischen dem kinematischen Modell, das in der Steuerung hinterlegt ist (siehe Bild rechts 1), und den tatsächlich an der Maschine vorhandenen kinematischen Verhältnissen (siehe Bild rechts 2). Diese Abweichungen führen beim Positionieren der Drehachsen zu einem Fehler am Werkstück (siehe Bild rechts 3). Es muss also eine Möglichkeit geschaffen werden, Modell und Wirklichkeit möglichst Nahe aufeinander abzustimmen.

Die neue TNC-Funktion KinematicsOpt ist ein wichtiger Baustein der hilft, diese komplexe Anforderung auch wirklich umsetzen zu können: Ein 3D Tastsystem-Zyklus vermisst die an Ihrer Maschine vorhandenen Drehachsen vollautomatisch, unabhängig davon, ob die Drehachsen mechanisch als Tisch oder Kopf ausgeführt sind. Dabei wird eine Kalibrierkugel an einer beliebigen Stelle auf dem Maschinentisch befestigt und in einer von Ihnen definierbaren Feinheit vermessen. Sie legen bei der Zyklus-Definition lediglich für jede Drehachse separat den Bereich fest, den Sie vermessen wollen.

Aus den gemessenen Werten ermittelt die TNC die statische Schwenkgenauigkeit. Dabei minimiert die Software den durch die Schwenkbewegungen entstehenden Positionierfehler und speichert die Maschinengeometrie am Ende des Messvorgangs automatisch in den jeweiligen Maschinenkonstanten der Kinematiktabelle ab.


Übersicht

Die TNC stellt Zyklen zur Verfügung, mit denen Sie Ihre Maschinenkinematik automatisch sichern, wiederherstellen, prüfen und optimieren können:

Zyklus | Softkey | Seite
450 KINEMATIK SICHERN: Automatisches Sichern und Wiederherstellen von Kinematiken |  | KINEMATIK SICHERN (Zyklus 450, DIN/ISO: G450, Option)
451 KINEMATIK VERMESSEN: Automatisches Prüfen oder Optimieren der Maschinenkinematik |  | KINEMATIK VERMESSEN (Zyklus 451, DIN/ISO: G451, Option)
452 PRESET-KOMPENSATION: Automatisches Prüfen oder Optimieren der Maschinenkinematik |  | PRESET-KOMPENSATION (Zyklus 452, DIN/ISO: G452, Option)


Voraussetzungen

Um KinematicsOpt nutzen zu können, müssen folgende Voraussetzungen erfüllt sein:

  • Die Software-Optionen 48 (KinematicsOpt) und 8 (Software-Option 1), sowie FCL3 müssen freigeschaltet sein
  • Die Software-Option 52 (KinematicsComp) wird benötigt, wenn Kompensationen von Winkellagen durchgeführt werden soll
  • Das für die Vermessung verwendete 3D-Tastsystem muss kalibriert sein
  • Die Zyklen können nur mit Werkzeugachse Z ausgeführt werden
  • Eine Messkugel mit exakt bekanntem Radius und ausreichender Steifigkeit muss an einer beliebigen Stelle auf dem Maschinentisch befestigt sein. Wir empfehlen die Verwendung der Kalibrierkugeln KKH 250 (Bestell-Nummer 655 475-01) oder KKH 100 (Bestell-Nummer 655 475-02), die eine besonders hohe Steifigkeit aufweisen und speziell für die Maschinenkalibrierung konstruiert wurden. Setzen Sie sich bei Interesse mit HEIDENHAIN in Verbindung.
  • Die Kinematikbeschreibung der Maschine muss vollständig und korrekt definiert sein. Die Transformationsmaße müssen mit einer Genauigkeit von ca. 1 mm eingetragen sein
  • Die Maschine muss vollständig geometrisch vermessen sein (wird vom Maschinenhersteller bei der Inbetriebnahme durchgeführt)
  • Im Maschinen-Parameter MP6600 muss die Toleranzgrenze festgelegt sein, ab der die TNC einen Hinweis anzeigen soll, wenn die Änderungen an den Kinematikdaten über diesem Grenzwert liegen (siehe KinematicsOpt, Toleranzgrenze für Modus Optimieren: MP6600)
  • Im Maschinen-Parameter MP6601 muss die maximal erlaubte Abweichung des von den Zyklen automatisch gemessenen Kalibrierkugelradius vom eingegebenen Zyklusparameter festgelegt sein (siehe KinematicsOpt, erlaubte Abweichung Kalibrierkugelradius: MP6601)
  • Im Maschinen-Parameter MP 6602 muss die M-Funktions-Nummer eingetragen werden, die für die Drehachspositionierungen verwendet werden sollen, oder -1, wenn die NC die Positionierung durchführen soll. Eine M-Funktion muss von Ihrem Maschinenhersteller speziell für diesen Einsatz vorgesehen sein.
Weitere Informationen:
> Beim Programmieren beachten!


Beim Programmieren beachten!

Die KinematicsOpt-Zyklen verwenden die globalen Stringparameter QS0 bis QS99. Bitte beachten Sie, dass diese nach der Ausführung dieser Zyklen verändert sein können!

Wenn MP 6602 ungleich -1 ist, dann müssen Sie vor Starten eines der KinematicsOpt-Zyklen (außer 450) die Drehachsen auf 0 Grad (IST-System) positionieren.


KINEMATIK SICHERN (Zyklus 450, DIN/ISO: G450, Option)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter
> Protokollfunktion


Zyklusablauf

Mit dem Tastsystem-Zyklus 450 können Sie die aktive Maschinenkinematik sichern, eine zuvor gesicherte Maschinenkinematik wiederherstellen oder den aktuellen Speicherstatus am Bildschirm und in ein Protokoll ausgeben lassen. Es stehen 10 Speicherplätze (Nummern 0 bis 9) zur Verfügung.


Beim Programmieren beachten!

    Bevor Sie eine Kinematik-Optimierung durchführen, sollten Sie die aktive Kinematik grundsätzlich sichern. Vorteil:

  • Entspricht das Ergebnis nicht den Erwartungen, oder treten während der Optimierung Fehler auf (z.B. Stromausfall) dann können Sie die alten Daten wiederherstellen.

Modus Sichern: Die TNC speichert grundsätzlich immer die zuletzt unter MOD eingegebene Schlüsselzahl (beliebige Schlüsselzahl definierbar) mit ab. Sie können dann diesen Speicherplatz nur durch Eingabe dieser Schlüsselzahl wieder überschreiben. Wenn Sie eine Kinematik ohne Schlüsselzahl gesichert haben, dann überschreibt die TNC diesen Speicherplatz beim nächsten Sicherungsvorgang ohne Rückfrage!

Modus Herstellen: Gesicherte Daten kann die TNC grundsätzlich nur in eine identische Kinematikbeschreibung zurückschreiben.

Modus Herstellen: Beachten Sie, dass eine Änderung der Kinematik immer auch eine Änderung des Presets zur Folge hat. Preset ggf. neu setzen.


Zyklusparameter

Beispiel: NC-Sätze
5 TCH PROBE 450 KINEMATIK SICHERN
Q410=0 ;modus
Q409=1 ;speicherplatz

Modus (0/1/2) Q410: Festlegen, ob Sie eine Kinematik sichern oder wiederherstellen wollen: 0: Aktive Kinematik sichern 1: Eine gespeicherte Kinematik widerherstellen 2: Aktuellen Speicherstatus anzeigen

Speicherplatz (0…9) Q409: Nummer des Speicherplatzes, auf den Sie die gesamte Kinematik sichern wollen, bzw. Nummer des Speicherplatzes von dem Sie die gespeicherte Kinematik wiederherstellen wollen. Eingabebereich 0 bis 9, ohne Funktion, wenn Modus 2 gewählt ist


Protokollfunktion

    Die TNC erstellt nach dem Abarbeiten des Zyklus 450 ein Protokoll (tchpr450.txt), das folgende Daten enthält:

  • Datum und Uhrzeit, an dem das Protokoll erstellt wurde
  • Pfadname des NC-Programms, aus dem der Zyklus abgearbeitet wurde
  • Durchgeführter Modus (0=sichern/1=herstellen/2=Speicherstatus)
  • Nummer des Speicherplatzes (0 bis 9)
  • Zeilennummer der Kinematik aus der Kinematik-Tabelle
  • Schlüsselzahl, sofern Sie eine Schlüsselzahl direkt vor Ausführung von Zyklus 450 eingegeben haben

    Die weiteren Daten im Protokoll hängen vom gewählten Modus ab:

  • Modus 0:
    Protokollierung aller Achs- und Transformationseinträge der Kinematikkette, die die TNC gesichert hat
  • Modus 1:
    Protokollierung aller Transformationseinträge vor und nach der Wiederherstellung
  • Modus 2:
    Auflistung des aktuellen Speicherstatus am Bildschirm und im Textprotokoll mit Speicherplatznumer, Schlüsselzahlen, Kinematiknummer und Sicherungsdatum


KINEMATIK VERMESSEN (Zyklus 451, DIN/ISO: G451, Option)

Weitere Informationen:
> Zyklusablauf
> Positionierrichtung
> Maschinen mit hirthverzahnten-Achsen
> Wahl der Anzahl der Messpunkte
> Wahl der Position der Kalibrierkugel auf dem Maschinentisch
> Hinweise zur Genauigkeit
> Hinweise zu verschiedenen Kalibriermethoden
> Lose
> Beim Programmieren beachten!
> Zyklusparameter
> Verschiedene Modi (Q406)
> Protokollfunktion


Zyklusablauf

Mit dem Tastsystem-Zyklus 451 können Sie die Kinematik Ihrer Maschine prüfen und bei Bedarf optimieren. Dabei vermessen Sie mit dem 3D-Tastsystem TS eine HEIDENHAIN Kalibrierkugel, die Sie auf dem Maschinentisch befestigt haben.

HEIDENHAIN empfiehlt die Verwendung der Kalibrierkugeln KKH 250 (Bestell-Nummer 655 475-01) oder KKH 100 (Bestell-Nummer 655 475-02) , die eine besonders hohe Steifigkeit aufweisen und speziell für die Maschinenkalibrierung konstruiert wurden. Setzen Sie sich bei Interesse mit HEIDENHAIN in Verbindung.

Die TNC ermittelt die statische Schwenkgenauigkeit. Dabei minimiert die Software den durch die Schwenkbewegungen entstehenden Raumfehler und speichert die Maschinengeometrie am Ende des Messvorgangs automatisch in den jeweiligen Maschinenkonstanten der Kinematikbeschreibung ab.

  1. Kalibrierkugel aufspannen, auf Kollisionsfreiheit achten
  2. In der Betriebsart Manuell den Bezugspunkt in das Kugelzentrum setzen oder, wenn Q431=1 oder Q431=3 definiert ist: Tastsystem manuell in der Tastsystem-Achse über die Kalibrierkugel und in der Bearbeitungsebene in die Kugelmitte positionieren
  3. Programmlauf-Betriebsart wählen und Kalibrier-Programm starten
  4. Die TNC vermisst automatisch nacheinander alle Drehachsen in der von Ihnen definierten Feinheit. In einem Überblendfenster zeigt die TNC den aktuellen Status der Messung an. Die TNC blendet das Statusfenster aus, sobald ein Weg zu verfahren ist, der größer als der Tastkugelradius ist
  5. Die Messwerte speichert die TNC in folgenden Q-Parametern:
Parameter-Nummer | Bedeutung
Q141 | Gemessene Standardabweichung A‑Achse (-1, wenn Achse nicht vermessen wurde)
Q142 | Gemessene Standardabweichung B‑Achse (-1, wenn Achse nicht vermessen wurde)
Q143 | Gemessene Standardabweichung C‑Achse (-1, wenn Achse nicht vermessen wurde)
Q144 | Optimierte Standardabweichung A-Achse (-1, wenn Achse nicht optimiert wurde)
Q145 | Optimierte Standardabweichung B-Achse (-1, wenn Achse nicht optimiert wurde)
Q146 | Optimierte Standardabweichung C-Achse (-1, wenn Achse nicht optimiert wurde)
Q147 | Offsetfehler in X-Richtung, zur manuellen Übernahme in den entsprechenden Maschinen-Parameter
Q148 | Offsetfehler in Y-Richtung, zur manuellen Übernahme in den entsprechenden Maschinen-Parameter
Q149 | Offsetfehler in Z-Richtung, zur manuellen Übernahme in den entsprechenden Maschinen-Parameter


Positionierrichtung

Die Positionierrichtung der zu vermessenden Rundachse ergibt sich aus dem von Ihnen im Zyklus definierten Start- und Endwinkel. Bei 0° erfolgt automatisch eine Referenzmessung. Die TNC gibt einen Fehler aus, wenn sich durch die Wahl von Startwinkel, Endwinkel und Anzahl Messpunkte eine Messposition bei 0° ergibt.

Start- und Endwinkel so wählen, dass dieselbe Position von der TNC nicht doppelt vermessen wird. Eine doppelte Messpunktaufnahme (z.B. Messposition +90° und -270°) ist, wie erwähnt, nicht sinnvoll, führt jedoch zu keiner Fehlermeldung.

  • Beispiel: Startwinkel = +90°, Endwinkel = -90°
    • Startwinkel = +90°
    • Endwinkel = -90°
    • Anzahl Messpunkte = 4
    • Daraus berechneter Winkelschritt = (-90 - +90) / (4-1) = -60°
    • Messpunkt 1 = +90°
    • Messpunkt 2 = +30°
    • Messpunkt 3 = -30°
    • Messpunkt 4 = -90°
  • Beispiel: Startwinkel = +90°, Endwinkel = +270°
    • Startwinkel = +90°
    • Endwinkel = +270°
    • Anzahl Messpunkte = 4
    • Daraus berechneter Winkelschritt = (270 - 90) / (4-1) = +60°
    • Messpunkt 1 = +90°
    • Messpunkt 2 = +150°
    • Messpunkt 3 = +210°
    • Messpunkt 4 = +270°


Maschinen mit hirthverzahnten-Achsen

Achtung Kollisionsgefahr!

Zum Positionieren muss sich die Achse aus dem Hirthraster bewegen. Achten Sie deshalb auf einen ausreichend großen Sicherheits-Abstand, damit es zu keiner Kollision zwischen Tastsystem und Kalibrierkugel kommt. Gleichzeitig darauf achten, dass zum Anfahren des Sicherheits-Abstands genügend Platz ist (Software-Endschalter).

Rückzugshöhe Q408 größer 0 definieren, wenn Software-Option 2 (M128, function tcpm) nicht vefügbar ist.

Die TNC rundet ggf. die Messpositionen so, dass sie in das Hirth-Raster passen (abhängig von Startwinkel, Endwinkel und Anzahl Messpunkte).

Abhängig von der Maschinenkonfiguration kann die TNC die Drehachsen nicht automatisch positionieren. In diesem Fall benötigen Sie eine spezielle M-Funktion vom Maschinenhersteller, über die die TNC die Drehachsen bewegen kann. Im Maschinen-Parameter MP6602 muss der Maschinenhersteller dazu die Nummer der M-Funktion eingetragen haben.

Die Messpositionen errechnen sich aus Startwinkel, Endwinkel und Anzahl der Messungen für die jeweilige Achse und dem Hirth-Raster.

Rechenbeispiel Messpositionen für eine A-Achse:

Startwinkel Q411 = -30

Endwinkel Q412 = +90

Anzahl Messpunkte Q414 = 4

Hirth-Raster = 3°

Berechneter Winkelschritt = ( Q412 - Q411 ) / ( Q414 -1 )

Berechneter Winkelschritt = ( 90 - -30 ) / ( 4 - 1 ) = 120 / 3 = 40

Messposition 1 = Q411 + 0 * Winkelschritt = -30° --> -30°

Messposition 2 = Q411 + 1 * Winkelschritt = +10° --> 9°

Messposition 3 = Q411 + 2 * Winkelschritt = +50° --> 51°

Messposition 4 = Q411 + 3 * Winkelschritt = +90° --> 90°


Wahl der Anzahl der Messpunkte

Um Zeit zu sparen, können Sie eine Groboptimierung mit einer geringen Anzahl an Messpunkten (1-2) durchführen.

Eine anschließende Feinoptimierung führen Sie dann mit mittlerer Messpunktanzahl (empfohlener Wert = 4) durch. Eine noch höhere Messpunktanzahl bringt meist keine besseren Ergebnisse. Idealerweise sollten Sie die Messpunkte gleichmäßig über den Schwenkbereich der Achse verteilen.

Eine Achse mit einem Schwenkbereich von 0-360° vermessen Sie daher idealerweise mit 3 Messpunkten auf 90°, 180° und 270°.

Wenn Sie die Genauigkeit entsprechend prüfen wollen, dann können Sie im Modus Prüfen eine höhere Anzahl an Messpunkten angeben.

Sie dürfen einen Messpunkt nicht bei 0°, bzw. 360°, definieren. Diese Positionen liefern keine messtechnisch relevanten Daten und führen zu einer Fehlermeldung!


Wahl der Position der Kalibrierkugel auf dem Maschinentisch

    Prinzipiell können Sie die Kalibrierkugel an jeder zugänglichen Stelle auf dem Maschinentisch anbringen, aber auch auf Spannmitteln oder Werkstücken befestigen. Folgende Faktoren können das Messergebnis positiv beeinflussen:

  • Maschinen mit Rundtisch/Schwenktisch:
    Kalibrierkugel möglichst weit vom Drehzentrum entfernt aufspannen
  • Maschinen mit großen Verfahrwegen:
    Kalibrierkugel möglichst nahe an der späteren Bearbeitungsposition aufspannen


Hinweise zur Genauigkeit

Geometrie- und Positionierfehler der Maschine beeinflussen die Messwerte und damit auch die Optimierung einer Rundachse. Ein Restfehler, der sich nicht beseitigen lässt, wird somit immer vorhanden sein.

Geht man davon aus, dass Geometrie-, und Positionierfehler nicht vorhanden wären, wären die vom Zyklus ermittelten Werte an jedem beliebigen Punkt in der Maschine zu einem bestimmten Zeitpunkt exakt reproduzierbar. Je größer Geometrie- und Positionierfehler sind, desto größer wird die Streuung der Messergebnisse, wenn Sie die Messkugel an unterschiedlichen Positionen im Maschinenkoordinatensystem anbringen.

Die von der TNC im Messprotokoll ausgegebene Streuung ist ein Maß für die Genauigkeit der statischen Schwenkbewegungen einer Maschine. In die Genauigkeitsbetrachtung muss allerdings der Messkreisradius und auch Anzahl und Lage der Messpunkte mit einfließen. Bei nur einem Messpunkt lässt sich keine Streuung berechnen, die ausgegebene Streuung entspricht in diesem Fall dem Raumfehler des Messpunkts.

Bewegen sich mehrere Rundachsen gleichzeitig, so überlagern sich deren Fehler, im ungünstigsten Fall addieren sie sich.

Wenn Ihre Maschine mit einer geregelten Spindel ausgerüstet ist, sollten Sie die Winkelnachführung über Maschinen-Parameter MP6165 aktivieren. Dadurch erhöhen Sie generell die Genauigkeiten beim Messen mit einem 3D-Tastsystem.

Ggf. für die Dauer der Vermessung die Klemmung der Rundachsen deaktivieren, ansonsten können die Messergebnisse verfälscht werden. Maschinenhandbuch beachten.


Hinweise zu verschiedenen Kalibriermethoden

  • Groboptimierung während der Inbetriebnahme nach Eingabe ungefährer Maße
    • Messpunktanzahl zwischen 1 und 2
    • Winkelschritt der Drehachsen: Ca. 90°
  • Feinoptimierung über den kompletten Verfahrbereich
    • Messpunktanzahl zwischen 3 und 6
    • Start- und Endwinkel sollen einen möglichst großen Verfahrbereich der Drehachsen abdecken
    • Positionieren Sie die Kalibrierkugel so auf dem Maschinentisch, dass bei Tischdrehachsen ein großer Messkreisradius entsteht, bzw. dass bei Kopfdrehachsen die Vermessung an einer repräsentativen Position erfolgen kann (z.B. in der Mitte des Verfahrbereichs)
  • Optimierung einer speziellen Drehachsposition
    • Messpunktanzahl zwischen 2 und 3
    • Die Messungen erfolgen um den Drehachswinkel, bei dem die Bearbeitung später stattfinden soll
    • Positionieren Sie die Kalibrierkugel so auf dem Maschinentisch, dass die Kalibrierung an der Stelle stattfindet, an der auch die Bearbeitung stattfindet
  • Prüfen der Maschinengenauigkeit
    • Messpunktanzahl zwischen 4 und 8
    • Start- und Endwinkel sollen einen möglichst großen Verfahrbereich der Drehachsen abdecken
  • Ermittlung der Drehachslose
    • Messpunktanzahl zwischen 8 und 12
    • Start- und Endwinkel sollen einen möglichst großen Verfahrbereich der Drehachsen abdecken


Lose

Unter Lose versteht man ein geringfügiges Spiel zwischen Drehgeber (Winkelmessgerät) und Tisch, das bei einer Richtungsumkehr entsteht. Haben die Drehachsen eine Lose außerhalb der Regelstrecke, beispielsweise weil die Winkelmessung mit dem Motordrehgeber erfolgt, so kann das zu beträchtlichen Fehlern beim Schwenken führen.

Mit dem Eingabeparameter Q432 können Sie eine Messung der Lose aktivieren. Dazu geben Sie einen Winkel ein, den die TNC als Überfahrtswinkel verwendet. Der Zyklus führt dann pro Drehachse zwei Messungen aus. Wenn Sie den Winkelwert 0 übernehmen, dann ermittelt die TNC keine Lose.

Die TNC führt keine automatische Kompensation der Lose durch.

Ist der Messkreisradius < 1 mm, so führt die TNC keine Ermittlung der Lose mehr durch. Je größer der Messkreisradius ist, desto genauer kann die TNC die Drehachslose bestimmen (siehe auch Protokollfunktion).

Wenn Maschinen-Parameter MP6602 gesetzt ist, oder die Achse eine Hirth-Achse ist, dann ist keine Ermittlung der Lose möglich.


Beim Programmieren beachten!

Darauf achten, dass alle Funktionen zum Schwenken der Bearbeitungsebene zurückgesetzt sind. M128 oder FUNCTION TCPM werden ausgeschaltet.

Die Position der Kalibrierkugel auf dem Maschinentisch so wählen, dass beim Messvorgang keine Kollision erfolgen kann.

Vor der Zyklus-Definition müssen Sie den Bezugspunkt ins Zentrum der Kalibrierkugel gesetzt und diesen aktiviert haben, oder Sie definieren den Eingabeparameter Q431 entsprechend auf 1 oder 3.

Wenn Maschinen-Parameter MP6602 ungleich -1 (PLC-Makro positioniert Drehachsen) definiert ist, dann starten Sie eine Messung nur, wenn alle Drehachsen auf 0° stehen.

Die TNC verwendet als Positioniervorschub zum Anfahren der Antasthöhe in der Tastsystem-Achse den kleineren Wert aus Zyklus-Parameter Q253 und Maschinen-Parameter MP6150. Drehachsbewegungen führt die TNC grundsätzlich mit Positioniervorschub Q253 aus, dabei ist die Tasterüberwachung inaktiv.

Wenn im Modus Optimieren die ermittelten Kinematikdaten über dem erlaubten Grenzwert (MP6600) liegen, gibt die TNC eine Warnmeldung aus. Die Übernahme der ermittelten Werte müssen Sie dann mit NC-Start bestätigen.

Beachten Sie, dass eine Änderung der Kinematik immer auch eine Änderung des Presets zur Folge hat. Nach einer Optimierung den Preset neu setzen.

Die TNC ermittelt bei jedem Antastvorgang zunächst den Radius der Kalibrierkugel. Weicht der ermittelte Kugelradius vom eingegebenen Kugelradius mehr ab, als Sie im Maschinen-Parameter MP6601 definiert haben, gibt die TNC eine Fehlermeldung aus und beendet die Vermessung.

Wenn Sie den Zyklus während der Vermessung abbrechen, können sich ggf. die Kinematikdaten nicht mehr im ursprünglichen Zustand befinden. Sichern Sie die aktive Kinematik vor einer Optimierung mit Zyklus 450, damit Sie im Fehlerfall die zuletzt aktive Kinematik wieder herstellen können.

Inch-Programmierung: Messergebnisse und Protokolldaten gibt die TNC grundsätzlich in mm aus.

Die TNC ignoriert Angaben in der Zyklus-Definition für nicht aktive Achsen.


Zyklusparameter

Beispiel: Kalibrierprogramm
4 tool call “taster“ Z
5 TCH PROBE 450 KINEMATIK SICHERN
Q410=0 ;modus
Q409=5 ;speicherplatz
6 TCH PROBE 451 kinematik vermessen
Q406=1 ;modus
Q407=12.5 ;kugelradius
Q320=0 ;sicherheits-abst.
Q408=0 ;rueckzugshoehe
Q253=750 ;vorschub vorpos.
Q380=0 ;bezugswinkel
Q411=-90 ;startwinkel a-achse
Q412=+90 ;endwinkel A-achse
Q413=0 ;anstellw. a-achse
Q414=0 ;Messpunkte a-achse
Q415=-90 ;startwinkel b-achse
Q416=+90 ;endwinkel b-achse
Q417=0 ;anstellw. b-achse
Q418=2 ;Messpunkte b-achse
Q419=-90 ;startwinkel c-achse
Q420=+90 ;endwinkel c-achse
Q421=0 ;anstellw. c-achse
Q422=2 ;Messpunkte c-achse
Q423=4 ;ANZAHL MESSPUNKTE
Q431=1 ;preset setzen
Q432=0 ;WINKELBEREICH LOSE

Modus (0/1/2) Q406: Festlegen, ob die TNC die aktive Kinematik prüfen oder optimieren soll: 0: Aktive Maschinenkinematik prüfen. Die TNC vermisst die Kinematik in den von Ihnen definierten Drehachsen, führt jedoch keine Änderungen an der aktiven Kinematik durch. Die Messergebnisse zeigt die TNC in einem Messprotokoll an 1: Aktive Maschinenkinematik optimieren. Die TNC vermisst die Kinematik in den von Ihnen definierten Drehachsen und optimiert die Position der Drehachsen der aktiven Kinematik 2: Aktive Maschinenkinematik optimieren. Die TNC vermisst die Kinematik in den von Ihnen definierten Drehachsen und optimiert die Position und kompensiert den Winkel der Drehachsen der aktiven Kinematik. Option KinematicsComp muss für Modus 2 freigeschaltet sein

Exakter Kalibrierkugelradius Q407: Exakten Radius der verwendeten Kalibrierkugel eingeben. Eingabebereich 0,0001 bis 99,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Rückzugshöhe Q408 (absolut): Eingabebereich 0,0001 bis 99999,9999

  • Eingabe 0:
    Keine Rückszugshöhe anfahren, die TNC fährt die nächste Messposition in der zu vermessenden Achse an. Nicht erlaubt für Hirthachsen! Die TNC fährt die erste Messposition in der Reihenfolge A, dann B, dann C an
  • Eingabe >0:
    Rückzugshöhe im ungeschwenkten Werkstückkoordinatensystem, auf den die TNC vor einer Drehachspositionierung die Spindelachse positioniert. Zusätzlich positioniert die TNC das Tastsystem in der Bearbeitungsebene auf den Nullpunkt. Tasterüberwachung in diesem Modus nicht aktiv, Positioniergeschwindigkeit im Parameter Q253 definieren

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Positionieren in mm/min. Eingabebereich 0,0001 bis 99999,9999 alternativ fmax, fauto, predef

Bezugswinkel Q380 (absolut): Bezugswinkel (Grunddrehung) für die Erfassung der Messpunkte im wirksamen Werkstückkoordinatensystem. Das Definieren eines Bezugswinkels kann den Messbereich einer Achse erheblich vergrößern. Eingabebereich 0 bis 360,0000

Startwinkel A-Achse Q411 (absolut): Startwinkel in der A-Achse, an dem die erste Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Endwinkel A-Achse Q412 (absolut): Endwinkel in der A-Achse, an dem die letzte Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Anstellwinkel A-Achse Q413: Anstellwinkel der A-Achse, in dem die anderen Drehachsen vermessen werden sollen. Eingabebereich -359,999 bis 359,999

Anzahl Messpunkte A-Achse Q414: Anzahl der Antastungen, die die TNC zur Vermessung der A-Achse verwenden soll. Bei Eingabe = 0 führt die TNC keine Vermessung dieser Achse durch. Eingabebereich 0 bis 12

Startwinkel B-Achse Q415 (absolut): Startwinkel in der B-Achse, an dem die erste Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Endwinkel B-Achse Q416 (absolut): Endwinkel in der B-Achse, an dem die letzte Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Anstellwinkel B-Achse Q417: Anstellwinkel der B-Achse, in dem die anderen Drehachsen vermessen werden sollen. Eingabebereich -359,999 bis 359,999

Anzahl Messpunkte B-Achse Q418: Anzahl der Antastungen, die die TNC zur Vermessung der B-Achse verwenden soll. Bei Eingabe = 0 führt die TNC keine Vermessung dieser Achse durch. Eingabebereich 0 bis 12

Startwinkel C-Achse Q419 (absolut): Startwinkel in der C-Achse, an dem die erste Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Endwinkel C-Achse Q420 (absolut): Endwinkel in der C-Achse, an dem die letzte Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Anstellwinkel C-Achse Q421: Anstellwinkel der C-Achse, in dem die anderen Drehachsen vermessen werden sollen. Eingabebereich -359,999 bis 359,999

Anzahl Messpunkte C-Achse Q422: Anzahl der Antastungen, die die TNC zur Vermessung der C-Achse verwenden soll. Eingabebereich 0 bis 12. Bei Eingabe = 0 führt die TNC keine Vermessung dieser Achse durch

Anzahl Messpunkte Q423: Festlegen, mit wie vielen Antastungen die TNC die Kalibrierkugel in der Ebene Antastungen vermessen soll. Eingabebereich 3 bis 8 Messungen

Preset setzen (0/1/2/3) Q431: Festlegen, ob die TNC den aktiven Preset (Bezugspunkt) automatisch ins Kugelzentrum setzen soll: 0: Preset nicht automatisch ins Kugelzentrum setzen: Preset manuell vor Zyklusstart setzen 1: Preset vor der Vermessung automatisch ins Kugelzentrum setzen: Tastsystem manuell vor dem Zyklusstart über der Kalibrierkugel vorpositionieren 2: Preset nach der Vermessung automatisch ins Kugelzentrum setzen: Preset manuell vor Zyklusstart setzen 3: Preset vor und nach der Messung ins Kugelzentrum setzen: Tastsystem manuell vor dem Zyklusstart über der Kalibrierkugel vorpositionieren

Winkelbereich Lose Q432: Hier definieren Sie den Winkelwert, der als Überfahrt für die Messung der Drehachslose verwendet werden soll. Der Überfahrtswinkel muss deutlich größer sein, als die tatsächliche Lose der Drehachsen. Bei Eingabe = 0 führt die TNC keine Vermessung der Lose durch. Eingabebereich: -3,0000 bis +3,0000

Wenn Sie das Preset setzen vor der Vermessung aktiviert haben (Q431 = 1/3), dann positionieren Sie vor Zyklusstart das Tastsystem ungefähr mittig über die Kalibrierkugel.


Verschiedene Modi (Q406)

Beispiel: Winkel- und Positionsoptimierung der Drehachsen mit vorausgehendem automatischem Bezugspunktsetzen
1 tool call “tS640“ Z
2 TCH PROBE 451 kinematik vermessen
Q406=2 ;modus
Q407=12.5 ;kugelradius
Q320=0 ;sicherheits-abst.
Q408=0 ;rueckzugshoehe
Q253=750 ;vorschub vorpos.
Q380=0 ;bezugswinkel
Q411=-90 ;startwinkel a-achse
Q412=+90 ;endwinkel A-achse
Q413=0 ;anstellw. a-achse
Q414=0 ;Messpunkte a-achse
Q415=-90 ;startwinkel b-achse
Q416=+90 ;endwinkel b-achse
Q417=0 ;anstellw. b-achse
Q418=4 ;Messpunkte b-achse
Q419=+90 ;startwinkel c-achse
Q420=+270 ;endwinkel c-achse
Q421=0 ;anstellw. c-achse
Q422=3 ;Messpunkte c-achse
Q423=3 ;ANZAHL MESSPUNKTE
Q431=1 ;preset setzen
Q432=0 ;WINKELBEREICH LOSE
  • Modus „Prüfen“ Q406 = 0
    • Die TNC vermisst die Drehachsen in den definierten Positionen und ermittelt daraus die statische Genauigkeit der Schwenktransformation
    • Die TNC protokolliert Ergebnisse einer möglichen Positionsoptimierung, nimmt jedoch keine Anpassungen vor
  • Modus „Position“ optimieren Q406 = 1
    • Die TNC vermisst die Drehachsen in den definierten Positionen und ermittelt daraus die statische Genauigkeit der Schwenktransformation
    • Dabei versucht die TNC, die Position der Drehachse im Kinematikmodell so zu verändern, das eine höhere Genauigkeit erreicht wird
    • Die Anpassungen der Maschinendaten erfolgen automatisch
  • Modus „Position und Winkel“ optimieren Q406 = 2
    • Die TNC vermisst die Drehachsen in den definierten Positionen und ermittelt daraus die statische Genauigkeit der Schwenktransformation
    • Die TNC versucht zuerst, die Winkellage der Drehachse über eine Kompensation zu optimieren (Option #52 KinematicsComp).
    • Konnte die TNC eine Winkeloptimierung durchführen, so optimiert die TNC anschliessend die Position durch eine weitere Messreihe

Für eine Optimierung der Winkel muss der Maschinenhersteller die Konfiguration entsprechend angepasst haben. Ob das der Fall ist und ob eine Winkeloptimierung sinnvoll ist, erfragen Sie bei Ihrem Maschinenhersteller. Vor allem an kleinen, kompakten Maschinen kann eine Optimierung der Winkel Verbesserungen bringen.

Eine Kompensation der Winkel ist nur mit der Option #52 KinematicsComp möglich.


Protokollfunktion

    Die TNC erstellt nach dem Abarbeiten des Zyklus 451 ein Protokoll (TCHPR451.TXT), das folgende Daten enthält:

  • Datum und Uhrzeit, an dem das Protokoll erstellt wurde
  • Pfadname des NC-Programms, aus dem der Zyklus abgearbeitet wurde
  • Durchgeführter Modus (0=prüfen/1=Position optimieren/2=pose optimieren)
  • Aktive Kinematiknummer
  • Eingegebener Messkugelradius
  • Für jede vermessene Drehachse:
    • Startwinkel
    • Endwinkel
    • Anstellwinkel
    • Anzahl der Messpunkte
    • Streuung (Standardabweichung)
    • Maximaler Fehler
    • Winkelfehler
    • Gemittelte Lose
    • Gemittelter Positionierfehler
    • Messkreisradius
    • Korrekturbeträge in allen Achsen (Preset-Verschiebung)
    • Bewertung der Messpunkte
    • Messunsicherheit für Drehachsen
Weitere Informationen:
> Erläuterungen zu den Protokollwerten


Erläuterungen zu den Protokollwerten
  • Ausgaben der Fehler
    Im Modus Prüfen (Q406=0) gibt die TNC die durch eine Optimierung erreichbare Genauigkeit, bzw. bei einer Optimierung (Modus 1 und 2) die erzielten Genauigkeiten aus.
    Konnte die Winkellage einer Drehachse berechnet werden, dann erscheinen die gemessenen Daten ebenfalls im Protokoll.
  • Streuung
    Den aus der Statistik stammenden Begriff Streuung verwendet die TNC im Protokoll als Maß für die Genauigkeit. Die gemessene Streuung sagt aus, dass 68.3% der tatsächlich gemessenen Raumfehler innerhalb dieser angegebenen Streuung liegen (+/-). Die optimierte Streuung sagt aus, dass 68.3% der zu erwartenden Raumfehler nach der Korrektur der Kinematik innerhalb dieser angegebenen Streuung liegen (+/-).
  • Bewertung der Messpunkte Die Bewertungszahlen sind ein Maß für die Qualität der Messpositionen in Bezug auf die änderbaren Transformationen des Kinematikmodells. Je höher die Bewertungszahl ist, desto besser konnte die TNC die Optimierung berechnen. Die Bewertungszahl jeder Drehachse sollte einen Wert von 2 nicht unterschreiten, anzustreben sind Werte größer oder gleich 4. Sind die Bewertungszahlen zu klein, dann vergrößern Sie den Messbereich der Drehachse, oder auch die Anzahl der Messpunkte.

Sind die Bewertungszahlen zu klein, dann vergrößern Sie den Messbereich der Drehachse, oder auch die Anzahl der Messpunkte. Sollten Sie durch diese Maßnahme keine Verbesserung der Bewertungszahl erreichen, kann dies an einer fehlerhaften Kinematikbeschreibung liegen. Ggf. Kundendienst benachrichtigen.

Messunsicherheit für Winkel

Die Messunsicherheit gibt die TNC immer in Grad / 1 µm Systemunsicherheit an. Diese Information ist wichtig, um die Qualität der gemessenen Positionierfehler oder der Lose einer Drehachse abschätzen zu können.

In die Systemunsicherheit fließen mindestens die Wiederholgenauigkeiten der Achsen (Lose), bzw. die Positionsunsicherheit der Linearachsen (Positionierfehler) sowie die des Messtasters ein. Da der TNC die Genauigkeit des Gesamtsystems nicht bekannt ist, müssen Sie eine eigene Abschätzung durchführen.

  • Beispiel für die Unsicherheit der errechneten Positionierfehler:
    • Positionsunsicherheit jeder Linearachse: 10µm
    • Unsicherheit des Messtasters: 2µm
    • protokollierte Messunsicherheit: 0,0002 °/µm
    • Systemunsicherheit = SQRT( 3 * 10² + 2² ) = 17,4 µm
    • Messunsicherheit = 0,0002 °/µm * 17,4 µm = 0,0034°
  • Beispiel für die Unsicherheit der errechneten Lose:
    • Wiederholgenauigkeit jeder Linearachse: 5 µm
    • Unsicherheit des Messtasters: 2 µm
    • protokollierte Messunsicherheit: 0,0002 °/µm
    • Systemunsicherheit = SQRT( 3 * 5² + 2² ) = 8,9 µm
    • Messunsicherheit = 0,0002 °/µm * 8,9 µm = 0,0018°


PRESET-KOMPENSATION (Zyklus 452, DIN/ISO: G452, Option)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter
> Abgleich von Wechselköpfen
> Driftkompensation
> Protokollfunktion


Zyklusablauf

Mit dem Tastsystem-Zyklus 452 können Sie die kinematische Transformationskette Ihrer Maschine optimieren (siehe KINEMATIK VERMESSEN (Zyklus 451, DIN/ISO: G451, Option)). Anschließend korrigiert die TNC ebenfalls im Kinematikmodell das Werkstückkoordinatensystem so, daß der aktuelle Preset nach der Optimierung im Zentrum der Kalibrierkugel ist.

Mit diesem Zyklus können Sie beispielsweise Wechselköpfe untereinander abstimmen.

  1. Kalibrierkugel aufspannen
  2. Referenzkopf mit Zyklus 451 vollständig vermessen und abschließend vom Zyklus 451 den Preset in das Kugelzentrum setzen lassen
  3. Zweiten Kopf einwechseln
  4. Wechselkopf mit Zyklus 452 bis zur Kopfwechsel-Schnittstelle vermessen
  5. weitere Wechselköpfe mit Zyklus 452 an den Referenzkopf angleichen

Wenn Sie während der Bearbeitung die Kalibrierkugel auf dem Maschinentisch aufgespannt lassen können, so können Sie beispielsweise eine Drift der Maschine kompensieren. Dieser Vorgang ist auch auf einer Maschine ohne Drehachsen möglich.

  1. Kalibrierkugel aufspannen, auf Kollisionsfreiheit achten
  2. Preset in der Kalibrierkugel setzen
  3. Preset am Werkstück setzen und Bearbeitung des Werkstücks starten
  4. Die TNC vermisst automatisch nacheinander alle Drehachsen in der von Ihnen definierten Feinheit. In einem Überblendfenster zeigt die TNC den aktuellen Status der Messung an. Die TNC blendet das Statusfenster aus, sobald ein Weg zu verfahren ist, der größer als der Tastkugelradius ist
  5. Mit Zyklus 452 in regelmäßigen Abständen eine Presetkompensation ausführen. Dabei erfaßt die TNC die Drift der beteiligten Achsen und korrigiert diese in der Kinematik
Parameter-Nummer | Bedeutung
Q141 | Gemessene Standardabweichung A‑Achse (-1, wenn Achse nicht vermessen wurde)
Q142 | Gemessene Standardabweichung B‑Achse (-1, wenn Achse nicht vermessen wurde)
Q143 | Gemessene Standardabweichung C‑Achse (-1, wenn Achse nicht vermessen wurde)
Q144 | Optimierte Standardabweichung A-Achse (-1, wenn Achse nicht vermessen wurde)
Q145 | Optimierte Standardabweichung B-Achse (-1, wenn Achse nicht vermessen wurde)
Q146 | Optimierte Standardabweichung C-Achse (-1, wenn Achse nicht vermessen wurde)
Q147 | Offsetfehler in X-Richtung, zur manuellen Übernahme in den entsprechenden Maschinen-Parameter
Q148 | Offsetfehler in Y-Richtung, zur manuellen Übernahme in den entsprechenden Maschinen-Parameter
Q149 | Offsetfehler in Z-Richtung, zur manuellen Übernahme in den entsprechenden Maschinen-Parameter


Beim Programmieren beachten!

Um eine Presetkompensation durchführen zu können, muß die Kinematik entsprechend vorbereitet sein. Maschinenhandbuch beachten.

Darauf achten, dass alle Funktionen zum Schwenken der Bearbeitungsebene zurückgesetzt sind. M128 oder FUNCTION TCPM werden ausgeschaltet.

Die Position der Kalibrierkugel auf dem Maschinentisch so wählen, dass beim Messvorgang keine Kollision erfolgen kann.

Vor der Zyklus-Definition müssen Sie den Bezugspunkt ins Zentrum der Kalibrierkugel gesetzt und diesen aktiviert haben.

Wählen Sie bei Achsen ohne separatem Lagemesssystem die Messpunkte so, daß Sie 1 Grad Verfahrweg bis zum Endschalter haben. Die TNC benötigt diesen Weg für die interne Lose-Kompensation.

Die TNC verwendet als Positioniervorschub zum Anfahren der Antasthöhe in der Tastsystem-Achse den kleineren Wert aus Zyklus-Parameter Q253 und Maschinen-Parameter MP6150. Drehachsbewegungen führt die TNC grundsätzlich mit Positioniervorschub Q253 aus, dabei ist die Tasterüberwachung inaktiv.

Wenn im Modus Optimieren die ermittelten Kinematikdaten über dem erlaubten Grenzwert (MP6600) liegen, gibt die TNC eine Warnmeldung aus. Die Übernahme der ermittelten Werte müssen Sie dann mit NC-Start bestätigen.

Beachten Sie, dass eine Änderung der Kinematik immer auch eine Änderung des Presets zur Folge hat. Nach einer Optimierung den Preset neu setzen.

Die TNC ermittelt bei jedem Antastvorgang zunächst den Radius der Kalibrierkugel. Weicht der ermittelte Kugelradius vom eingegebenen Kugelradius mehr ab, als Sie im Maschinen-Parameter MP6601 definiert haben, gibt die TNC eine Fehlermeldung aus und beendet die Vermessung.

Wenn Sie den Zyklus während der Vermessung abbrechen, können sich ggf. die Kinematikdaten nicht mehr im ursprünglichen Zustand befinden. Sichern Sie die aktive Kinematik vor einer Optimierung mit Zyklus 450, damit Sie im Fehlerfall die zuletzt aktive Kinematik wieder herstellen können.

Inch-Programmierung: Messergebnisse und Protokolldaten gibt die TNC grundsätzlich in mm aus.


Zyklusparameter

Beispiel: Kalibrierprogramm
4 tool call “taster“ Z
5 TCH PROBE 450 KINEMATIK SICHERN
Q410=0 ;modus
Q409=5 ;speicherplatz
6 TCH PROBE 452 preset-kompensation
Q407=12.5 ;kugelradius
Q320=0 ;sicherheits-abst.
Q408=0 ;rueckzugshoehe
Q253=750 ;vorschub vorpos.
Q380=0 ;bezugswinkel
Q411=-90 ;startwinkel a-achse
Q412=+90 ;endwinkel A-achse
Q413=0 ;anstellw. a-achse
Q414=0 ;Messpunkte a-achse
Q415=-90 ;startwinkel b-achse
Q416=+90 ;endwinkel b-achse
Q417=0 ;anstellw. b-achse
Q418=2 ;Messpunkte b-achse
Q419=-90 ;startwinkel c-achse
Q420=+90 ;endwinkel c-achse
Q421=0 ;anstellw. c-achse
Q422=2 ;Messpunkte c-achse
Q423=4 ;ANZAHL MESSPUNKTE
Q432=0 ;WINKELBEREICH LOSE

Exakter Kalibrierkugelradius Q407: Exakten Radius der verwendeten Kalibrierkugel eingeben. Eingabebereich 0,0001 bis 99,9999

Sicherheits-Abstand Q320 (inkremental): Zusätzlicher Abstand zwischen Messpunkt und Tastsystemkugel. Q320 wirkt additiv zu MP6140. Eingabebereich 0 bis 99999,9999 alternativ predef

Rückzugshöhe Q408 (absolut): Eingabebereich 0,0001 bis 99999,9999

  • Eingabe 0:
    Keine Rückszugshöhe anfahren, die TNC fährt die nächste Messposition in der zu vermessenden Achse an. Nicht erlaubt für Hirthachsen! Die TNC fährt die erste Messposition in der Reihenfolge A, dann B, dann C an
  • Eingabe >0:
    Rückzugshöhe im ungeschwenkten Werkstückkoordinatensystem, auf den die TNC vor einer Drehachspositionierung die Spindelachse positioniert. Zusätzlich positioniert die TNC das Tastsystem in der Bearbeitungsebene auf den Nullpunkt. Tasterüberwachung in diesem Modus nicht aktiv, Positioniergeschwindigkeit im Parameter Q253 definieren

Vorschub Vorpositionieren Q253: Verfahrgeschwindigkeit des Werkzeugs beim Positionieren in mm/min. Eingabebereich 0,0001 bis 99999,9999 alternativ fmax, fauto predef

Bezugswinkel Q380 (absolut): Bezugswinkel (Grunddrehung) für die Erfassung der Messpunkte im wirksamen Werkstückkoordinatensystem. Das Definieren eines Bezugswinkels kann den Messbereich einer Achse erheblich vergrößern. Eingabebereich 0 bis 360,0000

Startwinkel A-Achse Q411 (absolut): Startwinkel in der A-Achse, an dem die erste Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Endwinkel A-Achse Q412 (absolut): Endwinkel in der A-Achse, an dem die letzte Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Anstellwinkel A-Achse Q413: Anstellwinkel der A-Achse, in dem die anderen Drehachsen vermessen werden sollen. Eingabebereich -359,999 bis 359,999

Anzahl Messpunkte A-Achse Q414: Anzahl der Antastungen, die die TNC zur Vermessung der A-Achse verwenden soll. Bei Eingabe = 0 führt die TNC keine Vermessung dieser Achse durch. Eingabebereich 0 bis 12

Startwinkel B-Achse Q415 (absolut): Startwinkel in der B-Achse, an dem die erste Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Endwinkel B-Achse Q416 (absolut): Endwinkel in der B-Achse, an dem die letzte Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Anstellwinkel B-Achse Q417: Anstellwinkel der B-Achse, in dem die anderen Drehachsen vermessen werden sollen. Eingabebereich -359,999 bis 359,999

Anzahl Messpunkte B-Achse Q418: Anzahl der Antastungen, die die TNC zur Vermessung der B-Achse verwenden soll. Bei Eingabe = 0 führt die TNC keine Vermessung dieser Achse durch. Eingabebereich 0 bis 12

Startwinkel C-Achse Q419 (absolut): Startwinkel in der C-Achse, an dem die erste Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Endwinkel C-Achse Q420 (absolut): Endwinkel in der C-Achse, an dem die letzte Messung erfolgen soll. Eingabebereich -359,999 bis 359,999

Anstellwinkel C-Achse Q421: Anstellwinkel der C-Achse, in dem die anderen Drehachsen vermessen werden sollen. Eingabebereich -359,999 bis 359,999

Anzahl Messpunkte C-Achse Q422: Anzahl der Antastungen, die die TNC zur Vermessung der C-Achse verwenden soll. Bei Eingabe = 0 führt die TNC keine Vermessung dieser Achse durch. Eingabebereich 0 bis 12

Anzahl Messpunkte Q423: Festlegen, mit wie vielen Antastungen die TNC die Kalibrierkugel in der Ebene Antastungen vermessen soll. Eingabebereich 3 bis 8 Messungen

Winkelbereich Lose Q432: Hier definieren Sie den Winkelwert, der als Überfahrt für die Messung der Drehachslose verwendet werden soll. Der Überfahrtswinkel muss deutlich größer sein, als die tatsächliche Lose der Drehachsen. Bei Eingabe = 0 führt die TNC keine Vermessung der Lose durch. Eingabebereich: -3,0000 bis +3,0000


Abgleich von Wechselköpfen

Beispiel: Referenzkopf vermessen
1 tool call “taster“ Z
2 TCH PROBE 451 KINEMATIK VERMESSEN
Q406=1 ;MODUS
Q407=12.5 ;KUGELRADIUS
Q320=0 ;SICHERHEITS-ABST.
Q408=0 ;RUECKZUGSHOEHE
Q253=2000 ;VORSCHUB VORPOS.
Q380=45 ;BEZUGSWINKEL
Q411=-90 ;STARTWINKEL A-ACHSE
Q412=+90 ;ENDWINKEL A-ACHSE
Q413=45 ;ANSTELLW. A-ACHSE
Q414=4 ;MESSPUNKTE A-ACHSE
Q415=-90 ;STARTWINKEL B-ACHSE
Q416=+90 ;ENDWINKEL B-ACHSE
Q417=0 ;ANSTELLW. B-ACHSE
Q418=2 ;MESSPUNKTE B-ACHSE
Q419=+90 ;STARTWINKEL C-ACHSE
Q420=+270 ;ENDWINKEL C-ACHSE
Q421=0 ;ANSTELLW. C-ACHSE
Q422=3 ;MESSPUNKTE C-ACHSE
Q423=4 ;ANZAHL MESSPUNKTE
Q431=3 ;PRESET SETZEN
Q432=0 ;WINKELBEREICH LOSE

Die Zielsetzung dieses Vorgangs ist, daß nach dem Wechseln von Drehachsen (Kopfwechsel) der Preset am Werkstück unverändert ist

Im folgenden Beispiel wird der Abgleich eines Gabelkopfes mit den Achsen AC beschrieben. Die A-Achsen werden gewechselt, die C-Achse bleibt an der Grundmaschine.

  • Einwechseln einer der Wechselköpfe, der dann als Referenzkopf dient

  • Kalibrierkugel aufspannen

  • Tastsystem einwechseln

  • Vermessen Sie die vollständige Kinematik mit dem Referenzkopf mittels Zyklus 451

  • Setzen Sie den Preset (mit Q431 = 2 oder 3 in Zyklus 451) nach dem Vermessen des Referenzkopfes

Beispiel: Wechselkopf abgleichen
3 tool call “taster“ Z
4 TCH PROBE 452 PRESET-KOMPENSATION
Q407=12.5 ;KUGELRADIUS
Q320=0 ;SICHERHEITS-ABST.
Q408=0 ;RUECKZUGSHOEHE
Q253=2000 ;VORSCHUB VORPOS.
Q380=45 ;BEZUGSWINKEL
Q411=-90 ;STARTWINKEL A-ACHSE
Q412=+90 ;ENDWINKEL A-ACHSE
Q413=45 ;ANSTELLW. A-ACHSE
Q414=4 ;MESSPUNKTE A-ACHSE
Q415=-90 ;STARTWINKEL B-ACHSE
Q416=+90 ;ENDWINKEL B-ACHSE
Q417=0 ;ANSTELLW. B-ACHSE
Q418=2 ;MESSPUNKTE B-ACHSE
Q419=+90 ;STARTWINKEL C-ACHSE
Q420=+270 ;ENDWINKEL C-ACHSE
Q421=0 ;ANSTELLW. C-ACHSE
Q422=0 ;MESSPUNKTE C-ACHSE
Q423=4 ;ANZAHL MESSPUNKTE
Q432=0 ;WINKELBEREICH LOSE

  • Einwechseln des zweiten Wechselkopfes

  • Tastsystem einwechseln

  • Wechselkopf mit Zyklus 452 vermessen

  • Vermessen Sie nur die Achsen, die tatsächlich gewechselt wurden (im Beispiel nur die A-Achse, die C-Achse ist mit Q422 augeblendet)

  • Den Preset und die Position der Kalibrierkugel dürfen Sie während des gesamten Vorgangs nicht verändern

  • Alle weiteren Wechselköpfe können Sie auf die gleiche Weise angepassen

Der Kopfwechsel ist eine maschinenspezifische Funktion. Beachten Sie das Maschinenhandbuch.


Driftkompensation

Beispiel: Referenzmessung für Driftkompensation
1 tool call “taster“ Z
2 CYCL DEF 247 BEZUGSPUNKT SETZEN
Q339=1 ;BEZUGSPUNKT-NUMMER
3 TCH PROBE 451 KINEMATIK VERMESSEN
Q406=1 ;MODUS
Q407=12.5 ;KUGELRADIUS
Q320=0 ;SICHERHEITS-ABST.
Q408=0 ;RUECKZUGSHOEHE
Q253=750 ;VORSCHUB VORPOS.
Q380=45 ;BEZUGSWINKEL
Q411=+90 ;STARTWINKEL A-ACHSE
Q412=+270 ;ENDWINKEL A-ACHSE
Q413=45 ;ANSTELLW. A-ACHSE
Q414=4 ;MESSPUNKTE A-ACHSE
Q415=-90 ;STARTWINKEL B-ACHSE
Q416=+90 ;ENDWINKEL B-ACHSE
Q417=0 ;ANSTELLW. B-ACHSE
Q418=2 ;MESSPUNKTE B-ACHSE
Q419=+90 ;STARTWINKEL C-ACHSE
Q420=+270 ;ENDWINKEL C-ACHSE
Q421=0 ;ANSTELLW. C-ACHSE
Q422=3 ;MESSPUNKTE C-ACHSE
Q423=4 ;ANZAHL MESSPUNKTE
Q431=3 ;PRESET SETZEN
Q432=0 ;WINKELBEREICH LOSE

Während der Bearbeitung unterliegen verschiedene Bauteile einer Maschine aufgrund von sich ändernden Umgebungseinflüssen einer Drift. Ist die Drift über den Verfahrbereich ausreichend konstant und kann während der Bearbeitung die Kalibrierkugel auf dem Maschinentisch stehen bleiben, so lässt sich diese Drift mit Zyklus 452 erfassen und kompensieren.

  • Kalibrierkugel aufspannen

  • Tastsystem einwechseln

  • Vermessen Sie die Kinematik vollständig mit Zyklus 451 bevor Sie mit der Bearbeitung beginnen

  • Setzen Sie den Preset (mit Q432 = 2 oder 3 in Zyklus 451) nach dem Vermessen der Kinematik

  • Setzen Sie dann die Presets für Ihre Werkstücke und starten Sie die Bearbeitung
Beispiel: Drift kompensieren
4 tool call “taster“ Z
5 TCH PROBE 452 PRESET-KOMPENSATION
Q407=12.5 ;KUGELRADIUS
Q320=0 ;SICHERHEITS-ABST.
Q408=0 ;RUECKZUGSHOEHE
Q253=99999 ;VORSCHUB VORPOS.
Q380=45 ;BEZUGSWINKEL
Q411=-90 ;STARTWINKEL A-ACHSE
Q412=+90 ;ENDWINKEL A-ACHSE
Q413=45 ;ANSTELLW. A-ACHSE
Q414=4 ;MESSPUNKTE A-ACHSE
Q415=-90 ;STARTWINKEL B-ACHSE
Q416=+90 ;ENDWINKEL B-ACHSE
Q417=0 ;ANSTELLW. B-ACHSE
Q418=2 ;MESSPUNKTE B-ACHSE
Q419=+90 ;STARTWINKEL C-ACHSE
Q420=+270 ;ENDWINKEL C-ACHSE
Q421=0 ;ANSTELLW. C-ACHSE
Q422=3 ;MESSPUNKTE C-ACHSE
Q423=3 ;ANZAHL MESSPUNKTE
Q432=0 ;WINKELBEREICH LOSE

  • Erfassen Sie in regelmäßigen Intervallen die Drift der Achsen

  • Tastsystem einwechseln

  • Preset in der Kalibrierkugel aktivieren

  • Vermessen Sie mit Zyklus 452 die Kinematik

  • Den Preset und die Position der Kalibrierkugel dürfen Sie während des gesamten Vorgangs nicht verändern

Dieser Vorgang ist auch möglich auf Maschinen ohne Drehachsen


Protokollfunktion

    Die TNC erstellt nach dem Abarbeiten des Zyklus 452 ein Protokoll (TCHPR452.TXT), das folgende Daten enthält:

  • Datum und Uhrzeit, an dem das Protokoll erstellt wurde
  • Pfadname des NC-Programms, aus dem der Zyklus abgearbeitet wurde
  • Aktive Kinematiknummer
  • Eingegebener Messkugelradius
  • Für jede vermessene Drehachse:
    • Startwinkel
    • Endwinkel
    • Anstellwinkel
    • Anzahl der Messpunkte
    • Streuung (Standardabweichung)
    • Maximaler Fehler
    • Winkelfehler
    • Gemittelte Lose
    • Gemittelter Positionierfehler
    • Messkreisradius
    • Korrekturbeträge in allen Achsen (Preset-Verschiebung)
    • Bewertung der Messpunkte
    • Messunsicherheit für Drehachsen
Weitere Informationen:
> Erläuterungen zu den Protokollwerten


Erläuterungen zu den Protokollwerten

(siehe Erläuterungen zu den Protokollwerten)


Tastsystemzyklen: Werkzeuge automatisch vermessen

Weitere Informationen:
> Grundlagen
> TT kalibrieren (Zyklus 30 oder 480, DIN/ISO: G480)
> Kabelloses TT 449 kalibrieren (Zyklus 484, DIN/ISO: G484)
> Werkzeug-Länge vermessen (Zyklus 31 oder 481, DIN/ISO: G481)
> Werkzeug-Radius vermessen (Zyklus 32 oder 482, DIN/ISO: G482)
> Werkzeug komplett vermessen (Zyklus 33 oder 483, DIN/ISO: G483)


Grundlagen

Weitere Informationen:
> Übersicht
> Unterschiede zwischen den Zyklen 31 bis 33 und 481 bis 483
> Maschinen-Parameter einstellen
> Eingaben in der Werkzeug-Tabelle TOOL.T
> Messergebnisse anzeigen


Übersicht

Maschine und TNC müssen vom Maschinenhersteller für das Tastsystem TT vorbereitet sein.

Ggf. stehen an Ihrer Maschine nicht alle hier beschriebenen Zyklen und Funktionen zur Verfügung. Beachten Sie Ihr Maschinenhandbuch.

Mit dem Tischtastsystem und den Werkzeug-Vermessungszyklen der TNC vermessen Sie Werkzeuge automatisch: Die Korrekturwerte für Länge und Radius werden von der TNC im zentralen Werkzeugspeicher TOOL.T abgelegt und automatisch am Ende des Antast-Zyklus verrechnet. Folgende Vermessungsarten stehen zur Verfügung:

  • Werkzeug-Vermessung mit stillstehendem Werkzeug
  • Werkzeug-Vermessung mit rotierendem Werkzeug
  • Einzelschneiden-Vermessung

Die Zyklen zur Werkzeug-Vermessung programmieren Sie in der Betriebsart Programm-Einspeichern/Editieren über die Taste TOUCH PROBE. Folgende Zyklen stehen zur Verfügung:

Zyklus | Neues Format | Altes Format | Seite
TT kalibrieren, Zyklen 30 und 480 |  |  | TT kalibrieren (Zyklus 30 oder 480, DIN/ISO: G480)
Kabelloses TT 449 kalibrieren, Zyklus 484 |  |  | Kabelloses TT 449 kalibrieren (Zyklus 484, DIN/ISO: G484)
Werkzeug-Länge vermessen, Zyklen 31 und 481 |  |  | Werkzeug-Länge vermessen (Zyklus 31 oder 481, DIN/ISO: G481)
Werkzeug-Radius vermessen, Zyklen 32 und 482 |  |  | Werkzeug-Radius vermessen (Zyklus 32 oder 482, DIN/ISO: G482)
Werkzeug-Länge und -Radius vermessen, Zyklen 33 und 483 |  |  | Werkzeug komplett vermessen (Zyklus 33 oder 483, DIN/ISO: G483)

Die Vermessungszyklen arbeiten nur bei aktivem zentralen Werkzeugspeicher TOOL.T.

Bevor Sie mit den Vermessungszyklen arbeiten, müssen Sie alle zur Vermessung erforderlichen Daten im zentralen Werkzeugspeicher eingetragen und das zu vermessende Werkzeug mit TOOL CALL aufgerufen haben.

Sie können Werkzeuge auch bei geschwenkter Bearbeitungsebene vermessen.


Unterschiede zwischen den Zyklen 31 bis 33 und 481 bis 483

Der Funktionsumfang und der Zyklus-Ablauf ist absolut identisch. Zwischen den Zyklen 31 bis 33 und 481 bis 483 bestehen lediglich die zwei folgenden Unterschiede:

  • Die Zyklen 481 bis 483 stehen unter G481 bis G483 auch in DIN/ISO zur Verfügung
  • Anstelle eines frei wählbaren Parameters für den Status der Messung verwenden die neuen Zyklen den festen Parameter Q199


Maschinen-Parameter einstellen

Die TNC verwendet für die Vermessung mit stehender Spindel den Antast-Vorschub aus MP6520.

Beim Vermessen mit rotierendem Werkzeug berechnet die TNC die Spindeldrehzahl und den Antast-Vorschub automatisch.

Die Spindeldrehzahl berechnet sich dabei wie folgt:

n = MP6570 / ( r • 0,0063) mit

n | Drehzahl [U/min]
MP6570 | Maximal zulässige Umlaufgeschwindigkeit [m/min]
r | Aktiver Werkzeug-Radius [mm]

Der Antast-Vorschub berechnet sich aus:v = Messtoleranz • n mit

v | Antast-Vorschub [mm/min]
Messtoleranz | Messtoleranz [mm], abhängig von MP6507
n | Drehzahl [1/min]

Mit MP6507 stellen Sie die Berechnung des Antast-Vorschubs ein:

MP6507=0:

Die Messtoleranz bleibt konstant – unabhängig vom Werkzeug-Radius. Bei sehr großen Werkzeugen reduziert sich der Antast-Vorschub jedoch zu Null. Dieser Effekt macht sich um so früher bemerkbar, je kleiner Sie die maximale Umlaufgeschwindigkeit (MP6570) und die zulässige Toleranz (MP6510) wählen.

MP6507=1:

Die Messtoleranz verändert sich mit zunehmendem Werkzeug-Radius. Das stellt auch bei großen Werkzeug-Radien noch einen ausreichenden Antast-Vorschub sicher. Die TNC verändert die Messtoleranz nach folgender Tabelle:

Werkzeug-Radius | Messtoleranz
bis 30 mm | MP6510
30 bis 60 mm | 2 • MP6510
60 bis 90 mm | 3 • MP6510
90 bis 120 mm | 4 • MP6510

MP6507=2:

Der Antast-Vorschub bleibt konstant, der Messfehler wächst jedoch linear mit größer werdendem Werkzeug-Radius:

Messtoleranz = (r • MP6510)/ 5 mm) mit

r | Aktiver Werkzeug-Radius [mm]
MP6510 | Maximal zulässiger Messfehler


Eingaben in der Werkzeug-Tabelle TOOL.T

Abk. | Eingaben | Dialog
CUT | Anzahl der Werkzeug-Schneiden (max. 20 Schneiden) | Anzahl der Schneiden?
LTOL | Zulässige Abweichung von der Werkzeug-Länge L für Verschleiß-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status L). Eingabebereich: 0 bis 0,9999 mm | Verschleiß-Toleranz: Länge?
RTOL | Zulässige Abweichung vom Werkzeug-Radius R für Verschleiß-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status l). Eingabebereich: 0 bis 0,9999 mm | Verschleiß-Toleranz: Radius?
DIRECT. | Schneid-Richtung des Werkzeugs für Vermessung mit drehendem Werkzeug | Schneid-Richtung (M3 = –)?
TT:R-OFFS | Längenvermessung: Versatz des Werkzeugs zwischen Stylus-Mitte und Werkzeug-Mitte. Voreinstellung: Werkzeug-Radius R (Taste NO ENT erzeugt R) | Werkzeug-Versatz Radius?
TT:L-OFFS | Radiusvermessung: zusätzlicher Versatz des Werkzeugs zu MP6530 zwischen Stylus-Oberkante und Werkzeug-Unterkante. Voreinstellung: 0 | Werkzeug-Versatz Länge?
LBREAK | Zulässige Abweichung von der Werkzeug-Länge L für Bruch-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status L). Eingabebereich: 0 bis 0,9999 mm | Bruch-Toleranz: Länge?
RBREAK | Zulässige Abweichung vom Werkzeug-Radius R für Bruch-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status l). Eingabebereich: 0 bis 0,9999 mm | Bruch-Toleranz: Radius?
Weitere Informationen:
> Eingabebeispiele für gängige Werkzeug-Typen


Eingabebeispiele für gängige Werkzeug-Typen
Werkzeug-Typ | CUT | TT:R-OFFS | TT:L-OFFS
Bohrer | – (ohne Funktion) | 0 (kein Versatz erforderlich, da Bohrerspitze gemessen werden soll) |
Zylinderfräser mit Durchmesser < 19 mm | 4 (4 Schneiden) | 0 (kein Versatz erforderlich, da Werkzeug-Durchmesser kleiner ist als der Tellerdurchmesser des TT) | 0 (kein zusätzlicher Versatz bei der Radiusvermessung erforderlich. Versatz wird aus MP6530 verwendet)
Zylinderfräser mit Durchmesser > 19 mm | 4 (4 Schneiden) | R (Versatz erforderlich, da Werkzeug-Durchmesser größer ist als der Tellerdurchmesser des TT) | 0 (kein zusätzlicher Versatz bei der Radiusvermessung erforderlich. Versatz wird aus MP6530 verwendet)
Radiusfräser | 4 (4 Schneiden) | 0 (kein Versatz erforderlich, da Kugel-Südpol gemessen werden soll) | 5 (immer Werkzeug-Radius als Versatz definieren, damit der Durchmesser nicht im Radius gemessen wird)


Messergebnisse anzeigen

In der zusätzlichen Status-Anzeige können Sie die Ergebnisse der Werkzeug-Vermessung einblenden (in den Maschinen-Betriebsarten). Die TNC zeigt dann links das Programm und rechts die Messergebnisse an. Messwerte, die die zulässige Verschleißtoleranz überschritten haben, kennzeichnet die TNC mit einem „*“– Messwerte, die die zulässige Bruchtoleranz überschritten haben, mit einem „B“.


TT kalibrieren (Zyklus 30 oder 480, DIN/ISO: G480)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Das TT kalibrieren Sie mit dem Messzyklus TCH PROBE 30 oder TCH PROBE 480 (siehe auch Unterschiede zwischen den Zyklen 31 bis 33 und 481 bis 483). Der Kalibrier-Vorgang läuft automatisch ab. Die TNC ermittelt auch automatisch den Mittenversatz des Kalibrierwerkzeugs. Dazu dreht die TNC die Spindel nach der Hälfte des Kalibrier-Zyklus um 180°.

Als Kalibrier-Werkzeug verwenden Sie ein exakt zylindrisches Teil, z.B. einen Zylinderstift. Die Kalibrier-Werte speichert die TNC und berücksichtigt sie bei nachfolgenden Werkzeug-Vermessungen.

Das Kalibrierwerkzeug sollte einen Durchmesser größer 15 mm besitzen und ca. 50 mm aus dem Spannfutter herausstehen. Bei dieser Konstellation entsteht eine Verbiegung von 0.1 µm pro 1 N Antastkraft.


Beim Programmieren beachten!

Die Funktionsweise des Kalibrierzyklus ist abhängig von Maschinen-Parameter 6500. Beachten Sie Ihr Maschinenhandbuch.

Bevor Sie kalibrieren, müssen Sie den genauen Radius und die genaue Länge des Kalibrier-Werkzeugs in der Werkzeug-Tabelle TOOL.T eintragen.

In den Maschinen-Parametern 6580.0 bis 6580.2 muss die Lage des TT im Arbeitsraum der Maschine festgelegt sein.

Wenn Sie einen der Maschinen-Parameter 6580.0 bis 6580.2 ändern, müssen Sie neu kalibrieren.


Zyklusparameter

Beispiel: NC-Sätze altes Format
6 tool call 1 z
7 TCH PROBE 30.0 tt kalibrieren
8 TCH PROBE 30.1 hoehe: +90
Beispiel: NC-Sätze neues Format
6 tool call 1 z
7 tch probe 480 tt kalibrieren
Q260=+100 ;SICHERE HOEHE

Sichere Höhe: Position in der Spindelachse eingeben, in der eine Kollision mit Werkstücken oder Spannmitteln ausgeschlossen ist. Die Sichere Höhe bezieht sich auf den aktiven Werkstück-Bezugspunkt. Wenn die Sichere Höhe so klein eingegeben ist, dass die Werkzeugspitze unterhalb der Telleroberkante liegen würde, positioniert die TNC das Kalibrierwerkzeug automatisch über den Teller (Sicherheitszone aus MP6540). Eingabebereich ‑99999,9999 bis 99999,9999 alternativ predef


Kabelloses TT 449 kalibrieren (Zyklus 484, DIN/ISO: G484)

Weitere Informationen:
> Grundlegendes
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Grundlegendes

Mit dem Zyklus 484 kalibrieren Sie das kabellose Infrarot-Tischtastsystem TT 449. Der Kalibriervorgang läuft nicht vollautomatisch ab, da die Positioin des TT‘s auf dem Maschinentisch nicht festgelegt ist.


Zyklusablauf

  • Kalibrierwerkzeug einwechseln

  • Kalibrierzyklus definieren und starten

  • Kalibrierwerkzeug manuell über die Mitte des Tastsystems positionieren und den Anweisungen im Überblendfenster folgen. Darauf achten, dass das Kalibrierwerkzeug über der Messfläche des Tastelementes steht

Der Kalibrier-Vorgang läuft halbautomatisch ab. Die TNC ermittelt auch den Mittenversatz des Kalibrierwerkzeugs. Dazu dreht die TNC die Spindel nach der Hälfte des Kalibrier-Zyklus um 180°.

Als Kalibrier-Werkzeug verwenden Sie ein exakt zylindrisches Teil, z.B. einen Zylinderstift. Die Kalibrier-Werte speichert die TNC und berücksichtigt sie bei nachfolgenden Werkzeug-Vermessungen.

Das Kalibrierwerkzeug sollte einen Durchmesser größer 15 mm besitzen und ca. 50 mm aus dem Spannfutter herausstehen. Bei dieser Konstellation entsteht eine Verbiegung von 0.1 µm pro 1 N Antastkraft.


Beim Programmieren beachten!

Die Funktionsweise des Kalibrierzyklus ist abhängig von Maschinen-Parameter 6500. Beachten Sie Ihr Maschinenhandbuch.

Bevor Sie kalibrieren, müssen Sie den genauen Radius und die genaue Länge des Kalibrier-Werkzeugs in der Werkzeug-Tabelle TOOL.T eintragen.

Wenn Sie die Position des TT auf dem Tisch verändern, müssen Sie neu kalibrieren.


Zyklusparameter

Zyklus 484 besitzt keine Zyklusparameter.


Werkzeug-Länge vermessen (Zyklus 31 oder 481, DIN/ISO: G481)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Zum Vermessen der Werkzeug-Länge programmieren Sie den Mess-Zyklus TCH PROBE 31 oder TCH PROBE 481 (siehe auch Unterschiede zwischen den Zyklen 31 bis 33 und 481 bis 483). Über Eingabe-Parameter können Sie die Werkzeug-Länge auf drei verschiedene Arten bestimmen:

  • Wenn der Werkzeug-Durchmesser größer als der Durchmesser der Messfläche des TT ist, dann vermessen Sie mit rotierendem Werkzeug
  • Wenn der Werkzeug-Durchmesser kleiner als der Durchmesser der Messfläche des TT ist oder wenn Sie die Länge von Bohrern oder Radiusfräsern bestimmen, dann vermessen Sie mit stillstehendem Werkzeug
  • Wenn der Werkzeug-Durchmesser größer als der Durchmesser der Messfläche des TT ist, dann führen Sie eine Einzelschneiden-Vermessung mit stillstehendem Werkzeug durch
Weitere Informationen:
> Ablauf „Vermessung mit rotierendem Werkzeug“
> Ablauf „Vermessung mit stillstehendem Werkzeug“ (z.B. für Bohrer)
> Ablauf „Einzelschneiden-Vermessung“


Ablauf „Vermessung mit rotierendem Werkzeug“

Um die längste Schneide zu ermitteln wird das zu vermessende Werkzeug versetzt zum Tastsystem-Mittelpunkt und rotierend auf die Messfläche des TT gefahren. Den Versatz programmieren Sie in der Werkzeug-Tabelle unter Werkzeug-Versatz: Radius (TT: R-OFFS).


Ablauf „Vermessung mit stillstehendem Werkzeug“ (z.B. für Bohrer)

Das zu vermessende Werkzeug wird mittig über die Messfläche gefahren. Anschließend fährt es mit stehender Spindel auf die Messfläche des TT. Für diese Messung tragen Sie den Werkzeug-Versatz: Radius (TT: R-OFFS) in der Werkzeug-Tabelle mit „0“ ein.


Ablauf „Einzelschneiden-Vermessung“

Die TNC positioniert das zu vermessende Werkzeug seitlich vom Tastkopf vor. Die Werkzeug-Stirnfläche befindet sich dabei unterhalb der Tastkopf-Oberkante wie in MP6530 festgelegt. In der Werkzeug-Tabelle können Sie unter Werkzeug-Versatz: Länge (TT: L-OFFS) einen zusätzlichen Versatz festlegen. Die TNC tastet mit rotierendem Werkzeug radial an, um den Startwinkel für die Einzelschneiden-Vermessung zu bestimmen. Anschließend vermisst sie die Länge aller Schneiden durch Ändern der Spindel-Orientierung. Für diese Messung programmieren Sie die SCHNEIDENVERMESSUNG im ZYKLUS TCH PROBE 31 = 1.


Beim Programmieren beachten!

Bevor Sie Werkzeuge zum ersten Mal vermessen, tragen Sie den ungefähren Radius, die ungefähre Länge, die Anzahl der Schneiden und die Schneid-Richtung des jeweiligen Werkzeugs in die Werkzeug-Tabelle TOOL.T ein.

Eine Einzelschneidenvermessung können Sie für Werkzeuge mit bis zu 99 Schneiden ausführen. In der Status-Anzeige zeigt die TNC die Messwerte von maximal 24 Schneiden an.


Zyklusparameter

Beispiel: Erstvermessung mit rotierendem Werkzeug; altes Format
6 tool call 12 z
7 TCH PROBE 31.0 WERKZEUG-LAENGE
8 TCH PROBE 31.1 PRUEFEN: 0
9 TCH PROBE 31.2 hoehe: +120
10 TCH PROBE 31.3 SCHNEIDENVERMESSUNG: 0
Beispiel: Prüfen mit Einzelschneiden-Vermessung, Status in Q5 speichern; altes Format
6 tool call 12 z
7 TCH PROBE 31.0 WERKZEUG-LAENGE
8 TCH PROBE 31.1 PRUEFEN: 1 q5
9 TCH PROBE 31.2 hoehe: +120
10 TCH PROBE 31.3 SCHNEIDENVERMESSUNG: 1
Beispiel: NC-Sätze; neues Format
6 tool call 12 z
7 TCH PROBE 481 WERKZEUG-LAENGE
Q340=1 ;pruefen
Q260=+100 ;sichere hoehe
Q341=1 ;SCHNEIDENVERMESSUNG

Werkzeug messen=0 / prüfen=1: Festlegen, ob das Werkzeug zum ersten Mal vermessen wird oder ob Sie ein bereits vermessenes Werkzeug überprüfen möchten. Bei der Erstvermessung überschreibt die TNC die Werkzeug-Länge L im zentralen Werkzeugspeicher TOOL.T und setzt den Delta-Wert DL = 0. Falls Sie ein Werkzeug prüfen, wird die gemessene Länge mit der Werkzeug-Länge L aus TOOL.T verglichen. Die TNC berechnet die Abweichung vorzeichenrichtig und trägt diese als Delta-Wert DL in TOOL.T ein. Zusätzlich steht die Abweichung auch im Q-Parameter Q115 zur Verfügung. Wenn der Delta-Wert größer ist als die zulässige Verschleiß- oder Bruch-Toleranz für die Werkzeug-Länge, dann sperrt die TNC das Werkzeug (Status L in TOOL.T)

Parameter-Nr. für Ergebnis?: Parameter-Nummer, in der die TNC den Status der Messung abspeichert: 0,0: Werkzeug innerhalb der Toleranz 1,0: Werkzeug ist verschlissen (LTOL überschritten) 2,0: Werkzeug ist gebrochen (LBREAK überschritten) Wenn Sie das Messergebnis nicht innerhalb des Programms weiterverarbeiten wollen, Dialogfrage mit Taste NO ENT bestätigen

Sichere Höhe: Position in der Spindelachse eingeben, in der eine Kollision mit Werkstücken oder Spannmitteln ausgeschlossen ist. Die Sichere Höhe bezieht sich auf den aktiven Werkstück-Bezugspunkt. Wenn die Sichere Höhe so klein eingegeben ist, dass die Werkzeugspitze unterhalb der Telleroberkante liegen würde, positioniert die TNC das Werkzeug automatisch über den Teller (Sicherheitszone aus MP6540). Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Schneidenvermessung 0=Nein / 1=Ja: Festlegen, ob eine Einzelschneiden-Vermessung durchgeführt werden soll (maximal 99 Schneiden vermessbar)


Werkzeug-Radius vermessen (Zyklus 32 oder 482, DIN/ISO: G482)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Zum Vermessen des Werkzeug-Radius programmieren Sie den Mess-Zyklus TCH PROBE 32 oder TCH PROBE 482 (siehe auch Unterschiede zwischen den Zyklen 31 bis 33 und 481 bis 483). Über Eingabe-Parameter können Sie den Werkzeug-Radius auf zwei Arten bestimmen:

  • Vermessung mit rotierendem Werkzeug
  • Vermessung mit rotierendem Werkzeug und anschließender Einzelschneiden-Vermessung

Die TNC positioniert das zu vermessende Werkzeug seitlich vom Tastkopf vor. Die Fräserstirnfläche befindet sich dabei unterhalb der Tastkopf-Oberkante, wie in MP6530 festgelegt. Die TNC tastet mit rotierendem Werkzeug radial an. Falls zusätzlich eine Einzelschneiden-Vermessung durchgeführt werden soll, werden die Radien aller Schneiden mittels Spindel-Orientierung vermessen.


Beim Programmieren beachten!

Bevor Sie Werkzeuge zum ersten Mal vermessen, tragen Sie den ungefähren Radius, die ungefähre Länge, die Anzahl der Schneiden und die Schneid-Richtung des jeweiligen Werkzeugs in die Werkzeug-Tabelle TOOL.T ein.

Zylinderförmige Werkzeuge mit Diamantoberfläche können mit stehender Spindel vermessen werden. Dazu müssen Sie in der Werkzeugtabelle die Schneidenanzahl CUT mit 0 definieren und Maschinen-Parameter 6500 anpassen. Beachten Sie Ihr Maschinenhandbuch.

Eine Einzelschneidenvermessung können Sie für Werkzeuge mit bis zu 99 Schneiden ausführen. In der Status-Anzeige zeigt die TNC die Messwerte von maximal 24 Schneiden an.


Zyklusparameter

Beispiel: Erstvermessung mit rotierendem Werkzeug; altes Format
6 tool call 12 z
7 TCH PROBE 32.0 WERKZEUG-RADIUS
8 TCH PROBE 32.1 PRUEFEN: 0
9 TCH PROBE 32.2 hoehe: +120
10 TCH PROBE 32.3 SCHNEIDENVERMESSUNG: 0
Beispiel: Prüfen mit Einzelschneiden-Vermessung, Status in Q5 speichern; altes Format
6 tool call 12 z
7 TCH PROBE 32.0 WERKZEUG-RADIUS
8 TCH PROBE 32.1 PRUEFEN: 1 q5
9 TCH PROBE 32.2 hoehe: +120
10 TCH PROBE 32.3 SCHNEIDENVERMESSUNG: 1
Beispiel: NC-Sätze; neues Format
6 tool call 12 z
7 TCH PROBE 482 WERKZEUG-RADIUS
Q340=1 ;pruefen
Q260=+100 ;sichere hoehe
Q341=1 ;SCHNEIDENVERMESSUNG

Werkzeug messen=0 / prüfen=1: Festlegen, ob Sie das Werkzeug zum ersten Mal vermessen oder ob ein bereits vermessenes Werkzeug überprüft werden soll. Bei der Erstvermessung überschreibt die TNC den Werkzeug-Radius R im zentralen Werkzeugspeicher TOOL.T und setzt den Delta-Wert DR = 0. Falls Sie ein Werkzeug prüfen, wird der gemessene Radius mit dem Werkzeug-Radius R aus TOOL.T verglichen. Die TNC berechnet die Abweichung vorzeichenrichtig und trägt diese als Delta-Wert DR in TOOL.T ein. Zusätzlich steht die Abweichung auch im Q-Parameter Q116 zur Verfügung. Wenn der Delta-Wert größer ist als die zulässige Verschleiß- oder Bruch-Toleranz für den Werkzeug-Radius, dann sperrt die TNC das Werkzeug (Status L in TOOL.T)

Parameter-Nr. für Ergebnis?: Parameter-Nummer, in der die TNC den Status der Messung abspeichert: 0,0: Werkzeug innerhalb der Toleranz 1,0: Werkzeug ist verschlissen (RTOL überschritten) 2,0: Werkzeug ist gebrochen (RBREAK überschritten) Wenn Sie das Messergebnis nicht innerhalb des Programms weiterverarbeiten wollen, Dialogfrage mit Taste NO ENT bestätigen

Sichere Höhe: Position in der Spindelachse eingeben, in der eine Kollision mit Werkstücken oder Spannmitteln ausgeschlossen ist. Die Sichere Höhe bezieht sich auf den aktiven Werkstück-Bezugspunkt. Wenn die Sichere Höhe so klein eingegeben ist, dass die Werkzeugspitze unterhalb der Telleroberkante liegen würde, positioniert die TNC das Werkzeug automatisch über den Teller (Sicherheitszone aus MP6540). Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Schneidenvermessung 0=Nein / 1=Ja: Festlegen, ob zusätzlich eine Einzelschneiden-Vermessung durchgeführt werden soll oder nicht (maximal 99 Schneiden vermessbar)


Werkzeug komplett vermessen (Zyklus 33 oder 483, DIN/ISO: G483)

Weitere Informationen:
> Zyklusablauf
> Beim Programmieren beachten!
> Zyklusparameter


Zyklusablauf

Um das Werkzeug komplett zu vermessen (Länge und Radius), programmieren Sie den Mess-Zyklus TCH PROBE 33 oder TCH PROBE 482 (siehe auch Unterschiede zwischen den Zyklen 31 bis 33 und 481 bis 483). Der Zyklus eignet sich besonders für die Erstvermessung von Werkzeugen, da – verglichen mit der Einzelvermessung von Länge und Radius – ein erheblicher Zeitvorteil besteht. Über Eingabe-Parameter können Sie das Werkzeug auf zwei Arten vermessen:

  • Vermessung mit rotierendem Werkzeug
  • Vermessung mit rotierendem Werkzeug und anschließender Einzelschneiden-Vermessung

Die TNC vermisst das Werkzeug nach einem fest programmierten Ablauf. Zunächst wird der Werkzeug-Radius und anschließend die Werkzeug-Länge vermessen. Der Messablauf entspricht den Abläufen aus Messzyklus 31 und 32.


Zyklusparameter

Beispiel: Erstvermessung mit rotierendem Werkzeug; altes Format
6 tool call 12 z
7 TCH PROBE 33.0 WERKZEUG MESSEN
8 TCH PROBE 33.1 PRUEFEN: 0
9 TCH PROBE 33.2 hoehe: +120
10 TCH PROBE 33.3 SCHNEIDENVERMESSUNG: 0
Beispiel: Prüfen mit Einzelschneiden-Vermessung, Status in Q5 speichern; altes Format
6 tool call 12 z
7 TCH PROBE 33.0 WERKZEUG MESSEN
8 TCH PROBE 33.1 PRUEFEN: 1 q5
9 TCH PROBE 33.2 hoehe: +120
10 TCH PROBE 33.3 SCHNEIDENVERMESSUNG: 1
Beispiel: NC-Sätze; neues Format
6 tool call 12 z
7 TCH PROBE 483 WERKZEUG MESSEN
Q340=1 ;pruefen
Q260=+100 ;sichere hoehe
Q341=1 ;SCHNEIDENVERMESSUNG

Werkzeug messen=0 / prüfen=1: Festlegen, ob das Werkzeug zum ersten Mal vermessen wird oder ob Sie ein bereits vermessenes Werkzeug überprüfen möchten. Bei der Erstvermessung überschreibt die TNC den Werkzeug-Radius R und die Werkzeug-Länge L im zentralen Werkzeugspeicher TOOL.T und setzt die Delta-Werte DR und DL = 0. Falls Sie ein Werkzeug prüfen, werden die gemessenen Werkzeug-Daten mit den Werkzeug-Daten aus TOOL.T verglichen. Die TNC berechnet die Abweichungen vorzeichenrichtig und trägt diese als Delta-Werte DR und DL in TOOL.T ein. Zusätzlich stehen die Abweichungen auch in den Q-Parametern Q115 und Q116 zur Verfügung. Wenn einer der Delta-Werte größer ist als die zulässigen Verschleiß- oder Bruch-Toleranzen, dann sperrt die TNC das Werkzeug (Status L in TOOL.T)

Parameter-Nr. für Ergebnis?: Parameter-Nummer, in der die TNC den Status der Messung abspeichert: 0,0: Werkzeug innerhalb der Toleranz 1,0: Werkzeug ist verschlissen (LTOL oder/und RTOL überschritten) 2,0: Werkzeug ist gebrochen (LBREAK oder/und RBREAK überschritten) Wenn Sie das Messergebnis nicht innerhalb des Programms weiterverarbeiten wollen, Dialogfrage mit Taste NO ENT bestätigen

Sichere Höhe: Position in der Spindelachse eingeben, in der eine Kollision mit Werkstücken oder Spannmitteln ausgeschlossen ist. Die Sichere Höhe bezieht sich auf den aktiven Werkstück-Bezugspunkt. Wenn die Sichere Höhe so klein eingegeben ist, dass die Werkzeugspitze unterhalb der Telleroberkante liegen würde, positioniert die TNC das Werkzeug automatisch über den Teller (Sicherheitszone aus MP6540). Eingabebereich -99999,9999 bis 99999,9999 alternativ predef

Schneidenvermessung 0=Nein / 1=Ja: Festlegen, ob zusätzlich eine Einzelschneiden-Vermessung durchgeführt werden soll oder nicht (maximal 99 Schneiden vermessbar)


Übersichtstabelle

Weitere Informationen:
> Übersichtstabelle


Übersichtstabelle

Übersichtstabelle

Weitere Informationen:
> Bearbeitungszyklen
> Tastsystemzyklen


Bearbeitungszyklen

Zyklus-Nummer | Zyklus-Bezeichnung | DEF-aktiv | CALL-aktiv | Seite
7 | Nullpunkt-Verschiebung | ■ |  | NULLPUNKT-Verschiebung (Zyklus 7, DIN/ISO: G54)
8 | Spiegeln | ■ |  | SPIEGELN (Zyklus 8, DIN/ISO: G28)
9 | Verweilzeit | ■ |  | VERWEILZEIT (Zyklus 9, DIN/ISO: G04)
10 | Drehung | ■ |  | DREHUNG (Zyklus 10, DIN/ISO: G73)
11 | Maßfaktor | ■ |  | MASSFAKTOR (Zyklus 11, DIN/ISO: G72)
12 | Programm-Aufruf | ■ |  | PROGRAMM-AUFRUF (Zyklus 12, DIN/ISO: G39)
13 | Spindel-Orientierung | ■ |  | SPINDEL-ORIENTIERUNG (Zyklus 13, DIN/ISO: G36)
14 | Konturdefinition | ■ |  | KONTUR (Zyklus 14, DIN/ISO: G37)
19 | Bearbeitungsebene schwenken | ■ |  | BEARBEITUNGSEBENE (Zyklus 19, DIN/ISO: G80, Software-Option 1)
20 | Kontur-Daten SL II | ■ |  | KONTUR-DATEN (Zyklus 20, DIN/ISO: G120)
21 | Vorbohren SL II |  | ■ | VORBOHREN (Zyklus 21, DIN/ISO: G121)
22 | Räumen SL II |  | ■ | RAEUMEN (Zyklus 22, DIN/ISO: G122)
23 | Schlichten Tiefe SL II |  | ■ | SCHLICHTEN TIEFE (Zyklus 23, DIN/ISO: G123)
24 | Schlichten Seite SL II |  | ■ | SCHLICHTEN SEITE (Zyklus 24, DIN/ISO: G124)
25 | Konturzug |  | ■ | KONTUR-ZUG (Zyklus 25, DIN/ISO: G125)
26 | Maßfaktor Achsspezifisch | ■ |  | MASSFAKTOR ACHSSP. (Zyklus 26)
27 | Zylinder-Mantel |  | ■ | SL-Zyklen
28 | Zylinder-Mantel Nutenfräsen |  | ■ | ZYLINDER-MANTEL Nutenfräsen (Zyklus 28, DIN/ISO: G128, Software‑Option 1)
29 | Zylinder-Mantel Steg |  | ■ | ZYLINDER-MANTEL Stegfräsen (Zyklus 29, DIN/ISO: G129, Software‑Option 1)
30 | 3D-Daten abarbeiten |  | ■ | 3D-DATEN ABARBEITEN (Zyklus 30, DIN/ISO: G60)
32 | Toleranz | ■ |  | TOLERANZ (Zyklus 32, DIN/ISO: G62)
39 | Zylinder-Mantel Außenkontur |  | ■ | ZYLINDER-MANTEL Außenkontur fräsen (Zyklus 39, DIN/ISO: G139, Software‑Option 1)
200 | Bohren |  | ■ | BOHREN (Zyklus 200)
201 | Reiben |  | ■ | REIBEN (Zyklus 201, DIN/ISO: G201)
202 | Ausdrehen |  | ■ | AUSDREHEN (Zyklus 202, DIN/ISO: G202)
203 | Universal-Bohren |  | ■ | UNIVERSAL-BOHREN (Zyklus 203, DIN/ISO: G203)
204 | Rückwärts-Senken |  | ■ | RUECKWAERTS-SENKEN (Zyklus 204, DIN/ISO: G204)
205 | Universal-Tiefbohren |  | ■ | UNIVERSAL-TIEFBOHREN (Zyklus 205, DIN/ISO: G205)
206 | Gewindebohren mit Ausgleichsfutter, neu |  | ■ | GEWINDEBOHREN NEU mit Ausgleichsfutter (Zyklus 206, DIN/ISO: G206)
207 | Gewindebohren ohne Ausgleichsfutter, neu |  | ■ | GEWINDEBOHREN ohne Ausgleichsfutter GS NEU (Zyklus 207, DIN/ISO: G207)
208 | Bohrfräsen |  | ■ | BOHRFRAESEN (Zyklus 208)
209 | Gewindebohren mit Spanbruch |  | ■ | GEWINDEBOHREN SPANBRUCH (Zyklus 209, DIN/ISO: G209)
220 | Punktemuster auf Kreis | ■ |  | PUNKTEMUSTER AUF KREIS (Zyklus 220, DIN/ISO: G220)
221 | Punktemuster auf Linien | ■ |  | PUNKTEMUSTER AUF LINIEN (Zyklus 221, DIN/ISO: G221)
225 | Gravieren | ■ |  | KONTUR-ZUG 3D (Zyklus 276, DIN/ISO: G276)
230 | Abzeilen |  | ■ | ABZEILEN (Zyklus 230, DIN/ISO: G230)
231 | Regelfläche |  | ■ | REGELFLAECHE (Zyklus 231; DIN/ISO: G231)
232 | Planfräsen |  | ■ | PLANFRAESEN (Zyklus 232, DIN/ISO: G232)
240 | Zentrieren |  | ■ | ZENTRIEREN (Zyklus 240, DIN/ISO: G240)
241 | Einlippen-Bohren |  | ■ | EINLIPPEN-BOHREN (Zyklus 241, DIN/ISO: G241)
247 | Bezugspunkt Setzen | ■ |  | BEZUGSPUNKT SETZEN (Zyklus 247, DIN/ISO: G247)
251 | Rechtecktasche Komplettbearbeitung |  | ■ | RECHTECKTASCHE (Zyklus 251, DIN/ISO: G251)
252 | Kreistasche Komplettbearbeitung |  | ■ | KREISTASCHE (Zyklus 252, DIN/ISO: G252)
253 | Nutenfräsen |  | ■ | NUTENFRAESEN (Zyklus 253, DIN/ISO: G253)
254 | Runde Nut |  | ■ | RUNDE NUT (Zyklus 254, DIN/ISO: G254)
256 | Rechteckzapfen Komplettbearbeitung |  | ■ | RECHTECKZAPFEN (Zyklus 256, DIN/ISO: G256)
257 | Kreiszapfen Komplettbearbeitung |  | ■ | KREISZAPFEN (Zyklus 257, DIN/ISO: G257)
262 | Gewindefräsen |  | ■ | GEWINDEFRAESEN (Zyklus 262, DIN/ISO: G262)
263 | Senkgewindefräsen |  | ■ | SENKGEWINDEFRAESEN (Zyklus 263, DIN/ISO: G263)
264 | Bohrgewindefräsen |  | ■ | BOHRGEWINDEFRAESEN (Zyklus 264, DIN/ISO: G264)
265 | Helix-Bohrgewindefräsen |  | ■ | HELIX- BOHRGEWINDEFRAESEN (Zyklus 265, DIN/ISO: G265)
267 | Aussengewindefräsen |  | ■ | AUSSENGEWINDE-FRAESEN (Zyklus 267, DIN/ISO: G267)
270 | Konturzug-Daten | ■ |  | KONTURZUG-Daten (Zyklus 270, DIN/ISO: G270)
275 | Konturnut Trochoidal |  | ■ | NUTENFRAESEN (Zyklus 253, DIN/ISO: G253)
290 | Interpolationsdrehen |  | ■ | INTERPOLATIONSDREHEN (Software-Option, Zyklus 290, DIN/ISO: G290)


Tastsystemzyklen

Zyklus-Nummer | Zyklus-Bezeichnung | DEF-aktiv | CALL-aktiv | Seite
0 | Bezugsebene | ■ |  | BEZUGSEBENE (Zyklus 0, DIN/ISO: G55)
1 | Bezugspunkt polar | ■ |  | BEZUGSEBENE Polar (Zyklus 1)
2 | TS kalibrieren Radius | ■ |  | TS KALIBRIEREN (Zyklus 2)
3 | Messen | ■ |  | MESSEN (Zyklus 3)
4 | Messen 3D | ■ |  | MESSEN 3D (Zyklus 4, FCL 3‑Funktion)
9 | TS kalibrieren Länge | ■ |  | TS KALIBRIEREN LAENGE (Zyklus 9)
30 | TT kalibrieren | ■ |  | TT kalibrieren (Zyklus 30 oder 480, DIN/ISO: G480)
31 | Werkzeug-Länge messen/prüfen | ■ |  | Werkzeug-Länge vermessen (Zyklus 31 oder 481, DIN/ISO: G481)
32 | Werkzeug-Radius messen/prüfen | ■ |  | Werkzeug-Radius vermessen (Zyklus 32 oder 482, DIN/ISO: G482)
33 | Werkzeug-Länge und -Radius messen/prüfen | ■ |  | Werkzeug komplett vermessen (Zyklus 33 oder 483, DIN/ISO: G483)
400 | Grunddrehung über zwei Punkte | ■ |  | GRUNDDREHUNG (Zyklus 400, DIN/ISO: G400)
401 | Grunddrehung über zwei Bohrungen | ■ |  | GRUNDDREHUNG über zwei Bohrungen (Zyklus 401, DIN/ISO: G401)
402 | Grunddrehung über zwei Zapfen | ■ |  | GRUNDDREHUNG über zwei Zapfen (Zyklus 402, DIN/ISO: G402)
403 | Schieflage mit Drehachse kompensieren | ■ |  | GRUNDDREHUNG über eine Drehachse kompensieren (Zyklus 403, DIN/ISO: G403)
404 | Grunddrehung setzen | ■ |  | GRUNDDREHUNG SETZEN (Zyklus 404, DIN/ISO: G404)
405 | Schieflage mit C-Achse kompensieren | ■ |  | Schieflage eines Werkstücks über C-Achse ausrichten (Zyklus 405, DIN/ISO: G405)
408 | Bezugspunkt-Setzen Mitte Nut (FCL 3-Funktion) | ■ |  | BEZUGSPUNKT MITTE NUT (Zyklus 408, DIN/ISO: G408, FCL 3-Funktion)
409 | Bezugspunkt-Setzen Mitte Steg (FCL 3-Funktion) | ■ |  | BEZUGSPUNKT MITTE STEG (Zyklus 409, DIN/ISO: G409, FCL 3-Funktion)
410 | Bezugspunkt-Setzen Rechteck innen | ■ |  | BEZUGSPUNKT RECHTECK INNEN (Zyklus 410, DIN/ISO: G410)
411 | Bezugspunkt-Setzen Rechteck aussen | ■ |  | BEZUGSPUNKT RECHTECK AUSSEN (Zyklus 411, DIN/ISO: G411)
412 | Bezugspunkt-Setzen Kreis innen (Bohrung) | ■ |  | BEZUGSPUNKT KREIS INNEN (Zyklus 412, DIN/ISO: G412)
413 | Bezugspunkt-Setzen Kreis aussen (Zapfen) | ■ |  | BEZUGSPUNKT KREIS AUSSEN (Zyklus 413, DIN/ISO: G413)
414 | Bezugspunkt-Setzen Ecke aussen | ■ |  | BEZUGSPUNKT ECKE AUSSEN (Zyklus 414, DIN/ISO: G414)
415 | Bezugspunkt-Setzen Ecke innen | ■ |  | BEZUGSPUNKT ECKE INNEN (Zyklus 415, DIN/ISO: G415)
416 | Bezugspunkt-Setzen Lochkreis-Mitte | ■ |  | BEZUGSPUNKT LOCHKREIS-MITTE (Zyklus 416, DIN/ISO: G416)
417 | Bezugspunkt-Setzen Tastsystem-Achse | ■ |  | BEZUGSPUNKT TASTSYSTEM-ACHSE (Zyklus 417, DIN/ISO: G417)
418 | Bezugspunkt-Setzen Mitte von vier Bohrungen | ■ |  | BEZUGSPUNKT MITTE 4 BOHRUNGEN (Zyklus 418, DIN/ISO: G418)
419 | Bezugspunkt-Setzen einzelne, wählbare Achse | ■ |  | BEZUGSPUNKT EINZELNE ACHSE (Zyklus 419, DIN/ISO: G419)
420 | Werkstück messen Winkel | ■ |  | MESSEN WINKEL (Zyklus 420, DIN/ISO: G420)
421 | Werkstück messen Kreis innen (Bohrung) | ■ |  | MESSEN BOHRUNG (Zyklus 421, DIN/ISO: G421)
422 | Werkstück messen Kreis aussen (Zapfen) | ■ |  | MESSEN KREIS AUSSEN (Zyklus 422, DIN/ISO: G422)
423 | Werkstück messen Rechteck innen | ■ |  | MESSEN RECHTECK INNEN (Zyklus 423, DIN/ISO: G423)
424 | Werkstück messen Rechteck aussen | ■ |  | MESSEN RECHTECK AUSSEN (Zyklus 424, DIN/ISO: G424)
425 | Werkstück messen Breite innen (Nut) | ■ |  | MESSEN BREITE INNEN (Zyklus 425, DIN/ISO: G425)
426 | Werkstück messen Breite aussen (Steg) | ■ |  | MESSEN STEG AUSSEN (Zyklus 426, DIN/ISO: G426)
427 | Werkstück messen einzelne, wählbare Achse | ■ |  | MESSEN KOORDINATE (Zyklus 427, DIN/ISO: G427)
430 | Werkstück messen Lochkreis | ■ |  | MESSEN LOCHKREIS (Zyklus 430, DIN/ISO: G430)
431 | Werkstück messen Ebene | ■ |  | MESSEN EBENE (Zyklus 431, DIN/ISO: G431)
440 | Achsverschiebung messen | ■ |  | ACHSVERSCHIEBUNG MESSEN (Tastsystem-Zyklus 440, DIN/ISO: G440)
441 | Schnelles Antasten: Globale Tastsystem-Parameter setzen (FCL 2-Funktion) | ■ |  | SCHNELLES ANTASTEN (Zyklus 441, DIN/ISO: G441, FCL 2-Funktion)
450 | KinematicsOpt: Kinematik sichern (Option) | ■ |  | KINEMATIK SICHERN (Zyklus 450, DIN/ISO: G450, Option)
451 | KinematicsOpt: Kinematik vermessen (Option) | ■ |  | KINEMATIK VERMESSEN (Zyklus 451, DIN/ISO: G451, Option)
452 | KinematicsOpt: Preset-Kompensation (Option) | ■ |  | KINEMATIK VERMESSEN (Zyklus 451, DIN/ISO: G451, Option)
460 | TS kalibrieren: Radius- und Längenkalibrierung an einer Kalibrierkugel | ■ |  | TS KALIBRIEREN (Zyklus 460, DIN/ISO: G460)
480 | TT kalibrieren | ■ |  | TT kalibrieren (Zyklus 30 oder 480, DIN/ISO: G480)
481 | Werkzeug-Länge messen/prüfen | ■ |  | Werkzeug-Länge vermessen (Zyklus 31 oder 481, DIN/ISO: G481)
482 | Werkzeug-Radius messen/prüfen | ■ |  | Werkzeug-Radius vermessen (Zyklus 32 oder 482, DIN/ISO: G482)
483 | Werkzeug-Länge und -Radius messen/prüfen | ■ |  | Zyklusablauf
484 | Infrarot-TT kalibrieren | ■ |  | Kabelloses TT 449 kalibrieren (Zyklus 484, DIN/ISO: G484)