BHB DIN/ISO

Benutzer-Handbuch DIN/ISO-Programmierung

Gültig für:
606420-04, 606421-04, 606424-04

Stand:
07.04.2014-de-

Copyright © 2014 DR. JOHANNES HEIDENHAIN GmbH. Alle Rechte vorbehalten.


Bedienelemente der TNC

Weitere Informationen:
> Bedienelemente der TNC


Bedienelemente der TNC

Bedienelemente der TNC

Weitere Informationen:
> Bedienelemente am Bildschirm
> Alpha-Tastatur
> Maschinen-Betriebsarten
> Programmier-Betriebsarten
> Programme/Dateien verwalten, TNC-Funktionen
> Navigationstasten
> Potentiometer für Vorschub und Spindeldrehzahl
> Zyklen, Unterprogramme und Programmteil-Wiederholungen
> Angaben zu Werkzeugen
> Bahnbewegungen programmieren
> Sonderfunktionen/smarT.NC
> Koordinatenachsen und Ziffern eingeben, Editieren


Bedienelemente am Bildschirm

Taste | Funktion
 | Bildschirm-Aufteilung wählen
 | Bildschirm zwischen Maschinen- und Programmier-Betriebsart umschalten
 | Softkeys: Funktion im Bildschirm wählen
 | Softkey-Leisten umschalten


Alpha-Tastatur

Taste | Funktion
 | Dateinamen, Kommentare
 | DIN/ISO-Programmierung


Maschinen-Betriebsarten

Taste | Funktion
 | Manueller Betrieb
 | Elektronisches Handrad
 | smarT.NC
 | Positionieren mit Handeingabe
 | Programmlauf Einzelsatz
 | Programmlauf Satzfolge


Programmier-Betriebsarten

Taste | Funktion
 | Programm Einspeichern/Editieren
 | Programm-Test


Programme/Dateien verwalten, TNC-Funktionen

Taste | Funktion
 | Programme/Dateien wählen und löschen, externe Datenübertragung
 | Programm-Aufruf definieren, Nullpunkt- und Punkte Tabellen wählen
 | MOD-Funktion wählen
 | Hilfstexte anzeigen bei NC-Fehlermeldungen, TNCguide aufrufen
 | Alle anstehenden Fehlermeldungen anzeigen
 | Taschenrechner einblenden


Navigationstasten

Taste | Funktion
 | Hellfeld verschieben
 | Sätze, Zyklen und Parameter-Funktionen direkt wählen


Potentiometer für Vorschub und Spindeldrehzahl

Vorschub | Spindeldrehzahl


Zyklen, Unterprogramme und Programmteil-Wiederholungen

Taste | Funktion
 | Tastsystem-Zyklen definieren
 | Zyklen definieren und aufrufen
 | Unterprogramme und Programmteil-Wiederholungen eingeben und aufrufen
 | Programm-Halt in ein Programm eingeben


Angaben zu Werkzeugen

Taste | Funktion
 | Werkzeugdaten im Programm definieren
 | Werkzeugdaten aufrufen


Bahnbewegungen programmieren

Taste | Funktion
 | Kontur anfahren/verlassen
 | Freie Konturprogrammierung FK
 | Gerade
 | Kreismittelpunkt/Pol für Polarkoordinaten
 | Kreisbahn um Kreismittelpunkt
 | Kreisbahn mit Radius
 | Kreisbahn mit tangentialem Anschluss
 | Fase/Ecken-Runden


Sonderfunktionen/smarT.NC

Taste | Funktion
 | Sonderfunktionen anzeigen
 | smarT.NC: Nächsten Reiter im Formular wählen
 | smarT.NC: Erstes Eingabefeld im vorherigen/ nächsten Rahmen wählen


Koordinatenachsen und Ziffern eingeben, Editieren

Taste | Funktion
 | Koordinatenachsen wählen bzw. ins Programm eingeben
 | Ziffern
 | Dezimal-Punkt/Vorzeichen umkehren
 | Polarkoordinaten Eingabe / Inkremental-Werte
 | Q-Parameter-Programmierung / Q-Parameter-Status
 | Ist-Position, Werte vom Taschenrechner übernehmen
 | Dialogfragen übergehen und Wörter löschen
 | Eingabe abschließen und Dialog fortsetzen
 | Satz abschließen, Eingabe beenden
 | Zahlenwert-Eingaben rücksetzen oder TNC Fehlermeldung löschen
 | Dialog abbrechen, Programmteil löschen


Über dieses Handbuch

Weitere Informationen:
> Über dieses Handbuch
> TNC-Typ, Software und Funktionen
> Neue Funktionen 60642x‑01 bezogen auf die Vorgänger-Versionen 34049x-05
> Neue Funktionen 60642x‑02
> Neue Funktionen 60642x‑03
> Neue Funktionen 60642x‑04
> Geänderte Funktionen 60642x‑01 bezogen auf die Vorgänger-Versionen 34049x-05
> Geänderte Funktionen 60642x‑02
> Geänderte Funktionen 60642x‑03
> Geänderte Funktionen 60642x‑04


Über dieses Handbuch

Über dieses Handbuch

Nachfolgend finden Sie eine Liste der in diesem Handbuch verwendeten Hinweis-Symbole

Dieses Symbol zeigt Ihnen, dass zur beschriebenen Funktion besondere Hinweise zu beachten sind.

Dieses Symbol zeigt Ihnen, dass bei Verwendung der beschriebenen Funktion eine oder mehrere der folgenden Gefahren bestehen:

  • Gefahren für Werkstück
  • Gefahren für Spannmittel
  • Gefahren für Werkzeug
  • Gefahren für Maschine
  • Gefahren für Bediener

Dieses Symbol zeigt Ihnen, dass die beschriebene Funktion von Ihrem Maschinenhersteller angepasst werden muss. Die beschriebene Funktion kann demnach von Maschine zu Maschine unterschiedlich wirken.

Dieses Symbol zeigt Ihnen, dass Sie detailliertere Beschreibungen einer Funktion in einem anderen Benutzer-Handbuch finden.
Weitere Informationen:
> Änderungen gewünscht oder den Fehlerteufel entdeckt?


Änderungen gewünscht oder den Fehlerteufel entdeckt?

Wir sind ständig bemüht unsere Dokumentation für Sie zu verbessern. Helfen Sie uns dabei und teilen uns bitte Ihre Änderungswünsche unter folgender E-Mail-Adresse mit: tnc-userdoc@heidenhain.de.


TNC-Typ, Software und Funktionen

Dieses Handbuch beschreibt Funktionen, die in den TNCs ab den folgenden NC-Software-Nummern verfügbar sind.

TNC-Typ | NC-Software-Nr.
iTNC 530, HSCI und HEROS 5 | 606420-04
iTNC 530 E, HSCI und HEROS 5 | 606421-04
iTNC 530 Programmierplatz, HEROS 5 | 606424-04

    Der Kennbuchstabe E kennzeichnet die Exportversion der TNC. Für die Exportversionen der TNC gilt folgende Einschränkung:

  • Geradenbewegungen simultan bis zu 4 Achsen

HSCI (HEIDENHAIN Serial Controller Interface) kennzeichnet die neue Hardware-Plattform der TNC-Steuerungen.

HEROS 5 kennzeichnet das Betriebssystem der HSCI basierten TNC-Steuerungen.

Der Maschinenhersteller paßt den nutzbaren Leistungsumfang der TNC über Maschinen-Parameter an die jeweilige Maschine an. Daher sind in diesem Handbuch auch Funktionen beschrieben, die nicht an jeder TNC verfügbar sind.

    TNC-Funktionen, die nicht an allen Maschinen zur Verfügung stehen, sind beispielsweise:

  • Werkzeug-Vermessung mit dem TT

Setzen Sie sich bitte mit dem Maschinenhersteller in Verbindung, um den tatsächlichen Funktionsumfang Ihrer Maschine kennenzulernen.

Viele Maschinenhersteller und HEIDENHAIN bieten für die TNCs Programmier-Kurse an. Die Teilnahme an solchen Kursen ist empfehlenswert, um sich intensiv mit den TNC-Funktionen vertraut zu machen.

Benutzer-Handbuch Zyklenprogrammierung:

Alle Zyklen-Funktionen (Tastsystem-Zyklen und Bearbeitungszyklen sind in einem separaten Benutzer-Handbuch beschrieben. Wenden Sie sich ggf. an HEIDENHAIN, wenn Sie dieses Benutzer-Handbuch benötigen. ID: 670388-xx

Benutzer-Dokumentation smarT.NC:

Die Betriebsart smarT.NC ist in einem separaten Lotsen beschrieben. Wenden Sie sich ggf. an HEIDENHAIN, wenn Sie diesen Lotsen benötigen. ID: 533191-xx.
Weitere Informationen:
> Software-Optionen
> Entwicklungsstand (Upgrade-Funktionen)
> Vorgesehener Einsatzort
> Rechtlicher Hinweis


Software-Optionen

Die iTNC 530 verfügt über verschiedene Software-Optionen, die von Ihnen oder Ihrem Maschinenhersteller freigeschaltet werden können. Jede Option ist separat freizuschalten und beinhaltet jeweils die nachfolgend aufgeführten Funktionen:

Software-Option 1

Zylindermantel-Interpolation (Zyklen 27, 28, 29 und 39)

Vorschub in mm/min bei Rundachsen: M116

Schwenken der Bearbeitungsebene (Zyklus 19, PLANE-Funktion und Softkey 3D-ROT in der Betriebsart Manuell)

Kreis in 3 Achsen bei geschwenkter Bearbeitungsebene
Software-Option 2

5-Achs-Interpolation

Spline-Interpolation

3D-Bearbeitung:

  • M114: Automatische Korrektur der Maschinengeometrie beim Arbeiten mit Schwenkachsen
  • M128: Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM)
  • FUNCTION TCPM: Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM) mit Einstellmöglichkeit der Wirkungsweise
  • M144: Berücksichtigung der Maschinen-Kinematik in IST/SOLL-Positionen am Satzende
  • Zusätzliche Parameter Schlichten/Schruppen und Toleranz für Drehachsen im Zyklus 32 (G62)
  • LN-Sätze (3D-Korrektur)
Software-Option DCM Collision | Beschreibung
Funktion, die vom Maschinenhersteller definierte Bereiche überwacht, um Kollisionen zu vermeiden. | Dynamische Kollisionsüberwachung (Software-Option)
Software-Option DXF-Converter | Beschreibung
Konturen und Bearbeitungspositionen aus DXF-Dateien (Format R12) extrahieren. | DXF-Dateien verarbeiten (Software-Option)
Software-Option Globale Programm-Einstellungen | Beschreibung
Funktion zur Überlagerung von Koordinaten-Transformationen in den Abarbeiten-Betriebsarten, handragüberlagertes Verfahren in virtueller Achsrichtung. | Globale Programm-einstellungen (Software-Option)
Software-Option AFC | Beschreibung
Funktion adaptive Vorschubregelung zur Optimierung der Schnittbedingungen bei Serienproduktion. | Adaptive Vorschubregelung AFC (Software-Option)
Software-Option KinematicsOpt | Beschreibung
Tastsystem-Zyklen zur Prüfung und Optimierung der Maschinengenauigkeit. | Benutzer-Handbuch Zyklen
Software-Option erweiterte Werkzeug-Verwaltung | Beschreibung
Vom Maschinenhersteller über Python-Scripte anpassbare Werkzeug-Verwaltung. | Werkzeug-Verwaltung (Software-Option)
Software-Option Interpolationsdrehen | Beschreibung
Interpolationsdrehen eines Absatzes mit Zyklus 290. | Benutzer-Handbuch Zyklen
Software-Option CAD-Viewer | Beschreibung
Öffnen von 3D-Modellen auf der Steuerung. | 3D-CAD-Daten öffnen (Software-Option)
Software-Option Remote Desktop Manager | Beschreibung
Fernbedienung externer Rechner-Einheiten (z. B. Windows-PC) über die Benutzer-Oberfläche der TNC | Maschinen-Handbuch
Software-Option Cross Talk Compensation CTC | Beschreibung
Kompensation von Achskopplungen | Maschinen-Handbuch
Software-Option Position Adaptive Control PAC | Beschreibung
Anpassung von Regelparametern | Maschinen-Handbuch
Software-Option Load Adaptive Control LAC | Beschreibung
Dynamische Anpassung von Regelparametern | Maschinen-Handbuch
Software-Option Active Chatter Control ACC | Beschreibung
Vollautomaische Funktion zur Ratter-Unterdrückung während der Bearbeitung | Maschinen-Handbuch


Entwicklungsstand (Upgrade-Funktionen)

Neben Software-Optionen werden wesentliche Weiterentwicklungen der TNC-Software über Upgrade-Funktionen, den sogenannten Feature Content Level (engl. Begriff für Entwicklungsstand), verwaltet. Funktionen die dem FCL unterliegen, stehen Ihnen nicht zur Verfügung, wenn Sie an Ihrer TNC einen Software-Update erhalten.

Wenn Sie eine neue Maschine erhalten, dann stehen Ihnen alle Upgrade-Funktionen ohne Mehrkosten zur Verfügung.

Upgrade-Funktionen sind im Handbuch mit FCL n gekennzeichnet, wobei n die fortlaufende Nummer des Entwicklungsstandes kennzeichnet.

Sie können durch eine käuflich zu erwerbende Schlüsselzahl die FCL-Funktionen dauerhaft freischalten. Setzen Sie sich hierzu mit Ihrem Maschinenhersteller oder mit HEIDENHAIN in Verbindung.

FCL 4-Funktionen | Beschreibung
Grafische Darstellung des Schutzraumes bei aktiver Kollisionsüberwachung DCM | Grafische Darstellung des Schutzraumes (FCL4-Funktion)
Handradüberlagerung in gestopptem Zustand bei aktiver Kollisionsüberwachung DCM | Kollisionsüberwachung im Automatikbetrieb
3D-Grunddrehung (Aufspannkompensation) | Maschinen-Handbuch
FCL 3-Funktionen | Beschreibung
Tastsystem-Zyklus zum 3D-Antasten | Benutzer-Handbuch Zyklen
Tastsystem-Zyklen zum automatischen Bezugspunkt-Setzen Mitte Nut/Mitte Steg | Benutzer-Handbuch Zyklen
Vorschubreduzierung bei Konturtaschenbearbeitung wenn Werkzeug im Volleingriff ist | Benutzer-Handbuch Zyklen
PLANE-Funktion: Achswinkeleingabe | Bearbeitungsebene über Achswinkel: PLANE AXIAL (FCL 3-Funktion)
Benutzer-Dokumentation als Kontextsensitives Hilfesystem | Kontextsensitives Hilfesystem TNCguide (FCL3-Funktion)
smarT.NC: smarT.NC programmieren parallel zur Bearbeitung | smarT.NC-Programme wählen
smarT.NC: Konturtasche auf Punktemuster | Lotse smarT.NC
smarT.NC: Preview von Konturprogrammen im Datei-Manager | Lotse smarT.NC
smarT.NC: Positionierstrategie bei Punkte-Bearbeitungen | Lotse smarT.NC
FCL 2-Funktionen | Beschreibung
3D-Liniengrafik | 3D-Liniengrafik (FCL2-Funktion)
Virtuelle Werkzeug-Achse | Aktuelle Werkzeugachs-Richtung als aktive Bearbeitungsrichtung setzen (FCL 2-Funktion)
USB-Unterstützung von Block-Geräten (Speicher-Sticks, Festplatten, CD-ROM-Laufwerke) | USB-Gerät anbinden/entfernen
Möglichkeit, jeder Teilkontur bei der Konturformel unterschiedliche Tiefen zuzuweisen | Benutzer-Handbuch Zyklen
Tastsystem-Zyklus zum globalen Einstellen von Tastsystem-Parametern | Benutzer-Handbuch Tastsystem-Zyklen
smarT.NC: Satzvorlauf grafisch unterstützt | Lotse smarT.NC
smarT.NC: Koordinaten-Transformationen | Lotse smarT.NC
smarT.NC: PLANE-Funktion | Lotse smarT.NC


Vorgesehener Einsatzort

Die TNC entspricht der Klasse A nach EN 55022 und ist hauptsächlich für den Betrieb in Industriegebieten vorgesehen.


Rechtlicher Hinweis

Dieses Produkt verwendet Open Source Software. Weitere Informationen finden Sie auf der Steuerung unter

  • Betriebsart Einspeichern/Editieren

  • MOD-Funktion

  • Softkey rechtliche Hinweise


Neue Funktionen 60642x‑01 bezogen auf die Vorgänger-Versionen 34049x-05

  • Öffnen und Berabeiten von extern erstellten Dateien neu dazu (siehe Zusatztools zur Verwaltung externer Datei-Typen)
  • Neue Funktionen in der Task-Leiste dazu (siehe Task-Leiste)
  • Erweiterte Funktionen bei der Konfiguration der Ethernet-Schnittstelle (siehe TNC konfigurieren)
  • Erweiterungen zur Funktionalen Sicherheit FS (Option):
    • Allgemeines zur Funktionalen Sicherheit FS (siehe Allgemeines)
    • Begriffserklärungen (siehe Begriffserklärungen)
    • Prüfung der Achspositionen (siehe Achspositionen prüfen)
    • Vorschubbegrenzung aktivieren (siehe Vorschubbegrenzung aktivieren)
    • Erweiterungen in der allgemeinen Status-Anzeige bei einer TNC mit funktionaler Sicherheit (siehe Zusätzliche Status-Anzeigen)
  • Die neuen Handräder HR 520 und HR 550 FS werden unterstützt (siehe Verfahren mit elektronischen Handrädern)
  • Neue Software-Option 3D-ToolComp: Eingriffswinkelabhängige 3D- Werkzeug-Radiuskorrektur bei Sätzen mit Flächen-Normalenvektoren (LN-Sätzen)
  • 3D-Liniengrafik jetzt auch im Full-Screen Modus möglich (siehe 3D-Liniengrafik (FCL2-Funktion))
  • Für die Auswahl von Dateien in verschiedenen NC-Funktionen und in der Tabellen-Ansicht der Paletten-Tabelle steht jetzt ein Dateiauswahldialog zur Verfügung (siehe Beliebiges Programm als Unterprogramm aufrufen)
  • DCM: Sichern und Wiederherstellen von Aufspannsituationen
  • DCM: Das Formluar beim Erzeugen eines Prüfprogrammes enthält jetzt auch Icons und Tipp-Texte (siehe Position des eingemessenen Spannmittels prüfen)
  • DCM, FixtureWizard: Antastpunkte und Antastreihenfolge werden eindeutiger dargestellt
  • DCM, FixtureWizard: Bezeichnungen, Antastpunkte und Nachmesspunkte können ein- und ausgeblendet werden (siehe FixtureWizard bedienen)
  • DCM, FixtureWizard: Spannmittel und Einhängepunkte lassen sich jetzt auch per Mouse-Klick wählen
  • DCM: Es steht nun eine Bibliothek mit Standard-Spannmitteln zur Verfügung (siehe Spannmittelvorlagen)
  • DCM: Werkzeugträger-Verwaltung (siehe Werkzeugträger-Verwaltung (Software-Option DCM))
  • In der Betriebsart Programm-Test kann jetzt die Bearbeitungsebene manuell definiert werden (siehe Geschwenkte Bearbeitungsebene für Programm-Test einstellen)
  • Im Manuellen Betrieb steht nun auch der Modus RW-3D für die Positions-Anzeige zur Verfügung (siehe Positions-Anzeige wählen)
  • Erweiterungen in der Werkzeug-Tabelle TOOL.T (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten):
    • Neue Spalte DR2TABLE zur Definition einer Korrekturtabelle für die eingriffswinkelabhängige Werkzeug-Radiuskorrektur
    • Neue Spalte LAST_USE, in der die TNC Datum und Uhrzeit des letzten Werkzeug-Aufrufs einträgt
  • Q-Parameter-Programmierung: String-Parameter QS können nun auch für Sprungadressen bei bedingten Sprüngen, Unterprogrammen oder Programmteil-Wiederholungen verwendet werden (siehe Unterprogramm aufrufen, siehe Programmteil-Wiederholung aufrufen und siehe Wenn/dann-Entscheidungen programmieren)
  • Die Erstellung der Werkzeug-Einsatzlisten in den Abarbeiten-Betriebsarten kann über ein Formular konfiguriert werden (siehe Einstellungen für die Werkzeug-Einsatzprüfung)
  • Das Verhalten beim Löschen von Werkzeugen aus der Werkzeug-Tabelle kann jetzt über den Maschinen-Parameter 7263 beeinflusst werden siehe Werkzeug-Tabellen editieren
  • Im Positionermodus TURN der PLANE-Funktion kann nun eine Sicherheitshöhe definiert werden, auf die das Werkzeug vor dem Einschwenken in Werkzeug-Achsrichtung zurückgezogen werden soll (siehe Automatisches Einschwenken: MOVE/TURN/STAY (Eingabe zwingend erforderlich))
  • In der erweiterten Werkzeug-Verwaltung stehen nun folgende zusätzliche Funktionen zur Verfügung (siehe Werkzeug-Verwaltung (Software-Option)):
    • Spalten mit Sonderfunktionen sind nun auch editierbar
    • Die Formularansicht der Werkzeugdaten lässt sich nun wahlweise mit Speicherung oder ohne Speicherung von geänderten Werten beenden
    • In der Tabellenansicht steht nun eine Suchfunktion zur Verfügung
    • Indizierte Werkzeuge werden nun in der Formularansicht richtig dargestellt
    • In der Werkzeugfolgeliste stehen nun weitere Detailinformationen zur Verfügung
    • Die Be- und Entladeliste des Werkzeug-Magazins ist nun per Drag and Drop be- und entladbar
    • Spalten lassen sich in der Tabellenansicht einfach per Drag and Drop verschieben
  • In der Betriebsart MDI stehen nun auch einige Sonderfunktionen (Taste SPEC FCT) zur Verfügung (siehe Einfache Bearbeitungen programmieren und abarbeiten)
  • Es steht ein neuer manueller Antast-Zyklus zur Verfügung, mit dem Werkstückschieflagen über eine Rundtischdrehung ausgeglichen werden können (siehe Werkstück ausrichten über 2 Punkte)
  • Neuer Tastsystem-Zyklus zum Kalibrieren eines Tastsystems an einer Kalibrierkugel (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • KinematicsOpt: Bessere Unterstützung zur Positionierung von hirthverzahnten Achsen (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • KinematicsOpt: Ein zusätzlicher Parameter zur Ermittlung der Lose einer Drehachse wurde eingeführt (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Neuer Bearbeitungszyklus 275 Nutenfräsen trochoidal (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Beim Zyklus 241 zum Einlippen-Bohren kann nun auch eine Verweiltiefe definiert werden (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • An- und Wegfahrverhalten des Zyklus 39 ZYLINDERMANTEL KONTUR ist nun einstellbar (siehe Benutzer-Handbuch Zyklen-Programmierung)


Neue Funktionen 60642x‑02

  • Neue Funktion zum Öffnen von 3D-Daten (Software-Option) direkt auf der TNC 3D-CAD-Daten öffnen (Software-Option)
  • Erweiterungen bei der dynamischen Kollisionsüberwachung DCM:
    • Die Darstellung von Stufenwerkzeugen wurde verbessert
    • Beim Wählen einer Werkzeugträger-Kinematik zeigt die TNC jetzt eine Vorschaugrafik der Trägerkinematik an (siehe Trägerkinematik zuweisen)
  • Erweiterung bei Funktionen zur Mehrachsbearbeitung:
    • Im manuellen Betrieb können die Achsen jetzt auch dann verfahren werden, wenn TCPM und Ebenen schwenken gleichzeitig aktiv sind
    • Ein Werkzeugwechsel kann nun auch bei aktivem M128/FUNCTION TCPM ausgeführt werden
  • Datei-Verwaltung: Archivieren von Dateien in ZIP-Archiven Dateien archivieren
  • Die Verschachtelungstiefe bei Programmaufrufen wurde von 6 auf 10 erhöht (siehe Verschachtelungstiefe)
  • Im Überblendfenster zur Werkzeugauswahl steht jetzt eine Suchfunktion für Werkzeugnamen zur Verfügung (siehe Nach Werkzeugnamen im Auswahlfenster suchen)
  • Erweiterungen im Bereich der Paletten-Bearbeitung:
    • Um Aufspannungen automatisiert aktivieren zu können, wurde in der Paletten-Tabelle die neue Spalte fixture eingeführt Palettenbetrieb mit werkzeugorientierter Bearbeitung
    • In der Paletten-Tabelle wurde der neue Werkstück-Status auslassen (SKIP) eingeführt Palettenebene einstellen
    • Wird eine Werkzeugfolgeliste für eine Paletten-Tabelle erzeugt, dann prüft die TNC jetzt auch, ob alle NC-Programm der Paletten-Tabelle vorhanden sind (siehe Werkzeug-Verwaltung aufrufen)
  • Die neue Funktion Leitrechner-Betrieb wurde eingeführt (siehe Leitrechner-Betrieb)
  • Die Sicherheitssoftware SELinux steht zur Verfügung (siehe Sicherheitssoftware SELinux)
  • Erweiterungen im DXF-Konverter:
    • Konturen können nun auch aus .H-Dateien extrahiert werden (siehe Datenübernahme aus Klartext-Dialog-Programmen)
    • Vorselektierte Konturen lassen sich jetzt auch über die Baumstruktur wählen (siehe Kontur wählen und speichern)
    • Fangfunktion erleichtert die Konturauswahl
    • Statusanzeige erweitert (siehe Grundeinstellungen)
    • Hintergrundfarbe umstellbar (siehe Grundeinstellungen)
    • Darstellung zwischen 2D/3D umschaltbar (siehe Grundeinstellungen)
  • Erweiterungen bei den globalen Programmeinstellung GS:
    • Alle Formulardaten können jetzt programmgesteuert gesetzt und rückgesetzt werden (siehe Technische Voraussetzungen)
    • Handradüberlagerungswert VT kann bei einem Werkzeug-Wechsel abgelöscht werden (siehe Virtuelle Achse VT)
    • Bei aktiver Funktion Achsen tauschen sind nun auch Positionierungen auf maschinenfeste Positionen in den nicht getauschten Achsen erlaubt
  • Erweiterungen in der Werkzeug-Tabelle TOOL.T:
    • Über den Softkey AKT. WERKZEUGNAMEN SUCHEN können Sie prüfen, ob gleiche Werkzeugnamen in der Werkzeug-Tabelle definiert sind Werkzeug-Tabellen editieren
    • Der Eingabebereich der Deltawerte DL, DR und DR2 wurde auf 999,9999 mm erhöht Werkzeug-Tabelle: Standard Werkzeug-Daten
  • In der erweiterten Werkzeug-Verwaltung stehen nun folgende zusätzliche Funktionen zur Verfügung (siehe Werkzeug-Verwaltung (Software-Option)):
    • Importieren von Werkzeugdaten im CSV-Format (siehe Werkzeugdaten importieren)
    • Exportieren von Werkzeugdaten im CSV-Format (siehe Werkzeugdaten exportieren)
    • Markieren und Löschen wählbarer Werkzeugdaten (siehe Markierte Werkzeugdaten löschen)
    • Einfügen von Werkzeug-Indizes (siehe Werkzeug-Verwaltung bedienen)
  • Neuer Bearbeitungszyklus 225 Gravieren (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Neuer Bearbeitungszyklus 276 Konturzug 3D (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Neuer Bearbeitungszyklus 290 Interpolationsdrehen (Software-Option, siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Bei den Gewindefräszyklen 26x steht jetzt ein separater Vorschub für das tangentiale Anfahren an Gewinde zur Verfügung das (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Bei den KinematicsOpt-Zyklen wurden folgende Verbesserungen durchgeführt (siehe Benutzer-Handbuch Zyklen-Programmierung):
    • Neuer, schnellerer OptimierungsalgorythmusNach der Winkeloptimierung ist keine separate Messreihe mehr für die Positionsoptimierung erforderlichRückgabe der Offsetfehler (Änderung des Maschinennullpunkts) in den Parametern Q147-149Mehr Ebenenmesspunkte bei der KugelmessungDrehachsen die nicht konfiguriert sind werden von der TNC beim Ausführen des Zyklus ignoriert


Neue Funktionen 60642x‑03

  • Neue Software-Option Aktive Ratter-Unterdrückung ACC (Active Chatter Control) (siehe Aktive Ratterunterdrückung ACC (Software-Option))
  • Erweiterungen bei der dynamischen Kollisionsüberwachung DCM:
    • Die Software unterstützt jetzt bei der NC-Syntax SEL FIXTURE ein Auswahlfenster mit Dateivorschau zur Selektion von gesicherten Aufspannungen (siehe Aufspannung programmgesteuert laden)
  • Die Verschachtelungstiefe bei Programmaufrufen wurde von 10 auf 30 erhöht (siehe Verschachtelungstiefe)
  • Bei der Nutzung der zweiten Ethernet-Schnittstelle für ein Maschinen-Netzwerk lässt sich jetzt auch ein DHCP-Server konfigurieren, um die Maschinen mit dynamischen IP-Adressen zu versorgen Allgemeine Netzwerk-Einstellungen
  • Über den Maschinen-Parameter 7268.x lassen sich jetzt Spalten in der Bezugspunkt-Tabelle anordnen und auch ausblenden Liste der allgemeinen Anwenderparameter
  • Der Schalter SEQ der PLANE-Funktion kann nun auch mit einem Q-Parameter belegt werden (siehe Auswahl von alternativen Schwenk-möglichkeiten: SEQ +/– (Eingabe optional))
  • Erweiterungen NC-Editor:
    • Programm speichern (siehe Änderungen bewusst speichern)
    • Programm unter anderem Namen speichern (siehe Programm in einer neuen Datei speichern)
    • Änderungen aufheben (siehe Änderungen rückgängig machen)
  • Erweiterungen im DXF-Konverter:DXF-Dateien verarbeiten (Software-Option)
    • Erweiterungen in der Statusleiste
    • DXF-Konverter speichert beim Verlassen verschiedene Informationen und stellt diese bei erneutem Aufruf wieder her
    • Beim Speichern von Konturen und Punkten kann jetzt das gewünschte Datei-Format gewählt werden
    • Bearbeitungs-Positionen können jetzt auch in ein Klartext-Dialog-Programmgespeichert werden
    • DXF-Konverter steht jetzt in einem neuen Look and Feel zur Verfügung, wenn die DXF-Datei über die Datei-Verwaltung direkt geöffnet wird
  • Erweiterungen in der Datei-Verwaltung:
    • In der Datei-Verwaltung steht jetzt eine Vorschaufunktion zur Verfügung (siehe Datei-Verwaltung aufrufen)
    • In der Datei-Verwaltung stehen zusätzliche Einstellmöglichkeiten zur Verfügung (siehe Datei-Verwaltung anpassen)
  • Erweiterungen bei den globalen Programmeinstellung GS:
    • Die Funktion Limit-Ebene steht jetzt zur Verfügung (siehe Limit-Ebene)
  • Erweiterungen in der Werkzeug-Tabelle TOOL.T:
    • Die Inhalte von Tabellenzeilen können entweder per Softkeys oder per Shortcuts kopiert und wieder eingefügt werden (siehe Editierfunktionen)
    • Die neue Spalte ACC wurde eingeführt (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten)
  • In der erweiterten Werkzeug-Verwaltung stehen nun folgende zusätzliche Funktionen zur Verfügung:
    • Grafische Darstellung des Werkzeug-Typs in der Tabellenansicht und im Formular Werkzeug-Daten (siehe Werkzeug-Verwaltung (Software-Option))
    • Neue Funktion ANSICHT AKTUALISIEREN zur Neuinitialisierung bei inkosistentem Datenbestand (siehe Werkzeug-Verwaltung bedienen)
    • Neue Funktion Tabelle auffüllen beim Importieren von Werkzeug-Daten (siehe Werkzeugdaten importieren)
  • In der zusätzlichen Status-Anzeige steht jetzt ein zusätzlicher Reiter zur Verfügung, in dem die Bereichsgrenzen und die Istwerte von Handradüberlagerungen agezeigt werden (siehe Informationen zur Handrad-Überlagerung (Reiter POS HR))
  • Beim Satzvorlauf auf eine Punkt-Tabelle steht jetzt ein Vorschaubild zur Verfügung, über das sich die Einstiegsposition grafisch selektieren lässt (siehe Beliebiger Einstieg ins Programm (Satzvorlauf))
  • Beim Zyklus 256 Rechteckzapfen steht jetzt ein Parameter zur Verfügung, mit dem Sie die Anfahrposition am Zapfen festlegen können (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Beim Zyklus 257 Kreiszapfen steht jetzt ein Parameter zur Verfügung, mit dem Sie die Anfahrposition am Zapfen festlegen können (siehe Benutzer-Handbuch Zyklen-Programmierung)


Neue Funktionen 60642x‑04

  • Für die Steuerung der Funktion adaptive Vorschubregelung AFC wurde eine neue NC-Syntax eingeführt (siehe Lernschnitt durchführen)
  • Über die globalen Programmeinstellungen können Sie eine Handradüberlagerung nun auch im geschwenkten Koordinatensystem ausführen (siehe Handrad-Überlagerung)
  • Werkzeugnamen im TOOL CALL-Satz können nun auch über String-Parameter QS aufgerufen werden (siehe Werkzeug-Daten aufrufen)
  • Die Verschachtelungstiefe bei Programmaufrufen wurde von 10 auf 30 erhöht (siehe Verschachtelungstiefe)
    • Die neue Spalte ACC wurde eingeführt (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten)
  • In der Werkzeug-Tabelle stehen folgende neue Spalten zur Verfügung:
    • Spalte OVRTIME: Definieren einer maximal möglichen Standzeitüberschreitung (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten)
    • Spalte P4: Übergabemöglichkeit eines Wertes an die PLC (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten)
    • Spalte CR: Übergabemöglichkeit eines Wertes an die PLC (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten)
    • Spalte CL: Übergabemöglichkeit eines Wertes an die PLC (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten)
  • DXF-Konverter:
    • Lesezeichen einfügbar bei der Speichern-Funktion (siehe Lesezeichen)
  • Zyklus 25: Automatische Restmaterialerkennung neu dazu (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 200: Eingabeparameter Q359 zur Festlegung des Tiefenbezugs ergänzt (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 203: Eingabeparameter Q359 zur Festlegung des Tiefenbezugs ergänzt (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 205: Eingabeparameter Q208 für Rückzugsvorschub ergänzt (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 205: Eingabeparameter Q359 zur Festlegung des Tiefenbezugs ergänzt (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 225: Eingabe von Umlauten ermöglicht, Text kann jetzt auch schräg angeordnet werden (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 253: Eingabeparameter Q439 für Vorschubbezug ergänzt (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 254: Eingabeparameter Q439 für Vorschubbezug ergänzt (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 276: Automatische Restmaterialerkennung neu dazu (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 290: Mit Zyklus 290 kann nun auch ein Einstich hergestellt werden (siehe Benutzer-Handbuch Zyklen-Programmierung)
  • Zyklus 404: Eingabeparameter Q305 neu dazu, um eine Grunddrehung in einer beliebigen Zeile der Bezugspunkt-Tabelle speichern zu können (siehe Benutzer-Handbuch Zyklen-Programmierung)


Geänderte Funktionen 60642x‑01 bezogen auf die Vorgänger-Versionen 34049x-05

  • In den Kalibriermenüs für Tastsystem-Länge und -Radius werden nun auch Nummer und Name des aktiven Werkzeugs angezeigt (wenn Kalibrierdaten aus der Werkzeug-Tabelle verwendet werden sollen, MP7411 = 1, siehe Mehrere Sätze von Kalibrierdaten verwalten)
  • Die PLANE-Funktion zeigt jetzt beim Einschwenken im Modus Restweg den tatsächlich noch zu verfahrenden Winkel bis zur Zielposition an (siehe Positions-Anzeige)
  • Anfahrverhalten beim Seitenschlichten mit Zyklus 24 (DIN/ISO: G124) geändert (siehe Benutzer-Handbuch Zyklen-Programmierung)


Geänderte Funktionen 60642x‑02

  • Werkzeugnamen können nun mit 32 Zeichen definiert werden (siehe Werkzeug-Nummer, Werkzeug-Name)
  • Verbesserte und vereinheitlichte Bedienung per Mouse und Touchpad in allen Grafikfenstern (siehe Funktionen der 3D-Liniengrafik)
  • Verschieden Überblendfenster wurden auf ein neues Design umgestellt
  • Wird ein Programm-Test ohne Ermittlung der Bearbeitungszeit ausgeführt, dann erzeugt die TNC dennoch eine Werkzeug-Einsatzdatei (siehe Werkzeug-Einsatzprüfung)
  • Die Größe von Service-ZIP-Files wurde auf 40 MByte erhöht (siehe Servicedateien erzeugen)
  • M124 kann jetzt durch Eingabe vom M124 ohne T deaktiviert werden (siehe Punkte beim Abarbeiten von nicht korrigierten Geradensätzen nicht berücksichtigen: M124)
  • Der Softkey Preset Tabelle wurde in Bezugspunkt-Verwaltung umbenannt
  • Der Softkey PRESET SPEICHERN wurde umbenannt in AKTIVEN PRESET SPEICHERN


Geänderte Funktionen 60642x‑03

  • Verschieden Überblendfenster (z.B. Fenster der Messprotokolle, FN16-Fenster) wurden auf ein neues Design umgestellt. Diese Fenster haben jetzt eine Scrollbar und sind auf dem Bildschirm per Mouse verschiebbar
  • Eine Grunddrehung kann jetzt auch mit angestellten Drehachsen angetastet werden (siehe Einführung)
  • Die Werte in der Beugspunkt-Tabelle werden nun auch in Inch angezeigt, wenn die Positions-Anzeige auf INCH gestellt ist (siehe Bezugspunkt-Verwaltung mit der Bezugspunkt-Tabelle)


Geänderte Funktionen 60642x‑04

  • DXF-Konverter:
    • Die Richtung einer Kotur ist nun bereits durch den ersten Klick auf das erste Konturelement festgelegt (siehe Kontur wählen und speichern)
    • Das Löschen mehrer bereits selektierter Bohrpositionen kann nun durch Aufziehen eines Fensters bei gleichzeitig gedrückter STRG-Taste erfolgen (siehe Schnellanwahl von Bohrpositionen über Mouse-Bereich)
  • Die TNC zeigt Laufwerke in der Datei-Verwaltung in einer festgelegten Reihenfolge an (siehe Datei-Verwaltung aufrufen)
  • Die TNC wertet die Spalte PITCH der Werkzeug-Tabelle in Verbindung mit Gewindebohrzyklen aus (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten)


Erste Schritte mit der iTNC 530

Weitere Informationen:
> Übersicht
> Einschalten der Maschine
> Das erste Teil programmieren
> Das erste Teil grafisch testen
> Werkzeuge einrichten
> Werkstück einrichten
> Das erste Programm abarbeiten


Übersicht

Dieses Kapitel soll TNC-Einsteigern helfen, schnell mit den wichtigsten Bedienfolgen der TNC zurechtzukommen. Nähere Informationen zum jeweiligen Thema finden Sie in der zugehörigen Beschreibung, auf die jeweils verwiesen ist.

    Folgende Themen werden in diesem Kapitel behandelt:

  • Einschalten der Maschine
  • Das erste Teil programmieren
  • Das erste Teil grafisch testen
  • Werkzeuge einrichten
  • Werkstück einrichten
  • Das erste Programm abarbeiten


Einschalten der Maschine

Weitere Informationen:
> Stromunterbrechung quittieren und Referenzpunkte anfahren


Stromunterbrechung quittieren und Referenzpunkte anfahren

Das Einschalten und Anfahren der Referenzpunkte ist eine maschinenabhängige Funktion. Beachten Sie dazu auch Ihr Maschinenhandbuch.

  • Die Versorgungsspannung von TNC und Maschine einschalten: Die TNC startet das Betriebssystem. Dieser Vorgang kann einige Minuten dauern. Danach zeigt die TNC in der Kopfzeile des Bildschirms den Dialog Stromunterbrechung an

Taste CE drücken: Die TNC übersetzt das PLC-Programm

Steuerspannung einschalten: Die TNC überprüft die Funktion der Not-Aus-Schaltung und wechselt in den Modus Referenzpunkt fahren

Referenzpunkte in vorgegebener Reihenfolge überfahren: Für jede Achse externe START-Taste drücken. Wenn Sie absolute Längen- und Winkelmessgeräte an Ihrer Maschine haben, entfällt das Anfahren der Referenzpunkte

Die TNC ist jetzt betriebsbereit und befindet sich in der Betriebsart Manueller Betrieb.

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Referenzpunkte anfahren: Siehe Einschalten
  • Betriebsarten: Siehe Programm-Einspeichern/Editieren


Das erste Teil programmieren

Weitere Informationen:
> Die richtige Betriebsart wählen
> Die wichtigsten Bedienelemente der TNC
> Ein neues Programm eröffnen/Datei-Verwaltung
> Ein Rohteil definieren
> Programmaufbau
> Eine einfache Kontur programmieren
> Zyklenprogramm erstellen


Die richtige Betriebsart wählen

Programme erstellen können Sie ausschließlich in der Betriebsart Einspeichern/Editieren:

Betriebsarten-Taste drücken: Die TNC wechselt in die Betriebsart Einspeichern/Editieren
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Betriebsarten: Siehe Programm-Einspeichern/Editieren


Die wichtigsten Bedienelemente der TNC

Funktionen zur Dialogführung | Taste
Eingabe bestätigen und nächste Dialogfrage aktivieren |
Dialogfrage übergehen |
Dialog vorzeitig beenden |
Dialog abbrechen, Eingaben verwerfen |
Softkeys am Bildschirm, mit denen Sie abhängig vom aktiven Betriebszustand Funktion wählen |
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Programme erstellen und ändern: Siehe Programm editieren
  • Tastenübersicht: Siehe Bedienelemente der TNC


Ein neues Programm eröffnen/Datei-Verwaltung

Taste PGM MGT drücken: Die TNC öffnet die Datei-Verwaltung. Die Datei-Verwaltung der TNC ist ähnlich aufgebaut wie die Datei-Verwaltung auf einem PC mit dem Windows Explorer. Mit der Datei-Verwaltung verwalten Sie die Daten auf der TNC-Festplatte

Wählen Sie mit den Pfeiltasten den Ordner, in dem Sie die neue Datei öffnen wollen

Geben Sie einen Dateinamen mit der Endung .i ein: Die TNC öffnet dann automatisch ein Programm und fragt nach der Maßeinheit des neuen Programmes. Beachten Sie die Einschränkungen in Bezug auf Sonderzeichen im Dateinamen (siehe Namen von Dateien)

Maßeinheit wählen: Softkey MM oder INCH drücken: Die TNC startet automatisch die Rohteildefinition (siehe Ein Rohteil definieren)

Die TNC erzeugt den ersten und letzten Satz des Programmes automatisch. Diese Sätze können Sie nachträglich nicht mehr verändern.

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Datei-Verwaltung: Siehe Arbeiten mit der Datei-Verwaltung
  • Neues Programm erstellen: Siehe Programme eröffnen und eingeben


Ein Rohteil definieren

Nachdem Sie ein neues Programm eröffnet haben, startet die TNC sofort den Dialog zur Eingabe der Rohteildefinition. Als Rohteil definieren Sie immer einen Quader durch Angabe des MIN- und MAX-Punktes, jeweils bezogen auf den gewählten Bezugspunkt.

Nachdem Sie ein neues Programm eröffnet haben, leitet die TNC automatisch die Rohteil-Definition ein und fragt die erforderlichen Rohteildaten ab:

  • Spindelachse Z - Ebene XY?: Aktive Spindelachse eingeben. G17 ist als Voreinstellung hinterlegt, mit Taste ENT übernehmen

  • Koordinaten?: Kleinste X-Koordinate des Rohteils bezogen auf den Bezugspunkt eingeben, z.B. 0, mit Taste ENT bestätigen

  • Koordinaten?: Kleinste Y-Koordinate des Rohteils bezogen auf den Bezugspunkt eingeben, z.B. 0, mit Taste ENT bestätigen

  • Koordinaten?: Kleinste Z-Koordinate des Rohteils bezogen auf den Bezugspunkt eingeben, z.B. -40, mit Taste ENT bestätigen

  • Koordinaten?: Größte X-Koordinate des Rohteils bezogen auf den Bezugspunkt eingeben, z.B. 100, mit Taste ENT bestätigen

  • Koordinaten?: Größte Y-Koordinate des Rohteils bezogen auf den Bezugspunkt eingeben, z.B. 100, mit Taste ENT bestätigen

  • Koordinaten?: Größte Z-Koordinate des Rohteils bezogen auf den Bezugspunkt eingeben, z.B. 0, mit Taste ENT bestätigen: Die TNC beendet den Dialog

NC-Beispielsätze
%neu g71 *
n10 g30 g17 x+0 y+0 z-40 *
n20 G31 x+100 y+100 z+0 *
n99999999 %neu G71 *
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Rohteil definieren: Neues Bearbeitungs-Programm eröffnen


Programmaufbau

Bearbeitungsprogramme sollten möglichst immer ähnlich aufgebaut sein. Das erhöht die Übersicht, beschleunigt die Programmierung und reduziert Fehlerquellen.

Weitere Informationen:
> Empfohlener Programmaufbau bei einfachen, konventionellen Konturbearbeitungen
> Empfohlener Programmaufbau bei einfachen Zyklenprogrammen


Empfohlener Programmaufbau bei einfachen, konventionellen Konturbearbeitungen
Beispiel: Programmaufbau Konturprogrammierung
%bspcont g71 *
n10 g30 g71 x... y... z... *
n20 g31 x... y... z... *
n30 t5 g17 s5000 *
n40 g00 g40 g90 z+250 *
n50 x... y... *
n60 g01 z+10 f3000 m13 *
n70 x... y... rl f500 *
...
n160 g40 ... x... y... f3000 m9 *
n170 g00 z+250 m2 *
n99999999 bspcont g71 *
  1. Werkzeug aufrufen, Werkzeugachse definieren
  2. Werkzeug freifahren
  3. In der Bearbeitungsebene in die Nähe des Konturstartpunktes vorpositionieren
  4. In der Werkzeugachse über das Werkstück oder gleich auf Tiefe vorpositionieren, bei Bedarf Spindel/Kühlmittel einschalten
  5. Kontur anfahren
  6. Kontur bearbeiten
  7. Kontur verlassen
  8. Werkzeug freifahren, Programm beenden
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema:


Erste Schritte mit der iTNC 530 / Das erste Teil programmieren / Programmaufbau / Empfohlener Programmaufbau bei einfachen, konventionellen Konturbearbeitungen
Detaillierte Informationen zu diesem Thema:
  • Konturprogrammierung: Siehe Werkzeug-Bewegungen


Empfohlener Programmaufbau bei einfachen Zyklenprogrammen
Beispiel: Programmaufbau Zyklenprogrammierung
%bsbcyc g71 *
n10 g30 g71 x... y... z... *
n20 g31 x... y... z... *
n30 t5 g17 s5000 *
n40 g00 g40 g90 z+250 *
n50 g200... *
n60 x... y... *
n70 g79 m13 *
n80 g00 z+250 m2 *
n99999999 bsbcyc g71 *
  1. Werkzeug aufrufen, Werkzeugachse definieren
  2. Werkzeug freifahren
  3. Bearbeitungszyklus definieren
  4. Bearbeitungsposition anfahren
  5. Zyklus aufrufen, Spindel/Kühlmittel einschalten
  6. Werkzeug freifahren, Programm beenden
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema:


Detaillierte Informationen zu diesem Thema:
  • Zyklenprogrammierung: Siehe Benutzer-Handbuch Zyklen


Eine einfache Kontur programmieren

Die im Bild rechts dargestellte Kontur soll auf Tiefe 5 mm einmal umfräst werden. Die Rohteildefinition haben Sie bereits erstellt. Nachdem Sie über eine Funktionstaste einen Dialog eröffnet haben, geben Sie alle von der TNC in der Kopfzeile des Bildschirms abgefragten Daten ein.

Werkzeug aufrufen: Geben Sie die Werkzeugdaten ein. Bestätigen Sie die Eingabe jeweils mit der Taste ent, Werkzeugachse nicht vergessen

Werkzeug freifahren: Drücken Sie die orange Achstaste Z, um in der Werkzeugachse freizufahren, und geben den Wert für die anzufahrende Position ein, z.B. 250. Mit Taste ENT bestätigen

Radiuskorr.: RL/RR/keine Korr.? mit Taste ENT bestätigen: Keine Radiuskorrektur aktivieren

Zusatz-Funktion M? mit Taste END bestätigen: Die TNC speichert den eingegebenen Verfahrsatz

Werkzeug in der Bearbeitungsebene vorpositionieren: Drücken Sie die orange Achstaste X und geben den Wert für die anzufahrende Position ein, z.B. -20

Drücken Sie die orange Achstaste Y und geben den Wert für die anzufahrende Position ein, z.B. -20. Mit Taste ENT bestätigen

Radiuskorr.: RL/RR/keine Korr.? mit Taste ENT bestätigen: Keine Radiuskorrektur aktivieren

Zusatz-Funktion M? mit Taste END bestätigen: Die TNC speichert den eingegebenen Verfahrsatz

Werkzeug auf Tiefe fahren: Drücken Sie die orange Achstaste und geben den Wert für die anzufahrende Position ein, z.B. -5. Mit Taste ENT bestätigen

Radiuskorr.: RL/RR/keine Korr.? mit Taste ENT bestätigen: Keine Radiuskorrektur aktivieren

Vorschub F=? Positioniervorschub eingeben, z.B. 3000 mm/min, mit Taste ENT bestätigen

Zusatz-Funktion M? Spindel und Kühlmittel einschalten, z.B. M13, mit Taste END bestätigen: Die TNC speichert den eingegebenen Verfahrsatz

Kontur anfahren: Rundungs-Radius des Einfahrkreises definieren

Kontur bearbeiten, Konturpunkt 2 anfahren: Es genügt die Eingabe der sich ändernden Informationen, also lediglich Y-Koordinate 95 eingeben und mit Taste END Eingaben speichern

Konturpunkt 3 anfahren: X-Koordinate 95 eingeben und mit Taste END Eingaben speichern

Fase am Konturpunkt 3 definieren: Fasenbreite 10 mm eingeben, mit Taste END speichern

Konturpunkt 4 anfahren: Y-Koordinate 5 eingeben und mit Taste END Eingaben speichern

Fase am Konturpunkt 4 definieren: Fasenbreite 20 mm eingeben, mit Taste END speichern

Konturpunkt 1 anfahren: X-Koordinate 5 eingeben und mit Taste END Eingaben speichern

Kontur verlassen: Rundungs-Radius des Ausfahrkreises definieren

Werkzeug freifahren: Drücken Sie die orange Achstaste Z, um in der Werkzeugachse freizufahren, und geben den Wert für die anzufahrende Position ein, z.B. 250. Mit Taste ENT bestätigen

Radiuskorr.: RL/RR/keine Korr.? mit Taste ENT bestätigen: Keine Radiuskorrektur aktivieren

Zusatz-Funktion M? M2 für Programmende eingeben, mit Taste END bestätigen: Die TNC speichert den eingegebenen Verfahrsatz

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Komplettes Beispiel mit NC-Sätzen: Siehe
  • Neues Programm erstellen: Siehe Programme eröffnen und eingeben
  • Konturen anfahren/verlassen: Siehe Kontur anfahren und verlassen
  • Konturen programmieren: Siehe Übersicht der Bahnfunktionen
  • Werkzeug-Radiuskorrektur: Siehe Werkzeug-Radiuskorrektur
  • Zusatz-Funktionen M: Siehe Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel


Zyklenprogramm erstellen

Die im Bild rechts dargestellten Bohrungen (Tiefe 20 mm) sollen mit einem Standardbohrzyklus gefertigt werden. Die Rohteildefinition haben Sie bereits erstellt.

Werkzeug aufrufen: Geben Sie die Werkzeugdaten ein. Bestätigen Sie die Eingabe jeweils mit der Taste ent, Werkzeugachse nicht vergessen

Werkzeug freifahren: Drücken Sie die orange Achstaste Z, um in der Werkzeugachse freizufahren, und geben den Wert für die anzufahrende Position ein, z.B. 250. Mit Taste ENT bestätigen

Radiuskorr.: RL/RR/keine Korr.? mit Taste ENT bestätigen: Keine Radiuskorrektur aktivieren

Zusatz-Funktion M? mit Taste END bestätigen: Die TNC speichert den eingegebenen Verfahrsatz

Zyklenmenü aufrufen

Bohrzyklen anzeigen

Standardbohrzyklus 200 wählen: Die TNC startet den Dialog zur Zyklusdefinition. Geben Sie die von der TNC abgefragten Parameter Schritt für Schritt ein, Eingabe jeweils mit Taste ENT bestätigen. Die TNC zeigt im rechten Bildschirm zusätzlich eine Grafik an, in der der jeweilige Zyklusparameter dargestellt ist

Erste Bohrposition anfahren: Koordinaten der Bohrposition eingeben, Kühlmittel und Spindel einschalten, Zyklus mit M99 rufen

Weitere Bohrposition anfahren: Koordinaten der jeweiligen Bohrpositionen eingeben, Zyklus mit M99 rufen

Werkzeug freifahren: Drücken Sie die orange Achstaste Z, um in der Werkzeugachse freizufahren, und geben den Wert für die anzufahrende Position ein, z.B. 250. Mit Taste ENT bestätigen

Radiuskorr.: RL/RR/keine Korr.? mit Taste ENT bestätigen: Keine Radiuskorrektur aktivieren

Zusatz-Funktion M? M2 für Programmende eingeben, mit Taste END bestätigen: Die TNC speichert den eingegebenen Verfahrsatz

NC-Beispielsätze
%C200 G71 * |
n10 g30 g17 X+0 Y+0 Z-40 * | Rohteil-Definition
n20 g31 X+100 Y+100 Z+0 * |
n30 T5 g17 S4500 * | Werkzeug-Aufruf
n40 g00 g40 g90 Z+250 * | Werkzeug freifahren
n50 g200 BOHREN | Zyklus definieren
Q200=2 ;sicherheits-abst. |
Q201=-20 ;tiefe |
Q206=250 ;f tiefenzust. |
Q202=5 ;zustell-tiefe |
Q210=0 ;F.-zeit oben |
Q203=-10 ;koor. oberfl. |
Q204=20 ;2. s.-abstand |
Q211=0.2 ;verweilzeit unten |
n60 x+10 y+10 m13 m99 * | Spindel und Kühlmittel ein, Zyklus aufrufen
n70 x+10 y+90 m99 * | Zyklus aufrufen
n80 x+90 y+10 m99 * | Zyklus aufrufen
n90 x+90 y+90 m99 * | Zyklus aufrufen
n100 g00 Z+250 M2 * | Werkzeug freifahren, Programm-Ende
n99999999 %c200 g71 * |
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Neues Programm erstellen: Siehe Programme eröffnen und eingeben
  • Zyklenprogrammierung: Siehe Benutzer-Handbuch Zyklen


Das erste Teil grafisch testen

Weitere Informationen:
> Die richtige Betriebsart wählen
> Werkzeug-Tabelle für den Programm-Test wählen
> Das Programm wählen, das Sie testen wollen
> Die Bildschirm-Aufteilung und die Ansicht wählen
> Den Programm-Test starten


Die richtige Betriebsart wählen

Programme testen können Sie ausschließlich in der Betriebsart Programm-Test:

Betriebsarten-Taste drücken: Die TNC wechselt in die Betriebsart Programm-Test
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Betriebsarten der TNC: Siehe Betriebsarten
  • Programme testen: Siehe Programm-Test


Werkzeug-Tabelle für den Programm-Test wählen

Diesen Schritt müssen Sie nur Ausführen, wenn Sie in der Betriebsart Programm-Test noch keine Werkzeug-Tabelle aktiviert haben.

Taste PGM MGT drücken: Die TNC öffnet die Datei-Verwaltung

Softkey typ wählen drücken: Die TNC zeigt ein Softkeymenü zur Auswahl des anzuzeigenden Datei-Typs

Softkey alle anz. drücken: Die TNC zeigt alle gespeicherten Dateien im rechten Fenster an

Hellfeld nach links auf die Verzeichnisse schieben

Hellfeld auf das Verzeichnis TNC:\ schieben

Hellfeld nach rechts auf die Dateien schieben

Hellfeld auf die Datei TOOL.T (aktive Werkzeug-Tabelle) schieben, mit Taste ENT übernehmen: TOOL.T erhält den Status S und ist damit für den Programm-Test aktiv

Taste END drücken: Datei-Verwaltung verlassen

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Werkzeug-Verwaltung: Siehe Werkzeug-Daten in die Tabelle eingeben
  • Programme testen: Siehe Programm-Test


Das Programm wählen, das Sie testen wollen

Taste PGM MGT drücken: Die TNC öffnet die Datei-Verwaltung

Softkey letzte dateien drücken: Die TNC öffnet ein Überblendfenster mit den zuletzt gewählten Dateien

Mit den Pfeiltasten das Programm wählen, das Sie testen wollen, mit Taste ENT übernehmen

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Programm wählen: Siehe Arbeiten mit der Datei-Verwaltung


Die Bildschirm-Aufteilung und die Ansicht wählen

Taste zur Auswahl der Bildschirm-Aufteilung drücken: Die TNC zeigt in der Softkey-Leiste alle verfügbaren Alternativen an

Softkey programm + grafik drücken: Die TNC zeigt in der linken Bildschirmhäfte das Progamm, in der rechten Bildschirmhälfte das Rohteil an

Per Softkey die gewünschte Ansicht wählen

Draufsicht anzeigen

Darstellung in 3 Ebenen anzeigen

3D-Darstellung anzeigen

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Grafikfunktionen: Siehe Grafiken
  • Programm-Test durchführen: Siehe Programm-Test


Den Programm-Test starten

Softkey reset + start drücken: Die TNC simuliert das aktive Programm, bis zu einer programmierten Unterbrechung oder bis zum Programmende

Während die Simulation läuft, können Sie über die Softkeys die Ansichten wechseln

Softkey stopp drücken: Die TNC unterbricht den Programm-Test

Softkey start drücken: Die TNC setzt den Programm-Test nach einer Unterbrechung fort

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Programm-Test durchführen: Siehe Programm-Test
  • Grafikfunktionen: Siehe Grafiken
  • Testgeschwindigkeit einstellen: Siehe Geschwindigkeit des Programm-Tests einstellen


Werkzeuge einrichten

Weitere Informationen:
> Die richtige Betriebsart wählen
> Werkzeuge vorbereiten und vermessen
> Die Werkzeug-Tabelle TOOL.T
> Die Platz-Tabelle TOOL_P.TCH


Die richtige Betriebsart wählen

Werkzeuge richten Sie in der Betriebsart Manueller Betrieb ein:

Betriebsarten-Taste drücken: Die TNC wechselt in die Betriebsart Manueller Betrieb
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Betriebsarten der TNC: Siehe Betriebsarten


Werkzeuge vorbereiten und vermessen

  • Erforderliche Werkzeuge in die jeweiligen Spannfutter spannen

  • Bei Vermessung mit externem Werkzeug-Voreinstellgerät: Werkzeuge vermessen, Länge und Radius notieren oder direkt mit einem Übertragungsprogramm zur Maschine übertragen

  • Bei Vermessung auf der Maschine: Werkzeuge im Werkzeugwechsler einlagern Die Platz-Tabelle TOOL_P.TCH


Die Werkzeug-Tabelle TOOL.T

In der Werkzeug-Tabelle TOOL.T (fest gespeichert unter TNC:\) speichern Sie Werkzeugdaten wie Länge und Radius, aber auch weitere werkzeugspezifische Informationen, die die TNC für die Ausführung verschiedenster Funktionen benötigt.

Um Werkzeugdaten in die Werkzeug-Tabelle TOOL.T einzugeben, gehen Sie wie folgt vor:

Werkzeug-Tabelle anzeigen: Die TNC zeigt die Werkzeug-Tabelle in einer Tabellendarstellung

Werkzeug-Tabelle ändern: Softkey EDITIEREN auf EIN setzen

Mit den Pfeiltasten nach unten oder nach oben die Werkzeug-Nummer wählen, die Sie ändern wollen

Mit den Pfeiltasten nach rechts oder nach links die Werkzeugdaten wählen, die Sie ändern wollen

Werkzeug-Tabelle verlassen: Taste END drücken

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Betriebsarten der TNC: Siehe Betriebsarten
  • Arbeiten mit der Werkzeug-Tabelle: Siehe Werkzeug-Daten in die Tabelle eingeben


Die Platz-Tabelle TOOL_P.TCH

Die Funktionsweise der Platz-Tabelle ist maschinenabhängig. Beachten Sie dazu auch Ihr Maschinenhandbuch.

In der Platz-Tabelle TOOL_P.TCH (fest gespeichert unter TNC:\) legen Sie fest, welche Werkzeuge in Ihrem Werkzeug-Magazin bestückt sind.

Um Daten in die Platz-Tabelle TOOL_P.TCH einzugebengehen Sie wie folgt vor:

Werkzeug-Tabelle anzeigen: Die TNC zeigt die Werkzeug-Tabelle in einer Tabellendarstellung

Platz-Tabelle anzeigen: Die TNC zeigt die Platz-Tabelle in einer Tabellendarstellung

Platz-Tabelle ändern: Softkey EDITIEREN auf EIN setzen

Mit den Pfeiltasten nach unten oder nach oben die Platz-Nummer wählen, die Sie ändern wollen

Mit den Pfeiltasten nach rechts oder nach links die Daten wählen, die Sie ändern wollen

Platz-Tabelle verlassen: Taste END drücken

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Betriebsarten der TNC: Siehe Betriebsarten
  • Arbeiten mit der Platz-Tabelle: Siehe Platz-Tabelle für Werkzeug-Wechsler


Werkstück einrichten

Weitere Informationen:
> Die richtige Betriebsart wählen
> Werkstück aufspannen
> Werkstück ausrichten mit Tastsystem
> Bezugspunkt-Setzen mit Tastsystem


Die richtige Betriebsart wählen

Werkstücke richten Sie in der Betriebsart Manueller Betrieb oder El. Handrad ein

Betriebsarten-Taste drücken: Die TNC wechselt in die Betriebsart Manueller Betrieb
Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Der Manuelle Betrieb: Siehe Verfahren der Maschinenachsen


Werkstück aufspannen

Spannen Sie das Werkstück mit einer Spannvorrichtung auf den Maschinentisch. Wenn Sie ein Tastsystem an Ihrer Maschine zur Verfügung haben, dann entfällt das achsparallele Ausrichten des Werkstücks.

Wenn Sie kein Tastsystem zur Verfügung haben, dann müssen Sie das Werkstück so ausrichten, dass es parallel zu den Maschinenachsen aufgespannt ist.


Werkstück ausrichten mit Tastsystem

  • Tastsystem einwechseln: In der Betriebsart MDI (MDI = Manual Data Input) einen TOOL CALL-Satz mit Angabe der Werkzeugachse ausführen und anschließend wieder die Betriebsart Manueller Betrieb wählen (in der Betriebsart MDI können Sie beliebige NC-Sätze unabhängig voneinander satzweise abarbeiten)

Antast-Funktionen wählen: Die TNC zeigt in der Softkey-Leiste die verfügbaren Funktionen an

Grunddrehung messen: Die TNC blendet das Grunddrehungsmenü ein. Zum Erfassen der Grunddrehung zwei Punkte auf einer Geraden am Werkstück antasten

Tastsystem mit den Achsrichtungstasten in die Nähe des ersten Antastpunktes vorpositionieren

Per Softkey die Antastrichtung wählen

NC-Start drücken: Das Tastsystem fährt in die definierte Richtung, bis es das Werkstück berührt und anschließend automatisch wieder zurück auf den Startpunkt

Tastsystem mit den Achsrichtungstasten in die Nähe des zweiten Antastpunktes vorpositionieren

NC-Start drücken: Das Tastsystem fährt in die definierte Richtung, bis es das Werkstück berührt und anschließend automatisch wieder zurück auf den Startpunkt

Anschließend zeigt die TNC die ermittelte Grunddrehung an

Menü mit Taste END verlassen, Frage nach Übernahme der Grunddrehung in die Preset-Tabelle mit Taste NO ENT bestätigen (nicht übernehmen)

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Betriebsart MDI: Siehe Einfache Bearbeitungen programmieren und abarbeiten
  • Werkstück ausrichten: Siehe Werkstück-Schieflage mit Tastsystem kompensieren


Bezugspunkt-Setzen mit Tastsystem

  • Tastsystem einwechseln: In der Betriebsart MDI einen TOOL CALL-Satz mit Angabe der Werkzeugachse ausführen und anschließend wieder die Betriebsart Manueller Betrieb wählen

Antast-Funktionen wählen: Die TNC zeigt in der Softkey-Leiste die verfügbaren Funktionen an

Bezugspunkt z.B. an die Werkstückecke setzen: Die TNC fragt, ob Sie die Antastpunkte aus der zuvor erfassten Grunddrehung übernehmen wollen. Taste ENT drücken, um Punkte zu übernehmen

Tastsystem in die Nähe des ersten Antastpunkts auf der Werkstückkante positionieren, die für die Grunddrehung nicht angetastet wurde

Per Softkey die Antastrichtung wählen

NC-Start drücken: Das Tastsystem fährt in die definierte Richtung, bis es das Werkstück berührt und anschließend automatisch wieder zurück auf den Startpunkt

Tastsystem mit den Achsrichtungstasten in die Nähe des zweiten Antastpunktes vorpositionieren

NC-Start drücken: Das Tastsystem fährt in die definierte Richtung, bis es das Werkstück berührt und anschließend automatisch wieder zurück auf den Startpunkt

Anschließend zeigt die TNC die Koordinaten des ermittelten Eckpunktes an

0 setzen: Softkey bezugsp. setzen drücken

Menü mit Taste END verlassen

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Bezugspunkte setzen: Siehe Bezugspunkt-Setzen mit Tastsystem


Das erste Programm abarbeiten

Weitere Informationen:
> Die richtige Betriebsart wählen
> Das Programm wählen, das Sie abarbeiten wollen
> Programm starten


Die richtige Betriebsart wählen

Programme abarbeiten können Sie entweder in der Betriebsart Programmlauf Einzelsatz oder in der Betriebsart Programmlauf-Satzfolge:

Betriebsarten-Taste drücken: Die TNC wechselt in die Betriebsart Programmlauf Einzelsatz, die TNC arbeitet das Programm Satz für Satz ab. Sie müssen jeden Satz mit der Taste NC-Start bestätigen

Betriebsarten-Taste drücken: Die TNC wechselt in die Betriebsart Programmlauf Satzfolge, die TNC arbeitet das Programm nach NC-Start bis zu einer Programm-Unterbrechung oder bis zum Ende ab

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Betriebsarten der TNC: Siehe Betriebsarten
  • Programme abarbeiten: Siehe Programmlauf


Das Programm wählen, das Sie abarbeiten wollen

Taste PGM MGT drücken: Die TNC öffnet die Datei-Verwaltung

Softkey letzte Dateien drücken: Die TNC öffnet ein Überblendfenster mit den zuletzt gewählten Dateien

Bei Bedarf mit den Pfeiltasten das Programm wählen, das Sie abarbeiten wollen, mit Taste ENT übernehmen

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Datei-Verwaltung: Siehe Arbeiten mit der Datei-Verwaltung


Programm starten

Taste NC-Start drücken: Die TNC arbeitet das aktive Programm ab

Weitere Informationen:
> Detaillierte Informationen zu diesem Thema


Detaillierte Informationen zu diesem Thema
  • Programme abarbeiten: Siehe Programmlauf


Einführung

Weitere Informationen:
> Die iTNC 530
> Bildschirm und Bedienfeld
> Betriebsarten
> Status-Anzeigen
> Window-Manager
> Sicherheitssoftware SELinux
> Zubehör: Tastsysteme und elektronische Handräder von HEIDENHAIN


Die iTNC 530

HEIDENHAIN TNC’s sind werkstattgerechte Bahnsteuerungen, mit denen Sie herkömmliche Fräs- und Bohrbearbeitungen direkt an der Maschine im leicht verständlichen Klartext-Dialog programmieren. Sie sind für den Einsatz an Fräs- und Bohrmaschinen sowie Bearbeitungszentren ausgelegt. Die iTNC 530 kann bis zu 18 Achsen steuern. Zusätzlich können Sie die Winkelposition von bis zu 2 Spindeln programmiert einstellen.

Auf der integrierten Festplatte können Sie beliebig viele Programme speichern, auch wenn diese extern erstellt wurden. Für schnelle Berechnungen lässt sich ein Taschenrechner jederzeit aufrufen.

Bedienfeld und Bildschirmdarstellung sind übersichtlich gestaltet, so dass Sie alle Funktionen schnell und einfach erreichen können.

Weitere Informationen:
> Programmierung: HEIDENHAIN Klartext-Dialog, smarT.NC und DIN/ISO
> Kompatibilität


Programmierung: HEIDENHAIN Klartext-Dialog, smarT.NC und DIN/ISO

Besonders einfach ist die Programm-Erstellung im benutzerfreundlichen HEIDENHAIN-Klartext-Dialog. Eine Programmier-Grafik stellt die einzelnen Bearbeitungs-Schritte während der Programmeingabe dar. Zusätzlich hilft die Freie Kontur-Programmierung FK, wenn einmal keine NC-gerechte Zeichnung vorliegt. Die grafische Simulation der Werkstückbearbeitung ist sowohl während des Programm-Tests als auch während des Programmlaufs möglich.

TNC-Neueinsteigern bietet die Betriebsart smarT.NC eine besonders komfortable Möglichkeit, schnell und ohne großen Schulungsaufwand strukturierte Klartext-Dialog-Programme zu erstellen. Für smarT.NC steht eine separate Benutzer-Dokumentation zur Verfügung.

Zusätzlich können Sie die TNC’s auch nach DIN/ISO oder im DNC-Betrieb programmieren.

Ein Programm lässt sich auch dann eingeben und testen, während ein anderes Programm gerade eine Werkstückbearbeitung ausführt.


Kompatibilität

Die TNC kann Bearbeitungs-Programme abarbeiten, die an -HEIDENHAIN-Bahnsteuerungen ab der TNC 150 B erstellt wurden. Sofern alte TNC-Programme Herrsteller-Zyklen enthalten, ist seitens der iTNC 530 eine Anpassung mit der PC-Software CycleDesign durchzuführen. Setzen Sie sich dazu mit Ihrem Maschinenhersteller oder mit HEIDENHAIN in Verbindung.


Bildschirm und Bedienfeld

Weitere Informationen:
> Bildschirm
> Bildschirm-Aufteilung festlegen
> Bedienfeld


Bildschirm

Die TNC wird mit einem 15-Zoll Farb-Flachbildschirm geliefert. Alternativ steht auch ein 19-Zoll Farb-Flachbildschirm zur Verfügung.

1 | Kopfzeile Bei eingeschalteter TNC zeigt der Bildschirm in der Kopfzeile die angewählten Betriebsarten an: Maschinen-Betriebsarten links und Programmier-Betriebsarten rechts. Im größeren Feld der Kopfzeile steht die Betriebsart, auf die der Bildschirm geschaltet ist: dort erscheinen Dialogfragen und Meldetexte (Ausnahme: Wenn die TNC nur Grafik anzeigt).
2 | Softkeys In der Fußzeile zeigt die TNC weitere Funktionen in einer Softkey-Leiste an. Diese Funktionen wählen Sie über die darunterliegenden Tasten. Zur Orientierung zeigen schmale Balken direkt über der Softkey-Leiste die Anzahl der Softkey-Leisten an, die sich mit den außen angeordneten schwarzen Pfeil-Tasten wählen lassen. Die aktive Softkey-Leiste wird als aufgehellter Balken dargestellt. Beim 15-Zoll-Bildschirm stehen 8 Softkeys zur Verfügung, beim 19-Zoll-Bildschirm 10 Softkeys.
3 | Softkey-Wahltasten
4 | Softkey-Leisten umschalten
5 | Festlegen der Bildschirm-Aufteilung
6 | Bildschirm-Umschalttaste für Maschinen- und Programmier-Betriebsarten
7 | Softkey-Wahltasten für Maschinenhersteller-Softkeys. Beim 15-Zoll-Bildschirm stehen 6 Softkeys zur Verfügung, beim 19-Zoll-Bildschirm 18 Softkeys.
8 | Softkey-Leisten für Maschinenhersteller-Softkeys umschalten


Bildschirm-Aufteilung festlegen

Der Benutzer wählt die Aufteilung des Bildschirms: So kann die TNC z.B. in der Betriebsart Programm-Einspeichern/Editieren das Programm im linken Fenster anzeigen, während das rechte Fenster gleichzeitig z.B. eine Programmier-Grafik darstellt. Alternativ lässt sich im rechten Fenster auch die Programm-Gliederung anzeigen oder ausschließlich das Programm in einem großen Fenster. Welche Fenster die TNC anzeigen kann, hängt von der gewählten Betriebsart ab.

Bildschirm-Aufteilung festlegen:

Bildschirm-Umschalttaste drücken: Die Softkey-Leiste zeigt die möglichen Bildschirm-Aufteilungen an, siehe Betriebsarten

Bildschirm-Aufteilung mit Softkey wählen


Bedienfeld

Die TNC wird mit unterschiedlichen Bedienfeldern geliefert. Die Abbildungen zeigen die Bedienelemente der Bedienfelder TE 730 (15“) und TE 740 (19“):

1

Alpha-Tastatur für Texteingaben, Dateinamen und DIN/ISO-Programmierungen.

Zwei-Prozessor-Version: Zusätzliche Tasten zur Windows-Bedienung

2
  • Datei-Verwaltung
  • Taschenrechner
  • MOD-Funktion
  • HELP-Funktion

3

Programmier-Betriebsarten

4

Maschinen-Betriebsarten

5

Eröffnen der Programmier-Dialoge

6

Navigations-Tasten und Sprunganweisung GOTO

7

Zahleneingabe und Achswahl

8

Touchpad

9

smarT.NC-Navigationstasten

10

USB-Anschluss

Die Funktionen der einzelnen Tasten sind auf der ersten Umschlagsseite zusammengefasst.

Manche Maschinenhersteller verwenden nicht das Standard-Bedienfeld von HEIDENHAIN. Beachten Sie in diesen Fällen das Maschinenhandbuch.

Externe Tasten, wie z.B. NC-START oder NC-STOPP, sind ebenfalls im Maschinenhandbuch beschrieben.


Betriebsarten

Weitere Informationen:
> Manueller Betrieb und El. Handrad
> Positionieren mit Handeingabe
> Programm-Einspeichern/Editieren
> Programm-Test
> Programmlauf Satzfolge und Programmlauf Einzelsatz


Manueller Betrieb und El. Handrad

Das Einrichten der Maschinen geschieht im Manuellen Betrieb. In dieser Betriebsart lassen sich die Maschinenachsen manuell oder schrittweise positionieren, die Bezugspunkte setzen und die Bearbeitungsebene schwenken.

Die Betriebsart El. Handrad unterstützt das manuelle Verfahren der Maschinenachsen mit einem elektronischen Handrad HR.

Softkeys zur Bildschirm-Aufteilung (wählen wie zuvor beschrieben)

Fenster | Softkey
Positionen |
Links: Positionen, rechts: Status-Anzeige |
Links: Positionen, rechts: Aktive Kollisionskörper (FCL4-Funktion) |


Positionieren mit Handeingabe

In dieser Betriebsart lassen sich einfache Verfahrbewegungen programmieren, z.B. um planzufräsen oder vorzupositionieren.

Softkeys zur Bildschirm-Aufteilung

Fenster | Softkey
Programm |
Links: Programm, rechts: Status-Anzeige |
Links: Programm, rechts: Aktive Kollisionskörper (FCL4-Funktion). Wenn Sie diese Ansicht gewählt haben, zeigt die TNC eine Kollision durch rote Umrandung des Grafikfensters an. |


Programm-Einspeichern/Editieren

Ihre Bearbeitungs-Programme erstellen Sie in dieser Betriebsart. Vielseitige Unterstützung und Ergänzung beim Programmieren bieten die Freie Kontur-Programmierung, die verschiedenen Zyklen und die Q-Parameter-Funktionen. Auf Wunsch zeigt die Programmier-Grafik oder die 3D-Liniengrafik (FCL 2-Funktion) die programmierten Verfahrwege an.

Softkeys zur Bildschirm-Aufteilung

Fenster | Softkey
Programm |
Links: Programm, rechts: Programm-Gliederung |
Links: Programm, rechts: Programmier-Grafik |
Links: Programm, rechts: 3D-Liniengrafik |
3D-Liniengrafik |


Programm-Test

Die TNC simuliert Programme und Programmteile in der Betriebsart Programm-Test, um z.B. geometrische Unverträglichkeiten, fehlende oder falsche Angaben im Programm und Verletzungen des Arbeitsraumes herauszufinden. Die Simulation wird grafisch mit verschiedenen Ansichten unterstützt.

In Verbindung mit der Software-Option DCM (dynamische Kollisionsüberwachung), können Sie das Programm auf Kollisionen prüfen. Die TNC berücksichtigt dabei, wie beim Programmlauf, alle vom Maschinenhersteller definierten maschinenfesten Bauteile und eingemessene Spannmittel.

Softkeys zur Bildschirm-Aufteilung: siehe Programmlauf Satzfolge und Programmlauf Einzelsatz.


Programmlauf Satzfolge und Programmlauf Einzelsatz

In Programmlauf Satzfolge führt die TNC ein Programm bis zum Programm-Ende oder zu einer manuellen bzw. programmierten Unterbrechung aus. Nach einer Unterbrechung können Sie den Programmlauf wieder aufnehmen.

In Programmlauf Einzelsatz starten Sie jeden Satz mit der externen START-Taste einzeln.

Softkeys zur Bildschirm-Aufteilung

Fenster | Softkey
Programm |
Links: Programm, rechts: Programm-Gliederung |
Links: Programm, rechts: Status |
Links: Programm, rechts: Grafik |
Grafik |
Links: Programm, rechts: Aktive Kollisionskörper (FCL4-Funktion). Wenn Sie diese Ansicht gewählt haben, zeigt die TNC eine Kollision durch rote Umrandung des Grafikfensters an. |
Aktive Kollisionskörper (FCL4-Funktion). Wenn Sie diese Ansicht gewählt haben, zeigt die TNC eine Kollision durch rote Umrandung des Grafikfensters an. |

Softkeys zur Bildschirm-Aufteilung bei Paletten-Tabellen

Fenster | Softkey
Paletten-Tabelle |
Links: Programm, rechts: Paletten-Tabelle |
Links: Paletten-Tabelle, rechts: Status |
Links: Paletten-Tabelle, rechts: Grafik |


Status-Anzeigen

Weitere Informationen:
> „Allgemeine“ Status-Anzeige
> Zusätzliche Status-Anzeigen


„Allgemeine“ Status-Anzeige

    Die allgemeine Status-Anzeige im unteren Bereich des Bildschirms informiert Sie über den aktuellen Zustand der Maschine. Sie erscheint automatisch in den Betriebsarten

  • Programmlauf Einzelsatz und Programmlauf Satzfolge, solange für die Anzeige nicht ausschließlich „Grafik“ gewählt wurde, und beim
  • Positionieren mit Handeingabe.

In den Betriebsarten Manueller Betrieb und El. Handrad erscheint die Status-Anzeige im großen Fenster.

Informationen der Status-Anzeige

Symbol | Bedeutung
 | Ist- oder Soll-Koordinaten der aktuellen Position
 | Maschinenachsen; Hilfsachsen zeigt die TNC mit kleinen Buchstaben an. Die Reihenfolge und Anzahl der angezeigten Achsen legt Ihr Maschinenhersteller fest. Beachten Sie Ihr Maschinenhandbuch
 | Die Anzeige des Vorschubs in Zoll entspricht dem zehnten Teil des wirksamen Wertes. Drehzahl S, Vorschub F und wirksame Zusatzfunktion M
 | Programmlauf ist gestartet
 | Achse ist geklemmt
 | Achse kann mit dem Handrad verfahren werden
 | Achsen werden unter Berücksichtigung der Grund-drehung verfahren
 | Achsen werden in geschwenkter Bearbeitungsebene verfahren
 | Die Funktion M128 oder FUNCTION TCPM ist aktiv
 | Die Funktion Dynamische Kollisionsüberwachung DCM ist aktiv
 | Die Funktion Adaptive Vorschubregelung AFC ist aktiv (Software-Option)
 | Eine oder mehrere globale Programmeinstellungen sind aktiv (Software-Option)
 | Die Funktion aktive Ratterundrückung ACC ist aktiv (Software-Option)
 | Die Funktion Cross Talk Compensation zur Kompensation beschleunigungsabhängiger Positionsabweichungen CTC ist aktiv (Software-Option)
 | Nummer des aktiven Bezugspunkts aus der Preset-Tabelle. Wenn der Bezugspunkt manuell gesetzt wurde, zeigt die TNC hinter dem Symbol den Text MAN an


Zusätzliche Status-Anzeigen

Die zusätzlichen Status-Anzeigen geben detaillierte Informationen zum Programm-Ablauf. Sie lassen sich in allen Betriebsarten aufrufen, mit Ausnahme der Betriebsart Programm-Einspeichern/Editieren.

Weitere Informationen:
> Zusätzliche Status-Anzeige einschalten
> Zusätzliche Status-Anzeigen wählen
> Übersicht
> Allgemeine Programm-Information (Reiter PGM)
> Allgemeine Paletten-Information (Reiter PAL)
> Programmteil-Wiederholung/Unterprogramme (Reiter LBL)
> Informationen zu Standard-Zyklen (Reiter CYC)
> Aktive Zusatzfunktionen M (Reiter M)
> Positionen und Koordinaten (Reiter POS)
> Informationen zur Handrad-Überlagerung (Reiter POS HR)
> Informationen zu den Werkzeugen (Reiter TOOL)
> Werkzeug-Vermessung (Reiter TT)
> Koordinaten-Umrechnungen (Reiter TRANS)
> Globale Programmeinstellungen 1 (Reiter GPS1, Software-Option)
> Globale Programmeinstellungen 2 (Reiter GPS2, Software-Option)
> Adaptive Vorschubregelung AFC (Reiter AFC, Software-Option)


Zusätzliche Status-Anzeige einschalten

Softkey-Leiste für die Bildschirm-Aufteilung aufrufen

Bildschirmdarstellung mit zusätzlicher Status-Anzeige wählen: Die TNC zeigt in der rechten Bildschirmhälfte das Statusformular Übersicht an


Zusätzliche Status-Anzeigen wählen

Softkey-Leiste umschalten, bis STATUS-Softkeys erscheinen

Zusätzliche Status-Anzeige direkt per Softkey wählen, z.B. Positionen und Koordinaten, oder

Gewünschte Ansicht per Umschalt-Softkeys wählen

Nachfolgend sind die verfügbaren Status-Anzeigen beschrieben, die Sie über direkt über Softkeys oder über die Umschalt-Softkeys wählen können.

Beachten Sie bitte, dass einige der nachfolgend beschriebenen Status-Informationen nur dann zur Verfügung stehen, wenn Sie die dazugehörende Software-Option an Ihrer TNC freigeschaltet haben.


Übersicht

Das Status-Formular Übersicht zeigt die TNC nach dem Einschalten der TNC an, sofern Sie die Bildschirm-Aufteilung PROGRAMM+STATUS (bzw. POSITION + STATUS) gewählt haben. Das Übersichtsformular enthält zusammengefasst die wichtigsten Status-Informationen, die Sie auch verteilt auf den entsprechenden Detailformularen finden.

Softkey | Bedeutung
 | Positionsanzeige in bis zu 5 Achsen
 | Werkzeug-Informationen
 | Aktive M-Funktionen
 | Aktive Koordinaten-Transformtaionen
 | Aktives Unterprogramm
 | Aktive Programmteil-Wiederholung
 | Mit PGM CALL gerufenes Programm
 | Aktuelle Bearbeitungszeit
 | Name des aktiven Hauptprogrammes


Allgemeine Programm-Information (Reiter PGM)
Softkey | Bedeutung
Keine Direktanwahl möglich | Name des aktiven Hauptprogrammes
 | Kreismittelpunkt CC (Pol)
 | Zähler für Verweilzeit
 | Bearbeitungszeit, wenn das Programm in der Betriebsart Programm-Test vollständig simuliert wurde
 | Aktuelle Bearbeitungszeit in %
 | Aktuelle Uhrzeit
 | Aktueller Bahnvorschub
 | Aufgerufene Programme


Allgemeine Paletten-Information (Reiter PAL)
Softkey | Bedeutung
Keine Direktanwahl möglich | Nummer des aktiven Paletten-Presets


Programmteil-Wiederholung/Unterprogramme (Reiter LBL)
Softkey | Bedeutung
Keine Direktanwahl möglich | Aktive Programmteil-Wiederholungen mit Satz-Nummer, Label-Nummer und Anzahl der programmierten/noch auszuführenden Wiederholungen
 | Aktive Unterprogramm-Nummern mit Satz-Nummer, in der das Unterprogramm gerufen wurde und Label-Nummer die aufgerufen wurde


Informationen zu Standard-Zyklen (Reiter CYC)
Softkey | Bedeutung
Keine Direktanwahl möglich | Aktiver Bearbeitungs-Zyklus
 | Aktive Werte des Zyklus G62 Toleranz


Aktive Zusatzfunktionen M (Reiter M)
Softkey | Bedeutung
Keine Direktanwahl möglich | Liste der aktiven M-Funktionen mit festgelegter Bedeutung
 | Liste der aktiven M-Funktionen, die von Ihrem Maschinenhersteller angepasst werden


Positionen und Koordinaten (Reiter POS)
Softkey | Bedeutung
 | Art der Positionsanzeige, z. B. Ist-Position
 | In virtueller Achsrichtung VT verfahrener Wert (nur bei Software-Option Globale Programmeinstellungen)
 | Schwenkwinkel für die Bearbeitungsebene
 | Winkel der Grunddrehung


Informationen zur Handrad-Überlagerung (Reiter POS HR)
Softkey Bedeutung

Keine Direktanwahl möglich
  • Anzeige Achse: Anzeige aller aktiven Achsen der Maschine (VT = virtuelle Achse)
  • Anzeige Max.-Wert:
    Maximal erlaubter Verfahrweg in der jeweiligen Achse (definiert über M118 oder globale Programm-Einstellungen)
  • Anzeige Istwert:
    Tatsächlich mit Handradüberlagerung verfahrener Wert in der jeweiligen Achse


Informationen zu den Werkzeugen (Reiter TOOL)
Softkey Bedeutung

  • Anzeige T: Werkzeug-Nummer und -Name
  • Anzeige RT: Nummer und Name eines Schwester-Werkzeugs

Werkzeugachse

Werkzeug-Länge und -Radien

Aufmaße (Delta-Werte) aus der der Werkzeug-Tabelle (TAB) und dem TOOL CALL (PGM)

Standzeit, maximale Standzeit (TIME 1) und maximale Standzeit bei TOOL CALL (TIME 2)

Anzeige des aktiven Werkzeugs und des (nächsten) Schwester-Werkzeugs


Werkzeug-Vermessung (Reiter TT)

Die TNC zeigt den Reiter TT nur dann an, wenn diese Funktion an Ihrer Maschine aktiv ist.

Softkey | Bedeutung
Keine Direktanwahl möglich | Nummer des Werkzeugs, das vermessen wird
 | Anzeige, ob Werkzeug-Radius oder -Länge vermessen wird
 | MIN- und MAX-Wert Einzelschneiden-Vermessung und Ergebnis der Messung mit rotierendem Werkzeug (DYN)
 | Nummer der Werkzeug-Schneide mit zugehörigem Messwert. Der Stern hinter dem Messwert zeigt an, dass die Toleranz aus der Werkzeug-Tabelle überschritten wurde. Die TNC zeigt die Messwerte von maximal 24 Schneiden an.


Koordinaten-Umrechnungen (Reiter TRANS)
Softkey | Bedeutung
 | Name der aktiven Nullpunkt-Tabelle
 | Aktive Nullpunkt-Nummer (#), Kommentar aus der aktiven Zeile der aktiven Nullpunkt-Nummer (DOC) aus Zyklus G53
 | Aktive Nullpunkt-Verschiebung (Zyklus G54); Die TNC zeigt eine aktive Nullpunkt-Verschiebung in bis zu 8 Achsen an
 | Gespiegelte Achsen (Zyklus G28)
 | Aktive Grunddrehung
 | Aktiver Drehwinkel (Zyklus G73)
 | Aktiver Maßfaktor / Maßfaktoren (Zyklen G72); Die TNC zeigt einen aktiven Maßfaktor in bis zu 6 Achsen an
 | Mittelpunkt der zentrischen Streckung

Siehe Benutzer-Handbuch Zyklen, Zyklen zur Koordinaten-Umrechnung.


Globale Programmeinstellungen 1 (Reiter GPS1, Software-Option)

Die TNC zeigt den Reiter nur dann an, wenn diese Funktion an Ihrer Maschine aktiv ist.

Softkey | Bedeutung
Keine Direktanwahl möglich | Getauschte Achsen
 | Überlagerte Nullpunkt-Verschiebung
 | Überlagerte Spiegelung


Globale Programmeinstellungen 2 (Reiter GPS2, Software-Option)

Die TNC zeigt den Reiter nur dann an, wenn diese Funktion an Ihrer Maschine aktiv ist.

Softkey | Bedeutung
Keine Direktanwahl möglich | Gesperrte Achsen
 | Überlagerte Grunddrehung
 | Überlagerte Rotation
 | Aktiver Vorschubfaktor


Adaptive Vorschubregelung AFC (Reiter AFC, Software-Option)

Die TNC zeigt den Reiter AFC nur dann an, wenn diese Funktion an Ihrer Maschine aktiv ist.

Softkey | Bedeutung
Keine Direktanwahl möglich | Aktiver Modus, in dem die adaptive Vorschubregelung betrieben wird
 | Aktives Werkzeug (Nummer und Name)
 | Schnittnummer
 | Aktueller Faktor des Vorschub-Potentiometers in %
 | Aktuelle Spindellast in %
 | Referenzlast der Spindel
 | Aktuelle Drehzahl der Spindel
 | Aktuelle Abweichung der Drehzahl
 | Aktuelle Bearbeitungszeit
 | Liniendiagramm, in dem die aktuelle Spindellast und der von der TNC kommandierte Wert des Vorschub-Overrides angezeigt wird


Window-Manager

Ihr Maschinenhersteller legt den Funktionsumfang und das Verhalten des Window-Managers fest. Maschinenhandbuch beachten!

Auf der TNC steht der Window-Manager Xfce zur Verfügung. Xfce ist eine Standardanwendung für UNIX-basierte Betriebssysteme, mit der sich die grafische Benutzer-Oberfläche verwalten lässt. Mit dem Window-Manager sind folgende Funktionen möglich:

  • Taskleiste zum Umschalten zwischen verschiedenen Anwendungen (Benutzeroberflächen) anzeigen.
  • Zusätzlichen Desktop verwalten, auf dem Sonderanwendungen Ihres Maschinenherstellers ablaufen können.
  • Steuern des Fokus zwischen Anwendungen der NC-Software und Anwendungen des Maschinenherstellers.
  • Überblendfenster (Pop-Up Fenster) können Sie in Größe und Position verändern. Schließen, Wiederherstellen und Minimieren der Überblendfenster ist ebenfalls möglich.

Die TNC blendet im Bildschirm links oben einen Stern ein, wenn eine Anwendung des Windows-Managers, oder der Window-Manager selbst einen Fehler verursacht hat. Wechseln Sie in diesem Fall in den Window-Manager und beheben das Problem, ggf. Maschinenhandbuch beachten.

Weitere Informationen:
> Task-Leiste


Task-Leiste

Über die Task-Leiste, die Sie über die linke Windows-Taste auf der ASCII-Tastatur einblenden können, wählen Sie per Mouse verschiedene Arbeitsbereiche. Die iTNC stellt folgende Arbeitsbereiche zur Verfügung:

  • Arbeitsbereich 1: Aktive Maschinen-Betriebsart
  • Arbeitsbereich 2: Aktive Programmier-Betriebsart
  • Arbeitsbereich 3: Anwendungen des Maschinenherstellers (optional verfügbar), z.B. Fernsteuerung eines Windows-Rechners

Darüber hinaus können Sie über die Task-Leiste auch andere Anwendungen wählen, die Sie parallel zur TNC gestartet haben (z.B. auf den PDF Betrachter oder den TNCguide umschalten).

Über das grüne HEIDENHAIN-Symbol öffnen Sie per Mouse-Klick ein Menü, über das Sie Informationen erhalten, Einstellungen vornehmen oder Anwendungen starten können. Folgende Funktionen stehen zur Verfügung:

  • Über HeROS: Informationen zum Betriebssystem der TNC
  • NC Control: TNC-Software starten und stoppen. Nur für Diagnose-Zwecke erlaubt
  • Web Browser: Mozilla Firefox starten
  • RemoteDesktopManager: Konfiguration der Software-Option RemoteDesktopManager
  • Diagnostics: Benutzung nur für autorisierte Fachkräfte zum Starten von Diagnoseanwendungen
  • Einstellungen: Konfiguration verschiedener Einstellungen
    • Bildschirmschoner: Konfigurieren der verfügbaren Bildschirmschoner
    • Date/Time: Einstellung von Datum und Uhrzeit
    • Firewall: Konfiguration der Firewall
    • Language: Spracheinstellung für Systemdialoge. Die TNC überschreibt diese Einstellung beim Starten mit der Spracheinstellung des Maschinen-Parameters 7230
    • Network: Netzwerk-Einstellung
    • SELinux: Konfiguration des Virenscanners
    • Shares: Netzwerk-Verbindungen konfigurieren
    • VNC: Konfiguration des VNC-Servers
    • WindowManagerConfig: Konfiguration des Window-Managers
  • Tools: Nur für autorisierte Benutzer freigegeben. Die unter Tools verfügbaren Anwendungen können Sie durch Anwahl des zugehörigen Datei-Typs in der Datei-Verwaltung der TNC direkt starten (siehe Zusatztools zur Verwaltung externer Datei-Typen)


Sicherheitssoftware SELinux

SELinux ist eine Erweiterung für Linux-basierte Betriebssysteme. SELinux ist eine zusätzliche Sicherheitssoftware im Sinne von Mandatory Access Control (MAC) und schützt das System gegen die Ausführung nicht autorisierter Prozesse oder Funktionen und somit Viren und andere Schadsoftware.

MAC bedeutet, dass jede Aktion explizit erlaubt sein muss, andernfalls führt die TNC diese nicht aus. Die Software dient als zusätzlicher Schutz zur normalen Zugriffsbeschränkung unter Linux. Nur wenn die Standard-Funktionen und die Zugriffkontrolle von SELinux das Ausführen bestimmter Prozesse und Aktionen erlauben, wird dies zugelassen.

Die SELinux-Installation der TNC ist so vorbereitet, dass nur Programme ausgeführt werden dürfen, die mit der NC-Software von HEIDENHAIN installiert werden. Andere Programme können mit der Standard-Installation nicht ausgeführt werden.

Die Zugriffkontrolle von SELinux unter HEROS 5 ist wie folgt geregelt:

  • Die TNC führt nur Anwendungen aus, die mit der NC-Software von HEIDENHAIN installiert werden.
  • Dateien, die in Zusammenhang mit der Sicherheit der Software stehen (Systemdateien von SELinux, Boot-Dateien von HEROS 5, usw.) dürfen nur von explizit ausgewählten Programmen verändert werden.
  • Dateien, die von anderen Programmen neu erstellt werden, dürfen grundsätzlich nicht ausgeführt werden.
  • Es gibt nur zwei Vorgänge, denen es erlaubt ist neue Dateien auszuführen:
    • Starten eines Software-Updates
      Ein Software-Update von HEIDENHAIN kann Systemdateien ersetzen oder ändern.
    • Starten der SELinux-Konfiguration
      Die Konfiguration von SELinux ist in der Regel von Ihrem Maschinenhersteller durch ein Passwort geschützt, Maschinenhandbuch beachten.

HEIDENHAIN empfiehlt grundsätzlich die Aktivierung von SELinux, da dies einen zusätzlich Schutz gegen einen Angriff von außen darstellt.


Zubehör: Tastsysteme und elektronische Handräder von HEIDENHAIN

Weitere Informationen:
> Tastsysteme
> Elektronische Handräder HR


Tastsysteme

    Mit den verschiedenen Tastsystemen von HEIDENHAIN können Sie:

  • Werkstücke automatisch ausrichten
  • Schnell und genau Bezugspunkte setzen
  • Messungen am Werkstück während des Programmlaufs ausführen
  • Werkzeuge vermessen und prüfen

Alle Tastsystem-Funktionen sind im Benutzer-Handbuch Zyklen beschrieben. Wenden Sie sich ggf. an HEIDENHAIN, wenn Sie dieses Benutzer-Handbuch benötigen. ID: 670388‑xx.

Beachten Sie, dass HEIDENHAIN grundsätzlich nur dann die Gewährleistung für die Funktion der Tastsystem-Zyklen übernimmt, wenn Sie HEIDENHAIN-Tastsysteme verwenden!
Weitere Informationen:
> Die schaltenden Tastsysteme TS 220, TS 640 und TS 440
> Das Werkzeug-Tastsystem TT 140 zur Werkzeug-Vermessung


Die schaltenden Tastsysteme TS 220, TS 640 und TS 440

Diese Tastsysteme eignen sich besonders gut zum automatischen Werkstück-Ausrichten, Bezugspunkt-Setzen, für Messungen am Werkstück. Das TS 220 überträgt die Schaltsignale über ein Kabel und ist zudem eine kostengünstige Alternative, wenn Sie gelegentlich digitalisieren müssen.

Speziell für Maschinen mit Werkzeugwechsler eignen sich die Tastsysteme TS 640 (siehe Bild) und das kleinere TS 440, die die Schaltsignale via Infrarot-Strecke kabellos übertragen.

Das Funktionsprinzip: In den schaltenden Tastsystemen von HEIDENHAIN registriert ein verschleißfreier optischer Schalter die Auslenkung des Taststifts. Das erzeugte Signal veranlasst, den Istwert der aktuellen Tastsystem-Position zu speichern.


Das Werkzeug-Tastsystem TT 140 zur Werkzeug-Vermessung

Das TT 140 ist ein schaltendes Tastsystem zum Vermessen und Prüfen von Werkzeugen. Die TNC stellt hierzu 3 Zyklen zur Verfügung, mit denen sich Werkzeug-Radius und -Länge bei stehender oder rotierender Spindel ermitteln lassen. Die besonders robuste Bauart und die hohe Schutzart machen das TT 140 gegenüber Kühlmittel und Spänen unempfindlich. Das Schaltsignal wird mit einem verschleißfreien optischen Schalter gebildet, der sich durch eine hohe Zuverlässigkeit auszeichnet.


Elektronische Handräder HR

Die elektronischen Handräder vereinfachen das präzise manuelle Verfahren der Achsschlitten. Der Verfahrweg pro Handrad-Umdrehung ist in einem weiten Bereich wählbar. Neben den Einbau-Handrädern HR 130 und HR 150 bietet HEIDENHAIN auch die portablen Handräder HR 520 und HR 550 FS an. Eine detaillierte Beschreibung des HR 520 finden Sie im Kapitel 14 (siehe Verfahren mit elektronischen Handrädern)


Programmieren: Grundlagen, Datei-Verwaltung

Weitere Informationen:
> Grundlagen
> Programme eröffnen und eingeben
> Datei-Verwaltung: Grundlagen
> Arbeiten mit der Datei-Verwaltung


Grundlagen

Weitere Informationen:
> Wegmessgeräte und Referenzmarken
> Bezugssystem
> Bezugssystem an Fräsmaschinen
> Polarkoordinaten
> Absolute und inkrementale Werkstück-Positionen
> Bezugspunkt wählen


Wegmessgeräte und Referenzmarken

An den Maschinenachsen befinden sich Wegmessgeräte, die die Positionen des Maschinentisches bzw. des Werkzeugs erfassen. An Linearachsen sind üblicherweise Längenmessgeräte angebaut, an Rundtischen und Schwenkachsen Winkelmessgeräte.

Wenn sich eine Maschinenachse bewegt, erzeugt das dazugehörige Wegmessgerät ein elektrisches Signal, aus dem die TNC die genaue Ist-Position der Maschinenachse errechnet.

Bei einer Stromunterbrechung geht die Zuordnung zwischen der Maschinenschlitten-Position und der berechneten Ist-Position verloren. Um diese Zuordnung wieder herzustellen, verfügen inkrementale Wegmessgeräte über Referenzmarken. Beim Überfahren einer Referenzmarke erhält die TNC ein Signal, das einen maschinenfesten Bezugspunkt kennzeichnet. Damit kann die TNC die Zuordnung der Ist-Position zur aktuellen Maschinenposition wieder herstellen. Bei Längenmessgeräten mit abstandscodierten Referenzmarken müssen Sie die Maschinenachsen maximal 20 mm verfahren, bei Winkelmessgeräten um maximal 20°.

Bei absoluten Messgeräten wird nach dem Einschalten ein absoluter Positionswert zur Steuerung übertragen. Dadurch ist, ohne Verfahren der Maschinenachsen, die Zuordnung zwischen der Ist-Position und der Maschinenschlitten-Position direkt nach dem Einschalten wieder hergestellt.


Bezugssystem

Mit einem Bezugssystem legen Sie Positionen in einer Ebene oder im Raum eindeutig fest. Die Angabe einer Position bezieht sich immer auf einen festgelegten Punkt und wird durch Koordinaten beschrieben.

Im rechtwinkligen System (kartesisches System) sind drei Richtungen als Achsen X, Y und Z festgelegt. Die Achsen stehen jeweils senkrecht zueinander und schneiden sich in einem Punkt, dem Nullpunkt. Eine Koordinate gibt den Abstand zum Nullpunkt in einer dieser Richtungen an. So lässt sich eine Position in der Ebene durch zwei Koordinaten und im Raum durch drei Koordinaten beschreiben.

Koordinaten, die sich auf den Nullpunkt beziehen, werden als absolute Koordinaten bezeichnet. Relative Koordinaten beziehen sich auf eine beliebige andere Position (Bezugspunkt) im Koordinatensystem. Relative Koordinaten-Werte werden auch als inkrementale Koordinaten-Werte bezeichnet.


Bezugssystem an Fräsmaschinen

Bei der Bearbeitung eines Werkstücks an einer Fräsmaschine beziehen Sie sich generell auf das rechtwinklige Koordinatensystem. Das Bild rechts zeigt, wie das rechtwinklige Koordinatensystem den Maschinenachsen zugeordnet ist. Die Drei-Finger-Regel der rechten Hand dient als Gedächtnisstütze: Wenn der Mittelfinger in Richtung der Werkzeugachse vom Werkstück zum Werkzeug zeigt, so weist er in die Richtung Z+, der Daumen in die Richtung X+ und der Zeigefinger in Richtung Y+.

Die iTNC 530 kann insgesamt maximal 18 Achsen steuern. Neben den Hauptachsen X, Y und Z gibt es parallel laufende Zusatzachsen U, V und W. Drehachsen werden mit A, B und C bezeichnet. Das Bild rechts unten zeigt die Zuordnung der Zusatzachsen bzw. Drehachsen zu den Hauptachsen.

Darüber hinaus kann der Maschinenhersteller noch beliebige Hilfsachsen definieren, die mit beliebigen Kleinbuchstaben gekennzeichnet sind


Polarkoordinaten

Wenn die Fertigungszeichnung rechtwinklig bemaßt ist, erstellen Sie das Bearbeitungs-Programm auch mit rechtwinkligen Koordinaten. Bei Werkstücken mit Kreisbögen oder bei Winkelangaben ist es oft einfacher, die Positionen mit Polarkoordinaten festzulegen.

Im Gegensatz zu den rechtwinkligen Koordinaten X, Y und Z beschreiben Polarkoordinaten nur Positionen in einer Ebene. Polarkoordinaten haben ihren Nullpunkt im Pol CC (CC = circle centre; engl. Kreismittelpunkt). Eine Position in einer Ebene ist so eindeutig festgelegt durch:

  • Polarkoordinaten-Radius: der Abstand vom Pol CC zur Position
  • Polarkoordinaten-Winkel: Winkel zwischen der Winkel-Bezugsachse und der Strecke, die den Pol CC mit der Position verbindet
Weitere Informationen:
> Festlegen von Pol und Winkel-Bezugsachse


Festlegen von Pol und Winkel-Bezugsachse

Den Pol legen Sie durch zwei Koordinaten im rechtwinkligen Koordinatensystem in einer der drei Ebenen fest. Damit ist auch die Winkel-Bezugsachse für den Polarkoordinaten-Winkel H eindeutig zugeordnet.

Pol-Koordinaten (Ebene) | Winkel-Bezugsachse
X/Y | +X
Y/Z | +Y
Z/X | +Z


Absolute und inkrementale Werkstück-Positionen

Weitere Informationen:
> Absolute Werkstück-Positionen
> Inkrementale Werkstück-Positionen
> Absolute und inkrementale Polarkoordinaten


Absolute Werkstück-Positionen

Wenn sich die Koordinaten einer Position auf den Koordinaten-Nullpunkt (Ursprung) beziehen, werden diese als absolute Koordinaten bezeichnet. Jede Position auf einem Werkstück ist durch ihre absoluten Koordinaten eindeutig festgelegt.

Beispiel 1: Bohrungen mit absoluten Koordinaten:

Bohrung 1 | Bohrung 2 | Bohrung 3
X = 10 mm | X = 30 mm | X = 50 mm
Y = 10 mm | Y = 20 mm | Y = 30 mm


Inkrementale Werkstück-Positionen

Inkrementale Koordinaten beziehen sich auf die zuletzt programmierte Position des Werkzeugs, die als relativer (gedachter) Nullpunkt dient. Inkrementale Koordinaten geben bei der Programmerstellung somit das Maß zwischen der letzten und der darauf folgenden Soll-Position an, um die das Werkzeug verfahren soll. Deshalb wird es auch als Kettenmaß bezeichnet.

Ein Inkremental-Maß kennzeichnen Sie durch die Funktion G91 vor der Achsbezeichnung.

Beispiel 2: Bohrungen mit inkrementalen Koordinaten

Absolute Koordinaten der Bohrung 4

X = 10 mm
Y = 10 mm

Bohrung 5, bezogen auf 4 | Bohrung 6, bezogen auf 5
G91 X = 20 mm | G91 X = 20 mm
G91 Y = 10 mm | G91 Y = 10 mm


Absolute und inkrementale Polarkoordinaten

Absolute Koordinaten beziehen sich immer auf den Pol und die Winkel-Bezugsachse.

Inkrementale Koordinaten beziehen sich immer auf die zuletzt programmierte Position des Werkzeugs..


Bezugspunkt wählen

Eine Werkstück-Zeichnung gibt ein bestimmtes Formelement des Werkstücks als absoluten Bezugspunkt (Nullpunkt) vor, meist eine Werkstück-Ecke. Beim Bezugspunkt-Setzen richten Sie das Werkstück zuerst zu den Maschinenachsen aus und bringen das Werkzeug für jede Achse in eine bekannte Position zum Werkstück. Für diese Position setzen Sie die Anzeige der TNC entweder auf Null oder einen vorgegebenen Positionswert. Dadurch ordnen Sie das Werkstück dem Bezugssystem zu, das für die TNC-Anzeige bzw. Ihr Bearbeitungs-Programm gilt.

Gibt die Werkstück-Zeichnung relative Bezugspunkte vor, so nutzen Sie einfach die Zyklen zur Koordinaten-Umrechnung (siehe Benutzer-Handbuch Zyklenprogrammierung, Zyklen zur Koordinaten-Umrechnung).

Wenn die Werkstück-Zeichnung nicht NC-gerecht bemaßt ist, dann wählen Sie eine Position oder eine Werkstück-Ecke als Bezugspunkt, von dem aus sich die Maße der übrigen Werkstückpositionen möglichst einfach ermitteln lassen.

Besonders komfortabel setzen Sie Bezugspunkte mit einem Tastsystem von HEIDENHAIN. Siehe Benutzer-Handbuch Tastsystem-Zyklen „Bezugspunkt-Setzen mit Tastsystemen“.

Weitere Informationen:
> Beispiel


Beispiel

Die Werkstück-Skizze zeigt Bohrungen (1 bis 4), deren Bemaßungen sich auf einen absoluten Bezugspunkt mit den Koordinaten X=0 Y=0 beziehen. Die Bohrungen (5 bis 7) beziehen sich auf einen relativen Bezugspunkt mit den absoluten Koordinaten X=450 Y=750. Mit dem Zyklus NULLPUNKT-VERSCHIEBUNG können Sie den Nullpunkt vorübergehend auf die Position X=450, Y=750 verschieben, um die Bohrungen (5 bis 7) ohne weitere Berechnungen zu programmieren.


Programme eröffnen und eingeben

Weitere Informationen:
> Aufbau eines NC-Programms im DIN/ISO-Format
> Rohteil definieren: G30/G31
> Neues Bearbeitungs-Programm eröffnen
> Werkzeug-Bewegungen in DIN/ISO programmieren
> Ist-Positionen übernehmen
> Programm editieren
> Die Suchfunktion der TNC


Aufbau eines NC-Programms im DIN/ISO-Format

Ein Bearbeitungs-Programm besteht aus einer Reihe von Programm-Sätzen. Das Bild rechts zeigt die Elemente eines Satzes.

Die TNC nummeriert die Sätze eines Bearbeitungs-Programms automatisch, in Abhängigkeit von MP7220. MP7220 definiert die Satznummern-Schrittweite.

Der erste Satz eines Programms ist mit %, dem Programm-Namen und der gültigen Maßeinheit gekennzeichnet.

Die darauffolgenden Sätze enthalten Informationen über:

  • das Rohteil
  • Werkzeug-Aufrufe
  • Anfahren einer Sicherheits-Position
  • Vorschübe und Drehzahlen
  • Bahnbewegungen, Zyklen und weitere Funktionen

Der letzte Satz eines Programms ist mit N99999999, dem Programm-Namen und der gültigen Maßeinheit gekennzeichnet.

Achtung Kollisionsgefahr!

HEIDENHAIN empfiehlt, dass Sie nach dem Werkzeug-Aufruf grundsätzlich eine Sicherheits-Position anfahren, von der aus die TNC kollisionsfrei zur Bearbeitung positionieren kann!


Rohteil definieren: G30/G31

Direkt nach dem Eröffnen eines neuen Programms definieren Sie ein quaderförmiges, unbearbeitetes Werkstück. Um das Rohteil nachträglich zu definieren, drücken Sie die Taste spec fct und anschließend die Softkeys PROGRAMM VORGABEN und BLK FORM. Diese Definition benötigt die TNC für die grafischen Simulationen. Die Seiten des Quaders dürfen maximal 100 000 mm lang sein und liegen parallel zu den Achsen X,Y und Z. Dieses Rohteil ist durch zwei seiner Eckpunkte festgelegt:

  • MIN-Punkt G30: kleinste X-,Y- und Z-Koordinate des Quaders; Absolut-Werte eingeben
  • MAX-Punkt G31: größte X-,Y- und Z-Koordinate des Quaders; Absolut- oder Inkremental-Werte eingeben

Die Rohteil-Definition ist nur erforderlich, wenn Sie das Programm grafisch testen wollen!


Neues Bearbeitungs-Programm eröffnen

Ein Bearbeitungs-Programm geben Sie immer in der Betriebsart Programm-Einspeichern/Editieren ein. Beispiel für eine Programm-Eröffnung:

 | Betriebsart Programm-Einspeichern/Editieren wählen
 | Datei-Verwaltung aufrufen: Taste PGM MGT drücken
Wählen Sie das Verzeichnis, in dem Sie das neue Programm speichern wollen:
Datei-Name = ALT.H
 | Neuen Programm-Namen eingeben, mit Taste ENT bestätigen
 | Maßeinheit wählen: Softkey MM oder INCH drücken. Die TNC wechselt ins Programm-Fenster und eröffnet den Dialog zur Definition der BLK-FORM (Rohteil)
Spindelachse parallel X/Y/Z?
 | Spindelachse eingeben, z.B. Z
Def BLK-FORM: Min-Punkt?
 | Nacheinander X-, Y- und Z-Koordinaten des MIN-Punkts eingeben und jeweils mit Taste ENT bestätigen
Def BLK-FORM: MAX-Punkt?
 | Nacheinander X-, Y- und Z-Koordinaten des MAX-Punkts eingeben und jeweils mit Taste ENT bestätigen
Beispiel: Anzeige der BLK-Form im NC-Programm
%neu g71 * | Programm-Anfang, Name, Maßeinheit
n10 g30 g17 x+0 y+0 z-40 * | Spindelachse, MIN-Punkt-Koordinaten
n20 g31 x+100 y+100 z+0 * | MAX-Punkt-Koordinaten
n99999999 %neu G71 * | Programm-Ende, Name, Maßeinheit

Die TNC erzeugt den ersten und letzten Satz des Programms automatisch.

Wenn Sie keine Rohteil-Definition programmieren wollen, brechen Sie den Dialog bei Spindelachse parallel X/Y/Z mit der Taste DEL ab!

Die TNC kann die Grafik nur dann darstellen, wenn die kürzeste Seite mindestens 50 µm und die längste Seite maximal 99 999,999 mm groß ist.


Werkzeug-Bewegungen in DIN/ISO programmieren

Um einen Satz zu programmieren, wählen Sie eine DIN/ISO-Funktionstaste auf der Alpha-Tastatur. Sie können auch die grauen Bahnfunktionstasten benutzen, um den entsprechenden G-Code zu erhalten.

Achten Sie darauf, dass die Großschreibung aktiv ist.
Weitere Informationen:
> Beispiel für einen Positioniersatz


Beispiel für einen Positioniersatz
 | Satz eröffnen
Koordinaten?
 | Zielkoordinate für X-Achse eingeben
 | Zielkoordinate für Y-Achse eingeben, mit Taste ENT zur nächste Frage
Fräsermittelspunktsbahn
 | Ohne Werkzeug-Radiuskorrektur verfahren: Mit Taste ENT bestätigen, oder
 | Links bzw. rechts der programmierten Kontur verfahren: G41 bzw. G42 über Softkey wählen
Vorschub F=?
 | Vorschub für diese Bahnbewegung 100 mm/min, mit Taste ENT zur nächsten Frage
Zusatz-Funktion M?
 | Zusatzfunktion M3 „Spindel ein“, mit Taste ENT beendet die TNC diesen Dialog
Das Programmfenster zeigt die Zeile:
n30 g01 g40 X+10 Y+5 F100 M3 *


Ist-Positionen übernehmen

Die TNC ermöglicht die aktuelle Position des Werkzeugs in das Programm zu übernehmen, z.B. wenn Sie

  • Verfahrsätze programmieren
  • Zyklen programmieren
  • Werkzeuge mit G99 definieren

Um die richtigen Positionswerte zu übernehmen, gehen Sie wie folgt vor:

  • Eingabfeld an die Stelle in einem Satz positionieren, an der Sie eine Position übernehmen wollen

Funktion Ist-Position übernehmen wählen: Die TNC zeigt in der Softkey-Leiste die Achsen an, deren Positionen Sie übernehmen können

Achse wählen: Die TNC schreibt die aktuelle Position der gewählten Achse in das aktive Eingabefeld

Die TNC übernimmt in der Bearbeitungsebene immer die Koordinaten des Werkzeug-Mittelpunktes, auch wenn die Werkzeug-Radiuskorrektur aktiv ist.

Die TNC übernimmt in der Werkzeug-Achse immer die Koordinate der Werkzeug-Spitze, berücksichtigt also immer die aktive Werkzeug-Längenkorrektur.

Die TNC lässt die Softkey-Leiste zur Achsauswahl so lange aktiv, bis Sie diese durch erneutes Drücken der Taste „Ist-Position übernehmen“ wieder ausschalten. Dieses Verhalten gilt auch dann, wenn Sie den aktuellen Satz speichern und per Bahnfunktionstaste einen neuen Satz eröffnen. Wenn Sie ein Satzelement wählen, in dem Sie per Softkey eine Eingabealternative wählen müssen (z.B. die Radiuskorrektur), dann schließt die TNC die Softkey-Leiste zur Achsauswahl ebenfalls.

Die Funktion „Ist-Position übernehmen“ ist nicht erlaubt, wenn die Funktion Bearbeitungsebene schwenken aktiv ist.


Programm editieren

Sie können ein Programm nur dann editieren, wenn es nicht gerade in einer Maschinen-Betriebsart von der TNC abgearbeitet wird. Die TNC erlaubt zwar das Eincursorn in den Satz, unterbindet jedoch das Speichern von Änderungen mit einer Fehlermeldung.

Während Sie ein Bearbeitungs-Programm erstellen oder verändern, können Sie mit den Pfeil-Tasten oder mit den Softkeys jede Zeile im Programm und einzelne Wörter eines Satzes wählen:

Funktion | Softkey/Tasten
Seite nach oben blättern |
Seite nach unten blättern |
Sprung zum Programm-Anfang |
Sprung zum Programm-Ende |
Position des aktuellen Satzes im Bildschirm verändern. Damit können Sie mehr Programmsätze anzeigen lassen, die vor dem aktuellen Satz programmiert sind |
Position des aktuellen Satzes im Bildschirm verändern. Damit können Sie mehr Programmsätze anzeigen lassen, die hinter dem aktuellen Satz programmiert sind |
Von Satz zu Satz springen |
Einzelne Wörter im Satz wählen |
Bestimmten Satz wählen: Taste GOTO drücken, gewünschte Satznummer eingeben, mit Taste ENT bestätigen. Oder: Satznummernschritt eingeben und die Anzahl der eingegeben Zeilen durch Druck auf Softkey N ZEILEN nach oben oder unten überspringen |
Funktion | Softkey/Taste
Wert eines gewählten Wortes auf Null setzen |
Falschen Wert löschen |
Fehlermeldung (nicht blinkend) löschen |
Gewähltes Wort löschen |
Gewählten Satz löschen |
Zyklen und Programmteile löschen |
Satz einfügen, den Sie zuletzt editiert bzw. gelöscht haben |
Weitere Informationen:
> Sätze an beliebiger Stelle einfügen
> Änderungen bewusst speichern
> Programm in einer neuen Datei speichern
> Änderungen rückgängig machen
> Wörter ändern und einfügen
> Gleiche Wörter in verschiedenen Sätzen suchen
> Beliebigen Text finden
> Programmteile markieren, kopieren, löschen und einfügen


Sätze an beliebiger Stelle einfügen

  • Wählen Sie den Satz, hinter dem Sie einen neuen Satz einfügen wollen und eröffnen Sie den Dialog


Änderungen bewusst speichern

Standardmäßig speichert die TNC Änderungen automatisch, wenn Sie einen Betriebsartenwechsel ausführen oder die Datei-Verwaltung bzw. die MOD-Funktion anwählen. Wenn Sie Änderungen am Programm gezielt speichern wollen, gehen Sie wie folgt vor:

  • Softkey-Leiste mit den Funktionen zum Speichern wählen

  • Softkey SPEICHERN betätigen, die TNC speichert alle Änderungen ab, die Sie seit dem letzten Speichern getätigt haben


Programm in einer neuen Datei speichern

Wenn gewünscht, können Sie den Inhalt des momentan gewählten Programmes unter einem anderen Programm-Namen speichern. Gehen Sie dabei wie folgt vor:

  • Softkey-Leiste mit den Funktionen zum Speichern wählen

  • Softkey SPEICHERN UNTER betätigen: Die TNC blendet ein Fenster ein, in dem Sie das Verzeichnis und den neuen Datei-Namen eingeben können

  • Datei-Namen eingeben, mit Softkey OK oder Taste ENT bestätigen, bzw. Vorgang mit Softkey ABBRECHEN beenden


Änderungen rückgängig machen

Wenn gewünscht, können Sie alle Änderungen rückgängig machen, die Sie seit dem letzten Speichern durchgeführt haben. Gehen Sie dabei wie folgt vor:

  • Softkey-Leiste mit den Funktionen zum Speichern wählen

  • Softkey ÄNDERUNGEN AUFHEBEN betätigen: Die TNC blendet ein Fenster ein, in dem Sie den Vorgang bestätigen oder abbrechen können

  • Änderungen mit Softkey Ja oder Taste ENT verwerfen. Vorgang mit Softkey nein abbrechen


Wörter ändern und einfügen

  • Wählen Sie in einem Satz ein Wort und überschreiben Sie es mit dem neuen Wert. Während Sie das Wort gewählt haben, steht der Klartext-Dialog zur Verfügung

  • Änderung abschließen: Taste END drücken

Wenn Sie ein Wort einfügen wollen, betätigen Sie die Pfeil-Tasten (nach rechts oder links), bis der gewünschte Dialog erscheint und geben den gewünschten Wert ein.


Gleiche Wörter in verschiedenen Sätzen suchen

Für diese Funktion Softkey AUTOM. ZEICHNEN auf AUS setzen.

Ein Wort in einem Satz wählen: Pfeil-Tasten so oft drücken, bis gewünschtes Wort markiert ist

Satz mit Pfeiltasten wählen

Die Markierung befindet sich im neu gewählten Satz auf dem gleichen Wort, wie im zuerst gewählten Satz.

Wenn Sie in sehr langen Programmen die Suche gestartet haben, blendet die TNC ein Fenster mit Fortschritts-Anzeige ein. Zusätzlich können Sie dann per Softkey die Suche abbrechen.


Beliebigen Text finden

  • Suchfunktion wählen: Softkey SUCHEN drücken. Die TNC zeigt den Dialog Suche Text:

  • Gesuchten Text eingeben

  • Text suchen: Softkey AUSFÜHREN drücken


Programmteile markieren, kopieren, löschen und einfügen

Um Programmteile innerhalb eines NC-Programms, bzw. in ein anderes NC-Programm zu kopieren, stellt die TNC folgende Funktionen zur Verfügung: Siehe Tabelle unten.

Um Programmteile zu kopieren gehen Sie wie folgt vor:

  • Softkeyleiste mit Markierungsfunktionen wählen

  • Ersten (letzten) Satz des zu kopierenden Programmteils wählen

  • Ersten (letzten) Satz markieren: Softkey BLOCK MARKIEREN drücken. Die TNC hinterlegt die erste Stelle der Satznummer mit einem Hellfeld und blendet den Softkey MARKIEREN ABBrechen ein

  • Bewegen Sie das Hellfeld auf den letzten (ersten) Satz des Programmteils den Sie kopieren oder löschen wollen. Die TNC stellt alle markierten Sätze in einer anderen Farbe dar. Sie können die Markierungsfunktion jederzeit beenden, indem Sie den Softkey MARKIEREN ABBRECHEN drücken

  • Markiertes Programmteil kopieren: Softkey BLOCK KOPIEREN drücken, markiertes Programmteil löschen: Softkey BLOCK LÖSCHEN drücken. Die TNC speichert den markierten Block

  • Wählen Sie mit den Pfeiltasten den Satz, hinter dem Sie das kopierte (gelöschte) Programmteil einfügen wollen

Um das kopierte Programmteil in einem anderen Programm einzufügen, wählen Sie das entsprechende Programm über die Datei-Verwaltung und markieren dort den Satz, hinter dem Sie einfügen wollen.

  • Gespeichertes Programmteil einfügen: Softkey BLOCK EINFÜGEN drücken

  • Markierungsfunktion beenden: Softkey markieren abbrechen drücken

Funktion | Softkey
Markierungsfunktion einschalten |
Markierungsfunktion ausschalten |
Markierten Block löschen |
Im Speicher befindlichen Block einfügen |
Markierten Block kopieren |


Die Suchfunktion der TNC

Mit der Suchfunktion der TNC können Sie beliebige Texte innerhalb eines Programmes suchen und bei Bedarf auch durch einen neuen Text ersetzen.

Weitere Informationen:
> Nach beliebigen Texten suchen
> Suchen/Ersetzen von beliebigen Texten


Nach beliebigen Texten suchen

  • Ggf. Satz wählen, in dem das zu suchende Wort gespeichert ist

Suchfunktion wählen: Die TNC blendet das Suchfenster ein und zeigt in der Softkey-Leiste die zur Verfügung stehenden Suchfunktionen an (siehe Tabelle Suchfunktionen)

Zu suchenden Text eingeben, auf Groß- / Kleinschreibung achten

Suchvorgang einleiten: Die TNC zeigt in der Softkey-Leiste die zur Verfügung stehenden Suchoptionen an (siehe Tabelle Suchoptionen)

Ggf. Suchoptionen ändern

Suchvorgang starten: Die TNC springt auf den nächsten Satz, in dem der gesuchte Text gespeichert ist

Suchvorgang wiederholen: Die TNC springt auf den nächsten Satz, in dem der gesuchte Text gespeichert ist

Suchfunktion beenden

Suchfunktionen | Softkey
Überblendfenster anzeigen, in dem die letzten Suchelemente angezeigt werden. Über Pfeiltaste Suchelement wählbar, mit Taste ENT übernehmen |
Überblendfenster anzeigen, in dem mögliche Suchelemente des aktuellen Satzes gespeichert sind. Über Pfeiltaste Suchelement wählbar, mit Taste ENT übernehmen |
Überblendfenster anzeigen, in dem eine Auswahl der wichtigsten NC-Funktionen angezeigt werden. Über Pfeiltaste Suchelement wählbar, mit Taste ENT übernehmen |
Suchen/Ersetzen-Funktion aktivieren |
Suchoptionen | Softkey
Suchrichtung festlegen |
Suchende festlegen: Einstellung Komplett sucht vom aktuellen Satz bis zum aktuellen Satz |
Neue Suche starten |


Suchen/Ersetzen von beliebigen Texten

Die Funktion Suchen/Ersetzen ist nicht möglich, wenn

  • Ein Programm geschützt ist
  • Wenn das Programm von der TNC gerade abgearbeitet wird

Bei der Funktion ALLES ERSETZEN darauf achten, dass Sie nicht versehentlich Textteile ersetzen, die eigentlich unverändert bleiben sollen. Ersetzte Texte sind unwiederbringlich verloren.

  • Ggf. Satz wählen, in dem das zu suchende Wort gespeichert ist

Suchfunktion wählen: Die TNC blendet das Suchfenster ein und zeigt in der Softkey-Leiste die zur Verfügung stehenden Suchfunktionen an

Ersetzen aktivieren: Die TNC zeigt im Überblendfenster eine zusätzlich Eingabemöglichkeit für den Text an, der eingesetzt werden soll

Zu suchenden Text eingeben, auf Groß- / Kleinschreibung achten, mit Taste ENT bestätigen

Text eingeben der eingesetzt werden soll, auf Groß- / Kleinschreibung achten

Suchvorgang einleiten: Die TNC zeigt in der Softkey-Leiste die zur Verfügung stehenden Suchoptionen an (siehe Tabelle Suchoptionen)

Ggf Suchoptionen ändern

Suchvorgang starten: Die TNC springt auf den nächsten gesuchten Text

Um den Text zu ersetzen und anschließend die nächste Fundstelle anzuspringen: Softkey ersetzen drücken, oder um alle gefundenen Textstellen zu ersetzen: Softkey alles ersetzen drücken, oder um den Text nicht zu ersetzen und die nächste Fundstelle anzuspringen: Softkey nicht ersetzen drücken

Suchfunktion beenden


Datei-Verwaltung: Grundlagen

Weitere Informationen:
> Dateien
> Extern erstellte Dateien auf der TNC anzeigen
> Datensicherung


Dateien

Dateien in der TNC | Typ
Programme im HEIDENHAIN-Format im DIN/ISO-Format | .H .I
smarT.NC-Dateien Strukturierte Unit-Programme Konturbeschreibungen Punkte-Tabellen für -Bearbeitungspositionen | .HU .HC .HP
Tabellen für Werkzeuge Werkzeug-Wechsler Paletten Nullpunkte Punkte Presets Schnittdaten Schneidstoffe, Werkstoffe | .T .TCH .P .D .PNT .PR .CDT .TAB
Texte als ASCII-Dateien Hilfe-Dateien | .A .CHM
Zeichnungsdaten als ASCII-Dateien | .DXF
Sonstige Dateien Spannmittelvorlagen Parametrisierte Spannmittel Abhängige Daten (z.B. Gliederungspunkte) Archive | .CFT .CFX .DEP .ZIP

Wenn Sie ein Bearbeitungs-Programm in die TNC eingeben, geben Sie diesem Programm zuerst einen Namen. Die TNC speichert das Programm auf der Festplatte als eine Datei mit dem gleichen Namen ab. Auch Texte und Tabellen speichert die TNC als Dateien.

Damit Sie die Dateien schnell auffinden und verwalten können, verfügt die TNC über ein spezielles Fenster zur Datei-Verwaltung. Hier können Sie die verschiedenen Dateien aufrufen, kopieren, umbenennen und löschen.

Sie können mit der TNC nahezu beliebig viele Dateien verwalten, mindestens jedoch 21 GByte. Die tatsächliche Größe der Festplatte hängt vom Hauptrechner ab, der in Ihrer Maschine verbaut ist, technische Daten beachten. Ein einzelnes NC-Programm darf maximal 2 GByte groß sein.

Weitere Informationen:
> Namen von Dateien


Namen von Dateien

Bei Programmen, Tabellen und Texten hängt die TNC noch eine Erweiterung an, die vom Datei-Namen durch einen Punkt getrennt ist. Diese Erweiterung kennzeichnet den Datei-Typ.

PROG20 | .H
Datei-Name | Datei-Typ

Die Länge von Dateinamen sollte 25 Zeichen nicht überschreiten, ansonsten zeigt die TNC den Programm-Namen nicht mehr vollständig an.

Dateinamen auf der TNC unterliegen volgender Norm: The Open Group Base Specifications Issue 6 IEEE Std 1003.1, 2004 Edition (Posix-Standard). Demnach dürfen Dateinamen folgende Zeichen enthalten:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z a b c d e f g h i j k l m n o p q r s t u v w x y z 0 1 2 3 4 5 6 7 8 9 . _ -

Alle anderen Zeichen sollten Sie in Dateinamen nicht verwenden, um Probleme bei der Dateiübertragung zu vermeiden.

Die maximal erlaubte Länge von Dateinamen darf so lang sein, dass die maximal erlaubte Pfadlänge von 82 Zeichen nicht überschritten wird (siehe Pfade).


Extern erstellte Dateien auf der TNC anzeigen

Auf der TNC sind einige Zusatztools installiert, mit denen Sie die in der folgenden Tabelle dargestellten Dateien anzeigen und teilweise auch bearbeiten können.

Dateiarten | Typ
PDF-Dateien Excel-Tabellen Internet-Dateien | pdf xls csv html
Text-Dateien | txt ini
Grafik-Dateien | bmp gif jpg png

Weitere Informationen zum Anzeigen und Bearbeiten der aufgeführten Datei-Typen: Siehe Zusatztools zur Verwaltung externer Datei-Typen


Datensicherung

HEIDENHAIN empfiehlt, die auf der TNC neu erstellten Programme und Dateien in regelmäßigen Abständen auf einem PC zu sichern.

Mit der kostenlosen Datenübertragungs-Software TNCremo NT stellt -HEIDENHAIN eine einfache Möglichkeit zur Verfügung, Backups von auf der TNC gespeicherten Daten zu erstellen .

Weiterhin benötigen Sie einen Datenträger, auf dem alle maschinenspezifischen Daten (PLC-Programm, Maschinen-Parameter usw.) gesichert sind. Wenden Sie sich hierzu ggf. an Ihren Maschinenhersteller.

Falls Sie alle auf der Festplatte befindlichen Dateien (> 2 GByte) sichern wollen, nimmt dies mehrere Stunden in Anspruch. Verlagern Sie den Sicherungsvorgang ggf. in die Nachtstunden.

Löschen Sie von Zeit zu Zeit nicht mehr benötigte Dateien, damit die TNC für Systemdateien (z.B. Werkzeug-Tabelle) immer genügend freien Festplattenspeicher zur Verfügung hat.

Bei Festplatten ist, abhängig von den Betriebsbedingungen (z.B. Vibrationsbelastung), nach einer Dauer von 3 bis 5 Jahren mit einer erhöhten Ausfallrate zu rechnen. HEIDENHAIN empfiehlt daher die Festplatte nach 3 bis 5 Jahren prüfen zu lassen.


Arbeiten mit der Datei-Verwaltung

Weitere Informationen:
> Verzeichnisse
> Pfade
> Übersicht: Funktionen der Datei-Verwaltung
> Datei-Verwaltung aufrufen
> Laufwerke, Verzeichnisse und Dateien wählen
> Neues Verzeichnis erstellen (nur auf Laufwerk TNC:\ möglich)
> Neue Datei erstellen (nur auf Laufwerk TNC:\ möglich)
> Einzelne Datei kopieren
> Datei in ein anderes Verzeichnis kopieren
> Tabelle kopieren
> Verzeichnis kopieren
> Eine der zuletzt gewählten Dateien auswählen
> Datei löschen
> Verzeichnis löschen
> Dateien markieren
> Datei umbenennen
> Zusätzliche Funktionen
> Arbeiten mit Shortcuts
> Dateien archivieren
> Dateien aus Archiv extrahieren
> Zusatztools zur Verwaltung externer Datei-Typen
> Datenübertragung zu/von einem externen Datenträger
> Die TNC am Netzwerk
> USB-Geräte an der TNC (FCL 2-Funktion)


Verzeichnisse

Da Sie auf der Festplatte sehr viele Programme bzw. Dateien speichern können, legen Sie die einzelnen Dateien in Verzeichnissen (Ordnern) ab, um den Überblick zu wahren. In diesen Verzeichnissen können Sie weitere Verzeichnisse einrichten, sogenannte Unterverzeichnisse. Mit der Taste -/+ oder ENT können Sie Unterverzeichnisse ein- bzw. ausblenden.

Die TNC verwaltet maximal 6 Verzeichnis-Ebenen!

Wenn Sie mehr als 512 Dateien in einem Verzeichnis speichern, dann sortiert die TNC die Dateien nicht mehr alphabetisch!
Weitere Informationen:
> Namen von Verzeichnissen


Namen von Verzeichnissen

Der Name eines Verzeichnisses darf so lang sein, dass er die maximal erlaubte Pfadlänge von 82 Zeichen nicht überschreitet (siehe Pfade).


Pfade

Ein Pfad gibt das Laufwerk und sämtliche Verzeichnisse bzw. Unterverzeichnisse an, in denen eine Datei gespeichert ist. Die einzelnen Angaben werden mit „\“ getrennt.

Die maximal erlaubte Pfadlänge, also alle Zeichen von Laufwerk, Verzeichnis und Dateiname inklusive Erweiterung, darf 82 Zeichen nicht überschreiten!

Laufwerksbezeichner dürfen maximal 8 Großbuchstaben besitzen.
Weitere Informationen:
> Beispiel


Beispiel

Auf dem Laufwerk TNC:\ wurde das Verzeichnis AUFTR1 angelegt. Danach wurde im Verzeichnis AUFTR1 noch das Unterverzeichnis NCPROG angelegt und dort das Bearbeitungs-Programm PROG1.H hineinkopiert. Das Bearbeitungs-Programm hat damit den Pfad:

TNC:\AUFTR1\NCPROG\PROG1.H

Die Grafik rechts zeigt ein Beispiel für eine Verzeichnisanzeige mit verschiedenen Pfaden.


Übersicht: Funktionen der Datei-Verwaltung

Wenn Sie mit der alten Datei-Verwaltung arbeiten wollen, dann müssen Sie über die MOD-Funktion auf die alte Datei-Verwaltung umstellen (siehe Einstellung PGM MGT ändern)

Funktion | Softkey | Seite
Einzelne Datei kopieren (und konvertieren) |  | Einzelne Datei kopieren
Ziel-Verzeichnis wählen |  | Einzelne Datei kopieren
Bestimmten Datei-Typ anzeigen |  | Laufwerke, Verzeichnisse und Dateien wählen
Neue Datei anlegen |  | Neue Datei erstellen (nur auf Laufwerk TNC:\ möglich)
Die letzten 10 gewählten Dateien anzeigen |  | Eine der zuletzt gewählten Dateien auswählen
Datei oder Verzeichnis löschen |  | Datei löschen
Datei markieren |  | Dateien markieren
Datei umbenennen |  | Datei umbenennen
Datei gegen Löschen und Ändern schützen |  | Datei schützen/Dateischutz aufheben
Datei-Schutz aufheben |  | Datei schützen/Dateischutz aufheben
Dateien archivieren |  | Dateien archivieren
Dateien aus Archiv restaurieren |  | Dateien aus Archiv extrahieren
smarT.NC-Programm öffnen |  | smarT.NC-Programme wählen
Netzlaufwerke verwalten |  | Die TNC am Netzwerk
Verzeichnis kopieren |  | Verzeichnis kopieren
Verzeichnissbaum aktualisieren, z.B. um erkennen zu können, wenn auf einem Netzlaufwerk bei geöffneter Datei-Verwaltung ein neues Verzeichnis angelegt wurde |  |


Datei-Verwaltung aufrufen

Taste PGM MGT drücken: Die TNC zeigt das Fenster zur Datei-Verwaltung (das Bild zeigt die Grundeinstellung. Wenn die TNC eine andere Bildschirm-Aufteilung anzeigt, drücken Sie den Softkey FENSTER)

Das linke, schmale Fenster zeigt die vorhandenen Laufwerke und Verzeichnisse an. Laufwerke bezeichnen Geräte, mit denen Daten gespeichert oder übertragen werden. Ein Laufwerk ist die Festplatte der TNC, weitere Laufwerke sind die Schnittstellen (RS232, RS422, Ethernet), an die Sie beispielsweise einen Personal-Computer anschließen können. Ein Verzeichnis ist immer durch ein Ordner-Symbol (links) und den Verzeichnis-Namen (rechts) gekennzeichnet. Unterverzeichnisse sind nach rechts eingerückt. Befindet sich ein Dreieck vor dem Ordner-Symbol, dann sind noch weitere Unterverzeichnisse vorhanden, die Sie mit der Taste -/+ oder ENT einblenden können.

    Die TNC zeigt Laufwerke grundsätzlich immer in folgender Reihenfolge an:

    • Zunächst serielle Schnittstellen (RS232 und RS422)
    • Dann das TNC-Laufwerk
    • Dann alle weiteren Laufwerke

Innerhalb der drei Gruppen zeigt die TNC die Laufwerke jeweils in alphabetisch aufsteigender Reihenfolge an.

Das rechte, breite Fenster zeigt alle Dateien an, die in dem gewählten Verzeichnis gespeichert sind. Zu jeder Datei werden mehrere Informationen gezeigt, die in der Tabelle unten aufgeschlüsselt sind.

Anzeige | Bedeutung
Datei-Name | Name mit maximal 25 Zeichen
Typ | Datei-Typ
Größe | Dateigröße in Byte
Geändert | Datum und Uhrzeit, an der die Datei das letzte Mal geändert wurde. Datumsformat einstellbar
Status | Eigenschaft der Datei: E: Programm ist in der Betriebsart Programm-Einspeichern/Editieren angewählt S: Programm ist in der Betriebsart Programm-Test angewählt M: Programm ist in einer Programmlauf-Betriebsart angewählt P: Datei ist gegen Löschen und Ändern geschützt (Protected) +: Es sind abhängige Dateien vorhanden (Gliederungs-Datei, Werkzeug-Einsatzdatei)

Zusätzlich zeigt die TNC im Fenster links unten bei den meisten Datei-Typen ein Vorschaubild der Datei an, auf der das Hellfeld momentan steht. Der Aufbau des Vorschaubildes kann bei sehr großen Dateien einige Zeit in Anspruch nehmen. Die Funktion Dateivorschau können Sie auch deaktivieren (siehe Datei-Verwaltung anpassen)


Laufwerke, Verzeichnisse und Dateien wählen

 | Datei-Verwaltung aufrufen
Benutzen Sie die Pfeil-Tasten oder die Softkeys, um das Hellfeld an die gewünschte Stelle auf dem Bildschirm zu bewegen:
 | Bewegt das Hellfeld vom rechten ins linke Fenster und umgekehrt
 | Bewegt das Hellfeld in einem Fenster auf und ab
 | Bewegt das Hellfeld in einem Fenster seitenweise auf und ab

Schritt 1: Laufwerk wählen

Laufwerk im linken Fenster markieren:
 | Laufwerk wählen: Softkey WÄHLEN drücken, oder
 | Taste ENT drücken

Schritt 2: Verzeichnis wählen

Verzeichnis im linken Fenster markieren: Das rechte Fenster zeigt automatisch alle Dateien aus dem Verzeichnis an, das markiert (hell hinterlegt) ist

Schritt 3: Datei wählen

 | Softkey TYP WÄHLEN drücken
 | Softkey des gewünschten Datei-Typs drücken, oder
 | alle Dateien anzeigen: Softkey ALLE ANZ. drücken, oder
 | Wildcards benutzen, z.B. alle Dateien vom Dateityp .H anzeigen, die mit 4 beginnen
Datei im rechten Fenster markieren:
 | Softkey WÄHLEN drücken, oder
 | Taste ENT drücken
Die TNC aktiviert die gewählte Datei in der Betriebsart, aus der Sie die Datei-Verwaltung aufgerufen haben
Weitere Informationen:
> smarT.NC-Programme wählen


smarT.NC-Programme wählen

In der Betriebsart smarT.NC erstellte Programme können Sie in der Betriebsart Programm Einspeichern/Editiern wahlweise mit dem smarT.NC-Editor oder mit dem Klartext-Editor öffnen. Standardmäßig öffnet die TNC .HU- und .HC-Programme immer mit dem smarT.NC-Editor. Wenn Sie die Programme mit dem Klartext-Editor öffnen wollen, gehen Sie wie folgt vor:

 | Datei-Verwaltung aufrufen
Benutzen Sie die Pfeil-Tasten oder die Softkeys, um das Hellfeld auf eine .HU oder eine .HC-Datei zu bewegen:
 | Bewegt das Hellfeld vom rechten ins linke Fenster und umgekehrt
 | Bewegt das Hellfeld in einem Fenster auf und ab
 | Bewegt das Hellfeld in einem Fenster seitenweise auf und ab
 | Softkey-Leiste umschalten
 | Untermenü zur Auswahl des Editors wählen
 | .HU- oder .HC-Programm mit Klartext-Editor öffnen
 | .HU-Programm mit smarT.NC-Editor öffnen
 | .HC-Programm mit smarT.NC-Editor öffnen


Neues Verzeichnis erstellen (nur auf Laufwerk TNC:\ möglich)

Verzeichnis im linken Fenster markieren, in dem Sie ein Unterverzeichnis erstellen wollen
 | Den neuen Verzeichnisnamen eingeben, Taste ENT drücken
Verzeichnis \NEU erzeugen?
 | Mit Softkey JA bestätigen, oder
 | mit Softkey Nein abbrechen


Neue Datei erstellen (nur auf Laufwerk TNC:\ möglich)

Verzeichnis wählen, in dem Sie die neue Datei erstellen wollen
 | Den neuen Dateinamen mit Datei-Endung eingeben, Taste ENT drücken
 | Dialog zum Erstellen einer neuen Datei öffnen
 | Den neuen Dateinamen mit Datei-Endung eingeben, Taste ENT drücken


Einzelne Datei kopieren

  • Bewegen Sie das Hellfeld auf die Datei, die kopiert werden soll

Softkey KOPIEREN drücken: Kopierfunktion wählen. Die TNC blendet eine Softkeyleiste mit mehreren Funktionen ein. Alternativ können Sie auch den Shortcut CTRL+C verwenden, um den Kopiervorgang zu starten

Namen der Ziel-Datei eingeben und mit Taste ENT oder Softkey OK übernehmen: Die TNC kopiert die Datei ins aktuelle Verzeichnis, bzw. ins gewählte Ziel-Verzeichnis. Die ursprüngliche Datei bleibt erhalten.

Drücken Sie den Softkey Ziel-Verzeichnis, um in einem Überblendfenster das Ziel-Verzeichnis zu wählen und mit Taste ENT oder Softkey OK übernehmen: Die TNC kopiert die Datei mit dem gleichen Namen ins gewählte Verzeichnis. Die ursprüngliche Datei bleibt erhalten

Die TNC zeigt ein Überblendfenster mit der Fortschrittanzeige, wenn Sie den Kopiervorgang mit der Taste ENT oder dem Softkey OK gestartet haben.


Datei in ein anderes Verzeichnis kopieren

  • Bildschirm-Aufteilung mit gleich großen Fenstern wählen

  • In beiden Fenstern Verzeichnisse anzeigen: Softkey PFAD drücken

Rechtes Fenster

  • Hellfeld auf das Verzeichnis bewegen, in das Sie die Dateien kopieren möchten und mit Taste ENT Dateien in diesem Verzeichnis anzeigen

Linkes Fenster

  • Verzeichnis mit den Dateien wählen, die Sie kopieren möchten und mit Taste ENT Dateien anzeigen

Funktionen zum Markieren der Dateien anzeigen

Hellfeld auf Datei bewegen, die Sie kopieren möchten und markieren. Falls gewünscht, markieren Sie weitere Dateien auf die gleiche Weise

Die markierten Dateien in das Zielverzeichnis kopieren

Weitere Markierungs-Funktionen: siehe Dateien markieren.

Wenn Sie sowohl im linken als auch im rechten Fenster Dateien markiert haben, dann kopiert die TNC von dem Verzeichnis aus in dem das Hellfeld steht.

Weitere Informationen:
> Dateien überschreiben


Dateien überschreiben

Wenn Sie Dateien in ein Verzeichnis kopieren, in dem sich Dateien mit gleichem Namen befinden, dann fragt die TNC, ob die Dateien im Zielverzeichnis überschrieben werden dürfen:

  • Alle Dateien überschreiben: Softkey JA drücken oder

  • Keine Datei überschreiben: Softkey NEIN drücken oder

  • Überschreiben jeder einzelnen Datei bestätigen: Softkey BESTÄTIG. drücken

Wenn Sie eine geschütze Datei überschreiben wollen, müssen Sie dies separat bestätigen bzw. abbrechen.


Tabelle kopieren

    Wenn Sie Tabellen kopieren, können Sie mit dem Softkey FELDER ERSETZEN einzelne Zeilen o der Spalten in der Ziel-Tabelle überschreiben. Voraussetzungen:

  • die Ziel-Tabelle muss bereits existieren
  • die zu kopierende Datei darf nur die zu ersetzenden Spalten oder Zeilen enthalten

Der Softkey FELDER ERSETZEN erscheint nicht, wenn Sie von extern mit einer Datenübertragungssoftware z. B. TNCremoNT die Tabelle in der TNC überschreiben wollen. Kopieren Sie die extern erstellte Datei in ein anderes Verzeichnis und führen Sie anschließend den Kopiervorgang mit der Dateiverwaltung der TNC aus.

Der Datei-Typ der extern erstellten Tabelle sollte .A (ASCII) sein. In diesen Fällen kann die Tabelle dann beliebige Zeilennummern enthalten. Wenn Sie den Datei-Typ .T erstellen, dann muss die Tabelle fortlaufende, mit 0 beginnende Zeilennummern enthalten.

Beispiel

    Sie haben auf einem Voreinstellgerät die Werkzeug-Länge und den Werkzeug-Radius von 10 neuen Werkzeugen vermessen. Anschließend erzeugt das Voreinstellgerät die Werkzeug-Tabelle TOOL.A mit 10 Zeilen (sprich 10 Werkzeugen) und den Spalten

  • Werkzeug-Nummer (Spalte T)
  • Werkzeug-Länge (Spalte L)
  • Werkzeug-Radius (Spalte R)

  • Kopieren Sie diese Tabelle von dem externen Datenträger in ein beliebiges Verzeichnis

  • Kopieren Sie die extern erstellte Tabelle mit der Dateiverwaltung der TNC über die bestehende Tabelle TOOL.T: Die TNC fragt, ob die bestehende Werkzeug-Tabelle TOOL.T überschrieben werden soll:

  • Drücken Sie den Softkey JA, dann überschreibt die TNC die aktuelle Datei TOOL.T vollständig. Nach dem Kopiervorgang besteht TOOL.T also aus 10 Zeilen. Alle Spalten – natürlich außer den Spalten Nummer, Länge und Radius– werden zurückgesetzt

  • Oder drücken Sie den Softkey FELDER ERSETZEN, dann überschreibt die TNC in der Datei TOOL.T nur die Spalten Nummer, Länge und Radius der ersten 10 Zeilen. Die Daten der restlichen Zeilen und Spalten werden von der TNC nicht verändert


Verzeichnis kopieren

Um Verzeichnisse kopieren zu können, müssen Sie die Ansicht so eingestellt haben, dass die TNC Verzeichnisse im rechten Fenster anzeigt (siehe Datei-Verwaltung anpassen).

Beachten Sie, dass die TNC beim Kopieren von Verzeichnissen nur die Dateien kopiert, die durch die aktuelle Filtereinstellung auch angezeigt werden.

  • Bewegen Sie das Hellfeld im rechten Fenster auf das Verzeichnis das Sie kopieren wollen

  • Drücken Sie den Softkey kopieren: Die TNC blendet das Fenster zur Auswahl des Zielverzeichnisses ein

  • Zielverzeichnis wählen und mit Taste ENT oder Softkey OK bestätigen: Die TNC kopiert das gewählte Verzeichnis inclusive Unterverzeichnisse in das gewählte Zielverzeichnis


Eine der zuletzt gewählten Dateien auswählen

 | Datei-Verwaltung aufrufen
 | Die letzten 15 angewählten Dateien anzeigen: Softkey LETZTE DATEIEN drücken
Benutzen Sie die Pfeil-Tasten, um das Hellfeld auf die Datei zu bewegen, die Sie anwählen wollen:
 | Bewegt das Hellfeld in einem Fenster auf und ab
 | Datei wählen: Softkey WÄHLEN drücken, oder
 | Taste ENT drücken


Datei löschen

Achtung, Datenverlust möglich!

Das Löschen von Dateien können Sie nicht mehr rückgängig machen!

  • Bewegen Sie das Hellfeld auf die Datei, die löschen möchten

Löschfunktion wählen: Softkey LÖSCHEN drücken. Die TNC fragt, ob die Datei tatsächlich gelöscht werden soll

Löschen bestätigen: Softkey JA drücken oderLöschen abbrechen: Softkey NEIN drücken


Verzeichnis löschen

Achtung, Datenverlust möglich!

Das Löschen von Verzeichnissen und Dateien können Sie nicht mehr rückgängig machen!

  • Bewegen Sie das Hellfeld auf das Verzeichnis, das Sie löschen möchten

Löschfunktion wählen: Softkey LÖSCHEN drücken. Die TNC fragt, ob das Verzeichnis mit allen Unterverzeichnissen und Dateien tatsächlich gelöscht werden soll

Löschen bestätigen: Softkey JA drücken oderLöschen abbrechen: Softkey NEIN drücken


Dateien markieren

Markierungs-Funktion | Softkey
Cursor nach oben bewegen |
Cursor nach unten bewegen |
Einzelne Datei markieren |
Alle Dateien im Verzeichnis markieren |
Markierung für einzelne Datei aufheben |
Markierung für alle Dateien aufheben |
Alle markierten Dateien kopieren |

Funktionen, wie das Kopieren oder Löschen von Dateien, können Sie sowohl auf einzelne als auch auf mehrere Dateien gleichzeitig anwenden. Mehrere Dateien markieren Sie wie folgt:

Hellfeld auf erste Datei bewegen
 | Markierungs-Funktionen anzeigen: Softkey MARKIEREN drücken
 | Datei markieren: Softkey DATEI MARKIEREN -drücken
 | Hellfeld auf weitere Datei bewegen. Funktioniert nur über Softkeys, nicht mit den Pfeiltasten navigieren!
 | Weitere Datei markieren: Softkey DATEI MARKIEREN drücken usw.
 | Markierte Dateien kopieren: Softkey KOP. MARK. drücken, oder
 | Markierte Dateien löschen: Softkey ENDE drücken, um Markierungs-Funktionen zu verlassen und anschließend Softkey LÖSCHEN drücken, um markierte Dateien zu löschen
Weitere Informationen:
> Dateien markieren mit Shortcuts


Dateien markieren mit Shortcuts

  • Hellfeld auf erste Datei bewegen

  • Taste CTRL drücken und gedrückt halten

  • Mit Pfeiltasten den Cursor-Rahmen auf weitere Dateien bewegen

  • BLANK-Taste markiert die Datei

  • Wenn Sie alle gewünschten Dateien markiert haben: CTRL-Taste loslassen und gewünschte Dateioperation ausführen

CTRL+A markiert alle im aktuellen Verzeichnis befindlichen Dateien.

Wenn Sie anstelle der Taste CTRL die Taste SHIFT drücken, markiert die TNC automatisch alle Dateien, die sie mit den Pfeiltasten anwählen.


Datei umbenennen

  • Bewegen Sie das Hellfeld auf die Datei, die umbenennen möchten

Funktion zum Umbenennen wählen

Neuen Datei-Namen eingeben; der Datei-Typ kann nicht geändert werden

Umbenennen ausführen: Taste ENT drücken


Zusätzliche Funktionen

Weitere Informationen:
> Datei schützen/Dateischutz aufheben
> USB-Gerät anbinden/entfernen
> Datei-Verwaltung anpassen


Datei schützen/Dateischutz aufheben

  • Bewegen Sie das Hellfeld auf die Datei, die Sie schützen möchten

Zusätzliche Funktionen wählen: Softkey ZUSÄTZL. FUNKT. drücken

Dateischutz aktivieren: Softkey SCHÜTZEN drücken, die Datei erhält Status P

Dateischutz aufheben: Softkey UNGESCH. drücken


USB-Gerät anbinden/entfernen

  • Bewegen Sie das Hellfeld ins linke Fenster

Zusätzliche Funktionen wählen: Softkey ZUSÄTZL. FUNKT. drücken

Nach USB-Gerät suchen

Um das USB-Gerät zu entfernen: Bewegen Sie das Hellfeld auf das USB-Gerät

USB-Gerät entfernen

Weitere Informationen: Siehe USB-Geräte an der TNC (FCL 2-Funktion).


Datei-Verwaltung anpassen

Das Menü zur Anpassung der Datei-Verwaltung können Sie entweder durch Mouse-Klick auf den Pfadnamen, oder per Softkeys öffnen:

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Dritte Softkey-Leiste wählen

  • Softkey zusätzl. funkt. drücken

  • Softkey optionen drücken: Die TNC blendet das Menü zur Anpassung der Datei-Verwaltung ein

  • Mit den Pfeiltasten Hellfeld auf die gewünschte Einstellung schieben

  • Mit der Blank-Taste die gewünschte Einstellung aktivieren/deaktivieren

    Folgende Anpassungen können Sie an der Datei-Verwaltung vornehmen:

  • Bookmarks
    Über Bookmarks verwalten Sie Ihre Verzeichnis-Favoriten. Sie können das aktive Verzeichnis hinzufügen oder löschen oder alle Bookmarks löschen. Alle von Ihnen hinzugefügten Verzeichnisse erscheinen in der Bookmark-Liste und lassen sich somit schnell anwählen
  • Ansicht
    Im Menüpunkt Ansicht legen Sie fest, welche Informationen die TNC im Dateifenster anzeigen soll
  • Datums-Format
    Im Menüpunkt Datums-Format legen Sie fest, in welchem Format die TNC das Datum in der Spalte Geändert anzeigen soll
  • Einstellungen
    • Cursor: Fenster wechseln
      Wenn Cursor im Verzeichnisbaum steht: Festlegen, ob die TNC beim Drücken der Pfeil nach rechts-Taste das Fenster wechseln soll, oder ob die TNC ggf. vorhandene Unterverzeichnisse aufklappen soll
    • Ordner: durchsuchen
      Festlegen, ob die TNC beim Navigieren in der Verszeichnisstruktur im momentan aktiven Ordner nach Unterordnern suchen soll oder nicht (inaktiv: Geschwindigkeitssteigerung)
    • Vorschau: anzeigen
      Festlegen, ob die TNC das Vorschaufenster anzeigen soll oder nicht (siehe Datei-Verwaltung aufrufen)


Arbeiten mit Shortcuts

Shortcuts sind Kurzbefehle, die Sie durch bestimmte Tastenkombinationen auslösen. Kurzbefehle führen immer eine Funktion aus, die Sie durch einen Softkey ebenfalls ausführen können. Folgende Shortcuts stehen zur Verfügung:

  • CTRL+S:
    Datei wählen (siehe auch Laufwerke, Verzeichnisse und Dateien wählen)
  • CTRL+N:
    Dialog starten, um eine neue Datei/ein neues Verzeichnis zu erstellen (siehe auch Neue Datei erstellen (nur auf Laufwerk TNC:\ möglich))
  • CTRL+C:
    Dialog starten, um gewählte Dateien/Verzeichnisse zu kopieren (siehe auch Einzelne Datei kopieren)
  • CTRL+R:
    Dialog starten, um gewählte Datei/Verzeichnis umzubenennen (siehe auch Datei umbenennen)
  • Taste DEL:
    Dialog starten, um gewählte Dateien/Verzeichnisse zu löschen (siehe auch Datei löschen)
  • CTRL+O:
    Öffnen-Mit-Dialog starten (siehe auch smarT.NC-Programme wählen)
  • CTRL+W:
    Bildschirm-Aufteilung umschalten (siehe auch Datenübertragung zu/von einem externen Datenträger)
  • CTRL+E:
    Funktionen zum Anpassen der Datei-Verwaltung einblenden (siehe auch Datei-Verwaltung anpassen)
  • CTRL+M:
    USB-Gerät verbinden (siehe auch USB-Geräte an der TNC (FCL 2-Funktion))
  • CTRL+K:
    USB-Gerät lösen (siehe auch USB-Geräte an der TNC (FCL 2-Funktion))
  • Shift+Pfeiltaste auf bzw. ab:
    Mehrere Dateien bzw. Verzeichnisse markieren (siehe auch Dateien markieren)
  • Taste ESC:
    Funktion abbrechen


Dateien archivieren

Mit der Archivierungsfunktion der TNC können sie Dateien und Verzeichnisse in einem ZIP-Archiv speichern. Die ZIP-Archive können extern mit handelsüblichen Programmen geöffnet werden.

Die TNC packt alle markierten Dateien und Verzeichnisse in das gewünschte ZIP-Archiv. TNC-spezifische Dateien (z.B. Klartext-Dialog-Programme) packt die TNC dabei im ASCII-Format, so dass Sie diese ggf. mit einem ASCII-Editor extern öffnen können

Gehen Sie beim Archivieren wie folgt vor

  • Markieren Sie in der rechten Bildschirmhälfte die Dateien und Verzeichnisse, die Sie archivieren möchten

Zusätzliche Funktionen wählen: Softkey ZUSÄTZL. FUNKT. drücken

Archiv erzeugen: Softkey zip drücken, die TNC blendet ein Fenster zur Eingabe des Archivnamens ein

Gewünschten Archivnamen eingeben

Mit Softkey OK bestätigen: Die TNC blendet ein Fenster zur Auswahl des Verzeichnisses ein, in dem Sie das Archiv speichern wollen

Gewünschtes Verzeichnis wählen, mit Softkey OK bestätigen

Wenn Ihre Steuerung in Ihr Firmennetz eingebunden und mit Schreibrechten versehen ist, dann können Sie das Archiv auch direkt auf einem Netzlaufwerk speichern.

Über den Shortcut CTRL+Q können Sie bereits markierte Dateien direkt archivieren.


Dateien aus Archiv extrahieren

Gehen Sie beim Extrahieren wie folgt vor

  • Markieren Sie in der rechten Bildschirmhälfte die ZIP-Datei, die Sie extrahieren möchten

Zusätzliche Funktionen wählen: Softkey ZUSÄTZL. FUNKT. drücken

Gewähltes Archiv extrahieren: Softkey Unzip drücken, die TNC blendet ein Fenster zur Auswahl des Zielverzeichnisses ein

Gewünschtes Zielverzeichnis wählen

Mit Softkey OK bestätigen: Die TNC extrahiert das Archiv

Die TNC extrahiert die Dateien immer bezogen auf das von Ihnen gewählte Zielverzeichnis. Enthält das Archiv Verzeichnisse, dann legt die TNC diese als Unterverzeichnisse an.

Über den Shortcut CTRL+T können Sie eine markierte ZIP-Datei direkt extrahieren.


Zusatztools zur Verwaltung externer Datei-Typen

Mit Zusatztools können Sie verschiedene, extern erstellte Datei-Typen auf der TNC anzeigen oder bearbeiten.

Dateiarten | Beschreibung
PDF-Dateien (pdf) Excel-Tabellen (xls, csv) Internet-Dateien (htm, html) ZIP-Archive (zip) | PDF-Dateien anzeigen Excel-Dateien anzeigen und bearbeiten Internet-Dateien anzeigen Arbeiten mit ZIP-Archiven
Text-Dateien (ASCII-Dateien, z.B. txt, ini) | Text-Dateien anzeigen oder bearbeiten
Grafik-Dateien (bmp, gif, jpg, png) | Grafik-Dateien anzeigen

Wenn Sie die Dateien vom PC aus mit TNCremoNT auf die Steuerung übertragen, dann müssen Sie die Dateinamenserweiterungen pdf, xls, zip, bmp gif, jpg und png in die Liste der binär zu übertragenden Dateitypen eingetragen haben (Menüpunkt >Extras >Konfiuration >Modus in TNCremoNT).

Weitere Informationen:
> PDF-Dateien anzeigen
> Excel-Dateien anzeigen und bearbeiten
> Internet-Dateien anzeigen
> Arbeiten mit ZIP-Archiven
> Text-Dateien anzeigen oder bearbeiten
> Grafik-Dateien anzeigen


PDF-Dateien anzeigen

Um PDF-Dateien direkt auf der TNC zu öffnen, gehen Sie wie folgt vor:

Datei-Verwaltung aufrufen

Verzeichnis wählen, in dem die PDF-Datei gespeichert ist

Bewegen Sie das Hellfeld auf die PDF-Datei

Taste ENT drücken: Die TNC öffnet die PDF-Datei mit dem Zusatz-Tool PDF Betrachter in einer eigenen Anwendung

Mit der Tasten-Kombination ALT+TAB können Sie jederzeit auf die TNC-Oberfläche zurückschalten und die PDF-Datei geöffnet lassen. Alternativ können Sie auch per Mouse-Klick auf das entsprechende Symbol in der Task-Leiste zurück auf die TNC-Oberfläche wechseln.

Wenn Sie den Mouse-Zeiger über einer Schaltfläche positionieren, erhalten Sie einen kurzen Tipp-Text zur jeweiligen Funktion der Schaltfläche. Weitere Informationen zur Bedienung des PDF Betrachters finden Sie unter Hilfe.

Um den PDF Betrachter zu beenden gehen Sie wie folgt vor:

  • Mit der Mouse Menüpunkt Datei wählen

  • Menüpunkt Schließen wählen: Die TNC kehrt zurück in die Datei-Verwaltung


Excel-Dateien anzeigen und bearbeiten

Um Excel-Dateien mit der Dateiendung xls oder csv direkt auf der TNC zu öffnen und zu bearbeiten, gehen Sie wie folgt vor:

Datei-Verwaltung aufrufen

Verzeichnis wählen, in dem die Excel-Datei gespeichert ist

Bewegen Sie das Hellfeld auf die Excel-Datei

Taste ENT drücken: Die TNC öffnet die Excel-Datei mit dem Zusatz-Tool Gnumeric in einer eigenen Anwendung

Mit der Tasten-Kombination ALT+TAB können Sie jederzeit auf die TNC-Oberfläche zurückschalten und die Excel-Datei geöffnet lassen. Alternativ können Sie auch per Mouse-Klick auf das entsprechende Symbol in der Task-Leiste zurück auf die TNC-Oberfläche wechseln.

Wenn Sie den Mouse-Zeiger über einer Schaltfläche positionieren, erhalten Sie einen kurzen Tipp-Text zur jeweiligen Funktion der Schaltfläche. Weitere Informationen zur Bedienung von Gnumeric finden Sie unter Help.

Um Gnumeric zu beenden gehen Sie wie folgt vor:

  • Mit der Mouse Menüpunkt File wählen

  • Menüpunkt Quit wählen: Die TNC kehrt zurück in die Datei-Verwaltung


Internet-Dateien anzeigen

Um Internet-Dateien mit der Dateiendung htm oder html direkt auf der TNC zu öffnen, gehen Sie wie folgt vor:

Datei-Verwaltung aufrufen

Verzeichnis wählen, in dem die Internet-Datei gespeichert ist

Bewegen Sie das Hellfeld auf die Internet-Datei

Taste ENT drücken: Die TNC öffnet die Internet-Datei mit dem Zusatz-Tool Mozilla Firefox in einer eigenen Anwendung

Mit der Tasten-Kombination ALT+TAB können Sie jederzeit auf die TNC-Oberfläche zurückschalten und die PDF-Datei geöffnet lassen. Alternativ können Sie auch per Mouse-Klick auf das entsprechende Symbol in der Task-Leiste zurück auf die TNC-Oberfläche wechseln.

Wenn Sie den Mouse-Zeiger über einer Schaltfläche positionieren, erhalten Sie einen kurzen Tipp-Text zur jeweiligen Funktion der Schaltfläche. Weitere Informationen zur Bedienung des Mozilla Firefox finden Sie unter Help.

Um den Mozilla Firefox zu beenden gehen Sie wie folgt vor:

  • Mit der Mouse Menüpunkt File wählen

  • Menüpunkt Quit wählen: Die TNC kehrt zurück in die Datei-Verwaltung


Arbeiten mit ZIP-Archiven

Um ZIP-Archive mit der Dateiendung zip direkt auf der TNC zu öffnen, gehen Sie wie folgt vor:

Datei-Verwaltung aufrufen

Verzeichnis wählen, in dem die Archiv-Datei gespeichert ist

Bewegen Sie das Hellfeld auf die Archiv-Datei

Taste ENT drücken: Die TNC öffnet die Archiv-Datei mit dem Zusatz-Tool Xarchiver in einer eigenen Anwendung

Mit der Tasten-Kombination ALT+TAB können Sie jederzeit auf die TNC-Oberfläche zurückschalten und die Archiv-Datei geöffnet lassen. Alternativ können Sie auch per Mouse-Klick auf das entsprechende Symbol in der Task-Leiste zurück auf die TNC-Oberfläche wechseln.

Wenn Sie den Mouse-Zeiger über einer Schaltfläche positionieren, erhalten Sie einen kurzen Tipp-Text zur jeweiligen Funktion der Schaltfläche. Weitere Informationen zur Bedienung von Xarchiver finden Sie unter Hilfe.

Beachten Sie, dass die TNC beim Packen und Entpacken von NC-Programmen und NC-Tabellen keine Konvertierung von binär nach ASCII bzw. umgekehrt durchführt. Beim Übertragen auf TNC-Steuerungen mit anderen Software-Versionen, können solche Dateien dann ggf. nicht von der TNC gelesen werden.

Um Xarchiver zu beenden gehen Sie wie folgt vor:

  • Mit der Mouse Menüpunkt Archiv wählen

  • Menüpunkt Beenden wählen: Die TNC kehrt zurück in die Datei-Verwaltung


Text-Dateien anzeigen oder bearbeiten

Um Text-Dateien (ASCII-Dateien, z.B. mit Dateiendung txt oder ini) zu öffnen und zu bearbeiten, gehen Sie wie folgt vor:

Datei-Verwaltung aufrufen

Laufwerk und Verzeichnis wählen, in dem die Text-Datei gespeichert ist

Bewegen Sie das Hellfeld auf die Text-Datei

Taste ENT drücken: Die TNC zeigt ein Fenster zur Auswahl des gewünschten Editors

Taste ENT drücken um die Mousepad-Anwendung zu wählen. Alternativ können Sie TXT-Dateien auch mit dem internen Text-Editor der TNC öffnen

Die TNC öffnet die Text-Datei mit dem Zusatz-Tool Mousepad in einer eigenen Anwendung

Wenn Sie eine H oder I-Datei auf einem externen Laufwerk öffnen und mit Mousepad auf dem TNC-Laufwerk speichern, erfolgt keine automatische Wandlung der Programme in das interne Steuerungsformat. So gespeicherte Programme können Sie nicht mit dem TNC-Editor öffnen oder abarbeiten.

Mit der Tasten-Kombination ALT+TAB können Sie jederzeit auf die TNC-Oberfläche zurückschalten und die Text-Datei geöffnet lassen. Alternativ können Sie auch per Mouse-Klick auf das entsprechende Symbol in der Task-Leiste zurück auf die TNC-Oberfläche wechseln.

Innerhalb von Mousepad stehen die von Windows her bekannten Shortcuts zur Verfügung, mit denen Sie Texte schnell bearbeiten können (STRG+C, STRG+V,...).

Um Mousepad zu beenden gehen Sie wie folgt vor:

  • Mit der Mouse Menüpunkt Datei wählen

  • Menüpunkt Beenden wählen: Die TNC kehrt zurück in die Datei-Verwaltung


Grafik-Dateien anzeigen

Um Grafik-Dateien mit der Dateiendung bmp, gif, jpg oder png direkt auf der TNC zu öffnen, gehen Sie wie folgt vor:

Datei-Verwaltung aufrufen

Verzeichnis wählen, in dem die Grafik-Datei gespeichert ist

Bewegen Sie das Hellfeld auf die Grafik-Datei

Taste ENT drücken: Die TNC öffnet die Grafik-Datei mit dem Zusatz-Tool ristretto in einer eigenen Anwendung

Mit der Tasten-Kombination ALT+TAB können Sie jederzeit auf die TNC-Oberfläche zurückschalten und die Grafik-Datei geöffnet lassen. Alternativ können Sie auch per Mouse-Klick auf das entsprechende Symbol in der Task-Leiste zurück auf die TNC-Oberfläche wechseln.

Weitere Informationen zur Bedienung von ristretto finden Sie unter Hilfe.

Um ristretto zu beenden gehen Sie wie folgt vor:

  • Mit der Mouse Menüpunkt Datei wählen

  • Menüpunkt Beenden wählen: Die TNC kehrt zurück in die Datei-Verwaltung


Datenübertragung zu/von einem externen Datenträger

Bevor Sie Daten zu einem externen Datenträger übertragen können, müssen Sie die Datenschnittstelle einrichten (siehe Datenschnittstellen einrichten).

Wenn Sie über die serielle Schnittstelle Daten übertragen, dann können in Abhängigkeit von der verwendeten Datenübertragungs-Software Probleme auftreten, die Sie durch wiederholtes Ausführen der Übertragung beheben können.

 | Datei-Verwaltung aufrufen
 | Bildschirm-Aufteilung für die Datenübertragung wählen: Softkey FENSTER drücken. Die TNC zeigt in der linken Bildschirmhälfte alle Dateien des aktuellen Verzeichnisses und in der rechten Bildschirmhälfte alle Dateien, die im Root-Verzeichnis TNC:\ gespeichert sind
Benutzen Sie die Pfeil-Tasten, um das Hellfeld auf die Datei zu bewegen, die Sie übertragen wollen:
 | Bewegt das Hellfeld in einem Fenster auf und ab
 | Bewegt das Hellfeld vom rechten Fenster ins linke und umgekehrt
Wenn Sie von der TNC zum externen Datenträger kopieren wollen, schieben Sie das Hellfeld im linken Fenster auf die zu übertragende Datei.
Wenn Sie vom externen Datenträger in die TNC kopieren wollen, schieben Sie das Hellfeld im rechten Fenster auf die zu übertragende Datei.
 | Anderes Laufwerk oder Verzeichnis wählen: Softkey zur Verzeichniswahl drücken, die TNC zeigt ein Überblendfenster. Wählen Sie im Überblendfenster mit den Pfeiltasten und der Taste ENT das gewünschte Verzeichnis
 | Einzelne Datei übertragen: Softkey KOPIEREN drücken, oder
 | mehrere Dateien übertragen: Softkey MARKIEREN drücken (auf der zweiten Softkey-Leiste, siehe Dateien markieren)
Mit Softkey ok oder mit der Taste ENT bestätigen. Die TNC blendet ein Status-Fenster ein, das Sie über den Kopierfortschritt informiert, oder
 | Datenübertragung beenden: Hellfeld ins linke Fenster schieben und danach Softkey FENSTER drücken. Die TNC zeigt wieder das Standardfenster für die Datei-Verwaltung

Um bei der doppelten Dateifenster-Darstellung ein anderes Verzeichnis zu wählen, drücken Sie den Softkey zur Verzeichniswahl. Wählen Sie im Überblendfenster mit den Pfeiltasten und der Taste ENT das gewünschte Verzeichnis!


Die TNC am Netzwerk

Um die Ethernet-Karte an Ihr Netzwerk anzuschließen, siehe Ethernet-Schnittstelle.

Fehlermeldungen während des Netzwerk-Betriebs protokolliert die TNC siehe Ethernet-Schnittstelle.

Wenn die TNC an ein Netzwerk angeschlossen ist, stehen Ihnen bis zu 7 zusätzliche Laufwerke im linken Verzeichnis-Fenster zur Verfügung (siehe Bild). Alle zuvor beschriebenen Funktionen (Laufwerk wählen, Dateien kopieren usw.) gelten auch für Netzlaufwerke, sofern Ihre Zugriffsberechtigung dies erlaubt.

Weitere Informationen:
> Netzlaufwerk verbinden und lösen


Netzlaufwerk verbinden und lösen

Datei-Verwaltung wählen: Taste PGM MGT drücken, ggf. mit Softkey FENSTER die Bildschirm-Aufteilung so wählen, wie im Bild rechts oben dargestellt

Netzlaufwerke verwalten: Softkey NETZWERK (zweite Softkey-Leiste) drücken. Die TNC zeigt im rechten Fenster mögliche Netzlaufwerke an, auf die Sie Zugriff haben. Mit den nachfolgend beschriebenen Softkeys legen Sie für jedes Laufwerk die Verbindungen fest

Funktion | Softkey
Netzwerk-Verbindung herstellen, die TNC schreibt in die Spalte Mnt ein M, wenn die Verbindung aktiv ist. Sie können bis zu 7 zusätzliche Laufwerke mit der TNC verbinden |
Netzwerk-Verbindung beenden |
Netzwerk-Verbindung beim Einschalten der TNC automatisch herstellen. Die TNC schreibt in die Spalte Auto ein A, wenn die Verbindung automatisch hergestellt wird |
Netzwerk-Verbindung beim Einschalten der TNC nicht automatisch herstellen |

Der Aufbau der Netzwerk-Verbindung kann einige Zeit in Anspruch nehmen. Die TNC zeigt dann rechts oben am Bildschirm [READ DIR] an. Die maximale Übertragungs-Geschwindigkeit liegt bei 2 bis 5 MBit/s, je nachdem welchen Datei-Typ Sie übertragen und wie hoch die Netzauslastung ist.


USB-Geräte an der TNC (FCL 2-Funktion)

Besonders einfach können Sie Daten über USB-Geräte sichern bzw. in die TNC einspielen. Die TNC unterstützt folgende USB-Blockgeräte:

  • Disketten-Laufwerke mit Dateisystem FAT/VFAT
  • Memory-Sticks mit Dateisystem FAT/VFAT
  • Festplatten mit Dateisystem FAT/VFAT
  • CD-ROM-Laufwerke mit Dateisystem Joliet (ISO9660)

Solche USB-Geräte erkennt die TNC beim Anstecken automatisch. USB-Geräte mit anderen Dateisystemen (z.B. NTFS) unterstützt die TNC nicht. Die TNC gibt beim Anstecken dann die Fehlermeldung USB: TNC unterstützt Gerät nicht aus.

Die TNC gibt die Fehlermeldung USB: TNC unterstützt Gerät nicht auch dann aus, wenn Sie einen USB-Hub anschließen. In diesem Fall die Meldung einfach mit der Taste CE quittieren.

Prinzipiell sollten alle USB-Geräte mit oben erwähnten Dateisystemen an die TNC anschließbar sein. Sollten dennoch Probleme auftreten, setzen Sie sich bitte mit HEIDENHAIN in Verbindung.

In der Datei-Verwaltung sehen Sie USB-Geräte als eigenes Laufwerk im Verzeichnisbaum, so dass Sie die in den vorherigen Abschnitten beschriebenen Funktionen zur Datei-Verwaltung entsprechend nutzen können.

Ihr Maschinenhersteller kann für USB-Geräte feste Namen vergeben. Maschinen-Handbuch beachten!

Um ein USB-Gerät zu entfernen, müssen Sie grundsätzlich wie folgt vorgehen:

Datei-Verwaltung wählen: Taste PGM MGT drücken

Mit der Pfeiltaste das linke Fenster wählen

Mit einer Pfeiltaste das zu trennende USB-Gerät wählen

Softkey-Leiste weiterschalten

Zusätzliche Funktionen wählen

Funktion zum Entfernen von USB-Geräten wählen: Die TNC entfernt das USB-Geräte aus dem Verzeichnisbaum

Datei-Verwaltung beenden

Umgekehrt können Sie ein zuvor entferntes USB-Gerät wieder anbinden, indem Sie folgenden Softkey betätigen:

Funktion zum Wiederanbinden von USB-Geräten wählen


Programmieren: Programmierhilfen

Weitere Informationen:
> Kommentare einfügen
> Programme gliedern
> Der Taschenrechner
> Programmier-Grafik
> 3D-Liniengrafik (FCL2-Funktion)
> Direkte Hilfe bei NC-Fehlermeldungen
> Liste aller anstehenden Fehlermeldungen
> Kontextsensitives Hilfesystem TNCguide (FCL3-Funktion)


Kommentare einfügen

Weitere Informationen:
> Anwendung
> Kommentar während der Programmeingabe
> Kommentar nachträglich einfügen
> Kommentar in eigenem Satz
> Funktionen beim Editieren des Kommentars


Anwendung

Jeden Satz in einem Bearbeitungs-Programm können Sie mit einem Kommentar versehen, um Programmschritte zu erläutern oder Hinweise zu geben.

Wenn die TNC einen Kommentar nicht mehr vollständig am Bildschirm anzeigen kann, erscheint das Zeichen >> am Bildschirm.

Das letzte Zeichen in einem Kommentarsatz darf keine Tilde sein (~).

Sie haben drei Möglichkeiten, einen Kommentar einzugeben:


Kommentar während der Programmeingabe

  • Daten für einen Programm-Satz eingeben, dann „;“ (Semikolon) auf der Alpha-Tastatur drücken – die TNC zeigt die Frage Kommentar?

  • Kommentar eingeben und den Satz mit der Taste END abschließen


Kommentar nachträglich einfügen

  • Den Satz wählen, an den Sie den Kommentar anfügen wollen

  • Mit der Pfeil-nach-rechts-Taste das letzte Wort im Satz wählen: Ein Semikolon erscheint am Satzende und die TNC zeigt die Frage Kommentar?

  • Kommentar eingeben und den Satz mit der Taste END abschließen


Kommentar in eigenem Satz

  • Satz wählen, hinter dem Sie den Kommentar einfügen wollen

  • Programmier-Dialog mit der Taste „;“ (Semikolon) auf der Alpha-Tastatur eröffnen

  • Kommentar eingeben und den Satz mit der Taste END abschließen


Funktionen beim Editieren des Kommentars

Funktion | Softkey
An den Anfang des Kommentars springen |
An das Ende des Kommentars springen |
An den Anfang eines Wortes springen. Wörter sind durch ein Blank zu trennen |
An das Ende eines Wortes springen. Wörter sind durch ein Blank zu trennen |
Umschalten zwischen Einfüge- und Überschreib-Modus |


Programme gliedern

Weitere Informationen:
> Definition, Einsatzmöglichkeit
> Gliederungs-Fenster anzeigen/Aktives Fenster wechseln
> Gliederungs-Satz im Programm-Fenster (links) einfügen
> Sätze im Gliederungs-Fenster wählen


Definition, Einsatzmöglichkeit

Die TNC gibt Ihnen die Möglichkeit, die Bearbeitungs-Programme mit Gliederungs-Sätzen zu kommentieren. Gliederungs-Sätze sind kurze Texte (max. 37 Zeichen), die als Kommentare oder Überschriften für die nachfolgenden Programmzeilen zu verstehen sind.

Lange und komplexe Programme lassen sich durch sinnvolle Gliederungs-Sätze übersichtlicher und verständlicher gestalten.

Das erleichtert besonders spätere Änderungen im Programm. Gliederungs-Sätze fügen Sie an beliebiger Stelle in das Bearbeitungs-Programm ein. Sie lassen sich zusätzlich in einem eigenen Fenster darstellen und auch bearbeiten bzw. ergänzen.

Die eingefügten Gliederungspunkte werden von der TNC in einer separaten Datei verwaltet (Endung .SEC.DEP). Dadurch erhöht sich die Geschwindigkeit beim Navigieren im Gliederungsfenster.


Gliederungs-Fenster anzeigen/Aktives Fenster wechseln

Gliederungs-Fenster anzeigen: Bildschirm-Aufteilung PROGRAMM + GLIEDER. wählen

Das aktive Fenster wechseln: Softkey „Fenster wechseln“ drücken


Gliederungs-Satz im Programm-Fenster (links) einfügen

  • Gewünschten Satz wählen, hinter dem Sie den Gliederungs-Satz einfügen wollen

Softkey GLIEDERUNG EINFÜGEN oder Taste * auf der ASCII-Tastatur drücken

Gliederungs-Text über Alpha-Tastatur eingeben

Ggf. Gliederungstiefe per Softkey verändern


Sätze im Gliederungs-Fenster wählen

Wenn Sie im Gliederungs-Fenster von Satz zu Satz springen, führt die TNC die Satz-Anzeige im Programm-Fenster mit. So können Sie mit wenigen Schritten große Programmteile überspringen.


Der Taschenrechner

Weitere Informationen:
> Bedienung


Bedienung

Die TNC verfügt über einen Taschenrechner mit den wichtigsten mathematischen Funktionen.

  • Mit der Taste CALC den Taschenrechner einblenden bzw. wieder schließen

  • Rechenfunktionen über Kurzbefehle mit der Alpha-Tastatur wählen. Die Kurzbefehle sind im Taschenrechner farblich gekennzeichnet

Rechen-Funktion | Kurzbefehl (Taste)
Addieren | +
Subtrahieren | –
Multiplizieren | *
Dividieren | :
Sinus | S
Cosinus | C
Tangens | T
Arcus-Sinus | AS
Arcus-Cosinus | AC
Arcus-Tangens | AT
Potenzieren | ^
Quadratwurzel ziehen | Q
Umkehrfunktion | /
Klammer-Rechnung | ( )
PI (3.14159265359) | P
Ergebnis anzeigen | =
Weitere Informationen:
> Berechneten Wert ins Programm übernehmen


Berechneten Wert ins Programm übernehmen

  • Mit den Pfeiltasten das Wort wählen, in das der berechnete Wert übernommen werden soll

  • Mit der Taste calc den Taschenrechner einblenden und gewünschte Berechnung durchführen

  • Taste „Ist-Position-übernehmen“ drücken: Die TNC übernimmt den berechneten Wert ins aktive Eingabefeld und schließt den Taschenrechner


Programmier-Grafik

Weitere Informationen:
> Programmier-Grafik mitführen/nicht mitführen
> Programmier-Grafik für bestehendes Programm erstellen
> Satz-Nummern ein- und ausblenden
> Grafik löschen
> Ausschnittsvergrößerung oder -verkleinerung


Programmier-Grafik mitführen/nicht mitführen

Während Sie ein Programm erstellen, kann die TNC die programmierte Kontur mit einer 2D-Strichgrafik anzeigen.

  • Zur Bildschirm-Aufteilung Programm links und Grafik rechts wechseln: Taste SPLIT SCREEN und Softkey PROGRAMM + GRAFIK drücken

Softkey AUTOM. ZEICHNEN auf EIN setzen. Während Sie die Programmzeilen eingeben, zeigt die TNC jede programmierte Bahnbewegung im Grafik-Fenster rechts an

Wenn die TNC die Grafik nicht mitführen soll, setzen Sie den Softkey AUTOM. ZEICHNEN auf AUS.

AUTOM. ZEICHNEN EIN zeichnet keine Programmteil-Wiederholungen mit.


Programmier-Grafik für bestehendes Programm erstellen

  • Wählen Sie mit den Pfeil-Tasten den Satz, bis zu dem die Grafik erstellt werden soll oder drücken Sie GOTO und geben die gewünschte Satz-Nummer direkt ein

Grafik erstellen: Softkey RESET + START drücken

Weitere Funktionen:

Funktion | Softkey
Programmier-Grafik vollständig erstellen |
Programmier-Grafik satzweise erstellen |
Programmier-Grafik komplett erstellen oder nach RESET + START vervollständigen |
Programmier-Grafik anhalten. Dieser Softkey erscheint nur, während die TNC eine Programmier-Grafik erstellt |
Programmier-Grafik neu zeichnen, wenn z.B. durch Überschneidungen Linien gelöscht wurden |

Die Programmiergrafik verrechnet keine Schwenkfunktionen, die TNC gibt in solchen Fällen ggf. eine Fehlermeldung aus.


Satz-Nummern ein- und ausblenden

Softkey-Leiste umschalten: Siehe Bild

Satz-Nummern einblenden: Softkey ANZEIGEN AUSBLEND. SATZ-NR. auf ANZEIGEN setzen

Satz-Nummern ausblenden: Softkey ANZEIGEN AUSBLEND. SATZ-NR. auf AUSBLEND. setzen


Grafik löschen

Softkey-Leiste umschalten: Siehe Bild

Grafik löschen: Softkey GRAFIK LÖSCHEN drücken


Ausschnittsvergrößerung oder -verkleinerung

Sie können die Ansicht für eine Grafik selbst festlegen. Mit einem Rahmen wählen Sie den Ausschnitt für die Vergrößerung oder Verkleinerung.

  • Softkey-Leiste für Ausschnitts-Vergrößerung/Verkleinerung wählen (zweite Leiste, siehe Bild)

Damit stehen folgende Funktionen zur Verfügung:

Funktion | Softkey
Rahmen einblenden und verschieben. Zum Verschieben jeweiligen Softkey gedrückt halten |
Rahmen verkleinern – zum Verkleinern Softkey gedrückt halten |
Rahmen vergrößern – zum Vergrößern Softkey gedrückt halten |

Mit Softkey ROHTEIL AUSSCHN. ausgewählten Bereich übernehmen

Mit dem Softkey ROHTEIL WIE BLK FORM stellen Sie den ursprünglichen Ausschnitt wieder her.


3D-Liniengrafik (FCL2-Funktion)

Weitere Informationen:
> Anwendung
> Funktionen der 3D-Liniengrafik
> NC-Sätze in der Grafik farblich hervorheben
> Satz-Nummern ein- und ausblenden
> Grafik löschen


Anwendung

Mit der dreidimensionalen Liniengrafik können Sie die programmierten Verfahrwege von der TNC dreidimensional darstellen lassen. Um Details schnell erkennen zu können, steht eine leistungsfähige Zoom-Funktion zur Verfügung.

Insbesondere extern erstellte Programme können Sie mit der 3D-Liniengrafik schon vor der Bearbeitung auf Unregelmäßigkeiten prüfen, um unerwünschte Bearbeitungsmarken am Werkstück zu vermeiden. Solche Bearbeitungsmarken treten beispielsweise dann auf, wenn Punkte vom Postprozessor falsch ausgegeben wurden.

Damit Sie schnell Fehlerstellen aufspüren können, markiert die TNC den im linken Fenster aktiven Satz in der 3D-Liniengrafik andersfarbig (Grundeinstellung: Rot).

Die 3D-Liniengrafik können Sie im Split-Screen-Modus oder im Full-Screen-Modus verwenden:

  • Programm links und 3D-Linien rechts anzeigen: Taste SPLIT SCREEN und Softkey PROGRAMM + 3D-LINIEN drücken

  • 3D-Liniengrafik auf dem ganzen Bildschirm anzeigen: Taste SPLIT SCREEN und Softkey 3D-LINIEN drücken


Funktionen der 3D-Liniengrafik

Funktion | Softkey
Zoom-Rahmen einblenden und nach oben verschieben. Zum Verschieben Softkey gedrückt halten |
Zoom-Rahmen einblenden und nach unten verschieben. Zum Verschieben Softkey gedrückt halten |
Zoom-Rahmen einblenden und nach links verschieben. Zum Verschieben Softkey gedrückt halten |
Zoom-Rahmen einblenden und nach rechts verschieben. Zum Verschieben Softkey gedrückt halten |
Rahmen vergrößern – zum Vergrößern Softkey gedrückt halten |
Rahmen verkleinern – zum Verkleinern Softkey gedrückt halten |
Ausschnitts-Vergrößerung zurücksetzen, so dass die TNC das Werkstück gemäß programmierter BLK-Form anzeigt |
Ausschnitt übernehmen |
Werkstück im Uhrzeigersinn drehen |
Werkstück im Gegen-Uhrzeigersinn drehen |
Werkstück nach hinten kippen |
Werkstück nach vorne kippen |
Darstellung schrittweise vergrößern. Ist die Darstellung vergrößert, zeigt die TNC in der Fußzeile des Grafikfensters den Buchstaben Z an |
Darstellung schrittweise verkleinern. Ist die Darstellung verkleinert, zeigt die TNC in der Fußzeile des Grafikfensters den Buchstaben Z an |
Werkstück in Originalgröße anzeigen |
Werkstück in der zuletzt aktiven Ansicht anzeigen |
Programmierte Endpunkte durch einen Punkt auf der Linie anzeigen/nicht anzeigen |
Den im linken Fenster angewählten NC-Satz in der 3D-Liniengrafik farblich hervorgehoben anzeigen/nicht anzeigen |
Satz-Nummern anzeigen/nicht anzeigen |

Sie können die 3D-Liniengrafik auch mit der Mouse bedienen. Folgende Funktionen stehen zur Verfügung:

  • Um das dargestellte Drahtmodell dreidimensional zu drehen: rechte Mouse-Taste gedrückt halten und Mouse bewegen. Die TNC zeigt ein Koordinatensystem an, das die momentan aktive Ausrichtung des Wekstückes darstellt. Nachdem Sie die rechte Mouse-Taste losgelassen haben, orientiert die TNC das Werkstück auf die definierte Ausrichtung

  • Um das dargestellte Drahtmodell zu verschieben: mittlere Mouse-Taste, bzw. Mouse-Rad, gedrückt halten und Mouse bewegen. Die TNC verschiebt das Werkstück in die entsprechende Richtung. Nachdem Sie die mittlere Mouse-Taste losgelassen haben, verschiebt die TNC das Werkstück auf die definierte Position

  • Um mit der Mouse einen bestimmten Bereich zu zoomen: mit gedrückter linker Mouse-Taste den rechteckigen Zoom-Bereich markieren, Sie können den Zoom-Bereich durch horizontales und vertikales Bewegen der Mouse noch verschieben. Nachdem Sie die linke Mouse-Taste losgelassen haben, vergrößert die TNC das Werkstück auf den definierten Bereich

  • Um mit der Mouse schnell aus- und einzuzoomen: Mouserad vor bzw. zurückdrehen

  • Doppelklick mit der rechten Mouse-Taste: Standardansicht anwählen


NC-Sätze in der Grafik farblich hervorheben

Softkey-Leiste umschalten

Im Bildschirm links angewählten NC-Satz in der 3D-Liniengrafik rechts farblich markiert anzeigen: Softkey akt. elem. markieren aus / ein. auf ein setzen

Im Bildschirm links angewählten NC-Satz in der 3D-Liniengrafik rechts nicht farblich markiert anzeigen: Softkey akt. elem. markieren aus / ein. auf aus setzen


Satz-Nummern ein- und ausblenden

Softkey-Leiste umschalten

Satz-Nummern einblenden: Softkey ANZEIGEN AUSBLEND. SATZ-NR. auf ANZEIGEN setzen

Satz-Nummern ausblenden: Softkey ANZEIGEN AUSBLEND. SATZ-NR. auf AUSBLEND. setzen


Grafik löschen

Softkey-Leiste umschalten

Grafik löschen: Softkey GRAFIK LÖSCHEN drücken


Direkte Hilfe bei NC-Fehlermeldungen

Weitere Informationen:
> Fehlermeldungen anzeigen
> Hilfe anzeigen


Fehlermeldungen anzeigen

Fehlermeldungen zeigt die TNC automatisch unter anderem bei

  • falschen Eingaben
  • logischen Fehlern im Programm
  • nicht ausführbaren Konturelementen
  • unvorschriftsmäßigen Tastsystem-Einsätzen

Eine Fehlermeldung, die die Nummer eines Programmsatzes enthält, wurde durch diesen Satz oder einen vorhergegangenen verursacht. TNC-Meldetexte löschen Sie mit der Taste CE, nachdem Sie die Fehlerursache beseitigt haben. Fehlermeldungen, die zu einem Steuerungsabsturz führen müssen Sie durch Drücken der Taste END quittieren. Die TNC startet dann neu.

Um nähere Informationen zu einer anstehenden Fehlermeldung zu erhalten, drücken Sie die Taste HELP. Die TNC blendet dann ein Fenster ein, in dem die Fehlerursache und die Fehlerbehebung beschrieben sind.


Hilfe anzeigen

Hilfe anzeigen: Taste HELP drücken

Fehlerbeschreibung und die Möglichkeiten zur Fehlerbeseitigung durchlesen. Ggf. zeigt die TNC noch Zusatz-Informationen an, die bei der Fehlersuche durch HEIDENHAIN-Mitarbeiter hilfreich sind. Mit der Taste CE schließen Sie das Hilfe-Fenster und quittieren gleichzeitig die anstehende Fehlermeldung

Fehler gemäß der Beschreibung im Hilfe-Fenster beseitigen


Liste aller anstehenden Fehlermeldungen

Weitere Informationen:
> Funktion
> Fehlerliste anzeigen
> Fenster-Inhalt
> Hilfesystem TNCguide aufrufen
> Servicedateien erzeugen


Funktion

Mit dieser Funktion können Sie ein Überblendfenster anzeigen lassen, in der die TNC alle anstehenden Fehlermeldungen anzeigt. Die TNC zeigt sowohl Fehler die aus der NC als auch Fehler, die von Ihrem Maschinenhersteller ausgegeben werden.


Fehlerliste anzeigen

Sobald mindestens eine Fehlermeldungen ansteht können Sie die Liste anzeigen lassen:

Liste anzeigen: Taste ERR drücken

Mit den Pfeiltasten können Sie eine der anstehenden Fehlermeldungen anwählen

Mit der Taste CE oder der Taste DEL löschen Sie die Fehlermeldung aus dem Überblendfenster, die momentan angwählt ist. Wenn nur eine Fehlermeldung ansteht, schließen sich gleichzeitig das Überblendfenster

Überblendfenster schließen: Taste ERR erneut drücken. Anstehende Fehlermeldungen bleiben erhalten

Parallel zur Fehlerliste können Sie auch den jeweils zugehörigen Hilfetext in einem separaten Fenster anzeigen lassen: Taste HELP drücken.


Fenster-Inhalt

Spalte Bedeutung

Nummer

Fehlernummer (-1: Keine Fehlernummer definiert), die von HEIDENHAIN oder Ihrem Maschinenhersteller vergeben wird

Klasse

    Fehlerklasse. Legt fest, wie die TNC diesen Fehler verarbeitet:

  • ERROR
    Sammelfehlerklasse für Fehler, bei denen je nach Zustand der Maschine bzw. aktiven Betriebsart unterschiedliche Fehlerreaktionen ausgelöst werden)
  • FEED HOLD
    Die Vorschub-Freigabe wird gelöscht
  • PGM HOLD
    Der Programmlauf wird unterbrochen (STIB blinkt)
  • PGM ABORT
    Der Programmlauf wird abgebrochen (INTERNER STOPP)
  • EMERG. STOPP
    NOT-AUS wird ausgelöst
  • reset
    TNC führt einen Warmstart aus
  • WARNING
    Warnmeldung, Programmlauf wird fortgesetzt
  • INFO
    Info-Meldung, Programmlauf wird fortgesetzt

Gruppe

    Gruppe. Legt fest, aus welchem Teil der Betriebssystem-Software die Fehlermeldung erzeugt wurde

  • operating
  • programming
  • plc
  • general

Fehlermeldung

Fehlertext, den die TNC jeweils anzeigt


Hilfesystem TNCguide aufrufen

Per Softkey können Sie das Hilfesystem der TNC aufrufen. Momentan erhalten Sie innerhalb des Hilfesystems dieselbe Fehlererklärung, die Sie auch beim Druck auf die Taste HELP erhalten.

Wenn Ihr Maschinenhersteller auch ein Hilfesystem zur Verfügung stellt, dann blendet die TNC den zusätzlichen Softkey maschinen-hersteller ein, über den Sie dieses separate Hilfesystem aufrufen können. Dort finden Sie dann weitere, detailiertere Informationen zur anstehenden Fehlermeldung.

Hilfe zu HEIDENHAIN-Fehlermeldungen aufrufen

Wenn vefügbar, Hilfe zu maschinenspezifischen Fehlermeldungen aufrufen


Servicedateien erzeugen

Mit dieser Funktion können Sie alle für Servicezwecke relevante Daten in eine ZIP-Datei speichern. Die entsprechenden Daten der NC und PLC werden von der TNC in der Datei TNC:\service\service<xxxxxxxx>.zip gespeichert. Den Namen der Datei legt die TNC automatisch fest, wobei <xxxxxxxx> als eindeutige Zeichenfolge die Systemzeit darstellt.

Es stehen folgende Möglichkeiten zur Verfügung eine Servicedatei zu erzeugen:

  • Drücken des Softkeys SERVICE-DATEIEN SPEICHERN nachdem Sie die Taste ERR betätigt haben
  • Von extern über die Datenübertragungs-Software TNCremoNT
  • Beim Absturz der NC-Software aufgrund eines schwerwiegenden Fehlers erzeugt die TNC die Servicedateien automatisch
  • Zusätzlich kann Ihr Maschinenhersteller für PLC-Fehlermeldungen ebenfalls automatisch Servicedateien erzeugen lassen.

Unter anderem werden folgende Daten in die Servicedatei gespeichert:

  • Logbuch
  • PLC-Logbuch
  • Angewählte Dateien (*.H/*.I/*.T/*.TCH/*.D) aller Betriebsarten
  • *.SYS-Dateien
  • Maschinen-Parameter
  • Informations- und Protokolldateien des Betriebssystems (teilweise über MP7691 aktivierbar)
  • PLC-Speicherinhalte
  • In PLC:\NCMACRO.SYS definierte NC-Makros
  • Informationen über die Hardware

Zusätzlich können Sie auf Anweisung des Kundendienstes eine weitere Steuerdatei TNC:\service\userfiles.sys im ASCII-Format hinterlegen. Die TNC packt dann auch die dort definierten Daten mit in die ZIP-Datei.

Die Servicedatei enthält alle NC-Daten, die zur Fehlersuche erforderlich sind. Mit der Weitergabe der Servicedatei erklären Sie sich einverstanden, dass Ihr Maschinenhersteller bzw. die DR. JOHANNES HEIDENHAIN GmbH diese Daten zu Diagnosezwecken nutzt.

Die Maximalgröße einer Service-Datei beträgt 40 MByte


Kontextsensitives Hilfesystem TNCguide (FCL3-Funktion)

Weitere Informationen:
> Anwendung
> Arbeiten mit dem TNCguide
> Aktuelle Hilfedateien downloaden


Anwendung

Das Hilfesystem TNCguide steht nur zur Verfügung, wenn Ihre Steuerungshardware über mindestens 256 MByte Arbeitsspeicher verfügt und zusätzlich FCL3 gesetzt ist.

Das kontextsensitive Hilfesystem TNCguide enthält die Benutzer-Dokumentation im HTML-Format. Der Aufruf des TNCguide erfolgt über die HELP-Taste, wobei die TNC teilweise situationsabhängig die zugehörige Information direkt anzeigt (kontextsensitiver Aufruf). Auch wenn Sie in einem NC-Satz editieren und die HELP-Taste drücken, gelangen Sie in der Regel genau an die Stelle in der Dokumentation, an der die entsprechende Funktion beschrieben ist.

Standardmäßig werden die deutsche und englische Dokumentation mit der jeweiligen NC-Software ausgeliefert. Die restlichen Dialogsprachen stellt HEIDENHAIN zum kostenlosen Download zur Verfügung, sobald die jeweiligen Übersetzungen verfügbar sind (siehe Aktuelle Hilfedateien downloaden).

Die TNC versucht grundsätzlich den TNCguide in der Sprache zu starten, die Sie als Dialogsprache an Ihrer TNC eingestellt haben. Wenn die Dateien dieser Dialogsprache an Ihrer TNC noch nicht zur Verfügung stehen, dann öffnet die TNC die englische Version.

    Folgende Benutzer-Dokumentationen sind im TNCguide verfügbar:

  • Benutzer-Handbuch Klartext-Dialog (BHBKlartext.chm)
  • Benutzer-Handbuch DIN/ISO (BHBIso.chm)
  • Benutzer-Handbuch Zyklen (BHBcycles.chm)
  • Benutzer-Handbuch smarT.NC (Lotsenformat, BHBSmart.chm)
  • Liste aller NC-Fehlermeldungen (errors.chm)

Zusätzlich ist noch die Buchdatei main.chm verfügbar, in der alle vorhandenen chm-Dateien zusammengefasst dargestellt sind.

Optional kann Ihr Maschinenhersteller noch maschinenspezifische Dokumentationen in den TNCguide einbetten. Diese Dokumente erscheinen dann als separates Buch in der Datei main.chm.


Arbeiten mit dem TNCguide

TNCguide aufrufen

Um den TNCguide zu starten, stehen mehrere Möglichkeiten zur Verfügung:

  • Taste HELP drücken, wenn die TNC nicht gerade eine Fehlermeldung anzeigt

  • Per Mouse-Klick auf Softkeys, wenn Sie zuvor das rechts unten im Bildschirm eingeblendete Hilfesymbol angeklickt haben

  • Über die Datei-Verwaltung eine Hilfe-Datei (CHM-Datei) öffnen. Die TNC kann jede beliebige CHM-Datei öffnen, auch wenn diese nicht auf der Festplatte der TNC gespeichert ist

Wenn eine oder mehrere Fehlermeldungen anstehen, dann blendet die TNC die direkte Hilfe zu den Fehlermeldungen ein. Um den TNCguide starten zu können, müssen Sie zunächst alle Fehlermeldungen quittieren.

Die TNC startet beim Aufruf des Hilfesystems auf dem Programmierplatz und der Zwei-Prozessor-Version den systemintern definierten Standardbrowser (in der Regel den Internet Explorer) und auf der Einprozessor-Version einen von HEIDENHAIN angepassten Browser.

Zu vielen Softkeys steht ein kontextsensitiver Aufruf zur Verfügung, über den Sie direkt zur Funktionsbeschreibung des jeweiligen Softkeys gelangen. Diese Funktionalität steht Ihnen nur über Mouse-Bedienung zur Verfügung. Gehen Sie wie folgt vor:

  • Softkey-Leiste wählen, in der der gewünschte Softkey angezeigt wird

  • Mit der Mouse auf das Hilfesymbol klicken, das die TNC direkt rechts über der Softkey-Leiste anzeigt: Der Mouse-Cursor ändert sich zum Fragezeichen

  • Mit dem Fragezeichen auf den Softkey klicken, dessen Funktion Sie erklärt haben wollen: Die TNC öffnet den TNCguide. Wenn für den von Ihnen gewählten Softkey keine Einsprungstelle existiert, dann öffnet die TNC die Buchdatei main.chm, von der aus Sie per Volltextsuche oder per Navigation manuell die gewünschte Erklärung suchen müssen

Auch wenn Sie gerade einen NC-Satz editieren steht ein kontextsensitiver Aufruf zur Verfügung:

  • Beliebigen NC-Satz wählen

  • Mit Pfeiltasten in den Satz cursorn

  • Taste HELP drücken: Die TNC startet das Hilfesystem und zeigt die Beschreibung zur aktiven Funktion (gilt nicht für Zusatz-Funktionen oder Zyklen, die von Ihrem Maschinenhersteller integriert wurden)

Im TNCguide navigieren

Am einfachsten können Sie per Mouse im TNCguide navigieren. Auf der linken Seite ist das Inhaltsverzeichnis sichtbar. Sie können durch Klick auf das nach rechts zeigende Dreieck die darunterliegenden Kapitel anzeigen lassen oder direkt durch Klick auf den jeweiligen Eintrag die entsprechende Seite anzeigen lassen. Die Bedienung ist identisch zur Bedienung des Windows Explorers.

Verlinkte Textstellen (Querverweise) sind blau und unterstrichen dargestellt. Ein Klick auf einen Link öffnet die entsprechende Seite.

Selbstverständlich können Sie den TNCguide auch per Tasten und Softkeys bedienen. Nachfolgende Tabelle enthält eine Übersicht der entsprechenden Tastenfunktionen.

Funktion Softkey
  • Inhaltsverzeichnis links ist aktiv:
    Den darunter- bzw. darüberliegenden Eintrag wählen
  • Textfenster rechts ist aktiv:
    Seite nach unten bzw. nach oben verschieben, wenn Text oder Grafiken nicht vollständig angezeigt werden

  • Inhaltsverzeichnis links ist aktiv:
    Inhaltsverzeichnis aufklappen. Wenn Inhaltsverzeichnis nicht mehr aufklappbar, dann Sprung ins rechte Fenster
  • Textfenster rechts ist aktiv:
    Keine Funktion

  • Inhaltsverzeichnis links ist aktiv:
    Inhaltsverzeichnis zuklappen
  • Textfenster rechts ist aktiv:
    Keine Funktion

  • Inhaltsverzeichnis links ist aktiv:
    Per Cursor-Taste gewählte Seite anzeigen
  • Textfenster rechts ist aktiv:
    Wenn Cursor auf einem Link steht, dann Sprung auf die verlinkte Seite

  • Inhaltsverzeichnis links ist aktiv:
    Reiter umschalten zwischen Anzeige des Inhalts-Verzeichnisses, Anzeige des Stichwort-Verzeichnisses und der Funktion Volltextsuche und Umschalten auf die rechte Bildschirmseite
  • Textfenster rechts ist aktiv:
    Sprung zurück ins linke Fenster

  • Inhaltsverzeichnis links ist aktiv:
    Den darunter- bzw. darüberliegenden Eintrag wählen
  • Textfenster rechts ist aktiv:
    Nächsten Link anspringen

Zuletzt angezeigte Seite wählen

Vorwärts blättern, wenn Sie mehrfach die Funktion „zuletzt angezeigte Seite wählen“ verwendet haben

Eine Seite zurück blättern

Eine Seite nach vorne blättern

Inhaltsverzeichnis anzeigen/ausblenden

Wechseln zwischen Vollbild-Darstellung und reduzierter Darstellung. Bei reduzierter Darstellung sehen Sie noch einen Teil der TNC-Oberfläche

Der Fokus wird intern auf die TNC-Anwendung gewechselt, so dass Sie bei geöffnetem TNCguide die Steuerung bedienen können. Wenn die Vollbild-Darstellung aktiv ist, dann reduziert die TNC vor dem Fokuswechsel automatisch die Fenstergröße

TNCguide beenden

Stichwort-Verzeichnis

Die wichtigsten Stichwörter sind im Stichwortverzeichnis (Reiter Index) aufgeführt und können von Ihnen per Mouse-Klick oder durch Selektieren per Cursor-Tasten direkt angewählt werden.

Die linke Seite ist aktiv.

Reiter Index wählen

Eingabefeld Schlüsselwort aktivieren

Zu suchendes Wort eingeben, die TNC synchronisiert dann das Stichwortverzeichnis bezogen auf den eingegebenen Text, so dass Sie das Stichwort in der aufgeführten Liste schneller finden können, oder

Per Pfeiltaste gewünschtes Stichwort hell hinterlegen

Mit Taste ENT Informationen zum gewählten Stichwort anzeigen lassen

Weitere Informationen:
> Volltext-Suche


Volltext-Suche

Im Reiter Suchen haben Sie die Möglichkeit, den kompletten TNCguide nach einem bestimmten Wort zu durchsuchen.

Die linke Seite ist aktiv.

Reiter Suchen wählen

Eingabefeld Suchen: aktivieren

Zu suchendes Wort eingeben, mit Taste ENT bestätigen: Die TNC listet alle Fundstellen auf, die dieses Wort enthalten

Per Pfeiltaste gewünschte Stelle hell hinterlegen

Mit Taste ENT die gewählte Fundstelle anzeigen

Die Volltext-Suche können Sie immer nur mit einem einzelnen Wort durchführen.

Wenn Sie die Funktion Nur in Titeln suchen aktivieren (per Mouse-Taste oder durch ancursorn und anschließendes Betätigen der Blank-Taste), durchsucht die TNC nicht den kompletten Text sondern nur alle Überschriften.


Aktuelle Hilfedateien downloaden

Die zu Ihrer TNC-Software passenden Hilfedateien finden sie auf der HEIDENHAIN-Homepage www.heidenhain.de unter:

  • Dokumentation / Information

  • Dokumentation

  • Benutzer-Dokumentation

  • TNCguide

  • Gewünschte Sprache wählen, z.B. Deutsch

  • TNC-Steuerungen

  • Baureihe TNC 500

  • Gewünschte NC-Software-Nummer, z.B. iTNC 530 (340 49x-06)

  • Aus der Tabelle Online-Hilfe TNCguide (CHM-Dateien) die gewünschte Sprachversion wählen

  • ZIP-Datei herunterladen und auspacken

  • Die ausgepackten CHM-Dateien auf die TNC in das Verzeichnis TNC:\tncguide\de bzw. in das entsprechende Sprach-Unterverzeichnis übertragen (siehe auch nachfolgende Tabelle)

Wenn Sie die CHM-Dateien mit TNCremoNT zur TNC übertragen, müssen Sie im Menüpunkt Extras>Konfiguration>Modus>Übertragung im Binärformat die Extension .CHM eintragen.

Sprache | TNC-Verzeichnis
Deutsch | TNC:\tncguide\de
Englisch | TNC:\tncguide\en
Tschechisch | TNC:\tncguide\cs
Französisch | TNC:\tncguide\fr
Italienisch | TNC:\tncguide\it
Spanisch | TNC:\tncguide\es
Portugiesisch | TNC:\tncguide\pt
Schwedisch | TNC:\tncguide\sv
Dänisch | TNC:\tncguide\da
Finnisch | TNC:\tncguide\fi
Niederländisch | TNC:\tncguide\nl
Polnisch | TNC:\tncguide\pl
Ungarisch | TNC:\tncguide\hu
Russisch | TNC:\tncguide\ru
Chinesisch (simplified) | TNC:\tncguide\zh
Chinesisch (traditional) | TNC:\tncguide\zh-tw
Slowenisch (Software-Option) | TNC:\tncguide\sl
Norwegisch | TNC:\tncguide\no
Slowakisch | TNC:\tncguide\sk
Lettisch | TNC:\tncguide\lv
Koreanisch | TNC:\tncguide\kr
Estnisch | TNC:\tncguide\et
Türkisch | TNC:\tncguide\tr
Rumänisch | TNC:\tncguide\ro
Litauisch | TNC:\tncguide\lt


Programmieren: Werkzeuge

Weitere Informationen:
> Werkzeugbezogene Eingaben
> Werkzeug-Daten
> Werk eug-Korrektur


Werkzeugbezogene Eingaben

Weitere Informationen:
> Vorschub F
> Spindeldrehzahl S


Vorschub F

Der Vorschub F ist die Geschwindigkeit in mm/min (inch/min), mit der sich der Werkzeugmittelpunkt auf seiner Bahn bewegt. Der maximale Vorschub kann für jede Maschinenachse unterschiedlich sein und ist durch Maschinen-Parameter festgelegt.

Weitere Informationen:
> Eingabe
> Eilgang
> Wirkungsdauer
> Änderung während des Programmlaufs


Eingabe

Den Vorschub können Sie im T-Satz (Werkzeug-Aufruf) und in jedem Positioniersatz eingeben (siehe Werkzeug-Bewegungen in DIN/ISO programmieren). In Millimeter-Programmen geben Sie den Vorschub in der Einheit mm/min ein, in Inch-Programmen aus Gründen der Auflösung in 1/10 inch/min.


Eilgang

Für den Eilgang geben Sie G00 ein.


Wirkungsdauer

Der mit einem Zahlenwert programmierte Vorschub gilt bis zu dem Satz, in dem ein neuer Vorschub programmiert wird. Ist der neue Vorschub G00 (Eilgang), gilt nach dem nächsten Satz mit G01 wieder der letzte mit Zahlenwert programmierte Vorschub.


Änderung während des Programmlaufs

Während des Programmlaufs ändern Sie den Vorschub mit dem Override-Drehknopf F für den Vorschub.


Spindeldrehzahl S

Die Spindeldrehzahl S geben Sie in Umdrehungen pro Minute (U/min) in einem T-Satz ein (Werkzeug-Aufruf). Alternativ können Sie auch eine Schnittgeschwindigkeit Vc in m/min definieren.

Weitere Informationen:
> Programmierte Änderung
> Änderung während des Programmlaufs


Programmierte Änderung

Im Bearbeitungs-Programm können Sie die Spindeldrehzahl mit einem T-Satz ändern, indem Sie ausschließlich die neue Spindeldrehzahl eingeben:

Spindeldrehzahl programmieren: Taste S auf der Alpha-Tastatur drücken

Neue Spindeldrehzahl eingeben


Änderung während des Programmlaufs

Während des Programmlaufs ändern Sie die Spindeldrehzahl mit dem Override-Drehknopf S für die Spindeldrehzahl.


Werkzeug-Daten

Weitere Informationen:
> Voraussetzung für die Werkzeug-Korrektur
> Werkzeug-Nummer, Werkzeug-Name
> Werkzeug-Länge L
> Werkzeug-Radius R
> Delta-Werte für Längen und Radien
> Werkzeug-Daten ins Programm eingeben
> Werkzeug-Daten in die Tabelle eingeben
> Werkzeugträger-Kinematik
> Einzelne Werkzeugdaten von einem externen PC aus überschreiben
> Platz-Tabelle für Werkzeug-Wechsler
> Werkzeug-Daten aufrufen
> Werkzeugwechsel
> Werkzeug-Einsatzprüfung
> Werkzeug-Verwaltung (Software-Option)


Voraussetzung für die Werkzeug-Korrektur

Üblicherweise programmieren Sie die Koordinaten der Bahnbewegungen so, wie das Werkstück in der Zeichnung bemaßt ist. Damit die TNC die Bahn des Werkzeug-Mittelpunkts berechnen, also eine Werkzeug-Korrektur durchführen kann, müssen Sie Länge und Radius zu jedem eingesetzten Werkzeug eingeben.

Werkzeug-Daten können Sie entweder mit der Funktion G99 direkt im Programm oder separat in Werkzeug-Tabellen eingeben. Wenn Sie die Werkzeug-Daten in Tabellen eingeben, stehen weitere werkzeugspezifische Informationen zur Verfügung. Die TNC berücksichtigt alle eingegebenen Informationen, wenn das Bearbeitungs-Programm läuft.


Werkzeug-Nummer, Werkzeug-Name

Jedes Werkzeug ist durch eine Nummer zwischen 0 und 30000 gekennzeichnet. Wenn Sie mit Werkzeug-Tabellen arbeiten, können Sie zusätzlich Werkzeug-Namen vergeben. Werkzeug-Namen dürfen maximal aus 32 Zeichen bestehen.

Das Werkzeug mit der Nummer 0 ist als Null-Werkzeug festgelegt und hat die Länge L=0 und den Radius R=0. In Werkzeug-Tabellen sollten Sie das Werkzeug T0 ebenfalls mit L=0 und R=0 definieren.


Werkzeug-Länge L

Die Werkzeug-Länge L sollten Sie grundsätzlich als absolute Länge bezogen auf den Werkzeug-Bezugspunkt eingeben. Die TNC benötigt für zahlreiche Funktionen in Verbindung mit Mehrachsbearbeitung zwingend die Gesamtlänge des Werkzeugs.


Werkzeug-Radius R

Den Werkzeug-Radius R geben Sie direkt ein.


Delta-Werte für Längen und Radien

Delta-Werte bezeichnen Abweichungen für die Länge und den Radius von Werkzeugen.

Ein positiver Delta-Wert steht für ein Aufmaß (DL, DR, DR2>0). Bei einer Bearbeitung mit Aufmaß geben Sie den Wert für das Aufmaß beim Programmieren des Werkzeug-Aufrufs mit T ein.

Ein negativer Delta-Wert bedeutet ein Untermaß (DL, DR, DR2<0). Ein Untermaß wird in der Werkzeug-Tabelle für den Verschleiß eines Werkzeugs eingetragen.

Delta-Werte geben Sie als Zahlenwerte ein, in einem T-Satz können Sie den Wert auch mit einem Q-Parameter übergeben.

Eingabebereich: Delta-Werte dürfen maximal ± 99,999 mm betragen.

Delta-Werte aus der Werkzeug-Tabelle beeinflussen die grafische Darstellung des Werkzeuges. Die Darstellung des Werkstückes in der Simulation bleibt gleich.

Delta-Werte aus dem T-Satz verändern in der Simulation die dargestellte Größe des Werkstückes. Die simulierte Werkzeuggröße bleibt gleich.


Werkzeug-Daten ins Programm eingeben

Nummer, Länge und Radius für ein bestimmtes Werkzeug legen Sie im Bearbeitungs-Programm einmal in einem g99-Satz fest:

  • Werkzeug-Definition wählen: Taste TOOL DEF drücken

Werkzeug-Nummer: Mit der Werkzeug-Nummer ein Werkzeug eindeutig kennzeichnen

Werkzeug-Länge: Korrekturwert für die Länge

Werkzeug-Radius: Korrekturwert für den Radius

Während des Dialogs können Sie den Wert für die Länge und den Radius direkt in das Dialogfeld einfügen: Gewünschten Achs-Softkey drücken.

Wenn die Werkzeug-Tabelle TOOL.T aktiv ist, dann bewirkt ein G99-Satz eine Werkzeug-Vorauswahl. Maschinenhandbuch beachten.

Beispiel
N40 G99 T5 L+10 R+5 *


Werkzeug-Daten in die Tabelle eingeben

In einer Werkzeug-Tabelle können Sie bis zu 30000 Werkzeuge -definieren und deren Werkzeug-Daten speichern. Die Anzahl der Werkzeuge, die die TNC beim Öffnen einer neuen Tabelle anlegt, -definieren Sie mit dem Maschinen-Parameter 7260. Beachten Sie auch die Editier-Funktionen weiter unten in diesem Kapitel. Um zu einem Werkzeug mehrere Korrekturdaten eingeben zu können -(Werkzeug-Nummer indizieren), setzen Sie den Maschinen-Parameter 7262 ungleich 0.

    Sie müssen die Werkzeug-Tabellen verwenden, wenn

  • Sie indizierte Werkzeuge, wie z.B. Stufenbohrer mit mehreren Längenkorrekturen, einsetzen wollen Wenn die TNC nicht alle Positionen in der Werkzeug-Tabelle gleichzeitig anzeigen kann, zeigt der Balken oben in der Tabelle das Symbol „>>“ bzw. „<<“.

  • Ihre Maschine mit einem automatischen Werkzeug-Wechsler ausgerüstet ist

  • Sie mit dem TT 130 Werkzeuge automatisch vermessen wollen (siehe Benutzer-Handbuch Tastsystem-Zyklen)

  • Sie mit dem Bearbeitungs-Zyklus G122 nachräumen wollen (siehe Benutzer-Handbuch Zyklen, Zyklus RAUMEN)

  • Sie mit den Bearbeitungs-Zyklen 251 bis 254 arbeiten wollen (siehe Benutzer-Handbuch Zyklen, Zyklen 251 bis 254)

  • Sie mit automatischer Schnittdaten-Berechnung arbeiten wollen

Weitere Informationen:
> Werkzeug-Tabelle: Standard Werkzeug-Daten
> Werkzeug-Tabelle: Werkzeug-Daten für die automatische Werkzeug-Vermessung
> Werkzeug-Tabelle: Werkzeug-Daten für automatische Drehzahl- / Vorschub-Berechnung
> Werkzeug-Tabelle: Werkzeug-Daten für schaltende Tastsysteme (nur wenn Bit1 in MP7411 = 1 gesetzt ist, siehe auch Benutzer-Handbuch Tastsystem-Zyklen)
> Werkzeug-Tabellen editieren
> Editierfunktionen
> Werkzeug-Tabelle verlassen
> Hinweise zu Werkzeug-Tabellen


Werkzeug-Tabelle: Standard Werkzeug-Daten
Abk. | Eingaben | Dialog
T | Nummer, mit der das Werkzeug im Programm aufgerufen wird (z.B. 5, indiziert: 5.2). | -
NAME | Name, mit dem Sie das Werkzeug im Programm aufrufen. Eingabebereich: Maximal 32 Zeichen, nur Großbuchstaben, kein Leerzeichen). Beim Überspielen von Werkzeug-Tabellen in ältere Softwarestände der iTNC 530 bzw. in ältere TNC-Steuerungen darauf achten, dass Werkzeug-Namen nicht länger als 16 Zeichen sind, da diese von der TNC beim Einlesen ggf. gekürzt (abgeschnitten) werden. Dies kann zu Fehlern in Verbindung mit der Funktion Schwester-Werkzeuge führen. | Werkzeug-Name?
L | Korrekturwert für die Werkzeug-Länge L. Eingabebereich mm: -99999.9999 bis +99999.9999 Eingabebereich inch: -3936.9999 bis +3936.9999 | Werkzeug-Länge?
R | Korrekturwert für den Werkzeug-Radius R. Eingabebereich mm: -99999.9999 bis +99999.9999 Eingabebereich inch: -3936.9999 bis +3936.9999 | Werkzeug-Radius R?
R2 | Werkzeug-Radius 2 für Ecken-Radiusfräser (nur für dreidimensionale Radiuskorrektur oder grafische Darstellung der Bearbeitung mit Radiusfräser). Eingabebereich mm: -99999.9999 bis +99999.9999 Eingabebereich inch: -3936.9999 bis +3936.9999 | Werkzeug-Radius R2?
DL | Delta-Wert Werkzeug-Länge L. Eingabebereich mm: -999.9999 bis +999.9999 Eingabebereich inch: -39.37 bis +39.37 | Aufmaß Werkzeug-Länge?
DR | Delta-Wert Werkzeug-Radius R. Eingabebereich mm: -999.9999 bis +999.9999 Eingabebereich inch: -39.37 bis +39.37 | Aufmaß Werkzeug-Radius?
DR2 | Delta-Wert Werkzeug-Radius R2. Eingabebereich mm: -999.9999 bis +999.9999 Eingabebereich inch: -39.37 bis +39.37 | Aufmaß Werkzeug-Radius R2?
LCUTS | Schneidenlänge des Werkzeugs für Zyklus 22. Eingabebereich mm: 0 bis +99999.9999 Eingabebereich inch: 0 bis +3936.9999 | Schneidenlänge in der Wkz-Achse?
ANGLE | Maximaler Eintauchwinkel des Werkzeug bei pendelnder Eintauchbewegung für Zyklen 22, 208 und 25x. Eingabebereich: 0 bis 90° | Maximaler Eintauchwinkel?
TL | Werkzeug-Sperre setzen (TL: für Tool Locked = engl. Werkzeug gesperrt). Eingabebereich: L oder Leerzeichen | Wkz gesperrt? Ja = ENT / Nein = NO ENT
RT | Nummer eines Schwester-Werkzeugs – falls vorhanden – als Ersatz-Werkzeug (RT: für Replacement Tool = engl. Ersatz-Werkzeug); siehe auch TIME2). Eingabebereich: 0 bis 65535 | Schwester-Werkzeug?
TIME1 | Maximale Standzeit des Werkzeugs in Minuten. Diese Funktion ist maschinenabhängig und ist im Maschinenhandbuch beschrieben. Eingabebereich: 0 bis 9999 Minuten | Max. Standzeit?
TIME2 | Maximale Standzeit des Werkzeugs bei einem TOOL CALL in Minuten: Erreicht oder überschreitet die aktuelle Standzeit diesen Wert, so setzt die TNC beim nächsten TOOL CALL das Schwester-Werkzeug ein (siehe auch CUR.TIME). Eingabebereich: 0 bis 9999 Minuten | Maximale Standzeit bei TOOL CALL?
CUR.TIME | Aktuelle Standzeit des Werkzeugs in Minuten: Die TNC zählt die aktuelle Standzeit (CUR.TIME: für CURrent TIME = engl. aktuelle/laufende Zeit) selbsttätig hoch. Für benutzte Werkzeuge können Sie eine Vorgabe eingeben. Eingabebereich: 0 bis 99999 Minuten | Aktuelle Standzeit?
ovRTIME | Maximale erlaubte Standzeitüberschreitung des Werkzeugs in Minuten. Diese Funktion ist maschinenabhängig und ist im Maschinenhandbuch beschrieben. Eingabebereich: 0 bis 99 Minuten | Erlaubte Standzeitüberschreitung?
DOC | Kommentar zum Werkzeug. Eingabebereich: Maximal 16 Zeichen | Werkzeug-Kommentar?
PLC | Information zu diesem Werkzeug, die an die PLC übertragen werden soll. Eingabebereich: Bitcodiert 8 Zeichen | PLC-Status?
PLC-VAL | Wert zu diesem Werkzeug, der an die PLC übertragen werden soll. Eingabebereich: -99999.9999 bis +99999.9999 | PLC-Wert?
PTYP | Werkzeugtyp zur Auswertung in der Platz-Tabelle. Eingabebereich: 0 bis +99 | Werkzeugtyp für Platztabelle?
nmax | Begrenzung der Spindeldrehzahl für dieses Werkzeug. Überwacht wird sowohl der programmierte Wert (Fehlermeldung) als auch eine Drehzahlerhöhung über Potentiometer. Funktion inaktiv: – eingeben. Eingabebereich: 0 bis +99999, Funktion inaktiv: – eingeben | Maximaldrehzahl [1/min]?
liftoff | Festlegung, ob die TNC das Werkzeug bei einem NC-Stopp oder bei Stromausfall in Richtung der positiven Werkzeug-Achse freifahren soll, um Freischneidemarkierungen auf der Kontur zu vermeiden. Wenn Y definiert ist, fährt die TNC das Werkzeug um bis zu 30 mm von der Kontur zurück, wenn diese Funktion im NC-Programm mit M148 aktiviert wurde (siehe Werkzeug bei NC-Stopp automatisch von der Kontur abheben: M148). Eingabe: Y und N | Werkzeug abheben Y/N ?
p1 ... P4 | Maschinenabhängige Funktion: Übergabe eines Wertes an die PLC. Maschinen-Handbuch beachten. Eingabebereich: -99999.9999 bis +99999.9999 | Wert?
kinematic | Maschinenabhängige Funktion: Kinematik-Beschreibung für Winkelfräsköpfe, die additiv zur aktiven Maschinenkinematik von der TNC verrechnet werden. Verfügbare Kinematik-Beschreibungen per Softkey kinematik zuweisen wählen (siehe auch Werkzeugträger-Kinematik). Eingabebereich: Maximal 16 Zeichen | Zusätzl. Kinematikbeschreibung?
T-angle | Spitzenwinkel des Werkzeuges. Wird von den Bohrzyklen 200, 203, 205 und 240 verwendet, um aus der Durchmesser-Eingabe die Tiefe berechnen zu können. Eingabebereich: -180 bis +180° | Spitzenwinkel (Typ DRILL+CSINK)?
Pitch | Gewindesteigung des Werkzeuges. Wird von den Gewindebohrzyklen 206, 207 und 209 verwendet um zu überwachen, ob die im Zyklus definierte Steigung mit der Steigung des Werkzeugs übereinstimmt. Eingabebereich mm: -99999.99990 bis +99999.9999 Eingabebereich inch: -3936.9999 bis +3936.9999 | Gewindesteigung (nur WZ-Typ TAP)?
afc | Regeleinstellung für die adaptive Vorschubregelung AFC, die Sie in der Spalte NAME der Tabelle AFC.TAB festgelegt haben. Regelstrategie per Softkey AFC REGELEIN. zuweisen (3. Softkey-Leiste) übernehmen Eingabebereich: Maximal 10 Zeichen | Regelstrategie?
dr2table | Software-Option 3D-ToolComp: Name der Korrekturwert-Tabelle eingeben, aus der die TNC die winkelabhängigen Delta-Radiuswerte DR2 entnehmen soll Eingabebereich: Maximal 16 Zeichen ohne Datei-Endung | Korrekturwert-Tabelle?
last_use | Datum und Uhrzeit, zu der die TNC das Werkzeug das letzte Mal per TOOL CALL eingewechselt hat Eingabebereich: Maximal 16 Zeichen, Format intern festgelegt: Datum = JJJJ.MM.TT, Uhrzeit = hh.mm | Datum/Uhrzeit letzter Wz.-Aufruf?
aCc | Aktive Ratter-Unterdrückung für das jeweilige Werkzeug aktivieren oder deaktivieren (siehe auch Aktive Ratterunterdrückung ACC (Software-Option)). Eingabebereich: 0 (inaktiv) und 1 (aktiv) | ACC-Status 1=aktiv/0=inaktiv
CR | Maschinenabhängige Funktion: Übergabe eines Wertes an die PLC. Maschinen-Handbuch beachten. Eingabebereich: -99999.9999 bis +99999.9999 | Wert?
CL | Maschinenabhängige Funktion: Übergabe eines Wertes an die PLC. Maschinen-Handbuch beachten. Eingabebereich: -99999.9999 bis +99999.9999 | Wert?


Werkzeug-Tabelle: Werkzeug-Daten für die automatische Werkzeug-Vermessung

Beschreibung der Zyklen zur automatischen Werkzeug-Vermessung: Siehe Benutzer-Handbuch Zyklenprogrammierung

Abk. | Eingaben | Dialog
CUT | Anzahl der Werkzeug-Schneiden (max. 99 Schneiden) Eingabebereich: 0 bis 99 | Anzahl der Schneiden?
LTOL | Zulässige Abweichung von der Werkzeug-Länge L für Verschleiß-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status L). Eingabebereich: 0 bis 0,9999 mm Eingabebereich mm: 0 bis +0.9999 Eingabebereich inch: 0 bis +0.03936 | Verschleiß-Toleranz: Länge?
RTOL | Zulässige Abweichung vom Werkzeug-Radius R für Verschleiß-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status L). Eingabebereich: 0 bis 0,9999 mm Eingabebereich mm: 0 bis +0.9999 Eingabebereich inch: 0 bis +0.03936 | Verschleiß-Toleranz: Radius?
R2TOL | Zulässige Abweichung vom Werkzeug-Radius R2 für Verschleiß-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status L). Eingabebereich: 0 bis 0,9999 mm Eingabebereich mm: 0 bis +0.9999 Eingabebereich inch: 0 bis +0.03936 | Verschleiß-Toleranz: Radius 2?
DIRECT. | Schneid-Richtung des Werkzeugs für Vermessung mit drehendem Werkzeug | Schneid-Richtung (M3 = –)?
TT:R-OFFS | Längenvermessung: Versatz des Werkzeugs zwischen Stylus-Mitte und Werkzeug-Mitte. Voreinstellung: Werkzeug-Radius R (Taste NO ENT erzeugt R) Eingabebereich mm: -99999.9999 bis +99999.9999 Eingabebereich inch: -3936.9999 bis +3936.9999 | Werkzeug-Versatz Radius?
TT:L-OFFS | Radiusvermessung: zusätzlicher Versatz des Werkzeugs zu MP6530 zwischen Stylus-Oberkante und Werkzeug-Unterkante. Voreinstellung: 0 Eingabebereich mm: -99999.9999 bis +99999.9999 Eingabebereich inch: -3936.9999 bis +3936.9999 | Werkzeug-Versatz Länge?
LBREAK | Zulässige Abweichung von der Werkzeug-Länge L für Bruch-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status L). Eingabebereich: 0 bis 0,9999 mm Eingabebereich mm: 0 bis 3.2767 Eingabebereich inch: 0 bis +0.129 | Bruch-Toleranz: Länge?
RBREAK | Zulässige Abweichung vom Werkzeug-Radius R für Bruch-Erkennung. Wird der eingegebene Wert überschritten, sperrt die TNC das Werkzeug (Status L). Eingabebereich: 0 bis 0,9999 mm Eingabebereich mm: 0 bis 0.9999 Eingabebereich inch: 0 bis +0.03936 | Bruch-Toleranz: Radius?


Werkzeug-Tabelle: Werkzeug-Daten für automatische Drehzahl- / Vorschub-Berechnung
Abk. | Eingaben | Dialog
TYP | Werkzeugtyp: Softkey TYP zuweisen (3. Softkey-Leiste); Die TNC blendet ein Fenster ein, in dem Sie den Werkzeugtyp wählen können. Nur die Werkzeug-Typen DRILL und MILL sind momentan mit Funktionen belegt | Werkzeugtyp?
TMAT | Werkzeug-Schneidstoff: Softkey SCHNEIDSTOFF zuweisen (3. Softkey-Leiste); Die TNC blendet ein Fenster ein, in dem Sie den Schneidstoff wählen können Eingabebereich: Maximal 16 Zeichen | Werkzeug-Schneidstoff?
CDT | Schnittdaten-Tabelle: Softkey CDT WÄHLEN (3. Softkey-Leiste); Die TNC blendet ein Fenster ein, in dem Sie die Schnittdaten-Tabelle wählen können Eingabebereich: Maximal 16 Zeichen | Name Schnittdaten-Tabelle?


Werkzeug-Tabelle: Werkzeug-Daten für schaltende Tastsysteme (nur wenn Bit1 in MP7411 = 1 gesetzt ist, siehe auch Benutzer-Handbuch Tastsystem-Zyklen)
Abk. | Eingaben | Dialog
CAL-OF1 | Die TNC legt beim Kalibrieren den Mittenversatz in der Hauptachse eines Tasters in dieser Spalte ab, wenn im Kalibriermenü eine Werkzeugnummer angegeben ist Eingabebereich mm: -99999.9999 bis +99999.9999 Eingabebereich inch: -3936.9999 bis +3936.9999 | Taster-Mittenversatz Hauptachse?
CAL-OF2 | Die TNC legt beim Kalibrieren den Mittenversatz in der Nebenachse eines Tasters in dieser Spalte ab, wenn im Kalibriermenü eine Werkzeugnummer angegeben ist Eingabebereich mm: -99999.9999 bis +99999.9999 Eingabebereich inch: -3936.9999 bis +3936.9999 | Taster-Mittenversatz Nebenachse?
CAL-ANG | Die TNC legt beim Kalibrieren den Spindelwinkel ab, bei dem ein Tasters kalibriert wurde, wenn im Kalibriermenü eine Werkzeugnummer angegeben ist Eingabebereich: -360 bis +360° | Spindelwinkel beim Kalibrieren?


Werkzeug-Tabellen editieren

Die für den Programmlauf gültige Werkzeug-Tabelle hat den Datei-Namen TOOL.T. TOOL T muss im Verzeichnis TNC:\ gespeichert sein und kann nur in einer Maschinen-Betriebsart editiert werden. Werkzeug-Tabellen, die Sie archivieren oder für den Programm-Test einsetzen wollen, geben Sie einen beliebigen anderen Datei-Namen mit der Endung .T .

Werkzeug-Tabelle TOOL.T öffnen:

  • Beliebige Maschinen-Betriebsart wählen

Werkzeug-Tabelle wählen: Softkey WERKZEUG TABELLE drücken

Softkey EDITIEREN auf „EIN“ setzen

Beliebige andere Werkzeug-Tabelle öffnen

  • Betriebsart Programm-Einspeichern/Editieren wählen

Datei-Verwaltung aufrufen

Wahl der Datei-Typen anzeigen: Softkey TYPE WÄHLEN drücken

Dateien vom Typ .T anzeigen: Softkey ZEIGE .T drücken

Wählen Sie eine Datei oder geben einen neuen Dateinamen ein. Bestätigen Sie mit der Taste ENT oder mit dem Softkey WÄHLEN


Editierfunktionen

Wenn Sie eine Werkzeug-Tabelle zum Editieren geöffnet haben, dann können Sie das Hellfeld in der Tabelle mit den Pfeiltasten oder mit den Softkeys auf jede beliebige Position bewegen. An einer beliebigen Position können Sie die gespeicherten Werte überschreiben oder neue Werte eingeben. Zusätzliche Editierfunktionen entnehmen Sie bitte aus nachfolgender Tabelle.

Wenn die TNC nicht alle Positionen in der Werkzeug-Tabelle gleichzeitig anzeigen kann, zeigt der Balken oben in der Tabelle das Symbol „>>“ bzw. „<<“.

Editierfunktionen für Werkzeug-Tabellen | Softkey
Tabellen-Anfang wählen |
Tabellen-Ende wählen |
Vorherige Tabellen-Seite wählen |
Nächste Tabellen-Seite wählen |
Werkzeug-Namen in der Tabelle suchen |
Informationen zum Werkzeug spaltenweise darstellen oder alle Informationen zu einem Werkzeug auf einer Bildschirmseite darstellen |
Sprung zum Zeilenanfang |
Sprung zum Zeilenende |
Hell hinterlegtes Feld kopieren |
Kopiertes Feld einfügen |
Eingebbare Anzahl von Zeilen (Werkzeugen) am Tabellenende anfügen |
Zeile mit indizierter Werkzeug-Nummer hinter der aktuellen Zeile einfügen. Funktion ist nur aktiv, wenn Sie für ein Werkzeug mehrere Korrekturdaten ablegen dürfen (Maschinen-Parameter 7262 ungleich 0). Die TNC fügt hinter dem letzten vorhandenen Index eine Kopie der Werkzeug-Daten ein und erhöht den Index um 1. Anwendung: z.B. Stufenbohrer mit mehreren Längenkorrekturen |
Aktuelle Zeile (Werkzeug) löschen: Die TNC löscht den Inhalt der Tabellenzeile. Ist das zu löschende Werkzeug in der Platz-Tabelle eingetragen, dann hängt das Verhalten dieser Funktion vom Maschinen-Parameter 7263 ab (siehe Liste der allgemeinen Anwenderparameter) |
Platznummern anzeigen / nicht anzeigen |
Alle Werkzeuge anzeigen / nur die Werkzeuge anzeigen, die in der Platz-Tabelle gespeichert sind |
Werkzeug-Tabelle nach Werkzeugnamen des angewählten Werkzeugs durchsuchen. Die TNC zeigt die Liste mit identischen Namen in einem Überblendfenster an, wenn sie ein Werkzeug mit gleichem Namen findet. Mit Doppelklick im Fenster auf das entsprechende Werkzeug, oder wählen mit Pfeiltasten und bestätigen mit der Taste ENT, setzt die TNC das Hellfeld auf das gewählte Werkzeug |
Alle Werkzeugdaten einer Zeile kopieren (geht ebenso mit CTRL+C) |
Zuvor kopierte Werkzeugdaten wieder einfügen (geht ebenso mit CTRL+V) |


Werkzeug-Tabelle verlassen

  • Datei-Verwaltung aufrufen und eine Datei eines anderen Typs wählen, z.B. ein Bearbeitungs-Programm


Hinweise zu Werkzeug-Tabellen

Über den Maschinen-Parameter 7266.x legen Sie fest, welche Angaben in einer Werkzeug-Tabelle eingetragen werden können und in welcher Reihenfolge sie aufgeführt werden.

Sie können einzelne Spalten oder Zeilen einer Werkzeug-Tabelle mit dem Inhalt einer anderen Datei überschreiben. Voraussetzungen:

  • Die Ziel-Datei muss bereits existieren
  • Die zu kopierende Datei darf nur die zu ersetzenden Spalten (Zeilen) enthalten

Einzelne Spalten oder Zeilen kopieren Sie mit dem Softkey FELDER ERSETZEN (siehe Einzelne Datei kopieren).


Werkzeugträger-Kinematik

Um Werkzeugträger-Kinematik verrechnen zu können muss die TNC von Ihrem Maschinenhersteller angepasst werden. Insbesondere muss Ihr Maschinenhersteller entsprechende Trägerkinematiken oder parametrisierbare Werkzeugträger zur Verfügung stellen. Maschinenhanduch beachten!

In der Werkzeug-Tabelle TOOL.T können Sie in der Spalte KINEMATIC bei Bedarf jedem Werkzeug eine zusätzliche Werkzeugträger-Kinematik zuweisen. Im einfachsten Fall kann diese Trägerkinematik den Spannschaft simulieren, um diesen mit in der dynamischen Kollisionsüberwachung zu berücksichtigen. Desweiteren können Sie über diese Funktion auf einfachste Weise Winkelköpfe in die Maschinenkinematik integrieren.

HEIDENHAIN stellt Werkzeugträger-Kinematiken für HEIDENHAIN-Tastsysteme zur Verfügung. Wenden Sie sich bei Bedarf an HEIDENHAIN.
Weitere Informationen:
> Trägerkinematik zuweisen


Trägerkinematik zuweisen

Um einem Werkzeug eine Trägerkinematik zuzuweisen, gehen Sie wie folgt vor:

  • Beliebige Maschinen-Betriebsart wählen

Werkzeug-Tabelle wählen: Softkey WERKZEUG TABELLE drücken

Softkey EDITIEREN auf „EIN“ setzen

Letzte Softkeyleiste wählen

Liste der verfügbaren Kinematik einblenden: Die TNC zeigt alle Trägerkinematiken (.TAB-Dateien) und alle bereits von Ihnen parametrisierten Werkzeugträger-Kinematiken (.CFX-Dateien) an. Zusätzlich sehen Sie im Auswahlfenster eine Vorschau der momentan aktiven Trägerkinematik

Mit Pfeiltasten die gewünschte Kinematik wählen und mit Softkey OK übernehmen

Beachten Sie auch die Hinweise zur Werkzeugträger-Verwaltung in Verbindung mit der dynamischen Kollisionsüberwachung DCM: Siehe Werkzeugträger-Verwaltung (Software-Option DCM)


Einzelne Werkzeugdaten von einem externen PC aus überschreiben

Eine besonders komfortable Möglichkeit, beliebige Werkzeugdaten von einem externen PC aus zu überschreiben, bietet die HEIDENHAIN Datenübertragungs-Software TNCremoNT (siehe Software für Datenübertragung). Dieser Anwendungsfall tritt dann ein, wenn Sie Werkzeugdaten auf einem externen Voreinstellgerät ermitteln und anschließend zur TNC übertragen wollen. Beachten Sie folgende Vorgehensweise:

  • Werkzeug-Tabelle TOOL.T auf der TNC kopieren, z.B. nach TST.T

  • Datenübertragungs-Software TNCremoNT auf dem PC starten

  • Verbindung zur TNC erstellen

  • Kopierte Werkzeug-Tabelle TST.T zum PC übertragen

  • Datei TST.T mit einem beliebigen Texteditor auf die Zeilen und Spalten reduzieren, die geändert werden sollen (siehe Bild). Darauf achten, dass die Kopfzeile nicht verändert wird und die Daten immer bündig in der Spalte stehen. Die Wekzeug-Nummer (Spalte T) muss nicht fortlaufend sein

  • In der TNCremoNT den Menüpunkt <Extras> und <TNCcmd> wählen: TNCcmd wird gestartet

  • Um die Datei TST.T zur TNC zu übertragen, folgenden Befehl eingeben und mit Return ausführen (siehe Bild): put tst.t tool.t /m

Bei der Übrtragung werden nur die Werkzeug-Daten überschrieben, die in der Teildatei (z.B. TST.T) definiert sind. Alle anderen Werkzeug-Daten der Tabelle TOOL.T bleiben unverändert.

Wie Sie Werkzeug-Tabellen über die TNC-Datei-Verwaltung kopieren können in der Datei-Verwaltung beschrieben (siehe Tabelle kopieren).


Platz-Tabelle für Werkzeug-Wechsler

Der Maschinenhersteller passt den Funktionsumfang der Platz-Tabelle an Ihre Maschine an. Maschinenhandbuch beachten!

Für den automatischen Werkzeugwechsel benötigen Sie die Platz-Tabelle TOOL_P.TCH. Die TNC verwaltet mehrere Platz-Tabellen mit beliebigen Dateinamen. Die Platz-Tabelle, die Sie für den Programmlauf aktivieren wollen, wählen Sie in einer Programmlauf-Betriebsart über die Datei-Verwaltung aus (Status M). Um in einer Platztabelle mehrere Magazine verwalten zu können -(Platz-Nummer indizieren), setzen Sie die Maschinen-Parameter 7261.0 bis 7261.3 ungleich 0.

Die TNC kann bis zu 9999 Magazinplätze in der Platz-Tabelle verwalten.

Weitere Informationen:
> Platz-Tabelle in einer Programmlauf-Betriebsart editieren
> Platz-Tabelle in der Betriebsart Programm-Einspeichern / Editieren wählen


Platz-Tabelle in einer Programmlauf-Betriebsart editieren

Werkzeug-Tabelle wählen: Softkey WERKZEUG TABELLE drücken

Platz-Tabelle wählen: Softkey PLATZ TABELLE wählen

Softkey EDITIEREN auf EIN setzen, kann ggf. an Ihrer Maschine nicht nötig bzw. möglich sein: Maschinenhandbuch beachten


Platz-Tabelle in der Betriebsart Programm-Einspeichern / Editieren wählen

Datei-Verwaltung aufrufen

Wahl der Datei-Typen anzeigen: Softkey TYPE WÄHLEN drücken

Dateien vom Typ .TCH anzeigen: Softkey TCH FILES drücken (zweite Softkey-Leiste)

Wählen Sie eine Datei oder geben einen neuen Dateinamen ein. Bestätigen Sie mit der Taste ENT oder mit dem Softkey WÄHLEN

Abk. | Eingaben | Dialog
P | Platz-Nummer des Werkzeugs im Werkzeug-Magazin | -
T | Werkzeug-Nummer | Werkzeug-Nummer?
ST | Werkzeug ist Sonderwerkzeug (ST: für Special Tool = engl. Sonderwerkzeug); wenn Ihr Sonderwerkzeug Plätze vor und hinter seinem Platz blockiert, dann sperren Sie den entsprechenden Platz in der Spalte L (Status L) | Sonderwerkzeug?
F | Werkzeug immer auf gleichen Platz im Magazin zurückwechseln (F: für Fixed = engl. festgelegt) | Festplatz? Ja = ENT / Nein = NO ENT
L | Platz sperren (L: für Locked = engl. gesperrt, siehe auch Spalte ST) | Platz gesperrt Ja = ENT / Nein = NO ENT
PLC | Information, die zu diesem Werkzeug-Platz an die PLC übertragen werden soll | PLC-Status?
TNAMe | Anzeige des Werkzeugnamen aus TOOL.T | -
DOC | Anzeige des Kommentar zum Werkzeug aus TOOL.T | -
ptyp | Werkzeugtyp. Funktion wird vom Maschinenhersteller definiert. Maschinendokumentation beachten | Werkzeugtyp für Platztabelle?
p1 ... p5 | Funktion wird vom Maschinenhersteller definiert. Maschinendokumentation beachten | Wert?
rsv | Platz-Reservierung für Flächenmagazin | Platz reserv.: Ja=ENT/Nein = NOENT
locked_above | Flächenmagazin: Platz oberhalb sperren | Platz oben sperren?
locked_below | Flächenmagazin: Platz unterhalb sperren | Platz unten sperren?
locked_left | Flächenmagazin: Platz links sperren | Platz links sperren?
locked_right | Flächenmagazin: Platz rechts sperren | Platz rechts sperren?
S1 ... S5 | Funktion wird vom Maschinenhersteller definiert. Maschinendokumentation beachten | Wert?
Editierfunktionen für Platz-Tabellen | Softkey
Tabellen-Anfang wählen |
Tabellen-Ende wählen |
Vorherige Tabellen-Seite wählen |
Nächste Tabellen-Seite wählen |
Platz-Tabelle rücksetzen |
Spalte Werkzeug-Nummer T rücksetzen |
Sprung zum Anfang der nächsten Zeile |
Spalte rücksetzen in Grundzustand. Gilt nur für Spalten RSV, LOCKED_ABOVE, LOCKED_BELOW, LOCKED_LEFT und LOCKED_RIGHT |
Alle Werkzeugdaten einer Zeile kopieren (geht ebenso mit CTRL+C) |
Zuvor kopierte Werkzeugdaten wieder einfügen (geht ebenso mit CTRL+V) |


Werkzeug-Daten aufrufen

Einen Werkzeug-Aufruf TOOL CALL im Bearbeitungs-Programm programmieren Sie mit folgenden Angaben:

  • Werkzeug-Aufruf mit Taste TOOL CALL wählen

Werkzeug-Nummer: Nummer oder Name des Werkzeugs eingeben. Das Werkzeug haben Sie zuvor in einem g99-Satz oder in der Werkzeug-Tabelle festgelegt. Per Softkey Werkzeug-Name auf Nameneingabe umschalten. Einen Werkzeug-Namen setzt die TNC automatisch in Anführungszeichen. Namen beziehen sich auf einen Eintrag in der aktiven Werkzeug-Tabelle TOOL.T. Per Softkey QS können Sie auch einen String-Parameter definieren, der den Namen des zu rufenden Werkzeugs beinhaltet. Um ein Werkzeug mit anderen Korrekturwerten aufzurufen, geben Sie den in der Werkzeug-Tabelle definierten Index nach einem Dezimalpunkt mit ein. Per Softkey wählen können Sie ein Fenster einblenden, über das Sie ein in der Werkzeug-Tabelle TOOL.T definiertes Werkzeug direkt ohne Eingabe der Nummer oder des Namens wählen können: Siehe auch Werkzeugdaten im Auswahlfenster editieren

Spindelachse parallel X/Y/Z: Werkzeugachse eingeben

Spindeldrehzahl S: Spindeldrehzahl direkt eingeben, oder von der TNC berechnen lassen, wenn Sie mit Schnittdaten-Tabellen arbeiten. Drücken Sie dazu den Softkey S AUTOM. BERECHNEN. Die TNC begrenzt die Spindeldrehzahl auf den maximalen Wert, der in Maschinen-Parameter 3515 festgelegt ist. Alternativ können Sie eine Schnittgeschwindigkeit Vc [m/min] definieren. Drücken Sie dazu den Softkey VC

Vorschub F: Vorschub direkt eingeben, oder von der TNC berechnen lassen, wenn Sie mit Schnittdaten-Tabellen arbeiten. Drücken Sie dazu den Softkey F AUTOM. BERECHNEN. Die TNC begrenzt den Vorschub auf den maximalen Vorschub der „langsamsten Achse“ (in Maschinen-Parameter 1010 festgelegt). F wirkt solange, bis Sie in einem Positioniersatz oder in einem TOOL CALL-Satz einen neuen Vorschub programmieren

Aufmaß Werkzeug-Länge DL: Delta-Wert für die Werkzeug-Länge

Aufmaß Werkzeug-Radius DR: Delta-Wert für den Werkzeug-Radius

Aufmaß Werkzeug-Radius DR2: Delta-Wert für den Werkzeug-Radius 2

Werkzeugdaten im Auswahlfenster editieren

Im Überblendfenster zur Werkzeugauswahl können Sie die angezeigten Werkzeugdaten auch editieren:

  • Per Pfeiltasten die Zeile und anschließend die Spalte des zu editierenden Wertes wählen: Der hellblaue Rahmen kennzeichnet das editierbare Feld

  • Softkey editieren auf ein stellen, gewünschten Wert eingeben und mit Taste ENT bestätigen

  • Bei Bedarf weitere Spalten wählen und zuvor beschriebene Vorgehensweise erneut durchführen

  • Gewähltes Werkzeug mit Taste ENT ins Programm übernehmen
Nach Werkzeugnamen im Auswahlfenster suchen

Im Überblendfenster zur Werkzeugauswahl können Sie nach Werkzeugnamen suchen:

  • Softkey suchen drücken

  • Gewünschten Werkzeugnamen eingeben und mit Taste ENT bestätigen: Die TNC setzt das Hellfeld auf die nächste Zeile, in der der gesuchte Werkzeugname vorkommt

Beispiel: Werkzeug-Aufruf

Aufgerufen wird Werkzeug Nummer 5 in der Werkzeugachse Z mit der Spindeldrehzahl 2500 U/min und einem Vorschub von 350 mm/min. Das Aufmaß für die Werkzeug-Länge und den Werkzeug-Radius 2 beträgt 0,2 bzw. 0,05 mm, das Untermaß für den Werkzeug-Radius 1 mm.

N20 t 5.2 G17 s2500 dl+0.2 dr-1

Das D vor L und R steht für Delta-Wert.

Weitere Informationen:
> Vorauswahl bei Werkzeug-Tabellen


Vorauswahl bei Werkzeug-Tabellen

Wenn Sie Werkzeug-Tabellen einsetzen, dann treffen Sie mit einem g51-Satz eine Vorauswahl für das nächste einzusetzende Werkzeug. Dazu geben Sie die Werkzeug-Nummer bzw. einen Q-Parameter ein, oder einen Werkzeug-Namen in Anführungszeichen.


Werkzeugwechsel

Der Werkzeugwechsel ist eine maschinenabhängige Funktion. Maschinenhandbuch beachten!
Weitere Informationen:
> Werkzeugwechsel-Position
> Manueller Werkzeugwechsel
> Automatischer Werkzeugwechsel
> Automatischer Werkzeugwechsel beim Überschreiten der Standzeit: M101
> Voraussetzungen für Standard-NC-Sätze mit Radiuskorrektur G41, G42


Werkzeugwechsel-Position

Die Werkzeugwechsel-Position muss kollisionsfrei anfahrbar sein. Mit den Zusatzfunktionen M91 und M92 können Sie eine maschinenfeste Wechselposition anfahren. Wenn Sie vor dem ersten Werkzeug-Aufruf T 0 programmieren, dann verfährt die TNC den Einspannschaft in der Spindelachse auf eine Position, die von der Werkzeug-Länge unabhängig ist.


Manueller Werkzeugwechsel

Vor einem manuellen Werkzeugwechsel wird die Spindel gestoppt und das Werkzeug auf die Werkzeugwechsel-Position gefahren:

  • Werkzeugwechsel-Position programmiert anfahren

  • Programmlauf unterbrechen, siehe Bearbeitung unterbrechen

  • Werkzeug wechseln

  • Programmlauf fortsetzen, siehe Programmlauf nach einer Unterbrechung fortsetzen


Automatischer Werkzeugwechsel

Beim automatischen Werkzeugwechsel wird der Programmlauf nicht unterbrochen. Bei einem Werkzeug-Aufruf mit T wechselt die TNC das Werkzeug aus dem Werkzeug-Magazin ein.


Automatischer Werkzeugwechsel beim Überschreiten der Standzeit: M101

M101 ist eine maschinenabhängige Funktion. Maschinenhandbuch beachten!

Einen automatischen Werkzeugwechsel kann die TNC nur dann ausführen, wenn der Werkzeugwechsel über ein NC-Makro ausgeführt wird, Maschinenhandbuch beachten!

Wenn die Standzeit eines Werkzeugs TIME2 erreicht, wechselt die TNC automatisch ein Schwester-Werkzeug ein. Dazu aktivieren Sie am Programm-Anfang die Zusatzfunktion M101. Die Wirkung von M101 können Sie mit M102, durch Neuanwahl des Programms oder durch Neuanwahl eines anderen NC-Satzes mit GOTO aufheben. Maschinenhersteller den Beim Erreichen der TIME1 setzt die TNC lediglich einen internen Merker, der über die PLC ausgewertet werden kann (Maschinenhandbuch beachen). Die Wirkungsweise der maximal erlaubten Standzeitüberschreitung OVRTIME legt ebenfalls der Maschinenhersteller fest, auch hier Maschinenhandbuch beachten.

Die Nummer des einzuwechslenden Schwester-Werkzeuges tragen Sie in der Spalte RT der Werkzeug-Tabelle ein. Ist dort keine Werkzeug-Nummer eingetragen, dann wechselt die TNC ein Werkzeug ein, das denselben Namen hat wie das momentan aktive. Die TNC startet die Suche nach dem Schwester-Werkzeug immer am Anfang der Werkzeug-Tabelle, wechselt also immer das erste Werkzeug ein, das vom Tabellenanfang gesehen zu finden ist.

Der automatische Werkzeugwechsel erfolgt

  • nach dem nächsten NC-Satz nach Ablauf der Standzeit, oder
  • ca. eine Minute plus einem NC-Satz nach Ablauf der Standzeit (Berechnung erfolgt für 100%-Potentiometerstellung)

Läuft die Standzeit bei aktivem M120 (Look Ahead) ab, so wechselt die TNC das Werkzeug erst nach dem Satz ein, in dem Sie die Radiuskorrektur aufgehoben haben.

Die TNC führt einen automatischen Werkzeugwechsel nicht aus, wenn sie gerade einen Zyklus abarbeitet. Ausnahme: Bei den Musterzyklen 220 und 221 (Lochkreis und Lochfläche) führt die TNC einen automatischen Werkzeugwechsel bei Bedarf zwischen zwei Bearbeitungspositionen aus.

Ein automatischer Werkzeugwechsel mit aktiver Werkzeug-Radiuskorrektur ist grundsätzlich nicht möglich.

Achtung Gefahr für Werkzeug und Werkstück!

Den automatischen Werkzeugwechsel mit M102 ausschalten, wenn Sie mit Sonderwerkzeugen (z.B. Scheibenfräser) arbeiten, da die TNC das Werkzeug zunächst immer in Werkzeug-Achsrichtung vom Werkstück wegfährt.


Voraussetzungen für Standard-NC-Sätze mit Radiuskorrektur G41, G42

Der Radius des Schwester-Werkzeugs muss gleich dem Radius des ursprünglich eingesetzten Werkzeugs sein. Sind die Radien nicht gleich, zeigt die TNC einen Meldetext an und wechselt das Werkzeug nicht ein.

Bei NC-Programmen ohne Radiuskorrektur prüft die TNC den Werkzeug-Radius des Schwester-Werkzeuges beim Wechsel nicht.


Werkzeug-Einsatzprüfung

Die Funktion Werkzeug-Einsatzprüfung muss vom Maschinenhersteller freigegeben werden. Beachten Sie Ihr Maschinenhandbuch.

Um eine Werkzeug-Einsatzprüfung durchführen zu können, müssen folgende Voraussetzungen erfüllt sein:

  • Bit2 des Maschinen-Parameters 7246 muss =1 gesetzt sein
  • Bearbeitungszeit ermitteln in der Betriebsart Programm-Test muss aktiv sein
  • Das zu prüfende Klartext-Dialog-Programm muss in der Betriebsart Programm-Test vollständig simuliert worden sein

Ist keine gültige Werkzeug-Einsatzdatei vorhanden und die Bearbeitungszeit-Ermittlung deaktiviert, dann erstellt die TNC eine Werkzeug-Einsatzdatei mit einer Default-Zeit von 10s für jeden Werkzeug-Einsatz.
Weitere Informationen:
> Einstellungen für die Werkzeug-Einsatzprüfung
> Werkzeug-Einsatzprüfung anwenden


Einstellungen für die Werkzeug-Einsatzprüfung

Um das Verhalten der Werkzeug-Einsatzprüfung beeinflussen zu können, steht ein Formular zur Verfügung, das Sie wie folgt aufrufen können:

  • Betriebsart Programmlauf Einzelsatz oder Satzfolge wählen

  • Softkey Werkzeug-Einsatz drücken: Die TNC zeigt eine Softkey-Leiste mit Funktionen zur Einsatz-Prüfung an

  • Softkey EINSTELLUNGEN drücken: Die TNC zeigt das Formular mit den zur Verfügung stehen Einstellmöglichkeiten an

    Folgende Einstellungen können Sie getrennt für Programmlauf Satzfolge / Einzelsatz und den Programm-Test vornehmen:

  • Einstellung keine Werkzeug-Einsatzdatei erzeugen:
    Die TNC erstellt keine Werkzeug-Einsatzdatei
  • Einstellung Werkzeug-Einsatzdatei einmalig erzeugen:
    Die TNC erzeugt eine Werkzeug-Einsatzdatei einmalig mit dem nächsten NC-Start bzw. Start der Simulation. Anschließend aktiviert die TNC automatisch den Modus Keine Werkzeug-Einsatzdatei erzeugen um zu verhindern, dass mit weiteren NC-Starts die Einsatzdatei überschrieben wird
  • Einstellung Werkzeug-Einsatzdatei bei Bedarf bzw. Änderungen neu erzeugen (Grundeinstellung):
    Die TNC erzeugt eine Werkzeug-Einsatzdatei mit jedem NC-Start bzw. mit jedem Start des Programm-Tests. Diese Einstellung stellt sicher, dass die TNC nach Programm-Änderungen die Werkzeug-Einsatzdatei auch neu erzeugt


Werkzeug-Einsatzprüfung anwenden

Über die Softkeys werkzeug einsatz und werkzeug einsatzprüfung können sie vor dem Start eines Programmes in der Betriebsart Abarbeiten prüfen, ob die im angewählten Programm verwendeten Werkzeuge noch über genügend Reststandzeit verfügen. Die TNC vergleicht hierbei die Standzeit-Istwerte aus der Werkzeug-Tabelle, mit den Sollwerten aus der Werkzeug-Einsatzdatei.

Die TNC zeigt, nachdem Sie den Softkey werkzeug einsatzprüfung betätigt haben, das Ergebnis der Einsatzprüfung in einem Überblendfenster an. Überblendfenster mit Taste CE schließen.

Die TNC speichert die Werkzeug-Einsatzzeiten in einer separaten Datei mit der Endung pgmname.H.T.DEP. (siehe MOD-Einstellung Abhängige Dateien ändern). Die erzeugte Werkzeug-Einsatzdatei enthält folgende Informationen:

Spalte Bedeutung

TOKEN
  • TOOL: Werkzeug-Einsatzzeit pro TOOL CALL. Die Einträge sind in chronologischer Reihenfolge aufgelistet
  • TTOTAL: Gesamte Einsatzzeit eines Werkzeugs
  • STOTAL: Aufruf eines Unterprogramms (einschließlich Zyklen); die Einträge sind in chronologischer Reihenfolge aufgelistet
  • timetotal: Gesamtbearbeitungszeit des NC-Programms wird in der Spalte wtime eingetragen. In der Spalte PATH hinterlegt die TNC den Pfadnamen des entsprechenden NC-Programms. Die Spalte TIME enthält die Summe aller TIME-Eintrage (nur mit Spindel-Ein und ohne Eilgangbewegungen). Alle übrigen Spalten setzt die TNC auf 0
  • toolfile: In der Spalte PATH hinterlegt die TNC den Pfadnamen der Werkzeug-Tabelle, mit der Sie den Programm-Test durchgeführt haben. Dadurch kann die TNC bei der eigentlichen Werkzeug-Einsatzprüfung festellen, ob Sie den Programm-Test mit TOOL.T durchgeführt haben

TNR

Werkzeug-Nummer (–1: noch kein Werkzeug eingewechselt)

IDX

Werkzeug-Index

NAME

Werkzeug-Name aus der Werkzeug-Tabelle

TIME

Werkzeugeinsatz-Zeit in Sekunden (Vorschub-Zeit)

WTIME

Werkzeugeinsatz-Zeit in Sekunden (Gesamteinsatzzeit von Werkzeugwechsel zu Werkzeugwechsel)

RAD

Werkzeug-Radius R + Aufmaß Werkzeug-Radius DR aus der Werkzeug-Tabelle. Einheit ist 0.1 µm

BLOCK

Satznummer, in dem der TOOL CALL-Satz programmiert wurde

PATH
  • TOKEN = TOOL: Pfadname des aktiven Haupt- bzw. Unterprogramms
  • TOKEN = STOTAL: Pfadname des Unterprogramms

T

Werkzeug-Nummer mit Werkzeug-Index

OVRMAX

Während der Bearbeitung maximal aufgetretener Vorschub-Override. Beim Programm-Test trägt die TNC hier den Wert 100 (%) ein

OVRMIN

Während der Bearbeitung minimal aufgetretener Vorschub-Override. Beim Programm-Test trägt die TNC hier den Wert -1 ein

NAMEPROG
  • 0: Werkzeug-Nummer ist programmiert
  • 1: Werkzeug-Name ist programmiert

Bei der Werkzeug-Einsatzprüfung einer Paletten-Datei stehen zwei Möglichkeiten zur Verfügung:

  • Hellfeld steht in der Paletten-Datei auf einem Paletten-Eintrag:
    Die TNC führt für die Werkzeug-Einsatzprüfung für die komplette Palette durch
  • Hellfeld steht in der Paletten-Datei auf einem Programm-Eintrag:
    Die TNC führt nur für das angewählte Programm die Werkzeug-Einsatzprüfung durch


Werkzeug-Verwaltung (Software-Option)

Die Werkzeug-Verwaltung ist eine maschinenabhängige Funktion, die teilweise oder auch vollständig deaktiviert sein kann. Den genauen Funktionsumfang legt Ihr Maschinenhersteller fest, Maschinenhandbuch beachten!

    Über die Werkzeug-Verwaltung kann Ihr Maschinenhersteller verschiedenste Funktionen in Bezug auf das Werkzeughandling zur Verfügung stellen. Beispiele:

  • Übersichtliche und wenn von Ihnen gewünscht, anpassbare Darstellung der Werkzeugdaten in Formularen
  • Beliebige Bezeichnung der einzelnen Werkzeugdaten in der neuen Tabellenansicht
  • Gemischte Darstellung von Daten aus der Werkzeug-Tabelle und der Platz-Tabelle
  • Schnelle Sortiermöglichkeit aller Werkzeugdaten durch Mouse-Klick
  • Verwendung von grafischen Hilfsmitteln, z.B. farbliche Unterscheidungen von Werkzeug- oder Magazinstatus
  • Programmspezifische Bestückungsliste aller Werkzeuge zur Verfügung stellen
  • Programmspezifische Einsatzfolge aller Werkzeuge zur Verfügung stellen
  • Kopieren und Einfügen aller zu einem Werkzeug gehörenden Werkzeugdaten
  • Grafische Darstellung des Werkzeug-Typs in der Tabellenansicht und in der Detailansicht zur besseren Übersicht der verfügbaren Werkzeugtypen
Weitere Informationen:
> Werkzeug-Verwaltung aufrufen
> Werkzeug-Verwaltung bedienen
> Werkzeugdaten importieren
> Werkzeugdaten exportieren
> Markierte Werkzeugdaten löschen


Werkzeug-Verwaltung aufrufen

Der Aufruf der Werkzeug-Verwaltung kann sich von der nachfolgend beschriebenen Art und Weise unterscheiden, Maschinenhandbuch beachten!

Werkzeug-Tabelle wählen: Softkey WERKZEUG TABELLE drücken

Softkey-Leiste weiterschalten

Softkey werkzeug-verwaltung wählen: Die TNC wechselt in die neue Tabellenansicht (siehe Bild rechts)

    In der neuen Ansicht stellt die TNC alle Werkzeuginformationen in den folgenden vier Karteikartenreitern dar:

  • Werkzeuge:
    Werkzeugspezifische Informationen
  • Plätze:
    Platzspezifische Informationen
  • Bestückungsliste:
    Liste aller Werkzeuge des NC-Programms, das in der Programmlauf-Betriebsart angewählt ist (nur wenn Sie bereits eine Werkzeug-Einsatzdatei erstellt haben, siehe Werkzeug-Einsatzprüfung). Die TNC zeigt in der Bestückungsliste fehlende Werkzeuge in der Spalte WZ-INFO mit dem rot markierten Dialog nicht definiert an
  • T-Einsatzfolge:
    Liste der Reihenfolge aller Werkzeuge, die in dem Programm eingwechselt werden, das in der Programmlauf-Betriebsart angewählt ist (nur wenn Sie bereits eine Werkzeug-Einsatzdatei erstellt haben, siehe Werkzeug-Einsatzprüfung). Die TNC zeigt in der Einsatzfolge-Liste fehlende Werkzeuge in der Spalte WZ-INFO mit dem rot markierten Dialog nicht definiert an

Editieren können Sie die Werkzeugdaten ausschließlich in der Formularansicht, die Sie durch Betätigen des Softkeys FORMULAR werkzeug oder der Taste ENT für das jeweils hell hinterlegte Werkzeug aktivieren können.


Werkzeug-Verwaltung bedienen

Die Werkzeug-Verwaltung ist sowohl mit der Mouse als auch per Tasten und Softkeys bedienbar:

Editierfunktionen der Werkzeug-Verwaltung Softkey

Tabellen-Anfang wählen

Tabellen-Ende wählen

Vorherige Tabellen-Seite wählen

Nächste Tabellen-Seite wählen

Formularansicht zum in der Tabelle hell hinterlegten Werkzeug oder Magazinpatz aufrufen. Alternative Funktion: Taste ENT drücken

Reiter weiterschalten: Werkzeuge, Plätze, Bestückungsliste, T-Einsatzfolge

Reiter zurückschalten: Werkzeuge, Plätze, Bestückungsliste, T-Einsatzfolge

Suchfunktion: In der Suchfunktion können Sie die zu durchsuchende Spalte und anschließend den Suchbegriff über eine Liste oder durch Eingabe des Suchbegriffes wählen

Werkzeugdaten importieren: Importieren von Werkzeugdaten im CSV-Format (siehe Werkzeugdaten importieren)

Werkzeugdaten exportieren: Exportieren von Werkzeugdaten im CSV-Format (siehe Werkzeugdaten exportieren)

Markierte Werkzeugdaten löschen: Siehe Markierte Werkzeugdaten löschen

Ansicht aktualisieren, um bei inkonsistentem Datenbestand eine Neuinitialisierung durchzuführen

Spalte Programmierte Werkzeuge anzeigen (wenn Reiter Plätze aktiv ist)

    Einstellungen definieren:

  • SPALTE SORTIEREN aktiv:
    Mous-Klick auf Spaltenkopf sortiert den Spalteninhalt
  • SPALTE SCHIEBEN aktiv:
    Spalte lässt sich per Drag+Drop verschieben

Manuell durchgeführte Einstellungen (Spalten verschoben) wieder in den ursprünglichen Zustand rücksetzen

    Folgende Funktionen können Sie zusätzlich per Mouse-Bedienung durchführen:

  • Sortierfunktion
    Durch Klicken in eine Spalte des Tabellenkopfs sortiert die TNC die Daten in aufsteigender oder absteigender Reihenfolge (abhängig von der aktivierten Einstellung)
  • Spalten verschieben
    Durch Klicken in eine Spalte des Tabellenkopfes und anschließendes Verschieben mit gedrückt gehaltener Mouse-Taste, können Sie die Spalten in der von Ihnen bevorzugten Reihenfolge anordnen. Die TNC speichert momentan die Spaltenfolge beim Verlassen der Werkzeug-Verwaltung nicht ab (abhängig von der aktivierten Einstellung)
  • Zusatzinformationen in der Formularansicht anzeigen
    Tipptexte zeigt die TNC dann an, wenn Sie den Softkey EDITIEREN AUS/EIN auf EIN gestellt haben, den Mouse-Cursor über ein aktives Eingabefeld bewegen und eine Sekunde stehen lassen

Bei aktiver Formularansicht stehen folgende Funktionen zur Verfügung:

Editierfunktionen Formularansicht | Softkey
Werkzeug-Daten des vorheriges Werkzeugs wählen |
Werkzeug-Daten des nächstes Werkzeugs wählen |
Vorherigen Werkzeug-Index wählen (nur aktiv, wenn Indizierung aktiv ist) |
Nächsten Werkzeug-Index wählen (nur aktiv, wenn Indizierung aktiv ist) |
Änderungen verwerfen, die Sie seit dem Auruf des Formulares durchgeführt haben (Undo-Funktion) |
Neues Werkzeug einfügen (Softkey-Leiste 2) |
Werkzeug löschen (Softkey-Leiste 2) |
Werkzeug-Index einfügen (Softkey-Leiste 2) |
Werkzeug-Index löschen (Softkey-Leiste 2) |
Werkzeugdaten des angewählten Werkzeugs kopieren (Softkey-Leiste 2) |
Kopierte Werkzeugdaten in das angewählte Werkzeug einfügen (Softkey-Leiste 2) |
Selektieren/deselektieren von Check-Boxen (z.B. bei TL-Zeile) |
Öffnen von Auswahllisten bei Combo-Boxen (z.B. bei AFC-Zeile) |


Werkzeugdaten importieren

Über diese Funktion können Sie auf einfache Weise Werkzeugdaten importieren, die Sie z.B. extern auf einem Voreinstellgerät vermessen haben. Die zu importierende Datei muss dem CSV-Format (comma separated value) entsprechen. Das Dateiformat CSV beschreibt den Aufbau einer Textdatei zum Austausch einfach strukturierter Daten. Demnach muss die Importdatei wie folgt aufgebaut sein:

  • Zeile 1:
    In der ersten Zeile sind die jeweiligen Spaltennamen zu definieren, in denen die in den nachfolgenden Zeilen definierten Daten landen sollen. Die Spaltennamen sind durch Komma zu trennen.
  • Weitere Zeilen:
    Alle weiteren Zeilen enthalten die Daten, die Sie in die Werkzeug-Tabelle importieren wollen. Die Reihenfolge der Daten muss zu der Reihenfolge der in Zeile 1 aufgeführten Spaltennamen passen. Die Daten sind durch Komma zu trennen, Dezimalzahlen sind mit einem Dezimalpunkt zu definieren.

Gehen Sie beim Importieren wie folgt vor:

  • Zu importierende Werkzeug-Tabelle auf die Festplatte der TNC in das Verzeichnis TNC:\systems\tooltab kopieren

  • Erweiterte Werkzeug-Verwaltung starten

  • In der Werkzeug-Verwaltung den Softkey WERKZEUG IMPORT wählen: Die TNC zeigt ein Überblendfenster mit den CSV-Dateien, die im Verzeichnis TNC:\systems\tooltab gespeichert sind

  • Mit den Pfeiltasten oder per Mouse die zu importierende Datei wählen, mit Taste ENT bestätigen: Die TNC zeigt in einem Überblendfenster den Inhalt der CSV-Datei

  • Importvorgang mit Softkeys OK und AUSFÜHREN starten.

  • Enthält die zu importierende Werkzeug-Datendatei Werkzeugnummern die nicht in der internen Werkeug-Tabelle verfügbar sind, dann dann blendet die TNC den Softkey TABELLE AUFFÜLLEN ein. Betätigen Sie den Softkey, dann fügt die TNC so lange leere Datensätze ein, bis die höheren Werkzeugnummern einlesbar sind.
  • Die zu importierende CSV-Datei muss im Verzeichnis TNC:\system\tooltab gespeichert sein.
  • Wenn Sie Werkzeugdaten zu Werkzeugen importieren, deren Nummer in der Platz-Tabelle eingetragen ist, gibt die TNC eine Fehlermeldung aus. Sie können dann entscheiden, ob Sie diesen Datensatz überspringen oder ein neues Werkzeug einfügen wollen. Die TNC fügt einen neues Werkzeug in die erste leere Zeile der Werkzeug-Tabelle ein.
  • Darauf achten, dass die Spaltenbezeichnungen korrekt angegeben sind (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten).
  • Sie können beliebige Werkzeugdaten importieren, der jeweilige Datensatz muss nicht alle Spalten (bzw. Daten) der Werkzeug-Tabelle enthalten.
  • Die Reihenfolge der Spaltennamen kann beliebig sein, die Daten müssen in dazu passender Reihenfolge definiert sein.
Beispiel-Importdatei:
T,L,R,DL,DR | Zeile 1 mit Spaltennamen
4,125.995,7.995,0,0 | Zeile 2 mit Werkzeugdaten
9,25.06,12.01,0,0 | Zeile 3 mit Werkzeugdaten
28,196.981,35,0,0 | Zeile 4 mit Werkzeugdaten


Werkzeugdaten exportieren

Über diese Funktion können Sie auf einfache Weise Werkzeugdaten exportieren, um diese z.B. in die Werkzeugdatenbank Ihres CAM-Systems einzulesen. Die TNC speichert die exportierte Datei im CSV-Format (comma separated value). Das Dateiformat CSV beschreibt den Aufbau einer Textdatei zum Austausch einfach strukturierter Daten. Die Exportdatei ist wie folgt aufgebaut:

  • Zeile 1:
    In der ersten Zeile speichert die TNC die Spaltennamen aller der jeweiligen Werkzeugdaten zu definieren. Die Spaltennamen sind durch Komma getrennt.
  • Weitere Zeilen:
    Alle weiteren Zeilen enthalten die Daten der Werkzeuge, die Sie exportiert haben. Die Reihenfolge der Daten passt zur Reihenfolge der in Zeile 1 aufgeführten Spaltennamen. Die Daten sind durch Komma getrennt, Dezimalzahlen gibt die TNC mit einem Dezimalpunkt aus.

Gehen Sie beim Exportieren wie folgt vor:

  • In der Werkzeug-Verwaltung die Werkzeugdaten die Sie exportieren wollen mit den Pfeiltasten oder mit der Mouse markieren

  • Den Softkey WERKZEUG EXPORT wählen, die TNC zeigt ein Überblendfenster an: Namen für die CSV-Datei angeben, mit Taste ENT bestätigen

  • Exportvorgang mit Softkeys OK und AUSFÜHREN starten: Die TNC zeigt in einem Überblendfenster den Status des Exportvorgangs an

  • Exportvorgang mit Taste oder Softkey END beenden

Die TNC speichert die exportierte CSV-Datei grundsätzlich im Verzeichnis TNC:\system\tooltab ab.


Markierte Werkzeugdaten löschen

Mit dieser Funktion können Sie auf einfache Weise Werkzeugdaten löschen, wenn Sie diese nicht mehr benötigen.

Gehen Sie beim Löschen wie folgt vor:

  • In der Werkzeug-Verwaltung die Werkzeugdaten die Sie löschen wollen mit den Pfeiltasten oder mit der Mouse markieren

  • Den Softkey markierte WERKZEUGe löschen wählen, die TNC zeigt ein Überblendfenster an, in dem die zu löschenden Werkzeugdaten aufgeführt sind

  • Löschvorgang mit Softkey START starten: Die TNC zeigt in einem Überblendfenster den Status des Löschvorgangs an

  • Löschvorgang mit Taste oder Softkey END beenden

  • Die TNC löscht alle Daten aller selektierten Werkzeuge. Sicherstellen, dass Sie die Werkzeugdaten nicht mehr benötigen, da keine Undo-Funktion zur Verfügung steht.
  • Werkzeugdaten von Werkzeugen, die noch in der Platz-Tabelle gespeichert sind, können Sie nicht löschen. Werkzeug zunächst aus dem Magazin entladen.


Werk eug-Korrektur

Weitere Informationen:
> Einführung
> Werkzeug-Längenkorrektur
> Werkzeug-Radiuskorrektur


Einführung

Die TNC korrigiert die Werkzeugbahn um den Korrekturwert für Werkzeug-Länge in der Spindelachse und um den Werkzeug-Radius in der Bearbeitungsebene.

Wenn Sie das Bearbeitungs-Programm direkt an der TNC erstellen, ist die Werkzeug-Radiuskorrektur nur in der Bearbeitungsebene wirksam. Die TNC berücksichtigt dabei bis zu fünf Achsen incl. der Drehachsen.


Werkzeug-Längenkorrektur

Die Werkzeug-Korrektur für die Länge wirkt, sobald Sie ein Werkzeug aufrufen und in der Spindelachse verfahren. Sie wird aufgehoben, sobald ein Werkzeug mit der Länge L=0 aufgerufen wird.

Achtung Kollisionsgefahr!

Wenn Sie eine Längenkorrektur mit positivem Wert mit T0 aufheben, verringert sich der Abstand vom Werkzeug zu Werkstück.

Nach einem Werkzeug-Aufruf T ändert sich der programmierte Weg des Werkzeugs in der Spindelachse um die Längendifferenz zwischen altem und neuem Werkzeug.

Bei der Längenkorrektur werden Delta-Werte sowohl aus dem T-Satz als auch aus der Werkzeug-Tabelle berücksichtigt.

Korrekturwert = L + DLTOOL CALL + DLTAB mit

L: | Werkzeug-Länge L aus g99-Satz oder Werkzeug-Tabelle
DL TOOL CALL: | Aufmaß DL für Länge aus T0-Satz (von der Positionsanzeige nicht berücksichtigt)
DL TAB: | Aufmaß DL für Länge aus der Werkzeug-Tabelle


Werkzeug-Radiuskorrektur

Der Programm-Satz für eine Werkzeug-Bewegung enthält

  • g41 oder g42 für eine Radiuskorrektur
  • g43 oder g44, für eine Radiuskorrektur bei einer achsparallelen Verfahrbewegung
  • g40, wenn keine Radiuskorrektur ausgeführt werden soll

Die Radiuskorrektur wirkt, sobald ein Werkzeug aufgerufen und mit einem Geradensatz in der Bearbeitungsebene mit g41 oder g42 verfahren wird.

Die TNC hebt die Radiuskorrektur auf, wenn Sie:

  • einen Geradensatz mit g40 programmieren. Enthält der Geradensatz lediglich eine Koordinate in der Werkzeug-Achsrichtung, dann hebt die TNC die Radiuskorrektur zwar auf, fährt die Korrektur in der Bearbeitungsebene jedoch nicht heraus.

  • einen PGM CALL programmieren

  • ein neues Programm mit PGM MGT anwählen

Bei der Radiuskorrektur berücksichtigt die TNC Delta-Werte sowohl aus dem t-Satz als auch aus der Werkzeug-Tabelle berücksichtigt:

Korrekturwert = R + DRTOOL CALL + DRTAB mit

R: | Werkzeug-Radius R aus g99-Satz oder Werkzeug-Tabelle
DR TOOL CALL: | Aufmaß DR für Radius aus t-Satz (von der Positionsanzeige nicht berücksichtigt)
DR TAB: | Aufmaß DR für Radius aus der Werkzeug-Tabelle
Weitere Informationen:
> Bahnbewegungen ohne Radiuskorrektur: G40
> Bahnbewegungen mit Radiuskorrektur: G42 und G41
> Eingabe der Radiuskorrektur
> Radiuskorrektur: Ecken bearbeiten
> Ecken ohne Radiuskorrektur bearbeiten


Bahnbewegungen ohne Radiuskorrektur: G40

Das Werkzeug verfährt in der Bearbeitungsebene mit seinem Mittelpunkt auf der programmierten Bahn, bzw. auf die programmierten Koordinaten.

Anwendung: Bohren, Vorpositionieren.


Bahnbewegungen mit Radiuskorrektur: G42 und G41
g43 | Das Werkzeug verfährt rechts von der Kontur
g42 | Das Werkzeug verfährt links von der Kontur

Der Werkzeug-Mittelpunkt hat dabei den Abstand des Werkzeug-Radius von der programmierten Kontur. „Rechts“ und „links“ bezeichnet die Lage des Werkzeugs in Verfahrrichtung entlang der Werkstück-Kontur. Siehe Bilder.

Zwischen zwei Programm-Sätzen mit unterschiedlicher Radiuskorrektur g43 und g42 muss mindestens ein Verfahrsatz in der Bearbeitungsebene ohne Radiuskorrektur (also mit g40) stehen.

Die TNC aktiviert eine Radiuskorrektur zum Ende des Satzes, in dem Sie das erste Mal die Korrektur programmiert haben.

Sie können die Radiuskorrektur auch für Zusatzachsen der Bearbeitungsebene aktivieren. Programmieren Sie die Zusatzachsen auch in jedem nachfolgenden Satz, da die TNC ansonsten die Radiuskorrektur wieder in der Hauptachse durchführt.

Beim ersten Satz mit Radiuskorrektur g42/G41 und beim Aufheben mit g40 positioniert die TNC das Werkzeug immer senkrecht auf den programmierten Start- oder Endpunkt. Positionieren Sie das Werkzeug so vor dem ersten Konturpunkt bzw. hinter dem letzten Konturpunkt, dass die Kontur nicht beschädigt wird.


Eingabe der Radiuskorrektur

Die Radiuskorrektur geben Sie in einen G01-Satz ein:

Werkzeugbewegung links von der programmierten Kontur: G41-Funktion wählen, oder

Werkzeugbewegung rechts von der programmierten Kontur: G42-Funktion wählen, oder

Werkzeugbewegung ohne Radiuskorrektur bzw. Radiuskorrektur aufheben: G40-Funktion wählen

Satz beenden: Taste END drücken


Radiuskorrektur: Ecken bearbeiten

  • Außenecken:
    Wenn Sie eine Radiuskorrektur programmiert haben, dann führt die TNC das Werkzeug an den Außenecken entweder auf einem Übergangskreis oder auf einem Spline (Auswahl über MP7680). Falls nötig, reduziert die TNC den Vorschub an den Außenecken, zum Beispiel bei großen Richtungswechseln.

  • Innenecken:
    An Innenecken errechnet die TNC den Schnittpunkt der Bahnen, auf denen der Werkzeug-Mittelpunkt korrigiert verfährt. Von diesem Punkt an verfährt das Werkzeug am nächsten Konturelement entlang. Dadurch wird das Werkstück an den Innenecken nicht beschädigt. Daraus ergibt sich, dass der Werkzeug-Radius für eine bestimmte Kontur nicht beliebig groß gewählt werden darf.

Achtung Gefahr für Werkstück!

Legen Sie den Start- oder Endpunkt bei einer Innenbearbeitung nicht auf einen Kontur-Eckpunkt, da sonst die Kontur beschädigt werden kann.


Ecken ohne Radiuskorrektur bearbeiten

Ohne Radiuskorrektur können Sie Werkzeugbahn und Vorschub an Werkstück-Ecken mit der Zusatzfunktion M90 beeinflussen, siehe Ecken verschleifen: M90.


Programmieren: Konturen programmieren

Weitere Informationen:
> Werkzeug-Bewegungen
> Grundlagen zu den Bahnfunktionen
> Kontur anfahren und verlassen
> Bahnbewegungen - rechtwinklige Koordinaten
> Bahnbewegungen – Polarkoordinaten


Werkzeug-Bewegungen

Weitere Informationen:
> Bahnfunktionen
> Zusatzfunktionen M
> Unterprogramme und Programmteil-Wiederholungen
> Programmieren mit Q-Parametern


Bahnfunktionen

Eine Werkstück-Kontur setzt sich gewöhnlich aus mehreren Konturelementen wie Geraden und Kreisbögen zusammen. Mit den Bahnfunktionen programmieren Sie die Werkzeugbewegungen für Geraden und Kreisbögen.


Zusatzfunktionen M

    Mit den Zusatzfunktionen der TNC steuern Sie

  • den Programmlauf, z.B. eine Unterbrechung des Programmlaufs
  • die Maschinenfunktionen, wie das Ein- und Ausschalten der Spindeldrehung und des Kühlmittels
  • das Bahnverhalten des Werkzeugs


Unterprogramme und Programmteil-Wiederholungen

Bearbeitungs-Schritte, die sich wiederholen, geben Sie nur einmal als Unterprogramm oder Programmteil-Wiederholung ein. Wenn Sie einen Teil des Programms nur unter bestimmten Bedingungen ausführen lassen möchten, dann legen Sie diese Programmschritte ebenfalls in einem Unterprogramm fest. Zusätzlich kann ein Bearbeitungs-Programm ein weiteres Programm aufrufen und ausführen lassen.

Das Programmieren mit Unterprogrammen und Programmteil-Wiederholungen ist in Kapitel 8 beschrieben.


Programmieren mit Q-Parametern

Im Bearbeitungs-Programm stehen Q-Parameter stellvertretend für Zahlenwerte: Einem Q-Parameter wird an anderer Stelle ein Zahlenwert zugeordnet. Mit Q-Parametern können Sie mathematische Funktionen programmieren, die den Programmlauf steuern oder die eine Kontur beschreiben.

Zusätzlich können Sie mit Hilfe der Q-Parameter-Programmierung Messungen mit dem Tastsystem während des Programmlaufs ausführen.

Das Programmieren mit Q-Parametern ist in Kapitel 9 beschrieben.


Grundlagen zu den Bahnfunktionen

Weitere Informationen:
> Werkzeugbewegung für eine Bearbeitung programmieren


Werkzeugbewegung für eine Bearbeitung programmieren

Wenn Sie ein Bearbeitungs-Programm erstellen, programmieren Sie nacheinander die Bahnfunktionen für die einzelnen Elemente der Werkstück-Kontur. Dazu geben Sie gewöhnlich die Koordinaten für die Endpunkte der Konturelemente aus der Maßzeichnung ein. Aus diesen Koordinaten-Angaben, den Werkzeug-Daten und der Radiuskorrektur ermittelt die TNC den tatsächlichen Verfahrweg des Werkzeugs.

Die TNC fährt gleichzeitig alle Maschinenachsen, die Sie in dem Programm-Satz einer Bahnfunktion programmiert haben.

Weitere Informationen:
> Bewegungen parallel zu den Maschinenachsen
> Bewegungen in den Hauptebenen
> Dreidimensionale Bewegung
> Eingabe von mehr als drei Koordinaten
> Kreise und Kreisbögen
> Drehsinn DR bei Kreisbewegungen
> Radiuskorrektur
> Vorpositionieren


Bewegungen parallel zu den Maschinenachsen

Der Programm-Satz enthält eine Koordinaten-Angabe: Die TNC fährt das Werkzeug parallel zur programmierten Maschinenachse.

Je nach Konstruktion Ihrer Maschine bewegt sich beim Abarbeiten entweder das Werkzeug oder der Maschinentisch mit dem aufgespannten Werkstück. Beim Programmieren der Bahnbewegung tun Sie grundsätzlich so, als ob sich das Werkzeug bewegt.

Beispiel:
N50 G00 X+100 *
n50 | Satznummer
g00 | Bahnfunktion „Gerade im Eilgang“
X+100 | Koordinaten des Endpunkts

Das Werkzeug behält die Y- und Z-Koordinaten bei und fährt auf die Position X=100. Siehe Bild.


Bewegungen in den Hauptebenen

Der Programm-Satz enthält zwei Koordinaten-Angaben: Die TNC fährt das Werkzeug in der programmierten Ebene.

Beispiel:
N50 G00 X+70 Y+50 *

Das Werkzeug behält die Z-Koordinate bei und fährt in der XY-Ebene auf die Position X=70, Y=50. Siehe Bild


Dreidimensionale Bewegung

Der Programm-Satz enthält drei Koordinaten-Angaben: Die TNC fährt das Werkzeug räumlich auf die programmierte Position.

Beispiel:
N50 G01 X+80 Y+0 Z-10 *


Eingabe von mehr als drei Koordinaten

Die TNC kann bis zu 5 Achsen gleichzeitig steuern (Software-Option). Bei einer Bearbeitung mit 5 Achsen bewegen sich beispielsweise 3 Linear- und 2 Drehachsen gleichzeitig.

Das Bearbeitungs-Programm für eine solche Bearbeitung liefert gewöhnlich ein CAM-System und kann nicht an der Maschine erstellt werden.

Beispiel:
n123 g01 g40 x+20 y+10 z+2 a+15 c+6 f100 m3 *


Kreise und Kreisbögen

Bei Kreisbewegungen fährt die TNC zwei Maschinenachsen gleichzeitig: Das Werkzeug bewegt sich relativ zum Werkstück auf einer Kreisbahn. Für Kreisbewegungen können Sie einen Kreismittelpunkt CC eingeben.

Mit den Bahnfunktionen für Kreisbögen programmieren Sie Kreise in den Hauptebenen: Die Hauptebene ist beim Werkzeug-Aufruf TOOL CALL mit dem Festlegen der Spindelachse zu definieren:

Spindelachse | Hauptebene
(g17) | XY, auch UV, XV, UY
(g18) | ZX, auch WU, ZU, WX
(g19) | YZ, auch VW, YW, VZ

Kreise, die nicht parallel zur Hauptebene liegen, programmieren Sie auch mit der Funktion „Bearbeitungsebene schwenken“ (siehe Benutzer-Handbuch Zyklen, Zyklus 19, BEARBEITUNGSEBENE), oder mit Q-Parametern (siehe Prinzip und Funktionsübersicht).


Drehsinn DR bei Kreisbewegungen

Für Kreisbewegungen ohne tangentialen Übergang zu anderen Konturelementen geben Sie den Drehsinn wie folgt ein:

Drehung im Uhrzeigersinn: G02/G12
Drehung gegen den Uhrzeigersinn: G03/G13


Radiuskorrektur

Die Radiuskorrektur muss in dem Satz stehen, mit dem Sie das erste Konturelement anfahren. Die Radiuskorrektur dürfen Sie nicht in einem Satz für eine Kreisbahn aktivieren. Programmieren Sie diese zuvor in einem Geraden-Satz (siehe Bahnbewegungen - rechtwinklige Koordinaten).


Vorpositionieren

Positionieren Sie das Werkzeug zu Beginn eines Bearbeitungs-Programms so vor, dass eine Beschädigung von Werkzeug und Werkstück ausgeschlossen ist.


Kontur anfahren und verlassen

Weitere Informationen:
> Start- und Endpunkt
> Tangential An- und Wegfahren


Start- und Endpunkt

Das Werkzeug fährt vom Startpunkt aus den ersten Konturpunkt an. Anforderungen an den Startpunkt:

  • Ohne Radiuskorrektur programmiert
  • Kollisionsfrei anfahrbar
  • Nahe am ersten Konturpunkt

Beispiel

Bild rechts oben: Wenn Sie den Startpunkt im dunkelgrauen Bereich festlegen, dann wird die Kontur beim Anfahren des ersten Konturpunkts beschädigt.

Weitere Informationen:
> Erster Konturpunkt
> Startpunkt in der Spindelachse anfahren
> Endpunkt
> Gemeinsamer Start- und Endpunkt


Erster Konturpunkt

Für die Werkzeugbewegung auf den ersten Konturpunkt programmieren Sie eine Radiuskorrektur.


Startpunkt in der Spindelachse anfahren

Beim Anfahren des Startpunkts muss das Werkzeug in der Spindelachse auf Arbeitstiefe fahren. Bei Kollisionsgefahr den Startpunkt in der Spindelachse separat anfahren.

NC-Beispielsätze
N30 G00 G40 X+20 Y+30 *
N40 Z-10 *


Endpunkt

Voraussetzungen für die Wahl des Endpunkts:

  • Kollisionsfrei anfahrbar
  • Nahe am letzten Konturpunkt
  • Konturbeschädigung ausschließen: Der optimale Endpunkt liegt in der Verlängerung der Werkzeugbahn für die Bearbeitung des letzten Konturelements

Beispiel

Bild rechts oben: Wenn Sie den Endpunkt im dunkelgrauen Bereich festlegen, dann wird die Kontur beim Anfahren des Endpunkts beschädigt.

Endpunkt in der Spindelachse verlassen:

Beim Verlassen des Endpunkts programmieren Sie die Spindelachse separat. Siehe Bild rechts Mitte.

NC-Beispielsätze
N50 G00 G40 X+60 Y+70 *
N60 Z+250 *


Gemeinsamer Start- und Endpunkt

Für einen gemeinsamen Start- und Endpunkt programmieren Sie keine Radiuskorrektur.

Konturbeschädigung ausschließen: Der optimale Startpunkt liegt zwischen den Verlängerungen der Werkzeugbahnen für die Bearbeitung des ersten und letzten Konturelements.

Beispiel

Bild rechts oben: Wenn Sie den Endpunkt im schraffierten Bereich festlegen, dann wird die Kontur beim Anfahren des ersten Konturpunktes beschädigt.


Tangential An- und Wegfahren

Mit G26 (Bild rechts oben) können Sie an das Werkstück tangential anfahren und mit G27 (Bild rechts unten) vom Werkstück tangential wegfahren. Dadurch vermeiden Sie Freischneidemarkierungen.

Weitere Informationen:
> Start- und Endpunkt
> Anfahren
> Wegfahren


Start- und Endpunkt

Start- und Endpunkt liegen nahe am ersten bzw. letzten Konturpunkt außerhalb des Werkstücks und sind ohne Radiuskorrektur zu programmieren.


Anfahren

  • G26 nach dem Satz eingeben, in dem der erste Konturpunkt programmiert ist: Das ist der erste Satz mit Radiuskorrektur G41/G42


Wegfahren

  • G27 nach dem Satz eingeben, in dem der letzte Konturpunkt programmiert ist: Das ist der letzte Satz mit Radiuskorrektur G41/G42

Den Radius für G26 und G27 müssen Sie so wählen, dass die TNC die Kreisbahn zwischen Startpunkt und erstem Konturpunkt sowie letztem Konturpunkt und Endpunkt ausführen kann.

NC-Beispielsätze
n50 g00 g40 g90 x-30 y+50 * | Startpunkt
n60 g01 g41 x+0 y+50 f350 * | Erster Konturpunkt
n70 g26 r5 * | Tangential anfahren mir Radius R = 5 mm
. . . |
konturelemente programmieren |
. . . | Letzter Konturpunkt
n210 g27 r5 * | Tangential Wegfahren mit Radius R = 5 mm
n220 g00 g40 x-30 y+50 * | Endpunkt


Bahnbewegungen - rechtwinklige Koordinaten

Weitere Informationen:
> Übersicht der Bahnfunktionen
> Gerade im Eilgang G00 Gerade mit Vorschub G01 F
> Fase zwischen zwei Geraden einfügen
> Ecken-Runden G25
> Kreismittelpunkt I, J
> Kreisbahn C um Kreismittelpunkt CC
> Kreisbahn G02/G03/G05 mit festgelegtem Radius
> Kreisbahn G06 mit tangentialem Anschluss
> Beispiel: Geradenbewegung und Fasen kartesisch
> Beispiel: Kreisbewegung kartesisch
> Beispiel: Vollkreis kartesisch


Übersicht der Bahnfunktionen

Funktion | Bahnfunktionstaste | Werkzeug-Bewegung | Erforderliche Eingaben | Seite
Gerade L engl.: Line |  | Gerade | Koordinaten des Geraden-Endpunkts | Gerade im Eilgang G00 Gerade mit Vorschub G01 F
Fase: CHF engl.: CHamFer |  | Fase zwischen zwei Geraden | Fasenlänge | Fase zwischen zwei Geraden einfügen
Kreismittelpunkt CC; engl.: Circle Center |  | Keine | Koordinaten des Kreismittelpunkts bzw. Pols | Kreismittelpunkt I, J
Kreisbogen C engl.: Circle |  | Kreisbahn um Kreismittelpunkt CC zum Kreisbogen-Endpunkt | Koordinaten des Kreis-Endpunkts, Drehrichtung | Kreisbahn C um Kreismittelpunkt CC
Kreisbogen CR engl.: Circle by Radius |  | Kreisbahn mit bestimmten Radius | Koordinaten des Kreis-Endpunkts, Kreisradius, Drehrichtung | Kreisbahn G02/G03/G05 mit festgelegtem Radius
Kreisbogen CT engl.: Circle Tangential |  | Kreisbahn mit tangentialem Anschluss an vorheriges und nachfolgendes Konturelement | Koordinaten des Kreis-Endpunkts | Kreisbahn G06 mit tangentialem Anschluss
Ecken-Runden RND engl.: RouNDing of Corner |  | Kreisbahn mit tangentialem Anschluss an vorheriges und nachfolgendes Konturelement | Eckenradius R | Ecken-Runden G25


Gerade im Eilgang G00 Gerade mit Vorschub G01 F

Die TNC fährt das Werkzeug auf einer Geraden von seiner aktuellen Position zum Endpunkt der Geraden. Der Startpunkt ist der Endpunkt des vorangegangenen Satzes.

Koordinaten des Endpunkts der Geraden, falls nötig

Radiuskorrektur G41/G42/G40

Vorschub F

Zusatz-Funktion M
NC-Beispielsätze
N70 G01 G41 X+10 Y+40 F200 M3 *
N80 G91 X+20 Y-15 *
N90 G90 X+60 G91 Y-10 *
Weitere Informationen:
> Ist-Position übernehmen


Ist-Position übernehmen

Einen Geraden-Satz (G01-Satz) können Sie auch mit der Taste „Ist-Position-übernehmen“ generieren:

  • Fahren Sie das Werkzeug in der Betriebsart Manueller Betrieb auf die Position, die übernommen werden soll

  • Bildschirm-Anzeige auf Programm-Einspeichern/Editieren wechseln

  • Programm-Satz wählen, hinter dem der L-Satz eingefügt werden soll

Taste „Ist-Position-übernehmen“ drücken: Die TNC generiert einen L-Satz mit den Koordinaten der Ist-Position

Die Anzahl der Achsen, die die TNC im G01-Satz speichert, legen Sie über die MOD-Funktion fest (siehe Achsauswahl für G01-Satz-Generierung).


Fase zwischen zwei Geraden einfügen

Konturecken, die durch den Schnitt zweier Geraden entstehen, können Sie mit einer Fase versehen.

  • In den Geradensätzen vor und nach dem g24-Satz programmieren Sie jeweils beide Koordinaten der Ebene, in der die Fase ausgeführt wird
  • Die Radiuskorrektur vor und nach g24-Satz muss gleich sein
  • Die Fase muss mit dem aktuellen Werkzeug ausführbar sein

Fasen-Abschnitt: Länge der Fase, falls nötig:

Vorschub F (wirkt nur im g24-Satz)

NC-Beispielsätze
N70 G01 G41 X+0 Y+30 F300 M3 *
N80 X+40 G91 Y+5 *
N90 G24 R12 F250 *
N100 G91 X+5 G90 Y+0 *

Eine Kontur nicht mit einem g24-Satz beginnen.

Eine Fase wird nur in der Bearbeitungsebene ausgeführt.

Der von der Fase abgeschnittene Eckpunkt wird nicht angefahren.

Ein im CHF-Satz programmierter Vorschub wirkt nur in diesem CHF-Satz. Danach ist wieder der vor dem g24-Satz programmierte Vorschub gültig.


Ecken-Runden G25

Die Funktion g25 rundet Kontur-Ecken ab.

Das Werkzeug fährt auf einer Kreisbahn, die sowohl an das vorhergegangene als auch an das nachfolgende Konturelement tangential anschließt.

Der Rundungskreis muss mit dem aufgerufenen Werkzeug ausführbar sein.

Rundungs-Radius: Radius des Kreisbogens, falls nötig:

Vorschub F (wirkt nur im g25-Satz)

NC-Beispielsätze
5 L X+10 Y+40 RL F300 M3
6 L X+40 Y+25
7 RND R5 F100
8 L X+10 Y+5

Das vorhergehende und nachfolgende Konturelement sollte beide Koordinaten der Ebene enthalten, in der das Ecken-Runden ausgeführt wird. Wenn Sie die Kontur ohne Werkzeug-Radiuskorrektur bearbeiten, dann müssen Sie beide Koordinaten der Bearbeitungsebene programmieren.

Der Eckpunkt wird nicht angefahren.

Ein im g25-Satz programmierter Vorschub wirkt nur in diesem g25-Satz. Danach ist wieder der vor dem g25-Satz programmierte Vorschub gültig.

Ein RND-Satz lässt sich auch zum weichen Anfahren an die Kontur nutzen.


Kreismittelpunkt I, J

Den Kreismittelpunkt legen Sie für Kreisbahnen fest, die Sie mit den Funktionen G02, G03 oder G05 programmieren. Dazu

  • geben Sie die rechtwinkligen Koordinaten des Kreismittelpunkts in der Bearbeitungsebene ein oder
  • übernehmen die zuletzt programmierte Position oder

  • übernehmen die Koordinaten mit der Taste „Ist-Positionen-übernehmen“

Koordinaten für den Kreismittelpunkt eingeben oder Um die zuletzt programmierte Position zu übernehmen: G29 eingeben

NC-Beispielsätze
N50 I+25 J+25 *

oder

N10 G00 G40 X+25 Y+25 *
N20 G29 *

Die Programmzeilen 10 und 11 beziehen sich nicht auf das Bild.

Gültigkeit

Der Kreismittelpunkt bleibt solange festgelegt, bis Sie einen neuen Kreismittelpunkt programmieren. Einen Kreismittelpunkt können Sie auch für die Zusatzachsen U, V und W festlegen.

Kreismittelpunkt inkremental eingeben

Eine inkremental eingegebene Koordinate für den Kreismittelpunkt bezieht sich immer auf die zuletzt programmierte Werkzeug-Position.

Mit CC kennzeichnen Sie eine Position als Kreismittelpunkt: Das Werkzeug fährt nicht auf diese Position.

Der Kreismittelpunkt ist gleichzeitig Pol für Polarkoordinaten.

Wenn Sie Parallelachsen als Pol definieren wollen, drücken Sie zuerst die Taste I (J) auf der ASCII-Tastatur und anschließend die orangene Achstaste der entsprechenden Parallelachse.


Kreisbahn C um Kreismittelpunkt CC

Legen Sie den Kreismittelpunkt I, J fest, bevor Sie die Kreisbahn programmieren. Die zuletzt programmierte Werkzeug-Position vor der Kreisbahn der Startpunkt der Kreisbahn.

Drehsinn
  • Im Uhrzeigersinn: G02
  • Im Gegen-Uhrzeigersinn: G03
  • Ohne Drehrichtungs-Angabe: G05. Die TNC fährt die Kreisbahn mit der zuletzt programmierten Drehrichtung

  • Werkzeug auf den Startpunkt der Kreisbahn fahren

Koordinaten des Kreismittelpunkts eingeben

Koordinaten des Kreisbogen-Endpunkts eingeben, falls nötig:

Vorschub FZusatz-Funktion M

Die TNC verfährt Kreisbewegungen normalerweise in der aktiven Bearbeitungsebene. Wenn Sie Kreise programmieren, die nicht in der aktiven Bearbeitungseben liegen, z.B. g2 Z... X... bei Werkzeug-Achse Z, und gleichzeitig diese Bewegung rotieren, dann verfährt die TNC einen Raumkreis, also einen Kreis in 3 Achsen.

NC-Beispielsätze
N50 I+25 J+25 *
N60 G01 G42 X+45 Y+25 F200 M3 *
N70 G03 X+45 Y+25 *

Vollkreis

Programmieren Sie für den Endpunkt die gleichen Koordinaten wie für den Startpunkt.

Start- und Endpunkt der Kreisbewegung müssen auf der Kreisbahn liegen.

Eingabe-Toleranz: bis 0.016 mm (über MP7431 wählbar).

Kleinstmöglicher Kreis, den die TNC verfahren kann: 0.016 mm.


Kreisbahn G02/G03/G05 mit festgelegtem Radius

Das Werkzeug fährt auf einer Kreisbahn mit dem Radius R.

Drehsinn
  • Im Uhrzeigersinn: G02
  • Im Gegen-Uhrzeigersinn: G03
  • Ohne Drehrichtungs-Angabe: G05. Die TNC fährt die Kreisbahn mit der zuletzt programmierten Drehrichtung

Koordinaten des Kreisbogen-Endpunkts

Radius R Achtung: Das Vorzeichen legt die Größe des Kreisbogens fest!

Zusatz-Funktion MVorschub F

Vollkreis

Für einen Vollkreis programmieren Sie zwei Kreissätze hintereinander:

Der Endpunkt des ersten Halbkreises ist Startpunkt des zweiten. Endpunkt des zweiten Halbkreises ist Startpunkt des ersten.

Weitere Informationen:
> Zentriwinkel CCA und Kreisbogen-Radius R


Zentriwinkel CCA und Kreisbogen-Radius R

Startpunkt und Endpunkt auf der Kontur lassen sich durch vier verschiedene Kreisbögen mit gleichem Radius miteinander verbinden:

Kleinerer Kreisbogen: CCA<180°
Radius hat positives Vorzeichen R>0

Größerer Kreisbogen: CCA>180°
Radius hat negatives Vorzeichen R<0

Über den Drehsinn legen Sie fest, ob der Kreisbogen außen (konvex) oder nach innen (konkav) gewölbt ist:

Konvex: Drehsinn G02 (mit Radiuskorrektur G41)

Konkav: Drehsinn G03 (mit Radiuskorrektur G41)

NC-Beispielsätze
N100 G01 G41 X+40 Y+40 F200 M3 *
N110 G02 X+70 Y+40 R+20 * (Bogen 1)

oder

N110 G03 X+70 Y+40 R+20 * (Bogen 2)

oder

N110 G02 X+70 Y+40 R-20 * (Bogen 3)

oder

N110 G03 X+70 Y+40 R-20 * (Bogen 4)

Der Abstand von Start- und Endpunkt des Kreisdurchmessers darf nicht größer als der Kreisdurchmesser sein.

Der maximale, direkt eingebbare Radius beträgt 99,9999 m, über Q-Parameter-Programmierung 210 m.

Winkelachsen A, B und C werden unterstützt.


Kreisbahn G06 mit tangentialem Anschluss

Das Werkzeug fährt auf einem Kreisbogen, der tangential an das zuvor programmierte Konturelement anschließt.

Ein Übergang ist „tangential“, wenn am Schnittpunkt der Konturelemente kein Knick- oder Eckpunkt entsteht, die Konturelemente also stetig ineinander übergehen.

Das Konturelement, an das der Kreisbogen tangential anschließt, programmieren Sie direkt vor dem G06-Satz. Dazu sind mindestens zwei Positionier-Sätze erforderlich

Koordinaten des Kreisbogen-Endpunkts, falls nötig:

Vorschub F

Zusatz-Funktion M
NC-Beispielsätze
N70 G01 G41 X+0 Y+25 F300 M3 *
N80 X+25 Y+30 *
N90 G06 X+45 Y+20 *
G01 Y+0 *

Der G06-Satz und das zuvor programmierte Konturelement sollten beide Koordinaten der Ebene enthalten, in der der Kreisbogen ausgeführt wird!


Beispiel: Geradenbewegung und Fasen kartesisch

%linear g71 * |
n10 g30 g17 x+0 y+0 z-20 * | Rohteil-Definition für grafische Simulation der Bearbeitung
n20 g31 g90 x+100 y+100 z+0 * |
n40 t1 g17 s4000 * | Werkzeug-Aufruf mit Spindelachse und Spindeldrehzahl
n50 g00 g40 g90 z+250 * | Werkzeug freifahren in der Spindelachse mit Eilgang
n60 x-10 y-10 * | Werkzeug vorpositionieren
n70 g01 z-5 f1000 m3 * | Auf Bearbeitungstiefe fahren mit Vorschub F = 1000 mm/min
n80 g01 g41 x+5 y+5 f300 * | Kontur an Punkt 1 anfahren, Radiuskorrektur G41 aktivieren
n90 g26 r5 f150 * | Tangentiales Anfahren
n100 y+95 * | Punkt 2 anfahren
n110 x+95 * | Punkt 3: erste Gerade für Ecke 3
n120 g24 r10 * | Fase mit Länge 10 mm programmieren
n130 y+5 * | Punkt 4: zweite Gerade für Ecke 3, erste Gerade für Ecke 4
n140 g24 r20 * | Fase mit Länge 20 mm programmieren
n150 x+5 * | Letzten Konturpunkt 1 anfahren, zweite Gerade für Ecke 4
n160 g27 r5 f500 * | Tangentiales Wegfahren
n170 g40 x-20 y-20 f1000 * | Freifahren in der Bearbeitungsebene, Radiuskorrektur aufheben
n180 g00 z+250 m2 * | Werkzeug freifahren, Programm-Ende
n99999999 %linear g71 * |


Beispiel: Kreisbewegung kartesisch

%circular g71 * |
n10 g30 g17 x+0 y+0 z-20 * | Rohteil-Definition für grafische Simulation der Bearbeitung
n20 g31 g90 x+100 y+100 z+0 * |
n40 t1 g17 s4000 * | Werkzeug-Aufruf mit Spindelachse und Spindeldrehzahl
n50 g00 g40 g90 z+250 * | Werkzeug freifahren in der Spindelachse mit Eilgang
n60 x-10 y-10 * | Werkzeug vorpositionieren
n70 g01 z-5 f1000 m3 * | Auf Bearbeitungstiefe fahren mit Vorschub F = 1000 mm/min
n80 g01 g41 x+5 y+5 f300 * | Kontur an Punkt 1 anfahren, Radiuskorrektur G41 aktivieren
n90 g26 r5 f150 * | Tangentiales Anfahren
n100 y+85 * | Punkt 2: erste Gerade für Ecke 2
n110 g25 r10 * | Radius mit R = 10 mm einfügen, Vorschub: 150 mm/min
n120 x+30 * | Punkt 3 anfahren: Startpunkt des Kreises
n130 g02 x+70 y+95 r+30 * | Punkt 4 anfahren: Endpunkt des Kreises mit G02, Radius 30 mm
n140 g01 x+95 * | Punkt 5 anfahren
n150 y+40 * | Punkt 6 anfahren
n160 g06 x+40 y+5 * | Punkt 7 anfahren: Endpunkt des Kreises, Kreisbogen mit tangentialem Anschluss an Punkt 6, TNC berechnet den Radius selbst
n170 g01 x+5 * | Letzten Konturpunkt 1 anfahren
n180 g27 r5 f500 * | Kontur verlassen auf einer Kreisbahn mit tangentialem Anschluss
n190 g40 x-20 y-20 f1000 * | Freifahren in der Bearbeitungsebene, Radiuskorrektur aufheben
n200 g00 z+250 m2 * | Werkzeug freifahren in der Werkzeug-Achse, Programm-Ende
n99999999 %circular g71 * |


Beispiel: Vollkreis kartesisch

%c-cc g71 * |
n10 g30 g17 x+0 y+0 z-20 * | Rohteil-Definition
n20 g31 g90 x+100 y+100 z+0 * |
n40 t1 g17 s3150 * | Werkzeug-Aufruf
n50 g00 g40 g90 z+250 * | Werkzeug freifahren
n60 i+50 j+50 * | Kreismittelpunkt definieren
n70 x-40 y+50 * | Werkzeug vorpositionieren
n80 g01 z-5 f1000 m3 * | Auf Bearbeitungstiefe fahren
n90 g41 x+0 y+50 f300 * | Kreisstartpunkt anfahren, Radiuskorrektur G41
n100 g26 r5 f150 * | Tangentiales Anfahren
n110 g02 x+0 * | Kreisendpunkt (=Kreisstartpunkt) anfahren
n120 g27 r5 f500 * | Tangentiales Wegfahren
n130 g01 g40 x-40 y-50 f1000 * | Freifahren in der Bearbeitungsebene, Radiuskorrektur aufheben
n140 g00 z+250 m2 * | Werkzeug freifahren in der Werkzeug-Achse, Programm-Ende
n99999999 %c-cc g71 * |


Bahnbewegungen – Polarkoordinaten

Weitere Informationen:
> Übersicht
> Polarkoordinaten-Ursprung: Pol I, J
> Gerade im Eilgang G10 Gerade mit Vorschub G11 F
> Kreisbahn G12/G13/G15 um Pol I, J
> Kreisbahn G16 mit tangentialem Anschluss
> Schraubenlinie (Helix)
> Beispiel: Geradenbewegung polar
> Beispiel: Helix


Übersicht

Mit Polarkoordinaten legen Sie eine Position über einen Winkel H und einen Abstand R zu einem zuvor definierten Pol I, J fest.

    Polarkoordinaten setzen Sie vorteilhaft ein bei:

  • Positionen auf Kreisbögen
  • Werkstück-Zeichnungen mit Winkelangaben, z.B. bei Lochkreisen
Weitere Informationen:
> Übersicht der Bahnfunktion mit Polarkoordinaten


Übersicht der Bahnfunktion mit Polarkoordinaten
Funktion | Bahnfunktionstaste | Werkzeug-Bewegung | Erforderliche Eingaben | Seite
Gerade G10, G11 | + | Gerade | Polarradius, Polarwinkel des Geraden-Endpunkts | Gerade im Eilgang G10 Gerade mit Vorschub G11 F
Kreisbogen G12, G13 | + | Kreisbahn um Kreismittelpunkt/ Pol zum Kreisbogen-Endpunkt | Polarwinkel des Kreisendpunkts | Kreisbahn G12/G13/G15 um Pol I, J
Kreisbogen G15 | + | Kreisbahn entsprechend aktiver Drehrichtung | Polarwinkel des Kreisendpunkts | Kreisbahn G12/G13/G15 um Pol I, J
Kreisbogen G16 | + | Kreisbahn mit tangentialem Anschluss an vorheriges Konturelement | Polarradius, Polarwinkel des Kreisendpunkts | Kreisbahn G16 mit tangentialem Anschluss
Schraubenlinie (Helix) | + | Überlagerung einer Kreisbahn mit einer Geraden | Polarradius, Polarwinkel des Kreisendpunkts, Koordinate des Endpunkts in der Werkzeugachse | Schraubenlinie (Helix)


Polarkoordinaten-Ursprung: Pol I, J

Den Pol CC können Sie an beliebigen Stellen im Bearbeitungs-Programm festlegen, bevor Sie Positionen durch Polarkoordinaten angeben. Gehen Sie beim Festlegen des Pols vor, wie beim Programmieren des Kreismittelpunkts.

Koordinaten: Rechtwinklige Koordinaten für den Pol eingeben oder um die zuletzt programmierte Position zu übernehmen: G29 eingeben. Den Pol festlegen, bevor Sie Polarkoordinaten programmieren. Pol nur in rechtwinkligen Koordinaten programmieren. Der Pol ist solange wirksam, bis Sie einen neuen Pol festlegen.

NC-Beispielsätze
N120 I+45 j+45 *


Gerade im Eilgang G10 Gerade mit Vorschub G11 F

Das Werkzeug fährt auf einer Geraden von seiner aktuellen Position zum Endpunkt der Geraden. Der Startpunkt ist der Endpunkt des vorangegangenen Satzes.

Polarkoordinaten-Radius R: Abstand des Geraden-Endpunkts zum Pol CC eingeben

Polarkoordinaten-Winkel H: Winkelposition des Geraden-Endpunkts zwischen –360° und +360°

    Das Vorzeichen von H ist durch die Winkel-Bezugsachse festgelegt:

  • Winkel von der Winkel-Bezugsachse zu R gegen den Uhrzeigersinn: H>0
  • Winkel von der Winkel-Bezugsachse zu R im Uhrzeigersinn: H<0
NC-Beispielsätze
N120 I+45 J+45 *
N130 G11 G42 R+30 h+0 F300 M3 *
N140 H+60 *
N150 G91 H+60 *
N160 G90 H+180 *


Kreisbahn G12/G13/G15 um Pol I, J

Der Polarkoordinaten-Radius R ist gleichzeitig Radius des Kreisbogens. R ist durch den Abstand des Startpunkts zum Pol I, J festgelegt. Die zuletzt programmierte Werkzeug-Position vor der Kreisbahn ist der Startpunkt der Kreisbahn.

Drehsinn
  • Im Uhrzeigersinn: G12
  • Im Gegen-Uhrzeigersinn: G13
  • Ohne Drehrichtungs-Angabe: G15. Die TNC fährt die Kreisbahn mit der zuletzt programmierten Drehrichtung

Polarkoordinaten-Winkel H: Winkelposition des Kreisbahn-Endpunkts zwischen –99999,9999° und +99999,9999°

Drehsinn DR
NC-Beispielsätze
N180 I+25 J+25 *
N190 G11 G42 R+20 h+0 F250 M3 *
N200 G13 H+180 *


Kreisbahn G16 mit tangentialem Anschluss

Das Werkzeug fährt auf einer Kreisbahn, die tangential an ein vorangegangenes Konturelement anschließt.

Polarkoordinaten-Radius R: Abstand des Kreisbahn-Endpunkts zum Pol I, J

Polarkoordinaten-Winkel H: Winkelposition des Kreisbahn-Endpunkts

NC-Beispielsätze
N120 I+40 J+35 *
N130 G01 G42 X+0 Y+35 F250 M3 *
N140 G11 R+25 H+120 *
N150 G16 R+30 H+30 *
N160 G01 Y+0 *

Der Pol ist nicht Mittelpunkt des Konturkreises!


Schraubenlinie (Helix)

Eine Schraubenlinie entsteht aus der Überlagerung einer Kreisbewegung und einer Geradenbewegung senkrecht dazu. Die Kreisbahn programmieren Sie in einer Hauptebene.

Die Bahnbewegungen für die Schraubenlinie können Sie nur in Polarkoordinaten programmieren.

Weitere Informationen:
> Einsatz
> Berechnung der Schraubenlinie
> Form der Schraubenlinie
> Schraubenlinie programmieren


Einsatz
  • Innen- und Außengewinde mit größeren Durchmessern
  • Schmiernuten


Berechnung der Schraubenlinie

Zum Programmieren benötigen Sie die inkrementale Angabe des Gesamtwinkels, den das Werkzeug auf der Schraubenlinie fährt und die Gesamthöhe der Schraubenlinie.

Für die Berechnung in Fräsrichtung von unten nach oben gilt:

Anzahl Gänge n | Gewindegänge + Gangüberlauf am Gewinde-Anfang und -Ende
Gesamthöhe h | Steigung P x Anzahl der Gänge n
Inkrementaler Gesamtwinkel h | Anzahl der Gänge x 360° + Winkel für Gewinde-Anfang + Winkel für Gangüberlauf
Anfangskoordinate Z | Steigung P x (Gewindegänge + Gangüberlauf am Gewinde-Anfang)


Form der Schraubenlinie

Die Tabelle zeigt die Beziehung zwischen Arbeitsrichtung, Drehsinn und Radiuskorrektur für bestimmte Bahnformen.

Innengewinde | Arbeits-richtung | Drehsinn | Radius-korrektur
rechtsgängig linksgängig | Z+ Z+ | G13 G12 | G41 G42
rechtsgängig linksgängig | Z– Z– | G12 G13 | G42 G41
Außengewinde |  |  |
rechtsgängig linksgängig | Z+ Z+ | G13 G12 | G42 G41
rechtsgängig linksgängig | Z– Z– | G12 G13 | G41 G42


Schraubenlinie programmieren

Geben Sie Drehsinn und den inkrementalen Gesamtwinkel G91 h mit gleichem Vorzeichen ein, sonst kann das Werkzeug in einer falschen Bahn fahren.

Für den Gesamtwinkel G91 h ist einen Wert von ‑99 999,9999° bis +99 999,9999° eingebbar.

Polarkoordinaten-Winkel: Gesamtwinkel inkremental eingeben, den das Werkzeug auf der Schraubenlinie fährt. Nach der Eingabe des Winkels wählen Sie die Werkzeug-Achse mit einer Achswahltaste.

Koordinate für die Höhe der Schraubenlinie inkremental eingeben

Radiuskorrektur gemäß Tabelle eingeben

NC-Beispielsätze: Gewinde M6 x 1 mm mit 4 Gängen
N120 I+40 J+25 *
N130 G01 Z+0 F100 M3 *
N140 G11 G41 R+3 h+270 *
N150 G12 G91 h-1440 Z+5 *


Beispiel: Geradenbewegung polar

%linearpo g71 * |
n10 g30 g17 x+0 y+0 z-20 * | Rohteil-Definition
n20 g31 g90 x+100 y+100 z+0 * |
n40 t1 g17 s4000 * | Werkzeug-Aufruf
n50 g00 g40 g90 z+250 * | Bezugspunkt für Polarkoordinaten definieren
n60 i+50 j+50 * | Werkzeug freifahren
n70 g10 r+60 h+180 * | Werkzeug vorpositionieren
n80 g01 z-5 f1000 m3 * | Auf Bearbeitungstiefe fahren
n90 g11 g41 r+45 h+180 f250 * | Kontur an Punkt 1 anfahren
n100 g26 r5 * | Kontur an Punkt 1 anfahren
n110 h+120 * | Punkt 2 anfahren
n120 h+60 * | Punkt 3 anfahren
n130 h+0 * | Punkt 4 anfahren
n140 h-60 * | Punkt 5 anfahren
n150 h-120 * | Punkt 6 anfahren
n160 h+180 * | Punkt 1 anfahren
n170 g27 r5 f500 * | Tangentiales Wegfahren
n180 g40 r+60 h+180 f1000 * | Freifahren in der Bearbeitungsebene, Radiuskorrektur aufheben
n190 g00 z+250 m2 * | Freifahren in der Spindelachse, Programm-Ende
n99999999 %linearpo g71 * |


Beispiel: Helix

%helix g71 * |
n10 g30 g17 x+0 y+0 z-20 * | Rohteil-Definition
n20 g31 g90 x+100 y+100 z+0 * |
n40 t1 g17 s1400 * | Werkzeug-Aufruf
n50 g00 g40 g90 z+250 * | Werkzeug freifahren
n60 x+50 y+50 * | Werkzeug vorpositionieren
n70 g29 * | Letzte programmierte Position als Pol übernehmen
n80 g01 z-12,75 f1000 m3 * | Auf Bearbeitungstiefe fahren
n90 g11 g41 r+32 h+180 f250 * | Ersten Konturpunkt anfahren
n100 g26 r2 * | Anschluss
n110 g13 g91 h+3240 z+13,5 f200 * | Helix fahren
n120 g27 r2 f500 * | Tangentiales Wegfahren
n170 g01 g40 g90 x+50 y+50 f1000 * | Werkzeug freifahren, Programm-Ende
n180 g00 z+250 m2 * |


Programmieren: Datenübernahme aus DXF-Dateien oder Klartext-Konturen

Weitere Informationen:
> DXF-Dateien verarbeiten (Software-Option)
> Datenübernahme aus Klartext-Dialog-Programmen
> 3D-CAD-Daten öffnen (Software-Option)


DXF-Dateien verarbeiten (Software-Option)

Weitere Informationen:
> Anwendung
> DXF-Datei öffnen
> Arbeiten mit dem DXF-Konverter
> Grundeinstellungen
> Layer einstellen
> Bezugspunkt festlegen
> Kontur wählen und speichern
> Bearbeitungspositionen wählen und speichern


Anwendung

Auf einem CAD-System erzeugte DXF-Dateien können Sie direkt auf der TNC öffnen, um daraus Konturen oder Bearbeitungspositionen zu extrahieren und diese als Klartext-Dialog-Programme bzw. als Punkte-Dateien zu speichern. Die bei der Konturselektion gewonnen Klartext-Dialog-Programme können Sie auch auf älteren TNC-Steuerungen abarbeiten, da die Konturprogramme nur L- und CC-/C-Sätze enthalten.

Wenn Sie DXF-Dateien in der Betriebsart Programm-Einspeichern/Editieren verarbeiten, dann erzeugt die TNC Konturprogramme standardmäßig mit der Dateiendung .H und Punkte-Dateien mit der Endung .PNT. Wenn Sie DXF-Dateien in der Betriebsart smarT.NC verarbeiten, dann erzeugt die TNC Kontur-Programme standardmäßig mit der Dateiendung .HC und Punkte-Dateien mit der Endung .HP. Sie können jedoch beim Speichern-Dialog den Datei-Typ frei wählen. Darüber hinaus können Sie die selektierte Kontur bzw. die selektierten Bearbeitungspositionen auch in den Zwischenspeicher der TNC ablegen, um diese anschließend direkt in ein NC-Programm einzufügen.

Die zu verarbeitende DXF-Datei muss auf der Festplatte der TNC gespeichert sein.

Vor dem Einlesen in die TNC darauf achten, dass der Dateiname der DXF-Datei keine Leerzeichen bzw. nicht erlaubte Sonderzeichen enthält (siehe Namen von Dateien).

Die zu öffnende DXF-Datei muss mindestens einen Layer enthalten.

Die TNC unterstützt das am weitesten verbreitete DXF-Format R12 (entspricht AC1009).

Die TNC unterstützt kein binäres DXF-Format. Beim Erzeugen der DXF-Datei aus dem CAD- oder Zeichenprogramm darauf achten, dass Sie die Datei im ASCII-Format speichern.

    Als Kontur selektierbar sind folgende DXF-Elemente:

    • LINE (Gerade)
    • CIRCLE (Vollkreis)
    • ARC (Teilkreis)
    • POLYLINE (Poly-Linie)


DXF-Datei öffnen

Betriebsart Einspeichern/Editieren wählen

Datei-Verwaltung wählen

Softkey-Menü zur Auswahl der anzuzeigenden Datei-Typen wählen: Softkey TYP WÄHLEN drücken

Alle DXF-Dateien anzeigen lassen: Softkey zeige DXF drücken

Verzeichnis wählen, in dem die DXF-Datei gespeichert ist

Gewünschte DXF-Datei wählen, mit Taste ENT übernehmen: Die TNC startet den DXF-Konverter und zeigt den Inhalt der DXF-Datei am Bildschirm an. Im linken Fenster zeigt die TNC die sogenannten Layer (Ebenen) an, im rechten Fenster die Zeichnung


Arbeiten mit dem DXF-Konverter

Um den DXF-Konverter bedienen zu können, benötigen Sie zwingend eine Mouse. Alle Betriebsmodi und Funktionen, sowie die Anwahl von Konturen und Bearbeitungspositionen sind ausschließlich per Mouse möglich.

Der DXF-Konverter läuft als separate Anwendung auf dem 3. Desktop der TNC. Sie können daher mit der Bildschirm-Umschalttaste beliebig zwischen den Maschinen-Betriebsarten, den Programmier-Betriebsarten und dem DXF-Konverter hin- und herschalten. Dies ist besonders dann hilfreich, wenn Sie Konturen oder Bearbeitungspositionen durch Kopieren über die Zwischenablage in ein Klartext-Programm einfügen wollen.


Grundeinstellungen

Die nachfolgend aufgeführten Grundeinstellungen wählen Sie über die Icons der Kopfleiste. Manche Icons zeigt die TNC nur in bestimmten Modi an.

Einstellung Icon

Zoom auf größtmögliche Darstellung setzen

Farbschema umschalten (Hintergrundfarbe wechseln)

Umschalten zwischen 2D- und 3D-Modus. Bei aktivem 3D-Modus können sie die Ansicht mit der rechten Mouse-Taste drehen und neigen

Maßeinheit mm oder inch der DXF-Datei einstellen. In dieser Maßeinheit gibt die TNC auch das Konturprogramm bzw. die Bearbeitungspositionen aus

Auflösung einstellen: Die Auflösung legt fest, mit wie viel Nachkommastellen die TNC das Kontur-Programm erzeugen soll. Grundeinstellung: 4 Nachkommastellen (entspricht 0.1 µm Auflösung bei aktiver Maßeinheit MM)

Modus Konturübernahme, Toleranz einstellen: Die Toleranz legt fest, wie weit benachbarte Konturelemente voneinander entfernt sein dürfen. Mit der Toleranz können Sie Ungenauigkeiten ausgleichen, die bei der Zeichnungserstellung gemacht wurden. Grundeinstellung ist abhängig von der Ausdehnung der gesamten DXF-Datei

    Modus Punktübernahme bei Kreisen und Teilkreisen: Modus legt fest, ob die TNC beim Wählen von Bearbeitungspositionen mit einem Mouse-Klick den Kreismittelpunkt direkt übernehmen soll (AUS), oder ob die TNC zunächst zusätzliche Kreispunkte anzeigen soll.

    • AUS
      Zusätzliche Kreispunkte nicht anzeigen, Kreismittelpunkt direkt übernehmen, wenn Sie einen Kreis oder einen Teilkreis anklicken
    • EIN
      Zusätzliche Kreispunkte anzeigen, gewünschten Kreispunkt durch erneutes Anklicken übernehmen

Modus Punktübernahme: Festlegen, ob die TNC beim Wählen von Bearbeitungspositionen den Verfahrweg des Werkzeugs anzeigen soll oder nicht.

Beachten Sie, dass Sie die richtige Maßeinheit einstellen müssen, da in der DXF-Datei diesbezüglich keine Informationen enthalten sind.

Wenn Sie Programme für ältere TNC-Steuerungen erzeugen wollen, müssen Sie die Auflösung auf 3 Nachkommastellen begrenzen. Zusätzlich müssen Sie die Kommentare entfernen, die der DXF-Konverter mit in das Konturprogramm ausgibt.

Die TNC zeigt die aktiven Grundeinstellungen in der Fußzeile am Bildschirm an.


Layer einstellen

DXF-Dateien enthalten in der Regel mehrere Layer (Ebenen), mit denen der Konstrukteur seine Zeichnung organisieren kann. Mit Hilfe der Layertechnik gruppiert der Konstrukteur verschiedenartige Elemente, z.B. die eigentliche Werkstück-Kontur, Bemaßungen, Hilfs- und Konstruktionslinien, Schraffuren und Texte.

Um bei der Konturauswahl möglichst wenig überflüssige Informationen am Bildschirm zu haben, können Sie alle überflüssigen, in der DXF-Datei enthaltenen Layer ausblenden.

Die zu verarbeitende DXF-Datei muss mindestens einen Layer enthalten.

Sie können eine Kontur auch dann selektieren, wenn der Konstrukteur diese auf unterschiedlichen Layern gespeichert hat.

Wenn nicht schon aktiv, den Modus zum Einstellen der Layer wählen: Die TNC zeigt im linken Fenster alle Layer an, die in der aktiven DXF-Datei enthalten sind

Um einen Layer auszublenden: Mit der linken Mouse-Taste den gewünschten Layer wählen und durch -Klicken auf das Kontrollkästchen ausblenden

Um einen Layer einzublenden: Mit der linken Mouse-Taste den gewünschten Layer wählen und durch -Klicken auf das Kontrollkästchen wieder einblenden


Bezugspunkt festlegen

Der Zeichnungs-Nullpunkt der DXF-Datei liegt nicht immer so, dass Sie diesen direkt als Werkstück-Bezugspunkt verwenden können. Die TNC stellt daher eine Funktion zur Verfügung, mit der Sie den Zeichnungs-Nullpunkt durch Anklicken eines Elementes an eine sinnvolle Stelle verschieben können.

    An folgenden Stellen können Sie den Bezugspunkt definieren:

  • Am Anfangs-, Endpunkt oder in der Mitte einer Geraden
  • Am Anfangs- oder Endpunkt eines Kreisbogens
  • Jeweils am Quadrantenübergang oder in der Mitte eines Vollkreises
  • Im Schnittpunkt von
    • Gerade – Gerade, auch wenn der Schnittpunkt in der Verlängerung der jeweiligen Geraden liegt
    • Gerade – Kreisbogen
    • Gerade – Vollkreis
    • Kreis – Kreis (unabhängig ob Teil- oder Vollkreis)

Um einen Bezugspunkt festlegen zu können, müssen Sie das Touch-Pad auf der TNC-Tastatur oder eine über USB angeschlossene Mouse verwenden.

Sie können den Bezugspunkt auch noch verändern, wenn Sie die Kontur bereits gewählt haben. Die TNC berechnet die tatsächlichen Konturdaten erst, wenn Sie die gewählte Kontur in ein Konturprogramm speichern.
Weitere Informationen:
> Bezugspunkt auf einzelnem Element wählen
> Bezugspunkt als Schnittpunkt zweier Elemente wählen
> Elementinformationen


Bezugspunkt auf einzelnem Element wählen

Modus zum Festlegen des Bezugspunktes wählen

Mit der linken Mouse-Taste das gewünschte Element anklicken auf das Sie den Bezugspunkt legen wollen: Die TNC zeigt per Stern wählbare Bezugspunkte an, die auf dem selektierten Element liegen

Auf den Stern klicken, den Sie als Bezugspunkt wählen wollen: Die TNC setzt das Bezugspunkt-Symbol auf die gewählte Stelle. Ggf. Zoom-Funktion verwenden, wenn das gewählte Element zu klein ist


Bezugspunkt als Schnittpunkt zweier Elemente wählen

Modus zum Festlegen des Bezugspunktes wählen

Mit der linken Mouse-Taste das erste Element (Gerade, Vollkreis oder Kreisbogen) anklicken: Die TNC zeigt per Stern wählbare Bezugspunkte an, die auf dem selektierten Element liegen

Mit der linken Mouse-Taste das zweite Element (Gerade, Vollkreis oder Kreisbogen) anklicken: Die TNC setzt das Bezugspunkt-Symbol auf den Schnittpunkt

Die TNC berechnet den Schnittpunkt zweier Elemente auch dann, wenn dieser in der Verlängerung eines Elementes liegt.

Wenn die TNC mehrere Schnittpunkte berechnen kann, dann wählt die Steuerung den Schnittpunkt, der dem Mouseklick des zweiten Elementes am nächsten liegt.

Wenn die TNC keinen Schnittpunkt berechnen kann, dann hebt sie ein bereits markiertes Element wieder auf.


Elementinformationen

Die TNC zeigt im Bildschirm links unten an, wie weit der von Ihnen gewählte Bezugspunkt vom Zeichnungsnullpunkt entfernt ist.


Kontur wählen und speichern

Um eine Kontur wählen zu können, müssen Sie das Touch-Pad auf der TNC-Tastatur oder eine über USB angeschlossene Mouse verwenden.

Wenn Sie das Kontur-Programm nicht in der Betriebsart smarT.NC verwenden, dann müssen Sie die Umlaufrichtung bei der Konturauswahl so festlegen, dass sie mit der gewünschten Bearbeitungsrichtung übereinstimmt.

Wählen Sie das erste Konturelement so aus, dass ein kollisionsfreies Anfahren möglich ist.

Sollten die Konturelemente sehr dicht aufeinander liegen, Zoom-Funktion nutzen.

Modus zum Selektieren der Kontur wählen: Die TNC blendet die im linken Fenster angezeigten Layer aus und das rechte Fenster ist für die Konturauswahl aktiv

Um ein Konturelement zu wählen: Mit dem Mousezeiger über das zu wählende Konturelement fahren: Die TNC stellt per Pfeil die aktuelle Umlaufrichtung dar, die Sie durch ändern der Mouseposition auf dem Konturelement ändern können. Mit der linken Mouse-Taste auf das gewünschten Konturelement klicken. Die TNC stellt das ausgewählte Konturelement blau dar. Gleichzeitig zeigt die TNC das gewählte Element mit einem Symbol (Kreis oder Gerade) im linken Fenster an. Wenn weitere Konturelemente in der gewählten Umlaufrichtung eindeutig selektierbar sind, dann kennzeichnet die TNC diese Elemente grün. Durch Klicken auf das letzte grüne Element übernehmen Sie alle Elemente in das Konturprogramm. Im linken Fenster zeigt die TNC alle selektierten Konturelemente an. Noch grün markierte Elemente zeigt die TNC ohne Häkchen in der Spalte NC an. Solche Elemente speichert die TNC nicht in das Konturprogramm. Sie können markierte Elemente auch durch Anklicken im linken Fenster in das Konturprogramm übernehmen

Bei Bedarf können Sie bereits selektierte Elemente wieder deselektieren, indem Sie das Element im rechten Fenster erneut anklicken, jedoch zusätzlich die Taste CTRL gedrückt halten. Durch Klick auf das Papierkorb-Symbol können Sie alle selektierten Elemente deselektieren

Wenn Sie Poly-Linien selektiert haben, dann zeigt die TNC im linken Fenster eine zweistufige Id-Nummer an. Die erste Nummer ist die fortlaufende Konturelement-Nummer, die zweite Nummer ist die aus der DXF-Datei stammende Elementnummer der jeweiligen Poly-Linie.

Gewählte Konturelemente in den Zwischenspeicher der TNC speichern, um die Kontur anschließend in einem Klartext-Dialog-Programm einfügen zu können, oder

Gewählte Konturelemente in einem Klartext-Dialog-Programm speichen: Die TNC zeigt ein Überblendfenster, in dem Sie das Zielverzeichnis und einen beliebigen Dateinamen eingeben können. Grundeinstellung: Name der DXF-Datei. Wenn der Name der DXF Umlaute oder Leerstellen enthält, dann ersetzt die TNC diese Zeichen durch einen Unterstrich. Alternativ können Sie auch den Datei-Typ wählen: Klartext-Dialog-Programm (.H) oder Konturbeschreibung (.HC)

Eingabe bestätigen: Die TNC speichert das Kontur-Programm in dem gewählten Verzeichnis

Wenn Sie noch weitere Konturen wählen wollen: Icon gewähte Elemente deselktieren drücken und nächste Kontur wie zuvor beschrieben wählen

Die TNC gibt zwei Rohteil-Definitionen (BLK FORM) mit ins Konturprogramm aus. Die erste Definition enthält die Abmessungen der gesamten DXF-Datei, die zweite und damit - zunächst wirksame Definition - umschließt die selektierten Konturelemente, so dass eine optimierte Rohteilgröße entsteht.

Die TNC speichert nur die Elemente, die tatsächlich auch selektiert sind (blaue markierte Elemente), also mit einem Häckchen im linken Fenster versehen sind.
Weitere Informationen:
> Lesezeichen
> Konturelemente teilen, verlängern, verkürzen
> Elementinformationen


Lesezeichen

Über Bookmarks können Sie Ihre Verzeichnis-Favoriten verwalten. Sie können das aktive Verzeichnis hinzufügen oder löschen oder alle Bookmarks löschen. Alle von Ihnen hinzugefügten Verzeichnisse erscheinen in der Bookmark-Liste und lassen sich somit schnell wählen.

Die Bookmark-Funktionen erhalten Sie, indem Sie im rechten Teil des Überblendfensters der Speichern-Funktion auf den Pfadnamen klicken.

Lesezeichen verwalten Sie wie folgt:

  • Die Speichern-Funktion ist aktiv: Die TNC zeigt das Überblendfenster Dateiname für Kontur-Programm definieren an

  • Im rechten, oberen Teil des Überblendfensters auf den aktuell angezeigten Pfadnamen klicken (linke Mouse-Taste): Die TNC zeigt ein Pop Up-Menü an

  • Mit der linken Mouse-Taste den Menüpunkt Lesezeichen wählen und die gewünschte Funktion anklicken


Konturelemente teilen, verlängern, verkürzen

Wenn zu selektierende Konturelemente in der Zeichnung stumpf aneinanderstoßen, müssen Sie das entsprechende Konturelement zunächst teilen. Diese Funktion steht Ihnen automatisch zur Verfügung, wenn Sie sich im Modus zum Selektieren einer Kontur befinden.

Gehen Sie wie folgt vor:

  • Das stumpf anstoßende Konturelement ist ausgewählt, also blau markiert

  • Zu teilendes Konturelement anklicken: Die TNC zeigt den Schnittpunkt durch einen Stern mit Kreis an und die selektierbaren Endpunkte durch einen einfachen Stern

  • Mit gedrückter Taste CTRL auf den Schnittpunkt klicken: Die TNC teilt das Konturelement im Schnittpunkt und blendet die Punkte wieder aus. Ggf. verlängert oder verkürzt die TNC das stumpf anstoßende Konturelement bis an den Schnittpunkt beider Elemente

  • Das geteilte Konturelement erneut anklicken: Die TNC blendet den Schnitt- und die Endpunkte wieder ein

  • Gewünschten Endpunkt anklicken: Die TNC markiert das jetzt geteilte Element blau

  • Nächstes Konturelement wählen

Wenn das zu verlängernde/zu verkürzende Konturelement eine Gerade ist, dann verlängert/verkürzt die TNC das Konturelement linear. Wenn das zu verlängernde/zu verkürzende Konturelement ein Kreisbogen ist, dann verlängert/verkürzt die TNC den Kreisbogen zirkular.

Um diese Funktionen nutzen zu können, müssen mindestens zwei Konturelemente bereits selektiert sein, damit die Richtung eindeutig bestimmt ist.


Elementinformationen

    Die TNC zeigt im Bildschirm links unten verschiedene Informationen zu dem Konturelement an, das Sie zuletzt im linken oder rechten Fenster per Mouse-Klick gewählt haben.

  • Gerade
    Endpunkt der Geraden und zusätzlich ausgegraut den Startpunkt der Geraden
  • Kreis, Teilkreis
    Kreismittelpunkt, Kreisendpunkt und Drehsinn. Zusätzlich ausgegraut Startpunkt und Radius des Kreises


Bearbeitungspositionen wählen und speichern

Um Bearbeitungspositionen wählen zu können, müssen Sie das Touch-Pad auf der TNC-Tastatur oder eine über USB angeschlossene Mouse verwenden.

Sollten die zu wählenden Positionen sehr dicht aufeinander liegen, Zoom-Funktion nutzen.

Ggf. Grundeinstellung so wählen, dass die TNC Werkzeugbahnen anzeigt (siehe Grundeinstellungen).

    Um Bearbeitungspositionen zu wählen, stehen Ihnen drei Möglichkeiten zur Verfügung:

  • Einzelanwahl:
    Sie wählen die gewünschte Bearbeitungsposition durch einzelne Mouse-Klicks (siehe Einzelanwahl)
  • Schnellanwahl für Bohrpositionen über Mouse-Bereich:
    Sie wählen durch Aufziehen eines Bereiches mit der Mouse alle darin enthaltenen Bohrpositionen aus (siehe Schnellanwahl von Bohrpositionen über Mouse-Bereich)
  • Schnellanwahl für Bohrpositionen über Durchmesser-Eingabe:
    Sie wählen durch Eingabe eines Bohrungsdurchmessers alle in der DXF-Datei enthaltenen Bohrpossitionen mit diesem Durchmesser aus (siehe Schnellanwahl von Bohrpositionen über Durchmesser-Eingabe)
Weitere Informationen:
> Einzelanwahl
> Schnellanwahl von Bohrpositionen über Mouse-Bereich
> Schnellanwahl von Bohrpositionen über Durchmesser-Eingabe
> Lesezeichen
> Filtereinstellungen
> Elementinformationen
> Aktionen rückgängig machen
> Mouse-Funktionen


Einzelanwahl

Modus zum Selektieren von Bearbeitungsposition wählen: Die TNC blendet die im linken Fenster angezeigten Layer aus und das rechte Fenster ist für die Positionsauswahl aktiv

Um eine Bearbeitungsposition zu wählen: Mit der linken Mouse-Taste das gewünschte Element anklicken: Die TNC zeigt per Stern wählbare Bearbeitungspositionen an, die auf dem selektierten Element liegen. Einen der Sterne anklicken: Die TNC übernimmt die gewählte Position ins linke Fenster (anzeigen eines Punkt-Symbols). Wenn Sie einen Kreis anklicken, dann übernimmt die TNC den Kreismittelpunkt direkt als Bearbeitungsposition

Bei Bedarf können Sie bereits selektierte Elemente wieder deselektieren, indem Sie das Element im rechten Fenster erneut anklicken, jedoch zusätzlich die Taste CTRL gedrückt halten (innerhalb der Markierung anklicken)

Wenn Sie die Bearbeitungsposition durch Schneiden zweier Elemente bestimmen wollen, erstes Element mit der linken Mouse-Taste anklicken: Die TNC zeigt per Stern wählbare Bearbeitungspositionen an

Mit der linken Mouse-Taste das zweite Element (Gerade, Vollkreis oder Kreisbogen) anklicken: Die TNC übernimmt den Schnittpunkt der Elemente ins linke Fenster (anzeigen eines Punkt-Symbols)

Gewählte Bearbeitungspositionen in den Zwischenspeicher der TNC speichern, um diese dann anschließend als Positioniersatz mit Zyklus-Aufruf in einem Klartext-Dialog-Programm einfügen zu können, oder

Gewählte Bearbeitungspositionen in eine Punkte-Datei speichen: Die TNC zeigt ein Überblendfenster, in dem Sie das Zielverzeichnis und einen beliebigen Dateinamen eingeben können. Grundeinstellung: Name der DXF-Datei. Wenn der Name der DXF-Datei Umlaute oder Leerstellen enthält, dann ersetzt die TNC diese Zeichen durch einen Unterstrich. Alternativ können Sie auch den Datei-Typ wählen: Punkte-Tabelle (.pnt), Mustergenerator-Tabelle (.HP) oder Klartext-Dialog-Programm (.H). Wenn Sie die Bearbeitungspositionen in ein Klartext-Dialog-Programm speichern, dann erzeugt die TNC für jede Bearbeitungsposition einen separaten Linearsatz mit Zyklusaufruf (L X... Y... M99). Dieses Programm können Sie auch auf alte TNC-Steuerungen übertragenund dort abarbeiten.

Eingabe bestätigen: Die TNC speichert das Kontur-Programm in dem Verzeichnis, in dem auch die DXF-Datei gespeichert ist

Wenn Sie noch weitere Bearbeitungspositionen wählen wollen um diese in einer anderen Datei zu speichern: Icon gewählte Elemente aufheben drücken und wie zuvor beschrieben wählen


Schnellanwahl von Bohrpositionen über Mouse-Bereich

Modus zum Selektieren von Bearbeitungsposition wählen: Die TNC blendet die im linken Fenster angezeigten Layer aus und das rechte Fenster ist für die Positionsauswahl aktiv

Shift-Taste auf der Tastatur drücken und mit der linken Mouse-Taste einen Bereich aufziehen, in dem die TNC alle enthaltenen Kreismittelpunkte als Bohrpositionen übernehmen soll: Die TNC blendet ein Fenster ein, in dem Sie die Bohrungen nach ihrer Größe filtern können

Filtereinstellungen setzen (siehe Filtereinstellungen) und mit Schaltfläche Anwenden bestätigen: Die TNC übernimmt die gewählten Positionen ins linke Fenster (anzeigen eines Punkt-Symbols)

Bei Bedarf können Sie bereits selektierte Elemente wieder deselektieren, indem Sie nochmal einen Bereich aufziehen, jedoch zusätzlich die Taste CTRL gedrückt halten

Gewählte Bearbeitungspositionen in den Zwischenspeicher der TNC speichern, um diese dann anschließend als Positioniersatz mit Zyklus-Aufruf in einem Klartext-Dialog-Programm einfügen zu können, oder

Gewählte Bearbeitungspositionen in eine Punkte-Datei speichen: Die TNC zeigt ein Überblendfenster, in dem Sie das Zielverzeichnis und einen beliebigen Dateinamen eingeben können. Grundeinstellung: Name der DXF-Datei. Wenn der Name der DXF-Datei Umlaute oder Leerstellen enthält, dann ersetzt die TNC diese Zeichen durch einen Unterstrich. Alternativ können Sie auch den Datei-Typ wählen: Punkte-Tabelle (.pnt), Mustergenerator-Tabelle (.HP) oder Klartext-Dialog-Programm (.H). Wenn Sie die Bearbeitungspositionen in ein Klartext-Dialog-Programm speichern, dann erzeugt die TNC für jede Bearbeitungsposition einen separaten Linearsatz mit Zyklusaufruf (L X... Y... M99). Dieses Programm können Sie auch auf alte TNC-Steuerungen übertragenund dort abarbeiten.

Eingabe bestätigen: Die TNC speichert das Kontur-Programm in dem Verzeichnis, in dem auch die DXF-Datei gespeichert ist

Wenn Sie noch weitere Bearbeitungspositionen wählen wollen um diese in einer anderen Datei zu speichern: Icon gewählte Elemente aufheben drücken und wie zuvor beschrieben wählen


Schnellanwahl von Bohrpositionen über Durchmesser-Eingabe

Modus zum Selektieren von Bearbeitungsposition wählen: Die TNC blendet die im linken Fenster angezeigten Layer aus und das rechte Fenster ist für die Positionsauswahl aktiv

Dialog zur Durchmessereingabe öffnen: Die TNC zeigt ein Überblendfenster, in dem Sie einen beliebigen Durchmesser eingeben können

Gewünschten Durchmesser eingeben, mit Taste ENT bestätigen: Die TNC durchsucht die DXF-Datei nach dem eingegebenen Durchmesser und blendet danach ein Fenster ein, in dem der Durchmesser gewählt ist, der dem von Ihnen eingegebenen Durchmesser am nächsten kommt. Zusätzlich können Sie die Bohrungen nachträglich nach ihrer Größe filtern

Ggf. Filtereinstellungen setzen (siehe Filtereinstellungen) und mit Schaltfläche Anwenden bestätigen: Die TNC übernimmt die gewählten Positionen ins linke Fenster (anzeigen eines Punkt-Symbols)

Bei Bedarf können Sie bereits selektierte Elemente wieder deselektieren, indem Sie nochmal einen Bereich aufziehen, jedoch zusätzlich die Taste CTRL gedrückt halten

Gewählte Bearbeitungspositionen in den Zwischenspeicher der TNC speichern, um diese dann anschließend als Positioniersatz mit Zyklus-Aufruf in einem Klartext-Dialog-Programm einfügen zu können, oder

Gewählte Bearbeitungspositionen in eine Punkte-Datei speichen: Die TNC zeigt ein Überblendfenster, in dem Sie das Zielverzeichnis und einen beliebigen Dateinamen eingeben können. Grundeinstellung: Name der DXF-Datei. Wenn der Name der DXF-Datei Umlaute oder Leerstellen enthält, dann ersetzt die TNC diese Zeichen durch einen Unterstrich. Alternativ können Sie auch den Datei-Typ wählen: Punkte-Tabelle (.pnt), Mustergenerator-Tabelle (.HP) oder Klartext-Dialog-Programm (.H). Wenn Sie die Bearbeitungspositionen in ein Klartext-Dialog-Programm speichern, dann erzeugt die TNC für jede Bearbeitungsposition einen separaten Linearsatz mit Zyklusaufruf (L X... Y... M99). Dieses Programm können Sie auch auf alte TNC-Steuerungen übertragenund dort abarbeiten.

Eingabe bestätigen: Die TNC speichert das Kontur-Programm in dem Verzeichnis, in dem auch die DXF-Datei gespeichert ist

Wenn Sie noch weitere Bearbeitungspositionen wählen wollen um diese in einer anderen Datei zu speichern: Icon gewählte Elemente aufheben drücken und wie zuvor beschrieben wählen


Filtereinstellungen

Nachdem Sie über die Schnellauswahl Bohrpositionen markiert haben, zeigt die TNC ein Überblendfenster an, in dem links der kleinste und rechts der größte gefundene Bohrungsdurchmesser angezeigt wird. Mit den Schaltflächen unterhalb der Durchmesseranzeige können Sie im linken Bereich den unteren und im rechten Bereich den oberen Durchmesser so einstellen, dass Sie die von Ihnen gewünschten Bohrungsdurchmesser übernehmen können.

Folgende Schaltflächen stehen zur Verfügung:

Filtereinstellung kleinster Durchmesser | Icon
Kleinsten gefundenen Durchmesser anzeigen (Grundeinstellung) |
Nächst kleineren gefundenen Durchmesser anzeigen |
Nächst größeren gefundenen Durchmesser anzeigen |
Größten gefundenen Durchmesser anzeigen. Die TNC setzt den Filter für den kleinsten Durchmesser auf den Wert, der für den größten Durchmesser gesetzt ist |
Filtereinstellung größter Durchmesser | Icon
Kleinsten gefundenen Durchmesser anzeigen. Die TNC setzt den Filter für den größten Durchmesser auf den Wert, der für den kleinsten Durchmesser gesetzt ist |
Nächst kleineren gefundenen Durchmesser anzeigen |
Nächst größeren gefundenen Durchmesser anzeigen |
Größten gefundenen Durchmesser anzeigen (Grundeinstellung) |

Mit der Option Wegoptimierung anwenden (Grundeinstellung ist Wegoptimierung anwenden) sortiert die TNC die gewählten Bearbeitungspositionen so, dass möglichst keine unnötigen Leerwege entstehen. Die Werkzeugbahn können Sie sich über das Icon Werkzeugbahn anzeigen einblenden lassen (siehe Grundeinstellungen).


Elementinformationen

Die TNC zeigt im Bildschirm links unten die Koordinaten der Bearbeitungsposition an, die Sie zuletzt im linken oder rechten Fenster per Mouse-Klick gewählt haben.


Aktionen rückgängig machen

Sie können die letzten vier Aktionen, die Sie im Modus zum Selektieren von Bearbeitungspositionen durchgeführt haben, rückgängig machen. Hierfür stehen folgende Icons zur Verfügung:

Funktion | Icon
Zuletzt durchgeführte Aktion rückgängig machen |
Zuletzt durchgeführte Aktion wiederholen |


Mouse-Funktionen

    Vergrößern und verkleinern können Sie mit der Mouse wie folgt:

  • Zoombereich festlegen durch Aufziehen mit gedrückter linker Maustaste
  • Wenn Sie eine Mouse mit Rad verwenden, dann können Sie durch Drehen des Rades Ein- und Auszoomen. Das Zoomzentrum liegt an der Stelle, an der sich der Mouse-Zeiger gerade befindet
  • Durch Einfachklick auf das Lupen-Icon oder durch Doppelklick mit der rechten Mouse-Taste setzen die Ansicht wieder in die Grundstellung zurück

Die aktuelle Ansicht können sie durch gedrückt halten der mittleren Mouse-Taste verschieben.

Bei aktivem Modus 3D können Sie durch gedrückt halten der rechten Mouse-Taste die Ansicht drehen und neigen.


Datenübernahme aus Klartext-Dialog-Programmen

Weitere Informationen:
> Anwendung
> Klartext-Dialogdatei öffnen
> Bezugspunkt festlegen, Konturen wählen und speichern


Anwendung

Mit dieser Funktion können Sie Konturabschnitte oder auch vollständige Konturen aus bestehenden, insbesondere mit CAM-Systemen erzeugten, Klartext-Dialog-Programmen entnehmen. Die TNC stellt die Klartext-Dialog-Programme zwei- oder dreidimensional dar.

Besonders effizient nutzen Sie die Datenübernahme in Verbindung mit dem smartWizard, der Konturbearbeitungs-UNIT‘s für 2D- und 3D-Bearbeitungen zur Verfügung stellt.


Klartext-Dialogdatei öffnen

Betriebsart Einspeichern/Editieren wählen

Datei-Verwaltung wählen

Softkey-Menü zur Auswahl der anzuzeigenden Datei-Typen wählen: Softkey TYP WÄHLEN drücken

Alle Klartext-Dialog-Dateien anzeigen lassen: Softkey zeige H drücken

Verzeichnis wählen, in dem die Datei gespeichert ist

Gewünschte H-Datei wählen

Mit Tastenkombination CTRL+O den Öffnen mit...-Dialog wählen

Öffnen mit Konverter wählen, mit Taste ENT bestätigen: Die TNC öffnet die Klartext-Datei und stellt Konturelemente grafisch dar


Bezugspunkt festlegen, Konturen wählen und speichern

Das Setzen des Bezugspunktes und das wählen der Konturen ist identisch wie bei der Datenübernahme aus der DXF-Datei:

  • Siehe Bezugspunkt festlegen
  • Siehe Kontur wählen und speichern

Zum schnellen Wählen von Konturen steht zusätzlich eine Sonderfunktion zur Verfügung: Im Modus Layer zeigt die TNC Konturnamen an, sofern das Programm entsprechend formatierte Gliederungspunkt enthält.

Durch Doppelklick auf einen Layer wählt die TNC automatisch die komplette Kontur bis zum nächsten Gliederungspunkt. Über die Funktion Speichern können Sie die gewählte Kontur dann direkt als NC-Programm sichern.

NC-Beispielsätze
6 ... | Beliebiger Vorspann
7 L Z... | Vorpositionierung
8 * - Kontur innen | Gliederungssatz, den die TNC als Layer anzeigt
9 L X+20 Y+20 RR F100 | Erster Konturpunkt
10 L x+35 Y+35 | Endpunkt erstes Konturelement
11 L ... | Weitere Konturelemente
12 L ... |
2746 L ... | Letzter Konturpunkt
2747 * - Konturende | Gliederungssatz, der das Konturende kennzeichnet
2748 L ... | Zwischenpositionierungen


3D-CAD-Daten öffnen (Software-Option)

Weitere Informationen:
> Anwendung
> CAD-Viewer bedienen


Anwendung

Mit einer neuen Funktion können Sie standardisierte 3D-CAD-Datenformate direkt auf der TNC öffnen. Dabei ist es unerheblich, ob Ihnen die Datei auf der Festplatte der iTNC oder auf einem angebundenen Laufwerk zur Verfügung steht.

Die Anwahl erfolgt einfach über die Dateiverwaltung der TNC, so wie Sie auch NC-Programme oder sonstige Dateien anwählen. Dadurch lassen sich auf schnelle und einfache Weise direkt im 3D-Modell Unklarheiten prüfen. .

    Die TNC unterstützt momentan folgende Dateiformate:

  • Step-Dateien (Datei-Endung STP)
  • Iges-Dateien (Datei-Endung IGS oder IGES)


CAD-Viewer bedienen

Funktion | Icon
Schattiertes Modell anzeigen. |
Drahtmodell anzeigen |
Drahtmodell ohne unsichtbare Kanten anzeigen |
Darstellungsgröße an Bildschirmgröße anpassen |
Standard 3D-Ansicht wählen |
Draufsicht wählen |
Ansicht von unten wählen |
Ansicht von links wählen |
Ansicht von rechts wählen |
Ansicht von vorne wählen |
Ansicht von hinten wählen |
Weitere Informationen:
> Mouse-Funktionen


Mouse-Funktionen

Folgende Funktionen zur Mouse-Bedienung stehen zur Verfügung:

  • Um das dargestellte Modell dreidimensional zu drehen: rechte Mouse-Taste gedrückt halten und Mouse bewegen. Nachdem Sie die rechte Mouse-Taste losgelassen haben, orientiert die TNC das Modell auf die definierte Ausrichtung

  • Um das dargestellte Modell zu verschieben: mittlere Mouse-Taste, bzw. Mouse-Rad, gedrückt halten und Mouse bewegen. Die TNC verschiebt das Modell in die entsprechende Richtung. Nachdem Sie die mittlere Mouse-Taste losgelassen haben, verschiebt die TNC das Modell auf die definierte Position

  • Um mit der Mouse einen bestimmten Bereich zu zoomen: mit gedrückter linker Mouse-Taste den rechteckigen Zoom-Bereich markieren, Sie können den Zoom-Bereich durch horizontales und vertikales Bewegen der Mouse noch verschieben. Nachdem Sie die linke Mouse-Taste losgelassen haben, vergrößert die TNC das Werkstück auf den definierten Bereich

  • Um mit der Mouse schnell aus- und einzuzoomen: Mouserad vor bzw. zurückdrehen

  • Doppelklick mit der rechten Mouse-Taste: Standardansicht anwählen


Programmieren: Unterprogramme und Programmteil-Wiederholungen

Weitere Informationen:
> Unterprogramme und Programmteil-Wiederholungen kennzeichnen
> Unterprogramme
> Programmteil-Wiederholungen
> Beliebiges Programm als Unterprogramm
> Verschachtelungen
> Programmier-Beispiele


Unterprogramme und Programmteil-Wiederholungen kennzeichnen

Einmal programmierte Bearbeitungsschritte können Sie mit Unterprogrammen und Programmteil-Wiederholungen wiederholt ausführen lassen.

Weitere Informationen:
> Label


Label

Unterprogramme und Programmteil-Wiederholungen beginnen im Bearbeitungsprogramm mit der Marke G98 l, eine Abkürzung für LABEL (engl. für Marke, Kennzeichnung).

LABEL erhalten eine Nummer zwischen 1 und 999 oder einen von Ihnen definierbaren Namen. Jede LABEL-Nummer, bzw. jeden LABEL-Namen, dürfen Sie im Programm nur einmal vergeben mit der Taste LABEL SET oder durch Eingabe von G98. Die Anzahl von eingebbaren Label-Namen ist lediglich durch den internen Speicher begrenzt.

Wenn Sie eine LABEL-Nummer bzw. einen Label-Namen mehrmals vergeben, gibt die TNC beim Beenden des G98 -Satzes eine Fehlermeldung aus. Bei sehr langen Programmen können Sie über MP7229 die Überprüfung auf eine eingebbare Anzahl von Sätzen begrenzen.

Label 0 (G98 L0) kennzeichnet ein Unterprogramm-Ende und darf deshalb beliebig oft verwendet werden.


Unterprogramme

Weitere Informationen:
> Arbeitsweise
> Programmier-Hinweise
> Unterprogramm programmieren
> Unterprogramm aufrufen


Arbeitsweise

  1. Die TNC führt das Bearbeitungs-Programm bis zu einem Unterprogramm-Aufruf Ln,0 aus
  2. Ab dieser Stelle arbeitet die TNC das aufgerufene Unterprogramm bis zum Unterprogramm-Ende g98 L0 ab
  3. Danach führt die TNC das Bearbeitungs-Programm mit dem Satz fort, der auf den Unterprogramm-Aufruf Ln,0 folgt


Programmier-Hinweise

  • Ein Hauptprogramm kann bis zu 254 Unterprogramme enthalten
  • Sie können Unterprogramme in beliebiger Reihenfolge beliebig oft aufrufen
  • Ein Unterprogramm darf sich nicht selbst aufrufen
  • Unterprogramme ans Ende des Hauptprogramms (hinter dem Satz mit M2 bzw. M30) programmieren
  • Wenn Unterprogramme im Bearbeitungs-Programm vor dem Satz mit M2 oder M30 stehen, dann werden sie ohne Aufruf mindestens einmal abgearbeitet


Unterprogramm programmieren

Anfang kennzeichnen: Taste LBL SET drücken

Unterprogramm-Nummer eingeben. Wenn Sie LABEL-Namen verwenden wollen: Softkey lbl-name drücken, um zur Texteingabe zu wechseln

Ende kennzeichnen: Taste LBL SET drücken und Label-Nummer „0“ eingeben


Unterprogramm aufrufen

Unterprogramm aufrufen: Taste LBL CALL drücken

Unterprogr./Wiederholung rufen: Label-Nummer des aufzurufenden Unterprogramms eingeben. Wenn Sie LABEL-Namen verwenden wollen: Softkey lbl-name drücken, um zur Texteingabe zu wechseln. Wenn Sie die Nummer eines String-Parameters als Ziel-Adresse eingeben wollen: Softkey QS drücken, die TNC springt dann auf den Label-Namen, der im definierten String-Parameter angegeben ist

g98 L 0 ist nicht erlaubt, da es dem Aufruf eines Unterprogramm-Endes entspricht.


Programmteil-Wiederholungen

Weitere Informationen:
> Label G98
> Arbeitsweise
> Programmier-Hinweise
> Programmteil-Wiederholung programmieren
> Programmteil-Wiederholung aufrufen


Label G98

Programmteil-Wiederholungen beginnen mit der Marke G98 L. Eine Programmteil-Wiederholung schließt mit Ln,m ab.


Arbeitsweise

  1. Die TNC führt das Bearbeitungs-Programm bis zum Ende des Programmteils (Ln,m) aus
  2. Anschließend wiederholt die TNC den Programmteil zwischen dem aufgerufenen LABEL und dem Label-Aufruf Ln,m so oft, wie Sie unter m angegeben haben
  3. Danach arbeitet die TNC das Bearbeitungs-Programm weiter ab


Programmier-Hinweise

  • Sie können einen Programmteil bis zu 65 534 mal hintereinander wiederholen
  • Programmteile werden von der TNC immer einmal häufiger ausgeführt, als Wiederholungen programmiert sind


Programmteil-Wiederholung programmieren

Anfang kennzeichnen: Taste LBL SET drücken und LABEL-Nummer für den zu wiederholenden Programmteil eingeben. Wenn Sie LABEL-Namen verwenden wollen: Softkey lbl-name drücken, um zur Texteingabe zu wechseln

Programmteil eingeben


Programmteil-Wiederholung aufrufen

Taste LBL CALL drücken

Unterprogr./Wiederholung rufen: Label-Nummer des aufzurufenden Unterprogramms eingeben. Wenn Sie LABEL-Namen verwenden wollen: Softkey lbl-name drücken, um zur Texteingabe zu wechseln. Wenn Sie die Nummer eines String-Parameters als Ziel-Adresse eingeben wollen: Softkey QS drücken, die TNC springt dann auf den Label-Namen, der im definierten String-Parameter angegeben ist

Wiederholung REP: Anzahl der Wiederholung eingeben, mit Taste ent bestätigen


Beliebiges Programm als Unterprogramm

Weitere Informationen:
> Arbeitsweise
> Programmier-Hinweise
> Beliebiges Programm als Unterprogramm aufrufen


Arbeitsweise

  1. Die TNC führt das Bearbeitungs-Programm aus, bis Sie ein anderes Programm mit % aufrufen
  2. Anschließend führt die TNC das aufgerufene Programm bis zu seinem Ende aus
  3. Danach arbeitet die TNC das (aufrufende) Bearbeitungs-Programm mit dem Satz weiter ab, der auf den Programm-Aufruf folgt


Programmier-Hinweise

  • Um ein beliebiges Programm als Unterprogramm zu verwenden, benötigt die TNC keine LABELs
  • Das aufgerufene Programm darf keine Zusatz-Funktion M2 oder M30 enthalten. Wenn Sie in dem aufgerufenen Programm Unterprogramme mit Labeln definiert haben, dann können Sie M2 bzw. M30 mit der Sprung-Funktion D09 P01 +0 P02 +0 p03 99 verwenden, um diesen Programmteil zwingend zu überspringen
  • Das aufgerufene Programm darf keinen Aufruf % ins aufrufende Programm enthalten (Endlosschleife)


Beliebiges Programm als Unterprogramm aufrufen

Funktionen zum Programm-Aufruf wählen: Taste PGM CALL drücken

Softkey PROGRAMM drücken

Softkey Auswahl fenster drücken: Die TNC blendet ein Fenster ein, in dem Sie das zu rufende Programm wählen können

Gewünschtes Programm mit Pfeiltasten oder per Mouse-Klick wählen, mit Taste ENT bestätigen: Die TNC trägt den vollständigen Pfadnamen in den call pgm-Satz ein

Funktion mit Taste END abschließen

Alternativ können Sie den Programm-Namen oder den vollständigen Pfadnamen des aufzurufenden Programms auch direkt über die Tastatur eingeben.

Das aufgerufene Programm muss auf der Festplatte der TNC gespeichert sein.

Wenn Sie nur den Programm-Namen eingeben, muss das aufgerufene Programm im selben Verzeichnis stehen wie das rufende Programm.

Wenn das aufgerufene Programm nicht im selben Verzeichnis steht wie das rufende Programm, dann geben Sie den vollständigen Pfadnamen ein, z.B. TNC:\ZW35\SCHRUPP\PGM1.H oder wählen das Programm über den Softkey AUSWAHL FENSTER aus.

Wenn Sie ein DIN/ISO-Programm aufrufen wollen, dann geben Sie den Datei-Typ .I hinter dem Programm-Namen ein.

Sie können ein beliebiges Programm auch über den Zyklus G39 aufrufen.

Q-Parameter wirken bei einem % grundsätzlich global. Beachten Sie daher, dass Änderungen an Q-Parametern im aufgerufenen Programm sich ggf. auch auf das aufrufende Programm auswirken.

Achtung Kollisionsgefahr!

Koordinaten-Umrechnungen, die Sie im gerufenen Programm definieren und nicht gezielt zurücksetzen, bleiben grundsätzlich auch für das rufende Programm aktiv. Die Einstellung des Maschinen-Parameters MP7300 hat hierauf keinen Einfluss.


Verschachtelungen

Weitere Informationen:
> Verschachtelungsarten
> Verschachtelungstiefe
> Unterprogramm im Unterprogramm
> Programmteil-Wiederholungen wiederholen
> Unterprogramm wiederholen


Verschachtelungsarten

  • Unterprogramme im Unterprogramm
  • Programmteil-Wiederholungen in Programmteil-Wiederholung
  • Unterprogramme wiederholen
  • Programmteil-Wiederholungen im Unterprogram


Verschachtelungstiefe

Die Verschachtelungs-Tiefe legt fest, wie oft Programmteile oder Unterprogramme weitere Unterprogramme oder Programmteil-Wiederholungen enthalten dürfen.

  • Maximale Verschachtelungstiefe für Unterprogramme: 8
  • Maximale Verschachtelungstiefe für Hauptprogramm-Aufrufe: 30, wobei ein G79 wie ein Hauptprogramm-Aufruf wirkt
  • Programmteil-Wiederholungen können Sie beliebig oft verschachteln


Unterprogramm im Unterprogramm

NC-Beispielsätze
%upgms g71 * |
... |
n17 l “up1“,0 * | Unterprogramm bei G98 L UP1 wird aufgerufen
... |
n35 g00 g40 z+100 m2 * | Letzter Programmsatz des
 | Hauptprogramms (mit M2)
N36 g98 L “UP1“ | Anfang von Unterprogramm UP1
... |
n39 l2,0 * | Unterprogramm bei G98 L2 wird aufgerufen
... |
n45 g98 l0 * | Ende von Unterprogramm 1
n46 g98 l2 * | Anfang von Unterprogramm 2
... |
n62 g98 l0 * | Ende von Unterprogramm 2
n99999999 %upgms g71 * |
Programm-Ausführung
  1. Hauptprogramm UPGMS wird bis Satz 17 ausgeführt
  2. Unterprogramm UP1 wird aufgerufen und bis Satz 39 ausgeführt
  3. Unterprogramm 2 wird aufgerufen und bis Satz 62 ausgeführt. Ende von Unterprogramm 2 und Rücksprung zum Unterprogramm, von dem es aufgerufen wurde
  4. Unterprogramm 1 wird von Satz 40 bis Satz 45 ausgeführt. Ende von Unterprogramm 1 und Rücksprung ins Hauptprogramm UPGMS
  5. Hauptprogramm UPGMS wird von Satz 18 bis Satz 35 ausgeführt. Rücksprung zu Satz 1 und Programm-Ende


Programmteil-Wiederholungen wiederholen

NC-Beispielsätze
0 begin pgm reps mm |
... |
15 lbl 1 | Anfang der Programmteil-Wiederholung 1
... |
20 lbl 2 | Anfang der Programmteil-Wiederholung 2
... |
27 call lbl 2 rep 2 | Programmteil zwischen diesem Satz und LBL 2
... | (Satz 20) wird 2 mal wiederholt
35 call lbl 1 rep 1 | Programmteil zwischen diesem Satz und LBL 1
... | (Satz 15) wird 1 mal wiederholt
50 end pgm reps mm |
%reps g71 * |
... |
n15 g98 l1 * | Anfang der Programmteil-Wiederholung 1
... |
n20 g98 l2 * | Anfang der Programmteil-Wiederholung 2
... |
n27 l2,2 * | Programmteil zwischen diesem Satz und G98 L2
... | (Satz N20) wird 2 mal wiederholt
n35 l1,1 * | Programmteil zwischen diesem Satz und G98 L1
... | (Satz N15) wird 1 mal wiederholt
n99999999 %reps g71 * |
Programm-Ausführung
  1. Hauptprogramm REPS wird bis Satz 27 ausgeführt
  2. Programmteil zwischen Satz 27 und Satz 20 wird 2 mal wiederholt
  3. Hauptprogramm REPS wird von Satz 28 bis Satz 35 ausgeführt
  4. Programmteil zwischen Satz 35 und Satz 15 wird 1 mal wiederholt (beinhaltet die Programmteil-Wiederholung zwischen Satz 20 und Satz 27)
  5. Hauptprogramm REPS wird von Satz 36 bis Satz 50 ausgeführt (Programm-Ende)


Unterprogramm wiederholen

NC-Beispielsätze
%upgrep g71 * |
... |
n10 g98 l1 * | Anfang der Programmteil-Wiederholung 1
n11 l2,0 * | Unterprogramm-Aufruf
n12 l1,2 * | Programmteil zwischen diesem Satz und G98 L1
... | (Satz N10) wird 2 mal wiederholt
n19 g00 g40 z+100 m2 * | Letzter Satz des Hauptprogramms mit M2
n20 g98 l2 * | Anfang des Unterprogramms
... |
n28 g98 l0 * | Ende des Unterprogramms
n99999999 %upgrep g71 * |
Weitere Informationen:
> Programm-Ausführung


Programm-Ausführung
  1. Hauptprogramm UPGREP wird bis Satz 11 ausgeführt
  2. Unterprogramm 2 wird aufgerufen und ausgeführt
  3. Programmteil zwischen Satz 12 und Satz 10 wird 2 mal wiederholt: Unterprogramm 2 wird 2 mal wiederholt
  4. Hauptprogramm UPGREP wird von Satz 13 bis Satz 19 ausgeführt; Programm-Ende


Programmier-Beispiele

Weitere Informationen:
> Beispiel: Konturfräsen in mehreren Zustellungen
> Beispiel: Bohrungsgruppen
> Beispiel: Bohrungsgruppe mit mehreren Werkzeugen


Beispiel: Konturfräsen in mehreren Zustellungen

    Programm-Ablauf

  • Werkzeug vorpositionieren auf Oberkante Werkstück
  • Zustellung inkremental eingeben
  • Konturfräsen
  • Zustellung und Konturfräsen wiederholen
%PGMWDH G71 * |
n10 g30 g17 x+0 y+0 z-40 * |
n20 g31 g90 x+100 y+100 z+0 * |
n40 t1 g17 s3500 * | Werkzeug-Aufruf
n50 g00 g40 g90 z+250 * | Werkzeug freifahren
n60 i+50 j+50 * | Pol setzen
n70 g10 r+60 h+180 * | Vorpositionieren Bearbeitungsebene
n80 g01 z+0 f1000 m3 * | Vorpositionieren auf Oberkante Werkstück
n90 g98 l1 * | Marke für Programmteil-Wiederholung
n100 g91 z-4 * | Inkrementale Tiefen-Zustellung (im Freien)
n110 g11 g41 g90 r+45 h+180 f250 * | Erster Konturpunkt
n120 g26 r5 * | Kontur anfahren
n130 h+120 * |
n140 h+60 * |
n150 h+0 * |
n160 h-60 * |
n170 h-120 * |
n180 h+180 * |
n190 g27 r5 f500 * | Kontur verlassen
n200 g40 r+60 h+180 f1000 * | Freifahren
n210 l1,4 * | Rücksprung zu Label 1; insgesamt viermal
n220 g00 z+250 m2 * | Werkzeug freifahren, Programm-Ende
n99999999 %pgmwdh G71 * |


Beispiel: Bohrungsgruppen

    Programm-Ablauf

  • Bohrungsgruppen anfahren im Hauptprogramm
  • Bohrungsgruppe aufrufen (Unterprogramm 1)
  • Bohrungsgruppe nur einmal im Unterprogramm 1 programmieren
%UP1 G71 * |
n10 g30 g17 x+0 y+0 z-40 * |
n20 g31 g90 x+100 y+100 z+0 * |
n40 t1 g17 s3500 * | Werkzeug-Aufruf
n50 g00 g40 g90 z+250 * | Werkzeug freifahren
n60 g200 BOHREN | Zyklus-Definition Bohren
Q200=2 ;sicherheits-abst. |
Q201=-30 ;tiefe |
Q206=300 ;f tiefenzust. |
Q202=5 ;zustell-tiefe |
Q210=0 ;F.-zeit oben |
Q203=+0 ;koor. oberfl. |
Q204=2 ;2. s.-abstand |
Q211=0 ;verweilzeit unten |
n70 x+15 y+10 m3 * | Startpunkt Bohrungsgruppe 1 anfahren
n80 l1,0 * | Unterprogramm für Bohrungsgruppe rufen
n90 x+45 y+60 * | Startpunkt Bohrungsgruppe 2 anfahren
n100 l1,0 * | Unterprogramm für Bohrungsgruppe rufen
n110 x+75 y+10 * | Startpunkt Bohrungsgruppe 3 anfahren
n120 l1,0 * | Unterprogramm für Bohrungsgruppe rufen
n130 g00 z+250 m2 * | Ende des Hauptprogramms
n140 g98 l1 * | Anfang des Unterprogramms 1: Bohrungsgruppe
n150 g79 * | Zyklus aufrufen für Bohrung 1
n160 g91 x+20 m99 * | Bohrung 2 anfahren, Zyklus aufrufen
n170 y+20 m99 * | Bohrung 3 anfahren, Zyklus aufrufen
n180 x-20 g90 m99 * | Bohrung 4 anfahren, Zyklus aufrufen
n190 g98 l0 * | Ende des Unterprogramms 1
n99999999 %up1 g71 * |


Beispiel: Bohrungsgruppe mit mehreren Werkzeugen

    Programm-Ablauf

  • Bearbeitungs-Zyklen programmieren im Hauptprogramm
  • Komplettes Bohrbild aufrufen (Unterprogramm 1)
  • Bohrungsgruppen anfahren im Unterprogramm 1, Bohrungsgruppe aufrufen (Unterprogramm 2)
  • Bohrungsgruppe nur einmal im Unterprogramm 2 programmieren
%UP2 G71 * |
n10 g30 g17 x+0 y+0 z-40 * |
n20 g31 g90 x+100 y+100 z+0 * |
n60 t1 g17 s5000 * | Werkzeug-Aufruf Zentrierbohrer
n70 g00 g40 g90 z+250 * | Werkzeug freifahren
n80 g200 BOHREN | Zyklus-Definition Zentrieren
Q200=2 ;sicherheits-abst. |
Q201=-3 ;tiefe |
Q206=250 ;f tiefenzust. |
Q202=3 ;zustell-tiefe |
Q210=0 ;F.-zeit oben |
Q203=+0 ;koor. oberfl. |
Q204=10 ;2. s.-abstand |
Q211=0.2 ;verweilzeit unten |
n90 l1,0 * | Unterprogramm 1 für komplettes Bohrbild rufen
n100 g00 z+250 m6 * | Werkzeug-Wechsel
n110 t2 g17 s4000 * | Werkzeug-Aufruf Bohrer
n120 d0 q201 p01 -25 * | Neue Tiefe fürs Bohren
n130 d0 q202 p01 +5 * | Neue Zustellung fürs Bohren
n140 l1,0 * | Unterprogramm 1 für komplettes Bohrbild rufen
n150 g00 z+250 m6 * | Werkzeug-Wechsel
n160 t3 g17 s500 * | Werkzeug-Aufruf Reibahle
n80 g201 reiben | Zyklus-Definition Reiben
Q200=2 ;sicherheits-abst. |
Q201=-15 ;tiefe |
Q206=250 ;vorschub tiefenz. |
Q211=0.5 ;verweilzeit unten |
Q208=400 ;vorschub rueckzug |
Q203=+0 ;koor. oberfl. |
Q204=10 ;2. s.-abstand |
n180 l1,0 * | Unterprogramm 1 für komplettes Bohrbild rufen
n190 g00 z+250 m2 * | Ende des Hauptprogramms
n200 g98 l1 * | Anfang des Unterprogramms 1: Komplettes Bohrbild
n210 g00 g40 g90 x+15 y+10 m3 * | Startpunkt Bohrungsgruppe 1 anfahren
n220 l2,0 * | Unterprogramm 2 für Bohrungsgruppe rufen
n230 x+45 y+60 * | Startpunkt Bohrungsgruppe 2 anfahren
n240 l2,0 * | Unterprogramm 2 für Bohrungsgruppe rufen
n250 x+75 y+10 * | Startpunkt Bohrungsgruppe 3 anfahren
n260 l2,0 * | Unterprogramm 2 für Bohrungsgruppe rufen
n270 g98 l0 * | Ende des Unterprogramms 1
n280 g98 l2 * | Anfang des Unterprogramms 2: Bohrungsgruppe
n290 g79 * | Zyklus aufrufen für Bohrung 1
n300 g91 x+20 m99 * | Bohrung 2 anfahren, Zyklus aufrufen
n310 y+20 m99 * | Bohrung 3 anfahren, Zyklus aufrufen
n320 x-20 g90 m99 * | Bohrung 4 anfahren, Zyklus aufrufen
n330 g98 l0 * | Ende des Unterprogramms 2
n340 %up2 g71 * |


Programmieren: Q-Parameter

Weitere Informationen:
> Prinzip und Funktionsübersicht
> Teilefamilien – Q-Parameter statt Zahlenwerte
> Konturen durch mathematische Funktionen beschreiben
> Winkelfunktionen (Trigonometrie)
> Wenn/dann-Entscheidungen mit Q-Parametern
> Q-Parameter kontrollieren und ändern
> Zusätzliche Funktionen
> Formel direkt eingeben
> String-Parameter
> Vorbelegte Q-Parameter
> Programmier-Beispiele


Prinzip und Funktionsübersicht

Mit Parametern können Sie in einem Bearbeitungs-Programm ganze Teilefamilien definieren. Dazu geben Sie anstelle von Zahlenwerten Platzhalter ein: die Q-Parameter.

    Q-Parameter stehen beispielsweise für

  • Koordinatenwerte
  • Vorschübe
  • Drehzahlen
  • Zyklus-Daten

Außerdem können Sie mit Q-Parametern Konturen programmieren, die über mathematische Funktionen bestimmt sind oder die Ausführung von Bearbeitungsschritten von logischen Bedingungen abhängig machen.

Q-Parameter sind durch Buchstaben und eine Nummer zwischen 0 und 1999 gekennzeichnet. Es stehen Parameter mit unterschiedlicher Wirkungsweise zur Verfügung, siehe nachfolgende Tabelle:

Bedeutung | Bereich
Frei verwendbare Parameter, sofern keine Überschneidungen mit SL-Zyklen auftreten können, global für alle im TNC-Speicher befindlichen Programme wirksam | Q0 bis Q99
Parameter für Sonderfunktionen der TNC | Q100 bis Q199
Parameter, die bevorzugt für Zyklen verwendet werden, global für alle im TNC-Speicher befindlichen Programme wirksam | Q200 bis Q1199
Parameter, die bevorzugt für Hersteller-Zyklen verwendet werden, global für alle im TNC-Speicher befindlichen Programme wirksam. Ggf. Abstimmung mit Maschinenhersteller oder Drittanbieter erforderlich | Q1200 bis Q1399
Parameter, die bevorzugt für Call-Aktive Hersteller-Zyklen verwendet werden, global für alle im TNC-Speicher befindlichen Programme wirksam | Q1400 bis Q1499
Parameter, die bevorzugt für Def-Aktive Hersteller-Zyklen verwendet werden, global für alle im TNC-Speicher befindlichen Programme wirksam | Q1500 bis Q1599
Frei verwendbare Parameter, global für alle im TNC-Speicher befindlichen Programme wirksam | Q1600 bis Q1999
Frei verwendbare Parameter QL, nur lokal innerhalb eines Programmes wirksam | QL0 bis QL499
Frei verwendbare Parameter QR, dauerhaft (remanent) wirksam, auch über eine Stromunterbrechung hinaus | QR0 bis QR499

Zusätzlich stehen Ihnen auch QS-Parameter (S steht für String) zur Verfügung, mit denen Sie auf der TNC auch Texte verarbeiten können. Prinzipiell gelten für QS-Parameter dieselben Bereiche wie für Q-Parameter (siehe Tabelle oben).

Beachten Sie, dass auch bei den QS-Parametern der Bereich QS100 bis QS199 für interne Texte reserviert ist.

Weitere Informationen:
> Programmierhinweise
> Q-Parameter-Funktionen aufrufen


Programmierhinweise

Q-Parameter und Zahlenwerte dürfen Sie in ein Programm gemischt eingeben.Sie können Q-Parametern Zahlenwerte zwischen –999 999 999 und +999 999 999 zuweisen, insgesamt sind also inclusive Vorzeichen 10 Stellen erlaubt. Das Dezimalkomma können Sie an beliebiger Stelle setzen. Intern kann die TNC Zahlenwerte bis zu einer Breite von 57 Bit vor und bis zu 7 Bit nach dem Dezimalpunkt berechnen (32 bit Zahlenbreite entsprechen einem Dezimalwert von 4 294 967 296).

QS-Parametern können Sie maximal 254 Zeichen zuweisen.

Die TNC weist einigen Q- und QS-Parametern selbsttätig immer die gleichen Daten zu, z.B. dem Q-Parameter Q108 den aktuellen Werkzeug-Radius, siehe Vorbelegte Q-Parameter.

Wenn Sie die Parameter Q60 bis Q99 in verschlüsselten Hersteller-Zyklen verwenden, legen Sie über den Maschinen-Parameter MP7251 fest, ob diese Parameter nur lokal im Hersteller-Zyklus (.CYC-File) wirken oder global für alle Programme.

Mit dem Maschinen-Parameter 7300 legen Sie fest, ob die TNC Q-Parameter am Programmende zurücksetzen soll, oder ob die Werte erhalten bleiben sollen. Darauf achten, dass diese Einstellung keine Auswirkung auf Ihre Q-Parameter-Programme hat!

Die TNC speichert Zahlenwerte intern in einem binären Zahlenformat (Norm IEEE 754). Durch die Verwendung dieses genormten Formats können manche Dezimalzahlen nicht zu 100% exakt binär dargestellt werden (Rundungsfehler). Beachten Sie diesen Umstand insbesondere dann, wenn Sie, berechnete Q-Parameter-Inhalte bei Sprungbefehlen oder Positionierungen verwenden.


Q-Parameter-Funktionen aufrufen

Während Sie ein Bearbeitungsprogramm eingeben, drücken Sie die Taste „Q“ (im Feld für Zahlen-Eingaben und Achswahl unter –/+ -Taste). Dann zeigt die TNC folgende Softkeys:

Funktionsgruppe | Softkey | Seite
Mathematische Grundfunktionen |  | Konturen durch mathematische Funktionen beschreiben
Winkelfunktionen |  | Winkelfunktionen (Trigonometrie)
Wenn/dann-Entscheidungen, Sprünge |  | Wenn/dann-Entscheidungen mit Q-Parametern
Sonstige Funktionen |  | Zusätzliche Funktionen
Formel direkt eingeben |  | Formel direkt eingeben
Funktion zur Bearbeitung komplexer Konturen |  | Zyklen-Handbuch
Funktion zur String-Verarbeitung |  | String-Parameter

Wenn Sie auf der ASCII-Tastatur die Taste Q betätigen, dann öffnet die TNC den Dialog zur Formeleingabe direkt.

Um lokale Parameter Ql zu definieren oder zuzweisen, in einem beliebigen Dialog zunächst die Taste Q und anschließend die Taste L auf der ASCII-Tastatur betätigen.

Um remanente Parameter QR zu definieren oder zuzweisen, in einem beliebigen Dialog zunächst die Taste Q und anschließend die Taste R auf der ASCII-Tastatur betätigen.


Teilefamilien – Q-Parameter statt Zahlenwerte

Weitere Informationen:
> Anwendung


Anwendung

Mit der Q-Parameter-Funktion d0: ZUWEISUNG können Sie Q-Parametern Zahlenwerte zuweisen. Dann setzen Sie im Bearbeitungs-Programm statt dem Zahlenwert einen Q-Parameter ein.

NC-Beispielsätze
N150 D00 Q10 P01 +25 * | Zuweisung
... | Q10 erhält den Wert 25
N250 G00 X +Q10 * | entspricht G00 X +25

Für Teilefamilien programmieren Sie z.B. die charakteristischen Werkstück-Abmessungen als Q-Parameter.

Für die Bearbeitung der einzelnen Teile weisen Sie dann jedem dieser Parameter einen entsprechenden Zahlenwert zu.

Beispiel

Zylinder mit Q-Parametern

Zylinder-Radius | R = Q1
Zylinder-Höhe | H = Q2
Zylinder Z1 | Q1 = +30 Q2 = +10
Zylinder Z2 | Q1 = +10 Q2 = +50


Konturen durch mathematische Funktionen beschreiben

Weitere Informationen:
> Anwendung
> Übersicht
> Grundrechenarten programmieren


Anwendung

Mit Q-Parametern können Sie mathematische Grundfunktionen im Bearbeitungsprogramm programmieren:

  • Q-Parameter-Funktion wählen: Taste Q drücken (im Feld für Zahlen-Eingabe, rechts). Die Softkey-Leiste zeigt die Q-Parameter-Funktionen

  • Mathematische Grundfunktionen wählen: Softkey GRUNDFUNKT. drücken. Die TNC zeigt folgende Softkeys:


Übersicht

Funktion | Softkey
D00: ZUWEISUNG z.B. D00 Q5 P01 +60 * Wert direkt zuweisen |
D01: ADDITION z.B. D01 Q1 P01 -Q2 P02 -5 * Summe aus zwei Werten bilden und zuweisen |
D02: SUBTRAKTION z.B. D02 Q1 P01 +10 P02 +5 * Differenz aus zwei Werten bilden und zuweisen |
D03: MULTIPLIKATION z.B. D03 Q2 P01 +3 P02 +3 * Produkt aus zwei Werten bilden und zuweisen |
D04: DIVISION z.B. D04 Q4 P01 +8 P02 +Q2 * Quotient aus zwei Werten bilden und zuweisen Verboten: Division durch 0! |
D05: WURZEL z.B. D05 Q50 P01 4 * Wurzel aus einer Zahl ziehen und zuweisen Verboten: Wurzel aus negativem Wert! |

    Rechts vom „=“-Zeichen dürfen Sie eingeben:

  • zwei Zahlen
  • zwei Q-Parameter
  • eine Zahl und einen Q-Parameter

Die Q-Parameter und Zahlenwerte in den Gleichungen können Sie beliebig mit Vorzeichen versehen.


Grundrechenarten programmieren

Beispiel: Programmsätze in der TNC
N17 D00 q5 P01 +10 *
N17 D03 Q12 P01 +Q5 P02 +7 *

Beispiel:

 | Q-Parameter-Funktionen wählen: Taste Q drücken
 | Mathematische Grundfunktionen wählen: Softkey GRUNDFUNKT. drücken
 | Q-Parameter-Funktion ZUWEISUNG wählen: Softkey d0 X = Y drücken
Parameter-Nr. für Ergebnis?
 | Nummer des Q- Parameters eingeben: 5
1. Wert oder Parameter?
 | Q5 den Zahlenwert 10 zuweisen
 | Q-Parameter-Funktionen wählen: Taste Q drücken
 | Mathematische Grundfunktionen wählen: Softkey GRUNDFUNKT. drücken
 | Q-Parameter-Funktion MULTIPLIKATION wählen: Softkey d3 X * Y drücken
Parameter-Nr. für Ergebnis?
 | Nummer des Q- Parameters eingeben: 12
1. Wert oder Parameter?
 | Q5 als ersten Wert eingeben
2. Wert oder Parameter?
 | 7 als zweiten Wert eingeben


Winkelfunktionen (Trigonometrie)

Weitere Informationen:
> Definitionen
> Winkelfunktionen programmieren


Definitionen

Sinus, Cosinus und Tangens entsprechen den Seitenverhältnissen eines rechtwinkligen Dreiecks. Dabei entspricht

Sinus: | sin α = a / c
Cosinus: | cos α = b / c
Tangens: | tan α = a / b = sin α / cos α

    Dabei ist

  • c die Seite gegenüber dem rechten Winkel
  • a die Seite gegenüber dem Winkel α
  • b die dritte Seite

Aus dem Tangens kann die TNC den Winkel ermitteln:

α = arctan (a / b) = arctan (sin α / cos α)

Beispiel:

a = 25 mm

b = 50 mm

α = arctan (a / b) = arctan 0,5 = 26,57°

Zusätzlich gilt:

a² + b² = c² (mit a² = a x a)


Winkelfunktionen programmieren

Die Winkelfunktionen erscheinen mit Druck auf den Softkey WINKEL---FUNKT. Die TNC zeigt die Softkeys in der Tabelle unten.

Programmierung: vergleiche „Beispiel: Grundrechenarten programmieren“

Funktion | Softkey
D06: SINUS z.B. D06 Q20 P01 -Q5 * Sinus eines Winkels in Grad (°) bestimmen und zuweisen |
D07: COSINUS z.B. D07 Q21 P01 -Q5 * Cosinus eines Winkels in Grad (°) bestimmen und zuweisen |
D08: WURZEL AUS QUADRATSUMME z.B. D08 Q10 P01 +5 P02 +4 * Länge aus zwei Werten bilden und zuweisen |
D13: WINKEL z.B. D13 Q20 P01 +10 P02 -Q1 * Winkel mit arctan aus zwei Seiten oder sin und cos des Winkels (0 < Winkel < 360°) bestimmen und zuweisen |


Wenn/dann-Entscheidungen mit Q-Parametern

Weitere Informationen:
> Anwendung
> Unbedingte Sprünge
> Wenn/dann-Entscheidungen programmieren


Anwendung

Bei Wenn/Dann-Entscheidungen vergleicht die TNC einen Q-Parameter mit einem anderen Q-Parameter oder einem Zahlenwert. Wenn die Bedingung erfüllt ist, dann setzt die TNC das Bearbeitungs-Programm an dem Label fort, der hinter der Bedingung programmiert ist (Label siehe Unterprogramme und Programmteil-Wiederholungen kennzeichnen). Wenn die Bedingung nicht erfüllt ist, dann führt die TNC den nächsten Satz aus.

Wenn Sie ein anderes Programm als Unterprogramm aufrufen möchten, dann programmieren Sie hinter dem Label einen Programm-Auruf mit %.


Unbedingte Sprünge

Unbedingte Sprünge sind Sprünge, deren Bedingung immer (=unbedingt) erfüllt ist, z.B.

D09 P01 +10 P02 +10 P03 1 *


Wenn/dann-Entscheidungen programmieren

    Zur Eingabe der Sprungadresse stehen 3 Möglichkeiten zur Verfügung:

  • Label-Nummer, über Softkey LBL-Nummer wählbar
  • Label-Name, über Softkey lbl-name wählbar
  • String-Parameter, über Softkey QS wählbar

Die Wenn/dann-Entscheidungen erscheinen mit Druck auf den Softkey SPRÜNGE. Die TNC zeigt folgende Softkeys:

Funktion | Softkey
D09: WENN GLEICH, SPRUNG z.B. D09 P01 +Q1 P02 +Q3 P03 “UPCAN25“ * Wenn beide Werte oder Parameter gleich, Sprung zu angegebenem Label |
D10: WENN UNGLEICH, SPRUNG z.B. D10 P01 +10 P02 -Q5 P03 10 * Wenn beide Werte oder Parameter ungleich, Sprung zu angegebenem Label |
D11: WENN GROESSER, SPRUNG z.B. D11 P01 +Q1 P02 +10 P03 QS5 * Wenn erster Wert oder Parameter größer als zweiter Wert oder Parameter, Sprung zu angegebenem Label |
D12: WENN KLEINER, SPRUNG z.B. D12 P01 +Q5 P02 +0 P03 “ANYNAME“ * Wenn erster Wert oder Parameter kleiner als zweiter Wert oder Parameter, Sprung zu angegebenem Label |


Q-Parameter kontrollieren und ändern

Weitere Informationen:
> Vorgehensweise


Vorgehensweise

Sie können Q-Parameter beim Erstellen, Testen und Abarbeiten in den Betriebsarten Programm Einspeichern/Editieren, Programm Test, Programmlauf Satzfolge und Programmlauf Einzelsatz kontrollieren und auch ändern.

  • Ggf. Programmlauf abbrechen (z.B. externe STOPP-Taste und Softkey INTERNER STOPP drücken) bzw. Programm-Test anhalten

Q-Parameter-Funktionen aufrufen: Taste Q bzw. Softkey Q INFO in der Betriebsart Programm Einspeichern/Editieren drücken

Die TNC listet alle Parameter und die dazugehörigen aktuellen Werte auf. Wählen Sie mit den Pfeil-Tasten oder den Softkeys zum seitenweise Blättern den gewünschten Parameter an

Wenn Sie den Wert ändern möchten, geben Sie einen neuen Wert ein, bestätigen Sie mit der Taste ENT

Wenn Sie den Wert nicht ändern möchten, dann -drücken Sie den Softkey AKTUELLEN WERT oder beenden Sie den Dialog mit der Taste END

Von der TNC in Zyklen oder intern verwendete Parameter, sind mit Kommentaren versehen.

Wenn Sie lokale, globale oder String-Parameter kontrollieren oder ändern wollen, drücken Sie den Softkey parameter anzeigen q QL QR qs. Die TNC stellt dann alle jeweiligen Parameter dar, die zuvor beschriebenen Funktionen gelten ebenso.


Zusätzliche Funktionen

Weitere Informationen:
> Übersicht
> D14: ERROR: Fehlermeldungen ausgeben
> D15 PRINT: Texte oder Q-Parameter-Werte ausgeben
> D19 PLC: Werte an PLC übergeben


Übersicht

Die zusätzlichen Funktionen erscheinen mit Druck auf den Softkey SONDER-FUNKT. Die TNC zeigt folgende Softkeys:

Funktion | Softkey | Seite
D14:ERROR Fehlermeldungen ausgeben |  | D14: ERROR: Fehlermeldungen ausgeben
D15:PRINT Texte oder Q-Parameter-Werte unformatiert ausgeben |  | D15 PRINT: Texte oder Q-Parameter-Werte ausgeben
D19:PLC Werte an die PLC übergeben |  | D19 PLC: Werte an PLC übergeben


D14: ERROR: Fehlermeldungen ausgeben

Mit der Funktion d14 können Sie programmgesteuert Meldungen ausgeben lassen, die vom Maschinenhersteller bzw. von -HEIDENHAIN vorgegeben sind: Wenn die TNC im Programmlauf oder Programm-Test zu einem Satz mit d14 kommt, so unterbricht sie und gibt eine Meldung aus. Anschließend müssen Sie das Programm neu starten. Fehler-Nummern: siehe Tabelle unten.

Bereich Fehler-Nummern | Standard-Dialog
0 ... 299 | FN 14: Fehler-Nummer 0 .... 299
300 ... 999 | Maschinenabhängiger Dialog
1000 ... 1099 | Interne Fehlermeldungen (siehe Tabelle rechts)
NC-Beispielsatz

Die TNC soll eine Meldung ausgeben, die unter der Fehler-Nummer 254 gespeichert ist

N180 D14 P01 254 *
Von HEIDENHAIN vorbelegte Fehlermeldung
Fehler-Nummer | Text
1000 | Spindel?
1001 | Werkzeugachse fehlt
1002 | Werkzeug-Radius zu klein
1003 | Werkzeug-Radius zu groß
1004 | Bereich überschritten
1005 | Anfangs-Position falsch
1006 | DREHUNG nicht erlaubt
1007 | MASSFAKTOR nicht erlaubt
1008 | SPIEGELUNG nicht erlaubt
1009 | Verschiebung nicht erlaubt
1010 | Vorschub fehlt
1011 | Eingabewert falsch
1012 | Vorzeichen falsch
1013 | Winkel nicht erlaubt
1014 | Antastpunkt nicht erreichbar
1015 | Zu viele Punkte
1016 | Eingabe widersprüchlich
1017 | CYCL unvollständig
1018 | Ebene falsch definiert
1019 | Falsche Achse programmiert
1020 | Falsche Drehzahl
1021 | Radius-Korrektur undefiniert
1022 | Rundung nicht definiert
1023 | Rundungs-Radius zu groß
1024 | Undefinierter Programmstart
1025 | Zu hohe Verschachtelung
1026 | Winkelbezug fehlt
1027 | Kein Bearb.-Zyklus definiert
1028 | Nutbreite zu klein
1029 | Tasche zu klein
1030 | Q202 nicht definiert
1031 | Q205 nicht definiert
1032 | Q218 größer Q219 eingeben
1033 | CYCL 210 nicht erlaubt
1034 | CYCL 211 nicht erlaubt
1035 | Q220 zu groß
1036 | Q222 größer Q223 eingeben
1037 | Q244 größer 0 eingeben
1038 | Q245 ungleich Q246 eingeben
1039 | Winkelbereich < 360° eingeben
1040 | Q223 größer Q222 eingeben
1041 | Q214: 0 nicht erlaubt
1042 | Verfahrrichtung nicht definiert
1043 | Keine Nullpunkt-Tabelle aktiv
1044 | Lagefehler: Mitte 1. Achse
1045 | Lagefehler: Mitte 2. Achse
1046 | Bohrung zu klein
1047 | Bohrung zu groß
1048 | Zapfen zu klein
1049 | Zapfen zu groß
1050 | Tasche zu klein: Nacharbeit 1.A.
1051 | Tasche zu klein: Nacharbeit 2.A.
1052 | Tasche zu groß: Ausschuss 1.A.
1053 | Tasche zu groß: Ausschuss 2.A.
1054 | Zapfen zu klein: Ausschuss 1.A.
1055 | Zapfen zu klein: Ausschuss 2.A.
1056 | Zapfen zu groß: Nacharbeit 1.A.
1057 | Zapfen zu groß: Nacharbeit 2.A.
1058 | TCHPROBE 425: Fehler Größtmaß
1059 | TCHPROBE 425: Fehler Kleinstmaß
1060 | TCHPROBE 426: Fehler Größtmaß
1061 | TCHPROBE 426: Fehler Kleinstmaß
1062 | TCHPROBE 430: Durchm. zu groß
1063 | TCHPROBE 430: Durchm. zu klein
1064 | Keine Messachse definiert
1065 | Werkzeug-Bruchtoleranz überschr.
1066 | Q247 ungleich 0 eingeben
1067 | Betrag Q247 größer 5 eingeben
1068 | Nullpunkt-Tabelle?
1069 | Fräsart Q351 ungleich 0 eingeben
1070 | Gewindetiefe verringern
1071 | Kalibrierung durchführen
1072 | Toleranz überschritten
1073 | Satzvorlauf aktiv
1074 | ORIENTIERUNG nicht erlaubt
1075 | 3DROT nicht erlaubt
1076 | 3DROT aktivieren
1077 | Tiefe negativ eingeben
1078 | Q303 im Messzyklus undefiniert!
1079 | Werkzeugachse nicht erlaubt
1080 | Berechnete Werte fehlerhaft
1081 | Messpunkte widersprüchlich
1082 | Sichere Höhe falsch eingegeben
1083 | Eintauchart widersprüchlich
1084 | Bearbeitungszyklus nicht erlaubt
1085 | Zeile ist schreibgeschützt
1086 | Aufmaß größer als Tiefe
1087 | Kein Spitzenwinkel definiert
1088 | Daten widersprüchlich
1089 | Nutlage 0 nicht erlaubt
1090 | Zustellung ungleich 0 eingeben
1091 | Umschaltung Q399 nicht erlaubt
1092 | Werkzeug nicht definiert
1093 | Werkzeug-Nummer nicht erlaubt
1094 | Werkzeug-Name nicht erlaubt
1095 | Software-Option nicht aktiv
1096 | Restore Kinematik nicht möglich
1097 | Funktion nicht erlaubt
1098 | Rohteilmaße widersprüchlich
1099 | Messposition nicht erlaubt
1100 | Kinematik-Zugriff nicht möglich
1101 | Messpos. nicht im Verfahrbereich
1102 | Presetkompensation nicht möglich


D15 PRINT: Texte oder Q-Parameter-Werte ausgeben

Datenschnittstelle einrichten: Im Menüpunkt PRINT bzw. PRINT-TEST legen Sie den Pfad fest, auf dem die TNC die Texte oder Q-Parameter-Werte speichern soll. Siehe Zuweisung.

Mit der Funktion D15 können Sie Werte von Q-Parametern und Fehlermeldungen über die Datenschnittstelle ausgeben, zum Beispiel an einen Drucker. Wenn Sie die Werte intern abspeichern oder an einen Rechner ausgeben, speichert die TNC die Daten in der Datei %FN 15RUN.A (Ausgabe während des Programmlaufs) oder in der Datei %FN15SIM.A (Ausgabe während des Programm-Tests).

Die Ausgabe erfolgt gepuffert und wird spätestens am PGM-Ende, oder wenn Sie das PGM anhalten, ausgelöst. In der Betriebsart Einzelsatz startet die Datenübertragung am Satzende.

Dialoge und Fehlermeldung ausgeben mit FN 15: PRINT „Zahlenwert“
Zahlenwert 0 bis 99: | Dialoge für Hersteller-Zyklen
ab 100: | PLC-Fehlermeldungen
Beispiel: Dialog-Nummer 20 ausgeben
N67 D15 P01 20 *
Dialoge und Q-Parameter ausgeben mit D15 PRINT „Q-Parameter“

Anwendungsbeispiel: Protokollieren einer Werkstück-Vermessung.

Sie können bis zu sechs Q-Parameter und Zahlenwerte gleichzeitig ausgeben. Die TNC trennt diese mit Schrägstrichen.

Beispiel: Dialog 1 und Zahlenwert Q1 ausgeben
N70 D15 P01 1 P02 Q1 *


D19 PLC: Werte an PLC übergeben

Mit der Funktion d19 können Sie bis zu zwei Zahlenwerte oder Q-Parameter an die PLC übergeben.

Schrittweiten und Einheiten: 0,1 µm bzw. 0,0001°

Beispiel: Zahlenwert 10 (entspricht 1µm bzw. 0,001°) an PLC übergeben
N56 D19 P01 +10 P02 +Q3 *


Formel direkt eingeben

Weitere Informationen:
> Formel eingeben
> Rechenregeln
> Eingabe-Beispiel


Formel eingeben

Über Softkeys können Sie mathematische Formeln, die mehrere Rechenoperationen beinhalten, direkt ins Bearbeitungs-Programm eingeben.

Die mathematischen Verknüpfungs-Funktionen erscheinen mit Druck auf den Softkey FORMEL. Die TNC zeigt folgende Softkeys in mehreren Leisten:

Verknüpfungs-Funktion | Softkey
Addition z.B. Q10 = Q1 + Q5 |
Subtraktion z.B. Q25 = Q7 – Q108 |
Multiplikation z.B. Q12 = 5 * Q5 |
Division z.B. Q25 = Q1 / Q2 |
Klammer auf z.B. Q12 = Q1 * (Q2 + Q3) |
Klammer zu z.B. Q12 = Q1 * (Q2 + Q3) |
Wert quadrieren (engl. square) z.B. Q15 = SQ 5 |
Wurzel ziehen (engl. square root) z.B. Q22 = SQRT 25 |
Sinus eines Winkels z.B. Q44 = SIN 45 |
Cosinus eines Winkels z.B. Q45 = COS 45 |
Tangens eines Winkels z.B. Q46 = TAN 45 |
Arcus-Sinus Umkehrfunktion des Sinus; Winkel bestimmen aus dem Verhältnis Gegenkathete/Hypotenuse z.B. Q10 = ASIN 0,75 |
Arcus-Cosinus Umkehrfunktion des Cosinus; Winkel bestimmen aus dem Verhältnis Ankathete/Hypotenuse z.B. Q11 = ACOS Q40 |
Arcus-Tangens Umkehrfunktion des Tangens; Winkel bestimmen aus dem Verhältnis Gegenkathete/Ankathete z.B. Q12 = ATAN Q50 |
Werte potenzieren z.B. Q15 = 3^3 |
Konstante Pl (3,14159) z.B. Q15 = PI |
Logarithmus Naturalis (LN) einer Zahl bilden Basiszahl 2,7183 z.B. Q15 = LN Q11 |
Logarithmus einer Zahl bilden, Basiszahl 10 z.B. Q33 = LOG Q22 |
Exponentialfunktion, 2,7183 hoch n z.B. Q1 = EXP Q12 |
Werte negieren (Multiplikation mit -1) z.B. Q2 = NEG Q1 |
Nachkomma-Stellen abschneiden Integer-Zahl bilden z.B. Q3 = INT Q42 |
Absolutwert einer Zahl bilden z.B. Q4 = ABS Q22 |
Vorkomma-Stellen einer Zahl abschneiden Fraktionieren z.B. Q5 = FRAC Q23 |
Vorzeichen einer Zahl prüfen z.B. Q12 = SGN Q50 Wenn Rückgabewert Q12 = 1, dann Q50 >= 0 Wenn Rückgabewert Q12 = -1, dann Q50 < 0 |
Modulowert (Divisionsrest) berechnen z.B. Q12 = 400 % 360 Ergebnis: Q12 = 40 |


Rechenregeln

Für das Programmieren mathematischer Formeln gelten folgende Regeln:

Punkt- vor Strichrechnung
12 Q1 = 5 * 3 + 2 * 10 = 35
  1. Rechenschritt 5 * 3 = 15
  2. Rechenschritt 2 * 10 = 20
  3. Rechenschritt 15 + 20 = 35
oder
13 Q2 = SQ 10 - 3^3 = 73
  1. Rechenschritt 10 quadrieren = 100
  2. Rechenschritt 3 mit 3 potenzieren = 27
  3. Rechenschritt 100 – 27 = 73
Distributivgesetz

Gesetz der Verteilung beim Klammerrechnen a * (b + c) = a * b + a * c


Eingabe-Beispiel

Winkel berechnen mit arctan aus Gegenkathete (Q12) und Ankathete (Q13); Ergebnis Q25 zuweisen:

 | Formel-Eingabe wählen: Taste Q und Softkey FORMEL drücken, oder Schnelleinstieg nutzen:
 | Q-Taste auf der ASCII-Tastatur drücken
Parameter-Nr. für Ergebnis?
 | Parameter-Nummer eingeben
 | Softkey-Leiste weiterschalten und Arcus-Tangens-Funktion wählen
 | Softkey-Leiste weiterschalten und Klammer öffnen
 | Q-Parameter Nummer 12 eingeben
 | Division wählen
 | Q-Parameter Nummer 13 eingeben
 | Klammer schließen und Formel-Eingabe beenden
NC-Beispielsatz
37 Q25 = ATAN (Q12/Q13)


String-Parameter

Weitere Informationen:
> Funktionen der Stringverarbeitung
> String-Parameter zuweisen
> String-Parameter verketten
> Numerischen Wert in einen String-Parameter umwandeln
> Teilstring aus einem String-Parameter kopieren
> Systemdaten in einen String-Parameter kopieren
> String-Parameter in einen numerischen Wert umwandeln
> Prüfen eines String-Parameters
> Länge eines String-Parameters ermitteln
> Alphabetische Reihenfolge vergleichen


Funktionen der Stringverarbeitung

Die Stringverarbeitung (engl. string = Zeichenkette) über QS-Parameter können Sie verwenden, um variable Zeichenketten zu erstellen.

Einem String-Parametern können Sie eine Zeichenkette (Buchstaben, Ziffern, Sonderzeichen, Steuerzeichen und Leerzeichen) mit einer Länge von bis zu 256 Zeichen zuweisen. Die zugewiesenen bzw.eingelesenen Werte können Sie mit den nachfolgend beschriebenen Funktionen weiter verarbeiten und überprüfen. Wie bei der Q-Parameter-Programmierung stehen Ihnen insgesamt 2000 QS-Parameter zur Verfügung (siehe auch Prinzip und Funktionsübersicht).

In den Q-Parameter-Funktionen STRING FORMEL und FORMEL sind unterschiedliche Funktionen für die Verarbeitung von String-Parametern enthalten.

Funktionen der String Formel | Softkey | Seite
String-Parameter zuweisen |  | String-Parameter zuweisen
String-Parameter verketten |  | String-Parameter verketten
Numerischen Wert in einen String-Parameter umwandeln |  | Numerischen Wert in einen String-Parameter umwandeln
Teilstring aus einem String-Parameter kopieren |  | Teilstring aus einem String-Parameter kopieren
Systemdaten in einen String-Parameter kopieren |  | Systemdaten in einen String-Parameter kopieren
String-Funktionen in der Formel-Funktion | Softkey | Seite
String-Parameter in einen numerischen Wert umwandeln |  | String-Parameter in einen numerischen Wert umwandeln
Prüfen eines String-Parameters |  | Prüfen eines String-Parameters
Länge eines String-Parameters ermitteln |  | Länge eines String-Parameters ermitteln
Alphabetische Reihenfolge vergleichen |  | Alphabetische Reihenfolge vergleichen

Wenn Sie die Funktion STRING FORMEL verwenden, ist das Ergebnis der durchgeführten Rechenoperation immer ein String. Wenn Sie die Funktion FORMEL verwenden, ist das Ergebnis der durchgeführten Rechenoperation immer ein numerischen Wert.


String-Parameter zuweisen

Bevor Sie String-Variablen verwenden, müssen Sie diese zuerst zuweisen. Dazu verwenden Sie den Befehl DECLARE STRING.

Softkey-Leiste mit Sonderfunktionen einblenden

Menü für Funktionen zur Definition verschiedener Klartext-Funktionen wählen

String-Funktionen wählen

Funktion DECLARE STRING wählen

NC-Beispielsatz:
n37 DECLARE STRING QS10 = "Werkstück"


String-Parameter verketten

Mit dem Verkettungsoperator (String-Parameter || String-Parameter) können Sie mehrere String-Parameter miteinander verbinden.

Softkey-Leiste mit Sonderfunktionen einblenden

Menü für Funktionen zur Definition verschiedener Klartext-Funktionen wählen

String-Funktionen wählen

Funktion string-formel wählen

Nummer des String-Parameters eingeben, in den die TNC den verketteten String speichern soll, mit Taste ent bestätigen

Nummer des String-Parameters eingeben, in dem der erste Teilstring gespeichert ist, mit Taste ent bestätigen: Die TNC zeigt das Verkettungs-Symbol || an

Mit Taste ent bestätigen

Nummer des String-Parameters eingeben, in dem der zweite Teilstring gespeichert ist, mit Taste ent bestätigen

Vorgang widerholen, bis Sie alle zu verkettenden Teilstrings gewählt haben, mit Taste end beenden

Beispiel: QS10 soll den kompletten Text von QS12, QS13 und QS14 enthalten
n37 QS10 = QS12 || QS13 || QS14

    Parameter-Inhalte:

  • QS12: Werkstück
  • QS13: Status:
  • QS14: Ausschuss
  • QS10: Werkstück Status: Ausschuss


Numerischen Wert in einen String-Parameter umwandeln

Mit der Funktion TOCHAR wandelt die TNC einen numerischen Wert in einen String-Parameter um. Auf diese Weise können Sie Zahlenwerte mit Stringvariablen verketten.

Q-Parameter-Funktionen wählen

Funktion string-formel wählen

Funktion zum Umwandeln eines numerischen Wertes in einen String-Parameter wählen

Zahl oder gewünschten Q-Parameter eingeben, den die TNC wandeln soll, mit Taste ENT bestätigen

Wenn gewünscht die Anzahl der Nachkommastellen eingeben, die die TNC mit umwandeln soll, mit Taste ent bestätigen

Klammerausdruck mit Taste ent schließen und Eingabe mit Taste end beenden

Beispiel: Parameter Q50 in String-Parameter QS11 umwandeln, 3 Dezimalstellen verwenden
n37 QS11 = TOCHAR ( DAT+Q50 DECIMALS3 )


Teilstring aus einem String-Parameter kopieren

Mit der Funktion SUBSTR können Sie aus einem String-Parameter einen definierbaren Bereich herauskopieren.

Q-Parameter-Funktionen wählen

Funktion string-formel wählen

Nummer des Parameters eingeben, in den die TNC die kopierte Zeichenfolge speichern soll, mit Taste ent bestätigen

Funktion zum Ausschneiden eines Teilstrings wählen

Nummer des QS-Parameters eingeben, aus dem Sie den Teilstring herauskopieren wollen, mit Taste ENT bestätigen

Nummer der Stelle eingeben, ab der Sie den Teilstring kopieren wollen, mit Taste ent bestätigen

Anzahl der Zeichen eingeben, die Sie kopieren wollen, mit Taste ent bestätigen

Klammerausdruck mit Taste ent schließen und Eingabe mit Taste end beenden

Darauf achten, dass das erste Zeichen einer Textfolge intern an der 0. Stelle beginnt.
Beispiel: Aus dem String-Parameter QS10 ist ab der dritten Stelle (BEG2) ein vier Zeichen langer Teilstring (LEN4) zu lesen
n37 QS13 = SUBSTR ( SRC_QS10 BEG2 LEN4 )


Systemdaten in einen String-Parameter kopieren

Mit der Funktion sysstr können Sie Systemdaten in einen String-Parameter kopieren. Momentan steht nur das Auslesen der aktuellen Systemzeit zur Verfügung:

Q-Parameter-Funktionen wählen

Funktion string-formel wählen

Nummer des Parameters eingeben, in den die TNC die kopierte Zeichenfolge speichern soll, mit Taste ent bestätigen

Funktion zum Kopieren von Systemdaten wählen

Nummer des Systemschlüssels, für die Systemzeit ID321 eingeben, den Sie kopieren wollen, mit Taste ENT bestätigen

Index zu Systemschlüssel eingeben. Definiert das Format der auszulessenden Systemzeit, mit Taste ent bestätigen (siehe Beschreibung weiter unten)

Arrayindex der zu lesenden Quelle hat momentan keine Funktion, mit Taste NO ENT bestätigen

Zahl, die in Text zu wandeln ist, hat momentan keine Funktion, mit Taste NO ENT bestätigen

Klammerausdruck mit Taste ent schließen und Eingabe mit Taste end beenden

Diese Funktion ist für zukünftige Erweiterungen vorbereitet. Die Parameter IDX und DAT haben momentan keine Funktion.

    Für die Formatierung des Datums können Sie folgende Formate verwenden:

  • 00: TT.MM.JJJJ hh:mm:ss
  • 01: T.MM.JJJJ h:mm:ss
  • 02: T.MM.JJJJ h:mm
  • 03: T.MM.JJ h:mm
  • 04: JJJJ-MM-TT- hh:mm:ss
  • 05: JJJJ-MM-TT hh:mm
  • 06: JJJJ-MM-TT h:mm
  • 07: JJ-MM-TT h:mm
  • 08: TT.MM.JJJJ
  • 09: T.MM.JJJJ
  • 10: T.MM.JJ
  • 11: JJJJ-MM-TT
  • 12: JJ-MM--TT
  • 13: hh:mm:ss
  • 14: h:mm:ss
  • 15: h:mm
Beispiel: Aktuelle Systemzeit im Format TT.MM.JJJJ hh:mm:ss auslesen und im Parameter QS13 ablegen.
N70 QS13 = sysstr ( id321 nr0)


String-Parameter in einen numerischen Wert umwandeln

Die Funktion TONUMB wandelt einen String-Parameter in einen numerischen Wert um. Der umzuwandelnde Wert sollte nur aus Zahlenwerten bestehen.

Der umzuwandelnde QS-Parameter darf nur einen Zahlenwert enthalten, ansonsten gibt die TNC eine Fehlermeldung aus.

Q-Parameter-Funktionen wählen

Funktion formel wählen

Nummer des Parameters eingeben, in den die TNC den numerischen Wert speichern soll, mit Taste ent bestätigen

Softkey-Leiste umschalten

Funktion zum Umwandeln eines String-Parameters in einen numerischen Wert wählen

Nummer des QS-Parameters eingeben, den die TNC wandeln soll, mit Taste ENT bestätigen

Klammerausdruck mit Taste ent schließen und Eingabe mit Taste end beenden

Beispiel: String-Parameter QS11 in einen numerischen Parameter Q82 umwandeln
n37 Q82 = TONUMB ( SRC_QS11 )


Prüfen eines String-Parameters

Mit der Funktion INSTR können Sie überprüfen, ob bzw. wo ein String-Parameter in einem anderen String-Parameter enthalten ist.

Q-Parameter-Funktionen wählen

Funktion formel wählen

Nummer des Q-Parameters eingeben, in den die TNC die Stelle speichern soll, an der der zu suchende Text beginnt, mit Taste ent bestätigen

Softkey-Leiste umschalten

Funktion zum Prüfen eines String-Parameters wählen

Nummer des QS-Parameters eingeben, in dem der zu suchende Text gespeichert ist, mit Taste ENT bestätigen

Nummer des QS-Parameters eingeben, den die TNC durchsuchen soll, mit Taste ENT bestätigen

Nummer der Stelle eingeben, ab der die TNC den Teilstring suchen soll, mit Taste ent bestätigen

Klammerausdruck mit Taste ent schließen und Eingabe mit Taste end beenden

Darauf achten, dass das erste Zeichen einer Textfolge intern an der 0. Stelle beginnt.

Wenn die TNC den zu suchenden Teilstring nicht findet, dann speichert sie die Gesamtlänge des zu durchsuchenden Strings (Zählung beginnt hier bei 1) in den Ergebnis-Parameter.

Tritt der zu suchende Teilstring mehrfach auf, dann liefert die TNC die erste Stelle zurück, an der Sie den Teilstring findet.
Beispiel: QS10 durchsuchen auf den in Parameter QS13 gespeicherten Text. Suche ab der dritten Stelle beginnen
n37 Q50 = INSTR ( SRC_QS10 SEA_QS13 BEG2 )


Länge eines String-Parameters ermitteln

Die Funktion STRLEN liefert die Länge des Textes, der in einem wählbaren String-Parameter gespeichert ist.

Q-Parameter-Funktionen wählen

Funktion formel wählen

Nummer des Q-Parameters eingeben, in dem die TNC die zu ermittelnde Stringlänge speichern soll, mit Taste ent bestätigen

Softkey-Leiste umschalten

Funktion zum ermitteln der Textlänge eines String-Parameters wählen

Nummer des QS-Parameters eingeben, von dem die TNC die Länge ermitteln soll, mit Taste ENT bestätigen

Klammerausdruck mit Taste ent schließen und Eingabe mit Taste end beenden

Beispiel: Länge von QS15 ermitteln
n37 Q52 = STRLEN ( SRC_QS15 )


Alphabetische Reihenfolge vergleichen

Mit der Funktion STRCOMP können Sie die alphabetische Reihenfolge von String-Parametern vergleichen.

Q-Parameter-Funktionen wählen

Funktion formel wählen

Nummer des Q-Parameters eingeben, in dem die TNC das Vergleichsergebnis speichern soll, mit Taste ent bestätigen

Softkey-Leiste umschalten

Funktion zum Vergleichen von String-Parametern wählen

Nummer des ersten QS-Parameters eingeben, den die TNC vergleichen soll, mit Taste ENT bestätigen

Nummer des zweiten QS-Parameters eingeben, den die TNC vergleichen soll, mit Taste ENT bestätigen

Klammerausdruck mit Taste ent schließen und Eingabe mit Taste end beenden

    Die TNC liefert folgende Ergebnisse zurück:

  • 0: Die verglichenen QS-Parameter sind identisch
  • -1: Der erste QS-Parameter liegt alphabetisch vor dem zweiten QS-Parameter
  • +1: Der erste QS-Parameter liegt alphabetisch hinter dem zweiten QS-Parameter
Beispiel: Alphabetische Reihenfolge von QS12 und QS14 vergleichen
N37 Q52 = STRCOMP ( SRC_QS12 SEA_QS14 )


Vorbelegte Q-Parameter

    Die Q-Parameter Q100 bis Q199 werden von der TNC mit Werten belegt. Den Q-Parametern werden zugewiesen:

  • Werte aus der PLC
  • Angaben zu Werkzeug und Spindel
  • Angaben zum Betriebszustand
  • Messergebnisse aus Tastsystem-Zyklen usw.

Vorbelegte Q-Parameter (QS-Parameter) zwischen Q100 und Q199 (QS100 und QS199) dürfen Sie in NC-Programmen nicht als Rechenparameter verwenden, ansonsten können unerwünschte Effekte auftreten.

Weitere Informationen:
> Werte aus der PLC: Q100 bis Q107
> WMAT-Satz: QS100
> Aktiver Werkzeug-Radius: Q108
> Werkzeugachse: Q109
> Spindelzustand: Q110
> Kühlmittelversorgung: Q111
> Überlappungsfaktor: Q112
> Maßangaben im Programm: Q113
> Werkzeug-Länge: Q114
> Koordinaten nach Antasten während des Programmlaufs
> Ist-Sollwert-Abweichung bei automatischer Werkzeug-Vermessung mit dem TT 130
> Schwenken der Bearbeitungsebene mit Werkstück-Winkeln: von der TNC berechnete Koordinaten für Drehachsen
> Messergebnisse von Tastsystem-Zyklen (siehe auch Benutzer-Handbuch Zyklenprogrammierung)


Werte aus der PLC: Q100 bis Q107

Die TNC benutzt die Parameter Q100 bis Q107, um Werte aus der PLC in ein NC-Programm zu übernehmen.


WMAT-Satz: QS100

Die TNC legt das im WMAT-Satz definierte Material im Parameter QS100 ab.


Aktiver Werkzeug-Radius: Q108

    Der aktive Wert des Werkzeug-Radius wird Q108 zugewiesen. Q108 setzt sich zusammen aus:

  • Werkzeug-Radius R (Werkzeug-Tabelle oder g99-Satz)
  • Delta-Wert DR aus der Werkzeug-Tabelle
  • Delta-Wert DR aus dem T-Satz

Die TNC speichert den aktiven Werkzeug-Radius auch über eine Stromunterbrechung hinaus.


Werkzeugachse: Q109

Der Wert des Parameters Q109 hängt von der aktuellen Werkzeugachse ab:

Werkzeugachse | Parameter-Wert
Keine Werkzeugachse definiert | Q109 = –1
X-Achse | Q109 = 0
Y-Achse | Q109 = 1
Z-Achse | Q109 = 2
U-Achse | Q109 = 6
V-Achse | Q109 = 7
W-Achse | Q109 = 8


Spindelzustand: Q110

Der Wert des Parameters Q110 hängt von der zuletzt programmierten M-Funktion für die Spindel ab:

M-Funktion | Parameter-Wert
Kein Spindelzustand definiert | Q110 = –1
M3: Spindel EIN, Uhrzeigersinn | Q110 = 0
M4: Spindel EIN, Gegenuhrzeigersinn | Q110 = 1
M5 nach M3 | Q110 = 2
M5 nach M4 | Q110 = 3


Kühlmittelversorgung: Q111

M-Funktion | Parameter-Wert
M8: Kühlmittel EIN | Q111 = 1
M9: Kühlmittel AUS | Q111 = 0


Überlappungsfaktor: Q112

Die TNC weist Q112 den Überlappungsfaktor beim Taschenfräsen (MP7430) zu.


Maßangaben im Programm: Q113

Der Wert des Parameters Q113 hängt bei Verschachtelungen mit PGM CALL von den Maßangaben des Programms ab, das als erstes andere Programme ruft.

Maßangaben des Hauptprogramms | Parameter-Wert
Metrisches System (mm) | Q113 = 0
Zoll-System (inch) | Q113 = 1


Werkzeug-Länge: Q114

Der aktuelle Wert der Werkzeug-Länge wird Q114 zugewiesen.

    Der aktive Wert der Werkzeug-Länge wird Q114 zugewiesen. Q114 setzt sich zusammen aus:

  • Werkzeug-Länge L (Werkzeug-Tabelle oder g99-Satz)
  • Delta-Wert DL aus der Werkzeug-Tabelle
  • Delta-Wert DL aus dem T-Satz

Die TNC speichert die aktive Werkzeug-Länge auch über eine Stromunterbrechung hinaus.


Koordinaten nach Antasten während des Programmlaufs

Die Parameter Q115 bis Q119 enthalten nach einer programmierten Messung mit dem Tastsystem die Koordinaten der Spindelposition zum Antast-Zeitpunkt. Die Koordinaten beziehen sich auf den Bezugspunkt, der in der Betriebsart Manuell aktiv ist.

Die Länge des Taststifts und der Radius der Tastkugel werden für diese Koordinaten nicht berücksichtigt.

Koordinatenachse | Parameter-Wert
X-Achse | Q115
Y-Achse | Q116
Z-Achse | Q117
IV. Achse abhängig von MP100 | Q118
V. Achse abhängig von MP100 | Q119


Ist-Sollwert-Abweichung bei automatischer Werkzeug-Vermessung mit dem TT 130

Ist-Soll-Abweichung | Parameter-Wert
Werkzeug-Länge | Q115
Werkzeug-Radius | Q116


Schwenken der Bearbeitungsebene mit Werkstück-Winkeln: von der TNC berechnete Koordinaten für Drehachsen

Koordinaten | Parameter-Wert
A-Achse | Q120
B-Achse | Q121
C-Achse | Q122


Messergebnisse von Tastsystem-Zyklen (siehe auch Benutzer-Handbuch Zyklenprogrammierung)

Gemessene Istwerte | Parameter-Wert
Winkel einer Geraden | Q150
Mitte in der Hauptachse | Q151
Mitte in der Nebenachse | Q152
Durchmesser | Q153
Taschenlänge | Q154
Taschenbreite | Q155
Länge in der im Zyklus gewählten Achse | Q156
Lage der Mittelachse | Q157
Winkel der A-Achse | Q158
Winkel der B-Achse | Q159
Koordinate der im Zyklus gewählten Achse | Q160
Ermittelte Abweichung | Parameter-Wert
Mitte in der Hauptachse | Q161
Mitte in der Nebenachse | Q162
Durchmesser | Q163
Taschenlänge | Q164
Taschenbreite | Q165
Gemessene Länge | Q166
Lage der Mittelachse | Q167
Ermittelte Raumwinkel | Parameter-Wert
Drehung um die A-Achse | Q170
Drehung um die B-Achse | Q171
Drehung um die C-Achse | Q172
Werkstück-Status | Parameter-Wert
Gut | Q180
Nacharbeit | Q181
Ausschuss | Q182
Gemessene Abweichung mit Zyklus 440 | Parameter-Wert
X-Achse | Q185
Y-Achse | Q186
Z-Achse | Q187
Merker für Zyklen | Q188
Werkzeug-Vermessung mit BLUM-Laser | Parameter-Wert
Reserviert | Q190
Reserviert | Q191
Reserviert | Q192
Reserviert | Q193
Reserviert für interne Verwendung | Parameter-Wert
Merker für Zyklen | Q195
Merker für Zyklen | Q196
Merker für Zyklen (Bearbeitungsbilder) | Q197
Nummer des zuletzt aktiven Messzyklus | Q198
Status Werkzeug-Vermessung mit TT | Parameter-Wert
Werkzeug innerhalb Toleranz | Q199 = 0,0
Werkzeug ist verschlissen (LTOL/RTOL überschritten) | Q199 = 1,0
Werkzeug ist gebrochen (LBREAK/RBREAK überschritten) | Q199 = 2,0


Programmier-Beispiele

Weitere Informationen:
> Beispiel: Ellipse
> Beispiel: Zylinder konkav mit Radiusfräser
> Beispiel: Kugel konvex mit Schaftfräser


Beispiel: Ellipse

    Programm-Ablauf

  • Die Ellipsen-Kontur wird durch viele kleine Geradenstücke angenähert (über Q7 definierbar). Je mehr Berechnungsschritte definiert sind, desto glatter wird die Kontur
  • Die Fräsrichtung bestimmen Sie über den Start- und Endwinkel in der Ebene:
    Bearbeitungsrichtung im Uhrzeigersinn:
    Startwinkel > Endwinkel
    Bearbeitungsrichtung im Gegen-Uhrzeigersinn:
    Startwinkel < Endwinkel
  • Werkzeug-Radius wird nicht berücksichtigt
%ellipse g71 * |
n10 q1 = +50 * | Mitte X-Achse
n20 Q2 = +50 * | Mitte Y-Achse
n30 Q3 = +50 * | Halbachse X
n40 Q4 = +30 * | Halbachse Y
n50 Q5 = +0 * | Startwinkel in der Ebene
n60 Q6 = +360 * | Endwinkel in der Ebene
n70 Q7 = +40 * | Anzahl der Berechnungs-Schritte
n80 Q8 = +30 * | Drehlage der Ellipse
n90 Q9 = +5 * | Frästiefe
n100 Q10 = +100 * | Tiefenvorschub
n110 Q11 = +350 * | Fräsvorschub
n120 Q12 = +2 * | Sicherheits-Abstand für Vorpositionierung
n130 g30 g17 x+0 y+0 z-20 * | Rohteil-Definition
n140 g31 g90 x+100 y+100 z+0 * |
n160 t1 g17 s4000 * | Werkzeug-Aufruf
n170 g00 g40 g90 z+250 * | Werkzeug freifahren
n180 l10,0 * | Bearbeitung aufrufen
n190 g00 z+250 m2 * | Werkzeug freifahren, Programm-Ende
n200 g98 l10 * | Unterprogramm 10: Bearbeitung
n210 g54 x+q1 y+q2 * | Nullpunkt ins Zentrum der Ellipse verschieben
n220 g73 g90 h+q8 * | Drehlage in der Ebene verrechnen
n230 q35 = ( q6 - q5 ) / q7 * | Winkelschritt berechnen
n240 Q36 = +Q5 * | Startwinkel kopieren
n250 Q37 = +0 +0 * | Schnittzähler setzen
n260 q21 = q3 * cos q36 * | X-Koordinate des Startpunkts berechnen
n270 q22 = q4 * sin q36 * | Y-Koordinate des Startpunkts berechnen
n280 g00 g40 x+q21 y+q22 m3 * | Startpunkt anfahren in der Ebene
n290 z+q12 * | Vorpositionieren auf Sicherheits-Abstand in der Spindelachse
n300 g01 z-q9 fq10 * | Auf Bearbeitungstiefe fahren
n310 g98 l1 * |
n320 q36 = q36 + q35 * | Winkel aktualisieren
n330 q37 = Q37 + 1 * | Schnittzähler aktualisieren
n340 q21 = q3 * cos q36 * | Aktuelle X-Koordinate berechnen
n350 q22 = q4 * sin q36 * | Aktuelle Y-Koordinate berechnen
n360 g01 x+q21 y+q22 fq11 * | Nächsten Punkt anfahren
n370 d12 p01 +q37 p02 +q7 p03 1 * | Abfrage ob unfertig, wenn ja dann Rücksprung zu Label 1
n380 g73 g90 h+0 * | Drehung rücksetzen
n390 g54 x+0 y+0 * | Nullpunkt-Verschiebung rücksetzen
n400 g00 g40 z+q12 * | Auf Sicherheits-Abstand fahren
n410 g98 l0 * | Unterprogramm-Ende
n99999999 %ellipse g71 * |


Beispiel: Zylinder konkav mit Radiusfräser

    Programm-Ablauf

  • Programm funktioniert nur mit Radiusfräser, die Werkzeuglänge bezieht sich auf das Kugelzentrum
  • Die Zylinder-Kontur wird durch viele kleine Geradenstücke angenähert (über Q13 definierbar). Je mehr Schnitte definiert sind, desto glatter wird die Kontur
  • Der Zylinder wird in Längsschnitten (hier: Parallel zur Y-Achse) gefräst
  • Die Fräsrichtung bestimmen Sie über den Start- und Endwinkel im Raum:
    Bearbeitungsrichtung im Uhrzeigersinn:
    Startwinkel > Endwinkel
    Bearbeitungsrichtung im Gegen-Uhrzeigersinn:
    Startwinkel < Endwinkel
  • Werkzeug-Radius wird automatisch korrigiert
%zylin g71 * |
n10 Q1 = +50 * | Mitte X-Achse
n20 Q2 = +0 * | Mitte Y-Achse
n30 Q3 = +0 * | Mitte Z-Achse
n40 Q4 = +90 * | Startwinkel Raum (Ebene Z/X)
n50 Q5 = +270 * | Endwinkel Raum (Ebene Z/X)
n60 Q6 = +40 * | Zylinderradius
n70 Q7 = +100 * | Länge des Zylinders
n80 Q8 = +0 * | Drehlage in der Ebene X/Y
n90 Q10 = +5 * | Aufmaß Zylinderradius
n100 Q11 = +250 * | Vorschub Tiefenzustellung
n110 Q12 = +400 * | Vorschub Fräsen
n120 Q13 = +90 * | Anzahl Schnitte
n130 g30 g17 x+0 y+0 z-50 * | Rohteil-Definition
n140 g31 g90 x+100 y+100 z+0 * |
n160 t1 g17 s4000 * | Werkzeug-Aufruf
n170 g00 g40 g90 z+250 * | Werkzeug freifahren
n180 l10,0 * | Bearbeitung aufrufen
n190 Q10 = +0 * | Aufmaß rücksetzen
n200 l10,0 | Bearbeitung aufrufen
n210 g00 g40 z+250 m2 * | Werkzeug freifahren, Programm-Ende
n220 g98 l10 * | Unterprogramm 10: Bearbeitung
n230 q16 = q6 - q10 - q108 * | Aufmaß und Werkzeug bezogen auf Zylinder-Radius verrechnen
n240 Q20 = +1 * | Schnittzähler setzen
n250 Q24 = +Q4 * | Startwinkel Raum (Ebene Z/X) kopieren
n260 q25 = ( q5 - q4 ) / q13 * | Winkelschritt berechnen
n270 g54 x+q1 y+q2 z+q3 * | Nullpunkt in die Mitte des Zylinders (X-Achse) verschieben
n280 g73 g90 h+q8 * | Drehlage in der Ebene verrechnen
n290 g00 g40 x+0 y+0 * | Vorpositionieren in der Ebene in die Mitte des Zylinders
n300 g01 z+5 f1000 m3 * | Vorpositionieren in der Spindelachse
n310 g98 l1 * |
n320 i+0 k+0 * | Pol setzen in der Z/X-Ebene
n330 g11 r+q16 h+q24 fq11 * | Startposition auf Zylinder anfahren, schräg ins Material eintauchend
n340 g01 g40 y+q7 fq12 * | Längsschnitt in Richtung Y+
n350 Q20 = +Q20 + 1 * | Schnittzähler aktualisieren
n360 Q24 = +Q24 + +Q25 * | Raumwinkel aktualisieren
n370 d11 p01 +q20 p02 +q13 p03 99 * | Abfrage ob bereits fertig, wenn ja, dann ans Ende springen
n380 g11 r+q16 h+q24 fq11 * | Angenäherten “Bogen” fahren für nächsten Längsschnitt
n390 g01 g40 y+0 fq12 * | Längsschnitt in Richtung Y–
n400 d01 q20 p01 +q20 p02 +1 * | Schnittzähler aktualisieren
n410 d01 q24 p01 +q24 p02 +q25 * | Raumwinkel aktualisieren
n420 d12 p01 +q20 p02 +q13 p03 1 * | Abfrage ob unfertig, wenn ja dann Rücksprung zu LBL 1
n430 g98 l99 * |
n440 g73 g90 h+0 * | Drehung rücksetzen
n450 g54 x+0 y+0 z+0 * | Nullpunkt-Verschiebung rücksetzen
n460 g98 l0 * | Unterprogramm-Ende
n99999999 %zylin g71 * |


Beispiel: Kugel konvex mit Schaftfräser

    Programm-Ablauf

  • Programm funktioniert nur mit Schaftfräser
  • Die Kugel-Kontur wird durch viele kleine Geradenstücke angenähert (Z/X-Ebene, über Q14 definierbar). Je kleiner der Winkelschritt definiert ist, desto glatter wird die Kontur
  • Die Anzahl der Kontur-Schnitte bestimmen Sie durch den Winkelschritt in der Ebene (über Q18)
  • Die Kugel wird im 3D-Schnitt von unten nach oben gefräst
  • Werkzeug-Radius wird automatisch korrigiert
%kugel g71 * |
n10 Q1 = +50 * | Mitte X-Achse
n20 Q2 = +50 * | Mitte Y-Achse
n30 Q4 = +90 * | Startwinkel Raum (Ebene Z/X)
n40 Q5 = +0 * | Endwinkel Raum (Ebene Z/X)
n50 Q14 = +5 * | Winkelschritt im Raum
n60 Q6 = +45 * | Kugelradius
n70 Q8 = +0 * | Startwinkel Drehlage in der Ebene X/Y
n80 Q9 = +360 * | Endwinkel Drehlage in der Ebene X/Y
n90 Q18 = +10 * | Winkelschritt in der Ebene X/Y fürs Schruppen
n100 Q10 = +5 * | Aufmaß Kugelradius fürs Schruppen
n110 Q11 = +2 * | Sicherheits-Abstand für Vorpositionierung in der Spindelachse
n120 Q12 = +350 * | Vorschub Fräsen
n130 g30 g17 x+0 y+0 z-50 * | Rohteil-Definition
n140 g31 g90 x+100 y+100 z+0 * |
n160 t1 g17 s4000 * | Werkzeug-Aufruf
n170 g00 g40 g90 z+250 * | Werkzeug freifahren
n180 l10,0 * | Bearbeitung aufrufen
n190 Q10 = +0 * | Aufmaß rücksetzen
n200 Q18 = +5 * | Winkelschritt in der Ebene X/Y fürs Schlichten
n210 l10,0 * | Bearbeitung aufrufen
n220 g00 g40 z+250 m2 * | Werkzeug freifahren, Programm-Ende
n230 g98 l10 * | Unterprogramm 10: Bearbeitung
n240 Q23 = Q11 + Q6 * | Z-Koordinate für Vorpositionierung berechnen
n250 Q24 = +Q4 * | Startwinkel Raum (Ebene Z/X) kopieren
n260 Q26 = Q6 + Q108 * | Kugelradius korrigieren für Vorpositionierung
n270 Q28 = +Q8 * | Drehlage in der Ebene kopieren
n280 Q16 = Q6 + -Q10 * | Aufmaß berücksichtigen beim Kugelradius
n290 g54 x+q1 y+q2 z-q16 * | Nullpunkt ins Zentrum der Kugel verschieben
n300 g73 g90 h+q8 * | Startwinkel Drehlage in der Ebene verrechnen
n310 g98 l1 * | Vorpositionieren in der Spindelachse
n320 i+0 j+0 * | Pol setzen in der X/Y-Ebene für Vorpositionierung
n330 g11 g40 r+q26 h+q8 fq12 * | Vorpositionieren in der Ebene
n340 i+q108 k+0 * | Pol setzen in der Z/X-Ebene, um Werkzeug-Radius versetzt
n350 g01 y+0 z+0 fq12 * | Fahren auf Tiefe
n360 g98 l2 * |
n370 g11 g40 r+q6 h+q24 fq12 * | Angenäherten „Bogen” nach oben fahren
n380 Q24 = Q24 - Q14 * | Raumwinkel aktualisieren
n390 d11 p01 +q24 p02 +q5 p03 2 * | Abfrage ob ein Bogen fertig, wenn nicht, dann zurück zu LBL 2
n400 g11 r+q6 h+q5 fq12 * | Endwinkel im Raum anfahren
n410 g01 g40 z+q23 f1000 * | In der Spindelachse freifahren
n420 g00 g40 x+q26 * | Vorpositionieren für nächsten Bogen
n430 Q28 = Q28 + Q18 * | Drehlage in der Ebene aktualisieren
n440 Q24 = +Q4 * | Raumwinkel rücksetzen
n450 g73 g90 h+q28 * | Neue Drehlage aktivieren
n460 d12 p01 +q28 p02 +q9 p03 1 * | Abfrage ob unfertig, wenn ja, dann Rücksprung zu LBL 1
n470 d09 p01 +q28 p02 +q9 p03 1 * |
n480 g73 g90 h+0 * | Drehung rücksetzen
n490 g54 x+0 y+0 z+0 * | Nullpunkt-Verschiebung rücksetzen
n500 g98 l0 * | Unterprogramm-Ende
n99999999 %kugel g71 * |


Programmieren: Zusatz-Funktionen

Weitere Informationen:
> Zusatz-Funktionen M und STOPP eingeben
> Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel
> Zusatz-Funktionen für Koordinatenangaben
> Zusatz-Funktionen für das Bahnverhalten
> Zusatz-Funktionen für Laser-Schneidmaschinen


Zusatz-Funktionen M und STOPP eingeben

Weitere Informationen:
> Grundlagen


Grundlagen

    Mit den Zusatz-Funktionen der TNC - auch M-Funktionen genannt -steuern Sie

  • den Programmlauf, z.B. eine Unterbrechung des Programmlaufs
  • Maschinenfunktionen, wie das Ein- und Ausschalten der Spindeldrehung und des Kühlmittels
  • das Bahnverhalten des Werkzeugs

Der Maschinenhersteller kann Zusatz-Funktionen freigeben, die nicht in diesem Handbuch beschrieben sind. Beachten Sie Ihr Maschinenhandbuch.

Sie können bis zu zwei Zusatz-Funktionen M am Ende eines Positionier-Satzes oder auch in einem separaten Satz eingeben. Die TNC zeigt dann den Dialog: Zusatz-Funktion M ?

Gewöhnlich geben Sie im Dialog nur die Nummer der Zusatz-Funktion an. Bei einigen Zusatz-Funktionen wird der Dialog fortgeführt, damit Sie Parameter zu dieser Funktion eingeben können.

In den Betriebsarten Manueller Betrieb und El. Handrad geben Sie die Zusatz-Funktionen über den Softkey M ein.

Beachten Sie, dass einige Zusatz-Funktionen zu Beginn eines Positionier-Satzes wirksam werden, andere am Ende, unabhängig von der Reihenfolge, in der sie im jeweiligen NC-Satz stehen.

Die Zusatz-Funktionen wirken ab dem Satz, in dem sie aufgerufen werden.

Einige Zusatz-Funktionen gelten nur in dem Satz, in dem sie programmiert sind. Wenn die Zusatz-Funktion nicht nur satzweise wirksam ist, müssen Sie diese in einem nachfolgenden Satz mit einer separaten M-Funktion wieder aufheben, oder Sie wird automatisch von der TNC am Programm-Ende aufgehoben.

Weitere Informationen:
> Zusatz-Funktion im STOPP-Satz eingeben


Zusatz-Funktion im STOPP-Satz eingeben

Ein programmierter STOPP-Satz unterbricht den Programmlauf bzw. den Programm-Test, z.B. für eine Werkzeug-Überprüfung. In einem STOPP-Satz können Sie eine Zusatz-Funktion M programmieren:

Programmlauf-Unterbrechung programmieren: Taste STOPP drücken

Zusatz-Funktion M eingeben

NC-Beispielsätze
n87 g36 M6


Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel

Weitere Informationen:
> Übersicht


Übersicht

Der Maschinenhersteller kann das Verhalten der nachfolgend beschriebenen Zusatz-Funktionen beeinflussen. Beachten Sie Ihr Maschinenhandbuch.

M | Wirkung | Wirkung am Satz - | Anfang | Ende
M0 | Programmlauf HALT Spindel HALT |  |  | ■
M1 | Wahlweiser Programmlauf HALT ggf. Spindel HALT ggf. Kühlmittel AUS (wirkt nicht im Programm-Test, Funktion wird vom Maschinenhersteller festgelegt) |  |  | ■
M2 | Programmlauf HALT Spindel HALT Kühlmittel aus Rücksprung zu Satz 1 Löschen der Status-Anzeige (abhängig von Maschinen-Parameter 7300) |  |  | ■
M3 | Spindel EIN im Uhrzeigersinn |  | ■ |
M4 | Spindel EIN gegen den Uhrzeigersinn |  | ■ |
M5 | Spindel HALT |  |  | ■
M6 | Werkzeugwechsel Spindel HALT Programmlauf HALT (abhängig von Maschinen-Parameter 7440) |  |  | ■
M8 | Kühlmittel EIN |  | ■ |
M9 | Kühlmittel AUS |  |  | ■
M13 | Spindel EIN im Uhrzeigersinn Kühlmittel EIN |  | ■ |
M14 | Spindel EIN gegen den Uhrzeigersinn Kühlmittel ein |  | ■ |
M30 | wie M2 |  |  | ■


Zusatz-Funktionen für Koordinatenangaben

Weitere Informationen:
> Maschinenbezogene Koordinaten programmieren: M91/M92
> Zuletzt gesetzten Bezugspunkt aktivieren: M104
> Positionen im ungeschwenkten Koordinaten-System bei geschwenkter Bearbeitungsebene anfahren: M130


Maschinenbezogene Koordinaten programmieren: M91/M92

Maßstab-Nullpunkt

Auf dem Maßstab legt eine Referenzmarke die Position des Maßstab-Nullpunkts fest.

Maschinen-Nullpunkt

    Den Maschinen-Nullpunkt benötigen Sie, um

  • Verfahrbereichs-Begrenzungen (Software-Endschalter) zu setzen
  • maschinenfeste Positionen (z.B. Werkzeugwechsel-Position) anzufahren
  • einen Werkstück-Bezugspunkt zu setzen

Der Maschinenhersteller gibt für jede Achse den Abstand des Maschinen-Nullpunkts vom Maßstab-Nullpunkt in einen Maschinen-Parameter ein.

Standardverhalten

Koordinaten bezieht die TNC auf den Werkstück-Nullpunkt, siehe Bezugspunkt-Setzen ohne Tastsystem.

Verhalten mit M91 – Maschinen-Nullpunkt

Wenn sich Koordinaten in Positionier-Sätzen auf den Maschinen-Nullpunkt beziehen sollen, dann geben Sie in diesen Sätzen M91 ein.

Wenn Sie in einem M91-Satz inkrementale Koordinaten programmieren, dann beziehen sich diese Koordinaten auf die letzte programmierte M91-Position. Ist im aktiven NC-Programm keine M91-Position programmiert, dann beziehen sich die Koordinaten auf die aktuelle Werkzeug-Position.

Wenn Sie M3 oder M4 gemeinsam in einem Satz mit M91 programmieren, dann M3 grundsätzlich immer vor M91 programmieren.

Die TNC zeigt die Koordinatenwerte bezogen auf den Maschinen-Nullpunkt an. In der Status-Anzeige schalten Sie die Koordinaten-Anzeige auf REF, siehe Status-Anzeigen.

Verhalten mit M92 – Maschinen-Bezugspunkt

Neben dem Maschinen-Nullpunkt kann der Maschinenhersteller noch eine weitere maschinenfeste Position (Maschinen-Bezugspunkt) festlegen.

Der Maschinenhersteller legt für jede Achse den Abstand des Maschinen-Bezugspunkts vom Maschinen-Nullpunkt fest (siehe Maschinenhandbuch).

Wenn sich die Koordinaten in Positionier-Sätzen auf den Maschinen-Bezugspunkt beziehen sollen, dann geben Sie in diesen Sätzen M92 ein.

Auch mit M91 oder M92 führt die TNC die Radiuskorrektur korrekt aus. Die Werkzeug-Länge wird jedoch nicht berücksichtigt.

Wenn Sie M3 oder M4 gemeinsam in einem Satz mit M92 programmieren, dann M3 grundsätzlich immer vor M92 programmieren.
Wirkung

M91 und M92 wirken nur in den Programmsätzen, in denen M91 oder M92 programmiert ist.

M91 und M92 werden wirksam am Satz-Anfang.

Werkstück-Bezugspunkt

Wenn sich Koordinaten immer auf den Maschinen-Nullpunkt beziehen sollen, dann kann das Bezugspunkt-Setzen für eine oder mehrere Achsen gesperrt werden.

Wenn das Bezugspunkt-Setzen für alle Achsen gesperrt ist, dann zeigt die TNC den Softkey BEZUGSPUNKT SETZEN in der Betriebsart Manueller Betrieb nicht mehr an.

Das Bild zeigt Koordinatensysteme mit Maschinen- und Werkstück-Nullpunkt.

M91/M92 in der Betriebsart Programm-Test

Um M91/M92-Bewegungen auch grafisch simulieren zu können, müssen Sie die Arbeitsraum-Überwachung aktivieren und das Rohteil bezogen auf den gesetzten Bezugspunkt anzeigen lassen, siehe Rohteil im Arbeitsraum darstellen.


Zuletzt gesetzten Bezugspunkt aktivieren: M104

Funktion

Beim Abarbeiten von Paletten-Tabellen überschreibt die TNC ggf. den zuletzt von Ihnen gesetzten Bezugspunkt mit Werten aus der Paletten-Tabelle. Mit der Funktion M104 aktivieren Sie wieder den zuletzt von Ihnen gesetzten Bezugspunkt.

Wirkung

M104 wirkt nur in den Programm-Sätzen, in denen M104 programmiert ist.

M104 wird wirksam am Satz-Ende.

Die TNC verändert die aktive Grunddrehung beim Ausführen der Funktion M104 nicht.


Positionen im ungeschwenkten Koordinaten-System bei geschwenkter Bearbeitungsebene anfahren: M130

Standardverhalten bei geschwenkter Bearbeitungsebene

Koordinaten in Positionier-Sätzen bezieht die TNC auf das geschwenkte Koordinatensystem.

Verhalten mit M130

Koordinaten in Geraden-Sätzen bezieht die TNC bei aktiver, geschwenkter Bearbeitungsebene auf das ungeschwenkte Koordinatensystem

Die TNC positioniert dann das (geschwenkte) Werkzeug auf die programmierte Koordinate des ungeschwenkten Systems.

Achtung Kollisionsgefahr!

Nachfolgende Positionensätze bzw. Bearbeitungszyklen werden wieder im geschwenkten Koordinaten-System ausgeführt, dies kann bei Bearbeitungszyklen mit absoluter Vorpositionierung zu Problemen führen.

Die Funktion M130 ist nur erlaubt, wenn die Funktion Bearbeitungsebene Schwenken aktiv ist.
Wirkung

M130 ist satzweise wirksam in Geraden-Sätzen ohne Werkzeug-Radiuskorrektur.


Zusatz-Funktionen für das Bahnverhalten

Weitere Informationen:
> Ecken verschleifen: M90
> Definierten Rundungskreis zwischen Geradenstücken einfügen: M112
> Punkte beim Abarbeiten von nicht korrigierten Geradensätzen nicht berücksichtigen: M124
> Kleine Konturstufen bearbeiten: M97
> Offene Konturecken vollständig bearbeiten: M98
> Vorschubfaktor für Eintauchbewegungen: M103
> Vorschub in Millimeter/Spindel-Umdrehung: M136
> Vorschubgeschwindigkeit bei Kreisbögen: M109/M110/M111
> Radiuskorrigierte Kontur vorausberechnen (LOOK AHEAD): M120
> Handrad-Positionierung während des Programmlaufs überlagern: M118
> Rückzug von der Kontur in Werkzeugachsen-Richtung: M140
> Tastsystem-Überwachung unterdrücken: M141
> Modale Programminformationen löschen: M142
> Grunddrehung löschen: M143
> Werkzeug bei NC-Stopp automatisch von der Kontur abheben: M148
> Endschaltermeldung unterdrücken: M150


Ecken verschleifen: M90

Standardverhalten

Die TNC hält bei Positionier-Sätzen ohne Werkzeug-Radiuskorrektur das Werkzeug an den Ecken kurz an (Genau-Halt).

Bei Programmsätzen mit Radiuskorrektur (RR/RL) fügt die TNC an Außenecken automatisch einen Übergangskreis ein.

Verhalten mit M90

Das Werkzeug wird an eckigen Übergängen mit konstanter Bahngeschwindigkeit geführt: Die Ecken verschleifen und die Werkstück-Oberfläche wird glatter. Zusätzlich verringert sich die Bearbeitungszeit.

Anwendungsbeispiel: Flächen aus kurzen Geradenstücken.

Wirkung

M90 wirkt nur in dem Programmsatz, in dem M90 programmiert ist.

M90 wird wirksam am Satz-Anfang. Betrieb mit Schleppabstand muss angewählt sein.


Definierten Rundungskreis zwischen Geradenstücken einfügen: M112

Kompatibilität

Aus Kompatibilitätsgründen ist die Funktion M112 weiterhin verfügbar. Um die Toleranz beim schnellen Konturfräsen festzulegen, empfiehlt HEIDENHAIN jedoch die Verwendung des Zyklus TOLERANZ (siehe Benutzer-Handbuch Zyklen, Zyklus 32 TOLERANZ).


Punkte beim Abarbeiten von nicht korrigierten Geradensätzen nicht berücksichtigen: M124

Standardverhalten

Die TNC arbeitet alle Geradensätze ab, die im aktiven Programm eingegeben sind.

Verhalten mit M124

Beim Abarbeiten von nicht korrigierten Geradensätzen mit sehr kleinen Punktabständen können Sie über den Parameter T einen minimalen Punktabstand definieren, bis zu dem die TNC Punkte beim Abarbeiten nicht berücksichtigen soll.

Wirkung

M124 wird wirksam am Satzanfang.

Die TNC setzt M124 zurück, wenn Sie M124 ohne den Parameter T eingeben, oder wenn Sie ein neues Programm anwählen.

M124 eingeben

Wenn Sie in einem Positionier-Satz M124 eingeben, dann führt die TNC den Dialog für diesen Satz fort und erfragt den minimalen Punktabstand T.

T können Sie auch über Q-Parameter festlegen (siehe Prinzip und Funktionsübersicht).


Kleine Konturstufen bearbeiten: M97

Standardverhalten

Die TNC fügt an der Außenecke einen Übergangskreis ein. Bei sehr kleinen Konturstufen würde das Werkzeug dadurch die Kontur beschädigen.

Die TNC unterbricht an solchen Stellen den Programmlauf und gibt die Fehlermeldung „Werkzeug-Radius zu groß“ aus.

Verhalten mit M97

Die TNC ermittelt einen Bahnschnittpunkt für die Konturelemente – wie bei Innenecken – und fährt das Werkzeug über diesen Punkt.

Programmieren Sie M97 in dem Satz, in dem der Außeneckpunkt festgelegt ist.

Anstelle M97 sollten Sie die wesentlich leistungsfähigere Funktion M120 LA verwenden (siehe Radiuskorrigierte Kontur vorausberechnen (LOOK AHEAD): M120)!

Wirkung

M97 wirkt nur in dem Programmsatz, in dem M97 programmiert ist.

Die Konturecke wird mit M97 nur unvollständig bearbeitet. Eventuell müssen Sie die Konturecke mit einem kleineren Werkzeug nachbearbeiten.
NC-Beispielsätze
n50 T20 g01 ...* | Werkzeug mit großem Werkzeug-Radius
... |
n130 x ... y ... f ... m97 * | Konturpunkt 13 anfahren
n140 g91 y-0,5 ... f ... * | Kleine Konturstufe 13 und 14 bearbeiten
n150 x+100 ... * | Konturpunkt 15 anfahren
n160 y+0,5 ... f ... m97 * | Kleine Konturstufe 15 und 16 bearbeiten
n170 g90 x ... y ... * | Konturpunkt 17 anfahren


Offene Konturecken vollständig bearbeiten: M98

Standardverhalten

Die TNC ermittelt an Innenecken den Schnittpunkt der Fräserbahnen und fährt das Werkzeug ab diesem Punkt in die neue Richtung.

Wenn die Kontur an den Ecken offen ist, dann führt das zu einer unvollständigen Bearbeitung:

Verhalten mit M98

Mit der Zusatz-Funktion M98 fährt die TNC das Werkzeug so weit, dass jeder Konturpunkt tatsächlich bearbeitet wird:

Wirkung

M98 wirkt nur in den Programmsätzen, in denen M98 programmiert ist.

M98 wird wirksam am Satz-Ende.

NC-Beispielsätze

Nacheinander Konturpunkte 10, 11 und 12 anfahren:

n100 g01 g41 x ... y ... f ... *
n110 x ... g91 y ... m98 *
n120 x+ ... *


Vorschubfaktor für Eintauchbewegungen: M103

Standardverhalten

Die TNC fährt das Werkzeug unabhängig von der Bewegungsrichtung mit dem zuletzt programmierten Vorschub.

Verhalten mit M103

Vorschubreduzierung mit M103 ist nur wirksam, wenn Bit4 im MP7440=1 gesetzt ist.

Die TNC reduziert den Bahnvorschub, wenn das Werkzeug in negativer Richtung der Werkzeugachse fährt. Der Vorschub beim Eintauchen FZMAX wird errechnet aus dem zuletzt programmierten Vorschub FPROG und einem Faktor F%:

FZMAX = FPROG x F%

M103 eingeben

Wenn Sie in einem Positionier-Satz M103 eingeben, dann führt die TNC den Dialog fort und erfragt den Faktor F.

Wirkung

M103 wird wirksam am Satz-Anfang.
M103 aufheben: M103 ohne Faktor erneut programmieren

M103 wirkt auch bei aktiver geschwenkter Bearbeitungsebene. Die Vorschubreduzierung wirkt dann beim Verfahren in negativer Richtung der geschwenkten Werkzeugachse.

NC-Beispielsätze

Vorschub beim Eintauchen beträgt 20% des Ebenenvorschubs.

... | Tatsächlicher Bahnvorschub (mm/min):
n170 g01 g41 x+20 y+20 f500 m103 f20 * | 500
n180 y+50 * | 500
n190 g91 z-2,5 * | 100
n200 y+5 z-5 * | 141
n210 x+50 * | 500
n220 g90 z+5 * | 500


Vorschub in Millimeter/Spindel-Umdrehung: M136

Standardverhalten

Die TNC verfährt das Werkzeug mit dem im Programm festgelegten Vorschub F in mm/min.

Verhalten mit M136

In Inch-Programmen ist M136 in Kombination mit der neu eingeführten Vorschub-Alternative FU nicht erlaubt.

Bei aktivem M136 darf die Spindel nicht in Regelung sein.

Mit M136 verfährt die TNC das Werkzeug nicht in mm/min sondern mit dem im Programm festgelegten Vorschub F in Millimeter/Spindel-Umdrehung. Wenn Sie die Drehzahl über den Spindel-Override verändern, passt die TNC den Vorschub automatisch an.

Wirkung

M136 wird wirksam am Satz-Anfang.

M136 heben Sie auf, indem Sie M137 programmieren.


Vorschubgeschwindigkeit bei Kreisbögen: M109/M110/M111

Standardverhalten

Die TNC bezieht die programmierte Vorschubgeschwindigkeit auf die Werkzeug-Mittelpunktsbahn.

Verhalten bei Kreisbögen mit M109

Die TNC hält bei Innen- und Außenbearbeitungen den Vorschub von Kreisbögen an der Werkzeug-Schneide konstant.

Achtung Gefahr für Werkzeug und Werkstück!

Bei sehr kleinen Außenecken, erhöht die TNC den Vorschub ggf. so stark, dass Werkzeug oder Werkstück beschädigt werden können. M109 bei kleinen Außenecken vermeiden.

Verhalten bei Kreisbögen mit M110

Die TNC hält den Vorschub bei Kreisbögen ausschließlich bei einer Innenbearbeitung konstant. Bei einer Außenbearbeitung von Kreisbögen wirkt keine Vorschub-Anpassung.

M110 wirkt auch bei der Innenbearbeitung von Kreisbögen mit Konturzyklen (Sonderfall).

Wenn Sie M109 bzw. M110 vor dem Aufruf eines Bearbeitungszyklus mit einer Nummer größer 200 definieren, wirkt die Vorschub-Anpassung auch bei Kreisbögen innerhalb dieser Bearbeitungszyklen. Am Ende oder nach Abbruch eines Bearbeitungszyklus wird der Ausgangszustand wieder hergestellt.

Wirkung

M109 und M110 werden wirksam am Satz-Anfang. M109 und M110 setzen Sie mit M111 zurück.


Radiuskorrigierte Kontur vorausberechnen (LOOK AHEAD): M120

Standardverhalten

Wenn der Werkzeug-Radius größer ist, als eine Konturstufe, die radiuskorrigiert zu fahren ist, dann unterbricht die TNC den Programmlauf und zeigt eine Fehlermeldung. M97 (siehe Kleine Konturstufen bearbeiten: M97) verhindert die Fehlermeldung, führt aber zu einer Freischneidemarkierung und verschiebt zusätzlich die Ecke.

Bei Hinterschneidungen verletzt die TNC u.U. die Kontur.

Verhalten mit M120

Die TNC überprüft eine radiuskorrigierte Kontur auf Hinterschneidungen und Überschneidungen und berechnet die Werkzeugbahn ab dem aktuellen Satz voraus. Stellen, an denen das Werkzeug die Kontur beschädigen würde, bleiben unbearbeitet (im Bild dunkel dargestellt). Sie können M120 auch verwenden, um Digitalisierdaten oder Daten, die von einem externen Programmier-System erstellt wurden, mit Werkzeug-Radiuskorrektur zu versehen. Dadurch sind Abweichungen vom theoretischen Werkzeug-Radius kompensierbar.

Die Anzahl der Sätze (maximal 99), die die TNC vorausrechnet, legen Sie mit LA (engl. Look Ahead: schaue voraus) hinter M120 fest. Je größer Sie die Anzahl der Sätze wählen, die die TNC vorausrechnen soll, desto langsamer wird die Satzverarbeitung.

Eingabe

Wenn Sie in einem Positionier-Satz M120 eingeben, dann führt die TNC den Dialog für diesen Satz fort und erfragt die Anzahl der vorauszuberechnenden Sätze LA.

Wirkung

    M120 muss in einem NC-Satz stehen, der auch die Radiuskorrektur g41 oder G42 enthält. M120 wirkt ab diesem Satz bis Sie

  • die Radiuskorrektur mit G40 aufheben
  • M120 LA0 programmieren
  • M120 ohne LA programmieren
  • mit % ein anderes Programm aufrufen
  • mit Zyklus g80 oder mit der PLANE-Funktion die Bearbeitungsebene schwenken

M120 wird wirksam am Satz-Anfang.

Einschränkungen
  • Den Wiedereintritt in eine Kontur nach Extern/Intern Stopp dürfen Sie nur mit der Funktion VORLAUF ZU SATZ N durchführen. Bevor Sie den Satzvorlauf starten, müssen Sie M120 aufheben (Programm über PGM MGT neu anwählen, nicht GOTO 0 verwenden), ansonsten gibt die TNC eine Fehlermeldung aus
  • Wenn Sie die Bahnfunktionen G25 und G24 verwenden, dürfen die Sätze vor und hinter G25 bzw. G24 nur Koordinaten der Bearbeitungsebene enthalten
  • Wenn Sie den LA-Wert zu groß eingeben, kann sich die bearbeitete Kontur verändern, da die TNC dannggf. zu viele NC-Sätze auslässt
  • Vor Verwendung der nachfolgend aufgeführte Funktionen müssen Sie M120 und die Radiuskorrektur aufheben:
    • Zyklus G60 Toleranz
    • Zyklus G80 Bearbeitungsebene
    • PLANE-Funktion
    • M114
    • M128
    • M138
    • M144
    • FUNCTION TCPM (nur Klartext-Dialog)
    • WRITE TO KINEMATIC (nur Klartext-Dialog)


Handrad-Positionierung während des Programmlaufs überlagern: M118

Standardverhalten

Die TNC fährt das Werkzeug in den Programmlauf-Betriebsarten wie im Bearbeitungs-Programm festgelegt.

Verhalten mit M118

Mit M118 können Sie während des Programmlaufs manuelle Korrekturen mit dem Handrad durchführen. Dazu programmieren Sie M118 und geben einen achsspezifischen Wert (Linearachse oder Drehachse) in mm ein.

Eingabe

Wenn Sie in einem Positionier-Satz M118 eingeben, dann führt die TNC den Dialog fort und erfragt die achsspezifischen Werte. Benutzen Sie die orangefarbenen Achstasten oder die ASCII-Tastatur zur Koordinaten-Eingabe.

Wirkung

Die Handrad-Positionierung heben Sie auf, indem Sie M118 ohne Koordinaten-Eingabe erneut programmieren.

M118 wird wirksam am Satz-Anfang.

NC-Beispielsätze

Während des Programmlaufs soll mit dem Handrad in der Bearbeitungsebene X/Y um ±1 mm und in der Drehachse B um ±5° vom programmierten Wert verfahren werden können:

n250 G01 g41 X+0 Y+38.5 F125 M118 X1 Y1 B5 *

M118 wirkt immer im Original-Koordinatensystem, auch wenn die Funktion Bearbeitungsebene schwenken aktiv ist!

M118-Werte für Linearachsen interpretiert die TNC in MM-Programmen in der Maßeinheit mm und in INCH-Programmen in der Maßeinheit inch.

M118 wirkt auch in der Betriebsart Positionieren mit Handeingabe!

M118 ist in Verbindung mit der Kollisionsüberwachung DCM nur in gestopptem Zustand (STIB blinkt) möglich. Wenn Sie versuchen handradüberlagert zu verfahren, gibt die TNC eine Fehlermeldung aus.


Rückzug von der Kontur in Werkzeugachsen-Richtung: M140

Standardverhalten

Die TNC fährt das Werkzeug in den Programmlauf-Betriebsarten wie im Bearbeitungs-Programm festgelegt.

Verhalten mit M140

Mit M140 MB (move back) können Sie einen eingebbaren Weg in Richtung der Werkzeugachse von der Kontur wegfahren.

Eingabe

Wenn Sie in einem Positionier-Satz M140 eingeben, dann führt die TNC den Dialog fort und erfragt den Weg, den das Werkzeug von der Kontur wegfahren soll. Geben Sie den gewünschten Weg ein, den das Werkzeug von der Kontur wegfahren soll oder drücken Sie den Softkey mb MAX, um bis an den Rand des Verfahrbereichs zu fahren.

Zusätzlich ist ein Vorschub programmierbar, mit dem das Werkzeug den eingegebenen Weg verfährt. Wenn Sie keinen Vorschub eingeben, verfährt die TNC den programmierten Weg im Eilgang.

Wirkung

M140 wirkt nur in dem Programmsatz, in dem M140 programmiert ist.

M140 wird wirksam am Satz-Anfang.

NC-Beispielsätze

Satz 250: Werkzeug 50 mm von der Kontur wegfahren

Satz 251: Werkzeug bis an den Rand des Verfahrbereichs fahren

n250 g01 x+0 y+38.5 f125 m140 mb50 *
n251 g01 x+0 y+38.5 f125 m140 mb MAx *

M140 wirkt auch wenn die Funktion Bearbeitungsebene schwenken, M114 oder M128 aktiv ist. Bei Maschinen mit Schwenkköpfen verfährt die TNC das Werkzeug dann im geschwenkten System.

Mit der Funktion FN18: SYSREAD ID230 NR6 können Sie den Abstand von der aktuellen Position zur Verfahrbereichsgrenze der positiven Werkzeugachse ermitteln.

Mit M140 MB MAX können Sie nur in positiver Richtung freifahren.

Vor M140 grundsätzliche einen Werkzeug-Aufruf mit Werkzeug-Achse definieren, ansonsten ist die Verfahrrichtung nicht definiert.

Achtung Kollisionsgefahr!

Bei aktiver Kollisions-Überwachung DCM, verfährt die TNC das Werkzeug ggf. nur bis eine Kollision erkannt wird und arbeitet das NC-Programm dann von dort aus ohne Fehlermeldung weiter ab. Dadurch können Bewegungen enstehen, die so nicht programmiert wurden!


Tastsystem-Überwachung unterdrücken: M141

Standardverhalten

Die TNC gibt bei ausgelenktem Taststift eine Fehlermeldung aus, sobald Sie eine Maschinenachse verfahren wollen.

Verhalten mit M141

Die TNC verfährt die Maschinenachsen auch dann, wenn das Tastsystem ausgelenkt ist. Diese Funktion ist erforderlich, wenn Sie einen eigenen Messzyklus in Verbindung mit dem Messzyklus 3 schreiben, um das Tastsystem nach dem Auslenken mit einem Positioniersatz wieder freizufahren.

Achtung Kollisionsgefahr!

Wenn Sie die Funktion M141 einsetzen, dann darauf achten, dass Sie das Tastsystem in die richtige Richtung freifahren.

M141 wirkt nur in Verfahrbewegungen mit Geraden-Sätzen.
Wirkung

M141 wirkt nur in dem Programmsatz, in dem M141 programmiert ist.

M141 wird wirksam am Satz-Anfang.


Modale Programminformationen löschen: M142

Standardverhalten

Die TNC setzt modale Programminformationen in folgenden Situationen zurück:

  • Neues Programm wählen
  • Zusatzfunktionen M2, M30 oder den Satz N99999999 %.... ausführen (abhängig von Maschinen-Parameter 7300)
  • Zyklus mit Werten für das Grundverhalten erneut definieren
Verhalten mit M142

Alle modalen Programminformationen bis auf die Grunddrehung, 3D-Rotation und Q-Parameter werden zurückgesetzt.

Die Funktion M142 ist bei einem Satzvorlauf nicht erlaubt.

Wirkung

M142 wirkt nur in dem Programmsatz, in dem M142 programmiert ist.

M142 wird wirksam am Satz-Anfang.


Grunddrehung löschen: M143

Standardverhalten

Die Grunddrehung bleibt solange wirksam, bis sie zurückgesetzt oder mit einen neuen Wert überschrieben wird.

Verhalten mit M143

Die TNC löscht eine programmierte Grunddrehung im NC-Programm.

Die Funktion M143 ist bei einem Satzvorlauf nicht erlaubt.

Wirkung

M143 wirkt nur in dem Programmsatz, in dem M143 programmiert ist.

M143 wird wirksam am Satz-Anfang.


Werkzeug bei NC-Stopp automatisch von der Kontur abheben: M148

Standardverhalten

Die TNC stoppt bei einem NC-Stop alle Verfahrbewegungen. Das Werkzeug bleibt am Unterbrechungspunkt stehen.

Verhalten mit M148

Die Funktion M148 muss vom Maschinenhersteller freigegeben sein.

Die TNC fährt das Werkzeug um 0.1 mm in Richtung der Werkzeug-Achse von der Kontur zurück, wenn Sie in der Werkzeug-Tabelle in der Spalte LIFTOFF für das aktive Werkzeug den Parameter Y gesetzt haben (siehe Werkzeug-Tabelle: Standard Werkzeug-Daten).

    LIFTOFF wirkt in folgenden Situationen:

  • Bei einem von Ihnen ausgelösten NC-Stopp
  • Bei einem von der Software ausgelösten NC-Stopp, z.B. wenn im Antriebssystem ein Fehler aufgetreten ist
  • Bei einer Stromunterbrechung. Der Weg, den die TNC bei einer Stromunterbrechung zurückzieht, legt Ihr Maschinenhersteller im Maschinen-Parameter 1160 fest

Achtung Kollisionsgefahr!

Beachten Sie, dass beim Wiederanfahren an die Kontur insbesondere bei gekrümmten Flächen Konturverletzungen entstehen können. Werkzeug vor dem Wiederanfahren freifahren!
Wirkung

M148 wirkt solange, bis die Funktion mit M149 deaktiviert wird.

M148 wird wirksam am Satz-Anfang, M149 am Satz-Ende.


Endschaltermeldung unterdrücken: M150

Standardverhalten

Die TNC stoppt den Programmlauf mit einer Fehlermeldung, wenn das Werkzeug in einem Positioniersatz den aktiven Arbeitsraum verlassen würde. Die Fehlermeldung wird ausgegeben, bevor der Positioniersatz ausgeführt wird.

Verhalten mit M150

Liegt der Endpunkt eines Positioniersatzes mit M150 ausserhalb des aktiven Arbeitsraumes, dann verfährt die TNC das Werkzeug bis an die Grenze des Arbeitsraumes und setzt den Programmlauf dann ohne Fehlermeldung fort.

Achtung Kollisionsgefahr!

Beachten Sie, dass sich der Anfahrweg auf die nach dem M150-Statz programmierte Position ggf. erheblich verändern kann!

M150 wirkt auch auf Verfahrbereichsgrenzen, die Sie über die MOD-Funktion definiert haben.

M150 wirkt auch, wenn Sie die Funktion Handradüberlagerung aktiv haben. Die TNC fährt das Werkzeug dann um den definierten Maximalwert der Handradüberlagerung weniger weit in Richtung Endschalter.

Bei aktiver Kollisions-Überwachung DCM, verfährt die TNC das Werkzeug ggf. nur bis eine Kollision erkannt wird und arbeitet das NC-Programm dann von dort aus ohne Fehlermeldung weiter ab. Dadurch können Bewegungen enstehen, die so nicht programmiert wurden!
Wirkung

M150 wirkt nur bei Geradensätzen und in dem Programmsatz, in dem M150 programmiert ist.

M150 wird wirksam am Satz-Anfang.


Zusatz-Funktionen für Laser-Schneidmaschinen

Weitere Informationen:
> Prinzip
> Programmierte Spannung direkt ausgeben: M200
> Spannung als Funktion der Strecke: M201
> Spannung als Funktion der Geschwindigkeit: M202
> Spannung als Funktion der Zeit ausgeben (zeitabhängige Rampe): M203
> Spannung als Funktion der Zeit ausgeben (zeitabhängiger Puls): M204


Prinzip

Zum Steuern der Laserleistung gibt die TNC über den S-Analog-Ausgang Spannungswerte aus. Mit den M-Funktionen M200 bis M204 können Sie während des Programmlaufs die Laserleistung beeinflussen.

Weitere Informationen:
> Zusatz-Funktionen für Laser-Schneidmaschinen eingeben


Zusatz-Funktionen für Laser-Schneidmaschinen eingeben

Wenn Sie in einem Positionier-Satz eine M-Funktion für Laser-Schneidmaschinen eingeben, dann führt die TNC den Dialog fort und erfragt die jeweiligen Parameter der Zusatz-Funktion.

Alle Zusatz-Funktionen für Laser-Schneidmaschinen werden wirksam am Satz-Anfang.


Programmierte Spannung direkt ausgeben: M200

Verhalten mit M200

Die TNC gibt den hinter M200 programmierten Wert als Spannung V aus.

Eingabebereich: 0 bis 9.999 V

Wirkung

M200 wirkt solange, bis über M200, M201, M202, M203 oder M204 eine neue Spannung ausgegeben wird.


Spannung als Funktion der Strecke: M201

Verhalten mit M201

M201 gibt die Spannung abhängig vom zurückgelegten Weg aus. Die TNC erhöht oder verringert die aktuelle Spannung linear auf den programmierten Wert V.

Eingabebereich: 0 bis 9.999 V

Wirkung

M201 wirkt solange, bis über M200, M201, M202, M203 oder M204 eine neue Spannung ausgegeben wird.


Spannung als Funktion der Geschwindigkeit: M202

Verhalten mit M202

Die TNC gibt die Spannung als Funktion der Geschwindigkeit aus. Der Maschinenhersteller legt in Maschinen-Parametern bis zu drei Kennlinien FNR. fest, in denen Vorschub-Geschwindigkeiten Spannungen zugeordnet werden. Mit M202 wählen Sie die Kennlinie FNR., aus der die TNC die auszugebende Spannung ermittelt.

Eingabebereich: 1 bis 3

Wirkung

M202 wirkt solange, bis über M200, M201, M202, M203 oder M204 eine neue Spannung ausgegeben wird.


Spannung als Funktion der Zeit ausgeben (zeitabhängige Rampe): M203

Verhalten mit M203

Die TNC gibt die Spannung V als Funktion der Zeit TIME aus. Die TNC erhöht oder verringert die aktuelle Spannung linear in einer programmierten Zeit TIME auf den programmierten Spannungs-Wert V.

Eingabebereich
Spannung V: | 0 bis 9.999 Volt
Zeit TIME: | 0 bis 1.999 Sekunden
Wirkung

M203 wirkt solange, bis über M200, M201, M202, M203 oder M204 eine neue Spannung ausgegeben wird.


Spannung als Funktion der Zeit ausgeben (zeitabhängiger Puls): M204

Verhalten mit M204

Die TNC gibt eine programmierte Spannung als Puls mit einer programmierten Dauer TIME aus.

Eingabebereich
Spannung V: | 0 bis 9.999 Volt
Zeit TIME: | 0 bis 1.999 Sekunden
Wirkung

M204 wirkt solange bis über M200, M201, M202, M203 oder M204 eine neue Spannung ausgegeben wird.


Programmieren: Sonderfunktionen

Weitere Informationen:
> Übersicht Sonderfunktionen
> Dynamische Kollisionsüberwachung (Software-Option)
> Spannmittelüberwachung (Software-Option DCM)
> Werkzeugträger-Verwaltung (Software-Option DCM)
> Globale Programm-einstellungen (Software-Option)
> Adaptive Vorschubregelung AFC (Software-Option)
> Aktive Ratterunterdrückung ACC (Software-Option)
> Text-Dateien erstellen
> Arbeiten mit Schnittdaten-Tabellen


Übersicht Sonderfunktionen

Die TNC stellt für verschiedenste Anwendung folgende leistungsfähige Sonderfunktionen zur Verfügung:

Funktion | Beschreibung
Dynamische Kollisionsüberwachung DCM mit integrierter Spannmittelverwaltung (Software-Option) | Dynamische Kollisionsüberwachung (Software-Option)
Globale Programmeinstellungen GS (Software-Option) | Globale Programm-einstellungen (Software-Option)
Adaptive Vorschubregelung AFC (Software-Option) | Adaptive Vorschubregelung AFC (Software-Option)
Ratterunterdrückung ACC (Software-Option) | Aktive Ratterunterdrückung ACC (Software-Option)
Arbeiten mit Textdateien | Text-Dateien erstellen
Arbeiten mit Schnittdatentabellen | Arbeiten mit Schnittdaten-Tabellen

Über die Taste SPEC FCT und die entsprechenden Softkeys, haben Sie Zugriff auf weitere Sonderfunktionen der TNC. In den folgenden Tabellen erhalten Sie eine Übersicht, welche Funktionen verfügbar sind.

Weitere Informationen:
> Hauptmenü Sonderfunktionen SPEC FCT
> Menü Programmvorgaben
> Menü Funktionen für Kontur- und Punktbearbeitungen
> Menü Funktionen für Kontur- und Punktbearbeitungen
> Menü verschiedene DIN/ISO-Funktionen definieren


Hauptmenü Sonderfunktionen SPEC FCT

Sonderfunktionen wählen

Funktion | Softkey | Beschreibung
Funktionen für Kontur- und Punktbearbeitungen |  | Menü Funktionen für Kontur- und Punktbearbeitungen
PLANE-Funktion definieren |  | PLANE-Funktion definieren
Verschiedene DIN/ISO-Funktionen definieren |  | Menü verschiedene DIN/ISO-Funktionen definieren
Gliederungspunkt definieren |  | Programme gliedern


Menü Programmvorgaben

Menü Programmvorgaben wählen

Funktion | Softkey | Beschreibung
Rohteil definieren |  | Rohteil definieren: G30/G31
Werkstoff definieren |  | Werkstück-Material im NC-Programm festlegen
Nullpunkt-Tabelle wählen |  | Siehe Benutzer-Handbuch Zyklen
Aufspannung laden |  | Aufspannung programmgesteuert laden
Aufspannung rücksetzen |  | Aufspannung programmgesteuert laden


Menü Funktionen für Kontur- und Punktbearbeitungen

Menü für Funktionen zur Kontur- und Punktbearbeitung wählen

Funktion | Softkey | Beschreibung
Menü für komplexe Konturformel aufrufen |  | Siehe Benutzer-Handbuch Zyklen
Punkte-Datei mit Bearbeitungspositionen wählen |  | Siehe Benutzer-Handbuch Zyklen


Menü Funktionen für Kontur- und Punktbearbeitungen

Menü für Funktionen zur Kontur- und Punktbearbeitung wählen

Funktion | Softkey | Beschreibung
Konturdefinition wählen |  | Siehe Benutzer-Handbuch Zyklen
Konturbeschreibung zuweisen |  | Siehe Benutzer-Handbuch Zyklen
Komplexe Konturformel definieren |  | Siehe Benutzer-Handbuch Zyklen


Menü verschiedene DIN/ISO-Funktionen definieren

Menü zur Definition verschiedener Klartext-Funktionen wählen

Funktion | Softkey | Beschreibung
String-Funktionen definieren |  | String-Parameter


Dynamische Kollisionsüberwachung (Software-Option)

Weitere Informationen:
> Funktion
> Kollisionsüberwachung in den manuellen Betriebsarten
> Kollisionsüberwachung im Automatikbetrieb
> Grafische Darstellung des Schutzraumes (FCL4-Funktion)
> Kollisionsüberwachung in der Betriebsart Programm-Test


Funktion

Die dynamische Kollisionsüberwachung DCM (engl.: Dynamic Collision Monitoring) muss von Ihrem Maschinenhersteller an die TNC und an die Maschine angepasst werden. Beachten Sie Ihr Maschinenhandbuch.

Der Maschinenhersteller kann beliebige Objekte definieren, die von der TNC bei allen Maschinenbewegungen und auch im Programm-Test überwacht werden. Unterschreiten zwei kollisionsüberwachte Objekte einen bestimmten Abstand zueinander, gibt die TNC beim Programm-Test und der Bearbeitung eine Fehlermeldung aus.

Die definierten Kollisionskörper kann die TNC in allen Maschinenbetriebsarten und der Betriebsart Programm-Test grafisch darstellen (siehe Grafische Darstellung des Schutzraumes (FCL4-Funktion)).

Die TNC überwacht auch das aktive Werkzeug mit der in der Werkzeug-Tabelle eingetragenen Länge und dem eingetragenen Radius auf Kollision (zylindrisches Werkzeug vorausgesetzt). Stufenwerkzeug überwacht die TNC ebenfalls entsprechend der Definition in der Werkzeug-Tabelle und stellt dieses auch entsprechend dar.

Sofern Sie für das jeweilige Werkzeug eine eigene Trägerkinematik incl. einer Kollisionskörper-Beschreibung definiert und dem Werkzeug in der Spalte KINEMATIC der Werkzeug-Tabelle zugewiesen haben, überwacht die TNC auch diesen Werkzeugträger (siehe Werkzeugträger-Kinematik).

Darüber hinaus können Sie auch einfache Spannmittel in die Kollisionsüberwachung integrieren (siehe Spannmittelüberwachung (Software-Option DCM)).

    Beachten Sie folgende Einschränkungen:

  • DCM hilft die Kollisionsgefahr zu reduzieren. Die TNC kann jedoch nicht alle Konstellationen im Betrieb berücksichtigen.
  • Kollisionen von definierten Maschinenkomponenten und dem Werkzeug mit dem Werkstück werden von der TNC nicht erkannt.
  • DCM kann nur Maschinenkomponenten vor Kollision schützen, die Ihr Maschinenhersteller richtig bezüglich Abmessungen und Position im Maschinen-Koordinatensystem definiert hat.
  • Die TNC kann das Werkzeug nur dann überwachen, wenn in der Werkzeug-Tabelle ein positiver Werkzeug-Radius definiert ist. Ein Werkzeug mit Radius 0 (kommt oftmals bei Bohrwerkzeugen zum Einsatz) kann die TNC nicht überwachen und gibt daher eine entsprechende Fehlermeldung aus.
  • Die TNC kann nur Werkzeuge überwachen, für die Sie positive Werkzeug-Längen definiert haben.
  • Beim Starten eines Tastsystem-Zyklus überwacht die TNC die Taststift-Länge und den Tastkugel-Durchmesser nicht mehr, damit Sie auch innerhalb von Kollisionskörpern antasten können.
  • Bei bestimmten Werkzeugen (z.B. bei Messerköpfen) kann der kollisionsverursachende Durchmesser größer sein als die durch die Werkzeug-Korrekturdaten definierten Abmessungen.
  • Die Funktion „Handradüberlagerung“ (M118 und globale Programmeinstellungen) ist in Verbindung mit der Kollisionsüberwachung nur in gestopptem Zustand (STIB blinkt) möglich. Um M118 ohne Einschränkung nutzen zu können müssen Sie DCM entweder über Softkey im Menü Kollisionsüberwachung (DCM) abwählen, oder eine Kinematik ohne Kollisionskörper (CMOs) aktivieren
  • Bei den Zyklen zum „Gewindebohren ohne Ausgleichsfutter“ funktioniert DCM nur dann, wenn per MP7160 die exakte Interpolation der Werkzeugachse mit der Spindel aktiviert ist


Kollisionsüberwachung in den manuellen Betriebsarten

In den Betriebsarten Manuell oder El. Handrad stoppt die TNC eine Bewegung, wenn zwei kollisionsüberwachte Objekte einen Abstand zueinander von 3 bis 5 mm unterschreiten. In diesem Fall zeigt die TNC eine Fehlermeldung an, in der die beiden kollisionsverursachenden Körper benannt sind.

Wenn Sie die Bildschirm-Aufteilung so gewählt haben, dass links Positionen und rechts Kollisionskörper dargestellt werden, dann färbt die TNC zusätzlich die kollidierenden Kollisionskörper rot ein.

Nach Anzeige der Kollisionswarnung ist eine Maschinenbewegung mit Richtungstaste oder Handrad nur noch möglich, wenn die Bewegung den Abstand der Kollisionskörper vergrößert, also beispielsweise durch Drücken der entgegengesetzten Achs-Richtungstaste.

Bewegungen, die den Abstand verkleinern oder gleich lassen, sind nicht erlaubt, solange die Kollisionsüberwachung aktiv ist.
Weitere Informationen:
> Kollisionsüberwachung deaktivieren


Kollisionsüberwachung deaktivieren

Wenn Sie den Abstand zwischen kollisionsüberwachten Objekten aus Platzgründen verringern müssen, ist die Kollisionsüberwachung zu deaktivieren.

Kollisionsgefahr!

Wenn Sie die Kollisionsüberwachung deaktiviert haben, blinkt in der Betriebsartenzeile das Symbol für die Kollisionsüberwachung (siehe nachfolgende Tabelle).

Funktion | Symbol
Symbol, das in der Betriebsartenzeile blinkt, wenn die Kollisionsüberwachung nicht aktiv ist. |

Ggf. Softkey-Leiste umschalten

Menü zum Deaktivieren der Kollisionsüberwachung wählen

Menüpunkt Manueller Betrieb wählen

Kollisionsüberwachung deaktivieren: Taste ENT drücken, das Symbol für die Kollisionsüberwachung in der Betriebsartenzeile blinkt

  • Achsen manuell fahren, auf Verfahrrichtung achten

  • Kollisionsüberwachung wieder aktivieren: Taste ENT drücken


Kollisionsüberwachung im Automatikbetrieb

Die Funktion Handradüberlagerung mit M118 ist in Verbindung mit der Kollisionsüberwachung nur in gestopptem Zustand (STIB blinkt) möglich.

Wenn die Kollisions-Überwachung aktiv ist, zeigt die TNC in der Positions-Anzeige das Symbol [image] an.

Wenn Sie die Kollisionsüberwachung deaktiviert haben, dann blinkt das Symbol für die Kollisionsüberwachung in der Betriebsartenzeile.

Achtung Kollisionsgefahr!

Die Funktionen M140 (siehe Rückzug von der Kontur in Werkzeugachsen-Richtung: M140) und M150 (siehe Endschaltermeldung unterdrücken: M150) führen ggf. zu nicht programmierten Bewegungen, wenn beim Abarbeiten dieser Funktionen von der TNC eine Kollision erkannt wird!

Die TNC überwacht Bewegungen satzweise, gibt also eine Kollisionswarnung in dem Satz aus, der eine Kollision verursachen würde und unterbricht den Programmlauf. Eine Vorschubreduzierung wie im Manuellen Betrieb findet generell nicht statt.


Grafische Darstellung des Schutzraumes (FCL4-Funktion)

Über die Taste Bildschirm-Aufteilung können Sie die an Ihrer Maschine definierten maschinenfesten Kollisionskörper und eingemessene Spannmittel dreidimensional anzeigen lassen (siehe Programmlauf Satzfolge und Programmlauf Einzelsatz).

Per Softkey können Sie zwischen verschiedenen Ansichtmodi wählen:

Funktion | Softkey
Umschalten zwischen Drahtmodell und Volumenansicht |
Umschalten zwischen Volumenansicht und transparenter Ansicht |
Einblenden/ausblenden der Koordinatensysteme, die durch Transformationen in der Kinematikbeschreibung entstehen |
Funktionen zum Drehen, Rotieren und Zoomen |

Sie können die Grafik auch mit der Mouse bedienen. Folgende Funktionen stehen zur Verfügung:

  • Um das dargestellte Modell dreidimensional zu drehen: rechte Mouse-Taste gedrückt halten und Mouse bewegen. Nachdem Sie die rechte Mouse-Taste losgelassen haben, orientiert die TNC das Werkstück auf die definierte Ausrichtung

  • Um das dargestellte Modell zu verschieben: mittlere Mouse-Taste, bzw. Mouse-Rad, gedrückt halten und Mouse bewegen. Die TNC verschiebt das Modell in die entsprechende Richtung. Nachdem Sie die mittlere Mouse-Taste losgelassen haben, verschiebt die TNC das Modell auf die definierte Position

  • Um mit der Mouse einen bestimmten Bereich zu zoomen: mit gedrückter linker Mouse-Taste den rechteckigen Zoom-Bereich markieren, Sie können den Zoom-Bereich durch horizontales und vertikales Bewegen der Mouse noch verschieben. Nachdem Sie die linke Mouse-Taste losgelassen haben, vergrößert die TNC das Werkstück auf den definierten Bereich

  • Um mit der Mouse schnell aus- und einzuzoomen: Mouserad vor bzw. zurückdrehen

  • Doppelklick mit der rechten Mouse-Taste: Standardansicht anwählen


Kollisionsüberwachung in der Betriebsart Programm-Test

Weitere Informationen:
> Anwendung
> Voraussetzungen
> Kollisionstest durchführen


Anwendung

Mit dieser Funktion können Sie bereits vor dem Abarbeiten eine Kollisionsprüfung durchführen.


Voraussetzungen

Um einen grafischen Simulationstest durchführen zu können, muss Ihr Maschinenhersteller diese Funktion freigegeben haben.


Kollisionstest durchführen

Den Bezugspunkt für den Kollisionstest legen Sie in der MOD-Funktion Rohteil im Arbeitsraum fest (siehe Rohteil im Arbeitsraum darstellen)!

Betriebsart Programm-Test wählen

Programm wählen, dass Sie auf Kollision prüfen wollen

Bildschirm-Aufteilung programm+kinematik oder KINEMATIK wählen

Softkeyleiste zweimal umschalten

Kollisionsprüfung auf EIN setzen

Softkeyleiste zweimal zurückschalten

Programm-Test starten

Per Softkey können Sie auch zwischen verschiedenen Ansichtmodi wählen:

Funktion | Softkey
Umschalten zwischen Drahtmodell und Volumenansicht |
Umschalten zwischen Volumenansicht und transparenter Ansicht |
Einblenden/ausblenden der Koordinatensysteme, die durch Transformationen in der Kinematikbeschreibung entstehen |
Funktionen zum Drehen, Rotieren und Zoomen |

Mausbedienung: (siehe Grafische Darstellung des Schutzraumes (FCL4-Funktion))


Spannmittelüberwachung (Software-Option DCM)

Weitere Informationen:
> Grundlagen
> Spannmittelvorlagen
> Spannmittel parametrisieren: FixtureWizard
> Spannmittel auf der Maschine platzieren
> Spannmittel ändern
> Spannmittel entfernen
> Position des eingemessenen Spannmittels prüfen
> Aufspannungen verwalten


Grundlagen

Um die Spannmittelüberwachung nutzen zu können, muss Ihr Maschinenhersteller erlaubte Platzierungspunkte in der Kinematikbeschreibung definiert haben. Maschinenhandbuch beachten!

Ihre Maschine muss über ein schaltendes Tastsystem zur Werkstück-Vermessung verfügen, ansonsten können Sie das Spannmittel nicht auf der Maschine platzieren.

Über die Spannmittelverwaltung im manuellen Betrieb können Sie einfache Spannmittel im Arbeitsbereich der Maschine platzieren, um eine Kollisionsüberwachung zwischen Werkzeug und Spannmittel zu realisieren.

    Um Spannmittel platzieren zu können sind mehrere Arbeitsschritte erforderlich:

  • Spannmittelvorlage modellieren
    HEIDENHAIN stellt auf der HEIDENHAIN-Website Spannmittelvorlagen wie Schraubstöcke oder Backenfutter in einer Spannmittelbibliothek zur Verfügung (siehe Spannmittelvorlagen), die mit einer PC-Software erstellt wurden (KinematicsDesign). Ihr Maschinenhersteller kann zusätzliche Spannmittelvorlagen modellieren und Ihnen zur Verfügung stellen. Spannmittelvorlagen besitzen die Dateiendung cft
  • Spannmittel parametrisieren: FixtureWizard
    Mit dem FixtureWizard (fixture = engl.: Spannvorrichtung) definieren Sie die genauen Abmessungen des Spannmittels durch Parametrisierung der Spannmittelvorlage. Der FixtureWizard steht innerhalb der Spannmittelverwaltung der TNC zur Verfügung und erzeugt ein platzierbares Spannmittel mit konkreten, von Ihnen zu definierenden Abmessungen (siehe Spannmittel parametrisieren: FixtureWizard). Platzierbare Spannmittel besitzen die Dateiendung cfx
  • Spannmittel auf der Maschine platzieren
    In einem interaktiven Menü führt Sie die TNC durch den eigentlichen Einmessvorgang. Der Einmessvorgang besteht im wesentlichen im Ausführen verschiedener Antast-Funktionen am Spannmittel und der Eingabe von variablen Größen wie beispielsweise des Backenabstandes eines Schraubstocks (siehe Spannmittel auf der Maschine platzieren)
  • Position des eingemessenen Spannmittels prüfen
    Nachdem Sie das Spannmittel platziert haben können Sie von der TNC bei Bedarf ein Messprogramm erstellen lassen, mit dem Sie die Istposition des platzierten Spannmittels mit der Sollposition überprüfen lassen können. Die TNC gibt bei zu großen Abweichungen zwischen Soll- und Istposition eine Fehlermeldung aus (siehe Position des eingemessenen Spannmittels prüfen)


Spannmittelvorlagen

HEIDENHAIN stellt verschiedene Spannmittelvorlagen in einer Spannmittelbibliothek zur Verfügung. Setzen Sie sich bitte bei Bedarf mit HEIDENHAIN (E-Mail-Adresse: service.nc-pgm@heidenhain.de) oder Ihrem Maschinen-Hersteller in Verbindung.


Spannmittel parametrisieren: FixtureWizard

Mit dem FixtureWizard erstellen Sie aus einer Spannmittelvorlage ein Spannmittel mit exakten Abmessungen. Spannmittelvorlagen für Standard-Spannmittel stellt HEIDENHAIN zur Verfügung, ggf. erhalten Sie Spannmittelvorlagen auch von Ihrem Maschinenhersteller.

Bevor Sie den FixtureWizard starten, müssen Sie die zu parametrisierende Spannmittelvorlage auf die TNC kopiert haben!

Spannmittelverwaltung aufrufen

FixtureWizard starten: Die TNC öffnet das Menü zur Parametrisierung von Spannmittelvorlagen

Spannmittelvorlage wählen: Die TNC öffnet das Fenster zur Auswahl einer Spannmittelvorlage (Dateien mit Dateiendung cft). Die TNC zeigt ein Vorschaubild an, wenn das Hellfeld auf eine CFT-Datei steht

Mit der Mouse die Spannmittelvorlage wählen, die Sie parametrisieren wollen, mit Taste Öffnen bestätigen

Alle im linken Fenster dargestellten Spannmittelparameter eingeben, Cursor mit Pfeiltasten auf das nächste Eingabefeld bewegen. Die TNC aktualisiert nach der Werteingabe die 3D-Ansicht des Spannmittels im Fenster rechts unten. Sofern verfügbar, zeigt die TNC im Fenster rechts oben ein Hilfsbild an, dass den einzugebenden Spannmittelparameter grafisch darstellt

Name des parametrisierten Spannmittels im Eingabefeld Ausgabedatei eingeben und mit Schaltfläche Datei generieren bestätigen. Die Eingabe einer Dateiendung (cfx für parametrisierte Spannmittel) ist nicht erforderlich

FixtureWizard beenden

Weitere Informationen:
> FixtureWizard bedienen


FixtureWizard bedienen

Die Bedienung des FixtureWizard erfolgt primär mit der Mouse. Die Bildschirm-Aufteilung können Sie durch Ziehen der Trennlinien so einstellen, dass Parameter, Hilfsbild und 3D-Grafik in der von Ihnen bevorzugten Größe von der TNC dargestellt werden.

    Die Darstellung der 3D-Grafik können Sie wie folgt verändern:

    • Modell Vergrößern/Verkleinern:
      Drehen des Mouse-Rads vergrößert oder verkleinert das Modell
    • Modell verschieben:
      Drücken des Mouse-Rads und gleichzeitiges Bewegen der Mouse verschiebt das Modell
    • Modell drehen:
      Rechte Mouse-Taste gedrückt halten und gleichzeitiges Bewegen der Mouse dreht das Modell

Darüber hinaus stehen Icons zur Verfügung, die folgende Funktionen durch Anklicken ausführen:

Funktion | Icon
FixtureWizard Beenden |
Spannmittelvorlage (Dateien mit Dateiendung cft) wählen |
Umschalten zwischen Drahtmodell und Volumenansicht |
Umschalten zwischen Volumenansicht und transparenter Ansicht |
Anzeigen/Ausblenden der Bezeichnungen der im Spannmittel definierten Kollisionskörper |
Anzeigen/Ausblenden der im Spannmittel definierten Prüfpunkte (keine Funktion im ToolHolderWizard) |
Anzeigen/Ausblenden der im Spannmittel definierten Einmesspunkte (keine Funktion im ToolHolderWizard) |
Ausgangsposition der 3D-Ansicht wieder herstellen |


Spannmittel auf der Maschine platzieren

Bevor Sie ein Spannmittel platzieren, Tastsystem einwechseln!

Spannmittelverwaltung aufrufen

Spannmittel wählen: Die TNC öffnet das Menü zur Spannmittelauswahl und zeigt im linken Fenster alle im aktiven Verzeichnis verfügbaren Spannmittel an. Sobald Sie ein Spannmittel angewählt haben, zeigt die TNC im rechten Fenster eine grafische Vorschau an, die es Ihnen erleichtert das richtige Spannmittel auszuwählen. Spannmittel besitzen die Dateiendung CFX

Im linken Fenster per Mouse oder per Pfeiltasten ein Spannmittel wählen. Die TNC zeigt im rechten Fenster eine Vorschau des jeweils selektierten Spannmittels an

Spannmittel übernehmen: Die TNC ermittelt die erforderliche Messreihenfolge und zeigt diese im linken Fenster an. Im rechten Fenster stellt die TNC das Spannmittel dar. Einmesspunkte sind am Spannmittel mit einem farbigen Bezugspunkt-Symbol markiert. Zusätzlichen zeigt eine Nummerierung, in welcher Reihenfolge Sie das Spannmittel einmessen müssen

Einmessvorgang starten: Die TNC zeigt eine Softkeyleiste mit erlaubten Antast-Funktionen für den jeweilige Messvorgang an

Erforderliche Antast-Funktion wählen: Die TNC befindet sich im Menü zum manuellen Antasten. Beschreibung der Antast-Funktionen: Siehe Übersicht

Am Ende des Antastvorgangs zeigt die TNC am Bildschirm die ermittelten Messwerte an

Messwerte übernehmen: Die TNC beendet den Einmessvorgang, hakt diesen in der Messreihenfolge ab und setzt das Hellfeld auf die folgende Aufgabe

Wenn im jeweiligen Spannmittel eine Werteingabe erforderlich ist, blendet die TNC am unteren Ende des Bildschirms ein Eingabefeld ein. Abgefragten Wert, z.B. Spannweite eines Schraubstocks, eingeben und mit Softkey WERT ÜBERNEHMEN bestätigen

Wenn alle Einmessaufgaben von der TNC abgehakt sind: Mit Softkey FERTIGSTELLEN den Einmessvorgang beenden

Die Messreihenfolge ist in der Spannmittelvorlage festgelegt. Sie müssen die Messreihenfolge Schritt für Schritt von oben nach unten durchlaufen.

Bei Mehrfachaufspannungen müssen Sie jedes Spannmittel separat platzieren.


Spannmittel ändern

Änderbar sind ausschließlich Werteingaben. Die Position des Spannmittels auf dem Maschinentisch lässt sich nachträglich nicht mehr korrigieren. Wenn Sie die Position des Spannmittel verändern, dann müssen Sie es entfernen und neu platzieren!

Spannmittelverwaltung aufrufen

Mit der Mouse oder mit den Pfeiltasten das Spannmittel wählen, das Sie ändern wollen: Die TNC markiert das gewählte Spannmittel in der Maschinenansicht farbig

Gewähltes Spannmittel ändern: Die TNC zeigt im Fenster Messreihenfolge die Spannmittelparameter an, die Sie verändern können

Entfernen mit Softkey JA bestätigen oder mit Softkey NEIN abbrechen


Spannmittel entfernen

Achtung Kollisionsgefahr!

Wenn Sie ein Spannmittel entfernen, dann überwacht die TNC dieses Spannmittel nicht mehr auch wenn es noch auf dem Maschinentisch aufgespannt ist!

Spannmittelverwaltung aufrufen

Mit der Mouse oder mit den Pfeiltasten das Spannmittel wählen, das Sie entfernen wollen: Die TNC markiert das gewählte Spannmittel in der Maschinenansicht farbig

Gewähltes Spannmittel entfernen

Entfernen mit Softkey JA bestätigen oder mit Softkey NEIN abbrechen


Position des eingemessenen Spannmittels prüfen

Um eingemessene Spannmittel zu überprüfen, können Sie von der TNC ein Prüfprogramm erzeugen lassen. Das Prüfprogramm müssen Sie in der Betriebsart Satzfolge abarbeiten. Die TNC tastet dabei Prüfpunkte an, die vom Spannmittel-Designer in der Spannmittelvorlage festgelegt sind und wertet diese aus. Das Ergebnis der Prüfung erhalten Sie als Protokoll auf dem Bildschirm und als Protokolldatei.

Die TNC speichert Prüfprogramme grundsätzlich immer im Verzeichnis TNC:system\Fixture\TpCheck_PGM.

Spannmittelverwaltung aufrufen

Im Fenster Platzierte Spannmittel das zu prüfende Spannmittel mit der Mouse markieren: Die TNC stellt das markierte Spannmittel in der 3D-Ansicht andersfarbig dar

Dialog zum Erstellen des Prüfprogramms starten: Die TNC öffnet das Fenster zur Eingabe der Prüfprogramm-Parameter

Manuelle Positionierung: Festlegen, ob Sie das Tastsystem manuell oder automatisch zwischen den einzelnen Prüfpunkten positionieren wollen: 1: Manuell positionieren; Sie müssen jeden Prüfpunkt mit den Achsrichtungs-Tasten anfahren und den Messvorgang mit NC-Start bestätigen 0: Prüfprogramm läuft, nachdem Sie das Tastsystem manuell auf sichere Höhe vorpositioniert haben, vollautomatisch ab

Vorschub Messen: Tastsystem-Vorschub in mm/min für den Messvorgang. Eingabebereich 0 bis 3000

Vorschub Vorpositionieren: Positioniervorschub in mm/min zum Anfahren der einzelnen Messpositionen. Eingabebereich 0 bis 99999,999

Sicherheits-Abstand: Sicherheits-Abstand zum Messpunkt, den die TNC beim Vorpositionieren einhalten soll. Eingabebereich 0 bis 99999,9999

Toleranz: Maximal erlaubte Abweichung zwischen Soll- und Istposition der jeweiligen Prüfpunkte. Eingabebereich 0 bis 99999,999. Überschreitet ein Prüfpunkt die Toleranz, gibt die TNC eine Fehlermeldung aus

Werkzeugnummer/Werkzeugname: Werkzeug-Nummer oder -Name des Tastsystem. Eingabebereich 0 bis 30000,9 bei Nummerneingabe, maximal 16 Zeichen bei Namenseingabe. Bei Namenseingabe den Werkzeug-Namen zwischen Hochkommata eingeben

Eingaben bestätigen: Die TNC erstellt das Prüfprogramm, zeigt den Namen des Prüfprogramms in einem Übernlendfenster an und fragt, ob Sie das Prüfprogramm abarbeiten wollen

Mit NEIN beantworten, wenn Sie das Prüfprogramm später abarbeiten wollen, mit Ja beantworten, wenn Sie das Prüfprogramm gleich abarbeiten wollen

Wenn Sie mit Ja bestätigt haben wechselt die TNC in die Betriebsart Satzfolge und wählt das erstellte Prüfprogramm automatisch an

Prüfprogramm starten: Die TNC fordert Sie auf, das Tastsystem manuell so vorzupositionieren, dass es auf sicherer Höhe steht. Den Anweisungen im Überblendfenster folgen

Messvorgang starten: Die TNC fährt jeden Prüfpunkt nacheinander an. Sie legen dabei per Softkey die Positionierstrategie fest. Jeweils mit NC-Start bestätigen

Am Ende des Prüfprogramms zeigt die TNC ein Überblendfenster mit den Abweichungen von der Sollposition an. Liegt ein Prüfpunkt ausserhalb der Toleranz, dann gibt die TNC einen Fehlertext in das Überblendfenster aus


Aufspannungen verwalten

Eingemessenne Spannmittel können Sie über die Archiv-Funktion sichern und wiederherstellen. Diese Funktion ist insbesondere für Nullpunkt-Spannsysteme hilfreich und beschleunigt den Einrichtevorgang erheblich.

Weitere Informationen:
> Funktionen zum Verwalten von Aufspannungen
> Aufspannung sichern
> Aufspannung manuell laden
> Aufspannung programmgesteuert laden
> Aufspannung programmgesteuert deaktivieren


Funktionen zum Verwalten von Aufspannungen

Folgende Funktionen stehen zur Verwaltung von Aufspannungen zur Verfügung:

Funktion | Softkey
Aufspannung sichern |
Gespeicherte Aufspannung laden |
Gespeicherte Aufspannung kopieren |
Gespeicherte Aufspannung umbenennen |
Gespeicherte Aufspannung löschen |


Aufspannung sichern

Ggf. Spannmittelverwaltung aufrufen

Mit Pfeiltasten das Spannmittel wählen das Sie sichern wollen

Archivfunktion wählen: Die TNC blendet ein Fenster ein und zeigt bereits gespeicherte Aufspannungen an

Aktives Spannmittel in ein Archiv (ZIP-Datei) sichern: Die TNC blendet ein Fenster ein, in dem Sie den Archivnamen definieren können

Gewünschten Dateinamen eingeben und mit Softkey ja bestätigen: Die TNC speichert das ZIP-Archiv in einem festen Archivordner ab (TNC:\system\Fixture\Archive)


Aufspannung manuell laden

Ggf. Spannmittelverwaltung aufrufen

Ggf. mit Pfeiltasten den Einhängepunkt wählen auf dem Sie eine gespeicherte Aufspannung wiederherstellen wollen

Archivfunktion wählen: Die TNC blendet ein Fenster ein und zeigt bereits gespeicherte Aufspannungen an

Mit Pfeiltasten die Aufspannung wählen, die Sie wiederherstellen wollen

Gewählte Aufspannung laden: Die TNC aktiviert die gewählte Aufspannung und zeigt das in der Aufspannung enthaltene Spannmittel grafisch an

Wenn Sie die Aufspannung auf einen anderen Einhängepunkt wiederherstellen, dann müssen Sie die entsprechende Dialogfrage der TNC mit dem Softkey JA bestätigen.


Aufspannung programmgesteuert laden

Gesicherte Aufspannungen können Sie auch programmgesteuert aktivieren und deaktivieren. Gehen Sie dabei wie folgt vor:

Softkey-Leiste mit Sonderfunktionen einblenden

Gruppe PROGRAMM VORGABEN wählen.

Softkey-Leiste weiterschalten

Pfad- und Dateiname der gespeicherten Aufspannung angeben, mit Taste ENT bestätigen, oder über den Softkey AUSWAHL FENSTER den Datei-Auswahldialog öffnen, um die gespeicherte Aufspannung zu wählen. Die TNC zeigt im Auswahldialog ein Vorschaubild an, wenn Sie das Hellfeld auf eine gespeicherte Aufspannung setzen

Gespeicherte Aufspannungen befinden sich standardmäßig im Verzeichnis TNC:\system\Fixture\Archive.

Darauf achten, dass die zu ladende Aufspannung auch mit der aktiven Kinematik gesichert wurde.

Darauf achten, dass beim automatischen Aktivieren einer Aufspannung kein anderes Spannmittel aktiv ist, ggf. zuvor die Funktion FIXTURE SELECTION RESET verwenden.

Aufspannungen können Sie auch über Paletten-Tabellen in der Spalte FIXTURE aktivieren.


Aufspannung programmgesteuert deaktivieren

Eine aktive Aufspannungen können Sie programmgesteuert deaktivieren. Gehen Sie dabei wie folgt vor:

Softkey-Leiste mit Sonderfunktionen einblenden

Gruppe PROGRAMM VORGABEN wählen.

Softkey-Leiste weiterschalten

Funktion zum Rücksetzen wählen, mit Taste END bestätigen


Werkzeugträger-Verwaltung (Software-Option DCM)

Weitere Informationen:
> Grundlagen
> Werkzeugträger-Vorlagen
> Werkzeugträger parametrisieren: ToolHolderWizard
> Werkzeugträger entfernen


Grundlagen

Ihre Maschinenhersteller muss die TNC für diese Funktion angepasst haben, Maschinenhandbuch beachten.

Analog zur Spannmittelüberwachung können Sie auch Werkzeugträger mit in die Kollisionsüberwachung integrieren.

    Um Werkzeugträger für die Kollisionsüberwachung aktivieren zu können, sind mehrere Arbeitsschritte erforderlich:

  • Werkzeugträger modellieren
    HEIDENHAIN stellt auf der HEIDENHAIN-Website Werkzeugträgervorlagen, die mit einer PC-Software erstellt wurden (KinematicsDesign). Ihr Maschinenhersteller kann zusätzliche Werkzeugträgervorlagen modellieren und Ihnen zur Verfügung stellen. Werkzeugträgervorlagen besitzen die Dateiendung cft
  • Werkzeugträger parametrisieren: ToolHolderWizard
    Mit dem ToolHolderWizard (toolholder = engl.: Werkzeugträger) definieren Sie die genauen Abmessungen des Trägers durch Parametrisierung der Werkzeugträgervorlage. Den ToolHolderWizard rufen Sie aus der Werkzeug-Tabelle auf, wenn Sie eine Werkzeugträger-Kinematik einem Werkzeug zuweisen wollen. Parametrisierte Werkzeugträger besitzen die Dateiendung cfx
  • Werkzeugträger aktivieren
    In der Werkzeug-Tabelle TOOL.T weisen Sie einem Werkzeug in der Spalte KINEMATIC den gewünschten Werkzeugträger zu (siehe Trägerkinematik zuweisen)


Werkzeugträger-Vorlagen

HEIDENHAIN stellt verschiedene Werkzeugträger-Vorlagen zur Verfügung. Setzen Sie sich bitte bei Bedarf mit HEIDENHAIN (E-Mail-Adresse: service.nc-pgm@heidenhain.de) oder Ihrem Maschinen-Hersteller in Verbindung.


Werkzeugträger parametrisieren: ToolHolderWizard

Mit dem ToolHolderWizard erstellen Sie aus einer Werkzeugträger-Vorlage einen Werkzeugträger mit exakten Abmessungen. Vorlagen dafür stellt HEIDENHAIN zur Verfügung, ggf. erhalten Sie Werkzeugträger-Vorlagen auch von Ihrem Maschinenhersteller.

Bevor Sie den ToolHolderWizard starten, müssen Sie die zu parametrisierende Werkzeugträger-Vorlage auf die TNC kopiert haben!

Um einem Werkzeug eine Trägerkinematik zuzuweisen, gehen Sie wie folgt vor:

  • Beliebige Maschinen-Betriebsart wählen

Werkzeug-Tabelle wählen: Softkey WERKZEUG TABELLE drücken

Softkey EDITIEREN auf „EIN“ setzen

Letzte Softkeyleiste wählen

Liste der verfügbaren Kinematik einblenden: Die TNC zeigt alle Trägerkinematiken (.TAB-Dateien) und alle bereits von Ihnen parametrisierten Werkzeugträger-Kinematiken (.CFX-Dateien) an

ToolHolderWizard aufrufen

Werkzeugträger-Vorlage wählen: Die TNC öffnet das Fenster zur Auswahl einer Werkzeugträger-Vorlage (Dateien mit Dateiendung cft)

Mit der Mouse die Werkzeugträger-Vorlage wählen, die Sie parametrisieren wollen, mit Taste Öffnen bestätigen

Alle im linken Fenster dargestellten Parameter eingeben, Cursor mit Pfeiltasten auf das nächste Eingabefeld bewegen. Die TNC aktualisiert nach der Werteingabe die 3D-Ansicht des Werkzeugträgers im Fenster rechts unten. Sofern verfügbar, zeigt die TNC im Fenster rechts oben ein Hilfsbild an, dass den einzugebenden Parameter grafisch darstellt

Name des parametrisierten Werkzeugträgers im Eingabefeld Ausgabedatei eingeben und mit Schaltfläche Datei generieren bestätigen. Die Eingabe einer Dateiendung (cfx für parametrisierte Spannmittel) ist nicht erforderlich

ToolHolderWizard beenden

Weitere Informationen:
> ToolHolderWizard bedienen


ToolHolderWizard bedienen

Die Bedienung des ToolHolderWizard ist identisch mit der Bedienung des FixtureWizards: (siehe FixtureWizard bedienen).


Werkzeugträger entfernen

Achtung Kollisionsgefahr!

Wenn Sie einen Werkzeugträger entfernen, dann überwacht die TNC diesen Träger nicht mehr auch wenn er noch in der Spindel steckt!

  • Namen des Werkzeugträgers aus der Spalte KINEMATIC der Werkzeug-Tabelle TOOL.T löschen.


Globale Programm-einstellungen (Software-Option)

Weitere Informationen:
> Anwendung
> Technische Voraussetzungen
> Funktion aktivieren/deaktivieren
> Grunddrehung
> Achsen tauschen
> Überlagertes Spiegeln
> Zusätzliche, additive Nullpunkt-Verschiebung
> Sperren von Achsen
> Überlagerte Drehung
> Vorschub-Override
> Handrad-Überlagerung
> Limit-Ebene


Anwendung

Die Funktion Globale Programmeinstellungen, die insbesondere im Großformenbau zum Einsatz kommt, steht in den Programmlauf-Betriebsarten und im MDI-Betrieb zur Verfügung. Sie können damit verschiedene Koordinaten-Transformationen und Einstellungen definieren, die global und überlagert für das jeweils angewählte NC-Programm wirken, ohne dass Sie hierfür das NC-Programm verändern müssen.

Sie können globale Programmeinstellungen auch mitten im Programm aktivieren bzw. deaktivieren, sofern Sie den Programmlauf unterbrochen haben (siehe Bearbeitung unterbrechen). Die TNC berücksichtigt die von Ihnen definierten Werte sofort, nachdem Sie das NC-Programm wieder gestartet haben, ggf. fährt die Steuerung über das Wiederanfahrmenü die neue Position an (siehe Wiederanfahren an die Kontur).

Folgende globale Programmeinstellungen stehen zur Verfügung:

Funktionen | Icon | Seite
Grunddrehung |  | Grunddrehung
Achsen tauschen |  | Achsen tauschen
Zusätzliche, additive Nullpunkt-Verschiebung |  | Zusätzliche, additive Nullpunkt-Verschiebung
Überlagertes Spiegeln |  | Überlagertes Spiegeln
Sperren von Achsen |  | Sperren von Achsen
Überlagerte Drehung |  | Überlagerte Drehung
Definition eines global gültigen Vorschubfaktors |  | Vorschub-Override
Definition einer Handrad-Überlagerung, auch in virtueller Achsrichtung VT |  | Handrad-Überlagerung
Definition von Limit-Ebenen, grafisch unterstützt |  | Limit-Ebene

    Wenn Sie die Funktion M91/M92 (Verfahren auf maschinenfeste Positionen) in Ihrem NC-Programm verwendet haben, dann dürfen Sie folgende globale Programmeinstellungen nicht verwenden:

  • Achsen tauschen in den Achsen, in denen Sie maschinenfeste Positionen anfahren
  • Achsen sperren

Die Look Ahead-Funktion M120 können Sie dann verwenden, wenn Sie die globalen Programmeinstellungen vor dem Start des Programms aktiviert haben. Sobald Sie bei aktivem M120 mitten im Programm globale Programmeinstellungen ändern, gibt die TNC eine Fehlermeldung aus und sperrt das weitere Abarbeiten.

Bei aktiver Kollisionsüberwachung DCM können Sie nur mit Handrad-Überlagerung verfahren, wenn Sie das Bearbeitungs-Programm mit extern Stopp unterbrochen haben.

Die TNC stellt alle Achsen, die an Ihrer Maschine nicht aktiv sind, im Formular ausgegraut dar.

Verschiebungswerte und Werte für die Handrad-Überlagerung im Formular sind grundsätzlich in der Maßeinheit mm, Winkelangaben bei Drehungen in Grad zu definieren.


Technische Voraussetzungen

Die Funktion Globale Programmeinstellungen ist eine Software-Option und muss von Ihrem Maschinenhersteller freigeschaltet sein.

Der Maschinenhersteller kann Funktionen zur Verfügung stellen, mit denen Sie globale Programmeinstellungen programmgesteuert setzen und rücksetzen können, z.B. M-Funktionen oder Hersteller-Zyklen. Über Q-Parameter-Funktion können Sie den Status der Globalen Programmeinstellungen GS abfragen.

Um die Funktion Handrad-Überlagerung komfortabel nutzen zu können, empfiehlt HEIDENHAIN die Verwendung des Handrades HR 520 (siehe Verfahren mit elektronischen Handrädern). Die Anwahl der virtuellen Werkzeug-Achse ist mit dem HR 520 direkt möglich.

Das Handrad HR 410 ist grundsätzlich auch nutzbar, Ihr Maschinenhersteller muss dann aber eine Funktionstaste des Handrades zur Anwahl der virtuellen Achse belegen und in seinem PLC-Programm ausprogrammieren.

    Um alle Funktionen uneingeschränkt nutzen zu können, müssen folgende Maschinen-Parameter gesetzt sein:

  • MP7641, Bit 4 = 1: Anwahl der virtuellen Achse am HR 420 erlauben
  • MP7503 = 1: Verfahren in aktiver Werkzeugachsrichtung aktiv in Betriebsart Manuell und bei einer Programm-Unterbrechung
  • MP7682, Bit 9 = 1: Schwenkzustand aus dem Automatikbetrieb automatisch in die Funktion Achsen während einer Programm-Unterbrechung verfahren übernehmen
  • MP7682, Bit 10 = 1: 3D-Korrektur bei aktiver geschwenkter Bearbeitungsebene und aktivem M128 (TCPM) erlauben


Funktion aktivieren/deaktivieren

Globale Programmeinstellungen bleiben solange aktiv, bis Sie von Ihnen wieder manuell zurückgesetzt werden. Beachten Sie, dass Ihr Maschinenhersteller Funktionen zur Verfügung stellen kann, mit denen Sie globale Programmeinstellungen auch programmgesteuert setzen oder zurücksetzen können.

Die TNC zeigt in der Positions-Anzeige das Symbol [image] an, wenn eine beliebige globale Programmeinstellung aktiv ist.

Wenn Sie über die Datei-Verwaltung ein Programm wählen, gibt die TNC eine Warnmeldung aus, wenn globale Programmeinstellungen aktiv sind. Sie können dann per Softkey die Meldung einfach quittieren oder das Formular direkt aufrufen, um Änderungen vorzunehmen.

Globale Programmeinstellungen wirken in der Betriebsart smarT.NC generell nicht.

Programmlauf-Betriebsart oder Betriebsart MDI wählen

Softkey-Leiste umschalten

Formular globale Programmeinstellungen aufrufen

Gewünschte Funktionen mit entsprechenden Werten aktivieren

    Wenn Sie mehrere globale Programmeinstellungen gleichzeitig aktivieren, dann berechnet die TNC die Transformationen intern in folgender Reihenfolge:

  • 1: Grunddrehung
  • 2: Achsentausch
  • 3: Spiegeln
  • 4: Verschiebung
  • 5: Überlagerte Drehung

Die restlichen Funktionen Achsen sperren, Handrad-Überlagerung, Limit-Ebene und Vorschubfaktor wirken unabhängig voneinander.

Um im Formular navigieren zu können stehen die nachfolgend Funktionen zur Verfügung. Zusätzlich können Sie das Formular auch per Mouse bedienen.

Funktionen Taste / Softkey

Sprung zur vorherigen Funktion

Sprung zur nächsten Funktion

Nächstes Element wählen

Vorheriges Element wählen

Funktion Achsen tauschen: Liste der verfügbaren Achsen aufklappen

Funktion Ein-/Ausschalten, wenn Fokus auf einer Checkbox steht

    Funktion globale Programmeinstellungen rücksetzen:

  • Alle Funktionen deaktivieren
  • Alle eingegebenen Werte = 0 setzen, Vorschubfaktor = 100 setzen. Grunddrehung = 0 setzen, wenn keine Grunddrehung im Grunddrehungsmenü oder in der Spalte ROT des aktiven Bezugspunktes in der Preset-Tabelle aktiv ist. Ansonsten setzt die TNC die dort eingetragene Grunddrehung aktiv

Alle Änderungen seit dem letzten Aufruf des Formulares verwerfen

Alle aktiven Funktionen deaktivieren, eingegebene bzw. eingestellte Werte bleiben erhalten

Alle Änderungen speichern und Formular schließen


Grunddrehung

Mit der Funktion Grunddrehung kompensieren Sie eine Werkstück-Schieflage. Die Wirkungsweise entspricht der Funktion Grunddrehung, die Sie im manuellen Betrieb über Antastfunktionen erfassen können. Demzufolge synchronisiert die TNC Werte, die im Grunddrehungsmenü oder der Spalte ROT der Preset-Tabelle eingetragen sind mit dem Formular.

Sie können die Grunddrehungswerte im Formular verändern, die TNC schreibt diesen Wert jedoch nicht zurück in das Grunddrehungsmenü bzw. in die Preset-Tabelle.

Wenn Sie den Softkey Standardwert setzen drücken, dann stellt die TNC die Grunddrehung wieder her, die dem aktiven Bezugspunkt (Preset) zugeordnet ist.

Darauf achten, dass nach Aktivierung dieser Funktion ggf. ein Wiederanfahren an die Kontur erforderlich wird. Die TNC ruft das Wiederanfahr-Menü dann automatisch nach dem Schließen des Formulars auf (siehe Wiederanfahren an die Kontur).

Darauf achten, dass Antast-Zyklen, mit denen Sie eine Grunddrehung während der Programm-Abarbeitung erfassen und schreiben, einen von Ihnen im Formular definierten Wert überschreiben.


Achsen tauschen

Mit der Funktion Achsen tauschen können Sie die in einem beliebigen NC-Programm programmierten Achsen auf die Achskonfiguration Ihrer Maschine oder auf die jeweilige Aufspannsituation anpassen:

Nach Aktivierung der Funktion Achsen tauschen wirken alle nachfolgend durchgeführten Transformationen auf die getauschte Achse.

Darauf achten, dass Sie den Achsentausch sinnvoll durchführen, ansonsten gibt die TNC Fehlermeldungen aus.

Positionierungen auf M91-Positionen sind für getauschte Achsen nicht erlaubt.

Darauf achten, dass nach Aktivierung dieser Funktion ggf. ein Wiederanfahren an die Kontur erforderlich wird. Die TNC ruft das Wiederanfahr-Menü dann automatisch nach dem Schließen des Formulars auf (siehe Wiederanfahren an die Kontur).

  • Im Formular globale Programmeinstellungen den Fokus auf Tauschen Ein/Aus setzen, Funktion mit Taste SPACE aktivieren

  • Mit der Pfeiltaste nach unten den Fokus auf die Zeile setzen, in der links die zu tauschende Achse steht

  • Taste Goto drücken, um die Liste der Achsen anzuzeigen, auf die Sie tauschen wollen

  • Mit der Pfeiltaste nach unten die Achse wählen auf die Sie tauschen wollen und mit Taste ent übernehmen

Wenn Sie mit einer Mouse arbeiten, dann können Sie durch Klick auf das jeweilige Pull-Down-Menü die gewünschte Achse direkt wählen.


Überlagertes Spiegeln

Mit der Funktion überlagertes Spiegeln können Sie alle aktiven Achsen spiegeln.

Die im Formular definierten Spiegelachsen wirken zusätzlich zu bereits im Programm über Zyklus 8 (Spiegeln) definierten Werten.

Darauf achten, dass nach Aktivierung dieser Funktion ggf. ein Wiederanfahren an die Kontur erforderlich wird. Die TNC ruft das Wiederanfahr-Menü dann automatisch nach dem Schließen des Formulars auf (siehe Wiederanfahren an die Kontur).

  • Im Formular globale Programmeinstellungen den Fokus auf Spiegeln Ein/Aus setzen, Funktion mit Taste SPACE aktivieren

  • Mit der Pfeiltaste nach unten den Fokus auf die Achse setzen die Sie spiegeln wollen

  • Taste SPACE drücken, um die Achse zu spiegeln. Erneutes Betätigen der Taste SPACE hebt die Funktion wieder auf

Wenn Sie mit einer Mouse arbeiten, dann können Sie durch Klick auf die jeweilige Achse die gewünschte Achse direkt aktivieren.


Zusätzliche, additive Nullpunkt-Verschiebung

Mit der Funktion additive Nullpunkt-Verschiebung können Sie beliebige Versätze in allen aktiven Achsen kompensieren.

Die im Formular definierten Werte wirken zusätzlich zu bereits im Programm über Zyklus 7 (Nullpunkt-Verschiebung) definierten Werten.

Beachten Sie, dass die Verschiebungen bei aktiver geschwenkter Bearbeitungsebene im Maschinenkoordinatensystem wirken.

Darauf achten, dass nach Aktivierung dieser Funktion ggf. ein Wiederanfahren an die Kontur erforderlich wird. Die TNC ruft das Wiederanfahr-Menü dann automatisch nach dem Schließen des Formulars auf (siehe Wiederanfahren an die Kontur).


Sperren von Achsen

Mit dieser Funktion können Sie alle aktiven Achsen sperren. Die TNC führt dann beim Abarbeiten des Programmes keine Bewegungen in den von Ihnen gesperrten Achsen aus.

Darauf achten, dass beim Aktivieren dieser Funktion die Position der ausgesperrten Achse keine Kollisionen verursacht.

  • Im Formular globale Programmeinstellungen den Fokus auf Sperren Ein/Aus setzen, Funktion mit Taste SPACE aktivieren

  • Mit der Pfeiltaste nach unten den Fokus auf die Achse setzen die Sie sperren wollen

  • Taste SPACE drücken, um die Achse zu sperren. Erneutes Betätigen der Taste SPACE hebt die Funktion wieder auf

Wenn Sie mit einer Mouse arbeiten, dann können Sie durch Klick auf die jeweilige Achse die gewünschte Achse direkt aktivieren.


Überlagerte Drehung

Mit der Funktion überlagerte Drehung können Sie eine beliebige Drehung des Koordinatensystem in der momentan aktiven Bearbeitungsebene definieren.

Die im Formular definierte überlagerte Drehung wirkt zusätzlich zum bereits im Programm über Zyklus 10 (Rotation) definierten Wert.

Darauf achten, dass nach Aktivierung dieser Funktion ggf. ein Wiederanfahren an die Kontur erforderlich wird. Die TNC ruft das Wiederanfahr-Menü dann automatisch nach dem Schließen des Formulars auf (siehe Wiederanfahren an die Kontur).


Vorschub-Override

Mit der Funktion Vorschub-Override können Sie den programmierten Vorschub prozentual reduzieren oder erhöhen. Die TNC erlaubt Eingaben zwischen 1 und 1000%.

Darauf achten, dass die TNC den Vorschubfaktor immer auf den aktuellen Vorschub bezieht, den Sie ggf. bereits durch Änderung des Vorschub-Overrides erhöht oder reduziert haben können.


Handrad-Überlagerung

Mit der Funktion Handrad-Überlagerung erlauben Sie das überlagerte Verfahren mit dem Handrad während die TNC ein Programm abarbeitet. Wenn die Funktion Bearbeitungsebene Schwenken aktiv ist, können Sie per Checkbox wählen, ob Sie das Werkzeug im Maschinenkoordinatensystem oder im geschwenkten Koordinatensystem verfahren wollen.

In der Spalte Max.-Wert definieren Sie den maximal erlaubten Weg, den Sie per Handrad verfahren können. Den tatsächlich in jeder Achse verfahrenen Wert übernimmt die TNC in die Spalte Istwert, sobald Sie den Programmlauf unterbrechen (STIB=OFF). Der istwert bleibt so lange gespeichert, bis Sie diesen löschen, auch über eine Stromunterbrechung hinaus. Den Istwert können Sie auch editieren, die TNC reduziert den von Ihnen eingegebenen Wert ggf. auf den jeweiligen Max.-Wert.

Wenn beim Aktivieren der Funktion ein Istwert eingetragen ist, dann ruft die TNC beim Schließen des Fensters die Funktion Wiederanfahren an die Kontur auf, um den definierten Wert zu verfahren (siehe Wiederanfahren an die Kontur).

Einen bereits im NC-Programm mit M118 definierten maximalen Verfahrweg überschreibt die TNC mit dem im Formular eingetragenen Wert. Bereits mit dem Handrad über M118 verfahrene Werte trägt die TNC wiederum in die Spalte Istwert des Formulares ein, so dass beim Aktivieren kein Sprung in der Anzeige entsteht. Ist der über M118 bereits verfahrene Weg größer als der im Formular erlaubte Maximalwert, dann ruft die TNC beim Schließen des Fensters die Funktion Wiederanfahren an die Kontur auf, um den Differenzwert zu verfahren (siehe Wiederanfahren an die Kontur).

Wenn Sie versuchen einen Istwert einzugeben, der größer als der Max.-Wert ist, gibt die TNC eine Fehlermeldung aus. Istwert grundsätzlich nicht größer als Max.-Wert eingeben.

Weitere Informationen:
> Virtuelle Achse VT


Virtuelle Achse VT

Um mit dem Handrad in virtueller Achsrichtung VT verfahren zu können, müssen Sie die Funktion M128 oder FUNCTION TCPM aktivieren.

In virtueller Achsrichtung können Sie handradüberlagert nur bei inaktivem DCM verfahren.

Sie können eine Handrad-Überlagerung auch in der momentan aktiven Werkzeug-Achsrichtung ausführen. Für die Aktivierung dieser Funktion steht die Zeile VT (virtual toolaxis) zur Verfügung.

Mit dem Handrad in virtueller Achse verfahrene Werte bleiben in der Grundeinstellung auch über einen Werkzeugwechsel hinweg aktiv. Über die Funktion VT-Wert rücksetzen können Sie festlegen, dass die TNC in VT verfahrene Werte beim Werkzeugwechsel zurücksetzt:

  • Im Formular globale Programmeinstellungen den Fokus auf VT-Wert rücksetzen setzen, Funktion mit Taste SPACE aktivieren

Über ein Handrad HR 5xx können Sie die Achse VT direkt anwählen, um überlagert in virtueller Achsrichtung verfahren zu können (siehe Zu verfahrende Achse wählen). Das Arbeiten mit der virtuellen Achse VT ist mit dem Funkhandrad HR 550 FS besonders komfortabel möglich (siehe Verfahren mit elektronischen Handrädern).

Auch in der zusätzlichen Status-Anzeige (Reiter POS) zeigt die TNC den in der virtuellen Achse verfahrenen Wert in einer eigenen Positionsanzeige VT an.

Ihr Maschinenhersteller kann Funktionen zur Verfügung stellen, mit der das Verfahren in virtueller Achsrichtung von der PLC beeinflusst werden kann.


Limit-Ebene

    Mit der Limit-Ebene stellt die TNC eine leistungsfähige Funktion für unterschiedliche Anwendungen zur Verfügung. Insbesondere können Sie damit folgende Bearbeitungen auf einfache Weise realisieren:

  • Endschaltermeldungen vermeiden:
    Im CAM-System erstellte NC-Programme geben oftmals Sicherheits-Positionierungen nahe am Endschalterbereich einer bestimmten Maschine aus. Wenn Sie die Bearbeitung kurzfristig auf eine kleinere Maschine legen müssen führen diese Positioniersätze zu Programmlauf-Unterbrechungen. Mit der Limit-Ebenenfunktion können Sie den Verfahrbereich einer kleineren Maschine einschränken, so dass keine Endschaltermeldungen mehr entstehen.
  • Definierbare Bereiche bearbeiten:
    Bei Reparaturarbeiten, die sich oftmals nur auf einen kleinen Bereich beschränken, können Sie über die Limit-Ebenen den Bereich schnell und einfach, grafisch unterstützt definieren. Die TNC führt die Bearbeitung dann nur innerhalb des definierten Bereichs aus.
  • Bearbeiten auf Limithöhe:
    Über die Definition einer Limit-Ebene in Werkzeugachs-Richtung, können Sie, sofern beispielsweise nur die Schlichtkontur verfügbar ist, durch mehrfaches Versetzen des Limits in die negative Richtung Zustellungen simulieren. Die TNC führt Bearbeitungen außerhalb des Limits dann zwar aus, lässt aber das Werkzeug in der Werkzeugachs-Richtung auf dem jeweils definierten Limit stehen.
Weitere Informationen:
> Funktionsbeschreibung
> Positionierlogik


Funktionsbeschreibung

Achtung Kollisionsgefahr!

Beachten Sie, dass die Definitionen einer oder mehrerere Limitebenen zu Positionierungen führen, die nicht im NC-Programm definiert und somit auch nicht simulierbar sind!

Die Funktion Limitebene ausschließlich in Verbindung mit Geradensätzen verwenden. Die TNC überwacht grundsätzlich keine Kreisbewegungen!

Beim Satzvorlauf auf eine Position außerhalb des aktiven Verfahrbereichs positioniert die TNC das Werkzeug auf die Position, an der es den definierten Verfahrbereich verlassen würde.

Befindet sich das Werkzeug bei einem Zyklus-Aufruf auf einer Position außerhalb des Verfahrbereichs, dann führt die TNC den kompletten Zyklus nicht aus!

Die TNC führt alle Zusatzfunktion M aus, die außerhalb des Verfahrbereichs im NC-Programm definiert sind. Dies gilt auch für PLC-Positionierungen oder Verfahrbefehlen aus NC-Makros.

Die Funktion Limit-Ebene ist auch in der Betriebsart MDI aktiv.

Die Funktionen zur Definition der Limit-Ebene finden Sie im Formular globale Programmeinstellungen auf dem Reiter Limit-Ebene. Sobald Sie die Funktion Limit-Ebene eingeschaltet (Checkbox Ein/Aus) und in einer Achse einen Bereich per Checkbox aktiviert haben, stellt die TNC auf der rechten Seite diese Ebene grafisch dar. Der grüne Quader entspricht dem Verfahrbereich Ihrer Maschine.

Die TNC stellt die nachfolgend beschriebenen Funktionen zur Verfügung:

  • Bereich Koordinatensystem:
    Hier legen Sie fest, auf welches Koordinatensystem sich die im Bereich Limitwerte eingegebenen Daten beziehen sollen.
    • Maschinensystem:
      Limitwerte beziehen sich auf das Maschinen-Koordinatensystem (M91-System).
    • Werkstücksystem:
      Limitwerte beziehen sich auf das Werkstück-Koordinatensystem. Das Werkstück-Koordinatensystem bezieht sich auf den am Werkstück gesetzten Bezugspunkt ohne Berücksichtigung einer definierten Grunddrehung und ohne Berücksichtigung von sonstigen aktiven Koordinatenumrechnungen.
    • Eingabesystem:
      Limitwerte beziehen sich auf das Eingabe-Koordinatensystem. Das Eingabe-Koordinatensystem stimmt mit dem Werkstück-Koordinatensystem überein, wenn keine Koordinatenumrechnungen aktiv sind. Bei aktiven Koordinatenumrechnungen (Grunddrehung Nullpunktverschiebung, Spiegeln, Drehung, Maßfaktor, Bearbeitungsebene Schwenken) weicht das Eingabe-Koordinatensystem vom Werkstück-Koordinatensystem entsprechend ab.
  • Bereich Limitwerte:
    Hier definieren Sie die eigentlichen Limitwerte. Sie können für jede Achse eine minimale und maximale Limitebene definieren. Zusätzlichc müssen Sie per Checkbox die Funktion für jede Achse aktivieren.
    • X Min:
      Minimalwert der Limitebene in X-Richtung, Einheit mm bzw. inch
    • X Max:
      Maximalwert der Limitebene in X-Richtung, Einheit mm bzw. inch
    • Y Min:
      Minimalwert der Limitebene in Y-Richtung, Einheit mm bzw. inch
    • Y Max:
      Maximalwert der Limitebene in Z-Richtung, Einheit mm bzw. inch
    • Z Min:
      Minimalwert der Limitebene in Z-Richtung, Einheit mm bzw. inch
    • Z Max:
      Maximalwert der Limitebene in Z-Richtung, Einheit mm bzw. inch
  • Bereich Modus WZ-Achslimit:
    Hier legen Sie fest, wie sich die TNC an einer Limitebene in Werkzeug-Achsrichtung verhalten soll.
    • Bearbeitung ausblenden:
      Die TNC stoppt das Werkzeug an der Stelle, an der es an das minimale Achslimit in Werkzeug-Achsrichtung stößt. Wenn ein Sicherheits-Abstand definiert ist, dann zieht die TNC das Werkzeug um diesen Wert zurück. Sobald sich eine Position wieder innerhalb des erlaubten Verfahrbereichs befindet, positioniert die TNC das Werkzeug mit Positionierlogik dorthin, ggf. unter Berücksichtigung eines definierten Anpositionier-Abstands.
    • Auf Limit bearbeiten:
      Die TNC stoppt Bewegungen in Richtung der negativen Werkzeug-Achse, führt aber alle Bewegungen außerhalb des Limits in der Bearbeitungsebene aus. Sobald sich die Position in der Werkzeug wieder innerhalb des Verfahrbereichs befindet, verfährt die TNC das Werkzeug wieder wie programmiert. Funktion nicht in positive Werkzeug-Achsrichtung verfügbar
  • Bereich Zusatzdaten:
    • Sicherheits-Abst.:
      Sicherheits-Abstand, um den die TNC das Werkzeug in Richtung der positiven Werkzeug-Achse verfährt, wenn eine Position eine Limitebene überschreitet. Wert wirkt inkremental. Wenn 0 eingegeben, dann bleibt das Werkzeug am Austrittspunkt stehen
    • Anpositionier-Abst.:
      Vorhalteabstand, auf den die TNC das Werkzeug positioniert, nachdem sich das Werkzeug wieder innerhalb des Verfahrbereichs befindet. Wert wirkt inkremental auf den Wiedereintrittspunkt


Positionierlogik

Die TNC fährt zwischen Austritts- und Wiedereintrittsposition mit folgender Positionierlogik:

  • Sofern definiert, fährt die TNC das Werkzeug in positive Werkzeug-Achsrichtung um den Sicherheits-Abst. frei

  • Anschließend positioniert die TNC das Werkzeug auf einer Geraden zur Wiedereintrittsposition. Die TNC verschiebt die Wiedereintrittsposition um den Anpositionier-Abst. in positive Werkzeug-Achsrichtung, wenn er definiert ist.

  • Abschließend fährt die TNC das Werkzeug auf die Wiedereintrittsposition und arbeitet das Programm weiter ab


Adaptive Vorschubregelung AFC (Software-Option)

Weitere Informationen:
> Anwendung
> AFC-Grundeinstellungen definieren
> Lernschnitt durchführen
> AFC aktivieren/deaktivieren
> Protokolldatei
> Werkzeugbruch/Werkzeugverschleiß überwachen
> Spindellast überwachen


Anwendung

Die Funktion AFC muss vom Maschinenhersteller freigegeben und angepasst werden. Beachten Sie Ihr Maschinenhandbuch.

Insbesondere kann Ihr Maschinenhersteller auch festgelegt haben, ob die TNC die Spindelleistung oder einen beliebigen anderen Wert als Eingangsgröße für die Vorschubregelung verwenden soll.

Für Werkzeuge unter 5 mm Durchmesser ist die adaptive Vorschubregelung nicht sinnvoll. Der Grenzdurchmesser kann auch größer sein, wenn die Nennleistung der Spindel sehr hoch ist.

Bei Bearbeitungen, bei denen Vorschub und Spindeldrehzahl zueinander passen müssen (z.B. beim Gewindebohren), dürfen Sie nicht mit adaptiver Vorschubregelung arbeiten.

Bei der adaptiven Vorschubregelung regelt die TNC abhängig von der aktuellen Spindelleistung den Bahnvorschub beim Abarbeiten eines Programmes automatisch. Die zu jedem Bearbeitungsabschnitt gehörende Spindelleistung ist in einem Lernschnitt zu ermitteln und wird von der TNC in einer zum Bearbeitungs-Programm gehörenden Datei gespeichert. Beim Start des jeweiligen Bearbeitungsabschnitts, der im Normalfall durch das Einschalten der Spindel erfolgt, regelt die TNC dann den Vorschub so, dass sich dieser innerhalb von Ihnen definierbarer Grenzen befindet.

Auf diese Weise lassen sich negative Auswirkungen auf Werkzeug, Werkstück und Maschine vermeiden, die durch sich ändernde Schnittbedingungen entstehen können. Schnittbedingungen ändern sich insbesondere durch:

  • Werkzeug-Verschleiß
  • Schwankende Schnitttiefen, die vermehrt bei Gussteilen auftreten
  • Härteschwankungen, die durch Materialeinschlüsse entstehen

Der Einsatz der adaptiven Vorschubregelung AFC bietet folgende Vorteile:

  • Optimierung der Bearbeitungszeit
    Durch Regelung des Vorschubs versucht die TNC, die vorher gelernte maximale Spindelleistung während der gesamten Bearbeitungszeit einzuhalten. Die Gesamtbearbeitungszeit wird durch Vorschuberhöhung in Bearbeitungszonen mit weniger Materialabtrag verkürzt
  • Werkzeug-Überwachung
    Überschreitet die Spindelleistung den eingelernten Maximalwert, reduziert die TNC den Vorschub so weit, bis die Referenz-Spindelleistung wieder erreicht ist. Wird beim Bearbeiten die maximale Spindelleistung überschritten und dabei gleichzeitig der von Ihnen definierte Mindestvorschub unterschritten, führt die TNC eine Abschaltreaktion durch. Dadurch lassen sich Folgeschäden nach Fräserbruch oder Fräserverschleiß verhindern.
  • Schonung der Maschinenmechanik
    Durch rechtzeitige Vorschubreduzierung bzw. durch entsprechende Abschaltreaktionen lassen sich Überlastschäden an der Maschine vermeiden


AFC-Grundeinstellungen definieren

In der Tabelle AFC.TAB, die im Root-Verzeichnis TNC:\ gespeichert sein muss, legen Sie die Regeleinstellungen fest, mit denen die TNC die Vorschubregelung durchführen soll.

Die Daten in dieser Tabelle stellen Defaultwerte dar, die beim Lernschnitt in eine zum jeweiligen Bearbeitungs-Programm gehörende abhängige Datei kopiert werden und als Grundlage für die Regelung dienen. Folgende Daten sind in dieser Tabelle zu definieren:

Spalte Funktion

NR

Laufende Zeilennummer in der Tabelle (hat sonst keine weitere Funktion)

AFC

Name der Regeleinstellung. Diesen Namen müssen Sie in die Spalte AFC der Werkzeug-Tabelle eintragen. Er legt die Zuordnung der Regelparameter zum Werkzeug fest

FMIN

Vorschub, bei dem die TNC eine Überlastreaktion ausführen soll. Wert prozentual bezogen auf den programmierten Vorschub eingeben. Eingabebereich: 50 bis 100%

FMAX

Maximaler Vorschub im Material, bis zu dem die TNC automatisch erhöhen darf. Wert prozentual bezogen auf den programmierten Vorschub eingeben

FIDL

Vorschub mit dem die TNC verfahren soll, wenn das Werkzeug nicht schneidet (Vorschub in der Luft). Wert prozentual bezogen auf den programmierten Vorschub eingeben

FENT

Vorschub mit dem die TNC verfahren soll, wenn das Werkzeug ins Material hinein- oder herausfährt. Wert prozentual bezogen auf den programmierten Vorschub eingeben. Maximaler Eingabewert: 100%

OVLD

    Reaktion, die die TNC bei Überlast ausführen soll:

  • M: Abarbeiten eines vom Maschinenhersteller definierten Makros
  • S: Sofort NC-Stopp ausführen
  • F: NC-Stopp ausführen, wenn das Werkzeug freigefahren ist
  • E: Nur eine Fehlermeldung am Bildschirm anzeigen
  • -: Keine Überlastreaktion ausführen

Die Überlastreaktion führt die TNC aus, wenn bei aktiver Regelung die maximale Spindelleistung für mehr als 1 Sekunde überschritten und dabei gleichzeitig der von Ihnen definierte Mindestvorschub unterschritten wird. Gewünschte Funktion über die ASCII-Tastatur eingeben

POUT

Spindelleistung bei der die TNC einen Werkstück-Austritt erkennen soll. Wert prozentual bezogen auf die gelernte Referenzlast eingeben. Empfohlener Wert: 8%

SENS

Empfindlichkeit (Aggressivität) der Regelung. Wert zwischen 50 und 200 eingebbar. 50 entspricht einer trägen, 200 einer sehr aggressiven Regelung. Eine aggressive Regelung reagiert schnell und mit hohen Werteänderungen, neigt jedoch zum Überschwingen. Empfohlener Wert: 100

PLC

Wert, den die TNC zu Beginn eines Bearbeitungsabschnittes an die PLC übertragen soll. Funktion legt der Maschinenhersteller fest, Maschinenhandbuch beachten

Sie können in der Tabelle AFC.TAB beliebig viele Regeleinstellungen (Zeilen) definieren.

Wenn im Verzeichnis TNC:\ keine Tabelle AFC.TAB vorhanden ist, dann verwendet die TNC einen intern fest definierte Regeleinstellungen für den Lernschnitt. Es empfiehlt sich jedoch grundsätzlich mit der Tabelle AFC.TAB zu arbeiten.

Gehen Sie wie folgt vor, um die Datei AFC.TAB anzulegen (nur erforderlich, wenn die Datei noch nicht vorhanden ist):

  • Betriebsart Programm-Einspeichern/Editieren wählen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Verzeichnis TNC:\ wählen

  • Neue Datei AFC.TAB eröffnen, mit Taste ENT bestätigen: Die TNC blendet eine Liste mit Tabellen-Formaten ein

  • Tabellenformat AFC.TAB wählen und mit Taste ENT bestätigen: Die TNC legt die Tabelle mit der Regeleinstellung Standard an


Lernschnitt durchführen

    Die TNC stellt mehrere Funktionen zur Verfügung, mit denen Sie einen Lernschnitt starten und beenden können:

  • FUNCTION AFC CUT BEGIN TIME1 DIST2 LOAD3: Die TNC startet eine Schnittsequenz mit aktivem AFC. Der Wechsel vom Lernschnitt in den Regelbetrieb erfolgt, sobald die Referenzleistung durch die Lernphase ermittelt werden konnte oder wenn eine der Vorgaben TIME, DIST oder LOAD erfüllt ist. Mit TIME definieren Sie die maximale Dauer der Lernphase in Sekunden. DIST definiert die maximale Strecke für den Lernschnitt. Mit LOAD können Sie eine Referenzlast direkt vorgegeben. Die Angaben in TIME, DIST und LOAD wirken modal, Sie können die jeweilige Funktion durch erneutes Programmieren mit dem Wert 0 zurücksetzen.
  • FUNCTION AFC CUT END: Die Funktion AFC CUT END beendet die AFC-Regelung
  • FUNCTION AFC CTRL: Die Funktion AFC CTRL startet den Regelbetrieb ab der Stelle, an der dieser Satz abgearbeitet wird (auch wenn die Lernphase noch nicht beendet wurde)

Um die AFC-Funktionen zum Starten und Beenden des Lernschnitts zu programmieren, gehen Sie wie folgt vor:

  • In der Betriebsart Programmieren Taste SPEC FCT wählen

  • Softkey PROGRAMM FUNKTIONEN wählen

  • Softkey FUNCTION AFC wählen

  • Funktion wählen

Bei einem Lernschnitt kopiert die TNC zunächst für jeden Bearbeitungsabschnitt die in der Tabelle AFC.TAB definierten Grundeinstellungen in die Datei <name>.H.AFC.DEP. <name> entspricht dabei dem Namen des NC-Programms, für das Sie den Lernschnitt durchgeführt haben. Zusätzlich erfasst die TNC die während des Lernschnitts aufgetretene maximale Spindelleistung und speichert diesen Wert ebenfalls in die Tabelle ab.

Jede Zeile der Datei <name>.H.AFC.DEP entspricht einem Bearbeitungsabschnitt, den Sie mit FUNCTION AFC CUT BEGIN starten und mit FUNCTION AFC CUT END beenden. Alle Daten der Datei <name>.H.AFC.DEP können Sie editieren, sofern Sie noch Optimierungen vornehmen wollen. Wenn Sie Optimierungen im Vergleich zu den in der Tabelle AFC.TAB eingetragenen Werten durchgeführt haben, schreibt die TNC einen * vor die Regeleinstellung in der Spalte AFC. Neben den Daten aus der Tabelle AFC.TAB (siehe AFC-Grundeinstellungen definieren), speichert die TNC noch folgende zusätzliche Informationen in die Datei <name>.H.AFC.DEP:

Spalte Funktion

NR

Nummer des Bearbeitungsabschnitts

TOOL

Nummer oder Name des Werkzeugs, mit dem der Bearbeitungsabschnitt durchgeführt wurde (nicht editierbar)

IDX

Index des Werkzeugs, mit dem der Bearbeitungsabschnitt durchgeführt wurde (nicht editierbar)

N

    Unterscheidung für Werkzeug-Aufruf:

  • 0: Werkzeug wurde mit seiner Werkzeug-Nummer aufgerufen
  • 1: Werkzeug wurde mit seinem Werkzeug-Namen aufgerufen

PREF

Referenzlast der Spindel. Die TNC ermittelt den Wert prozentual, bezogen auf die Nennleistung der Spindel

ST

    Status des Bearbeitungsabschnitts:

  • l: Beim nächsten Abarbeiten erfolgt für diesen Bearbeitungsabschnitt ein Lernschnitt, bereits eingetragene Werte in dieser Zeile werden von der TNC überschrieben
  • c: Lernschnitt wurde erfolgreich durchgeführt. Beim nächsten Abarbeiten kann automatische Vorschubregelung erfolgen

AFC

Name der Regeleinstellung

    Bevor Sie einen Lernschnitt durchführen, auf folgende Voraussetzungen achten:

  • Bei Bedarf die Regeleinstellungen in der Tabelle AFC.TAB anpassen
  • Gewünschte Regeleinstellung für alle Werkzeuge in der Spalte AFC der Werkzeug-Tabelle TOOL.T eintragen
  • Programm anwählen das Sie einlernen wollen
  • Funktion adaptive Vorschubregelung per Softkey aktivieren (siehe AFC aktivieren/deaktivieren)

Wenn Sie einen Lernschnitt durchführen, zeigt die TNC in einem Überblendfenster die bis dato ermittelte Spindel-Referenzleistung an.

Sie können die Referenzleistung jederzeit zurücksetzen, indem Sie den Softkey pref reset drücken. Die TNC startet dann die Lernphase neu.

Wenn Sie einen Lernschnitt durchführen, setzt die TNC intern den Spindel-Override auf 100%. Sie können die Spindeldrehzahl dann nicht mehr verändern.

Sie können während des Lernschnittes über den Vorschub-Override den Bearbeitungsvorschub beliebig verändern und somit Einfluss auf die ermittelte Referenzlast nehmen.

Sie müssen nicht den vollständigen Bearbeitungsschritt im Lernmodus fahren. Wenn sich die Schnittbedingungen nicht mehr wesentlich verändern, dann können Sie sofort in den Modus Regeln wechseln. Drücken Sie dazu den Softkey LERNEN BEENDEN, der Status ändert sich dann von L auf C.

Sie können einen Lernschnitt bei Bedarf beliebig oft wiederholen. Setzen Sie dazu den Status ST manuell wieder auf L. Eine Wiederholung des Lernschnitts kann erforderlich sein, wenn der programmierte Vorschub viel zu hoch programmiert war und Sie während des Bearbeitungsschrittes den Vorschub-Override stark zurückdrehen müssen.

Die TNC wechselt den Status von Lernen (L) auf Regeln (C) nur dann, wenn die ermittelte Referenzlast größer als 2% beträgt. Bei kleineren Werten ist eine adaptive Vorschubregelung nicht möglich.

Gehen Sie wie folgt vor, um die Datei <name>.H.AFC.DEP anzuwählen und ggf. zu editieren:

Betriebsart Programmlauf Satzfolge wählen

Softkeyleiste umschalten

Tabelle der AFC-Einstellungen wählen

Wenn erforderlich Optimierungen durchführen

Beachten Sie, das die Datei <name>.H.AFC.DEP zum Editieren gesperrt ist, solange Sie das NC-Programm <name>.H abarbeiten. Die TNC zeigt die Daten in der Tabelle dann rot an.

    Die TNC setzt die Editiersperre erst zurück, wenn eine der folgenden Funktionen abgearbeitet wurde:

  • M02
  • M30
  • END PGM

Sie können die Datei <name>.H.AFC.DEP auch in der Betriebsart Programm-Einspeichern/Editieren verändern. Falls erforderlich, können Sie dort auch einen Bearbeitungsabschitt (komplette Zeile) löschen.

Um die Datei <name>.H.AFC.DEP editieren zu können, müssen Sie ggf. die Datei-Verwaltung so einstellen, das die TNC abhängige Dateien anzeigen soll (siehe PGM MGT konfigurieren).


AFC aktivieren/deaktivieren

Betriebsart Programmlauf Satzfolge wählen

Softkeyleiste umschalten

Adaptive Vorschubregelung aktivieren: Softkey auf EIN stellen, die TNC zeigt in der Positions-Anzeige das AFC-Symbol an (siehe Status-Anzeigen)

Adaptive Vorschubregelung deaktivieren: Softkey auf AUS stellen

Die adaptive Vorschubregelung bleibt so lange aktiv, bis Sie diese wieder per Softkey deaktivieren. Die TNC speichert die Stellung des Softkeys auch über eine Stromunterbrechung hinaus.

Wenn die adaptive Vorschubregelung im Modus Regeln aktiv ist, setzt die TNC intern den Spindel-Override auf 100%. Sie können die Spindeldrehzahl dann nicht mehr verändern.

    Wenn die adaptive Vorschubregelung im Modus Regeln aktiv ist, übernimmt die TNC die Funktion des Vorschub-Overrides:

  • Wenn Sie den Vorschub-Override erhöhen, hat dies keinen Einfluss auf die Regelung.
  • Wenn Sie den Vorschub-Override um mehr als 10% bezogen auf die maximale Stellung reduzieren, dann schaltet die TNC die adaptive Vorschubregelung ab. In diesem Fall blendet die TNC ein Fenster mit entsprechendem Hinweistext ein

In NC-Sätzen, in denen FMAX programmiert ist, ist die adaptive Vorschubregelung nicht aktiv.

Satzvorlauf bei aktiver Vorschubregelung ist erlaubt, die TNC berücksichtigt die Schnittnummer der Einstiegsstelle.

Die TNC zeigt in der zusätzlichen Status-Anzeige verschiedene Informationen an, wenn die adaptive Vorschubregelung aktiv ist (siehe Adaptive Vorschubregelung AFC (Reiter AFC, Software-Option)). Zusätzlich zeigt die TNC in der Positions-Anzeige das Symbol [image] an.


Protokolldatei

Während eines Lernschnitts speichert die TNC für jeden Bearbeitungsabschnitt verschiedene Informationen in der Datei <name>.H.AFC2.DEP ab. <name> entspricht dabei dem Namen des NC-Programms, für das Sie den Lernschnitt durchgeführt haben. Beim Regeln aktualisiert die TNC die Daten und führt verschiedene Auswertungen durch. Folgende Daten sind in dieser Tabelle gespeichert:

Spalte Funktion

NR

Nummer des Bearbeitungsabschnitts

TOOL

Nummer oder Name des Werkzeugs, mit dem der Bearbeitungsabschnitt durchgeführt wurde

IDX

Index des Werkzeugs, mit dem der Bearbeitungsabschnitt durchgeführt wurde

SNOM

Solldrehzahl der Spindel [U/min]

SDIF

Maximale Differenz der Spindeldrehzahl in % von der Solldrehzahl

LTIME

Bearbeitungszeit für den Lernschnitt

CTIME

Bearbeitungszeit für den Regelschnitt

TDIFF

Zeitunterschied zwischen der Bearbeitungszeit beim Lernen und Regeln in %

PMAX

Maximal aufgetretene Spindelleistung während der Bearbeitung. Die TNC zeigt den Wert prozentual, bezogen auf die Nennleistung der Spindel an

PREF

Referenzlast der Spindel. Die TNC zeigt den Wert prozentual, bezogen auf die Nennleistung der Spindel an

FMIN

Kleinster aufgetretener Vorschubfaktor. Die TNC zeigt den Wert prozentual, bezogen auf den programmierten Vorschub an

OVLD

    Reaktion, die die TNC bei Überlast ausgeführt hat:

  • M: Ein vom Maschinenhersteller definiertes Makro wurde abgearbeitet
  • S: Direkter NC-Stopp wurde ausgeführt
  • F: NC-Stopp wurde ausgeführt, nachdem das Werkzeug freigefahren wurde
  • E: Es wurde eine Fehlermeldung am Bildschirm angezeigt
  • -: Es wurde keine Überlastreaktion ausführt

BLOCK

Satznummer, an der der Bearbeitungsabschnitt beginnt

Die TNC ermittelt die gesamte Bearbeitungszeit für alle Lernschnitte (LTIME), alle Regelschnitte (CTIME) und den gesamten Zeitunterschied (TDIFF) und trägt diese Daten hinter dem Schlüsselwort TOTAL in die letzte Zeile der Protokolldatei ein.

Die TNC kann den Zeitunterschied (TDIFF) nur dann ermitteln, wenn Sie den Lernschnitt komplett durchführen. Ansonsten bleibt die Spalte leer.

Gehen Sie wie folgt vor, um die Datei <name>.H.AFC2.DEP anzuwählen:

Betriebsart Programmlauf Satzfolge wählen

Softkeyleiste umschalten

Tabelle der AFC-Einstellungen wählen

Protokoll-Datei anzeigen


Werkzeugbruch/Werkzeugverschleiß überwachen

Diese Funktion muss vom Maschinenhersteller freigegeben und angepasst werden. Beachten Sie Ihr Maschinenhandbuch.

Mit der Funktion Bruch-/Verschleißüberwachung lässt sich eine schnittbezogene Werkzeugbrucherkennung bei aktivem AFC realisieren.

Über vom Maschinenhersteller definierbare Funktionen können Sie die prozentualen Werte für Verschleiß- oder Brucherkennung in Bezug auf die Nennleistung definieren.

Beim Über- oder Unterschreiten der definierten Grenzspindelleistung führt die TNC einen NC-Stopp aus.


Spindellast überwachen

Diese Funktion muss vom Maschinenhersteller freigegeben und angepasst werden. Beachten Sie Ihr Maschinenhandbuch.

Mit der Funktion Spindellastüberwachung lässt sich auf einfache Weise die Spindellast überwachen, um beispielsweise Überlasten in Bezug auf die Spindelleistung zu erkennen.

Die Funktion ist unabhängig von AFC, also nicht schnittbezogen und nicht abhängig von Lernschitten. Über eine vom Maschinenhersteller definierbare Funktion ist lediglich der prozentuale Wert der Grenzspindelleistung in Bezug auf die Nennleistung zu definieren.

Beim Über- oder Unterschreiten der definierten Grenzspindelleistung führt die TNC einen NC-Stopp aus.


Aktive Ratterunterdrückung ACC (Software-Option)

Weitere Informationen:
> Anwendung
> ACC aktivieren/deaktivieren


Anwendung

Die Funktion ACC muss vom Maschinenhersteller freigegeben und angepasst werden. Beachten Sie Ihr Maschinenhandbuch.

Bei der Schrupp-Bearbeitung (Leistungsfräsen) treten große Fräskräfte auf. Abhängig von der Drehzahl des Werkzeugs, sowie von den in der Werkzeugmaschine vorhandenen Resonanzen und dem Spanvolumen (Schnittleistung beim Fräsen) kann es dabei zu sogenanntem „Rattern“ kommen. Dieses Rattern stellt für die Maschine eine hohe Beanspruchung dar. Auf der Werkstück-Oberfläche führt dieses Rattern zu unschönen Marken. Auch das Werkzeug nutzt sich durch das Rattern stark und ungleichmäßig ab, im Extremfall kann es sogar zum Werkzeugbruch kommen.

Zur Reduzierung der Ratter-Neigung einer Maschine bietet HEIDENHAIN nun mit ACC (Active Chatter Control) eine wirkungsvolle Reglerfunktion. Im Bereich der Schwerzerspanung wirkt sich der Einsatz dieser Reglerfunktion besonders positiv aus. Mit ACC sind wesentlich bessere Schnittleistungen möglich. Abhänig vom Maschinentyp kann in der gleichen Zeit das Zerspanvolumen um bis zu 25 % und mehr erhöht werden. Gleichzeitig reduzieren Sie die Belastung für die Maschine und erhöhen die Standzeit des Werkzeugs

Beachten Sie, dass ACC insbesondere für die Schwerzerspanung entwickelt wurde und in diesem Bereich besonders effektiv einsetzbar ist. Ob ACC auch bei normaler Schruppbearbeitung Vorteile bietet müssen Sie durch entsprechende Versuche ermitteln.


ACC aktivieren/deaktivieren

Um ACC zu aktivieren müssen Sie für das entsprechende Werkzeug in der Werkzeug-Tabelle TOOL.T die Spalte ACC auf 1 setzen. Weitere Einstellungen sind nicht erforderlich. Wenn ACC aktiv ist, dann zeigt die TNC bei der Positions-Anzeige ein entsprechendes Symbol an.

Um ACC zu deaktivieren, müssen Sie die Spalte ACC auf 0 setzen.


Text-Dateien erstellen

Weitere Informationen:
> Anwendung
> Text-Datei öffnen und verlassen
> Texte editieren
> Zeichen, Wörter und Zeilen löschen und wieder einfügen
> Textblöcke bearbeiten
> Textteile finden


Anwendung

An der TNC können Sie Texte mit einem Text-Editor erstellen und überarbeiten. Typische Anwendungen:

  • Erfahrungswerte festhalten
  • Arbeitsabläufe dokumentieren
  • Formelsammlungen erstellen

Text-Dateien sind Dateien vom Typ .A (ASCII). Wenn Sie andere Dateien bearbeiten möchten, dann konvertieren Sie diese zuerst in den Typ .A.

Text-Dateien sind Dateien vom Typ .A (ASCII). Wenn Sie andere Dateien bearbeiten möchten, dann benutzen Sie das Zusatz-Tool Mousepad (siehe Text-Dateien anzeigen oder bearbeiten).


Text-Datei öffnen und verlassen

  • Betriebsart Programm-Einspeichern/Editieren wählen

  • Datei-Verwaltung aufrufen: Taste PGM MGT drücken

  • Dateien vom Typ .A anzeigen: Nacheinander Softkey TYP WÄHLEN und Softkey ANZEIGEN .A drücken

  • Datei wählen und mit Softkey WÄHLEN oder Taste ENT öffnen oder eine neue Datei öffnen: Neuen Namen eingeben, mit Taste ENT bestätigen

Wenn Sie den Text-Editor verlassen wollen, dann rufen Sie die Datei-Verwaltung auf und wählen eine Datei eines anderen Typs, wie z.B. ein Bearbeitungs-Programm.

Cursor-Bewegungen | Softkey
Cursor ein Wort nach rechts |
Cursor ein Wort nach links |
Cursor auf die nächste Bildschirmseite |
Cursor auf die vorherige Bildschirmseite |
Cursor zum Datei-Anfang |
Cursor zum Datei-Ende |
Editier-Funktionen | Taste
Neue Zeile beginnen |
Zeichen links vom Cursor löschen |
Leerzeichen einfügen |
Groß-/Kleinschreibung umschalten |


Texte editieren

In der ersten Zeile des Text-Editors befindet sich ein Informations-Balken, der den Datei-Namen, den Aufenthaltsort und den Schreibmodus des Cursors (Engl. Einfügemarke) anzeigt:

Datei: | Name der Text-Datei
Zeile: | Aktuelle Zeilenposition des Cursors
Spalte: | Aktuelle Spaltenposition des Cursors
INSERT: | Neu eingegebene Zeichen werden eingefügt
OVERWRITE: | Neu eingegebene Zeichen überschreiben vorhandenen Text an der Cursor-Position

Der Text wird an der Stelle eingefügt, an der sich der Cursor gerade befindet. Mit den Pfeil-Tasten bewegen Sie den Cursor an jede beliebige Stelle der Text-Datei.

Die Zeile, in der sich der Cursor befindet, wird farblich hervorgehoben. Eine Zeile kann maximal 77 Zeichen enthalten und wird mit der Taste RET (Return) oder ENT umbrochen.


Zeichen, Wörter und Zeilen löschen und wieder einfügen

Mit dem Text-Editor können Sie ganze Worte oder Zeilen löschen und an anderer Stelle wieder einfügen.

  • Cursor auf Wort oder Zeile bewegen, die gelöscht und an anderer Stelle eingefügt werden soll

  • Softkey WORT LÖSCHEN bzw. ZEILE LÖSCHEN drücken: Der Text wird entfernt und zwischengespeichert

  • Cursor auf Position bewegen, an der der Text eingefügt werden soll und Softkey ZEILE/WORT EINFÜGEN drücken

Funktion | Softkey
Zeile löschen und zwischenspeichern |
Wort löschen und zwischenspeichern |
Zeichen löschen und zwischenspeichern |
Zeile oder Wort nach Löschen wieder einfügen |


Textblöcke bearbeiten

Sie können Textblöcke beliebiger Größe kopieren, löschen und an anderer Stelle wieder einfügen. In jedem Fall markieren Sie zuerst den gewünschten Textblock:

  • Textblock markieren: Cursor auf das Zeichen bewegen, an dem die Textmarkierung beginnen soll

Softkey BLOCK MARKIEREN drücken

Cursor auf das Zeichen bewegen, an dem die Textmarkierung enden soll. Wenn Sie den Cursor mit den Pfeil-Tasten direkt nach oben und unten bewegen, werden die dazwischenliegenden Textzeilen vollständig markiert – der markierte Text wird farblich hervorgehoben

Nachdem Sie den gewünschten Textblock markiert haben, bearbeiten Sie den Text mit folgenden Softkeys weiter:

Funktion | Softkey
Markierten Block löschen und zwischenspeichern |
Markierten Block zwischenspeichern, ohne zu löschen (kopieren) |

Wenn Sie den zwischengespeicherten Block an anderer Stelle einfügen wollen, führen Sie noch folgende Schritte aus:

  • Cursor auf die Position bewegen, an der Sie den zwischengespeicherten Textblock einfügen wollen

Softkey BLOCK EINFÜGEN drücken: Text wird eingefügt

Solange sich der Text im Zwischenspeicher befindet, können Sie ihn beliebig oft einfügen.

Weitere Informationen:
> Markierten Block in andere Datei übertragen
> Andere Datei an Cursor-Position einfügen


Markierten Block in andere Datei übertragen

  • Den Textblock wie bereits beschrieben markieren

Softkey ANHÄNGEN AN DATEI drücken. Die TNC zeigt den Dialog Ziel-Datei =

Pfad und Namen der Zieldatei eingeben. Die TNC hängt den markierten Textblock an die Zieldatei an. Wenn keine Zieldatei mit dem eingegebenen Namen existiert, dann schreibt die TNC markierten Text in eine neue Datei


Andere Datei an Cursor-Position einfügen

  • Den Cursor an die Stelle im Text bewegen, an der Sie eine andere Textdatei einfügen möchten

Softkey EINFÜGEN VON DATEI drücken. Die TNC zeigt den Dialog Datei-Name =

Pfad und Namen der Datei eingeben, die Sie einfügen wollen


Textteile finden

Die Suchfunktion des Text-Editors findet Worte oder Zeichenketten im Text. Die TNC stellt zwei Möglichkeiten zur Verfügung.

Weitere Informationen:
> Aktuellen Text finden
> Beliebigen Text finden


Aktuellen Text finden

Die Suchfunktion soll ein Wort finden, das dem Wort entspricht, in dem sich der Cursor gerade befindet:

  • Cursor auf das gewünschte Wort bewegen

  • Suchfunktion wählen: Softkey SUCHEN drücken

  • Softkey AKTUELLES WORT SUCHEN drücken

  • Suchfunktion verlassen: Softkey ENDE drücken


Beliebigen Text finden

  • Suchfunktion wählen: Softkey SUCHEN drücken. Die TNC zeigt den Dialog Suche Text:

  • Gesuchten Text eingeben

  • Text suchen: Softkey AUSFÜHREN drücken

  • Suchfunktion verlassen Softkey ENDE drücken


Arbeiten mit Schnittdaten-Tabellen

Weitere Informationen:
> Hinweis
> Einsatzmöglichkeiten
> Tabelle für Werkstück-Materialien
> Tabelle für Werkzeug-Schneidstoffe
> Tabelle für Schnittdaten
> Erforderliche Angaben in der Werkzeug-Tabelle
> Vorgehensweise beim Arbeiten mit automatischer Drehzahl-/Vorschub-Berechnung
> Datenübertragung von Schnittdaten-Tabellen
> Konfigurations-Datei TNC.SYS


Hinweis

Die TNC muss vom Maschinenhersteller für das Arbeiten mit Schnittdaten-Tabellen vorbereitet sein.

Ggf. stehen an Ihrer Maschine nicht alle hier beschriebenen oder zusätzliche Funktionen zur Verfügung. Beachten Sie Ihr Maschinenhandbuch.


Einsatzmöglichkeiten

Über Schnittdaten-Tabellen, in denen beliebige Werkstoff/Schneidstoff-Kombinationen festgelegt sind, kann die TNC aus der Schnittgeschwindigkeit VC und dem Zahnvorschub fZ die Spindeldrehzahl S und den Bahnvorschub F berechnen. Grundlage für die Berechnung ist, dass Sie im Programm das Werkstück-Material und in einer Werkzeug-Tabelle verschiedene werkzeugspezifische Eigenschaften festgelegt haben.

Bevor Sie Schnittdaten automatisch von der TNC berechnen lassen, müssen Sie in der Betriebsart Programm-Test die Werkzeug-Tabelle aktiviert haben (Status S), aus der die TNC die werkzeugspezifischen Daten entnehmen soll.

Editierfunktionen für Schnittdaten-Tabellen | Softkey
Zeile einfügen |
Zeile löschen |
Anfang der nächsten Zeile wählen |
Tabelle sortieren |
Hell hinterlegtes Feld kopieren (2. Softkey-Leiste) |
Kopiertes Feld einfügen (2. Softkey-Leiste) |
Tabellenformat editieren (2. Softkey-Leiste) |


Tabelle für Werkstück-Materialien

Werkstück-Materialien definieren Sie in der Tabelle WMAT.TAB (siehe Bild). WMAT.TAB ist standardmäßig im Verzeichnis TNC:\ gespeichert und kann beliebig viele Materialnamen enthalten. Der Materialnamen darf maximal 32 Zeichen (auch Leerzeichen) lang sein. Die TNC zeigt den Inhalt der Spalte NAME an, wenn Sie im Programm das Werkstück-Material festlegen (siehe nachfolgenden Abschnitt).

Wenn Sie die Standard Werkstoff-Tabelle verändern, müssen Sie diese in ein anderes Verzeichnis kopieren. Ansonsten werden Ihre Änderungen bei einem Software-Update mit den HEIDENHAIN-Standarddaten überschrieben. Definieren Sie dann den Pfad in der Datei TNC.SYS mit dem Schlüsselwort WMAT= (siehe Konfigurations-Datei TNC.SYS).

Um Datenverlust zu vermeiden, sichern Sie die Datei WMAT.TAB in regelmäßigen Abständen.
Weitere Informationen:
> Werkstück-Material im NC-Programm festlegen


Werkstück-Material im NC-Programm festlegen

Im NC-Programm wählen Sie den Werkstoff über den Softkey WMAT aus der Tabelle WMAT.TAB aus:

Softkey-Leiste mit Sonderfunktionen einblenden

Gruppe PROGRAMM VORGABEN wählen.

Werkstück-Material programmieren: In der Betriebsart Programm-Einspeichern/Editieren Softkey WMAT drücken.

Tabelle WMAT.TAB einblenden: Softkey AUSWAHL FENSTER drücken, die TNC blendet in einem überlagerten Fenster die Werkstoffe ein, die in WMAT.TAB gespeichert sind

Werkstück-Material wählen: Bewegen Sie das Hellfeld mit den Pfeiltasten auf das gewünschte Material und bestätigen Sie mit der Taste ENT. Die TNC übernimmt den Werkstoff in den WMAT-Satz

Dialog beenden: Taste END drücken

Wenn Sie in einem Programm den WMAT-Satz ändern, gibt die TNC eine Warnmeldung aus. Überprüfen Sie, ob die im TOOL CALL-Satz gespeicherten Schnittdaten noch gültig sind.


Tabelle für Werkzeug-Schneidstoffe

Werkzeug-Schneidstoffe definieren Sie in der Tabelle TMAT.TAB. TMAT.TAB ist standardmäßig im Verzeichnis TNC:\ gespeichert und kann beliebig viele Schneidstoffnamen enthalten (siehe Bild). Der Schneidstoffname darf maximal 16 Zeichen (auch Leerzeichen) lang sein. Die TNC zeigt den Inhalt der Spalte NAME an, wenn Sie in der Werkzeug-Tabelle TOOL.T den Werkzeug-Schneidstoff festlegen.

Wenn Sie die Standard Schneidstoff-Tabelle verändern, müssen Sie diese in ein anderes Verzeichnis kopieren. Ansonsten werden Ihre Änderungen bei einem Software-Update mit den HEIDENHAIN-Standarddaten überschrieben. Definieren Sie dann den Pfad in der Datei TNC.SYS mit dem Schlüsselwort TMAT= (siehe Konfigurations-Datei TNC.SYS).

Um Datenverlust zu vermeiden, sichern Sie die Datei TMAT.TAB in regelmäßigen Abständen.


Tabelle für Schnittdaten

Die Werkstoff/Schneidstoff-Kombinationen mit den zugehörigen Schnittdaten definieren Sie in einer Tabelle mit dem Nachnamen .CDT (engl. cutting data file: Schnittdaten-Tabelle; siehe Bild). Die Einträge in der Schnittdaten-Tabelle können von Ihnen frei konfiguriert werden. Neben den zwingend erforderlichen Spalten NR, WMAT und TMAT kann die TNC bis zu vier Schnittgeschwindigkeit (VC)/Vorschub (F)-Kombinationen verwalten.

Im Verzeichnis TNC:\ ist die Standard Schnittdaten-Tabelle FRAES_2.CDT gespeichert. Sie können FRAES_2.CDT beliebig editieren und ergänzen oder beliebig viele neu Schnittdaten-Tabellen hinzufügen.

Wenn Sie die Standard Schnittdaten-Tabelle verändern, müssen Sie diese in ein anderes Verzeichnis kopieren. Ansonsten werden Ihre Änderungen bei einem Software-Update mit den HEIDENHAIN-Standarddaten überschrieben (siehe Konfigurations-Datei TNC.SYS).

Alle Schnittdaten-Tabellen müssen im selben Verzeichnis gespeichert sein. Ist das Verzeichnis nicht das Standardverzeichnis TNC:\, müssen Sie in der Datei TNC.SYS nach dem Schlüsselwort PCDT= den Pfad eingeben, in dem Ihre Schnittdaten-Tabellen gespeichert sind.

Um Datenverlust zu vermeiden, sichern Sie Ihre Schnittdaten-Tabellen in regelmäßigen Abständen.
Weitere Informationen:
> Neue Schnittdaten-Tabelle anlegen


Neue Schnittdaten-Tabelle anlegen

  • Betriebsart Programm-Einspeichern/Editieren wählen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Verzeichnis wählen, in dem die Schnittdaten-Tabellen gespeichert sein müssen (Standard: TNC:\)

  • Beliebigen Dateinamen und Datei-Typ .CDT eingeben, mit Taste ENT bestätigen

  • Die TNC öffnet eine Standard-Schnittdaten-Tabelle oder zeigt in der rechten Bildschirmhälfte verschiedene Tabellenformate an (maschinenabhängig), die sich in der Anzahl der Schnittgeschwindigkeit/Vorschub-Kombinationen unterscheiden. Schieben Sie in diesem Fall das Hellfeld mit den Pfeiltasten auf das gewünschte Tabellenformat und bestätigen mit der Taste ENT. Die TNC erzeugt eine neue leere Schnittdaten-Tabelle


Erforderliche Angaben in der Werkzeug-Tabelle

  • Werkzeug-Radius – Spalte R (DR)
  • Anzahl der Zähne (nur bei Fräswerkzeugen) – Spalte CUT
  • Werkzeugtyp – Spalte TYP
  • Der Werkzeugtyp beeinflusst die Berechnung des Bahnvorschubs:
    Fräswerkzeuge: F = S · fZ · z
    Alle anderen Werkzeuge: F = S · fU
    S: Spindeldrehzahl
    fZ: Vorschub pro Zahn
    fU: Vorschub pro Umdrehung
    z: Anzahl der Zähne
  • Werkzeug-Schneidstoff – Spalte TMAT
  • Name der Schnittdaten-Tabelle, die für dieses Werkzeug verwendet werden soll – Spalte CDT

  • Den Werkzeugtyp, den Werkzeug-Schneidstoff und den Namen der Schnittdaten-Tabelle wählen Sie in der Werkzeug-Tabelle über Softkey (siehe Werkzeug-Tabelle: Werkzeug-Daten für automatische Drehzahl- / Vorschub-Berechnung).


Vorgehensweise beim Arbeiten mit automatischer Drehzahl-/Vorschub-Berechnung

  1. Wenn noch nicht eingetragen: Werkstück-Material in Datei WMAT.TAB eintragen
  2. Wenn noch nicht eingetragen: Schneidstoff-Material in Datei TMAT.TAB eintragen
  3. Wenn noch nicht eingetragen: Alle für die Schnittdaten-Berechnung erforderlichen werkzeugspezifischen Daten in der Werkzeug-Tabelle eintragen:
    • Werkzeug-Radius
    • Anzahl der Zähne
    • Werkzeug-Typ
    • Werkzeug-Schneidstoff
    • Zum Werkzeug gehörende Schnittdaten-Tabelle
  4. Wenn noch nicht eingetragen: Schnittdaten in einer beliebigen Schnittdaten-Tabelle (CDT-Datei) eintragen
  5. Betriebsart Test: Werkzeug-Tabelle aktivieren, aus der die TNC die werkzeugspezifischen Daten entnehmen soll (Status S)
  6. Im NC-Programm: Über Softkey WMAT Werkstück-Material festlegen
  7. Im NC-Programm: Im T-Satz Spindeldrehzahl und Vorschub über Softkey automatisch berechnen lassen


Datenübertragung von Schnittdaten-Tabellen

Wenn Sie eine Datei vom Datei-Typ .TAB oder .CDT über eine externe Datenschnittstelle ausgeben, speichert die TNC die Strukturdefinition der Tabelle mit ab. Die Strukturdefinition beginnt mit der Zeile #STRUCTBEGIN und endet mit der Zeile #STRUCTEND. Entnehmen Sie die Bedeutung der einzelnen Schlüsselwörter aus der Tabelle „Strukturbefehl“. Hinter #STRUCTEND speichert die TNC den eigentlichen Inhalt der Tabelle ab.


Konfigurations-Datei TNC.SYS

Die Konfigurations-Datei TNC.SYS müssen Sie verwenden, wenn Ihre Schnittdaten-Tabellen nicht im Standard-Verzeichnis TNC:\ gespeichert sind. Dann legen Sie in der TNC.SYS die Pfade fest, in denen Ihre Schnittdaten-Tabellen gespeichert sind.

Die Datei TNC.SYS muss im Root-Verzeichnis TNC:\ gespeichert sein.

Einträge in TNC.SYS | Bedeutung
WMAT= | Pfad für Werkstoff-Tabelle
TMAT= | Pfad für Schneidstoff-Tabelle
PCDT= | Pfad für Schnittdaten-Tabellen
Beispiel für TNC.SYS
WMAT=TNC:\CUTTAB\WMAT_GB.TAB
TMAT=TNC:\CUTTAB\TMAT_GB.TAB
PCDT=TNC:\CUTTAB\


Programmieren: Mehrachsbearbeitung

Weitere Informationen:
> Funktionen für die Mehrachsbearbeitung
> Die PLANE-Funktion: Schwenken der Bearbeitungsebene (Software-Option 1)
> Sturzfräsen in der geschwenkten Ebene
> Zusatz-Funktionen für Drehachsen
> Peripheral Milling: 3D-Radiuskorrektur mit Werkzeug-Orientierung


Funktionen für die Mehrachsbearbeitung

In diesem Kapitel sind die TNC-Funktionen zusammengefasst, die mit der Mehrachsbearbeitung zusammenhängen:

TNC-Funktion | Beschreibung | Seite
PLANE | Beabeitungen in der geschwenkten Bearbeitungsebene definieren | Die PLANE-Funktion: Schwenken der Bearbeitungsebene (Software-Option 1)
PLANE/M128 | Sturzfräsen | Sturzfräsen in der geschwenkten Ebene
M116 | Vorschub von Drehachsen | Vorschub in mm/min bei Drehachsen A, B, C: M116 (Software-Option 1)
M126 | Drehachsen wegoptimiert verfahren | Drehachsen wegoptimiert fahren: M126
M94 | Anzeigewert von Drehachsen reduzieren | Anzeige der Drehachse auf Wert unter 360° reduzieren: M94
M114 | Verhalten der TNC beim Positionieren von Drehachsen festlegen | Automatische Korrektur der Maschinengeometrie beim Arbeiten mit Schwenkachsen: M114 (Software-Option 2)
M128 | Verhalten der TNC beim Positionieren von Drehachsen festlegen | Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM): M128 (Software-Option 2)
M134 | Genauhalt beim Positionieren mit Drehachsen | Genauhalt an Ecken mit nicht tangentialen Übergängen: M134
M138 | Auswahl von Schwenkachsen | Auswahl von Schwenkachsen: M138
M144 | Maschinenkinematik verrechnen | Berücksichtigung der Maschinen-Kinematik in IST/SOLL-Positionen am Satzende: M144 (Software-Option 2)


Die PLANE-Funktion: Schwenken der Bearbeitungsebene (Software-Option 1)

Weitere Informationen:
> Einführung
> PLANE-Funktion definieren
> Positions-Anzeige
> PLANE-Funktion rücksetzen
> Bearbeitungsebene über Raumwinkel definieren: PLANE SPATIAL
> Bearbeitungsebene über Projektionswinkel definieren: PLANE PROJECTED
> Bearbeitungsebene über Eulerwinkel definieren: PLANE EULER
> Bearbeitungsebene über zwei Vektoren definieren: PLANE VECTOR
> Bearbeitungsebene über drei Punkte definieren: PLANE POINTS
> Bearbeitungsebene über einen einzelnen, inkrementalen Raumwinkel definieren: PLANE RELATIVE
> Bearbeitungsebene über Achswinkel: PLANE AXIAL (FCL 3-Funktion)
> Positionierverhalten der PLANE-Funktion festlegen


Einführung

Die Funktionen zum Schwenken der Bearbeitungsebene müssen von Ihrem Maschinenhersteller freigegeben sein!

Alle PLANE-Funktionen, mit Ausnahme von PLANE AXIAL, können Sie nur mit Werkzeug-Achse Z anwenden.

Die PLANE-Funktion können Sie grundsätzlich nur an Maschinen einsetzen, die über mindestens zwei Drehachsen (Tisch oder/und Kopf) verfügen. Ausnahme: Die Funktion PLANE AXIAL können Sie auch dann verwenden, wenn an Ihrer Maschine nur eine einzelne Drehachse vorhanden bzw. aktiv ist.

Mit der PLANE-Funktion (engl. plane = Ebene) steht Ihnen eine leistungsfähige Funktion zur Verfügung, mit der Sie auf unterschiedliche Weisen geschwenkte Bearbeitungsebenen definieren können.

Alle in der TNC verfügbaren PLANE-Funktionen beschreiben die gewünschte Bearbeitungsebene unabhängig von den Drehachsen, die tatsächlich an Ihrer Maschine vorhanden sind. Folgende Möglichkeiten stehen zur Verfügung:

Funktion | Erforderliche Parameter | Softkey | Seite
spatial | Drei Raumwinkel SPA, SPB, SPC |  | Bearbeitungsebene über Raumwinkel definieren: PLANE SPATIAL
projected | Zwei Projektionswinkel PROPR und PROMIN sowie ein Rotationswinkel ROT |  | Bearbeitungsebene über Projektionswinkel definieren: PLANE PROJECTED
EULER | Drei Eulerwinkel Präzession (EULPR), Nutation (EULNU) und Rotation (EULROT), |  | Bearbeitungsebene über Eulerwinkel definieren: PLANE EULER
vector | Normalenvektor zur Definition der Ebene und Basisvektor zur Definition der Richtung der geschwenkten X-Achse |  | Bearbeitungsebene über zwei Vektoren definieren: PLANE VECTOR
points | Koordinaten von drei beliebigen Punkten der zu schwenkenden Ebene |  | Bearbeitungsebene über drei Punkte definieren: PLANE POINTS
relativ | Einzelner, inkremental wirkender Raumwinkel |  | Bearbeitungsebene über einen einzelnen, inkrementalen Raumwinkel definieren: PLANE RELATIVE
AXIAL | Bis zu drei absolute oder inkrementale Achswinkel A, B, C |  | Bearbeitungsebene über Achswinkel: PLANE AXIAL (FCL 3-Funktion)
reset | PLANE-Funktion rücksetzen |  | PLANE-Funktion rücksetzen

Um die Unterschiede zwischen den einzelnen Definitionsmöglichkeiten bereits vor der Funktionsauswahl zu verdeutlichen, können Sie per Softkey eine Animation starten.

    Die Parameter-Definition der PLANE-Funktion ist in zwei Teile gegliedert:

  • Die geometrische Definition der Ebene, die für jede der verfügbaren PLANE-Funktionen unterschiedlich ist
  • Das Positionierverhalten der PLANE-Funktion, das unabhängig von der Ebenendefinition zu sehen ist und für alle PLANE-Funktionen identisch ist (siehe Positionierverhalten der PLANE-Funktion festlegen)

Die Funktion Ist-Position übernehmen ist bei aktiver geschwenkter Bearbeitungsebene nicht möglich.

Wenn Sie die PLANE-Funktion bei aktivem M120 verwenden, dann hebt die TNC die Radius-Korrektur und damit auch die Funktion M120 automatisch auf.

PLANE-Funktionen grundsätzlich immer mit PLANE RESET zurücksetzen. Die Eingabe von 0 in allen PLANE-Parametern setzt die Funktion nicht vollständig zurück.


PLANE-Funktion definieren

Softkey-Leiste mit Sonderfunktionen einblenden

PLANE-Funktion wählen: Softkey bearb.-ebene schwenken drücken: Die TNC zeigt in der Softkey-Leiste die zur Verfügung stehenden Definitionsmöglichkeiten an

Funktion wählen bei aktiver Animation

  • Animation einschalten: Softkey animation wählen ein/aus auf EIN stellen

  • Animation für die verschiedenen Definitionsmöglichkeiten starten: Einen der zur Verfügung stehenden Softkeys drücken, die TNC hinterlegt den gedrückten Softkey andersfarbig und startet die zugehörige Animation

  • Um die momentan aktive Funktion zu übernehmen: Taste ENT drücken oder Softkey der aktiven Funktion erneut drücken: Die TNC führt den Dialog fort und fragt die erforderlichen Parameter ab

Funktion wählen bei inaktiver Animation

  • Gewünschte Funktion per Softkey direkt wählen: Die TNC führt den Dialog fort und fragt die erforderlichen Parameter ab


Positions-Anzeige

Sobald eine beliebige PLANE-Funktion aktiv ist, zeigt die TNC in der zusätzlichen Status-Anzeige den berechneten Raumwinkel an (siehe Bild). Grundsätzlich rechnet die TNC – unabhängig von der verwendeten PLANE-Funktion – intern immer zurück auf Raumwinkel.

Im Modus Restweg (RESTW) zeigt die TNC beim Einschwenken (Modus MOVE oder TURN) in der Drehachse den Weg bis zur definierten (bzw. berechneten) Endposition der Drehachse an.


PLANE-Funktion rücksetzen

Beispiel: NC-Satz
25 plane reset move abst50 f1000

Softkey-Leiste mit Sonderfunktionen einblenden

TNC Sonderfunktionen wählen: Softkey spezielle TNC funkt. drücken

PLANE-Funktion wählen: Softkey bearb.-ebene schwenken drücken: Die TNC zeigt in der Softkey-Leiste die zur Verfügung stehenden Definitionsmöglichkeiten an

Funktion zum Rücksetzen wählen: Damit ist die PLANE-Funktion intern zurückgesetzt, an den aktuellen Achspositionen ändert sich dadurch nichts

Festlegen, ob die TNC die Schwenkachsen automatisch in Grundstellung fahren soll (MOVE oder TURN) oder nicht (STAY), (siehe Automatisches Einschwenken: MOVE/TURN/STAY (Eingabe zwingend erforderlich))

Eingabe beenden: Taste END drücken

Die Funktion PLANE RESET setzt die aktive PLANE-Funktion – oder einen aktiven Zyklus G80 – vollständig zurück (Winkel = 0 und Funktion inaktiv). Eine Mehrfachdefinition ist nicht erforderlich.


Bearbeitungsebene über Raumwinkel definieren: PLANE SPATIAL

Weitere Informationen:
> Anwendung
> Eingabeparameter


Anwendung

Raumwinkel definieren eine Bearbeitungsebene durch bis zu drei Drehungen um ein Koordinatensystem, wobei hierfür zwei Sichtweisen existieren, die immer auf dasselbe Ergebnis führen.

  • Drehungen um das maschinenfeste Koordinatensystem: Die Reihenfolge der Drehungen erfolgt zunächst um die Maschinenachse C, dann um die Maschinenachse B, dann um die Maschinenachse A.
  • Drehungen um das jeweils geschwenkte Koordinatensystem: Die Reihenfolge der Drehungen erfolgt zunächst um die Maschinenachse C, dann um die gedrehte Achse B, dann um die gedrehte Achse A. Diese Sichtweise ist in der Regel einfacher verständlich, da sich die Drehungen des Koordinatensystems durch das Feststehen einer Drehachse einacher nachvollziehen lassen,

Beachten Sie vor dem Programmieren

Sie müssen immer alle drei Raumwinkel spa, spb und spc definieren, auch wenn einer der Winkel 0 ist.

Die Funktionsweise entspricht der des Zyklus 19, sofern die Eingaben im Zyklus 19 maschinenseitig auf Raumwinkeleingabe gestellt sind.

Parameterbeschreibung für das Positionierverhalten: Siehe Positionierverhalten der PLANE-Funktion festlegen.


Eingabeparameter
Beispiel: NC-Satz
5 plane spatial spa+27 spb+0 spc+45 .....

Raumwinkel A?: Drehwinkel SPA um die maschinenfeste Achse X (siehe Bild rechts oben). Eingabebereich von -359.9999° bis +359.9999°

Raumwinkel B?: Drehwinkel SPB um die maschinenfeste Achse Y (siehe Bild rechts oben). Eingabebereich von -359.9999° bis +359.9999°

Raumwinkel C?: Drehwinkel SPC um die maschinenfeste Achse Z (siehe Bild rechts Mitte). Eingabebereich von -359.9999° bis +359.9999°

Weiter mit den Positioniereigenschaften (siehe Positionierverhalten der PLANE-Funktion festlegen)

Verwendete Abkürzungen

Abkürzung | Bedeutung
SPATIAL | Engl. spatial = räumlich
SPA | spatial A: Drehung um X-Achse
SPB | spatial B: Drehung um Y-Achse
SPC | spatial C: Drehung um Z-Achse


Bearbeitungsebene über Projektionswinkel definieren: PLANE PROJECTED

Weitere Informationen:
> Anwendung
> Eingabeparameter


Anwendung

Projektionswinkel definieren eine Bearbeitungsebene durch die Angabe von zwei Winkeln, die Sie durch Projektion der 1. Koordinaten-ebene (Z/X bei Werkzeugachse Z) und der 2. Koordinatenebene (Y/Z bei Werkzeugachse Z) in die zu definierende Bearbeitungsebene ermitteln können.

Beachten Sie vor dem Programmieren

Projektionswinkel können Sie nur dann verwenden, wenn die Winkeldefinitionen sich auf einen rechtwinkligen Quader beziehen. Ansonsten entstehen Verzerrungen am Werkstück.

Parameterbeschreibung für das Positionierverhalten: Siehe Positionierverhalten der PLANE-Funktion festlegen.


Eingabeparameter

Proj.-Winkel 1. Koordinatenebene?: Projizierter Winkel der geschwenkten Bearbeitungsebene in die 1. Koordinatenebene des maschinenfesten Koordinatensystems (Z/X bei Werkzeugachse Z, siehe Bild rechts oben). Eingabebereich von ‑89.9999° bis +89.9999°. 0°-Achse ist die Hauptachse der aktiven Bearbeitungsebene (X bei Werkzeugachse Z, positive Richtung siehe Bild rechts oben)

Proj.-Winkel 2. Koordinatenebene?: Projizierter Winkel in die 2. Koordinatenebene des maschinenfesten Koordinatensystems (Y/Z bei Werkzeugachse Z, siehe Bild rechts oben). Eingabebereich von -89.9999° bis +89.9999°. 0°-Achse ist die Nebenachse der aktiven Bearbeitungsebene (Y bei Werkzeugachse Z)

ROT-Winkel der geschw. Ebene?: Drehung des geschwenkten Koordinatensystems um die geschwenkte Werkzeug-Achse (entspricht sinngemäß einer Rotation mit Zyklus 10 DREHUNG). Mit dem Rotations-Winkel können Sie auf einfache Weise die Richtung der Hauptachse der Bearbeitungsebene (X bei Werkzeug-Achse Z, Z bei Werkzeug-Achse Y, siehe Bild rechts Mitte) bestimmen. Eingabebereich von 0° bis +360°

Weiter mit den Positioniereigenschaften (siehe Positionierverhalten der PLANE-Funktion festlegen)

NC-Satz
5 plane projected propr+24 promin+24 rot+30 .....

Verwendete Abkürzungen

Abkürzung | Bedeutung
PROJECTED | Engl. projected = projiziert
PROPR | principle plane: Hauptebene
PROMIN | minor plane: Nebenebene
ROT | Engl. rotation: Rotation


Bearbeitungsebene über Eulerwinkel definieren: PLANE EULER

Weitere Informationen:
> Anwendung
> Eingabeparameter


Anwendung

Eulerwinkel definieren eine Bearbeitungsebene durch bis zu drei Drehungen um das jeweils geschwenkte Koordinatensystem. Die drei Eulerwinkel wurden vom Schweizer Mathematiker Euler definiert. Übertragen auf das Maschinen-Koordinatensystem ergeben sich folgende Bedeutungen:

Präzessionswinkel EULPR | Drehung des Koordinatensystems um die Z-Achse
Nutationswinkel EULNU | Drehung des Koordinatensystems um die durch den Präzessionswinkel verdrehte X-Achse
Rotationswinkel EULROT | Drehung der geschwenkten Bearbeitungsebene um die geschwenkte Z-Achse

Beachten Sie vor dem Programmieren

Parameterbeschreibung für das Positionierverhalten: Siehe Positionierverhalten der PLANE-Funktion festlegen.


Eingabeparameter

Drehw. Haupt-Koordinatenebene?: Drehwinkel EULPR um die Z-Achse (siehe Bild rechts oben). Beachten Sie:

  • Eingabebereich ist -180.0000° bis 180.0000°
  • 0°-Achse ist die X-Achse

Schwenkwinkel Werkzeug-Achse?: Schwenkwinkel EULNUT des Koordinatensystems um die durch den Präzessionswinkel verdrehte X-Achse (siehe Bild rechts Mitte). Beachten Sie:

  • Eingabebereich ist 0° bis 180.0000°
  • 0°-Achse ist die Z-Achse

ROT-Winkel der geschw. Ebene?: Drehung EULROT des geschwenkten Koordinatensystems um die geschwenkte Z-Achse (entspricht sinngemäß einer Rotation mit Zyklus 10 DREHUNG). Mit dem Rotations-Winkel können Sie auf einfache Weise die Richtung der X-Achse in der geschwenkten Bearbeitungsebene bestimmen (siehe Bild rechts unten). Beachten Sie:

  • Eingabebereich ist 0° bis 360.0000°
  • 0°-Achse ist die X-Achse

Weiter mit den Positioniereigenschaften (siehe Positionierverhalten der PLANE-Funktion festlegen)

NC-Satz
5 plane euler eulpr45 eulnu20 eulrot22 .....

Verwendete Abkürzungen

Abkürzung | Bedeutung
EULER | Schweizer Mathematiker, der die sogenannten Euler-Winkel definierte
EULPR | Präzessions-Winkel: Winkel, der die Drehung des Koordinatensystems um die Z-Achse beschreibt
EULNU | Nutationswinkel: Winkel, der die Drehung des Koordinatensystems um die durch den Präzessionswinkel verdrehte X-Achse beschreibt
EULROT | Rotations-Winkel: Winkel, der die Drehung der geschwenkten Bearbeitungsebene um die geschwenkte Z-Achse beschreibt


Bearbeitungsebene über zwei Vektoren definieren: PLANE VECTOR

Weitere Informationen:
> Anwendung
> Eingabeparameter


Anwendung

Die Definition einer Bearbeitungsebene über zwei Vektoren können Sie dann verwenden, wenn Ihr CAD-System den Basisvektor und den Normalenvektor der geschwenkten Bearbeitungsebene berechnen kann. Eine normierte Eingabe ist nicht erforderlich. Die TNC berechnet die Normierung intern, so dass Sie Werte zwischen -99.999999 und +99.999999 eingeben können.

Der für die Definition der Bearbeitungsebene erforderliche Basisvektor ist durch die Komponenten bx, by und bz definiert (siehe Bild rechts oben). Der Normalenvektor ist durch die Komponenten NX, NY und NZ definiert.

Beachten Sie vor dem Programmieren

Der Basisvektor definiert die Richtung der Hauptachse in der geschwenkten Bearbeitunsebene, der Normalenvektor muss senkrecht auf der geschwenkten Bearbeitungsebene stehen und bestimmt somit deren Ausrichtung.

Die TNC berechnet intern aus den von Ihnen eingegebenen Werten jeweils normierte Vektoren.

Parameterbeschreibung für das Positionierverhalten: Siehe Positionierverhalten der PLANE-Funktion festlegen.


Eingabeparameter

X-Komponente Basisvektor?: X-Komponente BX des Basisvektors B (siehe Bild rechts oben). Eingabebereich: -99.9999999 bis +99.9999999

Y-Komponente Basisvektor?: Y-Komponente BY des Basisvektors B (siehe Bild rechts oben). Eingabebereich: -99.9999999 bis +99.9999999

Z-Komponente Basisvektor?: Z-Komponente BZ des Basisvektors B (siehe Bild rechts oben). Eingabebereich: -99.9999999 bis +99.9999999

X-Komponente Normalenvektor?: X-Komponente nX des Normalenvektors N (siehe Bild rechts Mitte). Eingabebereich: -99.9999999 bis +99.9999999

Y-Komponente Normalenvektor?: Y-Komponente nY des Normalenvektors N (siehe Bild rechts Mitte). Eingabebereich: -99.9999999 bis +99.9999999

Z-Komponente Normalenvektor?: Z-Komponente nZ des Normalenvektors N (siehe Bild rechts unten). Eingabebereich: -99.9999999 bis +99.9999999

Weiter mit den Positioniereigenschaften (siehe Positionierverhalten der PLANE-Funktion festlegen)

NC-Satz
5 plane vector bx0.8 by-0.4 bz-0.42 nx0.2 ny0.2 NZ0.92 ..

Verwendete Abkürzungen

Abkürzung | Bedeutung
Vector | Englisch vector = Vektor
bx, by, bz | Basisvektor: X-, Y- und Z-Komponente
nx, ny, nz | Normalenvektor: X-, Y- und Z-Komponente


Bearbeitungsebene über drei Punkte definieren: PLANE POINTS

Weitere Informationen:
> Anwendung
> Eingabeparameter


Anwendung

Eine Bearbeitungsebene lässt sich eindeutig definieren durch die Angabe dreier beliebiger Punkte P1 bis P3 dieser Ebene. Diese Möglichkeit ist in der Funktion PLANE POINTS realisiert.

Beachten Sie vor dem Programmieren

Die Verbindung von Punkt 1 zu Punkt 2 legt die Richtung der geschwenkten Hauptachse fest (X bei Werkzeugachse Z).

Die Richtung der geschwenkten Werkzeugachse bestimmen Sie durch die Lage des 3. Punktes bezogen auf die Verbindungslinie zwischen Punkt 1und Punkt 2. Mit Hilfe der Rechte-Hand-Regel (Daumen = X-Achse, Zeigefinger = Y-Achse, Mittelfinger = Z-Achse, siehe Bild rechts oben), gilt: Daumen (X-Achse) zeigt von Punkt 1 nach Punkt 2, Zeigefinger (Y-Achse) zeigt parallel zur geschwenkten Y-Achse in Richtung Punkt 3. Dann zeigt der Mittelfinger in Richtung der geschwenkten Werkzeug-Achse.

Die drei Punkte definieren die Neigung der Ebene. Die Lage des aktiven Nullpunkts wird von der TNC nicht verändert.

Parameterbeschreibung für das Positionierverhalten: Siehe Positionierverhalten der PLANE-Funktion festlegen.


Eingabeparameter

X-Koordinate 1. Ebenenpunkt?: X-Koordinate p1X des 1. Ebenenpunktes (siehe Bild rechts oben)

Y-Koordinate 1. Ebenenpunkt?: Y-Koordinate p1y des 1. Ebenenpunktes (siehe Bild rechts oben)

Z-Koordinate 1. Ebenenpunkt?: Z-Koordinate p1z des 1. Ebenenpunktes (siehe Bild rechts oben)

X-Koordinate 2. Ebenenpunkt?: X-Koordinate p2X des 2. Ebenenpunktes (siehe Bild rechts Mitte)

Y-Koordinate 2. Ebenenpunkt?: Y-Koordinate p2y des 2. Ebenenpunktes (siehe Bild rechts Mitte)

Z-Koordinate 2. Ebenenpunkt?: Z-Koordinate p2z des 2. Ebenenpunktes (siehe Bild rechts Mitte)

X-Koordinate 3. Ebenenpunkt?: X-Koordinate p3X des 3. Ebenenpunktes (siehe Bild rechts unten)

Y-Koordinate 3. Ebenenpunkt?: Y-Koordinate p3y des 3. Ebenenpunktes (siehe Bild rechts unten)

Z-Koordinate 3. Ebenenpunkt?: Z-Koordinate p3z des 3. Ebenenpunktes (siehe Bild rechts unten)

Weiter mit den Positioniereigenschaften (siehe Positionierverhalten der PLANE-Funktion festlegen)

NC-Satz
5 plane points p1x+0 P1y+0 p1z+20 p2x+30 p2y+31 p2z+20 P3x+0 p3y+41 p3z+32.5 .....

Verwendete Abkürzungen

Abkürzung | Bedeutung
points | Englisch points = Punkte


Bearbeitungsebene über einen einzelnen, inkrementalen Raumwinkel definieren: PLANE RELATIVE

Weitere Informationen:
> Anwendung
> Eingabeparameter


Programmieren: Mehrachsbearbeitung / Die PLANE-Funktion: Schwenken der Bearbeitungsebene (Software-Option 1) / Bearbeitungsebene über einen einzelnen, inkrementalen Raumwinkel definieren: PLANE RELATIVE
Anwendung

Den inkrementalen Raumwinkel verwenden Sie dann, wenn eine bereits aktive geschwenkte Bearbeitungsebene durch eine weitere Drehung geschwenkt werden soll. Beispiel 45° Fase an einer geschwenkten Ebene anbringen.

Beachten Sie vor dem Programmieren

Der definierte Winkel wirkt immer bezogen auf die aktive Bearbeitungsebene, ganz gleich mit welcher Funktion Sie diese aktiviert haben.

Sie können beliebig viele PLANE relative-Funktionen nacheinander programmieren.

Wollen Sie wieder auf die Bearbeitungsebene zurück, die vor der PLANE relative Funktion aktive war, dann definieren Sie plane relative mit dem gleichen Winkel, jedoch mit dem entgegengesetzen Vorzeichen.

Wenn Sie PLANE RELATIVE auf eine ungeschwenkte Bearbeitungsebene anwenden, dann drehen Sie die ungeschwenkte Ebene einfach um den in der PLANE-Funktion definierten Raumwinkel.

Parameterbeschreibung für das Positionierverhalten: Siehe Positionierverhalten der PLANE-Funktion festlegen.


Programmieren: Mehrachsbearbeitung / Die PLANE-Funktion: Schwenken der Bearbeitungsebene (Software-Option 1) / Bearbeitungsebene über einen einzelnen, inkrementalen Raumwinkel definieren: PLANE RELATIVE
Eingabeparameter
Beispiel: NC-Satz
5 plane relativ spb-45 .....

Inkrementaler Winkel?: Raumwinkel, um den die aktive Bearbeitungsebene weitergeschwenkt werden soll (siehe Bild rechts oben). Achse um die geschwenkt werden soll per Softkey wählen. Eingabebereich: -359.9999° bis +359.9999°

Weiter mit den Positioniereigenschaften (siehe Positionierverhalten der PLANE-Funktion festlegen)

Verwendete Abkürzungen

Abkürzung | Bedeutung
relativ | Englisch relative = bezogen auf


Bearbeitungsebene über Achswinkel: PLANE AXIAL (FCL 3-Funktion)

Weitere Informationen:
> Anwendung
> Eingabeparameter


Anwendung

Die Funktion PLANE AXIAL definiert sowohl die Lage der Bearbeitungsebene als auch die Soll-Koordinaten der Drehachsen. Insbesondere bei Maschinen mit rechtwinkligen Kinematiken und mit Kinematiken in denen nur eine Drehachse aktiv ist, lässt sich diese Funktion einfach einsetzen.

Die Funktion PLANE AXIAL können Sie auch dann verwenden, wenn Sie nur eine Drehachse an Ihrer Maschine aktiv haben.

Die Funktion PLANE RELATIV können Sie nach PLANE AXIAL verwenden, wenn Ihre Maschine Raumwinkeldefinitionen erlaubt. Maschinenhandbuch beachten.

Beachten Sie vor dem Programmieren

Nur Achswinkel eingeben, die tatsächlich an Ihrer Maschine vorhanden sind, ansonsten gibt die TNC eine Fehlermeldung aus.

Mit PLANE AXIAL definierte Drehachs-Koordinaten sind modal wirksam. Mehrfachdefinitionen bauen also aufeinander auf, inkrementale Eingaben sind erlaubt.

Zum Rücksetzen der Funktion PLANE AXIal die Funktion PLANE RESET verwenden. Rücksetzen durch Eingabe von 0 deaktiviert PLANE AXIAL nicht.

Die Funktionen SEQ, TABLE ROT und COORD ROT haben in Verbindung mit PLANE AXIal keine Funktion.

Parameterbeschreibung für das Positionierverhalten: Siehe Positionierverhalten der PLANE-Funktion festlegen.


Eingabeparameter
Beispiel: NC-Satz
5 plane axial b-45 .....

Achswinkel A?: Achswinkel, auf den die A-Achse eingeschwenkt werden soll. Wenn inkremental eingegeben, dann Winkel, um den die A-Achse von der aktuellen Position aus weitergeschwenkt werden soll. Eingabebereich: -99999,9999° bis +99999,9999°

Achswinkel B?: Achswinkel, auf den die B-Achse eingeschwenkt werden soll. Wenn inkremental eingegeben, dann Winkel, um den die B-Achse von der aktuellen Position aus weitergeschwenkt werden soll. Eingabebereich: -99999,9999° bis +99999,9999°

Achswinkel C?: Achswinkel, auf den die C-Achse eingeschwenkt werden soll. Wenn inkremental eingegeben, dann Winkel, um den die C-Achse von der aktuellen Position aus weitergeschwenkt werden soll. Eingabebereich: -99999,9999° bis +99999,9999°

Weiter mit den Positioniereigenschaften (siehe Positionierverhalten der PLANE-Funktion festlegen)

Verwendete Abkürzungen

Abkürzung | Bedeutung
axial | Englisch axial = achsenförmig


Positionierverhalten der PLANE-Funktion festlegen

Weitere Informationen:
> Übersicht
> Automatisches Einschwenken: MOVE/TURN/STAY (Eingabe zwingend erforderlich)
> Drehachsen in einem separaten Satz einschwenken
> Auswahl von alternativen Schwenk-möglichkeiten: SEQ +/– (Eingabe optional)
> Auswahl der Transformationsart (Eingabe optional)


Übersicht

    Unabhängig davon, welche PLANE-Funktion Sie verwenden um die geschwenkte Bearbeitungsebene zu definieren, stehen folgende Funktionen zum Positionierverhalten immer zur Verfügung:

  • Automatisches Einschwenken
  • Auswahl von alternativen Schwenkmöglichkeiten
  • Auswahl der Transformationsart


Automatisches Einschwenken: MOVE/TURN/STAY (Eingabe zwingend erforderlich)

Nachdem Sie alle Parameter zur Ebenendefinition eingegeben haben, müssen Sie festlegen, wie die Drehachsen auf die berechneten Achswerte eingeschwenkt werden sollen:

Die PLANE-Funktion soll die Drehachsen automatisch auf die berechneten Achswerte einschwenken, wobei sich die Relativposition zwischen Werkstück und Werkzeug nicht verändert. Die TNC führt eine Ausgleichsbewegung in den Linearachsen aus

Die PLANE-Funktion soll die Drehachsen automatisch auf die berechneten Achswerte einschwenken, wobei die TNC nur die Drehachsen positioniert. Die TNC führt keine Ausgleichsbewegung in den -Linearachsen aus

Sie schwenken die Drehachsen in einem nachfolgenden, separaten Positioniersatz ein

Wenn Sie die Option MOVE (PLANE-Funktion soll automatisch mit Ausgleichsbewegung einschwenken) gewählt haben, sind noch die zwei nachfolgend erklärten Parameter Abstand Drehpunkt von WZ-Spitze und Vorschub? F= zu definieren.

Wenn Sie die Option TURN (PLANE-Funktion soll automatisch ohne Ausgleichsbewegung einschwenken) gewählt haben, sind noch die nachfolgend erklärten Parameter Rückzugslänge MB und Vorschub? F= zu definieren.

Alternativ zu einem direkt per Zahlenwert definierten Vorschub F, können Sie die Einschwenkbewegung auch mit FMAX (Eilgang) oder FAUTO (Vorschub aus T-Satz) ausführen lassen.

Wenn Sie die Funktion PLANE AXIAL in Verbindung mit STAY verwenden, dann müssen Sie die Drehachsen in einem separaten Positioniersatz nach der PLANE-Funktion einschwenken (siehe Drehachsen in einem separaten Satz einschwenken).

  • Abstand Drehpunkt von WZ-Spitze (inkremental): Die TNC schwenkt das Werkzeug (den Tisch) um die Werkzeugspitze ein. Über den Parameter ABST verlagern Sie den Drehpunkt der Einschwenkbewegung bezogen auf die aktuelle Position der Werkzeugspitze.

  • Wenn das Werkzeug vor dem Einschwenken auf dem angegebenen Abstand zum Werkstück steht, dann steht das Werkzeug auch nach dem Einschwenken relativ gesehen auf der gleichen Position (siehe Bild rechts Mitte, 1 = ABST)
  • Wenn das Werkzeug vor dem Einschwenken nicht auf dem angegebenen Abstand zum Werkstück steht, dann steht das Werkzeug nach dem Einschwenken relativ gesehen versetzt zur ursprünglichen Position (siehe Bild rechts unten, 1 = ABST)

  • Vorschub? F=: Bahngeschwindigkeit, mit der das Werkzeug einschwenken soll

  • Rückzugslänge in der WZ-Achse?: Rückzugsweg MB, wirkt inkremental von der aktuellen Werkzeug-Position in der aktiven Werkzeug-Achsrichtung, den die TNC vor dem Einschwenkvorgang anfährt. MB MAX fährt das Werkzeug bis kurz vor den Software-Endschalter


Drehachsen in einem separaten Satz einschwenken

Wenn Sie die Drehachsen in einem separaten Positioniersatz einschwenken wollen (Option STAY gewählt), gehen Sie wie folgt vor:

Achtung Kollisionsgefahr!

Werkzeug so vorpositionieren, dass beim Einschwenken keine Kollision zwischen Werkzeug und Werkstück (Spannmittel) erfolgen kann.

  • Beliebige PLANE-Funkion wählen, automatisches Einschwenken mit stay definieren. Beim Abarbeiten berechnet die TNC die Positionswerte der an Ihrer Maschine vorhandenen Drehachsen und legt diese in den Systemparametern Q120 (A-Achse), Q121 (B-Achse) und Q122 (C-Achse) ab

  • Positioniersatz definieren mit den von der TNC berechneten Winkelwerten
NC-Beispielsätze: Maschine mit C-Rundtisch und A-Schwenktisch auf einen Raumwinkel B+45° einschwenken.
... |
12 L Z+250 r0 fmax | Auf sichere Höhe positionieren
13 plane spatial spa+0 spb+45 spc+0 stay | PLANE-Funktion definieren und aktivieren
14 l a+q120 c+q122 f2000 | Drehachse positionieren mit den von der TNC berechneten Werten
... | Bearbeitung in der geschwenkten Ebene definieren


Auswahl von alternativen Schwenk-möglichkeiten: SEQ +/– (Eingabe optional)

Aus der von Ihnen definierten Lage der Bearbeitungsebene muss die TNC die dazu passende Stellung der an Ihrer Maschine vorhandenen Drehachsen berechnen. In der Regel ergeben sich immer zwei Lösungsmöglichkeiten.

    Über den Schalter SEQ stellen Sie ein, welche Lösungsmöglichkeit die TNC verwenden soll:

  • SEQ+ positioniert die Masterachse so, dass sie einen positiven Winkel einnimmt. Die Masterachse ist die 2. Drehachse ausgehend vom Tisch oder die 1. Drehachse ausgehend vom Werkzeug (abhängig von der Maschinenkonfiguration, siehe auch Bild rechts oben)
  • SEQ- positioniert die Masterachse so, dass sie einen negativen Winkel einnimmt

Liegt die von Ihnen über SEQ gewählte Lösung nicht im Verfahrbereich der Maschine, gibt die TNC die Fehlermeldung Winkel nicht erlaubt aus.

Bei Verwendung der Funktion PLANE AXIS hat der Schalter seq keine Funktion.

Den Schalter SEQ können Sie auch mit Q-Parametern programmieren. Positive Q-Parameter-Werte führen zur Lösung SEQ+, negative zur Lösung SEQ-.

Bei Verwendung der Funktion PLANE SPATIAL A+0 B+0 C+0 dürfen Sie kein SEQ- programmieren, ansonsten gibt die TNC einen Fehler aus.

Wenn Sie SEQ nicht definieren, ermittelt die TNC die Lösung wie folgt:

  1. Die TNC prüft zunächst, ob beide Lösungsmöglichkeiten im Verfahrbereich der Drehachsen liegen
  2. Trifft dies zu, wählt die TNC die Lösung, die auf dem kürzesten Weg zu erreichen ist
  3. Liegt nur eine Lösung im Verfahrbereich, dann verwendet die TNC diese Lösung
  4. Liegt keine Lösung im Verfahrbereich, dann gibt die TNC die Fehlermeldung Winkel nicht erlaubt aus

Beispiel für eine Maschine mit C-Rundtisch und A-Schwenktisch. Programmierte Funktion: PLane spatial SPA+0 SPB+45 SPC+0

Endschalter | Startposition | SEQ | Ergebnis Achsstellung
Keine | A+0, C+0 | nicht progr. | A+45, C+90
Keine | A+0, C+0 | + | A+45, C+90
Keine | A+0, C+0 | – | A–45, C–90
Keine | A+0, C–105 | nicht progr. | A–45, C–90
Keine | A+0, C–105 | + | A+45, C+90
Keine | A+0, C–105 | – | A–45, C–90
–90 < A < +10 | A+0, C+0 | nicht progr. | A–45, C–90
–90 < A < +10 | A+0, C+0 | + | Fehlermeldung
Keine | A+0, C–135 | + | A+45, C+90


Auswahl der Transformationsart (Eingabe optional)

Für Maschinen die einen C-Rundtisch haben, steht eine Funktion zur Verfügung, mit der Sie die Art der Transformation festlegen können:

COORD ROT legt fest, dass die PLANE-Funktion nur das Koordinatensystem auf den definierten Schwenkwinkel drehen soll. Der Rundtisch wird nicht bewegt, die Kompensation der Drehung erfolgt rechnerisch

table ROT legt fest, dass die PLANE-Funktion den Rundtisch auf den definierten Schwenkwinkel positionieren soll. Die Kompensation erfolgt durch eine Werkstück-Drehung

Bei Verwendung der Funktion PLANE AXIS haben die Funktionen coord rot und table rot keine Funktion.

Wenn Sie die Funktion TABLE ROT in Verbindung mit einer Grunddrehung und Schwenkwinkel 0 verwenden, dann schwenkt die TNC den Tisch auf den in der Grunddrehung definierten Winkel.


Sturzfräsen in der geschwenkten Ebene

Weitere Informationen:
> Funktion
> Sturzfräsen durch inkrementales Verfahren einer Drehachse


Funktion

    In Verbindung mit den neuen PLANE-Funktionen und M128 können Sie in einer geschwenkten Bearbeitungsebene sturzfräsen. Hierfür stehen zwei Definitionsmöglichkeiten zur Verfügung:

  • Sturzfräsen durch inkrementales Verfahren einer Drehachse
  • Sturzfräsen über Normalenvektoren

Sturzfräsen in der geschwenkten Ebene funktioniert nur mit Radiusfräsern.


Sturzfräsen durch inkrementales Verfahren einer Drehachse

  • Werkzeug freifahren

  • Beliebige PLANE-Funktion definieren, Positionierverhalten beachten

  • Über einen Geraden-Satz den gewünschten Sturzwinkel in der entsprechenden Achse inkremental verfahren

  • M128 aktivieren
NC-Beispielsätze:
... |
n12 g00 g40 Z+50 * | Auf sichere Höhe positionieren
n13 plane spatial spa+0 spB-45 spc+0 MOVE abst50 F900 * | PLANE-Funktion definieren und aktivieren
n14 g01 g91 f1000 B-17 M128 * | Sturzwinkel einstellen, M128 aktivieren
... | Bearbeitung in der geschwenkten Ebene definieren


Zusatz-Funktionen für Drehachsen

Weitere Informationen:
> Vorschub in mm/min bei Drehachsen A, B, C: M116 (Software-Option 1)
> Drehachsen wegoptimiert fahren: M126
> Anzeige der Drehachse auf Wert unter 360° reduzieren: M94
> Automatische Korrektur der Maschinengeometrie beim Arbeiten mit Schwenkachsen: M114 (Software-Option 2)
> Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM): M128 (Software-Option 2)
> Genauhalt an Ecken mit nicht tangentialen Übergängen: M134
> Auswahl von Schwenkachsen: M138
> Berücksichtigung der Maschinen-Kinematik in IST/SOLL-Positionen am Satzende: M144 (Software-Option 2)


Vorschub in mm/min bei Drehachsen A, B, C: M116 (Software-Option 1)

Standardverhalten

Die TNC interpretiert den programmierten Vorschub bei einer Drehachse in Grad/min (in mm-Programmen und auch in inch-Programmen). Der Bahnvorschub ist also abhängig von der Entfernung des Werkzeug-Mittelpunktes zum Drehachsen-Zentrum.

Je größer diese Entfernung wird, desto größer wird der Bahnvorschub.

Vorschub in mm/min bei Drehachsen mit M116

Die Maschinengeometrie muss vom Maschinenhersteller in der Kinematikbeschreibung definiert sein.

M116 wirkt nur bei Rund- und Drehtischen. Bei Schwenkköpfen können Sie M116 nicht verwenden. Sollte Ihre Maschine mit einer Tisch-/Kopf-Kombination ausgerüstet sein, ignoriert die TNC Schwenkkopf-Drehachsen.

M116 wirkt auch bei aktiver geschwenkter Bearbeitungsebene und in Kombination mit M128, wenn Sie über die Funktion M138 Drehachsen ausgewählt haben (siehe Auswahl von Schwenkachsen: M138). M116 wirkt dann nur auf die nicht mit M138 ausgewählten Drehachsen.

Die TNC interpretiert den programmierten Vorschub bei einer Drehachse in mm/min (bzw. 1/10 inch/min). Dabei berechnet die TNC jeweils am Satz-Anfang den Vorschub für diesen Satz. Der Vorschub bei einer Drehachse ändert sich nicht, während der Satz abgearbeitet wird, auch wenn sich das Werkzeug auf das Drehachsen-Zentrum zubewegt.

Wirkung

M116 wirkt in der Bearbeitungsebene. Mit M117 setzen Sie M116 zurück; am Programm-Ende wird M116 ebenfalls unwirksam.

M116 wird wirksam am Satz-Anfang.


Drehachsen wegoptimiert fahren: M126

Standardverhalten

Das Verhalten der TNC beim Positionieren von Drehachsen ist eine maschinenabhängige Funktion. Maschinenhandbuch beachten!

Das Verhalten der TNC beim Positionieren von Drehachsen, deren Anzeige auf Werte unter 360° reduziert ist, ist abhängig vom Bit 2 des Maschinen-Parameter 7682. Dort ist festgelegt, ob die TNC die Differenz zwischen Soll- und Ist-Position grundsätzlich immer (auch ohne M126) auf kürzestem Weg verfahren soll oder nur wenn M126 programmiert ist. Beispiele, wenn die TNC die Drehachse immer entlang des Zahlenstrahls verfahren soll:

Ist-Position | Soll-Position | Fahrweg
350° | 10° | –340°
10° | 340° | +330°
Verhalten mit M126

Mit M126 fährt die TNC eine Drehachse, deren Anzeige auf Werte unter 360° reduziert ist, auf kurzem Weg. Beispiele:

Ist-Position | Soll-Position | Fahrweg
350° | 10° | +20°
10° | 340° | –30°
Wirkung

M126 wird wirksam am Satzanfang.

M126 setzen Sie mit M127 zurück; am Programm-Ende wird M126 ebenfalls unwirksam.


Anzeige der Drehachse auf Wert unter 360° reduzieren: M94

Standardverhalten

Die TNC fährt das Werkzeug vom aktuellen Winkelwert auf den programmierten Winkelwert.

Beispiel:

Aktueller Winkelwert: | 538°
Programmierter Winkelwert: | 180°
Tatsächlicher Fahrweg: | -358°
Verhalten mit M94

Die TNC reduziert am Satzanfang den aktuellen Winkelwert auf einen Wert unter 360° und fährt anschließend auf den programmierten Wert. Sind mehrere Drehachsen aktiv, reduziert M94 die Anzeige aller Drehachsen. Alternativ können Sie hinter M94 eine Drehachse eingeben. Die TNC reduziert dann nur die Anzeige dieser Achse.

NC-Beispielsätze

Anzeigewerte aller aktiven Drehachsen reduzieren:

n50 m94 *

Nur Anzeigewert der C-Achse reduzieren:

n50 m94 c *

Anzeige aller aktiven Drehachsen reduzieren und anschließend mit der C-Achse auf den programmierten Wert fahren:

N50 G00 C+180 M94 *
Wirkung

M94 wirkt nur in dem Programmsatz, in dem M94 programmiert ist.

M94 wird wirksam am Satz-Anfang.


Automatische Korrektur der Maschinengeometrie beim Arbeiten mit Schwenkachsen: M114 (Software-Option 2)

Standardverhalten

Die TNC fährt das Werkzeug auf die im Bearbeitungs-Programm festgelegten Positionen. Ändert sich im Programm die Position einer Schwenkachse, so muss der Postprozessor den daraus entstehenden Versatz in den Linearachsen berechnen und in einem Positioniersatz verfahren. Da hier auch die Maschinen-Geometrie eine Rolle spielt, muss für jede Maschine das NC-Programm separat berechnet werden.

Verhalten mit M114

Die Maschinengeometrie muss vom Maschinenhersteller in der Kinematikbeschreibung definiert sein.

Ändert sich im Programm die Position einer gesteuerten Schwenkachse, so kompensiert die TNC den Versatz des Werkzeugs mit einer 3D-Längenkorrektur automatisch. Da die Geometrie der Maschine in Maschinen-Parametern abgelegt ist, kompensiert die TNC auch maschinenspezifische Versätze automatisch. Programme müssen vom Postprozessor nur einmal berechnet werden, auch wenn sie auf unterschiedlichen Maschinen mit TNC-Steuerung abgearbeitet werden.

Wenn Ihre Maschine keine gesteuerten Schwenkachsen besitzt (Kopf manuell zu schwenken, Kopf wird von der PLC positioniert), können Sie hinter M114 die jeweils gültige Schwenkkopf-Position eingeben (z.B. M114 B+45, Q-Parameter erlaubt).

Die Werkzeug-Radiuskorrektur muss vom CAD-System bzw. vom Postprozessor berücksichtigt werden. Eine programmierte Radiuskorrektur RL/RR führt zu einer Fehlermeldung.

Wenn die TNC die Werkzeug-Längenkorrektur vornimmt, dann bezieht sich der programmierte Vorschub auf die Werkzeugspitze, sonst auf den Werkzeug-Bezugspunkt.

Wenn Ihre Maschine einen gesteuerten Schwenkkopf hat, können Sie den Programmlauf unterbrechen und die Stellung der Schwenkachse verändern (z.B. mit dem Handrad).

Mit der Funktion VORLAUF ZU SATZ N können Sie das Bearbeitungs-Programm danach an der Unterbrechungsstelle fortführen. Die TNC berücksichtigt bei aktivem M114 automatisch die neue Stellung der Schwenkachse.

Um die Stellung der Schwenkachse mit dem Handrad während des Programmlaufs zu ändern, benutzen Sie M118 in Verbindung mit M128.

Wirkung

M114 wird wirksam am Satz-Anfang, M115 am Satz-Ende. M114 wirkt nicht bei aktiver Werkzeug-Radiuskorrektur.

M114 setzen Sie mit M115 zurück. Am Programm-Ende wird M114 ebenfalls unwirksam.


Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM): M128 (Software-Option 2)

Standardverhalten

Die TNC fährt das Werkzeug auf die im Bearbeitungs-Programm festgelegten Positionen. Ändert sich im Programm die Position einer Schwenkachse, so muss der daraus entstehende Versatz in den Linearachsen berechnet und in einem Positioniersatz verfahren werden.

Verhalten mit M128 (TCPM: Tool Center Point Management)

Die Maschinengeometrie muss vom Maschinenhersteller in der Kinematikbeschreibung definiert sein.

Ändert sich im Programm die Position einer gesteuerten Schwenkachse, dann bleibt während des Schwenkvorganges die Position der Werkzeugspitze gegenüber dem Werkstück unverändert.

Verwenden Sie M128 in Verbindung mit M118, wenn Sie während des Programmlaufs die Stellung der Schwenkachse mit dem Handrad verändern wollen. Die Überlagerung einer Handrad-Positionierung erfolgt bei aktivem M128 im maschinenfesten Koordinatensystem.

Achtung Gefahr für Werkstück!

Bei Schwenkachsen mit Hirth-Verzahnung: Stellung der Schwenkachse nur verändern, nachdem Sie das Werkzeug freigefahren haben. Ansonsten können durch das Herausfahren aus der Verzahnung Konturverletzungen entstehen.

Hinter M128 können Sie noch einen Vorschub eingeben, mit dem die TNC die Ausgleichsbewegungen in den Linearachsen ausführt. Wenn Sie keinen Vorschub eingeben, oder einen der größer ist als im Maschinen-Parameter 7471 festgelegt ist, wirkt der Vorschub aus Maschinen-Parameter 7471.

Vor Positionierungen mit M91 oder M92: M128 rücksetzen.

Um Kontur-Verletzungen zu vermeiden dürfen Sie mit M128 nur Radiusfräser verwenden.

Die Werkzeug-Länge muss sich auf das Kugelzentrum des Radiusfräsers beziehen.

Wenn M128 aktiv ist, zeigt die TNC in der Status-Anzeige das Symbol [image] an.

M128 bei Schwenktischen

Wenn Sie bei aktivem M128 eine Schwenktisch-Bewegung programmieren, dann dreht die TNC das Koordinaten-System entsprechend mit. Drehen Sie z.B. die C-Achse um 90° (durch positionieren oder durch Nullpunkt-Verschiebung) und programmieren anschließend eine Bewegung in der X-Achse, dann führt die TNC die Bewegung in der Maschinenachse Y aus.

Auch den gesetzten Bezugspunkt, der sich durch die Rundtisch-Bewegung verlagert, transformiert die TNC.

M128 bei dreidimensionaler Werkzeug-Korrektur

Wenn Sie bei aktivem M128 und aktiver Radiuskorrektur G41/G42 eine dreidimensionale Werkzeug-Korrektur durchführen, positioniert die TNC bei bestimmten Maschinengeometrien die Drehachsen automatisch.

Wirkung

M128 wird wirksam am Satz-Anfang, M129 am Satz-Ende. M128 wirkt auch in den manuellen Betriebsarten und bleibt nach einem Betriebsartenwechsel aktiv. Der Vorschub für die Ausgleichsbewegung bleibt so lange wirksam, bis Sie einen neuen programmieren oder M128 mit M129 rücksetzen.

M128 setzen Sie mit M129 zurück. Wenn Sie in einer Programmlauf-Betriebsart ein neues Programm wählen, setzt die TNC M128 ebenfalls zurück.

NC-Beispielsätze

Ausgleichsbewegungen mit einem Vorschub von 1000 mm/min durchführen:

n50 g01 g41 X+0 Y+38.5 IB-15 F125 M128 F1000 *
Sturzfräsen mit nicht gesteuerten Drehachsen

Wenn Sie an Ihrer Maschine nicht gesteuerte Drehachsen haben (sogenannte Zählerachsen), dann können Sie in Verbindung mit M128 auch mit diesen Achsen angestellte Bearbeitungen durchführen.

Gehen Sie dabei wie folgt vor:

  1. Die Drehachsen manuell in die gewünschte Position bringen. M128 darf dabei nicht aktiv sein
  2. M128 aktivieren: Die TNC liest die Istwerte aller vorhandenen Drehachsen, berechnet daraus die neue Position des Werkzeug-Mittelpunktes und aktualisiert die Positions-Anzeige
  3. Die erforderliche Ausgleichsbewegung führt die TNC mit dem nächsten Positioniersatz aus
  4. Bearbeitung durchführen
  5. Am Programm-Ende M128 mit M129 rücksetzen und Drehachsen wieder in Ausgangsstellung bringen

Solange M128 aktiv ist, überwacht die TNC die Istposition der nicht gesteuerten Drehachsen. Weicht die Istposition einen vom Maschinenhersteller definierbaren Wert von der Sollposition ab, gibt die TNC eine Fehlermeldung aus und unterbricht den Programmlauf.
Überschneidung M128 und M114

M128 ist eine Weiterentwicklung der Funktion M114.

M114 berechnet erforderliche Ausgleichsbewegungen in der Geometrie vor Ausführung des jeweiligen NC-Satzes. Die TNC verrechnet die Ausgleichsbewegung so, dass diese bis zum Ende des jeweiligen NC-Satzes durchführt ist.

M128 berechnet alle Ausgleichsbewegungen in Echtzeit, erforderliche Ausgleichsbewegungen führt die TNC unmittelbar aus, nachdem diese durch eine Drehachsbewegung erforderlich geworden ist.

M114 und M128 dürfen nicht gleichzeitig aktiv sein, ansonsten würden Überschneidungen beider Funktionen auftreten, die das Werkstück beschädigen könnten. Die TNC gibt eine entsprechende Fehlermeldung aus.


Genauhalt an Ecken mit nicht tangentialen Übergängen: M134

Standardverhalten

Die TNC verfährt das Werkzeug bei Positionierungen mit Drehachsen so, dass an nicht tangentialen Konturübergängen ein Übergangselement eingefügt wird. Der Konturübergang ist abhängig von der Beschleunigung, dem Ruck und der festgelegten Toleranz der Konturabweichung.

Das Standardverhalten der TNC können Sie mit dem Maschinen-Parameter 7440 so ändern, das mit Anwahl eines Programmes M134 automatisch aktiv wird, siehe Allgemeine Anwender-parameter.

Verhalten mit M134

Die TNC verfährt das Werkzeug bei Positionierungen mit Drehachsen so, dass an nicht tangentialen Konturübergängen ein Genauhalt ausgeführt wird.

Wirkung

M134 wird wirksam am Satz-Anfang, M135 am Satz-Ende.

M134 setzen Sie mit M135 zurück. Wenn Sie in einer Programmlauf-Betriebsart ein neues Programm wählen, setzt die TNC M134 ebenfalls zurück.


Auswahl von Schwenkachsen: M138

Standardverhalten

Die TNC berücksichtigt bei den Funktionen M114, M128 und Bearbeitungsebene schwenken die Drehachsen, die von Ihrem Maschinenhersteller in Maschinen-Parametern festgelegt sind.

Verhalten mit M138

Die TNC berücksichtigt bei den oben aufgeführten Funktionen nur die Schwenkachsen, die Sie mit M138 definiert haben.

Wirkung

M138 wird wirksam am Satz-Anfang.

M138 setzen Sie zurück, indem Sie M138 ohne Angabe von Schwenkachsen erneut programmieren.

NC-Beispielsätze

Für die oben aufgeführten Funktionen nur die Schwenkachse C berücksichtigen:

n50 g00 Z+100 R0 M138 C *


Berücksichtigung der Maschinen-Kinematik in IST/SOLL-Positionen am Satzende: M144 (Software-Option 2)

Standardverhalten

Die TNC fährt das Werkzeug auf die im Bearbeitungs-Programm festgelegten Positionen. Ändert sich im Programm die Position einer Schwenkachse, so muss der daraus entstehende Versatz in den Linearachsen berechnet und in einem Positioniersatz verfahren werden.

Verhalten mit M144

Die TNC berücksichtigt eine Änderung der Maschinen-Kinematik in der Positionsanzeige, wie sie z.B. durch Einwechseln einer Vorsatzspindel entsteht. Ändert sich die Position einer gesteuerten Schwenkachse, dann wird während des Schwenkvorganges auch die Position der Werkzeugspitze gegenüber dem Werkstück verändert. Der entstandene Versatz wird in der Positionsanzeige verrechnet.

Positionierungen mit M91/M92 sind bei aktivem M144 erlaubt.

Die Positionsanzeige in den Betriebsarten SATZFOLGE und EINZELSATZ ändert sich erst, nachdem die Schwenkachsen ihre Endposition erreicht haben.
Wirkung

M144 wird wirksam am Satz-Anfang. M144 wirkt nicht in Verbindung mit M114, M128 oder Bearbeitungsebene Schwenken.

M144 heben Sie auf, indem Sie M145 programmieren.

Die Maschinengeometrie muss vom Maschinenhersteller in der Kinematikbeschreibung definiert sein.

Der Maschinenhersteller legt die Wirkungsweise in den Automatik-Betriebsarten und manuellen Betriebsarten fest. Beachten Sie Ihr Maschinenhandbuch.


Peripheral Milling: 3D-Radiuskorrektur mit Werkzeug-Orientierung

Weitere Informationen:
> Anwendung


Anwendung

Beim Peripheral Milling versetzt die TNC das Werkzeug senkrecht zur Bewegungsrichtung und senkrecht zur Werkzeugrichtung um die Summe der Delta-Werte DR (Werkzeug-Tabelle und T-Satz). Die Korrekturrichtung legen Sie mit der Radiuskorrektur G41/G42 fest (siehe Bild rechts oben, Bewegungsrichtung Y+).

Damit die TNC die vorgegebene Werkzeug-Orientierung erreichen kann, müssen Sie die Funktion M128 (siehe Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM): M128 (Software-Option 2)) und anschließend die Werkzeug-Radiuskorrektur aktivieren. Die TNC positioniert dann die Drehachsen der Maschine automatisch so, dass das Werkzeug die durch die Drehachsen-Koordinaten vorgegebene Werkzeug-Orientierung mit der aktiven Korrektur erreicht.

Diese Funktion ist nur an Maschinen möglich, für deren Schwenkachsen-Konfiguration Raumwinkel definierbar sind. Beachten Sie Ihr Maschinenhandbuch.

Die TNC kann nicht bei allen Maschinen die Drehachsen automatisch positionieren. Beachten Sie Ihr Maschinenhandbuch.

Beachten Sie, dass die TNC eine Korrektur um die definierten Delta-Werte durchführt. Ein in der Werkzeug-Tabelle definierter Werkzeug-Radius R hat keinen Einfluss auf die Korrektur.

Achtung Kollisionsgefahr!

Bei Maschinen, deren Drehachsen nur einen eingeschränkten Verfahrbereich erlauben, können beim automatischen Positionieren Bewegungen auftreten, die beispielsweise eine 180°-Drehung des Tisches erfordern. Achten Sie auf Kollisionsgefahr des Kopfes mit dem Werkstück oder mit Spannmitteln.

Die Werkzeug-Orientierung können Sie in einem G01-Satz wie nachfolgend beschrieben definieren.

Beispiel: Definition der Werkzeug-Orientierung mit M128 und Koordinaten der Drehachsen
n10 g00 g90 x-20 y+0 z+0 b+0 c+0 * | Vorpositionieren
n20 m128 * | M128 aktivieren
n30 g01 g42 x+0 y+0 z+0 b+0 c+0 f1000 * | Radius-Korrektur aktivieren
n40 x+50 y+0 z+0 b-30 c+0 * | Drehachse anstellen (Werkzeug-Orientierung)


Programmieren: Paletten-Verwaltung

Weitere Informationen:
> Paletten-Verwaltung
> Palettenbetrieb mit werkzeugorientierter Bearbeitung


Paletten-Verwaltung

Weitere Informationen:
> Anwendung
> Paletten-Tabelle wählen
> Paletten-Datei verlassen
> Palettenbezugspunkt-Verwaltung mit der Palettenpreset-Tabelle
> Paletten-Datei abarbeiten


Anwendung

Die Paletten-Verwaltung ist eine maschinenabhängige Funktion. Im folgenden wird der Standard-Funktionsumfang beschrieben. Beachten Sie zusätzlich Ihr Maschinenhandbuch.

Paletten-Tabellen werden in Bearbeitungs-Zentren mit Paletten-Wechslern eingesetzt: Die Paletten-Tabelle ruft für die verschiedenen Paletten die zugehörigen Bearbeitungs-Programme auf und aktiviert Nullpunkt-Verschiebungen bzw. Nullpunkt-Tabellen.

Sie können Paletten-Tabellen auch verwenden, um verschiedene Programme mit unterschiedlichen Bezugspunkten hintereinander abzuarbeiten.

Paletten-Tabellen enthalten folgende Angaben:

  • PAL/PGM (Eintrag zwingend erforderlich):
    Kennung Palette oder NC-Programm (mit Taste ENT bzw. NO ENT wählen)
  • NAME (Eintrag zwingend erforderlich):
    Paletten-, bzw. Programm-Name. Die Paletten-Namen legt der Maschinenhersteller fest (Maschinenhandbuch beachten). Programm-Namen müssen im selben Verzeichnis gespeichert sein wie die Paletten-Tabelle, ansonsten müssen Sie den vollständigen Pfadnamen des Programms eingeben
  • PALPRES (Eintrag wahlweise):
    Preset-Nummer aus der Palettenpreset-Tabelle. Die hier definierte Preset-Nummer wird von der TNC als Paletten-Bezugspunkt (Eintrag PAL in Spalte PAL/PGM) interpretiert. Der Palettenpreset kann verwendet werden, um mechanische Unterschiede zwischen den Paletten auszugleichen. Ein Palettenpreset lässt sich auch beim Einwechseln der Palette automatisch aktivieren
  • PRESET (Eintrag wahlweise):
    Preset-Nummer aus der Preset-Tabelle. Die hier definierte Preset-Nummer wird von der TNC entweder als Paletten-Bezugspunkt (Eintrag PAL in Spalte PAL/PGM) o der als Werkstück-Bezugspunkt (Eintrag PGM in Zeile PAL/PGM) interpretiert. Wenn an Ihrer Maschine eine Paletten-Preset-Tabelle aktiv ist, dann die Spalte PRESET nur für Werkstück-Bezugspunkte verwenden
  • DATUM (Eintrag wahlweise):
    Name der Nullpunkt-Tabelle. Nullpunkt-Tabellen müssen im selben Verzeichnis gespeichert sein wie die Paletten-Tabelle, ansonsten müssen Sie den vollständigen Pfadnamen der Nullpunkt-Tabelle eingeben. Nullpunkte aus der Nullpunkt-Tabelle aktivieren Sie im NC-Programm mit dem Zyklus 7 NULLPUNKT-VERSCHIEBUNG
  • X, Y, Z (Eintrag wahlweise, weitere Achsen möglich):
    Bei Paletten-Namen beziehen sich die programmierten Koordinaten auf den Maschinen-Nullpunkt. Bei NC-Programmen beziehen sich die programmierten Koordinaten auf den Paletten-Nullpunkt. Diese Einträge überschreiben den Bezugspunkt, den Sie zuletzt in der Betriebsart Manuell gesetzt haben. Mit der Zusatz-Funktion M104 können Sie den letzten gesetzten Bezugspunkt wieder aktivieren. Mit der Taste „Ist-Position übernehmen“, blendet die TNC ein Fenster ein, mit dem Sie verschiedene Punkte von der TNC als Bezugspunkt eintragen lassen können (siehe folgende Tabelle)
Position | Bedeutung
Istwerte | Koordinaten der aktuellen Werkzeug-Position bezogen auf das aktive Koordinaten-System eintragen
Referenzwerte | Koordinaten der aktuellen Werkzeug-Position bezogen auf den Maschinen-Nullpunkt eintragen
Messwerte IST | Koordinaten bezogen auf das aktive Koordinaten-System des zuletzt in der Betriebsart Manuell angetasteten Bezugspunkts eintragen
Messwerte REF | Koordinaten bezogen auf den Maschinen-Nullpunkt des zuletzt in der Betriebsart Manuell angetasteten Bezugspunkts eintragen

Mit den Pfeiltasten und der Taste ENT wählen Sie die Position die Sie übernehmen wollen. Anschließend wählen Sie mit dem Softkey ALLE WERTE, dass die TNC die jeweiligen Koordinaten aller aktiven Achsen in die Paletten-Tabelle speichert. Mit dem Softkey AKTUELLEN WERT speichert die TNC die Koordinate der Achse, auf der das Hellfeld in der Paletten-Tabelle gerade steht.

Wenn Sie vor einem NC-Programm keine Palette definiert haben, beziehen sich die programmierten Koordinaten auf den Maschinen-Nullpunkt. Wenn Sie keinen Eintrag definieren, bleibt der manuell gesetzte Bezugspunkt aktiv.

Editier-Funktion | Softkey
Tabellen-Anfang wählen |
Tabellen-Ende wählen |
Vorherige Tabellen-Seite wählen |
Nächste Tabellen-Seite wählen |
Zeile am Tabellen-Ende einfügen |
Zeile am Tabellen-Ende löschen |
Anfang der nächsten Zeile wählen |
Eingebbare Anzahl von Zeilen am Tabellenende anfügen |
Hell hinterlegtes Feld kopieren (2. Softkey-Leiste) |
Kopiertes Feld einfügen (2. Softkey-Leiste) |


Paletten-Tabelle wählen

  • In der Betriebsart Programm-Einspeichern/Editieren oder Programmlauf Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Dateien vom Typ .P anzeigen: Softkeys TYP WÄHLEN und ANZEIGEN .P drücken

  • Paletten-Tabelle mit Pfeil-Tasten wählen oder Namen für eine neue Tabelle eingeben

  • Auswahl mit Taste ENT bestätigen


Paletten-Datei verlassen

  • Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Anderen Datei-Typ wählen: Softkey TYP WÄHLEN und Softkey für den gewünschten Datei-Typ drücken, z.B. ANZEIGEN .H

  • Gewünschte Datei wählen


Palettenbezugspunkt-Verwaltung mit der Palettenpreset-Tabelle

Die Palettenpreset-Tabelle wird von Ihrem Maschinenhersteller konfiguriert, Maschinenhandbuch beachten!

Neben der Preset-Tabelle zur Werkstück-Bezugspunktverwaltung steht zusätzlich eine Preset-Tabelle zur Bezugspunktverwaltung von Paletten zur Verfügung. Damit lassen sich Palettenbezugspunkte unabhängig von den Werkstückbezugspunkten verwalten.

Über die Palettenbezugspunkte lassen sich beispielsweise mechanisch bedingte Differenzen zwischen einzelnen Paletten auf einfache Weise kompensieren.

Zur Erfassung der Paletten-Bezugspunkte steht in den manuellen Antastfunktionen ein zusätzlicher Softkey zur Verfügung, mit dem Sie Antastergebnisse auch in die Palettenpreset-Tabelle speichern können (siehe Messwerte in der Paletten-Beugspunkt-Tabelle speichern).

Es können immer nur ein Werkstückbezugspunkt und ein Palettenbezugspunkt gleichzeitig aktiv sein. Beide Bezugspunkte wirken in Summe.

Die Nummer des aktiven Palettenpresets zeigt die TNC in der zusätzlichen Status-Anzeige an (siehe Allgemeine Paletten-Information (Reiter PAL)).

Weitere Informationen:
> Mit der Palettenpreset-Tabelle arbeiten


Mit der Palettenpreset-Tabelle arbeiten

Änderungen an der Palettenpreset-Tabelle nur in Absprache mit Ihrem Maschinenhersteller durchführen!

Sofern Ihr Maschinenhersteller die Palettenpreset-Tabelle freigeschaltet hat, können Sie die Palettenpreset-Tabelle in der Betriebsart Manuell editieren:

  • Betriebsart Manueller Betrieb oder El. Handrad wählen

Preset-Tabelle öffnen: Softkey bezugspkt. verwaltung drücken. Die TNC öffnet die Preset-Tabelle

Softkey-Leiste weiterschalten

Palettenpreset-Tabelle öffnen: Softkey paletten pres. tab. drücken. Die TNC zeigt weitere Softkeys: Siehe Tabelle unten

Folgende Editierfunktionen stehen zur Verfügung:

Editier-Funktion im Tabellenmodus | Softkey
Tabellen-Anfang wählen |
Tabellen-Ende wählen |
Vorherige Tabellen-Seite wählen |
Nächste Tabellen-Seite wählen |
Einzelne Zeile am Tabellen-Ende einfügen |
Einzelne Zeile am Tabellen-Ende löschen |
Editieren einschalten/ausschalten |
Den Palettenbezugspunkt der aktuell angewählten Zeile aktivieren (2. Softkey-Leiste) |
Den momentan aktiven Palettenbezugspunkt deaktivieren (2. Softkey-Leiste) |


Paletten-Datei abarbeiten

Per Maschinen-Parameter ist festgelegt, ob die Paletten-Tabelle satzweise oder kontinuierlich abgearbeitet wird.

Sofern über den Maschinen-Parameter 7246 die Werkzeug-Einsatzprüfung aktiviert ist, können Sie die Werkzeug-Standzeit für alle in einer Palette verwendeten Werkzeuge überprüfen (siehe Werkzeug-Einsatzprüfung).

  • In der Betriebsart Programmlauf Satzfolge oder Programmlauf Einzelsatz Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Dateien vom Typ .P anzeigen: Softkeys TYP WÄHLEN und ANZEIGEN .P drücken

  • Paletten-Tabelle mit Pfeil-Tasten wählen, mit Taste ENT bestätigen

  • Paletten-Tabelle abarbeiten: Taste NC-Start drücken, die TNC arbeitet die Paletten ab wie im Maschinen-Parameter 7683 festgelegt
Weitere Informationen:
> Bildschirm-Aufteilung beim Abarbeiten der Paletten-Tabelle


Bildschirm-Aufteilung beim Abarbeiten der Paletten-Tabelle

Wenn Sie den Programm-Inhalt und den Inhalt der Paletten-Tabelle gleichzeitig sehen wollen, dann wählen Sie die Bildschirm-Aufteilung PROGRAMM + PALETTE. Während des Abarbeitens stellt die TNC dann auf der linken Bildschirmseite das Programm und auf der rechten Bildschirmseite die Palette dar. Um den Programm-Inhalt vor dem Abarbeiten ansehen zu können gehen Sie wie folgt vor:

  • Paletten-Tabelle wählen

  • Mit Pfeiltasten Programm wählen, das Sie kontrollieren wollen

  • Softkey PROGRAMM ÖFFNEN drücken: Die TNC zeigt das gewählte Programm am Bildschirm an. Mit den Pfeiltasten können Sie jetzt im Programm blättern

  • Zurück zur Paletten-Tabelle: Drücken Sie den Softkey END PGM


Palettenbetrieb mit werkzeugorientierter Bearbeitung

Weitere Informationen:
> Anwendung
> Paletten-Datei wählen
> Paletten-Datei mit Eingabeformular einrichten
> Ablauf der werkzeugorientierten Bearbeitung
> Paletten-Datei verlassen
> Paletten-Datei abarbeiten


Anwendung

Die Paletten-Verwaltung in Verbindung mit der werkzeugorientierten Bearbeitung ist eine maschinenabhängige Funktion. Im folgenden wird der Standard-Funktionsumfang beschrieben. Beachten Sie zusätzlich Ihr Maschinenhandbuch.

Paletten-Tabellen werden in Bearbeitungs-Zentren mit Paletten-Wechslern eingesetzt: Die Paletten-Tabelle ruft für die verschiedenen Paletten die zugehörigen Bearbeitungs-Programme auf und aktiviert Nullpunkt-Verschiebungen bzw. Nullpunkt-Tabellen.

Sie können Paletten-Tabellen auch verwenden, um verschiedene Programme mit unterschiedlichen Bezugspunkten hintereinander abzuarbeiten.

Paletten-Tabellen enthalten folgende Angaben:

  • PAL/PGM (Eintrag zwingend erforderlich):
    Der Eintrag Pal legt die Kennung für eine Palette fest, mit FIX wird eine Aufspannungsebene gekennzeichnet und mit PGM geben Sie ein Werkstück an
  • W-STATE :
    Aktueller Bearbeitungs-Status. Durch den Bearbeitungs-Status wird der Fortschritt der Bearbeitung festgelegt. Geben Sie für das unbearbeitete Werkstück BLANK an. Die TNC ändert diesen Eintrag bei der Bearbeitung auf INCOMPLETE und nach der vollständigen Bearbeitung auf ENDEd. Mit dem Eintrag EMPTY wird ein Platz gekennzeichnet, an dem kein Werkstück aufgespannt ist. Mit dem Eintrag SKIP legen Sie fest, dass ein Werkstück von der TNC nicht bearbeitet werden soll
  • METHOD (Eintrag zwingend erforderlich):
    Angabe, nach welcher Methode die Programm-Optimierung erfolgt. Mit WPO erfolgt die Bearbeitung werkstückorientiert. Mit TO erfolgt die Bearbeitung für das Teil werkzeugorientiert. Um nachfolgende Werkstücke in die werkzeugorientierte Bearbeitung miteinzubeziehen müssen Sie den Eintrag CTO (continued tool oriented) verwenden. Die werkzeugorientierte Bearbeitung ist auch über Aufspannungen einer Palette hinweg möglich, nicht jedoch über mehrere Paletten
  • NAME (Eintrag zwingend erforderlich):
    Paletten-, bzw. Programm-Name. Die Paletten-Namen legt der Maschinenhersteller fest (Maschinenhandbuch beachten). Programme müssen im selben Verzeichnis gespeichert sein wie die Paletten-Tabelle, ansonsten müssen Sie den vollständigen Pfadnamen des Programms eingeben
  • PALPRESET (Eintrag wahlweise):
    Preset-Nummer aus der Palettenpreset-Tabelle. Die hier definierte Preset-Nummer wird von der TNC als Paletten-Bezugspunkt (Eintrag PAL in Spalte PAL/PGM) interpretiert. Der Palettenpreset kann verwendet werden, um mechanische Unterschiede zwischen den Paletten auszugleichen. Ein Palettenpreset lässt sich auch beim Einwechseln der Palette automatisch aktivieren
  • PRESET (Eintrag wahlweise):
    Preset-Nummer aus der Preset-Tabelle. Die hier definierte Preset-Nummer wird von der TNC entweder als Paletten-Bezugspunkt (Eintrag PAL in Spalte PAL/PGM) oder als Werkstück-Bezugspunkt (Eintrag PGM in Zeile PAL/PGM) interpretiert. Wenn an Ihrer Maschine eine Paletten-Preset-Tabelle aktiv ist, dann die Spalte PRESET nur für Werkstück-Bezugspunkte verwenden
  • DATUM (Eintrag wahlweise):
    Name der Nullpunkt-Tabelle. Nullpunkt-Tabellen müssen im selben Verzeichnis gespeichert sein wie die Paletten-Tabelle, ansonsten müssen Sie den vollständigen Pfadnamen der Nullpunkt-Tabelle eingeben. Nullpunkte aus der Nullpunkt-Tabelle aktivieren Sie im NC-Programm mit dem Zyklus 7 NULLPUNKT-VERSCHIEBUNG
  • X, Y, Z (Eintrag wahlweise, weitere Achsen möglich):
    Bei Paletten und Aufspannungen beziehen sich die programmierten Koordinaten auf den Maschinen-Nullpunkt. Bei NC-Programmen beziehen sich die programmierten Koordinaten auf den Paletten- bzw. Aufspannungs-Nullpunkt. Diese Einträge überschreiben den Bezugspunkt, den Sie zuletzt in der Betriebsart Manuell gesetzt haben. Mit der Zusatz-Funktion M104 können Sie den letzten gesetzten Bezugspunkt wieder aktivieren. Mit der Taste „Ist-Position übernehmen“, blendet die TNC ein Fenster ein, mit dem Sie verschiedene Punkte von der TNC als Bezugspunkt eintragen lassen können (siehe folgende Tabelle)
Position | Bedeutung
Istwerte | Koordinaten der aktuellen Werkzeug-Position bezogen auf das aktive Koordinaten-System eintragen
Referenzwerte | Koordinaten der aktuellen Werkzeug-Position bezogen auf den Maschinen-Nullpunkt eintragen
Messwerte IST | Koordinaten bezogen auf das aktive Koordinaten-System des zuletzt in der Betriebsart Manuell angetasteten Bezugspunkts eintragen
Messwerte REF | Koordinaten bezogen auf den Maschinen-Nullpunkt des zuletzt in der Betriebsart Manuell angetasteten Bezugspunkts eintragen

Mit den Pfeiltasten und der Taste ENT wählen Sie die Position die Sie übernehmen wollen. Anschließend wählen Sie mit dem Softkey ALLE WERTE, dass die TNC die jeweiligen Koordinaten aller aktiven Achsen in die Paletten-Tabelle speichert. Mit dem Softkey AKTUELLEN WERT speichert die TNC die Koordinate der Achse, auf der das Hellfeld in der Paletten-Tabelle gerade steht.

Wenn Sie vor einem NC-Programm keine Palette definiert haben, beziehen sich die programmierten Koordinaten auf den Maschinen-Nullpunkt. Wenn Sie keinen Eintrag definieren, bleibt der manuell gesetzte Bezugspunkt aktiv.

  • SP-X, SP-Y, SP-Z (Eintrag wahlweise, weitere Achsen möglich):
    Für die Achsen können Sicherheitspositionen angegeben werden, welche mit SYSREAD FN18 ID510 NR 6 von NC-Makros aus gelesen werden können. Mit SYSREAD FN18 ID510 NR 5 kann ermittelt werden, ob in der Spalte ein Wert programmiert wurde. Die angegebenen Positionen werden nur angefahren, wenn in den NC-Makros diese Werte gelesen und entsprechend programmiert werden.
  • CTID (Eintrag erfolgt durch TNC):
    Die Kontext-Identnummer wird von der TNC vergeben und enthält Hinweise über den Bearbeitungs-Fortschritt. Wird der Eintrag gelöscht, bzw. geändert, ist ein Wiedereinstieg in die Bearbeitung nicht möglich
  • fixture
    In dieser Spalte können Sie ein Spannmittelarchiv (ZIP-Datei) angeben, das die TNC beim Abarbeiten der Paletten-Tabelle automatisch aktivieren soll. Spannmittelarchive müssen Sie über die Spannmittel-Verwaltung archivieren (siehe Aufspannungen verwalten)
Editier-Funktion im Tabellenmodus | Softkey
Tabellen-Anfang wählen |
Tabellen-Ende wählen |
Vorherige Tabellen-Seite wählen |
Nächste Tabellen-Seite wählen |
Zeile am Tabellen-Ende einfügen |
Zeile am Tabellen-Ende löschen |
Anfang der nächsten Zeile wählen |
Eingebbare Anzahl von Zeilen am Tabellenende anfügen |
Tabellenformat editieren |
Editier-Funktion im Formularmodus | Softkey
Vorherige Palette wählen |
Nächste Palette wählen |
Vorherige Aufspannung wählen |
Nächste Aufspannung wählen |
Vorheriges Werkstück wählen |
Nächstes Werkstück wählen |
Auf Palettenebene wechseln |
Auf Aufspannungsebene wechseln |
Auf Werkstückebene wechseln |
Standardansicht Palette wählen |
Detailansicht Palette wählen |
Standardansicht Aufspannung wählen |
Detailansicht Aufspannung wählen |
Standardansicht Werkstück wählen |
Detailansicht Werkstück wählen |
Palette einfügen |
Aufspannung einfügen |
Werkstück einfügen |
Palette löschen |
Aufspannung löschen |
Werkstück löschen |
Zwischenspeicher löschen |
Werkzeugoptimierte Bearbeitung |
Werkstückoptimierte Bearbeitung |
Verbinden bzw. Trennen der Bearbeitungen |
Ebene als leer kennzeichnen |
Ebene als unbearbeitet kennzeichnen |


Paletten-Datei wählen

  • In der Betriebsart Programm-Einspeichern/Editieren oder Programmlauf Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Dateien vom Typ .P anzeigen: Softkeys TYP WÄHLEN und ANZEIGEN .P drücken

  • Paletten-Tabelle mit Pfeil-Tasten wählen oder Namen für eine neue Tabelle eingeben

  • Auswahl mit Taste ENT bestätigen


Paletten-Datei mit Eingabeformular einrichten

    Der Palettenbetrieb mit werkzeug- bzw. werkstückorientierter Bearbeitung gliedert sich in die drei Ebenen:

  • Palettenebene Pal
  • Aufspannungsebene FIX
  • Werkstückebene PGM

Auf jeder Ebene ist ein Wechsel in die Detailansicht möglich. In der normalen Ansicht können Sie die Bearbeitungsmethode und den Status für die Palette, Aufspannung und Werkstück festlegen. Falls Sie eine vorhandene Paletten-Datei editieren, werden die aktuellen Einträge angezeigt. Verwenden Sie die Detailansicht zum Einrichten der Paletten-Datei.

Richten Sie die Paletten-Datei entsprechend der Maschinenkonfiguration ein. Falls Sie nur eine Aufspannvorrichtung mit mehreren Werkstücken haben, ist es ausreichend eine Aufspannung FIX mit Werkstücken PGM zu definieren. Enthält eine Palette mehrere Aufspannvorrichtungen oder wird eine Aufspannung mehrseitig bearbeitet, müssen Sie eine Palette PAL mit entsprechenden Aufspannungsebenen FIX definieren.

Sie können zwischen der Tabellenansicht und der Formularansicht mit der Taste für die Bildschirm-Aufteilung wechseln.

Die grafische Unterstützung der Formulareingabe ist noch nicht verfügbar.

Die verschiedenen Ebenen im Eingabeformular sind mit den jeweiligen Softkeys erreichbar. In der Statuszeile wird im Eingabeformular immer die aktuelle Ebene hell hinterlegt. Wenn Sie mit der Taste für die Bildschirm-Aufteilung in die Tabellendarstellung wechseln, steht der Cursor auf der gleichen Ebene wie in der Formulardarstellung.

Weitere Informationen:
> Palettenebene einstellen
> Details in der Palettenebene einrichten
> Aufspannungsebene einstellen
> Details in der Aufspannungsebene einrichten
> Werkstückebene einstellen
> Details in der Werkstückebene einrichten


Palettenebene einstellen
  • Paletten-Id: Der Name der Palette wird angezeigt
  • Methode: Sie können die Bearbeitungsmethoden WERKSTUECK ORIENTIERT bzw. WERKZEUG ORIENTIERT auswählen. Die getroffene Auswahl wird in die dazugehörige Werkstückebene mit übernommen und überschreibt eventuell vorhandene Einträge. In der Tabellenansicht erscheint die Methode WERKSTUECK ORIENTIERT mit WPO und WERKZEUG ORIENTIERT mit TO.

Der Eintrag WERKST./WERKT. ORIENT. kann nicht über Softkey eingestellt werden. Dieser erscheint nur, wenn in der Werkstück- bzw. Aufspannungsebene unterschiedliche Bearbeitungsmethoden für die Werkstücke eingestellt wurden.

Wird die Bearbeitungsmethode in der Aufspannungsebene eingestellt, werden die Einträge in die Werkstückebene übernommen und eventuell vorhandene überschrieben.
  • Status: Der Sofkey ROHTEIL kennzeichnet die Palette mit den dazugehörigen Aufspannungen bzw. Werkstücken als noch nicht bearbeitet, im Feld Status wird BLANK eingetragen. Verwenden Sie den Softkey FREIER PLATZ oder AUSLASSEN, falls Sie die Palette bei der Bearbeitung überspringen möchten, im Feld Status erscheint Empty bzw. SKIP


Details in der Palettenebene einrichten
  • Paletten-Id: Geben Sie den Namen der Palette ein
  • Preset-Nr.: Preset-Nummer für Palette eingeben
  • Nullpunkt: Nullpunkt für Palette eingeben
  • NP-Tabelle: Tragen Sie Namen und Pfad der Nullpunkt-Tabelle für das Werkstück ein. Die Eingabe wird in die Aufspannungs- und Werkstückebene übernommen.
  • Sich. Höhe: (optional): Sichere Position für die einzelnen Achsen bezogen auf die Palette. Die angegebenen Positionen werden nur angefahren, wenn in den NC-Makros diese Werte gelesen und entsprechend programmiert wurden.


Aufspannungsebene einstellen
  • Aufspannung: Die Nummer der Aufspannung wird angezeigt, nach dem Schrägstrich wird die Anzahl der Aufspannungen innerhalb dieser Ebene angezeigt
  • Methode: Sie können die Bearbeitungsmethoden WERKSTUECK ORIENTIERT bzw. WERKZEUG ORIENTIERT auswählen. Die getroffene Auswahl wird in die dazugehörige Werkstückebene mit übernommen und überschreibt eventuell vorhandene Einträge. In der Tabellenansicht erscheint der Eintrag WERKSTUECK ORIENTIERT mit WPO und WERKZEUG ORIENTIERT mit TO.
    Mit dem Softkey VERBINDEN/TRENNEN kennzeichnen Sie Aufspannungen, welche bei werkzeugorientierter Bearbeitung in die Berechnung für den Arbeitsablauf mit eingehen. Verbundene Aufspannungen werden durch einen unterbrochenen Trennungsstrich gekennzeichnet, getrennte Aufspannungen durch eine durchgehende Linie. In der Tabellenansicht werden verbundene Werkstücke in der Spalte METHOD mit CTO gekennzeichnet.

Der Eintrag WERKST./WERKT. ORIENT. kann nicht über Softkey eingestellt werden, der erscheint nur, wenn in der Werkstückebene unterschiedliche Bearbeitungsmethoden für die Werkstücke eingestellt wurden.

Wird die Bearbeitungsmethode in der Aufspannungsebene eingestellt, werden die Einträge in die Werkstückebene übernommen und eventuell vorhandene überschrieben.
  • Status: Mit dem Softkey ROHTEIL wird die Aufspannung mit den dazugehörigen Werkstücken als noch nicht bearbeitet gekennzeichnet und im Feld Status wird BLANK eingetragen. Verwenden Sie den Softkey FREIER PLATZ oder AUSLASSEN, falls Sie die Aufspannung bei der Bearbeitung überspringen möchten, im Feld Status erscheint Empty bzw. SKIP


Details in der Aufspannungsebene einrichten
  • Aufspannung: Die Nummer der Aufspannung wird angezeigt, nach dem Schrägstrich wird die Anzahl der Aufspannungen innerhalb dieser Ebene angezeigt
  • Nullpunkt: Nullpunkt für Aufspannung eingeben
  • NP-Tabelle: Tragen Sie Namen und Pfad der Nullpunkt-Tabelle ein, welche für die Bearbeitung des Werkstückes gültig ist. Die Eingabe wird in die Werkstückebene übernommen.
  • NC-Makro: Bei werkzeugorientierter Bearbeitung wird das Makro TCTOOLMODE anstelle des normalen Werkzeugwechsel-Makro ausgeführt.
  • Sich. Höhe: (optional): Sichere Position für die einzelnen Achsen bezogen auf die Aufspannung

Für die Achsen können Sicherheitspositionen angegeben werden, welche mit SYSREAD FN18 ID510 NR 6 von NC-Makros aus gelesen werden können. Mit SYSREAD FN18 ID510 NR 5 kann ermittelt werden, ob in der Spalte ein Wert programmiert wurde. Die angegebenen Positionen werden nur angefahren, wenn in den NC-Makros diese Werte gelesen und entsprechend programmiert werden


Werkstückebene einstellen
  • Werkstück: Die Nummer des Werkstückes wird angezeigt, nach dem Schrägstrich wird die Anzahl der Werkstücke innerhalb dieser Aufspannungsebene angezeigt
  • Methode: Sie können die Bearbeitungsmethoden WORKPIECE ORIENTED bzw. TOOL ORIENTED auswählen. In der Tabellenansicht erscheint der Eintrag WORKPIECE ORIENTED mit WPO und TOOL ORIENTED mit TO.
    Mit dem Softkey VERBINDEN/TRENNEN kennzeichnen Sie Werkstücke, welche bei werkzeugorientierter Bearbeitung in die Berechnung für den Arbeitsablauf miteingehen. Verbundene Werkstücke werden durch einen unterbrochenen Trennungsstrich gekennzeichnet, getrennte Werkstücke durch eine durchgehende Linie. In der Tabellenansicht werden verbundene Werkstücke in der Spalte METHOD mit CTO gekennzeichnet.
  • Status: Mit dem Sofkey ROHTEIL wird das Werkstück als noch nicht bearbeitet gekennzeichnet und im Feld Status wird BLANK eingetragen. Verwenden Sie den Softkey FREIER PLATZ oder AUSLASSEN, falls Sie ein Werkstück bei der Bearbeitung überspringen möchten, im Feld Status erscheint Empty bzw. SKIP

Stellen Sie Methode und Status in der Paletten- bzw. Aufspannungsebene ein, die Eingabe wird für alle dazugehörigen Werkstücke übernommen.

Bei mehreren Werkstückvarianten innerhalb einer Ebene sollten Werkstücke einer Variante nacheinander angegeben werden. Bei werkzeugorientierter Bearbeitung können die Werkstücke der jeweiligen Variante dann mit dem Softkey VERBINDEN/TRENNEN gekennzeichnet und gruppenweise bearbeitet werden.


Details in der Werkstückebene einrichten
  • Werkstück: Die Nummer des Werkstückes wird angezeigt, nach dem Schrägstrich wird die Anzahl der Werkstücke innerhalb dieser Aufspannungs- bzw. Palettenebene angezeigt
  • Nullpunkt: Nullpunkt für Werkstück eingeben
  • NP-Tabelle: Tragen Sie Namen und Pfad der Nullpunkt-Tabelle ein, welche für die Bearbeitung des Werkstückes gültig ist. Falls Sie für alle Werkstücke die gleiche Nullpunkttabelle verwenden, tragen Sie den Namen mit der Pfadangabe in die Paletten- bzw. Aufspannungsebenen ein. Die Angaben werden automatisch in die Werkstückebene übernommen.
  • NC-Programm: Geben Sie den Pfad des NC-Programmes an, welches für die Bearbeitung des Werkstücks notwendig ist
  • Sich. Höhe: (optional): Sichere Position für die einzelnen Achsen bezogen auf das Werkstück. Die angegebenen Positionen werden nur angefahren, wenn in den NC-Makros diese Werte gelesen und entsprechend programmiert wurden.


Ablauf der werkzeugorientierten Bearbeitung

Die TNC führt eine werkzeugorientierte Bearbeitung nur dann durch, wenn bei der Methode WERKZEUG ORIENTIERT gewählt wurde und dadurch der Eintrag TO bzw. CTO in der Tabelle steht.
  • Die TNC erkennt durch den Eintrag TO bzw. CTO im Feld Methode, das über diese Zeilen hinweg die optimierte Bearbeitung erfolgen muss.
  • Die Palettenverwaltung startet das NC-Programm, welches in der Zeile mit dem Eintrag TO steht
  • Das erste Werkstück wird bearbeitet, bis der nächste TOOL CALL ansteht. In einem speziellen Werkzeugwechselmakro wird vom Werkstück weggefahren
  • In der Spalte W-STATE wird der Eintrag BLANK auf INCOMPLETE geändert und im Feld CTID wird von der TNC ein Wert in hexadezimaler Schreibweise eingetragen

Der im Feld CTID eingetragene Wert stellt für die TNC eine eindeutige Information für den Bearbeitungsfortschritt dar. Wird dieser Wert gelöscht oder geändert, ist eine weitergehende Bearbeitung oder ein Vorauslauf bzw. Wiedereintritt nicht mehr möglich.
  • Alle weiteren Zeilen der Paletten-Datei, die im Feld METHODE die Kennung CTO haben, werden in gleicher Weise abgearbeitet, wie das erste Werkstück. Die Bearbeitung der Werkstücke kann über mehrere Aufspannungen hinweg erfolgen.
  • Die TNC führt mit dem nächsten Werkzeug die weiteren Bearbeitungsschritte wieder beginnend ab der Zeile mit dem Eintrag TO aus, wenn sich folgende Situation ergibt:
    • im Feld PAL/PGM der nächsten Zeile würde der Eintrag PAL stehen
    • im Feld METHOD der nächsten Zeile würde der Eintrag TO oder WPO stehen
    • in den bereits abgearbeiteten Zeilen befinden sich unter METHODE noch Einträge, welche nicht den Status EMPTY oder ENDED haben
  • Aufgrund des im Feld CTID eingetragenen Wertes wird das NC-Programm an der gespeicherten Stelle fortgesetzt. In der Regel wird bei dem ersten Teil ein Werkzeugwechsel ausgeführt, bei den nachfolgenden Werkstücken unterdrückt die TNC den Werkzeugwechsel
  • Der Eintrag im Feld CTID wird bei jedem Bearbeitungsschritt aktualisiert. Wird im NC-Programm ein END PGM oder M2 abgearbeitet, wird ein eventuell vorhandener Eintrag gelöscht und im Feld Bearbeitungs-Status ENDED eingetragen.
  • Wenn alle Werkstücke innerhalb einer Gruppe von Einträgen mit TO bzw. CTO den Status ENDED haben, werden in der Paletten-Datei die nächsten Zeilen abgearbeitet

Bei einem Satzvorlauf ist nur eine werkstückorientierte Bearbeitung möglich. Nachfolgende Teile werden nach der eingetragenen Methode bearbeitet.

Der im Feld CT-ID eingetragene Wert bleibt maximal 2 Wochen lang erhalten. Innerhalb dieser Zeit kann die Bearbeitung an der gespeicherten Stelle fortgesetzt werden. Danach wird der Wert gelöscht, um zu große Datenmengen auf der Festplatte zu vermeiden.

Der Wechsel der Betriebsart ist nach dem Abarbeiten einer Gruppe von Einträgen mit TO bzw. CTO erlaubt

    Folgende Funktionen sind nicht erlaubt:

  • Verfahrbereichsumschaltung
  • PLC-Nullpunktverschieben
  • M118


Paletten-Datei abarbeiten

Im Maschinen-Parameter 7683 legen Sie fest, ob die Paletten-Tabelle satzweise oder kontinuierlich abgearbeitet wird (siehe Allgemeine Anwender-parameter).

Sofern über den Maschinen-Parameter 7246 die Werkzeug-Einsatzprüfung aktiviert ist, können Sie die Werkzeug-Standzeit für alle in einer Palette verwendeten Werkzeuge überprüfen (siehe Werkzeug-Einsatzprüfung).

  • In der Betriebsart Programmlauf Satzfolge oder Programmlauf Einzelsatz Datei-Verwaltung wählen: Taste PGM MGT drücken

  • Dateien vom Typ .P anzeigen: Softkeys TYP WÄHLEN und ANZEIGEN .P drücken

  • Paletten-Tabelle mit Pfeil-Tasten wählen, mit Taste ENT bestätigen

  • Paletten-Tabelle abarbeiten: Taste NC-Start drücken, die TNC arbeitet die Paletten ab wie im Maschinen-Parameter 7683 festgelegt
Weitere Informationen:
> Bildschirm-Aufteilung beim Abarbeiten der Paletten-Tabelle


Handbetrieb und Einrichten

Weitere Informationen:
> Einschalten, Ausschalten
> Verfahren der Maschinenachsen
> Spindeldrehzahl S, Vorschub F und Zusatzfunktion M
> Funktionale Sicherheit FS (Option)
> Bezugspunkt-Setzen ohne Tastsystem
> Tastsystem verwenden
> Tastsystem kalibrieren
> Werkstück-Schieflage mit Tastsystem kompensieren
> Bezugspunkt-Setzen mit Tastsystem
> Bearbeitungsebene schwenken (Software-Option 1)


Einschalten, Ausschalten

Weitere Informationen:
> Einschalten
> Ausschalten


Einschalten

Das Einschalten und das Anfahren der Referenzpunkte sind maschinenabhängige Funktionen. Beachten Sie Ihr Maschinenhandbuch.

Die Versorgungsspannung von TNC und Maschine einschalten. Danach zeigt die TNC folgenden Dialog an:

Speichertest
Speicher der TNC wird automatisch überprüft
Stromunterbrechung
 | TNC-Meldung, dass Stromunterbrechung vorlag – Meldung löschen
PLC-Programm übersetzen
PLC-Programm der TNC wird automatisch übersetzt
Steuerspannung für Relais fehlt
 | Steuerspannung einschalten. Die TNC überprüft die Funktion der Not-Aus-Schaltung
Manueller Betrieb Referenzpunkte überfahren
 | Referenzpunkte in vorgegebener Reihenfolge überfahren: Für jede Achse externe START-Taste drücken, oder
 | Referenzpunkte in beliebiger Reihenfolge überfahren: Für jede Achse externe Richtungstaste drücken und halten, bis Referenzpunkt überfahren ist

Wenn Ihre Maschine mit absoluten Messgeräten ausgerüstet ist, entfällt das Überfahren der Referenzmarken. Die TNC ist dann sofort nach dem Einschalten der Steuerspannungs funktionsbereit.

Wenn Ihre Maschine mit inkrementalen Messgeräten ausgerüstet ist, dann können Sie bereits vor dem Anfahren des Referenzpunktes die Verfahrbereichsüberwachung durch Drücken des Softkeys ÜBERWACH. SW-ENDSCH. aktivieren. Diese Funktion kann Ihr Maschinenhersteller achsspezifisch zur Verfügung stellen. Beachten Sie, dass durch Drücken des Softkeys die Verfahrbereichsüberwachung nicht in allen Achsen aktiv sein muss. Maschinenhandbuch beachten.

Stellen Sie sicher, dass Sie alle Achsen refernziert haben, bevor Sie den Programmlauf starten. Die TNC stoppt ansonsten die Bearbeitung, sobald sie einen NC-Satz mit einer nicht referenzierten Achse abarbeiten soll.

Die TNC ist jetzt funktionsbereit und befindet sich in der Betriebsart Manueller Betrieb.

Die Referenzpunkte müssen Sie nur dann überfahren, wenn Sie die Maschinenachsen verfahren wollen. Wenn Sie nur Programme editieren oder testen wollen, dann wählen Sie nach dem Einschalten der Steuerspannung sofort die Betriebsart Programm-Einspeichern/Editieren oder Programm-Test.

Die Referenzpunkte können Sie dann nachträglich überfahren. Drücken Sie dazu in der Betriebsart Manueller Betrieb den Softkey REF.-PKT. ANFAHREN.

Weitere Informationen:
> Referenzpunkt überfahren bei geschwenkter Bearbeitungsebene


Referenzpunkt überfahren bei geschwenkter Bearbeitungsebene

Referenzpunkt-Überfahren im geschwenkten Koordinatensystem ist über die externen Achsrichtungs-Tasten möglich. Dazu muss die Funktion „Bearbeitungsebene schwenken“ in Manueller Betrieb aktiv sein, siehe Manuelles Schwenken aktivieren. Die TNC interpoliert dann beim Betätigen einer Achsrichtungs-Taste die entsprechenden Achsen.

Achtung Kollisionsgefahr!

Beachten Sie, dass die im Menü eingetragenen Winkelwerte mit den tatsächlichen Winkeln der Schwenkachse übereinstimmen.

Sofern verfügbar, können Sie die Achsen auch in der aktuellen Werkzeugachs-Richtung verfahren (siehe Aktuelle Werkzeugachs-Richtung als aktive Bearbeitungsrichtung setzen (FCL 2-Funktion)).

Achtung Kollisionsgefahr!

Wenn Sie diese Fuktion nutzen, dann müssen Sie bei nicht absoluten Messgeräten die Position der Drehachsen, die die TNC dann in einem Überblendfenster anzeigt, bestätigen. Die angezeigte Position entspricht der letzten, vor dem Auschalten aktiven Position der Drehachsen.

Sofern eine der Beiden zuvor aktiven Funktionen aktiv ist, hat die NC-START-Taste keine Funktion. Die TNC gibt eine entsprechende Fehlermeldung aus.


Ausschalten

Um Datenverluste beim Ausschalten zu vermeiden, müssen Sie das Betriebssystem der TNC gezielt herunterfahren:

  • Betriebsart Manuell wählen

Funktion zum Herunterfahren wählen, nochmal mit Softkey JA bestätigen

Wenn die TNC in einem Überblendfenster den Text Jetzt können Sie ausschalten anzeigt, dürfen Sie die Versorgungsspannung zur TNC unterbrechen

Willkürliches Ausschalten der TNC kann zu Datenverlust führen!

Beachten Sie, dass das Betätigen der END-Taste nach dem Herunterfahren der Steuerung zu einem Neustart der Steuerung führt. Auch das Ausschalten während dem Neustart kann zu Datenverlust führen!


Verfahren der Maschinenachsen

Weitere Informationen:
> Hinweis
> Achse mit den externen Richtungstasten verfahren
> Schrittweises Positionieren
> Verfahren mit elektronischen Handrädern


Hinweis

Das Verfahren mit den externen Richtungstasten ist maschinenabhängig. Maschinenhandbuch beachten!


Achse mit den externen Richtungstasten verfahren

Betriebsart Manueller Betrieb wählen

Externe Richtungstaste drücken und halten, solange Achse verfahren soll, oder

Achse kontinuierlich verfahren: Externe Richtungstaste gedrückt halten und externe START-Taste kurz drücken

Anhalten: Externe STOPP-Taste drücken

Mit beiden Methoden können Sie auch mehrere Achsen gleichzeitig verfahren. Den Vorschub, mit dem die Achsen verfahren, ändern Sie über den Softkey F, siehe Spindeldrehzahl S, Vorschub F und Zusatzfunktion M.


Schrittweises Positionieren

Beim schrittweisen Positionieren verfährt die TNC eine Maschinenachse um ein von Ihnen festgelegtes Schrittmaß.

 | Betriebsart Manuell oder El. Handrad wählen
 | Softkey-Leiste umschalten
 | Schrittweises Positionieren wählen: Softkey SCHRITTMASS auf EIN
Zustellung =
 | Zustellung in mm eingeben, mit Taste ent bestätigen
 | Externe Richtungstaste drücken: beliebig oft positionieren

Der maximal eingebbare Wert für eine Zustellung beträgt 10 mm.


Verfahren mit elektronischen Handrädern

    Die iTNC unterstützt das Verfahren mit folgenden neuen elektronischen Handrädern:

  • HR 520:
    Anschlusskompatibles Handrad zum HR 420 mit Display, Datenübertragung per Kabel
  • HR 550 FS:
    Handrad mit Display, Datenübertragung per Funk

Darüber hinaus unterstützt die TNC weiterhin die Kabelhandräder HR 410 (ohne Display) und HR 420 (mit Display).

Achtung, Gefahr für Bediener und Handrad!

Alle Verbindungsstecker des Handrads dürfen nur von autorisiertem Service-Personal entfernt werden, auch wenn dies ohne Werkzeug möglich ist!

Maschine grundsätzlich nur mit angestecktem Handrad einschalten!

Wenn Sie Ihre Maschine bei nicht angestecktem Handrad betreiben wollen, dann Kabel von der Maschine abstecken und die offene Buchse mit einer Kappe sichern!

Ihr Maschinenhersteller kann zusätzliche Funktionen für die Handräder HR 5xx zur Verfügung stellen. Maschinen-Handbuch beachten

Ein Handrad HR 5xx ist empfehlenswert, wenn Sie die Funktion Handradüberlagerung in virtueller Achse einsetzen wollen (siehe Virtuelle Achse VT).

Die tragbaren Handräder HR 5xx sind mit einem Display ausgestattet, auf dem die TNC verschiedene Informationen anzeigt. Darüber hinaus können Sie über die Handrad-Softkeys wichtige Einrichte-Funktionen ausführen, z.B. Bezugspunkte setzen oder M-Funktionen eingeben und abarbeiten.

Sobald Sie das Handrad über die Handrad-Aktivierungstaste aktiviert haben, ist keine Bedienung über das Bedienpult mehr möglich. Die TNC zeigt diesen Zustand am TNC-Bildschirm durch ein Überblendfenster an.

Die Handräder HR 5xx verfügen über folgende Bedienelemente:

1 | NOT-AUS-Taste
2 | Handrad-Display zur Status-Anzeige und Auswahl von Funktionen, weitere Informationen dazu: Siehe Handrad-Display
3 | Softkeys
4 | Achswahltasten, können vom Maschinenhersteller entsprechend der Achskonfiguration getauscht werden
5 | Zustimmtaste
6 | Pfeiltasten zur Definition der Handrad-Empfindlichkeit
7 | Handrad-Aktivierungstaste
8 | Richtungstaste, in die die TNC die gewählte Achse verfährt
9 | Eilgangüberlagerung für Richtungstaste
10 | Spindel einschalten (maschinenabhängige Funktion, Taste vom Maschinenhersteller tauschbar)
11 | Taste „NC-Satz generieren“ (maschinenabhängige Funktion, Taste vom Maschinenhersteller tauschbar)
12 | Spindel ausschalten (maschinenabhängige Funktion, Taste vom Maschinenhersteller tauschbar)
13 | CTRL-Taste für Sonderfunktionen (maschinenabhängige Funktion, Taste vom Maschinenhersteller tauschbar)
14 | NC-Start (maschinenabhängige Funktion, Taste vom Maschinenhersteller tauschbar)
15 | NC-Stopp (maschinenabhängige Funktion, Taste vom Maschinenhersteller tauschbar)
16 | Handrad
17 | Spindeldrehzahl-Potentiometer
18 | Vorschub-Potentiometer
19 | Kabelanschluss, entfällt bei Funkhandrad HR 550 FS
Weitere Informationen:
> Handrad-Display
> Besonderheiten des Funkhandrades HR 550 FS
> Zu verfahrende Achse wählen
> Handrad-Empfindlichkeit einstellen
> Achsen verfahren
> Potentiometer-Einstellungen
> Schrittweise positionieren
> Zusatz-Funktionen M eingeben
> Spindeldrehzahl S eingeben
> Vorschub F eingeben
> Bezugspunkt setzen
> Betriebsarten wechseln
> Kompletten L-Satz erzeugen
> Funktionen in den Programmlauf-Betriebsarten


Handrad-Display

Das Handrad-Display (siehe Bild) besteht aus einer Kopfzeile und 6 Statuszeilen, in denen die TNC folgende Informationen anzeigt:

1 | Nur beim Funkhandrad HR 550 FS: Anzeige, ob Handrad in der Docking-Station liegt oder ob Funkbetrieb aktiv ist
2 | Nur beim Funkhandrad HR 550 FS: Anzeige der Feldstärke, 6 Balken = maximale Feldstärke
3 | Nur beim Funkhandrad HR 550 FS: Ladezustand des Akkus, 6 Balken = maximaler Ladezustand. Während des Ladevorgangs läuft ein Balken von links nach rechts
4 | IST: Art der Positionsanzeige
5 | Y+129.9788: Position der gewählten Achse
6 | *: STIB (Steuerung in Betrieb); Programmlauf ist gestartet oder Achse ist in Bewegung
7 | S0: Aktuelle Spindeldrehzahl
8 | F0: Aktueller Vorschub, mit dem die gewählte Achse momentan verfahren wird
9 | E: Fehlermeldung steht an
10 | 3D: Funktion Bearbeitungsebene schwenken ist aktiv
11 | 2D: Funktion Grunddrehung ist aktiv
12 | RES 5.0: Aktive Handrad-Auflösung. Weg in mm/Umdrehung (°/Umdrehung bei Drehachsen), den die gewählte Achse bei einer Handradumdrehung verfährt
13 | STEP ON bzw. OFF: Schrittweises Positionieren aktiv bzw. inaktiv. Bei aktiver Funktion zeigt die TNC zusätzlich den aktiven Verfahrschritt an
14 | Softkey-Leiste: Auswahl verschiedener Funktionen, Beschreibung in den nachfolgenden Abschnitten


Besonderheiten des Funkhandrades HR 550 FS

Eine Funkverbindung besitzt aufgrund vieler möglicher Störeinflüsse nicht die gleiche Verfügbarkeit wie eine leitungsgebundene Verbindung. Bevor Sie das Funkhandrad einsetzen ist daher zu prüfen, ob Störungen mit anderen, im Umfeld der Maschine vorhandenen, Funkteilnehmer bestehen. Diese Prüfung in Bezug auf vorhandene Funkfrequenzen, bzw. -kanäle, empfiehlt sich für alle industriellen Funksysteme.

Wenn Sie das HR 550 nicht verwenden, setzen sie es immer in die dafür vorgesehene Handrad-Aufnahme. Dadurch stellen Sie sicher, das über die Kontaktleiste auf der Rückseite des Funkhandrads eine stete Einsatzbereitschaft der Handrad-Akkus durch eine Laderegelung und eine direkte Kontaktverbindung für den Not-Aus-Kreis gewährleistet ist.

Das Funkhandrad reagiert im Fehlerfall (Funkunterbrechung, schlechte Empfangsqualität, Defekt einer Handrad-Komponente) immer mit einer Not-Aus-Reaktion.

Beachten Sie die Hinweise zur Konfiguration des Funkhandrades HR 550 FS (siehe Funkhandrad HR 550 FS konfigurieren)

Achtung, Gefahr für Bediener und Maschine!

Aus Sicherheitsgründen müssen Sie das Funkhandrad und die Handradaufnahme spätestens nach einer Betriebsdauer von 120 Stunden ausschalten, damit die TNC beim Wiedereinschalten einen Funktionstest ausführen kann!

Wenn Sie in Ihrer Werkstatt mehrere Maschinen mit Funkhandrädern betreiben, müssen Sie die zusammengehörenden Handräder und Handradaufnahmen so markieren, dass diese eindeutig als zusammengehörig erkennbar sind (z.B. durch Farbaufkleber oder Nummerierung). Die Markierungen müssen am Funkhandrad und an der Handradaufnahme für den Bediener eindeutig sichtbar angebracht sein!

Prüfen Sie vor jeder Verwendung, ob das richtige Funkhandrad für Ihre Maschine aktiv ist!

Das Funkhandrad HR 550 FS ist mit einem Akku ausgestattet. Der Akku wird geladen, sobald Sie das Handrad in die Handrad-Aufnahme (siehe Bild) eingelegt haben.

Sie können das HR 550 FS mit dem Akku bis zu 8 Stunden betreiben, bevor Sie es wieder aufladen müssen. Es empfiehlt sich jedoch das Handrad grundsätzlich in die Handrad-Aufnahme zu legen, wenn Sie es nicht benützen.

Sobald das Handrad in der Handrad-Aufnahme liegt, schaltet es intern auf Kabelbetrieb um. Dadurch können Sie das Handrad auch verwenden, wenn es vollständig entladen wäre. Die Funktionalität ist dabei identisch zum Funkbetrieb.

Wenn das Handrad vollständig entladen ist, dauert es ca. 3 Stunden, bis es in der Handrad-Aufnahme wieder voll aufgeladen ist.

Reinigen Sie die Kontakte 1 der Handrad-Aufnahme und des Handrades regelmäßig, um deren Funktion sicherzustellen.

Der Übertragungsbereich der Funkstrecke ist großzügig bemessen. Sollte es dennoch vorkommen, dass Sie – z.B. bei sehr großen Maschinen – an den Rand der Übertragungstrecke kommen, warnt Sie das HR 550 FS rechtzeitig durch einen sicher bemerkbaren Vibrationsalarm. In diesem Fall müssen Sie den Abstand zur Handrad-Aufnahme, in der der Funkempfänger integriert ist, wieder verringern.

Achtung, Gefahr für Werkzeug und Werkstück!

Wenn die Funkstrecke keinen unterbrechungsfreien Betrieb mehr zulässt, löst die TNC automatisch einen NOT-AUS aus. Dies kann auch während der Bearbeitung passieren. Abstand zur Handrad-Aufnahme möglichst gering halten und das Handrad in die Handrad-Aufnahme legen, wenn Sie es nicht verwenden!

Wenn die TNC einen NOT-AUS ausgelöst hat, müssen Sie das Handrad wieder neu aktivieren. Gehen Sie dabei wie folgt vor:

  • Betriebsart Programm-Einspeichern/Editieren wählen

  • MOD-Funktion wählen: Taste MOD drücken

  • Softkey-Leiste weiterschalten

Konfigurationsmenü für Funkhandrad wählen: Softkey funkhandrad einrichten drücken

Über die Schaltfläche Handrad starten das Funkhandrad wieder aktivieren

Konfiguration speichern und Konfigurationsmenü verlassen: Schaltfläche ENDE drücken

Für die Inbetriebnahme und Konfiguration des Handrades steht in der Betriebsart MOD eine entsprechende Funktion zur Verfügung (siehe Funkhandrad HR 550 FS konfigurieren).


Zu verfahrende Achse wählen

Die Hauptachsen X, Y und Z, sowie drei weitere, vom Maschinenhersteller definierbare Achsen, können Sie direkt über die Achswahltasten aktivieren. Auch die virtuelle Achse VT kann Ihr Maschinenhersteller direkt auf eine der freien Achstasten legen. Liegt die virtuelle Achse VT nicht auf einer Achswahltaste, gehen Sie wie folgt vor:

  • Handrad-Softkey F1 (AX) drücken: Die TNC zeigt auf dem Handrad-Display alle aktiven Achsen an. Die momentan aktive Achse blinkt

  • Gewünschte Achse, z.B. die Achse VT, mit Handrad-Softkeys F1 (->) oder F2 (<-) wählen und mit Handrad-Softkey F3 (OK) bestätigen


Handrad-Empfindlichkeit einstellen

Die Handrad-Empfindlichkeit legt fest, welchen Weg eine Achse pro Handrad-Umdrehung verfahren soll. Die definierbaren Empfindlichkeiten sind fest eingestellt und über die Handrad-Pfeiltasten direkt wählbar (nur wenn Schrittmaß nicht aktiv ist).

Einstellbare Empfindlichkeiten: 0.01/0.02/0.05/0.1/0.2/0.5/1/2/5/10/20 [mm/Umdrehung bzw. Grad/Umdrehung]


Achsen verfahren
 | Handrad aktiveren: Handrad-Taste auf dem HR 5xx drücken: Sie können die TNC jetzt nur noch über das HR 5xx bedienen, die TNC zeigt ein Überblendfenster mit Hinweistext am TNC-Bildschirm an
Ggf. über Softkey opm die gewünschte Betriebsart wählen (siehe Betriebsarten wechseln)
 | Ggf. Zustimmtasten gedrückt halten
 | Auf dem Handrad die Achse wählen, die Sie verfahren wollen. Zusatz-Achsen ggf. über Softkeys wählen
 | Aktive Achse in Richtung + verfahren, oder
 | Aktive Achse in Richtung – verfahren
 | Handrad deaktiveren: Handrad-Taste auf dem HR 5xx drücken: Sie können die TNC jetzt wieder über das Bedienfeld bedienen


Potentiometer-Einstellungen

Nachdem Sie das Handrad aktiviert haben, sind weiterhin die Potentiometer des Maschinen-Bedienfeldes aktiv. Wenn Sie die Potentiometer am Handrad nutzen wollen, gehen Sie wie folgt vor:

  • Tasten Ctrl und Handrad am HR 5xx drücken, die TNC zeigt im Handrad-Display das Softkey-Menü zur Potentiometer-Auswahl an

  • Softkey HW drücken, um die Handrad-Potentiometer aktiv zu schalten

Sobald Sie die Handrad-Potentiometer aktiviert haben, müssen Sie vor der Abwahl des Handrades die Potentiometer des Maschinen-Bedienfeldes wieder aktivieren. Gehen Sie wie folgt vor:

  • Tasten CTRL und Handrad am HR 5xx drücken, die TNC zeigt im Handrad-Display das Softkey-Menü zur Potentiometer-Auswahl an

  • Softkey KBD drücken, um die Potentiometer auf dem Maschinen-Bedienfeld aktiv zu schalten


Schrittweise positionieren

Beim schrittweisen Positionieren verfährt die TNC die momentan aktive Handrad-Achse um ein von Ihnen festgelegtes Schrittmaß:

  • Handrad-Softkey F2 (STEP) drücken

  • Schrittweise positionieren aktivieren: Handrad-Softkey 3 (ON) drücken

  • Gewünschtes Schrittmaß durch Drücken der Tasten F1 oder F2 wählen. Wenn Sie die jeweilige Taste gedrückt halten, erhöht die TNC den Zählschritt bei einem Zehnerwechsel jeweils um den Faktor 10. Durch zusätzliches Drücken der Taste Ctrl erhöht sich der Zählschritt auf 1. Kleinstmögliches Schrittmaß ist 0.0001 mm, größtmögliches Schrittmaß ist 10 mm

  • Gewähltes Schrittmaß mit Softkey 4 (OK) übernehmen

  • Mit Handrad-Taste + bzw. – die aktive Handrad-Achse in die entsprechende Richtung verfahren


Zusatz-Funktionen M eingeben

  • Handrad-Softkey F3 (MSF) drücken

  • Handrad-Softkey F1 (M) drücken

  • Gewünschte M-Funktionsnummer durch Drücken der Tasten F1 oder F2 wählen

  • Zusatz-Funktion M mit Taste NC-Start ausführen


Spindeldrehzahl S eingeben

  • Handrad-Softkey F3 (MSF) drücken

  • Handrad-Softkey F2 (S) drücken

  • Gewünschte Drehzahl durch Drücken der Tasten F1 oder F2 wählen. Wenn Sie die jeweilige Taste gedrückt halten, erhöht die TNC den Zählschritt bei einem Zehnerwechsel jeweils um den Faktor 10. Durch zusätzliches Drücken der Taste Ctrl erhöht sich der Zählschritt auf 1000

  • Neue Drehzahl S mit Taste NC-Start aktivieren


Vorschub F eingeben

  • Handrad-Softkey F3 (MSF) drücken

  • Handrad-Softkey F3 (F) drücken

  • Gewünschten Vorschub durch Drücken der Tasten F1 oder F2 wählen. Wenn Sie die jeweilige Taste gedrückt halten, erhöht die TNC den Zählschritt bei einem Zehnerwechsel jeweils um den Faktor 10. Durch zusätzliches Drücken der Taste Ctrl erhöht sich der Zählschritt auf 1000

  • Neuen Vorschub F mit Handrad-Softkey F3 (OK) übernehmen


Bezugspunkt setzen

  • Handrad-Softkey F3 (MSF) drücken

  • Handrad-Softkey F4 (PRS) drücken

  • Ggf. Achse wählen, in der der Bezugspunkt gesetzt werden soll

  • Achse mit Handrad-Softkey F3 (OK) abnullen, oder mit Handrad-Softkeys F1 und F2 gewünschten Wert einstellen und dann mit Handrad-Softkey F3 (OK) übernehmen. Durch zusätzliches Drücken der Taste Ctrl erhöht sich der Zählschritt auf 10


Betriebsarten wechseln

Über den Handrad-Softkey F4 (OPM) können Sie vom Handrad aus die Betriebsart umschalten, sofern der aktuelle Zustand der Steuerung ein Umschalten erlaubt.

  • Handrad-Softkey F4 (OPM) drücken

  • Über Handrad-Softkeys gewünschte Betriebsart wählen

    • MAN: Manueller Betrieb
    • MDI: Positionieren mit Handeingabe
    • SGL: Programmlauf Einzelsatz
    • RUN: Programmlauf Satzfolge


Kompletten L-Satz erzeugen

Ihr Maschinenhersteller kann die Handradtaste „NC-Satz generieren“ mit einer beliebigen Funktion belegen, Maschinenhandbuch beachten.

Über die MOD-Funktion die Achswerte definieren, die in einen NC-Satz übernommen werden sollen (siehe Achsauswahl für G01-Satz-Generierung).

Sind keine Achsen ausgewählt, zeigt die TNC die Fehlermeldung Keine Achsauswahl vorhanden an

  • Betriebsart Positionieren mit Handeingabe wählen

  • Ggf. mit den Pfeiltasten auf der TNC-Tastatur den NC-Satz wählen, hinter den Sie den neuen L-Satz einfügen wollen

  • Handrad aktivieren

  • Handrad-Taste „NC-Satz generieren“ drücken: Die TNC fügt einen kompletten L-Satz ein, der alle über die MOD-Funktion ausgewählten Achspositionen enthält


Funktionen in den Programmlauf-Betriebsarten

In den Programmlauf-Betriebsarten können Sie folgende Funktionen ausführen:

  • NC-Start (Handrad-Taste NC-Start)
  • NC-Stopp (Handrad-Taste NC-Stopp)
  • Wenn Sie NC-Stopp betätigt haben: Interner Stopp (Handrad-Softkeys MOP und dann Stopp)
  • Wenn Sie NC-Stopp betätigt haben: Manuell Achsen verfahren (Handrad-Softkeys MOP und dann MAN)
  • Wiederanfahren an die Kontur, nachdem Achsen während einer Programm-Unterbrechung manuell verfahren wurden (Handrad-Softkeys MOP und dann REPO). Die Bedienung erfolgt per Handrad-Softkeys, wie über die Bildschirm-Softkeys (siehe Wiederanfahren an die Kontur)
  • Ein-/Ausschalten der Funktion Bearbeitungsebene schwenken (Handrad-Softkeys MOP und dann 3D)


Spindeldrehzahl S, Vorschub F und Zusatzfunktion M

Weitere Informationen:
> Anwendung
> Werte eingeben
> Spindeldrehzahl und Vorschub ändern


Anwendung

In den Betriebsarten Manueller Betrieb und El. Handrad geben Sie Spindeldrehzahl S, Vorschub F und Zusatzfunktion M über Softkeys ein. Die Zusatzfunktionen sind in „7. Programmieren: Zusatzfunktionen“ beschrieben.

Der Maschinenhersteller legt fest, welche Zusatzfunktionen M Sie nutzen können und welche Funktion sie haben.


Werte eingeben

Spindeldrehzahl S, Zusatzfunktion M

 | Eingabe für Spindeldrehzahl wählen: Softkey S
Spindeldrehzahl S=
 | Spindeldrehzahl eingeben und mit der externen START-Taste übernehmen

Die Spindeldrehung mit der eingegebenen Drehzahl S starten Sie mit einer Zusatzfunktion M. Eine Zusatzfunktion M geben Sie auf die gleiche Weise ein.

Vorschub F

Die Eingabe eines Vorschub F müssen Sie anstelle mit der externen START-Taste mit der Taste ENT bestätigen.

    Für den Vorschub F gilt:

  • Wenn F=0 eingegeben, dann wirkt der kleinste Vorschub aus MP1020
  • F bleibt auch nach einer Stromunterbrechung erhalten


Spindeldrehzahl und Vorschub ändern

Mit den Override-Drehknöpfen für Spindeldrehzahl S und Vorschub F lässt sich der eingestellte Wert von 0% bis 150% ändern.

Der Override-Drehknopf für die Spindeldrehzahl wirkt nur bei Maschinen mit stufenlosem Spindelantrieb.


Funktionale Sicherheit FS (Option)

Weitere Informationen:
> Allgemeines
> Begriffserklärungen
> Achspositionen prüfen
> Übersicht über erlaubte Vorschübe und Drehzahlen
> Vorschubbegrenzung aktivieren
> Zusätzliche Status-Anzeigen


Allgemeines

Jeder Bediener einer Werkzeugmaschine ist Gefahren ausgesetzt. Schutzeinrichtungen können zwar den Zugriff zu Gefahrenstellen verhindern, andererseits muss der Bediener aber auch ohne Schutzeinrichtung (z.B. bei geöffneter Schutztüre) an der Maschine arbeiten können. Um diese Gefahren zu minimieren, wurden in den letzten Jahren verschiedene Richtlinien und Vorschriften erarbeitet.

Das HEIDENHAIN-Sicherheitskonzept, das in die TNC-Steuerungen integriert wurde, entspricht dem Performance-Level d gemäß EN 13849-1 und SIL 2 nach IEC 61508, bietet sicherheitsbezogene Betriebsarten entsprechend der EN 12417 und gewährleistet einen weitreichenden Personenschutz.

Grundlage des HEIDENHAIN-Sicherheitskonzepts ist die zweikanalige Prozessorstruktur, die aus dem Hauptrechner MC (main computing unit) und einem oder mehreren Antriebsregelmodulen CC (control computing unit) besteht. Alle Überwachungsmechanismen werden redundant in den Steuerungssystemen angelegt. Sicherheitsrelevante Systemdaten unterliegen einem wechselseitigen zyklischen Datenvergleich. Sicherheitsrelevante Fehler führen immer über definierte Stopp-Reaktionen zu einem sicheren Stillsetzen aller Antriebe.

Über sicherheitsbezogene Ein- und Ausgänge (zweikanalig ausgeführt), die in allen Betriebsarten auf den Prozeß Einfluß nehmen, löst die TNC bestimmte Sicherheitsfunktionen aus und erreicht sichere Betriebszustände.

In diesem Kapitel finden Sie Erklärungen zu den Funktionen, die bei einer TNC mit Funktionaler Sicherheit zusätzlich zur Verfügung stehen.

Ihr Maschinenhersteller passt das HEIDENHAIN-Sicherheitskonzept an Ihre Maschine an. Maschinenhandbuch beachten!


Begriffserklärungen

Sicherheitsbezogene Betriebsarten:

Bezeichnung | Kurzbeschreibung
SOM_1 | Safe operating mode 1: Automatikbetrieb, Produktionsbetrieb
SOM_2 | Safe operating mode 2: Einrichtebetrieb
SOM_3 | Safe operating mode 3: Manuelles Eingreifen, nur für qualifizierte Bediener
SOM_4 | Safe operating mode 4: Erweitertes manuelles Eingreifen, Prozessbeobachtung

Sicherheitsfunktionen

Bezeichnung | Kurzbeschreibung
SS0, SS1, SS1F, SS2 | Safe stop: Sicherers Stillsetzen der Antriebe auf unterschiedliche Arten.
STO | Safe torque off: Energieversorgung zum Motor ist unterbrochen. Bietet Schutz gegen unerwartetes Anlaufen der Antriebe
SOS | Safe operating Stop: Sicherer Betriebshalt. Bietet Schutz gegen unerwartetes Anlaufen der Antriebe
SLS | Safety-limited-speed: Sicher begrenzte Geschwindigkeit. Verhindert, dass die Antriebe bei geöffneter Schutztür vorgegebene Geschwindigkeitsgrenzwerte überschreiten


Achspositionen prüfen

Diese Funktion muss von Ihrem Maschinenhersteller an die TNC angepasst werden. Maschinenhandbuch beachten!

Nach dem Einschalten prüft die TNC, ob die Position einer Achse mit der Position direkt nach dem Ausschalten übereinstimmt. Tritt eine Abweichung auf, kennzeichnet die TNC diese Achse in der Positions-Anzeige mit einem Warndreieck hinter dem Positionswert. Achsen, die mit dem Warndreieck gekennzeichnet sind, können Sie bei geöffneter Tür nicht mehr verfahren.

In solchen Fällen müssen Sie für die entsprechenden Achsen eine Prüfposition anfahren. Gehen Sie dabei wie folgt vor:

  • Betriebsart Manueller Betrieb wählen

  • Softkey-Leiste weiterschalten, bis Sie eine Leiste sehen auf der alle Achsen aufgelistet sind, die Sie auf die Prüfposition fahren müssen

  • Per Softkey eine Achse wählen, die Sie auf die Prüfposition fahren wollen

Achtung Kollisionsgefahr!

Die Prüfpositionen so nacheinander anfahren, dass keine Kollision mit dem Werkstück oder mit Spannmitteln entstehen kann! Ggf. Achsen manuell entsprechend vorpositionieren!

  • Anfahrvorgang mit NC-Start ausführen

  • Nachdem die Prüfposition erreicht ist, fragt die TNC nach, ob die Prüfposition richtig angefahren wurde: Mit Softkey JA bestätigen wenn die TNC die Prüfposition richtig angefahren hat, mit Softkey NEIN bestätigen, wenn die TNC die Prüfposition falsch angefahren hat

  • Wenn Sie mit Softkey JA bestätigt haben, dann müssen Sie mit der Zustimmtaste auf dem Maschinenbedienfeld die Richtigkeit der Prüfposition erneut bestätigen

  • Den zuvor beschriebenen Vorgang für alle Achsen, die Sie auf die Prüfposition fahren wollen, wiederholen

Wo sich die Prüfposition befindet, legt Ihr Maschinenhersteller fest. Maschinenhandbuch beachten!


Übersicht über erlaubte Vorschübe und Drehzahlen

Die TNC stellt eine Übersicht zur Verfügung, in der die erlaubten Drehzahlen und Vorschübe für alle Achsen in Abhängigkeit zur aktiven Betriebsart dargestellt sind.

Betriebsart Manueller Betrieb wählen

Auf letzte Softkey-Leiste weiterschalten

Softkey INFO SOM drücken: Die TNC öffnet das Übersichtsfenster für erlaubte Drehzahlen und Vorschübe

Spalte | Bedeutung
SLS2 | Sicher reduzierte Geschwindikeiten in der sicherheitsbezogenen Betriebsart 2 (SOM_2) für die jeweiligen Achsen
SLS3 | Sicher reduzierte Geschwindikeiten in der sicherheitsbezogenen Betriebsart 3 (SOM_3) für die jeweiligen Achsen
SLS4 | Sicher reduzierte Geschwindikeiten in der sicherheitsbezogenen Betriebsart 4 (SOM_4) für die jeweiligen Achsen


Vorschubbegrenzung aktivieren

Die TNC limitiert beim Setzen des Softkey F LIMITIERT auf EIN die maximal zugelassene Geschwindigkeit der Achsen auf die festgelegte, sicher begrenzte Geschwindigkeit. Die für die aktive Betriebsart gültigen Geschwindigkeiten entnehmen Sie bitte der Tabelle Safety-MP (siehe Übersicht über erlaubte Vorschübe und Drehzahlen).

Betriebsart Manueller Betrieb wählen

Auf letzte Softkey-Leiste weiterschalten

Vorschublimit ein- oder ausschalten


Zusätzliche Status-Anzeigen

Bei einer Steuerung mit Funktionaler Sicherheit FS enthält die allgemeine Status-Anzeige zusätzliche Informationen in Bezug auf den aktuellen Status von Sicherheitsfunktionen. Diese Informationen zeigt die TNC in Form von Betriebszuständen zu den Status-Anzeigen T, S und F an.

Status-Anzeige | Kurzbeschreibung
STO | Energieversorgung zur Spindel oder zu einem Vorschubantrieb ist unterbrochen
SLS | Safety-limited-speed: Eine sicher reduzierte Geschwindigkeit ist aktiv
SOS | Safe operating Stop: Sicherer Betriebshalt ist aktiv
STO | Safe torque off: Energieversorgung zum Motor ist unterbrochen

Die aktive sicherheitsbezogene Betriebsart zeigt die TNC mit einem Icon in der Kopfzeile rechts neben dem Betriebsartentext an. Ist die Betriebsart SOM_1 aktiv, dann zeigt die TNC kein Icon an.

Icon | Sicherheitsbezogene Betriebsart
 | Betriebsart SOM_2 aktiv
 | Betriebsart SOM_3 aktiv
 | Betriebsart SOM_4 aktiv


Bezugspunkt-Setzen ohne Tastsystem

Weitere Informationen:
> Hinweis
> Vorbereitung
> Bezugspunkt setzen mit Achstasten
> Bezugspunkt-Verwaltung mit der Bezugspunkt-Tabelle


Hinweis

Bezugspunkt-Setzen mit Tastsystem: Bezugspunkt-Setzen mit Tastsystem.

Beim Bezugspunkt-Setzen setzen Sie die Anzeige der TNC auf die Koordinaten einer bekannten Werkstück-Position.


Vorbereitung

  • Werkstück aufspannen und ausrichten

  • Nullwerkzeug mit bekanntem Radius einwechseln

  • Sicherstellen, dass die TNC Ist-Positionen anzeigt


Bezugspunkt setzen mit Achstasten

Schutzmaßnahme

Falls die Werkstück-Oberfläche nicht angekratzt werden darf, wird auf das Werkstück ein Blech bekannter Dicke d gelegt. Für den Bezugspunkt geben Sie dann einen um d größeren Wert ein.

 | Betriebsart Manueller Betrieb wählen
 | Werkzeug vorsichtig verfahren, bis es das Werkstück berührt (ankratzt)
 | Achse wählen (alle Achsen sind auch über die ASCII-Tastatur wählbar)
Bezugspunkt-Setzen Z=
 | Nullwerkzeug, Spindelachse: Anzeige auf bekannte Werkstück-Position (z.B. 0) setzen oder Dicke d des Blechs eingeben. In der Bearbeitungsebene: Werkzeug-Radius berücksichtigen

Die Bezugspunkte für die verbleibenden Achsen setzen Sie auf die gleiche Weise.

Wenn Sie in der Zustellachse ein voreingestelltes Werkzeug verwenden, dann setzen Sie die Anzeige der Zustellachse auf die Länge L des Werkzeugs bzw. auf die Summe Z=L+d.


Bezugspunkt-Verwaltung mit der Bezugspunkt-Tabelle

Die Bezugspunkt-Verwaltung sollten Sie unbedingt verwenden, wenn

  • Ihre Maschine mit Drehachsen (Schwenktisch oder Schwenkkopf) ausgerüstet ist und Sie mit der Funktion Bearbeitungsebene schwenken arbeiten
  • Ihre Maschine mit einem Kopfwechsel-System ausgerüstet ist
  • Sie bisher an älteren TNC-Steuerungen mit REF-bezogenen Nullpunkt-Tabellen gearbeitet haben
  • Sie mehrere gleiche Werkstücke bearbeiten wollen, die mit unterschiedlicher Schieflage aufgespannt sind

Die Bezugspunkt-Tabelle darf beliebig viele Zeilen (Bezugspunkte) enthalten. Um die Dateigröße und die Verarbeitungs-Geschwindigkeit zu optimieren, sollten Sie nur so viele Zeilen verwenden, wie Sie für Ihre Bezugspunkt-Verwaltung auch benötigen.

Neue Zeilen können Sie aus Sicherheitsgründen nur am Ende der Bezugspunkt-Tabelle einfügen.

Wenn Sie über die MOD-Funktion die Positions-Anzeige auf INCH umstellen, zeigt die TNC auch die gespeicherten Bezugspunkt-Koordinaten in inch an.

Über den Maschinen-Parameter 7268.x können Sie die Spalten in der Bezugspunkt-Tabelle beliebig anordnen und bei Bedarf auch ausblenden Liste der allgemeinen Anwenderparameter.

Weitere Informationen:
> Bezugspunkte in der Bezugspunkt-Tabelle speichern
> Bezugspunkte manuell in der Bezugspunkt-Tabelle speichern
> Bezugspunkt-Tabelle editieren
> Bezugspunkt aus der Bezugspunkt-Tabelle in der Betriebsart Manuell aktivieren
> Bezugspunkt aus der Bezugspunkt-Tabelle in einem NC-Programm aktivieren


Bezugspunkte in der Bezugspunkt-Tabelle speichern

Die Bezugspunkt-Tabelle hat den Namen PRESET.PR und ist im Verzeichnis TNC:\ gespeichert. PRESET.PR ist nur in der Betriebsart Manuell und El. Handrad editierbar. In der Betriebsart Programm-Einspeichern/Editieren können Sie die Tabelle nur lesen, nicht jedoch verändern.

Das Kopieren der Bezugspunkt-Tabelle in ein anderes Verzeichnis (zur Datensicherung) ist erlaubt. Zeilen, die von Ihrem Maschinenhersteller schreibgeschützt wurden, sind auch in den kopierten Tabellen grundsätzlich schreibgeschützt, können also von Ihnen nicht verändert werden.

Verändern Sie in den kopierten Tabellen die Anzahl der Zeilen grundsätzlich nicht! Dies könnte zu Problemen führen, wenn Sie die Tabelle wieder aktivieren wollen.

Um die in ein anderes Verzeichnis kopierte Bezugspunkt-Tabelle zu aktivieren, müssen Sie diese wieder in das Verzeichnis TNC:\ zurückkopieren.

    Sie haben mehrere Möglichkeiten, Bezugspunkte/Grunddrehungen in der Bezugspunkt-Tabelle zu speichern:

  • Über Antast-Zyklen in der Betriebsart Manuell bzw. El. Handrad (siehe Kapitel 14)Über die Antast-Zyklen 400 bis 402 und 410 bis 419 im Automatik-Betrieb (siehe Benutzer-Handbuch Zyklen, Kapitel 14 und 15)Manuelles eintragen (siehe nachfolgende Beschreibung)

Grunddrehungen aus der Bezugspunkt-Tabelle drehen das Koordinatensystem um den Bezugspunkt, der in derselben Zeile steht wie die Grunddrehung.

Die TNC prüft beim Setzen des Bezugspunktes, ob die Position der Schwenkachsen mit den entsprechenden Werten des 3D ROT-Menüs übereinstimmt (abhängig von einer Einstellung in der Kinematik-Tabelle). Daraus folgt:

  • Bei inaktiver Funktion Bearbeitungsebene Schwenken muss die Positionsanzeige der Drehachsen = 0° sein (ggf. Drehachsen abnullen)
  • Bei aktiver Funktion Bearbeitungsebene Schwenken müssen die Positionsanzeigen der Drehachsen und die eingetragenen Winkel im 3D ROT-Menü übereinstimmen

Ihr Maschinenhersteller kann beliebige Zeilen der Bezugspunkt-Tabelle sperren, um darin feste Bezugspunkte abzulegen (z.B. einen Rundtisch-Mittelpunkt). Solche Zeilen sind in der Bezugspunkt-Tabelle andersfarbig markiert (Standardmarkierung ist rot).

Die Zeile 0 in der Bezugspunkt-Tabelle ist grundsätzlich schreibgeschützt. Die TNC speichert in der Zeile 0 immer den Bezugspunkt, den Sie zuletzt manuell über die Achstasten oder per Softkey gesetzt haben. Ist der manuell gesetzte Bezugspunkt aktiv, zeigt die TNC in der Status-Anzeige den Text MAN(0) an

Wenn Sie mit den Tastsystem-Zyklen zum Bezugspunkt-Setzen automatisch die TNC-Anzeige setzen, dann speichert die TNC diese Werte nicht in der Zeile 0.

Achtung Kollisionsgefahr!

Beachten Sie, dass beim Verschieben eines Teilapparates auf Ihrem Maschinentisch (realisiert durch Veränderung der Kinematik-Beschreibung) ggf. auch Bezugspunkte verschoben werden, die nicht direkt mit dem Teilapparat zusammenhängen.


Bezugspunkte manuell in der Bezugspunkt-Tabelle speichern

Um Bezugspunkte in der Bezugspunkt-Tabelle speichern zu können, gehen Sie wie folgt vor

Betriebsart Manueller Betrieb wählen

Werkzeug vorsichtig verfahren, bis es das Werkstück berührt (ankratzt), oder Messuhr entsprechend positionieren

Bezugspunkt-Verwaltung aufrufen: Die TNC öffnet die Bezugspunkt-Tabelle und setzt den Cursor auf die aktive Tabellenzeile

Funktionen zur Bezugspunkt-Eingabe wählen: Die TNC zeigt in der Softkey-Leiste die verfügbaren Eingabemöglichkeiten an. Beschreibung der Eingabemöglichkeiten: siehe nachfolgende Tabelle

Zeile in der Bezugspunkt-Tabelle wählen, die Sie ändern wollen (Zeilennummer entspricht der Bezugspunkt-Nummer)

Ggf. Spalte (Achse) in der Bezugspunkt-Tabelle wählen, die Sie ändern wollen

Per Softkey eine der verfügbaren Eingabemöglichkeiten wählen (siehe nachfolgende Tabelle)

Funktion | Softkey
Die Ist-Position des Werkzeugs (der Messuhr) als neuen Bezugspunkt direkt übernehmen: Funktion speichert den Bezugspunkt nur in der Achse ab, in der das Hellfeld gerade steht |
Der Ist-Position des Werkzeugs (der Messuhr) einen beliebigen Wert zuweisen: Funktion speichert den Bezugspunkt nur in der Achse ab, in der das Hellfeld gerade steht. Gewünschten Wert im Überblendfenster eingeben |
Einen bereits in der Tabelle gespeicherten Bezugspunkt inkremental verschieben: Funktion speichert den Bezugspunkt nur in der Achse ab, in der das Hellfeld gerade steht. Gewünschten Korrekturwert vorzeichenrichtig im Überblendfenster eingeben. Bei aktiver inch-Anzeige: Wert in inch eingeben, die TNC rechnet intern den eingegebenen Wert nach mm um |
Neuen Bezugspunkt ohne Verrechnung der Kinematik direkt eingeben (achsspezifisch). Diese Funktion nur dann verwenden, wenn Ihre Maschine mit einem Rundtisch ausgerüstet ist und Sie durch direkte Eingabe von 0 den Bezugspunkt in die Rundtisch-Mitte setzen wollen. Funktion speichert den Wert nur in der Achse ab, in der das Hellfeld gerade steht. Gewünschten Wert im Überblendfenster eingeben. Bei aktiver inch-Anzeige: Wert in inch eingeben, die TNC rechnet intern den eingegebenen Wert nach mm um |
Den momentan aktiven Bezugspunkt in eine wählbare Tabellenzeile schreiben: Funktion speichert den Bezugspunkt in allen Achsen ab und aktiviert die jeweilige Tabellenzeile dann automatisch. Bei aktiver inch-Anzeige: Wert in inch eingeben, die TNC rechnet intern den eingegebenen Wert nach mm um |


Bezugspunkt-Tabelle editieren
Editier-Funktion im Tabellenmodus | Softkey
Tabellen-Anfang wählen |
Tabellen-Ende wählen |
Vorherige Tabellen-Seite wählen |
Nächste Tabellen-Seite wählen |
Funktionen zur Bezugspunkt-Eingabe wählen |
Den Bezugspunkt der aktuell angewählten Zeile der Bezugspunkt-Tabelle aktivieren |
Eingebbare Anzahl von Zeilen am Tabellenende anfügen (2. Softkey-Leiste) |
Hell hinterlegtes Feld kopieren 2. Softkey-Leiste) |
Kopiertes Feld einfügen (2. Softkey-Leiste) |
Aktuell angewählte Zeile zurücksetzen: Die TNC trägt in alle Spalten - ein (2. Softkey-Leiste) |
Einzelne Zeile am Tabellen-Ende einfügen (2. Softkey-Leiste) |
Einzelne Zeile am Tabellen-Ende löschen (2. Softkey-Leiste) |


Bezugspunkt aus der Bezugspunkt-Tabelle in der Betriebsart Manuell aktivieren

Achtung Kollisionsgefahr!

Beim Aktivieren eines Bezugspunktes aus der Bezugspunkt-Tabelle, setzt die TNC eine aktive Nullpunkt-Verschiebung zurück.

Eine Koordinaten-Umrechnung die Sie über Zyklus 19, Bearbeitungsebene schwenken oder die PLANE-Funktion programmiert haben, bleibt dagegen aktiv.

Wenn Sie einen Bezugspunkt aktivieren, der nicht in allen Koordinaten Werte enthält, dann bleibt in diesen Achsen der zuletzt wiksame Bezugspunkt aktiv.

Betriebsart Manueller Betrieb wählen

Bezugspunkt-Tabelle anzeigen lassen

Bezugspunkt-Numer wählen, die Sie aktivieren wollen, oder

über die Taste GOTO die Bezugspunkt-Numer wäh-len, die Sie aktivieren wollen, mit der Taste ENT bestätigen

Bezugspunkt aktivieren

Aktivieren des Bezugspunktes bestätigen. Die TNC setzt die Anzeige und – wenn definiert – die Grunddrehung

Bezugspunkt-Tabelle verlassen


Bezugspunkt aus der Bezugspunkt-Tabelle in einem NC-Programm aktivieren

Um Bezugspunkte aus der Bezugspunkt-Tabelle während des Programmlaufs zu aktivieren, benutzen Sie den Zyklus 247. Im Zyklus 247 definieren Sie lediglich die Nummer des Bezugspunktes den Sie aktivieren wollen (siehe Benutzer-Handbuch Zyklen, Zyklus 247 BEZUGSPUNKT-SETZEN).


Tastsystem verwenden

Weitere Informationen:
> Übersicht
> Tastsystem-Zyklus wählen
> Messwerte aus den Tastsystem-Zyklen protokollieren
> Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben
> Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben
> Messwerte in der Paletten-Beugspunkt-Tabelle speichern


Übersicht

Beachten Sie, dass HEIDENHAIN grundsätzlich nur dann die Gewährleistung für die Funktion der Tastsystem-Zyklen übernimmt, wenn Sie HEIDENHAIN-Tastsysteme verwenden!

In der Betriebsart Manueller Betrieb stehen Ihnen folgende Tastsystem-Zyklen zur Verfügung:

Funktion | Softkey | Seite
Wirksame Länge kalibrieren |  | Kalibrieren der wirksamen Länge
Wirksamen Radius kalibrieren |  | Wirksamen Radius kalibrieren und Tastsystem-Mittenversatz ausgleichen
Grunddrehung über eine Gerade ermitteln |  | Grunddrehung über 2 Punkte ermitteln
Bezugspunkt-Setzen in einer wählbaren Achse |  | Bezugspunkt-Setzen in einer beliebigen Achse
Ecke als Bezugspunkt setzen |  | Ecke als Bezugspunkt – Punkte übernehmen, die für Grunddrehung angetastet wurden
Kreismittelpunkt als Bezugspunkt setzen |  | Kreismittelpunkt als Bezugspunkt
Mittelachse als Bezugspunkt setzen |  | Mittelachse als Bezugspunkt
Grunddrehung über zwei Bohrungen/Kreiszapfen ermitteln |  | Bezugspunkte über Bohrungen/Kreiszapfen setzen
Bezugspunkt über vier Bohrungen/Kreiszapfen setzen |  | Bezugspunkte über Bohrungen/Kreiszapfen setzen
Kreismittelpunkt über drei Bohrungen/Zapfen setzen |  | Bezugspunkte über Bohrungen/Kreiszapfen setzen


Tastsystem-Zyklus wählen

  • Betriebsart Manueller Betrieb oder El. Handrad wählen

Antastfunktionen wählen: Softkey ANTAST-FUNKTION drücken. Die TNC zeigt weitere Softkeys: Siehe Tabelle oben

Tastsystem-Zyklus wählen: z.B. Softkey ANTASTEN ROT drücken, die TNC zeigt am Bildschirm das entsprechende Menü an


Messwerte aus den Tastsystem-Zyklen protokollieren

Die TNC muss für diese Funktion vom Maschinenhersteller vorbereitet sein. Maschinenhandbuch beachten!

Nachdem die TNC einen beliebigen Tastsystem-Zyklus ausgeführt hat, zeigt die TNC den Softkey DRUCKEN. Wenn Sie den Softkey betätigen, protokolliert die TNC die aktuellen Werte des aktiven Tastsystem-Zyklus. Über die PRINT-Funktion im Schnittstellen-Konfigurationsmenü (siehe Benutzer-Handbuch, „12 MOD-Funktionen, Datenschnittstelle einrichten“) legen Sie fest, ob die TNC:

  • die Messergebnisse ausdrucken soll
  • die Messergebnisse auf der Festplatte der TNC speichern soll
  • die Messergebnisse auf einem PC speichern soll

Wenn Sie die Messergebnisse speichern, legt die TNC die ASCII-Datei %TCHPRNT.A an. Falls Sie im Schnittstellen-Konfigurationsmenü keinen Pfad und keine Schnittstelle festgelegt haben, speichert die TNC die Datei %TCHPRNT im Haupt-Verzeichnis TNC:\ ab.

Wenn Sie den Softkey DRUCKEN drücken, darf die Datei %TCHPRNT.A in der Betriebsart Programm-Einspeichern/Editieren nicht angewählt sein. Sonst gibt die TNC eine Fehlermeldung aus.

Die TNC schreibt die Messwerte ausschließlich in die Datei %TCHPRNT.A. Wenn Sie mehrere Tastsystem-Zyklen hintereinander ausführen und deren Messwerte speichern wollen, müssen Sie den Inhalt der Datei %TCHPRNT.A zwischen den Tastsystem-Zyklen sichern, indem Sie sie kopieren oder umbenennen.

Format und Inhalt der Datei %TCHPRNT legt Ihr Maschinenhersteller fest.


Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben

Diese Funktion ist nur aktiv, wenn Sie an Ihrer TNC Nullpunkt-Tabellen aktiv haben (Bit 3 im Maschinen-Parameter 7224.0 =0).

Verwenden Sie diese Funktion, wenn Sie Messwerte im Werkstück-Koordinatensystem speichern wollen. Wenn Sie Messwerte im maschinenfesten Koordinatensystem (REF-Koordinaten) speichern wollen, verwenden Sie den Softkey EINTRAG BEZPKT- TABELLE (siehe Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben).

Über den Softkey EINTRAG NULLPUNKT TABELLE kann die TNC, nachdem ein beliebiger Tastsystem-Zyklus ausgeführt wurde, die Messwerte in eine Nullpunkt-Tabelle schreiben:

Achtung Kollisionsgefahr!

Beachten Sie, dass die TNC bei einer aktiven Nullpunkt-Verschiebung den angetasteten Wert immer auf den aktiven Bezugspunkt (bzw. auf den zuletzt in der Betriebsart Manuell gesetzten Bezugspunkt) bezieht, obwohl in der Positions-Anzeige die Nullpunkt-Verschiebung verrechnet wird.

  • Beliebige Antastfunktion durchführen

  • Gewünschte Koordinaten des Bezugspunkts in die dafür angebotenen Eingabefelder eintragen (abhängig vom ausgeführten Tastsystem-Zyklus)

  • Nullpunkt-Nummer im Eingabefeld Nummer in Tabelle = eingeben

  • Namen der Nullpunkt-Tabelle (vollständiger Pfad) im Eingabefeld Nullpunkt-Tabelle eingeben

  • Softkey EINTRAG NULLPUNKT TABELLE drücken, Die TNC speichert den Nullpunkt unter der eingegeben Nummer in die angegebene Nullpunkt-Tabelle


Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben

Verwenden Sie diese Funktion, wenn Sie Messwerte im maschinenfesten Koordinatensystem (REF-Koordinaten) speichern wollen. Wenn Sie Messwerte im Werkstück-Koordinatensystem speichern wollen, verwenden Sie den Softkey EINTRAG Nullpunkt TABELLE (siehe Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben).

Über den Softkey EINTRAG BEZPKT. TABELLE kann die TNC, nachdem ein beliebiger Tastsystem-Zyklus ausgeführt wurde, die Messwerte in die Bezugspunkt-Tabelle schreiben. Die Messwerte werden dann bezogen auf das maschinenfeste Koordinatensystem (REF-Koordinaten) gespeichert. Die Bezugspunkt-Tabelle hat den Namen PRESET.PR und ist im Verzeichnis TNC:\ gespeichert.

Achtung Kollisionsgefahr!

Beachten Sie, dass die TNC bei einer aktiven Nullpunkt-Verschiebung den angetasteten Wert immer auf den aktiven Bezugspunkt (bzw. auf den zuletzt in der Betriebsart Manuell gesetzten Bezugspunkt) bezieht, obwohl in der Positions-Anzeige die Nullpunkt-Verschiebung verrechnet wird.

  • Beliebige Antastfunktion durchführen

  • Gewünschte Koordinaten des Bezugspunkts in die dafür angebotenen Eingabefelder eintragen (abhängig vom ausgeführten Tastsystem-Zyklus)

  • Bezugspunkt-Nummer im Eingabefeld Nummer in Tabelle: eingeben

  • Softkey EINTRAG BEZPKT. TABELLE drücken: Die TNC speichert den Nullpunkt unter der eingegeben Nummer in die Bezugspunkt-Tabelle

Wenn Sie den aktiven Bezugspunkt überschreiben, dann blendet die TNC einen Warnhinweis ein. Sie können dann entscheiden, ob Sie wirklich überschreiben wollen (=Taste ENT) oder nicht (=Taste NO ENT).


Messwerte in der Paletten-Beugspunkt-Tabelle speichern

Verwenden Sie diese Funktion, wenn Sie Palettenbezugspunkte erfassen wollen. Diese Funktion muss von Ihrem Maschinenhersteller freigegeben sein.

Um einen Messwert in der Paletten-Bezugspunkt-Tabelle speichern zu können, müssen Sie vor dem Antastvorgang einen Null-Bezugspunkt aktivieren. Ein Null-Bezugspunkt enthält in allen Achsen der Bezugspunkt-Tabelle den Eintrag 0!

  • Beliebige Antastfunktion durchführen

  • Gewünschte Koordinaten des Bezugspunkts in die dafür angebotenen Eingabefelder eintragen (abhängig vom ausgeführten Tastsystem-Zyklus)

  • Bezugspunkt-Nummer im Eingabefeld Nummer in Tabelle: eingeben

  • Softkey EINTRAG PALETTEN BEZPKT. tab. drücken: Die TNC speichert den Nullpunkt unter der eingegeben Nummer in der Paletten-Bezugspunkt-Tabelle


Tastsystem kalibrieren

Weitere Informationen:
> Einführung
> Kalibrieren der wirksamen Länge
> Wirksamen Radius kalibrieren und Tastsystem-Mittenversatz ausgleichen
> Kalibrierwerte anzeigen
> Mehrere Sätze von Kalibrierdaten verwalten


Einführung

Um den tatsächlichen Schaltpunkt eines Tastsystems exakt bestimmen zu können, müssen Sie das Tastsystem kalibrieren, ansonsten kann die TNC keine exakten Messergebnisse ermitteln.

Tastsystem immer kalibrieren bei:

  • Inbetriebnahme
  • Taststift-Bruch
  • Taststift-Wechsel
  • Änderung des Antastvorschubs
  • Unregelmäßigkeiten, beispielsweise durch Erwärmung der Maschine
  • Änderung der aktiven Werkzeugachse

Beim Kalibrieren ermittelt die TNC die „wirksame“ Länge des Taststifts und den „wirksamen“ Radius der Tastkugel. Zum Kalibrieren des Tastsystems spannen Sie einen Einstellring mit bekannter Höhe und bekanntem Innenradius auf den Maschinentisch.


Kalibrieren der wirksamen Länge

Die wirksame Länge des Tastsystems bezieht sich immer auf den Werkzeug-Bezugspunkt. In der Regel legt der Maschinenhersteller den Werkzeug-Bezugspunkt auf die Spindelnase.

  • Bezugspunkt in der Spindel-Achse so setzen, dass für den Maschinentisch gilt: Z=0.

Kalibrier-Funktion für die Tastsystem-Länge wählen: Softkey ANTAST-FUNKTION und KAL. L drücken. Die TNC zeigt ein Menü-Fenster mit vier Eingabefeldern

Werkzeug-Achse eingeben (Achstaste)

Bezugspunkt: Höhe des Einstellrings eingeben

Menüpunkte Wirksamer Kugelradius und Wirksame Länge erfordern keine Eingabe

Tastsystem dicht über die Oberfläche des Einstellrings fahren

Wenn nötig Verfahrrichtung ändern: über Softkey oder Pfeiltasten wählen

Oberfläche antasten: NC-Start-Taste drücken


Wirksamen Radius kalibrieren und Tastsystem-Mittenversatz ausgleichen

Die Tastsystem-Achse fällt normalerweise nicht genau mit der Spindelachse zusammen. Die Kalibrier-Funktion erfasst den Versatz zwischen Tastsystem-Achse und Spindelachse und gleicht ihn rechnerisch aus.

Abhängig von der Einstellung des Maschinen-Parameters 6165 (Spindelnachführung aktiv/inaktiv) läuft die Kalibrier-Routine unterschiedlich ab. Während bei aktiver Spindelnachführung der Kalibriervorgang mit einem einzigen NC-Start abläuft, können Sie bei inaktiver Spindelnachführung entscheiden, ob Sie den Mittenversatz kalibrieren wollen oder nicht.

Bei der Mittenversatz-Kalibrierung dreht die TNC das Tastsystem um 180°. Die Drehung wird durch eine Zusatz-Funktion ausgelöst, die der Maschinenhersteller im Maschinen-Parameter 6160 festlegt.

Gehen Sie beim manuellen Kalibrieren wie folgt vor:

  • Tastkugel im Manuellen Betrieb in die Bohrung des Einstellrings positionieren

Kalibrier-Funktion für den Tastkugel-Radius und den Tastsystem-Mittenversatz wählen: Softkey KAL. R drücken

Werkzeug-Achse wählen, Radius des Einstellrings eingeben

Antasten: 4x NC-Start-Taste drücken. Das Tastsystem tastet in jede Achsrichtung eine Position der Bohrung an und errechnet den wirksamen Tastkugel-Radius

Wenn Sie die Kalibrierfunktion jetzt beenden möchten, dann Softkey ENDE drücken

Um den Tastkugel-Mittenversatz zu bestimmen, muss die TNC vom Maschinenhersteller vorbereitet sein. Maschinenhandbuch beachten!

Tastkugel-Mittenversatz bestimmen: Softkey 180° drücken. Die TNC dreht das Tastsystem um 180°

Antasten: 4 x NC-Start-Taste drücken. Das Tastsystem tastet in jede Achsrichtung eine Position in der Bohrung und errechnet den Tastsystem-Mittenversatz


Kalibrierwerte anzeigen

Die TNC speichert wirksame Länge, den wirksamen Radius und den Betrag des Tastsystem-Mittenversatzes und berücksichtigt diese Werte bei späteren Einsätzen des Tastsystems. Um die gespeicherten Werte anzuzeigen, drücken Sie KAL. L und KAL. R.

Wenn Sie mehrere Tastsysteme bzw. Kalibrierdaten verwenden: Siehe Mehrere Sätze von Kalibrierdaten verwalten.


Mehrere Sätze von Kalibrierdaten verwalten

Wenn Sie an Ihrer Maschine mehrere Tastsysteme oder Tastereinsätze mit kreuzförmiger Anordnung verwenden, müssen Sie ggf. mehrere Sätze von Kalibrierdaten verwenden.

Um mehrere Sätze von Kalibrierdaten verwenden zu können, müssen Sie den Maschinen-Parameter 7411=1 setzen. Das Ermitteln der Kalibrierdaten ist identisch zur Vorgehensweise beim Einsatz eines einzelnen Tassystems, die TNC speichert jedoch die Kalibrierdaten in der Werkzeug-Tabelle, wenn Sie das Kalibrier-Menü verlassen und das Schreiben der Kalibrierdaten in die Tabelle mit der Taste ENT bestätigen.

    Die TNC legt die Kalibrierdaten in folgenden Spalten der Werkzeug-Tabelle ab:

  • Wirksamer Tastkugel-Radius: Spalte R
  • Mittenversatz X: CAL-OF1
  • Mittenversatz Y: CAL-OF2
  • Kalibrierwinkel: ANGLE
  • Gemittelter Mittenveratz (nur für Zyklus 441 wirksam): DR

Die aktive Werkzeug-Nummer bestimmt dabei die Zeile in der Werkzeug-Tabelle, in der die TNC die Daten ablegt.

Beachten Sie, dass Sie die richtige Werkzeug-Nummer aktiv haben, wenn Sie das Tastsystem verwenden, unabhängig davon, ob Sie einen Tastsystem-Zyklus im Automatik-Betrieb oder im Manuellen Betrieb abarbeiten wollen.

Die TNC zeigt im Kalibriermenü Werkzeug-Nummer und -Name an, wenn der Maschinen-Parameter 7411=1 gesetzt ist.


Werkstück-Schieflage mit Tastsystem kompensieren

Weitere Informationen:
> Einführung
> Grunddrehung über 2 Punkte ermitteln
> Grunddrehung über 2 Bohrungen/Zapfen ermitteln
> Werkstück ausrichten über 2 Punkte


Einführung

Eine schiefe Werkstück-Aufspannung kompensiert die TNC rechnerisch durch eine „Grunddrehung“.

Dazu setzt die TNC den Drehwinkel auf den Winkel, den eine Werkstückfläche mit der Winkelbezugsachse der Bearbeitungsebene einschließen soll. Siehe Bild rechts.

Alternativ können Sie eine Werkstück-Schieflage auch durch eine Rundtischdrehung kompensieren.

Antastrichtung zum Messen der Werkstück-Schieflage immer senkrecht zur Winkelbezugsachse wählen.

Damit die Grunddrehung im Programmlauf richtig verrechnet wird, müssen Sie im ersten Verfahrsatz beide Koordinaten der Bearbeitungsebene programmieren.

Eine Grunddrehung können Sie auch in Kombination mit der PLANE-Funktion verwenden, Sie müssen in diesem Fall zuerst die Grunddrehung und dann die PLANE-Funktion aktivieren.

Wenn Sie die Grunddrehung verändern, frägt die TNC beim Verlassen des Menüs, ob Sie die geänderte Grunddrehung auch in der jeweils aktiven Zeile der Bezugspunkt-Tabelle speichern wollen. In diesem Fall mit Taste ENT bestätigen.

Die TNC kann auch eine echte, dreidimensionale Aufspannkompensation durchführen, wenn Ihre Maschine dafür vorbereitet ist. Setzen Sie sich ggf. mit Ihrem Maschinenhersteller in Verbindung.

Durch Setzen von Bit #18 in MP7680 lässt sich die Fehlermeldung Achswinkel ungleich Schwenkwinkel beim Ermitteln einer Grunddrehung und beim Ausrichten des Werkstücks mittels Drehachse mit manuellem Antast-Zyklen unterdrücken. Dadurch können Sie die Grunddrehung an Stellen ermitteln, die ohne einschwenken des Kopfes nicht erreichbar wären.

Weitere Informationen:
> Übersicht


Übersicht
Zyklus | Softkey
Grunddrehung über 2 Punkte: Die TNC ermittelt den Winkel zwischen der Verbindungslinie der 2 Punkte und einer Soll-Lage (Winkel-Bezugsachse). |
Grunddrehung über 2 Bohrungen/Zapfen: Die TNC ermittelt den Winkel zwischen der Verbindungslinie der Bohrungs-/Zapfen-Mittelpunkte und einer Soll-Lage (Winkel-Bezugsachse). |
Werkstück ausrichten über 2 Punkte: Die TNC ermittelt den Winkel zwischen der Verbindungslinie der 2 Punkte und einer Soll-Lage (Winkel-Bezugsachse) und kompensiert die Schieflage durch eine Rundtisch-Drehung. |


Grunddrehung über 2 Punkte ermitteln

Antastfunktion wählen: Softkey ANTASTEN ROT drücken

Tastsystem in die Nähe des ersten Antastpunkts positionieren

Antastrichtung senkrecht zur Winkelbezugsachse wählen: Achse und Richtung über Softkey wählen

Antasten: NC-Start-Taste drücken

Tastsystem in die Nähe des zweiten Antastpunkts positionieren

Antasten: NC-Start-Taste drücken. Die TNC ermittelt die Grunddrehung und zeigt den Winkel hinter dem Dialog Drehwinkel = an

Weitere Informationen:
> Grunddrehung in die Bezugspunkt-Tabelle speichern
> Grunddrehung in der Paletten-Bezugspunkt-Tabelle speichern
> Grunddrehung anzeigen
> Grunddrehung aufheben


Grunddrehung in die Bezugspunkt-Tabelle speichern

  • Nach dem Antast-Vorgang die Bezugspunkt-Nummer im Eingabefeld Nummer in Tabelle: eingeben, in der die TNC die aktive Grunddrehung speichern soll

  • Softkey eintrag BEZPKT. tabelle drücken, um die Grunddrehung in der Bezugspunkt-Tabelle zu speichern


Grunddrehung in der Paletten-Bezugspunkt-Tabelle speichern

Um eine Grunddrehung in der Paletten-Bezugspunkt-Tabelle speichern zu können, müssen Sie vor dem Antastvorgang einen Null-Bezugspunkt aktivieren. Ein Null-Bezugspunkt enthält in allen Achsen der Bezugspunkt-Tabelle den Eintrag 0!

  • Nach dem Antast-Vorgang die Bezugspunkt-Nummer im Eingabefeld Nummer in Tabelle: eingeben, in der die TNC die aktive Grunddrehung speichern soll

  • Softkey eintrag PALETTEN BEZKT. tab. drücken, um die Grunddrehung in der Paletten-Bezugspunkt-Tabelle zu speichern

Die TNC zeigt einen aktiven Paletten-Bezugspunkt in der zusätzlichen Status-Anzeige an (siehe Allgemeine Paletten-Information (Reiter PAL)).


Grunddrehung anzeigen

Der Winkel der Grunddrehung steht nach erneutem Wählen von ANTASTEN ROT in der Drehwinkel-Anzeige. Die TNC zeigt den Drehwinkel auch in der zusätzlichen Statusanzeige an (STATUS POS.)

In der Status-Anzeige wird ein Symbol für die Grunddrehung eingeblendet, wenn die TNC die Maschinen-Achsen entsprechend der Grunddrehung verfährt.


Grunddrehung aufheben

  • Antastfunktion wählen: Softkey ANTASTEN ROT drücken

  • Drehwinkel „0“ eingeben, mit Taste ENT übernehmen

  • Antastfunktion beenden: Taste END drücken


Grunddrehung über 2 Bohrungen/Zapfen ermitteln

Antastfunktion wählen: Softkey ANTASTEN ROT drücken (Softkey-Leiste 2)

Kreiszapfen sollen angetastet werden: Über Softkey festlegen

Bohrungen sollen angetastet werden: Über Softkey festlegen

Weitere Informationen:
> Bohrungen antasten
> Kreiszapfen antasten
> Grunddrehung in der Bezugspunkt-Tabelle speichern


Bohrungen antasten

Tastsystem ungefähr in der Mitte der Bohrung vorpositionieren. Nachdem Sie die NC-Start-Taste gedrückt haben, tastet die TNC automatisch vier Punkte der Bohrungswand an.

Anschließend fahren Sie das Tastsystem zur nächsten Bohrung und tasten diese genauso an. Die TNC wiederholt diesen Vorgang, bis alle Bohrungen für die Bezugspunkt-Bestimmung angetastet sind.


Kreiszapfen antasten

Tastsystem in die Nähe des ersten Antastpunkts am Kreiszapfen -positionieren. Über Softkey Antastrichtung wählen, Antastvorgang mit externer START-Taste ausführen. Vorgang insgesamt viermal ausführen.


Grunddrehung in der Bezugspunkt-Tabelle speichern

  • Nach dem Antast-Vorgang die Bezugspunkt-Nummer im Eingabefeld Nummer in Tabelle: eingeben, in der die TNC die aktive Grunddrehung speichern soll

  • Softkey eintrag BZPKT. tabelle drücken, um die Grunddrehung in der Bezugspunkt-Tabelle zu speichern


Werkstück ausrichten über 2 Punkte

Antastfunktion wählen: Softkey ANTASTEN ROT drücken (Softkey-Leiste 2)

Tastsystem in die Nähe des ersten Antastpunkts positionieren

Antastrichtung senkrecht zur Winkelbezugsachse wählen: Achse und Richtung über Softkey wählen

Antasten: NC-Start-Taste drücken

Tastsystem in die Nähe des zweiten Antastpunkts positionieren

Antasten: NC-Start-Taste drücken. Die TNC ermittelt die Grunddrehung und zeigt den Winkel hinter dem Dialog Drehwinkel = an

Weitere Informationen:
> Werkstück ausrichten
> Schieflage in der Bezugspunkt-Tabelle speichern


Werkstück ausrichten

Achtung Kollisionsgefahr!

Tastsystem vor dem Ausrichten so freifahren, dass keine Kollision mit Spannmitteln oder Werkstücken erfolgen kann.

  • Softkey rundtisch positionieren drücken, die TNC blendet einen Warnhinweis zum Freifahren des Tastsystems ein

  • Ausrichtvorgang mit NC-Start ausführen: Die TNC positioniert den Rundtisch

  • Nach dem Antast-Vorgang die Bezugspunkt-Nummer im Eingabefeld Nummer in Tabelle: eingeben, in der die TNC die aktive Grunddrehung speichern soll


Schieflage in der Bezugspunkt-Tabelle speichern

  • Nach dem Antast-Vorgang die Bezugspunkt-Nummer im Eingabefeld Nummer in Tabelle: eingeben, in der die TNC die ermittelte Werkstück-Schieflage speichern soll

  • Softkey eintrag BZPKT. tabelle drücken, um den Winkelwert als Verschiebung in der Drehachse in der Bezugspunkt-Tabelle zu speichern


Bezugspunkt-Setzen mit Tastsystem

Weitere Informationen:
> Übersicht
> Bezugspunkt-Setzen in einer beliebigen Achse
> Ecke als Bezugspunkt – Punkte übernehmen, die für Grunddrehung angetastet wurden
> Ecke als Bezugspunkt – Punkte nicht übernehmen, die für Grunddrehung angetastet wurden
> Kreismittelpunkt als Bezugspunkt
> Mittelachse als Bezugspunkt
> Bezugspunkte über Bohrungen/Kreiszapfen setzen
> Werkstücke vermessen mit Tastsystem
> Antastfunktionen nutzen mit mechanischen Tastern oder Messuhren


Übersicht

Die Funktionen zum Bezugspunkt-Setzen am ausgerichteten Werkstück wählen Sie mit folgenden Softkeys:

Softkey | Funktion | Seite
 | Bezugspunkt-Setzen in einer beliebigen Achse mit | Bezugspunkt-Setzen in einer beliebigen Achse
 | Ecke als Bezugspunkt setzen | Ecke als Bezugspunkt – Punkte übernehmen, die für Grunddrehung angetastet wurden
 | Kreismittelpunkt als Bezugspunkt setzen | Kreismittelpunkt als Bezugspunkt
 | Mittelachse als Bezugspunkt | Mittelachse als Bezugspunkt

Achtung Kollisionsgefahr!

Beachten Sie, dass die TNC bei einer aktiven Nullpunkt-Verschiebung den angetasteten Wert immer auf den aktiven Bezugspunkt (bzw. auf den zuletzt in der Betriebsart Manuell gesetzten Bezugspunkt) bezieht, obwohl in der Positions-Anzeige die Nullpunkt-Verschiebung verrechnet ist.


Bezugspunkt-Setzen in einer beliebigen Achse

Antastfunktion wählen: Softkey ANTASTEN POS drücken

Tastsystem in die Nähe des Antastpunkts positionieren

Antastrichtung und gleichzeitig Achse wählen, für die der Bezugspunkt gesetzt wird, z.B. Z in Richtung Z– antasten: Über Softkey wählen

Antasten: NC-Start-Taste drücken

Bezugspunkt: Soll-Koordinate eingeben, mit Softkey bezugsp. setzen übernehmen, oder Wert in eine Tabelle schreiben (siehe Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben, oder siehe Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben, oder siehe Messwerte in der Paletten-Beugspunkt-Tabelle speichern)

Antast-Funktion beenden: Taste END drücken


Ecke als Bezugspunkt – Punkte übernehmen, die für Grunddrehung angetastet wurden

Antastfunktion wählen: Softkey ANTASTEN P drücken

Antastpunkte aus Grunddrehung ?: Taste ENT drücken, um die Koordinaten der Antastpunkte zu übernehmen

Tastsystem in die Nähe des ersten Antastpunkts auf der Werkstück-Kante positionieren, die für die Grunddrehung nicht angetastet wurde

Antastrichtung wählen: Über Softkey wählen

Antasten: NC-Start-Taste drücken

Tastsystem in die Nähe des zweiten Antastpunkts auf der gleichen Kante positionieren

Antasten: NC-Start-Taste drücken

Bezugspunkt: Beide Koordinaten des Bezugspunkts im Menüfenster eingeben, mit Softkey bezugsp. -setzen übernehmen, oder Werte in eine Tabelle schreiben (siehe Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben, oder siehe Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben, oder siehe Messwerte in der Paletten-Beugspunkt-Tabelle speichern)

Antast-Funktion beenden: Taste END drücken


Ecke als Bezugspunkt – Punkte nicht übernehmen, die für Grunddrehung angetastet wurden

  • Antastfunktion wählen: Softkey ANTASTEN P drücken

  • Antastpunkte aus Grunddrehung ?: Mit Taste NO ENT verneinen (Dialogfrage erscheint nur, wenn Sie zuvor eine Grunddrehung durchgeführt haben)

  • Beide Werkstück-Kanten je zweimal antasten

  • Bezugspunkt: Koordinaten des Bezugspunkts eingeben, mit Softkey bezugsp. setzen übernehmen, oder Werte in eine Tabelle schreiben (siehe Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben, oder siehe Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben, oder siehe Messwerte in der Paletten-Beugspunkt-Tabelle speichern)

  • Antast-Funktion beenden: Taste END drücken


Kreismittelpunkt als Bezugspunkt

Mittelpunkte von Bohrungen, Kreistaschen, Vollzylindern, Zapfen, kreisförmigen Inseln usw. können Sie als Bezugspunkte setzen.

Weitere Informationen:
> Innenkreis:
> Außenkreis:


Innenkreis:

Die TNC tastet die Kreis-Innenwand in alle vier Koordinatenachsen-Richtungen an.

Bei unterbrochenen Kreisen (Kreisbögen) können Sie die Antastrichtung beliebig wählen.

  • Tastkugel ungefähr in die Kreismitte positionieren

Antastfunktion wählen: Softkey ANTASTEN CC wählen

Antasten: NC-Start-Taste viermal drücken. Das Tastsystem tastet nacheinander 4 Punkte der Kreis-Innenwand an

Wenn Sie mit Umschlagmessung arbeiten wollen (nur bei Maschinen mit Spindel-Orientierung, abhängig von MP6160) Softkey 180° drücken und erneut 4 Punkte der Kreis-Innenwand antasten

Wenn Sie ohne Umschlagmessung arbeiten wollen: Taste END drücken

Bezugspunkt: Im Menüfenster beide Koordinaten des Kreismittelpunkts eingeben, mit Softkey bezugsp. setzen übernehmen, oder Werte in eine Tabelle schreiben (siehe Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben, oder siehe Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben)

Antastfunktion beenden: Taste END drücken


Außenkreis:

  • Tastkugel in die Nähe des ersten Antastpunkts außerhalb des -Kreises positionieren

  • Antastrichtung wählen: Entsprechenden Softkey wählen

  • Antasten: NC-Start-Taste drücken

  • Antastvorgang für die übrigen 3 Punkte wiederholen. Siehe Bild rechts unten

  • Bezugspunkt: Koordinaten des Bezugspunkts eingeben, mit Softkey bezugsp. setzen übernehmen, oder Werte in eine Tabelle schreiben (siehe Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben, oder siehe Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben, oder siehe Messwerte in der Paletten-Beugspunkt-Tabelle speichern)

  • Antast-Funktion beenden: Taste END drücken

Nach dem Antasten zeigt die TNC die aktuellen Koordinaten des Kreismittelpunkts und den Kreisradius PR an.


Mittelachse als Bezugspunkt

Antastfunktion wählen: Softkey ANTASTEN drücken

Tastsystem in die Nähe des ersten Antastpunkts positionieren

Antastrichtung über Softkey wählen

Antasten: NC-Start-Taste drücken

Tastsystem in die Nähe des zweiten Antastpunkts positionieren

Antasten: NC-Start-Taste drücken

Bezugspunkt: Koordinate des Bezugspunkts im Menüfenster eingeben, mit Softkey bezugsp. -setzen übernehmen, oder Wert in eine Tabelle schreiben (siehe Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben, oder siehe Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben, oder siehe Messwerte in der Paletten-Beugspunkt-Tabelle speichern)

Antast-Funktion beenden: Taste END drücken


Bezugspunkte über Bohrungen/Kreiszapfen setzen

In der zweiten Softkey-Leiste stehen Softkeys zur Verfügung, mit denen Sie Bohrungen oder Kreiszapfen zum Bezugspunkt-Setzen nutzen können.

Weitere Informationen:
> Festlegen ob Bohrung oder Kreiszapfen angetastet werden soll
> Bohrungen antasten
> Kreiszapfen antasten
> Übersicht


Festlegen ob Bohrung oder Kreiszapfen angetastet werden soll

In der Grundeinstellung werden Bohrungen angetastet.

Antastfunktion wählen: Softkey ANTAST-FUNKTION drücken, Softkeyleiste weiterschalten

Antastfunktion wählen: z.B. Softkey ANTASTEN p drücken

Kreiszapfen sollen angetastet werden: Über Softkey festlegen

Bohrungen sollen angetastet werden: Über Softkey festlegen


Übersicht
Zyklus | Softkey
Grunddrehung über 2 Bohrungen: Die TNC ermittelt den Winkel zwischen der Verbindungslinie der Bohrungs-Mittelpunkte und einer Soll-Lage (Winkel-Bezugsachse) |
Bezugspunkt über 4 Bohrungen: Die TNC ermittelt den Schnittpunkt der beiden zuerst und der beiden zuletzt angetasteten Bohrungen. Tasten Sie dabei über Kreuz an (wie auf dem Softkey dargestellt), da die TNC sonst einen falschen Bezugspunkt berechnet |
Kreismittelpunkt über 3 Bohrungen: Die TNC ermittelt eine Kreisbahn, auf der alle 3 Bohrungen liegen und errechnet für die Kreisbahn einen Kreismittelpunkt. |


Werkstücke vermessen mit Tastsystem

Sie können das Tastsystem in den Betriebsarten Manuell und El. Handrad auch verwenden, um einfache Messungen am Werkstück durchzuführen. Für komplexere Messaufgaben stehen zahlreiche programmierbare Antast-Zyklen zur Verfügung (siehe Benutzer-Handbuch Zyklen, Kapitel 16, Werkstücke automatisch kontrollieren). Mit dem Tastsystem bestimmen Sie:

  • Positions-Koordinaten und daraus
  • Maße und Winkel am Werkstück
Weitere Informationen:
> Koordinate einer Position am ausgerichteten Werkstück bestimmen
> Koordinaten eines Eckpunktes in der Bearbeitungsebene bestimmen
> Werkstückmaße bestimmen
> Winkel zwischen der Winkelbezugsachse und einer Werkstück-Kante bestimmen


Koordinate einer Position am ausgerichteten Werkstück bestimmen

Antastfunktion wählen: Softkey ANTASTEN POS drücken

Tastsystem in die Nähe des Antastpunkts -positionieren

Antastrichtung und gleichzeitig Achse wählen, auf die die Koordinate sich beziehen soll: Entsprechenden Softkey wählen.

Antastvorgang starten: NC-Start-Taste drücken

Die TNC zeigt die Koordinate des Antastpunkts als Bezugspunkt an.


Koordinaten eines Eckpunktes in der Bearbeitungsebene bestimmen

Koordinaten des Eckpunktes bestimmen: Siehe Ecke als Bezugspunkt – Punkte nicht übernehmen, die für Grunddrehung angetastet wurden. Die TNC zeigt die Koordinaten der angetasteten Ecke als Bezugspunkt an.


Werkstückmaße bestimmen

Antastfunktion wählen: Softkey ANTASTEN POS drücken

Tastsystem in die Nähe des ersten Antastpunkts A positionieren

Antastrichtung über Softkey wählen

Antasten: NC-Start-Taste drücken

Als Bezugspunkt angezeigten Wert notieren (nur, falls vorher gesetzter Bezugspunkt wirksam bleibt)

Bezugspunkt: „0“ eingeben

Dialog abbrechen: Taste END drücken

Antastfunktion erneut wählen: Softkey ANTASTEN POS drücken

Tastsystem in die Nähe des zweiten Antastpunkts B positionieren

Antastrichtung über Softkey wählen: Gleiche Achse, jedoch entgegengesetzte Richtung wie beim ersten Antasten.

Antasten: NC-Start-Taste drücken

In der Anzeige Bezugspunkt steht der Abstand zwischen den beiden Punkten auf der Koordinatenachse.

Weitere Informationen:
> Positionsanzeige wieder auf Werte vor der Längenmessung setzen
> Winkel messen


Positionsanzeige wieder auf Werte vor der Längenmessung setzen

  • Antastfunktion wählen: Softkey ANTASTEN POS drücken

  • Ersten Antastpunkt erneut antasten

  • Bezugspunkt auf notierten Wert setzen

  • Dialog abbrechen: Taste END drücken


Winkel messen

Mit einem Tastsystem können Sie einen Winkel in der Bearbeitungsebene bestimmen. Gemessen wird der

  • Winkel zwischen der Winkelbezugsachse und einer Werkstück-Kante oder der
  • Winkel zwischen zwei Kanten

Der gemessene Winkel wird als Wert von maximal 90° angezeigt.


Winkel zwischen der Winkelbezugsachse und einer Werkstück-Kante bestimmen

Antastfunktion wählen: Softkey ANTASTEN ROT drücken

Drehwinkel: Angezeigten Drehwinkelnotieren, falls Sie die zuvor durchgeführte Grunddrehung später wieder herstellen möchten

Grunddrehung mit der zu vergleichenden Seite durchführen (siehe Werkstück-Schieflage mit Tastsystem kompensieren)

Mit Softkey ANTASTEN ROT den Winkel zwischen Winkelbezugsachse und Werkstückkante als Drehwinkel anzeigen lassen

Grunddrehung aufheben oder ursprüngliche Grunddrehung wieder herstellen

Drehwinkel auf notierten Wert setzen

Weitere Informationen:
> Winkel zwischen zwei Werkstück-Kanten bestimmen


Winkel zwischen zwei Werkstück-Kanten bestimmen

  • Antastfunktion wählen: Softkey ANTASTEN ROT drücken

  • Drehwinkel: Angezeigten Drehwinkel notieren, falls Sie die zuvor durchgeführte Grunddrehung wieder herstellen möchten

  • Grunddrehung für die erste Seite durchführen (siehe Werkstück-Schieflage mit Tastsystem kompensieren)

  • Zweite Seite ebenfalls wie bei einer Grunddrehung antasten, Drehwinkel hier nicht auf 0 setzen!

  • Mit Softkey ANTASTEN ROT Winkel PA zwischen den Werkstück-Kanten als Drehwinkel anzeigen lassen

  • Grunddrehung aufheben oder ursprüngliche Grunddrehung wieder herstellen: Drehwinkel auf notierten Wert setzen


Antastfunktionen nutzen mit mechanischen Tastern oder Messuhren

Sollten Sie an Ihrer Maschine kein elektronisches Tastsystem zur Verfügung haben, dann können Sie alle zuvor beschriebenen manuellen Antast-Funktionen (Ausnahme: Kalibrierfunktionen) auch mit mechanischen Tastern oder auch durch einfaches Ankratzen nutzen.

Anstelle eines elektronischen Signales, das automatisch von einem Tastsystem während der Antast-Funktion erzeugt wird, lösen Sie das Schaltsignal zur Übernahme der Antast-Position manuell über eine Taste aus. Gehen Sie dabei wie folgt vor:

Per Softkey beliebige Antastfunktion wählen

Mechanischen Taster auf die erste Position fahren, die von der TNC übernommen werden soll

Position übernehmen: Taste Ist-Positions-Übernahme drücken, die TNC speichert die aktuelle Position

Mechanischen Taster auf die nächste Position fahren, die von der TNC übernommen werden soll

Position übernehmen: Taste Ist-Positions-Übernahme drücken, die TNC speichert die aktuelle Position

Ggf. weitere Positionen anfahren und wie zuvor beschrieben übernehmen

Bezugspunkt: Im Menüfenster die Koordinaten des neuen Bezugspunktes eingeben, mit Softkey bezugsp. setzen übernehmen, oder Werte in eine Tabelle schreiben (siehe Messwerte aus den Tastsystem-Zyklen in eine Nullpunkt-Tabelle schreiben, oder siehe Messwerte aus den Tastsystem-Zyklen in die Bezugspunkt-Tabelle schreiben)

Antastfunktion beenden: Taste END drücken


Bearbeitungsebene schwenken (Software-Option 1)

Weitere Informationen:
> Anwendung, Arbeitsweise
> Referenzpunkte-Anfahren bei geschwenkten Achsen
> Bezugspunkt-Setzen im geschwenkten System
> Bezugspunkt-Setzen bei Maschinen mit Rundtisch
> Bezugspunkt-Setzen bei Maschinen mit Kopfwechsel-Systemen
> Positionsanzeige im geschwenkten System
> Einschränkungen beim Schwenken der Bearbeitungsebene
> Manuelles Schwenken aktivieren
> Aktuelle Werkzeugachs-Richtung als aktive Bearbeitungsrichtung setzen (FCL 2-Funktion)


Anwendung, Arbeitsweise

Die Funktionen zum Schwenken der Bearbeitungsebene werden vom Maschinenhersteller an TNC und Maschine angepasst. Bei bestimmten Schwenkköpfen (Schwenktischen) legt der Maschinenhersteller fest, ob die im Zyklus programmierten Winkel von der TNC als Koordinaten der Drehachsen oder als Winkelkomponenten einer schiefen Ebene interpretiert werden. Beachten Sie Ihr Maschinenhandbuch.

Die TNC unterstützt das Schwenken von Bearbeitungsebenen an Werkzeugmaschinen mit Schwenkköpfen sowie Schwenktischen. Typische Anwendungen sind z.B. schräge Bohrungen oder schräg im Raum liegende Konturen. Die Bearbeitungsebene wird dabei immer um den aktiven Nullpunkt geschwenkt. Wie gewohnt, wird die Bearbeitung in einer Hauptebene (z.B. X/Y-Ebene) programmiert, jedoch in der Ebene ausgeführt, die zur Hauptebene geschwenkt wurde.

    Für das Schwenken der Bearbeitungsebene stehen drei Funktionen zur Verfügung:

  • Manuelles Schwenken mit dem Softkey 3D ROT in den Betriebsarten Manueller Betrieb und El. Handrad, siehe Manuelles Schwenken aktivieren

  • Gesteuertes Schwenken, Zyklus g80 im Bearbeitungs-Programm (siehe Benutzer-Handbuch Zyklen, Zyklus 19 BEARBEITUNGSEBENE)

  • Gesteuertes Schwenken, Plane-Funktion im Bearbeitungs-Programm (siehe Die PLANE-Funktion: Schwenken der Bearbeitungsebene (Software-Option 1))

Die TNC-Funktionen zum „Schwenken der Bearbeitungsebene“ sind Koordinaten-Transformationen. Dabei steht die Bearbeitungsebene immer senkrecht zur Richtung der Werkzeugachse.

    Grundsätzlich unterscheidet die TNC beim Schwenken der Bearbeitungsebene zwei Maschinen-Typen:

  • Maschine mit Schwenktisch
    • Sie müssen das Werkstück durch entsprechende Positionierung des Schwenktisches, z.B. mit einem L-Satz, in die gewünschte Bearbeitungslage bringen

    • Die Lage der transformierten Werkzeugachse ändert sich im Bezug auf das maschinenfeste Koordinatensystem nicht. Wenn Sie Ihren Tisch – also das Werkstück – z.B. um 90° drehen, dreht sich das Koordinatensystem nicht mit. Wenn Sie in der Betriebsart Manueller Betrieb die Achsrichtungs-Taste Z+ drücken, verfährt das Werkzeug in die Richtung Z+

    • Die TNC berücksichtigt für die Berechnung des transformierten Koordinatensystems lediglich mechanisch bedingte Versätze des jeweiligen Schwenktisches – sogenannte „translatorische“ Anteile
  • Maschine mit Schwenkkopf
    • Sie müssen das Werkzeug durch entsprechende Positionierung des Schwenkkopfs, z.B. mit einem L-Satz, in die gewünschte Bearbeitungslage bringen
    • Die Lage der geschwenkten (transformierten) Werkzeugachse ändert sich im Bezug auf das maschinenfeste Koordinatensystem: Drehen Sie den Schwenkkopf Ihrer Maschine – also das Werkzeug – z.B. in der B-Achse um +90°, dreht sich das Koordinatensystem mit. Wenn Sie in der Betriebsart Manueller Betrieb die Achsrichtungs-Taste Z+ drücken, verfährt das Werkzeug in die Richtung X+ des maschinenfesten Koordinatensystems
    • Die TNC berücksichtigt für die Berechnung des transformierten Koordinatensystems mechanisch bedingte Versätze des Schwenkkopfs („translatorische“ Anteile) und Versätze, die durch das Schwenken des Werkzeugs entstehen (3D-Werkzeug-Längenkorrektur)


Referenzpunkte-Anfahren bei geschwenkten Achsen

Bei geschwenkten Achsen fahren Sie die Referenzpunkte mit den externen Richtungstasten an. Die TNC interpoliert dabei die entsprechenden Achsen. Beachten Sie, dass die Funktion „Bearbeitungsebene schwenken“ in der Betriebsart Manueller Betrieb aktiv ist und der Ist-Winkel der Drehachse im Menüfeld eingetragen wurde.


Bezugspunkt-Setzen im geschwenkten System

    Nachdem Sie die Drehachsen positioniert haben, setzen Sie den Bezugspunkt wie im ungeschwenkten System. Das Verhalten der TNC beim Bezugspunkt-Setzen ist dabei abhängig von der Einstellung des Maschinen-Parameters 7500 in Ihrer Kinematik-Tabelle:

  • MP 7500, Bit 5=0
    Die TNC prüft bei aktiver geschwenkter Bearbeitungsebene, ob beim Setzen des Bezugspunktes in den Achsen X, Y und Z die aktuellen Koordinaten der Drehachsen mit den von Ihnen definierten Schwenkwinkeln (3D-ROT-Menü) übereinstimmen. Ist die Funktion Bearbeitungsebe schwenken inaktiv, dann prüft die TNC, ob die Drehachsen auf 0° stehen (Ist-Positionen). Stimmen die Positionennicht überein, gibt die TNC eine Fehlermeldung aus.

  • MP 7500, Bit 5=1
    Die TNC prüft nicht, ob die aktuellen Koordinaten der Drehachsen (Ist-Positionen) mit den von Ihnen definierten Schwenkwinkeln übereinstimmen.

Achtung Kollisionsgefahr!

Bezugspunkt grundsätzlich immer in allen drei Hauptachsen setzen.

Falls die Drehachsen Ihrer Maschine nicht geregelt sind, müssen Sie die Ist-Position der Drehachse ins Menü zum manuellen Schwenken eintragen: Stimmt die Ist-Position der Drehachse(n) mit dem Eintrag nicht überein, berechnet die TNC den Bezugspunkt falsch.


Bezugspunkt-Setzen bei Maschinen mit Rundtisch

Wenn Sie das Werkstück durch eine Rundtischdrehung ausrichten, z.B. mit dem Antast-Zyklus 403, müssen Sie vor dem Setzen des Bezugspunktes in den Linearachsen X, Y und Z die Rundtischachse nach dem Ausricht-Vorgang abnullen. Ansonsten gibt die TNC eine Fehlermeldung aus. Der Zyklus 403 bietet diese Möglichkeit direkt an, indem Sie einen Eingabeparameter setzen (siehe Benutzer-Handbuch Tastsystem-Zyklen, „Grunddrehung über eine Drehachse kompensieren“).


Bezugspunkt-Setzen bei Maschinen mit Kopfwechsel-Systemen

Wenn Ihre Maschine mit einem Kopfwechsel-System ausgerüstet ist, sollten Sie Bezugspunkte grundsätzlich über die Bezugspunkt-Tabelle ver-walten. Bezugspunkte, die in Bezugspunkt-Tabellen gespeichert sind, bein-halten die Verrechnung der aktiven Maschinen-Kinematik (Kopfgeo-metrie). Wenn Sie einen neuen Kopf einwechseln, berücksichtigt die TNC die neuen, veränderten Kopfabmessungen, so dass der aktive Bezugspunkt erhalten bleibt.


Positionsanzeige im geschwenkten System

Die im Status-Feld angezeigten Positionen (SOLL und IST) beziehen sich auf das geschwenkte Koordinatensystem.


Einschränkungen beim Schwenken der Bearbeitungsebene

  • Die Antastfunktion Grunddrehung steht nicht zur Verfügung, wenn Sie in der Betriebsart Manuell die Funktion Bearbeitungsebene schwenken aktiviert haben
  • Die Funktion „Ist-Position übernehmen“ ist nicht erlaubt, wenn die Funktion Bearbeitungsebene schwenken aktiviert ist
  • PLC-Positionierungen (vom Maschinenhersteller festgelegt) sind nicht erlaubt


Manuelles Schwenken aktivieren

 | Manuelles Schwenken wählen: Softkey 3D ROT drücken
 | Hellfeld per Pfeiltaste auf Menüpunkt Manueller Betrieb positionieren
 | Manuelles Schwenken aktivieren: Softkey aktiv drücken
 | Hellfeld per Pfeiltaste auf gewünschte Drehachse positionieren
Schwenkwinkel eingeben
 | Eingabe beenden: Taste END

Zum Deaktivieren setzen Sie im Menü Bearbeitungsebene schwenken die gewünschten Betriebsarten auf Inaktiv.

Wenn die Funktion Bearbeitungsebene schwenken aktiv ist und die TNC die Maschinenachsen entsprechend der geschwenkten Achsen verfährt, blendet die Status-Anzeige das Symbol [image] ein.

Falls Sie die Funktion Bearbeitungsebene schwenken für die Betriebsart Programmlauf auf Aktiv setzen, gilt der im Menü eingetragene Schwenkwinkel ab dem ersten Satz des abzuarbeitenden Bearbeitungs-Programms. Verwenden Sie im Bearbeitungs-Programm den Zyklus g80 oder die PLANE-Funktion, sind die dort definierten Winkelwerte wirksam. Im Menü eingetragene Winkelwerte werden mit den aufgerufenen Werten überschrieben.


Aktuelle Werkzeugachs-Richtung als aktive Bearbeitungsrichtung setzen (FCL 2-Funktion)

Diese Funktion muss vom Maschinenhersteller freigeschaltet werden. Beachten Sie Ihr Maschinenhandbuch.

    Mit dieser Funktion können Sie in den Betriebsarten Manuell und El. Handrad das Werkzeug per externer Richtungstasten oder mit dem Handrad in der Richtung verfahren, in der die Werkzeugachse momentan zeigt. Diese Funktion benützen, wenn

  • Sie das Werkzeug während einer Programm-Unterbrechung in einem 5-Achs-Programm in Werkzeug-Achsrichtung freifahren wollen
  • Sie mit dem Handrad oder den externen Richtungstasten im Manuellen Betrieb eine Bearbeitung mit angestelltem Werkzeug durchführen wollen

Manuelles Schwenken wählen: Softkey 3D ROT drücken

Hellfeld per Pfeiltaste auf Menüpunkt Manueller Betrieb positionieren

Aktivie Werkzeugachs-Richtung als aktive Bearbeitungsrichtung aktivieren: Softkey wz-achse drücken

Eingabe beenden: Taste END

Zum Deaktivieren setzen Sie im Menü Bearbeitungsebene schwenken den Menüpunkt Manueller Betrieb auf Inaktiv.

Wenn die Funktion Verfahren in Werkzeugachs-Richtung aktiv ist, blendet die Status-Anzeige das Symbol [image] ein.

Diese Funktion steht auch dann zur Verfügung, wenn Sie den Programmlauf unterbrechen und die Achsen manuell verfahren wollen.


Positionieren mit Handeingabe

Weitere Informationen:
> Einfache Bearbeitungen programmieren und abarbeiten


Einfache Bearbeitungen programmieren und abarbeiten

Für einfache Bearbeitungen oder zum Vorpositionieren des Werkzeugs eignet sich die Betriebsart Positionieren mit Handeingabe. Hier können Sie ein kurzes Programm im HEIDENHAIN-Klartext-Format oder nach DIN/ISO eingeben und direkt ausführen lassen. Auch Bearbeitungs- und Tastsystem-Zyklen, sowie einige Sonderfunktionen (Taste SPEC FCT) der TNC lassen stehen im MDI-Betrieb zur Verfügung. Die TNC speichert das Programm automatisch in der Datei $MDI. Beim Positionieren mit Handeingabe lässt sich die zusätzliche Status-Anzeige aktivieren.

Weitere Informationen:
> Positionieren mit Handeingabe anwenden
> Programme aus $MDI sichern oder löschen


Positionieren mit Handeingabe anwenden

Betriebsart Positionieren mit Handeingabe wählen. Die Datei $MDI mit den verfügbaren Funktionen programmieren

Programmlauf starten: Externe START-Taste

Einschränkungen:

Die Freie Kontur-Programmierung FK, die Programmier-Grafiken und Programmlauf-Grafiken stehen nicht zur Verfügung.

Die Datei $MDI darf keinen Programm-Aufruf enthalten (%).

Beispiel 1

Ein einzelnes Werkstück soll mit einer 20 mm tiefen Bohrung versehen werden. Nach dem Aufspannen des Werkstücks, dem Ausrichten und Bezugspunkt-Setzen lässt sich die Bohrung mit wenigen Programmzeilen programmieren und ausführen.

Zuerst wird das Werkzeug mit Geraden-Sätzen über dem Werkstück vorpositioniert und auf einen Sicherheitsabstand von 5 mm über dem Bohrloch positioniert. Danach wird die Bohrung mit dem Zyklus G200 ausgeführt.

%$mdi g71 * |
n10 t1 g17 s2000 * | Werkzeug aufrufen: Werkzeugachse Z,
 | Spindeldrehzahl 2000 U/min
n20 g00 g40 g90 z+200 * | Werkzeug freifahren (Eilgang)
n30 x+50 y+50 m3 * | Werkzeug im Eilgang über Bohrloch positionieren,
 | Spindel ein
n40 g01 z+2 f2000 * | Werkzeug 2 mm über Bohrloch positionieren
n50 g200 BOHREN * | Zyklus G200 Bohren definieren
Q200=2 ;sicherheits-abst. | Sicherheitsabstand des Wkz über Bohrloch
Q201=-20 ;tiefe | Tiefe des Bohrlochs (Vorzeichen=Arbeitsrichtung)
Q206=250 ;f tiefenzust. | Bohrvorschub
Q202=10 ;zustell-tiefe | Tiefe der jeweiligen Zustellung vor dem Rückzug
Q210=0 ;F.-zeit oben | Verweilzeit oben beim Entspanen in Sekunden
Q203=+0 ;koor. oberfl. | Koordinate Oberkante Werkstück
Q204=50 ;2. s.-abstand | Position nach dem Zyklus, bezogen auf Q203
Q211=0.5 ;verweilzeit unten | Verweilzeit am Bohrungsgrund in Sekunden
n60 g79 * | Zyklus G200 Tiefbohren aufrufen
n70 g00 g40 z+200 m2 * | Werkzeug freifahren
n9999999 %$mdi g71 * | Programm-Ende

Geraden-Funktion: Siehe Gerade im Eilgang G00 Gerade mit Vorschub G01 F, Zyklus BOHREN: Siehe Benutzer-Handbuch Zyklen, Zyklus 200 BOHREN.

Beispiel 2: Werkstück-Schieflage bei Maschinen mit Rundtisch beseitigen
Grunddrehung mit Tastsystem durchführen. Siehe Benutzer-Handbuch Tastsystem-Zyklen, „Tastsystem-Zyklen in den Betriebsarten Manueller Betrieb und El. Handrad“, Abschnitt „Werkstück-Schieflage kompensieren“.
Drehwinkel notieren und Grunddrehung wieder aufheben
 | Betriebsart wählen: Positionieren mit Handeingabe
 | Rundtischachse wählen, notierten Drehwinkel und Vorschub eingeben z.B. G01 G40 G90 C+2.561 F50
 | Eingabe abschließen
 | NC-Start-Taste drücken: Schieflage wird durch Drehung des Rundtischs beseitigt


Programme aus $MDI sichern oder löschen

Die Datei $MDI wird gewöhnlich für kurze und vorübergehend benötigte Programme verwendet. Soll ein Programm trotzdem gespeichert werden, gehen Sie wie folgt vor:

 | Betriebsart wählen: Programm- Einspeichern/Editieren
 | Datei-Verwaltung aufrufen: Taste PGM MGT (Program Management)
 | Datei $MDI markieren
 | „Datei kopieren“ wählen: Softkey KOPIEREN
Ziel-Datei =
 | Geben Sie einen Namen ein, unter dem der aktuelle Inhalt der Datei $MDI gespeichert werden soll
 | Kopieren ausführen
 | Datei-Verwaltung verlassen: Softkey ENDE

Zum Löschen des Inhalts der Datei $MDI gehen Sie ähnlich vor: Anstatt sie zu kopieren, löschen Sie den Inhalt mit dem Softkey LÖSCHEN. Beim nächsten Wechsel in die Betriebsart Positionieren mit Handeingabe zeigt die TNC eine leere Datei $MDI an.

    Wenn Sie $MDI löschen wollen, dann

  • dürfen Sie die Betriebsart Positionieren mit Handeingabe nicht angewählt haben (auch nicht im Hintergrund)
  • dürfen Sie die Datei $MDI in der Betriebsart Programm Einspeichern/Editieren nicht angewählt haben

Weitere Informationen: siehe Einzelne Datei kopieren.


Programm-Test und Programmlauf

Weitere Informationen:
> Grafiken
> Funktionen zur Programmanzeige
> Programm-Test
> Programmlauf
> Automatischer Programmstart
> Sätze überspringen
> Wahlweiser Programmlauf-Halt


Grafiken

Weitere Informationen:
> Anwendung
> Übersicht: Ansichten
> Draufsicht
> Darstellung in 3 Ebenen
> 3D-Darstellung
> Ausschnitts-Vergrößerung
> Grafische Simulation wiederholen
> Werkzeug anzeigen
> Bearbeitungszeit ermitteln


Anwendung

    In den Programmlauf-Betriebsarten und der Betriebsart Programm-Test simuliert die TNC eine Bearbeitung grafisch. Über Softkeys wählen sie, ob als

  • Draufsicht
  • Darstellung in 3 Ebenen
  • 3D-Darstellung

Die TNC-Grafik entspricht der Darstellung eines Werkstücks, das mit einem zylinderförmigen Werkzeug bearbeitet wird. Bei aktiver Werkzeug-Tabelle können Sie die Bearbeitung mit einem Radiusfräser darstellen lassen. Geben Sie dazu in der Werkzeug-Tabelle R2 = R ein.

    Die TNC zeigt keine Grafik, wenn

  • das aktuelle Programm keine gültige Rohteil-Definition enthält
  • kein Programm angewählt ist

Mit der neuen 3D-Grafik können Sie in der Betriebsart Programm-Test auch Bearbeitungen in der geschwenkten Bearbeitungsebene und Mehrseiten-Bearbeitungen grafisch darstellen, nachdem Sie das Programm in einer anderen Ansicht simuliert haben. Um diese Funktion nutzen zu können, benötigen Sie zumindest die Hardware MC 422 B. Um bei älteren Hardware-Versionen die Geschwindigkeit der Test-Grafik zu beschleunigen, sollten Sie das Bit 5 des Maschinen-Parameters 7310 = 1 setzen. Dadurch werden Funktionen, die speziell für die neue 3D-Grafik implementiert wurden, deaktiviert.

Die TNC stellt ein im T-Satz programmiertes Radius-Aufmaß DR nicht in der Grafik dar.

Weitere Informationen:
> Grafische Simulation bei Sonderanwendungen
> Geschwindigkeit des Programm-Tests einstellen


Grafische Simulation bei Sonderanwendungen

Im Normalfall enthalten NC-Programme einen Werkzeug-Aufruf, der über die definierte Werkzeug-Nummer automatisch auch die Werkzeug-Daten für die grafische Simulation bestimmt.

Für Sonderanwendungen, die keine Werkzeug-Daten benötigen (z.B. Laserschneiden, Laserbohren oder Wasserstrahlschneiden) können Sie die Maschinen-Parameter 7315 bis 7317 so einstellen, dass die TNC auch dann eine grafische Simulation durchführen soll, wenn Sie keine Werkzeug-Daten aktiviert haben. Sie benötigen jedoch grundsätzlich immer einen Werkzeug-Aufruf mit Definition der Werkzeug-Achsrichtung (z.B. g17), die Eingabe einer Werkzeug-Nummer ist nicht erforderlich.


Geschwindigkeit des Programm-Tests einstellen

Die Geschwindigkeit beim Programm-Test können Sie nur dann einstellen, wenn Sie die Funktion „Bearbeitungszeit anzeigen“ aktiv haben (siehe Stoppuhr-Funktion anwählen). Ansonsten führt die TNC den Programm-Test immer mit maximal möglicher Geschwindigkeit aus.

Die zuletzt eingestellte Geschwindigkeit bleibt so lange aktiv (auch über eine Stromunterbrechung hinaus), bis Sie diese erneut verstellen.

Nachdem Sie ein Programm gestartet haben, zeigt die TNC folgende Softkeys, mit der Sie die Simulations-Geschwindigkeit einstellen können:

Funktionen | Softkey
Programm mit der Geschwindigkeiten testen, mit der es auch abgearbeitet wird (programmierte Vorschübe werden berücksichtigt) |
Testgeschwindigkeit schrittweise erhöhen |
Testgeschwindigkeit schrittweise verkleinern |
Programm mit maximal möglicher Geschwindigkeit testen (Grundeinstellung) |

Sie können die Simulations-Geschwindigkeit auch einstellen, bevor Sie ein Programm starten:

Softkeyleiste weiterschalten

Funktionen zur Einstellung der Simulationsgeschwindigkeit wählen

Gewünschte Funktion per Softkey wählen, z.B. Testgeschwindigkeit schrittweise erhöhen


Übersicht: Ansichten

In den Programmlauf-Betriebsarten und in der Betriebsart
Programm-Test zeigt die TNC folgende Softkeys:

Ansicht | Softkey
Draufsicht |
Darstellung in 3 Ebenen |
3D-Darstellung |
Weitere Informationen:
> Einschränkung während des Programmlaufs


Einschränkung während des Programmlaufs

Die Bearbeitung lässt sich nicht gleichzeitig grafisch darstellen, wenn der Rechner der TNC durch komplizierte Bearbeitungsaufgaben oder großflächige Bearbeitungen bereits ausgelastet ist. Beispiel: Abzeilen über das ganze Rohteil mit großem Werkzeug. Die TNC führt die Grafik nicht mehr fort und blendet den Text ERROR im Grafik-Fenster ein. Die Bearbeitung wird jedoch weiter ausgeführt.

Die TNC stellt in der Programmlaufgrafik Mehrachsbearbeitungen während des Abarbeitens nicht grafisch dar. Im Grafikfenster erscheint in solchen Fällen die Fehlermeldung Achse nicht darstellbar.


Draufsicht

Die grafische Simulation in dieser Ansicht läuft am schnellsten ab.

Sofern Sie eine Mouse an Ihrer Maschine verfügbar haben, können Sie durch Positionieren des Mousezeigers über eine beliebige Stelle des Werkstücks, die Tiefe an dieser Stelle in der Statuszeile ablesen.

Draufsicht mit Softkey wählen

Für die Tiefendarstellung dieser Grafik gilt: Je tiefer, desto dunkler


Darstellung in 3 Ebenen

Die Darstellung zeigt eine Draufsicht mit 2 Schnitten, ähnlich einer technischen Zeichnung. Ein Symbol links unter der Grafik gibt an, ob die Darstellung der Projektionsmethode 1 oder der Projektionsmethode 2 nach DIN 6, Teil 1 entspricht (über MP7310 wählbar).

Bei der Darstellung in 3 Ebenen stehen Funktionen zur Ausschnitts-Vergrößerung zur Verfügung, siehe Ausschnitts-Vergrößerung.

Zusätzlich können Sie die Schnittebene über Softkeys verschieben.:

Wählen Sie den Softkey für die Darstellung des Werkstücks in 3 Ebenen

Softkey-Leiste umschalten, bis der Auswahl-Softkey für die Funktionen zum Verschieben der Schnittebene erscheint

Funktionen zum Verschieben der Schnittebene wählen: Die TNC zeigt folgende Softkeys

Funktion | Softkeys
Vertikale Schnittebene nach rechts oder links verschieben |
Vertikale Schnittebene nach vorne oder hinten verschieben |
Horizontale Schnittebene nach oben oder unten verschieben |

Die Lage der Schnittebene ist während des Verschiebens am Bildschirm sichtbar.

Die Grundeinstellung der Schnittebene ist so gewählt, dass sie in der Bearbeitungsebene in der Werkstück-Mitte liegt und in der Werkzeug-Achse auf der Werkstück-Oberkante.

Weitere Informationen:
> Koordinaten der Schnittlinie


Koordinaten der Schnittlinie

Die TNC blendet die Koordinaten der Schnittlinie, bezogen auf den Werkstück-Nullpunkt unten im Grafik-Fenster ein. Angezeigt werden nur Koordinaten in der Bearbeitungsebene. Diese Funktion aktivieren Sie mit Maschinen-Parameter 7310.


3D-Darstellung

Die TNC zeigt das Werkstück räumlich. Wenn Sie über eine entsprechende Hardware verfügen, dann stellt die TNC in der hochauflösenden 3D-Grafik auch Bearbeitungen in der geschwenkten Bearbeitungsebene und Mehrseitenbearbeitungen grafisch dar.

Die 3D-Darstellung können Sie per Softkeys um die vertikale Achse drehen und um die horizontale Achse kippen. Sofern Sie eine Mouse an ihre TNC angeschlossen haben, können Sie durch gedrückt halten der rechten Mouse-Taste diese Funktion ebenso ausführen.

Die Umrisse des Rohteils zu Beginn der grafischen Simulation können Sie als Rahmen anzeigen lassen.

In der Betriebsart Programm-Test stehen Funktionen zur Ausschnitts-Vergrößerung zur Verfügung, siehe Ausschnitts-Vergrößerung.

3D-Darstellung mit Softkey wählen. Durch zweimaliges Drücken des Softkeys schalten Sie um auf die hochauflösende 3D-Grafik. Die Umschaltung ist nur möglich, wenn die Simulation bereits beendet ist. Die hochauflösende Grafik zeigt detaillierter die Oberfläche des bearbeiteten Werkstücks an.

Die Geschwindigkeit der 3D-Grafik hängt von der Schneidlänge (Spalte LCUTS in der Werkzeug-Tabelle) ab. Ist LCUTS mit 0 definiert (Grundeinstellung), dann rechnet die Simulation mit einer unendlich langen Schneidlänge, was zu hohen Rechenzeit führt. Sofern Sie kein LCUTS definieren wollen, können Sie den Maschinen-Parameter 7312 auf einen Wert zwischen 5 und 10 setzen. Dadurch begrenzt die TNC intern die Schneidlänge auf einen Wert, der sich errechnet aus MP7312 mal Werkzeug-Durchmesser.

Weitere Informationen:
> 3D-Darstellung drehen und vergrößern/verkleinern
> Rahmen für die Umrisse des Rohteils ein- und ausblenden


3D-Darstellung drehen und vergrößern/verkleinern

Softkey-Leiste umschalten, bis der Auswahl-Softkey für die Funktionen Drehen und Vergrößern/Verkleinern erscheint

Funktionen zum Drehen und Vergrößern/Verkleinern wählen:

Funktion | Softkeys
Darstellung in 5°-Schritten vertikal drehen |
Darstellung in 5°-Schritten horizontal kippen |
Darstellung schrittweise vergrößern. Ist die Darstellung vergrößert, zeigt die TNC in der Fußzeile des Grafikfensters den Buchstaben Z an |
Darstellung schrittweise verkleinern. Ist die Darstellung verkleinert, zeigt die TNC in der Fußzeile des Grafikfensters den Buchstaben Z an |
Darstellung auf programmierte Größe rücksetzen |

Sie können die 3D-Grafik auch mit der Mouse bedienen. Folgende Funktionen stehen zur Verfügung:

  • Um die dargestellte Grafik dreidimensional zu drehen: rechte Mouse-Taste gedrückt halten und Mouse bewegen. Die TNC zeigt ein Koordinatensystem an, das die momentan aktive Ausrichtung des Wekstückes darstellt. Nachdem Sie die rechte Mouse-Taste losgelassen haben, orientiert die TNC das Werkstück auf die definierte Ausrichtung

  • Um die dargestellte Grafik zu verschieben: mittlere Mouse-Taste, bzw. Mouse-Rad, gedrückt halten und Mouse bewegen. Die TNC verschiebt das Werkstück in die entsprechende Richtung. Nachdem Sie die mittlere Mouse-Taste losgelassen haben, verschiebt die TNC das Werkstück auf die definierte Position

  • Um mit der Mouse einen bestimmten Bereich zu zoomen: mit gedrückter linker Mouse-Taste den rechteckigen Zoom-Bereich markieren, Sie können den Zoom-Bereich durch horizontales und vertikales Bewegen der Mouse noch verschieben. Nachdem Sie die linke Mouse-Taste losgelassen haben, vergrößert die TNC das Werkstück auf den definierten Bereich

  • Um mit der Mouse schnell aus- und einzuzoomen: Mouserad vor bzw. zurückdrehen

  • Doppelklick mit der rechten Mouse-Taste: Standardansicht anwählen


Rahmen für die Umrisse des Rohteils ein- und ausblenden

  • Softkey-Leiste umschalten, bis der Auswahl-Softkey für die Funktionen Drehen und Vergrößern/Verkleinern erscheint

Funktionen zum Drehen und Vergrößern/Verkleinern wählen:

Rahmen für BLK-FORM einblenden: Hellfeld im Softkey auf ANZEIGEN stellen

Rahmen für BLK-FORM ausblenden: Hellfeld im Softkey auf AUSBLEND. stellen


Ausschnitts-Vergrößerung

Den Ausschnitt können Sie in der Betriebsart Programm-Test und in einer Programmlauf-Betriebsart in allen Ansichten verändern.

Dafür muss die grafische Simulation bzw. der Programmlauf gestoppt sein. Eine Ausschnitts-Vergrößerung ist immer in allen Darstellungsarten wirksam.

Weitere Informationen:
> Ausschnitts-Vergrößerung ändern
> Cursor-Position bei der Ausschnitts-Vergrößerung


Ausschnitts-Vergrößerung ändern

Softkeys siehe Tabelle

  • Falls nötig, grafische Simulation stoppen

  • Softkey-Leiste in der Betriebsart Programm-Test bzw. in einer Programmlauf-Betriebsart umschalten, bis der Auswahl-Softkey für die Ausschnitt-Vergrößerung erscheint

Softkey-Leiste umschalten, bis der Auswahl-Softkey mit Funktionen zur Auschnitts-Vergrößerung erscheint

Funktionen zur Auschnitts-Vergrößerung wählen

Werkstückseite mit Softkey (siehe Tabelle unten) wählen

Rohteil verkleinern oder vergrößern: Softkey „–“ bzw. „+“ gedrückt halten

Programm-Test oder Programmlauf neu starten mit Softkey START (RESET + START stellt das ursprüngliche Rohteil wieder her)

Funktion | Softkeys
Linke/rechte Werkstückseite wählen |
Vordere/hintere Werkstückseite wählen |
Obere/untere Werkstückseite wählen |
Schnittfläche zum Verkleinern oder Vergrößern des Rohteils verschieben |
Ausschnitt übernehmen |


Cursor-Position bei der Ausschnitts-Vergrößerung

Die TNC zeigt während einer Ausschnitts-Vergrößerung die Koordinaten der Achse an, die Sie gerade beschneiden. Die Koordinaten entsprechen dem Bereich, der für die Ausschnitts-Vergrößerung festgelegt ist. Links vom Schrägstrich zeigt die TNC die kleinste Koordinate des Bereichs (MIN-Punkt), rechts davon die größte (MAX-Punkt).

Bei einer vergrößerten Abbildung blendet die TNC unten rechts am Bildschirm MAGN ein.

Wenn die TNC das Rohteil nicht weiter verkleinern bzw. vergrößern kann, blendet die Steuerung eine entsprechende Fehlermeldung ins Grafik-Fenster ein. Um die Fehlermeldung zu beseitigen, vergrößern bzw. verkleinern Sie das Rohteil wieder.


Grafische Simulation wiederholen

Ein Bearbeitungs-Programm lässt sich beliebig oft grafisch simulieren. Dafür können Sie die Grafik wieder auf das Rohteil oder einen vergrößerten Ausschnitt aus dem Rohteil zurücksetzen.

Funktion | Softkey
Unbearbeitetes Rohteil in der zuletzt gewählten Ausschnitts-Vergrößerung anzeigen |
Ausschnitts-Vergrößerung zurücksetzen, so dass die TNC das bearbeitete oder unbearbeitete Werkstück gemäß programmierter BLK-Form anzeigt |

Mit dem Softkey ROHTEIL WIE BLK FORM zeigt die TNC – auch nach einem Ausschnitt ohne AUSSCHN. ÜBERNEHM. – das Rohteil wieder in programmierter Größe an.


Werkzeug anzeigen

In der Draufsicht und in der Darstellung in 3 Ebenen können Sie sich das Werkzeug während der Simulation anzeigen lassen. Die TNC stellt das Werkzeug in dem Durchmesser dar, der in der Werkzeug-Tabelle definiert ist.

Funktion | Softkey
Werkzeug bei der Simulation nicht anzeigen |
Werkzeug bei der Simulation anzeigen |


Bearbeitungszeit ermitteln

Weitere Informationen:
> Programmlauf-Betriebsarten
> Programm-Test
> Stoppuhr-Funktion anwählen


Programmlauf-Betriebsarten

Anzeige der Zeit vom Programm-Start bis zum Programm-Ende. Bei Unterbrechungen wird die Zeit angehalten.


Programm-Test

    Die TNC berücksichtigt für die Zeitberechnung folgende Punkte:

  • Verfahrbewegungen mit Vorschub
  • Verweilzeiten
  • Einstellungen zur Maschinen-Dynamik (Beschleunigungen, Filtereinstellungen, Bewegungsführung)

Die von der TNC ermittelte Zeit berücksichtigt keine Eilgangbewegungen und maschinenabhängigen Zeiten (z.B. für Werkzeug-Wechsel).

Wenn Sie Bearbeitungszeit ermitteln auf eingestellt haben, können Sie sich eine Datei erzeugen lassen, in der die Einsatzzeiten aller in einem Programm verwendeten Werkzeuge aufgeführt sind (siehe Werkzeug-Einsatzprüfung).


Stoppuhr-Funktion anwählen

Softkey-Leiste umschalten, bis der Auswahl-Softkey für die Stoppuhr-Funktionen erscheint

Stoppuhr-Funktionen wählen

Gewünschte Funktion per Softkey wählen, z.B. angezeigte zeit speichern

Stoppuhr-Funktionen | Softkey
Funktion Bearbeitungszeit ermitteln einschalten (EIN)/ausschalten (AUS) |
Angezeigte Zeit speichern |
Summe aus gespeicherter und angezeigter Zeit anzeigen |
Angezeigte Zeit löschen |

Die TNC setzt während des Programm-Tests die Bearbeitungszeit zurück, sobald ein neues Rohteil G30/G31 abgearbeitet wird.


Funktionen zur Programmanzeige

Weitere Informationen:
> Übersicht


Übersicht

In den Programmlauf-Betriebsarten und der Betriebsart Programm-Test zeigt die TNC Softkeys, mit denen Sie das Bearbeitungs-Programm seitenweise anzeigen lassen können:

Funktionen | Softkey
Im Programm um eine Bildschirm-Seite zurückblättern |
Im Programm um eine Bildschirm-Seite vorblättern |
Programm-Anfang wählen |
Programm-Ende wählen |


Programm-Test

Weitere Informationen:
> Anwendung


Anwendung

    In der Betriebsart Programm-Test simulieren Sie den Ablauf von Programmen und Programmteilen, um Programmierfehler im Programmlauf zu reduzieren. Die TNC unterstützt Sie beim Auffinden von

  • geometrischen Unverträglichkeiten
  • fehlenden Angaben
  • nicht ausführbaren Sprüngen
  • Verletzungen des Arbeitsraums
  • Kollisionen zwischen kollisionsüberwachten Bauteilen (Software-Option DCM erforderlich, siehe Kollisionsüberwachung in der Betriebsart Programm-Test)

    Zusätzlich können Sie folgende Funktionen nutzen:

  • Programm-Test satzweise
  • Testabbruch bei beliebigem Satz
  • Sätze überspringen
  • Funktionen für die grafische Darstellung
  • Bearbeitungszeit ermitteln
  • Zusätzliche Status-Anzeige

Wenn Ihre Maschine mit der Software-Option DCM (dynamische Kollisionsüberwachung) ausgerüstet ist, können Sie im Programm-Test auch eine Kollisionsprüfung durchführen lassen (siehe Kollisionsüberwachung in der Betriebsart Programm-Test)

Achtung Kollisionsgefahr!

Die TNC kann bei der grafischen Simulation nicht alle tatsächlich von der Maschine ausgeführten Verfahrbewegungen simulieren, z.B.

  • Verfahrbewegungen beim Werkzeugwechsel, die der Maschinenhersteller in einem Werkzeugwechsel-Makro oder über die PLC definiert hat
  • Positionierungen, die der Maschinenhersteller in einem M-Funktions-Makro definiert hat
  • Positionierungen, die der Maschinenhersteller über die PLC ausführt
  • Positionierungen, die einen Palettenwechsel durchführen

HEIDENHAIN empfiehlt daher jedes Programm mit entsprechender Vorsicht einzufahren, auch wenn der Programm-Test zu keiner Fehlermeldung und zu keinen sichtbaren Beschädigungen des Werkstücks geführt hat.

Die TNC startet einen Programm-Test nach einem -Werkzeug-Aufruf grundsätzlich immer auf folgender -Position:

  • In der Bearbeitungsebene in der Mitte des definierten Rohteils
  • In der Werkzeugachse 1 mm überhalb des in der BLK FORM definierten MAX-Punktes

Wenn Sie dasselbe Werkzeug aufrufen, dann simuliert die TNC das Programm weiter von der zuletzt, vor dem Werkzeug-Aufruf programmierten Position.

Um auch beim Abarbeiten ein eindeutiges Verhalten zu haben, sollten Sie nach einem Werkzeugwechsel grundsätzlich eine Position anfahren, von der aus die TNC kollisionsfrei zur Bearbeitung positionieren kann.

Ihr Maschinenhersteller kann auch für die Betriebsart Programm-Test ein Werkzeug-Wechselmakro definieren, dass das Verhalten der Maschine exakt simuliert, Maschinenhandbuch beachten.
Weitere Informationen:
> Programm-Test ausführen
> Programm-Test bis zu einem bestimmten Satz ausführen
> Kinematik für Programm-Test wählen
> Geschwenkte Bearbeitungsebene für Programm-Test einstellen


Programm-Test ausführen

Bei aktivem zentralen Werkzeug-Speicher müssen Sie für den Programm-Test eine Werkzeug-Tabelle aktiviert haben (Status S). Wählen Sie dazu in der Betriebsart Programm-Test über die Datei-Verwaltung (PGM MGT) eine Werkzeug-Tabelle aus.

Mit der MOD-Funktion ROHTEIL IM ARB.-RAUM aktivieren Sie für den Programm-Test eine Arbeitsraum-Überwachung, siehe Rohteil im Arbeitsraum darstellen.

Betriebsart Programm-Test wählen

Datei-Verwaltung mit Taste PGM MGT anzeigen und Datei wählen, die Sie testen möchten oder

Programm-Anfang wählen: Mit Taste GOTO Zeile „0“ wählen und Eingabe mit Taste ENT bestätigen

Die TNC zeigt folgende Softkeys:

Funktionen | Softkey
Rohteil rücksetzen und gesamtes Programm testen |
Gesamtes Programm testen |
Jeden Programm-Satz einzeln testen |
Programm-Test anhalten (Softkey erscheint nur, wenn Sie den Programm-Test gestartet haben) |

    Sie können den Programm-Test zu jeder Zeit – auch innerhalb von Bearbeitungs-Zyklen – unterbrechen und wieder fortsetzen. Um den Test wieder fortsetzen zu können, dürfen Sie folgende Aktionen nicht durchführen:

  • mit den Pfeiltasten oder der Taste GOTO einen anderen Satz wählen
  • Änderungen am Programm durchführen
  • die Betriebsart wechseln
  • ein neues Programm wählen


Programm-Test bis zu einem bestimmten Satz ausführen

Mit STOPP BEI N führt die TNC den Programm-Test nur bis zum Satz mit der Satz-Nummer N durch.

  • In der Betriebsart Programm-Test den Programm-Anfang wählen

  • Programm-Test bis zu bestimmtem Satz wählen: Softkey STOPP BEI N drücken

Stopp bei N: Satz-Nummer eingeben, bei der der Programm-Test gestoppt werden soll

Programm: Name des Programms eingeben, in dem der Satz mit der gewählten Satz-Nummer steht; die TNC zeigt den Namen des gewählten Programms an; wenn der Programm-Stopp in einem mit PGM CALL aufgerufenen Programm stattfinden soll, dann diesen Namen eintragen

Vorlauf bis: P: Wenn Sie in eine Punkte-Tabelle einsteigen wollen, hier die Zeilennummer eingeben, an der Sie einsteigen wollen

Tabelle (PNT): Wenn Sie in eine Punkte-Tabelle einsteigen wollen, hier den Namen der Punkte-Tabelle eingeben, in die Sie einsteigen wollen

Wiederholungen: Anzahl der Wiederholungen eingeben, die durchgeführt werden sollen, falls N innerhalb einer Programmteil-Wiederholung steht

Programm-Abschnitt testen: Softkey START drücken; die TNC testet das Programm bis zum eingegebenen Satz


Kinematik für Programm-Test wählen

Diese Funktion muss von Ihrem Maschinenhersteller freigegeben werden.

Diese Funktion können Sie verwenden um Programme zu testen, deren Kinematik nicht mit der aktiven Maschinenkinematik übereinstimmt (z.B. an Maschinen mit Kopfwechsel oder Verfahrbereichsumschaltung).

Sofern Ihr Maschinenhersteller unterschiedliche Kinematiken auf Ihrer Maschine hinterlegt hat, können Sie über die MOD-Funktion eine dieser Kinematiken für den Programm-Test aktivieren. Die aktive Maschinenkinematik bleibt davon unberührt.

Betriebsart Programm-Test wählen

Programm wählen, dass Sie testen wollen

MOD-Funktion wählen

Verfügbare Kinematiken in einem Überblendfenster anzeigen lassen, ggf. zuvor Softkey-Leiste umschalten

Gewünschte Kinematik mit Pfeiltasten wählen und mit Taste ENT übernehmen

Nach dem Einschalten der Steuerung ist in der Betriebsart Programm-Test grundsätzlich die Maschinenkinematik aktiv. Kinematik für Programm-Test ggf. nach dem Einschalten erneut wählen.

Wenn Sie über das Schlüsselwort kinematic eine Kinematik wählen, dann schaltet die TNC die Maschinenkinematik und die Testkinematik um.


Geschwenkte Bearbeitungsebene für Programm-Test einstellen

Diese Funktion muss von Ihrem Maschinenhersteller freigegeben werden.

Diese Funktion können Sie an Maschinen verwenden, an denen Sie die Bearbeitungsebene durch manuelles Einstellen der Maschinenachsen definieren wollen.

Betriebsart Programm-Test wählen

Programm wählen, dass Sie testen wollen

MOD-Funktion wählen

Menü zur Definition der Bearbeitungsebene wählen

Mit Taste ENT die Funktion aktivieren bzw. deaktivieren

Aktive Drehachskoordinaten aus der Maschinenbetriebsart übernehmen, oder

Hellfeld per Pfeiltaste auf gewünschte Drehachse positionieren und Drehachswert eingeben, den die TNC bei der Simulation verrechnen soll

Wenn diese Funktion von Ihrem Maschinenhersteller freigegeben ist, dann deaktiviert die TNC die Funktion Bearbeitungsebene Schwenken nicht mehr, wenn Sie ein neues Programm anwählen.

Wenn Sie ein Programm simulieren, das keinen T-Satz enthält, dann verwendet die TNC als Werkzeug-Achse die Achse, die Sie für das manuelle Antasten in der Betriebsart Manuell aktiviert haben.

Achten Sie darauf, dass die aktive Kinematik im Programm-Test zu dem Programm passt, das Sie testen wollen, ansonsten gibt die TNC ggf. Fehler aus.


Programmlauf

Weitere Informationen:
> Anwendung
> Bearbeitungs-Programm ausführen
> Bearbeitung unterbrechen
> Maschinenachsen während einer Unterbrechung verfahren
> Programmlauf nach einer Unterbrechung fortsetzen
> Beliebiger Einstieg ins Programm (Satzvorlauf)
> Wiederanfahren an die Kontur


Anwendung

In der Betriebsart Programmlauf Satzfolge führt die TNC ein Bearbeitungs-Programm kontinuierlich bis zum Programm-Ende oder bis zu einer Unterbrechung aus.

In der Betriebsart Programmlauf Einzelsatz führt die TNC jeden Satz nach Drücken der externen START-Taste einzeln aus.

    Die folgenden TNC-Funktionen können Sie in den Programmlauf-Betriebsarten nutzen:

  • Programmlauf unterbrechen
  • Programmlauf ab bestimmtem Satz
  • Sätze überspringen
  • Werkzeug-Tabelle TOOL.T editieren
  • Q-Parameter kontrollieren und ändern
  • Handrad-Positionierung überlagern
  • Funktionen für die grafische Darstellung
  • Zusätzliche Status-Anzeige


Bearbeitungs-Programm ausführen

Vorbereitung
  1. Werkstück auf dem Maschinentisch aufspannen
  2. Bezugspunkt setzen
  3. Benötigte Tabellen und Paletten–Dateien wählen (Status M)
  4. Bearbeitungs-Programm wählen (Status M)

Vorschub und Spindeldrehzahl können Sie mit den Override-Drehknöpfen ändern.

Über den Softkey FMAX können Sie die Vorschub-Geschwindigkeit reduzieren, wenn Sie das NC-Programm einfahren wollen. Die Reduzierung gilt für alle Eilgang- und Vorschubbewegungen. Der von Ihnen eingegebene Wert ist nach dem Aus- /Einschalten der Maschine nicht mehr aktiv. Um die jeweils festgelegte maximale Vorschub-Geschwindigkeit nach dem Einschalten wiederherzustellen, müssen Sie den entsprechenden Zahlenwert erneut eingeben.

Stellen Sie sicher, dass Sie alle Achsen refernziert haben, bevor Sie den Programmlauf starten. Die TNC stoppt ansonsten die Bearbeitung, sobald sie einen NC-Satz mit einer nicht referenzierten Achse abarbeiten soll.

Programmlauf Satzfolge

  • Bearbeitungs-Programm mit externer Start-Taste starten

Programmlauf Einzelsatz

  • Jeden Satz des Bearbeitungs-Programms mit der externen Start-Taste einzeln starten


Bearbeitung unterbrechen

    Sie haben verschiedene Möglichkeiten, einen Programmlauf zu unterbrechen:

  • Programmierte Unterbrechungen

  • Externe STOPP-Taste

  • Umschalten auf Programmlauf Einzelsatz
  • Programmieren von nicht gesteuerten Achsen (Zählerachsen)

Registriert die TNC während eines Programmlaufs einen Fehler, so unterbricht sie die Bearbeitung automatisch.

Programmierte Unterbrechungen

    Unterbrechungen können Sie direkt im Bearbeitungs-Programm festlegen. Die TNC unterbricht den Programmlauf, sobald das Bearbeitungs-Programm bis zu dem Satz ausgeführt ist, der eine der folgenden Eingaben enthält:

  • G38 (mit und ohne Zusatzfunktion)

  • Zusatzfunktion M0, M2 oder M30
  • Zusatzfunktion M6 (wird vom Maschinenhersteller festgelegt)
Unterbrechung durch externe STOPP-Taste

  • Externe STOPP-Taste drücken: Der Satz, den die TNC zum Zeitpunkt des Tastendrucks abarbeitet, wird nicht vollständig ausgeführt; in der Status-Anzeige blinkt das „*“-Symbol

  • Wenn Sie die Bearbeitung nicht fortführen wollen, dann die TNC mit dem Softkey INTERNER STOPP zurücksetzen: das „*“-Symbol in der Status-Anzeige erlischt. Programm in diesem Fall vom Programm-Anfang aus erneut starten

Bearbeitung unterbrechen durch Umschalten auf Betriebsart -Programmlauf Einzelsatz

Während ein Bearbeitungs-Programm in der Betriebsart Programmlauf Satzfolge abgearbeitet wird, Programmlauf Einzelsatz wählen. Die TNC unterbricht die Bearbeitung, nachdem der aktuelle Bearbeitungsschritt ausgeführt wurde.

Sprünge im Programm nach einer Unterbrechung

Wenn Sie ein Programm mit der Funktion INTERNER STOPP unterbrochen haben, merkt sich die TNC den aktuellen Bearbeitungszustand. Sie können dann die Bearbeitung in der Regel mit NC-Start wieder fortsetzen. Wenn Sie mit der Taste GOTO andere Programmzeilen anwählen, setzt die TNC modal wirksame Funktionen (z.B. M136) nicht zurück. Das kann zu unerwünschten Effekten, wie z.B. fehlerhaften Vorschüben, führen.

Achtung Kollisionsgefahr!

Beachten Sie, dass Programmsprünge mit der GOTO-Funktion modale Funktionen nicht zurücksetzen

Programm-Anfang nach einer Unterbrechung immer über Neuanwahl des Programms ausführen (Taste PGM MGT).

Programmieren von nicht gesteuerten Achsen (Zählerachsen)

Diese Funktion muss von Ihrem Maschinenhersteller angepasst werden. Beachten Sie Ihr Maschinenhandbuch.

Die TNC unterbricht den Programmlauf automatisch, sobald in einem Verfahrsatz eine Achse programmiert ist, die vom Maschinenhersteller als nicht gesteuerte Achse (Zählerachse) definiert wurde. In diesem Zustand können Sie die nicht gesteuerte Achse manuell auf die gewünschte Position fahren. Die TNC zeigt dabei im linken Bildschirmfenster alle anzufahrenden Sollpositionen an, die in diesem Satz programmiert sind. Bei nicht gesteuerten Achsen zeigt die TNC zusätzlich den Restweg an.

Sobald in allen Achsen die richtige Position erreicht ist, können Sie den Programlauf mit NC-Start fortsetzen.

Die gewünschte Anfahrfolge wählen und jeweils mit NC-Start ausführen. Nicht gesteuerte Achsen manuell positionieren, die TNC zeigt den noch verbleibenden Restweg in dieser Achse mit an (siehe Wiederanfahren an die Kontur)

Bei Bedarf wählen, ob gesteuerte Achsen im geschwenkten oder im ungeschwenkten Koordinatensystem verfahren werden sollen

Bei Bedarf gesteuerte Achsen per Handrad oder per Achsrichtungs-Taste verfahren


Maschinenachsen während einer Unterbrechung verfahren

Sie können die Maschinenachsen während einer Unterbrechung wie in der Betriebsart Manueller Betrieb verfahren.

Kollisionsgefahr!

Wenn sie bei geschwenkter Bearbeitungsebene den Programmlauf unterbrechen, können Sie mit dem Softkey 3D rot das Koordinatensystem zwischen geschwenkt/ungeschwenkt und aktive Werkzeugachs-Richtung umschalten.

Die Funktion der Achsrichtungstasten, des Handrads und der Wiederanfahrlogik werden dann von der TNC entsprechend ausgewertet. Achten Sie beim Freifahren darauf, dass das richtige Koordinatensystem aktiv ist, und die Winkelwerte der Drehachsen ggf. im 3D-ROT-Menü eingetragen sind.

Anwendungsbeispiel: Freifahren der Spindel nach Werkzeugbruch

  • Bearbeitung unterbrechen

  • Externe Richtungstasten freigeben: Softkey MANUEL VERFAHREN drücken

  • Ggf. per Softkey 3D ROT das Koordinatensystem aktivieren, in dem Sie verfahren wollen

  • Maschinenachsen mit externen Richtungstasten verfahren

Bei einigen Maschinen müssen Sie nach dem Softkey MANUEL VERFAHREN die externe START-Taste zur Freigabe der externen Richtungstasten drücken. Beachten Sie Ihr Maschinenhandbuch.

Ihr Maschinenhersteller kann festlegen, dass Sie die Achsen bei einer Programm-Unterbrechung immer im momentan aktiven, ggf. also im geschwenkten, Koordinatensystem verfahren. Beachten Sie Ihr Maschinenhandbuch.


Programmlauf nach einer Unterbrechung fortsetzen

Wenn Sie den Programmlauf während eines Bearbeitungszyklus unterbrechen, müssen Sie beim Wiedereinstieg mit dem Zyklusanfang fortfahren. Bereits ausgeführte Bearbeitungsschritte muss die TNC dann erneut abfahren.

Wenn Sie den Programmlauf innerhalb einer Programmteil-Wiederholung oder innerhalb eines Unterprogramms unterbrechen, müssen Sie mit der Funktion VORLAUF ZU SATZ N die Unterbrechungsstelle wieder anfahren.

    Die TNC speichert bei einer Programmlauf-Unterbrechung

  • die Daten des zuletzt aufgerufenen Werkzeugs
  • aktive Koordinaten-Umrechnungen (z.B. Nullpunkt-Verschiebung, Drehung, Spiegelung)
  • die Koordinaten des zuletzt definierten Kreismittelpunkts

Beachten Sie, dass die gespeicherten Daten solange aktiv bleiben, bis Sie sie zurücksetzen (z.B. indem Sie ein neues Programm anwählen).

Die TNC nutzt gespeicherte Daten für das Wiederanfahren an die Kontur nach manuellem Verfahren der Maschinenachsen während einer Unterbrechung (Softkey POSITION ANFAHREN).

Programmlauf mit START-Taste fortsetzen

    Nach einer Unterbrechung können Sie den Programmlauf mit der externen START-Taste fortsetzen, wenn Sie das Programm auf folgende Art angehalten haben:

  • Externe STOPP-Taste gedrückt

  • Programmierte Unterbrechung
Programmlauf nach einem Fehler fortsetzen

  • Fehlerursache beseitigen

  • Fehlermeldung am Bildschirm löschen: Taste CE drücken

  • Neustart oder Programmlauf fortsetzen an der Stelle, an der unterbrochen wurde

Nach einem Steuerungsabsturz

  • Taste END zwei Sekunden gedrückt halten, TNC führt einen Warmstart aus

  • Fehlerursache beseitigen

  • Neustart

Bei wiederholtem Auftreten des Fehlers notieren Sie bitte die Fehlermeldung und benachrichtigen den Kundendienst.


Beliebiger Einstieg ins Programm (Satzvorlauf)

Die Funktion VORLAUF ZU SATZ N muss vom Maschinenhersteller freigegeben und angepasst werden. Beachten Sie Ihr Maschinenhandbuch.

Mit der Funktion VORLAUF ZU SATZ N (Satzvorlauf) können Sie ein Bearbeitungs-Programm ab einem frei wählbaren Satz N abarbeiten. Die Werkstück-Bearbeitung bis zu diesem Satz wird von der TNC rechnerisch berücksichtigt. Sie kann von der TNC grafisch dargestellt werden. Wenn Sie auf eine Bearbeitungs-Position innerhalb einer smarT.NC Punkte-Tabelle (.HP) einsteigen, dann können Sie die Einstiegs-Position per Softkey grafisch unterstütz wählen. Beim Einstieg in eine Punkte-Tabelle mit der Dateiendung .PNT, stellt die TNC keine grafische Unterstützung zur Verfügung. Sie können jedoch einen beliebigen Punkt über die Punktenummer als Einstiegsstelle definieren.

Wenn Sie ein Programm mit einem INTERNEN STOPP abgebrochen haben, dann bietet die TNC automatisch den Satz N zum Einstieg an, in dem Sie das Programm abgebrochen haben.

Sofern das Programm durch einen der nachfolgend aufgeführten Umstände unterbrochen wurde, speichert die TNC diesen Unterbrechungspunkt:

  • Durch einen NOT-AUS
  • Durch einen Stromausfall
  • Durch einen Steuerungsabsturz

Nachdem Sie die Funktion Satzvorlauf aufgerufen haben, können Sie über den Softkey letzten SATZ wählen den Unterbrechungspunkt wieder aktivieren und per NC-Start anfahren. Die TNC zeigt dann nach dem Einschalten die Meldung NC-Programm wurde abgebrochen.

Der Satzvorlauf darf nicht in einem Unterprogramm beginnen.

Alle benötigten Programme, Tabellen und Paletten-Dateien müssen in einer Programmlauf-Betriebsart angewählt sein (Status M).

Enthält das Programm bis zum Ende des Satzvorlaufs eine programmierte Unterbrechung, wird dort der Satzvorlauf unterbrochen. Um den Satzvorlauf fortzusetzen, die externe START-Taste drücken.

Nach einem Satzvorlauf müssen Sie das Werkzeug mit der Funktion POSITION ANFAHREN auf die ermittelte Position fahren.

Die Werkzeug-Längenkorrektur wird erst durch den Werkzeug-Aufruf und einen nachfolgenden Positioniersatz wirksam. Das gilt auch dann, wenn Sie nur die Werkzeuglänge geändert haben.

Die Zusatz-Funktionen M142 (modale Programminformationen löschen) und M143 (Grunddrehung löschen) sind bei einem Satzvorlauf nicht erlaubt.

Über Maschinen-Parameter 7680 wird festgelegt, ob der Satzvorlauf bei verschachtelten Programmen im Satz 0 des Hauptprogramms oder im Satz 0 des Programms beginnt, in dem der Programmlauf zuletzt unterbrochen wurde.

Mit dem Softkey 3D rot können Sie das Koordinatensystem zum Anfahren der Einstiegspostion zwischen geschwenkt/ungeschwenkt und aktive Werkzeugachs-Richtung umschalten.

Wenn Sie den Satzvorlauf innerhalb einer Paletten-Tabelle einsetzen wollen, dann wählen Sie zunächst mit den Pfeiltasten in der Paletten-Tabelle das Programm, in das Sie einsteigen wollen und wählen dann direkt den Softkey VORLAUF ZU SATZ N.

Alle Tastsystemzyklen werden bei einem Satzvorlauf von der TNC übersprungen. Ergebnisparameter, die von diesen Zyklen beschrieben werden, enthalten dann ggf. keine Werte.

Die Funktionen M142/M143 und M120 sind bei einem Satzvorlauf nicht erlaubt.

Die TNC löscht vor Start des Satzvorlaufs Verfahrbewegungen, die Sie während des Programms mit M118 (Handradüberlagerung) durchgeführt hatten.

Achtung Kollisionsgefahr!

Aus Sicherheitsgründen nach einem Satzvorlauf grundsätzlich den Restweg auf die Einstiegsposition prüfen!

Wenn Sie einen Satzvorlauf in einem Programm ausführen, das M128 enthält, führt die TNC ggf. Ausgleichsbewegungen durch. Die Ausgleichsbewegungen werden der Anfahrbewegung überlagert!

Den Satzvorlauf dürfen Sie nicht in Verbindung mit werkzeugorientierter Paletten-Bearbeitung verwenden. Der Widereinstieg kann nur auf ein noch nicht bearbeitetes Werkstück erfolgen!

  • Ersten Satz des aktuellen Programms als Beginn für Vorlauf wählen: GOTO „0“ eingeben.

Satzvorlauf wählen: Softkey SATZVORLAUF drücken

Satznummer: Nummer des Satzes eingeben, bei dem der Vorlauf enden soll

Programm-Name: Namen des Programms eingeben, in das Sie einsteigen wollen. Änderung nur erforderlich, wenn Sie in ein per PGM CALL gerufenes Programm einsteigen wollen.

Punkte-Index: Wenn Sie im Feld Vorlauf bis N eine Satznummer eingegeben haben in der ein CYCL CALL PAT-Satz steht, dann stellt die TNC das Punktemuster im Feld Datei-Vorschau grafisch dar. Über die Softkeys NÄCHSTES ELEMENT bzw. VORHERIGES ELEMENT können Sie die Einstiegs-Position dann grafisch unterstützt wählen, sofern Sie das Vorschaufenster eingeblendet haben (Softkey VORSCHAU auf EIN stellen)

Wiederholungen: Anzahl der Wiederholungen eingeben, die im Satz-Vorlauf berücksichtigt werden sollen, falls Satz N innerhalb einer Programmteil-Wiederholung oder in einem mehrfach aufgerufenen Unterprogramm steht

Satzvorlauf starten: Externe START-Taste drücken

Kontur anfahren (siehe folgenden Abschnitt)

Weitere Informationen:
> Einstieg mit der Taste GOTO


Einstieg mit der Taste GOTO

Achtung Kollisionsgefahr!

Beim Einstieg mit der Taste GOTO Satznummer, führen weder die TNC noch die PLC irgendwelche Funktionen aus, die einen sicheren Einstieg gewährleisten.

Wenn Sie in ein Unterprogramm mit Taste GOTO Satznummer einsteigen, dann überliest die TNC das Unterprogramm-Ende (G98 L0)! In solchen Fällen grundsätzlich mit der Funktion Satzvorlauf einsteigen!


Wiederanfahren an die Kontur

    Mit der Funktion POSITION ANFAHREN fährt die TNC das Werkzeug in folgenden Situationen an die Werkstück-Kontur:

  • Wiederanfahren nach dem Verfahren der Maschinenachsen während einer Unterbrechung, die ohne INTERNER STOPP ausgeführt wurde

  • Wiederanfahren nach einem Vorlauf mit VORLAUF ZU SATZ N, z.B. nach einer Unterbrechung mit INTERNER STOPP

  • Wenn sich die Position einer Achse nach dem Öffnen des Regelkreises während einer Programm-Unterbrechung verändert hat (maschinenabhängig)
  • Wenn in einem Verfahrsatz auch eine ungeregelte Achse programmiert ist (siehe Programmieren von nicht gesteuerten Achsen (Zählerachsen))

  • Wiederanfahren an die Kontur wählen: Softkey POSITION ANFAHREN wählen

  • Ggf. Maschinenstatus wiederherstellen

  • Achsen in der Reihenfolge verfahren, die die TNC am Bildschirm vorschlägt: NC-Start-Taste drücken oder

  • Achsen in beliebiger Reihenfolge verfahren: Softkeys ANFAHREN X, ANFAHREN Z usw. drücken und jeweils mit externer START-Taste aktivieren

  • Bearbeitung fortsetzen: Externe START-Taste drücken


Automatischer Programmstart

Weitere Informationen:
> Anwendung


Anwendung

Um einen automatischen Programmstart durchführen zu können, muss die TNC von Ihrem Maschinenhersteller vorbereitet sein, Maschinen-Handbuch beachten.

Über den Softkey AUTOSTART (siehe Bild rechts oben), können Sie in einer Programmlauf-Betriebsart zu einem eingebbaren Zeitpunkt das in der jeweiligen Betriebsart aktive Programm starten:

Fenster zur Festlegung des Startzeitpunktes einblenden (siehe Bild rechts MItte)

Zeit (Std:Min:Sek): Uhrzeit, zu der das Programm gestartet werden soll

Datum (TT.MM.JJJJ): Datum, an dem das Programm gestartet werden soll

Um den Start zu aktivieren: Softkey AUTOSTART auf EIN stellen


Sätze überspringen

Weitere Informationen:
> Anwendung
> Löschen des „/“-Zeichens


Anwendung

Sätze, die Sie beim Programmieren mit einem „/“-Zeichen gekennzeichnet haben, können Sie beim Programm-Test oder Programmlauf überspringen lassen:

Programm-Sätze mit „/“-Zeichen nicht ausführen oder testen: Softkey auf EIN stellen

Programm-Sätze mit „/“-Zeichen ausführen oder testen: Softkey auf AUS stellen

Diese Funktion wirkt nicht für TOOL DEF-Sätze.

Die zuletzt gewählte Einstellung bleibt auch nach einer Stromunterbrechung erhalten.


Löschen des „/“-Zeichens

  • In der Betriebsart Programm-Einspeichern/Editieren den Satz wählen, bei dem das Ausblendzeichen gelöscht werden soll

„/“-Zeichen löschen


Wahlweiser Programmlauf-Halt

Weitere Informationen:
> Anwendung


Anwendung

Die TNC unterbricht wahlweise den Programmlauf bei Sätzen in denen ein M1 programmiert ist. Wenn Sie M1 in der Betriebsart Programmlauf verwenden, dann schaltet die TNC die Spindel und das Kühlmittel ggf. nicht ab, beachten Sie dazu Ihr Maschinen-Handbuch.

Programmlauf oder Programm-Test bei Sätzen mit M1 nicht unterbrechen: Softkey auf AUS stellen

Programmlauf oder Programm-Test bei Sätzen mit M1 unterbrechen: Softkey auf EIN stellen

M1 wirkt nicht in der Betriebsart Programm-Test.


MOD-Funktionen

Weitere Informationen:
> MOD-Funktion wählen
> Software-Nummern
> Schlüssel-Zahl eingeben
> Service-Packs laden
> Datenschnittstellen einrichten
> Ethernet-Schnittstelle
> PGM MGT konfigurieren
> Maschinenspezifische Anwenderparameter
> Rohteil im Arbeitsraum darstellen
> Positions-Anzeige wählen
> Maßsystem wählen
> Programmiersprache für $MDI wählen
> Achsauswahl für G01-Satz-Generierung
> Verfahrbereichs-Begrenzungen eingeben, Nullpunkt-Anzeige
> HILFE-Dateien anzeigen
> Betriebszeiten anzeigen
> Datenträger prüfen
> Systemzeit einstellen
> Teleservice
> Externer Zugriff
> Leitrechner-Betrieb
> Funkhandrad HR 550 FS konfigurieren


MOD-Funktion wählen

Über die MOD-Funktionen können Sie zusätzliche Anzeigen und Eingabemöglichkeiten wählen. Welche MOD-Funktionen zur Verfügung stehen, hängt von der gewählten Betriebsart ab.

Weitere Informationen:
> MOD-Funktionen wählen
> Einstellungen ändern
> MOD-Funktionen verlassen
> Übersicht MOD-Funktionen


MOD-Funktionen wählen

Betriebsart wählen, in der Sie MOD-Funktionen ändern möchten.

MOD-Funktionen wählen: Taste MOD drücken. Die Bilder rechts zeigen typische Bildschirm-Menüs für Programm-Einspeichern/Editieren (Bild rechts oben), Programm-Test (Bild rechts unten) und in einer Maschinen-Betriebsart (Bild nächste Seite)


Einstellungen ändern

  • MOD-Funktion im angezeigten Menü mit Pfeiltasten wählen

    Um eine Einstellung zu ändern, stehen – abhängig von der gewählten Funktion – drei Möglichkeiten zur Verfügung:

  • Zahlenwert direkt eingeben, z.B. beim Festlegen der Verfahrbereichs-Begrenzung
  • Einstellung durch Drücken der Taste ENT ändern, z.B. beim Festlegen der Programm-Eingabe
  • Einstellung ändern über ein Auswahlfenster. Wenn mehrere Einstellmöglichkeiten zur Verfügung stehen, können Sie durch Drücken der Taste GOTO ein Fenster einblenden, in dem alle Einstellmöglichkeiten auf einen Blick sichtbar sind. Wählen Sie die gewünschte Einstellung direkt durch Drücken der entsprechenden Zifferntaste (links vom Doppelpunkt), oder mit der Pfeiltaste und anschließendem bestätigen mit der Taste ENT. Wenn Sie die Einstellung nicht ändern wollen, schließen Sie das Fenster mit der Taste END


MOD-Funktionen verlassen

  • MOD-Funktion beenden: Softkey ENDE oder Taste END drücken


Übersicht MOD-Funktionen

Abhängig von der gewählten Betriebsart stehen folgende Funktionen zur Verfügung:

    Programm-Einspeichern/Editieren:

  • Verschiedene Software-Nummern anzeigen
  • Schlüsselzahl eingeben
  • Schnittstelle einrichten
  • Ggf. Diagnosefunktionen
  • Ggf. maschinenspezifische Anwenderparameter
  • Ggf. HILFE-Dateien anzeigen
  • Ggf. Maschinenkinematik wählen
  • Laden von Service-Packs
  • Zeitzone einstellen
  • Datenträgerprüfung starten
  • Konfiguration des Funkhandrades HR 550
  • Lizenz-Hinweise
  • Leitrechner-Betrieb

    Programm-Test:

  • Verschiedene Software-Nummern anzeigen
  • Schlüsselzahl eingeben
  • Datenschnittstelle einrichten
  • Rohteil im Arbeitsraum darstellen
  • Ggf. maschinenspezifische Anwenderparameter
  • Ggf. HILFE-Dateien anzeigen
  • Ggf. Maschinenkinematik wählen
  • Ggf. 3D ROT-Funktion einstellen
  • Zeitzone einstellen
  • Lizenz-Hinweise
  • Leitrechner-Betrieb

    Alle übrigen Betriebsarten:

  • Verschiedene Software-Nummern anzeigen
  • Kennziffern für vorhandene Optionen anzeigen
  • Positions-Anzeigen wählen
  • Maß-Einheit (mm/inch) festlegen
  • Programmier-Sprache festlegen für MDI
  • Achsen für Ist-Positions-Übernahme festlegen
  • Verfahrbereichs-Begrenzung setzen
  • Bezugspunkte anzeigen
  • Betriebszeiten anzeigen
  • Ggf. HILFE-Dateien anzeigen
  • Zeitzone einstellen
  • Ggf. Maschinenkinematik wählen
  • Lizenz-Hinweise


Software-Nummern

Weitere Informationen:
> Anwendung


Anwendung

    Folgende Software-Nummern stehen nach Anwahl der MOD-Funktionen im TNC-Bildschirm:

    • NC: Nummer der NC-Software (wird von HEIDENHAIN verwaltet)
    • PLC: Nummer oder Name der PLC-Software (wird von Ihrem Maschinenhersteller verwaltet)
    • Entwicklungsstand (FCL=Feature Content Level): Auf der Steuerung installierter Entwicklungsstand (siehe Entwicklungsstand (Upgrade-Funktionen)). Die TNC zeigt am Programmierplatz --- an, da dort kein Entwicklungsstand verwaltet wird
    • DSP1 bis DSP3: Nummer der Drehzahlregler-Software (wird von HEIDENHAIN verwaltet)
    • ICTL1 und ICTL3: Nummer der Stromregler-Software (wird von HEIDENHAIN verwaltet)


Schlüssel-Zahl eingeben

Weitere Informationen:
> Anwendung


Anwendung

Die TNC benötigt für folgende Funktionen eine Schlüssel-Zahl:

Funktion | Schlüssel-Zahl
Anwender-Parameter wählen und Musterdateien kopieren | 123
Ethernet-Karte konfigurieren (nicht iTNC 530 mit Windows XP) | NET123

Zusätzlich können Sie über das Schlüsselwort version eine Datei erstellen, die alle aktuellen Software-Nummern Ihrer Steuerung enthält:

  • Schlüsselwort version eingeben, mit Taste ent bestätigen

  • Die TNC zeigt am Bildschirm alle aktuellen Software-Nummern an

  • Versionsübersicht beenden: Taste End drücken

Weitere Informationen:
> Musterdateien kopieren


Musterdateien kopieren

Für verschiedene Datei-Typen (Paletten-Dateien, frei definierbare Tabellen, Schnittdaten-Tabellen usw.) sind in der TNC Musterdateien abgelegt. Um die Musterdateien auf der TNC-Partition zur Verfügung zu haben, gehen Sie wie folgt vor:

  • Geben Sie die Schlüsselzahl 123 ein, bestätigen Sie mit der Taste ent: Sie befinden sich nun in den Anwender-Parametern

  • Drücken Sie die Taste MOD, die TNC blendet verschiedene Informationen ein

  • Drücken Sie den Softkey UPDATE DATA, die TNC wechselt in das Menü für Software-Aktualisierungen.

  • Drücken Sie den Softkey COPY SAMPLE FILES, die TNC kopiert alle verfügbaren Musterdateien auf die TNC-Partition. Beachten Sie, dass die TNC bereits von Ihnen veränderte Musterdateien (z.B. Schnittdaten-Tabellen) überschreibt

  • Drücken Sie zwei Mal die Taste End, Sie befinden sich nun wieder im Ausgangsbildschirm


Service-Packs laden

Weitere Informationen:
> Anwendung


Anwendung

Setzen Sie sich unbedingt mit Ihrem Maschinenhersteller in Verbindung, bevor Sie ein Service-Pack installieren.

Die TNC führt nach Beendigung des Installations-Vorgangs einen Warmstart aus. Maschine vor dem Laden des Service-Packs in den NOT-AUS-Zustand bringen.

Falls noch nicht durchgeführt: Netzlaufwerk verbinden, von dem aus Sie das Service-Pack einspielen wollen.

Mit dieser Funktion können Sie auf einfache Weise an Ihrer TNC ein Software-Update durchführen

  • Betriebsart Programm-Einspeichern/Editieren wählen

  • Taste MOD drücken

  • Software-Update starten: Softkey „Service-Pack laden“ drücken, die TNC zeigt ein Überblendfenster zur Auswahl des Update-Files

  • Mit den Pfeiltasten das Verzeichnis wählen, in dem das Service-Pack gespeichert ist. Die Taste ENT klappt die jeweilige Unter-Verzeichnisstruktur auf

  • Datei wählen: Taste ENT auf dem gewählten Verzeichnis zweimal drücken. Die TNC wechselt vom Verzeichnisfenster ins Dateifenster

  • Update-Vorgang starten: Datei mit Taste ENT wählen: Die TNC entpackt alle erforderlichen Dateien und startet anschließend die Steuerung neu. Dieser Vorgang kann einige Minuten in Anspruch nehmen


Datenschnittstellen einrichten

Weitere Informationen:
> Anwendung
> RS-232-Schnittstelle einrichten
> RS-422-Schnittstelle einrichten
> BETRIEBSART des externen Geräts wählen
> BAUD-RATE einstellen
> Zuweisung
> Software für Datenübertragung


Anwendung

Zum Einrichten der Datenschnittstellen drücken Sie den Softkey RS 232- / RS 422 - EINRICHT. Die TNC zeigt ein Bildschirm-Menü, in das Sie folgende Einstellungen eingeben:


RS-232-Schnittstelle einrichten

Betriebsart und Baud-Raten werden für die RS-232-Schnittstelle links im Bildschirm eingetragen.


RS-422-Schnittstelle einrichten

Betriebsart und Baud-Raten werden für die RS-422-Schnittstelle rechts im Bildschirm eingetragen.


BETRIEBSART des externen Geräts wählen

In der Betriebsart EXT können Sie die Funktionen „alle Programme einlesen“, „angebotenes Programm einlesen“ und „Verzeichnis einlesen“ nicht nutzen.


BAUD-RATE einstellen

Die BAUD-RATE (Datenübertragungs-Geschwindigkeit) ist zwischen 110 und 115.200 Baud wählbar.

Externes Gerät | Betriebsart | Symbol
PC mit HEIDENHAIN Übertragungs-Software TNCremoNT | FE1 |
HEIDENHAIN Disketten-Einheiten FE 401 B FE 401 ab Prog.-Nr. 230 626 03 | FE1 FE1 |
Fremdgeräte, wie Drucker, Leser, Stanzer, PC ohne TNCremoNT | EXT1, EXT2 |


Zuweisung

Mit dieser Funktion legen Sie fest, wohin Daten von der TNC übertragen werden.

    Anwendungen:

  • Werte mit der Q-Parameter-Funktion FN15 ausgeben
  • Werte mit der Q-Parameter-Funktion FN16 ausgeben

Von der TNC-Betriebsart hängt ab, ob die Funktion PRINT oder PRINT-TEST benutzt wird:

TNC-Betriebsart | Übertragungs-Funktion
Programmlauf Einzelsatz | PRINT
Programmlauf Satzfolge | PRINT
Programm-Test | PRINT-TEST

PRINT und PRINT-TEST können Sie wie folgt einstellen:

Funktion | Pfad
Daten über RS-232 ausgeben | RS232:\....
Daten über RS-422 ausgeben | RS422:\....
Daten auf der Festplatte der TNC ablegen | TNC:\....
Daten auf einem Server ablegen, der mit der TNC verbunden ist | servername:\....
Daten in dem Verzeichnis speichern, in dem das Programm mit FN15/FN16 steht | leer

Datei-Namen:

Daten | Betriebsart | Datei-Name
Werte mit d15 | Programmlauf | %FN15RUN.A
Werte mit d15 | Programm-Test | %FN15SIM.A


Software für Datenübertragung

Zur Übertragung von Dateien von der TNC und zur TNC, sollten Sie die HEIDENHAIN-Software zur Datenübertragung TNCremoNT benutzen. Mit TNCremoNT können Sie über die serielle Schnittstelle oder über die Ethernet-Schnitstelle alle HEIDENHAIN-Steuerungen ansteuern.

Die aktuelle Version von TNCremoNT können Sie kostenlos von der HEIDENHAIN Filebase herunterladen (www.heidenhain.de, <Services und Dokumentation>, <Software>, <PC-Software>, <TNCremoNT>).

    System-Voraussetzungen für TNCremoNT:

  • PC mit 486 Prozessor oder besser
  • Betriebssystem Windows 95, Windows 98, Windows NT 4.0, Windows 2000, Windows XP, Windows Vista
  • 16 MByte Arbeitsspeicher
  • 5 MByte frei auf Ihrer Festplatte
  • Eine freie serielle Schnittstelle oder Anbindung ans TCP/IP-Netzwerk
Weitere Informationen:
> Installation unter Windows
> TNCremoNT unter Windows starten
> Datenübertragung zwischen TNC und TNCremoNT
> TNCremoNT beenden


Installation unter Windows

  • Starten Sie das Installations-Programm SETUP.EXE mit dem Datei-Manager (Explorer)

  • Folgen Sie den Anweisungen des Setup-Programms


TNCremoNT unter Windows starten

  • Klicken Sie auf <Start>, <Programme>, <HEIDENHAIN Anwendungen>, <TNCremoNT>

Wenn Sie TNCremoNT das erste Mal starten, versucht TNCremoNT automatisch eine Verbindung zur TNC herzustellen.


Datenübertragung zwischen TNC und TNCremoNT

Bevor Sie ein Programm von der TNC zum PC übertragen unbedingt sicherstellen, dass Sie das momentan auf der TNC angewählte Programm auch gespeichert haben. Die TNC speichert Änderungen automatisch, wenn Sie die Betriebsart auf der TNC wechseln oder wenn Sie über die Taste PGM MGT die Datei-Verwaltung anwählen.

Überprüfen Sie, ob die TNC an der richtigen seriellen Schnittstelle Ihres Rechners, bzw. am Netzwerk angeschlossen ist.

Nachdem Sie die TNCremoNT gestartet haben, sehen Sie im oberen Teil des Hauptfensters 1 alle Dateien, die im aktiven Verzeichnis gespeichert sind. Über <Datei>, <Ordner wechseln> können Sie ein beliebiges Laufwerk bzw. ein anderes Verzeichnis auf Ihrem Rechner wählen.

Wenn Sie die Datenübertragung vom PC aus steuern wollen, dann bauen Sie die Verbindung auf dem PC wie folgt auf:

  • Wählen Sie <Datei>, <Verbindung erstellen>. Die TNCremoNT empfängt nun die Datei- und Verzeichnis-Struktur von der TNC und zeigt diese im unteren Teil des Hauptfensters 2 an

  • Um eine Datei von der TNC zum PC zu übertragen, wählen Sie die Datei im TNC-Fenster durch Mausklick und ziehen die markierte Datei bei gedrückter Maustaste in das PC-Fenster 1

  • Um eine Datei vom PC zur TNC zu übertragen, wählen Sie die Datei im PC-Fenster durch Mausklick und ziehen die markierte Datei bei gedrückter Maustaste in das TNC-Fenster 2

Wenn Sie die Datenübertragung von der TNC aus steuern wollen, dann bauen Sie die Verbindung auf dem PC wie folgt auf:

  • Wählen Sie <Extras>, <TNCserver>. Die TNCremoNT startet dann den Serverbetrieb und kann von der TNC Daten empfangen, bzw. an die TNC Daten senden

  • Wählen Sie auf der TNC die Funktionen zur Datei-Verwaltung über die Taste PGM MGT (siehe Datenübertragung zu/von einem externen Datenträger) und übertragen die gewünschten Dateien


TNCremoNT beenden

Wählen Sie den Menüpunkt <Datei>, <Beenden>

Beachten Sie auch die kontextsensitive Hilfefunktion von TNCremoNT, in der alle Funktionen erklärt sind. Der Aufruf erfolgt über die Taste F1.


Ethernet-Schnittstelle

Weitere Informationen:
> Einführung
> Anschluss-Möglichkeiten
> TNC konfigurieren
> iTNC direkt mit einem Windows-PC verbinden


Einführung

Die TNC ist standardmäßig mit einer Ethernet-Karte ausgerüstet, um die Steuerung als Client in Ihr Netzwerk einzubinden. Die TNC überträgt Daten über die Ethernet-Karte mit

  • dem smb-Protokoll (server message block) für Windows-Betriebssysteme, oder
  • der TCP/IP-Protokoll-Familie (Transmission Control Protocol/Internet Protocol) und mit Hilfe des NFS (Network File System). Die TNC unterstützt auch das NFS V3-Protokoll, mit dem sich höhere Datenübertragungsraten erzielen lassen


Anschluss-Möglichkeiten

Sie können die Ethernet-Karte der TNC über den RJ45-Anschluss (X26,100BaseTX bzw. 10BaseT) in Ihr Netzwerk einbinden oder direkt mit einem PC verbinden. Der Anschluss ist galvanisch von der Steuerungselektronik getrennt.

Beim 100BaseTX bzw. 10BaseT-Anschluss verwenden Sie Twisted Pair-Kabel, um die TNC an Ihr Netzwerk anzuschließen.

Die maximale Kabellänge zwischen TNC und einem Knotenpunkt ist abhängig von der Güteklasse des Kabels, von der Ummantelung und von der Art des Netzwerks (100BaseTX oder 10BaseT).

Wenn Sie die TNC direkt mit einem PC verbinden, müssen Sie ein gekreuztes Kabel verwenden.


TNC konfigurieren

Lassen Sie die TNC von einem Netzwerk-Spezialisten konfigurieren.

Beachten Sie, dass die TNC einen automatischen Warmstart durchführt, wenn Sie die IP-Adresse der TNC ändern.

  • Drücken Sie in der Betriebsart Programm-Einspeichern/Editieren die Taste MOD. Geben Sie die Schlüsselzahl NET123 ein, die TNC zeigt den Hauptbildschirm zur Netzwerk-Konfiguration
Weitere Informationen:
> Allgemeine Netzwerk-Einstellungen
> Gerätespezifische Netzwerk-Einstellungen


Allgemeine Netzwerk-Einstellungen

  • Drücken Sie den Softkey DEFINE NET zur Eingabe der allgemeinen Netzwerk-Einstellungen. Reiter Computernamen ist aktiv:

Einstellung | Bedeutung
Primäre Schnittstelle | Name der Ethernet-Schnittstelle, die in Ihr Firmennetzwerk eingebunden werden soll. Nur aktiv, wenn eine optionale zweite Ethernetschnittstelle in der Steuerungshardware zur Verfügung steht
Rechnername | Name, mit der die TNC in Ihrem Firmennetzwerk sichtbar sein soll
Host-Datei | Nur für Sonderanwendungen erforderlich: Name einer Datei, in der Zuordnungen zwischen IP-Adressen und Rechnernamen definiert sind

  • Wählen Sie den Reiter Schnittstellen zur Eingabe der Schnittstellen-Einstellungen:

Einstellung Bedeutung

Schnittstellen-Liste

Liste der aktiven Ethernet-Schnittstellen. Eine der aufgelisteten Schnittstellen selektieren (per Mouse oder per Pfeiltasten)

  • Schaltfläche Aktivieren:
    Gewählte Schnittstelle aktivieren (X in Spalte Aktiv)
  • Schaltfläche Deaktivieren:
    Gewählte Schnittstelle deaktivieren (- in Spalte Aktiv)
  • Schaltfläche Konfigurieren:
    Konfigurationsmenü öffnen

IP-Forwarding erlauben

Diese Funktion muss standardmäßig deaktiviert sein.
Funktion nur aktivieren, wenn zu Diagnosezwecken von extern über die TNC auf die optional vorhandene zweite TNC Ethernet-Schnittstelle zugegriffen werden soll. Nur in Verbindung mit dem Kundendienst akivieren

  • Wählen Sie die Schaltfläche Konfigurieren zum Öffnen des Konfigurations-Menüs:

Einstellung Bedeutung

Status
  • Schnittstelle aktiv:
    Verbindungsstatus der gewählten Ethernet-Schnittstelle
  • Name:
    Name der Schnittstelle, die Sie gerade konfigurieren
  • Steckerverbindung:
    Nummer der Steckerverbindung dieser Schnittstelle an der Logikeinheit der Steuerung

Profil

Hier können Sie ein Profil erstellen bzw. auswählen, in dem alle in diesem Fenster sichtbaren Einstellungen hinterlegt sind. HEIDENHAIN stellt zwei Standardprofile zur Verfügung:

  • DHCP-LAN:
    Einstellungen für die Standard TNC Ethernet-Schnittstelle, die in einem Standard-Firmennetz funktionieren sollten
  • MachineNet:
    Einstellungen für die zweite, optionale Ethernet-Schnittstelle, zur Konfiguration des Maschinennetzwerks

Über die entsprechenden Schaltflächen können Sie die Profile speichern, laden und löschen

IP-Adresse
  • Option IP-Adresse automatisch beziehen:
    Die TNC soll die IP-Adresse vom DHCP-Server beziehen
  • Option IP-Adresse manuell einstellen:
    IP-Adresse und Subnet-Mask manuell definieren. Eingabe: Jeweils vier durch Punkt getrennte Zahlenwerte, z.B. 160.1.180.20 und 255.255.0.0

Domain Name Server (DNS)
  • Option DNS automatisch beziehen:
    Die TNC soll die IP-Adresse des Domain Name Servers automatisch beziehen
  • Option DNS manuell konfigurieren:
    IP-Adressen der Server und Domänenname manuell eingeben

Default Gateway
  • Option Default GW automatisch beziehen:
    Die TNC soll den Default-Gateway automatisch beziehen
  • Option Default GW manuell konfigurieren:
    IP-Adressen des Default-Gateways manuell eingeben

  • Änderungen mit Schaltfläche OK übernehmen oder mit Schaltfläche Abbrechen verwerfen

  • Wählen Sie den Reiter Internet:

Einstellung Bedeutung

Proxy
  • Direkte Verbindung zum Internet /NAT:
    Internet-Anfragen leitet die Steuerung an das Default-Gateway weiter und müssen dort über Network Address Translation weitergegeben werden (z.B. bei direktem Anschluss an ein Modem)
  • Proxy verwenden:
    Adresse und Port des Internet-Routers im Netzwerk definieren, beim Netzwerk-Administrator erfragen

Fernwartung

Der Maschinenhersteller konfiguriert hier den Server für die Fernwartung. Änderungen nur in Absprache mit Ihrem Maschinenhersteller durchführen

  • Wählen Sie den Reiter Ping/Routing zur Eingabe der Ping- und Routing-Einstellungen:

Einstellung Bedeutung

Ping

Im Eingabefeld Adresse: die IP-Nummer eingeben, zu der Sie eine Netzwerk-Verbindung prüfen wollen. Eingabe: Vier durch Punkt getrennte Zahlenwerte, z.B. 160.1.180.20. Alternativ können Sie auch den Rechnernamen eingeben, zu dem Sie die Verbindung prüfen wollen

  • Schaltfläche Start: Prüfung starten, die TNC blendet Statusinformationen im Pingfeld ein
  • Schaltfläche Stopp: Prüfung beenden

Routing

Für Netzwerkspezialisten: Statusinformationen des Betriebssystems zum aktuellen Routing

  • Schaltfläche Aktualisieren:
    Routing aktualisieren

  • Wählen Sie den Reiter NFS UID/GID zur Eingabe von Benutzer- und Gruppenkennungen:

Einstellung Bedeutung

UID/GID für NFS-Shares setzen
  • User ID:
    Definition, mit welcher User-Identifikation der Endanwender im Netzwerk auf Dateien zugreift. Wert beim Netzwerk-Spezialisten erfragen
  • Group ID:
    Definition, mit welcher Gruppen-Identifikation Sie im Netzwerk auf Dateien zugreifen. Wert beim Netzwerk-Spezialisten erfragen

  • Wählen Sie den Reiter DHCP-Server zur Konfiguration der DHCP-Server-Einstellungen des Maschinennetzes.

Die Konfiguration des DHCP-Servers ist über ein Passwort geschützt. Setzen Sie sich bitte mit Ihrem Maschinenhersteller in Verbindung.
Einstellung Bedeutung

DHCP Server aktiv auf:
  • IP Adressen ab:
    Definition, ab welcher IP-Adresse die TNC den Pool der dynamischen IP-Adressen ableiten soll. Die ausgegrauten Werte übernimmt die TNC aus der statischen IP-Adresse der definierten Ethernet-Schnittstelle, diese sind nicht veränderbar.
  • IP Adressen bis:
    Definition, bis zu welcher IP-Adresse die TNC den Pool der dynamischen IP-Adressen ableiten soll.
  • Lease Time (Stunden):
    Zeit, innerhalb der die dynamische IP-Adresse für einen Client reserviert bleiben soll. Meldet sich ein Client innerhalb dieser Zeit an, dann weist die TNC wieder dieselbe dynamische IP-Adresse zu.
  • Domainname:
    Hier können Sie bei Bedarf einen Namen für das Maschinennetz definieren. Ist erforderlich, wenn z.B. gleiche Namen im Maschinennetz und dem externen Netz vergeben sind.
  • DNS nach extern weiterleiten:
    Wenn IP Forwarding aktiv ist (Reiter Schnittstellen) können Sie bei aktiver Option festlegen, dass die Namensauflösung für Geräte am Maschinennetz auch vom externen Netz verwendet werden kann.
  • DNS von extern weiterleiten:
    Wenn IP Forwarding aktiv ist (Reiter Schnittstellen) können Sie bei aktiver Option festlegen, dass die TNS DNS-Anfragen von Geräten innerhalb des Maschinennetzes auch an den Namensserver des externen Netzes weiterleiten soll, sofern der DNS-Server der MC die Anfrage nicht beantworten kann.
  • Schaltfläche Status:
    Übersicht der Geräte aufrufen, die im Maschinennetz mit dynamischer IP-Adresse versorgt sind. Zusätzlich können Sie Einstellungen für diese Geräte vornehmen
  • Schaltfläche Erweiterte Optionen:
    Erweiterte Einstellmöglichkeiten für den DNS-/DHCP-Server.
  • Schaltfläche Setze Standardwerte:
    Werkseinstellungen setzen.


Gerätespezifische Netzwerk-Einstellungen

  • Drücken Sie den Softkey DEFINE MOUNT zur Eingabe der gerätespezifischen Netzwerk-Einstellungen. Sie können beliebig viele Netzwerk-Einstellungen festlegen, jedoch nur maximal 7 gleichzeitig verwalten

Einstellung Bedeutung

Netzwerklaufwerk

Liste aller verbundenen Netzwerklaufwerke. In den Spalten zeigt die TNC den jeweiligen Status der Netzwerkverbindungen an:

  • Mount:
    Netzlaufwerk verbunden/nicht verbunden
  • Auto:
    Netzlaufwerk soll automatisch/manuel verbunden werden
  • Typ:
    Art der Netzwerk-Verbindung. Möglich sind cifs und nfs
  • Laufwerk:
    Bezeichnung des Laufwerks auf der TNC
  • ID:
    Interne ID die kennzeichnet, wenn Sie mehrere Verbindungen über einen Mount-Point definiert haben
  • Server:
    Name des Servers
  • Freigabename:
    Name des Verzeichnisses auf dem Server auf das die TNC zugreifen soll
  • Benutzer:
    Name des Benutzers am Netzwerk
  • Passwort:
    Netzlaufwerk Passwort geschützt oder nicht
  • Passwort erfragen?:
    Passwort beim Verbinden erfragen/nicht erfragen
  • Optionen:
    Anzeige von zusätzlichen Verbindungsoptionen

Über die Schaltflächen verwalten Sie die Netzlaufwerke.

Um Netzwerklaufwerke hinzuzufügen, verwenden Sie die Schaltfläche Hinzufügen: Die TNC startet dann den Verbindungs-Assistenten, in dem Sie alle erforderlichen Angaben dialoggeführt eingeben können


iTNC direkt mit einem Windows-PC verbinden

Sie können die iTNC auch direkt mit einem-PC verbinden, der mit einer Ethernet-Karte ausgerüstet ist. Lassen Sie diese Einstellungen von einem Netzwerk-Spezialisten durchführen, Sie müssen ggf. die IP-Adresse Ihres PC an die IP-Adresse der iTNC anpassen lassen.

Voraussetzung:

Die Netzwerkkarte muss auf dem PC bereits installiert und funktionsfähig sein.

Wenn Sie den PC, mit dem Sie die iTNC verbinden wollen, bereits in ihrem Firmennetz eingebunden haben, sollten Sie die PC-Netzwerk-Adresse beibehalten und die Netzwerk-Adresse der TNC anpassen (siehe TNC konfigurieren).


PGM MGT konfigurieren

Weitere Informationen:
> Anwendung
> Einstellung PGM MGT ändern
> Abhängige Dateien


Anwendung

    Über die MOD-Funktion legen Sie fest, welche Verzeichnisse bzw. Dateien von der TNC angezeigt werden sollen:

  • Einstellung PGM MGT: Neu Mouse-Bedienbare Datei-Verwaltung oder alte Datei-Verwaltung wählen
  • Einstellung Abhängige Dateien: Definieren, ob abhängige Dateien angezeigt werden sollen oder nicht. Einstellung Manuell zeigt abhängige Dateien an, Einstellung Automatisch zeigt abhängige Dateien nicht an

Weitere Informationen: Siehe Arbeiten mit der Datei-Verwaltung.


Einstellung PGM MGT ändern

  • MOD-Funktion wählen: Taste MOD drücken

  • Softkey rs232 rs422 einricht. drücken

  • Einstellung PGM MGT wählen: Hellfeld mit Pfeiltasten auf Einstellung PGM MGT schieben, mit Taste ENT zwischen Erweitert 2 und Erweitert 1 umschalten

    Die Neue Datei-Verwaltung (Einstellung Erweitert 2) bietet folgende Vorteile:

  • Vollständige Mouse-Bedienung zusätzlich zur Tastenbedienung möglich
  • Sortierfunktion verfügbar
  • Texteingabe synchronisiert das Hellfeld auf den nächstmöglichen Dateinamen
  • Favoriten-Verwaltung
  • Konfigurationsmöglichkeit der anzuzeigenden Informationen
  • Datumsformat einstellbar
  • Fenstergrößen flexibel einstellbar
  • Schnellbedienung durch Verwendung von Shortcuts möglich


Abhängige Dateien

Abhängige Dateien haben zusätzlich zur Dateikennung die Endung .SEC.DEP (SECtion = engl. Gliederung, DEPendent = engl. abhängig). Folgende unterschiedliche Typen stehen zur Verfügung:

  • .H.SEC.DEP
    Dateien mit der Endung .SEC.DEP erzeugt die TNC, wenn Sie mit der Gliederungsfunktion arbeiten. In der Datei stehen Informationen, die die TNC benötigt, um schneller von einem Gliederungspunkt auf den nächsten zu springen
  • .T.DEP: Werkzeug-Einsatzdatei für einzelne Klartext-Dialog-Programme (siehe Werkzeug-Einsatzprüfung)
  • .P.T.DEP: Werkzeug-Einsatzdatei für eine komplette Palette
    Dateien mit der Endung .P.T.DEP erzeugt die TNC, wenn Sie in einer Programmlauf-Betriebsart die Werkzeug-Einsatzprüfung (siehe Werkzeug-Einsatzprüfung) für einen Paletteneintrag der aktiven Paletten-Datei durchführen. In dieser Datei ist dann die Summe aller Werkzeug-Einsatzzeiten aufgeführt, also die Einsatzzeiten aller Werkzeuge, die Sie innerhalb der Palette verwenden
  • .H.AFC.DEP: Datei, in der die TNC die Regelparameter für die adaptive Vorschubregelung AFC speichert (siehe Adaptive Vorschubregelung AFC (Software-Option))
  • .H.AFC2.DEP: Datei, in der die TNC statistische Daten der adaptiven Vorschubregelung AFC speichert (siehe Adaptive Vorschubregelung AFC (Software-Option))
Weitere Informationen:
> MOD-Einstellung Abhängige Dateien ändern


MOD-Einstellung Abhängige Dateien ändern

  • Datei-Verwaltung in der Betriebsart Programm-Einspeichern/Editieren wählen: Taste PGM MGT drücken

  • MOD-Funktion wählen: Taste MOD drücken

  • Einstellung Abhängige Dateien wählen: Hellfeld mit Pfeiltasten auf Einstellung Abhängige Dateien schieben, mit Taste ENT zwischen AUTOMATISCH und MANUELL umschalten

Abhängige Dateien sind in der Datei-Verwaltung nur sichtbar, wenn Sie die Einstellung MANUELL gewählt haben.

Existieren zu einer Datei abhängige Dateien, dann zeigt die TNC in der Status-Spalte der Datei-Verwaltung ein +-Zeichen an (nur wenn Abhängige Dateien auf AUTOMATISCH gestellt ist).


Maschinenspezifische Anwenderparameter

Weitere Informationen:
> Anwendung


Anwendung

Um die Einstellung maschinenspezifischer Funktionen für den Anwender zu ermöglichen, kann Ihr Maschinenhersteller bis zu 16 Maschinen-Parameter als Anwender-Parameter definieren.

Diese Funktion steht nicht bei allen TNC’s zur Verfügung. Beachten Sie Ihr Maschinenhandbuch.


Rohteil im Arbeitsraum darstellen

Weitere Informationen:
> Anwendung
> Gesamte Darstellung drehen


Anwendung

In der Betriebsart Programm-Test können Sie die Lage des Rohteils im Arbeitsraum der Maschine grafisch überprüfen und die Arbeitsraum-Überwachung in der Betriebsart Programm-Test aktivieren.

Die TNC stellt einen transparenten Quader als Arbeitsraum dar, dessen Maße in der Tabelle Verfahrbereich aufgeführt sind (Standardfarbe: Grün). Die Maße für den Arbeitsraum entnimmt die TNC aus den Maschinen-Parametern für den aktiven Verfahrbereich. Da der Verfahrbereich im Referenzsystem der Maschine definiert ist, entspricht der Nullpunkt des Quaders dem Maschinen-Nullpunkt. Die Lage des Maschinen-Nullpunkts im Quader können Sie durch drücken des Softkeys M91 (2. Softkey-Leiste) sichtbar machen (Standardfarbe: Weiß).

Ein weiterer transparenter Quader stellt das Rohteil dar, dessen Abmaße in der Tabelle BLK FORM aufgeführt sind (Standardfarbe: Blau). Die Abmaße übernimmt die TNC aus der Rohteil-Definition des angewählten Programms. Der Rohteil-Quader definiert das Eingabe-Koordinatensystem, dessen Nullpunkt innerhalb des Verfahrbereichs-Quaders liegt. Die Lage des aktiven Nullpunkts innerhalb des Verfahrbereiches können Sie durch Drücken des Softkeys „Werkstück-Nullpunkt anzeigen“ (2. Softkey-Leiste) sichtbar machen.

Wo sich das Rohteil innerhalb des Arbeitsraumes befindet ist im Normalfall für den Programm-Test unerheblich. Wenn Sie jedoch Programme testen, die Verfahrbewegungen mit M91 oder M92 enthalten, müssen Sie das Rohteil „grafisch“ so verschieben, dass keine Konturverletzungen auftreten. Benützen Sie dazu die in der nachfolgenden Tabelle aufgeführten Softkeys.

Wenn Sie einen grafischen Kollisionstest durchführen wollen (Software-Option), müssen Sie den Bezugspunkt ggf. grafisch so verschieben, dass keine Kollisionswarnungen auftreten.

Über den Softkey „Werkstück-Nullpunkt im Arbeitsraum anzeigen” können Sie sich die Lage des Rohteils im Maschinen-Koordinatensystem anzeigen lassen. Auf diese Koordinaten müssen Sie dann ihr Werkstück auf dem Maschinentisch platzieren, um beim Abarbeiten dieselben Verhältnisse wie beim Kollisionstest zu haben.

Darüber hinaus können Sie auch die Arbeitsraum-Überwachung für die Betriebsart Programm-Test aktivieren, um das Programm mit dem aktuellen Bezugspunkt und den aktiven Verfahrbereichen zu testen (siehe nachfolgende Tabelle, letzte Zeile).

Funktion | Softkey
Rohteil nach links verschieben |
Rohteil nach rechts verschieben |
Rohteil nach vorne verschieben |
Rohteil nach hinten verschieben |
Rohteil nach oben verschieben |
Rohteil nach unten verschieben |
Rohteil bezogen auf den gesetzten Bezugspunkt anzeigen: Die TNC übernimmt den aktiven Bezugspunkt (Preset) und die aktiven Endschalterpositionen aus den Maschinen-Betriebsarten in den Programm-Test |
Gesamten Verfahrbereich bezogen auf das dargestellte Rohteil anzeigen |
Maschinen-Nullpunkt im Arbeitsraum anzeigen |
Vom Maschinenhersteller festgelegte Position (z.B. Werkzeug- Wechselpunkt) im Arbeitsraum anzeigen |
Werkstück-Nullpunkt im Arbeitsraum anzeigen |
Arbeitsraum-Überwachung beim Programm-Test einschalten (EIN)/ ausschalten (AUS) |


Gesamte Darstellung drehen

Auf der dritten Softkey-Leiste stehen Ihnen Funktionen zur Verfügung, mit denen Sie die Gesamtdarstellung drehen und kippen können:

Funktion | Softkeys
Darstellung vertikal drehen |
Darstellung horizontal kippen |


Positions-Anzeige wählen

Weitere Informationen:
> Anwendung


Anwendung

Für den Manuellen Betrieb und die Programmlauf-Betriebsarten können Sie die Anzeige der Koordinaten beeinflussen:

  1. Das Bild rechts zeigt verschiedene Positionen des Werkzeugs
  2. Ausgangs-Position
  3. Ziel-Position des Werkzeugs
  4. Werkstück-Nullpunkt
  5. Maschinen-Nullpunkt

Für die Positions-Anzeigen der TNC können Sie folgende Koordinaten wählen:

Funktion | Anzeige
Ist-Position; momentane Werkzeug-Position | IST
Referenz-Position; Ist-Position bezogen auf den Maschinen-Nullpunkt | REF
Schleppfehler; Differenz zwischen Soll und Ist-Position | SCHPF
Soll-Position; von der TNC aktuell vorgegebener Wert | SOLL
Restweg zur programmierten Position im Maschinen-Koordinatensystem; Differenz zwischen Ist- und Ziel-Position | RESTW
Restweg zur programmierten Position im aktiven (ggf. geschwenkten) Koordinaten-System; Differenz zwischen Ist- und Ziel-Position | RW-3D
Verfahrwege, die mit der Funktion Handrad-Überlagerung (M118) ausgeführt wurden (Nur Positions-Anzeige 2) | M118

Mit der MOD-Funktion Positions-Anzeige 1 wählen Sie die Positions-Anzeige in der Status-Anzeige.

Mit der MOD-Funktion Positions-Anzeige 2 wählen Sie die Positions-Anzeige in der zusätzlichen Status-Anzeige.


Maßsystem wählen

Weitere Informationen:
> Anwendung


Anwendung

Mit dieser MOD-Funktion legen Sie fest, ob die TNC Koordinaten in mm oder Inch (Zoll-System) anzeigen soll.

  • Metrisches Maßsystem: z.B. X = 15,789 (mm) MOD-Funktion Wechsel mm/inch = mm. Anzeige mit 3 Stellen nach dem Komma
  • Zoll-System: z.B. X = 0,6216 (inch) MOD-Funktion Wechsel mm/inch = inch. Anzeige mit 4 Stellen nach dem Komma

Wenn Sie die Inch-Anzeige aktiv haben, zeigt die TNC auch den Vorschub in inch/min an. In einem Inch-Programm müssen Sie den Vorschub mit einem Faktor 10 größer eingeben.


Programmiersprache für $MDI wählen

Weitere Informationen:
> Anwendung


Anwendung

Mit der MOD-Funktion Programm-Eingabe schalten Sie die Programmierung der Datei $MDI um.

  • $MDI.H im Klartext-Dialog programmieren:
    Programm-Eingabe: HEIDENHAIN
  • $MDI.I gemäß DIN/ISO programmieren:
    Programm-Eingabe: ISO


Achsauswahl für G01-Satz-Generierung

Weitere Informationen:
> Anwendung


Anwendung

Im Eingabe-Feld für die Achsauswahl legen Sie fest, welche Koordinaten der aktuellen Werkzeug-Position in einen G01-Satz übernommen werden. Die Generierung eines separaten G01-Satzes erfolgt mit der Taste „Ist-Position übernehmen“. Die Auswahl der Achsen erfolgt wie bei Maschinen-Parametern bitorientiert:

Achsauswahl %11111: X, Y, Z, IV., V. Achse übernehmen

Achsauswahl %01111: X, Y, Z, IV. Achse übernehmen

Achsauswahl %00111: X, Y, Z Achse übernehmen

Achsauswahl %00011: X, Y Achse übernehmen

Achsauswahl %00001: X Achse übernehmen


Verfahrbereichs-Begrenzungen eingeben, Nullpunkt-Anzeige

Weitere Informationen:
> Anwendung
> Arbeiten ohne Verfahrbereichs-Begrenzung
> Maximalen Verfahrbereich ermitteln und eingeben
> Bezugspunkt-Anzeige


Anwendung

Innerhalb des maximalen Verfahrbereichs können Sie den tatsächlich nutzbaren Verfahrweg für die Koordinatenachsen einschränken.

Anwendungsbeispiel: Teilapparat gegen Kollisionen sichern.

Der maximale Verfahrbereich ist durch Software-Endschalter begrenzt. Der tatsächlich nutzbare Verfahrweg wird mit der MOD-Funktion VERFAHRBEREICH eingeschränkt: Dazu geben Sie die Maximalwerte in positiver und negativer Richtung der Achsen bezogen auf den Maschinen-Nullpunkt ein. Wenn Ihre Maschine über mehrere Verfahrbereiche verfügt, können Sie die Begrenzung für jeden Verfahrbereich separat einstellen (Softkey VERFAHRBEREICH (1) bis VERFAHRBEREICH (3)).


Arbeiten ohne Verfahrbereichs-Begrenzung

Für Koordinatenachsen, die ohne Verfahrbereichs-Begrenzungen verfahren werden sollen, geben Sie den maximalen Verfahrweg der TNC (+/- 99999 mm) als VERFAHRBEREICH ein.


Maximalen Verfahrbereich ermitteln und eingeben

  • Positions-Anzeige REF anwählen

  • Gewünschte positive und negative End-Positionen der X-, Y- und Z-Achse anfahren

  • Werte mit Vorzeichen notieren

  • MOD-Funktionen wählen: Taste MOD drücken

Verfahrbereichs-Begrenzung eingeben: Softkey VERFAHRBEREICH drücken. Notierte Werte für die Achsen als Begrenzungen eingeben

MOD-Funktion verlassen: Softkey ENDE drücken

Aktive Werkzeug-Radiuskorrekturen werden bei Verfahrbereichs-Begrenzungen nicht berücksichtigt.

Verfahrbereichs-Begrenzungen und Software-Endschalter werden berücksichtigt, nachdem die Referenz-Punkte überfahren sind.


Bezugspunkt-Anzeige

Die im Bildschirm rechts oben angezeigten Werte definieren den momentan aktiven Bezugspunkt. Der Bezugspunkt kann manuell gesetzt oder aus der Preset-Tabelle aktiviert worden sein. Sie können den Bezugspunkt im Bildschirm-Menü nicht verändern.

Die angezeigten Werte sind abhängig von Ihrer Maschinen-Konfiguration.


HILFE-Dateien anzeigen

Weitere Informationen:
> Anwendung
> HILFE-DATEIEN wählen


Anwendung

Hilfe-Dateien sollen den Bediener in Situationen unterstützen, in denen festgelegte Handlungsweisen, z.B. das Freifahren der Maschine nach einer Stromunterbrechung, erforderlich sind. Auch Zusatz-Funktionen lassen sich in einer HILFE-Datei dokumentieren. Das Bild rechts zeigt die Anzeige einer HILFE-Datei.

Die HILFE-Dateien sind nicht an jeder Maschine verfügbar. Nähere Informationen erteilt Ihr Maschinenhersteller.


HILFE-DATEIEN wählen

  • MOD-Funktion wählen: Taste MOD drücken

Wählen der zuletzt aktiven HILFE-Datei: Softkey HILFE drücken

Falls nötig, Datei Verwaltung aufrufen (Taste PGM MGT) und andere Hilfe-Datei wählen


Betriebszeiten anzeigen

Weitere Informationen:
> Anwendung


Anwendung

Über den Softkey MASCHINEN ZEIT können Sie sich verschiedene Betriebszeiten anzeigen lassen:

Betriebszeit | Bedeutung
Steuerung ein | Betriebszeit der Steuerung seit der Inbetriebnahme
Maschine ein | Betriebszeit der Maschine seit der Inbetriebnahme
Programmlauf | Betriebszeit für den gesteuerten Betrieb seit der Inbetriebnahme

Der Maschinenhersteller kann noch zusätzliche Zeiten anzeigen lassen. Maschinenhandbuch beachten!

Am unteren Ende des Bildschirms können Sie eine Schlüsselzahl eingeben, mit der die TNC die angezeigten Zeiten zurücksetzt. Welche Zeiten die TNC genau zurücksetzt, legt Ihr Maschinenhersteller fest, Maschinenhandbuch beachten!


Datenträger prüfen

Weitere Informationen:
> Anwendung
> Datenträgerprüfung durchführen


Anwendung

Über den Softkey dateisystem prüfen können Sie für die TNC- und PLC-Partition eine Festplattenprüfung mit automatischer Reparatur durchführen.

Die Systempartition der TNC wird automatisch bei jedem Neustart der Steuerung geprüft. Fehler auf der Systempartition meldet die TNC mit einem entsprechenden Fehler.


Datenträgerprüfung durchführen

Achtung Kollisionsgefahr!

Bevor Sie die Datenträgerprüfung starten, die Maschine in den NOT-AUS-Zustand bringen. Die TNC führt vor der Prüfung einen Neustart der Software durch!

  • MOD-Funktion wählen: Taste MOD drücken

Diagnosefunktionen wählen: Softkey diagnose drücken

Datenträgerprüfung starten: Softkey dateisystem prüfen drücken

Start der Prüfung mit Softkey JA nochmal bestätigen: Die Funktion fährt die TNC-Software herunter und startet mit der Datenträgerprüfung. Die Prüfung kann einige Zeit in Anspruch nehmen, abhängig von Anzahl und Größe der Dateien, die Sie auf der Festplatte gespeichert haben

Am Ende des Prüfvorgangs blendet die TNC ein Fenster mit den Ergebnissen der Prüfung ein. Die TNC schreibt die Ergebnisse zusätzlich auch in das Steuerungslogbuch

TNC-Software neu starten: Taste ENT drücken


Systemzeit einstellen

Weitere Informationen:
> Anwendung
> Einstellungen vornehmen


Anwendung

Über den Softkey datum/ uhzeit einstellen können Sie die Zeitzone, das Datum und die System-Uhrzeit einstellen.


Einstellungen vornehmen

Wenn Sie Zeitzone, Datum oder Systemzeit verstellen, dann ist ein Neustart der TNC erforderlich. Die TNC gibt in diesen Fällen beim Schließen des Fensters eine Warnung aus.

  • MOD-Funktion wählen: Taste MOD drücken

  • Softkey-Leiste weiterschalten

Zeitzonenfenster anzeigen: Softkey zeitzone einstellen drücken

Im rechten Teil Zeitzone per Mouse-Klick wählen, in der Sie sich befinden

Im linken Bereich des Überblendfensters wählen, ob Sie die Zeit manuell einstellen wollen (Option Zeit manuell einstellen aktivieren), oder ob die TNC die Zeit mit einem Server synchronisieren soll (Option Zeit über NTP Server synchronisieren aktivieren)

Bei Bedarf die Uhrzeit verstellen per Zahleneingabe

Einstellungen speichern: Schaltfläche OK anklicken

Änderungen verwerfen und Dialog abbrechen: Schaltfläche Abbrechen anklicken


Teleservice

Weitere Informationen:
> Anwendung
> Teleservice aufrufen/beenden


Anwendung

Die Funktionen zum Teleservice werden vom Maschinenhersteller freigegeben und festgelegt. Maschinenhandbuch beachten!

Die TNC stellt zwei Softkeys für den Teleservice zur Verfügung, damit zwei verschiedene Servicestellen eingerichten werden können.

Die TNC verfügt über die Möglichkeit, Teleservice durchführen zu können. Dazu sollte Ihre TNC mit einer Ethernet-Karte ausgerüstet sein, mit der sich eine höhere Datenübertragungs-Geschwindigkeit erreichen lässt als über die serielle Schnittstelle RS-232-C.

Mit der HEIDENHAIN TeleService-Software, kann Ihr Maschinenhersteller dann zu Diagnosezwecken über ein ISDN- Modem eine Verbindung zur TNC aufbauen. Folgende Funktionen stehen zur Verfügung:

  • Online-Bildschirmübertragung
  • Abfragen von Maschinenzuständen
  • Übertragung von Dateien
  • Fernsteuerung der TNC


Teleservice aufrufen/beenden

  • Beliebige Maschinenbetriebsart wählen

  • MOD-Funktion wählen: Taste MOD drücken

Verbindung zur Servicestelle aufbauen: Softkey SERVICE bzw. SUPPORT auf EIN stellen. Die TNC beendet die Verbindung automatisch, wenn für eine vom Maschinenhersteller festgelegte Zeit (Standard: 15 min) keine Datenübertragung durchgeführt wurde

Verbindung zur Servicestelle lösen: Softkey SERVICE bzw. support auf AUS stellen. Die TNC beendet die Verbindung nach ca. einer Minute


Externer Zugriff

Weitere Informationen:
> Anwendung


Anwendung

Der Maschinenhersteller kann die externen Zugriffsmöglichkeiten über die LSV-2 Schnittstelle konfigurieren. Maschinenhandbuch beachten!

Mit dem Softkey EXTERNER ZUGRIFF können Sie den Zugriff über die LSV-2 Schnittstelle freigeben oder sperren.

Durch einen Eintrag in der Konfigurationsdatei TNC.SYS können Sie ein Verzeichnis einschließlich vorhandener Unterverzeichnisse mit einem Passwort schützen. Bei einem Zugriff über die LSV-2 Schnittstelle auf die Daten aus diesem Verzeichnis wird das Passwort abgefragt. Legen Sie in der Konfigurationsdatei TNC.SYS den Pfad und das Passwort für den externen Zugriff fest.

Die Datei TNC.SYS muss im Root-Verzeichnis TNC:\ gespeichert sein.

Wenn Sie nur einen Eintrag für das Passwort vergeben, wird das ganze Laufwerk TNC:\ geschützt.

Verwenden Sie für die Datenübertragung die aktualisierten Versionen der HEIDENHAIN-Software TNCremo oder TNCremoNT.

Einträge in TNC.SYS | Bedeutung
REMOTE.PERMISSION= | LSV-2-Zugriff nur für definierte Rechner erlauben. Liste der Rechnernamen definieren
REMOTE.TNCPASSWORD= | Passwort für LSV-2 Zugriff
REMOTE.TNCPRIVATEPATH= | Pfad der geschützt werden soll
Beispiel für TNC.SYS
REMOTE.permission=PC2225;PC3547
REMOTE.TNCPASSWORD=KR1402
REMOTE.TNCPRIVATEPATH=TNC:\RK
Weitere Informationen:
> Externen Zugriff erlauben/sperren


Externen Zugriff erlauben/sperren

  • Beliebige Maschinenbetriebsart wählen

  • MOD-Funktion wählen: Taste MOD drücken

Verbindung zur TNC erlauben: Softkey EXTERNER ZUGRIFF auf EIN stellen. Die TNC lässt den Zugriff auf Daten über die LSV-2 Schnittstelle zu. Bei einem Zugriff auf ein Verzeichnis, welches in der Konfigurationsdatei TNC.SYS angegeben wurde, wird das Passwort abgefragt

Verbindung zur TNC sperren: Softkey EXTERNER ZUGRIFF auf AUS stellen. Die TNC sperrt den Zugriff über die LSV-2 Schnittstelle


Leitrechner-Betrieb

Weitere Informationen:
> Anwendung


Anwendung

Der Maschinenhersteller definiert Verhalten und Funktionalität des Leitrechner-Betriebs. Maschinenhandbuch beachten!

Mit dem Softkey Leitrechner-Betrieb übergeben Sie das Kommando einem externen Leitrechner, um beispielsweise Daten zur Steuerung zu übertragen.

Weitere Informationen:
> Externen Zugriff erlauben/sperren


Externen Zugriff erlauben/sperren

  • Betriebsart Programm-Einspeichern/Editieren oder Programm-Test wählen

  • MOD-Funktion wählen: Taste MOD drücken

  • Softkey-Leiste weiterschalten

Leitrechner-Betrieb aktivieren: Die TNC zeigt eine leere Bildschirmseite an

Leitrechner-Betrieb beenden: Softkey end drücken

Beachten Sie, dass Ihr Maschinenhersteller festlegen kann, dass Sie den Leitrechnerbetrieb nicht manuell beenden dürfen, Maschinenhandbuch beachten.

Beachten Sie, dass Ihr Maschinenhersteller festlegen kann, dass der Leitrechnerbetrieb auch von extern automatisch aktivierbar ist, Maschinenhandbuch beachten.


Funkhandrad HR 550 FS konfigurieren

Weitere Informationen:
> Anwendung
> Handrad einer bestimmten Handradaufnahme zuordnen
> Funkkanal einstellen
> Sendeleistung einstellen
> Statistik


Anwendung

Über den Softkey FUNKHANDRAD einrichten können Sie das Funkhandrad HR 550 FS konfigurieren. Folgende Funktionen stehen zur Verfügung:

  • Handrad einer bestimmten Handradaufnahme zuordnen
  • Funkkanal einstellen
  • Analyse des Frequenz-Spektrums zur Bestimmung des bestmöglichen Funkkanals
  • Sendeleistung einstellen
  • Statistische Informationen zur Übertragungsqualität


Handrad einer bestimmten Handradaufnahme zuordnen

  • Stellen Sie sicher, dass die Handradaufnahme mit der Steuerungshardware verbunden ist

  • Legen Sie das Funkhandrad, das Sie der Handradaufnahme zuordnen wollen, in die Handradaufnahme

  • MOD-Funktion wählen: Taste MOD drücken

  • Softkey-Leiste weiterschalten

Konfigurationsmenü für Funkhandrad wählen: Softkey funkhandrad einrichten drücken

Klicken Sie auf die Schaltfläche HR anbinden: Die TNC speichert die Seriennummer des eingelegten Funkhandrades ab und zeigt diese im Konfigurationsfenster links neben der Schaltfläche HR anbinden an

Konfiguration speichern und Konfigurationsmenü verlassen: Schaltfläche ENDE drücken


Funkkanal einstellen

Beim automatischen Starten des Funkhandrades versucht die TNC den Funkkanal zu wählen, der das beste Funksignal liefert. Wenn Sie den Funkkanal selber einstellen wollen, gehen Sie wie folgt vor:

  • MOD-Funktion wählen: Taste MOD drücken

  • Softkey-Leiste weiterschalten

Konfigurationsmenü für Funkhandrad wählen: Softkey funkhandrad einrichten drücken

Durch Mouse-Klick den Reiter Frequenz-Spektrum wählen

Klicken Sie auf die Schaltfläche HR anhalten: Die TNC stoppt die Verbindung zum Funkhandrad und ermittelt das aktuelle Frequenz-Spektrum für alle 16 verfügbaren Kanäle

Kanalnummer des Kanals merken, der am wenigsten Funkverkehr aufweist (kleinster Balken)

Über die Schaltfläche Handrad starten das Funkhandrad wieder aktivieren

Durch Mouse-Klick den Reiter Eigenschaften wählen

Klicken Sie auf die Schaltfläche Kanal wählen: Die TNC blendet alle verfügbaren Kanalnummern ein. Wählen Sie per Mouse die Kanalnummer, für die die TNC am wenigsten Funkverkehr ermittelt hat

Konfiguration speichern und Konfigurationsmenü verlassen: Schaltfläche ENDE drücken


Sendeleistung einstellen

Beachten Sie, dass beim Reduzieren der Sendeleistung die Reichweite des Funkhandrades abnimmt.

  • MOD-Funktion wählen: Taste MOD drücken

  • Softkey-Leiste weiterschalten

Konfigurationsmenü für Funkhandrad wählen: Softkey funkhandrad einrichten drücken

Klicken Sie auf die Schaltfläche Setze Leistung: Die TNC blendet die drei verfügbaren Leistungseinstellungen ein. Wählen Sie per Mouse die gewünschte Einstellung aus

Konfiguration speichern und Konfigurationsmenü verlassen: Schaltfläche ENDE drücken


Statistik

Unter Statistik zeigt die TNC Informationen zur Übertragungsqualität an.

Das Funkhandrad reagiert bei einer eingeschränkten Empfangsqualität, die einen einwandfreien, sicheren Halt der Achsen nicht mehr gewährleisten kann, mit einer Not-Aus-Reaktion.

Hinweis auf eine eingeschränkte Empfangsqualität gibt der angezeigte Wert Max. Folge verloren. Zeigt die TNC im normalen Betrieb des Funkhandrades, innerhalb des gewünschten Einsatzradius hier wiederholt Werte größer 2 an, so besteht die erhöhte Gefahr eines unerwünschten Verbindungsabbruchs. Abhilfe kann hier die Erhöhung der Sendeleistung, aber auch ein Kanalwechsel auf einen weniger frequentierten Kanal schaffen.

Versuchen Sie in solchen Fällen die Übertragungsqualität durch Auswählen eines anderen Kanals zu verbessern (siehe Funkkanal einstellen) oder die Sendeleistung zu erhöhen (siehe Sendeleistung einstellen).

Die Statistik-Daten können Sie wie folgt anzeigen lassen:

  • MOD-Funktion wählen: Taste MOD drücken

  • Softkey-Leiste weiterschalten

Konfigurationsmenü für Funkhandrad wählen: Softkey funkhandrad einrichten drücken: Die TNC zeigt das Konfigurationsmenü mit den Statistik-Daten


Tabellen und Übersichten

Weitere Informationen:
> Allgemeine Anwender-parameter
> Steckerbelegung und Anschlusskabel für Datenschnittstellen
> Technische Information
> Puffer-Batterie wechseln


Allgemeine Anwender-parameter

Allgemeine Anwenderparameter sind Maschinen-Parameter, die das Verhalten der TNC beeinflussen.

    Typische Anwenderparameter sind z.B.

  • die Dialogsprache
  • das Schnittstellen-Verhalten
  • Verfahrgeschwindigkeiten
  • Bearbeitungsabläufe
  • die Wirkung der Override
Weitere Informationen:
> Eingabemöglichkeiten für Maschinen-Parameter
> Allgemeine Anwenderparameter anwählen
> Liste der allgemeinen Anwenderparameter


Eingabemöglichkeiten für Maschinen-Parameter

    Maschinen-Parameter lassen sich beliebig programmieren als

  • Dezimalzahlen
    Zahlenwert direkt eingeben

  • Dual-/Binärzahlen
    Prozent-Zeichen „%“ vor Zahlenwert eingeben

  • Hexadezimalzahlen
    Dollar-Zeichen „$“ vor Zahlenwert eingeben

Weitere Informationen:
> Beispiel:


Beispiel:

Anstelle der Dezimalzahl 27 können Sie auch die Binärzahl %11011 oder die Hexadezimalzahl $1B eingeben.

Die einzelnen Maschinen-Parameter dürfen gleichzeitig in den verschiedenen Zahlensystemen angegeben sein.

Einige Maschinen-Parameter haben Mehrfach-Funktionen. Der Eingabewert solcher Maschinen-Parameter ergibt sich aus der Summe der mit einem + gekennzeichneten Einzeleingabewerte.


Allgemeine Anwenderparameter anwählen

Allgemeine Anwenderparameter wählen Sie in den MOD-Funktionen mit der Schlüsselzahl 123 an.

In den MOD-Funktionen stehen auch maschinenspezifische ANWENDERPARAMETER zur Verfügung.


Liste der allgemeinen Anwenderparameter

Externe Datenübertragung

TNC-Schnittstellen EXT1 (5020.0) und EXT2 (5020.1) an externes Gerät anpassen

MP5020.x 7 Datenbit (ASCII-Code, 8.bit = Parität): Bit 0 = 0
8 Datenbit (ASCII-Code, 9.bit = Parität): Bit 0 = 1

Block-Check-Charakter (BCC) beliebig: Bit 1 = 0 Block-Check-Charakter (BCC) Steuerzeichen nicht erlaubt: Bit 1 = 1
Übertragungs-Stopp durch RTS aktiv: Bit 2 = 1
Übertragungs-Stopp durch RTS nicht aktiv: Bit 2 = 0

Übertragungs-Stopp durch DC3 aktiv: Bit 3 = 1 Übertragungs-Stopp durch DC3 nicht aktiv: Bit 3 = 0
Zeichenparität geradzahlig: Bit 4 = 0 Zeichenparität ungeradzahlig: Bit 4 = 1

Zeichenparität unerwünscht: Bit 5 = 0 Zeichenparität erwünscht: Bit 5 = 1

Anzahl der Stopp-Bits, die am Ende eines Zeichens gesendet werden:
1 Stoppbit: Bit 6 = 0 2 Stoppbits: Bit 6 = 1
1 Stoppbit: Bit 7 = 1 1 Stoppbit: Bit 7 = 0

Beispiel:

TNC-Schnittstelle EXT2 (MP 5020.1) auf externes Fremdgerät mit folgender Einstellung anpassen:

8 Datenbit, BCC beliebig, Übertragungs-Stopp durch DC3, geradzahlige Zeichenparität, Zeichenparität erwünscht, 2 Stoppbit

Eingabe für MP 5020.1: %01101001

Schnittstellen-Typ für EXT1 (5030.0) und EXT2 (5030.1) festlegen

MP5030.x
Standard-Übertragung: 0 Schnittstelle für blockweises Übertragen: 1

Tastsysteme |
Übertragungsart wählen | MP6010 Tastsystem mit Kabel-Übertragung: 0 Tastsystem mit Infrarot-Übertragung: 1
Antastvorschub für schaltendes Tastsystem | MP6120 1 bis 3 000 [mm/min]
Maximaler Verfahrweg zum Antastpunkt | MP6130 0,001 bis 99 999,9999 [mm]
Sicherheitsabstand zum Antastpunkt bei -automatischem Messen | MP6140 0,001 bis 99 999,9999 [mm]
Eilgang zum Antasten für schaltendes -Tastsystem | MP6150 1 bis 300 000 [mm/min]
Vorpositionieren mit Maschinen-Eilgang | MP6151 Vorpositionieren mit Geschwindigkeit aus MP6150: 0 Vorpositionieren mit Maschinen-Eilgang: 1
Tastsystem-Mittenversatz messen beim -Kalibrieren des schaltenden Tastsystems | MP6160 Keine 180°-Drehung des Tastsystems beim Kalibrieren: 0 M-Funktion für 180°-Drehung des Tastsystems beim Kalibrieren: 1 bis 999
M-Funktion um Infrarottaster vor jedem Messvorgang zu orientieren | MP6161 Funktion inaktiv: 0 Orientierung direkt über die NC: -1 M-Funktion für Orientierung des Tastsystems: 1 bis 999
Orientierungswinkel für den Infrarottaster | MP6162 0 bis 359,9999 [°]
Differenz zwischen aktuellem Orientierungswinkel und Orientierungswinkel aus MP 6162 ab dem eine Spindelorientierung durchgeführt werden soll | MP6163 0 bis 3,0000 [°]
Automatik-Betrieb: Infrarottaster vor dem Antasten -automatisch auf die programmierte -Antastrichtung orientieren | MP6165 Funktion inaktiv: 0 Infrarottaster orientieren: 1
Manueller Betrieb: Antast-Richtung unter Berücksichtigung einer aktiven Grunddreung korrigieren | MP6166 Funktion inaktiv: 0 Grunddrehung berücksichtigen: 1
Mehrfachmessung für programmierbare Antastfunktion | MP6170 1 bis 3
Vertrauensbereich für Mehrfachmessung | MP6171 0,001 bis 0,999 [mm]
Automatischer Kalibrierzyklus: Mitte des Kalibrierrings in der X-Achse bezogen auf den Maschinen-Nullpunkt | MP6180.0 (Verfahrbereich 1) bis MP6180.2 (Verfahrbereich 3) 0 bis 99 999,9999 [mm]
Automatischer Kalibrierzyklus: Mitte des Kalibrierrings in der Y-Achse bezogen auf den Maschinen-Nullpunkt | MP6181.x (Verfahrbereich 1) bis MP6181.2 (Verfahrbereich 3) 0 bis 99 999,9999 [mm]
Automatischer Kalibrierzyklus: Oberkante des Kalibrierrings in der Z-Achse bezogen auf den Maschinen-Nullpunkt | MP6182.x (Verfahrbereich 1) bis MP6182.2 (Verfahrbereich 3) 0 bis 99 999,9999 [mm]
Automatischer Kalibrierzyklus: Abstand unterhalb der Ringoberkante, an der die TNC die Kalibrierung durchführt | MP6185.x (Verfahrbereich 1) bis MP6185.2 (Verfahrbereich 3) 0,1 bis 99 999,9999 [mm]
Radiusvermessung mit TT 130: -Antastrichtung | MP6505.0 (Verfahrbereich 1) bis 6505.2 (Verfahrbereich 3) Positive Antastrichtung in der Winkel-Bezugsachse (0°-Achse): 0 Positive Antastrichtung in der +90°-Achse: 1 Negative Antastrichtung in der Winkel-Bezugsachse (0°-Achse): 2 Negative Antastrichtung in der +90°-Achse: 3
Antastvorschub für zweite Messung mit TT 130, Stylus-Form, Korrekturen in TOOL.T | MP6507 Antastvorschub für zweite Messung mit TT 130 berechnen, mit konstanter Toleranz: Bit 0 = 0 Antastvorschub für zweite Messung mit TT 130 berechnen, mit variabler Toleranz: Bit 0 = 1 Konstanter Antastvorschub für zweite Messung mit TT 130: Bit 1 = 1
Maximal zulässiger Messfehler mit TT 130 bei der Messung mit rotierendem Werkzeug Notwendig für die Berechnung des Antastvorschubs in Verbindung mit MP6570 | MP6510.0 0,001 bis 0,999 [mm] (Empfehlung: 0,005 mm) MP6510.1 0,001 bis 0,999 [mm] (Empfehlung: 0,01 mm)
Antastvorschub für TT 130 bei stehendem Werkzeug | MP6520 1 bis 3 000 [mm/min]
Radius-Vermessung mit TT 130: Abstand Werkzeug-Unterkante zu Stylus-Oberkante | MP6530.0 (Verfahrbereich 1) bis MP6530.2 (Verfahrbereich 3) 0,001 bis 99,9999 [mm]
Sicherheits-Abstand in der Spindelachse über dem Stylus des TT 130 bei Vorpositionierung | MP6540.0 0,001 bis 30 000,000 [mm]
Sicherheitszone in der Bearbeitungsebene um den Stylus des TT 130 bei Vorpositionierung | MP6540.1 0,001 bis 30 000,000 [mm]
Eilgang im Antastzyklus für TT 130 | MP6550 10 bis 10 000 [mm/min]
M-Funktion für Spindel-Orientierung bei Einzelschneiden-Vermessung | MP6560 0 bis 999 -1: Funktion inaktiv
Messung mit rotierendem Werkzeug: Zulässige Umlaufgeschwindigkeit am Fräserumfang Notwendig für die Berechnung von Drehzahl und Antastvorschub | MP6570 1,000 bis 120,000 [m/min]
Messung mit rotierendem Werkzeug: Maximal zulässige Drehzahl | MP6572 0,000 bis 1 000,000 [U/min] Bei Eingabe 0 wird die Drehzahl auf 1000 U/min begrenzt
Koordinaten des TT-120-Stylus Mittelpunkts bezogen auf den Maschinen-Nullpunkt | MP6580.0 (Verfahrbereich 1) X-Achse MP6580.1 (Verfahrbereich 1) Y-Achse MP6580.2 (Verfahrbereich 1) Z-Achse MP6581.0 (Verfahrbereich 2) X-Achse MP6581.1 (Verfahrbereich 2) Y-Achse MP6581.2 (Verfahrbereich 2) Z-Achse MP6582.0 (Verfahrbereich 3) X-Achse MP6582.1 (Verfahrbereich 3) Y-Achse MP6582.2 (Verfahrbereich 3) Z-Achse
Überwachung der Stellung von Dreh- und Parallelachsen | MP6585 Funktion inaktiv: 0 Achsstellung überwachen, bitcodiert für jede Achse definierbar: 1
Dreh- und Parallelachsen definieren, die überwacht werden sollen | MP6586.0 Stellung der A-Achse nicht überwachen: 0 Stellung der A-Achse überwachen: 1 MP6586.1 Stellung der B-Achse nicht überwachen: 0 Stellung der B-Achse überwachen: 1 MP6586.2 Stellung der C-Achse nicht überwachen: 0 Stellung der C-Achse überwachen: 1 MP6586.3 Stellung der U-Achse nicht überwachen: 0 Stellung der U-Achse überwachen: 1 MP6586.4 Stellung der V-Achse nicht überwachen: 0 Stellung der V-Achse überwachen: 1 MP6586.5 Stellung der W-Achse nicht überwachen: 0 Stellung der W-Achse überwachen: 1
KinematicsOpt: Toleranzgrenze für Fehlermeldung im Modus Optimieren | MP6600 0.001 bis 0.999
KinematicsOpt: Maximal erlaubte Abweichung vom eingegebenen Kalibrierkugelradius | MP6601 0.01 bis 0.1
KinematicsOpt: M-Funktion für Rundachspositionierung | MP6602 Funktion inaktiv:-1 Rundachspositionierung über definierte Zusatz-Funktion ausführen: 0 bis 9999
TNC-Anzeigen, --TNC-Editor

Zyklus 17, 18 und 207: Spindelorientierung am Zyklus-Anfang

MP7160
Spindelorientierung durchführen: 0
Keine Spindelorientierung durchführen: 1

Programmierplatz -einrichten

MP7210
TNC mit Maschine: 0 TNC als Programmierplatz mit aktiver PLC: 1
TNC als Programmierplatz mit nicht aktiver PLC: 2

Dialog Stromunterbrechung nach dem Einschalten quittieren

MP7212
Mit Taste quittieren: 0
Automatisch quittieren: 1

DIN/ISO-Programmierung: Satznummern-Schrittweite festlegen

MP7220
0 bis 150

Anwahl von Datei-Typen sperren

MP7224.0 Alle Datei-Typen über Softkey anwählbar: %0000000 Anwahl von HEIDENHAIN-Programme sperren (Softkey ZEIGE .H): Bit 0 = 1 Anwahl von DIN/ISO-Programme sperren (Softkey ZEIGE .I): Bit 1 = 1 Anwahl von Werkzeug-Tabellen sperren (Softkey ZEIGE .T): Bit 2 = 1 Anwahl von Nullpunkt-Tabellen sperren (Softkey ZEIGE .D): Bit 3 = 1
Anwahl von Paletten-Tabellen sperren (Softkey ZEIGE .P): Bit 4 = 1 Anwahl von Text-Dateien sperren (Softkey ZEIGE .A): Bit 5 = 1 Anwahl von Punkte-Tabellen sperren (Softkey ZEIGE .PNT): Bit 6 = 1

Editieren von Datei-Typen sperren

Hinweis:

Falls Sie Datei-Typen sperren, löscht die TNC alle Dateien dieses Typs.

MP7224.1
Editor nicht sperren: %0000000
Editor sperren für

  • HEIDENHAIN-Programme: Bit 0 = 1

  • DIN/ISO-Programme: Bit 1 = 1

  • Werkzeug-Tabellen: Bit 2 = 1

  • Nullpunkt-Tabellen: Bit 3 = 1

  • Paletten-Tabellen: Bit 4 = 1

  • Text-Dateien: Bit 5 = 1

  • Punkte-Tabellen: Bit 6 = 1

Softkey bei Tabellen sperren

MP7224.2
Softkey editieren aus/ein nicht sperren: %0000000
Softkey editieren aus/ein sperren für

  • Ohne Funktion: Bit 0 = 1

  • Ohne Funktion: Bit 1 = 1

  • Werkzeug-Tabellen: Bit 2 = 1

  • Nullpunkt-Tabellen: Bit 3 = 1

  • Paletten-Tabellen: Bit 4 = 1

  • Ohne Funktion: Bit 5 = 1

  • Punkte-Tabellen: Bit 6 = 1

Paletten-Tabellen -konfigurieren

MP7226.0
Paletten-Tabelle nicht aktiv: 0
Anzahl der Paletten pro Paletten-Tabelle: 1 bis 255

Nullpunkt-Dateien konfigurieren

MP7226.1
Nullpunkt-Tabelle nicht aktiv: 0
Anzahl der Nullpunkte pro Nullpunkt-Tabelle: 1 bis 255

Programmlänge, bis zu der LBL-Nummern überprüft werden

MP7229.0
Sätze 100 bis 9 999

Programmlänge, bis zu der FK-Sätze überprüft werden

MP7229.1
Sätze 100 bis 9 999

Dialogsprache -festlegen

MP7230.0 bis MP7230.3
Englisch: 0 Deutsch: 1
Tschechisch: 2 Französisch: 3
Italienisch: 4
Spanisch: 5 Portugiesisch: 6 Schwedisch: 7
Dänisch: 8 Finnisch: 9 Niederländisch: 10 Polnisch: 11
Ungarisch: 12
reserviert: 13
Russisch (kyrillischer Zeichensatz): 14 (nur möglich ab MC 422 B)
Chinesisch (simplified): 15 (nur möglich ab MC 422 B)
Chinesisch (traditional): 16 (nur möglich ab MC 422 B)
Slowenisch: 17 (nur möglich ab MC 422 B)
Norwegisch: 18 (nur möglich ab MC 422 B)
Slowakisch: 19 (nur möglich ab MC 422 B)
Koreanisch: 21 (nur möglich ab MC 422 B)
Türkisch: 23 (nur möglich ab MC 422 B)
Rumänisch: 24 (nur möglich ab MC 422 B)
Hinweis: Die Dialogsprachen Lettisch, Estnisch und Litauisch werden nicht mehr unterstützt. Bei entsprechender Einstellung des MP7230 zeigt die TNC englische Dialoge.

Werkzeug-Tabelle -konfigurieren

MP7260
Nicht aktiv: 0
Anzahl der Werkzeuge, die die TNC beim Öffnen einer neuen Werkzeug-Tabelle generiert: 1 bis 254
Wenn Sie mehr als 254 Werkzeuge benötigen, können Sie die Werkzeug-Tabelle erweitern mit der Funktion N ZEILEN AM ENDE ANFÜGEN, siehe Werkzeug-Daten

Werkzeug-Platztabelle konfigurieren

MP7261.0 (Magazin 1) MP7261.1 (Magazin 2) MP7261.2 (Magazin 3) MP7261.3 (Magazin 4) MP7261.4 (Magazin 5) MP7261.5 (Magazin 6) MP7261.6 (Magazin 7) MP7261.7 (Magazin 8) Nicht aktiv: 0
Anzahl der Plätze im Werkzeug-Magazin: 1 bis 9999
Ist in MP 7261.1 bis MP7261.7 der Wert 0 eingetragen, verwendet die TNC nur ein Werkzeug-Magazin.

Werkzeug-Nummern indizieren, um zu einer Werkzeug-Nummer mehrere Korrektur-daten abzulegen

MP7262
Nicht indizieren: 0
Anzahl der erlaubten Indizierung: 1 bis 9

Konfiguration Werkzeug-Tabelle und Platz-Tabelle

MP7263
Konfigurationseinstellungen für Werkzeug-Tabelle und Platz-Tabelle: %0000

  • Softkey PLATZ TABELLE in der Werkzeug-Tabelle anzeigen: Bit 0 = 0

  • Softkey PLATZ TABELLE in der Werkzeug-Tabelle nicht anzeigen: Bit 0 = 1

  • Externe Datenübertragung: Nur angezeigte Spalten übertragen: Bit 1 = 0

  • Externe Datenübertragung: Alle Spalten übertragen: Bit 1 = 1

  • Softkey EDIT EIN/AUS in der Platz-Tabelle anzeigen: Bit 2 = 0

  • Softkey EDIT EIN/AUS in der Platz-Tabelle nicht anzeigen: Bit 2 = 1

  • Softkey RÜCKS. SPALTE T und PLATZ-TABELLE RÜCKS. aktiv: Bit 3 = 0

  • Softkey RÜCKS. SPALTE T und PLATZ-TABELLE RÜCKS. nicht aktiv: Bit 3 = 1

  • Löschen von Werkzeugen nicht erlauben, wenn es in der Platz-Tabelle steht: Bit 4 = 0

  • Löschen von Werkzeugen erlauben wenn es in der Platz-Tabelle steht, Anwender muss das Löschen bestätigen: Bit 4 = 1

  • Löschen von Werkzeugen die in der Platz-Tabelle stehen mit Bestätigung ausführen: Bit 5 = 0

  • Löschen von Werkzeugen die in der Platz-Tabelle stehen ohne Bestätigung ausführen: Bit 5 = 1

  • Indizierte Werkzeuge ohne Bestätigung löschen: Bit 6 = 0

  • Indizierte Werkzeuge mit Bestätigung löschen: Bit 6 = 1

Werkzeug-Tabelle konfigurieren (Nicht aufführen: 0); Spalten-Nummer in der Werkzeug-Tabelle für

MP7266.0
Werkzeug-Name – NAME: 0 bis 42; Spaltenbreite: 32 Zeichen
MP7266.1
Werkzeug-Länge – L: 0 bis 42; Spaltenbreite: 11 Zeichen
MP7266.2
Werkzeug-Radius – R: 0 bis 42; Spaltenbreite: 11 Zeichen
MP7266.3
Werkzeug-Radius 2 – R2: 0 bis 42; Spaltenbreite: 11 Zeichen
MP7266.4
Aufmaß Länge – DL: 0 bis 42; Spaltenbreite: 8 Zeichen
MP7266.5
Aufmaß Radius – DR: 0 bis 42; Spaltenbreite: 8 Zeichen
MP7266.6
Aufmaß Radius 2 – DR2: 0 bis 42; Spaltenbreite: 8 Zeichen
MP7266.7
Werkzeug gesperrt – TL: 0 bis 42; Spaltenbreite: 2 Zeichen
MP7266.8
Schwester-Werkzeug – RT: 0 bis 42; Spaltenbreite: 5 Zeichen
MP7266.9
Maximale Standzeit – TIME1: 0 bis 42; Spaltenbreite: 5 Zeichen
MP7266.10
Max. Standzeit bei TOOL CALL – TIME2: 0 bis 42; Spaltenbreite: 5 Zeichen
MP7266.11
Aktuelle Standzeit – CUR. TIME: 0 bis 42; Spaltenbreite: 8 Zeichen
MP7266.12
Werkzeug-Kommentar – DOC: 0 bis 42; Spaltenbreite: 16 Zeichen
MP7266.13
Anzahl der Schneiden – CUT.: 0 bis 42; Spaltenbreite: 4 Zeichen
MP7266.14
Toleranz für Verschleiß-Erkennung Werkzeug-Länge – LTOL: 0 bis 42; Spaltenbreite: 6 Zeichen
MP7266.15
Toleranz für Verschleiß-Erkennung Werkzeug-Radius – RTOL: 0 bis 42; Spaltenbreite: 6 Zeichen
MP7266.16
Schneid-Richtung – DIRECT.: 0 bis 42; Spaltenbreite: 7 Zeichen
MP7266.17
PLC-Status – PLC: 0 bis 42; Spaltenbreite: 9 Zeichen
MP7266.18
Zusätzlicher Versatz des Werkzeugs in der Werkzeugachse zu MP6530 – TT:L-OFFS: 0 bis 42;
Spaltenbreite: 11 Zeichen
MP7266.19
Versatz des Werkzeugs zwischen Stylus-Mitte und Werkzeug-Mitte – TT:R-OFFS: 0 bis 42;
Spaltenbreite: 11 Zeichen

Werkzeug-Tabelle konfigurieren (Nicht aufführen: 0); Spalten-Nummer in der Werkzeug-Tabelle für

MP7266.20
Toleranz für Bruch-Erkennung Werkzeug-Länge – LBREAK.: 0 bis 42; Spaltenbreite: 6 Zeichen
MP7266.21
Toleranz für Bruch-Erkennung Werkzeug-Radius – RBREAK: 0 bis 42; Spaltenbreite: 6 Zeichen
MP7266.22
Schneidenlänge (Zyklus 22) – LCUTS: 0 bis 42; Spaltenbreite: 11 Zeichen
MP7266.23
Maximaler Eintauchwinkel (Zyklus 22) – ANGLE.: 0 bis 42; Spaltenbreite: 7 Zeichen
MP7266.24
Werkzeug-Typ –TYP: 0 bis 42; Spaltenbreite: 5 Zeichen
MP7266.25
Werkzeug-Schneidstoff – TMAT: 0 bis 42; Spaltenbreite: 16 Zeichen
MP7266.26
Schnittdaten-Tabelle – CDT: 0 bis 42; Spaltenbreite: 16 Zeichen MP7266.27
PLC-Wert – PLC-VAL: 0 bis 42; Spaltenbreite: 11 Zeichen
MP7266.28
Taster-Mittenversatz Hauptachse – CAL-OFF1: 0 bis 42; Spaltenbreite: 11 Zeichen
MP7266.29
Taster-Mittenversatz Nebenachse – CALL-OFF2: 0 bis 42; Spaltenbreite: 11 Zeichen
MP7266.30
Spindelwinkel beim Kalibrieren – CALL-ANG: 0 bis 42; Spaltenbreite: 11 Zeichen
MP7266.31
Werkzeug-Typ für die Platz-Tabelle – PTYP: 0 bis 42; Spaltenbreite: 2 Zeichen
MP7266.32
Begrenzung Spindeldrehzahl – NMAX: 0 bis 42; Spaltenbreite: 6 Zeichen
MP7266.33
Freifahren bei NC-Stopp – LIFTOFF: 0 bis 42; Spaltenbreite: 1 Zeichen
MP7266.34
Maschinenabhängige Funktion – P1: 0 bis 42; Spaltenbreite: 10 Zeichen
MP7266.35
Maschinenabhängige Funktion – P2: 0 bis 42; Spaltenbreite: 10 Zeichen
MP7266.36
Maschinenabhängige Funktion – P3: 0 bis 42; Spaltenbreite: 10 Zeichen
MP7266.37
Werkzeugspezifische Kinematikbeschreibung – KINEMATIC: 0 bis 42; Spaltenbreite: 16 Zeichen
MP7266.38
Spitzenwinkel T_ANGLE: 0 bis 42; Spaltenbreite: 9 Zeichen
MP7266.39
Gewindesteigung PITCH: 0 bis 42; Spaltenbreite: 10 Zeichen
MP7266.40
Adaptive Vorschubregelung AFC: 0 bis 42; Spaltenbreite: 10 Zeichen
MP7266.41
Toleranz für Verschleiß-Erkennung Werkzeug-Radius 2 – R2TOL: 0 bis 42; Spaltenbreite: 6 Zeichen
MP7266.42
Name der Korrekturwert-Tabelle für eingriffswinkelabhängig 3D-Werkzeug-Radiuskorrektur
MP7266.43
Datum/Uhrzeit des letzten Werkzeug-Aufrufs

Werkzeug-Platztabelle konfigurieren (nicht aufführen: 0); Spalten-Nummer in der Platz-Tabelle für

MP7267.0
Werkzeugnummer – T: 0 bis 20
MP7267.1
Sonderwerkzeug – ST: 0 bis 20
MP7267.2
Festplatz – F: 0 bis 20
MP7267.3
Platz gesperrt – L: 0 bis 20
MP7267.4
PLC – Status – PLC: 0 bis 20
MP7267.5
Werkzeugname aus der Werkzeug-Tabelle – TNAME: 0 bis 20
MP7267.6
Kommentar aus der Werkzeug-Tabelle – DOC: 0 bis 20
MP7267.7
Werkzeugtyp – PTYP: 0 bis 20
MP7267.8
Wert für PLC – P1: 0 bis 20
MP7267.9
Wert für PLC – P2: 0 bis 20
MP7267.10
Wert für PLC – P3: 0 bis 20
MP7267.11
Wert für PLC – P4: 0 bis 20
MP7267.12
Wert für PLC – P5: 0 bis 20
MP7267.13
Reservierter Platz – RSV: 0 bis 20 MP7267.14
Platz oben sperren – LOCKED_ABOVE: 0 bis 20
MP7267.15
Platz unten sperren – LOCKED_BELOW: 0 bis 20
MP7267.16
Platz links sperren – LOCKED_LEFT: 0 bis 20
MP7267.17
Platz rechts sperren – LOCKED_RIGHT: 0 bis 20
MP7267.18
S1-Wert für PLC – P6: 0 bis 20
MP7267.19
S2-Wert für PLC – P7: 0 bis 20

Bezugspunkt-Tabelle konfigurieren (nicht aufführen: 0); Spalten-Nummer in der Bezugspunkt-Tabelle für

MP7268.0
Kommentar – DOC: 0 bis 11
MP7268.1
Grunddrehung – ROT: 0 bis 11
MP7268.2
Bezugspunkt X-Achse – X: 0 bis 11
MP7268.3
Bezugspunkt Y-Achse – Y: 0 bis 11
MP7268.4
Bezugspunkt Z-Achse – Z: 0 bis 11
MP7268.5
Bezugspunkt A-Achse – A: 0 bis 11
MP7268.6
Bezugspunkt B-Achse – B: 0 bis 11
MP7268.7
Bezugspunkt C-Achse – C: 0 bis 11
MP7268.8
Bezugspunkt U-Achse – U: 0 bis 11
MP7268.9
Bezugspunkt V-Achse – V: 0 bis 11
MP7268.10
Bezugspunkt W-Achse – W: 0 bis 11

Betriebsart Manueller Betrieb: Anzeige des Vorschubs

MP7270
Vorschub F nur anzeigen, wenn Achsrichtungs-Taste gedrückt wird: 0
Vorschub F anzeigen, auch wenn keine Achsrichtungs-Taste gedrückt wird (Vorschub, der über Softkey F definiert wurde oder Vorschub der „langsamsten“ Achse): 1

Dezimalzeichen -festlegen

MP7280
Komma als Dezimalzeichen anzeigen: 0
Punkt als Dezimalzeichen anzeigen: 1

Betriebsart Programm-Einspeichern: Darstellung mehrzeiliger NC-Sätze

MP7281.0
NC-Satz immer vollständig anzeigen: 0
Nur aktuellen NC-Satz vollständig anzeigen: 1
NC-Satz nur beim Editieren vollständig anzeigen: 2

Betriebsart Programmlauf: Darstellung mehrzeiliger NC-Sätze

MP7281.1
NC-Satz immer vollständig anzeigen: 0
Nur aktuellen NC-Satz vollständig anzeigen: 1
NC-Satz nur beim Editieren vollständig anzeigen: 2

Positions-Anzeige in der Werkzeugachse

MP7285
Anzeige bezieht sich auf den Werkzeug-Bezugspunkt: 0
Anzeige in der Werkzeugachse bezieht sich auf die
Werkzeug-Stirnfläche: 1

Anzeigeschritt für die Spindelposition

MP7289
0,1 °: 0 0,05 °: 1
0,01 °: 2
0,005 °: 3
0,001 °: 4
0,0005 °: 5
0,0001 °: 6

Anzeigeschritt

MP7290.0 (X-Achse) bis MP7290.13 (14. Achse)
0,1 mm: 0 0,05 mm: 1
0,01 mm: 2
0,005 mm: 3
0,001 mm: 4
0,0005 mm: 5
0,0001 mm: 6

Bezugspunkt-Setzen in der Preset-Tabelle sperren

MP7294
Bezugspunkt-Setzen nicht sperren: %00000000000000
Bezugspunkt-Setzen in der X-Achse sperren: Bit 0 = 1
Bezugspunkt-Setzen in der Y-Achse sperren: Bit 1 = 1
Bezugspunkt-Setzen in der Z-Achse sperren: Bit 2 = 1
Bezugspunkt-Setzen in der IV. Achse sperren: Bit 3 = 1
Bezugspunkt-Setzen in der V. Achse sperren: Bit 4 = 1
Bezugspunkt-Setzen in der 6. Achse sperren: Bit 5 = 1 Bezugspunkt-Setzen in der 7. Achse sperren: Bit 6 = 1 Bezugspunkt-Setzen in der 8. Achse sperren: Bit 7 = 1
Bezugspunkt-Setzen in der 9. Achse sperren: Bit 8 = 1 Bezugspunkt-Setzen in der 10. Achse sperren: Bit 9 = 1 Bezugspunkt-Setzen in der 11. Achse sperren: Bit 10 = 1 Bezugspunkt-Setzen in der 12. Achse sperren: Bit 11 = 1
Bezugspunkt-Setzen in der 13. Achse sperren: Bit 12 = 1
Bezugspunkt-Setzen in der 14. Achse sperren: Bit 13 = 1

Bezugspunkt-Setzen sperren

MP7295
Bezugspunkt-Setzen nicht sperren: %00000000000000
Bezugspunkt-Setzen in der X-Achse sperren: Bit 0 = 1
Bezugspunkt-Setzen in der Y-Achse sperren: Bit 1 = 1
Bezugspunkt-Setzen in der Z-Achse sperren: Bit 2 = 1
Bezugspunkt-Setzen in der IV. Achse sperren: Bit 3 = 1
Bezugspunkt-Setzen in der V. Achse sperren: Bit 4 = 1
Bezugspunkt-Setzen in der 6. Achse sperren: Bit 5 = 1 Bezugspunkt-Setzen in der 7. Achse sperren: Bit 6 = 1 Bezugspunkt-Setzen in der 8. Achse sperren: Bit 7 = 1
Bezugspunkt-Setzen in der 9. Achse sperren: Bit 8 = 1 Bezugspunkt-Setzen in der 10. Achse sperren: Bit 9 = 1 Bezugspunkt-Setzen in der 11. Achse sperren: Bit 10 = 1 Bezugspunkt-Setzen in der 12. Achse sperren: Bit 11 = 1
Bezugspunkt-Setzen in der 13. Achse sperren: Bit 12 = 1
Bezugspunkt-Setzen in der 14. Achse sperren: Bit 13 = 1

Bezugspunkt-Setzen mit orangenen Achs-tasten sperren

MP7296
Bezugspunkt-Setzen nicht sperren: 0
Bezugspunkt-Setzen über orangefarbige Achstasten sperren: 1

Status-Anzeige, Q-Parameter, Werkzeugdaten und Bearbeitungszeit rücksetzen

MP7300
Achtung: Aus Sicherheitsgründen die Einstellungen 0 bis 3 nicht verwenden! Die TNC löscht ansonsten die Werkzeugdaten.
Alles rücksetzen, wenn Programm angewählt wird: 0
Alles rücksetzen, wenn Programm angewählt wird und bei M2, M30, END PGM: 1
Nur Status-Anzeige, Bearbeitungszeit und Werkzeugdaten rücksetzen, wenn Programm angewählt wird: 2 Nur Status-Anzeige, Bearbeitungszeit und Werkzeugdaten rücksetzen, wenn Programm angewählt wird und bei M2, M30, END PGM: 3
Status-Anzeige, Bearbeitungszeit und Q-Parameter rücksetzen, wenn Programm angewählt wird: 4
Status-Anzeige, Bearbeitungszeit und Q-Parameter rücksetzen, wenn Programm angewählt wird und bei M2, M30, END PGM: 5
Status-Anzeige und Bearbeitungszeit rücksetzen, wenn Programm angewählt wird: 6
Status-Anzeige und Bearbeitungszeit rücksetzen, wenn Programm angewählt wird und bei M2, M30, END PGM: 7

Festlegungen für -Grafik-Darstellung

MP7310
Grafische Darstellung in drei Ebenen nach DIN 6, Teil 1, Projektionsmethode 1: Bit 0 = 0
Grafische Darstellung in drei Ebenen nach DIN 6, Teil 1, Projektionsmethode 2: Bit 0 = 1
Neue BLK FORM bei Zykl. 7 NULLPUNKT bezogen auf den alten Nullpunkt anzeigen: Bit 2 = 0
Neue BLK FORM bei Zykl. 7 NULLPUNKT bezogen auf den neuen Nullpunkt anzeigen: Bit 2 = 1
Cursorposition bei der Darstellung in drei Ebenen nicht anzeigen: Bit 4 = 0
Cursorposition bei der Darstellung in drei Ebenen anzeigen: Bit 4 = 1
Software-Funktionen der neuen 3D-Grafik aktiv: Bit 5 = 0
Software-Funktionen der neuen 3D-Grafik inaktiv: Bit 5 = 1

Begrenzung der zu simulierenden Schneidlänge eines Werkzeuges. Nur wirksam, wenn kein LCUTS definiert ist

MP7312
0 bis 99 999,9999 [mm]
Faktor mit dem der Werkzeug-Durchmesser multipliziert wird, um die Simulationsgeschwindigkeit zu erhöhen. Bei Eingabe von 0 nimmt die TNC eine unendlich lange Schneidlänge an, was die Simulationsdauer wesentlich erhöht.

Grafische Simulation ohne programmierte Spindelachse: Werkzeug-Radius

MP7315
0 bis 99 999,9999 [mm]

Grafische Simulation ohne programmierte Spindelachse: Eindringtiefe

MP7316
0 bis 99 999,9999 [mm]

Grafische Simulation ohne programmierte Spindelachse: M-Funktion für Start

MP7317.0
0 bis 88 (0: Funktion nicht aktiv)

Grafische Simulation ohne programmierte Spindelachse: -M-Funktion für Ende

MP7317.1
0 bis 88 (0: Funktion nicht aktiv)

Bildschirmschoner einstellen

MP7392.0
0 bis 99 [min]
Zeit in Minuten nach der der Bildschirmschoner einschaltet (0: Funktion nicht aktiv)

MP7392.1
Kein Bildschirmschoner aktiv: 0
Standard-Bildschirmschoner des X-Servers: 1
3D-Linienmuster: 2

Bearbeitung und Programmlauf |
Wirksamkeit Zyklus 11 MASSFAKTOR | MP7410 MASSFAKTOR wirkt in 3 Achsen: 0 MASSFAKTOR wirkt nur in der Bearbeitungsebene: 1
Werkzeugdaten/Kalibrierdaten verwalten | MP7411 Die TNC speichert die Kalibrierdaten für das Tastsystem intern: +0 Die TNC verwendet als Kalibrierdaten für das Tastsystem die Korrekturwerte des Tastsystems aus der Werkzeug-Tabelle: +1
SL-Zyklen | MP7420 Für die Zyklen 21, 22, 23, 24 gilt: Kanal um die Kontur fräsen im Uhrzeigersinn für Inseln und im Gegen-Uhrzeigersinn für Taschen: Bit 0 = 0 Kanal um die Kontur fräsen im Uhrzeigersinn für Taschen und im Gegen-Uhrzeigersinn für Inseln: Bit 0 = 1 Konturkanal vor dem Ausräumen fräsen: Bit 1 = 0 Konturkanal nach dem Ausräumen fräsen: Bit 1 = 1 Korrigierte Konturen vereinigen: Bit 2 = 0 Unkorrigierte Konturen vereinigen: Bit 2 = 1 Ausräumen jeweils bis zur Taschentiefe: Bit 3 = 0 Tasche vor jeder weiteren Zustellung vollständig umfräsen und ausräumen: Bit 3 = 1 Für die Zyklen 6, 15, 16, 21, 22, 23, 24 gilt: Werkzeug am Zyklusende auf die letzte vor dem Zyklus-Aufruf programmierte Position fahren: Bit 4 = 0 Werkzeug zum Zyklus-Ende nur in der Spinddelachse freifahren: Bit 4 = 1
Zyklus 4 TASCHENFRAESEN, Zyklus 5 KREISTASCHE: Überlappungsfaktor | MP7430 0,1 bis 1,414
Zulässige Abweichung des Kreisradius am Kreis-Endpunkt im Vergleich zum Kreis-Anfangspunkt | MP7431 0,0001 bis 0,016 [mm]
Endschaltertoleranz für M140 und M150 | MP7432 Funktion inaktiv: 0 Toleranz, um die der Software-Endschalter noch mit M140/M150 überfahren werden darf: 0.0001 bis 1.0000
Wirkungsweise verschiedener Zusatz- Funktionen M Hinweis: Die kV-Faktoren werden vom Maschinenhersteller festgelegt. Beachten Sie Ihr Maschinenhandbuch. | MP7440 Programmlauf-Halt bei M6: Bit 0 = 0 Kein Programmlauf-Halt bei M6: Bit 0 = 1 Kein Zyklus-Aufruf mit M89: Bit 1 = 0 Zyklus-Aufruf mit M89: Bit 1 = 1 Programmlauf-Halt bei M-Funktionen: Bit 2 = 0 Kein Programmlauf-Halt bei M-Funktionen: Bit 2 = 1 kV-Faktoren über M105 und M106 nicht umschaltbar: Bit 3 = 0 kV-Faktoren über M105 und M106 umschaltbar: Bit 3 = 1 Vorschub in der Werkzeugachse mit M103 F.. Reduzieren nicht aktiv: Bit 4 = 0 Vorschub in der Werkzeugachse mit M103 F.. Reduzieren aktiv: Bit 4 = 1 Reserviert: Bit 5 Genauhalt bei Positionierungen mit Drehachsen nicht aktiv: Bit 6 = 0 Genauhalt bei Positionierungen mit Drehachsen aktiv: Bit 6 = 1
Fehlermeldung bei Zyklusaufruf | MP7441 Fehlermeldung ausgeben, wenn kein M3/M4 aktiv: Bit 0 = 0 Fehlermeldung unterdrücken, wenn kein M3/M4 aktiv: Bit 0 = 1 reserviert: Bit 1 Fehlermeldung unterdrücken, wenn Tiefe positiv programmiert: Bit 2 = 0 Fehlermeldung ausgeben, wenn Tiefe positiv programmiert: Bit 2 = 1
M-Funktion für Spindel-Orientierung in den Bearbeitungszyklen | MP7442 Funktion inaktiv: 0 Orientierung direkt über die NC: -1 M-Funktion für die Spindel-Orientierung: 1 bis 999
Maximale Bahngeschwindigkeit bei Vorschub-Override 100% in den Programmlauf-Betriebsarten | MP7470 0 bis 99 999 [mm/min]
Vorschub für Ausgleichsbewegungen von Drehachsen | MP7471 0 bis 99 999 [mm/min]
Kompatibilitäts-Maschinen-Parameter für Nullpunkt-Tabellen | MP7475 Nullpunkt-Verschiebungen beziehen sich auf den Werkstück-Nullpunkt: 0 Bei Eingabe von 1 in älteren TNC-Steuerungen und in der Software 340420‑xx bezogen sich Nullpunkt-Verschiebungen auf den Maschinen-Nullpunkt. Diese Funktion steht jetzt nicht mehr zur Verfügung. Anstelle REF-bezogener Nullpunkt-Tabellen ist jetzt die Preset-Tabelle zu verwenden (siehe Bezugspunkt-Verwaltung mit der Bezugspunkt-Tabelle)
Zeit, die für die Einsatzdauer zusätzlich verrechnet werden soll | MP7485 0 bis 100 [%]


Steckerbelegung und Anschlusskabel für Datenschnittstellen

Weitere Informationen:
> Schnittstelle V.24/RS-232-C HEIDENHAIN-Geräte
> Fremdgeräte
> Schnittstelle V.11/RS-422
> Ethernet-Schnittstelle RJ45-Buchse


Schnittstelle V.24/RS-232-C HEIDENHAIN-Geräte

Die Schnittstelle erfüllt EN 50 178 „Sichere Trennung vom Netz“.

Bitte beachten, dass PIN 6 und 8 des Verbindungskabels 274545 gebrückt sind.

Bei Verwendung des 25-poligen Adapterblocks:

TNC |  | VB 365725‑xx |  |  | Adapterblock 310085‑01 |  | VB 274545‑xx
Stift | Belegung | Buchse | Farbe | Buchse | Stift | Buchse | Stift | Farbe | Buchse
1 | nicht belegen | 1 |  | 1 | 1 | 1 | 1 | weiß/braun | 1
2 | RXD | 2 | gelb | 3 | 3 | 3 | 3 | gelb | 2
3 | TXD | 3 | grün | 2 | 2 | 2 | 2 | grün | 3
4 | DTR | 4 | braun | 20 | 20 | 20 | 20 | braun | 8
5 | Signal GND | 5 | rot | 7 | 7 | 7 | 7 | rot | 7
6 | DSR | 6 | blau | 6 | 6 | 6 | 6 |  | 6
7 | RTS | 7 | grau | 4 | 4 | 4 | 4 | grau | 5
8 | CTS | 8 | rosa | 5 | 5 | 5 | 5 | rosa | 4
9 | nicht belegen | 9 |  |  |  |  | 8 | violett | 20
Geh. | Außenschirm | Geh. | Außenschirm | Geh. | Geh. | Geh. | Geh. | Außenschirm | Geh.

Bei Verwendung des 9-poligen Adapterblocks:

TNC |  | VB 355484‑xx |  |  | Adapterblock 363987‑02 |  | VB 366964‑xx
Stift | Belegung | Buchse | Farbe | Stift | Buchse | Stift | Buchse | Farbe | Buchse
1 | nicht belegen | 1 | rot | 1 | 1 | 1 | 1 | rot | 1
2 | RXD | 2 | gelb | 2 | 2 | 2 | 2 | gelb | 3
3 | TXD | 3 | weiß | 3 | 3 | 3 | 3 | weiß | 2
4 | DTR | 4 | braun | 4 | 4 | 4 | 4 | braun | 6
5 | Signal GND | 5 | schwarz | 5 | 5 | 5 | 5 | schwarz | 5
6 | DSR | 6 | violett | 6 | 6 | 6 | 6 | violett | 4
7 | RTS | 7 | grau | 7 | 7 | 7 | 7 | grau | 8
8 | CTS | 8 | weiß/grün | 8 | 8 | 8 | 8 | weiß/grün | 7
9 | nicht belegen | 9 | grün | 9 | 9 | 9 | 9 | grün | 9
Geh. | Außenschirm | Geh. | Außenschirm | Geh. | Geh. | Geh. | Geh. | Außenschirm | Geh.


Fremdgeräte

Die Stecker-Belegung am Fremdgerät kann erheblich von der Stecker-Belegung eines HEIDENHAIN-Gerätes abweichen.

Sie ist vom Gerät und der Übertragungsart abhängig. Entnehmen Sie bitte die Steckerbelegung des Adapter-Blocks der untenstehenden Tabelle.

Adapterblock 363987‑02 |  | VB 366964‑xx
Buchse | Stift | Buchse | Farbe | Buchse
1 | 1 | 1 | rot | 1
2 | 2 | 2 | gelb | 3
3 | 3 | 3 | weiß | 2
4 | 4 | 4 | braun | 6
5 | 5 | 5 | schwarz | 5
6 | 6 | 6 | violett | 4
7 | 7 | 7 | grau | 8
8 | 8 | 8 | weiß / grün | 7
9 | 9 | 9 | grün | 9
Geh. | Geh. | Geh. | Außenschirm | Geh.


Schnittstelle V.11/RS-422

An der V.11-Schnittstelle werden nur Fremdgeräte angeschlossen.

Die Schnittstelle erfüllt EN 50 178 „Sichere Trennung vom Netz“.

Die Steckerbelegungen von TNC-Logikeinheit (X28) und Adapter-Block sind identisch.

TNC |  | VB 355484‑xx |  |  | Adapterblock 363987‑01
Buchse | Belegung | Stift | Farbe | Buchse | Stift | Buchse
1 | RTS | 1 | rot | 1 | 1 | 1
2 | DTR | 2 | gelb | 2 | 2 | 2
3 | RXD | 3 | weiß | 3 | 3 | 3
4 | TXD | 4 | braun | 4 | 4 | 4
5 | Signal GND | 5 | schwarz | 5 | 5 | 5
6 | CTS | 6 | violett | 6 | 6 | 6
7 | DSR | 7 | grau | 7 | 7 | 7
8 | RXD | 8 | weiß / grün | 8 | 8 | 8
9 | TXD | 9 | grün | 9 | 9 | 9
Geh. | Außenschirm | Geh. | Außenschirm | Geh. | Geh. | Geh.


Ethernet-Schnittstelle RJ45-Buchse

    Maximale Kabellänge:

  • Ungeschirmt: 100 m
  • Geschirmt: 400 m
Pin | Signal | Beschreibung
1 | TX+ | Transmit Data
2 | TX- | Transmit Data
3 | REC+ | Receive Data
4 | frei |
5 | frei |
6 | REC- | Receive Data
7 | frei |
8 | frei |


Technische Information

    Symbolerklärung

  • Standard

  • Achs-Option

  • Software-Option 1

  • Software-Option 2

Benutzer-Funktionen

Kurzbeschreibung
  • Grundausführung: 3 Achsen plus Spindel
  • 16 weitere Achsen oder 15 weitere Achsen plus 2. Spindel
  • Digitale Strom- und Drehzahl-Regelung

Programm-Eingabe

Im HEIDENHAIN-Klartext-Dialog, mit smarT.NC und nach DIN/ISO

Positions-Angaben
  • Soll-Positionen für Geraden und Kreise in rechtwinkligen Koordinaten oder Polarkoordinaten
  • Maßangaben absolut oder inkremental
  • Anzeige und Eingabe in mm oder inch
  • Anzeige des Handrad-Wegs bei der Bearbeitung mit Handrad-Überlagerung

Werkzeug-Korrekturen
  • Werkzeug-Radius in der Bearbeitungsebene und Werkzeug-Länge
  • Radiuskorrigierte Kontur bis zu 99 Sätze vorausberechnen (M120)
  • Dreidimensionale Werkzeug-Radiuskorrektur zur nachträglichen Änderung von Werkzeugdaten, ohne das Programm erneut berechnen zu müssen

Werkzeug-Tabellen

Mehrere Werkzeug-Tabellen mit jeweils bis zu 30000 Werkzeugen

Schnittdaten-Tabellen

Schnittdaten-Tabellen zur automatischen Berechnung von Spindel-Drehzahl und Vorschub aus werkzeugspezifischen Daten (Schnittgeschwindigkeit, Vorschub pro Zahn)

Konstante -Bahngeschwindigkeit
  • Bezogen auf die Werkzeug-Mittelpunktsbahn
  • Bezogen auf die Werkzeugschneide

Parallelbetrieb

Programm mit grafischer Unterstützung erstellen, während ein anderes Programm abgearbeitet wird

3D-Bearbeitung (Software-Option 2)
  • 3D-Werkzeug-Korrektur über Flächennormalen- Vektor
  • Ändern der Schwenkkopfstellung mit dem elektronischen Handrad während des Programmlaufs; Position der Werkzeugspitze bleibt unverändert (TCPM = Tool Center Point Management)
  • Werkzeug senkrecht auf der Kontur halten
  • Werkzeug-Radiuskorrektur senkrecht zur Bewegungs- und -Werkzeugrichtung
  • Spline-Interpolation

Rundtisch-Bearbeitung (Software-Option 1)
  • Programmieren von Konturen auf der Abwicklung eines Zylinders
  • Vorschub in mm/min

Konturelemente
  • Gerade
  • Fase
  • Kreisbahn
  • Kreismittelpunkt
  • Kreisradius
  • Tangential anschließende Kreisbahn
  • Ecken-Runden

Anfahren und Verlassen der Kontur
  • Über Gerade: tangential oder senkrecht
  • Über Kreis

Freie Konturprogrammierung FK
  • Freie Konturprogrammierung FK im HEIDENHAIN-Klartext mit grafischer Unterstützung für nicht NC-gerecht bemaßte Werkstücke

Programmsprünge
  • Unterprogramme
  • Programmteil-Wiederholung
  • Beliebiges Programm als Unterprogramm

Bearbeitungs-Zyklen
  • Bohrzyklen zum Bohren, Tiefbohren, Reiben, Ausdrehen, Senken Gewindebohren mit und ohne Ausgleichsfutter
  • Zyklen zum Fräsen von Innen- und Außengewinden
  • Rechteck- und Kreistasche schruppen und schlichten
  • Zyklen zum Abzeilen ebener und schiefwinkliger Flächen
  • Zyklen zum Fräsen gerader und kreisförmiger Nuten
  • Punktemuster auf Kreis und Linien
  • Konturtasche – auch konturparallel
  • Konturzug
  • Zusätzlich können Herstellerzyklen – spezielle vom Maschinenhersteller erstellte Bearbeitungszyklen – integriert werden

Koordinaten-Umrechnung
  • Verschieben, Drehen, Spiegeln
  • Maßfaktor (achsspezifisch)
  • Schwenken der Bearbeitungsebene (Software-Option 1)

Q-Parameter Programmieren mit Variablen

  • Mathematische Funktionen =, +, –, *, /, sin α , cos α
  • Logische Verknüpfungen (=, =/, <, >)
  • Klammerrechnung
  • tan α , arcus sin, arcus cos, arcus tan, an, en, ln, log, -Absolutwert einer Zahl, Konstante π , Negieren, -Nachkommastellen oder Vorkommastellen abschneiden
  • Funktionen zur Kreisberechnung
  • String-Parameter

Programmierhilfen
  • Taschenrechner
  • Kontextsensitive Hilfe-Funktion bei Fehlermeldungen
  • Kontextsensitives Hilfesystem TNCguide (FCL 3-Funktion)
  • Grafische Unterstützung beim Programmieren von Zyklen
  • Kommentar-Sätze im NC-Programm

Teach-In
  • Ist-Postitionen werden direkt ins NC-Programm übernommen

Test-Grafik
Darstellungsarten

    Grafische Simulation des Bearbeitungsablaufs auch wenn ein anderes Programm abgearbeitet wird

  • Draufsicht / Darstellung in 3 Ebenen / 3D-Darstellung
  • Ausschnitt-Vergrößerung

Programmier-Grafik
  • In der Betriebsart „Programm-Einspeichern” werden die eingegebenen NC-Sätze mitgezeichnet (2D-Strich-Grafik) auch wenn ein anderes Programm abgearbeitet wird

Bearbeitungs-Grafik
Darstellungsarten

  • Grafische Darstellung des abgearbeiteten Programms in Draufsicht / Darstellung in 3 Ebenen / 3D-Darstellung

Bearbeitungszeit
  • Berechnen der Bearbeitungszeit in der Betriebsart „Programm-Test”
  • Anzeige der aktuellen Bearbeitungszeit in den -Programmlauf--Betriebsarten

Wiederanfahren an die Kontur
  • Satzvorlauf zu einem beliebigen Satz im Programm und Anfahren der errechneten Soll-Position zum Fortführen der Bearbeitung
  • Programm unterbrechen, Kontur verlassen und wieder anfahren

Nullpunkt-Tabellen
  • Mehrere Nullpunkt-Tabellen

Paletten-Tabellen
  • Paletten-Tabellen mit beliebig vielen Einträge zur Auswahl von Paletten, NC-Programmen und Nulllpunkten können werkstück- oder -werkzeugorientiert abgearbeitet werden

Tastsystem-Zyklen
  • Tastsystem kalibrieren
  • Werkstück-Schieflage manuell und automatisch kompensieren
  • Bezugspunkt manuell und automatisch setzen
  • Werkstücke automatisch vermessen
  • Zyklen zur automatischen Werkzeugvermessung
  • Zyklen zur automatischen Kinematik-Vermessung
Technische-Daten

Komponenten
  • Hauptrechner MC 74xx ode r MC 75xx, MC 6441, MC 65xx oder MC 66xx
  • Regler-Einheit CC 6106, 6108 oder 6110
  • Bedienfeld
  • TFT-Farb-Flachbildschirm mit Softkeys 15,1 Zoll oder 19 Zoll
  • Industrie-PC IPC 6341 mit Windows 7 (Option)

Programm-Speicher

Mindestens 21 GByte, je nach Hauptrechner bis zu 130 GByte

Eingabefeinheit und Anzeigeschritt
  • bis 0,1 µm bei Linearachsen
  • bis 0,000 1° bei Winkelachsen

Eingabebereich
  • Maximum 99 999,999 mm (3.937 Zoll) bzw. 99 999,999°

Interpolation
  • Gerade in 4 Achsen
  • Gerade in 5 Achsen (Export genehmigungspflichtig, Software-Option 1)
  • Kreis in 2 Achsen
  • Kreis in 3 Achsen bei geschwenkter Bearbeitungsebene (Software-Option 1)
  • Schraubenlinie:
    Überlagerung von Kreisbahn und Gerade
  • Spline:
    Abarbeiten von Splines (Polynom 3. Grades)

Satzverarbeitungszeit
3D-Gerade ohne Radiuskorrektur

  • 0,5 ms

Achsregelung
  • Lageregelfeinheit: Signalperiode des Positionsmessgeräts/1024
  • Zykluszeit Lageregler:1,8 ms
  • Zykluszeit Drehzahlregler: 600 µs
  • Zykluszeit Stromregler: minimal 100 µs

Verfahrweg
  • Maximal 100 m (3 937 Zoll)

Spindeldrehzahl
  • Maximal 40 000 U/min (bei 2 Polpaaren)

Fehler-Kompensation
  • Lineare und nichtlineare Achsfehler, Lose, Umkehrspitzen bei Kreisbewegungen, Wärmeausdehnung
  • Haftreibung

Datenschnittstellen
  • je eine V.24 / RS-232-C und V.11 / RS-422 max. 115 kBaud
  • Erweiterte Datenschnittstelle mit LSV-2-Protokoll zum externen Bedienen der TNC über die Datenschnittstelle mit HEIDENHAIN-Software TNCremo
  • Ethernet-Schnittstelle 100 Base T
    ca. 2 bis 5 MBaud (abhängig vom Dateityp und der Netzauslastung)
  • USB 2.0-Schnittstelle
    Zum Anschluss von Zeigegeräten (Maus) und Block-Geräten (Speicher-Sticks, Festplatten, CD-ROM-Laufwerke)

Umgebungstemperatur
  • Betrieb: 0°C bis +45°C
  • Lagerung: -30°C bis +70°C
Zubehör

Elektronische Handräder
  • ein tragbares Funkhandrad HR 550 FS mit Display oder
  • ein HR 520 tragbares Handrad mit Display oder
  • ein HR 420 tragbares Handrad mit Display oder
  • ein HR 410 tragbares Handrad oder
  • ein HR 130 Einbau-Handrad oder
  • bis zu drei HR 150 Einbau-Handräder über Handrad-Adapter HRA 110

Tastsysteme
  • TS 220: schaltendes Tastsystem mit Kabelanschluss oder
  • TS 440: schaltendes Tastsystem mit Infrarot-Übertragung
  • TS 444: batterieloses, schaltendes Tastsystem mit Infrarot-Übertragung
  • TS 640: schaltendes Tastsystem mit Infrarot-Übertragung
  • TS 740: hochgenaues, schaltendes Tastsystem mit Infrarot-Übertragung
  • TT 140: schaltendes Tastsystem zur Werkzeug-Vermessung
Software-Option 1

Rundtisch-Bearbeitung
  • Programmieren von Konturen auf der Abwicklung eines Zylinders
  • Vorschub in mm/min

Koordinaten-Umrechnungen
  • Schwenken der Bearbeitungsebene

Interpolation
  • Kreis in 3 Achsen bei geschwenkter Bearbeitungsebene
Software-Option 2

3D-Bearbeitung
  • 3D-Werkzeug-Korrektur über Flächennormalen-Vektor
  • Ändern der Schwenkkopfstellung mit dem elektronischen Handrad während des -Programmlaufs; Position der Werkzeugspitze bleibt unverändert (TCPM = Tool Center Point Management)
  • Werkzeug senkrecht auf der Kontur halten
  • Werkzeug-Radiuskorrektur senkrecht zur Bewegungs- und -Werkzeugrichtung
  • Spline-Interpolation

Interpolation
  • Gerade in 5 Achsen (Export genehmigungspflichtig)
Software-Option DXF-Konverter

Aus DXF-Daten Kontur-Programme und Bearbeitungspositionen extrahieren aus Klartext-Dialogprogrammen Konturabschnitte extrahieren.

  • Unterstütztes DXF-Format: AC1009 (AutoCAD R12)
  • Für Klartext-Dialog- und smarT.NC
  • Komfortable Bezugspunkt-Festlegung
  • Grafisches wählen von Konturabschnitten aus Klartext-Dialog-Programmen
Software-Option dynamische Kollisions-Überwachung (DCM)

Kollisions-Überwachung in allen Maschinen-Betriebsarten
  • Maschinenhersteller definiert zu überwachende Objekte
  • Spannmittelüberwachung zusätzlich möglich
  • Dreistufige Warnung im Manuellen Betrieb
  • Programm-Unterbrechung im Automatik-Betrieb
  • Überwachung auch von 5-Achs-Bewegungen
  • Programm-Test auf mögliche Kollisionen vor der Bearbeitung
Software-Option Globale Programm-Einstellungen

Funktion zur Überlagerung von Koordinaten-Transformationen in den Abarbeiten-Betriebsarten
  • Achsen tauschen
  • Überlagerte Nullpunkt-Verschiebung
  • Überlagertes Spiegeln
  • Sperren von Achsen
  • Handrad-Überlagerung
  • Überlagerte Grunddrehung und Rotation
  • Vorschubfaktor
Software-Option Adaptive Vorschubregelung AFC

Funktion adaptive Vorschubregelung zur Optimierung der Schnittbedingungen bei Serienproduktion
  • Erfassung der tatsächlichen Spindelleistung durch einen Lernschnitt
  • Definition von Grenzen, in denen die automatische Vorschubregelung stattfindet
  • Vollautomatische Vorschubregelung beim Abarbeiten
Software-Option KinematicsOpt

Tastsystem-Zyklen zum automatischen Prüfen und Optimieren der Maschinenkinematik
  • Aktive Kinematik sichern/wiederherstellen
  • Aktive Kinematik prüfen
  • Aktive Kinematik optimieren
Software-Option 3D-ToolComp

Eingriffswinkelabhängige 3D Werkzeug-Radiuskorrektur
  • Delta-Radius des Werkzeugs abhängig vom Eingriffswinkel am Werkstück kompensieren
  • LN-Sätze sind Voraussetzung
  • Korrekturwerte sind über eine separate Tabelle definierbar
Software-Option erweiterte Werkzeug-Verwaltung

Vom Maschinenhersteller über Python-Scripte anpassbare Werkzeug-Verwaltung.
  • Gemichte Darstellung beliebiger Daten aus Werkzeug- und Platz-Tabelle
  • Formularbasiertes Editieren der Werkzeugdaten
  • Werkzeug-Einsatz- und -folgelidte: Bestücksungsplan
Software-Option Interpolationsdrehen

Interpolationsdrehen
  • Schlichten von rotationssymmetrischen Absätzen durch Interpolation der Spindel mit den Achsen der Bearbeitungsebene
Software-Option CAD-Viewer

Öffnen von 3D-Modellen auf der Steuerung.
  • Öffnen von IGES-Dateien
  • Öffnen von STEP-Dateien
Software-Option Remote Desktop Manager

Fernbedienung externer Rechner-Einheiten (z. B. Windows-PC) über die Benutzer-Oberfläche der TNC
  • Windows auf einer separaten Rechner-Einheit
  • Eingebunden in die Oberfläche der TNC
Software-Option Cross Talk Compensation CTC

Kompensation von Achskopplungen
  • Erfassung von dynamisch bedingten Positionsabweichung durch Achsbeschleunigungen
  • Kompensation des TCPs
Software-Option Position Adaptive Control PAC

Anpassung von Regelparametern
  • Anpassung von Regelparametern in Abhängigkeit von der Stellung der Achsen im Arbeitsraum
  • Anpassung von Regelparametern in Abhängigkeit von der Geschwindigkeit oder der Beschleunigung einer Achse
Software-Option Load Adaptive Control LAC

Dynamische Anpassung von Regelparametern
  • Automatisches ermitteln von Werkstückmassen und Reibkräften
  • Während der Bearbeitung die Parameter der adaptiven Vorsteuerung kontinuierlich an die aktuelle Masse des Werkstücks anpassen
Software-Option Active Chatter Control ACC

Funktion zur Ratter-Unterdrückung
  • Regler-Funktion, die beim Leistungsfräsen die Ratterneigung erheblich reduzieren kann
  • Schonung der Maschinenmechanik
  • Verbesserung der Werkstück-Oberfläche
  • Reduzierung der Bearbeitungszeit
Upgrade-Funktionen FCL 2

Freischaltung von wesentlichen Weiterentwicklungen
  • Virtuelle Werkzeugachse
  • Antast-Zyklus 441, schnelles Antasten
  • CAD offline Punktefilter
  • 3D-Liniengrafik
  • Konturtasche: Jeder Teilkontur separate Tiefe zuweisen
  • smarT.NC: Koordinaten-Transformationen
  • smarT.NC: PLANE-Funktion
  • smarT.NC: Grafisch unterstützter Satzvorlauf
  • Erweiterte USB-Funktionalität
  • Netzwerk-Einbindung über DHCP und DNS
Upgrade-Funktionen FCL 3

Freischaltung von wesentlichen Weiterentwicklungen
  • Tastsystem-Zyklus zum 3D-Antasten
  • Antastzyklen 408 und 409 (UNIT 408 und 409 in smarT.NC) zum Setzen eines Bezugspunktes in der Mitte einer Nut bzw. in der Mitte eines Steges
  • PLANE-Funktion: Achswinkel-Eingabe
  • Benutzer-Dokumentation als kontextsensitive Hilfe direkt auf der TNC
  • Vorschubreduzierung bei Konturtaschenbearbeitung wenn Werkzeug im Volleingriff ist
  • smarT.NC: Konturtasche auf Muster
  • smarT.NC: Parallel-Programmierung möglich
  • smarT.NC: Preview von Konturprogrammen im Datei-Manager
  • smarT.NC: Positionierstrategie bei Punkte-Bearbeitungen
Upgrade-Funktionen FCL 4

Freischaltung von wesentlichen Weiterentwicklungen
  • Grafische Darstellung des Schutzraumes bei aktiver Kollisionsüberwachung DCM
  • Handradüberlagerung in gestopptem Zustand bei aktiver Kollisionsüberwachung DCM
  • 3D-Grunddrehung (Aufspannkompensation, muss vom Maschinenhersteller angepasst werden)

Eingabe-Formate und Einheiten von TNC-Funktionen
Positionen, Koordinaten, Kreisradien, Fasenlängen | -99 999.9999 bis +99 999.9999 (5,4: Vorkommastellen,Nachkommastellen) [mm]
Kreisradien | -99 999.9999 bis +99 999.9999 bei direkter Eingabe, über Q-Paramter-Programmierung bis zu 210 m Radius möglich (5,4: Vorkommastellen,Nachkommastellen) [mm]
Werkzeug-Nummern | 0 bis 32 767,9 (5,1)
Werkzeug-Namen | 32 Zeichen, bei TOOL CALL zwischen ““ geschrieben. Erlaubte Sonderzeichen: #, $, %, &, -
Delta-Werte für Werkzeug-Korrekturen | -999,9999 bis +999,9999 (3,4) [mm]
Spindeldrehzahlen | 0 bis 99 999,999 (5,3) [U/min]
Vorschübe | 0 bis 99 999,999 (5,3) [mm/min] oder [mm/Zahn] oder [mm/U]
Verweilzeit in Zyklus 9 | 0 bis 3 600,000 (4,3) [s]
Gewindesteigung in diversen Zyklen | -99,9999 bis +99,9999 (2,4) [mm]
Winkel für Spindel-Orientierung | 0 bis 360,0000 (3,4) [°]
Winkel für Polar-Koordinaten, Rotation, Ebene schwenken | -360,0000 bis 360,0000 (3,4) [°]
Polarkoordinaten-Winkel für Schraubenlinien-Interpolation (CP) | -99 999,9999 bis +99 999,9999 (5,4) [°]
Nullpunkt-Nummern in Zyklus 7 | 0 bis 2 999 (4,0)
Maßfaktor in Zyklen 11 und 26 | 0,000001 bis 99,999999 (2,6)
Zusatz-Funktionen M | 0 bis 999 (3,0)
Q-Parameter-Nummern | 0 bis 1999 (4,0)
Q-Parameter-Werte | -999 999 999 bis +999 999 999 (9 Stellen, Gleitkomma)
Marken (LBL) für Programm-Sprünge | 0 bis 999 (3,0)
Marken (LBL) für Programm-Sprünge | Beliebiger Textstring zwischen Hochkommas (““)
Anzahl von Programmteil-Wiederholungen REP | 1 bis 65 534 (5,0)
Fehler-Nummer bei Q-Parameter-Funktion FN14 | 0 bis 1 099 (4,0)
Spline-Parameter K | -9,9999999 bis +9,9999999 (1,7)
Exponent für Spline-Parameter | -255 bis 255 (3,0)
Normalenvektoren N und T bei 3D-Korrektur | -9,9999999 bis +9,9999999 (1,7)


Puffer-Batterie wechseln

Wenn die Steuerung ausgeschaltet ist, versorgt eine Puffer-Batterie die TNC mit Strom, um Daten im RAM-Speicher nicht zu verlieren.

Wenn die TNC die Meldung Puffer-Batterie wechseln anzeigt, müssen Sie die Batterie austauschen:

Achtung Gefahr für Leben!

Zum Wechseln der Puffer-Batterie Maschine und TNC ausschalten!

Die Puffer-Batterie darf nur von entsprechend geschultem Personal gewechselt werden!

Batterie-Typ: 1 Lithium-Batterie, Typ CR 2450N (Renata) ID 315878‑01

  1. Die Puffer-Batterie befindet sich an der Rückseite der MC 422 D
  2. Batterie wechseln; neue Batterie kann nur in der richtigen Lage eingesetzt werden


Übersichtstabellen

Weitere Informationen:
> Übersichtstabellen


Übersichtstabellen

Übersichtstabellen

Weitere Informationen:
> Bearbeitungszyklen
> Zusatz-Funktionen


Bearbeitungszyklen

Zyklus-Nummer | Zyklus-Bezeichnung | DEF-aktiv | CALL-aktiv
7 | Nullpunkt-Verschiebung | ■ |
8 | Spiegeln | ■ |
9 | Verweilzeit | ■ |
10 | Drehung | ■ |
11 | Maßfaktor | ■ |
12 | Programm-Aufruf | ■ |
13 | Spindel-Orientierung | ■ |
14 | Konturdefinition | ■ |
19 | Bearbeitungsebene schwenken | ■ |
20 | Kontur-Daten SL II | ■ |
21 | Vorbohren SL II |  | ■
22 | Räumen SL II |  | ■
23 | Schlichten Tiefe SL II |  | ■
24 | Schlichten Seite SL II |  | ■
25 | Konturzug |  | ■
26 | Maßfaktor Achsspezifisch | ■ |
27 | Zylinder-Mantel |  | ■
28 | Zylinder-Mantel Nutenfräsen |  | ■
29 | Zylinder-Mantel Steg |  | ■
30 | 3D-Daten abarbeiten |  | ■
32 | Toleranz | ■ |
39 | Zylinder-Mantel Außenkontur |  | ■
200 | Bohren |  | ■
201 | Reiben |  | ■
202 | Ausdrehen |  | ■
203 | Universal-Bohren |  | ■
204 | Rückwärts-Senken |  | ■
205 | Universal-Tiefbohren |  | ■
206 | Gewindebohren mit Ausgleichsfutter, neu |  | ■
207 | Gewindebohren ohne Ausgleichsfutter, neu |  | ■
208 | Bohrfräsen |  | ■
209 | Gewindebohren mit Spanbruch |  | ■
220 | Punktemuster auf Kreis | ■ |
221 | Punktemuster auf Linien | ■ |
230 | Abzeilen |  | ■
231 | Regelfläche |  | ■
232 | Planfräsen |  | ■
240 | Zentrieren |  | ■
241 | Einlippen-Bohren |  | ■
247 | Bezugspunkt Setzen | ■ |
251 | Rechtecktasche Komplettbearbeitung |  | ■
252 | Kreistasche Komplettbearbeitung |  | ■
253 | Nutenfräsen |  | ■
254 | Runde Nut |  | ■
256 | Rechteckzapfen Komplettbearbeitung |  | ■
257 | Kreiszapfen Komplettbearbeitung |  | ■
262 | Gewindefräsen |  | ■
263 | Senkgewindefräsen |  | ■
264 | Bohrgewindefräsen |  | ■
265 | Helix-Bohrgewindefräsen |  | ■
267 | Aussengewindefräsen |  | ■
270 | Konturzug-Daten | ■ |
275 | Konturnut trochoidal |  | ■


Zusatz-Funktionen

M | Wirkung | Wirkung am Satz - | Anfang | Ende | Seite
M0 | Programmlauf HALT /ggf. Spindel HALT/ggf. Kühlmittel AUS |  |  | ■ | Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel
M1 | Wahlweiser Programmlauf HALT/Spindel HALT/Kühlmittel AUS (maschinenabhängig) |  |  | ■ | Wahlweiser Programmlauf-Halt
M2 | Programmlauf HALT/Spindel HALT/Kühlmittel AUS/ggf. Löschen der Status-Anzeige (abhängig von Maschinen-Parameter)/Rücksprung zu Satz 1 |  |  | ■ | Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel
M3 M4 M5 | Spindel EIN im Uhrzeigersinn Spindel EIN gegen den Uhrzeigersinn Spindel HALT |  | ■ ■ | ■ | Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel
M6 | Werkzeugwechsel/Programmlauf HALT (abhängig von Maschinen-Parameter)/Spindel HALT |  |  | ■ | Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel
M8 M9 | Kühlmittel EIN Kühlmittel AUS |  | ■ | ■ | Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel
M13 M14 | Spindel EIN im Uhrzeigersinn /Kühlmittel EIN Spindel EIN gegen den Uhrzeigersinn/Kühlmittel ein |  | ■ ■ |  | Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel
M30 | Gleiche Funktion wie M2 |  |  | ■ | Zusatz-Funktionen für Programmlauf-Kontrolle, Spindel und Kühlmittel
M89 | Freie Zusatz-Funktion oder Zyklus-Aufruf, modal wirksam (abhängig von Maschinen-Parameter) |  | ■ | ■ | Zyklen-Handbuch
M90 | Nur im geschleppten Betrieb: konstante Bahngeschwindigkeit an Ecken |  |  | ■ | Ecken verschleifen: M90
M91 | Im Positioniersatz: Koordinaten beziehen sich auf den Maschinen-Nullpunkt |  | ■ |  | Maschinenbezogene Koordinaten programmieren: M91/M92
M92 | Im Positioniersatz: Koordinaten beziehen sich auf eine vom Maschinenhersteller definierte Position, z.B. auf die Werkzeugwechsel-Position |  | ■ |  | Maschinenbezogene Koordinaten programmieren: M91/M92
M94 | Anzeige der Drehachse reduzieren auf einen Wert unter 360° |  | ■ |  | Anzeige der Drehachse auf Wert unter 360° reduzieren: M94
M97 | Kleine Konturstufen bearbeiten |  |  | ■ | Kleine Konturstufen bearbeiten: M97
M98 | Offene Konturen vollständig bearbeiten |  |  | ■ | Offene Konturecken vollständig bearbeiten: M98
M99 | Satzweiser Zyklus-Aufruf |  |  | ■ | Zyklen-Handbuch
M101 M102 | Automatischer Werkzeugwechsel mit Schwesterwerkzeug, bei abgelaufener Standzeit M101 rücksetzen |  |  | ■ ■ | Automatischer Werkzeugwechsel beim Überschreiten der Standzeit: M101
M103 | Vorschub beim Eintauchen reduzieren auf Faktor F (prozentualer Wert) |  | ■ |  | Vorschubfaktor für Eintauchbewegungen: M103
M104 | Zuletzt gesetzten Bezugspunkt wieder aktivieren |  | ■ |  | Zuletzt gesetzten Bezugspunkt aktivieren: M104
M105 M106 | Bearbeitung mit zweitem kv-Faktor durchführen Bearbeitung mit erstem kv-Faktor durchführen |  | ■ ■ |  | Allgemeine Anwender-parameter
M107 M108 | Fehlermeldung bei Schwesterwerkzeugen mit Aufmaß unterdrücken M107 rücksetzen |  | ■ | ■ | Automatischer Werkzeugwechsel beim Überschreiten der Standzeit: M101
M109 M110 M111 | Konstante Bahngeschwindigkeit an der Werkzeug-Schneide (Vorschub-Erhöhung und -Reduzierung) Konstante Bahngeschwindigkeit an der Werkzeug-Schneide (nur Vorschub-Reduzierung) M109/M110 rücksetzen |  | ■ ■ | ■ | Vorschubgeschwindigkeit bei Kreisbögen: M109/M110/M111
M114 M115 | Autom. Korrektur der Maschinengeometrie beim Arbeiten mit Schwenkachsen M114 rücksetzen |  | ■ | ■ | Automatische Korrektur der Maschinengeometrie beim Arbeiten mit Schwenkachsen: M114 (Software-Option 2)
M116 M117 | Vorschub bei Drehachsen in mm/mi n M116 rücksetzen |  | ■ | ■ | Vorschub in mm/min bei Drehachsen A, B, C: M116 (Software-Option 1)
M118 | Handrad-Positionierung während des Programmlaufs überlager n |  | ■ |  | Handrad-Positionierung während des Programmlaufs überlagern: M118
M120 | Radiuskorrigierte Kontur vorausberechnen (LOOK AHEAD) |  | ■ |  | Radiuskorrigierte Kontur vorausberechnen (LOOK AHEAD): M120
M124 | Punkte beim Abarbeiten von nicht korrigierten Geradensätzen nicht berücksichtigen |  | ■ |  | Punkte beim Abarbeiten von nicht korrigierten Geradensätzen nicht berücksichtigen: M124
M126 M127 | Drehachsen wegoptimiert verfahren M126 rücksetzen |  | ■ | ■ | Drehachsen wegoptimiert fahren: M126
M128 M129 | Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM) M128 rücksetzen |  | ■ | ■ | Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM): M128 (Software-Option 2)
M130 | Im Positioniersatz: Punkte beziehen sich auf das ungeschwenkte Koordinatensystem |  | ■ |  | Positionen im ungeschwenkten Koordinaten-System bei geschwenkter Bearbeitungsebene anfahren: M130
M134 M135 | Genauhalt an nicht tangentialen Konturübergängen bei Positionierungen mit Drehachsen M134 rücksetzen |  | ■ | ■ | Genauhalt an Ecken mit nicht tangentialen Übergängen: M134
M136 M137 | Vorschub F in Millimeter pro Spindel-Umdrehung M136 rücksetzen |  | ■ | ■ | Vorschub in Millimeter/Spindel-Umdrehung: M136
M138 | Auswahl von Schwenkachsen |  | ■ |  | Auswahl von Schwenkachsen: M138
M140 | Rückzug von der Kontur in Werkzeugachsen-Richtung |  | ■ |  | Rückzug von der Kontur in Werkzeugachsen-Richtung: M140
M141 | Tastsystem-Überwachung unterdrücken |  | ■ |  | Tastsystem-Überwachung unterdrücken: M141
M142 | Modale Programminformationen löschen |  | ■ |  | Modale Programminformationen löschen: M142
M143 | Grunddrehung löschen |  | ■ |  | Grunddrehung löschen: M143
M144 M145 | Berücksichtigung der Maschinen-Kinematik in IST/SOLL-Positionen am Satzende M144 zurücksetzen |  | ■ | ■ | Berücksichtigung der Maschinen-Kinematik in IST/SOLL-Positionen am Satzende: M144 (Software-Option 2)
M148 M149 | Werkzeug bei NC-Stopp automatisch von der Kontur abheben M148 zurücksetzen |  | ■ | ■ | Werkzeug bei NC-Stopp automatisch von der Kontur abheben: M148
M150 | Endschaltermeldung unterdrücken (satzweise wirksame Funktion) |  | ■ |  | Endschaltermeldung unterdrücken: M150
M200 M201 M202M203 M204 | Laserschneiden: Programmierte Spannung direkt ausgeben Laserschneiden: Spannung als Funktion der Strecke ausgeben Laserschneiden: Spannung als Funktion der Geschwindigkeit ausgeben Laserschneiden: Spannung als Funktion der Zeit ausgeben (Rampe) Laserschneiden: Spannung als Funktion der Zeit ausgeben (Puls) |  | ■ ■ ■ ■ ■ |  | Zusatz-Funktionen für Laser-Schneidmaschinen


Funktionsübersicht DIN/ISO iTNC 530

Weitere Informationen:
> Funktionsübersicht DIN/ISO iTNC 530


Funktionsübersicht DIN/ISO iTNC 530

Funktionsübersicht DIN/ISO iTNC 530

M-Funktionen
M00 M01 M02 | Programmlauf HALT/Spindel HALT/Kühlmittel AUS Wahlweiser Programmlauf HALT Programmlauf HALT/Spindel HALT/Kühlmittel AUS/ggf. Löschen der Status-Anzeige (abhängig von Maschinen-Parameter)/Rücksprung zu Satz 1
M03 M04 M05 | Spindel EIN im Uhrzeigersinn Spindel EIN gegen den Uhrzeigersinn Spindel HALT
M06 | Werkzeugwechsel/Programmlauf HALT (abhängig von Maschinen-Parameter)/Spindel HALT
M08 M09 | Kühlmittel EIN Kühlmittel AUS
M13 M14 | Spindel EIN im Uhrzeigersinn/Kühlmittel EIN Spindel EIN gegen den Uhrzeigersinn/Kühlmittel ein
M30 | Gleiche Funktion wie M02
M89 | Freie Zusatz-Funktion oder Zyklus-Aufruf, modal wirksam (abhängig von Maschinen-Parameter)
M90 | Nur im geschleppten Betrieb: konstante Bahngeschwindigkeit an Ecken
M99 | Satzweiser Zyklus-Aufruf
M91 M92 | Im Positioniersatz: Koordinaten beziehen sich auf den Maschinen-Nullpunkt Im Positioniersatz: Koordinaten beziehen sich auf eine vom Maschinenhersteller definierte Position, z.B. auf die Werkzeugwechsel-Position
M94 | Anzeige der Drehachse reduzieren auf einen Wert unter 360°
M97 M98 | Kleine Konturstufen bearbeiten Offene Konturen vollständig bearbeiten
M101 M102 | Automatischer Werkzeugwechsel mit Schwesterwerkzeug, bei abgelaufener Standzeit M101 rücksetzen
M103 | Vorschub beim Eintauchen reduzieren auf Faktor F (prozentualer Wert)
M104 | Zuletzt gesetzten Bezugspunkt wieder aktivieren
M105 M106 | Bearbeitung mit zweitem kv-Faktor durchführen Bearbeitung mit erstem kv-Faktor durchführen
M107 M108 | Fehlermeldung bei Schwesterwerkzeugen mit Aufmaß unterdrücken M107 rücksetzen
M109 M110 M111 | Konstante Bahngeschwindigkeit an der Werkzeug-Schneide (Vorschub-Erhöhung und -Reduzierung Konstante Bahngeschwindigkeit an der Werkzeug-Schneide (nur Vorschub--Reduzierung M109/M110 rücksetzen
M114 M115 | Autom. Korrektur der Maschinengeometrie beim Arbeiten mit Schwenkachsen M114 rücksetzen
M116 M117 | Vorschub bei Winkelachsen in mm/min M116 rücksetzen
M118 | Handrad-Positionierung während des Programmlaufs überlagern
M120 | Radiuskorrigierte Kontur vorausberechnen (LOOK AHEAD)
M124 | Punkte beim Abarbeiten von nicht korrigierten Geradensätzen nicht berücksichtigen
M126 M127 | Drehachsen wegoptimiert verfahren M126 rücksetzen
M128 M129 | Position der Werkzeugspitze beim Positionieren von Schwenkachsen beibehalten (TCPM) M128 rücksetzen
M130 | Im Positioniersatz: Punkte beziehen sich auf das ungeschwenkte Koordinatensystem
M134 M135 | Genauhalt an nicht tangentialen Konturübergängen bei Positionierungen mit Drehachsen M134 rücksetzen
M136 M137 | Vorschub F in Millimeter pro Spindel-Umdrehung M136 rücksetzen
M138 | Auswahl von Schwenkachsen
M142 | Modale Programminformationen löschen
M143 | Grunddrehung löschen
M144 M145 | Berücksichtigung der Maschinen-Kinematik in IST/SOLL-Positionen am Satzende M144 rücksetzen
M150 | Endschaltermeldung unterdrücken
M200 M201 M202 M203 M204 | Laserschneiden: Programmierte Spannung direkt ausgeben Laserschneiden: Spannung als Funktion der Strecke ausgeben Laserschneiden: Spannung als Funktion der Geschwindigkeit ausgeben Laserschneiden: Spannung als Funktion der Zeit ausgeben (Rampe) Laserschneiden: Spannung als Funktion der Zeit ausgeben (Puls)
G-Funktionen
Werkzeug-Bewegungen
G00 G01 G02 G03 G05 G06 G07* G10 G11 G12 G13 G15 G16 | Geraden-Interpolation, kartesisch, im Eilgang Geraden-Interpolation, kartesisch Kreis-Interpolation, kartesisch, im Uhrzeigersinn Kreis-Interpolation, kartesisch, im Gegenuhrzeigersinn Kreis-Interpolation, kartesisch, ohne Drehrichtungsangabe Kreis-Interpolation, kartesisch, tangentialer -Konturanschluss Achsparalleler Positionier-Satz Geraden-Interpolation, polar, im Eilgang Geraden-Interpolation, polar Kreis-Interpolation, polar, im Uhrzeigersinn Kreis-Interpolation, polar, im Gegenuhrzeigersinn Kreis-Interpolation, polar, ohne -Drehrichtungsangabe Kreis-Interpolation, polar, tangentialer -Konturanschluss
Fase/Rundung/Kontur anfahren bzw. verlassen
G24* G25* G26* G27* | Fasen mit Fasenlänge R Ecken-Runden mit Radius R Weiches (tangentiales) Anfahren einer Kontur mit Radius R Weiches (tangentiales) Verlassen einer Kontur mit Radius R
Werkzeug-Definition
G99* | Mit Werkzeug-NummerT, Länge L, Radius R
Werkzeug-Radiuskorrektur
G40 G41 G42 G43 G44 | Keine Werkzeug-Radiuskorrektur Werkzeug-Bahnkorrektur, links von der Kontur Werkzeug-Bahnkorrektur, rechts von der Kontur Achsparallele Korrektur für G07, Verlängerung Achsparallele Korrektur für G07, Verkürzung
Rohteil-Definition für Grafik
G30 G31 | (G17/G18/G19) Minimal-Punkt (G90/G91) Maximal-Punkt
Zyklen zur Herstellung von Bohrungen und Gewinden
G240 G200 G201 G202 G203 G204 G205 G206 G207 G208 G209 G241 | Zentrieren Bohren Reiben Ausdrehen Universal-Bohren Rückwärts-Senken Universal-Tiefbohren Gewindebohren mit Ausgleichsfutter Gewindebohren ohne Ausgleichsfutter Bohrfräsen Gewindebohren mit Spanbruch Einlippen-Bohren
Zyklen zur Herstellung von Bohrungen und Gewinden
G262 G263 G264 G265 G267 | Gewindefräsen Senkgewindefräsen Bohrgewindefräsen Helix-Bohrgewindefräsen Aussengewinde Fräsen
Zyklen zum Fräsen von Taschen, Zapfen und Nuten
G251 G252 G253 G254 G256 G257 | Rechtecktasche komplett Kreistasche komplett Nut komplett Runde Nut komplett Rechteckzapfen Kreiszapfen
Zyklen zur Herstellung von Punktemustern
G220 G221 | Punktemuster auf Kreis Punktemuster auf Linien
SL-Zyklen Gruppe 2
G37 G120 G121 G122 G123 G124 G125 G127 G128 G275 | Kontur, Definition der Teilkontur-Unterprogramm-Nummern Kontur-Daten festlegen (gültig für G121 bis G124) Vorbohren Konturparallel Ausräumen (Schruppen) Tiefen-Schlichten Seiten-Schlichten Kontur-Zug (offene Kontur bearbeiten) Zylinder-Mantel Zylinder-Mantel Nutenfräsen Konturnut trochoidal
Koordinaten-Umrechnungen
G53 G54 G28 G73 G72 G80 G247 | Nullpunkt-Verschiebung aus Nullpunkt-Tabellen Nullpunkt-Verschiebung im Programm Spiegeln der Kontur Drehung des Koordinatensystems Maßfaktor, Kontur verkleinern/vergrößern Bearbeitungsebene schwenken Bezugspunkt Setzen
Zyklen zum Abzeilen
G60 G230 G231 | 3D-Daten abarbeiten Abzeilen ebener Flächen Abzeilen von beliebig geneigten Flächen
*) Satzweise wirksame Funktion
Tastsystem-Zyklen zur Erfassung einer Schieflage
G400 G401 G402 G403 G404 G405 | Grunddrehung über zwei Punkte Grunddrehung über zwei Bohrungen Grunddrehung über zwei Zapfen Grunddrehung über eine Drehachse kompensieren Grunddrehung setzen Schieflage über C-Achse kompensieren
Tastsystem-Zyklen zum Bezugspunkt-Setzen
G408 G409 G410 G411 G412 G413 G414 G415 G416 G417 G418 G419 | Bezugspunkt Mitte Nut Bezugspunkt Mitte Steg Bezugspunkt Rechteck innen Bezugspunkt Rechteck aussen Bezugspunkt Kreis innen Bezugspunkt Kreis aussen Bezugspunkt Ecke aussen Bezugspunkt Ecke innen Bezugspunkt Lockreis-Mitte Bezugspunkt in der Tastystem-Achse Bezugspunkt in der Mitte von 4 Bohrungen Bezugspunkt in wählbarer Achse
Tastsystem-Zyklen zur Werkstück-Vermessung
G55 G420 G421 G422 G423 G424 G425 G426 G427 G430 G431 | Messen beliebige Koordinate Messen beliebiger Winkel Messen Bohrung Messen Kreiszapfen Messen Rechtecktasche Messen Rechteckzapfen Messen Nut Messen Stegbreite Messen beliebige Koordinate Messen Lockreis-Mitte Messen beliebige Ebene
Tastsystem-Zyklen zur Kinematik-Vermessung
G450 G481 G482 G483 | TT kalibrieren Messen Werkzeug-Länge Messen Werkzeug-Radius Messen Werkzeug-Länge und -Radius
Tastsystem-Zyklen zur Werkzeug-Vermessung
G480 G481 G482 G483 G484 | TT kalibrieren Messen Werkzeug-Länge Messen Werkzeug-Radius Messen Werkzeug-Länge und -Radius Infrarot-TT kalibrieren
Sonder-Zyklen
G04* G36 G39* G62 G440 G441 | Verweilzeit mit F Sekunden Spindel-Orientierung Programm-Aufruf Toleranzabweichung für schnelles Konturfräsen Achsverschiebung messen Schnelles Antasten
Bearbeitungs-Ebene festlegen
G17 G18 G19 G20 | Ebene X/Y, Werkzeug-Achse Z Ebene Z/X, Werkzeug-Achse Y Ebene Y/Z, Werkzeug-Achse X Werkzeug-Achse IV
Maßangaben
G90 G91 | Maßangaben absolut Maßangaben inkremental
Maßeinheit
G70 G71 | Maßeinheit inch (am Programm-Anfang festlegen Maßeinheit Millimeter (am Programm-Anfang festlegen)
Sonstige G-Funktionen
G29 G38 G51* G79* G98* | Letzten Positions-Sollwert als Pol (Kreismittelpunkt) Programmlauf-STOPP Werkzeug-Vorauswahl (bei zentralem Werkzeug-Speicher Zyklus-Aufruf Label-Nummer setzen

*) Satzweise wirksame Funktion

Adressen
% % | Programm-Anfang Programm-Aufruf
# | Nullpunkt-Nummer mit G53
A B C | Drehbewegung um X-Achse Drehbewegung um Y-Achse Drehbewegung um Z-Achse
D | Q-Parameter-Definitionen
DL DR | Verschleiß-Korrektur Länge mit T Verschleiß-Korrektur Radius mit T
E | Toleranz mit M112 und M124
F F F F | Vorschub Verweilzeit mit G04 Maßfaktor mit G72 Faktor F-Reduzierung mit M103
G | G-Funktionen
H H H | Polarkoordinaten-Winkel Drehwinkel mit G73 Grenzwinkel mit M112
I | X-Koordinate des Kreismittelpunkts/Pols
J | Y-Koordinate des Kreismittelpunkts/Pols
K | Z-Koordinate des Kreismittelpunkts/Pols
L L L | Setzen einer Label-Nummer mit G98 Sprung auf eine Label-Nr. Werkzeug-Länge mit G99
M | M-Funktionen
N | Satznummer
P P | Zyklus-Parameter in Bearbeitungszyklen Wert oder Q-Parameter in Q-Parameter-Definition
Q | Parameter Q
R R R R | Polarkoordinaten-Radius Kreis-Radius mit G02/G03/G05 Rundungs-Radius mit G25/G26/G27 Werkzeug-Radius mit G99
S S | Spindeldrehzahl Spindel-Orientierung mit G36
T T T | Werkzeug-Definition mit G99 Werkzeug-Aufruf nächstes Werkzeug mit G51
U V W | Achse parallel zur X-Achse Achse parallel zur Y-Achse Achse parallel zur Z-Achse
X Y Z | X-Achse Y-Achse Z-Achse
* | Satzende

Konturzyklen

Programm-Aufbau bei Bearbeitung mit mehreren Werkzeugen
Liste der Kontur-Unterprogramme | G37 P01 ...
Kontur-Daten definieren | G120 Q1 ...
Bohrer definieren/aufrufen Konturzyklus: Vorbohren Zyklus-Aufruf | G121 Q10 ...
Schruppfräser definieren/aufrufen Konturzyklus: Ausräumen Zyklus-Aufruf | G122 Q10 ...
Schlichtfräser definieren/aufrufen Konturzyklus: Schlichten Tiefe Zyklus-Aufruf | G123 Q11 ...
Schlichtfräser definieren/aufrufen Konturzyklus: Schlichten Seite Zyklus-Aufruf | G124 Q11 ...
Ende des Haupt-Programmes, Rücksprung | M02
Kontur-Unterprogramme | G98 ... G98 L0

Radiuskorrektur der Kontur-Unterprogramme

Kontur | Programmierreihenfolge der Konturelemente | Radius- Korrektur
Innen (Tasche) | im Uhrzeigersinn (CW) Im Gegenuhrzeigersinn (CCW) | G42 (RR) G41 (RL)
Außen (Insel) | im Uhrzeigersinn (CW) Im Gegenuhrzeigersinn (CCW) | G41 (RL) G42 (RR)

Koordinaten-Umrechnungen

Koordinaten-Umrechnung | Aktivieren | Aufheben
Nullpunkt- Verschiebung | G54 X+20 Y+30 Z+10 | G54 X0 Y0 Z0
Spiegeln | G28 X | G28
Drehung | G73 H+45 | G73 H+0
Maßfaktor | G72 F 0,8 | G72 F1
Bearbeitungsebene | G80 A+10 B+10 C+15 | G80
Bearbeitungsebene | PLANE ... | PLANE RESET

Q-Parameter-Definitionen

D | Funktion
00 01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 19 | Zuweisung Addition Subtraktion Multiplikation Division Wurzel Sinus Cosinus Wurzel aus Quadratsumme c = √ a2+b2 Wenn gleich, Sprung auf Label-Nummer Wenn ungleich, Sprung auf Label-Nummer Wenn größer, Sprung auf Label-Nummer Wenn kleiner, Sprung auf Label-Nummer Angle (Winkel aus c sin a und c cos a) Fehler-Nummer Print Zuweisung PLC