Autodesk CAM Post Processor Documentation
Autodesk, Inc.
http://cam.autodesk.com
E-mail for all users: cam.p.nosp@m.osts.nosp@m.@auto.nosp@m.desk.nosp@m..com

Copyright (c) 2012-2018 by Autodesk, Inc.

This document describes the configuration format for use with Autodesk CAM Post Processor. It's also available in CHM format here.

Attention
Wrong NC programs can result in severe damage to CNC machine, machined part, and/or bodily injury. All programs must be verified before use.
  • Usage
  • Post Processor Configuration
  • Keywords
  • Entry Functions
  • Cycles
  • Translation

Technical Support

Please contact us using the e-mail address for the corresponding CAM solution for support issues or feature requests related specifically to the post processor. Problems related to other products using the post processor should be redirected to the appropriate support channels for these products.

E-mail for all users: cam.p.nosp@m.osts.nosp@m.@auto.nosp@m.desk.nosp@m..com

You can also report problems to us at this address. Please include the configuration script, intermediate NC file, and NC output file in a ZIP-archive with a description of the problem.

Generated by Autodesk, Inc. 20 January 2022
Copyright (c) 2012-2022 by Autodesk, Inc.


Usage

The post processor application is run from the command line which can be opened by selecting Start - Search -> Command Prompt.

The post processor at minimum takes the path of the post processor configuration script following by the path of the intermediate NC data file. The configuration scripts use the extension .cps which stands for "Customizable Post-processing System".

post config.cps intermediate.cnc

You can specify –help for getting a list of the available options.

post --help
  • --help : Dumps the help.
  • --nobackup : Disables backup of the original NC output file if it exists.
  • --noeditor : Specifies that the generated files should not be opened in the editor.
  • --noprogress : Disables processing progress.
  • --nointeraction : Disables user interaction during processing.
  • --timeout MINUTES : Specifies the maximum processing time in minutes before the processing is aborted. The processing does not time out by default.
  • --quiet : Disables most output to the command prompt.
  • --time : Enables timing output to the command prompt.
  • --verbose : Enables more output to the command prompt.
  • --debug : Enables debug mode.
  • --debugall : Enables debug mode with output of debugging information to the NC output file.
  • --property NAME VALUE : Specifies the value of a property.
  • --log PATH : Specifies the path of the log file. Defaults to the location of the NC output file. Use stdout and stderr to write the log to standard output and error, respectively.
  • --locale PATH : Specifies the path of the locale file.
  • --progress PATH : Specifies the path of the progress file.
  • --include PATH : Specifies a search path.
  • --noworkmapping : Disables automatic mapping of the toolpath motion into the WCS when possible.
  • --machine PATH : Specifies the path of the machine configuration file.
  • --format ID : Specifies the format of the intermediate NC file [CNC, APT, NCI]. The format is auto-detected by default.
  • --lang ID : Specifies the country code for the translation file. Defaults to the country code in the regional settings.
  • --shorten BLOCKS : Specifies the maximum number of blocks allowed per section. This is used to generate short example NC programs. The NC program cannot be run since they will be incomplete.
  • --encrypt PASSWORD : Encrypts the given post configuration using the password.
  • --decrypt PASSWORD : Decrypts the given encrypted post configuration using the password.
  • --interrogate : Returns the primary information about the given post as JSON. You can add multiple paths by using | as separator of the paths. When multiple posts are interrogated the output will be framed JSON. If no path is given on the command line, the interrogated posts will be read from stdin one line at a time.

The NC output path is automatically generated if not specified on the command line. The NC output filename will be set to the same as for the intermediate NC path.

The path of the log can be set using the –log option. If not set, the path will be set to the path of the NC output file with the extension substituted with "log".

The original NC output file is by default backed up to the file which has the extension substituted with 'bak'. The –nobackup option can be used to prevent this behavior.

The generated NC output should never be used if the processing has failed. The NC output file will only be generated on successful processing. On failure the generated NC output will be stored in a file which has the extention substituted with 'failed'.

The post processor may write debug information or error messages directly to the NC output file. These messages are all prefixed with an exclamation mark ('!'). An error message is always written to the NC output on processing failure to indicate bad NC data. The NC debug data can be enabled using the –debugall option.

Properties

You can override user-defined as well as built-in properties by specifying the name-value pairs using the –property option. This allows you to trigger specific post behavior without having to modify the post configuration itself.

The user-defined properties are dumped when running the post processor in verbose mode. The default value as well as the current value are shown. The modified properties are highlighted with an asterix ('*').

post --property programName 100 --property writeTools false config.cps intermediate.cnc

Localization

The post processor has built-in support for localization of the configuration script. Arbitrary messages can be translated into a specific language using the localize() function. When invoked localize() will lookup the specified message in a translation file (known as locale) which must accompany the configuration script. The path of the translation file is derived from the path of the configuration script by substituting the extension with the country code specified by the –lang option and adding '.lang'. For instance, if the path of the configuration script is 'C:\posts\genericiso.cps' and the language id is 'de' then the translation file path will be 'C:\posts\genericiso.de.lang'. The post processor will also try to load the translation file 'common.?.lang' (where ? is substituted with the country code). This allows several post configurations to be translated using a single translation file.

Editor

The post processor will try to open the log and NC output files automatically in the preferred editor when the post processing has completed. The path of the preferred editor is specified in the Windows Registry under "Software\Autodesk\Autodesk\Post Processor\editor" (string type). The entry is valid for both the personal and machine Registry with the personal setting taking priority.

The post processor will try to open the generated files in the included NC editor by default (see http://cam.autodesk.com).

Attention
Serious problems might occur if you modify the Windows Registry incorrectly. Modify the registry at your own risk.

Exit Codes

The post processor will returns different exit codes dependent on the kind of failure.

  • 0: Successful processing.
  • 1: Unspecified failure.
  • 100: Failed to load post configuration.
  • 101: Empty configuration.
  • 102: Failed to initialize.
  • 103: Failed to evaluate configuration.
  • 104: Invalid machine configuration.
  • 200: Failed to load intermediate NC data.
  • 201: Unknown format.
  • 300: Failed to open output file.
  • 400: Failed to open log file.
  • 500: Post processing failed.
  • 501: Post processing was aborted.
  • 502: Post processing timed out.
  • 1000-1999: User-defined exit codes. The exit code can be set using the setExitCode() function.


Post Processor Configuration

The format of the processed NC output is determined by a post processing configuration script. This script is responsible for transforming the intermediate NC data one NC record at a time. The basic format of the configuration script is the JavaScript language. The JavaScript language is quite simple and easy to learn. Tutorials for JavaScript are widely available on the Internet.

The following standard JavaScript API classes are supported from the configuration script: Array, Boolean, Date, Math, Number, and String.

Attention
Note that JavaScript is a case sensitive language meaning that 'qwerty' and 'Qwerty' do not refer to the same data. All angles are represented in radians unless otherwise specified. You can use toDeg() and toRad() functions to convert between radians and degrees. This allows seemless integration with the standard JavaScript API.

For a quick overview of the primary requirements you can start by examining the minimal post configuration script 'minimal.cps' located in the posts folder.


Keywords

Keywords are used to specify to a user of the post processor features or requirements for a post processing configuration script. Keywords should be specified as a space separated string.

keywords = "MODEL_IMAGE PREVIEW_IMAGE";

These keywords can then be queried using the --interrogate option when running the post processor.

MODEL_IMAGE
The post configuration requires an image of the current model.

PREVIEW_IMAGE
The post configuration can use preview images for each operation.

PREVIEW_IMAGE_ALWAYS
The post configuration expects a preview image for every operation.


Entry Functions

The intermediate NC data is transferred to the configuration script one record at a time using the special entry functions listed below.

Entry Functions

onMachine()

onMachine() is invoked when the machine configuration changes during post processing.

onOpen()

onOpen() is invoked once at post processing initialization. This is the place to output the program header.

The configuration script is not allowed to modify the entry functions after onOpen() has been invoked.

onParameter(String name, String value)

onParameter() is invoked for each parameter in the CLD data where a parameter is a simple name-value pair.

onPassThrough(String value)

onPassThrough() is invoked for pass-through information. Pass-through allows the user to transfer text unmodified through to the post processor to the output file. This feature should be used with caution as the post processor will ignore any pass-through data.

onComment(String comment)

onComment() is invoked for each comment.

onSection()

onSection() is invoked at the start of a section. A section commonly corresponds to an individual operation within the CAM system. However, note that it is perfectly legal from the post processors perspective if an operation generated multiple sections.

onSectionSpecialCycle()

onSectionSpecialCycle() is invoked at the start of a section if the section contains a cycle that has been marked as special. A section commonly corresponds to an individual operation within the CAM system. However, note that it is perfectly legal from the post processors perspective if an operation generated multiple sections. onSectionSpecialCycle() doesn't do anything by default. Use PostProcessor.setSectionSpecialCycle() to mark a cycle as special.

onDwell(Number seconds)

onDwell() is invoked per dwell command.

onSpindleSpeed(Number spindleSpeed)

Invoked when the spindle speed changes. The property spindleSpeed specifies the current spindleSpeed.

onRapid(Number x, Number y, Number z)

onRapid() is invoked per linear rapid (high-feed) motion. Make sure to prevent dog-leg movement in the generated program.

onLinear(Number x, Number y, Number z, Number feedrate)

onLinear() is invoked per linear motion.

onCircular(Boolean clockwise, Number cx, Number cy, Number cz, Number x, Number y, Number z, Number feedrate)

onCircular() is invoked per circular motion.

onRapid5D(Number x, Number y, Number z, Number dx, Number dy, Number dz)

onRapid5D() is invoked per linear 5-axis rapid motion.

onLinear5D(Number x, Number y, Number z, Number dx, Number dy, Number dz, Number feedrate)

onLinear5D() is invoked per linear 5-axis motion.

onRewindMachine(Number a, Number b, Number c) DEPRECATED

onRewindMachine() is invoked per for simultaneous 5-axis motion when machine axis rewind is required. Note that rewinds are commonly undesired but cannot be avoided for certain machine types.

onRewindMachineEntry(Number a, Number b, Number c)

onRewindMachineEntry() is invoked per for simultaneous 5-axis motion when machine axis rewind is required. This is called before performing a machine rewind in the kernel, as onRewindMachine() is now deprecated. Several other functions need to be implemented for rewind machine to perform properly, such as onTurnTCPOff(), onRotateAxes() etc. These are marked with "Required for machine rewinds" in this manual.

onMoveToSafeRetractPosition()

Required for machine rewinds. onMoveToSafeRetractPosition() is invoked during a machine rewind procedure. It needs to output the code for retracting to safe position before indexing rotaries (usually a retract in Z).

onReturnFromSafeRetractPosition(Number x, Number y, Number z)

Required for machine rewinds. onReturnFromSafeRetractPosition() is invoked during a machine rewind procedure. It needs to output the code for returning from safe position after indexing rotaries.

onRotateAxes(Number x, Number y, Number z, Number a, Number b, Number c)

Required for machine rewinds. onRotateAxes() is invoked during a machine rewind procedure. It needs to output the code for rotating the axes to new position above re-entry position. Usually just a call to onRapid5D() with xyz disabled before the call and re-enabled after.

onMovement(Integer movement)

onMovement() is invoked when the movement type changes. The property movement specifies the current movement type.

onPower(bool power)

onPower() is invoked when the power mode changes. The property power specifies the current power mode. Used for water jet, laser cutter, and plasma cutter.

onRadiusCompensation()

onRadiusCompensation() is invoked when the radius compensation mode changes. The property radiusCompensation specifies the current radius compensation mode.

onToolCompensation(Integer compensation)

onToolCompensation() is invoked when the tool compensation mode changes. Only used for tool types for which dual compensation is defined.

onCycle()

onCycle() is invoked at the beginning of each cycle. The variable cycleType holds the unique name identifying the type of the current cycle. The parameters of the cycles are available through the cycle variable.

onCyclePoint(Number x, Number y, Number z)

onCyclePoint() is invoked for each point associated with the active cycle. onCyclePoint() is only invoked between onCycle() and onCycleEnd().

onCyclePath()

onCyclePath() is invoked at the beginning of the cycle with toolpath (e.g. turning canned cycle). onCyclePath() is only invoked between onCycle() and onCycleEnd().

onCyclePathEnd()

onCyclePathEnd() is invoked at the ending of the cycle with toolpath (e.g. turning canned cycle). onCyclePathEnd() is only invoked between onCycle() and onCycleEnd().

onCycleEnd()

onCycleEnd() is invoked on cycle termination. A corresponding onCycleEnd() is guaranteed to follow an invocation of onCycle().

onCommand(Integer command)

onCommand() is invoked for well-known commands (e.g. stop spindle).

onManualNC()

onManualNC() is invoked when any of the Manual NC commands are processed. If onManualNC is not defined the previous method will be used (onParameter, onCommand, etc.).

onMachineCommand(Integer command)

onMachineCommand() is invoked for machine commands (e.g. 28 could be mapped to M28).

onLiveAlignment()

onLiveAlignment() is invoked after the last posted operation of a Part Alignment.

onOrientateSpindle(Number angle)

onOrientateSpindle() is invoked when a specific spindle orientation is required. The function may be invoked when expanding cycles.

onLinearExtrude(Number x, Number y, Number z, Number feedrate, Number extrusionLength)

onLinearExtrude() is invoked per linear extrusion motion in an additive FFF toolpath.

onCircularExtrude(Boolean clockwise, Number cx, Number cy, Number cz, Number x, Number y, Number z, Number feed, Number extrusionLength)

onCircularExtrude() is invoked per circular extrusion motion in an additive FFF toolpath.

onLayer(Number layerNumber)

onLayer() is invoked at the start of a layer in an additive FFF toolpath.

onExtrusionReset(Number length)

onExtrusionReset() is invoked when the extrusion length is reset in an additive FFF toolpath.

onExtruderChange(Number extruderId)

onExtruderChange() is invoked when the extruder is changed in an additive FFF toolpath.

onExtruderTemp(Number temp, bool wait, int extruderId)

onExtruderTemp() is invoked when the extruder temperature is changed in an additive FFF toolpath. The variable wait defines whether the process should wait to reach the desired extruder temperature before continuing.

onBedTemp(Number temp, bool wait)

onBedTemp() is invoked when the bed temperature is changed in an additive FFF toolpath. The variable wait defines whether the process should wait to reach the desired bed temperature before continuing.

onFanSpeed(Number speed, int fanId)

onFanSpeed() is invoked when the fan speed is changed in an additive FFF toolpath.

onMaxAcceleration(Number xAxis, Number yAxis, Number zAxis, Number eAxis)

onMaxAcceleration() is invoked when the max axis acceleration is changed in an additive FFF toolpath.

onAcceleration(Number travel, Number printing, Number retract)

onAcceleration() is invoked when the acceleration is changed in an additive FFF toolpath.

onJerk(Number xAxis, Number yAxis, Number zAxis, Number eAxis)

onJerk() is invoked when the axis jerk is changed in an additive FFF toolpath.

onSectionEnd()

onSectionEnd() is invoked at the termination of a section.

onSectionEndSpecialCycle()

onSectionEndSpecialCycle() is invoked at the termination of a section if the section contains a cycle that has been marked as special. onSectionEndSpecialCycle() doesn't do anything by default. Use PostProcessor.setSectionSpecialCycle() to mark a cycle as special.

onClose()

onClose() is invoked at post processing completion. This is the place to output your program footer.

onTerminate()

onTerminate() is invoked once after post processing has completed. The output file is unlocked at this point and can be moved and copied as desired.


Cycles

Each cycle has a unique id which is available through the cycleType property. All cycles are described by a set of parameters and an ordered set of points (or toolpath). The cycle parameters are available in the property cycle upon invocation of onCycle().

onCycle() // invoked on cycle
onCyclePoint(x, y, z) // invoked once per point
onCycleEnd() // invoked on cycle completion
onCycle() // invoked on cycle
onCyclePath() // invoked once at the beginning of cycle toolpath
onRapid()
...
onLinear()
...
onCircular()
...
onCyclePathEnd() // invoked once at the ending of cycle toolpath
onCycleEnd() // invoked on cycle completion

Well-Known Cycles

It is discouraged that you overload the meaning of built-in cycles and parameters. Instead a new cycle or parameter should be introduced.

Well-known cycles that do not have an NC counterpart for a particular control may be expanded by invoking expandCyclePoint(). expandCyclePoint() may in return invoke onCommand(). Some times it is acceptable to map rapid traversal to feed traversal but the oppsosite is not allowed unless it is guaranteed that the cutter cannot come in contact with (or close to) any stock. Note that not all cycles can be expanded into alternative commands and must be implemented in the post configuration to be supported.

Attention
The position after any completed cycle motion is by default expected to be the last given cycle point projected onto the initial Z-plane. If no cycle points have been provided the current position is expected to remain unchanged. The configuration script must explicitly set the current position using setCurrentPosition() if it is different from the default and possibly add additional motion.

The following parameters have been reserved. Note that not all cycles make use of each defined parameter.

  • clearance: The clearance plane (absolute coordinate).
  • retract: The retract plane (absolute coordinate). Rapid motion is allowed from the clearance plane and down to the retract plane). The retract plane defaults to the clearance plane. The retract plane can be ignored if not supported by the control.
  • stock: The stock plane (absolute coordinate).
  • depth: The depth below the stock plane. The depth is positive for points below the stock plane.
  • bottom: The bottom plane (stock - depth).
  • pitch: The helical pitch (incremental depth per turn).
  • feedrate: The primary feedrate. Usually specifies the plunging feedrate.
  • retractFeedrate: The retraction feedrate. Defaults to the primary feedrate if not specified.
  • plungeFeedrate: The plunge feedrate. Defaults to the primary feedrate if not specified. Note that the primary feedrate (feedrate) is the plunge feedrate for drilling cycles.
  • stopSpindle: Stop spindle during positioning/retracting.
  • positioningFeedrate: The positioning feedrate.
  • positioningSpindleSpeed: The positioning spindle speed.
  • dwellDepth: The dwelling depth.
  • dwell: The dwelling time in seconds.
  • incrementalDepth: The incremental/pecking depth.
  • incrementalDepthReduction: The incremental/pecking depth reduction per plunge. Defaults to 0.
  • minimumIncrementalDepth: The minimum incremental/pecking depth per plunge. Defaults to incrementalDepth.
  • accumulatedDepth: Specifies the total plunging depth before forcing full retract to the retract plane.
  • plungesPerRetract: Specifies the number of plunges per retract (derived from accumulatedDepth and incrementalDepth).
  • chipBreakDistance: Specifies the distance to retract to break the chip. Undefined by default.
  • shift: Specifies the shifting distance away from the boring wall.
  • shiftOrientation: Specifies the orientation of the cutter in radians when shifting. Defaults to machineParameters.spindleOrientation.
  • compensatedShiftOrientation: Specifies the orientation of the spindle in radians when shifting (shiftOrientation - tool.boringBarOrientation).
  • shiftDirection: Specifies the shift direction in radians when shifting (pi + shiftOrientation).
  • backBoreDistance: Specifies the back boring distance.
  • diameter: Specifies the diameter of the hole.
  • stepover: The maximum stepover between passes.
  • numberOfSteps: Specifies the number of passes/steps.
  • threading: Specifies left/right handed thread.
  • direction: Specifies climb/conventional milling.
  • repeatPass: Specifies that the final pass should be repeated.
  • compensation: Specifies that the compensation type. That valid types are computer, control, wear, and inverseWear.
  • incrementalX: Specifies the incremental distance along X.
  • incrementalZ: Specifies the incremental distance along Z.

The parameters bottom, plungesPerRetract, compensatedShiftOrientation, and shiftDirection are calculated by the post processor.

The post processor has built-in support for the following cycles. Please note that the G-codes specified below are only intended for guidance and may not be the proper mapping for a particular control.

Preliminary Motion

The preliminary default motion for a cycle point is as follows:

a) If the initial plane is above the clearance plane:

  1. Move at rapid traverse to the X-Y position at the initial plane.
  2. Move at rapid traverse to the clearance plane (along the tool axis).
  3. Move at rapid traverse to the retract plane (along the tool axis). This motion can be ignored.

b) If the initial plane is below the clearance plane:

  1. Move at rapid traverse to the clearance plane (along the tool axis).
  2. Move at rapid traverse to the X-Y position at the clearance plane.
  3. Move at rapid traverse to the retract plane (along the tool axis). This motion can be ignored.

drilling

Defined properties: clearance, retract, stock, depth, feedrate

Cycle for center drilling, drilling, reaming, and rough boring (G81 style). Same as counter-boring but without dwelling at the bottom of the hole.

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Retract at rapid traverse to clearance plane (or initial plane for last cycle point).

counter-boring

Defined properties: clearance, retract, stock, depth, feedrate, dwell

Cycle for counter boring, spot drilling, and face drilling (G82 style). Similar to drilling but dwells at the bottom of the hole.

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Dwell (dwell).
  4. Retract at rapid traverse to clearance plane (initial plane for the last cycle point).

chip-breaking

Defined properties: clearance, retract, stock, depth, feedrate, dwell, incrementalDepth, incrementalDepthReduction, accumulatedDepth, chipBreakDistance

This cycle is for chip breaking (G73 style). The property machineParameters.chipBreakingDistance specifies the distance that the machine will retract to break the chips for cycle chip-breaking. If machineParameters.chipBreakingDistance is undefined the cycle will use full retracts. When expanding the cycle the property machineParameters.drillingSafeDistance specifies the safety distance above the remaining stock for which the machine will rapid down (if undefined the cycle will do feed plunging from the clearance plane).

  1. Preliminary motion.
  2. Move toward bottom at by no more than the given plunge depth (incrementalDepth) at a time.
  3. Dwell (dwell).
  4. Retract by distance chipBreakDistance if defined and otherwise machineParameters.chipBreakingDistance to break chip (or retract to clearance plane if accumulatedDepth has been reached).
  5. Repeat step 2-4 until bottom has been reached.
  6. Retract at rapid traverse to clearance plane (initial plane for the last cycle point).

deep-drilling

Defined properties: clearance, retract, stock, depth, feedrate, dwell, incrementalDepth, incrementalDepthReduction, spindleSpeedDwell

This cycle is for deep hole drilling with full retract (G83 style). When expanding the cycle the property machineParameters.drillingSafeDistance specifies the safety distance above the remaining stock for which the machine will rapid down (if undefined the cycle will do feed plunging from the clearance plane).

  1. Preliminary motion.
  2. Move toward bottom by no more than the given plunge depth (incrementalDepth) at a time.
  3. Retract at rapid traverse to retract plane if bottom has not been reached.
  4. Repeat 2-3 until bottom has been reached.
  5. Dwell at bottom (dwell).
  6. Retract at rapid traverse to clearance plane (initial plane for the last cycle point).

break-through-drilling

Defined properties: clearance, retract, stock, depth, feedrate, stopSpindle, breakThroughDistance, breakThroughFeedrate, breakThroughSpindleSpeed, dwell, stopSpindle, dwell, spindleSpeedDwell

This cycle is for breaking through with reduced feed.

  1. Preliminary motion.
  2. Move to break through starting depth at feedrate (feedrate).
  3. Move to bottom at the break-through feedrate and speed (breakThroughFeedrate and breakThroughSpindleSpeed).
  4. Dwell at dwell depth (dwell).
  5. Conditionally stop spindle (stopSpindle).
  6. Retract at feedrate to clearance plane (initial plane for the last cycle point).
  7. Turn on spindle if stopped.
  8. Optional dwell (machineParameter.spindleSpeedDwell).

gun-drilling

Defined properties: clearance, retract, stock, depth, feedrate, startingDepth, stopSpindle, positioningFeedrate, positioningSpindleSpeed, dwellDepth, dwell, spindleSpeedDwell

This cycle is for guided deep hole drilling commonly known as gun drilling. This cycle is used for deep drilling with non self-guiding drills.

  1. Preliminary motion.
  2. Move to the starting position at the positioning feedrate (positioningFeedrate) and positioning spindle speed (positioningSpindleSpeed).
  3. Change spindle speed to cutting speed.
  4. Optional dwell (machineParameter.spindleSpeedDwell).
  5. Move to bottom at feedrate (feedrate).
  6. Dwell at dwell depth (dwell).
  7. Stop spindle or change spindle speed to positioning spindle speed (positioningSpindleSpeed).
  8. Retract at retract feedrate to clearance plane (initial plane for the last cycle point).

left-tapping

Defined properties: clearance, retract, stock, depth, feedrate, dwell

Left-tapping (G74 style).

  1. Preliminary motion.
  2. Start speed-feed synchronization.
  3. Move to bottom at feedrate (feedrate).
  4. Stop the spindle.
  5. Start the spindle in clockwise direction.
  6. Retract at feedrate to clearance plane (or initial plane for last cycle point).
  7. If speed-feed synch was not on before the cycle started, stop it.
  8. Stop the spindle.
  9. Start the spindle in counterclockwise direction.
  10. Retract at rapid traverse to clearance plane (initial plane for the last cycle point).

right-tapping

Defined properties: clearance, retract, stock, depth, feedrate, dwell

Right-tapping (G84 style). If the feedrate is not specified the feedrate will be set to the tapping feed of the current tool.

  1. Preliminary motion.
  2. Start speed-feed synchronization.
  3. Move to bottom at feedrate (feedrate).
  4. Stop the spindle.
  5. Start the spindle in counterclockwise direction.
  6. Retract at feedrate to clearance plane (or initial plane for last cycle point).
  7. If speed-feed synch was not on before the cycle started, stop it.
  8. Stop the spindle.
  9. Start the spindle in clockwise direction.
  10. Retract at rapid traverse to clearance plane (initial plane for the last cycle point).

tapping

Defined properties: clearance, retract, stock, depth, feedrate, dwell

Left tapping for left tapping tools otherwise right tapping. See left-tapping and right-tapping.

left-tapping-with-chip-breaking

Defined properties: clearance, retract, stock, depth, feedrate, incrementalDepth, incrementalDepthReduction, accumulatedDepth, chipBreakDistance, dwell

Right-tapping with chip breaking. If the feedrate is not specified the feedrate will be set to the tapping feed of the current tool. The property machineParameters.chipBreakingDistance specifies the distance that the machine will retract to break the chips for the cycle. If machineParameters.chipBreakingDistance is undefined the cycle will use full retracts. When expanding the cycle the property machineParameters.drillingSafeDistance specifies the safety distance above the remaining stock for which the machine will rapid down (if undefined the cycle will do feed plunging from the clearance plane).

  1. Preliminary motion.
  2. Start speed-feed synchronization.
  3. Move toward bottom at feedrate (feedrate) by no more than the given plunge depth (incrementalDepth) at a time.
  4. Stop the spindle.
  5. Start the spindle in clockwise direction.
  6. Retract by distance chipBreakDistance is defined and otherwise machineParameters.chipBreakingDistance to break chip (or retract to clearance plane (or initial plane for last cycle point) if accumulatedDepth has been reached).
  7. If speed-feed synch was not on before the cycle started, stop it.
  8. Stop the spindle.
  9. Start the spindle in counterclockwise direction.
  10. Repeat step 2-9 until bottom has been reached.
  11. Retract at rapid traverse to clearance plane (initial plane for the last cycle point).

right-tapping-with-chip-breaking

Defined properties: clearance, retract, stock, depth, feedrate, incrementalDepth, incrementalDepthReduction, accumulatedDepth, chipBreakDistance

Right-tapping with chip breaking. If the feedrate is not specified the feedrate will be set to the tapping feed of the current tool. The property machineParameters.chipBreakingDistance specifies the distance that the machine will retract to break the chips for the cycle. If machineParameters.chipBreakingDistance is undefined the cycle will use full retracts. When expanding the cycle the property machineParameters.drillingSafeDistance specifies the safety distance above the remaining stock for which the machine will rapid down (if undefined the cycle will do feed plunging from the clearance plane).

  1. Preliminary motion.
  2. Start speed-feed synchronization.
  3. Move toward bottom at feedrate (feedrate) by no more than the given plunge depth (incrementalDepth) at a time.
  4. Stop the spindle.
  5. Start the spindle in counterclockwise direction.
  6. Retract by distance chipBreakDistance is defined and otherwise machineParameters.chipBreakingDistance to break chip (or retract to clearance plane (or initial plane for last cycle point) if accumulatedDepth has been reached).
  7. If speed-feed synch was not on before the cycle started, stop it.
  8. Stop the spindle.
  9. Start the spindle in clockwise direction.
  10. Repeat step 2-9 until bottom has been reached.
  11. Retract at rapid traverse to clearance plane (initial plane for the last cycle point).

tapping-with-chip-breaking

Defined properties: clearance, retract, stock, depth, feedrate, incrementalDepth, incrementalDepthReduction, accumulatedDepth, chipBreakDistance

Left tapping for left tapping tools otherwise right tapping. See left-tapping-with-chip-breaking and right-tapping-with-chip-breaking.

reaming

Defined properties: clearance, retract, stock, depth, feedrate, retractFeedrate

This cycle is used to enlarge an existing hole slightly (G85 style).

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Retract at feedrate to retract plane (retractFeedrate).
  4. Retract at rapid traverse to clearance plane (initial plane for the last cycle point).

stop-boring

Defined properties: clearance, retract, stock, depth, feedrate, dwell

Boring cycle for tighter holes (G86 style). Counter boring for boring bar. This cycle is used to achieve accurate depths.

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Dwell (dwell).
  4. Stop spindle.
  5. Retract at rapid traverse to clearance plane.
  6. Start spindle.
  7. Retract at rapid traverse to initial plane for the last cycle point.

fine-boring

Defined properties: clearance, retract, stock, depth, feedrate, dwell, shift

Cycle for fine boring (G76 style).

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Dwell (dwell).
  4. Stop spindle.
  5. Orientate spindle.
  6. Move the tool away from bore wall by given distance (shift).
  7. Retract at rapid traverse.
  8. Start spindle.
  9. Retract at rapid traverse to initial plane for the last cycle point.

back-boring

Defined properties: clearance, retract, stock, depth, feedrate, dwell, shift, shiftOrientation, backBoreDistance

Back boring (G87 style). The machineParameters.spindleOrientation will be used when expanding the cycle if shiftOrientation is undefined. The tool must be compensated to the top of the cutter. You must make sure that there is room for the tool below the given Z-levels.

  1. Preliminary motion.
  2. Stop spindle.
  3. Orientate spindle.
  4. Shift tool position (shift and shiftOrientation).
  5. Move at rapid traverse to bottom along tool axis.
  6. Move at rapid traverse horizontally to center position (x and y).
  7. Start spindle.
  8. Move at feedrate to top of hole (feedrate and backBoreDistance).
  9. Move at feedrate to bottom of hole (feedrate).
  10. Stop spindle.
  11. Orientate spindle.
  12. Shift tool position (shift and shiftOrientation).
  13. Retract at rapid traverse to retract plane (retract).
  14. Move at rapid traverse horizontally to center position (x and y).
  15. Start spindle.
  16. Retract at rapid traverse to clearance plane (clearance).
  17. Retract at rapid traverse to initial plane for the last cycle point.

manual-boring

Defined properties: clearance, retract, stock, depth, feedrate, dwell

Boring cycle with manual retract (G88 style).

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Dwell (dwell).
  4. Stop spindle.
  5. Stop program.
  6. Retract at rapid traverse to clearance plane.
  7. Start spindle.
  8. Retract at rapid traverse to initial plane for the last cycle point.

boring

Defined properties: clearance, retract, stock, depth, feedrate, retractFeedrate, dwell

Boring (G89 style).

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Dwell (dwell).
  4. Retract at feedrate (retractFeedrate).
  5. Retract at rapid traverse to initial plane for the last cycle point.

bore-milling

Defined properties: clearance, retract, stock, depth, feedrate, pitch, diameter, direction, stepover, numberOfSteps, repeatPass, compensation

Bore milling.

  1. Preliminary motion.
  2. Move to bottom in helical motion at feedrate (feedrate).
  3. Do finishing of bottom at feedrate (feedrate).
  4. Move to center of hole at feedrate (feedrate).
  5. Retract at rapid traverse to initial plane for the last cycle point.

thread-milling

Defined properties: clearance, retract, stock, depth, feedrate, pitch, diameter, dwell, threading, direction, stepover, numberOfSteps, repeatPass, compensation

Thread milling.

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Climb mill to the stock plane or conventional mill to the bottom in helical motion at feedrate (feedrate).
  4. Dwell (dwell).
  5. Retract at rapid traverse to initial plane for the last cycle point.

circular-pocket-milling

Defined properties: clearance, retract, stock, depth, feedrate, plungeFeedrate, diameter, stepover, incrementalDepth, direction, repeatPass

Circular pocket milling.

  1. Preliminary motion.
  2. Plunge toward bottom at feedrate (feedrate) by no more than the given plunge depth (incrementalDepth) at a time.
  3. Clear level at feedrate (feedrate).
  4. Move to center at feedrate (feedrate).
  5. Repeat step 2-4 until bottom has been reached.
  6. Retract at rapid traverse to initial plane for the last cycle point.

probe

Defined properties: clearance, retract, stock, depth, feedrate

Cycle for probing.

  1. Preliminary motion.
  2. Move to bottom at feedrate (feedrate).
  3. Retract at rapid traverse to clearance plane (or initial plane for last cycle point).

thread-turning

Defined properties: clearance, pitch, incrementalX, incrementalZ

Thread turning.

  1. Preliminary motion.
  2. Move to starting ZX.
  3. Move to end of thread with feed-spindle synchronization.
  4. Retract at rapid traverse to initial ZX.

probing-x

probing-y

probing-z

probing-x-channel

probing-x-channel-not-symmetric

probing-x-channel-with-island

probing-x-wall

probing-x-wall-not-symmetric

probing-y-channel

probing-y-channel-not-symmetric

probing-y-channel-with-island

probing-y-wall

probing-y-wall-not-symmetric

probing-xy-inner-corner

probing-xy-outer-corner

probing-xy-circular-hole

probing-xy-circular-hole-with-island

probing-xy-circular-boss

probing-xy-circular-partial-hole

probing-xy-circular-partial-boss

probing-xy-circular-partial-hole-with-island

probing-xy-circular-hole-with-z

probing-xy-circular-hole-island-with-z

probing-xy-circular-boss-with-z

probing-xy-pcd-hole

probing-xy-pcd-boss

probing-xy-pcd-hole-with-island

probing-xy-rectangular-hole

probing-xy-rectangular-hole-with-island

probing-xy-rectangular-boss

probing-xy-rectangular-hole-with-z

probing-xy-rectangular-hole-island-with-z

probing-xy-rectangular-boss-with-z

probing-xyz-corner

probing-x-plane-angle

probing-y-plane-angle

secondary-spindle-grab

Defined properties: usePartCatcher, stopSpindle, feedrate, spindleSpeed, dwell, spindleOrientation, feedPosition, chuckPosition, useMachineFrame

secondary-spindle-pull

Defined properties: stopSpindle, spindleSpeed, feedrate, pullingDistance, dwell

secondary-spindle-return

Defined properties: stopSpindle, spindleSpeed, feedrate, dwell, feedPosition, useMachineFrame, unclampMode

Where unclampMode can be keep-clamped, unclamp-primary, or unclamp-secondary.


Translation

The post processor has built-in support for localization of the configuration script. The translation API allows the post configuration to be separated from its translation. Arbitrary messages can be translated into a specific language using the localize() function. When invoked localize() will lookup the specified message in a translation file (known as locale) which must accompany the configuration script. The path of the translation file is derived from the path of the configuration script by substituting the extension with the selected country code (see setLangId()) and adding '.lang'). For instance, if the path of the configuration script is 'C:\posts\genericiso.cps' and the language id is 'de' then the translation file path will be 'C:\posts\genericiso.de.lang'. The post processor will also try to load the translation file 'common.?.lang' (where ? is substituted with the country code). This allows several post configurations to be translated using a single translation file. The translation files are prioritized such that the last loaded file takes percedence over the other files.

The following line would write out "; Werkzeug" if used with the translation file listed below.

writeln("; " + localize("Tool"));

The translation file is an XML file which could look something like the following.

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?xml-stylesheet type='text/xsl' href='locale.xsl'?>
<locale xmlns="http://www.hsmworks.com/xml/2008/locale">
<!--The content of this document may be covered by copyright-->
<description>German</description>
<country>de</country>
<message name="Tool">Werkzeug</message>
<message name="Level">Niveau</message>
</locale>

This translation file will map the text "Tool" into "Werkzeug" and "Level" into "Niveau". All other text will not be translated unless another translation file maps the text.


Conventions

When developing post processors it is highly recommended that you follow strict conventions for the source code to increase the maintainability, allow easy sharing of future functionality between post configurations, and improve understanding of the source code.

Source code guidelines

  1. Indent all multi-line bodies by 2 spaces.
    function myFunction() {
    // indent by 2 spaces
    }
  2. Do not use TAB (tabulator) to avoid confusion when using different editors.
  3. Use descriptive names for all the variables, functions, and similar. Avoid short generic names like var1, var2, and var3 that do not tell anything about the usage.
  4. Avoid long and complex functions. Use smaller helper functions where relevant to simplify the source code.
  5. Add descriptive comments to allow better understanding of the behavior.
  6. Functions start with a lowercase letter and each following word starts with a capital letter (e.g. myFunction).
  7. Variables and properties are written similarly to function names (e.g. myVariable and myProperty).
  8. Classes use capital letter for the first letter in each word (e.g. MyClass).
  9. Constants are written in capital letters only with underscore separating words (e.g. MY_CONSTANT).


Deprecated List
Member MachineConfiguration::getPosition (Vector p, Vector abc)
Member MachineConfiguration::getReconfigure ()
Use performRewinds() instead.
Member MachineConfiguration::setReconfigure (Boolean enable)
Use enableMachineRewinds() and disableMachineRewinds() instead.
Member Matrix::getEuler (Integer convention)
Member Matrix::getEulerXYZ ()
Member Matrix::getEulerZXZ ()
Member Matrix::getEulerZYX ()
Member Matrix::getEulerZYZ ()
Member Section::getFirstPosition ()


Packages
Here are the packages with brief descriptions (if available):
N com


com Namespace Reference

Detailed Description

Copyright (c) 2012-2020 by Autodesk, Inc. http://www.autodesk.com Not for redistribution

Copyright (c) 2012-2019 by Autodesk, Inc. http://www.autodesk.com Not for redistribution


Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C Array
C Axis
C Base64
C BinaryFile
C Boolean
C BoundingBox
C Canvas
C CircularMotion
C Color
C Curve
C CurveEntity
C Date
C DeferredVariables
C FileSystem
C Format
C FormatNumber
C FormData
C Holder
C IncrementalVariable
C Integer
C MachineConfiguration
C MachineParameters
C Mail
C Map
C Math
C Matrix
C Mesh
C Modal
C ModalGroup
C MoveLength
C Number
C PostProcessor
C Range
C Record
C ReferenceVariable
C Section
C Shaft
C SMTP
C String
C StringBuffer
C StringSubstitution
C Table
C Template
C TextFile
C Tool
C ToolRenderer
C ToolTable
C Value
C Variable
C Vector
C VectorPair
C XMLHttpRequest
C ZipFile


Array Class Reference

Public Member Functions

Integer indexOf ()
Integer lastIndexOf ()

Detailed Description

JavaScript array.

Member Function Documentation

◆ indexOf()

Integer indexOf ( )

Returns the index of the given items first occurrence.

◆ lastIndexOf()

Integer lastIndexOf ( )

Returns the index of the given items last occurrence.


Member List

Array Member List

This is the complete list of members for Array, including all inherited members.


Axis Class Reference

Inherits ScriptObject, and UnitConsumer.

Public Member Functions

Axis ()
Axis (Boolean _table, Vector _axis, Vector _offset, Integer _coordinate)
Axis (Boolean _table, Vector _axis, Vector _offset, Integer _coordinate, Range _range)
String getName ()
setName (String name)
Integer getActuator ()
setActuator (Integer actuator)
Boolean isLinear ()
Boolean isRotational ()
Boolean isAggregate ()
Number getResolution ()
setResolution (Number resolution)
Number | clampToResolution (Number _value)
Number | getResolutionError (Number _value)
Number getMaximumFeed ()
setMaximumFeed (Number _maximumFeed)
Number getRapidFeed ()
setRapidFeed (Number _rapidFeed)
Integer getPreference ()
setPreference (Integer preference)
Integer getReset ()
setReset (Integer reset)
Boolean isEnabled ()
Boolean isHead ()
Boolean isTable ()
Vector getEffectiveAxis ()
Vector getAxis ()
Vector getOffset ()
Number getHomePosition ()
Number getDisplacement ()
Boolean isCyclic ()
Boolean isTCPEnabled ()
Range getRange ()
Integer getCoordinate ()
Boolean | isSupported (Number value)
Number | clamp (Number value)
Number | reduce (Number value)
Number | remapToRange (Number angle)
Number | remapToRange2 (Number angle, Number current)
Matrix | getAxisRotation (Number position)

Detailed Description

Machine axis specification.

Constructor & Destructor Documentation

◆ Axis() [1/3]

Axis ( )

Constructs an invalid axis.

◆ Axis() [2/3]

Axis | ( | Boolean | _table,
 |  | Vector | _axis,
 |  | Vector | _offset,
 |  | Integer | _coordinate
 | ) |  |

Constructs a rotational axis.

Parameters
_table | Specifies the axis is located in the table as opposed to the head.
_axis | The axis vector.
_offset | The axis offset.
_coordinate | The coordinate to which the axis coordinate is bound (0:X, 1:Y, 2:Z).

◆ Axis() [3/3]

Axis | ( | Boolean | _table,
 |  | Vector | _axis,
 |  | Vector | _offset,
 |  | Integer | _coordinate,
 |  | Range | _range
 | ) |  |

Constructs a rotational axis.

Parameters
_table | Specifies the axis is located in the table as opposed to the head.
_axis | The axis vector.
_offset | The axis offset.
_coordinate | The coordinate to which the axis coordinate is bound (0:X, 1:Y, 2:Z).
_range | The valid range.

Member Function Documentation

◆ clamp()

Number clamp ( Number value )

Returns the closest valid angle/offset.

Parameters
value The coordinate (angular for rotational axis and spatial for linear axis).

◆ clampToResolution()

Number clampToResolution ( Number _value )

Returns the axis value clamped to the resolution.

◆ getActuator()

Integer getActuator ( )

Returns the actuator type.

0: linear actuator. 1: rotational actuator.

◆ getAxis()

Vector getAxis ( )

Returns the axis direction.

◆ getAxisRotation()

Matrix getAxisRotation ( Number position )

Returns the rotation for the given axis position. Returns the identity matrix for a linear axis.

◆ getCoordinate()

Integer getCoordinate ( )

Returns the coordinate to which the axis coordinate is bound (0:X, 1:Y, 2:Z). Returns -1 if the axis is invalid.

◆ getDisplacement()

Number getDisplacement ( )

Returns the axis displacement.

◆ getEffectiveAxis()

Vector getEffectiveAxis ( )

Returns the effective axis direction. Flipped for head.

◆ getHomePosition()

Number getHomePosition ( )

Returns the axis home position.

◆ getMaximumFeed()

Number getMaximumFeed ( )

Returns the maximum feed of the axis.

◆ getName()

String getName ( )

Returns the identifier for the axis.

◆ getOffset()

Vector getOffset ( )

Returns the axis offset.

◆ getPreference()

Integer getPreference ( )

Returns the angle/offset preference.

0: don't care. 1: prefer positive angles/offsets. -1: prefer negative angles/offsets.

◆ getRange()

Range getRange ( )

Returns the range of the axis coordinate.

◆ getRapidFeed()

Number getRapidFeed ( )

Returns the rapid feed of the axis.

◆ getReset()

Integer getReset ( )

Returns the axis reset behavior.

0: disabled. 1: reset to 0 at new operation. 2: reset to 0 at rewind.. 3: reset to 0 at new operation and at rewind.

◆ getResolution()

Number getResolution ( )

Returns the resolution of the axis.

◆ getResolutionError()

Number getResolutionError ( Number _value )

Returns the signed resolution error for the specified axis value.

◆ isAggregate()

Boolean isAggregate ( )

Returns true if the axes is a fixed aggregate. That is, the axis is fixed at the given position.

◆ isCyclic()

Boolean isCyclic ( )

Returns true if the axis is cyclic. Only supported for rotational axes.

◆ isEnabled()

Boolean isEnabled ( )

Returns true if the axis is valid.

  1. The axis is non-degenerate.
  2. The coordinate is in the range [0; 2].
  3. The resolution must be >= 0.

◆ isHead()

Boolean isHead ( )

Returns true if the axis is a head axis.

◆ isLinear()

Boolean isLinear ( )

Returns true if the actuator is linear.

◆ isRotational()

Boolean isRotational ( )

Returns true if the actuator is rotational.

◆ isSupported()

Boolean isSupported ( Number value )

Returns true if the specified angle/offset is within the required range.

Parameters
value The coordinate (angular for rotational axis and spatial for linear axis).

◆ isTable()

Boolean isTable ( )

Returns true if the axis is a table axis.

◆ isTCPEnabled()

Boolean isTCPEnabled ( )

Returns true if TCP is enabled for the rotary axis.

◆ reduce()

Number reduce ( Number value )

Returns the reduced angle closest to 0 but restricted to the supported range. Actuator must be rotational.

Parameters
value The axis coordinate.
Returns
The output is in the range ]-PI; PI] unless axis is restricted to range.

◆ remapToRange()

Number remapToRange ( Number angle )

Returns the preferred angle in the allowed range. An exception is raised if no valid angle exists. Actuator must be rotational.

◆ remapToRange2()

Number remapToRange2 | ( | Number | angle,
 |  | Number | current
 | ) |  |

Returns the preferred angle in the allowed range closest to the current angle. An exception is raised if no valid angle exists. Actuator must be rotational.

◆ setActuator()

setActuator ( Integer actuator )

Sets the actuator type.

0: linear actuator. 1: rotational actuator.

◆ setMaximumFeed()

setMaximumFeed ( Number _maximumFeed )

Sets the maximum feed of the axis.

◆ setName()

setName ( String name )

Sets the identifier for the axis.

◆ setPreference()

setPreference ( Integer preference )

Sets the angle/offset preference.

0: don't care -1: prefer negative angles/offsets. 1: prefer positive angles/offsets.

Parameters
preference The preference.

◆ setRapidFeed()

setRapidFeed ( Number _rapidFeed )

Sets the rapid feed of the axis.

◆ setReset()

setReset ( Integer reset )

Sets the axis reset behavior.

0: disabled. 1: reset to 0 at new operation. 2: reset to 0 at rewind.. 3: reset to 0 at new operation and at rewind.

Parameters
reset The reset behavior.

◆ setResolution()

setResolution ( Number resolution )

Sets the resolution of the axis. Radians for rotational axis.


Member List

Axis Member List

This is the complete list of members for Axis, including all inherited members.

Axis() | Axis
Axis(Boolean _table, Vector _axis, Vector _offset, Integer _coordinate) | Axis
Axis(Boolean _table, Vector _axis, Vector _offset, Integer _coordinate, Range _range) | Axis
clamp(Number value) | Axis
clampToResolution(Number _value) | Axis
getActuator() | Axis
getAxis() | Axis
getAxisRotation(Number position) | Axis
getCoordinate() | Axis
getDisplacement() | Axis
getEffectiveAxis() | Axis
getHomePosition() | Axis
getMaximumFeed() | Axis
getName() | Axis
getOffset() | Axis
getPreference() | Axis
getRange() | Axis
getRapidFeed() | Axis
getReset() | Axis
getResolution() | Axis
getResolutionError(Number _value) | Axis
isAggregate() | Axis
isCyclic() | Axis
isEnabled() | Axis
isHead() | Axis
isLinear() | Axis
isRotational() | Axis
isSupported(Number value) | Axis
isTable() | Axis
isTCPEnabled() | Axis
reduce(Number value) | Axis
remapToRange(Number angle) | Axis
remapToRange2(Number angle, Number current) | Axis
setActuator(Integer actuator) | Axis
setMaximumFeed(Number _maximumFeed) | Axis
setName(String name) | Axis
setPreference(Integer preference) | Axis
setRapidFeed(Number _rapidFeed) | Axis
setReset(Integer reset) | Axis
setResolution(Number resolution) | Axis


Base64 Class Reference

Inherits ScriptObject.

Static Public Member Functions

static String | btoa (String text)
static String | atob (String text)

Detailed Description

Class format Base64 encoding/decoding.

Since
41349

Member Function Documentation

◆ atob()

static String atob ( String text )
static

Decodes the given string in Base64 format.

Parameters
text The encoded text.

◆ btoa()

static String btoa ( String text )
static

Encodes the given text in Base64 format.

Parameters
text The unencoded test.


Member List

Base64 Member List

This is the complete list of members for Base64, including all inherited members.

atob(String text) | Base64 | static
btoa(String text) | Base64 | static


BinaryFile Class Reference

Inherits ScriptObject.

Static Public Member Functions

static String | loadBinary (String path)
static | saveBinary (String path, String data)

Detailed Description

Class for binary file load and save.

Security: Requires security level 0.

Since
41349

Member Function Documentation

◆ loadBinary()

static String loadBinary ( String path )
static

Load binary file as string.

Parameters
path The path of the file.
Returns
Returns string with each byte represented as its own character.

◆ saveBinary()

static saveBinary | ( | String | path,
 |  | String | data
 | ) |  |
static

Save string as binary file. Each byte must be represented as its own character.

Parameters
path | The path of the file.
data | Specifies if the data to write.


Member List

BinaryFile Member List

This is the complete list of members for BinaryFile, including all inherited members.

loadBinary(String path) | BinaryFile | static
saveBinary(String path, String data) | BinaryFile | static


Boolean Class Reference

Detailed Description

JavaScript boolean.


BoundingBox Class Reference

Inherits ScriptObject.

Public Member Functions

BoundingBox ()
BoundingBox (Vector a, Vector b)
expandTo (Vector point)
expandToBox (BoundingBox box)
VectorPair getRayIntersection (Vector origin, Vector direction, Vector expansion=Vector())

Public Attributes

Vector lower
Vector upper

Detailed Description

3D bounding box specified by the lower and upper corners.

Constructor & Destructor Documentation

◆ BoundingBox() [1/2]

BoundingBox ( )

Initializes the bounding box and (0, 0, 0) -> (0, 0, 0).

◆ BoundingBox() [2/2]

BoundingBox | ( | Vector | a,
 |  | Vector | b
 | ) |  |

Initializes the bounding box for the specified corners.

Parameters
a | Corner of box.
b | Corner of box.

Member Function Documentation

◆ expandTo()

expandTo ( Vector point )

Expands the bounding box to include the specified position.

◆ expandToBox()

expandToBox ( BoundingBox box )

Expands the bounding box to include the specified bounding box.

◆ getRayIntersection()

VectorPair getRayIntersection | ( | Vector | origin,
 |  | Vector | direction,
 |  | Vector | expansion = Vector()
 | ) |  |

Gets intersection between the bounding box and a ray.

Parameters
origin | Origin point of the ray.
direction | Direction vector of the ray. Should be non-zero.
expansion | Additional thickness added to the bounding box. Should be non-negative.
Returns
Pair of intersection points. First intersection point is where the ray enters the bounding box. Second point, where the ray exits from the bounding. If ray's origin is inside the bounding box, first point is equal to second. Returns null, if the ray does not intersect the bounding box.
Since
r45500

Member Data Documentation

◆ lower

Vector lower

The lower corner.

◆ upper

Vector upper

The upper corner.


Member List

BoundingBox Member List

This is the complete list of members for BoundingBox, including all inherited members.

BoundingBox() BoundingBox
BoundingBox(Vector a, Vector b) | BoundingBox
expandTo(Vector point) | BoundingBox
expandToBox(BoundingBox box) | BoundingBox
getRayIntersection(Vector origin, Vector direction, Vector expansion=Vector()) | BoundingBox


Canvas Class Reference

Inherits ScriptObject.

Public Member Functions

Canvas (Integer _width, Integer _height)
Integer getWidth ()
Integer getHeight ()
clear (Integer rgba)
Color | getColor (Integer x, Integer y)
setColor (Integer x, Integer y, Color color)
Integer | getPixel (Integer x, Integer y)
setPixel (Integer x, Integer y, Integer rgba)
saveImage (String path, String mimetype)

Static Public Member Functions

static Canvas loadImage (String path, String mimetype)

Detailed Description

A 2D canvas for drawing.

Constructor & Destructor Documentation

◆ Canvas()

Canvas | ( | Integer | _width,
 |  | Integer | _height
 | ) |  |

Creates a new canvas frame buffer.

Member Function Documentation

◆ clear()

clear ( Integer rgba )

Clears the canvas.

◆ getColor()

Color getColor | ( | Integer | x,
 |  | Integer | y
 | ) |  |

Returns the RGBA color of the specified pixel.

◆ getHeight()

Integer getHeight ( )

Returns the height of the canvas.

◆ getPixel()

Integer getPixel | ( | Integer | x,
 |  | Integer | y
 | ) |  |

Returns the RGBA color of the specified pixel.

◆ getWidth()

Integer getWidth ( )

Returns the width of the canvas.

◆ loadImage()

static Canvas loadImage | ( | String | path,
 |  | String | mimetype
 | ) |  |
static

Loads the specified picture into a new Canvas.

Parameters
path | The path of the source file.
mimetype | The MIME type of the image (must be "image/png").

◆ saveImage()

saveImage | ( | String | path,
 |  | String | mimetype
 | ) |  |

Exports the canvas to the specified path.

Parameters
path | The path of the destination file.
mimetype | The MIME type of the image (must be "image/png").

◆ setColor()

setColor | ( | Integer | x,
 |  | Integer | y,
 |  | Color | color
 | ) |  |

Returns the RGBA color of the specified pixel.

◆ setPixel()

setPixel | ( | Integer | x,
 |  | Integer | y,
 |  | Integer | rgba
 | ) |  |

Sets the RGBA color of the specified pixel.


Member List

Canvas Member List

This is the complete list of members for Canvas, including all inherited members.

Canvas(Integer _width, Integer _height) | Canvas |
clear(Integer rgba) | Canvas |
getColor(Integer x, Integer y) | Canvas |
getHeight() | Canvas |
getPixel(Integer x, Integer y) | Canvas |
getWidth() | Canvas |
loadImage(String path, String mimetype) | Canvas | static
saveImage(String path, String mimetype) | Canvas |
setColor(Integer x, Integer y, Color color) | Canvas |
setPixel(Integer x, Integer y, Integer rgba) | Canvas |


CircularMotion Class Reference

Inherits ScriptObject.

Public Member Functions

Vector getPositionU (Number u)
Number getOffset ()

Detailed Description

A circular motion.

Member Function Documentation

◆ getOffset()

Number getOffset ( )

Helical offset.

◆ getPositionU()

Vector getPositionU ( Number u )

Returns the position at the specified u coordinate for the current motion (u is clamped to [0; 1]).


Member List

CircularMotion Member List

This is the complete list of members for CircularMotion, including all inherited members.

getOffset() | CircularMotion
getPositionU(Number u) | CircularMotion


Color Class Reference

Inherits ScriptObject.

Public Member Functions

Color ()
Color (Number red, Number green, Number blue)
Color (Number red, Number green, Number blue, Number alpha)
Number getRed ()
Number getGreen ()
Number getBlue ()
Number getAlpha ()
String toString ()

Detailed Description

Color specified by red, green, blue, and alpha values.

Constructor & Destructor Documentation

◆ Color() [1/3]

Color ( )

Initializes a new color as opaque white.

◆ Color() [2/3]

Color | ( | Number | red,
 |  | Number | green,
 |  | Number | blue
 | ) |  |

Initializes a new color as opaque (i.e. alpha equal to 1). All arguments are clamped to the range [0; 1].

Parameters
red | Red component.
green | Green component.
blue | Blue component.

◆ Color() [3/3]

Color | ( | Number | red,
 |  | Number | green,
 |  | Number | blue,
 |  | Number | alpha
 | ) |  |

Initializes a new color. All arguments are clamped to the range [0; 1].

Parameters
red | Red component.
green | Green component.
blue | Blue component.
alpha | Alpha component.

Member Function Documentation

◆ getAlpha()

Number getAlpha ( )

Returns the alpha component.

◆ getBlue()

Number getBlue ( )

Returns the blue component.

◆ getGreen()

Number getGreen ( )

Returns the green component.

◆ getRed()

Number getRed ( )

Returns the red component.

◆ toString()

String toString ( )

Converts the color to a string (e.g. [0.25, 0.25, 0.75, 1]).


Member List

Color Member List

This is the complete list of members for Color, including all inherited members.

Color() | Color
Color(Number red, Number green, Number blue) | Color
Color(Number red, Number green, Number blue, Number alpha) | Color
getAlpha() | Color
getBlue() | Color
getGreen() | Color
getRed() | Color
toString() | Color


Curve Class Reference

Inherits ScriptObject.

Public Member Functions

Integer getNumberOfEntities ()
CurveEntity | getEntity (Integer index)
Boolean isClosed ()
Boolean hasArcs ()
Number getLength ()
BoundingBox getExtent ()
Curve | getLinearize (Number tolerance)

Detailed Description

A 2D curve.

Since
41366

Member Function Documentation

◆ getEntity()

CurveEntity getEntity ( Integer index )

Returns the entity at the given index.

◆ getExtent()

BoundingBox getExtent ( )

Returns the extent of the curve.

◆ getLength()

Number getLength ( )

Returns the length of the curve.

◆ getLinearize()

Curve getLinearize ( Number tolerance )

Returns the linearization of the Curve.

Parameters
tolerance The linearization tolerance.

◆ getNumberOfEntities()

Integer getNumberOfEntities ( )

Returns the number of entities in the curve.

◆ hasArcs()

Boolean hasArcs ( )

Returns true if the curve has arcs.

◆ isClosed()

Boolean isClosed ( )

Returns true if the curve is closed.


Member List

Curve Member List

This is the complete list of members for Curve, including all inherited members.

getEntity(Integer index) | Curve
getExtent() Curve
getLength() Curve
getLinearize(Number tolerance) | Curve


CurveEntity Class Reference

Inherits ScriptObject.

Public Member Functions

CurveEntity ()
Number getLength ()
Number getRadius ()
Boolean isBigArc ()
Number getSweep ()
reverse ()
translate (Vector offset)

Static Public Member Functions

static CurveEntity | getLine (Vector start, Vector end)
static CurveEntity | getArc (Vector start, Vector end, Vector center, Boolean clockwise)

Public Attributes

Boolean arc
True for arc. Otherwise a line.
Boolean clockwise
The direction of the arc. Clockwise or counterclockwise.
Vector start
The start position. The Z coordinate is always 0.
Vector center
The center for an arc. The Z coordinate is always 0.
Vector end
The end position. The Z coordinate is always 0.

Detailed Description

Curve entity.

Since
41366

Constructor & Destructor Documentation

◆ CurveEntity()

CurveEntity ( )

Constructs a Curve entity.

Member Function Documentation

◆ getArc()

static CurveEntity getArc | ( | Vector | start,
 |  | Vector | end,
 |  | Vector | center,
 |  | Boolean | clockwise
 | ) |  |
static

Makes an arc entity.

◆ getLength()

Number getLength ( )

Returns the length of the entity.

◆ getLine()

static CurveEntity getLine | ( | Vector | start,
 |  | Vector | end
 | ) |  |
static

Makes a line entity.

◆ getRadius()

Number getRadius ( )

Returns the radius of the arc entity as defined by the end and center.

◆ getSweep()

Number getSweep ( )

Returns the sweep for the arc entity.

◆ isBigArc()

Boolean isBigArc ( )

Returns true if the arc entity if big. Sweep > 180deg.

◆ reverse()

reverse ( )

Reverses the entity.

◆ translate()

translate ( Vector offset )

Translates the entity. Z is ignored.


Member List

CurveEntity Member List

This is the complete list of members for CurveEntity, including all inherited members.

arc | CurveEntity |
center | CurveEntity |
clockwise | CurveEntity |
CurveEntity() | CurveEntity |
end | CurveEntity |
getArc(Vector start, Vector end, Vector center, Boolean clockwise) | CurveEntity | static
getLength() | CurveEntity |
getLine(Vector start, Vector end) | CurveEntity | static
getRadius() | CurveEntity |
getSweep() | CurveEntity |
isBigArc() | CurveEntity |
reverse() | CurveEntity |
start | CurveEntity |
translate(Vector offset) | CurveEntity |


Date Class Reference

Detailed Description

JavaScript date class.


DeferredVariables Class Reference

Static Public Member Functions

static String | get (String id, Format format)
static | set (String id, Number value)

Static Public Attributes

static String separator

Detailed Description

Deferred variables handling class.

This class is used for handling values, which are not known during outputting. For example, reference to sub-program's line number. For outputting deferred variable write:

writeBlock(DeferredVariables.get(id, format));

"id" - is an unique string identifier of variable to output; "format" - format, that should be used to format variable.

At place, where variable gets defined (for example, line number becomes known) write following code:

DeferredVariables.set(id, value);

"id" - is a same identifier, that was used during output; "value" - is an actual value of the variable.

If at least one deferred variable was written to output file, termination handler is set to replace them with actual values at the end of processing.

Since
r45238

Member Function Documentation

◆ get()

static String get | ( | String | id,
 |  | Format | format
 | ) |  |
static

Function for getting deferred variable for printing to output.

Parameters
id | An unique string identifier of variable to output.
format | Format, that should be used to format variable.
Returns
Returns formatted value of deferred variable, if it is defined, and string "##ID##", if not. If variable is not defined, it sets termination handler for replacing variables in output.

◆ set()

static set | ( | String | id,
 |  | Number | value
 | ) |  |
static

Function for setting deferred variable's value.

Parameters
id | An unique string identifier of variable to output.
value | Actual value of variable.

Member Data Documentation

◆ separator

String separator
static

Deferred variables id separator.

This property should be set to something, that cannot be found in output. Default value: "##"


Member List

DeferredVariables Member List

This is the complete list of members for DeferredVariables, including all inherited members.

get(String id, Format format) | DeferredVariables | static
separator | DeferredVariables | static
set(String id, Number value) | DeferredVariables | static


FileSystem Class Reference

Inherits ScriptObject.

Static Public Member Functions

static String | getCombinedPath (String rootPath, String relativePath)
static String | getFolderPath (String path)
static String | getFilename (String path)
static String | replaceExtension (String path, String extension)
static | makeFolder (String path)
static Boolean | isFolder (String path)
static Boolean | isFile (String path)
static | copyFile (String src, String dest)
static | moveFile (String src, String dest)
static | remove (String path)
static | removeFolder (String path)
static | removeFolderRecursive (String path)
static Integer | getFileSize (String path)
static String | getTemporaryFolder ()
static String | getTemporaryFile (String prefix)

Detailed Description

This class provides access to the file system.

Security: Requires security level 0.

Member Function Documentation

◆ copyFile()

static copyFile | ( | String | src,
 |  | String | dest
 | ) |  |
static

Copies the specified file from the source path to the destination path.

Parameters
src | The path of the source file.
dest | The path of the destination file.

◆ getCombinedPath()

static String getCombinedPath | ( | String | rootPath,
 |  | String | relativePath
 | ) |  |
static

Returns the combined paths.

Parameters
rootPath | The tool path.
relativePath | The relative path.

◆ getFilename()

static String getFilename ( String path )
static

Returns the filename from specified path.

Parameters
path The path.
Since
r16737

◆ getFileSize()

static Integer getFileSize ( String path )
static

Returns the size of the specified file.

Parameters
path The path of the file.

◆ getFolderPath()

static String getFolderPath ( String path )
static

Returns the path of the parent folder.

Parameters
path The path.

◆ getTemporaryFile()

static String getTemporaryFile ( String prefix )
static

Returns the path of a new temporary file.

Parameters
prefix The prefix of the file.

◆ getTemporaryFolder()

static String getTemporaryFolder ( )
static

Returns the path of the primary temporary folder.

◆ isFile()

static Boolean isFile ( String path )
static

Returns true if the specified file exists.

Parameters
path The path of the file.

◆ isFolder()

static Boolean isFolder ( String path )
static

Returns true if the specified folder exists.

Parameters
path The path of the folder.

◆ makeFolder()

static makeFolder ( String path )
static

Creates the specified folder.

Parameters
path The path of the folder.

◆ moveFile()

static moveFile | ( | String | src,
 |  | String | dest
 | ) |  |
static

Moves the specified file from the source path to the destination path.

Parameters
src | The path of the source file.
dest | The path of the destination file.

◆ remove()

static remove ( String path )
static

Removes the specified file.

◆ removeFolder()

static removeFolder ( String path )
static

Removes the specified folder.

◆ removeFolderRecursive()

static removeFolderRecursive ( String path )
static

Removes the specified folder recursively.

◆ replaceExtension()

static String replaceExtension | ( | String | path,
 |  | String | extension
 | ) |  |
static

Replaces the extension of the specified path.


Member List

FileSystem Member List

This is the complete list of members for FileSystem, including all inherited members.

copyFile(String src, String dest) | FileSystem | static
getCombinedPath(String rootPath, String relativePath) | FileSystem | static
getFilename(String path) | FileSystem | static
getFileSize(String path) | FileSystem | static
getFolderPath(String path) | FileSystem | static
getTemporaryFile(String prefix) | FileSystem | static
getTemporaryFolder() | FileSystem | static
isFile(String path) | FileSystem | static
isFolder(String path) | FileSystem | static
makeFolder(String path) | FileSystem | static
moveFile(String src, String dest) | FileSystem | static
remove(String path) | FileSystem | static
removeFolder(String path) | FileSystem | static
removeFolderRecursive(String path) | FileSystem | static
replaceExtension(String path, String extension) | FileSystem | static


Format Class Reference

Public Member Functions

Format (Map specifiers)
String | format (Number value)
Number | getResultingValue (Number value)
Number | getError (Number value)
Boolean | isSignificant (Number value)
Boolean | areDifferent (Number a, Number b)
Number getMinimumValue ()

Detailed Description

Format specification and formatter.

Constructor & Destructor Documentation

◆ Format()

Format ( Map specifiers )

Constructs the format specification for the given values. See createFormat().

Parameters
specifiers The format specifiers.

The supported specifiers are:

  1. decimals: Specifies the number of decimals. Defaults to 6.
  2. trim: Specifies that ending zero decimals should be trimming. Defaults to true.
  3. trimLeadZero: Specifies that the leading zero should be excluded. Eg. ".123" instead of "0.123". Defaults to false.
  4. forceSign: Specifies that the '+'-sign must be included for positive numbers. Defaults to false.
  5. forceDecimal: Specifies that the decimal symbol must be included. Defaults to false.
  6. zeropad: Specifies that zeros should be padded to the resulting string to fit the given width. Defaults to false.
  7. width: Specifies the width of the resulting string. Defaults to 0.
  8. separator: Specifies the decimal symbol. Defaults to '.'.
  9. cyclicLimit: Specifies the cyclic limit. Defaults to 0 (disabled).
  10. cyclicSign: Specifies the cyclic sign. Defaults to 0.
  11. scale: Specifies the scale. Defaults to 1.
  12. offset: Specifies the offset. Defaults to 0.
  13. prefix: Specifies the prefix. Defaults to empty string.
  14. suffix: Specifies the suffix. Defaults to empty string.
  15. inherit: Specifies the format to inherit.
var xFormat = createFormat({decimals:3, trim:false, forceSign:true});
xFormat.format(4.5); // returns "+4.500"
var yFormat = createFormat({decimals:3, forceSign:true});
yFormat.format(4.5); // returns "+4.5"
var toolFormat = createFormat({decimals:0, zeropad:true, width:2});
toolFormat.format(7); // returns "07"
var aFormat = createFormat({decimals:3, forceSign:true, forceDecimal:true, scale:DEG});
aFormat.format(Math.Pi); // returns "+180."

Member Function Documentation

◆ areDifferent()

Boolean areDifferent | ( | Number | a,
 |  | Number | b
 | ) |  |

Returns true if the specified values are different when formatted.

Since
r19569

◆ format()

String format ( Number value )

Returns the formatted string for the specified value.

◆ getError()

Number getError ( Number value )

Returns the error for the specified value.

var xFormat = createFormat({decimals:3, trim:false, forceSign:true});
xFormat.format(4.5005); // returns "+4.500"
xFormat.getError(4.5005); // returns -0.0005
xFormat.format(4.4995); // returns "+4.500"
xFormat.getError(4.4995); // returns 0.0005

◆ getMinimumValue()

Number getMinimumValue ( )

Returns the minimum epsilon value.

Returns
1 for no decimals, 0.1 for 1 decimal and so forth.

◆ getResultingValue()

Number getResultingValue ( Number value )

Returns the resulting value for the specified value.

var xFormat = createFormat({decimals:3, trim:false, forceSign:true});
xFormat.getResultingValue(123.1234); // returns 123.123
xFormat.getResultingValue(123.9876); // returns 123.988

◆ isSignificant()

Boolean isSignificant ( Number value )

Returns true if the specified value would be non-zero when formatted. See areDifferent() for comparing 2 values.

var xFormat = createFormat({decimals:3, trim:false, forceSign:true});
xFormat.isSignificant(4.5); // returns true
xFormat.isSignificant(0.0005); // returns true - because it is rounded to 0.001
xFormat.isSignificant(0.0004); // returns false
var v = new Vector(-0.00001, 0.0004, -0.001);
xFormat.isSignificant(v.abs.max); // returns true


Member List

Format Member List

This is the complete list of members for Format, including all inherited members.

areDifferent(Number a, Number b) | Format
format(Number value) | Format
Format(Map specifiers) | Format
getError(Number value) | Format
getMinimumValue() | Format
getResultingValue(Number value) | Format
isSignificant(Number value) | Format


FormatNumber Class Reference

Inherits ScriptObject.

Public Member Functions

FormatNumber ()
Integer getDecimalSymbol ()
setDecimalSymbol (Integer decimalSymbol)
Boolean getZeroPad ()
setZeroPad (Boolean zeroPad)
Boolean getForceSign ()
setForceSign (Boolean forceSign)
Boolean getForceDecimal ()
setForceDecimal (Boolean forceDecimal)
Integer getWidth ()
setWidth (Integer width)
Integer getNumberOfDecimals ()
setNumberOfDecimals (Integer numberOfDecimals)
Boolean getTrimZeroDecimals ()
setTrimZeroDecimals (Boolean trimZeroDecimals)
Boolean getTrimLeadZero ()
setTrimLeadZero (Boolean trimLeadZero)
Number | remap (Number value)
Number getCyclicLimit ()
Integer getCyclicSign ()
setCyclicMapping (Number limit, Integer sign)
Number getScale ()
setScale (Number scale)
Number getOffset ()
setOffset (Number offset)
String getPrefix ()
setPrefix (String prefix)
String getSuffix ()
setSuffix (String suffix)
String | format (Number value)
Boolean | isSignificant (Number value)
Boolean | areDifferent (Number a, Number b)
Number getMinimumValue ()
Number | getResultingValue (Number value)
Number | getError (Number value)

Public Attributes

Integer numberOfDecimals
The number of decimals.
Boolean trimZeroDecimals
Specifies that suffix zero decimals should be skipped. Defaults to true.
Boolean trimLeadZero
Specifies that the leading zero should be excluded. Eg. ".123" instead of "0.123". Defaults to false.
Boolean zeroPad
Specifies if the returned string should be padded with zeros to fit the width. Defaults to false.
Integer width
Specifies the width. Defaults to 0.
Integer decimalSymbol
The decimal symbol. Defaults to '.'.
Boolean forceSign
Specifies that a sign should always be returned. Defaults to false.
Boolean forceDecimal
Specifies that the decimal separator must be returned. Defaults to false.
Number cyclicLimit
Specifies the cyclic limit.
Integer cyclicSign
Specifies the cyclic sign. Only valid if cyclicLimit > 0.
Number scale
Specifies a scaling factor.
Number offset
Specifies an offset.
String prefix
Specifies a prefix.
String suffix
Specifies a suffix.

Detailed Description

This class converts numbers into strings in accordance with several modifiers.

When value remapping is enabled the cyclic mapping is done first, then the scaling, and finally the offset.

Constructor & Destructor Documentation

◆ FormatNumber()

FormatNumber ( )

Constructs a number formatting object.

Member Function Documentation

◆ areDifferent()

Boolean areDifferent | ( | Number | a,
 |  | Number | b
 | ) |  |

Returns true if the specified values are different when formatted.

◆ format()

String format ( Number value )

Returns the string for the specified value.

◆ getCyclicLimit()

Number getCyclicLimit ( )

Returns the cyclic limit.

◆ getCyclicSign()

Integer getCyclicSign ( )

Returns the cyclic sign.

◆ getDecimalSymbol()

Integer getDecimalSymbol ( )

Returns the decimal separator.

◆ getError()

Number getError ( Number value )

Returns the error for the specified value.

◆ getForceDecimal()

Boolean getForceDecimal ( )

Returns the force sign flag.

◆ getForceSign()

Boolean getForceSign ( )

Returns the force sign flag.

◆ getMinimumValue()

Number getMinimumValue ( )

Returns the minimum epsilon value.

Returns
1 for no decimals, 0.1 for 1 decimal and so forth.

◆ getNumberOfDecimals()

Integer getNumberOfDecimals ( )

Returns the number of decimals.

◆ getOffset()

Number getOffset ( )

Returns the offset.

◆ getPrefix()

String getPrefix ( )

Returns the prefix.

◆ getResultingValue()

Number getResultingValue ( Number value )

Returns the resulting value for the specified value.

◆ getScale()

Number getScale ( )

Returns the scale.

◆ getSuffix()

String getSuffix ( )

Returns the suffix.

◆ getTrimLeadZero()

Boolean getTrimLeadZero ( )

Returns true if the leading zero should be skipped.

◆ getTrimZeroDecimals()

Boolean getTrimZeroDecimals ( )

Returns true if the suffix zero decimals should be skipped.

◆ getWidth()

Integer getWidth ( )

Returns the width.

◆ getZeroPad()

Boolean getZeroPad ( )

Returns the zero padding mode.

◆ isSignificant()

Boolean isSignificant ( Number value )

Returns true if the specified value would be non-zero when formatted. When comparing 2 values use areDifferent() instead.

◆ remap()

Number remap ( Number value )

Returns the value after cyclic mapping, scaling, and offset.

◆ setCyclicMapping()

setCyclicMapping | ( | Number | limit,
 |  | Integer | sign
 | ) |  |

Sets the cyclic mapping.

Parameters
limit | Specifies the cyclic limit. Must be positive or 0. Cyclic mapping will be disabled when set to 0.
sign | Specifies the sign. Must in -1, 0, or 1.

For sign -1 the values will be mapped to the range [-cyclicLimit; 0] For sign 0 the values will be mapped to the range [-cyclicLimit; cyclicLimit] For sign 1 the values will be mapped to the range [0; cyclicLimit]

The cyclic mapping is done before scaling and offset.

◆ setDecimalSymbol()

setDecimalSymbol ( Integer decimalSymbol )

Sets the decimal separator.

◆ setForceDecimal()

setForceDecimal ( Boolean forceDecimal )

Sets the force sign flag.

◆ setForceSign()

setForceSign ( Boolean forceSign )

Sets the force sign flag.

◆ setNumberOfDecimals()

setNumberOfDecimals ( Integer numberOfDecimals )

Sets the number of decimals.

◆ setOffset()

setOffset ( Number offset )

Sets the offset.

◆ setPrefix()

setPrefix ( String prefix )

Sets the prefix.

◆ setScale()

setScale ( Number scale )

Sets the scale.

◆ setSuffix()

setSuffix ( String suffix )

Sets the suffix.

◆ setTrimLeadZero()

setTrimLeadZero ( Boolean trimLeadZero )

Sets the skip leading zero flag.

◆ setTrimZeroDecimals()

setTrimZeroDecimals ( Boolean trimZeroDecimals )

Sets the skip zero decimals flag.

◆ setWidth()

setWidth ( Integer width )

Sets the width.

◆ setZeroPad()

setZeroPad ( Boolean zeroPad )

Sets zero padding mode.


Member List

FormatNumber Member List

This is the complete list of members for FormatNumber, including all inherited members.

areDifferent(Number a, Number b) | FormatNumber
cyclicLimit | FormatNumber
cyclicSign | FormatNumber
decimalSymbol | FormatNumber
forceDecimal | FormatNumber
forceSign | FormatNumber
format(Number value) | FormatNumber
FormatNumber() | FormatNumber
getCyclicLimit() | FormatNumber
getCyclicSign() | FormatNumber
getDecimalSymbol() | FormatNumber
getError(Number value) | FormatNumber
getForceDecimal() | FormatNumber
getForceSign() | FormatNumber
getMinimumValue() | FormatNumber
getNumberOfDecimals() | FormatNumber
getOffset() | FormatNumber
getPrefix() | FormatNumber
getResultingValue(Number value) | FormatNumber
getScale() | FormatNumber
getSuffix() | FormatNumber
getTrimLeadZero() | FormatNumber
getTrimZeroDecimals() | FormatNumber
getWidth() | FormatNumber
getZeroPad() | FormatNumber
isSignificant(Number value) | FormatNumber
numberOfDecimals | FormatNumber
offset | FormatNumber
prefix | FormatNumber
remap(Number value) | FormatNumber
scale | FormatNumber
setCyclicMapping(Number limit, Integer sign) | FormatNumber
setDecimalSymbol(Integer decimalSymbol) | FormatNumber
setForceDecimal(Boolean forceDecimal) | FormatNumber
setForceSign(Boolean forceSign) | FormatNumber
setNumberOfDecimals(Integer numberOfDecimals) | FormatNumber
setOffset(Number offset) | FormatNumber
setPrefix(String prefix) | FormatNumber
setScale(Number scale) | FormatNumber
setSuffix(String suffix) | FormatNumber
setTrimLeadZero(Boolean trimLeadZero) | FormatNumber
setTrimZeroDecimals(Boolean trimZeroDecimals) | FormatNumber
setWidth(Integer width) | FormatNumber
setZeroPad(Boolean zeroPad) | FormatNumber
suffix | FormatNumber
trimLeadZero | FormatNumber
trimZeroDecimals | FormatNumber
width | FormatNumber
zeroPad | FormatNumber


FormData Class Reference

Inherits ScriptObject.

Public Member Functions

FormData ()
append (String name, String value, String filename)
Boolean | has (String name)
String | get (String name)

Detailed Description

FormData for use with XMLHttpRequest.

Since
41366

Constructor & Destructor Documentation

◆ FormData()

FormData ( )

Constructs a new FormData object.

Member Function Documentation

◆ append()

append | ( | String | name,
 |  | String | value,
 |  | String | filename
 | ) |  |

Append new value.

Parameters
name | The key.
value | The value.
filename | The filename.

◆ get()

String get ( String name )

Returns the value for the given key. Returns empty if key doesn't exist.

Parameters
name The key of the data.

◆ has()

Boolean has ( String name )

Returns true if the given key exists.

Parameters
name The key of the data.


Member List

FormData Member List

This is the complete list of members for FormData, including all inherited members.

append(String name, String value, String filename) | FormData
FormData() | FormData
get(String name) | FormData
has(String name) | FormData


Holder Class Reference

Inherits ScriptObject.

Public Member Functions

Boolean hasSections ()
Integer getNumberOfSections ()
Number getMaximumDiameter ()
Number getTotalLength ()
Number | getDiameter (Integer index)
Number | getLength (Integer index)

Public Attributes

Number maximumDiameter
The maximum diameter.
Number length
The length of the holder.

Detailed Description

Holder.

Member Function Documentation

◆ getDiameter()

Number getDiameter ( Integer index )

Returns the diameter of the specified section. The section is a value in the range [0; getNumberOfSections()].

◆ getLength()

Number getLength ( Integer index )

Returns the length of the specified section. The section is a value in the range [0; getNumberOfSections()].

◆ getMaximumDiameter()

Number getMaximumDiameter ( )

Returns the maximum diameter of the holder.

◆ getNumberOfSections()

Integer getNumberOfSections ( )

Returns the number of sections.

◆ getTotalLength()

Number getTotalLength ( )

Returns the length of the holder.

◆ hasSections()

Boolean hasSections ( )

Returns true if the holder has any sections.


Member List

Holder Member List

This is the complete list of members for Holder, including all inherited members.

getDiameter(Integer index) | Holder
getLength(Integer index) | Holder
getMaximumDiameter() | Holder
getNumberOfSections() | Holder
getTotalLength() | Holder
hasSections() | Holder
length | Holder
maximumDiameter | Holder


IncrementalVariable Class Reference

Public Member Functions

IncrementalVariable (Map specifiers, Format format)
String format (Number value)
Value getPrefix ()
setPrefix (Value prefix)
disable ()
reset ()
Value getCurrent ()

Detailed Description

An incremental formatting variable. State is maintained to avoid output for zero increments.

var xFormat = createFormat({decimals:3, trim:false});
var xVariable = new IncrementalVariable({prefix: "X"}, xFormat);
var str = xVariable.format(4.4); // returns "X4.400"
str = xVariable.format(4.4); // returns ""
str = xVariable.format(7); // returns "X2.600"

Constructor & Destructor Documentation

◆ IncrementalVariable()

IncrementalVariable | ( | Map | specifiers,
 |  | Format | format
 | ) |  |

Constructs a variable.

The supported specifiers are:

  1. prefix: Specifies a prefix to be prepended the formatted value.
  2. force: Specifies that the value always must be output.
  3. first: Specifies the first value to be output. The default is 0.

Member Function Documentation

◆ disable()

disable ( )

Disable variable. When invoked format() always returns the empty string.

◆ format()

String format ( Number value )

Returns the formatted string of the specified value. The empty string is returned if the value is identical to the last formatted value.

◆ getCurrent()

Value getCurrent ( )

Returns the last formatted value.

◆ getPrefix()

Value getPrefix ( )

Returns the prefix.

◆ reset()

reset ( )

Invoke to force output of value on the next invocation of format(). reset() has no effect if force has been set to true for the given format.

◆ setPrefix()

setPrefix ( Value prefix )

Sets the prefix.


Member List

IncrementalVariable Member List

This is the complete list of members for IncrementalVariable, including all inherited members.

disable() | IncrementalVariable
format(Number value) | IncrementalVariable
getCurrent() | IncrementalVariable
getPrefix() | IncrementalVariable
IncrementalVariable(Map specifiers, Format format) | IncrementalVariable
reset() | IncrementalVariable
setPrefix(Value prefix) | IncrementalVariable


Integer Class Reference

Detailed Description

JavaScript integer. This is a Number which is actually an integer.


MachineConfiguration Class Reference

Inherits ScriptObject, and UnitConsumer.

Public Member Functions

String getXML ()
MachineConfiguration ()
MachineConfiguration (Axis u)
MachineConfiguration (Axis u, Axis v)
MachineConfiguration (Axis u, Axis v, Axis w)
Boolean getMilling ()
setMilling (Boolean milling)
Boolean getTurning ()
setTurning (Boolean turning)
Boolean getWire ()
setWire (Boolean wire)
Boolean getJet ()
setJet (Boolean jet)
Boolean getAdditiveFFF ()
setAdditiveFFF (Boolean additive)
Boolean getInspection ()
setInspection (Boolean inspection)
Boolean getToolChanger ()
setToolChanger (Boolean toolChanger)
Boolean getToolPreload ()
setToolPreload (Boolean toolPreload)
Integer getNumberOfTools ()
setNumberOfTools (Integer numberOfTools)
Number getMaximumToolLength ()
setMaximumToolLength (Number maximumToolLength)
Number getMaximumToolDiameter ()
setMaximumToolDiameter (Number maximumToolDiameter)
Number getMaximumToolWeight ()
setMaximumToolWeight (Number maximumToolWeight)
Number getMaximumFeedrate ()
setMaximumFeedrate (Number maximumFeedrate)
Number getMaximumCuttingFeedrate ()
setMaximumCuttingFeedrate (Number maximumCuttingFeedrate)
Integer getMaximumBlockProcessingSpeed ()
setMaximumBlockProcessingSpeed (Integer maximumBlockProcessingSpeed)
Integer getNumberOfWorkOffsets ()
setNumberOfWorkOffsets (Integer numberOfWorkOffsets)
Number getFeedrateRatio ()
setFeedrateRatio (Number feedrateRatio)
Number getToolChangeTime ()
setToolChangeTime (Number toolChangeTime)
addAxis (Axis axis)
Boolean performRewinds ()
enableMachineRewinds ()
disableMachineRewinds ()
Boolean getReconfigure ()
setReconfigure (Boolean enable)
setRewindStockExpansion (Vector expansion)
Vector getRewindStockExpansion ()
setSafeRetractDistance (Number safeRetractDistance)
Number getSafeRetractDistance ()
setSafeRetractFeedrate (Number safeRetractFeedrate)
Number getSafeRetractFeedrate ()
setSafePlungeFeedrate (Number safePlungeFeedrate)
Number getSafePlungeFeedrate ()
Vector getDimensions ()
setDimensions (Vector dimensions)
Number getWidth ()
setWidth (Number width)
Number getDepth ()
setDepth (Number depth)
Number getHeight ()
setHeight (Number height)
Number getWeight ()
setWeight (Number weight)
Vector getPartDimensions ()
setPartDimensions (Vector partDimensions)
Number getPartMaximumX ()
setPartMaximumX (Number width)
Number getPartMaximumY ()
setPartMaximumY (Number depth)
Number getPartMaximumZ ()
setPartMaximumZ (Number height)
Number getWeightCapacity ()
setWeightCapacity (Number weightCapacity)
Vector getSpindleAxis ()
setSpindleAxis (Vector spindleAxis)
String getSpindleDescription ()
setSpindleDescription (String spindleDescription)
Number getMaximumSpindlePower ()
setMaximumSpindlePower (Number maximumSpindlePower)
Number getMaximumSpindleSpeed ()
setMaximumSpindleSpeed (Number maximumSpindleSpeed)
String getCollectChuck ()
setCollectChuck (String collectChuck)
Number getToolLength ()
setToolLength (Number toolLength)
Boolean getVirtualTooltip ()
setVirtualTooltip (Boolean virtualPositioning)
Axis | getAxisByName (String name)
Axis getAxisX ()
Axis getAxisY ()
Axis getAxisZ ()
Boolean | isSupportedPosition (Vector position)
Integer getValidityStatus ()
Boolean isSupported ()
setMultiAxisFeedrate (Integer feedMode, Number maximumFeedrate, Integer feedType, Number outputTolerance, Number bpwRatio)
Integer getMultiAxisFeedrateMode ()
Number getMultiAxisFeedrateMaximum ()
Integer getMultiAxisFeedrateDPMType ()
Integer getMultiAxisFeedrateInverseTimeUnits ()
Number getMultiAxisFeedrateOutputTolerance ()
Number getMultiAxisFeedrateBpwRatio ()
setSingularity (Boolean adjust, Integer method, Number cone, Number angle, Number tolerance, Number linearizationTolerance)
Boolean getSingularityAdjust ()
Integer getSingularityMethod ()
Number getSingularityCone ()
Number getSingularityAngle ()
Number getSingularityTolerance ()
Number getSingularityLinearizationTolerance ()
Boolean | isMachineAxisRotation (Vector abc)
Boolean is3DConfiguration ()
Boolean isMultiAxisConfiguration ()
Integer getNumberOfAxes ()
Boolean isHeadConfiguration ()
Boolean isTableConfiguration ()
Axis getAxisU ()
Axis getAxisV ()
Axis getAxisW ()
Integer | getIndexOfAxisById (AxisId id)
Boolean | isMachineCoordinate (Integer coordinate)
Axis | getAxisByCoordinate (Integer coordinate)
Vector | clamp (Vector _abc)
Vector | clampToResolution (Vector _abc)
Vector | getRotationAxis (Axis axis)
Vector | preserveRotaryAtZero (Vector currentDirection, Vector previousABC, Vector currentABC)
Vector | getClosestABC (Vector current, Vector abc)
Boolean | isXYZSupported (Vector _xyz)
Boolean | isABCSupported (Vector _abc)
Boolean | isDirectionSupported (Vector direction)
Vector | getOptimizedPosition (Vector currentXYZ, Vector currentABC, Integer tcpType, Integer optimizeType, Boolean forceAdjustment)
Vector | getOptimizedDirection (Vector direction, Vector currentABC, Boolean reverse, Boolean forceAdjustment)
Vector | getOptimizedTables (Vector currentXYZ, Vector currentABC, Boolean reverse, Integer optimizeType, Boolean isVector, Boolean forceAdjustment)
Vector | getOptimizedHeads (Vector currentXYZ, Vector currentABC, Boolean reverse, Integer optimizeType, Boolean forceAdjustment, Boolean pivotPoint)
Vector | getABC (Matrix orientation)
VectorPair | getABCByDirectionBoth (Vector direction)
Vector | getABCByDirection (Vector direction)
Vector | getABCByDirection2 (Vector direction)
Vector | getABCByPreference (Matrix orientation, Vector current, Integer controllingAxis, Integer type, Integer options)
Vector | getOtherABCByDirection (Vector abc)
Vector | getPreferredABC (Vector abc)
Vector | remapABC (Vector abc)
Vector | remapToABC (Vector abc, Vector current)
Integer getCoordinates ()
Vector | getPosition (Vector p, Vector abc)
Vector | getDirection (Vector abc)
Vector | getHeadABC (Vector abc)
Vector | getTableABC (Vector abc)
Matrix | getHeadOrientation (Vector abc)
Matrix | getTableOrientation (Vector abc)
Matrix | getOrientation (Vector abc)
Vector | getSpindleAxisABC (Vector abc)
Matrix | getRemainingOrientation (Vector abc, Matrix desired)
Number getRetractPlane ()
setRetractPlane (Number retractPlane)
Boolean hasHomePositionX ()
Number getHomePositionX ()
setHomePositionX (Number x)
Boolean hasHomePositionY ()
Number getHomePositionY ()
setHomePositionY (Number y)
Boolean hasHomePositionZ ()
Number getHomePositionZ ()
setHomePositionZ (Number z)
Boolean hasCenterPosition ()
Number getCenterPositionX ()
setCenterPositionX (Number x)
Number getCenterPositionY ()
setCenterPositionY (Number y)
Number getCenterPositionZ ()
setCenterPositionZ (Number z)
Boolean hasParkPosition ()
Number getParkPositionX ()
setParkPositionX (Number x)
Number getParkPositionY ()
setParkPositionY (Number y)
Number getParkPositionZ ()
setParkPositionZ (Number z)
Integer getNumberExtruders ()
setNumberExtruders (Integer num)
Number | getExtruderOffsetX (Integer extruderNo)
setExtruderOffsetX (Integer extruderNo, Number x)
Number | getExtruderOffsetY (Integer extruderNo)
setExtruderOffsetY (Integer extruderNo, Number y)
Number | getExtruderOffsetZ (Integer extruderNo)
setExtruderOffsetZ (Integer extruderNo, Number z)
String getModel ()
setModel (String model)
String getDescription ()
setDescription (String description)
String getVendor ()
setVendor (String vendor)
String getVendorUrl ()
setVendorUrl (String vendorUrl)
String getControl ()
setControl (String control)
Boolean | isCoolantSupported (Integer coolant)
setCoolantSupported (Integer coolant, Boolean available)
Boolean getRetractOnIndexing ()
setRetractOnIndexing (Boolean retractOnIndexing)
Boolean getShortestAngularRotation ()
setShortestAngularRotation (Boolean shortestAngularRotation)
Boolean isReceived ()
setIsReceived (Boolean received)
Sets m_isReceived. (hidden)

Static Public Member Functions

static Number | getAsSpatial (String text)
static Number | getAsSpatialFeedrate (String text)
static Number | getAsAngularFeedrate (String text)
static Number | getAsWeight (String text)
static Number | getAsPower (String text)
static Number | getAsAngular (String text)
static Number | getAsTime (String text)
static MachineConfiguration | createFromXML (String xml)
static MachineConfiguration | createFromPath (String path)
static String | getStatusDescription (Integer status)

Detailed Description

Machine configuration. This class describes the physical machine to allow mapping from global orientations and positions to machine axis coordinates.

Constructor & Destructor Documentation

◆ MachineConfiguration() [1/4]

MachineConfiguration ( )

Constructs a new 3D machine configuration.

◆ MachineConfiguration() [2/4]

MachineConfiguration ( Axis u )

Constructs a new 4-axis machine configuration.

Parameters
u The U axis.

◆ MachineConfiguration() [3/4]

MachineConfiguration | ( | Axis | u,
 |  | Axis | v
 | ) |  |

Constructs a new 5-axis machine configuration.

Parameters
u | The U axis.
v | The V axis.

◆ MachineConfiguration() [4/4]

MachineConfiguration | ( | Axis | u,
 |  | Axis | v,
 |  | Axis | w
 | ) |  |

Constructs a new 6-axis machine configuration.

Parameters
u | The U axis.
v | The V axis.
w | The W axis.

Member Function Documentation

◆ addAxis()

addAxis ( Axis axis )

Adds the specified axis.

◆ clamp()

Vector clamp ( Vector _abc )

Returns the clamped ABC angles. Disabled coordinates are set to 0.

◆ clampToResolution()

Vector clampToResolution ( Vector _abc )

Returns the clamped ABC angles. Disabled coordinates are set to 0.

◆ createFromPath()

static MachineConfiguration createFromPath ( String path )
static

Loads the machine configuration from the specified path.

◆ createFromXML()

static MachineConfiguration createFromXML ( String xml )
static

Loads the machine configuration from the specified XML.

◆ disableMachineRewinds()

disableMachineRewinds ( )

Disables machine rewinds.

◆ enableMachineRewinds()

enableMachineRewinds ( )

Enables machine rewinds.

◆ getABC()

Vector getABC ( Matrix orientation )

Returns the ABC angles for the specified orientation such that the forward direction is maintained. An extra Z rotation in the local frame is normally required to achieve the desired orientation.

Parameters
orientation The desired orientation.

◆ getABCByDirection()

Vector getABCByDirection ( Vector direction )

Returns the ABC angles for the specified direction. The solution with the least tilt is returned.

Parameters
direction The desired tool direction.

◆ getABCByDirection2()

Vector getABCByDirection2 ( Vector direction )

Returns the secondary ABC angles for the specified direction. Returns the primary solution if the secondary solution does not exist.

Parameters
direction The desired tool direction.

◆ getABCByDirectionBoth()

VectorPair getABCByDirectionBoth ( Vector direction )

Returns the ABC angles for both solutions for the specified direction. Both solutions will be identical when only one solution exists. The first solution is the one with the least tilt.

Parameters
direction The desired tool direction.

◆ getABCByPreference()

Vector getABCByPreference | ( | Matrix | orientation,
 |  | Vector | current,
 |  | Integer | controllingAxis,
 |  | Integer | type,
 |  | Integer | options
 | ) |  |

Returns the preferred ABC angles for the specified orientation such that the forward and optionally right directions are maintained. The preferences are defined in the 'controllingAxis', 'control', and 'options' parameters.

Parameters
orientation | The desired orientation.
current | The current machine angles.
controllingAxis | The axis used to determine the preferred solution. It can be A, B, C for a single axis or ABC to consider all axes.
type | The preference type. PREFER_PREFERENCE - the preference specified in the createAxis definition. PREFER_CLOSEST- the closest solution. PREFER_POSITIVE - a positive angle. Not valid with ABC. PREFER_NEGATIVE - a negative angle. Not valid with ABC. PREFER_CW - axis moves in a clockwise direction. Not valid with ABC. PREFER_CCW - axis moves in a counter-clockwise direction. Not valid with ABC.
options | - Options used to control the ABC selection. ENABLE_NONE - disables all options. ENABLE_RESET - respects the 'reset' parameter in the createAxis definition. ENABLE_WCS - solves for a rotary axis perpendicular to the spindle vector as defined by the tool orientation of the operation. ENABLE_ALL - enables all options (ENABLE_RESET and ENABLE_WCS).

◆ getAdditiveFFF()

Boolean getAdditiveFFF ( )

Returns true if additive fff is supported.

◆ getAsAngular()

static Number getAsAngular ( String text )
static

Returns the angle in the radians.

getAsAngular("180"); // returns Math.PI
getAsAngular("20rad"); // returns 20

◆ getAsAngularFeedrate()

static Number getAsAngularFeedrate ( String text )
static

Returns the angular feed in rad/min.

getAsAngularFeedrate("180deg/min"); // returns Math.PI
getAsAngularFeedrate("20rad/min"); // returns 20

◆ getAsPower()

static Number getAsPower ( String text )
static

Returns the power in W (Watt).

getAsPower("20000W"); // returns 20000
getAsPower("16kW"); // returns 16000
getAsPower("40hp"); // returns 29840

◆ getAsSpatial()

static Number getAsSpatial ( String text )
static

Returns the spatial text in the current unit.

getAsSpatial("10cm");
getAsSpatial("25m");
getAsSpatial("30yd");

◆ getAsSpatialFeedrate()

static Number getAsSpatialFeedrate ( String text )
static

Returns the spatial text in the current unit.

getAsSpatialFeedrate("5mm/min");
getAsSpatialFeedrate("5in/min");

◆ getAsTime()

static Number getAsTime ( String text )
static

Returns the time in the seconds.

getAsTime("30s"); // returns 30
getAsTime("2min"); // returns 180
getAsTime("1h"); // returns 3600

◆ getAsWeight()

static Number getAsWeight ( String text )
static

Returns the weight in kg.

getAsWeight("1g"); // returns 0.001
getAsWeight("10kg"); // returns 10
getAsWeight("25lb"); // returns 11.340

◆ getAxisByCoordinate()

Axis getAxisByCoordinate ( Integer coordinate )

Returns the rotary axis bound to the specified coordinate.

◆ getAxisByName()

Axis getAxisByName ( String name )

Returns the axis by name.

Parameters
name The name of the axis (i.e. "X", "Y", "Z", "U", "V", or "W").

◆ getAxisU()

Axis getAxisU ( )

Returns the U axis.

◆ getAxisV()

Axis getAxisV ( )

Returns the V axis.

◆ getAxisW()

Axis getAxisW ( )

Returns the W axis.

◆ getAxisX()

Axis getAxisX ( )

Returns the X axis.

◆ getAxisY()

Axis getAxisY ( )

Returns the Y axis.

◆ getAxisZ()

Axis getAxisZ ( )

Returns the Z axis.

◆ getCenterPositionX()

Number getCenterPositionX ( )

Returns the X-coordinate center position.

◆ getCenterPositionY()

Number getCenterPositionY ( )

Returns the Y-coordinate center position.

◆ getCenterPositionZ()

Number getCenterPositionZ ( )

Returns the Z-coordinate center position.

◆ getClosestABC()

Vector getClosestABC | ( | Vector | current,
 |  | Vector | abc
 | ) |  |

Returns the current angles closest to the new machine angles. (hidden)

◆ getCollectChuck()

String getCollectChuck ( )

Returns the collect chuck. Tool-holder interface.

◆ getControl()

String getControl ( )

Returns the control.

◆ getCoordinates()

Integer getCoordinates ( )

Returns the bits indicating the machine angle coordinates in use.

Bit 0: coordinate 0 is used. Bit 1: coordinate 1 is used. Bit 2: coordinate 2 is used.

◆ getDepth()

Number getDepth ( )

Returns the width of the machine.

◆ getDescription()

String getDescription ( )

Returns the description.

◆ getDimensions()

Vector getDimensions ( )

Returns the dimensions of the machine as (width, depth, height).

◆ getDirection()

Vector getDirection ( Vector abc )

Returns the direction for the specified ABC angles.

Parameters
abc The machine angles.

◆ getExtruderOffsetX()

Number getExtruderOffsetX ( Integer extruderNo )

Returns the extruder offset X-coordinate.

Parameters
extruderNo The extruder number. The first extruder is number 1.

◆ getExtruderOffsetY()

Number getExtruderOffsetY ( Integer extruderNo )

Returns the extruder offset Y-coordinate.

Parameters
extruderNo The extruder number. The first extruder is number 1.

◆ getExtruderOffsetZ()

Number getExtruderOffsetZ ( Integer extruderNo )

Returns the extruder offset Z-coordinate.

Parameters
extruderNo The extruder number. The first extruder is number 1.

◆ getFeedrateRatio()

Number getFeedrateRatio ( )

Returns the feedrate ratio.

◆ getHeadABC()

Vector getHeadABC ( Vector abc )

Returns the head ABC angles for the specified ABC angles. Ie. non-head axes are set to zero.

Parameters
abc The machine angles.

◆ getHeadOrientation()

Matrix getHeadOrientation ( Vector abc )

Returns the head orientation for the specified ABC angles.

Parameters
abc The machine angles.

◆ getHeight()

Number getHeight ( )

Returns the width of the machine.

◆ getHomePositionX()

Number getHomePositionX ( )

Returns the X-coordinate home position.

◆ getHomePositionY()

Number getHomePositionY ( )

Returns the Y-coordinate home position.

◆ getHomePositionZ()

Number getHomePositionZ ( )

Returns the Z-coordinate home position.

◆ getIndexOfAxisById()

Integer getIndexOfAxisById ( AxisId id )

Returns the order of the given axis. Returns -1 if not found.

◆ getInspection()

Boolean getInspection ( )

Returns true if inspection is supported.

◆ getJet()

Boolean getJet ( )

Returns true if jet is supported (waterjet, laser cutter, and plasma cutter).

◆ getMaximumBlockProcessingSpeed()

Integer getMaximumBlockProcessingSpeed ( )

Returns the maximum block processing speed.

◆ getMaximumCuttingFeedrate()

Number getMaximumCuttingFeedrate ( )

Returns the maximum cutting feedrate.

◆ getMaximumFeedrate()

Number getMaximumFeedrate ( )

Returns the maximum feedrate.

◆ getMaximumSpindlePower()

Number getMaximumSpindlePower ( )

Returns the maximum spindle power.

◆ getMaximumSpindleSpeed()

Number getMaximumSpindleSpeed ( )

Returns the maximum spindle speed.

◆ getMaximumToolDiameter()

Number getMaximumToolDiameter ( )

Returns the maximum tool diameter.

◆ getMaximumToolLength()

Number getMaximumToolLength ( )

Returns the maximum tool length.

◆ getMaximumToolWeight()

Number getMaximumToolWeight ( )

Returns the maximum tool weight.

◆ getMilling()

Boolean getMilling ( )

Returns true if milling is supported.

◆ getModel()

String getModel ( )

Returns the model.

◆ getMultiAxisFeedrateBpwRatio()

Number getMultiAxisFeedrateBpwRatio ( )

Returns the multi-axis feed rate bpw ratio. Raises an exception of the feed mode is not FEED_DPM. See setMultiAxisFeedrate() for description.

Since
45760

◆ getMultiAxisFeedrateDPMType()

Integer getMultiAxisFeedrateDPMType ( )

Returns the multi-axis feedrate DPM sub-type. Returns either DPM_STANDARD or DPM_COMBINATION. Raises an exception of the feedrate mode is not FEED_DPM. See setMultiAxisFeedrate() for description.

Since
45760

◆ getMultiAxisFeedrateInverseTimeUnits()

Integer getMultiAxisFeedrateInverseTimeUnits ( )

Returns the multi-axis feedrate time units. Returns either NVERSE_SECONDS or INVERSE_MINUTES. Raises an exception of the feedrate mode is not FEED_INVERSE_TIME. See setMultiAxisFeedrate() for description.

Since
45760

◆ getMultiAxisFeedrateMaximum()

Number getMultiAxisFeedrateMaximum ( )

Returns the multi-axis maximum feed rate. See setMultiAxisFeedrate() for description.

Since
45760

◆ getMultiAxisFeedrateMode()

Integer getMultiAxisFeedrateMode ( )

Returns the multi-axis feed mode. Returns FEED_INVERSE_TIME, FEED_DPM or FEED_FPM. See setMultiAxisFeedrate() for description.

Since
45760

◆ getMultiAxisFeedrateOutputTolerance()

Number getMultiAxisFeedrateOutputTolerance ( )

Returns the multi-axis feed rate output tolerance. Raises an exception of the feed mode is not FEED_DPM. See setMultiAxisFeedrate() for description.

Since
45760

◆ getNumberExtruders()

Integer getNumberExtruders ( )

Returns the number of extruders.

◆ getNumberOfAxes()

Integer getNumberOfAxes ( )

Returns the total number of axes.

◆ getNumberOfTools()

Integer getNumberOfTools ( )

Returns the maximum number of tools.

◆ getNumberOfWorkOffsets()

Integer getNumberOfWorkOffsets ( )

Returns the number of work offsets.

◆ getOptimizedDirection()

Vector getOptimizedDirection | ( | Vector | direction,
 |  | Vector | currentABC,
 |  | Boolean | reverse,
 |  | Boolean | forceAdjustment
 | ) |  |

Adjusts a vector for the rotary table rotations.

Parameters
direction | Vector to be adjusted.
currentABC | Current rotary axes positions.
reverse | Disabled converts the vector from the part system to the machine system. Enabled to convert the vector from machine system to part system.
forceAdjustment | Set to true if calculation should be done even if axes are not optimized for rotary angles.
Since
45270

◆ getOptimizedHeads()

Vector getOptimizedHeads | ( | Vector | currentXYZ,
 |  | Vector | currentABC,
 |  | Boolean | reverse,
 |  | Integer | optimizeType,
 |  | Boolean | forceAdjustment,
 |  | Boolean | pivotPoint
 | ) |  |

Adjust the tool position for the rotary head rotations.

◆ getOptimizedPosition()

Vector getOptimizedPosition | ( | Vector | currentXYZ,
 |  | Vector | currentABC,
 |  | Integer | tcpType,
 |  | Integer | optimizeType,
 |  | Boolean | forceAdjustment
 | ) |  |

Adjusts the tool position for the rotary table and head rotations based on the defined kinematics of the machine. You can obtain the adjusted coordinates of the tool position based on the optimization of the specified section instead by using the following command.

section.getOptimzedPosition(...)

Parameters
currentXYZ | Current tool end point or XYZ position based on conversion.
currentABC | Current rotary axes positions.
tcpType | Can be one of the following. TCP_XYZ - Converts the tool end point position to the XYZ machine position. currentXYZ should be the tool end point position. TCP_TOOL - Converts the XYZ machine position to tool end point position. currentXYZ should be the XYZ position. TCP_XYZ_OPTIMIZED - Converts the tool end point position to the XYZ machine position. currentXYZ should be based on the input position. TCP_TOOL_OPTIMIZED - Converts the XYZ machine position to tool end point position. currentXYZ should be the input position.
optimizeType | Can be one of the following. OPTIMIZE_BOTH - Converts the position based on both the table and head rotations. OPTIMIZE_TABLES - Converts the position based on table rotations. OPTIMIZE_HEADS - Converts the position based on the head rotations.
forceAdjustment | Set to true if calculation should be done even if axes are not optimized for rotary angles.
Since
45270

◆ getOptimizedTables()

Vector getOptimizedTables | ( | Vector | currentXYZ,
 |  | Vector | currentABC,
 |  | Boolean | reverse,
 |  | Integer | optimizeType,
 |  | Boolean | isVector,
 |  | Boolean | forceAdjustment
 | ) |  |

Adjust the tool position or tool vector for the rotary table rotations. Uses the same arguments as 'getOptimizedPosition' with the addition of 'isVector', when enabled states that 'currentXYZ' is a vector and not an XYZ coordinate.

◆ getOrientation()

Matrix getOrientation ( Vector abc )

Returns the matrix for the specified ABC angles.

Parameters
abc The machine angles.

◆ getOtherABCByDirection()

Vector getOtherABCByDirection ( Vector abc )

Returns the other ABC angles for the specified ABC angles. You should normally use getABCByDirection2() to get the secondary solution directly.

For up to 4 axis machines the return value is always the input ABC angles.

The result is undefined if given invalid ABC angles.

Parameters
abc The abc angles.

◆ getParkPositionX()

Number getParkPositionX ( )

Returns the X-coordinate park position.

◆ getParkPositionY()

Number getParkPositionY ( )

Returns the Y-coordinate park position.

◆ getParkPositionZ()

Number getParkPositionZ ( )

Returns the Z-coordinate park position.

◆ getPartDimensions()

Vector getPartDimensions ( )

Returns the maximum allowed part dimensions.

◆ getPartMaximumX()

Number getPartMaximumX ( )

Returns the width of the machine.

◆ getPartMaximumY()

Number getPartMaximumY ( )

Returns the width of the machine.

◆ getPartMaximumZ()

Number getPartMaximumZ ( )

Returns the width of the machine.

◆ getPosition()

Vector getPosition | ( | Vector | p,
 |  | Vector | abc
 | ) |  |

Returns the position for the specified absolute position and direction. Use getOptimizedPosition() instead to get the rotary axis adjusted position.

Parameters
p | The absolute position.
abc | The machine angles.
Deprecated:

◆ getPreferredABC()

Vector getPreferredABC ( Vector abc )

Returns the preferred ABC angles for the specified ABC angles.

Parameters
abc The abc angles.

◆ getReconfigure()

Boolean getReconfigure ( )

Returns whether machine config allows retract and reconfigure.

Deprecated:
Use performRewinds() instead.

◆ getRemainingOrientation()

Matrix getRemainingOrientation | ( | Vector | abc,
 |  | Matrix | desired
 | ) |  |

Returns the additional rotation required to reach the specified work orientation. For valid machine rotations this will always be a rotation around the Z.

Parameters
abc | The machine angles.
desired | The desired work orientation.

◆ getRetractOnIndexing()

Boolean getRetractOnIndexing ( )

Returns the retract on indexing mode.

◆ getRetractPlane()

Number getRetractPlane ( )

Returns the machine retraction plane coordinate.

◆ getRewindStockExpansion()

Vector getRewindStockExpansion ( )

Returns the stock expansion values used for retracts and rewinds.

◆ getRotationAxis()

Vector getRotationAxis ( Axis axis )

Return rotation axis adjusted for carrier rotations. (hidden)

◆ getSafePlungeFeedrate()

Number getSafePlungeFeedrate ( )

Returns the safe feedrate value used for plunge moves in rewinds.

Since
45790

◆ getSafeRetractDistance()

Number getSafeRetractDistance ( )

Returns the safe distance value for retract moves in rewinds.

Since
45790

◆ getSafeRetractFeedrate()

Number getSafeRetractFeedrate ( )

Returns the safe feedrate value used for retract moves in rewinds.

Since
45790

◆ getShortestAngularRotation()

Boolean getShortestAngularRotation ( )

Returns shortest angular rotation mode.

◆ getSingularityAdjust()

Boolean getSingularityAdjust ( )

Returns true if multi-axis singularity adjustment is enabled. See setSingularity() for description.

Since
41535

◆ getSingularityAngle()

Number getSingularityAngle ( )

Returns the multi-axis singularity angle. See setSingularity() for description. This parameter is in radians.

Since
41535

◆ getSingularityCone()

Number getSingularityCone ( )

Returns the multi-axis singularity cone. See setSingularity() for description. This parameter is in radians.

Since
41535

◆ getSingularityLinearizationTolerance()

Number getSingularityLinearizationTolerance ( )

Returns the multi-axis singularity linearization tolerance. See setMultiAxisSingularity() for description.

Since
41535

◆ getSingularityMethod()

Integer getSingularityMethod ( )

Returns the multi-axis singularity method. See setSingularity() for description.

Since
41535

◆ getSingularityTolerance()

Number getSingularityTolerance ( )

Returns the multi-axis singularity tolerance. See setSingularity() for description.

Since
41535

◆ getSpindleAxis()

Vector getSpindleAxis ( )

Returns the spindle axis without machine rotations.

◆ getSpindleAxisABC()

Vector getSpindleAxisABC ( Vector abc )

Returns the spindle axis for the given ABC machine angles.

◆ getSpindleDescription()

String getSpindleDescription ( )

Returns the spindle description.

◆ getStatusDescription()

static String getStatusDescription ( Integer status )
static

Returns the description for the specified status code.

◆ getTableABC()

Vector getTableABC ( Vector abc )

Returns the table ABC angles for the specified ABC angles. Ie. non-table axes are set to zero.

Parameters
abc The machine angles.

◆ getTableOrientation()

Matrix getTableOrientation ( Vector abc )

Returns the table orientation for the specified ABC angles.

Parameters
abc The machine angles.

◆ getToolChanger()

Boolean getToolChanger ( )

Returns true if an automatic tool changer is available.

◆ getToolChangeTime()

Number getToolChangeTime ( )

Returns the tool change time.

◆ getToolLength()

Number getToolLength ( )

Returns the tool length used for head coordinate adjustments.

◆ getToolPreload()

Boolean getToolPreload ( )

Returns true if a tool preload is supported.

◆ getTurning()

Boolean getTurning ( )

Returns true if turning is supported.

◆ getValidityStatus()

Integer getValidityStatus ( )

Returns a validity status code for the machine configuration. Use getStatusDescription() to convert the status code to an error message.

The following must be true for a configuration to be valid:

  1. X, Y, and Z axes must use coordinate 0, 1, and 2, respectively.
  2. The XYZ axes must be right-oriented orthogonal.
  3. The spindle axis must be non-degenerate.
  4. Axis U, V, and W must be rotational if defined.
  5. Axis V must only be defined if axis U is defined.
  6. Axis W must only be defined if axis V is defined.
  7. A coordinate must not be used by more than one machine axis.
  8. The angular span for any axis must be greater than 0.
  9. The angle between any defined axis must be greater than ~15deg.
  10. For 4-axis machines the angle between the tool axis and the 4th axis must be greater than ~15deg.
Returns
0 is returned for valid configurations.

◆ getVendor()

String getVendor ( )

Returns the vendor.

◆ getVendorUrl()

String getVendorUrl ( )

Returns the vendor url.

◆ getVirtualTooltip()

Boolean getVirtualTooltip ( )

Returns the virtual tool end positioning setting.

◆ getWeight()

Number getWeight ( )

Returns the weight of the machine.

◆ getWeightCapacity()

Number getWeightCapacity ( )

Returns the weight capacity.

◆ getWidth()

Number getWidth ( )

Returns the width of the machine.

◆ getWire()

Boolean getWire ( )

Returns true if wire is supported.

◆ getXML()

String getXML ( )

Returns the XML representation of the machine configuration.

◆ hasCenterPosition()

Boolean hasCenterPosition ( )

Returns true if the machine has a valid center position.

◆ hasHomePositionX()

Boolean hasHomePositionX ( )

Returns true if the X-coordinate of the home position is valid.

◆ hasHomePositionY()

Boolean hasHomePositionY ( )

Returns true if the Y-coordinate of the home position is valid.

◆ hasHomePositionZ()

Boolean hasHomePositionZ ( )

Returns true if the Z-coordinate of the home position is valid.

◆ hasParkPosition()

Boolean hasParkPosition ( )

Returns true if the machine has a valid park position.

◆ is3DConfiguration()

Boolean is3DConfiguration ( )

Returns true if this is a 3D machine configuration (i.e. axis U, V, and W are undefined).

◆ isABCSupported()

Boolean isABCSupported ( Vector _abc )

Returns true if the specified ABC angles are supported. Disabled coordinates are ignored.

◆ isCoolantSupported()

Boolean isCoolantSupported ( Integer coolant )

Returns true if the coolant is supported.

◆ isDirectionSupported()

Boolean isDirectionSupported ( Vector direction )

Returns true if the specified direction is supported by the machine configuration.

Parameters
direction The tool axis direction.

◆ isHeadConfiguration()

Boolean isHeadConfiguration ( )

Returns true if the configuration is a head configuration (i.e. if any axis excluding X, Y, and Z is a head axis).

◆ isMachineAxisRotation()

Boolean isMachineAxisRotation ( Vector abc )

Returns true if the specified rotation A, B, and C rotates around the available machine axes only. That is, the rotation around a non-machine axis must be exactly 0.

Parameters
abc The A, B, and C rotation.

◆ isMachineCoordinate()

Boolean isMachineCoordinate ( Integer coordinate )

Returns true if the specified coordinate is mapped to a machine rotary axis.

By convention coordinate 0, 1, and 2 maps to A, B, and C, respectively.

◆ isMultiAxisConfiguration()

Boolean isMultiAxisConfiguration ( )

Returns true if the configuration is a multi-axis configuration (i.e. if any of the U, V, or W axes are defined).

◆ isReceived()

Boolean isReceived ( )

Returns true if this MachineConfiguration was specified from the CAM system, or a machine file Returns false if the machine configuration was created by the post script.

Since
45765

◆ isSupported()

Boolean isSupported ( )

Returns true if the configuration is valid. See getValidityStatus() for additional information.

◆ isSupportedPosition()

Boolean isSupportedPosition ( Vector position )

Returns true if the specified machine axis position is supported. That is, within any given ranges for the X, Y, and Z axes.

Parameters
position The machine axes position.

◆ isTableConfiguration()

Boolean isTableConfiguration ( )

Returns true if the configuration is a table configuration (i.e. if all axes excluding X, Y, and Z are in the table).

◆ isXYZSupported()

Boolean isXYZSupported ( Vector _xyz )

Returns true if the specified XYZ position is supported. Disabled coordinates are ignored.

◆ performRewinds()

Boolean performRewinds ( )

Returns whether the machine should rewind when needed.

◆ preserveRotaryAtZero()

Vector preserveRotaryAtZero | ( | Vector | currentDirection,
 |  | Vector | previousABC,
 |  | Vector | currentABC
 | ) |  |

Keep secondary angle when tool axis is perpto rotary axis vector. (hidden)

◆ remapABC()

Vector remapABC ( Vector abc )

Maps the specified angles to the preferred ranges. An exception is raised if a requested rotation is not supported for an axis.

Parameters
abc The machine angles.

◆ remapToABC()

Vector remapToABC | ( | Vector | abc,
 |  | Vector | current
 | ) |  |

Maps the specified angles to the current machine angles. An exception is raised if a requested rotation is not supported for an axis. It is assumed that the desired angle difference is less than 180deg always.

Parameters
abc | The machine angles.
current | The current machine angles.

◆ setAdditiveFFF()

setAdditiveFFF ( Boolean additive )

Sets if additive fff is supported.

◆ setCenterPositionX()

setCenterPositionX ( Number x )

Sets the X-coordinate center position. (hidden)

◆ setCenterPositionY()

setCenterPositionY ( Number y )

Sets the Y-coordinate center position. (hidden)

◆ setCenterPositionZ()

setCenterPositionZ ( Number z )

Sets the Z-coordinate center position. (hidden)

◆ setCollectChuck()

setCollectChuck ( String collectChuck )

Sets the collect chuck. Tool-holder interface.

◆ setControl()

setControl ( String control )

Sets the control.

◆ setCoolantSupported()

setCoolantSupported | ( | Integer | coolant,
 |  | Boolean | available
 | ) |  |

Sets if the coolant is supported. Maximum limit is 256. COOLANT_OFF is not allowed.

◆ setDepth()

setDepth ( Number depth )

Sets the depth of the machine.

◆ setDescription()

setDescription ( String description )

Sets the description.

◆ setDimensions()

setDimensions ( Vector dimensions )

Sets the dimensions of the machine as (width, depth, height).

◆ setExtruderOffsetX()

setExtruderOffsetX | ( | Integer | extruderNo,
 |  | Number | x
 | ) |  |

Sets the extruder offset X-coordinate. (hidden)

◆ setExtruderOffsetY()

setExtruderOffsetY | ( | Integer | extruderNo,
 |  | Number | y
 | ) |  |

Sets the extruder offset Y-coordinate. (hidden)

◆ setExtruderOffsetZ()

setExtruderOffsetZ | ( | Integer | extruderNo,
 |  | Number | z
 | ) |  |

Sets the extruder offset Z-coordinate. (hidden)

◆ setFeedrateRatio()

setFeedrateRatio ( Number feedrateRatio )

Sets the feedrate ratio.

◆ setHeight()

setHeight ( Number height )

Sets the height of the machine.

◆ setHomePositionX()

setHomePositionX ( Number x )

Sets the X-coordinate home position.

◆ setHomePositionY()

setHomePositionY ( Number y )

Sets the Y-coordinate home position.

◆ setHomePositionZ()

setHomePositionZ ( Number z )

Sets the Z-coordinate home position.

◆ setInspection()

setInspection ( Boolean inspection )

Sets true if inspection is supported.

◆ setJet()

setJet ( Boolean jet )

Sets if jet is supported (waterjet, laser cutter, and plasma cutter).

◆ setMaximumBlockProcessingSpeed()

setMaximumBlockProcessingSpeed ( Integer maximumBlockProcessingSpeed )

Sets the maximum block processing speed.

◆ setMaximumCuttingFeedrate()

setMaximumCuttingFeedrate ( Number maximumCuttingFeedrate )

Sets the maximum cutting feedrate.

◆ setMaximumFeedrate()

setMaximumFeedrate ( Number maximumFeedrate )

Sets the maximum feedrate.

◆ setMaximumSpindlePower()

setMaximumSpindlePower ( Number maximumSpindlePower )

Sets the maximum spindle power.

◆ setMaximumSpindleSpeed()

setMaximumSpindleSpeed ( Number maximumSpindleSpeed )

Sets the maximum spindle speed.

◆ setMaximumToolDiameter()

setMaximumToolDiameter ( Number maximumToolDiameter )

Sets the maximum tool diameter.

◆ setMaximumToolLength()

setMaximumToolLength ( Number maximumToolLength )

Sets the maximum tool length.

◆ setMaximumToolWeight()

setMaximumToolWeight ( Number maximumToolWeight )

Sets the maximum tool weight.

◆ setMilling()

setMilling ( Boolean milling )

Sets if milling is supported.

◆ setModel()

setModel ( String model )

Sets the model.

◆ setMultiAxisFeedrate()

setMultiAxisFeedrate | ( | Integer | feedMode,
 |  | Number | maximumFeedrate,
 |  | Integer | feedType,
 |  | Number | outputTolerance,
 |  | Number | bpwRatio
 | ) |  |

Sets the multi-axis settings for feed rates

Parameters
feedMode | Can be FEED_INVERSE_TIME, FEED_DPM or FEED_FPM.
maximumFeedrate | The maximum feed rate value.
feedType | Option used for selecting inverse time and DPM options. If FEED_INVERSE_TIME is selected this sets the time units and can be set to INVERSE_SECONDS or INVERSE_MINUTES. If FEED_DPM is selected this sets whether to use standard DPM or a DPM/FPMcombination and can be set to DPM_STANDARD or DPM_COMBINATION.
outputTolerance | The tolerance for deciding whether to output feed rate value or not, only used for FEED_DPM.
bpwRatio | The pulse weight ratio, only used for FEED_DPM.
Since
45610

◆ setNumberExtruders()

setNumberExtruders ( Integer num )

Sets the number of extruders. (hidden)

◆ setNumberOfTools()

setNumberOfTools ( Integer numberOfTools )

Sets the maximum number of tools.

◆ setNumberOfWorkOffsets()

setNumberOfWorkOffsets ( Integer numberOfWorkOffsets )

Sets the number of work offsets.

◆ setParkPositionX()

setParkPositionX ( Number x )

Sets the X-coordinate park position. (hidden)

◆ setParkPositionY()

setParkPositionY ( Number y )

Sets the Y-coordinate park position. (hidden)

◆ setParkPositionZ()

setParkPositionZ ( Number z )

Sets the Z-coordinate park position. (hidden)

◆ setPartDimensions()

setPartDimensions ( Vector partDimensions )

Sets the maximum allowed part dimensions.

◆ setPartMaximumX()

setPartMaximumX ( Number width )

Sets the width of the machine.

◆ setPartMaximumY()

setPartMaximumY ( Number depth )

Sets the depth of the machine.

◆ setPartMaximumZ()

setPartMaximumZ ( Number height )

Sets the height of the machine.

◆ setReconfigure()

setReconfigure ( Boolean enable )

Sets the reconfigure.

Deprecated:
Use enableMachineRewinds() and disableMachineRewinds() instead.

◆ setRetractOnIndexing()

setRetractOnIndexing ( Boolean retractOnIndexing )

Sets the retract on indexing mode.

◆ setRetractPlane()

setRetractPlane ( Number retractPlane )

Sets the machine retraction plane coordinate.

◆ setRewindStockExpansion()

setRewindStockExpansion ( Vector expansion )

Sets the values by which the stock should be expanded when computing retract moves for rewinds.

◆ setSafePlungeFeedrate()

setSafePlungeFeedrate ( Number safePlungeFeedrate )

Sets the safe feedrate value for plunge moves in rewinds.

Since
45790

◆ setSafeRetractDistance()

setSafeRetractDistance ( Number safeRetractDistance )

Sets the safe distance value for retract moves in rewinds.

Since
45790

◆ setSafeRetractFeedrate()

setSafeRetractFeedrate ( Number safeRetractFeedrate )

Sets the safe feedrate value for retract moves in rewinds.

Since
45790

◆ setShortestAngularRotation()

setShortestAngularRotation ( Boolean shortestAngularRotation )

Sets shortest angular rotation mode.

◆ setSingularity()

setSingularity | ( | Boolean | adjust,
 |  | Integer | method,
 |  | Number | cone,
 |  | Number | angle,
 |  | Number | tolerance,
 |  | Number | linearizationTolerance
 | ) |  |

Sets the multi-axis settings specific for handling singularities in the toolpath.

Parameters
adjust | Set to 'true' to enable singularity optimization within the post processor. Singularity optimization includes the ability to adjust the tool axis to minimize singularity issues (large rotary axis movement when the tool axis approaches perpendicularity to a rotary axis) and the linearization of the moves around the singularity to keep the tool end point within tolerance.
method | When set to SINGULARITY_LINEARIZE_OFF it disables the linearization of the moves to keep the tool end point within tolerance of the programmed tool path around the singularity. SINGULARITY_LINEARIZE_ROTARY will linearize the moves around the singularity. Additional points are added to keep the tool within the specified tolerance and is optimized for revolved movement as if the tool were moving around a cylinder or other revolved feature. SINGULARITY_LINEARIZE_LINEAR will also add additional points to keep the tool within tolerance, but will keep the tool end point moving in a straight line.
cone | Specifies the angular distance that the tool axis vector must be within in reference to the singularity point before the singularity logic is activated. This is usually a small value (less than 5 degrees), since the further away the tool axis is from the singularity, the less noticeable the fluctuations in the rotary axes will be and the less benefit this feature will provide. This parameter is in radians.
angle | The minimum angular delta movement that the rotary axes have to move prior to considering adjusting the tool axis vector for singularity optimization. This limit is used to keep from adjusting the tool axis vector when the rotary axes do not fluctuate greatly. This is typically set to a vaule of 10 degrees or more. This parameter is in radians.
tolerance | The tolerance value to used to keep the tool within tolerance when the tool axis is adjusted to minimize rotary axis movement around the singularity.
linearizationTolerance | The tolerance value to use when addtional points are added to keep the tool end point within tolerance of the programmed move when the tool axis is near the singularity.
Since
41535

◆ setSpindleAxis()

setSpindleAxis ( Vector spindleAxis )

Sets the spindle axis without machine rotations. The default is (0, 0, 1).

◆ setSpindleDescription()

setSpindleDescription ( String spindleDescription )

Sets the spindle description.

◆ setToolChanger()

setToolChanger ( Boolean toolChanger )

Sets if an automatic tool changer is available.

◆ setToolChangeTime()

setToolChangeTime ( Number toolChangeTime )

Sets the tool change time.

◆ setToolLength()

setToolLength ( Number toolLength )

Defines the tool length used for head coordinate adjustments.

Parameters
toolLength - The tool length.

◆ setToolPreload()

setToolPreload ( Boolean toolPreload )

Sets the tool preload.

◆ setTurning()

setTurning ( Boolean turning )

Sets if turning is supported.

◆ setVendor()

setVendor ( String vendor )

Sets the vendor.

◆ setVendorUrl()

setVendorUrl ( String vendorUrl )

Sets the vendor url.

◆ setVirtualTooltip()

setVirtualTooltip ( Boolean virtualPositioning )

Defines if the virtual tool end position should be output.

Parameters
virtualPositioning - True if the virtual tool end point position is calculated for head offsets, false if the pivot point is calculated.

◆ setWeight()

setWeight ( Number weight )

Sets the weight of the machine.

◆ setWeightCapacity()

setWeightCapacity ( Number weightCapacity )

Sets the weight capacity.

◆ setWidth()

setWidth ( Number width )

Sets the width of the machine.

◆ setWire()

setWire ( Boolean wire )

Sets if wire is supported.


Member List

MachineConfiguration Member List

This is the complete list of members for MachineConfiguration, including all inherited members.

addAxis(Axis axis) | MachineConfiguration |
clamp(Vector _abc) | MachineConfiguration |
clampToResolution(Vector _abc) | MachineConfiguration |
createFromPath(String path) | MachineConfiguration | static
createFromXML(String xml) | MachineConfiguration | static
disableMachineRewinds() | MachineConfiguration |
enableMachineRewinds() | MachineConfiguration |
getABC(Matrix orientation) | MachineConfiguration |
getABCByDirection(Vector direction) | MachineConfiguration |
getABCByDirection2(Vector direction) | MachineConfiguration |
getABCByDirectionBoth(Vector direction) | MachineConfiguration |
getABCByPreference(Matrix orientation, Vector current, Integer controllingAxis, Integer type, Integer options) | MachineConfiguration |
getAdditiveFFF() | MachineConfiguration |
getAsAngular(String text) | MachineConfiguration | static
getAsAngularFeedrate(String text) | MachineConfiguration | static
getAsPower(String text) | MachineConfiguration | static
getAsSpatial(String text) | MachineConfiguration | static
getAsSpatialFeedrate(String text) | MachineConfiguration | static
getAsTime(String text) | MachineConfiguration | static
getAsWeight(String text) | MachineConfiguration | static
getAxisByCoordinate(Integer coordinate) | MachineConfiguration |
getAxisByName(String name) | MachineConfiguration |
getAxisU() | MachineConfiguration |
getAxisV() | MachineConfiguration |
getAxisW() | MachineConfiguration |
getAxisX() | MachineConfiguration |
getAxisY() | MachineConfiguration |
getAxisZ() | MachineConfiguration |
getCenterPositionX() | MachineConfiguration |
getCenterPositionY() | MachineConfiguration |
getCenterPositionZ() | MachineConfiguration |
getClosestABC(Vector current, Vector abc) | MachineConfiguration |
getCollectChuck() | MachineConfiguration |
getControl() | MachineConfiguration |
getCoordinates() | MachineConfiguration |
getDepth() | MachineConfiguration |
getDescription() | MachineConfiguration |
getDimensions() | MachineConfiguration |
getDirection(Vector abc) | MachineConfiguration |
getExtruderOffsetX(Integer extruderNo) | MachineConfiguration |
getExtruderOffsetY(Integer extruderNo) | MachineConfiguration |
getExtruderOffsetZ(Integer extruderNo) | MachineConfiguration |
getFeedrateRatio() | MachineConfiguration |
getHeadABC(Vector abc) | MachineConfiguration |
getHeadOrientation(Vector abc) | MachineConfiguration |
getHeight() | MachineConfiguration |
getHomePositionX() | MachineConfiguration |
getHomePositionY() | MachineConfiguration |
getHomePositionZ() | MachineConfiguration |
getIndexOfAxisById(AxisId id) | MachineConfiguration |
getInspection() | MachineConfiguration |
getJet() | MachineConfiguration |
getMaximumBlockProcessingSpeed() | MachineConfiguration |
getMaximumCuttingFeedrate() | MachineConfiguration |
getMaximumFeedrate() | MachineConfiguration |
getMaximumSpindlePower() | MachineConfiguration |
getMaximumSpindleSpeed() | MachineConfiguration |
getMaximumToolDiameter() | MachineConfiguration |
getMaximumToolLength() | MachineConfiguration |
getMaximumToolWeight() | MachineConfiguration |
getMilling() | MachineConfiguration |
getModel() | MachineConfiguration |
getMultiAxisFeedrateBpwRatio() | MachineConfiguration |
getMultiAxisFeedrateDPMType() | MachineConfiguration |
getMultiAxisFeedrateInverseTimeUnits() | MachineConfiguration |
getMultiAxisFeedrateMaximum() | MachineConfiguration |
getMultiAxisFeedrateMode() | MachineConfiguration |
getMultiAxisFeedrateOutputTolerance() | MachineConfiguration |
getNumberExtruders() | MachineConfiguration |
getNumberOfAxes() | MachineConfiguration |
getNumberOfTools() | MachineConfiguration |
getNumberOfWorkOffsets() | MachineConfiguration |
getOptimizedDirection(Vector direction, Vector currentABC, Boolean reverse, Boolean forceAdjustment) | MachineConfiguration |
getOptimizedHeads(Vector currentXYZ, Vector currentABC, Boolean reverse, Integer optimizeType, Boolean forceAdjustment, Boolean pivotPoint) | MachineConfiguration |
getOptimizedPosition(Vector currentXYZ, Vector currentABC, Integer tcpType, Integer optimizeType, Boolean forceAdjustment) | MachineConfiguration |
getOptimizedTables(Vector currentXYZ, Vector currentABC, Boolean reverse, Integer optimizeType, Boolean isVector, Boolean forceAdjustment) | MachineConfiguration |
getOrientation(Vector abc) | MachineConfiguration |
getOtherABCByDirection(Vector abc) | MachineConfiguration |
getParkPositionX() | MachineConfiguration |
getParkPositionY() | MachineConfiguration |
getParkPositionZ() | MachineConfiguration |
getPartDimensions() | MachineConfiguration |
getPartMaximumX() | MachineConfiguration |
getPartMaximumY() | MachineConfiguration |
getPartMaximumZ() | MachineConfiguration |
getPosition(Vector p, Vector abc) | MachineConfiguration |
getPreferredABC(Vector abc) | MachineConfiguration |
getReconfigure() | MachineConfiguration |
getRemainingOrientation(Vector abc, Matrix desired) | MachineConfiguration |
getRetractOnIndexing() | MachineConfiguration |
getRetractPlane() | MachineConfiguration |
getRewindStockExpansion() | MachineConfiguration |
getRotationAxis(Axis axis) | MachineConfiguration |
getSafePlungeFeedrate() | MachineConfiguration |
getSafeRetractDistance() | MachineConfiguration |
getSafeRetractFeedrate() | MachineConfiguration |
getShortestAngularRotation() | MachineConfiguration |
getSingularityAdjust() | MachineConfiguration |
getSingularityAngle() | MachineConfiguration |
getSingularityCone() | MachineConfiguration |
getSingularityLinearizationTolerance() | MachineConfiguration |
getSingularityMethod() | MachineConfiguration |
getSingularityTolerance() | MachineConfiguration |
getSpindleAxis() | MachineConfiguration |
getSpindleAxisABC(Vector abc) | MachineConfiguration |
getSpindleDescription() | MachineConfiguration |
getStatusDescription(Integer status) | MachineConfiguration | static
getTableABC(Vector abc) | MachineConfiguration |
getTableOrientation(Vector abc) | MachineConfiguration |
getToolChanger() | MachineConfiguration |
getToolChangeTime() | MachineConfiguration |
getToolLength() | MachineConfiguration |
getToolPreload() | MachineConfiguration |
getTurning() | MachineConfiguration |
getValidityStatus() | MachineConfiguration |
getVendor() | MachineConfiguration |
getVendorUrl() | MachineConfiguration |
getVirtualTooltip() | MachineConfiguration |
getWeight() | MachineConfiguration |
getWeightCapacity() | MachineConfiguration |
getWidth() | MachineConfiguration |
getWire() | MachineConfiguration |
getXML() | MachineConfiguration |
hasCenterPosition() | MachineConfiguration |
hasHomePositionX() | MachineConfiguration |
hasHomePositionY() | MachineConfiguration |
hasHomePositionZ() | MachineConfiguration |
hasParkPosition() | MachineConfiguration |
is3DConfiguration() | MachineConfiguration |
isABCSupported(Vector _abc) | MachineConfiguration |
isCoolantSupported(Integer coolant) | MachineConfiguration |
isDirectionSupported(Vector direction) | MachineConfiguration |
isHeadConfiguration() | MachineConfiguration |
isMachineAxisRotation(Vector abc) | MachineConfiguration |
isMachineCoordinate(Integer coordinate) | MachineConfiguration |
isMultiAxisConfiguration() | MachineConfiguration |
isReceived() | MachineConfiguration |
isSupported() | MachineConfiguration |
isSupportedPosition(Vector position) | MachineConfiguration |
isTableConfiguration() | MachineConfiguration |
isXYZSupported(Vector _xyz) | MachineConfiguration |
MachineConfiguration() | MachineConfiguration |
MachineConfiguration(Axis u) | MachineConfiguration |
MachineConfiguration(Axis u, Axis v) | MachineConfiguration |
MachineConfiguration(Axis u, Axis v, Axis w) | MachineConfiguration |
performRewinds() | MachineConfiguration |
preserveRotaryAtZero(Vector currentDirection, Vector previousABC, Vector currentABC) | MachineConfiguration |
remapABC(Vector abc) | MachineConfiguration |
remapToABC(Vector abc, Vector current) | MachineConfiguration |
setAdditiveFFF(Boolean additive) | MachineConfiguration |
setCenterPositionX(Number x) | MachineConfiguration |
setCenterPositionY(Number y) | MachineConfiguration |
setCenterPositionZ(Number z) | MachineConfiguration |
setCollectChuck(String collectChuck) | MachineConfiguration |
setControl(String control) | MachineConfiguration |
setCoolantSupported(Integer coolant, Boolean available) | MachineConfiguration |
setDepth(Number depth) | MachineConfiguration |
setDescription(String description) | MachineConfiguration |
setDimensions(Vector dimensions) | MachineConfiguration |
setExtruderOffsetX(Integer extruderNo, Number x) | MachineConfiguration |
setExtruderOffsetY(Integer extruderNo, Number y) | MachineConfiguration |
setExtruderOffsetZ(Integer extruderNo, Number z) | MachineConfiguration |
setFeedrateRatio(Number feedrateRatio) | MachineConfiguration |
setHeight(Number height) | MachineConfiguration |
setHomePositionX(Number x) | MachineConfiguration |
setHomePositionY(Number y) | MachineConfiguration |
setHomePositionZ(Number z) | MachineConfiguration |
setInspection(Boolean inspection) | MachineConfiguration |
setIsReceived(Boolean received) | MachineConfiguration |
setJet(Boolean jet) | MachineConfiguration |
setMaximumBlockProcessingSpeed(Integer maximumBlockProcessingSpeed) | MachineConfiguration |
setMaximumCuttingFeedrate(Number maximumCuttingFeedrate) | MachineConfiguration |
setMaximumFeedrate(Number maximumFeedrate) | MachineConfiguration |
setMaximumSpindlePower(Number maximumSpindlePower) | MachineConfiguration |
setMaximumSpindleSpeed(Number maximumSpindleSpeed) | MachineConfiguration |
setMaximumToolDiameter(Number maximumToolDiameter) | MachineConfiguration |
setMaximumToolLength(Number maximumToolLength) | MachineConfiguration |
setMaximumToolWeight(Number maximumToolWeight) | MachineConfiguration |
setMilling(Boolean milling) | MachineConfiguration |
setModel(String model) | MachineConfiguration |
setMultiAxisFeedrate(Integer feedMode, Number maximumFeedrate, Integer feedType, Number outputTolerance, Number bpwRatio) | MachineConfiguration |
setNumberExtruders(Integer num) | MachineConfiguration |
setNumberOfTools(Integer numberOfTools) | MachineConfiguration |
setNumberOfWorkOffsets(Integer numberOfWorkOffsets) | MachineConfiguration |
setParkPositionX(Number x) | MachineConfiguration |
setParkPositionY(Number y) | MachineConfiguration |
setParkPositionZ(Number z) | MachineConfiguration |
setPartDimensions(Vector partDimensions) | MachineConfiguration |
setPartMaximumX(Number width) | MachineConfiguration |
setPartMaximumY(Number depth) | MachineConfiguration |
setPartMaximumZ(Number height) | MachineConfiguration |
setReconfigure(Boolean enable) | MachineConfiguration |
setRetractOnIndexing(Boolean retractOnIndexing) | MachineConfiguration |
setRetractPlane(Number retractPlane) | MachineConfiguration |
setRewindStockExpansion(Vector expansion) | MachineConfiguration |
setSafePlungeFeedrate(Number safePlungeFeedrate) | MachineConfiguration |
setSafeRetractDistance(Number safeRetractDistance) | MachineConfiguration |
setSafeRetractFeedrate(Number safeRetractFeedrate) | MachineConfiguration |
setShortestAngularRotation(Boolean shortestAngularRotation) | MachineConfiguration |
setSingularity(Boolean adjust, Integer method, Number cone, Number angle, Number tolerance, Number linearizationTolerance) | MachineConfiguration |
setSpindleAxis(Vector spindleAxis) | MachineConfiguration |
setSpindleDescription(String spindleDescription) | MachineConfiguration |
setToolChanger(Boolean toolChanger) | MachineConfiguration |
setToolChangeTime(Number toolChangeTime) | MachineConfiguration |
setToolLength(Number toolLength) | MachineConfiguration |
setToolPreload(Boolean toolPreload) | MachineConfiguration |
setTurning(Boolean turning) | MachineConfiguration |
setVendor(String vendor) | MachineConfiguration |
setVendorUrl(String vendorUrl) | MachineConfiguration |
setVirtualTooltip(Boolean virtualPositioning) | MachineConfiguration |
setWeight(Number weight) | MachineConfiguration |
setWeightCapacity(Number weightCapacity) | MachineConfiguration |
setWidth(Number width) | MachineConfiguration |
setWire(Boolean wire) | MachineConfiguration |


MachineParameters Class Reference

Public Attributes

Number spindleOrientation
Number chipBreakingDistance
Number drillingSafeDistance
Number spindleSpeedDwell

Detailed Description

Machine parameters.

Member Data Documentation

◆ chipBreakingDistance

Number chipBreakingDistance

Specifies the distance that the machine will retract to break the chips.

◆ drillingSafeDistance

Number drillingSafeDistance

Specifies the safety distance above the remaining stock for which the machine will rapid down.

◆ spindleOrientation

Number spindleOrientation

Specifies the default spindle orientation for the machine.

◆ spindleSpeedDwell

Number spindleSpeedDwell

Specifies the dwell time in seconds when the spindle speed changes during a drilling cycle.

Since
42225


Member List

MachineParameters Member List

This is the complete list of members for MachineParameters, including all inherited members.

chipBreakingDistance | MachineParameters
drillingSafeDistance | MachineParameters
spindleOrientation | MachineParameters
spindleSpeedDwell | MachineParameters


Mail Class Reference

Inherits ScriptObject.

Public Member Functions

Mail ()
addRecipient (String email)
addRecipient2 (String email, String name)
addCCRecipient (String email)
addCCRecipient2 (String email, String name)
addBCCRecipient (String email)
addBCCRecipient2 (String email, String name)
String getBody ()
setBody (String body)
String getSubject ()
setSubject (String subject)
String getSenderName ()
setSenderName (String senderName)
String getSenderEmail ()
setSenderEmail (String senderEmail)
String getReplyTo ()
setReplyTo (String replyTo)

Detailed Description

Mail.

Security: Requires security level 0.

var mail = new Mail();
mail.addRecipient("to@you.com");
mail.setSenderEmail("from@me.com");
mail.setSubject("Greeting");
mail.setBody("Hello World!");
var smtp = new SMTP("mymailserver");
smtp.send(mail);

Constructor & Destructor Documentation

◆ Mail()

Mail ( )

Constructs a new mail interface.

Member Function Documentation

◆ addBCCRecipient()

addBCCRecipient ( String email )

Adds a BCC recipient.

Parameters
email The mail address.

◆ addBCCRecipient2()

addBCCRecipient2 | ( | String | email,
 |  | String | name
 | ) |  |

Adds a BCC recipient.

Parameters
email | The mail address.
name | The name of the recipient. Can be empty string.

◆ addCCRecipient()

addCCRecipient ( String email )

Adds a CC recipient.

Parameters
email The mail address.

◆ addCCRecipient2()

addCCRecipient2 | ( | String | email,
 |  | String | name
 | ) |  |

Adds a CC recipient.

Parameters
email | The mail address.
name | The name of the recipient. Can be empty string.

◆ addRecipient()

addRecipient ( String email )

Adds a recipient.

Parameters
email The mail address.

◆ addRecipient2()

addRecipient2 | ( | String | email,
 |  | String | name
 | ) |  |

Adds a recipient.

Parameters
email | The mail address.
name | The name of the recipient. Can be empty string.

◆ getBody()

String getBody ( )

Returns the body.

◆ getReplyTo()

String getReplyTo ( )

Returns the reply to address.

◆ getSenderEmail()

String getSenderEmail ( )

Returns the sender mail address.

◆ getSenderName()

String getSenderName ( )

Returns the sender.

◆ getSubject()

String getSubject ( )

Returns the subject.

◆ setBody()

setBody ( String body )

Sets the body.

◆ setReplyTo()

setReplyTo ( String replyTo )

Sets the reply to address.

◆ setSenderEmail()

setSenderEmail ( String senderEmail )

Sets the sender mail address.

◆ setSenderName()

setSenderName ( String senderName )

Sets the sender.

◆ setSubject()

setSubject ( String subject )

Sets the subject.


Member List

Mail Member List

This is the complete list of members for Mail, including all inherited members.

addBCCRecipient(String email) | Mail
addBCCRecipient2(String email, String name) | Mail
addCCRecipient(String email) | Mail
addCCRecipient2(String email, String name) | Mail
addRecipient(String email) | Mail
addRecipient2(String email, String name) | Mail
getBody() | Mail
getReplyTo() | Mail
getSenderEmail() | Mail
getSenderName() | Mail
getSubject() | Mail
Mail() | Mail
setBody(String body) | Mail
setReplyTo(String replyTo) | Mail
setSenderEmail(String senderEmail) | Mail
setSenderName(String senderName) | Mail
setSubject(String subject) | Mail


Map Class Reference

Detailed Description

JavaScript map (e.g. '{a:1, b:2, c:3}').


Math Class Reference

Detailed Description

JavaScript math class.


Matrix Class Reference

Inherits ScriptObject.

Public Types

enum EulerConvention {
EULER_XZX_S, EULER_YXY_S, EULER_ZYZ_S, EULER_XZX_R,
EULER_YXY_R, EULER_ZYZ_R, EULER_XZY_S, EULER_YXZ_S,
EULER_ZYX_S, EULER_YZX_R, EULER_ZXY_R, EULER_XYZ_R,
EULER_XYX_S, EULER_YZY_S, EULER_ZXZ_S, EULER_XYX_R,
EULER_YZY_R, EULER_ZXZ_R, EULER_XYZ_S, EULER_YZX_S,
EULER_ZXY_S, EULER_ZYX_R, EULER_XZY_R, EULER_YXZ_R
}

Public Member Functions

Matrix ()
Matrix (Number scale)
Matrix (Vector right, Vector up, Vector forward)
Matrix (Number m[9])
Matrix (Vector axis, Number angle)
rotateX (Number angle)
rotateY (Number angle)
rotateZ (Number angle)
Number | getElement (Integer row, Integer column)
setElement (Integer row, Integer column, Number value)
Vector | getRow (Integer row)
setRow (Integer row, Vector value)
Vector | getColumn (Integer column)
setColumn (Integer column, Vector value)
Vector getForward ()
setForward (Vector value)
Vector getUp ()
setUp (Vector value)
Vector getRight ()
setRight (Vector value)
Vector | getTiltAndTilt (Integer primary, Integer secondary)
Vector | getTurnAndTilt (Integer primary, Integer secondary)
Vector | getEuler (Integer convention)
Vector | getEuler2 (Integer convention)
Vector getEulerZXZ ()
Vector getEulerZYZ ()
Vector getEulerXYZ ()
Vector getEulerZYX ()
clamp (Number epsilon)
Boolean isZero ()
Boolean isIdentity ()
Number getN1 ()
Number getN2 ()
normalize ()
add (Matrix right)
subtract (Matrix right)
negate ()
Matrix getNegated ()
transpose ()
Matrix getTransposed ()
Matrix multiply (Number right)
Matrix multiply (Matrix right)
Vector multiply (Vector right)
String toString ()

Static Public Member Functions

static Matrix | getAxisRotation (Vector axis, Number angle)
static Matrix | getXRotation (Number angle)
static Matrix | getYRotation (Number angle)
static Matrix | getZRotation (Number angle)
static Matrix | getXYZRotation (Vector abc)
static Matrix | getEulerRotation (Integer convention, Vector angles)
static Matrix | getEulerXZXRotation (Vector angles)
static Matrix | getEulerYXYRotation (Vector angles)
static Matrix | getEulerZYZRotation (Vector angles)
static Matrix | getEulerXZYRotation (Vector angles)
static Matrix | getEulerYXZRotation (Vector angles)
static Matrix | getEulerZYXRotation (Vector angles)
static Matrix | getEulerXYXRotation (Vector angles)
static Matrix | getEulerYZYRotation (Vector angles)
static Matrix | getEulerZXZRotation (Vector angles)
static Matrix | getEulerXYZRotation (Vector angles)
static Matrix | getEulerYZXRotation (Vector angles)
static Matrix | getEulerZXYRotation (Vector angles)
static Matrix | sum (Matrix left, Matrix right)
static Matrix | diff (Matrix left, Matrix right)

Public Attributes

Number n1
The 1-norm.
Number n2
The 2-norm.
Matrix negated
The negated matrix.
Matrix transposed
The transposed matrix (equal to the inverse for rotations).
Vector up
The up vector.
Vector right
The right vector.
Vector forward
The forward vector.
Vector eulerXZX
Euler angles in radians for XZX static/world convention.
Vector eulerYXY
Euler angles in radians for YXY static/world convention.
Vector eulerZYZ
Euler angles in radians for ZYZ static/world convention.
Vector eulerXZX_R
Euler angles in radians for XZX body convention.
Vector eulerYXY_R
Euler angles in radians for YXY body convention.
Vector eulerZYZ_R
Euler angles in radians for ZYZ body convention.
Vector eulerXZY
Euler angles in radians for XZY static/world convention.
Vector eulerYXZ
Euler angles in radians for YXZ static/world convention.
Vector eulerZYX
Euler angles in radians for ZYX static/world convention.
Vector eulerYZX_R
Euler angles in radians for YZX body convention.
Vector eulerZXY_R
Euler angles in radians for ZXY body convention.
Vector eulerXYZ_R
Euler angles in radians for XYZ body convention.
Vector eulerXYX
Euler angles in radians for XYX static/world convention.
Vector eulerYZY
Euler angles in radians for YZY static/world convention.
Vector eulerZXZ
Euler angles in radians for ZXZ static/world convention.
Vector eulerXYX_R
Euler angles in radians for XYX body convention.
Vector eulerYZY_R
Euler angles in radians for YZY body convention.
Vector eulerZXZ_R
Euler angles in radians for ZXZ body convention.
Vector eulerXYZ
Euler angles in radians for XYZ static/world convention.
Vector eulerYZX
Euler angles in radians for YZX static/world convention.
Vector eulerZXY
Euler angles in radians for ZXY static/world convention.
Vector eulerZYX_R
Euler angles in radians for ZYX body convention.
Vector eulerXZY_R
Euler angles in radians for XZY body convention.
Vector eulerYXZ_R
Euler angles in radians for YXZ body convention.

Detailed Description

A 3 by 3 matrix.

Member Enumeration Documentation

◆ EulerConvention

enum EulerConvention

Euler conventions.

Enumerator
EULER_XZX_S | Euler XZX static/world convention.
EULER_YXY_S | Euler YXY static/world convention.
EULER_ZYZ_S | Euler ZYZ static/world convention.
EULER_XZX_R | Euler XZX body convention.
EULER_YXY_R | Euler YXY body convention.
EULER_ZYZ_R | Euler ZYZ body convention.
EULER_XZY_S | Euler XZY static/world convention.
EULER_YXZ_S | Euler YXZ static/world convention.
EULER_ZYX_S | Euler ZYX static/world convention.
EULER_YZX_R | Euler YZX body convention.
EULER_ZXY_R | Euler ZXY body convention.
EULER_XYZ_R | Euler XYZ body convention.
EULER_XYX_S | Euler XYX static/world convention.
EULER_YZY_S | Euler YZY static/world convention.
EULER_ZXZ_S | Euler ZXZ static/world convention.
EULER_XYX_R | Euler XYX body convention.
EULER_YZY_R | Euler YZY body convention.
EULER_ZXZ_R | Euler ZXZ body convention.
EULER_XYZ_S | Euler XYZ static/world convention.
EULER_YZX_S | Euler YZX static/world convention.
EULER_ZXY_S | Euler ZXY static/world convention.
EULER_ZYX_R | Euler ZYX body convention.
EULER_XZY_R | Euler XZY body convention.
EULER_YXZ_R | Euler YXZ body convention.

Constructor & Destructor Documentation

◆ Matrix() [1/5]

Matrix ( )

Construct a matrix as the identity matrix.

◆ Matrix() [2/5]

Matrix ( Number scale )

Construct a matrix as a scaling matrix.

◆ Matrix() [3/5]

Matrix | ( | Vector | right,
 |  | Vector | up,
 |  | Vector | forward
 | ) |  |

Constructs the matrix with the specified right, up, and forward directions.

◆ Matrix() [4/5]

Matrix ( Number m[9] )

Constructs the matrix with the specified elements.

◆ Matrix() [5/5]

Matrix | ( | Vector | axis,
 |  | Number | angle
 | ) |  |

Constructs the matrix as the specified axis rotation.

Parameters
axis | The axis of rotation.
angle | The angle of rotation (radians).
Precondition
axis.getLength() == 1

Member Function Documentation

◆ add()

add ( Matrix right )

Adds the specified matrix to this matrix.

◆ clamp()

clamp ( Number epsilon )

Clamps the matrix elements to -1, 0, and -1 with the specified epsilon value.

◆ diff()

static Matrix diff | ( | Matrix | left,
 |  | Matrix | right
 | ) |  |
static

Returns the difference between the specified matrices.

◆ getAxisRotation()

static Matrix getAxisRotation | ( | Vector | axis,
 |  | Number | angle
 | ) |  |
static

Returns the rotation matrix for the specified axis rotation.

Parameters
axis | The axis of rotation.
angle | The angle (in radians).
Precondition
axis.getLength() == 1

◆ getColumn()

Vector getColumn ( Integer column )

Returns the specified column.

Parameters
column The column [0; 2].

◆ getElement()

Number getElement | ( | Integer | row,
 |  | Integer | column
 | ) |  |

Returns the value of the specified element.

Parameters
row | The row [0; 2].
column | The column [0; 2].

◆ getEuler()

Vector getEuler ( Integer convention )

Returns the Euler angle for the specified convention in radians. Use getEuler2() instead to get the standard Euler conventions.

Deprecated:

◆ getEuler2()

Vector getEuler2 ( Integer convention )

Returns the Euler angle for the specified convention in radians.

Since
r41257

◆ getEulerRotation()

static Matrix getEulerRotation | ( | Integer | convention,
 |  | Vector | angles
 | ) |  |
static

Returns the rotation for the specified Euler angles and convention.

◆ getEulerXYXRotation()

static Matrix getEulerXYXRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (XYX static convention). Angles are in radians.

◆ getEulerXYZ()

Vector getEulerXYZ ( )

Returns the Euler angles (XYZ convention) in radians. Use Matrix.getEuler2() instead.

Deprecated:

◆ getEulerXYZRotation()

static Matrix getEulerXYZRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (XYZ static convention). Angles are in radians.

◆ getEulerXZXRotation()

static Matrix getEulerXZXRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (XZX static convention). Angles are in radians.

◆ getEulerXZYRotation()

static Matrix getEulerXZYRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (XZY static convention). Angles are in radians.

◆ getEulerYXYRotation()

static Matrix getEulerYXYRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (YXY static convention). Angles are in radians.

◆ getEulerYXZRotation()

static Matrix getEulerYXZRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (YXZ static convention). Angles are in radians.

◆ getEulerYZXRotation()

static Matrix getEulerYZXRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (YZX static convention). Angles are in radians.

◆ getEulerYZYRotation()

static Matrix getEulerYZYRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (YZY static convention). Angles are in radians.

◆ getEulerZXYRotation()

static Matrix getEulerZXYRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (ZXY static convention). Angles are in radians.

◆ getEulerZXZ()

Vector getEulerZXZ ( )

Returns the Euler angles (ZXZ convention) in radians. Use Matrix.getEuler2() instead.

Deprecated:

◆ getEulerZXZRotation()

static Matrix getEulerZXZRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (ZXZ static convention). Angles are in radians.

◆ getEulerZYX()

Vector getEulerZYX ( )

Returns the Euler angles (ZYX convention) in radians. Use Matrix.getEuler2() instead.

Deprecated:

◆ getEulerZYXRotation()

static Matrix getEulerZYXRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (ZYX static convention). Angles are in radians.

◆ getEulerZYZ()

Vector getEulerZYZ ( )

Returns the Euler angles (ZYZ convention) in radians. Use Matrix.getEuler2() instead.

Deprecated:

◆ getEulerZYZRotation()

static Matrix getEulerZYZRotation ( Vector angles )
static

Returns the rotation matrix for the specified Euler rotation (ZYZ static convention). Angles are in radians.

◆ getForward()

Vector getForward ( )

Returns the forward vector.

◆ getN1()

Number getN1 ( )

Return N1 of this matrix.

◆ getN2()

Number getN2 ( )

Return N2 of this matrix.

◆ getNegated()

Matrix getNegated ( )

Returns the negated matrix.

◆ getRight()

Vector getRight ( )

Returns the right vector.

◆ getRow()

Vector getRow ( Integer row )

Returns the specified row.

Parameters
row The row [0; 2].

◆ getTiltAndTilt()

Vector getTiltAndTilt | ( | Integer | primary,
 |  | Integer | secondary
 | ) |  |

Returns the X and Y rotations around the fixed frame to match the forward direction. Primary and secondary specifies the preferred rotations and must be different.

Parameters
primary | The primary coordinate (0, or 1).
secondary | The secondary coordinate (0 or 1).

◆ getTransposed()

Matrix getTransposed ( )

Returns the transposed matrix.

◆ getTurnAndTilt()

Vector getTurnAndTilt | ( | Integer | primary,
 |  | Integer | secondary
 | ) |  |

Returns the X, Y, Z rotations around the fixed frame to match the forward direction. Primary and secondary specifies the preferred rotations and must be different.

Parameters
primary | The primary coordinate (0, 1, or 2).
secondary | The secondary coordinate (0, 1, or 2).

◆ getUp()

Vector getUp ( )

Returns the up vector.

◆ getXRotation()

static Matrix getXRotation ( Number angle )
static

Returns the matrix for the specified X-axis rotation. The matrix will rotate the vector and not the frame.

Parameters
angle The rotation angle in radians.

◆ getXYZRotation()

static Matrix getXYZRotation ( Vector abc )
static

Returns the matrix for the specified X, Y, and Z rotations. The matrix will rotate the vector and not the frame. The order of the rotations are X, Y, and then Z.

Parameters
abc The rotation XYZ angles in radians.

◆ getYRotation()

static Matrix getYRotation ( Number angle )
static

Returns the matrix for the specified Y-axis rotation. The matrix will rotate the vector and not the frame.

Parameters
angle The rotation angle in radians.

◆ getZRotation()

static Matrix getZRotation ( Number angle )
static

Returns the matrix for the specified Z-axis rotation. The matrix will rotate the vector and not the frame.

Parameters
angle The rotation angle in radians.

◆ isIdentity()

Boolean isIdentity ( )

Returns true if the matrix is the identity matrix.

◆ isZero()

Boolean isZero ( )

Returns true if the matrix is the zero matrix (i.e. all elements are set to 0).

◆ multiply() [1/3]

Matrix multiply ( Number right )

Returns the multiple of this matrix (left) and the specified value (right).

◆ multiply() [2/3]

Matrix multiply ( Matrix right )

Returns the multiple of this matrix (left) and the specified matrix (right).

◆ multiply() [3/3]

Vector multiply ( Vector right )

Returns the multiple of this matrix (left) and the specified vector (right).

◆ negate()

negate ( )

Negates this matrix.

◆ normalize()

normalize ( )

Normalizes the orientation.

◆ rotateX()

rotateX ( Number angle )

Rotates this matrix around the X-axis by the specified angle.

Parameters
angle The rotation angle in radians.

◆ rotateY()

rotateY ( Number angle )

Rotates this matrix around the Y-axis by the specified angle.

Parameters
angle The rotation angle in radians.

◆ rotateZ()

rotateZ ( Number angle )

Rotates this matrix around the Z-axis by the specified angle.

Parameters
angle The rotation angle in radians.

◆ setColumn()

setColumn | ( | Integer | column,
 |  | Vector | value
 | ) |  |

Sets the specified column.

Parameters
column | The column [0; 2].
value | The desired column vector.

◆ setElement()

setElement | ( | Integer | row,
 |  | Integer | column,
 |  | Number | value
 | ) |  |

Sets the value of the specified element.

Parameters
row | The row [0; 2].
column | The column [0; 2].
value | The desired value of the element.

◆ setForward()

setForward ( Vector value )

Sets the forward vector.

Parameters
value The forward vector.

◆ setRight()

setRight ( Vector value )

Sets the right vector.

Parameters
value The right vector.

◆ setRow()

setRow | ( | Integer | row,
 |  | Vector | value
 | ) |  |

Sets the specified row.

Parameters
row | The row [0; 2].
value | The desired row vector.

◆ setUp()

setUp ( Vector value )

Sets the up vector.

Parameters
value The up vector.

◆ subtract()

subtract ( Matrix right )

Subtracts the specified matrix from this matrix.

◆ sum()

static Matrix sum | ( | Matrix | left,
 |  | Matrix | right
 | ) |  |
static

Returns the difference between the specified matrices.

◆ toString()

String toString ( )

Converts the matrix to a string (e.g. [[1, 2, 3], [4, 5, 6], [7, 8, 9]]).

◆ transpose()

transpose ( )

Transposed this matrix.


Member List

Matrix Member List

This is the complete list of members for Matrix, including all inherited members.

add(Matrix right) | Matrix |
clamp(Number epsilon) | Matrix |
diff(Matrix left, Matrix right) | Matrix | static
EULER_XYX_R enum value | Matrix |
EULER_XYX_S enum value | Matrix |
EULER_XYZ_R enum value | Matrix |
EULER_XYZ_S enum value | Matrix |
EULER_XZX_R enum value | Matrix |
EULER_XZX_S enum value | Matrix |
EULER_XZY_R enum value | Matrix |
EULER_XZY_S enum value | Matrix |
EULER_YXY_R enum value | Matrix |
EULER_YXY_S enum value | Matrix |
EULER_YXZ_R enum value | Matrix |
EULER_YXZ_S enum value | Matrix |
EULER_YZX_R enum value | Matrix |
EULER_YZX_S enum value | Matrix |
EULER_YZY_R enum value | Matrix |
EULER_YZY_S enum value | Matrix |
EULER_ZXY_R enum value | Matrix |
EULER_ZXY_S enum value | Matrix |
EULER_ZXZ_R enum value | Matrix |
EULER_ZXZ_S enum value | Matrix |
EULER_ZYX_R enum value | Matrix |
EULER_ZYX_S enum value | Matrix |
EULER_ZYZ_R enum value | Matrix |
EULER_ZYZ_S enum value | Matrix |
EulerConvention enum name | Matrix |
eulerXYX | Matrix |
eulerXYX_R | Matrix |
eulerXYZ | Matrix |
eulerXYZ_R | Matrix |
eulerXZX | Matrix |
eulerXZX_R | Matrix |
eulerXZY | Matrix |
eulerXZY_R | Matrix |
eulerYXY | Matrix |
eulerYXY_R | Matrix |
eulerYXZ | Matrix |
eulerYXZ_R | Matrix |
eulerYZX | Matrix |
eulerYZX_R | Matrix |
eulerYZY | Matrix |
eulerYZY_R | Matrix |
eulerZXY | Matrix |
eulerZXY_R | Matrix |
eulerZXZ | Matrix |
eulerZXZ_R | Matrix |
eulerZYX | Matrix |
eulerZYX_R | Matrix |
eulerZYZ | Matrix |
eulerZYZ_R | Matrix |
forward | Matrix |
getAxisRotation(Vector axis, Number angle) | Matrix | static
getColumn(Integer column) | Matrix |
getElement(Integer row, Integer column) | Matrix |
getEuler(Integer convention) | Matrix |
getEuler2(Integer convention) | Matrix |
getEulerRotation(Integer convention, Vector angles) | Matrix | static
getEulerXYXRotation(Vector angles) | Matrix | static
getEulerXYZ() | Matrix |
getEulerXYZRotation(Vector angles) | Matrix | static
getEulerXZXRotation(Vector angles) | Matrix | static
getEulerXZYRotation(Vector angles) | Matrix | static
getEulerYXYRotation(Vector angles) | Matrix | static
getEulerYXZRotation(Vector angles) | Matrix | static
getEulerYZXRotation(Vector angles) | Matrix | static
getEulerYZYRotation(Vector angles) | Matrix | static
getEulerZXYRotation(Vector angles) | Matrix | static
getEulerZXZ() | Matrix |
getEulerZXZRotation(Vector angles) | Matrix | static
getEulerZYX() | Matrix |
getEulerZYXRotation(Vector angles) | Matrix | static
getEulerZYZ() | Matrix |
getEulerZYZRotation(Vector angles) | Matrix | static
getForward() | Matrix |
getN1() | Matrix |
getN2() | Matrix |
getNegated() | Matrix |
getRight() | Matrix |
getRow(Integer row) | Matrix |
getTiltAndTilt(Integer primary, Integer secondary) | Matrix |
getTransposed() | Matrix |
getTurnAndTilt(Integer primary, Integer secondary) | Matrix |
getUp() | Matrix |
getXRotation(Number angle) | Matrix | static
getXYZRotation(Vector abc) | Matrix | static
getYRotation(Number angle) | Matrix | static
getZRotation(Number angle) | Matrix | static
isIdentity() | Matrix |
isZero() | Matrix |
Matrix() | Matrix |
Matrix(Number scale) | Matrix |
Matrix(Vector right, Vector up, Vector forward) | Matrix |
Matrix(Number m[9]) | Matrix |
Matrix(Vector axis, Number angle) | Matrix |
multiply(Number right) | Matrix |
multiply(Matrix right) | Matrix |
multiply(Vector right) | Matrix |
n1 | Matrix |
n2 | Matrix |
negate() | Matrix |
negated | Matrix |
normalize() | Matrix |
right | Matrix |
rotateX(Number angle) | Matrix |
rotateY(Number angle) | Matrix |
rotateZ(Number angle) | Matrix |
setColumn(Integer column, Vector value) | Matrix |
setElement(Integer row, Integer column, Number value) | Matrix |
setForward(Vector value) | Matrix |
setRight(Vector value) | Matrix |
setRow(Integer row, Vector value) | Matrix |
setUp(Vector value) | Matrix |
subtract(Matrix right) | Matrix |
sum(Matrix left, Matrix right) | Matrix | static
toString() | Matrix |
transpose() | Matrix |
transposed | Matrix |
up | Matrix |


Mesh Class Reference

Inherits ScriptObject.

Public Member Functions

Mesh ()
reserve (Integer numberOfFacets)
Integer getNumberOfVertices ()
Vector | getVertex (Integer index)
Integer getNumberOfFacets ()
Integer | getFacet (Integer index, Integer node)
clear ()
addFacet (Vector a, Vector b, Vector c)
scale (Number factor)
translate (Vector translation)
transform (Vector translation, Matrix orientation)
BoundingBox getBoundingBox ()

Static Public Member Functions

static Mesh | loadMesh (String path, String format)
static | saveMesh (String path, String format, Mesh mesh)

Detailed Description

A mesh.

Since
42020

Constructor & Destructor Documentation

◆ Mesh()

Mesh ( )

Constructs an empty mesh.

Member Function Documentation

◆ addFacet()

addFacet | ( | Vector | a,
 |  | Vector | b,
 |  | Vector | c
 | ) |  |

Adds facet. It is good convention to keep all facets CCW-wound (use the right hand rule).

Parameters
a | Vertex.
b | Vertex.
c | Vertex.

◆ clear()

clear ( )

Clears the mesh.

◆ getBoundingBox()

BoundingBox getBoundingBox ( )

Returns the bounding box of the mesh.

◆ getFacet()

Integer getFacet | ( | Integer | index,
 |  | Integer | node
 | ) |  |

Returns the given facet vertex index for the returned node.

Parameters
index | The index of the facet.
node | The node of the facet (0, 1, 2).

◆ getNumberOfFacets()

Integer getNumberOfFacets ( )

Returns the number of facets in the mesh.

◆ getNumberOfVertices()

Integer getNumberOfVertices ( )

Returns the number of vertices.

◆ getVertex()

Vector getVertex ( Integer index )

Returns the given vertex.

◆ loadMesh()

static Mesh loadMesh | ( | String | path,
 |  | String | format
 | ) |  |
static

Load mesh from file.

Parameters
path | The file path.
format | The file format. The format can be 'application/sla' or 'ascii-stl'.

◆ reserve()

reserve ( Integer numberOfFacets )

Reserves memory for the given number of facets.

◆ saveMesh()

static saveMesh | ( | String | path,
 |  | String | format,
 |  | Mesh | mesh
 | ) |  |
static

Save mesh to file.

Parameters
path | The file path.
format | The file format. The format can be 'application/sla' or 'ascii-stl'.
mesh | The mesh.

◆ scale()

scale ( Number factor )

Scales mesh.

Parameters
factor The factor used to scale all vertices.

◆ transform()

transform | ( | Vector | translation,
 |  | Matrix | orientation
 | ) |  |

Transforms mesh. new vertex = ORIENTATION * vertex + TRANSLATION

Parameters
translation | The translation for all vertices.
orientation | The orientation for all vertices.

◆ translate()

translate ( Vector translation )

Translates mesh.

Parameters
translation The translation for all vertices.


Member List

Mesh Member List

This is the complete list of members for Mesh, including all inherited members.

addFacet(Vector a, Vector b, Vector c) | Mesh |
clear() | Mesh |
getBoundingBox() | Mesh |
getFacet(Integer index, Integer node) | Mesh |
getNumberOfFacets() | Mesh |
getNumberOfVertices() | Mesh |
getVertex(Integer index) | Mesh |
loadMesh(String path, String format) | Mesh | static
Mesh() | Mesh |
reserve(Integer numberOfFacets) | Mesh |
saveMesh(String path, String format, Mesh mesh) | Mesh | static
scale(Number factor) | Mesh |
transform(Vector translation, Matrix orientation) | Mesh |
translate(Vector translation) | Mesh |


Modal Class Reference

Public Member Functions

Modal (Map specifiers, Format format)
String format (Value value)
Value getPrefix ()
setPrefix (Value prefix)
Value getSuffix ()
setSuffix (Value suffix)
reset ()
Value getCurrent ()

Detailed Description

A modal unformatted variable. State is maintained to avoid output for unchanged values.

var gModal = createModal({prefix: "G"}); // note space before 'G'
var str1 = gModal.format(4); // returns "G4"
var str2 = gModal.format(4); // returns ""
var str3 = gModal.format(1); // returns "G1"

Constructor & Destructor Documentation

◆ Modal()

Modal | ( | Map | specifiers,
 |  | Format | format
 | ) |  |

Constructs a modal variable.

Parameters
specifiers | The format specifiers.
format | The desired format (optional).

The supported specifiers are:

  1. prefix: Specifies the prefix.
  2. suffix: Specifies the suffix.
  3. force: Specifies that the value must always be returned.

Member Function Documentation

◆ format()

String format ( Value value )

Returns the corresponding string.

If the value is identical to the last value then the empty string is returned unless the force specifier has been set to true.

Parameters
value The value. This must be of type Number if a format has been specified.

◆ getCurrent()

Value getCurrent ( )

Returns the last formatted value.

◆ getPrefix()

Value getPrefix ( )

Returns the prefix.

◆ getSuffix()

Value getSuffix ( )

Returns the suffix.

◆ reset()

reset ( )

Invoke to force output of value on the next invocation of format(). reset() has no effect if force has been set to true.

◆ setPrefix()

setPrefix ( Value prefix )

Sets the prefix.

◆ setSuffix()

setSuffix ( Value suffix )

Sets the suffix.


Member List

Modal Member List

This is the complete list of members for Modal, including all inherited members.

format(Value value) | Modal
getCurrent() | Modal
getPrefix() | Modal
getSuffix() | Modal
Modal(Map specifiers, Format format) | Modal
reset() | Modal
setPrefix(Value prefix) | Modal
setSuffix(Value suffix) | Modal


ModalGroup Class Reference

Inherits ScriptObject.

Public Member Functions

ModalGroup ()
setStrict (Boolean strict)
setAutoReset (Boolean autoreset)
setLogUndefined (Boolean logundefined)
Integer getNumberOfGroups ()
Integer getNumberOfCodes ()
Integer | getNumberOfCodesInGroup (Integer group)
Boolean | isCodeDefined (Integer code)
Boolean | isActiveCode (Integer code)
makeActiveCode (Integer code)
Integer | getActiveCode (Integer group)
Boolean | hasActiveCode (Integer group)
reset ()
Integer | resetGroup (Integer group)
Integer createGroup ()
removeCode (Integer code)
addCode (Integer group, Integer code)
Boolean | isGroup (Integer group)
Integer | getGroup (Integer code)
Boolean | inSameGroup (Integer a, Integer b)
Boolean isEnabled ()
enable ()
disable ()
setForce (Boolean force)
setFormatNumber (FormatNumber formatNumber)
setPrefix (String prefix)
setSuffix (String suffix)
String | format (Integer code)

Detailed Description

A modal group.

Use createModalGroup() to construct the object.

var gFormat = createFormat({width:2, zeropad:true, decimals:0, prefix:"G"});
var gModal = createModalGroup(
{strict: false},
[
[[0, 1, 2, 3], interval(80, 89)], // motion
[20, 21], // unit
[90, 91] // absolute/relative
],
gFormat
);
gModal.format(90); // returns "G90"
gModal.format(0); // returns "G00"
gModal.format(0); // returns ""
gModal.format(1); // returns "G01"
gModal.format(90); // returns ""
gModal.format(91); // returns "G91"
gModal.format(1); // returns ""

Constructor & Destructor Documentation

◆ ModalGroup()

ModalGroup ( )

Construct a new modal group.

Member Function Documentation

◆ addCode()

addCode | ( | Integer | group,
 |  | Integer | code
 | ) |  |

Adds the specified code to the given group.

Parameters
group | The group.
code | The code.

◆ createGroup()

Integer createGroup ( )

Creates a new group.

◆ disable()

disable ( )

Disables the output.

◆ enable()

enable ( )

Enables the output.

◆ format()

String format ( Integer code )

Returns the formatted code.

Code must be defined in strict mode. If code is not defined in non-strict mode than the codes is output always.

◆ getActiveCode()

Integer getActiveCode ( Integer group )

Returns the active code in the specified group.

◆ getGroup()

Integer getGroup ( Integer code )

Returns the group id for the specified code.

Returns
Returns 0 if unknown id.

◆ getNumberOfCodes()

Integer getNumberOfCodes ( )

Returns the total number of defined codes.

◆ getNumberOfCodesInGroup()

Integer getNumberOfCodesInGroup ( Integer group )

Returns the number of codes in the specified group.

◆ getNumberOfGroups()

Integer getNumberOfGroups ( )

Returns the number of groups.

◆ hasActiveCode()

Boolean hasActiveCode ( Integer group )

Returns true if the specified group has an active code.

◆ inSameGroup()

Boolean inSameGroup | ( | Integer | a,
 |  | Integer | b
 | ) |  |

Returns true if the specified codes are in the same group.

Returns
Returns false is either code is unknown.

◆ isActiveCode()

Boolean isActiveCode ( Integer code )

Returns true if the specified code is active within its group.

◆ isCodeDefined()

Boolean isCodeDefined ( Integer code )

Returns true if the specified code is defined.

◆ isEnabled()

Boolean isEnabled ( )

Returns true if enabled.

◆ isGroup()

Boolean isGroup ( Integer group )

Returns true if the specified group is a valid group.

◆ makeActiveCode()

makeActiveCode ( Integer code )

Marks the specified code as active within its group.

◆ removeCode()

removeCode ( Integer code )

Removes the specified code.

Parameters
code The code.

◆ reset()

reset ( )

Resets all groups.

◆ resetGroup()

Integer resetGroup ( Integer group )

Resets the specified group.

Parameters
group The group.
Returns
Returns the active code. Returns -1 if no code is active.

◆ setAutoReset()

setAutoReset ( Boolean autoreset )

Sets the auto-reset mode. All groups are reset if an undefined code is output. Only appplies in non-strict mode.

◆ setForce()

setForce ( Boolean force )

Sets the force mode.

◆ setFormatNumber()

setFormatNumber ( FormatNumber formatNumber )

Sets the format.

◆ setLogUndefined()

setLogUndefined ( Boolean logundefined )

Enables output of for use of undefined codes. Only on the first usage.

◆ setPrefix()

setPrefix ( String prefix )

Sets the prefix.

◆ setStrict()

setStrict ( Boolean strict )

Sets the strict mode.

◆ setSuffix()

setSuffix ( String suffix )

Sets the suffix.


Member List

ModalGroup Member List

This is the complete list of members for ModalGroup, including all inherited members.

addCode(Integer group, Integer code) | ModalGroup
createGroup() | ModalGroup
disable() | ModalGroup
enable() | ModalGroup
format(Integer code) | ModalGroup
getActiveCode(Integer group) | ModalGroup
getGroup(Integer code) | ModalGroup
getNumberOfCodes() | ModalGroup
getNumberOfCodesInGroup(Integer group) | ModalGroup
getNumberOfGroups() | ModalGroup
hasActiveCode(Integer group) | ModalGroup
inSameGroup(Integer a, Integer b) | ModalGroup
isActiveCode(Integer code) | ModalGroup
isCodeDefined(Integer code) | ModalGroup
isEnabled() | ModalGroup
isGroup(Integer group) | ModalGroup
makeActiveCode(Integer code) | ModalGroup
ModalGroup() | ModalGroup
removeCode(Integer code) | ModalGroup
reset() | ModalGroup
resetGroup(Integer group) | ModalGroup
setAutoReset(Boolean autoreset) | ModalGroup
setForce(Boolean force) | ModalGroup
setFormatNumber(FormatNumber formatNumber) | ModalGroup
setLogUndefined(Boolean logundefined) | ModalGroup
setPrefix(String prefix) | ModalGroup
setStrict(Boolean strict) | ModalGroup
setSuffix(String suffix) | ModalGroup


MoveLength Class Reference

Inherits ScriptObject.

Public Member Functions

Number getLinearMoveLength ()
Number getRadialMoveLength ()
Number getRadialToolTipMoveLength ()

Public Attributes

Number linear
The length of the movement of the linear axes.
Number radial
The length of the movement of the rotary axes.
Number radialToolTip
The length of the rotary component of the tool tip movement.

Detailed Description

A group of lengths associated with a multi-axis move.

Member Function Documentation

◆ getLinearMoveLength()

Number getLinearMoveLength ( )

Gets the length of the movement of the linear axes.

◆ getRadialMoveLength()

Number getRadialMoveLength ( )

Gets the length of the movement of the rotary axes.

◆ getRadialToolTipMoveLength()

Number getRadialToolTipMoveLength ( )

Gets the length of the rotary component of the tool tip movement.


Member List

MoveLength Member List

This is the complete list of members for MoveLength, including all inherited members.

getLinearMoveLength() | MoveLength
getRadialMoveLength() | MoveLength
getRadialToolTipMoveLength() | MoveLength
linear | MoveLength
radial | MoveLength
radialToolTip | MoveLength


Number Class Reference

Detailed Description

JavaScript number.


PostProcessor Class Reference

Inherits ScriptObject.

Public Member Functions

PostProcessor ()
MachineConfiguration getMachineConfiguration ()
setMachineConfiguration (MachineConfiguration machine)
MoveLength | getMultiAxisMoveLength (Number x, Number y, Number z, Number a, Number b, Number c)
optimizeMachineAngles ()
optimizeMachineAngles2 (Integer optimizeType)
optimizeMachineAnglesByMachine (MachineConfiguration machine, Integer optimizeType)
Boolean | isSectionSpecialCycle (String uri)
setSectionSpecialCycle (String uri, Boolean specialCycle)
String getProduct ()
String getProductUri ()
String getProductUrl ()
String getVendor ()
String getVendorUrl ()
String getVersion ()
openUrl (String url)
Boolean | printDocument (String path)
Boolean | printDocumentTo (String path, String printerName)
ToolRenderer createToolRenderer ()
Boolean | invokeOnRapid (Number x, Number y, Number z)
Boolean | invokeOnRapid5D (Number x, Number y, Number z, Number dx, Number dy, Number dz)
Boolean | invokeOnLinear (Number x, Number y, Number z, Number feedrate)
Boolean | invokeOnLinear5D (Number x, Number y, Number z, Number dx, Number dy, Number dz, Number feedrate)
Boolean | invokeOnCircular (Boolean clockwise, Number cx, Number cy, Number cz, Number x, Number y, Number z, Number nx, Number ny, Number nz, Number feedrate)
VectorPair | activatePolarMode (Number tolerance, Number currentAngle, Vector polarDirection)
deactivatePolarMode ()
Boolean isPolarModeActive ()
VectorPair | getPolarPosition (Number x, Number y, Number z)
setCurrentPositionAndDirection (VectorPair posDir)
setExitCode (Integer code)
error (String message)
warning (String message)
warningOnce (String &message, Integer id)
log (String message)
String getCurrentNCLocation ()
Integer getSystemUnit ()
String getPlatform ()
Boolean | hasSymbol (Integer symbol)
Boolean | isTextSupported (String text)
Integer getCodePage ()
setCodePage (String name)
write (String message)
writeln (String message)
String getWordSeparator ()
setWordSeparator (String message)
writeWords (String message,...)
writeWords2 (String message,...)
String | formatWords (String message)
String | subst (String message,...)
String getLangId ()
Boolean | isSupportedText (String &message)
String | localize (String message)
String | localize2 (String section, String message)
Boolean | loadLocale (String langId)
include (String path)
String | findFile (String path)
String getHeader ()
String getHeaderVersion ()
String getHeaderCommit ()
String getHeaderDate ()
Date getHeaderDate2 ()
String | getHeaderSnippet (String keyword)
String getIntermediatePath ()
String getOutputPath ()
String getConfigurationFolder ()
String getConfigurationPath ()
String getPostProcessorFolder ()
String getPostProcessorPath ()
String getCascadingPath ()
setCascadingPath (String)
Integer getSecurityLevel ()
exportNCAs (String path, String format)
Integer | execute (String path, String arguments, Boolean hide, String workingFolder)
executeNoWait (String path, String arguments, Boolean hide, String workingFolder)
setEOL (String eol)
Boolean isRedirecting ()
closeRedirection ()
redirectToFile (String path)
redirectToBuffer ()
String getRedirectionBuffer ()
String | getRedirectionBuffer2 (Boolean clear)
registerPostProcessing (String path)
BoundingBox getWorkpiece ()
BoundingBox getFixture ()
String getMachineConfigurations ()
MachineConfiguration | getMachineConfigurationByName (String name)
MachineConfiguration | loadMachineConfiguration (String path)
Boolean isInteractionAllowed ()
alert (String title, String description)
String | promptKey (String title, String description)
String | promptKey2 (String title, String description, String accept)
String | promptKey3 (String title, String description, String accept, String keys)
String | promptText (String title, String description)
Integer | getAsInt (String text)
Number | getAsFloat (String text)
Boolean | isSafeText (String text, String permitted)
String | filterText (String text, String keep)
String | translateText (String text, String src, String dest)
String | loadText (String url, String encoding)
Integer getOutputUnit ()
setOutputUnit (Integer unit)
Boolean getDogLeg ()
setDogLeg (Boolean dogLeg)
Matrix getRotation ()
setRotation (Matrix rotation)
cancelRotation ()
Vector getTranslation ()
cancelTransformation ()
setTranslation (Vector translation)
cancelTranslation ()
Vector | getFramePosition (Vector position)
Vector | getFrameDirection (Vector direction)
Vector | getSectionFramePosition (Vector framePosition)
Vector | getSectionFrameDirection (Vector frameDirection)
Integer getHighFeedMapping ()
setHighFeedMapping (Integer mode)
Number getHighFeedrate ()
setHighFeedrate (Number feedrate)
Vector | getGlobalPosition (Vector p)
Vector | getWCSPosition (Vector p)
Vector | getSectionPosition (Vector p)
Vector getCurrentGlobalPosition ()
Vector getCurrentPosition ()
setCurrentPosition (Vector currentPosition)
setCurrentPositionX (Number x)
setCurrentPositionY (Number y)
setCurrentPositionZ (Number z)
Vector getCurrentDirection ()
setCurrentDirection (Vector currentDirection)
Number getCurrentSpindleSpeed ()
setCurrentSpindleSpeed (Number spindleSpeed)
setCurrentABC (Vector abc)
skipRemainingSection ()
Boolean isClockwiseSpindleDirection ()
Boolean isSpindleActive ()
Boolean isCoolantActive ()
Boolean | isProbeOperation (Section section)
Boolean | isInspectionOperation (Section section)
Boolean | isDepositionOperation (Section section)
Boolean | isDrillingCycle (Section section, Boolean checkBoringCycles)
Boolean | isTappingCycle (Section section)
Boolean | isAxialCenterDrilling (Section section, Boolean checkLiveTool)
Boolean | isMillingCycle (Section section, Boolean checkBoringCycles)
Boolean isSpeedFeedSynchronizationActive ()
Boolean is3D ()
Boolean isMultiAxis ()
Boolean isMultiChannelProgram ()
Integer getNumberOfChannels ()
Integer getCurrentChannel ()
Integer | getNumberOfSyncGroups (Integer channel)
Integer getCurrentSyncGroup ()
Integer getNumberOfRecords ()
Record | getRecord (Integer id)
Integer getCurrentSectionId ()
Integer getNumberOfSections ()
Section | getSection (Integer index)
Section getPreviousSection ()
Boolean hasNextSection ()
Section getNextSection ()
ToolTable getToolTable ()
writeToolTable (Integer orderBy)
Integer getCurrentRecordId ()
Number getMachiningDistance (Integer tool)
Boolean isExpanding ()
Vector getEnd ()
Vector getDirection ()
Number getLength ()
Vector getCircularCenter ()
Number getCircularStartRadius ()
Number getCircularRadius ()
Number getCircularSweep ()
Number getCircularChordLength ()
Boolean isClockwise ()
Boolean isFullCircle ()
Boolean isHelical ()
Boolean isSpiral ()
Vector getCircularNormal ()
Integer getCircularPlane ()
Vector getHelicalOffset ()
Number getHelicalDistance ()
Number getHelicalPitch ()
Boolean canLinearize ()
linearize (Number tolerance)
Integer getNumberOfSegments (Number tolerance)
Vector | getPositionU (Number u)
CircularMotion getCircularMotion ()
Number getFeedrate ()
Integer getMovement ()
Boolean getPower ()
Number getSpindleSpeed ()
Boolean | isSpindleSpeedDifferent (Section section)
Integer getRadiusCompensation ()
Integer getCompensationOffset ()
Boolean hasPreviousRecord ()
Record getPreviousRecord ()
Boolean hasNextRecord ()
Record getNextRecord ()
Tool getFirstTool ()
setWriteInvocations (Boolean writeInvocations)
setWriteStack (Boolean writeStack)
writeSectionNotes ()
writeSetupNotes ()
Boolean isFirstCyclePoint ()
Boolean isLastCyclePoint ()
Integer getCyclePointId ()
Integer getNumberOfCyclePoints ()
Vector | getCyclePoint (Integer index)
onImpliedCommand (Integer command)
Boolean | hasGlobalParameter (String name)
Value | getGlobalParameter (String name, Value defaultValue)
Value | getProperty (ScriptObject property, Value defaultValue)
setProperty (ScriptObject property, Value value)
Boolean | hasParameter (String name)
Value | getParameter (String name, Value defaultValue)
registerTerminationHandler (Function function)
Number | toDeg (Number radians)
Number | toRad (Number degrees)
Number | parseSpatial (String &value)
Integer | getPlane (Vector direction)
Integer getISOPlane (Integer plane)
Boolean | isSameDirection (a, b)
Array | getSectionsInChannel (Number channel)
Boolean validatePropertyDefinitions ()
Boolean validateProperties ()
Integer | getProgramNameAsInt (Integer min, Integer max)
String | getProgramNameAsString (Integer charLimit)
Boolean | isToolChangeNeeded (Section section, String arguments)
Tool | getNextTool (Integer number)
Tool | getNextTool (Section section, Boolean firstTool, String arguments)
Boolean | isNewWorkPlane (Section section)
Boolean | isNewWorkOffset (Section section)
Range toolZRange ()
Array | range (Number first, Number end, Number step)
Array | interval (Number from, Number to)
Array | flatten (Array array)
Integer | getQuadrant (Number angle)
String | conditional (condition, value)
validate (Value expression, String message)
debug (String message)
Number | spatial (Number value, Integer unit)
Number | getInverseTime (Number distance, Number speed)
cycleNotSupported ()
Boolean isWorkpieceDefined ()
Boolean isTurning ()
Boolean isMilling ()
Boolean isJet ()
Boolean isFirstSection ()
Boolean isLastSection ()
onExpandedRapid (Number x, Number y, Number z)
onExpandedLinear (Number x, Number y, Number z, Number feed)
onExpandedSpindleSpeed (Number spindleSpeed)
MachineConfiguration | createMachineConfiguration (Map specifiers)
String | getMachineConfigurationAsText (MachineConfiguration machine)
Axis | createAxis (Map specifiers)
FormatNumber | createFormat (Map specifiers)
Variable | createVariable (Map specifiers, Format format)
IncrementalVariable | createIncrementalVariable (Map specifiers, Format format)
ReferenceVariable | createReferenceVariable (Map specifiers, Format format)
Modal | createModal (Map specifiers, Format format)
ModalGroup | createModalGroup (Map specifiers, Array groups, Format format)
repositionToCycleClearance (Map cycle, Number x, Number y, Number z)
expandCyclePoint (Number x, Number y, Number z)
Boolean isWellKnownCycle ()
Boolean | isProbingCycle (String uri)
Boolean | isSubSpindleCycle (String uri)
Boolean | isWellKnownCommand (Integer command)
String | getCommandStringId (Integer command)
Boolean | canIgnoreCommand (Integer command)
onUnsupportedCommand (Integer command)
expandManualNC (Integer command, Value value)
onUnsupportedCoolant (Integer coolant)
String | getCoolantName (Integer coolant)
String | getMaterialName (Integer material)
String getToolTypeName (tool)
onMachine ()
onOpen ()
onCycle ()
onCyclePoint (Number x, Number y, Number z)
onCyclePath ()
onCyclePathEnd ()
onCycleEnd ()
onParameter (String name, Value value)
onPassThrough (Value value)
onComment (String comment)
onRapid (Number x, Number y, Number z)
onLinear (Number x, Number y, Number z, Number feed)
onLinearExtrude (Number x, Number y, Number z, Number feed, Number extrusionLength)
onCircular (Boolean clockwise, Number cx, Number cy, Number cz, Number x, Number y, Number z, Number feed)
onCircularExtrude (Boolean clockwise, Number cx, Number cy, Number cz, Number x, Number y, Number z, Number feed, Number extrusionLength)
onRapid5D (Number x, Number y, Number z, Number dx, Number dy, Number dz)
onLinear5D (Number x, Number y, Number z, Number dx, Number dy, Number dz, Number feed)
onRewindMachine (Number a, Number b, Number c)
onRewindMachineEntry (Number a, Number b, Number c)
onMoveToSafeRetractPosition ()
onReturnFromSafeRetractPosition (Number x, Number y, Number z)
onRotateAxes (Number x, Number y, Number z, Number a, Number b, Number c)
onMovement (Integer movement)
onPower (Boolean power)
onRadiusCompensation ()
onToolCompensation (Integer compensation)
onDwell (Number time)
onSpindleSpeed (Number spindleSpeed)
onLayer (Number layerNumber)
onExtrusionReset (Number length)
onExtruderChange (Number extruderId)
onExtruderTemp (Number temp, Boolean wait, Integer extruderId)
onBedTemp (Number temp, Boolean wait)
onFanSpeed (Number speed, Integer fanId)
onMaxAcceleration (Number xAxis, Number yAxis, Number zAxis, Number eAxis)
onAcceleration (Number travel, Number printing, Number retract)
onJerk (Number xAxis, Number yAxis, Number zAxis, Number eAxis)
onCommand (Integer command)
onOrientateSpindle (Number angle)
onSectionEnd ()
onClose ()

Public Attributes

Integer outputUnit
Section currentSection
Integer highFeedMapping
Number highFeedrate
Integer lineNumber
Vector initialCyclePosition
Boolean abortOnDeprecation
Vector end
Number length
Vector center
The center of the current circular motion.
Vector normal
The circular plane normal of the current circular motion.
Integer plane
Number radius
The radius of the current circular motion.
Number sweep
The sweep of the current circular motion.
Boolean clockwise
Specifies that the current cicular motion is clockwise.
Number chordLength
The chord length of the current circular motion (0 for full circles).
Boolean fullCircle
Specifies that the currect circular motion is a full circle.
Boolean helical
Specifies that the currect circular motion is helical.
Vector helicalOffset
The helical offset for the current circular motion.
Number helicalDistance
The helical distance for the currect circular motion.
Integer movement
Integer radiusCompensation
String description
String vendor
String vendorUrl
String legal
Integer unit
String programName
Boolean programNameIsInteger
Boolean debugMode
Boolean preventPost
String filename
String extension
String version
Integer certificationLevel
Integer revision
Integer minimumRevision
Boolean deprecated
Integer capabilities
Number tolerance
Boolean mapWorkOrigin
Boolean mapToWCS
Boolean allowMachineChangeOnSection
Number minimumChordLength
Number minimumCircularRadius
Number maximumCircularRadius
Number minimumCircularSweep
Number maximumCircularSweep
Boolean allowHelicalMoves
Boolean allowSpiralMoves
Integer allowedCircularPlanes
MachineParameters machineParameters
Map properties
String NUL
NUL ASCII control code.
String SOH
SOH ASCII control code.
String STX
STX ASCII control code.
String ETX
ETX ASCII control code.
String EOT
EOT ASCII control code.
String ENQ
ENQ ASCII control code.
String ACK
ACK ASCII control code.
String BEL
BEL ASCII control code.
String BS
BS ASCII control code.
String TAB
TAB ASCII control code.
String LF
LF ASCII control code.
String VT
VT ASCII control code.
String FF
FF ASCII control code.
String CR
CR ASCII control code.
String SO
SO ASCII control code.
String SI
SI ASCII control code.
String DLE
DLE ASCII control code.
String DC1
DC1 ASCII control code.
String DC2
DC2 ASCII control code.
String DC3
DC3 ASCII control code.
String DC4
DC4 ASCII control code.
String NAK
NAK ASCII control code.
String SYN
SYN ASCII control code.
String ETB
ETB ASCII control code.
String CAN
CAN ASCII control code.
String EM
EM ASCII control code.
String SUB
SUB ASCII control code.
String ESC
ESC ASCII control code.
String FS
FS ASCII control code.
String GS
GS ASCII control code.
String RS
RS ASCII control code.
String US
US ASCII control code.
String EOL
The default end-of-line marker.
String SP
Space string.
String PATH_SEPARATOR
File path separator.
Integer IN
Inch unit.
Integer MM
Millimeters unit.
Integer PLANE_XY
Circular XY plane.
Integer PLANE_XZ
Circular XZ plane. Deprecated use PLANE_ZX instead.
Integer PLANE_ZX
Circular ZX plane.
Integer PLANE_YZ
Circular YZ plane.
Integer X
X coordinate index.
Integer Y
Y coordinate index.
Integer Z
Z coordinate index.
Integer A
A rotary index.
Integer B
B rotary index.
Integer C
C rotary index.
Integer ABC
All rotaries index.
Integer TOOL_AXIS_X
YZ-plane.
Integer TOOL_AXIS_Y
ZX-plane.
Integer TOOL_AXIS_Z
XY-plane.
Integer RADIUS_COMPENSATION_OFF
Center radius compensation.
Integer RADIUS_COMPENSATION_LEFT
Left radius compensation.
Integer RADIUS_COMPENSATION_RIGHT
Right radius compensation.
Integer SINGULARITY_LINEARIZE_OFF
Don't linearize moves around multi-axis singularities. More...
Integer SINGULARITY_LINEARIZE_LINEAR
Integer SINGULARITY_LINEARIZE_ROTARY
Keep rotary axes in line during multi-axis singularity linearization. More...
Integer COOLANT_DISABLED
Coolant disabled.
Integer COOLANT_FLOOD
Flood coolant mode.
Integer COOLANT_MIST
Mist coolant mode.
Integer COOLANT_TOOL
Coolant through tool mode. Deprecated use COOLANT_THROUGH_TOOL instead.
Integer COOLANT_THROUGH_TOOL
Coolant through tool mode.
Integer COOLANT_AIR
Air mode.
Integer COOLANT_AIR_THROUGH_TOOL
Air through tool mode.
Integer COOLANT_SUCTION
Suction mode.
Integer COOLANT_FLOOD_MIST
Flood and mist coolant mode.
Integer COOLANT_FLOOD_THROUGH_TOOL
Flood and through tool coolant mode.
Integer MATERIAL_UNSPECIFIED
Unspecified material.
Integer MATERIAL_HSS
High-speed steel material.
Integer MATERIAL_TI_COATED
TI coated material.
Integer MATERIAL_CARBIDE
Carbide material.
Integer MATERIAL_CERAMICS
Ceramics material.
Integer TOOL_UNSPECIFIED
Unspecified tool.
Integer TOOL_DRILL
Drill.
Integer TOOL_DRILL_CENTER
Center drill.
Integer TOOL_DRILL_SPOT
Spot drill.
Integer TOOL_DRILL_BLOCK
Block drill.
Integer TOOL_MILLING_END_FLAT
Flat end-mill.
Integer TOOL_MILLING_END_BALL
Ball end-mill.
Integer TOOL_MILLING_END_BULLNOSE
Bullnose mill.
Integer TOOL_MILLING_CHAMFER
Chamfer mill.
Integer TOOL_MILLING_FACE
Face mill.
Integer TOOL_MILLING_SLOT
Slot mill.
Integer TOOL_MILLING_RADIUS
Radius mill.
Integer TOOL_MILLING_DOVETAIL
Dovetail mill.
Integer TOOL_MILLING_TAPERED
Tapered mill.
Integer TOOL_MILLING_LOLLIPOP
Lollipop mill.
Integer TOOL_TAP_RIGHT_HAND
Right tap tool.
Integer TOOL_TAP_LEFT_HAND
Left tap tool.
Integer TOOL_REAMER
Reamer tool.
Integer TOOL_BORING_BAR
Boring bar tool.
Integer TOOL_COUNTER_BORE
Counterbore tool.
Integer TOOL_COUNTER_SINK
Countersink tool.
Integer TOOL_HOLDER_ONLY
Holder.
Integer TOOL_TURNING_GENERAL
General turning tool.
Integer TOOL_TURNING_THREADING
Thread turning tool.
Integer TOOL_TURNING_GROOVING
Groove turning tool.
Integer TOOL_TURNING_BORING
Boring turning tool.
Integer TOOL_TURNING_CUSTOM
Custom turning tool.
Integer TOOL_PROBE
Probe.
Integer TOOL_WIRE
Wire.
Integer TOOL_WATER_JET
Water jet.
Integer TOOL_LASER_CUTTER
Laser cutter.
Integer TOOL_WELDER
Welder.
Integer TOOL_GRINDER
Grinder.
Integer TOOL_MILLING_FORM
Form mill.
Integer TOOL_PLASMA_CUTTER
Plasma cutter.
Integer TOOL_MARKER
Marker tool.
Integer TOOL_MILLING_THREAD
Thread mill.
Integer TOOL_COMPENSATION_INSERT_CENTER
Turning tool compensation.
Integer TOOL_COMPENSATION_TIP
Turning tool compensation.
Integer TOOL_COMPENSATION_TIP_CENTER
Turning tool compensation.
Integer TOOL_COMPENSATION_TIP_TANGENT
Turning tool compensation.
Integer HAS_PARAMETER
Has parameter flag.
Integer HAS_RAPID
Has rapid flag.
Integer HAS_LINEAR
Has linear flag.
Integer HAS_DWELL
Has dwell flag.
Integer HAS_CIRCULAR
Has circular flag.
Integer HAS_CYCLE
Has cycle flag.
Integer HAS_WELL_KNOWN_COMMAND
Has well-known command flag.
Integer HAS_COMMENT
Has comment flag.
Integer RECORD_INVALID
Invalid record type.
Integer RECORD_WELL_KNOWN_COMMAND
Well-known command.
Integer RECORD_PARAMETER
Parameter.
Integer RECORD_LINEAR
Linear motion.
Integer RECORD_LINEAR_5D
Linear 5-axis motion.
Integer RECORD_LINEAR_ZXN
Linear 5-axis motion.
Integer RECORD_LINEAR_EXTRUDE
Linear motion with extrude.
Integer RECORD_CIRCULAR
Circular motion.
Integer RECORD_DWELL
Dwell.
Integer RECORD_CYCLE
Cycle.
Integer RECORD_CYCLE_OFF
End of cycle.
Integer RECORD_COMMENT
Comment.
Integer RECORD_WIDE_COMMENT
Comment.
Integer RECORD_CIRCULAR_EXTRUDE
Circular motion with extrude.
Integer COMMAND_INVALID
Invalid (well-known command).
Integer COMMAND_STOP
Program stop (well-known command M00).
Integer COMMAND_OPTIONAL_STOP
Optional program stop (well-known command M01).
Integer COMMAND_END
Program end (well-known command M02).
Integer COMMAND_SPINDLE_CLOCKWISE
Clockwise spindle direction (well-known command M03).
Integer COMMAND_SPINDLE_COUNTERCLOCKWISE
Counterclockwise spidle direction (well-known command M04).
Integer COMMAND_START_SPINDLE
Integer COMMAND_STOP_SPINDLE
Spindle stop (well-known command M05).
Integer COMMAND_ORIENTATE_SPINDLE
Integer COMMAND_LOAD_TOOL
Tool change (M06).
Integer COMMAND_COOLANT_ON
Coolant on (M08).
Integer COMMAND_COOLANT_OFF
Coolant off (M09).
Integer COMMAND_ACTIVATE_SPEED_FEED_SYNCHRONIZATION
Activate speed-feed synchronization (well-known command).
Integer COMMAND_DEACTIVATE_SPEED_FEED_SYNCHRONIZATION
Deactivate speed-feed synchronization (well-known command).
Integer COMMAND_LOCK_MULTI_AXIS
Locks the 4th and 5th axes. This command is optional.
Integer COMMAND_UNLOCK_MULTI_AXIS
Unlocks the 4th and 5th axes. This command is optional.
Integer COMMAND_EXACT_STOP
Exact stop. This command is optional.
Integer COMMAND_START_CHIP_TRANSPORT
Close chip transport.
Integer COMMAND_STOP_CHIP_TRANSPORT
Stop chip transport.
Integer COMMAND_OPEN_DOOR
Open primary door.
Integer COMMAND_CLOSE_DOOR
Close primary door.
Integer COMMAND_BREAK_CONTROL
Break control.
Integer COMMAND_TOOL_MEASURE
Measure tool.
Integer COMMAND_CALIBRATE
Run calibration cycle.
Integer COMMAND_VERIFY
Verify part/tool/machine integrity.
Integer COMMAND_CLEAN
Run cleaning cycle.
Integer COMMAND_ALARM
Alarm.
Integer COMMAND_ALERT
Alert.
Integer COMMAND_CHANGE_PALLET
Change pallet.
Integer COMMAND_POWER_ON
Power on.
Integer COMMAND_POWER_OFF
Power off.
Integer COMMAND_MAIN_CHUCK_OPEN
Open main chuck. More...
Integer COMMAND_MAIN_CHUCK_CLOSE
Close main chuck. More...
Integer COMMAND_SECONDARY_CHUCK_OPEN
Open secondary chuck. More...
Integer COMMAND_SECONDARY_CHUCK_CLOSE
Close secondary chuck. More...
Integer COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_ACTIVATE
Activate spindle synchronization. More...
Integer COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_DEACTIVATE
Deactivate spindle synchronization. More...
Integer COMMAND_SYNC_CHANNELS
Sync channels.
Integer COMMAND_PROBE_ON
Probe on.
Integer COMMAND_PROBE_OFF
Probe off.
Integer MOVEMENT_RAPID
Rapid movement type.
Integer MOVEMENT_LEAD_IN
Lead-in movement type.
Integer MOVEMENT_CUTTING
Cutting movement type.
Integer MOVEMENT_LEAD_OUT
Lead-out movement type.
Integer MOVEMENT_LINK_TRANSITION
Transition linking movement type.
Integer MOVEMENT_LINK_DIRECT
Drection linking movement type.
Integer MOVEMENT_RAMP_HELIX
Helical ramp movement type.
Integer MOVEMENT_RAMP_PROFILE
Profile ramp movement type.
Integer MOVEMENT_RAMP_ZIG_ZAG
Zig-zag ramp movement type.
Integer MOVEMENT_RAMP
Ramp movement type.
Integer MOVEMENT_PLUNGE
Plunge movement type.
Integer MOVEMENT_PREDRILL
Predrill movement type.
Integer MOVEMENT_EXTENDED
Extended movement type.
Integer MOVEMENT_REDUCED
Reduced cutting feed movement type.
Integer MOVEMENT_FINISH_CUTTING
Finish cutting movement type.
Integer MOVEMENT_HIGH_FEED
High feed movement type.
Integer HIGH_FEED_NO_MAPPING
Do not map rapid travesal to high feed.
Integer HIGH_FEED_MAP_MULTI
Map rapid travesal along more than one axis to high feed.
Integer HIGH_FEED_MAP_XY_Z
Integer HIGH_FEED_MAP_ANY
Map all rapid travesals to high feed.
Tool tool
Integer spindleAxis
Number feedrate
Number spindleSpeed
MachineConfiguration machineConfiguration
String cycleType
Map cycle
Boolean cycleExpanded

Detailed Description

Post processor object. This is the main class. The post processor automatically instantiates an instance of this class at startup and makes it the global object for the posting context.

Constructor & Destructor Documentation

◆ PostProcessor()

PostProcessor ( )

Constructs a post processor object.

Member Function Documentation

◆ activatePolarMode()

VectorPair activatePolarMode | ( | Number | tolerance,
 |  | Number | currentAngle,
 |  | Vector | polarDirection
 | ) |  |

Call to activate and setup Polar Mode.

Parameters
tolerance | The tolerance to linearize to.
currentAngle | The current angle of the machine axis's that is perpendicular to the tool
polarDirection | A vector representing the line which the tool can move along to cut the part. (1, 0, 0) would be the x axis.
Returns
Returns the polar transformed initial position and direction as a pair of vectors.
var x_axis = new Vector(1, 0, 0);
var posDir = activatePolarMode(0.01, cOutput.getCurrent(), x_axis);
var x = posDir.first.x;
var y = posDir.first.y;
var z = posDir.first.z;
var a = posDir.second.x;
var b = posDir.second.y;
var c = posDir.second.z;
Since
r45636

◆ alert()

alert | ( | String | title,
 |  | String | description
 | ) |  |

Alerts the user and wait for user.

Parameters
title | The title.
description | The description.

◆ cancelRotation()

cancelRotation ( )

Cancels any active output frame rotation defined by setRotation().

Since
r42292

◆ cancelTransformation()

cancelTransformation ( )

Cancels any active output frame transformation defined by setRotation() and setTranslation().

◆ cancelTranslation()

cancelTranslation ( )

Cancels any active output frame translation defined by setTranslation().

Since
r42292

◆ canIgnoreCommand()

Boolean canIgnoreCommand ( Integer command )

Returns true if the specified command can be safely ignored in normal cases.

◆ canLinearize()

Boolean canLinearize ( )

Returns true if the current record can be linearized using getPositionU(). Only circular records can currently be linearized.

◆ closeRedirection()

closeRedirection ( )

Closes any redirection and switches to normal output. If redirection to buffer is active the buffer is cleared.

◆ conditional()

String conditional | ( | condition | ,
 |  | value |
 | ) |  |

Returns the specified value if the condition is true and otherwise the empty string.

◆ createAxis()

Axis createAxis ( Map specifiers )

Constructs a new machine axis.

The supported specifiers are:

  1. actuator: Specifies that the actuator type (ie. either "linear" or "rotational"). The default is "rotational".
  2. table: Specifies that the axis is located in the table or the head. The default is true for table.
  3. axis: Specifies the axis vector as a 3-element array (e.g. "[0, 0, 1]"). This specifier is required.
  4. homePosition: Specifies the axis home position. The default is 0.
  5. offset: Specifies the axis offset as a 3-element array (e.g. "[0, 0, 25]"). The default is [0, 0, 0].
  6. coordinate: Specifies the coordinate used in the ABC vectors (ie. "X", "Y", or "Z"). This specifier is required.
  7. cyclic: Specifies that the axis is cyclic. Only supported for rotational axes. Only used when a range is specified. The default is false.
  8. tcp: Specifies that the axis supports TCP. Only supported for rotational axes. The default is true.
  9. range: Specifies the angular range for the axis in degrees as a 2-element array (e.g. "[-120, 120]"). You can also specify a single number to create an axis for an aggregate. The default is unbound.
  10. preference: Specifies the preferred angles (-1:negative angles, 0:don't care, and 1:positive angles). The default is don't care.
  11. resolution: Specifies the resolution. In degrees for rotational actuator. The default is 0.
  12. maximumFeed: Specifies the maximum feed rate. The default is 0.
  13. rapidFeed: Specifies the rapid feed rate. The default is 0.
  14. reset: Resets the initial axis position to 0 (0:remember position from previous section, 1:reset at start of operation, 2:reset after automatic rewind, 3:reset for both situations). The default is remember position. Since r42226
Parameters
specifiers The axis specifiers.
var bAxis = createAxis({coordinate:1, table:true, axis:[0, 1, 0], range:[-120,120],
preference:1}); var cAxis = createAxis({coordinate:2, table:true, axis:[0, 0, 1],
range:[-999.999,999.999]}, reset:1);

◆ createFormat()

FormatNumber createFormat ( Map specifiers )

Constructs the format specification for the given values. See createFormat().

Parameters
specifiers The format specifiers.

The supported specifiers are:

  1. decimals: Specifies the number of decimals. Defaults to 6.
  2. trim: Specifies that ending zero decimals should be trimmed. Defaults to true.
  3. trimLeadZero: Specifies that the leading zero should be excluded. Eg. ".123" instead of "0.123". Defaults to false.
  4. forceSign: Specifies that the '+'-sign must be included for positive numbers. Defaults to false.
  5. forceDecimal: Specifies that the decimal symbol must be included. Defaults to false.
  6. zeropad: Specifies that zeros should be padded to the resulting string to fit the given width. Defaults to false.
  7. width: Specifies the width of the resulting string. Defaults to 0.
  8. separator: Specifies the decimal symbol. Defaults to '.'.
  9. cyclicLimit: Specifies the cyclic limit. Defaults to 0 (disabled).
  10. cyclicSign: Specifies the cyclic sign. Defaults to 0.
  11. scale: Specifies the scale. Defaults to 1.
  12. offset: Specifies the offset. Defaults to 0.
  13. prefix: Specifies the prefix. Defaults to empty string.
  14. suffix: Specifies the suffix. Defaults to empty string.
  15. inherit: Specifies the format to inherit.
var xFormat = createFormat({decimals:3, trim:false, forceSign:true});
xFormat.format(4.5); // returns "+4.500"
var yFormat = createFormat({decimals:3, forceSign:true});
yFormat.format(4.5); // returns "+4.5"
var toolFormat = createFormat({decimals:0, zeropad:true, width:2});
toolFormat.format(7); // returns "07"
var aFormat = createFormat({decimals:3, forceSign:true, forceDecimal:true, scale:DEG});
aFormat.format(Math.Pi); // returns "+180."

◆ createIncrementalVariable()

IncrementalVariable createIncrementalVariable | ( | Map | specifiers,
 |  | Format | format
 | ) |  |

Creates a new IncrementalVariable instance.

The supported specifiers are:

Parameters
specifiers | The specifiers.
format | The desired format.
  1. prefix: Specifies a prefix to be prepended the formatted value.
  2. force: Specifies that the value always must be output.
  3. first: Specifies the first value to be output. The default is 0.

◆ createMachineConfiguration()

MachineConfiguration createMachineConfiguration ( Map specifiers )

Constructs a new machine configuration.

The supported specifiers are:

  1. model: Specifies the machine model.
  2. description: Describes the machine configuration.
  3. vendor: Specifies the machine vendor.
  4. vendorUrl: Specifies the machine vendor link.
  5. width: Specifies the width of the machine.
  6. depth: Specifies the depth of the machine.
  7. height: Specifies the height of the machine.
  8. weight: Specifies the weight of the machine.
  9. weightCapacity: Specifies the weight capacity of the machine.
  10. spindleAxis: Specifies the spindle axis.
  11. maximumSpindlePower: Specifies the maximum spindle power.
  12. maximumSpindleSpeed: Specifies the maximum spindle speed.
  13. collectChuck: Specifies the collect chuck. Tool-holder interface.
  14. x: Specifies the X axis.
  15. y: Specifies the Y axis.
  16. z: Specifies the Z axis.
  17. u: Specifies the U axis.
  18. v: Specifies the V axis.
  19. w: Specifies the W axis.
Parameters
specifiers The specifiers.

◆ createModal()

Modal createModal | ( | Map | specifiers,
 |  | Format | format
 | ) |  |

Creates a new Modal instance.

Parameters
specifiers | The format specifiers.
format | The desired format (optional).

The supported specifiers are:

  1. prefix: Specifies the prefix.
  2. suffix: Specifies the suffix.
  3. force: Specifies that the value must always be returned.
  4. onchange: Specifies a method to be invoked when format() results in output.

◆ createModalGroup()

ModalGroup createModalGroup | ( | Map | specifiers,
 |  | Array | groups,
 |  | Format | format
 | ) |  |

Creates a new ModalGroup instance.

The supported specifiers are:

  1. force: Specifies that output is forced. The default is false.
  2. strict: Specifies the strict mode. The default is true.
Parameters
specifiers | The specifiers.
groups | The code groups (e.g. [[1, 2, 3, 4], [17, 18, 19]]).
format | The format.

◆ createReferenceVariable()

ReferenceVariable createReferenceVariable | ( | Map | specifiers,
 |  | Format | format
 | ) |  |

Creates a new ReferenceVariable instance.

The supported specifiers are:

Parameters
specifiers | The behavior specifiers.
format | The instance of type Format used to format the output values.

The supported specifiers are:

  1. prefix: Specifies a prefix to be prepended the formatted value.
  2. force: Specifies that the value always must be output.

◆ createToolRenderer()

ToolRenderer createToolRenderer ( )

Returns a new tool renderer.

◆ createVariable()

Variable createVariable | ( | Map | specifiers,
 |  | Format | format
 | ) |  |

Creates a new Variable instance.

Parameters
specifiers | The specifiers.
format | The desired format.

The supported specifiers are:

  1. prefix: Specifies a prefix to be prepended the formatted value.
  2. force: Specifies that the value always must be output.
  3. onchange: Specifies a method to be invoked when format() results in output.

◆ cycleNotSupported()

cycleNotSupported ( )

Returns an error message if the current cycle is not supported.

◆ deactivatePolarMode()

deactivatePolarMode ( )

Call to deactivate Polar Mode. This should be called in onSectionEnd() if activePolarMode has been called in onSection().

Since
r45636

◆ debug()

debug ( String message )

Writes the specified debug message to the log if debugging mode is enabled (i.e. debugMode is true).

Multiple arguments are allowed

Since
r41291 where the arguments will be concatenated using formatWords().

◆ error()

error ( String message )

Writes an error message and aborts the script.

◆ execute()

Integer execute | ( | String | path,
 |  | String | arguments,
 |  | Boolean | hide,
 |  | String | workingFolder
 | ) |  |

Runs the specified command. Note that you cannot open the primary output file until the onTerminate() is invoked. Post processor waits for the program to complete.

Security: Requires security level 0.

Parameters
path | The path of the command.
arguments | The arguments to be parsed to the command.
hide | Hide application.
workingFolder | The working folder.
Returns
Returns the exit code for the command.

Security: Requires security level 0.

◆ executeNoWait()

executeNoWait | ( | String | path,
 |  | String | arguments,
 |  | Boolean | hide,
 |  | String | workingFolder
 | ) |  |

Runs the specified command. Same as execute() but doesn't wait for application to complete.

Security: Requires security level 0.

Parameters
path | The path of the command.
arguments | The arguments to be parsed to the command.
hide | Hide application.
workingFolder | The working folder.

Security: Requires security level 0.

◆ expandCyclePoint()

expandCyclePoint | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

May be invoked in cycle mode to expand a well-known cycle. Used when a specific cycle is not supported by a control.

Parameters
x | The X coordiante of the cycle point.
y | The Y coordiante of the cycle point.
z | The Z coordiante of the cycle point.

◆ expandManualNC()

expandManualNC | ( | Integer | command,
 |  | Value | value
 | ) |  |

Processes Manual NC commands that are not handled in onManualNC.

Parameters
command | The Manual NC command.
value | The value.
Since
42292

◆ exportNCAs()

exportNCAs | ( | String | path,
 |  | String | format
 | ) |  |

Exports the toolpath data to the given file.

Security: Requires security level 0.

Parameters
path | The destination path.
format | The file format.

◆ filterText()

String filterText | ( | String | text,
 |  | String | keep
 | ) |  |

Returns a new string with all characters not present in keep removed.

Parameters
text | The original text.
keep | The characters to be preserved in the string.

◆ findFile()

String findFile ( String path )

Returns the full path for the specified relative path if found in the include paths.

Parameters
path the relative path.

◆ flatten()

Array flatten ( Array array )

Flattens the specified array.

Parameters
array The array to flatten.
flatten([1, 2, 3, [4, 5, [6]]]); // returns [1, 2, 3, 4, 5, 6]

◆ formatWords()

String formatWords ( String message )

Returns the string output by writeWords() without end-of-line.

◆ getAsFloat()

Number getAsFloat ( String text )

Converts the specified text to a float. Raises an exception if all the specified text cannot be converted.

Parameters
text The text to be converted.

◆ getAsInt()

Integer getAsInt ( String text )

Converts the specified text to an integer. Raises an exception if all the specified text cannot be converted.

Parameters
text The text to be converted.

◆ getCascadingPath()

String getCascadingPath ( )

Returns the cascading path set by the previous post. By default this will be the getOutputPath().

Since
41546

◆ getCircularCenter()

Vector getCircularCenter ( )

Returns the center for the current circular motion. Returns an unspecified value if the current motion is not circular.

◆ getCircularChordLength()

Number getCircularChordLength ( )

Returns the chord length for the current circular motion. Returns an unspecified value if the current motion is not circular. Returns 0 for full circular motion.

◆ getCircularMotion()

CircularMotion getCircularMotion ( )

Returns the circular motion description for the current circular record.

◆ getCircularNormal()

Vector getCircularNormal ( )

The CCW-normal of the circular plane. However, the normal is flipped if isClockwise() is true. This behavior ensures direct compatibility with RS274 for the right hand G17, G18, and G19 plane convention.

var n = getCircularNormal();
if (clockwise) {
n = Vector.product(n, -1);
}

◆ getCircularPlane()

Integer getCircularPlane ( )

Returns the circular plane. Returns -1 is the plane is not in a primary plane.

◆ getCircularRadius()

Number getCircularRadius ( )

Returns the end radius for the current circular motion. Returns an unspecified value if the current motion is not circular.

◆ getCircularStartRadius()

Number getCircularStartRadius ( )

Returns the start radius for the current circular motion. Returns an unspecified value if the current motion is not circular. The start radius can only be different from the end radius returned by getCircularRadius() for spiral motion.

◆ getCircularSweep()

Number getCircularSweep ( )

Returns the sweep for the current circular motion. Returns an unspecified value if the current motion is not circular.

◆ getCodePage()

Integer getCodePage ( )

Returns the current output code page id.

◆ getCommandStringId()

String getCommandStringId ( Integer command )

Returns the string id for the specified command.

◆ getCompensationOffset()

Integer getCompensationOffset ( )

Returns the current compensation offset.

◆ getConfigurationFolder()

String getConfigurationFolder ( )

Returns the path on the configuration folder.

◆ getConfigurationPath()

String getConfigurationPath ( )

Returns the path on the configuration file.

◆ getCoolantName()

String getCoolantName ( Integer coolant )

Returns the specified coolant as a string.

◆ getCurrentChannel()

Integer getCurrentChannel ( )

Returns the id for the current channel.

Since
r42045

◆ getCurrentDirection()

Vector getCurrentDirection ( )

Returns the current direction.

◆ getCurrentGlobalPosition()

Vector getCurrentGlobalPosition ( )

Returns the current position in the global coordinate system.

◆ getCurrentNCLocation()

String getCurrentNCLocation ( )

Returns a description of the current NC location.

◆ getCurrentPosition()

Vector getCurrentPosition ( )

Returns the current position.

◆ getCurrentRecordId()

Integer getCurrentRecordId ( )

Returns the id of the current record.

◆ getCurrentSectionId()

Integer getCurrentSectionId ( )

Returns the id of the current section. Returns -1 is no section is active.

◆ getCurrentSpindleSpeed()

Number getCurrentSpindleSpeed ( )

Returns the current spindle speed.

Since
r42066

◆ getCurrentSyncGroup()

Integer getCurrentSyncGroup ( )

Returns the multi-channel sync group for the current channel. Starting from 0.

Since
r42045

◆ getCyclePoint()

Vector getCyclePoint ( Integer index )

Returns the specified cycle point for the current cycle.

Parameters
index The index of the point. Must be less than the value returned by getNumberOfCyclePoints().
Since
r19569

◆ getCyclePointId()

Integer getCyclePointId ( )

Returns the id of the current cycle point. Returns 0 if cycle is not active.

Since
r19569

◆ getDirection()

Vector getDirection ( )

Returns the direction for the current motion.

◆ getDogLeg()

Boolean getDogLeg ( )

Returns the dog-leg flag. The default is false.

◆ getEnd()

Vector getEnd ( )

Returns the end position for the current motion.

◆ getFeedrate()

Number getFeedrate ( )

Returns the current feedrate.

◆ getFirstTool()

Tool getFirstTool ( )

Returns the first tool.

◆ getFixture()

BoundingBox getFixture ( )

Returns the fixture bounding box.

Since
r40294

◆ getFrameDirection()

Vector getFrameDirection ( Vector direction )

Returns the specified section direction in the current frame specified using setRotation().

◆ getFramePosition()

Vector getFramePosition ( Vector position )

Returns the specified section position in the current frame specified using setRotation() and setTranslation().

◆ getGlobalParameter()

Value getGlobalParameter | ( | String | name,
 |  | Value | defaultValue
 | ) |  |

Returns the first value of the specified global parameter.

Parameters
name | The name of the parameter to return
defaultValue | (optional, since r45606) The default value of the parameter to return if it is not defined.

e.g.

if (hasGlobalParameter("document-path")) {
var filename = FileSystem.getFilename(getGlobalParameter("document-path"));
if (filename) {
writeln("(" + filename + ")");
}
}
Since
r16737

◆ getGlobalPosition()

Vector getGlobalPosition ( Vector p )

Returns the specified position in the current section as the corresponding global position.

◆ getHeader()

String getHeader ( )

Returns the header of the post configuration where header is the first multi-line comment.

Since
r41192

◆ getHeaderCommit()

String getHeaderCommit ( )

Returns the commit from the header of the post configuration. Where commit is the second string within the

Revision
...

. Returns empty string if not found.

Since
r41192

◆ getHeaderDate()

String getHeaderDate ( )

Returns the modification date as string from the header of the post configuration. Where date is the string within the Date: ... $. Returns empty string if not found.

Since
r41192

◆ getHeaderDate2()

Date getHeaderDate2 ( )

Returns the modification date as Date from the header of the post configuration. Where date is the string within the Date: ... $. Returns undefined if not found.

Since
r41192

◆ getHeaderSnippet()

String getHeaderSnippet ( String keyword )

Returns the string following the given keyword from the header of the post configuration. Returns empty string if not found.

Parameters
keyword The keyword to look for. The keyword must match this regular expression [a-zA-Z][a-zA-Z0-9_]*.
Since
r41192

◆ getHeaderVersion()

String getHeaderVersion ( )

Returns the version from the header of the post configuration. Where version is the first string within the

Revision
...

. Returns empty string if not found.

Since
r41192

◆ getHelicalDistance()

Number getHelicalDistance ( )

Returns the helical distance of the current circular motion. Returns 0 for non-helical motion. Returns an unspecified value if the current motion is not circular.

◆ getHelicalOffset()

Vector getHelicalOffset ( )

Returns the helical offset of the current circular motion. Returns (0, 0, 0) for non-helical motion. Returns an unspecified value if the current motion is not circular.

◆ getHelicalPitch()

Number getHelicalPitch ( )

Returns the helical pitch of the current circular motion. Returns 0 for non-helical motion. Returns an unspecified value if the current motion is not circular.

◆ getHighFeedMapping()

Integer getHighFeedMapping ( )

Returns the high feed rapid traversal mapping mode.

◆ getHighFeedrate()

Number getHighFeedrate ( )

Returns the high feedrate used for mapping rapid traversal.

◆ getIntermediatePath()

String getIntermediatePath ( )

Returns the path on the intermediate file.

Since
r37310

◆ getInverseTime()

Number getInverseTime | ( | Number | distance,
 |  | Number | speed
 | ) |  |

Returns the inverse time (F).

◆ getISOPlane()

Integer getISOPlane ( Integer plane )

Returns the standard G-code plane number (17, 18, or 19).

PLANE_XY: 17 PLANE_ZX: 18 PLANE_YZ: 19

Returns 0 for all other planes.

◆ getLangId()

String getLangId ( )

Returns the language id.

◆ getLength()

Number getLength ( )

Returns the length of the current motion.

◆ getMachineConfiguration()

MachineConfiguration getMachineConfiguration ( )

Returns the active machine configuration.

◆ getMachineConfigurationAsText()

String getMachineConfigurationAsText ( MachineConfiguration machine )

Returns a description of the specified machine configuration.

Parameters
machine The machine configuration.

◆ getMachineConfigurationByName()

MachineConfiguration getMachineConfigurationByName ( String name )

Returns the specified machine configuration by name.

Parameters
name The name of the machine configuration.

◆ getMachineConfigurations()

String getMachineConfigurations ( )

Returns list of the available machine configurations.

◆ getMachiningDistance()

Number getMachiningDistance ( Integer tool )

Returns the machining distance for the specified tool at the current position.

◆ getMaterialName()

String getMaterialName ( Integer material )

Returns the specified material as a string.

◆ getMovement()

Integer getMovement ( )

Returns the current movement type.

◆ getMultiAxisMoveLength()

MoveLength getMultiAxisMoveLength | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | a,
 |  | Number | b,
 |  | Number | c
 | ) |  |

Returns an object containing length information about the current multiaxis move.

Parameters
x | The end linear x coordinate of the move
y | The end linear y coordinate of the move
z | The end linear z coordinate of the move
a | The end radial a coordinate of the move
b | The end radial b coordinate of the move
c | The end radial c coordinate of the move

◆ getNextRecord()

Record getNextRecord ( )

Returns the next record for the current section.

◆ getNextSection()

Section getNextSection ( )

Returns the next section.

◆ getNextTool() [1/2]

Tool getNextTool ( Integer number )

Returns the next tool with a different tool number.

Returns
Returns the next tool

◆ getNextTool() [2/2]

Tool getNextTool | ( | Section | section,
 |  | Boolean | firstTool,
 |  | String | arguments
 | ) |  |

Returns the next tool, based on the given criteria as arguments.

Parameters
section | The section to retrieve the next tool for. section is optional and if omitted currentSection will be used. Since r45845
firstTool | Returns the first tool if the end of program is reached when set to true. Returns undefined when set to false. Since r45845
arguments | The function can take any number of string arguments, which are the comparison criteria for the current and next tools. These can be "number", "description", "diameter", or any other property on the tool object. The tool number is checked if there are no arguments.
Returns
Returns the next tool
Since
r45600

◆ getNumberOfChannels()

Integer getNumberOfChannels ( )

Returns the number of channels for a multi-channel program.

Since
r42045

◆ getNumberOfCyclePoints()

Integer getNumberOfCyclePoints ( )

Returns the number of cycle points for the current cycle.

Since
r19569

◆ getNumberOfRecords()

Integer getNumberOfRecords ( )

Returns the number of records.

◆ getNumberOfSections()

Integer getNumberOfSections ( )

Returns the number of sections.

◆ getNumberOfSegments()

Integer getNumberOfSegments ( Number tolerance )

Returns the number of segments required to linearize the current record.

◆ getNumberOfSyncGroups()

Integer getNumberOfSyncGroups ( Integer channel )

Returns the number of sync groups in the program.

Since
r42045

◆ getOutputPath()

String getOutputPath ( )

Returns the path on the destination file.

◆ getOutputUnit()

Integer getOutputUnit ( )

Returns the output unit.

◆ getParameter()

Value getParameter | ( | String | name,
 |  | Value | defaultValue
 | ) |  |

Returns the value of the specified parameter.

Only parameters before the current record will be checked.

Parameters
name | The name of the parameter to return.
defaultValue | (optional, since r45606) The default value of the parameter to return if it is not defined.

e.g.

if (hasParameter("operation:tolerance") && hasParameter("operation:strategy")) {
var tolerance = getParameter("operation:tolerance");
if ((getParameter("operation:strategy") == "pocket2d") &&
(tolerance > 0) &&
(tolerance < spatial(10, MM))) {
// override defaults
} else {
// use defaults
}
}

◆ getPlane()

Integer getPlane ( Vector direction )

Returns the plane id for the given direction vector.

Vector(0, 0, 1): PLANE_XY Vector(0, 1, 0): PLANE_ZX Vector(1, 0, 0): PLANE_YZ

Returns
Returns undefined for all other directions.

◆ getPlatform()

String getPlatform ( )

Returns the platform identifier. E.g. "WIN32" for Windows and "OSX" for Mac OS X.

◆ getPolarPosition()

VectorPair getPolarPosition | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

Call to get the polar transformed direction from the given position. This function does not update the current position and direction. Call setCurrentPositionAndDirection() after to update.

Parameters
x | The x coordinate of point to be transformed
y | The y coordinate of point to be transformed
z | The z coordinate of point to be transformed
Returns
Returns the polar transformed position and direction.
var posDir = getPolarPosition(_x, _y, _z, cOutput.getCurrent());
setCurrentPositionAndDirection(posDir);
var x = posDir.first.x;
var y = posDir.first.y;
var z = posDir.first.z;
var a = posDir.second.x;
var b = posDir.second.y;
var c = posDir.second.z;
Since
r45636

◆ getPositionU()

Vector getPositionU ( Number u )

Returns the position at the specified u coordinate for the current motion. The u coordinate is clamped to the range [0; 1].

◆ getPostProcessorFolder()

String getPostProcessorFolder ( )

Returns the folder path on the running post processor.

◆ getPostProcessorPath()

String getPostProcessorPath ( )

Returns the path on the running post processor.

◆ getPower()

Boolean getPower ( )

Returns the current power mode (water jet, laser cutter, and plasma cutter).

◆ getPreviousRecord()

Record getPreviousRecord ( )

Returns the previous record for the current section.

◆ getPreviousSection()

Section getPreviousSection ( )

Returns the previous section. Must be called within a section.

◆ getProduct()

String getProduct ( )

Returns the formal name of the product.

◆ getProductUri()

String getProductUri ( )

Returns the unique id of the software component (i.e. 'http://www.autodesk.com/namespace/campostprocessor').

◆ getProductUrl()

String getProductUrl ( )

Returns the url for the product.

◆ getProgramNameAsInt()

Integer getProgramNameAsInt | ( | Integer | min,
 |  | Integer | max
 | ) |  |

Get the program name as an Integer if it is within the [min, max] range, or error otherwise.

Parameters
min | The minimum possible value for program name (inclusive).
max | The maximum possible value for program name (inclusive).
Since
r42272

◆ getProgramNameAsString()

String getProgramNameAsString ( Integer charLimit )

Get the program name as a String, truncated if it's longer than the character limit.

Parameters
charLimit The maximum number of characters for program name.
Since
r42272

◆ getProperty()

Value getProperty | ( | ScriptObject | property,
 |  | Value | defaultValue
 | ) |  |

Returns the value of the specified post property. If the specified property doesn't exist, it returns the default value if specified, otherwise it returns undefined.

You can retrieve an operation property of a specific section by using the 'section.getProperty()' function. It takes the same arguments as getProperty(). Since r45811.

Parameters
property | The property object or the property name.
defaultValue | (optional) The default value to return if the property does not exist. Since r45811.

e.g.

getProperty(properties.propName);
getProperty("propName", defaultValue);
getSection(sectionId).getProperty(properties.propName, defaultValue);
getSection(sectionId).getProperty("propName");
Since
r45702

◆ getQuadrant()

Integer getQuadrant ( Number angle )

Returns the quadrant for the specified angle (0 -> 3).

◆ getRadiusCompensation()

Integer getRadiusCompensation ( )

Returns the current radius compensation

◆ getRecord()

Record getRecord ( Integer id )

Returns the specified record.

◆ getRedirectionBuffer()

String getRedirectionBuffer ( )

Returns the current content of the redirection buffer.

◆ getRedirectionBuffer2()

String getRedirectionBuffer2 ( Boolean clear )

Returns the current content of the redirection buffer.

Parameters
clear Clears the redirection buffer if true.

◆ getRotation()

Matrix getRotation ( )

Returns the current rotation.

◆ getSection()

Section getSection ( Integer index )

Returns the specified section. The index must be in the range [0; getNumberOfSections()].

◆ getSectionFrameDirection()

Vector getSectionFrameDirection ( Vector frameDirection )

Returns the specified frame direction in the current section frame. Reverse mapping of getFrameDirection().

◆ getSectionFramePosition()

Vector getSectionFramePosition ( Vector framePosition )

Returns the specified frame position in the current section frame. Reverse mapping of getFramePosition().

◆ getSectionPosition()

Vector getSectionPosition ( Vector p )

Returns the specified global position as the corresponding position in the current section.

◆ getSectionsInChannel()

Array getSectionsInChannel ( Number channel )

Returns the array of sections which use the given channel.

Parameters
channel The channel.
Since
r42040

◆ getSecurityLevel()

Integer getSecurityLevel ( )

Returns the security level in which is post processor is running.

Since
41349

◆ getSpindleSpeed()

Number getSpindleSpeed ( )

Returns the current spindle speed.

◆ getSystemUnit()

Integer getSystemUnit ( )

Returns the system unit as defined in the regional settings.

◆ getToolTable()

ToolTable getToolTable ( )

Returns the tools. The order of the tools within the tool table is unspecified.

◆ getToolTypeName()

String getToolTypeName ( tool )

Returns the specified tool as a string.

◆ getTranslation()

Vector getTranslation ( )

Returns the current translation.

◆ getVendor()

String getVendor ( )

Returns the vendor of the product.

◆ getVendorUrl()

String getVendorUrl ( )

Returns the url for the vendor.

◆ getVersion()

String getVersion ( )

Returns the version of the software component.

◆ getWCSPosition()

Vector getWCSPosition ( Vector p )

Returns the specified position in the current section in the WCS. You likely want to use getGlobalPosition() instead.

◆ getWordSeparator()

String getWordSeparator ( )

Returns the separator for word-based the line output.

◆ getWorkpiece()

BoundingBox getWorkpiece ( )

Returns the workpiece bounding box.

Since
r19573

◆ hasGlobalParameter()

Boolean hasGlobalParameter ( String name )

Returns true if the specified parameter has been defined globally.

Since
r16737

◆ hasNextRecord()

Boolean hasNextRecord ( )

Returns true if the section has a next record.

◆ hasNextSection()

Boolean hasNextSection ( )

Returns true if the current section is succeeded by a section.

◆ hasParameter()

Boolean hasParameter ( String name )

Returns true if the specified parameter has been defined.

Only parameters before the current record will be checked.

◆ hasPreviousRecord()

Boolean hasPreviousRecord ( )

Returns true if the section has a previous record.

◆ hasSymbol()

Boolean hasSymbol ( Integer symbol )

Returns true if the specified character exists in the current code page.

◆ include()

include ( String path )

Includes the specified post processing script.

Parameters
path the path of the script to be included.

◆ interval()

Array interval | ( | Number | from,
 |  | Number | to
 | ) |  |

Returns an array with values in the requested interval. Also see range(). from must be less than or equal to to.

Parameters
from | The first value (inclusive).
to | The last value (inclusive).
interval(10, 15); // returns [10, 11, 12, 13, 14, 15]

◆ invokeOnCircular()

Boolean invokeOnCircular | ( | Boolean | clockwise,
 |  | Number | cx,
 |  | Number | cy,
 |  | Number | cz,
 |  | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | nx,
 |  | Number | ny,
 |  | Number | nz,
 |  | Number | feedrate
 | ) |  |

Called to invoke onCircular in the post engine.

Parameters
clockwise | True if tool should move in a clockwise direction.
cx | The x value of the point the tool will arc around.
cy | The y value of the point the tool will arc around.
cz | The z value of the point the tool will arc around.
x | The x value of the point the tool will arc to.
y | The y value of the point the tool will arc to.
z | The z value of the point the tool will arc to.
nx | The x value of the direction perpendicular to the arc.
ny | The y value of the direction perpendicular to the arc.
nz | The z value of the direction perpendicular to the arc.
feedrate | The feedrate of the tool.
Returns
Returns true on success.
Since
r45605

◆ invokeOnLinear()

Boolean invokeOnLinear | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | feedrate
 | ) |  |

Called to invoke onLinear in the post engine.

Parameters
x | The x value of the point the tool will move to.
y | The y value of the point the tool will move to.
z | The z value of the point the tool will move to.
feedrate | The feedrate of the tool.
Returns
Returns true on success.
Since
r45605

◆ invokeOnLinear5D()

Boolean invokeOnLinear5D | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | dx,
 |  | Number | dy,
 |  | Number | dz,
 |  | Number | feedrate
 | ) |  |

Called to invoke onLinear5D in the post engine.

Parameters
x | The x value of the point the tool will move to.
y | The y value of the point the tool will move to.
z | The z value of the point the tool will move to.
dx | the x value of the direction the tool will be orientated.
dy | the y value of the direction the tool will be orientated.
dz | the z value of the direction the tool will be orientated.
feedrate | The feedrate of the tool.
Returns
Returns true on success.
Since
r45605

◆ invokeOnRapid()

Boolean invokeOnRapid | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

Called to invoke onRapid in the post engine.

Parameters
x | The x value of the point the tool will move to.
y | The y value of the point the tool will move to.
z | The z value of the point the tool will move to.
Returns
Returns true on success.
Since
r45605

◆ invokeOnRapid5D()

Boolean invokeOnRapid5D | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | dx,
 |  | Number | dy,
 |  | Number | dz
 | ) |  |

Called to invoke onRapid5D in the post engine.

Parameters
x | The x value of the point the tool will move to.
y | The y value of the point the tool will move to.
z | The z value of the point the tool will move to.
dx | the x value of the direction the tool will be orientated.
dy | the y value of the direction the tool will be orientated.
dz | the z value of the direction the tool will be orientated.
Returns
Returns true on success.
Since
r45605

◆ is3D()

Boolean is3D ( )

Returns true if the program is a 3D program (i.e. the tool axis points along the Z-axis for all the sections).

◆ isAxialCenterDrilling()

Boolean isAxialCenterDrilling | ( | Section | section,
 |  | Boolean | checkLiveTool
 | ) |  |

Returns whether the current section is an axial center drilling operation

Parameters
section | The section to check for an axial center drilling operation. section is optional and if omitted currentSection will be used.
checkLiveTool | Set to true if live tools are respected and not considered for axial drilling cycles, false ignores the live tool setting
Returns
Returns true if section is an axial center drilling operation, otherwise returns false
Since
r45845

◆ isClockwise()

Boolean isClockwise ( )

Returns true if the current circular motion is clockwise. Returns an unspecified value if the current motion is not circular.

◆ isClockwiseSpindleDirection()

Boolean isClockwiseSpindleDirection ( )

Returns true if the current spindle direction is clockwise. The spindle may be stopped. The direction is assumed to be clockwise by default.

◆ isCoolantActive()

Boolean isCoolantActive ( )

Returns true if the coolant is active. The coolant is assumed to be inactive by default.

◆ isDepositionOperation()

Boolean isDepositionOperation ( Section section )

Returns whether the current section is a deposition operation

Parameters
section The section to check for a deposition operation. section is optional and if omitted currentSection will be used.
Returns
Returns true if section is a deposition operation, otherwise returns false
Since
r45845

◆ isDrillingCycle()

Boolean isDrillingCycle | ( | Section | section,
 |  | Boolean | checkBoringCycles
 | ) |  |

Returns whether the current section is a drilling operation

Parameters
section | The section to check for a drilling operation. section is optional and if omitted currentSection will be used.
checkBoringCycles | Set to true if boring cycles with a shift value should be considered a drilling cycle, set to false otherwise
Returns
Returns true if section is a drilling operation, otherwise returns false
Since
r45845

◆ isExpanding()

Boolean isExpanding ( )

Returns true if the current motion is a result of an expanded motion. Expanded motion is for instance produced by expandCyclePoint().

◆ isFirstCyclePoint()

Boolean isFirstCyclePoint ( )

Returns true if the current cycle point is the first motion for the current cycle. Returns false if cycle is not active.

◆ isFirstSection()

Boolean isFirstSection ( )

Returns true if the current section is the first section.

◆ isFullCircle()

Boolean isFullCircle ( )

Returns true if the current circular motion is a full circle (360deg). Returns an unspecified value if the current motion is not circular.

◆ isHelical()

Boolean isHelical ( )

Returns true if the current circular motion is helical. Returns an unspecified value if the current motion is not circular.

◆ isInspectionOperation()

Boolean isInspectionOperation ( Section section )

Returns whether the current section is an inspection operation

Parameters
section The section to check for an inspection operation. section is optional and if omitted currentSection will be used. Since r45845
Returns
Returns true if section is an inspection operation, otherwise returns false
Since
r45600

◆ isInteractionAllowed()

Boolean isInteractionAllowed ( )

Returns true if user interaction is allowed.

◆ isJet()

Boolean isJet ( )

Returns true for jet toolpath (waterjet, laser, and plasma cutting).

◆ isLastCyclePoint()

Boolean isLastCyclePoint ( )

Returns true if the current cycle point is the last motion for the current cycle. Returns false if cycle is not active.

◆ isLastSection()

Boolean isLastSection ( )

Returns true if the current section is the last section.

◆ isMilling()

Boolean isMilling ( )

Returns true for milling toolpath.

◆ isMillingCycle()

Boolean isMillingCycle | ( | Section | section,
 |  | Boolean | checkBoringCycles
 | ) |  |

Returns whether the current section is a milling cycle

Parameters
section | The section to check for a milling cycle. section is optional and if omitted currentSection will be used.
checkBoringCycles | Set to true if boring cycles with a shift value should be considered a milling cycle, set to false otherwise
Returns
Returns true if section is a milling cycle, otherwise returns false
Since
r45845

◆ isMultiAxis()

Boolean isMultiAxis ( )

Returns true if the post processor is in multi-axis mode.

◆ isMultiChannelProgram()

Boolean isMultiChannelProgram ( )

Returns true if the program is a multi-channel program.

Since
r42045

◆ isNewWorkOffset()

Boolean isNewWorkOffset ( Section section )

Returns whether a new work offset is used for the given section.

Parameters
section The section to check the work offset. section is optional and if omitted currentSection will be used.
Since
r45845

◆ isNewWorkPlane()

Boolean isNewWorkPlane ( Section section )

Returns whether a new work plane is needed for the given section.

Parameters
section The section to check the work plane. section is optional and if omitted currentSection will be used.
Since
r42290

◆ isPolarModeActive()

Boolean isPolarModeActive ( )

Call to check if Polar Mode is active.

Returns
Returns true if activatePolarMode() has been called.
Since
r45636

◆ isProbeOperation()

Boolean isProbeOperation ( Section section )

Returns whether the section is a probing operation

Parameters
section The section to check for a probing operation. section is optional and if omitted currentSection will be used. Since r45845
Returns
Returns true if section is a probing operation, otherwise returns false
Since
r45600

◆ isProbingCycle()

Boolean isProbingCycle ( String uri )

Returns true if the given cycle is a probing cycle.

Parameters
uri The identifier of the cycle.
Since
r41188

◆ isRedirecting()

Boolean isRedirecting ( )

Returns true if the output is being redirected.

◆ isSafeText()

Boolean isSafeText | ( | String | text,
 |  | String | permitted
 | ) |  |

Returns true if the specified string only contains the specified characters.

Parameters
text | The string.
permitted | The permitted characters.

◆ isSameDirection()

Boolean isSameDirection | ( | a | ,
 |  | b |
 | ) |  |

Returns true if the 2 specified normalized vectors are in the same direction.

The built-in implementation is:

function isSameDirection(a, b) {
return Vector.dot(a, b) > (1 - 1e-7);
}

You can easily change the post behavior by adding your own implementation of the function.

◆ isSectionSpecialCycle()

Boolean isSectionSpecialCycle ( String uri )

Returns true if the given cycle is considered a special cycle for which to call onSectionSpecialCycle()/onSectionEndSpecialCycle() instead of onSection()/onSectionEnd().

Parameters
uri The unique identifier of the cycle.
Since
r41185

◆ isSpeedFeedSynchronizationActive()

Boolean isSpeedFeedSynchronizationActive ( )

Returns true if the speed-feed asynchronization is active. The synchronization is assumed to be inactive by default.

◆ isSpindleActive()

Boolean isSpindleActive ( )

Returns true if the spindle is active. The direction is assumed to be inactive by default.

◆ isSpindleSpeedDifferent()

Boolean isSpindleSpeedDifferent ( Section section )

Returns whether the section's spindle speed or spindle mode (RPM/SFM) is different than the previous section's spindle speed or mode

Parameters
section The section to check for a spindle speed/mode change. section is optional and if omitted currentSection will be used.
Returns
True if the spindle speed or spindle mode differs from the previous section, false if they are the same
Since
r45845

◆ isSpiral()

Boolean isSpiral ( )

Returns true if the current circular motion is a spiral (i.e. the start and end radii do not match). Returns an unspecified value if the current motion is not circular.

◆ isSubSpindleCycle()

Boolean isSubSpindleCycle ( String uri )

Returns true if the given cycle is a sub spindle cycle.

Parameters
uri The identifier of the cycle.
Since
r41188

◆ isSupportedText()

Boolean isSupportedText ( String & message )

Returns true if the specified text can be output in the active code page/encoding without change.

◆ isTappingCycle()

Boolean isTappingCycle ( Section section )

Returns whether the current section is a tapping operation

Parameters
section The section to check for a tapping operation. section is optional and if omitted currentSection will be used.
Returns
Returns true if section is a tapping operation, otherwise returns false
Since
r45845

◆ isTextSupported()

Boolean isTextSupported ( String text )

Returns true if all the characters exist in the given text for the current code page.

◆ isToolChangeNeeded()

Boolean isToolChangeNeeded | ( | Section | section,
 |  | String | arguments
 | ) |  |

Returns whether a tool change is needed, based on the given criteria as arguments.

Parameters
section | The section to determine if a tool change is needed. section is optional and if omitted currentSection will be used. Since r45845
arguments | The function can take any number of string arguments, which are the comparison criteria for the current and previous tools. These can be "number", "description", "diameter", or any other property on the tool object. The tool number is checked if there are no arguments.
Returns
Returns whether a tool change is needed
Since
r45600

◆ isTurning()

Boolean isTurning ( )

Returns true for turning toolpath.

◆ isWellKnownCommand()

Boolean isWellKnownCommand ( Integer command )

Returns true if the specified command is well-known.

◆ isWellKnownCycle()

Boolean isWellKnownCycle ( )

Returns true if the current cycle is a well-known cycle.

◆ isWorkpieceDefined()

Boolean isWorkpieceDefined ( )

Returns true if the workpiece stock is defined.

◆ linearize()

linearize ( Number tolerance )

Linearizes the current motion to the specified tolerance. Use canLinearize() to determine if the current record can be linearized. The start position is not output.

◆ loadLocale()

Boolean loadLocale ( String langId )

Loads the specified locale.

Parameters
langId The language id of the locale file.

◆ loadMachineConfiguration()

MachineConfiguration loadMachineConfiguration ( String path )

Loads the specified machine configuration.

Parameters
path The path of the machine configuration.

◆ loadText()

String loadText | ( | String | url,
 |  | String | encoding
 | ) |  |

Returns the text loaded from the specified url. The url is relative to the configuration script. The file size is limited to 1Mb.

Parameters
url | The url.
encoding | The encoding (ascii, utf-7, utf-8, or utf-16). Alternative you can specify the code page as a string (e.g. 437).

◆ localize()

String localize ( String message )

Returns the localized text for the specified native text if the result is supported in the active code page/encoding. Otherwise the original text is returned.

◆ localize2()

String localize2 | ( | String | section,
 |  | String | message
 | ) |  |

Returns the localized text for the specified native text of the given section if the result is supported in the active code page/ encoding. Otherwise the original text is returned.

◆ log()

log ( String message )

Writes the specified message to the log.

◆ onAcceleration()

onAcceleration | ( | Number | travel,
 |  | Number | printing,
 |  | Number | retract
 | ) |  |

Entry function invoked when the acceleration is changed in an additive FFF toolpath.

Parameters
travel | Travel acceleration. Used for moves that include no extrusion.
printing | Printing acceleration. Used for moves that include extrusion (i.e., which employ the current tool).
retract | Retract acceleration. Used for extruder retraction moves.

◆ onBedTemp()

onBedTemp | ( | Number | temp,
 |  | Boolean | wait
 | ) |  |

Entry function invoked when the bed temperature is changed in an additive FFF toolpath.

Parameters
temp | The target temperature.
wait | If true, wait to reach the desired temperature before continuing.

◆ onCircular()

onCircular | ( | Boolean | clockwise,
 |  | Number | cx,
 |  | Number | cy,
 |  | Number | cz,
 |  | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | feed
 | ) |  |

Entry function for circular motion.

Parameters
clockwise | Specifies that the motion is clockwise.
cx | The X coordinate of the center position.
cy | The Y coordinate of the center position.
cz | The Z coordinate of the center position.
x | The X coordinate of the end position.
y | The Y coordinate of the end position.
z | The Z coordinate of the end position.
feed | The feedrate.

◆ onCircularExtrude()

onCircularExtrude | ( | Boolean | clockwise,
 |  | Number | cx,
 |  | Number | cy,
 |  | Number | cz,
 |  | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | feed,
 |  | Number | extrusionLength
 | ) |  |

Entry function invoked for circular extrusion motion at feed.

Parameters
clockwise | Specifies that the motion is clockwise.
cx | The X coordinate of the center position.
cy | The Y coordinate of the center position.
cz | The Z coordinate of the center position.
x | The X coordinate of the end position.
y | The Y coordinate of the end position.
z | The Z coordinate of the end position.
feed | The feedrate.
extrusionLength | The extrusion length.

◆ onClose()

onClose ( )

Invoked after the last section.

◆ onCommand()

onCommand ( Integer command )

Entry function invoked for well-known commands.

Parameters
command The well-known command.

The known commands are:

  • COMMAND_STOP - Program stop (M00)
  • COMMAND_OPTIONAL_STOP - Optional program stop (M01)
  • COMMAND_END - Program end (M02)
  • COMMAND_SPINDLE_CLOCKWISE - Clockwise spindle direction (M03)
  • COMMAND_SPINDLE_COUNTERCLOCKWISE - Counterclockwise spindle direction (M04)
  • COMMAND_START_SPINDLE - Start spindle M03 (clockwise) or M04 (counterclockwise)
  • COMMAND_STOP_SPINDLE - Stop spindle (M05)
  • COMMAND_ORIENTATE_SPINDLE - Orientate spindle - +X direction by default (M19)
  • COMMAND_LOAD_TOOL - Tool change (M06)
  • COMMAND_COOLANT_ON - Coolant on (M08)
  • COMMAND_COOLANT_OFF - Coolant off (M09)
  • COMMAND_ACTIVATE_SPEED_FEED_SYNCHRONIZATION - Active feed-speed synchronization
  • COMMAND_DEACTIVATE_SPEED_FEED_SYNCHRONIZATION - Deactive feed-speed synchronization
  • COMMAND_LOCK_MULTI_AXIS - Locks the 4th and 5th axes
  • COMMAND_UNLOCK_MULTI_AXIS - Unlocks the 4th and 5th axes
  • COMMAND_EXACT_STOP - Exact stop
  • COMMAND_START_CHIP_TRANSPORT - Close chip transport
  • COMMAND_STOP_CHIP_TRANSPORT - Stop chip transport
  • COMMAND_OPEN_DOOR - Open primary door
  • COMMAND_CLOSE_DOOR - Close primary door
  • COMMAND_BREAK_CONTROL - Break control
  • COMMAND_TOOL_MEASURE - Measure tool
  • COMMAND_CALIBRATE - Run calibration cycle
  • COMMAND_VERIFY - Verify part/tool/machine integrity
  • COMMAND_CLEAN - Run cleaning cycle
  • COMMAND_ALARM - Alarm
  • COMMAND_ALERT - Alert
  • COMMAND_CHANGE_PALLET - Change pallet
  • COMMAND_POWER_ON - Power on
  • COMMAND_POWER_OFF - Power off
  • COMMAND_MAIN_CHUCK_OPEN - Open main chuck
    Since
    r41179
  • COMMAND_MAIN_CHUCK_CLOSE - Close main chuck
    Since
    r41179
  • COMMAND_SECONDARY_CHUCK_OPEN - Open secondary chuck
    Since
    r41179
  • COMMAND_SECONDARY_CHUCK_CLOSE - Close secondary chuck
    Since
    r41179
  • COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_ACTIVATE - Activate spindle synchronization
    Since
    r41179
  • COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_DEACTIVATE - Deactivate spindle synchronization
    Since
    r41179
  • COMMAND_SYNC_CHANNEL - Sync channels
    Since
    r42013
  • COMMAND_PROBE_ON - Probe on
    Since
    r42013
  • COMMAND_PROBE_OFF - Probe off
    Since
    r42013

◆ onComment()

onComment ( String comment )

Entry function for comments.

Parameters
comment The comment.

◆ onCycle()

onCycle ( )

The onCycle() entry function is invoked for each cycle.

◆ onCycleEnd()

onCycleEnd ( )

The onCycleEnd() entry function is invoked on cycle termination.

◆ onCyclePath()

onCyclePath ( )

The onCyclePath() entry function is invoked at the beginning of cycle toolpath.

◆ onCyclePathEnd()

onCyclePathEnd ( )

The onCyclePathEnd() entry function is invoked at the ending of cycle toolpath.

◆ onCyclePoint()

onCyclePoint | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

onCyclePoint() is the entry function for cycle positions. The function expands all well-known cycles by default. The specified position is the center of the hole for drilling or equivalent cycles. You should always use cycle.bottom as the bottom coordinate if defined.

Parameters
x | The x coordinate for the drill position.
y | The y coordinate for the drill position.
z | The z coordinate for the drill position.

◆ onDwell()

onDwell ( Number time )

Entry function invoked for dwelling.

Parameters
time The dwelling time in seconds.

◆ onExpandedLinear()

onExpandedLinear | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | feed
 | ) |  |

onExpandedLinear() calls the onLinear() entry function and lets the post processor know that the current position has changed at the same time. You should generally not call onLinear() directly.

◆ onExpandedRapid()

onExpandedRapid | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

onExpandedRapid() calls the onRapid() entry function and lets the post processor know that the current position has changed at the same time. You should generally not call onRapid() directly.

◆ onExpandedSpindleSpeed()

onExpandedSpindleSpeed ( Number spindleSpeed )

onExpandedSpindleSpeed() calls the onSpindleSpeed() entry function and lets the post processor know that the current spindle speed has changed at the same time. You should generally not call onSpindleSpeed() directly.

◆ onExtruderChange()

onExtruderChange ( Number extruderId )

Entry function invoked when the extruder is changed in an additive FFF toolpath.

Parameters
extruderId The id of the extruder to change to.

◆ onExtruderTemp()

onExtruderTemp | ( | Number | temp,
 |  | Boolean | wait,
 |  | Integer | extruderId
 | ) |  |

Entry function invoked when the extruder temperature is changed in an additive FFF toolpath.

Parameters
temp | The target temperature.
wait | If true, wait to reach the desired temperature before continuing.
extruderId | The extruder id.

◆ onExtrusionReset()

onExtrusionReset ( Number length )

Entry function invoked when the extrusion length is reset in an additive FFF toolpath.

Parameters
length The extrusion length.

◆ onFanSpeed()

onFanSpeed | ( | Number | speed,
 |  | Integer | fanId
 | ) |  |

Entry function invoked when the fan speed is changed in an additive FFF toolpath.

Parameters
speed | The fan speed.
fanId | The fan id.

◆ onImpliedCommand()

onImpliedCommand ( Integer command )

Invoke this method to tell the post processor about state changes without triggering invocation of onCommand(). This method must be invoked when a state doesn't originate from an invocation of an entry function. If this method is not invoked the post processor may not know certain current state (e.g. whether the coolant is active). For instance, the state is important when the post processor is asked to expand cycles.

◆ onJerk()

onJerk | ( | Number | xAxis,
 |  | Number | yAxis,
 |  | Number | zAxis,
 |  | Number | eAxis
 | ) |  |

Entry function invoked when the axis jerk is changed in an additive FFF toolpath.

Parameters
xAxis | The X axis jerk.
yAxis | The Y axis jerk.
zAxis | The Z axis jerk.
eAxis | The E axis jerk.

◆ onLayer()

onLayer ( Number layerNumber )

Entry function invoked at the start of a layer in an additive FFF toolpath.

Parameters
layerNumber The layer number.

◆ onLinear()

onLinear | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | feed
 | ) |  |

Entry function invoked for linear motion at feed.

Parameters
x | The X coordinate of the end position.
y | The Y coordinate of the end position.
z | The Z coordinate of the end position.
feed | The feedrate.

◆ onLinear5D()

onLinear5D | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | dx,
 |  | Number | dy,
 |  | Number | dz,
 |  | Number | feed
 | ) |  |

Entry function invoked for linear 5-axis motion at feed. The tool axis may also be returned in machine angles depending on the mode in accordance with the active machine configuration.

Parameters
x | The x coordinate of the position.
y | The y coordinate of the position.
z | The z coordinate of the position.
dx | The dx coordinate of the tool axis direction.
dy | The dy coordinate of the tool axis direction.
dz | The dz coordinate of the tool axis direction.
feed | The feedrate.

◆ onLinearExtrude()

onLinearExtrude | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | feed,
 |  | Number | extrusionLength
 | ) |  |

Entry function invoked for linear extrusion motion at feed.

Parameters
x | The X coordinate of the end position.
y | The Y coordinate of the end position.
z | The Z coordinate of the end position.
feed | The feedrate.
extrusionLength | The extrusion length.

◆ onMachine()

onMachine ( )

Invoked during post processing when the machine configuration changes.

◆ onMaxAcceleration()

onMaxAcceleration | ( | Number | xAxis,
 |  | Number | yAxis,
 |  | Number | zAxis,
 |  | Number | eAxis
 | ) |  |

Entry function invoked when the max axis acceleration is changed in an additive FFF toolpath.

Parameters
xAxis | The X axis max acceleration.
yAxis | The Y axis max acceleration.
zAxis | The Z axis max acceleration.
eAxis | The E axis max acceleration.

◆ onMovement()

onMovement ( Integer movement )

Entry function invoked when the movement type changes.

◆ onMoveToSafeRetractPosition()

onMoveToSafeRetractPosition ( )

Entry function invoked during a machine rewind procedure. It needs to output the code for retracting to safe position before indexing rotaries(usually a retract in Z).

Since
r45400

◆ onOpen()

onOpen ( )

Invoked during initialization before the first section.

◆ onOrientateSpindle()

onOrientateSpindle ( Number angle )

This function must set the spindle orientation. The function may be invoked when expanding cycles.

Parameters
angle The requested spindle orientation.

◆ onParameter()

onParameter | ( | String | name,
 |  | Value | value
 | ) |  |

Parameter entry function.

Parameters
name | The name of the parameter.
value | The value of the parameter.

◆ onPassThrough()

onPassThrough ( Value value )

Pass-through entry function.

Parameters
value The value.

◆ onPower()

onPower ( Boolean power )

Entry function invoked when the power mode changes (used for water jet, laser cutter, and plasma cutter).

◆ onRadiusCompensation()

onRadiusCompensation ( )

Entry function invoked when the radius compensation mode changes.

◆ onRapid()

onRapid | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

Entry function invoked for linear motion at rapid traverse.

Parameters
x | The X coordinate of the end position.
y | The Y coordinate of the end position.
z | The Z coordinate of the end position.

◆ onRapid5D()

onRapid5D | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | dx,
 |  | Number | dy,
 |  | Number | dz
 | ) |  |

Entry function invoked for linear rapid 5-axis motion at rapid traverse. The tool axis may also be returned in machine angles depending on the mode in accordance with the active machine configuration.

Parameters
x | The x coordinate of the position.
y | The y coordinate of the position.
z | The z coordinate of the position.
dx | The dx coordinate of the tool axis direction.
dy | The dy coordinate of the tool axis direction.
dz | The dz coordinate of the tool axis direction.

◆ onReturnFromSafeRetractPosition()

onReturnFromSafeRetractPosition | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

Entry function invoked during a machine rewind procedure. It needs to output the code for returning from safe position after indexing rotaries.

Parameters
x | The X coordinate to return to.
y | The Y coordinate to return to.
z | The Z coordinate to return to.
Since
r45400

◆ onRewindMachine()

onRewindMachine | ( | Number | a,
 |  | Number | b,
 |  | Number | c
 | ) |  |

DEPRECATED. Entry function invoked for 5-axis motion when machine axis rewind is required.

Parameters
a | The A coordinate of the machine orientation.
b | The B coordinate of the machine orientation.
c | The C coordinate of the machine orientation.

◆ onRewindMachineEntry()

onRewindMachineEntry | ( | Number | a,
 |  | Number | b,
 |  | Number | c
 | ) |  |

Entry function invoked for 5-axis motion when machine axis rewind is required. This is called before performing a machine rewind in the kernel, as onRewindMachine() is now deprecated.

Parameters
a | The A coordinate of the machine orientation.
b | The B coordinate of the machine orientation.
c | The C coordinate of the machine orientation.
Returns
True if we don't want the kernel to perform the machine rewind, False otherwise.
Since
r45400

◆ onRotateAxes()

onRotateAxes | ( | Number | x,
 |  | Number | y,
 |  | Number | z,
 |  | Number | a,
 |  | Number | b,
 |  | Number | c
 | ) |  |

Entry function invoked during a machine rewind procedure. It needs to output the code for rotating the axes to new position above re-entry position.

Parameters
x | The X coordinate to rotate to.
y | The Y coordinate to rotate to.
z | The Z coordinate to rotate to.
a | The A coordinate to rotate to.
b | The B coordinate to rotate to.
c | The C coordinate to rotate to.
Since
r45400

◆ onSectionEnd()

onSectionEnd ( )

Entry function invoked at the end of each section.

◆ onSpindleSpeed()

onSpindleSpeed ( Number spindleSpeed )

Entry function invoked for spindle speed changes.

Parameters
spindleSpeed The spindle speed in RPM.

◆ onToolCompensation()

onToolCompensation ( Integer compensation )

Entry function invoked when the tool compensation changes. Only used for specific tool types for which dual compensation is defined.

◆ onUnsupportedCommand()

onUnsupportedCommand ( Integer command )

Writes an error message for the specified command.

◆ onUnsupportedCoolant()

onUnsupportedCoolant ( Integer coolant )

Writes an error message for the specified coolant.

◆ openUrl()

openUrl ( String url )

Opens the specified url.

◆ optimizeMachineAngles()

optimizeMachineAngles ( )

Optimizes the machine angles for 5-axis motion using the active machine configuration. The tool tip position is maintained (TCPM).

The directions for onRapid5D() and onLinear5D() are hereafter mapped to machine angles from the initial direction vector. The work plane and origin are mapped into the WCS plane and origin.

◆ optimizeMachineAngles2()

optimizeMachineAngles2 ( Integer optimizeType )

Optimizes the machine angles for 5-axis motion using the active machine configuration.

optimizeType options are:

  1. OPTIMIZE_NONE: Maintain tool tip position (TCPM).
  2. OPTIMIZE_BOTH: Map tool tip position.
  3. OPTMIZE_TABLES: Map tool tip position for machine axes for tables only.
    Since
    r41179
  4. OPTMIZE_HEADS: Map tool tip position for machine axes for heads only.
    Since
    r45270
  5. OPTMIZE_AXIS: Map tool tip position for machine axes per the Axis definition.
    Since
    r45270
    The directions for onRapid5D() and onLinear5D() are hereafter mapped to machine angles from the initial direction vector. The work plane and origin are mapped into the WCS plane and origin.

◆ optimizeMachineAnglesByMachine()

optimizeMachineAnglesByMachine | ( | MachineConfiguration | machine,
 |  | Integer | optimizeType
 | ) |  |

Optimizes the machine angles for 5-axis motion given the specified machine configuration.

The directions for onRapid5D() and onLinear5D() are hereafter mapped to machine angles from the initial direction vector. The work plane and origin are mapped into the WCS plane and origin.

Parameters
machine The machine configuration.
optimizeType Can be one of the following values.
  1. OPTIMIZE_NONE: Maintain tool tip position (TCPM).
  2. OPTIMIZE_BOTH: Map tool tip position.
  3. OPTMIZE_TABLES: Map tool tip position for machine axes for tables only.
Since
r41179
  1. OPTMIZE_HEADS: Map tool tip position for machine axes for heads only.
r45270
  1. OPTMIZE_AXIS: Map tool tip position for machine axes per the Axis definition.
r45270

◆ parseSpatial()

Number parseSpatial ( String & value )

Returns the given value and spatial unit in the current spatial unit.

The value can start with a sign (+ or -) followed by the digits and decimal ('.') and end with the unit.

The supported units are: yd, ft, in, mil or mils, thou, m, cm, mm, um, nm

yd = 3 ft ft = 12 in in = 1000 mil in = 1000 thou

m = 100 cm cm = 10 mm mm = 1000 um um = 1000 nm

◆ printDocument()

Boolean printDocument ( String path )

Prints the specified document. Note that you cannot open the primary output file until the onTerminate() is invoked. The document type must have the "print" command registered in the Windows Registry.

Parameters
path The path of the document.
Returns
Returns true on success.
printDocument("C:\\myfile.html");

◆ printDocumentTo()

Boolean printDocumentTo | ( | String | path,
 |  | String | printerName
 | ) |  |

Prints the specified document. Note that you cannot open the primary output file until the onTerminate() is invoked. The document type must have the "printto" command registered in the Windows Registry. If the "printto" command is not registered for a given document type you can sometimes print using the execute() function by referrencing the proper application and parsing appropriate parameters.

Parameters
path | The path of the document.
printerName | The printer name.
Returns
Returns true on success.
printDocumentTo("C:\\myfile.doc", "\"Microsoft XPS Document Writer\"");

◆ promptKey()

String promptKey | ( | String | title,
 |  | String | description
 | ) |  |

Waits for the user to hit a key. In console mode ESC or RETURN cancels. Not supported in graphical user interaction mode.

Parameters
title | The title.
description | The description.
Returns
Returns the empty string on cancel. Always returns the lower case character.

◆ promptKey2()

String promptKey2 | ( | String | title,
 |  | String | description,
 |  | String | accept
 | ) |  |

Waits for the user to hit a key. In console mode ESC or RETURN cancels or returns the first character in the accept string. The following accept modes are available in graphical user interface:

  1. YN: Yes/No
  2. YNC: Yes/No/Cancel
  3. RC: Retry/Cancel
  4. OC: Ok/Cancel
  5. ARI: Abort/Retry/Ignore
Parameters
title | The title.
description | The description.
accept | The allowed characters. Case is ignored. The first character in the string is the default.
Returns
Returns the empty string on cancel. Always returns the lower case character.

◆ promptKey3()

String promptKey3 | ( | String | title,
 |  | String | description,
 |  | String | accept,
 |  | String | keys
 | ) |  |

Waits for the user to hit a key. In console mode ESC or RETURN cancels or returns the first character in the accept string. The following accept modes are available in graphical user interface:

  1. YN: Yes/No
  2. YNC: Yes/No/Cancel
  3. RC: Retry/Cancel
  4. OC: Ok/Cancel
  5. ARI: Abort/Retry/Ignore
Parameters
title | The title.
description | The description.
accept | The allowed answers. Case is ignored. The first character in the string is the default.
keys | The allowed characters used in console mode. Case is ignored. The first character in the string is the default.
Returns
Returns the empty string on cancel. Always returns the lower case character.

◆ promptText()

String promptText | ( | String | title,
 |  | String | description
 | ) |  |

Waits for user to enter a text string. Not supported in graphical user interface mode.

Returns
Returns the empty string on cancel.

◆ range()

Array range | ( | Number | first,
 |  | Number | end,
 |  | Number | step
 | ) |  |

Returns an array with values in the requested range.

range(end) range(first, end) range(first, end, step)

range(); returns []
range(5); // returns [0, 1, 2, 3, 4]
range(10, 15); // returns [10, 11, 12, 13, 14]
range(10, 15, 2); // returns [10, 12, 14]
range(15, 10, -1); // returns [15, 14, 13, 12, 11]
for (var value in range(-10, -20, -1) { // output -10 to -19
writeln(value);
}

◆ redirectToBuffer()

redirectToBuffer ( )

Redirects the output to the global buffer. Use getRedirectionBuffer() to access the current buffer content. Use getRedirectionBuffer2() to clear the buffer during redirection. Close redirection again using closeRedirection().

◆ redirectToFile()

redirectToFile ( String path )

Redirects output to the specified file.

Security: Requires security level 0.

Attention
The file is overwritten if it already exists.
function onSection() {
var fileIndexFormat = createFormat({width:3, zeropad: true, decimals:0});
var path = FileSystem.replaceExtension(getOutputPath(), "-" +
fileIndexFormat.format(getCurrentSectionId()) + ".nc"); redirectToFile(path);
}
function onSectionEnd() {
closeRedirection();
}

◆ registerPostProcessing()

registerPostProcessing ( String path )

Registers post processing of the output file using the specified executable.

◆ registerTerminationHandler()

registerTerminationHandler ( Function function )

Registers a termination handler to be called after onTerminate(). The termination handlers are called in the opposite order of registration.

Parameters
function The termination handler. Must be a function.
Since
41664

◆ repositionToCycleClearance()

repositionToCycleClearance | ( | Map | cycle,
 |  | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

Repositions to cycle clearance plane. Attention: The tool is not moved over the hole if not required. The spindle axis must be along the Z-axis.

Parameters
cycle | The cycle parameters.
x | The X position of the cycle.
y | The Y position of the cycle.
z | The Z position of the cycle.

◆ setCascadingPath()

setCascadingPath ( String )

Sets the path used as the primary source for a cascading post. By default this will be the getOutputPath(). A cascading post is a specific post that takes as input the output from a previous post. The cascading post is run after the onTerminate() entry function.

Since
41546

◆ setCodePage()

setCodePage ( String name )

Sets the output code page.

The code page can be changed at any time but using different code pages in the same text file does normally not make sense. For binary output it can be relevant in some cases.

◆ setCurrentABC()

setCurrentABC ( Vector abc )

Called to pass the current machine angles back to the post engine.

This function allows machine angles chosen in a post script to be passed back to the post engine. This is used to drive simulation and should accompany calls to setRotation().
The machine angles set by this function will be cleared by a call to cancelRotation() or cancelTransformation()

Parameters
abc A vector representing the machine axis angles where a, b, and c map to the vector's x, y, and z respectively.
Since
r45672

◆ setCurrentDirection()

setCurrentDirection ( Vector currentDirection )

Sets the current direction.

◆ setCurrentPosition()

setCurrentPosition ( Vector currentPosition )

Sets the current position.

◆ setCurrentPositionAndDirection()

setCurrentPositionAndDirection ( VectorPair posDir )

Call to set the current position and direction at the same time.

Parameters
posDir A pair of vectors containing the position and direction wanting to be set.
Since
r45635

◆ setCurrentPositionX()

setCurrentPositionX ( Number x )

Sets only the current X position.

◆ setCurrentPositionY()

setCurrentPositionY ( Number y )

Sets only the current Y position.

◆ setCurrentPositionZ()

setCurrentPositionZ ( Number z )

Sets only the current Z position.

◆ setCurrentSpindleSpeed()

setCurrentSpindleSpeed ( Number spindleSpeed )

Sets the current spindle speed.

Since
r42066

◆ setDogLeg()

setDogLeg ( Boolean dogLeg )

Sets the dog-leg style. 3-axis rapid traversal will be substituted with dog-leg style rapid traversal when this flag is set to true.

◆ setEOL()

setEOL ( String eol )

Sets the EOL style. Windows EOL style CRLF is the default.

Parameters
eol The EOL to use. Only these are allowed CR, LF, CRLF, and LFCR.

◆ setExitCode()

setExitCode ( Integer code )

Sets the desired exit code. The default exit code is usually fine. The behavior is unspecified if the exit code is not a value in the range [1000; 1999].

◆ setHighFeedMapping()

setHighFeedMapping ( Integer mode )

Sets the high feed rapid traversal mapping mode.

See HIGH_FEED_NO_MAPPING, HIGH_FEED_MAP_MULTI, HIGH_FEED_MAP_XY_Z, and HIGH_FEED_MAP_ANY.

◆ setHighFeedrate()

setHighFeedrate ( Number feedrate )

Sets the high feedrate used for mapping rapid traversal.

◆ setMachineConfiguration()

setMachineConfiguration ( MachineConfiguration machine )

Sets the active machine configuration.

Parameters
machine The new machine configuration.

◆ setOutputUnit()

setOutputUnit ( Integer unit )

Sets the output unit.

◆ setProperty()

setProperty | ( | ScriptObject | property,
 |  | Value | value
 | ) |  |

Sets the value of the specified post property. The specified property must exist.

Parameters
property | The property object or the property name.
value | The new value of the property.

e.g.

setProperty(properties.propName, newValue);
setProperty("propName", newValue);
Since
r45811

◆ setRotation()

setRotation ( Matrix rotation )

Sets the rotation. This is normally used for rotating around the tool axis.

◆ setSectionSpecialCycle()

setSectionSpecialCycle | ( | String | uri,
 |  | Boolean | specialCycle
 | ) |  |

Tells the post processor to call onSectionSpecialCycle()/onSectionEndSpecialCycle() instead of onSection()/onSectionEnd() for sections starting with the given cycle.

Parameters
uri | The unique identifier of the cycle.
specialCycle | Indicates if the cycle should be considered special. Set to false to remove a built-in special cycles.
Since
r41185

◆ setTranslation()

setTranslation ( Vector translation )

Sets the translation.

◆ setWordSeparator()

setWordSeparator ( String message )

Sets the separator for word-based line output. Defaults to a space (i.e. " ").

◆ setWriteInvocations()

setWriteInvocations ( Boolean writeInvocations )

Specifies that the entry function should be written.

◆ setWriteStack()

setWriteStack ( Boolean writeStack )

Specifies that a stack dump should be written when text is output by the post processor.

◆ skipRemainingSection()

skipRemainingSection ( )

Tells the post processor to skip the remaining of the current section. onSectionEnd() will still be invoked.

◆ spatial()

Number spatial | ( | Number | value,
 |  | Integer | unit
 | ) |  |

Returns the specified spatial value and unit in the internal unit.

Note: IN values are scaled with 25 relative to MM.

Parameters
value | The value.
unit | The unit of the value.

◆ subst()

String subst | ( | String | message,
 |  |  | ...
 | ) |  |

Returns a new string with the named substrings of the first argument substituted by the specified arguments. This method supports up to 16 arguments.

subst("My first name is %1 and last name is %2", "John", "Doe"); // returns "My first name is
John and last name is Doe"

◆ toDeg()

Number toDeg ( Number radians )

Returns the specified angle in degrees.

Parameters
radians the angle in radians

◆ toolZRange()

Range toolZRange ( )

Returns the Z range for the currently active tool, for the current and upcoming consecutive sections that use this tool. Returns undefined if the tool does not have a Z axis (e.g. on 2D operations).

Returns
Returns the Range for the tool's Z axis.
Since
r45600

◆ toRad()

Number toRad ( Number degrees )

Returns the specified angle in radians.

Parameters
degrees the angle in degrees.

◆ translateText()

String translateText | ( | String | text,
 |  | String | src,
 |  | String | dest
 | ) |  |

Translates the specified string into a new string. The characters in src will be mapped to the character at the same index in dest.

Parameters
text | The original text.
src | The chars to be mapped.
dest | The destination characters.

◆ validate()

validate | ( | Value | expression,
 |  | String | message
 | ) |  |

Raises an exception if the expression is false. Use this function to make sure that you have protected your code against invalid cases.

Parameters
expression | The boolean expression.
message | Optional description of the constraint.
var feedVariable = createVariable({prefix:" F"}, createFormat({decimals:0, separator:","}));
function doSomething(feed) {
validate(feed > 0, localize("Feedrate must be greater than 0."));
return feedVariable.format(feed);
}

◆ validateProperties()

Boolean validateProperties ( )

Returns true if all user defined properties are valid according to the property definitions.

◆ validatePropertyDefinitions()

Boolean validatePropertyDefinitions ( )

Validates the property definitions.

◆ warning()

warning ( String message )

Writes a warning.

◆ warningOnce()

warningOnce | ( | String & | message,
 |  | Integer | id
 | ) |  |

Writes the specified warning if the given warning id has not been used before.

◆ write()

write ( String message )

Writes the specified text to the NC output file excluding an end-of-line marker.

◆ writeln()

writeln ( String message )

Writes the specified text to the NC output file including an end-of-line marker.

◆ writeSectionNotes()

writeSectionNotes ( )

Writes the notes for the current section as comments.

Since
r45600

◆ writeSetupNotes()

writeSetupNotes ( )

Writes the notes for the current setup as comments.

Since
r45600

◆ writeToolTable()

writeToolTable ( Integer orderBy )

Prints the tool table.

Parameters
orderBy An enum of the column to order the table by. It can be:
  • TOOL_NUMBER_COL
  • DIAMETER_COL
  • CORNER_RADIUS_COL
  • TAPER_COL
  • ZMIN_COL
  • DESCRIPTION_COL
  • TOOL_TABLE_NUM_COLS
Since
r45600

◆ writeWords()

writeWords | ( | String | message,
 |  |  | ...
 | ) |  |

Writes the specified words to the NC output file including an end-of-line marker using the word separator (see getWordSeparator() and setWordSeparator()). Empty strings or undefined values are ignored. No line is output for completely empty lines.

setWordSeparator(", ");
writeWords("first", "second", "third"); // writes "first, second, third" on a new line
writeWords(["first", "second"], "third"); // writes "first, second, third" on a new line
function writeBlock() {
writeWords("first", arguments);
}
writeBlock("second", "third"); // writes "first, second, third" on a new line
writeBlock(""); // writes "first" on a new line
writeBlock(undefined); // writes "first" on a new line

◆ writeWords2()

writeWords2 | ( | String | message,
 |  |  | ...
 | ) |  |

This method is similar to writeWords() with the exception that text is only output if the 2 argument or above results in text.

This function is useful when outputting block numbers to avoid output.

function writeBlock() {
if (properties.showSequenceNumbers) {
writeWords2("N" + sequenceNumber, arguments);
sequenceNumber += properties.sequenceNumberIncrement;
} else {
writeWords(arguments);
}
}

Member Data Documentation

◆ abortOnDeprecation

Boolean abortOnDeprecation

This property specifies that the post processing should be aborted if the post processor is deprecated. Defaults to true.

Specifies that the post processing should be aborted if the post processor has been deprecated.

◆ allowedCircularPlanes

Integer allowedCircularPlanes

Specifies the allowed circular planes to be output. Set to 0 to linearize all circular motion and undefined to allow any motion. Circular motion in disabled planes will be output as linear motion using the globally specified tolerance. allowedCircularPlanes is a bit mask. PLANE_XY, PLANE_ZX, and PLANE_YZ can be used for accessing the appropriate bits. Handling all planes in onCircular() gives more flexibility with regard to the used tolerances.

allowedCircularPlanes = 0; // disable all circular planes
allowedCircularPlanes = undefined; // allow all circular planes
allowedCircularPlanes = (1 << PLANE_XY) | (1 << PLANE_ZX) | (1 << PLANE_YZ); // only XY, ZX,
and YZ planes

◆ allowHelicalMoves

Boolean allowHelicalMoves

Specifies that helical motion is allowed. The helical motion is linearized if false.

◆ allowMachineChangeOnSection

Boolean allowMachineChangeOnSection

Specifies that the machine configuration may change during post processing when no machine configuration is defined in the post configuration. Only one machine configuration is allowed by default when they are defined/embedded in the toolpath. This property must be set to true to allow multiple machines to be defined during post processing in which case the machine configuration will become active on onSection() calls. Any machine configuration defined in the post configuration always takes precedence.

◆ allowSpiralMoves

Boolean allowSpiralMoves

Specifies that spiral motion is allowed (i.e. the start and end radii are different). The spiral motion is linearized if false.

◆ capabilities

Integer capabilities

Specifies the capability flags. CAPABILITY_MILLING, CAPABILITY_TURNING, CAPABILITY_JET, CAPABILITY_SETUP_SHEET, CAPABILITY_INTERMEDIATE, and CAPABILITY_CASCADING. The default is "CAPABILITY_MILLING".

◆ certificationLevel

Integer certificationLevel

Certification level of the post configuration. The post configuration must always use the property certificationLevel to set its certification level. The level should never be set higher than the current certification level of the post processor. The level defaults to 1 for all configurations. A warning will be output if the certication level of the post configuration is less than the level required by the post processor. This ensures that users will be notified when post configurations may not run properly in future releases of the post processor. The certification level of the post processor is rarely incremented.

The current certification level is 2.

◆ COMMAND_MAIN_CHUCK_CLOSE

Integer COMMAND_MAIN_CHUCK_CLOSE

Close main chuck.

Since
r41179

◆ COMMAND_MAIN_CHUCK_OPEN

Integer COMMAND_MAIN_CHUCK_OPEN

Open main chuck.

Since
r41179

◆ COMMAND_ORIENTATE_SPINDLE

Integer COMMAND_ORIENTATE_SPINDLE

Orientate spindle direction (well-known command M19). The property machineParameters.spindleOrientation must be set to the machine spindle orientation.

◆ COMMAND_SECONDARY_CHUCK_CLOSE

Integer COMMAND_SECONDARY_CHUCK_CLOSE

Close secondary chuck.

Since
r41179

◆ COMMAND_SECONDARY_CHUCK_OPEN

Integer COMMAND_SECONDARY_CHUCK_OPEN

Open secondary chuck.

Since
r41179

◆ COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_ACTIVATE

Integer COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_ACTIVATE

Activate spindle synchronization.

Since
r41179

◆ COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_DEACTIVATE

Integer COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_DEACTIVATE

Deactivate spindle synchronization.

Since
r41179

◆ COMMAND_START_SPINDLE

Integer COMMAND_START_SPINDLE

Spindle start (well-known command M03 or M04). This is a virtual command which maps to either COMMAND_SPINDLE_CLOCKWISE or COMMAND_SPINDLE_COUNTERCLOCKWISE dependent on the current spindle direction.

◆ currentSection

Section currentSection

The current section. This property is unspecified outside onSection() and onSectionEnd() invocations.

◆ cycle

Map cycle

Specifies the current cycle parameters in canned cycle mode.

◆ cycleExpanded

Boolean cycleExpanded

Specifies that a previous cycle point has been expended for the current cycle. Defaults to false.

◆ cycleType

String cycleType

Specifies the type of the current cycle in canned cycle mode.

◆ debugMode

Boolean debugMode

Specifies the debugging mode.

◆ deprecated

Boolean deprecated

Specifies that this version of the engine has been deprecated.

◆ description

String description

Description for the post processor configuration.

◆ end

Vector end

The end position of the current motion.

◆ extension

String extension

The default output extension (defaults to 'nc').

◆ feedrate

Number feedrate

The current feedrate.

◆ filename

String filename

The default filename (defaults to program name).

◆ HIGH_FEED_MAP_XY_Z

Integer HIGH_FEED_MAP_XY_Z

Map rapid travesal not in the X-Y plane or along the Z-axis to high feed.

◆ highFeedMapping

Integer highFeedMapping

Specifies the high feed mapping mode for rapid traversal.

◆ highFeedrate

Number highFeedrate

Specifies the high feedrate for rapid traversal to high feed mapping.

◆ initialCyclePosition

Vector initialCyclePosition

The initial cycle position.

◆ legal

String legal

Legal comment for the post processor configuration.

◆ length

Number length

The length of the current motion.

◆ lineNumber

Integer lineNumber

Specifies the line number in the source document. Will be 0 if the line number is unknown.

◆ machineConfiguration

MachineConfiguration machineConfiguration

The machine configuration.

◆ machineParameters

MachineParameters machineParameters

Machine parameters.

◆ mapToWCS

Boolean mapToWCS

Specifies that the section work plane should be mapped to the WCS. When disabled the post is responsible for handling the WCS and section work plane. By default this is enabled.

This is a special variable, and, therefore, it should be put in a comment, as per example.

// mapToWCS = false;

◆ mapWorkOrigin

Boolean mapWorkOrigin

Specifies that the section origin should be mapped to (0, 0, 0). When disabled the post is responsible for handling the section origin. By default this is enabled.

This is a special variable, and, therefore, it should be put in a comment, as per example.

// mapWorkOrigin = false;

◆ maximumCircularRadius

Number maximumCircularRadius

The maximum circular radius.

◆ maximumCircularSweep

Number maximumCircularSweep

The maximum circular sweep in radians.

◆ minimumChordLength

Number minimumChordLength

The minimum chord length. Not used for full circle motion.

◆ minimumCircularRadius

Number minimumCircularRadius

The minimum circular radius.

◆ minimumCircularSweep

Number minimumCircularSweep

The minimum circular sweep in radians.

◆ minimumRevision

Integer minimumRevision

Specifies the minimum allowed revision of the post processor (defaults to 1).

◆ movement

Integer movement

The current movement type. The supported types are: MOVEMENT_RAPID, MOVEMENT_LEAD_IN, MOVEMENT_CUTTING, MOVEMENT_LEAD_OUT, MOVEMENT_LINK_TRANSITION, MOVEMENT_LINK_DIRECT, MOVEMENT_RAMP_HELIX, MOVEMENT_RAMP_PROFILE, MOVEMENT_RAMP_ZIG_ZAG, MOVEMENT_RAMP, MOVEMENT_PLUNGE, MOVEMENT_PREDRILL, MOVEMENT_FINISH_CUTTING, MOVEMENT_REDUCED, and MOVEMENT_HIGH_FEED.

◆ outputUnit

Integer outputUnit

Specifies the output unit. Set to -1 to use original unit.

◆ plane

Integer plane

The circular plane of the current circular motion (PLANE_INVALID for non-primary planes).

◆ preventPost

Boolean preventPost

Denies post processing.

◆ programName

String programName

The program name.

◆ programNameIsInteger

Boolean programNameIsInteger

Specifies that the program name must be an integer.

◆ properties

Map properties

User-defined properties.

◆ radiusCompensation

Integer radiusCompensation

The current radius compensation mode. The modes are: RADIUS_COMPENSATION_OFF, RADIUS_COMPENSATION_LEFT, and RADIUS_COMPENSATION_RIGHT.

The current radius compensation. Defaults to RADIUS_COMPENSATION_OFF.

◆ revision

Integer revision

Specifies the revision of the post processor.

◆ SINGULARITY_LINEARIZE_LINEAR

Integer SINGULARITY_LINEARIZE_LINEAR

Keep top of tool in line with tool axis during multi-axis singularity linearization.

Since
41535

◆ SINGULARITY_LINEARIZE_OFF

Integer SINGULARITY_LINEARIZE_OFF

Don't linearize moves around multi-axis singularities.

Since
41535

◆ SINGULARITY_LINEARIZE_ROTARY

Integer SINGULARITY_LINEARIZE_ROTARY

Keep rotary axes in line during multi-axis singularity linearization.

Since
41535

◆ spindleAxis

Integer spindleAxis

The spindle axis. Defaults to TOOL_AXIS_Z.

◆ spindleSpeed

Number spindleSpeed

The current spindle speed in RPM. Positive for clockwise direction.

◆ tolerance

Number tolerance

Linearization tolerance.

◆ tool

Tool tool

The current tool.

◆ unit

Integer unit

The output unit (defaults to the specified measurement system in the regional settings).

◆ vendor

String vendor

The vendor of the post processor configuration.

◆ vendorUrl

String vendorUrl

The vendor url of the post processor configuration.

◆ version

String version

Specifies the configuration version (defaults to '1.0').


Member List

PostProcessor Member List

This is the complete list of members for PostProcessor, including all inherited members.

A PostProcessor
ABC PostProcessor
abortOnDeprecation PostProcessor
ACK PostProcessor
activatePolarMode(Number tolerance, Number currentAngle, Vector polarDirection) | PostProcessor
alert(String title, String description) | PostProcessor
allowedCircularPlanes PostProcessor
allowHelicalMoves PostProcessor
allowMachineChangeOnSection PostProcessor
allowSpiralMoves PostProcessor
B PostProcessor
BEL PostProcessor
BS PostProcessor
C PostProcessor
CAN PostProcessor
cancelRotation() PostProcessor
cancelTransformation() PostProcessor
cancelTranslation() PostProcessor
canIgnoreCommand(Integer command) | PostProcessor
canLinearize() PostProcessor
capabilities PostProcessor
center PostProcessor
certificationLevel PostProcessor
chordLength PostProcessor
clockwise PostProcessor
closeRedirection() PostProcessor
COMMAND_ACTIVATE_SPEED_FEED_SYNCHRONIZATION PostProcessor
COMMAND_ALARM PostProcessor
COMMAND_ALERT PostProcessor
COMMAND_BREAK_CONTROL PostProcessor
COMMAND_CALIBRATE PostProcessor
COMMAND_CHANGE_PALLET PostProcessor
COMMAND_CLEAN PostProcessor
COMMAND_CLOSE_DOOR PostProcessor
COMMAND_COOLANT_OFF PostProcessor
COMMAND_COOLANT_ON PostProcessor
COMMAND_DEACTIVATE_SPEED_FEED_SYNCHRONIZATION PostProcessor
COMMAND_END PostProcessor
COMMAND_EXACT_STOP PostProcessor
COMMAND_INVALID PostProcessor
COMMAND_LOAD_TOOL PostProcessor
COMMAND_LOCK_MULTI_AXIS PostProcessor
COMMAND_MAIN_CHUCK_CLOSE PostProcessor
COMMAND_MAIN_CHUCK_OPEN PostProcessor
COMMAND_OPEN_DOOR PostProcessor
COMMAND_OPTIONAL_STOP PostProcessor
COMMAND_ORIENTATE_SPINDLE PostProcessor
COMMAND_POWER_OFF PostProcessor
COMMAND_POWER_ON PostProcessor
COMMAND_PROBE_OFF PostProcessor
COMMAND_PROBE_ON PostProcessor
COMMAND_SECONDARY_CHUCK_CLOSE PostProcessor
COMMAND_SECONDARY_CHUCK_OPEN PostProcessor
COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_ACTIVATE PostProcessor
COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_DEACTIVATE PostProcessor
COMMAND_SPINDLE_CLOCKWISE PostProcessor
COMMAND_SPINDLE_COUNTERCLOCKWISE PostProcessor
COMMAND_START_CHIP_TRANSPORT PostProcessor
COMMAND_START_SPINDLE PostProcessor
COMMAND_STOP PostProcessor
COMMAND_STOP_CHIP_TRANSPORT PostProcessor
COMMAND_STOP_SPINDLE PostProcessor
COMMAND_SYNC_CHANNELS PostProcessor
COMMAND_TOOL_MEASURE PostProcessor
COMMAND_UNLOCK_MULTI_AXIS PostProcessor
COMMAND_VERIFY PostProcessor
conditional(condition, value) | PostProcessor
COOLANT_AIR PostProcessor
COOLANT_AIR_THROUGH_TOOL PostProcessor
COOLANT_DISABLED PostProcessor
COOLANT_FLOOD PostProcessor
COOLANT_FLOOD_MIST PostProcessor
COOLANT_FLOOD_THROUGH_TOOL PostProcessor
COOLANT_MIST PostProcessor
COOLANT_SUCTION PostProcessor
COOLANT_THROUGH_TOOL PostProcessor
COOLANT_TOOL PostProcessor
CR PostProcessor
createAxis(Map specifiers) | PostProcessor
createFormat(Map specifiers) | PostProcessor
createIncrementalVariable(Map specifiers, Format format) | PostProcessor
createMachineConfiguration(Map specifiers) | PostProcessor
createModal(Map specifiers, Format format) | PostProcessor
createModalGroup(Map specifiers, Array groups, Format format) | PostProcessor
createReferenceVariable(Map specifiers, Format format) | PostProcessor
createToolRenderer() PostProcessor
createVariable(Map specifiers, Format format) | PostProcessor
currentSection PostProcessor
cycle PostProcessor
cycleExpanded PostProcessor
cycleNotSupported() PostProcessor
cycleType PostProcessor
DC1 PostProcessor
DC2 PostProcessor
DC3 PostProcessor
DC4 PostProcessor
deactivatePolarMode() PostProcessor
debug(String message) | PostProcessor
debugMode PostProcessor
deprecated PostProcessor
description PostProcessor
DLE PostProcessor
EM PostProcessor
end PostProcessor
ENQ PostProcessor
EOL PostProcessor
EOT PostProcessor
error(String message) | PostProcessor
ESC PostProcessor
ETB PostProcessor
ETX PostProcessor
execute(String path, String arguments, Boolean hide, String workingFolder) | PostProcessor
executeNoWait(String path, String arguments, Boolean hide, String workingFolder) | PostProcessor
expandCyclePoint(Number x, Number y, Number z) | PostProcessor
expandManualNC(Integer command, Value value) | PostProcessor
exportNCAs(String path, String format) | PostProcessor
extension PostProcessor
feedrate PostProcessor
FF PostProcessor
filename PostProcessor
filterText(String text, String keep) | PostProcessor
findFile(String path) | PostProcessor
flatten(Array array) | PostProcessor
formatWords(String message) | PostProcessor
FS PostProcessor
fullCircle PostProcessor
getAsFloat(String text) | PostProcessor
getAsInt(String text) | PostProcessor
getCascadingPath() PostProcessor
getCircularCenter() PostProcessor
getCircularChordLength() PostProcessor
getCircularMotion() PostProcessor
getCircularNormal() PostProcessor
getCircularPlane() PostProcessor
getCircularRadius() PostProcessor
getCircularStartRadius() PostProcessor
getCircularSweep() PostProcessor
getCodePage() PostProcessor
getCommandStringId(Integer command) | PostProcessor
getCompensationOffset() PostProcessor
getConfigurationFolder() PostProcessor
getConfigurationPath() PostProcessor
getCoolantName(Integer coolant) | PostProcessor
getCurrentChannel() PostProcessor
getCurrentDirection() PostProcessor
getCurrentGlobalPosition() PostProcessor
getCurrentNCLocation() PostProcessor
getCurrentPosition() PostProcessor
getCurrentRecordId() PostProcessor
getCurrentSectionId() PostProcessor
getCurrentSpindleSpeed() PostProcessor
getCurrentSyncGroup() PostProcessor
getCyclePoint(Integer index) | PostProcessor
getCyclePointId() PostProcessor
getDirection() PostProcessor
getDogLeg() PostProcessor
getEnd() PostProcessor
getFeedrate() PostProcessor
getFirstTool() PostProcessor
getFixture() PostProcessor
getFrameDirection(Vector direction) | PostProcessor
getFramePosition(Vector position) | PostProcessor
getGlobalParameter(String name, Value defaultValue) | PostProcessor
getGlobalPosition(Vector p) | PostProcessor
getHeader() PostProcessor
getHeaderCommit() PostProcessor
getHeaderDate() PostProcessor
getHeaderDate2() PostProcessor
getHeaderSnippet(String keyword) | PostProcessor
getHeaderVersion() PostProcessor
getHelicalDistance() PostProcessor
getHelicalOffset() PostProcessor
getHelicalPitch() PostProcessor
getHighFeedMapping() PostProcessor
getHighFeedrate() PostProcessor
getIntermediatePath() PostProcessor
getInverseTime(Number distance, Number speed) | PostProcessor
getISOPlane(Integer plane) | PostProcessor
getLangId() PostProcessor
getLength() PostProcessor
getMachineConfiguration() PostProcessor
getMachineConfigurationAsText(MachineConfiguration machine) | PostProcessor
getMachineConfigurationByName(String name) | PostProcessor
getMachineConfigurations() PostProcessor
getMachiningDistance(Integer tool) | PostProcessor
getMaterialName(Integer material) | PostProcessor
getMovement() PostProcessor
getMultiAxisMoveLength(Number x, Number y, Number z, Number a, Number b, Number c) | PostProcessor
getNextRecord() PostProcessor
getNextSection() PostProcessor
getNextTool(Integer number) | PostProcessor
getNextTool(Section section, Boolean firstTool, String arguments) | PostProcessor
getNumberOfChannels() PostProcessor
getNumberOfCyclePoints() PostProcessor
getNumberOfRecords() PostProcessor
getNumberOfSections() PostProcessor
getNumberOfSegments(Number tolerance) | PostProcessor
getNumberOfSyncGroups(Integer channel) | PostProcessor
getOutputPath() PostProcessor
getOutputUnit() PostProcessor
getParameter(String name, Value defaultValue) | PostProcessor
getPlane(Vector direction) | PostProcessor
getPlatform() PostProcessor
getPolarPosition(Number x, Number y, Number z) | PostProcessor
getPositionU(Number u) | PostProcessor
getPostProcessorFolder() PostProcessor
getPostProcessorPath() PostProcessor
getPower() PostProcessor
getPreviousRecord() PostProcessor
getPreviousSection() PostProcessor
getProduct() PostProcessor
getProductUri() PostProcessor
getProductUrl() PostProcessor
getProgramNameAsInt(Integer min, Integer max) | PostProcessor
getProgramNameAsString(Integer charLimit) | PostProcessor
getProperty(ScriptObject property, Value defaultValue) | PostProcessor
getQuadrant(Number angle) | PostProcessor
getRadiusCompensation() PostProcessor
getRecord(Integer id) | PostProcessor
getRedirectionBuffer() PostProcessor
getRedirectionBuffer2(Boolean clear) | PostProcessor
getRotation() PostProcessor
getSection(Integer index) | PostProcessor
getSectionFrameDirection(Vector frameDirection) | PostProcessor
getSectionFramePosition(Vector framePosition) | PostProcessor
getSectionPosition(Vector p) | PostProcessor
getSectionsInChannel(Number channel) | PostProcessor
getSecurityLevel() PostProcessor
getSpindleSpeed() PostProcessor
getSystemUnit() PostProcessor
getToolTable() PostProcessor
getToolTypeName(tool) | PostProcessor
getTranslation() PostProcessor
getVendor() PostProcessor
getVendorUrl() PostProcessor
getVersion() PostProcessor
getWCSPosition(Vector p) | PostProcessor
getWordSeparator() PostProcessor
getWorkpiece() PostProcessor
GS PostProcessor
HAS_CIRCULAR PostProcessor
HAS_COMMENT PostProcessor
HAS_CYCLE PostProcessor
HAS_DWELL PostProcessor
HAS_LINEAR PostProcessor
HAS_PARAMETER PostProcessor
HAS_RAPID PostProcessor
HAS_WELL_KNOWN_COMMAND PostProcessor
hasGlobalParameter(String name) | PostProcessor
hasNextRecord() PostProcessor
hasNextSection() PostProcessor
hasParameter(String name) | PostProcessor
hasPreviousRecord() PostProcessor
hasSymbol(Integer symbol) | PostProcessor
helical PostProcessor
helicalDistance PostProcessor
helicalOffset PostProcessor
HIGH_FEED_MAP_ANY PostProcessor
HIGH_FEED_MAP_MULTI PostProcessor
HIGH_FEED_MAP_XY_Z PostProcessor
HIGH_FEED_NO_MAPPING PostProcessor
highFeedMapping PostProcessor
highFeedrate PostProcessor
IN PostProcessor
include(String path) | PostProcessor
initialCyclePosition PostProcessor
interval(Number from, Number to) | PostProcessor
invokeOnCircular(Boolean clockwise, Number cx, Number cy, Number cz, Number x, Number y, Number z, Number nx, Number ny, Number nz, Number feedrate) | PostProcessor
invokeOnLinear(Number x, Number y, Number z, Number feedrate) | PostProcessor
invokeOnLinear5D(Number x, Number y, Number z, Number dx, Number dy, Number dz, Number feedrate) | PostProcessor
invokeOnRapid(Number x, Number y, Number z) | PostProcessor
invokeOnRapid5D(Number x, Number y, Number z, Number dx, Number dy, Number dz) | PostProcessor
is3D() PostProcessor
isAxialCenterDrilling(Section section, Boolean checkLiveTool) | PostProcessor
isClockwise() PostProcessor
isClockwiseSpindleDirection() PostProcessor
isCoolantActive() PostProcessor
isDepositionOperation(Section section) | PostProcessor
isDrillingCycle(Section section, Boolean checkBoringCycles) | PostProcessor
isExpanding() PostProcessor
isFirstCyclePoint() PostProcessor
isFirstSection() PostProcessor
isFullCircle() PostProcessor
isHelical() PostProcessor
isInspectionOperation(Section section) | PostProcessor
isInteractionAllowed() PostProcessor
isJet() PostProcessor
isLastCyclePoint() PostProcessor
isLastSection() PostProcessor
isMilling() PostProcessor
isMillingCycle(Section section, Boolean checkBoringCycles) | PostProcessor
isMultiAxis() PostProcessor
isMultiChannelProgram() PostProcessor
isNewWorkOffset(Section section) | PostProcessor
isNewWorkPlane(Section section) | PostProcessor
isPolarModeActive() PostProcessor
isProbeOperation(Section section) | PostProcessor
isProbingCycle(String uri) | PostProcessor
isRedirecting() PostProcessor
isSafeText(String text, String permitted) | PostProcessor
isSameDirection(a, b) | PostProcessor
isSectionSpecialCycle(String uri) | PostProcessor
isSpeedFeedSynchronizationActive() PostProcessor
isSpindleActive() PostProcessor
isSpindleSpeedDifferent(Section section) | PostProcessor
isSpiral() PostProcessor
isSubSpindleCycle(String uri) | PostProcessor
isSupportedText(String &message) | PostProcessor
isTappingCycle(Section section) | PostProcessor
isTextSupported(String text) | PostProcessor
isToolChangeNeeded(Section section, String arguments) | PostProcessor
isTurning() PostProcessor
isWellKnownCommand(Integer command) | PostProcessor
isWellKnownCycle() PostProcessor
isWorkpieceDefined() PostProcessor
legal PostProcessor
length PostProcessor
LF PostProcessor
linearize(Number tolerance) | PostProcessor
lineNumber PostProcessor
loadLocale(String langId) | PostProcessor
loadMachineConfiguration(String path) | PostProcessor
loadText(String url, String encoding) | PostProcessor
localize(String message) | PostProcessor
localize2(String section, String message) | PostProcessor
log(String message) | PostProcessor
machineConfiguration PostProcessor
machineParameters PostProcessor
mapToWCS PostProcessor
mapWorkOrigin PostProcessor
MATERIAL_CARBIDE PostProcessor
MATERIAL_CERAMICS PostProcessor
MATERIAL_HSS PostProcessor
MATERIAL_TI_COATED PostProcessor
MATERIAL_UNSPECIFIED PostProcessor
maximumCircularRadius PostProcessor
maximumCircularSweep PostProcessor
minimumChordLength PostProcessor
minimumCircularRadius PostProcessor
minimumCircularSweep PostProcessor
minimumRevision PostProcessor
MM PostProcessor
movement PostProcessor
MOVEMENT_CUTTING PostProcessor
MOVEMENT_EXTENDED PostProcessor
MOVEMENT_FINISH_CUTTING PostProcessor
MOVEMENT_HIGH_FEED PostProcessor
MOVEMENT_LEAD_IN PostProcessor
MOVEMENT_LEAD_OUT PostProcessor
MOVEMENT_LINK_DIRECT PostProcessor
MOVEMENT_LINK_TRANSITION PostProcessor
MOVEMENT_PLUNGE PostProcessor
MOVEMENT_PREDRILL PostProcessor
MOVEMENT_RAMP PostProcessor
MOVEMENT_RAMP_HELIX PostProcessor
MOVEMENT_RAMP_PROFILE PostProcessor
MOVEMENT_RAMP_ZIG_ZAG PostProcessor
MOVEMENT_RAPID PostProcessor
MOVEMENT_REDUCED PostProcessor
NAK PostProcessor
normal PostProcessor
NUL PostProcessor
onAcceleration(Number travel, Number printing, Number retract) | PostProcessor
onBedTemp(Number temp, Boolean wait) | PostProcessor
onCircular(Boolean clockwise, Number cx, Number cy, Number cz, Number x, Number y, Number z, Number feed) | PostProcessor
onCircularExtrude(Boolean clockwise, Number cx, Number cy, Number cz, Number x, Number y, Number z, Number feed, Number extrusionLength) | PostProcessor
onClose() PostProcessor
onCommand(Integer command) | PostProcessor
onComment(String comment) | PostProcessor
onCycle() PostProcessor
onCycleEnd() PostProcessor
onCyclePath() PostProcessor
onCyclePathEnd() PostProcessor
onCyclePoint(Number x, Number y, Number z) | PostProcessor
onDwell(Number time) | PostProcessor
onExpandedLinear(Number x, Number y, Number z, Number feed) | PostProcessor
onExpandedRapid(Number x, Number y, Number z) | PostProcessor
onExpandedSpindleSpeed(Number spindleSpeed) | PostProcessor
onExtruderChange(Number extruderId) | PostProcessor
onExtruderTemp(Number temp, Boolean wait, Integer extruderId) | PostProcessor
onExtrusionReset(Number length) | PostProcessor
onFanSpeed(Number speed, Integer fanId) | PostProcessor
onImpliedCommand(Integer command) | PostProcessor
onJerk(Number xAxis, Number yAxis, Number zAxis, Number eAxis) | PostProcessor
onLayer(Number layerNumber) | PostProcessor
onLinear(Number x, Number y, Number z, Number feed) | PostProcessor
onLinear5D(Number x, Number y, Number z, Number dx, Number dy, Number dz, Number feed) | PostProcessor
onLinearExtrude(Number x, Number y, Number z, Number feed, Number extrusionLength) | PostProcessor
onMachine() PostProcessor
onMaxAcceleration(Number xAxis, Number yAxis, Number zAxis, Number eAxis) | PostProcessor
onMovement(Integer movement) | PostProcessor
onMoveToSafeRetractPosition() PostProcessor
onOpen() PostProcessor
onOrientateSpindle(Number angle) | PostProcessor
onParameter(String name, Value value) | PostProcessor
onPassThrough(Value value) | PostProcessor
onPower(Boolean power) | PostProcessor
onRadiusCompensation() PostProcessor
onRapid(Number x, Number y, Number z) | PostProcessor
onRapid5D(Number x, Number y, Number z, Number dx, Number dy, Number dz) | PostProcessor
onReturnFromSafeRetractPosition(Number x, Number y, Number z) | PostProcessor
onRewindMachine(Number a, Number b, Number c) | PostProcessor
onRewindMachineEntry(Number a, Number b, Number c) | PostProcessor
onRotateAxes(Number x, Number y, Number z, Number a, Number b, Number c) | PostProcessor
onSectionEnd() PostProcessor
onSpindleSpeed(Number spindleSpeed) | PostProcessor
onToolCompensation(Integer compensation) | PostProcessor
onUnsupportedCommand(Integer command) | PostProcessor
onUnsupportedCoolant(Integer coolant) | PostProcessor
openUrl(String url) | PostProcessor
optimizeMachineAngles() PostProcessor
optimizeMachineAngles2(Integer optimizeType) | PostProcessor
optimizeMachineAnglesByMachine(MachineConfiguration machine, Integer optimizeType) | PostProcessor
outputUnit PostProcessor
parseSpatial(String &value) | PostProcessor
PATH_SEPARATOR PostProcessor
plane PostProcessor
PLANE_XY PostProcessor
PLANE_XZ PostProcessor
PLANE_YZ PostProcessor
PLANE_ZX PostProcessor
PostProcessor() PostProcessor
preventPost PostProcessor
printDocument(String path) | PostProcessor
printDocumentTo(String path, String printerName) | PostProcessor
programName PostProcessor
programNameIsInteger PostProcessor
promptKey(String title, String description) | PostProcessor
promptKey2(String title, String description, String accept) | PostProcessor
promptKey3(String title, String description, String accept, String keys) | PostProcessor
promptText(String title, String description) | PostProcessor
properties PostProcessor
radius PostProcessor
RADIUS_COMPENSATION_LEFT PostProcessor
RADIUS_COMPENSATION_OFF PostProcessor
RADIUS_COMPENSATION_RIGHT PostProcessor
radiusCompensation PostProcessor
range(Number first, Number end, Number step) | PostProcessor
RECORD_CIRCULAR PostProcessor
RECORD_CIRCULAR_EXTRUDE PostProcessor
RECORD_COMMENT PostProcessor
RECORD_CYCLE PostProcessor
RECORD_CYCLE_OFF PostProcessor
RECORD_DWELL PostProcessor
RECORD_INVALID PostProcessor
RECORD_LINEAR PostProcessor
RECORD_LINEAR_5D PostProcessor
RECORD_LINEAR_EXTRUDE PostProcessor
RECORD_LINEAR_ZXN PostProcessor
RECORD_PARAMETER PostProcessor
RECORD_WELL_KNOWN_COMMAND PostProcessor
RECORD_WIDE_COMMENT PostProcessor
redirectToBuffer() PostProcessor
redirectToFile(String path) | PostProcessor
registerPostProcessing(String path) | PostProcessor
registerTerminationHandler(Function function) | PostProcessor
repositionToCycleClearance(Map cycle, Number x, Number y, Number z) | PostProcessor
revision PostProcessor
RS PostProcessor
setCascadingPath(String) | PostProcessor
setCodePage(String name) | PostProcessor
setCurrentABC(Vector abc) | PostProcessor
setCurrentDirection(Vector currentDirection) | PostProcessor
setCurrentPosition(Vector currentPosition) | PostProcessor
setCurrentPositionAndDirection(VectorPair posDir) | PostProcessor
setCurrentPositionX(Number x) | PostProcessor
setCurrentPositionY(Number y) | PostProcessor
setCurrentPositionZ(Number z) | PostProcessor
setCurrentSpindleSpeed(Number spindleSpeed) | PostProcessor
setDogLeg(Boolean dogLeg) | PostProcessor
setEOL(String eol) | PostProcessor
setExitCode(Integer code) | PostProcessor
setHighFeedMapping(Integer mode) | PostProcessor
setHighFeedrate(Number feedrate) | PostProcessor
setMachineConfiguration(MachineConfiguration machine) | PostProcessor
setOutputUnit(Integer unit) | PostProcessor
setProperty(ScriptObject property, Value value) | PostProcessor
setRotation(Matrix rotation) | PostProcessor
setSectionSpecialCycle(String uri, Boolean specialCycle) | PostProcessor
setTranslation(Vector translation) | PostProcessor
setWordSeparator(String message) | PostProcessor
setWriteInvocations(Boolean writeInvocations) | PostProcessor
setWriteStack(Boolean writeStack) | PostProcessor
SI PostProcessor
SINGULARITY_LINEARIZE_LINEAR PostProcessor
SINGULARITY_LINEARIZE_OFF PostProcessor
SINGULARITY_LINEARIZE_ROTARY PostProcessor
skipRemainingSection() PostProcessor
SO PostProcessor
SOH PostProcessor
SP PostProcessor
spatial(Number value, Integer unit) | PostProcessor
spindleAxis PostProcessor
spindleSpeed PostProcessor
STX PostProcessor
SUB PostProcessor
subst(String message,...) | PostProcessor
sweep PostProcessor
SYN PostProcessor
TAB PostProcessor
toDeg(Number radians) | PostProcessor
tolerance PostProcessor
tool PostProcessor
TOOL_AXIS_X PostProcessor
TOOL_AXIS_Y PostProcessor
TOOL_AXIS_Z PostProcessor
TOOL_BORING_BAR PostProcessor
TOOL_COMPENSATION_INSERT_CENTER PostProcessor
TOOL_COMPENSATION_TIP PostProcessor
TOOL_COMPENSATION_TIP_CENTER PostProcessor
TOOL_COMPENSATION_TIP_TANGENT PostProcessor
TOOL_COUNTER_BORE PostProcessor
TOOL_COUNTER_SINK PostProcessor
TOOL_DRILL PostProcessor
TOOL_DRILL_BLOCK PostProcessor
TOOL_DRILL_CENTER PostProcessor
TOOL_DRILL_SPOT PostProcessor
TOOL_GRINDER PostProcessor
TOOL_HOLDER_ONLY PostProcessor
TOOL_LASER_CUTTER PostProcessor
TOOL_MARKER PostProcessor
TOOL_MILLING_CHAMFER PostProcessor
TOOL_MILLING_DOVETAIL PostProcessor
TOOL_MILLING_END_BALL PostProcessor
TOOL_MILLING_END_BULLNOSE PostProcessor
TOOL_MILLING_END_FLAT PostProcessor
TOOL_MILLING_FACE PostProcessor
TOOL_MILLING_FORM PostProcessor
TOOL_MILLING_LOLLIPOP PostProcessor
TOOL_MILLING_RADIUS PostProcessor
TOOL_MILLING_SLOT PostProcessor
TOOL_MILLING_TAPERED PostProcessor
TOOL_MILLING_THREAD PostProcessor
TOOL_PLASMA_CUTTER PostProcessor
TOOL_PROBE PostProcessor
TOOL_REAMER PostProcessor
TOOL_TAP_LEFT_HAND PostProcessor
TOOL_TAP_RIGHT_HAND PostProcessor
TOOL_TURNING_BORING PostProcessor
TOOL_TURNING_CUSTOM PostProcessor
TOOL_TURNING_GENERAL PostProcessor
TOOL_TURNING_GROOVING PostProcessor
TOOL_TURNING_THREADING PostProcessor
TOOL_UNSPECIFIED PostProcessor
TOOL_WATER_JET PostProcessor
TOOL_WELDER PostProcessor
TOOL_WIRE PostProcessor
toolZRange() PostProcessor
toRad(Number degrees) | PostProcessor
translateText(String text, String src, String dest) | PostProcessor
unit PostProcessor
US PostProcessor
validate(Value expression, String message) | PostProcessor
validateProperties() PostProcessor
validatePropertyDefinitions() PostProcessor
vendor PostProcessor
vendorUrl PostProcessor
version PostProcessor
VT PostProcessor
warning(String message) | PostProcessor
warningOnce(String &message, Integer id) | PostProcessor
write(String message) | PostProcessor
writeln(String message) | PostProcessor
writeSectionNotes() PostProcessor
writeSetupNotes() PostProcessor
writeToolTable(Integer orderBy) | PostProcessor
writeWords(String message,...) | PostProcessor
writeWords2(String message,...) | PostProcessor


Range Class Reference

Inherits ScriptObject, and UnitConsumer.

Public Member Functions

Range ()
Range (Number a, Number b, Actuator actuator=Actuator::ACTUATOR_ROTATIONAL)
Boolean isNonRange ()
Number getMinimum ()
Number getMaximum ()
Number getSpan ()
Number getMiddle ()
grow (Number offset)
reduce (Number offset)
translate (Number offset)
expandTo (Number value)
expandToRange (Range value)
Number | getU (Number value)
Boolean | isWithin (Number value)
Number | clamp (Number value)
String toString ()

Public Attributes

Number minimum
The minimum coordinate of the range.
Number maximum
The maximum coordinate of the range.
Number span
The span of the range.
Number middle
The middle of the range.

Detailed Description

A 2D range specified by an minimum and maximum value.

Constructor & Destructor Documentation

◆ Range() [1/2]

Range ( )

Constructs the range as uninitialized.

◆ Range() [2/2]

Range | ( | Number | a,
 |  | Number | b,
 |  | Actuator | actuator = Actuator::ACTUATOR_ROTATIONAL
 | ) |  |

Constructs the range from the specified values.

Parameters
a | Outer value for the range.
b | Outer value for the range.
actuator | The actuator type (ie. either "linear" or "rotational"). The default is "rotational".

Member Function Documentation

◆ clamp()

Number clamp ( Number value )

Returns the nearest value which is in the range.

◆ expandTo()

expandTo ( Number value )

Expands the range to include the specified value.

◆ expandToRange()

expandToRange ( Range value )

Expands the range to include the specified range.

◆ getMaximum()

Number getMaximum ( )

Returns the maximum value.

◆ getMiddle()

Number getMiddle ( )

Returns the middle of the range.

◆ getMinimum()

Number getMinimum ( )

Returns the minimum value.

◆ getSpan()

Number getSpan ( )

Returns the span of the range.

◆ getU()

Number getU ( Number value )

Returns the U coordinate for the specified value. 0 and 1 corresponds to the minimum and maximum, respectively.

◆ grow()

grow ( Number offset )

Grows the range by the specified offset.

◆ isNonRange()

Boolean isNonRange ( )

Returns true if the range is a non-range.

◆ isWithin()

Boolean isWithin ( Number value )

Returns true if the specified value is within the range.

◆ reduce()

reduce ( Number offset )

Reduces the range by the specified offset. Returns the middle of the range if the range collapses.

◆ toString()

String toString ( )

Converts the range to a string (e.g. [-10.5; 5.75]).

◆ translate()

translate ( Number offset )

Translates the range.


Member List

Range Member List

This is the complete list of members for Range, including all inherited members.

clamp(Number value) | Range
expandTo(Number value) | Range
expandToRange(Range value) | Range
getMaximum() | Range
getMiddle() | Range
getMinimum() | Range
getSpan() | Range
getU(Number value) | Range
grow(Number offset) | Range
isNonRange() | Range
isWithin(Number value) | Range
maximum | Range
middle | Range
minimum | Range
Range() | Range
Range(Number a, Number b, Actuator actuator=Actuator::ACTUATOR_ROTATIONAL) | Range
reduce(Number offset) | Range
span | Range
toString() | Range
translate(Number offset) | Range


Record Class Reference

Inherits ScriptObject.

Public Member Functions

Record ()
Boolean isValid ()
Integer getId ()
Integer getType ()
Integer getCategories ()
Boolean isMotion ()
Boolean isCycle ()
String getCycleType ()
Boolean isParameter ()
String getParameterName ()
Value getParameterValue ()

Detailed Description

An NC record in the NC database.

Constructor & Destructor Documentation

◆ Record()

Record ( )

Constructs an invalid record.

Member Function Documentation

◆ getCategories()

Integer getCategories ( )

Returns the categories.

◆ getCycleType()

String getCycleType ( )

Returns the cycle type.

◆ getId()

Integer getId ( )

Returns the id of the record.

◆ getParameterName()

String getParameterName ( )

Returns the parameter name.

Since
r41192

◆ getParameterValue()

Value getParameterValue ( )

Returns the parameter value.

Since
r41192

◆ getType()

Integer getType ( )

Returns the type of the record.

◆ isCycle()

Boolean isCycle ( )

Returns true if the record is a cycle record.

◆ isMotion()

Boolean isMotion ( )

Returns true if the record is a motion record.

◆ isParameter()

Boolean isParameter ( )

Returns true if the record is a parameter.

Since
r41192

◆ isValid()

Boolean isValid ( )

Returns true if the record is valid.


Member List

Record Member List

This is the complete list of members for Record, including all inherited members.

getCategories() | Record
getCycleType() | Record
getId() | Record
getParameterName() | Record
getParameterValue() | Record
getType() | Record
isCycle() | Record
isMotion() | Record
isParameter() | Record
isValid() | Record
Record() | Record


ReferenceVariable Class Reference

Public Member Functions

ReferenceVariable (Map specifiers, Format format)
String format (Number value, Number reference)
Value getPrefix ()
setPrefix (Value prefix)
disable ()

Detailed Description

A referenced formatting variable. This object is used to avoid output of values if not required when values are identical to a specific reference value.

var xyzFormat = createFormat({decimals:3, trim:false});
var iVariable = createReferenceVariable({prefix: " I"}, xyzFormat); // note space in front of 'I'
var str = iVariable.format(4.4, 5); // returns " I4.400"
str = iVariable.format(5, 5); // returns ""

Constructor & Destructor Documentation

◆ ReferenceVariable()

ReferenceVariable | ( | Map | specifiers,
 |  | Format | format
 | ) |  |

Constructs a variable.

Parameters
specifiers | The behavior specifiers.
format | The instance of type Format used to format the output values.

The supported specifiers are:

  1. prefix: Specifies a prefix to be prepended the formatted value.
  2. force: Specifies that the value always must be output.

Member Function Documentation

◆ disable()

disable ( )

Disable variable. When invoked format() always returns the empty string.

◆ format()

String format | ( | Number | value,
 |  | Number | reference
 | ) |  |

Returns the formatted string of the specified value. The empty string is returned if the value is identical to the specified reference value. The reference value is optional. If not specified the value will be output.

Parameters
value | The value.
reference | The reference value.

◆ getPrefix()

Value getPrefix ( )

Returns the prefix.

◆ setPrefix()

setPrefix ( Value prefix )

Sets the prefix.

Parameters
prefix The prefix string.


Member List

ReferenceVariable Member List

This is the complete list of members for ReferenceVariable, including all inherited members.

disable() | ReferenceVariable
format(Number value, Number reference) | ReferenceVariable
getPrefix() | ReferenceVariable
ReferenceVariable(Map specifiers, Format format) | ReferenceVariable
setPrefix(Value prefix) | ReferenceVariable


Section Class Reference

Inherits ScriptObject.

Public Member Functions

Integer getId ()
PostPropertyMap::PropertyMap | getOperationProperties ()
optional< String > | getStrategy ()
Integer getNumberOfRecords ()
Record | getRecord (Integer id)
Integer getJobId ()
Integer getPatternId ()
Integer getNumberOfPatternInstances ()
Boolean isPatterned ()
Integer getChannel ()
Boolean getForceToolChange ()
Boolean isOptional ()
Integer getFirstCompensationOffset ()
Tool getTool ()
Integer getContent ()
Boolean isMultiAxis ()
Integer getUnit ()
Integer getType ()
Integer getQuality ()
Integer getJetMode ()
Boolean getTailstock ()
Boolean getPartCatcher ()
Integer getSpindle ()
Integer getFeedMode ()
Number getToolOrientation ()
Vector getWorkOrigin ()
Matrix getWorkPlane ()
Boolean isXOriented ()
Boolean isYOriented ()
Boolean isZOriented ()
Boolean isTopWorkPlane ()
Vector getGlobalWorkOrigin ()
Matrix getGlobalWorkPlane ()
Integer getToolAxis ()
Vector getWCSOrigin ()
Matrix getWCSPlane ()
Vector getDynamicWCSOrigin ()
Matrix getDynamicWCSPlane ()
Vector getFCSOrigin ()
Matrix getFCSPlane ()
Vector getModelOrigin ()
Matrix getModelPlane ()
Integer getWorkOffset ()
Integer getProbeWorkOffset ()
String getWCS ()
Integer getWCSIndex ()
Boolean hasDynamicWorkOffset ()
Integer getDynamicWorkOffset ()
Boolean getAxisSubstitution ()
Number getAxisSubstitutionRadius ()
Vector | getGlobalPosition (Vector p)
Vector | getWCSPosition (Vector p)
Vector | getSectionPosition (Vector p)
Number getMaximumSpindleSpeed ()
Number getMaximumFeedrate ()
Number getCuttingDistance ()
Number getRapidDistance ()
Integer getMovements ()
Number getCycleTime ()
Integer getNumberOfCyclePoints ()
Range getZRange ()
Range getGlobalZRange ()
Range | getGlobalRange (Vector direction)
BoundingBox getBoundingBox ()
BoundingBox getGlobalBoundingBox ()
Boolean | isCuttingMotionAwayFromRotary (Number distance, Number tolerance)
Boolean hasWellDefinedPosition ()
Vector getFirstPosition ()
Vector getInitialPosition ()
Vector getFinalPosition ()
Vector getInitialToolAxis ()
Vector getGlobalInitialToolAxis ()
Vector getInitialToolAxisABC ()
Vector getFinalToolAxis ()
Vector getFinalToolAxisABC ()
Vector getGlobalFinalToolAxis ()
Boolean getInitialSpindleOn ()
Number getInitialSpindleSpeed ()
Boolean getFinalSpindleOn ()
Number getFinalSpindleSpeed ()
Number getMaximumTilt ()
Vector getLowerToolAxisABC ()
Vector getUpperToolAxisABC ()
Boolean isOptimizedForMachine ()
Integer getOptimizedTCPMode ()
Boolean | hasParameter (String name)
Value | getParameter (String name, Value defaultValue)
Boolean | hasCycle (String uri)
Boolean hasAnyCycle ()
Integer | getNumberOfCyclesWithId (String uri)
Integer getNumberOfCycles ()
String | getCycleId (Integer index)
String getFirstCycle ()
String getLastCycle ()
Boolean | doesStartWithCycle (String uri)
Boolean | doesEndWithCycle (String &_uri) noexcept
Boolean | doesStartWithCycleIgnoringPositioning (String uri)
Boolean | doesEndWithCycleIgnoringPositioning (String uri)
Boolean | doesStrictCycle (String uri)
Boolean | hasCycleParameter (Integer index, String name)
Value | getCycleParameter (Integer index, String name)
optimizeMachineAnglesByMachine (MachineConfiguration machine, Integer optimizeType)
optimize3DPositionsByMachine (MachineConfiguration machine, Vector abc, Integer optimizeType)
Boolean | checkGroup (Integer groups)

Public Attributes

Integer unit
unit). More...
Vector workOrigin
The work origin in the WCS.
Matrix workPlane
The work plane in the WCS.
Vector wcsOrigin
The work coordinate system (WCS) origin.
Matrix wcsPlane
The work coordinate system (WCS) plane.
Integer workOffset
The work offset corresponding to the WCS.
Integer probeWorkOffset
The work offset corresponding to the Probe WCS.
Integer wcsIndex
The index used in the WCS.
String wcs
The WCS.
Integer dynamicWorkOffset
the display coordinates. More...
Boolean axisSubstitution
Specifies that the section uses axis substitution.
Number axisSubstitutionRadius
Specifies the nominal axis substitution radius.
Integer type
Specifies the type of the section (TYPE_MILLING, TYPE_TURNING, or TYPE_JET).
Integer quality
Specifies the associated quality.
Boolean tailstock
Specifies that tailstock is used.
Boolean partCatcher
Specifies that part catcher should be activated if available.
Integer spindle
Specifies the active spindle.
Map properties
The operation properties.
String strategy
Specifies the strategy type of the section.

Detailed Description

An NC section. A section is a group of NC data which shares the same work plane, tool, and related data.

Member Function Documentation

◆ checkGroup()

Boolean checkGroup ( Integer groups )

Returns true if the toolpath belongs to one or several specific strategy groups.

Parameters
groups The group flags to be checked. The available group flags are:
  • STRATEGY_2D
  • STRATEGY_3D
  • STRATEGY_ROUGHING
  • STRATEGY_FINISHING
  • STRATEGY_MILLING
  • STRATEGY_TURNING
  • STRATEGY_JET
  • STRATEGY_ADDITIVE
  • STRATEGY_PROBING
  • STRATEGY_INSPECTION
  • STRATEGY_DRILLING
  • STRATEGY_HOLEMILLING
  • STRATEGY_THREAD
  • STRATEGY_SAMPLING
  • STRATEGY_ROTARY
  • STRATEGY_SECONDARYSPINDLE
  • STRATEGY_SURFACE
  • STRATEGY_CHECKSURFACE
  • STRATEGY_MULTIAXIS

The function can take more than one flag as argurments. e.g.

if (currentSection.checkGroup(STRATEGY_2D, STRATEGY_FINISHING)) {
...// check if the current operation startegy is a 2D finishing strategy
}
Since
r45615

◆ doesEndWithCycle()

Boolean doesEndWithCycle ( String & _uri )
noexcept

Returns true if the given cycle is the last effective move within the section. E.g. if onLinear() would be called after onCycle() this method will return false. onParameter() and onComment() are ignored.

Since
r42100

◆ doesEndWithCycleIgnoringPositioning()

Boolean doesEndWithCycleIgnoringPositioning ( String uri )

Returns true if the given cycle is the first effective move within the section ignoring positioning moves (ie. rapid and high feed moves). E.g. if onLinear() would be called before onCycle() this method will return false. onParameter(), onComment() and onDwell() are ignored.

Since
r42100

◆ doesStartWithCycle()

Boolean doesStartWithCycle ( String uri )

Returns true if the given cycle is the first effective move within the section. E.g. if onLinear() would be called before onCycle() this method will return false. onParameter() and onComment() are ignored.

Since
r41184

◆ doesStartWithCycleIgnoringPositioning()

Boolean doesStartWithCycleIgnoringPositioning ( String uri )

Returns true if the given cycle is the first effective move within the section ignoring positioning moves (ie. rapid and high feed moves). E.g. if onLinear() would be called before onCycle() this method will return false. onParameter(), onComment() and onDwell() are ignored.

Since
r41215

◆ doesStrictCycle()

Boolean doesStrictCycle ( String uri )

Returns true if the given cycle is the only effective move within the section. onParameter() and onComment() are ignored.

Since
r41184

◆ getAxisSubstitution()

Boolean getAxisSubstitution ( )

Returns true if the section uses axis substitution. In axis substitution mode the coordinates are the following meaning:

X: The offset along the substitution axis. Y: The rotation angle in radians. Z: Radius (always positive)

◆ getAxisSubstitutionRadius()

Number getAxisSubstitutionRadius ( )

Returns the nominal axis substitution radius.

◆ getBoundingBox()

BoundingBox getBoundingBox ( )

Returns the bounding box of the toolpath of the section.

◆ getChannel()

Integer getChannel ( )

Returns the channel ID. Sections with the same channel ID belongs to the same channel.

◆ getContent()

Integer getContent ( )

Returns the content flags.

◆ getCuttingDistance()

Number getCuttingDistance ( )

Returns the cutting distance for the section (excluding rapid traversal).

◆ getCycleId()

String getCycleId ( Integer index )

Returns the ID of the given cycle within the section. Raises exception if index exceeds limit returned by Section.getNumberOfCycles().

Since
r41215

◆ getCycleParameter()

Value getCycleParameter | ( | Integer | index,
 |  | String | name
 | ) |  |

Returns the value of the first occurrence of the specified parameter within the given cycle.

Parameters
index | The index of the cycle.
name | The name of the parameter.
Since
r41215

◆ getCycleTime()

Number getCycleTime ( )

Returns the cycle time for the cutting moves the section (rapid traversal is ignored).

◆ getDynamicWCSOrigin()

Vector getDynamicWCSOrigin ( )

Returns the dynamic origin of the WCS. Only use if the dynamic work offset is set.

◆ getDynamicWCSPlane()

Matrix getDynamicWCSPlane ( )

Returns the dynamic WCS plane. Only use if the dynamic work offset is set.

◆ getDynamicWorkOffset()

Integer getDynamicWorkOffset ( )

Returns the dynamic work offset for the WCS. The dynamic work offset is used to control the display coordinates.

◆ getFCSOrigin()

Vector getFCSOrigin ( )

Returns the origin of the fixture coordinate system (FCS).

Since
r40294

◆ getFCSPlane()

Matrix getFCSPlane ( )

Returns the fixture coordinate system (FCS) plane.

Since
r40294

◆ getFeedMode()

Integer getFeedMode ( )

Returns the feed mode.

The available modes are:

  • FEED_PER_MINUTE
  • FEED_PER_REVOLUTION

◆ getFinalPosition()

Vector getFinalPosition ( )

Returns the final position for the section.

◆ getFinalSpindleOn()

Boolean getFinalSpindleOn ( )

Returns true if the spindle speed is on at the end of the section. Might be turned off due to final canned cycle.

Since
r42100

◆ getFinalSpindleSpeed()

Number getFinalSpindleSpeed ( )

Returns the final spindle speed which can be different from the tool spindle speed. Might be turned off due to final canned cycle.

Since
r42100

◆ getFinalToolAxis()

Vector getFinalToolAxis ( )

Returns the final tool axis for the section as the direction vector.

◆ getFinalToolAxisABC()

Vector getFinalToolAxisABC ( )

Returns the final tool axis machine angles for the section. The section must have been optimized for the machine using optimizeMachineAngles() or similar before called this method.

◆ getFirstCompensationOffset()

Integer getFirstCompensationOffset ( )

Returns the first active compensation for the section.

◆ getFirstCycle()

String getFirstCycle ( )

Returns the first cycle within the section. Returns empty string is no cycle occurs within the section.

Since
r41184

◆ getFirstPosition()

Vector getFirstPosition ( )

Returns the first position for the section. This method has been replaced by getInitialPosition().

Deprecated:

◆ getForceToolChange()

Boolean getForceToolChange ( )

Returns true if tool change should be forced.

◆ getGlobalBoundingBox()

BoundingBox getGlobalBoundingBox ( )

Returns the bounding box of the toolpath of the section in the global coordinate system.

◆ getGlobalFinalToolAxis()

Vector getGlobalFinalToolAxis ( )

Returns the final tool axis for the section in the WCS frame. Always returns the direction vector.

◆ getGlobalInitialToolAxis()

Vector getGlobalInitialToolAxis ( )

Returns the initial tool axis for the section in the WCS frame. Always returns the direction vector.

◆ getGlobalPosition()

Vector getGlobalPosition ( Vector p )

Returns the global position for the specified local position.

◆ getGlobalRange()

Range getGlobalRange ( Vector direction )

Returns the range of the toolpath of the section along the global direction.

Since
r39501

◆ getGlobalWorkOrigin()

Vector getGlobalWorkOrigin ( )

Returns the work origin in the global coordinate system (top view).

◆ getGlobalWorkPlane()

Matrix getGlobalWorkPlane ( )

Returns the work plane in the global coordinate system (top view).

◆ getGlobalZRange()

Range getGlobalZRange ( )

Returns the Z-coordinate range of the toolpath of the section in the global coordinate system.

◆ getId()

Integer getId ( )

Returns the zero-based id of the section.

◆ getInitialPosition()

Vector getInitialPosition ( )

Returns the initial position for the section.

◆ getInitialSpindleOn()

Boolean getInitialSpindleOn ( )

Returns true if the spindle speed is on initially. Might be turned off due to initial canned cycle when it starts with positioning moves.

Since
r41215

◆ getInitialSpindleSpeed()

Number getInitialSpindleSpeed ( )

Returns the initial spindle speed which can be different from the tool spindle speed. Might be turned off due to initial canned cycle.

Since
r41215

◆ getInitialToolAxis()

Vector getInitialToolAxis ( )

Returns the initial tool axis for the section as the direction vector.

◆ getInitialToolAxisABC()

Vector getInitialToolAxisABC ( )

Returns the initial tool axis machine angles for the section. The section must have been optimized for the machine using optimizeMachineAngles() or similar before called this method.

◆ getJetMode()

Integer getJetMode ( )

Returns the type of waterjet, laser, and plasma cutting of the section.

The available modes are:

  • JET_MODE_THROUGH
  • JET_MODE_ETCHING
  • JET_MODE_VAPORIZE

◆ getJobId()

Integer getJobId ( )

Returns the job id of the section.

◆ getLastCycle()

String getLastCycle ( )

Returns the last cycle within the section. Returns empty string is no cycle occurs within the section.

Since
r42100

◆ getLowerToolAxisABC()

Vector getLowerToolAxisABC ( )

Returns the upper machine angles for a multi-axis section. The section must have been optimized for the machine using optimizeMachineAngles() or similar before called this method.

◆ getMaximumFeedrate()

Number getMaximumFeedrate ( )

Returns the maximum feedrate for the section.

◆ getMaximumSpindleSpeed()

Number getMaximumSpindleSpeed ( )

Returns the maximum spindle speed for the section.

◆ getMaximumTilt()

Number getMaximumTilt ( )

Returns the maximum tilt in the range [-1; 1] for the given multi-axis section. 1 corresponds to 0deg tilt. -1 corresponds to 180deg tilt.

◆ getModelOrigin()

Vector getModelOrigin ( )

Returns the origin of the Model coordinate system.

Since
r42226

◆ getModelPlane()

Matrix getModelPlane ( )

Returns the Model coordinate system plane.

Since
r42226

◆ getMovements()

Integer getMovements ( )

Returns the movements (as a mask) in use for the section.

if (currentSection.getMovements() & (1 << MOVEMENT_CUTTING)) {
// cutting move is present in section
}
if (currentSection.getMovements() & (1 << MOVEMENT_LEAD_IN)) {
// lead in is present in section
}

◆ getNumberOfCyclePoints()

Integer getNumberOfCyclePoints ( )

Returns the number of cycle points for the entire section.

◆ getNumberOfCycles()

Integer getNumberOfCycles ( )

Returns the number cycles within the section.

Since
r41215

◆ getNumberOfCyclesWithId()

Integer getNumberOfCyclesWithId ( String uri )

Returns the number of times the given cycle occurs within the section.

Since
r41215

◆ getNumberOfPatternInstances()

Integer getNumberOfPatternInstances ( )

Returns the number of pattern instances for the section.

◆ getNumberOfRecords()

Integer getNumberOfRecords ( )

Returns the number of records in the section.

◆ getOperationProperties()

PostPropertyMap::PropertyMap getOperationProperties ( )

Returns the operation property map.

◆ getOptimizedTCPMode()

Integer getOptimizedTCPMode ( )

Returns the TCP mode used for the section when it was optimized for a machine configuration.

◆ getParameter()

Value getParameter | ( | String | name,
 |  | Value | defaultValue
 | ) |  |

Returns the value of the first occurrence of the specified parameter.

Parameters
name | The name of the parameter to return.
defaultValue | (optional, since r45615) The default value of the parameter to return if it is not defined.

◆ getPartCatcher()

Boolean getPartCatcher ( )

Returns true if part catcher should be activated if available for turning.

◆ getPatternId()

Integer getPatternId ( )

Returns the pattern id of the section. You can use this to tell which sections are pattern instances of the same original section. The motion coordinates will be identical for patterned sections but the work plane can be different. Note that, the pattern ids can be different for some types of patterns when the actual motion coordinates are mapped.

Attention
By default the work origins are mapped to the WCS origin to simplify the post customization. This results in a displacement between the pattern instances. You can get the displacement by subtracting the initial section positions.
Returns
0 means that the section is not patterned.

◆ getProbeWorkOffset()

Integer getProbeWorkOffset ( )

Returns the work offset for the WCS.

◆ getQuality()

Integer getQuality ( )

Returns the associated quality. Used for waterjet, laser, and plasma cutting.

◆ getRapidDistance()

Number getRapidDistance ( )

Returns the rapid traversal distance for the section.

◆ getRecord()

Record getRecord ( Integer id )

Returns the specified record within the section.

Since
r41192

◆ getSectionPosition()

Vector getSectionPosition ( Vector p )

Returns the local position for the specified global position.

◆ getSpindle()

Integer getSpindle ( )

Returns the active spindle.

The available values are:

  • SPINDLE_PRIMARY - The main/primary spindle.
  • SPINDLE_SECONDARY - The sub-spindle/secondary spindle.

◆ getStrategy()

optional< String > getStrategy ( )

Returns the strategy of the section.

◆ getTailstock()

Boolean getTailstock ( )

Returns true if tailstock is active for turning.

◆ getTool()

Tool getTool ( )

Returns the tool.

◆ getToolAxis()

Integer getToolAxis ( )

Returns the tool axis coordinate index (0:X, 1:Y, and 2:Z).

◆ getToolOrientation()

Number getToolOrientation ( )

Returns the turning tool orientation (radians).

◆ getType()

Integer getType ( )

Returns the type of the section.

The available types are:

  • TYPE_MILLING
  • TYPE_TURNING
  • TYPE_WIRE
  • TYPE_JET

◆ getUnit()

Integer getUnit ( )

Returns the original unit of the section. This may be different from the output unit.

The available values are:

  • IN - Inches
  • MM - Millimeters

◆ getUpperToolAxisABC()

Vector getUpperToolAxisABC ( )

Returns the upper machine angles for a multi-axis section. The section must have been optimized for the machine using optimizeMachineAngles() or similar before called this method.

◆ getWCS()

String getWCS ( )

Returns the WCS code string. If there is no WCS definition defined or the work offset is out of range, it will return an empty string.

◆ getWCSIndex()

Integer getWCSIndex ( )

Returns the WCS code index (without format). If there is no WCS definition defined or the work offset is out of range, it will return -1.

◆ getWCSOrigin()

Vector getWCSOrigin ( )

Returns the origin of the WCS.

◆ getWCSPlane()

Matrix getWCSPlane ( )

Returns the WCS plane.

◆ getWCSPosition()

Vector getWCSPosition ( Vector p )

Returns the WCS position for the specified local position.

◆ getWorkOffset()

Integer getWorkOffset ( )

Returns the work offset for the WCS.

◆ getWorkOrigin()

Vector getWorkOrigin ( )

Returns the work origin in the WCS.

◆ getWorkPlane()

Matrix getWorkPlane ( )

Returns the work plane in the WCS.

◆ getZRange()

Range getZRange ( )

Returns the Z-coordinate range of the toolpath of the section.

◆ hasAnyCycle()

Boolean hasAnyCycle ( )

Returns true if the section has any cycle.

Since
r41184

◆ hasCycle()

Boolean hasCycle ( String uri )

Returns true if the specified cycle occurs anywhere within the section.

Since
r41184

◆ hasCycleParameter()

Boolean hasCycleParameter | ( | Integer | index,
 |  | String | name
 | ) |  |

Returns true if the specified parameter has been defined in the given cycle.

Parameters
index | The index of the cycle.
name | The name of the parameter.
Since
r41215

◆ hasDynamicWorkOffset()

Boolean hasDynamicWorkOffset ( )

Returns true if the dynamic work offset is defined.

◆ hasParameter()

Boolean hasParameter ( String name )

Returns true if the specified parameter has been defined in the section.

◆ hasWellDefinedPosition()

Boolean hasWellDefinedPosition ( )

Returns true if the section has a well-defined position. Sections with no position would cause getInitialPosition() and getFinalPosition() to fail.

Since
r41192

◆ isCuttingMotionAwayFromRotary()

Boolean isCuttingMotionAwayFromRotary | ( | Number | distance,
 |  | Number | tolerance
 | ) |  |

Returns true if the milling motion for the section is further away from X0 Y0 than the given distance. Can be used to check if motion gets close to the rotary axis for XZC milling.

Parameters
distance | The minimum allowed distance from motion to X0 Y0.
tolerance | Tolerance used to linearize toolpath.
Returns
Returns false for non-milling toolpath.
Since
r41324

◆ isMultiAxis()

Boolean isMultiAxis ( )

Returns true is the section contains multi-axis toolpath.

◆ isOptimizedForMachine()

Boolean isOptimizedForMachine ( )

Returns true if the section has been optimized for a machine configuration.

◆ isOptional()

Boolean isOptional ( )

Returns true if the section is optional.

◆ isPatterned()

Boolean isPatterned ( )

Returns true if the section is patterned. Ie. at least one other section shares the same pattern id.

◆ isTopWorkPlane()

Boolean isTopWorkPlane ( )

Returns true if the work plane is set to the top plane (i.e. looking down the Z-axis) in the WCS.

This method has been deprecated. See isZOriented() instead.

◆ isXOriented()

Boolean isXOriented ( )

Returns true if the work plane is oriented such that forward is along the +X in the WCS.

The same as checking "currentSection.workPlane.forward.x >= (1 - EPSILON)".

◆ isYOriented()

Boolean isYOriented ( )

Returns true if the work plane is oriented such that forward is along the +Y in the WCS.

The same as checking "currentSection.workPlane.forward.y >= (1 - EPSILON)".

◆ isZOriented()

Boolean isZOriented ( )

Returns true if the work plane is oriented such that forward is along the +Z in the WCS.

The same as checking "currentSection.workPlane.forward.z >= (1 - EPSILON)".

◆ optimize3DPositionsByMachine()

optimize3DPositionsByMachine | ( | MachineConfiguration | machine,
 |  | Vector | abc,
 |  | Integer | optimizeType
 | ) |  |

Adjusts the tool end points for the rotary axes positions in 3+2 operations for the active machine configuration.

The directions for onRapid(), onLinear(), onCyclePoint(), and onCircular() are hereafter mapped according to the input rotary axis angles.

Parameters
machine | The machine configuration.
abc | The rotary axis positions.
optimizeType | Can be one of the following. OPTIMIZE_NONE: Maintain tool tip position (TCPM). OPTIMIZE_BOTH: Adjust for tables and heads OPTIMIZE_TABLES: Adjust for tables only. OPTIMIZE_HEADS: Adjust for heads only. OPTIMIZE_AXIS: Adjust per axis definition.

◆ optimizeMachineAnglesByMachine()

optimizeMachineAnglesByMachine | ( | MachineConfiguration | machine,
 |  | Integer | optimizeType
 | ) |  |

Optimizes the machine angles for 5-axis motion given the specified machine configuration.

The directions for onRapid5D() and onLinear5D() are hereafter mapped to machine angles from the initial direction vector. The work plane and origin are mapped into the WCS plane and origin.

Parameters
machine | The machine configuration.
optimizeType | 0 = TCP, 1 = adjust for tables and heads, 2 = adjust for tables, 3 = adjust for heads, 4 = adjust per axis definition.

Member Data Documentation

◆ dynamicWorkOffset

Integer dynamicWorkOffset

the display coordinates.

The dynamic work offset corresponding to the WCS used for controlling

◆ unit

Integer unit

unit).

Specifies the original unit of the section (this may be different from the output


Member List

Section Member List

This is the complete list of members for Section, including all inherited members.

axisSubstitution | Section
axisSubstitutionRadius | Section
checkGroup(Integer groups) | Section
doesEndWithCycle(String &_uri) noexcept | Section
doesEndWithCycleIgnoringPositioning(String uri) | Section
doesStartWithCycle(String uri) | Section
doesStartWithCycleIgnoringPositioning(String uri) | Section
doesStrictCycle(String uri) | Section
dynamicWorkOffset | Section
getAxisSubstitution() | Section
getAxisSubstitutionRadius() | Section
getBoundingBox() | Section
getChannel() | Section
getContent() | Section
getCuttingDistance() | Section
getCycleId(Integer index) | Section
getCycleParameter(Integer index, String name) | Section
getCycleTime() | Section
getDynamicWCSOrigin() | Section
getDynamicWCSPlane() | Section
getDynamicWorkOffset() | Section
getFCSOrigin() | Section
getFCSPlane() | Section
getFeedMode() | Section
getFinalPosition() | Section
getFinalSpindleOn() | Section
getFinalSpindleSpeed() | Section
getFinalToolAxis() | Section
getFinalToolAxisABC() | Section
getFirstCompensationOffset() | Section
getFirstCycle() | Section
getFirstPosition() | Section
getForceToolChange() | Section
getGlobalBoundingBox() | Section
getGlobalFinalToolAxis() | Section
getGlobalInitialToolAxis() | Section
getGlobalPosition(Vector p) | Section
getGlobalRange(Vector direction) | Section
getGlobalWorkOrigin() | Section
getGlobalWorkPlane() | Section
getGlobalZRange() | Section
getId() | Section
getInitialPosition() | Section
getInitialSpindleOn() | Section
getInitialSpindleSpeed() | Section
getInitialToolAxis() | Section
getInitialToolAxisABC() | Section
getJetMode() | Section
getJobId() | Section
getLastCycle() | Section
getLowerToolAxisABC() | Section
getMaximumFeedrate() | Section
getMaximumSpindleSpeed() | Section
getMaximumTilt() | Section
getModelOrigin() | Section
getModelPlane() | Section
getMovements() | Section
getNumberOfCyclePoints() | Section
getNumberOfCycles() | Section
getNumberOfCyclesWithId(String uri) | Section
getNumberOfPatternInstances() | Section
getNumberOfRecords() | Section
getOperationProperties() | Section
getOptimizedTCPMode() | Section
getParameter(String name, Value defaultValue) | Section
getPartCatcher() | Section
getPatternId() | Section
getProbeWorkOffset() | Section
getQuality() | Section
getRapidDistance() | Section
getRecord(Integer id) | Section
getSectionPosition(Vector p) | Section
getSpindle() | Section
getStrategy() | Section
getTailstock() | Section
getTool() | Section
getToolAxis() | Section
getToolOrientation() | Section
getType() | Section
getUnit() | Section
getUpperToolAxisABC() | Section
getWCS() | Section
getWCSIndex() | Section
getWCSOrigin() | Section
getWCSPlane() | Section
getWCSPosition(Vector p) | Section
getWorkOffset() | Section
getWorkOrigin() | Section
getWorkPlane() | Section
getZRange() | Section
hasAnyCycle() | Section
hasCycle(String uri) | Section
hasCycleParameter(Integer index, String name) | Section
hasDynamicWorkOffset() | Section
hasParameter(String name) | Section
hasWellDefinedPosition() | Section
isCuttingMotionAwayFromRotary(Number distance, Number tolerance) | Section
isMultiAxis() | Section
isOptimizedForMachine() | Section
isOptional() | Section
isPatterned() | Section
isTopWorkPlane() | Section
isXOriented() | Section
isYOriented() | Section
isZOriented() | Section
optimize3DPositionsByMachine(MachineConfiguration machine, Vector abc, Integer optimizeType) | Section
optimizeMachineAnglesByMachine(MachineConfiguration machine, Integer optimizeType) | Section
partCatcher | Section
probeWorkOffset | Section
properties | Section
quality | Section
spindle | Section
strategy | Section
tailstock | Section
type | Section
unit | Section
wcs | Section
wcsIndex | Section
wcsOrigin | Section
wcsPlane | Section
workOffset | Section
workOrigin | Section
workPlane | Section


Shaft Class Reference

Inherits ScriptObject.

Public Member Functions

Boolean hasSections ()
Integer getNumberOfSections ()
Number getMaximumDiameter ()
Number getTotalLength ()
Number | getDiameter (Integer index)
Number | getLength (Integer index)

Public Attributes

Number maximumDiameter
The maximum diameter.
Number length
from tip to tool holder. More...

Detailed Description

Shaft of tool.

Member Function Documentation

◆ getDiameter()

Number getDiameter ( Integer index )

Returns the diameter of the specified section. The section is a value in the range [0; getNumberOfSections()].

◆ getLength()

Number getLength ( Integer index )

Returns the length of the specified section. The section is a value in the range [0; getNumberOfSections()].

◆ getMaximumDiameter()

Number getMaximumDiameter ( )

Returns the maximum diameter of the shaft.

◆ getNumberOfSections()

Integer getNumberOfSections ( )

Returns the number of sections.

◆ getTotalLength()

Number getTotalLength ( )

Returns the length of the shaft.

◆ hasSections()

Boolean hasSections ( )

Returns true if the shaft has any sections.

Member Data Documentation

◆ length

Number length

from tip to tool holder.

The length of the shaft.

Attention
The tool body length specifies the length


Member List

Shaft Member List

This is the complete list of members for Shaft, including all inherited members.

getDiameter(Integer index) | Shaft
getLength(Integer index) | Shaft
getMaximumDiameter() | Shaft
getNumberOfSections() | Shaft
getTotalLength() | Shaft
hasSections() | Shaft
length | Shaft
maximumDiameter | Shaft


SMTP Class Reference

Inherits ScriptObject.

Public Member Functions

SMTP (String _hostname, short _port=25)
send (Mail mail)

Detailed Description

SMTP interface for sending e-mails. See Mail.

Constructor & Destructor Documentation

◆ SMTP()

SMTP | ( | String | _hostname,
 |  | short | _port = 25
 | ) |  |

Constructs a new SMTP instance.

Member Function Documentation

◆ send()

send ( Mail mail )

Sends the specified mail.


Member List

SMTP Member List

This is the complete list of members for SMTP, including all inherited members.

send(Mail mail) | SMTP
SMTP(String _hostname, short _port=25) | SMTP


String Class Reference

Public Member Functions

String | charAt (Integer index)
Array | split (String separator)
String toUpperCase ()
String toLowerCase ()

Detailed Description

JavaScript string.

Member Function Documentation

◆ charAt()

String charAt ( Integer index )

Returns the character at the specified index.

◆ split()

Array split ( String separator )

Splits the string at the specified separator.

◆ toLowerCase()

String toLowerCase ( )

Returns the lower case string for the specified string.

◆ toUpperCase()

String toUpperCase ( )

Returns the upper case string for the specified string.


Member List

String Member List

This is the complete list of members for String, including all inherited members.

charAt(Integer index) | String
split(String separator) | String


StringBuffer Class Reference

Inherits ScriptObject.

Public Member Functions

StringBuffer ()
clear ()
Boolean isEmpty ()
append (String text)
assign (String text)
String toString ()

Detailed Description

A string buffer for managing very long text.

Constructor & Destructor Documentation

◆ StringBuffer()

StringBuffer ( )

Initializes the buffer as empty.

Member Function Documentation

◆ append()

append ( String text )

Appends the specified text.

◆ assign()

assign ( String text )

Assigns the specified text.

◆ clear()

clear ( )

Clears the buffer.

◆ isEmpty()

Boolean isEmpty ( )

Returns true if the buffer is empty.

◆ toString()

String toString ( )

Returns the text in the buffer.


Member List

StringBuffer Member List

This is the complete list of members for StringBuffer, including all inherited members.

append(String text) | StringBuffer
assign(String text) | StringBuffer
clear() | StringBuffer
isEmpty() | StringBuffer
StringBuffer() | StringBuffer
toString() | StringBuffer


StringSubstitution Class Reference

Inherits ScriptObject.

Public Member Functions

StringSubstitution ()
setValue (String name, String value)
String substitute (String text)

Detailed Description

String substitution.

var subst = new StringSubstitution();
subst.setValue("description", "CNC Machine");
subst.setValue("tool", 16);
var text = subst.substitute(localize("Please load tool #${tool} on ${description}."));

Constructor & Destructor Documentation

◆ StringSubstitution()

StringSubstitution ( )

Constructs the string substituion instance.

Member Function Documentation

◆ setValue()

setValue | ( | String | name,
 |  | String | value
 | ) |  |

Sets the value for the specified key.

Parameters
name | The name.
value | The value.

◆ substitute()

String substitute ( String text )

Returns the substituted text.


Member List

StringSubstitution Member List

This is the complete list of members for StringSubstitution, including all inherited members.

setValue(String name, String value) | StringSubstitution
StringSubstitution() | StringSubstitution
substitute(String text) | StringSubstitution


Table Class Reference

Public Member Functions

Table (Array values, Map specifiers)
Value lookup (Integer index)
reset ()

Detailed Description

A lookup table.

var myTable = new Table(["A", "B", "C"], {initial:2, unchanged:"P"});
myTable.lookup(2); // returns "P"
myTable.lookup(1); // returns "B"
myTable.lookup(1); // returns "P"
myTable.reset();
myTable.lookup(1); // returns "B"

Constructor & Destructor Documentation

◆ Table()

Table | ( | Array | values,
 |  | Map | specifiers
 | ) |  |

Constructs a new lookup table.

Parameters
values | The array of possible values.
specifiers | The format specifiers.

The supported specifiers are:

  1. initial: The initial value.
  2. force: Specifies that the value must always be returned.
  3. unchanged: Specifies the value to be returned when the value is unchanged.

Member Function Documentation

◆ lookup()

Value lookup ( Integer index )

Returns the value at the specified index.

◆ reset()

reset ( )

Invoke to force output of value on the next invocation of lookup(). reset() has no effect if force has been set to true.


Member List

Table Member List

This is the complete list of members for Table, including all inherited members.

lookup(Integer index) | Table
reset() | Table
Table(Array values, Map specifiers) | Table


Template Class Reference

Public Member Functions

Template (String text)
String substitute (Map map)

Detailed Description

A string template.

var template = new Template("My first name is ${firstName} and my last name is ${lastName}.");
var str = template.substitute({firstName:"John", lastName:"Doe"});
// str is "My first name is John and my last name is Doe."

Constructor & Destructor Documentation

◆ Template()

Template ( String text )

Constructs a string template.

Parameters
text The templace text.

Member Function Documentation

◆ substitute()

String substitute ( Map map )

Returns the substitute text.

Parameters
map The variables.


Member List

Template Member List

This is the complete list of members for Template, including all inherited members.

substitute(Map map) | Template
Template(String text) | Template


TextFile Class Reference

Inherits ScriptObject.

Public Member Functions

TextFile (String path, Boolean write, String encoding)
Boolean isOpen ()
String readln ()
write (String text)
writeln (String text)
close ()

Detailed Description

Text file.

Security: Requires security level 0.

var path = FileSystem.replaceExtension(getOutputPath(), ".txt");
var file = new TextFile(path, true, "ansi");
file.writeln("Hello World!");
file.close();

Constructor & Destructor Documentation

◆ TextFile()

TextFile | ( | String | path,
 |  | Boolean | write,
 |  | String | encoding
 | ) |  |

Opens a text file for reading/writing.

Parameters
path | The path of the file to open.
write | Specifies if the file should be written or read.
encoding | The encoding of the text file.

Member Function Documentation

◆ close()

close ( )

Closes the file.

◆ isOpen()

Boolean isOpen ( )

Returns true if the file is open.

◆ readln()

String readln ( )

Reads a line.

◆ write()

write ( String text )

Writes the specified text without end-of-line.

Parameters
text The text to be written.

◆ writeln()

writeln ( String text )

Writes the specified text and an end-of-line.

Parameters
text The text to be written.


Member List

TextFile Member List

This is the complete list of members for TextFile, including all inherited members.

close() | TextFile
isOpen() | TextFile
readln() | TextFile
TextFile(String path, Boolean write, String encoding) | TextFile
write(String text) | TextFile
writeln(String text) | TextFile


Tool Class Reference

Inherits ScriptObject.

Public Member Functions

Tool ()
String getToolId ()
Integer getNumber ()
Integer getDiameterOffset ()
Integer getLengthOffset ()
Integer getSecondaryLengthOffset ()
Boolean isTurningTool ()
Boolean isJetTool ()
Integer getHolderNumber ()
Integer getSpindleMode ()
Number getSpindleRPM ()
Number getRampingSpindleRPM ()
Boolean isClockwise ()
Number getSurfaceSpeed ()
Number getMaximumSpindleSpeed ()
Integer getNumberOfFlutes ()
Number getThreadPitch ()
Number getTappingFeedrate ()
Boolean isDrill ()
Integer getCoolant ()
Integer getMaterial ()
String getDescription ()
String getComment ()
String getVendor ()
String getProductId ()
String getHolderDescription ()
String getHolderComment ()
String getHolderVendor ()
String getHolderProductId ()
String getAggregateId ()
Integer getUnit ()
Integer getType ()
Number getDiameter ()
Number getTipDiameter ()
Number getCornerRadius ()
Number getTaperAngle ()
Number getFluteLength ()
Number getShoulderLength ()
Number getShaftDiameter ()
Number getBodyLength ()
Shaft getShaft ()
Number getJetDiameter ()
Number getJetDistance ()
Number getHolderTipDiameter ()
Number getHolderDiameter ()
Number getHolderLength ()
Holder getHolder ()
Number getBoringBarOrientation ()
Integer getCompensationOffset ()
Integer getSecondaryCompensationOffset ()
Boolean getManualToolChange ()
Boolean getBreakControl ()
Boolean isLiveTool ()
Integer getTurret ()
Integer getInsertType ()
Integer getHolderType ()
Integer getCompensationMode ()
Vector getCompensationDisplacement ()
BoundingBox getExtent (Boolean includeHolder)
Curve getCutterProfile ()
Curve getHolderProfile ()
String getCutterProfileAsSVGPath ()
String getHolderProfileAsSVGPath ()
Mesh getCutterAsMesh (Number tolerance)
Mesh getHolderAsMesh (Number tolerance)

Public Attributes

Integer number
The tool number.
Integer turret
The turret.
Integer diameterOffset
The diameter offset (used for milling).
Integer lengthOffset
The length offset (used for milling).
Integer compensationOffset
The compensation offset (used for turning).
Boolean manualToolChange
True if tool must be manually changed.
Boolean breakControl
True if break control is enabled.
Boolean liveTool
True if the tool is live - otherwise it is static.
Integer holderNumber
Number identifying the holder.
Integer spindleMode
The spindle mode.
Number spindleRPM
The spindle speed in RPM. Positive for clockwise direction.
Number rampingSpindleRPM
The spindle speed in RPM for ramping. Positive for clockwise direction.
Number surfaceSpeed
The surface speed (CSS).
Number maximumSpindleSpeed
The maximum spindle speed (RPM) when using surface speed (CSS).
Integer numberOfFlutes
The number of flutes.
Number threadPitch
The number of thread per unit of length.
Integer coolant
The coolant.
Integer material
The material.
String comment
Comment.
String vendor
The vendor.
String productId
The product id.
Integer unit
The unit.
Integer type
The tool type.
Number diameter
The diameter.
Number cornerRadius
The corner radius.
Number taperAngle
The taper angle.
Number fluteLength
The flute length.
Number shoulderLength
The shoulder length.
Number shaftDiameter
The shaft diameter.
Number bodyLength
The body length.
Shaft shaft
The tool shaft.
Number holderTipDiameter
The holder tip diameter.
Number holderDiameter
The holder diameter.
Number holderLength
The holder length.
Holder holder
The tool holder.
Number boringBarOrientation
The boring bar orientation in radians.
Number inscribedCircleDiameter
The inscribed circle diameter for turning tool.
Number edgeLength
The edge length for turning tool.
Number noseRadius
The nose radius for turning tools.
Number reliefAngle
The relief angle in degrees.
Number thickness
The turning tool thickness;.
Number grooveWidth
The groove tool width.
String crossSection
The cross section type for turning tools.
String tolerance
The tolerance for turning tools.
Number pitch
The thread pitch for turning tools.
String hand
The holder hand. Left, Right, or Neutral.
String clamping
Clamping for turning tools.

Detailed Description

A tool specification.

Constructor & Destructor Documentation

◆ Tool()

Tool ( )

Constructs a tool.

Member Function Documentation

◆ getAggregateId()

String getAggregateId ( )

Returns the aggregate id.

◆ getBodyLength()

Number getBodyLength ( )

Returns the body length.

◆ getBoringBarOrientation()

Number getBoringBarOrientation ( )

Returns the boring bar orientation in radians.

◆ getBreakControl()

Boolean getBreakControl ( )

Returns true if break control is enabled.

◆ getComment()

String getComment ( )

Returns the tool comment.

◆ getCompensationDisplacement()

Vector getCompensationDisplacement ( )

Returns the turning compensation displacement for the toolpath. The Z-coordinate is always 0.

Since
41366

◆ getCompensationMode()

Integer getCompensationMode ( )

Returns the turning compensation mode.

The available modes are:

  • TOOL_COMPENSATION_INSERT_CENTER
  • TOOL_COMPENSATION_TIP
  • TOOL_COMPENSATION_TIP_CENTER
  • TOOL_COMPENSATION_TIP_TANGENT

◆ getCompensationOffset()

Integer getCompensationOffset ( )

Returns the primary compensation offset for turning.

◆ getCoolant()

Integer getCoolant ( )

Returns the coolant mode.

◆ getCornerRadius()

Number getCornerRadius ( )

Returns the corner radius.

◆ getCutterAsMesh()

Mesh getCutterAsMesh ( Number tolerance )

Returns the cutter as a mesh.

Parameters
tolerance The linearization tolerance.
Since
42020
var mesh = tool.getCutterAsMesh(tolerance);
mesh.scale(10);
Mesh.saveMesh("mycutter.stl", "application/sla", mesh);
mesh = tool.getHolderAsMesh(tolerance);
mesh.scale(10);
Mesh.saveMesh("myholder.stl", "application/sla", mesh);

◆ getCutterProfile()

Curve getCutterProfile ( )

Returns the profile of the cutter as a Curve.

Since
41366

◆ getCutterProfileAsSVGPath()

String getCutterProfileAsSVGPath ( )

Returns the SVG profile of the cutter.

Since
41366

◆ getDescription()

String getDescription ( )

Returns the tool description.

◆ getDiameter()

Number getDiameter ( )

Returns the cutter diameter.

◆ getDiameterOffset()

Integer getDiameterOffset ( )

Returns the diameter offset.

◆ getExtent()

BoundingBox getExtent ( Boolean includeHolder )

Returns the tool extent.

Parameters
includeHolder Set to true to include the extent of the holder.
Since
41366

◆ getFluteLength()

Number getFluteLength ( )

Returns the flute length.

◆ getHolder()

Holder getHolder ( )

Returns the holder.

◆ getHolderAsMesh()

Mesh getHolderAsMesh ( Number tolerance )

Returns the holder as a mesh.

Parameters
tolerance The linearization tolerance.
Since
42020

◆ getHolderComment()

String getHolderComment ( )

Returns the holder comment.

◆ getHolderDescription()

String getHolderDescription ( )

Returns the holder description.

◆ getHolderDiameter()

Number getHolderDiameter ( )

Returns the maximum holder diameter.

◆ getHolderLength()

Number getHolderLength ( )

Returns the total holder length.

◆ getHolderNumber()

Integer getHolderNumber ( )

Returns the holder number.

◆ getHolderProductId()

String getHolderProductId ( )

Returns the holder product id.

◆ getHolderProfile()

Curve getHolderProfile ( )

Returns the profile of the holder as a Curve.

Since
41366

◆ getHolderProfileAsSVGPath()

String getHolderProfileAsSVGPath ( )

Returns the SVG profile of the holder.

Since
41366

◆ getHolderTipDiameter()

Number getHolderTipDiameter ( )

Returns the tip diameter of the holder.

◆ getHolderType()

Integer getHolderType ( )

Returns the turning holder type.

The available types are:

  • HOLDER_NONE
  • HOLDER_ISO_A
  • HOLDER_ISO_B
  • HOLDER_ISO_C
  • HOLDER_ISO_D
  • HOLDER_ISO_E
  • HOLDER_ISO_F
  • HOLDER_ISO_G
  • HOLDER_ISO_H
  • HOLDER_ISO_J
  • HOLDER_ISO_K
  • HOLDER_ISO_L
  • HOLDER_ISO_M
  • HOLDER_ISO_N
  • HOLDER_ISO_P
  • HOLDER_ISO_Q
  • HOLDER_ISO_R
  • HOLDER_ISO_S
  • HOLDER_ISO_T
  • HOLDER_ISO_U
  • HOLDER_ISO_V
  • HOLDER_ISO_W
  • HOLDER_ISO_Y
  • HOLDER_OFFSET_PROFILE
  • HOLDER_STRAIGHT_PROFILE
  • HOLDER_GROOVE_EXTERNAL
  • HOLDER_GROOVE_INTERNAL
  • HOLDER_GROOVE_FACE
  • HOLDER_THREAD_STRAIGHT
  • HOLDER_THREAD_OFFSET
  • HOLDER_THREAD_FACE
  • HOLDER_BORING_BAR_ISO_F 0 deg end clearance
  • HOLDER_BORING_BAR_ISO_G 0 deg side clearance
  • HOLDER_BORING_BAR_ISO_J -3 deg side
  • HOLDER_BORING_BAR_ISO_K 15 deg end clearance
  • HOLDER_BORING_BAR_ISO_L -5 deg side clearance
  • HOLDER_BORING_BAR_ISO_P -27.5 deg end clearance
  • HOLDER_BORING_BAR_ISO_Q 17.5 deg end clearance
  • HOLDER_BORING_BAR_ISO_S 45 deg end
  • HOLDER_BORING_BAR_ISO_U -3 deg end clearance
  • HOLDER_BORING_BAR_ISO_W -30 deg end
  • HOLDER_BORING_BAR_ISO_Y 5 deg end
  • HOLDER_BORING_BAR_ISO_X 5 deg back boring

◆ getHolderVendor()

String getHolderVendor ( )

Returns the holder vendor.

◆ getInsertType()

Integer getInsertType ( )

Returns the turning insert type.

The available types are:

  • TURNING_INSERT_USER_DEFINED
  • TURNING_INSERT_ISO_A - 85deg parallelogram - 85deg
  • TURNING_INSERT_ISO_B - 82deg parallelogram - 82deg
  • TURNING_INSERT_ISO_C - 80deg diamond - 80deg
  • TURNING_INSERT_ISO_D - 55deg diamond - 55deg
  • TURNING_INSERT_ISO_E - 75deg diamond - 75deg
  • TURNING_INSERT_ISO_H - hexagon - 120deg
  • TURNING_INSERT_ISO_K - 55deg parallelogram - 55deg
  • TURNING_INSERT_ISO_L - rectangle - 90deg
  • TURNING_INSERT_ISO_M - 86deg diamond - 86deg
  • TURNING_INSERT_ISO_O - octagon - 135deg
  • TURNING_INSERT_ISO_P - pentagon - 108deg
  • TURNING_INSERT_ISO_R - round - full radius
  • TURNING_INSERT_ISO_S - square - 90deg
  • TURNING_INSERT_ISO_T - triangle - 60deg
  • TURNING_INSERT_ISO_V - 35deg diamond - 35deg
  • TURNING_INSERT_ISO_W - trigon - 80deg
  • TURNING_INSERT_GROOVE_ROUND
  • TURNING_INSERT_GROOVE_RADIUS
  • TURNING_INSERT_GROOVE_SQUARE
  • TURNING_INSERT_GROOVE_CHAMFER
  • TURNING_INSERT_GROOVE_40DEG
  • TURNING_INSERT_THREAD_ISO_DOUBLE_FULL
  • TURNING_INSERT_THREAD_ISO_TRIPLE_FULL
  • TURNING_INSERT_THREAD_UTS_DOUBLE_FULL
  • TURNING_INSERT_THREAD_UTS_TRIPLE_FULL
  • TURNING_INSERT_THREAD_ISO_DOUBLE_VPROFILE
  • TURNING_INSERT_THREAD_ISO_TRIPLE_VPROFILE
  • TURNING_INSERT_THREAD_UTS_DOUBLE_VPROFILE
  • TURNING_INSERT_THREAD_UTS_TRIPLE_VPROFILE

◆ getJetDiameter()

Number getJetDiameter ( )

Returns the jet diameter.

◆ getJetDistance()

Number getJetDistance ( )

Returns the jet distance.

◆ getLengthOffset()

Integer getLengthOffset ( )

Returns the length offset.

◆ getManualToolChange()

Boolean getManualToolChange ( )

Returns true if the tool must be manually changed.

◆ getMaterial()

Integer getMaterial ( )

Returns the material.

◆ getMaximumSpindleSpeed()

Number getMaximumSpindleSpeed ( )

Returns the maximum spindle speed (RPM) when using surface speed (CSS).

◆ getNumber()

Integer getNumber ( )

Returns the tool number.

◆ getNumberOfFlutes()

Integer getNumberOfFlutes ( )

Returns the number of flutes.

◆ getProductId()

String getProductId ( )

Returns the tool product id.

◆ getRampingSpindleRPM()

Number getRampingSpindleRPM ( )

Returns the ramping spindle speed in RPM (rotations per minute).

◆ getSecondaryCompensationOffset()

Integer getSecondaryCompensationOffset ( )

Returns the secondary compensation offset for turning.

◆ getSecondaryLengthOffset()

Integer getSecondaryLengthOffset ( )

Returns the secondary length offset.

◆ getShaft()

Shaft getShaft ( )

Returns the shaft.

◆ getShaftDiameter()

Number getShaftDiameter ( )

Returns the shaft diameter.

◆ getShoulderLength()

Number getShoulderLength ( )

Returns the shoulder length.

◆ getSpindleMode()

Integer getSpindleMode ( )

Returns the spindle mode.

The available modes are:

  • SPINDLE_CONSTANT_SPINDLE_SPEED
  • SPINDLE_CONSTANT_SURFACE_SPEED

◆ getSpindleRPM()

Number getSpindleRPM ( )

Returns the spindle speed in RPM (rotations per minute).

◆ getSurfaceSpeed()

Number getSurfaceSpeed ( )

Returns the surface speed (CSS).

◆ getTaperAngle()

Number getTaperAngle ( )

Returns the taper angle in radians.

◆ getTappingFeedrate()

Number getTappingFeedrate ( )

Returns the tapping feedrate as spindle RPM * thread pitch.

◆ getThreadPitch()

Number getThreadPitch ( )

Returns the number of threads per unit of length.

◆ getTipDiameter()

Number getTipDiameter ( )

Returns the tip diameter.

◆ getToolId()

String getToolId ( )

Returns the tool id.

Note: it is an internal (unique) id of the tool in a Fusion/Inventor document. For instance, when adding/creating a tool (not exist) in the document, a new id is created for the tool, which is added into the document's tool library.

◆ getTurret()

Integer getTurret ( )

Returns the turret for turning.

◆ getType()

Integer getType ( )

Returns the tool type.

The types are:

  • TOOL_UNSPECIFIED - Unspecified tool.
  • TOOL_DRILL - Drill.
  • TOOL_DRILL_CENTER - Center drill.
  • TOOL_DRILL_SPOT - Spot drill.
  • TOOL_DRILL_BLOCK - Block drill.
  • TOOL_MILLING_END_FLAT - Flat end-mill.
  • TOOL_MILLING_END_BALL - Ball end-mill.
  • TOOL_MILLING_END_BULLNOSE - Bullnose mill.
  • TOOL_MILLING_CHAMFER - Chamfer mill.
  • TOOL_MILLING_FACE - Face mill.
  • TOOL_MILLING_SLOT - Slot mill.
  • TOOL_MILLING_RADIUS - Radius mill.
  • TOOL_MILLING_DOVETAIL - Dovetail mill.
  • TOOL_MILLING_TAPERED - Tapered mill.
  • TOOL_MILLING_LOLLIPOP - Lollipop mill.
  • TOOL_TAP_RIGHT_HAND - Right tap tool.
  • TOOL_TAP_LEFT_HAND - Left tap tool.
  • TOOL_REAMER - Reamer tool.
  • TOOL_BORING_BAR - Boring bar tool.
  • TOOL_COUNTER_BORE - Counterbore tool.
  • TOOL_COUNTER_SINK - Countersink tool.
  • TOOL_HOLDER_ONLY - Holder.
  • TOOL_TURNING_GENERAL - General turning tool.
  • TOOL_TURNING_THREADING - Thread turning tool.
  • TOOL_TURNING_GROOVING - Groove turning tool.
  • TOOL_TURNING_BORING - Boring turning tool.
  • TOOL_TURNING_CUSTOM - Custom turning tool.
  • TOOL_PROBE - Probe.
  • TOOL_WIRE - Wire.
  • TOOL_WATER_JET - Water jet.
  • TOOL_LASER_CUTTER - Laser cutter.
  • TOOL_WELDER - Welder.
  • TOOL_GRINDER - Grinder.
  • TOOL_MILLING_FORM - Form mill.
  • TOOL_PLASMA_CUTTER - Plasma cutter.
  • TOOL_MARKER - Marker tool.
  • TOOL_MILLING_THREAD - Thread mill.

◆ getUnit()

Integer getUnit ( )

Returns the tool unit.

The available values are:

  • IN - Inches
  • MM - Millimeters

◆ getVendor()

String getVendor ( )

Returns the tool vendor.

◆ isClockwise()

Boolean isClockwise ( )

Returns true if the spindle rotates in clockwise direction.

◆ isDrill()

Boolean isDrill ( )

Returns true if the tool is a drill.

◆ isJetTool()

Boolean isJetTool ( )

Returns true if the tool is a jet tool.

◆ isLiveTool()

Boolean isLiveTool ( )

Returns true if the tool is live. Otherwise tool is static (ie. mounted without a spindle).

Since
41222

◆ isTurningTool()

Boolean isTurningTool ( )

Returns true if the tool is a turning tool.


Member List

Tool Member List

This is the complete list of members for Tool, including all inherited members.

bodyLength | Tool
boringBarOrientation | Tool
breakControl | Tool
clamping | Tool
comment | Tool
compensationOffset | Tool
coolant | Tool
cornerRadius | Tool
crossSection | Tool
diameter | Tool
diameterOffset | Tool
edgeLength | Tool
fluteLength | Tool
getAggregateId() | Tool
getBodyLength() | Tool
getBoringBarOrientation() | Tool
getBreakControl() | Tool
getComment() | Tool
getCompensationDisplacement() | Tool
getCompensationMode() | Tool
getCompensationOffset() | Tool
getCoolant() | Tool
getCornerRadius() | Tool
getCutterAsMesh(Number tolerance) | Tool
getCutterProfile() | Tool
getCutterProfileAsSVGPath() | Tool
getDescription() | Tool
getDiameter() | Tool
getDiameterOffset() | Tool
getExtent(Boolean includeHolder) | Tool
getFluteLength() | Tool
getHolder() | Tool
getHolderAsMesh(Number tolerance) | Tool
getHolderComment() | Tool
getHolderDescription() | Tool
getHolderDiameter() | Tool
getHolderLength() | Tool
getHolderNumber() | Tool
getHolderProductId() | Tool
getHolderProfile() | Tool
getHolderProfileAsSVGPath() | Tool
getHolderTipDiameter() | Tool
getHolderType() | Tool
getHolderVendor() | Tool
getInsertType() | Tool
getJetDiameter() | Tool
getJetDistance() | Tool
getLengthOffset() | Tool
getManualToolChange() | Tool
getMaterial() | Tool
getMaximumSpindleSpeed() | Tool
getNumber() | Tool
getNumberOfFlutes() | Tool
getProductId() | Tool
getRampingSpindleRPM() | Tool
getSecondaryCompensationOffset() | Tool
getSecondaryLengthOffset() | Tool
getShaft() | Tool
getShaftDiameter() | Tool
getShoulderLength() | Tool
getSpindleMode() | Tool
getSpindleRPM() | Tool
getSurfaceSpeed() | Tool
getTaperAngle() | Tool
getTappingFeedrate() | Tool
getThreadPitch() | Tool
getTipDiameter() | Tool
getToolId() | Tool
getTurret() | Tool
getType() | Tool
getUnit() | Tool
getVendor() | Tool
grooveWidth | Tool
hand | Tool
holder | Tool
holderDiameter | Tool
holderLength | Tool
holderNumber | Tool
holderTipDiameter | Tool
inscribedCircleDiameter | Tool
isClockwise() | Tool
isDrill() | Tool
isJetTool() | Tool
isLiveTool() | Tool
isTurningTool() | Tool
lengthOffset | Tool
liveTool | Tool
manualToolChange | Tool
material | Tool
maximumSpindleSpeed | Tool
noseRadius | Tool
number | Tool
numberOfFlutes | Tool
pitch | Tool
productId | Tool
rampingSpindleRPM | Tool
reliefAngle | Tool
shaft | Tool
shaftDiameter | Tool
shoulderLength | Tool
spindleMode | Tool
spindleRPM | Tool
surfaceSpeed | Tool
taperAngle | Tool
thickness | Tool
threadPitch | Tool
tolerance | Tool
Tool() | Tool
turret | Tool
type | Tool
unit | Tool
vendor | Tool


ToolRenderer Class Reference

Inherits ScriptObject.

Public Member Functions

ToolRenderer ()
setSegment (Integer segment)
setBackgroundColor (Color color)
setFluteColor (Color color)
setShoulderColor (Color color)
setShaftColor (Color color)
setHolderColor (Color color)
exportAs (String path, String mimetype, Tool tool, Number width, Number height)
String getAsBinary (String mimetype, Tool tool, Number width, Number height)

Detailed Description

Tool to image converter.

Constructor & Destructor Documentation

◆ ToolRenderer()

ToolRenderer ( )

Initializes the tool renderer.

Member Function Documentation

◆ exportAs()

exportAs | ( | String | path,
 |  | String | mimetype,
 |  | Tool | tool,
 |  | Number | width,
 |  | Number | height
 | ) |  |

Exports the tool image to the specified path.

Parameters
path | The destination path.
mimetype | The MIME type of the image (must be "image/png").
tool | The tool to render.
width | The width of the image.
height | The height of the image.

◆ getAsBinary()

String getAsBinary | ( | String | mimetype,
 |  | Tool | tool,
 |  | Number | width,
 |  | Number | height
 | ) |  |

Exports the tool image to a binary string.

Parameters
mimetype | The MIME type of the image (must be "image/png").
tool | The tool to render.
width | The width of the image.
height | The height of the image.
Returns
Returns string with each byte represented as its own character.
Since
41349

◆ setBackgroundColor()

setBackgroundColor ( Color color )

Sets the background color.

◆ setFluteColor()

setFluteColor ( Color color )

Sets the color of the flute.

◆ setHolderColor()

setHolderColor ( Color color )

Sets the color of the holder.

◆ setSegment()

setSegment ( Integer segment )

Sets the tool segments to render.

Parameters
segment The segment which can be TOOL_FLUTE, TOOL_SHOULDER, or TOOL_SHAFT.

◆ setShaftColor()

setShaftColor ( Color color )

Sets the color of the shaft.

◆ setShoulderColor()

setShoulderColor ( Color color )

Sets the color of the shoulder.


Member List

ToolRenderer Member List

This is the complete list of members for ToolRenderer, including all inherited members.

exportAs(String path, String mimetype, Tool tool, Number width, Number height) | ToolRenderer
getAsBinary(String mimetype, Tool tool, Number width, Number height) | ToolRenderer
setBackgroundColor(Color color) | ToolRenderer
setFluteColor(Color color) | ToolRenderer
setHolderColor(Color color) | ToolRenderer
setSegment(Integer segment) | ToolRenderer
setShaftColor(Color color) | ToolRenderer
setShoulderColor(Color color) | ToolRenderer


ToolTable Class Reference

Inherits ScriptObject.

Public Member Functions

Integer getNumberOfTools ()
Tool getTool (Integer index)

Detailed Description

Tool table.

Member Function Documentation

◆ getNumberOfTools()

Integer getNumberOfTools ( )

Returns the number of tools in the tool table.

◆ getTool()

Tool getTool ( Integer index )

Returns the tool at the specified index. The index must be in the range [0; getNumberOfTools()].


Member List

ToolTable Member List

This is the complete list of members for ToolTable, including all inherited members.

getNumberOfTools() | ToolTable
getTool(Integer index) | ToolTable


Value Class Reference

Detailed Description

JavaScript value. Can be either Boolean, Integer, Number, or String.


Variable Class Reference

Public Member Functions

Variable (Map specifiers, Format format)
String format (Number value)
Value getPrefix ()
setPrefix (Value prefix)
disable ()
reset ()
Value getCurrent ()

Detailed Description

A formatting variable. Instances of this class are used to format incoming values. State is maintained to avoid output for unchanged values.

var xFormat = createFormat({decimals:3, trim:false});
var xVariable = createVariable({prefix: "X"}, xFormat);
var str = xVariable.format(4.4); // returns "X4.400"
str = xVariable.format(4.4); // returns ""
str = xVariable.format(7); // returns "X7.000"

Constructor & Destructor Documentation

◆ Variable()

Variable | ( | Map | specifiers,
 |  | Format | format
 | ) |  |

Constructs a variable.

Parameters
specifiers | The specifiers.
format | The desired format.

The supported specifiers are:

  1. prefix: Specifies a prefix to be prepended the formatted value.
  2. force: Specifies that the value always must be output.

Member Function Documentation

◆ disable()

disable ( )

Disable variable. When invoked format() always returns the empty string.

◆ format()

String format ( Number value )

Returns the formatted string of the specified value. The empty string is returned if the value is identical to the last formatted value.

◆ getCurrent()

Value getCurrent ( )

Returns the last formatted value.

◆ getPrefix()

Value getPrefix ( )

Returns the prefix.

◆ reset()

reset ( )

Invoke to force output of value on the next invocation of format(). reset() has no effect if force has been set to true for the given format.

◆ setPrefix()

setPrefix ( Value prefix )

Sets the prefix.


Member List

Variable Member List

This is the complete list of members for Variable, including all inherited members.

disable() | Variable
format(Number value) | Variable
getCurrent() | Variable
getPrefix() | Variable
reset() | Variable
setPrefix(Value prefix) | Variable
Variable(Map specifiers, Format format) | Variable


Vector Class Reference

Inherits ScriptObject.

Public Member Functions

Vector ()
Vector (Number x, Number y, Number z)
Number getX ()
setX (Number x)
Number getY ()
setY (Number y)
Number getZ ()
setZ (Number z)
Number getCoordinate (Integer coordinate)
setCoordinate (Integer coordinate, Number value)
add (Vector value)
add (Number x, Number y, Number z)
subtract (Vector value)
subtract (Number x, Number y, Number z)
multiply (Number value)
divide (Number value)
Boolean isNonZero ()
Boolean isZero ()
Number getXYAngle ()
Number getZAngle ()
Number getLength ()
Number getLength2 ()
normalize ()
Vector getNormalized ()
negate ()
Vector getNegated ()
Vector getAbsolute ()
Number getMinimum ()
Number getMaximum ()
String toString ()
Vector toDeg ()
Vector toRad ()

Static Public Member Functions

static Vector | sum (Vector left, Vector right)
static Vector | diff (Vector left, Vector right)
static Vector | product (Vector left, Number right)
static Number | dot (Vector left, Vector right)
static Number | getAngle (Vector v1, Vector v2)
static Vector | cross (Vector left, Vector right)
static Number | getDistance (Vector left, Vector right)
static Number | getDistance2 (Vector left, Vector right)
static Vector | lerp (Vector left, Vector right, Number u)
static Vector | getBySpherical (Number xyAngle, Number zAngle, Number radius)

Public Attributes

Number x
The X coordinate.
Number y
The Y coordinate.
Number z
The Z coordinate.
Number length
The length of the vector.
Number length2
The square of the length of the vector.
Vector negated
The negated vector.
Vector abs
The vector with the absolute coordinates.
Vector normalized
The vector normalized to length 1.

Detailed Description

A 3D vector (X, Y, and Z coordinates).

Constructor & Destructor Documentation

◆ Vector() [1/2]

Vector ( )

Constructs a (0, 0, 0) vector.

◆ Vector() [2/2]

Vector | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

Constructs a vector with the specified x, y, and z coordinates.

Member Function Documentation

◆ add() [1/2]

add ( Vector value )

Adds the specified vector.

◆ add() [2/2]

add | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

Adds the specified X, Y, and Z coordinates.

◆ cross()

static Vector cross | ( | Vector | left,
 |  | Vector | right
 | ) |  |
static

Returns the cross product of this vector and the specified vector.

◆ diff()

static Vector diff | ( | Vector | left,
 |  | Vector | right
 | ) |  |
static

Returns the difference of the specified vectors.

◆ divide()

divide ( Number value )

Divides the vector by the specified value.

◆ dot()

static Number dot | ( | Vector | left,
 |  | Vector | right
 | ) |  |
static

Returns the dot product of this vector and the specified vector.

◆ getAbsolute()

Vector getAbsolute ( )

Returns the vector with the absolute values of the coordinates.

◆ getAngle()

static Number getAngle | ( | Vector | v1,
 |  | Vector | v2
 | ) |  |
static

Returns the angle between the specified vectors.

◆ getBySpherical()

static Vector getBySpherical | ( | Number | xyAngle,
 |  | Number | zAngle,
 |  | Number | radius
 | ) |  |
static

Returns the vector for the specified spherical coordinates.

◆ getCoordinate()

Number getCoordinate ( Integer coordinate )

Returns the specified coordinate (0:X, 1:Y, and 2:Z).

◆ getDistance()

static Number getDistance | ( | Vector | left,
 |  | Vector | right
 | ) |  |
static

Returns the distance between the specified vectors.

◆ getDistance2()

static Number getDistance2 | ( | Vector | left,
 |  | Vector | right
 | ) |  |
static

Returns the square of the distance between the specified vectors.

◆ getLength()

Number getLength ( )

Returns the length of this vector.

◆ getLength2()

Number getLength2 ( )

Returns the square length of this vector.

◆ getMaximum()

Number getMaximum ( )

Returns the value for the maximum coordinate.

◆ getMinimum()

Number getMinimum ( )

Returns the value for the minimum coordinate.

◆ getNegated()

Vector getNegated ( )

Returns the negated vector.

◆ getNormalized()

Vector getNormalized ( )

Returns the normalized vector.

◆ getX()

Number getX ( )

Returns the X coordinate.

◆ getXYAngle()

Number getXYAngle ( )

Returns the angle in the X-Y plane (spherical coordinate).

◆ getY()

Number getY ( )

Returns the Y coordinate.

◆ getZ()

Number getZ ( )

Returns the Z coordinate.

◆ getZAngle()

Number getZAngle ( )

Returns the Z angle relative to the X-Y plane (spherical coordinate).

◆ isNonZero()

Boolean isNonZero ( )

Returns true if the vector has non-zero length.

◆ isZero()

Boolean isZero ( )

Returns true if the vector has non-zero length.

◆ lerp()

static Vector lerp | ( | Vector | left,
 |  | Vector | right,
 |  | Number | u
 | ) |  |
static

Linear interpolation between the specified vectors. The U coordinate is clamped to the range [0; 1]. U equal to 0 and 1 corresponds to the left vector and the right vector, respectively.

◆ multiply()

multiply ( Number value )

Multiplies the specified value.

◆ negate()

negate ( )

Negates the vector.

◆ normalize()

normalize ( )

Normalizes the vector.

◆ product()

static Vector product | ( | Vector | left,
 |  | Number | right
 | ) |  |
static

Returns the product of the specified vector and number.

◆ setCoordinate()

setCoordinate | ( | Integer | coordinate,
 |  | Number | value
 | ) |  |

Sets the specified coordinate (0:X, 1:Y, and 2:Z).

◆ setX()

setX ( Number x )

Sets the X coordinate.

◆ setY()

setY ( Number y )

Sets the Y coordinate.

◆ setZ()

setZ ( Number z )

Sets the Z coordinate.

◆ subtract() [1/2]

subtract ( Vector value )

Subtracts the specified vector.

◆ subtract() [2/2]

subtract | ( | Number | x,
 |  | Number | y,
 |  | Number | z
 | ) |  |

Subtracts the specified X, Y, and Z coordinates.

◆ sum()

static Vector sum | ( | Vector | left,
 |  | Vector | right
 | ) |  |
static

Returns the sum of the specified vectors.

◆ toDeg()

Vector toDeg ( )

Returns the value converted from radians to degrees.

◆ toRad()

Vector toRad ( )

Returns the value converted from degrees to radians.

◆ toString()

String toString ( )

Converts the vector to a string (e.g. (1, 2, 3)).


Member List

Vector Member List

This is the complete list of members for Vector, including all inherited members.

abs Vector
add(Vector value) | Vector
add(Number x, Number y, Number z) | Vector
cross(Vector left, Vector right) | Vector | static
diff(Vector left, Vector right) | Vector | static
divide(Number value) | Vector
dot(Vector left, Vector right) | Vector | static
getAbsolute() Vector
getAngle(Vector v1, Vector v2) | Vector | static
getBySpherical(Number xyAngle, Number zAngle, Number radius) | Vector | static
getCoordinate(Integer coordinate) | Vector
getDistance(Vector left, Vector right) | Vector | static
getDistance2(Vector left, Vector right) | Vector | static
getLength() Vector
getLength2() Vector
getMaximum() Vector
getMinimum() Vector
getNegated() Vector
getNormalized() Vector
getX() Vector
getXYAngle() Vector
getY() Vector
getZ() Vector
getZAngle() Vector
isNonZero() Vector
isZero() Vector
length Vector
length2 Vector
lerp(Vector left, Vector right, Number u) | Vector | static
multiply(Number value) | Vector
negate() Vector
negated Vector
normalize() Vector
normalized Vector
product(Vector left, Number right) | Vector | static
setCoordinate(Integer coordinate, Number value) | Vector
setX(Number x) | Vector
setY(Number y) | Vector
setZ(Number z) | Vector
subtract(Vector value) | Vector
subtract(Number x, Number y, Number z) | Vector
sum(Vector left, Vector right) | Vector | static
toDeg() Vector
toRad() Vector
toString() Vector
Vector() Vector
Vector(Number x, Number y, Number z) | Vector


VectorPair Class Reference

Inherits ScriptObject.

Public Attributes

Vector first
Vector second

Detailed Description

Two vectors.

Member Data Documentation

◆ first

Vector first

The first vector.

◆ second

Vector second

The second vector.


Member List

VectorPair Member List

This is the complete list of members for VectorPair, including all inherited members.


XMLHttpRequest Class Reference

Inherits ScriptObject.

Public Member Functions

XMLHttpRequest ()
open (String method, String url, Boolean async, String user, String password)
abort ()
setRequestHeader (String name, String value)
send (String data)
String getResponseHeader (String name)

Public Attributes

String response
The request response.
String responseXML
Not supported.
Integer status
The status.
String statusText
The status text.

Detailed Description

XMLHttpRequest support.

Security: Requires security level 0.

var request = XMLHttpRequest();
request.open("GET", "https://autodesk.com", false, "", "");
request.send(null);
log(request.response);
Since
41366

Constructor & Destructor Documentation

◆ XMLHttpRequest()

XMLHttpRequest ( )

Constructs an XMLHttpRequest object.

Member Function Documentation

◆ abort()

abort ( )

Aborts the request.

◆ getResponseHeader()

String getResponseHeader ( String name )

Returns the value of response header field. Returns an empty string if the requested header field is not present or empty in the response

Parameters
name The name of the header field. Precondition: open() and send() called

◆ open()

open | ( | String | method,
 |  | String | url,
 |  | Boolean | async,
 |  | String | user,
 |  | String | password
 | ) |  |

Initializes the request.

Parameters
method | The request method.
url | The connection url.
async | True for asynchronous. Not supported.
user | The user.
password | The password.

◆ send()

send ( String data )

Sends the request.

Parameters
data The request body data.(unused for a GET request)

◆ setRequestHeader()

setRequestHeader | ( | String | name,
 |  | String | value
 | ) |  |

Sets the value of request header field. Must be called before send(). If the header field already exists, the value will be appended to the previous value.

Parameters
name | The name of the header field.
value | The value of the header field.


Member List

XMLHttpRequest Member List

This is the complete list of members for XMLHttpRequest, including all inherited members.

abort() XMLHttpRequest
getResponseHeader(String name) | XMLHttpRequest
open(String method, String url, Boolean async, String user, String password) | XMLHttpRequest
response XMLHttpRequest
responseXML XMLHttpRequest
send(String data) | XMLHttpRequest
setRequestHeader(String name, String value) | XMLHttpRequest


ZipFile Class Reference

Inherits ScriptObject.

Static Public Member Functions

static | unzipTo (String src, String dest)
static | zipTo (String src, String dest)

Detailed Description

ZIP file.

Security: Requires security level 0.

Member Function Documentation

◆ unzipTo()

static unzipTo | ( | String | src,
 |  | String | dest
 | ) |  |
static

Zips the specified folder content to the specified file.

Parameters
src | The path of the source folder.
dest | The path of the ZIP file.

◆ zipTo()

static zipTo | ( | String | src,
 |  | String | dest
 | ) |  |
static

Unzips the specified file to the specified folder.

Parameters
src | The path of the ZIP file.
dest | The path of the destination folder.


Member List

ZipFile Member List

This is the complete list of members for ZipFile, including all inherited members.

unzipTo(String src, String dest) | ZipFile | static
zipTo(String src, String dest) | ZipFile | static


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • A : PostProcessor
  • ABC : PostProcessor
  • abort() : XMLHttpRequest
  • abortOnDeprecation : PostProcessor
  • abs : Vector
  • ACK : PostProcessor
  • activatePolarMode() : PostProcessor
  • add() : Matrix , Vector
  • addAxis() : MachineConfiguration
  • addBCCRecipient() : Mail
  • addBCCRecipient2() : Mail
  • addCCRecipient() : Mail
  • addCCRecipient2() : Mail
  • addCode() : ModalGroup
  • addFacet() : Mesh
  • addRecipient() : Mail
  • addRecipient2() : Mail
  • alert() : PostProcessor
  • allowedCircularPlanes : PostProcessor
  • allowHelicalMoves : PostProcessor
  • allowMachineChangeOnSection : PostProcessor
  • allowSpiralMoves : PostProcessor
  • append() : FormData , StringBuffer
  • arc : CurveEntity
  • areDifferent() : Format , FormatNumber
  • assign() : StringBuffer
  • atob() : Base64
  • Axis() : Axis
  • axisSubstitution : Section
  • axisSubstitutionRadius : Section


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • B : PostProcessor
  • BEL : PostProcessor
  • bodyLength : Tool
  • boringBarOrientation : Tool
  • BoundingBox() : BoundingBox
  • breakControl : Tool
  • BS : PostProcessor
  • btoa() : Base64


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • C : PostProcessor
  • CAN : PostProcessor
  • cancelRotation() : PostProcessor
  • cancelTransformation() : PostProcessor
  • cancelTranslation() : PostProcessor
  • canIgnoreCommand() : PostProcessor
  • canLinearize() : PostProcessor
  • Canvas() : Canvas
  • capabilities : PostProcessor
  • center : CurveEntity , PostProcessor
  • certificationLevel : PostProcessor
  • charAt() : String
  • checkGroup() : Section
  • chipBreakingDistance : MachineParameters
  • chordLength : PostProcessor
  • clamp() : Axis , MachineConfiguration , Matrix , Range
  • clamping : Tool
  • clampToResolution() : Axis , MachineConfiguration
  • clear() : Canvas , Mesh , StringBuffer
  • clockwise : CurveEntity , PostProcessor
  • close() : TextFile
  • closeRedirection() : PostProcessor
  • Color() : Color
  • COMMAND_ACTIVATE_SPEED_FEED_SYNCHRONIZATION : PostProcessor
  • COMMAND_ALARM : PostProcessor
  • COMMAND_ALERT : PostProcessor
  • COMMAND_BREAK_CONTROL : PostProcessor
  • COMMAND_CALIBRATE : PostProcessor
  • COMMAND_CHANGE_PALLET : PostProcessor
  • COMMAND_CLEAN : PostProcessor
  • COMMAND_CLOSE_DOOR : PostProcessor
  • COMMAND_COOLANT_OFF : PostProcessor
  • COMMAND_COOLANT_ON : PostProcessor
  • COMMAND_DEACTIVATE_SPEED_FEED_SYNCHRONIZATION : PostProcessor
  • COMMAND_END : PostProcessor
  • COMMAND_EXACT_STOP : PostProcessor
  • COMMAND_INVALID : PostProcessor
  • COMMAND_LOAD_TOOL : PostProcessor
  • COMMAND_LOCK_MULTI_AXIS : PostProcessor
  • COMMAND_MAIN_CHUCK_CLOSE : PostProcessor
  • COMMAND_MAIN_CHUCK_OPEN : PostProcessor
  • COMMAND_OPEN_DOOR : PostProcessor
  • COMMAND_OPTIONAL_STOP : PostProcessor
  • COMMAND_ORIENTATE_SPINDLE : PostProcessor
  • COMMAND_POWER_OFF : PostProcessor
  • COMMAND_POWER_ON : PostProcessor
  • COMMAND_PROBE_OFF : PostProcessor
  • COMMAND_PROBE_ON : PostProcessor
  • COMMAND_SECONDARY_CHUCK_CLOSE : PostProcessor
  • COMMAND_SECONDARY_CHUCK_OPEN : PostProcessor
  • COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_ACTIVATE : PostProcessor
  • COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_DEACTIVATE : PostProcessor
  • COMMAND_SPINDLE_CLOCKWISE : PostProcessor
  • COMMAND_SPINDLE_COUNTERCLOCKWISE : PostProcessor
  • COMMAND_START_CHIP_TRANSPORT : PostProcessor
  • COMMAND_START_SPINDLE : PostProcessor
  • COMMAND_STOP : PostProcessor
  • COMMAND_STOP_CHIP_TRANSPORT : PostProcessor
  • COMMAND_STOP_SPINDLE : PostProcessor
  • COMMAND_SYNC_CHANNELS : PostProcessor
  • COMMAND_TOOL_MEASURE : PostProcessor
  • COMMAND_UNLOCK_MULTI_AXIS : PostProcessor
  • COMMAND_VERIFY : PostProcessor
  • comment : Tool
  • compensationOffset : Tool
  • conditional() : PostProcessor
  • coolant : Tool
  • COOLANT_AIR : PostProcessor
  • COOLANT_AIR_THROUGH_TOOL : PostProcessor
  • COOLANT_DISABLED : PostProcessor
  • COOLANT_FLOOD : PostProcessor
  • COOLANT_FLOOD_MIST : PostProcessor
  • COOLANT_FLOOD_THROUGH_TOOL : PostProcessor
  • COOLANT_MIST : PostProcessor
  • COOLANT_SUCTION : PostProcessor
  • COOLANT_THROUGH_TOOL : PostProcessor
  • COOLANT_TOOL : PostProcessor
  • copyFile() : FileSystem
  • cornerRadius : Tool
  • CR : PostProcessor
  • createAxis() : PostProcessor
  • createFormat() : PostProcessor
  • createFromPath() : MachineConfiguration
  • createFromXML() : MachineConfiguration
  • createGroup() : ModalGroup
  • createIncrementalVariable() : PostProcessor
  • createMachineConfiguration() : PostProcessor
  • createModal() : PostProcessor
  • createModalGroup() : PostProcessor
  • createReferenceVariable() : PostProcessor
  • createToolRenderer() : PostProcessor
  • createVariable() : PostProcessor
  • cross() : Vector
  • crossSection : Tool
  • currentSection : PostProcessor
  • CurveEntity() : CurveEntity
  • cycle : PostProcessor
  • cycleExpanded : PostProcessor
  • cycleNotSupported() : PostProcessor
  • cycleType : PostProcessor
  • cyclicLimit : FormatNumber
  • cyclicSign : FormatNumber


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DC1 : PostProcessor
  • DC2 : PostProcessor
  • DC3 : PostProcessor
  • DC4 : PostProcessor
  • deactivatePolarMode() : PostProcessor
  • debug() : PostProcessor
  • debugMode : PostProcessor
  • decimalSymbol : FormatNumber
  • deprecated : PostProcessor
  • description : PostProcessor
  • diameter : Tool
  • diameterOffset : Tool
  • diff() : Matrix , Vector
  • disable() : IncrementalVariable , ModalGroup , ReferenceVariable , Variable
  • disableMachineRewinds() : MachineConfiguration
  • divide() : Vector
  • DLE : PostProcessor
  • doesEndWithCycle() : Section
  • doesEndWithCycleIgnoringPositioning() : Section
  • doesStartWithCycle() : Section
  • doesStartWithCycleIgnoringPositioning() : Section
  • doesStrictCycle() : Section
  • dot() : Vector
  • drillingSafeDistance : MachineParameters
  • dynamicWorkOffset : Section


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • edgeLength : Tool
  • EM : PostProcessor
  • enable() : ModalGroup
  • enableMachineRewinds() : MachineConfiguration
  • end : CurveEntity , PostProcessor
  • ENQ : PostProcessor
  • EOL : PostProcessor
  • EOT : PostProcessor
  • error() : PostProcessor
  • ESC : PostProcessor
  • ETB : PostProcessor
  • ETX : PostProcessor
  • EULER_XYX_R : Matrix
  • EULER_XYX_S : Matrix
  • EULER_XYZ_R : Matrix
  • EULER_XYZ_S : Matrix
  • EULER_XZX_R : Matrix
  • EULER_XZX_S : Matrix
  • EULER_XZY_R : Matrix
  • EULER_XZY_S : Matrix
  • EULER_YXY_R : Matrix
  • EULER_YXY_S : Matrix
  • EULER_YXZ_R : Matrix
  • EULER_YXZ_S : Matrix
  • EULER_YZX_R : Matrix
  • EULER_YZX_S : Matrix
  • EULER_YZY_R : Matrix
  • EULER_YZY_S : Matrix
  • EULER_ZXY_R : Matrix
  • EULER_ZXY_S : Matrix
  • EULER_ZXZ_R : Matrix
  • EULER_ZXZ_S : Matrix
  • EULER_ZYX_R : Matrix
  • EULER_ZYX_S : Matrix
  • EULER_ZYZ_R : Matrix
  • EULER_ZYZ_S : Matrix
  • EulerConvention : Matrix
  • eulerXYX : Matrix
  • eulerXYX_R : Matrix
  • eulerXYZ : Matrix
  • eulerXYZ_R : Matrix
  • eulerXZX : Matrix
  • eulerXZX_R : Matrix
  • eulerXZY : Matrix
  • eulerXZY_R : Matrix
  • eulerYXY : Matrix
  • eulerYXY_R : Matrix
  • eulerYXZ : Matrix
  • eulerYXZ_R : Matrix
  • eulerYZX : Matrix
  • eulerYZX_R : Matrix
  • eulerYZY : Matrix
  • eulerYZY_R : Matrix
  • eulerZXY : Matrix
  • eulerZXY_R : Matrix
  • eulerZXZ : Matrix
  • eulerZXZ_R : Matrix
  • eulerZYX : Matrix
  • eulerZYX_R : Matrix
  • eulerZYZ : Matrix
  • eulerZYZ_R : Matrix
  • execute() : PostProcessor
  • executeNoWait() : PostProcessor
  • expandCyclePoint() : PostProcessor
  • expandManualNC() : PostProcessor
  • expandTo() : BoundingBox , Range
  • expandToBox() : BoundingBox
  • expandToRange() : Range
  • exportAs() : ToolRenderer
  • exportNCAs() : PostProcessor
  • extension : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • feedrate : PostProcessor
  • FF : PostProcessor
  • filename : PostProcessor
  • filterText() : PostProcessor
  • findFile() : PostProcessor
  • first : VectorPair
  • flatten() : PostProcessor
  • fluteLength : Tool
  • forceDecimal : FormatNumber
  • forceSign : FormatNumber
  • Format() : Format
  • format() : Format , FormatNumber , IncrementalVariable , Modal , ModalGroup , ReferenceVariable , Variable
  • FormatNumber() : FormatNumber
  • formatWords() : PostProcessor
  • FormData() : FormData
  • forward : Matrix
  • FS : PostProcessor
  • fullCircle : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • get() : DeferredVariables , FormData
  • getABC() : MachineConfiguration
  • getABCByDirection() : MachineConfiguration
  • getABCByDirection2() : MachineConfiguration
  • getABCByDirectionBoth() : MachineConfiguration
  • getABCByPreference() : MachineConfiguration
  • getAbsolute() : Vector
  • getActiveCode() : ModalGroup
  • getActuator() : Axis
  • getAdditiveFFF() : MachineConfiguration
  • getAggregateId() : Tool
  • getAlpha() : Color
  • getAngle() : Vector
  • getArc() : CurveEntity
  • getAsAngular() : MachineConfiguration
  • getAsAngularFeedrate() : MachineConfiguration
  • getAsBinary() : ToolRenderer
  • getAsFloat() : PostProcessor
  • getAsInt() : PostProcessor
  • getAsPower() : MachineConfiguration
  • getAsSpatial() : MachineConfiguration
  • getAsSpatialFeedrate() : MachineConfiguration
  • getAsTime() : MachineConfiguration
  • getAsWeight() : MachineConfiguration
  • getAxis() : Axis
  • getAxisByCoordinate() : MachineConfiguration
  • getAxisByName() : MachineConfiguration
  • getAxisRotation() : Axis , Matrix
  • getAxisSubstitution() : Section
  • getAxisSubstitutionRadius() : Section
  • getAxisU() : MachineConfiguration
  • getAxisV() : MachineConfiguration
  • getAxisW() : MachineConfiguration
  • getAxisX() : MachineConfiguration
  • getAxisY() : MachineConfiguration
  • getAxisZ() : MachineConfiguration
  • getBlue() : Color
  • getBody() : Mail
  • getBodyLength() : Tool
  • getBoringBarOrientation() : Tool
  • getBoundingBox() : Mesh , Section
  • getBreakControl() : Tool
  • getBySpherical() : Vector
  • getCascadingPath() : PostProcessor
  • getCategories() : Record
  • getCenterPositionX() : MachineConfiguration
  • getCenterPositionY() : MachineConfiguration
  • getCenterPositionZ() : MachineConfiguration
  • getChannel() : Section
  • getCircularCenter() : PostProcessor
  • getCircularChordLength() : PostProcessor
  • getCircularMotion() : PostProcessor
  • getCircularNormal() : PostProcessor
  • getCircularPlane() : PostProcessor
  • getCircularRadius() : PostProcessor
  • getCircularStartRadius() : PostProcessor
  • getCircularSweep() : PostProcessor
  • getClosestABC() : MachineConfiguration
  • getCodePage() : PostProcessor
  • getCollectChuck() : MachineConfiguration
  • getColor() : Canvas
  • getColumn() : Matrix
  • getCombinedPath() : FileSystem
  • getCommandStringId() : PostProcessor
  • getComment() : Tool
  • getCompensationDisplacement() : Tool
  • getCompensationMode() : Tool
  • getCompensationOffset() : PostProcessor , Tool
  • getConfigurationFolder() : PostProcessor
  • getConfigurationPath() : PostProcessor
  • getContent() : Section
  • getControl() : MachineConfiguration
  • getCoolant() : Tool
  • getCoolantName() : PostProcessor
  • getCoordinate() : Axis , Vector
  • getCoordinates() : MachineConfiguration
  • getCornerRadius() : Tool
  • getCurrent() : IncrementalVariable , Modal , Variable
  • getCurrentChannel() : PostProcessor
  • getCurrentDirection() : PostProcessor
  • getCurrentGlobalPosition() : PostProcessor
  • getCurrentNCLocation() : PostProcessor
  • getCurrentPosition() : PostProcessor
  • getCurrentRecordId() : PostProcessor
  • getCurrentSectionId() : PostProcessor
  • getCurrentSpindleSpeed() : PostProcessor
  • getCurrentSyncGroup() : PostProcessor
  • getCutterAsMesh() : Tool
  • getCutterProfile() : Tool
  • getCutterProfileAsSVGPath() : Tool
  • getCuttingDistance() : Section
  • getCycleId() : Section
  • getCycleParameter() : Section
  • getCyclePoint() : PostProcessor
  • getCyclePointId() : PostProcessor
  • getCycleTime() : Section
  • getCycleType() : Record
  • getCyclicLimit() : FormatNumber
  • getCyclicSign() : FormatNumber
  • getDecimalSymbol() : FormatNumber
  • getDepth() : MachineConfiguration
  • getDescription() : MachineConfiguration , Tool
  • getDiameter() : Holder , Shaft , Tool
  • getDiameterOffset() : Tool
  • getDimensions() : MachineConfiguration
  • getDirection() : MachineConfiguration , PostProcessor
  • getDisplacement() : Axis
  • getDistance() : Vector
  • getDistance2() : Vector
  • getDogLeg() : PostProcessor
  • getDynamicWCSOrigin() : Section
  • getDynamicWCSPlane() : Section
  • getDynamicWorkOffset() : Section
  • getEffectiveAxis() : Axis
  • getElement() : Matrix
  • getEnd() : PostProcessor
  • getEntity() : Curve
  • getError() : Format , FormatNumber
  • getEuler() : Matrix
  • getEuler2() : Matrix
  • getEulerRotation() : Matrix
  • getEulerXYXRotation() : Matrix
  • getEulerXYZ() : Matrix
  • getEulerXYZRotation() : Matrix
  • getEulerXZXRotation() : Matrix
  • getEulerXZYRotation() : Matrix
  • getEulerYXYRotation() : Matrix
  • getEulerYXZRotation() : Matrix
  • getEulerYZXRotation() : Matrix
  • getEulerYZYRotation() : Matrix
  • getEulerZXYRotation() : Matrix
  • getEulerZXZ() : Matrix
  • getEulerZXZRotation() : Matrix
  • getEulerZYX() : Matrix
  • getEulerZYXRotation() : Matrix
  • getEulerZYZ() : Matrix
  • getEulerZYZRotation() : Matrix
  • getExtent() : Curve , Tool
  • getExtruderOffsetX() : MachineConfiguration
  • getExtruderOffsetY() : MachineConfiguration
  • getExtruderOffsetZ() : MachineConfiguration
  • getFacet() : Mesh
  • getFCSOrigin() : Section
  • getFCSPlane() : Section
  • getFeedMode() : Section
  • getFeedrate() : PostProcessor
  • getFeedrateRatio() : MachineConfiguration
  • getFilename() : FileSystem
  • getFileSize() : FileSystem
  • getFinalPosition() : Section
  • getFinalSpindleOn() : Section
  • getFinalSpindleSpeed() : Section
  • getFinalToolAxis() : Section
  • getFinalToolAxisABC() : Section
  • getFirstCompensationOffset() : Section
  • getFirstCycle() : Section
  • getFirstPosition() : Section
  • getFirstTool() : PostProcessor
  • getFixture() : PostProcessor
  • getFluteLength() : Tool
  • getFolderPath() : FileSystem
  • getForceDecimal() : FormatNumber
  • getForceSign() : FormatNumber
  • getForceToolChange() : Section
  • getForward() : Matrix
  • getFrameDirection() : PostProcessor
  • getFramePosition() : PostProcessor
  • getGlobalBoundingBox() : Section
  • getGlobalFinalToolAxis() : Section
  • getGlobalInitialToolAxis() : Section
  • getGlobalParameter() : PostProcessor
  • getGlobalPosition() : PostProcessor , Section
  • getGlobalRange() : Section
  • getGlobalWorkOrigin() : Section
  • getGlobalWorkPlane() : Section
  • getGlobalZRange() : Section
  • getGreen() : Color
  • getGroup() : ModalGroup
  • getHeadABC() : MachineConfiguration
  • getHeader() : PostProcessor
  • getHeaderCommit() : PostProcessor
  • getHeaderDate() : PostProcessor
  • getHeaderDate2() : PostProcessor
  • getHeaderSnippet() : PostProcessor
  • getHeaderVersion() : PostProcessor
  • getHeadOrientation() : MachineConfiguration
  • getHeight() : Canvas , MachineConfiguration
  • getHelicalDistance() : PostProcessor
  • getHelicalOffset() : PostProcessor
  • getHelicalPitch() : PostProcessor
  • getHighFeedMapping() : PostProcessor
  • getHighFeedrate() : PostProcessor
  • getHolder() : Tool
  • getHolderAsMesh() : Tool
  • getHolderComment() : Tool
  • getHolderDescription() : Tool
  • getHolderDiameter() : Tool
  • getHolderLength() : Tool
  • getHolderNumber() : Tool
  • getHolderProductId() : Tool
  • getHolderProfile() : Tool
  • getHolderProfileAsSVGPath() : Tool
  • getHolderTipDiameter() : Tool
  • getHolderType() : Tool
  • getHolderVendor() : Tool
  • getHomePosition() : Axis
  • getHomePositionX() : MachineConfiguration
  • getHomePositionY() : MachineConfiguration
  • getHomePositionZ() : MachineConfiguration
  • getId() : Record , Section
  • getIndexOfAxisById() : MachineConfiguration
  • getInitialPosition() : Section
  • getInitialSpindleOn() : Section
  • getInitialSpindleSpeed() : Section
  • getInitialToolAxis() : Section
  • getInitialToolAxisABC() : Section
  • getInsertType() : Tool
  • getInspection() : MachineConfiguration
  • getIntermediatePath() : PostProcessor
  • getInverseTime() : PostProcessor
  • getISOPlane() : PostProcessor
  • getJet() : MachineConfiguration
  • getJetDiameter() : Tool
  • getJetDistance() : Tool
  • getJetMode() : Section
  • getJobId() : Section
  • getLangId() : PostProcessor
  • getLastCycle() : Section
  • getLength() : Curve , CurveEntity , Holder , PostProcessor , Shaft , Vector
  • getLength2() : Vector
  • getLengthOffset() : Tool
  • getLine() : CurveEntity
  • getLinearize() : Curve
  • getLinearMoveLength() : MoveLength
  • getLowerToolAxisABC() : Section
  • getMachineConfiguration() : PostProcessor
  • getMachineConfigurationAsText() : PostProcessor
  • getMachineConfigurationByName() : PostProcessor
  • getMachineConfigurations() : PostProcessor
  • getMachiningDistance() : PostProcessor
  • getManualToolChange() : Tool
  • getMaterial() : Tool
  • getMaterialName() : PostProcessor
  • getMaximum() : Range , Vector
  • getMaximumBlockProcessingSpeed() : MachineConfiguration
  • getMaximumCuttingFeedrate() : MachineConfiguration
  • getMaximumDiameter() : Holder , Shaft
  • getMaximumFeed() : Axis
  • getMaximumFeedrate() : MachineConfiguration , Section
  • getMaximumSpindlePower() : MachineConfiguration
  • getMaximumSpindleSpeed() : MachineConfiguration , Section , Tool
  • getMaximumTilt() : Section
  • getMaximumToolDiameter() : MachineConfiguration
  • getMaximumToolLength() : MachineConfiguration
  • getMaximumToolWeight() : MachineConfiguration
  • getMiddle() : Range
  • getMilling() : MachineConfiguration
  • getMinimum() : Range , Vector
  • getMinimumValue() : Format , FormatNumber
  • getModel() : MachineConfiguration
  • getModelOrigin() : Section
  • getModelPlane() : Section
  • getMovement() : PostProcessor
  • getMovements() : Section
  • getMultiAxisFeedrateBpwRatio() : MachineConfiguration
  • getMultiAxisFeedrateDPMType() : MachineConfiguration
  • getMultiAxisFeedrateInverseTimeUnits() : MachineConfiguration
  • getMultiAxisFeedrateMaximum() : MachineConfiguration
  • getMultiAxisFeedrateMode() : MachineConfiguration
  • getMultiAxisFeedrateOutputTolerance() : MachineConfiguration
  • getMultiAxisMoveLength() : PostProcessor
  • getN1() : Matrix
  • getN2() : Matrix
  • getName() : Axis
  • getNegated() : Matrix , Vector
  • getNextRecord() : PostProcessor
  • getNextSection() : PostProcessor
  • getNextTool() : PostProcessor
  • getNormalized() : Vector
  • getNumber() : Tool
  • getNumberExtruders() : MachineConfiguration
  • getNumberOfAxes() : MachineConfiguration
  • getNumberOfChannels() : PostProcessor
  • getNumberOfCodes() : ModalGroup
  • getNumberOfCodesInGroup() : ModalGroup
  • getNumberOfCyclePoints() : PostProcessor , Section
  • getNumberOfCycles() : Section
  • getNumberOfCyclesWithId() : Section
  • getNumberOfDecimals() : FormatNumber
  • getNumberOfEntities() : Curve
  • getNumberOfFacets() : Mesh
  • getNumberOfFlutes() : Tool
  • getNumberOfGroups() : ModalGroup
  • getNumberOfPatternInstances() : Section
  • getNumberOfRecords() : PostProcessor , Section
  • getNumberOfSections() : Holder , PostProcessor , Shaft
  • getNumberOfSegments() : PostProcessor
  • getNumberOfSyncGroups() : PostProcessor
  • getNumberOfTools() : MachineConfiguration , ToolTable
  • getNumberOfVertices() : Mesh
  • getNumberOfWorkOffsets() : MachineConfiguration
  • getOffset() : Axis , CircularMotion , FormatNumber
  • getOperationProperties() : Section
  • getOptimizedDirection() : MachineConfiguration
  • getOptimizedHeads() : MachineConfiguration
  • getOptimizedPosition() : MachineConfiguration
  • getOptimizedTables() : MachineConfiguration
  • getOptimizedTCPMode() : Section
  • getOrientation() : MachineConfiguration
  • getOtherABCByDirection() : MachineConfiguration
  • getOutputPath() : PostProcessor
  • getOutputUnit() : PostProcessor
  • getParameter() : PostProcessor , Section
  • getParameterName() : Record
  • getParameterValue() : Record
  • getParkPositionX() : MachineConfiguration
  • getParkPositionY() : MachineConfiguration
  • getParkPositionZ() : MachineConfiguration
  • getPartCatcher() : Section
  • getPartDimensions() : MachineConfiguration
  • getPartMaximumX() : MachineConfiguration
  • getPartMaximumY() : MachineConfiguration
  • getPartMaximumZ() : MachineConfiguration
  • getPatternId() : Section
  • getPixel() : Canvas
  • getPlane() : PostProcessor
  • getPlatform() : PostProcessor
  • getPolarPosition() : PostProcessor
  • getPosition() : MachineConfiguration
  • getPositionU() : CircularMotion , PostProcessor
  • getPostProcessorFolder() : PostProcessor
  • getPostProcessorPath() : PostProcessor
  • getPower() : PostProcessor
  • getPreference() : Axis
  • getPreferredABC() : MachineConfiguration
  • getPrefix() : FormatNumber , IncrementalVariable , Modal , ReferenceVariable , Variable
  • getPreviousRecord() : PostProcessor
  • getPreviousSection() : PostProcessor
  • getProbeWorkOffset() : Section
  • getProduct() : PostProcessor
  • getProductId() : Tool
  • getProductUri() : PostProcessor
  • getProductUrl() : PostProcessor
  • getProgramNameAsInt() : PostProcessor
  • getProgramNameAsString() : PostProcessor
  • getProperty() : PostProcessor
  • getQuadrant() : PostProcessor
  • getQuality() : Section
  • getRadialMoveLength() : MoveLength
  • getRadialToolTipMoveLength() : MoveLength
  • getRadius() : CurveEntity
  • getRadiusCompensation() : PostProcessor
  • getRampingSpindleRPM() : Tool
  • getRange() : Axis
  • getRapidDistance() : Section
  • getRapidFeed() : Axis
  • getRayIntersection() : BoundingBox
  • getReconfigure() : MachineConfiguration
  • getRecord() : PostProcessor , Section
  • getRed() : Color
  • getRedirectionBuffer() : PostProcessor
  • getRedirectionBuffer2() : PostProcessor
  • getRemainingOrientation() : MachineConfiguration
  • getReplyTo() : Mail
  • getReset() : Axis
  • getResolution() : Axis
  • getResolutionError() : Axis
  • getResponseHeader() : XMLHttpRequest
  • getResultingValue() : Format , FormatNumber
  • getRetractOnIndexing() : MachineConfiguration
  • getRetractPlane() : MachineConfiguration
  • getRewindStockExpansion() : MachineConfiguration
  • getRight() : Matrix
  • getRotation() : PostProcessor
  • getRotationAxis() : MachineConfiguration
  • getRow() : Matrix
  • getSafePlungeFeedrate() : MachineConfiguration
  • getSafeRetractDistance() : MachineConfiguration
  • getSafeRetractFeedrate() : MachineConfiguration
  • getScale() : FormatNumber
  • getSecondaryCompensationOffset() : Tool
  • getSecondaryLengthOffset() : Tool
  • getSection() : PostProcessor
  • getSectionFrameDirection() : PostProcessor
  • getSectionFramePosition() : PostProcessor
  • getSectionPosition() : PostProcessor , Section
  • getSectionsInChannel() : PostProcessor
  • getSecurityLevel() : PostProcessor
  • getSenderEmail() : Mail
  • getSenderName() : Mail
  • getShaft() : Tool
  • getShaftDiameter() : Tool
  • getShortestAngularRotation() : MachineConfiguration
  • getShoulderLength() : Tool
  • getSingularityAdjust() : MachineConfiguration
  • getSingularityAngle() : MachineConfiguration
  • getSingularityCone() : MachineConfiguration
  • getSingularityLinearizationTolerance() : MachineConfiguration
  • getSingularityMethod() : MachineConfiguration
  • getSingularityTolerance() : MachineConfiguration
  • getSpan() : Range
  • getSpindle() : Section
  • getSpindleAxis() : MachineConfiguration
  • getSpindleAxisABC() : MachineConfiguration
  • getSpindleDescription() : MachineConfiguration
  • getSpindleMode() : Tool
  • getSpindleRPM() : Tool
  • getSpindleSpeed() : PostProcessor
  • getStatusDescription() : MachineConfiguration
  • getStrategy() : Section
  • getSubject() : Mail
  • getSuffix() : FormatNumber , Modal
  • getSurfaceSpeed() : Tool
  • getSweep() : CurveEntity
  • getSystemUnit() : PostProcessor
  • getTableABC() : MachineConfiguration
  • getTableOrientation() : MachineConfiguration
  • getTailstock() : Section
  • getTaperAngle() : Tool
  • getTappingFeedrate() : Tool
  • getTemporaryFile() : FileSystem
  • getTemporaryFolder() : FileSystem
  • getThreadPitch() : Tool
  • getTiltAndTilt() : Matrix
  • getTipDiameter() : Tool
  • getTool() : Section , ToolTable
  • getToolAxis() : Section
  • getToolChanger() : MachineConfiguration
  • getToolChangeTime() : MachineConfiguration
  • getToolId() : Tool
  • getToolLength() : MachineConfiguration
  • getToolOrientation() : Section
  • getToolPreload() : MachineConfiguration
  • getToolTable() : PostProcessor
  • getToolTypeName() : PostProcessor
  • getTotalLength() : Holder , Shaft
  • getTranslation() : PostProcessor
  • getTransposed() : Matrix
  • getTrimLeadZero() : FormatNumber
  • getTrimZeroDecimals() : FormatNumber
  • getTurnAndTilt() : Matrix
  • getTurning() : MachineConfiguration
  • getTurret() : Tool
  • getType() : Record , Section , Tool
  • getU() : Range
  • getUnit() : Section , Tool
  • getUp() : Matrix
  • getUpperToolAxisABC() : Section
  • getValidityStatus() : MachineConfiguration
  • getVendor() : MachineConfiguration , PostProcessor , Tool
  • getVendorUrl() : MachineConfiguration , PostProcessor
  • getVersion() : PostProcessor
  • getVertex() : Mesh
  • getVirtualTooltip() : MachineConfiguration
  • getWCS() : Section
  • getWCSIndex() : Section
  • getWCSOrigin() : Section
  • getWCSPlane() : Section
  • getWCSPosition() : PostProcessor , Section
  • getWeight() : MachineConfiguration
  • getWeightCapacity() : MachineConfiguration
  • getWidth() : Canvas , FormatNumber , MachineConfiguration
  • getWire() : MachineConfiguration
  • getWordSeparator() : PostProcessor
  • getWorkOffset() : Section
  • getWorkOrigin() : Section
  • getWorkpiece() : PostProcessor
  • getWorkPlane() : Section
  • getX() : Vector
  • getXML() : MachineConfiguration
  • getXRotation() : Matrix
  • getXYAngle() : Vector
  • getXYZRotation() : Matrix
  • getY() : Vector
  • getYRotation() : Matrix
  • getZ() : Vector
  • getZAngle() : Vector
  • getZeroPad() : FormatNumber
  • getZRange() : Section
  • getZRotation() : Matrix
  • grooveWidth : Tool
  • grow() : Range
  • GS : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • hand : Tool
  • has() : FormData
  • HAS_CIRCULAR : PostProcessor
  • HAS_COMMENT : PostProcessor
  • HAS_CYCLE : PostProcessor
  • HAS_DWELL : PostProcessor
  • HAS_LINEAR : PostProcessor
  • HAS_PARAMETER : PostProcessor
  • HAS_RAPID : PostProcessor
  • HAS_WELL_KNOWN_COMMAND : PostProcessor
  • hasActiveCode() : ModalGroup
  • hasAnyCycle() : Section
  • hasArcs() : Curve
  • hasCenterPosition() : MachineConfiguration
  • hasCycle() : Section
  • hasCycleParameter() : Section
  • hasDynamicWorkOffset() : Section
  • hasGlobalParameter() : PostProcessor
  • hasHomePositionX() : MachineConfiguration
  • hasHomePositionY() : MachineConfiguration
  • hasHomePositionZ() : MachineConfiguration
  • hasNextRecord() : PostProcessor
  • hasNextSection() : PostProcessor
  • hasParameter() : PostProcessor , Section
  • hasParkPosition() : MachineConfiguration
  • hasPreviousRecord() : PostProcessor
  • hasSections() : Holder , Shaft
  • hasSymbol() : PostProcessor
  • hasWellDefinedPosition() : Section
  • helical : PostProcessor
  • helicalDistance : PostProcessor
  • helicalOffset : PostProcessor
  • HIGH_FEED_MAP_ANY : PostProcessor
  • HIGH_FEED_MAP_MULTI : PostProcessor
  • HIGH_FEED_MAP_XY_Z : PostProcessor
  • HIGH_FEED_NO_MAPPING : PostProcessor
  • highFeedMapping : PostProcessor
  • highFeedrate : PostProcessor
  • holder : Tool
  • holderDiameter : Tool
  • holderLength : Tool
  • holderNumber : Tool
  • holderTipDiameter : Tool


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • IN : PostProcessor
  • include() : PostProcessor
  • IncrementalVariable() : IncrementalVariable
  • indexOf() : Array
  • initialCyclePosition : PostProcessor
  • inSameGroup() : ModalGroup
  • inscribedCircleDiameter : Tool
  • interval() : PostProcessor
  • invokeOnCircular() : PostProcessor
  • invokeOnLinear() : PostProcessor
  • invokeOnLinear5D() : PostProcessor
  • invokeOnRapid() : PostProcessor
  • invokeOnRapid5D() : PostProcessor
  • is3D() : PostProcessor
  • is3DConfiguration() : MachineConfiguration
  • isABCSupported() : MachineConfiguration
  • isActiveCode() : ModalGroup
  • isAggregate() : Axis
  • isAxialCenterDrilling() : PostProcessor
  • isBigArc() : CurveEntity
  • isClockwise() : PostProcessor , Tool
  • isClockwiseSpindleDirection() : PostProcessor
  • isClosed() : Curve
  • isCodeDefined() : ModalGroup
  • isCoolantActive() : PostProcessor
  • isCoolantSupported() : MachineConfiguration
  • isCuttingMotionAwayFromRotary() : Section
  • isCycle() : Record
  • isCyclic() : Axis
  • isDepositionOperation() : PostProcessor
  • isDirectionSupported() : MachineConfiguration
  • isDrill() : Tool
  • isDrillingCycle() : PostProcessor
  • isEmpty() : StringBuffer
  • isEnabled() : Axis , ModalGroup
  • isExpanding() : PostProcessor
  • isFile() : FileSystem
  • isFirstCyclePoint() : PostProcessor
  • isFirstSection() : PostProcessor
  • isFolder() : FileSystem
  • isFullCircle() : PostProcessor
  • isGroup() : ModalGroup
  • isHead() : Axis
  • isHeadConfiguration() : MachineConfiguration
  • isHelical() : PostProcessor
  • isIdentity() : Matrix
  • isInspectionOperation() : PostProcessor
  • isInteractionAllowed() : PostProcessor
  • isJet() : PostProcessor
  • isJetTool() : Tool
  • isLastCyclePoint() : PostProcessor
  • isLastSection() : PostProcessor
  • isLinear() : Axis
  • isLiveTool() : Tool
  • isMachineAxisRotation() : MachineConfiguration
  • isMachineCoordinate() : MachineConfiguration
  • isMilling() : PostProcessor
  • isMillingCycle() : PostProcessor
  • isMotion() : Record
  • isMultiAxis() : PostProcessor , Section
  • isMultiAxisConfiguration() : MachineConfiguration
  • isMultiChannelProgram() : PostProcessor
  • isNewWorkOffset() : PostProcessor
  • isNewWorkPlane() : PostProcessor
  • isNonRange() : Range
  • isNonZero() : Vector
  • isOpen() : TextFile
  • isOptimizedForMachine() : Section
  • isOptional() : Section
  • isParameter() : Record
  • isPatterned() : Section
  • isPolarModeActive() : PostProcessor
  • isProbeOperation() : PostProcessor
  • isProbingCycle() : PostProcessor
  • isReceived() : MachineConfiguration
  • isRedirecting() : PostProcessor
  • isRotational() : Axis
  • isSafeText() : PostProcessor
  • isSameDirection() : PostProcessor
  • isSectionSpecialCycle() : PostProcessor
  • isSignificant() : Format , FormatNumber
  • isSpeedFeedSynchronizationActive() : PostProcessor
  • isSpindleActive() : PostProcessor
  • isSpindleSpeedDifferent() : PostProcessor
  • isSpiral() : PostProcessor
  • isSubSpindleCycle() : PostProcessor
  • isSupported() : Axis , MachineConfiguration
  • isSupportedPosition() : MachineConfiguration
  • isSupportedText() : PostProcessor
  • isTable() : Axis
  • isTableConfiguration() : MachineConfiguration
  • isTappingCycle() : PostProcessor
  • isTCPEnabled() : Axis
  • isTextSupported() : PostProcessor
  • isToolChangeNeeded() : PostProcessor
  • isTopWorkPlane() : Section
  • isTurning() : PostProcessor
  • isTurningTool() : Tool
  • isValid() : Record
  • isWellKnownCommand() : PostProcessor
  • isWellKnownCycle() : PostProcessor
  • isWithin() : Range
  • isWorkpieceDefined() : PostProcessor
  • isXOriented() : Section
  • isXYZSupported() : MachineConfiguration
  • isYOriented() : Section
  • isZero() : Matrix , Vector
  • isZOriented() : Section


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • lastIndexOf() : Array
  • legal : PostProcessor
  • length : Holder , PostProcessor , Shaft , Vector
  • length2 : Vector
  • lengthOffset : Tool
  • lerp() : Vector
  • LF : PostProcessor
  • linear : MoveLength
  • linearize() : PostProcessor
  • lineNumber : PostProcessor
  • liveTool : Tool
  • loadBinary() : BinaryFile
  • loadImage() : Canvas
  • loadLocale() : PostProcessor
  • loadMachineConfiguration() : PostProcessor
  • loadMesh() : Mesh
  • loadText() : PostProcessor
  • localize() : PostProcessor
  • localize2() : PostProcessor
  • log() : PostProcessor
  • lookup() : Table
  • lower : BoundingBox


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MachineConfiguration() : MachineConfiguration
  • machineConfiguration : PostProcessor
  • machineParameters : PostProcessor
  • Mail() : Mail
  • makeActiveCode() : ModalGroup
  • makeFolder() : FileSystem
  • manualToolChange : Tool
  • mapToWCS : PostProcessor
  • mapWorkOrigin : PostProcessor
  • material : Tool
  • MATERIAL_CARBIDE : PostProcessor
  • MATERIAL_CERAMICS : PostProcessor
  • MATERIAL_HSS : PostProcessor
  • MATERIAL_TI_COATED : PostProcessor
  • MATERIAL_UNSPECIFIED : PostProcessor
  • Matrix() : Matrix
  • maximum : Range
  • maximumCircularRadius : PostProcessor
  • maximumCircularSweep : PostProcessor
  • maximumDiameter : Holder , Shaft
  • maximumSpindleSpeed : Tool
  • Mesh() : Mesh
  • middle : Range
  • minimum : Range
  • minimumChordLength : PostProcessor
  • minimumCircularRadius : PostProcessor
  • minimumCircularSweep : PostProcessor
  • minimumRevision : PostProcessor
  • MM : PostProcessor
  • Modal() : Modal
  • ModalGroup() : ModalGroup
  • moveFile() : FileSystem
  • movement : PostProcessor
  • MOVEMENT_CUTTING : PostProcessor
  • MOVEMENT_EXTENDED : PostProcessor
  • MOVEMENT_FINISH_CUTTING : PostProcessor
  • MOVEMENT_HIGH_FEED : PostProcessor
  • MOVEMENT_LEAD_IN : PostProcessor
  • MOVEMENT_LEAD_OUT : PostProcessor
  • MOVEMENT_LINK_DIRECT : PostProcessor
  • MOVEMENT_LINK_TRANSITION : PostProcessor
  • MOVEMENT_PLUNGE : PostProcessor
  • MOVEMENT_PREDRILL : PostProcessor
  • MOVEMENT_RAMP : PostProcessor
  • MOVEMENT_RAMP_HELIX : PostProcessor
  • MOVEMENT_RAMP_PROFILE : PostProcessor
  • MOVEMENT_RAMP_ZIG_ZAG : PostProcessor
  • MOVEMENT_RAPID : PostProcessor
  • MOVEMENT_REDUCED : PostProcessor
  • multiply() : Matrix , Vector


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • n1 : Matrix
  • n2 : Matrix
  • NAK : PostProcessor
  • negate() : Matrix , Vector
  • negated : Matrix , Vector
  • normal : PostProcessor
  • normalize() : Matrix , Vector
  • normalized : Vector
  • noseRadius : Tool
  • NUL : PostProcessor
  • number : Tool
  • numberOfDecimals : FormatNumber
  • numberOfFlutes : Tool


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • offset : FormatNumber
  • onAcceleration() : PostProcessor
  • onBedTemp() : PostProcessor
  • onCircular() : PostProcessor
  • onCircularExtrude() : PostProcessor
  • onClose() : PostProcessor
  • onCommand() : PostProcessor
  • onComment() : PostProcessor
  • onCycle() : PostProcessor
  • onCycleEnd() : PostProcessor
  • onCyclePath() : PostProcessor
  • onCyclePathEnd() : PostProcessor
  • onCyclePoint() : PostProcessor
  • onDwell() : PostProcessor
  • onExpandedLinear() : PostProcessor
  • onExpandedRapid() : PostProcessor
  • onExpandedSpindleSpeed() : PostProcessor
  • onExtruderChange() : PostProcessor
  • onExtruderTemp() : PostProcessor
  • onExtrusionReset() : PostProcessor
  • onFanSpeed() : PostProcessor
  • onImpliedCommand() : PostProcessor
  • onJerk() : PostProcessor
  • onLayer() : PostProcessor
  • onLinear() : PostProcessor
  • onLinear5D() : PostProcessor
  • onLinearExtrude() : PostProcessor
  • onMachine() : PostProcessor
  • onMaxAcceleration() : PostProcessor
  • onMovement() : PostProcessor
  • onMoveToSafeRetractPosition() : PostProcessor
  • onOpen() : PostProcessor
  • onOrientateSpindle() : PostProcessor
  • onParameter() : PostProcessor
  • onPassThrough() : PostProcessor
  • onPower() : PostProcessor
  • onRadiusCompensation() : PostProcessor
  • onRapid() : PostProcessor
  • onRapid5D() : PostProcessor
  • onReturnFromSafeRetractPosition() : PostProcessor
  • onRewindMachine() : PostProcessor
  • onRewindMachineEntry() : PostProcessor
  • onRotateAxes() : PostProcessor
  • onSectionEnd() : PostProcessor
  • onSpindleSpeed() : PostProcessor
  • onToolCompensation() : PostProcessor
  • onUnsupportedCommand() : PostProcessor
  • onUnsupportedCoolant() : PostProcessor
  • open() : XMLHttpRequest
  • openUrl() : PostProcessor
  • optimize3DPositionsByMachine() : Section
  • optimizeMachineAngles() : PostProcessor
  • optimizeMachineAngles2() : PostProcessor
  • optimizeMachineAnglesByMachine() : PostProcessor , Section
  • outputUnit : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • parseSpatial() : PostProcessor
  • partCatcher : Section
  • PATH_SEPARATOR : PostProcessor
  • performRewinds() : MachineConfiguration
  • pitch : Tool
  • plane : PostProcessor
  • PLANE_XY : PostProcessor
  • PLANE_XZ : PostProcessor
  • PLANE_YZ : PostProcessor
  • PLANE_ZX : PostProcessor
  • PostProcessor() : PostProcessor
  • prefix : FormatNumber
  • preserveRotaryAtZero() : MachineConfiguration
  • preventPost : PostProcessor
  • printDocument() : PostProcessor
  • printDocumentTo() : PostProcessor
  • probeWorkOffset : Section
  • product() : Vector
  • productId : Tool
  • programName : PostProcessor
  • programNameIsInteger : PostProcessor
  • promptKey() : PostProcessor
  • promptKey2() : PostProcessor
  • promptKey3() : PostProcessor
  • promptText() : PostProcessor
  • properties : PostProcessor , Section


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • quality : Section


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • radial : MoveLength
  • radialToolTip : MoveLength
  • radius : PostProcessor
  • RADIUS_COMPENSATION_LEFT : PostProcessor
  • RADIUS_COMPENSATION_OFF : PostProcessor
  • RADIUS_COMPENSATION_RIGHT : PostProcessor
  • radiusCompensation : PostProcessor
  • rampingSpindleRPM : Tool
  • range() : PostProcessor
  • Range() : Range
  • readln() : TextFile
  • Record() : Record
  • RECORD_CIRCULAR : PostProcessor
  • RECORD_CIRCULAR_EXTRUDE : PostProcessor
  • RECORD_COMMENT : PostProcessor
  • RECORD_CYCLE : PostProcessor
  • RECORD_CYCLE_OFF : PostProcessor
  • RECORD_DWELL : PostProcessor
  • RECORD_INVALID : PostProcessor
  • RECORD_LINEAR : PostProcessor
  • RECORD_LINEAR_5D : PostProcessor
  • RECORD_LINEAR_EXTRUDE : PostProcessor
  • RECORD_LINEAR_ZXN : PostProcessor
  • RECORD_PARAMETER : PostProcessor
  • RECORD_WELL_KNOWN_COMMAND : PostProcessor
  • RECORD_WIDE_COMMENT : PostProcessor
  • redirectToBuffer() : PostProcessor
  • redirectToFile() : PostProcessor
  • reduce() : Axis , Range
  • ReferenceVariable() : ReferenceVariable
  • registerPostProcessing() : PostProcessor
  • registerTerminationHandler() : PostProcessor
  • reliefAngle : Tool
  • remap() : FormatNumber
  • remapABC() : MachineConfiguration
  • remapToABC() : MachineConfiguration
  • remapToRange() : Axis
  • remapToRange2() : Axis
  • remove() : FileSystem
  • removeCode() : ModalGroup
  • removeFolder() : FileSystem
  • removeFolderRecursive() : FileSystem
  • replaceExtension() : FileSystem
  • repositionToCycleClearance() : PostProcessor
  • reserve() : Mesh
  • reset() : IncrementalVariable , Modal , ModalGroup , Table , Variable
  • resetGroup() : ModalGroup
  • response : XMLHttpRequest
  • responseXML : XMLHttpRequest
  • reverse() : CurveEntity
  • revision : PostProcessor
  • right : Matrix
  • rotateX() : Matrix
  • rotateY() : Matrix
  • rotateZ() : Matrix
  • RS : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • saveBinary() : BinaryFile
  • saveImage() : Canvas
  • saveMesh() : Mesh
  • scale : FormatNumber , Mesh
  • second : VectorPair
  • send() : SMTP , XMLHttpRequest
  • separator : DeferredVariables
  • set() : DeferredVariables
  • setActuator() : Axis
  • setAdditiveFFF() : MachineConfiguration
  • setAutoReset() : ModalGroup
  • setBackgroundColor() : ToolRenderer
  • setBody() : Mail
  • setCascadingPath() : PostProcessor
  • setCenterPositionX() : MachineConfiguration
  • setCenterPositionY() : MachineConfiguration
  • setCenterPositionZ() : MachineConfiguration
  • setCodePage() : PostProcessor
  • setCollectChuck() : MachineConfiguration
  • setColor() : Canvas
  • setColumn() : Matrix
  • setControl() : MachineConfiguration
  • setCoolantSupported() : MachineConfiguration
  • setCoordinate() : Vector
  • setCurrentABC() : PostProcessor
  • setCurrentDirection() : PostProcessor
  • setCurrentPosition() : PostProcessor
  • setCurrentPositionAndDirection() : PostProcessor
  • setCurrentPositionX() : PostProcessor
  • setCurrentPositionY() : PostProcessor
  • setCurrentPositionZ() : PostProcessor
  • setCurrentSpindleSpeed() : PostProcessor
  • setCyclicMapping() : FormatNumber
  • setDecimalSymbol() : FormatNumber
  • setDepth() : MachineConfiguration
  • setDescription() : MachineConfiguration
  • setDimensions() : MachineConfiguration
  • setDogLeg() : PostProcessor
  • setElement() : Matrix
  • setEOL() : PostProcessor
  • setExitCode() : PostProcessor
  • setExtruderOffsetX() : MachineConfiguration
  • setExtruderOffsetY() : MachineConfiguration
  • setExtruderOffsetZ() : MachineConfiguration
  • setFeedrateRatio() : MachineConfiguration
  • setFluteColor() : ToolRenderer
  • setForce() : ModalGroup
  • setForceDecimal() : FormatNumber
  • setForceSign() : FormatNumber
  • setFormatNumber() : ModalGroup
  • setForward() : Matrix
  • setHeight() : MachineConfiguration
  • setHighFeedMapping() : PostProcessor
  • setHighFeedrate() : PostProcessor
  • setHolderColor() : ToolRenderer
  • setHomePositionX() : MachineConfiguration
  • setHomePositionY() : MachineConfiguration
  • setHomePositionZ() : MachineConfiguration
  • setInspection() : MachineConfiguration
  • setIsReceived() : MachineConfiguration
  • setJet() : MachineConfiguration
  • setLogUndefined() : ModalGroup
  • setMachineConfiguration() : PostProcessor
  • setMaximumBlockProcessingSpeed() : MachineConfiguration
  • setMaximumCuttingFeedrate() : MachineConfiguration
  • setMaximumFeed() : Axis
  • setMaximumFeedrate() : MachineConfiguration
  • setMaximumSpindlePower() : MachineConfiguration
  • setMaximumSpindleSpeed() : MachineConfiguration
  • setMaximumToolDiameter() : MachineConfiguration
  • setMaximumToolLength() : MachineConfiguration
  • setMaximumToolWeight() : MachineConfiguration
  • setMilling() : MachineConfiguration
  • setModel() : MachineConfiguration
  • setMultiAxisFeedrate() : MachineConfiguration
  • setName() : Axis
  • setNumberExtruders() : MachineConfiguration
  • setNumberOfDecimals() : FormatNumber
  • setNumberOfTools() : MachineConfiguration
  • setNumberOfWorkOffsets() : MachineConfiguration
  • setOffset() : FormatNumber
  • setOutputUnit() : PostProcessor
  • setParkPositionX() : MachineConfiguration
  • setParkPositionY() : MachineConfiguration
  • setParkPositionZ() : MachineConfiguration
  • setPartDimensions() : MachineConfiguration
  • setPartMaximumX() : MachineConfiguration
  • setPartMaximumY() : MachineConfiguration
  • setPartMaximumZ() : MachineConfiguration
  • setPixel() : Canvas
  • setPreference() : Axis
  • setPrefix() : FormatNumber , IncrementalVariable , Modal , ModalGroup , ReferenceVariable , Variable
  • setProperty() : PostProcessor
  • setRapidFeed() : Axis
  • setReconfigure() : MachineConfiguration
  • setReplyTo() : Mail
  • setRequestHeader() : XMLHttpRequest
  • setReset() : Axis
  • setResolution() : Axis
  • setRetractOnIndexing() : MachineConfiguration
  • setRetractPlane() : MachineConfiguration
  • setRewindStockExpansion() : MachineConfiguration
  • setRight() : Matrix
  • setRotation() : PostProcessor
  • setRow() : Matrix
  • setSafePlungeFeedrate() : MachineConfiguration
  • setSafeRetractDistance() : MachineConfiguration
  • setSafeRetractFeedrate() : MachineConfiguration
  • setScale() : FormatNumber
  • setSectionSpecialCycle() : PostProcessor
  • setSegment() : ToolRenderer
  • setSenderEmail() : Mail
  • setSenderName() : Mail
  • setShaftColor() : ToolRenderer
  • setShortestAngularRotation() : MachineConfiguration
  • setShoulderColor() : ToolRenderer
  • setSingularity() : MachineConfiguration
  • setSpindleAxis() : MachineConfiguration
  • setSpindleDescription() : MachineConfiguration
  • setStrict() : ModalGroup
  • setSubject() : Mail
  • setSuffix() : FormatNumber , Modal , ModalGroup
  • setToolChanger() : MachineConfiguration
  • setToolChangeTime() : MachineConfiguration
  • setToolLength() : MachineConfiguration
  • setToolPreload() : MachineConfiguration
  • setTranslation() : PostProcessor
  • setTrimLeadZero() : FormatNumber
  • setTrimZeroDecimals() : FormatNumber
  • setTurning() : MachineConfiguration
  • setUp() : Matrix
  • setValue() : StringSubstitution
  • setVendor() : MachineConfiguration
  • setVendorUrl() : MachineConfiguration
  • setVirtualTooltip() : MachineConfiguration
  • setWeight() : MachineConfiguration
  • setWeightCapacity() : MachineConfiguration
  • setWidth() : FormatNumber , MachineConfiguration
  • setWire() : MachineConfiguration
  • setWordSeparator() : PostProcessor
  • setWriteInvocations() : PostProcessor
  • setWriteStack() : PostProcessor
  • setX() : Vector
  • setY() : Vector
  • setZ() : Vector
  • setZeroPad() : FormatNumber
  • shaft : Tool
  • shaftDiameter : Tool
  • shoulderLength : Tool
  • SI : PostProcessor
  • SINGULARITY_LINEARIZE_LINEAR : PostProcessor
  • SINGULARITY_LINEARIZE_OFF : PostProcessor
  • SINGULARITY_LINEARIZE_ROTARY : PostProcessor
  • skipRemainingSection() : PostProcessor
  • SMTP() : SMTP
  • SO : PostProcessor
  • SOH : PostProcessor
  • SP : PostProcessor
  • span : Range
  • spatial() : PostProcessor
  • spindle : Section
  • spindleAxis : PostProcessor
  • spindleMode : Tool
  • spindleOrientation : MachineParameters
  • spindleRPM : Tool
  • spindleSpeed : PostProcessor
  • spindleSpeedDwell : MachineParameters
  • split() : String
  • start : CurveEntity
  • status : XMLHttpRequest
  • statusText : XMLHttpRequest
  • strategy : Section
  • StringBuffer() : StringBuffer
  • StringSubstitution() : StringSubstitution
  • STX : PostProcessor
  • SUB : PostProcessor
  • subst() : PostProcessor
  • substitute() : StringSubstitution , Template
  • subtract() : Matrix , Vector
  • suffix : FormatNumber
  • sum() : Matrix , Vector
  • surfaceSpeed : Tool
  • sweep : PostProcessor
  • SYN : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TAB : PostProcessor
  • Table() : Table
  • tailstock : Section
  • taperAngle : Tool
  • Template() : Template
  • TextFile() : TextFile
  • thickness : Tool
  • threadPitch : Tool
  • toDeg() : PostProcessor , Vector
  • tolerance : PostProcessor , Tool
  • toLowerCase() : String
  • tool : PostProcessor
  • Tool() : Tool
  • TOOL_AXIS_X : PostProcessor
  • TOOL_AXIS_Y : PostProcessor
  • TOOL_AXIS_Z : PostProcessor
  • TOOL_BORING_BAR : PostProcessor
  • TOOL_COMPENSATION_INSERT_CENTER : PostProcessor
  • TOOL_COMPENSATION_TIP : PostProcessor
  • TOOL_COMPENSATION_TIP_CENTER : PostProcessor
  • TOOL_COMPENSATION_TIP_TANGENT : PostProcessor
  • TOOL_COUNTER_BORE : PostProcessor
  • TOOL_COUNTER_SINK : PostProcessor
  • TOOL_DRILL : PostProcessor
  • TOOL_DRILL_BLOCK : PostProcessor
  • TOOL_DRILL_CENTER : PostProcessor
  • TOOL_DRILL_SPOT : PostProcessor
  • TOOL_GRINDER : PostProcessor
  • TOOL_HOLDER_ONLY : PostProcessor
  • TOOL_LASER_CUTTER : PostProcessor
  • TOOL_MARKER : PostProcessor
  • TOOL_MILLING_CHAMFER : PostProcessor
  • TOOL_MILLING_DOVETAIL : PostProcessor
  • TOOL_MILLING_END_BALL : PostProcessor
  • TOOL_MILLING_END_BULLNOSE : PostProcessor
  • TOOL_MILLING_END_FLAT : PostProcessor
  • TOOL_MILLING_FACE : PostProcessor
  • TOOL_MILLING_FORM : PostProcessor
  • TOOL_MILLING_LOLLIPOP : PostProcessor
  • TOOL_MILLING_RADIUS : PostProcessor
  • TOOL_MILLING_SLOT : PostProcessor
  • TOOL_MILLING_TAPERED : PostProcessor
  • TOOL_MILLING_THREAD : PostProcessor
  • TOOL_PLASMA_CUTTER : PostProcessor
  • TOOL_PROBE : PostProcessor
  • TOOL_REAMER : PostProcessor
  • TOOL_TAP_LEFT_HAND : PostProcessor
  • TOOL_TAP_RIGHT_HAND : PostProcessor
  • TOOL_TURNING_BORING : PostProcessor
  • TOOL_TURNING_CUSTOM : PostProcessor
  • TOOL_TURNING_GENERAL : PostProcessor
  • TOOL_TURNING_GROOVING : PostProcessor
  • TOOL_TURNING_THREADING : PostProcessor
  • TOOL_UNSPECIFIED : PostProcessor
  • TOOL_WATER_JET : PostProcessor
  • TOOL_WELDER : PostProcessor
  • TOOL_WIRE : PostProcessor
  • ToolRenderer() : ToolRenderer
  • toolZRange() : PostProcessor
  • toRad() : PostProcessor , Vector
  • toString() : Color , Matrix , Range , StringBuffer , Vector
  • toUpperCase() : String
  • transform() : Mesh
  • translate() : CurveEntity , Mesh , Range
  • translateText() : PostProcessor
  • transpose() : Matrix
  • transposed : Matrix
  • trimLeadZero : FormatNumber
  • trimZeroDecimals : FormatNumber
  • turret : Tool
  • type : Section , Tool


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • unit : PostProcessor , Section , Tool
  • unzipTo() : ZipFile
  • up : Matrix
  • upper : BoundingBox
  • US : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • validate() : PostProcessor
  • validateProperties() : PostProcessor
  • validatePropertyDefinitions() : PostProcessor
  • Variable() : Variable
  • Vector() : Vector
  • vendor : PostProcessor , Tool
  • vendorUrl : PostProcessor
  • version : PostProcessor
  • VT : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • warning() : PostProcessor
  • warningOnce() : PostProcessor
  • wcs : Section
  • wcsIndex : Section
  • wcsOrigin : Section
  • wcsPlane : Section
  • width : FormatNumber
  • workOffset : Section
  • workOrigin : Section
  • workPlane : Section
  • write() : PostProcessor , TextFile
  • writeln() : PostProcessor , TextFile
  • writeSectionNotes() : PostProcessor
  • writeSetupNotes() : PostProcessor
  • writeToolTable() : PostProcessor
  • writeWords() : PostProcessor
  • writeWords2() : PostProcessor


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • X : PostProcessor
  • x : Vector
  • XMLHttpRequest() : XMLHttpRequest


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • Y : PostProcessor
  • y : Vector


Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • Z : PostProcessor
  • z : Vector
  • zeroPad : FormatNumber
  • zipTo() : ZipFile


Class Members - Functions

- a -

  • abort() : XMLHttpRequest
  • activatePolarMode() : PostProcessor
  • add() : Matrix , Vector
  • addAxis() : MachineConfiguration
  • addBCCRecipient() : Mail
  • addBCCRecipient2() : Mail
  • addCCRecipient() : Mail
  • addCCRecipient2() : Mail
  • addCode() : ModalGroup
  • addFacet() : Mesh
  • addRecipient() : Mail
  • addRecipient2() : Mail
  • alert() : PostProcessor
  • append() : FormData , StringBuffer
  • areDifferent() : Format , FormatNumber
  • assign() : StringBuffer
  • atob() : Base64
  • Axis() : Axis


Class Members - Functions

- b -

  • BoundingBox() : BoundingBox
  • btoa() : Base64


Class Members - Functions

- c -

  • cancelRotation() : PostProcessor
  • cancelTransformation() : PostProcessor
  • cancelTranslation() : PostProcessor
  • canIgnoreCommand() : PostProcessor
  • canLinearize() : PostProcessor
  • Canvas() : Canvas
  • charAt() : String
  • checkGroup() : Section
  • clamp() : Axis , MachineConfiguration , Matrix , Range
  • clampToResolution() : Axis , MachineConfiguration
  • clear() : Canvas , Mesh , StringBuffer
  • close() : TextFile
  • closeRedirection() : PostProcessor
  • Color() : Color
  • conditional() : PostProcessor
  • copyFile() : FileSystem
  • createAxis() : PostProcessor
  • createFormat() : PostProcessor
  • createFromPath() : MachineConfiguration
  • createFromXML() : MachineConfiguration
  • createGroup() : ModalGroup
  • createIncrementalVariable() : PostProcessor
  • createMachineConfiguration() : PostProcessor
  • createModal() : PostProcessor
  • createModalGroup() : PostProcessor
  • createReferenceVariable() : PostProcessor
  • createToolRenderer() : PostProcessor
  • createVariable() : PostProcessor
  • cross() : Vector
  • CurveEntity() : CurveEntity
  • cycleNotSupported() : PostProcessor


Class Members - Functions

- d -

  • deactivatePolarMode() : PostProcessor
  • debug() : PostProcessor
  • diff() : Matrix , Vector
  • disable() : IncrementalVariable , ModalGroup , ReferenceVariable , Variable
  • disableMachineRewinds() : MachineConfiguration
  • divide() : Vector
  • doesEndWithCycle() : Section
  • doesEndWithCycleIgnoringPositioning() : Section
  • doesStartWithCycle() : Section
  • doesStartWithCycleIgnoringPositioning() : Section
  • doesStrictCycle() : Section
  • dot() : Vector


Class Members - Functions

- e -

  • enable() : ModalGroup
  • enableMachineRewinds() : MachineConfiguration
  • error() : PostProcessor
  • execute() : PostProcessor
  • executeNoWait() : PostProcessor
  • expandCyclePoint() : PostProcessor
  • expandManualNC() : PostProcessor
  • expandTo() : BoundingBox , Range
  • expandToBox() : BoundingBox
  • expandToRange() : Range
  • exportAs() : ToolRenderer
  • exportNCAs() : PostProcessor


Class Members - Functions

- f -

  • filterText() : PostProcessor
  • findFile() : PostProcessor
  • flatten() : PostProcessor
  • Format() : Format
  • format() : Format , FormatNumber , IncrementalVariable , Modal , ModalGroup , ReferenceVariable , Variable
  • FormatNumber() : FormatNumber
  • formatWords() : PostProcessor
  • FormData() : FormData


Class Members - Functions

- g -

  • get() : DeferredVariables , FormData
  • getABC() : MachineConfiguration
  • getABCByDirection() : MachineConfiguration
  • getABCByDirection2() : MachineConfiguration
  • getABCByDirectionBoth() : MachineConfiguration
  • getABCByPreference() : MachineConfiguration
  • getAbsolute() : Vector
  • getActiveCode() : ModalGroup
  • getActuator() : Axis
  • getAdditiveFFF() : MachineConfiguration
  • getAggregateId() : Tool
  • getAlpha() : Color
  • getAngle() : Vector
  • getArc() : CurveEntity
  • getAsAngular() : MachineConfiguration
  • getAsAngularFeedrate() : MachineConfiguration
  • getAsBinary() : ToolRenderer
  • getAsFloat() : PostProcessor
  • getAsInt() : PostProcessor
  • getAsPower() : MachineConfiguration
  • getAsSpatial() : MachineConfiguration
  • getAsSpatialFeedrate() : MachineConfiguration
  • getAsTime() : MachineConfiguration
  • getAsWeight() : MachineConfiguration
  • getAxis() : Axis
  • getAxisByCoordinate() : MachineConfiguration
  • getAxisByName() : MachineConfiguration
  • getAxisRotation() : Axis , Matrix
  • getAxisSubstitution() : Section
  • getAxisSubstitutionRadius() : Section
  • getAxisU() : MachineConfiguration
  • getAxisV() : MachineConfiguration
  • getAxisW() : MachineConfiguration
  • getAxisX() : MachineConfiguration
  • getAxisY() : MachineConfiguration
  • getAxisZ() : MachineConfiguration
  • getBlue() : Color
  • getBody() : Mail
  • getBodyLength() : Tool
  • getBoringBarOrientation() : Tool
  • getBoundingBox() : Mesh , Section
  • getBreakControl() : Tool
  • getBySpherical() : Vector
  • getCascadingPath() : PostProcessor
  • getCategories() : Record
  • getCenterPositionX() : MachineConfiguration
  • getCenterPositionY() : MachineConfiguration
  • getCenterPositionZ() : MachineConfiguration
  • getChannel() : Section
  • getCircularCenter() : PostProcessor
  • getCircularChordLength() : PostProcessor
  • getCircularMotion() : PostProcessor
  • getCircularNormal() : PostProcessor
  • getCircularPlane() : PostProcessor
  • getCircularRadius() : PostProcessor
  • getCircularStartRadius() : PostProcessor
  • getCircularSweep() : PostProcessor
  • getClosestABC() : MachineConfiguration
  • getCodePage() : PostProcessor
  • getCollectChuck() : MachineConfiguration
  • getColor() : Canvas
  • getColumn() : Matrix
  • getCombinedPath() : FileSystem
  • getCommandStringId() : PostProcessor
  • getComment() : Tool
  • getCompensationDisplacement() : Tool
  • getCompensationMode() : Tool
  • getCompensationOffset() : PostProcessor , Tool
  • getConfigurationFolder() : PostProcessor
  • getConfigurationPath() : PostProcessor
  • getContent() : Section
  • getControl() : MachineConfiguration
  • getCoolant() : Tool
  • getCoolantName() : PostProcessor
  • getCoordinate() : Axis , Vector
  • getCoordinates() : MachineConfiguration
  • getCornerRadius() : Tool
  • getCurrent() : IncrementalVariable , Modal , Variable
  • getCurrentChannel() : PostProcessor
  • getCurrentDirection() : PostProcessor
  • getCurrentGlobalPosition() : PostProcessor
  • getCurrentNCLocation() : PostProcessor
  • getCurrentPosition() : PostProcessor
  • getCurrentRecordId() : PostProcessor
  • getCurrentSectionId() : PostProcessor
  • getCurrentSpindleSpeed() : PostProcessor
  • getCurrentSyncGroup() : PostProcessor
  • getCutterAsMesh() : Tool
  • getCutterProfile() : Tool
  • getCutterProfileAsSVGPath() : Tool
  • getCuttingDistance() : Section
  • getCycleId() : Section
  • getCycleParameter() : Section
  • getCyclePoint() : PostProcessor
  • getCyclePointId() : PostProcessor
  • getCycleTime() : Section
  • getCycleType() : Record
  • getCyclicLimit() : FormatNumber
  • getCyclicSign() : FormatNumber
  • getDecimalSymbol() : FormatNumber
  • getDepth() : MachineConfiguration
  • getDescription() : MachineConfiguration , Tool
  • getDiameter() : Holder , Shaft , Tool
  • getDiameterOffset() : Tool
  • getDimensions() : MachineConfiguration
  • getDirection() : MachineConfiguration , PostProcessor
  • getDisplacement() : Axis
  • getDistance() : Vector
  • getDistance2() : Vector
  • getDogLeg() : PostProcessor
  • getDynamicWCSOrigin() : Section
  • getDynamicWCSPlane() : Section
  • getDynamicWorkOffset() : Section
  • getEffectiveAxis() : Axis
  • getElement() : Matrix
  • getEnd() : PostProcessor
  • getEntity() : Curve
  • getError() : Format , FormatNumber
  • getEuler() : Matrix
  • getEuler2() : Matrix
  • getEulerRotation() : Matrix
  • getEulerXYXRotation() : Matrix
  • getEulerXYZ() : Matrix
  • getEulerXYZRotation() : Matrix
  • getEulerXZXRotation() : Matrix
  • getEulerXZYRotation() : Matrix
  • getEulerYXYRotation() : Matrix
  • getEulerYXZRotation() : Matrix
  • getEulerYZXRotation() : Matrix
  • getEulerYZYRotation() : Matrix
  • getEulerZXYRotation() : Matrix
  • getEulerZXZ() : Matrix
  • getEulerZXZRotation() : Matrix
  • getEulerZYX() : Matrix
  • getEulerZYXRotation() : Matrix
  • getEulerZYZ() : Matrix
  • getEulerZYZRotation() : Matrix
  • getExtent() : Curve , Tool
  • getExtruderOffsetX() : MachineConfiguration
  • getExtruderOffsetY() : MachineConfiguration
  • getExtruderOffsetZ() : MachineConfiguration
  • getFacet() : Mesh
  • getFCSOrigin() : Section
  • getFCSPlane() : Section
  • getFeedMode() : Section
  • getFeedrate() : PostProcessor
  • getFeedrateRatio() : MachineConfiguration
  • getFilename() : FileSystem
  • getFileSize() : FileSystem
  • getFinalPosition() : Section
  • getFinalSpindleOn() : Section
  • getFinalSpindleSpeed() : Section
  • getFinalToolAxis() : Section
  • getFinalToolAxisABC() : Section
  • getFirstCompensationOffset() : Section
  • getFirstCycle() : Section
  • getFirstPosition() : Section
  • getFirstTool() : PostProcessor
  • getFixture() : PostProcessor
  • getFluteLength() : Tool
  • getFolderPath() : FileSystem
  • getForceDecimal() : FormatNumber
  • getForceSign() : FormatNumber
  • getForceToolChange() : Section
  • getForward() : Matrix
  • getFrameDirection() : PostProcessor
  • getFramePosition() : PostProcessor
  • getGlobalBoundingBox() : Section
  • getGlobalFinalToolAxis() : Section
  • getGlobalInitialToolAxis() : Section
  • getGlobalParameter() : PostProcessor
  • getGlobalPosition() : PostProcessor , Section
  • getGlobalRange() : Section
  • getGlobalWorkOrigin() : Section
  • getGlobalWorkPlane() : Section
  • getGlobalZRange() : Section
  • getGreen() : Color
  • getGroup() : ModalGroup
  • getHeadABC() : MachineConfiguration
  • getHeader() : PostProcessor
  • getHeaderCommit() : PostProcessor
  • getHeaderDate() : PostProcessor
  • getHeaderDate2() : PostProcessor
  • getHeaderSnippet() : PostProcessor
  • getHeaderVersion() : PostProcessor
  • getHeadOrientation() : MachineConfiguration
  • getHeight() : Canvas , MachineConfiguration
  • getHelicalDistance() : PostProcessor
  • getHelicalOffset() : PostProcessor
  • getHelicalPitch() : PostProcessor
  • getHighFeedMapping() : PostProcessor
  • getHighFeedrate() : PostProcessor
  • getHolder() : Tool
  • getHolderAsMesh() : Tool
  • getHolderComment() : Tool
  • getHolderDescription() : Tool
  • getHolderDiameter() : Tool
  • getHolderLength() : Tool
  • getHolderNumber() : Tool
  • getHolderProductId() : Tool
  • getHolderProfile() : Tool
  • getHolderProfileAsSVGPath() : Tool
  • getHolderTipDiameter() : Tool
  • getHolderType() : Tool
  • getHolderVendor() : Tool
  • getHomePosition() : Axis
  • getHomePositionX() : MachineConfiguration
  • getHomePositionY() : MachineConfiguration
  • getHomePositionZ() : MachineConfiguration
  • getId() : Record , Section
  • getIndexOfAxisById() : MachineConfiguration
  • getInitialPosition() : Section
  • getInitialSpindleOn() : Section
  • getInitialSpindleSpeed() : Section
  • getInitialToolAxis() : Section
  • getInitialToolAxisABC() : Section
  • getInsertType() : Tool
  • getInspection() : MachineConfiguration
  • getIntermediatePath() : PostProcessor
  • getInverseTime() : PostProcessor
  • getISOPlane() : PostProcessor
  • getJet() : MachineConfiguration
  • getJetDiameter() : Tool
  • getJetDistance() : Tool
  • getJetMode() : Section
  • getJobId() : Section
  • getLangId() : PostProcessor
  • getLastCycle() : Section
  • getLength() : Curve , CurveEntity , Holder , PostProcessor , Shaft , Vector
  • getLength2() : Vector
  • getLengthOffset() : Tool
  • getLine() : CurveEntity
  • getLinearize() : Curve
  • getLinearMoveLength() : MoveLength
  • getLowerToolAxisABC() : Section
  • getMachineConfiguration() : PostProcessor
  • getMachineConfigurationAsText() : PostProcessor
  • getMachineConfigurationByName() : PostProcessor
  • getMachineConfigurations() : PostProcessor
  • getMachiningDistance() : PostProcessor
  • getManualToolChange() : Tool
  • getMaterial() : Tool
  • getMaterialName() : PostProcessor
  • getMaximum() : Range , Vector
  • getMaximumBlockProcessingSpeed() : MachineConfiguration
  • getMaximumCuttingFeedrate() : MachineConfiguration
  • getMaximumDiameter() : Holder , Shaft
  • getMaximumFeed() : Axis
  • getMaximumFeedrate() : MachineConfiguration , Section
  • getMaximumSpindlePower() : MachineConfiguration
  • getMaximumSpindleSpeed() : MachineConfiguration , Section , Tool
  • getMaximumTilt() : Section
  • getMaximumToolDiameter() : MachineConfiguration
  • getMaximumToolLength() : MachineConfiguration
  • getMaximumToolWeight() : MachineConfiguration
  • getMiddle() : Range
  • getMilling() : MachineConfiguration
  • getMinimum() : Range , Vector
  • getMinimumValue() : Format , FormatNumber
  • getModel() : MachineConfiguration
  • getModelOrigin() : Section
  • getModelPlane() : Section
  • getMovement() : PostProcessor
  • getMovements() : Section
  • getMultiAxisFeedrateBpwRatio() : MachineConfiguration
  • getMultiAxisFeedrateDPMType() : MachineConfiguration
  • getMultiAxisFeedrateInverseTimeUnits() : MachineConfiguration
  • getMultiAxisFeedrateMaximum() : MachineConfiguration
  • getMultiAxisFeedrateMode() : MachineConfiguration
  • getMultiAxisFeedrateOutputTolerance() : MachineConfiguration
  • getMultiAxisMoveLength() : PostProcessor
  • getN1() : Matrix
  • getN2() : Matrix
  • getName() : Axis
  • getNegated() : Matrix , Vector
  • getNextRecord() : PostProcessor
  • getNextSection() : PostProcessor
  • getNextTool() : PostProcessor
  • getNormalized() : Vector
  • getNumber() : Tool
  • getNumberExtruders() : MachineConfiguration
  • getNumberOfAxes() : MachineConfiguration
  • getNumberOfChannels() : PostProcessor
  • getNumberOfCodes() : ModalGroup
  • getNumberOfCodesInGroup() : ModalGroup
  • getNumberOfCyclePoints() : PostProcessor , Section
  • getNumberOfCycles() : Section
  • getNumberOfCyclesWithId() : Section
  • getNumberOfDecimals() : FormatNumber
  • getNumberOfEntities() : Curve
  • getNumberOfFacets() : Mesh
  • getNumberOfFlutes() : Tool
  • getNumberOfGroups() : ModalGroup
  • getNumberOfPatternInstances() : Section
  • getNumberOfRecords() : PostProcessor , Section
  • getNumberOfSections() : Holder , PostProcessor , Shaft
  • getNumberOfSegments() : PostProcessor
  • getNumberOfSyncGroups() : PostProcessor
  • getNumberOfTools() : MachineConfiguration , ToolTable
  • getNumberOfVertices() : Mesh
  • getNumberOfWorkOffsets() : MachineConfiguration
  • getOffset() : Axis , CircularMotion , FormatNumber
  • getOperationProperties() : Section
  • getOptimizedDirection() : MachineConfiguration
  • getOptimizedHeads() : MachineConfiguration
  • getOptimizedPosition() : MachineConfiguration
  • getOptimizedTables() : MachineConfiguration
  • getOptimizedTCPMode() : Section
  • getOrientation() : MachineConfiguration
  • getOtherABCByDirection() : MachineConfiguration
  • getOutputPath() : PostProcessor
  • getOutputUnit() : PostProcessor
  • getParameter() : PostProcessor , Section
  • getParameterName() : Record
  • getParameterValue() : Record
  • getParkPositionX() : MachineConfiguration
  • getParkPositionY() : MachineConfiguration
  • getParkPositionZ() : MachineConfiguration
  • getPartCatcher() : Section
  • getPartDimensions() : MachineConfiguration
  • getPartMaximumX() : MachineConfiguration
  • getPartMaximumY() : MachineConfiguration
  • getPartMaximumZ() : MachineConfiguration
  • getPatternId() : Section
  • getPixel() : Canvas
  • getPlane() : PostProcessor
  • getPlatform() : PostProcessor
  • getPolarPosition() : PostProcessor
  • getPosition() : MachineConfiguration
  • getPositionU() : CircularMotion , PostProcessor
  • getPostProcessorFolder() : PostProcessor
  • getPostProcessorPath() : PostProcessor
  • getPower() : PostProcessor
  • getPreference() : Axis
  • getPreferredABC() : MachineConfiguration
  • getPrefix() : FormatNumber , IncrementalVariable , Modal , ReferenceVariable , Variable
  • getPreviousRecord() : PostProcessor
  • getPreviousSection() : PostProcessor
  • getProbeWorkOffset() : Section
  • getProduct() : PostProcessor
  • getProductId() : Tool
  • getProductUri() : PostProcessor
  • getProductUrl() : PostProcessor
  • getProgramNameAsInt() : PostProcessor
  • getProgramNameAsString() : PostProcessor
  • getProperty() : PostProcessor
  • getQuadrant() : PostProcessor
  • getQuality() : Section
  • getRadialMoveLength() : MoveLength
  • getRadialToolTipMoveLength() : MoveLength
  • getRadius() : CurveEntity
  • getRadiusCompensation() : PostProcessor
  • getRampingSpindleRPM() : Tool
  • getRange() : Axis
  • getRapidDistance() : Section
  • getRapidFeed() : Axis
  • getRayIntersection() : BoundingBox
  • getReconfigure() : MachineConfiguration
  • getRecord() : PostProcessor , Section
  • getRed() : Color
  • getRedirectionBuffer() : PostProcessor
  • getRedirectionBuffer2() : PostProcessor
  • getRemainingOrientation() : MachineConfiguration
  • getReplyTo() : Mail
  • getReset() : Axis
  • getResolution() : Axis
  • getResolutionError() : Axis
  • getResponseHeader() : XMLHttpRequest
  • getResultingValue() : Format , FormatNumber
  • getRetractOnIndexing() : MachineConfiguration
  • getRetractPlane() : MachineConfiguration
  • getRewindStockExpansion() : MachineConfiguration
  • getRight() : Matrix
  • getRotation() : PostProcessor
  • getRotationAxis() : MachineConfiguration
  • getRow() : Matrix
  • getSafePlungeFeedrate() : MachineConfiguration
  • getSafeRetractDistance() : MachineConfiguration
  • getSafeRetractFeedrate() : MachineConfiguration
  • getScale() : FormatNumber
  • getSecondaryCompensationOffset() : Tool
  • getSecondaryLengthOffset() : Tool
  • getSection() : PostProcessor
  • getSectionFrameDirection() : PostProcessor
  • getSectionFramePosition() : PostProcessor
  • getSectionPosition() : PostProcessor , Section
  • getSectionsInChannel() : PostProcessor
  • getSecurityLevel() : PostProcessor
  • getSenderEmail() : Mail
  • getSenderName() : Mail
  • getShaft() : Tool
  • getShaftDiameter() : Tool
  • getShortestAngularRotation() : MachineConfiguration
  • getShoulderLength() : Tool
  • getSingularityAdjust() : MachineConfiguration
  • getSingularityAngle() : MachineConfiguration
  • getSingularityCone() : MachineConfiguration
  • getSingularityLinearizationTolerance() : MachineConfiguration
  • getSingularityMethod() : MachineConfiguration
  • getSingularityTolerance() : MachineConfiguration
  • getSpan() : Range
  • getSpindle() : Section
  • getSpindleAxis() : MachineConfiguration
  • getSpindleAxisABC() : MachineConfiguration
  • getSpindleDescription() : MachineConfiguration
  • getSpindleMode() : Tool
  • getSpindleRPM() : Tool
  • getSpindleSpeed() : PostProcessor
  • getStatusDescription() : MachineConfiguration
  • getStrategy() : Section
  • getSubject() : Mail
  • getSuffix() : FormatNumber , Modal
  • getSurfaceSpeed() : Tool
  • getSweep() : CurveEntity
  • getSystemUnit() : PostProcessor
  • getTableABC() : MachineConfiguration
  • getTableOrientation() : MachineConfiguration
  • getTailstock() : Section
  • getTaperAngle() : Tool
  • getTappingFeedrate() : Tool
  • getTemporaryFile() : FileSystem
  • getTemporaryFolder() : FileSystem
  • getThreadPitch() : Tool
  • getTiltAndTilt() : Matrix
  • getTipDiameter() : Tool
  • getTool() : Section , ToolTable
  • getToolAxis() : Section
  • getToolChanger() : MachineConfiguration
  • getToolChangeTime() : MachineConfiguration
  • getToolId() : Tool
  • getToolLength() : MachineConfiguration
  • getToolOrientation() : Section
  • getToolPreload() : MachineConfiguration
  • getToolTable() : PostProcessor
  • getToolTypeName() : PostProcessor
  • getTotalLength() : Holder , Shaft
  • getTranslation() : PostProcessor
  • getTransposed() : Matrix
  • getTrimLeadZero() : FormatNumber
  • getTrimZeroDecimals() : FormatNumber
  • getTurnAndTilt() : Matrix
  • getTurning() : MachineConfiguration
  • getTurret() : Tool
  • getType() : Record , Section , Tool
  • getU() : Range
  • getUnit() : Section , Tool
  • getUp() : Matrix
  • getUpperToolAxisABC() : Section
  • getValidityStatus() : MachineConfiguration
  • getVendor() : MachineConfiguration , PostProcessor , Tool
  • getVendorUrl() : MachineConfiguration , PostProcessor
  • getVersion() : PostProcessor
  • getVertex() : Mesh
  • getVirtualTooltip() : MachineConfiguration
  • getWCS() : Section
  • getWCSIndex() : Section
  • getWCSOrigin() : Section
  • getWCSPlane() : Section
  • getWCSPosition() : PostProcessor , Section
  • getWeight() : MachineConfiguration
  • getWeightCapacity() : MachineConfiguration
  • getWidth() : Canvas , FormatNumber , MachineConfiguration
  • getWire() : MachineConfiguration
  • getWordSeparator() : PostProcessor
  • getWorkOffset() : Section
  • getWorkOrigin() : Section
  • getWorkpiece() : PostProcessor
  • getWorkPlane() : Section
  • getX() : Vector
  • getXML() : MachineConfiguration
  • getXRotation() : Matrix
  • getXYAngle() : Vector
  • getXYZRotation() : Matrix
  • getY() : Vector
  • getYRotation() : Matrix
  • getZ() : Vector
  • getZAngle() : Vector
  • getZeroPad() : FormatNumber
  • getZRange() : Section
  • getZRotation() : Matrix
  • grow() : Range


Class Members - Functions

- h -

  • has() : FormData
  • hasActiveCode() : ModalGroup
  • hasAnyCycle() : Section
  • hasArcs() : Curve
  • hasCenterPosition() : MachineConfiguration
  • hasCycle() : Section
  • hasCycleParameter() : Section
  • hasDynamicWorkOffset() : Section
  • hasGlobalParameter() : PostProcessor
  • hasHomePositionX() : MachineConfiguration
  • hasHomePositionY() : MachineConfiguration
  • hasHomePositionZ() : MachineConfiguration
  • hasNextRecord() : PostProcessor
  • hasNextSection() : PostProcessor
  • hasParameter() : PostProcessor , Section
  • hasParkPosition() : MachineConfiguration
  • hasPreviousRecord() : PostProcessor
  • hasSections() : Holder , Shaft
  • hasSymbol() : PostProcessor
  • hasWellDefinedPosition() : Section


Class Members - Functions

- i -

  • include() : PostProcessor
  • IncrementalVariable() : IncrementalVariable
  • indexOf() : Array
  • inSameGroup() : ModalGroup
  • interval() : PostProcessor
  • invokeOnCircular() : PostProcessor
  • invokeOnLinear() : PostProcessor
  • invokeOnLinear5D() : PostProcessor
  • invokeOnRapid() : PostProcessor
  • invokeOnRapid5D() : PostProcessor
  • is3D() : PostProcessor
  • is3DConfiguration() : MachineConfiguration
  • isABCSupported() : MachineConfiguration
  • isActiveCode() : ModalGroup
  • isAggregate() : Axis
  • isAxialCenterDrilling() : PostProcessor
  • isBigArc() : CurveEntity
  • isClockwise() : PostProcessor , Tool
  • isClockwiseSpindleDirection() : PostProcessor
  • isClosed() : Curve
  • isCodeDefined() : ModalGroup
  • isCoolantActive() : PostProcessor
  • isCoolantSupported() : MachineConfiguration
  • isCuttingMotionAwayFromRotary() : Section
  • isCycle() : Record
  • isCyclic() : Axis
  • isDepositionOperation() : PostProcessor
  • isDirectionSupported() : MachineConfiguration
  • isDrill() : Tool
  • isDrillingCycle() : PostProcessor
  • isEmpty() : StringBuffer
  • isEnabled() : Axis , ModalGroup
  • isExpanding() : PostProcessor
  • isFile() : FileSystem
  • isFirstCyclePoint() : PostProcessor
  • isFirstSection() : PostProcessor
  • isFolder() : FileSystem
  • isFullCircle() : PostProcessor
  • isGroup() : ModalGroup
  • isHead() : Axis
  • isHeadConfiguration() : MachineConfiguration
  • isHelical() : PostProcessor
  • isIdentity() : Matrix
  • isInspectionOperation() : PostProcessor
  • isInteractionAllowed() : PostProcessor
  • isJet() : PostProcessor
  • isJetTool() : Tool
  • isLastCyclePoint() : PostProcessor
  • isLastSection() : PostProcessor
  • isLinear() : Axis
  • isLiveTool() : Tool
  • isMachineAxisRotation() : MachineConfiguration
  • isMachineCoordinate() : MachineConfiguration
  • isMilling() : PostProcessor
  • isMillingCycle() : PostProcessor
  • isMotion() : Record
  • isMultiAxis() : PostProcessor , Section
  • isMultiAxisConfiguration() : MachineConfiguration
  • isMultiChannelProgram() : PostProcessor
  • isNewWorkOffset() : PostProcessor
  • isNewWorkPlane() : PostProcessor
  • isNonRange() : Range
  • isNonZero() : Vector
  • isOpen() : TextFile
  • isOptimizedForMachine() : Section
  • isOptional() : Section
  • isParameter() : Record
  • isPatterned() : Section
  • isPolarModeActive() : PostProcessor
  • isProbeOperation() : PostProcessor
  • isProbingCycle() : PostProcessor
  • isReceived() : MachineConfiguration
  • isRedirecting() : PostProcessor
  • isRotational() : Axis
  • isSafeText() : PostProcessor
  • isSameDirection() : PostProcessor
  • isSectionSpecialCycle() : PostProcessor
  • isSignificant() : Format , FormatNumber
  • isSpeedFeedSynchronizationActive() : PostProcessor
  • isSpindleActive() : PostProcessor
  • isSpindleSpeedDifferent() : PostProcessor
  • isSpiral() : PostProcessor
  • isSubSpindleCycle() : PostProcessor
  • isSupported() : Axis , MachineConfiguration
  • isSupportedPosition() : MachineConfiguration
  • isSupportedText() : PostProcessor
  • isTable() : Axis
  • isTableConfiguration() : MachineConfiguration
  • isTappingCycle() : PostProcessor
  • isTCPEnabled() : Axis
  • isTextSupported() : PostProcessor
  • isToolChangeNeeded() : PostProcessor
  • isTopWorkPlane() : Section
  • isTurning() : PostProcessor
  • isTurningTool() : Tool
  • isValid() : Record
  • isWellKnownCommand() : PostProcessor
  • isWellKnownCycle() : PostProcessor
  • isWithin() : Range
  • isWorkpieceDefined() : PostProcessor
  • isXOriented() : Section
  • isXYZSupported() : MachineConfiguration
  • isYOriented() : Section
  • isZero() : Matrix , Vector
  • isZOriented() : Section


Class Members - Functions

- l -

  • lastIndexOf() : Array
  • lerp() : Vector
  • linearize() : PostProcessor
  • loadBinary() : BinaryFile
  • loadImage() : Canvas
  • loadLocale() : PostProcessor
  • loadMachineConfiguration() : PostProcessor
  • loadMesh() : Mesh
  • loadText() : PostProcessor
  • localize() : PostProcessor
  • localize2() : PostProcessor
  • log() : PostProcessor
  • lookup() : Table


Class Members - Functions

- m -

  • MachineConfiguration() : MachineConfiguration
  • Mail() : Mail
  • makeActiveCode() : ModalGroup
  • makeFolder() : FileSystem
  • Matrix() : Matrix
  • Mesh() : Mesh
  • Modal() : Modal
  • ModalGroup() : ModalGroup
  • moveFile() : FileSystem
  • multiply() : Matrix , Vector


Class Members - Functions

- n -

  • negate() : Matrix , Vector
  • normalize() : Matrix , Vector


Class Members - Functions

- o -

  • onAcceleration() : PostProcessor
  • onBedTemp() : PostProcessor
  • onCircular() : PostProcessor
  • onCircularExtrude() : PostProcessor
  • onClose() : PostProcessor
  • onCommand() : PostProcessor
  • onComment() : PostProcessor
  • onCycle() : PostProcessor
  • onCycleEnd() : PostProcessor
  • onCyclePath() : PostProcessor
  • onCyclePathEnd() : PostProcessor
  • onCyclePoint() : PostProcessor
  • onDwell() : PostProcessor
  • onExpandedLinear() : PostProcessor
  • onExpandedRapid() : PostProcessor
  • onExpandedSpindleSpeed() : PostProcessor
  • onExtruderChange() : PostProcessor
  • onExtruderTemp() : PostProcessor
  • onExtrusionReset() : PostProcessor
  • onFanSpeed() : PostProcessor
  • onImpliedCommand() : PostProcessor
  • onJerk() : PostProcessor
  • onLayer() : PostProcessor
  • onLinear() : PostProcessor
  • onLinear5D() : PostProcessor
  • onLinearExtrude() : PostProcessor
  • onMachine() : PostProcessor
  • onMaxAcceleration() : PostProcessor
  • onMovement() : PostProcessor
  • onMoveToSafeRetractPosition() : PostProcessor
  • onOpen() : PostProcessor
  • onOrientateSpindle() : PostProcessor
  • onParameter() : PostProcessor
  • onPassThrough() : PostProcessor
  • onPower() : PostProcessor
  • onRadiusCompensation() : PostProcessor
  • onRapid() : PostProcessor
  • onRapid5D() : PostProcessor
  • onReturnFromSafeRetractPosition() : PostProcessor
  • onRewindMachine() : PostProcessor
  • onRewindMachineEntry() : PostProcessor
  • onRotateAxes() : PostProcessor
  • onSectionEnd() : PostProcessor
  • onSpindleSpeed() : PostProcessor
  • onToolCompensation() : PostProcessor
  • onUnsupportedCommand() : PostProcessor
  • onUnsupportedCoolant() : PostProcessor
  • open() : XMLHttpRequest
  • openUrl() : PostProcessor
  • optimize3DPositionsByMachine() : Section
  • optimizeMachineAngles() : PostProcessor
  • optimizeMachineAngles2() : PostProcessor
  • optimizeMachineAnglesByMachine() : PostProcessor , Section


Class Members - Functions

- p -

  • parseSpatial() : PostProcessor
  • performRewinds() : MachineConfiguration
  • PostProcessor() : PostProcessor
  • preserveRotaryAtZero() : MachineConfiguration
  • printDocument() : PostProcessor
  • printDocumentTo() : PostProcessor
  • product() : Vector
  • promptKey() : PostProcessor
  • promptKey2() : PostProcessor
  • promptKey3() : PostProcessor
  • promptText() : PostProcessor


Class Members - Functions

- r -

  • range() : PostProcessor
  • Range() : Range
  • readln() : TextFile
  • Record() : Record
  • redirectToBuffer() : PostProcessor
  • redirectToFile() : PostProcessor
  • reduce() : Axis , Range
  • ReferenceVariable() : ReferenceVariable
  • registerPostProcessing() : PostProcessor
  • registerTerminationHandler() : PostProcessor
  • remap() : FormatNumber
  • remapABC() : MachineConfiguration
  • remapToABC() : MachineConfiguration
  • remapToRange() : Axis
  • remapToRange2() : Axis
  • remove() : FileSystem
  • removeCode() : ModalGroup
  • removeFolder() : FileSystem
  • removeFolderRecursive() : FileSystem
  • replaceExtension() : FileSystem
  • repositionToCycleClearance() : PostProcessor
  • reserve() : Mesh
  • reset() : IncrementalVariable , Modal , ModalGroup , Table , Variable
  • resetGroup() : ModalGroup
  • reverse() : CurveEntity
  • rotateX() : Matrix
  • rotateY() : Matrix
  • rotateZ() : Matrix


Class Members - Functions

- s -

  • saveBinary() : BinaryFile
  • saveImage() : Canvas
  • saveMesh() : Mesh
  • scale() : Mesh
  • send() : SMTP , XMLHttpRequest
  • set() : DeferredVariables
  • setActuator() : Axis
  • setAdditiveFFF() : MachineConfiguration
  • setAutoReset() : ModalGroup
  • setBackgroundColor() : ToolRenderer
  • setBody() : Mail
  • setCascadingPath() : PostProcessor
  • setCenterPositionX() : MachineConfiguration
  • setCenterPositionY() : MachineConfiguration
  • setCenterPositionZ() : MachineConfiguration
  • setCodePage() : PostProcessor
  • setCollectChuck() : MachineConfiguration
  • setColor() : Canvas
  • setColumn() : Matrix
  • setControl() : MachineConfiguration
  • setCoolantSupported() : MachineConfiguration
  • setCoordinate() : Vector
  • setCurrentABC() : PostProcessor
  • setCurrentDirection() : PostProcessor
  • setCurrentPosition() : PostProcessor
  • setCurrentPositionAndDirection() : PostProcessor
  • setCurrentPositionX() : PostProcessor
  • setCurrentPositionY() : PostProcessor
  • setCurrentPositionZ() : PostProcessor
  • setCurrentSpindleSpeed() : PostProcessor
  • setCyclicMapping() : FormatNumber
  • setDecimalSymbol() : FormatNumber
  • setDepth() : MachineConfiguration
  • setDescription() : MachineConfiguration
  • setDimensions() : MachineConfiguration
  • setDogLeg() : PostProcessor
  • setElement() : Matrix
  • setEOL() : PostProcessor
  • setExitCode() : PostProcessor
  • setExtruderOffsetX() : MachineConfiguration
  • setExtruderOffsetY() : MachineConfiguration
  • setExtruderOffsetZ() : MachineConfiguration
  • setFeedrateRatio() : MachineConfiguration
  • setFluteColor() : ToolRenderer
  • setForce() : ModalGroup
  • setForceDecimal() : FormatNumber
  • setForceSign() : FormatNumber
  • setFormatNumber() : ModalGroup
  • setForward() : Matrix
  • setHeight() : MachineConfiguration
  • setHighFeedMapping() : PostProcessor
  • setHighFeedrate() : PostProcessor
  • setHolderColor() : ToolRenderer
  • setHomePositionX() : MachineConfiguration
  • setHomePositionY() : MachineConfiguration
  • setHomePositionZ() : MachineConfiguration
  • setInspection() : MachineConfiguration
  • setIsReceived() : MachineConfiguration
  • setJet() : MachineConfiguration
  • setLogUndefined() : ModalGroup
  • setMachineConfiguration() : PostProcessor
  • setMaximumBlockProcessingSpeed() : MachineConfiguration
  • setMaximumCuttingFeedrate() : MachineConfiguration
  • setMaximumFeed() : Axis
  • setMaximumFeedrate() : MachineConfiguration
  • setMaximumSpindlePower() : MachineConfiguration
  • setMaximumSpindleSpeed() : MachineConfiguration
  • setMaximumToolDiameter() : MachineConfiguration
  • setMaximumToolLength() : MachineConfiguration
  • setMaximumToolWeight() : MachineConfiguration
  • setMilling() : MachineConfiguration
  • setModel() : MachineConfiguration
  • setMultiAxisFeedrate() : MachineConfiguration
  • setName() : Axis
  • setNumberExtruders() : MachineConfiguration
  • setNumberOfDecimals() : FormatNumber
  • setNumberOfTools() : MachineConfiguration
  • setNumberOfWorkOffsets() : MachineConfiguration
  • setOffset() : FormatNumber
  • setOutputUnit() : PostProcessor
  • setParkPositionX() : MachineConfiguration
  • setParkPositionY() : MachineConfiguration
  • setParkPositionZ() : MachineConfiguration
  • setPartDimensions() : MachineConfiguration
  • setPartMaximumX() : MachineConfiguration
  • setPartMaximumY() : MachineConfiguration
  • setPartMaximumZ() : MachineConfiguration
  • setPixel() : Canvas
  • setPreference() : Axis
  • setPrefix() : FormatNumber , IncrementalVariable , Modal , ModalGroup , ReferenceVariable , Variable
  • setProperty() : PostProcessor
  • setRapidFeed() : Axis
  • setReconfigure() : MachineConfiguration
  • setReplyTo() : Mail
  • setRequestHeader() : XMLHttpRequest
  • setReset() : Axis
  • setResolution() : Axis
  • setRetractOnIndexing() : MachineConfiguration
  • setRetractPlane() : MachineConfiguration
  • setRewindStockExpansion() : MachineConfiguration
  • setRight() : Matrix
  • setRotation() : PostProcessor
  • setRow() : Matrix
  • setSafePlungeFeedrate() : MachineConfiguration
  • setSafeRetractDistance() : MachineConfiguration
  • setSafeRetractFeedrate() : MachineConfiguration
  • setScale() : FormatNumber
  • setSectionSpecialCycle() : PostProcessor
  • setSegment() : ToolRenderer
  • setSenderEmail() : Mail
  • setSenderName() : Mail
  • setShaftColor() : ToolRenderer
  • setShortestAngularRotation() : MachineConfiguration
  • setShoulderColor() : ToolRenderer
  • setSingularity() : MachineConfiguration
  • setSpindleAxis() : MachineConfiguration
  • setSpindleDescription() : MachineConfiguration
  • setStrict() : ModalGroup
  • setSubject() : Mail
  • setSuffix() : FormatNumber , Modal , ModalGroup
  • setToolChanger() : MachineConfiguration
  • setToolChangeTime() : MachineConfiguration
  • setToolLength() : MachineConfiguration
  • setToolPreload() : MachineConfiguration
  • setTranslation() : PostProcessor
  • setTrimLeadZero() : FormatNumber
  • setTrimZeroDecimals() : FormatNumber
  • setTurning() : MachineConfiguration
  • setUp() : Matrix
  • setValue() : StringSubstitution
  • setVendor() : MachineConfiguration
  • setVendorUrl() : MachineConfiguration
  • setVirtualTooltip() : MachineConfiguration
  • setWeight() : MachineConfiguration
  • setWeightCapacity() : MachineConfiguration
  • setWidth() : FormatNumber , MachineConfiguration
  • setWire() : MachineConfiguration
  • setWordSeparator() : PostProcessor
  • setWriteInvocations() : PostProcessor
  • setWriteStack() : PostProcessor
  • setX() : Vector
  • setY() : Vector
  • setZ() : Vector
  • setZeroPad() : FormatNumber
  • skipRemainingSection() : PostProcessor
  • SMTP() : SMTP
  • spatial() : PostProcessor
  • split() : String
  • StringBuffer() : StringBuffer
  • StringSubstitution() : StringSubstitution
  • subst() : PostProcessor
  • substitute() : StringSubstitution , Template
  • subtract() : Matrix , Vector
  • sum() : Matrix , Vector


Class Members - Functions

- t -

  • Table() : Table
  • Template() : Template
  • TextFile() : TextFile
  • toDeg() : PostProcessor , Vector
  • toLowerCase() : String
  • Tool() : Tool
  • ToolRenderer() : ToolRenderer
  • toolZRange() : PostProcessor
  • toRad() : PostProcessor , Vector
  • toString() : Color , Matrix , Range , StringBuffer , Vector
  • toUpperCase() : String
  • transform() : Mesh
  • translate() : CurveEntity , Mesh , Range
  • translateText() : PostProcessor
  • transpose() : Matrix


Class Members - Functions

- u -

  • unzipTo() : ZipFile


Class Members - Functions

- v -

  • validate() : PostProcessor
  • validateProperties() : PostProcessor
  • validatePropertyDefinitions() : PostProcessor
  • Variable() : Variable
  • Vector() : Vector


Class Members - Functions

- w -

  • warning() : PostProcessor
  • warningOnce() : PostProcessor
  • write() : PostProcessor , TextFile
  • writeln() : PostProcessor , TextFile
  • writeSectionNotes() : PostProcessor
  • writeSetupNotes() : PostProcessor
  • writeToolTable() : PostProcessor
  • writeWords() : PostProcessor
  • writeWords2() : PostProcessor


Class Members - Functions

- x -

  • XMLHttpRequest() : XMLHttpRequest


Class Members - Functions

- z -

  • zipTo() : ZipFile


Class Members - Variables

- a -

  • A : PostProcessor
  • ABC : PostProcessor
  • abortOnDeprecation : PostProcessor
  • abs : Vector
  • ACK : PostProcessor
  • allowedCircularPlanes : PostProcessor
  • allowHelicalMoves : PostProcessor
  • allowMachineChangeOnSection : PostProcessor
  • allowSpiralMoves : PostProcessor
  • arc : CurveEntity
  • axisSubstitution : Section
  • axisSubstitutionRadius : Section


Class Members - Variables

- b -

  • B : PostProcessor
  • BEL : PostProcessor
  • bodyLength : Tool
  • boringBarOrientation : Tool
  • breakControl : Tool
  • BS : PostProcessor


Class Members - Variables

- c -

  • C : PostProcessor
  • CAN : PostProcessor
  • capabilities : PostProcessor
  • center : CurveEntity , PostProcessor
  • certificationLevel : PostProcessor
  • chipBreakingDistance : MachineParameters
  • chordLength : PostProcessor
  • clamping : Tool
  • clockwise : CurveEntity , PostProcessor
  • COMMAND_ACTIVATE_SPEED_FEED_SYNCHRONIZATION : PostProcessor
  • COMMAND_ALARM : PostProcessor
  • COMMAND_ALERT : PostProcessor
  • COMMAND_BREAK_CONTROL : PostProcessor
  • COMMAND_CALIBRATE : PostProcessor
  • COMMAND_CHANGE_PALLET : PostProcessor
  • COMMAND_CLEAN : PostProcessor
  • COMMAND_CLOSE_DOOR : PostProcessor
  • COMMAND_COOLANT_OFF : PostProcessor
  • COMMAND_COOLANT_ON : PostProcessor
  • COMMAND_DEACTIVATE_SPEED_FEED_SYNCHRONIZATION : PostProcessor
  • COMMAND_END : PostProcessor
  • COMMAND_EXACT_STOP : PostProcessor
  • COMMAND_INVALID : PostProcessor
  • COMMAND_LOAD_TOOL : PostProcessor
  • COMMAND_LOCK_MULTI_AXIS : PostProcessor
  • COMMAND_MAIN_CHUCK_CLOSE : PostProcessor
  • COMMAND_MAIN_CHUCK_OPEN : PostProcessor
  • COMMAND_OPEN_DOOR : PostProcessor
  • COMMAND_OPTIONAL_STOP : PostProcessor
  • COMMAND_ORIENTATE_SPINDLE : PostProcessor
  • COMMAND_POWER_OFF : PostProcessor
  • COMMAND_POWER_ON : PostProcessor
  • COMMAND_PROBE_OFF : PostProcessor
  • COMMAND_PROBE_ON : PostProcessor
  • COMMAND_SECONDARY_CHUCK_CLOSE : PostProcessor
  • COMMAND_SECONDARY_CHUCK_OPEN : PostProcessor
  • COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_ACTIVATE : PostProcessor
  • COMMAND_SECONDARY_SPINDLE_SYNCHRONIZATION_DEACTIVATE : PostProcessor
  • COMMAND_SPINDLE_CLOCKWISE : PostProcessor
  • COMMAND_SPINDLE_COUNTERCLOCKWISE : PostProcessor
  • COMMAND_START_CHIP_TRANSPORT : PostProcessor
  • COMMAND_START_SPINDLE : PostProcessor
  • COMMAND_STOP : PostProcessor
  • COMMAND_STOP_CHIP_TRANSPORT : PostProcessor
  • COMMAND_STOP_SPINDLE : PostProcessor
  • COMMAND_SYNC_CHANNELS : PostProcessor
  • COMMAND_TOOL_MEASURE : PostProcessor
  • COMMAND_UNLOCK_MULTI_AXIS : PostProcessor
  • COMMAND_VERIFY : PostProcessor
  • comment : Tool
  • compensationOffset : Tool
  • coolant : Tool
  • COOLANT_AIR : PostProcessor
  • COOLANT_AIR_THROUGH_TOOL : PostProcessor
  • COOLANT_DISABLED : PostProcessor
  • COOLANT_FLOOD : PostProcessor
  • COOLANT_FLOOD_MIST : PostProcessor
  • COOLANT_FLOOD_THROUGH_TOOL : PostProcessor
  • COOLANT_MIST : PostProcessor
  • COOLANT_SUCTION : PostProcessor
  • COOLANT_THROUGH_TOOL : PostProcessor
  • COOLANT_TOOL : PostProcessor
  • cornerRadius : Tool
  • CR : PostProcessor
  • crossSection : Tool
  • currentSection : PostProcessor
  • cycle : PostProcessor
  • cycleExpanded : PostProcessor
  • cycleType : PostProcessor
  • cyclicLimit : FormatNumber
  • cyclicSign : FormatNumber


Class Members - Variables

- d -

  • DC1 : PostProcessor
  • DC2 : PostProcessor
  • DC3 : PostProcessor
  • DC4 : PostProcessor
  • debugMode : PostProcessor
  • decimalSymbol : FormatNumber
  • deprecated : PostProcessor
  • description : PostProcessor
  • diameter : Tool
  • diameterOffset : Tool
  • DLE : PostProcessor
  • drillingSafeDistance : MachineParameters
  • dynamicWorkOffset : Section


Class Members - Variables

- e -

  • edgeLength : Tool
  • EM : PostProcessor
  • end : CurveEntity , PostProcessor
  • ENQ : PostProcessor
  • EOL : PostProcessor
  • EOT : PostProcessor
  • ESC : PostProcessor
  • ETB : PostProcessor
  • ETX : PostProcessor
  • eulerXYX : Matrix
  • eulerXYX_R : Matrix
  • eulerXYZ : Matrix
  • eulerXYZ_R : Matrix
  • eulerXZX : Matrix
  • eulerXZX_R : Matrix
  • eulerXZY : Matrix
  • eulerXZY_R : Matrix
  • eulerYXY : Matrix
  • eulerYXY_R : Matrix
  • eulerYXZ : Matrix
  • eulerYXZ_R : Matrix
  • eulerYZX : Matrix
  • eulerYZX_R : Matrix
  • eulerYZY : Matrix
  • eulerYZY_R : Matrix
  • eulerZXY : Matrix
  • eulerZXY_R : Matrix
  • eulerZXZ : Matrix
  • eulerZXZ_R : Matrix
  • eulerZYX : Matrix
  • eulerZYX_R : Matrix
  • eulerZYZ : Matrix
  • eulerZYZ_R : Matrix
  • extension : PostProcessor


Class Members - Variables

- f -

  • feedrate : PostProcessor
  • FF : PostProcessor
  • filename : PostProcessor
  • first : VectorPair
  • fluteLength : Tool
  • forceDecimal : FormatNumber
  • forceSign : FormatNumber
  • forward : Matrix
  • FS : PostProcessor
  • fullCircle : PostProcessor


Class Members - Variables

- g -

  • grooveWidth : Tool
  • GS : PostProcessor


Class Members - Variables

- h -

  • hand : Tool
  • HAS_CIRCULAR : PostProcessor
  • HAS_COMMENT : PostProcessor
  • HAS_CYCLE : PostProcessor
  • HAS_DWELL : PostProcessor
  • HAS_LINEAR : PostProcessor
  • HAS_PARAMETER : PostProcessor
  • HAS_RAPID : PostProcessor
  • HAS_WELL_KNOWN_COMMAND : PostProcessor
  • helical : PostProcessor
  • helicalDistance : PostProcessor
  • helicalOffset : PostProcessor
  • HIGH_FEED_MAP_ANY : PostProcessor
  • HIGH_FEED_MAP_MULTI : PostProcessor
  • HIGH_FEED_MAP_XY_Z : PostProcessor
  • HIGH_FEED_NO_MAPPING : PostProcessor
  • highFeedMapping : PostProcessor
  • highFeedrate : PostProcessor
  • holder : Tool
  • holderDiameter : Tool
  • holderLength : Tool
  • holderNumber : Tool
  • holderTipDiameter : Tool


Class Members - Variables

- i -

  • IN : PostProcessor
  • initialCyclePosition : PostProcessor
  • inscribedCircleDiameter : Tool


Class Members - Variables

- l -

  • legal : PostProcessor
  • length : Holder , PostProcessor , Shaft , Vector
  • length2 : Vector
  • lengthOffset : Tool
  • LF : PostProcessor
  • linear : MoveLength
  • lineNumber : PostProcessor
  • liveTool : Tool
  • lower : BoundingBox


Class Members - Variables

- m -

  • machineConfiguration : PostProcessor
  • machineParameters : PostProcessor
  • manualToolChange : Tool
  • mapToWCS : PostProcessor
  • mapWorkOrigin : PostProcessor
  • material : Tool
  • MATERIAL_CARBIDE : PostProcessor
  • MATERIAL_CERAMICS : PostProcessor
  • MATERIAL_HSS : PostProcessor
  • MATERIAL_TI_COATED : PostProcessor
  • MATERIAL_UNSPECIFIED : PostProcessor
  • maximum : Range
  • maximumCircularRadius : PostProcessor
  • maximumCircularSweep : PostProcessor
  • maximumDiameter : Holder , Shaft
  • maximumSpindleSpeed : Tool
  • middle : Range
  • minimum : Range
  • minimumChordLength : PostProcessor
  • minimumCircularRadius : PostProcessor
  • minimumCircularSweep : PostProcessor
  • minimumRevision : PostProcessor
  • MM : PostProcessor
  • movement : PostProcessor
  • MOVEMENT_CUTTING : PostProcessor
  • MOVEMENT_EXTENDED : PostProcessor
  • MOVEMENT_FINISH_CUTTING : PostProcessor
  • MOVEMENT_HIGH_FEED : PostProcessor
  • MOVEMENT_LEAD_IN : PostProcessor
  • MOVEMENT_LEAD_OUT : PostProcessor
  • MOVEMENT_LINK_DIRECT : PostProcessor
  • MOVEMENT_LINK_TRANSITION : PostProcessor
  • MOVEMENT_PLUNGE : PostProcessor
  • MOVEMENT_PREDRILL : PostProcessor
  • MOVEMENT_RAMP : PostProcessor
  • MOVEMENT_RAMP_HELIX : PostProcessor
  • MOVEMENT_RAMP_PROFILE : PostProcessor
  • MOVEMENT_RAMP_ZIG_ZAG : PostProcessor
  • MOVEMENT_RAPID : PostProcessor
  • MOVEMENT_REDUCED : PostProcessor


Class Members - Variables

- n -

  • n1 : Matrix
  • n2 : Matrix
  • NAK : PostProcessor
  • negated : Matrix , Vector
  • normal : PostProcessor
  • normalized : Vector
  • noseRadius : Tool
  • NUL : PostProcessor
  • number : Tool
  • numberOfDecimals : FormatNumber
  • numberOfFlutes : Tool


Class Members - Variables

- o -

  • offset : FormatNumber
  • outputUnit : PostProcessor


Class Members - Variables

- p -

  • partCatcher : Section
  • PATH_SEPARATOR : PostProcessor
  • pitch : Tool
  • plane : PostProcessor
  • PLANE_XY : PostProcessor
  • PLANE_XZ : PostProcessor
  • PLANE_YZ : PostProcessor
  • PLANE_ZX : PostProcessor
  • prefix : FormatNumber
  • preventPost : PostProcessor
  • probeWorkOffset : Section
  • productId : Tool
  • programName : PostProcessor
  • programNameIsInteger : PostProcessor
  • properties : PostProcessor , Section


Class Members - Variables

- q -

  • quality : Section


Class Members - Variables

- r -

  • radial : MoveLength
  • radialToolTip : MoveLength
  • radius : PostProcessor
  • RADIUS_COMPENSATION_LEFT : PostProcessor
  • RADIUS_COMPENSATION_OFF : PostProcessor
  • RADIUS_COMPENSATION_RIGHT : PostProcessor
  • radiusCompensation : PostProcessor
  • rampingSpindleRPM : Tool
  • RECORD_CIRCULAR : PostProcessor
  • RECORD_CIRCULAR_EXTRUDE : PostProcessor
  • RECORD_COMMENT : PostProcessor
  • RECORD_CYCLE : PostProcessor
  • RECORD_CYCLE_OFF : PostProcessor
  • RECORD_DWELL : PostProcessor
  • RECORD_INVALID : PostProcessor
  • RECORD_LINEAR : PostProcessor
  • RECORD_LINEAR_5D : PostProcessor
  • RECORD_LINEAR_EXTRUDE : PostProcessor
  • RECORD_LINEAR_ZXN : PostProcessor
  • RECORD_PARAMETER : PostProcessor
  • RECORD_WELL_KNOWN_COMMAND : PostProcessor
  • RECORD_WIDE_COMMENT : PostProcessor
  • reliefAngle : Tool
  • response : XMLHttpRequest
  • responseXML : XMLHttpRequest
  • revision : PostProcessor
  • right : Matrix
  • RS : PostProcessor


Class Members - Variables

- s -

  • scale : FormatNumber
  • second : VectorPair
  • separator : DeferredVariables
  • shaft : Tool
  • shaftDiameter : Tool
  • shoulderLength : Tool
  • SI : PostProcessor
  • SINGULARITY_LINEARIZE_LINEAR : PostProcessor
  • SINGULARITY_LINEARIZE_OFF : PostProcessor
  • SINGULARITY_LINEARIZE_ROTARY : PostProcessor
  • SO : PostProcessor
  • SOH : PostProcessor
  • SP : PostProcessor
  • span : Range
  • spindle : Section
  • spindleAxis : PostProcessor
  • spindleMode : Tool
  • spindleOrientation : MachineParameters
  • spindleRPM : Tool
  • spindleSpeed : PostProcessor
  • spindleSpeedDwell : MachineParameters
  • start : CurveEntity
  • status : XMLHttpRequest
  • statusText : XMLHttpRequest
  • strategy : Section
  • STX : PostProcessor
  • SUB : PostProcessor
  • suffix : FormatNumber
  • surfaceSpeed : Tool
  • sweep : PostProcessor
  • SYN : PostProcessor


Class Members - Variables

- t -

  • TAB : PostProcessor
  • tailstock : Section
  • taperAngle : Tool
  • thickness : Tool
  • threadPitch : Tool
  • tolerance : PostProcessor , Tool
  • tool : PostProcessor
  • TOOL_AXIS_X : PostProcessor
  • TOOL_AXIS_Y : PostProcessor
  • TOOL_AXIS_Z : PostProcessor
  • TOOL_BORING_BAR : PostProcessor
  • TOOL_COMPENSATION_INSERT_CENTER : PostProcessor
  • TOOL_COMPENSATION_TIP : PostProcessor
  • TOOL_COMPENSATION_TIP_CENTER : PostProcessor
  • TOOL_COMPENSATION_TIP_TANGENT : PostProcessor
  • TOOL_COUNTER_BORE : PostProcessor
  • TOOL_COUNTER_SINK : PostProcessor
  • TOOL_DRILL : PostProcessor
  • TOOL_DRILL_BLOCK : PostProcessor
  • TOOL_DRILL_CENTER : PostProcessor
  • TOOL_DRILL_SPOT : PostProcessor
  • TOOL_GRINDER : PostProcessor
  • TOOL_HOLDER_ONLY : PostProcessor
  • TOOL_LASER_CUTTER : PostProcessor
  • TOOL_MARKER : PostProcessor
  • TOOL_MILLING_CHAMFER : PostProcessor
  • TOOL_MILLING_DOVETAIL : PostProcessor
  • TOOL_MILLING_END_BALL : PostProcessor
  • TOOL_MILLING_END_BULLNOSE : PostProcessor
  • TOOL_MILLING_END_FLAT : PostProcessor
  • TOOL_MILLING_FACE : PostProcessor
  • TOOL_MILLING_FORM : PostProcessor
  • TOOL_MILLING_LOLLIPOP : PostProcessor
  • TOOL_MILLING_RADIUS : PostProcessor
  • TOOL_MILLING_SLOT : PostProcessor
  • TOOL_MILLING_TAPERED : PostProcessor
  • TOOL_MILLING_THREAD : PostProcessor
  • TOOL_PLASMA_CUTTER : PostProcessor
  • TOOL_PROBE : PostProcessor
  • TOOL_REAMER : PostProcessor
  • TOOL_TAP_LEFT_HAND : PostProcessor
  • TOOL_TAP_RIGHT_HAND : PostProcessor
  • TOOL_TURNING_BORING : PostProcessor
  • TOOL_TURNING_CUSTOM : PostProcessor
  • TOOL_TURNING_GENERAL : PostProcessor
  • TOOL_TURNING_GROOVING : PostProcessor
  • TOOL_TURNING_THREADING : PostProcessor
  • TOOL_UNSPECIFIED : PostProcessor
  • TOOL_WATER_JET : PostProcessor
  • TOOL_WELDER : PostProcessor
  • TOOL_WIRE : PostProcessor
  • transposed : Matrix
  • trimLeadZero : FormatNumber
  • trimZeroDecimals : FormatNumber
  • turret : Tool
  • type : Section , Tool


Class Members - Variables

- u -

  • unit : PostProcessor , Section , Tool
  • up : Matrix
  • upper : BoundingBox
  • US : PostProcessor


Class Members - Variables

- v -

  • vendor : PostProcessor , Tool
  • vendorUrl : PostProcessor
  • version : PostProcessor
  • VT : PostProcessor


Class Members - Variables

- w -

  • wcs : Section
  • wcsIndex : Section
  • wcsOrigin : Section
  • wcsPlane : Section
  • width : FormatNumber
  • workOffset : Section
  • workOrigin : Section
  • workPlane : Section


Class Members - Variables

- x -

  • X : PostProcessor
  • x : Vector


Class Members - Variables

- y -

  • Y : PostProcessor
  • y : Vector


Class Members - Variables

- z -

  • Z : PostProcessor
  • z : Vector
  • zeroPad : FormatNumber


Class Members - Enumerations

  • EulerConvention : Matrix


Class Members - Enumerator

  • EULER_XYX_R : Matrix
  • EULER_XYX_S : Matrix
  • EULER_XYZ_R : Matrix
  • EULER_XYZ_S : Matrix
  • EULER_XZX_R : Matrix
  • EULER_XZX_S : Matrix
  • EULER_XZY_R : Matrix
  • EULER_XZY_S : Matrix
  • EULER_YXY_R : Matrix
  • EULER_YXY_S : Matrix
  • EULER_YXZ_R : Matrix
  • EULER_YXZ_S : Matrix
  • EULER_YZX_R : Matrix
  • EULER_YZX_S : Matrix
  • EULER_YZY_R : Matrix
  • EULER_YZY_S : Matrix
  • EULER_ZXY_R : Matrix
  • EULER_ZXY_S : Matrix
  • EULER_ZXZ_R : Matrix
  • EULER_ZXZ_S : Matrix
  • EULER_ZYX_R : Matrix
  • EULER_ZYX_S : Matrix
  • EULER_ZYZ_R : Matrix
  • EULER_ZYZ_S : Matrix


Examples
Here is a list of all examples:
  • minimal.cps


minimal.cps

This is an example of a fairly minimal yet still meaningful post configuration script.

/**
Copyright (C) 2012-2014 by Autodesk, Inc.
All rights reserved.
Minimal post processor configuration.
$Revision$
$Date$
FORKID {96F3CC76-19C0-4828-BF27-6A50AED3B187}
*/
description = "Minimal Heidenhain";
vendor = "Autodesk";
vendorUrl = "http://www.autodesk.com";
legal = "Copyright (C) 2012-2014 by Autodesk, Inc.";
certificationLevel = 2;
longDescription = "Minimal milling post for Heidenhain.";
extension = "h";
setCodePage("ansi");
capabilities = CAPABILITY_MILLING;
var spindleAxisTable = new Table(["X", "Y", "Z"], {force:true});
var radiusCompensationTable = new Table(
[" R0", " RL", " RR"],
{initial:RADIUS_COMPENSATION_OFF},
"Invalid radius compensation"
);
var xyzFormat = createFormat({decimals:(unit == MM ? 3 : 4), forceSign:true});
var feedFormat = createFormat({decimals:(unit == MM ? 0 : 2), scale:(unit == MM ? 1 : 10)});
var rpmFormat = createFormat({decimals:0});
var mFormat = createFormat({prefix:"M", decimals:0});
var xOutput = createVariable({prefix:" X"}, xyzFormat);
var yOutput = createVariable({prefix:" Y"}, xyzFormat);
var zOutput = createVariable({prefix:" Z"}, xyzFormat);
var feedOutput = createVariable({prefix:" F"}, feedFormat);
var blockNumber = 0;
/**
Writes the specified block.
*/
function writeBlock(block) {
writeln(blockNumber + SP + block);
++blockNumber;
}
function onOpen() {
writeBlock(
"BEGIN PGM" + (programName ? (SP + programName) : "") + ((unit == MM) ? " MM" : " INCH")
);
writeBlock(mFormat.format(3)); // spindle on - clockwise
machineConfiguration.setRetractPlane(-1.0); // safe machine retract plane (M91)
}
/**
Invalidates the current position and feedrate. Invoke this function to
force X, Y, Z, and F in the following block.
*/
function invalidate() {
xOutput.reset();
yOutput.reset();
zOutput.reset();
feedOutput.reset();
}
function onSection() {
writeBlock("L Z" + xyzFormat.format(machineConfiguration.getRetractPlane()) + " M91");
var retracted = true;
writeBlock(
"TOOL CALL " + tool.number + SP + spindleAxisTable.lookup(spindleAxis) + " S" + rpmFormat.format(tool.spindleRPM)
);
setTranslation(currentSection.workOrigin);
setRotation(currentSection.workPlane);
invalidate();
var initialPosition = getFramePosition(currentSection.getInitialPosition());
if (!retracted) {
if (getCurrentPosition().z < initialPosition.z) {
writeBlock("L" + zOutput.format(initialPosition.z) + " FMAX");
}
}
writeBlock("L" + xOutput.format(initialPosition.x) + yOutput.format(initialPosition.y) + zOutput.format(initialPosition.z));
}
function onRapid(x, y, z) {
var xyz = xOutput.format(x) + yOutput.format(y) + zOutput.format(z);
if (xyz) {
writeBlock("L" + xyz + radiusCompensationTable.lookup(radiusCompensation) + " FMAX");
feedOutput.reset();
}
}
function onLinear(x, y, z, feed) {
var xyz = xOutput.format(x) + yOutput.format(y) + zOutput.format(z);
var f = feedOutput.format(feed);
if (xyz) {
writeBlock("L" + xyz + radiusCompensationTable.lookup(radiusCompensation) + f);
}
}
function onSectionEnd() {
// full retract in machine coordinate system
writeBlock("L Z" + xyzFormat.format(machineConfiguration.getRetractPlane()) + " R0 FMAX " + mFormat.format(91));
invalidate();
}
function onClose() {
writeBlock(mFormat.format(30)); // stop program, spindle stop, coolant off
writeBlock(
"END PGM" + (programName ? (SP + programName) : "") + ((unit == MM) ? " MM" : " INCH")
);
}


Class Index
a | b | c | d | f | h | i | m | n | p | r | s | t | v | x | z
a
Array
Axis
b
Base64
BinaryFile
Boolean
BoundingBox
c
Canvas
CircularMotion
Color
Curve
CurveEntity
d
Date
DeferredVariables
f
FileSystem
Format
FormatNumber
FormData
h
Holder
i
IncrementalVariable
Integer
m
MachineConfiguration
MachineParameters
Mail
Map
Math
Matrix
Mesh
Modal
ModalGroup
MoveLength
n
Number
p
PostProcessor
r
Range
Record
ReferenceVariable
s
Section
Shaft
SMTP
String
StringBuffer
StringSubstitution
t
Table
Template
TextFile
Tool
ToolRenderer
ToolTable
v
Value
Variable
Vector
VectorPair
x
XMLHttpRequest
z
ZipFile


post Directory Reference

  • post
post Directory Reference


machine/machine Directory Reference

  • machine
  • machine
machine Directory Reference

Directories

Generated by Autodesk, Inc. 20 January 2022
Copyright (c) 2012-2022 by Autodesk, Inc.


machine Directory Reference

  • machine
machine Directory Reference


machine/machine/PostMachineConfig Directory Reference

  • machine
  • machine
  • PostMachineConfig
PostMachineConfig Directory Reference


Related Pages
Here is a list of all related documentation pages:
Usage
Post Processor Configuration
Keywords
Entry Functions
Cycles
Translation
Conventions
Deprecated List