HSMWorks 2023 Help

All Parameters

Generated on February 22, 2022 at 11:51 for HSMWorks 2023

None | Email: cam.support@autodesk.com


All Parameters

Library...

Opens the Tool Library dialog box where you can select an existing tool, or create a new one to use.

Coolant

The type of coolant used with the tool.

Shaft & Holder

Enable to specify how the shaft and/or holder of the tool is used to avoid collisions with the workpiece.

Disabled | Enabled

Shaft And Holder Mode

Specifies how the toolpath should handle a collision between the shaft and/or holder and the workpiece.

Disabled | Trimmed

Pull away | Detect tool length

Trimmed - Sections of the toolpath that result in safe distances between the shaft and/or holder being violated are trimmed away.

Pull away - The toolpath pulls away from the workpiece to maintain a safe distance between the shaft and/or holder.

Detect tool length - The tool is automatically extended further out of the holder to maintain the specified safe distance between the shaft and/or holder and the workpiece. A message indicating how far the tool is extended out of the holder is logged.

Fail on collision - The toolpath calculation is aborted and an error message logged when the safe distance is violated.

Use Shaft

Specifies that the shaft of the selected tool will be used in the toolpath calculation to avoid collisions.

Shaft Clearance

The tool shaft always stays this distance from the part.

Use Holder

Specifies that the holder of the selected tool will be used in the toolpath calculation to avoid collisions.

Holder Clearance

The tool holder always stays this distance from the part.

Spindle Speed

The rotational speed of the spindle.

Surface Speed

The spindle speed expressed as the speed of the tool on the surface.

Ramp Spindle Speed

The rotational speed of the spindle when performing ramp movements.

Cutting Feedrate

Feed used in cutting moves.

Feed Per Tooth

The cutting feedrate expressed as the feed per tooth.

Lead-In Feedrate

Feed used when leading in to a cutting move.

Lead-Out Feedrate

Feed used when leading out from a cutting move.

Ramp Feedrate

Feed used when doing helical ramps into stock.

Plunge Feedrate

Feed used when plunging into stock.

Feed Per Revolution

The plunge feedrate expressed as the feed per revolution.

Retract Feedrate

Feed used when retracting and not using rapid (G0) moves.

Tool Orientation

Use this option if your lathe turret has a programmable B axis. Your post processor will need to support posting from this value. The toolpath pass direction is automatically rotated to suit this value to avoid tool breakage or deflection.

Tool Orientation @ 0 degrees | Tool Orientation @ 45 degrees

Type

The type of the tool.

Unit

The tool unit.

Vendor

The vendor of the tool.
Use this to identify the specific tool used.

Product ID

The vendors' identifier (ID) for the tool.
Use this to identify the specific tool used.

Description

A textual description of the tool.
This description is included in the tool name shown throughout the program.

Comment

A textual comment for the tool.
The comment is typically included in the post-processed output.

Number

The number used to select the tool on the CNC machine.

Diameter Offset

The index of the tool diameter offset.

Length Offset

The index of the tool length offset.
This parameter is normally set when using tools with multiple tips indexed by length.

Material

The tool material.

Break Control

Enable to check for tool breakage after use.

Manual Tool Change

Enable to force a manual tool change on machines with an automatic tool changer.

Diameter

The diameter of the cutter.

Tip Diameter

The tip diameter of the cutter.

Corner Radius

The corner radius of the cutter.

Taper Angle

The taper angle.

Tip Angle

The angle of the tool tip.
This angle is used to calculate the extra depth needed to break the tool through the material.

Flute Length

The tool flute length.

Shoulder Length

The tool shoulder length.

Body Length

The tool body length.

Shaft Diameter

The tool shaft/arbor diameter.

Number of Flutes

The number of cutting flutes on the tool.

Thread Pitch

The pitch of the tap thread, specified as the vertical distance between the teeth of the tap.

Spindle Rotation

Overall Length

Tip Length

Tip Offset

Turret

Tool Clearance Back

Specifies an angle that is added to the tool angle to provide clearance behind the cutting edge.

Shown with 20 deg Back Clearance and 30 deg Front Clearance

Sets the amount of relief between the part and the back edge of the cutting tool. Allows for a more gradual entry into the part and exerts less pressure on the tool.

Tool Clearance Front

Specifies an angle that is added to the tool angle to provide clearance in front of the cutting edge.

Shown with 30 deg Front Clearance and 20 deg Back Clearance

Sets the amount of relief between the part and the front edge of the cutting tool. Allows for a less dragging of the insert against the tools leading edge.

Compensation Offset

The index of the tool compensation offset used for turning.

Machine Inside (Boring)

Specifies that the operation should machine the ID of the workpiece.

Disabled | Enabled

Illustrated with Turning Profile

NOTE: Typically this also means switching from an OD turning tool to a boring tool.

Use Tailstock

A tailstock is used to apply support to the longitudinal rotary axis of the workpiece being machined. This is particularly useful when the workpiece is relatively long and slender. Failing to use a tailstock can cause the workpiece to bend excessively while being cut and cause "chatter".

For this option to take effect, your machine needs a programmable tailstock and your post processor has to be configured to write the code your machine needs.

Once configured, you would typically see M21 (tailstock forward) at the beginning of the operation and M22 (tailstock backward) at the end with this option enabled.

Go Home

The Home position is a known Z value relative to the WCS and is defined within the Work Coordinate System (WCS) section on the Setup tab of the Setup strategy dialog.

You can force the tool to move to the Home position prior to starting the operation, or once the operation has finished. The tool will always pull out of the stock in the X axis until it reaches the Clearance height, then move to the Home position in the Z.

Don't Go Home | Go Home At Beginning

Go Home At End | Go Home At Beginning And End

Note: The Home position referred to here is different from the G28 or G53 home position defined in the Post Processor dialog with some posts. Setting both values simultaneously could create unexpected results if you are unfamiliar with your post processor and machine.

Spindle Speed

Displays the spindle speed in rpm for each machining operation.

Surface Speed

The spindle speed expressed as the speed of the tool on the surface.

Use Constant Surface Speed

Automatically adjusts the spindle RPM to maintain a constant surface speed between the tool and the workpiece as the radial distance of the tool tip changes. Constant Surface Speed (CSS) is specified using G96 on most machines.

Use Feed Per Revolution

Automatically adjusts the feed rate based on the RPM of the spindle to maintain a constant chip load.

Cutting Feedrate

Feed used in cutting moves.

Cutting Feedrate Per Revolution

Sets the distance the tool cuts into the material for each 360 degree rotation of the spindle once the tool is fully engaged.

Lead-In Feedrate

Feed used when leading in to a cutting move.

Lead-In Feedrate Per Revolution

Sets the distance the tool cuts into the material for each 360 degree rotation of the spindle as the tool approaches and initially enters the material.

Lead-Out Feedrate

Feed used when leading out from a cutting move.

Lead-Out Feedrate Per Revolution

Sets the distance the tool cuts into the material for each 360 degree rotation of the spindle as the tool exits the material.

Tool Orientation

Use this option if your lathe turret has a programmable B axis. Your post processor will need to support posting from this value. The toolpath pass direction is automatically rotated to suit this value to avoid tool breakage or deflection.

Tool Orientation @ 0 degrees | Tool Orientation @ -15 degrees

Geometry

Select any sketch feature, or chain edges from the model to form open or closed contours for machining.

Geometry

You can specify specific target part surfaces here.

  • Job Model uses all available geometry in the part or assembly, or as specified in the setup of a job.
  • Selection uses only the bodies, faces or surfaces that is selected.

Note that bodies are selected by default.

If you want to select individual faces instead, you need to use either Select Other or by changing the selection filter to select only faces. You can show the Selection Filter toolbar by pressing F5.

Probe Mode

You can select faces from the part Model or the Stock.
Face selection options will change based on your choice.
Some examples are shown below:

Model Corner 2 Face Selection | Stock Center Top Face Selection
Model Boss Cylinder Face Selection | Stock Boss Top Face Selection

Note: If you're using a model for your stock definition, then you need to choose Model and not Stock in this drop-down menu.

Probe Type

Shows the available Probe Cycles based on your selection.
Probe Mode and your Face selection determines the type of probing that can be performed.

  • X/Y/Z Single Surface - Measure the X, Y, or Z coordinate of a wall.
  • X/Y Pocket - Measure the distance between two internal walls.
  • X/Y Pocket With Island - Measure the distance between two internal walls with an island between them.
  • X/Y Web - Measure the distance between two external walls.
  • X/Y Single Surface Angle - Measure the angle of a surface with reference to the X or Y axis.
  • Internal Corner - Measure the angle between two internal perpendicular walls.
  • Outer Corner - Measure the angle between two external perpendicular walls.
  • Circular Bore - Measure the diameter of the inside of a circular bore hole.
  • Circular Bore With Island - Measure the diameter of the inside of a circular bore hole with an island.
  • Circular Boss - Measure the diameter of the outside of a circular boss.
  • Rectangular Pocket - Measure the X and Y dimensions of a rectangular hole.
  • Rectangular Pocket With Island - Measure the X and Y dimensions of a rectangular hole with an island.
  • Rectangular Boss - Measure the X and Y dimensions of a rectangular extrusion.

Clearance

The distance the probe is to stay clear of the feature before probing.

Overtravel

The distance the probe is allowed to move beyond the expected strike point.

Comparison Tolerance

Used when comparing if two entities are the same, e.g. if two holes have the same diameter.

Advanced parameter. Only shown when advanced mode is enabled

Model

Enable to override the model geometry (surfaces/bodies) defined in the job.

Contact Only

Controls whether or not toolpaths are generated where the tool is not in contact with the machining surface. When disabled, toolpaths are extended to the limits of the containment boundary and across openings in the workpiece.

Enabled | Disabled

Stock Contours

Specifies the perimeter of the stock that needs to be faced.

Disabled | Enabled

Disabled - The perimeter of the stock as defined in the Setup is used.

Enabled - Selected faces or edges are projected to the model top.

Stock Contours

When checked, the toolpath is calculated to consider the boundaries of the defined Stock or a Selected boundary. This provides additional clearance for the Lead in and Lead out moves.

Toolpath is calculated against the Stock boundary, shown in yellow | Toolpath is calculated against a Selected boundary, shown in yellow

In the above example, a single edge is selected for a Contour and additional Roughing Passes are defined. Stock Contours extends the toolpath to clear the edges of the stock area. It can also limit the number of Roughing passes within that area.

Stock Selections

Select an edge or a sketch boundary. The toolpath will start outside the selected boundary. This allows you to create a toolpath that closely fits the contour of the part.

Toolpath is calculated
against a Selected boundary,
shown in yellow

In the above example, a single edge is selected for a Contour and additional Roughing Passes are defined. Stock Contours extends the toolpath to clear the edges of the stock area. It can also limit the number of Roughing passes within that area.

Stock Contours

When checked, the toolpath is calculated to consider the boundaries of the defined Stock or a selected boundary. The default boundary is the Stock box specified in the Setup. You can also select Edges from the model or a Sketch boundary. This provides additional clearance for the Lead in and Lead out moves. This can limit or extend the stock machining area. Leave unchecked for closed boundary pockets.

Calculated from the Stock

A Sketch larger than the Stock

The selected area can be any size or shape

NOTE: This is not a containment boundary, since the tool will approach from outside the selected area.

Stock Selections

Select a closed boundary to define the machining area. You can select any Edges from the model or a Sketch boundary. This can limit or extend the stock machining area. No selection is needed to machine the Stock box specified in the Setup. Selectcting a boundary larger than the stock extends the cutting area. This can be useful for irregular stock sizes. The selected machining boundary can be any shape.

Calculated from the Stock - No selection required

A Sketch larger than the Stock

The selected area can be any size or shape

NOTE: This is not a containment boundary, since the tool will approach from outside the selected area.

Stock Contours

When checked, the toolpath is calculated to consider the boundaries of the defined Stock or a selected boundary. The default boundary is the Stock box specified in the Setup. You can also select Edges from the model or a Sketch boundary. This provides additional clearance for the Lead in and Lead out moves. This can limit or extend the stock machining area. Leave unchecked for closed boundary pockets.

Calculated from the Stock

A Sketch larger than the Stock

The selected area can be any size or shape

NOTE: This is not a containment boundary, since the tool will approach from outside the selected area.

Stock Selections

Select a closed boundary to define the machining area. You can select any Edges from the model or a Sketch boundary. This can limit or extend the stock machining area. No selection is needed to machine the Stock box specified in the Setup. Selectcting a boundary larger than the stock extends the cutting area. This can be useful for irregular stock sizes. The selected machining boundary can be any shape.

Calculated from the Stock - No selection required

A Sketch larger than the Stock

The selected area can be any size or shape

NOTE: This is not a containment boundary, since the tool will approach from outside the selected area.

Drive Mode

Determines if the toolpath will be driven by the Faces of the model or user selected Contours.

With Faces selected, the actual surface will drive the Swarf Toollpath. | With Contours selected, the selected edges will drive the Swarf Toolpath.

Other side

Machine Other Side

Forces the toolpath to the opposite side of the machining contour.
Most likely will be needed with Flip Top-Bottom parameter change.

Flip top-bottom

Flip Top-Bottom

Changes the direction the tool points by switching the Lower Contour
and the Upper Contour. Only applies when Contours are selected.

Flips the Tool Vector 180 Degrees thru the Spindle Axis.

Chaining Tolerance

Used when chaining a boundary or contour. Any gaps closer than the chaining tolerance are automatically merged.

Advanced parameter. Only shown when advanced mode is enabled

Stock Offset

Specifies the distance the machining boundary extends beyond the stock boundary in both X & Y.

Stock Offset

Geometry

Allows you to select the drill positions from points (vertices, sketch points, etc.), sketches containing points, arcs (sketch or solid edges), or cylindrical faces.

Silhouette Aperture

Same Diameter

Check to select all holes with the same diameter as the currently select feature.

Example: If you activate this option, select a single 6mm hole and a single 12mm hole, every 6mm and 12mm hole on the part will automatically be selected.

A single selection can detect matching holes.

Note: This option is associative to the model. If additional holes with the same diameter are added to the model, regenerating the operation automatically includes the new holes.

Same Depth

Check to select all the holes that share the same top to bottom distance as the currently select feature.

Example: You can use this as a way to distinguish between 6mm tapped holes and 6mm drilled holes of different depths.

Short Depth 6mm Holes Selected

Short Depth ISO View | Short Depth Front View

Long Depth 6mm Holes Selected

Long Depth ISO View | Long Depth Front View

Only Same Z Top Height

Check to select all the holes that share the same Z top height as the currently select feature.

Arrow indicates the selected hole feature.

All Short Depth Holes at the Mid Level Height. | All Short Depth Holes at the Mid Level Height and All Long Depth Holes at the Lower Level Height.

Containment Boundary

Use this with Select Same Diameter and Diameter Range to include similar items inside the containment areas. Select any Edge or Sketch boundary to contain the drilling locations. Use multiple boundaries or nested boundaries, to include or exclude groups of holes. The toolpath will be inside the selected boundary unless the boundaries are nested. You can nest several boundaries inside each other.

In the examples below the selected boundaries are shown in blue.

Sketch Boundaries | Holes inside are included
Nested Boundaries | Inside areas are excluded
Selecting the rim area only | Excluding the rim area

Remove Duplicate Holes

Specifies that duplicate holes should be removed.

Order By Depth

Specifies that the passes should be ordered top down.

Disabled | Enabled

Order By Depth

For holes with multiple Z start heights.

Changes the order from the highest to lowest, or lowest to highest. Unchecked, the order will start with the holes at the highest Z level and progressively move down. Check to reverse the order.

When Unchecked First hole is at the highest Z. | When Checked First hole is at the lowest Z.

Geometry for Thread Milling

Select any cylindrical or conical faces for Thread Milling.

Thread Mill Geometry Selection

Select any cylindrical or conical face from the model. This can be a boss for OD thread milling or a hole for ID thread milling. Diameter, Starting height and Bottom depth is all derived from this selection.

Pocket Selections

Select any Face, Edge or Sketch to define the machining boundary. Use Edge selection for areas with holes or pockets inside of pockets. For standing bosses select the outer boundary of the boss and check the Stock Contours option shown below. The toolpath will be calculated between the selected boundary and the outer stock area.

Closed Pocket Face Selection | Closed Pocket Toolpath
Open Pocket Face Selection | Open Pocket Toolpath
Boss Edge Selection with Stock | Area Cleared with Boss Standing

If you select Faces with holes or pockets, Pocket will assume those openings are already cleared and avoid machining them. Use Edge or Sketch to select the machining area.

Pocket Selections

Select any Face, Edge or Sketch to define the machining boundary. Use Edge selection for areas with holes or pockets inside of pockets. For standing bosses select the outer boundary of the boss and check the Stock Contours option shown below. The toolpath will be calculated between the selected boundary and the outer stock area.

Closed Pocket Face Selection | Closed Pocket Toolpath
Open Pocket Face Selection | Open Pocket Toolpath
Boss Edge Selection with Stock | Area Cleared with Boss Standing

If you select Faces with holes or pockets, Adaptive will assume those openings are already cleared and avoid machining them. Use Edge or Sketch to select the machining area.

Geometry

Closed or open boundaries can be machined by selecting Faces, Edges or Sketches. You can remove stock from the inside of a pocket or the outside of a standing boss.

Closed area Pocket

Open area Pocket

Standing Boss

If you select Faces that have holes or pockets, Pocket will assume those openings are already cleared and avoid machining them. Use Edge selection for pockets with holes or pockets inside of the pocket. For standing bosses select the outer boundary of the boss and check the Stock Contours option shown below. The toolpath will be calculated between the selected boundary and the outer stock area.

Geometry for Thread Milling

You can Thread Mill cylindrical or conical faces.

Thread Mill Geometry Selection

Select any cylindrical or conical face from the model. This can be a boss for OD thread milling or a hole for ID thread milling. Diameter, Starting height and Bottom depth is all derived from this selection.

Geometry

Closed or open boundaries can be machined by selecting Faces, Edges or Sketches. You can remove stock from the inside of a pocket or the outside of a standing boss.

Closed area Pocket

Open area Pocket

Standing Boss

If you select Faces that have holes or pockets, Adaptive will assume those openings are already cleared and avoid machining them. Use Edge selection for pockets with holes or pockets inside of the pocket. For standing bosses select the outer boundary of the boss and check the Stock Contours option shown below. The toolpath will be calculated between the selected boundary and the outer stock area.

Drill Location Selections

You can select drilling locations by Model Face, Hole Edge, Sketch Point, Sketch Circle or a Diameter Size Range.

Face Selection | Edge Selection
Sketch Point Selection | Sketch Circle Selection

Hole Mode

Determines what you can select for your hole locations.

Selected Faces - Model based selection.

Cylinder Face Selection | Chamfer Face Selection

Selected Points - Geometry based selection.

Feature Edge Selection | Sketch Point Selection | Sketch Circle Selection

Diameter Range - Size based selection.

The system will evaluate the model based on the Minimum and Maximum Diameter values. Use this range to include or exclude hole sizes.
Example: Select all .250 - .2501 diameter holes for drilling and all .2505 - .2506 diameter holes for reaming.

Using Model based selections insures associativity to any future changes of the feature.

Note: Spot Drilling Options
* If you select the modeled chamfered face of a hole. The Bottom Height (depth) will automatically be determined to the theoretical tip.
* If you select by Diameter Range to includes all holes. Set the Bottom Height from Chamfer Width and set the Chamfer Width value.

Hole Faces

Shows the number of Faces selected for drilling.

Selected Faces - Model based selection.

Cylinder Face Selection | Chamfer Face Selection

Note: To select geometry, switch the Hole Mode to Selected Points.

Hole Points

Shows the number of Points, Circles or Edges selected for drilling.

Selected Points - Geometry based selection.

Feature Edge Selection | Sketch Point Selection | Sketch Circle Selection

Note: To select Model Features, switch the Hole Mode to Selected Faces.
Using Model based selections insures associativity to any future changes of the feature.

Optimize Order

When checked the path between holes is optimized for the shortest distance to reduce cycle time.

Preserve Order

When Selected, the chains/features are machined in the order they were selected.
When unselected, the program optimizes the cut order.

Order Inside-Out

Check to change the order of the toolpath to start at the inner most position of the part. Unchecked and the toolpath will start from an outside edge and work it's way across the part.

When Checked
First hole is at the inner most location.

Select Same Diameter

Check this to automatically select all holes with the same diameter as the hole currently selected in the selection box.

Example: To drill a single 6mm / 1/4" hole and all 12mm / 1/2" holes, first select the 6mm / 1/4" hole, then select one of the 12mm / 1/2" holes, and then check the Select same diameter option.

Using this option is associative to the model, so if additional holes with the same diameter are added later, regenerating the operation automatically includes the added holes in the drilling cycle.

Merge Hole Segments

Auto-Merge Hole Segments

Check to merge multiple hole segments. When enable all hole segments are included to determine the starting height for drilling.

Example: If a hole was Spot Drilled or Counter Bored first, you may want to start drilling from a clearance above that machined area. Enabling Auto-Merge will start the drilling from above the highest hole segment.

Left: Auto-Merge Disabled - Right: Auto-Merge Enabled
Blue line indicates the starting height for drilling.

Limit Angle

Minimum Angle

The smallest angle (from the tool orientation Z-axis) of the holes to machine.

Maximum Angle

The largest angle (from the tool orientation Z-axis) of the holes to machine.

Minimum Depth

Maximum Depth

Limit Diameter

Minimum Diameter

The diameter of the smallest holes to machine.

Maximum Diameter

The diameter of the largest holes to machine.

Include Drilled Holes

When enabled all blind holes with conical termination are detected.

Include Bored Holes

When enabled all blind holes with flat termination are detected.

Include Through Holes

When enabled all holes which are open at both ends are detected.

Include Split Holes

Include fillets

Minimize Tool Axis Changes

Minimize Tool Changes

Minimize Distance

Additional Offset

The additional offset is applied to the selected boundary/boundaries and tool containment.

A positive value offsets the boundary outwards unless the tool containment is Inside, in which case a positive value offsets inwards.

Negative offset Tool center on boundary option | No offset Tool center on boundary option | Positive offset Tool center on boundary option

To ensure that the edge of the tool overlaps the boundary, select the Outside tool containment method and specify a small positive value.

To ensure that the edge of the tool is completely clear of the boundary, select the Inside tool containment method and specify a small positive value.

Tangential Extension Distance

Used on open contours to extend the beginning and end of the selected chain or multiple chains. This creates a tangent linear extension based on the angle of the start and endpoints. This is an extension of the selected geometry.

No Extension | 12mm Extension

If the extension distance causes an overlap of a single chain, the intersection will be trimmed into a closed boundary.

Shown with Multiple Finish Passes set to 2 | Single pass Long extension

Tangential Extension has options for creating a different length on each end of the chain.

Note: You can use the Stock Contours option to force the toolpath past the defined Stock or a selected boundary. Great for irregular shapes. For an additional extenstion to the toolpath, go to the Passes Tab and use the Tangential Fragment Extension Distance.

Separate Tangential End Extension

Select this option to enter a different end extension length value.

16mm Start Extension
5mm End Extension

Machining Boundary

Boundaries mode specifies how the toolpath boundary is defined.

Example 1 | Example 2

Illustrated using a 3D Radial toolpath

Containment modes:

Bounding box | Silhouette | Selection

None - The toolpaths machine all stock without limitation. NOTE: The None option is not available for all machining strategies.

Bounding box - Contains toolpaths within a box defined by the maximum extents of the part as viewed from the WCS.

Silhouette - Contains toolpaths within a boundary defined by the part shadow as viewed from the WCS.

Selection - Contains toolpaths within a region specified by a selected boundary.

Machining Boundary Selection

Tool Containment

Use tool containment to control the tools' position in relation to the selected boundary or boundaries.

Tool inside boundary

The entire tool stays inside the boundary. As a result, the entire surface contained by the boundary might not be machined.

Tool center on boundary

The boundary limits the center of the tool. This setting ensures that the entire surface inside the boundary is machined. However, areas outside the boundary or boundaries might also be machined.

Tool outside boundary

The toolpath is created inside the boundary, but the tool edge can move on the outside edge of the boundary.

Inside | Center | Outside

To offset the boundary containment, use the Additional Offset parameter.

Boundaries Confine the Tool Contact Points

When enabled, extends the Machining boundary limits of the cut position to where the tool touches the part, rather than the tools center position. In the illustration below the red line indicates the machining boundary edge selection, as viewed thru the tool plane. The blue line indicates the tool contact point.

Disabled Center point determines the end of the cut. | Enabled Contact point determines the end of the cut.

Can be used to restrict roll over on the top edge of a cut. The difference is illustrated below on a Parallel toolpath.

Disabled | Enabled

Slope

Contains toolpaths based on a range of specified angles.

0 deg - 90 deg | 0 deg - 45 deg | 45 deg - 90 deg

Slope angle confinement is specified by the From Slope and To Slope Angle parameters on the Geometry tab. Angles are defined from 0 deg (horizontal) to 90 deg (vertical).

Only areas equal to or greater than the values in the From Slope and To Slope areas are machined.

Most 3D finishing strategies supports slope angle confinement. One use of slope confinement is to confine a selected toolpath strategy to angles where it works best. For example, Parallel Finish is better suited to shallow areas while Contour Finish is better suited to steep areas.

From Slope Angle

From Slope angle is defined from the 0 deg (horizontal) plane. Only areas equal to or greater than this value are machined.

Slope Angle From 0 deg

To Slope Angle

To Slope angle is defined from the 0 deg (horizontal) plane. Only areas equal to or less than this value are machined.

Slope Angle To 90 deg

Synchronization Mode

Rest Machining

Limits the operation to just remove material that a previous tool or operation could not remove.

Rest Machining ON | Rest Machining OFF

Rest Machining

Limits the operation to just remove material that a previous tool or operation could not remove.

Use Rest Machining ON | Use Rest Machining OFF

Rest Material Source

Specifies the source from which the rest machining is to be calculated.

  • From previous operation(s)
  • From operation(s)
  • From tool
  • From file
  • From solid(s)
  • From setup stock

Rest Material File

From Setup Stock

Rest Material Operation

Rest material operation.

Union Of All Dependent Operations

Union of all dependent operations.

Include All Previous Operations

Include all previous operations.

Rest Material Tool Taper Angle

Rest Material Tool Shoulder Length

Rest Material Resolution

Specifies the rest material resolution.

Rest Material Tool Corner Radius

Specifies the corner radius of the rest material tool.

Rest Material Stock To Leave

Specifies the rest material stock to leave.

Rest Material Adjustment

Selects the rest material adjustment for respectively ignoring or ensuring milling of small cusps.

  • Use as computed
  • Ignore cusps
  • Machine cusps

Rest Material Adjustment Offset

This parameter specifies the amount of stock to be ignored, or additionally removed, depending on the Rest Material Adjustment setting.

The parameter is primarily used to avoid machining of minor rest material with the Ignore cusps setting.

Rest Material Tool Diameter

Specifies the diameter of the rest material tool.

Tool Orientation

Override the tool orientation defined in the setup.

Works with all 2D and 3D operations to control 3 + 2 Axis programming.

Tool Orientation enabled | Tool Orientation disabled

Tool Orientation Selection

Specifies how the tool orientation is specified.

  • Use Origin & Orientation sets a specific tool orientation for this operation from any selected point and plane as the origin and orientation, respectively.
  • Use Coordinate System sets a specific tool orientation for this operation from any coordinate system feature in the model. This uses both the origin and orientation of the coordinate system feature. Use this if your model does not contain a suitable point & plane for your operation.
  • Use Z-Axis and X-Axis Select a face or an edge to define the Z axis and another face or edge to define the X axis. Both the Z and X axes can be flipped 180 degrees.
  • Use Z-Axis and Y-Axis Select a face or an edge to define the Z axis and another face or edge to define the Y axis. Both the Z and Y axes can be flipped 180 degrees.
  • Use X-Axis and Y-Axis Select a face or an edge to define the X axis and another face or edge to define the Y axis. Both the X and Y axes can be flipped 180 degrees.

Origin

Select any point or vertex as the origin of the tool orientation.

Orientation

Select any face, sketch, or plane as the orientation of the tool orientation.

Override Setup WCS

Specifies that the workpiece coordinate system (WCS) should be different from the WCS given for the setup.

Tool Orientation Selection

Specifies how the workpiece coordinate system is specified.

Origin & Orientation | Coordinate System | Stock & Orientation

Use Origin & Orientation - A sketch point or stock vertex is used to define the location of the WCS, and a plane or planar face is used to define the orientation of the WCS.

Use Coordinate System - An existing user coordinate system (UCS) is used to define both the location and orientation of the WCS.

Use Stock & Orientation - A location on the stock (Example: Top Center) is used to define the location of the WCS, and a plane or planar face is used to define the orientation of the WCS.

Tool Orientation Mode

  • 3 + 2 axis - This mode will allow the Drill Wizard to hunt for holes in all orientations and automatically set a custom Tool orientation for each hole.
  • Tool orientation only - Whereas this mode will only find holes inline with the currently active tool orientation. This may be the setup Z, or a specified Tool orientation set within the Drill Wizard Geometry tab.

Reverse X-Axis

Selecting this checkbox will flip the current coordinate system's X axis 180 degrees.

Reverse Y-Axis

Selecting this checkbox will flip the current coordinate system's Y axis 180 degrees.

Reverse Z-Axis

Selecting this checkbox will flip the current coordinate system's Z axis 180 degrees.

Origin

The Origin drop-down menu offers the following options for locating the triad origin:

Setup WCS origin - Uses the workpiece coordinate system (WCS) origin of the current setup for the tool origin.
Model origin - Uses the coordinate system (WCS) origin of the current part for the tool origin.
Selected point - Select a vertex or an edge for the triad origin.

Model

Enable to override the model geometry (surfaces/bodies) defined in the setup.

Wrap Toolpath

Wraps the toolpath around a cylinder.

The resulting toolpath can be output using axis substitution around a rotary axis, or as full multi-axis moves.

NOTE: Wrap Toolpath introduces a skewing that affects the precision of the result. Specifically any wall below the Wrap Radius will be overcut. To finish walls in a true 4-axis fashion, use Swarf with the Limit to 4-axis option enabled.

Wrap Radius Offset

When performing the wrapping, the toolpath can only be accurate at one radius, the Wrap Radius, which defaults to the radius of the selected wrap cylinder. This offset allows you to adjust the wrap radius.

Wrap Radius

When performing the wrapping, the toolpath can only be accurate at one radius. This is the radius at which the wrapping is performed, and the radius at which it will be accurate.

Any wall below this radius will be overcut, and any wall above this radius will be undercut.

Check Surfaces

Specifies surfaces to avoid. When enabled, toolpaths stay away from the selected surfaces by a specified amount.

Disabled | Enabled | Touch Check Surfaces

NOTE: Touch check surfaces inverts the meaning of the Check Surface setting. When enabled, the check surfaces are the ones that must be touched within the given clearance while the remaining surfaces are avoided.

Avoid/Touch Surfaces

Select the surfaces to avoid. Toolpaths stay away from the selected surfaces by the Surface Amount.

No Selection | Domes Selected | Base Surface Selected

NOTE: Touch surfaces inverts the meaning of the Avoid Surfaces selection. When enabled, the avoid surfaces are the ones that must be touched within the given clearance while the remaining surfaces are avoided.

Avoid/Touch Surface Clearance

Clearance distance from the selected surfaces.

Touch Check Surfaces

This setting inverts the meaning for check surfaces. When enabled, the check surfaces are the ones that must be touched within the given clearance while the remaining surfaces are avoided.

Check Surfaces | Disabled | Enabled

Groove Side Alignment

Back - Offsets the tool from the selected groove geometry in the negative Z direction (toward the backside of the stock).

Middle - Centers the tool on the selected groove geometry.

Front - Offsets the tool from the selected groove geometry in the positive Z direction (toward the frontside of the stock).

Groove Tip Alignment

Cut-through - The tool tip extends past the selected radial distance in the negative radial direction for outside grooving, and in the positive radial direction for inside grooving.

IMPORTANT: The choice between inside/outside grooving appears on the Tool tab - not the Geometry tab.

Tip - The tool tip stops at the selected radial distance.

Confinement

Turning operations attempt to remove all the remaining stock possible with the selected operation type. The toolpath can be contained within a specific region using confinement boundaries.

Confinement enabled | Confinement disabled

Illustrated with Turning Profile

Confinement

Confinement regions can be defined with a combination of edges, surfaces, and/or sketch points as shown below.

Geometry sections | Resulting toolpath

Illustrated with Turning Groove

Frontside Stock Offset

Specifies the distance to machine beyond the frontside of the model.

Confinement using offsets

Negative frontside offset

Positive frontside offset

NOTE: This offset applies to the frontside of the model or containment region, and can be used at the same time as a backside offset.

Backside Stock Offset

Specifies the distance to machine beyond the backside of the model.

Confinement using offsets

Negative backside offset

Positive backside offset

NOTE: This offset applies to the backside of the model or containment region, and can be used at the same time as a frontside offset.

Apply Back From Front

Makes the stock backside offset apply from the front side.

Tangent Propagation

Automatically chain edges tangentially from the selected edges.

Propagate Along Z

Automatically chain edges along the same Z-depth as the selected edges.

Rest Machining

Specifies that only stock left after previous operations should be machined.

Disabled | Enabled

Dwelling Period

Dwelling time in seconds.

Specifying a dwell time halts all axis movement for a specified time while the spindle continues revolving at the specified rpm. This can be used to ensure that chips are cleared before retracting from a hole, and will typically improve the finish of a hole.

Typically a dwelling time between 1/4 second and 1 second is sufficient.

Example: To dwell for 1/4 second, specify 0.25 or 1/4 in this field.

When post processing a drill cycle, the dwell time is specified as one of the drill cycle parameters (typically P), and in most cases it is output in milliseconds (ms).

250ms dwell time in G82

When posting using expanded cycles, the dwell time is output as a regular dwell command (G4).

To calculate the minimum dwell time that will ensure at least one complete revolution, use a value of 60 divided by the spindle speed.

Example: At 350 RPM the minimum dwell time should be 60 / 350 = 0.171s which could be rounded to 0.2s.

Notice: If the operator is running the program with a speed override, then the spindle speed is slower, but the dwell time is constant. To ensure one complete revolution when using a speed override of eg. 50%, the dwell time must be doubled.

Clearance Height

This parameter specifies the clearance plane.

Clearance height mode

The Clearance Height is the first height the tool rapids to on its way to the start of the tool path.

Clearance Heights
  • From Retract Height: incremental offset from the Retract Height.
  • From Feed Height: incremental offset from the Feed Height.
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Clearance height mode

The Clearance Height is the first height the tool rapids to on its way to the start of the tool path.

Clearance Heights
  • From Retract Height: incremental offset from the Retract Height.
  • From Feed Height: incremental offset from the Feed Height.
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Hole Top: incremental offset from the Hole Top.
  • From Hole Bottom: incremental offset from the Hole Bottom.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Height

The height position is the first height the probe rapids to on its way to the start of the probing and the point it returns to after the process is finished.

Probe Clearance Height Reference
  • From Retract Height: incremental offset from the Retract Height.
  • From Feed Height: incremental offset from the Feed Height.
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Clearance height reference

Select an object in the graphics area to use as a reference for this height plane. For each selection type, the plane will position itself at the maximum Z solution while remaining parallel to the active XY plane. Valid selections are:

  • Faces
  • Model Edges
  • Vertex or Points

Note: If you select a straight edge or a spline, the plane will intersect the midpoint of the edge. If you select an arc, the plane will intersect the center point.

Clearance height offset

The Clearance height offset is applied and is relative to the Clearance height mode selection in the above pull down list.

Clearance Height Offset

The Clearance height offset is an adjustment to the relative position specified in the above drop-down list.

Retract Height

This parameter specifies the retract plane.

Retract height mode

Retract height mode sets the height that the tool moves up to before the next cutting pass. Retract height mode should be set above the Feed height and Top. Retract height mode is used together with the subsequent offset to establish the height.

Retract Height
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Retract height mode

Retract height mode sets the height that the tool moves up to before the next cutting pass. Retract height mode should be set above the Feed height and Top. Retract height mode is used together with the subsequent offset to establish the height.

Retract Height
  • From Feed Height: incremental offset from Feed Height.
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Hole Top: incremental offset from the Hole Top.
  • From Hole Bottom: incremental offset from the Hole Bottom.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Retract Height

Retract height position sets an intermediate height between the Clearance and the Bottom height positions.

Probe Retract Height Reference
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Retract height reference

Select an object in the graphics area to use as a reference for this height plane. For each selection type, the plane will position itself at the maximum Z solution while remaining parallel to the active XY plane. Valid selections are:

  • Faces
  • Model Edges
  • Vertex or Points

Note: If you select a straight edge or a spline, the plane will intersect the midpoint of the edge. If you select an arc, the plane will intersect the center point.

Retract height offset

Retract height offset is applied and is relative to the Retract height mode selection in the above pull down list.

Retract Height Offset

Retract height offset is an adjustment to the relative position specified in the above drop-down list.

Feed Height

This parameter specifies the feed plane.

Feed height mode

Feed height mode set the height that the tool rapids to before changing to the feed/plunge rate to enter the part. Feed height mode should be set above the Top. Drilling operation will use this height as the initial feed height and the retract peck height. Feed height mode is used together with the subsequent offset to establish the height.

Feed Height
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Feed height mode

Feed height mode set the height that the tool rapids to before changing to the feed/plunge rate to enter the part. Feed height mode should be set above the Top. Drilling operation will use this height as the initial feed height and the retract peck height. Feed height mode is used together with the subsequent offset to establish the height.

Feed Height
  • Disabled:
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Hole Top: incremental offset from the Hole Top.
  • From Hole Bottom: incremental offset from the Hole Bottom.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Feed height reference

Select an object in the graphics area to use as a reference for this height plane. For each selection type, the plane will position itself at the maximum Z solution while remaining parallel to the active XY plane. Valid selections are:

  • Faces
  • Model Edges
  • Vertex or Points

Note: If you select a straight edge or a spline, the plane will intersect the midpoint of the edge. If you select an arc, the plane will intersect the center point.

Feed height offset

Feed height offset is applied and is relative to the Feed height mode selection in the above pull down list.

Top

Specifies the top of the stock.

Top mode

Top mode sets the height that describes the top of the cut. Top mode should be set above the Bottom. Top mode is used together with the subsequent offset to establish the height.

Top Height
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Top mode

Top mode sets the height that describes the top of the cut. Top mode should be set above the Bottom. Top mode is used together with the subsequent offset to establish the height.

Top Height
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Hole Top: incremental offset from the Hole Top.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Top reference

Select an object in the graphics area to use as a reference for this height plane. For each selection type, the plane will position itself at the maximum Z solution while remaining parallel to the active XY plane. Valid selections are:

  • Faces
  • Model Edges
  • Vertex or Points

Note: If you select a straight edge or a spline, the plane will intersect the midpoint of the edge. If you select an arc, the plane will intersect the center point.

Top offset

Top offset is applied and is relative to the Bottom mode selection in the above pull down list.

Bottom

The maximum cutting depth.

Bottom mode

Bottom mode determines the final machining height/depth and the lowest depth that the tool descends into the stock. Bottom mode needs to be set below the Top. Bottom mode is used together with the subsequent offset to establish the height.

Bottom Height
  • From Top: incremental offset from the Top.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Bottom mode

Bottom mode determines the final machining height/depth and the lowest depth that the tool descends into the stock. Bottom mode needs to be set below the Top. Bottom mode is used together with the subsequent offset to establish the height.

Bottom Height
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Hole Top: incremental offset from the Hole Top.
  • From Hole Bottom: incremental offset from the Hole Bottom.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.
  • To Chamfer Width: drills just deep enough to make the Chamfer Width match the specified chamfer width for the selected tool.
  • To Chamfer Diameter: drills just deep enough to make the Chamfer Diameter match the specified chamfer diameter for the selected tool.

Bottom Height

The Bottom height position determines the reference for the final probing depth. This reference and the Offset value establish the true probing depth. This position is to the contact point of the probe.

Probe Bottom Height Reference
  • From Top: incremental offset from the Top.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Bottom reference

Select an object in the graphics area to use as a reference for this height plane. For each selection type, the plane will position itself at the maximum Z solution while remaining parallel to the active XY plane. Valid selections are:

  • Faces
  • Model Edges
  • Vertex or Points

Note: If you select a straight edge or a spline, the plane will intersect the midpoint of the edge. If you select an arc, the plane will intersect the center point.

Bottom offset

Bottom offset is applied and is relative to the Bottom mode selection in the above pull down list.

Bottom Offset

Bottom height offset is an adjustment to the relative position specified in the above drop-down list. This position represents the tip, not the contact point (side) of the probe.

Drill Tip Through Bottom

When Enabled the tool tip will drill past the bottom of the hole. It positions the lip of the drill to the full diameter at the bottom of the hole.

Depth is to the Tip - Depth is to the Lip.
Left Side: Unchecked - Right Side: Checked

Note: When drilling through the bottom of the part, be aware of the fixture or material below the part.

Break-Through Depth

Specifies how far the lip of the tool drills past the bottom of the hole, to ensure a clean cut through the part. This must be a positive value.

Left: Break Through 0.0 - Right: Break Through 0.06

Note: When drilling through the bottom of the part, be aware of the fixture or material below the part.

Clearance height mode

The Clearance Height is the first height the tool rapids to on its way to the start of the tool path.

Clearance Heights
  • From Retract Height: incremental offset from the Retract Height.
  • From Feed Height: incremental offset from the Feed Height.
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Retract height mode

Retract height mode sets the height that the tool moves up to before the next cutting pass. Retract height mode should be set above the Feed height and Top. Retract height mode is used together with the subsequent offset to establish the height.

Retract Height
  • From Top: incremental offset from the Top.
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Top mode

Top mode sets the height that describes the top of the cut. Top mode should be set above the Bottom. Top mode is used together with the subsequent offset to establish the height.

Top Height
  • From Bottom: incremental offset from the Bottom.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Contour: incremental offset from a Contour selected on the model.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Bottom Height

Bottom mode determines the final machining height/depth and the lowest depth that the tool descends into the stock. Bottom mode needs to be set below the Top. Bottom mode is used together with the subsequent offset to establish the height.

Bottom Height
  • From Top: incremental offset from the Top.
  • From Model Top: incremental offset from the Model Top.
  • From Model Bottom: incremental offset from the Model Bottom.
  • From Stock Top: incremental offset from the Stock Top.
  • From Stock Bottom: incremental offset from the Stock Bottom.
  • From Selection: incremental offset from a Point (vertex), Edge or Face selected on the model.
  • Absolute (From Origin): absolute offset from the Origin that is defined in either the Job or in Tool Orientation within the specific operation.

Sideways Compensation

This setting determines the side of the toopath from which the tool center is offset. Choose between Left (climb milling) sideways compensation or Right (conventional milling) sideways compensation.

Climb Milling | Conventional Milling

Climb vs. Conventional Milling

Climb milling can be thought of as the cutter rolling along the surface that it is cutting. This generally gives a better finish in most metals, but requires good machine rigidity. Using this method, chips start at maximum thickness and get thinner towards the end of the cut, meaning more heat in the chip and less in the part.

With conventional milling, the cutter is rotating away from the surface it is cutting. This method is more commonly used with manual or less rigid machines. It does have some advantages, and can even give a better finish when machining certain materials including some woods.

Compensation Type

Specifies the compensation type.

  • In computer - Tool compensation is calculated automatically by the program, based on the selected tool diameter. The post-processed output contains the compensated path directly, instead of G41/G42 codes.
  • In control - Tool compensation is not calculated, but rather G41/G42 codes are output to allow the operator to set the compensation amount and wear on the machine tool control.
  • Wear - Works as if In computer was selected, but also outputs the G41/G42 codes. This lets the machine tool operator adjust for tool wear at the machine tool control by entering the difference in tool size as a negative number.
  • Inverse wear - Identical to the Wear option, except that the wear adjustment is entered as a positive number.

Note that control compensation (including Wear and Inverse wear) is only done on finishing passes.

Compensation Type

Specifies the compensation type.

  • In computer - Tool compensation is calculated automatically by the program, based on the selected tool diameter. The post-processed output contains the compensated path directly, instead of G41/G42 codes.
  • In control - Tool compensation is not calculated, but rather G41/G42 codes are output to allow the operator to set the compensation amount and wear on the machine tool control.
  • Wear - Works as if In computer was selected, but also outputs the G41/G42 codes. This lets the machine tool operator adjust for tool wear at the machine tool control by entering the difference in tool size as a negative number.
  • Inverse wear - Identical to the Wear option, except that the wear adjustment is entered as a positive number.

Boring Shift

Sets the distance that a boring bar tool moves away from the wall of the toolpath before approaching or retracting to prevent gouging. This option only applies to bore bar drill cycles.

Boring Shift applied for back boring cycle scenario

Spindle Shift Orientation

The spindle orientation to use when shifting during boring. Note that not all CNC controls have full support for controlling the spindle orientation.

Compensation Radius Allowance

This parameter specifies a range of tool diameters that can be safely used, instead of only the tool selected for the operation.

The allowed range of tool radii start from the selected tool radius and goes up to the selected tool radius, plus the given allowance.

Tolerance

The machining tolerance is the sum of the tolerances used for toolpath generation and geometry triangulation. Any additional filtering tolerances must be added to this tolerance to get the total tolerance.

Loose Tolerance .100 | Tight Tolerance .001

CNC machine contouring motion is controlled using line G1 and arc G2 G3 commands. To accommodate this, CAM approximates spline and surface toolpaths by linearizing them; creating many short line segments to approximate the desired shape. How accurately the toolpath matches the desired shape depends largely on the number of lines used. More lines result in a toolpath that more closely approximates the nominal shape of the spline or surface.

Data Starving

It is tempting to always use very tight tolerances, but there are trade-offs including longer toolpath calculation times, large G-code files, and very short line moves. The first two are not much of a problem because the program calculates very quickly and most modern controls have at least 1MB of RAM. However, short line moves, coupled with high feedrates, may result in a phenomenon known as data starving.

Data starving occurs when the control becomes so overwhelmed with data that it cannot keep up. CNC controls can only process a finite number of lines of code (blocks) per second. That can be as few as 40 blocks/second on older machines and 1,000 blocks/second or more on a newer machine like the Haas Automation control. Short line moves and high feedrates can force the processing rate beyond what the control can handle. When that happens, the machine must pause after each move and wait for the next servo command from the control.

Tolerance

The machining tolerance is the sum of the tolerances used for toolpath generation and geometry triangulation. Any additional filtering tolerances must be added to this tolerance to get the total tolerance.

Loose Tolerance .100 | Tight Tolerance .001

CNC machine contouring motion is controlled using line G1 and arc G2 G3 commands. To accommodate this, CAM approximates spline and surface toolpaths by linearizing them; creating many short line segments to approximate the desired shape. How accurately the toolpath matches the desired shape depends largely on the number of lines used. More lines result in a toolpath that more closely approximates the nominal shape of the spline or surface.

Data Starving

It is tempting to always use very tight tolerances, but there are trade-offs including longer toolpath calculation times, large G-code files, and very short line moves. The first two are not much of a problem because the program calculates very quickly and most modern controls have at least 1MB of RAM. However, short line moves, coupled with high feedrates, may result in a phenomenon known as data starving.

Data starving occurs when the control becomes so overwhelmed with data that it cannot keep up. CNC controls can only process a finite number of lines of code (blocks) per second. That can be as few as 40 blocks/second on older machines and 1,000 blocks/second or more on a newer machine like the Haas Automation control. Short line moves and high feedrates can force the processing rate beyond what the control can handle. When that happens, the machine must pause after each move and wait for the next servo command from the control.

Tolerance

The tolerance used when linearizing geometry such as splines and ellipses. The tolerance is taken as the maximum chord distance.

Loose Tolerance .100 | Tight Tolerance .001

CNC machine contouring motion is controlled using line G1 and arc G2 G3 commands. To accommodate this, CAM approximates spline and surface toolpaths by linearizing them; creating many short line segments to approximate the desired shape. How accurately the toolpath matches the desired shape depends largely on the number of lines used. More lines result in a toolpath that more closely approximates the nominal shape of the spline or surface.

Data Starving

It is tempting to always use very tight tolerances, but there are trade-offs including longer toolpath calculation times, large G-code files, and very short line moves. The first two are not much of a problem because the program calculates very quickly and most modern controls have at least 1MB of RAM. However, short line moves, coupled with high feedrates, may result in a phenomenon known as data starving.

Data starving occurs when the control becomes so overwhelmed with data that it cannot keep up. CNC controls can only process a finite number of lines of code (blocks) per second. That can be as few as 40 blocks/second on older machines and 1,000 blocks/second or more on a newer machine like the Haas Automation control. Short line moves and high feedrates can force the processing rate beyond what the control can handle. When that happens, the machine must pause after each move and wait for the next servo command from the control.

Flow Mode

Cutting Mode

The cutting mode specifies how to machine down the sides.

Single Pass

From Bottom | Trim from Bottom
From Top | Trim from Top
Spiral | Morph

Isometric Direction

Specifies whether to do the flow Along u (similar to the X-axis in the Cartesian coordinate system) or to flow Along v (similar to the Y-axis in the Cartesian coordinate system).

Along u

Along v

Multiple Passes

Enable to enter a stepover value.

Multiple Passes

Enable to enter a value for multiple depth cuts when Thread Milling.

Multiple Passes
Uses Multiple cuts to achieve the full thread milling depth

Cutting Mode

The cutting mode specifies how to machine along a given contact curve.

Cutting mode

The cutting mode specifies how to machine along the ISO parametric directions of selected surfaces.

Manual Stepdowns

Stock Thickness

Specifies the overall thickness of the stock.

Stock Height

Tool Offset

Specifies an extra offset along the tool axis relative to the bottom guide curve.

0.00 Tool Offset Extension | 0.20 Tool Offset Extension

Minimize Axial Motion

Along Stock

Pass Overlap

Specifies the distance to extend machining for a closed pass.

Maximum Fan Distance

Specifies the maximum distance over which to fan the tool axis.

Order By Islands

Specifies the order in which depth cuts are taken when there are multiple profiles.

Disabled | Enabled

Disabled - Depth cuts are ordered by depth.

Enabled - Depth cuts are ordered by profile.

NOTE: Ordering cuts by island minimizes the number of rapid moves.

Optimal Load

Specifies the amount of engagement the adaptive strategies should maintain.

NOTE: Legacy clearing toolpaths produce uneven cutter engagement throughout the clearing operation. Using an Adaptive Clearing strategy results in 40% faster material removal rates because larger depth cuts can be taken with full confidence that the cutter will never see spikes in tool engagement that would break cutters.

High Speed Clearing Toolpath | Legacy Clearing Toolpath

Load Deviation

The maximum deviation of the optimal tool load. The load is never higher than the optimal load plus the deviation.

Minimum Cutting Radius

With Minimum Cutting Radius Set

With Minimum Cutting Radius Set - Sharp corners in the toolpath are avoided minimizing chatter in finished parts.

Without Minimum Cutting Radius Set

Without Minimum Cutting Radius Set - The toolpath attempts to remove material anywhere the selected tool can reach. This produces sharp corners in the tool path that often leads to chatter in the machined part.

NOTE: Setting this parameter leaves more material in internal corners, requiring subsequent rest machining operations with a smaller tool.

Fine Stepdown

Specifies the fine stepdown for intermediate steps. These steps are upwards in the direction of the tool axis.

Round Walls

Enable to round the extruded walls.

Manual Stepover

Enable to set the stepover manually.

Use Stepover

Enable to enter a Maximum Stepover value.

Minimum Stepover

Specifies the minimum stepover.

Prevent Full-Width Cuts

Specifies that full-width cuts should be avoided.

Maximum Tool Engagement

Specifies the maximum tool engagement for full-width cuts.

Maximum Trochoidal Radius

Specifies the maximum trochoidal radius.

Machine Shallow Areas

Specifies that extra Z-level passes should be taken in shallow areas to remove excessive cusps.

Disabled | Enabled

Illustrated with 3D Contour

Minimum Shallow Stepdown

This parameter controls the minimum allowed stepdown between the extra Z-levels. It takes precedence over the Maximum Shallow Stepover.

Maximum Shallow Stepover

This parameter controls the stepover used to detect areas where extra Z-levels should be inserted. If the normal stepdown results in a stepover of more than this value, extra levels are inserted until the stepover or the minimum stepdown is reached.

Flat Area Detection

If enabled, the strategy attempts to detect the heights of flat areas and peaks, and machine at these levels.

If disabled, the strategy machines at exactly the specified stepdowns.

Important: Enabling this feature may increase calculation time considerably.

Machine Cavities

If enabled, the strategy ramps into pockets and machines these.

If disabled, the strategy only machines from the outside-in and leaves pockets unmachined.

Machine Cavities

Enable to machine on the inside of the selected closed contours.

Disable to machine on the outside of the selected closed contours.

Open contours may only be specified when this option is enabled.

Machine Cavities Enabled | Machine Cavities Disabled

Machine Cavities

If enabled, the strategy will ramp into pockets and machine these.

If disabled, the strategy will only machine from the outside-in, and leave pockets unmachined.

Minimum Stepdown

Used when detecting flat areas. This is the smallest allowable stepdown to make.

Axial Offset Passes

Enable to do multiple depth cuts.

Disabled | Three Axial Offset Passes

Illustrated with 3D Parallel

Axial offset passes are used to create multiple incremental Z offset passes in many of the 3D finishing strategies.

Axial offset passes work much like multiple finishing stepdowns in the 2D operations and are useful for removing a fixed amount of stock using several passes.

Number Of Stepdowns

Specifies the desired number of stepdowns.

Up/Down Milling

Use this option to break each pass into segments so that each piece is machined using either downward or upward moves only. This is useful when using insert cutters that are restricted to a specific cutting direction.

'''Don't Care''' | Down Milling

Up/Down Shallow Angle

Smooth Ramps

When enabled, ramps are started and ended tangentially in all three axes.

Ramping is done without discontinuities in the first order derivative so that smooth curves are used instead of the usual kinks in the path.

Order Bottom-Up

Contour passes are usually ordered from top to bottom. Enable this check box to specify that passes should be ordered bottom-up (bottom to top).

Ordering is done so that the passes with the smallest Z-level tool orientation are done first in one operation for multiple contours. This method is very useful for machining fragile materials like graphite.

Order By Step

When enabled, each roughing and finishing step is machined to the full depth before moving to the next step.

Disabled | Enabled

Add Perpendicular Passes

This setting adds a set of passes perpendicular to the specified machining direction to reduce machining cusps.

Disabled | Enabled

Machine Straight On

Avoids machining along the steep areas by automatically choosing the best direction for the parallel passes.

Machine Areas Using Boundaries

When enabled, passes are generated from the confinement boundaries defined by all confinement features (machining boundaries, slope, heights, etc.). When disabled, passes are generated from the machining boundaries resulting in passes normally not following the surface.

Boundary Overlap

When using slope confinement and/or rest machining for a Scallop operation, you can enable the Machine Areas Using Boundaries check box to start offsetting the toolpath from the boundaries created by the slope and/or rest material detection.

You can specify a boundary overlap so that the boundary of the detected slope range or rest area is extended by the specified overlap amount.

Area Smoothing

Spiral Mode

Spiral | Spiral with circles | Concentric circles

Spiral creates a path that spirals out from the center point until it reaches the containment boundary or max radius.

Spiral with circles adds a circular toolpath at the minimum radius and at the maximum radius. The circular toolpath is only added if the minimum radius is larger than 0 and the maximum radius is smaller than the radius of the containment boundary.

Concentric circles produces concentric circle paths that are linked. The resulting paths form a circular pattern rather than a spiral pattern.

Morphed spiral spirals from a shape that is not round.

Number Of Offset Stepovers

Contour Offset

This value is used to offset the center of the tool from the generated toolpath by a specified distance.

Morph Mode

Simple - Linear interpolation between points.

Closest - End-point-to-end-point.

Automatic - Automatic morph between points.

Maximum Segment Length

Specifies the maximum length of a single segment for the generated toolpath.

Maximum Tool Axis Sweep

Specifies the maximum angle change in a single tool axis sweep for the generated toolpath.

Allow Relinking

Overthickness

Additional thickness which is applied to the tool to detect passes.

The amount between the actual part radius and the actual tool radius.

Bitangency Angle

An angle in degrees, that is used to determine the number of passes along a wall or fold.

An angle representing the contact points for the tool.

Cutter paths are created along all the contact areas where it would make two simultaneous contacts with the part, at more than this angular difference.

Limit Number Of Stepovers

When disabled, the number of steps is unlimited, and the result is a collapsed pencil finish of the entire surface.

Multiple Finishing Passes

Enable to perform multiple finishing passes.

Roughing Clearing Pass

Specifies that cusps left by the initial roughing passes should be cleared. Enable this setting to avoid the tool loading up with a greater than expected amount of material during the final profile pass. This can become particularly relevant with some geometries when cusps are left on the groove wall.

Roughing Clearing Pass disabled | Roughing Clearing Pass enabled with a 1mm Finishing Stepover

The red shaded area at the left represents the stock that would be removed by Roughing Clearing Pass once enabled.

Note: The clearing pass itself is applied in the Down direction only, irrespective of the Up/Down Direction setting.

Smoothing Deviation

The maximum amount of smoothing applied to the roughing passes. Use this parameter to avoid sharp corners in the toolpath.

Corner Deviation

The maximum corner deviation. Use this parameter to avoid sharp corners in the toolpath.

Smoothing Deviation

The maximum amount of smoothing applied to the roughing passes. Use this parameter to avoid sharp corners in the toolpath.

Finishing Smoothing Deviation

The maximum amount of smoothing applied to the finishing passes. Use this parameter to avoid sharp corners in the toolpath. Setting this parameter leaves more stock than requested at the contour corners.

Roughing Passes

Can be used to take multiple cuts around the selected profile. This activates additional parameters for controlling the Stepover and Number of cuts.

Roughing Passes disabled | Roughing Passes enabled with a 3mm Maximum Stepover

Stepover

Specifies horizontal stepover between passes.

Horizontal Stepover

By default, this value is 95% of the cutter diameter less the tool corner radius.

Stepover

Specifies the stepover amount between passes.

The amount per each cut, when Multiple passes is activated.

Stepover

Spiral Stepover specifies the radial stepover between passes.

Spiral Stepover

The system default is based on 50% of the cutter diameter.

Stepover

The stepover between passes measured along the surface.

Stepover

The stepover between passes measured along the surface.

Number Of Stepovers

The number of roughing steps.

Number Of Stepovers

The number of cutting steps.

Uses Multiple cuts to achieve the full thread milling depth.
This illustration shows 2 Stepovers.

Number Of Stepovers

The number of additional steps to each side of the pencil seed.

Cusp Height

Cusp Height is the theoretical surface finish produced by successive toolpaths left by the radius of the cutter. A smaller tool diameter or a larger stepover produces a larger cusp height.

Cusp Height

Inside/Outside Direction

Specifies if the toolpath moves inside-out or outside-in. Selecting the Don't care option minimizes the ordering by distance.

Outside -> in | Inside -> out

Link From Inside To Outside

Enable to specify whether the linking between passes should be done without particular ordering or linking should be done by ordering from inside passes to outside passes.

Link from inside to outside

specifies whether the moves inside of the part then outward or outside-in.

'''Don't care''' | Inside -> Out | Outside -> In

Angular Step

The angular step in degrees between radial passes.

Angle From

The Radial starting angle in degrees measured from the X axis as viewed from the WCS.

From Angle

Angle To

The Radial ending angle in degrees measured from the X axis as viewed from the WCS.

To Angle

Inner Limit

Sets the minimum inner radius.

No inner Radius | Inner Radius

Illustrated with 3D Spiral

Outer Limit

Sets the maximum outer radius.

No outer Radius | Outer Radius

Illustrated with 3D Spiral

Manual Center

The center of the radial passes.

Clockwise

Specifies that the spiral is clockwise.

Machine Steep Areas

Specifies extra passes will be added where the surface is steep perpendicular to the machining direction. This is important for plastic injection molds where the cutting direction needs to be consistent to avoid marks on the parts.

Disabled | Enabled

Minimum Steep Stepover

Defines the minimum stepover that is used when Machine Steep Areas is enabled, regardless of the stepdown amount.

Maximum Steep Stepdown

Defines the maximum steep stepdown value.

Finishing Overlap

The finishing overlap is the distance that the tool passes beyond the entry point before leading out.

Specifying a Finishing Overlap ensures that the material at the entry point is properly cleared.

No finishing overlap | 0.25" finishing overlap

NOTE: The finishing overlap follows the selected contour, so it is safe to specify a large overlap.

Use Thin Wall

When milling part features with wall thicknesses comparable to sheet metal stock, or even thinner, the stock is subjected to the forces generated by metal removal. This can result in the delicate structure of thin walls moving relative to the tool, making it difficult to maintain dimensional accuracy and impart the specified surface finish.

This option can be used to reduce the vibration and chatter by ensuring that both sides of a thinwall are machined at the same time.

Thin Wall Width

The width of walls that should be considered thin walls.

Any wall with this width or thinner is machined on both sides at the same time to reduce vibration and chatter.

Pass Direction

Specifies the direction of the milling passes.

Pass Direction @ 0 degrees | Pass Direction @ 45 degrees

Maximum Stepover

Specifies the maximum stepover for each cut.

Maximum Stepover
The amount to cut per pass.

Maximum Stepover

Specifies the maximum horizontal stepover between passes.

NOTE: This is NOT the same as optimal load settings with adaptive clearing paths. With legacy 2D roughing, the tool still sees full cutter engagement when transitioning from one pass to the next.

Adaptive Clearing | Legacy 2D Clearing

Allow Stepover Cusps

When programming flat faces with a tool that has a radius in the corner, a cusp (or scallop) can be produced between stepovers.

By default, the Maximum Stepover value is overridden to insure that no stepover cusps are produced.

Allow Stepover Cusps Disabled | Allow Stepover Cusps Enabled

Above - Pocket machined with a 3/8" bullnose end mill @ .25" Maximum Stepover.

Finishing Passes

With Finishing Passes | Without Finishing Passes

Enable to perform finishing passes using the side of the tool.

NOTE: This option is typically used when roughing and finishing is being done with the same tool.

Stepover

Specifies the maximum stepover for each cut, when taking multiple finishing passes.

Finishing Stepover
The amount to cut per pass.

Number Of Finishing Passes

Specifies the number of finishing passes.

Shown with three finishing passes

Leads On All Finishing Passes

Forces a full lead in and out on every finishing pass.

Enabled | Disabled

NOTE: Lead parameters are set on the Linking tab of the Operations dialog box.

Repeat Finishing Pass

Enable to perform an additional finishing pass with zero (0.0) stock.
Clears the stock left over from tool deflection.
Also referred to as a Spring Pass.

Finish Feedrate

Feedrate used for the final finishing pass.

Outer Corner Mode

When machining outer corners, it may be necessary to avoid rolling around the corner in order to leave the corner perfectly sharp. The Outer corner mode setting lets you machine outer corners in three different ways.

Roll around corner - Keeps contact with the corner throughout the motion.

Keep sharp corner - Continues the toolpath to a single point corner, losing contact with the material temporarily.

Keep sharp corner with loop - Similar to Keep sharp corner, but also performs a horizontal lead-out and lead-in at the corner.

Roll Around Corners

Make Sharp Corners

Specifies that sharp corners must be forced.

Caution: Using a smaller tool on the machine can cause a gouge when using this feature.

Multiple Depths

Specifies that multiple depths should be taken.

With Multiple Depth cuts | Without Multiple Depth cuts

NOTE: Adaptive clearing strategies allow for much more aggressive depth cuts than legacy 2D pockets.

Use Slot Clearing

Enable this setting to start pocket clearing with a slot along its middle, before continuing with a spiral motion towards the pocket wall.

This feature can be used to reduce linking motion at corners for some pockets.

Enabled | Disabled

Slot Clearing Width

The width of the initial clearing slot along the middle of the pocket before continuing with a spiral motion towards the pocket wall.

Slot Clearing Width

Maximum Roughing Stepdown

Specifies the maximum stepdown between Z-levels for roughing.

Maximum Roughing Stepdown
Shown without Finishing Stepdowns

NOTE: Sequential Z-level stepdowns are taken at the Maximum Roughing Stepdown value. The Final Roughing stepdown takes the remaining stock, once the remaining stock is less than the Maximum Roughing Stepdown value.

Maximum Stepdown

Specifies the maximum stepdown between Z-levels.

Maximum Stepdown

Specifies the maximum stepdown between Z-levels.

Finishing Stepdowns

The number of finishing passes using the bottom of the tool.

Shown with three Finishing Passes

Finishing Stepdown

The size of each stepdown in the finishing passes.

Finishing Stepdown

Wall Taper Angle

Specifies the taper angle of the walls.

Defining a slope angle can be used to machine features with a 2D strategy that would have otherwise required a 3D strategy.

NOTE: - The slope angle is NOT driven by model geometry, so it is possible that an error entering the slope angle can affect the finished machined part.

Slope Angle @ 0 deg | Slope Angle @ 45 deg

Geometry Selection

Bottom Selection | Top Selection

NOTE: When using a slope angle with the Adaptive Clearing strategy, geometry must be selected at the top of the pocket.

Finish Only At Final Depth

Perform finishing passes only at the final depth to avoid leaving marks on the walls.

Disabled | Enabled

Use Even Stepdowns

Enable to create equal distances between machining passes.

Example: Suppose you are machining a profile with a depth of 23 mm and a maximum stepdown = 10 mm.

With Use even stepdowns enabled - you get three passes with the first value at -7.666 mm, the second at 15.3333 mm, and the third at -23 mm.

With Use even stepdowns disabled - again you get three passes, the first at -10 mm, the second at -20 mm, and the third at -23 mm.

Minimum Axial Engagement

Specifies the minimum allowed axial engagement for the intermediate steps.

This feature is commonly used to keep at least one flute constantly engaged as it turns and hence can reduce tool wear and chatter.

NOTE: - Skipping intermediate steps will leave extra stock for the following semi-roughing operation.

Finishing Step

Specifies that a finishing step should be taken

Finishing Step

From Other Side

Specifies that the toolpath starts on the other side of the part.

Unselected | Selected

Chamfer

Specifies that the contouring operation will be used to create a chamfer.

Geometry Selection Tips:

Sharp Corners | Chamfered Edges

Sharp Corners - Select the sharp corner and define the size of the chamfer using the Chamfer Width Setting.

Chamfered Edges - Select the bottom edge of the chamfer. The chamfer width is calculated automatically.

Important: All edges selected must be either the bottom edge of a chamfered face or unchamfered edges. If both edge types are selected, then the edges that already have the chamfers modeled end up with chamfers that are twice the size they should be.

Chamfer Width

Chamfer Depth

Chamfer Width

The width of the chamfer.

The amount to break the selected edge. This is the distance across the flat edge of the Chamfer.

Chamfer Width

Chamfer Width

The (additional) width of the chamfer.

For edges that are not already chamfered, this is the final width of the chamfer.

For chamfered edges, this is an additional offset; similar to using negative radial stock to leave.

Chamfer Tip Offset

This is added to the toolpath depth, while keeping the tool in contact with the selected edge by adjusting the toolpath radial offset.

Chamfer Tip Offset
Tool Tip Clearance Extension

NOTE: Allows you to cut past the bottom of the Chamfer edge. Keeps you from cutting with the bottom tool edge.

Chamfer Angle

The angle of the chamfer measured from the Z-axis.

Chamfer Extension

Distance by which to extend the chamfer cutting pass.

Chamfer Clearance

This value specifies how far the tool needs to stay away from model geometry that is not being chamfered.

Chamfer Clearance
Collision Avoidance Distance

NOTE: Allows you to cut the Chamfer to a blended edge, while avoiding collisions with intersecting walls.

Pass Extension

Distance to extend the passes beyond the machining boundary.

Pass Extension

Tangential Fragment Extension Distance

Used on open contours to extend the beginning and end of the calculated toolpath. This creates a tangent linear extension based on the angle of the start and endpoints. This extension can be used in combination with the Geometry - Tangential Extension Distance.

No Extension | 12mm Extension

Overlaping extensions of a single chain, will not be trimmed.

Shown with Multiple Finish Passes set to 2 | Single pass Long extension

Note: You can use the Stock Contours option to force the toolpath past the defined Stock or a selected boundary. Great for irregular shapes. If you need a different extension for each end of the cut, you can use Geometry Tab - Tangential Extension Distance.

Tangential Fragment Extension Distance

Extends the cut tangentially at both ends of the pass.

Tangent Extension at both ends of the cut

Tangential End Extension Distance

Specifies the distance to extend the end position.

16mm Start Extension
5mm End Extension

Direction

The direction option lets you control whether the program should try to maintain either climb or conventional milling.

Notice: Depending on the geometry, it is not always possible to maintain climb or conventional milling throughout the entire toolpath.

One way | Both ways

One way

Select One way to machine all the passes in a single direction. When One way is used, the program tries to use climb milling relative to the selected boundaries.

Other way

This reverses the direction of the toolpath compared to the One way setting to generate a conventional milling toolpath.

Both ways

When Both ways is selected, the program disregards the machining direction and links passes with the directions that result in the shortest toolpath.

Direction

Which way to probe along the selected axis.

Direction

Specifies if material is removed using Conventional Milling or Climb Milling, or a combination of both.

Conventional Milling | Climb Milling

Climb vs. Conventional Milling

Milling tools advance through the material so that the cutting flutes engage the material at maximum thickness and then decreases to zero. This is called Climb Milling.

Cutting in the opposite direction causes the tool to scoop up the material, starting at zero thickness and increasing to maximum. This is called Conventional Milling.

Conventional milling is used often on manual machines because backlash in the machine lead screws causes the tool to lurch when climb cutting. This is not a problem on CNC machines because they use ball screws.

Conventional milling causes the tool to rub against the cutting surface, work hardening the material, generating heat, and increasing tool wear. Raking chips across the finished surface also produces a poorer surface finish.

Unless specifically recommended by the tool manufacturer for the material being milled, always use climb milling on a CNC. Climb milling produces far less cutting pressure and heat, leaves a better surface finish, and results in longer tool life.

NOTE: When working with brittle materials, like acrylics, climb milling may be used so material does not "blow out" along edges.

Direction

Specifies the way the machining is done.

  • Climb milling
  • Conventional milling

Direction

Lets you specify whether the program should climb or conventional mill the thread.

Conventional Milling | Climb Milling

Other Considerations. The cut direction, the type of hole (OD or ID) and the threading hand direction (left or right) have an effect on where the thread milling starts. It's possible to cut from top to bottom or bottom to top, depending on these settings.
Examples:
A right hand thread on an OD (boss), with a climb cut will mill from the top to the bottom.
A right hand thread on an ID (hole), with a climb cut will mill from the bottom to the top.

Use the Climb or Conventional Direction parameter to control Top to Bottom or Bottom to Top cut direction.

Both Ways

Specifies that the operation uses both Climb and Conventional milling to machine open profiles.

Unselected | Selected

NOTE: This option only controls how muliple depth cuts are taken on a single open contour. It does not optimize the cut direction for multiple open contours.

Tilt Mode

Forward Tilt

Specifies the number of degrees the tool should be tilted forward.

Sideways Tilt

Specifies the number of degrees the tool should be tilted sideways.

Minimum Tilt

Specifies the minimum allowed tilt from the selected operation tool axis.

Maximum Tilt

Specifies the maximum allowed tilt from the selected operation tool axis.

Stock To Leave

Positive | None | Negative

Positive Stock Value - The amount of stock left for subsequent roughing or finishing operations.

No Stock to Leave - Remove all material up to the selected geometry or part model.

'Negative Stock Value - Removes material beyond the selected geometry or part model. This technique is often used in Electrode Machining to allow for a spark gap or to meet tolerance requirements of a part.

Radial (Wall) Stock To Leave

The radial stock to leave parameter controls the amount of material to leave in the radial (perpendicular to the tool axis) direction, i.e. at the side of the tool.

Radial stock to leave | Radial and Axial stock to leave

Specifying a positive radial stock to leave results in material being left on the vertical walls and steep areas of the part.

For surfaces that are not exactly vertical, the program interpolates between the axial (floor) and radial stock to leave values, so the stock left in the radial direction on these surfaces might be different from the specified value, depending on surface slope and the axial stock to leave value.

Changing the radial stock to leave automatically sets the axial stock to leave to the same amount, unless you manually enter the axial stock to leave.

For finishing operations, the default value is 0 mm/0 in, i.e. no material is left.

For roughing operations, the default is to leave a small amount of material that can then be removed later by one or more finishing operations.

Negative Stock to Leave

When using a negative stock to leave, the machining operation removes more material from your stock than your model shape. This can be used to machine electrodes with a spark gap, where the size of the spark gap is equal to the negative stock to leave.

Both the radial and axial stock to leave can be negative numbers. However, the negative radial stock to leave must be less than the tool radius.

When using a ball or radius cutter with a negative radial stock to leave that is greater than the corner radius, the negative axial stock to leave must be less than or equal to the corner radius.

Axial (Floor) Stock To Leave

The axial stock to leave parameter controls the amount of material to leave in the axial (along the Z-axis) direction, i.e. at the end of the tool.

Axial Stock to Leave | Both Radial and Axial Stock to Leave

Specifying a positive axial stock to leave results in material being left on the shallow areas of the part.

For surfaces that are not exactly horizontal, the program interpolates between the axial and radial (wall) stock to leave values, so the stock left in the axial direction on these surfaces might be different from the specified value, depending on surface slope and the radial stock to leave value.

Changing the radial stock to leave automatically sets the axial stock to leave to the same amount, unless you manually enter the axial stock to leave.

For finishing operations, the default value is 0 mm/0 in, i.e. no material is left.

For roughing operations, the default is to leave a small amount of material that can then be removed later by one or more finishing operations.

Negative Stock to Leave

When using a negative stock to leave, the machining operation removes more material from your stock than your model shape. This can be used to machine electrodes with a spark gap, where the size of the spark gap is equal to the negative stock to leave.

Both the radial and axial stock to leave can be negative numbers, however when using a ball or radius cutter with a negative radial stock to leave that is greater than the corner radius, the negative axial stock to leave must be less than or equal to the corner radius.

Axial Offset

Specifies an axial offset value for the toolpath for the chosen contour.

Minimum Diameter

Minimum Fragment Length

Fragment Extension Distance

Threading Hand

Right handed | Left handed

Threading Hand

Create a Right or Left handed thread direction.

Thread Pitch

The distance between threads.

The distance traversed for 1 complete thread.
1/Threads Per Inch (TPI) or or the actual pitch for metric threads.

Pitch

Specifies the distance per 360° step as the tool feeds to depth.
For straight walls this value is generally larger, than with tapered walls.
A finer Pitch on a Tapered wall creates a smoother surface finish.

Depth Per. Revolution

Fillet Radius

Specify a fillet radius.

Smoothing Filter

Smooths the toolpath by removing excessive points and fitting arcs where possible within the given filtering tolerance.

Smoothing Off | Smoothing On

Smoothing is used to reduce code size without sacrificing accuracy. Smoothing works by replacing collinear lines with one line and tangent arcs to replace multiple lines in curved areas.

The effects of smoothing can be dramatic. G-code file size may be reduced by as much as 50% or more. The machine will run faster and more smoothly and surface finish improves. The amount of code reduction depends on how well the toolpath lends itself to smoothing. Toolpaths that lay primarily in a major plane (XY, XZ, YZ), like parallel paths, filter well. Those that do not, such as 3D Scallop, are reduced less.

Smoothing Tolerance

Specifies the smoothing tolerance.

Smoothing works best when the tolerance (the accuracy with which the original linearized path is generated) is equal to or greater than the Smoothing (line arc fitting) tolerance.

NOTE: Total tolerance, or the distance the toolpath can stray from the ideal spline or surface shape, is the sum of the cut Tolerance and Smoothing Tolerance. For example, setting a cut Tolerance of .0004 in. and Smoothing Tolerance of .0004 in. means the toolpath can vary from the original spline or surface by as much as .0008 in. from the ideal path.

Maximum Directional Change

Specifies the maximum angular change allowed before the feedrate is reduced.

Reduced Feed Radius

Specifies the minimum radius allowed before the feed is reduced.

Reduced Feed Distance

Specifies the distance to reduce the feed before a corner.

Reduced Feed

Specifies a slower feedrate to be used when the tool is moving in the X direction while cutting material.

Only Inner Corners

Only reduce the feedrate on inner corners.

Incremental Depth

The depth of cut per pass.

Pitch

Specifies the distance per 360° step as the tool feeds to depth.
For straight walls this value is generally larger, than with tapered walls.
A finer Pitch on a Tapered wall creates a smoother surface finish.

Depth Per. Revolution

Pitch Diameter Offset

Creates a positive or negative diameter offset from the selected geometry.

Pitch Diameter Offset

The difference between the Major and Minor thread diameters.

The difference between the Major "D" and the Minor "d" diameters.
This is the thread depth and the value is always positive.

NOTE: Required if the hole is drawn to the Minor size,
or if the Boss/Cylinder is drawn to the Major size.

Chip Break Distance

With a chip breaking operation, the drill withdraws a specified distance after advancing into the hole to prevent the binding of chips.

Back Boring Distance

Manually enter the length of the undercut bore. This will determine the distance the boring bar moves up from the bottom of the selected hole, before shifting back by the Boring Shift value to retract out of the hole.

Consider the "flute length" of your boring bar when setting this value

Diameter

Because this toolpath will output a cycle at the selected hole center point coordinates, it ignores the diameter of the selected hole. Instead you must manually enter the diameter of the hole you would like to machine with your tool. The benefit of this approach, if your post processor & CNC controller supports it, is the machine operator can change the diameter variable in the canned cycle at the machine control.

Dwelling Period

Dwelling time in seconds.

Specifying a dwell time halts all axis movement for a specified time while the spindle continues revolving at the specified rpm. This can be used to ensure that chips are cleared before retracting from a hole, and will typically improve the finish of a hole.

Typically a dwelling time between 1/4 second and 1 second is sufficient.

Example: To dwell for 1/4 second, specify 0.25 or 1/4 in this field.

When post processing a drill cycle, the dwell time is specified as one of the drill cycle parameters (typically P), and in most cases it is output in milliseconds (ms).

250ms dwell time in G82

When posting using expanded cycles, the dwell time is output as a regular dwell command (G4).

To calculate the minimum dwell time that will ensure at least one complete revolution, use a value of 60 divided by the spindle speed.

Example: At 350 RPM the minimum dwell time should be 60 / 350 = 0.171s which could be rounded to 0.2s.

Notice: If the operator is running the program with a speed override, then the spindle speed is slower, but the dwell time is constant. To ensure one complete revolution when using a speed override of eg. 50%, the dwell time must be doubled.

Cycle Type

Selecting the type of drilling cycle changes which parameters can be used for the drilling operation. Shown with the common industry G-Code.

  • Drilling: Feed to Depth & Rapid Out - For holes with depths of less than 3x the tool diameter. (G81)
  • Counterboring: Feed to Depth, Dwell, Rapid Out - A dwell is used to improve the bottom finish of a hole. (G82)
  • Chip breaking: Uses multiple pecks that periodically retracting the tool to break the chips and/or allow coolant to enter the hole. For holes with depths more than three times the tool diameter. (G73)
  • Deep drilling: Similar to Chip breaking, but retracts completely out of the hole to clear chips and/or flood the hole with coolant. Also known as Peck drilling. (G83)
  • Break through: Allows for reduced feed and speed before breaking through a hole.
  • Guided deep drilling: A gun drill has a single cutting edge. Guide pads burnish the hole to produces a straight, deep hole with a precision diameter.
  • Tapping: Taps right or left handed threads depending on the selected tool.
  • Left tapping: Feed to Depth, Reverse the spindle, Feed Out - Rotates counterclockwise as it enters the hole to cut a thread. (G74)
  • Right tapping: Feed to Depth, Reverse the spindle, Feed Out - Rotates clockwise as it enters the hole to cut a thread. (G84)
  • Tapping with chip breaking: Feeds in and out multiple times, going deeper each time, until it reaches the final depth.
  • Reaming: Feed to Depth and immediately Feed Out upon reaching the final depth. (G85)
  • Boring: Feed to Depth, Dwell, Feed Out. (G86)
  • Stop boring: Feed to Depth, Stop the spindle, Rapid Out. (G87)
  • Fine boring: Feed to Depth, Stop the spindle, Shift from the wall, Rapid Out. (G76)
  • Back-boring: Boring from the back of an existing hole. (G77)
  • Circular pocket milling: This can be used to call a custom cycle for circular pocketing.
  • Bore milling: This can be used to call a custom cycle for helical bore milling.
  • Thread milling: This can be used to call a custom cycle for helical thread milling.
  • Probe: Used to call a probe tool macro from the machine. Requires a custom post processors. See the advanced Probing function, under the Setup pull down.

Pecking Depth

Sets the depth for the first peck move, which plunges in and out of the material to clear and break chips.

Pecking Depth Reduction

The amount by which the pecking depth is reduced per peck.

Minimum Pecking Depth

The minimum allowed pecking depth.

Accumulated Pecking Depth

Specifies the pecking depth which forces a full retract.

Break Through Distance

The starting distance above the bottom to switch to the break through feeds & speed.

Break Through Feedrate

Feedrate used during break through.

Break Through Spindle Speed

Spindle speed used during break through.

Starting Depth

This value is relative to the top of the selected hole (including any merged segments). The normal programmed feeds & speeds will commence from this position.

Positioning Feedrate

This feedrate is used from the Feed Height until the drill reaches the specified Starting Depth. At which point the feedrate specified on the Tool tab will commence.

Stop Spindle

Enabling this stops the spindle during positioning. The spindle is then started once the tool reaches the Starting Depth.

Note: You may need your post processor to be modified for this to work correctly for your machine.

Positioning Spindle Speed

This spindle speed is used until the drill reaches the specified Starting Depth. At which point the spindle speed specified on the Tool tab will commence.

Dwell Depth

Direction

This setting determines the side of the toolpath from which the tool center is offset. Choose between Left (climb milling) sideways compensation or Right (conventional milling) sideways compensation.

Climb Milling | Conventional Milling

Climb Vs. Conventional Milling

Climb milling can be thought of as the cutter rolling along the surface that it is cutting. This generally gives a better finish in most metals, but requires good machine rigidity. Using this method, chips start at maximum thickness and get thinner towards the end of the cut, meaning more heat in the chip and less in the part.

With conventional milling, the cutter is rotating away from the surface it is cutting. This method is more commonly used with manual or less rigid machines. It does have some advantages, and can even give a better finish when machining certain materials including some woods.

Repeat Pass

This setting has no impact on your toolpath,
unless it is supported by a canned cycle in your post processor.

Use Multiple Steps

Specifies that multiple radial stepovers should be taken.

Without Use multiple steps | With Use multiple steps

Number Of Steps

Specifies the number of radial steps.

3 Radial Steps

Stepover

The radial distance between each step over.

Tolerance

The tolerance used when linearizing geometry such as splines and ellipses. The tolerance is taken as the maximum chord distance.

Loose Tolerance .100 | Tight Tolerance .001

CNC machine contouring motion is controlled using line G1 and arc G2 G3 commands. To accommodate this, CAM approximates spline and surface toolpaths by linearizing them; creating many short line segments to approximate the desired shape. How accurately the toolpath matches the desired shape depends largely on the number of lines used. More lines result in a toolpath that more closely approximates the nominal shape of the spline or surface.

Data Starving

It is tempting to always use very tight tolerances, but there are trade-offs including longer toolpath calculation times, large G-code files, and very short line moves. The first two are not much of a problem because the program calculates very quickly and most modern controls have at least 1MB of RAM. However, short line moves, coupled with high feedrates, may result in a phenomenon known as data starving.

Data starving occurs when the control becomes so overwhelmed with data that it cannot keep up. CNC controls can only process a finite number of lines of code (blocks) per second. That can be as few as 40 blocks/second on older machines and 1,000 blocks/second or more on a newer machine like the Haas Automation control. Short line moves and high feedrates can force the processing rate beyond what the control can handle. When that happens, the machine must pause after each move and wait for the next servo command from the control.

Direction

In conjunction with the turning mode, this setting determines the tool direction when cutting.

Front to Back | Back to Front | Both Ways

Front to Back - Select this option to cut from the front side of the stock towards the back side, i.e. towards the main chuck.

Back to Front - Cuts from the back side, toward the front side. Away from the chuck. For tools with special geometry where chip thinning control is important. See the Use Back Cutting option shown on the Passes tab.

Both Ways - This option allows the tool to cut in both directions. The result is a back and forth cutting motion. Ensure that you are using an appropriate tool that can cut in both directions when selecting this option.

Chamfer Width

The distance across the chamfer flat.

The amount to break the selected edge. Shown below in the center illustration.

Chamfer Extension - Chamfer Width - Chamfer Angle

Chamfer Extension

The distance to extend the tool past the chamfer.

Provides additional clearance past the chamfer edge. Shown below in the left illustration.

Chamfer Extension - Chamfer Width - Chamfer Angle

Chamfer Angle

The angle of the chamfered face.

The angle is referenced from the Z axis. Shown below in the right illustration.

Chamfer Extension - Chamfer Width - Chamfer Angle

Pass Direction

Specifies the direction of the turning passes.

Pass Direction @ 0 degrees | Pass Direction @ 30 degrees

Grooving

Use this to allow or restrict undercut toolpath motion. Can be used to keep the tool from dipping into channels along the diameter, face or end of the part.

'''Don't allow grooving''' | Allow Radial grooving
Allow Axial grooving | Allow Radial and Axial Grooving

Note - Tool geometry will determine the effectiveness of clearing an area.

Back Cutting

For tools with special geometry where chip thinning control is important. This activates additional controls to set the Back Cutting Radius blend and Back Cutting Exit Distance. Only available when the cutting mode direction is set from Back to Front.

C = Cut direction - Away from the Chuck
R = Radius for Back Cutting entry
D = Distance for feed reduction

Starting the toolpath closest to the chuck side, the Radius blends onto the cut and feeds in the positive direction. At a distance before the end of the cut, the feedrate is reduced to prevent chipping of the part or the tool.

Back Cutting Radius

This radius is used for the initial blend onto the cut. Consult your tooling supplier for their recommendation on the best blend size. Generally a size equal to, or larger than the Maximum Roughing Stepdown will work as a starting point.

R = Radius for Back Cutting entry

Back Cutting Exit Distance

Specifies the distance before the end of the cut to slow down the feedrate.

D = Distance before the end of the cut

Reducing the feedrate before the end of the cut helps to prevent chipping of the part or the tool. This uses the Lead-Out Feedrate shown on the Tools Tab. Consult your tooling supplier for their recommendation on the best distance and feedrate to use

Maximum Roughing Stepdown

Controls the aggressiveness of the roughing cuts. By increasing the value, the cutter removes more material with each roughing pass.

Comparison between smaller (left) and larger (right) Maximum Roughing Stepdown values.

Roughing Overlap

Specifies at the end of a roughing pass how far the tool should move past the previous pass before it begins any lead-out or retract.

Roughing Overlap at 0mm | Roughing Overlap set at 5mm

Finishing Passes

Enable this option to perform the specified number of finishing passes.

Finishing Passes disabled | Finishing Passes enabled

Finishing Passes

Enable this option to perform the specified number of finishing passes.

Finishing Passes disabled | Finishing Passes enabled

Finishing Passes

This option is only available when Roughing Passes is enabled. The images below also have Roughing Clearing Pass enabled, creating the impression that there are two finishing passes. Tip: Using this technique can remove the requirement of a secondary finishing operation.

Finishing Passes disabled | 0.75mm Finishing Pass

Allow Grooving

Allows the tool to move towards the center of the stock in narrow areas. If disabled, the tool can only begin cuts on the front open face of the stock. When enabled, the tool can plunge into the stock in narrow areas to create grooves.

Allow Grooving disabled | Allow Grooving enabled

Up/Down Direction

Options that control the direction of the finishing passes.

Up and Down | Only Down | Only Up

Notice how the Only Down and Only Up options result in a discontinuous finish pass; with the tool either exiting or entering the finish pass from the center of the groove.

Pass Overlap

Specifies the overlap distance used for finish passes split due to Only Up and Only Down machining directions.

Pass Overlap at 0mm | Pass Overlap set at 3mm

Lead Mode

The lead mode settings provide very specific control of the leads. There are five options available.

Fail - Results in a failure if it is not possible to do the lead in/outs without causing a gouge. User intervention is then required to make the leads fit.

Discard passes - Discards any passes that cannot be reached with the given settings. This option leaves rest material for any following operations.

Move lead - Moves the lead position to a different location along the part until there is room, but keeps the lead as specified.

Turn lead - Changes the lead angle until there is room.

Retract lead - Is the most automatic lead mode and also the default setting. It allows linking of all parts and, in some cases, does radial retracts when there is no other alternative. This is the recommended setting.

Maximum Grooving Stepover

Specifies the maximum grooving stepover. The final stepover is less than this value to account for the radius on the tools insert, ensuring that no cusp is left on the surface. In the image below, the Maximum Grooving Stepover value is set to 10mm so the axial distance between passes will always be as close to 10mm as possible.

Maximum Grooving Stepover set at 10mm

Backoff Distance

Specifies the distance to back off from the stock before retracting.

Grooving Pattern

Specifies the strategy used to create the groove toolpath. The geometry you are turning, the material from which your part is made, and the type of grooving insert and holder you want to use determines which option is best to use.

Full Stepdown | Partial Stepdown | Sideways With Partial Stepdown

Full Stepdown - Removes all the material radially, before moving along the spindle axis to remove the next amount. The amount the tool steps over each time is controlled by the Maximum Grooving Stepover value.

Partial Stepdown - Removes all the material along the spindle axis before starting to remove the material at the next depth specified by the Maximum Groove Stepdown value.

Sideways With Partial Stepdown - In some materials it is better to groove from side to side since it results in smaller chips and increased tool life. For example, if the groove is wider than it is deep, using this option can result in faster overall material removal rate than the Full Stepdown or Partial Stepdown options. Tip: In a case like this, use the Both Ways option in the Direction drop-down menu on the Tool tab, as shown in the above image.

Use Pecking

Pecking forces the tool to cut into the material by the specified Pecking depth distance, gradually progressing down to the finished depth required. The tool then retracts along its path by the specified Pecking retract distance.

Use Pecking disabled | 3mm Pecking Depth

Tip: You can easily see the points where the tool is pecking and retracting, by enabling Show points in the Toolpath group while in Simulation.

Use Pecking

Pecking creates multiple steps across the length of the cutting direction. Between Pecking Depths the tool retracts along its path by the specified Pecking retract distance. Use this if your material creates long strings of chips.

Use Pecking disabled. Single cut along the path. | 18 mm Pecking Depth. 3 mm Retract between Pecks.

Tip: To see the points where the tool is pecking and retracting. Go to Simulation and under the Show Toolpath group, enable the Show points icon.

Use Pecking

Pecking creates multiple steps across the length of the cutting direction. Between Pecking Depths the tool retracts along its path by the specified Pecking retract distance. Use this if your material creates long strings of chips or to improve coolant flow to the tool tip.

Use Pecking disabled. Single cut along the path. | 8 mm Pecking Depth. 3 mm Retract between Pecks.

Tip: To see the points where the tool is pecking and retracting. Go to Simulation and under the Show Toolpath group, enable the Show points icon.

Pecking Depth

Specifies the maximum distance the tool cuts into the material before retracting to clear or break the chips. The red arrows in the image show where the tool is cutting down in increments equal to, or less than this value.

Pecking Depth

Peck Depth

Specifies the step distance per Peck along the length of the cutting direction. The distance to feed along the cut, between retracts.

Red arrows indicate Peck Depth segment

Tip: To see the points where the tool is pecking and retracting. Go to Simulation and under the Show Toolpath group, enable the Show points icon.

Peck Depth

Specifies the step distance per Peck along the length of the cutting direction. The distance to feed along the cut, between retracts.

Red arrows indicate Peck Depth segment

Tip: To see the points where the tool is pecking and retracting. Go to Simulation and under the Show Toolpath group, enable the Show points icon.

Pecking Retract

Specifies the distance the tool retracts from its pecking depth to clear or break the chips. The green arrow in the image shows where the tool is pulling out inbetween each peck.

Pecking Retract

Note: The tool retracts using the cutting feedrate.

Peck Retract

Specifies the Retract distance between Pecks along the cutting direction.

Red arrows indicate Peck Retract segment

Tip: To see the points where the tool is pecking and retracting. Go to Simulation and under the Show Toolpath group, enable the Show points icon.

Peck Retract

Specifies the Retract distance between Pecks along the cutting direction.

Red arrows indicate Peck Retract segment

Tip: To see the points where the tool is pecking and retracting. Go to Simulation and under the Show Toolpath group, enable the Show points icon.

Dwell Before Retract

Enables dwelling before pecking retracts to thin out chips. This can increase tool lift significantly depending on the material being machined.

Use Reduced Feedrate

Enable to reduce the feedrate when grooving along the X axis. Finish passes are still carried out using the original feedrate specified on the Tool tab.

The highlighted blue elements of the toolpath use the
reduced rate specified in the Reduced Feed field.

Transfer Stock

Specifies that the stock should be clamped for use on the other spindle.

Thread Depth

Specifies the thread depth.

Thread Depth = T

Shown as T in the illustration, it's the difference between the Major D and Minor d diameters.

Thread Pitch

Specifies the thread pitch.

Thread Pitch = P

Shown as P in the illustration, it's the distance traversed for 1 complete thread. 1/Threads Per Inch (TPI) or or the actual pitch for metric threads.

Do Multiple Threads

Enable to enter the number of threads.

Number Of Threads

Specifies the number of threads.

Multiple Finishing Passes

Enable to specify more than one finishing pass. If Finishing Passes is enabled, but Multiple Finishing Passes is disabled, then only one finishing pass is performed.

Multiple Finishing Passes ON | Multiple Finishing Passes OFF

Roughing Passes

Enabling roughing passes provides you with the ability to fine tune your grooving toolpath. Options such as grooving stepover, pecking, and additional finishing controls become available; as well as additional settings within the Roughing Passes group.

Roughing Passes disabled | Roughing Passes enabled with a 1mm Maximum Grooving Stepover

Note: With Roughing Passes disabled, the stepover for both Full & Partial Stepdown is automatically calculated based on the groove width value of the insert.

Roughing Passes

Enabling roughing passes provides you with the ability to fine tune your grooving toolpath. Options such as grooving stepover, pecking, and additional finishing controls become available; as well as additional settings within the Roughing Passes group.

Roughing Passes disabled | Roughing Passes enabled with a 1mm Maximum Grooving Stepover

Note: With Roughing Passes disabled, the stepover for both Full & Partial Stepdown is automatically calculated based on the groove width value of the insert.

Stepover

This distance determines the amount of material initial toolpaths leave for the first finishing pass and for any subsequent finishing stepovers.

0.5mm Stepover | 2mm Stepover

Stepover

This distance determines the amount of material initial toolpaths leave for the first finishing pass and for any subsequent finishing stepovers.

Two 0.75mm Stepovers

Number Of Stepovers

Controls the number of finishing stepovers to apply. If Roughing Clearing Pass is enabled in the Roughing Passes group, it can appear as though more stepovers have been applied than specified.

Two Stepovers | Two Stepovers + Roughing Clearing Pass

Infeed Mode

The infeed is the depth of cut per pass and is critical in threading. Each successive pass engages a larger portion of the cutting edge of the insert. There are three infeed mode options.

Constant infeed - With this option, the cutting force and metal removal rate can increase dramatically from one pass to the next. Example - When producing a 60 degree thread form using a constant 0.010 inch infeed per pass, the second pass removes three times the amount of metal as the first pass. The amount of metal removed continues to grow exponentially with each subsequent pass.

Reduced infeed - This option maintains more realistic cutting forces and reduces the depth of cut with each pass. Because it avoids the increased metal removal rate of constant infeed, it is the recommended setting.

Alternate infeed - Similar to the Reduced infeed, but this method alternates between feeding in from the left and right sides of the thread profile.

Constant Equal Plunges | Reduced Set To 29.5 Degrees
Alternating side feed | Alternating side feed

Infeed Angle

Specifies the infeed angle of the tool. Sometimes set to half of the included thread angle
of the insert, minus .5 degrees for clearance. Example: (60 deg. / 2) -.5 = 29.5

Infeed Set To 0 Degrees | Infeed Set To 29.5 Degrees

Feeding in on the angle reduces the load on the front edge of the tool.

Fade Thread End

Enable this setting to fade out the thread at the end.

Spring Pass

Enable to perform the final finishing pass twice to remove stock left due to tool deflection.

Use Cycle

Enable to request output as canned cycle.

Eject Stock

Specifies the amount of stock to eject from the current chuck.

Stock To Leave

Positive | None | Negative

Positive Stock Value - The amount of stock left for subsequent roughing or finishing operations.

No Stock to Leave - Remove all material up to the selected geometry or part model. This is the default.

Negative Stock Value - Removes material beyond the selected geometry or part model.

Radial Stock To Leave

Controls the amount of material to leave in the radial direction.
Used for leaving stock on the ID or OD of the part.

Radial Stock 1mm | Radial Stock 1mm

Radial Stock 0.0

Radial and Axial Stock -1mm

For surfaces that are not exactly horizontal, the program interpolates between the Axial Stock value (wall) and the Radial Stock values. The stock left in the radial direction on these surfaces might be different from the specified value, depending on surface slope and the axial stock to leave value.

Changing the Radial Stock to Leave value automatically sets the Axial Stock to Leave to the same amount. You can manually enter a different Axial Stock value.

If you plan on roughing and finishing with different tools, set the rough operation to the amount of stock to leave for the next finishing operation.

Negative Stock to Leave You may use a negative value. This will cause the tool to machine material beyond the edge of your model shape.

NOTE: - Maximum negative stock to leave must be less than the tool nose radius.
With an insert nose radius of .032, the largest negative stock would be -.032
You can not compensate past the theoretical tip of the tool.

Axial Stock To Leave

Controls the amount of material to leave on the vertical faces being turned.

Axial Stock 1mm | Axial Stock 1mm

Axial Stock 0.0

Radial and Axial Stock -1mm

For surfaces that are not exactly vertical, the program interpolates between the Axial Stock value (wall) and the Radial Stock values. The stock left in the axial direction on these surfaces might be different from the specified value, depending on surface slope and the radial stock to leave value.

Changing the Radial Stock to Leave value automatically sets the Axial Stock to Leave to the same amount. You can manually enter a different Axial Stock value.

If you plan on roughing and finishing with different tools, set the rough operation to the amount of stock to leave for the next finishing operation.

Negative Stock to Leave You may use a negative value. This will cause the tool to machine material beyond the edge of your model shape.

NOTE: - Maximum negative stock to leave must be less than the tool nose radius.
With an insert nose radius of .032, the largest negative stock would be -.032
You can not compensate past the theoretical tip of the tool.

Retraction Policy

Controls how the tool moves between cutting passes.

Full Retraction | Minimum Retraction | Shortest Path

Illustrated with Flow

Full retraction - Completely retracts the tool to the Retract Height at the end of the pass before moving above the start of the next pass.

Minimum retraction - Moves straight up to the lowest height where the tool clears the workpiece, plus any specified safe distance.

Shortest path - Moves the tool the shortest possible distance in a straight line between paths.

WARNING: Shortest path should not be used on machines that do not support linearized rapid movements where G0 moves are straight-line (versus G0 moves that drive all axes at maximum speed, sometimes referred to as "dogleg" moves). Failure to obey this rule will result in machine motion that cannot be properly simulated by the software, and may result in tool crashes.

For CNC machines that do not support linearized rapid moves, the post processor can be modified to convert all G0 moves to high-feed G1 moves. Contact technical support for more information or instructions on how to modify post processors as described.

Transition Type

Specifies the type of connection done between passes.

  • No contact - Sidesteps are not connected with each other on the same Z-level, but connected with a retract move.
  • Straight line - Simpler, direct connections using straight lines.
  • Shortest path - The shortest possible path between machining areas - typically a move in a straight line.
  • Smooth - Use smooth tangential movements using true arcs where appropriate.

Safe Distance

Minimum distance between the tool and the part surfaces during retract moves.

The distance is measured after stock to leave has been applied, so if a negative stock to leave is used, special care should be taken to ensure that safe distance is large enough to prevent any collisions.

High Feedrate Mode

Specifies when rapid movements should be output as true rapids (G0) and when they should be output as high feedrate movements (G1).

  • Preserve rapid movement - All rapid movements are preserved.
  • Preserve axial and radial rapid movement - Rapid movements moving only horizontally (radial) or vertically (axial) are output as true rapids.
  • Preserve axial rapid movement - Only rapid movements moving vertically.
  • Preserve radial rapid movement - Only rapid movements moving horizontally.
  • Preserve single axis rapid movement - Only rapid movements moving in one axis (X, Y or Z).
  • Always use high feed - Outputs rapid movements as (high feed moves) G01 moves instead of rapid movements (G0).

This parameter is usually set to avoid collisions at rapids on machines which perform "dogleg" movements at rapid.

High Feedrate

The feedrate to use for rapids movements output as G1 instead of G0.

Allow Rapid Retract

When enabled, retracts are done as rapid movements (G0). Disable to force retracts at lead-out feedrate.

Keep Tool Down

When enabled, the strategy avoids retracting when the distance to the next area is below the specified stay-down distance.

Maximum Stay-Down Distance

Specifies the maximum distance that is allowed for stay-down moves.

1" Maximum stay-down distance | 2" Maximum stay-down distance

Illustrated with 2D Adaptive Clearing

NOTE: Regardless of the stay-down distance, the tool retracts between passes if the rapid motion violates the workpiece.

Both Ways

When enabled, passes are done in both directions. Disable to force climb-only machining.

Lift Height

Specifies the lift distance during repositioning moves.

Lift Height 0 | Lift Height .1 in

No-Engagement Feedrate

Specifies the feedrate used for movements where the tool is not in engagement on the material, but is also not retracted.

Remove Spikes

Enable to remove spikes in the toolpath.

Maximum Spike Angle

Specifies the angle of the passes which triggers a spike.

Linear Lead-In Angle

Specifies the lead-in direction.

Lead-In Extension

Specifies the lead-in extension.

Linear Lead-Out Angle

Specifies the lead-out direction.

Lead-Out Extension

Specifies the lead-out extension.

Lead-In (Entry)

Enable to generate a lead-in.

Lead-In

Horizontal Lead-In Radius

Specifies the radius for horizontal lead-in moves.

Horizontal Lead-In Radius

Linear Lead Length

Specifies the length of the linear leads.

Lead-In Sweep Angle

Specifies the sweep of the lead-in arc.

Sweep Angle @ 90 degrees | Sweep Angle @ 45 degrees

Linear Lead-In Length

Specifies the length of the linear lead-in move for which to activate radius compensation in the controller.

Linear Lead-In Length

Perpendicular

Replaces tangential extensions of lead-in/lead-out arcs with a move perpendicular to the arc.

Shown with Perpendicular Entry/Exit

Example A bore that has lead arcs that are as large as possible (the larger the arc the less chance of dwell mark), and where a tangent linear lead is not possible because it would extend into the side of the bore.

Vertical Lead-In Radius

The radius of the vertical arc smoothing the entry move as it goes from the entry move to the toolpath itself.

Vertical Lead-In Radius

Lead-Out (Exit)

Enable to generate a lead-out.

Lead-Out

Same As Lead-In

If checked, the lead-out values be identical to the lead-in values.

Horizontal Lead-Out Radius

Specifies the radius for horizontal lead-out moves.

Horizontal Lead-Out Radius

Lead-Out Sweep Angle

Specifies the sweep of the lead-out arc.

Sweep Angle @ 90 degrees | Sweep Angle @ 45 degrees

Linear Lead-Out Distance

Specifies the length of the linear Lead-Out move for which to deactivate radius compensation in the controller.

Linear Lead-Out Distance

Perpendicular

Replaces tangential extensions of lead-in/lead-out arcs with a move perpendicular to the arc.

Shown with Perpendicular entry/exit

Example A bore that has lead arcs that are as large as possible (the larger the arc the less chance of dwell mark), and where a tangent linear lead is not possible because it would extend into the side of the bore.

Vertical Lead-Out Radius

Specifies the radius of the vertical lead-out.

Vertical Lead-Out Radius

Lead End Distance

Specifies the distance the leadout feed rate begins before the end of the selected geometry.

@ 0 in | @ .5 in

NOTE: This option is used when you desire to change the feedrate prior to breaking through at the end of the cut.

Lead To Center

Specifies that the lead in/out movement should be into the center of the geometry.

Ramp

Enable ramps.

Shown with a 15 degree Ramp angle

Ramp Type

Specfies how the cutter moves down for each depth cut.

Plunge Outside Stock

Predrill | Plunge

To use the Predrill option, Predrill location(s) must be defined.

Zig-Zag | Profile

Notice the smooth transitions on the Zig-Zag ramp type.

Smooth Profile | Helix

Ramping Angle (deg)

Controls the angle of the helix that leads into the cavity.

Shown with 2 Deg. Ramp

Ramp Taper Angle (deg)

Creates a cone shape entry cavity, to reduce tool load. Specified as an included angle.

Controls the starting and ending diameter of the helix that leads into the cavity.

Shown with 12 Deg. Taper

Maximum Angle (deg)

Specifies the maximum plunge angle for the passes.

Maximum Ramp Stepdown

Specifies the maximum stepdown per revolution on the ramping profile. This parameter allows the tool load to be constrained when doing full-width cuts during ramping.

Ramp Clearance Height

Clearance above the Top Height, where the Helix Ramp will start.

Clearance to start the Helix

Helical Ramp Diameter

The maximum diameter to use for a helical entry into the cavity.

An optimal value causes the tool to overlap it's center, while still creating the maximum helical bore for the entry into the cavity. The goal is for good chip evacuation. If the value is bigger than the diameter of the tool it can leave a boss standing in the center of the helix.

Value of 1.8 x the Dia. | Value of 0.8 x the Dia.

The system will determine the best location for the entry helix, unless and Entry Position is selected. (Entry Positions shown below). The complete area will always be cleared, regardless of the diameter. Note: The area width should be Tool Dia + Ramp Dia + Stock, or the helical entry will fail.

Minimum Ramp Diameter

The smallest Helix Ramp Diameter that is acceptable.

This value should always be smaller than the Helix Ramp Diameter, so the system can calculate a range that fits the available pocket or channel. Smaller diameters can reduce the chip evacuation, create jerking machine motion and can cause tool breakage.

Helical Ramp 0.100in - Min. Ramp 0.060in

Force Profile Ramp

Enable this to force a profile ramp on top of the selected contour(s).

Use this when cutting out holes, for example.

Trim Passes

Enable this to allow the passes to be trimmed back to fit the leads, where otherwise not possible, to allow the CNC machining to maintain a high feed. If disabled, forces the entire pass to be machined. This can result in sharp moves and the minimum corner radius may not be respected.

Manual Ramp Diameter

If checked, the minimum ramp diameter can be set.

Contact Ramp Angle

The maximum angle of contact ramps.

Smooth Contact Ramp

Specifies that the contact ramp should be smooth.

Ramp Radial Clearance

Specifies the minimum distance to the contour for the lead-in helix.

Set Minimum Profile Diameter

This allows a minimum profile diameter to be set. If a machining area is smaller than the specified minimum profile diameter, then it is not machined.

Minimum Profile Diameter

Specifies the minimum cavity to be cut.

Allow Plunging Outside Stock

Instead of machining the material inside the contour of a selected area, enabling this parameter allows you to remove the material outside the selected contour by picking an additional stock contour.

Disable this parameter to force ramping in stock.

Predrill Positions

Select points where holes have been drilled to provide clearance for the cutter to enter the material.

Entry Positions

Select geometry near the location where you want the tool to enter.

Retraction Policy

Controls whether the tool should retract to the clearance diameter after every cutting pass, or just retract a short distance away from the job. The distance is determined by the Safe Distance value.

Full Retraction | Minimum Retraction

Linear Lead-In Angle

Specifies the angle of the lead-in move at the start of a cutting pass. Note that the angle reference depends on the Use fixed lead direction setting.

Lead-In Angle @ 0 degrees | Lead-In Angle @ 45 degrees

Lead-In Extension

Specifies the lead-in extension value which has the effect of leading in before the point at which the cutting movement starts by the specified distance.

Lead-In Extension set to 0mm | Lead-In Extension set to 1mm

Linear Lead-Out Angle

Specifies the angle of the lead-out move at the end of a cutting pass. Note that the angle reference depends on the Use fixed lead direction setting.

Lead-Out Angle @ 45 degrees | Lead-Out Angle @ 90 degrees

Lead-Out Extension

This setting has the effect of delaying the point at which the cutter begins to lead out by the specified distance.

Lead-Out Extension set to 0mm | Lead-Out Extension set to 1mm

Lead-In (Entry)

Controls how the tool enters the cutting path. The radius, distance, and angle can be specified.

Lead-In

Lead-Out (Exit)

Controls how the tool exits the cutting path. The radius, distance, and angle can be specified.

Lead-Out

Lead-In Radius

Specifies the radius of the lead-in move at the start of a cutting pass.

Lead-In Radius @ 0mm | Lead-In Radius @ 3mm

Lead-Out Radius

Specifies the radius of the lead-out move at the end of a cutting pass.

Lead-Out Radius @ 0mm | Lead-Out Radius @ 3mm

Horizontal Lead-In/Out Radius

Creates an arc in the XY cutting plane for blending onto the part. The radius for horizontal lead moves.

Horizontal Lead Radius

Vertical Lead-In/Out Radius

Creates an arc in the vertical plane for blending down onto the part. The radius for vertical lead moves.

Vertical Lead-In/Out Radius

Linear Lead-In Length

Specifies the distance (length) of the lead-in move at the start of a cutting pass.

Linear Lead-In Length set to 0mm | Linear Lead-In Length set to 2mm

Linear Lead-Out Distance

Specifies the distance (length) of the lead-out move at the end of a cutting pass.

Linear Lead-Out Distance set to 1 mm | Linear Lead-Out Distance set to 5 mm

Use Helical Leads

Enable to use helical lead in/out movements instead of circular lead in/out movements.

Use Fixed Lead Direction

Specifies that the given lead directions are always relative to the XZ coordinate system. When disabled, the leads are relative to the front/back cutting direction of the individual pass.

Operation Type

Specifies the machining method.

Milling
All types of Milling machines.

Turning
2x Lathes, Lathes with mill/turn configurations.

Program Name/Number

Specifies the program name or number. This parameter is made available to the post processor.

Program Comment

Specifies the program comment. This parameter is made available to the post processor.

Use External Model

Model

Use this to specify the models/solids that are considered for the toolpath calculation.

Model Unit

Scale

Specifies the scale of the model.

Stock Mode

Specifies the size and shape of the stock.

Fixed Size Box - Creates a rectangular stock body of a specific (fixed) size. Relative Size Box - Creates a rectangular stock body larger than the model by a given set of values. Can be rounded up to the nearest specified increment. | Fixed Size Cylinder - Creates a cylindrical stock body of a specific (fixed) size. Relative Size Cylinder - Creates a cylindrical stock body larger than the model by a given set ofvalues. Can be rounded up to the nearest specified increment.
Fixed Size Tube - Creates a tube stock body of a specific (fixed) size. Relative Size Tube - Creates a tube stock body larger than the model by a given set of values. Can be rounded up to the nearest specified increment. | From Solid - Creates a stock by selecting a solid body in a multi-body part or from a part file in an assembly.

Stock Bottom Offset

Stock Width

Stock Depth

Stock Height

Stock Solid

Stock Sketch

Stock Offset

Specifies the distance to offset the stock contour outwards.

Stock Offset

Stock Height

Backside Stock Offset

Specifies the distance to machine beyond the backside of the model.

Frontside Stock Offset

Specifies the distance to machine beyond the frontside of the model.

Fixture

Select the geometry in the model that represents the fixture components.

Stock In Chuck

Specifies the amount of stock in the chuck.

Stock In Chuck Shifted Distance

Reverse Direction

Specifies which direction of the extrusion from sketch to be reversed.

Stock offset mode

Specifies how stock is added to the model.

Stock Offset Mode

No additional stock | Add stock to sides and top-bottom | Add stock to all sides

No additional stock - No offset values are added to the stock size.

Add stock to sides and top-bottom - Symmetrical stock offset for all sides. Unique values for top and bottom offsets.

Add stock to all sides - Unique values for all offset directions.

Stock side offset

Specifies the additional stock on the sides.

Stock top offset

Specifies the additional stock on the top.

Stock bottom offset

Specifies the additional stock on the bottom.

Stock +X offset

Specifies the offset of the stock.

Stock -X offset

Specifies the offset of the stock.

Stock +Y offset

Specifies the offset of the stock.

Stock -Y offset

Specifies the offset of the stock.

Stock +Z offset

Specifies the offset of the stock.

Stock -Z offset

Specifies the offset of the stock.

Use Stock Radius

Specifies the radius of cylindrical stock instead of using an offset value.

This option is helpful when working with bar stock that is ordered at a given diameter or radius.

Stock radius

Specifies the radius of the stock.

Radial stock offset

Specifies the radial offset of the stock.

Continue Machining From Previous Setup

Stock in Chuck

Specifies the amount of stock in the chuck.

Chuck Model

Clamp From inside

WCS Origin

Specifies the location of the Work Coordinate System (datum) for the job relative to the stock.

WCS Origin Selection

The orientation of the WCS above is defined with the WCS orientation selection box.

Home Position

Specifies the home position along the Z axis.

Spindle

Specifies the spindle to use.

Primary spindle

Secondary spindle

Work Offset

Identifies the desired workpiece coordinate system (WCS) for the setup. It is the responsibility of the post processor configuration to map this number to the actual WCS on the machine.

WCS Offset Increment

Specifies the work offset increment used for workpiece duplication.

Multiple WCS Offsets

Enable to specify that the workpiece is to be duplicated.

Work duplicates

Specifies the number of workpiece duplicates. This is the total number of instances.

Operation Order

Specifies the ordering of the individual operations.

Preserve order - Specifies that features are machined in the order in which they were selected.

Order by operation - Specifies the ordering of the individual operations.

Order by tool - Specifies the ordering of operations by tool. For example, all operations that use a 3/4" diameter flat mill are machined first. Then the next set of operations that use another identical tool, a 1/4" diameter flat mill for example, are machined next.

Fast 3D Mode

The fastest simulation mode. Simulation is done to a limited resolution controlled by the quality slider. This mode is only available when simulating 3-axis milling operations in the same tool orientation. Undercutting cannot be simulated for this mode.

Solid Mode

This is the most flexible mode. The stock quality is better than for the Fast 3D mode but done to a tolerance controlled by the Quality slider. This mode gives the best result for turning. This mode supports multi-core/CPU for fast simulation.

High Quality Mode

The High Quality mode can in some cases give better visualization of the stock and can also be faster to update than the other modes. However, the stock has to be updated whenever you zoom and rotate in the model viewport.

Fast Mode

The Fast mode will often provide good results for milling toolpath. For turning you should still prefer the Solid mode. This mode also supports multi-core/CPU for fast simulation and the mode will often give a result faster than possible with Solid mode.

Stock

Enable to show the stock during the simulation.

Tool

Toggles the on/off visibility of the tool.

Tool

Displays a tool description of the tool in use during the simulation.

Show Holder

Toggles the on/off visibility of the tool holder.

Show Shaft

Toggles the on/off visibility of the tool shaft.

Show Transparent

Enable to make both the tool shaft and tool holder transparent so that you can see through them.

Toolpath

Available visualization options allow the entire toolpath, all toolpath before or after the current tool position, toolpath for the operation, or toolpath tail until the current tool position to be shown during the simulation.

Show Points

When enabled, points along the toolpath are displayed. As you hover over each point, its XYZ position appears in the Position group.

Pattern Type

The pattern type to use for the folder.

Linear - Patterns operations/toolpaths in a straight line, or grid.

Circular - Patterns operations/toolpaths around a rotational center.

Mirror - Creates mirror-image operations/toolpaths that are flipped about a mirror plane.

Duplication - Creates a pattern using operations/toolpaths as the source and sketch points as the targets.

Component - Available in assemblies only, this option patterns operations/toolpaths from one component to multiple components in an assembly.

Operation Order

Specifies the ordering of the operations in the pattern.

Preserve order - Machines all operations in each instance of the pattern before moving to the next instance.

Order by operation - Machines all occurrences of each operation in the pattern before changing to the next operation.

Order by tool - Machines all operations in the pattern that use the current tool before changing tools.

Miscellaneous

Manual NC

Specifies the type of the Manual NC operation. These options can be used to directly control the generated NC code within the NC program. For instance, by forcing a tool change that would otherwise not be required. It is fully up to the post processor configuration to make use of these commands in the desired manner.

Note: press F1 to read the Manual NC page in the help file for more information.

Bottom

The maximum cutting depth.

Top

Specifies the top of the stock.

Rough final

Threading

Right handed | Left handed

Automatically create tools

Maximum tool depth

Default spot drill diameter

Chamfer size

Merge with spot drilling

Minimum pre-drill diameter

Increment pre-drill diameter

Stock per side remaining for finish tool

Normalization mode

Normalization reference

Normalization offset

Normalization

Generated on February 22, 2022 at 11:51 for HSMWorks 2023

None | Email: cam.support@autodesk.com