KinematicsDesign
KinematicsDesign Einführung


Einführung

KinematicsDesign Vorwort
KinematicsDesign / Einführung
Einführung


Vorwort

Einführung Was ist neu?
KinematicsDesign / Einführung / Vorwort
Vorwort
KinematicsDesign ist ein Programm zum interaktiven Erstellen von Steuerungs-Kinematiken für iTNC530 und NCK-basierten Steuerungen.

Durch die grafische Darstellung der gesamten Kinematik wird vor allem die Eingabe von Kollisionskörpern für die dynamische Kollisionsüberwachung (DCM) wesentlich erleichtert.

  • Übersichtliche Anzeige und Bearbeitung einer oder mehrerer Kinematiken in einer Baumansicht
  • Eingabefelder für die Bearbeitung der Kinematikelemente
  • Bearbeitung von lokalen Kinematikdateien oder der aktuellen Kinematik einer Steuerung über LSV2-Schnittstelle
  • Grafische Darstellung der gesamten Kinematikkette
  • Unterstützung von DCM durch Visualisierung der Kollisionskörper und Anzeige von Ausschluss-Objekten
  • Erstellung von Spannmitteln und Spannmittelvorlagen
  • Anzeige von STL-Dateien
  • Eigenes Programm zur Erstellung von Spannmitteln aus Vorlagen (FixtureWizard)
  • Visualisierung mit aktuellen oder simulierten Achspositionen und Anzeige von Kollisionen
  • Visualisierung des aktuellen oder simulierten Werkzeugs aus einer Werkzeugtabelle und Unterstützung von Werkzeugträgerkinematiken
  • Übertragen und Bearbeiten der Werkzeugtabelle
  • Importfunktion für iTNC530-Tabellen in NCK-Kinematik
KinematicsDesign ist in Deutsch und Englisch erhältlich.


Was ist neu?

Vorwort Systemvoraussetzungen
KinematicsDesign / Einführung / Was ist neu?
Was ist neu?
Dies sind die neuen Funktionen der Version 2.0:

  • Einblendung von STL-Dateien
    STL-Dateien
  • Rückgängig machen
    Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig
  • Eingabehilfe für Bohrungen
    Elemente einfügen
  • Numerische Eingabefelder mit Auf-/Ab-Buttons
    Elemente bearbeiten iTNC530, Elemente bearbeiten NCK
  • Ein-/Ausschalten der perspektivischen Darstellung
    Grafik allgemein
  • Unterstützung von Stufenwerkzeugen
    Werkzeugtabelle
  • Optionales Übertragen von MP-Dateien von und zur Steuerung
    Verbindungseinstellungen, Kinematik übertragen
  • Alternative Ausrichtung für einzelne Kinematiken
    Elemente bearbeiten iTNC530
  • Verbesserte Bedienung


Systemvoraussetzungen

Was ist neu? Lizenzvereinbarung
KinematicsDesign / Einführung / Systemvoraussetzungen
Systemvoraussetzungen
  • Betriebssystem Windows XP/Vista/7
  • Bildschirmauflösung mindestens 1024x768 Pixel
Tipp
KinematicsDesign läuft nicht auf dem Windows-Teil der Zweiprozessorsteuerung.


Lizenzvereinbarung

Systemvoraussetzungen Verfügbarkeit
KinematicsDesign / Einführung / Lizenzvereinbarung
Lizenzvereinbarung
KinematicsDesign wird von HEIDENHAIN seinen registrierten Partnern als kostenlose lizenzierte Software über das Internet zur Verfügung gestellt.

Die ausführlichen Nutzungs- und Lizenzbedingungen finden Sie in dem Programm-Verzeichnis in der Datei Eula.rtf.

Mit der Installation von KinematicsDesign haben Sie die Lizenzbedingungen akzeptiert.


Verfügbarkeit

Lizenzvereinbarung Kurzanleitung
KinematicsDesign / Einführung / Verfügbarkeit
Verfügbarkeit
iTNC530

KinematicsDesign bearbeitet die neuen Kinematiktabellen, die mit der NC-Version 34049x-01 eingeführt wurden. Die alten Kinematiktabellen werden von KinematicsDesign nicht unterstützt.

Die Kollisionsüberwachung mit Kollisionskörpern (CMO-Datei) gibt es ab der Version 34049x-02.

Ab der Version 34049x-03 können CMO-Dateien auch Transformationen (TRANS) enthalten.

Ab der Version 34049x-03 können die aktuellen Achspositionen der Steuerung abgefragt werden.

Ab der Version 34049x-04 können Dateiangaben auch relative Pfadangaben enthalten (relativ zur Zuordnungstabelle).

Ab der Version 34049x-04 können Kollisionskörper weitere Kollisionskörper enthalten.

Ab der Version 34049x-04 können auch Spannmittel überwacht werden.

Ab der Version 34049x-04 kann die Kinematik über die LSV2-Schnittstelle aktiviert und umgeschaltet werden.

Ab der Version 34049x-05 werden benutzerdefinierte Werkzeugträgerkinematiken unterstützt.

Ab der Version 34049x-07 / 60642x-02 werden alternative Ausrichtungen unterstützt.

NCK-basierte Steuerungen

KinematicsDesign unterstützt die vereinfachte Kinematikbeschreibung, die bei NCK-basierten Steuerungen mit der NCK-Version 597110-03 eingeführt wurde. Die alte Kinematikbeschreibung wird von KinematicsDesign nicht unterstützt.

Die Einführung der Kollisionsüberwachung und die Übermittlung der aktuellen Achspositionen über LSV2-Schnittelle stand bei Redaktionsschluss noch nicht fest.

Die Werkzeugtabelle von Drehsteuerungen (MANUALplus, CNCPILOT) wird von KinematicsDesign noch nicht unterstützt.


Kurzanleitung

Verfügbarkeit Bedienung
KinematicsDesign / Einführung / Kurzanleitung
Kurzanleitung
  • iTNC530
    Öffnen Sie eine vorhandene Kinematiktabelle oder legen Sie eine neue Datei an. Sie können sowohl die komplette Kinematik einer Steuerung über die Zuordnungstabelle oder einzelne Teildateien laden. Beim Öffnen werden immer alle abhängigen Dateien ebenfalls geladen.
    Sie können auch alle Kollisionskörper aus einem Verzeichnis auf einmal laden
    Neu / Öffnen / Speichern
  • NCK-basierte Steuerungen
    Öffnen Sie die Datei Configfiles.cfg. Alle konfigurierten Kinematiken werden geladen
    Neu / Öffnen / Speichern
  • Wenn Sie mit einer Steuerung verbunden sind, können Sie auch die aktuelle Kinematik von der Steuerung laden und bearbeiten.
    Kinematik übertragen
  • Bearbeiten Sie die geladene Kinematik in der Baumansicht. Fügen Sie Kinematikelemente hinzu und geben Sie die zugehörigen Parameter ein.
    iTNC530: Kinematik bearbeiten iTNC530
    NCK: Kinematik bearbeiten NCK
  • Kollisionskörper und Teilkinematiken können als Knoten in der Baumansicht auf- und zugeklappt werden.
    Baumansicht
  • Die aktuelle Kinematik wird immer parallel zur Eingabe als 3D-Grafik angezeigt.
    Grafik allgemein
  • Mit gedrückter linker Maustaste ziehen Sie ein Zoom-Rechteck auf.
  • Mit gedrückter rechter Maustaste drehen Sie die Ansicht in alle Richtungen.
  • Mit gedrücktem Mausrad (bzw. mittlerer Maustaste) verschieben Sie die Ansicht in alle Richtungen.
  • Mit dem Mausrad vergrößern oder verkleinern Sie die Ansicht (Zoom)
  • Bei der Grafik-Anzeige können simulierte Achspositionen oder die aktuellen Achspositionen der Steuerung verwendet werden.
    Achspositionen


Bedienung

Kurzanleitung Bedienoberfläche
KinematicsDesign / Bedienung
Bedienung


Bedienoberfläche

Bedienung Allgemein
KinematicsDesign / Bedienung / Bedienoberfläche
Bedienoberfläche


Allgemein

Bedienoberfläche Hilfe
KinematicsDesign / Bedienung / Bedienoberfläche / Allgemein
Allgemein
Die Bedienoberfläche ist in mehrere Fenster unterteilt, die mit den Befehlen unter Ansicht einzeln ein- oder ausgeblendet werden können.

  • Hauptmenü
  • Symbolleiste
  • Kinematikeditor mit Baumansicht und Eingabefeldern
  • 3D-Grafik der Kinematik mit Kollisionskörpern
  • Eingabefelder für die Werkzeugtabelle und Werkzeugnummer
  • Eingabefelder für die Achspositionen mit Schrittweiten und Nullpositionen
  • Eingabefelder für die Einblendung und Positionierung von Objekten aus STL-Dateien
  • Statusleiste


Hilfe

Allgemein Baumansicht
KinematicsDesign / Bedienung / Bedienoberfläche / Hilfe
Hilfe
KinematicsDesign verfügt über ein integriertes, kontextsensitives Hilfesystem.

Öffnen Sie das Hilfesystem entweder über einen der Befehle unter dem Menüpunkt ? oder positionieren Sie den Mauszeiger in ein Fenster, zu dem Sie Hilfe benötigen, und betätigen Sie die F1-Taste.

Mit dem Befehl ? > Tastaturbefehle... wird eine Tabelle mit allen gültigen Tastaturkommandos geöffnet.

Navigieren Sie innerhalb des Hilfesystems, indem Sie die unterstrichenen, grünen Texte (Hyperlinks) anklicken.

Zum Auffinden von Hilfethemen besitzt das Hilfesystem ein Fenster mit Registerkarten für die einzelnen Funktionen

Inhalt
Klicken Sie auf diese Registerkarte, wenn Sie alle Kapitel der Hilfe sehen möchten.

Index
In dieser Registerkarte können Sie im Index nach Schlagwörtern suchen.

Suchen
Mit dieser Registerkarte können Sie eine Volltextsuche über das gesamte Hilfesystem durchführen.

Favoriten
Wenn Sie ein Hilfethema zu einem späteren Zeitpunkt wieder benötigen (Lesezeichen), fügen Sie das aktuelle Thema mit dem Button Hinzufügen zur Liste der Favoriten hinzu.


Baumansicht

Hilfe Suchen
KinematicsDesign / Bedienung / Bedienoberfläche / Baumansicht
Baumansicht
Alle Elemente der Kinematik werden in einer übersichtlichen Baumansicht dargestellt. Kollisionskörper und Teilkinematiken bilden die Knoten in dem Baum, die auf- und zugeklappt werden können. Klicken Sie dazu auf die kleinen Pfeilsymbole.

Für jeden Element-Typ gibt es ein anderes Symbol. Der Text neben dem Symbol entspricht dem Eintrag in dem Eingabefeld Bezeichnung bzw. bei NCK-basierten Steuerungen Keyname und kann dort geändert werden.

Das aktive Element wird in der Grafik farbig hervorgehoben.
Grafik allgemein

Mit den Eingabefeldern unterhalb der Baumansicht können Sie alle Parameter des gerade aktiven Elementes editieren.

Markieren Sie in der Baumansicht das Element, das Sie bearbeiten oder entfernen möchten. Neue Elemente werden immer oberhalb des markierten Elementes eingefügt.
iTNC530: Kinematik bearbeiten iTNC530
NCK: Kinematik bearbeiten NCK

Mit dem Befehl Ansicht > Baumansicht können Sie die Baumansicht ein- und ausblenden.


Suchen

Baumansicht Kontextmenü
KinematicsDesign / Bedienung / Bedienoberfläche / Suchen
Suchen
Mit dem Befehl Bearbeiten > Suchen... können Sie nach einem Objekt in der Baumansicht suchen. Geben Sie den Suchtext an. Mit dem kleinen Pfeil am rechten Rand des Eingabefeldes öffnen Sie eine Liste mit den letzten Suchtexten.

Außer der Bezeichnung werden dabei je nach Art des Objekts weitere Felder, die Texte enthalten können, durchsucht. Groß/Kleinschreibung wird nicht berücksichtigt.

Mit dem Befehl Bearbeiten > Suche nächstes/vorheriges wird das nächste bzw. vorherige Objekt gesucht.


Kontextmenü

Suchen Optionen
KinematicsDesign / Bedienung / Bedienoberfläche / Kontextmenü
Kontextmenü
Das Kontextmenü enthält die wichtigsten Befehle, die Sie gerade benötigen.

Öffnen Sie das Kontextmenü mit der rechten Maustaste oder mit der Menü-Taste Ihrer Windows-Tastatur.


Optionen

Kontextmenü Info über die aktuelle Kinematik
KinematicsDesign / Bedienung / Bedienoberfläche / Optionen
Optionen
Mit dem Befehl Extras > Optionen... öffnen Sie einen Dialog zur Einstellung von Programm-Optionen.

Benutzerspezifisches Verzeichnis für Prototypdateien
Geben Sie hier ein alternatives Verzeichnis für Prototypdateien an, wenn Sie nicht mit den Standard-Prototypen arbeiten möchten. Wenn dieses Feld leer ist, werden die Standard-Prototypen verwendet.
Prototypen

Beim Programmstart zuletzt geöffnetes Projekt wiederherstellen
Aktivieren Sie dieses Kästchen, wenn beim Programmstart das zuletzt geöffnete Projekt wieder geöffnet werden soll.


Info über die aktuelle Kinematik

Optionen Info über KinematicsDesign
KinematicsDesign / Bedienung / Bedienoberfläche / Info über die aktuelle Kinematik
Info über die aktuelle Kinematik
Mit dem Befehl Extras > Infos... erhalten Sie zusätzliche Informationen über die aktuelle Kinematik.


Info über KinematicsDesign

Info über die aktuelle Kinematik Tastaturbefehle
KinematicsDesign / Bedienung / Bedienoberfläche / Info über KinematicsDesign
Info über KinematicsDesign
Mit dem Befehl ? > Info über KinematicsDesign... erhalten Sie Informationen über die aktuelle Software-Version.


Tastaturbefehle

Info über KinematicsDesign iTNC530
KinematicsDesign / Bedienung / Bedienoberfläche / Tastaturbefehle
Tastaturbefehle
Tastenkombination | Befehl
F1 | kontextsensitive Hilfe aufrufen
Umschalt+F10 | Kontextmenü öffnen
Tab | nächstes Feld auswählen
Umschalt+Tab | vorheriges Feld auswählen
Strg+O | Datei öffnen
Strg+S | Datei speichern
Strg+N | Datei neu
Strg+F4 | Datei schliessen
Alt+F4 | Programm beenden
F6 | Schaltet den Eingabefokus zwischen Baumansicht und Grafik hin und her
Strg+X Umschalt+Entf | aktives Feld ausschneiden
Strg+C Strg+Einfg | aktives Feld in Zwischenablage kopieren
Strg+V Umschalt+Einfg | aus Zwischenablage einfügen
Strg+F | Suche starten
F3 | Suche nächstes
Umschalt+F3 | Suche vorheriges
Strg+T | Transformation einfügen
Strg+M | Maschinenachse einfügen
Strg+K | Kollisionskörper einfügen
Strg+D | Zylinder einfügen
Strg+Q | Quader einfügen
Strg+L | Umschalten Achspositionen Online/Offline
Strg+E | Ein/Ausblenden der Koordinatensysteme von Transformationen
Strg+W | Umschalten Flächenmodell/Drahtmodell
Strg+R | Ansicht zurücksetzen
Pfeiltasten | Grafik rotieren
Umschalt+Pfeiltasten | Grafik verschieben
Strg+Pfeiltasten | Grafik zoomen


iTNC530

Tastaturbefehle Dateien
KinematicsDesign / Bedienung / iTNC530
iTNC530


Dateien

iTNC530 Übersicht
KinematicsDesign / Bedienung / iTNC530 / Dateien
Dateien


Übersicht

Dateien Neu / Öffnen / Speichern
KinematicsDesign / Bedienung / iTNC530 / Dateien / Übersicht
Übersicht
Mit KinematicsDesign können Sie folgende Tabellendateien bearbeiten:

  • Die Zuordnungstabelle
  • Kinematiktabellen
  • Teilkinematiktabellen
  • Kollisionskörper (CMO-Dateien)
  • Tabellen mit Ausschluss-Objekten zu Kollisionskörpern
  • Spannmittel und Werkzeugträgerkinematiken (*.cfx)
  • Spannmittel- und Werkzeugträgerkinematik-Vorlagen (*.cft)
Bei einer Zuordnungstabelle werden alle referenzierten Kinematiktabellen, Teilkinematiken und Kollisionskörper ebenfalls geladen und in einer Baumansicht angezeigt. Kollisionskörper und Teilkinematiken können als Knoten in diesem Baum auf- und zugefaltet werden.

Bei Kinematiktabellen werden ebenfalls alle enthaltenen Kollisionskörper geladen. Da der Dateiname von Teilkinematiken nicht in der Kinematiktabelle selber, sondern in der Zuordnungstabelle enthalten ist, werden Teilkinematiken nur als Platzhalter angelegt.

Teilkinematiken unterscheiden sich nur dadurch von Kinematiktabellen, dass sie keine weiteren Teilkinematiken enthalten können.

Sie können Kollisionskörper entweder einzeln öffnen und bearbeiten, oder Sie öffnen alle Kollisionskörper und Spannmittel aus einem Verzeichnis auf einmal.
Neu / Öffnen / Speichern

Tabellen mit Ausschluss-Objekten werden zusammen mit einer Kinematiktabelle als Eigenschaft eines Kollisionskörpers bearbeitet.

Die Tabellen für Spannmittel/Werkzeugträgerkinematiken und Spannmittel/Werkzeugträgerkinematik-Vorlagen werden nicht als frei definierbare iTNC530-Tabellen, sondern im csv-Format (comma separated values) angelegt. Dies ist ein allgemeineres Format, das z.B. auch von Microsoft-EXCEL bearbeitet werden kann.

Tipp
Wenn eine Datei in der Baumansicht mehrfach vorkommt, wird diese Datei nicht mehrfach eingelesen, sondern es wird intern mit Referenzen auf die gleichen Elemente gearbeitet. Änderungen an einem Element wirken sich daher auf alle Stellen in der Baumansicht aus, die dieses Element enthalten.


Neu / Öffnen / Speichern

Übersicht Dateipfade
KinematicsDesign / Bedienung / iTNC530 / Dateien / Neu / Öffnen / Speichern
Neu / Öffnen / Speichern
Mit dem Befehl Datei > Neu... legen Sie ein neues Kinematikprojekt an. Geben Sie an, was Sie genau erstellen möchten.

Mit dem Befehl Datei > Öffnen... öffnen Sie ein Kinematikprojekt. Wählen Sie eine Zuordnungstabelle, eine einzelne Kinematiktabelle oder einen einzelnen Kollisionskörper bzw. Spannmittel. Alle referenzierten Dateien werden ebenfalls geöffnet. Beim erstmaligen Öffnen einer Kinematik müssen Sie unter Umständen die Pfade der Zuordnungstabelle angeben.
Dateipfade.

Mit dem Befehl Datei > Schließen schließen Sie das aktuelle Projekt ohne das Programm zu beenden.

Mit dem Befehl Datei > Speichern speichern Sie alle geänderten Dateien des aktuellen Projekts.

Mit dem Befehl Datei > Speichern unter... speichern Sie die Datei der obersten Ebene unter einem anderen Namen.

Tipp
Wenn Sie abhängige Dateien unter einem anderen Namen speichern möchten, ändern Sie den Dateinamen bei den Eigenschaften des entsprechenden Elementes in der Baumansicht. Eine Datei mit dem neuen Namen darf dabei noch nicht existieren.
Elemente bearbeiten iTNC530

Mit dem Befehl Datei > CMO-Verzeichnis laden... laden Sie alle Kollisionskörper aus dem angegebenen Verzeichnis.


Dateipfade

Neu / Öffnen / Speichern Verzeichnisse einstellen
KinematicsDesign / Bedienung / iTNC530 / Dateien / Dateipfade
Dateipfade
Die Dateipfade in Kinematiktabellen (Spalte "FILE": Kinematiken, Teilkinematiken, Kollisionskörper oder Ausschluß-Dateien) sind entweder absolut (PLC:\...) oder relativ zu dem Verzeichnis der Zuordnungstabelle.

Dies führt unter Umständen zu Problemen bei der Zuordnung von Dateien auf dem PC.
Wenn Sie mit Unterverzeichnissen arbeiten, muß in jedem Fall die Verzeichnisstruktur relativ zur Zuordnungstabelle auf dem PC und auf der Steuerung identisch sein.

Absolute Dateipfade
Bei absoluten Steuerungs-Pfaden (PLC:\...) ist zunächst nicht bekannt, wo sich diese Dateien auf dem PC befinden. Deshalb müssen Sie beim Öffnen von Dateien, die Verweise auf Dateien mit absoluten Steuerungs-Pfaden enthalten, angeben, wo sich die Zuordnungstabelle auf der Steuerung befindet. Aus dieser Angabe wird der relative Pfadanteil auf dem PC ermittelt.

Tipp
Verwenden Sie nach Möglichkeit relative Pfadangaben. Dies erleichert die Zuordnung der Dateien auf dem PC und Sie können die gesamte Kinematik einfach an einen anderen Ort verschieben.

Relative Dateipfade
Ab der Version 34049x-04 der iTNC530 können auch relative Dateipfade angegeben werden.
Beim Öffnen der Zuordnungstabelle sind damit alle Dateipfade auf dem PC bekannt.
Wenn Sie jedoch eine Kinematik- oder Teilkinematikdatei öffnen, müssen Sie angeben, wo sich die Zuordnungstabelle relativ zu dieser Datei befindet, damit die relativen Pfade aufgelöst werden können. Die Zuordnungstabelle selber muss dazu gar nicht vorhanden sein. Zur Auflösung der relativen Pfadangaben ist nur deren relative Position zum aktuellen Verzeichnis wichtig.
Wenn sich die Zuordnungstabelle ebenfalls im aktuellen Verzeichnis befindet, können Sie das Eingabefeld leer lassen. Ansonsten geben Sie für jede Ordnerebene höher zwei Punkte an.

Beispiel 1
Die Zuordnungstabelle befindet sich im Verzeichnis C:\Projekte\Kinematiken.
Im Unterverzeichnis C:\Projekte\Kinematiken\Subfiles befinden sich die Teilkinematiken.
Im Unterverzeichnis C:\Projekte\Kinematiken\CMOs befinden sich die Kollisionskörper.
Eine Teilkinematik enthält einen Kollisionskörper mit der Dateiangabe CMOs\CMO_Head.Tab. Diese Dateiangabe ist relativ zur Zuordnungstabelle.

Wenn Sie die Zuordnungstabelle öffnen, sind alle Dateiangaben bekannt.

Wenn Sie jedoch eine Teilkinematik-Datei öffnen möchten, werden Sie aufgefordert anzugeben, wo sich die Zuordnungstabelle relativ zu dieser Datei befindet. Da sich die Zuordnungstabelle in diesem Beispiel eine Ordnerebene höher befindet, geben Sie zwei Punkte an "..".
Wenn sie sich zwei Ebenen höher befinden würde, müßten Sie "..\.." angeben.
Wenn sie sich in einem parallelen Verzeichnis "KINE" befinden würde, müßten Sie z.B. "..\KINE" eingeben usw.

Beispiel 2
Gleiche Verzeichnisstruktur wie Beispiel 1, aber eine Teilkinematik enthält die absolute Dateiangabe PLC:\KINEMAT\CMOs\CMO_Head.Tab.
Wenn Sie diese Teilkinematik auf dem PC öffnen möchten, müssen Sie zusätzlich angeben, wo sich die Zuordnungstabelle auf der Steuerung befindet, damit der relative Anteil auf dem PC ermittelt werden kann. Geben Sie in diesem Beispiel "PLC:\KINEMAT" ein.

Ini-Datei
Die oben beschriebenen Pfadangaben werden in der Datei KineDesign.ini im aktuellen Verzeichnis abgelegt. Sie müssen diese Angaben daher nur einmal machen.
Sollte sich an der Verzeichnisstruktur etwas ändern, müssen Sie eventuell die Einträge in dieser ini-Datei anpassen.
Verzeichnisse einstellen

Spannmitteldateien
Spannmitteldateien können wiederum Unter-Spannmittel enthalten (Ein Dreibackenfutter hat z.B. dreimal einen Verweis auf die gleiche Datei, in der einmal ein Backen definiert ist). Pfadangaben auf Unter-Spannmittel in Spannmitteldateien sind immer relativ zu der Spannmitteldatei selber. Auf diese Weise gibt es hier keine Probleme mit relativen Pfaden. Innerhalb von Spannmitteldateien dürfen keine absolute Pfade verwendet werden.


Verzeichnisse einstellen

Dateipfade Prototypen
KinematicsDesign / Bedienung / iTNC530 / Dateien / Verzeichnisse einstellen
Verzeichnisse einstellen
Mit dem Befehl Extras > Verzeichnisse... öffen Sie einen Dialog zum Ändern von Verzeichniseinstellungen, die in der Datei KineDesign.ini für die aktuelle Kinematik hinterlegt sind. Normalerweise werden diese Einstellungen beim Einlesen der Kinematik bereits ermittelt. Wenn sich an diesen Eintstellungen z.B. durch eine Veränderung der Verzeichnisstruktur der Kinematik etwas ändert, können Sie die Einstellungen hier anpassen.
Dateipfade

Verzeichnis der Zuordnungstabelle auf der STEUERUNG
Diese Angabe wird benötigt, um absolute Pfadangaben innerhalb von Kinematiktabellen auf dem PC auflösen zu können.

Beispiel
Eine Kinematiktabelle enthält in der Spalte FILE für eine CMO-Datei den Eintrag PLC:\KINEMAT\CMO\CMO_HEAD.TAB. Die Zuordnungstabelle befindet sich auf der Steuerung in dem Verzeichnis PLC:\KINEMAT. Geben Sie also hier PLC:\KINEMAT ein.

Pfad zu Zuordnungstabelle RELATIV zur aktuellen Kinematiktabelle
Da sich alle relativen Pfadangaben innerhalb einer Kinematikbeschreibung auf das Verzeichnis der Zuordnungstabelle beziehen, wird diese Angabe für die Auflösung relativer Pfadangaben benötigt. Wenn Sie nicht gerade eine Zuordnungstabelle geladen haben, sondern z.B. eine Kinematiktabelle, geben Sie hier an, wo sich die Zuordnungstabelle relativ zu der Datei befindet, die Sie gerade geöffnet haben. Wenn sich die Zuordnungstabelle im gleichen Verzeichnis befindet, können Sie dieses Feld leer lassen oder einen Punkt eingeben. Eine Verzeichniss-Ebene höher wird durch zwei Punkte gekennzeichnet.

Beispiel
Sie öffnen eine Teilkinematik C:\Kinematik\Subfiles\TABLE.TAB. Die Zuordnungstabelle befindet sich in dem Verzeichnis C:\Kinematik, also eine Ebene höher. Geben Sie in diesem Fall hier .. ein.

Verzeichnisse der Werkzeugträgerkinematiken

Diese Angaben werden u.U. für das Laden von Werkzeugträgerkinematiken aus einer Werkzeugtabelle benötigt. Wenn die Werkzeugtabelle für ein bestimmtes Werkzeug einen Dateinamen für eine Trägerkinematik enthält, wird diese Datei der Reihe nach in folgenden Verzeichnissen gesucht: TNC-Verzeichnis, PLC-Verzeichnis, Verzeichnis der Zuordnungstabelle.

TNC-Verzeichnis der Werkzeugträgerkinematiken
Geben Sie hier das Verzeichnis an, in dem sich auf dem PC die kundenspezifischen Trägerkinematiken befinden. Beachten Sie, dass kundenspezifische Trägerkinematiken immer cfx-Dateien sein müssen.

PLC-Verzeichnis der Werkzeugträgerkinematiken
Geben Sie hier das Verzeichnis an, in dem sich auf dem PC die OEM-spezifischen Trägerkinematiken befinden. Beachten Sie, dass OEM-spezifische Trägerkinematiken immer TAB-Dateien sein müssen.

Werkzeugträgerkinematik, Werkzeugtabelle


Prototypen

Verzeichnisse einstellen Kinematik bearbeiten iTNC530
KinematicsDesign / Bedienung / iTNC530 / Dateien / Prototypen
Prototypen
Die Kinematik wird bei der iTNC530 in ASCII-Tabellen abgelegt. In diesen Tabellen ist auch das Tabellenformat hinterlegt. Darin werden die einzelnen Spalten definiert mit Typ, Stellenzahl sowie mehrsprachigen Hilfetexten für den allgemeinen Tabelleneditor auf der Steuerung. Außer den notwendigen Spalten für die Kinematik ist es auch möglich, weitere benutzerdefinierte Spalten hinzuzufügen.

Dieses Tabellenformat wird für jeden Dateityp in einer Prototypdatei hinterlegt. Beim Anlegen einer neuen Datei wird zunächst eine Kopie einer Prototypdatei mit dem neuen Dateinamen erzeugt. Neue Dateien können auf zwei Arten angelegt werden: Entweder mit dem Befehl Datei > Neu... oder durch das Einfügen einer weiteren Datei in der Baumansicht.

Die Standard-Prototypdateien befinden sich in einem Unterverzeichnis des Programmverzeichnisses von KinematicsDesign. Optional können Sie aber auch ein alternatives Verzeichnis angeben, um selbst definierte Prototypen zu verwenden. Die Namen dieser Dateien sind gemäß folgender Tabelle festgelegt.
Optionen

Prototypdateien:

Dateiname | Typ
KINELIST.TAB | Zuordnungstabelle
KINEMATICS.TAB | Kinematik und Teilkinematiken (Subfiles)
CMO.TAB | Kollisionskörper (CMO-Datei)
DONTTEST.TAB | Liste von Ausschluss-Objekten
FIXTUREHOOK.TAB | Liste von Spannmitteln

Wenn Sie eigene Prototypdateien verwenden möchten, gehen Sie folgendermaßen vor:

  • Legen Sie ein beliebiges Prototyp-Verzeichnis auf Ihrem PC an.
  • Kopieren Sie die gewünschten Prototypdateien gemäß obiger Tabelle aus dem Unterverzeichnis Prototypes des Programmverzeichnisses von KinematicsDesign in ihr Prototyp-Verzeichnis.
    Falls Sie bereits eigene Prototypdateien angelegt haben, können Sie diese natürlich auch in das Prototyp-Verzeichnis kopieren und gemäß obiger Tabelle umbenennen.
  • Ändern Sie diese Prototypdateien nach Ihren Vorstellungen.
  • Geben Sie bei Extras > Optionen... Ihr alternatives Prototyp-Verzeichnis an.


Kinematik bearbeiten iTNC530

Prototypen Elemente einfügen
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530
Kinematik bearbeiten iTNC530
Elemente einfügen
Elemente bearbeiten iTNC530
Kollisionskörper
Teilkinematiken
Spannmittel
Werkzeugträgerkinematik
Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig
Kollisionslisten


Elemente einfügen

Kinematik bearbeiten iTNC530 Elemente bearbeiten iTNC530
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530 / Elemente einfügen
Elemente einfügen
Mit den Befehlen unter Einfügen fügen Sie in der Baumansicht neue Elemente oberhalb des markierten Elementes ein. Je nach Art und Position des markierten Elementes können Sie diese Elemente einfügen:

Element | Schlüsselwort (KEY) | Bemerkung
Kinematik |  | Kinematiktabelle, neue Zeile in der Zuordnungstabelle
Teilkinematik 1/2 | SUBFILE1/2 | Platzhalter für eine Teilkinematik. Erst bei Eingabe eines Dateinamens wird auch eine Kinematiktabelle angelegt und in der Zuordnungstabelle eingetragen
Transformation | Trans | Translation oder Rotation je nach Achse (A,B,C,X,Y,Z)
Maschinenachse | MachAxis | Maschinenachse
Werkzeugträgerkinematik | TOOLFILE | Platzhalter für eine Werkzeugträgerkinematik. Wird zur Laufzeit auf der Steuerung ermittelt
Werkzeugachse | ToolAxis | Erlaubte Werkzeugachse
Maschinenbett | MachBase | Legt das Maschinenbett fest, wird nur zur Visualisierung benötigt und hat keinen Einfluss auf die Kinematik
Kollisionskörper | CMO | CMO-Datei, beschreibt einen Kollisionskörper. Ein Kollisionskörper besteht aus einem oder mehreren einfachen Kollisionsobjekten
Zylinder | Cylinder | Zylinderförmiges Kollisionsobjekt
Quader | Cuboid | Quaderförmiges Kollisionsobjekt
Minimale/Maximale Begrenzung | LimitMin, LimitMax | Minimale bzw. maximale Begrenzungsfläche
Einhängepunkt für Spannmittel | Clamp | Hier können zur Laufzeit auf der Steuerung Spannmittel eingehängt werden.
Spannmittel | - - | Anlegen einer neuen Spannmitteldatei
Spannmittelvorlage *) | - - | Anlegen einer neuen Spannmittelvorlage
Variables Unter-Spannmittel | FCMO | Nur innerhalb einer Spannmittelvorlage: Variables Unter-Spannmittel (Wizard-CMO)
Variable | Var VarEntry VarTp VarParam | Typ: Allgemeine Variable Manuelles Eingabefeld Manueller Antastzyklus Wizard-Parameter
Antastzyklus | TpRef TpPos TpAng TpRefAng TpCheck | Typ: Bezugspunkt Ebene Bezugspunkt Achse Grunddrehung Grunddrehung mit Ecke Testpunkt

*) Nur in der Betriebsart 'CMO-Verzeichnis laden'.

Eine genaue Beschreibung dieser Elemente entnehmen Sie bitte dem Technischen Handbuch der Steuerung.

Kegelstumpf
Kegelstümpfe werden von der Kollisionsüberwachung nicht unterstützt. KinematicsDesign bietet aber eine Eingabehilfe, mit der Kegelstümpfe durch einen umhüllenden Zylinderstapel angenähert werden. Geben Sie die Bezeichnung, die Achse, die Höhe, die beiden Radien, die Position und die Anzahl der Stufen an. Bei Spannmitteln können Sie für Höhe und Radien auch Variablen oder Formeln eingeben.

Gefahr
Beachten Sie bitte bei der Verwendung von variablen Radien: Der Radius der Spitze muss immer kleiner bleiben, als der Radius der Basis. Andernfalls erzeugt dieser Algorithmus keinen umhüllenden, sondern einen innenliegenden Zylinderstapel. Dadurch wären Bereiche des Kegels ungeschützt!

Bohrung
Bohrungen werden von der Kollisionsüberwachung nicht unterstützt. KinematicsDesign bietet aber eine Eingabehilfe, mit der Bohrungen durch Quader angenähert werden können. Geben Sie die Bezeichnung, die Höhe, den äußeren Durchmesser, den Durchmesser der Bohrung und die Anzahl der Ecken an. Bei Spannmitteln können Sie für Höhe und Durchmesser auch Variablen oder Formeln eingeben.

Gefahr
Beachten Sie bitte, dass Sie mit diesen Eingabehilfen sehr viele Objekte auf einmal einfügen können. Wählen Sie daher die Anzahl der Stufen bzw. Ecken so klein wie möglich, um die Steuerung nicht unnötig zu belasten.


Elemente bearbeiten iTNC530

Elemente einfügen Kollisionskörper
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530 / Elemente bearbeiten iTNC530
Elemente bearbeiten iTNC530
Um die Parameter eines Elementes zu bearbeiten, klicken Sie auf das gewünschte Element in der Baumansicht. Je nach Typ des Elementes werden die passenden Eingabefelder geöffnet.

Die Änderungen werden entweder beim Verlassen des Eingabefeldes oder bei Betätigung der Eingabetaste (Return) übernommen.

Numerische Werte können Sie auch mit den kleinen Pfeil-Buttons am rechten Rand des Eingabefeldes verändern.

Wenn die Tabellendatei zusätzliche, benutzerdefinierte Spalten enthält, werden dafür weitere Eingabefelder angelegt.
Die Definition dieser Spalten ist ebenso wie die maximale Länge von Textfeldern und die Anzahl der Nachkommastellen von numerischen Werten in der Tabellendatei enthalten und kann in KinematicsDesign nicht verändert werden. Editieren Sie gegebenenfalls die Tabellendateien mit einem beliebigen ASCII-Editor und definieren Sie alternative Prototypdateien.
Prototypen.

Eingabefeld | Spalten-Überschrift | Bedeutung
Bezeichnung | DOC | beliebiger Text
Datei | FILE | Dateiname
Teildatei1/2 | SUBFILE1/2 | Teilkinematik 1 oder 2
MP7500 | MP7500 |
MP-Datei *) | MPFILE | Teil-MP-Datei
Alternative Ausrichtung | UPW, RIGHTW | Alternative Ausrichtung für die 3D-Ansicht. Ausrichtung
Achse | AXIS | Transformationsachse oder Maschinenachse oder Richtungsachse eines Zylinders
Wert | COORD | Wert einer Transformation
Temperatur-Kompensation | TEMPCOMP | Formel zur Temperaturkompensation
Kinematische Kompensation | COMPTAB | Formel zur kinematischen Kompensation
Aktiviert | ON/OFF | Kollisionsüberwachung für diesen Kollisionskörper ein oder aus
Ausgeschlossene Objekte | DONTTEST | Name der Ausschluss-Datei
X, Y, Z **) | X, Y, Z | Position und Abmessung eines Quaders oder Versatz eines Zylinders
Höhe | HEIGHT | Höhe eines Zylinders
Radius | RADIUS | Radius eines Zylinders
Nur für Spannmittel/Trägerkinematiken: |  |
Abmessungen | XSIZE, YSIZE, ZSIZE | Abmessung eines Quaders innerhalb einer Spannmitteldatei
Name | NAME | Name einer Variablen oder eines Antast-Zyklusses
Funktion | FUNC | Funktion zur Ermittlung des Wertes einer Variablen aus einem manuellen Antast-Zyklus
Wert | VALUE | Wert einer Variablen
Wertebereich | RANGE | zulässige Wertebereiche einer Variablen mit manuellem Eingabefeld. z.B. 1...10, ...-3, 100...
Darstellung | SUBTYPE | Darstellung einer Variablen mit manuellem Eingabefeld: Length: Längenangabe in mm oder inch Angle: Winkelangabe in Grad Integer: Aufzählungstyp Bool: Logischer Wert
Inchwert | DEFINCH | Mit diesem Wert wird die Variable bei der Einstellung 'Inch' vorbelegt. Nur für Längenangaben.
Hilfsbild | PICTURE | Datei mit Hilfsbild zu einer Variablen oder einem variablen Unterspannmittel
Labeltext | LABELID | Klartext oder Text-ID zu einer Variablen
Ansichtswinkel Horizontal/ Vertikal ***) | VIEWH, VIEWV | Ansichtswinkel unter dem das Spannmittel beim Positionieren auf der Steuerung dargestellt wird.
Automatisch | AUTOVIEW | Ansichtswinkel des Spannmittels wird beim Positionieren auf der Steuerung automatisch ermittelt.
Schwenkwinkel A,B,C | SPA, SPB, SPC | Schwenkwinkel beim Anfahren von Testpunkten

*) Sie können mit dem Browse-Button ... eine MP-Datei auswählen. Beachten Sie jedoch, dass auf der Steuerung (bis zur Version 34049x-05) eine absolute Pfadangabe erforderlich ist. Da der absolute Pfadanteil auf dem PC nicht bekannt ist, müssen Sie diesen manuell ergänzen. Beachten Sie außerdem, dass MP-Teildateien optional mit zur Steuerung übertragen werden.
Verbindungseinstellungen

**) Beachten Sie, dass ein Quader in der Tabellendatei mit Minimum/Maximum-Wert gespeichert wird. Zur besseren Handhabung werden diese Werte in KinematicsDesign in Position und Abmessung angegeben.

***) Mit dem Button Übernehmen wird der aktuelle Winkel als Ansichtswinkel übernommen. Mit dem Button Test wird das Spannmittel auf den angegebenen Ansichtswinkel gedreht.

Eine genaue Beschreibung dieser Parameter sowie die Bedeutung und Syntax der Formeln entnehmen Sie bitte dem Technischen Handbuch der Steuerung.

Tipp
Beachten Sie allgemein beim Ändern von Dateinamen:

  • Wenn die Datei noch nicht existiert, wird die Datei unter dem neuen Namen gespeichert.
  • Wenn die Datei bereits existiert, wird die bestehende Datei geladen und eventuell vorhandene Einträge in der Baumansicht überschrieben.
  • Relative Dateiangaben in TAB-Dateien sind immer relativ zur Zuordnungstabelle. Relative Dateiangaben in cfx/cft-Dateien sind immer relativ zu der Datei in der sie stehen.
  • Wenn Sie Dateien in Unterverzeichnissen ordnen, muss die Verzeichnisstruktur relativ zur Zuordnungstabelle auf der Steuerung und auf dem PC identisch sein.
  • Benutzen Sie den Browse-Button ... zur Eingabe bereits existierender Dateinamen.


Kollisionskörper

Elemente bearbeiten iTNC530 Teilkinematiken
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530 / Kollisionskörper
Kollisionskörper
Mit dem Kontrollkästchen Aktiviert kann der gesamte Kollisionskörper von der Kollisionsüberwachung ausgeschlossen werden. In der Betriebsart "Achspositionen online" kann der Kollisionskörper zur Laufzeit aktiviert oder deaktiviert werden.

Ausgeschlossene Objekte
Sie können eine Liste von Objekten angeben, gegen die dieser Kollisionskörper bei der Kollisionsüberwachung nicht getestet werden soll. Das sind in der Regel Objekte, bei denen eine Kollision auf Grund mechanischer Gegebenheiten ausgeschlossen ist. Die Angabe von Ausschluss-Objekten spart bei der Abarbeitung Rechenzeit. Objekte, die sich auf der gleichen Maschineneachse befinden, sind implizit ausgeschlossen und müssen hier nicht extra angegeben werden. HEIDENHAIN empfiehlt, diese Listen sehr sorgfältig zu pflegen, da die Kollisionsüberwachung extrem rechenintensiv ist.

Geben Sie zunächst einen Dateinamen für die Liste der Ausschluss-Objekte an.

Fügen Sie ein Objekt zu der Liste hinzu, indem Sie mit dem Pfeil-Button eine Auswahlliste aller Kollisions-Elemente der aktiven Kinematik öffnen und das gewünschte Element anklicken.

Oder betätigen Sie diesen Button und klicken Sie anschließend der Reihe nach direkt in der 3D-Grafik auf alle Objekte, die Sie hinzufügen möchten.
Bei gleichzeitig gedrückter Umschalt-Taste werden alle Objekte des zugehörigen Kollisionskörpers in die Liste übernommen. Durch erneutes Betätigen dieses Buttons wird diese Funktion wieder deaktiviert.

Löschen Sie ein markiertes Objekt aus der Liste mit der Entfernen-Taste.

Tipp
Wenn die Bezeichnung eines Objektes der Ausschluss-Liste geändert wird, werden die Einträge in allen Ausschluss-Listen, die dieses Objekt enthalten, automatisch angepasst.

Alternativ können Sie bei dem Dateinamen auch eine andere CMO-Datei angeben. In diesem Fall sind die Ausschluss-Objekte bereits durch diesen Kollisionskörper bestimmt und können hier nicht weiter bearbeitet werden.

Gefahr
Fehlerhafte Ausschluß-Listen können zu Kollisionen führen! Überprüfen Sie die Listen mit Hilfe der 3D-Grafik und den Kollisionslisten.

Kollisionslisten KollisionsüberwachungFehler bei der Dimensionierung der Kollisionskörper werden von KinematicsDesign natürlich nicht erkannt. Testen Sie die Kollisionsüberwachung immer auch an der Maschine!


Teilkinematiken

Kollisionskörper Spannmittel
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530 / Teilkinematiken
Teilkinematiken
Sie können in eine Kinematik an beliebiger Stelle maximal zwei Teilkinematiken einfügen. Zunächst sind die Teilkinematiken nur Platzhalter für Kinematikdateien. Die Namen dieser Teilkinematikdateien sind in der Zuordnungstabelle enthalten. Deshalb können Sie nur dann einen Dateinamen angeben, wenn Sie eine Zuordnungstabelle geladen haben. Wenn Sie nur eine einzelne Kinematik geöffnet haben, bleiben diese Platzhalter leer.


Spannmittel

Teilkinematiken Werkzeugträgerkinematik
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530 / Spannmittel
Spannmittel
Erstellen

Sie können mit KinematicsDesign Spannmittel und Spannmittelvorlagen für die Spannmittelüberwachung erstellen.

Tipp
Dies ist nur eine Kurzbeschreibung. Die Spannmittelüberwachung und die Erstellung von Spannmitteln insbesondere die Syntax von Formeln und Funktionen ist im Technischen Handbuch ausführlich beschrieben.

Spannmittel sind Kollisionskörper, die zur Laufzeit auf der Steuerung an vordefinierten Positionen plaziert und eingemessen werden können. Spannmittel können im Gegensatz zu normalen Kollisionskörpern bei Transformationen und einfachen Kollisionsobjekten anstelle von Werten auch mathematische Formeln mit Variablen enthalten. Diese Variablen werden auf der Steuerung beim Einmessen entweder durch ein Eingabefeld oder durch manuelle Meßzyklen aufgelöst.

Zum Erstellen eines Spannmittels gehen Sie folgendermassen vor:

  • Erzeugen Sie mit Datei > Neu... ein neues Spannmittel.
  • Modellieren Sie das Spannmittel zunächst mit Kollisionsobjekten mit festen Werten.
    Falls Sie eine STL-Datei zu dem Spannmittel haben, können Sie diese in die 3D-Ansicht einblenden.
    STL-Dateien
  • Falls der Kollisionskörper variable Abmessungen hat (z.B. der Backenabstand eines Schraubstocks), fügen Sie jetzt Variablen ein. Der Typ der Variablen legt fest, auf welche Weise die Variable aufgelöst werden soll. Mit dem Namen können die Variablen in den Formeln verwendet werden. Mit dem Wert wird die Variable vorbelegt. Für diesen Standardwert können Sie auch einen alternativen Inchwert angeben. Die Funktion legt fest, wie der Wert der Variablen aus einem Antastzyklus zu ermitteln ist. Die Darstellung und der Wertebereich definieren das Anzeigeformat und den zulässigen Wertebereich bei manuellen Eingabefeldern. Mit Hilfsbild können Sie der Variablen ein Hilfsbild zuordnen. Labeltext ermöglicht einen sprachabhängigen Text zu der Variablen.
  • Fügen Sie variable Transformationen ein, mit denen die Position des Spannmittels bezogen auf den Einhängepunkt in der Kinematik definiert wird. Verwenden Sie dazu die Namen der Variablen in einer Formel.
  • Fügen Sie jetzt die manuellen Antastzyklen ein, die benötigt werden, um die Variablen aufzulösen. Der Typ definiert den Zyklus. Ein Antastzyklus benötigt einen eindeutigen Namen mit dem er in der Funktion der zugehörigen Variablen verwendet werden kann. Achse und X,Y,Z legen die Richtung und Position des Symbols auf dem anzutastenden Körper fest. Der Ansichtswinkel gibt an, wie das Spannmittel beim Positionieren eines Antastpunktes auf der Steuerung dargestellt wird.
  • Ersetzen Sie jetzt die festen Werte von variablen Abmessungen in Kollisionsobjekten durch die Namen der Variablen. Überall, wo numerische Werte eingegeben werden müssen, können Sie bei Spannmitteln auch Variablen und mathematische Formeln eingeben.
Tipp
Modellieren Sie ein Spannmittel nicht filigraner als unbedingt notwendig! Versuchen Sie, mit sowenig Kollisionsobjekten wie möglich auszukommen, um die Steuerung nicht unnötig zu belasten.

Spannmittelvorlage

Eine Spannmittelvorlage enthält zusätzlich zu einem Spannmittel noch weitere Variablen für den FixtureWizard. Der FixtureWizard ist ein eigenständiges Programm, mit dem man aus einer Spannmittelvorlage konkrete Spannmittel generieren kann. Verwenden Sie Spannmittelvorlagen, wenn Sie mehrere ähnliche Spannmittel haben, die sich z.B. nur in einigen Abmessungen unterscheiden.

Der FixtureWizard wird zusammen mit KinematicsDesign auf Ihrem Rechner installiert.

Erstellen Sie eine Spannmittelvorlage zunächst genauso wie ein konkretes Spannmittel. Wählen Sie bei dem Auswahl-Dialog zu Datei > Neu... den Typ "Spannmittelvorlage". Fügen Sie zusätzliche Variablen vom Typ Wizard-Parameter ein. Diese Variablen können im Spannmittel-Wizard angepasst werden. Geben Sie Labeltexte und Hilfsbilder an, die im FixtureWizard angezeigt werden sollen. Legen Sie zusätzlich die Darstellung und den Wertebereich fest.

Ein Spannmittel kann auch Unter-Spannmittel in separaten Dateien enthalten. Aktivieren Sie das Kontrollkästchen Wizard-CMO wenn diese Unter-Spannmittel im Spannmittel-Wizard veränderbar sein soll.

Mit der Funktion Extras > Zu Spannmittelvorlage konvertieren können Sie ein konkretes Spannmittel wieder in eine Vorlage konvertieren. Verwenden Sie diese Funktion, wenn Sie aus einem konkreten Spannmittel eine Vorlage für weitere, ähnliche Spannmittel erstellen möchten.


Werkzeugträgerkinematik

Spannmittel Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530 / Werkzeugträgerkinematik
Werkzeugträgerkinematik
Es gibt bei der iTNC530 zwei verschiedene Arten von Werkzeugträgerkinematiken:

TAB-Datei
Trägerkinematiken als TAB-Dateien werden im Prinzip wie Teilkinematiken behandelt und müssen vom OEM entweder in das Kinematikverzeichnis oder (ab der Version 34049x-05) in das Verzeichnis PLC:\Toolkinematics übertragen werden. Mit KinematicsDesign können Sie diese Kinematiken wie normale Teilkinematiken erstellen.

cfx/cft-Datei
Ab der Version 34049x-05 werden von der iTNC530 auch benutzerdefinierte Trägerkinematiken in dem steuerungsunabhängigen cfx-Format unterstützt. Diese können auch vom Endanwender in das Verzeichnis TNC:\system\Toolkinematics übertragen werden.

Erstellen Sie cfx-Dateien indem Sie beim Erzeugen einer neuen Datei die Variante Werkzeugträgerkinematik wählen.

Werkzeugträgerkinematik-Vorlage

Genauso wie Spannmittelvorlagen können Sie auch Vorlagen für Werkzeugträgerkinematiken erstellen (*.cft). Mit dem FixtureWizard können aus Vorlagen konkrete Trägerkinematiken erzeugt werden.

Tipp
Eine detailiertere Beschreibung zu Werkzeugträgerkinematiken entnehmen Sie bitte dem Technischen Handbuch der Steuerung.


Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig

Werkzeugträgerkinematik Kollisionslisten
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530 / Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig
Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig
Mit dem Befehl Bearbeiten > Ausschneiden schneiden Sie das ausgewählte Element aus und kopieren es in die Zwischenablage.

Mit dem Befehl Bearbeiten > Kopieren kopieren Sie das ausgewählte Element in die Zwischenablage.

Mit dem Befehl Bearbeiten > Einfügen fügen Sie das Element aus der Zwischenablage oberhalb des markierten Elementes ein.

Mit dem Befehl Bearbeiten > Löschen löschen Sie das ausgewählte Element.

Mit dem Befehl Bearbeiten > Rückgängig machen Sie die letzte Aktion rückgängig

Tipp
Beim Kopieren einer Datei in der Baumansicht wird nur ein weiterer Verweis auf dieselbe Datei eingefügt. Die Datei selber wird nicht kopiert.


Kollisionslisten

Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig NCK-basierte Steuerungen
KinematicsDesign / Bedienung / iTNC530 / Kinematik bearbeiten iTNC530 / Kollisionslisten
Kollisionslisten
Mit dem Befehl Extras > Kollisionslisten erstellen... können Sie zwei Textdateien zur Überprüfung der Ausschluß-Kriterien erstellen. Geben Sie hierzu die beiden Dateinamen an.

Die Ausschlußliste enthält eine Aufstellung aller Kollisionskörperpaare, die nicht überwacht werden.
Die Kollisionsüberprüfung enthält eine Matrix aller Körper, die gegenseitig überwacht werden.


NCK-basierte Steuerungen

Kollisionslisten Dateien
KinematicsDesign / Bedienung / NCK-basierte Steuerungen
NCK-basierte Steuerungen


Dateien

NCK-basierte Steuerungen Allgemein
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Dateien
Dateien


Allgemein

Dateien Neu / Öffnen / Speichern
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Dateien / Allgemein
Allgemein
Die Kinematik wird in Form von Entitäten mit Keys und Attributen in cfg-Dateien abgelegt. Diese Entitäten können im Prinzip beliebig über alle cfg-Dateien verteilt werden. Es empfiehlt sich jedoch, entweder eine cfg-Datei für die gesamte Kinematik zu definieren oder eine eigene cfg-Datei für jede Teilkinematik.

Bei NCK-basierten Steuerungen gibt es keine feste Zuordnung von Achs-Buchstaben zu Maschinenachsen. Vielmehr muss jede Achse konfiguriert werden. Es ist deshalb nicht möglich, eine einzelne cfg-Datei zu öffnen, sondern es muss immer die gesamte Konfiguration mit allen cfg-Dateien geladen werden. Die Maschinenachsen müssen bereits konfiguriert sein.

Die Konfiguration muss genau eine Entität CfgKinList enthalten. Dies ist das Root-Element für die gesamte Kinematik.

Die Datei Configfiles.cfg enhält eine Liste aller benötigten cfg-Dateien. Sie können in KinematicsDesign cfg-Dateien hinzufügen oder entfernen. Diese Liste wird dann automatisch angepasst.


Neu / Öffnen / Speichern

Allgemein Dateipfade
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Dateien / Neu / Öffnen / Speichern
Neu / Öffnen / Speichern
Zum Bearbeiten einer Kinematik muss immer bereits eine Konfiguration vorhanden sein. Mit dem Befehl Datei > Neu... können Sie daher nur neue Kinematikprojekte für eine iTNC530 oder einzelne Spannmittel anlegen.

Mit dem Befehl Datei > Öffnen... öffnen Sie ein Kinematikprojekt. Geben Sie die Datei Configfiles.cfg an, die eine Liste aller cfg-Dateien enthält. Dateipfade

Mit dem Befehl Datei > Schließen schließen Sie das aktuelle Projekt ohne das Programm zu beenden.

Mit dem Befehl Datei > Speichern speichern Sie alle geänderten Dateien des aktuellen Projekts.

Tipp
Beim Öffnen eines Projekts müssen nicht alle cfg-Dateien, die in Configfiles.cfg angegeben sind, vorhanden sein. Es genügt, wenn alle cfg-Dateien mit den Achs-Konfigurationen und der Kinematik-Definition gelesen werden können.


Dateipfade

Neu / Öffnen / Speichern Kinematik bearbeiten NCK
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Dateien / Dateipfade
Dateipfade
Die Datei Configfiles.cfg enthält die Dateiangaben so wie sie auf der Steuerung benötigt werden. Zum Öffnen müssen die Pfade auf PC-Verzeichnisse umgesetzt werden. Dabei gibt es folgende Regeln:

  • Die Datei Configfiles.cfg befindet sich auf der Steuerung immer im Verzeichnis %OEM%\config. Beim Öffnen dieser Datei auf dem PC wird die Umgebungsvariable OEM daher auf das Verzeichnis eine Ebene oberhalb des aktuellen Verzeichnisses gesetzt.
  • Wenn das Attribut oemPath auf den Wert %OEM%\config gesetzt ist (NCK-Standard) wird auf dem PC eine Umgebungsvariable oemPath auf das aktuelle Verzeichnis gesetzt.
  • Die relative Verzeichnisstruktur auf dem PC und auf der Steuerug unterhalb von oemPath (oder OEM, falls oemPath nicht auf %OEM%\config gesetzt ist oder nicht verwendet wird) muss identisch sein.
  • Dateien, die mit der Umgebungsvariable %usrPath% oder %USR% beginnen, werden nicht geladen, da sich die Kinematik-Konfiguration üblicherweise in %OEM% befindet.
  • Falls Dateipfade noch andere Umgebungsvariablen enthalten, wird der Anwender in einem Dialog gefragt, durch welches Verzeichnis diese unbekannte Umgebungsvariable ersetzt werden soll. Diese Angabe wird in der Datei KineDesign.ini im aktuellen Verzeichnis abgelegt. Sie müssen diese Angaben daher nur einmal machen.
    Sollte sich an der Verzeichnisstruktur etwas ändern, müssen Sie eventuell die Einträge in dieser ini-Datei anpassen.
Beispiel:

Datei Configfiles.cfg

CfgConfigDataFiles {
  key:=“„,
  oemPath:=“%OEM%\\config“,
  usrPath:=%USR%\\config“,
  dataFiles:= [
     „%oemPath%\\aclist.cfg“,
     „%oemPath%\\kine.cfg“,
             :
     „%usrPath%\\user.cfg“
  ],
  updateFiles:=[]
)
Mit diesen Dateiangaben genügt es, wenn sich alle cfg-Dateien im gleichen Verzeichnis wie die Datei configfiles.cfg befinden.


Kinematik bearbeiten NCK

Dateipfade Elemente einfügen
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Kinematik bearbeiten NCK
Kinematik bearbeiten NCK


Elemente einfügen

Kinematik bearbeiten NCK Unbenutzte Elemente
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Kinematik bearbeiten NCK / Elemente einfügen
Elemente einfügen
Mit den Befehlen unter Einfügen fügen Sie in der Baumansicht neue Elemente oberhalb des markierten Elementes ein.

Element | Entität | Bemerkung
Kinematikliste | CfgKinList (kinCompositeModels) | Liste aller Kinematiken
Kinematik | CfgKinComposModel (subKinList) | Neue Kinematik. Eine Kinematik enthält eine Liste von Teilkinematiken
Teilkinematik | CfgKinSimpleModel (kinObjects) | Teilkinematik. Eine Teilkinematik enthält eine Liste von Kinematik-Elementen
Transformation | CfgKinSimpleTrans | Translation oder Rotation je nach Achse (A,B,C,X,Y,Z)
Maschinenachse | CfgKinSimpleAxis | Maschinenachse
Maschinenbett | CfgKinAnchor | Legt das Maschinenbett fest

Eine genaue Beschreibung dieser Elemente entnehmen Sie bitte dem Technischen Handbuch der Steuerung. Bitte beachten Sie, dass die Verfügbarkeit dieser Elemente von der NCK-Version abhängt.
Verfügbarkeit


Unbenutzte Elemente

Elemente einfügen Importieren
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Kinematik bearbeiten NCK / Unbenutzte Elemente
Unbenutzte Elemente
Kinematiken, die nicht in CfgKinList enthalten sind, können auf der Steuerung nicht angewählt werden. Solche Kinematiken werden in der Baumansicht mit einem ausgegrauten Symbol gekennzeichnet. Mit dem Kontrollkästchen Anwählbar legen Sie fest, ob eine Kinematik in der CfgKinList enthalten sein soll oder nicht. Beachten Sie, dass die Anzahl der zulässigen Kinematiken in der CfgKinList begrenzt ist.

Teilkinematiken und einzelne Elemente, die in keiner Kinematik verwendet werden, befinden sich am Ende der Baumansicht und sind ebenfalls mit ausgegrauten Symbolen gekennzeichnet. Sie können diese Elemente ganz normal bearbeiten und zu einer Kinematik hinzufügen, indem Sie sie über die Zwischenablage an die gewünschte Stelle kopieren. In diesem Fall werden die augegrauten Elemente automatisch entfernt.

Beim Löschen von Teilkinematiken aus einer Kinematik wird geprüft, ob diese Teilkinematik noch in einer anderen Kinematik enthalten ist. Falls diese Teilkinematik in keiner anderen Kinematik mehr enthalten ist, wird sie als unbenuztes Element an das Ende der Baumansicht angefügt. Erst wenn Sie auch dieses unbenutzte Element löschen, wird eine Teilkinematik endgültig gelöscht.


Importieren

Unbenutzte Elemente Elemente bearbeiten NCK
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Kinematik bearbeiten NCK / Importieren
Importieren
Importieren Sie Kinematiken und Teilkinematiken entweder aus einer anderen cfg-Datei, die nicht zu dem aktuellen Projekt gehört, oder fügen Sie bestehende iTNC530-Kinematiken in das aktuelle Projekt ein.

Markieren Sie zunächst die Stelle in der Baumansicht, an der Sie eine Kinematik oder Teilkinematik einfügen möchten. Mit dem Befehl Einfügen > Aus Datei importieren... wählen Sie die Datei aus, aus der Sie importieren möchten.

Importieren aus cfg-Datei

Je nachdem, welches Element in der Baumansicht markiert ist, wird die ausgewählte Datei entweder nach Kinematiken oder nach Teilkinematiken durchsucht. Werden mehrere passende Einträge gefunden, können Sie in einem Auswahldialog den Keynamen des gewünschten Elementes wählen. Anschließend wird das gewählte Element mit allen Unterelementen oberhalb der Markierung in die Baumansicht eingefügt. Keynamen, die bereits verwendet werden, werden durch neue, eindeutige Keynamen ersetzt.

Beachten Sie, dass sich alle Unterelemente in der angegebenen cfg-Datei befinden müssen. Ein Import von kompletten Kinematiken, bei denen die Teilkinematiken über mehrere Dateien verteilt sind, ist nicht möglich. In diesem Fall müssen Sie die Teilkinematiken einzeln importieren.

Importieren aus iTNC530-Kinematiken

Geben Sie als Datei eine iTNC530 Kinematiktabelle an. Zum Importieren der kompletten Kinematik geben Sie die Zuordnungstabelle an.

Die iTNC530 Kinematik wird dabei nach folgenden Regeln importiert:

  • Jedem Element wird ein eindeutiger Keyname zugewiesen. Nach Möglichkeit wird dabei der Eintrag in der DOC-Spalte verwendet. Dieser wird gegebenenfalls gekürzt bzw. um einen eindeutigen Index ergänzt. Wenn diese Spalte leer ist, wird ein Standard-Keyname wie für ein neues Element eingefügt.
  • Alle Einträge, die von der aktuellen NCK-Version noch nicht unterstützt werden, werden verworfen.
  • Bei NCK-basierten Steuerungen besteht jede Kinematik aus einer Liste von Teilkinematiken. Eine iTNC530-Kinematik aus Hauptkinematik und maximal zwei Teilkinematiken wird in eine Liste aus Teilkinematiken umgewandelt.
  • Bei der iTNC530 gibt es nur die Achsbuchstaben A,B,C,X,Y,Z. Diese werden in die Angaben für Achse und Richtung umgewandelt. Sollten andere Achs-Bezeichner (Keys) konfiguriert sein, müssen diese manuell angepasst werden.


Elemente bearbeiten NCK

Importieren Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Kinematik bearbeiten NCK / Elemente bearbeiten NCK
Elemente bearbeiten NCK
Um die Parameter eines Elementes zu editieren, klicken Sie auf das gewünschte Element in der Baumansicht. Je nach Typ des Elementes werden die passenden Eingabefelder geöffnet.

Die Änderungen werden entweder beim Verlassen des Eingabefeldes oder bei Betätigung der Eingabetaste (Return) übernommen.

Numerische Werte können Sie auch mit den kleinen Pfeil-Buttons am rechten Rand des Eingabefeldes verändern.

Eingabefeld | Attribut | Bedeutung
Keyname |  | Key, muss über alle Kinematik-Elemente eindeutig sein
Datei |  | Cfg-Datei (Speicherdatei)
Achse | axisRef | Maschinenachse
Wert | val | Wert einer Transformation
Richtung | dir | Richtung einer Transformation oder Maschinenachse
Spindel | activeSpindle | aktive Spindel
Schwenken erlaubt | tiltingAllowed | Schwenken erlaubt
Echtzeitkompensation | realtimeComp | Echtzeitkompensation

Eine genaue Beschreibung dieser Parameter entnehmen Sie bitte dem Technischen Handbuch der Steuerung.

Datei

Beachten Sie beim Ändern von Dateinamen:

  • Beim Einfügen eines neuen Elementes wird als Speicherdatei standardmäßig die cfg-Datei des übergeordneten Elements übernommen. Ändern Sie den Dateinamen, wenn eine Entität in einer anderen cfg-Datei gespeichert werden soll.
  • Wenn die Datei bereits existiert, wird sie beim Abspeichern überschrieben!
  • Geben Sie den Dateinamen so an, wie die Datei in der Dateiliste von Configfiles.cfg stehen soll (mit Umgebungsvariablen).
    Dateipfade
  • Wenn Sie bereits existierende Dateien mit dem Browse-Button ... eingeben, müssen Sie anschließend die Umgebungsvariablen manuell hinzufügen.

Keyname

Der Keyname muss über alle Kinematik-Elemente hinweg eindeutig sein. Beim Einfügen eines neuen Elementes wird automatisch ein neuer, eindeutiger Key vergeben. Dieser setzt sich zusammen aus einem Präfix, einer Kennung für den Elementtyp und einer fortlaufenden Index-Nummer. Der Präfix ergibt sich aus den ersten Zeichen des übergeordneten Elements, maximal bis zum ersten '_' -Zeichen. Der Keyname kann maximal 18 Zeichen lang sein.

Sie können diesen Standard-Keynamen durch einen sprechenden Text ersetzen, sofern dieser Text wieder eindeutig ist.

Mit dem Pfeil-Button neben dem Eingabefeld für Keynamen öffnen Sie eine Auswahlliste aller existierender Keys zu dem jeweiligen Element.

Wenn Sie mehrere Kinematiken mit z.T. gleichen Teilkinematiken angelegt haben, ergeben sich bei einer Änderung des Keynamens folgende Besonderheiten:

  • Wenn der neue Keyname bereits für eine andere Teilkinematik verwendet wird, wird die aktive Teilkinematik durch diese andere Teilkinematik ersetzt. Eventuell bereits vorhandene Elemente werden verworfen. Auf diese Weise ersetzen Sie die markierte Teilkinematik durch eine andere.
  • Wenn der neue Keyname noch nicht verwendet wird und die aktive Teilkinematik auch in anderen Kinematiken enthalten ist, kommt eine Abfrage, ob eine Kopie der Teilkinematik erstellt werden soll.
    Wenn Sie keine Kopie erstellen möchten, wird nur der Keyname geändert.
    Wenn Sie eine Kopie erstellen möchten, werden von allen Elementen der Teilkinematik Kopien erstellt. Auf diese Weise können Sie ähnliche Teilkinematiken unabhängig voneinander weiter bearbeiten.

Maschinenachsen

In der Auswahlliste Achse werden alle konfigurierten Maschinenachsen angeboten. Die Konfiguration enthält jedoch noch keine Angabe über die Richtung der Achse. Geben Sie deshalb zusätzlich die Richtung der Achse an. Ob es sich dabei um eine translatorische oder eine rotatorische Achse handelt, ist in der Konfiguration der Achse bereits festgelegt.

Tipp
Wenn die Achsbezeichnung mit den Buchstaben A,B,C,X,Y,Z beginnt, wird bei der Auswahl der Achse automatisch auch die Richtung eingestellt. Dies kann nachträglich aber wieder geändert werden.


Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig

Elemente bearbeiten NCK Verbindung zur Steuerung
KinematicsDesign / Bedienung / NCK-basierte Steuerungen / Kinematik bearbeiten NCK / Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig
Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig
Mit dem Befehl Bearbeiten > Ausschneiden schneiden Sie das ausgewählte Element aus und kopieren es in die Zwischenablage.

Mit dem Befehl Bearbeiten > Kopieren kopieren Sie das ausgewählte Element in die Zwischenablage.

Mit dem Befehl Bearbeiten > Einfügen fügen Sie das Element aus der Zwischenablage oberhalb des markierten Elementes ein.

Mit dem Befehl Bearbeiten > Löschen löschen Sie das ausgewählte Element.

Mit dem Befehl Bearbeiten > Rückgängig machen Sie die letzte Aktion rückgängig

Tipp
Beim Einfügen einer Teilkinematik in eine andere Kinematik wird dort nur ein weiterer Verweis auf diese Teilkinematik eingefügt. Wenn Sie tatsächlich eine Kopie erstellen möchten, um die Teilkinematik unabhängig weiter zu bearbeiten, kopieren Sie zunächst die gewünschte Teilkinematik und ändern dann den Keynamen.
Keyname

Von allen anderen Elementen wird beim Einfügen tatsächlich eine Kopie erstellt. Dabei wird automatisch ein neuer, eindeutiger Keyname vergeben.


Verbindung zur Steuerung

Ausschneiden / Kopieren / Einfügen / Löschen / Rückgängig Verbindungseinstellungen
KinematicsDesign / Bedienung / Verbindung zur Steuerung
Verbindung zur Steuerung


Verbindungseinstellungen

Verbindung zur Steuerung Kinematik übertragen
KinematicsDesign / Bedienung / Verbindung zur Steuerung / Verbindungseinstellungen
Verbindungseinstellungen
Mit dem Befehl Übertragen > Verbindungseinstellungen... öffnen Sie einen Dialog zur Einstellung der Verbindungsparameter.

Schnittstelle
Geben Sie hier die IP-Adresse oder den Netzwerk-Namen der Steuerung an. Für eine serielle Verbindung können Sie auch den Namen der COM-Schnittstelle eintragen (z.B.: COM1). Wenn Sie sich mit einem Programmierplatz auf demselben PC verbinden möchten, wählen Sie die Option Lokal.

PLC-Schlüsselzahl
Tragen Sie hier die PLC-Schlüsselzahl der Steuerung ein.

Verzeichnis für die übertragenen Dateien
Geben Sie das Verzeichnis an, in das die Dateien von der Steuerung übertragen werden sollen.

Tipp
Sie können dabei auch Umgebungsvariablen verwenden. Geben Sie für ein temporäres Verzeichnis z.B. %TEMP%\KineDesign an.

MP-Dateien ebenfalls übertragen
Aktivieren Sie diese Kontrollkästchen, wenn MP-Dateien ebenfalls mit übertragen werden sollen.
Elemente bearbeiten iTNC530


Kinematik übertragen

Verbindungseinstellungen Achspositionen online
KinematicsDesign / Bedienung / Verbindung zur Steuerung / Kinematik übertragen
Kinematik übertragen
Mit dem Befehl Übertragen > Alle Kinematiken von der Steuerung laden laden Sie bei der iTNC530 die aktive Zuordnungstabelle mit allen darin enthaltenen Kinematiken, Teilkinematiken und Kollisionskörpern von der Steuerung in das angegebene Verzeichnis und öffnen sie zur Bearbeitung.
Bei einer NCK-basierten Steuerung wird die Datei %OEM%\config\configfiles.cfg und alle darin aufgeführten cfg-Dateien geladen.

Mit dem Befehl Übertragen > Aktive Kinematik von der Steuerung laden laden Sie die nur die aktive Kinematik von der Steuerung in das angegebene Verzeichnis und öffnen sie zur Bearbeitung. Teilkinematiken werden ebenfalls geladen. Dieser Befehl ist bei NCK-basierten Steuerungen nicht möglich, da bei hier immer die komplette Konfiguration geladen werden muss.

Mit dem Befehl Übertragen > Werkzeugtabelle von der Steuerung laden laden Sie die aktuelle Werkzeugtabelle mit allen darin enthaltenen Werkzeugträgerkinematiken von der Steuerung in das angegebene Verzeichnis und übernehmen sie als aktive Werkzeugtabelle in das aktuelle Projekt.
Werkzeugtabelle

Mit dem Befehl Übertragen > Aktuelles Projekt zur Steuerung übertragen übertragen Sie das aktuelle Projekt auf die Steuerung. Eventuell in eine Kinematik eingehängte Werkzeugträgerkinematiken oder Spannmittel werden dabei nicht zur Steuerung übertragen.

nur iTNC530:
Wenn Sie in KinematicsDesign keine vollständige Kinematik mit Zuordnungstabelle sondern nur eine einzelne Kinematik/Teilkinematik oder nur einen einzelnen Kollisionskörper geladen haben, werden Sie aufgefordert das Zielverzeichnis anzugeben.
Beim Übertragen einer vollständigen Kinematik können Sie ein alternatives Zielverzeichnis angeben um die aktuelle Kinematik der Steuerung nicht zu überschreiben.
Wenn die Datei OEM.SYS auf der Steuerung keinen Eintrag "KINEMATIC" hat, oder der Dateiname von der aktuellen Zuordnungstabelle abweicht, wird der Eintrag in der OEM.SYS optional aktualisiert.
MP-Teildateien werden optional mit übertragen.
Verbindungseinstellungen

Nach dem Übertragen der Dateien wird die aktuelle Kinematik auf der Steuerung aktiviert.
Kinematik aktivieren

Wenn die Ausrichtung der aktuellen Maschine von der Standardeinstellung abweicht, wird zusätzlich die Datei KineDesign.ini mit der aktuellen Ausrichtung übertragen.
Ausrichtung


Achspositionen online

Kinematik übertragen Kinematik aktivieren
KinematicsDesign / Bedienung / Verbindung zur Steuerung / Achspositionen online
Achspositionen online
Mit dem Befehl Übertragen > Achspositionen online stellen Sie eine Verbindung zur Steuerung her. Dabei werden folgende Daten zyklisch aktualisiert:

  • Alle Achspositionen
  • Die aktuelle Werkzeugnummer
  • Der Aktivierungszustand von Kollisionskörpern
  • Der aktuelle Kinematik-Index
Diese Daten werden auf das aktuelle Projekt angewandt. Das muss nicht notwendigerweise die aktive Kinematik der Steuerung sein. Auf diese Weise können Sie eine lokale Kinematik auf dem PC bei einer realen Abarbeitung testen.

Zur Ermittlung des Werkzeugs und eventuell der Werzeugträger-Kinematik aus der Werkzeugnummer wird die lokale Werkzeugtabelle verwendet.

Der Kinematik-Index wird nur ausgewertet, wenn in KinematicsDesign eine Zuordnungstabelle geladen ist.

Tipp
Wenn Sie die aktuelle Kinematik der Steuerung mit online-Achswerten visualisieren möchten, übertragen Sie zunächst alle Kinematiken und die Werkzeugtabelle von der Steuerung.
Kinematik übertragen

Beachten Sie, dass diese Funktion von NCK-basierten Steuerungen nicht unterstützt wird.
Verfügbarkeit


Kinematik aktivieren

Achspositionen online Steuerung zurücksetzen
KinematicsDesign / Bedienung / Verbindung zur Steuerung / Kinematik aktivieren
Kinematik aktivieren
Mit dem Befehl Übertragen > Kinematik aktivieren aktivieren Sie die ausgewählte Kinematik auf der Steueung.

Verwenden Sie diesen Befehl, um auf eine andere Kinematik umzuschalten.


Steuerung zurücksetzen

Kinematik aktivieren Visualisierung
KinematicsDesign / Bedienung / Verbindung zur Steuerung / Steuerung zurücksetzen
Steuerung zurücksetzen
Mit dem Befehl Übertragen > Neustart der Steuerung führen Sie einen Neustart durch.


Visualisierung

Steuerung zurücksetzen Grafik allgemein
KinematicsDesign / Bedienung / Visualisierung
Visualisierung


Grafik allgemein

Visualisierung Kollisionsüberwachung
KinematicsDesign / Bedienung / Visualisierung / Grafik allgemein
Grafik allgemein
Die aktuelle Kinematik wird parallel zur Eingabe grafisch angezeigt. Außer den Kollisionskörpern werden dabei optional auch die Koordinatensysteme der jeweiligen Transformationen eingeblendet.

Das aktive Element der Baumansicht wird in der Grafik farbig hervorgehoben.

Mit dem Mausrad können Sie die Darstellung zoomen.

Mit gedrückter linker Maustaste können Sie ein Zoom-Rechteck aufziehen. Beim Loslassen der Maustaste wird die Ansicht auf das ausgewählte Rechteck gezoomt. Mit der <Esc>-Taste können Sie den Vorgang abbrechen.

Mit gedrückter rechter Maustaste können Sie die Darstellung in alle Richtungen drehen.

Mit gedrücktem Mausrad (mittlere Maustaste) können Sie die Darstellung in alle Richtungen verschieben.

Alternativ können Sie die Grafik auch mit den Pfeiltasten bedienen:

Klicken Sie zunächst in die Grafik oder betätigen Sie die F6-Taste, damit die Grafik den Eingabefokus bekommt.
Mit den Pfeiltasten alleine können Sie jetzt die Darstellung in alle Richtungen drehen.
Mit den Pfeiltasten bei gedrückter Umschalttaste können Sie die Darstellung in alle Richtungen verschieben.
Mit den Pfeiltasten auf/ab bei gedrückter Strg-Taste können Sie die Darstellung zoomen.

Mit dem Befehl Ansicht > Blinkwinkel zurücksetzen bringen Sie die Grafik wieder in den Grundzustand.

Mit dem Befehl Ansicht > Globale Transformationen können Sie für alle globalen Transformationen (außerhalb von Kollisionskörpern) das zugehörige Koordinatensystem ein- oder ausblenden.

Mit dem Befehl Ansicht > Transformationen in Kollisionskörpern können Sie für alle Transformationen innerhalb von Kollisionskörpern das zugehörige Koordinatensystem ein- oder ausblenden. Die Transformationen von selektierten Kollisisionskörpern werden unabhängig von dieser Einstellung immer angezeigt.

Unabhängig von dieser Einstellung werden die Koordinatensysteme von selektierten Elementen immer eingeblendet.

Mit dem Befehl Ansicht > Maschinenkoordinatensystem können Sie das Maschinenkoordinatensystem ein- oder ausblenden.

Mit dem Befehl Ansicht > Kollisionskörper können Sie alle Kollisionskörper ein- oder ausblenden.

Mit dem Befehl Ansicht > Drahtmodell schalten Sie zwischen Flächen- und Drahtmodell hin und her.

Mit dem Befehl Ansicht > Halbtransparent schalten Sie zwischen undurchsichtigen und halbtransparenten Kollisionskörpern hin und her.

Mit dem Befehl Ansicht > Perspektive schalten Sie zwischen perspektivischer und achsparalleler Darstellung hin und her.

Mit dem Befehl Ansicht >Bezeichnungen einblenden können Sie die Bezeichnungen von Kinematik-Objekten in der Grafik anzeigen. Sie können wahlweise alle Bezeichnungen oder nur die Bezeichnungen der markierten Objekte mit oder ohne Kollisionsziele einblenden.

Mit einem Mausklick auf ein Kollisionsobjekt oder auf eine Transformation selektieren Sie dieses Element in der Baumansicht .

Mit einem Mausklick mit gleichzeitig gedrückter Umschalt-Taste auf ein Kollisionsobjekt selektieren Sie den gesamten Kollisionskörper in der Baumansicht.


Kollisionsüberwachung

Grafik allgemein Achspositionen
KinematicsDesign / Bedienung / Visualisierung / Kollisionsüberwachung
Kollisionsüberwachung
Kollisionen anzeigen

Mit dem Befehl Ansicht > Kollisionen anzeigen können Sie wählen, ob Kollisionen grafisch angezeigt werden sollen oder nicht. Kollidierende Objekte werden andersfarbig dargestellt. Zusätzlich bekommt die Grafik einen Rahmen in der Kollisions-Farbe. Auf diese Weise werden auch Kollisionen erkannt, die außerhalb des sichtbaren Bereichs stattfinden.

Objekte, die sich im Nahbereich einer Kollision befinden, werden ebenfalls andersfarbig dargestellt. Der Grenzwert für diese Annäherung ist zusammen mit den Schrittweiten der Achs-Simulation einstellbar. Öffnen Sie dazu das Eingabefeld für die Achspositionen und klicken Sie auf den Reiter Schrittweiten.
Achspositionen

Inaktive Kollisionskörper

Kollisionskörper können aktiviert oder deaktiviert sein. Mit dem Befehl Ansicht > Inaktive Kollisionskörper ausblenden können Sie wählen, ob inaktive Kollisionskörper andersfarbig dargestellt oder komplett ausgeblendet werden sollen.

Ausgeschlossene Objekte

Alle oder einzelne Objekte eines Kollisionskörpers können von der Kollisionsüberwachung ausgeschlossen sein.

Zur Überprüfung der Ausschluss-Objekte klicken Sie auf ein Objekt eines Kollisionskörpers. In der Grafik werden alle Körper, gegen die eine Kollisionsüberwachung durchgeführt wird, andersfarbig dargestellt.

Nicht überwacht werden:

  • Objekte, die sich auf der gleichen Maschinenachse befinden
  • Objekte, die bei diesem Kollisionskörper in der Liste der ausgeschlossenen Objekte enthalten sind
  • Objekte, bei denen das selektierte Objekt in der Liste der ausgeschlossenen Objekte des zugehörigen Kollisionskörpers enthalten ist
  • Alle Objekte eines inaktiven Kollisionskörpers
Gefahr
KinematicsDesign kann nicht das Testen der DCM an der Maschine ersetzen!


Achspositionen

Kollisionsüberwachung Werkzeugtabelle
KinematicsDesign / Bedienung / Visualisierung / Achspositionen
Achspositionen
Mit dem Befehl Ansicht > Achspositionen öffnen Sie einen Bereich mit einem Eingabefeld für jede Maschinenachse der aktiven Kinematik. Damit können Sie im Offline-Betrieb Achspositionen eingeben oder mit den kleinen Pfeiltasten schrittweise vergrößern und verkleinern. Auf diese Weise können Sie z.B. die Kollisionsüberwachung testen.
Mit dem Button Zurücksetzen setzen Sie alle Achspositionen gleichzeitig auf die Nullposition.
Im Online-Betrieb werden hier die aktuellen Achspositionen der Steuerung eingeblendet.
Achspositionen online

Tipp
Wenn das Grafikfeld den Eingabefokus besitzt (klicken Sie dazu einfach in die Grafik) können die Achspositionen auch mit Tasteneingaben verändert werden. Zum Vergrößern der Achspositionen betätigen Sie die Taste mit dem zugehörigen Achs-Buchstaben. Zum Verkleinern betätigen Sie gleichzeitig die Umschalt-Taste.

Mit der Registerkarte Schrittweiten können Sie die zugehörigen Schrittweiten für das Vergrößern bzw. Verkleinern der Achspositionen verändern und den Nahbereich für die Kollisionsüberwachung definieren.

Mit der Registerkarte Nullpositionen können Sie die zugehörigen Nullpositionen verändern, die mit dem Button Zurücksetzen eingestellt werden.

Alle diese Einstellungen werden in der Datei KineDesign.ini im aktuellen Verzeichnis hinterlegt.


Werkzeugtabelle

Achspositionen STL-Dateien
KinematicsDesign / Bedienung / Visualisierung / Werkzeugtabelle
Werkzeugtabelle
Mit dem Befehl Ansicht > Werkzeugtabelle öffnen Sie einen Bereich zur Eingabe der aktiven Werkzeugtabelle.

Geben Sie bei Datei zunächst die Werkzeugtabelle an. Mit dem Browse-Button ... öffnen Sie dazu einen Datei-Auswahldialog.
Mit dem Befehl Bearbeiten > Werkzeugtabelle... können Sie die angegebene Werkzeugtabelle mit dem Notepad bearbeiten.

Tipp
Die angegebene Werkzeugtabelle wird zyklisch auf Änderung überwacht. Sobald Sie diese Datei mit irgendeinem ASCII-Editor abgespeichert haben, wird sie automatisch neu eingelesen und das aktuelle Werkzeug sowie eine eventuelle Werkzeugträgerkinematik wird aktualisiert.

Geben Sie die gewünschte Werkzeugnummer an. Mit den kleinen Pfeiltasten wählen Sie das nächste/vorherige Werkzeug aus der Werkzeugtabelle.

Diese Einstellungen werden in der Datei KineDesign.ini im aktuellen Verzeichnis hinterlegt.

Das ausgewählte Werkzeug wird in der Grafik angezeigt. Wenn für dieses Werkzeug eine Werkzeugträgerkinematik definiert ist, wird diese bei dem Platzhalter Werkzeugträgerkinematik in die Baumansicht eingefügt und kann dort auch bearbeitet werden.

Analog zur Steuerung kann sich die Werkzeugträgerkinematik in einem der folgenden Verzeichnisse befinden:

  • Kinematikverzeichnis (*.TAB)
  • ToolkinematicsPLC (*.TAB)
  • ToolkinematicsTNC (*.cfx)
Die Verzeichnisse ToolkinematicsPLC bzw.ToolkinematicsTNC werden aus der Datei KineDesign.ini entnommen. Wenn sich die Kinematikdatei aus der Werkzeugtabelle nicht in dem Kinematikverzeichnis befindet, werden anschließend die anderen beiden Verzeichnisse durchsucht. Wenn diese Datei auch dort nicht gefunden wird, oder es in KineDesign.ini noch keine Einträge für diese Verzeichnisse gibt, öffnet sich ein Datei-Eingabe-Dialog, mit dem die gesuchte Kinematikdatei angegeben werden kann. Das ausgewählte Verzeichnis wird dann in der Datei KineDesign.ini hinterlegt. Sie können diese Verzeichnisse auch nachträglich ändern.
Verzeichnisse der Werkzeugträgerkinematiken

Im Online-Betrieb wird die aktuelle Werkzeugnummer von der Steuerung ermittelt und auf die lokale Werkzeugtabelle angewandt.

Tipp
Beachten Sie, dass die Werkzeugtabelle von Drehsteuerungen von KinematicsDesign noch nicht unterstützt wird.
Verfügbarkeit

Achspositionen online, Werkzeugträgerkinematik


STL-Dateien

Werkzeugtabelle Ausrichtung
KinematicsDesign / Bedienung / Visualisierung / STL-Dateien
STL-Dateien
STL ist ein Dateiformat, bei dem dreidimensionale Datenmodelle durch eine große Anzahl von Dreiecken angenähert werden. Dieses Format ist eine Standardschnittstelle vieler CAD-Systeme.

KinematicsDesign ermöglicht die Anzeige von STL-Daten in der 3D-Ansicht um die Modellierung von Kollisionskörpern aus STL-Dateien zu vereinfachen.
Spannmittel

Mit dem Befehl Ansicht > STL-Datei öffnen Sie einen Bereich zur Darstellung von STL-Dateien. Geben Sie die gewünschte STL-Datei ein oder wählen Sie eine Datei mit dem Browse-Button ... aus.

Zur Überlagerung der STL-Darstellung mit einem bestehenden Kollisionskörper muss die STL-Ansicht an der richtigen Stelle in die Kinematik-Kette eingehängt werden. Wählen Sie dazu das Element in der Baumansicht, vor dem Sie das Koordinatensystem des STL-Objekts einhängen möchten. Öffnen Sie anschließend das Kontextmenü mit der rechten Maustaste und wählen Sie den Befehl Nullpunkt der STL-Ansicht oder klicken Sie im Eingabefeld auf den Button STL-Nullpunkt.

Mit den Eingabefeldern für die 6 Achsen können Sie die STL-Darstellung zusätzlich beliebig drehen und verschieben. Mit dem Button Zurücksetzen setzen Sie diese Einstellungen alle wieder auf 0.

Alle Einstellungen werden in der Datei KineDesign.ini hinterlegt, so dass sie bei erneutem Öffnern eines Kollisionskörpers wieder zur Verfügung stehen.


Ausrichtung

STL-Dateien Farben
KinematicsDesign / Bedienung / Visualisierung / Ausrichtung
Ausrichtung
Bei den meisten Maschinen zeigt die positive Z-Achse nach oben und die positive X-Achse nach rechts. Das ist die Standardeinstellung der Visualisierung.

Falls Ihre Maschine eine andere Ausrichtung hat, können Sie die Grafik mit dem Befehl Extras > Ausrichtung... anpassen.

Geben Sie mit den beiden Auswahllisten an, welche Achse nach oben und welche Achse nach rechts zeigt. Die dritte Achse ergibt sich daraus automatisch.

Diese Einstellungen werden in der Datei KineDesign.ini im aktuellen Verzeichnis hinterlegt. Sie werden daher immer für eine bestimmte Kinematik angegeben.

Alternative Ausrichtung
Wenn Sie mehrere Kinematiken definiert haben, kann es sein, dass einige davon eine andere Ausrichtung haben. Damit auch diese in der 3D-Ansicht lagerichtig dargestellt werden, können Sie für jede einzelne Kinematik eine alternative Ausrichtung angeben. Diese Ausrichtung wird in der Zuordnungstabelle hinterlegt (nur iTNC530).
Elemente bearbeiten iTNC530


Farben

Ausrichtung LSV-2 Fehlermeldungen
KinematicsDesign / Bedienung / Visualisierung / Farben
Farben
Mit dem Befehl Extras > Farben... können Sie die Farbeinstellungen der Grafik ändern.

Klicken Sie zunächst auf das Element in der Liste, dessen Farbe Sie ändern möchten. In dem Feld neben der Liste sehen Sie die gerade eingestellte Farbe.

Zum Ändern der Farbe klicken Sie entweder auf den Button Ändern... oder klicken Sie in das farbige Feld oder doppelklicken Sie direkt auf den Eintrag in der Liste. Wählen Sie in dem Farbauswahldialog die gewünschte Farbe.

Mit Farben definieren >> können Sie beliebige eigene Farben erzeugen. Wählen Sie dazu in dem mehrfarbigen Feld die gewünschte Farbe und mit dem Farbbalken daneben die gewünschte Helligkeit. Mit Farben hinzufügen fügen Sie die Farbe zu dem Feld Benutzerdefinierte Farben hinzu. Wählen Sie jetzt diese Farbe aus und bestätigen Sie die Auswahl mit OK.

Mit dem Button Standard stellen Sie die Standardeinstellungen wieder her.


LSV-2 Fehlermeldungen

Farben Allgemein
KinematicsDesign / LSV-2 Fehlermeldungen
LSV-2 Fehlermeldungen


Allgemein

LSV-2 Fehlermeldungen Systemfehler
KinematicsDesign / LSV-2 Fehlermeldungen / Allgemein
Allgemein
Die LSV-2-spezifischen Fehlernummern sind mit einem Offset versehen, um sie von Systemfehlern, die Windows selbst generiert, unterscheiden zu können.

Fehlertyp | Offset
Windows-Systemfehler | 0x00000000
Ausführungsfehler: Fehlermeldungen der Steuerung, die per T_ER oder T_BD Telegramme übertragen werden | 0x20001700
Protokollfehler Ethernet-Übertragung (TCP/IP) | 0x20001500
Protokollfehler serielle Übertragung (RS-232 oder RS-422) | 0x20001600


Systemfehler

Allgemein E5: Zugriff verweigert
KinematicsDesign / LSV-2 Fehlermeldungen / Systemfehler
Systemfehler
E5: Zugriff verweigert


E5: Zugriff verweigert

Systemfehler Ausführungsfehler
KinematicsDesign / LSV-2 Fehlermeldungen / Systemfehler / E5: Zugriff verweigert
E5: Zugriff verweigert
Diese Fehlermeldung erhalten Sie beim Empfangen einer Datei, wenn Sie keine Schreibberechtigung auf das Zielverzeichnis haben oder bereits eine Datei mit gleichen Namen existiert und diese schreibgeschützt ist.


Ausführungsfehler

E5: Zugriff verweigert E20001714: Formatfehler
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler
Ausführungsfehler
E20001714: Formatfehler
E20001715: Telegramm nicht erwartet
E20001716: Telegramm nicht bekannt
E20001717: Zugangsprivileg nicht erteilt
E20001718: Parameter nicht zulässig
E20001719: Vom Benutzer abgebrochen
E2000171E: Falsches (Login-)Passwort
E2000171F: Dateiname ungültig
E20001720: Datei/Ordner nicht vorhanden
E20001721: Datei kann nicht geöffnet werden
E20001722: Datei/Ordner existiert bereits
E20001723: Dateityp nicht zulässig
E20001724: Datei kann nicht gelöscht werden
E20001725: Datei kann nicht angelegt werden
E20001726: Attribut darf nicht verändert werden
E20001727: Tastencode nicht zulässig
E20001728: Maschinenparameter nicht vorhanden
E20001729: Windowtyp- bzw. Screennummer falsch oder gesperrt
E2000172A: Window nicht aktiv
E2000172B: Fehler beim Abholen von Informationen aus der TNC Anzeige
E2000172C: Tastenemulation nicht zulässig (Tastatur nicht gesperrt)
E2000172D: Dateizugriff nicht möglich
E2000172E: Falscher DNC Status
E2000172F: Ordner-/Laufwerkwechsel nicht möglich
E20001730: Datei kann nicht umbenannt werden
E20001731: Login nicht möglich
E20001732: Parameterfehler/Dateiformatfehler
E20001733: Zahlenformatfehler
E20001734: Speicheradresse nicht zulässig
E20001735: Nicht genug Speicher
E20001736: Ordner kann nicht gelöscht werden
E20001737: Ordner nicht vorhanden
E20001738: Falsche Betriebsart
E20001739: Kein weiterer FehlerAuf der Steuerung ist kein weiterer Fehler aktiv.E2000173B: Kein Schreibzugriff
E2000173C: Funktion nicht möglich, da NC noch aktiv
E2000173D: T_ER_REF_NECESSARY
E2000173E: T_ER_PLC_BUF_FULL
E2000173F: Angeforderte Information nicht gefunden
E20001740: T_ER_WRONG_FILE
E20001741: Binärcode auf Steuerung nicht aktuell
E20001742: Zu viele Tracepoints
E20001743: Datei kann nicht aktiviert werden
E20001744: Nicht genügend Systemresourcen
E20001746: DSP Kanalnummer nicht zulässig
E20001747: DSP Daten können nicht gesendet werden
E20001748: Parameter ausserhalb des gültigen Bereichs
E20001749: Gewählte Achsen ungültig
E2000174A: Achs-Streaming bereits aktiv
E2000174B: Achs-Streaming nicht aktiv
E2000174C: Achswerte ergeben eine Kollisionsbedingung
E2000174D: Mindestens einer der Achswerte außerhalb der Bereichsgrenzen
E20001750: Zu viele TCP Ports auf Steuerung geöffnet
E20001751: Kein freies Handle
E20001752: Konfiguration geändert: Remanenter PLC Speicher wurde zunächst gelöscht
E20001753: Kanalauswahl für Oszilloskop nicht zulässig
E20001754: Kanalauswahl für DSP-DEBUG nicht erlaubt
E20001755: Zu viele Oszilloskop-Kanäle
E20001756: Ungültige Kinematik
E2000175A: Übertragung noch aktiv
E2000175B: PLC Meldung noch nicht quittiert
E2000175C: Keine Verbindung
E2000175D: Kann Backupdatei nicht lesen
E2000175E: Datei in Backup nicht gefunden
E2000175F: Konverter-DLL nicht installiert
E20001760: Konverter-DLL nicht gefunden oder fehlerhaft
E20001761: Backup-Listdatei fehlerhaft
E20001763: Nicht dokumentierter LSV2 Fehler
E20001764: Datei kann nicht angelegt werden
E20001765: Nicht genügend Speicher
E20001766: Programm- und Dateiname stimmen nicht überein
E20001767: Telegramm nicht erwartet
E20001768: Fehler in Programmzeile
E20001769: Programmende bereits erreicht
E2000176A: Fehler beim Abholen von Informationen aus der TNC Anzeige
E2000176B: Window (noch) nicht definiert
E2000176C: Windowstatus zwischenzeitlich verändert
E2000176E: DNC Puffer voll
E2000176F: Übertragung abgebrochen
E20001770: Datenüberlauf Oszilloskop


E20001714: Formatfehler

Ausführungsfehler E20001715: Telegramm nicht erwartet
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001714: Formatfehler
E20001714: Formatfehler
Daten werden in einem nicht passenden Format übergeben.

Üblicherweise tritt dieser Fehler auf, wenn Sie versuchen binäre Dateien im Textmodus zu übertragen.

Überprüfen Sie die Verbindungskonfiguration. Sie können dort die binären Dateitypen anhand der Dateierweiterung definieren.


E20001715: Telegramm nicht erwartet

E20001714: Formatfehler E20001716: Telegramm nicht bekannt
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001715: Telegramm nicht erwartet
E20001715: Telegramm nicht erwartet
Von der Gegenstelle wurde ein Telegramm gesendet, das nicht in den spezifizierten Ablauf passt.


E20001716: Telegramm nicht bekannt

E20001715: Telegramm nicht erwartet E20001717: Zugangsprivileg nicht erteilt
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001716: Telegramm nicht bekannt
E20001716: Telegramm nicht bekannt
Es wurde ein Telegramm gesendet, das die Gegenstelle nicht kennt. Evtl. wird eine Softwareversion eingesetzt, die nicht zur Gegenstelle kompatibel ist.


E20001717: Zugangsprivileg nicht erteilt

E20001716: Telegramm nicht bekannt E20001718: Parameter nicht zulässig
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001717: Zugangsprivileg nicht erteilt
E20001717: Zugangsprivileg nicht erteilt
Die Steuerung lässt den Zugang für den gewünschten Dienst nicht zu.

Das kann folgende Gründe haben:

  • Eine andere Anwendung hat sich bereits für diesen Dienst angemeldet und dieser Dienst kann nur exklusiv für eine Anwendung zur Verfügung gestellt werden
  • Auf der Steuerung ist der "Externe Zugriff" ausgeschaltet.
    In der Maschinen- bzw. MOD-Betriebsart können Sie den Softkey "Externer Zugriff Ein/Aus" betätigen, um den Externen Zugriff freizugeben.
  • Ab NC Software 34049x 03 kann der Zugriff auf bestimmte Clients begrenzt sein. Dazu muss in der Datei TNC:\TNC.SYS ein Eintrag "REMOTE.PERMISSION =" vorhanden sein.
    Der Eintrag listet die Namen oder IP-Adressen von mehreren Clients auf, welche durch Strichpunkt getrennt sind.
    Beispiel: REMOTE.PERMISSION = pc123;160.1.240.2;pc2259
    Das Zugriffprivileg wird nicht erteilt wenn der Eintrag REMOTE.PERMISSION vorhanden ist, und der Client nicht in dieser Liste enthalten ist.
  • Ab NC Software 34049x xx können DNC Funktionen nur dann ausgeführt werden, wenn die kostenpflichtige SIK Option #18 (HEIDENHAIN DNC) freigeschaltet ist.


E20001718: Parameter nicht zulässig

E20001717: Zugangsprivileg nicht erteilt E20001719: Vom Benutzer abgebrochen
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001718: Parameter nicht zulässig
E20001718: Parameter nicht zulässig
Es wurde im Telegramm ein Parameter gesendet, der nicht zulässig ist.
Evtl. wird eine Softwareversion eingesetzt, die nicht zur Gegenstelle kompatibel ist.


E20001719: Vom Benutzer abgebrochen

E20001718: Parameter nicht zulässig E2000171E: Falsches (Login-)Passwort
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001719: Vom Benutzer abgebrochen
E20001719: Vom Benutzer abgebrochen
Eine länger dauernde Funktion (z.B. Dateiübertragung) wurde vom Benutzer abgebrochen.


E2000171E: Falsches (Login-)Passwort

E20001719: Vom Benutzer abgebrochen E2000171F: Dateiname ungültig
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000171E: Falsches (Login-)Passwort
E2000171E: Falsches (Login-)Passwort
Für bestimmte Dienste (z.B. Dateizugriff auf die für den Maschinenhersteller reservierte Partition) wird ein Passwort benötigt. Beim Anmelden für diesen Dienst wurde ein falsches Passwort angegeben.

Dieser Fehler kann auch beim Backup oder Restaurieren von Systemdateien auftreten, z.B. wenn Sie ein Maschinenbackup oder vollständiges Backup durchführen. Ursache ist in diesem Fall eine unterschiedliche Zeiteinstellung auf PC und Steuerung, da für den Zugriff aus der aktuellen Uhrzeit automatisch ein spezielles Passwort gebildet wird, das auf der Steuerung überprüft wird.


E2000171F: Dateiname ungültig

E2000171E: Falsches (Login-)Passwort E20001720: Datei/Ordner nicht vorhanden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000171F: Dateiname ungültig
E2000171F: Dateiname ungültig
Es wurde ein ungültiger Dateiname angegeben, der nicht der Syntax der Steuerung entspricht.

Sie können Dateien/Verzeichnisse mit oder ohne Verzeichnispfad angeben. Die einzelnen Unterverzeichnisnamen sind dabei durch "\" (Backslash) voneinander getrennt. Relative Verzeichnispfade von übergeordneten Verzeichnissen mit "..\" sind ebenfalls zulässig.

Die Syntax für aktuelles Verzeichnis ".\"ist nicht zulässig.

Die Länge des Dateipfads (Verzeichnispfad mit Dateinamen) ist auf 79 bzw. 255 Zeichen limitiert.

Beachten Sie auch, dass nicht alle Steuerungstypen, die LSV-2 unterstützen, Verzeichnisse in ihrem Dateisystem bieten.


E20001720: Datei/Ordner nicht vorhanden

E2000171F: Dateiname ungültig E20001721: Datei kann nicht geöffnet werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001720: Datei/Ordner nicht vorhanden
E20001720: Datei/Ordner nicht vorhanden
Es wurde ein Name einer Datei oder eines Verzeichnisses angegeben, der auf der Steuerung nicht vorhanden ist.

Sie können Dateien/Verzeichnisse mit oder ohne Verzeichnispfad angeben. Die einzelnen Unterverzeichnisnamen sind dabei durch "\" (Backslash) voneinander getrennt. Relative Verzeichnispfade von übergeordneten Verzeichnissen mit "..\" sind ebenfalls zulässig.

Die Syntax für aktuelles Verzeichnis ".\"ist nicht zulässig.

Beachten Sie bitte, dass nicht alle Steuerungstypen, die LSV-2 unterstützen, Verzeichnisse in ihrem Dateisystem bieten.


E20001721: Datei kann nicht geöffnet werden

E20001720: Datei/Ordner nicht vorhanden E20001722: Datei/Ordner existiert bereits
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001721: Datei kann nicht geöffnet werden
E20001721: Datei kann nicht geöffnet werden
Die angegebene Datei kann nicht geöffnet werden.


E20001722: Datei/Ordner existiert bereits

E20001721: Datei kann nicht geöffnet werden E20001723: Dateityp nicht zulässig
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001722: Datei/Ordner existiert bereits
E20001722: Datei/Ordner existiert bereits
Die angegebene Datei oder das Verzeichnis existiert bereits und kann daher nicht angelegt werden. Evtl. ist die Datei schreibgeschützt und kann daher nicht überschrieben werden.


E20001723: Dateityp nicht zulässig

E20001722: Datei/Ordner existiert bereits E20001724: Datei kann nicht gelöscht werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001723: Dateityp nicht zulässig
E20001723: Dateityp nicht zulässig
Der durch die Dateierweiterung festgelegte Dateityp ist für die Aktion nicht zulässig. Sie können beispielsweise Dateien, die als Binärtyp registriert sind nicht binär übertragen, wenn die angeschlossene Steuerung binärübertragung nicht unterstützt.


E20001724: Datei kann nicht gelöscht werden

E20001723: Dateityp nicht zulässig E20001725: Datei kann nicht angelegt werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001724: Datei kann nicht gelöscht werden
E20001724: Datei kann nicht gelöscht werden
Die angegebene Datei kann nicht gelöscht werden. Vermutlich ist sie schreibgeschützt oder gerade im NC Editor geöffnet.


E20001725: Datei kann nicht angelegt werden

E20001724: Datei kann nicht gelöscht werden E20001726: Attribut darf nicht verändert werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001725: Datei kann nicht angelegt werden
E20001725: Datei kann nicht angelegt werden
Die angegebene Datei kann nicht angelegt werden. Vermutlich ist das Verzeichnis, in dem sie angelegt werden soll, nicht vorhanden oder Sie haben keine Zugriffsberechtigung für dieses Verzeichnis.


E20001726: Attribut darf nicht verändert werden

E20001725: Datei kann nicht angelegt werden E20001727: Tastencode nicht zulässig
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001726: Attribut darf nicht verändert werden
E20001726: Attribut darf nicht verändert werden
Zur Zeit kann nur das Schreibschutz- (Protect-) Attribut verändert werden.


E20001727: Tastencode nicht zulässig

E20001726: Attribut darf nicht verändert werden E20001728: Maschinenparameter nicht vorhanden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001727: Tastencode nicht zulässig
E20001727: Tastencode nicht zulässig
Sie haben einen für die angeschlossene Steuerung ungültigen Tastencode eingegeben.


E20001728: Maschinenparameter nicht vorhanden

E20001727: Tastencode nicht zulässig E20001729: Windowtyp- bzw. Screennummer falsch oder gesperrt
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001728: Maschinenparameter nicht vorhanden
E20001728: Maschinenparameter nicht vorhanden
Sie haben einen für die angeschlossene Steuerung ungültigen Maschinenparameter eingegeben.


E20001729: Windowtyp- bzw. Screennummer falsch oder gesperrt

E20001728: Maschinenparameter nicht vorhanden E2000172A: Window nicht aktiv
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001729: Windowtyp- bzw. Screennummer falsch oder gesperrt
E20001729: Windowtyp- bzw. Screennummer falsch oder gesperrt
TNC 42x: Es wurden Informationen angefordert, die nicht verfügbar sind.


E2000172A: Window nicht aktiv

E20001729: Windowtyp- bzw. Screennummer falsch oder gesperrt E2000172B: Fehler beim Abholen von Informationen aus der TNC Anzeige
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000172A: Window nicht aktiv
E2000172A: Window nicht aktiv
TNC 42x: Es wurden Informationen zu einem nicht aktiven Fenster angefordert.


E2000172B: Fehler beim Abholen von Informationen aus der TNC Anzeige

E2000172A: Window nicht aktiv E2000172C: Tastenemulation nicht zulässig (Tastatur nicht gesperrt)
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000172B: Fehler beim Abholen von Informationen aus der TNC Anzeige
E2000172B: Fehler beim Abholen von Informationen aus der TNC Anzeige
TNC 42x: Allgemeiner Fehler beim Zugriff auf die Anzeige.

iTNC530: Verarbeitungsfehler beim Screen-Dump; Verarbeitungsfehler bei der Oszilloskopfunktion, kontaktieren Sie HEIDENHAIN.


E2000172C: Tastenemulation nicht zulässig (Tastatur nicht gesperrt)

E2000172B: Fehler beim Abholen von Informationen aus der TNC Anzeige E2000172D: Dateizugriff nicht möglich
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000172C: Tastenemulation nicht zulässig (Tastatur nicht gesperrt)
E2000172C: Tastenemulation nicht zulässig (Tastatur nicht gesperrt)
Tastenkommandos können nur dann an die Steuerung abgesetzt werden, wenn die Steuerungstastatur zuvor gesperrt wurde.


E2000172D: Dateizugriff nicht möglich

E2000172C: Tastenemulation nicht zulässig (Tastatur nicht gesperrt) E2000172E: Falscher DNC Status
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000172D: Dateizugriff nicht möglich
E2000172D: Dateizugriff nicht möglich
Dieser Fehler tritt oft in Zusammenhang mit dem Auslesen der Datei TOOL.T insbesondere bei serieller Übertragung auf. Die Übertragung über die serielle Schnittstelle lässt bei älteren Softwareversionen eine maximale Zeilenlänge von ca. 250 Zeichen zu. Wenn die Datei TOOL.T so konfiguriert ist, dass längere Tabellenzeilen entstehen, wird dieser Fehler ausgegeben.

Abhilfe:

  • Einzelne nicht benötigte Spalten ausblenden
  • Neueste NC Software aufspielen, die auch Zeilenlängen bis 1024 Zeichen zulässt

Dieser Fehler tritt auch beim Übertragen von längeren NC Programmen zum Programmierplatz (ab Software 340494 04) auf.
In der Demoversion wird nach 100 NC-Sätzen das Programm abgeschnitten und dieser Fehler ausgegeben.


E2000172E: Falscher DNC Status

E2000172D: Dateizugriff nicht möglich E2000172F: Ordner-/Laufwerkwechsel nicht möglich
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000172E: Falscher DNC Status
E2000172E: Falscher DNC Status
Telegramm im aktuellen DNC-Zustand nicht zulässig


E2000172F: Ordner-/Laufwerkwechsel nicht möglich

E2000172E: Falscher DNC Status E20001730: Datei kann nicht umbenannt werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000172F: Ordner-/Laufwerkwechsel nicht möglich
E2000172F: Ordner-/Laufwerkwechsel nicht möglich
Keine Information verfügbar


E20001730: Datei kann nicht umbenannt werden

E2000172F: Ordner-/Laufwerkwechsel nicht möglich E20001731: Login nicht möglich
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001730: Datei kann nicht umbenannt werden
E20001730: Datei kann nicht umbenannt werden
Das Dateisystem auf der Steuerung kann die Datei nicht umbenennen.


E20001731: Login nicht möglich

E20001730: Datei kann nicht umbenannt werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001731: Login nicht möglich
E20001731: Login nicht möglich
Die Anmeldung für einen bestimmten Dienst wurde abgelehnt.

Überprüfen Sie, ob andere Anwendungen diesen Dienst nutzen.


E20001732: Parameterfehler/Dateiformatfehler

E20001731: Login nicht möglich E20001733: Zahlenformatfehler
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001732: Parameterfehler/Dateiformatfehler
E20001732: Parameterfehler/Dateiformatfehler
Eine Datei, die im Binärformat gespeichert ist, hat eine Dateiversion, die von der aktuellen NC Software nicht unterstützt wird.

Eventuell wurde vor/nach einem Softwaretausch das Konvertieren der Dateien nicht durchgeführt.


E20001733: Zahlenformatfehler

E20001734: Speicheradresse nicht zulässig
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001733: Zahlenformatfehler
E20001733: Zahlenformatfehler
Keine Information verfügbar


E20001734: Speicheradresse nicht zulässig

E20001733: Zahlenformatfehler E20001735: Nicht genug Speicher
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001734: Speicheradresse nicht zulässig
E20001734: Speicheradresse nicht zulässig
Beim Zugriff auf den PLC Speicher wurde eine nicht zulässige Adresse angegeben.

Ursache für diese Fehlermeldung kann auch eine zwischenzeitlich geänderte PLC Speicheraufteilung sein, die durch Änderung entsprechender Einträge der Konfigurationsdatei auf der Steuerung verursacht wurde.


E20001735: Nicht genug Speicher

E20001734: Speicheradresse nicht zulässig E20001736: Ordner kann nicht gelöscht werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001735: Nicht genug Speicher
E20001735: Nicht genug Speicher
Das Dateisystem auf der Steuerung hat erkannt, dass für den gewünschten Auftrag nicht genügend Speicher zur Verfügung steht.


E20001736: Ordner kann nicht gelöscht werden

E20001735: Nicht genug Speicher E20001737: Ordner nicht vorhanden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001736: Ordner kann nicht gelöscht werden
E20001736: Ordner kann nicht gelöscht werden
Es wurde versucht einen Ordner zu löschen, der noch Dateien beinhaltet.

Siehe auch E20001724: Datei kann nicht gelöscht werden


E20001737: Ordner nicht vorhanden

E20001736: Ordner kann nicht gelöscht werden E20001738: Falsche Betriebsart
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001737: Ordner nicht vorhanden
E20001737: Ordner nicht vorhanden
Es wurde versucht einen Ordner zu löschen oder in einen Ordner zu wechseln, der nicht existiert.
Bei der ITNC 530 wird der Fehler E20001720 ausgegeben.

E20001720: Datei/Ordner nicht vorhanden


E20001738: Falsche Betriebsart

E20001737: Ordner nicht vorhanden E20001739: Kein weiterer FehlerAuf der Steuerung ist kein weiterer Fehler aktiv.E2000173B: Kein Schreibzugriff
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001738: Falsche Betriebsart
E20001738: Falsche Betriebsart
In der aktuellen Betriebsart kann der Dienst nicht durchgeführt werden.

Das kann eine DNC Funktion sein, die eine bestimmte NC Betriebsart voraussetzt, oder auch ein Überschreiben eines Tabellenteils, wenn diese Tabelle gerade aktiv editiert wird (Softkey Edit "On").


E20001739: Kein weiterer FehlerAuf der Steuerung ist kein weiterer Fehler aktiv.E2000173B: Kein Schreibzugriff

E20001738: Falsche Betriebsart E2000173C: Funktion nicht möglich, da NC noch aktiv
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001739: Kein weiterer FehlerAuf der Steuerung ist kein weiterer Fehler aktiv.E2000173B: Kein Schreibzugriff
E20001739: Kein weiterer FehlerAuf der Steuerung ist kein weiterer Fehler aktiv.E2000173B: Kein Schreibzugriff
Die Steuerung verweigert die für diese Funktion benötigte Schreibaktion.

Setzen von Preseteinträgen: Die angegebene Zeile ist gelockt.


E2000173C: Funktion nicht möglich, da NC noch aktiv

E20001739: Kein weiterer FehlerAuf der Steuerung ist kein weiterer Fehler aktiv.E2000173B: Kein Schreibzugriff
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000173C: Funktion nicht möglich, da NC noch aktiv
E2000173C: Funktion nicht möglich, da NC noch aktiv
PLC Programm oder Softkey Menü können nicht aktiviert werden, wenn die Steuerung gerade Programme abarbeitet.

Der DNC Betrieb kann nicht aufgenommen werden, wenn die Steuerung gerade Programme abarbeitet.


E2000173D: T_ER_REF_NECESSARY

E2000173C: Funktion nicht möglich, da NC noch aktiv
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000173D: T_ER_REF_NECESSARY
E2000173D: T_ER_REF_NECESSARY
Für den DNC Betrieb mit der TNC 406/416 darf für die Funktion NC Start die Steuerung nicht in der Betriebsart Referenz fahren sein.


E2000173E: T_ER_PLC_BUF_FULL

E2000173F: Angeforderte Information nicht gefunden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000173E: T_ER_PLC_BUF_FULL
E2000173E: T_ER_PLC_BUF_FULL
Eine Meldung an die PLC konnte nicht uebertragen werden, da die PLC die vorherige Nachricht noch nicht verarbeitet hat.

Wiederholen Sie den Sendeversuch.


E2000173F: Angeforderte Information nicht gefunden

KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000173F: Angeforderte Information nicht gefunden
E2000173F: Angeforderte Information nicht gefunden
Es ist keine Tabellenzeile/kein Datenelement vorhanden, die der Anfrage entspricht.


E20001740: T_ER_WRONG_FILE

E2000173F: Angeforderte Information nicht gefunden E20001741: Binärcode auf Steuerung nicht aktuell
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001740: T_ER_WRONG_FILE
E20001740: T_ER_WRONG_FILE
PLC Debug, Funktion Trace in source: Falscher Dateityp ( Versionsinfo in 1. Zeile defekt)


E20001741: Binärcode auf Steuerung nicht aktuell

E20001742: Zu viele Tracepoints
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001741: Binärcode auf Steuerung nicht aktuell
E20001741: Binärcode auf Steuerung nicht aktuell
PLC Debug, Funktion Trace in source: Der PLC Binärcode, der mit PLCdesign erstellt wurde, stimmt nicht mit dem auf der Steuerung aktiven Code überein.

Überprüfen Sie, ob Sie die aktuellen Quelldateien/den Zwischencode auf die Steuerung übertragen und aktiviert haben.

Überprüfen Sie anhand der Dokumentationsdateien (<Hauptdateiname>.lst), im Abschnitt Configuration Defines: ob Sie auf der Steuerung und in PLCdesign die gleichen Konfigurationsdefinitionen für die bedingte Kompilierung verwenden.


E20001742: Zu viele Tracepoints

E20001741: Binärcode auf Steuerung nicht aktuell E20001743: Datei kann nicht aktiviert werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001742: Zu viele Tracepoints
E20001742: Zu viele Tracepoints
PLC Debug, Funktion Trace in source: Remote Debug Anwendung hat versucht mehr Tracepoints zu setzen, als von der Steuerung unterstützt werden.


E20001743: Datei kann nicht aktiviert werden

E20001742: Zu viele Tracepoints E20001744: Nicht genügend Systemresourcen
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001743: Datei kann nicht aktiviert werden
E20001743: Datei kann nicht aktiviert werden
Angegebenes PLC Programm oder Softkey Menü können nicht aktiviert werden.

Mögliche Fehlerursachen:

Das PLC Programm kann nicht übersetzt werden:
Übersetzen Sie das PLC Programm manuell auf der Steuerung und kontrollieren Sie das Ausgabefenster auf Fehlermeldungen.

Das PLC Programm kann nicht geladen und gestartet werden:
Ein Fehlerprotokoll hierzu finden Sie bei der iTNC530 in der Datei PLC:\PLCDEBUG.LOG.

Die Softkeyresource kann nicht generiert, eingelesen oder aktiviert werden.
Generieren Sie die Softkeyresource manuell auf der Steuerung und kontrollieren Sie das Ausgabefenster auf Fehlermeldungen. Ist hier kein Fehler eingetragen, dann kontrollieren Sie den Inhalt des Aktivierungsprotokolls <soft key project>.spj.log.


E20001744: Nicht genügend Systemresourcen

E20001743: Datei kann nicht aktiviert werden E20001746: DSP Kanalnummer nicht zulässig
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001744: Nicht genügend Systemresourcen
E20001744: Nicht genügend Systemresourcen
Es stehen nicht genügend System-Resourcen auf der Steuerung zur verfügung, um die Aufgabe durchzuführen.


E20001746: DSP Kanalnummer nicht zulässig

E20001744: Nicht genügend Systemresourcen E20001747: DSP Daten können nicht gesendet werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001746: DSP Kanalnummer nicht zulässig
E20001746: DSP Kanalnummer nicht zulässig
Bei der Anforderung wurde ein nicht verfügbarer Kanal angegeben.

Antwort des DSP passt nicht zur Anfrage.


E20001747: DSP Daten können nicht gesendet werden

E20001746: DSP Kanalnummer nicht zulässig E20001748: Parameter ausserhalb des gültigen Bereichs
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001747: DSP Daten können nicht gesendet werden
E20001747: DSP Daten können nicht gesendet werden
Daten können nicht interpretiert werden, oder Kommandos kommen so schnell, dass sie vom DSP nicht rechtzeitig abgeholt werden können.


E20001748: Parameter ausserhalb des gültigen Bereichs

E20001747: DSP Daten können nicht gesendet werden E20001749: Gewählte Achsen ungültig
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001748: Parameter ausserhalb des gültigen Bereichs
E20001748: Parameter ausserhalb des gültigen Bereichs
Sie haben für die Konfiguration Werte angegeben, die außerhalb des gültigen Bereichs liegen.


E20001749: Gewählte Achsen ungültig

E20001748: Parameter ausserhalb des gültigen Bereichs E2000174A: Achs-Streaming bereits aktiv
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001749: Gewählte Achsen ungültig
E20001749: Gewählte Achsen ungültig
Sie haben Achsen angegeben, die in der aktuellen Steuerungskonfiguration nicht gültig sind.


E2000174A: Achs-Streaming bereits aktiv

E20001749: Gewählte Achsen ungültig E2000174B: Achs-Streaming nicht aktiv
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000174A: Achs-Streaming bereits aktiv
E2000174A: Achs-Streaming bereits aktiv
Sie haben versucht das Achs-Streaming zu aktivieren oder Einstellungen zu verändern, obwohl das Achs-Streaming bereits aktiv ist.


E2000174B: Achs-Streaming nicht aktiv

E2000174A: Achs-Streaming bereits aktiv E2000174C: Achswerte ergeben eine Kollisionsbedingung
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000174B: Achs-Streaming nicht aktiv
E2000174B: Achs-Streaming nicht aktiv
Sie haben versucht das Achs-Streaming zu stoppen, obwohl es gar nicht aktiv ist.


E2000174C: Achswerte ergeben eine Kollisionsbedingung

E2000174B: Achs-Streaming nicht aktiv E2000174D: Mindestens einer der Achswerte außerhalb der Bereichsgrenzen
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000174C: Achswerte ergeben eine Kollisionsbedingung
E2000174C: Achswerte ergeben eine Kollisionsbedingung
Die angegebene Achsposition ist nicht erreichbar, weil sie außerhalb der Bereichsgrenzen liegt oder sich eine Kollision ergeben würde.


E2000174D: Mindestens einer der Achswerte außerhalb der Bereichsgrenzen

E2000174C: Achswerte ergeben eine Kollisionsbedingung E20001750: Zu viele TCP Ports auf Steuerung geöffnet
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000174D: Mindestens einer der Achswerte außerhalb der Bereichsgrenzen
E2000174D: Mindestens einer der Achswerte außerhalb der Bereichsgrenzen
Sie haben versucht die Maschinenachsen auf eine nicht erreichbare Position zu setzen.
Die Softwareendschalter, die diese Bereichsgrenzen definieren, werden in den Maschinenparametern 910.x (obere Grenze) und 920.x (untere Grenze) festgelegt.


E20001750: Zu viele TCP Ports auf Steuerung geöffnet

E2000174D: Mindestens einer der Achswerte außerhalb der Bereichsgrenzen E20001751: Kein freies Handle
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001750: Zu viele TCP Ports auf Steuerung geöffnet
E20001750: Zu viele TCP Ports auf Steuerung geöffnet
Die Steuerung unterstützt eine begrenzt Anzahl gleichzeitig geöffneter TCP/IP Ports. Schließen Sie Anwendungen, die Sie gerade nicht brauchen.

Tipp
Ein Port steht erst nach einer gewissen Zeit, nachdem er geschlossen wurde, wieder zur Verfügung


E20001751: Kein freies Handle

E20001750: Zu viele TCP Ports auf Steuerung geöffnet E20001752: Konfiguration geändert: Remanenter PLC Speicher wurde zunächst gelöscht
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001751: Kein freies Handle
E20001751: Kein freies Handle
Die Kommunikations-Library unterstützt max. 16 Verbindungen in einer Anwendung.


E20001752: Konfiguration geändert: Remanenter PLC Speicher wurde zunächst gelöscht

E20001751: Kein freies Handle E20001753: Kanalauswahl für Oszilloskop nicht zulässig
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001752: Konfiguration geändert: Remanenter PLC Speicher wurde zunächst gelöscht
E20001752: Konfiguration geändert: Remanenter PLC Speicher wurde zunächst gelöscht
Beim Kompilieren de PLC Programms wurde festgestellt, dass sich die Speicherkonfiguration durch das neue PLC Programm ändert. Um einen definierten Ausgangzustand zu erreichen wird in einem solchen Fall der PLC Speicher gelöscht und diese Meldung ausgegeben.
Die Kompilierung muss anschließend noch einmal gestartet werden.


E20001753: Kanalauswahl für Oszilloskop nicht zulässig

E20001752: Konfiguration geändert: Remanenter PLC Speicher wurde zunächst gelöscht E20001754: Kanalauswahl für DSP-DEBUG nicht erlaubt
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001753: Kanalauswahl für Oszilloskop nicht zulässig
E20001753: Kanalauswahl für Oszilloskop nicht zulässig
Es wurde eine nicht zulässige Kombination von Kanälen zur Aufzeichnung ausgewählt.
So gibt es z.B. für bestimmte Kanäle, die von einer CC Hardware aufgezeichnet werden, die Einschränkung, dass max. 4 Kanäle dieses Typs gleichzeitig aufgezeichnet werden können.


E20001754: Kanalauswahl für DSP-DEBUG nicht erlaubt

E20001753: Kanalauswahl für Oszilloskop nicht zulässig E20001755: Zu viele Oszilloskop-Kanäle
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001754: Kanalauswahl für DSP-DEBUG nicht erlaubt
E20001754: Kanalauswahl für DSP-DEBUG nicht erlaubt
Die DSP-DEBUG Kanäle werden über Maschinenparameter konfiguriert.
Überprüfen Sie die aktuelle Einstellung!


E20001755: Zu viele Oszilloskop-Kanäle

E20001754: Kanalauswahl für DSP-DEBUG nicht erlaubt E20001756: Ungültige Kinematik
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001755: Zu viele Oszilloskop-Kanäle
E20001755: Zu viele Oszilloskop-Kanäle
Sie wollen mehr Kanäle gleichzeitig aufzeichnen als die Steuerung unterstützt.
Verringern Sie die Anzahl!


E20001756: Ungültige Kinematik

E20001755: Zu viele Oszilloskop-Kanäle E2000175A: Übertragung noch aktiv
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001756: Ungültige Kinematik
E20001756: Ungültige Kinematik
Beim Aktivieren einer Kinematik ist ein Fehler in der Kinematikbeschreibung erkannt worden.


E2000175A: Übertragung noch aktiv

E20001756: Ungültige Kinematik E2000175B: PLC Meldung noch nicht quittiert
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000175A: Übertragung noch aktiv
E2000175A: Übertragung noch aktiv
Länger dauernde Übertragungen können im Allgemeinen nicht durch andere Übertragungsfunktionen ausser Meldungen unterbrochen werden, wenn Sie über den gleichen Übertragungskanal abgewickelt werden.


E2000175B: PLC Meldung noch nicht quittiert

E2000175A: Übertragung noch aktiv E2000175C: Keine Verbindung
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000175B: PLC Meldung noch nicht quittiert
E2000175B: PLC Meldung noch nicht quittiert
Die PLC Meldungen dürfen erst dann abgesetzt werden, wenn die vorherige Meldung mit einer Quittierungsmeldung (X_OK) beantwortet worden ist.


E2000175C: Keine Verbindung

E2000175B: PLC Meldung noch nicht quittiert E2000175D: Kann Backupdatei nicht lesen
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000175C: Keine Verbindung
E2000175C: Keine Verbindung
Die gewünschte Verbindung konnte nicht hergestellt werden.


E2000175D: Kann Backupdatei nicht lesen

E2000175C: Keine Verbindung E2000175E: Datei in Backup nicht gefunden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000175D: Kann Backupdatei nicht lesen
E2000175D: Kann Backupdatei nicht lesen
Die angegebene Backupdatei ist entweder nicht vorhanden oder hat nicht das korrekte Format.


E2000175E: Datei in Backup nicht gefunden

E2000175D: Kann Backupdatei nicht lesen E2000175F: Konverter-DLL nicht installiert
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000175E: Datei in Backup nicht gefunden
E2000175E: Datei in Backup nicht gefunden
Die angegebene Datei ist nicht in der Backupdatei vorhanden. Evtl. passt die Dateiliste (.lst) nicht zur eigentlichen Backup-Datei (.bck)


E2000175F: Konverter-DLL nicht installiert

E2000175E: Datei in Backup nicht gefunden E20001760: Konverter-DLL nicht gefunden oder fehlerhaft
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000175F: Konverter-DLL nicht installiert
E2000175F: Konverter-DLL nicht installiert
Für die Online-Konvertierung werden eine spezielle DLL-Datei und weitere Konfigurationsdateien benötigt. Diese Fehlermeldung erhalten Sie, wenn die Übertragungsfunktion im Konverter-Modus aufgerufen wurde, ohne dass die benötigten Konverterdateien installiert worden sind.


E20001760: Konverter-DLL nicht gefunden oder fehlerhaft

E2000175F: Konverter-DLL nicht installiert E20001761: Backup-Listdatei fehlerhaft
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001760: Konverter-DLL nicht gefunden oder fehlerhaft
E20001760: Konverter-DLL nicht gefunden oder fehlerhaft
Für die Online-Konvertierung wird eine spezielle DLL-Datei und weitere Konfigurationsdateien benötigt. Falls sie nicht im angegebenen Verzeichnis gefunden werden, werden sie von der angeschlossenen Steuerung geladen.

Die angeschlossene Steuerung hat keine gültige DLL Datei oder es werden nicht alle Konfigurationsdateien gefunden.


E20001761: Backup-Listdatei fehlerhaft

E20001760: Konverter-DLL nicht gefunden oder fehlerhaft E20001763: Nicht dokumentierter LSV2 Fehler
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001761: Backup-Listdatei fehlerhaft
E20001761: Backup-Listdatei fehlerhaft
Die Liste der gesicherten/gescannten Dateien liegt in einem speziellen ASCII Format vor. Insbesondere darf die Versionsinformation in der ersten Zeile für die Erkennung als List-Datei nicht verändert werden.


E20001763: Nicht dokumentierter LSV2 Fehler

E20001761: Backup-Listdatei fehlerhaft E20001764: Datei kann nicht angelegt werden
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001763: Nicht dokumentierter LSV2 Fehler
E20001763: Nicht dokumentierter LSV2 Fehler
Kontaktieren Sie HEIDENHAIN.


E20001764: Datei kann nicht angelegt werden

E20001763: Nicht dokumentierter LSV2 Fehler E20001765: Nicht genügend Speicher
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001764: Datei kann nicht angelegt werden
E20001764: Datei kann nicht angelegt werden
Das Dateisystem auf der Steuerung kann die angegebene Datei nicht anlegen.


E20001765: Nicht genügend Speicher

E20001764: Datei kann nicht angelegt werden E20001766: Programm- und Dateiname stimmen nicht überein
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001765: Nicht genügend Speicher
E20001765: Nicht genügend Speicher
Das Dateisystem auf der Steuerung hat erkannt, dass für den gewünschten Auftrag nicht genügend Speicher zur Verfügung steht.


E20001766: Programm- und Dateiname stimmen nicht überein

E20001765: Nicht genügend Speicher E20001767: Telegramm nicht erwartet
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001766: Programm- und Dateiname stimmen nicht überein
E20001766: Programm- und Dateiname stimmen nicht überein
Dieser Fehler trat nur bei Steuerungen TNC 407 - 415 auf.

Es wurde überprüft, ob der Datei-Header identisch mit dem angegebenen Zieldateinamen ist.


E20001767: Telegramm nicht erwartet

E20001766: Programm- und Dateiname stimmen nicht überein E20001768: Fehler in Programmzeile
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001767: Telegramm nicht erwartet
E20001767: Telegramm nicht erwartet
Von der Gegenstelle wurde ein Telegramm gesendet, das nicht in den spezifizierten Ablauf passt.


E20001768: Fehler in Programmzeile

E20001767: Telegramm nicht erwartet E20001769: Programmende bereits erreicht
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001768: Fehler in Programmzeile
E20001768: Fehler in Programmzeile
Beim Umwandeln des Textformates der NC Datei in das interne Binärformat ist ein Fehler aufgetreten.


E20001769: Programmende bereits erreicht

E20001768: Fehler in Programmzeile E2000176A: Fehler beim Abholen von Informationen aus der TNC Anzeige
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001769: Programmende bereits erreicht
E20001769: Programmende bereits erreicht
TNC 4x6: Es wurde versucht ein Programm zu starten, das bereits fertig abgearbeitet ist.


E2000176A: Fehler beim Abholen von Informationen aus der TNC Anzeige

E20001769: Programmende bereits erreicht E2000176B: Window (noch) nicht definiert
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000176A: Fehler beim Abholen von Informationen aus der TNC Anzeige
E2000176A: Fehler beim Abholen von Informationen aus der TNC Anzeige
TNC 42x: Allgemeiner Fehler beim Zugriff auf die Anzeige.


E2000176B: Window (noch) nicht definiert

E2000176A: Fehler beim Abholen von Informationen aus der TNC Anzeige E2000176C: Windowstatus zwischenzeitlich verändert
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000176B: Window (noch) nicht definiert
E2000176B: Window (noch) nicht definiert
TNC 42x: Es wurden Informationen zu einem Fenster angefordert, das noch gar nicht verfügbar ist.


E2000176C: Windowstatus zwischenzeitlich verändert

E2000176B: Window (noch) nicht definiert E2000176E: DNC Puffer voll
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000176C: Windowstatus zwischenzeitlich verändert
E2000176C: Windowstatus zwischenzeitlich verändert
TNC 42x: Es wurden Informationen zu einem Fenster angefordert, das für die Anzeige nicht mehr relevant ist.


E2000176E: DNC Puffer voll

E2000176C: Windowstatus zwischenzeitlich verändert E2000176F: Übertragung abgebrochen
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000176E: DNC Puffer voll
E2000176E: DNC Puffer voll
Mit dieser Meldung meldet die Steuerung, dass Sie im Augenblick keine weiteren Datensätze aufnehmen kann.


E2000176F: Übertragung abgebrochen

E2000176E: DNC Puffer voll E20001770: Datenüberlauf Oszilloskop
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E2000176F: Übertragung abgebrochen
E2000176F: Übertragung abgebrochen
Die Übertragung wurde vom Benutzer oder von der Gegenseite abgebrochen.


E20001770: Datenüberlauf Oszilloskop

E2000176F: Übertragung abgebrochen Übertragungsfehler (TCP/IP)
KinematicsDesign / LSV-2 Fehlermeldungen / Ausführungsfehler / E20001770: Datenüberlauf Oszilloskop
E20001770: Datenüberlauf Oszilloskop
Wenn die Datenübertragung langsamer ist, als neue Daten anfallen, läuft der interne Puffer nach einer gewissen Zeit über. Dies passiert eigentlich nur bei serieller Übertragung.

  • Wählen Sie immer die schnellstmögliche Baudrate.
  • Überprüfen Sie, ob die Übertragung nicht durch Störungen Blockwiederholungen benötigt und damit gebremst wird. Evtl. ist ein nicht ausreichend geschirmtes Kabel die Ursache.
  • Reduzieren Sie die Anzahl der zu überwachenden Kanäle.


Übertragungsfehler (TCP/IP)

E20001770: Datenüberlauf Oszilloskop E20001501: Kein freies Handle
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (TCP/IP)
Übertragungsfehler (TCP/IP)
E20001501: Kein freies Handle
E20001502: Keine passende WINSOCK DLL im System
E20001503: Fehler beim Socket einrichten
E20001504: Fehlerhafte Host-Adresse
E20001505: Fehler beim Verbindungsaufbau zur Steuerung
E20001506: Fehler TCP Zeitüberwachung
E20001507: Verbindung abgebrochen


E20001501: Kein freies Handle

Übertragungsfehler (TCP/IP) E20001502: Keine passende WINSOCK DLL im System
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (TCP/IP) / E20001501: Kein freies Handle
E20001501: Kein freies Handle
Die Kommunikations-Library unterstützt max. 16 Verbindungen in einer Anwendung.


E20001502: Keine passende WINSOCK DLL im System

E20001501: Kein freies Handle E20001503: Fehler beim Socket einrichten
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (TCP/IP) / E20001502: Keine passende WINSOCK DLL im System
E20001502: Keine passende WINSOCK DLL im System
Es wird eine Windows Socket Bibliothek (winsock.dll) ab Version 1.1 auf dem Rechner benötigt. Diese Voraussetzung sollte bei allen Windows Systemen ab Windows 95 gegeben sein.


E20001503: Fehler beim Socket einrichten

E20001502: Keine passende WINSOCK DLL im System E20001504: Fehlerhafte Host-Adresse
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (TCP/IP) / E20001503: Fehler beim Socket einrichten
E20001503: Fehler beim Socket einrichten
Beim Öffnen des TCP/IP Sockets ist ein Fehler aufgetreten.


E20001504: Fehlerhafte Host-Adresse

E20001503: Fehler beim Socket einrichten E20001505: Fehler beim Verbindungsaufbau zur Steuerung
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (TCP/IP) / E20001504: Fehlerhafte Host-Adresse
E20001504: Fehlerhafte Host-Adresse
Für die Zieladresse wurde eine ungültige IP Adresse oder ein im System nicht bekannter Host-Name angegeben.


E20001505: Fehler beim Verbindungsaufbau zur Steuerung

E20001504: Fehlerhafte Host-Adresse E20001506: Fehler TCP Zeitüberwachung
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (TCP/IP) / E20001505: Fehler beim Verbindungsaufbau zur Steuerung
E20001505: Fehler beim Verbindungsaufbau zur Steuerung
Es war nicht möglich eine Verbindung zum Port 19000 der angegebenen IP Adresse aufzunehmen.

Überprüfen Sie, ob die Steuerung eingeschaltet ist und die korrekte IP Adresse bzw. der korrekte Hostname (bei iTNC 530 ab 34049x 02) verwendet wird.

Überprüfen Sie z.B. mit dem PING Befehl, ob die Steuerung überhaupt im Netz korrekt angeschlossen und konfiguriert ist.

Überprüfen Sie, ob eine Firewall den Port 19000 sperrt.


E20001506: Fehler TCP Zeitüberwachung

E20001505: Fehler beim Verbindungsaufbau zur Steuerung E20001507: Verbindung abgebrochen
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (TCP/IP) / E20001506: Fehler TCP Zeitüberwachung
E20001506: Fehler TCP Zeitüberwachung
Die Gegenstelle nimmt trotz Wiederholversuche keine Daten mehr entgegen.


E20001507: Verbindung abgebrochen

E20001506: Fehler TCP Zeitüberwachung Übertragungsfehler (seriell)
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (TCP/IP) / E20001507: Verbindung abgebrochen
E20001507: Verbindung abgebrochen
In der Zwischenzeit wurde von der Gegenstelle die Verbindung beendet.


Übertragungsfehler (seriell)

E20001507: Verbindung abgebrochen E20001601: Allgemeiner Timeout
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell)
Übertragungsfehler (seriell)
E20001601: Allgemeiner Timeout
E20001602: Zeichenübertragung ohne ENQ
E20001603: Abbruch Start Textübertragung (Timeout!)
E20001604: Falsche Steuerzeichen
E20001605:Falsche Telegrammlänge
E20001606: Blockcheck-Fehler
E20001607: EOT fehlt
E20001608: Steuerung antwortet nicht
E20001609: Sendekollision
E2000160A: Keine Blockquittierung
E2000160B: Fehlerhafte Übertragung (drei Versuche)
E2000160C: Textblock-Übertragungszeit zu lang
E2000160E: Schnittstelle kann nicht geöffnet werden
E20001610: Kein Telegramm angekommen, obwohl erwartet
E20001611: Message noch nicht quittiert
E20001614: Kein DTR Signal


E20001601: Allgemeiner Timeout

Übertragungsfehler (seriell) E20001602: Zeichenübertragung ohne ENQ
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001601: Allgemeiner Timeout
E20001601: Allgemeiner Timeout
Keine Information verfügbar.


E20001602: Zeichenübertragung ohne ENQ

E20001601: Allgemeiner Timeout E20001603: Abbruch Start Textübertragung (Timeout!)
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001602: Zeichenübertragung ohne ENQ
E20001602: Zeichenübertragung ohne ENQ
Es wurde dreimal vergeblich versucht ein Telegramm zu übertragen. Beim letzten Versuch wurden Daten ohne vorherige Anforderung übertragen.


E20001603: Abbruch Start Textübertragung (Timeout!)

E20001602: Zeichenübertragung ohne ENQ E20001604: Falsche Steuerzeichen
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001603: Abbruch Start Textübertragung (Timeout!)
E20001603: Abbruch Start Textübertragung (Timeout!)
Keine Information verfügbar.


E20001604: Falsche Steuerzeichen

E20001603: Abbruch Start Textübertragung (Timeout!) E20001605:Falsche Telegrammlänge
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001604: Falsche Steuerzeichen
E20001604: Falsche Steuerzeichen
Trotz wiederholter Übertragungsversuche wurde das Telegramm nicht korrekt übertragen.


E20001605:Falsche Telegrammlänge

E20001604: Falsche Steuerzeichen E20001606: Blockcheck-Fehler
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001605:Falsche Telegrammlänge
E20001605:Falsche Telegrammlänge
Keine Information verfügbar.


E20001606: Blockcheck-Fehler

E20001605:Falsche Telegrammlänge E20001607: EOT fehlt
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001606: Blockcheck-Fehler
E20001606: Blockcheck-Fehler
Es wurde dreimal vergeblich versucht ein Telegramm zu übertragen. Beim letzten Versuch hat die Prüfsumme nicht gestimmt.


E20001607: EOT fehlt

E20001606: Blockcheck-Fehler E20001608: Steuerung antwortet nicht
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001607: EOT fehlt
E20001607: EOT fehlt
Die Telegrammübertragung wurde nicht vollständig mit dem EOT Zeichen abgeschlossen.


E20001608: Steuerung antwortet nicht

E20001607: EOT fehlt E20001609: Sendekollision
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001608: Steuerung antwortet nicht
E20001608: Steuerung antwortet nicht
Die Steuerung meldet sich nicht, obwohl dreimal das Anforderungszeichen ENQ mit 3 Sekunden Abstand gesendet wurde.


E20001609: Sendekollision

E20001608: Steuerung antwortet nicht E2000160A: Keine Blockquittierung
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001609: Sendekollision
E20001609: Sendekollision
Anwendung verhält sich nicht Protokollkonform.


E2000160A: Keine Blockquittierung

E20001609: Sendekollision E2000160B: Fehlerhafte Übertragung (drei Versuche)
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E2000160A: Keine Blockquittierung
E2000160A: Keine Blockquittierung
Es wurde dreimal vergeblich versucht ein Telegramm zu übertragen. Beim letzten Versuch wurde der Datenblock nicht mit DLE<1> quittiert.


E2000160B: Fehlerhafte Übertragung (drei Versuche)

E2000160A: Keine Blockquittierung E2000160C: Textblock-Übertragungszeit zu lang
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E2000160B: Fehlerhafte Übertragung (drei Versuche)
E2000160B: Fehlerhafte Übertragung (drei Versuche)
Es wurde dreimal vergeblich versucht ein Telegramm zu übertragen.


E2000160C: Textblock-Übertragungszeit zu lang

E2000160B: Fehlerhafte Übertragung (drei Versuche) E2000160E: Schnittstelle kann nicht geöffnet werden
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E2000160C: Textblock-Übertragungszeit zu lang
E2000160C: Textblock-Übertragungszeit zu lang
Es wurde dreimal vergeblich versucht ein Telegramm zu übertragen. Beim letzten Versuch wurde die maximale Blockübertragungszeit überschritten.


E2000160E: Schnittstelle kann nicht geöffnet werden

E2000160C: Textblock-Übertragungszeit zu lang E20001610: Kein Telegramm angekommen, obwohl erwartet
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E2000160E: Schnittstelle kann nicht geöffnet werden
E2000160E: Schnittstelle kann nicht geöffnet werden
Die angegebene serielle Schnittstelle ist im System nicht für Anwendungen verfügbar.

Überprüfen Sie die Einstellungen im Gerätemanager.


E20001610: Kein Telegramm angekommen, obwohl erwartet

E2000160E: Schnittstelle kann nicht geöffnet werden E20001611: Message noch nicht quittiert
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001610: Kein Telegramm angekommen, obwohl erwartet
E20001610: Kein Telegramm angekommen, obwohl erwartet
Im Telegrammfluß hätte die Gegenstelle ein Telegramm senden sollen. Das Warten wurde durch Timeout oder den Benutzer abgebrochen.


E20001611: Message noch nicht quittiert

E20001610: Kein Telegramm angekommen, obwohl erwartet E20001614: Kein DTR Signal
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001611: Message noch nicht quittiert
E20001611: Message noch nicht quittiert
Keine Information verfügbar.


E20001614: Kein DTR Signal

E20001611: Message noch nicht quittiert Problembehandlung
KinematicsDesign / LSV-2 Fehlermeldungen / Übertragungsfehler (seriell) / E20001614: Kein DTR Signal
E20001614: Kein DTR Signal
Bei der seriellen Schnittstelle (RS-232) wird über das Leitungspaar DSR und DTR signalisiert, ob ein Gerät an der Gegenstelle angeschlossen und bereit ist.

Evtl. ist das Kabel nicht voll bestückt und auch nicht gebrückt.


Problembehandlung

E20001614: Kein DTR Signal Die Ausrichtung der Darstellung entspricht nicht der räumlichen Orientierung der aktuellen Maschine
KinematicsDesign / Problembehandlung
Problembehandlung
Die Ausrichtung der Darstellung entspricht nicht der räumlichen Orientierung der aktuellen Maschine
Bei Änderung der Achspositionen bewegt sich das Maschinenbett gegenüber anderen Kollisionskörpern
Eine Kinematik lässt sich in der Baumansicht nicht aufklappen
Bei der Grafik wird nur die Hintergrundfarbe angezeigt
Bestimmte Bereiche einer Fläche sind unregelmäßig zweifarbig und flackern bei der Drehung
Es wird gar keine Grafik angezeigt oder die Grafik sieht "komisch" aus
Im Online-Betrieb wird nicht das gleiche Werkzeug wie an der Steuerung angezeigt
Bei der Angabe der Werkzeugtabelle von Drehsteuerungen kommt eine Fehlermeldung
KinematicsDesign läuft nicht auf der Zweiprozessorsteuerung


Die Ausrichtung der Darstellung entspricht nicht der räumlichen Orientierung der aktuellen Maschine

Problembehandlung Bei Änderung der Achspositionen bewegt sich das Maschinenbett gegenüber anderen Kollisionskörpern
KinematicsDesign / Problembehandlung / Die Ausrichtung der Darstellung entspricht nicht der räumlichen Orientierung der aktuellen Maschine
Die Ausrichtung der Darstellung entspricht nicht der räumlichen Orientierung der aktuellen Maschine
Mit Extras > Ausrichtung können Sie die Darstellung an die reale Maschine anpassen.


Bei Änderung der Achspositionen bewegt sich das Maschinenbett gegenüber anderen Kollisionskörpern

Die Ausrichtung der Darstellung entspricht nicht der räumlichen Orientierung der aktuellen Maschine Eine Kinematik lässt sich in der Baumansicht nicht aufklappen
KinematicsDesign / Problembehandlung / Bei Änderung der Achspositionen bewegt sich das Maschinenbett gegenüber anderen Kollisionskörpern
Bei Änderung der Achspositionen bewegt sich das Maschinenbett gegenüber anderen Kollisionskörpern
Definieren Sie das Maschinenbett mit Einfügen > Maschinenbett an der richtigen Stelle in der Kinematik-Kette.


Eine Kinematik lässt sich in der Baumansicht nicht aufklappen

Bei Änderung der Achspositionen bewegt sich das Maschinenbett gegenüber anderen Kollisionskörpern Bei der Grafik wird nur die Hintergrundfarbe angezeigt
KinematicsDesign / Problembehandlung / Eine Kinematik lässt sich in der Baumansicht nicht aufklappen
Eine Kinematik lässt sich in der Baumansicht nicht aufklappen
Es handelt sich um eine alte Kinematikbeschreibung, die von KinematicsDesign nicht unterstützt wird.


Bei der Grafik wird nur die Hintergrundfarbe angezeigt

Eine Kinematik lässt sich in der Baumansicht nicht aufklappen Bestimmte Bereiche einer Fläche sind unregelmäßig zweifarbig und flackern bei der Drehung
KinematicsDesign / Problembehandlung / Bei der Grafik wird nur die Hintergrundfarbe angezeigt
Bei der Grafik wird nur die Hintergrundfarbe angezeigt
  • Die aktuelle Kinematik enthält eine alte Kinematikbeschreibung, die von KinematicsDesign nicht unterstützt wird.
  • Sowohl die Kollisionskörper als auch die Transformationen sind ausgeblendet. Prüfen Sie die Einstellungen unter Ansicht.
  • Die Körper befinden sich außerhalb des Anzeige-Bereichs. Setzen Sie die Anzeige mit Ansicht > Blickwinkel zurücksetzen in den Grundzustand.


Bestimmte Bereiche einer Fläche sind unregelmäßig zweifarbig und flackern bei der Drehung

Bei der Grafik wird nur die Hintergrundfarbe angezeigt Es wird gar keine Grafik angezeigt oder die Grafik sieht „komisch“ aus
KinematicsDesign / Problembehandlung / Bestimmte Bereiche einer Fläche sind unregelmäßig zweifarbig und flackern bei der Drehung
Bestimmte Bereiche einer Fläche sind unregelmäßig zweifarbig und flackern bei der Drehung
Dieser Effekt tritt auf, wenn sich Körper durchdringen oder berühren und dieser Bereich nicht eindeutig einem Körper zugeordnet werden kann. Es handelt sich lediglich um einen Schönheitsfehler in der Darstellung. Sie können diesen Effekt jedoch vermeiden, wenn Sie einen der beiden Körper eine Kleinigkeit vergrößern oder verkleinern, so dass das Modell wieder eine eindeutige Zuordnung der Flächen ermöglicht.


Es wird gar keine Grafik angezeigt oder die Grafik sieht „komisch“ aus

Bestimmte Bereiche einer Fläche sind unregelmäßig zweifarbig und flackern bei der Drehung Im Online-Betrieb wird nicht das gleiche Werkzeug wie an der Steuerung angezeigt
KinematicsDesign / Problembehandlung / Es wird gar keine Grafik angezeigt oder die Grafik sieht "komisch" aus
Es wird gar keine Grafik angezeigt oder die Grafik sieht "komisch" aus
Probleme mit der Grafikkarte bzw. dem Grafik-Treiber können zu den unterschiedlichsten Effekten führen.

Für die 3D-Grafik wird OpenGL benötigt. OpenGL wird grundsätzlich von Windows unterstützt. Je nach Grafikkarte bzw. Einstellungen der Grafikkarte wird OpenGL mehr oder weniger in Hard- oder Software ausgeführt.

Bei Problemen mit der Grafik sollte man zuerst prüfen, ob beim Grafikkarten-Hersteller ein Update des Grafik-Treibers verfügbar ist und gegebenenfalls den Treiber aktualisieren.

Manche Probleme lassen sich auch dadurch beheben, dass die Hardware-Beschleunigung der Grafikkarte reduziert wird. Diese Einstellung ist von der Grafikkarte abhängig und daher von PC zu PC verschieden.


Im Online-Betrieb wird nicht das gleiche Werkzeug wie an der Steuerung angezeigt

Es wird gar keine Grafik angezeigt oder die Grafik sieht „komisch“ aus Bei der Angabe der Werkzeugtabelle von Drehsteuerungen kommt eine Fehlermeldung
KinematicsDesign / Problembehandlung / Im Online-Betrieb wird nicht das gleiche Werkzeug wie an der Steuerung angezeigt
Im Online-Betrieb wird nicht das gleiche Werkzeug wie an der Steuerung angezeigt
Im Online-Betrieb wird nur die Werkzeugnummer von der Steuerung aktualisiert. Diese wird auf die lokale Werkzeugtabelle angewandt. Übertragen Sie zunächst die Werkzeugtabelle von der Steuerung auf den PC.

Werkzeugtabelle


Bei der Angabe der Werkzeugtabelle von Drehsteuerungen kommt eine Fehlermeldung

Im Online-Betrieb wird nicht das gleiche Werkzeug wie an der Steuerung angezeigt KinematicsDesign läuft nicht auf der Zweiprozessorsteuerung
KinematicsDesign / Problembehandlung / Bei der Angabe der Werkzeugtabelle von Drehsteuerungen kommt eine Fehlermeldung
Bei der Angabe der Werkzeugtabelle von Drehsteuerungen kommt eine Fehlermeldung
Die Werkzeugtabelle von Drehsteuerungen hat ein anderes Format, das von KinematicsDesign noch nicht unterstützt wird.

Werkzeugtabelle


KinematicsDesign läuft nicht auf der Zweiprozessorsteuerung

Bei der Angabe der Werkzeugtabelle von Drehsteuerungen kommt eine Fehlermeldung KinematicsDesign läuft nicht auf der Zweiprozessorsteuerung
KinematicsDesign / Problembehandlung / KinematicsDesign läuft nicht auf der Zweiprozessorsteuerung
KinematicsDesign läuft nicht auf der Zweiprozessorsteuerung
Aufgrund technischer Probleme mit OpenGL und dem X-Server kann KinematicsDesign nicht gestartet werden, wenn auf einer Zweiprozessorsteuerung bereits der Steuerungsteil gestartet ist.