Virtools VR SDK Documentation

  • VR SDK Principles

    This chapter introduces the basic concepts of the Virtools VRSDK.
  • Using the VR SDK

    This chapter contains several articles with examples to help you to use each concept of the Virtools VRSDK.
  • VR SDK Reference

    This is the reference for all classes,functions,structures,macros introduced by the VRSDK.
  • VR SDK source code

    This chapter gives a list of sample source code that are provided with the VRSDK.


VR SDK Principles

The VRSDK documentation assumes that the principles involved with Virtools usage (Behaviors, Parameters, Behavioral objects, scenes, scripts, etc.) and the basic architecture of the Virtools SDK are known and understood. If that's not the case, please take the time to read the Introducing Virtools SDK chapter.

Presentation

The Virtools VRSDK (VR Pack Software Development Kit) is a set of development tools (libraries, DLLs, header files) that give programmers low-level access to some features used in Virtools VR Pack applications.

Using the Virtools SDK, programmers can write the following software components:

  • Behavior Plugins
  • Managers Plugins

With the Virtools VRSDK, they can include the following additional features in these components :

View Warping

The main feature of this initial VRSDK version is the view warping mechanism it provides. The aim of this feature is to allow you to deform and blend the 3D Rendering image on any VR Pack composition without modification on the .cmo file. This can be very useful to deform an image that is to be projected on a non flat screen and / or to blend the images for several projectors that overlaps without specific hardware material.

More precisely, using methods that are described in this documentation, you can trigger an additional rendering for any VRPlayer view. Then, within VRManager specific callback, you can code the rendering pass to do:

Edge Blending

This feature enables the use of blending textures to blend images from several outputs seamlessly. Simply enable the plugin and choose the right texture for each output.

Configuration File Management

With the VRSDK, programmers can access any VR Pack or Custom token of the application configuration files.

Components

The VRSDK is made of the following header and library files that appear in the Include and Lib Virtools SDK subdirectories:

  • VRAll.h to include in all files using the VR SDK.
  • VRError.h defining the VR error codes.
  • VRTypes.h defining the main VR classes and types.
  • VRGlobals.h defining the VR global methods.
  • VRContext.h defining the VRContext class.
  • VRBaseManager.h defining the VRBaseManager class.
  • VRKernel.lib compiled with Visual .Net 2003

Compatibility

For this first release, the VRSDK is only compatible with the VRPlayer. A plugin can be added to the "Building Blocks" directory of Virtools Dev, but it will have no effect.


Using the VR SDK

This overview contains the following information :

  • Main Classes describes the main VRSDK classes.
  • VRPlayer Loop describes the main VRPlayer events.
  • Logging Messages describes how to log a message in the VRPlayer console window.
  • Configuration File Management describes how to get information from the configuration files.
  • View Warping described how to implement a simple warping plugin for the VRPlayer.

Main Classes

  • The VRContext is the CKContext of the VR environment. It contains a set of methods to get information about the VR environment, and in particular, some methods to register / unregister user defined VR Managers. You have access to the current VRContext through the VRBaseManager::m_VRContext variable.

    Note that in this first version, this variable is not NULL only when the plug-in is loaded by the Virtools VRPlayer. In all other cases (Virtools Dev, Custom Player), the variable is NULL.
  • The VRBaseManager is the CKBaseManager of the VR environment. By implementing a descendent class of VRBaseManager, you can access both the main Virtools events as it inherits them from CKBaseManager and the main VR events. Those are described more accurately below.

VRPlayer Loop

To understand the VRManager events, you need to understand the VRPlayer main loop:

  • Create the VRContext and parse the basic tokens : LogLevel, BaseDirectory, Hosts, VRResources, Resources.
  • Call VRBaseManager::OnParse for every registered VR Manager.
  • Parse the View_x_x tokens. And for each view defined for the current host:
    • Create the view.
    • Call VRBaseManager::OnViewCreate.
  • Load the composition.
  • Then, apply the following loop until exit:
    • Process Behaviors
    • For each view of the current host:
      • Clear the backbuffer if the CK_RENDER_CLEARVIEWPORT is not in the current render options and if we are the first view. If this flag is set, clear only the viewport whatever view we are,
      • Select rendering camera and set rendering mode to left / right / default according to configuration files.
      • If warping texture is activated, render the scene on the warping texture.
      • If warping is not activated or is activated without texture, render the scene on the backbuffer.
      • If warping is activated:
        • Set render options to the default value CK_RENDER_BACKGROUNDSPRITES|CK_RENDER_FOREGROUNDSPRITES.
        • call VRBaseManager::OnViewWarp for this view.
        • Reset to previous render options,
      • Swap the front and back buffer if we are the last view.
    • Reset rendering mode to default.
    • Reset initial camera.
  • When OnCKEnd event is raised on the managers, the VRContext is closed and call VRBaseManager::OnViewDelete for every view.

Logging Messages

To log a message in the VRPlayer console, use the VRContext::OutputToLog method. When doing so, you can specify a level for this message that will be displayed only if the LogLevel of the configuration files is smaller yours.

The VR Pack usually uses the following levels:

  • 0 when an error happens,
  • 1 when a warning happens,
  • 2 to 5 for other user information.

Setting Setereo Parameters

To change the Stereo parameters, such as the interpupillar distance and the focal length, use the IVRDisplayManager::SetStereoParameters method. To get a pointer to the VR Display Manager, use VRContext::GetVRDisplayManager.

Getting Stereo Informations

To know which eye the stereo mechanism is rendering, use the IVRDisplayManager::IsStereoRenderingLeftEye method. To get a pointer to the VR Display Manager, use VRContext::GetVRDisplayManager.

Configuration File Management

With the VRContext, you can access any token of the configuration files. Some tokens are parsed during the VRContext creation and can be accessed directly with the following methods:

  • VRContext::GetLogLevel
  • VRContext::GetBaseDirectory
  • VRContext::GetHostList

Some tokens are directly processed (host and view list) and result information can be access with the following methods:

  • VRContext::GetHostCount to get the number of hosts on the cluster.
    VRContext::GetHostID to get the Host ID of the current host.
  • VRContext::GetViewCount to get the number of views on the current host.
  • VRContext::GetView to get information on a view of the current host.

For all other tokens (including user custom tokens), you can use the following methods:

  • VRContext::GetToken to get a token and have its value displayed in the log window.
  • VRContext::GetHiddenToken to get a token silently without displaying it in the log window.

Note that each token can only be of 3 types : int, float or string. It is your responsibility to convert a string token value to any other custom "type" you want to get.

Finally, with the VRSDK, a notion of SubTokens appears. These subtokens are defined at the end of a view_x_x definition and allow you to get view specific extra information. For example, the following lines defines 3 subtokens: SubToken1 has an integer value, SubToken2 has a float value and SubToken3 has a string value (note that you can supply a value with a space using "" around it).

View_0_0 none FrontCamera 0 0 1024 768 SubToken1=1 SubToken2=2 SubToken3=StringValue

View_0_1 none FrontCamera 0 0 1024 768 SubToken1=1 SubToken2=3.5 SubToken3="With Space"

To get these subtoken values, use the VRContext::GetSubToken method.

View Warping

Sample Review

Before implementing your own warping plug-in, you can review the VRSdkSampleWarp that is provided with the VRSDK.

For more information on this sample, see the Virtools VRSDK Sample documentation.

Creating a New VRManager Plugin

To create a new Virtools VRManager Plug-in, use the Application Wizard and select the Manager creation. In the Manager definition page, select any Virtools events your manager need to handle. To work properly with the VRPlayer, the DLL you create must be placed in the Building Block directory of the VRPlayer.

You then need to modify the generated manager source code to have your manager inheriting from VRBaseManager instead of CKBaseManager, implement the creation method as done in the VRSdk Sample manager and implement the various VRManager methods as described below:

For more information, please review the following SDK documentation :

Using the Visual C++ AppWizard to Create a Manager

Creation of a New Manager

Implementing the VRManager Methods

Before to implement the different VRManager methods, make sure to review the VRPlayer Loop to understand when the VRManager callbacks are called.

  • You first need to register the manager in the system in its class constructor. Register it both as a CKBaseManager and as a VRBaseManager. Since this plug-in only works with the VRPlayer (Virtools Dev doesn’t implement warping support), registration only occurs in this case. Also, make sure to verify that the m_VRContext variable is not NULL before registering your manager as it will be NULL when in Virtools Dev or a custom player.
  • If your manager handles Virtools events and you need to implement CKBaseManager::GetValidFunctionsMask, make sure to return at least (CKMANAGER_FUNC_OnCKInit|CKMANAGER_FUNC_OnCKEnd) since these two methods are implemented by the VRBaseManager.
  • If you need to reimplement CKBaseManager::OnCKInit or CKBaseManager::OnCKEnd in your VRManager for a specific process, make sure to call the VRBaseManager parent implementation.
  • In VRBaseManager:: GetValidVRFunctionsMask, make sure to return a VR callback flag that your manager is handling. You can also implement VRBaseManager:: GetVRFunctionPriority to specify a priority value for your manager on a VR callback call.
  • In VRBaseManager:: OnParse, you may parse the general tokens that are needed by your plugin. If your plugin is not always activated (i.e. requires a specific view subtoken to be present), you can also do nothing here and parse the general tokens at the creation of the first view that actually uses your mechanism in order to avoid parsing tokens that are not used.
  • In VRBaseManager:: OnViewCreate, you may detect the views that define the subtoken for your plugin and do any initialization process that is needed. For instance, you may create specific Virtools objects (mesh, materials, etc.) to be used in the warp rendering pass. If you do so, make sure to modify these objects flags as follows to avoid having the system delete them before or after loading the user composition :

    CKObject::ModifyObjectFlags(CK_OBJECT_NOTTOBEDELETED|CK_OBJECT_PRIVATE, 0);

    Here, you can also attach a custom data to the view with the VRContext::SetViewData method. Note that only one data can be added to a view, and two plug-ins that concurrently add a data to the same view will interfere. So, make sure to add data only if the user actually request to use your plug-in.
  • In VRBaseManager:: OnViewDelete, get the data you have added to the view (if any) and delete it to avoid memory leaks.
  • Finally, in VRBaseManager:: OnViewWarp, you must implement the additional rendering. To do that, you will usually render specific Virtools object (mesh, materials, etc) that you previously created or loaded. When implementing this method, keep the following remarks in mind :
    • Warping a view using a texture is faster, but warping a view using the backbuffer allows you to take advantage of de-antialiasing feature.
    • The VRPlayer permits several views in the same rendering window. To avoid a flickering effect, it clears the full back buffer only once. You should never clear the entire back buffer by yourself.


VR SDK source code

VRSdkSampleWarp

Description

This sample implements a VRPlayer plug-in that is able to load any Virtools geometry as an .nmo file and render the scene on it instead of the normal rendering window.

Starting the Sample

To start the sample, follow these steps:

  1. Copy the VRSDKDisplayWarp.cfg file from

    "Virtools\VRPack\SystemConfig\ReferenceSamples" to

    "Virtools\VRPack\SystemConfig\"
  2. Copy "Virtools 4.0\Documentation\VirtoolsResources\VR\VRSDKCylinder.nmo" to the folder of your composition.
  3. Copy "Virtools 4.0\Sdk\Samples\VRSdk\SampleWarp\bin\VRSdkSampleWarp.dll" to the "Virtools 4.0\VRPack\Bin\plugins" folder.
  4. Include VRSDKDisplayWarp.cfg in your VRPackMaster.cfg file instead of VRDisplay.cfg
  5. Start any composition.

Sample's Tokens

If you edit the VRSDKDisplayWarp.cfg file, you will see that this sample uses the following general tokens :

  • WarpingFile gives the file that contains the warping geometry. Two files are available in the VRResources as samples: VRSDKPlane.nmo and VRSDKcylinder.nmo. If you want to do your own geometry, please read the topic below.

    The warping file is searched in the DataPath directories of the path manager.
  • WarpingWidth gives the width to use for the warping texture.
  • WarpingHeight gives the height to use for the warping texture.

Then, to warp a view, you need to add the following subtoken:

View_0_0 none FrontCamera 0 0 1024 768 Warping=SampleWarp

Creating a New Geometry

The VRSdkSampleWarp lets you warp the views on any display geometry. It requires an .nmo file that contains only one camera, one object, one mesh and one material. This geometry should be a 3D model exported from your favorite 3D modeling tool. Below, we explain how to create a new sphere geometry with 3D Studio Max:

  • Create a simple sphere by using the standard primitive tools.
  • Assign a UVW mapping in the modifier list (do not multiply the UVW tile).
  • Assign a default material.
  • Assign vertex colors from the utilities list.
  • Export the model as an .nmo file using to the Virtools 3dsmax Exporter.
  • Import the model in Virtools Dev (in a new composition).
  • Add a camera called “WarpCamera”.
  • Set camera’s position the way you want to see the final rendering in the VRPlayer.
  • Right click on “Level” in the Level Manager and save the composition as .nmo file.
  • Give the name of your file to the WarpingFile token.

Sample Source Code

The source code of this sample is located in the following directory :

"Virtools 4.0\Sdk\Samples\VRSdk\SampleWarp\"

VRSdkSampleBlend

Description

This sample implements a VRPlayer plug-in that is able to blend any image with the current rendered view. A different image can be blended for each camera.

Starting the Sample

To start the sample, follow these steps:

  1. Copy the VRSDKDisplayBlend.cfg file from

    "Virtools\VRPack\SystemConfig\ReferenceSamples" to

    "Virtools\VRPack\SystemConfig\"
  2. Copy "Virtools 4.0\Documentation\VirtoolsResources\VR\edge_filter.tga" to the folder of your composition.
  3. Copy "Virtools 4.0\Sdk\Samples\VRSdk\SampleBlend\bin\VRSdkSampleBlend.dll" to the "Virtools 4.0\VRPack\Bin\plugins" folder.
  4. Include VRSDKDisplayBlend.cfg in your VRPackMaster.cfg file instead of VRDisplay.cfg
  5. Start any composition.

Sample's Tokens

If you edit the VRSDKDisplayBlend.cfg file, you will see that this sample uses the following token :

  • UseBlendTexture : 1 if you want to use the blending feature, 0 otherwise.

Then, to warp a view, you need to add the following subtoken:

View_0_0 none FrontCamera 0 0 1024 768 BlendingType="TextureBlending" BlendTexture="filter.tga"

Blending Texture

The blending texture will simply be overlayed on top of the rendered view.

The overlay is modulated by the alpha channel of the texture.

If your blending texture doesn't have an alpha channel, you'll only see this texture, and not the rendered view.

For an example of edge blending texture, look at the edge_filter.tga image.

Sample Source Code

The source code of this sample is located in the following directory :

"Virtools 4.0\Sdk\Samples\VRSdk\SampleBlend\"


Classes

Class VRBaseManager | Base Class for VR managers.
Class VRContext | Main VR Interface Context

See Also

VR SDK Reference

Generated by the DocJet Source Code Documentation System version 6.1.3 Thursday, February 26, 2009


VRBaseManager

Group

Class VRBaseManager

Base Class for VR managers.

CKBaseManager
Show brief derivation trees

VRBaseManager

CKBaseManager
Show full derivation trees

VRBaseManager

Remarks

 This class inherits from CKBaseManager.
 It provides additionnal virtual methods that can be overriden to add some
    processing at VR specific events.
 The instances of managers may be retrieved through the global function
    CKContext::GetManagerByGuid()

Groups

Data Members
Member Variable m_VRContext | A pointer to the VRContext on which this manager is valid.
CKEvents
Virtual Method Method OnCKEnd | Called at deletion of a CKContext
Virtual Method Method OnCKInit | Called at the end of the creation of a CKContext.
VREvents
Virtual Method Method OnParse | Called when the player starts and reads the configuration files.In this method, you usually parse your own tokens with the parsing methods of the VRContext.
Virtual Method Method OnViewCreate | Called each time the VRPlayer creates a new view. The information on this view is provided as an argument by the parsing of the View_X_X token (See the VR Pack?s Documentation?s Viewport Setting topic). With this method, you usually read the additional view subtoken with the subtoken parsing methods of the VRContext and make any initialization needed by your plugin.
Virtual Method Method OnViewDelete | Called each time the VRPlayer deletes a view. Here, you should delete any data you attached to a view.
Virtual Method Method OnViewWarp | Called after each Virtools rendering for every warped view. Here, you should make your own custom rendering using either the warping texture or the information on the render context back buffer.
Manager Info
Virtual Method Method GetValidFunctionsMask | Returns list of functions implemented by the manager.
Virtual Method Method GetValidVRFunctionsMask | Returns list of VR functions implemented by the manager.
Virtual Method Method GetVRFunctionPriority | Returns the priority of the specified VR manager function.

See Also

CKBaseManager


VRBaseManager::m_VRContext

Owner

Member Variable VRBaseManager::m_VRContext

VRContext* VRBaseManager::m_VRContext

Remarks

A pointer to the VRContext on which this manager is valid.


VRBaseManager::OnCKEnd

Owner

Virtual Method Method VRBaseManager::OnCKEnd

virtual CKERROR VRBaseManager::OnCKEnd()

Called at deletion of a CKContext

Returns

CK_OK if successful An error code otherwise

Remarks

 You can override this function if you need to clean up things at the end of the session.
        If you do so, you must call the current implementation.
 This method is called at the beginning of the deletion of the CKContext, the manager
        is also deleted a short time after.
 The GetValidFunctionsMask implementation of the VRBaseManager return a valid mask for this method.

See Also

Main Virtools Events, CKBaseManager::OnCKEnd, VRBaseManager::GetValidFunctionsMask


VRBaseManager::OnCKInit

Owner

Virtual Method Method VRBaseManager::OnCKInit

virtual CKERROR VRBaseManager::OnCKInit()

Called at the end of the creation of a CKContext.

Returns

CK_OK if successful An error code otherwise

Remarks

 You can override this function if you need to add specific processing at initialization.
        If you do so, you must call the current implementation.
 If your manager is registered after the context has been created and if it implements the OnCKInit()
        function, this function will be called upon registration.
 The GetValidFunctionsMask implementation of the VRBaseManager return a valid mask for this method.

See Also

Main Virtools Events, CKBaseManager::OnCKInit, VRBaseManager::GetValidFunctionsMask


VRBaseManager::OnParse

Owner

Virtual Method Method VRBaseManager::OnParse

virtual CKERROR VRBaseManager::OnParse()

Called when the player starts and reads the configuration files.In this method, you usually parse your own tokens with the parsing methods of the VRContext.

Returns

CK_OK if successful An error code otherwise

Remarks

 You can override this function to parse your tokens. Note that the
        following tokens are already available in the VRContext: 'LogLevel',
        'BaseDirectory', 'Hosts', 'VRResources', 'Resources', 'BitmapPath',
        'DataPath' and 'SoundPath'. You can then use the CKPathManager to
        locate data, texture or sound path if needed.
 You must override GetValidVRFunctionsMask and return a value including
        VRMANAGER_FUNC_OnParse for this function to get called.

See Also

VRContext::GetToken, VRContext::GetHiddenToken, CKPathManager, VRBaseManager::GetValidVRFunctionsMask


VRBaseManager::OnViewCreate

Owner

Virtual Method Method VRBaseManager::OnViewCreate

virtual CKERROR VRBaseManager::OnViewCreate(VRView* iView)

Called each time the VRPlayer creates a new view. The information on this view is provided as an argument by the parsing of the View_X_X token (See the VR Pack?s Documentation?s Viewport Setting topic). With this method, you usually read the additional view subtoken with the subtoken parsing methods of the VRContext and make any initialization needed by your plugin.

Returns

CK_OK if successful An error code otherwise

Remarks

 You can override this function to add specific processing at view creation.
        In particular, you can activate the warping on the view. You can also attach
        a user data to the view.
 You must override GetValidVRFunctionsMask and return a value including
        VRMANAGER_FUNC_OnViewCreate for this function to get called.

See Also

VRBaseManager::GetValidVRFunctionsMask, VRContext::ActivateWarp, VRContext::SetViewData, VRContext::GetSubToken


VRBaseManager::OnViewDelete

Owner

Virtual Method Method VRBaseManager::OnViewDelete

virtual CKERROR VRBaseManager::OnViewDelete(VRView* iView)

Called each time the VRPlayer deletes a view. Here, you should delete any data you attached to a view.

Returns

CK_OK if successful An error code otherwise

Remarks

 You can override this function to add specific processing when a view is
        deleted. In particular, you should clear your user data if you added one
        to the current view.
 You must override GetValidVRFunctionsMask and return a value including
        VRMANAGER_FUNC_OnViewDelete for this function to get called.

See Also

VRContext::DeActivateWarp, VRContext::GetViewData, VRBaseManager::GetValidVRFunctionsMask


VRBaseManager::OnViewWarp

Owner

Virtual Method Method VRBaseManager::OnViewWarp

virtual CKERROR VRBaseManager::OnViewWarp(CKRenderContext* rc, VRView* iView)

Called after each Virtools rendering for every warped view. Here, you should make your own custom rendering using either the warping texture or the information on the render context back buffer.

Returns

CK_OK if successful An error code otherwise

Remarks

 You can override this function to implementing the view warping. Depending
        on the warping options, the Virtools rendering were done on the backbuffer or
        on a render texture.
 You must override GetValidVRFunctionsMask and return a value including
        VRMANAGER_FUNC_OnViewWarp for this function to get called.

See Also

VRContext::GetViewData, VRContext::GetWarpTexture, VRBaseManager::GetValidVRFunctionsMask


VRBaseManager::GetValidFunctionsMask

Owner

Virtual Method Method VRBaseManager::GetValidFunctionsMask

virtual CKDWORD VRBaseManager::GetValidFunctionsMask()

Returns list of functions implemented by the manager.

Returns

A combination of CKMANAGER_FUNCTIONS.

Remarks

You can override this function to indicates the additional callback methods that are implemented by your manager from the CKBaseManager vitual methods. If you do so, you must call the current implementation as the VRBaseManager overrides OnCKInit and OnCKEnd.

See Also

CKBaseManager::GetValidFunctionMask, CKMANAGER_FUNCTIONS


VRBaseManager::GetValidVRFunctionsMask

Owner

Virtual Method Method VRBaseManager::GetValidVRFunctionsMask

virtual CKDWORD VRBaseManager::GetValidVRFunctionsMask()

Returns list of VR functions implemented by the manager.

Returns

A combination of VRMANAGER_FUNCTIONS.

Remarks

You must override this function to indicate which functions your VR manager implements.

Example

The attribute manager implements two VRBaseManager functions : OnParse and OnViewWarp,
so its GetValidFunctionsMask looks like this:
   virtual CKDWORD GetValidVRFunctionsMask()
   {
       return  VRMANAGER_FUNC_OnParse      |
               VKMANAGER_FUNC_OnViewWarp   ;
   }

See Also

VRMANAGER_FUNCTIONS


VRBaseManager::GetVRFunctionPriority

Owner

Virtual Method Method VRBaseManager::GetVRFunctionPriority

virtual int VRBaseManager::GetVRFunctionPriority(VRMANAGER_FUNCTIONS Function)

Returns the priority of the specified VR manager function.

Returns

An integer giving priority for the specified function.

Remarks

Override this function if you want to specify a priority for one or several functions of your manager. The default implementation returns a priority of 0 for all functions.

Example

To ensure that your OnParse() function will be one of the first to be called among all managers:
   int MyManager::GetVRFunctionPriority(VRMANAGER_FUNCTIONS Function)
   {
       if (Function==VRMANAGER_FUNC_OnParse) return 10000; // High Priority
           return 0;
   }

See Also

VRMANAGER_FUNCTIONS


VRContext

Group

Class VRContext

Main VR Interface Context

Remarks

 The VRContext object gives access to all VR informations for Virtools VR Pack
      applications.
 Use VRCreateContext to create a new VR context and VRCloseContext to close it.
 Use VRGetContext to get the VRContext attached to a give CKContext.
 For now, the VRContext is not available in Virtools Dev Mode, it is only
    available in the VRPlayer mode.

Groups

Operations | Settings | Token Management | Utilities | View Management

Operations
Method _AddResourceToken |
Method CheckLicenses | check the licenses
Method CloseParse | Close the config file.
Method DoPrimaryRender | The VRPlayer will ask to do the render or not this frame (VRSDK purpose).
Method EnablePrimaryRender | Tells the VRPlayer to do the render or not this frame (VRSDK purpose).
Method FlagExit | Tells the VRPlayer to exit at the end of this frame.
Method GetVRDisplayManager | Get the VRDisplayManager
Method InitParse | Open the config file.
Method OutputToLog | Display a message on the output window (Event Log or Console Window)
Method RegisterNewManager | Register a new VR Manager.
Settings
Method GetBaseDirectory | Get the current BaseDirectory as it is defined in the application's configuration files (token 'BaseDirectory').
Method GetBaseMediaDirectory | Get the current BaseMediaDirectory as it is defined in the application's configuration files (token 'BaseMediaDirectory').
Method GetCfgFilename | Get the main configuration file name.
Method GetHostCount | Get the number of hosts that appears in the host list as it is define in the application's configuration file.
Method GetHostID | Get the ID of the current host (i.e. its index in the host list) as it is define in the application's configuration file.
Method GetHostList | Get the current list of hosts as it is define in the application's configuration file (token 'Hosts').
Method GetLogLevel | Get the current LogLevel as it is define in the application's configuration file (token 'LogLevel').
Method SetCfgFilename | Set the main configuration file name.
Token Management
Method GetFloat3 | Get a token value represented by an array of 3 floats
Method GetFloat4 | Get a token value represented by an array of 4 floats
Method GetHiddenToken | Get a token value without displaying it
Method GetInt3 | Get a token value represented by an array of 3 ints
Method GetString | Get a token value represented by a XString
Method GetSubToken | Get a subtoken value from the given string.
Method GetToken | Get a token value.
Utilities
Method GetExecutionMode | Get the current VR execution mode (Virtools Dev, VRPlayer...)
View Management
Method ActivateWarp | Activate the VRPlayer warping mode on the given view.
Method DeActivateWarp | Deactivate the VRPlayer warping mode on the given view.
Method GetView | Get a view of the current host
Method GetViewCount | Get the number of views on the current host
Method GetViewData | Get the user data attached to a view
Method GetWarpTexture | Get the warping texture used for the given view.
Method SetViewData | Attach a user data to a view

See Also

CKContext, VRCreateContext, VRCloseContext, VRGetContext.


VRContext::_AddResourceToken

Owner

Method VRContext::_AddResourceToken

void VRContext::_AddResourceToken(XString& iResources)


VRContext::CheckLicenses

Owner

Method VRContext::CheckLicenses

bool VRContext::CheckLicenses( void )

check the licenses

Returns

Value | Meaning
true | all licenses requested by the license configuration are present
false | at least one license is missing


VRContext::CloseParse

Owner

Method VRContext::CloseParse

void VRContext::CloseParse()

Close the config file.


VRContext::DoPrimaryRender

Owner

Method VRContext::DoPrimaryRender

CKBOOL VRContext::DoPrimaryRender()const

The VRPlayer will ask to do the render or not this frame (VRSDK purpose).


VRContext::EnablePrimaryRender

Owner

Method VRContext::EnablePrimaryRender

void VRContext::EnablePrimaryRender(CKBOOL enable)

Tells the VRPlayer to do the render or not this frame (VRSDK purpose).


VRContext::FlagExit

Owner

Method VRContext::FlagExit

void VRContext::FlagExit()

Tells the VRPlayer to exit at the end of this frame.


VRContext::GetVRDisplayManager

Owner

Method VRContext::GetVRDisplayManager

IVRDisplayManager* VRContext::GetVRDisplayManager( void )

Get the VRDisplayManager

Returns

A pointer to the VRDisplayManager


VRContext::InitParse

Owner

Method VRContext::InitParse

VRERROR VRContext::InitParse( void )
VRERROR VRContext::InitParse( XString& fileName )

Open the config file.

Returns

Value | Meaning
VR_OK | success
VRERR_INVALIDCFGFILE | couldn't open the file


VRContext::OutputToLog

Owner

Method VRContext::OutputToLog

void VRContext::OutputToLog(int iLevel, const char* iFormat,...) const

Display a message on the output window (Event Log or Console Window)

Parameters

Input argument iLevel
The message will be displayed only if iLevel is bigger than the
       current LogLevel.
iFormat...: Same format as the printf function. Please review you C++ documentation
       for more information.

See Also

GetLogLevel


VRContext::RegisterNewManager

Owner

Method VRContext::RegisterNewManager

CKERROR VRContext::RegisterNewManager(VRBaseManager* iManager)

Register a new VR Manager.

Parameters

iManager

the manager to register

Returns

Value | Meaning
CKERR_ALREADYPRESENT | if manager is already registered
VR_OK | if manager was successfully registered


VRContext::GetBaseDirectory

Owner

Method VRContext::GetBaseDirectory

XString VRContext::GetBaseDirectory()

Get the current BaseDirectory as it is defined in the application's configuration files (token 'BaseDirectory').

Returns

BaseDirectory value

Remarks

The BaseDirectory is always an absolute path


VRContext::GetBaseMediaDirectory

Owner

Method VRContext::GetBaseMediaDirectory

XString VRContext::GetBaseMediaDirectory()

Get the current BaseMediaDirectory as it is defined in the application's configuration files (token 'BaseMediaDirectory').

Returns

BaseMediaDirectory value if it is set, BaseDirectory otherwise

Remarks

The BaseMediaDirectory is always an absolute path


VRContext::GetCfgFilename

Owner

Method VRContext::GetCfgFilename

XString& VRContext::GetCfgFilename()

Get the main configuration file name.

Returns

Absolute path to the VRPack.cfg configuration file of the application or “” if not found.

See Also

SetCfgFilename


VRContext::GetHostCount

Owner

Method VRContext::GetHostCount

int VRContext::GetHostCount()

Get the number of hosts that appears in the host list as it is define in the application's configuration file.

Returns

Number of host on the cluster


VRContext::GetHostID

Owner

Method VRContext::GetHostID

int VRContext::GetHostID()

Get the ID of the current host (i.e. its index in the host list) as it is define in the application's configuration file.

Returns

The ID of the current host.

Remarks

When the current host appears 2 times in the host list, its ID depends on the current PipeID value:

 If it is 0, the ID is the first appearance of the host in the list,
 If it is 1, the ID is the second appearance of the host in the list,
 ...


VRContext::GetHostList

Owner

Method VRContext::GetHostList

XString VRContext::GetHostList()

Get the current list of hosts as it is define in the application's configuration file (token 'Hosts').

Returns

Hosts list

Remarks

Hosts are separated by a space in the host list string.


VRContext::GetLogLevel

Owner

Method VRContext::GetLogLevel

int VRContext::GetLogLevel() const

Get the current LogLevel as it is define in the application's configuration file (token 'LogLevel').

Returns

LogLevel value


VRContext::SetCfgFilename

Owner

Method VRContext::SetCfgFilename

void VRContext::SetCfgFilename( XString& )

Set the main configuration file name.

Parameters

Absolute path to the VRPack.cfg configuration file of the application

See Also

GetCfgFilename


VRContext::GetFloat3

Owner

Method VRContext::GetFloat3

CKERROR VRContext::GetFloat3(const XString& iToken, float* oValue, const float* iDefault)
CKERROR VRContext::GetFloat3(const XString& iToken, float* oValue)

Get a token value represented by an array of 3 floats

Parameters

Input argument iDefault | Default value to return when the token was not found
Input argument iToken | Token unique name
Output argument oValue | Token's read value

Returns

Value | Meaning
VR_OK | if successfully found
VRERR_INVALIDCFGFILE | when the configuration file is invalid
VRERR_TOKENNOTFOUND | when the token was not found

Remarks

 This method is case insensitive regarding the iToken value.
 When an error occurs, the returned oValue is set to iDefault.
 The token values is displayed on the output window (Event Log
    or Console Window).


VRContext::GetFloat4

Owner

Method VRContext::GetFloat4

CKERROR VRContext::GetFloat4(const XString& iToken, float* oValue, const float* iDefault)
CKERROR VRContext::GetFloat4(const XString& iToken, float* oValue)

Get a token value represented by an array of 4 floats

Parameters

Input argument iDefault | Default value to return when the token was not found
Input argument iToken | Token unique name
Output argument oValue | Token's read value

Returns

Value | Meaning
VR_OK | if successfully found
VRERR_INVALIDCFGFILE | when the configuration file is invalid
VRERR_TOKENNOTFOUND | when the token was not found

Remarks

 This method is case insensitive regarding the iToken value.
 When an error occurs, the returned oValue is set to iDefault.
 The token values is displayed on the output window (Event Log
    or Console Window).


VRContext::GetHiddenToken

Owner

Method VRContext::GetHiddenToken

CKERROR VRContext::GetHiddenToken(const XString& iToken, int *oValue, int iDefault=0)
CKERROR VRContext::GetHiddenToken(const XString& iToken, float *oValue, float iDefault=0.0f)
CKERROR VRContext::GetHiddenToken(const XString& iToken, XString *oValue, XString iDefault="-")

Get a token value without displaying it

Parameters

iToken | Token unique name
oValue | Token's readed value
iDefault | Default value to return when the token was not found.

Returns

Value | Meaning
VR_OK | if succesfully found
VRERR_INVALIDCFGFILE | when the configuration file is invalid
VRERR_TOKENNOTFOUND | when the token was not found

Remarks

 This method is case insensitive regarding the iToken value.
 When an error occurs, the returned oValue is set to iDefault.
 The token values is not displayed on the output window
        (Event Log or Console Window).

See Also

GetToken


VRContext::GetInt3

Owner

Method VRContext::GetInt3

CKERROR VRContext::GetInt3(const XString& iToken, int* oValue, const int* iDefault)
CKERROR VRContext::GetInt3(const XString& iToken, int* oValue)

Get a token value represented by an array of 3 ints

Parameters

Input argument iDefault | Default value to return when the token was not found
Input argument iToken | Token unique name
Output argument oValue | Token's read value

Returns

Value | Meaning
VR_OK | if successfully found
VRERR_INVALIDCFGFILE | when the configuration file is invalid
VRERR_TOKENNOTFOUND | when the token was not found

Remarks

 This method is case insensitive regarding the iToken value.
 When an error occurs, the returned oValue is set to iDefault.
 The token values is displayed on the output window (Event Log
    or Console Window).


VRContext::GetString

Owner

Method VRContext::GetString

CKERROR VRContext::GetString(const XString& iToken, char* oValue, const char* iDefault)
CKERROR VRContext::GetString(const XString& iToken, char* oValue)

Get a token value represented by a XString

Parameters

Input argument iDefault | Default value to return when the token was not found
Input argument iToken | Token unique name
Output argument oValue | Token's read value

Returns

Value | Meaning
VR_OK | if successfully found
VRERR_INVALIDCFGFILE | when the configuration file is invalid
VRERR_TOKENNOTFOUND | when the token was not found

Remarks

 This method is case insensitive regarding the iToken value.
 When an error occurs, the returned oValue is set to iDefault.
 The token values is displayed on the output window (Event Log
    or Console Window).


VRContext::GetSubToken

Owner

Method VRContext::GetSubToken

CKERROR VRContext::GetSubToken(const XString& iInput, const XString& iToken, int *oValue, int iDefault=0)
CKERROR VRContext::GetSubToken(const XString& iInput, const XString& iToken, float *oValue, float iDefault=0.0f)
CKERROR VRContext::GetSubToken(const XString& iInput, const XString& iToken, XString *oValue, XString iDefault="-")

Get a subtoken value from the given string.

Parameters

iInput | String to search
iToken | Subtoken unique name
oValue | Subtoken's readed value
iDefault | Subtoken's default value

Returns

Value | Meaning
VR_OK | if succesfully found
VRERR_TOKENNOTFOUND | when the token was not found
VRERR_TOKENFORMATERROR | when the token is wrongly formatted
VRERR_TOKENWRONGTYPE | when the token was found but is not of integer type

Remarks

 This method is case insensitive regarding the iToken value.
 A subtoken must be formated as (SubTokenName=SubTokenValue) when the
        value doesn't contain any space character or as (SubTokenName="SubToken Value")
        when the value contains or not a space character.
 You will usually use this method to parse the user token on the 'View'
        definition given by VRView::UserTokens.
 When an error occurs, the returned oValue is set to iDefault.

See Also

VRView::UserTokens


VRContext::GetToken

Owner

Method VRContext::GetToken

CKERROR VRContext::GetToken(const XString& iToken, int *oValue, int iDefault=0)
CKERROR VRContext::GetToken(const XString& iToken, float *oValue, float iDefault=0.0f)
CKERROR VRContext::GetToken(const XString& iToken, XString *oValue, XString iDefault="-")

Get a token value.

Parameters

iToken | Token unique name
oValue | Token's read value
iDefault | Default value to return when the token was not found

Returns

Value | Meaning
VR_OK | if successfully found
VRERR_INVALIDCFGFILE | when the configuration file is invalid
VRERR_TOKENNOTFOUND | when the token was not found

Remarks

 This method is case insensitive regarding the iToken value.
 When an error occurs, the returned oValue is set to iDefault.
 The token values is displayed on the output window (Event Log
        or Console Window).

See Also

GetHiddenToken


VRContext::GetExecutionMode

Owner

Method VRContext::GetExecutionMode

VR_EXECUTION_MODE VRContext::GetExecutionMode()

Get the current VR execution mode (Virtools Dev, VRPlayer...)

Returns

Current execution mode

See Also

SetExecutionMode


VRContext::ActivateWarp

Owner

Method VRContext::ActivateWarp

CKERROR VRContext::ActivateWarp(VRView* iView, WarpInfo* iInfo)

Activate the VRPlayer warping mode on the given view.

Parameters

Input argument iView | View to warp
Input argument iInfo | Warping info

Returns

Value | Meaning
VR_OK | if successfully
VRERR_WARPTOOLARGE | when the warping size is too large and a warping texture could not be created for it.

Remarks

 When activating texture warping, this method create a new warping texture
        and set it in iInfo::WarpTexture. This texture is created as a private and
        not for deleted object. All the objects you create for your warping mechanism
        should be created with these flags as well:
        CKObject::ModifyObjectFlags(CK_OBJECT_NOTTOBEDELETED|CK_OBJECT_PRIVATE, 0);
 The VRManager::OnViewWarp callback will be called for each warped view.
        You should implement the final warped rendering in this callback.
 You will usually call this method from VRBaseManager::OnViewCreate.

See Also

VRContext::GetViewCount, VRContext::GetView, VRContext::DeActivateWarp, VRContext::GetWarpTexture, VRBaseManager::OnViewWarp, VRBaseManager::OnViewCreate


VRContext::DeActivateWarp

Owner

Method VRContext::DeActivateWarp

void VRContext::DeActivateWarp(VRView* iView)

Deactivate the VRPlayer warping mode on the given view.

Parameters

Input argument iView

View to unwarp

Remarks

 If a warping texture was used, it is destroyed. So, make sure
        to remove any reference to this texture when unwarping a view.
 You will usually call this method from VRBaseManager::OnViewDelete.

See Also

VRContext::GetViewCount, VRContext::GetView, VRContext::ActivateWarp, VRContext::GetWarpTexture, VRBaseManager::OnViewDelete


VRContext::GetView

Owner

Method VRContext::GetView

VRView* VRContext::GetView(int iIndex)

Get a view of the current host

Parameters

Input argument iIndex

Index of the view (View ID)

Returns

NULL if the view was not found, a pointer on the view information otherwise.

Remarks

 The views are defined by the View_x_x tokens of the
        configuration files.
 The list order is given by the declaration order of the
        configuration files.

See Also

VRContext::GetViewCount


VRContext::GetViewCount

Owner

Method VRContext::GetViewCount

int VRContext::GetViewCount()

Get the number of views on the current host

Returns

View count on the current host

Remarks

 The views are defined by the View_x_x tokens of the
        configuration files.
 The list order is given by the declaration order of the
        configuration files.

See Also

VRContext::GetView, VRContext::GetViewData


VRContext::GetViewData

Owner

Method VRContext::GetViewData

void* VRContext::GetViewData(VRView* iView)

Get the user data attached to a view

Parameters

Input argument iView

View where to get the data from

Returns

The view data or NULL if none was set

See Also

VRContext::GetViewCount, VRContext::GetView, VRContext::SetViewData


VRContext::GetWarpTexture

Owner

Method VRContext::GetWarpTexture

CKTexture* VRContext::GetWarpTexture(VRView* iView)

Get the warping texture used for the given view.

Parameters

Input argument iView

Warped view

Returns

NULL if the view is not warped or not using a warping texture, the warping texture otherwise

See Also

VRContext::GetViewCount, VRContext::GetView, VRContext::ActivateWarp, VRView


VRContext::SetViewData

Owner

Method VRContext::SetViewData

void* VRContext::SetViewData(VRView* iView, void* data)

Attach a user data to a view

Parameters

Input argument iView

View where to get the data from iData: data to set

Returns

The previous data if one was set

See Also

VRContext::GetViewCount, VRContext::GetView, VRContext::GetViewData


Structures

Structure VRView | Information on a view.
Structure WarpInfo | Information on the warping of a view

See Also

VR SDK Reference


VRView

Group

Structure VRView

struct VRView
{
int ID;
XString CameraName;
XString Mode;

int PositionX;
int PositionY;
int Width;
int Height;

int ScreenID;
void* UserData;
XString UserTokens;

DWORD Flags;
CKTexture* WarpTexture;
}

Information on a view.

Members

CameraName | Camera used by the view
Flags | Reserved for internal use - Can be one or more of VR_VIEW_FLAGS
Height | Height in render window
ID | View ID (index) on the host
Mode | Camera mode : none, left, right, quad, custom...
PositionX | X position in render window
PositionY | Y position in render window
ScreenID | Reserved for future use - Screen ID
UserData | User data attached to the view
UserTokens | Additionnal user tokens
WarpTexture | Warping texture if available
Width | Width in render window

Remarks

This structure is filled according to the View_X_X token values of the configuration files.

See Also

VRContext::GetViewCount, VRContext::GetView,


WarpInfo

Group

Structure WarpInfo

struct WarpInfo
{
CKBOOL UseWarpTexture;
int Width;
int Height;
}

Information on the warping of a view

Members

Height | Height of the render target to use
UseWarpTexture | Should we use a render target
Width | Width of the render target to use

Remarks

Width and Height need to be specified only when using a warping texture.

See Also

VRContext::ActivateWarp


Enumerations

Enumerated Type VRMANAGER_FUNCTIONS | Mask for VR Base Manager overridable functions.
Enumerated Type VR_EXECUTION_MODE | Execution mode of the composition: Virtools Dev, VRPlayer...

See Also

VR SDK Reference


VRMANAGER_FUNCTIONS

Group

Enumerated Type VRMANAGER_FUNCTIONS

enum VRMANAGER_FUNCTIONS {
VRMANAGER_FUNC_OnParse = 0x00000001,
VRMANAGER_FUNC_OnViewCreate = 0x00000002,
VRMANAGER_FUNC_OnViewDelete = 0x00000004,
VRMANAGER_FUNC_OnViewWarp = 0x00000008,
}

Mask for VR Base Manager overridable functions.

Members

VRMANAGER_FUNC_OnParse | Called after common parsing and before view creation
VRMANAGER_FUNC_OnViewCreate | Called when a view is created by the VRPlayer
VRMANAGER_FUNC_OnViewDelete | Called when a view is deleted by the VRPlayer
VRMANAGER_FUNC_OnViewWarp | Called when a warped view should be rendered

Remarks

When implementing a VR manager the VRBaseManager::GetValidVRFunctionsMask must be overriden to return a combination of these flag to indicate which VR methods are implemented.

See Also

VRBaseManager::GetValidVRFunctionsMask


VR_EXECUTION_MODE

Group

Enumerated Type VR_EXECUTION_MODE

enum VR_EXECUTION_MODE
{
VREXECUTION_DEV,
VREXECUTION_VRPLAYER,
VREXECUTION_CUSTOM,
}

Execution mode of the composition: Virtools Dev, VRPlayer...

Members

VREXECUTION_CUSTOM | Any other custom player
VREXECUTION_DEV | Virtools Dev
VREXECUTION_VRPLAYER | VRPlayer

Remarks

By default, a VRContext is in Virtools Dev Mode

See Also

VRContext::GetExecutionMode, VRContext::SetExecutionMode


Type Definitions

Globals |
Type Definition VRERROR | A result of this type can be any of CKERR_xx or VRERR_xx defines values

See Also

VR SDK Reference


Globals

External Function VRCloseContext | Close a VRContext created with VRCreateContext.
External Function VRCreateContext | Create a new VRContext
External Function VRErrorToString | Convert a VRERROR code to a descriptive string.
External Function VRGetContext | Get the VRContext attached to the given CKContext

See Also

Type Definitions


VRCloseContext

Group

External Function VRCloseContext

VRERROR VRCloseContext(VRContext* iVRContext)

Close a VRContext created with VRCreateContext.

Parameters

Input argument iVRContext

context to close.

Returns

Value | Meaning
VR_OK | A result of this type can be any of CKERR_xx or VRERR_xx defines values

Remarks

 The VRContext should be close at the end of the application.
 Closing the VRContext will call OnViewDelete on all the VRManager
    to allow the VRBaseManager to delete user datas.

See Also

VRCreateContext, VRGetContext, VRContext.


VRCreateContext

Group

External Function VRCreateContext

VRERROR VRCreateContext(VRContext** oVRContext, CKContext* iCKContext)

Create a new VRContext

Parameters

Output argument oVRContext | created VRContext
Input argument iCKContext | CKContext to which the VRContext is attached. This argument may be NULL to allow getting token values prior to the CKContext creation. In this case, a CKContext is automatically attached when creating the VRMainManager.

Returns

Value | Meaning
VR_OK | if success
VR_ALREADYEXIST | if a VRContext already exist for the given CKContext

Remarks

The created context must be closed with VRCloseContext.

See Also

VRGetContext, VRCloseContext, VRContext.


VRErrorToString

Group

External Function VRErrorToString

CKSTRING VRErrorToString(VRERROR iErr)

Convert a VRERROR code to a descriptive string.

Parameters

Input argument iErr

An error code which description string should be returned.

Returns

A string describing the error.

Remarks

When the error is not a VRERROR, the string returned is “Unknown VR Error”

See Also

VRERROR


VRGetContext

Group

External Function VRGetContext

VRERROR VRGetContext(VRContext** oVRContext, CKContext* iCKContext)
VRContext* VRGetContext( CKContext* iCKContext )

Get the VRContext attached to the given CKContext

Parameters

Output argument oVRContext | The VRContext found, a NULL pointer otherwise.
iCKContext | CKContext to which the VRContext is attached.

Returns

Value | Meaning
VR_OK | A result of this type can be any of CKERR_xx or VRERR_xx defines values

See Also

VRCreateContext, VRCloseContext, VRContext.


VRERROR

Group

Type Definition VRERROR

#define VR_OK 0
#define VRERR_GENERICERROR -300
#define VRERR_INVALIDCFGFILE -301
#define VRERR_INVALIDHOST -302
#define VRERR_TOKENNOTFOUND -303
#define VRERR_TOKENFORMATERROR -304
#define VRERR_TOKENWRONGTYPE -305
#define VRERR_INVALIDVIEW -306
#define VRERR_WARPTOOLARGE -307
#define VRERR_ALREADYEXIST -308
#define VRERR_IMPOSSIBLE -309
#define VRERR_NOVRCONTEXT -310
typedef DWORD VRERROR

A result of this type can be any of CKERR_xx or VRERR_xx defines values

Remarks

+VR_OK: Operation successful, same as CK_OK. +VRERR_GENERICERROR: Generic VR Error when no precise description is available. +VRERR_INVALIDCFGFILE: The VRPack.cfg Configuration file is invalid. +VRERR_INVALIDHOST: The current host is not in the host list. +VRERR_TOKENNOTFOUND: The requested token could not be found. +VRERR_TOKENFORMATERROR: The requested token is wrongly formated. +VRERR_TOKENWRONGTYPE: The requested token has the wrong type. +VRERR_INVALIDVIEW: The given view index is invalid. +VRERR_WARPTOOLARGE: Warping size is too large. A target texture can not be created. +VRERR_ALREADYEXIST: The requested data already exist. +VRERR_IMPOSSIBLE: This error should never be raised +VRERR_NOVRCONTEXT: No VRContext is available (ie, we are not in the VRPlayer).


AUTHOR_GUID

Macro AUTHOR_GUID

#define AUTHOR_GUID VIRTOOLS_GUID


AUTHOR_NAME

Macro AUTHOR_NAME

#define AUTHOR_NAME "Virtools"


DISPLAY_CATEGORY

Macro DISPLAY_CATEGORY

#define DISPLAY_CATEGORY "VR/Visualisation"


DISTRIB_CATEGORY

Macro DISTRIB_CATEGORY

#define DISTRIB_CATEGORY "VR/Cluster"


GUID_PARAMETER_VRANAGLYPH_MODE

Macro GUID_PARAMETER_VRANAGLYPH_MODE

#define GUID_PARAMETER_VRANAGLYPH_MODE CKGUID(0x125d2eb4,0x2f7644a)


GUID_PARAMETER_VRCOMPOSITESTEREO_MODE

Macro GUID_PARAMETER_VRCOMPOSITESTEREO_MODE

#define GUID_PARAMETER_VRCOMPOSITESTEREO_MODE CKGUID(0x34d55edf,0x7d0817b2)


GUID_PARAMETER_VRPATHSMODE

Macro GUID_PARAMETER_VRPATHSMODE

#define GUID_PARAMETER_VRPATHSMODE CKGUID(0x1e904484,0x561134e)


PMREP_VRANAGLYPH_MODE

Macro PMREP_VRANAGLYPH_MODE

#define PMREP_VRANAGLYPH_MODE "Gray=0,Color=1,HalfColor=2,Optimized=3,Manual=4"


PMREP_VRCOMPOSITESTEREO_MODE

Macro PMREP_VRCOMPOSITESTEREO_MODE

#define PMREP_VRCOMPOSITESTEREO_MODE "None=0,Checkerboard=1,Anaglyph=2"


PMREP_VRPATHS_MODE

Macro PMREP_VRPATHS_MODE

#define PMREP_VRPATHS_MODE "AskConfirmation=0,AlwaysAdd=1,NeverAdd=2"


PNAME_VRANAGLYPH_MODE

Macro PNAME_VRANAGLYPH_MODE

#define PNAME_VRANAGLYPH_MODE "VRPack/AnaglyphMode"


PNAME_VRCOMPOSITESTEREO_MODE

Macro PNAME_VRCOMPOSITESTEREO_MODE

#define PNAME_VRCOMPOSITESTEREO_MODE "VRPack/CompositeStereoMode"


PNAME_VRPATHS_MODE

Macro PNAME_VRPATHS_MODE

#define PNAME_VRPATHS_MODE "VRPack/VRPathsMode"


TRCLEVEL_PLUGIN

Macro TRCLEVEL_PLUGIN

#define TRCLEVEL_PLUGIN 2

Remarks

Level after which we display the plugins that were loaded.


VMREP_VRANAGLYPH_MODE

Macro VMREP_VRANAGLYPH_MODE

#define VMREP_VRANAGLYPH_MODE "enum:0=Gray;1=Color;2=HalfColor;3=Optimized;4=Manual"


VMREP_VRCOMPOSITESTEREO_MODE

Macro VMREP_VRCOMPOSITESTEREO_MODE

#define VMREP_VRCOMPOSITESTEREO_MODE "enum:0=None;1=Checkerboard;2=Anaglyph"


VMREP_VRPATHS_MODE

Macro VMREP_VRPATHS_MODE

#define VMREP_VRPATHS_MODE "enum:0=AskConfirmation;1=AlwaysAdd;2=NeverAdd"


VR_COMMON

Macro VR_COMMON

#define VR_COMMON "VR/Core"


VRADDONS_DEVICES_CATEGORY

Macro VRADDONS_DEVICES_CATEGORY

#define VRADDONS_DEVICES_CATEGORY "VR/Devices - Addons"


VRCORE_BEHAVIORS_GUID

Macro VRCORE_BEHAVIORS_GUID

#define VRCORE_BEHAVIORS_GUID CKGUID(0x67fc33ee,0x2ec64ede)


VRDISPLAY_AUTHOR_GUID

Macro VRDISPLAY_AUTHOR_GUID

#define VRDISPLAY_AUTHOR_GUID VIRTOOLS_GUID


VRDISPLAY_AUTHOR_NAME

Macro VRDISPLAY_AUTHOR_NAME

#define VRDISPLAY_AUTHOR_NAME "Virtools"


VRDISPLAY_BEHAVIORS_GUID

Macro VRDISPLAY_BEHAVIORS_GUID

#define VRDISPLAY_BEHAVIORS_GUID CKGUID(0x2e0202b,0x2e083275)


VRDISPLAY_MANAGER_GUID

Macro VRDISPLAY_MANAGER_GUID

#define VRDISPLAY_MANAGER_GUID CKGUID(0x7006831,0x5b8a739f)


VRDISTRIB_BEHAVIORS_GUID

Macro VRDISTRIB_BEHAVIORS_GUID

#define VRDISTRIB_BEHAVIORS_GUID CKGUID(0x6d0f3f29,0xc014d8)


VRDISTRIB_MANAGER_GUID

Macro VRDISTRIB_MANAGER_GUID

#define VRDISTRIB_MANAGER_GUID CKGUID(0x593311eb,0x759a1966)


VRKERNEL_MANAGER_GUID

Macro VRKERNEL_MANAGER_GUID

#define VRKERNEL_MANAGER_GUID CKGUID(0x58480c87,0x4b787f3a)


VRMAIN_MANAGER_GUID

Macro VRMAIN_MANAGER_GUID

#define VRMAIN_MANAGER_GUID CKGUID(0xFB7BBA92,0x14EEE4E3)


VRPN_MANAGER_GUID

Macro VRPN_MANAGER_GUID

#define VRPN_MANAGER_GUID CKGUID(0x50da2d7b,0x59341bcc)


IVRDisplayManager

Class IVRDisplayManager

Interface for the VRDisplay Manager


VRGetFirstManagedContext

External Function VRGetFirstManagedContext

VRContext* VRGetFirstManagedContext( void )


EAnaglyphMode

Enumerated Type EAnaglyphMode

enum EAnaglyphMode
{
eTrue=0,
eGray=1,
eColor=2,
eHalfColor=3,
eOptimized=4,
eManual=5
}

Members

eColor
eGray
eHalfColor
eManual
eOptimized
eTrue


ECompositeStereoMode

Enumerated Type ECompositeStereoMode

enum ECompositeStereoMode
{
eNone = 0,
eCheckerboard = 1,
eAnaglyph = 2
}

Members

eAnaglyph
eCheckerboard
eNone


EVRPathsMode

Enumerated Type EVRPathsMode

enum EVRPathsMode
{
eAskConfirmation = 0,
eAlwaysAdd = 1,
eNeverAdd = 2,
}

Members

eAlwaysAdd | Always Add/Remove paths
eAskConfirmation | Ask user if he wants to add the VR path to DEV path
eNeverAdd | Never Add/Remove paths


FeaturesList

Type Definition FeaturesList

typedef std::list< std::string > FeaturesList


XVRManagerArray

Type Definition XVRManagerArray

typedef XArray<VRBaseManager*> XVRManagerArray


XVRManagerHashTable

Type Definition XVRManagerHashTable

typedef XHashTable<VRBaseManager*,CKGUID> XVRManagerHashTable


XVRManagerHashTableIt

Type Definition XVRManagerHashTableIt

typedef XVRManagerHashTable::Iterator XVRManagerHashTableIt


XVRManagerHashTablePair

Type Definition XVRManagerHashTablePair

typedef XVRManagerHashTable::Pair XVRManagerHashTablePair


VRBaseManager::VRBaseManager

Owner

Method VRBaseManager::VRBaseManager

VRBaseManager::VRBaseManager(CKContext *iCtx, CKGUID guid,CKSTRING Name)

Remarks

Description: Builds an instance of the object

This builds an instance of the object out of its parameters.


VRBaseManager::~VRBaseManager

Owner

Method VRBaseManager::~VRBaseManager

VRBaseManager::~VRBaseManager()

Remarks

Description: Destroys the object

This destroys all the subordinate objects for this object.


Table of Contents

Virtools VR SDK Documentation

VR SDK Principles

Using the VR SDK

VR SDK source code

VR SDK Reference

Classes

VRBaseManager

VRContext

Structures

VRView

WarpInfo

Enumerations

VRMANAGER_FUNCTIONS

VR_EXECUTION_MODE

Type Definitions

Globals

VRCloseContext

VRCreateContext

VRErrorToString

VRGetContext

VRERROR

Ungrouped Objects

_128_ABGR32F

_16_ABGR1555

_16_ABGR4444

_16_ARGB1555

_16_ARGB4444

_16_BGR555

_16_BGR565

_16_D16

_16_L6V5U5

_16_R16F

_16_RGB555

_16_RGB565

_16_V8U8

_24_BGR888

_24_RGB888

_32_ABGR8888

_32_ARGB8888

_32_BGR888

_32_BGRA8888

_32_D24_S8

_32_GR16F

_32_R32F

_32_RGB888

_32_RGBA8888

_32_V16U16

_32_X8L8V8U8

_4_ABGR8888_CLUT

_4_ARGB8888_CLUT

_64_ABGR16F

_64_GR32F

_8_ABGR8888_CLUT

_8_ARGB2222

_8_ARGB8888_CLUT

_8_RGB332

_CKStartUp

_DXT1

_DXT2

_DXT3

_DXT4

_DXT5

_rotl

_rotr

About the Rendering Loop

Absolute

Additionnal Tools

Animation classes

Animation controllers

Animation Keys

ASM_SUPPORTED

AUTHOR_GUID

AUTHOR_NAME

Available Source Code

Base Object Class

BaseClasses

Behavior declarations

Behavior Prototype Creation

BehaviorEngineClasses

Behaviors and Objects Activation

BehaviorsClasses

BGRAFTOCOLOR

Binding New C/C++ functionality for VSL

BITMAP_HANDLE

BITMAP_PATH_IDX

Bitmaps & Fonts functions

BitmapsFunctions

BOOL

Building Block Classes

BYTE

Callback Functions prototypes

Changes in New Version

Changing the Render Engine

ChannelType

CHANNELTYPE_COUNT

CHANNELTYPE_FLOAT1

CHANNELTYPE_FLOAT2

CHANNELTYPE_FLOAT3

CHANNELTYPE_FLOAT4

CHANNELTYPE_MATERIAL

ChooseRef

CK2dCurve

CK2dCurvePoint

CK2dEntity

CK3dEntity

CK3dObject

CK3dPointCloud

CK_2DENTITY_BACKGROUND

CK_2DENTITY_CLIPTOCAMERAVIEW

CK_2DENTITY_CLIPTOPARENT

CK_2DENTITY_FLAGS

CK_2DENTITY_NOTPICKABLE

CK_2DENTITY_POSITIONCHANGED

CK_2DENTITY_RATIOOFFSET

CK_2DENTITY_SIZECHANGED

CK_2DENTITY_STICKBOTTOM

CK_2DENTITY_STICKLEFT

CK_2DENTITY_STICKRIGHT

CK_2DENTITY_STICKTOP

CK_2DENTITY_UPDATEHOMOGENEOUSCOORD

CK_2DENTITY_USEHOMOGENEOUSCOORD

CK_2DENTITY_USESIZE

CK_2DENTITY_USESRCRECT

CK_2DENTITY_VIRTOOLS

CK_3DENTITY_CAMERAIGNOREASPECT

CK_3DENTITY_CHARACTERDOPROCESS

CK_3DENTITY_DEPRECATEDIK

CK_3DENTITY_DISABLESKINPROCESS

CK_3DENTITY_DUMMY

CK_3DENTITY_ENABLESKINOFFSET

CK_3DENTITY_FLAGS

CK_3DENTITY_FRAME

CK_3DENTITY_HIERARCHICALOBSTACLE

CK_3DENTITY_HWSKINING

CK_3DENTITY_IGNOREANIMATION

CK_3DENTITY_IKJOINTVALID

CK_3DENTITY_PARENTVALID

CK_3DENTITY_PLACEVALID

CK_3DENTITY_PORTAL

CK_3DENTITY_RESERVED0

CK_3DENTITY_TARGETCAMERA

CK_3DENTITY_TARGETLIGHT

CK_3DENTITY_UPDATELASTFRAME

CK_3DENTITY_ZORDERVALID

CK_ANIMATION_FLAGS

CK_ANIMATION_TRANSITION_MODE

CK_ARRAYTYPE

CK_ATTRIBUT_CAN_DELETE

CK_ATTRIBUT_CAN_MODIFY

CK_ATTRIBUT_DONOTCOPY

CK_ATTRIBUT_DONOTSAVE

CK_ATTRIBUT_FLAGS

CK_ATTRIBUT_HIDDEN

CK_ATTRIBUT_SYSTEM

CK_ATTRIBUT_TOSAVE

CK_ATTRIBUT_USER

CK_BEHAVIOR_CALLBACKMASK

CK_BEHAVIOR_FLAGS

CK_BEHAVIOR_RETURN

CK_BEHAVIOR_TYPE

CK_BEHAVIORIO_ACTIVE

CK_BEHAVIORIO_IN

CK_BEHAVIORIO_OUT

CK_BEHAVIORPROTOTYPE_FLAGS

CK_BEHAVIORPROTOTYPE_HIDDEN

CK_BEHAVIORPROTOTYPE_NORMAL

CK_BEHAVIORPROTOTYPE_OBSOLETE

CK_BEHRATE_LIMIT

CK_BEHRATE_MASK

CK_BEHRATE_SYNC

CK_BINARYOPERATOR

CK_BITMAP_SAVEOPTIONS

CK_BITMAP_SYSTEMCACHING

CK_BITMAPREADER_ERROR

CK_BONE_LOCAL

CK_BONE_WORLD

CK_BONE_WORLDVIEW

CK_BONES_REFERENTIAL

CK_CLASSID

CK_COMPOPERATOR

CK_CONFIG_DISABLEDINPUT

CK_CONFIG_DISABLEDSOUND

CK_CONFIG_DOWARN

CK_CONFIG_FLAGS

CK_DATAREADER_FILELOAD

CK_DATAREADER_FILESAVE

CK_DATAREADER_FLAGS

CK_DATAREADER_MEMORYLOAD

CK_DATAREADER_MEMORYSAVE

CK_DATAREADER_STREAMFILE

CK_DATAREADER_STREAMURL

CK_DATAREADER_VXSTREAMLOAD

CK_DEPENDENCIES_BUILD

CK_DEPENDENCIES_COPY

CK_DEPENDENCIES_CUSTOM

CK_DEPENDENCIES_DELETE

CK_DEPENDENCIES_FLAGS

CK_DEPENDENCIES_FULL

CK_DEPENDENCIES_NONE

CK_DEPENDENCIES_OPERATIONMODE

CK_DEPENDENCIES_OPMODE

CK_DEPENDENCIES_SAVE

CK_DESTROY_FLAGS

CK_DESTROY_FREEID

CK_DESTROY_NONOTIFY

CK_DESTROY_TEMPOBJECT

CK_EFFECTCALLBACK

CK_EXITINSTANCEFCT

CK_FILE_WRITEMODE

CK_FLOORGEOMETRY

CK_FLOORNEAREST

CK_FOCUSLOST_BEHAVIOR

CK_FOCUSLOST_NONE

CK_FOCUSLOST_PAUSEALL

CK_FOCUSLOST_PAUSEINPUT_MAIN

CK_FOCUSLOST_PAUSEINPUT_PLAYER

CK_FOCUSLOST_PAUSEINPUT_WHENOUT

CK_FRAMERATE_FREE

CK_FRAMERATE_LIMIT

CK_FRAMERATE_LIMITS

CK_FRAMERATE_MASK

CK_FRAMERATE_SYNC

CK_GEOMETRICPRECISION

CK_GRIDORIENTATION

CK_ID

CK_IMPACTINFO

CK_INITINSTANCEFCT

CK_LISTENERSETTINGS_ALL

CK_LISTENERSETTINGS_DISTANCE

CK_LISTENERSETTINGS_DOPPLER

CK_LISTENERSETTINGS_EQ

CK_LISTENERSETTINGS_GAIN

CK_LISTENERSETTINGS_PRIORITY

CK_LISTENERSETTINGS_ROLLOFF

CK_LISTENERSETTINGS_SOFTWARESOURCES

CK_LISTENERSETTINGS_UNITS

CK_LOAD_ANIMATION

CK_LOAD_AS_DYNAMIC_OBJECT

CK_LOAD_ASCHARACTER

CK_LOAD_AUTOMATICMODE

CK_LOAD_CHECKDEPENDENCIES

CK_LOAD_CHECKDUPLICATES

CK_LOAD_DEFAULT

CK_LOAD_DODIALOG

CK_LOAD_FLAGS

CK_LOAD_GEOMETRY

CK_LOAD_KEEP_CKFILE_OBJECT_AFTER_LOAD

CK_LOAD_ONLYBEHAVIORS

CK_LOAD_REPLACEALL_WITHSCRIPT

CK_LOCK_DEFAULT

CK_LOCK_DISCARD

CK_LOCK_NOOVERWRITE

CK_MESHRENDERCALLBACK

CK_MESSAGE_BROADCAST

CK_MESSAGE_GROUP

CK_MESSAGE_SENDINGTYPE

CK_MESSAGE_SINGLE

CK_MOUSEBUTTON

CK_MOUSEBUTTON_4

CK_MOUSEBUTTON_LEFT

CK_MOUSEBUTTON_MIDDLE

CK_MOUSEBUTTON_RIGHT

CK_MOVIEREADER_ERROR

CK_OBJECT_APPDATA

CK_OBJECT_DYNAMIC

CK_OBJECT_FLAGS

CK_OBJECT_FREEID

CK_OBJECT_HIERACHICALHIDE

CK_OBJECT_INTERFACEOBJ

CK_OBJECT_KEEPSINGLEACTIVITY

CK_OBJECT_LOADREPLACINGOBJECT

CK_OBJECT_LOADSKIPBEOBJECT

CK_OBJECT_NAMESHARED

CK_OBJECT_NOTTOBEDELETED

CK_OBJECT_NOTTOBELISTEDANDSAVED

CK_OBJECT_NOTTOBESAVED

CK_OBJECT_PARAMMASK

CK_OBJECT_PRIVATE

CK_OBJECT_SELECTIONSET

CK_OBJECT_SHOWOPTION

CK_OBJECT_SINGLEACTIVITY

CK_OBJECT_TOBEDELETED

CK_OBJECT_UPTODATE

CK_OBJECT_VISIBLE

CK_OBJECT_VR_DISTRIBUTED

CK_OBJECTANIMATION_FLAGS

CK_OBJECTANIMATION_IGNOREMORPH

CK_OBJECTANIMATION_IGNOREPOS

CK_OBJECTANIMATION_IGNOREROT

CK_OBJECTANIMATION_IGNORESCALE

CK_OBJECTANIMATION_IGNORESCALEROT

CK_OBJECTANIMATION_MERGED

CK_OBJECTANIMATION_RESERVED

CK_OBJECTANIMATION_WARPER

CK_OBJECTCREATION_ACTIVATE

CK_OBJECTCREATION_ASK

CK_OBJECTCREATION_DYNAMIC

CK_OBJECTCREATION_FLAGSMASK

CK_OBJECTCREATION_NONAMECHECK

CK_OBJECTCREATION_NONAMECOPY

CK_OBJECTCREATION_OPTIONS

CK_OBJECTCREATION_RENAME

CK_OBJECTCREATION_REPLACE

CK_OBJECTCREATION_USECURRENT

CK_OK

CK_ORTHOGRAPHICPROJECTION

CK_OVERRIDE_MATERIAL

CK_OVERRIDE_NONE

CK_OVERRIDE_PASS

CK_OVERRIDE_RENDERING

CK_OVERRIDE_TECHNIQUE

CK_OVERRIDE_USECURRENT

CK_PARAMETERCHECKFUNCTION

CK_PARAMETERCOPYFUNCTION

CK_PARAMETERCREATEDEFAULTFUNCTION

CK_PARAMETERDELETEFUNCTION

CK_PARAMETERGETCUSTOMOBJECTFUNCTION

CK_PARAMETERIN_DISABLED

CK_PARAMETERIN_THIS

CK_PARAMETEROPERATION

CK_PARAMETEROUT_DELETEAFTERUSE

CK_PARAMETEROUT_PARAMOP

CK_PARAMETERREMAPFUNCTION

CK_PARAMETERSAVELOADFUNCTION

CK_PARAMETERSTRINGFUNCTION

CK_PARAMETERTYPE_FLAGS

CK_PARAMETERUICREATORFUNCTION

CK_PATCH_FLAGS

CK_PATCH_QUAD

CK_PATCH_TRI

CK_PATHMANAGER_CATEGORY

CK_PERSPECTIVEPROJECTION

CK_PLUGIN_TYPE

CK_RAYINTERSECTION

CK_READSUBCHUNK_FLAGS

CK_RENDER_BACKGROUNDSPRITES

CK_RENDER_CLEARBACK

CK_RENDER_CLEARSTENCIL

CK_RENDER_CLEARVIEWPORT

CK_RENDER_CLEARZ

CK_RENDER_DEFAULTSETTINGS

CK_RENDER_DOBACKTOFRONT

CK_RENDER_DONOTUPDATEEXTENTS

CK_RENDER_FLAGS

CK_RENDER_FOREGROUNDSPRITES

CK_RENDER_HINTRENDERATTRIBTEX

CK_RENDER_OPTIONSMASK

CK_RENDER_PLAYERCONTEXT

CK_RENDER_RESTORENEXTFRAME

CK_RENDER_SKIP3D

CK_RENDER_SKIPDRAWSCENE

CK_RENDER_SKIPTRANSPARENT

CK_RENDER_USECAMERARATIO

CK_RENDER_USECURRENTSETTINGS

CK_RENDER_WAITVBL

CK_RENDERCALLBACK

CK_RENDEROBJECT_CALLBACK

CK_RSC_DEFAULT

CK_RSC_SCRATCH

CK_RSC_SKIP

CK_SCENEOBJECT_ACTIVE

CK_SCENEOBJECT_FLAGS

CK_SCENEOBJECT_START_ACTIVATE

CK_SCENEOBJECT_START_DEACTIVATE

CK_SCENEOBJECT_START_LEAVE

CK_SCENEOBJECT_START_RESET

CK_SCENEOBJECTACTIVITY_ACTIVATE

CK_SCENEOBJECTACTIVITY_DEACTIVATE

CK_SCENEOBJECTACTIVITY_DONOTHING

CK_SCENEOBJECTACTIVITY_FLAGS

CK_SCENEOBJECTACTIVITY_SCENEDEFAULT

CK_SCENEOBJECTRESET_DONOTHING

CK_SCENEOBJECTRESET_FLAGS

CK_SCENEOBJECTRESET_RESET

CK_SCENEOBJECTRESET_SCENEDEFAULT

CK_SECONDARYANIMATION_FLAGS

CK_SOUND_SAVEOPTIONS

CK_SOUNDMANAGER_ALL

CK_SOUNDMANAGER_CAPS

CK_SOUNDMANAGER_OCCLUSION

CK_SOUNDMANAGER_ONFLYTYPE

CK_SOUNDMANAGER_REFLECTION

CK_SOUNDREADER_ERROR

CK_TEXTURE_SAVEOPTIONS

CK_TRANSITION_BREAK

CK_TRANSITION_FROMANIMATION

CK_TRANSITION_FROMNOW

CK_TRANSITION_FROMWARPFROMCURRENT

CK_TRANSITION_LOOP

CK_TRANSITION_LOOPIFEQUAL

CK_TRANSITION_TOSTART

CK_TRANSITION_USEVELOCITY

CK_TRANSITION_WARPBEST

CK_TRANSITION_WARPMASK

CK_TRANSITION_WARPPOS

CK_TRANSITION_WARPSAMEPOS

CK_TRANSITION_WARPSTART

CK_TRANSITION_WARPTOBEST

CK_TRANSITION_WARPTOPOS

CK_TRANSITION_WARPTOSAMEPOS

CK_TRANSITION_WARPTOSTART

CK_VB_FAILED

CK_VB_LOST

CK_VB_OK

CK_VIDEO_ASYNCLOAD

CK_VIDEO_AUTHOR_FLAGS

CK_VIDEO_AUTHORMASK

CK_VIDEO_CANLOOP

CK_VIDEO_CANSEEK

CK_VIDEO_CANSPEED

CK_VIDEO_CANSPEEDBACK

CK_VIDEO_DISPLAY

CK_VIDEO_DISPLAYMASK

CK_VIDEO_ERRORS

CK_VIDEO_EVENT

CK_VIDEO_FILE

CK_VIDEO_FINISHED

CK_VIDEO_HASSOUND

CK_VIDEO_INVALID

CK_VIDEO_LIVE

CK_VIDEO_LOADING

CK_VIDEO_LOGOFF

CK_VIDEO_LOOP

CK_VIDEO_MANAGERSAVEOPTION

CK_VIDEO_PAUSED

CK_VIDEO_PLAYING

CK_VIDEO_PREVIEWMASK

CK_VIDEO_RESERVEDAFLAG0

CK_VIDEO_RESERVEDAFLAG1

CK_VIDEO_RESERVEDAFLAG2

CK_VIDEO_RESERVEDAFLAG3

CK_VIDEO_RESERVEDAFLAG4

CK_VIDEO_RESERVEDRFLAG0

CK_VIDEO_RESERVEDRFLAG1

CK_VIDEO_RESERVEDRFLAG2

CK_VIDEO_RESERVEDRFLAG3

CK_VIDEO_RESERVEDRFLAG4

CK_VIDEO_RUNTIME_FLAGS

CK_VIDEO_RUNTIMEMASK

CK_VIDEO_SAVEOPTION

CK_VIDEO_SAVEOPTIONMASK

CK_VIDEO_SCREEN

CK_VIDEO_SOUND

CK_VIDEO_STATE

CK_VIDEO_STATEMASK

CK_VIDEO_STOPPED

CK_VIDEO_STREAM

CK_VIDEO_TEXAUTOFORMAT

CK_VIDEO_TEXAUTOSIZE

CK_VIDEO_TEXFILL

CK_VIDEO_TEXNONPOW2

CK_VIDEO_TEXTURE

CK_VIDEO_TEXTUREREADY

CK_VIDEO_TYPE

CK_VIDEO_TYPEMASK

CK_VIDEO_UNLOADING

CK_VIDEOERR_GENERIC

CK_VIDEOERR_IMPSTART

CK_VIDEOERR_INFO

CK_VIDEOERR_INPUTTYPE

CK_VIDEOERR_LOADED

CK_VIDEOERR_LOADING

CK_VIDEOERR_MAXCOUNT

CK_VIDEOERR_NOPLUGIN

CK_VIDEOERR_NOTLOADED

CK_VIDEOERR_OUTPUTTYPE

CK_VIDEOERR_PLUGINCAPS

CK_VIDEOERR_PREVIEWSTATE

CK_VIDEOERR_PROTOCOL

CK_VIDEOERR_RESERVED0

CK_VIDEOERR_RESERVED1

CK_VIDEOERR_RESERVED2

CK_VIDEOERR_RESERVED3

CK_VIDEOERR_RESERVED4

CK_VIDEOERR_RESERVED5

CK_VIDEOERR_RESERVED6

CK_VIDEOERR_RESERVED7

CK_VIDEOERR_RESERVED8

CK_VIDEOERR_RESERVED9

CK_VIDEOERR_SEEKTIME

CK_VIDEOERR_STATE

CK_VIDEOERR_TEXTURE

CK_VIDEOERR_TEXTURELOCK

CK_VIDEOERR_TEXTUREUSED

CK_VIDEOERR_TIMEOUT

CK_VIDEOERR_UNLOADING

CK_VIDEOERR_VIDEOCAPS

CK_VIDEOEVENT_COUNT

CK_VIDEOEVENT_LOADED

CK_VIDEOEVENT_NEWIMAGE

CK_VIDEOEVENT_PROCESSIMAGE

CK_VIDEOEVENT_UNLOADED

CK_VIDEOSAVE_EXTERNAL

CK_VIDEOSAVE_GLOBAL

CK_VIDEOSAVE_IDBYINDEX

CK_VIDEOSAVE_IDBYNAME

CK_VIDEOSAVE_INTERNAL

CK_WAVESOUND_1ST_REFLECTIONS

CK_WAVESOUND_3DSETTINGS_ALL

CK_WAVESOUND_3DSETTINGS_CONE

CK_WAVESOUND_3DSETTINGS_DISTANCEFACTOR

CK_WAVESOUND_3DSETTINGS_DOPPLERFACTOR

CK_WAVESOUND_3DSETTINGS_HEADRELATIVE

CK_WAVESOUND_3DSETTINGS_MINMAXDISTANCE

CK_WAVESOUND_3DSETTINGS_ORIENTATION

CK_WAVESOUND_3DSETTINGS_POSITION

CK_WAVESOUND_3DSETTINGS_VELOCITY

CK_WAVESOUND_ALLTYPE

CK_WAVESOUND_BACKGROUND

CK_WAVESOUND_CONE

CK_WAVESOUND_COULDBERESTARTED

CK_WAVESOUND_FADE

CK_WAVESOUND_FADEIN

CK_WAVESOUND_FADEOUT

CK_WAVESOUND_FILESTREAMED

CK_WAVESOUND_HASMOVED

CK_WAVESOUND_LOCKENTIREBUFFER

CK_WAVESOUND_LOCKFROMWRITE

CK_WAVESOUND_LOCKMODE

CK_WAVESOUND_LOOPED

CK_WAVESOUND_MONO

CK_WAVESOUND_NEEDREWIND

CK_WAVESOUND_NODUPLICATE

CK_WAVESOUND_OCCLUSIONS

CK_WAVESOUND_PAUSED

CK_WAVESOUND_POINT

CK_WAVESOUND_SETTINGS_ALL

CK_WAVESOUND_SETTINGS_EQUALIZATION

CK_WAVESOUND_SETTINGS_GAIN

CK_WAVESOUND_SETTINGS_PAN

CK_WAVESOUND_SETTINGS_PITCH

CK_WAVESOUND_SETTINGS_PRIORITY

CK_WAVESOUND_STATE

CK_WAVESOUND_STREAMFULLYLOADED

CK_WAVESOUND_STREAMOVERLAP

CK_WAVESOUND_TYPE

CKADD

CKAnimation

CKANIMATION_ALIGNORIENTATION

CKANIMATION_ALLOWTURN

CKANIMATION_BEZIERFLOAT_CONTROL

CKANIMATION_BEZIERPOS_CONTROL

CKANIMATION_BEZIERSCL_CONTROL

CKANIMATION_CANBEBREAK

CKANIMATION_CONTROLLER

CKANIMATION_CONTROLLER_FLOAT

CKANIMATION_CONTROLLER_MASK

CKANIMATION_CONTROLLER_MORPH

CKANIMATION_CONTROLLER_POS

CKANIMATION_CONTROLLER_ROT

CKANIMATION_CONTROLLER_SCL

CKANIMATION_CONTROLLER_SCLAXIS

CKANIMATION_FORCESETSTEP

CKANIMATION_HANDLELOD

CKANIMATION_LINFLOAT_CONTROL

CKANIMATION_LINKTOFRAMERATE

CKANIMATION_LINPOS_CONTROL

CKANIMATION_LINROT_CONTROL

CKANIMATION_LINSCL_CONTROL

CKANIMATION_LINSCLAXIS_CONTROL

CKANIMATION_MORPH_CONTROL

CKANIMATION_SECONDARY_ALL

CKANIMATION_SECONDARY_DOWARP

CKANIMATION_SECONDARY_LASTFRAME

CKANIMATION_SECONDARY_LOOP

CKANIMATION_SECONDARY_LOOPNTIMES

CKANIMATION_SECONDARY_ONESHOT

CKANIMATION_SECONDARY_PRESET

CKANIMATION_SECONDARYWARPER

CKANIMATION_SUBANIMSSORTED

CKANIMATION_TCBFLOAT_CONTROL

CKANIMATION_TCBPOS_CONTROL

CKANIMATION_TCBROT_CONTROL

CKANIMATION_TCBSCL_CONTROL

CKANIMATION_TCBSCLAXIS_CONTROL

CKANIMATION_TRANSITION_ALL

CKANIMATION_TRANSITION_FROMNOW

CKANIMATION_TRANSITION_FROMWARPFROMCURRENT

CKANIMATION_TRANSITION_LOOPIFEQUAL

CKANIMATION_TRANSITION_PRESET

CKANIMATION_TRANSITION_TOSTART

CKANIMATION_TRANSITION_USEVELOCITY

CKANIMATION_TRANSITION_WARPBEST

CKANIMATION_TRANSITION_WARPPOS

CKANIMATION_TRANSITION_WARPSAMEPOS

CKANIMATION_TRANSITION_WARPSTART

CKANIMATION_TRANSITION_WARPTOBEST

CKANIMATION_TRANSITION_WARPTOPOS

CKANIMATION_TRANSITION_WARPTOSAMEPOS

CKANIMATION_TRANSITION_WARPTOSTART

CKAnimController

CKARRAYTYPE_FLOAT

CKARRAYTYPE_INT

CKARRAYTYPE_OBJECT

CKARRAYTYPE_PARAMETER

CKARRAYTYPE_STRING

CKATTRIBUTECALLBACK

CKAttributeCategory

CKAttributeManager

CKAttributeType

CKAttributeVal

CKBaseManager

CKBehavior

CKBEHAVIOR_ACTIVATENEXTFRAME

CKBEHAVIOR_ACTIVE

CKBEHAVIOR_BUILDINGBLOCK

CKBEHAVIOR_CUSTOMEDITDIALOG

CKBEHAVIOR_CUSTOMSETTINGSEDITDIALOG

CKBEHAVIOR_DEACTIVATENEXTFRAME

CKBEHAVIOR_EXECUTEDLASTFRAME

CKBEHAVIOR_INTERNALLYCREATEDINPUTPARAMS

CKBEHAVIOR_INTERNALLYCREATEDINPUTS

CKBEHAVIOR_INTERNALLYCREATEDLOCALPARAMS

CKBEHAVIOR_INTERNALLYCREATEDOUTPUTPARAMS

CKBEHAVIOR_INTERNALLYCREATEDOUTPUTS

CKBEHAVIOR_LAUNCHEDONCE

CKBEHAVIOR_LOCKED

CKBEHAVIOR_MESSAGERECEIVER

CKBEHAVIOR_MESSAGESENDER

CKBEHAVIOR_NONE

CKBEHAVIOR_PRIORITYMAX

CKBEHAVIOR_PRIORITYMIN

CKBEHAVIOR_RESERVED0

CKBEHAVIOR_RESERVED1

CKBEHAVIOR_RESERVED2

CKBEHAVIOR_RESETNEXTFRAME

CKBEHAVIOR_SCRIPT

CKBEHAVIOR_TARGETABLE

CKBEHAVIOR_TOPMOST

CKBEHAVIOR_USEFUNCTION

CKBEHAVIOR_VARIABLEINPUTS

CKBEHAVIOR_VARIABLEOUTPUTS

CKBEHAVIOR_VARIABLEPARAMETERINPUTS

CKBEHAVIOR_VARIABLEPARAMETEROUTPUTS

CKBEHAVIOR_WAITSFORMESSAGE

CKBEHAVIORCALLBACKFCT

CKBehaviorContext

CKBEHAVIORFCT

CKBehaviorIO

CKBehaviorLink

CKBEHAVIORLINK_ACTIVATEDLASTFRAME

CKBEHAVIORLINK_RESERVED

CKBehaviorManager

CKBehaviorPrototype

CKBEHAVIORTYPE_BASE

CKBEHAVIORTYPE_BEHAVIOR

CKBEHAVIORTYPE_SCRIPT

CKBeObject

CKBezierFloatKey

CKBEZIERKEY_FLAGS

CKBezierKeyFlags

CKBezierPositionKey

CKBezierScaleKey

CKBITMAP_DISCARD

CKBITMAP_PROCEDURAL

CKBITMAP_VIDEOSHADOW

CKBitmapData

CKBITMAPERROR_FILECORRUPTED

CKBITMAPERROR_GENERIC

CKBITMAPERROR_READERROR

CKBITMAPERROR_SAVEERROR

CKBITMAPERROR_UNSUPPORTEDFILE

CKBITMAPERROR_UNSUPPORTEDFUNCTION

CKBITMAPERROR_UNSUPPORTEDSAVEFORMAT

CKBitmapProperties

CKBitmapReader

CKBlendShape

CKBlendShapeInitialVertex

CKBlendShapeSet

CKBlendShapeVertexDelta

CKBodyPart

CKBOOL

CKBR_ACTIVATENEXTFRAME

CKBR_ATTACHFAILED

CKBR_BEHAVIORERROR

CKBR_BEHAVIORERROR_RETRY

CKBR_BREAK

CKBR_DETACHFAILED

CKBR_GENERICERROR

CKBR_GENERICERROR_RETRY

CKBR_INFINITELOOP

CKBR_LOCKED

CKBR_OK

CKBR_OWNERERROR

CKBR_OWNERERROR_RETRY

CKBR_PARAMETERERROR

CKBR_PARAMETERERROR_RETRY

CKBYTE

CKCamera

CKCB_BEHAVIORACTIVATESCRIPT

CKCB_BEHAVIORALL

CKCB_BEHAVIORATTACH

CKCB_BEHAVIORBASE

CKCB_BEHAVIORCREATE

CKCB_BEHAVIORDEACTIVATESCRIPT

CKCB_BEHAVIORDELETE

CKCB_BEHAVIORDETACH

CKCB_BEHAVIOREDITED

CKCB_BEHAVIOREDITIONS

CKCB_BEHAVIORLOAD

CKCB_BEHAVIORNEWSCENE

CKCB_BEHAVIORPAUSE

CKCB_BEHAVIORPOSTSAVE

CKCB_BEHAVIORPPR

CKCB_BEHAVIORPRESAVE

CKCB_BEHAVIORREADSTATE

CKCB_BEHAVIORRENAME

CKCB_BEHAVIORRESET

CKCB_BEHAVIORRESETINBREAKPOINT

CKCB_BEHAVIORRESUME

CKCB_BEHAVIORSAVELOAD

CKCB_BEHAVIORSETTINGSEDITED

CKCHAR

CKCharacter

CKCID_2DENTITY

CKCID_3DENTITY

CKCID_3DOBJECT

CKCID_ANIMATION

CKCID_BEHAVIOR

CKCID_BEHAVIORIO

CKCID_BEHAVIORLINK

CKCID_BEOBJECT

CKCID_BODYPART

CKCID_CAMERA

CKCID_CHARACTER

CKCID_CRITICALSECTION

CKCID_CURVE

CKCID_CURVEPOINT

CKCID_DATAARRAY

CKCID_GRID

CKCID_GROUP

CKCID_KEYEDANIMATION

CKCID_KINEMATICCHAIN

CKCID_LAYER

CKCID_LEVEL

CKCID_LIGHT

CKCID_MATERIAL

CKCID_MAXCLASSID

CKCID_MESH

CKCID_MIDISOUND

CKCID_OBJECT

CKCID_OBJECTANIMATION

CKCID_PARAMETER

CKCID_PARAMETERIN

CKCID_PARAMETERLOCAL

CKCID_PARAMETEROPERATION

CKCID_PARAMETEROUT

CKCID_PARAMETERVARIABLE

CKCID_PATCHMESH

CKCID_PLACE

CKCID_PROGRESSIVEMESH

CKCID_RENDERCONTEXT

CKCID_RENDEROBJECT

CKCID_SCENE

CKCID_SCENEOBJECT

CKCID_SOUND

CKCID_SPRITE

CKCID_SPRITE3D

CKCID_SPRITETEXT

CKCID_STATE

CKCID_SYNCHRO

CKCID_TARGETCAMERA

CKCID_TARGETLIGHT

CKCID_TEXTURE

CKCID_WAVESOUND

CKClassIDToCppClassName

CKClassIDToString

CKCloseContext

CKCOLLISION_BOX

CKCOLLISION_FACE

CKCOLLISION_NONE

CKCollisionManager

CKComputeDataCRC

CKContext

CKConvertEndian16

CKConvertEndian32

CKConvertEndianArray16

CKConvertEndianArray32

CKCopyBitmapProperties

CKCopyDefaultClassDependencies

CKCreateContext

CKCriticalSectionObject

CKCurve

CKCurvePoint

CKCustomParameter

CKDataArray

CKDataReader

CKDeletePointer

CKDependencies

CKDependenciesContext

CKDestroyObject

CKDirectoryParser

CKDIV

CKDLL_CREATEPROTOFUNCTION

CKDLL_OBJECTDECLARATIONFUNCTION

CKDWORD

CKEQUAL

CKERR_ALREADYFULLSCREEN

CKERR_ALREADYPRESENT

CKERR_ALREADYREGISTREDDLL

CKERR_BEHAVIORADDDENIEDBYCB

CKERR_CANCELLED

CKERR_CANCREATERENDERCONTEXT

CKERR_CANTWRITETOFILE

CKERR_DINPUTDISABLED

CKERR_FILECRCERROR

CKERR_INCOMPATIBLECLASSID

CKERR_INCOMPATIBLEPARAMETERS

CKERR_INVALIDANIMATION

CKERR_INVALIDCONDSOLEWINDOW

CKERR_INVALIDDLL

CKERR_INVALIDFILE

CKERR_INVALIDGUID

CKERR_INVALIDINDEX

CKERR_INVALIDKINEMATICCHAIN

CKERR_INVALIDMESSAGE

CKERR_INVALIDOBJECT

CKERR_INVALIDOPERATION

CKERR_INVALIDPARAMETER

CKERR_INVALIDPARAMETERTYPE

CKERR_INVALIDPLUGIN

CKERR_INVALIDPROTOTYPE

CKERR_INVALIDRENDERCONTEXT

CKERR_INVALIDSIZE

CKERR_MANAGERALREADYEXISTS

CKERR_NOANIMATIONKEY

CKERR_NOCURRENTLEVEL

CKERR_NODLLFOUND

CKERR_NOJOYSTICK

CKERR_NOKEYBOARD

CKERR_NOLEVEL

CKERR_NOLOADPLUGINS

CKERR_NOMOUSE

CKERR_NORENDERENGINE

CKERR_NOSAVEPLUGINS

CKERR_NOTENOUGHDISKPLACE

CKERR_NOTFOUND

CKERR_NOTIFICATIONNOTHANDLED

CKERR_NOTIMPLEMENTED

CKERR_NOTINITIALIZED

CKERR_OBSOLETEVIRTOOLS

CKERR_OPERATIONNOTIMPLEMENTED

CKERR_OUTOFMEMORY

CKERR_PAUSED

CKERR_PLUGINSMISSING

CKERR_RENDERCONTEXTINACTIVE

CKERR_SOUNDDISABLED

CKERROR

CKErrorToString

CKFile

CKFILE_CHUNKCOMPRESSED_OLD

CKFILE_EXTERNALTEXTURES_OLD

CKFILE_FORVIEWER

CKFILE_UNCOMPRESSED

CKFILE_WHOLECOMPRESSED

CKFileExtension

CKFileExtensionShort

CKFileInfo

CKFileObject

CKFilePluginDependencies

CKFloatKey

CKFLOOR_BOX

CKFLOOR_DOWN

CKFLOOR_FACES

CKFLOOR_NOFLOOR

CKFLOOR_UP

CKFloorManager

CKFloorPoint

CKGetClassCount

CKGetCommonParent

CKGetDefaultClassDependencies

CKGetObjectDeclarationFromGuid

CKGetParentClassID

CKGetPluginManager

CKGetPrototypeDeclaration

CKGetPrototypeDeclarationCount

CKGetPrototypeFromGuid

CKGetStartPath

CKGetVersion

CKGREATER

CKGREATEREQUAL

CKGrid

CKGRID_FREE

CKGRID_LAYER_FORMAT

CKGRID_LAYER_FORMAT_NORMAL

CKGRID_XY

CKGRID_XZ

CKGRID_YZ

CKGridManager

CKGroup

CKGUID

CKHIDE

CKHIERARCHICALHIDE

CKInitCustomPlayer

CKInputManager

CKIsChildClassOf

CKKey

CKKeyedAnimation

CKKinematicChain

CKLayer

CKLESSER

CKLESSEREQUAL

CKLevel

CKLight

CKListenerSettings

CKLoadBitmap

CKLOCKFLAGS

CKM_BEHAVIORACTIVATESCRIPT

CKM_BEHAVIORATTACH

CKM_BEHAVIORCREATE

CKM_BEHAVIORDEACTIVATESCRIPT

CKM_BEHAVIORDELETE

CKM_BEHAVIORDETACH

CKM_BEHAVIOREDITED

CKM_BEHAVIORLOAD

CKM_BEHAVIORNEWSCENE

CKM_BEHAVIORPAUSE

CKM_BEHAVIORPOSTSAVE

CKM_BEHAVIORPRESAVE

CKM_BEHAVIORREADSTATE

CKM_BEHAVIORRENAMED

CKM_BEHAVIORRESET

CKM_BEHAVIORRESETINBREAKBPOINT

CKM_BEHAVIORRESUME

CKM_BEHAVIORSETTINGSEDITED

CKM_MAX_BEHAVIOR_CALLBACKS

CKMANAGER_FUNC_OnCKEnd

CKMANAGER_FUNC_OnCKInit

CKMANAGER_FUNC_OnCKPause

CKMANAGER_FUNC_OnCKPlay

CKMANAGER_FUNC_OnCKPostReset

CKMANAGER_FUNC_OnCKReset

CKMANAGER_FUNC_OnPostBackToFront

CKMANAGER_FUNC_OnPostCopy

CKMANAGER_FUNC_OnPostFullScreen

CKMANAGER_FUNC_OnPostRender

CKMANAGER_FUNC_OnPostSpriteRender

CKMANAGER_FUNC_OnPreBackToFront

CKMANAGER_FUNC_OnPreCopy

CKMANAGER_FUNC_OnPreFullScreen

CKMANAGER_FUNC_OnPreRender

CKMANAGER_FUNC_OnPreSpriteRender

CKMANAGER_FUNC_OnRasterizerEvent

CKMANAGER_FUNC_OnSequenceAddedToScene

CKMANAGER_FUNC_OnSequenceDeleted

CKMANAGER_FUNC_OnSequenceRemovedFromScene

CKMANAGER_FUNC_OnSequenceToBeDeleted

CKMANAGER_FUNC_PostClearAll

CKMANAGER_FUNC_PostLaunchScene

CKMANAGER_FUNC_PostLoad

CKMANAGER_FUNC_PostProcess

CKMANAGER_FUNC_PostSave

CKMANAGER_FUNC_PreClearAll

CKMANAGER_FUNC_PreLaunchScene

CKMANAGER_FUNC_PreLoad

CKMANAGER_FUNC_PreProcess

CKMANAGER_FUNC_PreSave

CKMANAGER_FUNCTIONS

CKMaterial

CKMaterialShader

CKMesh

CKMessage

CKMessageHandler

CKMessageManager

CKMessageType

CKMidiManager

CKMidiSound

CKModelReader

CKMorphController

CKMorphKey

CKMOVIEERROR_FILECORRUPTED

CKMOVIEERROR_GENERIC

CKMOVIEERROR_READERROR

CKMOVIEERROR_SAVEERROR

CKMOVIEERROR_UNSUPPORTEDFILE

CKMOVIEERROR_UNSUPPORTEDSAVEFORMAT

CKMovieProperties

CKMovieReader

CKMUL

CKNOTEQUAL

CKObject

CKOBJECT_PRIORITYDEFAULT

CKOBJECT_PRIORITYLEVEL

CKOBJECT_PRIORITYMAX

CKOBJECT_PRIORITYMIN

CKOBJECT_PRIORITYPLACE

CKOBJECT_PRIORITYSCENE

CKObjectAnimation

CKObjectArray

CKObjectDeclaration

CKObjectsFunctions

CKOBJID

CKOperationDesc

CKOperationType

CKPackData

CKParameter

CKParameterIn

CKParameterLocal

CKParameterManager

CKParameterOperation

CKParameterOut

CKParameterType

CKPARAMETERTYPE_ENUMS

CKPARAMETERTYPE_FLAGS

CKPARAMETERTYPE_HIDDEN

CKPARAMETERTYPE_NOENDIANCONV

CKPARAMETERTYPE_RESERVED

CKPARAMETERTYPE_STRUCT

CKPARAMETERTYPE_TOSAVE

CKPARAMETERTYPE_USER

CKPARAMETERTYPE_VARIABLESIZE

CKParameterTypeDesc

CKParameterVariable

CKPatch

CKPatchEdge

CKPatchMesh

CKPathMaker

CKPathManager

CKPathSplitter

CKPGUID_2DCURVE

CKPGUID_2DENTITY

CKPGUID_2DVECTOR

CKPGUID_3DENTITY

CKPGUID_3DPOINTCLOUD

CKPGUID_3DSPRITEMODE

CKPGUID_ADDRESSMODE

CKPGUID_ANGLE

CKPGUID_ANIMATION

CKPGUID_ARRAYTYPE

CKPGUID_ATTRIBUTE

CKPGUID_AXIS

CKPGUID_BEHAVIOR

CKPGUID_BEOBJECT

CKPGUID_BINARYOPERATOR

CKPGUID_BITMAP_SYSTEMCACHING

CKPGUID_BLENDFACTOR

CKPGUID_BLENDMODE

CKPGUID_BODYPART

CKPGUID_BOOL

CKPGUID_BOX

CKPGUID_BUMPMAPPARAM

CKPGUID_CAMERA

CKPGUID_CHARACTER

CKPGUID_CLASSID

CKPGUID_COLOR

CKPGUID_COMBINE2TEX

CKPGUID_COMBINE3TEX

CKPGUID_COMPOPERATOR

CKPGUID_COPYDEPENDENCIES

CKPGUID_CRITICALSECTION

CKPGUID_CURVE

CKPGUID_CURVEPOINT

CKPGUID_CUSTOMIZEDPARAM

CKPGUID_DATAARRAY

CKPGUID_DELETEDEPENDENCIES

CKPGUID_DIRECTION

CKPGUID_ENUMS

CKPGUID_EULERANGLES

CKPGUID_FILLMODE

CKPGUID_FILTER

CKPGUID_FILTERMODE

CKPGUID_FLAGS

CKPGUID_FLOAT

CKPGUID_FLOATSLIDER

CKPGUID_FLOOR

CKPGUID_FLOORGEOMETRY

CKPGUID_FOCUSLOST_BEHAVIOR

CKPGUID_FOGMODE

CKPGUID_GLOBALEXMODE

CKPGUID_GROUP

CKPGUID_HOST_PLATFORM

CKPGUID_ID

CKPGUID_INT

CKPGUID_KERNELERROR

CKPGUID_KEY

CKPGUID_KINEMATICCHAIN

CKPGUID_LAYERTYPE

CKPGUID_LEVEL

CKPGUID_LIGHT

CKPGUID_LIGHTTYPE

CKPGUID_LITMODE

CKPGUID_MATERIAL

CKPGUID_MATERIALEFFECT

CKPGUID_MATRIX

CKPGUID_MESH

CKPGUID_MESSAGE

CKPGUID_MIDISOUND

CKPGUID_NONE

CKPGUID_OBJECT

CKPGUID_OBJECT3D

CKPGUID_OBJECTANIMATION

CKPGUID_OBJECTARRAY

CKPGUID_OBSTACLE

CKPGUID_OBSTACLEPRECISION

CKPGUID_OBSTACLEPRECISIONBEH

CKPGUID_OLDTIME

CKPGUID_PARAMETERTYPE

CKPGUID_PASS

CKPGUID_PATCHMESH

CKPGUID_PERCENTAGE

CKPGUID_PIXELFORMAT

CKPGUID_PLACE

CKPGUID_POINTER

CKPGUID_QUATERNION

CKPGUID_RECT

CKPGUID_RENDEROBJECT

CKPGUID_RENDEROPTIONS

CKPGUID_REPLACEDEPENDENCIES

CKPGUID_SAVEDEPENDENCIES

CKPGUID_SCENE

CKPGUID_SCENEACTIVITYFLAGS

CKPGUID_SCENEOBJECT

CKPGUID_SCENERESETFLAGS

CKPGUID_SCRIPT

CKPGUID_SETOPERATOR

CKPGUID_SHADEMODE

CKPGUID_SHADER

CKPGUID_SHADOWMAPATTENUATIONMODE

CKPGUID_SHADOWMAPFALLBACKPOLICY

CKPGUID_SHADOWMAPFORMAT

CKPGUID_SHADOWMAPTAPCOUNT

CKPGUID_SOUND

CKPGUID_SPRITE

CKPGUID_SPRITE3D

CKPGUID_SPRITEALIGN

CKPGUID_SPRITETEXT

CKPGUID_SPRITETEXTALIGNMENT

CKPGUID_STATE

CKPGUID_STATECHUNK

CKPGUID_STRING

CKPGUID_STRUCTS

CKPGUID_SUPPORT

CKPGUID_SYNCHRO

CKPGUID_TARGETCAMERA

CKPGUID_TARGETLIGHT

CKPGUID_TECHENUM

CKPGUID_TECHNIQUE

CKPGUID_TEXCOMBINE

CKPGUID_TEXGENEFFECT

CKPGUID_TEXGENREFEFFECT

CKPGUID_TEXTURE

CKPGUID_TIME

CKPGUID_UNICODESTRING

CKPGUID_VECTOR

CKPGUID_VECTOR4

CKPGUID_VIDEO

CKPGUID_VOIDBUF

CKPGUID_WAVESOUND

CKPGUID_WRAPMODE

CKPGUID_ZFUNC

CKPlace

CKPLUGIN_BEHAVIOR

CKPLUGIN_BEHAVIOR_DLL

CKPLUGIN_BITMAP

CKPLUGIN_BITMAP_READER

CKPLUGIN_EXTENSION_DLL

CKPLUGIN_EXTENSIONS

CKPLUGIN_MANAGER

CKPLUGIN_MANAGER_DLL

CKPLUGIN_MODEL

CKPLUGIN_MODEL_READER

CKPLUGIN_MOVIE

CKPLUGIN_MOVIE_READER

CKPLUGIN_RENDERENGINE

CKPLUGIN_RENDERENGINE_DLL

CKPLUGIN_SOUND

CKPLUGIN_SOUND_READER

CKPluginDll

CKPluginEntry

CKPluginEntryBehaviorsData

CKPluginEntryReadersData

CKPluginGetInfoCountFunction

CKPluginGetInfoFunction

CKPluginInfo

CKPluginManager

CKPOINT

CKPositionKey

CKRAYINTERSECTION_DEFAULT

CKRAYINTERSECTION_FIRSTCONTACT

CKRAYINTERSECTION_IGNOREALPHA

CKRAYINTERSECTION_IGNOREBOTHSIDED

CKRAYINTERSECTION_IGNORECULLING

CKRAYINTERSECTION_SEGMENT

CKReaderGetReaderFunction

CKReadObjectState

CKRECT

CKRenderContext

CKRenderManager

CKRenderObject

CKRotationKey

CKRRCALLBACKFCT

CKRST_2DCAPS

CKRST_2DCAPS_3D

CKRST_2DCAPS_GDI

CKRST_2DCAPS_WINDOWED

CKRST_ALCHEMY

CKRST_BLENDCAPS

CKRST_BLENDCAPS_BOTHINVSRCALPHA

CKRST_BLENDCAPS_BOTHSRCALPHA

CKRST_BLENDCAPS_DESTALPHA

CKRST_BLENDCAPS_DESTCOLOR

CKRST_BLENDCAPS_INVDESTALPHA

CKRST_BLENDCAPS_INVDESTCOLOR

CKRST_BLENDCAPS_INVSRCALPHA

CKRST_BLENDCAPS_INVSRCCOLOR

CKRST_BLENDCAPS_ONE

CKRST_BLENDCAPS_SRCALPHA

CKRST_BLENDCAPS_SRCALPHASAT

CKRST_BLENDCAPS_SRCCOLOR

CKRST_BLENDCAPS_ZERO

CKRST_CMPCAPS

CKRST_CMPCAPS_ALWAYS

CKRST_CMPCAPS_EQUAL

CKRST_CMPCAPS_GREATER

CKRST_CMPCAPS_GREATEREQUAL

CKRST_CMPCAPS_LESS

CKRST_CMPCAPS_LESSEQUAL

CKRST_CMPCAPS_NEVER

CKRST_CMPCAPS_NOTEQUAL

CKRST_DIRECTX

CKRST_DP_CL_V

CKRST_DP_CL_VC

CKRST_DP_CL_VCST

CKRST_DP_CL_VCT

CKRST_DP_DIFFUSE

CKRST_DP_DOCLIP

CKRST_DP_IWEIGHT

CKRST_DP_LIGHT

CKRST_DP_MATRIXPAL

CKRST_DP_SPECULAR

CKRST_DP_STAGE

CKRST_DP_STAGEFLAGS

CKRST_DP_STAGES0

CKRST_DP_STAGES1

CKRST_DP_STAGES2

CKRST_DP_STAGES3

CKRST_DP_STAGES4

CKRST_DP_STAGES5

CKRST_DP_STAGES6

CKRST_DP_STAGES7

CKRST_DP_STAGESMASK

CKRST_DP_TANSPACE

CKRST_DP_TR_CL_V

CKRST_DP_TR_CL_VC

CKRST_DP_TR_CL_VCS

CKRST_DP_TR_CL_VCST

CKRST_DP_TR_CL_VCT

CKRST_DP_TR_CL_VNT

CKRST_DP_TR_V

CKRST_DP_TR_VC

CKRST_DP_TR_VCS

CKRST_DP_TR_VCST

CKRST_DP_TR_VCT

CKRST_DP_TR_VNT

CKRST_DP_TRANSFORM

CKRST_DP_TRANSFORMW

CKRST_DP_V

CKRST_DP_VBUFFER

CKRST_DP_VC

CKRST_DP_VCST

CKRST_DP_VCT

CKRST_DP_WEIGHT

CKRST_DP_WEIGHTMASK

CKRST_DP_WEIGHTS1

CKRST_DP_WEIGHTS2

CKRST_DP_WEIGHTS3

CKRST_DP_WEIGHTS4

CKRST_DP_WEIGHTS5

CKRST_DPFLAGS

CKRST_EVENT_CREATE

CKRST_EVENT_DESTROY

CKRST_EVENT_LOST

CKRST_EVENT_RESET

CKRST_EVENT_RESIZED

CKRST_EVENT_RESIZING

CKRST_EVENTS

CKRST_MAX_STAGES

CKRST_MISCCAPS

CKRST_MISCCAPS_CONFORMANT

CKRST_MISCCAPS_CULLCCW

CKRST_MISCCAPS_CULLCW

CKRST_MISCCAPS_CULLNONE

CKRST_MISCCAPS_MASKZ

CKRST_OPENGL

CKRST_RASTERCAPS

CKRST_RASTERCAPS_ANISOTROPY

CKRST_RASTERCAPS_DITHER

CKRST_RASTERCAPS_FOGPIXEL

CKRST_RASTERCAPS_FOGRANGE

CKRST_RASTERCAPS_FOGVERTEX

CKRST_RASTERCAPS_SUBPIXEL

CKRST_RASTERCAPS_WBUFFER

CKRST_RASTERCAPS_WFOG

CKRST_RASTERCAPS_ZBIAS

CKRST_RASTERCAPS_ZBUFFERLESSHSR

CKRST_RASTERCAPS_ZFOG

CKRST_RASTERCAPS_ZTEST

CKRST_RSTFAMILY

CKRST_SOFT

CKRST_SPECIFICCAPS

CKRST_SPECIFICCAPS_AUTGENMIPMAP

CKRST_SPECIFICCAPS_BLENDTEXTEFFECT

CKRST_SPECIFICCAPS_CANDOINDEXBUFFER

CKRST_SPECIFICCAPS_CANDOVERTEXBUFFER

CKRST_SPECIFICCAPS_CLAMPEDGEALPHA

CKRST_SPECIFICCAPS_COPYTEXTURE

CKRST_SPECIFICCAPS_DX5

CKRST_SPECIFICCAPS_DX7

CKRST_SPECIFICCAPS_DX8

CKRST_SPECIFICCAPS_DX9

CKRST_SPECIFICCAPS_GLATTENUATIONMODEL

CKRST_SPECIFICCAPS_HARDWARE

CKRST_SPECIFICCAPS_HARDWARETL

CKRST_SPECIFICCAPS_HW_SKINNING

CKRST_SPECIFICCAPS_POINTSPRITES

CKRST_SPECIFICCAPS_SOFTWARE

CKRST_SPECIFICCAPS_SPRITEASTEXTURES

CKRST_SPECIFICCAPS_SUPPORTSHADERS

CKRST_SPECIFICCAPS_VERTEXCOLORABGR

CKRST_STENCILCAPS

CKRST_STENCILCAPS_DECR

CKRST_STENCILCAPS_DECRSAT

CKRST_STENCILCAPS_INCR

CKRST_STENCILCAPS_INCRSAT

CKRST_STENCILCAPS_INVERT

CKRST_STENCILCAPS_KEEP

CKRST_STENCILCAPS_REPLACE

CKRST_STENCILCAPS_ZERO

CKRST_STRETCHRECT_BAD_CUBE_FACE_ERROR

CKRST_STRETCHRECT_BLIT_FROM_MULTISAMPLED_BACKBUFFER_ERROR

CKRST_STRETCHRECT_BLIT_TO_MULTISAMPLED_BACKBUFFER_ERROR

CKRST_STRETCHRECT_DEST_EQUAL_SOURCE_ERROR

CKRST_STRETCHRECT_DEST_RECT_ERROR

CKRST_STRETCHRECT_ERROR

CKRST_STRETCHRECT_NO_ERROR

CKRST_STRETCHRECT_NONPOW2_DEST_TEX_ERROR

CKRST_STRETCHRECT_NONPOW2_SRC_TEX_ERROR

CKRST_STRETCHRECT_OPERATION_FAILED_ERROR

CKRST_STRETCHRECT_SRC_RECT_ERROR

CKRST_STRETCHRECT_UNSUPPORTED

CKRST_TADDRESSCAPS

CKRST_TADDRESSCAPS_BORDER

CKRST_TADDRESSCAPS_CLAMP

CKRST_TADDRESSCAPS_INDEPENDENTUV

CKRST_TADDRESSCAPS_MIRROR

CKRST_TADDRESSCAPS_WRAP

CKRST_TEXTURECAPS

CKRST_TEXTURECAPS_ALPHA

CKRST_TEXTURECAPS_CONDITIONALNONPOW2

CKRST_TEXTURECAPS_CUBEMAP

CKRST_TEXTURECAPS_PERSPECTIVE

CKRST_TEXTURECAPS_POW2

CKRST_TEXTURECAPS_PROJECTED

CKRST_TEXTURECAPS_SQUAREONLY

CKRST_TEXTURECAPS_VOLUMEMAP

CKRST_TEXTURESTAGESTATETYPE

CKRST_TFILTERCAPS

CKRST_TFILTERCAPS_ANISOTROPIC

CKRST_TFILTERCAPS_LINEAR

CKRST_TFILTERCAPS_LINEARMIPLINEAR

CKRST_TFILTERCAPS_LINEARMIPNEAREST

CKRST_TFILTERCAPS_MIPLINEAR

CKRST_TFILTERCAPS_MIPNEAREST

CKRST_TFILTERCAPS_NEAREST

CKRST_TSS_AARG1

CKRST_TSS_AARG2

CKRST_TSS_ADDRESS

CKRST_TSS_ADDRESSU

CKRST_TSS_ADDRESSV

CKRST_TSS_ADDRESW

CKRST_TSS_ALPHAARG0

CKRST_TSS_AOP

CKRST_TSS_ARG1

CKRST_TSS_ARG2

CKRST_TSS_BORDERCOLOR

CKRST_TSS_BUMPENVLOFFSET

CKRST_TSS_BUMPENVLSCALE

CKRST_TSS_BUMPENVMAT00

CKRST_TSS_BUMPENVMAT01

CKRST_TSS_BUMPENVMAT10

CKRST_TSS_BUMPENVMAT11

CKRST_TSS_COLORARG0

CKRST_TSS_MAGFILTER

CKRST_TSS_MAXANISOTROPY

CKRST_TSS_MAXMIPMLEVEL

CKRST_TSS_MINFILTER

CKRST_TSS_MIPMAPLODBIAS

CKRST_TSS_OP

CKRST_TSS_RESULTARG0

CKRST_TSS_STAGEBLEND

CKRST_TSS_TEXCOORDINDEX

CKRST_TSS_TEXTUREMAPBLEND

CKRST_TSS_TEXTURETRANSFORMFLAGS

CKRST_UNKNOWN

CKRST_VTXCAPS

CKRST_VTXCAPS_DIRECTIONALLIGHTS

CKRST_VTXCAPS_LOCALVIEWER

CKRST_VTXCAPS_MATERIALSOURCE

CKRST_VTXCAPS_POSITIONALLIGHTS

CKRST_VTXCAPS_TEXGEN

CKRST_VTXCAPS_VERTEXFOG

CKSaveBitmap

CKSaveObjectState

CKScaleAxisKey

CKScaleKey

CKScene

CKSceneObject

CKSceneObjectIterator

CKSECONDARYANIMATION_DOWARP

CKSECONDARYANIMATION_FROMANIMATION

CKSECONDARYANIMATION_LASTFRAME

CKSECONDARYANIMATION_LOOP

CKSECONDARYANIMATION_LOOPNTIMES

CKSECONDARYANIMATION_ONESHOT

CKShader

CKShaderManager

CKSHOW

CKShutdown

CKSkin

CKSkinBoneData

CKSkinVertexData

CKSound

CKSOUND_EXTERNAL

CKSOUND_INCLUDEORIGINALFILE

CKSOUND_READER_EOF

CKSOUND_READER_GENERICERR

CKSOUND_READER_NO_DATA_READY

CKSOUND_READER_OK

CKSOUND_USEGLOBAL

CKSOUNDHANDLE

CKSoundManager

CKSoundReader

CKSprite

CKSprite3D

CKSpriteText

CKSPRITETEXT_ALIGNMENT

CKSPRITETEXT_BOTTOM

CKSPRITETEXT_CENTER

CKSPRITETEXT_HCENTER

CKSPRITETEXT_LEFT

CKSPRITETEXT_RIGHT

CKSPRITETEXT_TOP

CKSPRITETEXT_VCENTER

CKSquare

CKStartUp

CKStateChunk

CKStateObject

CKStats

CKStrdelete

CKStrdup

CKStreamWriter

CKSTRING

CKStringToClassID

CKStrlwr

CKStructHelper

CKStrupr

CKSUB

CKSynchroObject

CKTargetCamera

CKTargetLight

CKTCBFloatKey

CKTCBPositionKey

CKTCBRotationKey

CKTCBScaleAxisKey

CKTCBScaleKey

CKTexture

CKTEXTURE_EXTERNAL

CKTEXTURE_IMAGEFORMAT

CKTEXTURE_INCLUDEORIGINALFILE

CKTEXTURE_RAWDATA

CKTEXTURE_USEGLOBAL

CKTimeManager

CKTVPatch

CKUCHAR

CKUICALLBACKFCT

CKUICallbackStruct

CKUnPackData

CKUSTRING

CKVariableManager

CKVB_STATE

CKVERSION

CKVertexBuffer

CKVideo

CKVideoInfo

CKVideoInputFormatDesc

CKVideoManager

CKVINDEX

CKWaveFormat

CKWaveSound

CKWaveSound3DSettings

CKWaveSoundSettings

CKWORD

Class Hierarchy

Class Identifiers

ClassesClasses

CloudAttributeDescription

CloudIterator

CloudSelection

ColorGetAlpha

ColorGetBlue

ColorGetGreen

ColorGetRed

ColorSetAlpha

ColorSetBlue

ColorSetGreen

ColorSetRed

Compilation Settings

CompressionFunctions

Container classes

Containers

CreateCKBehaviorPrototype

CreateCKObjectArray

CreateCKObjectDeclaration

CreateCKStateChunk

Creating a Custom Building Block Dialog Box

Creating a Standalone Application

Creating Building Blocks

Creating Extensions Plugins

Creating New Parameter Types

Creating New Plugins

Creation of a New Manager

Creation of Bitmap Media Plugins

Creation of Media Plugins

Creation of Model Media Plugins

Creation of Movie Media Plugins

Creation of new Parameter Operations

Creation of Sound Media Plugins

CrossProduct

Custom Rendering

DATA_PATH_IDX

Declaration of the Building Block

DEFAULT_MANAGERFUNC_PRIORITY

DeleteCKObjectArray

DeleteCKStateChunk

Directories functions

DIRECTORY_SEP_CHAR

DIRECTORY_SEP_STRING

DISPLAY_CATEGORY

DISTRIB_CATEGORY

DLL_EXPORT

DotProduct

Driver Caps

DWORD

Dynamic Objects

Endianness

Enumerations

EPSILON

Error Codes

Exp

External Managers classes

External Readers classes

FAQ

FlatShading

FONT_HANDLE

GaussianDistribution

GENERIC_HANDLE

GetBitCount

GetBitShift

GetProcessorDescription

GetProcessorFeatures

GetProcessorFrequency

GetProcessorType

GetQuantizationSamplingFactor

GetQuasiRandomGenerator

GetTempFileName

getWindowsOffset

Global Functions

GouraudShading

Graphic Utilities

GUID_PARAMETER_VRANAGLYPH_MODE

GUID_PARAMETER_VRCOMPOSITESTEREO_MODE

GUID_PARAMETER_VRPATHSMODE

HALFPI

Hash Tables

ImpactDesc

IMPACTNORMAL

IMPACTPOINT

IMPACTWORLDMATRIX

IMPLEMENT_POOL

IMPLEMENT_POOL_CLASS

Initializations

INSTANCE_HANDLE

Interpolate

InterpolateFloatArray

InterpolateVectorArray

Intersections

INV_RANDMAX

INVHALF_RANDMAX

InvMagnitude

InvSquareMagnitude

Is2Power

Level Organization

Ln

LnDif

LONG

LPVOID

MAC_USE_ANSI_FOR_VXFILE

Macro definitions

Macros

Magnitude

Main Steps of Building Block Creation

Main Virtools Events

MaterialDefault

Math Utilities

Matrix

Max

MAX_MANAGERFUNC_PRIORITY

MAX_PIXEL_FORMATS

MAX_USER_PROFILE

Maximize

Memory

Min

Minimize

Misc Utilities

Miscellaneous Classes

Miscellaneous functions

ModifyProcessorFeatures

MultiplyAdd

MultiplyAddVector4Array

MultiplyAddVectorArray

MultiplyVector2Array

MultiplyVector4Array

MultiplyVectorArray

MUPREVSIZE

MUSIZE

NB_STDPIXEL_FORMATS

Near2Power

Normalize

Object Dependencies Options

OBJECTARRAYCMPFCT

OBSTACLETOUCHED

operator!=

operator*

operator+

operator-

operator/

operator<

operator<=

operator==

Overloaded Operators

OverridenMaterial

OWNERENTITY

ParameterOperation Types

ParametersClasses

PhongShading

PI

PluginsClasses

PMREP_VRANAGLYPH_MODE

PMREP_VRCOMPOSITESTEREO_MODE

PMREP_VRPATHS_MODE

PNAME_VRANAGLYPH_MODE

PNAME_VRCOMPOSITESTEREO_MODE

PNAME_VRPATHS_MODE

Point Clouds

Pre-Registred Parameter Types

Presentation of the Behavioral Engine

Presentation of the Process Loop

Presentation of the Rasterizers

Presentation of the Render Engine

PROC_APIC

PROC_ATHLON

PROC_CMOV

PROC_CMPXCHG8B

PROC_DE

PROC_FXSR

PROC_HASFPU

PROC_HTT

PROC_K63DNOW

PROC_MCA

PROC_MCE

PROC_MMX

PROC_MSR

PROC_MTRR

PROC_PAE

PROC_PAT

PROC_PENTIUM

PROC_PENTIUM2

PROC_PENTIUM2CELERON

PROC_PENTIUM2XEON

PROC_PENTIUM3

PROC_PENTIUM4

PROC_PENTIUMMMX

PROC_PENTIUMPRO

PROC_PGE

PROC_PN

PROC_PPC_ARM

PROC_PPC_G3

PROC_PPC_G4

PROC_PPC_MIPS

PROC_PSE

PROC_PSP

PROC_PST32

PROC_PSX2

PROC_RESERVED

PROC_SEP

PROC_SIMD

PROC_SS

PROC_TIMESTAMP

PROC_TM

PROC_UNKNOWN

PROC_V86

PROC_WNI

PROC_XBOX2

Processor Identification

ProcessorsFeatures

ProcessorsType

QuasiRandomGenerator

Quaternions

Reflect

RegisterBehavior

Render Engine Enumerations

RenderEngineClasses

RGBAFTOCOLOR

RGBAITOCOLOR

Rotate

SetQuantizationSamplingFactor

SetWindowsOffset

Shaders and Effects

SIMD_SUPPORTED

sizeofarray

Slerp

SOUND_PATH_IDX

SoundEngineClasses

SPEEDSTEP_SAFE

Squad

SquareMagnitude

STAGEBLEND

StandardRandomGenerator

String functions

Strings

Structures

SUBOBSTACLETOUCHED

System Functions

System Utilities

The Context

The VxMath Library

Time Management

TOUCHEDFACE

TOUCHEDVERTEX

TOUCHINGFACE

TOUCHINGVERTEX

TRCLEVEL_PLUGIN

Type definitions

Types definitions

Understanding the Render Loop

UNKNOWN_PF

USE_PIX

Using 2D Entities

Using 3D Entities

Using Arrays

Using Attributes

Using Base Classes and Tools

Using Groups

Using Materials

Using Meshes

Using Messages

Using Parameters

Using Portals

Using Render Contexts

Using Sounds

Using State Chunks

Using Textures

Using the Behavior Engine

Using the Render Engine

Using the Visual C++ AppWizard to Create a Building Block

Using the Visual C++ AppWizard to Create a Manager

Using Virtools SDK

Using X Containers

VARDESCRIPTION

VariablesClasses

Vectors

Video Engine

Virtools API Architecture

Virtools Plugins Overview

Virtools SDK Architecture and Principles

Virtools SDK Documentation

Virtools SDK Reference

VIRTOOLS_MAX_EXTENSION_SIZE

VMREP_VRANAGLYPH_MODE

VMREP_VRCOMPOSITESTEREO_MODE

VMREP_VRPATHS_MODE

VR_COMMON

VRADDONS_DEVICES_CATEGORY

VRCORE_BEHAVIORS_GUID

VRDISPLAY_AUTHOR_GUID

VRDISPLAY_AUTHOR_NAME

VRDISPLAY_BEHAVIORS_GUID

VRDISPLAY_MANAGER_GUID

VRDISTRIB_BEHAVIORS_GUID

VRDISTRIB_MANAGER_GUID

VRKERNEL_MANAGER_GUID

VRMAIN_MANAGER_GUID

VRPN_MANAGER_GUID

Vx2DCapsDesc

Vx2DVector

Vx3DCapsDesc

Vx3DDecomposeMatrix

Vx3DDecomposeMatrixTotal

Vx3DDecomposeMatrixTotalPtr

Vx3DInterpolateMatrix

Vx3DInterpolateMatrixNoScale

Vx3DInverseMatrix

Vx3DInverseMatrix44

Vx3DMatrixDeterminant

Vx3DMatrixFromEulerAngles

Vx3DMatrixFromRotation

Vx3DMatrixFromRotationAndOrigin

Vx3DMatrixIdentity

Vx3DMatrixPolarDecomposition

Vx3DMatrixSpectralDecomposition

Vx3DMatrixToEulerAngles

Vx3DMultiplyMatrix

Vx3DMultiplyMatrix4

Vx3DMultiplyMatrixVector

Vx3DMultiplyMatrixVector4

Vx3DMultiplyMatrixVector4Strided

Vx3DMultiplyMatrixVectorMany

Vx3DMultiplyMatrixVectorStrided

Vx3DQuaternionConjugate

Vx3DQuaternionDivide

Vx3DQuaternionFromMatrix

Vx3DQuaternionMultiply

Vx3DRotateVector

Vx3DRotateVectorMany

Vx3DRotateVectorStrided

Vx3DTransposeMatrix

VX_BPP1

VX_BPP16

VX_BPP2

VX_BPP24

VX_BPP32

VX_BPP4

VX_BPP8

VX_EFFECT

VX_EFFECTCALLBACK_RETVAL

VX_LIGHTDIREC

VX_LIGHTPARA

VX_LIGHTPOINT

VX_LIGHTSPOT

VX_LINELIST

VX_LINESTRIP

VX_LITMESH

VX_LOCK_DEFAULT

VX_LOCK_DISCARD

VX_LOCK_READONLY

VX_LOCK_WRITEONLY

VX_LOCKFLAGS

VX_MOVEABLE_BOXVALID

VX_MOVEABLE_CHARACTERRENDERED

VX_MOVEABLE_DONTUPDATEFROMPARENT

VX_MOVEABLE_EXTENTSUPTODATE

VX_MOVEABLE_FLAGS

VX_MOVEABLE_HASMOVED

VX_MOVEABLE_HIERARCHICALHIDE

VX_MOVEABLE_INDIRECTMATRIX

VX_MOVEABLE_INVERSEWORLDMATVALID

VX_MOVEABLE_NOZBUFFERTEST

VX_MOVEABLE_NOZBUFFERWRITE

VX_MOVEABLE_PICKABLE

VX_MOVEABLE_RENDERFIRST

VX_MOVEABLE_RENDERLAST

VX_MOVEABLE_RESERVED2

VX_MOVEABLE_STENCILONLY

VX_MOVEABLE_UPTODATE

VX_MOVEABLE_USERBOX

VX_MOVEABLE_VISIBLE

VX_MOVEABLE_WORLDALIGNED

VX_MOVEABLE_ZBUFONLY

VX_OSINFO

VX_PIXELFORMAT

VX_PLATFORMINFO

VX_POINTLIST

VX_PRELITMESH

VX_TRIANGLEFAN

VX_TRIANGLELIST

VX_TRIANGLESTRIP

VxAddDirectorySeparator

VxAddLibrarySearchPath

VxAllocator

VxBbox

VxBigFile

VXBLEND_BOTHINVSRCALPHA

VXBLEND_BOTHSRCALPHA

VXBLEND_DESTALPHA

VXBLEND_DESTCOLOR

VXBLEND_INVDESTALPHA

VXBLEND_INVDESTCOLOR

VXBLEND_INVSRCALPHA

VXBLEND_INVSRCCOLOR

VXBLEND_MASK

VXBLEND_MODE

VXBLEND_ONE

VXBLEND_SRCALPHA

VXBLEND_SRCALPHASAT

VXBLEND_SRCCOLOR

VXBLEND_ZERO

VxBpps

VxBppToMask

VXBUFFER_BACKBUFFER

VXBUFFER_STENCILBUFFER

VXBUFFER_TYPE

VXBUFFER_ZBUFFER

VXCHANNEL_ACTIVE

VXCHANNEL_FLAGS

VXCHANNEL_HINT_USEORIGINALMESHVB

VXCHANNEL_KEEPFOG

VXCHANNEL_LAST

VXCHANNEL_MATERIALSUBSET

VXCHANNEL_MONO

VXCHANNEL_NOTLIT

VXCHANNEL_RESERVED1

VXCHANNEL_SAMENORMAL

VXCHANNEL_SAMEUV

VXCHANNEL_SUBSET

VXCHANNEL_UPTODATE

VXCHANNEL_USEORIGINALMESHVB

VXCHANNEL_VERTEXCOLOR

VxClientToScreen

VXCLIP_ALL

VXCLIP_BACK

VXCLIP_BACKFRONT

VXCLIP_BOTTOM

VXCLIP_FLAGS

VXCLIP_FRONT

VXCLIP_LEFT

VXCLIP_RIGHT

VXCLIP_TOP

VXCMP_ALWAYS

VXCMP_EQUAL

VXCMP_GREATER

VXCMP_GREATEREQUAL

VXCMP_LESS

VXCMP_LESSEQUAL

VXCMP_MASK

VXCMP_NEVER

VXCMP_NOTEQUAL

VXCMPFUNC

VxColor

VxCompressedVector

VxComputeBestFitBBox

VxCone

VxConsoleListener

VxConvertBitmap

VxConvertBitmapTo24

VxConvertEndianArray16

VxConvertEndianArray32

VxConvertPathToSystemPath

VxConvertToBumpMap

VxConvertToNormalMap

VxCopyBitmap

VxCopyDwords2Words

VxCopyStructure

VxCopyWords2Dwords

VxCreateBitmap

VxCreateFileTree

VxCreateFont

VXCULL

VXCULL_CCW

VXCULL_CW

VXCULL_MASK

VXCULL_NONE

VXCURSOR_BUSY

VXCURSOR_LINKSELECT

VXCURSOR_MOVE

VXCURSOR_NORMALSELECT

VXCURSOR_POINTER

VxDataMutexed

VxDeleteAligned

VxDeleteBitmap

VxDeleteDirectory

VxDeleteFile

VxDeleteFont

VxDirectXData

VxDisplayMode

VxDistance

VxDoAlphaBlit

VxDoBlit

VxDoBlitDeInterleaved

VxDoBlitDeInterleavedUpsideDown

VxDoBlitUpsideDown

VxDrawBitmapText

VxDrawBitmapTextW

VxDrawPrimitiveData

VxDrawPrimitiveDataSimple

VxDriverDesc

VXEFFECT_2TEXTURES

VXEFFECT_3TEXTURES

VXEFFECT_BUMPENV

VXEFFECT_DP3

VXEFFECT_MASK

VXEFFECT_NONE

VXEFFECT_TEXGEN

VXEFFECT_TEXGENREF

VxEffectDescription

VXEFFECTRETVAL_SKIPALL

VXEFFECTRETVAL_SKIPALLTEX

VXEFFECTRETVAL_SKIPNONE

VXEFFECTRETVAL_SKIPTEXMAT

VxEndian16Swap

VxEndian32Swap

VxFile

VxFileExist

VxFileListener

VXFILL_MASK

VXFILL_MODE

VXFILL_POINT

VXFILL_SOLID

VXFILL_WIREFRAME

VxFillStructure

VXFOG_EXP

VXFOG_EXP2

VXFOG_LINEAR

VXFOG_MODE

VXFOG_NONE

VXFONTINFO

VxFrustum

VxGenerateMipMap

VxGetBitCounts

VxGetBitShifts

VxGetClientRect

VxGetCurrentDirectory

VxGetDirectory

VxGetEnvironmentVariable

VxGetFontInfo

VxGetFPUControlWord

VxGetModuleFileName

VxGetMouseButtonsSwapped

VxGetOs

VxGetParent

VxGetPlatform

VxGetTempPath

VxGetV3DLAppSupportDirectory

VxGetWindowRect

VxImageDesc2PixelFormat

VxImageDescEx

VxIndexedCopy

VxIntersect

VxIntersectionDesc

VxInverseProject

VxIsAllocatedByNewAligned

VXLIGHT_TYPE

VxLog

VxLogListener

VxMakeDirectory

VxMakePath

VxMath Reference

VxMatrix

VxMemoryMappedFile

VxMemoryPool

VXMESH_ALLFLAGS

VXMESH_BOUNDINGUPTODATE

VXMESH_BWEIGHTS_CHANGED

VXMESH_COLOR_CHANGED

VXMESH_FACENORMALSCOMPUTED

VXMESH_FLAGS

VXMESH_FORCETRANSPARENCY

VXMESH_GENNORMALS

VXMESH_GENTANSPACE

VXMESH_HASTRANSPARENCY

VXMESH_HINTDYNAMIC

VXMESH_LITMODE

VXMESH_MONOMATERIAL

VXMESH_NORMAL_CHANGED

VXMESH_OPTIMIZED

VXMESH_PM_BUILDNORM

VXMESH_POS_CHANGED

VXMESH_PRELITMODE

VXMESH_PROCEDURALPOS

VXMESH_PROCEDURALUV

VXMESH_STRIPIFY

VXMESH_TRANSPARENCYUPTODATE

VXMESH_UPDATEINDEXBUF

VXMESH_USECOLORANDNORMAL

VXMESH_UV_CHANGED

VXMESH_VISIBLE

VXMESH_WRAPU

VXMESH_WRAPV

VxMMF_Error

VxMMF_FileMapping

VxMMF_FileOpen

VxMMF_MapView

VxMMF_NoError

VxMoveWindow

VxMutex

VxMutexLock

VxNewAligned

VxOBB

VXOS_LINUXX86

VXOS_MACOS9

VXOS_MACOSX

VXOS_PSP

VXOS_PSX2

VXOS_UNKNOWN

VXOS_WII

VXOS_WIN2K

VXOS_WIN31

VXOS_WIN95

VXOS_WIN98

VXOS_WINCE1

VXOS_WINCE2

VXOS_WINCE3

VXOS_WINME

VXOS_WINNT4

VXOS_WINSEVEN

VXOS_WINVISTA

VXOS_WINXP

VXOS_XBOX

VXOS_XBOX2

VXOS_XBOX360

VxOutputDebugListener

VxPixelFormat2ImageDesc

VxPixelFormat2String

VxPlane

VXPLATFORM_LINUX

VXPLATFORM_MAC

VXPLATFORM_PSP

VXPLATFORM_PSX2

VXPLATFORM_UNKNOWN

VXPLATFORM_WII

VXPLATFORM_WINCE

VXPLATFORM_WINDOWS

VXPLATFORM_XBOX

VXPLATFORM_XBOX2

VxPoolObject

VXPRIMITIVETYPE

VxProjectBoxZExtents

VxPtInRect

VxQuaternion

VxRay

VxRDTSCProfiler

VXRDTSCPROFILER

VxRect

VxRemoveDirectory

VxRenameFile

VXRENDERSTATE_ALPHABLENDENABLE

VXRENDERSTATE_ALPHAFUNC

VXRENDERSTATE_ALPHAREF

VXRENDERSTATE_ALPHATESTENABLE

VXRENDERSTATE_AMBIENT

VXRENDERSTATE_AMBIENTFROMVERTEX

VXRENDERSTATE_ANTIALIAS

VXRENDERSTATE_BLENDOP

VXRENDERSTATE_CLIPPING

VXRENDERSTATE_CLIPPLANEENABLE

VXRENDERSTATE_COLORVERTEX

VXRENDERSTATE_COLORWRITEENABLE

VXRENDERSTATE_CULLMODE

VXRENDERSTATE_DESTBLEND

VXRENDERSTATE_DIFFUSEFROMVERTEX

VXRENDERSTATE_DITHERENABLE

VXRENDERSTATE_EDGEANTIALIAS

VXRENDERSTATE_EMISSIVEFROMVERTEX

VXRENDERSTATE_FILLMODE

VXRENDERSTATE_FOGCOLOR

VXRENDERSTATE_FOGDENSITY

VXRENDERSTATE_FOGENABLE

VXRENDERSTATE_FOGEND

VXRENDERSTATE_FOGPIXELMODE

VXRENDERSTATE_FOGSTART

VXRENDERSTATE_FOGVERTEXMODE

VXRENDERSTATE_INDEXVBLENDENABLE

VXRENDERSTATE_INVERSEWINDING

VXRENDERSTATE_LIGHTING

VXRENDERSTATE_LINEPATTERN

VXRENDERSTATE_LOCALVIEWER

VXRENDERSTATE_LOCKMATERIALSTATES

VXRENDERSTATE_NORMALIZENORMALS

VXRENDERSTATE_POINTSCALE_A

VXRENDERSTATE_POINTSCALE_B

VXRENDERSTATE_POINTSCALE_C

VXRENDERSTATE_POINTSCALEENABLE

VXRENDERSTATE_POINTSIZE

VXRENDERSTATE_POINTSIZE_MAX

VXRENDERSTATE_POINTSIZE_MIN

VXRENDERSTATE_POINTSPRITEENABLE

VXRENDERSTATE_RANGEFOGENABLE

VXRENDERSTATE_SCISSORTESTENABLE

VXRENDERSTATE_SHADEMODE

VXRENDERSTATE_SOFTWAREVPROCESSING

VXRENDERSTATE_SPECULARENABLE

VXRENDERSTATE_SPECULARFROMVERTEX

VXRENDERSTATE_SRCBLEND

VXRENDERSTATE_STENCILENABLE

VXRENDERSTATE_STENCILFAIL

VXRENDERSTATE_STENCILFUNC

VXRENDERSTATE_STENCILMASK

VXRENDERSTATE_STENCILPASS

VXRENDERSTATE_STENCILREF

VXRENDERSTATE_STENCILWRITEMASK

VXRENDERSTATE_STENCILZFAIL

VXRENDERSTATE_TEXTUREFACTOR

VXRENDERSTATE_TEXTUREPERSPECTIVE

VXRENDERSTATE_TEXTURETARGET

VXRENDERSTATE_TWOSIDEDLIGHTING

VXRENDERSTATE_VERTEXBLEND

VXRENDERSTATE_WRAP0

VXRENDERSTATE_WRAP1

VXRENDERSTATE_WRAP2

VXRENDERSTATE_WRAP3

VXRENDERSTATE_WRAP4

VXRENDERSTATE_WRAP5

VXRENDERSTATE_WRAP6

VXRENDERSTATE_WRAP7

VXRENDERSTATE_ZBIAS

VXRENDERSTATE_ZENABLE

VXRENDERSTATE_ZFUNC

VXRENDERSTATE_ZWRITEENABLE

VXRENDERSTATETYPE

VxResizeImage32

VxScanCodeToAscii

VxScanCodeToName

VxScratch

VxScratchString

VxScreenToClient

VxSetBaseFPUControlWord

VxSetCurrentDirectory

VxSetCursor

VxSetEnvironmentVariable

VxSetFPUControlWord

VxSetParent

VXSHADE_FLAT

VXSHADE_GOURAUD

VXSHADE_MASK

VXSHADE_MODE

VXSHADE_PHONG

VxShadeType

VXSHADOWMAP_13TAPS

VXSHADOWMAP_1TAP

VXSHADOWMAP_5TAPS

VXSHADOWMAP_9TAPS

VXSHADOWMAP_ATTENUATIONMODE

VXSHADOWMAP_DEBUGMATERIAL

VXSHADOWMAP_DIRECTIONALATTENUATION

VXSHADOWMAP_FALLBACKPOLICY

VXSHADOWMAP_FLOAT16WBUFFER

VXSHADOWMAP_FLOAT32WBUFFER

VXSHADOWMAP_FORMAT

VXSHADOWMAP_FORMATCOUNT

VXSHADOWMAP_HWSHADOWMAP16

VXSHADOWMAP_HWSHADOWMAP24S8

VXSHADOWMAP_LIGHTFACTORS

VXSHADOWMAP_NOATTENUATION

VXSHADOWMAP_NOFALLBACK

VXSHADOWMAP_PREFERFILTERING

VXSHADOWMAP_PREFERSAMPLING

VXSHADOWMAP_TAPCOUNT

VXSHADOWMAP_UNKNOWNFORMAT

VxSharedLibrary

VxShowCursor

VxSortFunc

VxSphere

VXSPRITE2_DISABLE_AA_CORRECTION

VXSPRITE2_NONE

VXSPRITE3D_BILLBOARD

VXSPRITE3D_ORIENTABLE

VXSPRITE3D_TYPE

VXSPRITE3D_XROTATE

VXSPRITE3D_YROTATE

VXSPRITE_ALPHATEST

VXSPRITE_BLEND

VXSPRITE_FILTER

VXSPRITE_MODULATE

VXSPRITE_NONE

VXSPRITE_RENDEROPTIONS

VXSPRITE_RENDEROPTIONS2

VxSpriteRenderOptions

VxStats

VXSTENCILOP

VXSTENCILOP_DECR

VXSTENCILOP_DECRSAT

VXSTENCILOP_INCR

VXSTENCILOP_INCRSAT

VXSTENCILOP_INVERT

VXSTENCILOP_KEEP

VXSTENCILOP_MASK

VXSTENCILOP_REPLACE

VXSTENCILOP_ZERO

VxStream

VxStridedData

VxStridedDataBase

VxSubFile

VXT_OK

VXT_STILLACTIVE

VXT_TERMINATEFORCED

VXTERROR_EXITCODE

VXTERROR_NULLTHREAD

VXTERROR_TIMEOUT

VXTERROR_WAIT

VxTestDiskSpace

VXTEXT_ALIGNMENT

VXTEXT_BOTTOM

VXTEXT_CENTER

VXTEXT_HCENTER

VXTEXT_LEFT

VXTEXT_RIGHT

VXTEXT_TOP

VXTEXT_VCENTER

VXTEXTURE_ADDRESSBORDER

VXTEXTURE_ADDRESSCLAMP

VXTEXTURE_ADDRESSMASK

VXTEXTURE_ADDRESSMIRROR

VXTEXTURE_ADDRESSMIRRORONCE

VXTEXTURE_ADDRESSMODE

VXTEXTURE_ADDRESSWRAP

VXTEXTURE_BLENDMODE

VXTEXTURE_FILTERMODE

VXTEXTURE_WRAPMODE

VXTEXTUREBLEND_ADD

VXTEXTUREBLEND_COPY

VXTEXTUREBLEND_DECAL

VXTEXTUREBLEND_DECALALPHA

VXTEXTUREBLEND_DECALMASK

VXTEXTUREBLEND_DOTPRODUCT3

VXTEXTUREBLEND_MASK

VXTEXTUREBLEND_MAX

VXTEXTUREBLEND_MODULATE

VXTEXTUREBLEND_MODULATEALPHA

VXTEXTUREBLEND_MODULATEMASK

VXTEXTUREFILTER_ANISOTROPIC

VXTEXTUREFILTER_LINEAR

VXTEXTUREFILTER_LINEARMIPLINEAR

VXTEXTUREFILTER_LINEARMIPNEAREST

VXTEXTUREFILTER_MASK

VXTEXTUREFILTER_MIPLINEAR

VXTEXTUREFILTER_MIPNEAREST

VXTEXTUREFILTER_NEAREST

VXTEXTUREWRAP_NONE

VXTEXTUREWRAP_U

VXTEXTUREWRAP_UV

VXTEXTUREWRAP_V

VXTF_NOCOINITIALIZE

VXTF_USECOINITIALIZE

VXTF_USECOINITIALIZEEX

VxThread

VXTHREAD_PRIORITY

VXTHREAD_STATE

VxThreadFunction

VXTHREADWIN32_FLAGS

VxTimeProfiler

VXTP_ABOVENORMAL

VXTP_BELOWNORMAL

VXTP_HIGHLEVEL

VXTP_IDLE

VXTP_LOWLEVEL

VXTP_NORMAL

VXTP_TIMECRITICAL

VxTransformBox2D

VxTransformData

VXTS_CREATED

VXTS_INITIALE

VXTS_JOINABLE

VXTS_MAIN

VXTS_STARTED

VxURLDownloadToCacheFile

VxUV

VxVector

VxVector4

VxWindowFromPoint

VXWRAP_MASK

VXWRAP_MODE

VXWRAP_S

VXWRAP_T

VXWRAP_U

VXWRAP_V

What are Behavioral Objects ?

What are Behaviors ?

What are Parameters ?

WIN_HANDLE

Windows functions

WireFrame

WORD

Writing the Behavior Callback Function

Writing the Execution Function

XAbs

XAP

XArray

XBaseString

XBinaryTree

XBinaryTreeIt

XBinaryTreeNode

XBitArray

XBOOL

XBTree

XBYTE

XClassArray

XCos

XDWORD

XEqual

XEqualStringI

XEqualXStringI

XFabs

XGUID

XHashFun

XHashFunStringI

XHashFunXStringI

XHashTable

XList

XListIt

XMatrix

XMax

XMin

XMinMax

XNHashTable

XNHashTableConstIt

XNHashTableIt

XNHashTablePair

XNTree

XObjectArray

XObjectPointerArray

XP

XPriority

XPriorityQueue

XPtrStrided

XRefCount

XRemoveIf

XSHashTable

XSHashTableConstIt

XSHashTableIt

XSHashTablePair

XSin

XSmartPtr

XSObjectArray

XSObjectPointerArray

XSqrt

XString

XStringTokenizer

XSwap

XThreshold

XWORD

Classes

IVRDisplayManager

External Functions

VRGetFirstManagedContext

Type Definitions

EAnaglyphMode

ECompositeStereoMode

EVRPathsMode

FeaturesList

XVRManagerArray

XVRManagerHashTable

XVRManagerHashTableIt

XVRManagerHashTablePair


Glossary

Generated by the DocJet Source Code Documentation System version 6.1.3 Thursday, February 26, 2009


When you pressed the

When you pressed the "Edit" button in the browser window, you asked to be taken to the source code for the object you were looking at. The web page knows the relative path to the source code for the object - relative to the root of the project tree. What you are being asked to supply in this dialog is the path to the root of the project tree.

After you supply this directory, it will be stored away so that the next time you press "Edit" in the documentation for this project, you will not be bothered with this dialog.


Class Hierarchy

CKBaseManager

VRBaseManager

IVRDisplayManager

VRContext


Index

_AddResourceToken

ActivateWarp

AUTHOR_GUID

AUTHOR_NAME

CameraName

CheckLicenses

CloseParse

constructor

DeActivateWarp

destructor

DISPLAY_CATEGORY

DISTRIB_CATEGORY

DoPrimaryRender

eAlwaysAdd

eAnaglyph

EAnaglyphMode

eAskConfirmation

eCheckerboard

eColor

ECompositeStereoMode

eGray

eHalfColor

eManual

EnablePrimaryRender

eNeverAdd

eNone

eOptimized

eTrue

EVRPathsMode

FeaturesList

FlagExit

Flags

GetBaseDirectory

GetBaseMediaDirectory

GetCfgFilename

GetExecutionMode

GetFloat3

GetFloat4

GetHiddenToken

GetHostCount

GetHostID

GetHostList

GetInt3

GetLogLevel

GetString

GetSubToken

GetToken

GetValidFunctionsMask

GetValidVRFunctionsMask

GetView

GetViewCount

GetViewData

GetVRDisplayManager

GetVRFunctionPriority

GetWarpTexture

Globals

GUID_PARAMETER_VRANAGLYPH_MODE

GUID_PARAMETER_VRCOMPOSITESTEREO_MODE

GUID_PARAMETER_VRPATHSMODE

Height - see

WarpInfo::Height

VRView::Height

ID

InitParse

IVRDisplayManager

m_VRContext

Mode

OnCKEnd

OnCKInit

OnParse

OnViewCreate

OnViewDelete

OnViewWarp

OutputToLog

PMREP_VRANAGLYPH_MODE

PMREP_VRCOMPOSITESTEREO_MODE

PMREP_VRPATHS_MODE

PNAME_VRANAGLYPH_MODE

PNAME_VRCOMPOSITESTEREO_MODE

PNAME_VRPATHS_MODE

PositionX

PositionY

RegisterNewManager

ScreenID

SetCfgFilename

SetViewData

TRCLEVEL_PLUGIN

UserData

UserTokens

UseWarpTexture

Using the VR SDK

Virtools VR SDK Documentation

VMREP_VRANAGLYPH_MODE

VMREP_VRCOMPOSITESTEREO_MODE

VMREP_VRPATHS_MODE

VR SDK Principles

VR SDK Reference

VR SDK source code

VR_COMMON

VR_EXECUTION_MODE

VR_OK

VRADDONS_DEVICES_CATEGORY

VRBaseManager

VRClasses

VRCloseContext

VRContext

VRCORE_BEHAVIORS_GUID

VRCreateContext

VRDISPLAY_AUTHOR_GUID

VRDISPLAY_AUTHOR_NAME

VRDISPLAY_BEHAVIORS_GUID

VRDISPLAY_MANAGER_GUID

VRDISTRIB_BEHAVIORS_GUID

VRDISTRIB_MANAGER_GUID

VREnumerations

VRERR_ALREADYEXIST

VRERR_GENERICERROR

VRERR_IMPOSSIBLE

VRERR_INVALIDCFGFILE

VRERR_INVALIDHOST

VRERR_INVALIDVIEW

VRERR_NOVRCONTEXT

VRERR_TOKENFORMATERROR

VRERR_TOKENNOTFOUND

VRERR_TOKENWRONGTYPE

VRERR_WARPTOOLARGE

VRERROR

VRErrorToString

VREXECUTION_CUSTOM

VREXECUTION_DEV

VREXECUTION_VRPLAYER

VRGetContext

VRGetFirstManagedContext

VRKERNEL_MANAGER_GUID

VRMAIN_MANAGER_GUID

VRMANAGER_FUNC_OnParse

VRMANAGER_FUNC_OnViewCreate

VRMANAGER_FUNC_OnViewDelete

VRMANAGER_FUNC_OnViewWarp

VRMANAGER_FUNCTIONS

VRPN_MANAGER_GUID

VRStructures

VRType Definitions

VRView

WarpInfo

WarpTexture

Width - see

WarpInfo::Width

VRView::Width

XVRManagerArray

XVRManagerHashTable

XVRManagerHashTableIt

XVRManagerHashTablePair

~VRBaseManager